Intersoft WebGrid

Intersoft WebGrid Documentation
Intersoft WebGrid
See Also Send Feedback

Glossary Item Box

Intersoft WebGrid Enterprise gives you most powerful DataGrid component for ASP.NET Web development, with a host of innovative features that allows the control to display large data in highly efficient manner. WebGrid provides comprehensive Grid functionalities enabling enterprise-class information to be delivered in hierarchical layout with sophisticated user interactions, allowing users to work with the information in a more effective and productive way.

WebGrid also supports out-of-the-box graphical charting presentation, advanced paging, runtime column freezing, comprehensive data source control support and cutting-edge LINQ-to-SQL datasource, codeless hierarchical data binding, and sophisticated UX.

WebGrid includes over 200+ innovative features, including batch editing, client side binding, engaging visual themes, custom editor packs and full HTML5 support.

In This Section

Getting Started

Provides information and resources intended for developers that are new to WebGrid, which includes topics that discuss about development prerequisites, installation, and basic walkthroughs to use WebGrid in your ASP.NET projects.

What's New in WebGrid

Provides information and links to the new features and enhancements available in WebGrid 8.

Walkthrough Topics

Contains links to the walkthroughs topics that provide step-by-step guidance on using WebGrid controls to achieve various scenarios and business challenges.

How-to Topics

Contains links to the frequently asked questions and how-to topics that provide quick guidance on using WebGrid controls to achieve particular development challenges.

Features and Concepts

Describes the architecture, concepts and key features that are fundamental to build high-performance applications using WebGrid.

Learning More

Learn more about WebGrid features and its rich designer capabilities. Getting familiar with SmartTag Designer, and learn how to bind data using Datasource control, as well as customizing the control with Component Designer.

Miscellaneous WebGrid Settings

Describes the concept that might be adapted in WebGrid to make a good performance in your projects.

Server-side References

Provides links to the samples codes and documentation of assemblies, namespaces and types available in WebGrid.

Client-side References

Provides links to the samples codes and documentation of Javascript objects, properties and methods available in WebCombo.

Troubleshooting

Describes how to troubleshoot WebGrid in specific condition.

Product Support

Provides resources and links to get product support, report issues, submit feedback, and access to community sites such as developer network, forum and blog.

Licensing

Describes the methods to license WebCombo for the development and deployment, as well as provides information about software license agreement for end users.

See Also

Overview
Getting Started
WebGrid Features Overview

Other Resources
Walkthrough Topics
How-to Topics

©2014 Intersoft Solutions Corp. All Rights Reserved.


Getting Started

Getting Started
See Also Send Feedback
Intersoft WebGrid > Getting Started

Glossary Item Box

This section is designated to help you quickly getting started with WebGrid. You can use all links below to become familiar with WebGrid.

Installation

The following topics will guide you how to install WebGrid and what the system requirements you need to have in order to run WebGrid in your PC.

  • Installation Guide
  • Manually installing WebGrid to Visual Studio 2005 ToolBox
  • Use Toolbox Utility Tool to add Intersoft Products to Visual Studio toolbox
  • System Requirements

Deployment

This section will help you to configure and set the application in deploying the project to server. It also provides a Deployment Checklist which contains the essential things you need to manage before proceeding to deployment.

  • Deployment Guide
  • Application Wide Configurations

Upgrading

This following topics will give you the information about the breaking changes in WebGrid 6.0 and how to.

  • Breaking Changes in WebGrid.NET Enterprise 6.0
  • Upgrading from previous version
  • How-to: Upgrade WebGrid samples to be used in Visual Studio.NET 2008

WebGrid Walkthroughs

Walkthroughs will guide you through the completion of basic tasks using WebGrid. Use walkthrough topics to become familiar with WebGrid and know how to implement basic DataBinding.

Term | Definition
Walkthrough: Binding WebGrid to AccessDataSource control | Describes the process for binding WebGrid with AccessDataSource control.
Walkthrough: Binding WebGrid to Hierarchical ISDataSource control | Describes the process for binding WebGrid with ISDataSource control in hierarchical structure.
Walkthrough: Using WebGrid in Unbound Mode | Describes the process for configuring WebGrid to use unbound mode.

For the complete WebGrid walkthroughs, see WebGrid Walkthroughs.

See Also

Overview
Features Added in WebGrid 8
WebGrid Features Overview

Other Resources
Walkthrough Topics
How-to Topics


Installation

Installation
See Also Send Feedback
Intersoft WebGrid > Getting Started > Installation

Glossary Item Box

This section contains information on installing WebGrid.NET and specifying the system requirements needed by the component.

In This Section

Installation Guide
Information about installing WebGrid.NET on your PC.

Manually installing WebGrid to Visual Studio 2005 ToolBox
Information about installing WebGrid control to Visual Studio 2005 ToolBox manually.

Use Toolbox Utility Tool to add Intersoft Products to Visual Studio toolbox
Information about installing WebGrid control to Visual Studio ToolBox using Toolbox Utility tool.

System Requirements
Read about the Windows version, Visual Studio application, WebUI.NET Framework and other software requirements for installing WebGrid.NET.

See Also

Overview
Getting Started
WebGrid Features Overview

Other Resources
Walkthrough Topics
How-to Topics


Installation Guide

Installation Guide
See Also Send Feedback
Intersoft WebGrid > Getting Started > Installation > Installation Guide

Glossary Item Box

Installation Requirement

For system requirement, please see the System Requirements section.

Installing WebGrid 8

Intersoft has released the new setup installer which includes WebUI Framework 3, WebGrid 8, WebCombo 6, WebInput 4, WebDesktop 3, WebTreeView, ISDataSource, WebScheduler 3, WebAqua 2, WebTextEditor, WebEssentials and clientUI components.

Here are the step-by-step instructions to install WebGrid 8:

  1. Double click on the "Intersoft WebUI Studio 2012 R1.exe" icon to start the installation process. Read the instructions, and click next.

  2. Please read the license agreement. You must accept the terms in the license agreement in order to install WebGrid 8.

  3. Fill in your details such as User Name and Organization. Click Next to proceed.

  4. You can select the product edition and setup type that you would like to install and perform.

    The product contains three editions such as WebUI Studio for ASP.NET, WebUI Studio for Silverlight and WebUI Studio for WPF.

  5. Click Next to proceed with the installation process.

  6. The wizard is installing WebUI Studio 2012 R1.

  7. A window showing the installation progress appears. It will list the status of components that are being installed.

  8. After the installation process has been finished, you will see a confirmation window. Click Finish to close the window. At this rate, you have successfully installed the Intersoft WebUI Studio 2012 R1.

  9. To install the full version of WebGrid 8, proceed by using License Manager that can be triggered from Start menu >> All Programs >> Intersoft WebUI Studio 2012 R1 >> License Manager.

  10. Intersoft License Manager window will appear. Click "Add License" to proceed to the next step.

  11. Now, Select a product from the combo box. In this case, select WebGrid.NET Version 8.0.7200 and enter the license according to the component.

  12. Click Add and it will automatically check the license with the server through internet connection. If it is correct, then you have successfully installed the full version of WebGrid 8.

See Also

Overview
Getting Started
WebGrid Features Overview

Other Resources
Walkthrough Topics
How-to Topics


Manually installing WebGrid to Visual Studio 2005 ToolBox

Manually installing WebGrid to Visual Studio 2005 ToolBox
See Also Send Feedback
Intersoft WebGrid > Getting Started > Installation > Manually installing WebGrid to Visual Studio 2005 ToolBox

Glossary Item Box

This document provides a step-by-step guidance on how to manually install WebGrid to Visual Studio 2005 ToolBox.

Step-By Step Instructions

To manually install WebGrid to Visual Studio 2005 ToolBox

  1. Open Visual Studio 2005 application.
  2. Create a new WebSite application.
  3. In the Designer view, refer to the ToolBox on the left side.
  4. Right-click on the ToolBox and choose Add Tab.
  5. Named the Tab as "WebUI Studio.NET".
  6. Right-click on the created Tab and select Choose Items.
  7. Browse and Add ISNet.WebUI.WebGrid.dll from C:\Program Files\Intersoft Solutions\WebUI Studio for ASP.NET\WebGrid.NET 7.0\Bin.
  8. Finally, your ToolBox will look like the following:

    ToolBox

See Also

Overview
Getting Started
WebGrid Features Overview

Other Resources
Walkthrough Topics
How-to Topics


Use Toolbox Utility Tool to add Intersoft Products to Visual Studio toolbox

Use Toolbox Utility Tool to add Intersoft Products to Visual Studio toolbox
See Also Send Feedback
Intersoft WebGrid > Getting Started > Installation > Use Toolbox Utility Tool to add Intersoft Products to Visual Studio toolbox

Glossary Item Box

This topic provides a step-by-step instruction on how to manually add Intersoft products to Visual Studio Toolbox using Toolbox Utility tool.

To add Intersoft products to Visual Studio Toolbox

  1. Run Intersoft ToolBox Utility for Visual Studio from Start Menu >> All Programs >> Intersoft WebUI Studio 2010 R1 >> Intersoft ToolBox Utility for Visual Studio or you can access ToolBoxUtility.exe from [Installation Folder]\Intersoft Solutions\Intersoft WebUI Studio 2010 R1\ToolBoxUtility
  2. Select on the Visual Studio platform you want Intersoft products to be installed. By default, it will automatically select all Visual Studio versions installed on your PC.

  3. Click Register to run the tool and wait until the process is finished.

  4. Finally, open your project and you will notice that Intersoft products has been installed successfully into Visual Studio Toolbox.

See Also

Overview
Getting Started
WebGrid Features Overview

Other Resources
Walkthrough Topics
How-to Topics


System Requirements

System Requirements
See Also Send Feedback
Intersoft WebGrid > Getting Started > Installation > System Requirements

Glossary Item Box

Development Machine Requirements

  • Microsoft Windows Vista/7
  • Microsoft Windows 2000/2003/2008 Server family
  • Microsoft Windows XP Professional or Home Edition
  • Microsoft .NET Framework v2.0 or higher
  • Microsoft Visual Studio 2005 Professional/Team Studio/Express Edition
  • Microsoft Visual Studio 2008/2010
  • Intersoft WebUI.NET Framework v3.0 or higher

Server Machine Requirements

  • Windows Server 2003 Enterprise
  • Windows Server 2003 Web Edition
  • Windows Server 2008
  • Internet Information Services 6.0 or later
  • Microsoft .NET Framework Version 2.0 or later
  • Intersoft WebUI.NET Framework v3.0 or higher

Client Machine Requirements

  • Microsoft Internet Explorer 5.5 or higher
  • Mozilla V1.7 +for Windows/Mac/Linux/Solaris
  • Firefox V1.0+ for Windows/Mac/Linux/Solaris
  • Netscape V7.0+ for Windows/Mac/Linux/Solaris
  • Opera 9.5+ for Windows/Mac/Linux/Solaris/FreeBSD/BeOS/QNX
  • Apple Safari 3+ for Windows/Mac

See Also

Overview
Getting Started
WebGrid Features Overview

Other Resources
Walkthrough Topics
How-to Topics


Deployment

Deployment
See Also Send Feedback
Intersoft WebGrid > Getting Started > Deployment

Glossary Item Box

This section contains information on configuring the application and guiding user with a step-by-step Checklist instructions for deployment purposes.

In This Section

Deployment Guide
Information about Deployment Checklist that will list all the important tasks you need to do before deploying the project.

Application Wide Configurations
Read about the WebGrid's ability to configure deployment-related properties via web.config, such as ScriptDirectory and many others.

See Also

Overview
Getting Started
WebGrid Features Overview

Other Resources
Walkthrough Topics
How-to Topics


Deployment Guide

Deployment Guide
See Also Send Feedback
Intersoft WebGrid > Getting Started > Deployment > Deployment Guide

Glossary Item Box

This section continues to guide you on how to deploy the project by using Deployment Manager and SmartWebResources™.

In This Section

Using Deployment Manager
Learn how to use deployment manager to set the web.config.

Deploying project that uses SmartWebResources
Information about deploying project using SmartWebResources™.

Deploying project that does not use SmartWebResources
Information about deploying project without using SmartWebResources™. In other words, you need to copy CommonLibrary, project's directory and assemblies.

See Also

Overview
Getting Started
WebGrid Features Overview

Other Resources
Walkthrough Topics
How-to Topics


Using Deployment Manager
See Also Send Feedback
Intersoft WebGrid > Getting Started > Deployment > Deployment Guide > Using Deployment Manager

Glossary Item Box

Intersoft comes up with a new hassle-free Deployment Manager that is designated to help developers to easily manage configurations during deployment phase.

Now, you can quickly configure the common settings required in deployment such as entering runtime license keys, view state configurations and others through user-friendly Windows GUI application.

Using Deployment Manager

Here are the step-by-step instructions to use Deployment Manager:

  1. Open Deployment Manager from Start menu >> All Programs >> Intersoft WebUI Studio 2009 R1 >> WebUI Studio for ASP.NET >> Deployment Manager.
  2. Click Browse and select the project's directory of your web application to be configured. Click Next afterwards.

  3. Tick WebGrid.NET 7.0.7200 and put the Runtime License key according to the component. Click Next to proceed to the next step.

  4. In this step, there are many settings you can configure such as View State Storage, Optimization, Client Resources and Advanced sections.

    View State Storage Section

    View State Storage section lets you configure how ViewState is stored, specify how ViewState items are going to be saved in ViewState and determine the priority and duration of items stored in Cache object.

    Optimization Section

    Optimization section lets you choose whether to enable CSS Optimization and XML compression.

    Client Resources Section

    This section contains information on how to enable WebResources and set its mode.

    If you have applied SmartWebResources™ in your project, this option will be automatically selected with its default mode set to Auto.

    Advanced Section

    Advances section allows you to add necessary keys such as SharedScriptDirectory, ImagesDirectory or custom keys.

    In this section, you will learn how to assign the keys and values needed when you deploy the project.
    - In Advances section, click the ">" sign to move the available keys to the applied keys.
    - In Applied Keys table, Set the values like following:

    Key | Value
    ScriptDirectory | ~/CommonLibrary/WebGrid/V7_0_7200/
    SharedScriptDirectory | ~/CommonLibrary/Shared/
    ImagesDirectory | ~/CommonLibrary/Images/

    This section is very critical to be applied when you copy the CommonLibrary folder to the project's directory in development machine. However, if you have enabled SmartWebResources™, you no longer need to configure the directory settings.

  5. Click Next or Apply to save the configuration. Finally, the web.config has been updated successfully. Click Close to apply the settings.

See Also

Overview
Getting Started
WebGrid Features Overview

Other Resources
Walkthrough Topics
How-to Topics


Deploying project that uses SmartWebResources

Deploying project that uses SmartWebResources
See Also Send Feedback
Intersoft WebGrid > Getting Started > Deployment > Deployment Guide > Deploying project that uses SmartWebResources

Glossary Item Box

Intersoft Solutions constantly conduct extensive research and development to deliver new innovations that help developers become more productive by reducing the efforts and overwhelming complexity in both development and deployment stage.

SmartWebResources™ Framework is one of the great technology offered by Intersoft, which is used to eliminate the external physical resources such as scripts, images, etc.

WebGrid.NET Deployment Checklist

  1. RuntimeLicenseKey
    This is a key required in order to license the components for deployment purpose in production environment.

    Runtime license key is different with design-time license key that you get during purchase. Please obtain each licensed component's RuntimeLicenseKey from Intersoft Developer Network under My Component section. You only need to obtain once and reuse it in multiple projects. The login detail is provided in your purchase receipt. If you purchased from our resellers, it may take 24-48 hours for the verification and account creation process.

  2. Resources Assembly
    Ensure that you have copied the resources assemblies to your project's bin folder. The resources assembly can be found in C:\Program Files\Intersoft Solutions\WebUI Studio for ASP.NET\WebGrid.NET 7.0\Bin. The resources assemblies are:
    * ISNet.WebUI.WebGrid.Resources.dll
    * ISNet.WebUI.WebDesktop.Resources.dll
  3. Framework Assemblies
    You are required to copy framework assemblies to your project's bin folder. The framework assemblies can be found in C:\Program Files\Intersoft Solutions\WebUI Studio for ASP.NET\WebUI.NET Framework 3.0\Bin (Default installation directory). The framework assemblies are:
    * ISNet.dll
    * ISNet.WebUI.dll
  4. Component Assembly
    Component assembly is required to be copied to your project's bin folder. The component assembly can be found in C:\Program Files\Intersoft Solutions\WebUI Studio for ASP.NET\WebGrid.NET 7.0\Bin. The component assembly is:
    * ISNet.WebUI.WebGrid.dll
  5. Exporting Assembly
    Exporting assembly is required to be copied to your project's bin folder if the web application utilizes exporting feature in WebGrid. The exporting assembly can be found in C:\Program Files\Intersoft Solutions\WebUI Studio for ASP.NET\WebGrid.NET 7.0\Bin. The exporting assembly is:
    * ISNet.ActiveReports.Exporting.dll
  6. Charting Assembly
    Charting assembly is required to be copied to your project's bin folder if the web application utilizes charting feature in WebGrid. The charting assembly can be found in C:\Program Files\Intersoft Solutions\WebUI Studio for ASP.NET\WebGrid.NET 7.0\Bin. The charting assembly is:
    * ISNet.WebUI.WebGrid.ChartEngine.dll
    * ISNet.Nevron.Charting.dll

Deploying project that uses SmartWebResources™

Here are step-by-step instructions to deploy the project using SmartWebResources™:

  1. Before deploying the project, you have to configure SmartWebResources after you created a new web application. Click here for guidance.
  2. Next, you need to use Deployment Manager in order to set the web.config of your web application, such as defining Runtime License key. Please read Using Deployment Manager for more information.
  3. Finally, you simply need to XCopy all required web application files along with the bin folder (i.e. your project's directory) to a destination folder in your web server.

See Also

Overview
Getting Started
WebGrid Features Overview

Other Resources
Walkthrough Topics
How-to Topics


Deploying project that does not use SmartWebResources

Deploying project that does not use SmartWebResources
See Also Send Feedback
Intersoft WebGrid > Getting Started > Deployment > Deployment Guide > Deploying project that does not use SmartWebResources

Glossary Item Box

General

WebGrid.NET Enterprise is built on the top of WebUI.NET Framework. It includes the common concept, functionalities and features implemented in the framework level.

WebGrid.NET Deployment Checklist

  1. RuntimeLicenseKey.
    This is a key required in order to license the components for deployment purpose in production environment.

    Runtime license key is different with design-time license key that you get during purchase.

    Use Deployment Manager to set the project's Web.config. There are 2 important things you need to notice:

    - If you set CommonLibrary folder as IIS Virtual Directory in development machine, you may refer to Using Deployment Manager topic for guidance.

    - If you copy the CommonLibrary folder to the project's directory in development machine, you may refer to Using Deployment Manager topic under Advanced section for guidance.

    Please obtain each licensed component's RuntimeLicenseKey from Intersoft Developer Network under My Component section. You only need to obtain once and reuse it in multiple projects. The login detail is provided in your purchase receipt. If you purchased from our resellers, it may take 24-48 hours for the verification and account creation process.
  2. CommonLibrary
    All subfolders and files inside CommonLibrary folder is required.
  3. Framework Assemblies.
    You are required to copy framework assemblies to your project's bin folder. The framework assemblies can be found in C:\Program Files\Intersoft Solutions\WebUI Studio for ASP.NET\WebUI.NET Framework 3.0\Bin (Default installation directory). The framework assemblies are as following:
    * ISNet.dll
    * ISNet.WebUI.dll
  4. Component Assembly
    Component assembly is required to be copied to your project's bin folder. The component assembly can be found in C:\Program Files\Intersoft Solutions\WebUI Studio for ASP.NET\WebGrid.NET 7.0\Bin. The component assembly is as following:
    * ISNet.WebUI.WebGrid.dll
  5. Exporting Assembly
    Exporting assembly is required to be copied to your project's bin folder if the web application utilizes exporting feature in WebGrid. The exporting assembly can be found in C:\Program Files\Intersoft Solutions\WebUI Studio for ASP.NET\WebGrid.NET 7.0\Bin. The exporting assembly is:
    * ISNet.ActiveReports.Exporting.dll
  6. Charting Assembly
    Charting assembly is required to be copied to your project's bin folder if the web application utilizes charting feature in WebGrid. The charting assembly can be found in C:\Program Files\Intersoft Solutions\WebUI Studio for ASP.NET\WebGrid.NET 7.0\Bin. The charting assembly is:
    * ISNet.WebUI.WebGrid.ChartEngine.dll
    * ISNet.Nevron.Charting.dll

WebGrid.NET Deployment Guide

  1. If you set CommonLibrary folder as IIS Virtual Directory in development machine
    - XCopy all your required web application files along with the bin folder (i.e. your project's directory) to a destination folder in your web server.
    - XCopy the CommonLibrary folder to your web server. It is recommended to place it under wwwroot folder (usually c:\inetpub\wwwroot). You need to map the destination folder to IIS Virtual Directory with name "CommonLibrary".
  2. If you copy the CommonLibrary folder to the project's directory in development machine
    - XCopy all your required web application files along with the bin and CommonLibrary folders (i.e. your project's directory) to a destination folder in your web server.

    Creating CommonLibrary as IIS Virtual Directory is not required in this case.

See Also

Overview
Getting Started
WebGrid Features Overview

Other Resources
Walkthrough Topics
How-to Topics


Application Wide Configurations

Application Wide Configurations
See Also Send Feedback
Intersoft WebGrid > Getting Started > Deployment > Application Wide Configurations

Glossary Item Box

One of the unique features introduced since the initial products is the ability to configure specific deployment-related properties via web.config. WebUI.NET Framework further enhanced this capability by adding more properties which are configurable through web.config. Now, it also supports relative application path by using ~ character. The application-wide configurations feature allows centralized configuration for common deployment properties such as ScriptDirectory etc, which dramatically increase effectiveness and efficiency particularly for maintenance purpose.

Following is the list of properties that are configurable through web.config:

  • SharedScriptDirectory
  • ScriptDirectory
  • ImagesDirectory
  • LocalizationDirectory
  • RuntimeLicenseKey
  • MenuCssFile
  • EnableV3XAPISupport
  • HelpURL
  • AllowAutoDataCaching
  • CacheServerConnection
  • RenderingMode

The settings specified in web.config will only be applied to instances' properties that have Default value (unchanged).
The format of the key used for the configuration is AssemblyFullName.vProductVersion.Properties.

Examples:

The sample configuration in web.config below will change the property value of ScriptDirectory, ImagesDirectory, SharedScriptDirectory and LocalizationDirectory to all WebGrid V6.0.7200 instances in the application.

<configuration>

      <appSettings>

               <add key="ISNet.WebUI.WebGrid.v7_0_7200.ScriptDirectory" value="~/CommonLibrary/WebGrid/V7_0_7200/" />

               <add key="ISNet.WebUI.WebGrid.v7_0_7200.ImagesDirectory" value="~/CommonLibrary/Images/" />

               <add key="ISNet.WebUI.WebGrid.v7_0_7200.SharedScriptDirectory" value="/CommonLibrary/Shared/" />

               <add key="ISNet.WebUI.WebGrid.v7_0_7200.LocalizationDirectory" value="/CommonLibrary/WebGrid/V7_0_7200/Localization/" />

               <add key="ISNet.WebUI.WebGrid.v7_0_7200.CacheServerConnection" value="path=C:\Cache" />

      </appSettings>

      ... other settings

</configuration>

Additional application-wide configurations may be available specifically per product. Please refer to the Application-wide Configurations topic in the product's help file.

See Also

Overview
Getting Started
WebGrid Features Overview

Other Resources
Walkthrough Topics
How-to Topics


Upgrading

Upgrading
See Also Send Feedback
Intersoft WebGrid > Getting Started > Upgrading

Glossary Item Box

This section contains information on the breaking changes in WebGrid 6.0 and upgrading assembly reference from its previous version.

In This Section

Breaking Changes in WebGrid.NET Enterprise 6.0
Information about breaking changes in WebGrid 6.0 such as user interface and others.

Upgrading from previous version
Read about the latest upgrade in WebGrid 6.0.

How-to: Upgrade WebGrid samples to be used in Visual Studio.NET 2008
Information about how to upgrade WebGrid samples from Visual Studio.NET 2005 to Visual Studio.NET 2008.

See Also

Overview
Getting Started
WebGrid Features Overview

Other Resources
Walkthrough Topics
How-to Topics


Breaking Changes in WebGrid.NET Enterprise 6.0

Breaking Changes in WebGrid.NET Enterprise 6.0
See Also Send Feedback
Intersoft WebGrid > Getting Started > Upgrading > Breaking Changes in WebGrid.NET Enterprise 6.0

Glossary Item Box

There is no breaking changes in WebGrid.NET Enterprise 6.0. All existing object model, features and behaviors remain the same.

See Also

Overview
Getting Started
WebGrid Features Overview

Other Resources
Walkthrough Topics
How-to Topics


Upgrading from previous version

Upgrading from previous version
See Also Send Feedback
Intersoft WebGrid > Getting Started > Upgrading > Upgrading from previous version

Glossary Item Box

This section contains information on the upgrading areas from WebGrid's previous version.

In This Section

Overview
Read about the most significant major upgrade in WebGrid 6.0.

Assembly References
Learn how to migrate your existing web application to WebGrid 6.0.

Switching to new Client Side API
List all new changes in WebGrid's client side API.

See Also

Overview
Getting Started
WebGrid Features Overview

Other Resources
Walkthrough Topics
How-to Topics


Overview

Overview
See Also Send Feedback
Intersoft WebGrid > Getting Started > Upgrading > Upgrading from previous version > Overview

Glossary Item Box

WebGrid.NET Enterprise version 6.0 is the most significant major upgrade since initial version of WebGrid.NET containing key enhancements in user interface, enhanced grid functions, Excel® style column freezing, declarative data binding support and rich designer experience.

If you are planning to upgrade your existing web application to use WebGrid.NET Enterprise 6.0, please take the following points into consideration:

  • WebGrid.NET Enterprise 6.0 is especially designed for ASP.NET 2.0 in order to fully support native databinding features and new design-time features to improve developer's productivity. If your existing web application is still running on ASP.NET 1.x (developed using Visual Studio 2003), you cannot upgrade to version 5.0. We strongly encourage developers to start migrating to Visual Studio 2005 to obtain many benefits and features introduced in .NET 2.0.

    If you are a new web developer and would like to develop ASP.NET 2.0 web application using WebGrid.NET Enterprise 6.0, you may want to check out Microsoft's Visual Web Developer Express. Visual Web Developer Express is a lightweight version of Visual Studio 2005, and is provided for free by Microsoft. Since that WebGrid.NET Enterprise 6.0 is built on the top of Visual Studio 2005 architecture, Visual Web Developer Express is fully supported as well. To download Visual Web Developer Express, visit http://msdn.microsoft.com/vstudio/express/vwd/download/
  • Use new optimization features available in version 6.0 for better performance. Consider to enable the following features after your migration:
      • DefaultStyle
        Enable DefaultStyle feature in WebGrid will significantly reduce page output size, especially when large number of WebGrid is placed in a WebForm.
      • SmartWebResources
        When enabled, this feature will allow you to easily deploy WebGrid without the need of physical client scripts or client resources. With this feature, you can now develop ASP.NET 2.0 File System's website without additional efforts.

See Also

Overview
Getting Started
WebGrid Features Overview

Other Resources
Walkthrough Topics
How-to Topics


Assembly References

Assembly References
See Also Send Feedback
Intersoft WebGrid > Getting Started > Upgrading > Upgrading from previous version > Assembly References

Glossary Item Box

Our development team is working hard to ensure that you can upgrade your web application as smooth as possible in less efforts. You can easily migrate your existing web application to use version 6.0 by simply changing the assembly references to 6.0 assemblies. To upgrade an existing ASP.NET 2.0 web application to use WebGrid.NET Enterprise 6.0, please do the following:

  • Open an existing web application in Visual Studio 2005/Express
  • Expand Bin folder
  • Remove ISNet.dll, ISNet.WebUI.dll and ISNet.WebUI.WebGrid.dll
  • Right click on the Project node then click Add Reference
  • Add ISNet.dll, ISNet.WebUI.dll from [Installation Folder]\WebUI.NET Framework 3.0\Bin [Note that the file version should be 3.0.5000.400+]
  • Add ISNet.WebUI.WebGrid.dll from [Installation Folder]\WebGrid.NET 6.0\Bin
  • Rebuild your web application and run in browser
If you are planning to use new SmartWebResources™ feature available in WebGrid.NET Enterprise 5.0 for simpler deployment, please refer to SmartWebResources Deployment.
If your existing web application used WebGrid's Exporting feature, please do the following:
  • Remove all assemblies that started with ActiveReports from References.
  • WebGrid.NET Enterprise 6.0 comes with newer version of ActiveReports and simpler assembly deployment for Exporting feature. Now you only need to include one assembly reference for Exporting feature.
  • Add ISNet.ActiveReports.Exporting assembly from [Installation Folder]\WebGrid.NET 6.0\Bin

See Also

Overview
Getting Started
WebGrid Features Overview

Other Resources
Walkthrough Topics
How-to Topics


Switching to new Client Side API

Switching to new Client Side API
See Also Send Feedback
Intersoft WebGrid > Getting Started > Upgrading > Upgrading from previous version > Switching to new Client Side API

Glossary Item Box

Before getting started, the most important knowledge about the new changes is what kind of functions are deleted and what kind of functions are kept.

Global Functions

Global functions are defined as functions which don't belong to an object, and usually used as core function to perform object-independent operation, for example: wgGetCellByName, wgGetRowByRowByPositionExact and so on.

The global functions that kept in the previous version are mostly those which used as getter or setter that do not related to an object model. For example, these functions are still available in previous version:

wgGetGridById ' still supported, but recommended to use ISGetObject
wgGetCellCount
wgGetCellByPosition
wgIsRecordRow
wgGetRootRow

As you can see in the functions above, most of the available functions are those having these pattern "*Get", "*Is", and "*Set" AND those don't have relation to client objects.

For example, following functions are related to grid object and hence are obsolete in previous version:
wgSetCheckedRowsData(grid) - obsolete, changed as method of WebGrid object.
wgGetResponseText(grid) - obsolete, changed as method of WebGrid object.

The obsolete functions above have become part of the object model since it has relation to the object itself. So, to set checked rows data in previous version, you can simply use:

JavaScript Copy Image Copy Code
var grid = ISGetObject("WebGrid1");
grid.SetCheckedRowsData();

In addition to the obsolete pattern above, all functions that related to an action or task of object are obsolete as well, and have been moved as part of the object model.

For example:
wgMarkEdit(grid) - obsolete, use grid.MarkEdit()
wgExitEdit(grid, params) - obsolete, use grid.ExitEdit(params)

Object Model

The changes to "Members" or also called Properties of existing object model are not significant. 95% of them remain exist with same return value. The significantly changed part are the "Methods" where many new methods are added as the result of obsolete global functions (see section I. above).

Following is the list of existing objects and what have been changed (including new and obsolete methods)

WebGrid object

Method Name | New? | Obsolete | Replaced With
GettbGBBElement | - | x | GetElement
GettrGBBInfoElement | - | x | GetElement
SetAttribute | - | x | Set (See Common Object Methods)
GetAttribute | - | x | Get (See Common Object Methods)
GetElement | x | - | -

About GetElement method
The WebGrid and WebGridTable object now introduced GetElement method in order to obtain html element of the specified grid's part. The GetElement method replaced the old numerous methods such as GettbGBBElement, GetdvTBElement and so on; which are not effective and difficult to remember.

The GetElement method specification is as following:

WebGrid/WebGridTable
- GetElement(gridPart, htmlPart)

gridPart is the part of the grid you want to obtain. Valid values are:

Value | Description
COLHEADER | The column header element
COLFOOTER | The column footer element
BODY | The grid's body element
COLHEADERGROUP | The column header group element
COLFOOTERGROUP | The column footer group element
COLGROUP | The body's column group element
GROUPBYBOX | The group by box element
GROUPBYBOXLABEL | The group by box label element
STATUSBAR | The status bar element
STATUSBARRIGHT | The right part of the status bar element
STATUSICON | The icon part of the status bar element
STATUSBARCOMMAND | The command items part of the status bar element

htmlPart is the part of html you want to obtain. Valid values are:

Value | Description
HTMLDIV | The html DIV tag
HTMLTABLE | The html TABLE tag
HTMLCELL | The html TD tag
HTMLROW | The html TR tag

When specifying the values for gridPart and htmlPart, add the "WG40" as the prefix, which is used as the enum variable.

See below example:

Old approach:

Obtaining html table of body: table.gettbTBElement
Obtaining html div of col header : table.gettbCHElement

New approach:

Obtaining html table of body: table.GetElement(WG40.BODY, WG40.HTMLTABLE)
Obtaining html div of col header: table.GetElement(WG40.COLHEADER, WG40.HTMLDIV)

The single GetElement method is more effective in the programming model, as the name and parameters are quite easy to be used and recalled.

About Get/Set (Common Object Methods)

Get method
Every objects in WebGrid now have Get and Set method.

For example:

JavaScript Copy Image Copy Code
var grid = ISGetObject("WebGrid1");
alert(grid.Get("Visible"));

The purpose of the Get method is to overcome the limitation in IE's javascript language where there is no way to specify getter and setter.

For example:

grid.Visible <= resulting what the variable contains.
grid.Get("Visible") <= the object architecture executes the internal getter method (which really quering the visible state of the grid), and then returns the actual result.

However, most of the time both approaches will return the same value when there are no special getter method implemented.

Set method

Most of the time you can assign the value directly to an object, for example:

JavaScript Copy Image Copy Code
grid.LayoutSettings.AllowGrouping = false;

The above codes will affect only during the current runtime, and the changes will not be persisted in future postbacks.

The new object architecture now allowing the persistence of value changed in clients for future postbacks including both OnTheFly postbacks and full page postbacks. This is done by using the special Set method, for example:

JavaScript Copy Image Copy Code
grid.LayoutSettings.Set("AllowGrouping", false, true);

Notice that the set method has one extra parameter, that is to specify whether the value should be persisted for future postbacks.

The exact Set method definition is as following:

object.Set(propertyName, propertyValue, isPersisted);

See Also

Overview
Getting Started
WebGrid Features Overview

Other Resources
Walkthrough Topics
How-to Topics


How-to: Upgrade WebGrid samples to be used in Visual Studio.NET 2008

How-to: Upgrade WebGrid samples to be used in Visual Studio.NET 2008
See Also Send Feedback
Intersoft WebGrid > Getting Started > Upgrading > How-to: Upgrade WebGrid samples to be used in Visual Studio.NET 2008

Glossary Item Box

WebGrid samples from Visual Studio.NET 2005 are now available to be run in Visual Studio.NET 2008.

In this topic, you will learn how to perform the above scenario.

Upgrade WebGrid samples to be used in Visual Studio.NET 2008

  1. Open WebGrid C# or VB Samples in Visual Studio.NET 2008. It will ask you to convert and upgrade, do all as requested.

  2. Right click on the project's name and choose Add Reference.

  3. Focus on .NET tab and add System.Data.Linq.

See Also

Other Resources
Walkthrough Topics
How-to Topics


How-to: Get pending changes based on row state

How-to: Get pending changes based on row state
See Also Send Feedback

Glossary Item Box

WebGrid enhances its client side events by adding a method to get pending changes.

In this topic, you will learn how to get pending changes based on row state using button click event.

To get pending changes based on row state

  1. Drag HTML button to your WebForm.
  2. Write the following code in Button1_onclick client side event:

    Javascript Copy Image Copy Code
    function Button1_onclick()
{
   var grid = ISGetObject("WebGrid1");
   var state = "Modified";
   var key = grid.GetChanges(state)[0].KeyValues;
   alert(key);
}

  3. You can change the state variable to Added, Modified and Deleted. Depends on the row state that you want to get.
  4. Run the project.

See Also

Tasks
Walkthrough: Adding pending changes to WebGrid programmatically
How-to: Get all pending changes in WebGrid
How-to: Get pending changes on specific table
How-to: Undo changes on specific row
How-to: Accept all changes

Other Resources
Walkthrough Topics
How-to Topics


How-to: Get all pending changes in WebGrid

How-to: Get all pending changes in WebGrid
See Also Send Feedback

Glossary Item Box

WebGrid enhances its client side events by adding a method to get all pending changes.

In this topic, you will learn how to get all pending changes using GetChanges() method.

To get all pending in WebGrid

  1. Drag WebGrid and HTML button instances to your WebForm.
  2. You can get all changes in WebGrid that made during BatchUpdate operation by simply using:
    Javascript Copy Image Copy Code
    function Button1_Click()
{
   var grid = ISGetObject("WebGrid1");
   var allChanges = grid.GetChanges();
   return true;
}

  3. You can change the state variable to Added, Modified and Deleted. Depends on the row state that you want to get.
  4. Run the project.

See Also

Tasks
Walkthrough: Adding pending changes to WebGrid programmatically
How-to: Get pending changes based on row state
How-to: Get pending changes on specific table
How-to: Undo changes on specific row
How-to: Accept all changes

Other Resources
Walkthrough Topics
How-to Topics


How-to: Get pending changes on specific table

How-to: Get pending changes on specific table
See Also Send Feedback

Glossary Item Box

After doing some changes in BatchUpdate mode, you can also get pending changes on Specific table.

In this topic, you will learn how to get pending changes based on row state using button click event.

To get pending changes based on row state

  1. Binding WebGrid to hierarchical ISDataSource control.
  2. Set AllowReviewChanges property to true.
  3. Click on Review Pending Changes icon or right click on row to active Row Context Menu then choose Review Changes option.
  4. You can select the specific tables at the top.

  5. Use snippet codes for the first changes in both tables.
    C# Copy Code
    function Button1_onclick()
{
   var grid = ISGetObject("WebGrid1");
   alert("Table "+ grid.RootTable.DataMember + " has "+ grid.RootTable.GetChangesCount() + " and Table "+
grid.RootTable.ChildTables[0].DataMember + " has "+ grid.RootTable.ChildTables[0].GetChangesCount());

   alert("Table " + grid.RootTable.DataMember + " modified CustomerID " + grid.RootTable.GetChanges()[0].KeyValues + " and Table " + grid.RootTable.ChildTables[0].DataMember + " modified OrderID " + grid.RootTable.ChildTables[0].GetChanges()[0].KeyValues);
}

See Also

Tasks
Walkthrough: Adding pending changes to WebGrid programmatically
How-to: Get pending changes based on row state
How-to: Get all pending changes in WebGrid
How-to: Undo changes on specific row
How-to: Accept all changes

Other Resources
Walkthrough Topics
How-to Topics


How-to: Undo changes on specific row

How-to: Undo changes on specific row
See Also Send Feedback

Glossary Item Box

WebGrid provides a method to undo changes on specific row.

In this topic, you will learn how to cancel changes in the BatchMode update WebGrid.

To get pending changes based on row state

Using Context Menu

  1. Open the review changes window, by clicking the Review Pending Changes button in the WebGrid status bar or clicking the Review Changes... item on the context menu.

  2. Select the row you would like to cancel update/delete.
  3. Click the "Undo Selected" button.

Using Client-side

  1. Use this snippet to cancel changes on the first changed row.
    C# Copy Code
    var grid = ISGetObject("WebGrid1");
grid.GetChanges()[0].Row.UndoChanges();

See Also

Tasks
Walkthrough: Adding pending changes to WebGrid programmatically
How-to: Get pending changes based on row state
How-to: Get all pending changes in WebGrid
How-to: Get pending changes on specific table
How-to: Accept all changes

Other Resources
Walkthrough Topics
How-to Topics


How-to: Accept all changes

How-to: Accept all changes
See Also Send Feedback

Glossary Item Box

WebGrid 7 also supports scenario that submits all updates in a single AJAX request via built-in WebGrid user interface, or via API.

In this topic, you will learn how to accept all changes from client side event.

To accept all changes

  1. Creating Updatable Hierarchical WebGrid in Batch Update mode (Using ISDataSource).
  2. Open the page in VS Design view and add an HTML button.
  3. Double click the button in order to add OnClick client side event of the button.

    <input id="Button1" type="button" value="Accept All Changes" onclick="return Button1_onclick()" />
  4. On OnClick event of the button, write the following function:
    C# Copy Code
    function Button1_onclick()
{
   var grid = ISGetObject("WebGrid1");
   grid.AcceptAllChanges();
   return true;
}

  5. View the page in browser, make any changes to the grid, and click the button to accept all changes.

See Also

Tasks
How-to: Get pending changes based on row state
How-to: Get all pending changes in WebGrid
How-to: Get pending changes on specific table
How-to: Undo changes on specific row

Other Resources
Walkthrough Topics
How-to Topics


How-to: Enable Column Action

How-to: Enable Column Action
See Also Send Feedback

Glossary Item Box

In addition to the new dazzling Windows 7 theme, WebGrid 7 now supports Column Action UI - a small option indicator that will appear when you hover on the column header.

In this topic, you will learn how to enable column action using ShowColumnAction property.

To enable column action

  1. Right click on WebGrid control and choose Properties.
  2. In the Properties box, expand LayoutSettings.
  3. Set ShowColumnAction to True.

See Also

Tasks
How-to: Add new menu items in Column Action

Other Resources
Walkthrough Topics
How-to Topics


How-to: Add new menu items in Column Action

How-to: Add new menu items in Column Action
See Also Send Feedback

Glossary Item Box

WebGrid also supports column action customization, for instances, adding new commands or displaying predefined filter menu similar to Windows Explorer.

In this topic, you will learn how to customize menu items in column action using OnColumnAction client side event.

To add new menu items in Column Action

  1. Bind WebGrid to AccessDataSource control.
  2. Drag WebContextMenu control from Toolbox.
  3. Right click on WebContextMenu control and choose Visual Menu Builder.
  4. Create menu items according to your needs, for example:

  5. Enable Column Action.
  6. Put the following code in OnColumnAction client-side event to attach your custom column action.
    JavaScript Copy Code
    function OnColumnAction(controlId, column)
{
   if (column.Name == "ContactName")
   {
      var menu = ISGetObject("addItemMenu");
      var grid = ISGetObject(controlId);
      var eventLocation = menu.GetEventLocation();

      eventLocation.X -= 8;
      eventLocation.Y += 100;
      menu.Show(eventLocation);
      grid.ActionBoxShown = true;
      return false;
   }
}

  7. Invoke OnColumnAction() method using OnColumnAction client side events in WebGrid.

    <ClientSideEvents OnColumnAction="OnColumnAction" />
  8. Run the project and it will look like following:

See Also

Tasks
How-to: Enable Column Action

Other Resources
Walkthrough Topics
How-to Topics


How-to: Use WebTextEditor custom editor

How-to: Use WebTextEditor custom editor
See Also Send Feedback

Glossary Item Box

WebGrid 7 now supports integration with Intersoft's WebTextEditor as editing type. Natively integrated into WebGrid's inline editing architecture, WebTextEditor delivers the best rich text editing experiences for your data applications.

In this topic, you will learn how to use WebTextEditor custom editor.

To use WebTextEditor custom editor

  1. Bind WebGrid to ISDataSource control (Use Products table).
  2. Drag WebTextEditor control from Toolbox. Set the ID as wte1.
  3. Right click on WebTextEditor control and choose WebGrid.NET Designer.
  4. Go to Columns and set one of the column's Edit Control Type to WebTextEditor.

  5. Click See all properties and set CustomEditorServerId to wte1.

  6. Run the project. Try to double click on the Details cell to edit the value using WebTextEditor. When you finished the editing, simply click the provided Update button in the toolbar to apply your changes.

See Also

Other Resources
Custom Editors Pack 3
Walkthrough Topics
How-to Topics


How-to: Customize Pivot Chart User Interface

How-to: Customize Pivot Chart User Interface
See Also Send Feedback

Glossary Item Box

WebGrid.NET Enterprise comes with Interactive UI feature where you can customize the ChartView at run time. It also has a feature to customize the Chart Ribbon. With this option, you can limit what kind of interactions that a user can do with Chart Interactive UI.

WebGrid.NET Enterprise comes with Interactive UI feature where you can customize the ChartView at run time. The pivoting rules for the Chart Interactive UI includes:

  • ShowInChartFieldList
  • CanAddToChartData
  • CanAddToChartCategories
  • CanAddToChartFilter
  • CanAddToChartSeries

In this topic, you will learn how to enable hide chart ribbon initially, customize chart ribbon and pivot rules in WebGrid.

To hide Chart Ribbon initially

  1. Open WebGrid.NET Properties.
  2. In Charting properties go to ChartInteractiveUI and set RibbonState to Hidden.
  3. Run the project.

To customize Chart Ribbon in WebGrid

  1. Open WebGrid.NET Properties.
  2. In Charting properties go to ChartInteractiveUI, set TitlesRibbon visible to false.
  3. Set ChartTypeRibbon visible to false.
  4. Run the project.

To customize Pivot Rules in WebGrid

  1. Open WebGrid.NET Designer.
  2. Switch to Advanced tab. Expand RootTable >> Columns.
  3. Choose appropriate WebGridColumn Properties, customize one or all properties from above pivoting rules. For example: Select OrderID and set ShowInChartFieldList to true.
  4. Run the project.

See Also

Tasks
How-to: Customize Chart Ribbon
How-to: Customize Pivot Rules

Other Resources
Walkthrough Topics
How-to Topics


How-to: Customize Pivot Chart View

How-to: Customize Pivot Chart View
See Also Send Feedback

Glossary Item Box

WebGrid provides feature that enables the grid to show Pivot Chart view initially,but you can still revert back to GridView from status bar. Or, It can also enable the grid to show only Pivot Chart view and you are not able to revert back to GridView.

WebGrid also enables user to display both pivot chart and grid view at the same time.

In this topic, you will learn how to show pivot chart view initially, display pivot chart only and display both pivot chart and grid view.

To show Pivot Chart View initially

  1. Right click on WebGrid instance and click on WebGrid.Net Designer.
  2. Go to Advanced tab >> WebGrid >> LayoutSettings and set the InitialView to PivotChartView.
  3. Click Apply >> OK.
  4. Run the project.

To display Pivot Chart only

  1. Right click on WebGrid instance and click on WebGrid.Net Designer.
  2. Go to Advanced tab >> WebGrid >> LayoutSettings and set the InitialView to PivotChartViewExclusive.
  3. Click Apply >> OK.
  4. Run the project.

To display both Pivot Chart and Grid View

  1. Right click on WebGrid instance and click on WebGrid.Net Designer.
  2. Go to Advanced tab >> WebGrid >> LayoutSettings and set the InitialView to Both.
  3. You also need to set the ChartDisplayPosition to Bottom.
  4. Click Apply >> OK.
  5. Run the project.

See Also

Tasks
How-to: Display both Pivot Chart and Grid View
How-to: Move Pivot Chart view to another container using WebTab

Other Resources
Walkthrough Topics
How-to Topics


How-to: Configure Pivot Chart Header and Legend

How-to: Configure Pivot Chart Header and Legend
See Also Send Feedback

Glossary Item Box

WebGrid provides a way for you to change the chart title or header position.

By default, the chart legend position is set to right. However, you can customize the position to None, Top, Bottom, or Left.

The chart legend layout is set to RowOnly by default. You can change the layout to ColsOnly, RowFixed, or ColsFixed.

In this topic, you will learn how to the change the chart title/header position in the chart image, change the position of the chart legend and change its layout.

To change the chart title/header position in the chart image.

  1. Open WebGrid.NET Designer.
  2. Go to Pivot Charting Tab.
  3. Select Header and click See all properties.
  4. Set the Text to "Chart Header".
  5. Select TextStyle >> FontStyle.
  6. Set the EmSize to 18.
  7. Click OK to apply the changes.
  8. Run the project.
  9. Please see the Chart Header Layout from LiveSamples >> WebGrid >> ChartHeader for the result.

To change the position of the chart legend to Left

  1. Open WebGrid.NET Designer.
  2. Go to Pivot Charting Tab.
  3. Select Legend.
  4. In the Docking, set the Docking to Left.

  5. Click OK to apply the changes.
  6. Run the project.

To change the layout of the chart legend

  1. Open WebGrid.NET Designer.
  2. Go to Pivot Charting Tab.
  3. Select Legend.
  4. In the Layout, set the Expand Mode to ColsOnly.
  5. Click OK to apply the changes.
  6. Run the project.

See Also

Other Resources
Walkthrough Topics
How-to Topics


How-to: Customize Column Freezing

How-to: Customize Column Freezing
See Also Send Feedback

Glossary Item Box

WebGrid provides methods to freeze/unfreeze WebGrid column at runtime, change the FreezePane splitter line's appearance from designer.

With AbsoluteScrolling enabled, WebGrid is also able to automatically adjust the viewport to the next available column when user pressed on the left/right arrow of horizontal scrollbar. This behavior allows users to conveniently scroll through all the columns with less clicks.

In this topic, you will learn how to customize column freezing.

To allow user to freeze/unfreeze at runtime

  1. Bind WebGrid to AccessDataSource (Using Customers table from NorthWind data source).
  2. Open WebGrid.NET SmartTag and check Allow Column Freezing.
  3. Open WebGrid.NET Designer - Layout Settings.
  4. Search for FreezePaneSettings.
  5. Set ShowInContextMenu to True.

Try to right click on WebGrid header (CompanyName) then click Freeze Pane.

The result is CustomerID and CompanyName columns will become freeze columns.

To change splitter line's appearance

  1. Follow steps on the topic above (To allow user to freeze/unfreeze at runtime).
  2. Open WebGrid.NET designer.
  3. Search for FreezePaneSettings.
  4. Set SplitterLineColor to ForestGreen.
  5. Set SplitterLineWidth to 5.

To enable absolute scrolling

  1. Follow steps on the topic above (To allow user to freeze/unfreeze at runtime).
  2. Open WebGrid.NET designer.
  3. Search for FreezePaneSettings.
  4. Set AbsoluteScrolling to True.

See Also

Tasks
How-to: Enable column freezing and configure initial settings
How-to: Enable absolute scrolling

Other Resources
Walkthrough Topics
How-to Topics


How-to: Enable Multiple Row Selection with Keyboard Support

How-to: Enable Multiple Row Selection with Keyboard Support
See Also Send Feedback

Glossary Item Box

WebGrid.NET has capability to perform multiple selection without the need to use checkboxes.

In this topic, you will learn how to enable Multiple Row Selection with keyboard support.

To enable Multiple Row Selection with Keyboard Support

  1. Bind WebGrid to AccessDataSource (Using Products table from NorthWind data source).
  2. Go to WebGrid's properties by pressing F4 on WebGrid control or you can simply right click on WebGrid and choose Properties.
  3. Expand LayoutSettings and set AllowMultipleSelection to Yes.
  4. By using keyboard combination of Ctrl, Shift and Click, you can perform multiple row selection.
  5. Things to explore:
    • Ctrl + Click. Try to hold Ctrl key and click on different random rows. The clicked rows will become selected.
    • Shift + Click. Try to click a row for the selection start. Then hold Shift key and click on the destination row. The rows between start and destination selection will become selected. You can do this in both upward and downward directin.
    • Ctrl + Shift + Click. After you tried the above combination, you can hold Ctrl and Shift at the same time, and click on the destination row. It enables you to select a range of contagious rows while preserving the previous selection.
    • Right click on the selection. A new menu item "Copy Selection" is now added when there is active selection in WebGrid.

See Also

Tasks
How-to: Access the selected rows in client side and server side

Other Resources
Walkthrough Topics
How-to Topics


How-to: Sort Column Initially

How-to: Sort Column Initially
See Also Send Feedback

Glossary Item Box

WebGrid provides feature to sort column initially from designer.

In this topic, you will learn how to sort column initially.

To sort column initially

  1. Bind WebGrid to AccessDataSource (Using Customers table from NorthWind data source).
  2. Right click on WebGrid and choose WebGrid.NET Designer.
  3. Select Allow Sorting in Popular Settings section.
  4. Go to Advanced Tab. Expand RootTable >> SortColumns.
  5. Add a column. Set ColumnMember to ContactName and SortOrder to Ascending.
  6. Run the project and WebGrid will sort ContactName column initially.

See Also

Other Resources
Walkthrough Topics
How-to Topics


How-to: Customize Group Intervals

How-to: Customize Group Intervals
See Also Send Feedback

Glossary Item Box

There are about 11 new Group Interval modes that you can apply to the GroupColumn such as Text, Alphabetical, Date, Month, ShortTime, NamePeriod and so on.

In this topic, you will learn how to apply Alphabetical and case sensitive group interval.

To apply Alphabetical Group Interval

  1. Open WebGrid.NET Designer.
  2. Click See all properties. Set GroupByBoxVisible to True.
  3. Switch to Advanced tab. Expand RootTable and select GroupColumns.
  4. Add a column. Set ColumnMember to ContactName, GroupInterval to Alphabetical, SortOrder to Ascending.
  5. Run the project. WebGrid will group ContactName column alphabetically.

To apply Case Sensitive Group

  1. Open WebGrid.NET Designer.
  2. Click See all properties. Set AllowGrouping to Yes and GroupByBoxVisible to True.
  3. Switch to Advanced tab. Expand RootTable and select Columns.
  4. Select ContactTitle column and set CaseSensitiveGrouping to No.
  5. Run the project. When ContactTitle column contains data like "Owner", "owner", "oWner", WebGrid will ignore the case sensitive when you enable grouping. Therefore, WebGrid will group them into 1, that is "Owner".

See Also

Other Resources
Walkthrough Topics
How-to Topics


How-to: Group column initially

How-to: Group column initially
See Also Send Feedback

Glossary Item Box

WebGrid provides feature to group column initially from designer.

In this topic, you will learn how to group column initially.

To group column initially

  1. Bind WebGrid to AccessDataSource (Using Customers table from NorthWind data source).
  2. Right click on WebGrid and choose WebGrid.NET Designer.
  3. Click See all properties. Set GroupByBoxVisible to True.
  4. Switch to Advanced tab. Expand RootTable and select GroupColumns.
  5. Add a column. Set ColumnMember to Country, SortOrder to Ascending.
  6. Run the project. WebGrid will group Country column initially.

See Also

Other Resources
Walkthrough Topics
How-to Topics


How-to: Enable Group Footer

How-to: Enable Group Footer
See Also Send Feedback

Glossary Item Box

WebGrid is able to show column footer total which is fixed and non-scrolled as users scroll the table's content. The column footer total shows the summary information of all rows, regardless of grouped rows.

In this topic, you will learn how to enable Group Footer total.

To enable Group Footer

  1. Bind WebGrid to AccessDataSource (Using Invoices table from NorthWind data source).
  2. Right click on WebGrid and choose WebGrid.NET Designer.
  3. Click See all properties. Set GroupByBoxVisible to True.
  4. Switch to Advanced tab. Expand RootTable and select GroupColumns.
  5. Add two columns. The first column, set ColumnMember to CustomerID, SortOrder to Ascending. The second one, set ColumnMember to ProductName, SortOrder to Ascending.
  6. Go to Columns. Select UnitPrice and set AggregateFunction to Avg and FooterText to "Avg:".
  7. Select Quantity and set AggregateFunction to Sum and FooterText to "Sum:".
  8. Select Discount and set AggregateFunction to Max and FooterText to "Max:".
  9. Run the project.

See Also

Other Resources
Walkthrough Topics
How-to Topics


How-to: Enable Column Grouping with WebValueList

How-to: Enable Column Grouping with WebValueList
See Also Send Feedback

Glossary Item Box

WebGrid now supports column grouping along with WebValueList.

In this topic, you will learn how to enable column grouping with WebValueList.

To enable column grouping with WebValueList

  1. Bind Products, Supplies and Categories tables using ISDataSource.
  2. Right click on WebGrid and choose WebGrid.NET Designer.
  3. Click See all properties. Set GroupByBoxVisible to True.
  4. Switch to Advanced tab. Expand RootTable and select GroupColumns.
  5. Add a column. Set ColumnMember to SupplierID, GroupInterval to Text, SortOrder to Ascending.
  6. Go to Columns. Select SupplierID and go to Value List section.
  7. Set DataMember to Suppliers, Data Text Field to CompanyName and Data Value Field to SupplierID.
  8. Click See all properties. Set GroupInterval to Text and GroupRowInfoFormat to Supplier : [value].
  9. Run the project.

See Also

Tasks
How-to: Enable Automatic Filter suggestion
Walkthrough: Configuring automatic column sorting for a column using WebValueList

Other Resources
Walkthrough Topics
How-to Topics


How-to: Enable Automatic Filter suggestion

How-to: Enable Automatic Filter suggestion
See Also Send Feedback

Glossary Item Box

Automatic Filter Suggestion feature enables users to easily perform data filtering based on the currently selected cell.

In this topic, you will learn how to use Automatic Filter suggestion.

To enable Automatic Filter suggestion

  1. Open WebGrid.NET Designer.
  2. Click See all properties. Set AutoFilterSuggestion to True.
  3. Run the project.

See Also

Tasks
How-to: Enable Column Grouping with WebValueList
How-to: Enable Group Footer

Other Resources
Walkthrough Topics
How-to Topics


How-to: Filter column initially

How-to: Filter column initially
See Also Send Feedback

Glossary Item Box

WebGrid provides feature to filter column initially from designer.

In this topic, you will learn how to filter column initially.

To filter column initially

  1. Bind WebGrid to AccessDataSource (Using Customers table from NorthWind data source).
  2. Right click on WebGrid and choose WebGrid.NET Designer.
  3. Select Allow Filtering to show the filter bar.
  4. Switch to Advanced tab. Expand RootTable and select FilterColumns.
  5. Add a column. Set ColumnMember to ContactName, FilterText to Maria and FilterType to Like.
  6. Run the project. WebGrid will filter ContactName column based on text "Maria".

See Also

Other Resources
Walkthrough Topics
How-to Topics


How-to: Use WebCombo as Filter Editing Control

How-to: Use WebCombo as Filter Editing Control
See Also Send Feedback

Glossary Item Box

WebGrid enhances its feature to be able to set WebCombo as Filter editing control.

In this topic, you will learn how to use WebCobmo as Filter editing control from designer.

To use WebCombo as Filter editing control

  1. Bind WebGrid to AccessDataSource (Using Products table from NorthWind data source).
  2. Bind WebCombo to AccessDataSource (Using Products table as well).
  3. Open SmartTag. Set View Name to Products, Display Member to ProductName and Value Member to ProductName.
  4. Open WebGrid.NET Designer and go to Advanced tab. Select Columns and choose ProductName.
  5. Click See all properties. Set FilterEditType to WebComboNET and WebComboID to the WebCombo ID. (In this case, the id is WebCombo1).
  6. Run the project.

See Also

Tasks
How-to: Access the selected rows in client side and server side
How-to: Enable Multiple Row Selection with Keyboard Support

Other Resources
Walkthrough Topics
How-to Topics


How-to: Customize Classic Paging Interface

How-to: Customize Classic Paging Interface
See Also Send Feedback

Glossary Item Box

WebGrid provides three built-in user interface styles for the classic paging feature.

In this topic, you will learn how to customize classic paging UI.

To customize Classic Paging interface

  1. Open WebGrid.NET Designer and click See all properties.
  2. Set PagingMode to ClassicPaging.
  3. You can customize paging interface by setting Paging StyleUI to FirstPrevNextLast or SimpleDropDown or Slider.

See Also

Other Resources
Walkthrough Topics
How-to Topics


How-to: Implement Classic Paging in Client Binding

How-to: Implement Classic Paging in Client Binding
See Also Send Feedback

Glossary Item Box

WebGrid enables classic paging in client binding.

In this topic, you will learn how to implement Classic Paging in Client Binding.

To implement Classic Paging in Client Binding

  1. Configure client-binding using ServerDataSource mode.
  2. Open WebGrid.NET Designer. Set the following properties.
    Properties | Value
    PagingMode | ClassicPaging
    PagingStyleUI | Slider
    PagingLoadMode | Custom
    PagingDataRetrievalMode | ReturnPartialRow
    PagingSize | 15

  3. Run the project.

See Also

Tasks
How-to: Bind client-binding to Client DataSource
How-to: Use Batch Update Client Binding

Other Resources
Walkthrough Topics
How-to Topics


How-to: Enable Pivot Chart Both View with Classic Paging

How-to: Enable Pivot Chart Both View with Classic Paging
See Also Send Feedback

Glossary Item Box

WebGrid enables user to combine slider style paging with pivot chart view.

In this topic, you will learn how to enable pivot chart both view with classic paging.

To enable Pivot Chart both view with Classic Paging

  1. Display both Pivot Chart and Grid View.
  2. Set PagingMode to ClassicPaging and PagingStyleUI to Slider.

See Also

Tasks
How-to: Export all data when Classic Paging is enabled

Other Resources
Walkthrough Topics
How-to Topics


How-to: Customize VirtualLoad Paging Size

How-to: Customize VirtualLoad Paging Size
See Also Send Feedback

Glossary Item Box

WebGrid allows you to customize paging size in VirtualLoad mode.

In this topic, you will learn how to customize VirtualLoad Paging size.

To customize VirtualLoad Paging size

  1. Set Virtual Load in WebGrid.
  2. Set the VirtualPageSize property to specify the number of rows to retrieve. (e.g. 20).

See Also

Other Resources
Walkthrough Topics
How-to Topics


How-to: Use VirtualLoad in Large Data

How-to: Use VirtualLoad in Large Data
See Also Send Feedback

Glossary Item Box

WebGrid allows user to use VirtualLoad in large data.

In this topic, you will learn how to apply VirtualLoad in large data.

To use VirtualLoad in large data

  1. Set Virtual Load in WebGrid.
  2. Set the VirtualLoadMode property to LargeData.

See Also

Other Resources
Walkthrough Topics
How-to Topics


How-to: Implement Custom Load-On-Demand Paging

How-to: Implement Custom Load-On-Demand Paging
See Also Send Feedback

Glossary Item Box

WebGrid enables user to apply custom Load-On-Demand paging.

In this topic, you will learn how to implement custom Load-On-Demand Paging.

To implement custom Load-On-Demand Paging

  1. Bind WebGrid to ISDataSource (Using Customers table).
  2. Open WebGrid.NET Designer. Click See all Properties and set PagingMode to VirtualLoad, VirtualLoadMode to Custom.
  3. Open ISDataSource.NET Designer. Go to Tables and select Customers.
  4. Set EnablePaging to True, MaximumRowsParameterName to maximumRows, SelectCountMethod to SelectCount and StartRowIndexParameterName to startRowIndex.
  5. You need to prepare two method with the correct parameter in DAL :
    • Select Method with 3 parameters : startRowIndex, maximumRows, and sortExpression.
      e.g : public DataTable GetData(int startRowIndex, int maximumRows, string sortExpression)
    • SelectCount Method with 1 parameter : sortExpression
      e.g : public int SelectCount(string sortExpression)

See Also

Other Resources
Walkthrough Topics
How-to Topics


How-to: Customize Keyboard Support for Data Editing

How-to: Customize Keyboard Support for Data Editing
See Also Send Feedback

Glossary Item Box

WebGrid enables user to customize keyboard support to edit data.

In this topic, you will learn how to use "Enter" key to apply data editing.

To customize keyboard support for data editing

  1. Open WebGrid.NET Designer and click See all properties.
  2. Set AllowEdit to Yes and ApplyChangesKey to Enter.

See Also

Other Resources
Walkthrough Topics
How-to Topics


How-to: Customize Row Lost Focus Action

How-to: Customize Row Lost Focus Action
See Also Send Feedback

Glossary Item Box

WebGrid provides properties to enable user to customize row lost focus action.

In this topic, you will learn how to customize Row Lost Focus Action.

To customize Row Lost Focus Action

  1. Open WebGrid.NET Designer and click See all properties.
  2. Set AllowAddNew to Yes and AllowEdit to Yes.
  3. Set NewRowLostFocusAction to NeverUpdate/AlwaysPrompt/AlwaysUpdate. This action is used when the new row has lost its focus while the contained cells has been changed. Applied to data adding scenario.
  4. Set RowLostFocusAction to NeverUpdate/AlwaysPrompt/AlwaysUpdate. This action is used when the row has lost its focus while the contained cells has been changed. Apply to data editing scenario.

See Also

Other Resources
Walkthrough Topics
How-to Topics


How-to: Disable Editing in certain columns

How-to: Disable Editing in certain columns
See Also Send Feedback

Glossary Item Box

WebGrid provides feature to use different edit control for the new input.

In this topic, you will learn how to disable editing in certain columns.

To disable editing in certain columns

  1. Open WebGrid.NET Designer and click See all properties.
  2. Set AllowAddNew to Yes and AllowEdit to Yes.
  3. Go to Advanced tab. Expand RootTable and select Columns.
  4. Select CustomerID. Set EditType to NoEdit and NewRowEditType to TextBox.
  5. Run the project. In this case, WebGrid disables the editing for CustomerID column in normal row, while still allows editing for the column in new row

See Also

Other Resources
Walkthrough Topics
How-to Topics


How-to: Set default text for specific columns

How-to: Set default text for specific columns
See Also Send Feedback

Glossary Item Box

WebGrid can assign default values to the NewRow interface when user clicks on the NewRow area.

In this topic, you will learn how to set default text for specific columns when adding new row.

To set default text for specific columns

  1. Open WebGrid.NET Designer and click See all properties.
  2. Set AllowAddNew to Yes, AllowEdit to Yes, MarkDefaultValueAsDirty to False and NewRowLostFocusAction to AlwaysPrompt.
  3. Go to Advanced tab. Select Columns and choose ContactName.
  4. Set DefaultValue to Maria.
  5. Run the project. When you click on the NewRow, WebGrid will automatically assign value "Maria" on ContactName column.

See Also

Other Resources
Walkthrough Topics
How-to Topics


How-to: Display CallOut Notification during Batch Update

How-to: Display CallOut Notification during Batch Update
See Also Send Feedback

Glossary Item Box

When you set focus to other elements out from WebGrid, a Vista-style callout will appear to notify when you have unsaved pending changes.

In this topic, you will learn how to display CallOut notification during Batch Update.

To display CallOut notification

  1. Open WebGrid.NET Designer and click See all properties.
  2. Set AllowBatchUpdate to True, AllowAddNew to Yes, AllowEdit to Yes and AllowDelete to Yes.
  3. Expand BatchUpdateSettings and set NotifyOnLostFocus to True.
  4. Run the project.

See Also

Other Resources
Walkthrough Topics
How-to Topics


How-to: Trigger Data Export in Client-Side Programmatically

How-to: Trigger Data Export in Client-Side Programmatically
See Also Send Feedback

Glossary Item Box

WebGrid provides method to trigger exporting from client-side.

In this topic, you will learn how to trigger data export in Client-Side programmatically.

To trigger data export in Client-Side

  1. Open WebGrid.NET Designer and select Allow Exporting.
  2. Place a html button in the WebForm and named it as Button1.
  3. Put the following code under Button1_onclick() client-side event.

    Javascript Copy Image Copy Code
    function Button1_onclick()
{
   // retrieves WebGrid's object
   var WebGrid1 = ISGetObject("WebGrid1");
   WebGrid1.ExportGrid("", "EXCEL", "PORTRAIT"); // export grid to excel
}

  4. Invoke Button1_onclick from the html button like following:

    <input id="Button1" type="button" value="Export From Client" language="javascript" onclick="return Button1_onclick()" />

  5. Run the project.

See Also

Other Resources
Walkthrough Topics
How-to Topics


How-to: Create WebGrid in Server-Side programmatically

How-to: Create WebGrid in Server-Side programmatically
See Also Send Feedback

Glossary Item Box

WebGrid provides events in Server-Side to enable user implementing several tasks.

In this topic, you will learn how to create WebGrid in Server-Side programmatically.

To create WebGrid in Server-Side programmatically

  1. Put the following code in Page_Load event. These codes are used to define WebGrid's settings and events.
    C# Copy Image Copy Code
    protected void Page_Load(object sender, EventArgs e)
{
   WebGrid grid = new WebGrid();
   grid.ID = "WebGrid1";
   grid.Width = System.Web.UI.WebControls.Unit.Pixel(800);
   grid.Height = System.Web.UI.WebControls.Unit.Pixel(600);
   grid.UseDefaultStyle = true;

   grid.InitializeDataSource += new DataSourceEventHandler(grid_InitializeDataSource);
   grid.PrepareDataBinding += new DataSourceEventHandler(grid_PrepareDataBinding);
   grid.InitializeLayout += new LayoutEventHandler(grid_InitializeLayout);

   form1.Controls.Add(grid);
}

  2. Put the following code in OnInit event.
    C# Copy Image Copy Code
    protected override void OnInit(EventArgs e)
{
   base.OnInit(e);
}

  3. Put the following code in InitializeDataSource Server-Side event of WebGrid. These codes are used to bind the Customers table to DataSource.
    C# Copy Image Copy Code
    protected void grid_InitializeDataSource(object sender, ISNet.WebUI.WebGrid.DataSourceEventArgs e)
{
   dsNorthwind.CustomersDataTable dt = new dsNorthwind.CustomersDataTable();
   dsNorthwindTableAdapters.CustomersTableAdapter da = new dsNorthwindTableAdapters.CustomersTableAdapter();
   da.Fill(dt);
   e.DataSource = dt;
}

  4. Put the following code in PrepareDataBinding Server-Side event of WebGrid. These codes are used to retrieve and display the table structure in WebGrid.
    C# Copy Image Copy Code
    private void grid_PrepareDataBinding(object sender, ISNet.WebUI.WebGrid.DataSourceEventArgs e)
{
   if (!IsPostBack)
   {
      WebGrid grid = (WebGrid)sender;
      grid.RetrieveStructure();
   }
}

  5. Put the following code in InitializeLayout Server-Side event of WebGrid. These codes are used to set the layout settings available in WebGrid. In this case, WebGrid is set to enable context menu, export and edit.
    C# Copy Image Copy Code
    protected void grid_InitializeLayout(object sender, ISNet.WebUI.WebGrid.LayoutEventArgs e)
{
   e.Layout.AllowContextMenu = true;
   e.Layout.AllowExport = Export.Yes;
   e.Layout.AllowEdit = Edit.Yes;
}

  6. Run the project.

See Also

Other Resources
Walkthrough Topics
How-to Topics


How-to: Use Basic Client APIs

How-to: Use Basic Client APIs
See Also Send Feedback

Glossary Item Box

WebGrid provides a set of comprehensive client side API to let developers extend the Grid for their own use.

In this topic, you will learn how to use several basic Client-Side APIs.

To get WebGrid object

Use ISGetObject function to get the client object reference of any Intersoft's components, instead of using different function for each.

This topic will show you how to get WebGrid's object using ISGetObject.

  1. Drag WebGrid instance into the WebForm.
  2. Add a Client-Side function.
  3. JavaScript Copy Code
    var grid = ISGetObject("WebGrid1");

To get WebGrid selected row

Use GetSelectedObject function to get selected row in WebGrid via client side.

This topic will show you how to get WebGrid's selected row object using GetSelectedRow function.

  1. Drag WebGrid instance into the WebForm.
  2. Add a Client-Side function.
    JavaScript Copy Image Copy Code
    var grid = ISGetObject("WebGrid1");
var selectedObject = grid.GetSelectedObject().GetRowObject();

  3. Select a row.

To get WebGrid's row by KeyValue

Use GetRowByKeyValue function to get WebGrid's row by KeyValue in client side.

This topic will show you how to get WebGrid's row using GetRowByKeyValue.

  1. Drag WebGrid instance into the WebForm.
  2. Add a Client-Side function.
  3. JavaScript Copy Code
    function RowObject()
{
   var grid = ISGetObject("WebGrid1");
   var row = grid.RootTable.GetRowByKeyValue("VINET"); // get WebGridRow object by key value.
}

To set WebGrid's cell text

When you want to set a text into a cell in WebGrid, you can use SetText function in client side.

This topic will show you how to set WebGrid's cell text.

  1. Drag WebGrid instance into the WebForm.
  2. Add a Client-Side function.
  3. JavaScript Copy Code
    function SetText()
{
   var grid = ISGetObject("WebGrid1");
   var row = grid.RootTable.GetRowByKeyValue("SPLIR"); // get WebGridRow object by key value.
   var cells = row.GetCells();

   row.Select();
   cells.GetNamedItem("ContactTitle").SetText("Owner", true); // change contact title cell to Owner.
}

To call SendCustomRequest() from client side

Custom OnTheFlyPostback from client side to server side can be called using a function called SendCustomRequest.

This topic will show you how to set SendCustomRequest.

  1. Drag WebGrid instance into the WebForm.
  2. Add a Client-Side function .
  3. JavaScript Copy Image Copy Code
    function Grid1_ButtonClick()
{
   var grid = ISGetObject("WebGrid1");
   grid.SendCustomRequest();
   return true;
}

To show/hide WebGrid

When you want to set WebGrid visible/invisible, you can use Show or Hide functions in client side.

This topic will show you how to show or hide WebGrid.

  1. Drag WebGrid instance into the WebForm.
  2. Add a Client-Side function on your code.
  3. JavaScript Copy Code
    function showGrid()
{
   var grid = ISGetObject('WebGrid1');
   grid.Show();
}

function hideGrid()
{
   var grid = ISGetObject('WebGrid1');
   grid.Hide();
}

To select WebGrid's row from Client-Side

Use Select function to select a WebGrid row in client side.

This topic will show you how to select WebGrid's row.

  1. Drag WebGrid instance into the WebForm.
  2. Add a Client-Side function.
  3. JavaScript Copy Image Copy Code
    function SelectRow()
{
   var grid = ISGetObject("WebGrid1");
   var row = grid.RootTable.GetRowByKeyValue("VINET"); // get WebGridRow object by key value.
   row.Select(); // select this row for focus
}

To get value from hidden column using HiddenDataMember

Use client side function to get value from hidden column on WebGrid.

This topic will show you how to get the value.

  1. Drag WebGrid instance into the WebForm.
  2. Set HiddenDataMember property to one of column you want to hide, for example : City.
  3. Add a Client-Side function.
    JavaScript Copy Image Copy Code
    function getdata()
    {

       var grid = ISGetObject("WebGrid1");
       var rowObj = grid.GetSelectedObject().GetRowObject();
       var cells = rowObj.GetCells();
       var customer = cells.GetNamedItem("CustomerID");
       var city = customer.GetElement().attributes["City"].value;
       alert(city);
    }

  4. Select a row.

See Also

Other Resources
Walkthrough Topics
How-to Topics


How-to: Use Hierarchical Client APIs

How-to: Use Hierarchical Client APIs
See Also Send Feedback

Glossary Item Box

WebGrid provides a set of comprehensive client side API to let developers extend the Grid for their own use.

In this topic, you will learn how to use several hierarchical Client-Side APIs.

To obtain parent row's KeyValue in WebGrid

In hierarchical grid scenario, we can get parent row's KeyValue from child table.

This topic will show you how to obtain parent's row KeyValue.

  1. Drag WebGrid instance into the WebForm.
  2. Add a client side function.
  3. JavaScript Copy Image Copy Code
    function GetParentRow()
{
   var grid = ISGetObject("WebGrid1");
   var selObj = grid.GetSelectedObject();
   var row = selObj.GetRowObject();
   if (row.Table.IsRootTable)
      alert("Please select a child row");
   else
   {
      var parentRow = row.GetParentRow(); // get the parent row of this child
      alert("The parent row of this order is: " + parentRow.KeyValue);
       }
    }

To expand/collapse WebGrid's child row

Use ExpandChildRow function to expand/collapse WebGrid child row in client side.

This topic will show you how to expand/collapse WebGrid's child row.

  1. Drag WebGrid instance into the WebForm.
  2. Add a Client-Side function.
  3. JavaScript Copy Code
    function expandChildRow()
    {
         var WebGrid1 = ISGetObject(controlId);
         var row = WebGrid1.RootTable.GetRowByKeyValue("ANATR");
         row.ExpandChildRow(true);
         return true;
    }
    function collapseChildRow()
    {
         var WebGrid1 = ISGetObject(controlId);
         var row = WebGrid1.RootTable.GetRowByKeyValue("ANATR");
         row.CollapseChildRow(true);
         return true;
    }

See Also

Other Resources
Walkthrough Topics
How-to Topics


How-to: Display Self-Referencing Hierarchical Data

How-to: Display Self-Referencing Hierarchical Data
See Also Send Feedback

Glossary Item Box

WebGrid is capable to bind Self-Reference with hierarchical data.

In this topic, you will learn how to display Self-Referencing Hierarchical data.

To display Self-Referencing Hierarchical data

  1. Bind WebGrid to Hierarchical ISDataSource. (Bind Employees, Orders, and Orders Details table)
  2. Open WebGrid.NET Designer and go to Advanced tab.
  3. Select RootTable and Scroll down to Self Referencing section.
  4. Select Enable Self Referencing. Set Child Data Member to ReportsTo, Parent Data Member to EmployeeID and Expand Column Member to FirstName.
  5. Run the project.

See Also

Other Resources
Walkthrough Topics
How-to Topics


How-to: Bind client-binding to Client DataSource

How-to: Bind client-binding to Client DataSource
See Also Send Feedback

Glossary Item Box

In addition to built-in client services, you can also programmatically create your own datasource entirely in client-side, and then bind it to WebGrid via API. This mode is called ClientDataSource.

In this topic, you will learn how to bind client-binding to Client DataSource.

To bind client-binding to Client DataSource

  1. Open WebGrid.NET Designer and choose DataSource (Advanced).
  2. Select Client-side binding (Advanced) and Select Manually assign datasource in client side under client side binding settings.
  3. Go to Advanced tab. Select RootTable and set Data Key Field to ID.
  4. Expand RootTable and select Columns. Add 3 column afterwards.
  5. For the 1st column, set the following properties.
    Properties | Value
    Name | ID
    Caption | ID
    DataMember | ID
    Data Type | System.Int32

  6. For the 2nd column, set the following properties.
    Properties | Value
    Name | Text
    Caption | Text
    DataMember | Text
    Data Type | System.String

  7. For the 3rd column, set the following properties.
    Properties | Value
    Name | Bool
    Caption | Check
    DataMember | Bool
    Data Type | System.Boolean
    ColumnType | CheckBox

  8. Create the following function using client-side API.
    Javascript Copy Code
    function CreateData()
{
   var grid = ISGetObject("WebGrid1");
   var dataTable = new ISDataTable();
   var idColumn = new ISDataColumn(dataTable);
   var textColumn = new ISDataColumn(dataTable);
   var checkColumn = new ISDataColumn(dataTable);

   /* setup data columns */
   dataTable.Name = dataTable.TableName = "Root";
   idColumn.Name = idColumn.ColumnName = "ID";
   textColumn.Name = textColumn.ColumnName = "Text";
   checkColumn.Name = checkColumn.ColumnName = "Bool";

   /* add columns to data table */
   dataTable.Columns.Add(idColumn);
   dataTable.Columns.Add(textColumn);
   dataTable.Columns.Add(checkColumn);

   /* add rows to data table */
   for (var i = 0; i < 100; i++)
   {
      var dataRow = dataTable.NewRow();
      dataRow.Cells.GetNamedItem("ID").value = i;
      dataRow.Cells.GetNamedItem("Text").Value = "Item " + i;
      dataRow.Cells.GetNamedItem("Bool").value = (i % 3 != 0);

      dataTable.Rows.Add(dataRow);
   }

   /* bind the data table to WebGrid */
   grid.RootTable.Name = "Root";
   grid.SetDataSource(dataTable);
   grid.DataBind();
   grid.Render();

   event.cancelBubble = true;
   event.returnValue = false;
}

  9. Trigger CreateData() function using Button onclick event.

    <button onclick="CreateData()">Create Unbound DataSet</button>

  10. Run the project.

See Also

Tasks
How-to: Implement Classic Paging in Client Binding
How-to: Use Batch Update Client Binding
How-to: Enable Virtual Group Row Paging

Other Resources
Walkthrough Topics
How-to Topics


How-to: Use Self-Reference Client APIs

How-to: Use Self-Reference Client APIs
See Also Send Feedback

Glossary Item Box

WebGrid provides a set of comprehensive client side API to let developers extend the Grid for their own use.

In this topic, you will learn how to use several Self-Reference Client-Side APIs.

To expand/collapse Self-Reference row

  1. Drag WebGrid instance into the WebForm.
  2. Add a client side function. Use ExpandSelfRefRow() to expand self-reference row and CollapseSelfRefRow() to collapse self-reference row.
    JavaScript Copy Image Copy Code
    function ToggleExpandCollapse()
{
   // retrieves WebGrid's object
   var grid = ISGetObject("WebGrid1");

   var selectedObject = grid.GetSelectedObject(); // return object of type SelectedObject

   if (selectedObject != null)
   {
      var selectedRow = selectedObject.ToRowObject(); // return WebGridRow object
      if (selectedRow.SelfRefExpanded)
      {
         selectedRow.CollapseSelfRefRow(); // collapse self reference row
      }
      else
      {
         selectedRow.ExpandSelfRefRow(); // expand self reference row
      }
   }
   else
   {
      alert ("Please select a row first.");
   }

   return true;
}

  3. Run the project.

See Also

Other Resources
Walkthrough Topics
How-to Topics


How-to: Implement custom Editing Form

How-to: Implement custom Editing Form
See Also Send Feedback

Glossary Item Box

WebGrid allows user to implement custom Editing Form based on their requirement.

In this topic, you will learn how to create custom Editing Form.

To implement custom Editing Form

  1. Place the following code in client-side.
    JavaScript Copy Image Copy Code
    <div id="CustomerForm" style="position: absolute; background-color: aliceblue; width: 450px; left: 581px; top: 8px;">
   <div id="FormTitle" style="background-color: lightsteelblue; width: 100%; height: 20px; padding: 2px" class="text">
         [Title]
   </div>
   <table cellpadding="2" class="text" width="100%">
            <tr>
                <td style="width: 100px">
                    CustomerID</td>
                <td>
                    <input type="text" id="CustomerIDText" style="width: 100%" class="text" /></td>
            </tr>
            <tr>
                <td style="width: 100px">
                    CompanyName</td>
                <td>
                    <input type="text" id="CompanyNameText" style="width: 100%" class="text" /></td>
            </tr>
            <tr>
                <td style="width: 100px">
                    ContactName</td>
                <td>
                    <input type="text" id="ContactNameText" style="width: 100%" class="text" /></td>
            </tr>
            <tr>
                <td style="width: 100px">
                    ContactTitle</td>
                <td>
                    <input type="text" id="ContactTitleText" style="width: 100%" class="text" /></td>
            </tr>
   </table>
<input type="button" id="ActionButton" value="Action" class="text" style="width: 75px" onclick="DoAction()" />
</div>

  2. Create ToggleCustomerForm function to invoke the custom editing form.
    JavaScript Copy Image Copy Code
    function ToggleCustomerForm(visibility)
{
   var customerForm = document.getElementById("CustomerForm");

   if (visibility)
      customerForm.style.display = "";
   else
      customerForm.style.display = "none";
}

  3. Now, create AddNewRow function for adding data.
    JavaScript Copy Image Copy Code
    function AddNewRow()
{
   Clear(); // clear the customer form
   var customerForm = document.getElementById("CustomerForm");
   customerIDText.disabled = "";

   var formTitle = document.getElementById("FormTitle");
   formTitle.innerText = "Add new Customer";

   var actionButton = document.getElementById("ActionButton");
   actionButton.value = "Insert";

   ToggleCustomerForm(true);

   return true;
}

  4. Finally, create DoAction function to apply the data update.
    JavaScript Copy Image Copy Code
    function DoAction()
{
   // retrieves WebGrid's object
   var grid = ISGetObject("WebGrid1");

   var actionButton = document.getElementById("ActionButton");
   if (actionButton.value == "Insert")
   {
      var newRow = grid.RootTable.NewRow(); // create new row object
      var cells = newRow.GetCells() ; // get WebGridCell collection

      // populate new row object
      cells.GetNamedItem("CustomerID").SetText(customerIDText.value, true);
      cells.GetNamedItem("CompanyName").SetText(companyNameText.value, true);
      cells.GetNamedItem("ContactName").SetText(contactNameText.value, true);
      cells.GetNamedItem("ContactTitle").SetText(contactTitleText.value, true);

      newRow.Update(); // insert new record
   }
}

  5. Run the project.

See Also

Other Resources
Walkthrough Topics
How-to Topics


How-to: Extend data editing with Client-Side APIs

How-to: Extend data editing with Client-Side APIs
See Also Send Feedback

Glossary Item Box

Besides adding and editing data, WebGrid is also applicable for deleting and validating row.

In this topic, you will learn how to implement deleting and validating using Client-Side API.

To extend data editing with Client-Side APIs

  1. Create DeleteRow function to delete the selected row in WebGrid.
    JavaScript Copy Image Copy Code
    function DeleteRow()
{
   // retrieves WebGrid's object
   var grid = ISGetObject("WebGrid1");

   var selectedObject = grid.GetSelectedObject();  // return object of type SelectedObject
   if (selectedObject != null)
   {
      var selectedRow = selectedObject.ToRowObject(); // return WebGridRow object
      selectedRow.Delete(); // delete the selected row
   }
   else
   {
      alert("Please select a row first.");
   }
}

  2. Create ValidateRow function to validate the selected row in WebGrid.
    JavaScript Copy Image Copy Code
    function ValidateRow()
{
   // retrieves WebGrid's object
   var grid = ISGetObject("WebGrid1");

   var selectedObject = grid.GetSelectedObject();  // return object of type SelectedObject
   if (selectedObject != null)
   {
      var selectedRow = selectedObject.ToRowObject(); // return WebGridRow object
      selectedRow.Validate(); // validate the selected row
   }
   else
   {
      alert("Please select a row first.");
   }
}

  3. Run the project.

See Also

Other Resources
Walkthrough Topics
How-to Topics


How-to: Use Batch Update Client Binding

How-to: Use Batch Update Client Binding
See Also Send Feedback

Glossary Item Box

WebGrid now supports both client binding and batch update, which works consistently in any client data source mode.

In this topic, you will learn how to use Batch Update Client Binding.

To use Batch Update Client Binding

  1. Configure client-binding using WebService mode.
  2. Open WebGrid.NET Designer. Go to Popular Settings and select Allow Add New, Allow Editing and Allow Delete.
  3. Scroll down to Editing - Batch Update section. Select Activate SmartBatchUpdate and Allow users to review pending changes.
  4. Run the project.

See Also

Tasks
How-to: Implement Classic Paging in Client Binding
How-to: Bind client-binding to Client DataSource

Other Resources
Walkthrough Topics
How-to Topics


How-to: Enable Virtual Group Row Paging

How-to: Enable Virtual Group Row Paging
See Also Send Feedback

Glossary Item Box

WebGrid.NET now supports group row paging when used together with VirtualLoad™ mode. The group row paging significantly improves overall performance by loading only a small number of records (specified in GroupRowPageSize property) when user expands the group header.

In this topic, you will learn how to enable Virtual Group Row Paging.

To enable Virtual Group Row Paging

  1. Open WebGrid.NET Designer. In Popular Settings, scroll down to Paging section and set Paging Mode to VirtualLoad.
  2. Right click on WebGrid control and choose Properties.
  3. Expand ClientBindingSettings. Set EnableGroupRowPaging to True and GroupRowPageSize to 20.
  4. Run the project.

See Also

Tasks
How-to: Implement Classic Paging in Client Binding
How-to: Bind client-binding to Client DataSource

Other Resources
Walkthrough Topics
How-to Topics


How-to: Preload Group Totals with VirtualLoad Paging

How-to: Preload Group Totals with VirtualLoad Paging
See Also Send Feedback

Glossary Item Box

With preload group totals, WebGrid performs computation of data aggregation in the server-side while performing the binding and rendering in the Client-side - maintaining overall performance even in large data usage.

In this topic, you will learn how to preload group totals when using VirtualLoad paging with client binding.

To preload Group totals with VirtualLoad Paging

  1. Open WebGrid.NET Designer. In Popular Settings, scroll down to Paging section and set Paging Mode to VirtualLoad.
  2. Right click on WebGrid control and choose Properties.
  3. Expand ClientBindingSettings. Set PreloadGroupTotals to True.
  4. Run the project.

See Also

Tasks
How-to: Implement Classic Paging in Client Binding
How-to: Implement Classic Paging in Client Binding

Other Resources
Walkthrough Topics
How-to Topics


How-to: Sort Self-Referencing Child data

How-to: Sort Self-Referencing Child data
See Also Send Feedback

Glossary Item Box

WebGrid introduces a new setting in SelfReferenceSettings object called ApplyChildSorting. This feature instructs WebGrid to perform sorting on the self referencing child when the column sorting action occurred.

In this topic, you will learn how to sort Self-Referencing Child data.

To sort Self-Referencing Child data

  1. Create Self-Reference WebGrid.
  2. Open WebGrid.NET Designer and go to Advanced tab.
  3. Select RootTable and click See all properties.
  4. Expand SelfReferencingSettings and set ApplyChildSorting to True.
  5. Expand RootTable and Select SortColumns.
  6. Add a column and set ColumnMember to EmployeeID and SortOrder to Ascending.
  7. Run the project.

See Also

Other Resources
Walkthrough Topics
How-to Topics


How-to: Use Custom Object with Batch Update

How-to: Use Custom Object with Batch Update
See Also Send Feedback

Glossary Item Box

WebGrid.NET provides a new server-side event called OnBatchUpdate that you can handle to implement your own custom business logic.

In this topic, you will learn how to use Custom Object with Batch Update.

To use Custom Object with Batch Update

  1. First, you need to create DataLayer.cs in App_Code.
    C# Copy Image Copy Code
    using System;
using System.Data;
using System.Configuration;
using System.Web;
using System.Web.Security;
using System.Web.UI;
using System.Web.UI.WebControls;
using System.Web.UI.WebControls.WebParts;
using System.Web.UI.HtmlControls;
using System.Data.OleDb;
using System.Collections.Generic;

namespace CustomObjects
{
    [System.ComponentModel.DataObject]
    public class DataLayer
    {
        private static OleDbConnection _connection;

        private static OleDbConnection Connection
        {
            get
            {
                if (DataLayer._connection == null)
                {
                    DataLayer._connection = new OleDbConnection();
                    DataLayer._connection.ConnectionString = System.Configuration.ConfigurationManager.ConnectionStrings["NorthWindConnectionString"].ConnectionString;
                }

                return DataLayer._connection;
            }
        }

        #region Customers DataLayer

        private static Customer CreateCustomerData(OleDbDataReader dataReader)
        {
            Customer customer = new Customer();
            customer.CustomerID = dataReader.IsDBNull(0) ? string.Empty : dataReader.GetString(0);
            customer.CompanyName = dataReader.IsDBNull(1) ? string.Empty : dataReader.GetString(1);
            customer.ContactName = dataReader.IsDBNull(2) ? string.Empty : dataReader.GetString(2);
            customer.ContactTitle = dataReader.IsDBNull(3) ? string.Empty : dataReader.GetString(3);
            customer.Address = dataReader.IsDBNull(4) ? string.Empty : dataReader.GetString(4);
            customer.City = dataReader.IsDBNull(5) ? string.Empty : dataReader.GetString(5);
            customer.Region = dataReader.IsDBNull(6) ? string.Empty : dataReader.GetString(6);
            customer.PostalCode = dataReader.IsDBNull(7) ? string.Empty : dataReader.GetString(7);
            customer.Country = dataReader.IsDBNull(8) ? string.Empty : dataReader.GetString(8);
            customer.Phone = dataReader.IsDBNull(9) ? string.Empty : dataReader.GetString(9);
            customer.Fax = dataReader.IsDBNull(10) ? string.Empty : dataReader.GetString(10);

            return customer;
        }

        public static CustomerCollection GetCustomers()
        {
            OleDbCommand command = new OleDbCommand();
            command.CommandText = "SELECT CustomerID, CompanyName, ContactName, ContactTitle, Address, City, Region, PostalCode, Country, Phone, Fax From Customers";
            command.Connection = DataLayer.Connection;

            CustomerCollection customers = new CustomerCollection();
            try
            {
                command.Connection.Open();

                OleDbDataReader dataReader = command.ExecuteReader();
                while (dataReader.Read())
                {
                    Customer customer = DataLayer.CreateCustomerData(dataReader);
                    customers.Add(customer);
                }
            }
            finally
            {
                command.Connection.Close();
            }

            return customers;
        }

        public static Customer GetCustomer(string customerID)
        {
            OleDbCommand command = new OleDbCommand();
            command.CommandText = "SELECT CustomerID, CompanyName, ContactName, ContactTitle, Address, City, Region, PostalCode, Country, Phone, Fax From Customers WHERE CustomerID = ?";
            command.Parameters.Add(DataLayer.CreateParameter("CustomerID", customerID));
            command.Connection = DataLayer.Connection;

            try
            {
                command.Connection.Open();

                OleDbDataReader dataReader = command.ExecuteReader();
                if (dataReader.Read())
                {
                    Customer customer = DataLayer.CreateCustomerData(dataReader);
                    return customer;
                }
            }
            finally
            {
                command.Connection.Close();
            }

            return null;
        }

        public static int InsertCustomer(Customer customer)
        {
            OleDbCommand command = new OleDbCommand();
            command.CommandText = "INSERT INTO Customers (CustomerID, CompanyName, ContactName, ContactTitle, Address, City, Region, PostalCode, Country, Phone, Fax) Values (?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?)";
            command.Connection = DataLayer.Connection;
            command.Parameters.Add(DataLayer.CreateParameter("CustomerID", customer.CustomerID));
            command.Parameters.Add(DataLayer.CreateParameter("CompanyName", customer.CompanyName));
            command.Parameters.Add(DataLayer.CreateParameter("ContactName", customer.ContactName));
            command.Parameters.Add(DataLayer.CreateParameter("ContactTitle", customer.ContactTitle));
            command.Parameters.Add(DataLayer.CreateParameter("Address", customer.Address));
            command.Parameters.Add(DataLayer.CreateParameter("City", customer.City));
            command.Parameters.Add(DataLayer.CreateParameter("Region", customer.Region));
            command.Parameters.Add(DataLayer.CreateParameter("PostalCode", customer.PostalCode));
            command.Parameters.Add(DataLayer.CreateParameter("Country", customer.Country));
            command.Parameters.Add(DataLayer.CreateParameter("Phone", customer.Phone));
            command.Parameters.Add(DataLayer.CreateParameter("Fax", customer.Fax));

            return DataLayer.ExecuteNonQuery(command);
        }

        public static int UpdateCustomer(Customer customer)
        {
            OleDbCommand command = new OleDbCommand();
            command.CommandText = "UPDATE Customers SET CustomerID = ?, CompanyName = ?, ContactName = ?, ContactTitle = ?, " +
                "Address = ?, City = ?, Region = ?, PostalCode = ?, Country = ?, Phone = ?, Fax = ? WHERE CustomerID = ?";

            command.Parameters.Add(DataLayer.CreateParameter("CustomerID", customer.CustomerID));
            command.Parameters.Add(DataLayer.CreateParameter("CompanyName", customer.CompanyName));
            command.Parameters.Add(DataLayer.CreateParameter("ContactName", customer.ContactName));
            command.Parameters.Add(DataLayer.CreateParameter("ContactTitle", customer.ContactTitle));
            command.Parameters.Add(DataLayer.CreateParameter("Address", customer.Address));
            command.Parameters.Add(DataLayer.CreateParameter("City", customer.City));
            command.Parameters.Add(DataLayer.CreateParameter("Region", customer.Region));
            command.Parameters.Add(DataLayer.CreateParameter("PostalCode", customer.PostalCode));
            command.Parameters.Add(DataLayer.CreateParameter("Country", customer.Country));
            command.Parameters.Add(DataLayer.CreateParameter("Phone", customer.Phone));
            command.Parameters.Add(DataLayer.CreateParameter("Fax", customer.Fax));
            command.Parameters.Add(DataLayer.CreateParameter("OriginalCustomerID", customer.CustomerID));
            command.Connection = DataLayer.Connection;

            return DataLayer.ExecuteNonQuery(command);
        }

        public static int DeleteCustomer(Customer customer)
        {
            OleDbCommand command = new OleDbCommand();
            command.CommandText = "DELETE FROM Customers WHERE CustomerID = ?";
            command.Connection = DataLayer.Connection;
            command.Parameters.Add(DataLayer.CreateParameter("OriginalCustomerID", customer.CustomerID));

            return DataLayer.ExecuteNonQuery(command);
        }

        #endregion

    }
}

  2. Switch to C# view code in your WebGrid and add the following namespaces.

    using ISNet.WebUI.WebGrid;
    using CustomObjects;

  3. Add the following code to bind the Customers table under Initialize_DataSource and PrepareDataBinding server-side events.
    C# Copy Image Copy Code
    protected void WebGrid1_InitializeDataSource(object sender, DataSourceEventArgs e)
{
   e.DataSource = DataLayer.GetCustomers();
}

protected void WebGrid1_PrepareDataBinding(object sender, DataSourceEventArgs e)
{
   if (!IsPostBack)
   {
      WebGrid1.RetrieveStructure();
      WebGrid1.RootTable.DataKeyField = "CustomerID";
   }
}

  4. Add the following code to map the changes to object.
    C# Copy Image Copy Code
     private void MapChangesToObject(List<webgridcelldata> data, CustomObjects.Customer customer)
{
   foreach (WebGridCellData cellData in data)
   {
      string newText = cellData.NewText;

      switch (cellData.Column.DataMember)
      {
         case "CustomerID":
            customer.CustomerID = newText;
            break;

         case "Address":
            customer.Address = newText;
            break;

         case "City":
            customer.City = newText;
            break;

         case "CompanyName":
            customer.CompanyName = newText;
            break;

         case "ContactName":
            customer.ContactName = newText;
            break;

         case "ContactTitle":
            customer.ContactTitle = newText;
            break;

         case "Country":
            customer.Country = newText;
            break;

         case "Fax":
            customer.Fax = newText;
            break;

         case "Phone":
            customer.Phone = newText;
            break;

         case "PostalCode":
            customer.PostalCode = newText;
            break;

         case "Region":
            customer.Region = newText;
            break;
      }
   }
}

  5. Add the following code to implement Batch Update with custom object under Batch_Update server-side event.
    C# Copy Image Copy Code
    protected void WebGrid1_BatchUpdate(object sender, BatchUpdateEventArgs e)
{
   foreach (WebGridRowChanges rowChanges in e.PendingChanges)
   {
      CustomObjects.Customer customer = null;

      try
      {
         switch (rowChanges.RowState)
         {
            case RowState.Added:
               customer = new CustomObjects.Customer();
               MapChangesToObject(rowChanges.Data, customer);
               DataLayer.InsertCustomer(customer);
               break;

            case RowState.Modified:
               customer = DataLayer.GetCustomer(rowChanges.KeyValue.ToString());
               MapChangesToObject(rowChanges.Data, customer);
               DataLayer.UpdateCustomer(customer);
               break;

            case RowState.Deleted:
               customer = DataLayer.GetCustomer(rowChanges.KeyValue.ToString());
               DataLayer.DeleteCustomer(customer);
               break;
         }
      }
      catch (Exception exp)
      {
         // adds the Exception to batch update list to take advantage of WebGrid's partial errors support.

        WebGrid1.AddBatchUpdateException(new WebGridBatchUpdateException(rowChanges,
                        new Exception("Record '" + rowChanges.KeyValue.ToString() + "' has error '" + exp.Message + "'", exp)));
      }
   }
}

  6. Run the project.

See Also

Tasks
Walkthrough: Configuring Updatable WebGrid in Batch Update mode (Using DataSet Binding)
How-to: Display CallOut Notification during Batch Update

Other Resources
Walkthrough Topics
How-to Topics


How-to: Prevent empty data input

How-to: Prevent empty data input
See Also Send Feedback

Glossary Item Box

When adding a new row, WebGrid is able to validate the row in order to prevent empty data input.

In this topic, you will learn how to prevent empty data input.

To prevent empty data input

  1. Bind WebGrid to AccessDatasource control. (Use Customers table).
  2. Open WebGrid.NET Designer and select Allow Add New.
  3. Switch to Advanced tab and select Columns.
  4. Select CustomerID and click See all properties.
  5. Set InputRequired to True and EditInfoText to Enter CustomerID (*required).
  6. Run the project.

See Also

Other Resources
Walkthrough Topics
How-to Topics


How-to: Display Hierarchical data in TreeView mode

How-to: Display Hierarchical data in TreeView mode
See Also Send Feedback

Glossary Item Box

WebGrid is capable to act as TreeView instead of hierarchical layout.

In this topic, you will learn how to display hierarchical data in TreeView mode

To display Hierarchical data in TreeView mode

  1. Bind WebGrid to XmlDataSource control.
  2. After you select the Xml file you want to bind, a wizard will appear. Select Configure this WebGrid to act as TreeView.

  3. Run the project.

See Also

Other Resources
Walkthrough Topics
How-to Topics


How-to: Export all data when Classic Paging is enabled

How-to: Export all data when Classic Paging is enabled
See Also Send Feedback

Glossary Item Box

By default, when classic paging is enabled, user can only export the data in the current page.

In this topic, you will learn how to export all data when paging is enabled.

To export all data

  1. Open WebGrid.NET Designer and click See all properties.
  2. Set PagingExportMode to ExportAllData.
  3. Run the project.

See Also

Tasks
How-to: Enable Pivot Chart Both View with Classic Paging

Other Resources
Walkthrough Topics
How-to Topics


How-to: Use Column Aggregation

How-to: Use Column Aggregation
See Also Send Feedback

Glossary Item Box

WebGrid provides built-in column aggregation feature.

This topic will show you how to use column aggregation.

To use column aggregation

  1. Bind WebGrid to Products table.
  2. Right-click on WebGrid control and choose WebGrid.NET Designer.
  3. Switch to Advanced tab and go to RootTable.
  4. Set ColumnFooters to Yes.
  5. Expand RootTable and select Columns.
  6. In UnitPrice column, set AggregateFunction property to Max and FooterText property to "MaxPrice : ".
  7. In UnitInStock column, set AggregateFunction property to Sum and FooterText property to "Sum : ".
  8. In UnitOnOrder column, set AggregateFunction property to Avg and FooterText property to "Average : ".
  9. Run the project.

See Also

Other Resources
Walkthrough Topics
How-to Topics


Samples and Walkthroughs

Samples and Walkthroughs
See Also Send Feedback
Intersoft WebGrid > Getting Started > Samples and Walkthroughs

Glossary Item Box

This section contains information about location of sample and tutorial files, example codes and how to use WebGrid in Visual Studio 2005.

In This Section

Locating Sample Files
Discover the locations where sample files are stored on your computer or the installation source.

Locating Tutorial Files
Discover the locations where tutorial files are stored on your computer or the installation source.

WebGrid Walkthroughs
Learn how to create basic applications in WebGrid with these step-by-step guides.

See Also

Overview
Getting Started
WebGrid Features Overview

Other Resources
Walkthrough Topics
How-to Topics


Locating Sample Files

Locating Sample Files
See Also Send Feedback
Intersoft WebGrid > Getting Started > Samples and Walkthroughs > Locating Sample Files

Glossary Item Box

The default locations for Sample files in this release are listed below. %install% represents the location where Intersoft's components are installed, such as \Program Files\Intersoft Solutions\.

Product | Sample Location
WebGrid.NET Enterprise C# Samples (Visual Studio 2010 Solution) | C:\%install%\Intersoft WebUI Studio 2010 R1\Samples\For ASP.NET\ISNet.WebUI.Samples\cs
WebGrid.NET Enterprise VB Samples (Visual Studio 2010 Solution) | C:\%install%\Intersoft WebUI Studio 2010 R1\Samples\For ASP.NET\ISNet.WebUI.Samples\vb

See Also

Overview
Getting Started
WebGrid Features Overview

Other Resources
Walkthrough Topics
How-to Topics


Locating Tutorial Files

Locating Tutorial Files
See Also Send Feedback
Intersoft WebGrid > Getting Started > Samples and Walkthroughs > Locating Tutorial Files

Glossary Item Box

The default locations for Tutorial files in this release are listed below. %install% represents the location where Intersoft's components are installed, such as \Program Files\Intersoft Solutions\.

Product | Sample Location
WebGrid.NET Enterprise C# Tutorials (Visual Studio 2010 Solution) | C:\%install%\Intersoft WebUI Studio 2010 R1\Tutorials\cs
WebGrid.NET Enterprise VB Tutorials (Visual Studio 2010 Solution) | C:\%install%\Intersoft WebUI Studio 2010 R1\Tutorials\cs

See Also

Overview
Getting Started
WebGrid Features Overview

Other Resources
Walkthrough Topics
How-to Topics


Launching Samples and Tutorials in Visual Studio 2005

Launching Samples and Tutorials in Visual Studio 2005
See Also Send Feedback

Glossary Item Box

This topic provides a step-by-step guidance on how to launch WebGrid's samples and tutorials in Visual Studio 2005

Configuring WebGrid's Tutorials in Visual Studio 2005

  1. Download the tutorials in http://intersoftpt.com/Support/KBArticle.aspx?aid=198&cid=2&tid=1&pid=39,47,55.
  2. Extract files to C:\Inetpub\wwwroot\ WG40TutorialsNET2.
  3. Right click on the WG40TutorialsNET2 directory and choose Properties >> WebSharing >> Share this folder >> click OK twice to apply the changes.
  4. Go to Control Panel >> Administrative Tools >> Internet Information Services >> Web Sites >> Default Web Site.
  5. Search for WG40TutorialsNET2 and Right click on it. Choose Properties >> ASP.NET Tab >> change the ASP.NET version to 2.0.50727 >> click OK.
  6. Go to WG40TutorialsNET2 directory in C:\Inetpub\wwwroot and run WG40TutorialsNET2 solution then search for Solution Explorer.
  7. In Solution Explorer, Right click on the bin folder, then choose Add References.
  8. Browse and add:
    - ISNet.WebGrid.dll from C:\Program Files\Intersoft Solutions\WebGrid.NET V4.0\Bin\NET2
    - ISNet.dll and ISNet.WebUI.dll from C:\Program Files\Intersoft Solutions\WebUI.NET Framework 3.0\Bin
  9. Compile and run the project.

Configuring WebGrid's Samples in Visual Studio 2005

  1. Download the samples in http://intersoftpt.com/Support/KBArticle.aspx?aid=198&cid=2&tid=1&pid=39,47,55
  2. Extract files to C:\Inetpub\wwwroot\ WG40SamplesNET2.
  3. Right click on the WG40TutorialsNET2 directory and choose Properties >> WebSharing >> Share this folder >> click OK twice to apply the changes.
  4. Go to Control Panel >> Administrative Tools >> Internet Information Services >> Web Sites >> Default Web Site.
  5. Search for WG40TutorialsNET2 and Right click on it. Choose Properties >> ASP.NET Tab >> change the ASP.NET version to 2.0.50727 >> click OK.
  6. Go to WG40TutorialsNET2 directory in C:\Inetpub\wwwroot and run WG40TutorialsNET2 solution then search for Solution Explorer.
  7. In Solution Explorer, Right click on the bin folder, then choose Add References.
  8. Browse and add:
    - ISNet.WebGrid.dll from C:\Program Files\Intersoft Solutions\WebGrid.NET V4.0\Bin\NET2
    - ISNet.dll and ISNet.WebUI.dll from C:\Program Files\Intersoft Solutions\WebUI.NET Framework 3.0\Bin
  9. Compile and run the project.

See Also

Overview
Getting Started
WebGrid Features Overview

Other Resources
Walkthrough Topics
How-to Topics


WebGrid Walkthroughs

WebGrid Walkthroughs
See Also Send Feedback
Intersoft WebGrid > Getting Started > Samples and Walkthroughs > WebGrid Walkthroughs

Glossary Item Box

These walkthroughs introduce the important basic area of WebGrid component. Each walkthrough discusses the development of binding WebGrid for the first time, how to set up the DataSource and apply WebGrid basic features such as Unbound Mode and Column Types using a series of step-by-step instructions.

In This Section

Walkthrough: Binding WebGrid to AccessDataSource control
Demonstrates how to bind WebGrid with AccessDataSource control such as Access DataBase created by Microsoft Office.

Walkthrough: Binding WebGrid to Hierarchical ISDataSource control
Demonstrates how to bind WebGrid with the new Intersoft's technology, ISDataSource control hierarchically.

Walkthrough: Using WebGrid in Unbound Mode
Demonstrates how to configure WebGrid in unbound mode.

Walkthrough: Creating unbound WebGrid with Hierarchical enabled
Demonstrates how to use WebGrid in unbound mode with hierarchical enabled.

Walkthrough: Using Column Types
Demonstrates how to apply different Column Types in WebGrid.

More Walkthrough Topics
Lists complete walkthrough topics available in WebGrid.

See Also

Overview
Getting Started
WebGrid Features Overview

Other Resources
Walkthrough Topics
How-to Topics


Walkthrough: Binding WebGrid to AccessDataSource control

Walkthrough: Binding WebGrid to AccessDataSource control
See Also Send Feedback
Intersoft WebGrid > Getting Started > Samples and Walkthroughs > WebGrid Walkthroughs > Walkthrough: Binding WebGrid to AccessDataSource control

Glossary Item Box

This walkthrough shows you how to create and bind WebGrid to an AccessDataSource control.

During this walkthrough, you will learn how to do the following:

  • Use AccessDataSource.
  • Use SmartTag to set DataSource.
  • Use Data Source Configuration Wizard to set the Database and table.

Prerequisites

In order to complete this walkthrough, you will need the following:

  • Access to the Microsoft Access Northwind database.
  • Visual Studio 2005/2008/2010 Application.

Step-By-Step Instructions

To create new web application and bind WebGrid to AccessDataSource

  1. Launch Visual Studio.NET 2008.
  2. Click on File menu, then select New and click Web Site.
  3. Select ASP.NET Web Site in the Template box and set Location to HTTP.
  4. Named the Web Site and click OK.
  5. Right-click on Project's name and select Add New Item.
  6. Select Intersoft AppForm in the My Templates box and named it as Walkthrough.aspx.
  7. Drag WebGrid instance from ToolBar to WebForm.
  8. In the Solution Explorer, right-click on App_Data and select Add Existing Item.
  9. Browse and add NorthWind.mdb in C:\Program Files\Intersoft Solutions\Data (Default installation folder).
  10. Click the SmartTag on the upper right of the WebGrid.
  11. In Choose Data Source field, choose <New data source...>.

  12. In Data Source Configuration Wizard, choose AccessDatabase and click OK.

  13. Browse and select the database in App_Data (NorthWind.mdb) and click OK.

  14. Select the table that you want to use and click Next.

  15. In this step, you can view the table's database using Test Query button. Otherwise, click Finish to proceed to the next step.
  16. Finally, choose Retrieve Structure action in Connected to Data Source Control Wizard and click OK to apply all settings.

  17. Run the project and the WebGrid will look like following.

See Also

Tasks
Walkthrough: Binding WebGrid to ObjectDataSource control
Walkthrough: Binding WebGrid to Hierarchical ISDataSource control
Walkthrough: Using WebGrid in unbound mode

Other Resources
Walkthrough Topics
How-to Topics


Walkthrough: Binding WebGrid to ObjectDataSource control

Walkthrough: Binding WebGrid to ObjectDataSource control
See Also Send Feedback

Glossary Item Box

This walkthrough shows you how to create and bind WebGrid to an ObjectDataSource control.

During this walkthrough, you will learn how to do the following:

  • Use ObjectDataSource.
  • Use SmartTag to set DataSource.
  • Use Data Source Configuration Wizard to set the Database and table.

Prerequisites

In order to complete this walkthrough, you will need the following:

  • Access to the Microsoft Access Northwind database.
  • Visual Studio 2005 Application.

Step-By-Step Instructions

To create new web application and bind WebGrid to ObjectDataSource

  1. Launch Visual Studio.NET 2005.
  2. Click on File menu, then select New and click Web Site.
  3. Select ASP.NET Web Site in the Template box and set Location to HTTP.
  4. Named the Web Site and click OK.
  5. Right-click on Project's name and select Add New Item.
  6. Select Intersoft AppForm in the My Templates box and named it as Walkthrough.aspx.
  7. Drag WebGrid instance from ToolBar to WebForm.
  8. In the Solution Explorer, right-click on App_Data and select Add Existing Item.
  9. Browse and add NorthWind.mdb in C:\Program Files\Intersoft Solutions\Data (Default installation folder).
  10. Click the SmartTag on the upper right of the WebGrid.
  11. In Choose Data Source field, choose <New data source...>.

  12. In Data Source Configuration Wizard, choose Object and click OK.

  13. Select your Business Object and click Next.

  14. Click Finish afterwards.

  15. Finally, choose Retrieve Structure action in Connected to Data Source Control Wizard and click OK.

  16. Run the project and the WebGrid will look like following.

See Also

Tasks
Walkthrough: Binding WebGrid to AccessDataSource control
Walkthrough: Binding WebGrid to XMLDataSource control
Walkthrough: Configuring updatable WebGrid bound to ObjectDataSource control
FAQ: Can I perform retrieve structure programmatically when bound to DataSource control?

Other Resources
Walkthrough Topics
How-to Topics


Walkthrough: Binding WebGrid to XMLDataSource control

Walkthrough: Binding WebGrid to XMLDataSource control
See Also Send Feedback

Glossary Item Box

This walkthrough shows you how to create and bind WebGrid to a XMLDataSource control.

During this walkthrough, you will learn how to do the following:

  • Use XMLDataSource.
  • Use SmartTag to set DataSource.
  • Use DataSourceConfigurationWizard to set the Database and table.

Prerequisites

In order to complete this walkthrough, you will need the following:

  • Access to the XML database.
  • Visual Studio 2005/2008/2010 Application.

Step-By-Step Instructions

To create new web application and bind WebGrid to XMLDataSource

  1. Launch Visual Studio.NET 2008.
  2. Click on File menu, then select New and click Web Site.
  3. Select ASP.NET Web Site in the Template box and set Location to HTTP.
  4. Named the Web Site and click OK.
  5. Right-click on Project's name and select Add New Item.
  6. Select Intersoft AppForm in the My Templates box and named it as Walkthrough.aspx.
  7. Drag WebGrid instance from ToolBar to WebForm.
  8. Click the SmartTag on the upper right of the WebGrid.
  9. In Choose Data Source field, choose <New data source...>.

  10. In Data Source Configuration Wizard, choose XML File and click OK.

  11. Set the Data File and XPath expression then click OK.

  12. Finally, choose Retrieve Structure action in Connected to XMLData Source Control Wizard and clik OK.

  13. Run the project and the WebGrid will look like following.

See Also

Tasks
Walkthrough: Binding WebGrid to AccessDataSource control
Walkthrough: Binding WebGrid to ObjectDataSource control
Walkthrough: Configuring updatable WebGrid bound to ObjectDataSource control
FAQ: Can I perform retrieve structure programmatically when bound to DataSource control?

Other Resources
Walkthrough Topics
How-to Topics


Walkthrough: Configuring updatable WebGrid bound to ObjectDataSource control

Walkthrough: Configuring updatable WebGrid bound to ObjectDataSource control
See Also Send Feedback

Glossary Item Box

This walkthrough shows you how to configure updateable WebGrid to ObjectDataSource control.

During this walkthrough, you will learn how to do the following:

  • Use ObjectDataSource.
  • Use SmartTag to set DataSource and AllowEdit.
  • Use Data Source Configuration Wizard to set the Database and table.

Prerequisites

In order to complete this walkthrough, you will need the following:

  • Access to the Microsoft Access Northwind database.
  • Visual Studio 2005 Application.

Step-By-Step Instructions

To create new web application, bind WebGrid to ObjectDataSource and AllowEdit

  1. Launch Visual Studio.NET 2005.
  2. Click on File menu, then select New and click Web Site.
  3. Select ASP.NET Web Site in the Template box and set Location to HTTP.
  4. Named the Web Site and click OK.
  5. Right-click on Project's name and select Add New Item.
  6. Select Intersoft AppForm in the My Templates box and named it as Walkthrough.aspx.
  7. Drag WebGrid instance from ToolBar to WebForm.
  8. In the Solution Explorer, right-click on App_Data and select Add Existing Item.
  9. Browse and add NorthWind.mdb in C:\Program Files\Intersoft Solutions\Data (Default installation folder).
  10. Click the SmartTag on the upper right of the WebGrid.
  11. In ChooseDataSource field, choose <New data source...>.

  12. In Data Source Configuration Wizard, choose Object and click OK.

  13. Select your Business Object and click Next.

  14. Click Finish afterwards.

  15. Finally, choose Retrieve Structure action in Connected to Data Source Control Wizard and click OK.

  16. Select Allow Editing property from WebGrid's SmartTag.

  17. Run the project and the WebGrid will look like following.

See Also

Tasks
Walkthrough: Binding WebGrid to AccessDataSource control
Walkthrough: Binding WebGrid to ObjectDataSource control}
Walkthrough: Binding WebGrid to XMLDataSource control
FAQ: Can I perform retrieve structure programmatically when bound to DataSource control?

Other Resources
Walkthrough Topics
How-to Topics


Walkthrough: Binding WebGrid to Hierarchical ISDataSource control

Walkthrough: Binding WebGrid to Hierarchical ISDataSource control
See Also Send Feedback
Intersoft WebGrid > Getting Started > Samples and Walkthroughs > WebGrid Walkthroughs > Walkthrough: Binding WebGrid to Hierarchical ISDataSource control

Glossary Item Box

This walkthrough shows you how to create and bind WebGrid to an ISDataSource control.

During this walkthrough, you will learn how to do the following:

  • Use ISDataSource.
  • Use SmartTag to set DataSource.
  • Use DataSourceConfigurationWizard to set the Database and table.

Prerequisites

In order to complete this walkthrough, you will need the following:

  • Access to the Microsoft Access Northwind database.
  • Visual Studio 2005/2008/2010 Application.

Step-By-Step Instructions

To create new web application and bind WebGrid to ISDataSource

  1. Launch Visual Studio.NET 2008.
  2. Click on File menu, then select New and click Web Site.
  3. Select ASP.NET Web Site in the Template box and set Location to HTTP.
  4. Named the Web Site and click OK.
  5. Right-click on Project's name and select Add New Item.
  6. Select Intersoft AppForm in the My Templates box and named it as Walkthrough.aspx.
  7. Drag WebGrid instance from ToolBar to WebForm.
  8. In the Solution Explorer, right-click on App_Data and select Add Existing Item.
  9. Browse and add NorthWind.mdb in C:\Program Files\Intersoft Solutions\Data (Default installation folder).
  10. Click the SmartTag on the upper right of the WebGrid.
  11. In Choose Data Source field, choose <New data source...>.

  12. In Data Source Configuration Wizard, choose ISDataSource and click OK.

  13. Select the Schema Type that you want to use and click Next.

  14. Add two or more tables required and click Finish.

  15. Then, choose Retrieve Hierarchical Structure action in Connected to Data Source Control Wizard and click OK.

  17. Run the project and the WebGrid should look like following.

See Also

Tasks
Walkthrough: Binding WebGrid to AccessDataSource control
Walkthrough: Creating unbound WebGrid with Hierarchical enabled
Walkthrough: Using WebGrid in Unbound Mode

Other Resources
Walkthrough Topics
How-to Topics


Walkthrough: Configuring updatable WebGrid bound to ISDataSource control

Walkthrough: Configuring updatable WebGrid bound to ISDataSource control
See Also Send Feedback

Glossary Item Box

This walkthrough shows you how to configure updatable WebGrid bound to ISDataSource control.

During this walkthrough, you will learn how to do the following:

  • Use ISDataSource.
  • Use SmartTag to set DataSource and AllowEdit.
  • Use Data Source Configuration Wizard to set the Database and table.

Prerequisites

In order to complete this walkthrough, you will need the following:

  • Access to the Microsoft Access Northwind database.
  • Visual Studio 2005 Application.

Step-By-Step Instructions

To create new web application, bind WebGrid to ISDataSource and AllowEdit

  1. Launch Visual Studio.NET 2005.
  2. Click on File menu, then select New and click Web Site.
  3. Select ASP.NET Web Site in the Template box and set Location to HTTP.
  4. Named the Web Site and click OK.
  5. Right-click on Project's name and select Add New Item.
  6. Select Intersoft AppForm in the My Templates box and named it as Walkthrough.aspx.
  7. Drag WebGrid instance from ToolBar to WebForm.
  8. In the Solution Explorer, right-click on App_Data and select Add Existing Item.
  9. Browse and add NorthWind.mdb in C:\Program Files\Intersoft Solutions\Data (Default installation folder).
  10. Click the SmartTag on the upper right of the WebGrid.
  11. In Choose Data Source field, choose <New data source...>.

  12. In Data Source Configuration Wizard, choose ISDataSource and click OK.

  13. Select the Schema Type that you want to use and click Next.

  14. Add the 2 or more tables required and click Finish.

  15. Then choose Retrieve Hierarchical Structure action in Connected to Data Source Control Wizard and click OK.

  17. Set the AllowEdit property to True from WebGrid's SmartTag

  18. Run the project.

See Also

Tasks
Walkthrough: Binding WebGrid to Hierarchical ISDataSource control

Other Resources
Walkthrough Topics
How-to Topics


Walkthrough: Binding a WebValueList to a table defined in ISDataSourceControl

Walkthrough: Binding a WebValueList to a table defined in ISDataSourceControl
See Also Send Feedback

Glossary Item Box

This walkthrough shows you how to bind a WebValueList to a table defined in ISDataSourceControl.

During this walkthrough, you will learn how to do the following:

  • Use ISDataSource
  • Create DataSet.
  • Use ISDataSource SmartTag.
  • Use WebGrid's SmartTag to bind to ISDataSource
  • Use WebGrid.NET designer to bind a WebValueList

Prerequisites

    In order to complete this walkthrough, you will need the following:

    • Access to the Microsoft Access Northwind database.
    • Visual Studio 2005/2008/2010 Application.

    Step-By-Step Instructions

    To Bind DataSource in WebGrid at RunTime.

    1. Launch Visual Studio.NET 2008.
    2. Click on File menu, then select New and click Project.
    3. Select Visual C# Project in Project Types.
    4. Select ASP.NET Web Application in the Template box.
    5. Specify the Project's Location and click OK.
    6. Drag WebGrid instance into WebForm.
    7. Drag ISDataSource control into WebForm.
    8. In Solution Explorer, right click on the project then click "Add New Item...".
    9. Add a DataSet and name it NorthWind to the project.

    10. Add Order_Details and Products tables to the dataset.

    11. Open ISDataSource SmartTag, click "Configure Data Source...".
    12. Choose NorthWind dataset as ISDataSource SchemaName.
    13. Click Next and then add Order_Details and Products table to ISDataSource then Click Finish.

    14. Open WebGrid's SmartTag and set the DataSource to ISDataSource1 then click OK to Retrieve WebGrid's structure.

    15. Open WebGrid.NET Designer - Advanced tab - RootTable - Columns. Search for ProductID.
    16. In the ProductID go to ValueList Expandable panel.
    17. In ValueList Expandable panel, set the following properties:

      Property | Value
      DataMember | Products
      DataSourceID | ISDataSource1
      DataTextField | ProductName
      DataValueField | ProductID

    18. Compile and run the WebForm. The WebGrid will look like following:

    See Also

    Tasks
    Walkthrough: Binding a WebValueList to different DataSource control

    References
    WebValueList Class
    DataMember Property
    DataTextField Property
    DataValueField Property
    DataSourceID Property

    Other Resources
    Walkthrough Topics
    How-to Topics


Walkthrough: Binding a WebValueList to different DataSource control

Walkthrough: Binding a WebValueList to different DataSource control
See Also Send Feedback

Glossary Item Box

This walkthrough shows you how to bind a WebValueList to different DataSource control.

During this walkthrough, you will learn how to do the following:

  • Use AccessDataSet
  • Create DataSet.
  • Use AccessDataSet SmartTag.
  • Use WebGrid's SmartTag to bind to AccessDataSource.
  • Use WebGrid.NET designer to bind a WebValueList.

Prerequisites

    In order to complete this walkthrough, you will need the following:

    • Access to the Microsoft Access Northwind database.
    • Visual Studio 2005 Application.

    Step-By-Step Instructions

    1. Launch Visual Studio.NET 2005.
    2. Click on File menu, then select New and click Project.
    3. Select Visual C# Project in Project Types.
    4. Select ASP.NET Web Application in the Template box.
    5. Specify the Project's Location and click OK.
    6. Drag WebGrid instance into WebForm.
    7. Drag two AccessDataSource controls into WebForm.
    8. In Solution Explorer, right click on the project then click "Add New Item...".
    9. Add a DataSet and name it NorthWind to the project.

    10. Add Order_Details and Products table to the dataset.

    11. Open first AccessDataSource SmartTag and bind to Order_Details table.

    12. Open second AccessDataSource SmartTag and bind to Products table.

    13. Open WebGrid's SmartTag and set the DataSource to AccessDataSource1 then click OK to Retrieve WebGrid's structure.

    14. Open WebGrid.NET Designer - Advanced tab - RootTable - Columns. Search for ProductID.
    15. In ValueList Expandable panel, set the following properties:

      Property | Value
      DataMember | DefaultView
      DataSourceID | AccesDataSource2
      DataTextField | ProductName
      DataValueField | ProductID

    16. Compile and run the WebForm. The WebGrid will look like following:

    See Also

    Tasks
    Walkthrough: Binding a WebValueList to a table defined in ISDataSourceControl

    References
    WebValueList Class
    DataMember Property
    DataTextField Property
    DataValueField Property
    DataSourceID Property

    Other Resources
    Walkthrough Topics
    How-to Topics


Walkthrough: Using WebGrid in unbound mode

Walkthrough: Using WebGrid in unbound mode
See Also Send Feedback
Intersoft WebGrid > Getting Started > Samples and Walkthroughs > WebGrid Walkthroughs > Walkthrough: Using WebGrid in unbound mode

Glossary Item Box

This walkthrough shows you how to use WebGrid in unbound mode for displaying static columns and rows.

During this walkthrough, you will learn how to do the following:

  • Use WebGrid.NET Designer to set unbound mode.

Prerequisites

In order to complete this walkthrough, you will need the following:

  • Visual Studio 2005 Application.

Step-By-Step Instructions

To Create WebGrid in Unbound Mode

  1. Launch Visual Studio.NET 2005.
  2. Click on File menu, then select New and click Web Site.
  3. Select ASP.NET Web Site in the Template box and set Location to HTTP.
  4. Named the Web Site and click OK.
  5. Right-click on Project's name and select Add New Item.
  6. Select Intersoft AppForm in the My Templates box and named it as UnboundMode.aspx.
  7. Create new instance of WebGrid by dragging it from Toolbox to the WebForm.
  8. Right click on the WebGrid and click on WebGrid.NET Designer.
  9. The designer window appears, expand RootTable and select Columns node.
  10. Click Add three times to add three new columns.
  11. Select Column0 and set its Caption to "Item Name", Column1 to "Discount" and Column2 to "Price".
  12. Click on Rows node and click Add three times to add three new rows.
  13. Select Rows0 and click on ellipsis button of Cells to open Cells Editor. You will see three cells, which correspond to three columns you created in step 10.
  14. Click on Cell0 and set its Text to "Item1", Cell1 Text to "0", Cell2 Text to "100".
  15. Select Rows1 and repeat step 13 and 14. Set the Text of each cell to "Item2", "5", and "200".
  16. Select Rows2 and repeat step 13 and 14. Set the Text of each cell to "Item3", "10" and "500".
  17. Click OK.
  18. Save the WebForm and view in browser.
  19. The WebGrid will look like following.

See Also

Tasks
Walkthrough: Creating unbound WebGrid with Hierarchical enabled
Walkthrough: Binding WebGrid to AccessDataSource control

Other Resources
Walkthrough Topics
How-to Topics


Walkthrough: Creating unbound WebGrid with Hierarchical enabled

Walkthrough: Creating unbound WebGrid with Hierarchical enabled
See Also Send Feedback
Intersoft WebGrid > Getting Started > Samples and Walkthroughs > WebGrid Walkthroughs > Walkthrough: Creating unbound WebGrid with Hierarchical enabled

Glossary Item Box

This walkthrough shows you how to create unbound hierarchical WebGrid.

During this walkthrough, you will learn how to do the following:

  • Use WebGridTable.
  • Use WebGridRow.

Prerequisites

In order to complete this walkthrough, you will need the following:

  • Visual Studio 2005/2008/2010 Application.

Step-By-Step Instructions

  1. Launch Visual Studio.NET 2008.
  2. Click on File menu, then select New and click Project.
  3. Select Visual C# Project in Project Types.
  4. Select ASP.NET Web Application in the Template box.
  5. Specify the Project's Location and click OK.
  6. Drag WebGrid instance into WebForm.
  7. Right click on WebGrid instance and choose WebGrid.NET Designer.
  8. Go to Advanced tab - RootTable, set DataMember and Caption to Authors.
  9. Checked Table Header Visible checkbox in Basic Properties expandable panel.
  10. Focus to Columns and add 3 columns (AuthorID, LastName and FirstName).

  11. In ChildTables add one table and name it "Books".
  12. Checked Table Header Visible checkbox in Basic Properties expandable panel.
  13. Focus to Columns and add 4 columns (TitleID, Title, Type, and Price) to this table.

  14. Set the Price's DataType to "System.Double" and DataFormatString to "c".
  15. In Page_Load server side event, add these codes to setup RootTable and the ChildTable
C# Copy Image Copy Code
protected void Page_Load(object sender, EventArgs e)
{
   body.Style.Add("overflow", "hidden");

   /* setup root rows and add them to RootTable */

   WebGridRow[] rootRows = new WebGridRow[6];

   for (int i = 0; i <= 6; i++)
      rootRows[i] = WebGrid1.RootTable.CreateRow();

   rootRows[0].Cells.SetItemData(new string[] { "172-32-1176", "White", "Johnson" });
   rootRows[1].Cells.SetItemData(new string[] { "213-46-8915", "Green", "Marjorie" });
   rootRows[2].Cells.SetItemData(new string[] { "238-95-7766", "Carson", "Cheryl" });
   rootRows[3].Cells.SetItemData(new string[] { "267-41-2394", "O'Leary", "Michael" });
   rootRows[4].Cells.SetItemData(new string[] { "274-80-9391", "Straight", "Dean" });
   rootRows[5].Cells.SetItemData(new string[] { "341-22-1782", "Smith", "Meander" });

   WebGrid1.RootTable.Rows.AddRange(rootRows);

   /* - create child rows and add them to the parent row in the RootTable
    * - in this sample, the second row in the root is not expandable
    * - first row is expanded programmatically
    * - all expandable rows should have at least one child row and the SetHierarchicalType()
    *   must be set to the Children collection.
   */

   WebGridTable childTable = WebGrid1.RootTable.ChildTables[0];
   WebGridRow[] childRows = new WebGridRow[11];

   for (int i = 0; i < 11; i++)
      childRows[i] = childTable.CreateRow();

   childRows[0].Cells.SetItemData(new object[] { "BU1032", "The Busy Executive's Database Guide", "Business", 19.99 });
   childRows[1].Cells.SetItemData(new object[] { "BU1111", "Cooking with Computers: Surreptitious Balance Sheets", "Business", 11.95 });
   childRows[2].Cells.SetItemData(new object[] { "BU2075", "You Can Combat Computer Stress!", "Business", 2.99 });
   childRows[3].Cells.SetItemData(new object[] { "BU7832", "Straight Talk About Computers", "Business", 19.99 });
   childRows[4].Cells.SetItemData(new object[] { "MC2222", "Silicon Valley Gastronomic Treats", "Cooking", 19.99 });
   childRows[5].Cells.SetItemData(new object[] { "MC3021", "The Gourmet Microwave", "Cooking", 14.95 });
   childRows[6].Cells.SetItemData(new object[] { "MC3026", "The Psychology of Computer Cooking", "Undecided", 10.29 });
   childRows[7].Cells.SetItemData(new object[] { "PC1035", "But Is It User Friendly?", "Popular Computer", 11.05 });
   childRows[8].Cells.SetItemData(new object[] { "PC8888", "Secrets of Silicon Valley", "Popular Computer", 24.99 });
   childRows[9].Cells.SetItemData(new object[] { "PC9999", "Net Etiquette", "Popular Computer", 9.49 });
   childRows[10].Cells.SetItemData(new object[] { "PS1372", "Computer Phobic AND Non-Phobic Individuals: Behavior Variations", "Psychology", 14.69 });

   rootRows[0].Children.SetHierarchicalType();
   rootRows[0].Children.AddRange(new WebGridRow[] { childRows[0], childRows[1], childRows[2] });
   rootRows[0].ExpandChildRow();

   rootRows[1].ChildNotExpandable = true;

   rootRows[2].Children.SetHierarchicalType();
   rootRows[2].Children.AddRange(new WebGridRow[] { childRows[3], childRows[4] });

   rootRows[3].Children.SetHierarchicalType();
   rootRows[3].Children.AddRange(new WebGridRow[] { childRows[5], childRows[6] });

   rootRows[4].Children.SetHierarchicalType();
   rootRows[4].Children.AddRange(new WebGridRow[] { childRows[7], childRows[8] });

   rootRows[5].Children.SetHierarchicalType();
   rootRows[5].Children.AddRange(new WebGridRow[] { childRows[9], childRows[10] });
}

Here is the result :

See Also

Tasks
Walkthrough: Using WebGrid in Unbound Mode
Walkthrough: Binding WebGrid to Hierarchical ISDataSource control

References
WebGridTable Class

Other Resources
Walkthrough Topics
How-to Topics


Walkthrough: Configuring WebGrid to load PreviewRow on demand

Walkthrough: Configuring WebGrid to load PreviewRow on demand
See Also Send Feedback

Glossary Item Box

This walkthrough shows you how to load PreviewRow on demand.

During this walkthrough, you will learn how to do the following:

  • Use AccessDataSource.
  • Use SmartTag to set DataSource.
  • Use Data Source Configuration Wizard to set the Database and table.

Prerequisites

In order to complete this walkthrough, you will need the following:

  • Visual Studio 2005 Application.
  • Access to the Microsoft Access Northwind database.

Step-By-Step Instructions

  1. Binding WebGrid.NET to AccessDataSource.
  2. Use Employees table instead of Customers table.
  3. Open WebGrid.NET Designer - RootTable.
  4. Set PreviewRowVisible to True.
  5. In PreviewRowSettings, set DefaultExpanded to False and LoadOnDemand to True.
  6. In LoadPreviewRow server side event, add the following code:

    C# Copy Image Copy Code
    using ISNet.WebUI.WebGrid;

protected void WebGrid1_LoadPreviewRow(object sender, ISNet.WebUI.WebGrid.RowEventArgs e)
{
   if (e.Row.Type == ISNet.WebUI.WebGrid.RowType.Record)
   {
      e.Row.PreviewRowValue = ((DataRowView)e.Row.DataRow)["Notes"];
      WebGrid grid = sender as WebGrid;
      grid.ClientAction.SetStatus("Ready.");
   }
}

  7. Compile and run the project. The WebGrid will look like following.

See Also

DefaultExpanded Property

Tasks
Walkthrough: Loading child rows on demand based on the selected parent row

References
PreviewRowSettings Property
DefaultExpanded Property
LoadPreviewRow Event
LoadOnDemand Property
PreviewRowVisible Property

Other Resources
Walkthrough Topics
How-to Topics


Walkthrough: Configuring the WebValueList of a WebGridColumn to translate multiple values data

Walkthrough: Configuring the WebValueList of a WebGridColumn to translate multiple values data
See Also Send Feedback

Glossary Item Box

This walkthrough shows you how to configure the WebValueList of a WebGridColumn to translate multiple values data.

During this walkthrough, you will learn:

  • Use SqlDatasource to bind the grid.
  • Use WebValueList.
  • To translate multiple values data using improved WebValueList feature.

Prerequisites

    In order to complete this walkthrough, you will need the following:

    • Visual Studio 2005/2008/2010 Application.

    Step-By-Step Instructions

    To configure the WebValueList of a WebGridColumn to translate multiple values data

    1. Launch Visual Studio.NET 2008.
    2. Click on File menu, then select New and click Project.
    3. Select Visual C# Project in Project Types.
    4. Select ASP.NET Web Application in the Template box.
    5. Specify the Project's Location and click OK.
    6. Drag a WebGrid instance into WebForm.
    7. Drag two SqlDataSource controls into WebForm.
    8. Right click to the SqlDatasource1 and select Configure Datasource, then choose SqlSampleConnection.
    9. Select statement "SELECT * FROM [Employees]".

      SqlEmployees

    10. Right click to the SqlDatasource2 and select Configure Datasource, then choose SqlSampleConnection.
    11. Select statement "SELECT [RoleId], [RoleName] FROM [Roles]".

      SqlRoles

    12. Open WebGrid.NET Designer - RootTable - Columns. Add EmployeeID, FirstName, LastName, JoinDate, Roles columns.
    13. In LayoutSettings, set AllowEdit to Yes.
    14. In the Roles properties, expand ValueList and set the following properties:

      Property | Value
      DataSourceID | SqlDataSource2
      DataTextField | RoleName
      DataValueField | RoleId
      EnableMultipleValues | True

    15. Compile and run the WebForm. The WebGrid will look like following.

    See Also

    Tasks
    Walkthrough: Binding a WebValueList to a table defined in ISDataSourceControl
    Walkthrough: Binding a WebValueList to different DataSource control

    References
    WebValueList Class
    AllowEdit Property
    EnableMultipleValues Property
    DataSourceID Property
    DataTextField Property
    DataValueField Property

    Other Resources
    Walkthrough Topics
    How-to Topics


Walkthrough: Configuring multiple values editing using WebCombo.NET 4.0 control in WebGrid

Walkthrough: Configuring multiple values editing using WebCombo.NET 4.0 control in WebGrid
See Also Send Feedback

Glossary Item Box

This walkthrough shows you how to configure multiple values editing using WebCombo.NET 4.0 control in WebGrid.

During this walkthrough, you will learn:

  • Use SqlDatasource to bind the grid.
  • Use WebValueList.
  • Configure WebCombo to be inserted into WebGrid.

Prerequisites

    In order to complete this walkthrough, you will need the following:

    • Visual Studio 2005 Application.

    Step-By-Step Instructions

    To Configure multiple values editing using WebCombo.NET 4.0 control in WebGrid

    1. Launch Visual Studio.NET 2005.
    2. Click on File menu, then select New and click Project.
    3. Select Visual C# Project in Project Types.
    4. Select ASP.NET Web Application in the Template box.
    5. Specify the Project's Location and click OK.
    6. Drag a WebGrid instance into WebForm.
    7. Drag a WebCombo instance into WebForm.
    8. Drag two SqlDataSource controls into WebForm.
    9. Right click to the SqlDatasource1 and select Configure Datasource, then choose SqlSampleConnection.
    10. Select statement "SELECT * FROM [Employees]".

      SqlEmployees
    11. Right click to the SqlDatasource2 and select Configure Datasource, then choose SqlSampleConnection.
    12. Select statement "SELECT [RoleId], [RoleName] FROM [Roles]".

      SqlRoles
    13. Right click on WebCombo instance and choose Properties.
    14. Set DataTextField to "RoleName" and DataValueField to "RoleId".
    15. Right click on WebCombo instance and choose WebCombo.NET Designer.
    16. Go to Advanced Features, set the MultipleSelection Enabled to True, and SeparatorChar to ",".
    17. In Advanced Settings, LayoutSettings, set the following properties:

      Property | Value
      AllowFloatingText | False
      BoundMode | ForceUnbound
      TextMode | ReadOnly
      StatusBoxVisible | False

    18. Place the following code in Page_Load server side event.
      C# Copy Code
      protected void Page_Load(object sender, EventArgs e)
{
   if (!IsPostBack)
   {
      /* populate data as unbound to enable checkbox mode in multiple selection */
      DataView view = SqlDataSource2.Select(DataSourceSelectArguments.Empty) as DataView;
      WebCombo1.PopulateUnboundData(view, true);
   }
}

    19. Open WebGrid.NET Designer - RootTable - Columns. Add EmployeeID, FirstName, LastName, JoinDate, Roles columns.
    20. In Advanced Settings, LayoutSettings, set AllowEdit to Yes.
    21. In the Roles properties, expand ValueList and set the following properties:

      Property | Value
      DataSourceID | SqlDataSource2
      DataTextField | RoleName
      DataValueField | RoleId
      EnableMultipleValues | True

    22. Set Edit Control Type to "WebComboNET" and choose WebComboID to "WebCombo1"
    23. Compile and run the WebForm. The WebGrid will look like following.

    See Also

    Tasks
    Walkthrough: Configuring the WebValueList of a WebGridColumn to translate multiple values data
    FAQ: Does WebCombo.NET 4.0 control included in WebGrid.NET Enterprise 5.0?

    References
    DataSourceID Property
    DataTextField Property
    DataValueField Property
    EnableMultipleValues Property
    WebValueList Class

    Other Resources
    Walkthrough Topics
    How-to Topics


Walkthrough: Configuring automatic column sorting for a column using WebValueList

Walkthrough: Configuring automatic column sorting for a column using WebValueList
See Also Send Feedback

Glossary Item Box

This walkthrough shows you how to configure automatic column sorting for a column using WebValueList.

During this walkthrough, you will learn:

  • Use ISDatasource to bind the grid.
  • Use WebValueList.

Prerequisites

    In order to complete this walkthrough, you will need the following:

    • Visual Studio 2005 Application.

    Step-By-Step Instructions

    To Configure Automatic Column Sorting for a Column using WebValueList

    1. Launch Visual Studio.NET 2005.
    2. Click on File menu, then select New and click Project.
    3. Select Visual C# Project in Project Types.
    4. Select ASP.NET Web Application in the Template box.
    5. Specify the Project's Location and click OK.
    6. Drag a WebGrid instance into WebForm.
    7. Drag an ISDataSource control into WebForm.
    8. Right click to the ISDatasource1 and select Configure Datasource. Choose ShemaType to DataSet and Schema Name to dsNorthWind_ReadOnly, then click Next.
    9. Add Categories, Products, and Suppliers tables. Click Finish.
    10. Open WebGrid.NET Designer - RootTable - Columns. Add ProductID, ProductName, SupplierID, CategoryID, QuantityPerUnit, UnitPrice, Discontinued columns. WGDEsigner
    11. In the SupplierID properties, set GroupInterval property to Text.
    12. Expand ValueList and set the following properties:

      Property | Value
      DataMember | Suppliers
      DataTextField | CompanyName
      DataValueField | SupplierID

    13. In the CategoryID properties, set GroupInterval property to Text.
    14. Expand ValueList and set the following properties:

      Property | Value
      DataMember | Categories
      DataTextField | CategoryName
      DataValueField | CategoryID

    15. Go to WebGrid LayoutSettings, set AllowGrouping to Yes and AllowFiltering to Yes.
    16. Go to RootTable, set UseValueListForSorting property to Yes.
    17. Compile and run the WebForm. The WebGrid will look like following.

    See Also

    Tasks
    Walkthrough: Configuring multiple values editing using WebCombo.NET 4.0 control in WebGrid

    References
    DataTextField Property
    DataMember Property
    DataValueField Property
    WebValueList Class
    GroupInterval Property

    Other Resources
    Walkthrough Topics
    How-to Topics


Walkthrough: Configuring WebGrid to keep data cache in local computer's hard drive

Walkthrough: Configuring WebGrid to keep data cache in local computer's hard drive
See Also Send Feedback

Glossary Item Box

This walkthrough shows you how to keep data cache in local computer's hard drive. With FileServer, you no longer have to worry about memory leaks or limited server resources.

During this walkthrough, you will learn:

  • Use ISDatasource to bind the grid.
  • How to set FileServer to enable view state to be saved into a physical disk.

Prerequisites

    In order to complete this walkthrough, you will need the following:

    • Visual Studio 2005 Application.

    Step-By-Step Instructions

    To keep data cache in local computer's hard drive

    1. Launch Visual Studio.NET 2005.
    2. Click on File menu, then select New and click Project.
    3. Select Visual C# Project in Project Types.
    4. Select ASP.NET Web Application in the Template box.
    5. Specify the Project's Location and click OK.
    6. Drag a WebGrid into WebForm.
    7. Drag an ISDataSource into WebForm.
    8. Right click to the ISDatasource1 and select Configure Datasource, choose SchemaType to DataSet and Schema Name dsNorthWind_ReadOnly then click Next.
    9. Add Products table and click Finish.
    10. Go to View State Settings, and set ViewStateStorage to FileServer.
    11. Set ViewStateServerConnection to �??path=c:\CacheStorage�?� ViewStateServer
    Note: The specified path (eg. c:\CacheStorage) requires read and write permission for aspnet_wp worker process (in IIS 5.x) or iis_wpg (in IIS 6+)

    See Also

    Tasks
    How-to: Configure FileCacheServer to use shared network's hard drive

    References
    DataCacheStorage Property
    ViewStateStorage Property
    ViewStateItems Property
    ViewStateServerConnection Property

    Other Resources
    Walkthrough Topics
    How-to Topics


Walkthrough: Configuring a WebGridColumn to use Templated Cell

Walkthrough: Configuring a WebGridColumn to use Templated Cell
See Also Send Feedback

Glossary Item Box

This walkthrough shows you how to configuring a WebGridColumn to use Templated Cell.

During this walkthrough, you will learn how to do the following :

  • Change the WebGridColumn's ColumnType to Template using WebGrid.NET Designer.

Prerequisites

In order to complete this walkthrough, you will need the following:

  • Access to the Microsoft Access Northwind database.
  • Visual Studio 2005/2008/2010 Application.

Step-By-Step Instructions

To create new web application, configure ContactName to use Label and create a new Column and configure it to use HTML Button.

  1. Bind WebGrid to AccessDataSource.
  2. Set WebGrid's properties AllowEdit to True.
  3. Open WebGrid.NET Designer - Roots - Columns.
  4. Search for ContactName then set the ColumnType to Template.
  5. Click the "Add" button to add a new column and move it become first column.
  6. Set this new column's Name to Column11, then set ColumnType to Template.

  7. Right click on WebGrid instance and choose Edit Template - Columns.

  8. Drag and drop Label to the ContactName column.
  9. Drag and drop HTML Button to the Column11 column.

  10. Clear the Label's Text and set Font - Italic to True, ForeColor to Red.
  11. Go to HTML and set the Label's text to "<%# Bind("ContactName") %>".

    eg. <asp:Label ID="Label1" runat="server" Text='<%# Bind("ContactName") %>' ForeColor="Red" Font- Italic="true" />

  12. Add Client Side event (to retrieve row's KeyValue) to this button.

    JavaScript Copy Image Copy Code
    function Button1_onclick()
{
   var grid = ISGetObject("WebGrid1");
   var selObj = grid.GetSelectedObject();
   var rowObj = selObj.ToRowObject();
   alert("This row's KeyValue : " + rowObj.KeyValue);
}

  13. Here is the result.

See Also

Concepts
Templated Cell

Other Resources
Column Types
Walkthrough Topics
How-to Topics

References
ColumnType Property


Walkthrough: Using WebGrid with ASP.NET AJAX RTM

Walkthrough: Using WebGrid with ASP.NET AJAX RTM
See Also Send Feedback

Glossary Item Box

This walkthrough shows you how to use WebGrid with ASP.NET AJAX RTM.

During this walkthrough, you will learn how to do the following:

  • Use AccessDataSource.
  • Use SmartTag to set DataSource.
  • Use Data Source Configuration Wizard to set the Database and table.

Prerequisites

In order to complete this walkthrough, you will need the following:

  • Access to the Microsoft Access Northwind database.
  • Visual Studio 2005 Application.

Step-By-Step Instructions

To create new web application, bind WebGrid to AccessDataSource and use WebFlyPostBackManager

  1. Bind WebGrid to AccessDataSource.
  2. Drag and drop AJAX's UpdatePanel and .NET Button into the page.
  3. Put WebGrid and the AccessDataSource into UpdatePanel.

  4. Set UpdatePanel's Triggers to Button Click event.

  5. On Button Click server side event, add these codes to adding GroupColumn to WebGrid and then present the new changes when the user clicks on a the button
    C# Copy Image Copy Code
    protected void Button1_Click(object sender, EventArgs e)
{
   WebGrid1.RootTable.GroupedColumns.Add(new WebGridGroup("ContactTitle", SortOrder.Ascending, GroupMode.Collapsed, GroupInterval.Default));
   WebGrid1.DataBind();
}
  6. Here is the result when you press the Button.

See Also

Other Resources
Walkthrough Topics
How-to Topics


Walkthrough: Using WebGrid with WebFlyPostBackManager

Walkthrough: Using WebGrid with WebFlyPostBackManager
See Also Send Feedback

Glossary Item Box

This walkthrough shows you how to use WebGrid with FlyPostBackManager.

During this walkthrough, you will learn how to do the following:

  • Use AccessDataSource.
  • Use SmartTag to set DataSource.
  • Use Data Source Configuration Wizard to set the Database and table.

Prerequisites

In order to complete this walkthrough, you will need the following:

  • Access to the Microsoft Access Northwind database.
  • Visual Studio 2005 Application.

Step-By-Step Instructions

To create new web application, bind WebGrid to AccessDataSource and use WebFlyPostBackManager

  1. Bind WebGrid to AccessDataSource.
  2. Drag and drop WebFlyPostBackManager and a .NET Standard button to the page

  3. Set below properties in WebFlyPostBackManager's properties.
    ServiceURL | ~/Walkthrough.aspx (your page's name)
    EnableUIMode | True
  4. On Button Click server side event, add these codes to adding GroupColumn to WebGrid and then present the new changes when the user clicks on a the button
    C# Copy Image Copy Code
    protected void Button1_Click(object sender, EventArgs e)
{
   WebGrid1.RootTable.GroupedColumns.Add(new WebGridGroup("ContactTitle", SortOrder.Ascending, GroupMode.Collapsed, GroupInterval.Default));
   WebGrid1.RequiresUIRefresh = true;
   WebGrid1.DataBind();
}
  5. Here is the result when you press the Button.

See Also

Other Resources
Walkthrough Topics
How-to Topics


Walkthrough: Binding WebGrid to custom object

Walkthrough: Binding WebGrid to custom object
See Also Send Feedback

Glossary Item Box

This walkthrough shows you how to create and bind WebGrid to custom object.

During this walkthrough, you will learn how to do the following:

  • Use ISDataSource.
  • Use Custom Object.
  • Use SmartTag to set DataSource.
  • Use Data Source Configuration Wizard to set the Database and table.

Prerequisites

In order to complete this walkthrough, you will need the following:

  • Access to the Microsoft Access Northwind database.
  • Visual Studio 2005/2008/2010 Application.

Step-By-Step Instructions

To create new web application and bind WebCombo to CustomObject

  1. Launch Visual Studio.NET 2008.
  2. Click on File menu, then select New and click Web Site.
  3. Select ASP.NET Web Site in the Template box and set Location to HTTP.
  4. Named the Web Site and click OK.
  5. Right-click on Project's name and select Add New Item.
  6. Select Intersoft AppForm in the My Templates box and named it as Walkthrough.aspx.
  7. In the Solution Explorer, right-click on App_Data and select Add Existing Item.
  8. Browse and add NorthWind.mdb in C:\Program Files\Intersoft Solutions\Data (Default installation folder).
  9. Right click on App_Code folder, choose New Folder and name the new folder DataObject.
  10. After that right click on the DataObject folder and choose Add New Item.
  11. Then set C# class and named it as MyData.cs and MyDataAccess.cs respectively.
  12. In MyData.cs, add the following code:
    C# Copy Code
    namespace DataObject
{
    public class MyData
    {
        private int shipperID;
        private string companyName;
        private string phone;

        public int ShipperID
        {
            get { return this.shipperID; }
            set { this.shipperID = value; }
        }

        public string CompanyName
        {
            get { return this.companyName; }
            set { this.companyName = value; }
        }

        public string Phone
        {
            get { return this.phone; }
            set { this.phone = value; }
        }
    }
}

  13. In MyDataAccess.cs, add the following code:
    C# Copy Code
    namespace DataObject
{
    [System.ComponentModel.DataObject]
    public class MyDataAccess
    {

        private dsNorthwind_OverwriteChangesTableAdapters.ShippersTableAdapter shipperDA = new dsNorthwind_OverwriteChangesTableAdapters.ShippersTableAdapter();

        public MyDataAccess()
        {

        }

        [System.ComponentModel.DataObjectMethodAttribute(System.ComponentModel.DataObjectMethodType.Select, true)]
        public dsNorthwind_OverwriteChanges.ShippersDataTable GetData()
        {
            return shipperDA.GetData();
        }

        [System.ComponentModel.DataObjectMethodAttribute(System.ComponentModel.DataObjectMethodType.Insert, true)]
        public int Insert(MyData data)
        {
            return shipperDA.Insert(data.CompanyName, data.Phone);
        }

        [System.ComponentModel.DataObjectMethodAttribute(System.ComponentModel.DataObjectMethodType.Update, true)]
        public int Update(MyData data)
        {
            return shipperDA.Update(data.CompanyName, data.Phone, data.ShipperID);
        }

        [System.ComponentModel.DataObjectMethodAttribute(System.ComponentModel.DataObjectMethodType.Delete, true)]
        public int Delete(MyData data)
        {
            return shipperDA.Delete(data.ShipperID);
        }
    }
}

  14. Drag WebGrid instance from ToolBar to WebForm.
  15. Click the SmartTag on the upper right of the WebCombo.
  16. In Choose Data Source field, choose <New data source...>.

  17. In Data Source Configuration Wizard, choose ISDataSource and click OK.

  18. Set the Schema Type to CustomObject and click Next.

  19. Add new table and choose a business object like the following screenshot. Click Finish afterwards.

  20. Run the project and the grid will look like the following.

See Also

Other Resources
Walkthrough Topics
How-to Topics


Walkthrough: Implementing Custom Paging using ObjectDataSource

Walkthrough: Implementing Custom Paging using ObjectDataSource
See Also Send Feedback

Glossary Item Box

This walkthrough shows you how to implement custom paging using ObjectDataSource.

During this walkthrough, you will learn how to do the following:

  • Use ObjectDataSource.
  • Use SmartTag to set DataSource.
  • Use Data Source Configuration Wizard to set the Database and table.

Prerequisites

In order to complete this walkthrough, you will need the following:

  • Set EnablePaging od the datasource control to True.
  • Provides a method for Select. This method requires three parameters: startRow, maximumRows, and sortExpression.
  • Provides a method for SelectCount.
  • Visual Studio 2005 Application.

Step-By-Step Instructions

To create new web application and bind WebGrid to AccessDataSource

  1. Launch Visual Studio.NET 2005.
  2. Click on File menu, then select New and click Web Site.
  3. Select ASP.NET Web Site in the Template box and set Location to HTTP.
  4. Named the Web Site and click OK.
  5. Right-click on Project's name and select Add New Item.
  6. Select Intersoft AppForm in the My Templates box and named it as Walkthrough.aspx.
  7. Right-click on Project's name and select Add New Item.
  8. Choose DataSet and named it NorthWind.

  9. Add Customers table to the dataset.

  10. Right-click on Project's name and select Add New Item.
  11. Choose Class and named it NorthWind.

  12. Create Select method and SelectCount in the class (NorthWind.cs).

    C# Copy Image Copy Code
    namespace NorthWindTableAdapters
    {
        public partial class CustomersTableAdapter
        {
            public DataTable GetData(int startRowIndex, int maximumRows, string sortExpression)
            {
                NorthWind.CustomersDataTable dt = new NorthWind.CustomersDataTable();

                int topRows = startRowIndex + maximumRows;

                if (!string.IsNullOrEmpty(sortExpression))
                    sortExpression = " order by " + sortExpression;

                OleDbDataAdapter adapter = new OleDbDataAdapter();
                adapter.SelectCommand = new OleDbCommand();
                adapter.SelectCommand.CommandText = "Select TOP " + topRows.ToString() + " * FROM Customers" + sortExpression;
                adapter.SelectCommand.Connection = this.Connection;

                adapter.Fill(dt);

                return dt;
            }

            public int SelectCount(string sortExpression)
            {
                this.Connection.Open();
                OleDbDataAdapter adapter = new OleDbDataAdapter();
                adapter.SelectCommand = new OleDbCommand();
                adapter.SelectCommand.CommandText = "Select COUNT(*) From Customers";
                adapter.SelectCommand.Connection = this.Connection;

                int result = (int)adapter.SelectCommand.ExecuteScalar();
                this.Connection.Close();

                return result;
            }
        }
    }

  13. Drag WebGrid instance from ToolBar to WebForm.
  14. Click the SmartTag on the upper right of the WebGrid.
  15. In Choose Data Source field, choose <New data source...>.

  16. In Data Source Configuration Wizard, choose Object and click OK.

  17. Select your Business Object and click Next.

  18. Click Finish afterwards.

  19. Finally, choose Retrieve Structure action in Connected to Data Source Control Wizard and click OK.

  20. Set the WebGrid's properties as following:

    Property | Value
    PagingLoadMode | Custom
    PagingMode | ClassicPaging
    PagingStyleUI | Slider

  21. Set the ObjectDataSource's properties as following:

    Property | Value
    EnablePaging | True
    SelectCountMethod | SelectCount

  22. Run the project and the WebGrid will look like following.

See Also

Tasks
Walkthrough: Implementing Custom Paging using ISDataSource

Other Resources
Walkthrough Topics
How-to Topics


Walkthrough: Implementing Custom Paging using ISDataSource

Walkthrough: Implementing Custom Paging using ISDataSource
See Also Send Feedback

Glossary Item Box

This walkthrough shows you how to implement custom paging using ISDataSource.

During this walkthrough, you will learn how to do the following:

  • Use ISDataSource.
  • Use SmartTag to set DataSource.
  • Use Data Source Configuration Wizard to set the Database and table.

Prerequisites

In order to complete this walkthrough, you will need the following:

  • Set EnablePaging od the datasource control to True.
  • Provides a method for Select. This method requires three parameters: startRow, maximumRows, and sortExpression.
  • Provides a method for SelectCount.
  • Visual Studio 2005/2008/2010 Application.

Step-By-Step Instructions

To create new web application and bind WebGrid to AccessDataSource

  1. Launch Visual Studio.NET 2008.
  2. Click on File menu, then select New and click Web Site.
  3. Select ASP.NET Web Site in the Template box and set Location to HTTP.
  4. Named the Web Site and click OK.
  5. Right-click on Project's name and select Add New Item.
  6. Select Intersoft AppForm in the My Templates box and named it as Walkthrough.aspx.
  7. Right-click on Project's name and select Add New Item.
  8. Choose DataSet and named it NorthWind.

  9. Add Customers table to the dataset.

  10. Right-click on Project's name and select Add New Item.
  11. Choose Class and named it NorthWind.

  12. Create Select method and SelectCount in the class (NorthWind.cs).

    C# Copy Image Copy Code
    namespace NorthWindTableAdapters
{
   public partial class CustomersTableAdapter
   {
      public DataTable GetData(int startRowIndex, int maximumRows, string sortExpression)
      {
         NorthWind.CustomersDataTable dt = new NorthWind.CustomersDataTable();

         int topRows = startRowIndex + maximumRows;

         if (!string.IsNullOrEmpty(sortExpression))
            sortExpression = " order by " + sortExpression;

         OleDbDataAdapter adapter = new OleDbDataAdapter();
         adapter.SelectCommand = new OleDbCommand();
         adapter.SelectCommand.CommandText = "Select TOP " + topRows.ToString() + " * FROM Customers" + sortExpression;
         adapter.SelectCommand.Connection = this.Connection;

         adapter.Fill(dt);

         return dt;
      }

      public int SelectCount(string sortExpression)
      {
         this.Connection.Open();
         OleDbDataAdapter adapter = new OleDbDataAdapter();
         adapter.SelectCommand = new OleDbCommand();
         adapter.SelectCommand.CommandText = "Select COUNT(*) From Customers";
         adapter.SelectCommand.Connection = this.Connection;

         int result = (int)adapter.SelectCommand.ExecuteScalar();
         this.Connection.Close();

         return result;
      }
   }
}

  13. Drag WebGrid instance from ToolBar to WebForm.
  14. Click the SmartTag on the upper right of the WebGrid.
  15. In Choose Data Source field, choose <New data source...>.

  16. In Data Source Configuration Wizard, choose ISDataSource and click OK.

  17. Select the Schema Type that you want to use and click Next.

  18. Add Customers tables and click Finish

  19. Finally, choose Retrieve Structure action in Connected to Data Source Control Wizard and click OK.

  20. Set the WebGrid's properties as following:

    Property | Value
    PagingLoadMode | Custom
    PagingMode | ClassicPaging

  21. Open ISDataSource properties >> Tables and set Customer's Table properties as following:

    Property | Value
    EnablePaging | True
    SelectCountMethod | SelectCount

  22. Run the project and the WebGrid will look like following.

See Also

Tasks
Walkthrough: Implementing Custom Paging using ObjectDataSource

Other Resources
Walkthrough Topics
How-to Topics


Walkthrough: Applying projection to 3D chart types

Walkthrough: Applying projection to 3D chart types
See Also Send Feedback

Glossary Item Box

This walkthrough shows you how to apply projection to 3D chart types.

During this walkthrough, you will learn how to do the following:

  • Use AccessDataSource.
  • Use SmartTag to set DataSource.
  • Set Pivot Chart View for WebGrid.
  • Set lightning for 3D chart types.

Prerequisites

In order to complete this walkthrough, you will need the following:

  • Access to the Microsoft Access Northwind database.
  • Visual Studio 2005/2008/2010 Application.

Step-By-Step Instructions

To apply projection to 3D chart types

  1. Bind WebGrid to AccessDataSource control.
  2. Click on WebGrid instance and press F4 to open its Properties window.
  3. Expand LayoutSettings and set the InitialView property to PivotChartView.

  4. Right-click on WebGrid instance and select WebGrid.NET Designer.
  5. Set the Chart Data Collection property in Pivot Charting tab >> Pivot Charting.

  6. Set the Chart Series Collection property in Pivot Charting tab >> Pivot Charting.

  7. You also need to set the VisualEffect property in Pivot Charting tab.

  8. Set the Projection property in Pivot Charting tab.
  9. Run the project.

See Also

Other Resources
Walkthrough Topics
How-to Topics


Walkthrough: Applying lighting effect to 3D chart types

Walkthrough: Applying lighting effect to 3D chart types
See Also Send Feedback

Glossary Item Box

This walkthrough shows you how to apply lighting effect to 3D chart types.

During this walkthrough, you will learn how to do the following:

  • Use AccessDataSource.
  • Use SmartTag to set DataSource.
  • Set Pivot Chart View for WebGrid.
  • Set lightning for 3D chart types.

Prerequisites

In order to complete this walkthrough, you will need the following:

  • Access to the Microsoft Access Northwind database.
  • Visual Studio 2005/2008/2010 Application.

Step-By-Step Instructions

To apply lighting effect to 3D chart types

  1. Bind WebGrid to AccessDataSource control.
  2. Click on WebGrid instance and press F4 to open its Properties window.
  3. Expand LayoutSettings and set the InitialView property to PivotChartView.

  4. Right-click on WebGrid instance and select WebGrid.NET Designer.
  5. Set the Chart Data Collection property in Pivot Charting tab >> Pivot Charting.

  6. Set the Chart Series Collection property in Pivot Charting tab >> Pivot Charting.

  7. You also need to set the VisualEffect property in Pivot Charting tab.

  8. Set the Lighting property in Pivot Charting tab.
  9. Run the project.

See Also

Other Resources
Walkthrough Topics
How-to Topics


Walkthrough: Adding new data where a column's data type is AutoNumber

Walkthrough: Adding new data where a column's data type is AutoNumber
See Also Send Feedback

Glossary Item Box

This walkthrough shows you how to add new data using AccessDataSource control, where one of the columns data type is AutoNumber.

During this walkthrough, you will learn how to do the following:

  • Use AccessDataSource.
  • Use SmartTag to set DataSource.
  • Use Data Source Configuration Wizard to set the Database and table.
  • Add new data without having to specify the ProductID.

Prerequisites

In order to complete this walkthrough, you will need the following:

  • Access to the Microsoft Access Northwind database.
  • Visual Studio 2005 Application.

Step-By-Step Instructions

To create new web application and add new data into the WebGrid

  1. Binding WebGrid to AccesDataSource control. (Use Products table)
  2. Right click on WebGrid instance and choose WebGrid.NET Designer.
  3. In WebGrid.NET Designer - Quick Start - Popular Settings, tick Allow Add New.
  4. Save and run the project.
  5. Click on the NewRow section and add all the information needed but leave ProductID column blank/empty.

  6. Press Shift + Enter to add the new row. Notice that the ProductID will be set as auto-increment according to the previous one.

See Also

Other Resources
Walkthrough Topics
How-to Topics


Walkthrough: Binding WebGrid to ISLinqDataSource

Walkthrough: Binding WebGrid to ISLinqDataSource
See Also Send Feedback

Glossary Item Box

This walkthrough will guide you to bind the WebGrid control to ISLinqDataSource.

During this walkthrough, you will learn how to do the following:

  • Configure the LINQ to SQL classes.

Prerequisites

In order to complete this walkthrough, you will need the following:

  • Visual Studio 2005/2008/2010 Application.
  • Microsoft.NET Framework 3.5.
  • Intersoft WebUI Studio.NET 2009 R2 SP1.

Step-By-Step Instructions

To create new web application and bind WebGrid to ISLinqDataSource

  1. Create new WebForm from Intersoft Default Form template.
  2. Open the toolbox. Expand Intersoft WebUI Studio.NET 2008 R2 tab group. Drag WebGrid to the designer surface.
  3. Drag ISLinqDataSource to the designer surface. If you can't find ISLinqDataSource, please download ISLinqDataSource and save the assembly to [Program Files]\Intersoft Solutions\WebGrid 6.0\Bin. Then add it to Visual Studio toolbox by right clicking on the toolbox area and click Choose Items.
  4. Click Configure Datasource from the ISLinqDataSource smart tag. See below.
  5. The LinqDataSource Wizard is pretty simple and straightforward. On the first screen, it should already select NorthwindDataContext by default, so simply click Next.
  6. On the second screen, since we want to select all customer properties, we don't need to configure anything else, simply click Finish. See below.

  7. Select WebGrid instance and open its smart tag. Choose ISLinqDataSource1 as the DataSourceID, and the WebGrid wizard will appear such as shown below.

  8. Simply click OK as we want the WebGrid to retrieve the columns structure from the ISLinqDataSource.
  9. You're all set. Save the WebForm, and run the page in the browser.
  10. You have successfully bound a WebGrid control to LINQ-enabled datasource. Your browser should look like the image below.

See Also

Tasks
Walkthrough: Enabling Sorting, Grouping and Filtering
Walkthrough: Enabling Paging
Walkthrough: Enabling Transactions (Add/Edit/Delete)
Walkthrough: Enabling Aggregate Computation

Other Resources
Large Dataset Performance Demystified
Walkthrough Topics
How-to Topics


Walkthrough: Enabling Sorting, Grouping and Filtering

Walkthrough: Enabling Sorting, Grouping and Filtering
See Also Send Feedback

Glossary Item Box

This walkthrough will guide you to enable basic data operations on WebGrid, such as sorting, grouping and filtering.

During this walkthrough, you will learn how to do the following:

  • Configure the LINQ to SQL classes.

Prerequisites

In order to complete this walkthrough, you will need the following:

  • Visual Studio 2008 Application.
  • Microsoft.NET Framework 3.5.
  • Intersoft WebUI Studio.NET 2008 R2.

Step-By-Step Instructions

To create new web application and enable sorting, grouping and filtering

  1. Continuing from Walkthrough: Binding WebGrid to ISLinqDataSource, select WebGrid instance and open its smart tag panel.
  2. Simply check on Allow Filtering, Allow Grouping and Allow Sorting. See below.

  3. You're done - it's that easy.
  4. Save your WebForm and run the page to browser.
  5. You can try to interact with the WebGrid, such as right click on the Country column and choose "Group this Column", as well as filtering the ContactTitle to show only records with "Sales". See below.

See Also

Tasks
Walkthrough: Binding WebGrid to ISLinqDataSource
Walkthrough: Enabling Paging
Walkthrough: Enabling Transactions (Add/Edit/Delete)
Walkthrough: Enabling Aggregate Computation

Other Resources
Large Dataset Performance Demystified
Walkthrough Topics
How-to Topics


Walkthrough: Enabling Paging

Walkthrough: Enabling Paging
See Also Send Feedback

Glossary Item Box

This walkthrough will guide you to enable the paging feature in WebGrid, which is a crucial feature to deliver high performance data presentation to user.

During this walkthrough, you will learn how to do the following:

  • Configure the LINQ to SQL classes.

Prerequisites

In order to complete this walkthrough, you will need the following:

  • Visual Studio 2008 Application.
  • Microsoft.NET Framework 3.5.
  • Intersoft WebUI Studio.NET 2008 R2.

Step-By-Step Instructions

To create new web application and enable paging feature

  1. To better demonstrate paging feature, let's use a larger datasource such as Orders table. Repeat the same steps as in Walkthrough: Binding WebGrid to ISLinqDataSource, except step 6 where you should choose Orders table instead of Customers.

    After the Orders structure is retrieved, switch to Source view, and delete "Customer" column from the WebGrid's columns collection. The customer column is the association between order and its parent object, and is not required to be shown in WebGrid.
  2. Expand LayoutSettings.
  3. Set the following properties. Note: It's important to set these 3 properties to instruct WebGrid to take advantage of LINQ to SQL features through the connected LINQ-enabled datasource.
    1. PagingMode to ClassicPaging.
    2. PagingLoadMode to Custom.
    3. PagingRetrievalMode to ReturnPartialRows.
      See the following image for the details.

  4. You're all set. Save the WebForm and run it to browser.
  5. Try to go to last page, and notice the performance difference. The paging now took less than a second to perform. You can also try with combination of data operations such as filtering and sorting.

See Also

Tasks
Walkthrough: Binding WebGrid to ISLinqDataSource
Walkthrough: Enabling Sorting, Grouping and Filtering
Walkthrough: Enabling Transactions (Add/Edit/Delete)
Walkthrough: Enabling Aggregate Computation

Other Resources
Large Dataset Performance Demystified
Walkthrough Topics
How-to Topics


Walkthrough: Enabling Transactions (Add/Edit/Delete)

Walkthrough: Enabling Transactions (Add/Edit/Delete)
See Also Send Feedback

Glossary Item Box

This walkthrough will guide you to enable transaction operations in WebGrid, such as adding, editing and deleting.

During this walkthrough, you will learn how to do the following:

  • Configure the LINQ to SQL classes.

Prerequisites

In order to complete this walkthrough, you will need the following:

  • Visual Studio 2008 Application.
  • Microsoft.NET Framework 3.5.
  • Intersoft WebUI Studio.NET 2008 R2.

Step-By-Step Instructions

To create new web application and enable add, edit and delete

  1. You can choose to continue from Walkthrough: Enabling Sorting, Grouping and Filtering or Walkthrough: Enabling Paging.
  2. Select WebGrid, and open its smart tag designer.
  3. Simply check on Allow Add, Allow Edit and Allow Delete.
  4. Select ISLinqDataSource1, check on Enable Insert, Enable Update and Enable Delete. See below.

  5. You're all set - notice you haven't write any single line of codes so far.
  6. Save the WebForm and run it to browser.
  7. Try to edit a record, and press shift+enter to commit changes.

    Notice that data transaction is completed in less than a second - no matter how large your data is, or how complex your data view is.

See Also

Tasks
Walkthrough: Binding WebGrid to ISLinqDataSource
Walkthrough: Enabling Sorting, Grouping and Filtering
Walkthrough: Enabling Paging
Walkthrough: Enabling Aggregate Computation

Other Resources
Large Dataset Performance Demystified
Walkthrough Topics
How-to Topics


Walkthrough: Enabling Aggregate Computation

Walkthrough: Enabling Aggregate Computation
See Also Send Feedback

Glossary Item Box

This walkthrough will guide you to enable column footer and assign built-in aggregate function to WebGrid.

During this walkthrough, you will learn how to do the following:

  • Configure the LINQ to SQL classes.

Prerequisites

In order to complete this walkthrough, you will need the following:

  • Visual Studio 2008 Application.
  • Microsoft.NET Framework 3.5.
  • Intersoft WebUI Studio.NET 2008 R2.

Step-By-Step Instructions

To create new web application and enable aggregate function

  1. Continuing from Walkthrough: Enabling Transactions (Add/Edit/Delete), select WebGrid, right click and click WebGrid.NET Designer.
  2. Go to Advanced tab, expand WebGrid and select RootTable. Then click "See all properties" link in the right panel. See below.

  3. Set ColumnFooters property to Yes.
  4. Click on "Columns"node in the left panel.
  5. Select OrderID column, click See all properties.
  6. Set AggregateFunction to Count and FooterText to "Count".
  7. Select Freight column, click See all properties.
  8. Set AggregateFunction to Sum and FooterText to "Sum".
    At this point, you should see something similar to following screen:

  9. Click OK to apply all settings and close the designer.
  10. The last step is to set the ColumnFooterAggregateMode to ExternalDataSource. You can find this property inside LayoutSettings.

    It's very important to set ColumnFooterAggregateMode to ExternalDataSource option in order to take advantage of "LINQ to SQL" features through the connected ISLinqDataSource control.
  11. Save your WebForm, and run it to browser.
  12. Your browser should have similar results as in the following:

    Notice that the Count aggregate result is now shown in OrderID column footer. Although the paging is applied to the WebGrid, the aggregate result is not affected. That means, the aggregate result is computed against the data shape that created by the LINQ query, regardless of paging view.

See Also

Tasks
Walkthrough: Binding WebGrid to ISLinqDataSource
Walkthrough: Enabling Sorting, Grouping and Filtering
Walkthrough: Enabling Paging
Walkthrough: Enabling Transactions (Add/Edit/Delete)

Other Resources
Large Dataset Performance Demystified
Walkthrough Topics
How-to Topics


Walkthrough: Configuring Updatable WebGrid in Batch Update mode (Using DataSet Binding)

Walkthrough: Configuring Updatable WebGrid in Batch Update mode (Using DataSet Binding)
See Also Send Feedback

Glossary Item Box

This walkthrough shows you how to configure updatable WebGrid bound to DataSet.

During this walkthrough, you will learn how to do the following:

  • Use DataSet.
  • Use SmartTag to allow Add New, AllowEdit and Allow Delete.

Prerequisites

In order to complete this walkthrough, you will need the following:

  • Access to the Microsoft Access Northwind database.
  • Visual Studio 2008 Application.

Step-By-Step Instructions

To create new web application and bind WebGrid to AccessDataSource

  1. Launch Visual Studio.NET 2008.
  2. Click on File menu, then select New and click Web Site.
  3. Select ASP.NET Web Site in the Template box and set Location to HTTP.
  4. Named the Web Site and click OK.
  5. Right-click on Project's name and select Add New Item.
  6. Select Intersoft AppForm in the My Templates box and named it as Walkthrough.aspx.
  7. Drag WebGrid instance from ToolBar to WebForm.
  8. In the Solution Explorer, right-click on App_Data and select Add Existing Item.
  9. Browse and add NorthWind.mdb in C:\Program Files\Intersoft Solutions\Data (Default installation folder).
  10. In the Solution Explorer, Add App_Code folder on your project and create new DataSet that connect to NorthWind.mdb in that folder.
  11. Click the SmartTag on the upper right of the WebGrid.
  12. Select Allow Add New, Allow Editing, and Allow Delete properties.

  13. Set AllowBatchUpdate to True on WebGrid Layout Settings.

  14. Add InitializeDataSource, PrepareDataBinding, and BatchUpdate events from toolbar properties:

  15. On InitializeDataSource event add these codes to bind WebGrid into Dataset:
    C# Copy Image Copy Code
    protected void WebGrid1_InitializeDataSource(object sender, ISNet.WebUI.WebGrid.DataSourceEventArgs e)
{
   DsNorthwind.CustomersDataTable dt = new DsNorthwind.CustomersDataTable();
   DsNorthwindTableAdapters.CustomersTableAdapter da = new DsNorthwindTableAdapters.CustomersTableAdapter();
   da.Fill(dt);
   e.DataSource = dt;
}

  16. On PrepareDataBinding event add these codes to retrieve WebGrid structure:
    C# Copy Image Copy Code
    protected void WebGrid1_PrepareDataBinding(object sender, ISNet.WebUI.WebGrid.DataSourceEventArgs e)
{
   if (!IsPostBack)
      WebGrid1.RetrieveStructure();
}

  17. BatchUpdate event add these codes to update all changes that user made during batch update:
    C# Copy Image Copy Code
    protected void WebGrid1_BatchUpdate(object sender, ISNet.WebUI.WebGrid.BatchUpdateEventArgs e)
{
   DsNorthwindTableAdapters.CustomersTableAdapter da = new DsNorthwindTableAdapters.CustomersTableAdapter();
   DsNorthwind.CustomersDataTable dtCust = (DsNorthwind.CustomersDataTable)WebGrid1.GetCachedDataSource();
   DsNorthwind.CustomersDataTable changeDT = (DsNorthwind.CustomersDataTable)dtCust.GetChanges();
   da.Update(changeDT);
}

See Also

Tasks
Walkthrough: Configuring Updatable WebGrid in Batch Update mode (Using Declarative Datasource Control)

Other Resources
Walkthrough Topics
How-to Topics


Walkthrough: Configuring Updatable WebGrid in Batch Update mode (Using Declarative Datasource Control)

Walkthrough: Configuring Updatable WebGrid in Batch Update mode (Using Declarative Datasource Control)
See Also Send Feedback

Glossary Item Box

This walkthrough shows you how to configure updatable WebGrid in Batch Update mode using AccessDataSource control.

During this walkthrough, you will learn how to do the following:

  • Use AccessDataSource.
  • Use SmartTag to set DataSource.
  • Use Data Source Configuration Wizard to set the Database, table and also INSERT,UPDATE and DELETE statements.
  • Apply Batch Update Mode

Prerequisites

In order to complete this walkthrough, you will need the following:

  • Access to the Microsoft Access Northwind database.
  • Visual Studio 2008 Application.

Step-By-Step Instructions

To create new web application and bind WebGrid to AccessDataSource

  1. Launch Visual Studio.NET 2008.
  2. Click on File menu, then select New and click Web Site.
  3. Select ASP.NET Web Site in the Template box and set Location to HTTP.
  4. Named the Web Site and click OK.
  5. Right-click on Project's name and select Add New Item.
  6. Select Intersoft AppForm in the My Templates box and named it as Walkthrough.aspx.
  7. Drag WebGrid instance from ToolBar to WebForm.
  8. In the Solution Explorer, right-click on App_Data and select Add Existing Item.
  9. Browse and add NorthWind.mdb in C:\Program Files\Intersoft Solutions\Data (Default installation folder).
  10. Click the SmartTag on the upper right of the WebGrid.
  11. In Choose Data Source field, choose <New data source...>.

  12. In Data Source Configuration Wizard, choose AccessDatabase and click OK.

  13. Browse and select the database in App_Data (NorthWind.mdb) and click OK.

  14. Select the table that you want to use and click Next.

  15. Configure INSERT,UPDATE, and DELETE statements by clicking Advanced Button (Please check how to configure the INSERT,UPDATE and DELETE statements for another DataSourceControl).

  16. In this step, you can view the table's database using Test Query button. Otherwise, click Finish to proceed to the next step.
  17. Finally, choose Retrieve Structure action in Connected to Data Source Control Wizard and click OK to apply all settings.

  18. Run the project and the WebGrid will look like following.

  19. Set the AllowEdit,AllowAddNew and AllowDelete property to Yes from WebGrid's SmartTag.

  20. Press F4 in WebGrid and go to LayoutSettings property. Then set AllowBatchUpdate property to true.

  21. When you edit or do some changes, WebGrid will look like following

See Also

Tasks
Walkthrough: Configuring Updatable WebGrid in Batch Update mode (Using DataSet Binding)

Other Resources
Walkthrough Topics
How-to Topics


Walkthrough: Creating Updatable Hierarchical WebGrid in Batch Update mode (Using DataSet Binding)

Walkthrough: Creating Updatable Hierarchical WebGrid in Batch Update mode (Using DataSet Binding)
See Also Send Feedback

Glossary Item Box

This walkthrough shows you how to configure updatable hierarchical WebGrid in Batch Update mode.

During this walkthrough, you will learn how to do the following:

  • Binding Dataset to a WebGrid
  • Create updatable hierarchical WebGrid in batch update mode

Prerequisites

In order to complete this walkthrough, you will need the following:

  • Access to the Microsoft Access Northwind database.
  • Visual Studio 2008 Application.

Step-By-Step Instructions

To create updatable WebGrid in batch update mode

  1. Binding WebGrid to Hierarchical ISDataSource control.
  2. Implement function BatchUpdate server side event like following:
    C# Copy Image Copy Code
    void WebGrid1_BatchUpdate(object sender, BatchUpdateEventArgs e)
{
   CustomersTableAdapter daCustomer = new CustomersTableAdapter();
   OrdersTableAdapter daOrders = new OrdersTableAdapter();
   Order_DetailsTableAdapter daOrderDetails = new Order_DetailsTableAdapter();

   dsNorthwind ds = (dsNorthwind)WebGrid1.GetCachedDataSource();
   // updates all changes per table adapter from the root table
   // to each child table in ordered sequence

   daCustomer.Update(ds);
   daOrders.Update(ds);
   daOrderDetails.Update(ds);
}

See Also

Tasks
Walkthrough: Creating Updatable Hierarchical WebGrid in Batch Update mode (Using ISDataSource)

Other Resources
Walkthrough Topics
How-to Topics


Walkthrough: Creating Updatable Hierarchical WebGrid in Batch Update mode (Using ISDataSource)

Walkthrough: Creating Updatable Hierarchical WebGrid in Batch Update mode (Using ISDataSource)
See Also Send Feedback

Glossary Item Box

This walkthrough shows you how to configure updatable hierarchical WebGrid in Batch Update mode by using ISDataSource.

During this walkthrough, you will learn how to do the following:

  • Use ISDataSource
  • Use SmartTag to set DataSource
  • Use DataSourceConfiguration Wizard to set the database and table

Prerequisites

In order to complete this walkthrough, you will need the following:

  • Access to the Microsoft Access Northwind database.
  • Visual Studio 2008 Application.

Step-By-Step Instructions

To create updatable WebGrid in batch update mode

  1. Binding WebGrid to Hierarchical ISDataSource control.
  2. Click the SmartTag on the upper right of the WebGrid.
  3. In Behaviors field, check following list of checkboxes: Allow Add New; Allow Editing; Allow Delete; Allow Sorting [optional]; Allow Grouping [optional]; Allow Exporting [optional]; Allow Filtering [optional]; Allow Column Freezing [optional]; Allow Column Moving [optional]; Allow Column Sizing [optional]; Allow Column Selection [optional]; Allow Context Menu.

  4. Click WebGrid.NET Designer from the SmartTag menu of the WebGrid. Intersoft Component Designer 2.0 �?? WebGrid Enterprise® 7.0 will appear.

  5. On the Quick Start tab, click Popular Settings from left pane, and scroll down until the Editing section. Check Display verbose information in status bar during editing and Move selection to first editable cell after successful add operation; select AlwaysUpdate radio button on Action when the new row lost its focus and select AlwaysUpdate radio button on Action when the row lost its focus.

  6. Scroll down until the Editing �?? Batch Update section. Check the entire checkboxes option within this section.

  7. Scroll down until the Paging section. Set Paging Mode to ClassicPaging and Paging size for classic paging to 10.

  8. In the Properties, set the width of the WebGrid to 100% and height to 393px.
  9. Run the project and the WebGrid should look like following.

See Also

Tasks
Walkthrough: Creating Updatable Hierarchical WebGrid in Batch Update mode (Using DataSet Binding)

Other Resources
Walkthrough Topics
How-to Topics


Walkthrough: Creating Updatable WebGrid using DataTable

Walkthrough: Creating Updatable WebGrid using DataTable
See Also Send Feedback

Glossary Item Box

This walkthrough shows you how to create updatable WebGrid using DataTable in BatchUpdate mode (Insert Identity / AutoIncrement ID Scenario).

During this walkthrough, you will learn how to do the following:

  • Create Dataset

Prerequisites

In order to complete this walkthrough, you will need the following:

  • Access to the Microsoft Access Northwind database.
  • Visual Studio 2008 Application.

Step-By-Step Instructions

To create new web application and bind WebGrid to ObjectDataSource

  1. Launch Visual Studio.NET 2008.
  2. Click on File menu, then select New and click Web Site.
  3. Select ASP.NET Web Site in the Template box and set Location to HTTP.
  4. Named the Web Site and click OK.
  5. Right-click on Project's name and select Add New Item.
  6. Select Intersoft AppForm in the My Templates box and named it as Walkthrough.aspx.
  7. Drag WebGrid instance from ToolBar to WebForm.
  8. In the Solution Explorer, right-click on App_Data and select Add Existing Item.
  9. Browse and add NorthWind.mdb in C:\Program Files\Intersoft Solutions\Data (Default installation folder).
  10. Create DataSet (dsNorthWind) in App_code and go to Server explorer.

  11. Choose Northwind and drag and drops all tables into dataset.

  12. Create a new class object (dsNorthwind_Extended.cs) in App_code.

  13. Refer the namespace to dsNorthwindTableAdapters and add methods to select identity. Here are the following details.
    C# Copy Code
    usingSystem.Data.OleDb;namespacedsNorthwindTableAdapters
{
   public partial class OrdersTableAdapter : System.ComponentModel.Component
   {
      public OleDbDataAdapter DataAdapter
      {
         get { return this.Adapter; }
      }
   }
}

  14. Press F4 on WebGrid via VS Design mode and set the following event for server-side.

  15. Bind WebGrid traditionally and use the following methods for identity scenario.
    C# Copy Code
    dsNorthwindTableAdapters.OrdersTableAdapter daOrders;
protected void WebGrid1_InitializeDataSource(object sender, ISNet.WebUI.WebGrid.DataSourceEventArgs e)
{
   dsNorthwind.OrdersDataTable dt = new dsNorthwind.OrdersDataTable();
   dsNorthwindTableAdapters.OrdersTableAdapter daOrders = new dsNorthwindTableAdapters.OrdersTableAdapter();
   daOrders.Fill(dt);
   e.DataSource = dt;
}

protected void WebGrid1_PrepareDataBinding(object sender, ISNet.WebUI.WebGrid.DataSourceEventArgs e)
{
   WebGrid1.RetrieveStructure();
}

protected void WebGrid1_InitializeLayout(object sender, LayoutEventArgs e)
{
   e.Layout.AllowAddNew = AddNew.Yes;
   e.Layout.AllowBatchUpdate = true;
   e.Layout.AllowDelete = Delete.Yes;
   e.Layout.AllowEdit = Edit.Yes;
}

protected void WebGrid1_BatchUpdate(object sender, BatchUpdateEventArgs e)
{
   dsNorthwind.OrdersDataTable dt = (dsNorthwind.OrdersDataTable)WebGrid1.GetCachedDataSource();
   dsNorthwind.OrdersDataTable changeDT = (dsNorthwind.OrdersDataTable)dt.GetChanges();
   daOrders = new dsNorthwindTableAdapters.OrdersTableAdapter();
   daOrders.DataAdapter.RowUpdated += new OleDbRowUpdatedEventHandler(DataAdapter_RowUpdated);
   daOrders.Update(changeDT);
}

void DataAdapter_RowUpdated(object sender, OleDbRowUpdatedEventArgs e)
{
   // Conditionally execute this code block on inserts only.
   if (e.StatementType == StatementType.Insert)
   {
      if (e.Row.Table.TableName == "Orders")
      {
         /* Retrieve the new identity and call UpdateRowIdentity to process the new identity. */
         OleDbCommand cmdNewID = new OleDbCommand("SELECT @@IDENTITY", e.Command.Connection);
         WebGrid1.GetTableByName("Orders").UpdateRowIdentity("OrderID", e.Row["OrderID"], cmdNewID.ExecuteScalar());
      }
   }
}

See Also

Tasks
Walkthrough: Creating Updatable Hierarchical WebGrid using DataSet
Walkthrough: Creating Updatable WebGrid using ISDataSource
Walkthrough: Creating Updatable Hierarchical WebGrid using ISDataSource
Walkthrough: Creating Updatable WebGrid using Custom Object

Other Resources
Walkthrough Topics
How-to Topics


Walkthrough: Creating Updatable Hierarchical WebGrid using DataSet

Walkthrough: Creating Updatable Hierarchical WebGrid using DataSet
See Also Send Feedback

Glossary Item Box

This walkthrough shows you how to create updatable WebGrid using DataSet in BatchUpdate mode.

During this walkthrough, you will learn how to do the following:

  • Binding DataSet to a WebGrid
  • Create updatable Hierarchical WebGrid in batch update mode

Prerequisites

In order to complete this walkthrough, you will need the following:

  • dsNorthwind.xsd.
  • Visual Studio 2008 Application.

Step-By-Step Instructions

To create updatable hierarchical WebGrid using DataSet

  1. Binding WebGrid to Hierarchical ISDataSource control.
  2. Implement function BatchUpdate server side event. Here is the snippet:
    C# Copy Code
    void WebGrid1_BatchUpdate(object sender, BatchUpdateEventArgs e)
{
   CustomersTableAdapter daCustomer = new CustomersTableAdapter();
   OrdersTableAdapter daOrders = new OrdersTableAdapter();
   Order_DetailsTableAdapter daOrderDetails = new Order_DetailsTableAdapter();
   dsNorthwind ds = (dsNorthwind)WebGrid1.GetCachedDataSource();

   // updates all changes per table adapter from the root table to each child table in ordered sequence
   daCustomer.Update(ds);
   daOrders.Update(ds);
   daOrderDetails.Update(ds);
}

See Also

Tasks
Walkthrough: Creating Updatable WebGrid using DataTable
Walkthrough: Creating Updatable WebGrid using ObjectDataSource
Walkthrough: Creating Updatable Hierarchical WebGrid using ISDataSource
Walkthrough: Creating Updatable WebGrid using Custom Object

Other Resources
Walkthrough Topics
How-to Topics


Walkthrough: Creating Updatable WebGrid using ObjectDataSource

Walkthrough: Creating Updatable WebGrid using ObjectDataSource
See Also Send Feedback

Glossary Item Box

This walkthrough shows you how to create updatable WebGrid using ObjectDataSource in BatchUpdate mode (Insert Identity / AutoIncrement ID Scenario).

During this walkthrough, you will learn how to do the following:

  • Create Dataset
  • Use SmartTag to set DataSource

Prerequisites

In order to complete this walkthrough, you will need the following:

  • Access to the Microsoft Access Northwind database.
  • Visual Studio 2008 Application.

Step-By-Step Instructions

To create new web application and bind WebGrid to ObjectDataSource

  1. Launch Visual Studio.NET 2008.
  2. Click on File menu, then select New and click Web Site.
  3. Select ASP.NET Web Site in the Template box and set Location to HTTP.
  4. Named the Web Site and click OK.
  5. Right-click on Project's name and select Add New Item.
  6. Select Intersoft AppForm in the My Templates box and named it as Walkthrough.aspx.
  7. Drag WebGrid instance from ToolBar to WebForm.
  8. In the Solution Explorer, right-click on App_Data and select Add Existing Item.
  9. Browse and add NorthWind.mdb in C:\Program Files\Intersoft Solutions\Data (Default installation folder).
  10. Create DataSet (dsNorthWind) in App_code and go to Server explorer.

  11. Choose Northwind and drag and drops all tables into dataset.

  12. Create a new class object (dsNorthwind_Extended.cs) in App_code.

  13. Refer the namespace to dsNorthwindTableAdapters and add methods to select identity. Here are the following details.
    C# Copy Image Copy Code
    using System.Data.OleDb;namespace dsNorthwindTableAdapters
{
   public partial class OrdersTableAdapter : System.ComponentModel.Component
   {
   [System.ComponentModel.DataObjectMethodAttribute(System.ComponentModel.DataObjectMethodType.Insert, true)]
      public int DoInsert(ref System.Nullable OrderID, string CustomerID, System.Nullable EmployeeID,
      System.Nullable OrderDate, System.Nullable RequiredDate, System.Nullable
      ShippedDate, System.Nullable ShipVia, System.Nullable Freight, string ShipName, string ShipAddress, string ShipCity,
      string ShipRegion, string ShipPostalCode, string ShipCountry)
      {
         this.Connection.Open(); // important
         int affectedRows = this.Insert(CustomerID, EmployeeID, OrderDate, RequiredDate, ShippedDate, ShipVia, Freight,
               ShipName, ShipAddress, ShipCity, ShipRegion, ShipPostalCode, ShipCountry);
         int identity = this.SelectIdentityQuery();
         OrderID = identity;
         this.Connection.Close();
         return affectedRows;
      }

      public int SelectIdentityQuery()
      {
         OleDbCommand cmd = new OleDbCommand("SELECT @@IDENTITY", this.Connection);
         int newID = (int)cmd.ExecuteScalar();
         return newID;
      }
   }
}

  14. Click the SmartTag on the upper right of the WebGrid.
  15. In Choose Data Source field, choose <New data source...>.

  16. In Data Source Configuration Wizard, choose Object and click OK.

  17. Select your Business Object and click Next.

  18. Click Next and go to Insert Method. Ensure that the method is referring to the Insert method for identity which created at dsNorthwind_extended and click Finish.

  19. Finally, choose Retrieve Structure action in Connected to Data Source Control Wizard and click OK.

  20. Select ObjectDataSource control at design mode and press F4. Click on InsertParamerters Collection.

  21. Select OrderID and click on Show Advanced Properties.

  22. Ensure that Direction properties is assigned to InputOutput and OK.

  23. Click on ObjectDataSource control at design mode and press F4 (server side event mode).

  24. At Server-side, add the following code:
  25. C# Copy Code
    protected void ObjectDataSource1_Inserted(object sender, ObjectDataSourceStatusEventArgs e)
{
   WebGrid1.SetOutputParameters(e.OutputParameters);
}

See Also

Tasks
Walkthrough: Creating Updatable WebGrid using DataTable
Walkthrough: Creating Updatable Hierarchical WebGrid using DataSet
Walkthrough: Creating Updatable Hierarchical WebGrid using ISDataSource
Walkthrough: Creating Updatable WebGrid using Custom Object

Other Resources
Walkthrough Topics
How-to Topics


Walkthrough: Creating Updatable Hierarchical WebGrid using ISDataSource

Walkthrough: Creating Updatable Hierarchical WebGrid using ISDataSource
See Also Send Feedback

Glossary Item Box

This walkthrough shows you how to identity upon successive inserts by creating a new insert methods.

During this walkthrough, you will learn how to do the following:

  • Binding ISDataSource to a WebGrid
  • Create updatable Hierarchical WebGrid by returning new identity

Prerequisites

In order to complete this walkthrough, you will need the following:

  • Access to the Microsoft Access Northwind database.
  • Visual Studio 2008/2010 Application.

Step-By-Step Instructions

To create new web application and bind WebGrid to ObjectDataSource

  1. Bind WebGrid to Hierarchical ISDataSource control.
  2. Right click WebGrid instance and choose WebGrid.NET Designer.
  3. Enable the Editing - Batch Update features in WebGrid Component Designer.

  4. Create a DoInsert() method for each table which is used in the WebGrid and SelectIdentityQuery() function to retrieve the newly created ID, for example:
    C# Copy Code
    [DataObjectMethodAttribute(DataObjectMethodType.Insert, true)]
public int DoInsert(ref Nullable OrderID, string CustomerID, Nullable EmployeeID, Nullable OrderDate,Nullable RequiredDate, Nullable ShippedDate, Nullable ShipVia, Nullable Freight, string ShipName,string ShipAddress, string ShipCity, string ShipRegion, string ShipPostalCode, string ShipCountry)
{
   this.Connection.Open(); // important
   int affectedRows = this.Insert(CustomerID, EmployeeID, OrderDate, RequiredDate, ShippedDate, ShipVia,Freight, ShipName, ShipAddress, ShipCity, ShipRegion, ShipPostalCode, ShipCountry);
   int? identity = this.SelectIdentityQuery();
   OrderID = identity; // pass the new identity into OrderID param
   this.Connection.Close();
   return affectedRows;
}

public int SelectIdentityQuery()
{
   OleDbCommand cmd = new OleDbCommand("SELECT @@IDENTITY", this.Connection);
   int newID = (int)cmd.ExecuteScalar();
   return newID;
}

  5. Update the parameters in insert function in the ISDataSource for the ID parameter, set the Direction property to InputOutput. This parameter is required to reflect the parameter signature of DoInsert method.

  6. Click OK.
  7. You are all set. Run the page in browser.

See Also

Tasks
Walkthrough: Creating Updatable WebGrid using DataTable
Walkthrough: Creating Updatable Hierarchical WebGrid using DataSet
Walkthrough: Creating Updatable WebGrid using ObjectDataSource
Walkthrough: Creating Updatable WebGrid using Custom Object

Other Resources
Walkthrough Topics
How-to Topics


Walkthrough: Creating Updatable WebGrid using Custom Object

Walkthrough: Creating Updatable WebGrid using Custom Object
See Also Send Feedback

Glossary Item Box

This walkthrough shows you how to updatable WebGrid using custom object.

During this walkthrough, you will learn how to do the following:

  • Create custom object and bind it to WebGrid
  • Use SmartTag to set DataSource
  • Use DataSourceConfigurationWizard to set the database and table.

Prerequisites

In order to complete this walkthrough, you will need the following:

  • Access to the Microsoft Access Northwind database.
  • Visual Studio 2008 Application.

Step-By-Step Instructions

To create updatable WebGrid using custom object

  1. Launch Visual Studio.NET 2008.
  2. Click on File menu, then select New and click Web Site.
  3. Select ASP.NET Web Site in the Template box and set Location to HTTP.
  4. Named the Web Site and click OK.
  5. Create New Folder in App_Code folder (Please create App_Code folder if it doesn't exist yet.) and named it as GenericObject. We'll use GenericObject as the namespace for the class.
  6. Right-click on the GenericObject folder and select Add New Item from context menu.
  7. In Add New Item, choose Class from Visual Studio installed templates, select the language to be Visual C#, and named the class as Customers.cs.

  8. Write the following code inside the Customers.cs class.
    C# Copy Code
    using System;
using System.Data;
using System.Configuration;
using System.Web;
using System.Web.Security;
using System.Web.UI;
using System.Web.UI.WebControls;
using System.Web.UI.WebControls.WebParts;
using System.Web.UI.HtmlControls;
using ISNet.WebUI.DataSource;

namespace GenericObject
{
   public class Customer
   {
      #regionFields
      private string _customerID;
      private string _companyName;
      private string _contactName;
      private string _contactTitle;
      private string _address;
      private string _city;
      private string _region;
      private string _postalCode;
      private string _country;
      private string _phone;
      private string _fax;
      #endregion
      #regionProperties
      [PrimaryKey()]
      [Caption("Customer ID")]
      public string CustomerID
      {
         get { return this._customerID; }
         set { this._customerID = value; }
      }
      [Caption("Company Name")]
      public string CompanyName
      {
         get { return this._companyName; }
         set { this._companyName = value; }
      }
      [Caption("Contact Name")]
      public string ContactName
      {
         get { return this._contactName; }
         set { this._contactName = value; }
      }
      [Caption("Contact Title")]
      public string ContactTitle
      {
         get { return this._contactTitle; }
         set { this._contactTitle = value; }
      }
      public string Address
      {
         get { return this._address; }
         set { this._address = value; }
      }
      public string City
      {
         get { return this._city; }
         set { this._city = value; }
      }
      public string Region
      {
         get { return this._region; }
         set { this._region = value; }
      }
      [Caption("Postal Code")]
      public string PostalCode
      {
         get { return this._postalCode; }
         set { this._postalCode = value; }
      }
      public string Country
      {
         get { return this._country; }
         set { this._country = value; }
      }
      public string Phone
      {
         get { return this._phone; }
         set { this._phone = value; }
      }
      public string Fax
      {
         get { return this._fax; }
         set { this._fax = value; }
      }
      #endregion
      #regionConstructors
      public Customer()
      {

      }
      public Customer(string customerID)
      {
         this._customerID = customerID;
      }
      public Customer(string customerID, string companyName, string contactName, string contactTitle, string address,
          string city, string region, string postalCode, string country, string phone, string fax)
      {
         this._customerID = customerID;
         this._contactName = contactName;
         this._companyName = companyName;
         this._contactTitle = contactTitle;
         this._address = address;
         this._city = city;
         this._region = region;
         this._postalCode = postalCode;
         this._country = country;
         this._phone = phone;
         this._fax = fax;
      }
      #endregion
   }
}

  9. Right-click on the GenericObject folder and select Add New Item from context menu.
  10. In Add New Item, choose Class from Visual Studio installed templates, select the language to be Visual C#, and named the class as CustomerDataAccess.cs.
  11. Write the following code inside the CustomerDataAccess.cs class.
    C# Copy Code
    using System;
using System.Data;
using System.Configuration;
using System.Web;
using System.Web.Security;
using System.Web.UI;
using System.Web.UI.WebControls;
using System.Web.UI.WebControls.WebParts;
using System.Web.UI.HtmlControls;
using System.Data.OleDb;
using System.Collections.Generic;

namespace GenericObject
{
   [System.ComponentModel.DataObject]
   public class CustomerDataAccess
   {
      private OleDbConnection _connection;
      public OleDbConnection Connection
      {
         get
         {
            if (this._connection == null)
            {
               this._connection = new OleDbConnection();
               this._connection.ConnectionString = System.Configuration.ConfigurationManager.ConnectionStrings["NorthWindConnectionString"].ConnectionString;
            }
            return this._connection;
         }
      }
      public CustomerDataAccess()
      {
      }
       // using Generic Collection
       [System.ComponentModel.DataObjectMethodAttribute(System.ComponentModel.DataObjectMethodType.Select, true)]
       public List GetCustomers()
       {
          List customers = new List();
          try
          {
             this.Connection.Open();
             string cmdText = "SELECT " +
                      "CustomerID, CompanyName, ContactName, ContactTitle, Address, City, Region, " +
             "PostalCode, Country, Phone, Fax FROM Customers";
             OleDbCommand command = new OleDbCommand(cmdText, this.Connection);
             OleDbDataReader reader = command.ExecuteReader();
             while (reader.Read())
             {
                Customer customer = new Customer();
                customer.CustomerID = reader.GetString(0);
                customer.CompanyName = reader.GetString(1);
                customer.ContactName = reader.GetString(2);
                customer.ContactTitle = reader.GetString(3);
                customer.Address = reader.GetString(4);
                customer.City = reader.GetString(5);
                customer.Region = reader.IsDBNull(6) ? "" : reader.GetString(6);
                customer.PostalCode = reader.IsDBNull(7) ? "" : reader.GetString(7);
                customer.Country = reader.IsDBNull(8) ? "" : reader.GetString(8);
                customer.Phone = reader.IsDBNull(9) ? "" : reader.GetString(9);
                customer.Fax = reader.IsDBNull(10) ? "" : reader.GetString(10);
                customers.Add(customer);
             }
             return customers;
          }
          finally
          {
             this.Connection.Close();
          }
       }
       [System.ComponentModel.DataObjectMethodAttribute(System.ComponentModel.DataObjectMethodType.Update, true)]
       public int Update(Customer customer)
       {
          try
          {
             this.Connection.Open();
             string cmdText = @"UPDATE [Customers] SET " +
                   "[CompanyName] = @CompanyName, " +
                   "[ContactName] = @ContactName, [ContactTitle] = @ContactTitle, " +
                   "[Address] = @Address, [City] = @City, [Region] = @Region, " +
                   "[PostalCode] = @PostalCode, [Country] = @Country, [Phone] = @Phone, " +
                   "[Fax] = @Fax WHERE (([CustomerID] = @CustomerID))";
             OleDbCommand command = new OleDbCommand(cmdText, this.Connection);
             command.Parameters.Add(new OleDbParameter("@CompanyName", customer.CompanyName));
             command.Parameters.Add(new OleDbParameter("@ContactName", customer.ContactName));
             command.Parameters.Add(new OleDbParameter("@ContactTitle", customer.ContactTitle));
             command.Parameters.Add(new OleDbParameter("@Address", customer.Address));
             command.Parameters.Add(new OleDbParameter("@City", customer.City));
             command.Parameters.Add(new OleDbParameter("@Region", customer.Region));
             command.Parameters.Add(new OleDbParameter("@PostalCode", customer.PostalCode));
             command.Parameters.Add(new OleDbParameter("@Country", customer.Country));
             command.Parameters.Add(new OleDbParameter("@Phone", customer.Phone));
             command.Parameters.Add(new OleDbParameter("@Fax", customer.Fax));
             command.Parameters.Add(new OleDbParameter("@CustomerID", customer.CustomerID));
             return command.ExecuteNonQuery();
          }
          finally
          {
             this.Connection.Close();
          }
       }
       [System.ComponentModel.DataObjectMethodAttribute(System.ComponentModel.DataObjectMethodType.Delete, true)]
       public int Delete(Customer customer)
       {
          try
          {
             this.Connection.Open();
             string cmdText = "DELETE FROM [Customers] WHERE (([CustomerID] = @CustomerID))";
             OleDbCommand command = new OleDbCommand(cmdText, this.Connection);
             command.Parameters.Add(new OleDbParameter("@CustomerID", customer.CustomerID));
             return command.ExecuteNonQuery();
          }
          finally
          {
             this.Connection.Close();
          }
       }
       [System.ComponentModel.DataObjectMethodAttribute(System.ComponentModel.DataObjectMethodType.Insert, true)]       public int Insert(Customer customer)
       {
          try
          {
             this.Connection.Open();
             string cmdText = @"INSERT INTO [Customers] " +
                        "([CustomerID], [CompanyName], [ContactName], [ContactTitle], [Address], [City], [Region], [PostalCode], [Country], [Phone], [Fax]) " +
                        "VALUES (@CustomerID, @CompanyName, @ContactName, @ContactTitle, @Address, @City, @Region, @PostalCode, @Country, @Phone, @Fax)";
             OleDbCommand command = new OleDbCommand(cmdText, this.Connection);
             command.Parameters.Add(new OleDbParameter("@CustomerID", customer.CustomerID));
             command.Parameters.Add(new OleDbParameter("@CompanyName", customer.CompanyName));
             command.Parameters.Add(new OleDbParameter("@ContactName", customer.ContactName));
             command.Parameters.Add(new OleDbParameter("@ContactTitle", customer.ContactTitle));
             command.Parameters.Add(new OleDbParameter("@Address", customer.Address));
             command.Parameters.Add(new OleDbParameter("@City", customer.City));
             command.Parameters.Add(new OleDbParameter("@Region", customer.Region));
             command.Parameters.Add(new OleDbParameter("@PostalCode", customer.PostalCode));
             command.Parameters.Add(new OleDbParameter("@Country", customer.Country));
             command.Parameters.Add(new OleDbParameter("@Phone", customer.Phone));
             command.Parameters.Add(new OleDbParameter("@Fax", customer.Fax));
             return command.ExecuteNonQuery();
          }
          finally
          {
             this.Connection.Close();
          }
       }
   }
}

  12. Right-click on Project's name and select Add New Item.
  13. Select Intersoft AppForm in the My Templates box and named it as Walkthrough.aspx.
  14. Drag WebGrid instance from Toolbox to WebForm.
  15. In the design view of Walkthrough.aspx, click the SmartTag on the upper right of the WebGrid.
  16. In Choose Data Source field, choose <New data source...>.

  17. In Data Source Configuration Wizard, choose Object and click OK.

  18. Select GenericObject.CustomerDataAccess as the business object and then click Next.

  19. If the method for each select, update, insert, and delete operation is correct, click Finish.

  20. Choose Retrieve Structure in the Connected to Data Source Control wizard and click OK.

  21. Click WebGrid SmartTag on the upper right corner of WebGrid and check Allow Add New, Allow Editing, Allow Delete, Allow Column Sizing, and Allow Context Menu checkbox.

  22. In the Properties, set the width of the WebGrid to 100%.
  23. Run the project and the WebGrid should look like following.

See Also

Tasks
Walkthrough: Creating Updatable Hierarchical WebGrid using DataSet
Walkthrough: Creating Updatable WebGrid using DataTable
Walkthrough: Creating Updatable WebGrid using ObjectDataSource
Walkthrough: Creating Updatable Hierarchical WebGrid using ISDataSource

Other Resources
Walkthrough Topics
How-to Topics


Walkthrough: Adding pending changes to WebGrid programmatically

Walkthrough: Adding pending changes to WebGrid programmatically
See Also Send Feedback

Glossary Item Box

This walkthrough shows you how to create updatable WebGrid using DataTable in BatchUpdate mode (Insert Identity / AutoIncrement ID Scenario).

During this walkthrough, you will learn how to do the following:

  • Create Dataset

Prerequisites

In order to complete this walkthrough, you will need the following:

  • Access to the Microsoft Access Northwind database.
  • Visual Studio 2008 Application.

Step-By-Step Instructions

To create new web application and bind WebGrid to ObjectDataSource

  1. Launch Visual Studio.NET 2008.
  2. Click on File menu, then select New and click Web Site.
  3. Select ASP.NET Web Site in the Template box and set Location to HTTP.
  4. Named the Web Site and click OK.
  5. Right-click on Project's name and select Add New Item.
  6. Select Intersoft AppForm in the My Templates box and named it as Walkthrough.aspx.
  7. Drag WebGrid instance from ToolBar to WebForm.
  8. In the Solution Explorer, right-click on App_Data and select Add Existing Item.
  9. Browse and add NorthWind.mdb in C:\Program Files\Intersoft Solutions\Data (Default installation folder).
  10. Click the SmartTag on the upper right of the WebGrid.
  11. In Choose Data Source field, choose <New data source...>.

  12. In Data Source Configuration Wizard, choose AccessDatabase and click OK.

  13. Browse and select the database in App_Data (NorthWind.mdb) and click OK.

  14. Select the table that you want to use and click Next.

  15. Configure INSERT,UPDATE, and DELETE statements by clicking Advanced Button (Please check how to configure the INSERT,UPDATE and DELETE statements for another DataSourceControl).

  16. In this step, you can view the table's database using Test Query button. Otherwise, click Finish to proceed to the next step.
  17. Finally, choose Retrieve Structure action in Connected to Data Source Control Wizard and click OK to apply all settings.

  18. Go to LayoutSettings and set AllowEdit to Yes.
  19. Drag a html button and handle button click event include the snippet codes for adding pending changes programmatically.
  20. C# Copy Code
    function Button1_onclick()
{
   var grid = ISGetObject("WebGrid1");
   var row = grid.RootTable.GetRowByKeyValue("ALFKI");
   row.GetCells()[2].SetText("Maria", true);
   row.AddPendingChanges();
}

See Also

Tasks
How-to: Get pending changes based on row state
How-to: Get all pending changes in WebGrid
How-to: Get pending changes on specific table
How-to: Undo changes on specific row
How-to: Accept all changes

Other Resources
Walkthrough Topics
How-to Topics


Walkthrough: Configuring client-binding using ServerDataSource mode

Walkthrough: Configuring client-binding using ServerDataSource mode
See Also Send Feedback

Glossary Item Box

This walkthrough shows you how to configure updatable WebGrid bound to ServerDataSource.

During this walkthrough, you will learn how to do the following:

  • Use ISDataSource
  • Use WebGrid designer to define BindingOperationMode property in WebGrid.

Prerequisites

In order to complete this walkthrough, you will need the following:

  • Access to the Microsoft Access Northwind database.
  • Visual Studio 2008 Application.

Step-By-Step Instructions

To configure client binding using ServerDataSource mode

  1. Launch Visual Studio.NET 2008.
  2. Click on File menu, then select New and click Web Site.
  3. Select ASP.NET Web Site in the Template box and set Location to HTTP.
  4. Named the Web Site and click OK.
  5. Right-click on Project's name and select Add New Item.
  6. Select Intersoft AppForm in the My Templates box and named it as Walkthrough.aspx.
  7. Drag WebGrid and ISDataSource instances from ToolBar into WebForm.
  8. Click the SmartTag on the upper right of the ISDataSource and click Configure Data Source...

  9. Specifies the Schema Type and Schema Name that represent ISDataSource, and then click Next.

  10. Add TableName that represents ISDataSource, and choose Select, Update, Insert, and Delete for every table, and then press Finish.

  11. Set Data Source ID property from WebGrid's smart tag.

  12. Select a table view that will display as root table in WebGrid. And then select an action Retrieve Structure or if you use Hierarchical data structure you can choose Retrieve Hierarchical Structure.

  13. Choose WebGrid Designer link on WebGrid's smart tag to open WebGrid Designer.
  14. Choose Data Source (Advance) link on Quick Start and choose Client-side Binding (Advance) for data binding operation.

See Also

Tasks
Walkthrough: Configuring client-binding using WebService mode
Walkthrough: Configuring WebService client-binding to return paged data
Walkthrough: Configuring client-binding using AdoDataService mode

Other Resources
Client Binding API
Walkthrough Topics
How-to Topics


Walkthrough: Configuring client-binding using WebService mode

Walkthrough: Configuring client-binding using WebService mode
See Also Send Feedback

Glossary Item Box

This walkthrough shows you how to configure client binding using WebService mode.

During this walkthrough, you will learn how to do the following:

  • Create WebService
  • Bind WebService into WebGrid

Prerequisites

In order to complete this walkthrough, you will need the following:

  • Northwind.mdf.
  • Visual Studio 2008 Application.

Step-By-Step Instructions

To configure client binding using WebService mode

  1. Launch Visual Studio.NET 2008.
  2. Click on File menu, then select New and click Web Site.
  3. Select ASP.NET Web Site in the Template box and set Location to HTTP.
  4. Named the Web Site and click OK.
  5. In the Solution Explorer, right-click on App_Data and select Add Existing Item.
  6. Browse and add NorthWind.mdf in C:\Program Files\Intersoft Solutions\Data (Default installation folder).
  7. Add new page in App_Code and select Linq to Sql classes template. Named it Northwind.dbml.

  8. Drag Table Customer in Northwind.mdf from Server Explorer and set SerializationMode into Unidirectional.

  9. Right-click on Project's name and select Add New Item.
  10. Select Intersoft AppForm in the My Templates box and named it as Walkthrough.aspx.
  11. Drag WebGrid instance from ToolBar to WebForm.
  12. Set the properties based on the properties on aspx code below.
    <ISWebGrid:WebGrid ID="WebGrid1" runat="server" Height="250px" UseDefaultStyle="True"
    Width="500px" BindingOperationMode="ClientBinding">
    <RootTable>
        <Columns>
            <ISWebGrid:WebGridColumn Caption="CustomerID" DataMember="CustomerID" Name="CustomerID"
                Width="100px">
            </ISWebGrid:WebGridColumn>
            <ISWebGrid:WebGridColumn Caption="ContactTitle" DataMember="ContactTitle" Name="ContactTitle"
                Width="100px">
            </ISWebGrid:WebGridColumn>
        </Columns>
    </RootTable>
    <ClientBindingSettings DataSourceType="WebService" ServiceUrl="~/WebGrid/ClientBindingServiceEvents/WebService.asmx">
        <ServiceMethods SelectMethod="GetCustomers" />
    </ClientBindingSettings>
</ISWebGrid:WebGrid>

  13. Create at the WebService.asmx in the same level with your aspx name.

  14. Go to App_Code and add method GetCustomers in WebService.cs.

    C# Copy Image Copy Code
    [System.Web.Script.Services.ScriptService] )[WebMethod]
public List<customer> GetCustomers()
{
    NorthwindDataContext context = new NorthwindDataContext();
    context.DeferredLoadingEnabled = false;
    context.ObjectTrackingEnabled = false;
    return context.Customers.ToList();
}

  15. Save all the pages. Browse WebService.asmx to ensure that the service works then run Walkthrough.aspx

See Also

Tasks
Walkthrough: Configuring client-binding using ServerDataSource mode
Walkthrough: Configuring WebService client-binding to return paged data
Walkthrough: Configuring client-binding using AdoDataService mode

Other Resources
Client Binding API
Walkthrough Topics
How-to Topics


Walkthrough: Configuring WebService client-binding to return paged data

Walkthrough: Configuring WebService client-binding to return paged data
See Also Send Feedback

Glossary Item Box

This walkthrough shows you how to configure WebService on a client-binding WebGrid to return paged data.

During this walkthrough, you will learn how to do the following:

  • Create WebService data.
  • Bind a paged data WebService to a WebGrid using client binding

Prerequisites

In order to complete this walkthrough, you will need the following:

  • Access to BugTracker.mdf database.
  • Visual Studio 2008 Application.

Step-By-Step Instructions

To configure WebService client-binding to return paged data

  1. Launch Visual Studio.NET 2008.
  2. Click on File menu, then select New and click Web Site.
  3. Select ASP.NET Web Site in the Template box and set Location to HTTP.
  4. Named the Web Site and click OK.
  5. In the Solution Explorer, right-click on App_Data and select Add Existing Item.
  6. Browse and add BugTracker.mdf in C:\Program Files\Intersoft Solutions\WebUI Studio for ASP.NET\Data (Default installation folder).
  7. In the Solution Explorer, right-click on App_Code and select Add New Item.
  8. Create a new LINQ to SQL Class and named it BugTrackerModel.dbml.
  9. Drag and drop the Bugs table from the server explorer.

  10. Right-click on Project's name and select Add New Item.
  11. Select Web Service in the My Templates box and named it as WebService.asmx.
  12. Add a new WebMethod GetPagedBugs in the WebService.cs located in App_Code.

    C# Copy Code
    [WebMethod]
public object GetPagedBugs(DataSourceSelectArguments selectArguments)
{
   BugTrackerModelDataContext context = new BugTrackerModelDataContext();
   context.DeferredLoadingEnabled = false;
   var pagedData = context.Bugs.AsQueryable();

   // handle sorting
   if (!string.IsNullOrEmpty(selectArguments.SortExpression))
      pagedData = pagedData.OrderBy(selectArguments.SortExpression);

   // handle filtering
   if (!string.IsNullOrEmpty(selectArguments.FilterExpression))
      pagedData = pagedData.Where(selectArguments.GetLinqFilterExpression());

   if (selectArguments.OperationType == SelectOperation.SelectData)
   {
      // handle paging
      if (selectArguments.MaximumRows > 0)
         pagedData = pagedData.Skip(selectArguments.StartRowIndex).Take(selectArguments.MaximumRows - selectArguments.StartRowIndex);
         return pagedData.ToList();
   }
   else if (selectArguments.OperationType == SelectOperation.SelectCount)
      return pagedData.Count();
      throw new InvalidOperationException("Unsupported operation type!");
}

  13. Right-click on Project's name and select Add New Item.
  14. Select Intersoft AppForm in the My Templates box and named it as Walkthrough.aspx.
  15. Drag WebGrid instance from ToolBar to WebForm.
  16. Click the SmartTag on the upper right of the WebGrid and click the WebGrid.NET Designer link to open the Designer.
  17. In the Popular Setting page, set PagingMode to ClassicPaging and PagingSize to 15.

  18. On the Data Source (Advanced) page, use Client-side binding and connect to a WebService. Insert WebService.asmx to the service URL, Bug in the Item Type Name, and GetPagedBugs in the SelectMethod.

  19. Click OK.
  20. You are all set. Run the page in browser.

See Also

Tasks
Walkthrough: Configuring client-binding using ServerDataSource mode
Walkthrough: Configuring client-binding using WebService mode
Walkthrough: Configuring client-binding using AdoDataService mode

Other Resources
Walkthrough Topics
How-to Topics


Walkthrough: Configuring client-binding using AdoDataService mode

Walkthrough: Configuring client-binding using AdoDataService mode
See Also Send Feedback

Glossary Item Box

This walkthrough shows you how to WebGrid to client-binding using AdoDataService mode.

During this walkthrough, you will learn how to do the following:

  • Create and use AdoDataService mode.
  • Configure WebGrid to client-binding using AdoDataService mode

Prerequisites

In order to complete this walkthrough, you will need the following:

  • Access to the Microsoft Access Northwind database.
  • Visual Studio 2008 Application.

Step-By-Step Instructions

To configure client binding using AdoDataService mode

  1. Launch Visual Studio.NET 2008.
  2. Click on File menu, then select New and click Web Site.
  3. Select ASP.NET Web Site in the Template box and set Location to HTTP.
  4. Named the Web Site and click OK.
  5. In the Solution Explorer, right-click on App_Data and select Add Existing Item.
  6. Browse and add Northwind.mdf in C:\Program Files\Intersoft Solutions\WebUI Studio for ASP.NET\Data (Default installation folder).
  7. In the Solution Explorer, right-click on App_Code and select Add New Item.
  8. Create a new ADO.NET Entity Data Model and named it NorthwindDataModel.edmx. Pick generate the model from database, choose Northwind.mdf as the data source and named the entity as NorthwindEntities.

  9. On the next screen, choose Customers to include in your database model. Click Finish.
  10. In the Solution Explorer, right-click on the WebProject and select Add New Item.
  11. Create a new ADO.NET Data Service and named it NorthwindDataService.svc.
  12. Modify the NorthwindDataService.svc.cs to accept Customers and have full access.
    C# Copy Code
    using System;
using System.Collections.Generic;
using System.Data.Services;
using System.Linq;
using System.ServiceModel.Web;
using System.Web;
namespace WebApplicationWalkthrough2009
{
   [System.ServiceModel.ServiceBehavior(IncludeExceptionDetailInFaults = true)]
   public class NorthwindDataService : DataService<northwindentities>
   {
      // This method is called only once to initialize service-wide policies.
      public static void InitializeService(IDataServiceConfiguration config)
      {
         // TODO: set rules to indicate which entity sets and service operations are visible, updatable, etc.
         // Examples:
         // config.SetEntitySetAccessRule("MyEntityset", EntitySetRights.AllRead);
         // config.SetServiceOperationAccessRule("MyServiceOperation", ServiceOperationRights.All);

         config.SetEntitySetAccessRule("*", EntitySetRights.All);
         config.SetServiceOperationAccessRule("*", ServiceOperationRights.All);
         config.UseVerboseErrors = true;
      }
   }
}

  13. In the Solution Explorer, right click on the project and select Add New Item.
  14. Select Web Form in the Templates box and named it as Walkthrough.aspx.
  15. Open Walkthrough.aspx in Source view and change the doctype from

    <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml">
    Into the following
    <!DOCTYPE html PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN">
<html>
  16. Drag WebGrid instance from ToolBar to WebForm.
  17. Click the smart tag button on the upper right corner of WebGrid and then select WebGrid.NET Designer.
  18. Select Data Source (Advanced) from the left pane of Quick Start tab.
  19. On the specifies how WebGrid should perform data binding operation option, please select Client-side binding (Advanced).
  20. Select Connect to ADO.NET data service (Astoria) from Data source type option
  21. Set the Service Url to NorthwindDataService.svc.

  22. Click the Advanced tab and go to WebGrid - WebGrid1 > RootTable.
  23. Set DataKeyField to CustomerID and DataMember to Customers.
  24. Click the Advanced tab and go to WebGrid - WebGrid1 > RootTable > Columns.
  25. Click Add button from the right pane toolbar.
  26. Set Name, Caption, and DataMember to CustomerID.
  27. Repeat step number 26 and set the value of those properties to CompanyName; ContactName; ContactTitle; Address; City; Region; PostalCode; Country; Phone; and Fax.

  28. Run the project and the WebGrid should look like following.

See Also

Tasks
Walkthrough: Configuring client-binding using ServerDataSource mode
Walkthrough: Configuring client-binding using WebService mode
Walkthrough: Configuring WebService client-binding to return paged data

Other Resources
Client Binding API
Walkthrough Topics
How-to Topics


Walkthrough: Configuring client-binding using WcfService mode

Walkthrough: Configuring client-binding using WcfService mode
See Also Send Feedback

Glossary Item Box

This walkthrough shows you how to configure client binding using WcfService mode.

During this walkthrough, you will learn how to do the following:

  • Create WcfService
  • Bind WcfService into WebGrid

Prerequisites

In order to complete this walkthrough, you will need the following:

  • Northwind.mdf.
  • Visual Studio 2008 Application.

Step-By-Step Instructions

To configure client binding using WebService mode

  1. Launch Visual Studio.NET 2008.
  2. Click on File menu, then select New and click Web Site.
  3. Select ASP.NET Web Site in the Template box and set Location to HTTP.
  4. Named the Web Site and click OK.
  5. In the Solution Explorer, right-click on App_Data and select Add Existing Item.
  6. Browse and add NorthWind.mdf in C:\Program Files\Intersoft Solutions\Data (Default installation folder).
  7. Add new page in App_Code and select Linq to Sql classes template. Named it Northwind.dbml.

  8. Drag Table Customer in Northwind.mdf from Server Explorer and set SerializationMode into Unidirectional.

  9. Right-click on Project's name and select Add New Item.
  10. Select Intersoft AppForm in the My Templates box and named it as Walkthrough.aspx.
  11. Drag WebGrid instance from ToolBar to WebForm.
  12. Set the properties based on the properties on aspx code below.
    <ISWebGrid:WebGrid ID="WebGrid1" runat="server" Height="250px" UseDefaultStyle="True"
    Width="500px" BindingOperationMode="ClientBinding">
    <RootTable>
        <Columns>
            <ISWebGrid:WebGridColumn Caption="CustomerID" DataMember="CustomerID" Name="CustomerID"
                Width="100px">
            </ISWebGrid:WebGridColumn>
            <ISWebGrid:WebGridColumn Caption="ContactTitle" DataMember="ContactTitle" Name="ContactTitle"
                Width="100px">
            </ISWebGrid:WebGridColumn>
        </Columns>
    </RootTable>
    <ClientBindingSettings DataSourceType="WcfService" ServiceUrl="~/WebGrid/ClientBindingServiceEvents/WcfService.svc">
        <ServiceMethods SelectMethod="GetCustomers" />
    </ClientBindingSettings>
</ISWebGrid:WebGrid>

  13. Create at the WcfService.svc in the same level with your aspx name.

  14. Go to App_Code and add method GetCustomers in WcfService.cs.

    C# Copy Image Copy Code
    [System.Web.Script.Services.ScriptService] )[WebMethod]
public List<customer> GetCustomers()
{
    NorthwindDataContext context = new NorthwindDataContext();
    context.DeferredLoadingEnabled = false;
    context.ObjectTrackingEnabled = false;
    return context.Customers.ToList();
}

  15. Save all the pages. Browse WcfService.svc to ensure that the service works then run Walkthrough.aspx

See Also

Tasks
Walkthrough: Configuring client-binding using ServerDataSource mode
Walkthrough: Configuring client-binding using WebService mode

Other Resources
Walkthrough Topics
How-to Topics


How-to: Bind WebGrid after PostBack (Late Binding)

How-to: Bind WebGrid after PostBack (Late Binding)
See Also Send Feedback

Glossary Item Box

WebGrid provides feature to do binding after PostBack, which can be called Late Binding.

In this topic, you will learn the basic thing on how to implement Late Binding.

To Bind WebGrid after PostBack

  1. Drag Server Button to your WebForm.
  2. On ButtonClick event handler, add the following code:

    C# Copy Image Copy Code
    private void Button1_Click(object sender, System.EventArgs e)
{
      CurrentCountry = DropDownList1.SelectedValue;
      CurrentProfile = RadioButtonList1.SelectedValue;
      WebGrid1.ClearCachedDataSource();
      WebGrid1.RebindDataSource();
      WebGrid1.Visible = true;
}
  3. Double click on the WebForm to write Page_Load codes.

    C# Copy Image Copy Code
    private void Page_Load(object sender, System.EventArgs e)
{
        // Put user code to initialize the page here
        if (!IsPostBack)
        {
                OleDbDataAdapter da = new OleDbDataAdapter("select * from employees", oleDbConnection1);
                DataTable dt = new DataTable();
                da.Fill(dt);
                DropDownList2.DataSource = dt;
                DropDownList2.DataTextField = "FirstName";
                DropDownList2.DataValueField = "EmployeeID";
                DropDownList2.DataBind();
        }
        else
        {
                if (WebGrid1.FlyPostBackAction == PostBackAction.RefreshData)
                {
                        // simulate button click event when refresh icon is clicked
                        Button1_Click(null, null);
                }
        }
}
  4. Add the following code under the namespace:
    C# Copy Image Copy Code
    string[] Profile1_Root = {"CustomerID", "ContactTitle", "ContactName", "Country"};
string[] Profile2_Root = {"CustomerID", "Address", "CompanyName", "Phone"};

string[] Profile1_Child = {"OrderID", "OrderDate", "Freight"};
string[] Profile2_Child = {"OrderID", "EmployeeID", "RequiredDate"};

string CurrentProfile = null;
string CurrentCountry = null;

private DataSet GetCustomers(string Country, string Profile)
{
        if (Country == null)
        return null;

        OleDbDataAdapter da = new OleDbDataAdapter("select * from customers where country='" + Country + "'", oleDbConnection1);
        OleDbDataAdapter da2 = new OleDbDataAdapter("select o.* from orders o inner join customers c on o.customerid=c.customerid where c.country='" + Country + "'", oleDbConnection1);

        DataSet ds = new DataSet();
        DataTable dt1 = new DataTable("Customers");
        DataTable dt2 = new DataTable("Orders");

        da.Fill(dt1);
        da2.Fill(dt2);

        ds.Tables.Add(dt1);
        ds.Tables.Add(dt2);

        ds.Relations.Add(ds.Tables["Customers"].Columns["CustomerID"], ds.Tables["Orders"].Columns["CustomerID"]);

        CurrentProfile = Profile;
        return ds;
}

private void CreateStructure()
{
        string[] UseProfileRoot = null;
        string[] UseProfileChild = null;

        if (CurrentProfile == "Profile1")
        {
                UseProfileRoot = Profile1_Root;
                UseProfileChild = Profile1_Child;
        }
        else
        {
                UseProfileRoot = Profile2_Root;
                UseProfileChild = Profile2_Child;
        }

        WebGrid1.RootTable.Columns.Clear();
        WebGrid1.RootTable.ChildTables.Clear();
        WebGrid1.LayoutSettings.Hierarchical = true;

        WebGrid1.RootTable.DataMember = "Customers";
        WebGrid1.RootTable.DataKeyField = "CustomerID";
        foreach(string col in UseProfileRoot)
        {
                WebGrid1.RootTable.Columns.Add(new WebGridColumn(col, col, col));
        }

        WebGridTable childTable = new WebGridTable();
        childTable.DataMember = "Orders";
        childTable.DataKeyField = "OrderID";
        foreach(string col in UseProfileChild)
        {
                childTable.Columns.Add(new WebGridColumn(col, col, col));
        }

        WebGrid1.RootTable.ChildTables.Add(childTable);
}

private void FormatGrid()
{
        foreach (WebGridColumn col in WebGrid1.RootTable.Columns)
        {
                if (col.DataMember == "CustomerID")
                        col.CellStyle.HorizontalAlign = HorizontalAlign.Right;
        }

        foreach (WebGridColumn col in WebGrid1.GetTableByName("Orders").Columns)
        {
                if (col.DataMember == "OrderDate" || col.DataMember == "RequiredDate")
                {
                        col.DataFormatString = "d";
                }
                else
                {
                        col.CellStyle.HorizontalAlign = HorizontalAlign.Right;
                }
        }

        WebGrid1.LayoutSettings.AllowSorting = Sorting.Yes;
}
  5. Double click the WebGrid and add the following code under InitializeDataSource event handler.

    C# Copy Image Copy Code
    e.DataSource = GetCustomers(CurrentCountry, CurrentProfile);
  6. Then, it will automatically retrieve its structure by using RetrieveStructure() method in PrepareDataBinding event handler.

    C# Copy Image Copy Code
    if (IsPostBack)
{
        if (!WebGrid1.IsFlyPostBack)
        {
                CreateStructure();
        }
        FormatGrid();
}
  7. Add the following codes under InitializeTable event handler.

    C# Copy Image Copy Code
    private void WebGrid1_InitializeTable(object sender, ISNet.WebUI.WebGrid.TableEventArgs e)
{
        if (IsPostBack && !WebGrid1.IsFlyPostBack && e.Table.IsRootTable)
        {
                if (CheckBox1.Checked)
                {
                        // get customers rows where order's employeeid = selected value
                        OleDbDataAdapter da = new OleDbDataAdapter("select distinct customerid from orders where employeeid=" + DropDownList2.SelectedValue, oleDbConnection1);
                        DataTable dt = new DataTable();
                        da.Fill(dt);

                        foreach(WebGridRow row in WebGrid1.RootTable.Rows)
                        {
                                foreach(DataRow dr in dt.Rows)
                                {
                                        if (row.Cells.GetNamedItem("CustomerID").Text == dr["CustomerID"].ToString())
                                                row.ExpandChildRow();
                                }
                        }
                }
        }
}
  8. Compile and run the WebForm.

See Also

Tasks
Walkthrough: Binding WebGrid to a DataSource at RunTime
Walkthrough: Binding WebGrid to XML-based DataSource
Walkthrough: Binding WebGrid to IList DataSource
Walkthrough: Binding WebGrid with SQL Server 2000 Tables
Walkthrough: Binding WebGrid with a XSD schema and a XML file data

Other Resources
Walkthrough Topics
How-to Topics


How-to: Remove (+) sign for rows that do not contain child row

How-to: Remove (+) sign for rows that do not contain child row
See Also Send Feedback

Glossary Item Box

You can remove the (+) sign in rows that do not have any child rows.

In this topic, you will learn how to perform the above scenario.

To remove (+) sign for rows that contain no child row

  1. Add the following code under InitializeRow event handler.

    C# Copy Image Copy Code
    protected void WebGrid1_InitializeRow(object sender, ISNet.WebUI.WebGrid.RowEventArgs e)
{
  if (e.Row.GetChildTableRows(e.Row.Table.ChildTables[0]).Count == 0)
  e.Row.ChildNotExpandable = true;
}

  2. Compile and run the WebForm.

See Also

Tasks
How-to: Remove (+) sign for Self Reference LoadOnDemand rows that contain no Child Row

References
InitializeRow Event
GetChildTableRows Method
ChildNotExpandable Property

Other Resources
Walkthrough Topics
How-to Topics


How-to: Control WebGrid's styles using external CSS definition

How-to: Control WebGrid's styles using external CSS definition
See Also Send Feedback

Glossary Item Box

WebGrid.NET introduces several ways in maintaining the grid's appearance and styles. Generally, developer will enjoy using WebGrid.NET Designer to change the styles and create their own look&feel then save it to a layout file. The layout file can then be applied to other grid instances easily.

However, this technique doesn't seem to be preferred by web designers who want to control the styles of the grid in one single place and having the grid instances to share the same look&feel throughout the application. WebGrid.NET as well as other Intersoft's components share the same WebStyle class which allow you to use external CssClass instead of specifying the styles inline. All styles such as RowStyle, AlternateRowStyle are inherited from WebStyle thus exposing the CssClass property which you used to assign the CSS class name for that style

In this topic, you will learn the basic thing on how to control WebGrid's style using external CSS definition.

A few important notes to consider when using CssClass

  1. You can't use inline styles together with CssClass. That means when you used CssClass, you should remove all other styles attributes.
  2. The CSS class definition should be placed in the same page as the grid resides for the designer to render properly. You can use either <style> tag for page-level styles or use <link href=...> to link to external css stylesheet.
Following is the css class definitions sample which you can use in page-level (<style>) or insert it in an external linked css file:

HTML Copy Code
Sample of CSS Class definitions
.FrameStyle
{
    background:#F1EFE2;
}

.GroupByBox
{
        background:#808080;
}

.GroupByBoxLabel
{
        background:#FFFFFF;
        border-color:#000080;
        border-width:1px;
        border-style:solid;
        font-family:Verdana;
        font-size:8pt;
        font-weight:normal;
}

.Header
{
        background:#ECE9D8;
        border-color:#ACA899;
        border-width:1px;
        border-style:solid;
        font-family:Verdana;
        font-size:8pt;
        font-weight:normal;
        color:#000000;
        border-top-color: white;
        border-left-color: white;
}

.AltRow
{
        background:#FAEBD7;
        font-family:Verdana;
        font-size:8pt;
        font-weight:normal;
        text-overflow: ellipsis;
        overflow-x: hidden;
}

.Row
{
        background:#FFFFFF;
        font-family:Verdana;
        font-size:8pt;
        font-weight:normal;
        text-overflow: ellipsis;
        overflow-x: hidden;
}

.GroupRow
{
        background:#F1EFE2;
        border-color:#FFFFFF;
        border-width:1px;
        border-style:solid;
        font-family:Verdana;
        font-size:8pt;
        font-weight:normal;
        border-bottom-color: Silver;
        border-right-color: Silver;
}

.NewRow
{
        background:#FFFFFF;
        font-family:Verdana;
        font-size:8pt;
        font-weight:normal;
        color:#A9A9A9;
}

.StatusBar
{
        background:#ECE9D8;
        border-color:#ACA899;
        border-width:1px;
        border-style:solid;
        font-family:Verdana;
        font-size:8pt;
        font-weight:normal;
        padding:2px ;
}

.EditTextbox
{
        border-width:0px;
        border-style:none;
        font-family:Verdana;
        font-size:8pt;
        font-weight:normal;
}

Following is the modified LayoutSetting's styles which assign each style to appropriate class name. Note that all styles attributes is removed.

HTML Copy Code
LayoutSettings declaration codes

<NewRowStyle Cssclass=�?�NewRow�?�></NewRowstyle>
<EditTextboxStyle Cssclass=�?�EditTextBox�?�></EditTextboxstyle>
<alternatingRowStyle Cssclass=�?�AltRow�?�></AlternatingRowstyle>
<GroupRowInfoStyle Cssclass=�?�GroupRow�?�></GroupRowInfostyle>
<frameStyle Cssclass=�?�FrameStyle�?�></Framestyle>
<labelStyle Cssclass=�?�GroupByBoxLabel�?�></Labelstyle>
         <style Cssclass=�?�GroupByBox�?�>
         </style>
</GroupByBox>
<headerStyle Cssclass=�?�Header�?�></Headerstyle>
<RowStyle Cssclass=�?�Row�?�></Rowstyle>
<statusBarStyle Cssclass=�?�StatusBar�?�>
</StatusBarstyle>

See Also

Tasks
How-to: Position WebGrid relative to its container
How-to: Highlight the column header on mouse over

Concepts
Rich Styles

References
LayoutSet Class

Other Resources
Walkthrough Topics
How-to Topics


How-to: Position WebGrid relative to its container

How-to: Position WebGrid relative to its container
See Also Send Feedback

Glossary Item Box

You can associate WebGrid with a container, such as table or div. However, you need to configure a setting to display the WebGrid in a correct layout position.

This topic will show you how to place WebGrid inside a container where the edit object will be displayed in the current cell.

To position WebGrid inside a container

  1. Open WebGrid.NET Designer.
  2. Focus on Popular Settings and click see all properties.
  3. Set UseRelativePositioning to True.
  4. Click OK to apply the changes.
  5. Finally, WebGrid will be displayed relative to its container.

See Also

Tasks
How-to: Control WebGrid's styles using external CSS definition
How-to: Highlight the column header on mouse over

Concepts
Rich Styles

References
UseRelativePositioning Property

Other Resources
Walkthrough Topics
How-to Topics


How-to: Highlight the column header on mouse over

How-to: Highlight the column header on mouse over
See Also Send Feedback

Glossary Item Box

In this topic, you will learn how to manipulate the Column Header in order to respond with 'onmouseover' and 'onmouseout' client side events so that the Column Header will be highlighted at the bottom with different colors.

To highlight column header on mouse over

  1. Obtain grid's table column header element using GetElement() method at the client side.
  2. Attach 'onmouseover' as well as 'onmouseout' events using attachEvent() method.
  3. Provide codes for 'onmouseover' and 'onmouseout' js functions.

    JavaScript Copy Code
    function _wgGetTDElement(el)
{
  if (el == null) return null

  if (el.tagName == "TD") return wgGetColumnByElement(el);
  else if (el.tagName == "TABLE") return null; // can't find TD
  else {
    return _wgGetTDElement(el.parentElement);
  }
}

function start() {
// obtain WebGrid instance
var grid = ISGetObject("WebGrid1");

// obtain Column Header element of the grid
var table = grid.GetRootTable().GetElement(WG40.COLHEADER, WG40.HTMLTABLE);

// attach 'onmouseover' as well as 'onmouseout' events
// so that the appropriate functions will be invoked
// when certain mouse actions are performed
table.attachEvent("onmouseover", crm_over);
table.attachEvent("onmouseout", crm_out);
}

function crm_over() {
// retrieve the object that fired the event
var el = event.srcElement;
// obtain the grid's TD Element
var column = _wgGetTDElement(el);

var td = column.GetElement();
// override the borderBottom property at runtime
td.runtimeStyle.borderBottom = "orange 1px solid";
}

function crm_out() {
// retrieve the object that fired the event
var el = event.srcElement;
// obtain the grid's TD Element
var column = _wgGetTDElement(el);

var td = column.GetElement();
// override the borderBottom property at runtime
td.runtimeStyle.borderBottom = "darkgray 1px solid";
}

  4. Invoke the test function in <body MS_POSITIONING="GridLayout" onload="test">.
  5. Compile and run the WebForm.

See Also

Tasks
How-to: Control WebGrid's styles using external CSS definition
How-to: Position WebGrid relative to its container

Concepts
Rich Styles

Other Resources
Walkthrough Topics
How-to Topics


How-to: Perform Bulk Update on a Button Click event

How-to: Perform Bulk Update on a Button Click event
See Also Send Feedback

Glossary Item Box

In WebGrid, you can perform update to the Database after you have finished changes WebGrid's data.

In this topic, you will learn how to perform update to the Database using button click after modification through the WebGrid's data is done.

To perform Bulk Update

  1. Bind WebGrid to ISDataSource.
  2. Set WebGrid's AllowEdit, AllowDelete, AllowAddNew On the InitializeLayout server side event.
  3. Set ISDataSource's EnableCaching to Yes.

    C# Copy Code
    protected void WebGrid1_InitializeLayout(object sender, ISNet.WebUI.WebGrid.LayoutEventArgs e)
        {
            e.Layout.AllowEdit = ISNet.WebUI.WebGrid.Edit.Yes;
            e.Layout.AllowDelete = ISNet.WebUI.WebGrid.Delete.Yes;
            e.Layout.AllowAddNew = ISNet.WebUI.WebGrid.AddNew.Yes;
        }

  4. In the UpdateRow, AddRow, DeleteRow server side WebGrid event, set the return value to false so the record will be marked as dirty and will be updated later on.

    C# Copy Image Copy Code
        protected void WebGrid1_AddRow(object sender, ISNet.WebUI.WebGrid.RowEventArgs e)
        {
            e.ReturnValue = false;
        }

        protected void WebGrid1_DeleteRow(object sender, ISNet.WebUI.WebGrid.RowEventArgs e)
        {
            e.ReturnValue = false;
        }

        protected void WebGrid1_UpdateRow(object sender, ISNet.WebUI.WebGrid.RowEventArgs e)
        {
            e.ReturnValue = false;
        }

  5. Finally, put the following code in Button Click function to apply update from Database.

    C# Copy Code
        protected void Button1_Click(object sender, EventArgs e)
        {
            DataView view = this.ISDataSource1.Select("Customers") as DataView;
            NorthWind.CustomersDataTable table = view.Table as NorthWind.CustomersDataTable;
            table.AcceptChanges();
            NorthWindTableAdapters.CustomersTableAdapter da = new NorthWindTableAdapters.CustomersTableAdapter();
            da.Update(table);
        }

See Also

Tasks
Walkthrough: Using MultiLine TextBox
Walkthrough: Using CheckBox
Walkthrough: Using Calendar DropDown
Walkthrough: Using Calendar Combo
How-to: Use DropDownList as EditType of a WebGridColumn

References
AllowDelete Property
AllowEdit Property
AllowAddNew Property
InitializeLayout Event
AddRow Event
DeleteRow Event
UpdateRow Event
ButtonClick Event

Other Resources
Walkthrough Topics
How-to Topics


How-to: Autofit all columns in WebGrid

How-to: Autofit all columns in WebGrid
See Also Send Feedback

Glossary Item Box

WebGrid provides an AutoFit feature for all columns in WebGrid.

In this topic, you will learn how to apply AutoFit to all column in WebGrid.

To set AutoFit to all columns in WebGrid

  1. Open WebGrid.NET Designer.
  2. In Advanced-WebGrid-Layout Settings, set AutoFitColumns to true.

  3. Compile and run the WebForm.

See Also

Tasks
How-to: Set one of the columns as AutoWidth while the others fit the WebGrid

References
AutoFitColumns Property

Other Resources
Walkthrough Topics
How-to Topics


How-to: Set one of the columns as AutoWidth while the others fit the WebGrid

How-to: Set one of the columns as AutoWidth while the others fit the WebGrid
See Also Send Feedback

Glossary Item Box

WebGrid provides AutoFit and AutoWidth features for all columns in WebGrid.

In this topic, you will learn how to apply AutoWidth to one of the column and AutoFit to other columns in WebGrid.

To set AutoWidth to one column and AutoFit to other columns in WebGrid

  1. Open WebGrid.NET Designer.
  2. In Advanced-WebGrid-Layout Settings, set AutoFitColumns to true.

  3. In Advanced-RootTable-Columns-Address, select Is Auto Width Column.

  4. Compile and run the WebForm. You will see something like following.

See Also

Tasks
How-to: Autofit all columns in WebGrid

Concepts
Automatic Columns Fitting

References
AutoFitColumns Property
IsAutoWidth Property

Other Resources
Walkthrough Topics
How-to Topics


How-to: Set column's horizontal and vertical alignment

How-to: Set column's horizontal and vertical alignment
See Also Send Feedback

Glossary Item Box

WebGrid provides to set horizontal and vertical alignment for the column's in WebGrid.

In this topic, you will learn how to apply horizontal and vertical alignment in WebGrid.

To set AutoWidth to one column and AutoFit to other columns in WebGrid

  1. Open WebGrid.NET Designer.
  2. In Quick Start-User Interface-Miscellaneous section, set Default Row Height to 50px.
  3. In Advanced-RootTable-Columns-Address, set VerticalAlign to Top.
  4. In Advanced-RootTable-Columns-City, set HorizontalAlign to Right.
  5. In Advanced-RootTable-Columns-CompanyName, set HorizontalAlign to Right and VerticalAlign to Top.
  6. Compile and run the WebForm.

See Also

Tasks
How-to: Change the ForeColor of all odd rows
How-to: Change the ForeColor of a cell based on a specific condition
How-to: Set WebGrid cell and header as multiline and word wrap

Concepts
Automatic Style Merging

Other Resources
Walkthrough Topics
How-to Topics


How-to: Change the ForeColor of all odd rows

How-to: Change the ForeColor of all odd rows
See Also Send Feedback

Glossary Item Box

In WebGrid.NET the ForeColor can be changed programmatically in InitializeRow event handler.

In this topic, you will learn how to programmatically change the ForeColor of all odd rows in WebGrid.

To change the ForeColor of all odd rows in WebGrid

  1. Drag ASP.NET button to your WebForm.
  2. On InitializeRow event handler, put the following code:

    C# Copy Image Copy Code
    private void WebGrid1_InitializeRow(object sender, ISNet.WebUI.WebGrid.RowEventArgs e)
{
        int rowPosition = e.Row.Position;
        int rowIndexSelection = rowPosition%2;
        if(rowIndexSelection == 0)
        {
                e.Row.Style.ForeColor = Color.Red;
        }
}

  3. Compile and run the Project.

See Also

Tasks
How-to: Set column's horizontal and vertical alignment
How-to: Change the ForeColor of a cell based on a specific condition
How-to: Set WebGrid cell and header as multiline and word wrap

Concepts
Automatic Style Merging

Other Resources
Walkthrough Topics
How-to Topics


How-to: Change the ForeColor of a cell based on a specific condition

How-to: Change the ForeColor of a cell based on a specific condition
See Also Send Feedback

Glossary Item Box

In WebGrid.NET the ForeColor can be changed programmatically based on specific conditions.

In this topic, you will learn how to programmatically change the ForeColor of all rows that have UK as the Country.

To change the ForeColor of all rows that have UK as the Country

  1. Drag ASP.NET button to your WebForm.
  2. On InitializeRow event handler, put the following code:

    C# Copy Image Copy Code
    private void WebGrid1_InitializeRow(object sender, ISNet.WebUI.WebGrid.RowEventArgs e)
{
   string country = e.Row.Cells.GetNamedItem("Country").Text;

   if(country == "UK")
   {
     e.Row.Style.ForeColor = Color.Red;
   }
}

  3. Compile and run the Project.

See Also

Tasks
How-to: Set column's horizontal and vertical alignment
How-to: Change the ForeColor of all odd rows
How-to: Set WebGrid cell and header as multiline and word wrap

Concepts
Automatic Style Merging

Other Resources
Walkthrough Topics
How-to Topics


How-to: Set WebGrid cell and header as multiline and word wrap

How-to: Set WebGrid cell and header as multiline and word wrap
See Also Send Feedback

Glossary Item Box

In WebGrid.NET, you can set WebGridCell and Header as MultiLine and Word Wrap.

In this topic, you will learn how to set MultiLine and Word Wrap.

To set MultiLine and Word Wrap

  1. Open WebGrid.NET Designer.
  2. In Advanced-WebGrid-Layout Settings, set HeaderStyle-Height to Empty.
  3. Set the Advanced-WebGrid-LayoutSettings-RowHeightDefault to -1px.
  4. Go to Advanced-RootTable, then set Columns-CompanyName-AllowMultiline to True.
  5. Then set CellStyle-Wrap to True.
  6. And set HeaderStyle-Wrap to True.
  7. Compile and Run the project.

See Also

Tasks
How-to: Set column's horizontal and vertical alignment
How-to: Change the ForeColor of all odd rows
How-to: Change the ForeColor of a cell based on a specific condition

Concepts
Automatic Style Merging

References
WebGridCell Class
HeaderStyle Property
RowHeightDefault Property
AllowMultiLine Property
CellStyle Property
HeaderStyle Property

Other Resources
Walkthrough Topics
How-to Topics


How-to: Customize Filter context menu

How-to: Customize Filter context menu
See Also Send Feedback

Glossary Item Box

WebGrid provides a filtering feature which is very powerful to filter data based on several filter types, such as LIKE, BETWEEN, GREATER THAN and many others. If we do not want to show all the filter features we can customize it to the way we want.

In this topic, you will learn how to customize filter context menu.

To show only the "Not Set" and "Greater Than Or Equal"

Add function ChangeFilter as body onload function.

JavaScript Copy Image Copy Code
function ChangeFilter() {
   wg_Global.FilterType = new Array(["NotSet",0], ["GTET",1]);
}

These are the whole list of the available Filter Context Menu :

  1. ["NotSet", 0]
  2. ["GTET", 1]
  3. ["GT", 2]
  4. ["ET", 3]
  5. ["NET", 9]
  6. ["LTET", 4]
  7. ["LT", 5]
  8. ["Like", 6]
  9. ["NotLike", 11]
  10. ["Between", 7]
  11. ["NotBetween", 10]
  12. ["IsNull", 12]
  13. ["NotIsNull", 13]
  14. ["IsEmpty", 14]
  15. ["NotIsEmpty", 15]
  16. ["Contain ", 16]
  17. ["NotContain", 17]

See Also

Tasks
How-to: Add/Remove a menu in WebGrid's context menu
How-to: Add a SubMenu in WebGrid's context menu
How-to: Use WebContextMenu as WebGrid's context menu

Other Resources
Walkthrough Topics
How-to Topics


How-to: Add/Remove a menu in WebGrid's context menu

How-to: Add/Remove a menu in WebGrid's context menu
See Also Send Feedback

Glossary Item Box

When you right click on the WebGrid, a Context Menu will appear. Sometimes you need to add/remove the menus in the WebGrid's Context Menu.

In this topic, you will learn how to Add/Remove WebGrid's context menu.

To remove "Copy this row" from context menu

Add OnRowContextMenu client-side event:

JavaScript Copy Image Copy Code
function WebGrid1_OnRowContextMenu(controlId, rowType, rowElement, menuObject)
{
   menuObject.Items.GetNamedItem("mnuCopyRow").Hide();
   return true;
}

To add a menu to context menu

Add OnRowContextMenu client-side event:

JavaScript Copy Image Copy Code
function WebGrid1_OnRowContextMenu(controlId, rowType, rowElement, menuObject)
{
   var separator = new WebMenuItem();
   separator.Type = "Separator";
   separator.Name = "MySeparator";

   var menuItem = new WebMenuItem();
   menuItem.Text = "View Row's KeyValue";
   menuItem.Name = "MyMenu";
   menuItem.OnClick = "RowKeyValue";

   // Add Menu Separator and Menu Item
   menuObject.Items.Add(separator);
   menuObject.Items.Add(menuItem);
}

function RowKeyValue()
{
   var grid = ISGetObject("WebGrid1");
   var key = grid.GetSelectedObject().GetRowObject().KeyValue;
   alert(key);
}

See Also

Tasks
How-to: Customize Filter context menu
How-to: Add a SubMenu in WebGrid's context menu
How-to: Use WebContextMenu as WebGrid's context menu

Other Resources
Walkthrough Topics
How-to Topics


How-to: Add a SubMenu in WebGrid's context menu

How-to: Add a SubMenu in WebGrid's context menu
See Also Send Feedback

Glossary Item Box

Besides adding/removing a menu in WebGrid's ContextMenu, you can add a SubMenu in WebGrid's ContextMenu.

In this topic, you will learn how to add a SubMenu in WebGrid's context menu.

To add SubMenu in WebGrid's context menu

Add OnRowContextMenu client side event like following:

JavaScript Copy Image Copy Code
function WebGrid1_OnRowContextMenu(controlId, rowType, rowElement, menuObject)
{
    var menuItem1 = new WebMenuItem();
    menuItem1.Text = "Menu1";
    menuItem1.Name = "MyMenu1";
    menuItem1.OnClick = "OnClick";

    var menuItem2 = new WebMenuItem();
    menuItem2.Text = "Menu2";
    menuItem2.Name = "MyMenu2";
    menuItem2.OnClick = "OnClick";

    var menuItem3 = new WebMenuItem();
    menuItem3.Text = "Menu3";
    menuItem3.Name = "MyMenu3";
    menuItem3.OnClick = "OnClick";

    var separator = new WebMenuItem();
    separator.Type = "Separator"
    separator.Name = "MySeparator"

    var subItem1 = new WebMenuItem();
    subItem1.Text = "Sub 1";
    subItem1.Text = "MySub1";
    subItem1.OnClick = "OnClick";

    var subItem2 = new WebMenuItem();
    subItem2.Text = "Sub 2";
    subItem2.Text = "MySub2";
    subItem1.OnClick = "OnClick";

    menuItem1.Items.Add(subItem1);
    menuItem1.Items.Add(subItem2);

    menuObject.Items.Add(menuItem1);
    menuObject.Items.Add(menuItem2);
    menuObject.Items.Add(separator);
    menuObject.Items.Add(menuItem3);

    return true;
}

function OnClick(menuItem)
{
    // execute function for selected menuItem
    alert("Menu.Name : " + menuItem.Name + "\n" + "Menu.Text = " + menuItem.Text);
    return true;
}

See Also

Tasks
How-to: Customize Filter context menu
How-to: Add/Remove a menu in WebGrid's context menu
How-to: Use WebContextMenu as WebGrid's context menu

Other Resources
Walkthrough Topics
How-to Topics


How-to: Use WebContextMenu as WebGrid's context menu

How-to: Use WebContextMenu as WebGrid's context menu
See Also Send Feedback

Glossary Item Box

One of the advantages of Intersoft's components is compatibility among all of the components. Now, you will learn to use WebContextMenu from Intersoft's WebDesktop as WebGrid's context menu.

In this topic, you will learn how to use WebContextMenu as WebGrid's context menu.

To add WebContextMenu as WebGrid's context menu

WebContextMenu is part of WebDesktop so you need to have WebDesktop to implement this feature.

  1. Open WebContextMenu's properties and set ControlId to your WebGrid's Id (eg:WebGrid1).
  2. In Properties box, click the Items Collection button. It will bring you to the WebMenuItem Collection Editor box
  3. Click Add to add WebMenuItem

  5. Add OnRowContextMenu in WebGrid client side event

    JavaScript Copy Image Copy Code
    function WebGrid1_OnRowContextMenu(controlId, rowType, rowElement, menuObject) {
         return false;
}

See Also

Tasks
How-to: Customize Filter context menu
How-to: Add/Remove a menu in WebGrid's context menu
How-to: Add a SubMenu in WebGrid's context menu

Other Resources
Walkthrough Topics
How-to Topics


How-to: Display a ColumnSet layout hierarchically

How-to: Display a ColumnSet layout hierarchically
See Also Send Feedback

Glossary Item Box

WebGrid provides a ColumnSet feature which is helpful to show the WebGrid's information/data according to your needs.

In this topic, you will learn how to create ColumnSet in WebGrid Hierarchical mode.

To create a hierarchical ColumnSet

  1. Bind WebGrid to Hierarchical ISDataSource.
  2. Right click on WebGrid instance to open WebGrid.Net Designer.
  3. Go to Advanced tab >> RootTable.
  4. In RowLayout Expandable panel choose ColumnSet and Click Design ColumnSet button.
  5. Click "Add ColumnSet" (add a ColumnSet).
  6. Set focus to the ColumnSet and set the Caption to Customer Information.
  7. Set the ColumnSet's HeaderAlignment to Center.
  8. Click ColumnSet Designer and set like the picture below.

  10. Click OK.
  11. Set focus to ChildTables >> Orders >> ColumnSets.
  12. Click "Add ColumnSet" (add a ColumnSet).
  13. Set focus to the ColumnSet and set the Caption to Orders.
  14. Set the ColumnSet's HeaderAlignment to Center.
  15. Click ColumnSet Designer and set like the picture below.

  17. Click OK >> Apply >> OK.
  18. Finally, the WebGrid will look like the following snapshot:

See Also

References
ColumnSetSettings Class

Tasks
Walkthrough: Creating ColumnSet layout in WebGrid
Walkthrough: Configuring multiline row in ColumnSet layout

Other Resources
Walkthrough Topics
How-to Topics


Walkthrough: Using Column Types

Walkthrough: Using Column Types
See Also Send Feedback
Intersoft WebGrid > Getting Started > Samples and Walkthroughs > WebGrid Walkthroughs > Walkthrough: Using Column Types

Glossary Item Box

This walkthrough shows you how to use numerous column types available in WebGrid to display richer content data presentation.

During this walkthrough, you will learn how to do the following:

  • Use numerous column type like Text(default), Image, ImageAndText, CheckBox, Button and Custom.
  • Connect to a Microsoft Access database using Microsoft Jet 4.0 OLE DB Provider.
  • Use WebGrid's InitializeRow to set the row in WebGrid.

Prerequisites

In order to complete this walkthrough, you will need the following:

  • Access to the Microsoft Access Northwind database.
  • Visual Studio 2005/2008/2010 Application.

Step-By-Step Instructions

To create new web application and use numerous column types

  1. Bind WebGrid to AccesDataSource control.
  2. In WebGrid.NET Designer - Advanced tab, expand RootTable and select Columns.
  3. Add a new column and set its properties like following:

    Property | Value
    ColumnType | Button
    ButtonText | Edit
    Width | 50px
    Bound | False

  4. Add another new column and set its properties like following:

    Property | Value
    ColumnType | Image
    CellImage | /CommonLibrary/Images/Order-Details.gif
    Width | 20px
    Bound | False

  5. Add a new column and set its properties like following:

    Property | Value
    ColumnType | CheckBox
    Width | 20px
    Bound | False

  6. Add another new column and set its properties like following:

    Property | Value
    ColumnType | Custom
    Width | 150px
    Bound | False

  7. Now, select LayoutSettings node and set RowHeightDefault to 25px. Then, expand ButtonStyle node and set its properties like following:

    Property | Value
    BackColor | LighSteelBlue
    BorderColor | Navy
    BorderStyle | Solid
    BorderWidth | 1px

  8. Set WebGrid's width to 800px from its properties.
  9. Now, switch to HTML view and add OnInitializeRow="WebGrid1_InitRow" in the WebGrid tag.
  10. Switch back to code behind and add the following codes:

    C# Copy Image Copy Code
    protected void WebGrid1_InitRow(object sender ISNet.WebUI.WebGrid.RowEventArgs e)
{
  if (e.Row.Type == RowType.Record)
  {
    WebGridCellCollection cells = e.Row.Cells;
    cells.GetNamedItem("Custom").Text = "<b>Custom<b>";
  }
}

  11. Compile and run the WebForm. The WebGrid will look like following.

See Also

Tasks
Walkthrough: Utilizing button ColumnType
Walkthrough: Utilizing Various ColumnTypes
Walkthrough: Using CheckBox column in Hierarchical WebGrid
Walkthrough: Deleting a record using WebGrid button
Walkthrough: Configuring password as Column Type

Concepts
Column Types

Other Resources
Walkthrough Topics
How-to Topics


Walkthrough: Binding WebGrid to a DataSource at RunTime

Walkthrough: Binding WebGrid to a DataSource at RunTime
See Also Send Feedback

Glossary Item Box

This walkthrough shows you how to Bind WebGrid to a DataSource at RunTime.

During this walkthrough, you will learn how to do the following:

  • Connect to a Microsoft Access database using Microsoft Jet 4.0 OLE DB Provider.
  • Use OleDbDataAdapter to configure SQL Query and generate DataSet.
  • Set Web Application's environment and the DataSource.
  • Create DataSet.
  • Use WebGrid's InitializeDataSource event to bind the DataSet.
  • Use WebGrid's PrepareDataBinding event to retrieve structure in WebGrid.

Prerequisites

    In order to complete this walkthrough, you will need the following:

    • Access to the Microsoft Access Northwind database.
    • Visual Studio 2005 Application.

    Step-By-Step Instructions

    To Bind DataSource in WebGrid at RunTime.

    1. Launch Visual Studio.NET 2005.
    2. Click on File menu, then select New and click Project.
    3. Select Visual C# Project in Project Types.
    4. Select ASP.NET Web Application in the Template box.
    5. Specify the Project's Location and click OK.
    6. Drag WebGrid into WebForm.
    7. Add following DataSet inside the code-behind under the namespace then paste in the codes below:

      C# Copy Image Copy Code
      public DataSet LoadData()
{
  OleDbCommand cmd = oleDbConnection1.CreateCommand();
  cmd.CommandType = CommandType.Text;
  cmd.CommandText = "SELECT * FROM CUSTOMERS";

  OleDbDataAdapter da = newOleDbDataAdapter();
  da.SelectCommand = cmd;

  DataSet ds = new DataSet();
  da.Fill(ds);

  ds.Tables[0].TableName = "Customers";

  return ds;
}

    8. Double click the WebGrid and add following codes inside the InitializeDataSource event handler:

      C# Copy Image Copy Code
      e.DataSource = LoadData();

    9. Then, it will automatically retrieve its structure by using RetrieveStructure() method in PrepareDataBinding event handler:

      C# Copy Image Copy Code
      if(!IsPostBack)
{
  WebGrid1.RetrieveStructure();
}
    10. Compile and run the WebForm.

    See Also

    Tasks
    Walkthrough: Binding WebGrid to XML-based DataSource
    Walkthrough: Binding WebGrid to IList DataSource

    Other Resources
    Walkthrough Topics
    How-to Topics


Walkthrough: Binding WebGrid to XML-based DataSource

Walkthrough: Binding WebGrid to XML-based DataSource
See Also Send Feedback

Glossary Item Box

This walkthrough shows you how to create and bind an XMLDataSource to WebGrid.

During this walkthrough, you will learn how to do the following:

  • Use XMLDataSource.
  • Use SmartTag to set DataSource.
  • Use DataSourceConfigurationWizard to set the Database and table.

Prerequisites

In order to complete this walkthrough, you will need the following:

  • Access to the XML database.
  • Visual Studio 2005 Application.

Step-By-Step Instructions

To create new web application and bind WebGrid to XMLDataSource

  1. Launch Visual Studio.NET 2005.
  2. Click on File menu, then select New and click Web Site.
  3. Select ASP.NET Web Site in the Template box and set Location to HTTP.
  4. Named the Web Site and click OK.
  5. Right-click on Project's name and select Add New Item.
  6. Select Intersoft AppForm in the My Templates box and named it as Walkthrough.aspx.
  7. Drag WebGrid instance from ToolBar to WebForm.
  8. Click the SmartTag on the upper right of the WebGrid.
  9. In ChooseDataSource field, choose <New data source...>.

  10. In DataSourceConfigurationWizard, choose XML File and click next.

  11. Set the Data File and XPath expression then click OK.

  12. Then choose Retrieve Structure action in Connected to XMLData Source Control Wizard and clik OK.

  13. Run the project.

See Also

Tasks
Walkthrough: Binding WebGrid to IList DataSource
Walkthrough: Binding WebGrid with SQL Server 2000 Tables
Walkthrough: Binding WebGrid with a XSD schema and a XML file data

Other Resources
Walkthrough Topics
How-to Topics


Walkthrough: Binding WebGrid to IList DataSource

Walkthrough: Binding WebGrid to IList DataSource
See Also Send Feedback

Glossary Item Box

This walkthrough shows you how to bind IList DataSource to WebGrid.

During this walkthrough, you will learn how to do the following:

  • Connect to a Microsoft Access database using Microsoft Jet 4.0 OLE DB Provider.
  • Create new Class.
  • Use Page_Load event to add ArrayList, set DataSource, Retrieve Structure and DataBind.
  • Bind IList DataSource to WebGrid.

Prerequisites

In order to complete this walkthrough, you will need the following:

  • Access to the Microsoft Access Northwind database.
  • Visual Studio 2005 Application.

Step-By-Step Instructions

To Bind IList DataSource in WebGrid.

  1. Launch Visual Studio.NET 2005.
  2. Click on File menu, then select New and click Project.
  3. Select Visual C# Project in Project Types.
  4. Select ASP.NET Web Application in the Template box.
  5. Specify the Project's Location and click OK.
  6. Drag WebGrid into WebForm.
  7. Double click on the WebForm to write Page_Load codes:

    C# Copy Image Copy Code
    ArrayList aList = new ArrayList();
aList.Add( new Invoices(1, "INV-001", DateTime.Parse("2/1/2003"), "John Smith", 5, 750, 750 * 5) );
aList.Add( new Invoices(2, "INV-002", DateTime.Parse("2/2/2003"), "Steven Buchanan", 10, 450.7, 4507) );
aList.Add( new Invoices(3, "INV-003", DateTime.Parse("2/10/2003"), "Alexander King", 25, 700, 25 * 700) );
WebGrid1.DataSource = aList;
WebGrid1.RetrieveStructure();
WebGrid1.DataBind();

  8. Add following class inside the code-behind under the namespace or create a new class (.cs file), then paste in the codes below:

    C# Copy Image Copy Code
    public class Invoices
{
  private int mInvoiceId;
  private string mInvoiceNo;
  private DateTime mInvoiceDate;
  private string mCustomerName;
  private int mQty;
  private double mUnitPrice;
  private double mTotal;
  public Invoices (int InvoiceId, string InvoiceNo, DateTime InvoiceDate,
                    string CustomerName, int Qty, double UnitPrice, double Total)
  {
     this.mInvoiceId = InvoiceId;
     this.mInvoiceNo = InvoiceNo;
     this.mInvoiceDate = InvoiceDate;
     this.mCustomerName = CustomerName;
     this.mQty = Qty;
     this.mUnitPrice = UnitPrice;
     this.mTotal = Total;
  }
  public int InvoiceId
  {
     get { return this.mInvoiceId; }
  }
  public string InvoiceNo
  {
     get { return this.mInvoiceNo; }
  }
  public DateTime InvoiceDate
  {
     get { return this.mInvoiceDate; }
  }
  public string CustomerName
  {
     get { return this.mCustomerName; }
  }
  public int Qty
  {
     get { return this.mQty; }
  }
  public double UnitPrice
  {
     get { return this.mUnitPrice; }
  }
  public double Total
  {
     get { return this.mTotal; }
  }
}
  9. Now, open WebGrid Designer by right clicking WebGrid and choosing WebGrid.NET Designer. Select the Allow Sorting properties in QuickStart - Popular Settings - Main Features section.
  10. Compile and run the WebForm.

See Also

Tasks
Walkthrough: Binding WebGrid with SQL Server 2000 Tables
Walkthrough: Binding WebGrid with a XSD schema and a XML file data

Other Resources
Walkthrough Topics
How-to Topics


Walkthrough: Binding WebGrid with SQL Server 2000 Tables

Walkthrough: Binding WebGrid with SQL Server 2000 Tables
See Also Send Feedback

Glossary Item Box

This walkthrough shows you how to bind a SQL Server 2000 Tables to WebGrid.

During this walkthrough, you will learn how to do the following:

  • Connect to a Microsoft SQL Server 2000 database.
  • Set Web Application's environment and the DataSource.
  • Create SQL Server 2000 DataSet and relations between the table.
  • Use WebGrid's InitializeDataSource event to bind the DataSet.
  • Use WebGrid's PrepareDataBinding event to retrieve structure in WebGrid.

Prerequisites

In order to complete this walkthrough, you will need the following:

  • Access to the SQL Server 2000 database.
  • Visual Studio 2005 Application.

Step-By-Step Instructions

To Bind SQL Server 2000 Tables in WebGrid.

  1. Launch Visual Studio.NET 2005.
  2. Click on File menu, then select New and click Project.
  3. Select Visual C# Project in Project Types.
  4. Select ASP.NET Web Application in the Template box.
  5. Specify the Project's Location and click OK.
  6. Drag WebGrid into WebForm.
  7. Add following class inside the code-behind under the namespace then paste in the codes below:

    C# Copy Image Copy Code
    DataSet ds = new DataSet();

string connString = "workstation id=DEVELOPER2;packet size=4096;user id=sa;data source=DEVELOPER2;persist security info=False;initial catalog=Northwind";

SqlConnection conn = new SqlConnection(connString);

SqlDataAdapter daCustomers = new SqlDataAdapter();
string queryCustomers = "SELECT * FROM Customers";
daCustomers.SelectCommand = new SqlCommand(queryCustomers, conn);
daCustomers.Fill(ds, "Customers");

SqlDataAdapter daOrders = new SqlDataAdapter();
string queryOrders = "SELECT * FROM Orders";
daOrders.SelectCommand = new SqlCommand(queryOrders, conn);
daOrders.Fill(ds, "Orders");

SqlDataAdapter daOrderDetails = new SqlDataAdapter();
string queryOrderDetails = "SELECT * FROM [Order Details]";
daOrderDetails.SelectCommand = new SqlCommand(queryOrderDetails, conn);
daOrderDetails.Fill(ds, "Order_Details");

DataRelation drCusOrd = new DataRelation("CustOrd",
ds.Tables["Customers"].Columns["CustomerID"], ds.Tables["Orders"].Columns["CustomerID"] );

DataRelation drOrdOrdDetails = new DataRelation("OrdOrdDet",
ds.Tables["Orders"].Columns["OrderID"], ds.Tables["Order_Details"].Columns["OrderID"] );

ds.Relations.Add(drCusOrd);
ds.Relations.Add(drOrdOrdDetails);

return ds;
}

  8. Double click the WebGrid and add the following codes under InitializeDataSource event handler:

    C# Copy Image Copy Code
    e.DataSource = LoadData();
  9. Then, it will automatically retrieve its structure by using RetrieveStructure() method in PrepareDataBinding event handler:

    C# Copy Image Copy Code
    if(!IsPostBack)
{
  WebGrid1.RetrieveStructure();
}

  10. Compile and run the WebForm.

See Also

Tasks
Walkthrough: Binding WebGrid with a XSD schema and a XML file data
Walkthrough: Binding WebGrid to IList DataSource

Other Resources
Walkthrough Topics
How-to Topics


Walkthrough: Binding WebGrid with a XSD schema and a XML file data

Walkthrough: Binding WebGrid with a XSD schema and a XML file data
See Also Send Feedback

Glossary Item Box

This walkthrough shows you how to bind a XSD schema and a XML file data to WebGrid.

During this walkthrough, you will learn how to do the following:

  • Creating XSD schema into an XML file.
  • Read schema and load data from the XML file.
  • Use WebGrid's InitializeDataSource event to bind the DataSet.
  • Use WebGrid's PrepareDataBinding event to retrieve structure in WebGrid.

Prerequisites

In order to complete this walkthrough, you will need the following:

  • Access to the XML database.
  • Visual Studio 2005 Application.

Step-By-Step Instructions

To Bind WebGrid with a XSD schema and XML file data.

  1. Launch Visual Studio.NET 2005.
  2. Click on File menu, then select New and click Project.
  3. Select Visual C# Project in Project Types.
  4. Select ASP.NET Web Application in the Template box.
  5. Specify the Project's Location and click OK.
  6. Creating XSD schema into an XML file. Here is the sample schema code:

    XML Copy Image Copy Code
    <ltxs:schema id="dsCiti" targetNamespace="http://www.tempuri.org/dsCiti.xsd" xmlns:mstns="http://www.tempuri.org/dsCiti.xsd"
        xmlns="http://www.tempuri.org/dsCiti.xsd" xmlns:xs="http://www.w3.org/2001/XMLSchema" xmlns:msdata="urn:schemas-microsoft-com:xml-msdata"
        attributeFormDefault="qualified" elementFormDefault="qualified">
        <ltxs:element name="dsCiti" msdata:IsDataSet="true">
                <ltxs:complexType>
                        <ltxs:choice maxOccurs="unbounded">
                                <ltxs:element name="Total">
                                        <ltxs:complexType>
                                                <ltxs:sequence>
                                                        <ltxs:element name="ProfCode" type="xs:string" />
                                                        <ltxs:element name="ProfName" type="xs:string" minOccurs="0" />
                                                </xs:sequence>
                                        </xs:complexType>
                               </xs:element>
                               </xs:choice>
               </xs:complexType>
            <ltxs:unique name="Constraint1" msdata:PrimaryKey="true">
                    <ltxs:selector xpath=".//mstns:Level1" />
                    <ltxs:field xpath="mstns:Col1" />
            </xs:unique>
            <ltxs:keyref name="TotalLevel1" refer="mstns:Total_Constraint1">
                    <ltxs:selector xpath=".//mstns:Level1" />
                    <ltxs:field xpath="mstns:ProfCode" />
            </xs:keyref>
            <ltxs:key name="dsCitiKey1">
                    <ltxs:selector xpath=".//mstns:Level1" />
                    <ltxs:field xpath="mstns:Col1" />
                    <ltxs:field xpath="mstns:ProfCode" />
            </xs:key>
      </xs:element>
</xs:schema>
  7. Below is the sample for XML data:

    XML Copy Image Copy Code
    <?xml version="1.0" standalone="yes"?>
<ltdsCiti xmlns="http://www.tempuri.org/dsCiti.xsd">
  <ltTotal>
    <ltProfCode<gt23</Profcode>
    <ltProfName<gtTestProfile</ProfName>
    <ltDV01_1M<gt879335.26</DV01_1M>
  </Total>
</dsCity>
  8. Drag WebGrid into WebForm.
  9. Double click the WebGrid and add the following codes under InitializeDataSource event handler:

    C# Copy Image Copy Code
    XmlDataDocument xDoc;
private void WebGrid1_InitializeDataSource(object sender, ISNet.WebUI.WebGrid.DataSourceEventArgs e)
{
    xDoc = new XmlDataDocument();
    xDoc.DataSet.ReadXmlSchema(Server.MapPath("dsCiti.xml"));
    xDoc.Load(Server.MapPath("MyXML.xml"));
    e.DataSource = xDoc.DataSet;
}
  10. Then, it will automatically retrieve its structure by using RetrieveStructure() method in PrepareDataBinding event handler:

    C# Copy Image Copy Code
    if(!IsPostBack)
{
  WebGrid1.RetrieveStructure();
}
  11. Compile and run the WebForm.

See Also

Tasks
Walkthrough: Binding WebGrid to XML-based DataSource
Walkthrough: Binding WebGrid to IList DataSource
Walkthrough: Binding WebGrid with SQL Server 2000 Tables

Other Resources
Walkthrough Topics
How-to Topics


Walkthrough: Using client side events

Walkthrough: Using client side events
See Also Send Feedback

Glossary Item Box

This walkthrough shows you how to use the available client-side events to customize default client processing behavior.

During this walkthrough, you will learn how to do the following:

  • Connect to a Microsoft Access database using Microsoft Jet 4.0 OLE DB Provider.
  • Use OnRowSelect client side events to show the alert.

Prerequisites

In order to complete this walkthrough, you will need the following:

  • Access to the Microsoft Access Northwind database.
  • Visual Studio 2005 Application.

Step-By-Step Instructions

To create new web application and bind hierarchical WebGrid with DataSource

  1. Bind WebGrid to AccessDataSource.
  2. In LayoutSettings in IDE property window, expand ClientSideEvents.
  3. In OnRowSelect, open the dropdownlist and choose Add New Handler.
  4. Switch to HTML View and add the following function:

    JavaScript Copy Image Copy Code
    function DoRowSelect(gridId, tblName, rowIndex) {
    alert("The row index of selected row is : " + rowIndex);
    return true;
}

    The DoRowSelect function which is used to respond the RowSelect event has 3 parameters: gridId, tblName and rowIndex. You can do custom processing in the function and return true to process default behavior.

    WebGrid is built with complete client object model API that can be used to programmatically access or modify a behavior setting. You can get the instance of the WebGrid object in client by using: var gridObject = ISGetObject(gridName);

    The gridObject is the top most level object in the WebGrid client object model API. The gridObject contains Tables collection which contains Table object that defined in server side. Complete client side API documentation will be available in Intersoft's Developer Network.

  5. Compile and run the WebForm.

See Also

References
ClientEvents Class
OnRowSelect Property

Other Resources
Walkthrough Topics
How-to Topics


Walkthrough: Using Custom Aggregate function in WebGrid

Walkthrough: Using Custom Aggregate function in WebGrid
See Also Send Feedback

Glossary Item Box

WebGrid.NET introduces a powerful feature that is able to perform aggregation function on grouped rows as well as all rows totalling. The provided aggregation functions such as Count, Sum, Average, Min and Max are generally applicable to most application's requirements.

During this walkthrough, you will learn how to do the following:

  • Connect to a Microsoft Access database using Microsoft Jet 4.0 OLE DB Provider.
  • Use Custom Aggregate function in WebGrid.

Prerequisites

In order to complete this walkthrough, you will need the following:

  • Access to the Microsoft Access Northwind database.
  • Visual Studio 2005/2008/2010 Application.

Step-By-Step Instructions

To create new web application and use custom aggregate function

  1. Bind WebGrid to AccessDataSource.
  2. Open WebGrid.NET Designer-Advanced-WebGrid-LayoutSettings and set the ColumnFooters to Yes.

  3. Group a column by "ReorderLevel" column by using GroupColumns.

  4. Set the AggregateFunction to "Custom" and FooterText to "Count =" to the UnitsOnOrder column.

  5. Add custom aggregate code into the WebGrid1_CustomAggregate server side event.

    C# Copy Code
    if (e.Column.DataMember == "UnitsOnOrder")
{
   WebGridRowCollection rows = e.Rows;
   int count = 0;
   for (int i=0; i < rows.Count; i++)
   {
      WebGridCell cell = rows[i].Cells[e.Column.Position];
      if (int.Parse( cell.Value.ToString() ) > 0) count++;
   }
   e.AggregateResult = count;
}

  6. Compile and run the WebForm.

See Also

Tasks
Walkthrough: Displaying GroupTotal of child table
How-to: Use avg aggregate in group header

References
CustomAggregateArgs Class
CustomAggregate Event

Other Resources
Walkthrough Topics
How-to Topics


Walkthrough: Using Group Intervals in WebGrid

Walkthrough: Using Group Intervals in WebGrid
See Also Send Feedback

Glossary Item Box

The built-in Grouping capability in WebGrid.NET Professional has been one of its key successor, which automatically handles rows grouping based on specified Columns' value. The Enterprise edition extends this feature by allowing the grouping to be performed on different Group Interval, instead of the Column's Value. There are about 8 new Group Interval modes that you can apply to the GroupColumn such as Text, Alphabetical, Date, Month, ShortTime and so on. As always, you can apply these GroupIntervals visually in the designer and doesn't require you to write any codes in order to make it work. This greatly increases your application's value by delivering better grouping capability to end users while saving development time with its easy to use designer.

During this walkthrough, you will learn how to do the following:

  • Connect to a Microsoft Access database using Microsoft Jet 4.0 OLE DB Provider.
  • Use Group Intervals function in WebGrid.

Prerequisites

In order to complete this walkthrough, you will need the following:

  • Access to the Microsoft Access Northwind database.
  • Visual Studio 2005 Application.

Step-By-Step Instructions

  1. Binding WebGrid to AccessDataSource.
  2. Configure the 'OrderDate' column.
    The "OrderDate" column should be configured with "GroupRowInfoFormat" property value to [caption]: Year [value]. The "Caption" property will take the value from the name of the column which is "OrderDate". The "Value" property will take the value from the GroupRow value.
  3. Configure the 'CustomerID' GroupColumn.
    This GroupColumn is configured with 'Alphabetical' GroupInterval. With this configurations, the GroupRow will be shown like : CustomerID : A, CustomerID : B, CustomerID : C etc, according to the alphabetical order.

    This GroupColumn is also configured 'Expanded' GroupMode. When the page is loaded, this GroupColumn is expanded by this configuration.

    The most important configuration is the ColumnMember property. The ColumnMember property should be set to "CustomerID".

    Additional setting is the SortOrder property. The SortOrder can be configured with 'Ascending' or 'Descending'.
  4. Configure the 'OrderDate' GroupColumn.
    Additional GroupColumn can be added to the WebGridGroup collection. Here we are adding another WebGridGroup object which is configured with 'OrderDate' value for the ColumnMember property.

    Configure also the GroupInterval property to 'Year' so that the data will be grouped based on the year. The SortOrder property should be configured also the 'Ascending'

  5. Configure the below settings at the Advanced-WebGrid-LayoutSettings section:

    Property | Value | Description
    GridLineStyle | Solid | Define the style for the gridline
    PagingMode | VirtualLoad | Configure the grid to utilize 'VirtualLoad' PagingMode
    AutoWidth | True | Configure the grid to resize its width automatically according to the browser window
    CellPaddingDefault | 2 | Define the default cell padding
    RowHeightDefault | 20px | Define the default row height
    AlternatingColors | True | Configure the grid to use different color for the AlternatingRow
    GridLineColor | 236, 233, 216 | Define the color for the gridline
    AutoHeight | True | Configure the grid to resize its height automatically according to the browser window
    HideColumnsWhenGrouped | No | Configure the grid to still display the column which has been used in the GroupColumn

See Also

References
GroupInterval Property
GroupRowValueFormatString Property
ColumnMember Property

Other Resources
Walkthrough Topics
How-to Topics


Walkthrough: Integrating WebCombo in WebGrid

Walkthrough: Integrating WebCombo in WebGrid
See Also Send Feedback

Glossary Item Box

This walkthrough shows you how to integrate a WebCombo into WebGrid.

During this walkthrough, you will learn how to do the following:

  • Bind grid using AccessDatasource
  • Including the combo into certain WebGrid cells by setting the EditType and WebComboID properties.

Prerequisites

In order to complete this walkthrough, you will need the following:

  • Visual Studio 2005/2008/2010 Application.

Step-By-Step Instructions

To create new web application and integrate WebCombo into a WebGrid.

  1. Bind WebGrid and WebCombo to ISDataSource control.
    In this sample, WebGrid1 is bound to Products table, wcSuppliers to Suppliers table, and wcCategories to Categories table.
  2. Open designer then in by right clicking the WebGrid then choose WebGrid Designer.
  3. Set AllowEdit property to True.
  4. Go to Advanced >> RootTable >> Columns.
  5. Go to CategoryID and set the Edit Control Type to WebComboNET and select the WebCombo instance.
  6. Set the WebValueList for SupplierID and CategoryID columns.

See Also

Tasks
How-to: Integrate Linked WebCombo in WebGrid

Concepts
Intersoft WebCombo.NET Integration

References
AllowEdit Property
EditType Property
WebValueList Class

Other Resources
Walkthrough Topics
How-to Topics


Walkthrough: Applying custom sorting in WebGrid

Walkthrough: Applying custom sorting in WebGrid
See Also Send Feedback

Glossary Item Box

This walkthrough shows you how to apply CustomSort in WebGrid.

During this walkthrough, you will learn how to do the following :

  • Bind WebGrid to AccessDataSource
  • Create a CustomSort in WebGrid's CustomSort server side event.
  • Column's CustomerID will be sorted base on Column's ContactName

Prerequisites

In order to complete this walkthrough, you will need the following:

  • Access to the Microsoft Access Northwind database.
  • Visual Studio 2005 Application.

Step-By-Step Instructions

To create new web application and set CustomSort server side event.

  1. Bind WebGrid to AccessDataSource.
  2. Enable AllowEdit.
  3. Set Automatic Sort to false. You can find this property in WebGrid.NET Designer >> Advanced tab >> RootTable >> See all properties.
  4. In the CustomSort server side event of the WebGrid.

    C# Copy Code
    WebGridGroup sortCol;
sortCol = e.SortColumns.GetNamedItem("ContactName");

WebGridGroup oldSortCol;
oldSortCol = e.SortColumns.GetNamedItem("CustomerID");

if (oldSortCol != null)
{
   sortCol = new WebGridGroup();
   sortCol.Table = oldSortCol.Table;
   sortCol.ColumnMember = "ContactName";

   if (e.SortColumns.GetNamedItem("CustomerID").SortOrder == SortOrder.Ascending)
   {
      sortCol.SortOrder = SortOrder.Ascending;
   }
   else if (e.SortColumns.GetNamedItem("CustomerID").SortOrder == SortOrder.Descending)
   {
      sortCol.SortOrder = SortOrder.Descending;
   }

   e.SortColumns.Remove(oldSortCol); e.SortColumns.Add(sortCol);
}
  5. Please note to "using ISNet.WebUI.WebGrid"

See Also

Tasks
Walkthrough: Applying custom filtering in WebGrid
How-to: Perform sorting data and apply multiple sorting in WebGrid

References
WebGridGroup Class
SortOrder Property
CustomSort Event

Other Resources
Walkthrough Topics
How-to Topics


Walkthrough: Adding RowChecker in GroupRow

Walkthrough: Adding RowChecker in GroupRow
See Also Send Feedback

Glossary Item Box

This walkthrough shows you how to Add RowChecker column in GroupRow. If you expand a child row and click a RowChecker, all of the expanded rows will be checked.

During this walkthrough, you will learn how to do the following :

  • Add a new column and set the column to RowChecker.
  • Attach an event to CheckBox.

Prerequisites

In order to complete this walkthrough, you will need the following:

  • Access to the Microsoft Access Northwind database.
  • Visual Studio 2005 Application.

Step-By-Step Instructions

To add RowChecker in GroupRow.

  1. Add RowChecker column in WebGrid.
  2. Invoke OnGroupColumn client side event.

    JavaScript Copy Code
    function OnColumnGroup()
    {
        window.setTimeout(function() {ChangeRowCheckerBehaviour();}, 1000);
    }

  3. Create a function called ChangeRowCheckerBehaviour().

    JavaScript Copy Code
    function ChangeRowCheckerBehaviour()
    {
          var grid = ISGetObject("WebGrid1");
          var index = grid.RootTable.GroupedColumns.length;

          var headerColumns = grid.RootTable.GetElement(WG40.COLHEADERGROUP, WG40.HTMLTABLE).childNodes[0];
          var headerRowCheckerColumn = headerColumns.childNodes[index + 1];
          var checkboxRowChecker = headerRowCheckerColumn.childNodes[0].childNodes[0];
          Listener.Unload(checkboxRowChecker);
          Listener.Add(checkboxRowChecker, "onclick", function() {SelectiveCheckBoxHeaderClick(checkboxRowChecker);} );
    }

  4. Create a function called SelectiveCheckBoxHeaderClick(el).

    JavaScript Copy Code
    function SelectiveCheckBoxHeaderClick(el)
    {
          var grid = ISGetObject("WebGrid1");
          var gridBody = grid.RootTable.GetElement(WG40.BODY, WG40.HTMLTABLE);

          var groupIndex = -1;
          var expanded = false;

          for (i = 1 ; i < gridBody.childNodes.length ; i++)
          {
                 var rowEl = gridBody.childNodes[i].childNodes[0];

                 if (rowEl.type == "GroupHeader")
                 {
                      if (rowEl.expanded == "True")
                      {
                           groupIndex = rowEl.groupIndex;
                           expanded = true;
                      }
                      else
                           expanded = false;
                      }
                  else if (rowEl.type == "Record")
                  {
                      if (expanded && rowEl.parentGroupIndex == groupIndex)
                      {
                            var row = wgGetRowByElement(rowEl);
                             if (el.checked)
                                 row.Check();
                             else
                                 row.Uncheck();
                       }
                  }
          }
    }

See Also

Tasks
Walkthrough: Adding RowChecker column in WebGrid
How-to: Persist row checker during PostBack
How-to: Get checked rows in server side
How-to: Get checked rows in client side

Other Resources
Walkthrough Topics
How-to Topics


Walkthrough: Utilizing button ColumnType

Walkthrough: Utilizing button ColumnType
See Also Send Feedback

Glossary Item Box

Configure one column of WebGrid as a button column to perform some client-side task.

During this walkthrough, you will learn how to do the following:

  • Configure one column of WebGrid as a button column.
  • Use WebGrid's InitializeRow event to set the button conditions.
  • Use Button_Click event to show alert.

Prerequisites

In order to complete this walkthrough, you will need the following:

  • Visual Studio 2005 Application.

Step-By-Step Instructions

To configure one column as button

  1. Binding WebGrid to AccessDataSource.
  2. Open WebGrid.NET Designer, select WebGrid > RootTable > Columns from the TreeView and add a column.
  3. Set the ColumnType property of the new column to Button and the EditType property to NoEdit. You might also want to set the ButtonText and Caption properties.

    Property | Value
    Name | colBtn
    Caption | Button Column
    ColumnType | Button
    ButtonText | GetCustomerID

  4. Apply the following script to the page:

    C# Copy Image Copy Code
    function DoClick(ID)
{
    alert("CustomerID = " + ID);
    return true;
}

  5. Apply this code into the InitializeRow event. Please see the comments for explanation.

    C# Copy Image Copy Code
    private void WebGrid1_InitializeRow(object sender,
ISNet.WebUI.WebGrid.RowEventArgs e)
{
    if(e.Row.Type == RowType.Record)
    {
        // Get the row cells.
        WebGridCellCollection cells = e.Row.Cells;
        string customerID = cells.GetNamedItem("CustomerID").Text;

        // Construct the custom object attribute to be attached to the button.
        string customObjectAttributes =
            " onclick = \"DoClick(CustomerID)\"" +
            " CustomerID = \"" + customerID + "\"";

        string country = cells.GetNamedItem("Country").Text;

        // Set the ColumnType of the cell as text if the
        // Country cell's content is 'UK'.
        if(country == "UK")
        {
            cells.GetNamedItem("colBtn").Column.ColumnType = ColumnType.Text;
            cells.GetNamedItem("colBtn").Text = "Not Editable";
        }
        else
        {
            cells.GetNamedItem("colBtn").Column.ColumnType = ColumnType.Button;
            cells.GetNamedItem("colBtn").Column.ButtonText = "Get CustomerID";
        }

        // Attach the custom object attribute to the button cell of the row.
        cells.GetNamedItem("colBtn").CustomObjectAttributes =
            customObjectAttributes;
    }
}

  6. Run the sample.

See Also

Tasks
Walkthrough: Utilizing various ColumnTypes
Walkthrough: Using CheckBox column in Hierarchical WebGrid
Walkthrough: Deleting a record using WebGrid button
Walkthrough: Configuring password as ColumnType

Concepts
Column Types

References
ColumnType Property
InitializeLayout Event
OnButtonClick Property

Other Resources
Walkthrough Topics
How-to Topics


Walkthrough: Utilizing various ColumnTypes

Walkthrough: Utilizing various ColumnTypes
See Also Send Feedback

Glossary Item Box

In some scenarios, multiple column types for different purpose are required to achieve better user-experience.

During this walkthrough, you will learn how to do the following:

  • Create columns which are most suited its objective using our rich ColumnType and EditType.
  • Use JavaScript to show alert.

Prerequisites

In order to complete this walkthrough, you will need the following:

  • Visual Studio 2005 Application.

Step-By-Step Instructions

To create columns using our rich ColumnType and EditType

  1. Binding WebGrid to Hierarchical ISDataSource.
  2. Set the ValueList from column properties:

  3. Add this javaScript function which will later be used when the column colBtn is clicked.

    JavaScript Copy Image Copy Code
    <script language="javascript">
        function DoClick(ID)
        {
                alert("ProductID = " + ID);
                return true;
        }
</script>

  4. In the InitializeRow event of the grid, you put codes to set the value for column colCustom whose ColumnType is set to Custom , other than that you also add CustomObjectAttributes for column colBtn which when clicked will execute the javaScript function which has been declared above. You also set the HyperlinkFormatString property for column ProductID.

    C# Copy Code
    private void WebGrid1_InitializeRow(object sender, ISNet.WebUI.WebGrid.RowEventArgs e)
{
        if(e.Row.Type == RowType.Record)
        {
                string productID = e.Row.Cells.GetNamedItem("ProductID").Text;
                string categoryID = e.Row.Cells.GetNamedItem("CategoryID").Text;
                string customText = "" + productID + " " + categoryID +"";

                // obtain the cells collection of the current row
                WebGridCellCollection cells = e.Row.Cells;

                // assigns custom text
                cells.GetNamedItem("colCustom").Text = customText;

                // prepare CustomObjectAttributes text
                // of button type column
                // by invoking DoClick() at the client side
                // along with the CustomerID
                string customObjectAttributes =
                        " onclick = \"DoClick(ProductID)\"" +
                        " ProductID = \"" + productID + "\"";

                // attach the CustomObjectAttributes to the button
                // type column
                cells.GetNamedItem("colBtn").CustomObjectAttributes =
                        customObjectAttributes;

                int discontinued = Convert.ToInt16(cells.GetNamedItem("Discontinued").Value);

                // the objective is to make button invisible
                // if the 'Customer' is from 'UK'

                if(discontinued == 1)
                {
                        // Configure the column type to be ordinary text
                        // instead of button type column
                        cells.GetNamedItem("colBtn").Column.ColumnType = ColumnType.Text;
                        cells.GetNamedItem("colBtn").Text = "Not Editable";
                }
                else
                {
                        cells.GetNamedItem("colBtn").Column.ColumnType = ColumnType.Button;
                        cells.GetNamedItem("colBtn").Column.ButtonText = "Get ProductID";
                }

                string hypFormatString = "NewPage.aspx?ProductID='" + e.Row.Cells.GetNamedItem("ProductID").Text + "'&&CategoryID='" +
                e.Row.Cells.GetNamedItem("CategoryID").Text + "'";
                e.Row.Cells.GetNamedItem("ProductID").Column.HyperlinkFormatString = hypFormatString;
                e.Row.Cells.GetNamedItem("ProductID").Column.HyperlinkTarget = HyperlinkTarget.Blank;
        }
}

See Also

Tasks
Walkthrough: Utilizing button ColumnType
Walkthrough: Using CheckBox column in Hierarchical WebGrid
Walkthrough: Deleting a record using WebGrid button
Walkthrough: Configuring password as ColumnType

Concepts
Column Types

References
InitializeRow Event
ColumnType Property
EditType Property
ValueList Property

Other Resources
Walkthrough Topics
How-to Topics


Walkthrough: Using CheckBox column in Hierarchical WebGrid

Walkthrough: Using CheckBox column in Hierarchical WebGrid
See Also Send Feedback

Glossary Item Box

Mark all the child rows as checked if the CheckBox in the owning parent row is checked. This task is done by using client-side script.

During this walkthrough, you will learn how to do the following:

  • Using CheckBox column in hierarichal WebGrid.
  • Use WebGrid's InitializeRow to set the row conditions.
  • Using Client Side events.

Prerequisites

In order to complete this walkthrough, you will need the following:

  • Visual Studio 2005 Application.

Step-By-Step Instructions

To create new application and mark all the child rows

  1. Binding WebGrid to Hierarchical ISDataSource.
  2. Create a hierarchical grid with one column of each table is set to CheckBox column type and name the columns as 'CheckBoxColumn'.
  3. Attach the 'onclick' attributes to the parent CheckBox column in InitializeRow event.

    C# Copy Code
    private void WebGrid1_InitializeRow(object sender,
ISNet.WebUI.WebGrid.RowEventArgs e)
{
    if (e.Row.Table.DataMember == "Customers")
    {
        e.Row.Cells.GetNamedItem("CheckBoxColumn").CustomObjectAttributes =
            "onclick='doChecking(this)'";
    }
}

  4. Apply the following script to the page:

    JavaScript Copy Code

var row = null;
var IsExpandedByCheck = false;

function doChecking(obj)
{
    var grid = ISGetObject("WebGrid1");
    row = grid.GetSelectedObject().GetRowObject();
    // expand the row if it's not yet expanded
    if (!row.ChildExpanded)
    {
        IsExpandedByCheck = true;
        row.ExpandChildRow();
    }
    else
    {
        // if it's already expanded..
        MarkChildRows(row, obj.checked);
    }
}

// mark the child rows after being expanded
function WebGrid1_OnAfterResponseProcess(gridId, action, lastRO, xmlRO) {
    if (action == "LoadChild" && IsExpandedByCheck) {
        MarkChildRows(row, true);
        IsExpandedByCheck = false;
        row = null; // reset row
    }
    return true;
}

function MarkChildRows(row, checked) {
    var childRows = row.GetChildRows(); // get the child rows
    for (var i=0; i<childRows.length; i++) {
        if (childRows[i].GetElement().type == "Record") {
            var cell = wgGetCellByName(childRows[i].GetElement(), "CheckBoxColumn");
            cell.childNodes[0].checked = checked;
        }
    }
}

  5. Register the WebGrid1_OnAfterResponseProcess function to the grid's OnAfterResponseProcess client-side event.

See Also

Tasks
Walkthrough: Utilizing button ColumnType
Walkthrough: Utilizing various ColumnTypes
Walkthrough: Deleting a record using WebGrid button
Walkthrough: Configuring password as ColumnType

Concepts
Column Types

References
ColumnType Property
InitializeLayout Event
ClientEvents Class

Other Resources
Walkthrough Topics
How-to Topics


Walkthrough: Deleting a record using WebGrid button

Walkthrough: Deleting a record using WebGrid button
See Also Send Feedback

Glossary Item Box

Use JavaScript to programmatically delete a row on client side. The Delete method will be called in a button-click event.

During this walkthrough, you will learn how to do the following:

  • Configure one column of WebGrid as a button column.
  • Using Client Side events to delete a row.

Prerequisites

In order to complete this walkthrough, you will need the following:

  • Visual Studio 2005 Application.

Step-By-Step Instructions

To delete a record using WebGrid button

  1. Binding WebGrid to AccessDataSource.
  2. Add a column and set its ColumnType as Button.
  3. Make sure the column's ButtonAutoPostback property is set to false.
  4. Apply this script to the page:

    JavaScript Copy Code
    <script language="javascript">

    function WebGrid1_OnButtonClick(gridId, tblName, colName, cellValue) {
        var grid = ISGetObject(gridId);
        var row = grid.GetSelectedObject().GetRowObject();
        row.Delete();
        return true;
    }

</script>

  5. Register the function to the grid's OnButtonClick client-side event.
  6. Run the project.

See Also

Tasks
Walkthrough: Utilizing button ColumnType
Walkthrough: Utilizing various ColumnTypes
Walkthrough: Using CheckBox column in Hierarchical WebGrid
Walkthrough: Configuring password as ColumnType

Concepts
Column Types

Other Resources
Walkthrough Topics
How-to Topics


Walkthrough: Using OnCellClick and OnRowSelect events in NewRow

Walkthrough: Using OnCellClick and OnRowSelect events in NewRow
See Also Send Feedback

Glossary Item Box

This walkthrough shows you how to specify the OnCellClick and OnRowSelect events in NewRow.

During this walkthrough, you will learn how to do the following:

  • Manipulate the grid client side to attach OnRowSelect and OnCellClick in grid.

Prerequisites

In order to complete this walkthrough, you will need the following:

  • Access to the Microsoft Access Northwind database.
  • Visual Studio 2005 Application.

Step-By-Step Instructions

  1. Binding WebGrid to AccessDataSource.
  2. Right click on WebGrid and choose WebGrid.Net Designer.
  3. Select the AllowAddNew checkbox.
  4. In the WebGrid InitializeLayout server side event, put the following code:

    C# Copy Image Copy Code
    private void WebGrid1_InitializeLayout(object sender, ISNet.WebUI.WebGrid.LayoutEventArgs e)
{
        e.Layout.ClientSideEvents.OnRowSelect = "DoRowSelect";
        e.Layout.ClientSideEvents.OnCellClick = "DoCellClick";
}

  5. Write some javascript functions in the client side:

    JavaScript Copy Image Copy Code
    function DoRowSelect(gridId, tblName, rowIdx, rowElm)
    {
         alert("OnRowSelect : WebGridId = " + gridId + " TableName =  " + tblName + " RowIndex = " + rowIdx + " RowElement =  " + rowElm);
         return true;
    }

function DoCellClick(gridId, tblName, rowIdx, cellIdx, cellElm)
    {
         alert("OnCellClick : WebGridId = " + gridId + " TableName =  " + tblName + " RowIndex =  " + rowIdx + " CellIndex =  " + cellIdx + " CellElement =  " + cellElm);
         return true;
    }

See Also

References
OnCellClick Property
OnRowSelect Property
InitializeLayout Event

Other Resources
Walkthrough Topics
How-to Topics


Walkthrough: Modifying ColumnFooters style using client side programming

Walkthrough: Modifying ColumnFooters style using client side programming
See Also Send Feedback

Glossary Item Box

This walkthrough shows you how to modify ColumnFooters style.

During this walkthrough, you will learn how to do the following:

  • Manipulate the grid client side to modify the columnfooters.

Prerequisites

In order to complete this walkthrough, you will need the following:

  • Access to the Microsoft Access Northwind database.
  • Visual Studio 2005 Application.

Step-By-Step Instructions

  1. Bind WebGrid to AccessDataSource.
  2. Right click WebGrid and choose WebGrid Designer.
  3. Go to Advanced tab, click See All Properties.
  4. Go to RootTable and set ColumnFooters property to Yes.
  5. Go to appropriate column in WebGrid RootTable and set the AggregateFunction property to 'Count'.

    Aggregate

  6. Place a HTML button in order to invoke a client side function.

    JavaScript Copy Image Copy Code
    function DoClick()
{
    var grid = ISGetObject("WebGrid1");
    var colFooterCell = grid.RootTable.GetElement(WG40.COLFOOTER, WG40.HTMLTABLE).cells[8];
    colFooterCell.style.color = "red";
    return true;
}

  7. First of all, try to obtain the root table's WebGridTable object by using grid.RootTable. Next, we need to obtain the table's element of the root table's column footer, by utilizing GetElement method.
  8. After the column footer is obtained, delve into the specific cell (TD) object. Finally, we can change the color style of the text using style.color attribute.

See Also

Other Resources
Walkthrough Topics
How-to Topics


Walkthrough: Using client side programming to modify FilterText

Walkthrough: Using client side programming to modify FilterText
See Also Send Feedback

Glossary Item Box

This walkthrough shows you how to add a FilterColumn at runtime using client side scripts.

During this walkthrough, you will learn how to do the following:

  • Manipulate the grid client side to add a FilterColumn at runtime.

Prerequisites

In order to complete this walkthrough, you will need the following:

  • Access to the Microsoft Access Northwind database.
  • Visual Studio 2005 Application.

Step-By-Step Instructions

  1. Bind WebGrid to AccessDataSource.
  2. Place a HTML button in order to invoke a client side function:

    JavaScript Copy Image Copy Code
    function AddFilter()
{
        var grid = ISGetObject("WebGrid1");

        var newFilter = new WebGridFilter(); // construct WebGridFilter object
        newFilter.ColumnMember = "ContactTitle"; // assign properties the same way as in server side
        newFilter.FilterType = "EqualTo"; // use the same enumeration as in server side
        newFilter.FilterText = "Owner";

        grid.RootTable.FilteredColumns.Add(newFilter); // add new filter column the same way as in server side
        grid.RootTable.UpdateUI(); // update User Interface to reflect changes
        grid.Refresh(); // perform refresh to get the filter applied

        alert("ContactTitle Column is now filtered!");
}

    In order to filter a column at runtime, developers only have to create a WebGridFilter object. Configure the necessary properties of the WebGridFilter object such as ColumnMember, FilterType and FilterText properties. As soon as the WebGridFilter object is ready, add it to the FilteredColumns object collection from the RootTable object. There are two methods that are important to be invoked. The first one is UpdateUI method which is used to update the grid's user interface in order to reflect the addition of the WebGridFilter object. The other one is Refresh method in order to apply the WebGridFilter object.

  3. Now suppose you have configured a FilterColumn previously at DesignTime. You need to change the FilterText at runtime. Here are the codes:

    JavaScript Copy Image Copy Code
    function ChangeFilter()
{
        var grid = ISGetObject("WebGrid1");
        var contactFilter = grid.RootTable.FilteredColumns.GetNamedItem("ContactTitle");

        if (contactFilter == null)
        {
                alert("Please filter by ContactTitle first!");
                return;
        }
        else
        {
                contactFilter.FilterText = "Sales";
                contactFilter.FilterType = "Like";
                contactFilter.SetChanged(); // indicates that an object has been changed and require processing in UpdateUI
                grid.RootTable.UpdateUI(); // update User Interface to reflect changes
                grid.Refresh();
        }

        alert("ContactTitle FilterColumn's FilterText now changed to Sales and FilterType changed to Like");
}

    Another new method is SetChanged method. The method is used because previously a WebGridFilter object is present and some properties of that object has been modified at runtime.

See Also

Other Resources
Walkthrough Topics
How-to Topics


Walkthrough: Modifying WebGrid records externally

Walkthrough: Modifying WebGrid records externally
See Also Send Feedback

Glossary Item Box

This walkthrough shows you how to obtain other cells values using client side scripts.

During this walkthrough, you will learn how to do the following:

  • Manipulate the grid client side to modify other cell values.

Prerequisites

In order to complete this walkthrough, you will need the following:

  • Access to the Microsoft Access Northwind database.
  • Visual Studio 2005 Application.

Step-By-Step Instructions

  1. Bind WebGrid to AccessDataSource.
  2. Place a HTML button in order to invoke a client side function like following:

    JavaScript Copy Image Copy Code
    function AddCustomer()
{
        var grid = ISGetObject("WebGrid1");
        var txtCustomerID = document.getElementById("txtCustomerID");
        var txtContactName  = document.getElementById("txtContactName");
        var txtContactTitle = document.getElementById("txtContactTitle");
        var txtCompanyName = document.getElementById("txtCompanyName");
        var txtAddress = document.getElementById("txtAddress");
        var txtCity = document.getElementById("txtCity");
        var txtCountry = document.getElementById("txtCountry");
        var dvAddCust = document.getElementById("dvAddCust");

        var newRow = grid.RootTable.NewRow(); // initiates new WebGridRow object with cells collection.
        var cells = newRow.GetCells(); // get the cells to be assigned with new customer information
        cells.GetNamedItem("CustomerID").SetText(txtCustomerID.value, true);
        cells.GetNamedItem("ContactName").SetText(txtContactName.value, true);
        cells.GetNamedItem("ContactName").SetText(txtContactName.value, true);
        cells.GetNamedItem("ContactTitle").SetText(txtContactTitle.value, true);
        cells.GetNamedItem("CompanyName").SetText(txtCompanyName.value, true);
        cells.GetNamedItem("Address").SetText(txtAddress.value, true);
        cells.GetNamedItem("City").SetText(txtCity.value, true);
        cells.GetNamedItem("Country").SetText(txtCountry.value, true);

        newRow.Update(); // perform add if the WebGridRow object is new row, otherwise it will perform update

        dvAddCust.style.display = "none";
}

  3. Based on the above codes, in order to add a new record into the grid, developers need to obtain the new WebGridRow object by invoking NewRow method from the WebGridTable object, such as this : grid.RootTable.NewRow().

    In order to obtain the WebGridCell collection, simply invoke GetCells method from the WebGridRow object, like this : newRow.GetCells(). The next thing to do is to populate each cells by using SetText method. The first parameter decides the text property of the WebGridCell object and the second parameter decides the value property. When the second parameter is filled with the true value, means that the current value of the WebGridCell object is filled with the same value as the text property.

    The last important thing to do is to invoke Update method against the WebGridRow object. If the WebGridRow object is a new row type, then it will perform record addition, otherwise it will perform record modification.

  4. Here are the codes in order to perform some record update process:

    JavaScript Copy Image Copy Code
    function UpdateRow()
{
        var grid = ISGetObject("WebGrid1");
        var row = grid.RootTable.GetRowByKeyValue("SPLIR"); // get WebGridRow object by key value.
        var cells = row.GetCells();

        row.Select(); // select this row for focus
        cells.GetNamedItem("ContactTitle").SetText("Owner", true); // change contact title cell to Owner

        row.Update(); // perform Update
        alert("ContactTitle of this row has been changed to 'Owner'");
}

  5. In order to modify a single cell of the grid, basically developers need to perform the same procedures as the record addition.
    First of all, obtain the WebGridRow object where the cell resides. In the above codes, we are using GetRowByKeyValue method against the RootTable object (WebGridTable).
    The next thing to do is to obtain the WebGridCell collection object from the WebGridRow object. After the WebGridCell collection object is obtained, developers can simply search for particular cell by using GetNamedItem method. SetText method is utilized in order to configure the cell's text and value property. Finally, the Update method is invoked.
  6. Here are the codes to perform record deletion.

    JavaScript Copy Image Copy Code
    function DeleteRow()
{
        var grid = ISGetObject("WebGrid1");
        var row = grid.RootTable.GetRowByKeyValue("VINET"); // get WebGridRow object by key value.

        row.Select(); // select this row for focus
        alert("Click OK to delete this row.");
        row.Delete(); // delete this row
        alert("Customer 'VINET' has been deleted!");
}

  7. It is very simple to perform record deletion in WebGrid. Simply obtain the WebGridRow object and then invoke the Delete method against the WebGridRow object.

See Also

Other Resources
Walkthrough Topics
How-to Topics


Walkthrough: Modifying other cell values on client side

Walkthrough: Modifying other cell values on client side
See Also Send Feedback

Glossary Item Box

This walkthrough shows you how to obtain other cells values using client side scripts.

During this walkthrough, you will learn how to do the following:

  • Manipulate the grid client side to modify other cell values.

Prerequisites

In order to complete this walkthrough, you will need the following:

  • Access to the Microsoft Access Northwind database.
  • Visual Studio 2005 Application.

Step-By-Step Instructions

  1. Bind WebGrid to AccessDataSource.
  2. Create a HTML button to invoke the clientside function. Notice that by using GetCells method, developers can obtain the cells collection from the WebGridRow object. After the cells collection is obtained, simply utilize GetNamedItem method.

    JavaScript Copy Image Copy Code
    function GetCellText()
{
    var grid = ISGetObject("WebGrid1");
    var curSelObj = grid.GetSelectedObject(); // get selected object

    if (curSelObj == null)
    {
        alert("No row selected. Please select a row");
    }
    else
    {
        var row = curSelObj.GetRowObject(); // get the WebGridRow object
        if (row.Type == "GroupHeader")
        {
            alert("Currently selected row is a Group Row. " +
                "There is no cell information.");
        }
        else if (row.Type == "Record")
        {
            // obtain WebGridCellCollection of the specified row.
            var cells = row.GetCells();

            // get the address' WebGridCell object by name.
            var addressCell = cells.GetNamedItem("Address");

            alert("Current selected row's Address cell has this text : " +
                addressCell.Text + "\nThe cell's value is : " +
                (addressCell.Value == null ? "No Value" : addressCell.Value));
        }
    }
}

  3. You can utilize SetText method in order to modify the cell's text, such as following:

    JavaScript Copy Image Copy Code
    function UpdateRow()
{
    var grid = ISGetObject("WebGrid1");
    // get WebGridRow object by key value.
    var row = grid.RootTable.GetRowByKeyValue("SPLIR");
    var cells = row.GetCells();

    row.Select(); // select this row for focus
    // change contact title cell to Owner
    cells.GetNamedItem("ContactTitle").SetText("Owner", true);

    row.Update(); // perform Update
    alert("ContactTitle of this row has been changed to 'Owner'");
}

See Also

Other Resources
Walkthrough Topics
How-to Topics


Walkthrough: Modifying AllowEdit and AllowDelete attributes using client side programming

Walkthrough: Modifying AllowEdit and AllowDelete attributes using client side programming
See Also Send Feedback

Glossary Item Box

This walkthrough shows you how to set AllowEdit and AllowDelete in WebGrid.

During this walkthrough, you will learn how to do the following:

  • Manipulate the grid clientside XML element to modify the AllowEdit and AllowDelete properties.

Prerequisites

In order to complete this walkthrough, you will need the following:

  • Access to the Microsoft Access Northwind database.
  • Visual Studio 2005 Application.

Step-By-Step Instructions

  1. Bind WebGrid to AccessDataSource.
  2. Create a HTML button to invoke the clientside function.
  3. Create a html function to disable the allowedit and allowdelete like following:

  4. JavaScript Copy Image Copy Code
    function TurnOff()
{
    var grid = ISGetObject("WebGrid1");

    // get the XML element that store all properties
    // of the table var
    docxml = grid.Tables["Customers"].getXml();

    alert("Previously : AllowEdit = " + docxml.getAttribute("allowEdit"));
    alert("Previously : AllowDelete = " + docxml.getAttribute("allowDelete"));

    docxml.setAttribute("allowEdit","no");
    docxml.setAttribute("allowDelete","no");

    alert("Currently : AllowEdit = " + docxml.getAttribute("allowEdit"));
    alert("Currently : AllowDelete = " + docxml.getAttribute("allowDelete"));
    return true;
}

See Also

Other Resources
Walkthrough Topics
How-to Topics


Walkthrough: Changing 'Enter' key behavior

Walkthrough: Changing 'Enter' key behavior
See Also Send Feedback

Glossary Item Box

This walkthrough will show how to utilizie OnEditKeyDown Client Side Events in order to trap the "EnterKey" and reconfiguring the "EnterKey" to perform other functions such as a tab moving to the next row at the same column in new row.

During this walkthrough, you will learn how to do the following:

  • How to handle enter key and change it to tab.

Prerequisites

In order to complete this walkthrough, you will need the following:

  • Access to the Microsoft Access NorthWind database.
  • Visual Studio 2005 Application.

Step-By-Step Instructions

  1. Bind WebGrid to AccessDataSource.
  2. Invoke the Initialize Layout server side event to call the OnEditKeyDown clientside event.

    C# Copy Image Copy Code
    private void WebGrid1_InitializeLayout(object sender, ISNet.WebUI.WebGrid.LayoutEventArgs e)
{
   // Attach a client side event on 'OnEditKeyDown' event
   e.Layout.ClientSideEvents.OnEditKeyDown = "HandleEditKeyDown";
}

  3. Next, add following function to your clientside html page.

  4. JavaScript Copy Image Copy Code
    function HandleEditKeyDown(gridId)
{
   var grid = wg_States[gridId];
   var ac = grid.getActiveEditCell();
   if (ac.rowElement.type == "NewRow")
   {
      if (event.keyCode == 13) // If Enter key is pressed
         event.keyCode = 9;  // change it to Tab
   }
   return true; // continue default processing.
}

See Also

Other Resources
Walkthrough Topics
How-to Topics


Walkthrough: Maintaining scroll position

Walkthrough: Maintaining scroll position
See Also Send Feedback

Glossary Item Box

This walkthrough will show how to maintain the scroll position between page Postbacks.

During this walkthrough, you will learn how to do the following:

  • Client server interaction in WebGrid.
  • Maintain the scroll position between page Postbacks.

Prerequisites

In order to complete this walkthrough, you will need the following:

  • Access to the Microsoft Access NorthWind database.
  • Visual Studio 2005 Application.

Step-By-Step Instructions

  1. Bind WebGrid to AccessDataSource.
  2. In the InitializeLayout event, attach a client side event on 'OnBeforeRequest' event.
  3. C# Copy Code
    private void WebGrid1_InitializeLayout(object sender,
ISNet.WebUI.WebGrid.LayoutEventArgs e)
{
    e.Layout.ClientSideEvents.OnBeforeRequest = "DoBeforeRequest";
}
  4. On the client-side, write these client script functions.
  5. JavaScript Copy Code
    function DoBeforeRequest(gridId,action)
{
    // collecting the last position
    // of the vertical scrollbar
    // by obtaining the scrollTop property

    var grid = ISGetObject(gridId);

    // obtain the scrollTop property
    // of the vertical scrollbar
    var vl = grid.RootTable.GetElement(WG40.BODY, WG40.HTMLDIV).scrollTop + "";

    // only send the scrollTop property
    // of the server if the action performed
    // by the grid OTFPB is 'Refresh'
    if(action == "Refresh")
    {
        // sending over the scrollTop property
        // to the server by using AddInput method
        grid.AddInput("scrollTopPos", vl);
    }

    return true;
}

function ApplyLatestScroll(x)
{
    // set back the previous scrollTop property or
    // vertical scroll position with
    // the parameter sent from the server side

    var grid = ISGetObject("WebGrid1");

    // manually configure the vertical scroll position
    grid.RootTable.GetElement(WG40.BODY, WG40.HTMLDIV).scrollTop = x;
    return true;
}

function DoRefresh()
{
    // invoke data refresh in the grid
    // by calling Refresh()

    // the data refresh process is performed
    // using OnTheFly PostBack

        var grid = ISGetObject("WebGrid1"); grid.RefreshAll();
    return true;
}
  6. Invoke the InitializePostBack server side event.
  7. C# Copy Code
    private void WebGrid1_InitializePostBack(object sender,
ISNet.WebUI.WebGrid.PostbackEventArgs e)
{
    // only perform the below function
    // when the last action performed by the
    // grid OTFPB is 'Refresh'
    if(e.Action == "Refresh")
    {
        // prepare the parameter to be
        // passed over to the client side
        // in order to set back the previous
        // vertical scroll position
        FunctionParameter[] parm = new FunctionParameter[1];
        parm[0].Type = "x";

        // obtain the value passed from the client
        // side using AddInput method
        parm[0].Value = Request.Form["scrollTopPos"];

        // invoke the js function
        // in order to set the vertical scroll position
        WebGrid1.ClientAction.InvokeScript("ApplyLatestScroll", parm);
    }
}

See Also

References
OnBeforeRequest Property

Other Resources
Walkthrough Topics
How-to Topics


Walkthrough: Configuring Hierarchical CheckBox behavior

Walkthrough: Configuring Hierarchical CheckBox behavior
See Also Send Feedback

Glossary Item Box

This walkthrough will show how to configure a hierarchical check box.

During this walkthrough, you will learn how to do the following :

  • How to configure a hierarchical check box.

Prerequisites

In order to complete this walkthrough, you will need the following:

  • Access to the Microsoft Access NorthWind database.
  • Visual Studio 2005 Application.

Step-By-Step Instructions

  1. Bind WebGrid Hierarchical to ISDataSource.
  2. In the PrepareDataBinding event, use the following code to retrieve the structure and add isRowChecker columns.

  3. C# Copy Image Copy Code
    private void WebGrid1_PrepareDataBinding(object sender,
    ISNet.WebUI.WebGrid.DataSourceEventArgs e)
    {
        // Add a checkbox column in the root table
        // as well as in the child table
        // Configure the checkbox column as the RowChecker

        if(!IsPostBack)
        {

            WebGridColumn col = new WebGridColumn("chk1", "chk1");
            col.Bound = false;
            col.IsRowChecker = true;
            WebGrid1.RootTable.Columns.Insert(0, col);

            col = new WebGridColumn("chk2", "chk2");
            col.Bound = false;
            col.IsRowChecker = true;
            WebGrid1.GetTableByName("Orders").Columns.Insert(0, col);
        }
    }

  4. Invoke the Initialize Layout server side event to call the onCheckBoxClick clientside event.

  5. C# Copy Code
    private void WebGrid1_InitializeLayout(object sender, ISNet.WebUI.WebGrid.LayoutEventArgs e)
{
        // Attach a client side event on 'OnCheckBoxClick' event
        e.Layout.ClientSideEvents.OnCheckBoxClick = "DoCheckBoxClick";
}

  6. Following is the code for the DoCheckBoxClick function clientside javascript to call the onCheckBoxClick.

    JavaScript Copy Image Copy Code
    function DoCheckBoxClick(gridId, tblName, colName, checkBoxValue)
{

    // obtain WebGrid object

    var grid = ISGetObject(gridId);
    // obtain the current WebGridRow object of
    // the checked row

    var row = grid.Tables[tblName].ToRowObject(grid.CheckedRowContext);
    // only run the below function
    // when the current root table is "Customers"
    // and there is minimum one
    // child table under the "Customers" table

    if(tblName == "Customers" && row.Table.ChildTables.length > 0)
    {
        // check whether the child row has been expanded or not
        if(!row.ChildExpanded)
        {
            // utilize synchronous mode of WebGrid
            // so that all child rows can be
            // obtained in the same code flow

            row.ExpandChildRow(true);

            // obtain the WebGridRow collection of the child table

            var childRows = row.GetChildRows("Orders");

            // loop all the rows and check all rows if the parent row is checked
            // or uncheck all rows if the parent row is unchecked

            for(var i=0; i<childRows.length; i++)
            {
                if(checkBoxValue)
                {
                    childRows[i].Check();
                }
                else
                {
                    childRows[i].Uncheck();
                }
            }
        }
        else
        {
            // obtain the WebGridRow collection of the child table
            var childRows = row.GetChildRows("Orders");

            // loop all the rows and check all rows if the parent row is checked
            // or uncheck all rows if the parent row is unchecked
            for(var i=0; i<childRows.length; i++)
            {
                if(checkBoxValue)
                {
                    childRows[i].Check();
                }
                else
                {
                    childRows[i].Uncheck();
                }
            }
        }
    }

    return true;
}

  7. Run the project and the WebGrid will look like following.

See Also

References
PrepareDataBinding Event
OnCheckBoxClick Property
InitializeLayout Event

Other Resources
Walkthrough Topics
How-to Topics


Walkthrough: Applying custom filtering in WebGrid

Walkthrough: Applying custom filtering in WebGrid
See Also Send Feedback

Glossary Item Box

When a filter or more is applied to the grid, it will check the column with WebValueList applied to it and then do some manipulation on how data is suppose to be filtered. What it actually does is it filters a column which is not rendered in the grid, not the column you thought you are filtering.

During this walkthrough, you will learn how to do the following:

  • Using Custom Filter.
  • Using WebValueList.

Prerequisites

In order to complete this walkthrough, you will need the following:

  • Access to the Microsoft Access Northwind database
  • Visual Studio 2005 Application.

Step-By-Step Instructions

To Custom Filtering Feature in WebGrid

  1. Launch Visual Studio.NET 2005.
  2. Click on File menu, then select New and click Web Site.
  3. Select ASP.NET Web Site in the Template box and set Location to HTTP.
  4. Named the Web Site and click OK.
  5. Right-click on Project's name and select Add New Item.
  6. Select Intersoft AppForm in the My Templates box and named it as Walkthrough.aspx.
  7. Drag WebGrid instance from ToolBar to WebForm.
  8. In the Solution Explorer, right-click on App_Data and select Add Existing Item.
  9. Browse and add NorthWind.mdb in C:\Program Files\Intersoft Solutions\Data (Default installation folder).
  10. Click the SmartTag on the upper right of the WebGrid.
  11. In ChooseDataSource field, choose <New data source...>.

  12. In Data Source Configuration Wizard, choose ISDataSource and click OK.

  13. Select the Schema Type that you want to use and click Next.

  14. Add 2 or more tables required and click Finish.

  15. Finally, choose Retrieve Hierarchical Structure action in Connected to Data Source Control Wizard and click OK.

  16. Set the ValueList from column properties like following:

  17. Select AllowFilter, AllowEdit and AllowSorting properties from SmartTag..

  18. In the code behind, add the following code to the CustomFilter server side event of the grid.

    C# Copy Code
    private void WebGrid1_CustomFilter(object sender, ISNet.WebUI.WebGrid.FilterEventArgs e)
{
        WebGridFilter filter;
        filter = e.FilterColumns.GetNamedItem("CategoryName");
        if (filter!=null)
                e.FilterColumns.Remove(filter);

        WebGridFilter oldFilter;
        oldFilter = e.FilterColumns.GetNamedItem("CategoryID");
        if (oldFilter!=null)
        {
                e.FilterColumns.Remove(oldFilter);
                filter = new WebGridFilter();
                filter.Table = oldFilter.Table;
                // remember to set column member field BEFORE FilterType and FilterText
                filter.ColumnMember = "CategoryName";
                filter.FilterType = oldFilter.FilterType;
                filter.FilterText = oldFilter.FilterText;
                e.FilterColumns.Add(filter);
        }
}

See Also

Tasks
Walkthrough: Applying custom sorting in WebGrid
Walkthrough: Using DropDownList in Filter Row
Walkthrough: Using cookie to save FilterRow values
How-to: Perform filtering data and hide Filter Bar in WebGrid

References
CustomFilter Event

Other Resources
Walkthrough Topics
How-to Topics


Walkthrough: Using DropDownList in Filter Row

Walkthrough: Using DropDownList in Filter Row
See Also Send Feedback

Glossary Item Box

WebGrid.NET also supports filter column using DropDownList filter type.

During this walkthrough, you will learn how to do the following:

  • Configure a filter column as DropDownList filter type.
  • Using WebValueList.

Prerequisites

In order to complete this walkthrough, you will need the following:

  • Access to the Microsoft Access Northwind database
  • Visual Studio 2005 Application.

Step-By-Step Instructions

To use DropDownList as filter type

  1. Launch Visual Studio.NET 2005.
  2. Click on File menu, then select New and click Web Site.
  3. Select ASP.NET Web Site in the Template box and set Location to HTTP.
  4. Named the Web Site and click OK.
  5. Right-click on Project's name and select Add New Item.
  6. Select Intersoft AppForm in the My Templates box and named it as Walkthrough.aspx.
  7. Drag WebGrid instance from ToolBar to WebForm.
  8. In the Solution Explorer, right-click on App_Data and select Add Existing Item.
  9. Browse and add NorthWind.mdb in C:\Program Files\Intersoft Solutions\Data (Default installation folder).
  10. Click the SmartTag on the upper right of the WebGrid.
  11. In ChooseDataSource field, choose <New data source...>.

  12. In DataSourceConfigurationWizard, choose ISDataSource and click next.

  13. Select the Schema Type that you want to use and click Next.

  14. Add 2 or more tables required and click Finish.

  15. Then, choose Retrieve Hierarchical Structure action in Connected to Data Source Control Wizard and click OK.

  16. Set the ValueList from column properties:

    Property | Value
    DataSourceID | ISDataSource1
    Data Member | Categories
    Data Text Field | CategoryName
    Data Value Field | CategoryID

  17. Notice that CategoryID column content has been translated into CategoryName by utilizing WebValueList object of WebGrid. The most important thing is to configure the FilterEditType attribute of the CategoryID column into DropDownList.

  18. Do not forget to configure the AllowFilter attribute of the grid.
  19. Run the project.

See Also

Tasks
Walkthrough: Applying custom filtering in WebGrid
{Walkthrough: Using cookie to save FilterRow values}
{Walkthrough: Applying custom sorting in WebGrid}
{How-to: Perform filtering data and hide Filter Bar in WebGrid}

References
DataSourceID Property
DataTextField Property
DataValueField Property
DataMember Property
FilterEditType Property
AllowFilter Property

Other Resources
Walkthrough Topics
How-to Topics


Walkthrough: Using cookie to save FilterRow values

Walkthrough: Using cookie to save FilterRow values
See Also Send Feedback

Glossary Item Box

Some developers want to create a customized feature for each user. For example they want to customize the filter area of WebGrid, since some users prefer to for example directly show the list of customers' name starting with the word "A". So Every time the page is first loaded, it will check whether a cookie for that page exist. If the cookie exists, then the cookie value will be captured and a filter will be added to a column based on the cookie value

During this walkthrough, you will learn how to do the following:

  • Using Cookie.
  • Using JavaScript function.
  • Save FilterRow values
  • Use WebGrid's InitializePostBack event to save cookie OnTheFly.
  • Use WebGrid's Page_Load event to check whether the cookie exist or not.

Prerequisites

In order to complete this walkthrough, you will need the following:

  • Access to the Microsoft Access Northwind database
  • Visual Studio 2005 Application.

Step-By-Step Instructions

To Use Cookie to Save Filter Row values

  1. Launch Visual Studio.NET 2005.
  2. Click on File menu, then select New and click Web Site.
  3. Select ASP.NET Web Site in the Template box and set Location to HTTP.
  4. Named the Web Site and click OK.
  5. Right-click on Project's name and select Add New Item.
  6. Select Intersoft AppForm in the My Templates box and named it as Walkthrough.aspx.
  7. Drag WebGrid instance from ToolBar to WebForm.
  8. In the Solution Explorer, right-click on App_Data and select Add Existing Item.
  9. Browse and add NorthWind.mdb in C:\Program Files\Intersoft Solutions\Data (Default installation folder).
  10. Click the SmartTag on the upper right of the WebGrid.
  11. In ChooseDataSource field, choose <New data source...>.

  12. In DataSourceConfigurationWizard, choose AccessDatabase and click OK.

  13. Browse and select the database in App_Data (NorthWind.mdb) and click Next.

  14. Select the table that you want to use and click Next.

  15. In this step, you can view the table's database using Test Query button. Otherwise, click Finish to proceed to the next step.
  16. Finally, choose Retrieve Structure action in Connected to Data Source Control Wizard and click OK to apply all settings.

  17. Set the AllowFilter Property to Yes.
  18. Create a HTML button with it's onClick attribute set to the name of your JavaScript function for example
    <INPUT type="button" value="SaveFilterCookie" onclick="SaveFilterCookie();">
  19. Insert this javaScript function on the head area of your HTML .

    JavaScript Copy Code
    <script language="javascript" type="text/javascript">
 function SaveFilterCookie()
 {
  var webGrid = ISGetObject("WebGrid1");
  var rowFilter = webGrid.Tables["Customers"].FilteredColumns;
  var CustomerIDFilter;
  if(rowFilter.GetNamedItem("CustomerID") != null)
  {
   CustomerIDFilter = rowFilter.GetNamedItem("CustomerID").FilterText;
  }
  else
  {
   CustomerIDFilter = "";
  }
  webGrid.AddInput("CustomerIDFilter", CustomerIDFilter);
  webGrid.SendCustomRequest();
 }
</script>

  20. On the InitializePostBack event handler of the grid, you write code to save cookie on the fly.

    C# Copy Code
    private void WebGrid1_InitializePostBack(object sender, ISNet.WebUI.WebGrid.PostbackEventArgs e)
{
 if (e.Action == PostBackAction.Custom)
 {
  //request the CustomerIDFilter and store it in a cookie called UserPreference
  String CustomerIDFilter = Request["CustomerIDFilter"];
  HttpCookie myCookie = new HttpCookie("UserPreference");
  myCookie["CustomerIDFilter"] = CustomerIDFilter;
  myCookie.Expires = DateTime.Now.AddDays(2);
  Response.Cookies.Add(myCookie);
 }
}

  21. On the PageLoad event handler of the Page, write codes to check whether the cookie exist or not. If it does exist then the cookie value will be taken and used as a filter.

    C# Copy Code
    private void Page_Load(object sender, System.EventArgs e)
{
 if(!IsPostBack)
 {
  if (Request.Cookies["UserPreference"] != null)
  {
   string columnMember = "CustomerID";
   string filterText = Request.Cookies["UserPreference"]["CustomerIDFilter"];
   ISNet.WebUI.WebGrid.WebGridFilter filter = new ISNet.WebUI.WebGrid.WebGridFilter(columnMember,ISNet.WebUI.WebGrid.ColumnFilterType.Like,filterText);
   this.WebGrid1.RootTable.FilteredColumns.Add(filter);
  }
 }
}

See Also

Tasks
Walkthrough: Applying custom filtering in WebGrid
Walkthrough: Using DropDownList in Filter Row
Walkthrough: Applying custom sorting in WebGrid
How-to: Perform filtering data and hide Filter Bar in WebGrid

References
AllowFilter Property
InitializePostBack Event

Other Resources
Walkthrough Topics
How-to Topics


Walkthrough: Using ExpandChildRow to expand child tables

Walkthrough: Using ExpandChildRow to expand child tables
See Also Send Feedback

Glossary Item Box

This walkthrough shows you how to Expand Child table.

During this walkthrough, you will learn how to do the following :

  • Bind WebGrid to Hierarchical mode.
  • Use WebGrid's InitializeRow server side event to expand the child rows

Prerequisites

In order to complete this walkthrough, you will need the following:

  • Access to the Microsoft Access Northwind database.
  • Visual Studio 2005/2008/2010 Application.

Step-By-Step Instructions

  1. Bind WebGrid to Hierarchical ISDataSource.
  2. In the InitializeRow event of the grid, expand the child rows.

    C# Copy Code
    using ISNet.WebUI.WebGrid;

private void WebGrid1_InitializeRow(object sender, ISNet.WebUI.WebGrid.RowEventArgs e)
{
   // Only expands Customers' child table
   if(e.Row.Type == RowType.Record && e.Row.Table.Name == "Customers")
   {
      e.Row.ExpandChildRow();
   }
}

  3. Finally, the WebForm will look like the following snapshot:

See Also

Tasks
How-to: Select a row from server side

References
InitializeRow Event
ExpandChildRow Method

Other Resources
Walkthrough Topics
How-to Topics


Walkthrough: Hiding certain columns programmatically

Walkthrough: Hiding certain columns programmatically
See Also Send Feedback

Glossary Item Box

This walkthrough shows you how to hide certain column programmatically in server side.

During this walkthrough, you will learn how to do the following :

  • Binding Flat Datasource to WebGrid.
  • Hide certain column programmatically in WebGrid's InitializeRow server side event.

Prerequisites

In order to complete this walkthrough, you will need the following:

  • Access to the Microsoft Access Northwind database.
  • Visual Studio 2003 Application.

Step-By-Step Instructions

  1. Binding WebGrid to AccessDataSource.
  2. Add the following codes in InitializeRow server side event:

    C# Copy Code
    protected void WebGrid1_InitializeLayout(object sender, ISNet.WebUI.WebGrid.LayoutEventArgs e)
{
   WebGrid1.RootTable.Columns.GetNamedItem("Address").Visible = false;
   WebGrid1.RootTable.Columns.GetNamedItem("CompanyName").Visible = false;
}

See Also

Tasks
How-to: Hide/Show the column headers
How-to: Hide/Show the column footers
How-to: Move a column
How-to: Resize a column

Other Resources
Walkthrough Topics
How-to Topics


Walkthrough: Displaying GroupTotal of child table

Walkthrough: Displaying GroupTotal of child table
See Also Send Feedback

Glossary Item Box

This walkthrough shows you how to display GroupTotal of ChildTable.

During this walkthrough, you will learn how to do the following :

  • Bind WebGrid to Hierarchical mode.
  • GroupTotal of Quantity from Order Details in InitializeLayout.

Prerequisites

In order to complete this walkthrough, you will need the following:

  • Access to the Microsoft Access Northwind database.
  • Visual Studio 2005 Application.

Step-By-Step Instructions

  1. Bind WebGrid to Hierarchical mode.
  2. In the InitializeLayout event of the grid, expand the child rows.

    C# Copy Code
    if(!IsPostBack)
{
   // Prepare the Group Total
   WebGrid1.GetTableByName("Order Details").GroupTotalVisible = true;
   WebGrid1.GetTableByName("Order Details").Columns.GetNamedItem("Quantity").AggregateFunction = AggregateFunctions.Sum;

   WebGridGroup groupByProductID = new WebGridGroup();
   groupByProductID.Name = "GroupByProductID";
   groupByProductID.ColumnMember = "ProductID";
   WebGrid1.GetTableByName("Order Details").GroupedColumns.
   Add(groupByProductID);
}

  3. Finally, the WebForm will look like the following snapshot:

See Also

Tasks
Walkthrough: Using Custom Aggregate function in WebGrid
How-to: Use avg aggregate in group header

References
AggregateFunction Property
InitializeLayout Event

Other Resources
Walkthrough Topics
How-to Topics


Walkthrough: Configuring password as ColumnType

Walkthrough: Configuring password as ColumnType
See Also Send Feedback

Glossary Item Box

This walkthrough shows you how to configure Password as column type in WebGrid.

During this walkthrough, you will learn how to do the following :

  • Bind WebGrid to datasource.
  • Set CustomerID's column to password column.

Prerequisites

In order to complete this walkthrough, you will need the following:

  • Access to the Microsoft Access Northwind database.
  • Visual Studio 2003 Application.

Step-By-Step Instructions

To create new web application and set ColumnType as password.

  1. Binding WebGrid to AccessDataSource.
  2. Invoke the WebGrid's InitializeRow server side event to set the CustomerID's column type to password type.

    C# Copy Image Copy Code

    if(e.Row.Type == ISNet.WebUI.WebGrid.RowType.Record)

    {

        string strCustomerID = e.Row.Cells.GetNamedItem("CustomerID").Text;

        e.Row.Cells.GetNamedItem("CustomerID").Text = "<INPUT type=\"password\" value=\"" + strCustomerID + "\">";

    }

  3. Finally, the WebForm will look like the following snapshot:

See Also

Tasks
Walkthrough: Utilizing button ColumnType
Walkthrough: Utilizing various ColumnTypes
Walkthrough: Using CheckBox column in Hierarchical WebGrid
Walkthrough: Deleting a record using WebGrid button

Concepts
Column Types

Other Resources
Walkthrough Topics
How-to Topics


Walkthrough: Updating footer when loading data on demand

Walkthrough: Updating footer when loading data on demand
See Also Send Feedback

Glossary Item Box

This walkthrough shows you how to update the footer's text when load.

During this walkthrough, you will learn how to do the following :

  • Bind WebGrid to datasource.
  • Using Virtual Load.
  • Update footer text.

Prerequisites

In order to complete this walkthrough, you will need the following:

  • Access to the Microsoft Access Northwind database.
  • Visual Studio 2005 Application.

Step-By-Step Instructions

To create new web application and update footer when loading data on demand.

  1. Launch Visual Studio.NET 2005.
  2. Click on File menu, then select New and click Web Site.
  3. Select ASP.NET Web Site in the Template box and set Location to HTTP.
  4. Named the Web Site and click OK.
  5. Right-click on Project's name and select Add New Item.
  6. Select Intersoft AppForm in the My Templates box and named it as Walkthrough.aspx.
  7. Drag WebGrid instance from ToolBar to WebForm.
  8. In the Solution Explorer, right-click on App_Data and select Add Existing Item.
  9. Browse and add NorthWind.mdb in C:\Program Files\Intersoft Solutions\Data (Default installation folder).
  10. Click the SmartTag on the upper right of the WebGrid.
  11. In Choose Data Source field, choose <New data source...>.

  12. In Data Source Configuration Wizard, choose ISDataSource and click OK.

  13. Select the Schema Type that you want to use and click Next.

  14. Add Orders tables and click Finish.

  15. Then, choose Retrieve Hierarchical Structure action in Connected to Data Source Control Wizard and click OK.

  16. Right click on ISDataSource1 and launch the designer, set the Orders table's SelectCountMethod to GetCount, SelectMethod to GetData, and EnablePaging to True.

  17. Right click on WebGrid and launch the designer, in Popular Settings - Paging Expandable panel set Paging Mode = "VirtualLoad" and virtual load mode set to "Custom".

  18. Checked Show Column Footer checkbox in User Interface - User Interface settings expandable panel.
  19. In Advanced tab - RootTable - Columns - Freight - See all properties, set AggregateFunction to Count and FooterText = "COUNT = "

  20. Write codes that handle virtual load and the total row count in App_Code (NorthWind.cs).

    C# Copy Image Copy Code
    using System;
using System.Data;
using System.Configuration;
using System.Web;
using System.Web.Security;
using System.Web.UI;
using System.Web.UI.WebControls;
using System.Web.UI.WebControls.WebParts;
using System.Web.UI.HtmlControls;
using System.Data.OleDb;
using NorthWindTableAdapters;
using System.Data.OleDb;

namespace NorthWindTableAdapters
{
   public partial class OrdersTableAdapter : System.ComponentModel.Component
   {
      public DataTable GetData(string customerID)
      {
         NorthWind.OrdersDataTable dt = new NorthWind.OrdersDataTable();

         OleDbDataAdapter adapter = new OleDbDataAdapter();
         adapter.SelectCommand = new OleDbCommand("SELECT * FROM Orders WHERE CustomerID = '" + customerID + "'", this.Connection);
         adapter.Fill(dt);

         return dt;
      }

       /// <summary>
       /// This function is used in 5.0\CustomVirtualLoad tutorial.
       /// </summary>
       /// <remarks>
       /// When the WebGrid is configured to use VirtualLoad paging with Custom mode which is bound to ISDataSource,
       /// the datasource control requires a function which is written by developer to handle the paging logic.
       /// The function name is determined by the SelectMethod property.
       /// The paramaters need to be exactly the same as in the following.
       /// With the function defined in App_Code, the WebGrid does not handle the data retrieval logic any further.
       /// This results in clean separation between user interface and data component function. The WebGrid will simply
       /// gets a valid datasource returned by the datasource control. With this separation, WebGrid is now purely functioning
       /// as data presenter and providing user interface to allow users to interact with the information.
       /// </remarks>
       /// <param name="startRowIndex">The start row number. The value is passed from WebGrid control.</param>
       /// <param name="maximumRows">The maximum rows to retrieve.</param>
       /// <param name="sortExpression">The sort expression string if any.
       /// If there is more than one sort column in WebGrid, this sort expression can be passed to your
       /// SELECT query in order to get correct results.
       /// </param>
       /// <returns></returns>

      public DataTable GetData(int startRowIndex, int maximumRows, string sortExpression)
      {
         NorthWind.OrdersDataTable dt = new NorthWind.OrdersDataTable();
         int topRows = startRowIndex + maximumRows;
         if (!string.IsNullOrEmpty(sortExpression))
            sortExpression = " order by " + sortExpression;

         OleDbDataAdapter adapter = new OleDbDataAdapter();
         adapter.SelectCommand = new OleDbCommand("SELECT TOP " + topRows.ToString() + " * FROM Orders" + sortExpression, this.Connection);
         adapter.Fill(dt);

         return dt;
      }

      /// <summary>
      /// This function is used in 5.0\CustomVirtualLoad tutorial.
      /// </summary>
      /// <remarks>
      /// In order to create custom virtual load paging functionality, developer is required to write a function
      /// that retrieves the total rows of the table in the GetData context above.
      /// The function name is determined by SelectCount property in ISDataSourceTable object.
      /// The parameters need to be exactly the same as in the following.
      /// </remarks>
      /// <param name="sortExpression">The sort expression which is passed from WebGrid control.</param>
      /// <returns>Returns the count of the virtual rows.</returns>

      public int GetCount(string sortExpression)
      {
         OleDbDataAdapter adapter = new OleDbDataAdapter();
         adapter.SelectCommand = new OleDbCommand("Select COUNT(*) From Orders", this.Connection);

         this.Connection.Open();
         int result = (int)adapter.SelectCommand.ExecuteScalar();
         this.Connection.Close();

         return result;
      }
   }
}

  21. Finally, the WebGrid will look like the following:

See Also

Tasks
Walkthrough: Setting Virtual Load in WebGrid
How-to: Retrieve a different VirtualPageSize on a specific condition
How-to: Implement custom Virtual Load

References
ColumnFooters Property
VirtualLoadMode Property
OnAfterResponseProcess Property

Other Resources
Walkthrough Topics
How-to Topics


Walkthrough: Sending data to server using OnTheFlyPostBack architecture

Walkthrough: Sending data to server using OnTheFlyPostBack architecture
See Also Send Feedback

Glossary Item Box

This walkthrough shows you how to use OnTheFlyPostBack.

During this walkthrough, you will learn how to do the following :

  • Binding Flat Datasource to WebGrid.
  • Use SendCustomRequest to perform call back.

Prerequisites

In order to complete this walkthrough, you will need the following:

  • Access to the Microsoft Access Northwind database.
  • Visual Studio 2005/2008/2010 Application.

Step by step instructions

  1. Bind WebGrid to AccessDataSource control.
  2. Drag and drop four TextBox controls from toolbox to WebForm.
  3. Add OnRowSelect client side event.

    C# Copy Code
    function WebGrid1_OnRowSelect(controlId, tblName, rowIndex, rowEl)
{
   var grid = ISGetObject("WebGrid1");
   var selRow = grid.GetSelectedObject().GetRowElement();
   grid.AddInput("keyValue", selRow.keyValue);
   grid.SendCustomRequest();
   return true;
}

  4. After SendCustomRequest then WebGrid will call InitializePostBack server side event. In InitializePostBack insert these codes to retrieve record based on the selected row's keyValue. After the column value is retrieved, you then call a JavaScript function in the client with parameters set to the columns' value.

    C# Copy Code
    private void WebGrid1_InitializePostBack(object sender, ISNet.WebUI.WebGrid.PostbackEventArgs e)
{
   if(e.Action == ISNet.WebUI.WebGrid.PostBackAction.Custom)
   {
      string keyValue = Request.Form["keyValue"].ToString();
      DataSet ds = (DataSet)WebGrid1.DataSource;
      string filter = "CustomerID = '" + keyValue + "'";
           DataRow[] rows = ds.Tables["Customers"].Select(filter);
      string Address = rows[0]["Address"].ToString();
      string City = rows[0]["City"].ToString();
      string CompanyName = rows[0]["CompanyName"].ToString();
      string ContactName = rows[0]["ContactName"].ToString();
           ISNet.WebUI.FunctionParameter[] prms = new ISNet.WebUI.FunctionParameter[4];
      prms[0] = new ISNet.WebUI.FunctionParameter(Address,"string");
      prms[1] = new ISNet.WebUI.FunctionParameter(City,"string");
      prms[2] = new ISNet.WebUI.FunctionParameter(CompanyName,"string");
      prms[3] = new ISNet.WebUI.FunctionParameter(ContactName,"string");
           this.WebGrid1.ClientAction.InvokeScript("SetTxtValue", prms);
   }
}

  5. Add SetTxtValue client side function used to display values sent from server to TextBox.

    JavaScript Copy Code
    function SetTxtValue(Address,City,CompanyName,ContactName)
{
   document.getElementById("txtAddress").value = Address;
   document.getElementById("txtCity").value = City;
   document.getElementById("txtCompanyName").value = CompanyName;
   document.getElementById("txtContactName").value = ContactName;
}

See Also

References
InitializePostBack Event
OnRowSelect Property

Other Resources
Walkthrough Topics
How-to Topics


Walkthrough: Configuring multiline row in ColumnSet layout

Walkthrough: Configuring multiline row in ColumnSet layout
See Also Send Feedback

Glossary Item Box

WebGrid.NET also support to configure MultiLine Row in ColumnSet.

During this walkthrough, you will learn how to do the following:

  • Create ColumnSet.
  • Set MultiLine Row in ColumnSet.

Prerequisites

In order to complete this walkthrough, you will need the following:

  • Access to the Microsoft Access Northwind database
  • Visual Studio 2005 Application.

Step-By-Step Instructions

To set the column on that ColumnSet as a multiline

  1. Drag a WebGrid instance into the WebForm.
  2. Bind the grid to the DataSource then RetrieveStructure.
  3. Create a ColumnSet and set the height to "-1" for the column and including the spanned column where you want the height to be dynamic. Below is the XML generated in the HTML.

    XML Copy Code
    <iswebgrid:WebGridRowLayout width="116" height="-1" colspan="5" Row="2" ColumnMember="Notes" />
<iswebgrid:WebGridRowLayout width="116" height="-1" Spanned="Column" Row="2" Col="1" />
<iswebgrid:WebGridRowLayout width="116" height="-1" Spanned="Column" Row="2" Col="2" />
<iswebgrid:WebGridRowLayout width="116" height="-1" Spanned="Column" Row="2" Col="3" />
<iswebgrid:WebGridRowLayout width="116" height="-1" Spanned="Column" Row="2" Col="4" />

  4. Bind that column to a WebGridColumn and set that column's AllowMultiline to True. Below is the XML generated in the HTML.

    XML Copy Code
    <iswebgrid:WebGridColumn Caption="Notes" DataMember="Notes"
AllowMultiLine="True" name="Notes"  width="100px" />

See Also

Tasks
Walkthrough: Creating ColumnSet layout in WebGrid
How-to: Display a ColumnSet layout hierarchically
How-to: Create ColumnSet layout programmatically
How-to: Create ColumnSet layout when IList object is bound to WebGrid

Concepts
ColumnSets Layout

References
ColumnSetSettings Class
WebGridColumnSet Class

Other Resources
Walkthrough Topics
How-to Topics


Walkthrough: Using MultiLine TextBox

Walkthrough: Using MultiLine TextBox
See Also Send Feedback

Glossary Item Box

This walkthrough shows you how to set MultiLine TextBox as WebGridColumn's EditType.

During this walkthrough, you will learn how to do the following :

  • Change the WebGridColumn's EditType to MultiLine TextBox using either designer or programmatic runtime.

Prerequisites

In order to complete this walkthrough, you will need the following:

  • Access to the Microsoft Access Northwind database.
  • Visual Studio 2003 Application.

Step-By-Step Instructions

To create new web application and set ContactName column EditType to MultiLine TextBox.

  1. Bind WebGrid to AccessDataSource.
  2. Set WebGrid's properties AllowEdit to true.

Using designer

  1. Right click on WebGrid and click on WebGrid.Net Designer.
  2. Go to Advanced tab >> RootTable >> Columns
  3. Set focus to address's column and find Editing Expandable panel.
  4. Change TextBox to MultiLine TextBox
  5. Click Apply >> OK
  6. The picture will look like following:

Using programmatic runtime

  1. Add InitializeLayout event handler and put the following code inside it.

    C# Copy Code
    WebGrid1.RootTable.Columns.GetNamedItem("Address").EditType = ISNet.WebUI.WebGrid.EditType.MultilineTextbox;

  2. Finally, compile and run the project. The WebForm will be displayed like the following snapshot:

See Also

Tasks
Walkthrough: Using CheckBox
Walkthrough: Using Calendar DropDown
Walkthrough: Using Calendar Combo
How-to: Perform Bulk Update on a Button Click event
How-to: Use DropDownList as EditType of a WebGridColumn

References
AllowEdit Property
EditType Property

Other Resources
Walkthrough Topics
How-to Topics


Walkthrough: Using CheckBox

Walkthrough: Using CheckBox
See Also Send Feedback

Glossary Item Box

This walkthrough shows you how to set Checkbox as WebGridColumn's EditType.

During this walkthrough, you will learn how to do the following :

  • Change the WebGridColumn's EditType to Checkbox using designer.

Prerequisites

In order to complete this walkthrough, you will need the following:

  • Access to the Microsoft Access Northwind database.
  • Visual Studio 2005 Application.

Step-By-Step Instructions

To create new web application and set Discontinued column EditType, ColumnType to Checkbox.

  1. Bind WebGrid to AccessDataSource.
  2. Use Products table instead of Customers table.
  3. Set WebGrid's properties AllowEdit to true.

Using designer

  1. Right click on WebGrid and click on WebGrid.Net Designer.
  2. Go to Advanced tab >> RootTable >> Columns.
  3. Changed ColumnType from TextBox to CheckBox.
  4. Change Text to Checkbox.
  5. Set focus to Discontinued's column and find Editing Expandable panel.
  6. Change TextBox to Checkbox.
  7. Click Apply >> OK.
  8. The picture will be like this:

  9. Finally, compile and run the project. The WebForm will look like the following snapshot:

See Also

Tasks
Walkthrough: Using MultiLine TextBox
Walkthrough: Using Calendar DropDown
Walkthrough: Using Calendar Combo
How-to: Perform Bulk Update on a Button Click event
How-to: Use DropDownList as EditType of a WebGridColumn

References
ColumnType Property
EditType Property

Other Resources
Walkthrough Topics
How-to Topics


Walkthrough: Using Calendar DropDown

Walkthrough: Using Calendar DropDown
See Also Send Feedback

Glossary Item Box

This walkthrough shows you how to set Checkbox as WebGridColumn's EditType.

During this walkthrough, you will learn how to do the following :

  • Change the WebGridColumn's EditType to Calender DropDown using either designer.

Prerequisites

In order to complete this walkthrough, you will need the following:

  • Access to the Microsoft Access Northwind database.
  • Visual Studio 2005 Application.

Step-By-Step Instructions

To create new web application and set BirthDate column EditType to Calender DropDown.

  1. Bind WebGrid to AccessDataSource.
  2. Use Employees table instead of Customers table.
  3. Set WebGrid's properties AllowEdit to true

Using designer

  1. Right click on WebGrid and click on WebGrid.Net Designer.
  2. Go to Advanced tab >> RootTable >> Columns.
  3. Set focus to BirthDate's column and find Editing Expandable panel.
  4. Change TextBox to CalenderDropDown.
  5. Click Apply >> OK.
  6. The picture will be like this.

  7. Finally, compile and run the project. The WebForm will look like the following snapshot:

See Also

Tasks
Walkthrough: Using MultiLine TextBox
Walkthrough: Using CheckBox
Walkthrough: Using Calendar Combo
How-to: Perform Bulk Update on a Button Click event
How-to: Use DropDownList as EditType of a WebGridColumn

References
AllowEdit Property
EditType Property

Other Resources
Walkthrough Topics
How-to Topics


Walkthrough: Using Calendar Combo

Walkthrough: Using Calendar Combo
See Also Send Feedback

Glossary Item Box

This walkthrough shows you how to set Calender combo as WebGridColumn's EditType.

During this walkthrough, you will learn how to do the following :

  • Change the WebGridColumn's EditType to Calender combo using either designer.

Prerequisites

In order to complete this walkthrough, you will need the following:

  • Access to the Microsoft Access Northwind database.
  • Visual Studio 2003 Application.

Step-By-Step Instructions

To create new web application and set BirthDate column EditType to Calender Combo.

  1. Bind WebGrid to AccessDataSource.
  2. Use Employees table instead of Customers table.
  3. Set WebGrid's properties AllowEdit to true

Using designer

  1. Right click on WebGrid and click on WebGrid.Net Designer.
  2. Go to Advanced tab >> RootTable >> Columns.
  3. Set focus to BirthDate's column and find Editing Expandable panel.
  4. Change TextBox to CalenderCombo.
  5. Click Apply >> OK.
  6. The picture will be like this.

  7. Finally, compile and run the project. The WebForm should be displayed like the following snapshot:

See Also

Tasks
Walkthrough: Using MultiLine TextBox
Walkthrough: Using CheckBox
Walkthrough: Using Calendar DropDown
How-to: Perform Bulk Update on a Button Click event
How-to: Use DropDownList as EditType of a WebGridColumn

References
AllowEdit Property
EditType Property

Other Resources
Walkthrough Topics
How-to Topics


Walkthrough: Adding RowChecker column in WebGrid

Walkthrough: Adding RowChecker column in WebGrid
See Also Send Feedback

Glossary Item Box

This walkthrough shows you how to Add RowChecker column in WebGrid.

During this walkthrough, you will learn how to do the following :

  • Add a new column and set the column to RowChecker

Prerequisites

In order to complete this walkthrough, you will need the following:

  • Access to the Microsoft Access Northwind database.
  • Visual Studio 2005/2008/2010 Application.

Step-By-Step Instructions

To create new web application and set row checker using designer.

  1. Bind WebGrid to AccessDataSource.
  2. Set WebGrid's properties AllowEdit to true.
  3. Right click on WebGrid and click on WebGrid.Net Designer.
  4. Go to Popular Settings >> See all properties.
  5. Set PersistRowChecker to True.
  6. Go to Advanced tab - RootTable - Columns
  7. Click Add (to add a new column).
  8. Set focus to Layout expandable panel, checked "Is row checker column" checkbox.
  9. Click Apply and OK.
  10. The picture will look like the following.

  11. Finally, compile the project by pressing Ctrl+Shift+B and run the WebForm.

    The WebForm will look like the following snapshot:

See Also

Tasks
Walkthrough: Adding RowChecker in GroupRow
How-to: Persist row checker during PostBack
How-to: Get checked rows in server side
How-to: Get checked rows in client side

References
IsRowChecker Property
PersistRowChecker Property

Other Resources
Walkthrough Topics
How-to Topics


Walkthrough: Loading child rows on demand based on the selected parent row

Walkthrough: Loading child rows on demand based on the selected parent row
See Also Send Feedback

Glossary Item Box

This walkthrough shows you how to implement LoadOnDemand in Hierarchical table.

During this walkthrough, you will learn how to do the following:

  • Use ISDataSource control.
  • Use WebGrid and ISDataSource SmartTag.
  • Implement LoadOnDemand.

Prerequisites

In order to complete this walkthrough, you will need the following:

  • Access to the Microsoft Access Northwind database.
  • Visual Studio 2005/2008/2010 Application.

Step-By-Step Instructions

To create new web application and set LoadOnDemand using ISDataSource properties

  1. Bind WebGrid to ISDataSource.
  2. Add Query by double click on dsNorthWind.xsd in App_Code then right click on the Orders.
  3. In TableAdapter Query Configuration Wizard, choose Use SQL Statements, click Next.
  4. Then choose Select which returns rows, click Next.
  5. Specify this query "SELECT CustomerID, EmployeeID, Freight, OrderDate, OrderID, RequiredDate, ShipAddress, ShipCity, ShipCountry, ShipName, ShipPostalCode, ShipRegion, ShipVia, ShippedDate FROM Orders WHERE (CustomerID = ?)" then click Next.

  6. Set Fill a DataTable method name to FillBy and Return a DataTable method name to GetDataBy.

  7. Click Next - Finish.

  8. Set ISDataSource properties.

    Property | Value
    LoadOnDemand | True
    EnableCaching | Yes

  9. Open ISDataSource Designer

    Property | Value
    SelectChildRowMethod | GetDataBy

See Also

Other Resources
Walkthrough Topics
How-to Topics


Walkthrough: Creating ColumnSet layout in WebGrid

Walkthrough: Creating ColumnSet layout in WebGrid
See Also Send Feedback

Glossary Item Box

This walkthrough shows you how to creating ColumnSet in WebGrid.

During this walkthrough, you will learn how to do the following :

  • Bind WebGrid to datasource.
  • Create ColumnSet in WebGrid.

Prerequisites

In order to complete this walkthrough, you will need the following:

  • Access to the Microsoft Access Northwind database.
  • Visual Studio 2005/2008/2010 Application.

Step-By-Step Instructions

To create new web application and create a ColumnSet in WebGrid

  1. Bind WebGrid to AccessDataSource.
  2. Right-click on WebGrid and click on WebGrid.Net Designer.
  3. Go to Advanced tab >> RootTable.
  4. In RowLayout Expandable panel, choose ColumnSet and Click Design ColumnSet button.

  5. Click "Add ColumnSet" twice (add 2 ColumnSets).
  6. Set focus to the first ColumnSet and set the Caption to Customer Information.
  7. Set focus to the second ColumnSets and set the Caption to Customer Address.
  8. Set the first and second HeaderAlignment to Center
  9. Click ColumnSet Designer and set like the picture below

  11. To merge the Company or Country Column to one row, set the ColSpan to 3.
  12. Click OK and run the project.

See Also

Tasks
Walkthrough: Configuring multiline row in ColumnSet layout
How-to: Display a ColumnSet layout hierarchically
How-to: Create ColumnSet layout programmatically
How-to: Create ColumnSet layout when IList object is bound to WebGrid

References
ColumnSetSettings Class
WebGridColumnSet Class

Concepts
ColumnSets Layout

Other Resources
Walkthrough Topics
How-to Topics


Walkthrough: Updating the changes in WebGrid to physical Database

Walkthrough: Updating the changes in WebGrid to physical Database
See Also Send Feedback

Glossary Item Box

This walkthrough shows you how to update the changes in WebGrid to physical Database.

During this walkthrough, you will learn how to do the following :

  • Bind WebGrid to DataSource.
  • Update WebGrid's changes to physical Database.

Prerequisites

In order to complete this walkthrough, you will need the following:

  • Access to the Microsoft Access Northwind database.
  • Visual Studio 2005 Application.

Step-By-Step Instructions

  1. Launch Visual Studio.NET 2005.
  2. Click on File menu, then select New and click Web Site.
  3. Select ASP.NET Web Site in the Template box and set Location to HTTP.
  4. Named the Web Site and click OK.
  5. Right-click on Project's name and select Add New Item.
  6. Select Intersoft AppForm in the My Templates box and named it as Walkthrough.aspx.
  7. Drag WebGrid instance from ToolBar to WebForm.
  8. In the Solution Explorer, right-click on App_Data and select Add Existing Item.
  9. Browse and add NorthWind.mdb in C:\Program Files\Intersoft Solutions\Data (Default installation folder).
  10. Click the SmartTag on the upper right of the WebGrid.
  11. In Choose Data Source field, choose <New data source...>.

  12. In Data Source Configuration Wizard, choose AccessDatabase and click OK.

  13. Browse and select the database in App_Data (NorthWind.mdb) and click OK.

  14. Select the table that you want to use and click Next.

  15. Click Advanced button, check Generate INSERT, UPDATE and DELETE statement.

  16. In this step, you can view the table's database using Test Query button. Otherwise, click Finish to proceed to the next step.
  17. Finally, choose Retrieve Structure action in Connected to Data Source Control Wizard and click OK to apply all settings.

  18. Specify WebGrid to Allow Editing, Allow Add New, and Allow Delete from WebGrid SmartTag.

  19. Run the project and the WebGrid will look like following.

WebGrid.NET Enterprise 5.0 does not require codes anymore during updating, inserting or deleting when the WebGrid is bound to one of the supported DataSource control.

See Also

Tasks
Walkthrough: Updating footer when loading data on demand
How-to: Update or delete a row on button click
How-to: Reconfigure the "Enter" key functions on EditMode
How-to: Calculate a cell after a value is filled
How-to: Maintain the new row's value when there is error during adding action

Other Resources
Walkthrough Topics
How-to Topics


Walkthrough: Allowing Export in WebGrid

Walkthrough: Allowing Export in WebGrid
See Also Send Feedback

Glossary Item Box

This walkthrough shows you how to allow Export in WebGrid.

During this walkthrough, you will learn how to do the following:

  • Bind grid using AccessDatasource.
  • Set AllowExport to allow Export in grid to allow the export mode in grid.

Prerequisites

In order to complete this walkthrough, you will need the following:

  • Visual Studio 2005 Application.

Step-By-Step Instructions

  1. Binding WebGrid to AccessDataSource.
  2. Go to WebGrid Designer.
  3. Set the AllowExport to true.

  5. Click OK to apply all settings.
  6. Compile and run the WebForm.

    ExportResult

See Also

Tasks
How-to: Invoke Export feature programmatically
How-to: Customize Export function
How-to: Export text when WebValueList is used
How-to: Use CacheToDisk feature to reduce memory usage
How-to: Set a different location for CacheToDisk feature

References
DynARInfo Class
AllowExport Property

Other Resources
Walkthrough Topics
How-to Topics


Walkthrough: Integrating WebInput in WebGrid

Walkthrough: Integrating WebInput in WebGrid
See Also Send Feedback

Glossary Item Box

This walkthrough shows you that WebGrid.NET can be integrated with WebInput.NET as a custom editor. This integration can be specified using WebGrid.NET Designer or programmatically in runtime.

During this walkthrough, you will learn how to do the following:

  • Bind WebGrid by using AccessDatasource.
  • Configuring the WebGrid designer to include the WebInput into WebGrid.

Prerequisites

In order to complete this walkthrough, you will need the following:

  • Access to the Microsoft Access Northwind database.
  • Visual Studio 2005/2008/2010 Application.

Step-By-Step Instructions

To create new web application and integrate WebInput into WebGrid.

  1. Bind WebGrid to AccessDataSource.
  2. Drag a WebInput instance to the webform.
  3. Open WebGrid designer then choose an appropriate column you want to include the WebInput control into.
  4. Set the Edit Control Type to WebInput.NET then choose the WebInput instance.

    WIDesigner

See Also

Concepts
Intersoft WebInput.NET Integration

References
EditType Property

Other Resources
Walkthrough Topics
How-to Topics


Walkthrough: Changing the default Localization Text in Localization Manager

Walkthrough: Changing the default Localization Text in Localization Manager
See Also Send Feedback

Glossary Item Box

This walkthrough shows you how to change the default Localization Text in Localization Manager.

During this walkthrough, you will learn how to do the following:

  • Bind WebGrid to datasource
  • Change the default Localization Text in Localization Manager

Prerequisites

In order to complete this walkthrough, you will need the following:

  • Access to the Microsoft Access Northwind database.
  • Visual Studio 2005 Application.

Step-By-Step Instructions

To change the default localization text in Localization Manager

  1. Right click on WebGrid and click on WebGrid.Net Designer.
  2. Go to Localization Manager tab.
  3. Set the Language Mode to Default (en-US).
  4. Click Manage Language Files.
  5. Set Focus to CommonText in TextSetting Items.
  6. Change "Ready." to "Start." then Enter.
  7. Click OK to apply the changes.
  8. The picture will be like this.

  9. Finally, compile and run the project. The WebGrid will look like the following snapshot (see the footer word, already changed to "Start...").

See Also

Tasks
Walkthrough: Using French culture in WebGrid
Walkthrough: Specifying custom language used in WebGrid
How-to: Specify the Localization folder in web.config
How-to: Specify a TextItem programmatically

Concepts
Localization Manager

References
TextSettings Class
LocalizationFolder Property
Language Property

Other Resources
Walkthrough Topics
How-to Topics


Walkthrough: Using French culture in WebGrid

Walkthrough: Using French culture in WebGrid
See Also Send Feedback

Glossary Item Box

This walkthrough shows you how to Using French culture in WebGrid.

During this walkthrough, you will learn how to do the following :

  • Bind WebGrid to datasource
  • Change the WebGrid's culture to French

Prerequisites

In order to complete this walkthrough, you will need the following:

  • Access to the Microsoft Access Northwind database.
  • Visual Studio 2005 Application.

Step-By-Step Instructions

To use French culture in WebGrid

  1. Right click on WebGrid and click on WebGrid.Net Designer.
  2. Go to Localization Manager tab.
  3. Set the Language Mode to Inherit from Culture.
  4. Click OK to apply the changes.
  5. The picture will be like this.

  7. Now, Right Click on WebGrid to open WebGrid.NET Designer.
  8. Set focus to Popular Settings - Click See all properties and find Culture property.
  9. Set Culture to French (French).
  10. The picture will be like this.

  11. Finally, compile and run the project. The WebGrid will look like the following snapshot:

See Also

Tasks
Walkthrough: Changing the default Localization Text in Localization Manager
Walkthrough: Specifying custom language used in WebGrid
How-to: Specify the Localization folder in web.config
How-to: Specify a TextItem programmatically

Concepts
Localization Manager

References
TextSettings Class
Culture Property
Language Property

Other Resources
Walkthrough Topics
How-to Topics


Walkthrough: Specifying custom language used in WebGrid

Walkthrough: Specifying custom language used in WebGrid
See Also Send Feedback

Glossary Item Box

This walkthrough shows you how to specify custom language used in WebGrid.

During this walkthrough, you will learn how to do the following :

  • Bind WebGrid to datasource.
  • Custom your own language in WebGrid.

Prerequisites

In order to complete this walkthrough, you will need the following:

  • Access to the Microsoft Access Northwind database.
  • Visual Studio 2005 Application.

Step-By-Step Instructions

To specify custom language

  1. Right click on WebGrid and click on WebGrid.Net Designer.
  2. Go to Localization Manager tab.
  3. Set the Language Mode to Default (en-US).
  4. Click Manage Language Files.
  5. Set Focus to CommonText in TextSetting Items.
  6. Change "Ready." to "WebGrid is ready" then Enter.
  7. Click OK to apply the changes.
  8. The picture will be like this.

  9. Finally, compile and run the project. The WebGrid will look like the following (see the footer word, already changed to "WebGrid is ready").

See Also

Tasks
Walkthrough: Changing the default Localization Text in Localization Manager
Walkthrough: Using French culture in WebGrid
How-to: Specify the Localization folder in web.config
How-to: Specify a TextItem programmatically

Concepts
Localization Manager

References
TextSettings Class
Language Property

Other Resources
Walkthrough Topics
How-to Topics


Walkthrough: Using Preview Row in WebGrid

Walkthrough: Using Preview Row in WebGrid
See Also Send Feedback

Glossary Item Box

This walkthrough shows you how to set preview row in WebGrid.

During this walkthrough, you will learn how to do the following:

  • Bind WebGrid using AccessDatasource.
  • Set Preview Row Settings properties to allow preview row in WebGrid.

Prerequisites

In order to complete this walkthrough, you will need the following:

  • Visual Studio 2005/2008/2010 Application.

Step-By-Step Instructions

To create new web application and specify PreviewRow in WebGrid.

  1. Bind WebGrid to AccessDataSource.
  2. Open WebGrid Designer.
  3. Go to Advanced tab, RootTable
  4. Check the Enable Preview Row checkbox.
  5. Check the Expandable property.
  6. Set DataMember to a column name you want set as the preview row.

    PreviewRow

  7. Click OK to apply all settings.
  8. Compile and run the WebForm.
    PrevRow

See Also

Tasks
How-to: Retrieve Preview Row's text

Concepts
Preview Row

References
DataMember Property
Expandable Property
PreviewRowSettings Class

Other Resources
Walkthrough Topics
How-to Topics


Walkthrough: Creating Self Reference WebGrid

Walkthrough: Creating Self Reference WebGrid
See Also Send Feedback

Glossary Item Box

This walkthrough shows you how to create Self Reference in WebGrid.

During this walkthrough, you will learn how to do the following:

  • Bind WebGrid to AccessDatasource.
  • Use Self Reference Settings properties in a grid to specify the Self Reference.

Prerequisites

In order to complete this walkthrough, you will need the following:

  • Visual Studio 2005/2008/2010 Application.

Step-By-Step Instructions

To create new web application and specify Self Reference in WebGrid.

  1. Bind WebGrid to AccessDataSource.
  2. Open WebGrid.NET Designer.
  3. Go to Advanced tab and select RootTable.
  4. Check the Enable Self Referencing checkbox.
  5. Set Child Data Member to ReportsTo.
  6. Set Parent Data Member to EmployeeID.
  7. Set Expand Column Member to FirstName.

    SelfRefDesigner

  8. Click OK to close the window and run the application.

    SelfRef

See Also

Tasks
Walkthrough: Creating Self Reference LoadOnDemand WebGrid
How-to: Remove (+) sign for Self Reference LoadOnDemand rows that contain no Child Row

References
SelfReferencingSettings Class
ChildDataMember Property
Enabled Property
ExpandColumnMember Property
ParentDataMember Property

Other Resources
Walkthrough Topics
How-to Topics


More Walkthrough Topics

More Walkthrough Topics
See Also Send Feedback
Intersoft WebGrid > Getting Started > Samples and Walkthroughs > WebGrid Walkthroughs > More Walkthrough Topics

Glossary Item Box

To learn more about WebGrid's advanced features, please see Complete Walkthrough Topics.

See Also

Overview
Getting Started
WebGrid Features Overview

Other Resources
Walkthrough Topics
How-to Topics


What's New in WebGrid 9

What's New in WebGrid 9
Send Feedback
Intersoft WebGrid > What's New in WebGrid 9

Glossary Item Box

Intersoft WebGrid Enterprise gives you most powerful DataGrid component for ASP.NET Web development, with a host of innovative features that allows the control to display large data in highly efficient manner. WebGrid provides comprehensive Grid functionalities enabling enterprise-class information to be delivered in hierarchical layout with sophisticated user interactions, allowing users to work with the information in a more effective and productive way.

In version 9, WebGrid delivered some enhancements and features that might be useful for some of your scenarios.

The following list details show new enhancements introduced in WebGrid 9.

  • Improved reliability in column rendering and resizing when displaying hierarchical data.
  • WebGrid 9 now gracefully renders and adjusts the width column in all major browsers.
  • WebGrid now supports more special characters during data row manipulation.
  • Print data immediately as you see it with the new direct print feature.
    When turn on this feature, 'Print' icon would be available in status bar.

  • Provides new client API
  • WebGrid now has better support for JavaScript-based operations, such as selecting group rows and copy-pasting multiple rows.

  • Copy-paste multiple rows via javascript for BatchUpdate scenario
  • During copy-paste operation, WebGrid now supports value handling better.

  • You can now search by text to perform data filter in ValueList scenario

For more information about WebGrid's features, see WebGrid Features Overview.


How-to: Enable HTML5 Rendering Mode

How-to: Enable HTML5 Rendering Mode
See Also Send Feedback
Intersoft WebGrid > What's New In WebGrid 9 > How-to: Enable HTML5 Rendering Mode

Glossary Item Box

This topic explains how to configure WebGrid to emit HTML5 compliance output.

Configure Doc Type

Each doctype declaration in HTML specification produces different results and behaviors, mostly in the layout and rendering aspects. WebGrid supports most commonly used doctype and automatically adjust the behaviors and rendering results by detecting the doctype declaration of the HTML page.

In version 8, WebGrid has been significantly enhanced to deliver consistent behaviors and layout in HTML5 pages. All features should work exactly as in other doctype.

To enable HTML5 support in WebGrid, make sure you have configured the HTML pages to use the proper doctype. The standard doctype for HTML5 is <!DOCTYPE html>.

The following code example shows how to use WebGrid in a simple WebForm using HTML5 doctype.

ASPX Copy Code
<%@ Page Language="C#" AutoEventWireup="true" CodeFile="Default.aspx.cs" Inherits="cs_WebGrid_Default" %>
<%@ Register Assembly="ISNet.WebUI.WebGrid" Namespace="ISNet.WebUI.WebGrid" TagPrefix="ISWebGrid" %>

<!DOCTYPE html>
<html>
<head runat="server">
    <title></title>
</head>
<body>
    <form id="form1" runat="server">
    <div>
         <ISWebGrid:WebGrid ID="WebGrid1" runat="server" Height="300px" DataSourceID="AccessDataSource1">
         </ISWebGrid:WebGrid>
         <asp:AccessDataSource ID="AccessDataSource1" runat="server" DataFile="~/App_Data/NorthWind.mdb"
             SelectCommand="SELECT TOP 20 * FROM [Orders]"></asp:AccessDataSource>
    </div>
    </form>
</body>
</html>

Note that the xmlns attribute is no longer necessary to be defined in the <html> tag. If you upgraded your existing pages, make sure the xmlns attribute is removed from the <html> tag.

Configure Rendering Mode

To provide the best HTML5 support, WebGrid needs to adjust several features that are commonly processed in the server-side such as markup rendering and AJAX callback response. Unfortunately, the HTML5 doctype cannot be automatically detected by the server-side browser capability. As such, WebGrid introduces a new property called RenderingMode which you must set explicitly in order to activate HTML5 compliance output.

You can set the rendering mode in a WebGrid instance individually by setting the RenderingMode property to HTML5 value, such as shown in the example below.

ASPX Copy Code
<ISWebGrid:WebGrid ID="WebGrid1" runat="server" RenderingMode="HTML5">
</ISWebGrid:WebGrid>

Alternatively, you can also apply the rendering mode globally through the application-wide configuration, see the following example.

Web.config Copy Code
<add key="ISNet.WebUI.WebGrid.v8_0_7200.RenderingMode" value="HTML5"/>
If your project is exclusively targeting HTML5, it's recommended to use application-wide configuration to apply the rendering mode to all WebGrid instances in the project.

For more information about application-wide settings in WebGrid, see Application Wide Configurations.

See Also

Release History
Features Added in WebGrid 8

Other Resources
Walkthrough Topics
How-to Topics


How-to: Select a GroupRow in WebGrid

How-to: Select a GroupRow in WebGrid
Send Feedback

Glossary Item Box

This topic will show you how to select a group row by using javascript.

To Select a GroupRow in WebGrid:

  1. Please ensure WebGrid in Grouping mode.
  2. Add the following javascript codes in a button click.
    Code Copy Code
    function SelectGroupRow()
{
    var grid = ISGetObject("WebGrid1");
    var rootTable = grid.RootTable;
    var rows = rootTable.GetGroupRows();
    var rowObj = rootTable.ToRowObject(rows[0]); //Select the first index
    grid.RootTable.SelectRow(rowObj);
}
  3. Compile and run the project


How to: Copy Paste Multiple Rows via Javascript

How to: Copy Paste Multiple Rows via Javascript
Send Feedback

Glossary Item Box

This topic will show you how to copy multiple rows and paste them in new rows via button click.

To Copy Multiple Rows in WebGrid:

  1. Please ensure you set AllowMultipleSelection 'Yes' in WebGrid.
  2. Add the following javascript codes in button click.
    Code Copy Code
    function CopySelection()
{
    var grid = ISGetObject("WebGrid1");
    var rows = grid.RootTable.GetCheckedRows();
    if (rows.length == 0)
        alert("Please select row(s)")
    else
        grid.CopyMultipleRows();
}
  3. Add the following javascript codes in another button click.
    Code Copy Code
    function PasteSelection()
{
    var grid = ISGetObject("WebGrid1");
    grid.PasteMultipleRows();
}
  4. Run the sample. Select some rows in WebGrid and click Button click for Copy.
  5. Then, click another button click thats for Paste. Notice that the new rows has been automatically added in WebGrid.
This condition can only be used in Batch Update scenario


Walkthrough Topics

Walkthrough Topics
See Also Send Feedback
Intersoft WebGrid > Walkthrough Topics

Glossary Item Box

This topic provides the links to walkthroughs that demonstrate how to implement the features available in WebGrid, and how to customize the behaviors through the means of programmatic APIs and events.

Displaying Data

Walkthrough: Binding WebGrid to AccessDataSource control

Walkthrough: Binding WebGrid to ObjectDataSource control

Walkthrough: Binding WebGrid to XMLDataSource control

Walkthrough: Binding WebGrid to IList DataSource

Walkthrough: Configuring updatable WebGrid bound to ObjectDataSource control

Walkthrough: Binding WebGrid to custom object

Walkthrough: Binding WebGrid to a DataSource at RunTime

Walkthrough: Binding WebGrid to XML-based DataSource

Walkthrough: Binding WebGrid to IList DataSource

Walkthrough: Binding WebGrid with SQL Server 2000 Tables

Walkthrough: Binding WebGrid with a XSD schema and a XML file data

Walkthrough: Binding WebGrid to custom object

Walkthrough: Creating unbound WebGrid with Hierarchical enabled

Walkthrough: Binding WebGrid to Hierarchical ISDataSource control

Walkthrough: Configuring updatable WebGrid bound to ISDataSource control

Walkthrough: Loading child rows on demand based on the selected parent row

Walkthrough: Creating Self Reference WebGrid

Walkthrough: Creating Self Reference LoadOnDemand WebGrid

Walkthrough: Configuring client-binding using ServerDataSource mode

Walkthrough: Configuring client-binding using WebService mode

Walkthrough: Configuring client-binding using WcfService mode

Walkthrough: Configuring WebService client-binding to return paged data

Walkthrough: Configuring client-binding using AdoDataService mode

Walkthrough: Using WebGrid in unbound mode

Walkthrough: Applying Late Binding Hierarchical

Walkthrough: Binding WebGrid to ISLinqDataSource

Sorting Data

Walkthrough: Applying custom sorting in WebGrid

Walkthrough: Enabling Sorting, Grouping and Filtering

Grouping Data

Walkthrough: Using Group Intervals in WebGrid

Walkthrough: Enabling Sorting, Grouping and Filtering

Filtering Data

Walkthrough: Applying custom filtering in WebGrid

Walkthrough: Using DropDownList in Filter Row

Walkthrough: Using cookie to save FilterRow values

Walkthrough: Enabling Sorting, Grouping and Filtering

Editing Data

Walkthrough: Updating the changes in WebGrid to physical Database

Walkthrough: Configuring Updatable WebGrid in Batch Update mode (Using DataSet Binding)

Walkthrough: Configuring Updatable WebGrid in Batch Update mode (Using Declarative Datasource Control)

Walkthrough: Creating Updatable Hierarchical WebGrid in Batch Update mode (Using DataSet Binding)

Walkthrough: Creating Updatable Hierarchical WebGrid in Batch Update mode (Using ISDataSource)

Walkthrough: Creating Updatable WebGrid using DataTable

Walkthrough: Creating Updatable Hierarchical WebGrid using DataSet

Walkthrough: Creating Updatable WebGrid using ObjectDataSource

Walkthrough: Creating Updatable Hierarchical WebGrid using ISDataSource

Walkthrough: Creating Updatable WebGrid using Custom Object

Walkthrough: Adding pending changes to WebGrid programmatically

Walkthrough: Using MultiLine TextBox

Walkthrough: Using CheckBox

Walkthrough: Using Calendar DropDown

Walkthrough: Using Calendar Combo

Walkthrough: Using SliderBar Custom Editor in WebGrid

Walkthrough: Using HTMLEditor Custom Editor in WebGrid

Walkthrough: Using Calculator Custom Editor in WebGrid

Walkthrough: Using NumericUpDown Custom Editor in WebGrid

Walkthrough: Integrating WebCombo in WebGrid

Walkthrough: Configuring multiple values editing using WebCombo.NET 4.0 control in WebGrid

Walkthrough: Integrating WebInput in WebGrid

Walkthrough: Adding new data where a column's data type is AutoNumber

Walkthrough: Modifying WebGrid records externally

Walkthrough: Enabling Transactions (Add/Edit/Delete)

Exporting Data

Walkthrough: Allowing Export in WebGrid

Aggregating Data

Walkthrough: Enabling Aggregate Computation

Walkthrough: Using Custom Aggregate function in WebGrid

Walkthrough: Displaying GroupTotal of child table

Layouting

Walkthrough: Creating ColumnSet layout in WebGrid

Walkthrough: Configuring multiline row in ColumnSet layout

Walkthrough: Configuring a WebGridColumn to use Templated Cell

Walkthrough: Using Preview Row in WebGrid

Walkthrough: Configuring WebGrid to load PreviewRow on demand

Pivot Charting

Walkthrough: Applying lighting effect to 3D chart types

Walkthrough: Applying projection to 3D chart types

Paging Data

Walkthrough: Enabling Paging

Walkthrough: Setting Virtual Load in WebGrid

Walkthrough: Updating footer when loading data on demand

Walkthrough: Implementing Custom Paging using ObjectDataSource

Walkthrough: Implementing Custom Paging using ISDataSource

Walkthrough: Loading child rows on demand based on the selected parent row

Customizing Data

Walkthrough: Using Column Types

Walkthrough: Utilizing button ColumnType

Walkthrough: Utilizing various ColumnTypes

Walkthrough: Using CheckBox column in Hierarchical WebGrid

Walkthrough: Deleting a record using WebGrid button

Walkthrough: Configuring password as ColumnType

Walkthrough: Binding a WebValueList to a table defined in ISDataSourceControl

Walkthrough: Binding a WebValueList to different DataSource control

Walkthrough: Configuring the WebValueList of a WebGridColumn to translate multiple values data

Walkthrough: Configuring automatic column sorting for a column using WebValueList

Customizing UI

Walkthrough: Adding RowChecker column in WebGrid

Walkthrough: Adding RowChecker in GroupRow

Walkthrough: Changing the default Localization Text in Localization Manager

Walkthrough: Using French culture in WebGrid

Walkthrough: Specifying custom language used in WebGrid

Programming with Client-side API

Walkthrough: Hiding certain columns programmatically

Walkthrough: Using client side events

Walkthrough: Using OnCellClick and OnRowSelect events in NewRow

Walkthrough: Modifying ColumnFooters style using client side programming

Walkthrough: Using client side programming to modify FilterText

Walkthrough: Modifying other cell values on client side

Walkthrough: Modifying AllowEdit and AllowDelete attributes using client side programming

Walkthrough: Changing 'Enter' key behavior

Walkthrough: Maintaining scroll position

Walkthrough: Configuring Hierarchical CheckBox behavior

Walkthrough: Sending data to server using OnTheFlyPostBack architecture

Programming with Server-side API

Walkthrough: Configuring Hierarchical CheckBox behavior

Walkthrough: Configuring Updatable WebGrid in Batch Update mode (Using Declarative Datasource Control)

Optimizing Performance

Walkthrough: Configuring WebGrid to keep data cache in local computer's hard drive

Walkthrough: Using ExpandChildRow to expand child tables

Walkthrough: Using WebGrid with ASP.NET AJAX RTM

Walkthrough: Using WebGrid with WebFlyPostBackManager

See Also

Overview
Getting Started
WebGrid Features Overview

Other Resources
Walkthrough Topics
How-to Topics


How-to Topics

How-to Topics
See Also Send Feedback
Intersoft WebGrid > How-to Topics

Glossary Item Box

This topic lists the how-to and FAQ topics of WebGrid and describes how to implement the wide range of WebGrid features in your ASP.NET projects.

Displaying Data

How-to: Hide (+) sign in hierarchical mode

How-to: Bind WebGrid after PostBack (Late Binding)

How-to: Remove (+) sign for Self Reference LoadOnDemand rows that contain no Child Row

How-to: Display Self-Referencing Hierarchical Data

How-to: Sort Self-Referencing Child data

How-to: Implement Classic Paging in Client Binding

How-to: Bind client-binding to Client DataSource

How-to: Use Batch Update Client Binding

How-to: Enable Virtual Group Row Paging

How-to: Preload Group Totals with VirtualLoad Paging

How-to: Remove (+) sign for rows that do not contain child row

How-to: Display Hierarchical data in TreeView mode

Sorting Data

How-to: Sort Column Initially

How-to: Disable automatic sort in a specific table

How-to: Perform sorting data and apply multiple sorting in WebGrid

How-to: Set SortAscImage and SortDescImage to Images located in root application directory

Grouping Data

How-to: Group column initially

How-to: Perform grouping and ungrouping in WebGrid

How-to: Hide/Show the grouped column when the column is grouped

How-to: Change the format of GroupRowInfo

How-to: Display group by box

How-to: Customize Group Intervals

Filtering Data

How-to: Filter column initially

How-to: Disable automatic filter in a specific table

How-to: Use 'Enter' key to filter data

How-to: Perform filtering data and hide Filter Bar in WebGrid

How-to: Filter invisible column

How-to: Add and remove Filtered Column programmatically

How-to: Use WebCombo as Filter Editing Control

How-to: Enable Automatic Filter suggestion

Editing Data

How-to: Implement custom Editing Form

How-to: Perform adding a new row

How-to: Perform editing a row

How-to: Display an alert message before adding, deleting or updating a row

How-to: Customize Keyboard Support for Data Editing

How-to: Customize Row Lost Focus Action

How-to: Disable Editing in certain columns

How-to: Set default text for specific columns

How-to: Prevent empty data input

How-to: Reconfigure the 'Enter' key functions on EditMode

How-to: Maintain the new row's value when there is error during adding action

How-to: Display CallOut Notification during Batch Update

How-to: Use Custom Object with Batch Update

How-to: Get pending changes based on row state

How-to: Get all pending changes in WebGrid

How-to: Get pending changes on specific table

How-to: Undo changes on specific row

How-to: Accept all changes

How-to: Perform Bulk Update on a Button Click event

How-to: Use DropDownList as EditType of a WebGridColumn

How-to: Configure a column to use ResizableTextBox editing type

How-to: Integrate Linked WebCombo in WebGrid

How-to: Use WebTextEditor custom editor

How-to: Enable required input validation for a column

Exporting Data

How-to: Perform exporting data

How-to: Invoke Export feature programmatically

How-to: Trigger Data Export in Client-Side Programmatically

How-to: Customize Export function

How-to: Export text when WebValueList is used

How-to: Use CacheToDisk feature to reduce memory usage

How-to: Set a different location for CacheToDisk feature

Formatting Data

How-to: Change the format of GroupRowInfo

How-to: Set masked formatting to a cell

How-to: Create FormatConditions in a specific row and cell

How-to: Use CustomConditionText in FormatConditions

Aggregating Data

How-to: Show group total for a specific table

How-to: Enable Group Footer

How-to: Hide/Show the column footers

How-to: Use Column Aggregation

How-to: Use avg aggregate in group header

Layouting

How-to: Set WebGrid's row layout

How-to: Resize a column

How-to: Persist row checker during PostBack

How-to: Hide/Show the table header

How-to: Hide/Show the ColumnSet layout's headers

How-to: Remove the gridlines

How-to: Set AutoWidth and AutoHeight in WebGrid

How-to: Display a ColumnSet layout hierarchically

How-to: Create ColumnSet layout programmatically

How-to: Create ColumnSet layout when IList object is bound to WebGrid

How-to: Autofit all columns in WebGrid

How-to: Set one of the columns as AutoWidth while the others fit the WebGrid

How-to: Retrieve Preview Row's text

Pivot Charting

How-to: Enable Pivot Charting in WebGrid

How-to: Hide Chart Ribbon Initially

How-to: Customize Chart Ribbon

How-to: Customize Pivot Rules

How-to: Customize Available Chart Types

How-to: Customize Pivot Chart User Interface

How-to: Show Pivot Chart view initially

How-to: Display Pivot Chart only

How-to: Display both Pivot Chart and Grid View

How-to: Move Pivot Chart view to another container using WebTab

How-to: Set Pivot Chart's container to fit browser's width and height

How-to: Customize list of Chart Types

How-to: Customize Pivot Chart View

How-to: Demonstrate the bounds mode effect

How-to: Change the chart background appearance

How-to: Invert the chart axis value

How-to: Change the label orientation mode

How-to: Change the position of the chart legend

How-to: Change the layout of the chart legend

How-to: Change the chart title/header position in the chart image

How-to: Configure Pivot Chart Header and Legend

How-to: Change the chart wall style appearance

Paging Data

How-to: Enable load more data

How-to: Retrieve a different VirtualPageSize on a specific condition

How-to: Implement custom Virtual Load

How-to: Customize VirtualLoad Paging Size

How-to: Use VirtualLoad in Large Data

How-to: Implement Custom Load-On-Demand Paging

How-to: Customize Classic Paging Interface

How-to: Enable Pivot Chart Both View with Classic Paging

How-to: Export all data when Classic Paging is enabled

Customizing Data

How-to: Programmatically set WebValueList's DataSource

How-to: Enable Column Grouping with WebValueList

Customizing UI

How-to: Move a column

How-to: Allow select/deselect columns

How-to: Select a cell on mouse click

How-to: Display HourGlass when the Grid is in progress

How-to: Specify a different Help URL

How-to: Specify the location of image folder

How-to: Hide/Show the row headers

How-to: Hide/Show the refresh button

How-to: Hide/Show the treelines

How-to: Hide/Show the column headers

How-to: Hide the help button

How-to: Hide/Show status bar

How-to: Display context menu in WebGrid

How-to: Customize Filter context menu

How-to: Add/Remove a menu in WebGrid's context menu

How-to: Add a SubMenu in WebGrid's context menu

How-to: Use WebContextMenu as WebGrid's context menu

How-to: Persist row checker during PostBack

How-to: Get checked rows in server side

How-to: Get checked rows in client side

How-to: Specify the Localization folder in web.config

How-to: Specify a TextItem programmatically

How-to: Enable column freezing and configure initial settings

How-to: Allow user to freeze/unfreeze at runtime

How-to: Change splitter line's appearance

How-to: Enable absolute scrolling

How-to: Customize Column Freezing

How-to: Enable Default Style for existing instance of WebGrid

How-to: Access the selected rows in client side and server side

How-to: Enable Multiple Row Selection with Keyboard Support

How-to: Use ButtonImage column type and assign the Image of the Button

How-to: Enable Column Action

How-to: Add new menu items in Column Action

How-to: Set BrowserPrinterSettings

Programming with Client-side API

How-to: Copy Paste Multiple Rows via Javascript

How-to: Select a GroupRow in WebGrid

How-to: Add and remove Filtered Column programmatically

How-to: Hide/Show WebGrid

How-to: Reconfigure the 'Enter' key functions on EditMode

How-to: Calculate a cell after a value is filled

How-to: Open a new window that contains details of a selected row using OnButtonClick

How-to: Display the selected cell's text using OnCellSelect

How-to: Enable Cell Editing when the CheckBox is Checked Using OnCheckBoxClick

How-to: Disable a child table's column in a specific row using OnChildRowExpand

How-to: Prevent grouping on specific columns using OnColumnGroup

How-to: Validate input (number only) in a cell using OnEditKeyDown

How-to: Get the column's name when editing a cell using OnEnterEditMode

How-to: Modify other cell's value based on the selected value using OnExitEditMode

How-to: Display Delete menu item in WebGrid's context menu when in a specific row using OnRowContextMenu

How-to: Get KeyValue of selected row using OnRowSelect

How-to: Validate that a selected column cannot be empty when adding a new row using OnRowValidate

How-to: Use Basic Client APIs

How-to: Use Hierarchical Client APIs

How-to: Use Self-Reference Client APIs

How-to: Extend data editing with Client-Side APIs

How-to: Get Grid object

How-to: Get Selected row

How-to: Get row by index

How-to: Get row by KeyValue

How-to: Get a cell by index

How-to: Get a cell by name

How-to: Get a specific cell's text of a selected row

How-to: Get the row's KeyValue

How-to: Set the column's best fit

How-to: Get a column name of the selected cell

How-to: Set text to a specific cell

How-to: Trigger OnTheFlyPostBack for client side

How-to: Clear selected object

How-to: Refresh the Grid's data

How-to: Activate edit mode in a specific cell

How-to: Exit edit mode from a button click

How-to: Show/Hide Grid from client side

How-to: Set a default value in new row from a button click

How-to: Select a row from client side

How-to: Get checked rows on button click

How-to: Get parent row's KeyValue

How-to: Update or delete a row on button click

How-to: Expand/collapse child row

How-to: Get root row of ColumnSet layout

How-to: Use HiddenDataMember to get value from hidden column

How-to: Access the selected rows in client side and server side

How-to: Enable v3.5 API Support

Programming with Server-side API

How-to: Enable Cell Editing when the CheckBox is Checked Using OnCheckBoxClick

How-to: Use Custom Object with Batch Update

How-to: Access the selected rows in client side and server side

Styling

How-to: Position WebGrid relative to its container

How-to: Disable alternating color

How-to: Control WebGrid's styles using external CSS definition

How-to: Position WebGrid relative to its container

How-to: Highlight the column header on mouse over

How-to: Set column's horizontal and vertical alignment

How-to: Change the ForeColor of all odd rows

How-to: Change the ForeColor of a cell based on a specific condition

How-to: Set WebGrid cell and header as multiline and word wrap

Optimizing Performance

How-to: Enable XML compression

How-to: Configure SmartWebResources in a new web application

How-to: Disable SmartWebResources for Localization's language files

How-to: Configure FileCacheServer to use shared network's hard drive

How-to: Select a row from server side

How-to: Create WebGrid in Server-Side programmatically

How-to: Set FlyPostBackSettings

How-to: Improve performance

How-to: Optimize cache

How-to: Disable ViewState in WebGrid

How-to: Improve FlyPostBack performance

How-to: Improve performance using designer

See Also

Overview
Getting Started
WebGrid Features Overview

Other Resources
Walkthrough Topics
How-to Topics


Assembly Overview

ISNet.WebUI.WebGrid Assembly
See Also Send Feedback

Glossary Item Box

Namespaces

Namespace | Description
ISNet.WebUI.WebGrid |
ISNet.WebUI.WebGrid.Chart |
ISNet.WebUI.WebGrid.Chart.Settings |


Getting Started - Intersoft WebGrid Documentation

Getting Started
Send Feedback

Glossary Item Box


Introduction - Intersoft WebGrid Documentation

Introduction
Send Feedback

Glossary Item Box


WebGrid Features Overview

WebGrid Features Overview
See Also Send Feedback
Intersoft WebGrid > WebGrid Features Overview

Glossary Item Box

This topic summarizes the common concept and features of WebGrid such as automatic data processing, various editing mode, data management, and rich UI customizations. You will also learn how to use WebGrid such as using the control in data bound mode, customizing the data display and editing behaviors, customizing UI elements, and more.

This topic contains the following sections.

  • Automatic Data Processing
  • Editing Environment
  • Data Management
  • Rich User Interface Elements
  • Advanced User Interactions
  • Learn More

Automatic Data Processing

The full automated WebGrid's data processing allows developers to create a highly functional data presentation's applications in less time and codes. WebGrid provides automatic data processing while performing common Grid operations such as:

  • Column sorting
  • Column grouping/ungrouping/change group order
  • Column filtering
  • Retrieve more data. Applicable when VirtualLoad paging mode is used.
  • Retrieve child tables rows. Applicable when Hierarchical mode is used.

The automated processing works perfectly in combination with other WebGrid's key features such as non-page postback processing, server-side custom event processing, automated data caching, and many others. As of other key features, WebGrid also provides the ability to turn off automatic processing and write your own custom's code. This provides full customization to fit many business requirements.

To enable Automatic Sorting, make sure that AutomaticSort is set to True which is the default value. To allow users to do sorting in client-side, set the AllowSorting property in LayoutSettings to True.

To enable Automatic Filtering, make sure that AutomaticFilter is set to True which is the default value. To allow users to do filtering in client-side, set the AllowFilter property in LayoutSettings to True.

To enable Grouping, simply set the AllowGrouping in LayoutSettings to True.

Setting behavior properties on LayoutSettings will affect all default property in Table's or Column's object. This enables changes to be made globally without has to set each Table's or Column's properties. For more precise control, WebGrid allows child object's properties to override those properties configured in LayoutSettings. This is called property inheritance.

Property inheritance example

This setting affects all WebGrid's hierarchy including all tables and columns to allow sorting.

C# Copy Code
LayoutSettings.AllowSorting = "Yes"

This setting affects all tables to allow sorting, except tblCustomers.

C# Copy Code
LayoutSettings.AllowSorting = "Yes"
tblCustomers.AllowSorting = "No"

This setting affects all tables and columns to allow sorting, except the "FirstName" column of tblCustomers.

C# Copy Code
LayoutSettings.AllowSorting = "Yes"
tblCustomers.Columns.GetNamedItem("FirstName").AllowSorting = "No"

Editing Environment

WebGrid Enterprise is an award-winning ASP.NET data grid control with superior editing features such as in-place cell editing and batch update. Thanks to the Intersoft's OnTheFly AJAX architecture and Microsoft's ADO.NET in-memory architecture, the editing functionality in WebGrid is performed in fraction of seconds with less resource consumption. It completely redefines the Web standards with the advanced editing functionality concept, which renders only the added or modified record and updates to the physical database transparently. This results in great user experiences similar to desktop-based applications that users already familiar with.

The editing functionality can be easily activated by setting the following properties:

  • AllowAddNew property, to enable the display of special row which reside in the top of each table used to enter new data.
  • AllowEdit property, to allow editing directly in the cells.
  • AllowDelete property, to allow deletion of row when the Delete key is pressed.

Additionally, these properties are available in LayoutSettings object as the default and can be overridden in each Table definition. Therefore, you can specify the root table to be editable and no edit for the child tables, and so on.

Another important processing to note is the update to physical database as well as data manipulation in the server-side. Recognizing the various data provided supported in .NET and the different complexity level of business requirements, WebGrid doesn't automatically perform the physical update processing. Instead, it provides custom event handler and leave it for developers to write their own implementation of update codes. The events include OnAddRow, OnUpdateRow and OnDeleteRow. By handling these events, developers can perform physical updates the way they preferred, either by using data adapters, custom business classes or even raw transactions.

The following code example shows how to update added row using best practice custom business class. It uses the AddRow event handler to perform physical database update

C# Copy Code
private void WebGrid1_AddRow(object sender, ISNet.WebUI.WebGrid.RowEventArgs e)
{
    if (e.Row.Table.DataMember == "Customers")
    {
        // obtain cells containing new row cells data.
        WebGridCellCollection cells = e.Row.Cells;

        Customer NewCust = new Customer();
        NewCust.FirstName = cells.GetNamedItem("FirstName").Text;
        NewCust.LastName = cells.GetNamedItem("LastName").Text;
        ...

        int NewCustID = CustomerManager.AddNewCustomer( NewCust );

        // update the new customer's ID to datarow so that it reflects the
        // same ID generated by the database.
        DataRow dr = (DataRow)e.Row.DataRow;
        dr["CustomerID"] = NewCustID;
    }
}

Note that in the sample codes above, you are not required to manually add row to the existing data source as it has been automatically done by the internal WebGrid's handler. Notice that the e.Row contains the new DataRow object which contains the data of the new row. This allows you to concentrate on the business logic implementation and let WebGrid takes care the internal data processing. However, if you need to manually add the data row, you can instruct the WebGrid to cancel the automatic data insertion by setting the e.ReturnValue property to False.

As mentioned earlier, the Microsoft's ADO.NET architecture plays an important role to make changes in memory and avoid the need to perform full data rebinding. The architecture is fully utilized in WebGrid and combined with Intersoft's OnTheFly mechanism and therefore can provide the changes in almost real time to client.

In addition to the powerful editing, WebGrid also works perfectly and consistently when several features are used together. This means that the row adding, updating or deleting will also work when the Hierarchical mode is used – allowing users to quickly add a new child record. The editing also works flawlessly when there are SortedColumns, GroupedColumns, FilterColumns defined, as well as when Virtual Paging mode is activated.

For a better understanding, the following illustrations demonstrate the hierarchical row addition processes.

First, we click on the NewRow area and input some data as you can see in the following screenshot. Note that the row addition is performed when the CustomerID column is sorted in ascending order.

After finish inputting the data, we simply hit SHIFT+Enter to add the data immediately. Actually the row addition will be automatically invoked when users press TAB in the last editable cell. In this case, we only wanted to input several fields. Pressing ENTER will switch the mode between edit mode and navigation mode. Well, now let's see the result in the following screenshot.

The row addition took less than 1 second and doesn't generate any page refresh. As you can see in the red-marked rectangle, the position of the new row is automatically reflected as in the data source, it is inserted dynamically and we almost didn't see any difference at first glance.

The next step is, we then expand the newly added row and click on the NewRow area of the Orders table and start entering some order data as you can see in the following screenshot:

Again, we pressed SHIFT+Enter to immediately add the order record and following is what we get.

As you can notice, the NewRow area, which enables user to quickly add other rows, is immediately reinitialized after the row addition .One important thing to note is the CustomerID field of the Orders table which is used as relation between Customers table is automatically assigned. This dramatically prevent data mismatch that is usually generated by data entry and also provide the WebGrid layout to be consistent in hierarchical structure.

Again, the row addition is almost immediate, no page refresh so that we can continue inputting the order details by expanding the order row and click on the NewRow area of the OrderDetails table.

You can see that WebGrid is capable in accepting various input types, such as currency, numbers, date time, percentage and much more. We will discuss more about that in other section below.

Finally, here is the result as you can see in the following screenshot.

As seen in the above illustration, the WebGrid's unique editing concept radically improves the way users work in the Web by removing the need to refresh entire page and data source to accomplish data manipulation tasks. Since most of WebGrid operations are performed in client side, it provides comprehensive editing client-side events for developers such as OnBeforeEditMode, OnAfterEditMode, OnBeforeAdd, OnAfterAdd and much more.

Data Management

Basic Data Source Support

WebGrid has supported many line-of-business features such as new and improved data management features. It includes the exclusive support to ComponentOne's DataObjects so that you can take advantage of the DataObjects within WebGrid's designer and use it along with all data features implemented in WebGrid. This allows you to conveniently design your business logic and composite tables using DataObjects and display it easily with WebGrid. There are numerous enhancements to the WebGrid's built-in data management, such as new DataCacheStorage, automatic composite data keys support, new hierarchical structure mechanism, custom virtual load mode and large data support for VirtualPaging mode.

  1. Standalone ComponentOne DataObjects support
    • Intersoft Solutions has taken further strategy in possible integration with third party data objects which dramatically help developers to design business layer using tool such as C1DataObject and have WebGrid displayed the contents conveniently.
    • Version 4.0 adds independent support to C1DataObject in both design time and runtime capabilities. That means you can perform retrieve structure as well as retrieve hierarchical structure directly from WebGrid designer. WebGrid supports C1DataObject independently, means that there are no dependencies to the C1DataObject in WebGrid assembly.
    • WebGrid virtually supports 9 objects currently available in C1DataObject including: C1.Web.Data.C1DataSet, C1.Web.Data.C1WebDataSet, C1.Web.Data.Express.C1ExpressTable, C1.Data.C1DataSet, C1.Data.C1DataTable, C1.Data.C1DataTableSource, C1.Data.DataView, C1.Data.Express.C1ExpressTable and C1.Data.Express.C1ExpressView.
  2. New DataCacheStorage option
    • WebGrid enables your data to be cached automatically and therefore resulting in faster performance and reducing database workload. Now you can choose the cache storage of WebGrid to page cache or session. In previous version such as V3.5, data was stored in page cache which is also the default value in V4.0. The session cache storage allows a better and more stable cache mechanism, where the data will only expire when the session is expired. Using session, you can also take many benefits and advantages offered by ASP.NET, such as storing session in state server or Sql database for greater web application's scalability.
  3. Automatic composite data keys support
    • WebGrid adds automatic support for table that has more than one datakeyfield. The data keys will be obtained from your data source structure automatically, helping developers to prevent picking up incorrect datakeyfields which cause errors. With automatic composite data keys support, data manipulation operation such as editing, adding or deletion and other data operation such as filtering are done automatically as well.
  4. New hierarchical structure retrieval mechanism
    • From Version 4.0, WebGrid has improved the hierarchical structure retrieval so that it will work correctly with complex data relations and Xml data that have improper order of data relations.
  5. New VirtualPagingMode
    • One of the WebGrid's key innovations is its ability to fetch more data as you scrolled down to the bottom edge of grid. The new version has much focused in enterprise-class application scenarios where the size of database is relatively large and getting larger as the business grows. Version 4.0 added new VirtualPagingMode property consists of three modes: Normal, LargeData and Custom.
    • The LargeData mode is suitable for scenarios where the loaded data source is relatively large and filled at once then handled by WebGrid automatically. The difference with Normal mode is only a number of rows specified in VirtualPageSize are processed by grid, while Large mode processed all rows.
    • Custom mode allow developers to handle the data fetching logic, such as filling only a number of rows at first page load, then load more data as requested in VirtualLoadArgs.RequestedRows property. With the flexibility offered in this mode, it enables you to load any size of table efficiently and effectively.

Data Source Controls

WebGrid supports the codeless data binding introduced in ASP.NET 2.0 or later. Codeless data binding means that you can configure the data source, its connection and its related property without writing codes. In other words, you can quickly configure the WebGrid to connect to a data source by simply using drag, drop and click.

With this new data binding concept, programming data bind web application is very easy, simple and straightforward. Also notice that there are no code required in the page's code behind. In the previous version, you will need to configure InitializeDataSource event and write code inside the event to pass the data source to WebGrid via e.DataSource property. This is no longer needed in WebGrid, although the old data binding mechanism is still supported for backward compatibility.

The new data source control binding architecture supersedes the older data source object binding mechanism and dramatically changes the concept of how a user interface component should interact and handle data source.

In WebGrid, there are two major categories of data source control support as discussed in the following sections.

Basic DataSourceControl support

WebGrid supports basic data source control that available in ASP.NET 2.0 such as:

  1. AccessDataSource
  2. SqlDataSource
  3. ObjectDataSource

Three of the data source controls above support single table view and thus can only be used as flat configuration in WebGrid control.

Advanced DataSourceControl support

In addition to basic data source controls, WebGrid is designed to handle more advanced data source controls for enterprise development needs. The advanced data source controls supported are:
  1. XmlDataSource
  2. IntersoftDataSource

Rich User Interface Elements

WebGrid is designed with rich UI elements allowing users to work with data in a more intuitive and efficient manner. The following section lists the common user interface elements of WebGrid.

Show GroupBox

A box with visual representation of hierarchical Group Columns.

Show Unscrolled Header and Footer

A standard Windows GUI behavior where the header and footer of the table stay still even though the grid is scrolled. It brings a more consistent and standard layout for displaying tabular data which allows users to see information more effectively.

Show Table Headers

A special row which appears on top of each Table's column headers. Table headers which represent the context of displayed data can contain both Image and Text. Table headers are very useful especially when used in multiple nested tables.

Show Column Headers

Column headers can contain both Image and Text. The column headers can be clicked to perform sort operation. It can also be dragged and resized. When it is right clicked, it will display Column Menu.

Show Filter Row

A special row that appears exactly below column headers allowing users to search or filter data based on the column. You can change the filter type that includes 8 predefined operations such as Greater Than, Like, Equal, and so on; by clicking the Filter Icon on the right most of column.

Show Group Rows

Rows which occur as the result of grouping process. Child rows in the same group can be expanded or collapsed. Group rows can be used to display calculated or summary information such as the rows count of the child rows.

Show Row Headers

A cell that is added before any other data cells. Row headers are used to identify current selected row and can be clicked to select a row.

Show TreeLines structure [Refer to screenshot 1 - H]

When Hierarchical data display is being used, the tree lines is shown to give a better understanding on the Hierarchical structure of the displayed information by visually representing which rows are belong to which Table. The tree-lines structure is rendered and resized transparently as users expand or collapse child rows.

Show GroupTotal Row

A row that appears below of each GroupRow. The GroupTotalRow allows group totals of each column to be displayed independently, resulting in a more convenient experience when analyzing information. Each column of the total row is synchronized, means that if you moved or resized a column, the column's group total row will be affected as well. This enables a consistent layout throughout all WebGrid's UI elements.

Show Column Footers

It is possible to combine the visibility of both GroupTotalRow and Column Footers to deliver better summary display for information analysis purpose. The column footers will appear at the bottom of each Table which can contain custom footer's text and the result of AggregateFunctions applied to each column.

Show Status Bar [Refer to screenshot 1 - K]

A panel that is used to display the current progress of data operation, such as Loading more data, Grouping column, and so on. By default, it displays an animated progress bar and a text displaying WebGird's status at the left side of the panel. At the right side, it displays the loaded data, the number of the total rows, and a set of icons that are used to represent refresh action or load more data if VirtualLoad paging mode is applied.

Show Column Menu

A special menu UI that is shown when users right click on column headers. It contains numerous column-related data operation such as Sort Ascending, Sort Descending, Group by this Field, Best Fit, and Select Columns submenu which allow users to select which columns are visible. The menu UI is a limited runtime version of included Intersoft WebMenu.NET which is also a member of WebUI Studio.NET. Notice that the menu is browser's size independent, means that it can cover all windowed objects.

Show Filter Menu

A special menu UI that is shown when users click on Filter image while AllowFilter is applied. The filter menu contains numerous filter types such as Greater Than, Less Than, Equal To, and so on. Users can click on Apply All Filters to apply all configured filters.

Show Nested Tables

When working in Hierarchical mode, users can see nested tables within a Table. The nested table implements the same layout and core architecture such as OnTheFly data request, plus advanced child table's synchronization which is the ability to synchronize all visible tables at the same level to requested action such as sorting, grouping, column resizing and moving, and so on.

Show Automatic Tooltip

When a cell's text is longer than the width of its column, the text becomes truncated and it displays ... (ellipsis) at the right of truncated text. In the case of truncated text, users can choose either to resize the column to a larger width or select Best Fit from Column Menu. Alternatively, users can just move the mouse over the cell and a tooltip will appear containing the complete cell's text.

WebGrid Screenshot 1

WebGrid Screenshot 2

Advanced User Interactions

WebGrid's key strength is its complete UI interactions allowing users to do more with the control to find information faster and more productive. WebGrid allows users to:

  • Move column. A column header can be dragged and dropped to the targeted position.
  • Resize column. A column can be resized by moving the mouse to the right edge of a column and dragged. When dragged, a gray vertical splitter will appear to indicate the new size of the column as users move the mouse.
  • Group column. A column can be grouped by right clicking on the column header and clicking on Group By This Field. Alternatively, users can drag the column and drop it in GroupBox.
  • Change order of group column. The order of grouped column can be changed by dragging the group column's object and move it to targeted position. A column pointer image will appear when the mouse cursor is over a valid position.
  • Ungroup column. Grouped column can be easily ungrouped by right clicking on the column header and clicking on Ungroup By This Field. Users can also ungroup a column by dragging the group column's object and dropping it in Table's column headers or in any Grid's area to remove the column from view.
  • Sort column. Data can be sorted based on a column by clicking on the column header. The sort order of subsequent click is, Ascending, Descending and then back to None. Users can also sort multiple columns by pressing SHIFT key when click on column header. Alternatively, user can also do the sort selectively by right clicking on the column header and select on either Sort Ascending or Sort Descending.
  • Filter data. Users can specify row filter based on a column by typing the filter text in Filter TextBox and press ENTER. You can change the filter type, apply all filters, or clear all filters by clicking the Filter Image.
  • Show/Hide column. Users can show or hide columns by right clicking on any column header and point to Select Columns submenu. Users can then decide which columns to show or hide by clicking on the CheckBox.
  • Select row/cell. Users can select a row or cell by simply clicking on it. If CellClickAction is set to Cell, then the clicked cell will be selected instead of the entire row. In this context, users can still highlight a row by clicking on the row header.
  • Navigate using keyboard. Users can navigate the data by using up-down arrow to move up and down, up to move up, and so on. When a child table is shown, the active row will automatically jump into the last visible row of the child table.
  • Expand/Collapse GroupRow. Users can expand or collapse a group row by simply clicking on the + or - image, or simply by double clicking on the row. Navigation by keyboard is also supported by pressing left arrow to collapse and right arrow to expand.
  • Expand/Collapse ChildTable's rows. Users can expand or collapse child table's content by simply click on the + or - image. Alternatively, pressing + on keyboard's numpad will collapse the child rows, while - will expand the child rows.
  • Best fit column. When a table contains many rows, it is not effective for users to manually determine the size of a column. Therefore, a built-in function is provided to perform the task by right clicking on column's header and click on Best Fit. The width of the column will be automatically set based on the length of the rows.
  • Retrieve more data. When VirtualLoad paging mode is applied, WebGrid will only display a number of records defined in VirtualPageSize on initial load. The process of loading more data is automatically done as users scroll forward. The process performs transparently as users do not even notice or disturb.
  • Refresh data. Since WebGrid implements its own data caching mechanism which is an integral part of Intersoft WebUI Studio's core architecture, the data source is cached internally in a compact, lightweight Xml-based format. Users can always refresh the Grid's data by simply clicking on Refresh Image in the status bar area. In this context, WebGrid will automatically expire and remove old cache and assign the refreshed data in the cache. Developers can choose to turn this feature off in AllowAutoDataCaching property.

Learn More

In addition to rich end-user features, WebGrid provides a multitude of time-saving features for enterprise-class application development – from data display, data sorting, grouping, filtering, paging, to data aggregation and much more. To learn more about these specific features, see the following topics:

  • Displaying Data
  • Sorting Data
  • Grouping Data
  • Filtering Data
  • Editing Data
  • Exporting Data
  • Formatting Data
  • Aggregating Data
  • Layouting
  • Pivot Charting
  • Paging Data
  • Customizing Data
  • Customizing UI
  • Programming with Client-side API
  • Programming with Server-side API
  • Styling
  • Optimizing Performance

See Also

WebGrid Features Overview

Getting Started
Getting Started

Other Resources
Walkthrough Topics
How-to Topics


Displaying Data

Displaying Data
See Also Send Feedback
Intersoft WebGrid > WebGrid Features Overview > Displaying Data

Glossary Item Box

WebGrid sets new standards in data visualization through a host of innovative features that enable you to display data in a more intuitive and stylish fashion. Beyond standard data grid, WebGrid lets you visualize data that makes the most sense to your users – whether it is in tabular layout, hierarchical layout, columnset layout, tree layout, or even in stunning charts. For more information about visualizing data in charts, see Pivot Charting.

Displaying data in WebGrid involve extensive data binding operations. WebGrid supports two kind of data binding operations which are discussed in the following sections.

Server-side Binding

Server-side binding is a mechanism that processes data operation and binding life-cycle entirely in the server-side. This means that the data retrieval and items population happened in the server-side. In addition, server-side binding normally sent HTML markup as the final output, which is directly recognized by browsers with very minimum overhead in the client side.

There are a number of ways to perform data binding in server-side, particularly in the ASP.NET platform. You can bind the data through code, declarative data source controls, or LINQ query. For more information about server-side binding, see Server-side Binding.

Client-side Binding

In contrast to server-side binding, the client-side binding processes the raw data and transforms it into usable form entirely in the client-side. This includes the data population, sorting, filtering and paging.

Unlike server-side binding, client-side binding often returns raw data which has significantly smaller size compared to HTML markup. WebGrid incorporates new JSON (Javascript Object Notation) as its data exchange format for all data transfer operation required in client binding. For more information about client-side binding, see Client-side Binding.

See Also

WebGrid Features Overview

Getting Started
Getting Started

Other Resources
Walkthrough Topics
How-to Topics


Server-side Binding

Server-side Binding
See Also Send Feedback
Intersoft WebGrid > WebGrid Features Overview > Displaying Data > Server-side Binding

Glossary Item Box

Server-side binding is a mechanism that processes data operation and binding life-cycle entirely in the server-side. Server-side binding normally sent HTML markup as the final output, which is directly recognized by browsers with very minimum overhead in the client side.

Server-side binding processes data binding, initialization and rendering in the following way:

The most native way to bind data to WebGrid is through code where a datasource is provided to the control during InitializeDataSource event.

The following code shows how to bind WebGrid with code through InitializeDataSource event.

CS Copy Code
protected void InitializeDataSource(object sender, ISNet.WebUI.WebGrid.DataSourceEventArgs e)
{
  OleDbCommand cmd = oleDbConnection1.CreateCommand();
  cmd.CommandType = CommandType.Text;
  cmd.CommandText = "SELECT * FROM CUSTOMERS";

  OleDbDataAdapter da = newOleDbDataAdapter();
  da.SelectCommand = cmd;

  DataSet ds = new DataSet();
  da.Fill(ds);
  ds.Tables[0].TableName = "Customers";

  e.DataSource = ds;
}

For more complete example, see Walkthrough: Binding WebGrid to a DataSource at RunTime.

In addition, WebGrid also supports newer data binding mechanism such as those introduced in latter version of ASP.NET.

To learn more about these data binding concepts, see the following topics:

Codeless Data Binding

This topic provides an overview of the codeless data binding support in WebGrid, which includes the support for built-in ASP.NET data source controls such as SqlDataSource, AccessDataSource, and more.

Hierarchical Data Binding

This topic discusses the hierarchical data visualization in WebGrid and explains the data binding approaches to display hierarchical data in WebGrid such as the usage of ISDataSource control. In addition, it also explains the techniques to load the child data on demand, and other advanced data binding topics.

Self-referencing Data Binding

This topic overviews the self-referencing concept in WebGrid and discusses the data binding approaches as well as other best practices related to self-referencing tasks such as loading the self child rows on demand and support child rows sorting in the self-referencing scenarios.

See Also

WebGrid Features Overview
Client-side Binding

Getting Started
Getting Started

Other Resources
Walkthrough Topics
How-to Topics


Codeless Data Binding

Codeless Data Binding
See Also Send Feedback
Intersoft WebGrid > WebGrid Features Overview > Displaying Data > Server-side Binding > Codeless Data Binding

Glossary Item Box

WebGrid supports a number of ways to bind data from the database to the control. One of the most common ways to bind data to WebGrid is through the datasource controls which are introduced in latter version of ASP.NET. The datasource controls allow you to bind data in declarative manner, without requiring you to write a single line of code.

This topic contains the following sections:

  • Introduction
  • About ISDataSource Licensing in WebGrid
  • The Benefits of the DataSource Control Binding

Introduction

Codeless data binding means that you can configure the DataSource, its connection and its related property without writing codes. In other words, you can quickly configure the WebGrid to connect to a DataSource by simply using drag, drop and click. Declaratively, you can create a WebGrid instance and bind it to a table in your SQL database in two simple statements as in the following:

Code Copy Code
<asp:SqlDataSource ID="SqlDataSource1" runat="server"
ConnectionString="<%$ ConnectionStrings:SqlConnectionString %>"
SelectCommand="SELECT * FROM [Tasks]">
</asp:SqlDataSource>
<ISWebGrid:WebGrid ID="WebGrid1" runat="server"
DataSourceID="SqlDataSource1" Height="300px" HorizontalAlign="NotSet" Width="100%">
</ISWebGrid:WebGrid>

As you can see on the above statements, the WebGrid1 control is bound to a DataSource control through DataSourceID property. The WebGrid control connects to the specified DataSource control and displays data from the DataSource available in SqlDataSource1.

With this new data binding concept, programming databind web application is very easy, simple and straightforward. Also, notice that there are no codes required in the page's code behind. In previous version, you will need to configure InitializeDataSource event and write codes inside the event which pass the DataSource to e.DataSource. That is no longer needed in WebGrid version 5.0, although the old data binding mechanism is still supported for backward compatibility.
The new DataSource control binding architecture supersedes the older DataSource object binding mechanism and dramatically changes the concept of how a user interface component should interact and handle DataSource. To learn more about its differences and benefits, please refer to The benefits of new DataSource control binding support.
In WebGrid, there are two major categories of DataSource control supported:
  • Basic DataSourceControl support
  • Advanced DataSourceControl support

Basic DataSourceControl support

WebGrid supports basic DataSource control that is available in ASP.NET 2.0 such as:
  • AccessDataSource
  • SqlDataSource
  • ObjectDataSource

Three of the DataSource controls above support single table view and thus can only be used as flat configuration in WebGrid control.

Advanced DataSourceControl support

In addition to basic DataSource controls, WebGrid is designed to handle more advanced DataSource controls for enterprise development needs. The advanced DataSource controls supported are:

  • XMLDataSource
  • IntersoftDataSource

XMLDataSource control is a DataSource control designed to retrieve data from XML source. WebGrid control implements a special support for XMLDataSource so that it can read the XML source defined in the XMLDataSource and display it in a tree-like layout.

Note that the XMLDataSource control supported in WebGrid is a lightweight implementation that designed to simulate a TreeView control and thus can be used only for basic display purpose. For more advanced features of TreeView control, please refer to Intersoft's WebTreeView control.
There are several limitations in WebGrid when bound to XMLDataSource control:
  • Since that WebGrid utilizes its Hierarchical and ChildTable feature to simulate a tree-like display, WebGrid can effectively process structured XML only. Please avoid non-structured XML source as they will not be properly handled.
  • While operating in tree-like display, most Grid-specific features will be disabled such as column sorting, filtering, load more data, paging, etc.
  • Other advanced layout features are not supported and should be disabled since they are irrelevant to the TreeView function, such as ColumnSet layout, self referencing, preview row, etc.
  • The only functional feature in this mode is Grouping feature. The grouping feature enables you to group a hidden column available in the XML source. For instance, take a look at the following illustration.

To bind to a XmlDataSource control, WebGrid comes with full design-time support that allows you to easily configure the data binding. To learn more about design-time support for XMLDataSource, please refer to Design-time support: XML DataSource control.

The other advanced DataSource control supported by WebGrid is hierarchical (multi table views) DataSource control that enables you to easily connect the WebGrid control to a relational dataset available in your web application without any codes.

The hierarchical DataSource control named ISDataSource is exclusively developed by Intersoft Solutions to support the hierarchical feature of WebGrid while conforming the DataSource control architecture offered in ASP.NET 2.0.
To learn more about ISDataSource and its advanced capabilities, please refer to ISDataSource documentation. To learn more about using ISDataSource in WebGrid, please refer to Hierarchical Binding.

About ISDataSource Licensing in WebGrid

Intersoft DataSource Control, also known as ISDataSource, is sold as standalone component product that requires its own runtime license key. However, since ISDataSource plays a very important role in WebGrid's data access functionality, ISDataSource is provided at no additional cost when used together with WebGrid.

When ISDataSource detects a valid license of WebGrid in a web application, it will automatically functioning as licensed version. In this case, you are not required to set the runtime license key for ISDataSource in the application's web.config.

If you would like to use ISDataSource in a web application that does not contain WebGrid (also known as standalone mode), you would need a separate license to use ISDataSource. There are numerous standalone scenarios where ISDataSource is best used:

  • Using ISDataSource for WebCombo.NET 4.0's load on demand binding.
  • Using ISDataSource to replace multiple instances of ObjectDataSource in a web page.
  • Using ISDataSource to take advantage of its advanced caching capabilities, such as file server caching and flexible caching setting.
  • Using ISDataSource as the fundamental DataSource control for all data binding purposes. With powerful features such as automatic conflict detection, rich designers, custom object support and advanced load on demand support - it is worth to consider using ISDataSource as the main DataSource control in web application development.

The Benefits of the DataSource Control Binding

Here are the benefits of the new DataSource control binding support:

  • Improved developer's productivity via codeless, simple and hassle-free data binding.
  • Cleaner separation between User Interface and Data Access/Business Layer codes
    All data layer codes and logics are now handled at DataSource control level instead of component level. That means UI component such as WebGrid is now purely serving as data grid and visualization function, and no longer handling DataSource.
  • Better architecture
    For more than decades, developer was struggling to find the best pattern in developing databound application. DataSource control binding concept is one of the most appealing and acceptable mechanism recognizing its cleaner separation between user interface and data access layer.
  • Highly reusable
    DataSource control offers better reusability since it has rock solid architecture. For instance, developer can write business layer codes in application level which is used throughout the application and use ObjectDataSource to connect to the business layer function.
  • Extensible
    DataSource controls such as ObjectDataSource and ISDataSource (Intersoft's proprietary multi-views DataSource control) have the ability to connect to custom business layer codes. You can also connect the controls to DataSet and TableAdapter that generated using Visual Designer in Visual Studio 2005, as well as connect it to extended function that you write in an extended class through new "partial class" mechanism.

Several important notes that developer should aware with the new DataSource control concept:

  • InitializeDataSource event is no longer fired when the WebGrid is bound to DataSourceID. This event will still be fired normally when the DataSourceID property is empty (old data binding mode).
  • You cannot bind to DataSource control and DataSource object at the same time. For instance, if you set DataSourceID to SqlDataSource1 and at the same time set WebGrid1.DataSource = dsNorthWind.Customers in the code, this will throw an invalid operation exception.
  • All internal operations and existing functions in WebGrid are still working properly with the new DataSource control binding such as column sorting, filtering, grouping, etc. This ensures full compatibility in behaviors and functions with the previous versions.
  • When the DataSource control is configured for updating capabilities such as add new record, update record and delete record - WebGrid can automatically communicate to the assigned DataSource control for its data manipulation process without any codes at the Grid level. In previous versions, developers are required to write their own codes to process the updates to physical database. For more information, refer to Walkthrough: Configuring updatable WebGrid bound to ObjectDataSource control
  • Data caching
    In pre-2007 platform, Intersoft's databound control such as WebCombo.NET and WebGrid employ built-in automatic data caching mechanism. In 2007 product lines, the built-in data caching is no longer functioning when the control is bound to DataSource control. To configure data caching, please refer to the capability of the DataSource control that you used to bound to the control. For instance, if you bind a WebGrid control to SqlDataSource, then you can enable the caching by setting EnableCaching of the SqlDataSource control to True.

See Also

WebGrid Features Overview

Getting Started
Getting Started

Other Resources
Walkthrough Topics
How-to Topics
FAQ: Can I perform retrieve structure programmatically when bound to DataSource control?


Advanced LINQ to SQL Support

Advanced LINQ to SQL Support
See Also Send Feedback
Intersoft WebGrid > WebGrid Features Overview > Displaying Data > Server-side Binding > Codeless Data Binding > Advanced LINQ to SQL Support

Glossary Item Box

This section discusses the new technology introduced in Microsoft.NET Framework 3.5 to resolve many data-related and performance issues in ASP.NET web development. One of the most common issues in web development is the performance issue when data binding to a large datasource such as a table with several hundred thousands or millions of records.

This section will demystify the real technologies and behind-the-scene techniques to resolve the performance issue when binding to large datasource.

This topic contains the following sections:

  • Introduction to LINQ to SQL
  • Creating LINQ to SQL Classes
  • LinqDataSource control for ASP.NET web development
  • Automating Intersoft Databound Controls
  • WebGrid with LinqDataSource
  • Introducing ISLinqDataSource

Introduction to LINQ to SQL

One of the common techniques to address large datasource retrieval is by delegating the retrieval and paging operation at database (backend) level. However, some of the operations require advanced knowledge of T-SQL. Furthermore, developers are required to write many codes since the operations are difficult to be generalized (reused) due to complex scenarios. This has caused a great deal of frustrating performance bottlenecks as the database size is growing significantly.

LINQ to SQL is Microsoft's answer to this serious bottlenecks and problems. LINQ stands for Language Integrated Query, and is a subset of Microsoft .NET Framework 3.5. With LINQ, you can write SQL-like query in .NET managed languages such as C# or VB.NET. The LINQ to SQL means that your C# query will be automatically translated to Transact SQL behind the scene.

The real power of LINQ to SQL lays on its ability in generating T-SQL query that is compatible with SQL Server 2000, SQL Server 2005, SQL Server 2008 and SQL Express editions. LINQ to SQL is capable to generate T-SQL query that involves several operations in one execution, such as: sorting, grouping, aggregate computation, as well as paging.

Let's see how LINQ to SQL perfectly resolves performance bottlenecks by returning only the records that requested by the databound control.

As described in the above illustration, the LINQ to SQL performs the work necessary to translate the view requested by the databound control into T-SQL compatible query. This is a great time saving feature, as developers no longer have to write a lot of codes.

It's undoubted that "LINQ to SQL" is powerful enough to overcome performance issues and resolve complex business scenarios. The real question now is when and where to apply this new technology, and how easy to consume it.

In more realistic questions, are your databound controls "LINQ to SQL" enabled yet? Have your data presentation component supported "LINQ to SQL"

Creating LINQ to SQL Classes

To get started with LINQ to SQL, you need to configure the LINQ to SQL classes. First, create a new Web application project (or a new Website), and add Northwind.mdf to your App_Data folder. Next, add LINQ to SQL Classes and name it Northwind.dbml such as shown below.
Next, add LINQ to SQL Classes and name it Northwind.dbml such as shown below.
Finally,open Server Explorer, and drag the desired SQL tables into the designer surface of the newly created Northwind.dbml such as shown below:
Save Northwind.dbml, and you're good to go.

LinqDataSource control for ASP.NET Web development

LinqDataSource is a new datasource control that comes along with ASP.NET 3.5, which wraps most of the LINQ to SQL functionality into one simple, easy-to-use datasource control.

LinqDataSource supports some basic LINQ to SQL features such as:

  • Where
  • OrderBy
  • OrderGroupBy
  • GroupBy
  • Transaction operations, such as Insert, Update and Delete.
  • AutoPage
  • AutoSort

The only lacking feature in LinqDataSource is the aggregate computation predicate, which is not currently supported in either Select property.

Automating Intersoft Databound Controls

Now we have learnt the benefits of LINQ to SQL, and how to consume it using LINQ query language. In this section, we'll look how Intersoft is taking advantage of this powerful technology in their databound controls.

The latest version of Intersoft's WebUI Suite (2008 R2 Build 207+) has been significantly improved to support LINQ to SQL. The result is obvious - striking fast data retrieval operation and manipulation.

Intersoft's flagship databound controls - WebGrid.NET Enterprise™ and WebCombo.NET™ - sets a new record in performance benchmark, outpacing competing products that were using proprietary, slower and unproven mechanism.

WebGrid with LinqDataSource

The latest WebGrid version has implemented full support for LINQ to SQL technology via LinqDataSource control. With a simple LinqDataSource control in your page, WebGrid will be able to perform the following operations automatically - without the needs to write a single line of code:

  • Column sorting, supporting multiple columns.
  • Column filtering, supporting all expressions and operators that currently available in WebGrid.
  • Column grouping, supporting multiple groups.
  • Data paging, supporting both VirtualLoad™ and ClassicPaging™.
  • Data transactions, such as adding, editing and deleting. Also supports data transactions when the data is grouped, which is not supported by LINQ to SQL by default.

Introducing ISLinqDataSource

In order to provide more advanced functionality that doesn't exist in standard LinqDataSource control, we have developed a new datasource control that derives from LinqDataSource. We're proud to introduce ISLinqDataSource, a free download for every .NET developer who wants to build blazing fast web application.

The ISLinqDataSource is now included in the WebUI Studio installation. You can find the component in the Visual Studio toolbox, or in the Add References dialog box.

When WebGrid is bound to ISLinqDataSource, the following features will be automatically processed by using LINQ to SQL for best performance:

  • Column Total, with per page aggregation.
  • Column Total with global data aggregation, supporting following functions natively: Count, Sum, Avg, Min and Max.

See Also

WebGrid Features Overview

Getting Started
Getting Started

Other Resources
Walkthrough Topics
How-to Topics


Hierarchical Binding

Hierarchical Binding
See Also Send Feedback
Intersoft WebGrid > WebGrid Features Overview > Displaying Data > Server-side Binding > Hierarchical Binding

Glossary Item Box

This topic contains the following sections:

  • Introduction
  • Load all child tables DataSource (default)
  • Load child tables DataSource on demand
  • Hierarchical strongly typed collection

Introduction

WebGrid allows a hierarchical data source to be displayed in hierarchical navigation layout. It supports unlimited nested tables inside another table and provides sophisticated data analytical presentation. It also includes built-in automatic functionality that handles the process of retrieving child row based on defined relationships, as well as flexibility to load child data on demand The latest WebGrid now supports hierarchical data binding through ISDataSource component, enabling you to bind hierarchical data instantly. Click here to learn more on ISDataSource support.

There are two types of hierarchical select operation supported in WebGrid:

Load all child tables DataSource (default)

By default, all tables defined in the dataset that are connected to the DataSource control will be loaded at first page request. For instance, a dataset containing hierarchical tables such as Customers => Orders => Order Details will have all three tables loaded. This default scenario is best used to display relatively small amount of hierarchical data.

With declarative hierarchical DataSource control support, displaying hierarchical data has never been easier. The following codes illustrate how the WebGrid can be declaratively connected to the DataSource control which is also declaratively defined.
Code Copy Code
<ISWebGrid:WebGrid ID="WebGrid1" runat="server" Height="300px" UseDefaultStyle="True"
Width="100%" DataMember="Customers" DataSourceID="ISDataSource1">
   <RootTable Caption="Customers" DataKeyField="CustomerID" DataMember="Customers">
      <ChildTables>
         <ISWebGrid:WebGridTable Caption="Orders" DataKeyField="OrderID" DataMember="Orders">
            <ChildTables>
               <ISWebGrid:WebGridTable Caption="Order Details" DataMember="Order Details">
                  <Columns>
                     ... columns definition
                  </Columns>
               </ISWebGrid:WebGridTable>
            </ChildTables>
               <Columns>
                  ... columns definition
               </Columns>
         </ISWebGrid:WebGridTable>
      </ChildTables>
      <Columns>
         ...columns definitions
      </Columns>
   </RootTable>
   <LayoutSettings Hierarchical="True">
   </LayoutSettings>
</ISWebGrid:WebGrid>
<ISDataSource:ISDataSource ID="ISDataSource1" runat="server" SchemaName="dsNorthwind">
   <Tables>
      <ISDataSource:ISDataSourceTable ConflictDetection="CompareAllValues" SelectMethod="GetData"
      TableName="Customers" TypeName="dsNorthwindTableAdapters.CustomersTableAdapter">
      </ISDataSource:ISDataSourceTable>
      <ISDataSource:ISDataSourceTable ConflictDetection="CompareAllValues" SelectMethod="GetData"
      TableName="Orders" TypeName="dsNorthwindTableAdapters.OrdersTableAdapter">
      </ISDataSource:ISDataSourceTable>
      <ISDataSource:ISDataSourceTable ConflictDetection="CompareAllValues" SelectMethod="GetData"
      TableName="Order Details" TypeName="dsNorthwindTableAdapters.Order_DetailsTableAdapter">
      </ISDataSource:ISDataSourceTable>
   </Tables>
</ISDataSource:ISDataSource>

The ISDataSource control provides easy-to-use designer for connecting the DataSource to the dataset that available in the web application. The designer has the capability to retrieve the table schemas, type name, data object methods, as well as automatic conflict detection.

Although ISDataSource control can be declaratively written in html view mode, it is best practice to configure the DataSource at design time using the provided designer. The above sample has the markup generated by ISDataSource Designer.
To learn more about ISDataSource licensing when used together with WebGrid, see About ISDataSource licensing in WebGrid.NET Enterprise 5.0.

Load child tables DataSource on demand

Data binding and on demand data retrieval concept has significantly changed in WebGrid along with the new DataSource control support.

In previous versions, WebGrid is serving as both User Interface and Data Access component. By being Data Access component, it means WebGrid also handles the DataSource level functions such as initializing the DataSource and performing on demand function on Grid level through events.

In version 5 with DataSource control support, WebGrid is now serving as pure User Interface control. That means WebGrid no longer handle DataSource level manipulation. Instead, WebGrid simply connects to a DataSource control which primarily performing data retrieval and data manipulation. With this new concept, WebGrid simply displays a valid DataSource that has been successfully retrieved by DataSource control.
The new concept affects WebGrid's mechanism for loading child tables on demand. Several important points for loading child tables on demand in version 5.0:
  • Load on demand data retrieval is no longer handled at WebGrid level.
  • The load on demand data retrieval is now handled at DataSource level. At the time of WebGrid 5.0 release, the only DataSource control type that support this operation is ISDataSource.

Configuring a WebGrid to display load on demand child table is now easier and simpler. There is no configuration needed to set at WebGrid level.

At ISDataSource DataSource control level, you can enable load on demand operation by simply setting LoadOnDemand property to True. Next, you provide the method that retrieve the child table data and assign it to the ISDataSource control.

Code Copy Code
< ISDataSource : ISDataSource ID="ISDataSource1" runat="server" LoadOnDemand="True"
                SchemaName="dsNorthwind">
...
</ISDataSource:ISDataSource>

There are two ways to provide the method for retrieving child table data:

  • Write codes for the method in App_Code.
    The following codes illustrate the technique to load Orders table when a Customer record is drilled down.

    Code Copy Code
    public DataTable GetData(string customerID)
{
dsNorthwind.OrdersDataTable dt = new dsNorthwind.OrdersDataTable();
OleDbDataAdapter adapter = new OleDbDataAdapter();
adapter.SelectCommand = new OleDbCommand("SELECT * FROM Orders WHERE CustomerID = '" + customerID + "'", this.Connection);
adapter.Fill(dt);
return dt;
}

    Using this technique, you can assign the ISDataSourceTable's SelectMethod to GetData.

  • Create the method in Visual Studio 2005's DataSet Designer.
    Another way to create the data method is through DataSet Designer in Visual Studio 2005. The DataSet Designer enables you to create the method using a visual manner with less coding needed.

    See following steps for more details:

    • Firstly, right click on the TableAdapter area and click "Add Query".

    • Next, you can write the SQL statement or use Query Builder to select the data to be used by the DataSource control.
    • Next, name the method as "GetDataByCustomerID" in the Returns a DataTable option. Uncheck the Fill a DataTable option. Notice that the CustomerID parameter will be added by the designer automatically.
      After the method is successfully created, you can simply assign it to be consumed by ISDataSource by setting the SelectChildRowMethod of Orders DataSourceTable to GetDataByCustomerID. Note that in this technique, the SelectMethod is still set to GetData. The SelectChildRowMethod is provided for the convenience in setting the child row data method without has to change the main select method.

Once the ISDataSource control has been successfully configured, WebGrid will be able to automatically perform load on demand data retrieval without additional settings or codes at WebGrid level.

Hierarchical strongly typed collection

Easily bind hierarchical business objects in the same way and manner as in DataSet objects. WebGrid is the first grid component that implements extensive support to bind your custom hierarchical objects in an elegant, strongly-typed object approach.

Walkthrough Topics

Walkthrough: Binding WebGrid to Hierarchical ISDataSource control

Walkthrough: Configuring updatable WebGrid bound to ISDataSource control

Walkthrough: Loading child rows on demand based on the selected parent row

See Also

WebGrid Features Overview

Getting Started
Getting Started

Other Resources
Walkthrough Topics
How-to Topics


Self-referencing Binding

Self-referencing Binding
See Also Send Feedback
Intersoft WebGrid > WebGrid Features Overview > Displaying Data > Server-side Binding > Self-referencing Binding

Glossary Item Box

WebGrid's self-reference feature is unique in the way that it is implemented as a new feature without trading-off the other existing features. Therefore you can still enable normal Hierarchical mode along with the SelfReferencing feature, enabling sophisticated and never-possible-before scenarios to be implemented easily. As part of WebGrid's vision, the feature also supports LoadOnDemand capability which built on the top of the OnTheFly architecture. This allows developers to implement their own logic to fetch large data tables.

This topic contains the following sections:

  • Introduction
  • Load on Demand Implementation
  • Sorting Child Rows

Introduction

The self referencing table concept in WebGrid actually shares the same table structure and is not a "real" hierarchical drill-down mode. We only see the self referencing mode as another way to group and order the data in a way that follows specific constraints (that is ParentDataMember and ChildMember) to produce a convenient, well-ordered and expandable structure of rows. Therefore, WebGrid's powerful Hierarchical mode is not conflicted and can be enabled along with self referencing mode.

The child and parent recursive implementation is fully based on ADO.NET mechanism. That means if you apply the same child and parent member setting to ADO.NET, you will get the same results.

Settings available in SelfReferencingSettings:

Properties | Description
ChildDataMember | The child member of self referencing table.
Enabled | Specifies whether self referencing is enabled for this table.
ExpandColumnInnerTextPadding | Specifies the padding for expand column's inner text area.
ExpandColumnMember | Specifies where the expand/collapse icon will be rendered.
FitColumnOnExpand | Automatically best fit expand column when expanded.
IsTreeViewSelectionMode | Whether the self referencing will use tree view selection mode.
LoadOnDemand | Specifies whether child rows will be populated on demand.
ParentDataMember | The parent member of self referencing table.
ParentRootMode | Determines how parent rows are populated.
TreatOrphanRecordsAsRoot | Determines whether rows that doesn't have parent or child will be treated as root.

In order to enable basic self referencing table, simply set Enabled to True, and specify both ChildDataMember and ParentDataMember from dropdown in designer.

WebGrid now introduces a new setting in SelfReferenceSettings object called ApplyChildSorting. This feature instructs WebGrid to perform sorting on the self referencing child when the column sorting action occurred.

Load on Demand Implementation

Load on demand feature enables you to retrieve the child rows when the specific parent node is clicked. This flexible feature allows larger data table to be retrieved efficiently. When working in load on demand mode, the first time the page loads, it will only populate the parent rows and hence you only need to supply the parent rows DataSource. Next, you need to implement InitializeSelfReferenceDataSource server event to handle the process of retrieving childrows' datasource. In the event, you only need to fill the childrows into the datatable like in the sample below, the grid will be able to automatically populate the childrows without additional codes.

Note:Since Hierarchical and SelfReferencing can be both enabled at the same time, load on demand for both features can also be enabled in such advanced scenarios. Simply handle InitializeChildTableDataSource for Hierarchical mode and InitializeSelfReferenceDataSource for SelfReferencing mode. See the following screenshot for the results.

Sorting Child Rows

WebGrid now introduces a new setting in SelfReferenceSettings object called ApplyChildSorting. This feature instructs WebGrid to perform sorting on the self-referencing child when the column sorting action occurred.

For more information:

  • Walkthrough Topics
  • How-to Topics

See Also

Getting Started
Getting Started
Getting Started

Other Resources
Walkthrough Topics
How-to Topics


Unbound

Unbound
See Also Send Feedback
Intersoft WebGrid > WebGrid Features Overview > Displaying Data > Server-side Binding > Unbound

Glossary Item Box

This topic contains the following sections:

  • Working with WebGrid Unbound
  • Unbound Hierarchical

Working with WebGrid Unbound

WebGrid can also display data without binding it to database which is called unbound mode. To begin working with WebGrid Unbound, you only needs to specify data to their own object or specify it manually in design.

For example, the following code shows WebGrid unbound structure:

Code Copy Code
<ISWebgrid:WebGrid ID="WebGrid1" runat="server" Width="500px" Height="250px">
<RootTable>
                <Columns>
                    <iswebgrid:WebGridColumn Caption="Item Name" Name="Column0" Width="100px">
                    </iswebgrid:WebGridColumn>
                    <iswebgrid:WebGridColumn Caption="Discount" Name="Column1" Width="100px">
                    </iswebgrid:WebGridColumn>
                    <iswebgrid:WebGridColumn Caption="Price" Name="Column2" Width="100px">
                    </iswebgrid:WebGridColumn>
                </Columns>
                <Rows>
                    <iswebgrid:WebGridRow Height="">
                        <Cells>
                            <iswebgrid:WebGridCell Text="Item1">
                            </iswebgrid:WebGridCell>
                            <iswebgrid:WebGridCell Text="0">
                            </iswebgrid:WebGridCell>
                            <iswebgrid:WebGridCell Text="100">
                            </iswebgrid:WebGridCell>
                        </Cells>
                    </iswebgrid:WebGridRow>
                    <iswebgrid:WebGridRow Position="1" Height="">
                        <Cells>
                            <iswebgrid:WebGridCell Text="Item2">
                            </iswebgrid:WebGridCell>
                            <iswebgrid:WebGridCell Text="5">
                            </iswebgrid:WebGridCell>
                            <iswebgrid:WebGridCell Text="200">
                            </iswebgrid:WebGridCell>
                        </Cells>
                    </iswebgrid:WebGridRow>
                    <iswebgrid:WebGridRow Position="2" Height="">
                        <Cells>
                            <iswebgrid:WebGridCell Text="Item3">
                            </iswebgrid:WebGridCell>
                            <iswebgrid:WebGridCell Text="10">
                            </iswebgrid:WebGridCell>
                            <iswebgrid:WebGridCell Text="500">
                            </iswebgrid:WebGridCell>
                        </Cells>
                    </iswebgrid:WebGridRow>
                </Rows>
            </RootTable>
             …
</ISWebgrid:WebGrid>

Unbound Hierarchical

Since version 5, WebGrid allows you to configure Hierarchical child tables in Unbound mode. In previous versions, WebGrid only supported databound mode to be used in Hierarchical feature. To simulate Unbound mode in previous versions, you usually create a temporary DataSet and the DataTables and map them through DataRelation. However, you will no longer need temporary DataSet or workaround in order to configure hierarchical Grid in Unbound mode. WebGrid has supported pure Unbound mode through server side object model in since V5.0.

For more Information, see Walkthrough: Creating unbound WebGrid with Hierarchical enabled.

Note that when the Grid is operating in Unbound mode, all data-bound features -- such as sorting, grouping, etc -- should not be enabled.

For more information, see:

  • Walkthrough Topics

See Also

WebGrid Features Overview

Getting Started
Getting Started

Other Resources
Walkthrough Topics
How-to Topics


Client-side Binding

Client-side Binding
See Also Send Feedback
Intersoft WebGrid > WebGrid Features Overview > Displaying Data > Client-side Binding

Glossary Item Box

WebGrid is strongly focused on enterprise web development which has been evolved to adopt new web technologies such as cloud computing, software-as-a-service (SaaS) and other Web 2.0 related technologies.

Featuring a rock-solid client binding architecture, WebGrid Enterprise™ 7 is the most revolutionary release yet which has undergone major revamp and re-engineered to meet the high performance standards demanded by today's web application.
The following sections discuss Intersoft's approach to client data binding, its new technologies and benefits, and how it resolves performance bottleneck without trading-off fundamental features.

This topic contains the following sections:

  • Introduction to client-side binding
  • Innovative VirtualRendering
  • Benefits
  • Performance Benchmark and Comparison
  • Supported Features and Limitations
  • The Differences with Server-side Binding

Introduction to client-side binding

Client-side binding is a mechanism that processes data operation and binding life-cycle entirely in the client-side.

Data binding consists of a series of data processing operation that takes a raw-form of data and shapes it into a logical object, which is then rendered into user interface. Client-side binding simply means that data binding should be performed in the client-side (also known as browser), rather than in the server-side (ASP.NET).

All previous versions of WebGrid and most ASP.NET server-side controls perform data binding in the server-side since .NET Framework already offer rich base class libraries to perform these operations efficiently - such as data sorting, filtering, paging and other data access-related functions available in dataset, data table and data view.

Server-side binding normally sent HTML markup as the final output, which is directly recognized by browsers with very minimum overhead in the client side. In certain scenarios such as in data listing that consist of many rows and cells, the HTML markup result could become huge and takes longer time to transfer from the server to client. As a result, it could bring a potential performance problem that impact user experience in overall.

Unlike server-side binding, client-side binding often returns raw data which has significantly smaller size compared to HTML markup. WebGrid 7 incorporates new JSON (Javascript Object Notation) as its data exchange format for all data transfer operation required in client binding.

The following diagram illustrates the new WebGrid's architecture and client binding life cycle.

As seen in the above illustration, WebGrid is built on the top of solid client binding architecture which processes data operation entirely in the client-side - from the data dispatching, data shaping, binding to rendering.

Innovative VirtualRendering

VirtualRendering'is Intersoft's state-of-the-art client rendering framework that enables WebGrid to render data rows efficiently, while at the same time delivering identical user interface as in server-side rendering.

This rendering technology is one of the key components in Intersoft's client binding architecture that transform logical data object into user interface elements.

The uniqueness of Intersoft's rendering technology lies in its ability to perform rendering with very minimum overhead. This is made possible with sophisticated state management that automatically synchronizes its current state as user interacts with the Grid.

As a result, WebGrid doesn't require a row to be rendered from scratch which could lead to performance issues. Instead, it renders a row based on "delta algorithm" to produce high rendering quality in superior performance.

One of the outstanding achievements of VirtualRendering™ is its small size of the client scripts required to activate the client binding feature. Unlike traditional approaches that could bloat the client files up to half a megabyte, WebGrid 7 adds only as little as 60KB for data binding processing, data shaping and rendering.

Benefits

Client-side binding provides comprehensive solution for developers to accomplish many advanced scenarios and tasks which were previously difficult or not possible to be achieved. The following list explains several key benefits of client-side binding:

  • Data footprint reduction by over 90%
    When operating in client binding mode, WebGrid returns raw data in JSON format which is significantly more compact compared to HTML markup. In many scenarios, WebGrid has been proven to reduce data footprint consistently by over 90%. For more information, please refer to Client-side Binding.

  • Superior performance and increased response time
    With re-engineered architecture to support client binding extensively, WebGrid yields better performance and increased response time as it skips several default behaviors, data processing and rendering that used to be produced from server side. Learn the Introduction to client-side binding for more information.

  • More responsive, intuitive user experience
    The nature of client-side binding - which exchange data in its raw format, enables WebGrid to receive data faster from the server. As such, end user will get more responsive user experience even in relatively slower network connection.

  • Connect to external site or service-based datasource ("Cloud" support)
    With solid client binding implementation, it enables developers to get the data from external location such as mashup, or from service-based datasource such as Web service, Windows Communication Foundation (WCF) service, as well as Microsoft's new ADO.NET Data Service.

  • Future proof - supporting more service-oriented development methodology
    Intersoft's approach to client-side binding is an agnostic implementation that completely idependence from server-side object model. This enables WebGrid to perform data binding based on any raw form of data in JSON format, which can be produced by a server hosted by ASP.NET, PHP, or other platforms.

    Based on the understanding of Intersoft's client binding implementation, it also enables developers to achieve a completely unbound scenario as well as future development methodologies that are server-independence such as in ASP.NET MVC and Windows Azure™.

  • Build Web 3.0, offline-capable application
    WebGrid 7 includes new features that designed to help you build advanced Web 3.0 application easier and faster. You can combine WebGrid's state-of-the-art features such as client binding mode, in-line editing and batch update to build offline-capable application, which enables end user to make changes anywhere and anytime even without connection to server.

Performance Benchmark and Comparison

The following charts illustrate the performance comparison between server-side and client-side binding in several aspects, such as data footprint and network connection type. This section also shows the comparison between different modes of client-side binding.

Data footprint size comparison on AJAX operation based on various Grid configurations

The chart above compares several modes in various Grid scenarios. Lower graph is better, which means smaller response size.

Data footprint size comparison on transactional operation

Lower graph is better, which means smaller response size.

Data footprint size comparison based on various Grid functions and data load mode is set to "AllData"

Lower graph is better. Notice that client binding with service mode have zero data footprint, since the data functions will be done entirely in client side.

Response time comparison on AJAX operation (based on data footprint in first illustration above)

Lower graph is faster. The time measurement is per second.

*) Performance benchmark is tested on Intel® Core™ 2 Duo 2.4Ghz processor with 2 GB memory.

**) Tested samples are using the combination of Northwind's Customers and Orders data table.

Supported Features and Limitations

WebGrid 7 features unique client binding architecture that addresses performance bottleneck as well as introduces numerous benefits, without trading-off essential Grid features.

Intersoft's ClientBinding is designed to work in concert with key and fundamental features already implemented in WebGrid. The following features have been tested - and have been further enhanced to some extent -to fully support client binding operation mode:

  • Column and UI operations
    Column operations - such as resizing, moving and best fit - as well as UI operations - such as drag drop, context menu, filter bar etc - are fully supported. More advanced features such as column selection and column removing that require meticulous handling are supported as well.

    Thanks to VirtualRendering, WebGrid's new technology that provides sophisticated state management as end user interacts with WebGrid, which enables WebGrid to perform dynamic row binding and rendering regardless of the UI state.

  • Layout features
    Most layout and appearance features are fully supported in client binding mode - including all details such as border, gridlines, and alternating row. As such, WebGrid renders high-quality, identical user interface in the client side, as if it were rendered from server-side.

  • Grid fundamentals
    WebGrid 7's ClientBinding is a comprehensive client binding architecture that takes account every fundamental functions of WebGrid, in addition to many new features and capabilities that it provides.

    Fundamental WebGrid features - such as value list translation, column types, edit types, data formatting, custom editors and many of WebGrid's key features - continue to work flawlessly in client binding mode. To learn more on the framework enhancements that made it possible, please refer to comprehensive client data features.

  • Sorting and Multiple Sorting
    Data sorting is fully supported in client binding mode. Multiple columns sorting with different sort direction is supported as well. For example, sort on ContactTitle in ascending order and OrderDate in descending order.

  • Grouping and Multiple Grouping
    Data grouping is entirely performed in the client side, which enables multiple grouping and grouping-related operations to be done without server-side callback. Several advanced grouping features are also supported in client binding, such as group caption formatting, various group intervals, and group mode

  • Filtering and Multiple Filtering
    Client binding provides several implementation of filtering based on the selected data source type and selected loading mode. When using client service type of data source such as WebService and the service returns all data, WebGrid will perform filtering entirely in client side. However, if the service is configured to return paged data, WebGrid will fetch the data from the service through DataSourceSelectArguments. Refer to client binding concept to learn more.

  • Column Footer, Group Total and Aggregation
    Client binding fully supports data aggregation - such as Count, Average, Sum, Max and Min - which are fundamental features in a data grid. The aggregation operation is performed entirely in the client side without dependencies on server side, enabling WebGrid to recalculate the data aggregation anytime during user interaction. For instance, group total and column footer result will be updated instantly as user makes changes to the data.

  • Paging - VirtualLoad and Classic
    Paging is a crucial feature in data grid and will continue to work flawlessly in WebGrid's new client binding mode. Regardless of the client datasource type, the paging function will work in consistent behavior as if it were operating in server binding mode. Depends on the data loading mode, WebGrid will automatically determine whether it should perform paging entirely in the client side, or request a paged data from your service.

  • Custom Tag Serialization (New)
    When operating in client binding mode, WebGrid sent raw data instead of markup to the client side. Often times, you will need to send custom information along with the data row being sent to the client. A new property SerializeTagsToClient is introduced to address this requirement, which is only applicable to ServerDataSource type.

  • Transaction operations
    Data transactions - such as insert, update and delete - work out-of-the-box in client binding mode. When ServerDataSource is used and WebGrid is bound to updatable datasource control, the transaction operations can be done automatically without additional codes. The same is true for AdoDataSource which has full capability in data operations. For more information on how to configure transaction operations in client service, please see Elegant Client Binding Architecture.

  • Batch Editing (New)
     SmartBatchUpdate, a new major feature introduced in WebGrid 7, is extensively designed to work perfectly in client-side binding mode. When used together with client binding feature, SmartBatchUpdate™ delivers a new editing experience that allows end user to view and make changes to data entirely in client side. The combination of these features, along with inline-editing transforms your application into offline-capable and cloud-ready Web.

  • LiveFreeze
    Column freezing is supported in the same way it was supported in server-side mode. It has also been enhanced for client binding mode, so that it preserves consistent behavior every time the view has changed, such as upon sorting, filtering, paging - regardless of the client binding datasource type and loading mode.

  • Pivot Charting
    Since Charting require WebGrid to perform extensive data aggregation in server-side, Pivot Charting is supported only in ServerDataSource mode.

  • More features
    Intersoft's ClientBinding technology isn't merely a feature that capable to display plain data - or leaves advanced features disabled. It is rigorously engineered from scratch to ensure it covers advanced features available in WebGrid such as those explained above, as well as high extensibility to support upcoming features.

    In fact, ClientBinding supports nearly all WebGrid features that could end up in hundreds. Some noteworthy features are preview row, columnset layout, automatic column fit, multiple selection, section 508 standards, automatic row restoration, input masking, custom editors and more.

WebGrid 7 is focused on complete support for client binding in flat Grid mode, to ensure high reliability with existing APIs and feature and best performance in various scenarios. The following features are not supported in version 7, although the architecture has been properly designed to support implementation for those features in the next version:

  • Hierarchical Grid (Child Tables)
  • Self Referencing
Exporting is not supported in version 7 when binding mode is set to either WCF, WebService or Astoria. It is due to the datasource is handled externally from other external source, then return the data to Client-side directly to be processed. As for exporting, the data source needs to be on the Server-side in order to export the data and perform additional Server-side binding and processing.

The Differences with Server-side Binding

This section provides information on how client-side binding differs to server-side binding in terms of data processing and event life cycle. The details will also help you in upgrading existing implementation that used server-side binding into client-side binding properly.

Server-side binding processes data binding, initialization and rendering in the following way:

Client-side binding includes a special ServerDataSource mode to enable you to quickly leverage existing server-side infrastructure while taking advantage of many benefits introduced by client binding. This means that you can still connect WebGrid to a server-side data source - such as SqlDataSource, ObjectDataSource, LinqDataSource - or data source object assigned in InitializeDataSource event; while performing data binding operation in the client side.

Client-side binding using ServerDataSource mode processes data binding, initialization and rendering in the following way:

As you can see in the illustrated diagram above, client-side binding mode stripped several processes from the data binding, initialization and rendering process in server-side.

The key points of the differences can be summarized in the following:

  • Physical data connection such as retrieving data from data source control and prepare data binding event will still be invoked in client binding mode. The life cycle is consistent in both first page load and FlyPostBack actions, and works in the same way as in server-side binding mode.
  • Client binding shapes the raw data into semi-processed data, such as including important data such as value list translation, sorted rows, and more. It doesn't perform grouping operation.
  • WebGrid intelligently repackages the data into rowset required only by the current view - taking account paging, filtering and other aspects.
  • WebGrid sent the repackaged data in JSON format - reducing over 90 percent of data footprint.
  • Since the actual rendering does no longer occurring in the server side, the initialize events - such as InitializeTable, InitializeColumn, InitializeRow and InitializeCell - are no longer invoked.
  • As data binding is performed in the client side, WebGrid 7 provides new client side events for data post-processing requirements.

As such, if you have existing codes that perform initialization in one of the above mentioned events, the codes will no longer work. You'll need to migrate the codes to the appropriate client-side events.

For example, consider the following C# codes to handle post-processing in InitializeRow server-side event:

C# Copy Code
protected void WebGrid1_InitializeRow(object sender, RowEventArgs e)
{
   if (e.Row.Type == RowType.Record)
   {
      WebGridCell hasAttachment = e.Row.Cells.GetNamedItem("HasAttachment");
      WebGridCell isUnread = e.Row.Cells.GetNamedItem("IsUnread");
      WebGridCell priority = e.Row.Cells.GetNamedItem("Priority");
      WebGridCell size = e.Row.Cells.GetNamedItem("Size");
      if (hasAttachment.Value.ToString() == "True")
         hasAttachment.Text = "./images/Attachment.gif";
      else
         hasAttachment.Text = "./images/wg_blank.gif";
      if (isUnread.Value.ToString() == "True")
         isUnread.Text = "./images/message.gif";
      else
         isUnread.Text = "./images/wg_blank.gif";
      if (priority.Value.ToString() == "1")
         priority.Text = "./images/high.gif";
      else
        priority.Text = "./images/wg_blank.gif";
      size.Text += " KB";
   }
}

Since InitializeRow is no longer invoked, the above codes will not be executed. To achieve the same post-processing in client binding mode, handle the OnInitializeRow client-side event. Thanks to Intersoft???s client framework architecture that mimics server-side object model, you can easily convert the C# codes to Javascript such as shown in the following:

C# Copy Code
function WebGrid1_OnInitializeRow(id, row)
{
   if (row.Type == "Record")
   {
      var hasAttachment = row.Cells.GetNamedItem("HasAttachment");
      var isUnread = row.Cells.GetNamedItem("IsUnread");
      var priority = row.Cells.GetNamedItem("Priority");
      var size = row.Cells.GetNamedItem("Size");
      if (hasAttachment.Value.toString() == "true")
         hasAttachment.Text = "./images/Attachment.gif";
      else
         hasAttachment.Text = "./images/wg_blank.gif";
      if (isUnread.Value.toString() == "true")
         isUnread.Text = "./images/message.gif";
      else
         isUnread.Text = "./images/wg_blank.gif";
      if (priority.Value.toString() == "1")
         priority.Text = "./images/high.gif";
      else
         priority.Text = "./images/wg_blank.gif";
      size.Text += " KB";
   }
}

With above codes, you can achieve custom requirements with identical results between client and server binding mode.

See Also

WebGrid Features Overview
Server-side Binding

Getting Started
Getting Started

Other Resources
Walkthrough Topics
How-to Topics


Elegant Client Binding Architecture

Elegant Client Binding Architecture
See Also Send Feedback
Intersoft WebGrid > WebGrid Features Overview > Displaying Data > Client-side Binding > Elegant Client Binding Architecture

Glossary Item Box

WebGrid 7 relies heavily on a solid client data framework in order to perform client binding efficiently, and to support existing features in various configurations and scenarios. The following sections discuss Intersoft's client binding technology such as:

  • CDOF (Client Data Object Framework)
  • Data Loading Mode
  • Transaction Operations
  • Batch Update Support, and more

Client Data Object Framework

Intersoft's Client Data Object Framework can be illustrated as a lightweight, mini version of Microsoft's ADO.NET Framework. Client Data Object Framework will be further called CDOF in the following section.

CDOF includes client-side implementation of DataSet, DataTable and DataView - which acts as the backbone of all client-side data operations in WebGrid. The ISDataSet and ISDataTable represent the main data object which is then used by WebGrid for further processing such as data shaping, formatting, paging and more.

The following illustration describes the overall client binding processing in WebGrid.

As shown in above illustration, WebGrid doesn't process data shaping by its own - but it relies on CDOF to obtain finalized data shape, which is then processed further by VirtualRendering. This unique architecture model enables clean separation between data abstraction layer and rendering layer - making it easy to be consumed by WebGrid and other WebUI Studio family that requires client binding implementation in the future.

In addition to the overall binding process as shown above, it's also important to understand the new process model and events life cycle in WebGrid. The following information explains the client binding process life cycle in details:

With rock-solid foundation implemented in Client Data Object Framework, WebGrid 7 sets a new standard for "cloud"-ready application by providing comprehensive, reliable client binding platform that supports enterprise scenarios and advanced features at the same time, as well as high extensibility for future's platform and technologies.

Rich Client-side Data Processing

In addition to providing solid client binding platform, Client Data Object Framework (CDOF) also enables many client-side data processing which were previously difficult or not possible to be achieved.

The following lists the key features of client-side data processing:

  • Client-side Data Formatting
    One of the most powerful features in CDOF is its comprehensive data formatting function. It supports composite data formatting such as string, date time and number formatting. It also takes account Culture information. You can think it as a client-side implementation of .NET Data Formatting Library.

    The data formatting feature is heavily used in client-side binding operation to display formatted values instead of raw values.

    For example, your data service often returns number value in its simple form such as "50.9". However, you may want to have WebGrid displayed the value using "$ #,##.#0" format in "en-US" culture which will format the value as "$ 50.90".

    WebGrid automatically honors the DataFormatString value that you specified in WebGridColumn, and will format it according to the selected culture info.

  • Client-side Sorting
    CDOF implements high-performance client-side sorting that is capable to sort multiple columns in a fraction of seconds.

    The client sorting also supports different sorting direction on each column. For instances, sort on Country descending, while ContactTitle ascending.

    The client sorting is implemented at data access level instead of UI level - enables developers to have greater control over data shaping process. The sorting feature is implemented at ISDataView class.

  • Client-side Filtering
    CDOF features comprehensive filtering support enabling developers to easily perform row filtering at data object level. The client-side filtering implements syntax that is fully compatible with server-side ADO.NET Framework's filter expression - making it easy for .NET developers to consume client-side filtering features.

    The client-side filtering supports the following standard operators:
    • Equals to (=)
    • Not equals to (<>)
    • Greater than or equals to (>=)
    • Greater than (>)
    • Less than or equals to (<=)
    • Less than (<)

  • It also supports more advanced operators such as:
    • Like
    • Contains
    • Nested Conditioning Group

  • The value of the filter expression can be either one of the following types:
    • String. The value part of the expression should to be enclosed by quote character (")
    • Boolean. The value part can be written directly as it is.
    • Number. The value part can be written directly as it is.
    • DateTime. The value part should be enclosed by sharp character (#)

  • The following samples show various filter expression supported in CDOF.
  1. Basic string-type filter expression.
    [ContactTitle] = "Owner" and *Country+ = "USA"
  2. Filter expression on various types with group.
    (([ContactTitle+ = "Owner" or *ContactTitle+ like "sales") and (*OrderDate] > #1/1/2008# and [OrderDate] < #1/1/2009#))
  3. Number filter expression.
    [OrderAmount] > 123.45 and [OrderAmount] < 456.78
  4. Filtering out null or empty data.
    [Region] <> null and [Region] <> ""

  • Client-side Paging

    Because CDOF implements data shaping processing entirely in client side, it enables paging to be performed in client-side as well.

    Client-side paging is fairly easy to be implemented at control/UI level, as long as final data shape has been made available. WebGrid 7 implements client-side paging in its own process to support more comprehensive paging options such as VirtualLoad and Classic paging, as well as to gain better control over the paging process based on various data source types and scenarios.

Data Loading Mode

WebGrid 7's ClientBinding includes two type of data loading mode for client-based data service, regardless of the paging mode of WebGrid in User Interface level.

Data selection can be configured as easy as declarative property set - without requiring you to write Javascript code. For data selection to work, simply set the SelectMethod property in the ServiceMethods to the method name used for data retrieval in your data service.

Data loading modes are:

  • AllData

    If your data service is designed to return all data, then you should choose AllData as the value of DataLoadMode property.

    Tips: You can still enable UI paging in WebGrid level, such as VirtualLoad™ or Classic™ paging. When UI paging is enabled in this mode, WebGrid will perform paging in client-side. This means that page navigation will not require server round-trip, as it's performed and rendered entirely in client side. The same goes true for other data operations, such as sorting, filtering and grouping.
  • PagedData

    If your data table contains relatively large amount of data, you may want to retrieve only subset of the data for the current view. In this case, you should consider using PagedData mode.

    When using this mode, you are responsible to design your data service to return only paged data based on the information requested by WebGrid.

    Intersoft's ClientBinding introduces an elegant approach that enables you to easily retrieve paged data in your data service. ClientBinding encapsulates essential select arguments into an object called DataSourceSelectArguments. This object is always passed to the parameter of your Select method, enabling developers to easily perform data selection based on the information. See Paged Data C# sample to see how ClientBinding handles data paging elegantly.

    When data operation - such as sorting and filtering - is performed in PagedData mode, WebGrid will send a request to the specified data service by including complete request data in the selectArguments parameter. Developers are responsible to handle the sorting, filtering and paging based on the select arguments. In addition, WebGrid will also send a SelectCount request when it needs to invalidate the paging status.

    Important: When PagedData data loading mode is used, you are required to enable one of the paging mode available in WebGrid, such as VirtualLoad or Classic paging mode.

DataSourceSelectArguments class contains the following properties:

  • FilterExpression.
    The string of filter expression based on ADO.NET syntax.

  • SortExpression.
    The string of sort expression based on ADO.NET syntax.

  • MaximumRows.
    The number of maximum rows to be retrieved.

  • OperationType.
    The type of the operation for this request.

  • StartRowIndex.
    The start index of the row to be retrieved.

  • ViewName.
    The view name or table name to be selected.

  • Tag.
    Custom information passed from client-side.

Additionally, a special method GetLinqFilterExpression is provided to convert ADO.NET filter expression into LINQ-compatible filter expression. This method is specifically useful for data service that used LINQ to retrieve data.

The following C# sample shows how you can easily retrieve paged Orders data by using DataContext, LINQ to SQL, and dynamic LINQ.

C# Copy Code
[WebMethod]
public object GetPagedData(DataSourceSelectArguments selectArguments)
{
   NorthwindDataContext context = new NorthwindDataContext();
   context.DeferredLoadingEnabled = false;

   var pagedData = context.Customers.AsQueryable();

   // handle sorting
   if (!string.IsNullOrEmpty(selectArguments.SortExpression))
      pagedData = pagedData.OrderBy(selectArguments.SortExpression);

   // handle filtering
   if (!string.IsNullOrEmpty(selectArguments.FilterExpression))
      pagedData =  pagedData.Where(selectArguments.GetLinqFilterExpression());

   if (selectArguments.OperationType == SelectOperation.SelectData)
   {
      // handle paging
      if (selectArguments.MaximumRows > 0)
         pagedData = pagedData.Skip(selectArguments.StartRowIndex).Take(selectArguments.MaximumRows - selectArguments.StartRowIndex);
         return pagedData.ToList();
   }
   else if (selectArguments.OperationType == SelectOperation.SelectCount)
      return pagedData.Count();
   throw new InvalidOperationException("Unsupported operation type!");
}

Transaction Operations (Insert, Update and Delete)

ClientBinding fully supports transaction operations for data service types - in the same elegant way as in data selection process.

The ServiceMethods object includes the following properties to handle transaction operations:

  • InsertMethod.
  • UpdateMethod.
  • DeleteMethod.

Similar to SelectMethod, you need to have corresponding methods in your data service which is used to handle each operation. The method name is then set to each property.

ClientBinding handles the complex serialization and deserialization process automatically. As a result, you can develop your transaction methods in an elegant way by accepting the original and new item object. For this to work, you need to set the corresponding object name in ItemTypeName property, and provide the class structure of your object in the client-side.

The following example shows how you can support update operation for Customers table in WebGrid.

First step, create the corresponding class of Customer in the client-side and set ItemTypeName property to Customer.

C# Copy Code
function Customer()
{
   this.__type = "Customer";
   this.CustomerID = "";
   this.CompanyName = "";
   this.ContactName = "";
   this.ContactTitle = "";
   this.Address = "";
   this.City = "";
   this.Region = "";
   this.PostalCode = "";
   this.Country = "";
   this.Phone = "";
   this.Fax = "";
}

Next, create a method in your data service to handle the update operation. This sample is using WebService as the data service and LINQ-to-SQL as the data access.

C# Copy Code
[WebMethod]
   public TransactionResult UpdateCustomer(Customer newObject, Customer originalObject)
   {
      TransactionResult result = new TransactionResult();
      NorthwindDataContext context = new NorthwindDataContext();

      context.Customers.Attach(newObject, originalObject);

      try
      {
         context.SubmitChanges();
      }
      catch (ChangeConflictException conflictException)
      {
         result.Exception = new JsonException(conflictException);
      }
      catch (Exception exception)
      {
         result.Exception = new JsonException(exception);
      }

      result.OperationType = DataSourceOperation.Update;
      return result;
}

Finally, set the UpdateMethod of your WebGrid to UpdateCustomer.

As illustrated in the above sample, the update method consisted of the following processes:

  • The method signature should return TransactionResult object and accept two parameters which are newObject and originalObject.
  • If an error occurred during transaction process, assign the exception into Exception property. The type should be JsonException which encapsulates .NET Framework's original Exception object.
  • Set the OperationType of the transaction result accordingly.
  • Returns the transaction result.

Similarly, the Insert and Delete operation also includes patterned method signature. The following explains the method signature of each operation.

  • public TransactionResult <InsertMethod> (<Object> newObject)
  • public TransactionResult <UpdateMethod> (<Object> newObject, <Object> originalObject)
  • public TransactionResult <DeleteMethod> (<Object> originalObject)
WebGrid 7's transaction operations work best with .NET Framework 3.5 data access technologies such as LINQ to SQL and ADO.NET Entity Framework. As the above sample shows, transaction operations can be done in elegant way, hassles-free and very straightforward.

Batch Update Support

As if ClientBinding isn't comprehensive enough, it also includes a unique implementation of Batch Update that is provider independent - making ClientBinding the most advanced and reliable technology to address your ever-dynamic, "cloud"-ready enterprise Web 2.0 application.

WebGrid introduces SmartBatchUpdate, a major feature introduced in version 7 that revolutionizes data editing by enabling multiple editing in the client-side and then submit all changes in a single request. This new batch update feature also supports batch update operation in data service.

Similar to data transaction operations, implementing batch update in data service can be done elegantly through strongly-typed object model.

The batch update method has the following signature:
public TransactionResult <BatchUpdateMethod> (List<ClientRowChanges> changes)

The BatchUpdateMethod property is also made available in ServiceMethods object, which you can specify according to the name of web method in your data service.

When batch update feature is enabled and the client binding mode is using data service, WebGrid will automatically submit all changes by invoking the web method specified in BatchUpdateMethod.

WebGrid submit all changes in an object collection of List<ClientRowChanges>. In your data service end, you can easily loop on the provided changes collection, and perform physical update according to the modification state of each change.

The following C# sample shows how to perform batch update in WebService. The sample used LINQ-to-SQL and DataContext as the data access.

C# Copy Code
[WebMethod]
public TransactionResult UpdateCustomers(List<clientrowchanges> changes)
{
   TransactionResult result = new TransactionResult();
   NorthwindDataContext context = new NorthwindDataContext();

   foreach (ClientRowChanges change in changes)
   {
      try
      {
         if (change.RowState == ClientRowState.Added)
         {
            context.Customers.InsertOnSubmit((Customer)change.NewObject);
         }
         else if (change.RowState == ClientRowState.Deleted)
         {
             context.Customers.Attach((Customer)change.OriginalObject);
             context.Customers.DeleteOnSubmit((Customer)change.OriginalObject);
         }
         else if (change.RowState == ClientRowState.Modified)
          {
             context.Customers.Attach((Customer)change.NewObject, (Customer)change.OriginalObject);
          }                                                                                                                                                                                                                                                                                                                 }
      catch (Exception exception)
      {
         result.Exception = new JsonException(exception);

         /* set ExceptionHandled to true to suppress error message in the client side
             result.ExceptionHandled = true;
         */
      }
   }

    // no errors during object attachment, ok to proceed
    if (result.Exception == null)
    {
       try
       {
          // submit all changes in batch
         context.SubmitChanges();
       }
       catch (Exception exception)
       {
          result.Exception = new JsonException(exception);
       }
    }
    result.OperationType = DataSourceOperation.BatchUpdate;
    return result;
}

The batch update method works in similar way to other data operations, except it includes more information about a row change which is encapsulated in ClientRowChanges object.

The ClientRowChanges consisted of the following properties:

  • RowState.
    The changes state of the row.

  • TableName.
    The table name of the changed row.

  • NewObject.
    The new object that user adds in the client side.

  • OriginalObject.
    The original object that doesn't contain user changes, which is required for Update and Delete operation.

Service Events

All data operations in data service are powered with a solid, provider-based architecture that is highly extensible and scalable.

Client data services that supported by WebGrid 7 such as WebService, WcfService and AstoriaDataSource inherit the same data source provider base. As a result, these data services share the same process life cycle, same events and behaviors.

Client data services support the following events:

  • Selecting
    Invoked when the data provider is about to perform data selection.

  • Selected
    Invoked after the data provider has successfully selecting data.

  • Updating
    Invoked when the data provider is about to perform data update.

  • Updated
    Invoked after the data provider has successfully updating data.

  • Inserting
    Invoked when the data provider is about to perform data insert.

  • Inserted
    Invoked after the data provider has successfully inserting data.

  • Deleting
    Invoked when the data provider is about to perform data delete.

  • Deleted
    Invoked after the data provider has successfully deleting data.

  • BatchUpdating
    Invoked when the data provider is about to perform batch update.

  • BatchUpdated
    Invoked after the data provider has successfully perform batch update.

Each operation includes pre and post event for complete customizability. The pre event such as Selecting can be cancelled with a return false statement.

These service events are available in ServiceEvents object which is located in ClientBindingSettings.

See Also

WebGrid Features Overview

Getting Started
Getting Started

Other Resources
Walkthrough Topics
How-to Topics


Client Data Source and Data Service

Client Data Source and Data Service
See Also Send Feedback
Intersoft WebGrid > WebGrid Features Overview > Displaying Data > Client-side Binding > Client Data Source and Data Service

Glossary Item Box

The following sections explain the client data source implemented in ClientBinding.

There are three general types of client data source:

  1. Server-side Data Source and Data Service.
  2. Service-based data source.
    ClientBinding includes three built-in data providers implementation for data service, which are Web Service, WCF Service and ADO Data Service.
  3. Client-side data source.

Server-side data source

This data source type enables you to continue using server-side data source in WebGrid. Supported server-side data source are:

  • Datasource controls, such as AccessDataSource, LinqDataSource, ObjectDataSource, etc.
  • Datasource object, which is assigned in InitializeDataSource event (also known as Traditional Binding).

This data source type is designed to help you leverage and reuse existing infrastructure which has used server-side data source, while at the same time enables you to take advantage of many client binding benefits such as improved performance and reduced data footprint.

To learn the difference between server-side binding mode and client-side binding mode with server-side datasource type, please see The Difference with Server-side Binding.

Server-side data source type is the quickest and easiest way to take advantage of client-side binding. You don't need to create web service or data service as WebGrid seamlessly connects to server-side data source for data retrieval, which is then repackaged into lightweight format for further processing in the client-side.

Web Service

WebService data source type enables you to connect WebGrid to a web service in elegant fashion, which is done through properties configuration without requiring any Javascript codes.

To connect WebGrid to a web service, simply specifies the service address in the provided ServiceUrl property and specifies the web method used to retrieve data in SelectMethod property.

WebService will automatically activate full client-side operation mode when your data service returns all data. It also supports paged data retrieval for optimized performance.

WebService fully supports data transaction operations such as insert, update, and delete. It also supports more advanced operation such as batch update.

Markup example:

Code Copy Code
<ClientBindingSettings DataSourceType="WebService" ServiceUrl="~/Service1.asmx">
     <ServiceMethods SelectMethod="GetData"/>
</ClientBindingSettings>

Important: Your web service should have capability to return output in JSON format as client binding will accept only data in JSON format. If you're developing web service in ASP.NET 3.5, then your web service has supported JSON response format.

Windows Communication Foundation (WCF) Service

WcfService data source type enables you to connect WebGrid to a Windows Communication Foundation service in elegant fashion, which is done through properties configuration without requiring any Javascript codes.

To connect WebGrid to a WCF service, simply specifies the service address in the provided ServiceUrl property and specifies the web method used to retrieve data in SelectMethod property.

WcfService will automatically activate full client-side operation mode when your data service returns all data. It also supports paged data retrieval for optimized performance.

WcfService fully supports data transaction operations such as insert, update, and delete. It also supports more advanced operation such as batch update.

Markup example:

Code Copy Code
<ClientBindingSettings DataSourceType="WcfService" ServiceUrl="~/WcfService.svc">
      <ServiceMethods SelectMethod="GetData"/>
</ClientBindingSettings>

Important: Your web service should have capability to return output in JSON format as client binding will accept only data in JSON format. If you're developing WCF service in ASP.NET 3.5, then your web service has supported JSON response format.

ADO.NET Data Service (Astoria)

ADO.NET Data Service is Microsoft's latest data service technology introduced in .NET Framework 3.5 SP1. It enables data to be consumed programmatically through standard Web protocols such as REST, XML, SOAP and JSON. To learn more about ADO.NET Data Service, please visit ADO.NET Data Service Home.

Intersoft's ClientBinding™ is the first in the industry that implement full support for this cutting-edge technology.

To connect WebGrid to an ADO.NET data service, all you need to do is specifying the service address in the provided ServiceUrl property.

Astoria enables programmatic data access over the Web with very minimal efforts, which includes support for sorting, filtering and paging. It also includes native support for data transactions such as insert, update, delete, as well as more advanced operation such as batch update.

ClientBinding™ fully takes advantage of Astoria capabilities and implement direct interface to access Astoria's functionalities. As a result, you are not required to specify any of the service methods.

The following example shows a simple declarative markup to enable all data operations.

Code Copy Code
<ClientBindingSettings DataSourcetype="AdoDataService"
ServiceUrl="~/WebDataService1.svc" ItemTypename="Customer">
</ClientBindingSettings>
The current version of Astoria doesn't support complete paging feature yet. Therefore, you can only use AllData loading mode when using AdoDataService type.

Client-side data source

Client data source type allows you to assign a completely custom data source in client-side. When this type is used, WebGrid doesn't perform data loading automatically as the required datasource is not available.

This type is specifically useful when you need to retrieve datasource from external sites or data services that are not supported in Intersoft's ClientBinding. For example, you may have a requirement to fetch data from an external site manually in the client-side, and then pass the resulted data to WebGrid via API calls for data binding.

Pure client-side binding takes as little as three lines of code, such as shown in the following:

grid.SetDataSource(dataSource);
grid.DataBind();
grid.Render();

WebGrid accepts ISDataSet, ISDataTable or any array-based collection as data source. For more information about client binding API, please see Client Binding API.

See Also

WebGrid Features Overview

Getting Started
Getting Started

Other Resources
Walkthrough Topics
How-to Topics


Client Binding Consideration and Best Practices

Client Binding Consideration and Best Practices
See Also Send Feedback
Intersoft WebGrid > WebGrid Features Overview > Displaying Data > Client-side Binding > Client Binding Consideration and Best Practices

Glossary Item Box

This section discusses the consideration for using client binding mode in your application, along with best practices for several common scenarios.

This topic contains the following sections:

  • Considerations
  • Best practice #1 - Using ServerDataSource with Paging enabled
  • Best practice #2 - Using WebService with PagedData loading mode
  • Best practice #3 - Using AdoDataService
  • Limitations

Considerations

Although client binding offers numerous benefits, it doesn't always fit to all scenarios. If your application is running locally in corporate network or on fast broadband network, and that your application doesn't require connecting to a service-based datasource, you may consider to stay with server binding mode.

Likewise, if your target users run on thin-client with slightly limited resources, or slower terminal - client binding might not be suitable as client binding performs all operations - such as populating data, formatting, sorting, filtering, grouping, paging and more - entirely in client side.

Client binding can be generally viable with paged data loading mode, which balances the workload between server and client side. The following sections describe best practices for several scenarios.

Best practice #1 - Using ServerDataSource with Paging enabled

If you're already using WebGrid in your application (which means they were using server binding by default), you may consider using ServerDataSource mode to reuse your existing server assets and infrastructure when migrating to client binding.

ServerDataSource is the mode that requires the most minimal changes to your code. If you don't have post-binding processing in your codes (such as codes in InitializeRow, InitializeCell etc), the migration to client binding is almost seamless without any changes required.

In the above case, you simply need to set DataSourceType of ClientBindingSettings to ServerDataSource. Run your page to ensure everything is working fine.

Best practice #2 - Using WebService with PagedData loading mode

If you're considering developing application that retrieves data from data service, you can consider using WebService or WcfService depending on your server infrastructure.

To anticipate the growth of the data size returned by your data service, you can prepare your data service to return paged data instead of all data. This ensures your application to extend and scale up properly in the future.

Best practice #3 - Using AdoDataService

If you're considering developing data service platform that is accessible over the Web from various clients such as Silverlight or Web application - you may consider building ADO.NET data service.

Limitations

You can't use client-side binding when your WebGrid require specific features that are not supported in this version of WebGrid. For more information on the limitations, please see unsupported features in client binding.

See Also

WebGrid Features Overview

Getting Started
Getting Started

Other Resources
Walkthrough Topics
How-to Topics


Client Binding Configuration with Component Designer

Client Binding Configuration with Component Designer
See Also Send Feedback
Intersoft WebGrid > WebGrid Features Overview > Displaying Data > Client-side Binding > Client Binding Configuration with Component Designer

Glossary Item Box

ClientBinding provides comprehensive settings to support various scenarios used for enterprise Web 2.0 application. Thanks to the improved Smart Tag and Component Designer - making client binding configuration very easy.

To quickly getting started with client binding, open WebGrid's Smart Tag, then click Advanced as shown in the following.

WebGrid's award-winning Component Designer streamlines all client binding configurations in an intuitive user interface, making it easy for you to work with various client binding options. For your convenience, it also includes hints/tooltip description in each option.

See Also

WebGrid Features Overview

Getting Started
Getting Started

Other Resources
Walkthrough Topics
How-to Topics


Client Binding API

Client Binding API
See Also Send Feedback
Intersoft WebGrid > WebGrid Features Overview > Displaying Data > Client-side Binding > Client Binding API

Glossary Item Box

The client binding architecture included in WebGrid 7 is a set of comprehensive new classes, methods and interfaces to enable programmatic consumption in elegant fashion. Most of the user interface functions and high-level encapsulation of binding process called the same underlying APIs.

The following sections explain the new public methods and events which are available when client binding mode is enabled and the data source type is set to either client services or client data source.

This topic contains the following sections:

  • New Methods
  • New client side events

New Methods

Several methods have been added as extensions to provide programmatic client binding functionality. These methods will only be available when client binding feature is enabled.

Class | New Method | Parameters
WebGrid | SetDataSource (Assign a new client-side datasource to WebGrid) | dataSource, tableName
 | GetConvertedDataSource (Gets the datasource that has been converted to CDOF-compatible object) | -
 | DataBind (Instructs WebGrid to perform data binding based on assigned datasource) | -
 | LoadData (Instructs WebGrid to perform initial data loading) | -
 | Render (Perform rendering based on bound data) | -
 | RebindData (Rebind WebGrid with new datasource) | dataSource, skipDataDispatch
WebGridTable | GetUngroupedRows (Gets ungrouped rows collection of this table) | -
 | GetRowByKeyValues (Gets the WebGridRow based on the specified key values) | keyValues
 | DispatchDataTable (Gets the CDOF data table object) | -
 | GetView (Gets the CDOF data view object) | -
 | DataBind (Perform data binding for this table) | -
 | FillDataSourceArguments (Populate view state into datasource arguments used for data retrieval operation) | arguments, sortState, filterState, pagingState
 | GetSortExpression (Gets the sort expression required to construct the view for this table) |
 | GetFilterExpression (Gets the filter expression required to construct the view for this table) |
 | Render (Render the view for this table) | subTable
 | UpdateDataStatus (Updates the status of current datasource to UI) | -
WebGridRow | GetGroupRowLevel (Gets the group row level of this row) | -
 | HasCollapsedParent (Whether this row has collapsed parents) | -
 | HasGroupedChilds (Whether this row has grouped child rows) | -
 | HasExpandedChilds (Whether this row has expanded child rows) | -
 | ExpandGroupRowsToThisRow (Expands all parent group rows down to this row) | -
 | CopyTo (Copies this row's structure and data to destination object) | targetObject, isModifiedOnly, followTargetStructure

New client side events

The following table describes the new client side events related to client binding feature.

Event Name | Description | Parameters
OnCustomAggregate | Fired when WebGrid needs to perform custom aggregation for column which AggregateType is set to Custom. | controlId, columns, rows, type
OnInitializeRow | Fired when a row is initialized. | controlId, row
OnInitializeCell | Fired when a row requires synchronization. | controlId, row
OnSynchronizeRow | Fired when a row requires synchronization. | controlId, row
OnSynchronizeCell | Fired when a cell required synchronization | controlId, cell
OnDataSourceChanged | Fired when data source has been changed. | controlId
OnDataBound | Fired when data binding process is completed. | controlId
OnPreRender | Fired before WebGrid enters rendering phase. | controlId
OnPostRender | Fired after rendering operation is completed. | controlId

See Also

WebGrid Features Overview

Getting Started
Getting Started

Other Resources
Walkthrough Topics
How-to Topics


Sorting Data

Sorting Data
See Also Send Feedback
Intersoft WebGrid > WebGrid Features Overview > Sorting Data

Glossary Item Box

WebGrid provides sorting features to customize the data that has been loaded. This allows users to see their data in a more organized way. This topic provides an overview of the sorting feature in WebGrid.

This topic contains the following sections:

  • Enable Sorting
  • Sorting Types
  • Predefined Sorting Column
  • Sorting Value List
  • Support sorting in child rows when self-reference is enabled

Enable Sorting

To enable sorting in WebGrid, you only need to set property AllowSorting to Yes. Data can be sorted based on a column by clicking on the column header. The sort order of subsequent click is, Ascending, Descending and then back to None. Alternatively, you can also do the sort selectively by right clicking on the column header and select on either Sort Ascending or Sort Descending.

Predefined Sorting Column

To set which column that you want to have sorting, you need to define the SortedColumns property.

Example:

Code Copy Code
<RootTable>  <SortedColumns>
          <ISWebGrid:WebGridGroup ColumnMember="ContactName" SortOrder="Ascending" />
  </SortedColumns>
</RootTable>

For further information, please read How-to: Sort Column Initially.

Sorting Types

Normally, when the sorting is enabled, WebGrid performs sorting for a single column. However, you can also enable multiple sorting in WebGrid by setting additional property, HeaderClickAction to SortMulti.

Users can sort multiple columns by pressing SHIFT key when click on column header.

Sorting Value List

In some scenarios, you may want to sort other key field while the ColumnMember is a field which translated by ValueList such as CategoryID. One of the most implemented scenarios is where you used ValueList to translate the CategoryID into useful information such as CategoryName.

You might be more familiar to do sorting with CategoryName than CategoryID. To sort by using ValueList, you only need to set UseValueListForSorting property in WebGridColumn.

Code Copy Code
<ISWebGrid:WebGridColumn Caption="CategoryID" DataMember="CategoryID" DataType="System.Int32"
                        Name="CategoryID" Width="100px" UseValueListForSorting="Yes">
                        <ValueList DataMember="DefaultView" DataSourceID="AccessDataSource2"
                            DataTextField="CategoryName" DataValueField="CategoryID">
                        </ValueList>
</ISWebGrid:WebGridColumn>

Support Child Rows Sorting in Self-referencing Mode

WebGrid introduces a new setting in SelfReferenceSettings object called ApplyChildSorting. This feature instructs WebGrid to perform sorting on the self-referencing child when the column sorting action occurred.

See Also

WebGrid Features Overview

Getting Started
Getting Started

Other Resources
Walkthrough Topics
How-to Topics


Grouping Data

Grouping Data
See Also Send Feedback
Intersoft WebGrid > WebGrid Features Overview > Grouping Data

Glossary Item Box

This topic provides an overview of grouping feature in WebGrid.

This topic contains the following sections:

  • Enable Grouping
  • Group Intervals
  • Predefined Group Column
  • Automatic Group Total Update
  • Grouping Value List
  • GroupRow Paging Support

Enable Grouping

To enable grouping in WebGrid, you only need to set the AllowGrouping property to Yes. Data can be grouped by right clicking on the column header and clicking on Group By This Field. Alternatively, you can drag the column and drop it in GroupBox. As default, GroupedColumn would be sorted in Ascending. You can also use Multiple group in this feature.

Group Intervals

The built-in Grouping capability in WebGrid has been one of its key successor, which automatically handles rows grouping based on specified Columns' value. The Enterprise edition extends this feature by allowing the grouping to be performed on different Group Interval, instead of the Column's Value. There are about 8 new Group Interval modes that you can apply to the GroupColumn such as Text, Alphabetical, Date, Month, ShortTime and so on. As always, you can apply these GroupIntervals visually in the designer and does not require you to write any codes in order to make it work. This greatly increases your application's value by delivering better grouping capability to end users while saving development time with its capability to use designer.

GroupIntervals | Description
Value | The GroupRow will be grouped by GroupRow's value
Text | The GroupRow will be grouped by GroupRow's text
Alphabetical | The GroupRow will be grouped according Alphabetical order
Date | The GroupRow will be grouped base on Date
Month | The GroupRow will be grouped base on Month
Year | The GroupRow will be grouped base on Year
Hour | The GroupRow will be grouped base on Hour
Minute | The GroupRow will be grouped base on Minute
ShortTime | The GroupRow will be grouped base on ShortTime
Quarterly | The GroupRow will be grouped base on Quarterly
NamedPeriod | The GroupRow will be grouped base on NamedPeriod
Unlike other products, the GroupInterval feature in WebGrid works perfectly in any combinations of different modes specified in each level of GroupColumn object. For instance, you can have ContactName grouped with Alphabetical mode then followed by Country with Text mode, and so on. Technically, the WebGrid internal system automatically sorts each of the specified mode and performs the grouping in incremental method resulting in excellent performance.

Another improvement to the grouping feature is the ability to customize the GroupMode and GroupRowFormatString of each level of group columns. The GroupMode enables you to specify which level of group column that will be expanded or collapsed initially, and the GroupRowFormatString allows you to specify different string formatting for each level of the group columns.

Here is a screenshot of the GroupInterval feature:

For further information, please read Walkthrough: Using Group Intervals in WebGrid.

Predefined Group Column

To set which column that you want to be grouped, you need to set in GroupedColumns property. Then, specify ColumnMember property. For more information, please read How-to: Group column initially.

Example Copy Code
<RootTable>
    <GroupedColumns>
       <ISWebGrid:WebGridGroup ColumnMember="Country" GroupMode="Collapsed"
SortOrder="Ascending" />
    </GroupedColumns>
</RootTable>

There are others additional properties in GroupedColumns such as:

Property | Explanation
CaseSensitive | Specify if the group column text is case sensitive or not
GroupInterval | Specify interval in group column
GroupMode | Specify the group mode in Collapsed or Expanded ( as default set as Collapsed)
GroupRowValueFormatString | Specify the string format for the group row’s value
SortOrder | Specify the sort order for the group column. (as default set as Ascending)

Automatic Group Total Update

WebGrid is the first ASP.NET DataGrid that introduces rich data display features, such as grouping with built-in aggregation. In addition, WebGrid also allows developers to show GroupTotal in the data display. When enabled, every group will show a total row at the end of its group. This allows you to easily review the aggregate results of each column, per that group. For further information, please read (link Data Aggregation).

Grouping Value List

As explained in other topics, WebGrid also supports Valuelist. For grouping, normally it will group and show based its value (id). To have the valuelist result, simply set GroupInterval property as Text in WebGridColumn.

Example Copy Code
<ISWebGrid:WebGridColumn Caption="CategoryID" DataMember="CategoryID" DataType="System.Int32"
                        Name="CategoryID" Width="100px" GroupInterval="Text"
                        UseValueListForSorting="Yes">
                        <ValueList DataMember="DefaultView" DataSourceID="AccessDataSource2"
                            DataTextField="CategoryName" DataValueField="CategoryID">
                        </ValueList>
</ISWebGrid:WebGridColumn>

GroupRow Paging Support

WebGrid now supports group row paging when used together with VirtualLoad™ mode. The group row paging significantly improves overall performance by loading only a small number of records (specified in GroupRowPageSize property) when you expands the group header.

For more information, please read How-to: Enable Virtual Group Row Paging.

See Also

WebGrid Features Overview

Getting Started
Getting Started

Other Resources
Walkthrough Topics
How-to Topics


Filtering Data

Filtering Data
See Also Send Feedback
Intersoft WebGrid > WebGrid Features Overview > Filtering Data

Glossary Item Box

This topic provides an overview of filtering feature in WebGrid. You can specify row filter based on a column by typing the filter text in Filter TextBox and press ENTER. You can change the filter type, apply all filters, or clear all filters by clicking the Filter Image.

WebGrid includes intuitive filtering interface such as automatic filter suggestion, filter status indicator, column filter types and more – allowing you to work with data more efficiently.

This topic contains the following sections:

  • Enable Filtering
  • Filter Status Indicator
  • Advanced Column Filter
  • Automatic Filter Suggestion
  • Filter Value List
  • Column Filter Types
  • KeyStroke to Apply Column Filter
  • Filter Edit Type

Enable Filtering

WebGrid provides built-in column filtering which comes with rich user interface, allowing you to quickly perform data filtering. To enable data filtering in WebGrid, you simply set the AllowFilter property to Yes at LayoutSettings.

Filter Status Indicator

In conjunction with Automatic Filter Suggestion feature, Filter Status Indicator is a new user interface element which appear in the status bar. The filter indicator is useful to represent the current state of data when filter bar is not visible.

When this feature is enabled, it will automatically reflect the user's interaction in Filtering area. For instance, when you perform filtering from either context menu or filter bar, the filter indicator will be marked as active. Likewise, when all filters are removed, the indicator will be marked as disabled (inactive).

To use this feature, simply set ShowFilterStatus property to true and it will automatically reflect the user's interaction in Filtering area. For instance, when you perform filtering from either context menu or filter bar, the filter indicator will be marked as active. Likewise, when all filters are removed, the indicator will be marked as disabled (inactive).

Filter Status Indicator is a new user interface element which appears in the status bar. The filter indicator is useful to represent the current state of data when filter bar is not visible. This feature works best with the AutoFilterSuggestion feature.

The benefits of this feature are:

  • Quickly determines the current filter state of data.
  • Easily toggle the filter state by clicking on the filter indicator.
  • Visually enable filtering without the need to display filter bar.

When set to True, the status bar will show an indicator for the current state of filters. This feature allows you to easily determine the current state of data, as well as easily toggle the filter state.

To enable this feature, set ShowFilterStatus property of LayoutSettings object to True.

The following image illustrates the filter status indicator user interface element:

Advanced Column Filter

Since the initial version, WebGrid has provided predefined filter types that let users easily performing filters from the WebGrid user interface. The supported predefined filters are greater than or equal to, greater than, equal to, like, between, empty, null and more.

Often times, the predefined filter isn't sufficient to meet more complex requirements that involve multiple expressions in a column. WebGrid 7 introduces an advanced column filter that enables developers to write their own expressions per column.

The WebGridFilter object now includes three new properties:
  • UseAdvancedFilter
    Set this property to true to process this filter using custom filter expression.
  • AdvancedFilterKey
    Specifies the key name for this filter.
  • AdvancedFilterExpression
    Specifies the filter expression for this filter.
The advanced filter expression must be compatible with ADO.NET Expression. Furthermore, the advanced expression text will not be displayed in the WebGrid user interface. Some scenarios where advanced filter can be useful are predefined filtering from custom context menu interface or custom filtering from column action interface.

The following C# code shows how to add an advanced filter for the Modified column.

C# Copy Code
protected void WebGrid1_InitializeLayout(object sender, LayoutEventArgs e)
{
   WebGridFilter customFilter = new WebGridFilter();
   DateTime date1 = DateTime.Today.AddMonths(-1);
   DateTime date2 = DateTime.Today;

   customFilter.AdvancedFilterKey = "LastMonth";

   customFilter.AdvancedFilterExpression = "([modified] > #" + date1.ToShortDateString() + "#" + " and [modified] < #" + date2.ToShortDateString() + "#)";

   WebGrid1.RootTable.FilteredColumns.Add(customFilter);
}

Automatic Filter Suggestion

WebGrid is further refined to make filtering easier to use and more intuitive to users. Introducing Automatic Filter Suggestion, users cano now easily perform data filtering based on the currently selected cell. This feature automatically adds filter suggestions based on the data type and value of the selected cell. The benefits are:

  • Allow users to quickly perform filtering without has to type in the filter bar.
  • AllowFiltering/FilterBar can be turned off while allowing user to perform filtering on existing data.

This feature also allows you to filter wide range of date in the column's or cell's context menu. The special date range filters are like Today, Tomorrow, Yesterday, Next Week, Next Month and so on. Therefore, this feature will boost users productivity by allowing them to quickly perform filter based on the current selected cell data.

To enable this feature, simply set AutoFilterSuggestion property of LayoutSettings object to True. This feature is best used along with Filter Status Indicator feature.

Filter Value List

In some scenarios, you may want to filter other key field while the ColumnMember is a field which translated by ValueList such as CategoryID. One of the most implemented scenarios is where you used ValueList to translate the CategoryID into useful information such as CategoryName.

You might be more familiar to do filtering with CategoryName than CategoryID. To filter by using ValueList, you only need to set UseValueListForFilter property in WebGridColumn.

Code Copy Code
<ISWebGrid:WebGridColumn Caption="CategoryID" DataMember="CategoryID" DataType="System.Int32" Name="CategoryID" Width="100px" UseValueListForFilter="Yes">     <ValueList DataMember="DefaultView" DataSourceID="AccessDataSource2" DataTextField="CategoryName" DataValueField="CategoryID">     </ValueList> </ISWebGrid:WebGridColumn>

Column Filter Types

WebGridColumn can be filtered by numerous types, such as: EqualTo, GraeterThan, LessThan, Like, Between, NotEqualTo, NotBetween, etc. WebGrid shows different filter types depend on WebGridColumn value type (such as string, int and date).

Below are the lists of WebGrid filter types.

Member | Description
Between | WebGridColumn will be filtered by the value between the FilterText.
Contain |
EqualTo | WebGridColumn will be filtered by the value equal to the FilterText.
GreaterThan | WebGridColumn will be filtered by the value greater than the FilterText.
GreaterThanOrEqualTo | WebGridColumn will be filtered by the value greater than or equal to FilterText.
IsEmpty | WebGridColumn will be filtered by the value of FilterText which is empty.
IsNull | WebGridColumn will be filtered by the value of FilterText which is null.
LessThan | WebGridColumn will be filtered by the value less than the FilterText.
LessThanOrEqualTo | WebGridColumn will be filtered by the value less than or equal to the FilterText.
Like | WebGridColumn will be filtered by the value like the FilterText.
NoFilter | WebGridColumn will not be filtered.
NotBetween | WebGridColumn will be filtered by the value not between the FilterText.
NotContain |
NotEqualTo | WebGridColumn will be filtered by the value not equal to the FilterText
NotIsEmpty | WebGridColumn will be filtered by the value of FilterText which is not empty.
NotIsNull | WebGridColumn will be filtered by the value of FilterText which is not null.
NotLike | WebGridColumn will be filtered by the value not like the FilterText.
NotSet |

KeyStroke to Apply Column Filter

"ShiftEnter" key is used to filter data as default. However, you can change from "ShiftEnter" to "Enter" key to filter data. For more information, please read How-to: Use 'Enter' key to filter data.

Filter Edit Type

Normally, WebGrid will use textbox as the edit type in filtering. However, WebGrid can also use different filter edit type for filtering. Here is the list of Filter edit type.

CalendarCombo | WebGridColumn's filter row can be edited in CalendarCombo style.
Checkbox | WebGridColumn's filter row can be edited in Checkbox style.
DropdownList | WebGridColumn's filter row can be edited in Dropdownlist style.
NoEdit | WebGridColumn's filter row cannot be edited.
SameAsEditType | WebGridColumn's filter row can be edited same as edit type
TextBox | WebGridColumn's filter row can be edited in TextBox style.
WebComboNET | WebGridColumn's filter row can be edited in WebCombo style.

See Also

WebGrid Features Overview

Getting Started
Getting Started

Other Resources
Walkthrough Topics
How-to Topics


Editing Data

Editing Data
See Also Send Feedback
Intersoft WebGrid > WebGrid Features Overview > Editing Data

Glossary Item Box

Data editing is the most fundamental requirement of any data grid components. Intersoft WebGrid redefines the data editing experiences by providing in-place cell editing capability and equipped with dozens of built-in editors. In addition, WebGrid is also designed with plug-ins architecture allowing developers to create their own custom editors to extend the editing capability.

The latest WebGrid release comes with three packs of custom editor library which includes date time picker, numeric updown, slider bar, currency editor, and much more. In addition, the custom editor pack 3 allows you to easily embed Vista-style calendars or WebTextEditor to the WebGrid control for richer text editing.

This topic contains the following sections:

  • Built-in Editors
  • Data Editing with New Batch Update Mode
  • Built-in Custom Editor
  • Built-in Cell Validation through New Required Input
  • Enabling Add, Edit and Delete in WebGrid using AccessDataSource Control
  • Preventing New Row with Default Values to be Marked as Edit

Built-in Editors

WebGrid provides 7 built-in edit types such as Textbox, MultilineTextbox, Checkbox, DropdownList, CalendarDropdown, CalendarCombo and best of all, integration with WebCombo and WebInput.

Integration with WebCombo

Intersoft WebCombo provides many advanced functionalities over the standard DropdownList such as load on demand pick list, multiple columns, richer presentation and much more. The integration of the WebCombo component as EditType in the WebGrid results in a much sophisticated, smooth user experience in which large data such as Products, are no longer dumped out initially on page load.

Using the same OnTheFly AJAX architecture, WebCombo works perfectly when loading data on demand while WebGrid itself is in Edit mode. With both components working together, you can extend and customize your web applications in a way that is never possible before, such as entering data and have the WebCombo loads the data on demand as you can see in screenshot A, using Unbound and Readonly mode with image cell to allow static picklist as you can see in screenshot B, and much more.

The integration of the WebCombo can be easily achieved through WebGrid Designer by specifying the Column's EditType to WebComboNET, and then selecting the WebComboID from the dropdown list which automatically retrieves all valid WebCombo.NET instances (Version 2+) available in the WebForm designer.

Screenshot A.

Screenshot B.

Calendar and Date Picker

Another important editor in WebGrid is the Calendar Edit type. Similar to other UI controls such as ContextMenu, the Calendar control is designed as real window that is not limited to Internet Explorer's window boundaries. You can see the calendar edit type in following screenshot.

WebGrid includes full globalization support as available in .NET Framework. WebGrid adds a property called Culture in the LayoutSettings property, which is set to Default initially. When set to Default, it will use the current page's or current thread's CultureInfo. The Culture property in the WebGrid enables flexibility when different cultures need to be applied for each WebGrid.

More importantly, the Culture setting will affect the rendering of the number and datetime to follow current culture's setting and the custom data formatting. It also affects the client-side built-in validation, masked data display and calendar's text to follow the culture's settings as well as the custom data formatting which already has the culture settings applied.

The following screenshot shows the WebGrid when the Culture property is set to Chinese.

Resizable TextBox

WebGrid has introduced rich editing experience since the initial version, such as ability to perform data editing directly inside the Grid. Additionally, WebGrid also includes several rich editing types that you can use in the WebGrid.

In version 5.0, WebGrid redefines the editing experience by introducing a new edit type, resizable text box edit control. The resizable text box makes it easy and convenience for user while editing cell containing larger amount of text. With this new feature, user can easily resize the text box by dragging the resize handler at the bottom right position.
When a cell has been modified, you can press enter to accept the modified value as in normal text box. Note that you can also move the textbox control by dragging the empty space in the bottom bar. Combine it with resizing feature to fit your need for your editing convenience.
The following image illustrates the Resizable TextBox in Notes column.

Data Editing with New Batch Update Mode

WebGrid features SmartBatchUpdate, a new major innovation that takes editing experience to a new level. This new technology enables your end user to make multiple changes to the data in the client side, while at the same time maintaining the changes as they navigate the data around.

For more information, see Data editing with new Batch Update mode.

Built-in Custom Editor

WebGrid introduced several built-in EditType to be used in conjunction with built-in cell editing feature. In WebGrid Enterprise, you would be surprised that we do not add much EditType but one - Custom. The new version is promised to let you use your favorite editing control and "hook" it up into WebGrid easily. This great and powerful feature will allow you to use virtually any types of controls as WebGrid's EditType, whether it is an ASP.NET Server Control or a DHTML Client Control.

For more information, see Built-in Custom Editor.

Built-in Cell Validation through New Required Input

WebGrid provides built-in feature for Required Input during data editing and makes data validation a snap.

When the cell of the specified column is empty, the updating will be blocked until all required input are filled. To enable user input, simply set InputRequired property to true at WebGridColumn level. You can also modify the error message in the InputRequiredErrorText property.
Things to experiment:
  • Click on one of the existing record. Double click on SupplierID and clear the value.
  • Click on another row to perform updating. Notice that the updating is blocked.
  • Also notice that an error indicator will appear in SupplierID. Try to hover the error indicator to see the required error text.
  • Now try to clear the UnitPrice and try to perform updating again. Notice that the required error text is customized.
  • Notice the warning message text in the status bar.

With this built-in feature, data validation for requiring user input can be achieved easily without has to write single line of codes.

The following image illustrates the required input feature.

Enabling Add, Edit and Delete in WebGrid using AccessDataSource Control

WebGrid has expanded its feature by enabling user to perform adding, editing and deleting data in Webgrid using AccessDataSource control, where one of the columns data type is AutoNumber. For example: We have Products table in Northwind database, where ProductID is using AutoNumber data type.

Now, you can simply add new record without having to specify the ProductID manually. In the screenshot below, notice that ProductID = 79 is automatically added according to the previous ProductID.

To achieve the scenario above, you just simply need to configure the InsertQuery property in AccessDataSource control.

  • Remove [ProductID] and "?," from the INSERT command.

    INSERT INTO [Products] ([ProductName], [SupplierID], [CategoryID], [QuantityPerUnit], [UnitPrice], [UnitsInStock], [UnitsOnOrder], [ReorderLevel], [Discontinued]) VALUES (?, ?, ?, ?, ?, ?, ?, ?, ?)
  • Remove ProductID from Parameters.

Preventing New Row with Default Values to be Marked as Edit

WebGrid has a built-in feature that allows developers to specify the default value displayed when user type in the NewRow area. This reduces data entry effort when the default value matches the most of the new values to input.

A grid with default value in one of the columns is causing issue when the user set the cursor to the NewRow in the top of the grid and removes it by clicking somewhere else in the grid. In the current state the NewRow would be saved even if the user doesn't entered any data, especially when NewRowLostFocusAction property is set to AlwaysUpdate.

WebGrid now includes a new property MarkDefaultValuesAsDirty property inside LayoutSettings to provide more flexibility for developers to control this specific behavior. This new property is set to true by default to preserve the compatibility with existing behavior.

To prevent WebGrid to mark the new row with default values as dirty (edited), simply set the MarkDefaultValuesAsDirty property to false.

See Also

WebGrid Features Overview

Getting Started
Getting Started

Other Resources
Walkthrough Topics
How-to Topics


Data editing with new Batch Update mode

Data editing with new Batch Update mode
See Also Send Feedback
Intersoft WebGrid > WebGrid Features Overview > Editing Data > Data editing with new Batch Update mode

Glossary Item Box

WebGrid 7 features SmartBatchUpdate, a new major innovation that takes editing experience to a new level. This new technology enables your end user to make multiple changes to the data in the client side, while at the same time maintaining the changes as they navigate the data around.
Embracing elegant pending changes architecture, WebGrid submits all changes to server-side in a single request - making data update fast and efficient. Please see SmartBatchUpdate overview to learn the fundamental concept of this new feature.
WebGrid 7's batch update also supports advanced data transaction operations such as cascading inserts, hierarchical tables, automatic object updates, identity insert handling and more. The user interface has also been improved to provide users with intuitive way to review and manage the changes. Learn more about user interface improvements such as call out notification, changes status and more.
The new technologies in WebGrid 7 are also designed to work in concert with each other, making it the most advanced data visualization and management component for dynamic, Web 2.0-enabled application.
Learn how to combine client binding and batch update along with inline editing to deliver powerful, "cloud"-ready and offline-capable Web application.

This topic contains the following sections:

  • Introducing SmartBatchUpdate
  • Pending Changes Concept
  • Rich User Interface
  • Streamlined Editing Process
  • Built-in Changes Management
  • Hierarchical Tables Support
  • Automatic Changes Preservation
  • Updating to Physical Database
  • Localization
  • Compatibility with Other Features
  • Client-side Programmability
  • Server-side Programmability

Introducing SmartBatchUpdate

SmartBatchUpdate is a new feature in WebGrid 7 which enables you to perform multiple edits across multiple tables in real-time without postback/callback. All pending changes will be submitted into server at once with a single AJAX callback, thus eliminates waiting time and improves data editing experience in overall.

When WebGrid is operating in batch update editing mode, you can make multiple edits - such as adding new row, editing row, and deleting row - in real-time without server contact. You can also make multiple edits across hierarchical child tables which are linked through valid referential integrity in the same consistent fashion.

SmartBatchUpdate also supports more advanced scenarios such as cascading inserts and deletes on hierarchical tables. This allows you to conveniently add new master record and its child records in a row - making data entry across hierarchical tables a snap. Furthermore, WebGrid stores the relation between each new record and intelligently perform new identity translation and mapping it to related child records during physical database updates - freeing developers from tedious and lengthy codes.

SmartBatchUpdate provides numerous benefits for developers and end users, such as:

  • Improves data editing experience
    Unlike traditional data editing, WebGrid doesn't trigger page postback/callback when a row edit occurred. By eliminating the wait time for each row edits, end users can perform data editing faster and more efficient than ever.
  • Reduces server workload
    SmartBatchUpdate saves the changes of each modified row entirely in client-side which allows WebGrid to efficiently manage all pending changes without have to go back-and-forth to server. When end-users are ready to commit changes, WebGrid will send a single AJAX callback to submit all changes to be processed at the server. That translates to more efficient resource utilization and minimized server workload.
  • Prevents data entry errors
    SmartBatchUpdate includes powerful runtime features to help you make correct changes on data and prevent erroneous changes which you want to avoid at all costs. The Undo Changes feature lets end-users to undo a row changes before it is sent to server for processing. The Review Changes feature enables end-users to review all pending changes in an intuitive dialog box interface, where end-users can make correction on specific changes across multiple tables, or undo the changes.

Pending Changes Concept

SmartBatchUpdate employs pending changes concept to provide solid functionality and architecture for its batch update features. With the concept, every row that has changed since its first load will result in a pending change.

A record row can contain only one pending change at a time, which is one of four modes below:

  • Unmodified. When a change is undo'ed, the record will be set back to Unmodified.
  • Added. Newly added row will be marked as Added pending change.
  • Modified. Edited row will be marked as Modified pending change.
  • Deleted. Deleted row will be marked as Deleted pending change.
Each row's pending change is stored based on its corresponding table. This means that each table contains one or more pending changes which are associated with each logical row. As a result, SmartBatchUpdate provides solid and consistent object models and interfaces which enable pending changes to be consumed in multiple tables (hierarchical) configuration. For more information about batch update support for Hierarchical feature, please read Hierarchical Tables Support.

The following illustration describes the pending changes concept in a hierarchical Grid.

Pending changes are stored locally on client-side and can be accessed programmatically through client-side API.

Furthermore, pending changes are automatically restored and synchronized with the current view whenever the Grid performed a FlyPostBack action - such as sorting, filtering, grouping, etc - or page full postback. This provides users with greater experience to interacting with information while maintaining current changes simultaneously.

SmartBatchUpdate also includes built-in pending changes management, such as ability to undo changes, accept changes, as well as review changes. For more information about pending changes management, please see Built-in Changes Management.

It's important to note that WebGrid requires your tables to have at least one unique key field, which is assigned to DataKeyField property of each WebGridTable instance. Multiple key fields scenario is also supported.

When Accept Changes command is invoked by users, WebGrid submits all pending changes to server in a single FlyPostBack (AJAX) callback. Upon receiving batch update request, WebGrid will automatically apply all pending changes to the data source in batch. Depending on your data source type, WebGrid will decide whether it should automatically apply the changes to physical database. To learn more about physical database updates, please visit Updating to Physical Database.

With solid and extensible pending changes architecture provided by SmartBatchUpdate, WebGrid 7 delivers reliable client-side editing solution for your Web application, where data lost is not an option.

Rich User Interface

In addition to solid editing architecture and powerful runtime features, SmartBatchUpdate also provides your end-users with rich visual elements to easily determine added, modified and deleted rows.

The following image shows a WebGrid in hierarchical tables with several pending changes.

Figure 1. WebGrid provides rich visual hints and indicators for pending changes.

SmartBatchUpdate includes additional visual elements and indicators, such as explained below:

  • Changes indicator in row header

    The visual indicator in row header allows users to quickly distinguish the changes status of each row. Added row is marked with [image] icon; modified row is marked with [image] icon; while deleted row is marked with [image] icon.

  • Visual row style
    Different row change status will have different row style to let users recognize the status of each change instantly. By default, added rows are marked with light yellow, modified rows with light green, and deleted rows with light red. These visual styles can be customized through AddedRowStyle, ModifiedRowStyle and DeletedRowStyle respectively.

  • Pending changes status and related commands in status bar

    Whenever users make changes to data, add or remove a row, WebGrid will automatically maintain the pending changes status by updating the related user interface elements in the status bar area. The pending changes status makes it easy for users to understand the current changes state, as well as to perform an action that related to the current
    changes such as accepting all changes.

  • Integration with context menu

    SmartBatchUpdates naturally integrates into existing context menu interface. WebGrid will display various pending changes related command depending on the row state and the settings provided in BatchUpdateSettings object.

  • Callout notification on lost focus

    Users tend to forget to save changes when they are doing multiple tasks at the same time. With the eye-catching Vista-style notification in WebGrid 7, that is nothing to worry about.
    The Vista-style notification will appear automatically when WebGrid lose its focus and pending changes existed.

  • Prompt on page navigation

    Better yet - users will be prompted when they are about to leave the page while pending changes existed. This feature is especially useful to avoid changes lost due to accidental hyperlink clicks or browser close.

Streamlined Editing Process

SmartBatchUpdate incorporates streamlined editing behaviors to make it even easier, faster and more convenient for users to work with data.

When the batch update feature is enabled, the following behaviors will be automatically enabled:

  • Pending changes merging
    A record can contain only one mode of changes. Therefore, if you perform several changes on the same mode, the pending changes will merge automatically. If the change mode is different, it will remove the previous changes and set the latest change mode as active.

    For instances, consider the following scenarios:
    • User edited ContactName on record A. Next, CustomerName and Country are changed. The latter changes will be merged with first changes, resulting in single pending change that contains three fields edit.
    • User edited a record then later deletes it. In such case, the previous changes will be undo'ed and the delete pending change is added.
    • User added a record then later edits more fields. The record will remain marked as added pending change, while the latter edits will be merged.
    • User added a record the later deletes it. In such case, the record will be physically deleted from client view. Its pending change will be removed as well.

  • Go to next row on last cell
    When you pressed TAB key to edit data and past the last cell of the row, the edited row will be marked as pending changes. The active cell selection will also be set to the next row, which allows users to edit data faster.

  • Unique auto-increment fields will be set to (Auto)

    WebGrid will automatically set auto-increment column - which is usually used as DataKeyField - as read-only to avoid unnecessary data update error. Furthermore, the auto-increment field will use a user-friendly text such as "Auto" which tells the users that the value of the cell is automatically generated.

  • Automatically generate key values for auto-increment fields
    WebGrid includes ability to generate key values for auto-increment fields to simulate the database structure in the client side, which enables the pending changes concept to work effectively and reliably.

  • Select first cell after adding new row

    WebGrid provides a new setting to focus the selection to first editable cell upon successful row adding operation, which significantly improves data entry process. This setting can be turned on by setting SelectFirstCellOnAdd to true in the LayoutSettings object.

  • Rows with deleted pending change can't be edited

    When a row is marked with deleted pending change, WebGrid disables the row from further editing. This behavior is designated to prevent conflicts and unnecessary errors during the server-side batch update process.
  • New rows will always be added to the last position in the table

    Add pending changes in WebGrid will always be shown consistently in the last position of the table according to the sequence of insertion. This design allows users to easily locate newly added rows whenever they need to access it. Furthermore, the added rows will be displayed regardless of the view settings such as in the condition of sorted, filtered or grouped.

  • Added row will be removed from view on delete
    When delete action is performed on newly added row, WebGrid intelligently performs undo action on the specified new row. As a result, the added row will be removed from the client view as well as its associated pending changes.

In addition to the editing behaviors enhancement, SmartBatchUpdate also enhances the user experience in overall. To learn more, please see automatic changes preservation and compatibility with existing features.

Built-in Changes Management

SmartBatchUpdate provides a high-level built-in changes management, in addition to the solid underlying infrastructure which maintains the integrity and consistency of pending changes and batch update process.

Changes management in WebGrid 7 includes the following features:

  • Undo Changes
    WebGrid stores all pending changes and all its associated row objects in client side. This design enables WebGrid to track the changes made on each record. Therefore, it allows users to undo a pending change completely.

    You can access Undo Changes command by bringing the row's context menu (right click on selected row). If you would like to undo all changes that you have made, you can click on Undo All Changes command in the row's context menu. Alternatively, you can easily locate the command in the status bar.

    Please note that undo changes command will revert all changes back into its original state. Thanks to the state-of-the-art pending changes architecture, the operation is done in real-time without the needs for server postback/callback.
  • Review Changes
    Designed with solid architecture, SmartBatchUpdate allows your end user to make dozens to hundreds of pending changes in a single session.

    For instance, end user is allowed to make changes from one page, navigate to other page through paging function and make changes on the other pages, and so on. With so many changes in different views, users often have difficulty in reviewing or locating the pending changes.

    To support these dynamic scenarios, users will need the ability to access all pending changes that they have made in different views. Review Changes is a powerful runtime feature that makes it easy and efficient for users to review all changes regardless of the tables and pending changes state.

    Review Changes feature sports sleek dialog box interface to provide end user with a streamlined and convenient access to all pending changes within a single location. See below screenshot to get a better picture.

Review Changes dialog box provides easy-access to all pending changes across tables and views - makes it easy for users to undo several records or accept changes.

Note that the changes will be preserved even though the view has changed completely eg, through sorting or paging. To learn more, see Automatic Changes Preservation mode.

Hierarchical Tables Support

SmartBatchUpdate includes full support for hierarchical tables configuration, makes it the most advanced and reliable solution for enterprise-class data editing requirements.

Consider a WebGrid with Customers-Order-Order Details configuration. Ideally, end user will need the ability to perform changes in child table in the same way and manner as they do it in root table.

WebGrid Enterprise 7's unique SmartBatchUpdate technology simply makes it happen. The following image shows a hierarchical WebGrid with several changes on each table. The pending changes can be easily recognized by its visual style and row header's indicator.

When batch update feature is enabled in WebGrid, it will be automatically applied globally to include all child tables.

The batch update feature is supported in hierarchical WebGrid, regardless of the datasource type. That means no matter what your WebGrid is bound to - either it is a DataSet object, a hierarchical custom object, or an ISDataSource object - the batch update will always work in the same way and consistent fashion.

The batch update includes specific support for hierarchical WebGrid such as:

  • Maintain relations through referential integrity.
    WebGrid requires the tables to have valid referential integrity, that's all it needs for batch update feature to work. The referential integrity is usually defined at DataSet level through Relationships object. WebGrid makes use of this information in hierarchical data processing as well as in batch update processing. Through referential integrity between each table, WebGrid will be able to store appropriate changes such as edits or deletes in the child table.
  • Cascading Inserts.
    One of the most challenging requirements in hierarchical editing is the ability to perform cascading inserts in batch update mode.

    Cascading inserts essentially means that newly added rows in each linked table should be submitted at the same time in a single update process. From end user point, they require the ability to create the new row in parent table and continue to add its child rows - without having to physically create the parent row in the server.

    SmartBatchUpdate is designed to fully support cascading inserts, making it easier and more efficient for end user to add new data across multiple child tables.

    An example of cascading inserts in hierarchical WebGrid can be seen in the following illustration.

    As illustrated in the above image, user can quickly add a new data in the Customers table, drill down the record (even though it's not existed in server yet), add two new records into Orders table, drill down the Order record again, and finally add records to the Order Details table.

    The cascading inserts is made possible as SmartBatchUpdate smartly virtualizes the referential links and structure of each table, and intelligently generates the unique auto-generated values in the client side. See the red-boxed hints in above illustration.

    WebGrid supports auto-generated values for both auto-increment data type such as Int32 and GUID type. WebGrid will automatically show (Auto) text for auto-increment fields.

    When it comes to server-side processing, i.e. when user invoked Accept Changes command, WebGrid will automatically translate the new identity with the one resulted from the database inserts and map it recursively to the linked child rows. For more information, please see Updating to Physical Database.

Automatic Changes Preservation

As in the good tradition of WebGrid, SmartBatchUpdate is rigorously designed for the best user experiences. In simpler words, the batch update feature shouldn't limit end user to perform common data operations - especially the one that completely changes the current view.

For quick instances - data sorting, grouping or filtering are normally disabled when batch update feature is used. Some common reasons are that the changes are either too difficult to be maintained, or impossible to be preserved between view change.

SmartBatchUpdate takes data editing to a new height by allowing users to do what they used to do - column sorting, filtering, grouping, and even data paging - while simultaneously maintain the existing pending changes that they have made.

WebGrid does not only maintain the existing pending changes when you work on different views of your data, it perfectly restores the visual styles and row state of your pending changes as in where it left off.

Automatic changes preservation, an integral feature of SmartBatchUpdate - enables many scenarios not possible to achieve in the past - dramatically enhances user productivity. For instance, it is possible to edit a record in page 1, then jump to page 3 and edit more records, then go back to page 1 and edit more fields on existing edited record.

Automatic changes preservation works on data operations that change the view completely, such as:

  • Column Sorting
  • Column Filtering
  • Column Grouping
  • Column Visibility/Position Changing
  • Refresh and RefreshAll
  • Child Table Loading
  • Classic Paging
  • Virtual Load Paging
This feature is enabled by default when batch update feature is enabled. There are no additional steps required by developers to activate this feature.

Updating to Physical Database

SmartBatchUpdate provides sophisticated implementation to automate the batch updating process to the physical database.

The automatic updating feature significantly reduces development time - as you are not required to write any codes to perform the batch update, or very minimal efforts when you need to customize the updating process in more advanced scenarios.

To understand the physical updating concept better, please see the following illustration.

Understanding Batch Update Processes

As shown in the illustration above, the physical update has several processes such as detailed in the following:

  • Automatic object updates
    This setting is enabled by default. This feature will attempt to automatically apply the submitted pending changes to the intermediate data source that hold the objects during the binding process.

    For instance, when WebGrid is bound to DataSet or DataTable, your pending changes will be applied and then mapped to your data source. This enables you to simply call a line of code to perform the physical updates via DbAdapter.

    In more advanced scenario, such as when WebGrid is bound to unstructured data source or custom object, you can disable this feature by setting the AutomaticObjectUpdates property in BatchUpdateSettings to false.

    In addition to single table support, this feature is also designed to support nested hierarchical tables that linked through Referential Integrity. This feature makes advanced scenarios possible such as cascading inserts and other scenarios related to hierarchical tables.

    Please note that WebGrid doesn't perform physical update in this process.

  • BatchUpdate server side event
    WebGrid provides a new server side event named OnBatchUpdate, which is invoked when the pending changes are required to be submitted to physical database.

    When bound to data source other than data source controls, developers can handle OnBatchUpdate server side event to write the codes required to update the changes into physical database.

    When bound to updatable data source controls - such as AccessDataSource, ObjectDataSource, and others - WebGrid will handle all physical updates automatically, given that ReturnValue is true in OnBatchUpdate event. The ReturnValue is true by default, which can be set to false to cancel automatic physical updates.

    OnBatchUpdate server side event provides BatchUpdateEventArgs in the event argument, which is useful for developers who would like to customize the physical updating process, such as in the case of custom object binding.

    The BatchUpdateEventArgs contains two properties:
    • PendingChanges
      Returns a List<WebGridRowChanges> object.
      Access this property to get all pending changes, regardless of the row state and tables. For more information about the object model, see Server-side Programmability.

    • ReturnValue (Returns a Boolean value)
      When bound to updatable data source controls, such as SqlDataSource, WebGrid automatically connects to the data source controls and invokes the update function to process the changes. You can set this property to false to prevent WebGrid to continue the automatic updates, such as in the case of failed validation or other business logic constraints. The following C# codes show how to update all changes in a flat WebGrid that bound to a DataSet object.

    The following C# codes show how to update all changes in a flat WebGrid that bound to a DataSet object.

    C# Copy Code
    void WebGrid1_BatchUpdate(object sender, BatchUpdateEventArgs e)
{
    CustomersTableAdapter daCustomer = new CustomersTableAdapter();
    dsNorthwind ds = (dsNorthwind)WebGrid1.GetCachedDataSource();
    daCustomer.Update(ds); // updates all changes to database
}
  • Partial errors support
    In addition to solid batch update architecture and automatic object updates, SmartBatchUpdate is also equipped with support for partial errors, making it the most advanced and reliable solution for client-side data editing application.

    Partial errors occurred when one or more changes are failed to be updated while there are also some successful updates. Partial errors will not occur when all changes are failed.

    With partial errors support, user can make changes with confidence, without have to worry that error in one of the changes will cause all changes to fail. This means that WebGrid is able to isolate erroneous changes, and continue to update the next changes that are unrelated to the previously failed changes update.
    At client-side, WebGrid also restores the pending changes that were not successfully updated, so that end user can conveniently correct the errors and accept the changes.

    The following image shows a WebGrid with partial errors response. The error detail for each failed updates are shown in the message box, making it easy for end user to review and revise the errors.

    For more control over partial errors response in the client side, you can handle the OnBatchUpdateSuccess client side event and access the rowErrorXml parameter to get the error detail on each failed update. For more information about client side usage, please see Client-side Programmability.

Various Datasource Support

WebGrid 7 supports physical database updates in various scenarios, such as when bound to different type of datasource, hierarchical tables configuration, and more. The following list describes the supported scenarios in more details:

  • Traditional Binding (ADO.NET DataSet and DataTable)
    When bound to ADO.NET-compatible data source such as DataSet and DataTable, you will need to write codes in OnBatchUpdate server side event to update the changes to database.

    However, the required codes should be very minimal as ADO.NET already implemented batch update at data access level. Developers will then be able to simply invoking a single Update method to process all changes, which were previously mapped during Automatic Object Updates process.

    The following C# codes show how to update all changes that bound to a DataTable object.

  • Declarative Binding (Datasource Control such as SqlDataSource)
    Data source control is the most ideal data binding concept in ASP.NET that provides clear abstraction between UI and data logic. Introduced in .NET 2.0, data source control allows you to bind data in declarative markup, saving you from tedious tasks and lengthy codes.

    SmartBatchUpdate takes advantage of data source control to the fullest. When you connect WebGrid to an updatable data source control, you don't need to write codes to handle the physical updates.
    To enable batch update in declarative binding scenario, simply set AllowBatchUpdate to true and make sure your data source control has been configured properly to support data updates.

  • Hierarchical Traditional Binding (ADO.NET DataSet)
    Similar to Traditional Binding, you are also required to handle OnBatchUpdate server side event to write codes to perform database updates.

    Thanks to the automatic identity's mapping through referential integrity, WebGrid performs all the complex logics behind the scene, so that you only need to write a few lines of codes to update the dataset.

    The following C# codes show how to update all changes in each table contained in the DataSet object.
    C# Copy Code
    void WebGrid1_BatchUpdate(object sender, BatchUpdateEventArgs e)
{
   CustomersTableAdapter daCustomer = new CustomersTableAdapter();
   OrdersTableAdapter daOrders = new OrdersTableAdapter();
   Order_DetailsTableAdapter daOrderDetails = new Order_DetailsTableAdapter();

   dsNorthwind ds = (dsNorthwind)WebGrid1.GetCachedDataSource();
   // updates all changes per table adapter from the root table
   // to each child table in ordered sequence
   daCustomer.Update(ds);
   daOrders.Update(ds);
   daOrderDetails.Update(ds);
}

  • Hierarchical Declarative Binding (ISDataSource)
    As in flat WebGrid declarative binding, SmartBatchUpdate supports hierarchical WebGrid that is bound to ISDataSource control in the same way and consistent fashion.

    With ISDataSource control, you are not required to write codes in order to perform physical update into the underlying database.

    It is important to ensure that your ISDataSource instance has been properly configured to return new identity for each table in the event of insert. For more information, please see New Identity Insert in the section below.

  • Custom Object
    In addition to built-in .NET data sources, SmartBatchUpdate is rigorously designed to support advanced enterprise scenarios, such as using the feature in conjunction with custom object data binding.

    When bound to custom object collection - such as a list of Customer objects - you can disable automatic object updates feature. In this case, you are responsible to write codes to perform physical updates according to your business logic/model.
    In the same way as in other data sources, you handled OnBatchUpdate server side event to provide codes to perform physical update.

    To learn more on how to use batch update feature in custom object scenario, please see Server-side Programmability.

New Identity Insert

One of the best practices in database design concept is to have at least one unique, auto-increment field in each table which acts as the row's identifier.

When you insert a new row to the table, the database will issue a new, unique identity value of the new inserted row. However, each database provider has different ways to retrieve the new identity's value. As such, Microsoft .NET Framework doesn't include built-in implementation to retrieve identity insert in its ADO.NET technology.

SmartBatchUpdate relies heavily on row's identifier to differentiate each record in order to work properly. Therefore, developers should make sure that the new identity's value is correctly retrieved and passed to WebGrid during batch update processing.

The following list describes the techniques to retrieve the new identity's value in various data source type:

  • ADO.NET (DataSet).
    ADO.NET, as the middle-tier data object provided in Microsoft .NET, does not contain database specific implementation in its data access level. As such, the design enables it to work with any database providers that support .NET Framework.

    When a new row is inserted through DbAdapter compatible provider, it does
    not return the new row's identity by default. Thus, developers are required to write additional codes to programmatically obtain the new row's identity.

    The following C# codes show how to retrieve the new identity for Access or Sql database provider.
    C# Copy Code
    void WebGrid1_BatchUpdate(object sender, BatchUpdateEventArgs e)
{
   CustomersTableAdapter daCustomer = new CustomersTableAdapter();
   OrdersTableAdapter daOrders = new OrdersTableAdapter();
   Order_DetailsTableAdapter daOrderDetails = new Order_DetailsTableAdapter();

   dsNorthwind ds = (dsNorthwind)WebGrid1.GetCachedDataSource();
   // Handle RowUpdated event of DataAdapter
   daOrders.DataAdapter.RowUpdated += new OleDbRowUpdatedEventHandler(DataAdapter_RowUpdated);
   daCustomer.Update(ds);
   daOrders.Update(ds);
   daOrderDetails.Update(ds);
}

void DataAdapter_RowUpdated(object sender, OleDbRowUpdatedEventArgs e)
{
   // Conditionally execute this code block on inserts only.
   if (e.StatementType == StatementType.Insert)
   {
      if (e.Row.Table.TableName == "Orders")
      {
         OleDbCommand cmdNewID = new OleDbCommand("SELECT @@IDENTITY", e.Command.Connection);

         /* Retrieve the new identity and call UpdateRowIdentity to process the new identity. */
         WebGrid1.GetTableByName("Orders").UpdateRowIdentity("OrderID", e.Row["OrderID"], cmdNewID.ExecuteScalar());
      }
   }
}

  • Codes Explanation:

    1. In OnBatchUpdate server side event, you write your codes that invokes physical database updates. In the sample above, the RowUpdated event is handled before any calls to Update method.
    2. The function delegate for RowUpdated will be invoked for each successful insert. The above codes perform checking on StatementType and TableName respectively.
    3. A new OleDbCommand object is created to perform select identity retrieval, based on existing connection instance. It's important that you use the existing connection instance in order to get the new identity properly. Again, note that the select identity retrieval statement above only works for Access and Sql-compatible provider.
    4. Finally, UpdateRowIdentity method of the respective WebGridTable instance is called, passing the identity's data member name, the current value of the OrderID, and the new identity's value resulted from the successive insert.
    It's extremely important to call UpdateRowIdentity method to pass in the obtained new identity value. The method maps the new identity into each inserted row properly, which enables WebGrid to process the changes efficiently specifically in hierarchical configuration and more advanced scenarios such as cascading inserts.
  • Data source control.
    Most data source controls that shipped with Visual Studio 2005 or 2008 do not support automatic identity retrieval. The only data source control that supports automatic identity retrieval is SqlDataSource.
  • WebGrid extends the data source control further by providing automatic identity retrieval support for AccessDataSource, in addition to SqlDataSource. This means that if you bound WebGrid to either AccessDataSource or SqlDataSource, you don't need to write additional codes to retrieve the new identity.
    The following C# codes show how to retrieve new identity for ObjectDataSource control. The sample is referencing to Orders table in Northwind sample database.
  • C# Copy Code
    [DataObjectMethodAttribute(DataObjectMethodType.Insert, true)]
public int DoInsert(ref Nullable OrderID, string CustomerID, Nullable EmployeeID, Nullable OrderDate,
Nullable RequiredDate, Nullable ShippedDate, Nullable ShipVia, Nullable Freight,
string ShipName, string ShipAddress, string ShipCity, string ShipRegion, string ShipPostalCode, string ShipCountry)
{
   this.Connection.Open(); // important
   int affectedRows = this.Insert(CustomerID, EmployeeID, OrderDate, RequiredDate, ShippedDate, ShipVia, Freight,
ShipName, ShipAddress, ShipCity, ShipRegion, ShipPostalCode, ShipCountry);
   int identity = this.SelectIdentityQuery();
   OrderID = identity; // pass the new identity into OrderID param
   this.Connection.Close();
   return affectedRows;
}

public int SelectIdentityQuery()
{
   OleDbCommandcmd = new OleDbCommand("SELECT @@IDENTITY", this.Connection);
   int newID = (int)cmd.ExecuteScalar();
   return newID;
}

    At the WebForm (ASPX) page, make sure you reflect the InsertCommand with the new extended method name above. Furthermore, you'll need to add a new OrderID parameter in the InsertParameters collection. See the following sample:

  • Javascript Copy Code
    <asp:ObjectDataSource ID="ObjectDataSource1" runat="server" ...
InsertMethod="DoInsert" OnInserted="ObjectDataSource1_Inserted">
   <InsertParameters>
      <asp:Parameter Direction="InputOutput" Name="OrderID" Type="Object" />
      ...
   </InsertParameters>
</asp:ObjectDataSource>
    At the page code behind, you will need to provide the function as the delegate for OnInserted event that is defined in the WebForm (ASPX).

  • The following C# codes show how to access the output parameters that obtained during DoInsert command, and pass it to WebGrid for further processing.

  • C# Copy Code
    protected void ObjectDataSource1_Inserted(object sender,ObjectDataSourceStatusEventArgs e)
{
   WebGrid1.SetOutputParameters(e.OutputParameters);
}
    Codes Explanation:
    1. By default, the Visual Studio-generated table adapter doesn't contain implementation to return new identity upon successive inserts. Thus, we created a new method to extend the table adapter's Insert functionality.
    2. A new parameter OrderID with ref keyword is inserted into the first parameter of the extended Insert method. This parameter is used to hold the new identity value which is assigned during the process.
    3. The SelectIdentityQuery method is used to obtain the row's new identity as the result of successive insert. This query is compatible with Access and Sql providers.
    4. The extended Insert method name is assigned to the InsertCommand of the ObjectDataSource.
    5. Handle OnInserted server side event of the ObjectDataSource to obtain the resulted output parameters and pass it to WebGrid for further processing.
    6. Finally, adds a new <asp:Parameter> object into the InsertParameter collection of the ObjectDataSource. This new parameter is required to reflect the parameter signature of DoInsert method, which is used to hold the new identity value of OrderID column.
  • Intersoft Datasource Control (ISDataSource)

    Intersoft's flagship ISDataSource control also works the same way and manner as ObjectDataSource, where it is serving as intermediate data class that bridge between User Interface and backend provider. As such, ISDataSource does not contain vendor-specific implementation in order to support various database providers supported by .NET Framework.

    ISDataSource is the only provider in the market that supports multiple tables. As the result, WebGrid accepts only ISDataSource control for its hierarchical table feature.

    To retrieve new identity in ISDataSource, you can use the same technique as in ObjectDataSource above. The only exception is that you can skip the fifth step above. ISDataSource doesn't require you to pass the output parameters to WebGrid, since it is tightly integrated with ISDataSource and thus it has exclusive capability to access ISDataSource instance through standardized interfaces.

Localization

The new batch update feature in WebGrid 7 introduces a dozens of new User Interface elements, which contains many new textual settings as well.

As in good tradition of WebGrid, all textual settings are customizable according to the culture specified by developer. Each textual setting can also be overridden individually. You can find the complete text settings in default.xml which is located in the Localization folder.

The following table lists the new text settings that you can customize.

Category | Text Setting Key | Default Text Setting Value (English)
CommonText | PendingChanges | {0} pending change(s).
 | DeletedRowNoEdit | Row marked as deleted cannot be modified.
 | DeletedRowNoExpand | Row marked as deleted cannot be expanded.
 | BatchUpdateSuccess | All changes have been successfully updated to server.
 | BatchUpdateSuccessWithPartialErrors | One or more changes are not updated due to server errors.
MessageBoxText | UnsavedPendingChanges | You have made one or more changes on WebGrid records. Any unsaved changes will lose.
 | NotifyPendingChanges | There are {0} unsaved pending changes. Click Accept Changes button below to save changes.
 | UndoPendingChanges | Are you sure you want to undo all pending changes?
 | UndoSelectedPendingChanges | Are you sure you want to undo selected pending changes?
 | DeletedRowEditException | You cannot make changes to the row which parent has been marked as deleted.
 | DuplicateKeyException | The pending changes already contain a record with key '{0}'
 | PrimaryKeyEditException | Modification on primary key's field of pending changes is not allowed.
 | BatchUpdateException | An exception has occurred while processing batch update. please correct or undo your changes. \n\Exception details:\n{0}
 | BatchUpdatePartialException | WebGrid failed to update {0} out of {1} changes due to errors. Please review and correct your changes. \n\nThe following records were not updated:\n{2}
Tooltip | ModifiedRowState | Modified row
 | AddedRowState | Added row
 | DeletedRowState | Deleted row
 | PendingChangesEmpty | There are no pending changes
 | PendingChangesExisted | There are {0} pending changes: {1} insert(s), {2} edit(s), {3} delete(s)
 | ReviewChanges | Review Pending Changes
 | UndoChanges | Undo All Changes
 | AcceptChanges | Accept All Changes
ContextMenu/Row | UndoSelection | Undo Selection
 | DeleteSelection | Delete Selection

Note: You may find empty text entries when using languages other than English. If you found empty entries on the language and culture that you are familiar with, please help us to translate the entries using the default.xml as the template and send it to feedback@intersoftpt.com.

Compatibility with Other Features

As in every major release of WebGrid, every new feature and enhancement are designed to work in conjunction with existing features. There are, though, some conditions and scenarios where the enhancements are not applicable, such as due to behavior conflicts.

In addition to comprehensive hierarchical tables and client side editing support, SmartBatchUpdate is also designed to work with existing features. Some of noteworthy key features are such as listed in the following:

  • All user interaction features, such as column resizing, moving, selection and context menu.
  • All databound operations, such as sorting, grouping and filtering.
  • Special support for column grouping, where newly added rows will remain visible and will be properly indented according to the group level.
  • Data paging includes both classic paging and virtual load.
  • Cell-select editing mode.
  • Columnset layout mode.
  • Column freezing.
  • Auto-filter suggestion.
  • Preview row.
  • Self referencing.

Multiple Selection feature is also enhanced to work in harmony with batch update feature. When you select multiple rows that contain pending changes, the Undo Selection command will appear in context menu, allowing end user to quickly undo multiple pending changes. Also, when deletion feature is enabled and multiple rows are selected, Delete Selection will appear in the context menu.

All client side APIs and object models continue to work and function normally as published in the documentation.

There are no unknown compatibilities with specific features that could cause errors or misbehaviors when batch update is enabled as far as the time of this writing.

Client-side Programmability

SmartBatchUpdates is a set of comprehensive object models and application programming interfaces (API), serving as the main foundation and architecture for the pending changes concept introduced in WebGrid 7.

All pending changes operation that invoked from WebGrid's user interface is also using the same set of APIs and interfaces. The result is a powerful and highly extensible client side batch editing architecture, which enables developers to further extend the functionality to address their complex business requirements.

The following sections describe the new classes, methods and client side events that introduced as core programming interfaces for the batch update feature.

New classes

WebGridBatchUpdateSettings
This class contains all settings and behaviors related to batch update feature.

Properties:

  • AllowReviewChanges (bool)
  • AllowUndoChanges (bool)
  • AutomaticObjectUpdate (readonly, bool)
  • PromptOnUndoAllChanges (bool)
  • NotifyOnLostFocus (bool)
  • HighlightChanges (bool)

WebGridCellData
This class holds the delta information of modified cell data.

Properties:

  • Column (WebGridColumn object)
  • OldValue (object)
  • OldText (string)
  • NewValue (object)
  • NewText (string)

WebGridRowChanges
This class represents the changes for a row object.

Properties:

  • RowState (readonly, string). Possible values: Added, Modified, Deleted.
  • Element (readonly, HTMLRow object)
  • Data (readonly, Array of WebGridCellData)
  • Row (readonly, WebGridRow object)
  • KeyValues (readonly, string)
  • Table (readonly, WebGridTable object)

Methods:

  • MergeChanges. Parameter: the row to be merged (WebGridRow object).
  • GetExistingData. Parameter: the name of cell to retrieve (string).

New methods

Several methods have been added as extensions to provide batch update functionality. These methods will only be available when batch update feature is used.

Class | New Method | Parameters
WebGrid | GetChangesCount ( Returns the count of all pending changes regardless of the state and table) | -
 | UpdatePendingChangesStatus (Synchronize pending changes with Grid's user interface elements) | -
 | UndoallChanges (Undo all pending changes regardless of the state and table) | -
 | AcceptAllChanges (Accept all pending changes and submit them to server for batch update) | -
 | GetChanges (Returns a list of WebGridRowChange objects) | rowState (Specifies the state of the changes to get)
 | InvalidateChanges (Invalidate all pending changes to be reprocessed in the next synchronization) | -
 | ClearChanges (Clear and remove all pending changes regardless of the state and table) | -
WebGridTable | GetChanges (Return a list of pending changes that existed in this table) | rowState (Specifies the state of the changes to get)
 | GetChangesCount (Returns the count of the pending changes in this table) | -
 | UndoChanges (Undo all pending changes in this table) | -
 | InvalidateChanges (Invalidate all pending changes in this table) | -
WebGridRow | GetChanges (Returns the changes made to this row) | rowState (Specifies the state of the changes to get)
 | GetRowState (Returns the state of this row. It will returns Unmodified if this row has no changes) | -
 | InvalidateRowState (Invalidate the state of this row to be processed in the next synchronization) | -
 | UndoChanges (Undo changes made to this row) | skipUpdateStatus (Specifies whether to skip the status updating after undo)
 | AddPendingChanges (Mark changes made to this row and add it into pending changes collection) | isProgrammatic (Specifies whether the method is called by user code)
 | SetDeleted (Mark this row as deleted) | -
WebGridCell | SetChanges (Change the text and value of this cell) | text (The new text to be set) value (The new value to be set. This parameter is optional, and only useful for valuelist column)

New client side events

The following table describes the new client side events related to batch update feature.

Event Name | Description | Parameters
OnUndoChanges | Fired when a row changes is about to be undo'ed | controlId, rowObject (The row to be undo'ed)
OnUndoAllChanges | Fired when undo all changes command is performed. | controlId
OnAcceptAllChanges | Fired when accept all changes command is performed | controlId
OnAddPendingChanges | Fired when a pending changes is about to be added | controlId, table (The table on which pending changes is added to), rowChange (The tow change object)
OnRemovePendingChanges | Fired when a pending changes is about to be removed | controlId, table (The table on which pending changes is added to), rowChange (The row change object)
OnBatchUpdateSuccess | Fired when batch update operation has been successfully completed | controlId, hasPartialErrors (Whether the batch update contains one or more errors), partialErrorsXml (The xml document contains partial errors data)

Server-side Programmability

As in client-side, the same set of new classes and methods have also been added to server-side. This enables reliable synchronization between client-side and server-side, which results in consistent interfaces and elegant objects design.

For shared set of the new classes, methods and properties; please refer to Data editing with new Batch Update mode section above.

The following list shows additional methods to perform server-side related tasks.

  • WebGrid class.

  • Methods:
  • GetChanges()
    Returns all pending changes regardless of the row's state and table.

  • GetChanges(RowState rowState)
    Returns all pending changes with given row state.

  • PerformBatchUpdate(bool throwExceptionOnError)
    Processes changes and updates it to physical database programmatically.

  • GetBatchUpdateExceptions()
    Returns one or more exceptions that occurred while processing batch update.

  • AddBatchUpdateException(WebGridBatchUpdateException exception)
    Adds an exception when a batch update-related error occurred. Use this method to take advantage of partial error support in custom object updating scenario.

  • Events:

  • OnBatchUpdate. Provided BatchUpdateEventArgs as the event argument.
    This event will always be invoked when batch update feature is enabled. This event is required to be handled for traditional and custom object binding. You can cancel WebGrid for further processing by setting false to its ReturnValue.

  • WebGridTable class.

  • Methods:

  • GetChanges(RowState rowState)
    Returns all pending changes in this table, given the row state.

  • UpdateRowIdentity(string dataMember, object originalValue, object processedValue)
    Updates and maps new identity of successive row inserts to intermediate objects in the data source. This method is required for traditional and custom object binding.

The provided server side APIs, as described above, enables you to programmatically work against pending changes data that submitted from client-side.

Several scenarios that can be achieved by using the provided APIs:

  • Get the pending changes per table and per row state for further processing in your business object level.

    You can use GetChanges method at WebGrid or WebGridTable object to get the desired changes.

    The RowState enumeration includes the following values: Added, Modified and Deleted. You can query the changes based on one or multiple RowState.

    For example, the following C# codes show how to query pending changes for Added and Modified state:

    C# Copy Code
    List<WebGridRowChanges> changes = WebGrid1.RootTable.GetChanges(RowState.Added | RowState.Modified);
foreach (WebGridRowChanges change in changes)
{
   // process each changes
}

    Note that the pending changes data will not be submitted on WebGrid's FlyPostBack actions for performance wise. The changes will be available upon the following conditions:

    • Full Postback.
    • Accept Changes FlyPostBack action.
    • ASP.NET AJAX callback.

  • Perform batch update on a server-side button click. In some cases, you might prefer to have your own button to process the pending changes, in addition to the user interface provided by WebGrid.

    You can achieve this task by calling PerformBatchUpdate method available in WebGrid object. See the following C# sample:

    C# Copy Code
    private void Button1_Click(object sender, EventArgs e)
{
   WebGrid1.PerformBatchUpdate(true);
}
    The PerformBatchUpdate follows the same process and life cycle of batch update, such as processing automatic object updates and invoking OnBatchUpdate event.

  • Process pending changes programmatically and call your custom data access method to perform physical update. This scenario is especially useful when you bind WebGrid to custom object collection instead of dataset or datasource control.

    The following C# codes show how to use many of the server-side methods to iterate each change and update it using custom data access layer.

    C# Copy Code
    protected void WebGrid1_BatchUpdate(object sender, BatchUpdateEventArgs e)
{
   foreach (WebGridRowChanges rowChanges in e.PendingChanges)
   {
      CustomObjects.Customer customer = null;
      try
      {
         switch (rowChanges.RowState)
         {
            case RowState.Added:
                customer = new CustomObjects.Customer();
                MapChangesToObject(rowChanges.Data, customer);
                DataLayer.InsertCustomer(customer);
                break;
            case RowState.Modified:
                customer = DataLayer.GetCustomer(rowChanges.KeyValue.ToString());
                MapChangesToObject(rowChanges.Data, customer);
                DataLayer.UpdateCustomer(customer);
                break;
            case RowState.Deleted:
                customer = DataLayer.GetCustomer(rowChanges.KeyValue.ToString());
                DataLayer.DeleteCustomer(customer);
                break;
          }
       }
       catch (Exception exp)
       {
          // adds the Exception to batch update list to take advantage of WebGrid's partial errors support.
          WebGrid1.AddBatchUpdateException(
newWebGridBatchUpdateException(rowChanges,
          new Exception("Record '" + rowChanges.KeyValue.ToString() +
"' has error '"+ exp.Message + "'", exp)));
       }
    }
}
    The following is the C# codes to map the changes into object.
C# Copy Code
private void MapChangesToObject(List data, CustomObjects.Customer customer)
{
   foreach (WebGridCellData cellData in data)
   {
      string newText = cellData.NewText;
      switch (cellData.Column.DataMember)
      {
         case "CustomerID":
            customer.CustomerID = newText;
            break;
         case "Address":
            customer.Address = newText;
            break;
...
      }
   }
}

Codes Explanation:

  • In custom object scenario, developers often have their own data access layer to perform data management such as select, inserts, updates and deletes. Thus, you need to handle OnBatchUpdate server side event to process the changes as shown in above sample codes.
  • You can access all pending changes from e.PendingChanges, which is List<WebGridRowChanges>.
  • You iterate on each WebGridRowChanges. Then perform update based on the RowState value.
  • Notice that we used strongly-typed custom object to perform data update in elegant fashion. For add and modified changes, you need to map the changes into the object accordingly. In the sample above, it is done with MapChangesToObject function.
  • Call AddBatchUpdateException when an exception occurred. This enables the codes to continue updating the other records. This error handling is also taking advantage of partial errors support.

See Also

WebGrid Features Overview

Getting Started
Getting Started

Other Resources
Walkthrough Topics
How-to Topics


Built-in Custom Editor

Built-in Custom Editor
See Also Send Feedback
Intersoft WebGrid > WebGrid Features Overview > Editing Data > Built-in Custom Editor

Glossary Item Box

This topic contains the following sections:

  • Introduction
  • Define your own editing control
  • Custom Editor Interfaces
  • Attach your custom editor
  • Deployment
  • Tutorial
  • Using NumericUpDown CustomEditor
  • Using Calculator CustomEditor
  • Using HTMLEditor CustomEditor
  • Using SliderBar CustomEditor

Introduction

WebGrid introduced several built-in EditType to be used in conjunction with built-in cell editing feature. In WebGrid Enterprise, you would be surprised that we do not add much EditType but one - Custom. The new version is promised to let you use your favorite editing control and "hook" it up into WebGrid easily. This great and powerful feature will allow you to use virtually any types of controls as WebGrid's EditType, whether it is an ASP.NET Server Control or a DHTML Client Control.

The core architecture that made all of these possible - CustomEditor open architecture - is a set of client-side interfaces that need to be implemented by each custom editor in order for the interfacing with WebGrid.NET core editing architecture. These interfaces have been defined to be very flexible, extensible and modular. To give you an idea of how the interfaces work and correspond with built-in editing architecture, please see following chart:

Developers can easily wrap their favorite editor into these interfaces and WebGrid will be able to properly interface with the editor functionality and call appropriate methods and events based on user's action. Moreover, in conjunction with OnTheFly architecture, the custom editor interface is written once and can be reusable in any numbers of columns, tables and even in different grids instance in same page. Developers don't have to worry about the dealing with custom editor object itself, such as dynamic object creation, object instantiated for each assigned column, and more. We have made it so that there are no additional interfaces or codes needed in server side, all of them are automatic such as hiding them on first page load and so on. The final release of WebGrid 4.0 is planned to include "Editors Pack 1" which contains 3 editors that are ready to use. Two of them will be a DHTMLClientControl and one will be ServerControl. These editors will give developers a quick start to learn and develop rich editors that can be "hooked" up into WebGrid that built on the top of OnTheFly architecture. The installed Custom Editors will not be visible in CustomEditors designer since it is packed and shouldn't be modified. These editors will be automatically visible in CustomEditorName dropdown designer in WebGridColumn property.

As seen in following screenshot, a sample of server-side customeditor implementation by using WebGrid's editor (RichTextBox) server control. Something that is never possible before is now possible with the new version of WebGrid, enabling even more advanced data and content management application - with even richer and more sophisticated user's experience - to be done in much less time and efforts than ever before.

With the power and great extensibility provided with the Customeditor open architecture specifically and WebGrid built-in editing in general, it is hopefully to open new market and opportunity to 3rd party vendors to develop their editing products to support WebGrid CustomEditor architecture or develop new products specifically targetting WebGrid.NET Enterprise in near future.

Define your own editing control

You can easily define your editing control and its behavior in the rich object model provided by WebGrid in designer. In Custom Editors node inside WebGrid.NET Designer, click Add to create new custom editor. A custom editor is made of following properties:

Properties | Description
ControlType | The type of your custom editor. A Server Control or DHTML Client Control. Server Control means that the custom editor would require an instance of object in server side. DHTML Client Control doesn't require the custom editor to be instantiated in server side.
JavaScriptEncoded | Specifies whether the javascript files for this control is encoded. When set to True, the script will automatically rendered as "JScript.Encode".
JavaScriptFiles | The javascript files required by this control. Define multiple javascript files by using semi colon. Example: Object_Core.js; Object_UI.js.
Name | The name of the custom editor. The name must be unique through all collection regardless of whether it is installed custom editors or designer-persisted.
Persistence | Specifies how this custom editor should be persisted. Valid values are GridLevel and DesignerLevel. When GridLevel (default) is specified, the custom editor will be saved to the grid's instance and therefore will be applicable by that grid only and can't be seen in other grids. When DesignerLevel is specified, the custom editor definition will not be saved in the current webpage. Instead, it will be saved as a separate WCE file in a special CustomEditor folder. DesignerLevel's custom editors can be highly reusable and is visible throughout the entire project as well as in different projects.
ScriptFolder | Specifies the folder containing the scripts which should be accessible through IIS. By default, ScriptFolder is made on the top of grid's ScriptFolder. For example: Grid's ScriptFolder by default is /CommonLibrary/WebGrid/V3_5_5000/. In this case, the ScriptFolder for custom editor when set to Empty will point the scripts to /CommonLibrary/WebGrid/V3_5_5000/CustomEditors. If the ScriptFolder doesn't contain "/" character, the ScriptFolder will be made "relative" to the grid's [ScriptFolder]/CustomEditors. For example: ScriptFolder is set to "EditorsPack1", the result path would be "/CommonLibrary/WebGrid/V3_5_5000/CustomEditors/EditorsPack1".
ServerControlFullName | Specifies the server's control full name. This is required when the ControlType is ServerControl. The fully qualified assembly name should be : [AssemblyNamespace].[ClassName]. For example: ISNet.WebUI.WebCombo.WebCombo
Behavior: |
BaseEditorType | Defines the base editor type of the custom editor. Default is Textbox. Most of scenarios will use Textbox as the base editor control, such as NumericUpDown or Calculator. In this case, many of the base editing functionality is automatically handled by internal custom editor API. For more advanced scenarios, you can "draw" your own base editor type by setting this property to Custom. In that case, you would need to completely implement the GetBaseEditorElement interface and handle the base editor creation manually.
DropdownButtonImageFile | Specifies the dropdown button's image file. The image file should be located in the same folder as specified in ScriptFolder.
DropdownButtonType | Defines the dropdown button's type. The default button type is Image. You can set to Custom to build your own dropdown button and implement the GetDropdownButtonElement interface.
DropdownButtonWidth | Defines the width of dropdown button, if any.
HasDropdownButton | Determines whether the custom editor has dropdown behavior.
Tag | Specifies additional information about the custom editor.

Custom Editor Interfaces

Custom Editor interfaces is a set of client side methods which definition have been made very modular for flexibility. These methods are all the required implementation for a custom editor. There are no server-side interfaces that need to be implemented even for "ServerControl" control type as they have all been taken care automatically in WebGrid's internal code. The custom editor interfaces implementation are vary depending on the complexity of a custom editor. For example, several advanced interfaces can be left unimplemented when the custom editor doesn't need the scenario. However, most of the interfaces are required implementation and should be fully implemented in order for the core Editing to communicate with them properly.

You usually write a custom editor interface in a JS format (JavaScript). For quick start, you can grab NumericUpdown.js that come with "Editors Pack 1". All three included custom editors have the source code fully documented, so you can quickly pick one of them as your base template and start your own custom editor development. Once you finished the custom editor interfaces, you can reuse it throughout all your projects by setting the Persistence to DesignerLevel!

Interfaces List

Interface Name | Description
OnInitialize | Fired on WebGrid's initialization. Put codes to initialize custom editor's properties and create necessary objects here
OnUnload | Fired on WebGrid's unload. Put codes to clean up objects or resources here.
OnEnterEditMode | Fired when the control is entering edit mode.
OnSetValue | Fired when the control is about to be displayed during enter edit mode. The value of the editor need to be set to reflect current cell's text.
OnDirty | Fired when the editor's content is changed.
OnExitEditMode | Fired when the editor is about to exit edit mode.
OnApply | Fired when the changes in editor is applied/accepted.
OnCancel | Fired when user cancel the changes in editor, by pressing Escape in editor or entire row changes cancel.
OnValidate | Fired when the cell is about to exit edit mode. When the validation result is true, it will process to exit edit mode.
OnKeyDown | Fired when user type on keyboard (only for customeditor that has baseeditor).
OnDropdown | Fired when dropdown button is clicked. Automatically fired used when dropdown button type is Image, or F4 key is pressed
GetBaseEditorElement | Required method to get base editor element.
GetDropdownButtonElement | Required method to get dropdown button element.
GetDropdownObject | Required method to get dropdown list object.
IsDirty | Required method to get the IsDirty status of the editor.
GetText | Required method to get the content of the editor.
GetValue | Required method to get the value of the editor. Only useful when editor value is differ then content/text such as in Dropdownlist.
SetProperties | Required method to apply editor properties defined in Column's CustomEditorProperties.
ShouldProcessExitEditModeDefaultBehavior | Indicates whether default behavior of exit edit mode should be processed. This method is optional.
GetContentMode | Specifies the cell's content mode. This method is optional.

Attach your custom editor

Once your custom editor is ready, you can test it directly in the WebGrid. Firstly, you go to WebGrid Designer, and select a column of RootTable. Next, you simply dropdown the CustomEditorName property and a list of available custom editors will appear. Your custom editor should appear as well. If your custom editor is a ServerControl type, you would also need to create an instance of the server control first into the design surface. Then select the server control's ID from the CustomEditorServerID dropdown.

Deployment

The script files and all supporting client files such as xml or image files should be available in the folder specified in ScriptFolder (see above). These files must be copied along with your application. By default, the CustomEditor scriptfolder is based on grid's ScriptFolder which default to centralized deployment concept "CommonLibrary". It is highly recommended that you use the "CommonLibrary" deployment concept so that you only need to remember one thing - "CommonLibrary" - then simply copying it to your production's server and map it to IIS.

To deploy the project using SmartWebResources, see Deploying project that uses SmartWebResources.

Tutorial

A tutorial to guide you applying custom editor is available in WG50Tutorial Solution. Check out the "CustomEditor.aspx" web form inside the Tutorial solution.

Using NumericUpDown CustomEditor

NumericUpDown custom editor is built-in installed with WebGrid and should be available in CustomEditorName dropdown. NumericUpDown is a DHTMLClientControl and it is very easy to apply it to a Column.

  1. Set the CustomEditorName in WebGrid Designer.

  2. Set the CustomEditorProperties. There are two properties available in NumericUpDown :
    • MinValue: The minimal value allowed for the control. Data Type: Int. Default Value: 0.
    • MaxValue: The maximal value allowed for the control. Data Type: Int. Default Value: 2147483647.

To enable validation for a NumericUpDown, simply set the properties in CustomEditorProperties. Separate each property with ; character. For example: MinValue=10;MaxValue=50. You could find CustomEditorProperties in WebGrid.NET Designer - Advanced tab - RootTable - Click See all properties.

Deployment

The EditorsPack1 folder inside ScriptFolder/CustomEditors (default is /CommonLibrary/WebGrid/V5_0_7200/CustomEditors) must be copied along with your application files to production server. The EditorsPack1 folder must be placed inside ScriptFolder/CustomEditors. The centralized deployment concept "CommonLibrary" allows you to easily deploy Intersoft's components along with your web applications by simply copying the "CommonLibrary" folder and map it to IIS.

To deploy the project using SmartWebResources™, see Deploying project that uses SmartWebResources.

Using Calculator CustomEditor

Calculator custom editor is built-in installed with WebGrid and should be available in CustomEditorName dropdown. Calculator is a DHTMLClientControl and it is very easy to apply it to a Column.

  1. Set the CustomEditorName in WebGrid Designer.

  2. Set the CustomEditorProperties.

Following is a list of properties available in Calculator.
- Mode (Combo / DropDown). Data Type: String. Default Value: Combo. Valid Values: Combo or Dropdown
- Font-Name. Data Type: String. Default Value: Verdana. Valid Values: HTML Style Font-Name value
- Font-Size. Data Type: String. Default Value: 8pt. Valid Values: HTML Style Font-Size value
- Font-Weight. Data Type: String. Default Value: normal. Valid Values: HTML Style Font-Weight value
- ForeColor. Data Type: String. Default Value: Empty String. Valid Values: HTML Style ForeColor value
- Width. Data Type: String. Default Value: 120. Valid Values: HTML object Width value
- Height. Data Type: String. Default Value: 120. Valid Values: HTML object Height value
- BackgroundColor. Data Type: String. Default Value: "#f5f5f5". Valid Values: HTML Style Color value
- BorderColor. Data Type: String. Default Value: darkgray. Valid Values: HTML Style Color value
- NumericHighLightColor. Data Type: String. Default Value: ""#dcdcdc". Valid Values: HTML Style Color value
- OperatorHighLightColor. Data Type: String. Default Value: "#a9a9a9". Valid Values: HTML Style Color value

You can change the mode and other appearance settings of Calculator, simply set the properties in CustomEditorProperties. Separate each property with ; character.
For example: Mode=Combo;Font-Name=Tahoma;Font-Size=10pt

Deployment

The EditorsPack1 folder inside ScriptFolder/CustomEditors (default is /CommonLibrary/WebGrid/V6_0_7200/CustomEditors) must be copied along with your application files to production server. The EditorsPack1 folder must be placed inside ScriptFolder/CustomEditors. The centralized deployment concept "CommonLibrary" allows you to easily deploy Intersoft's components along with your web applications by simply copying the "CommonLibrary" folder and map it to IIS.

To deploy the project using SmartWebResources, see Deploying project that uses SmartWebResources.

Using HTMLEditor CustomEditor

Using HtmlEditor

HtmlEditor custom editor is built into WebGrid and should be available in the CustomEditorName property's dropdown. HtmlEditor is a DHTMLClientControl and designed so it is easy to use.

Setting a column to use HtmlEditor as its edit type

You can easily set a column of your table to use HtmlEditor as its edit type from the WebGrid Designer. Open the Designer and select the column you wish to apply. In the properties pane, select HtmlEditor from the dropdown of the CustomEditorName property. After the selection is accepted, the EditType value will automatically change to Custom. Click OK and the column will now be configured to use HtmlEditor as its edit type.

Editing text using HtmlEditor

Using the editor to edit text is intuitive and requires no specific knowledge. For example, to apply bold style to a word, simply highlight the word and click the bold icon.

Inserting objects into the HTML text is done by filling the input fields of the respective popup windows:

  • Insert image

  • Insert hyperlink

  • Color picker

The color picker will be shown when applying a color or highlight to the text.

Customizing HtmlEditor

HtmlEditor has its own folder -inside ScriptFolder/CustomEditors/EditorsPack2 (default folder is '/CommonLibrary/WebGrid/V6_0_7200/CustomEditors')- which is used to configure the layout of the control such as button icons and a number popup windows of the control.

You can customize many aspects of the HtmlEditor such as width, height, font names and sizes listed in the dropdowns, toolbar color, icons, etc.

To customize the HtmlEditor, first you need to create a .js file that will be used to store the configuration. The file should be put inside the '/CommonLibrary/WebGrid/V6_0_7200/CustomEditors' directory and named as editor_config.js. In the text file, create a new object that will be used to hold the configuration settings of the control. Then, you can set various properties to customize the control. Below is an example on how to customize the HtmlEditor control:

editor_config.js

JavaScript Copy Code
/* save as: editor_config.js */

// create new config object to store the configuration.
var config = new Object();

// set the desired width, height and body style
config.width = "90%";
config.height = "200px";
config.bodyStyle = 'background-color: white; font-family: "Verdana"; font-size: x-small;';
config.debug = 0;

// NOTE: You can remove any of these blocks (config.toolbar, config.fontnames, etc)
//       and then the default configuration will be used.
config.toolbar = [
    ['fontname'],
    ['fontsize'],
    ['fontstyle'],
    ['linebreak'],
    ['bold','italic','underline','separator'],
//  ['strikethrough','subscript','superscript','separator'],
    ['justifyleft','justifycenter','justifyright','separator'],
    ['OrderedList','UnOrderedList','Outdent','Indent','separator'],
    ['forecolor','backcolor','separator'],
    ['HorizontalRule','Createlink','InsertImage','htmlmode','separator'],
    ['about','help','popupeditor'],
];

config.fontnames = {
    "Arial":           "arial, helvetica, sans-serif",
    "Courier New":     "courier new, courier, mono",
    "Georgia":         "Georgia, Times New Roman, Times, Serif",
    "Tahoma":          "Tahoma, Arial, Helvetica, sans-serif",
    "Times New Roman": "times new roman, times, serif",
    "Verdana":         "Verdana, Arial, Helvetica, sans-serif",
    "impact":          "impact",
    "WingDings":       "WingDings"
};

config.fontsizes = {
    "1 (8 pt)":  "1",
    "2 (10 pt)": "2",
    "3 (12 pt)": "3",
    "4 (14 pt)": "4",
    "5 (18 pt)": "5",
    "6 (24 pt)": "6",
    "7 (36 pt)": "7"
};

// link a stylesheet to the config object.
// config.stylesheet = "http://www.domain.com/sample.css";

config.fontstyles = [
  { name: "headline", className: "headline",
    classStyle: "font-family: arial black, arial; font-size: 28px; letter-spacing: -2px;" },
  { name: "arial red", className: "headline2",
    classStyle: "font-family: arial black, arial; font-size: 12px;
    letter-spacing: -2px; color:red" },
  { name: "verdana blue", className: "headline4",
    classStyle: "font-family: verdana; font-size: 18px; letter-spacing: -2px;
                color:blue" }

  // you need to define a class somewhere (in a page or a stylesheet file)
  // and set its style if you leave the classStyle blank.
  { name: "verdana blue", className: "headline4", classStyle: "" }
];

Deployment

The EditorsPack1 folder inside ScriptFolder/CustomEditors (default is /CommonLibrary/WebGrid/V6_0_7200/CustomEditors) must be copied along with your application files to production server. The EditorsPack2 folder must be placed inside ScriptFolder/CustomEditors. The centralized deployment concept "CommonLibrary" allows you to easily deploy Intersoft's components along with your web applications by simply copying the "CommonLibrary" folder and map it to IIS as an application.

To deploy the project using SmartWebResources, see Deploying project that uses SmartWebResources.

Using SliderBar CustomEditor

Using SliderBar

SliderBar is a new custom editor control which is built into WebGrid Enterprise and should be available in CustomEditorName property's dropdown. SliderBar is a DHTMLClientControl and it is designed to allow users to conveniently input numeric values with rules such as maximum/minimum value, interval value, etc.

Navigating the SliderBar

SlideBar can be handled using mouse drags as well as keyboard navigation arrows (Up/Down arrow key for vertical SlideBar and Right/Left arrow key for horizontal SliderBar). Following is the list of keys that can also be used to navigate the slider:

  • Home - move to MinValue
  • End - move to MaxValue
  • PgUp - move lower per IntervalLarge value. (not applied for smooth movement / Interval=0)
  • PgDn - move higher per IntervalLarge value. (not applied for smooth movement / Interval=0)

Setting a column to use SliderBar as its edit type

You can easily set a column of your table to use SliderBar as its edit type from the WebGrid.NET Designer. Open the Designer and go to advanced tab - RootTable - click see all properties then select the column you wish to apply. In the properties pane, select SliderBar from the dropdown of the CustomEditorName property. After the selection is accepted, the EditType value will automatically change to Custom. Click OK and the column will now be configured to use SliderBar as its edit type.

In CustomEditorProperties you can set the MinValue and MaxValue as shown in the picture below.

Customizing SliderBar

You can change the mode and other appearance settings of SliderBar by simply setting the properties in CustomEditorProperties. Specify the property you want to customize and provide the value, then separate each property with a semicolon ';'. For example: "Type=x;Interval=5;MaxValue=80;MinValue=20;Width=150;"

Note that you should input the line above (without quotes) as a string into the CustomEditorProperties property.

Following is the list of properties you can customize in SliderBar:

Type

Description
Specifies the orientation of the slider control. 'x' for horizontal and 'y' for vertical.

ValueType
string

Default Value
'x'

Valid Value
'x' or 'y'

Width

Description
Specifies the width (in pixel) of the SliderBar.

ValueType
integer

Default Value
- 200 ( for horizontal SliderBar )
- 20 ( for vertical SliderBar )

Height Description
Specifies the height (in pixel) of the SliderBar.

ValueType
integer

Default Value
- 20 ( for horizontal SliderBar )
- 200 ( for vertical SliderBar )
SliderSize Description
Specifies the size (in pixel) of the slider.

ValueType
integer

Default Value
10
SliderImage Description
The path of the slider handle image.

ValueType
string

Default Value
-
MaxValue

Description
The maximum value of the SliderBar.

ValueType
integer

Default Value
10

MinValue

Description
The minimum value of the SliderBar.

ValueType
integer

Default Value
0

Interval

Description
The interval movement (snap) of the SliderBar.

ValueType
integer

Default Value
1

Valid Value

Any integer number that is less than (MaxValue - MinValue). Negative value is invalid. If set to 0, the slider movement would be per pixel (smooth movement, without snapping).

IntervalLarge

Description
The large interval movement of the SliderBar. The snap interval when the track of the SliderBar is clicked or when PageUp/PageDown button is used to navigate.

ValueType
integer

Default Value
2

Valid Value

Any integer number that is less than (MaxValue-MinValue) and bigger than Interval value. (Negative value is invalid).

Value

Description
The value of the SliderBar.

ValueType
integer

Default Value
-

TrackSize

Description
The size of the track in the SliderBar.

ValueType
integer

Default Value
5

Valid Value

Any integer number that is less than the value of the Height property (for horizontal SliderBar), or Width property (for vertical SliderBar).

See Also

WebGrid Features Overview

Getting Started
Getting Started

Other Resources
Walkthrough Topics
How-to Topics


Custom Editors Pack 3

Custom Editors Pack 3
See Also Send Feedback
Intersoft WebGrid > WebGrid Features Overview > Editing Data > Built-in Custom Editor > Custom Editors Pack 3

Glossary Item Box

For the first time since version 4, WebGrid 7 is preloaded with more custom editors - delivering richer and more natural editing experiences. Bundled into Custom Editors Pack 3, WebGrid introduces Vista-style calendar and WebTextEditor custom editor.

Vista-style Calendar Custom Editor

The new WebCalendar custom editor gives users the look and feel of Vista-style date picker which provides the easiest way to navigate month, year, and range of years. Unlike the built-in Calendar, WebCalendar is far more robust and versatile with its lightweight component design and minimalist visual theme.

Fully integrated with WebCalendar API, you can take advantage of many powerful calendar features, such as multiple months display, show week numbers, built-in themes, automatic globalization support, date format customization and much more.

When the WebCalendar custom editor is used, WebGrid will automatically add client resource references to WebScheduler_Calendar, several images and style resources. Please make sure that WebScheduler's resource files have been added to your project.

WebTextEditor Custom Editor

WebGrid 7 now supports WebTextEditor as the rich text editor integrated into WebGrid's editing environment - enabling users to leverage the powerful and advanced editing capabilities of WebTextEditor in the convenience of one-click inline editing.

WebTextEditor is Intersoft's flagship rich editing component for ASP.NET that delivers innovative editing features, high performance, and full cross-browser support. The key features include natural user interface with integrated spell-checker, real-time uploader, and built-in media gallery. Click here to learn more.

WebTextEditor is a standalone server-side component and require to be licensed separately. For more information about WebTextEditor licensing, please contact Intersoft Sales.

See Also

WebGrid Features Overview

Getting Started
Getting Started

Other Resources
Walkthrough Topics
How-to Topics


Intersoft WebCombo.NET Integration

Intersoft WebCombo.NET Integration
See Also Send Feedback
Intersoft WebGrid > WebGrid Features Overview > Editing Data > Built-in Custom Editor > Intersoft WebCombo.NET Integration

Glossary Item Box

WebGrid can be integrated with WebCombo.NET as an EditType. This integration can be specified using WebGrid Designer or programmatically in runtime.

This topic contains the following sections:

  • Using WebGrid Designer to Integrate WebCombo.NET
  • Programmatically Integrate WebCombo.NET
  • Multiple values editing using WebCombo.NET 4.0
  • Enhanced integration with WebCombo

Using WebGrid Designer to Integrate WebCombo.NET

Using WebGrid Designer, the integration can be done by specifying two properties which are EditType and WebComboID. In EditType property, choose WebComboNET and in WebComboID property, choose the WebCombo ID that will be integrated to WebGrid.

Programmatically Integrate WebCombo.NET

To integrate WebCombo.NET as WebGrid's edit type programmatically, you can add the following code in the server side:

C# Copy Code
private void WebGrid1_InitializeLayout(object sender, ISNet.WebUI.WebGrid.LayoutEventArgs e)
{
    WebGrid1.RootTable.Columns.GetNamedItem("SupplierID").EditType = EditType.WebComboNET;
    WebGrid1.RootTable.Columns.GetNamedItem("SupplierID").WebComboID = "wcCategory";
}

Multiple values editing using WebCombo.NET

In conjunction with Multiple Values feature in the improved WebValueList, WebGrid 5.0 also includes the ability to edit the multiple values data that translated using the WebValueList.

This powerful feature implements deep integration between Intersoft's WebGrid and WebCombo control. With Multiple Selection feature available in WebCombo.NET version 3.0+, the WebGrid control seamlessly connect to WebCombo control in order to edit and return multiple values data of the selected cell.

In addition to multiple values editing, WebGrid 5.0 supports deeper integration with WebCombo.NET 4.0 control in other areas such as in user interface and editing environment. For instance, when both WebCombo and WebGrid control are using Default Style, the WebCombo control's appearance will be adjusted automatically to fit into the editing cell. This automated behavior ensures rich editing experience with consistent look.

Enhanced integration with WebCombo

Since its initial release, WebGrid Enterprise™ has been well known with its tight integration with other Intersoft's products, especially integration with WebCombo.

In version 7, WebGrid enhances the WebCombo integration further in various scenarios such as when used in Custom and Image column type.

WebGrid 7 enables you to achieve more complex scenarios to deliver richer user experience, such as using Custom column type to display custom images. You can use WebCombo to allow your users to edit such type of information more intuitively.

When WebCombo is used in Custom column type, WebGrid automatically map the cell's value to the text field of WebCombo, while maintaining default inline editing behavior.

See Also

WebGrid Features Overview

Getting Started
Getting Started

Other Resources
Walkthrough Topics
How-to Topics
FAQ: Does WebCombo.NET 4.0 control included in WebGrid.NET Enterprise 5.0?


Intersoft WebInput.NET Integration

Intersoft WebInput.NET Integration
See Also Send Feedback
Intersoft WebGrid > WebGrid Features Overview > Editing Data > Built-in Custom Editor > Intersoft WebInput.NET Integration

Glossary Item Box

WebGrid can be integrated with WebInput.NET as a custom editor. This integration can be specified using WebGrid Designer or programmatically in runtime.

This topic contains the following sections:

  • Using WebGrid Designer to integrate WebInput.NET
  • Programmatically integrate WebInput.NET

Using WebGrid Designer to integrate WebInput.NET

Using WebGrid.NET Designer, the integration can be done by specifying two properties which are CustomEditorName and CustomEditorServerID. In CustomEditorName property, choose WebInputName and in CustomEditorServerID property, choose the WebInput ID that will be integrated to WebGrid.

Programmatically integrate WebInput.NET

To integrate WebInput.NET as WebGrid's edit type programmatically, add the following code in the server side :

C# Copy Code
private void WebGrid1_InitializeLayout(object sender, ISNet.WebUI.WebGrid.LayoutEventArgs e)
{
        WebGrid1.RootTable.Columns.GetNamedItem("Phone").EditType = ISNet.WebUI.WebGrid.EditType.Custom;
        WebGrid1.RootTable.Columns.GetNamedItem("Phone").CustomEditorName = "WebInputNET";
        WebGrid1.RootTable.Columns.GetNamedItem("Phone").CustomEditorServerId = "WebInput1";
}

See Also

WebGrid Features Overview

Getting Started
Getting Started

Other Resources
Walkthrough Topics
How-to Topics


Exporting Data

Exporting Data
See Also Send Feedback
Intersoft WebGrid > WebGrid Features Overview > Exporting Data

Glossary Item Box

The Enterprise edition includes built-in exporting functionality to HTML, PDF, TIFF, RTF, Excel, Text and XML format. The exporting process will take client's latest UI layout such as visible columns, columns order, grouped columns, sorted columns as well as filtered columns. This allows end-users to easily grab displayed data, manipulate and represent it in other way.

The exporting functionality is controlled in AllowExport property under LayoutSettings. When it is set to Yes, the Export icon will appear in the status bar. When clicked, a menu displaying export and page output options will appear. The export options depend on the last selected object, for instance, if a row is selected in child table then the 'Export selected child table' option will appear as you can see in following snapshot:

Generally, this feature is capable for exporting two type of grid's data, one is the root table and the other is selected child table's data. The export for root table will not export any hierarchical data because of performance issues and based on common requirements. The export for selected child table will export the entire data for the selected child table and not including any hierarchical data.

The built-in exporting feature incorporates DataDynamic's ActiveReports runtime engine to generate and output the reports to HTML and PDF format. The ActiveReport's engine is only used internally by WebGrid at runtime and does not require you to add references of ActiveReport's assembly in your VS.NET solution.

The included ActiveReport's engine doesn't contain any design-time capability and hence you can't use it for development purpose. Moreover, the ActiveReport's runtime is loaded on demand when the built-in exporting is used and export command is requested by client.

Instead of built-in exporting, WebGrid also allows you to use your own exporting codes or module to handle exporting functionality. You can handle the OnExport server side event, write customized exporting codes and set the event's ReturnValue to False for cancelling default process. You can also specify the different output file name to the provided ReportInfo object available in the event argument. When using your own custom exporting, you can skip the inclusion of built-in exporting runtime assemblies. That means WebGrid assembly does not depend on the built-in exporting runtime assemblies on deployment time. This makes the WebGrid totally independent, fully customizable and extensible.

Prior to the exporting process, you will need to create a folder to hold the generated output files. By default, the ReportPath is assigned to "~/TempReports" which means the "TempReports" folder should be created under the root of the web application. The folder also need to have enough permission to allow the asp-net worker process to write the generated output files into the folder. You can always change the ReportPath property and other report-specific property such as paper-type, orientation etc, in the ReportInfo object provided by the event argument in OnExport event.

If you have changed the default ReportPath, you also need to change the IISReportPath which is used as the relative IIS path for displaying the output file properly. The ReportPath contains the physical path of the output file such as "C:\Inetpub\wwwroot\WebApp1\TempReports\". The IISReportPath contains the relative path to the current web application, such as "TempReports/".

The exporting process also has the ability to delete temporary generated report file after a specific period of time. This setting can be changed in DeleteOutputFileTime property in the ReportInfo object provided. The DeleteOutputFileTime is based on Minute TimeSpan and has default value of 15.

Deployment Notes: This assembly needs to be installed in server's GAC for the built-in exporting to work properly: ISNet.ActiveReports.Exporting.dll

Walkthrough & How-To Topics

Walkthrough: Allowing Export in WebGrid

How-to: Invoke Export feature programmatically

How-to: Trigger Data Export in Client-Side Programmatically

How-to: Customize Export function

How-to: Export text when WebValueList is used

How-to: Use CacheToDisk feature to reduce memory usage

How-to: Set a different location for CacheToDisk feature

See Also

WebGrid Features Overview

Getting Started
Getting Started

Other Resources
Walkthrough Topics
How-to Topics


Printing Data

Printing Data
See Also Send Feedback
Intersoft WebGrid > WebGrid Features Overview > Printing Data

Glossary Item Box

In previous version, WebGrid already provided a feature, BrowserPrinterSettings if you want to print WebGrid. You can choose in BrowserPrinterSettings, whether just want to print as displayed on browser or all rows on WebGrid. However, there is no instant button to do print. You have to press 'ctrl + p' or choose print menu from the browser. In this version, WebGrid provides the instant button to do that. It is placed in status bar when you set 'AllowPrint' property to yes.

See Also

How-to: Set BrowserPrinter Settings
How-to: Set AllowPrint


Formatting Data

Formatting Data
See Also Send Feedback
Intersoft WebGrid > WebGrid Features Overview > Formatting Data

Glossary Item Box

WebGrid provides flexibility in displaying data, especially in data formatting. Often times, you need to display data in specific format in culture. WebGrid also provides this flexibility enabling you to customize the display data. You can show the data in specific format by setting DataFormatString property in WebGridColumn.

This topic contains the following sections:

  • Data Formatting
  • Conditional Formatting

Data Formatting

In edition to rich editing capability, WebGrid also provides full-featured data formatting capabilities such as masked data display and built-in validation support.

Built-in data validation and masked data display play important roles in the editing functionality. WebGrid includes a complete rewritten of .NET's data formatting feature into client side. This means that you can set any DataFormatString that is available to .NET such as "c" for currency, "d" for short date and even custom pattern such as "MM/dd/yyy" and so on. When the edit mode is activated, it will check the assigned DataFormatString and applies it to the built-in validation core function for data checking and masking.

The built-in validation is capable to validate Numeric and DateTime type precisely according to the specified CultureInfo and default international standards. For instances, when CultureInfo is set to English and the DataFormatString is set to "yyyy-MM-dd" for DateTime column, following input is properly parsed and validated:

Input | Description
07/20/2003 | Valid, meet CultureInfo's DateTime format.
07/20/03 or 07 20 03 | Valid, meet CultureInfo's DateTime format.
July 20, 2003 | Valid, meet CultureInfo's DateTime format.
Sunday, July 20, 2003 | Valid, meet CultureInfo's DateTime format.
07/20/03 13:50 | Valid, meet CultureInfo's DateTime format.
20 July 2003 or July 20 2003 | Valid, meet default custom DateTime pattern.
2003-07-20 | Valid, meet specified custom DateTime format pattern.

The results of the built-in validation for the above input are valid. WebGrid will invoke the formatting core engine to transform the masked input with the final result which is "2003-07-20".

This feature also works with the numeric data types such as Int32, Decimal, and so on. The most interesting part in Numeric masked display feature is its full support on Microsoft .NET's NumericInfo custom formatting, including positive pattern, negative pattern as well as zero pattern. It supports most of standard numeric format strings such as c for Currency, d for Decimal, e for Scientific, f for Floating Point, g for General, n for Number as well as p for Percent. Moreover, it also supports all custom format strings such as 0, #, ., comma, %, E0, \, Literal as well as ;.

For instances, when CultureInfo is set to English UK and DataFormatString is set to "$##,##0.00;##,##0.000 $-;Zero" (custom pattern), following inputs are properly validated and masked.

Input | Description | Format Result
150000 | Valid number. | £150,000.00
2,250 | Valid, meet CultureInfo's Number format. | £2,250.00
3,750.789 | Valid, meet CultureInfo's Number format. | £3,750.79
£ 42500 | Valid, meet CultureInfo's Number format. | £42,500.00
-12750 | Valid number. | 12,750.000 £-
-£1,500.50 | Valid, meet CultureInfo's Number format. | 1,500.500 £-
0 | Valid number. | Zero

The validation and display masking will take place immediately after you exit from the edit mode by pressing Tab, Shift Tab, Enter, Esc or click on another cell in the same row.

With all these powerful features in shell, WebGrid will be the most powerful and sophisticated data display and manipulation solutions for ASP.NET Web development available in the market at the time it is released.

Conditional Formatting

FormatConditions is a new feature attached per table, designed to allow you easily define the conditions in Designer and apply the styles automatically when the condition is met. There are numerous methods you can use to define the criteria, target object, and more.

There are two conditions matching mode, the first is a simple mode where you specify a ColumnMember, Operator and ConditionText to match and the second is CustomConditionText where you can specify a filtering against the datamember available in your datasource. The filtering used in CustomConditionText comforts to the ADO.NET expression specification and therefore allows you to match any complex conditions.

TargetObject contains two values : Row and Cell. When Row is used (default), the FormatStyle will be applied to the entire row when the condition criteria matched. When set to Cell, you need to specify the TargetColumnMember. In this mode, the FormatStyle will only be applied to TargetColumnMember.

FormatConditions is built on top of automatic style merging architecture, so if there are more than one condition that matched in a single target-object, the FormatStyle will all be applied having the style priority following the order of the format condition.

See Also

WebGrid Features Overview

Getting Started
Getting Started

Other Resources
Walkthrough Topics
How-to Topics


Aggregating Data

Aggregating Data
See Also Send Feedback
Intersoft WebGrid > WebGrid Features Overview > Aggregating Data

Glossary Item Box

WebGrid also provides aggregation feature to make you easier to do some calculated scenarios in displaying data. The built-in aggregate or calculated value would be displayed in Column Footer. To enable Column Footer, simply set ColumnFooters property to Yes.

This topic contains the following sections:

  • Custom Aggregation
  • Displaying Aggregate Values in Group Header
  • Automatic Group Total Update

Custom Aggregation

WebGrid introduces a powerful feature with the ability to perform aggregation function on grouped rows as well as all rows totaling. The provided aggregation functions such as Count, Sum, Average, Min and Max are generally applicable to most application's requirements. However, it does not allow you to perform your own calculation on the grouped rows or footer's totaling. This custom aggregation ability is now included in the Enterprise edition, so you can perform your own calculation to meet more complex application's scenario.

Here you can see how easy it is to implement your own aggregate calculation by handling the CustomAggregate event:

JavaScript Copy Code
private void WebGrid1_CustomAggregate(object sender,
ISNet.WebUI.WebGrid.CustomAggregateArgs e)
{
  if (e.Column.DataMember == "Status")
  {
    WebGridRowCollection rows = e.Rows;
    int count = 0;
    for (int i=0; i < rows.Count; i++)
    {
      WebGridCell cell = rows[i].Cells[e.Column.Position];
      if (cell.Value.ToString() == "Active")
      {
        count++;
      }
     }
     e.AggregateResult = count;
    }
}

Note that you can specify the CustomAggregate too as much columns as you want. The CustomAggregate event will be invoked each time the WebGrid found the specified CustomAggregate Column in the rendering process.

Displaying Aggregate Values in GroupHeader

Although built-in Aggregate Functions are already available in WebGridColumn in initial version, you need to enable GroupTotal feature to display the aggregated values. When enabled, a special total row will appear after the group header to display each calculated values of aggregate functions defined in specific WebGridColumn.

With the new feature to display basic aggregate functions in group header, you can display the calculated values without has to enable the GroupTotal feature. This new feature is useful when you only need to display a small number of calculated values and therefore reducing unnecessary clutter in the Grid's user interface.

The format string for new aggregate functions that you can apply in group header:

  • sum(Column Name)
  • avg(Column Name)
  • min(Column Name)
  • max(Column Name)

Automatic Group Total Update

WebGrid is the first ASP.NET DataGrid that introduces rich data display features, such as grouping with built-in aggregation. In addition, WebGrid also allows developers to show GroupTotal in the data display. When enabled, every group will show a total row at the end of its group. This allows users to easily review the aggregate results of each column, per that group.

New to this release is the ability to automatically update the group total and display the aggregate results correctly after data editing. This new enhancement removes the workaround needed to calculate the group total.

This new feature also works in multiple grouping mode. That means, if you have 3 group columns, WebGrid will still be able to update the aggregate results of all affected group totals.

The above screenshot shows a Grid with two grouped columns. When changes is made to the Freight column, the group total for both EmployeeID and CustomerID (as indicated in the red circle) are automatically updated.

See Also

WebGrid Features Overview

Getting Started
Getting Started

Other Resources
Walkthrough Topics
How-to Topics


Layouting

Layouting
See Also Send Feedback
Intersoft WebGrid > WebGrid Features Overview > Layouting

Glossary Item Box

To display data in rich presentation, WebGrid provides flexible layout customization that enables you to present information in more elegant ways. You can choose the layout type that is most suitable to your application scenarios, whether it is the standard tabular layout, columnset layout, or others.

This topic contains the following sections:

  • Column Set
  • Templated Cell
  • Automatic Column Fitting
  • Preview Row

Column Set

WebGrid ColumnSet is built on the top of rich object model called RowLayout. This allows true cell layouting without dependency to column object. It also enables you to construct the layout dynamically from your codes, for even greater flexibility!

You can enable columnset rowlayout rendering in any level of table without has to sacrifice existing features such as hierarchical, grouping, column footer, group totaling, add/edit/delete, filtering, keyboard navigation, automatic column width, exporting and so on.

Powerful and easy-to-use designer is also included. Our unique designer has been developed to let you easily and conveniently design the columnsets. You can also resize the cell’s width and height visually.

Intersoft Solutions also provides a unique designer to let you manipulate your ColumnSet structure easily and conveniently. You can add/remove columns, merge columns using RowSpan and ColSpan property, resize column width, and much other basic functionality which are required.

As you can see in the above illustration, WebGrid Designer fully supports all the metaphors in creating a ColumnSet.

The following is the step-by-step guides to create ColumnSet by using Designer:

  • Add a new ColumnSet into the ColumnSet Designer by pressing the "Add ColumnSet" button.
  • ColumnSet Designer is divided into 4 windows. They are ColumnSet Layout, Table properties, Column Properties and finally RowLayout Properties.
  • ColumnSet layout shows the ColumnSet schema. We can change the layout of the ColumnSet such as length of the column and also choose which column to be added in it.
  • To make ColumnSetheader visible or not and to set the ColumnSet RowCount, we can use Table Properties.
  • Every Column which has been added into the ColumnSet can be configured in Column Properties. We can set many properties in it from length, ColumnType, Caption, Bound Type, until Styles.
  • RowLayout Properties is used to set the Column and Row properties such as Span, Height, Width.

For more information, see Column Sets Layout Overview.

Templated Cell

Another interesting feature in WebGrid is its ability to add ASP.NET server controls to the WebGridCell using the new Template Column Type. When using the Template Column Type, you can put any server side controls inside the CellTemplate property of the WebGridColumn. This capability brings you greater flexibility and control over the data visualization and manipulation that suitable to your application needs. Given the current trend and ability of AJAX in delivering changes from server side control without page postback, this new feature enables developers to achieve broader scenario using professional server-side programming.

For more information, see Templated Cell Overview.

Automatic Column Fitting

In certain scenarios, you may want to display a Grid with all columns fitted into the screen which is called automatic column fitting (AutoFitColumns) feature. WebGrid fully supports AutoFitColumns feature which works in two different mode:

  • Proportional width mode.
    In this mode, all columns' width will be calculated proportionally to fit into the grid. This mode will be used by default when no AutoWidth column is specified.
  • AutoWidth column mode.
    In this mode, only the column which IsAutoWidth set to true will be expanded or shrinked to fit into the grid. Other columns' width will be leaving unmodified. However, when the width of the AutoWidth column is less than the number specified in AutoColMinWidth, the AutoWidth Column will be set to AutoColMinWidth and other columns' width will be calculated proportionally in order to fit into grid.

For more information, see Automatic Columns Fitting overview.

Keep in mind that Column Freezing feature should not be used with AutoFitColumns feature due to purpose’s conflict. AutoFitColumns feature purpose is to prevent horizontal scrolling by auto-fitting all columns, while Column Freezing feature requires horizontal scrolling. You can enable AutoFitColumns at child table level so that the columns fit into the main Grid's viewport. Arrange the child table layout so they are always inside the Grid's boundary to keep all columns visible.

Preview Row

WebGrid adds the capability to display expandable preview row, much like in Outlook® auto preview mode. There are numerous settings related to preview row feature such as you can customize its style, change the expander image or have it expanded by default.

For more information, see PreviewRow Overview.

See Also

WebGrid Features Overview

Getting Started
Getting Started

Other Resources
Walkthrough Topics
How-to Topics


ColumnSets Layout

ColumnSets Layout
See Also Send Feedback
Intersoft WebGrid > WebGrid Features Overview > Layouting > ColumnSets Layout

Glossary Item Box

This topic contains the following sections:

  • Introduction
  • Benefits
  • ColumnSet Designer
  • RowLayout Concept and client's API
  • ColumnSet Settings
  • Accessing ColumnSet in Client-side
  • Using ColumnSet in ChildTable
  • Customizing ColumnSet Settings

Introduction

One of the most powerful and innovative features in the WebGrid is the new row rendering engine, which is now capable to render a subset of cells and rows as one row unit. The unique row rendering mechanism enables implementation of features such as ColumnSets and PreviewRow without breaking the consistency with existing features and APIs. The subset of cells and rows are rendered in the same table hierarchy resulting in approximately faster performance and about 25% smaller output size compared to other grids which normally render "nested tables" for each subset of rows such as grouprow, columnsets row, and previewrow or selfreference childrow.

WebGrid's ColumnSet is built on the top of rich object model called RowLayout. This allows true cell layouting without dependency to column object. It also enables you to construct the layout dynamically from your codes, for even greater flexibility!

You can enable columnset rowlayout rendering in any level of table without has to sacrifice existing features such as hierarchical, grouping, column footer, group totaling, add/edit/delete, filtering, keyboard navigation, automatic column width, exporting and so on.

Powerful and easy-to-use designer is also included. Our unique designer has been developed to let you easily and conveniently design the columnsets. You can also resize the cell's width and height visually.

Benefits

The ColumnSet feature is designed to replace the standard .NET Templating approach which introduced following benefits:

  • Easy To Use.
    The provided Designer enables developers to easily design the layout they wanted, without advanced knowledge of HTML.
  • Time Saving.
    The ColumnSet Layout can be quickly configured and worked consistently with other 85+ features. There is no need to waste lengthy hours to construct TABLE, nested DIV, or other complex layout which requires advanced HTML knowledge. There is no need to use slower Template Editing designer too.
  • Accessible Objects.
    You can access the ColumnSet and the RowLayout objects easily in both server side and client side codes by using strongly-typed API. You cannot do this with .NET Template since it requires you to construct your own TABLE and therefore have no integration with other features.

ColumnSet Designer

Access to ColumnSet Designer from WebGrid Designer, Table, select ColumnSets node then click on ColumnSet Designer in right pane.

ColumnSet Designer Features:

  • Resize cell's width and height by using drag and drop.
  • Rich layout object model, allow you to access properties of specific cell in RowLayout Properties.
  • Allow unbound and empty cell.
  • Conveniently assign column member by clicking on drop-down arrow or right click on active cell.

RowLayout Concept and client's API

Without breaking existing API, the ColumnSet feature is built into the same, single structure which offered smaller output size and faster performance. WebGrid's row concept is an individual row element for each rowitem such as grouprow, columnsets or previewrow.

You may have already familiar with WebGrid's client side API such as getting selected row, retrieving keyValue, retrieving specific cell's information and so on. In ColumnSet mode, all row's attributes are only rendered in first row of each subset of rows to avoid duplication, named RootRow. The selected row will consistently reflect to the currently selected sub row of columnset rows (see screenshot above), so you may need to retrieve the RootRow in order to get information about a row.

Sample - Retrieving information of selected row (based on screenshot above)

C# Copy Code
var grid = ISGetObject("Webgrid1");
var selRow = grid.GetSelectedObject().GetSelectedRow();

alert(selRow.keyValue); // return undefined
alert(selRow.rowIndex); // return 4

var rootRow = wgGetRootRow(selRow);

alert(rootRow.keyValue); // return "2"
alert(rootRow.rowIndex); // return 3

var homePhoneCell = wgGetCellByName(rootRow, "HomePhone");
alert(homePhoneCell.innerText); // return "206 555-9857"

// get columnset rows
var colSetRows = wgGetColumnSetRows(rootRow);
alert(colSetRows.length); // return 3

ColumnSet Settings

ColumnSet settings is attached per table and can be found in expandable ColumnSetSettings property. You can customize numerous setting such as GridLineColor, GridLines, GridLineStyle, RowCount and ShowHeaders.

Accessing ColumnSet in Client-side

The entire ColumnSet ClientSide script has been completely reworked to provide object oriented API instead of using Global Functions like in previous versions. With this new client side object models, developers can now easily extend our WebGrid component to deliver greater values by adding more user interactive features as well as achieving complex business logic scenarios.

Here are some samples code using WebGrid.NET client side API :

  • Obtain a Cell Element in a ColumnSet.

  • JavaScript Copy Code
    function ObtainCell()
{
    var grid = ISGetObject("WebGrid1");
    if (grid.GetSelectedObject() == null)
        {
                alert("Please select a row.");
                return;
        }
        var row = grid.GetSelectedObject().GetRowObject();
        if (row.Type == "Record")
        {
                var cell = row.GetCell("City");
                var cellElement = cell.GetElement();
                cellElement.style.color = "red";
                alert("The City cell of current selected row's ForeColor is now Red.");
        }
        else
                alert("Please select a Record Row");
}
  • Obtain Row Element in ColumnSet

    JavaScript Copy Code
    function ObtainRow()
{
        var grid = ISGetObject("WebGrid1");

        if (grid.GetSelectedObject() == null)
        {
                alert("Please select a row.");
                return;
        }

        var row = grid.GetSelectedObject().GetRowObject();
        var rowElement = row.GetElement();

        rowElement.style.height = "30px";
        alert("Current selected row's Height is now 30px");
}
  • Obtain a Cell Text in ColumnSet

    JavaScript Copy Code
    function GetCellText()
{
            var grid = ISGetObject("WebGrid1");
            var curSelObj = grid.GetSelectedObject(); // get selected object
            if (curSelObj == null)
            {
                    alert("No row selected. Please select a row");
            }
            else
            {
                    var row = curSelObj.GetRowObject(); // get the WebGridRow object
                    if (row.Type == "GroupHeader")
                    {
                            alert("Currently selected row is a Group Row. There is no cell information.");
                    }
                    else if (row.Type == "Record")
                    {
                            var cells = row.GetCells(); // obtain WebGridCellCollection of the specified row.
                            var addressCell = cells.GetNamedItem("Address"); // get the address' WebGridCell object by name.

                            alert("Current selected row's Address cell has this text : " + addressCell.Text + "\nThe cell's value is : " + (addressCell.Value == null ? "No Value" : addressCell.Value));
                    }
            }
}
  • Obtain Table Header Element in ColumnSet

    JavaScript Copy Code
    function ObtainHeader()
{
    var grid = ISGetObject("WebGrid1");
    var tableHeader = grid.RootTable.GetElement(WG40.COLHEADER, WG40.HTMLTABLE); // use GetElement to obtain any elements by specifying valid values in the parameters.

    // perform manipulation to the header's table, for example, add border style to it.
    tableHeader.style.border = "black 1px solid";
    alert("TableHeader's border style is now : black 1px solid");
}
  • Obtain Body Element in ColumnSet

    JavaScript Copy Code
    function ObtainBody()
{
    var grid = ISGetObject("WebGrid1");
    var dvBody = grid.RootTable.GetElement(WG40.BODY, WG40.HTMLDIV); // use GetElement to obtain any elements by specifying valid values in the parameters.

    dvBody.style.border = "red 1px solid";
    alert("DivBody's border style is now : red 1px solid");
}
  • Obtain Column Caption in ColumnSet

    JavaScript Copy Code
    function GetColumnCaption()
{
    var grid = ISGetObject("WebGrid1");
    var addressColumn = grid.RootTable.Columns.GetNamedItem("Address"); // demonstrating the way to access object hierarchy the same way as in server side.

    alert("Address column's Caption is : " + addressColumn.Caption + "\nWidth: " + addressColumn.Width + "\nVisible: " + addressColumn.Visible);
}
  • Resize Column Width in ColumnSet

  • JavaScript Copy Code
    function ResizeColumn()
{
    var grid = ISGetObject("WebGrid1");
    var cityColumn = grid.RootTable.Columns.GetNamedItem("City");

    cityColumn.Resize(100); // resize to 100 px
    alert("City column's width is now: " + cityColumn.Width);
}
  • Get the first editable cell in the column set.

    JavaScript Copy Code
    function getfirsteditable()
{
        //get grid object
        var grid = IsGetObject("WebGrid1");

        //get the row element
        var rowElm = grid.GetSelectedObject().GetRowObject().GetElement();

        //get the first editable cell of the columnset
        var crow = wgGetCSFirstEditableCell(rowElm);
}
  • Get the column set position by row layout.

    JavaScript Copy Code
    function getcsposbyrl()
{
    //get the grid object.
    var grid = ISGetObject("WebGrid1");

    //get row element.
    var rowElm = grid.GetSelectedObject().GetRowObject().GetElement();

    //get row layout by using column name, in this case we use "city".
    var cityrl = grid.RootTable.GetRowLayoutByColName("City");

    //get ColumnSet position by using row layout.
    var pos = wgGetCSPosByRL(cityrl);
}
  • Get the lowest column of the column set rows.

    JavaScript Copy Code
    function getcslowestcs()
{
    //get the grid object.
    var grid = ISGetObject("WebGrid1");

    //get row element.
    var rowElm = grid.GetSelectedObject().GetRowObject().GetElement();
    wgGetLowestColumnSetRow(row.GetElement());
}

Using ColumnSet in ChildTable

The ColumnSet feature is not limited on RootTable only. You can also configure the Child Table to use ColumnSet Layout while still having the rest features to work in harmony.

Creating Hierarchical ColumnSet is similar with the common process of creating normal HierarchicalStructure of the grid.

ColsEt

These are the guides :

  • Bind the RootTable and ChildTable using ISDatasource.
  • Then create the ColumnSet RootTable column.
    C# Copy Code
    private void WebGrid1_PrepareDataBinding(object sender, ISNet.WebUI.WebGrid.DataSourceEventArgs e)
{
        if(!IsPostBack)
        {
             CreateColumnSet();
        }
}
  • Creating ColumnSet ChildTable Column.
    C# Copy Code
    protected void MainGrid_InitChildDataSource(object sender, ISNet.WebUI.WebGrid.ChildTableDataSourceEventArgs e)
{
        CreateChildColumnSet();
}
  • This is the code for ColumnSet RootTable :
    C# Copy Code
    private void CreateColumnSet()
{
        // Creating ColumnSet 0 and add into WebGrid
        WebGrid1.RootTable.RowLayout = RowLayoutMode.ColumnSet;
        WebGridColumnSet oColumnSet = new WebGridColumnSet();
        oColumnSet.Caption = "ColumnSet0";
        oColumnSet.Name = "ColumnSet0";
        oColumnSet.ColumnCount = 4;
        WebGrid1.RootTable.ColumnSets.Add(oColumnSet);

        //Creating RowLayout Object
        WebGridRowLayoutCollection oRowLayouts = oColumnSet.Layout;
        WebGridRowLayout oRowLayout = new WebGridRowLayout();
        WebGrid1.RootTable.ColumnSetSettings.RowCount=1;
        oRowLayout.Col = 0;
        oRowLayout.Row = 0;
        oRowLayout.ColumnMember = "CompanyName";
        oRowLayouts.Add(oRowLayout);
        oRowLayout = new WebGridRowLayout();
        oRowLayout.Col = 1;
        oRowLayout.Row = 0;
        oRowLayout.ColumnMember = "ContactName";
        oRowLayouts.Add(oRowLayout);

        oRowLayout = new WebGridRowLayout();
        oRowLayout.Col = 2;
        oRowLayout.Row = 0;
        oRowLayout.ColumnMember = "ContactTitle";
        oRowLayouts.Add(oRowLayout);

        oRowLayout = new WebGridRowLayout();
        oRowLayout.Col = 3;
        oRowLayout.Row = 0;
        oRowLayout.ColumnMember = "Address";
        oRowLayouts.Add(oRowLayout);

        oRowLayout = new WebGridRowLayout();
        oRowLayout.Col = 0;
        oRowLayout.Row = 1;
        oRowLayout.ColumnMember = "City";
        oRowLayouts.Add(oRowLayout);

        oRowLayout = new WebGridRowLayout();
        oRowLayout.Col = 1;
        oRowLayout.ColSpan = 3;
        oRowLayout.Row = 1;
        oRowLayout.ColumnMember = "Country";
        oRowLayouts.Add(oRowLayout);

        oRowLayout = new WebGridRowLayout();
        oRowLayout.Spanned = RowLayoutSpan.Column;
        oRowLayout.Col = 1;
        oRowLayout.Row = 1;
        oRowLayouts.Add(oRowLayout);

        oRowLayout = new WebGridRowLayout();
        oRowLayout.Spanned = RowLayoutSpan.Column;
        oRowLayout.Col = 2;
        oRowLayout.Row = 1;
        oRowLayouts.Add(oRowLayout);

        oRowLayout = new WebGridRowLayout();
        oRowLayout.Spanned = RowLayoutSpan.Column;
        oRowLayout.Col = 3;
        oRowLayout.Row = 1;
        oRowLayouts.Add(oRowLayout);

        WebGridRowLayout oRowLayout1;
        oRowLayout1 = new WebGridRowLayout();
        oRowLayout1.Col = 0;
        oRowLayout1.Row = 0;
        oRowLayout1.RowSpan = 2;
        oRowLayout1.ColumnMember = "Fax";
        oRowLayouts.Add(oRowLayout1);

        oRowLayout1 = new WebGridRowLayout();
        oRowLayout1.Col = 1;
        oRowLayout1.Row = 0;
        oRowLayout1.RowSpan = 2;
        oRowLayout1.ColumnMember = "Region";
        oRowLayouts.Add(oRowLayout1);
        oRowLayout1 = new WebGridRowLayout();
        oRowLayout1.Col = 0;
        oRowLayout1.Row = 1;
        oRowLayouts.Add(oRowLayout1);

        oRowLayout1 = new WebGridRowLayout();
        oRowLayout1.Col = 1;
        oRowLayout1.Row = 1;
        oRowLayouts.Add(oRowLayout1);
}
  • This is the ChildTable ColumnSet code :
    C# Copy Code
    private void CreateChildColumnSet()
{
        WebGrid1.RootTable.ChildTables[0].RowLayout = RowLayoutMode.ColumnSet;
        WebGridColumnSet oColumnSet = new WebGridColumnSet();
        oColumnSet.Caption = "ColumnSet2";
        oColumnSet.Name = "ColumnSet2";
        oColumnSet.ColumnCount = 3;
        WebGrid1.RootTable.ChildTables[0].ColumnSetSettings.RowCount=3;
        WebGrid1.RootTable.ChildTables[0].ColumnSets.Add(oColumnSet);

        WebGridRowLayoutCollection oRowLayouts = oColumnSet.Layout;
        WebGridRowLayout oRowLayout = new WebGridRowLayout();
        oRowLayout.Col = 0;
        oRowLayout.Row = 0;
        oRowLayout.ColumnMember = "OrderID";
        oRowLayouts.Add(oRowLayout);

        oRowLayout = new WebGridRowLayout();
        oRowLayout.Col = 1;
        oRowLayout.Row = 0;
        oRowLayout.ColumnMember = "OrderDate";
        oRowLayouts.Add(oRowLayout);

        oRowLayout = new WebGridRowLayout();
        oRowLayout.Col = 2;
        oRowLayout.Row = 0;
        oRowLayout.ColumnMember = "EmployeeID";
        oRowLayouts.Add(oRowLayout);

        oRowLayout = new WebGridRowLayout();
        oRowLayout.Col = 0;
        oRowLayout.Row = 1;
        oRowLayout.ColumnMember = "CustomerID";
        oRowLayouts.Add(oRowLayout);

        oRowLayout = new WebGridRowLayout();
        oRowLayout.Col = 1;
        oRowLayout.Row = 1;
        oRowLayout.ColumnMember = "Freight";
        oRowLayouts.Add(oRowLayout);

        oRowLayout = new WebGridRowLayout();
        oRowLayout.Col = 2;
        oRowLayout.Row = 1;
        oRowLayout.ColumnMember = "RequiredDate";
        oRowLayouts.Add(oRowLayout);

        oRowLayout = new WebGridRowLayout();
        oRowLayout.Col = 0;
        oRowLayout.Row = 2;
        oRowLayout.ColumnMember = "ShipVia";
        oRowLayouts.Add(oRowLayout);

        oRowLayout = new WebGridRowLayout();
        oRowLayout.Col = 1;
        oRowLayout.Row = 2;
        oRowLayout.ColumnMember = "ShippedDate";
        oRowLayouts.Add(oRowLayout);

        oRowLayout = new WebGridRowLayout();
        oRowLayout.Col = 2;
        oRowLayout.Row = 2;
        oRowLayout.ColumnMember = "ShipCountry";
        oRowLayouts.Add(oRowLayout);
}

Customizing ColumnSet Settings

Known as a rich feature component, Intersoft WebGrid.NET ColumnSet has many settings that can be attached to each table and can be found in expandable ColumnSetSettings property. We can customize numerous setting such as GridLineColor, GridLines, GridLineStyle, RowCount and ShowHeaders.

  • GridLineColor is a property to set a color to the grid line, example : red, blue.
  • GridLines is a property to set the type of grid line, example : vertical, horizontal.
  • GridLineStyle contains line styles that can be applied into grid line, example : dotted, solid, double.
  • RowCount is a property to set the number of rows in a ColumnSet.
  • ShowHeaders is a property to set whether the header of the ColumnSet is visible or not.

This is the snapshot of WebGrid.NET Designer showing the ColumnSet Settings.

When we set the ColumnSet Settings as above, the ColumnSet grid will be shown like below snapshot, look at the red dotted line on every horizontal GridLine.

Setting

See Also

WebGrid Features Overview

Getting Started
Getting Started

Other Resources
Walkthrough Topics
How-to Topics


Templated Cell

Templated Cell
See Also Send Feedback
Intersoft WebGrid > WebGrid Features Overview > Layouting > Templated Cell

Glossary Item Box

Another interesting new feature in WebGrid 5.0 is its ability to add ASP.NET server controls to the WebGridCell using the new Template Column Type. When using the Template Column Type, you can put any server side controls inside the CellTemplate property of the WebGridColumn.

This capability brings you greater flexibility and control over the data visualization and manipulation that suitable to your application needs. Given the current trend and ability of AJAX in delivering changes from server side control without page postback, this new feature enables developers to achieve broader scenario using professional server-side programming.
You can use Eval or Bind method for declarative data binding in the child controls of the CellTemplate.
For instance,
Code Copy Code
<ISWebGrid:WebGridColumn Caption="ContactName" ColumnType="Template" DataMember="ContactName"
    Name="ContactName" Width="200px">
    <celltemplate>
           <asp:Label ID="Label1" runat="server" Text='<%# Bind("ContactName") %>' ForeColor="Red" Font-Italic="true" />
    </celltemplate>
</ISWebGrid:WebGridColumn>

In order to allow grouping, sorting, and editing on Templated Column, the DataMember of the WebGridColumn need to be specified. This enables WebGrid to use native value of represented row item for the data operation purpose.

Editing is not affected with Templated Column. This means you can still specify the EditType of the Column, while it is displayed using Template ColumnType.
To edit the templated cell in Visual Studio 2005 design-time, the template editing options will automatically appear when it detected Templated ColumnType in the WebGrid. The template editing can be performed by right clicking on the WebGrid instance, then point to Edit Template menu, and finally click on Columns menu item.
Once you have entered template editing mode, you can drag and drop server side controls from your toolbox into the provided region surface. You can then customize the properties of the server controls or wire events to perform logic handing.
The following screenshot shows the template editing mode in Visual Studio 2005.

See Also

WebGrid Features Overview

Getting Started
Getting Started

Other Resources
Walkthrough Topics
How-to Topics


Automatic Columns Fitting

Automatic Columns Fitting
See Also Send Feedback
Intersoft WebGrid > WebGrid Features Overview > Layouting > Automatic Columns Fitting

Glossary Item Box

WebGrid now has the ability to fit all columns into grid's width. There are 2 modes introduced in this new version:

ProportionalWidth mode. In this mode, all columns' width will be calculated by its current percentage against new width proportionally. This mode is determined when there is no autowidthcolumn defined.

AutoColumnWidth mode. When working in this mode, only the column which its AutoWidthCol property set to True would be shrink or expanded to fit into the grid's width. This allows your columns to be displayed nicely because it leaves all other columns' width untouched. The grid also has the capability to automatically fallback to ProportionalWidth when the total columns' width exceeds the width of grid's width.

The auto fit columns feature worked consistently in conjunction with existing UI settings as well as new features, such as grouping, hidecolumnswhengrouped, best fit, column sizing, select columns, remove column, autowidth, and even in childtable and columnset mode! There are more than 32 scenarios in any combination of UI settings that are handled properly. This feature was developed with advanced logic so that it performs smoothly and does not used up 100% CPU or freeze the browser when user resize the window.

Screenshot A - ProportionalWidth mode

Screenshot B - AutoColumnWidth mode

See Also

WebGrid Features Overview

Getting Started
Getting Started

Other Resources
Walkthrough Topics
How-to Topics


Preview Row

Preview Row
See Also Send Feedback
Intersoft WebGrid > WebGrid Features Overview > Layouting > Preview Row

Glossary Item Box

WebGrid adds the capability to display expandable preview row, much like in Outlook auto preview mode. There are numerous settings related to preview row feature such as you can customize its style, change the expander image or have it expanded by default.

This topic contains the following sections:

  • PreviewRow Concept and client's API
  • PreviewRow Settings
  • Loading Preview Row on Demand

PreviewRow Concept and client's API

With the same row rendering concept as in ColumnSet mode, each sub row is rendered as one row element and therefore you need to get root row to access row's properties and custom attributes.

Sample - Retrieving preview row text

JavaScript Copy Code
    var grid = ISGetObject("WebGrid1");
    var selRow = grid.GetSelectedObject().GetRowObject();
    alert(selRow.KeyValue); // return "2";
    var prRow = wgGetPreviewRow(selRow.GetElement())
    var prCell = wgGetPreviewRowCell(prRow)
    alert(prCell.innerText);

PreviewRow Settings

PreviewRow settings are attached per table and can be found in expandable PreviewRowSettings property. Following is list of PreviewRowSettings:

  • DataMember

    The data field that will be displayed in preview row. (required)

  • DefaultExpanded

    Specifies whether the preview row should be expanded by default. Default value: True

  • Expandable

    Specifies whether the preview row is expandable. When set to False, PreviewRow Expander Column will not appear and DefaultExpanded must be set to True. Default value is True.

  • Height

    Specifies the height of preview row. Default is Empty, means that the height will follow the text's length in preview row.

  • Indentation

    Specifies the space width between edge to previewrow's text. Default is 18px.

Note that it is possible to enable previewrow mode along with columnset mode, as well as with other existing features such as grouping, hierarchical and dozens of UI settings' combinations.

Loading Preview Row on Demand

Oftentimes, preview row is used to display lengthy information such as Notes or Description. By default, WebGrid will render all preview row data at once in first load. This could introduce several performance issues due to large output size, and meanwhile user might not need to see all preview row's data at once.

In version 5.0, you can configure WebGrid to skip preview row rendering in first load to reduce initial page output size. In this scenario, the preview row Expanded state is automatically set to false (Collapse). The preview row data will be retrieved through AJAX callback when you clicked on the expand icon.

For more information, see Walkthrough: Configuring WebGrid to load PreviewRow on demand

See Also

WebGrid Features Overview

Getting Started
Getting Started

Other Resources
Walkthrough Topics
How-to Topics


Pivot Charting

Pivot Charting
See Also Send Feedback
Intersoft WebGrid > WebGrid Features Overview > Pivot Charting

Glossary Item Box

WebGrid redefines data visualization concept by introducing a new breakthrough Pivot Charting feature. The Pivot Charting is offered as built-in feature, including the automatic data processing and data aggregation. With Pivot Charting feature, transforming raw data from the Grid View into a stunning Chart View is only a matter of single button click. This section provides the overview and fundamental information of Pivot Charting so that you can quickly getting started with this new powerful feature.

This topic contains the following sections:

  • Introduction of Pivot Charting
  • Getting Started
  • Key Concepts
  • Chart Features

Introduction of Pivot Charting

Definition

Pivot Charting is a powerful data analysis and visualization tool that enables you to present your dataset in multiple viewpoints. Pivot Charting allows you to look at data in several dimensions; for example, sales by region, sales by sales rep, sales by product category, sales by month, etc. Such capability is provided in numerous decision support applications under various function names. The Pivot Charting terminology is first introduced in Microsoft Excel XP and Microsoft Access XP. The following illustration describes the concept of Pivot Charting in general.

The ability to quickly switch between one slice of data and another allows users to analyze their information in small palatable chunks instead of a giant report that is confusing.

How it works

A Pivot Chart has four essential elements:

  • Data fields: The Y-axis of the data space. This data field displays one of the aggregate functions (sum, count, max, min ...) of a data series.
  • Series fields: The Z-axis of the data space. This data field represents a series of unique data available in the data source which appears in each data category.
  • Category fields: The X-axis of the data space. The data must be categorical.
  • Filter fields: The fields used to filter the data source from global level.

You can assign multiple fields to the Data fields, Series fields, Category fields and Filter fields.

For example, you can assign "Year" as the major category; "Country" as the minor category; and divide the GDP into distinct sectors of the industry. Or you may drag "Country" from the category field to the page field if you find your table too crowded.
You can choose one of the built-in aggregation methods for each Data field. The common aggregation methods are:
  • Sum
  • Count
  • Min
  • Max
  • Average
  • Standard Deviation
  • Variance

Pivot Charting is an exact visualization of Pivot Table in Graph format instead of text. The Pivot Table itself has the same concept with Pivot Charting as mentioned above. The following illustration describes the sales data by order date in quarterly time interval.

A graphical data presentation with built-in aggregation, instead of raw flat data.

While in the Pivot Charting view, WebGrid takes the same datasource used by the Grid view and performs data pivoting and aggregation based on the specified root data member. The Chart Field List is retrieved from the available columns in the Grid view.

By default, the Pivot Charting view will show an empty Chart for the first time unless the initial series, data and category field is specified. You can start to analyze your data by dragging one of the fields in the Chart Field List to series, data and category zone.

For more information, see:

Pivot Charting in WebGrid

Pivot Charting and Business Intelligence

Getting Started

In addition to the wealth of Pivot Charting functions and comprehensive object model, WebGrid is designed to let you take advantage of these advanced features quickly and easily.

The Pivot Charting feature can be enabled in as easy as three steps:

  1. Launch WebGrid.NET Designer for the WebGrid instance.
  2. Select Pivot Charting tab, then check "Allow Pivot Charting".
  3. Click OK.

The following screenshot shows the Pivot Charting designer in WebGrid.NET Designer:

View your Webform in the browser. To see the data in Pivot Charting view, simply click the Switch to Pivot Chart View that appears in the status bar of the WebGrid.

Immediately after you clicked on the PivotChart View button, the Pivot Charting Interactive UI™ will be delivered to your browser similar to the following image.

With the Charting UI ready, the data aggregation and visualization is now at your fingertips. You can start by dragging OrderID field to the Data Fields area, then OrderDate (Years) to the Series Fields area. If you have been familiar with Multi-dimensional Data concept, you can try to drop several fields to Series and Category for data analytical, as well as to change the aggregation method of the Data Fields to get the right information you wanted.

For more information, see:

Using Designer with Pivot Charting

Deployment of Pivot Charting

Key Concepts

WebGrid.NET Enterprise's Pivot Charting is built on the top of rock solid architecture that allows great level of extensibility, customizability and scalability. This section provides more detailed explanation of the Pivot Charting's key concepts.

Pivot Charting User Interface

The Pivot Charting is bundled with intuitive user interface to ensure high efficiency and ease-to-use for end users. The Pivot Charting User Interface adopted Ribbon UI with two built-in themes: Standard and Elegant. The theme is determined with the Default Style mode value applied to the WebGrid control. The Default Style was firstly introduced in previous version. To learn more, please refer to Default Style.

The following screenshot describes the main User Interface of Pivot Charting.

As seen in above illustration, the main Pivot Charting's User Interface consists of two main parts:

  1. Ribbon UI
    The Ribbon UI consists of five group commands:
    1. Show/Hide (Toggle) the visibility of interface elements. You can toggle the visibility of three main essential interface elements:
      • Field List. The container that shows a list of available fields for pivot charting.
      • Drop Zone. The drop areas for data, series and category fields.
      • Legend. The legend of data series.
    2. Filter & Sort. This group contains commands to perform auto filtering, as well as data sorting for Series and Category fields.
    3. Chart group contains commands for customizing chart types. A list of supported chart types will be shown when you clicked on Chart Type command.
    4. Titles group allows you to enter custom axis labels that visualized along with the Chart image.
    5. Update command. When you need to refresh the Chart data, you can easily access the Update button.

  2. Pivot Surface Area
    The main pivot surface area consists of six essential user interface elements such as described in the following:
    1. Chart Field List. Represents the fields available for pivot charting. The available fields are WebGridColumn objects which ShowInChartFieldList property are set to True.
    2. Filter Drop Zone. Represents the filtered fields that applied to the global data view.
    3. Data Drop Zone. Represents the data fields used by the aggregate method.
    4. Chart Image Surface. Represents the chart image produced by the Charting engine based on the Pivot Chart Settings. The chart image is produced in the real time by using Intersoft's proprietary AJAX technology (FlyPostBack™).
    5. Series Zone. Represents the data fields displayed as series.
    6. Category Zone. Represents the data fields displayed as category.

Pivot Charting View Mode

Pivot Charting has several view modes that you can use.

  • Allow Pivot Charting (Initial View: Grid view)
    This mode show Grid view initially but the user can switch to Chart view from the PivotChart View button.

  • Allow Pivot Charting (Initial View: ChartView)
    This mode is the opposite approach than the previous one. The Chart view is shown initially but the user later can switch to Grid view by clicking the Grid View button.

  • Both View
    This mode shows both Grid and Chart view. You can switch the position to Top/Bottom/Custom.

    To place the chart view in custom container, you need to specify the ChartCustomContainerId (e.g. ChartCustomContainerId = "ChartImage")

    In this figure you can see that the Chart view is placed under ChartView tab while the Grid view is placed under GridView tab.

Drag and Drop

Drag and Drop is one of the Key Features in Pivot Charting User Interface. You can conveniently drag a field from Chart Field List to any of four available drop zones. You can also drag any field element from any drop zone to another in the same way and manner as in Microsoft Access 2007.

Furthermore, when you drag a field element there will be an indicator whether you can drag to that particular place or not.

Context Menu

The context menu for the Pivot Charting can be accessed by right clicking on anywhere in the Pivot Charting UI except the Chart Image Surface.

The context menu contains commands to toggle the visibility of user interface elements. The context menu is useful when the Ribbon UI is currently in Hidden state and you need to toggle the visibility of other interface elements.

The following screenshot shows the context menu of Pivot Charting.

The commands in the context menu have equal function to those in Ribbon UI.

Automatic Refresh vs Batch Refresh

To show more interactivity by default when the user performs an action at Pivot Charting interface (e.g. add field element to a drop zone, show/hide legend, show/hide table field list), the Chart Image will be refreshed. So the user will get the latest chart image based on their last action.

If you prefer not to refresh the Chart image after every action, you can turn off the ChartAutoRefresh property. With this setting, when there is an action the ChartImage container will be changed into a message notifying the user to click update to get the ChartImage such as shown in the following screenshot.

When ChartAutoRefresh is off, the changes will not be updated immediately. This enables you to perform multiple changes and update it at once.

Auto Resize Chart Image

Another interesting feature embedded in Pivot Chart User Interface is the capability to auto-resize the chart image based on browser's height / width. You can do this by setting the width / height of the WebGrid to 100%.

With this feature, the user who has larger screen size can get benefit from it because they can see larger data visualization. On the other hand, the user who has smaller screen will also get benefit because they do not need to scroll the browser since the image will be resized to fit their browser's size.

Auto Resize Chart Image

Another interesting feature embedded in Pivot Chart User Interface is the capability to auto-resize the chart image based on browser's height / width. You can do this by setting the width / height of the WebGrid to 100%.

With this feature, the user who has larger screen size can get benefit from it because they can see larger data visualization. On the other hand, the user who has smaller screen will also get benefit because they do not need to scroll the browser since the image will be resized to fit their browser's size.

Pivot Field Data Filtering

You can choose specific data of series or category to be included in the visualized chart image. The Pivot Charting includes built-in automatic filtering feature which can be easily accessed by clicking on the dropdown arrow of the category or series field.

The following screenshot describes the user interface for pivot filtering.

The filtering user interface allows you to check/uncheck specific items to be filtered.

Instead of checking/un-checking the data, user can also specify a filter expression. When filter expression is used, the checked/un-checked data will be ignored.

You can easily switch off the filtering for temporary by clicking the Auto Filter command in the Ribbon UI. When clicked once again, it will turn on the last specified filtering settings.

Pivot Field Data Aggregation

You can customize the aggregation method of each Data Field by clicking on its dropdown arrow. The Chart will be refreshed automatically when a new selection is made.

Pivot Data Processing

The pivot data visualization is generated by processing the collection of series fields, category fields, filter fields and data fields.

  • Data fields: The Y-axis of the data space. This data field displays one of the aggregate functions (sum, count, max, min ...) of a data series.

  • Series fields: The Z-axis of the data space. This data field represents a series of unique data available in the data source which appear in each data category.

  • Category fields: The X-axis of the data space. The data must be categorical.

  • Filter fields: The fields used to filter the data source from global level.

Data fields and series fields play parts in determining the series data that appear in each data category. If you only have one object in data fields' collection and also one object in series fields' collection, the chart engine will use the data in the series field's collection as the series data collection. (This series data collection will appear in legend if the legend is visible).

If you have more than one object in data fields' collection and/or series field's collection, the chart engine will perform a combination from both object in data fields' collection and series fields' collection for the series data. The following screenshot shows a Pivot Chart with two data fields.

The above screenshot shows a pivot chart with two series fields, while the below one shows the pivot with two series fields and two data fields.

Data category fields play parts in categorizing the series data. If you have one object in category fields' collection, the chart engine will categorize the data based on that object (e.g. categorize the sales per country).

If you have more than one object in category fields' collection, the chart engine will categorize the data based on the last object. For example, if we have country - city in the category collection, the data will be categorized based on city. However, the label will still use country-city format. The following screenshot shows a pivot chart with two category fields.

Automatic Image Handlers

Chart Image request handler uses HttpHandler that needs to be defined in web.config as:

web.config Copy Code
<httpHandlers>
        <add path="ISChart.axd" verb="GET" type="ISNet.WebUI.WebGrid.Chart.ChartRequestHandler,
        ISNet.WebUI.WebGrid" validate="true"/>
</httpHandlers>
The HttpHandler definition above is automatically registered in your Web application when you enable Pivot Charting in WebGrid Designer. To make sure you have enabled Pivot Charting in proper way, please see Getting Started with Pivot Charting.

When using the HttpHandler, the image will be rendered directly to the client's browser during AJAX call. Note that you might want to change the request handler mode to Centralized File Server mode if you are using Multiple Server/Web Farm environment for better scalability. The automatic image handler is a unique innovation in WebGrid's Charting feature which has more advantages over the traditional temporary images approach. Some of the key advantages are:
  • Hassles-free development and deployment. You do not need to configure IIS virtual directory or any other folders. Just a simple XCOPY of your Web application will do.
  • Better performance. Since there is no need to produce temporary images, it reduces the overhead of I/O operation and hence, increasing performance.
  • Better security measurement. Since there are no temporary images generated in the IIS-level directory, your Web application is more secure than ever.

Centralized Image File Server

When using centralized File Server, the image will be cached in file server specified in ImageFileServer settings and the client will then request the image from the file server. (E.g. ImageFileServer: path=C:\Cache).

Some of the benefits using File Server cache are:

  • Highly scalable. You can choose a network drive to store the caches which enables multiple web servers to access the state.
  • Decent performance. With more than dozen of high performance hard drives, you can choose a near memory speed with high random access and sequential read write hard drive to store the caches.
  • Easily extensible. Unlike memory (RAM), you can easily extend hard drives with larger one when it becomes insufficient.

Features of File Server:

  • Automatic cleaning. When the cache has expired, the caches will be automatically deleted.
  • Allow customizations on cache policy and expiration duration.

Chart Engine Interface (IChartEngine)

WebGrid Pivot Charting architecture provides an extensible Chart engine interface called IChartEngine.

C# Copy Code
public interface IChartEngine
{
    Bitmap GenerateChartImage(ChartConfig chartConfig, DataTable data);
}

You can implement this interface and generate the chart image using your own ChartEngine. Note that the return value must be a Bitmap type.

After you have implemented the interface, you can attach the engine into e.AlternativeChartEngine at ChartImageProcessing event.

C# Copy Code
protected void WebGrid1_ChartImageProcessing(object sender,
    ISNet.WebUI.WebGrid.Chart.WebGridChartEventArgs e)
{
    e.AlternativeChartEngine = new AlternativeChartEngine();
}

By implementing this approach, WebGrid will use the specified Chart Engine to perform the chart image generation, instead of using the built in Chart Engine. Just make sure that GenerateChartImage method of your AlternativeChartEngine produces the image in Bitmap type.

Generating Chart image process sequence

Assembly Relations

Language Localization

All textual items in Pivot Charting User Interface can be localized from WebGrid's localization settings. You can add the following tag in your localization file (which can be found in C:\Program Files\Intersoft Solutions\CommonLibrary\WebGrid\V8_0_7200\Localization) to customize the Pivot Charting UI text items based on your preference.

Component's Tag Copy Code
<Charting>
    <Loading>Loading Chart...</Loading>
    <Update>When you have done configuring the Chart settings, please click {UpdateLink} to refresh the Chart image</Update>
    <UpdateLinkText>[Update]</UpdateLinkText>
    <DropFilterField>Drop Filter Fields Here</DropFilterField>
    <DropDataField>Drop Data Fields Here</DropDataField>
    <DropSeriesField>Drop Series Fields Here</DropSeriesField>
    <DropCategoryField>Drop Category Fields Here</DropCategoryField>
    <DropXData>Drop X Data Fields Here</DropXData>
    <DropYData>Drop Y Data Fields Here</DropYData>
    <DropBubbleData>Drop Bubble Data Fields Here</DropBubbleData>
    <DropHighData>Drop High Data Fields Here</DropHighData>
    <DropLowData>Drop Low Data Fields Here</DropLowData>
    <DropOpenData>Drop Open Data Fields Here</DropOpenData>
    <DropCloseData>Drop Close Data Fields Here</DropCloseData>
    <DropThetaData>Drop Theta Data Fields Here</DropThetaData>
    <DropRadiusData>Drop Radius Data Fields Here</DropRadiusData>
    <ShowHideRibbon>Show / Hide</ShowHideRibbon>
    <FilterSortRibbon><![CDATA[Filter & Sort&cd;></FilterSortRibbon>
    <ChartRibbon>Chart</ChartRibbon>
    <TitlesRibbon>Titles</TitlesRibbon>
       <FieldListButton><![CDATA[Field<br/>List&cd;></FieldListButton>
    <DropZoneButton>Drop Zone</DropZoneButton>
    <LegendButton>Legend</LegendButton>
    <AutoFilterButton><![CDATA[Auto<br/>Filter&cd;></AutoFilterButton>
    <AscendingButton>Ascending</AscendingButton>
    <DescendingButton>Descending</DescendingButton>
    <ChartTypeButton><![CDATA[Chart<br/>Type&cd;></ChartTypeButton>
    <SwitchRowColumnButton><![CDATA[Switch Row & Column&cd;></SwitchRowColumnButton>
    <UpdateButton>Update</UpdateButton>
    <TitleXAxis>X Axis</TitleXAxis>
    <TitleYAxis>Y Axis</TitleYAxis>
    <TitleZAxis>Z Axis</TitleZAxis>
       <ErrorDuplicateData>Current PivotData already existed in PivotData Collection</ErrorDuplicateData>    <ErrorAddToData>Unable to add this field to Drop Data</ErrorAddToData>    <ErrorAddToFilter>Unable to add this field to Drop Filter</ErrorAddToFilter>    <ErrorAddToCategory>Unable to add this field to Drop Category</ErrorAddToCategory>    <ErrorAddToSeries>Unable to add this field to Drop Series</ErrorAddToSeries>
</Charting>

Chart Features

WebGrid ChartEngine which exclusively licensed from world's leading Charting provider, Nevron LLC comes with lots of fascinating features that can be utilized to produce a stunning data visualization.

The features are categorized into several sections.

  1. Series related features

    The features fall in this section are applied to the series object (the charting object itself). Each chart type has its own unique features that will be discussed in this section.

    For more information, see:

    Chart Series

  2. General features

    The features fall in this section are applied to the charting globally, independent from the chart type used by the user. The features are:

    1. Bounds Mode

      Bounds mode determines how the chart image should fit the bounds defined by the layout manager. There are three types of bounds mode.

      Fit

      In this mode the chart image does not break outside the panel bounds by scaling without breaking the aspect ratio of the panel content. This mode is best for 3D Chart types.

      Stretch

      In this mode the panel contents does not break outside the panel bounds by scaling along X and Y as much as needed to fit the entire bounds with the panel contents. This bounds mode does not preserve the aspect ratio of the original panel contents. This mode is best for 2D Chart types.

      None

      In this mode the panel does not try to fit in the bounds defined by the layout manager. It will only make sure that the center of the panel contents matches the center of the bounds.

      Automatic

      In this mode all 2D Chart except Pie and Doughnut will be using Stretch mode, the other chart type will use Fit Mode.

      The following code modifies the bounds mode of the chart image.

      C# Copy Code
      WebGrid1.ChartSettings.BoundsMode = BoundsMode.Stretch;
      If you modify the Zoom property of chart projection, the chart may break outside the bounds.
    2. Background

      Background of the chart is the chart container's space where the chart image and other chart elements are placed into.

      Various Fill Style

      There are four types of fill style (Gradient Fill, Color Fill, Hatch Fill, Image Fill). Each of them has their own attributes. Below are some samples of background fill.

    3. Axis

      Follows are things that can be modified for each chart's axis (X, Y, and Z Axis):

      1. Label Orientation Mode
      2. Invert Axis

      Label Orientation Mode

      You can modify the label orientation from:

      C# Copy Code
      ChartSettings chartSettings = WebGrid1.ChartSettings;
chartSettings.XAxis.LabelGenerationMode = LabelGenerationMode.Rotate90;

      There are seven types of label orientation mode (SingleLevel, Stagger2, Stagger3, Rotate30, Rotate45, Rotate90 and AutoScale). Except SingleLevel, Stagger2, Stagger3 modes, the other entire modes will be applied if the number of data point is quite large. In SingleLevel mode, the chart engine has the capability to determine the size and the stagger level. If you prefer to have only one line at all costs, try the AutoScale mode.

      Invert Axis

      You can invert the axis from:

      C# Copy Code
      ChartSettings chartSettings = WebGrid1.ChartSettings;
chartSettings.YAxis.Invert = true;

      By inverting the axis, you will get different perspective of data visualization as follow:

    4. Legend

      Chart's data legend visibility is controlled from:

      C# Copy Code
      ChartSettings chartSettings = WebGrid1.ChartSettings;
chartSettings.LegendSettings.Mode = LegendMode.Automatic;

      When legend is visible, you can controls its appearance. Firstly, you can dock the Legend to a specified position (Top, Left, Right, or Bottom).

      Furthermore, you can also control the layout of the legend. For example: instead of showing the legend data per row (RowsOnly) you can set it per column (ColsOnly).

      You can add a header / title text to Chart Image from:

      C# Copy Code
      ChartSettings chartSettings = WebGrid1.ChartSettings;
chartSettings.HeaderSettings.Text = "ChartHeader";

      By default the position of this Chart Header is at Top Left of the chart image, you can move the position using:

      C# Copy Code
      ChartSettings chartSettings = WebGrid1.ChartSettings;
chartSettings.HeaderSettings.Alignment = HeaderAlignment.TopRight;

      By default the position of this Chart Header is at Top Left of the chart image, you can move the position using:

      You can move the chart header to six positions (TopLeft, TopCenter, TopRIght, BottomLeft, BottomCenter, BottomRight)

      You can move the chart header to six positions (TopLeft, TopCenter, TopRIght, BottomLeft, BottomCenter, BottomRight)

    5. Image Format

      The chart image can be generated into four image format (Gif, Jpeg, Png and Bitmap). The default value is PNG.

    6. Walls

      Chart walls are visible when 3D Chart types is used. All the axis settings are also applied to chart walls. Furthermore, chart walls also have their own styles properties (BorderStyle, FillStyle and ShadowStyle), you can modified these properties to meet up with your preferences.

    You can specify the lighting from:

    Component's Tag Copy Code
    <ISWebGrid:WebGrid>...<ChartSettings>
   <LightModelSettings GlobalAmbientLight="Gainsboro" LightModel="NorthernLights" EnableLighting="true">
      <LightSources>
         <ISWebGrid:ChartLightSourceSettings Ambient="Black" Difuse="DimGray" Specular="DimGray"
            LightSourceType="Directional">
            <Position X="-1" Z="1" />
         </ISWebGrid:ChartLightSourceSettings>
         <ISWebGrid:ChartLightSourceSettings Ambient="Black" Difuse="DimGray" Specular="DimGray"
            LightSourceType="Directional">
            <Position Y="1" Z="1" />
         </ISWebGrid:ChartLightSourceSettings>
      </LightSources>
   </LightModelSettings>
   <VisualEffectSettings EnableJittering="True" JitteringSteps="4" RenderSurface="Window"
      ShapeRenderingMode="HighQuality" />
</ChartSettings>
...</ISWebGrid:WebGrid>

    The LightModelSettings property control the lighting effects to all chart types. You might want to use predefined lighting provided to fasten the process declaring the light sources.

    However, if you prefer to specify your own lighting settings, you can manipulate the following properties.

    1. GlobalAmbientLight
    2. LightSources collection.

    In each light sources you can specify:

    1. LightSourceType
    2. Ambient Color
    3. Difuse Color
    4. Specular Color
    5. Position
    6. Direction
    7. Constant Attenuation
    8. Linear Attenuation
    9. Quadratic Attenuation
    10. Spot Cutoff
    11. Spot Exponent

    Reference samples: WebGridSamples\ChartLighting.aspx.

  3. Projection

    In 3D chart types you can change the projection view of the chart from:

    C# Copy Code
    ChartProjectionSettings projection = WebGrid1.ChartSettings.ProjectionSettings;

    You can select the projection types from available predefined projection, or use your own projection settings by manipulating the following properties:

    1. Projection Type
    2. Elevation
    3. Perspective Angle
    4. Rotation
    5. Viewer Rotation
    6. X Depth
    7. Y Depth
    8. Zoom

    Reference Samples: WebGridSamples\ChartProjection.aspx.

See Also

WebGrid Features Overview

Getting Started
Getting Started

Other Resources
Walkthrough Topics
How-to Topics


Pivot Charting in WebGrid

Pivot Charting in WebGrid
See Also Send Feedback
Intersoft WebGrid > WebGrid Features Overview > Pivot Charting > Pivot Charting in WebGrid

Glossary Item Box

WebGrid 6.0 takes data presentation and visualization component to a new level by providing "out-of-the-box" Pivot Charting functionalities such as those provided in Microsoft Access 2007. The core functions of Pivot Charting included in WebGrid 6.0 are:

  • Ability to specify multiple fields to Data, Series, Categories and Filter. This function allows you to create multi-dimensional viewpoint of your data.
  • Ability to specify one of the aggregation methods for each Data field. The default aggregation method is Count.
  • Ability to perform auto filtering. You can easily slice your data by excluding the category or series that you do not want to see in the visualized Chart.
  • Ability to sort Category and Series field automatically in ascending or descending way. This function enables you to quickly display sorted data in the visualized Chart.
  • Ability to switch between Category and Series fields in one button click. This function enables you to easily inspect your data in different perspective.
  • Ability to break down DateTime field into five time intervals automatically. This powerful function automatically breaks down DateTime field into the following time intervals: Year, Quarter, Month, Week, Date. In the fraction of seconds, you can now visualize a series of data grouped by any time interval you preferred. For instance, order date in quarterly interval.
In addition to the comprehensive core pivoting functions above, WebGrid 6.0 is bundled with the best-of-breed Charting Engine and industry's most popular User Interface. The combination of both delivers the most sophisticated and the most advanced data visualization functions for enterprise ASP.NET Web development. The addition with the hundreds of existing features delivers perfect values that enable you to build just anything - from basic flat table presentation, hierarchical view, columnset presentation to a Pivot Charting-enabled presentation.
The Charting Engine included in WebGrid 6.0 is a royalty-free redistributable runtime Charting Engine which exclusively licensed from world's leading Charting provider, Nevron LLC. Nevron LLC is also the technology partner of Intersoft Solutions Corp. The included runtime Charting Engine is designed only for WebGrid to perform call to the visualization functions - and does not include the license for development environment.
The Charting Engine Key Features:
  • Over 50 chart types that you can customize at runtime.
  • High performance visualization. Ability to process large data points in fraction of seconds.
  • 3D predefined projection.
  • 3D predefined lighting and multiple light sources.
  • Visual effects, such as bevel, emboss, blur, transparency and more.
  • Styles and appearance. Ability to customize the styles of lines, titles, legend, wallpaper, docking, color series, markers and much more.

The User Interface Key Features:

  • Drag and Drop
    Conveniently drag a field from Chart Field List to any of four available drop zones. You can also drag any field element from any drop zone to another in the same way and manner as in Microsoft Access 2007.
  • Ribbon UI
    The UI adopts Microsoft's latest User Interface innovation used in Microsoft Office System 2007. The built-in Ribbon UI allows end users to easily understand the commands provided by the Pivot Charting.
  • Context Menu
    Easily toggle the visibility of user interface elements such as the Ribbon, Legend, Chart Field List and so on. This allows end users to hide one or more user interface elements for maximum screen real estate.
  • AJAX Chart Image Generation
    The Chart image is generated in near real-time by using Intersoft's high performance built-in AJAX technology, called FlyPostBack.

For detailed User Interface and Interactivity features, please refer to Pivot Charting.

See Also

WebGrid Features Overview

Getting Started
Getting Started

Other Resources
Walkthrough Topics
How-to Topics


Pivot Charting and Business Intelligence

Pivot Charting and Business Intelligence
See Also Send Feedback
Intersoft WebGrid > WebGrid Features Overview > Pivot Charting > Pivot Charting and Business Intelligence

Glossary Item Box

WebGrid 6.0 includes built-in data analytical and data processing functionality which automatically transforms raw data into pivot data view for the Pivot Charting rendering. This feature works in conjunction with the Grid View's datasource, which needs to show the raw flat data.

With the built-in data analytical and processing functions, this means you are not required to build complex data warehousing or separate OLAPS server. You can simply retrieve the datasource as usual and bind it to the Grid instance by either using DataSource Control or custom datasource object.
The pivot data analysis and processing offered in WebGrid 6.0 is a simplified approach to build Business Intelligence application. Business Intelligence (BI) is a far more complex system which takes advantage of multiple technologies such as data warehousing, data dimensioning, cubes and data mining. One of the most popular Business Intelligence tool today is Microsoft SQL Server 2005 Analysis Services.
The built-in data analytical function in WebGrid 6.0 is a scale-down version of Business Intelligence which primarily focused on single datasource and Charting projection of the pivot data. The concept adopted in WebGrid 6.0 is more similar to those in Microsoft Access 2007 rather than SQL Server 2005 Analysis Services.
Although you cannot connect directly to SQL Server 2005 Analysis Services data sources such as its cubes, dimensions etc - you can build a comprehensive query in your OLTP relational database to get a combined result to simulate the cubes in Analysis Services. When bound to WebGrid, the available fields can be specified as the facts and measures. You can have more than one facts and measures in the current implementation of Pivot Charting in WebGrid 6.0, which allows you to build a simplified Business Intelligence application.
In the future releases, WebGrid.NET Enterprise® will include more comprehensive functions to process larger Business Intelligence application by offering out-of-the-box integration with MDX technology and Analysis Services. This is made possible with the robust architecture of the current release which is extensible to the path of larger BI presentation implementation.

See Also

WebGrid Features Overview

Getting Started
Getting Started

Other Resources
Walkthrough Topics
How-to Topics


Using Designer

Using Designer
See Also Send Feedback
Intersoft WebGrid > WebGrid Features Overview > Pivot Charting > Using Designer

Glossary Item Box

WebGrid has come up with an addition tab to its designer, which is Pivot Charting. The new expandable and collapsible user interface allows you to quickly locate a feature. Most settings are presented in check box and radio selection interface which are designed to help you instantly enable or disable, or modify a feature with one mouse click.

In Pivot Charting tab, it is divided into 11 sections which are:

  • Pivot Charting
    This section allows user to customize the general settings of pivot charting, such as allow pivot charting, initial chart type, image format and many more.

  • Chart Interactive UI
    This section allows user to customize pivot charting user interface, such as show/hide ribbon, filter and sort ribbon, chart type ribbon and titles ribbon.

  • Series
    This section allows user to customize the series feature available in pivot charting, such as column, bar, line, pie, doughnut and many more.

  • Legend
    This section allows user to customize pivot charting's legend such as its docking position.

  • Axis
    This section allows user to customize the pivot charting's axis, which has 7 types of label orientation mode. They are SingleLevel, Stagger2, Stagger3, Rotate30, Rotate45, Rotate90 and AutoScale.

  • Projection
    This section allows user to customize the predefined or custom projection.

  • Lighting
    This section allows user to customize light sources to create stunning chart 3D images.

  • Background
    This section allows user to customize Fill and Frame styles to apply chart's background.

  • Chart Walls
    This section allows user to customize the chart's walls styles properties such as BorderStyle, FillStyle and ShadowStyle.

  • Header
    This section allows user to customize the chart header's position to TopLeft, TopCenter, TopRIght, BottomLeft, BottomCenter and BottomRight.

  • Visual Effects
    This section allows user to customize the jittering deviation and steps to make the 3D chart looks smooth.

See Also

WebGrid Features Overview

Getting Started
Getting Started

Other Resources
Walkthrough Topics
How-to Topics


Deployment

Deployment
See Also Send Feedback
Intersoft WebGrid > WebGrid Features Overview > Pivot Charting > Deployment

Glossary Item Box

Two additional assemblies are required to be copied to the private bin folder of your Web application in the production server. The assemblies required for Pivot Charting feature are:

  • ISNet.WebUI.WebGrid.ChartEngine.dll. The built-in charting and visualization implementation based on aggregated data in WebGrid and ChartSettings object.
  • ISNet.Nevron.Charting.dll. The runtime assembly of Core Charting developed by Nevron LLC which exclusively licensed for Intersoft Solutions Corporation for the use in WebGrid 6.0.

The complete deployment guide can be found in Deployment Guide topic.

See Also

WebGrid Features Overview

Getting Started
Getting Started

Other Resources
Walkthrough Topics
How-to Topics


Chart Series

Chart Series
See Also Send Feedback
Intersoft WebGrid > WebGrid Features Overview > Pivot Charting > Chart Series

Glossary Item Box

WebGrid have many chart series which can be used.

This topic contains the following sections:

  • Series Column
  • Series Bar
  • Series Line
  • Series Smooth Line
  • Series Step Line
  • Series Pie
  • Series Doughnut
  • Series Area
  • Other Series related features

Series Column

Series Column has seven sub types, they are:

  1. Clustered Column
  2. Stacked Column
  3. 100% Stacked Column
  4. Basic 3D Column
  5. Clustered 3D Column
  6. 100% Stacked 3D Column

You can select which chart type to be used from:

C# Copy Code
ChartSettings chartSettings = WebGrid1.ChartSettings;
chartSettings.SeriesColumnSettings.Type = SeriesColumnType.ClusteredColumn

Bar Shape

There are nine shapes of bar that you can choose from.

The shape of the bars is controlled from BarShape property. It accepts values from BarShape enumeration.

C# Copy Code
SeriesBar settings = WebGrid1.ChartSettings.SeriesColumnSettings.Settings;
settings.BarShape = BarShape.SmoothEdgeBar;

When the bars are displayed as SmoothEdgeBar or CutEdgeBar, you can control whether top and bottom edges of the bar are displayed in the respective manner with the help of the HasTopEdge and HasBottomEdge properties.

C# Copy Code
SeriesBar settings = WebGrid1.ChartSettings.SeriesColumnSettings.Settings;
settings.HasBottomEdge = true;
settings.HasTopEdge = true;

The size of the edge is controlled in percents of the smaller width or depth bar dimension. By default, it is set to 15. The following code will make the smooth bar edges twice bigger.

C# Copy Code
SeriesBar settings = WebGrid1.ChartSettings.SeriesColumnSettings.Settings;
Settings.BarEdgePercent = 30;

Origin

By default, all bars are using 0 as origin value (all bars begin from 0). You can turn off this behavior by setting the UseOrigin property to false.

C# Copy Code
SeriesBar settings = WebGrid1.ChartSettings.SeriesColumnSettings.Settings;
settings.UseOrigin = false;

If the bars do not use an origin value, they will all begin from the minimum bar value (the minimal bar will be displayed with zero height). In some cases, you may want the bars to begin from a certain value - for example 15. The following code will achieve the result:

C# Copy Code
SeriesBar settings = WebGrid1.ChartSettings.SeriesColumnSettings.Settings;
settings.UseOrigin = false;
settings.Origin = 15;

Series Bar

Series Bar has seven sub types, they are:

  1. Clustered Bar
  2. Stacked Bar
  3. 100% Stacked Bar
  4. Basic 3D Bar
  5. Clustered 3D Bar
  6. 100% Stacked 3D Bar

You can select which chart type to be used from:

C# Copy Code
ChartSettings chartSettings = WebGrid1.ChartSettings;chartSettings.SeriesBarSettings.Type = SeriesBarType.ClusteredBar;

Bar Shape

There are nine shapes of bar you can choose from.

The shape of the bars is controlled from BarShape property. It accepts values from BarShape enumeration.

C# Copy Code
SeriesBar settings = WebGrid1.ChartSettings.SeriesBarSettings.Settings;settings.BarShape = BarShape.SmoothEdgeBar;

When the bars are displayed as SmoothEdgeBar or CutEdgeBar, you can control whether top and bottom edges of the bar are displayed in the respective manner with the help of the HasTopEdge and HasBottomEdge properties.

C# Copy Code
SeriesBar settings = WebGrid1.ChartSettings.SeriesBarSettings.Settings;
settings.HasBottomEdge = true;
settings.HasTopEdge = true;

The size of the edge is controlled in percents of the smaller width or depth bar dimension. By default, it is set to 15. The following code will make the smooth bar edges twice bigger.

C# Copy Code
SeriesBar settings = WebGrid1.ChartSettings.SeriesBarSettings.Settings;
Settings.BarEdgePercent = 30;

Origin

By default, all bars are using 0 as origin value (all bars begin from 0). You can turn off this behavior by setting the UseOrigin property to false.

C# Copy Code
SeriesBar settings = WebGrid1.ChartSettings.SeriesBarSettings.Settings;
settings.UseOrigin = false;

If the bars do not use an origin value they will all begin from the minimum bar value (the minimal bar will be displayed with zero height). In some cases, you may want the bars to begin from a certain value - for example 15. The following code will achieve the result:

C# Copy Code
SeriesBar settings = WebGrid1.ChartSettings.SeriesBarSettings.Settings;
settings.UseOrigin = false;
settings.Origin = 15;

Series Line

Series Line has fourteen sub types, they are:

  1. Overlapped Line
  2. Overlapped Line With Markers
  3. Stacked Line
  4. Stacked Line With Markers
  5. 100% Stacked Line
  6. 100% Stacked Line With Markers
  7. Basic 3D Line
  8. Basic 3D Line With Markers
  9. Overlapped 3D Line
  10. Overlapped 3D Line With Markers
  11. Stacked 3D Line
  12. Stacked 3D Line With Markers
  13. 100% Stacked 3D Line
  14. 100% Stacked 3D Line With Markers

You can select which chart type to be used from:

C# Copy Code
ChartSettings chartSettings = WebGrid1.ChartSettings;
chartSettings.SeriesBarSettings.Type = SeriesBarType.ClusteredBar;

Line Shape

There are four types of shape that you can choose from.

The line segments can be visualized with different shapes. You can control the shape with the help of the LineSegmentShape property which accepts values from the LineSegmentShape enumeration. By default, the series is displayed as simple line. The following example will display the series as tape:

Example Title Copy Code
SeriesLine settings = WebGrid1.ChartSettings.SeriesLineSettings.Settings;
settings.LineSegmentShape = LineSegmentShape.Tape;

Series Smooth Line

Series Line has two sub types, they are:

  1. Overlapped Smooth Line
  2. Overlapped Smooth Line With Markers

You can select which chart type to be used from:

C# Copy Code
ChartSettings chartSettings = WebGrid1.ChartSettings;
chartSettings.SeriesSmoothLineSettings.Type = SeriesSmoothLineType.OverlappedSmoothLine;

Series Step Line

Series Step Line has four sub types, they are:

  1. Overlapped Step Line
  2. Overlapped Step Line With Markers
  3. Basic 3D Step Line
  4. Basic 3D Step Line With Markers

You can select which chart type to be used from:

C# Copy Code
ChartSettings chartSettings = WebGrid1.ChartSettings;
chartSettings.SeriesStepLineSettings.Type = SeriesStepLineType.OverlappedStepLine;

Line Shape

There are four types of shape that you can choose from.

The line segments can be visualized with different shapes. You can control the shape with the help of the LineSegmentShape property which accepts values from the LineSegmentShape enumeration. By default the series is displayed as simple line. The following example will display the series as tape:

C# Copy Code
SeriesStepLine settings = WebGrid1.ChartSettings.SeriesStepLineSettings.Settings;
settings.LineSegmentShape = LineSegmentShape.Tape;

Series Pie

Series Pie has four sub types:

  1. Pie
  2. Exploded Pie
  3. 3D Pie
  4. 3D Exploded Pie

You can select which chart type to be used from:

C# Copy Code
ChartSettings chartSettings = WebGrid1.ChartSettings;
chartSettings.SeriesPieSettings.Type = SeriesPieType.Pie;

Pie Style

There are two types of pie that you can choose from.

The shape of the pie segments can be controlled through the PieStyle property. It accepts values from the PieStyle enumeration. For example: the following code will display a smooth edge pie chart:

C# Copy Code
settings.PieStyle = PieStyle.Pie;

Explosion

You can explode the data point of the pie chart using:

Example Title Copy Code
SeriesPie settings = WebGrid1.ChartSettings.SeriesPieSettings.Settings;settings.ExplodeMode = PieExplodeMode.Biggest;settings.Explosion = 8;

Miscellaneous

The BeginAngle property specifies the initial rotation of the first item. The TotalAngle property controls the total angle (in degrees) in which pies is displayed. By default, this property is 360 degrees. The following code will change the begin angle of the pies to 30 degrees and set the total angle to 180 degrees.

C# Copy Code
SeriesPie settings = WebGrid1.ChartSettings.SeriesPieSettings.Settings;
settings.BeginAngle = 45;
settings.TotalAngle = 270;

Series Doughnut

Series Doughnut has four sub types:

  1. Doughnut
  2. Exploded Doughnut
  3. 3D Doughnut
  4. Exploded 3D Doughnut

You can select which chart type to be used from:

C# Copy Code
ChartSettings chartSettings = WebGrid1.ChartSettings;
chartSettings.SeriesDoughtnutSettings.Type = SeriesDoughnutType.Doughnut;

InnerRadius

Inner radius controls the length of the inner radius (the doughnut hole), the larger the value, the thinner the doughnut will be and vice versa. The maximum value is 50 which means the doughnut is not visible.

Explosion

You can explode the data point of the pie chart using:

C# Copy Code
SeriesPie settings = WebGrid1.ChartSettings.SeriesDoughnutSettings.Settings;settings.ExplodeMode = PieExplodeMode.Biggest;settings.Explosion = 8;

Miscellaneous

The BeginAngle property specifies the initial rotation of the first item. The TotalAngle property controls the total angle (in degrees) in which pies is displayed. By default, this property is 360 degrees. The following code will change the begin angle of the pies to 45 degrees and set the total angle to 270 degrees.

C# Copy Code
SeriesPie settings = WebGrid1.ChartSettings.SeriesDoughnutSettings.Settings;settings.BeginAngle = 45;settings.TotalAngle = 270;

Series Area

Series Area has five sub types:

  1. Stacked Area
  2. 100% Stacked Area
  3. Basic 3D Area
  4. Stacked 3D Area
  5. 100% Stacked 3D Area

You can select which chart type to be used from:

C# Copy Code
ChartSettings chartSettings = WebGrid1.ChartSettings;
chartSettings.SeriesAreaSettings.Type = SeriesAreaType.Doughnut;

Origin

By default, all bars are using 0 as origin value (all bars begin from 0). You can turn off this behavior by setting the UseOrigin property to false.

C# Copy Code
SeriesArea settings = WebGrid1.ChartSettings.SeriesAreaSettings.Settings;
settings.UseOrigin = false;

If the bars do not use an origin value, they will all begin from the minimum bar value (the minimal bar will be displayed with zero height). In some cases, you may want the bars to begin from a certain value - for example 26. The following code will achieve the result:

C# Copy Code
SeriesArea settings = WebGrid1.ChartSettings.SeriesAreaSettings.Settings;
settings.UseOrigin = false;
settings.Origin = 26;

Other Series related features

Except features that related to corresponding chart type, there also features that applied generally to entire series, they are:

  1. Series Legend

    This feature basically used to control the formatting of the legend text format.

    There are two types of legend mode that you can select from (Series or Data Points).

    In Series mode the legend will be set from the Chart Engine. If it is set to Data Points, the legend will be determined by the given format.

    C# Copy Code
    SeriesLegend seriesLegend = settings.SeriesLegend;
seriesLegend.Format = "<label> (<value>) (<percent>)";

  2. Series Data Point

    Data point is a mark that is placed in each series object that represents the data. By default, the data point is set to visible = false. If you want to show it, you can simply:

    C# Copy Code
    ChartDataLabelStyle labelStyle = settings.DataLabelStyle;
labelStyle.Visible = true;
labelStyle.Format = "(<percent>)";

    You can also specify the formatting text as in series legend. Furthermore, you can also specify the position of the data points according to your preference.

    In pie and doughnut chart, the data points can be visualized in more modes:

    1. Center - the data labels are displayed in the center of the pie segments.
    2. Rim the data labels are visualized at the pies rim.
    3. Spider the data labels are visualized at aligned in columns on the left and the right side of the pie.

Chart Tool Tip and Interactivity

You can show Chart tooltip and interactivity at chart object by activating ChartInteractiveStyle.

C# Copy Code
Series settings = WebGrid1.ChartSettings.GetSeries();
ChartInteractiveStyle interactive = settings.InteractiveStyle;
interactive.Enabled = true;

By doing this you can now show a tooltip at chart object and also attach mouse events (mouse over, mouse out, click, and double click).

You can control the tool tip format from:

C# Copy Code
Series settings = WebGrid1.ChartSettings.GetSeries();
ChartInteractiveStyle interactive = settings.InteractiveStyle;
interactive.Tooltip = "<label> (<value>)";

Here is the Formating available:

Format | Description
<label> | Show the data label
<value> | Show the data value
<index> | Show the index of the data
<total> | Show the total data value
<percent> | Show the percentage of current value

Beside tool tip you can also attach mouse events as follow:

C# Copy Code
Series settings = GetSeries();
ChartInteractiveStyle interactive = settings.InteractiveStyle;
interactive.OnClick = "ChartEventClick";

JavaScript Copy Code
function ChartEventClick(controlId, label, value, index, aggregate, filterExpression)
{
    label = unescape(label);
    value = unescape(value);
    index = unescape(index);
    aggregate = unescape(aggregate);
    filterExpression = unescape(filterExpression);

     alert (
        "Label : " + label + "\n" +
        "Value : " + value + "\n" +
        "Index : " + index + "\n" +
        "Aggregate : " + aggregate + "\n" +
         "Filter Expression : " + filterExpression + "\n");
}

The information passed to client side event handler are : controlId, label, value, index, aggregate, filterExpression of corresponding chart object.

You might want to use the filterExpression as additional filterExpression later for your child query in drill in concept.

See Also

WebGrid Features Overview

Getting Started
Getting Started

Other Resources
Walkthrough Topics
How-to Topics


Paging Data

Paging Data
See Also Send Feedback
Intersoft WebGrid > WebGrid Features Overview > Paging Data

Glossary Item Box

WebGrid introduces a breakthrough concept in data grid paging which allows you to retrieve data as needed. With this feature, you can build high-performance applications regardless of the data size. This will ultimately allow your application to grow and scale without trading-off performance.

This topic contains the following sections:

  • Virtual Load
  • Classic Paging

Virtual Load

The implementation of the VirtualLoad paging concept provides an effective approach for users as more data will retrieved from server transparently. WebGrid will initially load a number of rows specified in VirtualPageSize. This results in faster page rendering to client, less bandwith taken and reduced server's workload.

The key design of the feature is to enable a fast, effective and efficient data presentation when work in large DataSource's web applications. Developers are recommended to turn on VirtualLoad paging mode most of the times.

To use Virtual Load, you set the PagingMode to VirtualLoad. In addition, you will also need to specify VirtualPageSize property which allows you to define how many data that you want to load initially.

For more information, see Virtual Load Overview.

Classic Paging

In addition to the VirtualLoad paging, WebGrid also support traditional (classic) paging mode. Although VirtualLoad paging is best suitable for modern Web application, many end users still prefer to use classic paging mode. Classic paging mode is defined by a set of navigation controls (such as First, Previous, Next and Last) to control the active page. In classic paging, the total number of visible rows is a constant number (eg, 25).

Furthermore, WebGrid does not only provide the paging mechanism in ClassicPaging mode, but it also provides rich user interface/styles in PagingStyleUI property.

For more information, read Classic Paging Overview.

See Also

WebGrid Features Overview

Getting Started
Getting Started

Other Resources
Walkthrough Topics
How-to Topics


Virtual Load

Virtual Load
See Also Send Feedback
Intersoft WebGrid > WebGrid Features Overview > Paging Data > Virtual Load

Glossary Item Box

Built to support modern Web 2.0 applications, WebGrid introduces breakthrough virtual loading paging mode. Instead of having users to navigate pages, VirtualLoad seamlessly loads more data as the Grid is scrolled downward, makes data browsing more intuitive than ever.

With VirtualLoad paging you can stay one step ahead of your users. As users move through pages, this feature looks ahead to request not only the currently required page, but also the pages likely to be needed next. Previously displayed data is retained, allowing pages of data to be presented with fewer trips to the server. VirtualLoad is now enhanced to work seamlessly with grouped rows in Client Binding mode.

This topic contains the following section:

  • How VirtualLoad Paging Mode Works?
  • Enable VirtualLoad Paging
  • Customize VirtualLoad Paging Size
  • Customize Load Mechanism
  • Implement Custom Virtual Load
  • Enable Virtual Group Row Paging

How VirtualLoad Paging Mode Works?

The VirtualLoad™ paging concept, is a unique feature that enables more data to be retrieved from server transparently and virtually as users scroll the data forward. As of other key features, the VirtualLoad paging feature also works in conjunction with all other key's features such as automatic data caching and processing.

The VirtualLoad paging mode works in following ways:

  • When no group columns exist in top level Table, more rows can be retrieved by clicking on "Load More Data" icon or by scrolling the vertical scrollbars to the bottom edge of the Grid.
  • When group columns exist in top level Table, all parent group rows will be rendered to clients but only a number of defined rows are rendered counted from the first parent group row. Therefore, it is able to keep server's bandwidth usage as minimal as possible, while displaying all necessary information. When users click on + to expand group row, the control will transparently and virtually load the child rows of that group row.

Enable VirtualLoad Paging

To enable VirtualLoad, simply open the WebGrid Designer and set the PagingMode to VirtualLoad. The default value of VirtualPageSize is 50 which you can customize to fit your application’s need.

Code Copy Code
<ISWebGrid:WebGrid ID="WebGrid1" runat="server" ...>
    <RootTable ...>
        ...
    </RootTable>
    <LayoutSettings PagingMode="VirtualLoad">
    </LayoutSettings>
</ISWebGrid:WebGrid>

Customize VirtualLoad Paging Size

WebGrid allows you to customize paging size in VirtualLoad mode. To customize the VirtualLoad paging size, set the VirtualPageSize property to a number which specifies the number of rows to retrieve. (e.g. 20).

Customize Load Mechanism

WebGrid has VirtualLoadMode property which is appropriate for the enterprise-class application scenarios where the size of database is relatively large and getting larger as the business grows. There are three modes of VirtualLoadMode: Default, LargeData, and Custom.

On the default mode, WebGrid will retrieve and render a number of rows specified in VirtualPageSize. While on the LargeData mode, all rows in VirtualPageSize will be rendered by the the grid. This mode is appropriate for large-size data.

On the custom mode, developers need to specify the data fetching logic. Sorting, editing and all-other data aware functionalities can work in this mode, except Grouping since that Grouping requires all rows to be loaded.

Using LargeData option in the VirtualLoadMode property restricts the users to export ALL the data. Only a certain batch of data which has been retrieved by users, will be exported to the medium. Therefore, in order to export ALL data, the VirtualLoadMode property needs to be configured to Default option temporarily and invokes the RebindDataSource() method.

Implement Custom Virtual Load

Custom VirtualLoad is one of VirtualLoad features which allow developer to setup a grid with their own implementation and logic for fetching the data. Note that sorting, editing and all other data-aware functionalities can work in this mode, except Grouping since that Grouping requires all rows to be loaded.

For more detail information, please check the How-to: Implement custom Virtual Load.

Enable Virtual Group Row Paging

WebGrid now supports group row paging when used together with VirtualLoad™ mode. The group row paging significantly improves overall performance by loading only a small number of records (specified in GroupRowPageSize property) when user expands the group header.

To enable group row paging feature, simply set the EnableGroupRowPaging property to true. You can also customize the group row page size by setting the GroupRowPageSize property. These properties can be found in ClientBindingSettings.

To learn more, please check How-to: Enable Virtual Group Row Paging.

See Also

WebGrid Features Overview

Getting Started
Getting Started

Other Resources
Walkthrough Topics
How-to Topics


Classic Paging

Classic Paging
See Also Send Feedback
Intersoft WebGrid > WebGrid Features Overview > Paging Data > Classic Paging

Glossary Item Box

Due to popular demand, classic paging is now supported in WebGrid. Although VirtualLoad paging is best suitable for modern Web application, many end users still prefer to use classic paging mode. Classic paging mode is defined by a set of navigation controls (such as First, Previous, Next and Last) to control the active page. In classic paging, the total number of visible rows is a constant number (i.e., 25).

This topic provides an overview of the classic paging feature in WebGrid, shows how to enable classic paging, customizing paging style user interface, and explains about the classic paging API.

This topic contains the following sections:

  • Enable Classic Paging
  • Customizing Paging Size
  • Customizing Paging Style User Interface
  • Advanced LoadOnDemand
  • Custom Data Retrieval Classic Paging
  • Fully Compatible with All WebGrid Features
  • Classic Paging with Other Features
  • Extended Behavior
  • Customizing Texts and Images
  • Classic Paging API

Enable Classic Paging

To enable classic paging in WebGrid Enterprise, you set the PagingMode property to ClassicPaging.

Code Copy Code
<ISWebGrid:WebGrid ID="WebGrid1" runat="server" ...>
    ...
    <LayoutSettings PagingMode="ClassicPaging">
    </LayoutSettings>
</ISWebGrid:WebGrid>

When enabled, the PagingStyleUI is set to FirstPrevNextLast style, which will display a set of paging commands in the status bar.

The default PagingStyleUI provides five basic user interfaces for paging purpose, which is located at
status bar area:

  • First command. Move data view to the first page.
  • Previous command. Move data view to the previous page.
  • Next command. Move data view to the next page.
  • Last command. Move data view to the last page.
  • Goto command. Display available pages in context menu for direct paging. To try this functionality, click on the dropdown arrow besides the page status text.
  • Page Status. Display the current paging status.

Customizing Paging Size

You can customize the number of visible rows in one page by setting the PagingSize [link to PagingSize property] property. PagingSize property will get or sets the number of viewable records in a page when PagingMode is set to ClassicPaging. The default value of PagingSize property is 25.

Customizing Paging Style User Interface

WebGrid provides three built-in user interface styles for the classic paging feature. The paging styles are:

  • FirstPrevNextLast style
  • SimpleDropDown style
  • Slider style

FirstPrevNextLast style

This is the default value of paging style UI. This style includes the basic commands for navigating between pages. It also includes a handy “Jump To” interface accessible through dropdown menu.

SimpleDropDown style

In the scenario where the screen real estate is limited, this paging style is the most recommended, as it includes only basic navigation commands presented in simple and minimalistic design.

Slider style

This new innovative style resembles modern slider bar for intuitive navigation in minimalistic fashion. This style is perfect for every rich Web application that demand sophisticated user interface.

The Slider style paging UI introduces a new user experience to navigate between long pages. Instead of showing numerous different paging commands, Slider style sports a sleek, minimalist and visually compelling user interface in the status bar to let users perform data navigation in a smart and smoother experience. The Slider User Interface consists of several elements:

  • Minus command
    This command instructs WebGrid to show the previous page view.
  • Slider Track
    You can click on the slider track to quickly forward the pages. When you hold down the left mouse button for more than 1 second, it will smoothly move toward the current mouse cursor.
  • Slider Thumb
    Similar to the scrollbar behavior in Windows®, you can drag the slider thumb to the left or right direction and release mouse button as you reach destination page. While you drag the slider thumb, a handy tooltip will appear to indicate the page number where the scroll thumb is located.
  • Plus command
    This command instructs WebGrid to show the next page view.

There are two important properties related to Slider paging style UI:

  • PagingLatencyOnSlide
    When you drag the slider thumb to change the active page index, WebGrid does not perform AJAX callback immediately. Instead, it will wait for several milliseconds as specified in PagingLatencyOnSlide property to avoid "bogus callbacks". This feature improves user experience and increasing efficiency by invoking paging after end user has stop sliding for several milliseconds.
  • PagingSliderWidth
    By default, the slider bar width is set to 100px. You can customize the slider bar's width according to the screen real estate of your Web page. For instance, in a Web page which have only one WebGrid as the data presenter, you may want to have larger slider bar (such as 300px) to allow your users to conveniently scroll through long pages.

Advanced LoadOnDemand

This feature works in conjunction with Hierarchical grid mode and automatic data processing feature. With efficiency and scalability in mind, child rows data of its parent row will not be rendered to client on each loaded Table. The child rows of a Table will be retrieved transparently when users click on + sign to expand the child rows. This results in efficient information delivery by displaying necessary information and load more information transparently when needed, all without leaving the current state of the working page.

The LoadOnDemand feature provides a custom event handler in which developers can write custom codes to handle data source-related operations such as custom row filtering based on client's input or other server operations. The custom event handler called InitializeChildDataSource also provides a pair of parent constraint's information in Xml-based string format.

For more information, see Walkthrough: Loading child rows on demand based on the selected parent row

Custom Data Retrieval Classic Paging

Similar to Custom Paging provided in VirtualLoad paging feature, the classic paging also allow you to perform custom data retrieval for paging. By default, the classic paging will use Automatic data retrieval mode. In automatic mode, WebGrid determines the total data source rows based on the given data source and display the current page appropriately.

WebGrid allows you to implement custom paging through data source control. There are two data source controls that support native custom paging:

  • ObjectDataSource
    This data source control comes with ASP.NET 2.0.
  • ISDataSource
    This is a much advanced and superior data source control included with WebGrid 5 or later. To learn more about ISDataSource, please visit Intersoft DataSource Control Website.

In general, custom paging implementation requires three important steps:

  1. Set EnablePaging of the data source control to True.
  2. Provides a method for Select. This method requires three parameters: startRow, maximumRows, and sortExpression.
  3. Provides a method for SelectCount.

The heart of the custom paging is to provide custom logic for retrieving rows according to the current view of the WebGrid. This is done via custom codes in the Select method. The following is a C# sample for select method.

C# Copy Code
namespace dsNorthwindTableAdapters
{
   public partial class OrdersTableAdapter : System.ComponentModel.Component
   {
      public DataTable GetData(int startRowIndex, int maximumRows, string sortExpression)
      {
         dsNorthwind.OrdersDataTable dt = new dsNorthwind.OrdersDataTable();
         int topRows = startRowIndex + maximumRows; if (!string.IsNullOrEmpty(sortExpression))
            sortExpression = " order by " + sortExpression;

         OleDbDataAdapter adapter = new OleDbDataAdapter();
         adapter.SelectCommand = new OleDbCommand("SELECT TOP " + topRows.ToString() + " * FROM Orders" + sortExpression, this.Connection);
         adapter.Fill(dt);

         return dt;
      }
   }
}

Next, the select count method is required to pass the total number of data rows in the table in order for WebGrid to display the total pages. The following is a C# sample for select count method.

C# Copy Code
namespace dsNorthwindTableAdapters
{
   public partial class OrdersTableAdapter : System.ComponentModel.Component
   {
      public int GetCount(string sortExpression)
      {
         OleDbDataAdapter adapter = new OleDbDataAdapter();
         adapter.SelectCommand = new OleDbCommand("Select COUNT(*) From Orders", this.Connection);

         this.Connection.Open();
         int result = (int)adapter.SelectCommand.ExecuteScalar();
         this.Connection.Close();

         return result;
      }
   }
}

Fully Compatible with All WebGrid Features

Although a recent addition, WebGrid’s classic paging feature has been rigorously tested in a wide variety of scenarios. From the basic functions of Add, Edit and Delete, to more complex features such as Sorting and Filtering, Multiple Grouping, and Load On Demand ClassicPaging™ mode have been subjected to extensive real-world environments. Special emphasis has been placed on runtime features and data-heavy scenarios, ensuring that what works in the lab performs flawlessly in real life.

Classic Paging with Other Features

The Classic Paging feature has been extensively tested to meet the high quality and product standards by providing compatibility when used together with the following key features/scenarios:

  • Flat Grid
  • Flat with Custom Paging
  • Grouping
  • Grouping with Partial Row Detection
  • Multiple Grouping
  • Sorting
  • Multiple Sorting + Grouping
  • Filtering
  • Refresh / RefreshAll
  • Add
  • Add + Group
  • Edit
  • Edit + Group / + Sort
  • Delete
  • Delete + Group / + Sort
  • Self Referencing
  • Self Referencing + Load On Demand
  • Self Referencing + Load On Demand + Grouping + DetectPartialGroupRows
  • Column Set
  • Preview Row
  • Hierarchical with multiple child tables
  • Hierarchical + (Add/Edit/Delete)
  • Group Total
  • Column Total
  • Group + Hierarchical
  • Column Freezing
  • Exporting

Important notes:

  • In non self-referencing mode and paging load mode is Automatic, the paging will be applied directly during the data binding process. This ensures high performance and scalability over large data source.
  • When used together with self referencing in preload mode (load-on-demand is off), the paging will be applied after the initialization of self referencing. The paging size will be applied to the root rows, excluding the child rows. This behavior ensures effective navigation between pages of the available root rows.
  • When self referencing is enabled and grouping is enabled, you can still enable PagingDetectPartialGroupRows feature to deliver better record information to user. For more information about partial group rows detection feature, see Classic Paging.

Extended Behavior

With the introduction of classic paging in version 6.0, WebGrid includes extended behavior when used together with Grouping feature. When the grouping is enabled and classic paging is used, WebGrid will display the grouped rows of the respective rows in the active page.

Unlike the flat view, grouped rows in paged view may include only partial rows. This may cause misunderstanding on viewer side especially when group total or column aggregation is enabled. For this purpose, WebGrid includes a special paging feature for grouping purpose called PagingDetectPartialGroupRows. By default, this feature is not turned on.

The following screenshot illustrates a page view when Grouping is enabled and PagingDetectPartialGroupRows is set to False.

The following screenshot illustrates a page view with PagingDetectPartialGroupRows enabled.

As seen in the two illustrations above, the first WebGrid simply shows the group rows of the active page index, without telling the readers whether the group rows are complete. For instance, the Owner group actually contains 17 rows but only 4 rows are displayed due to the paging (called partial grouped rows). The second WebGrid appropriately tells readers that the Owner group consisted of partial rows (eg, Record 14-17 of 17).

The PagingDetectPartialGroupRows feature automatically detects possible partial grouped rows of first and last row of the active page view. By using advanced delta mechanism, this feature does not sacrifice performance as it does not use multiple-loop detection mechanism.

However, please note that this feature does not take affect when Custom Paging is enabled. The main reason is because Custom Paging returns only current paged view records which do not include the previous or next records of the table.

Customizing Texts and Images

The classic paging feature introduces several new text items to the localizable language files. The following shows the list of added text items related to classic paging feature:

  • Under CommonText
    • PagingLoading
    • PagingStatu
    • PagingPartialGroup
  • Under Tooltip
    • PagingFirst
    • PagingPrev
    • PagingNext
    • PagingLast
    • PagingGoT
    • PagingSlider
  • Under Paging
    • PagingFormat

To learn more about localization feature and how to customize text settings in WebGrid, see Localization Manager.

In addition to new text items, you can also customize the images used by the classic paging feature. The following shows the list of new image settings related to classic paging feature:

  • Under ImageSettings
    • PagingMoveFirst
    • PagingMovePrevious
    • PagingMoveNext
    • PagingMoveLast
    • PagingDropdown
    • PagingSliderMinus
    • PagingSliderPlus
    • SliderThumbImage
The image files for the classic paging feature is available in both physical files and SmartWebResources assembly. For hassles-free development and deployment, it is highly recommended to enable SmartWebResources feature. To learn more SmartWebResources, please refer to Deployment Guide.

Classic Paging API

The Classic Paging feature in WebGrid is built upon rock-solid, robust object model and API. This enables developers to create their own user interface and perform WebGrid's paging functionality by accessing the provided API.

The following is the list of methods/API related to classic paging:

  • IsClassicPaging()
  • GetCurrentPage()
  • GetTotalPages()
  • GotoFirstPage()
  • GotoLastPage()
  • GotoPreviousPage()
  • GotoNextPage()
  • GotoPage(targetPageNumber)
  • CreatePagingSlider(containerId, sliderId)
  • SynchronizeSliderUI()

For the complete client side object model and API list, please see Client Side References - WebGrid Methods.

For an example that demonstrates classic paging API, please refer to Classic paging with Vista Style sample in Integrated Samples. The following is the screenshot of Classic paging with Vista Style sample.

See Also

WebGrid Features Overview

Getting Started
Getting Started

Other Resources
Walkthrough Topics
How-to Topics


Customizing Data

Customizing Data
See Also Send Feedback
Intersoft WebGrid > WebGrid Features Overview > Customizing Data

Glossary Item Box

WebGrid lets you customize data in flexible ways through the available column types such as Image, CheckBox, and more. In addition, it also supports built-in value list with multiple values capability.

This topic contains the following sections:

  • Column Types
  • Value List

Column Types

WebGrid provides predefined column type such as CheckBox, Image, ImageAndText and so on, which is most commonly used. For greater level of customization, WebGridColumn contents can also be customized to display rich HTML-based contents by setting its ColumnType to Custom.

For more information, see Column Types Overview.

Value List

WebGridColumn also provides the mechanism for value to text translation through ValueList property. You can now easily display different data instead of its value that is more readable and useful by assigning the ValueList property with WebValueList object that has been properly constructed.

To use ValueList, simply set the provided ValueList property. Several properties in the ValueList need to be configured as well such as, DataSourceID, DataTextField, DataValueField. Furthermore, WebGrid also supports multiple values and sorting when used together with ValueList.

For more information, see Value List Overview.

See Also

WebGrid Features Overview

Getting Started
Getting Started

Other Resources
Walkthrough Topics
How-to Topics


Column Types

Column Types
See Also Send Feedback
Intersoft WebGrid > WebGrid Features Overview > Customizing Data > Column Types

Glossary Item Box

WebGrid introduces a built-in column type to display richer content data presentation. WebGrid provides 6 column types such as Text, Image, ImageAndText, CheckBox, Button, Custom, Hyperlink.

Custom column type means that you can freely write any HTML tags into the column to be displayed. Therefore, column types are designed to give users flexibility to use any kind of data presentation in general.

The following screenshot shows how the column types will look like:

  • The 1st column shows how to display Button column type.
  • The 2nd column shows how to display Image column type.
  • The 3rd up to 7th column show how to display Text column type by default.
  • The 8th column shows how to display CheckBox column type.
  • The last column shows how to display Custom column type. In this column, it uses HTML tag to create a bold and italic text.

See Also

WebGrid Features Overview

Getting Started
Getting Started

Other Resources
Walkthrough Topics
How-to Topics


Value List

Value List
See Also Send Feedback
Intersoft WebGrid > WebGrid Features Overview > Customizing Data > Value List

Glossary Item Box

This topic contains the following sections:

  • Codeless WebValueList Data Binding
  • Multiple Values Support in WebValueList
  • Automatic Column Sorting useing WebValueList
  • Filtering Column Based on WebValueList
  • Copy mode option for WebGridColumn which uses WebValueList

Codeless WebValueLIst Data Binding

With declarative DataSource control supported in WebGrid, this makes it very easy for developers to bind the control to a DataSource. In addition to binding the Grid to DataSource control for its main data, WebGrid also enables you to bind a column's value list to DataSource control. This feature completely removes the needs to write codes in the Grid control and allows you to declaratively specify the DataSource control and DataMember for the value list.

As an example, the value list for a WebGridColumn can now be specified declaratively such as:

Code Copy Code
<ISWebGrid:WebGrid...>
            <RootTable DataMember="Products" UseValueListForSorting="Yes">
               <Columns>
                        ...
                       <ISWebGrid:WebGridColumn ...>
                        <ValueList DataMember="Products" DataTextField="ProductName" DataValueField="ProductID">
                        </ValueList>
                      </ISWebGrid:WebGridColumn>
                      ...
               </Columns>
            </RootTable>
</ISWebGrid:WebGrid>

In previous versions, the only way to setup WebValueList is through code behind. You will need to write several line of codes to populate a WebValueList. The declarative WebValueList feature in version 5.0 significantly improves developer's productivity by eliminating codes.

When the WebGrid is bound to ISDataSource control, you can bind the WebValueList to an existing ISDataSourceTable defined in the ISDataSource control. In this case, you don't need to specify the DataSourceControlID of the WebValueList, such as shown in the above markup sample.

Multiple Values Support in WebValueList

WebGrid 5.0 includes enhancement in WebValueList feature to support multiple values data. In previous version, you can easily translate an ID field to user friendly field through WebValueList in WebGrid. However, you can only display one translated value. For instance, RoleID = 1 being translated to Research Staff.

In version 5.0, WebGrid makes it easy to translate multiple values data using the improved WebValueList feature.

To enable multiple values data lookup, you can set EnableMultipleValues property of the WebValueList object to True. You can also specify the separator character used to separate the values data in MultipleValuesSeparator property.
The following image shows the Roles column which values have been properly translated using WebValueList.

Automatic Column Sorting useing WebValueList

Since the introduction of WebGrid 3.1, WebValueList has been one of the most popular feature in WebGrid control. With WebValueList, you can easily translate ID to Text Lookup by using the DataSource populated in the WebValueList object. For instance, the Supplier Name in the WebGrid above is actually an ID column which is translated to Company Name field of Suppliers table through WebValueList.

In version 5.0, WebValueList feature has been significantly enhanced to overcome several limitations introduced in previous versions of WebGrid. The column sorting and grouping can now take advantage of the same DataSource that populated in the WebValueList. With this enhanced WebValueList, you no longer have to manually retrieve the text field of the value column in the WebGrid's main DataSource.

Sample codes (ASPX):

Code Copy Code
<ISWebGrid:WebGrid id="WebGrid2" runat="server" height="300px" UseDefaultstyle="True"
            width="100%" DataMember="Products" DataSourceid="ISDataSource1">
            <RootTable DataMember="Products" UseValueListForSorting="Yes">
               <Columns>
                     ...
                       <ISWebGrid:WebGridColumn ...>
                        <ValueList DataMember="Suppliers" DataTextField="CompanyName" DataValueField="SupplierID">
                        </ValueList>
                    </ISWebGrid:WebGridColumn>
                    ...
                </Columns>
            </RootTable>
            <LayoutSettings AllowSorting="Yes" AllowGrouping="Yes">
            </LayoutSettings>
</ISWebGrid:WebGrid>

Filtering Column Based on WebValueList

Normally, ValueList will represent ID (assume as int) as value and text field (assume as string) as text. This became a problem in filtering scenario. WebGrid filter will show integer filter type instead of text filter type. You will get confused to filter the data cause you might more familiar with text than value. With this enhanced ValueList, you might use the proper information when filtering the information.

Sample codes (ASPX):

Code Copy Code
<ISWebGrid:WebGrid id="WebGrid2" runat="server" height="300px" UseDefaultstyle="True" width="100%" DataMember="Products" DataSourceid="ISDataSource1">     <RootTable DataMember="Products" UseValueListForFilter="Yes">         <Columns>             ...             <ISWebGrid:WebGridColumn ...>             <ValueList DataMember="Suppliers" DataTextField="CompanyName" DataValueField="SupplierID">             </ValueList>             </ISWebGrid:WebGridColumn> ...         </Columns>     </RootTable>     <LayoutSettings AllowSorting="Yes" AllowGrouping="Yes">     </LayoutSettings> </ISWebGrid:WebGrid>

Copy mode option for WebGridColumn which uses WebValueList

In WebValueList scenario, WebGrid usually shows text information instead of id. When you want to copy a certain row, it will show text for WebGridColumn which uses WebValueList. However, sometimes you only need to know the value instead of text.

WebGrid 9 introduces new property that called 'ClipboardCopyMode' which allow you to decide which information should be copied. You can choose text or value for ClipboardCopyMode property. With this property, you can decide based on your needed. This property is available in Column level.

Sample codes (ASPX):

Code Copy Code
<ISWebGrid:WebGrid id="WebGrid2" runat="server" height="300px" UseDefaultstyle="True" width="100%" DataMember="Products" DataSourceid="ISDataSource1">     <RootTable DataMember="Products" UseValueListForFilter="Yes">         <Columns>             ...             <ISWebGrid:WebGridColumn Caption="SupplierID" DataMember="SupplierID" DataType="System.Int32"                EditType="DropdownList" Name="SupplierID" Width="100px" ClipboardCopyMode="Value">                <ValueList DataMember="Suppliers" DataTextField="CompanyName" DataValueField="SupplierID">                </ValueList>            </ISWebGrid:WebGridColumn> ...         </Columns>     </RootTable>     <LayoutSettings AllowSorting="Yes" AllowGrouping="Yes">     </LayoutSettings> </ISWebGrid:WebGrid>

See Also

WebGrid Features Overview

Getting Started
Getting Started

Other Resources
Walkthrough Topics
How-to Topics


Customizing UI

Customizing UI
See Also Send Feedback
Intersoft WebGrid > WebGrid Features Overview > Customizing UI

Glossary Item Box

WebGrid provides flexibility for developers to customize many aspects of the user interface elements. For instances, you can customize the context menu, displaying the row checker, showing verbose information during editing, show or hide filter status bar indicator, localizing text, freezing columns, and much more.

This topic contains the following sections:

  • Context Menu
  • Verbose Editing Info Text
  • Row Checker
  • Localization Manager
  • Rich User Interface Elements
  • Column Freezing
  • Customizing Default Style
  • Multiple Row Selection
  • ButtonImage Column Type
  • Predefined Visual Themes
  • Column Action
  • Section 508 Standards and Accessibility Support
  • Text Settings
  • XHTML and HTML5 Support

Context Menu

WebGrid introduces convenient context menus for column header, allowing user to perform column-related actions based on the column's context. In Enterprise edition, the context menu is applicable to all WebGrid's UI objects such as grouped column header in GroupByBox area, cell, row, grouped row and so on. The context menus selectively displays a list of actions which is valid in the current context of the object. For instance, the "Show child rows" menu will appear for hierarchical row or the "Expand" menu will appear when the grouped row is right-clicked. This allows end-users to perform actions in the way that they prefer by either using keyboard or mouse.

Following is screenshot of objects that has context menu applicable.

GroupColumn

Standard Cell/Row

Grouped Row

Row with Edit and Delete feature.

Edited New Row

Context Menu Customization

WebGrid is continually enhanced to meet your most demanding Web 2.0 applications. It now supports customization on all context menu elements such as header context menu and exporting context menu - giving developers the utmost flexibility to create rich user experiences required in today's business applications.

The context menu can be customized through the new OnColumnContextMenu client-side event. For more information on the event arguments supplied in this event, please see New Client Events.

The following Javascript code shows how to add custom menu to the header context menu. It adds Google Map functionality when users right click on the Address column header.

JavaScript Copy Code
function OnColumnContextMenu(controlId, column, menu, isGroup, location)
{
   var grid = ISGetObject(controlId);
   var selectedObject = grid.GetSelectedObject();
   var selectedRow = (selectedObject ? selectedObject.ToRowObject() : null);

   if (column.Name == "Address" && selectedRow != null &&
           selectedRow.Type == "Record")
   {
      var mapsMenu = new WebMenuItem("maps", "Google Maps");
      var templateMenu = new WebMenuItem("maps_canvas", "");
      var address = selectedRow.GetCell(column.Name).Text;

      templateMenu.Type = "Template";
      templateMenu.Enabled = false;

      if (googleMapInitialized && address != "")
      {
         mapsMenu.SubMenu.Items.Add(templateMenu);

         // add our new menu items to the header context menu
         menu.Items.Add(new WebMenuSeparatorItem());
         menu.Items.Add(mapsMenu);

         ShowMapByAddress(address);
      }
      else
      {
         mapsMenu.Enabled = false;
      }
   }
}

Turn Off Animation in Context Menu

One of the best features in WebGrid is its rich user interaction. WebGrid includes rich context menu natively, so that users can choose from various commands that related to a specific object or context. By default, the context menu will be shown with fading animation for best user experience.

The following image shows the context menu on row object with AutoFilterSuggestion feature enabled.

New to this version is the option to turn off animation in context menu. WebGrid now provides a property called ContextMenuAnimation inside the LayoutSettings property. You can set it to false value to turn off the animation in all WebGrid's context menu.

The following image illustrates the result of the sample which integrates Google Map into WebGrid's header context menu.

Verbose Editing Info Text

WebGrid comes with many enhancements related to editing feature. One of the most significant enhancements is the new verbose information text in editing mode. This new feature is useful to deliver intuitive editing experience for users as they can notice on important information related to a specific column in status bar area.

This new feature allows you to assign information text and image for each WebGridColumn. You can try to click on different cells in this sample and notice the verbose infotext in the status bar. When this feature is enabled, there are several automated behaviors:

  • Column with EditType = NoEdit (read only) will have the status text and icon configured automatically.
  • When EditInfoImage is provided, the image will appear in status bar.
  • When a cell is being edited, the Edit Image will appear in status bar.
  • When a cell is being edited or has been modified - and EditInfoText is not provided, the status text and image will be configured automatically.
  • When the edit cursor is focused on cell which has been modified, the Edit Image indicator will appear in the status bar. This allows users to easily discover whether a cell has been modified or not.
  • New user-friendly text and icon will be displayed after the successful add/edit/delete operation. For instance, the text Record is updated successfully will be displayed instead of Ready after successful update.

Row Checker

A significant improvement in WebGrid is column's IsRowChecker property, allowing you to create efficient multiple rows selection grid interface quickly. There are numerous automated behavior attached when working in this mode, such as select/deselect all checkbox in column header, application of CheckedRowStyle, batch multiple rows selection by pressing Shift key, and much more.

Behavior

When a column has its IsRowChecker property set to True, a few other properties will be automatically configured such as Width to 25px, ColumnType to Checkbox, SelectColumns To No and so on. The "select/deselect all" checkbox in Caption is automatically generated for IsRowChecker column. The code for the select/deselect all functionality has also been written internally and so you do not have to do anything else, just focus on your business logic. When you check a row and select another row, the checked row will have appeared in another style named "CheckedRowStyle". The CheckedRowStyle can be customized in designer and its purpose is to let users easily notice and read which rows have been checked. When not in Edit mode, you can press Spacebar to toggle the checkbox state of a row. Use Ctrl Spacebar when the table is editable.

Another useful behavior is its ability to perform "batch" selection or deselection by clicking on a checkbox for starting point, pressing Shift key afterwards and finally clicking on another check box far below or up from the starting point. All checkboxes between the starting point and the secondly clicked checkbox will be check marked. This made "multiple rows selection" is not only possible in today's high innovative web applications, but also improves the efficiency which results in more productivity.

Client API

To get checked rows in root table, you can use following syntax:

JavaScript Copy Code
var grid = ISGetObject("WebGrid1");
var table = grid.RootTable;
var checkedRows = table.GetCheckedRows();
alert(checkedRows.length); // return 4

for (var i=0; i<checkedrows.length; i++)
   alert(checkedRows[i].keyValue);

Server API

You can easily retrieve checked rows in root table at server side by using:

C# Copy Code
ArrayList checkedRows = WebGrid1.RootTable.GetCheckedRows();

Localization Manager

Localization Manager is a feature to help you configuring the language settings in WebGrid. In this new version, Localization Manager has been much improved with the adoption of clean and uncluttered user interface which results in better development experience and easier to use.

The improved Localization Manager also incorporates the new SmartWebResources™ feature in its user interface so that you can effortlessly configure resources and related language settings in one streamlined user interface. For more information, please read Localization Manager Overview.

Rich User Interface Elements

WebGrid is the most significant release since its initial debut. Version 5.0 includes many enhancements to Grid-specific functions, data binding and new features in User Interface.

WebGrid comes with new user interface such as new icon-sets, new context menu engine and styles, as well as new "Elegant" style. These new features help end users to interact with information better with a Grid which is not only powerful in functions, but appealing to eyes and experience as well.

The following screenshot captures the "First Experience" sample of WebGrid 5.0. The new visual appearance and interface redefines user experience while interacting with the control.

Some of the new features related to user interface are:

  • Status bar group. The status text is now easier to be read with clear separation between each different function group.
  • New theme and improved styles with smooth blue "Glass" appearance in Elegant style.
  • New set of icons, such as new status bar icons and better loading indicator. All context menu items are also having new icons as well.
  • User-friendly command messages based on data type. For instance, sorting text is now customized according to the data type. These new textual elements are included as localizable text (controlled by Localization feature).
  • New RowHighlightType for more convenient editing experience.
  • New high-performance context menu interface with smooth fading animation and shadow effect.
  • Improved User Interface for Error Dialog Box.
  • Visual indicator for action status and editing information in Status Bar.
    The following screenshot demonstrates the new "Elegant" style while operating in editing mode. Notice that cell border of selected row remains visible (new RowHighlightType) and larger edit cell for more convenience editing experience.

The following screenshot demonstrates the new "Elegant" style while operating in editing mode. Notice that cell border of selected row remains visible (new RowHighlightType) and larger edit cell for more convenience editing experience.

Column Freezing

WebGrid is the industry's first WebGrid that successfully implements Microsoft Excel style column freezing feature. In this new version, WebGrid introduces LiveFreeze™technology which enables users to "lively" perform column freezing and unfreezing in real-time without the need of postback or callback.

For more information, see Column Freezing overview.

Customizing Default Style

The DefaultStyle feature in WebGrid will significantly reduce page output size, especially if you have large number of WebGrid in a webform. We recommend you to enable the default style feature since it offers the following benefits:

  • Clean control definition during development. This significantly improves loading time in the VS 2005 designer because unnecessary style objects do not need to be created.
  • Best performance in server throughput. Using default style will significantly reduce server side processing because there is no need for serializing styles, validating and parsing the styles and finally generate the styles into css-based classes in the page output.
  • When default style is enabled, in-line styles are no longer generated in the webpage. Instead, all WebGrid instances in the same webpage will share the same external stylesheet which significantly reducing output size.
  • Reduced page output size up to 70 percent. Based on a research, more than 60 percent of web developers do not modify the styles of Intersoft’s controls in their web application.

For more information, read Customize Default Style overview.

Multiple Row Selection

WebGrid provides a feature that allows users to select multiple rows using checkbox. With this initial approach, checkbox will appear in every row in the Grid to allow users to check on the checkbox in order to select the row.

In several scenarios, developers often want the ability to select multiple rows without using checkbox due to application design. WebGrid Enterprise in 2008 R2 release now allows you to perform multiple row selection by using the user-friendly Ctrl and Shift key combination. This feature allows you to simulate Windows-like interactivity and elegant design to select multiple rows without the need to use checkbox.

IMPORTANT: Multiple Row Selection can't be used alongside with RowChecker feature, as both features will cause conflict and undesired effect to the selection result. You should enable only RowChecker feature (which used checkbox) or the new Multiple Row Selection feature at a time.

Keyboard combination supported in this new feature:

  • Use Ctrl + Click to select any individual rows.

    To select individual rows, hold down Ctrl key, and then click on the row to select it.

  • Use Shift + Click to select a range of continuous rows.

    You can easily select a range of continuous rows by clicking on the start row, then hold down Shift key, and click on the destination ending row.

  • Use Ctrl + Shift + Click to select a range of continuous rows without clearing previous selection.

    Use the combination of Ctrl and Shift key to select a range of continuous rows while preserving the previous selection.
Thanks to the innovative architecture in WebGrid - you can enable this feature by simply setting the AllowMultipleSelection property to Yes value. This means you no longer require any workarounds or custom codes to enable this interactivity feature.

Other enhancements related to Multiple Row Selection feature

The new Multiple Row Selection feature can be used in conjunction with many existing features. The bare-metal architecture of WebGrid allows a new feature to work flawlessly with other features, providing a great flexibility and options for developers to customize WebGrid's behaviors.

When Multiple Row Selection is enabled, the row context menu will show a new command item to allow users to copy the selected rows to the clipboard.

The following screenshot shows the Multiple Selection feature in a Grid with ColumnSet configuration.

The new "Copy Selection" menu item will appear when you right click on the selection (any selected rows area).

The Copy Selection function is a handy way to copy selected information to other sources. For instance, you can copy the selection to clipboard, and paste them to Excel worksheet or Word document.

By default, when AllowMultipleSelection property is set to Yes, all tables (WebGridTable) in the hierarchical configuration will apply the setting as well, thus allowing multiple selection on all tables. You can also disable the feature on individual table by setting the AllowMultipleSelection property of the desired table to No value.

The Multiple Row Selection feature can be enabled only in Child Table, while disabled in Root Table.

ButtonImage Column Type

Due to popular demand, WebGrid now includes a new ButtonImage column type for handy button display with image. Although developers can use Template column type to specify any kind of contents such as <asp:Image>, it doesn't take advantage of WebGrid's postback mechanism and developers have to handle the events manually, which is time consuming.

The following screenshot shows a WebGrid using ButtonImage column type in the first column.

The ButtonImage column type takes advantage of existing architecture such as ButtonAutoPostback property and ButtonPostbackMode property. The ButtonClick client side event is invoked as well for ButtonImage column type.

The sample ButtonImage definition in WebGridColumn is as following:

C# Copy Code
<ISWebGrid:WebGridColumn Width="25px" ColumnType="ButtonImage"
    ButtonImage="images/info.gif" ButtonAutoPostback="true">
</ISWebGrid:WebGridColumn>

Predefined Visual Themes

Designed from the ground up by Intersoft artists, WebGrid 7 now is preloaded with three new dazzling visual themes: Windows 7, Glassy Black and Metallic Silver.

Thanks to WebGrid's DefaultStyle - architecture, applying the new theme can be done as easy as one property set. The new themes are available as new options in DefaultStyleMode property in the WebGrid control.

Each visual theme is designed with high quality graphics and balanced color scheme. In addition to the main WebGrid interface, the theme also covers all aspects of WebGrid user interface elements, including context menu, pivot charting interface, ribbon, buttons, status bar and more.

The following screenshots illustrate the design for each visual theme:

Windows 7

Grid View

Pivot Chart View

Black Theme

Grid View

Pivot Chart View

Silver Theme

Grid View

Pivot Chart View

To set the theme in Webform, simply set the DefaultStyleMode property to the desired theme name in the WebGrid control. Alternatively, you can also set the theme in the design-time by using the enhanced WebGrid Designer.

Column Action

New in WebGrid 7 is Column Action, a new user interface feature to display contextual column actions through a visual hint that automatically appear when users hover on a column - making it even easier and faster for users to access column-related commands.

By default, the column action will show the column context menu which includes built-in commands such as sorting, grouping, column freezing, select columns or other column-related features that are currently enabled.

In addition to the default behavior, WebGrid also supports column action customization to enable broader and more advanced scenarios, for instances, adding new commands or displaying predefined filter menu similar to Windows Explorer. The customization can be elegantly done by handling OnColumnAction client-side event.

The following example shows how to show a custom context menu during column action.

ASPX

C# Copy Code
<ISWebGrid:WebGrid ID="WebGrid1" runat="server">
   <LayoutSettings>
      <ClientSideEvents OnColumnAction="OnColumnAction" />
   </LayoutSettings>
</ISWebGrid:WebGrid>

Javascript

JavaScript Copy Code
function OnColumnAction(controlId, column)
{
   if (column.Name == "Modified")
   {
      var menu = ISGetObject("dateFilterMenu");
      var grid = ISGetObject(controlId);
      var eventLocation = menu.GetEventLocation();

       eventLocation.X -= 8;
       eventLocation.Y += 5;
       menu.Show(eventLocation);
       grid.ActionBoxShown = true;

       return false; // cancel default behavior
   }
}

The following screenshot illustrates a WebGrid sample that used Explorer-style predefined date filter as the column action.

The column action is customized to display Windows Explorer style date filter menu

Section 508 Standards and Accessibility Support

WebGrid now fully implements the support for Section 508 Standards in the following provision:

  • Provision 1194.22 - About Data Table Headers & Associations
    • Row and column headers should be identified for data tables.
    • Column headers should be in the same table structure as the table's contents (rows).
    • Markup shall be used to associate data cells and header cells for data tables that have two or more logical levels of row or column headers.
  • Objectives:
    • Allows Web developers with their assistive technology to build solution using WebGrid.NET Enterprise for supporting people with visual disabilities.
    • Allows users of screen readers to interpret table data efficiently.

Development notes and changes in WebGrid when this new feature is enabled:

  • WebGrid renders column headers inside the content's table structure. The header and content structure is no longer separated.
  • The fixed column header is no longer applicable. This means that when you scroll downward to the bottom, the column headers will follow as well.
  • Column headers appearance and styles will still be rendered in the same fashion as in normal mode.
  • Other type or headers such as filter row and new row is now rendered inside the content's table structure as well.
  • Basic column operations are still supported in this accessibility mode, such as column moving, resizing, sorting, grouping and filtering.
  • Working perfectly in conjunction with the following advanced features:
    • User Interactions using keyboard, context menu, mouse selection, and drag drop.
    • Virtual Load.
    • Column Freezing.
    • AutoFit Columns.
    • All FlyPostBack actions such as refresh, grouping, load more data, etc.
  • Hierarchical and Self Referencing modes are supported.
  • Client side API is internally restructured, no public API changes is necessary. This means, your existing codes should run properly without any changes required.
  • ColumnSet layout mode is not supported in this version.

Enabling Section 508 Standards in WebGrid

WebGrid makes it very easy for developers to enable Section 508 Standards mode in WebGrid instances. A new property at the WebGrid level has been added to take advantage of this mode.

To enable Section 508 Standards mode in your WebGrid, simply locate the EnableSection508Standards property in Visual Studio property window, and set it to True.
When you run the WebForm in the browser, you wouldn't notice significant difference with the normal mode, except the column headers are now scrolled when the vertical scrollbar of the Grid is scrolled downward.
While having significant changes in WebGrid's internal structures and APIs to support this new Accessibility mode, WebGrid is still fully compatible with all existing features such as column moving, grouping, resizing, filtering, sorting, context menu and the rest of advanced features.
Thanks to the rock solid architecture of WebGrid, it allows all existing public APIs to function properly without requiring users to modify their existing codes.

Using new properties for assistive technology requirement

WebGrid also exposes several new properties at the Column level to provide flexibility and customization for developers to build their own assistive technology, which connected into the WebGrid instance.

The new properties for WebGridColumn are listed in the following:

  • HtmlScope
    When specified, WebGrid will render the scope attribute to the column header. Valid values are None, Row, Col, RowGroup and ColGroup.
  • HtmlUniqueId
    When specified, WebGrid will render the id attribute to the column header according to the value of this property.
  • HtmlHeaders
    When specified, WebGrid will render the headers attribute to the column header according to the value of this property.

To access the new properties of WebGridColumn in design time, please do the following:

  • Right click on the WebGrid instance.
  • Choose WebGrid.NET Designer.
  • Click on Advanced tab.
  • Expand WebGrid, RootTable, and choose Columns.
  • Select a column.
  • Click "See all properties" in the right panel containing properties. Please refer to the following screenshot for more details.

Text Settings

To match the flexibility of WebGrid's XML Localization Manager, we have completely removed the property-based TextSettings such as Refresh, RefreshAll etc. As replacement, grid-level TextSettings can be customized in WebGrid Designer under Text Settings node as you can see in the screenshot below. You can add variety of TextItem to be customized by simply clicking on Add button and select a TextItem by selecting it from dropdown designer.

The grid-level TextSettings customization is the lowest level which will override the definition in default xml language file as well as custom defined language file. This provides flexibility to developers who wanted to customize specific TextItem that applicable to a grid instance only. Note that all properties in TextSettings should be removed in order for the new grid to work properly.

XHTML and HTML5 Support

WebGrid continues to deliver constant improvement to support Web standards such as HTML5. The latest release now supports pixel-perfect rendering when operating in HTML5 document type.

For more information about HTML5 support, see Features Added in WebGrid 8.

The supported browsers for HTML5 document type are:

  • Internet Explorer 9 Standards mode
  • Firefox 7+
  • Safari 5+
  • Opera 11+
  • Other Gecko or Webkit variants

See Also

WebGrid Features Overview

Getting Started
Getting Started

Other Resources
Walkthrough Topics
How-to Topics


Localization Manager

Localization Manager
See Also Send Feedback
Intersoft WebGrid > WebGrid Features Overview > Customizing UI > Localization Manager

Glossary Item Box

This topic contains the following sections:

  • Introduction
  • Batch Update Localization
  • Deployment

Introduction

Intersoft Solutions has taken important strategy in localization capability of all its products.

This version allows you to customize all textual elements available in WebGrid's UI, from common text such as Ready, Refresh etc to context menu. The new localization feature works in conjunction with the LanguageMode which is also a new property added to the TextSettings object. There are three language modes that you can use to internationalize WebGrid efficiently:

  • Default mode

    The default language file will be used regardless of any settings.

  • Inherit from Culture mode

    The control will pick the language based on the specified Culture in WebGrid level or Thread level. When the language file cannot be found, it will fallback to use the default language file.

  • UseCustom mode

    You will decide which language exactly that the WebGrid will use, regardless of any culture settings. If the language file cannot be found, it will fallback to use the default language file.

For greater flexibility, the common text settings are still customizable per grid's instance and will override any of the language mode above. The default localization folder is inside ScriptFolder and needs to be shipped along with your application.

Batch Update Localization

The new batch update feature in WebGrid 7 introduces a dozens of new User Interface elements, which contains many new textual settings as well.

As in good tradition of WebGrid, all textual settings are customizable according to the culture specified by developer. Each textual setting can also be overridden individually. You can find the complete text settings in default.xml which is located in the Localization folder.

The following table lists the new text settings that you can customize.

Category | Text Setting Key | Default Text Setting Value (English)
CommonText | PendingChanges | {0} pending change(s).
 | DeletedRowNoEdit | Row marked as deleted cannot be modified.
 | DeletedRowNoExpand | Row marked as deleted cannot be expanded.
 | BatchUpdateSuccess | All changes have been successfully updated to server.
 | BatchUpdateSuccessWithPartialErrors | One or more changes are not updated due to server errors.
MessageBoxText | UnsavedPendingChanges | You have made one or more changes on WebGrid records. Any unsaved changes will lose.
 | NotifyPendingChanges | There are {0} unsaved pending changes. Click Accept Changes button below to save changes.
 | UndoPendingChanges | Are you sure you want to undo all pending changes?
 | UndoSelectedPendingChanges | Are you sure you want to undo selected pending changes?
 | DeletedRowEditException | You cannot make changes to the row which parent has been marked as deleted.
 | DuplicateKeyException | The pending changes already contain a record with key '{0}'
 | PrimaryKeyEditException | Modification on primary key's field of pending changes is not allowed.
 | BatchUpdateException | An exception has occurred while processing batch update. please correct or undo your changes. \n\Exception details:\n{0}
 | BatchUpdatePartialException | WebGrid failed to update {0} out of {1} changes due to errors. Please review and correct your changes. \n\nThe following records were not updated:\n{2}
Tooltip | ModifiedRowState | Modified row
 | AddedRowState | Added row
 | DeletedRowState | Deleted row
 | PendingChangesEmpty | There are no pending changes
 | PendingChangesExisted | There are {0} pending changes: {1} insert(s), {2} edit(s), {3} delete(s)
 | ReviewChanges | Review Pending Changes
 | UndoChanges | Undo All Changes
 | AcceptChanges | Accept All Changes
ContextMenu/Row | UndoSelection | Undo Selection
 | DeleteSelection | Delete Selection

Note: You may find empty text entries when using languages other than English. If you found empty entries on the language and culture that you are familiar with, please help us to translate the entries using the default.xml as the template and send it to feedback@intersoftpt.com.

Deployment

By default, language files are stored in LocalizationFolder which has default value "/CommonLibrary/WebGrid/V8_0_7200/Localization". Intersoft's products have a concept of "centralized deployment" where client scripts and all supporting files are placed in "CommonLibrary" folder. With this concept, developers can easily deploy web applications along with Intersoft's products by copying only "CommonLibrary" folder to the production server. The CommonLibrary needs to be mapped as IIS Virtual Directory in production server.

Features that depend on centralized "CommonLibrary" concept by default are Localization Manager with its XML language files and CustomEditors with its custom editor definitions and supporting client files.

See Also

WebGrid Features Overview

Getting Started
Getting Started

Other Resources
Walkthrough Topics
How-to Topics


Column Freezing

Column Freezing
See Also Send Feedback
Intersoft WebGrid > WebGrid Features Overview > Customizing UI > Column Freezing

Glossary Item Box

This topic contains the following sections:

  • Introduction
  • Main Concept
  • Runtime freezing/unfreezing
  • Absolute Scrolling
  • LiveFreeze™ behaviors and other notes

Introduction

WebGrid is the industry's first WebGrid that successfully implements Microsoft Excel style column freezing feature. In this new version, WebGrid introduces LiveFreeze technology which enables users to "lively" perform column freezing and unfreezing in realtime without the need of postback or callback.

WebGrid's unique LiveFreeze architecture enables frozen columns to stay visible eventhough the horizontal scrollbar of the WebGrid is scrolled. Some of great results from LiveFreeze implementation are:

  • High performance scrolling. The Grid is capable to handle fast scrolling by either dragging the scrollbar's thumb or click on the left and right arrow.
  • Excel® scrolling behavior. When scrolled, hidden columns must be entirely hidden (instead of partially).
  • Splitter indicator at column header and cell to let users easily determine the current state of frozen columns.
  • Works with all existing WebGrid's functions and FlyPostBack (AJAX) actions such as Grouping, Sorting and Filtering. Try to perform sorting or grouping, notice that scroll position will stay and hidden columns will remain hidden.
  • "Lively" perform freezing and unfreezing in realtime. No AJAX callback or postback is required.
  • Works perfectly with keyboard navigation in cell select mode as well as in editing environment. The hidden column will be automatically visible and focused during editing, the scrollbar will also automatically reflect the current position of the edit cell.
  • Column moving and resizing are supported for unfrozen columns. When moved or resized, scrollbar and current view will be automatically adjusted.

The following image shows a simple WebGrid with Column Freezing feature enabled. The OrderID and CustomerID column remains visible, while the horizontal scrollbar is set to the right most position.

Main Concept

LiveFreeze™ enables you to configure initial column freezing setting from server side property. There are two main properties that need to be set to activate this feature: AllowColumnFreezing property in LayoutSettings and ActiveFrozenColumns property in FreezePaneSettings.

The ActiveFrozenColumns property defines how many columns are frozen in initial page load. The default value is 0, which indicates there are no frozen columns that need to be configured. The value of ActiveFrozenColumns property determines the number of visible columns to be frozen in respective columns order. For instance, if you have a WebGrid with columns "FirstName, LastName, ContactTitle" and LastName's Visible is False and ActiveFrozenColumns set to 2, then the active frozen columns would be "FirstName" and "ContactTitle".
It is best practice to keep the ActiveFrozenColumns property to a value where the column freezing feature may deliver best results in user experience. For instance, if you set ActiveFrozenColumns to a value exceeding half of the columns length, then the column freezing display might not be useful.
Most settings related to column freezing are represented in FreezePaneSettings object, which is located inside LayoutSettings. You can also configure the MaxFrozenColumns, the splitter's line color and style and much more.
The above image shows a WebGrid with ActiveFrozenColumns property set to 2.

Runtime freezing/unfreezing

WebGrid's LiveFreeze™ feature allows users to perform freezing/unfreezing at runtime through column context menu. When the WebGrid detects an active frozen settings, the Unfreeze Pane command will be enabled. Likewise, the Freeze Pane command will be enabled if the WebGrid does not have an active frozen columns.

The runtime freezing feature can be easily enabled by setting ShowInContextMenu property in FreezePaneSettings object to True.

For example:

HTML Copy Code
<ISWebGrid:WebGrid ID="WebGrid1" runat="server">
   <LayoutSettings AllowColumnFreezing="Yes" AllowColumnMove="Yes">
      <FreezePaneSettings ActiveFrozenColumns="2" MaxFrozenColumns="3" ShowInContextMenu="True" />
   </LayoutSettings>
</ISWebGrid:WebGrid>

The following image shows the result of the above sample in Mozilla Firefox 2.0 browser:

Absolute Scrolling

To better simulate Excel® scrolling behavior while freezing is active, WebGrid.NET Enterprise® 5.0 introduces Absolute Scrolling™ in conjunction with the LiveFreeze™ implementation.

With Absolute Scrolling enabled, WebGrid is able to automatically adjust the viewport to the next available column when user pressed on the left/right arrow of horizontal scrollbar. This behavior allows users to conveniently scroll through all the columns with less clicks.
This feature is controlled through AbsoluteScrolling property in FreezePaneSettings object. To learn more, see How-to: Enable absolute scrolling.

LiveFreeze™ behaviors and other notes

The following is a list of helpful notes related to LiveFreeze™ behaviors when used with other WebGrid's features:

  • Frozen columns are designed for flat-view and can be applied to RootTable only. Child tables are not applicable.
  • Frozen columns are not moveable. This behavior is set automatically.
  • Frozen columns will not appear in Select Columns automatically.
  • Frozen columns cannot be grouped, unless HideColumnsWhenGrouped property is set to False.
  • Frozen columns visibility are locked and cannot be set to hidden. If you would like to enable users to remove the column, unfreeze the column first to remove it from the Grid.
  • Frozen columns cannot work together with ColumnSet layout, since ColumnSet layout does not have suitable display and purpose to be applicable for Column Freezing feature.
  • Column Freezing feature should not be used with AutoFitColumns feature due to purpose's conflict. AutoFitColumns feature purpose is to prevent horizontal scrolling by auto-fitting all columns, while Column Freezing feature requires horizontal scrolling.
  • Column Freezing feature is designed for flat-view Grid. However, you can still enable Hierarchical Grid to be used together with this feature.
  • When Hierarchical is enabled along with Column Freezing feature, horizontal scrolling affects to RootTable view only. The child table will not be scrolled.
    Design Considerations: Enable AutoFitColumns at child table level so that the columns fit into the main Grid's viewport. Arrange the child table layout so they are always inside the Grid's boundary to keep all columns visible.
  • For best performance, limit the RootTable rows to a reasonable maximum number of rows. Enable VirtualLoad paging if needed.
  • If you are displaying large data (e.g. more than 1000 rows) in the WebGrid, it is recommended to set ShowSplitterLine to false for best performance.
  • For best usability, set the MaxFrozenColumns to appropriate value where the frozen columns can be kept visible even in minimum window size.
  • When the frozen pane's width exceeds the visible client area of the WebGrid, the horizontal scrolling will automatically fallback to default scrolling behavior. This means the frozen pane will no longer in effect until the frozen pane's boundary is visible back in the client's viewport. This automatic behavior ensures WebGrid to behave and display properly as users working with information.
  • When column freezing is enabled, the horizontal scrollbar will always appear regardless of the WebGrid's width. This is designed for consistent user interface.
  • When column freezing is enabled, you can still access the client side Columns object model as usual since LiveFreeze™ used a new developed algorithm that does not require changes in core DOM structure.
  • Hidden columns that resulted from the scrolling process will be automatically persisted in FlyPostBack™ (AJAX) actions, except Refresh and RefreshAll action. The hidden columns will not be persisted in full postback event.
  • Column freezing feature can be used together with the following features:
    • Column resize and moving (for non-frozen columns)
    • Grouping
    • Filtering
    • Sorting
    • GroupTotal
    • AllowAdd
    • AllowEditing
    • Keyboard Navigation
    • VirtualLoad™ Paging
    • CellSelect mode
    • EditOnClick mod
    • PreviewRow
  • Extensively supported in Mozilla browsers. Optimized for latest browsers such as Internet Explorer 7.0+ and Mozilla FireFox 2.0+

See Also

WebGrid Features Overview

Getting Started
Getting Started

Other Resources
Walkthrough Topics
How-to Topics


Customizing Default Style

Customizing Default Style
See Also Send Feedback
Intersoft WebGrid > WebGrid Features Overview > Customizing UI > Customizing Default Style

Glossary Item Box

This topic contains the following sections:

  • Introduction
  • Default Style Mode
  • Default Style Merging

Introduction

New in version 5.0 is the default style concept to deliver optimal performance right out-of-the-box.

The default style feature offers the following benefits:

  • Clean control definition during development. This significantly improves loading time in the Visual Studio 2005 designer because unnecessary style objects do not need to be created. For instance, WebGrid version 5.0 only requires the following simple tag.
    HTML Copy Code
    <ISWebGrid:WebGrid ID="WebGrid1" runat="server" UseDefaultStyle="true">
</ISWeGrid:WebGrid>

    In previous version, WebGrid automatically generates a lot of codes containing the styles definition in order for the WebGrid control to display properly.
  • Best performance in server throughput. If your end users are satisfied with the default style of WebGrid, we highly recommend you to use the default style whenever possible. By enabling default style, the server side processing is significantly reduced because there is no need for serializing, validating and parsing the styles and finally generate the styles into css-based classes in the page output.
  • Reduced page output size up to 70 percent. Based on a research, more than 60 percent of web developers do not modify the styles of Intersoft's controls in their web application.

    In previous version of WebGrid, all styles are automatically generated to the page output, regardless whether the style is the one that come with the control or custom style that applied by the developer. So let's say that you have 10 instances of WebGrid that use default style, the control will generate each style of each instance to the page output. This is normal behavior in previous version since there is no mechanism that tell the control whether the defined style is a default style or custom style.

    In version 5.0 with the Default Style feature, WebGrid control no longer produces page-level styles for instances that enable Default Style. This mechanism enables page output reduction up to 70 percent, since styles are no longer produced regardless of the number of WebGrid instances in a page.

The following illustration compares the page output between WebGrid and its predecessors.

Several important things to note around Default Style feature:

  • When Default Style is enabled, WebGrid will include a link to external stylesheet that contains reusable style definition used by the Default Style. This external resource is fetched by using standard WebResource feature, and is automatically handled by WebGrid. There is no efforts required by developers.
  • When Default Style is enabled, all styles definition in the control instance should be removed. You cannot have styles definition and using default style at the same time.
  • Default Style feature is enabled by default for new instance of WebGrid.NET Enterprise 5.0. Existing instances of WebGrid (i.e., after migrated from previous version) will continue to use their existing styles definition.

There are couple ways to enable DefaultStyle of WebGrid:

  1. SmartTag Designer.
  2. Property Set.

For more information, see How-to: Enable Default Style for existing instance of WebGrid.

Default Style Mode

WebGrid 5.0 comes with two default styles as discussed in the following:

  • Standard Style
    This is the classic WebGrid style which has been improved to use more neutral colors. By default, Standard Style is used when the DefaultStyle feature is enabled.
  • Elegant Style
    This is a new style introduced in WebGrid 5.0. Included as DefaultStyle, you can easily change the WebGrid's appearance to use this new style by simply setting the DefaultStyleMode to ElegantStyle.

    The ElegantStyle mode sports modern visual such as glass backgrounds combined with soft blue backgrounds. The new ElegantStyle is designed to deliver visually compelling user interface and better user experience. See the following image for more details.

Default Style Merging

WebGrid 7 introduces Default Style Merging, a new feature that automatically merges your customized styles with default style.

Default Style, a feature introduced in version 5 is designed to let you easily change WebGrid's theme in a single property set. However, you can no longer customize WebGrid styles when you activate this feature without additional workaround. Default Style Merging is designed to address this limitation, makes it easy for you to customize WebGrid styles while preserving the original default styles.

To enable Default Style Merging feature, simply set AllowDefaultStyleMerging property to true. This new property can be found in LayoutSettings object.

For example, the following screenshot shows WebGrid with Elegant default style.

Next, assume you would like to change the font's color to Red, you would have the following style definition in LayoutSettings.

HTML Copy Code
<ISWebGrid:WebGrid...>        <LayoutSettings...>            <HeaderStyle ForeColor="Red" />        </LayoutSettings></ISWebGrid:WebGrid>

The following shows the comparison two different results.

Without Default Style Merging

With Default Style Merging

The header's default style is lost after you defined custom header style.

The header's default style is flawlessly merged with your custom header style.

See Also

WebGrid Features Overview

Getting Started
Getting Started

Other Resources
Walkthrough Topics
How-to Topics
FAQ: What does Default Style look like?


Programming with Client-side API

Programming with Client-side API
See Also Send Feedback
Intersoft WebGrid > WebGrid Features Overview > Programming with Client-side API

Glossary Item Box

The client-side API of WebGrid has been completely redesigned and rewritten to more faithfully adhere to OOP standards. An important part of this process has been to create a consistent, unified API model for both client and server development. This model, now defined as standard in the WebUI Framework, reduces your development time by presenting a consistent set of methods and properties across all controls and tasks. An added benefit is that the new client API performs up to 80% faster than the previous version.

Bridging the gap between client and server, Client Action is a major enhancement to the OnTheFlyPostBack™ architecture. A Client Action object is attached to an individual WebGrid instance, enabling predefined client actions to be executed directly from server code during flypostback. This powerful and easy-to-use feature eliminates a great deal of unnecessary client-side coding. Better still, your applications will be more resilient and more easily debugged since client functions may be invoked directly from server code.

In addition to serving as a solid foundation for Intersoft’s rich suite of components, WebUI Framework tightly integrates into the Microsoft Visual Studio development environment. Among its many Designer features is the Client Event Designer, which increases your productivity by automating tasks commonly required when connecting code to events in Visual Studio.

In some complex scenarios, user might want to customize the element, style or maybe use their own function/method in application. Of course, WebGrid has provided rich Client-side API that makes you to play with client more flexible.

This topic contains the following sections:

  • Understanding Client-side Events
  • Switching to new Client Side-API
  • Extensible Client side API Programming

Understanding Client-side Events

WebGrid provides a set of comprehensive client side API to let developers extend the Grid for their own use. You can access Grid's properties and methods easily with similar server side syntax.

For more information, see Client-side Events.

Switching to new Client Side-API

If you were using our previous WebGrid version (v 4.0 or lower), you have to know that we have many breaking changes from that version until now. Most of the codes in the old version are already obsoleted. Therefore, it is important for you to know about the new Client-side API.

For more information, see Switching to new Client Side-API.

Extensible Client side API Programming

WebGrid provides a set of comprehensive client side API to let developers extend the Grid for their own use. You can access Grid's properties and methods easily with similar server side syntax.

Here is the example on how to collapse child row using client side API:

See Also

WebGrid Features Overview

Getting Started
Getting Started

Other Resources
Walkthrough Topics
How-to Topics


Client-side Events

Client-side Events
See Also Send Feedback
Intersoft WebGrid > WebGrid Features Overview > Programming with Client-side API > Client-side Events

Glossary Item Box

Following is the list of client-side events, which is also accessible from LayoutSettings property.

  • OnAcceptAllChanges
    Specifies the client side (JavaScript) function that will be invoked when accept all changes command is performed.
  • OnActionDispatched
    Specifies the client side (JavaScript) function that will be invoked after an FlyPostBack action is dispacthed during response.
  • OnAddPendingChanges
    Specifies the client side (JavaScript) function that will be invoked when a pending changes is about to be add.
  • OnAfterAdd
    Specifies the client side (JavaScript) function that will be invoked after the new row has been added.
  • OnAfterDelete
    Specifies the client side (JavaScript) function that will be invoked after the delete process is done.
  • OnAfterExitEditMode
    Specifies the client side (JavaScript) function that will be invoked after edit mode has ended successfully.
  • OnAfterInitialize
    Specifies the client side (JavaScript) function that will be invoked when the grid has passed initialization phase.
  • OnAfterPrint
    Specifies the client side (JavaScript) function that will be invoked after the Grid is printed from browser Print menu.
  • OnAfterResponseProcess
    Specifies the client side (JavaScript) function that will be invoked after the response action of a request has been performed.
  • OnAfterUpdate
    Specifies the client side (JavaScript) function that will be invoked after the update process is done.
  • OnBatchUpdateError
    Specifies the client side (JavaScript) function that will be invoked when one or more records are failed to be updated during batch update process
  • OnBatchUpdateSuccess
    Specifies the client side (JavaScript) function that will be invoked when batch update operation has been successfully completed.
  • OnBeforeAdd
    Specifies the client side (JavaScript) function that will be invoked before new row request is invoked..
  • OnBeforeDelete
    Specifies the client side (JavaScript) function that will be invoked before delete request is performed.
  • OnBeforePrint
    Specifies the client side (JavaScript) function that will be invoked before the Grid is printed from browser Print menu.
  • OnBeforeRequest
    Specifies the client side (JavaScript) function that will be invoked when request action to server is about to be made.
  • OnBeforeRowSelect
    Specifies the client side (JavaScript) function that will be invoked before a row is selected.
  • OnBeforeUpdate
    Specifies the client side (JavaScript) function that will be invoked before the update request is invoked.
  • OnBeginRowEditing
    Specifies the client side (JavaScript) function that will be invoked when users edit a row for the first time.
  • OnButtonClick
    Specifies the client side (JavaScript) function that will be invoked when button cell is clicked.
  • OnCalendarSelect
    Specifies the client side (JavaScript) function that will be invoked when selection is made from Calendar popup.
  • OnCancelRowEditing
    Specifies the client side (JavaScript) function that will be invoked when users edit a row for the first time.
  • OnCellClick
    Specifies the client side (JavaScript) function that will be invoked when a cell is clicked.
  • OnCellDblClick
    Specifies the client side (JavaScript) function that will be invoked when a cell is double clicked.
  • OnCellSelect
    Specifies the client side (JavaScript) function that will be invoked when a cell is selected.
  • OnCheckBoxClick
    Specifies the client side (JavaScript) function that will be invoked when checkbox is clicked.
  • OnChildRowCollapse
    Specifies the client side (JavaScript) function that will be invoked when a childRow is being collapsed.
  • OnChildRowExpand
    Specifies the client side (JavaScript) function that will be invoked when a childRow is being expanded.
  • OnColumnAction
    Specifies the client side (JavaScript) function that will be invoked when users click on the column action indicator.
  • OnColumnChanged
    Specifies the client side (JavaScript) function that will be invoked when a column is changed. Columns changed means that it is being removed or added directly from WebGrid client UI.
  • OnColumnContextMenu
    Specifies the client side (JavaScript) function that will be invoked when the column's context menu is about to be display.
  • OnColumnFilter
    Specifies the client side (JavaScript) function that will be invoked when a column is about to be filtered by user.
  • OnColumnGroup
    Specifies the client side (JavaScript) function that will be invoked when a column is about to be grouped by user.
  • OnColumnGroupChange
    Specifies the client side (JavaScript) function that will be invoked when a group column's order is about to be changed by user.
  • OnColumnMove
    Specifies the client side (JavaScript) function that will be invoked when a column is being moved.
  • OnColumnResize
    Specifies the client side (JavaScript) function that will be invoked when a column is being resized.
  • OnColumnSort
    Specifies the client side (JavaScript) function that will be invoked when a column is about to be filtered by user.
  • OnColumnUngroup
    Specifies the client side (JavaScript) function that will be invoked when a column is about to be ungrouped by user.
  • OnCustomAggregate
    Specifies the client side (JavaScript) function that will be invoked when batch update operation has been successfully completed.
  • OnDataBound
    Specifies the client side (JavaScript) function that will be invoked when WebGrid has completed the data binding process in client binding mode.
  • OnDataSourceChanged
    Specifies the client side (JavaScript) function that will be invoked when a new datasource is assigned to WebGrid in client binding mode.
  • OnEditKeyDown
    Specifies the client side (JavaScript) function that will be invoked when keypress is detected during editing mode (edit control is in focus).
  • OnEndRowEditing
    Specifies the client side (JavaScript) function that will be invoked when users ended row editing.
  • OnEnterEditMode
    Specifies the client side (JavaScript) function that will be invoked when edit mode is about to be activated.
  • OnExitEditMode
    Specifies the client side (JavaScript) function that will be invoked when edit mode is being ended.
  • OnExportContextMenu
    Specifies the client side (JavaScript) function that will be invoked when the exporting context menu is about to be display.
  • OnFilterContextMenu
    Specifies the client side (JavaScript) function that will be invoked when the column filter's context menu is about to be display.
  • OnFocus
    Specifies the client side (JavaScript) function that will be invoked when the focus is set to the grid.
  • OnGroupCollapse
    Specifies the client side (JavaScript) function that will be invoked when a group is being collapsed.
  • OnGroupExpand
    Specifies the client side (JavaScript) function that will be invoked when a group is being expanded.
  • OnInitialize
    Specifies the client side (JavaScript) function that will be invoked when the grid is in initialization process.
  • OnInitializeCell
    Specifies the client side (JavaScript) function that will be invoked when a WebGridCell is initialized in client binding mode.
  • OnInitializeCustomEditor
    Specifies the client side (JavaScript) function that will be invoked when a custom editor is about to be initialized.
  • OnInitializeRow
    Specifies the client side (JavaScript) function that will be invoked when a WebGridRow is initialized in client binding mode.
  • OnKeyDown
    Specifies the client side (JavaScript) function that will be invoked when keypress is detected during editing mode (edit control is in focus).
  • OnKeyUp
    Specifies the client side (JavaScript) function that will be invoked after keystroke is made.
  • OnLostFocus
    Specifies the client side (JavaScript) function that will be invoked when the grid lost focus.
  • OnPostRender
    Specifies the client side (JavaScript) function that will be invoked after data rendering has been completed in client binding mode.
  • OnPreRender
    Specifies the client side (JavaScript) function that will be invoked before data rendering phase in client binding mode.
  • OnRemovePendingChanges
    Specifies the client side (JavaScript) function that will be invoked when a pending changes is about to be removed.
  • OnResponse
    Specifies the client side (JavaScript) function that will be invoked when a response from server is returned.
  • OnRowContextMenu
    Specifies the client side (JavaScript) function that will be invoked when row context menu is about to be displayed.
  • OnRowSelect
    Specifies the client side (JavaScript) function that will be invoked when a row is selected.
  • OnRowSelectorClick
    Specifies the client side (JavaScript) function that will be invoked when rowSelector is clicked.
  • OnRowValidate
    Specifies the client side (JavaScript) function that will be invoked when the row is being validated.
  • OnScroll
    Specifies the client side (JavaScript) function that will be invoked when the WebGrid main view is scrolled.
  • OnSelfRefRowCollapse
    Specifies the client side (JavaScript) function that will be invoked when a self referencing row is being collapsed.
  • OnSelfRefRowExpand
    Specifies the client side (JavaScript) function that will be invoked when a self referencing row is being expanded.
  • OnSynchronizeCell
    Specifies the client side (JavaScript) function that will be invoked when a WebGridCell is being synchronized during client side binding.
  • OnSynchronizeChangesUI
    Specifies the client side (JavaScript) function that will be invoked when a pending changes is synchronized to row during UI update.
  • OnSynchronizeRow
    Specifies the client side (JavaScript) function that will be invoked when a WebGridRow is being synchronized during client side binding.
  • OnUndoAllChanges
    Specifies the client side (JavaScript) function that will be invoked when undo all changes command is performed.
  • OnUndoChanges
    Specifies the client side (JavaScript) function that will be invoked when row changes is about to be undo'ed.
  • OnUnhandledError
    Specifies the client side (JavaScript) function that will be invoked when unhandled error occured.

The following code shows how to implement the client-side event in WebGrid.

HTML Copy Code
<ISWebGrid:WebGrid ID="WebGrid1" runat="server" Height="300px" UseDefaultStyle="True"
                Width="100%" DataSourceID="AccessDataSource1">
                <LayoutSettings AllowFilter="Yes">
                    <ClientSideEvents OnAfterAdd="WebGrid1_OnAfterAdd" />
                ...
                </LayoutSettings>
<ISWebGrid:WebGrid>
JavaScript Copy Code
function WebGrid1_OnAfterAdd(controlId, tblName, rowObject, xmlResponseObject)
{
   var WebGrid1 = ISGetObject(controlId);
   alert("Data added");
   return true;
}

See Also

WebGrid Features Overview

Getting Started
Getting Started

Other Resources
Walkthrough Topics
How-to Topics


Programming with Server-side API

Programming with Server-side API
See Also Send Feedback
Intersoft WebGrid > WebGrid Features Overview > Programming with Server-side API

Glossary Item Box

This topic provides an overview of Server-side API in WebGrid.

This topic contains the following sections:

  • Understanding Server-side Events
  • Create WebGrid in Server-side programmatically
  • Working with Client Action
  • ClientAction Engine
  • Preserving checked/selected rows on FlyPostBack actions
  • Preserving expanded child rows

Understanding Server-side Events

WebGrid design is to enable seamless interactions between client and server. In previous version, many tasks become difficult to be implemented because the limitation of the architecture. The new version’s improvements in the core architecture now allow you to perform client tasks easily. There are many events in WebGrid, for example InitializeLayout, InitializeDataSource, PrepareDataBinding, etc. The purpose of this article is to give better explanation about which parts of codes are better placed in certain events and also the sequence of the events when they are executed during the first time the page is loaded.

For more information, see Server-side Events.

Create WebGrid in Server-side programmatically

With the provided server-side events, you can also create WebGrid in server-side programmatically. You can also apply the settings and structure in server-side events.

For more information, please read How-to: Create WebGrid in Server-Side programmatically.

Working with Client Action

ClientAction is another great improvement to the OnTheFlyPostback architecture. This object is attached per grid instance and designed to bridge the gaps between client and server. It enables predefined client actions to be executed directly from server code during OnTheFly Postback, therefore avoiding writing unnecessary client-side codes.

This powerful and easy-to-use feature also allows you to invoke your own client function directly from the server codes, remove many erroneous which is time consuming.

For more information, see ClientAction Engine overview.

ClientAction Engine

ClientAction is another great improvement to the OnTheFly Postback architecture. This object is attached per grid instance and designed to bridge the gaps between client and server. It enables predefined client actions to be executed directly from server code during OnTheFly Postback, therefore avoiding writing unnecessary client-side codes.

This powerful and easy-to-use feature also allows you to invoke your own client function directly from the server codes, remove many erroneous which is time consuming.

There are two types of predefined client actions, one is in global scope, means that it does not require grid's instance, for example, Alert, NavigateTo, OpenWindow and so on. The other is in grid's scope, such as Refresh, SetFocus, SetStatus and so on. These kind of actions can also be applied to different grid instance, for example, you can call WebGrid2.ClientAction.Refresh() while the grid performing OnTheFly Postback is WebGrid1. This capability will enable you to create any types of interactive web applications easier than ever before.

Scenario 1 - Display messagebox to user if UpdateRow can't be done for specific case

C# Copy Code
private void WebGrid1_UpdateRow(object sender, ISNet.WebUI.WebGrid.RowEventArgs e)
{
    if (e.Row.Cells.GetNamedItem("Country").Text == "UK")
    {
        // Display alert to user
        WebGrid1.ClientAction.Alert("You can't update this row!");
        DataRowView drv = (DataRowView)e.Row.DataRow;
        drv.Row.RejectChanges();
        e.ReturnValue = false;
    }
}

In previous version, you could also achieve above scenario but with more codes and efforts. You have to implement OnAfterResponse client side event and write the function to check for many cases in the Onafterresponse event in order to achieve one easy task.

Scenario 2 - Refreshing second grid after invoking send custom request of first grid

C# Copy Code
private void WebGrid1_InitializePostBack(object sender,
ISNet.WebUI.WebGrid.PostbackEventArgs e)
{
    if (e.Action == PostBackAction.Custom)
    {
        // perform business logic here
        WebGrid2.ClientAction.Refresh();
    }
}

As you can see, you only need one code to perform refresh to Grid2. The ClientAction is able to perform "cross-grid" operation like in the above scenario where the grid in context (WebGrid1) is different with grid to refresh (WebGrid2). In previous version, you need to implement wgCustomActionResponse clientside event to parse the Xml result and then call the grid2's refresh client API to perform the refresh. With the ClientAction, wgCustomActionResponse is no longer required although the mechanism is still available to use.

Scenario 3 - Navigate to specific page after record addition

C# Copy Code
private void WebGrid1_AddRow(object sender, ISNet.WebUI.WebGrid.RowEventArgs e)
{
    if (e.Row.Cells.GetNamedItem("Status").Text = "0")
    {
        oleDbDataAdapter1.Update();
        WebGrid1.ClientAction.NavigateTo("StatusForm.aspx?UserId=" +
            e.Row.Cells.GetNamedItem("UserId").Value.ToString());
    }
}

The ClientAction engine is designed to "bridge" client and server interactions to produce transparent and smooth result without having to write codes in client side. The ClientAction works in conjunction with OnTheFly Postback technology

Preserving checked/selected rows on FlyPostBack actions

Now that WebGrid has two ways to allow users to perform multiple row selection. The first is using IsRowChecker feature which is introduced back in WebGrid version 4.0. The latter one is using Multiple Row Selection, which is a new feature in this release.

One important requirement related to the multiple row selection is the ability to persist the checked/selected rows between postbacks and AJAX callbacks (FlyPostBack). This requirement is especially useful when used in conjunction with Classic Paging feature. Users will then be able to check some rows in a page, moving to another page or perform sorting and check some more rows, and finally submit all checked/selected rows to server. The previous version of WebGrid already includes a function called PersistRowChecker to persist checked rows on postback. It is, however, applies only to Full Postback.

New to WebGrid 6.0 in this second 2008 release is the new feature to automatically preserve checked/selected rows on both FullPostBack and FlyPostBack. With this feature, users can now preserve the previously checked rows while performing other actions such as moving to other pages, grouping, sorting, and filtering and so on. Furthermore, WebGrid will mark back the checked rows when it found the previously checked rows in the page. It will also restore the checked selection so that users can easily notice on checked rows.

The checked rows are now automatically restored after FlyPostBack™ actions.

The setting to enable this feature is controlled by RestoreRowSelection property inside the LayoutSettings property of WebGrid. This property has 4 possible values:

  • Disabled
    The default value, which turns off the row selection restoration.

  • RootTableOnly
    Only checked rows in root table will be restored.

  • ChildTableOnly
    Only checked rows in child table will be restored.

  • All
    All checked rows in any table types will be restored.

Preserving expanded child rows

WebGrid 6.0 in this new release includes a nice enhancement to preserve expanded child rows automatically. A new property named RestoreExpandedChildRows is now added to the LayoutSettings.

When enabled, WebGrid automatically tracks the child rows that end users expanded during user interaction. Next, when users performed any FlyPostBack™ actions - such as sorting, refresh, filtering, etc - WebGrid will restore any matching child rows that expanded previously. This long-awaited enhancement is also applicable to any level of nested tables.

To enable this feature, simply set RestoreExpandedChildRows property to true value.

See Also

WebGrid Features Overview

Getting Started
Getting Started

Other Resources
Walkthrough Topics
How-to Topics


Server-side Events

Server-side Events
See Also Send Feedback
Intersoft WebGrid > WebGrid Features Overview > Programming with Server-side API > Server-side Events

Glossary Item Box

WebGrid is implemented with full extensibility and customization as its key design consideration. The WebGrid is specifically designed to be consumed by enterprise web applications that require extensibility to meet complex business requirements.

WebGrid allows you to handle specific events from both client and server side.

Server Events

The following is the list of server-side events:

  • AddRow
  • BatchUpdate
  • ButtonClick
  • ChartImageProcessed
  • ChartImageProcessing
  • CustomAggregate
  • CustomFilter
  • CustomSort
  • DataBinding
  • DeleteRow
  • Disposed
  • Export
  • ExportComplete
  • Init
  • InitializeCell
  • InitializeChildTableDataSource
  • InitializeJsonRow
  • InitializeLayout
  • InitializePostBack
  • InitializeRow
  • InitializeSelfReferenceDataSource
  • InitializeTable
  • Load
  • LoadPreviewRow
  • PreInitialize
  • PrepareDataBinding
  • PrepareExportExecute
  • PreRender
  • RowChanged
  • Unload
  • UpdateRow

For more information and walkthroughs on implementing the server events, see Walkthrough Topics.

Event Sequences of Server-side Events

There are many events in WebGrid, for example InitializeLayout, InitializeDataSource, PrepareDataBinding, etc. The purpose of this article is to give better explanation about which parts of codes are better placed in certain events and also the sequence of the events when they are executed during the first time the page is loaded.

The events sequence ordering in WebGrid are (During Not On The FlyPostBack):

  1. WebGrid_ PreInitialize
  2. WebGrid_Initialize
  3. Page_Load : Event loading of the current page
  4. WebGrid_InitializeLayout : Layout initialization such as assigning static behavior, appearance and styles
  5. WebGrid_InitializeDataSource : Data source initialization
  6. WebGrid_PrepareDataBinding : Column structure retrieval and creation of necessary objects
  7. WebGrid_Load : Indication of successfully preparation of data binding process and data populating in all rows
  8. <<ServerControl Events>> - if Page.IsPostBack: Execution of server control events such as Button1_Click
  9. Page_PreRender
  10. ...
  11. WebGrid_Load
  12. WebGrid_PreRender
  13. ...
  14. Page_SaveViewState
  15. Page_Render
  16. ...
  17. WebGrid_InitializeTable
  18. WebGrid_InitializeColumn
  19. WebGrid_InitializeRow
  20. WebGrid_InitializeCell
  21. ...
  22. WebGrid_Unload

The events sequence ordering in WebGrid are (During On The Fly PostBack):

  1. WebGrid_PreInitialize : Control initialization
  2. WebGrid_Initialize
  3. Page_Load : Event loading of the current page
  4. WebGrid_InitializeLayout : Layout initialization such as assigning static behavior, appearance and styles
  5. WebGrid_InitializeDataSource : Data source initialization
  6. WebGrid_PrepareDataBinding : Column structure retrieval and creation of necessary objects
  7. WebGrid_Load : Indication of successfully preparation of data binding process and data populating in all rows
  8. WebGrid_InitializePostback
  9. WebGrid_Unload

WebGrid_PrepareDataBinding process preceeds the WebGrid_Load process so that all data has been populated and can be accessed further in WebGrid_Load event. WebGrid_PrepareDataBinding process succeeds the WebGrid_Load process and that caused many limitation because certain objects can not be accessed effectively in any of page's events.

In ordinary ASP.NET control lifecycle methodology, the server events are always fired after Page_Load event. The purpose is obviously to allow access to all objects which should have been loaded during Initialization and Load event. The WebGrid now has followed this methodology which can be seen from the current events sequence.

In this topic, certain important events will be explained extensively in order to give a good programming style of where to place certain codes in proper events in WebGrid. The advantage of following this style is to utilize the advantages of WebGrid component extensively such as data caching feature is enabled if the assignment of WebGrid data source is placed in InitializeDataSource event.

  • InitializeDataSource event

All codes related to the assignment of data source to the WebGrid component should be placed here. Since in this event, an instance of DataSourceEventArgs can be obtained, so the assignment code should be :

e.DataSource = DSName; // --> instead of WebGrid1.DataSource = DSName;

Avoid assigning the DataSource property to the Grid object such as WebGrid.DataSource = DSName, since in the InitializeDataSource event, developers could obtain an object of DataSourceEventArgs here using e.

Code that related to the DataTable structure creation, DataSet populating process with the DataAdapter and so many data related task could be processed here. In the conclusion, only data populating related codes should be placed here, no process of assigning WebGrid layout should be placed as depicted from the event name (InitializeDataSource)

What are the differences between DesignTime binding and Runtime Binding? DesignTime binding is used when the DataSource is relatively static and can be obtained at the design time without needing the web application to be run first. In example showing the Customers table in the grid. Runtime binding is a more complex scenario when the DataSource can't be obtained at Design Time and the grid needs to wait for users' selection in order to select which particular data source needs to be binded to the grid. For examples, a dropdownlist will show a list of tables to the users. The grid will be in invisible mode until users select a table from the dropdownlist. In this scenario, obviously it's not possible to bind a certain data source to the grid, so the solution is by waiting for a button_click event (for example) in order to switch the data source.

Since the server control events will be invoked after the grid's events, then developers need to invoke ClearCachedDataSource() along with RebindDataSource() in order to force the grid to invoke the InitializeDataSource event again. Afterward, developers could programmatically switch the data source to be binded to the grid according to users selection.

If the data source can't be decided at page_load then it is necessary to assign null to the grid's data source such as this : grid.DataSource = null; otherwise a classic error message will be produced such as this "Please set WebGrid1's datasource e.g. WebGrid1.DataSource = NorthWindLookups.GetProductList();"

  • PrepareDataBinding event

WebGrid has successfully binded its DataSource which defined using e.DataSource. In this event, developers can conveniently populate all the columns structure. There are many cases that developers often forgot to place all "object creation" codes under !IsPostBack condition, so please remember to place WebGrid1.RetrieveStructure() or WebGrid1.RetrieveHierarchicalStructure() under !IsPostBack condition. There are cases such as users has utilized resizing columns, sorting and grouping features and invoked PostBack to the server, but after the PostBack all the features applied are overrided back to the first configuration erasing all features that have been applied.

When the InitializeDataSource event is invoked and the codes inside the InitializeDataSource event are executed, WebGrid will proceed to invoke the PrepareDataBinding event automatically. If there is no single codes to be executed in the InitializeDataSource, then the grid will simply skip the PrepareDataBinding event.

There are some cases that developers would like to invoke InitializeDataSource event in order to assign a new DataSource to the WebGrid in the certain events such as Button1_Click event. The solution for that case is by simply invoking WebGrid1.ClearCachedDataSource() to remove all cached DataSource and proceed by invoking WebGrid1.RebindDataSource(). Whenever RebindDataSource method is invoked, WebGrid will automatically reinvoke InitializeDataSource event, so the concept of centralized DataSource initialization still persist.

Another issue is about the difference between using old tradition DataBind compared to using RebindDataSource in version 3.5. The data binding process can be processed only once in the internal processing. In order to overcome that limitation, a new method called RebindDataSource is introduced in order to invoke the InitializeDataSource event once again, but it is under one condition that ClearCachedDataSource is invoked first before invoking RebindDataSource, otherwise RebindDataSource will only invoke PrepareDataBinding event because there is a cache maintained inside the WebGrid.

  • InitializeLayout event

InitializeLayout event is originally designed to let developers programmatically configure static WebGrid's behavior, appearance, look and feel, styles etc. It is quite easy to configure the layout by just using e.Layout , since in this event developers could obtained the LayoutSetting properties from LayoutEventArgs. No dynamic objects or data related settings should be placed here especially if those objects are created during runtime.

This event is also an important event in order to modify the grid's layout and styles. All the layout settings could be configured and persisted here while it will be ignored at other events. Pay attention to the events sequences for developers who use Runtime Binding. Since the InitializeLayout event will be called before InitializeDataSource event and PrepareDataBinding event, then it won't be possible for grid to obtain the tables' name and columns' name. Try to reference this : WebGrid1.RootTable.Columns.GetNamedItem("CustomerID").CellStyle.HorizontalAlign = HorizontalAlign.Center, then developers will get the "Object Error", because the tables and columns population are created using either RetrieveStructure() or RetrieveHierarchicalStructure() at PrepareDataBinding. So what's the solution then ?

The solution is by manually configuring the root table and its child tables along with all columns at InitializeLayout event, such as this :

C# Copy Code
protected void WebGrid1_InitializeLayout(object sender, ISNet.WebUI.WebGrid.LayoutEventArgs e)
{
  WebGrid1.RootTable = null;
  WebGrid1.RootTable.Columns.Clear();
  WebGrid1.RootTable.ChildTables.Clear();
  WebGrid1.RootTable.DataMember = "Customers";
  WebGrid1.RootTable.DataKeyField = "CustomerID";
  foreach(string col in UseProfileRoot)
  {
     WebGrid1.RootTable.Columns.Add(new WebGridColumn(col, col, col));
  }

  WebGridTable childTable = new WebGridTable();
  childTable.DataMember = "Orders";
  childTable.DataKeyField = "OrderID";
  foreach(string col in UseProfileChild)
  {
     childTable.Columns.Add(new WebGridColumn(col, col, col));
  }
  WebGrid1.RootTable.ChildTables.Add(childTable);
}

For developers who use Runtime Binding, make sure that the RootTable is null along with its child tables and also all columns, in order to avoid the clash between old data source and the new data source. The sign of conflict can be seen when the project is running and producing "The assign column 'ColumnName' can't be found in the DataSource"

All the events ordering explained above are only applied during the first time the page is loaded and also during "normal" PostBack condition. It is not applied during OnTheFly PostBack. The reason behind that is because WebGrid is developed to avoid duplication calling of those all events. The duplication calling is avoided because the "action" against a request could be only performed after WebGrid_Load event. That is one reason why WebGrid PostBack process is much faster compared to the other conventional server controls.

The following sections explain the comparison between conventional server postback and WebGrid's postback process.

Conventional Server Control PostBack Process

  1. Init
  2. RestoreViewState (All objects are restored in this point which makes the process slow, in example 500 records of rows)
  3. Load
  4. RaisePostBackEvent (All objects are recreated again due to DataBinding process in order to response an action)

WebGrid OnTheFlyPostBack Process

  1. Init
  2. RestoreViewState (Only restore dynamic objects and modified objects, no data population here, so there would be no problem even there are 1000 records)
  3. Load
  4. RaisePostBackEvent (Invoke InitDataSource or obtain from cache if data is cached and call other required events), continue to populate data according to user's action)

As can be seen from the comparison table, RestoreViewState process is extremely fast here (1 point), FlyPostBackHandler will use cached data (AutoDataCache feature - 1 point) and finally all data are populated directly based on user's action (1 point). So in the conclusion WebGrid is 3x times faster compared to conventional server control.

See Also

WebGrid Features Overview

Getting Started
Getting Started

Other Resources
Walkthrough Topics
How-to Topics


Styling

Styling
See Also Send Feedback
Intersoft WebGrid > WebGrid Features Overview > Styling

Glossary Item Box

In addition to displaying rich data with WebGrid, you can also customize the appearance and look of the control. WebGrid allows you to freely customize the user interface elements available in WebGrid.

This topic contains the following sections:

  • Rich Styles
  • Automatic Style Merging

Rich Styles

WebGrid allows you to completely customize its appearance, look and behavior. The core style object is implemented in WebGridFormatStyle class, which contains numerous appearance-related such as BackColor, Font, BorderColor and so on. It is implemented by all UI elements such as Rows and Cells. The WebGridFormatStyle also allows you to put custom CSS Rules with the CustomRules property.

For more information, read Rich Styles Overview.

Automatic Style Merging

One of significant enhancements in WebGrid is extensive styles merging mechanism allowing many combinations of styles to be displayed correctly, such as both style definition and CssClass are taken affect, while only one of them is taken affect in previous version. Other enhancements including:

  • Improved object’s style cascading and inheritance, in conjunction with automatic style merging.
  • New attributes added to WebGridFormatStyle object enabling richer and detailed object model, such as BackColor2, GradientType and BorderSettings.
  • In WebGrid, all styles are automatically merged without any extra works.

For more informations, read Automatic Style Merging Overview.

See Also

WebGrid Features Overview

Getting Started
Getting Started

Other Resources
Walkthrough Topics
How-to Topics


Rich Styles

Rich Styles
See Also Send Feedback
Intersoft WebGrid > WebGrid Features Overview > Styling > Rich Styles

Glossary Item Box

WebGrid allows you to completely customize its appearance, look and behavior. The core style object is implemented in WebGridFormatStyle class, which contains numerous appearance-related such as BackColor, Font, BorderColor and so on. It is implemented by all UI elements such as Rows and Cells. The WebGridFormatStyle also allows you to put custom CSS Rules with the CustomRules property.

WebGrid's UI Elements that support the style customization through WebGridFormatStyle are:

  • AlternatingRowStyle
    To get or set the style that is used to display alternate row.

  • ButtonStyle
    The style of button object of Button Column.

  • CheckedRowStyle
    The style is applied to checked row.

  • EditFocusCellStyle
    The style of the focused cell object.

  • EditTextboxStyle
    The style of the cell object during edit mode.

  • FilterRowStyle
    The style is applied to filter row.

  • FocusCellStyle
    To get or set the style used when a row or cell is focused/selected.

  • FooterStyle
    The style is applied to the column footer.

  • FrameStyle
    To specify the style applied to main WebGrid's frame.

  • GroupRowInfoStyle
    To get or set the style for GroupRow.

  • HeaderStyle
    The style is applied to the column headers.

  • HyperlinkStyle
    The style is used for HyperLink column type.

  • LostFocusRowStyle
    The style is applied to the selected row when the focus is out of the grid's area.

  • NewRowStyle
    The style is applied to new row.

  • PreviewRowStyle
    The style is applied to preview row area.

  • RowHeaderStyle
    The style is applied to row's header.

  • RowStyle
    The style is used to display WebGridRow object.

  • ScrollBarStyle
    The style of the grid's ScrollBar.

  • SelectedRowStyle
    The style is used to highlight selected row or cell.

  • SortedColumnStyle
    The style is applied to the cell which column is sorted.

  • StatusBarCommandStyle
    The normal, hover and active style for the command item in status bar.

  • StatusBarStyle
    The style is applied to the status bar.

All of the styles above are accessible through LayoutSettings property, the centralized repository for all appearance and behavior-related settings. Most of element's styles support property inheritance, in which higher-level object's settings will override all lower-level object's settings which has "default" setting.

The WebGridFormatStyle itself contains numerous appearance-related settings including:

  • BackColor.
  • BackgroundImage.
  • BorderWidth, BorderColor, BorderSize.
  • CustomRules.
  • CssClass.
  • Cursor.
  • Font.
  • ForeColor.
  • Padding, Margin.
  • Height, Width. Note that these properties are not applicable to some UI elements such as CellStyle because those element's height and width are automatically calculated based on Row's height and Column's width to deliver consistent layout.
  • Horizontal Align, Vertical Align.
  • Wrap.

Some UI Elements' styles are defined separately and individually in their specific object holder such as GroupBox and FocusCellStyle, which are also contained in LayoutSettings property. You can also change the images used in WebGrid with your own in ImageSettings, which is also under the LayoutSettings property.

Developers generally have 2 considerations while customizing the styles of WebGrid:

  • Direct styles customization
    This can be done through WebGrid.NET Designer and directly changing the styles in LayoutSettings or individual objects such as Table or Column. You can also apply a predefined layout from Layout Manager .
  • StyleSheet-controlled styles
    It allows you to create a set of styles defined in external StyleSheet and have it linked to the WebGrid. It also enables the web applications to have global theme support for overall WebSite appearance. To use the styles that defined in-line or in external StyleSheet, simply set the CssClass of each element's style. When it is rendered, WebGrid will automatically be displayed using the specified CssClass and corresponded to defined styles.

Property inheritance example:

C# Copy Code
// This setting affects all WebGrid's hierarchy including all tables and columns to allow sorting.
LayoutSettings.AllowSorting = "Yes"
C# Copy Code
// This setting affects all tables to allow sorting, except tblCustomers.
LayoutSettings.AllowSorting = "Yes"
tblCustomers.AllowSorting = "No"
C# Copy Code
// This setting affects all tables and columns to allow sorting, except the the "FirstName" column of tblCustomers.
LayoutSettings.AllowSorting = "Yes"
tblCustomers.Columns.GetNamedItem("FirstName").AllowSorting = "No"

See Also

WebGrid Features Overview

Getting Started
Getting Started

Other Resources
Walkthrough Topics
How-to Topics


Automatic Style Merging

Automatic Style Merging
See Also Send Feedback
Intersoft WebGrid > WebGrid Features Overview > Styling > Automatic Style Merging

Glossary Item Box

One of significant enhancements in WebGrid is extensive styles merging mechanism allowing many combinations of styles to be displayed correctly, such as both style definition and CssClass are taken affect, while only one of them is taken affect in previous version. Other enhancements including:

  • Improved object's style cascading and inheritance, in conjunction with automatic style merging.
  • New attributes added to WebGridFormatStyle object enabling richer and detailed object model, such as BackColor2, GradientType and BorderSettings.

In WebGrid, all styles are automatically merged without any extra works! Example for cell appearance itself, there are 12 levels of styles inheritance in this new version, from Cell's style level, Cell's CssClass then Column's style, Column's CssClas then LayoutSetting's RowStyle and its CssClass. Multiples above with AlternatingRowStyle. And we haven't mentioned how it can combined with SortedColumnStyle, CheckedRowStyle, FormatConditions and more... Conclusively, there are about more than 48 combinations for only cell appearance customization.

Yet, grid's output html is still compact and even more compact than previous version and other grids, as we used advanced class optimizing technique, and NOT embedding styles inline or generate each style for each cell which increase output size to 200%.

For tutorial about Automatic Style merging, please open WebGrid Tutorials Solution file and open AutoStyleMerging.aspx

See Also

WebGrid Features Overview

Getting Started
Getting Started

Other Resources
Walkthrough Topics
How-to Topics


Optimizing Performance

Optimizing Performance
See Also Send Feedback
Intersoft WebGrid > WebGrid Features Overview > Optimizing Performance

Glossary Item Box

Nowadays, developers are required to make their applications as light-weight and faster as possible. This topic explains how to optimize and fine-tune WebGrid to achieve the performance you desired.

This topic contains the following sections:

  • SmartWebResources Deployment
  • Improved Data Caching (for traditional data binding)
  • Enhanced Client-Server Programmability

SmartWebResources Deployment

Oftentimes, developers found it too complex in order to deploy their web application that used third party components. There are too much things that need to be recalled before a web application can be successfully deployed. For an instance, the javascript files, images and other runtime client files need to be copied in order for the component to run properly.

In order to simplify the deployment process, WebGrid provides an advanced deployment infrastructure called SmartWebResources. This enables WebGrid control to function perfectly right out-of-the-box when deployed with a simple XCOPY deployment.

For more information, see SmartWebResources Deployment.

Improved Data Caching (for traditional data binding)

The data caching feature in WebGrid has been significantly improved to avoid memory leaks and lower usage of allocated resources when the DataCacheStorage is set to PageCache (default).

Note that the built-in data caching is disabled by default when the WebGrid is bound to DataSource control. The data caching is provided for the usage when the WebGrid is bound to DataSource object (i.e. through InitializeDataSource event). When bound to DataSource control, the data caching is handled at DataSource control level (through EnableCaching property) and thus no longer need to be handled by WebGrid.

For more information about datasource control support, see Declarative DataSource Control.

Another new feature related to built-in data caching is the ability to store the cache to physical disk. WebGrid now adds a new option in the DataCacheStorage called "FileServer". When you choose this option, the data cache will be stored to the path defined in CacheServerConnection property. This new option allows better scalability and reliability to your web application, as the data caches are no longer stored in ASP.NET's worker process or Session.

New Cache-To-Disk option for ViewStateStorage

In previous version of Framework, we have introduced three kind of storage for saving ViewState. They are PageCache, Session and Client.

In 2007 R2, the Framework now includes new option to save the state to physical disk. The option called FileServer enables the view state to be saved to a physical disk in the local computer or a shared drive in network.

The FileServer cache option solved many barriers around view state topic. With FileServer, you no longer have to worry about memory leaks or limited server resources.

Some of benefits using FileServer cache are:

  • Highly scalable. You can choose a network drive to store the caches which enable multiple web servers to access the state.
  • Decent performance. With more than dozen of high performance hard drives, you can choose a near-memory speed with high random access and sequential read write hard drive to store the caches.
  • Easily extensible. Unlike memory (RAM), you can easily extend hard drives with larger one when it becomes insufficient.

Features of FileServer:

  • Automatic cleaning. When the cache for the viewstate has expired, the caches will be automatically deleted.
  • Easily configurable for application-wide through web.config.
  • Allow customizations on cache policy and expiration duration.

Enhanced Client-Server Programmability

WebGrid's key design is to enable seamless interactions between client and server. In previous version, many tasks become difficult to be implemented because the limitation of the architecture. The new version's improvements in the core architecture now allow you to perform client tasks easily. To give you an idea of what is possible, here we list a few of commonly used tasks:

  • SetFocus can be called from server side to force focus to specify grid at page load.
  • Selected row can now be set from server side through SetSelectedObject method.
  • Selected object's element can now be consistently obtained regardless of whether it is at root or any level of child tables.
  • Added several new client side events, such as OnButtonClick, OnFocus, OnLostFocus and more.

The tutorial for this enhancement can be found in ServerProgrammability.aspx.

Sample code:

C# Copy Code
private void WebGrid1_Load(object sender, System.EventArgs e)
{
    if (!IsPostBack)
    {
        // always select first row on first page load
        WebGrid1.SetSelectedObject(new SelectedObject(WebGrid1.RootTable, 0));

        // set focus to grid
        WebGrid1.SetFocus();

        // in v3.5, this event indicates that the datasource has been populated
        // and rows has been loaded so you can access row's value directly.
        // let's try to change the second row's style.
        WebGrid1.RootTable.Rows[1].Style.BackColor = Color.AliceBlue;

        // access to cell
        WebGrid1.RootTable.Rows[2].Cells[0].Text = "New Text";
    }
}

See Also

WebGrid Features Overview

Getting Started
Getting Started

Other Resources
Walkthrough Topics
How-to Topics


SmartWebResources Deployment

SmartWebResources Deployment
See Also Send Feedback
Intersoft WebGrid > WebGrid Features Overview > Optimizing Performance > SmartWebResources Deployment

Glossary Item Box

Oftentimes, developers found it too complex in order to deploy their web application that used third party components. There are too much things that need to be recalled before a web application can be successfully deployed. For an instance, the javascript files, images and other runtime client files need to be copied in order for the component to run properly.

One of the goal in Intersoft's product platform is to simplify the deployment process required in Intersoft's controls. Our approach is by developing a new infrastructure that handles the storage and retrieval system of these client resources so that physical files can be totally eliminated. This new infrastructure is called SmartWebResources.

WebGrid fully supports SmartWebResources infrastructure. This enables WebGrid control to function perfectly right out-of-the-box after the simple XCOPY deployment. Both developers and site administrators can now deploy Intersoft's components by simply copying the assemblies in the Bin folder of the project - and totally eliminates the need to copy javascript files, component-specific images and runtime files.
As best practice, it is highly recommended to enable SmartWebResources feature for all Intersoft's components especially WebGrid. Furthermore, WebGrid 5.0 exclusively requires WebDesktop's SmartWebResources Assembly in order to use some advanced User Interface features in WebGrid such as the new ContextMenu engine and runtime engines for dialog boxes and windowing system.

To learn how SmartWebResources works, see How does SmartWebResources work.

To learn more about the benefits introduced by SmartWebResources, read Features and benefits introduced by SmartWebResources.

About Localization Files

WebGrid.NET Enterprise includes numerous language files in Xml Format for localization purpose. In previous version, the language files must be located inside IIS directory to be accessible from client.

In version 5.0, language files are included in WebGrid SmartWebResources Assembly. This means the physical language files in IIS directory are no longer required.

If the language file is set to be retrieved from SmartWebResources, you cannot modify or customize the texts (strings) as the files are now embedded inside assembly. If you want to use modified version of language file, then you can switch the language retrieval back to classic physical files retrieval mode. For more information, see How-to: Disable SmartWebResources for Localization's language files.

New SmartWebResources Framework

At Intersoft Solutions, we constantly conduct extensive research and development to deliver new innovations that help developers become more productive by reducing the efforts and overwhelming complexity in both development and deployment stage.

The brand-new SmartWebResources Framework is one of the exciting technology that we had to offer in 2007 R1 platform. The key objective of SmartWebResources is to eliminate the external physical resources (such as scripts, images, etc) which required by web components to function properly.

Problems introduced in traditional web components approach

Most web components require client resources such as scripts, images, stylesheets and other client files to gear up some advanced and powerful features. Normally these client resources are delivered through physical client files. In ASP.NET, these files may be located in aspnet_client folder or other common folder which needs to be mapped properly into IIS virtual path in order to function properly.

There are several issues with this traditional approach which causing inefficiency, such as:

  • Special IIS virtual directory is required to store the client resources. In several webhosting that does not support manual virtual directory setup, this can be a significant deployment problem.
  • Special attention and more efforts are required during deployment.
  • Versioning problems. This could cause overwhelming complexity while maintaining the versions of the client resources for specific components.
  • Complexity in maintaining control-specific's resources folder. For instance, some scripts are located in folder X, images in folder Y, and other scripts in folder Z.

The solution

The solution to the several issues mentioned above can be achieved by eliminating the requirements to use physical client resources. Thanks to the new SmartWebResources Framework, the physical client resources can be completely eliminated.

The client resources are still required in our web components. It is just they are now stored in "virtual location" which does not require the awareness of developers. They are fetched and delivered to client (browsers) in a new, different way.

How does SmartWebResources work

Each product has their own resources such as scripts and images. For instance, previously these resources are stored in /CommonLibrary/Shared for core framework resources. WebGrid's resources are stored in /CommonLibrary/WebGrid/v4_0_6200.

With SmartWebResources, they are now embedded into .NET assembly. Unlike ASP.NET's built-in Web Resources which embeds client resources in main assembly, SmartWebResources stores each product's client resources in separate assembly. This enables flexible update (maintenance) to the client resources without has to rebuild the main server-side assembly.
SmartWebResources implements each product's client resources as separate resources assembly. Each product that supports SmartWebResources technology will have a companion resources assembly. The resources assembly commonly has this format: [ProductAssemblyFullName].Resources.dll.
For instance, the assembly hierarchy for WebCombo.NET 4.0 looks like in the following illustration:

The SmartWebResources works by intercepting the HTTP request through custom HTTP handler that extended in the Framework runtime. The SmartWebResources will then dispatch the request and automatically determining the correct resources assembly, then finally fetching the resource from the assembly and deliver it to the client.
The way it works can be seen in the following illustration:

With SmartWebResources enabled, you no longer need to aware what you should do to configure the client scripts virtual directory, or where to locate/store it. You simply ensure that the resources assemblies are in the Bin folder of your application. For more information, read How-to: Configure SmartWebResources in a new web application.

Features and benefits introduced by SmartWebResources

Here are lists of all features and benefits in SmartWebResources:

  • Better throughput: IIS6 Kernel-level Caching
  • More secure: Does not use query string
  • Faster performance: Does not use Reflection. The SmartWebResources does not use WebResourceAttribute mechanism, so avoiding the needs to use Reflection.
  • Smaller output: Simpler path formatting and does not use long-encrypted string. For instance, the built-in ASP.NET 2.0's Web Resource commonly produced a web resource url such as /WebResource.axd?d=X3DBWN0WSNooBvJskjFXaHbLs_89EdATLyWdaCXXWBuO_EqnAFr_Di1ag4ubAsDdMu4h_k0tff_bX4YhT_csWQ2&t=632939437740000000. In SmartWebResources, the output url format is as simple as /ISRes.axd?C/WebCombo.js/4072001
  • Hassle-free Deployment: No more external client resources are required during deployment. Only one assembly is required to be copied into your app's bin folder.
  • Reduced Complexity: SmartWebResources includes automatic web resources configuration. When in auto mode, the client resources will be retrieved from Web Resources assembly whenever possible. Otherwise, it will automatically fallback the retrieval from traditional external resources which stored in IIS virtual directory (also known as CommonLibrary)
  • Easy to Configure: Easily configure the settings from application level. You can also customize the settings for individual control's instances for more precise control.
  • Flexibility: You can easily switch between SmartWebResources or external resources mode through EnableWebResources setting.
  • Seamless integration with VS 2005: The handlers and resources configuration can seamlessly added to your web application configuration.
  • FileSystem Project Support: For better design-time experience in FileSystem web project, the image resources are now properly displayed in the Visual Studio 2005 designer. Thanks to SmartWebResources Framework that provides automatic url conversion mechanism in design-time.

See Also

WebGrid Features Overview

Getting Started
Getting Started

Other Resources
Walkthrough Topics
How-to Topics
FAQ: Does SmartWebResources feature automatically enabled in WebGrid.NET Enterprise 5.0?
FAQ: Briefly, what are the files included in WebGrid SmartWebResources Assembly?
FAQ: I got a warning message 'ContextMenu is disabled due to missing resources' after page load in the browser. What should I do to resolve this problem?
FAQ: I am aware that WebGrid.NET Enterprise 5.0 requiring WebDesktop SmartWebResources as part of its User Interface engine. Do I need to purchase a separate WebDesktop's license in order to use its SmartWebResources?


Release History

Release History
See Also Send Feedback
Intersoft WebGrid > Release History

Glossary Item Box

This section summarizes features added by the early version of WebGrid. There are some major improvements added to the WebGrid's capability. Now, it is not only more powerful but it is also much easier to use since the client-side API has been reconstructed and added some properties and design-time for common business scenarios. Therefore, you do not need to write long codes anymore.

In This Section

Features Added in WebGrid 8
Information about the features added into WebGrid in version 7

Features Added in WebGrid 7
Information about the features added into WebGrid in version 7

Features Added in WebGrid 6
Information about the features added into WebGrid in version 6

Features Added in WebGrid 5
Information about the features added into WebGrid in version 5

See Also

Other Resources
Learning More
Advanced Topics
Walkthrough Topics
How-to Topics


Features Added in WebGrid 8

Features Added in WebGrid 8
See Also Send Feedback
Intersoft WebGrid > Release History > Features Added in WebGrid 8

Glossary Item Box

Intersoft WebGrid Enterprise gives you most powerful DataGrid component for ASP.NET Web development, with a host of innovative features that allows the control to display large data in highly efficient manner. WebGrid provides comprehensive Grid functionalities enabling enterprise-class information to be delivered in hierarchical layout with sophisticated user interactions, allowing users to work with the information in a more effective and productive way.

In version 8, WebGrid has been refined to fully support the latest web standards. This allows you to use many of the advanced WebGrid features in your next-generation web applications and at the same time leveraging cutting-edge technologies such as HTML5 and CSS3.

The following list details the enhancements and new features introduced in WebGrid 8.

  • Full compliance with HTML5 doc type.

    HTML5 doc type enables consistent results and pixel-perfect rendering across all modern browsers that support HTML5.

    The following features have been enhanced to support HTML5 doc type:
      • Auto Height and Auto Resize
      • Column Freezing and Absolute Scrolling mode
      • Classic Paging
          • Default mode
          • Slider mode
      • Client Binding
          • ADO Data Service
          • WCF Service
          • Paging
          • Virtual Group Paging
      • Pivot Charting
          • Core Layout Rendering
          • Auto Resize
          • Ribbon Bar
          • Drag and Drop
      • Smart Batch Update
          • Core Batch Update Optimization
          • Review Changes Dialog
      • Hierarchical Layout
          • Child Table Rendering
          • TreeLines Rendering
      • Columnset Layout
      • Self-referencing Layout
      • Preview Row Layout
      • Load-on-demand in Preview Row
      • Built-in Calendar Editor
      • Context Menu
      • Custom Editor
          • Numeric UpDown
          • Slider Bar
          • Calculator
          • Vista Calendar
      • Interactivity:
          • Column Sorting
          • Column Filtering
          • Column Drag-drop, Moving and Resizing
          • Checked Rows
          • Expand Child Rows
          • Keyboard Navigation

To learn how to enable HTML5 rendering mode in WebGrid, see How-to: Enable HTML5 Rendering Mode.

  • CSS3 support.

    When the WebGrid control is hosted in pages that use HTML5 doc type, it will automatically enable CSS3 to deliver better visual effects and consistent results across all modern browsers. The CSS3 adoption also increases performance in overall due to the reduced HTML output. This is possible because certain markups are no longer required in the rendering which makes the WebGrid output even more compact, for instances, the drop shadow in the Batch Update Review Dialog now uses CSS3's drop shadow instead of rendering PNG images.
WebGrid 8 continues to support backward compatibility with HTML4 and XHTML doc type. This means that you can upgrade your existing projects to WebGrid 8 without any additional efforts.

For more information about WebGrid's features, see WebGrid Features Overview.

See Also

Other Resources
Release History
Learning More

Getting Started
Getting Started


Features Added in WebGrid 7

Features Added in WebGrid 7
See Also Send Feedback
Intersoft WebGrid > Release History > Features Added in WebGrid 7

Glossary Item Box

WebGrid 7 is the next-generation data visualization component for ASP.NET that revolutionizes data editing experience and improves reliability by addressing performance bottlenecks with a sophisticated client binding implementation.

WebGrid 7 is strongly focused on enterprise data application that takes advantage of new Web technologies such as "cloud" data service and offline-capable editing. This new version includes re-engineered architecture to fully support client data operation, which is the key answer to client-side binding while preserving the compatibilities with existing advanced features.

Intersoft's ClientBinding is the technology behind WebGrid's client binding implementation, which reduces data footprint by over 90 percent and improves overall response time by 10 times. In addition, client binding also introduces numerous benefits. Learn more about Introduction to client-side binding and its Benefits.

One of the key features in ClientBinding is its high-level encapsulation that enables you to easily leverage existing investments of your data service infrastructure. ClientBinding enables you to connect to data service in an elegant way, without requiring you to write Javascript codes. See Elegant Client Binding Architecture to learn how you can quickly getting started with client binding.

Use Component Designer which has been redesigned to help you easily configure client binding settings in WebGrid. With so many features provided by ClientBinding such as data source type, loading mode, transaction support and more, please refer to Client Binding Practices to help you find the best configuration for your client binding implementation.

WebGrid 7 also features SmartBatchUpdate, a new major innovation that takes editing experience to a new level. This new technology enables your end user to make multiple changes to the data in the client side, while at the same time maintaining the changes as they navigate the data around.
Embracing Pending Changes Concept, WebGrid submits all changes to server-side in a single request - making data update fast and efficient. Please see Introducing SmartBatchUpdate™ to learn the fundamental concept of this new feature.

WebGrid 7's batch update also supports advanced data transaction operations such as cascading inserts, Hierarchical Tables Support, Automatic Changes Preservation, New Identity Insert and more. The user interface has also been improved to provide users with intuitive way to review and manage the changes. Learn more about user Rich User Interfaces such as call out notification, changes status and more.

The new technologies in WebGrid 7 are also designed to work in concert with each other, making it the most advanced data visualization and management component for dynamic, Web 2.0-enabled application.

WebGrid Enterprise 7 R2 includes a multitude of refinements in user interface areas - from new Vista-style column action, customizable header context menu, rich text editing integration to engaging UI themes - making WebGrid even more versatile and naturally easier to use.

In This Section

This section describes the new features and technologies introduced in WebGrid 7. Here are the following list of new features supported by WebGrid 7:

Data editing with new Batch Update mode

Introducing SmartBatchUpdate, pending changes concept, streamlined editing process and many others.

Client-side data binding

Discuss about WebGrid's approach to client data binding, its new technologies and benefits, and how it resolves performance bottleneck without trading-off fundamental features.

Elegant Client Binding Architecture

Discuss about WebGrid's client binding technology such as Client Data Object Framework, data loading mode, transaction and batch update support.

Client Data Source and Data Service

This section explains the client data source implemented in ClientBinding.

Client Binding Consideration and Best Practices

This section discusses the consideration for using client binding mode in your application, along with best practices for several common scenarios.

Client Binding API

This section explains the new public methods and events which are available when client binding mode is enabled and the data source type is set to either client services or client data source.

New Visual UI Theme

WebGrid introduces its latest three new dazzling visual themes, which are Windows 7, Glassy Black and Metallic Silver.

Column Action

WebGrid provides a new user interface feature to display contextual column actions through a visual hint.

Custom Editors Pack 3

WebGrid introduces Vista-style calendar and WebTextEditor custom editor in this pack.

Improved Designer

WebGrid improves its designer to work better with the new features.

Context Menu Customization

WebGrid supports customization on all context menu elements such as header context menu and exporting context menu.

New Client Events

WebGrid introduces numerous client side events to provide more extensibility.

Advanced Column Filter

WebGrid introduces an advanced column filter that enables developers to write their own expressions per column.

XHTML Support

WebGrid now supports the latest web Standards such as XHTML and HTML5.

Enhancements

Provides a comprehensive overview about the enhancements introduced in WebGrid 7.

See Also

Getting Started
Getting Started

Overview
WebGrid Features Overview
Release History

Other Resources
Walkthrough Topics
How-to Topics


Features Added in WebGrid 6

Features Added in WebGrid 6
See Also Send Feedback
Intersoft WebGrid > Release History > Features Added in WebGrid 6

Glossary Item Box

WebGrid extends its version 6 with new features, improvements to existing features, and enhancements to the documentation. This section provides information about the key additions and modifications.

In This Section

Classic Paging

WebGrid comes with the new classic paging in addition to support the VirtualLoad paging mode.

Pivot Charting

WebGrid introduces a new built-in feature called pivot charting. It transforms raw data from the Grid view into a Chart view.

Enabling add, edit and delete in WebGrid using AccessDataSource control

WebGrid enhances its feature by allowing user to perform adding, editing and deleting data in WebGrid using AccessDataSource control, where one of the columns data type is AutoNumber.

Customizing UI

WebGrid now fully implements the support for Section 508 Standards and accessibility.

Automatic Group Total Update

WebGrid introduces grouping with built-in aggregation.

Preventing new row with default values to be marked as edit

WebGrid provides a built-in feature that allows developers to specify the default value displayed when user type in the NewRow area.

WebCombo.NET as FilterEditType

WebGrid provides strong integration with WebCombo. Now, WebCombo can be used as editing type in the WebGrid as well as filter editing type.

Multiple Row Selection

WebGrid adds new feature that allows user to select multiple rows using checkbox.

Preserving checked/selected rows on FlyPostBack™ actions

WebGrid now able to persist the checked/selected rows between postbacks and AJAX callbacks (FlyPostBack).

New 'ButtonImage' Column type

WebGrid now includes a new ButtonImage column type for displaying button with image.

Option to turn off animation in context menu

WebGrid simply adds a new feature to its rich user interaction, which is the ability to turn off the context menu's animation.

Preserving expanded child rows

WebGrid includes an enhancement to preserver expanded child rows automatically.

See Also

Getting Started
Getting Started

Overview
WebGrid Features Overview
Release History

Other Resources
Walkthrough Topics
How-to Topics


Features Added in WebGrid 5

Features Added in WebGrid 5
See Also Send Feedback
Intersoft WebGrid > Release History > Features Added in WebGrid 5

Glossary Item Box

WebGrid extends its version 5 with new features, improvements to existing features, and enhancements to the documentation. This section provides information about the key additions and modifications.

In This Section

Codeless data binding through DataSourceControl support

WebGrid provides the new and codeless data binding experience, means that you are not required to write any codes to configure DataSource, connection and related properties.

Codeless Hierarchical data binding

WebGrid has been enhanced to let user implementing hierarchical data binding without writing any codes. You can quickly configure the WebGrid by simply using drag, drop and click.

Codeless WebValueList data binding

In addition to binding the Grid to DataSource control for its main data, WebGrid also enables you to bind a column's value list to DataSource control. This feature completely removes the needs to write codes in the Grid control and allow you to declaratively specify the DataSource control and DataMember for the value list.

Design-time support for DataSourceControl

WebGrid boost developer's productivity by introducing various ways to connect to a DataSource control in design-time through rich designers and wizards.

New user interface with new styles

WebGrid comes with new user interface such as new icon-sets, new context menu engine and styles, as well as new "Elegant" style.

Column Freezing

WebGrid is the industry's first WebGrid that successfully implementing Microsoft Excel® style column freezing feature.

Customizing default style

New in version 5.0 is the default style concept that will completely boost up the performance and improve the loading time.

Hassle-free deployment through SmartWebResources™ technology

WebGrid introduces SmartWebResources™ which is designed to simplify the deployment process. No more copying javascript, component images and runtime files. You can simply copy the assemblies to the bin folder.

Verbose editing InfoText

One of the most significant enhancements in WebGrid is the new verbose information text in editing mode. This feature is useful to deliver intuitive editing experience for users as they can notice on important information related to a specific column in status bar area.

Automatic Filter suggestion

This new feature enables users to easily perform data filtering based on the currently selected cell.

Filter Status Indicator

Filter Status Indicator is a new user interface element which appears in the status bar. The filter indicator is useful to represent the current state of data when filter bar is not visible.

Unbound Hierarchical

Previously, WebGrid only supports databound mode to be applied in hierarchical feature. Now, WebGrid allows you to configure Hierarchical child tables in unbound mode.

Loading preview on demand

You can configure WebGrid to skip preview row rendering in first load to reduce initial page output size.

Displaying aggregate values in GroupHeader

With the new feature to display basic aggregate functions in group header, you can display the calculated values without enabling the GroupTotal feature.

Multiple values support in WebValueList

WebGrid includes enhancement in WebValueList feature to support multiple values data.

Multiple values editing using WebCombo.NET 4.0

WebGrid also includes the ability to edit the multiple values data that translated using the WebValueList.

Automatic column sorting using WebValueList

The column sorting and grouping can now take advantage of the same DataSource that populated in the WebValueList. With this enhanced WebValueList, you no longer have to manually retrieve the text field of the value column in the WebGrid's main DataSource.

Built-in cell validation through new required input

WebGrid now provides built-in feature for required input during data editing and makes data validation a snap.

New Edit Type "Resizable TextBox"

WebGrid introduces a new edit type, that is resizable text box edit control. With this new feature, user can easily resize the text box by dragging the resize handler at the bottom right position.

Improved Data Caching (for traditional data binding)

The data caching feature in version 5 has been significantly improved to avoid memory leaks and lower usage of allocated resources when the DataCacheStorage is set to PageCache (default).

Templated Cell

Another interesting new feature in WebGrid is its ability to add ASP.NET server controls to the WebGridCell using the new Template Column Type.

WebGrid.NET Component Designer 2.0

WebGrid introduces a new level of rich component designer to help developer easily configure the advanced settings in WebGrid.

Enhancements

Enhancement applied on WebGrid 5.

See Also

Getting Started
Getting Started

Overview
WebGrid Features Overview
Release History

Other Resources
Walkthrough Topics
How-to Topics


Improved Designer

Improved Designer
See Also Send Feedback

Glossary Item Box

In addition to the impressive UI themes and other new runtime features, WebGrid 7 also improves its Designer to make it even easier to work with the new features.

Styles Selection

Easily select a style with the revamped Styles Designer. The Styles Designer now displays all available styles in visually appealing interface.

Improves Styles Selection Interface.

Custom Editor Selection

Along with new Custom Editors Pack 3, the WebGrid Designer has also been improved to let you easily select the custom editor from the available list. When server-side editor type is selected, the designer will automatically show all available controls having the same type of the required custom editor.

The intuitive designer lets you choose an editor with a simple point-and-click.

See Also

Other Resources
New Visual UI Themes
Column Action
Custom Editors Pack 3
Context Menu Customization
Advanced Column Filter
XHTML Support
New Client Events


New Client Events

New Client Events
See Also Send Feedback

Glossary Item Box

Numerous client-side events are introduced in this release to more extensibility and greater control over WebGrid's functions and behaviors.

The new client side events are:

  • OnInitializeCustomEditor
    Specifies the client side (JavaScript) function that will be invoked when a custom editor is about to be initialized.
    Parameters: controlId, editorName, editorObject, customEditor

  • OnColumnContextMenu
    Specifies the client side (JavaScript) function that will be invoked when the column's context menu is about to be displayed.
    Parameters: controlId, col, menu, isGroup, location

  • OnExportContextMenu
    Specifies the client side (JavaScript) function that will be invoked when the exporting context menu is about to be displayed.
    Parameters: controlId, table, menu, location

  • OnBatchUpdateError
    Specifies the client side (JavaScript) function that will be invoked when one or more records are failed to be updated during batch update process.
    Parameters: controlId, errorXml

  • OnColumnAction
    Specifies the client side (JavaScript) function that will be invoked when users click on the column action indicator.
    Parameters: controlId, column

  • OnAfterExitEditMode. The parameters are controlId, tableName, editObject.
    This event is invoked after user exits cell-level editing. Unlike OnExitEditMode event, OnAfterExitEditMode is fired after default editing process is completed, making it possible for you to inspect the new cell values and perform custom logic.

  • OnBeginRowEditing. The parameters are controlId, row.
    This event is invoked when user begins to edit a row. Unlike OnEnterEditMode, this event is fired only one-time when a row is about to be edited. Furthermore, this event is applicable on row-level instead of cell-level.

  • OnEndRowEditing. The parameters are controlId, row.
    This event is invoked when user ended row editing completely. Similar to OnBeginRowEditing, this event is applied on row-level, and is called only one-time when user ended row editing. This event is fired after OnExitEditMode and before OnRowValidate.

  • OnCancelRowEditing. The parameters are controlId, row.
    This event is invoked when user canceled row editing. This new client side event enables you to process custom logic when user canceled the editing. For example, you may want to validate if the cancelation has met specific condition before the cancelation is allowed to be processed further.

See Also

Overview
Client-side Events


Enhancements

Enhancements
See Also Send Feedback

Glossary Item Box

In addition to major new features such as described in above topics, WebGrid Enterprise™ 7 also includes enhancements to various areas based on customer feedback. These enhancements are designed to help you achieving complex scenarios in professional approach.

Improved User Interface

WebGrid 7.0 improves various user interface factors, making it more intuitive for end user to work with information.

  • For more information, see Improved User Interface.

New client side events for inline editing

WebGrid 7 enables developers to have greater control and customizability over the editing process by introducing four new client side events.

  • For more information, see New client side events for inline editing.

Enhanced integration with WebCombo

WebGrid enhances the WebCombo integration further in various scenarios such as when used in Custom and Image column type.

  • For more information, see Enhanced integration with WebCombo.

Default Style Merging

WebGrid Enterprise™ 7 introduces Default Style Merging, a new feature that automatically merges your customized styles with default style.

  • For more information, see Default Style Merging.

See Also

Other Resources
Walkthrough Topics
How-to Topics


WebCombo.NET as FilterEditType

WebCombo.NET as FilterEditType
See Also Send Feedback

Glossary Item Box

WebGrid provides strong integration with other Intersoft products, such as ability to use WebCombo.NET as the editing type in the WebGrid. In addition, these integration features are applicable to filter editing type as well.

New in this version is the ability to specify WebCombo.NET as the FilterEditType individually. Previously you can only use WebCombo.NET as FilterEditType when the EditType is using WebCombo.NET. This introduces limitation when EditType is set to NoEdit.

With this enhancement in this new version, you can now set EditType to any editing type, and still be able to set FilterEditType to WebCombo.NET specifically.

How-To Topics

How-to: Use WebCombo as Filter Editing Control

See Also

Other Resources
Edit Types


Design-time support for DataSourceControl

Design-time support for DataSourceControl
See Also Send Feedback

Glossary Item Box

WebGrid.NET Enterprise 5.0 boosts developer's productivity by introducing various ways to connect to a DataSource control in design-time through rich designers and wizards.'

SmartTag Action Panel

The easiest way to start with data binding is through SmartTag Action Panel. By default, when you drop a new instance of WebGrid to designer, the SmartTag will appear automatically as shown in the following image.

The Choose Data Source dropdown enables you to quickly connect to a DataSource control available in the web page. The dropdown will list all valid DataSource controls. You can also click on <New data source...> item to create a new DataSource control from scratch. This feature is reflected directly to DataSourceControlID property of WebGrid.

When connected to a DataSource control that supports multiple views such as in ISDataSource control, the View Names dropdown will list available views defined in the specified DataSource control such as shown in above image. This feature is reflected directly to DataMember property of WebGrid.

Retrieve Structure and Hierarchical Structure Context Command

When you have modification to DataSource schema which is already assigned to WebGrid, you do not need to change the DataSourceControlID or DataMember property. Instead, you can simply re-retrieve the schema (structure) by using the commands in control's context menu. Refer to the following image for details.

Note that if the existing WebGrid already has structures defined such as Columns, GroupColumn, SortColumns etc - the Retrieve Structure and Retrieve Hierarchical Structure will override existing structure with new schema defined in the DataSource control.

Flat table DataSource control

When the WebGrid is connected to flat DataSource control, such as AccessDataSource or SqlDataSource control, the WebGrid DataSource Connect wizard dialog box will appear, such as illustrated in the following image.

The DataSource connection wizard integrates deeply with Visual Studio 2005® to provide rich design-time experience, such as automatic DataSource detection when the DataSourceID property has changed. The wizard also has the ability to retrieve the DataSource schema available in the DataSource control.
As seen in above image, the view names dropdown list and retrieve hierarchical structure option are automatically disabled. In flat-view DataSource control, the DataMember does not need to be set as the DataSource control should contain only 1 table view. The flat table view is also called as DefaultView data member.

XML DataSource control

WebGrid V5.0 exclusively supports XmlDataSource control and display the XML data as hierarchical Grid to simulate TreeView. For more information about XmlDataSource control support in WebGrid V5.0, see Advanced DataSourceControl support.

When connected to an XMLDataSource control in design-time through either SmartTag Action Panel or Property Window, the XMLDataSource Connect wizard will be displayed as shown in following image.

The XmlDataSource Connect wizard has two primary features:

  • Auto retrieve schema.
    WebGrid simulates the TreeView display by using its Hierarchical and ChildTables feature. This option allows WebGrid to inspect the XmlDataSource schema, read and translate it to nested ChildTables in WebGrid control.

    It is recommended to check this option as default.
  • Auto configure as TreeView.
    WebGrid provides many settings and flexibility to customize appearance. With this option checked, WebGrid automatically configures its appearance so it looks like a TreeView control.

Several notes related to XmlDataSource control support:

  • The TreeView support in WebGrid V5.0 is provided as basic complimentary feature to DataSource control only. It is not intended to be as used as TreeView's replacement. For more advanced TreeView-specific functions, please use Intersoft's WebTreeView for ASP.NET 2.0 instead.
  • WebGrid simulates the TreeView support by loading all XML Data at first load. In this case, all Tree nodes are rendered at once in first request and no load-on-demand is necessary. Simply put, the WebGrid is working as Unbound mode.
  • With its Unbound mode behavior limitation, data-related features - such as Sorting, Filtering, Paging, Editing and others - are not supported and should be disabled. However, Grouping is exclusively supported, and can be enabled.
  • WebGrid is treating each XmlAttribute of a Node as Column. The auto-generated schema always assumes first attribute to be used as display text in the Tree. To change the column to be used as display text, simply moves the designated column to first column and sets its Visible property to True. Other columns Visible should be set to False. You may also want to set the first column's width to 100% to properly simulate TreeView display.

Hierarchical DataSource control

Similar to flat-view DataSource control and XMLDataSource control, WebGrid automatically displays DataSource Connect wizard when a valid multi-view (hierarchical) DataSource control is assigned to WebGrid.

The following image shows the wizard for Hierarchical DataSource control connection.

When connected to a valid hierarchical DataSource control, WebGrid allows you to perform the following actions in designer:

  • Select a view available in the View Names dropdown as WebGrid's RootTable. The selection of the view in RootTable determines and affects the hierarchical child tables that will be automatically retrieved.
  • Retrieve hierarchical structure. This option is enabled when WebGrid detects a valid hierarchical DataSource control being assigned. When selected, WebGrid automatically retrieves the child tables based on the relationship definition that specified in the associated dataset. The child table retrieval starts from the table view that assigned as RootTable (see option 1 above).
In order for Retrieve Hierarchical Structure to work successfully, ensure you have defined the table's relationship properly using DataSet Designer.

See Also

Other Resources
Walkthrough Topics
How-to Topics


WebGrid.NET Component Designer 2.0

WebGrid.NET Component Designer 2.0
See Also Send Feedback

Glossary Item Box

WebGrid.NET Enterprise 5.0 takes web development to a new level by introducing rich component designer to help developers easily configure the powerful and advanced settings available in WebGrid.

Based on Intersoft's state-of-the-art Component Designer 2.0 architecture, WebGrid.NET Enterprise 5.0 Designer is a highly advanced component editor delivering unmatched ease-of-use and streamlined user interface.

WebGrid.NET Enterprise® 5.0 Designer comes with 5 main tab-style interfaces such as shown in the following screenshot.

The main user interface of WebGrid Designer in version 5.0

Quick Start

The quick start page is the main access point of most popular settings to help you quickly getting started with WebGrid. By default, the quick start page is displayed automatically when launched from design surface.

The quick start page consists of 8 sub pages. The Data Source sub page is automatically displayed when the WebGrid does not have binding configuration yet. The Popular Settings sub page will be displayed when the WebGrid already has a valid binding configuration. This allows you to concentrate on WebGrid's customization based on its current state.

The new expandable and collapsible user interface allows you to quickly locate a feature. Most settings are presented in check box and radio selection interface which are designed to help you instantly enable or disable, or modify a feature with one mouse click.

The following image shows the screenshot of Popular Settings in Quick Start page.

Advanced

The Advanced page gives you complete control over the WebGrid configuration and its tables structure. While most main features can be easily enabled in Quick Start page, some advanced features such as column set display, self referencing, or other table-level settings can only be configured in Advanced page.

Combining the state-of-the-art Component Designer with streamlined user interface concept in WebGrid.NET Enterprise 5.0, the Advanced page also displays rich designer for several main objects such as WebGridTable and WebGridColumn. This results in sophisticated designer experience and dramatically increasing developer's productivity.

With rich designer, you can now easily modify advanced configuration. For instance, you can launch ColumnSet Wizard by clicking on Design ColumnSet button in this screen, instead of having to set related settings in several locations.

The following image shows the screenshot of Advanced page, while focused at a WebGridTable.

Thanks to the rock-solid Component Designer architecture that made rich designer experience possible, you can now instantly select an editing control for the selected column by simply clicking on the visual clue. No more tedious steps and lengthy procedure to use a custom editor such as Calculator or Html Editor.

The following image shows the screenshot of Advanced page, while focused at a WebGridColumn.

The following image shows the screenshot of Advanced page, when See all properties link is clicked. For advanced developer who preferred to browse all properties, here is the mode for you.

Layout Manager

The Layout Manager feature has been introduced since previous version of WebGrid.NET Enterprise. The feature was previously implemented in WebUI.NET Framework as part of Component Designer 1.0. Layout Manager is a powerful feature to let you easily apply from a predefined style as well as save your own style and reuse it later.

The Layout Manager in second generation of Component Designer has been much improved in many areas. It now has cleaner look and uncluttered user interface to bring you larger space for the preview.
You can easily preview a style before decide to apply it by simply clicking on Preview command. The preview is performed in real time and is showing the exact visual appearances as in runtime.
The following screenshot shows the new Layout Manager in Component Designer 2.0.

For more information, see:

Apply predefined Layout

Save current Layout

Apply saved Layout

Preview Layout

Structure Manager

Structure Manager is a new feature in WebGrid.NET Enterprise 5.0. This feature enables you to save the structure of an existing WebGrid in design-time. The structure includes table configuration such as columns, grouped columns, filtered columns as well as child tables.

Structure Manager allows you to preview an existing structure before you choose to apply it. This feature increases productivity by enabling developers to reuse a complex structure in multiple instances or projects.

With this feature, you can easily reuse a WebGrid's structure by applying the saved configuration in Structure Manager.

The following image demonstrates Structure Manager page in action.

Localization Manager

Localization Manager is a feature to help you configuring the language settings in WebGrid. In this new version, Localization Manager has been much improved with the adoption of clean and uncluttered user interface which results in better development experience and easier to use.

The improved Localization Manager also incorporates the new SmartWebResources™ feature in its user interface so that you can effortlessly configure resources and related language settings in one streamlined user interface.
Note that when the language resources are retrieved from SmartWebResources™, the WebGrid requires the main SmartWebResources™ setting to be enabled. This is the recommended setting in WebGrid.NET Enterprise 5.0 as well as other 2007 platform products. To learn more about SmartWebResources™ feature, see SmartWebResources Deployment.
The following image shows the main user interface of Localization Manager.

If you would like to use modified language file, or your own language file which is not shipped along with WebGrid, you need to use Physical Client Resources mode so that your language file can be retrieved through classic web client url.
When you used Physical Client Resources mode, you can manage the language list from the user interface. You can also customize the text entry in the Manage Language Files sub page.
The Manage Language Files feature lets you add or remove a language file, or customize the existing language file with your own customized text entry.
The following image shows the Localization Manager with Manage Language Files sub page activated.

For more information, see:

Choose Language

Manage Language Files

Assign Localized Text

See Also

Other Resources
Walkthrough Topics
How-to Topics


Enhancements

Enhancements
See Also Send Feedback

Glossary Item Box

In addition to dozens of exciting new features introduced in version 5.0, WebGrid also includes enhancements to performance, server side and client side object model and several important areas such as discussed in following sub topics.

Server-side object model

Most significantly enhanced server-side object model in version 5.0 is related to new classes constructors and overloads for commonly used classes. For instance, you can now create several cells and rows in one line of code, and add them at once using AddRange method of the collection.

Sample codes in C#:

C# Copy Code
WebGridRow[] rootRows = new WebGridRow[6];

for (int i = 0; i < 6; i++)
     rootRows[i] = WebGrid1.RootTable.CreateRow();

rootRows[0].Cells.SetItemData(new string[] { "172-32-1176", "White", "Johnson" });
rootRows[1].Cells.SetItemData(new string[] { "213-46-8915", "Green", "Marjorie" });
rootRows[2].Cells.SetItemData(new string[] { "238-95-7766", "Carson", "Cheryl" });
rootRows[3].Cells.SetItemData(new string[] { "267-41-2394", "O'Leary", "Michael" });
rootRows[4].Cells.SetItemData(new string[] { "274-80-9391", "Straight", "Dean" });
rootRows[5].Cells.SetItemData(new string[] { "341-22-1782", "Smith", "Meander" });

WebGrid1.RootTable.Rows.AddRange(rootRows);

In above sample, the CreateRow is a new method of WebGridTable class which creates and initializes WebGridCell according to the columns and structures available in WebGridTable. The SetItemData method allows you to easily set an array of string which will be mapped to the cells in WebGridCellCollection respectively. The AddRange method finally perform the addition of the WebGridRow arrays to the WebGridTable.
In previous version, the same sample could take 2-3 times more codes compared to above codes. The enhanced server side object model in version 5.0 enables developers to access and manipulate the WebGrid control in less efforts and codes.

Client-side object model

New methods and objects have been added to client-side object model in version 5.0 to reflect new API that added to server side. The following is the details of newly added objects and methods:

  • API performance is now faster up to 80% compared to previous version. Check out Sample: High Performance Client-side API.

Client events and user interaction

  • Added OnScroll event to client side event.
  • Added OnAfterInitialize event to client side event.
  • Ability to navigate through different groups using the Tab key.

Exporting

  • Added OutputType property to ReportInfo. The temporary report file name format is now set to use Guid by default. In previous version, the default value is ExecutionTime.
  • Exporting is now working properly without default printer installed. The error message like "Printer not Installed" or "PaperKind does not supported" has been completely eliminated.
  • Reduced memory usage and fixed leaks.
  • Core engine has been rewritten for better performance.
  • Added CacheToDisk property to ReportInfo. This feature allows the exporting to write temporary cache to disk instead of using memory.
  • Added CacheToDiskLocation property to ReportInfo. You can customize the folder to store the cache. By default, you do not have to set this property.
  • Improved exporting menu. The export types are now represented with icons.
  • Added exporting command to row/cell context menu. This allows you to easily perform exporting from your current mouse position in the Grid.

User Interface

  • Unhandled server exception's error box can now be skipped. By setting DisplayDetailsOnUnhandledError property to False, the error box will not be displayed immediately. Instead, the error indicator will appear in the status bar. You can then click on the status bar to display the error detail message box.
  • Pixel-perfect rendering for Mozilla-based browsers. In version 5.0, the box dimensions for cell, row and other user interface has the equal layout as displayed in Internet Explorer.
  • New RowHighlightType property. The BackgroundOnly option allows WebGrid to redraw only the background color for selected row.
  • To learn more new features related to User Interface, see Rich User Interface Elements.

Core engine on output optimization

  • Reduced output size up to 60%.
  • When culture is set to default (en-US), the XML data for culture info is no longer generated in the webpage.
  • When default style is enabled, in-line styles are no longer generated in the webpage. Instead, all WebGrid instances in the same webpage will share the same external stylesheet which significantly reducing output size.

Hierarchical

One of the new enhancements in this feature is that WebGrid now fully supports hierarchical data binding in unbound mode.

  • Supports child row preloading.
  • Supports true unbound mode through server-side object model.

Editing

The editing performance has been enhanced in the latest WebGrid's version, such as HtmlEditor supports Mozilla and SmartWebResources.

  • PromptBeforeDelete property is now affected when user tries to delete a row from context menu. In previous version, PromptBeforeDelete only works when user press Delete key to delete a row.
  • HtmlEditor Editing Control now supports SmartWebResources. This allows you to use HtmlEditor without has to worry about client images, scripts and the popups required by the editing control.
  • HtmlEditor Editing Control now supports Mozilla-based browsers.
  • Calculator Editing Control now supports Mozilla-based browsers.

Filtering

In WebGrid V5.0, Filter types are now displayed based on column's data type.

  • Filter types now displayed based on column's data type. Unrelated filters will be automatically removed from the list. This enhancement is automatic and does not need further configuration.
  • Special date range filters. When AutoFilterSuggestion is set to true, user can choice wider selection of date range filters in the column's or cell's context menu. The special date range filters are like Today, Tomorrow, Yesterday, Next Week, Next Month and so on.
  • Added "Contains" and "Does Not Contain" as new filter types for string data type.

Context Menu

Context menu comes up with a new runtime engine, which is now based on Intersoft's Hybrid Menu Runtime System™. Hence, the performance is faster and it has a better stability.

  • Runtime engine is now based on Intersoft's Hybrid Menu Runtime System™. The Hybrid Menu Runtime System is the core menu engine used in WebMenu component, as part of WebDesktop.
  • As the result of new runtime engine, the display performance is significantly faster and has better stability. The context menu now has pixel-perfect layout between Internet Explorer and Mozilla-based browsers.
  • New context menu styles and appearance with new icon-sets.
  • Comprehensive menu commands on column and row level context menu.
  • Commands are improved in most areas of feature that depend on Context Menu, such as in Exporting feature and so on.

Self Reference

One of the ability of enhanced grid's self reference is to select the child row of a specified parent row from server side.

  • Ability to select the child row of a specified parent row in Self Reference Grid from server side.

    Sample C# codes:

    protected void WebGrid1_InitializeRow(object sender, ISNet.WebUI.WebGrid.RowEventArgs e)
    {
    if (e.Row.Cells.GetNamedItem("FirstName").Text == "Andrew")
    {
    e.Row.ExpandSelfRefRow();
    }
    else if (e.Row.Cells.GetNamedItem("FirstName").Text == "Janet")
    {
    e.Row.Selected = true;
    WebGrid1.SetFocus();
    }
    }

    To learn more, refer to WebGrid V5.0 Tutorial > SelectSelfRefChildRow.aspx.

  • Ability to get the self reference child rows of a specified parent row in client side.

Sample codes in JavaScript:

function GetChildRows()
{
var grid = ISGetObject("WebGrid1");
var selObj = grid.GetSelectedObject();

if (selObj != null)
{
var row = selObj.GetRowObject();
var srChildRows = row.GetSelfRefChildRows();

if (srChildRows.length > 0)
{
var firstChild = srChildRows[0];

alert("Total child rows: " + srChildRows.length + "\n" + "First child row's FirstName Text: " + firstChild.GetCell("FirstName").Text);
}
else
alert("There are no child rows for this parent.");
}
}

To learn more, refer to WebGrid V5.0 Tutorial > GetSelfRefChildRow.aspx.

WebGrid with external AJAX Framework

WebGrid V5.0 now fully supports external AJAX Framework such as ASP.NET AJAX.

In addition to powerful built-in AJAX capability, WebGrid also allows you to use external AJAX Framework to partially refresh the control using AJAX technique. This is made possible with the rock-solid server side architecture and extensible built-in AJAX Framework which is based on WebUI.NET Framework.

WebGrid includes native support for emerging AJAX Framework such as ASP.NET. WebGrid includes native support for emerging AJAX Framework such as ASP.NET AJAX from Microsoft. You can use ASP.NET AJAX's UpdatePanel to perform partial update on the WebGrid control. WebGrid also supports Intersoft's proprietary AJAX Manager, known as WebFlyPostBackManager.

To learn more about these features, please refer to the section below.

Walkthrough Topics

Walkthrough: Using WebGrid with ASP.NET AJAX RTM

Walkthrough: Using WebGrid with WebFlyPostBackManager

See Also

Other Resources
Walkthrough Topics
FAQ and How-to Topics
New Features in V5.0
Features and Concepts
Learning More
Miscellaneous WebGrid Settings


Learning More

Learning More
See Also Send Feedback
Intersoft WebGrid > Learning More

Glossary Item Box

The topics in this section provide essential information on working with Designer, ChildTables, Collection DataBinding, ColumnSet Layout and Self Referencing Table.

In This Section

Working with Designer
Learn how to get familiar with WebGrid.NET Designer.

Working with ChildTables
Learn how to get child table and retrieve parent row's KeyValue.

Working with Collection DataBinding
Learn how to display flat and hierarchical collections.

Working with ColumnSet Layout
Learn how to understand and use ColumnSet layout in more details.

Working with Advanced Client-Server Interaction
Learn how to use SendCustomRequest and ClientAction features.

Working with Self Referencing Table
Learn how to create and customize self reference table.

See Also

Overview
Getting Started
WebGrid Features Overview

Other Resources
Walkthrough Topics
How-to Topics


Working with Designer

Working with Designer
See Also Send Feedback
Intersoft WebGrid > Learning More > Working with Designer

Glossary Item Box

WebGrid.NET Enterprise takes web development to a new level by introducing rich component designer to help developers easily configure the powerful and advanced settings available in WebGrid.

Based on Intersoft's state-of-the-art Component Designer 2.0 architecture, WebGrid.NET Enterprise 5.0 Designer is a highly advanced component editor delivering unmatched ease-of-use and streamlined user interface.

This section will guides you to get familiar with Intersoft's rich WebGrid.Net designer.

In This Section

Quick Start

Configuring Data Source

Advanced

Layout Manager

Structure Manager

Localization Manager

See Also

Overview
Getting Started
WebGrid Features Overview

Other Resources
Walkthrough Topics
How-to Topics


Using Layout Manager

Using Layout Manager
See Also Send Feedback

Glossary Item Box

Layout Manager utility can be used to apply predefined or custom layouts into WebGrid. It can be reached by opening WebGrid.NET Designer. In the Visual Studio .NET IDE, right-click an instance of WebGrid and choose WebGrid.NET Designer. Pay attention to the 3 sections at the top : "Properties", "Localization Manager" and "Layout Manager". When Layout Manager section is clicked, developers will be presented with below screenshot:

When developers want to apply a predefined layout such as 'Default 2005 (Mozilla)', simply double-click that entry. The below screen shot show the result :

The current layout is utilizing standard xml format, as can be seen when saving the layout as *.isl extension.

Since the file is saved as *.isl extension in xml format, developers can easily create many layout files in xml format and then save them into *.isl.

In This Section

Apply predefined Layout

Save current Layout

Apply saved Layout

Preview Layout

See Also

Overview
Getting Started
WebGrid Features Overview

Other Resources
Walkthrough Topics
How-to Topics


Quick Start

Quick Start
See Also Send Feedback
Intersoft WebGrid > Learning More > Working with Designer > Quick Start

Glossary Item Box

The quick start page is the main access point of most popular settings to help you quickly getting started with WebGrid. By default, the quick start page is displayed automatically when launched from design surface.

The quick start page consists of 8 sub pages. The Data Source sub page is automatically displayed when the WebGrid does not have binding configuration yet. The Popular Settings sub page will be displayed when the WebGrid already has a valid binding configuration. This allows you to concentrate on WebGrid's customization based on its current state.

The new expandable and collapsible user interface allows you to quickly locate a feature. Most settings are presented in check box and radio selection interface which are designed to help you instantly enable or disable, or modify a feature with one mouse click.

The following image shows the screenshot of Popular Settings in Quick Start page.

See Also

Related Sections
Advanced
Layout Manager
Structure Manager
Localization Manager

Other Resources
Working with Designer
Walkthrough Topics
How-to Topics


Configuring Data Source

Configuring Data Source
See Also Send Feedback
Intersoft WebGrid > Learning More > Working with Designer > Configuring Data Source

Glossary Item Box

Beside configuring data source using WebGrid's SmartTag like in the Walkthrough: Binding WebGrid to AccessDataSource control, you are also able to configure data source using WebGrid.NET Designer.

Here are the steps to configure data source using WebGrid.NET Designer.

  1. Drag and drop WebGrid and AccessDataSource instance.
  2. Set NorthWind database (Table Customers) to AccessDataSource.
  3. Right click on WebGrid instance to open WebGrid.NET Designer.
  4. Configure AccessDataSource to WebGrid using WebGrid.NET Designer.

    Set DataSouce ID to AccessDataSource1.
    Set View Name to DefaultView.

  5. Click Retrieve Structure button to automatically configure WebGrid for displaying data.
  6. Here is the result.

See Also

Getting Started
Getting Started

Overview
WebGrid Features Overview

Other Resources
Walkthrough Topics
How-to Topics


Advanced

Advanced
See Also Send Feedback
Intersoft WebGrid > Learning More > Working with Designer > Advanced

Glossary Item Box

The Advanced page gives you complete control over the WebGrid configuration and its tables structure. While most main features can be easily enabled in Quick Start page, some advanced features such as column set display, self referencing, or other table-level settings can only be configured in Advanced page.

Combining the state-of-the-art Component Designer with streamlined user interface concept in WebGrid.NET Enterprise 5.0, the Advanced page also displays rich designer for several main objects such as WebGridTable and WebGridColumn. This results in sophisticated designer experience and dramatically increasing developer's productivity.

With rich designer, you can now easily modify advanced configuration. For instance, you can launch ColumnSet Wizard by clicking on Design ColumnSet button in this screen, instead of having to set related settings in several locations.

The following image shows the screenshot of Advanced page, while focused at a WebGridTable.

Thanks to the rock-solid Component Designer architecture that made rich designer experience possible, you can now instantly select an editing control for the selected column by simply clicking on the visual clue. No more tedious steps and lengthy procedure to use a custom editor such as Calculator or Html Editor.

The following image shows the screenshot of Advanced page, while focused at a WebGridColumn.

The following image shows the screenshot of Advanced page, when See all properties link is clicked. For advanced developer who preferred to browse all properties, here is the mode for you.

See Also

Related Sections
Quick Start
Layout Manager
Structure Manager
Localization Manager

Other Resources
Working with Designer
Walkthrough Topics
How-to Topics


Layout Manager

Layout Manager
See Also Send Feedback
Intersoft WebGrid > Learning More > Working with Designer > Layout Manager

Glossary Item Box

The Layout Manager feature has been introduced since previous version of WebGrid.NET Enterprise. The feature was previously implemented in WebUI.NET Framework as part of Component Designer 1.0. Layout Manager is a powerful feature to let you easily apply from a predefined style as well as save your own style and reuse it later.

The Layout Manager in second generation of Component Designer has been much improved in many areas. It now has cleaner look and uncluttered user interface to bring you larger space for the preview.
You can easily preview a style before decide to apply it by simply clicking on Preview command. The preview is performed in real time and is showing the exact visual appearances as in runtime.
The following screenshot shows the new Layout Manager in Component Designer 2.0.

In This Section

Apply predefined Layout

Save current Layout

Apply saved Layout

Preview Layout

See Also

Related Sections
Quick Start
Advanced
Structure Manager
Localization Manager

Other Resources
Working with Designer
Walkthrough Topics
How-to Topics


Apply predefined Layout

Apply predefined Layout
See Also Send Feedback
Intersoft WebGrid > Learning More > Working with Designer > Layout Manager > Apply predefined Layout

Glossary Item Box

By default, WebGrid.NET is equipped with 12 predefined layouts, such as 'Default Basic', 'Default Hierarchical', 'Default Enterprise' etc.

Here are step-by-step procedures :

  1. In the Visual Studio .NET IDE, right-click an instance of WebGrid and choose WebGrid.NET Designer. Pay attention to the 5 sections at the top : "Quick Start", "Advanced", "Layout Manager", "Structure Manager" and "Localization Manager". When Layout Manager section is clicked, developers will be presented with below snapshot:

  2. When developers want to apply a predefined layout such as 'Default 2005 (Mozilla)', simply double-click that entry. The below snapshot shows the result :

  3. Remember to click the 'Apply' button in order to apply the new predefined layout. When it is finished, the grid will show the following snapshot :

  4. Click the 'OK' button and in the Visual Studio .NET IDE, the grid layout will be changed into the new layout.

See Also

Overview
Getting Started
WebGrid Features Overview

Other Resources
Walkthrough Topics
How-to Topics


Save current Layout

Save current Layout
See Also Send Feedback
Intersoft WebGrid > Learning More > Working with Designer > Layout Manager > Save current Layout

Glossary Item Box

Developers can save the current layout of WebGrid into *.isl file. Therefore, it could be retrieved easily in the future.

Here are step by step procedures :

  1. Try to modify the RowStyle BackColor into 'Ivory' using WebGrid.NET Designer.

    This style will be saved into an *.isl file.

  2. In the Visual Studio .NET IDE, right-click an instance of WebGrid and choose WebGrid.NET Designer. Pay attention to the 5 sections at the top : "Quick Start", "Advanced", "Layout Manager", "Structure Manager" and "Localization Manager". When Layout Manager section is clicked, developers will be presented with below snapshot:

  3. Click the 'Save' button in order to save the grid's current layout into a file.

  4. Try to open the saved *.isl file using a Text Editor. Notice that the modified RowStyle is saved into the file.

See Also

Overview
Getting Started
WebGrid Features Overview

Other Resources
Walkthrough Topics
How-to Topics


Apply saved Layout

Apply saved Layout
See Also Send Feedback
Intersoft WebGrid > Learning More > Working with Designer > Layout Manager > Apply saved Layout

Glossary Item Box

Developers can easily apply their past saved layout which is retrieved from the *.isl file.

Here are step by step procedures:

  1. We are trying to apply our custom layout into the grid.

  2. In the Visual Studio .NET IDE, right-click an instance of WebGrid and choose WebGrid.NET Designer. Pay attention to the 5 sections at the top : "Quick Start", "Advanced", "Layout Manager", "Structure Manager" and "Localization Manager". When Layout Manager section is clicked, developers will be presented with below snapshot:

  3. Click the 'Add (+)' button in order to add developers' custom layout into the Layout Manager. In this sample, we're retrieving 'Layout.isl' into the Layout Manager. When it is successful, the 'Layout.isl' should be listed in the 'Custom Layout' part in the left pane.

  4. Double-click the 'Layout.isl' in the left pane and the right pane will show the preview of the intended layout.

  5. Click the 'Apply' button to apply the current layout.

  6. Here is the result:

See Also

Overview
Getting Started
WebGrid Features Overview

Other Resources
Walkthrough Topics
How-to Topics


Preview Layout

Preview Layout
See Also Send Feedback
Intersoft WebGrid > Learning More > Working with Designer > Layout Manager > Preview Layout

Glossary Item Box

By default, WebGrid.NET is equipped with 12 predefined layouts, such as 'Default Basic', 'Default Hierarchical', 'Default Enterprise', etc.

Here are the step by step procedures:

  1. In the Visual Studio .NET IDE, right-click an instance of WebGrid and choose WebGrid.NET Designer. Pay attention to the 5 sections at the top : "Quick Start", "Advanced", "Layout Manager", "Structure Manager" and "Localization Manager". When Layout Manager section is clicked, developers will be presented with below snapshot:

  2. When developers want to apply a predefined layout such as 'Default 2005 (Mozilla)', simply double-click that entry. The below snapshot show the result :

  3. Remember to click the 'Apply Layout' button in order to apply the new predefined layout. When it is finished, the grid will show the following snapshot:

  4. Click the 'Preview' button in order to see the preview of the current layout.

  5. Click the 'OK' button and in the Visual Studio .NET IDE, the grid layout will be changed into the new layout.

See Also

Overview
Getting Started
WebGrid Features Overview

Other Resources
Walkthrough Topics
How-to Topics


Structure Manager

Structure Manager
See Also Send Feedback
Intersoft WebGrid > Learning More > Working with Designer > Structure Manager

Glossary Item Box

Structure Manager is a new feature in WebGrid.NET Enterprise 5.0. This feature enables you to save the structure of an existing WebGrid in design-time. The structure includes table configuration such as columns, grouped columns, filtered columns as well as child tables.

Structure Manager allows you to preview an existing structure before you choose to apply it. This feature increases productivity by enabling developers to reuse a complex structure in multiple instances or projects.

With this feature, you can easily reuse a WebGrid's structure by applying the saved configuration in Structure Manager.

The following image demonstrates Structure Manager page in action.

See Also

Related Sections
Quick Start
Advanced
Layout Manager
Localization Manager

Other Resources
Working with Designer
Walkthrough Topics
How-to Topics


Localization Manager

Localization Manager
See Also Send Feedback
Intersoft WebGrid > Learning More > Working with Designer > Localization Manager

Glossary Item Box

Localization Manager is a feature to help you configuring the language settings in WebGrid. In this new version, Localization Manager has been much improved with the adoption of clean and uncluttered user interface which results in better development experience and easier to use.

The improved Localization Manager also incorporates the new SmartWebResources™ feature in its user interface so that you can effortlessly configure resources and related language settings in one streamlined user interface.
Note that when the language resources are retrieved from SmartWebResources™, the WebGrid requires the main SmartWebResources™ setting to be enabled. This is the recommended setting in WebGrid.NET Enterprise 5.0 as well as other 2007 platform products. To learn more about SmartWebResources™ feature, see SmartWebResources Deployment.
The following image shows the main user interface of Localization Manager.

If you would like to use modified language file, or your own language file which is not shipped along with WebGrid, you need to use Physical Client Resources mode so that your language file can be retrieved through classic web client url.
When you used Physical Client Resources mode, you can manage the language list from the user interface. You can also customize the text entry in the Manage Language Files sub page.
The Manage Language Files feature lets you add or remove a language file, or customize the existing language file with your own customized text entry.
The following image shows the Localization Manager with Manage Language Files sub page activated.

In This Section

Choose Language

Manage Language Files

Assign Localized Text

See Also

Related Sections
Quick Start
Advanced
Layout Manager
Structure Manager

Other Resources
Working with Designer
Walkthrough Topics
How-to Topics

References
LocalizationFolder Property
Language Property


Installation

Installation
See Also Send Feedback

Glossary Item Box

Issue

I have just downloaded WebGrid 4.0 and installed it on my development PC. When I build the Tutorials or Samples, I get an error message like "The type or namespace name 'AutoIncrement' could not be found (are you missing a using directive or an assembly reference?)". I also have WebGrid 3.5 installed and I do not want to uninstall WebGrid 3.5.

Resolution

The error happens because Visual Studio loads the DLL from the last working path. Press Ctrl+Alt+L to open the Solution Explorer window. Expand the References node and delete ISNet.WebUI.WebGrid which is still referring to WebGrid 3.5. Then, add a new reference that points to 'C:\Program Files\Intersoft Solutions\WebGrid.NET V4.0\Bin\ISNet.WebUI.WebGrid.dll' and set the CopyLocal property to 'True'.

Issue

I have had all of the trial versions successfully installed. When I purchased the products, you sent me license keys. I deinstalled all the products and then reinstalled them, entering the license key at installation time. Everything seems to install correctly, but when I go into Visual Studio, some products seem to be still trial versions and some products seem be unlicensed versions. I have deinstalled and reinstalled a total of six times. The last time I did this, I even went as far as deleting all reference to your controls in the registry. Please help.

Resolution

Perhaps, the .dll reference still directed to the old .dll reference.
Here is what you have to do:
1). Open your VS and refer to Solution Explorer bar on the right side.
2). In Solution Explorer, expand References and Remove/delete ISNet.WebUI.WebGrid.
3). Then, right-click References, and choose Add Reference.
4). Browse and Add ISNet.WebUI.WebGrid.dll from C:\Program Files\Intersoft Solutions\WebGrid.NET V4.0\Bin (This is the default installation folder).
5). Finally, try to drag the component again from ToolBox. It should work by now.

Apply these steps above to other components as well, such as WebCombo and WebInput. You just need to remove ISNet.WebUI.WebCombo or ISNet.WebUI.WebInput and add them from the source bin folder.

Issue

I have installed WebGrid 4.0 Trial and starting the samples I get the error 'System.UnauthorizedAccessException in mscorlib.dll'.

Resolution

Try to set Debug-Exception-Common Language Runtime Exceptions property. There are 2 groups of radio buttons. In the "When the exception is thrown: ", choose "Continue", and in the "When the exception is not handled", choose "Break into the debugger". This should fix your problem.

Issue

I always get the error message "WebGrid.NET Enterprise Edition - Unlicensed version. The system is unable to find the license needed to run this component".

I have tried to uninstall and reinstall WebGrid.

Resolution

Please make sure you have entered a valid design-time license key (not the runtime license key) when installing WebGrid and use all caps for that because it is case-sensitive.

Issue

I get "Design time license key not found or not valid" error message when trying to create new instance in VS.NET IDE.

Resolution

The component can't be initialized because of incorrect design-time license key.

Please follow this steps to resolve this problem:

  • Uninstall any versions of the product including Trial version if you have it installed.
  • Restart your machine to ensure that installation is clean.
  • Install the retail version of the product.
  • Enter the provided design-time license key correctly using all caps. Note that the installer will not prompt you an error message for entering invalid license key.

Issue

V4.0.6200 does not accept its license key (V3.5.5000 worked fine). The error is "Unacceptable character. You can only type a number here." The last characters in our license key are characters but it demands numbers. How do we install V4.0.6200?

Resolution

The license key validator in V4.0.6200 only accepts copy & paste, so you can't type the key. This is to ensure you entered the right key

See Also

Related Sections
Getting Started: Installation
Getting Started: Deployment


Deployment

Deployment
See Also Send Feedback

Glossary Item Box

Issue | Does WebGrid support XCOPY deployment to the MS Windows 2003 Server? or do i have to install the component at the production server?
Resolution | WebGrid.NET does fully support XCOPY deployment. In order to deploy the component, you only need to copy all the necessary WebGrid.NET dlls to the production server. For full details, please delve into the Deployment Guide section. Full installation of WebGrid on the server is not required.
Issue | When deploying WebGrid.NET 4.0 to the production web servers, the following error occurs "The system was unable to find the license needed to run this component".
Resolution | The new runtime key format will be applied starting from version 3.5 and higher. The runtime key format will be "ISNet.WebUI.WebGrid.vX_X_XXXX.RuntimeLicenseKey". So for the version 4.0, the runtime key format will be "ISNet.WebUI.WebGrid.v4_0_6200.RuntimeLicenseKey".
Issue | I have to reinstall WebGrid each time I start a new project because when I do and I drag a grid from the tool box on to the form I get the 'Unlicenced Version' error until I reinstall. What should I do?
Resolution | When creating a new project, please check in registry, HKLM-Software-IntersoftSolutions-4.0.6200, check the SID key, is it empty or contains a key? In some situation, an application can erase this key, that's why you got the error. If it's empty when you're creating a new project, simply copy n paste the key back to registry.

See Also

Related Sections
Installation
Deployment


Using Designer

Using Designer
See Also Send Feedback

Glossary Item Box

Issue | How do I change the message 'There are no rows in this view' to my predefined message in the frame?
Resolution | You just open your WebGrid.NET Designer, and go to Localization Manager tab, which is placed on the top of the designer (there are 3 of them, which are Properties, Localization Manager and Layout Manager. After switch to Localization Manager, in TextSetting Items, choose CommonText. You will see a table with 2 columns (Localization Item and Localization Text) on your right-side. In the 1st column, find a row called "NoData" which has a Localization Text said "There are no rows in this view". Change that Localization Text with the text you desired.
Issue | When resizing a column in ASP .NET 2.0 Beta 2 with master pages, the line that shows where the column will be is not rendered in the correct place. This happens in both IE and FireFox. I resize the Username column. The master page simply had a header on the top and a navigation menu on the left side.
Resolution | This offset issue occurs if you use DIV or TABLE in your page. To solve this problem, simply set UseRelativePositioning to true.
Issue | Some of our data are numbers, so we hope to show the numbers at the right side of the column. That means the table columns should be right aligned. Any setting we can use?
Resolution | Please follow these instructions: 1). Open WebGrid.NET Designer. 2). Go to RootTable --> Columns. 3). Choose the column you want to set the alignment. 4). In the column property on the right side, Expand CellStyle. 5). Set HorizontalAlign to Right.
Issue | When a column is set to Readonly, this also prevents you from entering in a "Filter" value. The readonly should only affect the grid, not the filter functionality at the top.
Resolution | Setting the EditType property to NoEdit will specify the column as ReadOnly. Should you want to enable the filtering function in the column, simply set FilterEditType property of the column to TextBox. Both of them can be configured using WebGrid.NET Designer.

See Also

Learning More
Working with Designer


FAQ: Can I perform retrieve structure programmatically when bound to DataSource control?

FAQ: Can I perform retrieve structure programmatically when bound to DataSource control?
See Also Send Feedback

Glossary Item Box

You can perform retrieve structure programmatically from PrepareDataBinding event handler. Here is the code snippet:

JavaScript Copy Image Copy Code
protected void WebGrid1_PrepareDataBinding(object sender, ISNet.WebUI.WebGrid.DataSourceEventArgs e)
{
  if (!IsPostBack)
     WebGrid1.RetrieveStructure();
}

See Also

Tasks
Walkthrough: Binding WebGrid to AccessDataSource control
Walkthrough: Binding WebGrid to ObjectDataSource control
Walkthrough: Binding WebGrid to XMLDataSource control
Walkthrough: Configuring updatable WebGrid bound to ObjectDataSource control


FAQ: What does Default Style look like?

FAQ: What does Default Style look like?
See Also Send Feedback

Glossary Item Box

Please refer to Default Style Mode topic to see the look and feel of the Default Style.

See Also

Tasks
How-to: Enable Default Style for existing instance of WebGrid


FAQ: Does SmartWebResources feature automatically enabled in WebGrid.NET Enterprise 5.0?

FAQ: Does SmartWebResources feature automatically enabled in WebGrid.NET Enterprise 5.0?
See Also Send Feedback

Glossary Item Box

By default, Intersoft 2007 product platform has the SmartWebResources set to Automatic mode. This automatic mode ensures compatibility with existing web application when developers migrated to 2007 platform, while at the same time attempting to utilize SmartWebResources in new web application whenever possible.

When you created a new web application and started to use WebGrid.NET version 5.0, the SmartWebResources is not configured initially. With the automatic mode as default behavior, WebGrid.NET will use physical resources since the SmartWebResources is not configured initially.

See Also

Tasks
FAQ: Briefly, what are the files included in WebGrid SmartWebResources Assembly?
FAQ: I got a warning message "ContextMenu is disabled due to missing resources" after page load in the browser. What should I do to resolve this problem?
FAQ: I am aware that WebGrid.NET Enterprise 5.0 requiring WebDesktop SmartWebResources as part of its User Interface engine. Do I need to purchase a separate WebDesktop's license in order to use its SmartWebResources?
How-to: Configure SmartWebResources in a new web application
How-to: Disable SmartWebResources for Localization's language files

Concepts
SmartWebResources Deployment


FAQ: Briefly, what are the files included in WebGrid SmartWebResources Assembly?

FAQ: Briefly, what are the files included in WebGrid SmartWebResources Assembly?
See Also Send Feedback

Glossary Item Box

The single assembly of WebGrid's SmartWebResources contains all required scripts and images that used by the control at runtime. It includes:

  • Core Scripts, such as WebGrid_Core.js, WebGrid_UI.js etc.
  • Custom Editor Scripts, such as the scripts for Slider, Rich Html Editor etc.
  • Core Images Set, such as tree lines, background images, command icons etc.
  • Theme Images Set, such as the Outlook-style images used in Outlook Predefined Style.
  • Language Files, such as the Xml Data for English language. There are about 15 languages included in this resource assembly.
  • Stylesheets and other document files that will be automatically loaded when needed by the module in client side.

See Also

Tasks
FAQ: Does SmartWebResources feature automatically enabled in WebGrid.NET Enterprise 5.0?
FAQ: I got a warning message "ContextMenu is disabled due to missing resources" after page load in the browser. What should I do to resolve this problem?
FAQ: I am aware that WebGrid.NET Enterprise 5.0 requiring WebDesktop SmartWebResources as part of its User Interface engine. Do I need to purchase a separate WebDesktop's license in order to use its SmartWebResources?
How-to: Configure SmartWebResources in a new web application
How-to: Disable SmartWebResources for Localization's language files

Concepts
Hassle-free deployment through SmartWebResources™ technology


FAQ: I got a warning message 'ContextMenu is disabled due to missing resources' after page load in the browser. What should I do to resolve this problem?

FAQ: I got a warning message 'ContextMenu is disabled due to missing resources' after page load in the browser. What should I do to resolve this problem?
See Also Send Feedback

Glossary Item Box

If you get this warning prompt, that means the WebGrid is unable to find the WebDesktop SmartWebResources Assembly in runtime. Ensure you have properly registered the SmartWebResources.

See Also

Tasks
FAQ: Does SmartWebResources feature automatically enabled in WebGrid.NET Enterprise 5.0?
FAQ: Briefly, what are the files included in WebGrid SmartWebResources Assembly?
FAQ: I am aware that WebGrid.NET Enterprise 5.0 requiring WebDesktop SmartWebResources as part of its User Interface engine. Do I need to purchase a separate WebDesktop's license in order to use its SmartWebResources?
How-to: Configure SmartWebResources in a new web application
How-to: Disable SmartWebResources for Localization's language files

Concepts
Hassle-free deployment through SmartWebResources™ technology


FAQ: I am aware that WebGrid.NET Enterprise 5.0 requiring WebDesktop SmartWebResources as part of its User Interface engine. Do I need to purchase a separate WebDesktop's license in order to use its SmartWebResources?

FAQ: I am aware that WebGrid.NET Enterprise 5.0 requiring WebDesktop SmartWebResources as part of its User Interface engine. Do I need to purchase a separate WebDesktop's license in order to use its SmartWebResources?
See Also Send Feedback

Glossary Item Box

No, you do not need to purchase a separate license for WebDesktop to use its SmartWebResources. However, you may use and redistribute WebDesktop SmartWebResources Assembly only when you use it together with WebGrid.NET Enterprise 5.0.

Note that starting from 2007 product platform, all products are installed through a single integrated installer. This enables deeper integration between Intersoft's components in runtime without affecting licensing. For more information about new installation and licensing mechanism in 2007 product platform, refer to WebUI.NET Framework 2007 Documentation.

See Also

Tasks
FAQ: Does SmartWebResources feature automatically enabled in WebGrid.NET Enterprise 5.0?
FAQ: Briefly, what are the files included in WebGrid SmartWebResources Assembly?
FAQ: I got a warning message "ContextMenu is disabled due to missing resources" after page load in the browser. What should I do to resolve this problem?
How-to: Configure SmartWebResources in a new web application
How-to: Disable SmartWebResources for Localization's language files

Concepts
Hassle-free deployment through SmartWebResources™ technology


FAQ: Does WebCombo.NET 4.0 control included in WebGrid.NET Enterprise 5.0?

FAQ: Does WebCombo.NET 4.0 control included in WebGrid.NET Enterprise 5.0?
See Also Send Feedback

Glossary Item Box

No, WebCombo.NET 4.0 license is not included with WebGrid.NET Enterprise 5.0 purchase. WebCombo.NET 4.0 is a standalone component and is sold separately. However if you owned a valid Subscription license, WebCombo.NET 4.0 should be available to you without additional costs.

See Also

Tasks
Walkthrough: Configuring multiple values editing using WebCombo.NET 4.0 control in WebGrid


Choose Language

Choose Language
See Also Send Feedback
Intersoft WebGrid > Learning More > Working with Designer > Localization Manager > Choose Language

Glossary Item Box

There are three language modes inside the 'Language' section:

  1. Use Default

    When 'Use Default' option is selected, regardless of any Culture settings anywhere, the default language file will be used.

  2. Use Inherit from Culture

    The language file that will be used by WebGrid will be selected based of the specified Culture setting. The system will look for any Culture setting configured inside the WebGrid first. If none is defined, the system will look for the Culture setting specified in the Page level or Thread level.

  3. Use Custom

    The system will use the Custom Culture as the language file. It will override any Culture setting specified in the WebGrid level or Page level. If the language file can't be found, the system will use Default language file. In the below screen shot, we are trying to use Italian(Italy) custom culture.

  4. Here is the result when it is applied to the grid.

See Also

Overview
Getting Started
WebGrid Features Overview

Other Resources
Walkthrough Topics
How-to Topics


Manage Language Files

Manage Language Files
See Also Send Feedback
Intersoft WebGrid > Learning More > Working with Designer > Localization Manager > Manage Language Files

Glossary Item Box

In the 'Manage Language Files' section, developers can add new language files.

Try to click the '+' symbol in order to add a new language file, in example : 'Malaysia'. In the 'Add New Language' window, define the 'Culture' and 'Description' for the new language file. Finally, click 'OK'

The new language file will be listed in the 'Available Language Files' list. Next, developers need to insert the 'TextSettings Items' based on the new language file. In this example, we are inserting 'Siap' as the new value for 'Ready'.

Developers can see the end result when viewing the grid in the browser.

See Also

Overview
Getting Started
WebGrid Features Overview

Other Resources
Walkthrough Topics
How-to Topics


Assign Localized Text

Assign Localized Text
See Also Send Feedback
Intersoft WebGrid > Learning More > Working with Designer > Localization Manager > Assign Localized Text

Glossary Item Box

Developers can modify the 'TextSettings' items in the available list.

Here are step by step procedures:

  1. Open the Localization Manager. Make sure that in the 'Language Mode', 'Italian (Italy)' value is selected.
  2. Click the 'Italian' entry in the 'Available Language Files' list and then click the 'Manage Language Files'.

  3. In the 'Ready' value of the 'Content', change the text from 'Pronto.' to 'Pronto xyz'. Make sure that 'Save Changes' button is clicked in order to save the changes.

  4. Here is the result in the browser:

See Also

Overview
Getting Started
WebGrid Features Overview

Other Resources
Walkthrough Topics
How-to Topics


Working with ChildTables

Working with ChildTables
See Also Send Feedback
Intersoft WebGrid > Learning More > Working with ChildTables

Glossary Item Box

This section contains information on how to work with child table in hierarchical mode.

In This Section

Get ChildTable on client side and server side event
Shows how to get key value on the parent row from server side and client side.

Retrieve Parent KeyValue
Shows how to get parent row's key value of child row in client side.

See Also

Getting Started
Getting Started

Overview
WebGrid Features Overview

Other Resources
Walkthrough Topics
How-to Topics


Get ChildTable on client side and server side event

Get ChildTable on client side and server side event
See Also Send Feedback
Intersoft WebGrid > Learning More > Working with ChildTables > Get ChildTable on client side and server side event

Glossary Item Box

Since WebGrid.NET supports hierarchical mode, there are many scenarios related to the child table. For instance, how to get a child row's key value, expand the child table and many more. As a sample, we use key value to be obtained in ChildTable.

There are 2 ways to obtain key value at client side on the parent row, from server side and client side.

  • Client-side

  • To obtain a key value on child table, we need a subtableId from the parent row that needs to be expanded first in order to render the sub table of the related key value.

    SubtableId returns an array of a SubTable object which belongs to the table's current level that has been expanded before.

    Here is the sample code on how to get the childRow keyValue of expanded parent row :

    JavaScript CopyHover Image Copy Code
       function getKeyValue()
       {
           var grid = ISGetObject("WebGrid1");
           var selObj = grid.GetSelectedObject();
           var row = selObj.GetRowObject();
               if (row.Table.ChildTables.length > 0)
               {
                   if (!row.ChildExpanded)
                   {
                      row.ExpandChildRow(true);
                      alert(grid.Tables["Orders"].SubTableIds[0].GetElement(WG40.BODY,
                          WG40.HTMLTABLE).childNodes[1].childNodes[0].keyValue);
                   }
                }
       }

    With the latest client side API in WebGrid.NET Enterprise 5.0, there is another way to get the child row by using GetChildRows object based on defined relations.

    JavaScript CopyHover Image Copy Code
       function ExpChild()
        {
            var grid = ISGetObject("WebGrid1");
            var selObj = grid.GetSelectedObject();
            var row = selObj.GetRowObject();
            if (row.Table.ChildTables.length > 0)
            {
                if (!row.ChildExpanded)
                {
                    row.ExpandChildRow(true);
                    var childRows = row.GetChildRows("Orders");
                    var s = "";
                    for (var i=0; i<childRows.length; i++)
                    s += "\nOrderID: " + childRows[i].KeyValue;
                    debugger
                    alert("Customer '" + row.KeyValue + "' has " + childRows.length +
                        " orders.\nThe orders are:" + s);
                }
            }
        }

These samples above show how to get the key value, obtain and set another property inside the object.

  • Server-side

  • In ServerSide, we can simply use "WebGrid1.RetrieveClientLastSelectedObject().KeyValue" to get the child's or parent's key value. However, we need to click to the proper row before.

See Also

Overview
Getting Started
WebGrid Features Overview

Other Resources
Walkthrough Topics
How-to Topics


Retrieve Parent KeyValue

Retrieve Parent KeyValue
See Also Send Feedback
Intersoft WebGrid > Learning More > Working with ChildTables > Retrieve Parent KeyValue

Glossary Item Box

In hierarchical WebGrid, we often need to get the parent row's key value of a child row in client side. With the new enhancement in client side API, we can easily retrieve the key value.

First, we need to get the parent row. You can use this command to get the parent row:

JavaScript CopyHover Image Copy Code
var grid = ISGetObject("WebGrid1");
var selObj = grid.GetSelectedObject();
var row = selObj.GetRowObject();
var parentRow = row.GetParentRow();

Then, you simply use this command to get the parent row's key value.

JavaScript CopyHover Image Copy Code
var keyValue = parentRow.KeyValue;
When you run the application, select a child row to obtain the parent row's key value.

See Also

Overview
Getting Started
WebGrid Features Overview

Other Resources
Walkthrough Topics
How-to Topics


Working with Collection DataBinding

Working with Collection DataBinding
See Also Send Feedback
Intersoft WebGrid > Learning More > Working with Collection DataBinding

Glossary Item Box

This section contains information on how to display flat and hierarchical collections of data binding in WebGrid.

In This Section

Flat Collection
Shows how to perform flat collection data binding.

Hierarchical Collection
Shows how to perform hierarchical collection data binding.

See Also

Getting Started
Getting Started

Overview
WebGrid Features Overview

Other Resources
Walkthrough Topics
How-to Topics


Flat Collection

Flat Collection
See Also Send Feedback
Intersoft WebGrid > Learning More > Working with Collection DataBinding > Flat Collection

Glossary Item Box

Flat Collection data binding has been introduced since Version 3.5 of WebGrid.NET Enterprise. Along with the addition of Hierarchical Collection binding support in V4.0, there are multiple ways to display flat collection in V5.0.

There are two methods on how V5.0 handles Flat Collection:

  • Direct binding

    This is the flat collection implementation used in V3.5. Direct binding does not require additional implementation of interfaces or attributes to existing collections, although it still has many limitations and scoped for basic scenarios.

    This traditional method is provided for backward compatibility purpose in V5.0.

    The tutorial for Direct Binding is available in Tutorials Solution >> V3.1 >> BindingIList.aspx

    When a collection does not implement IHierarchicalList interface, WebGrid.NET will automatically use this Direct binding method to handle Flat collection.
  • IHierarchicalList implementation

    V5.0 introduces a more powerful collection handling which is originally designed for Hierarchical Collection. This new implementation overcomes many limitations over the traditional implementation, such as the usage of Attributes to easily control the Table's Name, Column's Caption and Visibility of a public property and more.

    Due to broad scenarios support of hierarchical collections, the final version of 4.0 has opened the support to use similar implementation for Flat Collection. To use the new implementation for Flat collection, you only need to implement the

    IHierarchicalList interface.

    Hierarchical property of the LayoutSettings is required to be set to False for Flat Collection support using new implementation.

    Sample code for IHierarchicalList implementation for Flat Collection:

    C# CopyHover Image Copy Code
    public class CustomerCollection : System.Collections.CollectionBase, IHierarchicalList
{
    public void Add(Customer aCustomer)
    {
        aCustomer.Owner = this;
        List.Add(aCustomer);
    }

    public bool Remove(int index)
    {
        // Check to see if there is a customer at the supplied index.
        if (index > Count - 1 || index < 0)
        {
            return false;
        }
        else
        {
            List.RemoveAt(index);
            return true;
        }
    }

    public void Remove(Customer cust)
    {
        List.Remove(cust);
    }

    public Customer Item(int Index)
    {
        return (Customer) List[Index];
    }

    public Customer FindByID(string customerID)
    {
        foreach (Customer c in this.InnerList)
        {
            if (c.CustomerID == customerID) return c;
        }
        return null;
    }

    #region IHierarchicalList Members

    public Type ItemType
    {
        get
        {
            return typeof(Customer);
        }
    }

    #endregion
}

    Sample code for data binding:

    C# CopyHover Image Copy Code
    private void WebGrid1_InitializeDataSource(object sender,
ISNet.WebUI.WebGrid.DataSourceEventArgs e)
{
    CustomerCollection customers = DataLayer.GetCustomers();

    // populate order to all customers
    foreach (Customer cust in customers)
    {
        cust.PopulateOrders();
    }
    e.DataSource = customers;
}

See Also

Overview
Getting Started
WebGrid Features Overview

Other Resources
Walkthrough Topics
How-to Topics


Hierarchical Collection

Hierarchical Collection
See Also Send Feedback
Intersoft WebGrid > Learning More > Working with Collection DataBinding > Hierarchical Collection

Glossary Item Box

This section lists all links to perform Hierarchical collection data binding using Inbound and Unbound mode.

In This Section

Inbound Mode
Information about Hierarchical collection data binding using Inbound mode.

Unbound Mode
Information about Hierarchical collection data binding using Unbound mode.

See Also

Getting Started
Getting Started

Overview
WebGrid Features Overview

Other Resources
Walkthrough Topics
How-to Topics


Inbound Mode

Inbound Mode
See Also Send Feedback
Intersoft WebGrid > Learning More > Working with Collection DataBinding > Hierarchical Collection > Inbound Mode

Glossary Item Box

The first methodology to support Hierarchical Collection DataBinding is by using Inbound Mode. This mode indicates that you have accessed to the Collection and Business Object source codes during development where you can easily implement the required Interfaces directly to your collections and objects.

The inbound mode offers a more powerful control to the behavior of how the object would be displayed in the Grid. It also offers more automation process, such as you can easily mark a property as PrimaryKey or specify a different display Caption for the property by simply utilizing the provided Attributes.

Despite of the power and flexibility offered by Inbound Mode, it also introduced some limitations such as the following:

  • Business Layer Separation.

    The Inbound mode assumes that you have the Business Layer in the same project along with the User Interface layer such as the WebForm aspx files. This could cause confusion and mix up between Business and UI Layer.

    You can still use Inbound mode in separate project for Business Layer. However, you need to refer to WebGrid's assembly in the Business Layer project.
  • Packaged Business Object scenario.

    There is no way to modify Packaged Business Object, that means you do not have access to development sources and hence cannot easily perform any Interface implementation to the compiled objects. The Packaged Business Object is usually generated by 3rd party tool or developed by other team. The result is usually assembly (DLL) files.

Recognizing the above limitations, a new Outbound Mode is revealed to solve these limitations and therefore, enabling broader scenarios of business object binding support.

The tutorial for Inbound mode is available in Tutorial Solution >> V4.0 >> Hierarchical_Binding.aspx

See Also

Overview
Getting Started
WebGrid Features Overview

Other Resources
Walkthrough Topics
How-to Topics


Unbound Mode

Unbound Mode
See Also Send Feedback
Intersoft WebGrid > Learning More > Working with Collection DataBinding > Hierarchical Collection > Unbound Mode

Glossary Item Box

The Unbound mode enables developers to set the object relations definitions and object types information externally, without requires any changes to the business object's sources.

Although it is more convenient to use Inbound mode where you can fully control the behavior of the objects by using provided Attributes, Unbound mode allows external entities to be displayed properly in WebGrid.NET by using the same concepts.

To set the object relations definitions, use the SetObjectRelations method provided by WebGrid.

The SetObjectRelations method must be called in PreInitialize event in order for the Hierarchical Collection to work properly.

Following is the sample to use SetObjectRelations method.

C# CopyHover Image Copy Code
protected void WebGrid1_PreInitialize(object sender, System.EventArgs e)
{
    // assign OnPreInitialize event in ASPX
    // defines the Object Relations
    ArrayList objectRelations = new ArrayList();
objectRelations.Add(new WebGridObjectRelation(
        typeof(CustomerCollection), "CustomerID", "Orders",
        typeof(OrderCollection), "CustomerID"));
objectRelations.Add(new WebGridObjectRelation(
        typeof(OrderCollection), "OrderID", "OrderDetails",
        typeof(OrderDetailCollection), "OrderID"));

    // defines the Parent and Child Type information
    // objectTypes contains 3 object array: The parent collection type,
    // child item type, the primary keys of child collection
    // Primary keys can be string (if only 1 primary key defined),
    // or array of string for multiple primary keys scenario.
    ArrayList objectTypes = new ArrayList();
objectTypes.Add(new object[] {
        typeof(CustomerCollection), typeof(Customer), "CustomerID"});
objectTypes.Add(new object[] {
        typeof(OrderCollection), typeof(Order), "OrderID"});
objectTypes.Add(new object[] {
        typeof(OrderDetailCollection), typeof(OrderDetail), new string[] {
        "OrderID", "ProductID"}});

    // assign the required definitions through SetObjectRelations method
    // the SetObjectRelations need to be called in new PreInitialize method
    // since it needs to be initialized in earliest phase.
    WebGrid1.SetObjectRelations(objectRelations, objectTypes);
}

The ObjectRelations definition used the same concept as in Inbound Mode, that is by constructing WebGridObjectRelation and add it to an instantiated ArrayList.

The ObjectTypes parameter holds information about the type of the ParentCollection, the type of the Item, and the primary keys existed in the Item. To clearly understand the terms of the ObjectTypes concept, see following Northwind's Customer Table illustration:

  • ParentCollection

    CustomerCollection Type, a collection which contains all Item of type Customer.

  • Item/ChildObject

    Customer Type, the Type contained in ParentCollection.

  • PrimaryKeys

    CustomerID, this is a public property available within the Customer Type.

  • The tutorial for Outbound mode is available in Tutorial Solution >> V4.0 >> Hierarchical_Binding_Outbound.aspx

See Also

Overview
Getting Started
WebGrid Features Overview

Other Resources
Walkthrough Topics
How-to Topics


Working with ColumnSet Layout

Working with ColumnSet Layout
See Also Send Feedback
Intersoft WebGrid > Learning More > Working with ColumnSet Layout

Glossary Item Box

This section contains information on how to create, use and customize ColumnSet layout in WebGrid.

In This Section

Understanding ColumnSets Layout
Information about ColumnSet layout's introduction and benefits.

Creating ColumnSet
Learn how to configure ColumnSet layout programmatically or using the designer.

Accessing ColumnSet in client side
Learn how to obtain elements in ColumnSet layout using client side API.

Using ColumnSet in ChildTable
Learn how to configure ColumnSet in child table.

Customizing ColumnSet Settings
Learn how to configure numerous settings in ColumnSetSettings property.

See Also

Getting Started
Getting Started

Overview
WebGrid Features Overview

Other Resources
Walkthrough Topics
How-to Topics


Understanding ColumnSets Layout

Understanding ColumnSets Layout
See Also Send Feedback
Intersoft WebGrid > Learning More > Working with ColumnSet Layout > Understanding ColumnSets Layout

Glossary Item Box

Introduction

One of the most powerful and innovative features added in V4.0 is the new row rendering engine, which is now capable to render a subset of cells and rows as one row unit. The unique row rendering mechanism enables implemention of features such as ColumnSets and PreviewRow without breaking the consistency with existing features and APIs. The subset of cells and rows are rendered in the same table hierarchy resulting in approximately faster performance and about 25% smaller output size compared to other grids which normally render "nested tables" for each subset of rows such as grouprow, columnsets row, and previewrow or selfreference childrow.

WebGrid.NET's ColumnSets is built on the top of rich object model called RowLayout. This allows true cell layouting without dependency to column object. It also enables you to construct the layout dynamically from your codes, for even greater flexibility!

You can enable columnset rowlayout rendering in any level of table without has to sacrifice existing features such as hierarchical, grouping, column footer, group totaling, add/edit/delete, filtering, keyboard navigation, automatic column width, exporting and so on.

Powerful and easy-to-use designer is also included. Our unique designer has been developed to let you easily and conveniently design the columnsets. You can also resize the cell's width and height visually.

Benefits

The ColumnSet feature is designed to replace the standard .NET Templating approach which introduced following benefits:

  • Easy To Use.
    The provided Designer enables developers to easily design the layout they wanted, without advanced knowledge of HTML.
  • Time Saving.
    The ColumnSet Layout can be quickly configured and work consistently with other 85+ features. There is no need to waste lengthy hours to construct TABLE, nested DIV, or other complex layout which requires advanced HTML knowledge. There is no need to use slower Template Editing designer too.
  • Accessible Objects.
    You can access the ColumnSet and the RowLayout objects easily in both server side and client side codes by using strongly-typed API. You can't do this with .NET Template since it required you to construct your own TABLE and therefore have no integration with other features.

ColumnSet Designer

Access to ColumnSet Designer from WebGrid.NET Designer, Table, select ColumnSets node then click on ColumnSet Designer in right pane.

ColumnSet Designer Features:

  • Resize cell's width and height by using drag and drop.
  • Rich layout object model, allow you to access properties of specific cell in RowLayout Properties.
  • Allow unbound and empty cell.
  • Conveniently assign column member by clicking on drop-down arrow or right click on active cell.

RowLayout Concept and client's API

Without breaking existing API, the ColumnSet feature is built into the same, single structure which offered smaller output size and faster performance. WebGrid's row concept is an individual row element for each rowitem such as grouprow, columnsets or previewrow.

You may have already familiar with WebGrid's client side API such as getting selected row, retrieving keyValue, retrieving specific cell's information and so on. In ColumnSet mode, all row's attributes are only rendered in first row of each subset of rows to avoid duplication, named RootRow. The selected row will consistently reflect to the currently selected sub row of columnset rows (see screenshot above), so you may need to retrieve the RootRow in order to get information about a row.

Sample - Retrieving information of selected row (based on screenshot above)

JavaScript Copy Code
var grid = ISGetObject("webgrid1");
var selRow = grid.GetSelectedObject().GetSelectedRow();

alert(selRow.keyValue); // return undefined
alert(selRow.rowIndex); // return 4

var rootRow = wgGetRootRow(selRow);

alert(rootRow.keyValue); // return "2"
alert(rootRow.rowIndex); // return 3

var homePhoneCell = wgGetCellByName(rootRow, "HomePhone");
alert(homePhoneCell.innerText); // return "206 555-9857"

// get columnset rows
var colSetRows = wgGetColumnSetRows(rootRow);
alert(colSetRows.length); // return 3

ColumnSet Settings

ColumnSet settings is attached per table and can be found in expandable ColumnSetSettings property. You can customize numerous setting such as GridLineColor, GridLines, GridLineStyle, RowCount and ShowHeaders.

See Also

Overview
Getting Started
WebGrid Features Overview

Other Resources
Walkthrough Topics
How-to Topics


Creating ColumnSet

Creating ColumnSet
See Also Send Feedback
Intersoft WebGrid > Learning More > Working with ColumnSet Layout > Creating ColumnSet

Glossary Item Box

This section shows how to create a ColumnSet layout in WebGrid.

In This Section

ColumnSet Designer
Learn how to set ColumnSet layout using ColumnSet Designer.

How-to: Create ColumnSet layout programmatically
Learn how to create ColumnSet layout programmatically in WebGrid.

See Also

Getting Started
Getting Started

Overview
WebGrid Features Overview

Other Resources
Walkthrough Topics
How-to Topics


ColumnSet Designer

ColumnSet Designer
See Also Send Feedback
Intersoft WebGrid > Learning More > Working with ColumnSet Layout > Creating ColumnSet > ColumnSet Designer

Glossary Item Box

Other than using code to create a ColumnSet, Intersoft Solutions provides a unique designer to let you manipulate your ColumnSet structure easily and conveniently. You can add/remove columns, merge columns using RowSpan and ColSpan property, resize column width, and many other basic functionalities which are required.

ColSet

As we can see at the ColumnSet picture above, WebGrid.NET Designer can fully support all the needs in creating a ColumnSet.

These are guides to create ColumnSet by using Designer:

  • Add a new ColumnSet into the ColumnSet Designer by pressing the "Add ColumnSet" button.
  • ColumnSet Designer is divided into 4 windows. They are ColumnSet Layout, Table properties, Column Properties and finally RowLayout Properties.
  • ColumnSet layout shows the ColumnSet schema. We can change the layout of the ColumnSet such as length of the column and also choose which column to be added in it.
  • To make ColumnSetheader visible or not and to set the ColumnSet RowCount, we can use Table Properties.
  • Every Column which has been added into the ColumnSet can be configured in Column Properties. We can set many properties in it from length, ColumnType, Caption, Bound Type, until Styles.
  • RowLayout Properties is used to set the Column and Row properties such as Span, Height, Width.

See Also

Overview
Getting Started
WebGrid Features Overview

Other Resources
Walkthrough Topics
How-to Topics


How-to: Create ColumnSet layout programmatically

How-to: Create ColumnSet layout programmatically
See Also Send Feedback
Intersoft WebGrid > Learning More > Working with ColumnSet Layout > Creating ColumnSet > How-to: Create ColumnSet layout programmatically

Glossary Item Box

WebGrid provides a ColumnSet feature which is helpful to show the WebGrid's information/data according to your needs.

In this topic, you will learn how to create ColumnSet programmatically.

To create ColumnSet programmatically

  1. Bind WebGrid to AccessDataSource.
  2. Retrieve WebGrid's structure In the PrepareDataBinding event of the grid, you retrieve the structure of the grid.

    C# Copy Code
    protected void WebGrid1_PrepareDataBinding(object sender, ISNet.WebUI.WebGrid.DataSourceEventArgs e)
{
   WebGrid1.RootTable.ColumnSetSettings.RowCount = 3;
   CreateColumnSet();
}

  3. Create a function and name it CreateColumnSet, then Insert these codes.

    C# Copy Code
       WebGrid1.RootTable.RowLayout = RowLayoutMode.ColumnSet;

       WebGridColumnSet oColumnSet = new WebGridColumnSet();
       oColumnSet.Caption = "Personal Information";
       oColumnSet.Name = "ColumnSet0";
       oColumnSet.ColumnCount = 3;

       WebGrid1.RootTable.ColumnSets.Add(oColumnSet);

       WebGridRowLayoutCollection oRowLayouts = oColumnSet.Layout;

       WebGridRowLayout oRowLayout;

       oRowLayout = new WebGridRowLayout();
       oRowLayout.Col = 0;
       oRowLayout.Row = 0;
       oRowLayout.ColumnMember = "Photo";
       oRowLayout.RowSpan = 3;
       oRowLayouts.Add(oRowLayout);

       oRowLayout = new WebGridRowLayout();
       oRowLayout.Spanned = RowLayoutSpan.Column;
       oRowLayout.Col = 0;
       oRowLayout.Row = 1;
       oRowLayouts.Add(oRowLayout);

       oRowLayout = new WebGridRowLayout();
       oRowLayout.Spanned = RowLayoutSpan.Column;
       oRowLayout.Col = 0;
       oRowLayout.Row = 2;
       oRowLayouts.Add(oRowLayout);

       oRowLayout = new WebGridRowLayout();
       oRowLayout.Col = 1;
       oRowLayout.Row = 0;
       oRowLayout.ColumnMember = "FirstName";
       oRowLayouts.Add(oRowLayout);

       oRowLayout = new WebGridRowLayout();
       oRowLayout.Col = 1;
       oRowLayout.Row = 1;
       oRowLayout.ColumnMember = "Title";
       oRowLayouts.Add(oRowLayout);

       oRowLayout = new WebGridRowLayout();
       oRowLayout.Col = 1;
       oRowLayout.Row = 2;
       oRowLayout.ColumnMember = "BirthDate";
       oRowLayouts.Add(oRowLayout);

       oRowLayout = new WebGridRowLayout();
       oRowLayout.Col = 2;
       oRowLayout.Row = 0;
       oRowLayout.ColumnMember = "LastName";
       oRowLayouts.Add(oRowLayout);

       oRowLayout = new WebGridRowLayout();
       oRowLayout.Col = 2;
       oRowLayout.Row = 1;
       oRowLayout.ColumnMember = "TitleOfCourtesy";
       oRowLayouts.Add(oRowLayout);

       oRowLayout = new WebGridRowLayout();
       oRowLayout.Col = 2;
       oRowLayout.Row = 2;
       oRowLayout.ColumnMember = "HireDate";
       oRowLayouts.Add(oRowLayout);

    //Contact Information

       WebGridColumnSet oColumnSet1 = new WebGridColumnSet();
       oColumnSet1.Caption = "Contact Information";
       oColumnSet1.Name = "ColumnSet1";
       oColumnSet1.ColumnCount = 3;

       WebGrid1.RootTable.ColumnSets.Add(oColumnSet1);

       WebGridRowLayoutCollection oRowLayouts1 = oColumnSet1.Layout;

       WebGridRowLayout oRowLayout1;

       oRowLayout1 = new WebGridRowLayout();
       oRowLayout1.Col = 0;
       oRowLayout1.Row = 0;
       oRowLayout1.ColumnMember = "Address";
       oRowLayouts1.Add(oRowLayout1);

       oRowLayout1 = new WebGridRowLayout();
       oRowLayout1.Col = 1;
       oRowLayout1.Row = 0;
       oRowLayout1.ColumnMember = "City";
       oRowLayouts1.Add(oRowLayout1);

       oRowLayout1 = new WebGridRowLayout();
       oRowLayout1.Col = 2;
       oRowLayout1.Row = 0;
       oRowLayout1.RowSpan = 3;
       oRowLayout1.ColumnMember = "Country";
       oRowLayouts1.Add(oRowLayout1);

       oRowLayout1 = new WebGridRowLayout();
       oRowLayout1.Col = 0;
       oRowLayout1.Row = 1;
       oRowLayout1.ColumnMember = "PostalCode";
       oRowLayouts1.Add(oRowLayout1);

       oRowLayout1 = new WebGridRowLayout();
       oRowLayout1.Col = 1;
       oRowLayout1.Row = 1;
       oRowLayout1.ColumnMember = "Region";
       oRowLayouts1.Add(oRowLayout1);

       oRowLayout1 = new WebGridRowLayout();
       oRowLayout1.Spanned = RowLayoutSpan.Column;
       oRowLayout1.Col = 2;
       oRowLayout1.Row = 1;
       oRowLayouts1.Add(oRowLayout1);

       oRowLayout1 = new WebGridRowLayout();
       oRowLayout1.Col = 0;
       oRowLayout1.Row = 2;
       oRowLayout1.ColumnMember = "HomePhone";
       oRowLayouts1.Add(oRowLayout1);

       oRowLayout1 = new WebGridRowLayout();
       oRowLayout1.Col = 1;
       oRowLayout1.Row = 2;
       oRowLayout1.ColumnMember = "Extension";
       oRowLayouts1.Add(oRowLayout1);

       oRowLayout1 = new WebGridRowLayout();
       oRowLayout1.Spanned = RowLayoutSpan.Column;
       oRowLayout1.Col = 2;
       oRowLayout1.Row = 2;
       oRowLayouts1.Add(oRowLayout1);

       //Notes
       WebGridColumnSet oColumnSet2 = new WebGridColumnSet();
       oColumnSet2.Caption = "Notes";
       oColumnSet2.Name = "ColumnSet2";
       oColumnSet2.ColumnCount = 1;

       WebGrid1.RootTable.ColumnSets.Add(oColumnSet2);

       WebGridRowLayoutCollection oRowLayouts2 = oColumnSet2.Layout;
       WebGridRowLayout oRowLayout2;

       oRowLayout2 = new WebGridRowLayout();
       oRowLayout2.Col = 0;
       oRowLayout2.Row = 0;
       oRowLayout2.RowSpan = 3;
       oRowLayout2.ColumnMember = "Notes";
       oRowLayouts2.Add(oRowLayout2);

       oRowLayout2 = new WebGridRowLayout();
       oRowLayout2.Spanned = RowLayoutSpan.Column;
       oRowLayout2.Col = 0;
       oRowLayout2.Row = 1;
       oRowLayouts2.Add(oRowLayout2);

       oRowLayout2 = new WebGridRowLayout();
       oRowLayout2.Spanned = RowLayoutSpan.Column;
       oRowLayout2.Col = 0;
       oRowLayout2.Row = 2;
       oRowLayouts2.Add(oRowLayout2);

       oRowLayout2 = new WebGridRowLayout();
       oRowLayout2.Spanned = RowLayoutSpan.Column;
       oRowLayout2.Col = 0;
       oRowLayout2.Row = 3;
       oRowLayouts2.Add(oRowLayout2);

  4. Finally, compile the project by pressing Ctrl+Shift+B and run the WebForm. The WebGrid will look like the following snapshot:

See Also

Tasks
Walkthrough: Creating ColumnSet layout in WebGrid
Walkthrough: Configuring multiline row in ColumnSet layout
How-to: Display a ColumnSet layout hierarchically
How-to: Create ColumnSet layout when IList object is bound to WebGrid

Concepts
ColumnSets Layout

References
ColumnSetSettings Class
WebGridColumnSet Class

Other Resources
Walkthrough Topics
How-to Topics


How-to: Create ColumnSet layout when IList object is bound to WebGrid

How-to: Create ColumnSet layout when IList object is bound to WebGrid
See Also Send Feedback

Glossary Item Box

We can also create a ColumnSet when we used IList object bound to WebGrid.

In this topic, you will learn how to create ColumnSet when IList object bound to WebGrid.

To Create ColumnSet when IList object is bound to WebGrid :

  1. Bind WebGrid to IList DataSource.
  2. Right click on WebGrid instance to open WebGrid.Net Designer.
  3. Go to Advanced tab >> RootTable.
  4. In RowLayout Expandable panel choose ColumnSet and Click Design ColumnSet button.
  5. Set focus to the ColumnSet and set the Caption to Invoices.
  6. Set the ColumnSet's HeaderAlignment to Center.
  7. Click ColumnSet Designer and set like the picture below.

  9. Click OK >> Apply >> OK.
  10. Finally, the WebGrid will look like the following snapshot:

See Also

Tasks
Walkthrough: Creating ColumnSet layout in WebGrid
Walkthrough: Configuring multiline row in ColumnSet layout
How-to: Display a ColumnSet layout hierarchically
How-to: Create ColumnSet layout programmatically

Concepts
ColumnSets Layout

References
ColumnSetSettings Class

Other Resources
Walkthrough Topics
How-to Topics


How-to: Create FormatConditions in a specific row and cell

How-to: Create FormatConditions in a specific row and cell
See Also Send Feedback

Glossary Item Box

WebGrid provides FormatConditions feature to help you create your own format for the information/data in WebGrid.

In this topic, you will learn how to create FormatConditions in specific row and cell using table Customers from NorthWind database.

To create FormatConditions in a specific row and cell

Add InitializeLayout server side event:

C# Copy Image Copy Code
using ISNet.WebUI.WebGrid;

private void WebGrid1_InitializeLayout(object sender, ISNet.WebUI.WebGrid.LayoutEventArgs e)
{
   //specific row
   WebGridFormatCondition a = new WebGridFormatCondition();
   a.ColumnMember = "Country";
   a.ConditionText = "UK";
   a.Name = "Format1";
   a.FormatStyle.ForeColor = Color.Red;
   a.TargetObject = ISNet.WebUI.WebGrid.TargetObjectType.Row;

   //specific Cell
   WebGridFormatCondition b = new WebGridFormatCondition();
   b.ColumnMember = "City";
   b.ConditionText = "Madrid";
   b.Name = "Format2";
   b.TargetColumnMember = "City";
   b.FormatStyle.Font.Bold = true;
   b.TargetObject = ISNet.WebUI.WebGrid.TargetObjectType.Cell;

   WebGrid1.RootTable.FormatConditions.Add(a);
   WebGrid1.RootTable.FormatConditions.Add(b);
}

Please note that if you are using RetrieveStructure, then you need to put the above codes in PrepareDataBinding.

See Also

Tasks
How-to: Use CustomConditionText in FormatConditions

Other Resources
Walkthrough Topics
How-to Topics


How-to: Use CustomConditionText in FormatConditions

How-to: Use CustomConditionText in FormatConditions
See Also Send Feedback

Glossary Item Box

Previously, you learn how to create a format condition. However, you can create a custom condition text to apply in FormatConditions.

In this topic, you will learn how to create FormatConditions in specific row and cell using table Customers from NorthWind database.

To use CustomFormatConditions in FormatConditions

Add InitializeLayout server side event:

C# Copy Image Copy Code
using ISNet.WebUI.WebGrid;

private void WebGrid1_InitializeLayout(object sender, ISNet.WebUI.WebGrid.LayoutEventArgs e)
{
   WebGridFormatCondition a = new WebGridFormatCondition();
   a.Name = "Format3";
   a.CustomConditionText = "[ContactName] like 'a%' and [ContactTitle] like 'Sales%'";
   a.FormatStyle.Font.Italic = true;
   a.TargetObject = ISNet.WebUI.WebGrid.TargetObjectType.Row;

   WebGrid1.RootTable.FormatConditions.Add(a);
}

Please note that if you are using RetrieveStructure, then you need to put the above codes in PrepareDataBinding.

See Also

Tasks
How-to: Create FormatConditions in a specific row and cell

Other Resources
Walkthrough Topics
How-to Topics


How-to: Display MessageBox to user if UpdateRow cannot be invoked in a specific case

How-to: Display MessageBox to user if UpdateRow cannot be invoked in a specific case
See Also Send Feedback

Glossary Item Box

MessageBox can be displayed to user if UpdateRow cannot be invoked in a specific case by using ClientAction engine in WebGrid. ClientAction engine is attached per grid instance and designed to bridge the gaps between client and server.

In this topic, you will learn the basic thing on how to display the MessageBox in WebGrid if the UpdateRow can not be invoked.

To display MessageBox in WebGrid

  1. Go to WebGrid properties, server side event.
  2. Attach the WebGrid UpdateRow event into the WebGrid.
  3. Inside of the condition, use ClientAction engine to do a client side Alert.

    C# Copy Image Copy Code
    private void WebGrid1_UpdateRow(object sender, ISNet.WebUI.WebGrid.RowEventArgs e)
{
   if (e.Row.Cells.GetNamedItem("Country").Text == "UK")
   {
      // Display alert to user
      WebGrid1.ClientAction.Alert("You can't update this row!");
      DataRowView drv = (DataRowView)e.Row.DataRow;
      drv.Row.RejectChanges();
      e.ReturnValue = false;
   }
}

  4. Run the project.

See Also

Tasks
How-to: Refresh second Grid after invoking SendCustomRequest of first Grid
How-to: Refresh Child Tables only
How-to: Refresh other controls during update

References
UpdateRow Event

Other Resources
Walkthrough Topics
How-to Topics


How-to: Refresh second Grid after invoking SendCustomRequest of first Grid

How-to: Refresh second Grid after invoking SendCustomRequest of first Grid
See Also Send Feedback

Glossary Item Box

You only need one code to perform refresh to Grid2. The ClientAction engine is able to perform "cross-grid" operation where the grid in context (WebGrid1) is different with grid to refresh (WebGrid2).

In this topic, you will learn the basic thing on how to refresh second grid after invoking OnTheFlyPostBack of first grid.

To refresh second WebGrid after SendCustomRequest

  1. Go to WebGrid properties, server side event.
  2. Attach the WebGrid InitializePostBack event into the WebGrid.
  3. Inside of the e.Action == PostBackAction.Custom condition, use ClientAction engine to perform a client side Refresh method.
  4. C# Copy Code
    private void WebGrid1_InitializePostBack(object sender,ISNet.WebUI.WebGrid.PostbackEventArgs e)
{
   if (e.Action == PostBackAction.Custom)
   {
      // perform business logic here
      WebGrid2.ClientAction.Refresh();
   }
}
  5. Run the project.

See Also

Tasks
How-to: Display MessageBox to user if UpdateRow cannot be invoked in a specific case
How-to: Refresh Child Tables only
How-to: Refresh other controls during update

Other Resources
Walkthrough Topics
How-to Topics


How-to: Refresh Child Tables only

How-to: Refresh Child Tables only
See Also Send Feedback

Glossary Item Box

One of WebGrid's enhancement is its ability to perform refresh on only specific level of child table. This enhancement is made for scenarios where only child table needs to be refreshed without has to refresh the whole grid.

To refresh WebGrid Child Tables only

  1. Add a function in client side.
  2. Refresh the child table using Refresh method.

    JavaScript Copy Code
    function refreshChild()
{
   var grid = ISGetObject("WebGrid1");
   grid.Tables["Orders"].Refresh();
}

  3. Run the project.

See Also

Tasks
How-to: Display MessageBox to user if UpdateRow cannot be invoked in a specific case
How-to: Refresh second Grid after invoking SendCustomRequest of first Grid
How-to: Refresh other controls during update

Other Resources
Walkthrough Topics
How-to Topics


How-to: Refresh other controls during update

How-to: Refresh other controls during update
See Also Send Feedback

Glossary Item Box

WebGrid has an ability refresh other server controls during the OnTheFly-PostBack context. The architecture now provides these functionalities and therefore resulting in greater user experience.

To refresh other controls during WebGrid update.

This feature can be utilized in 2 ways:
  • Manual mode. For even greater control, developers can decide which controls to be refreshed and which are not.
    1. Attach an UpdateRow event into a grid.
    2. To refresh individual control, use ClientAction's RenderControl method.

      C# Copy Code
        WebGrid.ClientAction.RenderControl(TextBox1);

    3. Run the project.

  • Automatic mode. This mode is suitable when you have several controls to be refreshed. This method will intelligently determines which controls have been modified since its ViewState initialization in LoadViewState phase.
    1. Attach an UpdateRow event into a grid.
    2. To refresh multiple modified controls automatically, use ClientAction's RefreshModifiedControls method.

      C# Copy Code
        WebGrid1.ClientAction.RefreshModifiedControls();

    3. Run the project.

See Also

Tasks
How-to: Display MessageBox to user if UpdateRow cannot be invoked in a specific case
How-to: Refresh second Grid after invoking SendCustomRequest of first Grid
How-to: Refresh Child Tables only

Other Resources
Walkthrough Topics
How-to Topics


How-to: Reconfigure the 'Enter' key functions on EditMode

How-to: Reconfigure the 'Enter' key functions on EditMode
See Also Send Feedback

Glossary Item Box

Many User would like to mimic the behavior of Microsoft Excel while editing some cells contents. In MS.Excel, after users modified a cell content followed by pressing Enter key the next cell at the next row (rowIndex+1) at the same column will be directly highlighted.

In this topic, you will learn the how to reconfigure the "Enter" key function on EditMode.

To reconfigure the "Enter" key functions on EditMode.

  1. Bind WebGrid to Hierarchical ISDataSource (using NorthWind Customers and Orders table)
  2. Set AllowEdit to true.
  3. Add OnEditKeyDown client side event:

  4. JavaScript Copy Image Copy Code
    function WebGrid1_OnEditKeyDown(controlId)
    {
       if(event.keyCode == 13) {
        //cancel the event as it'll be handled manually
        event.returnValue = false;

        var grid = ISGetObject("WebGrid1");

        //get currently active edit cell
        var ac = grid.GetActiveEditCell();

        if(ac.rowElement.type == "Record") {
         //get the table object
         var tbl = grid.Tables[ac.tblName];
         grid.ExitEdit(1,0,0) // exit and update the row if dirty

         //find out if the table of current row is parent
         var isParent = (tbl.GetChildTables().length > 0)?true : false;

         window.setTimeout(function() {SelectNext(ac, isParent);},500);

         //you can try to remove this line if you receive a javascript error
         return false;
        }
       }
       return true;
      }

      function SelectNext(ac, isParent) {
       var curRow = ac.rowElement;
       var tblElm = wgGetTable(curRow);
       var curRowIndex = curRow.rowIndex;

       //if a table is a parent, the index numbering increases by 2
       var i = (isParent)? 2 : 1;

       //check if current row is the last row of the table
       if(curRowIndex < tblElm.rows.length-i){
        //get destination now
        var destRow = wgGetRowByPosition(tblElm, curRowIndex+i);

        //highlight the destination row
        //wgHighlightROw(destRow);

        //get the column name
        var cellName = wgGetColNameByCell(ac.element);

        //get the destination cell
        var destCell = wgGetCellByName(destRow, cellName);

        //select nextRow and highlight the destination cell
        window.setTimeout(function() { MoveRow(destRow,destCell);}, 500);

       }
      }

      function MoveRow(destRow, destCell)
      {
       wgGetRowByElement(destRow).Select();
       wgHighlightEditCell(destCell);
      }

See Also

Tasks
Walkthrough: Updating the changes in WebGrid to physical Database
How-to: Calculate a cell after a value is filled
How-to: Maintain the new row's value when there is error during adding action

References
AllowEdit Property
OnEditKeyDown Property

Other Resources
Walkthrough Topics
How-to Topics


How-to: Calculate a cell after a value is filled

How-to: Calculate a cell after a value is filled
See Also Send Feedback

Glossary Item Box

Sometimes when you finished editing a cell, you want other cell to be calculated based on the value that we have inputted.

In this topic, you will learn how to calculate a cell after a value is filled.

To calculate a cell after a value is filled.

  1. Use NorthWind database (table : Order Details).
  2. Add OnExitEditMode client side event

    JavaScript Copy Image Copy Code
    function WebGrid1_OnExitEditMode(controlId, tblName, editObject)
      {
       var WebGrid1 = ISGetObject(controlId);
       var cell = wgGetCellByElement(editObject.cellElement);
       var colName = cell.Name;

       if(colName=="Quantity")
       {
        var row = cell.Row;
        var disc = parseFloat(row.GetCells().GetNamedItem("Discount").Text);
        var quantity = parseInt(editObject.element.value);

        if(disc == 0) {
         result = quantity;
        }
        else {
         result = quantity * disc;
        }
        row.GetCells().GetNamedItem("UnitPrice").SetText(String(result), true);
       }

       return true
    };

Column's UnitPrice value will be calculate based on Quantity * Discount

See Also

Tasks
Walkthrough: Updating the changes in WebGrid to physical Database
How-to: Reconfigure the "Enter" key functions on EditMode
How-to: Maintain the new row's value when there is error during adding action

References
OnExitEditMode Property

Other Resources
Walkthrough Topics
How-to Topics


How-to: Maintain the new row's value when there is error during adding action

How-to: Maintain the new row's value when there is error during adding action
See Also Send Feedback

Glossary Item Box

Sometimes when you perform adding new row, an error will be occurred because you input the wrong value. The default settings is all values that you have entered into the newRow will be disappeared.

In this topic, you will how to maintain the new row's value when there is error during adding action.

To maintain the new row's value when there is error during adding action.

  1. Open WebGrid.NET's Designer.
  2. Set focus on Popular Settings - Click See all properties.
  3. Set ResetNewRowValuesOnError to False.

Now, if you try to insert the KeyValue that exists in the WebGrid (eg : ALFKI --> NorthWind's CustomerID) to the new row an error will occur, but all of the values that we have entered will still exist.

See Also

Tasks
Walkthrough: Updating the changes in WebGrid to physical Database
How-to: Reconfigure the "Enter" key functions on EditMode
How-to: Calculate a cell after a value is filled

References
ResetNewRowValuesOnError Property

Other Resources
Walkthrough Topics
How-to Topics


How-to: Invoke Export feature programmatically

How-to: Invoke Export feature programmatically
See Also Send Feedback

Glossary Item Box

WebGrid now has an ability to invoke the export feature without using 'Export' button on the right corner side of the grid. The export feature now can be invoked programmatically without the users interference anymore.

To Invoke Export feature programmatically in WebGrid

  1. Drag WebGrid to the WebForm.
  2. Invoke ExportGrid() method to accept DynARInfo object.

  3. C# Copy Image Copy Code
    private void Button1_Click(object sender, System.EventArgs e)
{
   // invoke the grid's export feature
   // through the server side
   WebGrid1.ExportGrid(SetDynInfo());
}

private DynARInfo SetDynInfo()
{
   // configure the DynARInfo object
   // as the parameter for the ExportGrid() method

   // need to configure 4 things :
   // dynInfo.ReportType
   // dynInfo.ReportPath
   // dynInfo.IISReportPath
   // dynInfo.DynPageOrientation

   DynARInfo dynInfo = new DynARInfo("html", Server.MapPath("~/TempReports") + @"\");
   dynInfo.IISReportPath = "/TempReports/";
   dynInfo.DynPageOrientation = PageOrientation.Portrait;
   return dynInfo;
}

  4. Run the project.

See Also

Tasks
Walkthrough: Allowing Export in WebGrid
How-to: Customize Export function
How-to: Export text when WebValueList is used
How-to: Use CacheToDisk feature to reduce memory usage
How-to: Set a different location for CacheToDisk feature

References
AllowExport Property
DynARInfo Class
ExportGrid() Method

Other Resources
Walkthrough Topics
How-to Topics


How-to: Export text when WebValueList is used

How-to: Export text when WebValueList is used
See Also Send Feedback

Glossary Item Box

WebValueList is used to translate value to text in a WebGridColumn object. If you use WebValueList in one of the columns and export the data, the value of the column (not the text) will be exported.

To export text when WebValueList is used

  1. Drag WebGrid to the WebForm.
  2. Go to WebGrid properties and expand server side event.
  3. Attach the WebGrid Export event into the WebGrid.
  4. Specify the EnableValueList property to True.

    C# Copy Image Copy Code
    private void WebGrid1_Export(object sender, ISNet.WebUI.WebGrid.ExportEventArgs e)
    {
      e.ReportInfo.EnableValueList = true;
    }

  5. Run the project.

See Also

Tasks
How-to: Invoke Export feature programmatically
How-to: Customize Export function
How-to: Use CacheToDisk feature to reduce memory usage
How-to: Set a different location for CacheToDisk feature

References
AllowExport Property
Export Event

Other Resources
Walkthrough Topics
How-to Topics


How-to: Integrate Linked WebCombo in WebGrid

How-to: Integrate Linked WebCombo in WebGrid
See Also Send Feedback

Glossary Item Box

Linked WebCombo can be integrated into grid columns, and automatically called when you enter into grid edit mode in appropriate column.

In this topic, you will learn how to include 2 combos which are linked each other into 2 grid columns.

To include Linked WebCombos into WebGrid

  1. Drag and drop a WebGrid to your form and bind it .
  2. Drag and drop 2 webcombos into the form and bind them.
  3. Go to the WebCombo2 Designer and Expand the LinkSettings property.
  4. Set the Enabled property to True.
  5. Set the FilterDataMember property to Country.
  6. Set the ParentWebComboID property to WebCombo1.

  7. Go to the Column1 and Column2 in WebGrid then set the Edit Control Type to WebComboNET in WebGrid Designer, Advanced.
  8. Run the project.

See Also

Tasks
Walkthrough: Integrating WebCombo in WebGrid

Concepts
Intersoft WebCombo.NET Integration

Other Resources
Walkthrough Topics
How-to Topics


How-to: Specify the Localization folder in web.config

How-to: Specify the Localization folder in web.config
See Also Send Feedback

Glossary Item Box

Beside using WebGrid's User Interface to set the Localization folder path, you can also specify the Localization folder path in web.config.

In this topic, you will learn how to specify the Localization folder in web.config.

To specify the Localization folder in web.config

Add the following code in web.config:

web.config Copy Code
<configuration>
<appSettings>
   <add key="ISNet.WebUI.WebGrid.v4_0_6200.LocalizationDirectory" value="~/CommonLibrary/WebGrid/V4_0_6200/Localization/" />
</appSettings>
</configuration>

See Also

Tasks
Walkthrough: Changing the default Localization Text in Localization Manager
Walkthrough: Using French culture in WebGrid
Walkthrough: Specifying custom language used in WebGrid
How-to: Specify a TextItem programmatically

Concepts
Localization Manager

Other Resources
Walkthrough Topics
How-to Topics


How-to: Specify a TextItem programmatically

How-to: Specify a TextItem programmatically
See Also Send Feedback

Glossary Item Box

Beside you can specify a TextItem using WebGrid's Designer, you also can specify TextItem programmatically.

In this topic, you will learn how to specify a TextItem programmatically, such as set CommonText "Ready" to "Start".

To Specify a TextItem Programmatically.

Add the following code in InitializeLayout server side event:

C# Copy Code
private void WebGrid1_InitializeLayout(object sender, ISNet.WebUI.WebGrid.LayoutEventArgs e)
{
   WebGridTextItem oItem = new WebGridTextItem("CommonText/Ready","Start");
   WebGrid1.LayoutSettings.TextSettings.TextItems.Add(oItem);
}

See Also

Tasks
Walkthrough: Changing the default Localization Text in Localization Manager
Walkthrough: Using French culture in WebGrid
Walkthrough: Specifying custom language used in WebGrid
How-to: Specify the Localization folder in web.config

Concepts
Localization Manager

References
WebGridTextItem Class
TextSettings Property
TextValue Property

Other Resources
Walkthrough Topics
How-to Topics


How-to: Set masked formatting to a cell

How-to: Set masked formatting to a cell
See Also Send Feedback

Glossary Item Box

WebGrid has a client side built-in ability to validate masked data display.

In this topic, you will learn the basic thing on how to apply masked feature in WebGrid.

To set DateTime to a Column

  1. Open WebGrid.NET Designer.
  2. Go to Advanced.
  3. In the appropriate date column set DataType, for example: System.DateTime
  4. Set DataFormatString property, for example: MM/dd/yyyy.
  5. Set the EditType to CalendarDropDown or CalendarCombo.
  6. Click OK to apply the changes.

    To set Currency to a Column

    1. Open WebGrid.NET Designer.
    2. Go to Advanced.
    3. In the appropriate date column set DataType, for example: System.Double.
    4. Set DataFormatString property, for example: $##,###.00.
    5. Set the AggregateFunction property, for example: Sum.
    6. Click OK to apply the changes.

    To set Number Format to a Column

    1. Open WebGrid.NET Designer.
    2. Go to Advanced.
    3. In the appropriate date column set DataType, for example to System.Single.
    4. Set DataFormatString property, for example: #0.##%.
    5. Click OK to apply the changes.

    See Also

    References
    DataFormatString Property
    AggregateFunction Property
    EditType Property

    Other Resources
    Walkthrough Topics
    How-to Topics


How-to: Retrieve Preview Row's text

How-to: Retrieve Preview Row's text
See Also Send Feedback

Glossary Item Box

WebGrid Preview Row's text can be obtained in client side.

In this topic, you will learn how to get the preview row text in WebGrid.

To get Preview Row's text in WebGrid

  1. Drag WebGrid to your form and bind it .
  2. Specify the PreviewRow settings in the grid.
  3. Create a function at the client side and use following code.

  4. JavaScript Copy Image Copy Code
    var grid = ISGetObject("WebGrid1");
var selRow = grid.GetSelectedObject().GetRowObject();
var rootRow = wgGetRootRow(selRow);
alert(rootRow.keyValue); // return "2";

var prRow = wgGetPreviewRow(rootRow);
var prCell = wgGetPreviewRowCell(prRow);
alert(prCell.innerText);

  5. Run the project.

See Also

Tasks
Walkthrough: Using Preview Row in WebGrid

Concepts
Preview Row

References
PreviewRowSettings Class

Other Resources
Walkthrough Topics
How-to Topics


How-to: Remove (+) sign for Self Reference LoadOnDemand rows that contain no Child Row

How-to: Remove (+) sign for Self Reference LoadOnDemand rows that contain no Child Row
See Also Send Feedback

Glossary Item Box

WebGrid SelfReference LoadOnDemand can remove the (+) sign if the row contains no child row to be expanded.

In this topic, you will learn how to remove the (+) mark on self reference load on demand in WebGrid.

To Remove (+) sign in Self Reference LoadOnDemand rows in WebGrid

  1. Drag and drop a WebGrid to your form.
  2. Drag and drop ISDatasource and specify Self Reference LoadOnDemand in WebGrid.
  3. In InitializeRow event at the server side, use e.Row.SelfRefChildNotExpandable = true; code to remove the + button.
  4. C# Copy Code
    private void WebGrid1_InitializeRow(object sender, ISNet.WebUI.WebGrid.RowEventArgs e)
{
        OleDbCommand comm = new OleDbCommand("select * from employees where reportsto = " + e.Row.KeyValue.ToString(),oleDbConnection1);
        oleDbConnection1.Open();
        OleDbDataReader dtr = comm.ExecuteReader();

        if(!dtr.HasRows)
                e.Row.SelfRefChildNotExpandable = true;

        oleDbConnection1.Close();
}

See Also

Tasks
Walkthrough: Creating Self Reference WebGrid
Walkthrough: Creating Self Reference LoadOnDemand WebGrid

References
SelfRefChildNotExpandable Property
InitializeRow Event

Other Resources
Walkthrough Topics
How-to Topics


How-to: Retrieve a different VirtualPageSize on a specific condition

How-to: Retrieve a different VirtualPageSize on a specific condition
See Also Send Feedback

Glossary Item Box

Different VirtualPageSize in VirtualLoad can be retrieved in a specific condition. You can navigate to anywhere in grid paging.

To Implement different VirtualPageSize in WebGrid

  1. Set the PagingMode to VirtualLoad.
  2. Set the VirtualPageSize property to a value.
  3. In the JavaScript, use the following code:

    JavaScript Copy Code
    var timeout = 1000;
function go_to()
{
    var rowIndex = document.getElementById("txtGoto").value;
    move(rowIndex);
}

function move(rowIndex)
{
    var grid = ISGetObject("WebGrid1");
    if (grid.TotalLoadedRows < rowIndex)
    {
        wgLoadMore('WebGrid1');
        setTimeout(function() {move(rowIndex);},timeout)
    }
    else
    {
        grid.RootTable.GetRow(rowIndex-1).Select();
    }
}

  4. Run the project.

See Also

Tasks
Walkthrough: Setting Virtual Load in WebGrid
Walkthrough: Updating footer when loading data on demand
How-to: Implement custom Virtual Load

References
PagingMode Property
VirtualPageSize Property

Other Resources
Walkthrough Topics
How-to Topics


How-to: Implement custom Virtual Load

How-to: Implement custom Virtual Load
See Also Send Feedback

Glossary Item Box

Custom VirtualLoad is one of VirtualLoad features which allow developer to setup a grid with their own implementation and logic for fetching the data. Note that sorting, editing and all other data-aware functionalities can work in this mode, except Grouping since that Grouping requires all rows to be loaded.

In this topic, you will learn how to implement the custom virtual load in WebGrid.

To Implement custom Virtual Load in WebGrid

  1. Set the PagingMode to VirtualLoad.
  2. Set the VirtualLoadMode to Custom.
  3. Drag ISDataSource control from toolbox to the designer surface.
  4. Configure Data Source for the newly created ISDataSource.
  5. Select DataSet for the SchemaType.
  6. Click Schema Name dropdown and select dsNorthWind from the list.
  7. In the next dialog, click AutoGenerate button which is located at the most bottom. Click Finish.
  8. Drag WebGrid control from toolbox to the designer surface.
  9. Set the DataSourceID to ISDataSource1.
  10. In the Connect to DataSource dialog, select Orders table as root table and select Retrieve Structure, then click OK.
  11. Right click on ISDataSource1 and launch the designer, set the Orders table's SelectCount property to GetCount.
  12. For the WebGrid, set the PagingMode to VirtualLoad and VirtualLoadMode to Custom.
  13. Write codes that handle virtual load and the total row count in App_Code. For reference, see the codes in App_Code\dsNorthwind_Extended.cs.
  14. Run the page in browser.

See Also

Tasks
Walkthrough: Setting Virtual Load in WebGrid
Walkthrough: Updating footer when loading data on demand
How-to: Retrieve a different VirtualPageSize on a specific condition

References
PagingMode Property
VirtualLoadMode Property

Other Resources
Walkthrough Topics
How-to Topics


How-to: Filter invisible column

How-to: Filter invisible column
See Also Send Feedback

Glossary Item Box

WebGrid provides a filtering feature for invisible column.

In this topic, you will learn how to apply Filtering invisible column in WebGrid.

To filter invisible column in WebGrid

  1. Open WebGrid.NET Designer.
  2. Select the Allow Filtering properties in QuickStart - Popular Settings - Main Features section
  3. In Advanced-WebGrid-Layout Settings, set AllowFilter to Yes.
  4. Go to Advanced-RootTable-Columns, select one of the column that you want to set invisible(i.e ContactName), set Visible to false.
  5. Go back to Advanced-RootTable-FilterColumns, click add, then set the ColumnMember=ContactName, FilterText=Ana, FilterType=Like.
  6. Click OK to apply the changes.
  7. Run the project.
  8. The WebGrid will automatically filter the invisible column.

See Also

Tasks
How-to: Perform filtering data and hide Filter Bar in WebGrid
How-to: Add and remove Filtered Column programmatically

References
AllowFilter Property
Visible Property
FilterText Property
FilterType Property

Other Resources
Walkthrough Topics
How-to Topics


How-to: Add and remove Filtered Column programmatically

How-to: Add and remove Filtered Column programmatically
See Also Send Feedback

Glossary Item Box

Filtering feature can be added or removed programmatically.

In this topic, you will learn how to programmatically add and remove filter in WebGrid.

To add filter programmatically in WebGrid

Server Side

  1. Drag a standard button to your WebForm.
  2. On ButtonClick event handler, put the following code:

    C# Copy Image Copy Code
    private void Button1_Click(object sender, System.EventArgs e)
{
   WebGridFilter fltr = new WebGridFilter("ContactName", ColumnFilterType.Like, "Ana");
   WebGrid1.RootTable.FilteredColumns.Add(fltr);
}

  3. Run the Project.

Client Side

  1. Drag a HTML button to your form.
  2. Create AddFilter() functions in client-side:

    JavaScript Copy Image Copy Code
    function AddFilter()
{
   var grid = ISGetObject("WebGrid1");
   var newFilter = new WebGridFilter();
   newFilter.ColumnMember = "ContactName";
   newFilter.FilterType = "Like";
   newFilter.FilterText = "Ana";
   grid.RootTable.FilteredColumns.Add(newFilter);
   grid.RootTable.UpdateUI();
   grid.Refresh();
}

  3. Invoke AddFilter() function in <INPUT type="button" value="Add Filter" onclick="AddFilter()">
  4. Run the Project.

To remove filter programmatically in WebGrid

Server Side

  1. Drag a standard button to your WebForm.
  2. On ButtonClick event handler, put the following code:

    C# Copy Image Copy Code
    private void Button2_Click(object sender, System.EventArgs e)
{
  WebGrid1.RootTable.FilteredColumns[0].FilterType = ColumnFilterType.NotSet;
  WebGrid1.RootTable.FilteredColumns[0].FilterText = "";
}

  3. Run the Project.

Client Side

  1. Drag a HTML button to your form.
  2. Add RemoveFilter() functions in client-side:

    JavaScript Copy Image Copy Code
    function RemoveFilter()
{
  var grid = ISGetObject("WebGrid1");
  grid.RootTable.FilteredColumns.Remove(grid.RootTable.FilteredColumns[0], true);
  grid.RootTable.FilteredColumns[0].FilterType = "";
  grid.RootTable.FilteredColumns[0].FilterText = "";
  grid.RootTable.UpdateUI();
  grid.Refresh();
}

  3. Call RemoveFilter() function in <INPUT type="button" value="Remove Filter" onclick="RemoveFilter()">.
  4. Run the Project.

See Also

Tasks
How-to: Filter invisible column

References
AllowFilter Property
ButtonClick Event
FilterType Property
FilterText Property

Other Resources
Walkthrough Topics
How-to Topics


How-to: Customize Export function

How-to: Customize Export function
See Also Send Feedback

Glossary Item Box

Sometimes when you export WebGrid, you would like the output such as the font, WebGrid's column or WebGrid's column width to be different.

In this topic, you will learn how to customize export function.

To customize export function

  1. Binding WebGrid to AccessDataSource.
  2. In the Export server side event of WebGrid.

    C# Copy Code
       e.Table.Columns.GetNamedItem("CustomerID").Visible = false; //hidden CustomerID's column
       e.Table.Columns.GetNamedItem("Address").Width = Unit.Pixel(300); //set Address's column width to 300px

       //Set Export's font
   e.ReportInfo.DynFonts = new DynARFonts(new Font("Tahoma",15), null, null, null, null, null, null, null, null);
       e.ReportInfo.ReportName = "WebGridExport"; //set WebGrid export file name

See Also

Tasks
Walkthrough: Allowing Export in WebGrid
How-to: Invoke Export feature programmatically
How-to: Export text when WebValueList is used
How-to: Use CacheToDisk feature to reduce memory usage
How-to: Set a different location for CacheToDisk feature

References
AllowExport Property
Export Event
ReportInfo Property

Other Resources
Walkthrough Topics
How-to Topics


How-to: Perform filtering data and hide Filter Bar in WebGrid

How-to: Perform filtering data and hide Filter Bar in WebGrid
See Also Send Feedback

Glossary Item Box

WebGrid provides a filtering feature which is very powerful to filter data based on several filter types, such as LIKE, BETWEEN, GREATER THAN and many others.

In this topic, you will learn the basic thing on how to apply Filtering feature in WebGrid.

To filter data in WebGrid

  1. Open WebGrid.NET Designer.
  2. In Layout Settings, set AllowFilter to Yes.
  3. Click OK to apply the changes.
  4. Run the project.
  5. Select the Filter Row and type the data you want to filter.
  6. Click the blue icon to display the filter types.
  7. Select one of the filter types and click Apply All Filters.
  8. Finally, WebGrid will automatically filter the data.

To hide Filter Bar in WebGrid

  1. Open WebGrid.NET Designer.
  2. In Layout Settings, set FilterBarVisible to True.
  3. Click OK to apply the changes.
  4. Run the project and WebGrid will hide the Filter Bar when it is in Filter mode.

See Also

Tasks
Walkthrough: Applying Custom Filter Feature in WebGrid
Walkthrough: Using DropDownList in Filter Row

References
AllowFilter Property
FilterBarVisible Property

Other Resources
Walkthrough Topics
How-to Topics


How-to: Perform grouping and ungrouping in WebGrid

How-to: Perform grouping and ungrouping in WebGrid
See Also Send Feedback

Glossary Item Box

WebGrid provides a grouping feature which is very helpful for the user to perform data grouping.

In this topic, you will learn the basic thing on how to apply Grouping feature in WebGrid.

To group data in WebGrid

  1. Open WebGrid.NET Designer.
  2. Select the Allow Grouping properties in QuickStart - Popular Settings - Main Features section
  3. Click OK to apply the changes.
  4. Run the project.
  5. Select the column that you want to group.
  6. Right click the column header and choose Group By this field.
  7. Or, you can right click the column header and choose Group By Box then you can drag the column header to the black box above the WebGrid. You can display GroupByBox as well when the page loads by setting GroupByBoxVisible to True.
  8. Finally, WebGrid will automatically group the data.

To ungroup data in WebGrid

  1. Drag the column header from the GroupBox to the WebGrid.
  2. WebGrid will automatically ungroup the data.

See Also

References
AllowGrouping Property
GroupByBoxVisible Property

Other Resources
Walkthrough Topics
How-to Topics


How-to: Perform sorting data and apply multiple sorting in WebGrid

How-to: Perform sorting data and apply multiple sorting in WebGrid
See Also Send Feedback

Glossary Item Box

WebGrid provides a sorting feature which is very useful to sort data in ascending or descending behavior.

In this topic, you will learn the basic thing on how to apply sorting feature in WebGrid.

To sort data in WebGrid

  1. Open WebGrid.NET Designer.
  2. In Layout Settings, set AllowSorting to Yes.
  3. Click OK to apply the changes.
  4. Run the project.
  5. Click on any header columns to apply sorting data.

To apply multiple sorting data in WebGrid

  1. Open WebGrid.NET Designer.
  2. In Layout Settings, set HeaderClickAction to SortMulti.
  3. Click OK to apply the changes.
  4. Run the project.
  5. Click on any header columns and press SHIFT key to apply multiple sorting data.

See Also

Tasks
Walkthrough: Applying CustomSort in WebGrid

References
AllowSorting Property
HeaderClickAction Property

Other Resources
Walkthrough Topics
How-to Topics


How-to: Use DropDownList as EditType of a WebGridColumn

How-to: Use DropDownList as EditType of a WebGridColumn
See Also Send Feedback

Glossary Item Box

WebGrid provides a feature to set EditType to DropDownList. To perform this feature you have to use WebValueList.

In this topic, you will learn how to use DropDownList as EditType.

To set EditType WebGridColumn to DropDownList using Designer

  1. Right click on WebGrid and click on WebGrid.Net Designer.
  2. Go to Advanced tab >> RootTable >> Columns.
  3. Set focus to ProductID's column and find Editing Expandable panel.
  4. Change TextBox to DropDownList.
  5. Click Apply >> OK.
  6. The picture will look like following:

  7. Finally, the WebForm will look like the following snapshot:

See Also

Tasks
Walkthrough: Using MultiLine TextBox
Walkthrough: Using CheckBox
Walkthrough: Using Calendar DropDown
Walkthrough: Using Calendar Combo
How-to: Perform Bulk Update on a Button Click event

References
EditType Property

Other Resources
Walkthrough Topics
How-to Topics


How-to: Select a row from server side

How-to: Select a row from server side
See Also Send Feedback

Glossary Item Box

WebGrid provides features to select a row from server side.

In this topic, you will learn the basic thing on how to select a row from server side.

To Select a row from Server side

  1. Add following codes inside the InitializeRow event handler.

    C# Copy Image Copy Code
    private void WebGrid1_InitializeRow(object sender, ISNet.WebUI.WebGrid.RowEventArgs e)
{
        string customerID = e.Row.Cells.GetNamedItem("CustomerID").Text;
        if(customerID == "BLONP")
        {
                WebGrid1.SetFocus();
                e.Row.Selected = true;
        }
}

  2. Compile and run the WebForm.

See Also

Tasks
Walkthrough: Using ExpandChildRow to expand child tables

References
InitializeRow Event

Other Resources
Walkthrough Topics
How-to Topics


How-to: Display group by box

How-to: Display group by box
See Also Send Feedback

Glossary Item Box

When users set this property to False, the GroupByBox will not be visible even though the AllowGrouping is set to Yes.

In this topic, you will learn the basic thing on how to show the WebGrid's GroupByBox.

To display GroupByBox

  1. Right click on the WebGrid and choose WebGrid.NET Designer.
  2. Set focus on User Interface and select "Show Group Box" checkbox.

See Also

Tasks
How-to: Perform grouping and ungrouping in WebGrid
How-to: Hide/Show the grouped column when the column is grouped
How-to: Prevent grouping on specific columns using OnColumnGroup

References
GroupByBox Property

Other Resources
Walkthrough Topics
How-to Topics


How-to: Hide/Show status bar

How-to: Hide/Show status bar
See Also Send Feedback

Glossary Item Box

By default, WebGrid will show the status bar. However, you can also hide this status bar.

In this topic, you will learn the basic thing on how to hide WebGrid's status bar.

To hide/Show status bar

  1. Right click on the WebGrid and choose WebGrid.NET Designer.
  2. Focus on User Interface.
  3. Uncheck "Show Status Bar" check box.

See Also

Tasks
How-to: Hide the help button
How-to: Hide/Show the refresh button

Other Resources
Walkthrough Topics
How-to Topics


How-to: Display context menu in WebGrid

How-to: Display context menu in WebGrid
See Also Send Feedback

Glossary Item Box

By default, WebGrid will show the context menu. You can right click on WebGrid to display or hide the context menu.

In this topic, you will learn the basic thing on how to show/hide the WebGrid's context menu.

To hide context menu in WebGrid

  1. Right click on the WebGrid and choose WebGrid.NET Designer.
  2. Focus on Popular Settings.
  3. Uncheck "Allow Context Menu" checkbox.

See Also

Tasks
How-to: Customize Filter context menu
How-to: Add/Remove a menu in WebGrid's context menu
How-to: Add a SubMenu in WebGrid's context menu

References
AllowContextMenu Property

Other Resources
Walkthrough Topics
How-to Topics


How-to: Disable alternating color

How-to: Disable alternating color
See Also Send Feedback

Glossary Item Box

By default, WebGrid will enable the alternating color. However, you can also disable WebGrid's alternating color.

In this topic, you will learn the basic thing on how to disable the WebGrid's alternating color.

To disable alternating color

  1. Right click on the WebGrid and choose WebGrid.NET Designer.
  2. Focus on Popular Settings and click see all properties.
  3. Set AlternatingColor to False.

See Also

Tasks
How-to: Change the ForeColor of all odd rows
How-to: Change the ForeColor of a cell based on a specific condition

References
AlternatingColors Property

Other Resources
Walkthrough Topics
How-to Topics


How-to: Hide the help button

How-to: Hide the help button
See Also Send Feedback

Glossary Item Box

By default, WebGrid will show a help button in the status bar. However, you can also hide this help button.

In this topic, you will learn the basic thing on how to hide the WebGrid's help button.

To hide the help button

  1. Right click on the WebGrid and choose WebGrid.NET Designer.
  2. Focus on User Interface.
  3. Uncheck "Show Help Command" checkbox.

See Also

Tasks
How-to: Hide/Show status bar
How-to: Hide/Show the refresh button

Other Resources
Walkthrough Topics
How-to Topics


How-to: Set AutoWidth and AutoHeight in WebGrid

How-to: Set AutoWidth and AutoHeight in WebGrid
See Also Send Feedback

Glossary Item Box

Sometimes you need WebGrid to automatically appear full screen based on your page's width and height. You can use AutoWidth and AutoHeight to perform this scenario.

In this topic, you will learn how to set WebGrid's AutoWidth and AutoHeight.

To set AutoWidth and AutoHeight in WebGrid

  1. Right click on the WebGrid to open WebGrid.NET Designer.
  2. Focus on Popular Settings - Layout Expandable panel.
  3. Checked "Automatically resize WebGrid to fit available width" checkbox.
  4. Checked "Automatically resize WebGrid to fit available height" checkbox.

See Also

Tasks
How-to: Autofit all columns in WebGrid
How-to: Set one of the columns as AutoWidth while the others fit the WebGrid

Other Resources
Walkthrough Topics
How-to Topics


How-to: Hide/Show the column headers

How-to: Hide/Show the column headers
See Also Send Feedback

Glossary Item Box

By default, WebGrid will display its header. In some cases, you will need to hide this header.

In this topic, you will learn how to hide/show the WebGrid's column headers.

To hide/show the column headers

  1. Right click on the WebGrid to open WebGrid.NET Designer.
  2. Focus on User Interface.
  3. Unchecked "Show Column Headers" checkbox to hide the column headers.

See Also

Tasks
How-to: Hide/Show the column footers
How-to: Hide/Show the ColumnSet layout's headers
How-to: Hide/Show the row headers
How-to: Hide/Show the table header

Other Resources
Walkthrough Topics
How-to Topics


How-to: Hide/Show the column footers

How-to: Hide/Show the column footers
See Also Send Feedback

Glossary Item Box

By default, WebGrid will show the footers column. In some cases, you will need to hide the footer.

In this topic, you will learn how to hide/show the WebGrid's column footers.

To hide/show the column footers

  1. Right click on the WebGrid to open WebGrid.NET Designer.
  2. Focus on User Interface.
  3. Checked "Show Column Footers" checkbox to show the column footers.

See Also

Tasks
How-to: Hide/Show the column headers
How-to: Hide/Show status bar
How-to: Hide/Show the refresh button

References
ColumnFooters Property

Other Resources
Walkthrough Topics
How-to Topics


How-to: Hide/Show the ColumnSet layout's headers

How-to: Hide/Show the ColumnSet layout's headers
See Also Send Feedback

Glossary Item Box

By default, WebGrid will show the ColumnSet layout's header. However, you are able hide the header as well.

In this topic, you will learn how to hide/show ColumnSet layout's header.

To hide/show the ColumnSet layout's headers

  1. Right click on the WebGrid to open WebGrid.NET Designer.
  2. Focus on User Interface.
  3. Uncheck "Show ColumnSet Header" checkbox to hide the ColumnSet layout's headers.

See Also

Tasks
How-to: Hide/Show the column headers
How-to: Hide/Show the column footers

Other Resources
Walkthrough Topics
How-to Topics


How-to: Remove the gridlines

How-to: Remove the gridlines
See Also Send Feedback

Glossary Item Box

You will have vertical and horizontal gridlines as a default WebGrid's gridlines. We can remove these gridlines so that WebGrid will only have either vertical or horizontal gridline. You can also remove both vertical and horizontal gridlines.

In this topic, you will learn how to remove the WebGrid's gridlines.

To remove the gridlines

  1. Right click on the WebGrid to open WebGrid.NET Designer.
  2. Focus on Popular Settings - Click see all properties.
  3. Set GridLines to None to remove both vertical and horizontal gridlines.

See Also

References
GridLines Property

Other Resources
Walkthrough Topics
How-to Topics


How-to: Change the format of GroupRowInfo

How-to: Change the format of GroupRowInfo
See Also Send Feedback

Glossary Item Box

You can change the GroupRowInfo format, ex: add a total rows count information.

In this topic, you will learn how to change the format of WebGrid's GroupRowInfo.

To change the format of GroupRowInfo

  1. Right click on the WebGrid to open WebGrid.NET Designer.
  2. Set focus Popular Settings - Click see all properties. .
  3. Set GroupRowInfoFormatDefault to [caption]: [value], Total Rows:[count].
  4. After we have applied the new format, the GroupRowInfo will be like this when we grouped column(s) in WebGrid.

See Also

References
GroupRowInfoFormatDefault Property

Other Resources
Walkthrough Topics
How-to Topics


How-to: Specify a different Help URL

How-to: Specify a different Help URL
See Also Send Feedback

Glossary Item Box

You can specify a different Help URL when user click on the WebGrid's help button.

In this topic, you will learn how to specify a different Help URL.

To specify a different Help URL

  1. Right click on the WebGrid to open WebGrid.NET Designer.
  2. Set focus on Popular Settings and click see all properties. .
  3. Set HelpURL to http://www.intersoftpt.com.

See Also

Tasks
How-to: Hide the help button
How-to: Specify the location of image folder

References
HelpURL Property

Other Resources
Walkthrough Topics
How-to Topics


How-to: Hide/Show the grouped column when the column is grouped

How-to: Hide/Show the grouped column when the column is grouped
See Also Send Feedback

Glossary Item Box

By default, when we grouped a column eg.City. This City column will be invisible. However we can show this grouped column.

In this topic, you will learn how to hide/show the grouped WebGrid's column.

To hide/show the grouped column when the column is grouped

  1. Right click on the WebGrid to open WebGrid.NET Designer.
  2. Focus on Popular Settings - Layout Expandable panel.
  3. Uncheck "Hide columns when they are grouped" checkbox.

See Also

References
HideColumnsWhenGrouped Property

Other Resources
Walkthrough Topics
How-to Topics


How-to: Hide (+) sign in hierarchical mode

How-to: Hide (+) sign in hierarchical mode
See Also Send Feedback

Glossary Item Box

You will notice (+) sign when our WebGrid in hierarchical mode. Sometimes you want to hide this (+) sign and display the WebGrid in flat mode.

In this topic, you will learn how to hide (+) sign in WebGrid's hierarchical mode.

To hide (+) sign in hierarchical mode

  1. Right click on the WebGrid to open WebGrid.NET Designer.
  2. Focus on Popular Settings.
  3. Uncheck "Enable Hierarchical Display" checkbox.

See Also

Tasks
How-to: Hide/Show the treelines

References
HierarchicalMode Property

Other Resources
Walkthrough Topics
How-to Topics


How-to: Specify the location of image folder

How-to: Specify the location of image folder
See Also Send Feedback

Glossary Item Box

By default, image folder will be set to /CommonLibrary/Images/. However, you can specify the location of the image folder.

In this topic, you will learn how to specify the image folder location.

To specify the location of image folder

  1. Right click on the WebGrid to open WebGrid.NET Designer.
  2. Focus on Popular Settings - Click see all properties.
  3. Find ImageSettings.
  4. Set the Folder to /CommonLibrary/WebGrid/Images/.
The CommonLibrary in the above sample is located inside Intersoft Solutions folder where you install the component. E.g. C:\Program Files\Intersoft Solutions\CommonLibrary

See Also

Tasks
How-to: Specify the Localization folder in web.config
How-to: Specify a different Help URL

References
ImageSettings Property

Other Resources
Walkthrough Topics
How-to Topics


How-to: Hide/Show the row headers

How-to: Hide/Show the row headers
See Also Send Feedback

Glossary Item Box

By default, WebGrid will show the row headers. However, you can hide this footer.

In this topic, you will learn how to hide/show the WebGrid's row headers.

To hide/show the row headers

  1. Right click on the WebGrid to open WebGrid.NET Designer.
  2. Focus on User Interface.
  3. Uncheck "Show Row Headers" checkbox to hide the row headers.

See Also

Tasks
How-to: Hide/Show the column headers
How-to: Hide/Show the column footers

References
RowHeaders Property

Other Resources
Walkthrough Topics
How-to Topics


How-to: Hide/Show the refresh button

How-to: Hide/Show the refresh button
See Also Send Feedback

Glossary Item Box

Refresh button is placed in WebGrid's status bar and by default, you can see the refresh button.

In this topic, you will learn how to hide/show the WebGrid's refresh button.

To hide/show the refresh button

  1. Right click on the WebGrid to open WebGrid.NET Designer.
  2. Focus on User Interface.
  3. Uncheck "Show Refresh Command" checkbox to hide the refresh button.

See Also

Tasks
How-to: Hide/Show status bar
How-to: Hide the help button

References
ShowRefreshButton Property

Other Resources
Walkthrough Topics
How-to Topics


How-to: Hide/Show the treelines

How-to: Hide/Show the treelines
See Also Send Feedback

Glossary Item Box

By default, when WebGrid in Hierarchical mode you will notice (+) sign and the line between the (+) sign. However, you can hide this line using TreeLines method.

In this topic, you will learn how to hide/show the TreeLines.

To hide/show the row headers

  1. Right click on the WebGrid to open WebGrid.NET Designer.
  2. Focus on User Interface.
  3. Uncheck "Show TreeLines (In Hierarchical Grid)" checkbox to hide the lines.

See Also

Tasks
How-to: Hide (+) sign in hierarchical mode

Other Resources
Walkthrough Topics
How-to Topics


How-to: Set WebGrid's row layout

How-to: Set WebGrid's row layout
See Also Send Feedback

Glossary Item Box

When you set WebGrid to ColumnSet layout, you can change it back to PlainColumn by setting WebGrid's row layout.

This topic will show you how to set WebGrid's row layout.

To hide/show the row headers

  1. Make sure your WebGrid already in ColumnSet layout.
  2. Right click on the WebGrid to open WebGrid.NET Designer.
  3. Set focus on Advanced tab - RootTable - RowLayout Expandable panel.
  4. Set RowLayout to PlainColumn.

See Also

References
RowLayout Property

Other Resources
Walkthrough Topics
How-to Topics


How-to: Hide/Show the table header

How-to: Hide/Show the table header
See Also Send Feedback

Glossary Item Box

By default, WebGrid's table header will be hidden. However, you can show the table header.

This topic will show you how to hide/show WebGrid's table header.

To hide/show the table headers

  1. Right click on the WebGrid to open WebGrid.NET Designer.
  2. Set focus on Advanced tab - RootTable.
  3. Check "Table Header Visible" checkbox.

See Also

Tasks
How-to: Hide/Show the column headers
How-to: Hide/Show the row headers


How-to: Display HourGlass when the Grid is in progress

How-to: Display HourGlass when the Grid is in progress
See Also Send Feedback

Glossary Item Box

When WebGrid is in progress, you can change the WebGrid to display HourGlass.

This topic will show you how to display it.

To display HourGlass when the Grid is in progress

  1. Right click on the WebGrid to open WebGrid.NET Designer.
  2. Focus on User Interface - Miscellaneous Expandable panel.
  3. Set Behavior when the Grid is busy to ChangeCursorToHourGalss.

See Also

References
InProgressUIBehavior Property

Other Resources
Walkthrough Topics
How-to Topics


How-to: Hide/Show WebGrid

How-to: Hide/Show WebGrid
See Also Send Feedback

Glossary Item Box

If you need to Hide/Show WebGrid, we can use the WebGrid's Visible property.

This topic will show you how to hide/show WebGrid

To hide/show WebGrid

  1. Click on the WebGrid's instance.
  2. Then press F4 to show the WebGrid's properties.
  3. Set Visible to False.

See Also

Tasks
How-to: Hide/Show status bar
How-to: Hide the help button
How-to: Hide/Show the refresh button


Accessing ColumnSet in client side

Accessing ColumnSet in client side
See Also Send Feedback
Intersoft WebGrid > Learning More > Working with ColumnSet Layout > Accessing ColumnSet in client side

Glossary Item Box

The entire ColumnSet ClientSide script has been completely reworked to provide object oriented API instead of using Global Functions like in previous versions. With this new client side object models, developers can now easily extend our WebGrid component to deliver greater values by adding more user interactive features as well as achieving complex business logic scenarios.

Here are some samples code using WebGrid.NET client side API :

  • Obtain a Cell Element in a ColumnSet.

  • JavaScript Copy Image Copy Code
    function ObtainCell()
{
    var grid = ISGetObject("WebGrid1");
    if (grid.GetSelectedObject() == null)
        {
                alert("Please select a row.");
                return;
        }
        var row = grid.GetSelectedObject().GetRowObject();
        if (row.Type == "Record")
        {
                var cell = row.GetCell("City");
                var cellElement = cell.GetElement();
                cellElement.style.color = "red";
                alert("The City cell of current selected row's ForeColor is now Red.");
        }
        else
                alert("Please select a Record Row");
}
  • Obtain Row Element in ColumnSet
  • JavaScript Copy Code
    function ObtainRow()
    {
        var grid = ISGetObject("WebGrid1");

        if (grid.GetSelectedObject() == null)
        {
                alert("Please select a row.");
                return;
        }

        var row = grid.GetSelectedObject().GetRowObject();
        var rowElement = row.GetElement();

        rowElement.style.height = "30px";
        alert("Current selected row's Height is now 30px");
    }
  • Obtain a Cell Text in ColumnSet
  • JavaScript Copy Image Copy Code
    function GetCellText()
        {
            var grid = ISGetObject("WebGrid1");
            var curSelObj = grid.GetSelectedObject(); // get selected object
            if (curSelObj == null)
            {
                    alert("No row selected. Please select a row");
            }
            else
            {
                    var row = curSelObj.GetRowObject(); // get the WebGridRow object
                    if (row.Type == "GroupHeader")
                    {
                            alert("Currently selected row is a Group Row. There is no cell information.");
                    }
                    else if (row.Type == "Record")
                    {
                            var cells = row.GetCells(); // obtain WebGridCellCollection of the specified row.
                            var addressCell = cells.GetNamedItem("Address"); // get the address' WebGridCell object by name.

                            alert("Current selected row's Address cell has this text : " + addressCell.Text + "\nThe cell's value is : " + (addressCell.Value == null ? "No Value" : addressCell.Value));
                    }
            }
        }
  • Obtain Table Header Element in ColumnSet
  • JavaScript Copy Image Copy Code
    function ObtainHeader()
{
    var grid = ISGetObject("WebGrid1");
    var tableHeader = grid.RootTable.GetElement(WG40.COLHEADER, WG40.HTMLTABLE); // use GetElement to obtain any elements by specifying valid values in the parameters.

    // perform manipulation to the header's table, for example, add border style to it.
    tableHeader.style.border = "black 1px solid";
    alert("TableHeader's border style is now : black 1px solid");
}
  • Obtain Body Element in ColumnSet
  • JavaScript Copy Code
    function ObtainBody()
{
    var grid = ISGetObject("WebGrid1");
    var dvBody = grid.RootTable.GetElement(WG40.BODY, WG40.HTMLDIV); // use GetElement to obtain any elements by specifying valid values in the parameters.

    dvBody.style.border = "red 1px solid";
    alert("DivBody's border style is now : red 1px solid");
}
  • Obtain Column Caption in ColumnSet
  • JavaScript Copy Code
    function GetColumnCaption()
{
    var grid = ISGetObject("WebGrid1");
    var addressColumn = grid.RootTable.Columns.GetNamedItem("Address"); // demonstrating the way to access object hierarchy the same way as in server side.

    alert("Address column's Caption is : " + addressColumn.Caption + "\nWidth: " + addressColumn.Width + "\nVisible: " + addressColumn.Visible);
}
  • Resize Column Width in ColumnSet

  • JavaScript Copy Code
    function ResizeColumn()
{
    var grid = ISGetObject("WebGrid1");
    var cityColumn = grid.RootTable.Columns.GetNamedItem("City");

    cityColumn.Resize(100); // resize to 100 px
    alert("City column's width is now: " + cityColumn.Width);
}
  • Get the first editable cell in the column set.
  • JavaScript Copy Code
    function getfirsteditable()
   {
        //get grid object
        var grid = IsGetObject("WebGrid1");

        //get the row element
        var rowElm = grid.GetSelectedObject().GetRowObject().GetElement();

        //get the first editable cell of the columnset
        var crow = wgGetCSFirstEditableCell(rowElm);
   }
  • Get the column set position by row layout.
  • JavaScript Copy Code
    function getcsposbyrl()
{
    //get the grid object.
    var grid = ISGetObject("WebGrid1");

    //get row element.
    var rowElm = grid.GetSelectedObject().GetRowObject().GetElement();

    //get row layout by using column name, in this case we use "city".
    var cityrl = grid.RootTable.GetRowLayoutByColName("City");

    //get ColumnSet position by using row layout.
    var pos = wgGetCSPosByRL(cityrl);
}
  • Get the lowest column of the column set rows.
    JavaScript Copy Code
    function getcslowestcs()
{
    //get the grid object.
    var grid = ISGetObject("WebGrid1");

    //get row element.
    var rowElm = grid.GetSelectedObject().GetRowObject().GetElement();
    wgGetLowestColumnSetRow(row.GetElement());
}

See Also

Overview
Getting Started
WebGrid Features Overview

Other Resources
Walkthrough Topics
How-to Topics


Using ColumnSet in ChildTable

Using ColumnSet in ChildTable
See Also Send Feedback
Intersoft WebGrid > Learning More > Working with ColumnSet Layout > Using ColumnSet in ChildTable

Glossary Item Box

The ColumnSet feature is not limited on RootTable only. You can also configure the Child Table to use ColumnSet Layout while still having the rest features to work in harmony.

Creating Hierarchical ColumnSet is similar with the common process of creating normal HierarchicalStructure of the grid.

ColsEt

These are the guides :

  • Bind the RootTable and ChildTable using ISDatasource.
  • Then create the ColumnSet RootTable column.
  • C# Copy Code
    private void WebGrid1_PrepareDataBinding(object sender, ISNet.WebUI.WebGrid.DataSourceEventArgs e)
{
        if(!IsPostBack)
        {
             CreateColumnSet();
        }
}
  • Creating ColumnSet ChildTable Column.
  • C# Copy Code
    protected void MainGrid_InitChildDataSource(object sender, ISNet.WebUI.WebGrid.ChildTableDataSourceEventArgs e)
{
        CreateChildColumnSet();
}
  • This is the code for ColumnSet RootTable :
  • C# Copy Code
    private void CreateColumnSet()
{
        // Creating ColumnSet 0 and add into WebGrid
        WebGrid1.RootTable.RowLayout = RowLayoutMode.ColumnSet;
        WebGridColumnSet oColumnSet = new WebGridColumnSet();
        oColumnSet.Caption = "ColumnSet0";
        oColumnSet.Name = "ColumnSet0";
        oColumnSet.ColumnCount = 4;
        WebGrid1.RootTable.ColumnSets.Add(oColumnSet);

        //Creating RowLayout Object
        WebGridRowLayoutCollection oRowLayouts = oColumnSet.Layout;
        WebGridRowLayout oRowLayout = new WebGridRowLayout();
        WebGrid1.RootTable.ColumnSetSettings.RowCount=1;
        oRowLayout.Col = 0;
        oRowLayout.Row = 0;
        oRowLayout.ColumnMember = "CompanyName";
        oRowLayouts.Add(oRowLayout);
        oRowLayout = new WebGridRowLayout();
        oRowLayout.Col = 1;
        oRowLayout.Row = 0;
        oRowLayout.ColumnMember = "ContactName";
        oRowLayouts.Add(oRowLayout);

        oRowLayout = new WebGridRowLayout();
        oRowLayout.Col = 2;
        oRowLayout.Row = 0;
        oRowLayout.ColumnMember = "ContactTitle";
        oRowLayouts.Add(oRowLayout);

        oRowLayout = new WebGridRowLayout();
        oRowLayout.Col = 3;
        oRowLayout.Row = 0;
        oRowLayout.ColumnMember = "Address";
        oRowLayouts.Add(oRowLayout);

        oRowLayout = new WebGridRowLayout();
        oRowLayout.Col = 0;
        oRowLayout.Row = 1;
        oRowLayout.ColumnMember = "City";
        oRowLayouts.Add(oRowLayout);

        oRowLayout = new WebGridRowLayout();
        oRowLayout.Col = 1;
        oRowLayout.ColSpan = 3;
        oRowLayout.Row = 1;
        oRowLayout.ColumnMember = "Country";
        oRowLayouts.Add(oRowLayout);

        oRowLayout = new WebGridRowLayout();
        oRowLayout.Spanned = RowLayoutSpan.Column;
        oRowLayout.Col = 1;
        oRowLayout.Row = 1;
        oRowLayouts.Add(oRowLayout);

        oRowLayout = new WebGridRowLayout();
        oRowLayout.Spanned = RowLayoutSpan.Column;
        oRowLayout.Col = 2;
        oRowLayout.Row = 1;
        oRowLayouts.Add(oRowLayout);

        oRowLayout = new WebGridRowLayout();
        oRowLayout.Spanned = RowLayoutSpan.Column;
        oRowLayout.Col = 3;
        oRowLayout.Row = 1;
        oRowLayouts.Add(oRowLayout);

        WebGridRowLayout oRowLayout1;
        oRowLayout1 = new WebGridRowLayout();
        oRowLayout1.Col = 0;
        oRowLayout1.Row = 0;
        oRowLayout1.RowSpan = 2;
        oRowLayout1.ColumnMember = "Fax";
        oRowLayouts.Add(oRowLayout1);

        oRowLayout1 = new WebGridRowLayout();
        oRowLayout1.Col = 1;
        oRowLayout1.Row = 0;
        oRowLayout1.RowSpan = 2;
        oRowLayout1.ColumnMember = "Region";
        oRowLayouts.Add(oRowLayout1);
        oRowLayout1 = new WebGridRowLayout();
        oRowLayout1.Col = 0;
        oRowLayout1.Row = 1;
        oRowLayouts.Add(oRowLayout1);

        oRowLayout1 = new WebGridRowLayout();
        oRowLayout1.Col = 1;
        oRowLayout1.Row = 1;
        oRowLayouts.Add(oRowLayout1);
}
  • This is the ChildTable ColumnSet code :
  • C# Copy Code
     private void CreateChildColumnSet()
{
        WebGrid1.RootTable.ChildTables[0].RowLayout = RowLayoutMode.ColumnSet;
        WebGridColumnSet oColumnSet = new WebGridColumnSet();
        oColumnSet.Caption = "ColumnSet2";
        oColumnSet.Name = "ColumnSet2";
        oColumnSet.ColumnCount = 3;
        WebGrid1.RootTable.ChildTables[0].ColumnSetSettings.RowCount=3;
        WebGrid1.RootTable.ChildTables[0].ColumnSets.Add(oColumnSet);

        WebGridRowLayoutCollection oRowLayouts = oColumnSet.Layout;
        WebGridRowLayout oRowLayout = new WebGridRowLayout();
        oRowLayout.Col = 0;
        oRowLayout.Row = 0;
        oRowLayout.ColumnMember = "OrderID";
        oRowLayouts.Add(oRowLayout);

        oRowLayout = new WebGridRowLayout();
        oRowLayout.Col = 1;
        oRowLayout.Row = 0;
        oRowLayout.ColumnMember = "OrderDate";
        oRowLayouts.Add(oRowLayout);

        oRowLayout = new WebGridRowLayout();
        oRowLayout.Col = 2;
        oRowLayout.Row = 0;
        oRowLayout.ColumnMember = "EmployeeID";
        oRowLayouts.Add(oRowLayout);

        oRowLayout = new WebGridRowLayout();
        oRowLayout.Col = 0;
        oRowLayout.Row = 1;
        oRowLayout.ColumnMember = "CustomerID";
        oRowLayouts.Add(oRowLayout);

        oRowLayout = new WebGridRowLayout();
        oRowLayout.Col = 1;
        oRowLayout.Row = 1;
        oRowLayout.ColumnMember = "Freight";
        oRowLayouts.Add(oRowLayout);

        oRowLayout = new WebGridRowLayout();
        oRowLayout.Col = 2;
        oRowLayout.Row = 1;
        oRowLayout.ColumnMember = "RequiredDate";
        oRowLayouts.Add(oRowLayout);

        oRowLayout = new WebGridRowLayout();
        oRowLayout.Col = 0;
        oRowLayout.Row = 2;
        oRowLayout.ColumnMember = "ShipVia";
        oRowLayouts.Add(oRowLayout);

        oRowLayout = new WebGridRowLayout();
        oRowLayout.Col = 1;
        oRowLayout.Row = 2;
        oRowLayout.ColumnMember = "ShippedDate";
        oRowLayouts.Add(oRowLayout);

        oRowLayout = new WebGridRowLayout();
        oRowLayout.Col = 2;
        oRowLayout.Row = 2;
        oRowLayout.ColumnMember = "ShipCountry";
        oRowLayouts.Add(oRowLayout);
}

See Also

Overview
Getting Started
WebGrid Features Overview

Other Resources
Walkthrough Topics
How-to Topics


Customizing ColumnSet Settings

Customizing ColumnSet Settings
See Also Send Feedback
Intersoft WebGrid > Learning More > Working with ColumnSet Layout > Customizing ColumnSet Settings

Glossary Item Box

Known as a rich feature component, Intersoft WebGrid.NET ColumnSet has many settings that can be attached to each table and can be found in expandable ColumnSetSettings property. We can customize numerous setting such as GridLineColor, GridLines, GridLineStyle, RowCount and ShowHeaders.

  • GridLineColor is a property to set a color to the grid line, example : red, blue.
  • GridLines is a property to set the type of grid line, example : vertical, horizontal.
  • GridLineStyle contains line styles that can be applied into grid line, example : dotted, solid, double.
  • RowCount is a property to set the number of rows in a ColumnSet.
  • ShowHeaders is a property to set whether the header of the ColumnSet is visible or not.

This is the snapshot of WebGrid.NET Designer showing the ColumnSet Settings.

When we set the ColumnSet Settings as above, the ColumnSet grid will be shown like below snapshot, look at the red dotted line on every horizontal GridLine.

Setting

See Also

Getting Started
Getting Started
Getting Started

Other Resources
Walkthrough Topics
How-to Topics


Working with Advanced Client-Server Interaction

Working with Advanced Client-Server Interaction
See Also Send Feedback
Intersoft WebGrid > Learning More > Working with Advanced Client-Server Interaction

Glossary Item Box

This section contains information about interaction between client and server when OnTheFlyPostBack is applied.

In This Section

Advanced Client-Server Interaction Sample
Information about using SendCustomRequest and ClientAction engine.

Using ClientAction Engine
Learn how to use ClientAction engine together with a sample.

See Also

Getting Started
Getting Started

Overview
WebGrid Features Overview

Other Resources
Walkthrough Topics
How-to Topics


Advanced Client-Server Interaction Sample

Advanced Client-Server Interaction Sample
See Also Send Feedback
Intersoft WebGrid > Learning More > Working with Advanced Client-Server Interaction > Advanced Client-Server Interaction Sample

Glossary Item Box

The OnTheFly-Postback™ architecture is one of the main features in WebGrid. The architecture is designed not only for data retrieval, but also to provide a solid framework which allows developers to control numerous aspects and behaviors of WebGrid such as sorting, grouping, editing, etc. In fact, most actions in WebGrid are performed using this architecture.

In this sample we utilize two unique features of WebGrid which are parts of the architecture: SendCustomRequest and ClientAction engine. The SendCustomRequest basically sends a custom request to the server, just like the Refresh request which is made when you click the Refresh icon at the bottom-right corner of a WebGrid.

There are two methods that can be optionally used together with SendCustomRequest: wgPrepareCustomAction and wgCustomActionResponse. The first one is called when the custom request is about to be made. You can place some code in the function to, for instance, set the StatusBar text. The latter is invoked after a response for the custom request is received. You can also send custom data to the server during the custom request.

The ClientAction engine acts as a bridge between the client and the server, allowing client-side functions to be invoked from server side during OnTheFly Postback. This results in smoother interactions and most importantly much reduced codes and time needed for more complex scenarios.

This section describes how to utilize the architecture to send data to the server to be processed and then send the result back to the client, all without Page Postback and yet conforming to the ASP.NET page lifecycle.

Specifically, the sample will show how to get a row's data on the server, process it and send the results back to be displayed in another grid. When a user selects a row from the Customer table (WebGrid1), WebGrid2 will then load and display the Orders and OrderDetails data of that selected customer. If the selected customer does not have any Orders data associated, WebGrid2 will not be shown.

The logic behind this scenario is as following:

  1. Invoke a custom request from the client in OnRowSelect event.
  2. On the server side, check if the Postback action is invoked by the custom request.
  3. If yes, refresh WebGrid2 so it can get and then show the new data.
  4. Get the key value of the selected row using RetrieveClientLastSelectedObject().
  5. Load the Orders and OrderDetails data based on that key value.
  6. Hide WebGrid2 if the selected customer does not have any Orders.
  7. When the refreshing process is done the Orders and OrderDetails data will automatically show up, if any.

Note that in this sample we use two strongly-typed DataSets, dsCustomers and dsOrders. dsCustomers contains the Customers table and is used for WebGrid1. dsOrders contains the Orders and OrderDetails (linked by a DataRelation) and is used for WebGrid2. The column structures of these grids are created at design time.

Client-side script:

JavaScript Copy Code
<script language="javascript" type="text/javascript">

    // (1)
    function WebGrid1_OnRowSelect(gridId, tblName, rowIndex, rowElm) {
        var grid = ISGetObject(gridId); // get the grid instance
        grid.SendCustomRequest();
        return true;
    }

    // This function is invoked when the custom request is about to be made.
    function wgPrepareCustomAction(grid, xmlr, name) {
        grid.SetStatus1("Loading Orders data...");
        return true;
    }

    // This function is invoked after a response for the custom request is received.
    function wgCustomActionResponse(grid, xmlrp) {
        grid.SetStatus1("Ready.");
        return true;
    }

</script>
<!-- Hide WebGrid2 on first page load -->
<body onload="ISGetObject('WebGrid2').Hide()">

Server-side code:

C# Copy Code
private void WebGrid1_InitializeDataSource(object sender,
ISNet.WebUI.WebGrid.DataSourceEventArgs e)
{
    daCustomers.Fill(dsCustomers1);
    e.DataSource = dsCustomers1;
}

private void WebGrid1_InitializePostBack(object sender,
ISNet.WebUI.WebGrid.PostbackEventArgs e)
{
    // (2)
    // If a custom request is received,
    // rebind and refresh WebGrid2.
    if (e.Action == PostBackAction.Custom)
    {
        // (3)
        WebGrid2.ClearCachedDataSource();
        WebGrid2.RebindDataSource();
        WebGrid2.ClientAction.Refresh();
    }
}

private void WebGrid2_InitializeDataSource(object sender,
ISNet.WebUI.WebGrid.DataSourceEventArgs e)
{
    // Only fill when it's a refresh request.
    if (WebGrid2.FlyPostBackAction == PostBackAction.RefreshData)
    {
        // (4)
        SelectedObject selObj = WebGrid1.RetrieveClientLastSelectedObject();
        if (selObj != null)
        {
            // Select the Order item based on the selected CustomerID in WebGrid1.
            daOrders.SelectCommand.CommandText =
                "SELECT * FROM Orders WHERE CustomerID = '" +
                selObj.KeyValue.ToString() + "'";

            // (5)
            daOrders.Fill(dsOrders1.Orders);

            // Get the OrderDetails item based on the retrieved Orders items.
            foreach (DataRow aRow in dsOrders1.Orders)
            {
                daOrderDetails.SelectCommand.CommandText =
                    "SELECT * FROM [Order Details] WHERE OrderID = " + aRow["OrderID"];

                daOrderDetails.Fill(dsOrders1.Order_Details);
            }

            // (6)
            // Hide WebGrid2 if there is no row in the Orders table.
            if (dsOrders1.Orders.Rows.Count > 0)
                WebGrid2.ClientAction.Show();
            else
                WebGrid2.ClientAction.Hide();
        }
    }

    // Bind the datasource.
    e.DataSource = dsOrders1;
}

See Also

Getting Started
Getting Started

Overview
WebGrid Features Overview

Other Resources
Walkthrough Topics
How-to Topics


Using ClientAction Engine

Using ClientAction Engine
See Also Send Feedback
Intersoft WebGrid > Learning More > Working with Advanced Client-Server Interaction > Using ClientAction Engine

Glossary Item Box

ClientAction Engine was first introduced in to enable smoother client interactions during server OnTheFly-PostBack context. The ClientAction is now embedded in Framework level to provide shared functionality among other products. Numerous powerful features have been added into the enhanced ClientAction engine such as the ability to easily set value and assign a WebStyle to any valid HTML elements.

In V5.0, more features are added into the ClientAction engine. One of the most exciting feature is the ability to RefreshModifiedControls on the fly. One of the examples on how to do this is available in our tutorial file(V4.0/FlyPostBackRenderControls.aspx), it allows controls which are edited during OnTheFly Postback to be modified. Below is a sample code which shows you how to do this.

C# Copy Code
private void WebGrid1_UpdateRow(object sender, ISNet.WebUI.WebGrid.RowEventArgs e)
{
    if (e.Row.Cells.GetNamedItem("Country").Text == "UK")
    {
        Label1.BackColor = Color.Red;
        TextBox1.Text = "Can't update this row!";

        // Refresh any intrinsic controls whose properties
        // have been changed since Load event.
        WebGrid1.ClientAction.RefreshModifiedControls();
    }
    else
    {
        Label1.BackColor = Color.White;
        TextBox1.Text = "Update OK!";
        WebGrid1.ClientAction.RefreshModifiedControls();
    }
}

In previous version, you can also achieve above scenario but with more codes and efforts. You have to implement OnAfterResponse client side event and write the function to check for many cases in the OnAfterResponse event in order to achieve one easy task.

The example above shows how to use ClientActionEngine during OnTheFly Postback. When a row is about to be updated, it performs some checking then configures a TextBox control and refreshes it.

One important thing to note about ClientActionEngine is that it is only applicable during OnTheFly Postback, you cannot use it in full Postback.

See Also

Getting Started
Getting Started

Overview
WebGrid Features Overview

Other Resources
Walkthrough Topics
How-to Topics


Working with Self Referencing Table

Working with Self Referencing Table
See Also Send Feedback
Intersoft WebGrid > Learning More > Working with Self Referencing Table

Glossary Item Box

This section contains information about creating and customizing self reference table in WebGrid.

In This Section

Creating Self Reference Table
Learn how to create simple self reference table.

Hierarchical Self Reference
Learn how to enable self reference along with true hierarchical mode.

LoadOnDemand Self Reference
Learn how to retrieve a row's child rows using load on demand.

Customizing Self Reference Table
Learn how to set self reference table with either TreeView or Parent root mode.

See Also

Getting Started
Getting Started

Overview
WebGrid Features Overview

Other Resources
Walkthrough Topics
How-to Topics


Creating Self Reference Table

Creating Self Reference Table
See Also Send Feedback
Intersoft WebGrid > Learning More > Working with Self Referencing Table > Creating Self Reference Table

Glossary Item Box

SelfReference makes a simple flat grid becomes hierarchical. It is because of the reference from one column to another based on the DataMember in it. There are numerous UI settings applicable to this feature, such as TreeView selection mode, parent root mode, AutoFit column on expand, and more.

You bind data the same way as you usually do in a normal flat table. The grid will then be able to automatically group the child rows based on SelfReferenceSettings. This feature works perfectly in conjunction with all existing features such as sorting, grouping and so on.

Based on the picture above, WebGrid.NET designer provides a collection of settings called SelfReferenceSettings. These settings will reflect to WebGrid's SelfReference feature.

  • ChildDataMember = ChildDataMember is a property to set a child's data member that will be referred to the parent.
  • Enabled = Enabled is a property to set the whether the SelfReference is enabled or not.
  • ExpandColumnInnerTextPadding = ExpandColumnInnerTextPadding is a property to specify the padding for expand column's inner text area.
  • ExpandColumnMember = ExpandColumnMember is a property to specify where the expand/collapse icon will be rendered.
  • FitColumnOnExpand = FitColumnOnExpand is a property to automatically set best fit when expanded.
  • IsTreeViewSelectionMode = IsTreeViewSelectionMode is a property to specify whether the selection mode will use TreeView-like selection.
  • LoadOnDemand = LoadOnDemand is a property to specify whether child rows will be populated on demand.
  • ParentDataMember = ParentDataMember is a property to set parent data member of self referencing table.
  • TreatOrphanRecordAsRoot = TreatOrphanRecordAsRoot is a property to determine whether rows that doesn't have parent or child will be treated as root.

The picture belows will show how the SelfReference works.

FirstName is an ExpandColumnMember, EmployeeID is a ParentDataMember, and ReportsTo is a ChildDataMember. Please don't forget to enable the Enabled property at the SelfReferenceSettings.

Please take a look carefully at the FirstName, EmployeeID, and ReportsTo columns. EmployeeID has 2 as a DataMember, and it will be a parent for some of ReportsTo column DataMember that has 2 as the values, and so on. FirstName column will be added a + icon to expand the self reference hierarchy and - icon to collapse.

See Also

Getting Started
Getting Started

Overview
WebGrid Features Overview

Other Resources
Walkthrough Topics
How-to Topics


Hierarchical Self Reference

Hierarchical Self Reference
See Also Send Feedback
Intersoft WebGrid > Learning More > Working with Self Referencing Table > Hierarchical Self Reference

Glossary Item Box

As SelfReference is not a true hierarchical mode, therefore it shouldn't sacrifice the original Hierarchical mode being enjoyed by most developers.

SelfReference is actually another way to group and order the rows. It gives us additional information which ChildRows should be attached to which parent. Since SelfReference is a flat-table view (share same structure), it isn't a true hierarchical mode which drills down data from other tables. SelfReferencing can be enabled along with the "True" Hierarchical mode without any problem.

After expanding the row on above snapshot, the grid will look like below snapshot. The expanded hierarchical grid is now mixed with the expanded SelfReference table.

Hier

Since SelfReference is a flat-table view (share same structure), it isn't a true hierarchical mode which drills down data from other tables. In WebGrid SelfReferencing can be enabled along with the "True" Hierarchical mode without any problem. The grid hierarchical needs to be bound by using ISDatasource control.

See Also

Getting Started
Getting Started

Overview
WebGrid Features Overview

Other Resources
Walkthrough Topics
How-to Topics


Walkthrough: Creating Self Reference LoadOnDemand WebGrid

Walkthrough: Creating Self Reference LoadOnDemand WebGrid
See Also Send Feedback
Intersoft WebGrid > Learning More > Working with Self Referencing Table > Walkthrough: Creating Self Reference LoadOnDemand WebGrid

Glossary Item Box

This walkthrough shows you how to create Self Reference LoadOnDemand in WebGrid.

During this walkthrough, you will learn how to do the following:

  • Setting a Self Reference Load On Demand in a WebGrid.

Prerequisites

In order to complete this walkthrough, you will need the following:

  • Visual Studio 2005/2008/2010 Application.

Step-By-Step Instructions

To create new web application and specify Self Reference LoadOnDemand in WebGrid.

  1. Open WebGrid.NET Designer, Advanced, click See All Properties.
  2. Select RootTable.
  3. Expand SelfReferenceSettings.
  4. Set ParentDataMember to EmployeeID.
  5. Set ChildDataMember to ReportsTo.
  6. Set ExpandColumnMember to FirstName.
  7. Set Enabled to True.

    SelfRefDes

  8. Drag ISDataSource control from toolbox to the designer surface.
  9. Configure Data Source for the newly created ISDataSource.
  10. Select DataSet for the SchemaType.
  11. Click Schema Name dropdown and select dsNorthWind from the list.
  12. In the next dialog, click Add button then select Employees in the dropdown menu.
  13. In the Select Method dropdown list, select GetDataBy(Nullable<Int32> ReportsTo) method.
  14. Click Finish.

    ISDSSelfRef1

  15. Open ISDataSource .NET Designer.
  16. Click on Employees table.
  17. Set SelectSelfReferenceRowMethod to GetDataBy.

    ISDSSElfRef2

  18. Drag WebGrid control from toolbox to the designer surface.
  19. Set the DataSourceID to ISDataSource1.

    a

  20. In the Connect to DataSource dialog, select Retrieve Structure, choose "Employees" table then click OK.
  21. Open WebGrid.NET Designer >> Advanced and click See all properties.
  22. Expand SelfReferencingSettings, set Enabled to True, set ExpandColumnMember to FirstName, set ChildDataMember to ReportsTo and ParentDataMember to EmployeeID.
  23. In SelfReferencingSettings, remember to set LoadOnDemand to True.

    SelfRefLOD

See Also

Tasks
Walkthrough: Creating Self Reference WebGrid
How-to: Remove (+) sign for Self Reference LoadOnDemand rows that contain no Child Row

References
SelfReferencingSettings Class
ChildDataMember Property
Enabled Property
ExpandColumnMember Property
LoadOnDemand Property
ParentDataMember Property
PreviewRowSettings Class

Other Resources
Walkthrough Topics
How-to Topics


Walkthrough: Setting Virtual Load in WebGrid

Walkthrough: Setting Virtual Load in WebGrid
See Also Send Feedback

Glossary Item Box

This walkthrough shows you how to specify Virtual Load to WebGrid.

During this walkthrough, you will learn how to do the following:

  • Bind WebGrid to AccessDatasource.
  • Specify a VirtualLoad feature in a grid to increase the productivity and performance.

Prerequisites

In order to complete this walkthrough, you will need the following:

  • Access to the Microsoft Access Northwind database.
  • Visual Studio 2005/2008/2010 Application.

Step-By-Step Instructions

To create new web application and specify Virtual Load in WebGrid.

  1. Bind WebGrid to AccessDataSource.
  2. Open WebGrid Designer.
  3. Select PopularSettings.
  4. Set the PagingMode property to VirtualLoad.
  5. Set the VirtualLoadMode property to Default.
  6. Set the VirtualPageSize property to specify the number of rows to retrieve.

    VloadDesigner

  7. Click OK to close the window.

See Also

Tasks
Walkthrough: Updating footer when loading data on demand
How-to: Retrieve a different VirtualPageSize on a specific condition
How-to: Implement custom Virtual Load

References
PagingMode Property
VirtualLoadMode Property
VirtualPageSize Property

Other Resources
Walkthrough Topics
How-to Topics


Walkthrough: Using NumericUpDown Custom Editor in WebGrid

Walkthrough: Using NumericUpDown Custom Editor in WebGrid
See Also Send Feedback

Glossary Item Box

This walkthrough shows you how to use NumericUpDown in WebGrid.

During this walkthrough, you will learn how to do the following:

  • Bind WebGrid with AccessDatasource.
  • Setting a NumericUpDown control in a grid column using WebGrid Designer.

Prerequisites

In order to complete this walkthrough, you will need the following:

  • Visual Studio 2005 Application.

Step-By-Step Instructions

To create new web application and specify NumericUpDown control in WebGrid

  1. Bind WebGrid to AccessDataSource.
  2. Please use Products table instead of Customers table.
  3. Right click on WebGrid and click on Retrieve Structure to retrieve all columns based on assigned DataSource.
  4. Go to the WebGrid designer.
  5. Set WebGrid's properties AllowEdit to true
  6. Go to Advanced, click See All Properties.
  7. Specify the CustomEditorName property to NumericUpDown.
  8. Set the EditType property to Custom.
  9. Set the CustomEditorProperties
  10. There are two properties available in NumericUpDown CustomEditorProperties property that can be set:
    • MinValue: The minimal value allowed for the control. Data Type: int. Default Value: 0.
    • MaxValue: The maximal value allowed for the control. Data Type: int. Default Value: 2147483647.

See Also

References
CustomEditorName Property
EditType Property
CustomEditorProperties Property

Other Resources
Walkthrough Topics
How-to Topics


Walkthrough: Using Calculator Custom Editor in WebGrid

Walkthrough: Using Calculator Custom Editor in WebGrid
See Also Send Feedback

Glossary Item Box

This walkthrough shows you how to use Calculator in WebGrid.

During this walkthrough, you will learn how to do the following:

  • Bin WebGrid to AccessDatasource.
  • Setting a Calculator control in a grid column using WebGrid Designer.

Prerequisites

In order to complete this walkthrough, you will need the following:

  • Visual Studio 2005 Application.

Step-By-Step Instructions

To create new web application and specify Calculator control in WebGrid

  1. Bind WebGrid to AccessDataSource.
  2. Please use Products table instead of Customers table.
  3. Right click on WebGrid and click on Retrieve Structure to retrieve all columns based on assigned DataSource.
  4. Go to the WebGrid designer.
  5. Set WebGrid's properties AllowEdit to true.
  6. In Advanced, click the Edit Control Type to Calculator.

     CalculatorDesigner

    SliderResult

See Also

References
AllowEdit Property
EditType Property
CustomEditorName Property

Other Resources
Walkthrough Topics
How-to Topics


Walkthrough: Using WebValueList in WebGrid

Walkthrough: Using WebValueList in WebGrid
See Also Send Feedback

Glossary Item Box

This walkthrough shows you how to use WebValueList in WebGrid.

During this walkthrough, you will learn how to do the following:

  • Connect to a Microsoft Access database using Microsoft Jet 4.0 OLE DB Provider.
  • Use OleDbDataAdapter to configure SQL Query and generate DataSet.
  • Set Web Application's environment and the DataSource.
  • Use WebGrid's InitializeDataSource event to bind the DataSet.
  • Specify a WebValueList feature in a grid to replace the id with value.

Prerequisites

In order to complete this walkthrough, you will need the following:

  • Access to the Microsoft Access NorthWind database.
  • Visual Studio 2003 Application.

Step-By-Step Instructions

To create new web application and specify WebValueList in WebGrid.

  1. Binding Hierarchical DataSource to WebGrid.
  2. Drag OleDbDataAdapter from Data tab to the WebForm.
  3. Click Next until Generate SQL statements page, type in SELECT * FROM PRODUCTS in the textbox and click Next then Finish. Right click the newly created oleDbDataAdapter and select Generate DataSet, click OK.
  4. Rename the oleDbDataAdapter object to daProducts.
  5. Switch to HTML View and add the event OnInitializeLayout="WebGrid1_InitLayout" inside the <ISWebGrid:WebGrid id="WebGrid1" ... tag.
  6. Now open the code-behind editor by right clicking on the page and click View Code.
  7. Add using ISNet.WebUI.WebGrid; at the top of the code-behind page.
  8. Add following C# code:
    C# Copy Code
    protected void WebGrid1_InitLayout(object sender, ISNet.WebUI.WebGrid.LayoutEventArgs e)
{
        // set valuelist for ShipVia
        WebValueList vlShipVia = WebGrid1.GetTableByName("Orders").Columns.GetNamedItem("ShipVia").ValueList;
        Hashtable htShipVia = new Hashtable();
        htShipVia.Add("1", "Speedy Express");
        htShipVia.Add("2", "United Package");
        htShipVia.Add("3", "Federal Shipping");

        vlShipVia.DataSource = htShipVia;

        // set valuelist for Products
        WebValueList vlProd = WebGrid1.GetTableByName("Order Details").Columns.GetNamedItem("ProductID").ValueList;

        if (!vlProd.IsDataCached())
        {
                daProducts.Fill(dsNorthWind1.Products);
                vlProd.DataSource = dsNorthWind1;
        }

            vlProd.SetDataSource("Products", "ProductName","ProductID");

    }
  9. Set the WebGrid's Width to 600px, Height to 300px for larger display.
  10. Open WebGrid.NET Designer, expand RootTable, expand ChildTables, expand Orders table and select its Columns.
  11. Move the ShipVia column to the third column from the top.
  12. Click OK to apply all settings.
  13. Compile and run the WebForm.

See Also

References
WebValueList Class


Walkthrough: Using HTMLEditor Custom Editor in WebGrid

Walkthrough: Using HTMLEditor Custom Editor in WebGrid
See Also Send Feedback

Glossary Item Box

HtmlEditor is a DHTMLClientControl and designed so it is easy to use. This walkthrough shows you how to use HtmlEditor in WebGrid.

During this walkthrough, you will learn how to do the following:

  • Bind WebGrid using AccessDatasource.
  • Setting a HtmlEditor in a grid column using WebGrid designer.

Prerequisites

In order to complete this walkthrough, you will need the following:

  • Visual Studio 2005 Application.

Step-By-Step Instructions

To create new web application and specify HTMLEditor control in WebGrid

  1. Bind WebGrid to AccessDataSource.
  2. Please use Products table instead of Customers table.
  3. Right click on WebGrid and click on Retrieve Structure to retrieve all columns based on assigned DataSource.
  4. Go to the WebGrid designer.
  5. Set WebGrid's properties AllowEdit to true.
  6. In Advanced, click the Edit Control Type to HtmlEditor.

  7. After that click the See all properties hyperlink and set Column Type to Custom.

  8. You also need to set MaxHeight property to 20px. But if you want to set the cell to be multiline, then you need to set the MaxHeight property to -1px.

  9. Run the project.

See Also

References
EditType Property
AllowEdit Property
CustomEditorName Property

Other Resources
Walkthrough Topics
How-to Topics


Walkthrough: Using SliderBar Custom Editor in WebGrid

Walkthrough: Using SliderBar Custom Editor in WebGrid
See Also Send Feedback

Glossary Item Box

SliderBar can be handled using mouse drags as well as keyboard navigation arrows (Up/Down arrow key for vertical SliderBar and Right/Left arrow key for horizontal SliderBar). This walkthrough shows you how to use SliderBar in WebGrid.

During this walkthrough, you will learn how to do the following:

  • Bind WebGrid to AccessDatasource.
  • Setting a SliderBar in a grid column using WebGrid Designer.

Prerequisites

In order to complete this walkthrough, you will need the following:

  • Visual Studio 2005 Application.

Step-By-Step Instructions

To create new web application and specify SliderBar control in WebGrid

  1. Bind WebGrid to AccessDataSource.
  2. Please use Products table instead of Customers table.
  3. Right click on WebGrid and click on Retrieve Structure to retrieve all columns based on assigned DataSource.
  4. Go to the WebGrid designer.
  5. Set WebGrid's properties AllowEdit to true.
  6. In Advanced, click Edit Control Type to Slider Bar.

    SliderBarDesigne

    SliderResult

See Also

References
AllowEdit Property
EditType Property
CustomEditorProperties Property

Other Resources
Walkthrough Topics
How-to Topics


Walkthrough: Applying Late Binding Hierarchical

Walkthrough: Applying Late Binding Hierarchical
See Also Send Feedback

Glossary Item Box

This walkthrough shows you how to create a late binding to Hierarchical WebGrid.

During this walkthrough, you will learn how to do the following:

  • Connect to a Microsoft Access database using Microsoft Jet 4.0 OLE DB Provider.
  • Use WebGrid's InitializeDataSource event to bind.
  • Use late binding scenario.

Prerequisites

In order to complete this walkthrough, you will need the following:

  • Access to the Microsoft Access Northwind database.
  • Visual Studio 2005 Application.

Step-By-Step Instructions

To create new web application and apply late binding hierarchical

  1. Launch Visual Studio.NET 2005.
  2. Click on File menu, then select New and click Web Site.
  3. Select ASP.NET Web Site in the Template box and set Location to HTTP.
  4. Named the Web Site and click OK.
  5. Right-click on Project's name and select Add New Item.
  6. Select Intersoft AppForm in the My Templates box and named it as Walkthrough.aspx.
  7. Drag WebGrid instance from ToolBar to WebForm.
  8. Drag an ASP.Net button to WebForm.
  9. Double click the button and write the following code:

    C# Copy Code
    protected void Button1_Click(object sender, EventArgs e)
{
   WebGrid1.ClearCachedDataSource();
   WebGrid1.RebindDataSource();
   WebGrid1.Visible = true;
}

  10. On the Page_Load event handler, write the following code:

    C# Copy Code
    protected void Page_Load(object sender, EventArgs e)
{
  body.Style.Add("overflow", "hidden");

  if (WebGrid1.FlyPostBackAction == PostBackAction.RefreshData)
  {
     Button1_Click(null, null);
  }
}

  11. Double click the WebGrid instance and write the following code:

    C# Copy Code
    protected void WebGrid1_InitializeDataSource(object sender, ISNet.WebUI.WebGrid.DataSourceEventArgs e)
{
   e.DataSource = GetCustomers();
}

  12. On Prepare_DataBinding event handler, write the following code:

    C# Copy Code
    protected void WebGrid1_PrepareDataBinding(object sender, ISNet.WebUI.WebGrid.DataSourceEventArgs e)
{
   if (IsPostBack)
   {
     if (!WebGrid1.IsFlyPostBack)
     {
        CreateStructure();
     }
     FormatGrid();
   }
}

  13. Write the follwoing code under namespace:

    C# Copy Code
    string[] Profile1_Root = { "CustomerID", "ContactTitle", "ContactName", "Country" };
string[] Profile2_Root = { "CustomerID", "Address", "CompanyName", "Phone" };

string[] Profile1_Child = { "OrderID", "OrderDate", "Freight" };
string[] Profile2_Child = { "OrderID", "EmployeeID", "RequiredDate" };

string CurrentProfile = null;

OleDbConnection oConn = new OleDbConnection(@"Provider=Microsoft.Jet.OLEDB.4.0;Data Source=|DataDirectory|\NorthWind.mdb");

private DataSet GetCustomers()
{
    OleDbDataAdapter da = new OleDbDataAdapter("select * from customers", oConn);
    OleDbDataAdapter da2 = new OleDbDataAdapter("select o.* from orders o inner join customers c on o.customerid=c.customerid", oConn);

    DataSet ds = new DataSet();
    DataTable dt1 = new DataTable("Customers");
    DataTable dt2 = new DataTable("Orders");

    da.Fill(dt1);
    da2.Fill(dt2);

    ds.Tables.Add(dt1);
    ds.Tables.Add(dt2);

    ds.Relations.Add(ds.Tables["Customers"].Columns["CustomerID"], ds.Tables["Orders"].Columns["CustomerID"]);

    return ds;
}

private void CreateStructure()
{
    string[] UseProfileRoot = null;
    string[] UseProfileChild = null;

    if (CurrentProfile == "Profile1")
    {
       UseProfileRoot = Profile1_Root;
       UseProfileChild = Profile1_Child;
    }
    else
    {
       UseProfileRoot = Profile2_Root;
       UseProfileChild = Profile2_Child;
    }

    WebGrid1.RootTable.Columns.Clear();
    WebGrid1.RootTable.ChildTables.Clear();
    WebGrid1.LayoutSettings.Hierarchical = true;

    WebGrid1.RootTable.DataMember = "Customers";
    WebGrid1.RootTable.DataKeyField = "CustomerID";
    foreach (string col in UseProfileRoot)
    {
       WebGrid1.RootTable.Columns.Add(new WebGridColumn(col, col, col));
    }

    WebGridTable childTable = new WebGridTable();
    childTable.DataMember = "Orders";
    childTable.DataKeyField = "OrderID";
    foreach (string col in UseProfileChild)
    {
       childTable.Columns.Add(new WebGridColumn(col, col, col));
    }

    WebGrid1.RootTable.ChildTables.Add(childTable);
}

private void FormatGrid()
{
    foreach (WebGridColumn col in WebGrid1.GetTableByName("Orders").Columns)
    {
       if (col.DataMember == "OrderDate" || col.DataMember == "RequiredDate")
       {
          col.DataFormatString = "d";
       }
    }

    WebGrid1.LayoutSettings.AllowSorting = Sorting.Yes;
}

See Also

Tasks
Walkthrough: Binding WebGrid to Hierarchical ISDataSource control

References
InitializeDataSource Event
PrepareDataBinding Event

Other Resources
Walkthrough Topics
How-to Topics


Customizing Self Reference Table

Customizing Self Reference Table
See Also Send Feedback
Intersoft WebGrid > Learning More > Working with Self Referencing Table > Customizing Self Reference Table

Glossary Item Box

This section provides information on customizing self reference table in either TreeView or Parent root mode.

In This Section

TreeView Mode
Learn how to set self reference table as TreeView mode.

Parent Root Mode
Learn how to set self reference table as Parent root mode.

See Also

Getting Started
Getting Started

Overview
WebGrid Features Overview

Other Resources
Walkthrough Topics
How-to Topics


Retrieving Data Structures

Retrieving Data Structures
See Also Send Feedback

Glossary Item Box

After you have bound WebGrid to the DataSource control such as AccessDataSource. You could choose Retrieve Structure action in Connected to Data Source Control Wizard and click OK to apply all settings.

Finally, choose Retrieve Structure action in Connected to Data Source Control Wizard and click OK to apply all settings.

In this sample, we are going to use the Customers from the NorthWind database. The step-by-step procedures are:

  1. Drag WebGrid instance from ToolBar to WebForm.
  2. Click the SmartTag on the upper right of the WebGrid.
  3. In ChooseDataSource field, choose <New data source...>.

  4. In DataSourceConfigurationWizard, choose AccessDatabase and click OK.

  5. Browse and select the database in App_Data (NorthWind.mdb) and click Next.

  6. Select the table that you want to use and click Next.

  7. In this step, you can view the table's database using Test Query button. Otherwise, click Finish to proceed to the next step.
  8. Finally, choose Retrieve Structure action in Connected to Data Source Control Wizard and click OK to apply all settings.

  9. Run the project and the WebGrid should look like following.

See Also

Getting Started
Getting Started

Overview
WebGrid Features Overview

Other Resources
Walkthrough Topics
How-to Topics


Manipulating Object and Properties

Manipulating Object and Properties
See Also Send Feedback

Glossary Item Box

WebGrid.NET Designer is designed to allow you to easily manipulate WebGrid's settings and properties so you do not need to write code to modify WebGrid's settings or appearance at design-time, nor you have to remember the element tags or attributes of the grid.

In this section, we will create a WebGrid instance and retrieve table's structure then remove the column structure using WebGrid.NET Designer. Furthermore, we will modify the alternating row style of the grid.

Creating and binding columns:

  1. Drag WebGrid instance from ToolBar to WebForm.
  2. In the Solution Explorer, right-click on App_Data and select Add Existing Item.
  3. Browse and add NorthWind.mdb in C:\Program Files\Intersoft Solutions\Data (Default installation folder).
  4. Click the SmartTag on the upper right of the WebGrid.
  5. In ChooseDataSource field, choose <New data source...>.

  6. In DataSourceConfigurationWizard, choose AccessDatabase and click OK.

  7. Browse and select the database in App_Data (NorthWind.mdb) and click Next.

  8. Select the table that you want to use and click Next.

  9. In this step, you can view the table's database using Test Query button. Otherwise, click Finish to proceed to the next step.
  10. Finally, choose Retrieve Structure action in Connected to Data Source Control Wizard and click OK to apply all settings.

  11. Open WebGrid.NET Designer - RootTable - Columns and remove the Columns that you do not like.
  12. Remove the column(s) by select the button then clicking the Remove button

  13. Click OK to apply the new column structure and switch to design view of the page.
  14. Run the project and the WebGrid should look like following

Now we are going to modify the alternating row style of the grid:

  1. With the WebGrid.NET Designer opened, select the 'Layout Settings' node under the WebGrid node in the TreeView pane.
  2. Expand the AlternatingRowStyle properties node and set the ForeColor property to 'DarkRed' (without quotes).

  3. Click OK to close WebGrid.NET Designer and build the page.

See Also

Getting Started
Getting Started

Overview
WebGrid Features Overview

Other Resources
Walkthrough Topics
How-to Topics


Client Side Event Editor

Client Side Event Editor
See Also Send Feedback

Glossary Item Box

One of WebGrid's most powerful features is the ability to accommodate a broad range of scenarios through its extendable capability using client-side events. In this section, we will see how we can attach a client-side event handler to the event using the Client-side Event Editor.

Assuming that you already have the grid bound to a data source and there is data to display, the steps needed are as following:

  1. Switch to design view of the page and right-click on the grid, then select Properties.
  2. In the Properties tab, expand LayoutSettings > ClientSideEvents nodes.

  3. Find the OnRowSelect event and click the drop down arrow. In the drop down list you will see an item 'Add New Handler - WebGrid1_OnRowSelect(controlId, tblName, rowIndex, rowEl)' and/or other event handler names if the page has already contained other client-side event handlers.
  4. Click on the 'Add New Handler...' item. The page will then automatically switch to HTML view and the event handler will be added there.

See Also

Getting Started
Getting Started

Overview
WebGrid Features Overview

Other Resources
Walkthrough Topics
How-to Topics


TreeView Mode

TreeView Mode
See Also Send Feedback
Intersoft WebGrid > Learning More > Working with Self Referencing Table > Customizing Self Reference Table > TreeView Mode

Glossary Item Box

With more styles and appearance customizability, automatic columns fitting, condition-based formatting and more, WebGrid.NET SelfReference introduce a TreeView selection mode which will make application development easier, for example : Outlook 2003, Support Management System, Discussion Board.

In order to make a grid with TreeView selection mode, we need to set the IsTreeViewSelectionMode to true. Please check sample code belows:

C# Copy Code
WebGrid1.RootTable.SelfReferencingSettings.Enabled = true;
WebGrid1.RootTable.SelfReferencingSettings.ParentDataMember = "FolderID";
WebGrid1.RootTable.SelfReferencingSettings.ChildDataMember = "ParentFolderID";
WebGrid1.RootTable.SelfReferencingSettings.ExpandColumnMember = "Name";
WebGrid1.RootTable.SelfReferencingSettings.IsTreeViewSelectionMode=True;
WebGrid1.RootTable.SelfReferencingSettings.ParentRootMode =
    ISNet.WebUI.WebGrid.ParentRootMode.UseParentRootValue;

This is the result of the TreeView mode sample using SelfReference feature of WebGrid :

See Also

Getting Started
Getting Started

Overview
WebGrid Features Overview

Other Resources
Walkthrough Topics
How-to Topics


Parent Root Mode

Parent Root Mode
See Also Send Feedback
Intersoft WebGrid > Learning More > Working with Self Referencing Table > Customizing Self Reference Table > Parent Root Mode

Glossary Item Box

WebGrid.NET with Self Reference has a setting called ParentRootMode. ParentRootMode is a property as a pointer where the root of the self referencing table is.

ParentRootMode contains 3 options :

  • UseParentRootValue : UseParentrootValue is a property to show self reference table based on the parent value.
  • NullValue : NullValue is a property to show self reference table based on null value.
  • SelfReferencingNode : SelfReferencingNode is a property to show the selfreference table based on only the parentnode which has reference.

In order to use ParentRootMode based on the UseParentRootValue, we need to define some major SelfReference settings. Please check sample code belows:

C# Copy Code
WebGrid1.RootTable.SelfReferencingSettings.Enabled = true;
WebGrid1.RootTable.SelfReferencingSettings.ParentDataMember = "EmployeeID";
WebGrid1.RootTable.SelfReferencingSettings.ChildDataMember = "ReportsTo";
WebGrid1.RootTable.SelfReferencingSettings.ExpandColumnMember = "FirstName";
WebGrid1.RootTable.SelfReferencingSettings.ParentRootMode = ISNet.WebUI.WebGrid.ParentRootMode.UseParentRootValue;
// A DropDownList is configured with a collection of the possible values of ParentRootValue
WebGrid1.RootTable.SelfReferencingSettings.ParentRootValue = Int32.Parse(DropDownList1.SelectedItem.Value);

Above codes is recommended to be placed inside PrepareDataBinding event if Runtime Data Binding method is utilized, but if DesignTime Data Binding method is utilized, then it's safe to place above codes inside InitializeLayout or PrepareDataBinding event since the columns collection have been determined earlier using DesignTime Data Binding.

There are 4 major properties which need to be placed in order to configure Self Referencing table. They are : Enabled, ParentDataMember, ChildDataMember and ExpandColumnMember. Since we would like to designate a value other than 'Null' value as the ParentRootValue then the ParentRootMode property as well as ParentRootValue property need to be configured.

See Also

Overview
Getting Started
WebGrid Features Overview

Other Resources
Walkthrough Topics
How-to Topics


Miscellaneous WebGrid Settings

Miscellaneous WebGrid Settings
See Also Send Feedback
Intersoft WebGrid > Miscellaneous WebGrid Settings

Glossary Item Box

In this section, you will learn about performance and compatibility in depth.

In This Section

How-to: Set FlyPostBackSettings

How-to: Enable XML compression

How-to: Improve performance

How-to: Optimize cache

How-to: Enable v3.5 API Support

How-to: Set ScriptDirectory and SharedScriptDirectory

How-to: Set BrowserPrinterSettings

How-to: Disable ViewState in WebGrid

How-to: Improve FlyPostBack performance

How-to: Improve performance using designer

How-to: Set AllowPrint

See Also

Overview
Getting Started
WebGrid Features Overview

Other Resources
Walkthrough Topics
How-to Topics


Release History

Release History
Send Feedback

Glossary Item Box


How-to: Set FlyPostBackSettings

How-to: Set FlyPostBackSettings
See Also Send Feedback
Intersoft WebGrid > Miscellaneous WebGrid Settings > How-to: Set FlyPostBackSettings

Glossary Item Box

WebGrid provides a FlyPostBack feature which is very powerful.

In this topic, you will learn the basic thing on how to set FlyPostBack in WebGrid.

To set FlyPostBackSettings in WebGrid

  1. Open WebGrid.NET Designer.
  2. In Advanced-WebGrid-FlyPostBackSettings set:

    Property | Description | DefaultValue
    PostControlState | Gets or sets whether CONTROL should be posted to server | True
    PostHiddenFields | Gets or sets whether INPUT hidden fields should be posted to server | True
    PostInputControls | Gets or sets whether input-related controls such as INPUT, SELECT or TEXTAREA should be posted to server | False
    PostViewState | Gets or sets whether VIEWSTATE should be posted to server | True

  3. Click OK to apply the changes.
  4. Run the project.

See Also

Other Resources
Miscellaneous WebGrid Settings
Walkthrough Topics
How-to Topics

References
FlyPostBackSettings Property


How-to: Improve performance

How-to: Improve performance
See Also Send Feedback

Glossary Item Box

You could improve WebGrid's performance by disable WebGrid's data caching, set PagingMode to Virtual Load and set WebGrid's ViewStateStorage to none

This topic will show you how to improve WebGrid's performance.

To disable WebGrid's data caching

  1. Click on the WebGrid's instance.
  2. Then press F4 to show the WebGrid's properties.
  3. Set AllowAutoDataCaching to False.

To VirtualLoad as PagingMode

  1. Click on the WebGrid's instance.
  2. Then press F4 to show the WebGrid's properties - LayoutSettings.
  3. Set PagingMode to VirtualLoad.

To disable ViewStateStorage

  1. Click on the WebGrid's instance.
  2. Then press F4 to show the WebGrid's properties.
  3. Set ViewStateStorage to None.

See Also

Other Resources
Walkthrough Topics
How-to Topics


How-to: Optimize cache

How-to: Optimize cache
See Also Send Feedback

Glossary Item Box

You could improve WebGrid's performance by disable WebGrid's data caching, set PagingMode to Virtual Load and set WebGrid's ViewStateStorage to none

This topic will show you how to optimize WebGrid's cache.

To optimize cache

  1. Click on the WebGrid's instance.
  2. Then press F4 to show the WebGrid's properties - LayoutSettings.
  3. Set PagingMode to VirtualLoad.

See Also

References
PagingMode Property
ViewStateStorage Property

Other Resources
Walkthrough Topics
How-to Topics


How-to: Enable XML compression

How-to: Enable XML compression
See Also Send Feedback
Intersoft WebGrid > Miscellaneous WebGrid Settings > How-to: Enable XML compression

Glossary Item Box

By default, Enabled XML compression is set to false.

This topic will show you how to Enable XML compression.

To enable XML compression

  1. Click on the WebGrid's instance.
  2. Then, press F4 to show the WebGrid's properties.
  3. Set XMLCompressionEnabled to True.

See Also

Other Resources
Miscellaneous WebGrid Settings
Walkthrough Topics
How-to Topics


How-to: Resize a column

How-to: Resize a column
See Also Send Feedback

Glossary Item Box

WebGrid provides a resize feature which is very helpful to resize the width of the column.

In this topic, you will learn the basic thing on how to resize a column in WebGrid.

To resize column in WebGrid

  1. Open WebGrid.NET Designer.
  2. Select the Allow Column Sizing properties in QuickStart - Popular Settings - Main Features section.
  3. Click OK to apply the changes.
  4. Run the project and try to resize the column in WebGrid.

See Also

Tasks
How-to: Move a column

References
AllowColumnSizing Property

Other Resources
Walkthrough Topics
How-to Topics


How-to: Enable load more data

How-to: Enable load more data
See Also Send Feedback

Glossary Item Box

WebGrid provides a virtual load feature which is very powerful to save the memory usage.

In this topic, you will learn the basic thing on how to enable load more data in WebGrid.

To enable load more data in WebGrid

  1. Open WebGrid.NET Designer.
  2. Set PagingMode to VirtualLoad in QuickStart - Popular Settings - Paging section
  3. Click OK to apply the changes.
  4. Run the project.

See Also

References
PagingMode Property

Other Resources
Walkthrough Topics
How-to Topics


How-to: Perform adding a new row

How-to: Perform adding a new row
See Also Send Feedback

Glossary Item Box

WebGrid provides a powerful feature to add new row in WebGrid.

In this topic, you will learn the basic thing on how to allow add new row in WebGrid.

To allow add new row in WebGrid

  1. Open WebGrid.NET Designer.
  2. Select the Allow Add New properties in QuickStart - Popular Settings - Main Features section.
  3. Click OK to apply the changes.
  4. Run the project.

See Also

Tasks
How-to: Perform editing a row

References
AllowAddNew Property

Other Resources
Walkthrough Topics
How-to Topics


How-to: Perform editing a row

How-to: Perform editing a row
See Also Send Feedback

Glossary Item Box

WebGrid provides an edit feature that allows the user to edit the data in WebGrid.

In this topic, you will learn the basic thing on how to allow editing in WebGrid.

To allow editing in WebGrid

  1. Open WebGrid.NET Designer.
  2. Select the Allow Editing properties in QuickStart - Popular Settings - Main Features section.
  3. Click OK to apply the changes.
  4. Run the project.

See Also

Tasks
How-to: Perform adding a new row

References
AllowEdit Property

Other Resources
Walkthrough Topics
How-to Topics


How-to: Move a column

How-to: Move a column
See Also Send Feedback

Glossary Item Box

WebGrid provides an AllowColumnMove function that is very helpful to move the column in WebGrid.

In this topic, you will learn the basic thing on how to set AllowColumnMoving from designer.

To move a column in WebGrid

  1. Open WebGrid.NET Designer.
  2. Select the Allow Column Moving properties in QuickStart - Popular Settings - Main Features section.
  3. Click OK to apply the changes.
  4. Run the project.

See Also

Tasks
How-to: Resize a column

References
AllowColumnMove Property

Other Resources
Walkthrough Topics
How-to Topics


How-to: Perform exporting data

How-to: Perform exporting data
See Also Send Feedback

Glossary Item Box

WebGrid provides an exporting feature which is very helpful to export the data in WebGrid.

In this topic, you will learn how to set Allow Exporting from designer.

To perform exporting data in WebGrid

  1. Open WebGrid.NET Designer.
  2. Select the Allow Exporting properties in QuickStart - Popular Settings - Main Features section.
  3. Click OK to apply the changes.
  4. Create a folder to hold the generated output files. By default, the ReportPath is assigned to "~/TempReports" which means the "TempReports" folder should be created under the root of the web application. The folder also needs permission to allow the asp-net worker process to write the generated output files into the folder.
  5. Run the project.

See Also

Tasks
How-to: Export text when WebValueList is used

References
AllowExport Property

Other Resources
Walkthrough Topics
How-to Topics


How-to: Allow select/deselect columns

How-to: Allow select/deselect columns
See Also Send Feedback

Glossary Item Box

By default, the select column menu is hidden. You need to activate it so that we can select/deselect WebGrid's columns.

In this topic, you will learn how to allow select/deselect columns.

To allow select/deselect columns

  1. Right click on the WebGrid to open WebGrid.NET Designer.
  2. Focus on Popular Settings.
  3. Select "Allow Column Selection" checkbox.
  4. Run WebGrid, then right click on WebGrid's header. A context menu will appear. In the last row of this context menu you will see "Select Columns".

See Also

References
AllowSelectColumns Property

Other Resources
Walkthrough Topics
How-to Topics


How-to: Use 'Enter' key to filter data

How-to: Use 'Enter' key to filter data
See Also Send Feedback

Glossary Item Box

By default, "ShiftEnter" key is used to filter data. However, you can change from "ShiftEnter" to "Enter" key to filter data.

In this topic, you will learn how to use "Enter" key to filter data.

To use "Enter" key to filter data

  1. Right click on the WebGrid to open WebGrid.NET Designer.
  2. Focus on Popular Settings - Navigation Expandable panel.
  3. Set Keystroke for applying filter to Enter.

See Also

Tasks
How-to: Perform filtering data and hide Filter Bar in WebGrid
How-to: Filter invisible column
How-to: Add and remove Filtered Column programmatically

References
AllowFilter Property
ApplyFiltersKey Property

Other Resources
Walkthrough Topics
How-to Topics


How-to: Select a cell on mouse click

How-to: Select a cell on mouse click
See Also Send Feedback

Glossary Item Box

By default, when WebGrid is clicked, it will automatically select a row. However, you can select WebGrid's cell instead of row.

In this topic, you will learn how to select a cell on mouse click.

To select a cell on mouse click

  1. Right click on the WebGrid to open WebGrid.NET Designer.
  2. Focus on Popular Settings - Navigation Expandable panel.
  3. Set Action when cell is clicked to CellSelect.

See Also

References
CellClickAction Property

Other Resources
Walkthrough Topics
How-to Topics


How-to: Display an alert message before adding, deleting or updating a row

How-to: Display an alert message before adding, deleting or updating a row
See Also Send Feedback

Glossary Item Box

By default, WebGrid will directly add, update or delete a row. However, you can display an alert message before WebGrid add, update or delete a row.

In this topic, you will learn how to display an alert message before adding, updating or deleting.

To display an alert message before adding, deleting or updating a row

  1. Right click on the WebGrid to open WebGrid.NET Designer.
  2. Focus on Popular Settings and click See all properties.
  3. To display an alert message before adding a row, set NewRowLostFocusAction to AlwaysPrompt.
  4. To display an alert message before updating a row, set RowLostFocusAction to AlwaysPrompt.
  5. To display an alert message before deleting a row, set PromptBeforeDelete to True.

See Also

Tasks
How-to: Display MessageBox to user if UpdateRow cannot be invoked in a specific case

References
PromptBeforeDelete Property
NewRowLostFocusAction Property
RowLostFocusAction Property

Other Resources
Walkthrough Topics
How-to Topics


How-to: Persist row checker during PostBack

How-to: Persist row checker during PostBack
See Also Send Feedback

Glossary Item Box

WebGrid provides a row checker function which is very helpful to select multiple rows in WebGrid.

In this topic, you will learn the basic thing on how to persist row checker during PostBack in WebGrid. This makes the row checker is not being cleared during postback.

To persist row checker during postback

  1. Open WebGrid.NET Designer.
  2. Focus on Popular Settings and click See all properties.
  3. Set PersistRowChecker to True in Advanced - WebGrid - LayoutSettings.

See Also

Tasks
How-to: Get checked rows in client side
How-to: Get checked rows in server side

References
PersistRowChecker Property

Other Resources
Walkthrough Topics
How-to Topics


How-to: Disable automatic filter in a specific table

How-to: Disable automatic filter in a specific table
See Also Send Feedback

Glossary Item Box

WebGrid provides Automatic Filter feature to disable or enable the automatic filter in WebGrid.

In this topic, you will learn the basic thing on how to disable automatic filter feature in WebGrid.

To disable automatic filter in WebGrid

  1. Open WebGrid.NET Designer.
  2. In Advanced tab, click See All Properties.
  3. In RootTable, set AutomaticFilter to False.
  4. Click OK to apply the changes.
  5. Run the project.

See Also

Tasks
How-to: Disable automatic sort in a specific table

References
AutomaticFilter Property

Other Resources
Walkthrough Topics
How-to Topics


How-to: Disable automatic sort in a specific table

How-to: Disable automatic sort in a specific table
See Also Send Feedback

Glossary Item Box

WebGrid provides Automatic Sort feature to disable or enable the automatic sort in WebGrid.

In this topic, you will learn the basic thing on how to disable automatic sort feature in WebGrid.

To disable automatic sort in WebGrid

  1. Open WebGrid.NET Designer.
  2. In Advanced tab, click See All Properties.
  3. In RootTable, set AutomaticSort to False.
  4. Click OK to apply the changes.
  5. Run the project.

See Also

Tasks
How-to: Disable automatic filter in a specific table

References
AutomaticSort Property

Other Resources
Walkthrough Topics
How-to Topics


How-to: Show group total for a specific table

How-to: Show group total for a specific table
See Also Send Feedback

Glossary Item Box

WebGrid provides a feature to show group total for a specific table using Column Footer and Custom Aggregate function in WebGrid.

In this topic, you will learn how to display the Group Total feature in specific table.

To show group total for specific table in WebGrid

  1. Open WebGrid.NET Designer.
  2. In Popular Settings, click See All Properties.
  3. Set ColumnFooter to Yes.
  4. Go to appropriate column then set the AggregateFunction property.
  5. Click OK to close the designer.
  6. Run the project.

See Also

References
ColumnFooters Property
AggregateFunction Property

Other Resources
Walkthrough Topics
How-to Topics


How-to: Get checked rows in server side

How-to: Get checked rows in server side
See Also Send Feedback

Glossary Item Box

WebGrid provides a RowChecker feature which is very helpful to select multiple rows in WebGrid.

In this topic, you will learn the basic thing on how to get checked rows in server side.

To get checked rows in server side

  1. Add an ASP.NET button and TextBox in WebForm.
  2. On Button1_Click event handler, add this function:

    C# Copy Image Copy Code
    protected void Button1_Click(object sender, EventArgs e)
{
  WebGrid1.ClientAction.InvokeScript("test");
  TextBox1.Text = "Checked rows are : \n";
  foreach (string keyValue in WebGrid1.RootTable.GetCheckedRows())
  {
    TextBox1.Text += keyValue + " ; \n";
  }
}

  3. Run the project.

See Also

Tasks
Walkthrough: Adding RowChecker column in WebGrid
Walkthrough: Adding RowChecker in GroupRow
How-to: Persist row checker during PostBack
How-to: Get checked rows in client side

References
ButtonClick Event
GetCheckedRows Method

Other Resources
Walkthrough Topics
How-to Topics


How-to: Get checked rows in client side

How-to: Get checked rows in client side
See Also Send Feedback

Glossary Item Box

WebGrid provides a RowChecker feature which is very helpful to select multiple rows in WebGrid.

In this topic, you will learn the basic thing on how to get checked rows in client side.

To get checked rows in client side

  1. Add a HTML button in WebForm.
  2. Create test() function in client side like following:

    JavaScript Copy Code
    function test()
{
  var grd = wgGetGridById("WebGrid1");
  var table = grd.GetRootTable();
  var checkedRows = table.GetCheckedRows();
  var tl = parseFloat(grd.TotalRows);
  for(var i=0; i<checkedRows.length; i++)
  {
    alert(checkedRows[i].cells[3].innerText);
  }
}

  3. Add OnClick="test()" on your HTML button tag.
  4. Run the project.

See Also

Tasks
Walkthrough: Adding RowChecker column in WebGrid
Walkthrough: Adding RowChecker in GroupRow
How-to: Persist row checker during PostBack
How-to: Get checked rows in server side

Other Resources
Walkthrough Topics
How-to Topics


How-to: Open a new window that contains details of a selected row using OnButtonClick

How-to: Open a new window that contains details of a selected row using OnButtonClick
See Also Send Feedback

Glossary Item Box

This walkthrough will show you how to use OnButtonClick client side event.

In this topic, you will learn the basic thing on how to display the selected row's details using OnButtonClick.

To display the selected row's details using OnButtonClick

  1. Select WebGrid's instance and press F4.
  2. In Layout Settings, select ClientSideEvents, then set OnButtonClick to MyOpen.
  3. Write this function in OnButtonClick client side event:

    JavaScript Copy Image Copy Code
    function MyOpen()
{
  window.open("NewPage.aspx",null,"height=200,width=400,status=yes,toolbar=no,menubar=no,location=no");
}

  4. Create a new page and named it "NewPage.aspx".
  5. On Window onload client side events, write the following function:

    JavaScript Copy Image Copy Code
    function window::onload()
{
  var grid = window.opener.ISGetObject("WebGrid1");
  var row = grid.GetSelectedObject().ToRowObject();
  var cell = row.GetCells();
  Label1.innerText = cell[3].Text;
  Label2.innerText = cell[4].Text;
}

See Also

References
OnButtonClick Property

Other Resources
Walkthrough Topics
How-to Topics


How-to: Display the selected cell's text using OnCellSelect

How-to: Display the selected cell's text using OnCellSelect
See Also Send Feedback

Glossary Item Box

This walkthrough will show you how to use OnCellSelect client side event.

In this topic, you will learn the basic thing on how to display the selected cell's text using OnCellSelect.

To display the selected cell's text in WebGrid

  1. Select WebGrid's instance and press F4.
  2. In Layout Settings, select ClientSideEvents, then set OnCellSelect to WebGrid1_OnCellSelect.
  3. Write the following function in OnCellSelect client side event:

    JavaScript Copy Image Copy Code
    function WebGrid1_OnCellSelect(controlId, tblName, rowIndex, cellIndex)
{
   var WebGrid1 = ISGetObject(controlId);
   var selObj = WebGrid1.GetSelectedObject().GetRowElement();
   var cell = selObj.cells[cellIndex+1].innerText;
   alert(cell);
   return true;
}

  4. Run the project.

See Also

References
OnCellSelect Property

Other Resources
Walkthrough Topics
How-to Topics


How-to: Enable Cell Editing when the CheckBox is Checked Using OnCheckBoxClick

How-to: Enable Cell Editing when the CheckBox is Checked Using OnCheckBoxClick
See Also Send Feedback

Glossary Item Box

This walkthrough will show you how to use OnCheckBoxClick client side event.

In this topic, you will learn the basic thing on how to enable a readonly cell using OnCheckBoxClick.

To enable readonly cell using OnCheckBoxClick

  1. On WebGrid1_InitializeRow, put the following code:

    C# Copy Image Copy Code
    protected void WebGrid1_InitializeRow(object sender, ISNet.WebUI.WebGrid.RowEventArgs e)
{
  e.Row.Cells.GetNamedItem("Address").ForceNoEdit = true;
}

  2. Select WebGrid's instance and press F4.
  3. In Layout Settings, select ClientSideEvents, then set OnCheckBoxClick to WebGrid1_OnCheckBoxClick.
  4. Write the following function in OnCheckBoxClick client side event:

    JavaScript Copy Image Copy Code
    function WebGrid1_OnCheckBoxClick(controlId, tblName, colName, checkboxValue, originalCheckBoxValue)
{
  var WebGrid1 = ISGetObject(controlId);
  var selObj = WebGrid1.GetSelectedObject();
  var cel = selObj.ToRowObject().GetCells();
  cel[1].SetForceNoEdit(false);
  return true;
}

  5. Run the project.

See Also

References
OnCheckBoxClick Property

Other Resources
Walkthrough Topics
How-to Topics


How-to: Disable a child table's column in a specific row using OnChildRowExpand

How-to: Disable a child table's column in a specific row using OnChildRowExpand
See Also Send Feedback

Glossary Item Box

This walkthrough will show you how to use OnChildRowExpand client side events.

In this topic, you will learn the basic thing on how to disable a child table's column using OnChildRowExpand.

To disable a child table's column in WebGrid

  1. Select WebGrid's instance and press F4.
  2. In Layout Settings, select ClientSideEvents, then set OnChildRowExpand to WebGrid1_OnChildRowExpand.
  3. Write the following function in OnChildRowExpand client side event:

    JavaScript Copy Image Copy Code
    function WebGrid1_OnChildRowExpand(controlId, tblName, rowIndex, rowEl)
{
  var WebGrid1 = ISGetObject(controlId);
  var selObj = WebGrid1.GetSelectedObject();
  var row = selObj.ToRowObject();
  var cell = row.GetCells();
  if(cell[8].Text=="UK")
  {
    return false;
  }
  return true;
}

  4. Run the project.

See Also

References
OnChildRowExpand Property

Other Resources
Walkthrough Topics
How-to Topics


How-to: Prevent grouping on specific columns using OnColumnGroup

How-to: Prevent grouping on specific columns using OnColumnGroup
See Also Send Feedback

Glossary Item Box

This walkthrough will show you how to use OnColumnGroup client side event.

In this topic, you will learn the basic thing on how to prevent grouping on specific column using OnColumnGroup.

To prevent grouping on spesific column using OnColumnGroup

  1. Select WebGrid's instance and press F4.
  2. In Layout Settings, select ClientSideEvents, then set OnColumnGroup to WebGrid1_OnColumnGroup.
  3. Write the following function in OnColumnGroup client side event:

    JavaScript Copy Image Copy Code
    function WebGrid1_OnColumnGroup(controlId, columnObject)
{
  var WebGrid1 = ISGetObject(controlId);
  var colName = columnObject.Name;
  if(colName == "CustomerID")
  {
    return false;
  }
  return true;
}

  4. Run the project.

See Also

References
OnColumnGroup Property

Other Resources
Walkthrough Topics
How-to Topics


How-to: Validate input (number only) in a cell using OnEditKeyDown

How-to: Validate input (number only) in a cell using OnEditKeyDown
See Also Send Feedback

Glossary Item Box

This walkthrough will show you how to use OnEditKeyDown client side event.

In this topic, you will learn the basic thing on how to validate input (number only) in a cell using OnEditKeyDown.

To validate input (number only) in a cell using OnEditKeyDown

  1. Select WebGrid's instance and press F4.
  2. In Layout Settings, select ClientSideEvents, then set OnEditKeyDown to WebGrid1_OnEditKeyDown.
  3. Write the following function in OnEditKeyDown client side event:

    JavaScript Copy Image Copy Code
    function WebGrid1_OnEditKeyDown(controlId)
{
  var WebGrid1 = ISGetObject(controlId);
  var key = event.keyCode;
  if(key < 96 || key > 105)
  {
   return false;
  }
  else
  {
   return true;
  }
}

  4. Run the project.

See Also

References
OnEditKeyDown Property

Other Resources
Walkthrough Topics
How-to Topics


How-to: Get the column's name when editing a cell using OnEnterEditMode

How-to: Get the column's name when editing a cell using OnEnterEditMode
See Also Send Feedback

Glossary Item Box

This walkthrough will show you how to use OnEnterEditMode client side event.

In this topic, you will learn the basic thing on how to get column's name when editing a cell using OnEnterEditMode.

To get column's name when editing a cell using OnEnterEditMode

  1. Select WebGrid's instance and press F4.
  2. In Layout Settings, select ClientSideEvents, then set OnEnterEditMode to WebGrid1_OnEnterEditMode.
  3. Write the following function function in OnEnterEditMode client side event:

    JavaScript Copy Image Copy Code
    function WebGrid1_OnEnterEditMode(controlId, tblName, editObject)
{
    var WebGrid1 = ISGetObject(controlId);
    var cell = editObject.cellElement;
    alert(wgGetColNameByCell(cell));
    return true;
}

  4. Run the project.

See Also

References
OnEnterEditMode Property

Other Resources
Walkthrough Topics
How-to Topics


How-to: Modify other cell's value based on the selected value using OnExitEditMode

How-to: Modify other cell's value based on the selected value using OnExitEditMode
See Also Send Feedback

Glossary Item Box

This walkthrough shows you how to use OnExitEditMode client side event.

In this topic, you will learn the basic thing on how to modify other cell's value based on the selected value using OnExitEditMode.

To modify other cell's value based on the selected value using OnExitEditMode

  1. Select WebGrid's instance and press F4.
  2. In Layout Settings, select ClientSideEvents, then set OnExitEditMode to WebGrid1_OnExitEditMode.
  3. Write the following function in OnExitEditMode client side event:

    JavaScript Copy Image Copy Code
    function WebGrid1_OnExitEditMode(controlId, tblName, editObject)
{
  var WebGrid1 = ISGetObject(controlId);
  var editObj = editObject.element.value;
  if (editObj == "Brad")
  {
    var selObj = WebGrid1.GetSelectedObject();
    var cell = selObj.ToRowObject().GetCells();
    cell[9].SetText("UK", true);
    cell[9].SetValue("UK");
  }
  return true;
}

  4. Run the project.

See Also

References
OnExitEditMode Property

Other Resources
Walkthrough Topics
How-to Topics


How-to: Display Delete menu item in WebGrid's context menu when in a specific row using OnRowContextMenu

How-to: Display Delete menu item in WebGrid's context menu when in a specific row using OnRowContextMenu
See Also Send Feedback

Glossary Item Box

This walkthrough shows you how to use OnRowContextMenu client side event.

In this topic, you will learn the basic thing on how to display delete menu item in WebGrid's context menu using OnRowContextMenu.

To display delete menu item in WebGrid's context menu using OnRowContextMenu

  1. Select WebGrid's instance and press F4.
  2. In Layout Settings, select ClientSideEvents, then set OnRowContextMenu to WebGrid1_OnRowContextMenu.
  3. Write the following function in OnRowContextMenu client side event:

    JavaScript Copy Image Copy Code
    function WebGrid1_OnRowContextMenu(controlId, rowType, rowElement, menuObject)
{
        var WebGrid1 = ISGetObject(controlId);
        var cell = rowElement.cells[10].innerText;
        if (rowType == "Record"&& cell == "UK")
        {
          menuObject.add( new MenuSeparator() );
          menuObject.add( new MenuItem("DeleteRow", function() {delete();}));
        }
        return true;
}

  4. Run the project.

See Also

References
OnRowContextMenu Property

Other Resources
Walkthrough Topics
How-to Topics


How-to: Get KeyValue of selected row using OnRowSelect

How-to: Get KeyValue of selected row using OnRowSelect
See Also Send Feedback

Glossary Item Box

This walkthrough shows you how to use OnRowSelect client side event.

In this topic, you will learn the basic thing on how to get KeyValue of selected row using OnRowSelect.

To get KeyValue of selected row using OnRowSelect

  1. Select WebGrid's instance and press F4.
  2. In Layout Settings, select ClientSideEvents, then set OnRowSelect to WebGrid1_OnRowSelect.
  3. Write the following function in OnRowSelect client side event:

    JavaScript Copy Image Copy Code
    function WebGrid1_OnRowSelect(controlId, tblName, rowIndex, rowEl)
{
   var WebGrid1 = ISGetObject(controlId);
   var row = WebGrid1.GetSelectedObject().GetRowObject();
   var key = row.KeyValue;
   alert(key);
   return true;
}

  4. Run the project.

See Also

Other Resources
Walkthrough Topics
How-to Topics


How-to: Validate that a selected column cannot be empty when adding a new row using OnRowValidate

How-to: Validate that a selected column cannot be empty when adding a new row using OnRowValidate
See Also Send Feedback

Glossary Item Box

WebGrid provides an OnRowValidate client side events.

In this topic, you will learn the basic thing on how to validate empty cell when adding new row using OnRowValidate.

To validate empty cell when adding new row using OnRowValidate

  1. Select WebGrid's instance and press F4.
  2. In Layout Settings, select ClientSideEvents, then set OnRowValidate to WebGrid1_OnRowValidate.
  3. Write the following function in OnRowValidate client side event:

    JavaScript Copy Image Copy Code
    function WebGrid1_OnRowValidate(rowObject)
{
  var cellName = wgGetCellByName(rowObject, "ContactName");
  if (cellName.cellValue == "" || typeof(cellName.cellValue) == "undefined")
  {
    alert("You must fill in ContactName.");
        // set focus the cellProduct and activate edit mode.
        ISGetObject("WebGrid1").ActivateEditMode();
        // return false so that the addnew will not process.
        return false;
  }
  return true;
}

  4. Run the project.

See Also

References
OnRowValidate Property

Other Resources
Walkthrough Topics
How-to Topics


How-to: Get Grid object

How-to: Get Grid object
See Also Send Feedback

Glossary Item Box

Use ISGetObject() function to get the client object reference of any Intersoft's components, instead of using different function for each.

This topic will show you how to get WebGrid's object using ISGetObject.

To get WebGrid object

  1. Drag WebGrid instance into the WebForm.
  2. Add a client side function on your code.
  3. You can get the grid's instance by simply using:
  4. JavaScript Copy Code
    var grid = ISGetObject("WebGrid1");

See Also

Other Resources
Walkthrough Topics
How-to Topics


How-to: Get Selected row

How-to: Get Selected row
See Also Send Feedback

Glossary Item Box

Use GetSelectedRow function to get selected row in WebGrid via client side.

This topic will show you how to get WebGrid's selected row object using GetSelectedRow function.

To get WebGrid selected row

  1. Drag WebGrid instance into the WebForm.
  2. Add a client side function on your code.
  3. Select a row.
  4. You can get the grid's selected row by simply using:

  5. JavaScript Copy Code
    var grid = ISGetObject("WebGrid1");
var selectedObject = grid.GetSelectedObject().GetRowObject();

See Also

Other Resources
Walkthrough Topics
How-to Topics


How-to: Get row by index

How-to: Get row by index
See Also Send Feedback

Glossary Item Box

Use wgGetRowByPosition function to get WebGrid row using index in client side.

This topic will show you how to get WebGrid's row using wgGetRowByPosition.

To get WebGrid's row by index

  1. Drag WebGrid instance into the WebForm.
  2. Add a client side function on your code.
  3. You can get the grid's row by index simply by using:

  4. JavaScript Copy Code
    function GetRowElement()
{
   var grid = ISGetObject("WebGrid1");
   var htmlTbl = grid.RootTable.GetElement(WG40.BODY, WG40.HTMLTABLE);
   var htmlRowElm = wgGetRowByPosition(htmlTbl, 0);
   alert(htmlRowElm.type);
   return true;
}

See Also

Other Resources
Walkthrough Topics
How-to Topics


How-to: Get row by KeyValue

How-to: Get row by KeyValue
See Also Send Feedback

Glossary Item Box

Use GetRowByKeyValue function to get WebGrid row by KeyValue in client side.

This topic will show you how to get WebGrid's row using GetRowByKeyValue.

To get WebGrid's row by KeyValue

  1. Drag WebGrid instance into the WebForm.
  2. Add a client side function on your code.
  3. You can get the grid's row by KeyValue simply by using:

  4. JavaScript Copy Code
    function RowObject()
{
   var grid = ISGetObject("WebGrid1");
   var row = grid.RootTable.GetRowByKeyValue("VINET");  // get WebGridRow object by key value.
}

See Also

Other Resources
Walkthrough Topics
How-to Topics


How-to: Get a cell by index

How-to: Get a cell by index
See Also Send Feedback

Glossary Item Box

Use wgGetCellByPosition function to get WebGrid cell by index position in client side.

This topic will show you how to get WebGrid's cell using wgGetCellByPosition.

To get WebGrid's cell by index

  1. Drag WebGrid instance into the WebForm.
  2. Add a client side function on your code.
  3. You can get the grid's cell by position simply by using:

  4. JavaScript Copy Code
    function GetCell()
    {
        var grid = ISGetObject("WebGrid1");
        var wgRow = grid.RootTable.GetRow(0);
        var htmlRow = wgRow.GetElement();
        alert(wgGetCellByPosition(htmlRow, 1).innerText);
        return true;
    }

See Also

Other Resources
Walkthrough Topics
How-to Topics


How-to: Get a cell by name

How-to: Get a cell by name
See Also Send Feedback

Glossary Item Box

Use wgGetCellByName function to get WebGrid cell by name in client side.

This topic will show you how to get WebGrid's cell using wgGetCellByName.

To get WebGrid's cell by name

  1. Drag WebGrid instance into the WebForm.
  2. Add a client side function on your code.
  3. You can get the grid's cell by name simply by using:

  4. JavaScript Copy Code
    function GetCellContents()
    {
            var grid = ISGetObject("WebGrid1");
            var wgRow = grid.RootTable.GetRow(0);
            var htmlRow = wgRow.GetElement();
            alert(wgGetCellByName(htmlRow, "Country").innerText);
            return true;
    }

See Also

Other Resources
Walkthrough Topics
How-to Topics


How-to: Get a specific cell's text of a selected row

How-to: Get a specific cell's text of a selected row
See Also Send Feedback

Glossary Item Box

You can get a specific cell's text of selected row in client side.

This topic will show you how to get WebGrid's cell of selected row in WebGrid.

To get a specific cell of a selected row in WebGrid

  1. Drag WebGrid instance into the WebForm.
  2. Add a client side function on your code.
  3. Select a row.
  4. You can get the grid's specific cell by simply using:

  5. JavaScript Copy Code
    function Button1_onclick()
    {
        var grid = ISGetObject("WebGrid1");
        var row = grid.GetSelectedObject().GetRowObject();
        var cells = row.GetCells();
        alert(cells.GetNamedItem("ProductName").Text);
    }

See Also

Other Resources
Walkthrough Topics
How-to Topics


How-to: Get the row's KeyValue

How-to: Get the row's KeyValue
See Also Send Feedback

Glossary Item Box

Use keyValue property to get WebGrid keyValue of a selected row in client side.

This topic will show you how to get WebGrid's keyValue.

To get WebGrid's row KeyValue

  1. Drag WebGrid instance into the WebForm.
  2. Add a client side function on your code.
  3. Select a row.
  4. You can get the grid's selected row KeyValue by simply using:

  5. JavaScript Copy Code
    function doRowSelect()
    {
         var webGrid = ISGetObject("WebGrid1");
         var selRow = webGrid.GetSelectedObject().GetRowElement();
         alert(selRow.keyValue);
    }

See Also

Other Resources
Walkthrough Topics
How-to Topics


How-to: Set the column's best fit

How-to: Set the column's best fit
See Also Send Feedback

Glossary Item Box

Use ResizeBestFit function to automatic resize WebGrid column to best fit based on text in it via client side.

This topic will show you how to automatic resize WebGrid's column.

To resize WebGrid column's best fit

  1. Drag WebGrid instance into the WebForm.
  2. Add a client side function on your code.
  3. You can resize best fit grid's column by simply using:

  4. JavaScript Copy Code
    function Button1_onclick()
    {
        var grid = ISGetObject("WebGrid1");
        var prodColumn = grid.RootTable.Columns.GetNamedItem("ProductName");
        prodColumn.ResizeBestFit();
    }

See Also

Other Resources
Walkthrough Topics
How-to Topics


How-to: Get a column name of the selected cell

How-to: Get a column name of the selected cell
See Also Send Feedback

Glossary Item Box

Use wgGetColNameByCell function to get WebGrid column name of a selected cell in client side.

This topic will show you how to get WebGrid's column name.

To get WebGrid's column name by selecting a cell

  1. Drag WebGrid instance into the WebForm.
  2. Add a client side function on your code.
  3. Select a row.
  4. You can get the grid's column name by simply using:

  5. JavaScript Copy Code
    function Button1_onclick()
    {
         var grid = ISGetObject("WebGrid1");
         var rowElm = grid.GetSelectedObject().GetRowObject().GetElement();
         var columnName = wgGetColNameByCell(rowElm.cells[3]);
         alert(columnName);
    }

See Also

Other Resources
Walkthrough Topics
How-to Topics


How-to: Set text to a specific cell

How-to: Set text to a specific cell
See Also Send Feedback

Glossary Item Box

When you want to set a text into a cell in WebGrid, you can use SetText function in client side.

This topic will show you how to set WebGrid's cell text.

To set WebGrid's cell text

  1. Drag WebGrid instance into the WebForm.
  2. Add a client side function on your code.
  3. You can set text to a specific cell simply by using:

  4. JavaScript Copy Code
    function SetText()
    {
       var grid = ISGetObject("WebGrid1");
       var row = grid.RootTable.GetRowByKeyValue("SPLIR"); // get WebGridRow object by key value.
       var cells = row.GetCells();

       row.Select();
       cells.GetNamedItem("ContactTitle").SetText("Owner", true); // change contact title cell to Owner
    }

See Also

Other Resources
Walkthrough Topics
How-to Topics


How-to: Trigger OnTheFlyPostBack for client side

How-to: Trigger OnTheFlyPostBack for client side
See Also Send Feedback

Glossary Item Box

Custom OnTheFlyPostback from client side to server side can be called using a function called SendCustomRequest.

This topic will show you how to set SendCustomRequest.

To call SendCustomRequest() from client side

  1. Drag WebGrid instance into the WebForm.
  2. Add a client side function on your code.
  3. You can trigger OnTheFlyPostBack simply by using:

  4. JavaScript Copy Image Copy Code
    function Grid1_ButtonClick()
      {
         var grid = ISGetObject("WebGrid1");
         grid.SendCustomRequest();
         return true;

      }

See Also

Other Resources
Walkthrough Topics
How-to Topics


How-to: Clear selected object

How-to: Clear selected object
See Also Send Feedback

Glossary Item Box

Use ClearSelectedObject function to clear WebGrid selected object in client side.

This topic will show you how to clear WebGrid's selected object.

To clear WebGrid's selected object

  1. Drag WebGrid instance into the WebForm.
  2. Add a client side function on your code.
  3. Select a row.
  4. You can clear grid's selected object by simply using:

  5. JavaScript Copy Image Copy Code
    function ClearSelectedObj()
    {
         var grid = ISGetObject('WebGrid1');
         grid.ClearSelectedObject();
         grid.Refresh();  // To refresh the grid in order to remove the selected object highlight
         return true;
    }

See Also

Other Resources
Walkthrough Topics
How-to Topics


How-to: Refresh the Grid's data

How-to: Refresh the Grid's data
See Also Send Feedback

Glossary Item Box

Use Refresh function to refresh WebGrid in client side. This method will refresh only the data.

This topic will show you how to refresh WebGrid's data.

To refresh WebGrid's data

  1. Drag WebGrid instance into the WebForm.
  2. Add a client side function on your code.
  3. You can refresh grid's data by simply using:

  4. JavaScript Copy Code
    function doClick()
    {
        var grid = ISGetObject("WebGrid1");
        grid.Refresh();
    }

See Also

Other Resources
Walkthrough Topics
How-to Topics


How-to: Activate edit mode in a specific cell

How-to: Activate edit mode in a specific cell
See Also Send Feedback

Glossary Item Box

Use ActiveEditMode function to activate WebGrid edit mode in client side.

This topic will show you how to activate WebGrid's edit mode in a specific cell.

To activate or deactivate WebGrid edit mode in a specific cell

  1. Drag WebGrid instance into the WebForm.
  2. Add a client side function on your code.
  3. You can activate edit mode by simply using:

  4. JavaScript Copy Code
    function SelectNewRow()
    {
       var grid = ISGetObject("WebGrid1");
       var newRowElement = grid.RootTable.GetNewRow(); // return the html element of the newrow
       var newRow = grid.RootTable.ToRowObject(newRowElement); // convert to WebGridRow object

       newRow.Select(); // select new row

       var cells = newRow.GetCells(); // populate cells
       cells.GetNamedItem("City").ActivateEdit();
    }

See Also

Other Resources
Walkthrough Topics
How-to Topics


How-to: Exit edit mode from a button click

How-to: Exit edit mode from a button click
See Also Send Feedback

Glossary Item Box

Use ExitEditMode function to exit from WebGrid edit mode in client side.

This topic will show you how to exit from WebGrid's edit mode.

To exit from WebGrid edit mode

  1. Drag WebGrid instance into the WebForm.
  2. Add a client side function on your code.
  3. You can exit from edit mode by simply using:

  4. JavaScript Copy Code
    function ExitEditMode()
    {
       var grid = ISGetObject("WebGrid1");
       grid.ExitEditMode(false);
    }

See Also

Other Resources
Walkthrough Topics
How-to Topics


How-to: Show/Hide Grid from client side

How-to: Show/Hide Grid from client side
See Also Send Feedback

Glossary Item Box

When you want to set WebGrid visible/invisible, you can use Show or Hide functions in client side.

This topic will show you how to show or hide WebGrid.

To show/hide WebGrid

  1. Drag WebGrid instance into the WebForm.
  2. Add a client side function on your code.
  3. You can show or hide grid simply by using:

  4. JavaScript Copy Code
    function showGrid()
    {
       var grid = ISGetObject('WebGrid1');
       grid.Show();
    }
    function hideGrid()
    {
       var grid = ISGetObject('WebGrid1');
       grid.Hide();
    }

See Also

Other Resources
Walkthrough Topics
How-to Topics


How-to: Set a default value in new row from a button click

How-to: Set a default value in new row from a button click
See Also Send Feedback

Glossary Item Box

Default value can be set in New Row by using SetText function during onExitEditMode client side event.

This topic will show you how to set default value in WebGrid's new row.

To set a default value in new row from a button click

  1. Drag WebGrid instance into the WebForm.
  2. Add a client side function on your code.
  3. You can set default value in new row by simply using:

    JavaScript Copy Image Copy Code
    function SelectNewRow()
      {
          var grid = ISGetObject("WebGrid1");
          var newRowElement = grid.RootTable.GetNewRow(); // return the html element of the newrow
          var newRow = grid.RootTable.ToRowObject(newRowElement); // convert to WebGridRow object

          newRow.Select(); // select new row

          var cells = newRow.GetCells(); // populate cells
          cells.GetNamedItem("City").ActivateEdit(); // activate edit cell on City cell, instead of first cell
          cells.GetNamedItem("CustomerID").SetText("NEWCUST", true); // set the CustomerID cell's text to NEWCUST, 2nd parameter is true indicating that the value is same as the text.
          cells.GetNamedItem("Address").SetText("New Address", true);

          newRow.SetDataChanged(); // indicates that this row's data has been changed.
          grid.MarkEdit(); // sets the row's status as edited, as if user has typed inside the cell.
      }

  4. Invoke SelectNewRow() function in a HTML button click.

See Also

Other Resources
Walkthrough Topics
How-to Topics


How-to: Select a row from client side

How-to: Select a row from client side
See Also Send Feedback

Glossary Item Box

Use Select function to select a WebGrid row in client side.

This topic will show you how to select WebGrid's row.

To select WebGrid's row from client side

  1. Drag WebGrid instance into the WebForm.
  2. Add a client side function on your code.
  3. You can select grid's row by simply using:

  4. JavaScript Copy Image Copy Code
    function SelectRow()
    {
         var grid = ISGetObject("WebGrid1");
         var row = grid.RootTable.GetRowByKeyValue("VINET"); // get WebGridRow object by key value.
         row.Select(); // select this row for focus
    }

See Also

Other Resources
Walkthrough Topics
How-to Topics


How-to: Get checked rows on button click

How-to: Get checked rows on button click
See Also Send Feedback

Glossary Item Box

GetCheckedRows function has ability to obtain all checked rows in WebGrid via client side.

This topic will show you how to obtain all checked rows using button click.

To obtain checked rows in WebGrid

  1. Drag WebGrid instance into the WebForm.
  2. Add a client side function on your code.
  3. You can get checked rows on button click by simply using:

  4. JavaScript Copy Image Copy Code
    function CheckSelected()
      {
          var grid = ISGetObject("GlbWebGrid");
          var checkRows = grid.RootTable.GetCheckedRows();
          if(checkRows == '')
          {
              alert("Please select at least one item from the list.")
              return false;
          }
      }

See Also

Other Resources
Walkthrough Topics
How-to Topics


How-to: Get parent row's KeyValue

How-to: Get parent row's KeyValue
See Also Send Feedback

Glossary Item Box

In hierarchical grid scenario, we can get parent row's KeyValue from child table.

This topic will show you how to obtain parent's row KeyValue.

To obtain parent row's KeyValue in WebGrid

  1. Drag WebGrid instance into the WebForm.
  2. Add a client side function on your code.
  3. You can obtain parent's row KeyValue by simply using:

  4. JavaScript Copy Image Copy Code
    function GetParentRow()
    {
       var grid = ISGetObject("WebGrid1");
       var selObj = grid.GetSelectedObject();
       var row = selObj.GetRowObject();
       if (row.Table.IsRootTable)
          alert("Please select a child row");
       else
       {
          var parentRow = row.GetParentRow(); // get the parent row of this child
          alert("The parent row of this order is: " + parentRow.KeyValue);
       }
    }

See Also

Other Resources
Walkthrough Topics
How-to Topics


How-to: Update or delete a row on button click

How-to: Update or delete a row on button click
See Also Send Feedback

Glossary Item Box

On client side, we also can manipulate grid row such as Update or Delete row.

This topic will show you how to update or delete row in WebGrid.

To update or delete a row on button click

  1. Drag WebGrid instance into the WebForm.
  2. Add a client side function on your code.
  3. You can update or delete grid's row by simply using:

  4. JavaScript Copy Code
    function DeleteRow()
    {
     var grid = ISGetObject("WebGrid1");
     var row = grid.RootTable.GetRowByKeyValue("VINET");

     row.Delete(); // delete this row
     alert("Customer 'VINET' has been deleted!");
    }
    function UpdateRow()
    {
     var grid = ISGetObject("WebGrid1");
     var row = grid.RootTable.GetRowByKeyValue("SPLIR");
     row.Update(); // perform Update
     alert("ContactTitle of this row has been changed to 'Owner'");
    }

See Also

Other Resources
Walkthrough Topics
How-to Topics


How-to: Expand/collapse child row

How-to: Expand/collapse child row
See Also Send Feedback

Glossary Item Box

Use ExpandChildRow function to expand/collapse WebGrid child row in client side.

This topic will show you how to expand/collapse WebGrid's child row.

To expand/collapse WebGrid's child row

  1. Drag WebGrid instance into the WebForm.
  2. Add a client side function on your code.
  3. You can expand/collapse grid's child row by simply using:

  4. JavaScript Copy Code
    function expandChildRow()
    {
         var WebGrid1 = ISGetObject(controlId);
         var row = WebGrid1.RootTable.GetRowByKeyValue("ANATR");
         row.ExpandChildRow(true);
         return true;
    }
    function collapseChildRow()
    {
         var WebGrid1 = ISGetObject(controlId);
         var row = WebGrid1.RootTable.GetRowByKeyValue("ANATR");
         row.CollapseChildRow(true);
         return true;
    }

See Also

Other Resources
Walkthrough Topics
How-to Topics


How-to: Get root row of ColumnSet layout

How-to: Get root row of ColumnSet layout
See Also Send Feedback

Glossary Item Box

Use wgGetRootRow function to get root row of ColumnSet or PreviewRow layout in client side.

This topic will show you how to get root row.

To get root row in WebGrid's ColumnSet

  1. Drag WebGrid instance into the WebForm.
  2. Add a client side function on your code.
  3. You can get grid's row in ColumnSet by simply using:

  4. JavaScript Copy Image Copy Code
    function SelectRow()
    {

       var grid = ISGetObject("WebGrid1");
       var rowElm = grid.GetSelectedObject().GetRowObject().GetElement();
       var rootRow = wgGetRootRow(rowElm);
    }

See Also

Other Resources
Walkthrough Topics
How-to Topics


How-to: Enable v3.5 API Support

How-to: Enable v3.5 API Support
See Also Send Feedback
Intersoft WebGrid > Miscellaneous WebGrid Settings > How-to: Enable v3.5 API Support

Glossary Item Box

WebGrid provides a v3.5 API Support feature which is very helpful to resize the width of the column.

In this topic, you will learn the basic thing on how to Enable v3.5 API Support in WebGrid. For example, you currently have 3 web applications which are still using V3.5 and do not wish to upgrade to V4.0 for these projects, then you can still continue to develop using V3.5 for these projects.

To enable v3.5 API Support in WebGrid

  1. Open WebGrid.NET Designer.
  2. Set EnableV3XAPISupport to True in Advanced-WebGrid.
  3. Click OK to apply the changes.
  4. Run the project.

See Also

Other Resources
Miscellaneous WebGrid Settings
Walkthrough Topics
How-to Topics

References
EnableV3XAPISupport Property


How-to: Set ScriptDirectory and SharedScriptDirectory

How-to: Set ScriptDirectory and SharedScriptDirectory
See Also Send Feedback
Intersoft WebGrid > Miscellaneous WebGrid Settings > How-to: Set ScriptDirectory and SharedScriptDirectory

Glossary Item Box

TasksScriptDirectory and SharedScriptDirectory are one of the most essential things when you deploy a project. It is also a place where all scripts for the WebGrid are stored.

In this topic, you will learn how to set ScriptDirectory and SharedScriptDirectory in WebGrid.

To set ScriptDirectory and SharedScriptDirectory in WebGrid

  1. Open WebGrid.NET Designer.
  2. Set ScriptDirectory to /CommonLibrary/WebGrid/V4_0_6200/ in Advanced-WebGrid.
  3. Set SharedScriptDirectory to /CommonLibrary/Shared/ in Advanced-WebGrid.
  4. Click OK to apply the changes.
  5. Run the project.

See Also

Other Resources
Miscellaneous WebGrid Settings
Walkthrough Topics
How-to Topics

References
ScriptDirectory Property
SharedScriptDirectory Property


How-to: Set BrowserPrinterSettings

How-to: Set BrowserPrinterSettings
See Also Send Feedback
Intersoft WebGrid > Miscellaneous WebGrid Settings > How-to: Set BrowserPrinterSettings

Glossary Item Box

WebGrid provides a BrowserPrinterSettings feature which is very helpful to print the WebGrid.

In this topic, you will learn the basic thing on how to set BrowserPrinterSettings in WebGrid.

To set BrowserPrinterSettings in WebGrid

  1. Open WebGrid.NET Designer.
  2. In Advanced-WebGrid-BrowserPrinterSettings, set GridLayout to AsDisplayedInBrowser.
  3. In Advanced-WebGrid-BrowserPrinterSettings, set PrintStatusBar to True.
  4. Click OK to apply the changes.
  5. Run the project.

See Also

Other Resources
Miscellaneous WebGrid Settings
Walkthrough Topics
How-to Topics

References
BrowserPrintSettings Property


How-to: Disable ViewState in WebGrid

How-to: Disable ViewState in WebGrid
See Also Send Feedback
Intersoft WebGrid > Miscellaneous WebGrid Settings > How-to: Disable ViewState in WebGrid

Glossary Item Box

The default behavior of ViewState property in WebGrid is true.

In this topic, you will learn the basic thing on how to disable ViewState in WebGrid.

To disable ViewState in WebGrid

  1. Open WebGrid.NET Designer.
  2. Set ViewStateStorage to None in Advanced-WebGrid.
  3. Click OK to apply the changes.
  4. Run the project.

See Also

Other Resources
Miscellaneous WebGrid Settings
Walkthrough Topics
How-to Topics


How-to: Use HiddenDataMember to get value from hidden column

How-to: Use HiddenDataMember to get value from hidden column
See Also Send Feedback

Glossary Item Box

Use client side function to get value from hidden column on WebGrid.

This topic will show you how to get the value.

To get value from hidden column using HiddenDataMember

  1. Drag WebGrid instance into the WebForm.
  2. Set HiddenDataMember property to one of column you want to hide, for example : City.
  3. Add a client side function on your code.
  4. Select a row.
  5. You can get grid's value by simply using:

  6. JavaScript Copy Image Copy Code
    function getdata()
    {

       var grid = ISGetObject("WebGrid1");
       var rowObj = grid.GetSelectedObject().GetRowObject();
       var cells = rowObj.GetCells();
       var customer = cells.GetNamedItem("CustomerID");
       var city = customer.GetElement().attributes["City"].value;
       alert(city);
    }

See Also

Other Resources
Walkthrough Topics
How-to Topics


How-to: Enable column freezing and configure initial settings

How-to: Enable column freezing and configure initial settings
See Also Send Feedback

Glossary Item Box

Column freezing is one of WebGrid.NET Enterprise V5.0 new features that successfully implementing Microsoft Excel style column freezing feature.

In this topic, you will learn how to enable column freezing and configure initial settings.

To enable column freezing and configure initial settings

  1. Bind WebGrid to AccessDataSource (Using Customers table from NorthWind data source).
  2. Open WebGrid.NET SmartTag and select Allow Column Freezing.
  3. Open WebGrid.NET Designer - Layout Settings.
  4. Search for FreezePaneSettings.
  5. Set ActiveFrozenColumn to 1.

This setting will make CustomerID as the freezing column.

See Also

Tasks
How-to: Allow user to freeze/unfreeze at runtime
How-to: Change splitter line's appearance
How-to: Enable absolute scrolling

References
AllowColumnFreezing Property
FreezePaneSettings Property
ActiveFrozenColumns Property

Other Resources
Walkthrough Topics
How-to Topics


How-to: Allow user to freeze/unfreeze at runtime

How-to: Allow user to freeze/unfreeze at runtime
See Also Send Feedback

Glossary Item Box

WebGrid provides a method to freeze/unfreeze WebGrid column at runtime.

In this topic, you will learn how to set column freezing from designer.

To allow user to freeze/unfreeze at runtime

  1. Bind WebGrid to AccessDataSource (Using Customers table from NorthWind data source).
  2. Open WebGrid.NET SmartTag and check Allow Column Freezing.
  3. Open WebGrid.NET Designer - Layout Settings.
  4. Search for FreezePaneSettings.
  5. Set ShowInContextMenu to True.

Try to right click on WebGrid header (CompanyName) then click Freeze Pane.

The result is CustomerID and CompanyName columns will become freeze columns.

See Also

Tasks
How-to: Enable column freezing and configure initial settings
How-to: Change splitter line's appearance
How-to: Enable absolute scrolling

References
AllowColumnFreezing Property
FreezePaneSettings Property
ShowInContextMenu Property

Other Resources
Walkthrough Topics
How-to Topics


How-to: Change splitter line's appearance

How-to: Change splitter line's appearance
See Also Send Feedback

Glossary Item Box

You are able to change the FreezePane splitter line's appearance from designer.

In this topic, you will learn how to set the splitter line's appearance.

To change splitter line's appearance

  1. Enable column freezing.
  2. Open WebGrid.NET designer.
  3. Search for FreezePaneSettings.
  4. Set SplitterLineColor to ForestGreen.
  5. Set SplitterLineWidth to 5.

See Also

Tasks
How-to: Enable column freezing and configure initial settings
How-to: Allow user to freeze/unfreeze at runtime
How-to: Enable absolute scrolling

References
FreezePaneSettings Property
SplitterLineColor Property
SplitterLineWidth Property

Other Resources
Walkthrough Topics
How-to Topics


How-to: Enable absolute scrolling

How-to: Enable absolute scrolling
See Also Send Feedback

Glossary Item Box

With AbsoluteScrolling enabled, WebGrid is able to automatically adjust the viewport to the next available column when user pressed on the left/right arrow of horizontal scrollbar. This behavior allows users to conveniently scroll through all the columns with less clicks.

In this topic, you will learn how to enable absolute scrolling.

To enable absolute scrolling

  1. Enable column freezing.
  2. Open WebGrid.NET designer.
  3. Search for FreezePaneSettings.
  4. Set AbsoluteScrolling to True.

See Also

Tasks
How-to: Enable column freezing and configure initial settings
How-to: Allow user to freeze/unfreeze at runtime
How-to: Change splitter line's appearance

References
FreezePaneSettings Property
AbsoluteScrolling Property

Other Resources
Walkthrough Topics
How-to Topics


How-to: Enable Default Style for existing instance of WebGrid

How-to: Enable Default Style for existing instance of WebGrid
See Also Send Feedback

Glossary Item Box

You can enable default style in one of the three way described in the following:

  1. SmartTag Designer
    The easiest way to enable Default Style for an existing instance of WebGrid is through SmartTag Designer. SmartTag Designer is a new feature in WebGrid.NET version 5.0. To enable default style from SmartTag Designer:
    • Select an instance of WebGrid.
    • If the SmartTag Designer Panel does not appear, please click the [image] symbol that appears at the right top relatively to the WebGrid.
    • With the SmartTag Designer Panel displayed, click on the "Default Style" dropdown list which is under Styles category.

      Using SmartTag Designer is the recommended way to enable Default Style feature. The Default Style selection will automatically clean up all style tags in the control definition.
  2. Property Set
    You can also manually enable the Default Style feature by setting the UseDefaultStyle property to True in the Visual Studio's property window.

However note that this manual approach does not automatically clean up existing style definition.

See Also

Tasks
FAQ: What does Default Style look like?

References
UseDefaultStyle Property

Other Resources
Walkthrough Topics
How-to Topics


How-to: Configure SmartWebResources in a new web application

How-to: Configure SmartWebResources in a new web application
See Also Send Feedback

Glossary Item Box

As the best practice in using Intersoft 2007's product lines, you are recommended to perform the following steps after you have created a new web application or migrated an existing web application.

  1. Right click on one of the Intersoft's control instance. For instance, WebGrid1.
  2. Click Register SmartWebResources™ command in the context menu.

  3. In short time after you clicked the command, you should receive a message prompt similar to the following:
    "SmartWebResources has been successfully configured for this web application."

If you are receiving an error message, it is likely that you have not installed the product properly. Please note that you can't enable this feature in older products (non 2007-platform products).

To learn more about SmartWebResources, please read Introducing SmartWebResources™.

See Also

Tasks
How-to: Disable SmartWebResources for Localization's language files
FAQ: Does SmartWebResources feature automatically enabled in WebGrid.NET Enterprise 5.0?
FAQ: Briefly, what are the files included in WebGrid SmartWebResources Assembly?
FAQ: I got a warning message "ContextMenu is disabled due to missing resources" after page load in the browser. What should I do to resolve this problem?
FAQ: I am aware that WebGrid.NET Enterprise 5.0 requiring WebDesktop SmartWebResources as part of its User Interface engine. Do I need to purchase a separate WebDesktop's license in order to use its SmartWebResources?

Concepts
Hassle-free deployment through SmartWebResources™ technology

Other Resources
Walkthrough Topics
How-to Topics


How-to: Disable SmartWebResources for Localization's language files

How-to: Disable SmartWebResources for Localization's language files
See Also Send Feedback

Glossary Item Box

You can specifically disable the SmartWebResources for language files only without affecting SmartWebResources for scripts and other client resources.

To disable the SmartWebResources for language files, set UseWebResources of TextSettings object to false. When disabled, the language file will be retrieved using the classic physical path through IIS virtual directory. For instance, http://localhost/CommonLibrary/WebGrid/V5_0_7200/Localization/default.xml
Sample codes in C#:
WebGrid1.LayoutSettings.TextSettings.UseWebResources = false;
There are several scenarios where SmartWebResources need to be disabled for localization:
  • You want to use modified version of the language file.
  • You want to use new language file that is not included in WebGrid package.
If you want to change only specific item of text for webpage-specific scenario, you can override the text item by adding the entry in the TextItems collection of a WebGrid instance. This enables WebGrid to use SmartWebResources for the selected language and use the overridden TextItem that you have specified.

See Also

Tasks
How-to: Configure SmartWebResources in a new web application
FAQ: Does SmartWebResources feature automatically enabled in WebGrid.NET Enterprise 5.0?
FAQ: Briefly, what are the files included in WebGrid SmartWebResources Assembly?
FAQ: I got a warning message "ContextMenu is disabled due to missing resources" after page load in the browser. What should I do to resolve this problem?
FAQ: I am aware that WebGrid.NET Enterprise 5.0 requiring WebDesktop SmartWebResources as part of its User Interface engine. Do I need to purchase a separate WebDesktop's license in order to use its SmartWebResources?

Concepts
Hassle-free deployment through SmartWebResources™ technology

References
TextSettings Class
UseWebResources Property
LocalizationFolder Property

Other Resources
Walkthrough Topics
How-to Topics


How-to: Use avg aggregate in group header

How-to: Use avg aggregate in group header
See Also Send Feedback

Glossary Item Box

With the new feature to display basic aggregate functions in group header, you can display the calculated values without has to enable the GroupTotal feature.

In this topic, you will learn how to configure avg aggregate in group header .

To configure avg aggregate in group header

  1. Bind WebGrid to AccessDataSource1 (Using Orders table from NorthWind data source).
  2. Bind WebGrid to AccessDataSource2 (Using Employees table from NorthWind data source).
  3. Open WebGrid.NET Designer - Advanced tab - RootTable.
  4. Group the Orders table based on EmployeeID column by expanding the RootTable and choose GroupColumns.
  5. Go to EmployeeID column and click See All Properties to set the GroupRowInfoFormat property to [value] - Total Orders: [count] items. Average Freight: [avg(Freight)].
  6. Go to EmployeeID column and Expand ValueList and set the following properties:
    Property | Value
    DataSourceID | AccessDataSource2
    DataTextField | FirstName
    DataValueField | EmployeeID
  7. As the result, the avg aggregate will look like following:
    AVGAggregate

See Also

Tasks
Walkthrough: Using Custom Aggregate function in WebGrid
Walkthrough: Displaying GroupTotal of child table

References
DataSourceID Property
DataTextField Property
DataValueField Property
AggregateFunction Property
GroupRowInfoFormat Property

Other Resources
Walkthrough Topics
How-to Topics


How-to: Enable required input validation for a column

How-to: Enable required input validation for a column
See Also Send Feedback

Glossary Item Box

WebGrid.NET Enterprise 5.0 now provides built-in feature for Required Input during data editing and makes data validation a snap.

In this topic, you will learn how to configure required input validation for a column.

To configure required input validation for a column

  1. Bind WebGrid to AccessDataSource (Using Products table from NorthWind datasource).
  2. Open WebGrid.NET Designer - Advanced tabs - RootTable.
  3. Go to appropriate Column you want to enable the ResizableTextbox feature.
  4. Check the Cell requires user input checkbox.
  5. The error message can also be modified in Input Required Error Text property.

As the result, the error text will appear when cell requires user input.

RequiredInput

See Also

References
InputRequired Property
InputRequiredErrorText Property

Other Resources
Walkthrough Topics
How-to Topics


How-to: Configure a column to use ResizableTextBox editing type

How-to: Configure a column to use ResizableTextBox editing type
See Also Send Feedback

Glossary Item Box

WebGrid.NET 5.0 Enterprise redefines the editing experience by introducing a new edit type, resizable text box edit control. The resizable text box makes it easy and convenience for user while editing cell containing larger amount of text. With this new feature, user can easily resize the text box by dragging the resize handler at the bottom right position.

In this topic, you will learn how to configure a column to use ResizableTextBox editing type.

To configure a column to use ResizableTextbox editing type

  1. Bind WebGrid to AccessDataSource (Using Employees table from NorthWind datasource).
  2. Open WebGrid.NET Designer - Advanced tabs - RootTable.
  3. Go to appropriate Column you want to enable the ResizableTextbox feature.
  4. Set the Edit Control Type property to Resizable Textbox.

As the result, edited text box can be resized dynamically.

Resizable

See Also

References
EditType Property

Other Resources
Walkthrough Topics
How-to Topics


How-to: Configure FileCacheServer to use shared network's hard drive

How-to: Configure FileCacheServer to use shared network's hard drive
See Also Send Feedback

Glossary Item Box

WebGrid.NET Enterprise 5.0 now provides built-in feature to use shared network's hard drive to configure the FileCacheServer.

In this topic, you will learn how to use a shared network drive for the file server:

To configure FileCacheServer to use shared network's hard drive

  1. Bind WebGrid to AccessDataSource.
  2. Open WebGrid.NET Designer.
  3. Go to View State Settings, and set ViewStateStorage to FileServer.
  4. Set ViewStateServerConnection to "path=\\CacheServer\CacheStorage"
  5. Configure the identity of the account that has access to the server and network resources in web.config.

  6. Sample web.config setting for identity:
  7. <system.web>
    <identity impersonate="true" userName="CacheServer\CacheAccount" password="CachePassword" />
    </system.web>

See Also

Tasks
Walkthrough: Configuring WebGrid to keep data cache in local computer's hard drive

References
ViewStateStorage Property
ViewStateServerConnection Property

Other Resources
Walkthrough Topics
How-to Topics


How-to: Improve FlyPostBack performance

How-to: Improve FlyPostBack performance
See Also Send Feedback
Intersoft WebGrid > Miscellaneous WebGrid Settings > How-to: Improve FlyPostBack performance

Glossary Item Box

This topic will discuss the concept of FlyPostback architecture and how to improve its performance in Internet-zone web applications.

OnTheFly-Postback Introduction

Since introduced in WebCombo.NET V1.0 back in 2002, the FlyPostBack architecture developed by Intersoft Solutions have been significantly enhanced from time to time, until the release of WebUI.NET Framework 2.0.

Today we have seen the trend of AJAX or callback in ASP.NET 2.0, component vendors are now focusing to provide similar functionality to their products. Many of our customers have asked whether AJAX is something similar to our OnTheFly-Postback architecture, or is it something new. In this article, I'll try to explore some comparison of concepts and functionalities between our architecture and the others.

FlyPostback concepts and features

As you may have already know, AJAX is not a technology, it is an approach. It basically means that the approach used Asynchronous Javascript and XML to perform communications between client and server by using XmlHttp request which is supported by most modern browsers. So the whole idea is XmlHttp request. However, XmlHttp is not a new thing, it has been existed since 2001 when Microsoft introduced Internet Explorer 5.0. The point is, it is just getting attention and becomes popular recently as Gecko and Opera started to support it.

FlyPostback architecture is not just about using XmlHttp request to perform out-of-band callbacks to server and then obtain the response from server. FlyPostback is kind of framework or engine which built on the top of XmlHttp plus our own features implementation to bring a new standards for our ASP.NET components product line.

To clearly understand the concept of FlyPostback architecture, I've listed some of the unique features below which can't be accomplished by other similar XmlHttp-based approach:

  • Full ASP.NET Framework and Page support

    It means that FlyPostback supports any kind of ASP.NET Framework scenarios and page life cycle. For example, you can use inline <% %> server side codes in the aspx and the FlyPostback can still perform perfectly. The FlyPostback can work seamlessly and do not require you to configure HttpModule or any changes in your web configuration file.

  • ViewState restoration.

    Unlike other XmlHttp approach, FlyPostback automatically restores the viewstate of all server controls available in the Page. This enables developers to be able to obtain other controls' value while in the FlyPostback context.

  • Controls state and input parameters

    All products that built on the top of FlyPostback architecture such as WebGrid.NET Enterprise and WebCombo.NET will have its state automatically maintained by the FlyPostback architecture. This is very crucial and important for developers in order to extend the products functionalities to fit their custom logics. For example, I can get the selected object of WebGrid1 instance while the current context of FlyPostback is initiated by WebGrid2. I will then be able to populate data based on the selection made in WebGrid1. Remember that we're on FlyPostback context, not a full page postback.

    I can also add custom parameters and send it along with the FlyPostback request, for example, adding additional data or flag during updating row. It can be easily done by using AddInput() method which is applicable to all products that supported FlyPostback.

Improving FlyPostback performance

Now, the interesting part of this article is how we can improve the performance of FlyPostback. By understanding the concepts and features above, we clearly understand that FlyPostback architecture posted quite a lot of data during the request. There is no significant performance issues when the application is running in intranet or extranet zone, however when utilized in public website -- and especially when end users used narrow-bandwith, it is noticable that the FlyPostback request is a bit slow in the response.

In WebUI.NET Framework 2.0, we have developed a few properties which developers can configure in order to turn off specific features of FlyPostback in case they did not utilize it in their applications. Many of our customers still have not aware of these capabilities and hopefully with this article, they would be able to set best configuration to use for their applications.

Following are the list of features which may be turned off to improve the response time of FlyPostback request. These settings can be found in FlyPostbackSettings object in control's instance:

  • PostViewState.

    The value is True by default. When set to true, FlyPostback will automatically restores the viewstate of all server controls available in the page. So, if you do not access other controls' properties in FlyPostback context, you can safely set this property to False. This will give significant improvement especially when the viewstate of the Page is large.

  • PostHiddenFields.

    The default value is True. If you do not access hidden fields on page load or in FlyPostback requests, you can safely turn off this feature by setting it to False.

  • PostInputControls.

    The default value is False. This feature enables you to get the latest value for the html input fields in the FlyPostback context. If you do not need to access other controls' value (such as TextBox's value), then you should have this property's value remain False.

  • PostControlState.

    This is a new property added in WebUI.NET Framework Build 12. The default value is True. In previous build, you have to turn on PostHiddenFields in order for the FlyPostback's control to maintain its state properly during request. However, since PostHiddenFields also send out other controls' hidden fields, it becomes ineffective and causing slower response time due to larger post data. Now, you can safely turn off PostHiddenFields and leaving this property value to True.

    The control state is the most interesting point in the features above since it needs to be configured properly, otherwise client interactions will react improperly. The best value for this configuration is based on the nature of product and which features are enabled. For example, in WebCombo, you may turn off this feature since WebCombo did not have as much client interaction as in WebGrid. As for WebGrid, this feature is recommended to be turned on (by default). There are however, certain scenarios where you can safely turn off this feature in WebGrid. For instance, if your Grid instance does not require clientside user interactions features such as column moving, resizing, sorting, filtering or others, then you can safely turn off this feature. These scenarios are suitable for application which require only hierarchical load on demand Grid mode or self hierarchical load on demand feature.

By summary, if you do not access other controls' value or properties, here's the most recommended FlyPostBackSettings:

For WebCombo.NET 3.0:

  • PostViewState = False
  • PostHiddenFields = False
  • PostInputControls = False
  • PostControlState = False

For WebGrid.NET Enterprise 4.0:

  • PostViewState=False
  • PostHiddenFields=False
  • PostInputControls=False
  • PostControlState=True

With above configurations, you'll get a significant response time improvement of every FlyPostback requests by at least 60%. Thus, if previously it needs 3 seconds to load WebCombo during dropdown, you'll now get the results in 1 or 1.5 seconds. Again, note that the context of this article is using narrow-bandwith protocols such as dialup

Conclusion

As a proof of concept, we have also modified our live samples to use minimal features since they are not utilized in common basic scenarios. For WebCombo, please take a look and play with the "Basic" sample. For WebGrid, play with the "Hierarchical" sample. Then, compare with other samples. You'll be able to see significant response time improvement in both samples mentioned above.

As a final note, you would need to update to latest build for the framework and all products in order to take advantage of some of the new functionalities.

The Future

Our current FlyPostback architecture enables the options to provide richer functionalities, or to tradeoff between speed and functionalities. In the future, we would provide a new breakthrough in the server communication architecture, enabling both rich functionalities and speed to work in harmony.

See Also

References
OnTheFly-PostBack Architecture and Concepts
Improved OnTheFly-Postback and ClientAction Engine

Other Resources
Miscellaneous WebGrid Settings
Walkthrough Topics
How-to Topics


How-to: Improve performance using designer

How-to: Improve performance using designer
See Also Send Feedback
Intersoft WebGrid > Miscellaneous WebGrid Settings > How-to: Improve performance using designer

Glossary Item Box

This topic will discuss how to improve performance by managed WebGrid's caching, Client performance, Server performance and AJAX performance using WebGrid.NET Designer.

Caching

WebGrid.NET control includes automatic data caching feature to help reducing database workload. When enabled, a copy of datasource per user session will be stored in cache. As long as the cache is still valid and active, WebGrid will use the cached data for all data-aware functions, including during AJAX callback and full page postback.

Please note that this feature does not take into affect when the WebGrid is bound to DataSourceControl because DatasourceControl already has its own Caching mechanism and is more sophisticated. This feature is designed to traditional datasouce binding (eg. via InitializeDataSource event)

  • Data Cache Storage. Specifies a location that hold the temporary data cache.
  1. Page Cache.
    This is a good option to cache relatively small datasource.
    The cache is oftenly cleared when the system needs more memory resource.
  2. Session
    Store data cache to ASP.NET Session.
    This is a good option to store user-specified datasource. Session is also recommended when you need data to remain cached as long as the user's session is active .
  3. File Server
    Store data cache to physical disk, usually file server.
    This is a preferrence when you need to cache relatively large data source in a long time span.
    Please note that this option may be slower than in-memory storage.

    If you have set Data Cache to File Server, you must specify FileServer Connection. Example "C:\CacheStorage". Note that you need to set read and write permission for the worker process to access the specified path
  • Use cached data on first load. This is an advanced setting and should be set to false in common scenarios.
    If you set this setting to True, then when first load WebGrid will find whether there is a cached data or not. If there is a cached data, then WebGrid's data will be loaded base on the cached data.

Performance Tuning

Performance tuning in WebGrid can be grouped into 3 categories.

  1. Client performance.
    The tuning significantly reduces page output size which results in faster page response
    • Enable default style feature.
      When default style is enabled, WebGrid does not generate individual control style in the rendered page. This results in significantly reduced page size, especially when there are lot of WebGrid instances in the page
    • Use WebStyleManager to apply theme globally into entire application.
      WebStyleManager is a great way for applying global theme to entire application. WebStyleManager allows you to use custom styles with high page performance by generating the styles into external stylesheet.
      To learn more about WebStyleManager, please refer to WebDesktop.NET documentation, and read the concepts under WebStyleManager's topic.
  2. Server performance.
    You can gain better page throughput and performance by using appropriate Cache configuration and ViewState setting.
    • Reduce database workload by caching frequently used data.
      Appropriate utilization of built-in data cache feature in WebGrid.NET can help in delivering better response and page performance in overall.
    • Determine best ViewStateStorage configuration-set for this control.
      • ViewState Storage
        1. None
        2. PageCache
        3. Session
        4. FileServer
        With this setting, you can choose where to store the view state of this control. In common simple scenarios, you can set this to None which result in best performance. Set to FileServer if you want maximum availability and access to the state from multiple web servers
      • ViewState Item.
        1. Behavior
        2. BehaviorAndCollection
        3. BehaviorAndStyle
        4. All
        Select the kind of properties that should be saved in the view state. The behavior option should result in best performance.
      • ViewState FileServer Connection.
        If you choose FileServer option for ViewStateStorage, you need to set the FileServer Connection.
        Example : "C:\CacheStorage".
        Note that you need to set read and write permission for the worker process to access the specified path
  3. AJAX performance (Advanced).
    By properly configuring the following settings, you can significantly improve AJAX's callback performance. These settings are applicable only in DataBound mode usage.
      • Post control state.
        When set to true, the control state is submitted during AJAX call.
        If you set the control's properties in design-time to repopulate during postback, you can set this option to False.
      • Post hidden fields.
        When set to True, the hidden fields in this page are submitted along the AJAX call.
        If you do need to access hidden fields in WebGrid events, you can generally set this option to False
      • Post INPUT controls.
        When set to True, the INPUT controls such as textbox, radio button, check box and other html input controls are submitted along the AJAX call.
        If you do not access these controls (or you do not need to obtain the values of these controls), you can set this option to False
      • Post view state.
        When set to true, the viewstate of the page is submitted along the AJAX call.
        If you do not need to access or interact with other controls in the page during WebGrid's AJAX events, you can set this option to False

See Also

Other Resources
Miscellaneous WebGrid Settings
Walkthrough Topics
How-to Topics


How-to: Use CacheToDisk feature to reduce memory usage

How-to: Use CacheToDisk feature to reduce memory usage
See Also Send Feedback

Glossary Item Box

In exporting WebGrid, you can use cache to disk feature to reduce memory usage and memory performance enhancement.

To enable the CacheToDisk in WebGrid

  1. Drag WebGrid to the WebForm.
  2. Go to WebGrid properties, server side event.
  3. Attach the WebGrid Export event into the WebGrid.
  4. Specify the CacheToDisk property to True.

    C# Copy Image Copy Code
    private void WebGrid1_Export(object sender, ISNet.WebUI.WebGrid.ExportEventArgs e)
    {
       e.ReportInfo.CacheToDisk = true;
    }

  5. Run the project.

See Also

Tasks
How-to: Invoke Export feature programmatically
How-to: Customize Export function
How-to: Export text when WebValueList is used
How-to: Set a different location for CacheToDisk feature

Other Resources
Walkthrough Topics
How-to Topics


How-to: Set a different location for CacheToDisk feature

How-to: Set a different location for CacheToDisk feature
See Also Send Feedback

Glossary Item Box

In exporting WebGrid, you can use cache to disk feature to reduce memory usage and memory performance enhancement. However, the cache to disk location can be set manually depends on the user needs.

To set different location for CacheToDisk feature in WebGrid

  1. Drag WebGrid to the WebForm.
  2. Go to WebGrid properties, server side event.
  3. Attach the WebGrid Export event into the WebGrid.
  4. Specify the CacheToDiskLocation property in the local harddisk.

    C# Copy Image Copy Code
    private void WebGrid1_Export(object sender, ISNet.WebUI.WebGrid.ExportEventArgs e)
    {
       e.ReportInfo.CacheToDiskLocation = "c:\\ExportPath\\";
    }

  5. Run the project.

See Also

Tasks
How-to: Invoke Export feature programmatically
How-to: Customize Export function
How-to: Export text when WebValueList is used
How-to: Use CacheToDisk feature to reduce memory usage

Other Resources
Walkthrough Topics
How-to Topics


How-to: Hide Chart Ribbon Initially

How-to: Hide Chart Ribbon Initially
See Also Send Feedback

Glossary Item Box

WebGrid.NET Enterprise 6.0 comes with Interactive UI feature where you can customize the ChartView at run time.

In this topic, you will learn how to enable hide chart ribbon initially in WebGrid.

To hide Chart Ribbon initially in WebGrid

  1. Open WebGrid.NET Properties.
  2. In Charting properties go to ChartInteractiveUI and set RibbonState to Hidden.
  3. Run the project.

See Also

Tasks
How-to: Customize Chart Ribbon
How-to: Customize Available Chart Types
How-to: Customize Pivot Rules

Other Resources
Walkthrough Topics
How-to Topics


How-to: Customize Chart Ribbon

How-to: Customize Chart Ribbon
See Also Send Feedback

Glossary Item Box

WebGrid.NET Enterprise 6.0 has a feature to customize the Chart Ribbon. With this option, you can limit what kind of interactions that a user can do with Chart Interactive UI.

In this topic, you will learn how to customize chart ribbon in WebGrid.

To customize Chart Ribbon in WebGrid

  1. Open WebGrid.NET Properties.
  2. In Charting properties go to ChartInteractiveUI, set TitlesRibbon visible to false.
  3. Set ChartTypeRibbon visible to false.
  4. Run the project.

See Also

Tasks
How-to: Hide Chart Ribbon Initially
How-to: Customize Available Chart Types
How-to: Customize Pivot Rules

Other Resources
Walkthrough Topics
How-to Topics


How-to: Customize Pivot Rules

How-to: Customize Pivot Rules
See Also Send Feedback

Glossary Item Box

WebGrid.NET Enterprise 6.0 comes with Interactive UI feature where you can customize the ChartView at run time. The pivoting rules for the Chart Interactive UI includes:

  • ShowInChartFieldList
  • CanAddToChartData
  • CanAddToChartCategories
  • CanAddToChartFilter
  • CanAddToChartSeries

In this topic, you will learn how to customize Pivot Rules in WebGrid.

To customize Pivot Rules in WebGrid

  1. Open WebGrid.NET Designer.
  2. Switch to Advanced tab. Expand RootTable >> Columns.
  3. Choose appropriate WebGridColumn Properties, customize one or all properties from above pivoting rules. For example: Select OrderID and set ShowInChartFieldList to true.
  4. Run the project.

See Also

Tasks
How-to: Hide Chart Ribbon Initially
How-to: Customize Chart Ribbon
How-to: Customize Available Chart Types

Other Resources
Walkthrough Topics
How-to Topics


How-to: Customize Available Chart Types

How-to: Customize Available Chart Types
See Also Send Feedback

Glossary Item Box

WebGrid.NET 6.0 has an ability to customize list of chart types that user can select. The chart type includes:

  • AreaType
  • BarType
  • ColumnType
  • DoughnutType
  • LineType
  • PieType
  • SmoothLineType
  • StepLineType

In this topic, you will learn how to customize available chart typed in WebGrid.

To customize available Chart Types in WebGrid

  1. Open WebGrid.NET Properties.
  2. In Charting properties go to ChartInteractiveUI then ChartTypeRibbon.
  3. Set Enable property to one of the chart type.
  4. Run the project.

See Also

Tasks
How-to: Hide Chart Ribbon Initially
How-to: Customize Chart Ribbon
How-to: Customize Pivot Rules

Other Resources
Walkthrough Topics
How-to Topics


How-to: Enable Pivot Charting in WebGrid

How-to: Enable Pivot Charting in WebGrid
See Also Send Feedback

Glossary Item Box

WebGrid provides a feature to enable pivot charting.

In this topic, you will learn how to enable pivot charting in webgrid.

To enable Pivot Charting in WebGrid

  1. Right click on WebGrid instance and click on WebGrid.Net Designer.
  2. Check the Allow Pivot Charting in Pivot Charting tab.
  3. Click Apply >> OK.
  4. Run the project.

See Also

Concepts
Pivot Charting in WebGrid.NET Enterprise 6.0
Pivot Charting and Business Intelligence

Other Resources
Walkthrough Topics
How-to Topics


How-to: Show Pivot Chart view initially

How-to: Show Pivot Chart view initially
See Also Send Feedback

Glossary Item Box

WebGrid provides a feature that enables the grid to show Pivot Chart view initially. But you can still revert back to GridView from status bar.

In this topic, you will learn how to show pivot chart view initially.

To show Pivot Chart view initially

  1. Right click on WebGrid instance and click on WebGrid.Net Designer.
  2. Go to Advanced tab >> WebGrid >> LayoutSettings and set the InitialView to PivotChartView.
  3. Click Apply >> OK.
  4. Run the project.

See Also

Tasks
How-to: Display Pivot Chart only
How-to: Display both Pivot Chart and Grid View
How-to: Move Pivot Chart view to another container using WebTab
How-to: Set Pivot Chart's container to fit browser's width and height
How-to: Customize list of Chart Types

Other Resources
Walkthrough Topics
How-to Topics


How-to: Display Pivot Chart only

How-to: Display Pivot Chart only
See Also Send Feedback

Glossary Item Box

WebGrid provides a feature that enables the grid to show only Pivot Chart view and you can not revert back to GridView.

In this topic, you will learn how to show pivot chart only.

To display pivot chart only

  1. Right click on WebGrid instance and click on WebGrid.Net Designer.
  2. Go to Advanced tab >> WebGrid >> LayoutSettings and set the InitialView to PivotChartViewExclusive.
  3. Click Apply >> OK.
  4. Run the project.

See Also

Tasks
How-to: Show Pivot Chart view initially
How-to: Display both Pivot Chart and Grid View
How-to: Move Pivot Chart view to another container using WebTab
How-to: Set Pivot Chart's container to fit browser's width and height
How-to: Customize list of Chart Types

Other Resources
Walkthrough Topics
How-to Topics


How-to: Display both Pivot Chart and Grid View

How-to: Display both Pivot Chart and Grid View
See Also Send Feedback

Glossary Item Box

WebGrid provides a feature that enables the grid to display both pivot chart and grid view.

In this topic, you will learn how to display both pivot chart and grid view.

To display both Pivot Chart and Grid View

  1. Right click on WebGrid instance and click on WebGrid.Net Designer.
  2. Go to Advanced tab >> WebGrid >> LayoutSettings and set the InitialView to Both.
  3. You also need to set the ChartDisplayPosition to Bottom.
  4. Click Apply >> OK.
  5. Run the project.

See Also

Tasks
How-to: Show Pivot Chart view initially
How-to: Display Pivot Chart only
How-to: Move Pivot Chart view to another container using WebTab
How-to: Set Pivot Chart's container to fit browser's width and height
How-to: Customize list of Chart Types

Other Resources
Walkthrough Topics
How-to Topics


How-to: Move Pivot Chart view to another container using WebTab

How-to: Move Pivot Chart view to another container using WebTab
See Also Send Feedback

Glossary Item Box

WebGrid's chart can be moved to view in another container (e.g WebTab).

In this topic, you will learn how to move Pivot Chart view to another container using WebTab.

To move pivot chart view to another container using WebTab

  1. Display both Pivot Chart and Grid View.
  2. Drag WebTab to the page.
  3. On the first tab of WebTab, add a div and named it ChartImage.
  4. On the second tab, put the WebGrid.
  5. Click on WebGrid instance and press F4.
  6. Set ChartDisplayPosition property in Advanced tab >> WebGrid to Custom.
  7. Set ChartCustomContainerId property in Advanced tab >> WebGrid to ChartImage.
  8. Run the project.

See Also

Tasks
How-to: Show Pivot Chart view initially
How-to: Display Pivot Chart only
How-to: Display both Pivot Chart and Grid View
How-to: Set Pivot Chart's container to fit browser's width and height
How-to: Customize list of Chart Types

Other Resources
Walkthrough Topics
How-to Topics


How-to: Set Pivot Chart's container to fit browser's width and height

How-to: Set Pivot Chart's container to fit browser's width and height
See Also Send Feedback

Glossary Item Box

WebGrid can be set to fit browser's width and height.

In this topic, you will learn how to set Pivot Chart's container to fit browser width and height.

To set Pivot Chart's container to fit browser's width and height

  1. Display Pivot Chart only.
  2. Click on WebGrid instance and press F4.
  3. Set WebGrid's height and width to 100%.
  4. Run the project.

See Also

Tasks
How-to: Show Pivot Chart view initially
How-to: Display Pivot Chart only
How-to: Display both Pivot Chart and Grid View
How-to: Move Pivot Chart view to another container using WebTab
How-to: Customize list of Chart Types

Other Resources
Walkthrough Topics
How-to Topics


How-to: Customize list of Chart Types

How-to: Customize list of Chart Types
See Also Send Feedback

Glossary Item Box

WebGrid allows the chart types to be customized.

In this topic, you will learn how to customize list of chart types.

To customize list of Chart Types

  1. Right click on WebGrid instance and click on WebGrid.Net Designer.
  2. On Pivot Charting tab select Chart Interactive UI >> Chart Type Ribbon.
  3. On Bar Type scrollable pane, uncheck the Enable user to switch to Bar type property.
  4. On Line Type scrollable pane, uncheck the Enable user to switch to Line type property.
  5. On Smooth Line Type scrollable pane, uncheck the Enable user to switch to Smooth Line type property.
  6. On Step Line Type scrollable pane, uncheck the Enable user to switch to Step Line type property.
  7. On Pie Type scrollable pane, uncheck the Enable user to switch to Pie type property.
  8. On Doughnut Type scrollable pane, uncheck the Enable user to switch to Doughnut type property.
  9. On Area Type scrollable pane, uncheck the Enable user to switch to Area type property.
  10. Click Apply >> OK.
  11. Run the project.

See Also

Tasks
How-to: Show Pivot Chart view initially
How-to: Display Pivot Chart only
How-to: Display both Pivot Chart and Grid View
How-to: Move Pivot Chart view to another container using WebTab
How-to: Set Pivot Chart's container to fit browser's width and height

Other Resources
Walkthrough Topics
How-to Topics


How-to: Change the position of the chart legend

How-to: Change the position of the chart legend
See Also Send Feedback

Glossary Item Box

By default, the chart legend position is set to right. However, you can change the position to None, Top, Bottom, or Left.

In this topic, you will learn how to the change the position of the chart legend.

To change the position of the chart legend to Left

  1. Open WebGrid.NET Designer.
  2. Go to Pivot Charting Tab.
  3. Select Legend.
  4. In the Docking, set the Docking to Left.

  5. Click OK to apply the changes.
  6. Run the project.

See Also

Tasks
How-to: Change the layout of the chart legend

Other Resources
Walkthrough Topics
How-to Topics


How-to: Change the layout of the chart legend

How-to: Change the layout of the chart legend
See Also Send Feedback

Glossary Item Box

By default, the chart legend layout is RowOnly. However, you can change the layout to ColsOnly, RowFixed, or ColsFixed.

In this topic, you will learn how to the change the position of the char legend.

To change the layout of the chart legend

  1. Open WebGrid.NET Designer.
  2. Go to Pivot Charting Tab.
  3. Select Legend.
  4. In the Layout, set the Expand Mode to ColsOnly.
  5. Click OK to apply the changes.
  6. Run the project.

See Also

Tasks
How-to: Change the position of the chart legend

Other Resources
Walkthrough Topics
How-to Topics


How-to: Change the chart title/header position in the chart image

How-to: Change the chart title/header position in the chart image
See Also Send Feedback

Glossary Item Box

WebGrid provides a way for you to change the chart title or header position.

In this topic, you will learn how to the change the chart title or header position in the chart image.

To change the chart title/header position in the chart image.

  1. Open WebGrid.NET Designer.
  2. Go to Pivot Charting Tab.
  3. Select Header and click See all properties.
  4. Set the Text to "Chart Header".
  5. Select TextStyle >> FontStyle.
  6. Set the EmSize to 18.
  7. Click OK to apply the changes.
  8. Run the project.
  9. Please see the Chart Header Layout from LiveSamples >> WebGrid >> ChartHeader for the result.

See Also

Other Resources
Walkthrough Topics
How-to Topics


How-to: Invert the chart axis value

How-to: Invert the chart axis value
See Also Send Feedback

Glossary Item Box

WebGrid provides a way for you to change the chart axis value.

In this topic, you will learn how to invert chart axis value.

To invert the chart axis value

  1. Open WebGrid.NET Designer.
  2. Go to Pivot Charting Tab.
  3. Select Axis >> Y Axis.
  4. Set Invert to True.
  5. Click OK to apply the changes.
  6. Run the project.

See Also

Tasks
How-to: Change the label orientation mode

Other Resources
Walkthrough Topics
How-to Topics


How-to: Change the label orientation mode

How-to: Change the label orientation mode
See Also Send Feedback

Glossary Item Box

WebGrid provides a way to change the label orientation mode for X Axis, Y Axis and Z Axis.

There are 7 types of Label orientation mode (SingleLevel, Stagger2, Stagger3, Rotate30, Rotate45, Rotate90 and AutoScale). Except SingleLevel mode, all the styles will be applied if the number of data point is quite large.

In SingleLevel mode , the chart engine has the capability to determine the size and the stagger level. If you prefer to have only one line at all cost, try the AutoScale mode. The default mode of Label orientation is SingleLevel.

In this topic, you will learn how to change the Label orientation mode.

To change the label orientation mode

  1. Open WebGrid.NET Designer.
  2. Go to Pivot Charting Tab.
  3. Select Axis >> Y Axis.
  4. Set the Label orientation to AutoScale.
  5. Click OK to apply the changes.
  6. Run the project.

See Also

Tasks
How-to: Invert the chart axis value

Other Resources
Walkthrough Topics
How-to Topics


How-to: Demonstrate the bounds mode effect

How-to: Demonstrate the bounds mode effect
See Also Send Feedback

Glossary Item Box

WebGrid 6.0 charting has some bounds mode that can be set such as Stretch, Fit, None, Automatic.

In this topic, you will learn how to demonstrate the bounds mode effect to the Chart.

To demonstrate the bounds mode effect

  1. Open WebGrid.NET Designer.
  2. Go to Pivot Charting Tab.
  3. In the first Content Panel Mode, please set these following setting:

    Properties | Value
    BoundsMode | Stretch

  4. Click OK to apply the changes.
  5. Run the project.

See Also

Other Resources
Walkthrough Topics
How-to Topics


How-to: Change the chart wall style appearance

How-to: Change the chart wall style appearance
See Also Send Feedback

Glossary Item Box

In WebGrid 6.0 charting, you can determine which chart wall type appearance to be applied.

In this topic, you will learn how to change the chart wall type appearance.

To change the chart wall type appearance

  1. Open WebGrid.NET Designer.
  2. Go to Pivot Charting Tab.
  3. Choose ChartWall and set the Back, Floor and Left style collection.
  4. Go to GradientFillStyle under FillStyle, Back style collection and set following properties.

    Properties | Value
    BeginColor | SteelBlue
    EndColor | AliceBlue
  5. Go to GradientFillStyle under FillStyle, Floor style collection and set following property.

    Properties | Value
    ColorFillStyle | AliceBlue

  6. Go to GradientFillStyle under FillStyle, Left style collection and set following properties.

    Properties | Value
    BeginColor | SteelBlue
    EndColor | AliceBlue

  7. Click OK to apply the changes.
  8. Run the project.

See Also

Other Resources
Walkthrough Topics
How-to Topics


How-to: Change the chart background appearance

How-to: Change the chart background appearance
See Also Send Feedback

Glossary Item Box

In WebGrid 6.0 charting, you can determine which type of fill style to be applied.

In this topic, you will learn how to change the chart background appearance.

To change the chart background appearance

  1. Open WebGrid.NET Designer.
  2. Go to Pivot Charting Tab.
  3. Choose Background and set the FillStyle collection.
  4. Go to ColorFillStyle under the FillStyle and set following property.

    Properties | Value
    Color | AliceBlue

  5. Click OK to apply the changes.
  6. Run the project.

See Also

Other Resources
Walkthrough Topics
How-to Topics


How-to: Set SortAscImage and SortDescImage to Images located in root application directory

How-to: Set SortAscImage and SortDescImage to Images located in root application directory
See Also Send Feedback

Glossary Item Box

Everytime WebGrid implements sorting feature, you can see the sorting image right beside the column's name.

This topic will show you how to set SortAscImage and SortDescImage to Images located in root application directory.

To set SortAscImage and SortDescImage to Images located in root application directory

  1. Click on WebGrid instance and press F4 to open its properties window.
  2. Focus on LayoutSettings >> ImageSettings.
  3. You can set the SortAscImage and SortDescImage to the image that is located inside your project.

    If your image located at the same root with your page, then you can set the SortAscImage and SortDescImage to "./your image name.jpg". Else if your image located at the root and your page are inside a folder, then you can set the SortAscImage and SortDescImage to "../your image name.jpg".

See Also

Other Resources
Miscellaneous WebGrid Settings
Walkthrough Topics
How-to Topics


How-to: Programmatically set WebValueList's DataSource

How-to: Programmatically set WebValueList's DataSource
See Also Send Feedback

Glossary Item Box

You can set WebValueList for WebGrid programmatically.

In this topic, you will learn the basic thing on how to programmatically set WebValueList's DataSource.

To programmatically set WebValueList's DataSource

  1. On WebGrid's PrepareDataBinding event handler, add the following code:

    C# Copy Image Copy Code
    protected void WebGrid1_PrepareDataBinding(object sender, ISNet.WebUI.WebGrid.DataSourceEventArgs e)
{
    if (!IsPostBack)
    {
        WebGrid1.RetrieveStructure();
    }
    WebValueList vlCat = WebGrid1.RootTable.Columns.GetNamedItem("CategoryID").ValueList;
    vlCat.SetDataSource("ISDataSource1", "Categories", "CategoryName", "CategoryID");
}

  2. Run the project.

See Also

Tasks
Walkthrough: Binding a WebValueList to a table defined in ISDataSourceControl
Walkthrough: Binding a WebValueList to different DataSource control

Other Resources
Walkthrough Topics
How-to Topics


How-to: Access the selected rows in client side and server side

How-to: Access the selected rows in client side and server side
See Also Send Feedback

Glossary Item Box

To get the selected rows in client side, you can use GetCheckedRows() method of a WebGridTable instance. It is the same method used in initial RowChecker feature.

Similarly, to get the selected rows in server side, you use the GetCheckedRows() method of a WebGridTable instance. See following example:

C# Copy Image Copy Code
protected void button1_Click(object sender, EventArgs e)
{
    Response.Write(WebGrid1.RootTable.GetCheckedRows().Count);
}

See Also

Other Resources
Walkthrough Topics
How-to Topics


How-to: Use ButtonImage column type and assign the Image of the Button

How-to: Use ButtonImage column type and assign the Image of the Button
See Also Send Feedback

Glossary Item Box

WebGrid now includes a new ButtonImage column type. Therefore, you can simply display a button with image.

In this topic, you will learn how to display button image in WebGrid.

To use ButtonImage column type

  1. Bind WebGrid to AccessDataSource (Using Customers table from NorthWind data source).
  2. Open WebGrid.NET Designer >> Advanced.
  3. Go to RootTable >> Columns. Add a new column and named it as btnImage.
  4. Set Column Type to Button Image, ButtonAutoPostBack to True and ButtonImage to the location of the image's directory.
  5. Click OK to apply the settings.
  6. Save and run the project. The ButtonImage column type will look like following:

See Also

Tasks
Walkthrough: Utilizing various ColumnTypes

Other Resources
Walkthrough Topics
How-to Topics


How-to: Set AllowPrint

How-to: Set AllowPrint
Send Feedback
Intersoft WebGrid > Miscellaneous WebGrid Settings > How-to: Set AllowPrint

Glossary Item Box

WebGrid provides 'AllowPrint' property which is very helpful to print the WebGrid.

In this topic, you will learn the basic thing on how to set AllowPrint in WebGrid.

To set AllowPrint in WebGrid:

  1. Click on WebGrid's instance.
  2. Then, press F4 to show WebGrid's properties.
  3. Go to LayoutSettings property and choose AllowPrint property.
  4. Set AllowPrint to Yes.
    To use Print functionality correctly, you need to set BrowserPrinterSettings correctly.


Server-side References

Server-side References
Send Feedback
Intersoft WebGrid > Server-side References

Glossary Item Box

This section is designated to help user working with server-side references in WebGrid.NET.


ISNet.WebUI.WebGrid Namespace

ISNet.WebUI.WebGrid Namespace
See Also Inheritance Hierarchy Send Feedback

Glossary Item Box

Classes

 | Class | Description
Class | AutoIncrementAttribute |
Class | BaseEventArgs |
Class | BatchUpdateEventArgs |
Class | BrowserPrintSettings |
Class | ButtonEventArgs |
Class | CaptionAttribute |
Class | CellEventArgs |
Class | ChartFillStyle |
Class | ChartLightSourceSettings |
Class | ChartMarkerStyle |
Class | ChartPivotConfig |
Class | ChartPivotDataConfig |
Class | ChartPivotFilterConfig |
Class | ChartScaleStripStyle |
Class | ChildTableDataSourceEventArgs |
Class | ClientEvents |
Class | ClientSideAction |
Class | ColumnEventArgs |
Class | ColumnSetSettings |
Class | CustomAggregateArgs |
Class | CustomEditorEditor |
Class | CustomEditorNameEditor |
Class | CustomVirtualLoad |
Class | DataFieldEditor |
Class | DataSourceEventArgs |
Class | DynARInfo |
Class | ExportCompletedEventArgs |
Class | ExportEventArgs |
Class | FieldTypeEditor |
Class | FilterEventArgs |
Class | FocusStyle |
Class | GenericContainerTemplate |
Class | GenericDataSourceTableSchema |
Class | GroupByBoxObject |
Class | ImageSettings |
Class | LayoutEventArgs |
Class | LayoutSet |
Class | Margins |
Class | NonRetrievableAttribute |
Class | ObjectRow |
Class | PostBackAction |
Class | PostbackEventArgs |
Class | PrepareExportExecuteEventArgs |
Class | PreviewRowSettings |
Class | PrimaryKeyAttribute |
Class | RowChangedEventArgs |
Class | RowEventArgs |
Class | SelectedObject |
Class | SelfReferencingSettings |
Class | SortEventArgs |
Class | SpanEventArgs |
Class | TableEventArgs |
Class | TextItemEditor |
Class | TextSettings |
Class | WebComboEditor |
Class | WebGrid |
Class | WebGridBatchUpdateException |
Class | WebGridBatchUpdateSettings |
Class | WebGridCell |
Class | WebGridCellCollection |
Class | WebGridCellData |
Class | WebGridCellTemplateContainer |
Class | WebGridClientBindingSettings |
Class | WebGridColumn |
Class | WebGridColumnCollection |
Class | WebGridColumnSet |
Class | WebGridColumnSetCollection |
Class | WebGridCommandItem |
Class | WebGridComponentEditor |
Class | WebGridCustomEditor |
Class | WebGridCustomEditorBehavior |
Class | WebGridCustomEditorCollection |
Class | WebGridDataSourceInfo |
Class | WebGridDesigner |
Class | WebGridFilter |
Class | WebGridFilterCollection |
Class | WebGridFormatCondition |
Class | WebGridFormatConditionCollection |
Class | WebGridFormatStyle |
Class | WebGridFreezePaneSettings |
Class | WebGridGroup |
Class | WebGridGroupCollection |
Class | WebGridObjectRelation |
Class | WebGridRow |
Class | WebGridRowChanges |
Class | WebGridRowCollection |
Class | WebGridRowLayout |
Class | WebGridRowLayoutCollection |
Class | WebGridScrollBarStyle |
Class | WebGridTable |
Class | WebGridTableCollection |
Class | WebGridTextItem |
Class | WebGridTextItemCollection |
Class | WebValueList |

Interfaces

 | Interface | Description
Interface | IHierarchicalList |
Interface | IHierarchicalObject |
Interface | IObjectRelations |

Structures

 | Structure | Description
Structure | DynARFonts |
Structure | DynRptCaptions |

Delegates

 | Delegate | Description
Delegate | AddRowEventHandler |
Delegate | ButtonClickEventHandler |
Delegate | CellEventHandler |
Delegate | ChildTableDataSourceEventHandler |
Delegate | ColumnEventHandler |
Delegate | CustomAggregateEventHandler |
Delegate | CustomFilterEventHandler |
Delegate | CustomSortEventHandler |
Delegate | DataSourceEventHandler |
Delegate | DeleteRowEventHandler |
Delegate | ExportCompletedEventHandler |
Delegate | ExportEventHandler |
Delegate | LayoutEventHandler |
Delegate | PostBackEventHandler |
Delegate | PrepareExportExecuteEventHandler |
Delegate | RowEventHandler |
Delegate | RowLayoutSpanEventHandler |
Delegate | TableEventHandler |
Delegate | UpdateRowEventHandler |

Enumerations

 | Enumeration | Description
Enumeration | AddNew |
Enumeration | AggregateFunctions |
Enumeration | Alignment |
Enumeration | BaseEditorType |
Enumeration | CaseSensitive |
Enumeration | CellClick |
Enumeration | ChartPosition |
Enumeration | ChildrenType |
Enumeration | ChildRowAction |
Enumeration | ClassicPagingExportMode |
Enumeration | ClassicPagingLoadMode |
Enumeration | ClassicPagingRetrievalMode |
Enumeration | ClassicPagingStyle |
Enumeration | ClipboardCopyMode |
Enumeration | ColumnFilterType |
Enumeration | ColumnFooterAggregateMode |
Enumeration | ColumnFreezing |
Enumeration | ColumnMove |
Enumeration | ColumnSizing |
Enumeration | ColumnType |
Enumeration | ColumnVisibility |
Enumeration | ControlType |
Enumeration | DefaultStyleKind |
Enumeration | Delete |
Enumeration | DropdownButtonType |
Enumeration | Edit |
Enumeration | EditKeyMode |
Enumeration | EditType |
Enumeration | Export |
Enumeration | Filter |
Enumeration | FilterEditType |
Enumeration | FilterKeyMode |
Enumeration | GridInitialView |
Enumeration | GridLines |
Enumeration | GridPrintLayoutMode |
Enumeration | Grouping |
Enumeration | GroupInterval |
Enumeration | GroupMode |
Enumeration | HeaderClick |
Enumeration | HideColumns |
Enumeration | HierarchicalOperation |
Enumeration | HtmlHeaderScope |
Enumeration | HyperlinkTarget |
Enumeration | InProgressUIBehavior |
Enumeration | LanguageMode |
Enumeration | LostFocusMode |
Enumeration | MultipleSelection |
Enumeration | NewRowEditType |
Enumeration | PageOrientation |
Enumeration | PagingMode |
Enumeration | ParentRootMode |
Enumeration | PersistenceType |
Enumeration | PostbackMode |
Enumeration | Print |
Enumeration | ReportFileFormat |
Enumeration | RestorationLevel |
Enumeration | RestoreSelection |
Enumeration | RowChangedAction |
Enumeration | RowHeaders |
Enumeration | RowHighlightType |
Enumeration | RowLayoutMode |
Enumeration | RowLayoutSpan |
Enumeration | RowState |
Enumeration | RowType |
Enumeration | SchemaRetrievalMode |
Enumeration | SelectColumns |
Enumeration | Sorting |
Enumeration | SortOrder |
Enumeration | TargetObjectType |
Enumeration | ValueListFilter |
Enumeration | ValueListSorting |
Enumeration | VirtualLoadMode |
Enumeration | WebGridDesigner.DialogType |

See Also

Reference

ISNet.WebUI.WebGrid Assembly


ISNet.WebUI.WebGrid Namespace Inheritance Hierarchy

ISNet.WebUI.WebGrid Namespace Inheritance Hierarchy
See Also Send Feedback

Glossary Item Box

Inheritance Hierarchy

System.Object
ISNet.WebUI.BaseClientSideAction
ISNet.WebUI.WebGrid.ClientSideAction
ISNet.WebUI.DataSourceInfo
ISNet.WebUI.WebGrid.WebGridDataSourceInfo
ISNet.WebUI.WebGrid.CustomVirtualLoad
ISNet.WebUI.WebGrid.DynARInfo
ISNet.WebUI.WebGrid.GenericContainerTemplate
ISNet.WebUI.WebGrid.GenericDataSourceTableSchema
ISNet.WebUI.WebGrid.Margins
ISNet.WebUI.WebGrid.PostBackAction
ISNet.WebUI.WebGrid.SelectedObject
ISNet.WebUI.WebGrid.WebGridCellData
ISNet.WebUI.WebGrid.WebGridCommandItem
ISNet.WebUI.WebGrid.WebGridObjectRelation
ISNet.WebUI.WebGrid.WebGridRowChanges
ISNet.WebUI.WebGrid.WebGridScrollBarStyle
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.ClientBindingSettings
ISNet.WebUI.WebGrid.WebGridClientBindingSettings
ISNet.WebUI.NamedObjectBase
ISNet.WebUI.WebGrid.ChartFillStyle
ISNet.WebUI.WebGrid.ChartLightSourceSettings
ISNet.WebUI.WebGrid.ChartMarkerStyle
ISNet.WebUI.WebGrid.ChartPivotConfig
ISNet.WebUI.WebGrid.ChartPivotDataConfig
ISNet.WebUI.WebGrid.ChartPivotFilterConfig
ISNet.WebUI.WebGrid.WebGridCell
ISNet.WebUI.WebGrid.WebGridColumn
ISNet.WebUI.WebGrid.WebGridColumnSet
ISNet.WebUI.WebGrid.WebGridCustomEditor
ISNet.WebUI.WebGrid.WebGridFormatCondition
ISNet.WebUI.WebGrid.WebGridGroup
ISNet.WebUI.WebGrid.WebGridFilter
ISNet.WebUI.WebGrid.WebGridRow
ISNet.WebUI.WebGrid.WebGridRowLayout
ISNet.WebUI.WebGrid.WebGridTable
ISNet.WebUI.WebGrid.WebGridTextItem
ISNet.WebUI.WebGrid.WebValueList
ISNet.WebUI.WebGrid.BrowserPrintSettings
ISNet.WebUI.WebGrid.ChartScaleStripStyle
ISNet.WebUI.WebGrid.ClientEvents
ISNet.WebUI.WebGrid.ColumnSetSettings
ISNet.WebUI.WebGrid.FocusStyle
ISNet.WebUI.WebGrid.GroupByBoxObject
ISNet.WebUI.WebGrid.ImageSettings
ISNet.WebUI.WebGrid.LayoutSet
ISNet.WebUI.WebGrid.PreviewRowSettings
ISNet.WebUI.WebGrid.SelfReferencingSettings
ISNet.WebUI.WebGrid.TextSettings
ISNet.WebUI.WebGrid.WebGridBatchUpdateSettings
ISNet.WebUI.WebGrid.WebGridCustomEditorBehavior
ISNet.WebUI.WebGrid.WebGridFreezePaneSettings
System.Attribute
ISNet.WebUI.WebGrid.AutoIncrementAttribute
ISNet.WebUI.WebGrid.CaptionAttribute
ISNet.WebUI.WebGrid.NonRetrievableAttribute
ISNet.WebUI.WebGrid.PrimaryKeyAttribute
System.Collections.CollectionBase
ISNet.WebUI.ISCollectionBase
ISNet.WebUI.WebGrid.WebGridCellCollection
ISNet.WebUI.WebGrid.WebGridColumnCollection
ISNet.WebUI.WebGrid.WebGridColumnSetCollection
ISNet.WebUI.WebGrid.WebGridCustomEditorCollection
ISNet.WebUI.WebGrid.WebGridFilterCollection
ISNet.WebUI.WebGrid.WebGridFormatConditionCollection
ISNet.WebUI.WebGrid.WebGridGroupCollection
ISNet.WebUI.WebGrid.WebGridRowCollection
ISNet.WebUI.WebGrid.WebGridRowLayoutCollection
ISNet.WebUI.WebGrid.WebGridTableCollection
ISNet.WebUI.WebGrid.WebGridTextItemCollection
System.ComponentModel.ComponentEditor
System.Windows.Forms.Design.WindowsFormsComponentEditor
ISNet.WebUI.WebGrid.WebGridComponentEditor
System.ComponentModel.Design.ComponentDesigner
System.Web.UI.Design.HtmlControlDesigner
System.Web.UI.Design.ControlDesigner
ISNet.WebUI.ISDesignerBase
ISNet.WebUI.ISDataBoundDesignerBase
ISNet.WebUI.WebGrid.WebGridDesigner
System.Data.DataRow
ISNet.WebUI.WebGrid.ObjectRow
System.Drawing.Design.UITypeEditor
ISNet.WebUI.WebGrid.CustomEditorEditor
ISNet.WebUI.WebGrid.CustomEditorNameEditor
ISNet.WebUI.WebGrid.DataFieldEditor
ISNet.WebUI.WebGrid.FieldTypeEditor
ISNet.WebUI.WebGrid.TextItemEditor
ISNet.WebUI.WebGrid.WebComboEditor
System.EventArgs
ISNet.WebUI.WebGrid.BaseEventArgs
ISNet.WebUI.WebGrid.BatchUpdateEventArgs
ISNet.WebUI.WebGrid.ButtonEventArgs
ISNet.WebUI.WebGrid.CellEventArgs
ISNet.WebUI.WebGrid.Chart.WebGridChartEventArgs
ISNet.WebUI.WebGrid.Chart.WebGridChartStatusArgs
ISNet.WebUI.WebGrid.ChildTableDataSourceEventArgs
ISNet.WebUI.WebGrid.ColumnEventArgs
ISNet.WebUI.WebGrid.CustomAggregateArgs
ISNet.WebUI.WebGrid.DataSourceEventArgs
ISNet.WebUI.WebGrid.ExportCompletedEventArgs
ISNet.WebUI.WebGrid.ExportEventArgs
ISNet.WebUI.WebGrid.FilterEventArgs
ISNet.WebUI.WebGrid.LayoutEventArgs
ISNet.WebUI.WebGrid.PostbackEventArgs
ISNet.WebUI.WebGrid.PrepareExportExecuteEventArgs
ISNet.WebUI.WebGrid.RowEventArgs
ISNet.WebUI.WebGrid.RowChangedEventArgs
ISNet.WebUI.WebGrid.SortEventArgs
ISNet.WebUI.WebGrid.TableEventArgs
ISNet.WebUI.WebGrid.SpanEventArgs
System.Exception
ISNet.WebUI.WebGrid.WebGridBatchUpdateException
System.MarshalByRefObject
System.ComponentModel.Component
System.Web.UI.WebControls.Style
ISNet.WebUI.WebStyle
ISNet.WebUI.WebGrid.WebGridFormatStyle
System.ValueType
ISNet.WebUI.WebGrid.DynARFonts
ISNet.WebUI.WebGrid.DynRptCaptions
System.Web.UI.Control
System.Web.UI.WebControls.WebControl
ISNet.WebUI.ISNetControl
ISNet.WebUI.WebGrid.WebGrid
System.Web.UI.WebControls.Panel
ISNet.WebUI.WebGrid.WebGridCellTemplateContainer

See Also

Reference

ISNet.WebUI.WebGrid Assembly


AutoIncrementAttribute Class

[image]
Intersoft WebGrid Documentation
AutoIncrementAttribute Class
Members See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : AutoIncrementAttribute Class

Glossary Item Box

Object Model

AutoIncrementAttribute Class

Syntax

Visual Basic (Declaration)
<System.AttributeUsageAttribute(ValidOn=AttributeTargets.Assembly Or  _
    AttributeTargets.Module Or  _
    AttributeTargets.Class Or  _
    AttributeTargets.Struct Or  _
    AttributeTargets.Enum Or  _
    AttributeTargets.Constructor Or  _
    AttributeTargets.Method Or  _
    AttributeTargets.Property Or  _
    AttributeTargets.Field Or  _
    AttributeTargets.Event Or  _
    AttributeTargets.Interface Or  _
    AttributeTargets.Parameter Or  _
    AttributeTargets.Delegate Or  _
    AttributeTargets.ReturnValue Or  _
    AttributeTargets.GenericParameter Or  _
    AttributeTargets.All,
   AllowMultiple=False,
   Inherited=True)>
Public Class AutoIncrementAttribute
   Inherits System.Attribute
Visual Basic (Usage) Copy Code
Dim instance As AutoIncrementAttribute
C#
[System.AttributeUsageAttribute(ValidOn=AttributeTargets.Assembly |
    AttributeTargets.Module |
    AttributeTargets.Class |
    AttributeTargets.Struct |
    AttributeTargets.Enum |
    AttributeTargets.Constructor |
    AttributeTargets.Method |
    AttributeTargets.Property |
    AttributeTargets.Field |
    AttributeTargets.Event |
    AttributeTargets.Interface |
    AttributeTargets.Parameter |
    AttributeTargets.Delegate |
    AttributeTargets.ReturnValue |
    AttributeTargets.GenericParameter |
    AttributeTargets.All,
   AllowMultiple=false,
   Inherited=true)]
public class AutoIncrementAttribute : System.Attribute
Delphi
public class AutoIncrementAttribute = class(System.Attribute)
JScript
System.AttributeUsageAttribute(ValidOn=AttributeTargets.Assembly |
    AttributeTargets.Module |
    AttributeTargets.Class |
    AttributeTargets.Struct |
    AttributeTargets.Enum |
    AttributeTargets.Constructor |
    AttributeTargets.Method |
    AttributeTargets.Property |
    AttributeTargets.Field |
    AttributeTargets.Event |
    AttributeTargets.Interface |
    AttributeTargets.Parameter |
    AttributeTargets.Delegate |
    AttributeTargets.ReturnValue |
    AttributeTargets.GenericParameter |
    AttributeTargets.All,
   AllowMultiple=,
   Inherited=)
public class AutoIncrementAttribute extends System.Attribute
Managed Extensions for C++
[System.AttributeUsageAttribute(ValidOn=AttributeTargets.Assembly |
    AttributeTargets.Module |
    AttributeTargets.Class |
    AttributeTargets.Struct |
    AttributeTargets.Enum |
    AttributeTargets.Constructor |
    AttributeTargets.Method |
    AttributeTargets.Property |
    AttributeTargets.Field |
    AttributeTargets.Event |
    AttributeTargets.Interface |
    AttributeTargets.Parameter |
    AttributeTargets.Delegate |
    AttributeTargets.ReturnValue |
    AttributeTargets.GenericParameter |
    AttributeTargets.All,
   AllowMultiple=false,
   Inherited=true)]
public __gc class AutoIncrementAttribute : public System.Attribute
C++/CLI
[System.AttributeUsageAttribute(ValidOn=AttributeTargets.Assembly |
    AttributeTargets.Module |
    AttributeTargets.Class |
    AttributeTargets.Struct |
    AttributeTargets.Enum |
    AttributeTargets.Constructor |
    AttributeTargets.Method |
    AttributeTargets.Property |
    AttributeTargets.Field |
    AttributeTargets.Event |
    AttributeTargets.Interface |
    AttributeTargets.Parameter |
    AttributeTargets.Delegate |
    AttributeTargets.ReturnValue |
    AttributeTargets.GenericParameter |
    AttributeTargets.All,
   AllowMultiple=false,
   Inherited=true)]
public ref class AutoIncrementAttribute : public System.Attribute

Inheritance Hierarchy

System.Object
System.Attribute
ISNet.WebUI.WebGrid.AutoIncrementAttribute

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AutoIncrementAttribute Members
ISNet.WebUI.WebGrid Namespace


AutoIncrementAttribute Class Members

[image]
Intersoft WebGrid Documentation
AutoIncrementAttribute Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebGrid Namespace : AutoIncrementAttribute Class

Glossary Item Box

The following tables list the members exposed by AutoIncrementAttribute.

Public Constructors

 | Name | Description
Public Constructor | AutoIncrementAttribute Constructor |
Top

Public Properties

 | Name | Description
Public Property | TypeId | (Inherited from System.Attribute)
Top

Public Methods

 | Name | Description
Public Method | Equals | (Inherited from System.Attribute)
Public Method | GetHashCode | (Inherited from System.Attribute)
Public Method | IsDefaultAttribute | (Inherited from System.Attribute)
Public Method | Match | (Inherited from System.Attribute)
Top

See Also

Reference

AutoIncrementAttribute Class
ISNet.WebUI.WebGrid Namespace


AutoIncrementAttribute Class Methods

[image]
Intersoft WebGrid Documentation
AutoIncrementAttribute Class Methods
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : AutoIncrementAttribute Class

Glossary Item Box

For a list of all members of this type, see AutoIncrementAttribute members.

Public Methods

 | Name | Description
Public Method | Equals | (Inherited from System.Attribute)
Public Method | GetHashCode | (Inherited from System.Attribute)
Public Method | IsDefaultAttribute | (Inherited from System.Attribute)
Public Method | Match | (Inherited from System.Attribute)
Top

See Also

Reference

AutoIncrementAttribute Class
ISNet.WebUI.WebGrid Namespace


AutoIncrementAttribute Class Properties

[image]
Intersoft WebGrid Documentation
AutoIncrementAttribute Class Properties
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : AutoIncrementAttribute Class

Glossary Item Box

For a list of all members of this type, see AutoIncrementAttribute members.

Public Properties

 | Name | Description
Public Property | TypeId | (Inherited from System.Attribute)
Top

See Also

Reference

AutoIncrementAttribute Class
ISNet.WebUI.WebGrid Namespace


AutoIncrementAttribute Constructor

[image]
Intersoft WebGrid Documentation
AutoIncrementAttribute Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > AutoIncrementAttribute Class : AutoIncrementAttribute Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New AutoIncrementAttribute()
C#
public AutoIncrementAttribute()
Delphi
public AutoIncrementAttribute();
JScript
public function AutoIncrementAttribute();
Managed Extensions for C++
public: AutoIncrementAttribute();
C++/CLI
public:
AutoIncrementAttribute();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AutoIncrementAttribute Class
AutoIncrementAttribute Members


Equals Method

[image]
Intersoft WebGrid Documentation
Equals Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > AutoIncrementAttribute Class : Equals Method

obj

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Security.SecuritySafeCriticalAttribute()>
<__DynamicallyInvokableAttribute()>
Public Overridable Function Equals( _
   ByVal obj As System.Object _
) As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As AutoIncrementAttribute
Dim obj As System.Object
Dim value As System.Boolean

value = instance.Equals(obj)
C#
[System.Security.SecuritySafeCriticalAttribute()]
[__DynamicallyInvokableAttribute()]
public virtual System.bool Equals(
   System.object obj
)
Delphi
public function Equals(
    obj: System.TObject
): System.Boolean; virtual;
JScript
System.Security.SecuritySafeCriticalAttribute()
__DynamicallyInvokableAttribute()
public function Equals(
   obj : System.Object
) : System.boolean;
Managed Extensions for C++
[System.Security.SecuritySafeCriticalAttribute()]
[__DynamicallyInvokableAttribute()]
public: virtual System.bool Equals(
   System.Object* obj
)
C++/CLI
[System.Security.SecuritySafeCriticalAttribute()]
[__DynamicallyInvokableAttribute()]
public:
virtual System.bool Equals(
   System.Object^ obj
)

Parameters

obj

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AutoIncrementAttribute Class
AutoIncrementAttribute Members


GetHashCode Method

[image]
Intersoft WebGrid Documentation
GetHashCode Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > AutoIncrementAttribute Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Security.SecuritySafeCriticalAttribute()>
<__DynamicallyInvokableAttribute()>
Public Overridable Function GetHashCode() As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As AutoIncrementAttribute
Dim value As System.Integer

value = instance.GetHashCode()
C#
[System.Security.SecuritySafeCriticalAttribute()]
[__DynamicallyInvokableAttribute()]
public virtual System.int GetHashCode()
Delphi
public function GetHashCode(): System.Integer; virtual;
JScript
System.Security.SecuritySafeCriticalAttribute()
__DynamicallyInvokableAttribute()
public function GetHashCode() : System.int;
Managed Extensions for C++
[System.Security.SecuritySafeCriticalAttribute()]
[__DynamicallyInvokableAttribute()]
public: virtual System.int GetHashCode();
C++/CLI
[System.Security.SecuritySafeCriticalAttribute()]
[__DynamicallyInvokableAttribute()]
public:
virtual System.int GetHashCode();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AutoIncrementAttribute Class
AutoIncrementAttribute Members


IsDefaultAttribute Method

[image]
Intersoft WebGrid Documentation
IsDefaultAttribute Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > AutoIncrementAttribute Class : IsDefaultAttribute Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsDefaultAttribute() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As AutoIncrementAttribute
Dim value As System.Boolean

value = instance.IsDefaultAttribute()
C#
public virtual System.bool IsDefaultAttribute()
Delphi
public function IsDefaultAttribute(): System.Boolean; virtual;
JScript
public function IsDefaultAttribute() : System.boolean;
Managed Extensions for C++
public: virtual System.bool IsDefaultAttribute();
C++/CLI
public:
virtual System.bool IsDefaultAttribute();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AutoIncrementAttribute Class
AutoIncrementAttribute Members


Match Method

[image]
Intersoft WebGrid Documentation
Match Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > AutoIncrementAttribute Class : Match Method

obj

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Match( _
   ByVal obj As System.Object _
) As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As AutoIncrementAttribute
Dim obj As System.Object
Dim value As System.Boolean

value = instance.Match(obj)
C#
public virtual System.bool Match(
   System.object obj
)
Delphi
public function Match(
    obj: System.TObject
): System.Boolean; virtual;
JScript
public function Match(
   obj : System.Object
) : System.boolean;
Managed Extensions for C++
public: virtual System.bool Match(
   System.Object* obj
)
C++/CLI
public:
virtual System.bool Match(
   System.Object^ obj
)

Parameters

obj

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AutoIncrementAttribute Class
AutoIncrementAttribute Members


TypeId Property

[image]
Intersoft WebGrid Documentation
TypeId Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > AutoIncrementAttribute Class : TypeId Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property TypeId As System.Object
Visual Basic (Usage) Copy Code
Dim instance As AutoIncrementAttribute
Dim value As System.Object

value = instance.TypeId
C#
public virtual System.object TypeId {get;}
Delphi
public read-only property TypeId: System.TObject; virtual;
JScript
public function get TypeId : System.Object
Managed Extensions for C++
public: __property virtual System.Object* get_TypeId();
C++/CLI
public:
virtual property System.Object^ TypeId {
   System.Object^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AutoIncrementAttribute Class
AutoIncrementAttribute Members


BaseEventArgs Class

[image]
Intersoft WebGrid Documentation
BaseEventArgs Class
Members See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : BaseEventArgs Class

Glossary Item Box

Object Model

BaseEventArgs Class

Syntax

Visual Basic (Declaration)
Public Class BaseEventArgs
   Inherits System.EventArgs
Visual Basic (Usage) Copy Code
Dim instance As BaseEventArgs
C#
public class BaseEventArgs : System.EventArgs
Delphi
public class BaseEventArgs = class(System.EventArgs)
JScript
public class BaseEventArgs extends System.EventArgs
Managed Extensions for C++
public __gc class BaseEventArgs : public System.EventArgs
C++/CLI
public ref class BaseEventArgs : public System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
ISNet.WebUI.WebGrid.BaseEventArgs
ISNet.WebUI.WebGrid.BatchUpdateEventArgs
ISNet.WebUI.WebGrid.ButtonEventArgs
ISNet.WebUI.WebGrid.CellEventArgs
ISNet.WebUI.WebGrid.Chart.WebGridChartEventArgs
ISNet.WebUI.WebGrid.Chart.WebGridChartStatusArgs
ISNet.WebUI.WebGrid.ChildTableDataSourceEventArgs
ISNet.WebUI.WebGrid.ColumnEventArgs
ISNet.WebUI.WebGrid.CustomAggregateArgs
ISNet.WebUI.WebGrid.DataSourceEventArgs
ISNet.WebUI.WebGrid.ExportCompletedEventArgs
ISNet.WebUI.WebGrid.ExportEventArgs
ISNet.WebUI.WebGrid.FilterEventArgs
ISNet.WebUI.WebGrid.LayoutEventArgs
ISNet.WebUI.WebGrid.PostbackEventArgs
ISNet.WebUI.WebGrid.PrepareExportExecuteEventArgs
ISNet.WebUI.WebGrid.RowEventArgs
ISNet.WebUI.WebGrid.SortEventArgs
ISNet.WebUI.WebGrid.TableEventArgs

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BaseEventArgs Members
ISNet.WebUI.WebGrid Namespace


BaseEventArgs Class Members

[image]
Intersoft WebGrid Documentation
BaseEventArgs Class Members
See Also Properties Send Feedback
ISNet.WebUI.WebGrid Namespace : BaseEventArgs Class

Glossary Item Box

The following tables list the members exposed by BaseEventArgs.

Public Constructors

 | Name | Description
Public Constructor | BaseEventArgs Constructor |
Top

Public Properties

 | Name | Description
Public Property | ReturnValue |
Top

See Also

Reference

BaseEventArgs Class
ISNet.WebUI.WebGrid Namespace


BaseEventArgs Constructor

[image]
Intersoft WebGrid Documentation
BaseEventArgs Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > BaseEventArgs Class : BaseEventArgs Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New BaseEventArgs()
C#
public BaseEventArgs()
Delphi
public BaseEventArgs();
JScript
public function BaseEventArgs();
Managed Extensions for C++
public: BaseEventArgs();
C++/CLI
public:
BaseEventArgs();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BaseEventArgs Class
BaseEventArgs Members


BaseEventArgs Class Properties

[image]
Intersoft WebGrid Documentation
BaseEventArgs Class Properties
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : BaseEventArgs Class

Glossary Item Box

For a list of all members of this type, see BaseEventArgs members.

Public Properties

 | Name | Description
Public Property | ReturnValue |
Top

See Also

Reference

BaseEventArgs Class
ISNet.WebUI.WebGrid Namespace


ReturnValue Property

[image]
Intersoft WebGrid Documentation
ReturnValue Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > BaseEventArgs Class : ReturnValue Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property ReturnValue As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As BaseEventArgs
Dim value As System.Boolean

instance.ReturnValue = value

value = instance.ReturnValue
C#
public System.bool ReturnValue {get; set;}
Delphi
public read-write property ReturnValue: System.Boolean;
JScript
public function get,set ReturnValue : System.boolean
Managed Extensions for C++
public: __property System.bool get_ReturnValue();
public: __property void set_ReturnValue(
   System.bool value
);
C++/CLI
public:
property System.bool ReturnValue {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BaseEventArgs Class
BaseEventArgs Members


BatchUpdateEventArgs Class

[image]
Intersoft WebGrid Documentation
BatchUpdateEventArgs Class
Members See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : BatchUpdateEventArgs Class

Glossary Item Box

Object Model

BatchUpdateEventArgs Class

Syntax

Visual Basic (Declaration)
Public Class BatchUpdateEventArgs
   Inherits BaseEventArgs
Visual Basic (Usage) Copy Code
Dim instance As BatchUpdateEventArgs
C#
public class BatchUpdateEventArgs : BaseEventArgs
Delphi
public class BatchUpdateEventArgs = class(BaseEventArgs)
JScript
public class BatchUpdateEventArgs extends BaseEventArgs
Managed Extensions for C++
public __gc class BatchUpdateEventArgs : public BaseEventArgs
C++/CLI
public ref class BatchUpdateEventArgs : public BaseEventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
ISNet.WebUI.WebGrid.BaseEventArgs
ISNet.WebUI.WebGrid.BatchUpdateEventArgs

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BatchUpdateEventArgs Members
ISNet.WebUI.WebGrid Namespace


BatchUpdateEventArgs Class Members

[image]
Intersoft WebGrid Documentation
BatchUpdateEventArgs Class Members
See Also Properties Send Feedback
ISNet.WebUI.WebGrid Namespace : BatchUpdateEventArgs Class

Glossary Item Box

The following tables list the members exposed by BatchUpdateEventArgs.

Public Properties

 | Name | Description
Public Property | PendingChanges |
Public Property | ReturnValue | (Inherited from ISNet.WebUI.WebGrid.BaseEventArgs)
Top

See Also

Reference

BatchUpdateEventArgs Class
ISNet.WebUI.WebGrid Namespace


BatchUpdateEventArgs Class Properties

[image]
Intersoft WebGrid Documentation
BatchUpdateEventArgs Class Properties
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : BatchUpdateEventArgs Class

Glossary Item Box

For a list of all members of this type, see BatchUpdateEventArgs members.

Public Properties

 | Name | Description
Public Property | PendingChanges |
Public Property | ReturnValue | (Inherited from ISNet.WebUI.WebGrid.BaseEventArgs)
Top

See Also

Reference

BatchUpdateEventArgs Class
ISNet.WebUI.WebGrid Namespace


PendingChanges Property

[image]
Intersoft WebGrid Documentation
PendingChanges Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > BatchUpdateEventArgs Class : PendingChanges Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property PendingChanges As System.Collections.Generic.List(Of WebGridRowChanges)
Visual Basic (Usage) Copy Code
Dim instance As BatchUpdateEventArgs
Dim value As System.Collections.Generic.List(Of WebGridRowChanges)

value = instance.PendingChanges
C#
public System.Collections.Generic.List<WebGridRowChanges> PendingChanges {get;}
Delphi
public read-only property PendingChanges: System.Collections.Generic.List;
JScript
public function get PendingChanges : System.Collections.Generic.List
Managed Extensions for C++
public: __property System.Collections.Generic.List<WebGridRowChanges*>* get_PendingChanges();
C++/CLI
public:
property System.Collections.Generic.List<WebGridRowChanges^>^ PendingChanges {
   System.Collections.Generic.List<WebGridRowChanges^>^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BatchUpdateEventArgs Class
BatchUpdateEventArgs Members


BrowserPrintSettings Class

[image]
Intersoft WebGrid Documentation
BrowserPrintSettings Class
Members See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : BrowserPrintSettings Class

Glossary Item Box

Object Model

BrowserPrintSettings Class

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.DescriptionAttribute()>
<System.SerializableAttribute()>
Public Class BrowserPrintSettings
   Inherits ISNet.WebUI.WebUIBaseClass
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Visual Basic (Usage) Copy Code
Dim instance As BrowserPrintSettings
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DescriptionAttribute()]
[System.SerializableAttribute()]
public class BrowserPrintSettings : ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Delphi
public class BrowserPrintSettings = class(ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize)
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.DescriptionAttribute()
System.SerializableAttribute()
public class BrowserPrintSettings extends ISNet.WebUI.WebUIBaseClass implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DescriptionAttribute()]
[System.SerializableAttribute()]
public __gc class BrowserPrintSettings : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DescriptionAttribute()]
[System.SerializableAttribute()]
public ref class BrowserPrintSettings : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.WebGrid.BrowserPrintSettings

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BrowserPrintSettings Members
ISNet.WebUI.WebGrid Namespace


BrowserPrintSettings Class Members

[image]
Intersoft WebGrid Documentation
BrowserPrintSettings Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebGrid Namespace : BrowserPrintSettings Class

Glossary Item Box

The following tables list the members exposed by BrowserPrintSettings.

Public Constructors

 | Name | Description
Public Constructor | BrowserPrintSettings Constructor |
Top

Public Properties

 | Name | Description
Public Property | GridLayout |
Public Property | PrintStatusBar |
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

BrowserPrintSettings Class
ISNet.WebUI.WebGrid Namespace


BrowserPrintSettings Constructor

[image]
Intersoft WebGrid Documentation
BrowserPrintSettings Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > BrowserPrintSettings Class : BrowserPrintSettings Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New BrowserPrintSettings()
C#
public BrowserPrintSettings()
Delphi
public BrowserPrintSettings();
JScript
public function BrowserPrintSettings();
Managed Extensions for C++
public: BrowserPrintSettings();
C++/CLI
public:
BrowserPrintSettings();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BrowserPrintSettings Class
BrowserPrintSettings Members


Clone Method

[image]
Intersoft WebGrid Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > BrowserPrintSettings Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As System.Object
Visual Basic (Usage) Copy Code
Dim instance As BrowserPrintSettings
Dim value As System.Object

value = instance.Clone()
C#
public virtual System.object Clone()
Delphi
public function Clone(): System.TObject; virtual;
JScript
public function Clone() : System.Object;
Managed Extensions for C++
public: virtual System.Object* Clone();
C++/CLI
public:
virtual System.Object^ Clone();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BrowserPrintSettings Class
BrowserPrintSettings Members


CopyFrom Method

[image]
Intersoft WebGrid Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > BrowserPrintSettings Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BrowserPrintSettings Class
BrowserPrintSettings Members


CopyFrom(Object) Method

[image]
Intersoft WebGrid Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > BrowserPrintSettings Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As BrowserPrintSettings
Dim objSource As System.Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   System.object objSource
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BrowserPrintSettings Class
BrowserPrintSettings Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebGrid Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > BrowserPrintSettings Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object, _
   ByVal cloneSourceValue As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As BrowserPrintSettings
Dim objSource As System.Object
Dim cloneSourceValue As System.Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   System.object objSource,
   System.bool cloneSourceValue
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject;
    cloneSourceValue: System.Boolean
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object,
   cloneSourceValue : System.boolean
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource,
   System.bool cloneSourceValue
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource,
   System.bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BrowserPrintSettings Class
BrowserPrintSettings Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebGrid Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > BrowserPrintSettings Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As BrowserPrintSettings
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure DeSerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function DeSerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void DeSerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void DeSerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BrowserPrintSettings Class
BrowserPrintSettings Members


GetHashCode Method

[image]
Intersoft WebGrid Documentation
GetHashCode Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > BrowserPrintSettings Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As BrowserPrintSettings
Dim value As System.Integer

value = instance.GetHashCode()
C#
public virtual System.int GetHashCode()
Delphi
public function GetHashCode(): System.Integer; virtual;
JScript
public function GetHashCode() : System.int;
Managed Extensions for C++
public: virtual System.int GetHashCode();
C++/CLI
public:
virtual System.int GetHashCode();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BrowserPrintSettings Class
BrowserPrintSettings Members


BrowserPrintSettings Class Methods

[image]
Intersoft WebGrid Documentation
BrowserPrintSettings Class Methods
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : BrowserPrintSettings Class

Glossary Item Box

For a list of all members of this type, see BrowserPrintSettings members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

BrowserPrintSettings Class
ISNet.WebUI.WebGrid Namespace


GetObjectData Method

[image]
Intersoft WebGrid Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > BrowserPrintSettings Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As BrowserPrintSettings
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure GetObjectData(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
); override;
JScript
public override function GetObjectData(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void GetObjectData(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
) override
C++/CLI
public:
void GetObjectData(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
) override

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BrowserPrintSettings Class
BrowserPrintSettings Members


IsEmpty Method

[image]
Intersoft WebGrid Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > BrowserPrintSettings Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As BrowserPrintSettings
Dim value As System.Boolean

value = instance.IsEmpty()
C#
public virtual System.bool IsEmpty()
Delphi
public function IsEmpty(): System.Boolean; virtual;
JScript
public function IsEmpty() : System.boolean;
Managed Extensions for C++
public: virtual System.bool IsEmpty();
C++/CLI
public:
virtual System.bool IsEmpty();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BrowserPrintSettings Class
BrowserPrintSettings Members


Reset Method

[image]
Intersoft WebGrid Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > BrowserPrintSettings Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As BrowserPrintSettings

instance.Reset()
C#
public virtual void Reset()
Delphi
public procedure Reset(); virtual;
JScript
public function Reset();
Managed Extensions for C++
public: virtual void Reset();
C++/CLI
public:
virtual void Reset();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BrowserPrintSettings Class
BrowserPrintSettings Members


SerializeObjectData Method

[image]
Intersoft WebGrid Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > BrowserPrintSettings Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As BrowserPrintSettings
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure SerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function SerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void SerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void SerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BrowserPrintSettings Class
BrowserPrintSettings Members


ToString Method

[image]
Intersoft WebGrid Documentation
ToString Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > BrowserPrintSettings Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As System.String
Visual Basic (Usage) Copy Code
Dim instance As BrowserPrintSettings
Dim value As System.String

value = instance.ToString()
C#
public virtual System.string ToString()
Delphi
public function ToString(): System.String; virtual;
JScript
public function ToString() : System.String;
Managed Extensions for C++
public: virtual System.string* ToString();
C++/CLI
public:
virtual System.String^ ToString();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BrowserPrintSettings Class
BrowserPrintSettings Members


BrowserPrintSettings Class Properties

[image]
Intersoft WebGrid Documentation
BrowserPrintSettings Class Properties
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : BrowserPrintSettings Class

Glossary Item Box

For a list of all members of this type, see BrowserPrintSettings members.

Public Properties

 | Name | Description
Public Property | GridLayout |
Public Property | PrintStatusBar |
Top

See Also

Reference

BrowserPrintSettings Class
ISNet.WebUI.WebGrid Namespace


BrowserPrintSettings Constructor

[image]
Intersoft WebGrid Documentation
BrowserPrintSettings Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > BrowserPrintSettings Class : BrowserPrintSettings Constructor

Glossary Item Box

Overload List

Overload | Description
BrowserPrintSettings Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BrowserPrintSettings Class
BrowserPrintSettings Members


GridLayout Property

[image]
Intersoft WebGrid Documentation
GridLayout Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > BrowserPrintSettings Class : GridLayout Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Determines the mode that WebGrid should use during printing. ")>
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property GridLayout As GridPrintLayoutMode
Visual Basic (Usage) Copy Code
Dim instance As BrowserPrintSettings
Dim value As GridPrintLayoutMode

instance.GridLayout = value

value = instance.GridLayout
C#
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Determines the mode that WebGrid should use during printing. ")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public GridPrintLayoutMode GridLayout {get; set;}
Delphi
public read-write property GridLayout: GridPrintLayoutMode;
JScript
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Determines the mode that WebGrid should use during printing. ")
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set GridLayout : GridPrintLayoutMode
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Determines the mode that WebGrid should use during printing. ")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property GridPrintLayoutMode get_GridLayout();
public: __property void set_GridLayout(
   GridPrintLayoutMode value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Determines the mode that WebGrid should use during printing. ")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property GridPrintLayoutMode GridLayout {
   GridPrintLayoutMode get();
   void set (    GridPrintLayoutMode value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BrowserPrintSettings Class
BrowserPrintSettings Members


PrintStatusBar Property

[image]
Intersoft WebGrid Documentation
PrintStatusBar Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > BrowserPrintSettings Class : PrintStatusBar Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Determines whether the status bar of the Grid should be included in the printing.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property PrintStatusBar As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As BrowserPrintSettings
Dim value As System.Boolean

instance.PrintStatusBar = value

value = instance.PrintStatusBar
C#
[System.ComponentModel.DescriptionAttribute("Determines whether the status bar of the Grid should be included in the printing.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.bool PrintStatusBar {get; set;}
Delphi
public read-write property PrintStatusBar: System.Boolean;
JScript
System.ComponentModel.DescriptionAttribute("Determines whether the status bar of the Grid should be included in the printing.")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set PrintStatusBar : System.boolean
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Determines whether the status bar of the Grid should be included in the printing.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.bool get_PrintStatusBar();
public: __property void set_PrintStatusBar(
   System.bool value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Determines whether the status bar of the Grid should be included in the printing.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.bool PrintStatusBar {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BrowserPrintSettings Class
BrowserPrintSettings Members


ButtonEventArgs Class

[image]
Intersoft WebGrid Documentation
ButtonEventArgs Class
Members See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : ButtonEventArgs Class

Glossary Item Box

Object Model

ButtonEventArgs Class

Syntax

Visual Basic (Declaration)
Public Class ButtonEventArgs
   Inherits BaseEventArgs
Visual Basic (Usage) Copy Code
Dim instance As ButtonEventArgs
C#
public class ButtonEventArgs : BaseEventArgs
Delphi
public class ButtonEventArgs = class(BaseEventArgs)
JScript
public class ButtonEventArgs extends BaseEventArgs
Managed Extensions for C++
public __gc class ButtonEventArgs : public BaseEventArgs
C++/CLI
public ref class ButtonEventArgs : public BaseEventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
ISNet.WebUI.WebGrid.BaseEventArgs
ISNet.WebUI.WebGrid.ButtonEventArgs

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ButtonEventArgs Members
ISNet.WebUI.WebGrid Namespace


ButtonEventArgs Class Members

[image]
Intersoft WebGrid Documentation
ButtonEventArgs Class Members
See Also Properties Send Feedback
ISNet.WebUI.WebGrid Namespace : ButtonEventArgs Class

Glossary Item Box

The following tables list the members exposed by ButtonEventArgs.

Public Properties

 | Name | Description
Public Property | CellValue |
Public Property | Column |
Public Property | ReturnValue | (Inherited from ISNet.WebUI.WebGrid.BaseEventArgs)
Public Property | Table |
Top

See Also

Reference

ButtonEventArgs Class
ISNet.WebUI.WebGrid Namespace


ButtonEventArgs Class Properties

[image]
Intersoft WebGrid Documentation
ButtonEventArgs Class Properties
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : ButtonEventArgs Class

Glossary Item Box

For a list of all members of this type, see ButtonEventArgs members.

Public Properties

 | Name | Description
Public Property | CellValue |
Public Property | Column |
Public Property | ReturnValue | (Inherited from ISNet.WebUI.WebGrid.BaseEventArgs)
Public Property | Table |
Top

See Also

Reference

ButtonEventArgs Class
ISNet.WebUI.WebGrid Namespace


CellValue Property

[image]
Intersoft WebGrid Documentation
CellValue Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ButtonEventArgs Class : CellValue Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property CellValue As System.String
Visual Basic (Usage) Copy Code
Dim instance As ButtonEventArgs
Dim value As System.String

value = instance.CellValue
C#
public System.string CellValue {get;}
Delphi
public read-only property CellValue: System.String;
JScript
public function get CellValue : System.String
Managed Extensions for C++
public: __property System.string* get_CellValue();
C++/CLI
public:
property System.String^ CellValue {
   System.String^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ButtonEventArgs Class
ButtonEventArgs Members


Column Property

[image]
Intersoft WebGrid Documentation
Column Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ButtonEventArgs Class : Column Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Column As WebGridColumn
Visual Basic (Usage) Copy Code
Dim instance As ButtonEventArgs
Dim value As WebGridColumn

value = instance.Column
C#
public WebGridColumn Column {get;}
Delphi
public read-only property Column: WebGridColumn;
JScript
public function get Column : WebGridColumn
Managed Extensions for C++
public: __property WebGridColumn* get_Column();
C++/CLI
public:
property WebGridColumn^ Column {
   WebGridColumn^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ButtonEventArgs Class
ButtonEventArgs Members


Table Property

[image]
Intersoft WebGrid Documentation
Table Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ButtonEventArgs Class : Table Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Table As WebGridTable
Visual Basic (Usage) Copy Code
Dim instance As ButtonEventArgs
Dim value As WebGridTable

value = instance.Table
C#
public WebGridTable Table {get;}
Delphi
public read-only property Table: WebGridTable;
JScript
public function get Table : WebGridTable
Managed Extensions for C++
public: __property WebGridTable* get_Table();
C++/CLI
public:
property WebGridTable^ Table {
   WebGridTable^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ButtonEventArgs Class
ButtonEventArgs Members


CaptionAttribute Class

[image]
Intersoft WebGrid Documentation
CaptionAttribute Class
Members See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : CaptionAttribute Class

Glossary Item Box

Object Model

CaptionAttribute Class

Syntax

Visual Basic (Declaration)
<System.AttributeUsageAttribute(ValidOn=AttributeTargets.Assembly Or  _
    AttributeTargets.Module Or  _
    AttributeTargets.Class Or  _
    AttributeTargets.Struct Or  _
    AttributeTargets.Enum Or  _
    AttributeTargets.Constructor Or  _
    AttributeTargets.Method Or  _
    AttributeTargets.Property Or  _
    AttributeTargets.Field Or  _
    AttributeTargets.Event Or  _
    AttributeTargets.Interface Or  _
    AttributeTargets.Parameter Or  _
    AttributeTargets.Delegate Or  _
    AttributeTargets.ReturnValue Or  _
    AttributeTargets.GenericParameter Or  _
    AttributeTargets.All,
   AllowMultiple=False,
   Inherited=True)>
Public Class CaptionAttribute
   Inherits System.Attribute
Visual Basic (Usage) Copy Code
Dim instance As CaptionAttribute
C#
[System.AttributeUsageAttribute(ValidOn=AttributeTargets.Assembly |
    AttributeTargets.Module |
    AttributeTargets.Class |
    AttributeTargets.Struct |
    AttributeTargets.Enum |
    AttributeTargets.Constructor |
    AttributeTargets.Method |
    AttributeTargets.Property |
    AttributeTargets.Field |
    AttributeTargets.Event |
    AttributeTargets.Interface |
    AttributeTargets.Parameter |
    AttributeTargets.Delegate |
    AttributeTargets.ReturnValue |
    AttributeTargets.GenericParameter |
    AttributeTargets.All,
   AllowMultiple=false,
   Inherited=true)]
public class CaptionAttribute : System.Attribute
Delphi
public class CaptionAttribute = class(System.Attribute)
JScript
System.AttributeUsageAttribute(ValidOn=AttributeTargets.Assembly |
    AttributeTargets.Module |
    AttributeTargets.Class |
    AttributeTargets.Struct |
    AttributeTargets.Enum |
    AttributeTargets.Constructor |
    AttributeTargets.Method |
    AttributeTargets.Property |
    AttributeTargets.Field |
    AttributeTargets.Event |
    AttributeTargets.Interface |
    AttributeTargets.Parameter |
    AttributeTargets.Delegate |
    AttributeTargets.ReturnValue |
    AttributeTargets.GenericParameter |
    AttributeTargets.All,
   AllowMultiple=,
   Inherited=)
public class CaptionAttribute extends System.Attribute
Managed Extensions for C++
[System.AttributeUsageAttribute(ValidOn=AttributeTargets.Assembly |
    AttributeTargets.Module |
    AttributeTargets.Class |
    AttributeTargets.Struct |
    AttributeTargets.Enum |
    AttributeTargets.Constructor |
    AttributeTargets.Method |
    AttributeTargets.Property |
    AttributeTargets.Field |
    AttributeTargets.Event |
    AttributeTargets.Interface |
    AttributeTargets.Parameter |
    AttributeTargets.Delegate |
    AttributeTargets.ReturnValue |
    AttributeTargets.GenericParameter |
    AttributeTargets.All,
   AllowMultiple=false,
   Inherited=true)]
public __gc class CaptionAttribute : public System.Attribute
C++/CLI
[System.AttributeUsageAttribute(ValidOn=AttributeTargets.Assembly |
    AttributeTargets.Module |
    AttributeTargets.Class |
    AttributeTargets.Struct |
    AttributeTargets.Enum |
    AttributeTargets.Constructor |
    AttributeTargets.Method |
    AttributeTargets.Property |
    AttributeTargets.Field |
    AttributeTargets.Event |
    AttributeTargets.Interface |
    AttributeTargets.Parameter |
    AttributeTargets.Delegate |
    AttributeTargets.ReturnValue |
    AttributeTargets.GenericParameter |
    AttributeTargets.All,
   AllowMultiple=false,
   Inherited=true)]
public ref class CaptionAttribute : public System.Attribute

Inheritance Hierarchy

System.Object
System.Attribute
ISNet.WebUI.WebGrid.CaptionAttribute

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CaptionAttribute Members
ISNet.WebUI.WebGrid Namespace


CaptionAttribute Class Members

[image]
Intersoft WebGrid Documentation
CaptionAttribute Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebGrid Namespace : CaptionAttribute Class

Glossary Item Box

The following tables list the members exposed by CaptionAttribute.

Public Constructors

 | Name | Description
Public Constructor | CaptionAttribute Constructor |
Top

Public Properties

 | Name | Description
Public Property | Caption |
Public Property | TypeId | (Inherited from System.Attribute)
Top

Public Methods

 | Name | Description
Public Method | Equals | (Inherited from System.Attribute)
Public Method | GetHashCode | (Inherited from System.Attribute)
Public Method | IsDefaultAttribute | (Inherited from System.Attribute)
Public Method | Match | (Inherited from System.Attribute)
Top

See Also

Reference

CaptionAttribute Class
ISNet.WebUI.WebGrid Namespace


CaptionAttribute Class Methods

[image]
Intersoft WebGrid Documentation
CaptionAttribute Class Methods
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : CaptionAttribute Class

Glossary Item Box

For a list of all members of this type, see CaptionAttribute members.

Public Methods

 | Name | Description
Public Method | Equals | (Inherited from System.Attribute)
Public Method | GetHashCode | (Inherited from System.Attribute)
Public Method | IsDefaultAttribute | (Inherited from System.Attribute)
Public Method | Match | (Inherited from System.Attribute)
Top

See Also

Reference

CaptionAttribute Class
ISNet.WebUI.WebGrid Namespace


CaptionAttribute Constructor

[image]
Intersoft WebGrid Documentation
CaptionAttribute Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > CaptionAttribute Class : CaptionAttribute Constructor

caption

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal caption As System.String _
)
Visual Basic (Usage) Copy Code
Dim caption As System.String

Dim instance As New CaptionAttribute(caption)
C#
public CaptionAttribute(
   System.string caption
)
Delphi
public CaptionAttribute(
    caption: System.String
);
JScript
public function CaptionAttribute(
   caption : System.String
);
Managed Extensions for C++
public: CaptionAttribute(
   System.string* caption
)
C++/CLI
public:
CaptionAttribute(
   System.String^ caption
)

Parameters

caption

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CaptionAttribute Class
CaptionAttribute Members


Equals Method

[image]
Intersoft WebGrid Documentation
Equals Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > CaptionAttribute Class : Equals Method

obj

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Security.SecuritySafeCriticalAttribute()>
<__DynamicallyInvokableAttribute()>
Public Overridable Function Equals( _
   ByVal obj As System.Object _
) As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As CaptionAttribute
Dim obj As System.Object
Dim value As System.Boolean

value = instance.Equals(obj)
C#
[System.Security.SecuritySafeCriticalAttribute()]
[__DynamicallyInvokableAttribute()]
public virtual System.bool Equals(
   System.object obj
)
Delphi
public function Equals(
    obj: System.TObject
): System.Boolean; virtual;
JScript
System.Security.SecuritySafeCriticalAttribute()
__DynamicallyInvokableAttribute()
public function Equals(
   obj : System.Object
) : System.boolean;
Managed Extensions for C++
[System.Security.SecuritySafeCriticalAttribute()]
[__DynamicallyInvokableAttribute()]
public: virtual System.bool Equals(
   System.Object* obj
)
C++/CLI
[System.Security.SecuritySafeCriticalAttribute()]
[__DynamicallyInvokableAttribute()]
public:
virtual System.bool Equals(
   System.Object^ obj
)

Parameters

obj

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CaptionAttribute Class
CaptionAttribute Members


GetHashCode Method

[image]
Intersoft WebGrid Documentation
GetHashCode Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > CaptionAttribute Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Security.SecuritySafeCriticalAttribute()>
<__DynamicallyInvokableAttribute()>
Public Overridable Function GetHashCode() As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As CaptionAttribute
Dim value As System.Integer

value = instance.GetHashCode()
C#
[System.Security.SecuritySafeCriticalAttribute()]
[__DynamicallyInvokableAttribute()]
public virtual System.int GetHashCode()
Delphi
public function GetHashCode(): System.Integer; virtual;
JScript
System.Security.SecuritySafeCriticalAttribute()
__DynamicallyInvokableAttribute()
public function GetHashCode() : System.int;
Managed Extensions for C++
[System.Security.SecuritySafeCriticalAttribute()]
[__DynamicallyInvokableAttribute()]
public: virtual System.int GetHashCode();
C++/CLI
[System.Security.SecuritySafeCriticalAttribute()]
[__DynamicallyInvokableAttribute()]
public:
virtual System.int GetHashCode();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CaptionAttribute Class
CaptionAttribute Members


IsDefaultAttribute Method

[image]
Intersoft WebGrid Documentation
IsDefaultAttribute Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > CaptionAttribute Class : IsDefaultAttribute Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsDefaultAttribute() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As CaptionAttribute
Dim value As System.Boolean

value = instance.IsDefaultAttribute()
C#
public virtual System.bool IsDefaultAttribute()
Delphi
public function IsDefaultAttribute(): System.Boolean; virtual;
JScript
public function IsDefaultAttribute() : System.boolean;
Managed Extensions for C++
public: virtual System.bool IsDefaultAttribute();
C++/CLI
public:
virtual System.bool IsDefaultAttribute();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CaptionAttribute Class
CaptionAttribute Members


Match Method

[image]
Intersoft WebGrid Documentation
Match Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > CaptionAttribute Class : Match Method

obj

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Match( _
   ByVal obj As System.Object _
) As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As CaptionAttribute
Dim obj As System.Object
Dim value As System.Boolean

value = instance.Match(obj)
C#
public virtual System.bool Match(
   System.object obj
)
Delphi
public function Match(
    obj: System.TObject
): System.Boolean; virtual;
JScript
public function Match(
   obj : System.Object
) : System.boolean;
Managed Extensions for C++
public: virtual System.bool Match(
   System.Object* obj
)
C++/CLI
public:
virtual System.bool Match(
   System.Object^ obj
)

Parameters

obj

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CaptionAttribute Class
CaptionAttribute Members


CaptionAttribute Class Properties

[image]
Intersoft WebGrid Documentation
CaptionAttribute Class Properties
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : CaptionAttribute Class

Glossary Item Box

For a list of all members of this type, see CaptionAttribute members.

Public Properties

 | Name | Description
Public Property | Caption |
Public Property | TypeId | (Inherited from System.Attribute)
Top

See Also

Reference

CaptionAttribute Class
ISNet.WebUI.WebGrid Namespace


Caption Property

[image]
Intersoft WebGrid Documentation
Caption Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > CaptionAttribute Class : Caption Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Caption As System.String
Visual Basic (Usage) Copy Code
Dim instance As CaptionAttribute
Dim value As System.String

value = instance.Caption
C#
public System.string Caption {get;}
Delphi
public read-only property Caption: System.String;
JScript
public function get Caption : System.String
Managed Extensions for C++
public: __property System.string* get_Caption();
C++/CLI
public:
property System.String^ Caption {
   System.String^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CaptionAttribute Class
CaptionAttribute Members


TypeId Property

[image]
Intersoft WebGrid Documentation
TypeId Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > CaptionAttribute Class : TypeId Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property TypeId As System.Object
Visual Basic (Usage) Copy Code
Dim instance As CaptionAttribute
Dim value As System.Object

value = instance.TypeId
C#
public virtual System.object TypeId {get;}
Delphi
public read-only property TypeId: System.TObject; virtual;
JScript
public function get TypeId : System.Object
Managed Extensions for C++
public: __property virtual System.Object* get_TypeId();
C++/CLI
public:
virtual property System.Object^ TypeId {
   System.Object^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CaptionAttribute Class
CaptionAttribute Members


CellEventArgs Class

[image]
Intersoft WebGrid Documentation
CellEventArgs Class
Members See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : CellEventArgs Class

Glossary Item Box

Object Model

CellEventArgs Class

Syntax

Visual Basic (Declaration)
Public Class CellEventArgs
   Inherits BaseEventArgs
Visual Basic (Usage) Copy Code
Dim instance As CellEventArgs
C#
public class CellEventArgs : BaseEventArgs
Delphi
public class CellEventArgs = class(BaseEventArgs)
JScript
public class CellEventArgs extends BaseEventArgs
Managed Extensions for C++
public __gc class CellEventArgs : public BaseEventArgs
C++/CLI
public ref class CellEventArgs : public BaseEventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
ISNet.WebUI.WebGrid.BaseEventArgs
ISNet.WebUI.WebGrid.CellEventArgs

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CellEventArgs Members
ISNet.WebUI.WebGrid Namespace


CellEventArgs Class Members

[image]
Intersoft WebGrid Documentation
CellEventArgs Class Members
See Also Properties Send Feedback
ISNet.WebUI.WebGrid Namespace : CellEventArgs Class

Glossary Item Box

The following tables list the members exposed by CellEventArgs.

Public Properties

 | Name | Description
Public Property | Cell |
Public Property | ReturnValue | (Inherited from ISNet.WebUI.WebGrid.BaseEventArgs)
Top

See Also

Reference

CellEventArgs Class
ISNet.WebUI.WebGrid Namespace


CellEventArgs Class Properties

[image]
Intersoft WebGrid Documentation
CellEventArgs Class Properties
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : CellEventArgs Class

Glossary Item Box

For a list of all members of this type, see CellEventArgs members.

Public Properties

 | Name | Description
Public Property | Cell |
Public Property | ReturnValue | (Inherited from ISNet.WebUI.WebGrid.BaseEventArgs)
Top

See Also

Reference

CellEventArgs Class
ISNet.WebUI.WebGrid Namespace


Cell Property

[image]
Intersoft WebGrid Documentation
Cell Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > CellEventArgs Class : Cell Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Cell As WebGridCell
Visual Basic (Usage) Copy Code
Dim instance As CellEventArgs
Dim value As WebGridCell

value = instance.Cell
C#
public WebGridCell Cell {get;}
Delphi
public read-only property Cell: WebGridCell;
JScript
public function get Cell : WebGridCell
Managed Extensions for C++
public: __property WebGridCell* get_Cell();
C++/CLI
public:
property WebGridCell^ Cell {
   WebGridCell^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CellEventArgs Class
CellEventArgs Members


ChartFillStyle Class

[image]
Intersoft WebGrid Documentation
ChartFillStyle Class
Members See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : ChartFillStyle Class

Glossary Item Box

Object Model

ChartFillStyle Class

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.SerializableAttribute()>
Public Class ChartFillStyle
   Inherits ISNet.WebUI.NamedObjectBase
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject
Visual Basic (Usage) Copy Code
Dim instance As ChartFillStyle
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public class ChartFillStyle : ISNet.WebUI.NamedObjectBase, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject
Delphi
public class ChartFillStyle = class(ISNet.WebUI.NamedObjectBase, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject)
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.SerializableAttribute()
public class ChartFillStyle extends ISNet.WebUI.NamedObjectBase implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public __gc class ChartFillStyle : public ISNet.WebUI.NamedObjectBase, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public ref class ChartFillStyle : public ISNet.WebUI.NamedObjectBase, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.NamedObjectBase
ISNet.WebUI.WebGrid.ChartFillStyle

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartFillStyle Members
ISNet.WebUI.WebGrid Namespace


ChartFillStyle Class Members

[image]
Intersoft WebGrid Documentation
ChartFillStyle Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebGrid Namespace : ChartFillStyle Class

Glossary Item Box

The following tables list the members exposed by ChartFillStyle.

Public Constructors

 | Name | Description
Public Constructor | ChartFillStyle Constructor |
Top

Public Properties

 | Name | Description
Public Property | ChartFillType |
Public Property | ColorFillStyle |
Public Property | GradientFillStyle |
Public Property | HatchFillStyle |
Public Property | ImageFillStyle |
Public Property | MaterialStyle |
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

ChartFillStyle Class
ISNet.WebUI.WebGrid Namespace


ChartFillStyle Constructor

[image]
Intersoft WebGrid Documentation
ChartFillStyle Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ChartFillStyle Class : ChartFillStyle Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New ChartFillStyle()
C#
public ChartFillStyle()
Delphi
public ChartFillStyle();
JScript
public function ChartFillStyle();
Managed Extensions for C++
public: ChartFillStyle();
C++/CLI
public:
ChartFillStyle();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartFillStyle Class
ChartFillStyle Members


Clone Method

[image]
Intersoft WebGrid Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ChartFillStyle Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As System.Object
Visual Basic (Usage) Copy Code
Dim instance As ChartFillStyle
Dim value As System.Object

value = instance.Clone()
C#
public virtual System.object Clone()
Delphi
public function Clone(): System.TObject; virtual;
JScript
public function Clone() : System.Object;
Managed Extensions for C++
public: virtual System.Object* Clone();
C++/CLI
public:
virtual System.Object^ Clone();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartFillStyle Class
ChartFillStyle Members


CopyFrom Method

[image]
Intersoft WebGrid Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ChartFillStyle Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartFillStyle Class
ChartFillStyle Members


CopyFrom(Object) Method

[image]
Intersoft WebGrid Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ChartFillStyle Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartFillStyle
Dim objSource As System.Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   System.object objSource
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartFillStyle Class
ChartFillStyle Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebGrid Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ChartFillStyle Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object, _
   ByVal cloneSourceValue As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartFillStyle
Dim objSource As System.Object
Dim cloneSourceValue As System.Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   System.object objSource,
   System.bool cloneSourceValue
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject;
    cloneSourceValue: System.Boolean
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object,
   cloneSourceValue : System.boolean
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource,
   System.bool cloneSourceValue
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource,
   System.bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartFillStyle Class
ChartFillStyle Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebGrid Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ChartFillStyle Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartFillStyle
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure DeSerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function DeSerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void DeSerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void DeSerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartFillStyle Class
ChartFillStyle Members


GetHashCode Method

[image]
Intersoft WebGrid Documentation
GetHashCode Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ChartFillStyle Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As ChartFillStyle
Dim value As System.Integer

value = instance.GetHashCode()
C#
public virtual System.int GetHashCode()
Delphi
public function GetHashCode(): System.Integer; virtual;
JScript
public function GetHashCode() : System.int;
Managed Extensions for C++
public: virtual System.int GetHashCode();
C++/CLI
public:
virtual System.int GetHashCode();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartFillStyle Class
ChartFillStyle Members


ChartFillStyle Class Methods

[image]
Intersoft WebGrid Documentation
ChartFillStyle Class Methods
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : ChartFillStyle Class

Glossary Item Box

For a list of all members of this type, see ChartFillStyle members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

ChartFillStyle Class
ISNet.WebUI.WebGrid Namespace


GetObjectData Method

[image]
Intersoft WebGrid Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ChartFillStyle Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=False,
   UnmanagedCode=False,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=True,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Action=SecurityAction.Demand,
   Unrestricted=False)>
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartFillStyle
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure GetObjectData(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
); override;
JScript
System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=,
   UnmanagedCode=,
   SkipVerification=,
   Execution=,
   ControlThread=,
   ControlEvidence=,
   ControlPolicy=,
   SerializationFormatter=,
   ControlDomainPolicy=,
   ControlPrincipal=,
   ControlAppDomain=,
   RemotingConfiguration=,
   Infrastructure=,
   BindingRedirects=,
   Action=SecurityAction.Demand,
   Unrestricted=)
public override function GetObjectData(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public: void GetObjectData(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
) override
C++/CLI
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public:
void GetObjectData(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
) override

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartFillStyle Class
ChartFillStyle Members


IsEmpty Method

[image]
Intersoft WebGrid Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ChartFillStyle Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As ChartFillStyle
Dim value As System.Boolean

value = instance.IsEmpty()
C#
public virtual System.bool IsEmpty()
Delphi
public function IsEmpty(): System.Boolean; virtual;
JScript
public function IsEmpty() : System.boolean;
Managed Extensions for C++
public: virtual System.bool IsEmpty();
C++/CLI
public:
virtual System.bool IsEmpty();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartFillStyle Class
ChartFillStyle Members


Reset Method

[image]
Intersoft WebGrid Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ChartFillStyle Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As ChartFillStyle

instance.Reset()
C#
public virtual void Reset()
Delphi
public procedure Reset(); virtual;
JScript
public function Reset();
Managed Extensions for C++
public: virtual void Reset();
C++/CLI
public:
virtual void Reset();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartFillStyle Class
ChartFillStyle Members


SerializeObjectData Method

[image]
Intersoft WebGrid Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ChartFillStyle Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartFillStyle
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure SerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function SerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void SerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void SerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartFillStyle Class
ChartFillStyle Members


ToString Method

[image]
Intersoft WebGrid Documentation
ToString Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ChartFillStyle Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As System.String
Visual Basic (Usage) Copy Code
Dim instance As ChartFillStyle
Dim value As System.String

value = instance.ToString()
C#
public virtual System.string ToString()
Delphi
public function ToString(): System.String; virtual;
JScript
public function ToString() : System.String;
Managed Extensions for C++
public: virtual System.string* ToString();
C++/CLI
public:
virtual System.String^ ToString();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartFillStyle Class
ChartFillStyle Members


ChartFillStyle Class Properties

[image]
Intersoft WebGrid Documentation
ChartFillStyle Class Properties
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : ChartFillStyle Class

Glossary Item Box

For a list of all members of this type, see ChartFillStyle members.

Public Properties

 | Name | Description
Public Property | ChartFillType |
Public Property | ColorFillStyle |
Public Property | GradientFillStyle |
Public Property | HatchFillStyle |
Public Property | ImageFillStyle |
Public Property | MaterialStyle |
Top

See Also

Reference

ChartFillStyle Class
ISNet.WebUI.WebGrid Namespace


ChartFillStyle Constructor

[image]
Intersoft WebGrid Documentation
ChartFillStyle Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ChartFillStyle Class : ChartFillStyle Constructor

Glossary Item Box

Overload List

Overload | Description
ChartFillStyle Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartFillStyle Class
ChartFillStyle Members


ChartFillType Property

[image]
Intersoft WebGrid Documentation
ChartFillType Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ChartFillStyle Class : ChartFillType Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Appearance")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Defines the type of Fill Style to be applied.")>
Public Property ChartFillType As ChartFillType
Visual Basic (Usage) Copy Code
Dim instance As ChartFillStyle
Dim value As ChartFillType

instance.ChartFillType = value

value = instance.ChartFillType
C#
[System.ComponentModel.CategoryAttribute("Appearance")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Defines the type of Fill Style to be applied.")]
public ChartFillType ChartFillType {get; set;}
Delphi
public read-write property ChartFillType: ChartFillType;
JScript
System.ComponentModel.CategoryAttribute("Appearance")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Defines the type of Fill Style to be applied.")
public function get,set ChartFillType : ChartFillType
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Appearance")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Defines the type of Fill Style to be applied.")]
public: __property ChartFillType get_ChartFillType();
public: __property void set_ChartFillType(
   ChartFillType value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Appearance")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Defines the type of Fill Style to be applied.")]
public:
property ChartFillType ChartFillType {
   ChartFillType get();
   void set (    ChartFillType value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartFillStyle Class
ChartFillStyle Members


ColorFillStyle Property

[image]
Intersoft WebGrid Documentation
ColorFillStyle Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ChartFillStyle Class : ColorFillStyle Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Appearance")>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute("setColorFillStyle")>
<System.ComponentModel.DescriptionAttribute("Controls the color fill effect when ChartFillType is set to ColorFill.")>
Public ReadOnly Property ColorFillStyle As ChartColorFillStyle
Visual Basic (Usage) Copy Code
Dim instance As ChartFillStyle
Dim value As ChartColorFillStyle

value = instance.ColorFillStyle
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute("setColorFillStyle")]
[System.ComponentModel.DescriptionAttribute("Controls the color fill effect when ChartFillType is set to ColorFill.")]
public ChartColorFillStyle ColorFillStyle {get;}
Delphi
public read-only property ColorFillStyle: ChartColorFillStyle;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Appearance")
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute("setColorFillStyle")
System.ComponentModel.DescriptionAttribute("Controls the color fill effect when ChartFillType is set to ColorFill.")
public function get ColorFillStyle : ChartColorFillStyle
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute("setColorFillStyle")]
[System.ComponentModel.DescriptionAttribute("Controls the color fill effect when ChartFillType is set to ColorFill.")]
public: __property ChartColorFillStyle* get_ColorFillStyle();
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute("setColorFillStyle")]
[System.ComponentModel.DescriptionAttribute("Controls the color fill effect when ChartFillType is set to ColorFill.")]
public:
property ChartColorFillStyle^ ColorFillStyle {
   ChartColorFillStyle^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartFillStyle Class
ChartFillStyle Members


GradientFillStyle Property

[image]
Intersoft WebGrid Documentation
GradientFillStyle Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ChartFillStyle Class : GradientFillStyle Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Controls the gradient fill effect when ChartFillType is set to GradientFill.")>
<ISNet.Serialization.BinarySerializableAttribute("setGradientFillStyle")>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<System.ComponentModel.CategoryAttribute("Appearance")>
<System.ComponentModel.DefaultValueAttribute()>
Public ReadOnly Property GradientFillStyle As ChartGradientFillStyle
Visual Basic (Usage) Copy Code
Dim instance As ChartFillStyle
Dim value As ChartGradientFillStyle

value = instance.GradientFillStyle
C#
[System.ComponentModel.DescriptionAttribute("Controls the gradient fill effect when ChartFillType is set to GradientFill.")]
[ISNet.Serialization.BinarySerializableAttribute("setGradientFillStyle")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.DefaultValueAttribute()]
public ChartGradientFillStyle GradientFillStyle {get;}
Delphi
public read-only property GradientFillStyle: ChartGradientFillStyle;
JScript
System.ComponentModel.DescriptionAttribute("Controls the gradient fill effect when ChartFillType is set to GradientFill.")
ISNet.Serialization.BinarySerializableAttribute("setGradientFillStyle")
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
System.ComponentModel.CategoryAttribute("Appearance")
System.ComponentModel.DefaultValueAttribute()
public function get GradientFillStyle : ChartGradientFillStyle
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Controls the gradient fill effect when ChartFillType is set to GradientFill.")]
[ISNet.Serialization.BinarySerializableAttribute("setGradientFillStyle")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property ChartGradientFillStyle* get_GradientFillStyle();
C++/CLI
[System.ComponentModel.DescriptionAttribute("Controls the gradient fill effect when ChartFillType is set to GradientFill.")]
[ISNet.Serialization.BinarySerializableAttribute("setGradientFillStyle")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property ChartGradientFillStyle^ GradientFillStyle {
   ChartGradientFillStyle^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartFillStyle Class
ChartFillStyle Members


HatchFillStyle Property

[image]
Intersoft WebGrid Documentation
HatchFillStyle Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ChartFillStyle Class : HatchFillStyle Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Appearance")>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<System.ComponentModel.DescriptionAttribute("Controls the patterned (hatch) fill effect when ChartFillType is set to HatchFill. ")>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute("setHatchFillStyle")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public ReadOnly Property HatchFillStyle As ChartHatchFillStyle
Visual Basic (Usage) Copy Code
Dim instance As ChartFillStyle
Dim value As ChartHatchFillStyle

value = instance.HatchFillStyle
C#
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DescriptionAttribute("Controls the patterned (hatch) fill effect when ChartFillType is set to HatchFill. ")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute("setHatchFillStyle")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public ChartHatchFillStyle HatchFillStyle {get;}
Delphi
public read-only property HatchFillStyle: ChartHatchFillStyle;
JScript
System.ComponentModel.CategoryAttribute("Appearance")
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
System.ComponentModel.DescriptionAttribute("Controls the patterned (hatch) fill effect when ChartFillType is set to HatchFill. ")
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute("setHatchFillStyle")
System.ComponentModel.NotifyParentPropertyAttribute()
public function get HatchFillStyle : ChartHatchFillStyle
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DescriptionAttribute("Controls the patterned (hatch) fill effect when ChartFillType is set to HatchFill. ")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute("setHatchFillStyle")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property ChartHatchFillStyle* get_HatchFillStyle();
C++/CLI
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DescriptionAttribute("Controls the patterned (hatch) fill effect when ChartFillType is set to HatchFill. ")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute("setHatchFillStyle")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property ChartHatchFillStyle^ HatchFillStyle {
   ChartHatchFillStyle^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartFillStyle Class
ChartFillStyle Members


ImageFillStyle Property

[image]
Intersoft WebGrid Documentation
ImageFillStyle Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ChartFillStyle Class : ImageFillStyle Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Appearance")>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.DescriptionAttribute("Controls the image fill effect when ChartFillType is set to ImageFill.")>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute("setImageFillStyle")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
Public ReadOnly Property ImageFillStyle As ChartImageFillStyle
Visual Basic (Usage) Copy Code
Dim instance As ChartFillStyle
Dim value As ChartImageFillStyle

value = instance.ImageFillStyle
C#
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DescriptionAttribute("Controls the image fill effect when ChartFillType is set to ImageFill.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute("setImageFillStyle")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
public ChartImageFillStyle ImageFillStyle {get;}
Delphi
public read-only property ImageFillStyle: ChartImageFillStyle;
JScript
System.ComponentModel.CategoryAttribute("Appearance")
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.DescriptionAttribute("Controls the image fill effect when ChartFillType is set to ImageFill.")
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute("setImageFillStyle")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
public function get ImageFillStyle : ChartImageFillStyle
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DescriptionAttribute("Controls the image fill effect when ChartFillType is set to ImageFill.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute("setImageFillStyle")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
public: __property ChartImageFillStyle* get_ImageFillStyle();
C++/CLI
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DescriptionAttribute("Controls the image fill effect when ChartFillType is set to ImageFill.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute("setImageFillStyle")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
public:
property ChartImageFillStyle^ ImageFillStyle {
   ChartImageFillStyle^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartFillStyle Class
ChartFillStyle Members


MaterialStyle Property

[image]
Intersoft WebGrid Documentation
MaterialStyle Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ChartFillStyle Class : MaterialStyle Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Appearance")>
<ISNet.Serialization.BinarySerializableAttribute("setMaterialStyle")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Controls the material style of the fill style effect.")>
Public ReadOnly Property MaterialStyle As ChartMaterialStyle
Visual Basic (Usage) Copy Code
Dim instance As ChartFillStyle
Dim value As ChartMaterialStyle

value = instance.MaterialStyle
C#
[System.ComponentModel.CategoryAttribute("Appearance")]
[ISNet.Serialization.BinarySerializableAttribute("setMaterialStyle")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Controls the material style of the fill style effect.")]
public ChartMaterialStyle MaterialStyle {get;}
Delphi
public read-only property MaterialStyle: ChartMaterialStyle;
JScript
System.ComponentModel.CategoryAttribute("Appearance")
ISNet.Serialization.BinarySerializableAttribute("setMaterialStyle")
System.ComponentModel.NotifyParentPropertyAttribute()
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Controls the material style of the fill style effect.")
public function get MaterialStyle : ChartMaterialStyle
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Appearance")]
[ISNet.Serialization.BinarySerializableAttribute("setMaterialStyle")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Controls the material style of the fill style effect.")]
public: __property ChartMaterialStyle* get_MaterialStyle();
C++/CLI
[System.ComponentModel.CategoryAttribute("Appearance")]
[ISNet.Serialization.BinarySerializableAttribute("setMaterialStyle")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Controls the material style of the fill style effect.")]
public:
property ChartMaterialStyle^ MaterialStyle {
   ChartMaterialStyle^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartFillStyle Class
ChartFillStyle Members


ChartLightSourceSettings Class

[image]
Intersoft WebGrid Documentation
ChartLightSourceSettings Class
Members See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : ChartLightSourceSettings Class

Glossary Item Box

Object Model

ChartLightSourceSettings Class

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.SerializableAttribute()>
Public Class ChartLightSourceSettings
   Inherits ISNet.WebUI.NamedObjectBase
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject
Visual Basic (Usage) Copy Code
Dim instance As ChartLightSourceSettings
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public class ChartLightSourceSettings : ISNet.WebUI.NamedObjectBase, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject
Delphi
public class ChartLightSourceSettings = class(ISNet.WebUI.NamedObjectBase, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject)
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.SerializableAttribute()
public class ChartLightSourceSettings extends ISNet.WebUI.NamedObjectBase implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public __gc class ChartLightSourceSettings : public ISNet.WebUI.NamedObjectBase, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public ref class ChartLightSourceSettings : public ISNet.WebUI.NamedObjectBase, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.NamedObjectBase
ISNet.WebUI.WebGrid.ChartLightSourceSettings

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartLightSourceSettings Members
ISNet.WebUI.WebGrid Namespace


ChartLightSourceSettings Class Members

[image]
Intersoft WebGrid Documentation
ChartLightSourceSettings Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebGrid Namespace : ChartLightSourceSettings Class

Glossary Item Box

The following tables list the members exposed by ChartLightSourceSettings.

Public Constructors

 | Name | Description
Public Constructor | ChartLightSourceSettings Constructor |
Top

Public Properties

 | Name | Description
Public Property | Ambient |
Public Property | ConstantAttenuation |
Public Property | Difuse |
Public Property | Direction |
Public Property | LightSourceType |
Public Property | LinearAttenuation |
Public Property | Name | Overridden.
Public Property | Position |
Public Property | QuadraticAttenuation |
Public Property | Specular |
Public Property | SpotCutoff |
Public Property | SpotExponent |
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

ChartLightSourceSettings Class
ISNet.WebUI.WebGrid Namespace


ChartLightSourceSettings Constructor

[image]
Intersoft WebGrid Documentation
ChartLightSourceSettings Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ChartLightSourceSettings Class : ChartLightSourceSettings Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New ChartLightSourceSettings()
C#
public ChartLightSourceSettings()
Delphi
public ChartLightSourceSettings();
JScript
public function ChartLightSourceSettings();
Managed Extensions for C++
public: ChartLightSourceSettings();
C++/CLI
public:
ChartLightSourceSettings();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartLightSourceSettings Class
ChartLightSourceSettings Members


Clone Method

[image]
Intersoft WebGrid Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ChartLightSourceSettings Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As System.Object
Visual Basic (Usage) Copy Code
Dim instance As ChartLightSourceSettings
Dim value As System.Object

value = instance.Clone()
C#
public virtual System.object Clone()
Delphi
public function Clone(): System.TObject; virtual;
JScript
public function Clone() : System.Object;
Managed Extensions for C++
public: virtual System.Object* Clone();
C++/CLI
public:
virtual System.Object^ Clone();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartLightSourceSettings Class
ChartLightSourceSettings Members


CopyFrom Method

[image]
Intersoft WebGrid Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ChartLightSourceSettings Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartLightSourceSettings Class
ChartLightSourceSettings Members


CopyFrom(Object) Method

[image]
Intersoft WebGrid Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ChartLightSourceSettings Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartLightSourceSettings
Dim objSource As System.Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   System.object objSource
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartLightSourceSettings Class
ChartLightSourceSettings Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebGrid Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ChartLightSourceSettings Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object, _
   ByVal cloneSourceValue As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartLightSourceSettings
Dim objSource As System.Object
Dim cloneSourceValue As System.Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   System.object objSource,
   System.bool cloneSourceValue
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject;
    cloneSourceValue: System.Boolean
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object,
   cloneSourceValue : System.boolean
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource,
   System.bool cloneSourceValue
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource,
   System.bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartLightSourceSettings Class
ChartLightSourceSettings Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebGrid Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ChartLightSourceSettings Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartLightSourceSettings
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure DeSerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function DeSerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void DeSerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void DeSerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartLightSourceSettings Class
ChartLightSourceSettings Members


GetHashCode Method

[image]
Intersoft WebGrid Documentation
GetHashCode Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ChartLightSourceSettings Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As ChartLightSourceSettings
Dim value As System.Integer

value = instance.GetHashCode()
C#
public virtual System.int GetHashCode()
Delphi
public function GetHashCode(): System.Integer; virtual;
JScript
public function GetHashCode() : System.int;
Managed Extensions for C++
public: virtual System.int GetHashCode();
C++/CLI
public:
virtual System.int GetHashCode();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartLightSourceSettings Class
ChartLightSourceSettings Members


ChartLightSourceSettings Class Methods

[image]
Intersoft WebGrid Documentation
ChartLightSourceSettings Class Methods
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : ChartLightSourceSettings Class

Glossary Item Box

For a list of all members of this type, see ChartLightSourceSettings members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

ChartLightSourceSettings Class
ISNet.WebUI.WebGrid Namespace


GetObjectData Method

[image]
Intersoft WebGrid Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ChartLightSourceSettings Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=False,
   UnmanagedCode=False,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=True,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Action=SecurityAction.Demand,
   Unrestricted=False)>
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartLightSourceSettings
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure GetObjectData(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
); override;
JScript
System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=,
   UnmanagedCode=,
   SkipVerification=,
   Execution=,
   ControlThread=,
   ControlEvidence=,
   ControlPolicy=,
   SerializationFormatter=,
   ControlDomainPolicy=,
   ControlPrincipal=,
   ControlAppDomain=,
   RemotingConfiguration=,
   Infrastructure=,
   BindingRedirects=,
   Action=SecurityAction.Demand,
   Unrestricted=)
public override function GetObjectData(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public: void GetObjectData(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
) override
C++/CLI
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public:
void GetObjectData(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
) override

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartLightSourceSettings Class
ChartLightSourceSettings Members


IsEmpty Method

[image]
Intersoft WebGrid Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ChartLightSourceSettings Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As ChartLightSourceSettings
Dim value As System.Boolean

value = instance.IsEmpty()
C#
public virtual System.bool IsEmpty()
Delphi
public function IsEmpty(): System.Boolean; virtual;
JScript
public function IsEmpty() : System.boolean;
Managed Extensions for C++
public: virtual System.bool IsEmpty();
C++/CLI
public:
virtual System.bool IsEmpty();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartLightSourceSettings Class
ChartLightSourceSettings Members


Reset Method

[image]
Intersoft WebGrid Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ChartLightSourceSettings Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As ChartLightSourceSettings

instance.Reset()
C#
public virtual void Reset()
Delphi
public procedure Reset(); virtual;
JScript
public function Reset();
Managed Extensions for C++
public: virtual void Reset();
C++/CLI
public:
virtual void Reset();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartLightSourceSettings Class
ChartLightSourceSettings Members


SerializeObjectData Method

[image]
Intersoft WebGrid Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ChartLightSourceSettings Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartLightSourceSettings
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure SerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function SerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void SerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void SerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartLightSourceSettings Class
ChartLightSourceSettings Members


ToString Method

[image]
Intersoft WebGrid Documentation
ToString Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ChartLightSourceSettings Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As System.String
Visual Basic (Usage) Copy Code
Dim instance As ChartLightSourceSettings
Dim value As System.String

value = instance.ToString()
C#
public virtual System.string ToString()
Delphi
public function ToString(): System.String; virtual;
JScript
public function ToString() : System.String;
Managed Extensions for C++
public: virtual System.string* ToString();
C++/CLI
public:
virtual System.String^ ToString();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartLightSourceSettings Class
ChartLightSourceSettings Members


ChartLightSourceSettings Class Properties

[image]
Intersoft WebGrid Documentation
ChartLightSourceSettings Class Properties
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : ChartLightSourceSettings Class

Glossary Item Box

For a list of all members of this type, see ChartLightSourceSettings members.

Public Properties

 | Name | Description
Public Property | Ambient |
Public Property | ConstantAttenuation |
Public Property | Difuse |
Public Property | Direction |
Public Property | LightSourceType |
Public Property | LinearAttenuation |
Public Property | Name | Overridden.
Public Property | Position |
Public Property | QuadraticAttenuation |
Public Property | Specular |
Public Property | SpotCutoff |
Public Property | SpotExponent |
Top

See Also

Reference

ChartLightSourceSettings Class
ISNet.WebUI.WebGrid Namespace


ChartLightSourceSettings Constructor

[image]
Intersoft WebGrid Documentation
ChartLightSourceSettings Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ChartLightSourceSettings Class : ChartLightSourceSettings Constructor

Glossary Item Box

Overload List

Overload | Description
ChartLightSourceSettings Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartLightSourceSettings Class
ChartLightSourceSettings Members


Ambient Property

[image]
Intersoft WebGrid Documentation
Ambient Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ChartLightSourceSettings Class : Ambient Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("The ambient color emitted by this light source. ")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Emission")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property Ambient As System.Drawing.Color
Visual Basic (Usage) Copy Code
Dim instance As ChartLightSourceSettings
Dim value As System.Drawing.Color

instance.Ambient = value

value = instance.Ambient
C#
[System.ComponentModel.DescriptionAttribute("The ambient color emitted by this light source. ")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Emission")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.Drawing.Color Ambient {get; set;}
Delphi
public read-write property Ambient: System.Drawing.Color;
JScript
System.ComponentModel.DescriptionAttribute("The ambient color emitted by this light source. ")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Emission")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set Ambient : System.Drawing.Color
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("The ambient color emitted by this light source. ")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Emission")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.Drawing.Color get_Ambient();
public: __property void set_Ambient(
   System.Drawing.Color value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("The ambient color emitted by this light source. ")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Emission")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.Drawing.Color Ambient {
   System.Drawing.Color get();
   void set (    System.Drawing.Color value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartLightSourceSettings Class
ChartLightSourceSettings Members


ConstantAttenuation Property

[image]
Intersoft WebGrid Documentation
ConstantAttenuation Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ChartLightSourceSettings Class : ConstantAttenuation Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies the constant attenuation factor for this light.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Attenuation")>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property ConstantAttenuation As System.Single
Visual Basic (Usage) Copy Code
Dim instance As ChartLightSourceSettings
Dim value As System.Single

instance.ConstantAttenuation = value

value = instance.ConstantAttenuation
C#
[System.ComponentModel.DescriptionAttribute("Specifies the constant attenuation factor for this light.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Attenuation")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.float ConstantAttenuation {get; set;}
Delphi
public read-write property ConstantAttenuation: System.Single;
JScript
System.ComponentModel.DescriptionAttribute("Specifies the constant attenuation factor for this light.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.CategoryAttribute("Attenuation")
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set ConstantAttenuation : System.float
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies the constant attenuation factor for this light.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Attenuation")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.float get_ConstantAttenuation();
public: __property void set_ConstantAttenuation(
   System.float value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies the constant attenuation factor for this light.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Attenuation")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.float ConstantAttenuation {
   System.float get();
   void set (    System.float value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartLightSourceSettings Class
ChartLightSourceSettings Members


Difuse Property

[image]
Intersoft WebGrid Documentation
Difuse Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ChartLightSourceSettings Class : Difuse Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("The diffuse color emitted by this light source. ")>
<System.ComponentModel.CategoryAttribute("Emission")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property Difuse As System.Drawing.Color
Visual Basic (Usage) Copy Code
Dim instance As ChartLightSourceSettings
Dim value As System.Drawing.Color

instance.Difuse = value

value = instance.Difuse
C#
[System.ComponentModel.DescriptionAttribute("The diffuse color emitted by this light source. ")]
[System.ComponentModel.CategoryAttribute("Emission")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.Drawing.Color Difuse {get; set;}
Delphi
public read-write property Difuse: System.Drawing.Color;
JScript
System.ComponentModel.DescriptionAttribute("The diffuse color emitted by this light source. ")
System.ComponentModel.CategoryAttribute("Emission")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set Difuse : System.Drawing.Color
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("The diffuse color emitted by this light source. ")]
[System.ComponentModel.CategoryAttribute("Emission")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.Drawing.Color get_Difuse();
public: __property void set_Difuse(
   System.Drawing.Color value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("The diffuse color emitted by this light source. ")]
[System.ComponentModel.CategoryAttribute("Emission")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.Drawing.Color Difuse {
   System.Drawing.Color get();
   void set (    System.Drawing.Color value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartLightSourceSettings Class
ChartLightSourceSettings Members


Direction Property

[image]
Intersoft WebGrid Documentation
Direction Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ChartLightSourceSettings Class : Direction Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute("setDirection")>
<System.ComponentModel.DescriptionAttribute("A vector which specifies the direction of the light source.")>
<System.ComponentModel.CategoryAttribute("General")>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
Public ReadOnly Property Direction As ChartVector3DValue
Visual Basic (Usage) Copy Code
Dim instance As ChartLightSourceSettings
Dim value As ChartVector3DValue

value = instance.Direction
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute("setDirection")]
[System.ComponentModel.DescriptionAttribute("A vector which specifies the direction of the light source.")]
[System.ComponentModel.CategoryAttribute("General")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
public ChartVector3DValue Direction {get;}
Delphi
public read-only property Direction: ChartVector3DValue;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute("setDirection")
System.ComponentModel.DescriptionAttribute("A vector which specifies the direction of the light source.")
System.ComponentModel.CategoryAttribute("General")
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
public function get Direction : ChartVector3DValue
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute("setDirection")]
[System.ComponentModel.DescriptionAttribute("A vector which specifies the direction of the light source.")]
[System.ComponentModel.CategoryAttribute("General")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
public: __property ChartVector3DValue* get_Direction();
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute("setDirection")]
[System.ComponentModel.DescriptionAttribute("A vector which specifies the direction of the light source.")]
[System.ComponentModel.CategoryAttribute("General")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
public:
property ChartVector3DValue^ Direction {
   ChartVector3DValue^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartLightSourceSettings Class
ChartLightSourceSettings Members


LightSourceType Property

[image]
Intersoft WebGrid Documentation
LightSourceType Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ChartLightSourceSettings Class : LightSourceType Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Selects between positional and directional light source.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("General")>
Public Property LightSourceType As LightSourceType
Visual Basic (Usage) Copy Code
Dim instance As ChartLightSourceSettings
Dim value As LightSourceType

instance.LightSourceType = value

value = instance.LightSourceType
C#
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Selects between positional and directional light source.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("General")]
public LightSourceType LightSourceType {get; set;}
Delphi
public read-write property LightSourceType: LightSourceType;
JScript
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Selects between positional and directional light source.")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("General")
public function get,set LightSourceType : LightSourceType
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Selects between positional and directional light source.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("General")]
public: __property LightSourceType get_LightSourceType();
public: __property void set_LightSourceType(
   LightSourceType value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Selects between positional and directional light source.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("General")]
public:
property LightSourceType LightSourceType {
   LightSourceType get();
   void set (    LightSourceType value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartLightSourceSettings Class
ChartLightSourceSettings Members


LinearAttenuation Property

[image]
Intersoft WebGrid Documentation
LinearAttenuation Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ChartLightSourceSettings Class : LinearAttenuation Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies the linear attenuation factor for this light.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Attenuation")>
Public Property LinearAttenuation As System.Single
Visual Basic (Usage) Copy Code
Dim instance As ChartLightSourceSettings
Dim value As System.Single

instance.LinearAttenuation = value

value = instance.LinearAttenuation
C#
[System.ComponentModel.DescriptionAttribute("Specifies the linear attenuation factor for this light.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Attenuation")]
public System.float LinearAttenuation {get; set;}
Delphi
public read-write property LinearAttenuation: System.Single;
JScript
System.ComponentModel.DescriptionAttribute("Specifies the linear attenuation factor for this light.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Attenuation")
public function get,set LinearAttenuation : System.float
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies the linear attenuation factor for this light.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Attenuation")]
public: __property System.float get_LinearAttenuation();
public: __property void set_LinearAttenuation(
   System.float value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies the linear attenuation factor for this light.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Attenuation")]
public:
property System.float LinearAttenuation {
   System.float get();
   void set (    System.float value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartLightSourceSettings Class
ChartLightSourceSettings Members


Name Property

[image]
Intersoft WebGrid Documentation
Name Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ChartLightSourceSettings Class : Name Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.BrowsableAttribute(True)>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Visible)>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Overrides Property Name As System.String
Visual Basic (Usage) Copy Code
Dim instance As ChartLightSourceSettings
Dim value As System.String

instance.Name = value

value = instance.Name
C#
[System.ComponentModel.BrowsableAttribute(true)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Visible)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public override System.string Name {get; set;}
Delphi
public read-write property Name: System.String; override;
JScript
System.ComponentModel.BrowsableAttribute()
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Visible)
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public override function get,set Name : System.String
Managed Extensions for C++
[System.ComponentModel.BrowsableAttribute(true)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Visible)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.string* get_Name() override;
public: __property void set_Name(
   System.string* value
) override;
C++/CLI
[System.ComponentModel.BrowsableAttribute(true)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Visible)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.String^ Name {
   System.String^ get() override;
   void set (    System.String^ value) override;
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartLightSourceSettings Class
ChartLightSourceSettings Members


Position Property

[image]
Intersoft WebGrid Documentation
Position Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ChartLightSourceSettings Class : Position Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("A vector which specifies the position of the light source in 3D space.")>
<System.ComponentModel.CategoryAttribute("General")>
<ISNet.Serialization.BinarySerializableAttribute("setPosition")>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
Public ReadOnly Property Position As ChartVector3DValue
Visual Basic (Usage) Copy Code
Dim instance As ChartLightSourceSettings
Dim value As ChartVector3DValue

value = instance.Position
C#
[System.ComponentModel.DescriptionAttribute("A vector which specifies the position of the light source in 3D space.")]
[System.ComponentModel.CategoryAttribute("General")]
[ISNet.Serialization.BinarySerializableAttribute("setPosition")]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
public ChartVector3DValue Position {get;}
Delphi
public read-only property Position: ChartVector3DValue;
JScript
System.ComponentModel.DescriptionAttribute("A vector which specifies the position of the light source in 3D space.")
System.ComponentModel.CategoryAttribute("General")
ISNet.Serialization.BinarySerializableAttribute("setPosition")
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
public function get Position : ChartVector3DValue
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("A vector which specifies the position of the light source in 3D space.")]
[System.ComponentModel.CategoryAttribute("General")]
[ISNet.Serialization.BinarySerializableAttribute("setPosition")]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
public: __property ChartVector3DValue* get_Position();
C++/CLI
[System.ComponentModel.DescriptionAttribute("A vector which specifies the position of the light source in 3D space.")]
[System.ComponentModel.CategoryAttribute("General")]
[ISNet.Serialization.BinarySerializableAttribute("setPosition")]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
public:
property ChartVector3DValue^ Position {
   ChartVector3DValue^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartLightSourceSettings Class
ChartLightSourceSettings Members


QuadraticAttenuation Property

[image]
Intersoft WebGrid Documentation
QuadraticAttenuation Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ChartLightSourceSettings Class : QuadraticAttenuation Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Specifies the quadratic attenuation factor for this light.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Attenuation")>
Public Property QuadraticAttenuation As System.Single
Visual Basic (Usage) Copy Code
Dim instance As ChartLightSourceSettings
Dim value As System.Single

instance.QuadraticAttenuation = value

value = instance.QuadraticAttenuation
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the quadratic attenuation factor for this light.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Attenuation")]
public System.float QuadraticAttenuation {get; set;}
Delphi
public read-write property QuadraticAttenuation: System.Single;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the quadratic attenuation factor for this light.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Attenuation")
public function get,set QuadraticAttenuation : System.float
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the quadratic attenuation factor for this light.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Attenuation")]
public: __property System.float get_QuadraticAttenuation();
public: __property void set_QuadraticAttenuation(
   System.float value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the quadratic attenuation factor for this light.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Attenuation")]
public:
property System.float QuadraticAttenuation {
   System.float get();
   void set (    System.float value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartLightSourceSettings Class
ChartLightSourceSettings Members


Specular Property

[image]
Intersoft WebGrid Documentation
Specular Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ChartLightSourceSettings Class : Specular Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("The specular color emitted by this light source. ")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Emission")>
Public Property Specular As System.Drawing.Color
Visual Basic (Usage) Copy Code
Dim instance As ChartLightSourceSettings
Dim value As System.Drawing.Color

instance.Specular = value

value = instance.Specular
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("The specular color emitted by this light source. ")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Emission")]
public System.Drawing.Color Specular {get; set;}
Delphi
public read-write property Specular: System.Drawing.Color;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DescriptionAttribute("The specular color emitted by this light source. ")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Emission")
public function get,set Specular : System.Drawing.Color
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("The specular color emitted by this light source. ")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Emission")]
public: __property System.Drawing.Color get_Specular();
public: __property void set_Specular(
   System.Drawing.Color value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("The specular color emitted by this light source. ")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Emission")]
public:
property System.Drawing.Color Specular {
   System.Drawing.Color get();
   void set (    System.Drawing.Color value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartLightSourceSettings Class
ChartLightSourceSettings Members


SpotCutoff Property

[image]
Intersoft WebGrid Documentation
SpotCutoff Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ChartLightSourceSettings Class : SpotCutoff Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("The spot cutoff angle of the light source.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Spotlight")>
Public Property SpotCutoff As System.Single
Visual Basic (Usage) Copy Code
Dim instance As ChartLightSourceSettings
Dim value As System.Single

instance.SpotCutoff = value

value = instance.SpotCutoff
C#
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("The spot cutoff angle of the light source.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Spotlight")]
public System.float SpotCutoff {get; set;}
Delphi
public read-write property SpotCutoff: System.Single;
JScript
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("The spot cutoff angle of the light source.")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Spotlight")
public function get,set SpotCutoff : System.float
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("The spot cutoff angle of the light source.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Spotlight")]
public: __property System.float get_SpotCutoff();
public: __property void set_SpotCutoff(
   System.float value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("The spot cutoff angle of the light source.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Spotlight")]
public:
property System.float SpotCutoff {
   System.float get();
   void set (    System.float value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartLightSourceSettings Class
ChartLightSourceSettings Members


SpotExponent Property

[image]
Intersoft WebGrid Documentation
SpotExponent Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ChartLightSourceSettings Class : SpotExponent Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("The spot exponent specifies the intensity distribution of a spot light. ")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Spotlight")>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property SpotExponent As System.Single
Visual Basic (Usage) Copy Code
Dim instance As ChartLightSourceSettings
Dim value As System.Single

instance.SpotExponent = value

value = instance.SpotExponent
C#
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("The spot exponent specifies the intensity distribution of a spot light. ")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Spotlight")]
[ISNet.Serialization.BinarySerializableAttribute()]
public System.float SpotExponent {get; set;}
Delphi
public read-write property SpotExponent: System.Single;
JScript
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("The spot exponent specifies the intensity distribution of a spot light. ")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.CategoryAttribute("Spotlight")
ISNet.Serialization.BinarySerializableAttribute()
public function get,set SpotExponent : System.float
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("The spot exponent specifies the intensity distribution of a spot light. ")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Spotlight")]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.float get_SpotExponent();
public: __property void set_SpotExponent(
   System.float value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("The spot exponent specifies the intensity distribution of a spot light. ")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Spotlight")]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.float SpotExponent {
   System.float get();
   void set (    System.float value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartLightSourceSettings Class
ChartLightSourceSettings Members


ChartMarkerStyle Class

[image]
Intersoft WebGrid Documentation
ChartMarkerStyle Class
Members See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : ChartMarkerStyle Class

Glossary Item Box

Object Model

ChartMarkerStyle Class

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.SerializableAttribute()>
Public Class ChartMarkerStyle
   Inherits ISNet.WebUI.NamedObjectBase
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject
Visual Basic (Usage) Copy Code
Dim instance As ChartMarkerStyle
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public class ChartMarkerStyle : ISNet.WebUI.NamedObjectBase, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject
Delphi
public class ChartMarkerStyle = class(ISNet.WebUI.NamedObjectBase, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject)
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.SerializableAttribute()
public class ChartMarkerStyle extends ISNet.WebUI.NamedObjectBase implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public __gc class ChartMarkerStyle : public ISNet.WebUI.NamedObjectBase, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public ref class ChartMarkerStyle : public ISNet.WebUI.NamedObjectBase, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.NamedObjectBase
ISNet.WebUI.WebGrid.ChartMarkerStyle

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartMarkerStyle Members
ISNet.WebUI.WebGrid Namespace


ChartMarkerStyle Class Members

[image]
Intersoft WebGrid Documentation
ChartMarkerStyle Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebGrid Namespace : ChartMarkerStyle Class

Glossary Item Box

The following tables list the members exposed by ChartMarkerStyle.

Public Constructors

 | Name | Description
Public Constructor | ChartMarkerStyle Constructor |
Top

Public Properties

 | Name | Description
Public Property | AutoDepth |
Public Property | BorderStyle |
Public Property | Depth |
Public Property | FillStyle |
Public Property | Height |
Public Property | PointShape |
Public Property | VerticalAlign |
Public Property | Visible |
Public Property | Width |
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

ChartMarkerStyle Class
ISNet.WebUI.WebGrid Namespace


ChartMarkerStyle Constructor

[image]
Intersoft WebGrid Documentation
ChartMarkerStyle Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ChartMarkerStyle Class : ChartMarkerStyle Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New ChartMarkerStyle()
C#
public ChartMarkerStyle()
Delphi
public ChartMarkerStyle();
JScript
public function ChartMarkerStyle();
Managed Extensions for C++
public: ChartMarkerStyle();
C++/CLI
public:
ChartMarkerStyle();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartMarkerStyle Class
ChartMarkerStyle Members


Clone Method

[image]
Intersoft WebGrid Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ChartMarkerStyle Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As System.Object
Visual Basic (Usage) Copy Code
Dim instance As ChartMarkerStyle
Dim value As System.Object

value = instance.Clone()
C#
public virtual System.object Clone()
Delphi
public function Clone(): System.TObject; virtual;
JScript
public function Clone() : System.Object;
Managed Extensions for C++
public: virtual System.Object* Clone();
C++/CLI
public:
virtual System.Object^ Clone();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartMarkerStyle Class
ChartMarkerStyle Members


CopyFrom Method

[image]
Intersoft WebGrid Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ChartMarkerStyle Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartMarkerStyle Class
ChartMarkerStyle Members


CopyFrom(Object) Method

[image]
Intersoft WebGrid Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ChartMarkerStyle Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartMarkerStyle
Dim objSource As System.Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   System.object objSource
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartMarkerStyle Class
ChartMarkerStyle Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebGrid Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ChartMarkerStyle Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object, _
   ByVal cloneSourceValue As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartMarkerStyle
Dim objSource As System.Object
Dim cloneSourceValue As System.Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   System.object objSource,
   System.bool cloneSourceValue
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject;
    cloneSourceValue: System.Boolean
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object,
   cloneSourceValue : System.boolean
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource,
   System.bool cloneSourceValue
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource,
   System.bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartMarkerStyle Class
ChartMarkerStyle Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebGrid Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ChartMarkerStyle Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartMarkerStyle
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure DeSerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function DeSerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void DeSerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void DeSerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartMarkerStyle Class
ChartMarkerStyle Members


GetHashCode Method

[image]
Intersoft WebGrid Documentation
GetHashCode Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ChartMarkerStyle Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As ChartMarkerStyle
Dim value As System.Integer

value = instance.GetHashCode()
C#
public virtual System.int GetHashCode()
Delphi
public function GetHashCode(): System.Integer; virtual;
JScript
public function GetHashCode() : System.int;
Managed Extensions for C++
public: virtual System.int GetHashCode();
C++/CLI
public:
virtual System.int GetHashCode();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartMarkerStyle Class
ChartMarkerStyle Members


ChartMarkerStyle Class Methods

[image]
Intersoft WebGrid Documentation
ChartMarkerStyle Class Methods
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : ChartMarkerStyle Class

Glossary Item Box

For a list of all members of this type, see ChartMarkerStyle members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

ChartMarkerStyle Class
ISNet.WebUI.WebGrid Namespace


GetObjectData Method

[image]
Intersoft WebGrid Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ChartMarkerStyle Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=False,
   UnmanagedCode=False,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=True,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Action=SecurityAction.Demand,
   Unrestricted=False)>
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartMarkerStyle
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure GetObjectData(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
); override;
JScript
System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=,
   UnmanagedCode=,
   SkipVerification=,
   Execution=,
   ControlThread=,
   ControlEvidence=,
   ControlPolicy=,
   SerializationFormatter=,
   ControlDomainPolicy=,
   ControlPrincipal=,
   ControlAppDomain=,
   RemotingConfiguration=,
   Infrastructure=,
   BindingRedirects=,
   Action=SecurityAction.Demand,
   Unrestricted=)
public override function GetObjectData(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public: void GetObjectData(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
) override
C++/CLI
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public:
void GetObjectData(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
) override

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartMarkerStyle Class
ChartMarkerStyle Members


IsEmpty Method

[image]
Intersoft WebGrid Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ChartMarkerStyle Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As ChartMarkerStyle
Dim value As System.Boolean

value = instance.IsEmpty()
C#
public virtual System.bool IsEmpty()
Delphi
public function IsEmpty(): System.Boolean; virtual;
JScript
public function IsEmpty() : System.boolean;
Managed Extensions for C++
public: virtual System.bool IsEmpty();
C++/CLI
public:
virtual System.bool IsEmpty();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartMarkerStyle Class
ChartMarkerStyle Members


Reset Method

[image]
Intersoft WebGrid Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ChartMarkerStyle Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As ChartMarkerStyle

instance.Reset()
C#
public virtual void Reset()
Delphi
public procedure Reset(); virtual;
JScript
public function Reset();
Managed Extensions for C++
public: virtual void Reset();
C++/CLI
public:
virtual void Reset();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartMarkerStyle Class
ChartMarkerStyle Members


SerializeObjectData Method

[image]
Intersoft WebGrid Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ChartMarkerStyle Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartMarkerStyle
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure SerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function SerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void SerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void SerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartMarkerStyle Class
ChartMarkerStyle Members


ToString Method

[image]
Intersoft WebGrid Documentation
ToString Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ChartMarkerStyle Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As System.String
Visual Basic (Usage) Copy Code
Dim instance As ChartMarkerStyle
Dim value As System.String

value = instance.ToString()
C#
public virtual System.string ToString()
Delphi
public function ToString(): System.String; virtual;
JScript
public function ToString() : System.String;
Managed Extensions for C++
public: virtual System.string* ToString();
C++/CLI
public:
virtual System.String^ ToString();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartMarkerStyle Class
ChartMarkerStyle Members


ChartMarkerStyle Class Properties

[image]
Intersoft WebGrid Documentation
ChartMarkerStyle Class Properties
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : ChartMarkerStyle Class

Glossary Item Box

For a list of all members of this type, see ChartMarkerStyle members.

Public Properties

 | Name | Description
Public Property | AutoDepth |
Public Property | BorderStyle |
Public Property | Depth |
Public Property | FillStyle |
Public Property | Height |
Public Property | PointShape |
Public Property | VerticalAlign |
Public Property | Visible |
Public Property | Width |
Top

See Also

Reference

ChartMarkerStyle Class
ISNet.WebUI.WebGrid Namespace


ChartMarkerStyle Constructor

[image]
Intersoft WebGrid Documentation
ChartMarkerStyle Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ChartMarkerStyle Class : ChartMarkerStyle Constructor

Glossary Item Box

Overload List

Overload | Description
ChartMarkerStyle Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartMarkerStyle Class
ChartMarkerStyle Members


AutoDepth Property

[image]
Intersoft WebGrid Documentation
AutoDepth Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ChartMarkerStyle Class : AutoDepth Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("When set to true the component automatically determines the marker depth")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("General")>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property AutoDepth As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As ChartMarkerStyle
Dim value As System.Boolean

instance.AutoDepth = value

value = instance.AutoDepth
C#
[System.ComponentModel.DescriptionAttribute("When set to true the component automatically determines the marker depth")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public System.bool AutoDepth {get; set;}
Delphi
public read-write property AutoDepth: System.Boolean;
JScript
System.ComponentModel.DescriptionAttribute("When set to true the component automatically determines the marker depth")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("General")
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get,set AutoDepth : System.boolean
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("When set to true the component automatically determines the marker depth")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.bool get_AutoDepth();
public: __property void set_AutoDepth(
   System.bool value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("When set to true the component automatically determines the marker depth")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.bool AutoDepth {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartMarkerStyle Class
ChartMarkerStyle Members


BorderStyle Property

[image]
Intersoft WebGrid Documentation
BorderStyle Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ChartMarkerStyle Class : BorderStyle Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Gets or sets the stroke style applied to the data point markers")>
<ISNet.Serialization.BinarySerializableAttribute("setBorderStyle")>
<System.ComponentModel.DefaultValueAttribute()>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<System.ComponentModel.CategoryAttribute("Appearance")>
Public ReadOnly Property BorderStyle As ChartStrokeStyle
Visual Basic (Usage) Copy Code
Dim instance As ChartMarkerStyle
Dim value As ChartStrokeStyle

value = instance.BorderStyle
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the stroke style applied to the data point markers")]
[ISNet.Serialization.BinarySerializableAttribute("setBorderStyle")]
[System.ComponentModel.DefaultValueAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.CategoryAttribute("Appearance")]
public ChartStrokeStyle BorderStyle {get;}
Delphi
public read-only property BorderStyle: ChartStrokeStyle;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the stroke style applied to the data point markers")
ISNet.Serialization.BinarySerializableAttribute("setBorderStyle")
System.ComponentModel.DefaultValueAttribute()
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
System.ComponentModel.CategoryAttribute("Appearance")
public function get BorderStyle : ChartStrokeStyle
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the stroke style applied to the data point markers")]
[ISNet.Serialization.BinarySerializableAttribute("setBorderStyle")]
[System.ComponentModel.DefaultValueAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.CategoryAttribute("Appearance")]
public: __property ChartStrokeStyle* get_BorderStyle();
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the stroke style applied to the data point markers")]
[ISNet.Serialization.BinarySerializableAttribute("setBorderStyle")]
[System.ComponentModel.DefaultValueAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.CategoryAttribute("Appearance")]
public:
property ChartStrokeStyle^ BorderStyle {
   ChartStrokeStyle^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartMarkerStyle Class
ChartMarkerStyle Members


Depth Property

[image]
Intersoft WebGrid Documentation
Depth Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ChartMarkerStyle Class : Depth Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Controls the depth of the data point marker in model units if AutoDepth is set to false")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("General")>
Public Property Depth As System.Nullable(Of Single)
Visual Basic (Usage) Copy Code
Dim instance As ChartMarkerStyle
Dim value As System.Nullable(Of Single)

instance.Depth = value

value = instance.Depth
C#
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Controls the depth of the data point marker in model units if AutoDepth is set to false")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("General")]
public System.Nullable<float> Depth {get; set;}
Delphi
public read-write property Depth: System.Nullable;
JScript
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Controls the depth of the data point marker in model units if AutoDepth is set to false")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("General")
public function get,set Depth : System.Nullable
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Controls the depth of the data point marker in model units if AutoDepth is set to false")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("General")]
public: __property System.Nullable<float> get_Depth();
public: __property void set_Depth(
   System.Nullable<float> value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Controls the depth of the data point marker in model units if AutoDepth is set to false")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("General")]
public:
property System.Nullable<float> Depth {
   System.Nullable<float> get();
   void set (    System.Nullable<float> value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartMarkerStyle Class
ChartMarkerStyle Members


FillStyle Property

[image]
Intersoft WebGrid Documentation
FillStyle Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ChartMarkerStyle Class : FillStyle Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute("setFillStyle")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<System.ComponentModel.CategoryAttribute("Appearance")>
<System.ComponentModel.DescriptionAttribute("Gets or sets the fill style applied to the data point markers")>
Public ReadOnly Property FillStyle As ChartFillStyle
Visual Basic (Usage) Copy Code
Dim instance As ChartMarkerStyle
Dim value As ChartFillStyle

value = instance.FillStyle
C#
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute("setFillStyle")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the fill style applied to the data point markers")]
public ChartFillStyle FillStyle {get;}
Delphi
public read-only property FillStyle: ChartFillStyle;
JScript
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute("setFillStyle")
System.ComponentModel.NotifyParentPropertyAttribute()
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
System.ComponentModel.CategoryAttribute("Appearance")
System.ComponentModel.DescriptionAttribute("Gets or sets the fill style applied to the data point markers")
public function get FillStyle : ChartFillStyle
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute("setFillStyle")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the fill style applied to the data point markers")]
public: __property ChartFillStyle* get_FillStyle();
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute("setFillStyle")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the fill style applied to the data point markers")]
public:
property ChartFillStyle^ FillStyle {
   ChartFillStyle^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartMarkerStyle Class
ChartMarkerStyle Members


Height Property

[image]
Intersoft WebGrid Documentation
Height Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ChartMarkerStyle Class : Height Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("General")>
<System.ComponentModel.DescriptionAttribute("Controls the height of the data point marker in model units")>
Public Property Height As System.Nullable(Of Single)
Visual Basic (Usage) Copy Code
Dim instance As ChartMarkerStyle
Dim value As System.Nullable(Of Single)

instance.Height = value

value = instance.Height
C#
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DescriptionAttribute("Controls the height of the data point marker in model units")]
public System.Nullable<float> Height {get; set;}
Delphi
public read-write property Height: System.Nullable;
JScript
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("General")
System.ComponentModel.DescriptionAttribute("Controls the height of the data point marker in model units")
public function get,set Height : System.Nullable
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DescriptionAttribute("Controls the height of the data point marker in model units")]
public: __property System.Nullable<float> get_Height();
public: __property void set_Height(
   System.Nullable<float> value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DescriptionAttribute("Controls the height of the data point marker in model units")]
public:
property System.Nullable<float> Height {
   System.Nullable<float> get();
   void set (    System.Nullable<float> value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartMarkerStyle Class
ChartMarkerStyle Members


PointShape Property

[image]
Intersoft WebGrid Documentation
PointShape Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ChartMarkerStyle Class : PointShape Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Defines the style of the data point markers")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("General")>
Public Property PointShape As PointShape
Visual Basic (Usage) Copy Code
Dim instance As ChartMarkerStyle
Dim value As PointShape

instance.PointShape = value

value = instance.PointShape
C#
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Defines the style of the data point markers")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("General")]
public PointShape PointShape {get; set;}
Delphi
public read-write property PointShape: PointShape;
JScript
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Defines the style of the data point markers")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("General")
public function get,set PointShape : PointShape
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Defines the style of the data point markers")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("General")]
public: __property PointShape get_PointShape();
public: __property void set_PointShape(
   PointShape value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Defines the style of the data point markers")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("General")]
public:
property PointShape PointShape {
   PointShape get();
   void set (    PointShape value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartMarkerStyle Class
ChartMarkerStyle Members


VerticalAlign Property

[image]
Intersoft WebGrid Documentation
VerticalAlign Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ChartMarkerStyle Class : VerticalAlign Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Controls the vertical alignment of the data point markers")>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Alignment")>
Public Property VerticalAlign As VerticalAlign
Visual Basic (Usage) Copy Code
Dim instance As ChartMarkerStyle
Dim value As VerticalAlign

instance.VerticalAlign = value

value = instance.VerticalAlign
C#
[System.ComponentModel.DescriptionAttribute("Controls the vertical alignment of the data point markers")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Alignment")]
public VerticalAlign VerticalAlign {get; set;}
Delphi
public read-write property VerticalAlign: VerticalAlign;
JScript
System.ComponentModel.DescriptionAttribute("Controls the vertical alignment of the data point markers")
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Alignment")
public function get,set VerticalAlign : VerticalAlign
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Controls the vertical alignment of the data point markers")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Alignment")]
public: __property VerticalAlign get_VerticalAlign();
public: __property void set_VerticalAlign(
   VerticalAlign value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Controls the vertical alignment of the data point markers")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Alignment")]
public:
property VerticalAlign VerticalAlign {
   VerticalAlign get();
   void set (    VerticalAlign value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartMarkerStyle Class
ChartMarkerStyle Members


Visible Property

[image]
Intersoft WebGrid Documentation
Visible Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ChartMarkerStyle Class : Visible Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Controls the visibility of the data point markers")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("General")>
Public Property Visible As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As ChartMarkerStyle
Dim value As System.Boolean

instance.Visible = value

value = instance.Visible
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Controls the visibility of the data point markers")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("General")]
public System.bool Visible {get; set;}
Delphi
public read-write property Visible: System.Boolean;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Controls the visibility of the data point markers")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("General")
public function get,set Visible : System.boolean
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Controls the visibility of the data point markers")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("General")]
public: __property System.bool get_Visible();
public: __property void set_Visible(
   System.bool value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Controls the visibility of the data point markers")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("General")]
public:
property System.bool Visible {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartMarkerStyle Class
ChartMarkerStyle Members


Width Property

[image]
Intersoft WebGrid Documentation
Width Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ChartMarkerStyle Class : Width Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Controls the width of the data point marker in model units")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("General")>
Public Property Width As System.Nullable(Of Single)
Visual Basic (Usage) Copy Code
Dim instance As ChartMarkerStyle
Dim value As System.Nullable(Of Single)

instance.Width = value

value = instance.Width
C#
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Controls the width of the data point marker in model units")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("General")]
public System.Nullable<float> Width {get; set;}
Delphi
public read-write property Width: System.Nullable;
JScript
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Controls the width of the data point marker in model units")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("General")
public function get,set Width : System.Nullable
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Controls the width of the data point marker in model units")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("General")]
public: __property System.Nullable<float> get_Width();
public: __property void set_Width(
   System.Nullable<float> value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Controls the width of the data point marker in model units")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("General")]
public:
property System.Nullable<float> Width {
   System.Nullable<float> get();
   void set (    System.Nullable<float> value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartMarkerStyle Class
ChartMarkerStyle Members


ChartPivotConfig Class

[image]
Intersoft WebGrid Documentation
ChartPivotConfig Class
Members See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : ChartPivotConfig Class

Glossary Item Box

Object Model

ChartPivotConfig Class

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.SerializableAttribute()>
Public MustInherit Class ChartPivotConfig
   Inherits ISNet.WebUI.NamedObjectBase
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject
Visual Basic (Usage) Copy Code
Dim instance As ChartPivotConfig
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public abstract class ChartPivotConfig : ISNet.WebUI.NamedObjectBase, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject
Delphi
public class ChartPivotConfig = class(ISNet.WebUI.NamedObjectBase, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject)abstract;
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.SerializableAttribute()
public abstract class ChartPivotConfig extends ISNet.WebUI.NamedObjectBase implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public __gc abstract class ChartPivotConfig : public ISNet.WebUI.NamedObjectBase, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public ref class ChartPivotConfig abstract : public ISNet.WebUI.NamedObjectBase, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.NamedObjectBase
ISNet.WebUI.WebGrid.ChartPivotConfig
ISNet.WebUI.WebGrid.ChartPivotDataConfig
ISNet.WebUI.WebGrid.ChartPivotFilterConfig

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartPivotConfig Members
ISNet.WebUI.WebGrid Namespace


ChartPivotConfig Class Members

[image]
Intersoft WebGrid Documentation
ChartPivotConfig Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebGrid Namespace : ChartPivotConfig Class

Glossary Item Box

The following tables list the members exposed by ChartPivotConfig.

Public Properties

 | Name | Description
Public Property | DataMember |
Public Property | DataType |
Public Property | Name | Overridden.
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

ChartPivotConfig Class
ISNet.WebUI.WebGrid Namespace


ChartPivotConfig Class Methods

[image]
Intersoft WebGrid Documentation
ChartPivotConfig Class Methods
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : ChartPivotConfig Class

Glossary Item Box

For a list of all members of this type, see ChartPivotConfig members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

ChartPivotConfig Class
ISNet.WebUI.WebGrid Namespace


GetObjectData Method

[image]
Intersoft WebGrid Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ChartPivotConfig Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=False,
   UnmanagedCode=False,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=True,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Action=SecurityAction.Demand,
   Unrestricted=False)>
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartPivotConfig
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure GetObjectData(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
); override;
JScript
System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=,
   UnmanagedCode=,
   SkipVerification=,
   Execution=,
   ControlThread=,
   ControlEvidence=,
   ControlPolicy=,
   SerializationFormatter=,
   ControlDomainPolicy=,
   ControlPrincipal=,
   ControlAppDomain=,
   RemotingConfiguration=,
   Infrastructure=,
   BindingRedirects=,
   Action=SecurityAction.Demand,
   Unrestricted=)
public override function GetObjectData(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public: void GetObjectData(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
) override
C++/CLI
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public:
void GetObjectData(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
) override

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartPivotConfig Class
ChartPivotConfig Members


IsEmpty Method

[image]
Intersoft WebGrid Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ChartPivotConfig Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As ChartPivotConfig
Dim value As System.Boolean

value = instance.IsEmpty()
C#
public virtual System.bool IsEmpty()
Delphi
public function IsEmpty(): System.Boolean; virtual;
JScript
public function IsEmpty() : System.boolean;
Managed Extensions for C++
public: virtual System.bool IsEmpty();
C++/CLI
public:
virtual System.bool IsEmpty();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartPivotConfig Class
ChartPivotConfig Members


Reset Method

[image]
Intersoft WebGrid Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ChartPivotConfig Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As ChartPivotConfig

instance.Reset()
C#
public virtual void Reset()
Delphi
public procedure Reset(); virtual;
JScript
public function Reset();
Managed Extensions for C++
public: virtual void Reset();
C++/CLI
public:
virtual void Reset();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartPivotConfig Class
ChartPivotConfig Members


SerializeObjectData Method

[image]
Intersoft WebGrid Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ChartPivotConfig Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartPivotConfig
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure SerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function SerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void SerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void SerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartPivotConfig Class
ChartPivotConfig Members


ToString Method

[image]
Intersoft WebGrid Documentation
ToString Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ChartPivotConfig Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As System.String
Visual Basic (Usage) Copy Code
Dim instance As ChartPivotConfig
Dim value As System.String

value = instance.ToString()
C#
public virtual System.string ToString()
Delphi
public function ToString(): System.String; virtual;
JScript
public function ToString() : System.String;
Managed Extensions for C++
public: virtual System.string* ToString();
C++/CLI
public:
virtual System.String^ ToString();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartPivotConfig Class
ChartPivotConfig Members


ChartPivotConfig Class Properties

[image]
Intersoft WebGrid Documentation
ChartPivotConfig Class Properties
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : ChartPivotConfig Class

Glossary Item Box

For a list of all members of this type, see ChartPivotConfig members.

Public Properties

 | Name | Description
Public Property | DataMember |
Public Property | DataType |
Public Property | Name | Overridden.
Top

See Also

Reference

ChartPivotConfig Class
ISNet.WebUI.WebGrid Namespace


Clone Method

[image]
Intersoft WebGrid Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ChartPivotConfig Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As System.Object
Visual Basic (Usage) Copy Code
Dim instance As ChartPivotConfig
Dim value As System.Object

value = instance.Clone()
C#
public virtual System.object Clone()
Delphi
public function Clone(): System.TObject; virtual;
JScript
public function Clone() : System.Object;
Managed Extensions for C++
public: virtual System.Object* Clone();
C++/CLI
public:
virtual System.Object^ Clone();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartPivotConfig Class
ChartPivotConfig Members


CopyFrom Method

[image]
Intersoft WebGrid Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ChartPivotConfig Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartPivotConfig Class
ChartPivotConfig Members


CopyFrom(Object) Method

[image]
Intersoft WebGrid Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ChartPivotConfig Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartPivotConfig
Dim objSource As System.Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   System.object objSource
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartPivotConfig Class
ChartPivotConfig Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebGrid Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ChartPivotConfig Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object, _
   ByVal cloneSourceValue As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartPivotConfig
Dim objSource As System.Object
Dim cloneSourceValue As System.Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   System.object objSource,
   System.bool cloneSourceValue
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject;
    cloneSourceValue: System.Boolean
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object,
   cloneSourceValue : System.boolean
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource,
   System.bool cloneSourceValue
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource,
   System.bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartPivotConfig Class
ChartPivotConfig Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebGrid Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ChartPivotConfig Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartPivotConfig
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure DeSerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function DeSerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void DeSerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void DeSerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartPivotConfig Class
ChartPivotConfig Members


GetHashCode Method

[image]
Intersoft WebGrid Documentation
GetHashCode Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ChartPivotConfig Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As ChartPivotConfig
Dim value As System.Integer

value = instance.GetHashCode()
C#
public virtual System.int GetHashCode()
Delphi
public function GetHashCode(): System.Integer; virtual;
JScript
public function GetHashCode() : System.int;
Managed Extensions for C++
public: virtual System.int GetHashCode();
C++/CLI
public:
virtual System.int GetHashCode();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartPivotConfig Class
ChartPivotConfig Members


DataMember Property

[image]
Intersoft WebGrid Documentation
DataMember Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ChartPivotConfig Class : DataMember Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("DataMember of the Pivot object.")>
<System.ComponentModel.CategoryAttribute("General")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property DataMember As System.String
Visual Basic (Usage) Copy Code
Dim instance As ChartPivotConfig
Dim value As System.String

instance.DataMember = value

value = instance.DataMember
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("DataMember of the Pivot object.")]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DefaultValueAttribute()]
public System.string DataMember {get; set;}
Delphi
public read-write property DataMember: System.String;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DescriptionAttribute("DataMember of the Pivot object.")
System.ComponentModel.CategoryAttribute("General")
System.ComponentModel.DefaultValueAttribute()
public function get,set DataMember : System.String
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("DataMember of the Pivot object.")]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.string* get_DataMember();
public: __property void set_DataMember(
   System.string* value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("DataMember of the Pivot object.")]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.String^ DataMember {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartPivotConfig Class
ChartPivotConfig Members


DataType Property

[image]
Intersoft WebGrid Documentation
DataType Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ChartPivotConfig Class : DataType Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("General")>
<System.ComponentModel.DescriptionAttribute("DataType of the Pivot object.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property DataType As System.String
Visual Basic (Usage) Copy Code
Dim instance As ChartPivotConfig
Dim value As System.String

instance.DataType = value

value = instance.DataType
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DescriptionAttribute("DataType of the Pivot object.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.string DataType {get; set;}
Delphi
public read-write property DataType: System.String;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("General")
System.ComponentModel.DescriptionAttribute("DataType of the Pivot object.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set DataType : System.String
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DescriptionAttribute("DataType of the Pivot object.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.string* get_DataType();
public: __property void set_DataType(
   System.string* value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DescriptionAttribute("DataType of the Pivot object.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.String^ DataType {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartPivotConfig Class
ChartPivotConfig Members


Name Property

[image]
Intersoft WebGrid Documentation
Name Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ChartPivotConfig Class : Name Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Name.")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("General")>
Public Overrides Property Name As System.String
Visual Basic (Usage) Copy Code
Dim instance As ChartPivotConfig
Dim value As System.String

instance.Name = value

value = instance.Name
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Name.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
public override System.string Name {get; set;}
Delphi
public read-write property Name: System.String; override;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DescriptionAttribute("Name.")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("General")
public override function get,set Name : System.String
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Name.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
public: __property System.string* get_Name() override;
public: __property void set_Name(
   System.string* value
) override;
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Name.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
public:
property System.String^ Name {
   System.String^ get() override;
   void set (    System.String^ value) override;
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartPivotConfig Class
ChartPivotConfig Members


ChartPivotDataConfig Class

[image]
Intersoft WebGrid Documentation
ChartPivotDataConfig Class
Members See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : ChartPivotDataConfig Class

Glossary Item Box

Object Model

ChartPivotDataConfig Class

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.SerializableAttribute()>
Public Class ChartPivotDataConfig
   Inherits ChartPivotConfig
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject
Visual Basic (Usage) Copy Code
Dim instance As ChartPivotDataConfig
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public class ChartPivotDataConfig : ChartPivotConfig, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject
Delphi
public class ChartPivotDataConfig = class(ChartPivotConfig, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject)
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.SerializableAttribute()
public class ChartPivotDataConfig extends ChartPivotConfig implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public __gc class ChartPivotDataConfig : public ChartPivotConfig, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public ref class ChartPivotDataConfig : public ChartPivotConfig, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.NamedObjectBase
ISNet.WebUI.WebGrid.ChartPivotConfig
ISNet.WebUI.WebGrid.ChartPivotDataConfig

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartPivotDataConfig Members
ISNet.WebUI.WebGrid Namespace


ChartPivotDataConfig Class Members

[image]
Intersoft WebGrid Documentation
ChartPivotDataConfig Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebGrid Namespace : ChartPivotDataConfig Class

Glossary Item Box

The following tables list the members exposed by ChartPivotDataConfig.

Public Constructors

 | Name | Description
Public Constructor | ChartPivotDataConfig Constructor |
Top

Public Properties

 | Name | Description
Public Property | AutoCalc |
Public Property | DataMember | (Inherited from ISNet.WebUI.WebGrid.ChartPivotConfig)
Public Property | DataType | (Inherited from ISNet.WebUI.WebGrid.ChartPivotConfig)
Public Property | Name | (Inherited from ISNet.WebUI.WebGrid.ChartPivotConfig)
Public Property | Text |
Public Property | Type |
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

ChartPivotDataConfig Class
ISNet.WebUI.WebGrid Namespace


ChartPivotDataConfig Constructor

[image]
Intersoft WebGrid Documentation
ChartPivotDataConfig Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ChartPivotDataConfig Class : ChartPivotDataConfig Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New ChartPivotDataConfig()
C#
public ChartPivotDataConfig()
Delphi
public ChartPivotDataConfig();
JScript
public function ChartPivotDataConfig();
Managed Extensions for C++
public: ChartPivotDataConfig();
C++/CLI
public:
ChartPivotDataConfig();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartPivotDataConfig Class
ChartPivotDataConfig Members


Clone Method

[image]
Intersoft WebGrid Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ChartPivotDataConfig Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As System.Object
Visual Basic (Usage) Copy Code
Dim instance As ChartPivotDataConfig
Dim value As System.Object

value = instance.Clone()
C#
public virtual System.object Clone()
Delphi
public function Clone(): System.TObject; virtual;
JScript
public function Clone() : System.Object;
Managed Extensions for C++
public: virtual System.Object* Clone();
C++/CLI
public:
virtual System.Object^ Clone();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartPivotDataConfig Class
ChartPivotDataConfig Members


CopyFrom Method

[image]
Intersoft WebGrid Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ChartPivotDataConfig Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartPivotDataConfig Class
ChartPivotDataConfig Members


CopyFrom(Object) Method

[image]
Intersoft WebGrid Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ChartPivotDataConfig Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartPivotDataConfig
Dim objSource As System.Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   System.object objSource
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartPivotDataConfig Class
ChartPivotDataConfig Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebGrid Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ChartPivotDataConfig Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object, _
   ByVal cloneSourceValue As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartPivotDataConfig
Dim objSource As System.Object
Dim cloneSourceValue As System.Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   System.object objSource,
   System.bool cloneSourceValue
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject;
    cloneSourceValue: System.Boolean
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object,
   cloneSourceValue : System.boolean
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource,
   System.bool cloneSourceValue
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource,
   System.bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartPivotDataConfig Class
ChartPivotDataConfig Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebGrid Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ChartPivotDataConfig Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartPivotDataConfig
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure DeSerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function DeSerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void DeSerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void DeSerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartPivotDataConfig Class
ChartPivotDataConfig Members


GetHashCode Method

[image]
Intersoft WebGrid Documentation
GetHashCode Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ChartPivotDataConfig Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As ChartPivotDataConfig
Dim value As System.Integer

value = instance.GetHashCode()
C#
public virtual System.int GetHashCode()
Delphi
public function GetHashCode(): System.Integer; virtual;
JScript
public function GetHashCode() : System.int;
Managed Extensions for C++
public: virtual System.int GetHashCode();
C++/CLI
public:
virtual System.int GetHashCode();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartPivotDataConfig Class
ChartPivotDataConfig Members


ChartPivotDataConfig Class Methods

[image]
Intersoft WebGrid Documentation
ChartPivotDataConfig Class Methods
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : ChartPivotDataConfig Class

Glossary Item Box

For a list of all members of this type, see ChartPivotDataConfig members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

ChartPivotDataConfig Class
ISNet.WebUI.WebGrid Namespace


GetObjectData Method

[image]
Intersoft WebGrid Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ChartPivotDataConfig Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=False,
   UnmanagedCode=False,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=True,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Action=SecurityAction.Demand,
   Unrestricted=False)>
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartPivotDataConfig
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure GetObjectData(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
); override;
JScript
System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=,
   UnmanagedCode=,
   SkipVerification=,
   Execution=,
   ControlThread=,
   ControlEvidence=,
   ControlPolicy=,
   SerializationFormatter=,
   ControlDomainPolicy=,
   ControlPrincipal=,
   ControlAppDomain=,
   RemotingConfiguration=,
   Infrastructure=,
   BindingRedirects=,
   Action=SecurityAction.Demand,
   Unrestricted=)
public override function GetObjectData(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public: void GetObjectData(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
) override
C++/CLI
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public:
void GetObjectData(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
) override

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartPivotDataConfig Class
ChartPivotDataConfig Members


IsEmpty Method

[image]
Intersoft WebGrid Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ChartPivotDataConfig Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As ChartPivotDataConfig
Dim value As System.Boolean

value = instance.IsEmpty()
C#
public virtual System.bool IsEmpty()
Delphi
public function IsEmpty(): System.Boolean; virtual;
JScript
public function IsEmpty() : System.boolean;
Managed Extensions for C++
public: virtual System.bool IsEmpty();
C++/CLI
public:
virtual System.bool IsEmpty();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartPivotDataConfig Class
ChartPivotDataConfig Members


Reset Method

[image]
Intersoft WebGrid Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ChartPivotDataConfig Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As ChartPivotDataConfig

instance.Reset()
C#
public virtual void Reset()
Delphi
public procedure Reset(); virtual;
JScript
public function Reset();
Managed Extensions for C++
public: virtual void Reset();
C++/CLI
public:
virtual void Reset();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartPivotDataConfig Class
ChartPivotDataConfig Members


SerializeObjectData Method

[image]
Intersoft WebGrid Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ChartPivotDataConfig Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartPivotDataConfig
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure SerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function SerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void SerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void SerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartPivotDataConfig Class
ChartPivotDataConfig Members


ToString Method

[image]
Intersoft WebGrid Documentation
ToString Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ChartPivotDataConfig Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As System.String
Visual Basic (Usage) Copy Code
Dim instance As ChartPivotDataConfig
Dim value As System.String

value = instance.ToString()
C#
public virtual System.string ToString()
Delphi
public function ToString(): System.String; virtual;
JScript
public function ToString() : System.String;
Managed Extensions for C++
public: virtual System.string* ToString();
C++/CLI
public:
virtual System.String^ ToString();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartPivotDataConfig Class
ChartPivotDataConfig Members


ChartPivotDataConfig Class Properties

[image]
Intersoft WebGrid Documentation
ChartPivotDataConfig Class Properties
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : ChartPivotDataConfig Class

Glossary Item Box

For a list of all members of this type, see ChartPivotDataConfig members.

Public Properties

 | Name | Description
Public Property | AutoCalc |
Public Property | DataMember | (Inherited from ISNet.WebUI.WebGrid.ChartPivotConfig)
Public Property | DataType | (Inherited from ISNet.WebUI.WebGrid.ChartPivotConfig)
Public Property | Name | (Inherited from ISNet.WebUI.WebGrid.ChartPivotConfig)
Public Property | Text |
Public Property | Type |
Top

See Also

Reference

ChartPivotDataConfig Class
ISNet.WebUI.WebGrid Namespace


ChartPivotDataConfig Constructor

[image]
Intersoft WebGrid Documentation
ChartPivotDataConfig Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ChartPivotDataConfig Class : ChartPivotDataConfig Constructor

Glossary Item Box

Overload List

Overload | Description
ChartPivotDataConfig Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartPivotDataConfig Class
ChartPivotDataConfig Members


AutoCalc Property

[image]
Intersoft WebGrid Documentation
AutoCalc Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ChartPivotDataConfig Class : AutoCalc Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("AutoCalc value used for the data aggregation.")>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("General")>
Public Property AutoCalc As AutoCalc
Visual Basic (Usage) Copy Code
Dim instance As ChartPivotDataConfig
Dim value As AutoCalc

instance.AutoCalc = value

value = instance.AutoCalc
C#
[System.ComponentModel.DescriptionAttribute("AutoCalc value used for the data aggregation.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("General")]
public AutoCalc AutoCalc {get; set;}
Delphi
public read-write property AutoCalc: AutoCalc;
JScript
System.ComponentModel.DescriptionAttribute("AutoCalc value used for the data aggregation.")
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("General")
public function get,set AutoCalc : AutoCalc
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("AutoCalc value used for the data aggregation.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("General")]
public: __property AutoCalc get_AutoCalc();
public: __property void set_AutoCalc(
   AutoCalc value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("AutoCalc value used for the data aggregation.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("General")]
public:
property AutoCalc AutoCalc {
   AutoCalc get();
   void set (    AutoCalc value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartPivotDataConfig Class
ChartPivotDataConfig Members


Text Property

[image]
Intersoft WebGrid Documentation
Text Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ChartPivotDataConfig Class : Text Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Text of pivot data")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("General")>
Public ReadOnly Property Text As System.String
Visual Basic (Usage) Copy Code
Dim instance As ChartPivotDataConfig
Dim value As System.String

value = instance.Text
C#
[System.ComponentModel.DescriptionAttribute("Text of pivot data")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("General")]
public System.string Text {get;}
Delphi
public read-only property Text: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Text of pivot data")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("General")
public function get Text : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Text of pivot data")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("General")]
public: __property System.string* get_Text();
C++/CLI
[System.ComponentModel.DescriptionAttribute("Text of pivot data")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("General")]
public:
property System.String^ Text {
   System.String^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartPivotDataConfig Class
ChartPivotDataConfig Members


Type Property

[image]
Intersoft WebGrid Documentation
Type Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ChartPivotDataConfig Class : Type Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Type of pivot data")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("General")>
Public Property Type As PivotDataType
Visual Basic (Usage) Copy Code
Dim instance As ChartPivotDataConfig
Dim value As PivotDataType

instance.Type = value

value = instance.Type
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Type of pivot data")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("General")]
public PivotDataType Type {get; set;}
Delphi
public read-write property Type: PivotDataType;
JScript
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Type of pivot data")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("General")
public function get,set Type : PivotDataType
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Type of pivot data")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("General")]
public: __property PivotDataType get_Type();
public: __property void set_Type(
   PivotDataType value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Type of pivot data")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("General")]
public:
property PivotDataType Type {
   PivotDataType get();
   void set (    PivotDataType value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartPivotDataConfig Class
ChartPivotDataConfig Members


ChartPivotFilterConfig Class

[image]
Intersoft WebGrid Documentation
ChartPivotFilterConfig Class
Members See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : ChartPivotFilterConfig Class

Glossary Item Box

Object Model

ChartPivotFilterConfig Class

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.SerializableAttribute()>
Public Class ChartPivotFilterConfig
   Inherits ChartPivotConfig
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject
Visual Basic (Usage) Copy Code
Dim instance As ChartPivotFilterConfig
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public class ChartPivotFilterConfig : ChartPivotConfig, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject
Delphi
public class ChartPivotFilterConfig = class(ChartPivotConfig, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject)
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.SerializableAttribute()
public class ChartPivotFilterConfig extends ChartPivotConfig implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public __gc class ChartPivotFilterConfig : public ChartPivotConfig, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public ref class ChartPivotFilterConfig : public ChartPivotConfig, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.NamedObjectBase
ISNet.WebUI.WebGrid.ChartPivotConfig
ISNet.WebUI.WebGrid.ChartPivotFilterConfig

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartPivotFilterConfig Members
ISNet.WebUI.WebGrid Namespace


ChartPivotFilterConfig Class Members

[image]
Intersoft WebGrid Documentation
ChartPivotFilterConfig Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebGrid Namespace : ChartPivotFilterConfig Class

Glossary Item Box

The following tables list the members exposed by ChartPivotFilterConfig.

Public Constructors

 | Name | Description
Public Constructor | ChartPivotFilterConfig Constructor |
Top

Public Properties

 | Name | Description
Public Property | DataMember |
Public Property | DataType | (Inherited from ISNet.WebUI.WebGrid.ChartPivotConfig)
Public Property | DateFormat |
Public Property | DateInterval |
Public Property | FilterCriterias |
Public Property | FilterExpression |
Public Property | Name | (Inherited from ISNet.WebUI.WebGrid.ChartPivotConfig)
Public Property | PivotType |
Public Property | SortOrder |
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

ChartPivotFilterConfig Class
ISNet.WebUI.WebGrid Namespace


ChartPivotFilterConfig Constructor

[image]
Intersoft WebGrid Documentation
ChartPivotFilterConfig Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ChartPivotFilterConfig Class : ChartPivotFilterConfig Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New ChartPivotFilterConfig()
C#
public ChartPivotFilterConfig()
Delphi
public ChartPivotFilterConfig();
JScript
public function ChartPivotFilterConfig();
Managed Extensions for C++
public: ChartPivotFilterConfig();
C++/CLI
public:
ChartPivotFilterConfig();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartPivotFilterConfig Class
ChartPivotFilterConfig Members


Clone Method

[image]
Intersoft WebGrid Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ChartPivotFilterConfig Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As System.Object
Visual Basic (Usage) Copy Code
Dim instance As ChartPivotFilterConfig
Dim value As System.Object

value = instance.Clone()
C#
public virtual System.object Clone()
Delphi
public function Clone(): System.TObject; virtual;
JScript
public function Clone() : System.Object;
Managed Extensions for C++
public: virtual System.Object* Clone();
C++/CLI
public:
virtual System.Object^ Clone();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartPivotFilterConfig Class
ChartPivotFilterConfig Members


CopyFrom Method

[image]
Intersoft WebGrid Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ChartPivotFilterConfig Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartPivotFilterConfig Class
ChartPivotFilterConfig Members


CopyFrom(Object) Method

[image]
Intersoft WebGrid Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ChartPivotFilterConfig Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartPivotFilterConfig
Dim objSource As System.Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   System.object objSource
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartPivotFilterConfig Class
ChartPivotFilterConfig Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebGrid Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ChartPivotFilterConfig Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object, _
   ByVal cloneSourceValue As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartPivotFilterConfig
Dim objSource As System.Object
Dim cloneSourceValue As System.Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   System.object objSource,
   System.bool cloneSourceValue
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject;
    cloneSourceValue: System.Boolean
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object,
   cloneSourceValue : System.boolean
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource,
   System.bool cloneSourceValue
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource,
   System.bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartPivotFilterConfig Class
ChartPivotFilterConfig Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebGrid Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ChartPivotFilterConfig Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartPivotFilterConfig
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure DeSerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function DeSerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void DeSerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void DeSerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartPivotFilterConfig Class
ChartPivotFilterConfig Members


GetHashCode Method

[image]
Intersoft WebGrid Documentation
GetHashCode Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ChartPivotFilterConfig Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As ChartPivotFilterConfig
Dim value As System.Integer

value = instance.GetHashCode()
C#
public virtual System.int GetHashCode()
Delphi
public function GetHashCode(): System.Integer; virtual;
JScript
public function GetHashCode() : System.int;
Managed Extensions for C++
public: virtual System.int GetHashCode();
C++/CLI
public:
virtual System.int GetHashCode();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartPivotFilterConfig Class
ChartPivotFilterConfig Members


ChartPivotFilterConfig Class Methods

[image]
Intersoft WebGrid Documentation
ChartPivotFilterConfig Class Methods
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : ChartPivotFilterConfig Class

Glossary Item Box

For a list of all members of this type, see ChartPivotFilterConfig members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

ChartPivotFilterConfig Class
ISNet.WebUI.WebGrid Namespace


GetObjectData Method

[image]
Intersoft WebGrid Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ChartPivotFilterConfig Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=False,
   UnmanagedCode=False,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=True,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Action=SecurityAction.Demand,
   Unrestricted=False)>
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartPivotFilterConfig
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure GetObjectData(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
); override;
JScript
System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=,
   UnmanagedCode=,
   SkipVerification=,
   Execution=,
   ControlThread=,
   ControlEvidence=,
   ControlPolicy=,
   SerializationFormatter=,
   ControlDomainPolicy=,
   ControlPrincipal=,
   ControlAppDomain=,
   RemotingConfiguration=,
   Infrastructure=,
   BindingRedirects=,
   Action=SecurityAction.Demand,
   Unrestricted=)
public override function GetObjectData(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public: void GetObjectData(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
) override
C++/CLI
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public:
void GetObjectData(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
) override

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartPivotFilterConfig Class
ChartPivotFilterConfig Members


IsEmpty Method

[image]
Intersoft WebGrid Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ChartPivotFilterConfig Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As ChartPivotFilterConfig
Dim value As System.Boolean

value = instance.IsEmpty()
C#
public virtual System.bool IsEmpty()
Delphi
public function IsEmpty(): System.Boolean; virtual;
JScript
public function IsEmpty() : System.boolean;
Managed Extensions for C++
public: virtual System.bool IsEmpty();
C++/CLI
public:
virtual System.bool IsEmpty();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartPivotFilterConfig Class
ChartPivotFilterConfig Members


Reset Method

[image]
Intersoft WebGrid Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ChartPivotFilterConfig Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As ChartPivotFilterConfig

instance.Reset()
C#
public virtual void Reset()
Delphi
public procedure Reset(); virtual;
JScript
public function Reset();
Managed Extensions for C++
public: virtual void Reset();
C++/CLI
public:
virtual void Reset();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartPivotFilterConfig Class
ChartPivotFilterConfig Members


SerializeObjectData Method

[image]
Intersoft WebGrid Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ChartPivotFilterConfig Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartPivotFilterConfig
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure SerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function SerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void SerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void SerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartPivotFilterConfig Class
ChartPivotFilterConfig Members


ToString Method

[image]
Intersoft WebGrid Documentation
ToString Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ChartPivotFilterConfig Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As System.String
Visual Basic (Usage) Copy Code
Dim instance As ChartPivotFilterConfig
Dim value As System.String

value = instance.ToString()
C#
public virtual System.string ToString()
Delphi
public function ToString(): System.String; virtual;
JScript
public function ToString() : System.String;
Managed Extensions for C++
public: virtual System.string* ToString();
C++/CLI
public:
virtual System.String^ ToString();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartPivotFilterConfig Class
ChartPivotFilterConfig Members


ChartPivotFilterConfig Class Properties

[image]
Intersoft WebGrid Documentation
ChartPivotFilterConfig Class Properties
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : ChartPivotFilterConfig Class

Glossary Item Box

For a list of all members of this type, see ChartPivotFilterConfig members.

Public Properties

 | Name | Description
Public Property | DataMember |
Public Property | DataType | (Inherited from ISNet.WebUI.WebGrid.ChartPivotConfig)
Public Property | DateFormat |
Public Property | DateInterval |
Public Property | FilterCriterias |
Public Property | FilterExpression |
Public Property | Name | (Inherited from ISNet.WebUI.WebGrid.ChartPivotConfig)
Public Property | PivotType |
Public Property | SortOrder |
Top

See Also

Reference

ChartPivotFilterConfig Class
ISNet.WebUI.WebGrid Namespace


ChartPivotFilterConfig Constructor

[image]
Intersoft WebGrid Documentation
ChartPivotFilterConfig Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ChartPivotFilterConfig Class : ChartPivotFilterConfig Constructor

Glossary Item Box

Overload List

Overload | Description
ChartPivotFilterConfig Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartPivotFilterConfig Class
ChartPivotFilterConfig Members


DataMember Property

[image]
Intersoft WebGrid Documentation
DataMember Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ChartPivotFilterConfig Class : DataMember Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("DataMember of the Pivot object.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("General")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Shadows Property DataMember As System.String
Visual Basic (Usage) Copy Code
Dim instance As ChartPivotFilterConfig
Dim value As System.String

instance.DataMember = value

value = instance.DataMember
C#
[System.ComponentModel.DescriptionAttribute("DataMember of the Pivot object.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public new System.string DataMember {get; set;}
Delphi
public read-write property DataMember: System.String;
JScript
System.ComponentModel.DescriptionAttribute("DataMember of the Pivot object.")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("General")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public hide function get,set DataMember : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("DataMember of the Pivot object.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property new System.string* get_DataMember();
public: __property new void set_DataMember(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("DataMember of the Pivot object.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
new property System.String^ DataMember {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartPivotFilterConfig Class
ChartPivotFilterConfig Members


DateFormat Property

[image]
Intersoft WebGrid Documentation
DateFormat Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ChartPivotFilterConfig Class : DateFormat Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Format the date with custom format. This will override the pre-defined formatting.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("General")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property DateFormat As System.String
Visual Basic (Usage) Copy Code
Dim instance As ChartPivotFilterConfig
Dim value As System.String

instance.DateFormat = value

value = instance.DateFormat
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Format the date with custom format. This will override the pre-defined formatting.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.string DateFormat {get; set;}
Delphi
public read-write property DateFormat: System.String;
JScript
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Format the date with custom format. This will override the pre-defined formatting.")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("General")
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set DateFormat : System.String
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Format the date with custom format. This will override the pre-defined formatting.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.string* get_DateFormat();
public: __property void set_DateFormat(
   System.string* value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Format the date with custom format. This will override the pre-defined formatting.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.String^ DateFormat {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartPivotFilterConfig Class
ChartPivotFilterConfig Members


DateInterval Property

[image]
Intersoft WebGrid Documentation
DateInterval Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ChartPivotFilterConfig Class : DateInterval Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Type of Date Interval. Applicable for DateTime data type.")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("General")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property DateInterval As DateInterval
Visual Basic (Usage) Copy Code
Dim instance As ChartPivotFilterConfig
Dim value As DateInterval

instance.DateInterval = value

value = instance.DateInterval
C#
[System.ComponentModel.DescriptionAttribute("Type of Date Interval. Applicable for DateTime data type.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public DateInterval DateInterval {get; set;}
Delphi
public read-write property DateInterval: DateInterval;
JScript
System.ComponentModel.DescriptionAttribute("Type of Date Interval. Applicable for DateTime data type.")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("General")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set DateInterval : DateInterval
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Type of Date Interval. Applicable for DateTime data type.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property DateInterval get_DateInterval();
public: __property void set_DateInterval(
   DateInterval value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Type of Date Interval. Applicable for DateTime data type.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property DateInterval DateInterval {
   DateInterval get();
   void set (    DateInterval value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartPivotFilterConfig Class
ChartPivotFilterConfig Members


FilterCriterias Property

[image]
Intersoft WebGrid Documentation
FilterCriterias Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ChartPivotFilterConfig Class : FilterCriterias Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("General")>
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Filter Criterias that applied for the data processing. The value is a comma separated value used for DateTime filtering purpose when PivotType is set to ByMonth / ByWeek.")>
Public Property FilterCriterias As System.String
Visual Basic (Usage) Copy Code
Dim instance As ChartPivotFilterConfig
Dim value As System.String

instance.FilterCriterias = value

value = instance.FilterCriterias
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Filter Criterias that applied for the data processing. The value is a comma separated value used for DateTime filtering purpose when PivotType is set to ByMonth / ByWeek.")]
public System.string FilterCriterias {get; set;}
Delphi
public read-write property FilterCriterias: System.String;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("General")
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DescriptionAttribute("Filter Criterias that applied for the data processing. The value is a comma separated value used for DateTime filtering purpose when PivotType is set to ByMonth / ByWeek.")
public function get,set FilterCriterias : System.String
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Filter Criterias that applied for the data processing. The value is a comma separated value used for DateTime filtering purpose when PivotType is set to ByMonth / ByWeek.")]
public: __property System.string* get_FilterCriterias();
public: __property void set_FilterCriterias(
   System.string* value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Filter Criterias that applied for the data processing. The value is a comma separated value used for DateTime filtering purpose when PivotType is set to ByMonth / ByWeek.")]
public:
property System.String^ FilterCriterias {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartPivotFilterConfig Class
ChartPivotFilterConfig Members


FilterExpression Property

[image]
Intersoft WebGrid Documentation
FilterExpression Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ChartPivotFilterConfig Class : FilterExpression Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Filter Expression that applied for the data processing.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("General")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property FilterExpression As System.String
Visual Basic (Usage) Copy Code
Dim instance As ChartPivotFilterConfig
Dim value As System.String

instance.FilterExpression = value

value = instance.FilterExpression
C#
[System.ComponentModel.DescriptionAttribute("Filter Expression that applied for the data processing.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DefaultValueAttribute()]
public System.string FilterExpression {get; set;}
Delphi
public read-write property FilterExpression: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Filter Expression that applied for the data processing.")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("General")
System.ComponentModel.DefaultValueAttribute()
public function get,set FilterExpression : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Filter Expression that applied for the data processing.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.string* get_FilterExpression();
public: __property void set_FilterExpression(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Filter Expression that applied for the data processing.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.String^ FilterExpression {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartPivotFilterConfig Class
ChartPivotFilterConfig Members


PivotType Property

[image]
Intersoft WebGrid Documentation
PivotType Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ChartPivotFilterConfig Class : PivotType Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Type of Pivot Filter")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("General")>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Property PivotType As PivotType
Visual Basic (Usage) Copy Code
Dim instance As ChartPivotFilterConfig
Dim value As PivotType

instance.PivotType = value

value = instance.PivotType
C#
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Type of Pivot Filter")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[ISNet.Serialization.XmlSerializableAttribute()]
public PivotType PivotType {get; set;}
Delphi
public read-write property PivotType: PivotType;
JScript
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Type of Pivot Filter")
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("General")
ISNet.Serialization.XmlSerializableAttribute()
public function get,set PivotType : PivotType
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Type of Pivot Filter")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property PivotType get_PivotType();
public: __property void set_PivotType(
   PivotType value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Type of Pivot Filter")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property PivotType PivotType {
   PivotType get();
   void set (    PivotType value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartPivotFilterConfig Class
ChartPivotFilterConfig Members


SortOrder Property

[image]
Intersoft WebGrid Documentation
SortOrder Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ChartPivotFilterConfig Class : SortOrder Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("General")>
<System.ComponentModel.DescriptionAttribute("Sort order that applied for the data processing.")>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Property SortOrder As SortOrder
Visual Basic (Usage) Copy Code
Dim instance As ChartPivotFilterConfig
Dim value As SortOrder

instance.SortOrder = value

value = instance.SortOrder
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DescriptionAttribute("Sort order that applied for the data processing.")]
[ISNet.Serialization.XmlSerializableAttribute()]
public SortOrder SortOrder {get; set;}
Delphi
public read-write property SortOrder: SortOrder;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("General")
System.ComponentModel.DescriptionAttribute("Sort order that applied for the data processing.")
ISNet.Serialization.XmlSerializableAttribute()
public function get,set SortOrder : SortOrder
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DescriptionAttribute("Sort order that applied for the data processing.")]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property SortOrder get_SortOrder();
public: __property void set_SortOrder(
   SortOrder value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DescriptionAttribute("Sort order that applied for the data processing.")]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property SortOrder SortOrder {
   SortOrder get();
   void set (    SortOrder value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartPivotFilterConfig Class
ChartPivotFilterConfig Members


ChartScaleStripStyle Class

[image]
Intersoft WebGrid Documentation
ChartScaleStripStyle Class
Members See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : ChartScaleStripStyle Class

Glossary Item Box

Object Model

ChartScaleStripStyle Class

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.SerializableAttribute()>
Public Class ChartScaleStripStyle
   Inherits ISNet.WebUI.WebUIBaseClass
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Visual Basic (Usage) Copy Code
Dim instance As ChartScaleStripStyle
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public class ChartScaleStripStyle : ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Delphi
public class ChartScaleStripStyle = class(ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize)
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.SerializableAttribute()
public class ChartScaleStripStyle extends ISNet.WebUI.WebUIBaseClass implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public __gc class ChartScaleStripStyle : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public ref class ChartScaleStripStyle : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.WebGrid.ChartScaleStripStyle

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartScaleStripStyle Members
ISNet.WebUI.WebGrid Namespace


ChartScaleStripStyle Class Members

[image]
Intersoft WebGrid Documentation
ChartScaleStripStyle Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebGrid Namespace : ChartScaleStripStyle Class

Glossary Item Box

The following tables list the members exposed by ChartScaleStripStyle.

Public Constructors

 | Name | Description
Public Constructor | ChartScaleStripStyle Constructor |
Top

Public Properties

 | Name | Description
Public Property | Begin |
Public Property | End |
Public Property | FillStyle |
Public Property | Infinite |
Public Property | Interlaced |
Public Property | Interval |
Public Property | Length |
Public Property | StrokeStyle |
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

ChartScaleStripStyle Class
ISNet.WebUI.WebGrid Namespace


ChartScaleStripStyle Constructor

[image]
Intersoft WebGrid Documentation
ChartScaleStripStyle Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ChartScaleStripStyle Class : ChartScaleStripStyle Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New ChartScaleStripStyle()
C#
public ChartScaleStripStyle()
Delphi
public ChartScaleStripStyle();
JScript
public function ChartScaleStripStyle();
Managed Extensions for C++
public: ChartScaleStripStyle();
C++/CLI
public:
ChartScaleStripStyle();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartScaleStripStyle Class
ChartScaleStripStyle Members


Clone Method

[image]
Intersoft WebGrid Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ChartScaleStripStyle Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As System.Object
Visual Basic (Usage) Copy Code
Dim instance As ChartScaleStripStyle
Dim value As System.Object

value = instance.Clone()
C#
public virtual System.object Clone()
Delphi
public function Clone(): System.TObject; virtual;
JScript
public function Clone() : System.Object;
Managed Extensions for C++
public: virtual System.Object* Clone();
C++/CLI
public:
virtual System.Object^ Clone();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartScaleStripStyle Class
ChartScaleStripStyle Members


CopyFrom Method

[image]
Intersoft WebGrid Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ChartScaleStripStyle Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartScaleStripStyle Class
ChartScaleStripStyle Members


CopyFrom(Object) Method

[image]
Intersoft WebGrid Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ChartScaleStripStyle Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartScaleStripStyle
Dim objSource As System.Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   System.object objSource
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartScaleStripStyle Class
ChartScaleStripStyle Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebGrid Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ChartScaleStripStyle Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object, _
   ByVal cloneSourceValue As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartScaleStripStyle
Dim objSource As System.Object
Dim cloneSourceValue As System.Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   System.object objSource,
   System.bool cloneSourceValue
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject;
    cloneSourceValue: System.Boolean
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object,
   cloneSourceValue : System.boolean
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource,
   System.bool cloneSourceValue
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource,
   System.bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartScaleStripStyle Class
ChartScaleStripStyle Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebGrid Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ChartScaleStripStyle Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartScaleStripStyle
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure DeSerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function DeSerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void DeSerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void DeSerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartScaleStripStyle Class
ChartScaleStripStyle Members


GetHashCode Method

[image]
Intersoft WebGrid Documentation
GetHashCode Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ChartScaleStripStyle Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As ChartScaleStripStyle
Dim value As System.Integer

value = instance.GetHashCode()
C#
public virtual System.int GetHashCode()
Delphi
public function GetHashCode(): System.Integer; virtual;
JScript
public function GetHashCode() : System.int;
Managed Extensions for C++
public: virtual System.int GetHashCode();
C++/CLI
public:
virtual System.int GetHashCode();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartScaleStripStyle Class
ChartScaleStripStyle Members


ChartScaleStripStyle Class Methods

[image]
Intersoft WebGrid Documentation
ChartScaleStripStyle Class Methods
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : ChartScaleStripStyle Class

Glossary Item Box

For a list of all members of this type, see ChartScaleStripStyle members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

ChartScaleStripStyle Class
ISNet.WebUI.WebGrid Namespace


GetObjectData Method

[image]
Intersoft WebGrid Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ChartScaleStripStyle Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=False,
   UnmanagedCode=False,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=True,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Action=SecurityAction.Demand,
   Unrestricted=False)>
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartScaleStripStyle
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure GetObjectData(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
); override;
JScript
System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=,
   UnmanagedCode=,
   SkipVerification=,
   Execution=,
   ControlThread=,
   ControlEvidence=,
   ControlPolicy=,
   SerializationFormatter=,
   ControlDomainPolicy=,
   ControlPrincipal=,
   ControlAppDomain=,
   RemotingConfiguration=,
   Infrastructure=,
   BindingRedirects=,
   Action=SecurityAction.Demand,
   Unrestricted=)
public override function GetObjectData(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public: void GetObjectData(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
) override
C++/CLI
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public:
void GetObjectData(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
) override

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartScaleStripStyle Class
ChartScaleStripStyle Members


IsEmpty Method

[image]
Intersoft WebGrid Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ChartScaleStripStyle Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As ChartScaleStripStyle
Dim value As System.Boolean

value = instance.IsEmpty()
C#
public virtual System.bool IsEmpty()
Delphi
public function IsEmpty(): System.Boolean; virtual;
JScript
public function IsEmpty() : System.boolean;
Managed Extensions for C++
public: virtual System.bool IsEmpty();
C++/CLI
public:
virtual System.bool IsEmpty();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartScaleStripStyle Class
ChartScaleStripStyle Members


Reset Method

[image]
Intersoft WebGrid Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ChartScaleStripStyle Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As ChartScaleStripStyle

instance.Reset()
C#
public virtual void Reset()
Delphi
public procedure Reset(); virtual;
JScript
public function Reset();
Managed Extensions for C++
public: virtual void Reset();
C++/CLI
public:
virtual void Reset();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartScaleStripStyle Class
ChartScaleStripStyle Members


SerializeObjectData Method

[image]
Intersoft WebGrid Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ChartScaleStripStyle Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartScaleStripStyle
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure SerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function SerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void SerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void SerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartScaleStripStyle Class
ChartScaleStripStyle Members


ToString Method

[image]
Intersoft WebGrid Documentation
ToString Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ChartScaleStripStyle Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As System.String
Visual Basic (Usage) Copy Code
Dim instance As ChartScaleStripStyle
Dim value As System.String

value = instance.ToString()
C#
public virtual System.string ToString()
Delphi
public function ToString(): System.String; virtual;
JScript
public function ToString() : System.String;
Managed Extensions for C++
public: virtual System.string* ToString();
C++/CLI
public:
virtual System.String^ ToString();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartScaleStripStyle Class
ChartScaleStripStyle Members


ChartScaleStripStyle Class Properties

[image]
Intersoft WebGrid Documentation
ChartScaleStripStyle Class Properties
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : ChartScaleStripStyle Class

Glossary Item Box

For a list of all members of this type, see ChartScaleStripStyle members.

Public Properties

 | Name | Description
Public Property | Begin |
Public Property | End |
Public Property | FillStyle |
Public Property | Infinite |
Public Property | Interlaced |
Public Property | Interval |
Public Property | Length |
Public Property | StrokeStyle |
Top

See Also

Reference

ChartScaleStripStyle Class
ISNet.WebUI.WebGrid Namespace


ChartScaleStripStyle Constructor

[image]
Intersoft WebGrid Documentation
ChartScaleStripStyle Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ChartScaleStripStyle Class : ChartScaleStripStyle Constructor

Glossary Item Box

Overload List

Overload | Description
ChartScaleStripStyle Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartScaleStripStyle Class
ChartScaleStripStyle Members


Begin Property

[image]
Intersoft WebGrid Documentation
Begin Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ChartScaleStripStyle Class : Begin Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("The begin row or column of this interlace style.")>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Range")>
Public Property Begin As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As ChartScaleStripStyle
Dim value As System.Integer

instance.Begin = value

value = instance.Begin
C#
[System.ComponentModel.DescriptionAttribute("The begin row or column of this interlace style.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Range")]
public System.int Begin {get; set;}
Delphi
public read-write property Begin: System.Integer;
JScript
System.ComponentModel.DescriptionAttribute("The begin row or column of this interlace style.")
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Range")
public function get,set Begin : System.int
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("The begin row or column of this interlace style.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Range")]
public: __property System.int get_Begin();
public: __property void set_Begin(
   System.int value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("The begin row or column of this interlace style.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Range")]
public:
property System.int Begin {
   System.int get();
   void set (    System.int value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartScaleStripStyle Class
ChartScaleStripStyle Members


End Property

[image]
Intersoft WebGrid Documentation
End Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ChartScaleStripStyle Class : End Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("The end row or column of this interlace style is Infinite is set to false.")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Range")>
Public Property End As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As ChartScaleStripStyle
Dim value As System.Integer

instance.End = value

value = instance.End
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("The end row or column of this interlace style is Infinite is set to false.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Range")]
public System.int End {get; set;}
Delphi
public read-write property End: System.Integer;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DescriptionAttribute("The end row or column of this interlace style is Infinite is set to false.")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Range")
public function get,set End : System.int
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("The end row or column of this interlace style is Infinite is set to false.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Range")]
public: __property System.int get_End();
public: __property void set_End(
   System.int value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("The end row or column of this interlace style is Infinite is set to false.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Range")]
public:
property System.int End {
   System.int get();
   void set (    System.int value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartScaleStripStyle Class
ChartScaleStripStyle Members


FillStyle Property

[image]
Intersoft WebGrid Documentation
FillStyle Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ChartScaleStripStyle Class : FillStyle Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Controls the fill style of the interlace style.")>
<ISNet.Serialization.BinarySerializableAttribute("setFillStyle")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<System.ComponentModel.CategoryAttribute("Appearance")>
Public ReadOnly Property FillStyle As ChartFillStyle
Visual Basic (Usage) Copy Code
Dim instance As ChartScaleStripStyle
Dim value As ChartFillStyle

value = instance.FillStyle
C#
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Controls the fill style of the interlace style.")]
[ISNet.Serialization.BinarySerializableAttribute("setFillStyle")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.CategoryAttribute("Appearance")]
public ChartFillStyle FillStyle {get;}
Delphi
public read-only property FillStyle: ChartFillStyle;
JScript
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Controls the fill style of the interlace style.")
ISNet.Serialization.BinarySerializableAttribute("setFillStyle")
System.ComponentModel.NotifyParentPropertyAttribute()
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
System.ComponentModel.CategoryAttribute("Appearance")
public function get FillStyle : ChartFillStyle
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Controls the fill style of the interlace style.")]
[ISNet.Serialization.BinarySerializableAttribute("setFillStyle")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.CategoryAttribute("Appearance")]
public: __property ChartFillStyle* get_FillStyle();
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Controls the fill style of the interlace style.")]
[ISNet.Serialization.BinarySerializableAttribute("setFillStyle")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.CategoryAttribute("Appearance")]
public:
property ChartFillStyle^ FillStyle {
   ChartFillStyle^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartScaleStripStyle Class
ChartScaleStripStyle Members


Infinite Property

[image]
Intersoft WebGrid Documentation
Infinite Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ChartScaleStripStyle Class : Infinite Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Whether or not this style is repeated infinitely along the chart wall or not.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Range")>
Public Property Infinite As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As ChartScaleStripStyle
Dim value As System.Boolean

instance.Infinite = value

value = instance.Infinite
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Whether or not this style is repeated infinitely along the chart wall or not.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Range")]
public System.bool Infinite {get; set;}
Delphi
public read-write property Infinite: System.Boolean;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Whether or not this style is repeated infinitely along the chart wall or not.")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Range")
public function get,set Infinite : System.boolean
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Whether or not this style is repeated infinitely along the chart wall or not.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Range")]
public: __property System.bool get_Infinite();
public: __property void set_Infinite(
   System.bool value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Whether or not this style is repeated infinitely along the chart wall or not.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Range")]
public:
property System.bool Infinite {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartScaleStripStyle Class
ChartScaleStripStyle Members


Interlaced Property

[image]
Intersoft WebGrid Documentation
Interlaced Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ChartScaleStripStyle Class : Interlaced Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specify whether strip style will be interlaced (synchronized with the view order of the range sampler)")>
<System.ComponentModel.CategoryAttribute("Appearance")>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property Interlaced As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As ChartScaleStripStyle
Dim value As System.Boolean

instance.Interlaced = value

value = instance.Interlaced
C#
[System.ComponentModel.DescriptionAttribute("Specify whether strip style will be interlaced (synchronized with the view order of the range sampler)")]
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.bool Interlaced {get; set;}
Delphi
public read-write property Interlaced: System.Boolean;
JScript
System.ComponentModel.DescriptionAttribute("Specify whether strip style will be interlaced (synchronized with the view order of the range sampler)")
System.ComponentModel.CategoryAttribute("Appearance")
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set Interlaced : System.boolean
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specify whether strip style will be interlaced (synchronized with the view order of the range sampler)")]
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.bool get_Interlaced();
public: __property void set_Interlaced(
   System.bool value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specify whether strip style will be interlaced (synchronized with the view order of the range sampler)")]
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.bool Interlaced {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartScaleStripStyle Class
ChartScaleStripStyle Members


Interval Property

[image]
Intersoft WebGrid Documentation
Interval Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ChartScaleStripStyle Class : Interval Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Appearance")>
<System.ComponentModel.DescriptionAttribute("The interval (gap) between two consecutive interlace stripes.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
Public Property Interval As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As ChartScaleStripStyle
Dim value As System.Integer

instance.Interval = value

value = instance.Interval
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.DescriptionAttribute("The interval (gap) between two consecutive interlace stripes.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public System.int Interval {get; set;}
Delphi
public read-write property Interval: System.Integer;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Appearance")
System.ComponentModel.DescriptionAttribute("The interval (gap) between two consecutive interlace stripes.")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
public function get,set Interval : System.int
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.DescriptionAttribute("The interval (gap) between two consecutive interlace stripes.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.int get_Interval();
public: __property void set_Interval(
   System.int value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.DescriptionAttribute("The interval (gap) between two consecutive interlace stripes.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.int Interval {
   System.int get();
   void set (    System.int value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartScaleStripStyle Class
ChartScaleStripStyle Members


Length Property

[image]
Intersoft WebGrid Documentation
Length Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ChartScaleStripStyle Class : Length Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Appearance")>
<System.ComponentModel.DescriptionAttribute("The length in rows or columns of each interlace stripe.")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property Length As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As ChartScaleStripStyle
Dim value As System.Integer

instance.Length = value

value = instance.Length
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.DescriptionAttribute("The length in rows or columns of each interlace stripe.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.int Length {get; set;}
Delphi
public read-write property Length: System.Integer;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Appearance")
System.ComponentModel.DescriptionAttribute("The length in rows or columns of each interlace stripe.")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set Length : System.int
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.DescriptionAttribute("The length in rows or columns of each interlace stripe.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.int get_Length();
public: __property void set_Length(
   System.int value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.DescriptionAttribute("The length in rows or columns of each interlace stripe.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.int Length {
   System.int get();
   void set (    System.int value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartScaleStripStyle Class
ChartScaleStripStyle Members


StrokeStyle Property

[image]
Intersoft WebGrid Documentation
StrokeStyle Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ChartScaleStripStyle Class : StrokeStyle Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<System.ComponentModel.DescriptionAttribute("Controls the stroke style of the interlace style.")>
<ISNet.Serialization.BinarySerializableAttribute("setStrokeStyle")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("Appearance")>
Public ReadOnly Property StrokeStyle As ChartStrokeStyle
Visual Basic (Usage) Copy Code
Dim instance As ChartScaleStripStyle
Dim value As ChartStrokeStyle

value = instance.StrokeStyle
C#
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DescriptionAttribute("Controls the stroke style of the interlace style.")]
[ISNet.Serialization.BinarySerializableAttribute("setStrokeStyle")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Appearance")]
public ChartStrokeStyle StrokeStyle {get;}
Delphi
public read-only property StrokeStyle: ChartStrokeStyle;
JScript
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
System.ComponentModel.DescriptionAttribute("Controls the stroke style of the interlace style.")
ISNet.Serialization.BinarySerializableAttribute("setStrokeStyle")
System.ComponentModel.NotifyParentPropertyAttribute()
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("Appearance")
public function get StrokeStyle : ChartStrokeStyle
Managed Extensions for C++
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DescriptionAttribute("Controls the stroke style of the interlace style.")]
[ISNet.Serialization.BinarySerializableAttribute("setStrokeStyle")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Appearance")]
public: __property ChartStrokeStyle* get_StrokeStyle();
C++/CLI
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DescriptionAttribute("Controls the stroke style of the interlace style.")]
[ISNet.Serialization.BinarySerializableAttribute("setStrokeStyle")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Appearance")]
public:
property ChartStrokeStyle^ StrokeStyle {
   ChartStrokeStyle^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartScaleStripStyle Class
ChartScaleStripStyle Members


ChildTableDataSourceEventArgs Class

[image]
Intersoft WebGrid Documentation
ChildTableDataSourceEventArgs Class
Members See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : ChildTableDataSourceEventArgs Class

Glossary Item Box

Object Model

ChildTableDataSourceEventArgs Class

Syntax

Visual Basic (Declaration)
Public Class ChildTableDataSourceEventArgs
   Inherits BaseEventArgs
Visual Basic (Usage) Copy Code
Dim instance As ChildTableDataSourceEventArgs
C#
public class ChildTableDataSourceEventArgs : BaseEventArgs
Delphi
public class ChildTableDataSourceEventArgs = class(BaseEventArgs)
JScript
public class ChildTableDataSourceEventArgs extends BaseEventArgs
Managed Extensions for C++
public __gc class ChildTableDataSourceEventArgs : public BaseEventArgs
C++/CLI
public ref class ChildTableDataSourceEventArgs : public BaseEventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
ISNet.WebUI.WebGrid.BaseEventArgs
ISNet.WebUI.WebGrid.ChildTableDataSourceEventArgs

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChildTableDataSourceEventArgs Members
ISNet.WebUI.WebGrid Namespace


ChildTableDataSourceEventArgs Class Members

[image]
Intersoft WebGrid Documentation
ChildTableDataSourceEventArgs Class Members
See Also Properties Send Feedback
ISNet.WebUI.WebGrid Namespace : ChildTableDataSourceEventArgs Class

Glossary Item Box

The following tables list the members exposed by ChildTableDataSourceEventArgs.

Public Properties

 | Name | Description
Public Property | CustomRequestData |
Public Property | DataSource |
Public Property | ParentConstraints |
Public Property | ParentKeyValues |
Public Property | ParentObject |
Public Property | ReturnValue | (Inherited from ISNet.WebUI.WebGrid.BaseEventArgs)
Public Property | Table |
Top

See Also

Reference

ChildTableDataSourceEventArgs Class
ISNet.WebUI.WebGrid Namespace


ChildTableDataSourceEventArgs Class Properties

[image]
Intersoft WebGrid Documentation
ChildTableDataSourceEventArgs Class Properties
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : ChildTableDataSourceEventArgs Class

Glossary Item Box

For a list of all members of this type, see ChildTableDataSourceEventArgs members.

Public Properties

 | Name | Description
Public Property | CustomRequestData |
Public Property | DataSource |
Public Property | ParentConstraints |
Public Property | ParentKeyValues |
Public Property | ParentObject |
Public Property | ReturnValue | (Inherited from ISNet.WebUI.WebGrid.BaseEventArgs)
Public Property | Table |
Top

See Also

Reference

ChildTableDataSourceEventArgs Class
ISNet.WebUI.WebGrid Namespace


CustomRequestData Property

[image]
Intersoft WebGrid Documentation
CustomRequestData Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ChildTableDataSourceEventArgs Class : CustomRequestData Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property CustomRequestData As System.String
Visual Basic (Usage) Copy Code
Dim instance As ChildTableDataSourceEventArgs
Dim value As System.String

value = instance.CustomRequestData
C#
public System.string CustomRequestData {get;}
Delphi
public read-only property CustomRequestData: System.String;
JScript
public function get CustomRequestData : System.String
Managed Extensions for C++
public: __property System.string* get_CustomRequestData();
C++/CLI
public:
property System.String^ CustomRequestData {
   System.String^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChildTableDataSourceEventArgs Class
ChildTableDataSourceEventArgs Members


DataSource Property

[image]
Intersoft WebGrid Documentation
DataSource Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ChildTableDataSourceEventArgs Class : DataSource Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property DataSource As System.Object
Visual Basic (Usage) Copy Code
Dim instance As ChildTableDataSourceEventArgs
Dim value As System.Object

value = instance.DataSource
C#
public System.object DataSource {get;}
Delphi
public read-only property DataSource: System.TObject;
JScript
public function get DataSource : System.Object
Managed Extensions for C++
public: __property System.Object* get_DataSource();
C++/CLI
public:
property System.Object^ DataSource {
   System.Object^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChildTableDataSourceEventArgs Class
ChildTableDataSourceEventArgs Members


ParentConstraints Property

[image]
Intersoft WebGrid Documentation
ParentConstraints Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ChildTableDataSourceEventArgs Class : ParentConstraints Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ParentConstraints As System.String
Visual Basic (Usage) Copy Code
Dim instance As ChildTableDataSourceEventArgs
Dim value As System.String

value = instance.ParentConstraints
C#
public System.string ParentConstraints {get;}
Delphi
public read-only property ParentConstraints: System.String;
JScript
public function get ParentConstraints : System.String
Managed Extensions for C++
public: __property System.string* get_ParentConstraints();
C++/CLI
public:
property System.String^ ParentConstraints {
   System.String^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChildTableDataSourceEventArgs Class
ChildTableDataSourceEventArgs Members


ParentKeyValues Property

[image]
Intersoft WebGrid Documentation
ParentKeyValues Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ChildTableDataSourceEventArgs Class : ParentKeyValues Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ParentKeyValues As System.Collections.Hashtable
Visual Basic (Usage) Copy Code
Dim instance As ChildTableDataSourceEventArgs
Dim value As System.Collections.Hashtable

value = instance.ParentKeyValues
C#
public System.Collections.Hashtable ParentKeyValues {get;}
Delphi
public read-only property ParentKeyValues: System.Collections.Hashtable;
JScript
public function get ParentKeyValues : System.Collections.Hashtable
Managed Extensions for C++
public: __property System.Collections.Hashtable* get_ParentKeyValues();
C++/CLI
public:
property System.Collections.Hashtable^ ParentKeyValues {
   System.Collections.Hashtable^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChildTableDataSourceEventArgs Class
ChildTableDataSourceEventArgs Members


ParentObject Property

[image]
Intersoft WebGrid Documentation
ParentObject Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ChildTableDataSourceEventArgs Class : ParentObject Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property ParentObject As System.Object
Visual Basic (Usage) Copy Code
Dim instance As ChildTableDataSourceEventArgs
Dim value As System.Object

instance.ParentObject = value

value = instance.ParentObject
C#
public System.object ParentObject {get; set;}
Delphi
public read-write property ParentObject: System.TObject;
JScript
public function get,set ParentObject : System.Object
Managed Extensions for C++
public: __property System.Object* get_ParentObject();
public: __property void set_ParentObject(
   System.Object* value
);
C++/CLI
public:
property System.Object^ ParentObject {
   System.Object^ get();
   void set (    System.Object^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChildTableDataSourceEventArgs Class
ChildTableDataSourceEventArgs Members


Table Property

[image]
Intersoft WebGrid Documentation
Table Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ChildTableDataSourceEventArgs Class : Table Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Table As WebGridTable
Visual Basic (Usage) Copy Code
Dim instance As ChildTableDataSourceEventArgs
Dim value As WebGridTable

value = instance.Table
C#
public WebGridTable Table {get;}
Delphi
public read-only property Table: WebGridTable;
JScript
public function get Table : WebGridTable
Managed Extensions for C++
public: __property WebGridTable* get_Table();
C++/CLI
public:
property WebGridTable^ Table {
   WebGridTable^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChildTableDataSourceEventArgs Class
ChildTableDataSourceEventArgs Members


ClientEvents Class

[image]
Intersoft WebGrid Documentation
ClientEvents Class
Members See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : ClientEvents Class

Glossary Item Box

Object Model

ClientEvents Class

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.DescriptionAttribute()>
<System.SerializableAttribute()>
Public Class ClientEvents
   Inherits ISNet.WebUI.WebUIBaseClass
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Visual Basic (Usage) Copy Code
Dim instance As ClientEvents
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DescriptionAttribute()]
[System.SerializableAttribute()]
public class ClientEvents : ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Delphi
public class ClientEvents = class(ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize)
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.DescriptionAttribute()
System.SerializableAttribute()
public class ClientEvents extends ISNet.WebUI.WebUIBaseClass implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DescriptionAttribute()]
[System.SerializableAttribute()]
public __gc class ClientEvents : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DescriptionAttribute()]
[System.SerializableAttribute()]
public ref class ClientEvents : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.WebGrid.ClientEvents

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ClientEvents Members
ISNet.WebUI.WebGrid Namespace


ClientEvents Class Members

[image]
Intersoft WebGrid Documentation
ClientEvents Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebGrid Namespace : ClientEvents Class

Glossary Item Box

The following tables list the members exposed by ClientEvents.

Public Constructors

 | Name | Description
Public Constructor | ClientEvents Constructor |
Top

Public Properties

 | Name | Description
Public Property | OnAcceptAllChanges |
Public Property | OnActionDispatched |
Public Property | OnAddPendingChanges |
Public Property | OnAfterAdd |
Public Property | OnAfterDelete |
Public Property | OnAfterExitEditMode |
Public Property | OnAfterInitialize |
Public Property | OnAfterPrint |
Public Property | OnAfterResponseProcess |
Public Property | OnAfterUpdate |
Public Property | OnBatchUpdateError |
Public Property | OnBatchUpdateSuccess |
Public Property | OnBeforeAdd |
Public Property | OnBeforeDelete |
Public Property | OnBeforePrint |
Public Property | OnBeforeRequest |
Public Property | OnBeforeRowSelect |
Public Property | OnBeforeUpdate |
Public Property | OnBeginRowEditing |
Public Property | OnButtonClick |
Public Property | OnCalendarSelect |
Public Property | OnCancelRowEditing |
Public Property | OnCellClick |
Public Property | OnCellDblClick |
Public Property | OnCellSelect |
Public Property | OnCheckBoxClick |
Public Property | OnChildRowCollapse |
Public Property | OnChildRowExpand |
Public Property | OnColumnAction |
Public Property | OnColumnChanged |
Public Property | OnColumnContextMenu |
Public Property | OnColumnFilter |
Public Property | OnColumnGroup |
Public Property | OnColumnGroupChange |
Public Property | OnColumnMove |
Public Property | OnColumnResize |
Public Property | OnColumnSort |
Public Property | OnColumnUngroup |
Public Property | OnComboItemCheck |
Public Property | OnCustomAggregate |
Public Property | OnDataBound |
Public Property | OnDataSourceChanged |
Public Property | OnEditKeyDown |
Public Property | OnEndRowEditing |
Public Property | OnEnterEditMode |
Public Property | OnExitEditMode |
Public Property | OnExportContextMenu |
Public Property | OnFilterContextMenu |
Public Property | OnFocus |
Public Property | OnGroupCollapse |
Public Property | OnGroupExpand |
Public Property | OnInitialize |
Public Property | OnInitializeCell |
Public Property | OnInitializeCustomEditor |
Public Property | OnInitializeRow |
Public Property | OnKeyDown |
Public Property | OnKeyUp |
Public Property | OnLostFocus |
Public Property | OnPostRender |
Public Property | OnPreRender |
Public Property | OnRemovePendingChanges |
Public Property | OnResponse |
Public Property | OnRowContextMenu |
Public Property | OnRowSelect |
Public Property | OnRowSelectorClick |
Public Property | OnRowValidate |
Public Property | OnScroll |
Public Property | OnSelfRefRowCollapse |
Public Property | OnSelfRefRowExpand |
Public Property | OnSynchronizeCell |
Public Property | OnSynchronizeChangesUI |
Public Property | OnSynchronizeRow |
Public Property | OnUndoAllChanges |
Public Property | OnUndoChanges |
Public Property | OnUnhandledError |
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString |
Top

See Also

Reference

ClientEvents Class
ISNet.WebUI.WebGrid Namespace


ClientEvents Constructor

[image]
Intersoft WebGrid Documentation
ClientEvents Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ClientEvents Class : ClientEvents Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New ClientEvents()
C#
public ClientEvents()
Delphi
public ClientEvents();
JScript
public function ClientEvents();
Managed Extensions for C++
public: ClientEvents();
C++/CLI
public:
ClientEvents();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ClientEvents Class
ClientEvents Members


Clone Method

[image]
Intersoft WebGrid Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ClientEvents Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As System.Object
Visual Basic (Usage) Copy Code
Dim instance As ClientEvents
Dim value As System.Object

value = instance.Clone()
C#
public virtual System.object Clone()
Delphi
public function Clone(): System.TObject; virtual;
JScript
public function Clone() : System.Object;
Managed Extensions for C++
public: virtual System.Object* Clone();
C++/CLI
public:
virtual System.Object^ Clone();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ClientEvents Class
ClientEvents Members


CopyFrom Method

[image]
Intersoft WebGrid Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ClientEvents Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ClientEvents Class
ClientEvents Members


CopyFrom(Object) Method

[image]
Intersoft WebGrid Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ClientEvents Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As ClientEvents
Dim objSource As System.Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   System.object objSource
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ClientEvents Class
ClientEvents Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebGrid Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ClientEvents Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object, _
   ByVal cloneSourceValue As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As ClientEvents
Dim objSource As System.Object
Dim cloneSourceValue As System.Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   System.object objSource,
   System.bool cloneSourceValue
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject;
    cloneSourceValue: System.Boolean
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object,
   cloneSourceValue : System.boolean
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource,
   System.bool cloneSourceValue
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource,
   System.bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ClientEvents Class
ClientEvents Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebGrid Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ClientEvents Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As ClientEvents
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure DeSerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function DeSerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void DeSerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void DeSerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ClientEvents Class
ClientEvents Members


GetHashCode Method

[image]
Intersoft WebGrid Documentation
GetHashCode Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ClientEvents Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As ClientEvents
Dim value As System.Integer

value = instance.GetHashCode()
C#
public virtual System.int GetHashCode()
Delphi
public function GetHashCode(): System.Integer; virtual;
JScript
public function GetHashCode() : System.int;
Managed Extensions for C++
public: virtual System.int GetHashCode();
C++/CLI
public:
virtual System.int GetHashCode();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ClientEvents Class
ClientEvents Members


ClientEvents Class Methods

[image]
Intersoft WebGrid Documentation
ClientEvents Class Methods
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : ClientEvents Class

Glossary Item Box

For a list of all members of this type, see ClientEvents members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString |
Top

See Also

Reference

ClientEvents Class
ISNet.WebUI.WebGrid Namespace


GetObjectData Method

[image]
Intersoft WebGrid Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ClientEvents Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As ClientEvents
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure GetObjectData(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
); override;
JScript
public override function GetObjectData(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void GetObjectData(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
) override
C++/CLI
public:
void GetObjectData(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
) override

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ClientEvents Class
ClientEvents Members


IsEmpty Method

[image]
Intersoft WebGrid Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ClientEvents Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As ClientEvents
Dim value As System.Boolean

value = instance.IsEmpty()
C#
public virtual System.bool IsEmpty()
Delphi
public function IsEmpty(): System.Boolean; virtual;
JScript
public function IsEmpty() : System.boolean;
Managed Extensions for C++
public: virtual System.bool IsEmpty();
C++/CLI
public:
virtual System.bool IsEmpty();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ClientEvents Class
ClientEvents Members


Reset Method

[image]
Intersoft WebGrid Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ClientEvents Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As ClientEvents

instance.Reset()
C#
public virtual void Reset()
Delphi
public procedure Reset(); virtual;
JScript
public function Reset();
Managed Extensions for C++
public: virtual void Reset();
C++/CLI
public:
virtual void Reset();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ClientEvents Class
ClientEvents Members


SerializeObjectData Method

[image]
Intersoft WebGrid Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ClientEvents Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As ClientEvents
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure SerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function SerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void SerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void SerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ClientEvents Class
ClientEvents Members


ToString Method

[image]
Intersoft WebGrid Documentation
ToString Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ClientEvents Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString() As System.String
Visual Basic (Usage) Copy Code
Dim instance As ClientEvents
Dim value As System.String

value = instance.ToString()
C#
public override System.string ToString()
Delphi
public function ToString(): System.String; override;
JScript
public override function ToString() : System.String;
Managed Extensions for C++
public: System.string* ToString(); override
C++/CLI
public:
System.String^ ToString(); override

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ClientEvents Class
ClientEvents Members


ClientEvents Class Properties

[image]
Intersoft WebGrid Documentation
ClientEvents Class Properties
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : ClientEvents Class

Glossary Item Box

For a list of all members of this type, see ClientEvents members.

Public Properties

 | Name | Description
Public Property | OnAcceptAllChanges |
Public Property | OnActionDispatched |
Public Property | OnAddPendingChanges |
Public Property | OnAfterAdd |
Public Property | OnAfterDelete |
Public Property | OnAfterExitEditMode |
Public Property | OnAfterInitialize |
Public Property | OnAfterPrint |
Public Property | OnAfterResponseProcess |
Public Property | OnAfterUpdate |
Public Property | OnBatchUpdateError |
Public Property | OnBatchUpdateSuccess |
Public Property | OnBeforeAdd |
Public Property | OnBeforeDelete |
Public Property | OnBeforePrint |
Public Property | OnBeforeRequest |
Public Property | OnBeforeRowSelect |
Public Property | OnBeforeUpdate |
Public Property | OnBeginRowEditing |
Public Property | OnButtonClick |
Public Property | OnCalendarSelect |
Public Property | OnCancelRowEditing |
Public Property | OnCellClick |
Public Property | OnCellDblClick |
Public Property | OnCellSelect |
Public Property | OnCheckBoxClick |
Public Property | OnChildRowCollapse |
Public Property | OnChildRowExpand |
Public Property | OnColumnAction |
Public Property | OnColumnChanged |
Public Property | OnColumnContextMenu |
Public Property | OnColumnFilter |
Public Property | OnColumnGroup |
Public Property | OnColumnGroupChange |
Public Property | OnColumnMove |
Public Property | OnColumnResize |
Public Property | OnColumnSort |
Public Property | OnColumnUngroup |
Public Property | OnComboItemCheck |
Public Property | OnCustomAggregate |
Public Property | OnDataBound |
Public Property | OnDataSourceChanged |
Public Property | OnEditKeyDown |
Public Property | OnEndRowEditing |
Public Property | OnEnterEditMode |
Public Property | OnExitEditMode |
Public Property | OnExportContextMenu |
Public Property | OnFilterContextMenu |
Public Property | OnFocus |
Public Property | OnGroupCollapse |
Public Property | OnGroupExpand |
Public Property | OnInitialize |
Public Property | OnInitializeCell |
Public Property | OnInitializeCustomEditor |
Public Property | OnInitializeRow |
Public Property | OnKeyDown |
Public Property | OnKeyUp |
Public Property | OnLostFocus |
Public Property | OnPostRender |
Public Property | OnPreRender |
Public Property | OnRemovePendingChanges |
Public Property | OnResponse |
Public Property | OnRowContextMenu |
Public Property | OnRowSelect |
Public Property | OnRowSelectorClick |
Public Property | OnRowValidate |
Public Property | OnScroll |
Public Property | OnSelfRefRowCollapse |
Public Property | OnSelfRefRowExpand |
Public Property | OnSynchronizeCell |
Public Property | OnSynchronizeChangesUI |
Public Property | OnSynchronizeRow |
Public Property | OnUndoAllChanges |
Public Property | OnUndoChanges |
Public Property | OnUnhandledError |
Top

See Also

Reference

ClientEvents Class
ISNet.WebUI.WebGrid Namespace


ClientEvents Constructor

[image]
Intersoft WebGrid Documentation
ClientEvents Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ClientEvents Class : ClientEvents Constructor

Glossary Item Box

Overload List

Overload | Description
ClientEvents Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ClientEvents Class
ClientEvents Members


OnAcceptAllChanges Property

[image]
Intersoft WebGrid Documentation
OnAcceptAllChanges Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ClientEvents Class : OnAcceptAllChanges Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.EventParameterAttribute("controlId")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when accept all changes command is performed.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")>
Public Property OnAcceptAllChanges As System.String
Visual Basic (Usage) Copy Code
Dim instance As ClientEvents
Dim value As System.String

instance.OnAcceptAllChanges = value

value = instance.OnAcceptAllChanges
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.EventParameterAttribute("controlId")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when accept all changes command is performed.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
public System.string OnAcceptAllChanges {get; set;}
Delphi
public read-write property OnAcceptAllChanges: System.String;
JScript
ISNet.Serialization.BinarySerializableAttribute()
ISNet.EventParameterAttribute("controlId")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when accept all changes command is performed.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")
public function get,set OnAcceptAllChanges : System.String
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.EventParameterAttribute("controlId")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when accept all changes command is performed.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
public: __property System.string* get_OnAcceptAllChanges();
public: __property void set_OnAcceptAllChanges(
   System.string* value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.EventParameterAttribute("controlId")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when accept all changes command is performed.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
public:
property System.String^ OnAcceptAllChanges {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ClientEvents Class
ClientEvents Members


OnActionDispatched Property

[image]
Intersoft WebGrid Documentation
OnActionDispatched Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ClientEvents Class : OnActionDispatched Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.EventParameterAttribute("controlId, actionName")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked after an FlyPostBack action is dispacthed during response.")>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property OnActionDispatched As System.String
Visual Basic (Usage) Copy Code
Dim instance As ClientEvents
Dim value As System.String

instance.OnActionDispatched = value

value = instance.OnActionDispatched
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.EventParameterAttribute("controlId, actionName")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked after an FlyPostBack action is dispacthed during response.")]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.Serialization.BinarySerializableAttribute()]
public System.string OnActionDispatched {get; set;}
Delphi
public read-write property OnActionDispatched: System.String;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.XmlSerializableAttribute()
ISNet.EventParameterAttribute("controlId, actionName")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked after an FlyPostBack action is dispacthed during response.")
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")
ISNet.Serialization.BinarySerializableAttribute()
public function get,set OnActionDispatched : System.String
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.EventParameterAttribute("controlId, actionName")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked after an FlyPostBack action is dispacthed during response.")]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.string* get_OnActionDispatched();
public: __property void set_OnActionDispatched(
   System.string* value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.EventParameterAttribute("controlId, actionName")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked after an FlyPostBack action is dispacthed during response.")]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.String^ OnActionDispatched {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ClientEvents Class
ClientEvents Members


OnAddPendingChanges Property

[image]
Intersoft WebGrid Documentation
OnAddPendingChanges Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ClientEvents Class : OnAddPendingChanges Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.EventParameterAttribute("controlId, table, rowChange")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when a pending changes is about to be added.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")>
Public Property OnAddPendingChanges As System.String
Visual Basic (Usage) Copy Code
Dim instance As ClientEvents
Dim value As System.String

instance.OnAddPendingChanges = value

value = instance.OnAddPendingChanges
C#
[ISNet.EventParameterAttribute("controlId, table, rowChange")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when a pending changes is about to be added.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
public System.string OnAddPendingChanges {get; set;}
Delphi
public read-write property OnAddPendingChanges: System.String;
JScript
ISNet.EventParameterAttribute("controlId, table, rowChange")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when a pending changes is about to be added.")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")
public function get,set OnAddPendingChanges : System.String
Managed Extensions for C++
[ISNet.EventParameterAttribute("controlId, table, rowChange")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when a pending changes is about to be added.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
public: __property System.string* get_OnAddPendingChanges();
public: __property void set_OnAddPendingChanges(
   System.string* value
);
C++/CLI
[ISNet.EventParameterAttribute("controlId, table, rowChange")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when a pending changes is about to be added.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
public:
property System.String^ OnAddPendingChanges {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ClientEvents Class
ClientEvents Members


OnAfterAdd Property

[image]
Intersoft WebGrid Documentation
OnAfterAdd Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ClientEvents Class : OnAfterAdd Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.EventParameterAttribute("controlId, tblName, rowObject, xmlResponseObject")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked after the new row has been added.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")>
Public Property OnAfterAdd As System.String
Visual Basic (Usage) Copy Code
Dim instance As ClientEvents
Dim value As System.String

instance.OnAfterAdd = value

value = instance.OnAfterAdd
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.EventParameterAttribute("controlId, tblName, rowObject, xmlResponseObject")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked after the new row has been added.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
public System.string OnAfterAdd {get; set;}
Delphi
public read-write property OnAfterAdd: System.String;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
ISNet.EventParameterAttribute("controlId, tblName, rowObject, xmlResponseObject")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked after the new row has been added.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")
public function get,set OnAfterAdd : System.String
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.EventParameterAttribute("controlId, tblName, rowObject, xmlResponseObject")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked after the new row has been added.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
public: __property System.string* get_OnAfterAdd();
public: __property void set_OnAfterAdd(
   System.string* value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.EventParameterAttribute("controlId, tblName, rowObject, xmlResponseObject")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked after the new row has been added.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
public:
property System.String^ OnAfterAdd {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ClientEvents Class
ClientEvents Members


OnAfterDelete Property

[image]
Intersoft WebGrid Documentation
OnAfterDelete Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ClientEvents Class : OnAfterDelete Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked after the delete process is done.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")>
<ISNet.EventParameterAttribute("controlId, tblName, rowObject, xmlResponseObject")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property OnAfterDelete As System.String
Visual Basic (Usage) Copy Code
Dim instance As ClientEvents
Dim value As System.String

instance.OnAfterDelete = value

value = instance.OnAfterDelete
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked after the delete process is done.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.EventParameterAttribute("controlId, tblName, rowObject, xmlResponseObject")]
[System.ComponentModel.DefaultValueAttribute()]
public System.string OnAfterDelete {get; set;}
Delphi
public read-write property OnAfterDelete: System.String;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked after the delete process is done.")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")
ISNet.EventParameterAttribute("controlId, tblName, rowObject, xmlResponseObject")
System.ComponentModel.DefaultValueAttribute()
public function get,set OnAfterDelete : System.String
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked after the delete process is done.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.EventParameterAttribute("controlId, tblName, rowObject, xmlResponseObject")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.string* get_OnAfterDelete();
public: __property void set_OnAfterDelete(
   System.string* value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked after the delete process is done.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.EventParameterAttribute("controlId, tblName, rowObject, xmlResponseObject")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.String^ OnAfterDelete {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ClientEvents Class
ClientEvents Members


OnAfterExitEditMode Property

[image]
Intersoft WebGrid Documentation
OnAfterExitEditMode Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ClientEvents Class : OnAfterExitEditMode Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked after edit mode has ended successfully.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.EventParameterAttribute("controlId, tableName, editObject")>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")>
Public Property OnAfterExitEditMode As System.String
Visual Basic (Usage) Copy Code
Dim instance As ClientEvents
Dim value As System.String

instance.OnAfterExitEditMode = value

value = instance.OnAfterExitEditMode
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked after edit mode has ended successfully.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.EventParameterAttribute("controlId, tableName, editObject")]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
public System.string OnAfterExitEditMode {get; set;}
Delphi
public read-write property OnAfterExitEditMode: System.String;
JScript
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked after edit mode has ended successfully.")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.EventParameterAttribute("controlId, tableName, editObject")
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")
public function get,set OnAfterExitEditMode : System.String
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked after edit mode has ended successfully.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.EventParameterAttribute("controlId, tableName, editObject")]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
public: __property System.string* get_OnAfterExitEditMode();
public: __property void set_OnAfterExitEditMode(
   System.string* value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked after edit mode has ended successfully.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.EventParameterAttribute("controlId, tableName, editObject")]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
public:
property System.String^ OnAfterExitEditMode {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ClientEvents Class
ClientEvents Members


OnAfterInitialize Property

[image]
Intersoft WebGrid Documentation
OnAfterInitialize Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ClientEvents Class : OnAfterInitialize Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when the grid has passed initialization phase.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.EventParameterAttribute("controlId")>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")>
Public Property OnAfterInitialize As System.String
Visual Basic (Usage) Copy Code
Dim instance As ClientEvents
Dim value As System.String

instance.OnAfterInitialize = value

value = instance.OnAfterInitialize
C#
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when the grid has passed initialization phase.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.EventParameterAttribute("controlId")]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
public System.string OnAfterInitialize {get; set;}
Delphi
public read-write property OnAfterInitialize: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when the grid has passed initialization phase.")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
ISNet.EventParameterAttribute("controlId")
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")
public function get,set OnAfterInitialize : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when the grid has passed initialization phase.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.EventParameterAttribute("controlId")]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
public: __property System.string* get_OnAfterInitialize();
public: __property void set_OnAfterInitialize(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when the grid has passed initialization phase.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.EventParameterAttribute("controlId")]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
public:
property System.String^ OnAfterInitialize {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ClientEvents Class
ClientEvents Members


OnAfterPrint Property

[image]
Intersoft WebGrid Documentation
OnAfterPrint Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ClientEvents Class : OnAfterPrint Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked after the Grid is printed from browser Print menu.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.EventParameterAttribute("controlId")>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")>
Public Property OnAfterPrint As System.String
Visual Basic (Usage) Copy Code
Dim instance As ClientEvents
Dim value As System.String

instance.OnAfterPrint = value

value = instance.OnAfterPrint
C#
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked after the Grid is printed from browser Print menu.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.EventParameterAttribute("controlId")]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
public System.string OnAfterPrint {get; set;}
Delphi
public read-write property OnAfterPrint: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked after the Grid is printed from browser Print menu.")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
ISNet.EventParameterAttribute("controlId")
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")
public function get,set OnAfterPrint : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked after the Grid is printed from browser Print menu.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.EventParameterAttribute("controlId")]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
public: __property System.string* get_OnAfterPrint();
public: __property void set_OnAfterPrint(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked after the Grid is printed from browser Print menu.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.EventParameterAttribute("controlId")]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
public:
property System.String^ OnAfterPrint {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ClientEvents Class
ClientEvents Members


OnAfterResponseProcess Property

[image]
Intersoft WebGrid Documentation
OnAfterResponseProcess Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ClientEvents Class : OnAfterResponseProcess Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.EventParameterAttribute("controlId, actionName, lastRequestObject, xmlResponseObject")>
<System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked after the response action of a request has been performed.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
Public Property OnAfterResponseProcess As System.String
Visual Basic (Usage) Copy Code
Dim instance As ClientEvents
Dim value As System.String

instance.OnAfterResponseProcess = value

value = instance.OnAfterResponseProcess
C#
[ISNet.EventParameterAttribute("controlId, actionName, lastRequestObject, xmlResponseObject")]
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked after the response action of a request has been performed.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public System.string OnAfterResponseProcess {get; set;}
Delphi
public read-write property OnAfterResponseProcess: System.String;
JScript
ISNet.EventParameterAttribute("controlId, actionName, lastRequestObject, xmlResponseObject")
System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked after the response action of a request has been performed.")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
public function get,set OnAfterResponseProcess : System.String
Managed Extensions for C++
[ISNet.EventParameterAttribute("controlId, actionName, lastRequestObject, xmlResponseObject")]
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked after the response action of a request has been performed.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.string* get_OnAfterResponseProcess();
public: __property void set_OnAfterResponseProcess(
   System.string* value
);
C++/CLI
[ISNet.EventParameterAttribute("controlId, actionName, lastRequestObject, xmlResponseObject")]
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked after the response action of a request has been performed.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.String^ OnAfterResponseProcess {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ClientEvents Class
ClientEvents Members


OnAfterUpdate Property

[image]
Intersoft WebGrid Documentation
OnAfterUpdate Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ClientEvents Class : OnAfterUpdate Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.EventParameterAttribute("controlId, tblName, rowObject, xmlResponseObject")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked after the update process is done.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property OnAfterUpdate As System.String
Visual Basic (Usage) Copy Code
Dim instance As ClientEvents
Dim value As System.String

instance.OnAfterUpdate = value

value = instance.OnAfterUpdate
C#
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.EventParameterAttribute("controlId, tblName, rowObject, xmlResponseObject")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked after the update process is done.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.string OnAfterUpdate {get; set;}
Delphi
public read-write property OnAfterUpdate: System.String;
JScript
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.EventParameterAttribute("controlId, tblName, rowObject, xmlResponseObject")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked after the update process is done.")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set OnAfterUpdate : System.String
Managed Extensions for C++
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.EventParameterAttribute("controlId, tblName, rowObject, xmlResponseObject")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked after the update process is done.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.string* get_OnAfterUpdate();
public: __property void set_OnAfterUpdate(
   System.string* value
);
C++/CLI
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.EventParameterAttribute("controlId, tblName, rowObject, xmlResponseObject")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked after the update process is done.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.String^ OnAfterUpdate {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ClientEvents Class
ClientEvents Members


OnBatchUpdateError Property

[image]
Intersoft WebGrid Documentation
OnBatchUpdateError Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ClientEvents Class : OnBatchUpdateError Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when one or more records are failed to be updated during batch update process.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.EventParameterAttribute("controlId, errorXml")>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")>
Public Property OnBatchUpdateError As System.String
Visual Basic (Usage) Copy Code
Dim instance As ClientEvents
Dim value As System.String

instance.OnBatchUpdateError = value

value = instance.OnBatchUpdateError
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when one or more records are failed to be updated during batch update process.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.EventParameterAttribute("controlId, errorXml")]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
public System.string OnBatchUpdateError {get; set;}
Delphi
public read-write property OnBatchUpdateError: System.String;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when one or more records are failed to be updated during batch update process.")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
ISNet.EventParameterAttribute("controlId, errorXml")
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")
public function get,set OnBatchUpdateError : System.String
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when one or more records are failed to be updated during batch update process.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.EventParameterAttribute("controlId, errorXml")]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
public: __property System.string* get_OnBatchUpdateError();
public: __property void set_OnBatchUpdateError(
   System.string* value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when one or more records are failed to be updated during batch update process.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.EventParameterAttribute("controlId, errorXml")]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
public:
property System.String^ OnBatchUpdateError {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ClientEvents Class
ClientEvents Members


OnBatchUpdateSuccess Property

[image]
Intersoft WebGrid Documentation
OnBatchUpdateSuccess Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ClientEvents Class : OnBatchUpdateSuccess Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when batch update operation has been successfully completed.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.EventParameterAttribute("controlId, hasPartialErrors, partialErrorsXml")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")>
Public Property OnBatchUpdateSuccess As System.String
Visual Basic (Usage) Copy Code
Dim instance As ClientEvents
Dim value As System.String

instance.OnBatchUpdateSuccess = value

value = instance.OnBatchUpdateSuccess
C#
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when batch update operation has been successfully completed.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.EventParameterAttribute("controlId, hasPartialErrors, partialErrorsXml")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
public System.string OnBatchUpdateSuccess {get; set;}
Delphi
public read-write property OnBatchUpdateSuccess: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when batch update operation has been successfully completed.")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
ISNet.EventParameterAttribute("controlId, hasPartialErrors, partialErrorsXml")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")
public function get,set OnBatchUpdateSuccess : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when batch update operation has been successfully completed.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.EventParameterAttribute("controlId, hasPartialErrors, partialErrorsXml")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
public: __property System.string* get_OnBatchUpdateSuccess();
public: __property void set_OnBatchUpdateSuccess(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when batch update operation has been successfully completed.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.EventParameterAttribute("controlId, hasPartialErrors, partialErrorsXml")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
public:
property System.String^ OnBatchUpdateSuccess {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ClientEvents Class
ClientEvents Members


OnBeforeAdd Property

[image]
Intersoft WebGrid Documentation
OnBeforeAdd Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ClientEvents Class : OnBeforeAdd Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked before new row request is invoked.")>
<ISNet.EventParameterAttribute("controlId, tblName, rowObject")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")>
Public Property OnBeforeAdd As System.String
Visual Basic (Usage) Copy Code
Dim instance As ClientEvents
Dim value As System.String

instance.OnBeforeAdd = value

value = instance.OnBeforeAdd
C#
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked before new row request is invoked.")]
[ISNet.EventParameterAttribute("controlId, tblName, rowObject")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
public System.string OnBeforeAdd {get; set;}
Delphi
public read-write property OnBeforeAdd: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked before new row request is invoked.")
ISNet.EventParameterAttribute("controlId, tblName, rowObject")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")
public function get,set OnBeforeAdd : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked before new row request is invoked.")]
[ISNet.EventParameterAttribute("controlId, tblName, rowObject")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
public: __property System.string* get_OnBeforeAdd();
public: __property void set_OnBeforeAdd(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked before new row request is invoked.")]
[ISNet.EventParameterAttribute("controlId, tblName, rowObject")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
public:
property System.String^ OnBeforeAdd {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ClientEvents Class
ClientEvents Members


OnBeforeDelete Property

[image]
Intersoft WebGrid Documentation
OnBeforeDelete Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ClientEvents Class : OnBeforeDelete Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")>
<ISNet.EventParameterAttribute("controlId, tblName, rowObject")>
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked before delete request is performed.")>
Public Property OnBeforeDelete As System.String
Visual Basic (Usage) Copy Code
Dim instance As ClientEvents
Dim value As System.String

instance.OnBeforeDelete = value

value = instance.OnBeforeDelete
C#
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.EventParameterAttribute("controlId, tblName, rowObject")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked before delete request is performed.")]
public System.string OnBeforeDelete {get; set;}
Delphi
public read-write property OnBeforeDelete: System.String;
JScript
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")
ISNet.EventParameterAttribute("controlId, tblName, rowObject")
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked before delete request is performed.")
public function get,set OnBeforeDelete : System.String
Managed Extensions for C++
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.EventParameterAttribute("controlId, tblName, rowObject")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked before delete request is performed.")]
public: __property System.string* get_OnBeforeDelete();
public: __property void set_OnBeforeDelete(
   System.string* value
);
C++/CLI
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.EventParameterAttribute("controlId, tblName, rowObject")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked before delete request is performed.")]
public:
property System.String^ OnBeforeDelete {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ClientEvents Class
ClientEvents Members


OnBeforePrint Property

[image]
Intersoft WebGrid Documentation
OnBeforePrint Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ClientEvents Class : OnBeforePrint Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked before the Grid is printed from browser Print menu.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.EventParameterAttribute("controlId")>
Public Property OnBeforePrint As System.String
Visual Basic (Usage) Copy Code
Dim instance As ClientEvents
Dim value As System.String

instance.OnBeforePrint = value

value = instance.OnBeforePrint
C#
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked before the Grid is printed from browser Print menu.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.EventParameterAttribute("controlId")]
public System.string OnBeforePrint {get; set;}
Delphi
public read-write property OnBeforePrint: System.String;
JScript
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked before the Grid is printed from browser Print menu.")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
ISNet.EventParameterAttribute("controlId")
public function get,set OnBeforePrint : System.String
Managed Extensions for C++
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked before the Grid is printed from browser Print menu.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.EventParameterAttribute("controlId")]
public: __property System.string* get_OnBeforePrint();
public: __property void set_OnBeforePrint(
   System.string* value
);
C++/CLI
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked before the Grid is printed from browser Print menu.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.EventParameterAttribute("controlId")]
public:
property System.String^ OnBeforePrint {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ClientEvents Class
ClientEvents Members


OnBeforeRequest Property

[image]
Intersoft WebGrid Documentation
OnBeforeRequest Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ClientEvents Class : OnBeforeRequest Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.EventParameterAttribute("controlId, action")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when request action to server is about to be made.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")>
Public Property OnBeforeRequest As System.String
Visual Basic (Usage) Copy Code
Dim instance As ClientEvents
Dim value As System.String

instance.OnBeforeRequest = value

value = instance.OnBeforeRequest
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.EventParameterAttribute("controlId, action")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when request action to server is about to be made.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
public System.string OnBeforeRequest {get; set;}
Delphi
public read-write property OnBeforeRequest: System.String;
JScript
ISNet.Serialization.XmlSerializableAttribute()
ISNet.EventParameterAttribute("controlId, action")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when request action to server is about to be made.")
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")
public function get,set OnBeforeRequest : System.String
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.EventParameterAttribute("controlId, action")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when request action to server is about to be made.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
public: __property System.string* get_OnBeforeRequest();
public: __property void set_OnBeforeRequest(
   System.string* value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.EventParameterAttribute("controlId, action")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when request action to server is about to be made.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
public:
property System.String^ OnBeforeRequest {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ClientEvents Class
ClientEvents Members


OnBeforeRowSelect Property

[image]
Intersoft WebGrid Documentation
OnBeforeRowSelect Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ClientEvents Class : OnBeforeRowSelect Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked before a row is selected.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.EventParameterAttribute("controlId, tblName, lastSelectedObject")>
Public Property OnBeforeRowSelect As System.String
Visual Basic (Usage) Copy Code
Dim instance As ClientEvents
Dim value As System.String

instance.OnBeforeRowSelect = value

value = instance.OnBeforeRowSelect
C#
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked before a row is selected.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.EventParameterAttribute("controlId, tblName, lastSelectedObject")]
public System.string OnBeforeRowSelect {get; set;}
Delphi
public read-write property OnBeforeRowSelect: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked before a row is selected.")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
ISNet.EventParameterAttribute("controlId, tblName, lastSelectedObject")
public function get,set OnBeforeRowSelect : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked before a row is selected.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.EventParameterAttribute("controlId, tblName, lastSelectedObject")]
public: __property System.string* get_OnBeforeRowSelect();
public: __property void set_OnBeforeRowSelect(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked before a row is selected.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.EventParameterAttribute("controlId, tblName, lastSelectedObject")]
public:
property System.String^ OnBeforeRowSelect {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ClientEvents Class
ClientEvents Members


OnBeforeUpdate Property

[image]
Intersoft WebGrid Documentation
OnBeforeUpdate Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ClientEvents Class : OnBeforeUpdate Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.EventParameterAttribute("controlId, tblName, rowObject")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked before the update request is invoked.")>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Property OnBeforeUpdate As System.String
Visual Basic (Usage) Copy Code
Dim instance As ClientEvents
Dim value As System.String

instance.OnBeforeUpdate = value

value = instance.OnBeforeUpdate
C#
[ISNet.EventParameterAttribute("controlId, tblName, rowObject")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked before the update request is invoked.")]
[ISNet.Serialization.XmlSerializableAttribute()]
public System.string OnBeforeUpdate {get; set;}
Delphi
public read-write property OnBeforeUpdate: System.String;
JScript
ISNet.EventParameterAttribute("controlId, tblName, rowObject")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked before the update request is invoked.")
ISNet.Serialization.XmlSerializableAttribute()
public function get,set OnBeforeUpdate : System.String
Managed Extensions for C++
[ISNet.EventParameterAttribute("controlId, tblName, rowObject")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked before the update request is invoked.")]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property System.string* get_OnBeforeUpdate();
public: __property void set_OnBeforeUpdate(
   System.string* value
);
C++/CLI
[ISNet.EventParameterAttribute("controlId, tblName, rowObject")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked before the update request is invoked.")]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property System.String^ OnBeforeUpdate {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ClientEvents Class
ClientEvents Members


OnBeginRowEditing Property

[image]
Intersoft WebGrid Documentation
OnBeginRowEditing Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ClientEvents Class : OnBeginRowEditing Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when users edit a row for the first time.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.EventParameterAttribute("controlId, row")>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")>
Public Property OnBeginRowEditing As System.String
Visual Basic (Usage) Copy Code
Dim instance As ClientEvents
Dim value As System.String

instance.OnBeginRowEditing = value

value = instance.OnBeginRowEditing
C#
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when users edit a row for the first time.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.EventParameterAttribute("controlId, row")]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
public System.string OnBeginRowEditing {get; set;}
Delphi
public read-write property OnBeginRowEditing: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when users edit a row for the first time.")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
ISNet.EventParameterAttribute("controlId, row")
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")
public function get,set OnBeginRowEditing : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when users edit a row for the first time.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.EventParameterAttribute("controlId, row")]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
public: __property System.string* get_OnBeginRowEditing();
public: __property void set_OnBeginRowEditing(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when users edit a row for the first time.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.EventParameterAttribute("controlId, row")]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
public:
property System.String^ OnBeginRowEditing {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ClientEvents Class
ClientEvents Members


OnButtonClick Property

[image]
Intersoft WebGrid Documentation
OnButtonClick Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ClientEvents Class : OnButtonClick Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")>
<ISNet.EventParameterAttribute("controlId, tblName, colName, cellValue")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property OnButtonClick As System.String
Visual Basic (Usage) Copy Code
Dim instance As ClientEvents
Dim value As System.String

instance.OnButtonClick = value

value = instance.OnButtonClick
C#
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.EventParameterAttribute("controlId, tblName, colName, cellValue")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public System.string OnButtonClick {get; set;}
Delphi
public read-write property OnButtonClick: System.String;
JScript
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")
ISNet.EventParameterAttribute("controlId, tblName, colName, cellValue")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute()
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get,set OnButtonClick : System.String
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.EventParameterAttribute("controlId, tblName, colName, cellValue")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.string* get_OnButtonClick();
public: __property void set_OnButtonClick(
   System.string* value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.EventParameterAttribute("controlId, tblName, colName, cellValue")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.String^ OnButtonClick {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ClientEvents Class
ClientEvents Members


OnCalendarSelect Property

[image]
Intersoft WebGrid Documentation
OnCalendarSelect Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ClientEvents Class : OnCalendarSelect Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when selection is made from Calendar popup.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")>
<ISNet.EventParameterAttribute("controlId, editElement, yearValue, monthValue, dayValue")>
Public Property OnCalendarSelect As System.String
Visual Basic (Usage) Copy Code
Dim instance As ClientEvents
Dim value As System.String

instance.OnCalendarSelect = value

value = instance.OnCalendarSelect
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when selection is made from Calendar popup.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.EventParameterAttribute("controlId, editElement, yearValue, monthValue, dayValue")]
public System.string OnCalendarSelect {get; set;}
Delphi
public read-write property OnCalendarSelect: System.String;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when selection is made from Calendar popup.")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")
ISNet.EventParameterAttribute("controlId, editElement, yearValue, monthValue, dayValue")
public function get,set OnCalendarSelect : System.String
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when selection is made from Calendar popup.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.EventParameterAttribute("controlId, editElement, yearValue, monthValue, dayValue")]
public: __property System.string* get_OnCalendarSelect();
public: __property void set_OnCalendarSelect(
   System.string* value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when selection is made from Calendar popup.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.EventParameterAttribute("controlId, editElement, yearValue, monthValue, dayValue")]
public:
property System.String^ OnCalendarSelect {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ClientEvents Class
ClientEvents Members


OnCancelRowEditing Property

[image]
Intersoft WebGrid Documentation
OnCancelRowEditing Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ClientEvents Class : OnCancelRowEditing Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")>
<System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when users canceled row editing.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.EventParameterAttribute("controlId, row")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
Public Property OnCancelRowEditing As System.String
Visual Basic (Usage) Copy Code
Dim instance As ClientEvents
Dim value As System.String

instance.OnCancelRowEditing = value

value = instance.OnCancelRowEditing
C#
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when users canceled row editing.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.EventParameterAttribute("controlId, row")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public System.string OnCancelRowEditing {get; set;}
Delphi
public read-write property OnCancelRowEditing: System.String;
JScript
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")
System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when users canceled row editing.")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
ISNet.EventParameterAttribute("controlId, row")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
public function get,set OnCancelRowEditing : System.String
Managed Extensions for C++
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when users canceled row editing.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.EventParameterAttribute("controlId, row")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.string* get_OnCancelRowEditing();
public: __property void set_OnCancelRowEditing(
   System.string* value
);
C++/CLI
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when users canceled row editing.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.EventParameterAttribute("controlId, row")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.String^ OnCancelRowEditing {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ClientEvents Class
ClientEvents Members


OnCellClick Property

[image]
Intersoft WebGrid Documentation
OnCellClick Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ClientEvents Class : OnCellClick Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")>
<ISNet.EventParameterAttribute("controlId, tblName, rowIndex, cellIndex, cellEl")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when a cell is clicked.")>
Public Property OnCellClick As System.String
Visual Basic (Usage) Copy Code
Dim instance As ClientEvents
Dim value As System.String

instance.OnCellClick = value

value = instance.OnCellClick
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.EventParameterAttribute("controlId, tblName, rowIndex, cellIndex, cellEl")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when a cell is clicked.")]
public System.string OnCellClick {get; set;}
Delphi
public read-write property OnCellClick: System.String;
JScript
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")
ISNet.EventParameterAttribute("controlId, tblName, rowIndex, cellIndex, cellEl")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when a cell is clicked.")
public function get,set OnCellClick : System.String
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.EventParameterAttribute("controlId, tblName, rowIndex, cellIndex, cellEl")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when a cell is clicked.")]
public: __property System.string* get_OnCellClick();
public: __property void set_OnCellClick(
   System.string* value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.EventParameterAttribute("controlId, tblName, rowIndex, cellIndex, cellEl")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when a cell is clicked.")]
public:
property System.String^ OnCellClick {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ClientEvents Class
ClientEvents Members


OnCellDblClick Property

[image]
Intersoft WebGrid Documentation
OnCellDblClick Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ClientEvents Class : OnCellDblClick Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")>
<ISNet.EventParameterAttribute("controlId, tblName, rowIndex, cellIndex, cellEl")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when a cell is double clicked.")>
Public Property OnCellDblClick As System.String
Visual Basic (Usage) Copy Code
Dim instance As ClientEvents
Dim value As System.String

instance.OnCellDblClick = value

value = instance.OnCellDblClick
C#
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.EventParameterAttribute("controlId, tblName, rowIndex, cellIndex, cellEl")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when a cell is double clicked.")]
public System.string OnCellDblClick {get; set;}
Delphi
public read-write property OnCellDblClick: System.String;
JScript
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")
ISNet.EventParameterAttribute("controlId, tblName, rowIndex, cellIndex, cellEl")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when a cell is double clicked.")
public function get,set OnCellDblClick : System.String
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.EventParameterAttribute("controlId, tblName, rowIndex, cellIndex, cellEl")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when a cell is double clicked.")]
public: __property System.string* get_OnCellDblClick();
public: __property void set_OnCellDblClick(
   System.string* value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.EventParameterAttribute("controlId, tblName, rowIndex, cellIndex, cellEl")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when a cell is double clicked.")]
public:
property System.String^ OnCellDblClick {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ClientEvents Class
ClientEvents Members


OnCellSelect Property

[image]
Intersoft WebGrid Documentation
OnCellSelect Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ClientEvents Class : OnCellSelect Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when a cell is selected.")>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")>
<ISNet.EventParameterAttribute("controlId, tblName, rowIndex, cellIndex")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property OnCellSelect As System.String
Visual Basic (Usage) Copy Code
Dim instance As ClientEvents
Dim value As System.String

instance.OnCellSelect = value

value = instance.OnCellSelect
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when a cell is selected.")]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.EventParameterAttribute("controlId, tblName, rowIndex, cellIndex")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public System.string OnCellSelect {get; set;}
Delphi
public read-write property OnCellSelect: System.String;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when a cell is selected.")
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")
ISNet.EventParameterAttribute("controlId, tblName, rowIndex, cellIndex")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get,set OnCellSelect : System.String
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when a cell is selected.")]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.EventParameterAttribute("controlId, tblName, rowIndex, cellIndex")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.string* get_OnCellSelect();
public: __property void set_OnCellSelect(
   System.string* value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when a cell is selected.")]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.EventParameterAttribute("controlId, tblName, rowIndex, cellIndex")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.String^ OnCellSelect {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ClientEvents Class
ClientEvents Members


OnCheckBoxClick Property

[image]
Intersoft WebGrid Documentation
OnCheckBoxClick Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ClientEvents Class : OnCheckBoxClick Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.EventParameterAttribute("controlId, tblName, colName, checkboxValue, originalCheckBoxValue")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when checkbox is clicked.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")>
Public Property OnCheckBoxClick As System.String
Visual Basic (Usage) Copy Code
Dim instance As ClientEvents
Dim value As System.String

instance.OnCheckBoxClick = value

value = instance.OnCheckBoxClick
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.EventParameterAttribute("controlId, tblName, colName, checkboxValue, originalCheckBoxValue")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when checkbox is clicked.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
public System.string OnCheckBoxClick {get; set;}
Delphi
public read-write property OnCheckBoxClick: System.String;
JScript
ISNet.Serialization.BinarySerializableAttribute()
ISNet.EventParameterAttribute("controlId, tblName, colName, checkboxValue, originalCheckBoxValue")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when checkbox is clicked.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")
public function get,set OnCheckBoxClick : System.String
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.EventParameterAttribute("controlId, tblName, colName, checkboxValue, originalCheckBoxValue")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when checkbox is clicked.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
public: __property System.string* get_OnCheckBoxClick();
public: __property void set_OnCheckBoxClick(
   System.string* value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.EventParameterAttribute("controlId, tblName, colName, checkboxValue, originalCheckBoxValue")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when checkbox is clicked.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
public:
property System.String^ OnCheckBoxClick {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ClientEvents Class
ClientEvents Members


OnChildRowCollapse Property

[image]
Intersoft WebGrid Documentation
OnChildRowCollapse Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ClientEvents Class : OnChildRowCollapse Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")>
<ISNet.EventParameterAttribute("controlId, tblName, rowIndex, rowEl")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when a childRow is being collapsed.")>
Public Property OnChildRowCollapse As System.String
Visual Basic (Usage) Copy Code
Dim instance As ClientEvents
Dim value As System.String

instance.OnChildRowCollapse = value

value = instance.OnChildRowCollapse
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.EventParameterAttribute("controlId, tblName, rowIndex, rowEl")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when a childRow is being collapsed.")]
public System.string OnChildRowCollapse {get; set;}
Delphi
public read-write property OnChildRowCollapse: System.String;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")
ISNet.EventParameterAttribute("controlId, tblName, rowIndex, rowEl")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when a childRow is being collapsed.")
public function get,set OnChildRowCollapse : System.String
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.EventParameterAttribute("controlId, tblName, rowIndex, rowEl")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when a childRow is being collapsed.")]
public: __property System.string* get_OnChildRowCollapse();
public: __property void set_OnChildRowCollapse(
   System.string* value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.EventParameterAttribute("controlId, tblName, rowIndex, rowEl")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when a childRow is being collapsed.")]
public:
property System.String^ OnChildRowCollapse {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ClientEvents Class
ClientEvents Members


OnChildRowExpand Property

[image]
Intersoft WebGrid Documentation
OnChildRowExpand Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ClientEvents Class : OnChildRowExpand Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.EventParameterAttribute("controlId, tblName, rowIndex, rowEl")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when a childRow is being expanded.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")>
Public Property OnChildRowExpand As System.String
Visual Basic (Usage) Copy Code
Dim instance As ClientEvents
Dim value As System.String

instance.OnChildRowExpand = value

value = instance.OnChildRowExpand
C#
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.EventParameterAttribute("controlId, tblName, rowIndex, rowEl")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when a childRow is being expanded.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
public System.string OnChildRowExpand {get; set;}
Delphi
public read-write property OnChildRowExpand: System.String;
JScript
System.ComponentModel.DefaultValueAttribute()
ISNet.EventParameterAttribute("controlId, tblName, rowIndex, rowEl")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when a childRow is being expanded.")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")
public function get,set OnChildRowExpand : System.String
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.EventParameterAttribute("controlId, tblName, rowIndex, rowEl")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when a childRow is being expanded.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
public: __property System.string* get_OnChildRowExpand();
public: __property void set_OnChildRowExpand(
   System.string* value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.EventParameterAttribute("controlId, tblName, rowIndex, rowEl")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when a childRow is being expanded.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
public:
property System.String^ OnChildRowExpand {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ClientEvents Class
ClientEvents Members


OnColumnAction Property

[image]
Intersoft WebGrid Documentation
OnColumnAction Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ClientEvents Class : OnColumnAction Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")>
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.EventParameterAttribute("controlId, column")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when users click on the column action indicator.")>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Property OnColumnAction As System.String
Visual Basic (Usage) Copy Code
Dim instance As ClientEvents
Dim value As System.String

instance.OnColumnAction = value

value = instance.OnColumnAction
C#
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.EventParameterAttribute("controlId, column")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when users click on the column action indicator.")]
[ISNet.Serialization.XmlSerializableAttribute()]
public System.string OnColumnAction {get; set;}
Delphi
public read-write property OnColumnAction: System.String;
JScript
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")
ISNet.Serialization.BinarySerializableAttribute()
ISNet.EventParameterAttribute("controlId, column")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when users click on the column action indicator.")
ISNet.Serialization.XmlSerializableAttribute()
public function get,set OnColumnAction : System.String
Managed Extensions for C++
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.EventParameterAttribute("controlId, column")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when users click on the column action indicator.")]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property System.string* get_OnColumnAction();
public: __property void set_OnColumnAction(
   System.string* value
);
C++/CLI
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.EventParameterAttribute("controlId, column")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when users click on the column action indicator.")]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property System.String^ OnColumnAction {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ClientEvents Class
ClientEvents Members


OnColumnChanged Property

[image]
Intersoft WebGrid Documentation
OnColumnChanged Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ClientEvents Class : OnColumnChanged Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")>
<ISNet.EventParameterAttribute("controlId, tblName, colName, action")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when a column is changed. Columns changed means that it is being removed or added directly from WebGrid client UI.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
Public Property OnColumnChanged As System.String
Visual Basic (Usage) Copy Code
Dim instance As ClientEvents
Dim value As System.String

instance.OnColumnChanged = value

value = instance.OnColumnChanged
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.EventParameterAttribute("controlId, tblName, colName, action")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when a column is changed. Columns changed means that it is being removed or added directly from WebGrid client UI.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public System.string OnColumnChanged {get; set;}
Delphi
public read-write property OnColumnChanged: System.String;
JScript
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")
ISNet.EventParameterAttribute("controlId, tblName, colName, action")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when a column is changed. Columns changed means that it is being removed or added directly from WebGrid client UI.")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
public function get,set OnColumnChanged : System.String
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.EventParameterAttribute("controlId, tblName, colName, action")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when a column is changed. Columns changed means that it is being removed or added directly from WebGrid client UI.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.string* get_OnColumnChanged();
public: __property void set_OnColumnChanged(
   System.string* value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.EventParameterAttribute("controlId, tblName, colName, action")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when a column is changed. Columns changed means that it is being removed or added directly from WebGrid client UI.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.String^ OnColumnChanged {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ClientEvents Class
ClientEvents Members


OnColumnContextMenu Property

[image]
Intersoft WebGrid Documentation
OnColumnContextMenu Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ClientEvents Class : OnColumnContextMenu Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when the column's context menu is about to be displayed.")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.EventParameterAttribute("controlId, col, menu, isGroup, location")>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")>
Public Property OnColumnContextMenu As System.String
Visual Basic (Usage) Copy Code
Dim instance As ClientEvents
Dim value As System.String

instance.OnColumnContextMenu = value

value = instance.OnColumnContextMenu
C#
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when the column's context menu is about to be displayed.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.EventParameterAttribute("controlId, col, menu, isGroup, location")]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
public System.string OnColumnContextMenu {get; set;}
Delphi
public read-write property OnColumnContextMenu: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when the column's context menu is about to be displayed.")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
ISNet.EventParameterAttribute("controlId, col, menu, isGroup, location")
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")
public function get,set OnColumnContextMenu : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when the column's context menu is about to be displayed.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.EventParameterAttribute("controlId, col, menu, isGroup, location")]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
public: __property System.string* get_OnColumnContextMenu();
public: __property void set_OnColumnContextMenu(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when the column's context menu is about to be displayed.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.EventParameterAttribute("controlId, col, menu, isGroup, location")]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
public:
property System.String^ OnColumnContextMenu {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ClientEvents Class
ClientEvents Members


OnColumnFilter Property

[image]
Intersoft WebGrid Documentation
OnColumnFilter Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ClientEvents Class : OnColumnFilter Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.EventParameterAttribute("controlId, tableObject")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when a column is about to be filtered by user.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")>
Public Property OnColumnFilter As System.String
Visual Basic (Usage) Copy Code
Dim instance As ClientEvents
Dim value As System.String

instance.OnColumnFilter = value

value = instance.OnColumnFilter
C#
[ISNet.EventParameterAttribute("controlId, tableObject")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when a column is about to be filtered by user.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
public System.string OnColumnFilter {get; set;}
Delphi
public read-write property OnColumnFilter: System.String;
JScript
ISNet.EventParameterAttribute("controlId, tableObject")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when a column is about to be filtered by user.")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")
public function get,set OnColumnFilter : System.String
Managed Extensions for C++
[ISNet.EventParameterAttribute("controlId, tableObject")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when a column is about to be filtered by user.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
public: __property System.string* get_OnColumnFilter();
public: __property void set_OnColumnFilter(
   System.string* value
);
C++/CLI
[ISNet.EventParameterAttribute("controlId, tableObject")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when a column is about to be filtered by user.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
public:
property System.String^ OnColumnFilter {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ClientEvents Class
ClientEvents Members


OnColumnGroup Property

[image]
Intersoft WebGrid Documentation
OnColumnGroup Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ClientEvents Class : OnColumnGroup Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when a column is about to be grouped by user.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.EventParameterAttribute("controlId, columnObject")>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property OnColumnGroup As System.String
Visual Basic (Usage) Copy Code
Dim instance As ClientEvents
Dim value As System.String

instance.OnColumnGroup = value

value = instance.OnColumnGroup
C#
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when a column is about to be grouped by user.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.EventParameterAttribute("controlId, columnObject")]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.string OnColumnGroup {get; set;}
Delphi
public read-write property OnColumnGroup: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when a column is about to be grouped by user.")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
ISNet.EventParameterAttribute("controlId, columnObject")
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set OnColumnGroup : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when a column is about to be grouped by user.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.EventParameterAttribute("controlId, columnObject")]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.string* get_OnColumnGroup();
public: __property void set_OnColumnGroup(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when a column is about to be grouped by user.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.EventParameterAttribute("controlId, columnObject")]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.String^ OnColumnGroup {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ClientEvents Class
ClientEvents Members


OnColumnGroupChange Property

[image]
Intersoft WebGrid Documentation
OnColumnGroupChange Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ClientEvents Class : OnColumnGroupChange Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when a group column's order is about to be changed by user.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")>
<ISNet.EventParameterAttribute("controlId, columnObject")>
Public Property OnColumnGroupChange As System.String
Visual Basic (Usage) Copy Code
Dim instance As ClientEvents
Dim value As System.String

instance.OnColumnGroupChange = value

value = instance.OnColumnGroupChange
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when a group column's order is about to be changed by user.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.EventParameterAttribute("controlId, columnObject")]
public System.string OnColumnGroupChange {get; set;}
Delphi
public read-write property OnColumnGroupChange: System.String;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when a group column's order is about to be changed by user.")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")
ISNet.EventParameterAttribute("controlId, columnObject")
public function get,set OnColumnGroupChange : System.String
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when a group column's order is about to be changed by user.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.EventParameterAttribute("controlId, columnObject")]
public: __property System.string* get_OnColumnGroupChange();
public: __property void set_OnColumnGroupChange(
   System.string* value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when a group column's order is about to be changed by user.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.EventParameterAttribute("controlId, columnObject")]
public:
property System.String^ OnColumnGroupChange {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ClientEvents Class
ClientEvents Members


OnColumnMove Property

[image]
Intersoft WebGrid Documentation
OnColumnMove Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ClientEvents Class : OnColumnMove Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")>
<ISNet.EventParameterAttribute("controlId, tblName, sourceIndex, targetIndex, sourceColumn, targetColumn")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when a column is being moved.")>
Public Property OnColumnMove As System.String
Visual Basic (Usage) Copy Code
Dim instance As ClientEvents
Dim value As System.String

instance.OnColumnMove = value

value = instance.OnColumnMove
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.EventParameterAttribute("controlId, tblName, sourceIndex, targetIndex, sourceColumn, targetColumn")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when a column is being moved.")]
public System.string OnColumnMove {get; set;}
Delphi
public read-write property OnColumnMove: System.String;
JScript
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")
ISNet.EventParameterAttribute("controlId, tblName, sourceIndex, targetIndex, sourceColumn, targetColumn")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when a column is being moved.")
public function get,set OnColumnMove : System.String
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.EventParameterAttribute("controlId, tblName, sourceIndex, targetIndex, sourceColumn, targetColumn")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when a column is being moved.")]
public: __property System.string* get_OnColumnMove();
public: __property void set_OnColumnMove(
   System.string* value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.EventParameterAttribute("controlId, tblName, sourceIndex, targetIndex, sourceColumn, targetColumn")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when a column is being moved.")]
public:
property System.String^ OnColumnMove {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ClientEvents Class
ClientEvents Members


OnColumnResize Property

[image]
Intersoft WebGrid Documentation
OnColumnResize Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ClientEvents Class : OnColumnResize Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when a column is being resized.")>
<ISNet.EventParameterAttribute("controlId, tblName, column, width")>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")>
Public Property OnColumnResize As System.String
Visual Basic (Usage) Copy Code
Dim instance As ClientEvents
Dim value As System.String

instance.OnColumnResize = value

value = instance.OnColumnResize
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when a column is being resized.")]
[ISNet.EventParameterAttribute("controlId, tblName, column, width")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
public System.string OnColumnResize {get; set;}
Delphi
public read-write property OnColumnResize: System.String;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when a column is being resized.")
ISNet.EventParameterAttribute("controlId, tblName, column, width")
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")
public function get,set OnColumnResize : System.String
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when a column is being resized.")]
[ISNet.EventParameterAttribute("controlId, tblName, column, width")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
public: __property System.string* get_OnColumnResize();
public: __property void set_OnColumnResize(
   System.string* value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when a column is being resized.")]
[ISNet.EventParameterAttribute("controlId, tblName, column, width")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
public:
property System.String^ OnColumnResize {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ClientEvents Class
ClientEvents Members


OnColumnSort Property

[image]
Intersoft WebGrid Documentation
OnColumnSort Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ClientEvents Class : OnColumnSort Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when a column is about to be sorted by user.")>
<ISNet.EventParameterAttribute("controlId, columnObject")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")>
Public Property OnColumnSort As System.String
Visual Basic (Usage) Copy Code
Dim instance As ClientEvents
Dim value As System.String

instance.OnColumnSort = value

value = instance.OnColumnSort
C#
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when a column is about to be sorted by user.")]
[ISNet.EventParameterAttribute("controlId, columnObject")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
public System.string OnColumnSort {get; set;}
Delphi
public read-write property OnColumnSort: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when a column is about to be sorted by user.")
ISNet.EventParameterAttribute("controlId, columnObject")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")
public function get,set OnColumnSort : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when a column is about to be sorted by user.")]
[ISNet.EventParameterAttribute("controlId, columnObject")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
public: __property System.string* get_OnColumnSort();
public: __property void set_OnColumnSort(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when a column is about to be sorted by user.")]
[ISNet.EventParameterAttribute("controlId, columnObject")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
public:
property System.String^ OnColumnSort {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ClientEvents Class
ClientEvents Members


OnColumnUngroup Property

[image]
Intersoft WebGrid Documentation
OnColumnUngroup Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ClientEvents Class : OnColumnUngroup Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when a column is about to be ungrouped by user.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.EventParameterAttribute("controlId, columnObject")>
Public Property OnColumnUngroup As System.String
Visual Basic (Usage) Copy Code
Dim instance As ClientEvents
Dim value As System.String

instance.OnColumnUngroup = value

value = instance.OnColumnUngroup
C#
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when a column is about to be ungrouped by user.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.EventParameterAttribute("controlId, columnObject")]
public System.string OnColumnUngroup {get; set;}
Delphi
public read-write property OnColumnUngroup: System.String;
JScript
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when a column is about to be ungrouped by user.")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.EventParameterAttribute("controlId, columnObject")
public function get,set OnColumnUngroup : System.String
Managed Extensions for C++
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when a column is about to be ungrouped by user.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.EventParameterAttribute("controlId, columnObject")]
public: __property System.string* get_OnColumnUngroup();
public: __property void set_OnColumnUngroup(
   System.string* value
);
C++/CLI
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when a column is about to be ungrouped by user.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.EventParameterAttribute("controlId, columnObject")]
public:
property System.String^ OnColumnUngroup {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ClientEvents Class
ClientEvents Members


OnComboItemCheck Property

[image]
Intersoft WebGrid Documentation
OnComboItemCheck Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ClientEvents Class : OnComboItemCheck Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when a checkbox on WebComboItem is checked/unchecked.")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")>
<ISNet.EventParameterAttribute("controlId, comboId, checkboxEl")>
Public Property OnComboItemCheck As System.String
Visual Basic (Usage) Copy Code
Dim instance As ClientEvents
Dim value As System.String

instance.OnComboItemCheck = value

value = instance.OnComboItemCheck
C#
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when a checkbox on WebComboItem is checked/unchecked.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.EventParameterAttribute("controlId, comboId, checkboxEl")]
public System.string OnComboItemCheck {get; set;}
Delphi
public read-write property OnComboItemCheck: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when a checkbox on WebComboItem is checked/unchecked.")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")
ISNet.EventParameterAttribute("controlId, comboId, checkboxEl")
public function get,set OnComboItemCheck : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when a checkbox on WebComboItem is checked/unchecked.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.EventParameterAttribute("controlId, comboId, checkboxEl")]
public: __property System.string* get_OnComboItemCheck();
public: __property void set_OnComboItemCheck(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when a checkbox on WebComboItem is checked/unchecked.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.EventParameterAttribute("controlId, comboId, checkboxEl")]
public:
property System.String^ OnComboItemCheck {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ClientEvents Class
ClientEvents Members


OnCustomAggregate Property

[image]
Intersoft WebGrid Documentation
OnCustomAggregate Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ClientEvents Class : OnCustomAggregate Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.EventParameterAttribute("controlId, columns, rows, type")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when batch update operation has been successfully completed.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")>
Public Property OnCustomAggregate As System.String
Visual Basic (Usage) Copy Code
Dim instance As ClientEvents
Dim value As System.String

instance.OnCustomAggregate = value

value = instance.OnCustomAggregate
C#
[ISNet.EventParameterAttribute("controlId, columns, rows, type")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when batch update operation has been successfully completed.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
public System.string OnCustomAggregate {get; set;}
Delphi
public read-write property OnCustomAggregate: System.String;
JScript
ISNet.EventParameterAttribute("controlId, columns, rows, type")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when batch update operation has been successfully completed.")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")
public function get,set OnCustomAggregate : System.String
Managed Extensions for C++
[ISNet.EventParameterAttribute("controlId, columns, rows, type")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when batch update operation has been successfully completed.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
public: __property System.string* get_OnCustomAggregate();
public: __property void set_OnCustomAggregate(
   System.string* value
);
C++/CLI
[ISNet.EventParameterAttribute("controlId, columns, rows, type")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when batch update operation has been successfully completed.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
public:
property System.String^ OnCustomAggregate {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ClientEvents Class
ClientEvents Members


OnDataBound Property

[image]
Intersoft WebGrid Documentation
OnDataBound Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ClientEvents Class : OnDataBound Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when WebGrid has completed the data binding process in client binding mode.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.EventParameterAttribute("controlId")>
Public Property OnDataBound As System.String
Visual Basic (Usage) Copy Code
Dim instance As ClientEvents
Dim value As System.String

instance.OnDataBound = value

value = instance.OnDataBound
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when WebGrid has completed the data binding process in client binding mode.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.EventParameterAttribute("controlId")]
public System.string OnDataBound {get; set;}
Delphi
public read-write property OnDataBound: System.String;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when WebGrid has completed the data binding process in client binding mode.")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.EventParameterAttribute("controlId")
public function get,set OnDataBound : System.String
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when WebGrid has completed the data binding process in client binding mode.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.EventParameterAttribute("controlId")]
public: __property System.string* get_OnDataBound();
public: __property void set_OnDataBound(
   System.string* value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when WebGrid has completed the data binding process in client binding mode.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.EventParameterAttribute("controlId")]
public:
property System.String^ OnDataBound {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ClientEvents Class
ClientEvents Members


OnDataSourceChanged Property

[image]
Intersoft WebGrid Documentation
OnDataSourceChanged Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ClientEvents Class : OnDataSourceChanged Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")>
<ISNet.EventParameterAttribute("controlId")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when a new datasource is assigned to WebGrid in client binding mode.")>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property OnDataSourceChanged As System.String
Visual Basic (Usage) Copy Code
Dim instance As ClientEvents
Dim value As System.String

instance.OnDataSourceChanged = value

value = instance.OnDataSourceChanged
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.EventParameterAttribute("controlId")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when a new datasource is assigned to WebGrid in client binding mode.")]
[ISNet.Serialization.BinarySerializableAttribute()]
public System.string OnDataSourceChanged {get; set;}
Delphi
public read-write property OnDataSourceChanged: System.String;
JScript
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")
ISNet.EventParameterAttribute("controlId")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when a new datasource is assigned to WebGrid in client binding mode.")
ISNet.Serialization.BinarySerializableAttribute()
public function get,set OnDataSourceChanged : System.String
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.EventParameterAttribute("controlId")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when a new datasource is assigned to WebGrid in client binding mode.")]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.string* get_OnDataSourceChanged();
public: __property void set_OnDataSourceChanged(
   System.string* value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.EventParameterAttribute("controlId")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when a new datasource is assigned to WebGrid in client binding mode.")]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.String^ OnDataSourceChanged {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ClientEvents Class
ClientEvents Members


OnEditKeyDown Property

[image]
Intersoft WebGrid Documentation
OnEditKeyDown Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ClientEvents Class : OnEditKeyDown Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.EventParameterAttribute("controlId")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when keypress is detected during editing mode (edit control is in focus).")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")>
Public Property OnEditKeyDown As System.String
Visual Basic (Usage) Copy Code
Dim instance As ClientEvents
Dim value As System.String

instance.OnEditKeyDown = value

value = instance.OnEditKeyDown
C#
[ISNet.EventParameterAttribute("controlId")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when keypress is detected during editing mode (edit control is in focus).")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
public System.string OnEditKeyDown {get; set;}
Delphi
public read-write property OnEditKeyDown: System.String;
JScript
ISNet.EventParameterAttribute("controlId")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when keypress is detected during editing mode (edit control is in focus).")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")
public function get,set OnEditKeyDown : System.String
Managed Extensions for C++
[ISNet.EventParameterAttribute("controlId")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when keypress is detected during editing mode (edit control is in focus).")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
public: __property System.string* get_OnEditKeyDown();
public: __property void set_OnEditKeyDown(
   System.string* value
);
C++/CLI
[ISNet.EventParameterAttribute("controlId")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when keypress is detected during editing mode (edit control is in focus).")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
public:
property System.String^ OnEditKeyDown {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ClientEvents Class
ClientEvents Members


OnEndRowEditing Property

[image]
Intersoft WebGrid Documentation
OnEndRowEditing Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ClientEvents Class : OnEndRowEditing Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.EventParameterAttribute("controlId, row")>
<System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when users ended row editing.")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property OnEndRowEditing As System.String
Visual Basic (Usage) Copy Code
Dim instance As ClientEvents
Dim value As System.String

instance.OnEndRowEditing = value

value = instance.OnEndRowEditing
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.EventParameterAttribute("controlId, row")]
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when users ended row editing.")]
[System.ComponentModel.DefaultValueAttribute()]
public System.string OnEndRowEditing {get; set;}
Delphi
public read-write property OnEndRowEditing: System.String;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
ISNet.EventParameterAttribute("controlId, row")
System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when users ended row editing.")
System.ComponentModel.DefaultValueAttribute()
public function get,set OnEndRowEditing : System.String
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.EventParameterAttribute("controlId, row")]
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when users ended row editing.")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.string* get_OnEndRowEditing();
public: __property void set_OnEndRowEditing(
   System.string* value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.EventParameterAttribute("controlId, row")]
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when users ended row editing.")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.String^ OnEndRowEditing {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ClientEvents Class
ClientEvents Members


OnEnterEditMode Property

[image]
Intersoft WebGrid Documentation
OnEnterEditMode Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ClientEvents Class : OnEnterEditMode Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.EventParameterAttribute("controlId, tblName, editObject")>
<System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when edit mode is about to be activated.")>
Public Property OnEnterEditMode As System.String
Visual Basic (Usage) Copy Code
Dim instance As ClientEvents
Dim value As System.String

instance.OnEnterEditMode = value

value = instance.OnEnterEditMode
C#
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.EventParameterAttribute("controlId, tblName, editObject")]
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when edit mode is about to be activated.")]
public System.string OnEnterEditMode {get; set;}
Delphi
public read-write property OnEnterEditMode: System.String;
JScript
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.EventParameterAttribute("controlId, tblName, editObject")
System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when edit mode is about to be activated.")
public function get,set OnEnterEditMode : System.String
Managed Extensions for C++
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.EventParameterAttribute("controlId, tblName, editObject")]
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when edit mode is about to be activated.")]
public: __property System.string* get_OnEnterEditMode();
public: __property void set_OnEnterEditMode(
   System.string* value
);
C++/CLI
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.EventParameterAttribute("controlId, tblName, editObject")]
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when edit mode is about to be activated.")]
public:
property System.String^ OnEnterEditMode {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ClientEvents Class
ClientEvents Members


OnExitEditMode Property

[image]
Intersoft WebGrid Documentation
OnExitEditMode Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ClientEvents Class : OnExitEditMode Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when edit mode is being ended.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")>
<ISNet.EventParameterAttribute("controlId, tblName, editObject")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property OnExitEditMode As System.String
Visual Basic (Usage) Copy Code
Dim instance As ClientEvents
Dim value As System.String

instance.OnExitEditMode = value

value = instance.OnExitEditMode
C#
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when edit mode is being ended.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.EventParameterAttribute("controlId, tblName, editObject")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.string OnExitEditMode {get; set;}
Delphi
public read-write property OnExitEditMode: System.String;
JScript
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when edit mode is being ended.")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")
ISNet.EventParameterAttribute("controlId, tblName, editObject")
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set OnExitEditMode : System.String
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when edit mode is being ended.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.EventParameterAttribute("controlId, tblName, editObject")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.string* get_OnExitEditMode();
public: __property void set_OnExitEditMode(
   System.string* value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when edit mode is being ended.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.EventParameterAttribute("controlId, tblName, editObject")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.String^ OnExitEditMode {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ClientEvents Class
ClientEvents Members


OnExportContextMenu Property

[image]
Intersoft WebGrid Documentation
OnExportContextMenu Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ClientEvents Class : OnExportContextMenu Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when the exporting  context menu is about to be displayed.")>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.EventParameterAttribute("controlId, table, menu, location")>
Public Property OnExportContextMenu As System.String
Visual Basic (Usage) Copy Code
Dim instance As ClientEvents
Dim value As System.String

instance.OnExportContextMenu = value

value = instance.OnExportContextMenu
C#
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when the exporting  context menu is about to be displayed.")]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.EventParameterAttribute("controlId, table, menu, location")]
public System.string OnExportContextMenu {get; set;}
Delphi
public read-write property OnExportContextMenu: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when the exporting  context menu is about to be displayed.")
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
ISNet.EventParameterAttribute("controlId, table, menu, location")
public function get,set OnExportContextMenu : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when the exporting  context menu is about to be displayed.")]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.EventParameterAttribute("controlId, table, menu, location")]
public: __property System.string* get_OnExportContextMenu();
public: __property void set_OnExportContextMenu(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when the exporting  context menu is about to be displayed.")]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.EventParameterAttribute("controlId, table, menu, location")]
public:
property System.String^ OnExportContextMenu {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ClientEvents Class
ClientEvents Members


OnFilterContextMenu Property

[image]
Intersoft WebGrid Documentation
OnFilterContextMenu Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ClientEvents Class : OnFilterContextMenu Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")>
<System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when the column filter's context menu is about to be displayed.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.EventParameterAttribute("controlId, col, menu, location")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property OnFilterContextMenu As System.String
Visual Basic (Usage) Copy Code
Dim instance As ClientEvents
Dim value As System.String

instance.OnFilterContextMenu = value

value = instance.OnFilterContextMenu
C#
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when the column filter's context menu is about to be displayed.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.EventParameterAttribute("controlId, col, menu, location")]
[System.ComponentModel.DefaultValueAttribute()]
public System.string OnFilterContextMenu {get; set;}
Delphi
public read-write property OnFilterContextMenu: System.String;
JScript
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")
System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when the column filter's context menu is about to be displayed.")
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
ISNet.EventParameterAttribute("controlId, col, menu, location")
System.ComponentModel.DefaultValueAttribute()
public function get,set OnFilterContextMenu : System.String
Managed Extensions for C++
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when the column filter's context menu is about to be displayed.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.EventParameterAttribute("controlId, col, menu, location")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.string* get_OnFilterContextMenu();
public: __property void set_OnFilterContextMenu(
   System.string* value
);
C++/CLI
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when the column filter's context menu is about to be displayed.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.EventParameterAttribute("controlId, col, menu, location")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.String^ OnFilterContextMenu {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ClientEvents Class
ClientEvents Members


OnFocus Property

[image]
Intersoft WebGrid Documentation
OnFocus Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ClientEvents Class : OnFocus Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.EventParameterAttribute("controlId")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")>
Public Property OnFocus As System.String
Visual Basic (Usage) Copy Code
Dim instance As ClientEvents
Dim value As System.String

instance.OnFocus = value

value = instance.OnFocus
C#
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.EventParameterAttribute("controlId")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
public System.string OnFocus {get; set;}
Delphi
public read-write property OnFocus: System.String;
JScript
System.ComponentModel.DefaultValueAttribute()
ISNet.EventParameterAttribute("controlId")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute()
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")
public function get,set OnFocus : System.String
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.EventParameterAttribute("controlId")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
public: __property System.string* get_OnFocus();
public: __property void set_OnFocus(
   System.string* value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.EventParameterAttribute("controlId")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
public:
property System.String^ OnFocus {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ClientEvents Class
ClientEvents Members


OnGroupCollapse Property

[image]
Intersoft WebGrid Documentation
OnGroupCollapse Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ClientEvents Class : OnGroupCollapse Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")>
<ISNet.EventParameterAttribute("controlId, tblName, groupIndex, rowPosition, rowIndex")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when a group is being collapsed.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
Public Property OnGroupCollapse As System.String
Visual Basic (Usage) Copy Code
Dim instance As ClientEvents
Dim value As System.String

instance.OnGroupCollapse = value

value = instance.OnGroupCollapse
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.EventParameterAttribute("controlId, tblName, groupIndex, rowPosition, rowIndex")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when a group is being collapsed.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public System.string OnGroupCollapse {get; set;}
Delphi
public read-write property OnGroupCollapse: System.String;
JScript
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")
ISNet.EventParameterAttribute("controlId, tblName, groupIndex, rowPosition, rowIndex")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when a group is being collapsed.")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
public function get,set OnGroupCollapse : System.String
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.EventParameterAttribute("controlId, tblName, groupIndex, rowPosition, rowIndex")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when a group is being collapsed.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.string* get_OnGroupCollapse();
public: __property void set_OnGroupCollapse(
   System.string* value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.EventParameterAttribute("controlId, tblName, groupIndex, rowPosition, rowIndex")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when a group is being collapsed.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.String^ OnGroupCollapse {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ClientEvents Class
ClientEvents Members


OnGroupExpand Property

[image]
Intersoft WebGrid Documentation
OnGroupExpand Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ClientEvents Class : OnGroupExpand Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when a group is being expanded.")>
<ISNet.EventParameterAttribute("controlId, tblName, groupIndex, rowPosition, rowIndex")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")>
Public Property OnGroupExpand As System.String
Visual Basic (Usage) Copy Code
Dim instance As ClientEvents
Dim value As System.String

instance.OnGroupExpand = value

value = instance.OnGroupExpand
C#
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when a group is being expanded.")]
[ISNet.EventParameterAttribute("controlId, tblName, groupIndex, rowPosition, rowIndex")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
public System.string OnGroupExpand {get; set;}
Delphi
public read-write property OnGroupExpand: System.String;
JScript
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when a group is being expanded.")
ISNet.EventParameterAttribute("controlId, tblName, groupIndex, rowPosition, rowIndex")
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")
public function get,set OnGroupExpand : System.String
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when a group is being expanded.")]
[ISNet.EventParameterAttribute("controlId, tblName, groupIndex, rowPosition, rowIndex")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
public: __property System.string* get_OnGroupExpand();
public: __property void set_OnGroupExpand(
   System.string* value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when a group is being expanded.")]
[ISNet.EventParameterAttribute("controlId, tblName, groupIndex, rowPosition, rowIndex")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
public:
property System.String^ OnGroupExpand {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ClientEvents Class
ClientEvents Members


OnInitialize Property

[image]
Intersoft WebGrid Documentation
OnInitialize Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ClientEvents Class : OnInitialize Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when the grid is in initialization process.")>
<ISNet.EventParameterAttribute("controlId")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")>
Public Property OnInitialize As System.String
Visual Basic (Usage) Copy Code
Dim instance As ClientEvents
Dim value As System.String

instance.OnInitialize = value

value = instance.OnInitialize
C#
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when the grid is in initialization process.")]
[ISNet.EventParameterAttribute("controlId")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
public System.string OnInitialize {get; set;}
Delphi
public read-write property OnInitialize: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when the grid is in initialization process.")
ISNet.EventParameterAttribute("controlId")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")
public function get,set OnInitialize : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when the grid is in initialization process.")]
[ISNet.EventParameterAttribute("controlId")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
public: __property System.string* get_OnInitialize();
public: __property void set_OnInitialize(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when the grid is in initialization process.")]
[ISNet.EventParameterAttribute("controlId")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
public:
property System.String^ OnInitialize {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ClientEvents Class
ClientEvents Members


OnInitializeCell Property

[image]
Intersoft WebGrid Documentation
OnInitializeCell Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ClientEvents Class : OnInitializeCell Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.EventParameterAttribute("controlId, cell")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when a WebGridCell is initialized in client binding mode.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")>
Public Property OnInitializeCell As System.String
Visual Basic (Usage) Copy Code
Dim instance As ClientEvents
Dim value As System.String

instance.OnInitializeCell = value

value = instance.OnInitializeCell
C#
[ISNet.EventParameterAttribute("controlId, cell")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when a WebGridCell is initialized in client binding mode.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
public System.string OnInitializeCell {get; set;}
Delphi
public read-write property OnInitializeCell: System.String;
JScript
ISNet.EventParameterAttribute("controlId, cell")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when a WebGridCell is initialized in client binding mode.")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")
public function get,set OnInitializeCell : System.String
Managed Extensions for C++
[ISNet.EventParameterAttribute("controlId, cell")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when a WebGridCell is initialized in client binding mode.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
public: __property System.string* get_OnInitializeCell();
public: __property void set_OnInitializeCell(
   System.string* value
);
C++/CLI
[ISNet.EventParameterAttribute("controlId, cell")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when a WebGridCell is initialized in client binding mode.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
public:
property System.String^ OnInitializeCell {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ClientEvents Class
ClientEvents Members


OnInitializeCustomEditor Property

[image]
Intersoft WebGrid Documentation
OnInitializeCustomEditor Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ClientEvents Class : OnInitializeCustomEditor Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")>
<System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when a custom editor is about to be initialized.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.EventParameterAttribute("controlId, editorName, editorObject, customEditor")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property OnInitializeCustomEditor As System.String
Visual Basic (Usage) Copy Code
Dim instance As ClientEvents
Dim value As System.String

instance.OnInitializeCustomEditor = value

value = instance.OnInitializeCustomEditor
C#
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when a custom editor is about to be initialized.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.EventParameterAttribute("controlId, editorName, editorObject, customEditor")]
[System.ComponentModel.DefaultValueAttribute()]
public System.string OnInitializeCustomEditor {get; set;}
Delphi
public read-write property OnInitializeCustomEditor: System.String;
JScript
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")
System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when a custom editor is about to be initialized.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
ISNet.EventParameterAttribute("controlId, editorName, editorObject, customEditor")
System.ComponentModel.DefaultValueAttribute()
public function get,set OnInitializeCustomEditor : System.String
Managed Extensions for C++
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when a custom editor is about to be initialized.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.EventParameterAttribute("controlId, editorName, editorObject, customEditor")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.string* get_OnInitializeCustomEditor();
public: __property void set_OnInitializeCustomEditor(
   System.string* value
);
C++/CLI
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when a custom editor is about to be initialized.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.EventParameterAttribute("controlId, editorName, editorObject, customEditor")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.String^ OnInitializeCustomEditor {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ClientEvents Class
ClientEvents Members


OnInitializeRow Property

[image]
Intersoft WebGrid Documentation
OnInitializeRow Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ClientEvents Class : OnInitializeRow Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.EventParameterAttribute("controlId, row")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when a WebGridRow is initialized in client binding mode.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")>
Public Property OnInitializeRow As System.String
Visual Basic (Usage) Copy Code
Dim instance As ClientEvents
Dim value As System.String

instance.OnInitializeRow = value

value = instance.OnInitializeRow
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.EventParameterAttribute("controlId, row")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when a WebGridRow is initialized in client binding mode.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
public System.string OnInitializeRow {get; set;}
Delphi
public read-write property OnInitializeRow: System.String;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.EventParameterAttribute("controlId, row")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when a WebGridRow is initialized in client binding mode.")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")
public function get,set OnInitializeRow : System.String
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.EventParameterAttribute("controlId, row")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when a WebGridRow is initialized in client binding mode.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
public: __property System.string* get_OnInitializeRow();
public: __property void set_OnInitializeRow(
   System.string* value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.EventParameterAttribute("controlId, row")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when a WebGridRow is initialized in client binding mode.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
public:
property System.String^ OnInitializeRow {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ClientEvents Class
ClientEvents Members


OnKeyDown Property

[image]
Intersoft WebGrid Documentation
OnKeyDown Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ClientEvents Class : OnKeyDown Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")>
<ISNet.EventParameterAttribute("controlId, tblName, rowIndex, cellIndex")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when keystroke is being made.")>
Public Property OnKeyDown As System.String
Visual Basic (Usage) Copy Code
Dim instance As ClientEvents
Dim value As System.String

instance.OnKeyDown = value

value = instance.OnKeyDown
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.EventParameterAttribute("controlId, tblName, rowIndex, cellIndex")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when keystroke is being made.")]
public System.string OnKeyDown {get; set;}
Delphi
public read-write property OnKeyDown: System.String;
JScript
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")
ISNet.EventParameterAttribute("controlId, tblName, rowIndex, cellIndex")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when keystroke is being made.")
public function get,set OnKeyDown : System.String
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.EventParameterAttribute("controlId, tblName, rowIndex, cellIndex")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when keystroke is being made.")]
public: __property System.string* get_OnKeyDown();
public: __property void set_OnKeyDown(
   System.string* value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.EventParameterAttribute("controlId, tblName, rowIndex, cellIndex")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when keystroke is being made.")]
public:
property System.String^ OnKeyDown {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ClientEvents Class
ClientEvents Members


OnKeyUp Property

[image]
Intersoft WebGrid Documentation
OnKeyUp Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ClientEvents Class : OnKeyUp Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")>
<ISNet.EventParameterAttribute("controlId, tblName, rowIndex, cellIndex")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked after keystroke is made.")>
Public Property OnKeyUp As System.String
Visual Basic (Usage) Copy Code
Dim instance As ClientEvents
Dim value As System.String

instance.OnKeyUp = value

value = instance.OnKeyUp
C#
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.EventParameterAttribute("controlId, tblName, rowIndex, cellIndex")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked after keystroke is made.")]
public System.string OnKeyUp {get; set;}
Delphi
public read-write property OnKeyUp: System.String;
JScript
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")
ISNet.EventParameterAttribute("controlId, tblName, rowIndex, cellIndex")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked after keystroke is made.")
public function get,set OnKeyUp : System.String
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.EventParameterAttribute("controlId, tblName, rowIndex, cellIndex")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked after keystroke is made.")]
public: __property System.string* get_OnKeyUp();
public: __property void set_OnKeyUp(
   System.string* value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.EventParameterAttribute("controlId, tblName, rowIndex, cellIndex")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked after keystroke is made.")]
public:
property System.String^ OnKeyUp {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ClientEvents Class
ClientEvents Members


OnLostFocus Property

[image]
Intersoft WebGrid Documentation
OnLostFocus Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ClientEvents Class : OnLostFocus Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")>
<ISNet.EventParameterAttribute("controlId")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property OnLostFocus As System.String
Visual Basic (Usage) Copy Code
Dim instance As ClientEvents
Dim value As System.String

instance.OnLostFocus = value

value = instance.OnLostFocus
C#
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.EventParameterAttribute("controlId")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public System.string OnLostFocus {get; set;}
Delphi
public read-write property OnLostFocus: System.String;
JScript
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")
ISNet.EventParameterAttribute("controlId")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute()
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get,set OnLostFocus : System.String
Managed Extensions for C++
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.EventParameterAttribute("controlId")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.string* get_OnLostFocus();
public: __property void set_OnLostFocus(
   System.string* value
);
C++/CLI
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.EventParameterAttribute("controlId")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.String^ OnLostFocus {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ClientEvents Class
ClientEvents Members


OnPostRender Property

[image]
Intersoft WebGrid Documentation
OnPostRender Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ClientEvents Class : OnPostRender Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked after data rendering has been completed in client binding mode.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.EventParameterAttribute("controlId")>
Public Property OnPostRender As System.String
Visual Basic (Usage) Copy Code
Dim instance As ClientEvents
Dim value As System.String

instance.OnPostRender = value

value = instance.OnPostRender
C#
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked after data rendering has been completed in client binding mode.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.EventParameterAttribute("controlId")]
public System.string OnPostRender {get; set;}
Delphi
public read-write property OnPostRender: System.String;
JScript
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked after data rendering has been completed in client binding mode.")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
ISNet.EventParameterAttribute("controlId")
public function get,set OnPostRender : System.String
Managed Extensions for C++
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked after data rendering has been completed in client binding mode.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.EventParameterAttribute("controlId")]
public: __property System.string* get_OnPostRender();
public: __property void set_OnPostRender(
   System.string* value
);
C++/CLI
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked after data rendering has been completed in client binding mode.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.EventParameterAttribute("controlId")]
public:
property System.String^ OnPostRender {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ClientEvents Class
ClientEvents Members


OnPreRender Property

[image]
Intersoft WebGrid Documentation
OnPreRender Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ClientEvents Class : OnPreRender Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")>
<ISNet.EventParameterAttribute("controlId")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked before data rendering phase in client binding mode.")>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property OnPreRender As System.String
Visual Basic (Usage) Copy Code
Dim instance As ClientEvents
Dim value As System.String

instance.OnPreRender = value

value = instance.OnPreRender
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.EventParameterAttribute("controlId")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked before data rendering phase in client binding mode.")]
[ISNet.Serialization.BinarySerializableAttribute()]
public System.string OnPreRender {get; set;}
Delphi
public read-write property OnPreRender: System.String;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")
ISNet.EventParameterAttribute("controlId")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked before data rendering phase in client binding mode.")
ISNet.Serialization.BinarySerializableAttribute()
public function get,set OnPreRender : System.String
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.EventParameterAttribute("controlId")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked before data rendering phase in client binding mode.")]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.string* get_OnPreRender();
public: __property void set_OnPreRender(
   System.string* value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.EventParameterAttribute("controlId")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked before data rendering phase in client binding mode.")]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.String^ OnPreRender {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ClientEvents Class
ClientEvents Members


OnRemovePendingChanges Property

[image]
Intersoft WebGrid Documentation
OnRemovePendingChanges Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ClientEvents Class : OnRemovePendingChanges Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when a pending changes is about to be removed.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")>
<ISNet.EventParameterAttribute("controlId, table, rowChange")>
Public Property OnRemovePendingChanges As System.String
Visual Basic (Usage) Copy Code
Dim instance As ClientEvents
Dim value As System.String

instance.OnRemovePendingChanges = value

value = instance.OnRemovePendingChanges
C#
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when a pending changes is about to be removed.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.EventParameterAttribute("controlId, table, rowChange")]
public System.string OnRemovePendingChanges {get; set;}
Delphi
public read-write property OnRemovePendingChanges: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when a pending changes is about to be removed.")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")
ISNet.EventParameterAttribute("controlId, table, rowChange")
public function get,set OnRemovePendingChanges : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when a pending changes is about to be removed.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.EventParameterAttribute("controlId, table, rowChange")]
public: __property System.string* get_OnRemovePendingChanges();
public: __property void set_OnRemovePendingChanges(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when a pending changes is about to be removed.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.EventParameterAttribute("controlId, table, rowChange")]
public:
property System.String^ OnRemovePendingChanges {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ClientEvents Class
ClientEvents Members


OnResponse Property

[image]
Intersoft WebGrid Documentation
OnResponse Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ClientEvents Class : OnResponse Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")>
<ISNet.EventParameterAttribute("controlId, status")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when a response from server is returned.")>
Public Property OnResponse As System.String
Visual Basic (Usage) Copy Code
Dim instance As ClientEvents
Dim value As System.String

instance.OnResponse = value

value = instance.OnResponse
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.EventParameterAttribute("controlId, status")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when a response from server is returned.")]
public System.string OnResponse {get; set;}
Delphi
public read-write property OnResponse: System.String;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")
ISNet.EventParameterAttribute("controlId, status")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when a response from server is returned.")
public function get,set OnResponse : System.String
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.EventParameterAttribute("controlId, status")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when a response from server is returned.")]
public: __property System.string* get_OnResponse();
public: __property void set_OnResponse(
   System.string* value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.EventParameterAttribute("controlId, status")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when a response from server is returned.")]
public:
property System.String^ OnResponse {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ClientEvents Class
ClientEvents Members


OnRowContextMenu Property

[image]
Intersoft WebGrid Documentation
OnRowContextMenu Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ClientEvents Class : OnRowContextMenu Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when row context menu is about to be displayed.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.EventParameterAttribute("controlId, rowType, rowElement, menuObject")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")>
Public Property OnRowContextMenu As System.String
Visual Basic (Usage) Copy Code
Dim instance As ClientEvents
Dim value As System.String

instance.OnRowContextMenu = value

value = instance.OnRowContextMenu
C#
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when row context menu is about to be displayed.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.EventParameterAttribute("controlId, rowType, rowElement, menuObject")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
public System.string OnRowContextMenu {get; set;}
Delphi
public read-write property OnRowContextMenu: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when row context menu is about to be displayed.")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
ISNet.EventParameterAttribute("controlId, rowType, rowElement, menuObject")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")
public function get,set OnRowContextMenu : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when row context menu is about to be displayed.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.EventParameterAttribute("controlId, rowType, rowElement, menuObject")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
public: __property System.string* get_OnRowContextMenu();
public: __property void set_OnRowContextMenu(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when row context menu is about to be displayed.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.EventParameterAttribute("controlId, rowType, rowElement, menuObject")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
public:
property System.String^ OnRowContextMenu {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ClientEvents Class
ClientEvents Members


OnRowSelect Property

[image]
Intersoft WebGrid Documentation
OnRowSelect Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ClientEvents Class : OnRowSelect Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.EventParameterAttribute("controlId, tblName, rowIndex, rowEl")>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when a row is selected.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property OnRowSelect As System.String
Visual Basic (Usage) Copy Code
Dim instance As ClientEvents
Dim value As System.String

instance.OnRowSelect = value

value = instance.OnRowSelect
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.EventParameterAttribute("controlId, tblName, rowIndex, rowEl")]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when a row is selected.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.string OnRowSelect {get; set;}
Delphi
public read-write property OnRowSelect: System.String;
JScript
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
ISNet.EventParameterAttribute("controlId, tblName, rowIndex, rowEl")
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when a row is selected.")
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set OnRowSelect : System.String
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.EventParameterAttribute("controlId, tblName, rowIndex, rowEl")]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when a row is selected.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.string* get_OnRowSelect();
public: __property void set_OnRowSelect(
   System.string* value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.EventParameterAttribute("controlId, tblName, rowIndex, rowEl")]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when a row is selected.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.String^ OnRowSelect {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ClientEvents Class
ClientEvents Members


OnRowSelectorClick Property

[image]
Intersoft WebGrid Documentation
OnRowSelectorClick Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ClientEvents Class : OnRowSelectorClick Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")>
<System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when rowSelector is clicked.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.EventParameterAttribute("controlId, tblName, rowIndex, rowEl")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property OnRowSelectorClick As System.String
Visual Basic (Usage) Copy Code
Dim instance As ClientEvents
Dim value As System.String

instance.OnRowSelectorClick = value

value = instance.OnRowSelectorClick
C#
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when rowSelector is clicked.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.EventParameterAttribute("controlId, tblName, rowIndex, rowEl")]
[System.ComponentModel.DefaultValueAttribute()]
public System.string OnRowSelectorClick {get; set;}
Delphi
public read-write property OnRowSelectorClick: System.String;
JScript
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")
System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when rowSelector is clicked.")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.EventParameterAttribute("controlId, tblName, rowIndex, rowEl")
System.ComponentModel.DefaultValueAttribute()
public function get,set OnRowSelectorClick : System.String
Managed Extensions for C++
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when rowSelector is clicked.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.EventParameterAttribute("controlId, tblName, rowIndex, rowEl")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.string* get_OnRowSelectorClick();
public: __property void set_OnRowSelectorClick(
   System.string* value
);
C++/CLI
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when rowSelector is clicked.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.EventParameterAttribute("controlId, tblName, rowIndex, rowEl")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.String^ OnRowSelectorClick {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ClientEvents Class
ClientEvents Members


OnRowValidate Property

[image]
Intersoft WebGrid Documentation
OnRowValidate Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ClientEvents Class : OnRowValidate Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when the row is being validated.")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")>
<ISNet.EventParameterAttribute("rowObject")>
Public Property OnRowValidate As System.String
Visual Basic (Usage) Copy Code
Dim instance As ClientEvents
Dim value As System.String

instance.OnRowValidate = value

value = instance.OnRowValidate
C#
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when the row is being validated.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.EventParameterAttribute("rowObject")]
public System.string OnRowValidate {get; set;}
Delphi
public read-write property OnRowValidate: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when the row is being validated.")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")
ISNet.EventParameterAttribute("rowObject")
public function get,set OnRowValidate : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when the row is being validated.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.EventParameterAttribute("rowObject")]
public: __property System.string* get_OnRowValidate();
public: __property void set_OnRowValidate(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when the row is being validated.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.EventParameterAttribute("rowObject")]
public:
property System.String^ OnRowValidate {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ClientEvents Class
ClientEvents Members


OnScroll Property

[image]
Intersoft WebGrid Documentation
OnScroll Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ClientEvents Class : OnScroll Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when the WebGrid main view is scrolled.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.EventParameterAttribute("controlId")>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")>
Public Property OnScroll As System.String
Visual Basic (Usage) Copy Code
Dim instance As ClientEvents
Dim value As System.String

instance.OnScroll = value

value = instance.OnScroll
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when the WebGrid main view is scrolled.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.EventParameterAttribute("controlId")]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
public System.string OnScroll {get; set;}
Delphi
public read-write property OnScroll: System.String;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when the WebGrid main view is scrolled.")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
ISNet.EventParameterAttribute("controlId")
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")
public function get,set OnScroll : System.String
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when the WebGrid main view is scrolled.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.EventParameterAttribute("controlId")]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
public: __property System.string* get_OnScroll();
public: __property void set_OnScroll(
   System.string* value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when the WebGrid main view is scrolled.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.EventParameterAttribute("controlId")]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
public:
property System.String^ OnScroll {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ClientEvents Class
ClientEvents Members


OnSelfRefRowCollapse Property

[image]
Intersoft WebGrid Documentation
OnSelfRefRowCollapse Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ClientEvents Class : OnSelfRefRowCollapse Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")>
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.EventParameterAttribute("controlId, tblName, rowIndex, rowEl")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when a self referencing row is being collapsed.")>
Public Property OnSelfRefRowCollapse As System.String
Visual Basic (Usage) Copy Code
Dim instance As ClientEvents
Dim value As System.String

instance.OnSelfRefRowCollapse = value

value = instance.OnSelfRefRowCollapse
C#
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.EventParameterAttribute("controlId, tblName, rowIndex, rowEl")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when a self referencing row is being collapsed.")]
public System.string OnSelfRefRowCollapse {get; set;}
Delphi
public read-write property OnSelfRefRowCollapse: System.String;
JScript
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute()
ISNet.EventParameterAttribute("controlId, tblName, rowIndex, rowEl")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when a self referencing row is being collapsed.")
public function get,set OnSelfRefRowCollapse : System.String
Managed Extensions for C++
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.EventParameterAttribute("controlId, tblName, rowIndex, rowEl")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when a self referencing row is being collapsed.")]
public: __property System.string* get_OnSelfRefRowCollapse();
public: __property void set_OnSelfRefRowCollapse(
   System.string* value
);
C++/CLI
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.EventParameterAttribute("controlId, tblName, rowIndex, rowEl")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when a self referencing row is being collapsed.")]
public:
property System.String^ OnSelfRefRowCollapse {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ClientEvents Class
ClientEvents Members


OnSelfRefRowExpand Property

[image]
Intersoft WebGrid Documentation
OnSelfRefRowExpand Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ClientEvents Class : OnSelfRefRowExpand Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")>
<ISNet.EventParameterAttribute("controlId, tblName, rowIndex, rowEl")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when a self referencing row is being expanded.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property OnSelfRefRowExpand As System.String
Visual Basic (Usage) Copy Code
Dim instance As ClientEvents
Dim value As System.String

instance.OnSelfRefRowExpand = value

value = instance.OnSelfRefRowExpand
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.EventParameterAttribute("controlId, tblName, rowIndex, rowEl")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when a self referencing row is being expanded.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public System.string OnSelfRefRowExpand {get; set;}
Delphi
public read-write property OnSelfRefRowExpand: System.String;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")
ISNet.EventParameterAttribute("controlId, tblName, rowIndex, rowEl")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when a self referencing row is being expanded.")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get,set OnSelfRefRowExpand : System.String
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.EventParameterAttribute("controlId, tblName, rowIndex, rowEl")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when a self referencing row is being expanded.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.string* get_OnSelfRefRowExpand();
public: __property void set_OnSelfRefRowExpand(
   System.string* value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.EventParameterAttribute("controlId, tblName, rowIndex, rowEl")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when a self referencing row is being expanded.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.String^ OnSelfRefRowExpand {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ClientEvents Class
ClientEvents Members


OnSynchronizeCell Property

[image]
Intersoft WebGrid Documentation
OnSynchronizeCell Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ClientEvents Class : OnSynchronizeCell Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.EventParameterAttribute("controlId, cell")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when a WebGridCell is being synchronized during client side binding.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")>
Public Property OnSynchronizeCell As System.String
Visual Basic (Usage) Copy Code
Dim instance As ClientEvents
Dim value As System.String

instance.OnSynchronizeCell = value

value = instance.OnSynchronizeCell
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.EventParameterAttribute("controlId, cell")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when a WebGridCell is being synchronized during client side binding.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
public System.string OnSynchronizeCell {get; set;}
Delphi
public read-write property OnSynchronizeCell: System.String;
JScript
ISNet.Serialization.BinarySerializableAttribute()
ISNet.EventParameterAttribute("controlId, cell")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when a WebGridCell is being synchronized during client side binding.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")
public function get,set OnSynchronizeCell : System.String
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.EventParameterAttribute("controlId, cell")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when a WebGridCell is being synchronized during client side binding.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
public: __property System.string* get_OnSynchronizeCell();
public: __property void set_OnSynchronizeCell(
   System.string* value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.EventParameterAttribute("controlId, cell")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when a WebGridCell is being synchronized during client side binding.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
public:
property System.String^ OnSynchronizeCell {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ClientEvents Class
ClientEvents Members


OnSynchronizeChangesUI Property

[image]
Intersoft WebGrid Documentation
OnSynchronizeChangesUI Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ClientEvents Class : OnSynchronizeChangesUI Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when a pending changes is synchronized to row during UI update.")>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")>
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.EventParameterAttribute("controlId, change, row")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
Public Property OnSynchronizeChangesUI As System.String
Visual Basic (Usage) Copy Code
Dim instance As ClientEvents
Dim value As System.String

instance.OnSynchronizeChangesUI = value

value = instance.OnSynchronizeChangesUI
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when a pending changes is synchronized to row during UI update.")]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.EventParameterAttribute("controlId, change, row")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public System.string OnSynchronizeChangesUI {get; set;}
Delphi
public read-write property OnSynchronizeChangesUI: System.String;
JScript
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when a pending changes is synchronized to row during UI update.")
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")
ISNet.Serialization.BinarySerializableAttribute()
ISNet.EventParameterAttribute("controlId, change, row")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
public function get,set OnSynchronizeChangesUI : System.String
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when a pending changes is synchronized to row during UI update.")]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.EventParameterAttribute("controlId, change, row")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.string* get_OnSynchronizeChangesUI();
public: __property void set_OnSynchronizeChangesUI(
   System.string* value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when a pending changes is synchronized to row during UI update.")]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.EventParameterAttribute("controlId, change, row")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.String^ OnSynchronizeChangesUI {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ClientEvents Class
ClientEvents Members


OnSynchronizeRow Property

[image]
Intersoft WebGrid Documentation
OnSynchronizeRow Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ClientEvents Class : OnSynchronizeRow Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.EventParameterAttribute("controlId, row")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when a WebGridRow is being synchronized during client side binding.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")>
Public Property OnSynchronizeRow As System.String
Visual Basic (Usage) Copy Code
Dim instance As ClientEvents
Dim value As System.String

instance.OnSynchronizeRow = value

value = instance.OnSynchronizeRow
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.EventParameterAttribute("controlId, row")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when a WebGridRow is being synchronized during client side binding.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
public System.string OnSynchronizeRow {get; set;}
Delphi
public read-write property OnSynchronizeRow: System.String;
JScript
ISNet.Serialization.BinarySerializableAttribute()
ISNet.EventParameterAttribute("controlId, row")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when a WebGridRow is being synchronized during client side binding.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")
public function get,set OnSynchronizeRow : System.String
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.EventParameterAttribute("controlId, row")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when a WebGridRow is being synchronized during client side binding.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
public: __property System.string* get_OnSynchronizeRow();
public: __property void set_OnSynchronizeRow(
   System.string* value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.EventParameterAttribute("controlId, row")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when a WebGridRow is being synchronized during client side binding.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
public:
property System.String^ OnSynchronizeRow {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ClientEvents Class
ClientEvents Members


OnUndoAllChanges Property

[image]
Intersoft WebGrid Documentation
OnUndoAllChanges Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ClientEvents Class : OnUndoAllChanges Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.EventParameterAttribute("controlId")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when undo all changes command is performed.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")>
Public Property OnUndoAllChanges As System.String
Visual Basic (Usage) Copy Code
Dim instance As ClientEvents
Dim value As System.String

instance.OnUndoAllChanges = value

value = instance.OnUndoAllChanges
C#
[ISNet.EventParameterAttribute("controlId")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when undo all changes command is performed.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
public System.string OnUndoAllChanges {get; set;}
Delphi
public read-write property OnUndoAllChanges: System.String;
JScript
ISNet.EventParameterAttribute("controlId")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when undo all changes command is performed.")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")
public function get,set OnUndoAllChanges : System.String
Managed Extensions for C++
[ISNet.EventParameterAttribute("controlId")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when undo all changes command is performed.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
public: __property System.string* get_OnUndoAllChanges();
public: __property void set_OnUndoAllChanges(
   System.string* value
);
C++/CLI
[ISNet.EventParameterAttribute("controlId")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when undo all changes command is performed.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
public:
property System.String^ OnUndoAllChanges {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ClientEvents Class
ClientEvents Members


OnUndoChanges Property

[image]
Intersoft WebGrid Documentation
OnUndoChanges Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ClientEvents Class : OnUndoChanges Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when row changes is about to be undo'ed.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.EventParameterAttribute("controlId, rowObject")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")>
Public Property OnUndoChanges As System.String
Visual Basic (Usage) Copy Code
Dim instance As ClientEvents
Dim value As System.String

instance.OnUndoChanges = value

value = instance.OnUndoChanges
C#
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when row changes is about to be undo'ed.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.EventParameterAttribute("controlId, rowObject")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
public System.string OnUndoChanges {get; set;}
Delphi
public read-write property OnUndoChanges: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when row changes is about to be undo'ed.")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
ISNet.EventParameterAttribute("controlId, rowObject")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")
public function get,set OnUndoChanges : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when row changes is about to be undo'ed.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.EventParameterAttribute("controlId, rowObject")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
public: __property System.string* get_OnUndoChanges();
public: __property void set_OnUndoChanges(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when row changes is about to be undo'ed.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.EventParameterAttribute("controlId, rowObject")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
public:
property System.String^ OnUndoChanges {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ClientEvents Class
ClientEvents Members


OnUnhandledError Property

[image]
Intersoft WebGrid Documentation
OnUnhandledError Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ClientEvents Class : OnUnhandledError Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when unhandled error occured.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")>
<ISNet.EventParameterAttribute("controlId, tblName, lastRequestObject, errorString")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property OnUnhandledError As System.String
Visual Basic (Usage) Copy Code
Dim instance As ClientEvents
Dim value As System.String

instance.OnUnhandledError = value

value = instance.OnUnhandledError
C#
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when unhandled error occured.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.EventParameterAttribute("controlId, tblName, lastRequestObject, errorString")]
[System.ComponentModel.DefaultValueAttribute()]
public System.string OnUnhandledError {get; set;}
Delphi
public read-write property OnUnhandledError: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when unhandled error occured.")
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")
ISNet.EventParameterAttribute("controlId, tblName, lastRequestObject, errorString")
System.ComponentModel.DefaultValueAttribute()
public function get,set OnUnhandledError : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when unhandled error occured.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.EventParameterAttribute("controlId, tblName, lastRequestObject, errorString")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.string* get_OnUnhandledError();
public: __property void set_OnUnhandledError(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function that will be invoked when unhandled error occured.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.EventParameterAttribute("controlId, tblName, lastRequestObject, errorString")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.String^ OnUnhandledError {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ClientEvents Class
ClientEvents Members


ClientSideAction Class

[image]
Intersoft WebGrid Documentation
ClientSideAction Class
Members See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : ClientSideAction Class

Glossary Item Box

Object Model

ClientSideAction Class

Syntax

Visual Basic (Declaration)
Public Class ClientSideAction
   Inherits ISNet.WebUI.BaseClientSideAction
Visual Basic (Usage) Copy Code
Dim instance As ClientSideAction
C#
public class ClientSideAction : ISNet.WebUI.BaseClientSideAction
Delphi
public class ClientSideAction = class(ISNet.WebUI.BaseClientSideAction)
JScript
public class ClientSideAction extends ISNet.WebUI.BaseClientSideAction
Managed Extensions for C++
public __gc class ClientSideAction : public ISNet.WebUI.BaseClientSideAction
C++/CLI
public ref class ClientSideAction : public ISNet.WebUI.BaseClientSideAction

Inheritance Hierarchy

System.Object
ISNet.WebUI.BaseClientSideAction
ISNet.WebUI.WebGrid.ClientSideAction

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ClientSideAction Members
ISNet.WebUI.WebGrid Namespace


ClientSideAction Class Members

[image]
Intersoft WebGrid Documentation
ClientSideAction Class Members
See Also Methods Send Feedback
ISNet.WebUI.WebGrid Namespace : ClientSideAction Class

Glossary Item Box

The following tables list the members exposed by ClientSideAction.

Public Constructors

 | Name | Description
Public Constructor | ClientSideAction Constructor |
Top

Public Methods

 | Name | Description
Public Method | AddString | (Inherited from ISNet.WebUI.BaseClientSideAction)
Public Method | AddStyle | (Inherited from ISNet.WebUI.BaseClientSideAction)
Public Method | Alert | (Inherited from ISNet.WebUI.BaseClientSideAction)
Public Method | DisplayErrorBox |
Public Method | ExcludeControlFromUpdate | (Inherited from ISNet.WebUI.BaseClientSideAction)
Public Method | FixSemiColon | (Inherited from ISNet.WebUI.BaseClientSideAction)
Public Method | GetAction | (Inherited from ISNet.WebUI.BaseClientSideAction)
Public Method | HasAction | (Inherited from ISNet.WebUI.BaseClientSideAction)
Public Method | Hide | (Inherited from ISNet.WebUI.BaseClientSideAction)
Public Method | InvalidateIntersoftControl | (Inherited from ISNet.WebUI.BaseClientSideAction)
Public Method | InvalidateIntersoftControlTemplate | (Inherited from ISNet.WebUI.BaseClientSideAction)
Public Method | InvokeMethod | Overloaded. (Inherited from ISNet.WebUI.BaseClientSideAction)
Public Method | InvokeScript | Overloaded. (Inherited from ISNet.WebUI.BaseClientSideAction)
Public Method | MarkDirty | (Inherited from ISNet.WebUI.BaseClientSideAction)
Public Method | MarkTypeAsContainer | (Inherited from ISNet.WebUI.BaseClientSideAction)
Public Method | NavigateTo | (Inherited from ISNet.WebUI.BaseClientSideAction)
Public Method | OpenWindow | (Inherited from ISNet.WebUI.BaseClientSideAction)
Public Method | Refresh |
Public Method | RefreshAll |
Public Method | RefreshChildTable |
Public Method | RefreshModifiedControls | (Inherited from ISNet.WebUI.BaseClientSideAction)
Public Method | RenderControl | (Inherited from ISNet.WebUI.BaseClientSideAction)
Public Method | SetFocus | (Inherited from ISNet.WebUI.BaseClientSideAction)
Public Method | SetStatus |
Public Method | SetStyle | Overloaded. (Inherited from ISNet.WebUI.BaseClientSideAction)
Public Method | SetValue | (Inherited from ISNet.WebUI.BaseClientSideAction)
Public Method | Show | (Inherited from ISNet.WebUI.BaseClientSideAction)
Public Method | UpdateViewState | (Inherited from ISNet.WebUI.BaseClientSideAction)
Top

See Also

Reference

ClientSideAction Class
ISNet.WebUI.WebGrid Namespace


ClientSideAction Constructor

[image]
Intersoft WebGrid Documentation
ClientSideAction Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ClientSideAction Class : ClientSideAction Constructor

_ctrl

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal _ctrl As WebGrid _
)
Visual Basic (Usage) Copy Code
Dim _ctrl As WebGrid

Dim instance As New ClientSideAction(_ctrl)
C#
public ClientSideAction(
   WebGrid _ctrl
)
Delphi
public ClientSideAction(
    _ctrl: WebGrid
);
JScript
public function ClientSideAction(
   _ctrl : WebGrid
);
Managed Extensions for C++
public: ClientSideAction(
   WebGrid* _ctrl
)
C++/CLI
public:
ClientSideAction(
   WebGrid^ _ctrl
)

Parameters

_ctrl

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ClientSideAction Class
ClientSideAction Members


AddString Method

[image]
Intersoft WebGrid Documentation
AddString Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ClientSideAction Class : AddString Method

tagName
data

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub AddString( _
   ByVal tagName As System.String, _
   ByVal data As System.String _
)
Visual Basic (Usage) Copy Code
Dim instance As ClientSideAction
Dim tagName As System.String
Dim data As System.String

instance.AddString(tagName, data)
C#
public void AddString(
   System.string tagName,
   System.string data
)
Delphi
public procedure AddString(
    tagName: System.String;
    data: System.String
);
JScript
public function AddString(
   tagName : System.String,
   data : System.String
);
Managed Extensions for C++
public: void AddString(
   System.string* tagName,
   System.string* data
)
C++/CLI
public:
void AddString(
   System.String^ tagName,
   System.String^ data
)

Parameters

tagName
data

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ClientSideAction Class
ClientSideAction Members


AddStyle Method

[image]
Intersoft WebGrid Documentation
AddStyle Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ClientSideAction Class : AddStyle Method

style

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub AddStyle( _
   ByVal style As ISNet.WebUI.WebStyle _
)
Visual Basic (Usage) Copy Code
Dim instance As ClientSideAction
Dim style As ISNet.WebUI.WebStyle

instance.AddStyle(style)
C#
public void AddStyle(
   ISNet.WebUI.WebStyle style
)
Delphi
public procedure AddStyle(
    style: ISNet.WebUI.WebStyle
);
JScript
public function AddStyle(
   style : ISNet.WebUI.WebStyle
);
Managed Extensions for C++
public: void AddStyle(
   ISNet.WebUI.WebStyle* style
)
C++/CLI
public:
void AddStyle(
   ISNet.WebUI.WebStyle^ style
)

Parameters

style

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ClientSideAction Class
ClientSideAction Members


Alert Method

[image]
Intersoft WebGrid Documentation
Alert Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ClientSideAction Class : Alert Method

text

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub Alert( _
   ByVal text As System.String _
)
Visual Basic (Usage) Copy Code
Dim instance As ClientSideAction
Dim text As System.String

instance.Alert(text)
C#
public void Alert(
   System.string text
)
Delphi
public procedure Alert(
    text: System.String
);
JScript
public function Alert(
   text : System.String
);
Managed Extensions for C++
public: void Alert(
   System.string* text
)
C++/CLI
public:
void Alert(
   System.String^ text
)

Parameters

text

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ClientSideAction Class
ClientSideAction Members


ClientSideAction Class Methods

[image]
Intersoft WebGrid Documentation
ClientSideAction Class Methods
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : ClientSideAction Class

Glossary Item Box

For a list of all members of this type, see ClientSideAction members.

Public Methods

 | Name | Description
Public Method | AddString | (Inherited from ISNet.WebUI.BaseClientSideAction)
Public Method | AddStyle | (Inherited from ISNet.WebUI.BaseClientSideAction)
Public Method | Alert | (Inherited from ISNet.WebUI.BaseClientSideAction)
Public Method | DisplayErrorBox |
Public Method | ExcludeControlFromUpdate | (Inherited from ISNet.WebUI.BaseClientSideAction)
Public Method | FixSemiColon | (Inherited from ISNet.WebUI.BaseClientSideAction)
Public Method | GetAction | (Inherited from ISNet.WebUI.BaseClientSideAction)
Public Method | HasAction | (Inherited from ISNet.WebUI.BaseClientSideAction)
Public Method | Hide | (Inherited from ISNet.WebUI.BaseClientSideAction)
Public Method | InvalidateIntersoftControl | (Inherited from ISNet.WebUI.BaseClientSideAction)
Public Method | InvalidateIntersoftControlTemplate | (Inherited from ISNet.WebUI.BaseClientSideAction)
Public Method | InvokeMethod | Overloaded. (Inherited from ISNet.WebUI.BaseClientSideAction)
Public Method | InvokeScript | Overloaded. (Inherited from ISNet.WebUI.BaseClientSideAction)
Public Method | MarkDirty | (Inherited from ISNet.WebUI.BaseClientSideAction)
Public Method | MarkTypeAsContainer | (Inherited from ISNet.WebUI.BaseClientSideAction)
Public Method | NavigateTo | (Inherited from ISNet.WebUI.BaseClientSideAction)
Public Method | OpenWindow | (Inherited from ISNet.WebUI.BaseClientSideAction)
Public Method | Refresh |
Public Method | RefreshAll |
Public Method | RefreshChildTable |
Public Method | RefreshModifiedControls | (Inherited from ISNet.WebUI.BaseClientSideAction)
Public Method | RenderControl | (Inherited from ISNet.WebUI.BaseClientSideAction)
Public Method | SetFocus | (Inherited from ISNet.WebUI.BaseClientSideAction)
Public Method | SetStatus |
Public Method | SetStyle | Overloaded. (Inherited from ISNet.WebUI.BaseClientSideAction)
Public Method | SetValue | (Inherited from ISNet.WebUI.BaseClientSideAction)
Public Method | Show | (Inherited from ISNet.WebUI.BaseClientSideAction)
Public Method | UpdateViewState | (Inherited from ISNet.WebUI.BaseClientSideAction)
Top

See Also

Reference

ClientSideAction Class
ISNet.WebUI.WebGrid Namespace


DisplayErrorBox Method

[image]
Intersoft WebGrid Documentation
DisplayErrorBox Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ClientSideAction Class : DisplayErrorBox Method

caption
errorMessage

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DisplayErrorBox( _
   ByVal caption As System.String, _
   ByVal errorMessage As System.String _
)
Visual Basic (Usage) Copy Code
Dim instance As ClientSideAction
Dim caption As System.String
Dim errorMessage As System.String

instance.DisplayErrorBox(caption, errorMessage)
C#
public void DisplayErrorBox(
   System.string caption,
   System.string errorMessage
)
Delphi
public procedure DisplayErrorBox(
    caption: System.String;
    errorMessage: System.String
);
JScript
public function DisplayErrorBox(
   caption : System.String,
   errorMessage : System.String
);
Managed Extensions for C++
public: void DisplayErrorBox(
   System.string* caption,
   System.string* errorMessage
)
C++/CLI
public:
void DisplayErrorBox(
   System.String^ caption,
   System.String^ errorMessage
)

Parameters

caption
errorMessage

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ClientSideAction Class
ClientSideAction Members


ExcludeControlFromUpdate Method

[image]
Intersoft WebGrid Documentation
ExcludeControlFromUpdate Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ClientSideAction Class : ExcludeControlFromUpdate Method

id

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub ExcludeControlFromUpdate( _
   ByVal id As System.String _
)
Visual Basic (Usage) Copy Code
Dim instance As ClientSideAction
Dim id As System.String

instance.ExcludeControlFromUpdate(id)
C#
public void ExcludeControlFromUpdate(
   System.string id
)
Delphi
public procedure ExcludeControlFromUpdate(
    id: System.String
);
JScript
public function ExcludeControlFromUpdate(
   id : System.String
);
Managed Extensions for C++
public: void ExcludeControlFromUpdate(
   System.string* id
)
C++/CLI
public:
void ExcludeControlFromUpdate(
   System.String^ id
)

Parameters

id

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ClientSideAction Class
ClientSideAction Members


FixSemiColon Method

[image]
Intersoft WebGrid Documentation
FixSemiColon Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ClientSideAction Class : FixSemiColon Method

sText

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function FixSemiColon( _
   ByVal sText As System.String _
) As System.String
Visual Basic (Usage) Copy Code
Dim instance As ClientSideAction
Dim sText As System.String
Dim value As System.String

value = instance.FixSemiColon(sText)
C#
public System.string FixSemiColon(
   System.string sText
)
Delphi
public function FixSemiColon(
    sText: System.String
): System.String;
JScript
public function FixSemiColon(
   sText : System.String
) : System.String;
Managed Extensions for C++
public: System.string* FixSemiColon(
   System.string* sText
)
C++/CLI
public:
System.String^ FixSemiColon(
   System.String^ sText
)

Parameters

sText

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ClientSideAction Class
ClientSideAction Members


GetAction Method

[image]
Intersoft WebGrid Documentation
GetAction Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ClientSideAction Class : GetAction Method

actionName

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetAction( _
   ByVal actionName As System.String _
) As System.Object()
Visual Basic (Usage) Copy Code
Dim instance As ClientSideAction
Dim actionName As System.String
Dim value() As System.Object

value = instance.GetAction(actionName)
C#
public System.object[] GetAction(
   System.string actionName
)
Delphi
public function GetAction(
    actionName: System.String
): System.array of TObject;
JScript
public function GetAction(
   actionName : System.String
) : System.Object[];
Managed Extensions for C++
public: System.Object*[]* GetAction(
   System.string* actionName
)
C++/CLI
public:
System.array<Object^>^ GetAction(
   System.String^ actionName
)

Parameters

actionName

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ClientSideAction Class
ClientSideAction Members


HasAction Method

[image]
Intersoft WebGrid Documentation
HasAction Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ClientSideAction Class : HasAction Method

actionName

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function HasAction( _
   ByVal actionName As System.String _
) As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As ClientSideAction
Dim actionName As System.String
Dim value As System.Boolean

value = instance.HasAction(actionName)
C#
public System.bool HasAction(
   System.string actionName
)
Delphi
public function HasAction(
    actionName: System.String
): System.Boolean;
JScript
public function HasAction(
   actionName : System.String
) : System.boolean;
Managed Extensions for C++
public: System.bool HasAction(
   System.string* actionName
)
C++/CLI
public:
System.bool HasAction(
   System.String^ actionName
)

Parameters

actionName

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ClientSideAction Class
ClientSideAction Members


Hide Method

[image]
Intersoft WebGrid Documentation
Hide Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ClientSideAction Class : Hide Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub Hide()
Visual Basic (Usage) Copy Code
Dim instance As ClientSideAction

instance.Hide()
C#
public void Hide()
Delphi
public procedure Hide();
JScript
public function Hide();
Managed Extensions for C++
public: void Hide();
C++/CLI
public:
void Hide();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ClientSideAction Class
ClientSideAction Members


InvalidateIntersoftControl Method

[image]
Intersoft WebGrid Documentation
InvalidateIntersoftControl Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ClientSideAction Class : InvalidateIntersoftControl Method

control

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub InvalidateIntersoftControl( _
   ByVal control As ISNet.WebUI.ISNetControl _
)
Visual Basic (Usage) Copy Code
Dim instance As ClientSideAction
Dim control As ISNet.WebUI.ISNetControl

instance.InvalidateIntersoftControl(control)
C#
public void InvalidateIntersoftControl(
   ISNet.WebUI.ISNetControl control
)
Delphi
public procedure InvalidateIntersoftControl(
    control: ISNet.WebUI.ISNetControl
);
JScript
public function InvalidateIntersoftControl(
   control : ISNet.WebUI.ISNetControl
);
Managed Extensions for C++
public: void InvalidateIntersoftControl(
   ISNet.WebUI.ISNetControl* control
)
C++/CLI
public:
void InvalidateIntersoftControl(
   ISNet.WebUI.ISNetControl^ control
)

Parameters

control

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ClientSideAction Class
ClientSideAction Members


InvalidateIntersoftControlTemplate Method

[image]
Intersoft WebGrid Documentation
InvalidateIntersoftControlTemplate Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ClientSideAction Class : InvalidateIntersoftControlTemplate Method

control

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub InvalidateIntersoftControlTemplate( _
   ByVal control As ISNet.WebUI.ISNetControl _
)
Visual Basic (Usage) Copy Code
Dim instance As ClientSideAction
Dim control As ISNet.WebUI.ISNetControl

instance.InvalidateIntersoftControlTemplate(control)
C#
public void InvalidateIntersoftControlTemplate(
   ISNet.WebUI.ISNetControl control
)
Delphi
public procedure InvalidateIntersoftControlTemplate(
    control: ISNet.WebUI.ISNetControl
);
JScript
public function InvalidateIntersoftControlTemplate(
   control : ISNet.WebUI.ISNetControl
);
Managed Extensions for C++
public: void InvalidateIntersoftControlTemplate(
   ISNet.WebUI.ISNetControl* control
)
C++/CLI
public:
void InvalidateIntersoftControlTemplate(
   ISNet.WebUI.ISNetControl^ control
)

Parameters

control

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ClientSideAction Class
ClientSideAction Members


InvokeMethod Method

[image]
Intersoft WebGrid Documentation
InvokeMethod Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ClientSideAction Class : InvokeMethod Method

Glossary Item Box

Overload List

Overload | Description
InvokeMethod(String) | (Inherited from ISNet.WebUI.BaseClientSideAction)
InvokeMethod(String,FunctionParameter[]) | (Inherited from ISNet.WebUI.BaseClientSideAction)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ClientSideAction Class
ClientSideAction Members


InvokeMethod(String) Method

[image]
Intersoft WebGrid Documentation
InvokeMethod(String) Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ClientSideAction Class > InvokeMethod Method : InvokeMethod(String) Method

methodName

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Sub InvokeMethod( _
   ByVal methodName As System.String _
)
Visual Basic (Usage) Copy Code
Dim instance As ClientSideAction
Dim methodName As System.String

instance.InvokeMethod(methodName)
C#
public void InvokeMethod(
   System.string methodName
)
Delphi
public procedure InvokeMethod(
    methodName: System.String
);
JScript
public function InvokeMethod(
   methodName : System.String
);
Managed Extensions for C++
public: void InvokeMethod(
   System.string* methodName
)
C++/CLI
public:
void InvokeMethod(
   System.String^ methodName
)

Parameters

methodName

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ClientSideAction Class
ClientSideAction Members
Overload List


InvokeMethod(String,FunctionParameter[]) Method

[image]
Intersoft WebGrid Documentation
InvokeMethod(String,FunctionParameter[]) Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ClientSideAction Class > InvokeMethod Method : InvokeMethod(String,FunctionParameter[]) Method

methodName
functionParameters

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Sub InvokeMethod( _
   ByVal methodName As System.String, _
   ByVal functionParameters() As ISNet.WebUI.FunctionParameter _
)
Visual Basic (Usage) Copy Code
Dim instance As ClientSideAction
Dim methodName As System.String
Dim functionParameters() As ISNet.WebUI.FunctionParameter

instance.InvokeMethod(methodName, functionParameters)
C#
public void InvokeMethod(
   System.string methodName,
   ISNet.WebUI.FunctionParameter[] functionParameters
)
Delphi
public procedure InvokeMethod(
    methodName: System.String;
    functionParameters: ISNet.WebUI.FunctionParameterarray of
);
JScript
public function InvokeMethod(
   methodName : System.String,
   functionParameters : ISNet.WebUI.FunctionParameter[]
);
Managed Extensions for C++
public: void InvokeMethod(
   System.string* methodName,
   ISNet.WebUI.FunctionParameter[]* functionParameters
)
C++/CLI
public:
void InvokeMethod(
   System.String^ methodName,
   ISNet.WebUI.array<FunctionParameter>^ functionParameters
)

Parameters

methodName
functionParameters

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ClientSideAction Class
ClientSideAction Members
Overload List


InvokeScript Method

[image]
Intersoft WebGrid Documentation
InvokeScript Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ClientSideAction Class : InvokeScript Method

Glossary Item Box

Overload List

Overload | Description
InvokeScript(String) | (Inherited from ISNet.WebUI.BaseClientSideAction)
InvokeScript(String,FunctionParameter[]) | (Inherited from ISNet.WebUI.BaseClientSideAction)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ClientSideAction Class
ClientSideAction Members


InvokeScript(String) Method

[image]
Intersoft WebGrid Documentation
InvokeScript(String) Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ClientSideAction Class > InvokeScript Method : InvokeScript(String) Method

functionString

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Sub InvokeScript( _
   ByVal functionString As System.String _
)
Visual Basic (Usage) Copy Code
Dim instance As ClientSideAction
Dim functionString As System.String

instance.InvokeScript(functionString)
C#
public void InvokeScript(
   System.string functionString
)
Delphi
public procedure InvokeScript(
    functionString: System.String
);
JScript
public function InvokeScript(
   functionString : System.String
);
Managed Extensions for C++
public: void InvokeScript(
   System.string* functionString
)
C++/CLI
public:
void InvokeScript(
   System.String^ functionString
)

Parameters

functionString

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ClientSideAction Class
ClientSideAction Members
Overload List


InvokeScript(String,FunctionParameter[]) Method

[image]
Intersoft WebGrid Documentation
InvokeScript(String,FunctionParameter[]) Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ClientSideAction Class > InvokeScript Method : InvokeScript(String,FunctionParameter[]) Method

functionName
functionParameters

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Sub InvokeScript( _
   ByVal functionName As System.String, _
   ByVal functionParameters() As ISNet.WebUI.FunctionParameter _
)
Visual Basic (Usage) Copy Code
Dim instance As ClientSideAction
Dim functionName As System.String
Dim functionParameters() As ISNet.WebUI.FunctionParameter

instance.InvokeScript(functionName, functionParameters)
C#
public void InvokeScript(
   System.string functionName,
   ISNet.WebUI.FunctionParameter[] functionParameters
)
Delphi
public procedure InvokeScript(
    functionName: System.String;
    functionParameters: ISNet.WebUI.FunctionParameterarray of
);
JScript
public function InvokeScript(
   functionName : System.String,
   functionParameters : ISNet.WebUI.FunctionParameter[]
);
Managed Extensions for C++
public: void InvokeScript(
   System.string* functionName,
   ISNet.WebUI.FunctionParameter[]* functionParameters
)
C++/CLI
public:
void InvokeScript(
   System.String^ functionName,
   ISNet.WebUI.array<FunctionParameter>^ functionParameters
)

Parameters

functionName
functionParameters

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ClientSideAction Class
ClientSideAction Members
Overload List


MarkDirty Method

[image]
Intersoft WebGrid Documentation
MarkDirty Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ClientSideAction Class : MarkDirty Method

control

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub MarkDirty( _
   ByVal control As System.Web.UI.WebControls.WebControl _
)
Visual Basic (Usage) Copy Code
Dim instance As ClientSideAction
Dim control As System.Web.UI.WebControls.WebControl

instance.MarkDirty(control)
C#
public void MarkDirty(
   System.Web.UI.WebControls.WebControl control
)
Delphi
public procedure MarkDirty(
    control: System.Web.UI.WebControls.WebControl
);
JScript
public function MarkDirty(
   control : System.Web.UI.WebControls.WebControl
);
Managed Extensions for C++
public: void MarkDirty(
   System.Web.UI.WebControls.WebControl* control
)
C++/CLI
public:
void MarkDirty(
   System.Web.UI.WebControls.WebControl^ control
)

Parameters

control

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ClientSideAction Class
ClientSideAction Members


MarkTypeAsContainer Method

[image]
Intersoft WebGrid Documentation
MarkTypeAsContainer Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ClientSideAction Class : MarkTypeAsContainer Method

type

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub MarkTypeAsContainer( _
   ByVal type As System.Type _
)
Visual Basic (Usage) Copy Code
Dim instance As ClientSideAction
Dim type As System.Type

instance.MarkTypeAsContainer(type)
C#
public void MarkTypeAsContainer(
   System.Type type
)
Delphi
public procedure MarkTypeAsContainer(
    type: System.Type
);
JScript
public function MarkTypeAsContainer(
   type : System.Type
);
Managed Extensions for C++
public: void MarkTypeAsContainer(
   System.Type* type
)
C++/CLI
public:
void MarkTypeAsContainer(
   System.Type^ type
)

Parameters

type

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ClientSideAction Class
ClientSideAction Members


NavigateTo Method

[image]
Intersoft WebGrid Documentation
NavigateTo Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ClientSideAction Class : NavigateTo Method

location

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub NavigateTo( _
   ByVal location As System.String _
)
Visual Basic (Usage) Copy Code
Dim instance As ClientSideAction
Dim location As System.String

instance.NavigateTo(location)
C#
public void NavigateTo(
   System.string location
)
Delphi
public procedure NavigateTo(
    location: System.String
);
JScript
public function NavigateTo(
   location : System.String
);
Managed Extensions for C++
public: void NavigateTo(
   System.string* location
)
C++/CLI
public:
void NavigateTo(
   System.String^ location
)

Parameters

location

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ClientSideAction Class
ClientSideAction Members


OpenWindow Method

[image]
Intersoft WebGrid Documentation
OpenWindow Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ClientSideAction Class : OpenWindow Method

sUrl
sName
sFeatures

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub OpenWindow( _
   ByVal sUrl As System.String, _
   ByVal sName As System.String, _
   ByVal sFeatures As System.String _
)
Visual Basic (Usage) Copy Code
Dim instance As ClientSideAction
Dim sUrl As System.String
Dim sName As System.String
Dim sFeatures As System.String

instance.OpenWindow(sUrl, sName, sFeatures)
C#
public void OpenWindow(
   System.string sUrl,
   System.string sName,
   System.string sFeatures
)
Delphi
public procedure OpenWindow(
    sUrl: System.String;
    sName: System.String;
    sFeatures: System.String
);
JScript
public function OpenWindow(
   sUrl : System.String,
   sName : System.String,
   sFeatures : System.String
);
Managed Extensions for C++
public: void OpenWindow(
   System.string* sUrl,
   System.string* sName,
   System.string* sFeatures
)
C++/CLI
public:
void OpenWindow(
   System.String^ sUrl,
   System.String^ sName,
   System.String^ sFeatures
)

Parameters

sUrl
sName
sFeatures

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ClientSideAction Class
ClientSideAction Members


Refresh Method

[image]
Intersoft WebGrid Documentation
Refresh Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ClientSideAction Class : Refresh Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub Refresh()
Visual Basic (Usage) Copy Code
Dim instance As ClientSideAction

instance.Refresh()
C#
public void Refresh()
Delphi
public procedure Refresh();
JScript
public function Refresh();
Managed Extensions for C++
public: void Refresh();
C++/CLI
public:
void Refresh();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ClientSideAction Class
ClientSideAction Members


RefreshAll Method

[image]
Intersoft WebGrid Documentation
RefreshAll Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ClientSideAction Class : RefreshAll Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub RefreshAll()
Visual Basic (Usage) Copy Code
Dim instance As ClientSideAction

instance.RefreshAll()
C#
public void RefreshAll()
Delphi
public procedure RefreshAll();
JScript
public function RefreshAll();
Managed Extensions for C++
public: void RefreshAll();
C++/CLI
public:
void RefreshAll();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ClientSideAction Class
ClientSideAction Members


RefreshChildTable Method

[image]
Intersoft WebGrid Documentation
RefreshChildTable Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ClientSideAction Class : RefreshChildTable Method

tblName

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub RefreshChildTable( _
   ByVal tblName As System.String _
)
Visual Basic (Usage) Copy Code
Dim instance As ClientSideAction
Dim tblName As System.String

instance.RefreshChildTable(tblName)
C#
public void RefreshChildTable(
   System.string tblName
)
Delphi
public procedure RefreshChildTable(
    tblName: System.String
);
JScript
public function RefreshChildTable(
   tblName : System.String
);
Managed Extensions for C++
public: void RefreshChildTable(
   System.string* tblName
)
C++/CLI
public:
void RefreshChildTable(
   System.String^ tblName
)

Parameters

tblName

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ClientSideAction Class
ClientSideAction Members


RefreshModifiedControls Method

[image]
Intersoft WebGrid Documentation
RefreshModifiedControls Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ClientSideAction Class : RefreshModifiedControls Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub RefreshModifiedControls()
Visual Basic (Usage) Copy Code
Dim instance As ClientSideAction

instance.RefreshModifiedControls()
C#
public void RefreshModifiedControls()
Delphi
public procedure RefreshModifiedControls();
JScript
public function RefreshModifiedControls();
Managed Extensions for C++
public: void RefreshModifiedControls();
C++/CLI
public:
void RefreshModifiedControls();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ClientSideAction Class
ClientSideAction Members


RenderControl Method

[image]
Intersoft WebGrid Documentation
RenderControl Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ClientSideAction Class : RenderControl Method

targetCtrl

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub RenderControl( _
   ByVal targetCtrl As System.Web.UI.Control _
)
Visual Basic (Usage) Copy Code
Dim instance As ClientSideAction
Dim targetCtrl As System.Web.UI.Control

instance.RenderControl(targetCtrl)
C#
public void RenderControl(
   System.Web.UI.Control targetCtrl
)
Delphi
public procedure RenderControl(
    targetCtrl: System.Web.UI.Control
);
JScript
public function RenderControl(
   targetCtrl : System.Web.UI.Control
);
Managed Extensions for C++
public: void RenderControl(
   System.Web.UI.Control* targetCtrl
)
C++/CLI
public:
void RenderControl(
   System.Web.UI.Control^ targetCtrl
)

Parameters

targetCtrl

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ClientSideAction Class
ClientSideAction Members


SetFocus Method

[image]
Intersoft WebGrid Documentation
SetFocus Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ClientSideAction Class : SetFocus Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SetFocus()
Visual Basic (Usage) Copy Code
Dim instance As ClientSideAction

instance.SetFocus()
C#
public void SetFocus()
Delphi
public procedure SetFocus();
JScript
public function SetFocus();
Managed Extensions for C++
public: void SetFocus();
C++/CLI
public:
void SetFocus();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ClientSideAction Class
ClientSideAction Members


SetStatus Method

[image]
Intersoft WebGrid Documentation
SetStatus Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ClientSideAction Class : SetStatus Method

status

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SetStatus( _
   ByVal status As System.String _
)
Visual Basic (Usage) Copy Code
Dim instance As ClientSideAction
Dim status As System.String

instance.SetStatus(status)
C#
public void SetStatus(
   System.string status
)
Delphi
public procedure SetStatus(
    status: System.String
);
JScript
public function SetStatus(
   status : System.String
);
Managed Extensions for C++
public: void SetStatus(
   System.string* status
)
C++/CLI
public:
void SetStatus(
   System.String^ status
)

Parameters

status

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ClientSideAction Class
ClientSideAction Members


SetStyle Method

[image]
Intersoft WebGrid Documentation
SetStyle Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ClientSideAction Class : SetStyle Method

Glossary Item Box

Overload List

Overload | Description
SetStyle(WebControl,WebStyle) | (Inherited from ISNet.WebUI.BaseClientSideAction)
SetStyle(String,WebStyle) | (Inherited from ISNet.WebUI.BaseClientSideAction)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ClientSideAction Class
ClientSideAction Members


SetStyle(WebControl,WebStyle) Method

[image]
Intersoft WebGrid Documentation
SetStyle(WebControl,WebStyle) Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ClientSideAction Class > SetStyle Method : SetStyle(WebControl,WebStyle) Method

ctrl
style

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Sub SetStyle( _
   ByVal ctrl As System.Web.UI.WebControls.WebControl, _
   ByVal style As ISNet.WebUI.WebStyle _
)
Visual Basic (Usage) Copy Code
Dim instance As ClientSideAction
Dim ctrl As System.Web.UI.WebControls.WebControl
Dim style As ISNet.WebUI.WebStyle

instance.SetStyle(ctrl, style)
C#
public void SetStyle(
   System.Web.UI.WebControls.WebControl ctrl,
   ISNet.WebUI.WebStyle style
)
Delphi
public procedure SetStyle(
    ctrl: System.Web.UI.WebControls.WebControl;
    style: ISNet.WebUI.WebStyle
);
JScript
public function SetStyle(
   ctrl : System.Web.UI.WebControls.WebControl,
   style : ISNet.WebUI.WebStyle
);
Managed Extensions for C++
public: void SetStyle(
   System.Web.UI.WebControls.WebControl* ctrl,
   ISNet.WebUI.WebStyle* style
)
C++/CLI
public:
void SetStyle(
   System.Web.UI.WebControls.WebControl^ ctrl,
   ISNet.WebUI.WebStyle^ style
)

Parameters

ctrl
style

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ClientSideAction Class
ClientSideAction Members
Overload List


SetStyle(String,WebStyle) Method

[image]
Intersoft WebGrid Documentation
SetStyle(String,WebStyle) Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ClientSideAction Class > SetStyle Method : SetStyle(String,WebStyle) Method

clientID
style

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Sub SetStyle( _
   ByVal clientID As System.String, _
   ByVal style As ISNet.WebUI.WebStyle _
)
Visual Basic (Usage) Copy Code
Dim instance As ClientSideAction
Dim clientID As System.String
Dim style As ISNet.WebUI.WebStyle

instance.SetStyle(clientID, style)
C#
public void SetStyle(
   System.string clientID,
   ISNet.WebUI.WebStyle style
)
Delphi
public procedure SetStyle(
    clientID: System.String;
    style: ISNet.WebUI.WebStyle
);
JScript
public function SetStyle(
   clientID : System.String,
   style : ISNet.WebUI.WebStyle
);
Managed Extensions for C++
public: void SetStyle(
   System.string* clientID,
   ISNet.WebUI.WebStyle* style
)
C++/CLI
public:
void SetStyle(
   System.String^ clientID,
   ISNet.WebUI.WebStyle^ style
)

Parameters

clientID
style

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ClientSideAction Class
ClientSideAction Members
Overload List


SetValue Method

[image]
Intersoft WebGrid Documentation
SetValue Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ClientSideAction Class : SetValue Method

inputCtrl
sValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SetValue( _
   ByVal inputCtrl As System.Web.UI.WebControls.WebControl, _
   ByVal sValue As System.String _
)
Visual Basic (Usage) Copy Code
Dim instance As ClientSideAction
Dim inputCtrl As System.Web.UI.WebControls.WebControl
Dim sValue As System.String

instance.SetValue(inputCtrl, sValue)
C#
public void SetValue(
   System.Web.UI.WebControls.WebControl inputCtrl,
   System.string sValue
)
Delphi
public procedure SetValue(
    inputCtrl: System.Web.UI.WebControls.WebControl;
    sValue: System.String
);
JScript
public function SetValue(
   inputCtrl : System.Web.UI.WebControls.WebControl,
   sValue : System.String
);
Managed Extensions for C++
public: void SetValue(
   System.Web.UI.WebControls.WebControl* inputCtrl,
   System.string* sValue
)
C++/CLI
public:
void SetValue(
   System.Web.UI.WebControls.WebControl^ inputCtrl,
   System.String^ sValue
)

Parameters

inputCtrl
sValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ClientSideAction Class
ClientSideAction Members


Show Method

[image]
Intersoft WebGrid Documentation
Show Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ClientSideAction Class : Show Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub Show()
Visual Basic (Usage) Copy Code
Dim instance As ClientSideAction

instance.Show()
C#
public void Show()
Delphi
public procedure Show();
JScript
public function Show();
Managed Extensions for C++
public: void Show();
C++/CLI
public:
void Show();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ClientSideAction Class
ClientSideAction Members


UpdateViewState Method

[image]
Intersoft WebGrid Documentation
UpdateViewState Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ClientSideAction Class : UpdateViewState Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub UpdateViewState()
Visual Basic (Usage) Copy Code
Dim instance As ClientSideAction

instance.UpdateViewState()
C#
public void UpdateViewState()
Delphi
public procedure UpdateViewState();
JScript
public function UpdateViewState();
Managed Extensions for C++
public: void UpdateViewState();
C++/CLI
public:
void UpdateViewState();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ClientSideAction Class
ClientSideAction Members


ColumnEventArgs Class

[image]
Intersoft WebGrid Documentation
ColumnEventArgs Class
Members See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : ColumnEventArgs Class

Glossary Item Box

Object Model

ColumnEventArgs Class

Syntax

Visual Basic (Declaration)
Public Class ColumnEventArgs
   Inherits BaseEventArgs
Visual Basic (Usage) Copy Code
Dim instance As ColumnEventArgs
C#
public class ColumnEventArgs : BaseEventArgs
Delphi
public class ColumnEventArgs = class(BaseEventArgs)
JScript
public class ColumnEventArgs extends BaseEventArgs
Managed Extensions for C++
public __gc class ColumnEventArgs : public BaseEventArgs
C++/CLI
public ref class ColumnEventArgs : public BaseEventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
ISNet.WebUI.WebGrid.BaseEventArgs
ISNet.WebUI.WebGrid.ColumnEventArgs

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ColumnEventArgs Members
ISNet.WebUI.WebGrid Namespace


ColumnEventArgs Class Members

[image]
Intersoft WebGrid Documentation
ColumnEventArgs Class Members
See Also Properties Send Feedback
ISNet.WebUI.WebGrid Namespace : ColumnEventArgs Class

Glossary Item Box

The following tables list the members exposed by ColumnEventArgs.

Public Properties

 | Name | Description
Public Property | Column |
Public Property | ReturnValue | (Inherited from ISNet.WebUI.WebGrid.BaseEventArgs)
Top

See Also

Reference

ColumnEventArgs Class
ISNet.WebUI.WebGrid Namespace


ColumnEventArgs Class Properties

[image]
Intersoft WebGrid Documentation
ColumnEventArgs Class Properties
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : ColumnEventArgs Class

Glossary Item Box

For a list of all members of this type, see ColumnEventArgs members.

Public Properties

 | Name | Description
Public Property | Column |
Public Property | ReturnValue | (Inherited from ISNet.WebUI.WebGrid.BaseEventArgs)
Top

See Also

Reference

ColumnEventArgs Class
ISNet.WebUI.WebGrid Namespace


Column Property

[image]
Intersoft WebGrid Documentation
Column Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ColumnEventArgs Class : Column Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Column As WebGridColumn
Visual Basic (Usage) Copy Code
Dim instance As ColumnEventArgs
Dim value As WebGridColumn

value = instance.Column
C#
public WebGridColumn Column {get;}
Delphi
public read-only property Column: WebGridColumn;
JScript
public function get Column : WebGridColumn
Managed Extensions for C++
public: __property WebGridColumn* get_Column();
C++/CLI
public:
property WebGridColumn^ Column {
   WebGridColumn^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ColumnEventArgs Class
ColumnEventArgs Members


ColumnSetSettings Class

[image]
Intersoft WebGrid Documentation
ColumnSetSettings Class
Members See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : ColumnSetSettings Class

Glossary Item Box

Object Model

ColumnSetSettings Class

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.DescriptionAttribute()>
<System.SerializableAttribute()>
Public Class ColumnSetSettings
   Inherits ISNet.WebUI.WebUIBaseClass
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Visual Basic (Usage) Copy Code
Dim instance As ColumnSetSettings
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DescriptionAttribute()]
[System.SerializableAttribute()]
public class ColumnSetSettings : ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Delphi
public class ColumnSetSettings = class(ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize)
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.DescriptionAttribute()
System.SerializableAttribute()
public class ColumnSetSettings extends ISNet.WebUI.WebUIBaseClass implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DescriptionAttribute()]
[System.SerializableAttribute()]
public __gc class ColumnSetSettings : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DescriptionAttribute()]
[System.SerializableAttribute()]
public ref class ColumnSetSettings : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.WebGrid.ColumnSetSettings

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ColumnSetSettings Members
ISNet.WebUI.WebGrid Namespace


ColumnSetSettings Class Members

[image]
Intersoft WebGrid Documentation
ColumnSetSettings Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebGrid Namespace : ColumnSetSettings Class

Glossary Item Box

The following tables list the members exposed by ColumnSetSettings.

Public Constructors

 | Name | Description
Public Constructor | ColumnSetSettings Constructor |
Top

Public Properties

 | Name | Description
Public Property | GridLineColor |
Public Property | GridLines |
Public Property | GridLineStyle |
Public Property | RowCount |
Public Property | ShowHeaders |
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString |
Top

See Also

Reference

ColumnSetSettings Class
ISNet.WebUI.WebGrid Namespace


ColumnSetSettings Constructor

[image]
Intersoft WebGrid Documentation
ColumnSetSettings Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ColumnSetSettings Class : ColumnSetSettings Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New ColumnSetSettings()
C#
public ColumnSetSettings()
Delphi
public ColumnSetSettings();
JScript
public function ColumnSetSettings();
Managed Extensions for C++
public: ColumnSetSettings();
C++/CLI
public:
ColumnSetSettings();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ColumnSetSettings Class
ColumnSetSettings Members


Clone Method

[image]
Intersoft WebGrid Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ColumnSetSettings Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As System.Object
Visual Basic (Usage) Copy Code
Dim instance As ColumnSetSettings
Dim value As System.Object

value = instance.Clone()
C#
public virtual System.object Clone()
Delphi
public function Clone(): System.TObject; virtual;
JScript
public function Clone() : System.Object;
Managed Extensions for C++
public: virtual System.Object* Clone();
C++/CLI
public:
virtual System.Object^ Clone();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ColumnSetSettings Class
ColumnSetSettings Members


CopyFrom Method

[image]
Intersoft WebGrid Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ColumnSetSettings Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ColumnSetSettings Class
ColumnSetSettings Members


CopyFrom(Object) Method

[image]
Intersoft WebGrid Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ColumnSetSettings Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As ColumnSetSettings
Dim objSource As System.Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   System.object objSource
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ColumnSetSettings Class
ColumnSetSettings Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebGrid Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ColumnSetSettings Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object, _
   ByVal cloneSourceValue As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As ColumnSetSettings
Dim objSource As System.Object
Dim cloneSourceValue As System.Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   System.object objSource,
   System.bool cloneSourceValue
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject;
    cloneSourceValue: System.Boolean
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object,
   cloneSourceValue : System.boolean
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource,
   System.bool cloneSourceValue
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource,
   System.bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ColumnSetSettings Class
ColumnSetSettings Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebGrid Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ColumnSetSettings Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As ColumnSetSettings
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure DeSerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function DeSerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void DeSerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void DeSerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ColumnSetSettings Class
ColumnSetSettings Members


GetHashCode Method

[image]
Intersoft WebGrid Documentation
GetHashCode Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ColumnSetSettings Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As ColumnSetSettings
Dim value As System.Integer

value = instance.GetHashCode()
C#
public virtual System.int GetHashCode()
Delphi
public function GetHashCode(): System.Integer; virtual;
JScript
public function GetHashCode() : System.int;
Managed Extensions for C++
public: virtual System.int GetHashCode();
C++/CLI
public:
virtual System.int GetHashCode();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ColumnSetSettings Class
ColumnSetSettings Members


ColumnSetSettings Class Methods

[image]
Intersoft WebGrid Documentation
ColumnSetSettings Class Methods
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : ColumnSetSettings Class

Glossary Item Box

For a list of all members of this type, see ColumnSetSettings members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString |
Top

See Also

Reference

ColumnSetSettings Class
ISNet.WebUI.WebGrid Namespace


GetObjectData Method

[image]
Intersoft WebGrid Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ColumnSetSettings Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As ColumnSetSettings
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure GetObjectData(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
); override;
JScript
public override function GetObjectData(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void GetObjectData(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
) override
C++/CLI
public:
void GetObjectData(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
) override

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ColumnSetSettings Class
ColumnSetSettings Members


IsEmpty Method

[image]
Intersoft WebGrid Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ColumnSetSettings Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As ColumnSetSettings
Dim value As System.Boolean

value = instance.IsEmpty()
C#
public virtual System.bool IsEmpty()
Delphi
public function IsEmpty(): System.Boolean; virtual;
JScript
public function IsEmpty() : System.boolean;
Managed Extensions for C++
public: virtual System.bool IsEmpty();
C++/CLI
public:
virtual System.bool IsEmpty();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ColumnSetSettings Class
ColumnSetSettings Members


Reset Method

[image]
Intersoft WebGrid Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ColumnSetSettings Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As ColumnSetSettings

instance.Reset()
C#
public virtual void Reset()
Delphi
public procedure Reset(); virtual;
JScript
public function Reset();
Managed Extensions for C++
public: virtual void Reset();
C++/CLI
public:
virtual void Reset();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ColumnSetSettings Class
ColumnSetSettings Members


SerializeObjectData Method

[image]
Intersoft WebGrid Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ColumnSetSettings Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As ColumnSetSettings
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure SerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function SerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void SerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void SerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ColumnSetSettings Class
ColumnSetSettings Members


ToString Method

[image]
Intersoft WebGrid Documentation
ToString Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ColumnSetSettings Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString() As System.String
Visual Basic (Usage) Copy Code
Dim instance As ColumnSetSettings
Dim value As System.String

value = instance.ToString()
C#
public override System.string ToString()
Delphi
public function ToString(): System.String; override;
JScript
public override function ToString() : System.String;
Managed Extensions for C++
public: System.string* ToString(); override
C++/CLI
public:
System.String^ ToString(); override

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ColumnSetSettings Class
ColumnSetSettings Members


ColumnSetSettings Class Properties

[image]
Intersoft WebGrid Documentation
ColumnSetSettings Class Properties
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : ColumnSetSettings Class

Glossary Item Box

For a list of all members of this type, see ColumnSetSettings members.

Public Properties

 | Name | Description
Public Property | GridLineColor |
Public Property | GridLines |
Public Property | GridLineStyle |
Public Property | RowCount |
Public Property | ShowHeaders |
Top

See Also

Reference

ColumnSetSettings Class
ISNet.WebUI.WebGrid Namespace


ColumnSetSettings Constructor

[image]
Intersoft WebGrid Documentation
ColumnSetSettings Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ColumnSetSettings Class : ColumnSetSettings Constructor

Glossary Item Box

Overload List

Overload | Description
ColumnSetSettings Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ColumnSetSettings Class
ColumnSetSettings Members


GridLineColor Property

[image]
Intersoft WebGrid Documentation
GridLineColor Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ColumnSetSettings Class : GridLineColor Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property GridLineColor As System.Drawing.Color
Visual Basic (Usage) Copy Code
Dim instance As ColumnSetSettings
Dim value As System.Drawing.Color

instance.GridLineColor = value

value = instance.GridLineColor
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.Drawing.Color GridLineColor {get; set;}
Delphi
public read-write property GridLineColor: System.Drawing.Color;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set GridLineColor : System.Drawing.Color
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.Drawing.Color get_GridLineColor();
public: __property void set_GridLineColor(
   System.Drawing.Color value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.Drawing.Color GridLineColor {
   System.Drawing.Color get();
   void set (    System.Drawing.Color value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ColumnSetSettings Class
ColumnSetSettings Members


GridLines Property

[image]
Intersoft WebGrid Documentation
GridLines Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ColumnSetSettings Class : GridLines Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property GridLines As GridLines
Visual Basic (Usage) Copy Code
Dim instance As ColumnSetSettings
Dim value As GridLines

instance.GridLines = value

value = instance.GridLines
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public GridLines GridLines {get; set;}
Delphi
public read-write property GridLines: GridLines;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set GridLines : GridLines
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property GridLines get_GridLines();
public: __property void set_GridLines(
   GridLines value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property GridLines GridLines {
   GridLines get();
   void set (    GridLines value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ColumnSetSettings Class
ColumnSetSettings Members


GridLineStyle Property

[image]
Intersoft WebGrid Documentation
GridLineStyle Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ColumnSetSettings Class : GridLineStyle Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DescriptionAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
Public Property GridLineStyle As System.Web.UI.WebControls.BorderStyle
Visual Basic (Usage) Copy Code
Dim instance As ColumnSetSettings
Dim value As System.Web.UI.WebControls.BorderStyle

instance.GridLineStyle = value

value = instance.GridLineStyle
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public System.Web.UI.WebControls.BorderStyle GridLineStyle {get; set;}
Delphi
public read-write property GridLineStyle: System.Web.UI.WebControls.BorderStyle;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DescriptionAttribute()
System.ComponentModel.DefaultValueAttribute()
public function get,set GridLineStyle : System.Web.UI.WebControls.BorderStyle
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.Web.UI.WebControls.BorderStyle get_GridLineStyle();
public: __property void set_GridLineStyle(
   System.Web.UI.WebControls.BorderStyle value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.Web.UI.WebControls.BorderStyle GridLineStyle {
   System.Web.UI.WebControls.BorderStyle get();
   void set (    System.Web.UI.WebControls.BorderStyle value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ColumnSetSettings Class
ColumnSetSettings Members


RowCount Property

[image]
Intersoft WebGrid Documentation
RowCount Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ColumnSetSettings Class : RowCount Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DescriptionAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property RowCount As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As ColumnSetSettings
Dim value As System.Integer

instance.RowCount = value

value = instance.RowCount
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.int RowCount {get; set;}
Delphi
public read-write property RowCount: System.Integer;
JScript
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DescriptionAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set RowCount : System.int
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.int get_RowCount();
public: __property void set_RowCount(
   System.int value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.int RowCount {
   System.int get();
   void set (    System.int value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ColumnSetSettings Class
ColumnSetSettings Members


ShowHeaders Property

[image]
Intersoft WebGrid Documentation
ShowHeaders Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ColumnSetSettings Class : ShowHeaders Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Property ShowHeaders As ColumnVisibility
Visual Basic (Usage) Copy Code
Dim instance As ColumnSetSettings
Dim value As ColumnVisibility

instance.ShowHeaders = value

value = instance.ShowHeaders
C#
[System.ComponentModel.DescriptionAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
public ColumnVisibility ShowHeaders {get; set;}
Delphi
public read-write property ShowHeaders: ColumnVisibility;
JScript
System.ComponentModel.DescriptionAttribute()
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.XmlSerializableAttribute()
public function get,set ShowHeaders : ColumnVisibility
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property ColumnVisibility get_ShowHeaders();
public: __property void set_ShowHeaders(
   ColumnVisibility value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property ColumnVisibility ShowHeaders {
   ColumnVisibility get();
   void set (    ColumnVisibility value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ColumnSetSettings Class
ColumnSetSettings Members


CustomAggregateArgs Class

[image]
Intersoft WebGrid Documentation
CustomAggregateArgs Class
Members See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : CustomAggregateArgs Class

Glossary Item Box

Object Model

CustomAggregateArgs Class

Syntax

Visual Basic (Declaration)
Public Class CustomAggregateArgs
   Inherits BaseEventArgs
Visual Basic (Usage) Copy Code
Dim instance As CustomAggregateArgs
C#
public class CustomAggregateArgs : BaseEventArgs
Delphi
public class CustomAggregateArgs = class(BaseEventArgs)
JScript
public class CustomAggregateArgs extends BaseEventArgs
Managed Extensions for C++
public __gc class CustomAggregateArgs : public BaseEventArgs
C++/CLI
public ref class CustomAggregateArgs : public BaseEventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
ISNet.WebUI.WebGrid.BaseEventArgs
ISNet.WebUI.WebGrid.CustomAggregateArgs

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CustomAggregateArgs Members
ISNet.WebUI.WebGrid Namespace


CustomAggregateArgs Class Members

[image]
Intersoft WebGrid Documentation
CustomAggregateArgs Class Members
See Also Properties Send Feedback
ISNet.WebUI.WebGrid Namespace : CustomAggregateArgs Class

Glossary Item Box

The following tables list the members exposed by CustomAggregateArgs.

Public Properties

 | Name | Description
Public Property | AggregateResult |
Public Property | Column |
Public Property | ReturnValue | (Inherited from ISNet.WebUI.WebGrid.BaseEventArgs)
Public Property | Rows |
Public Property | Type |
Top

See Also

Reference

CustomAggregateArgs Class
ISNet.WebUI.WebGrid Namespace


CustomAggregateArgs Class Properties

[image]
Intersoft WebGrid Documentation
CustomAggregateArgs Class Properties
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : CustomAggregateArgs Class

Glossary Item Box

For a list of all members of this type, see CustomAggregateArgs members.

Public Properties

 | Name | Description
Public Property | AggregateResult |
Public Property | Column |
Public Property | ReturnValue | (Inherited from ISNet.WebUI.WebGrid.BaseEventArgs)
Public Property | Rows |
Public Property | Type |
Top

See Also

Reference

CustomAggregateArgs Class
ISNet.WebUI.WebGrid Namespace


AggregateResult Property

[image]
Intersoft WebGrid Documentation
AggregateResult Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > CustomAggregateArgs Class : AggregateResult Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property AggregateResult As System.Object
Visual Basic (Usage) Copy Code
Dim instance As CustomAggregateArgs
Dim value As System.Object

instance.AggregateResult = value

value = instance.AggregateResult
C#
public System.object AggregateResult {get; set;}
Delphi
public read-write property AggregateResult: System.TObject;
JScript
public function get,set AggregateResult : System.Object
Managed Extensions for C++
public: __property System.Object* get_AggregateResult();
public: __property void set_AggregateResult(
   System.Object* value
);
C++/CLI
public:
property System.Object^ AggregateResult {
   System.Object^ get();
   void set (    System.Object^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CustomAggregateArgs Class
CustomAggregateArgs Members


Column Property

[image]
Intersoft WebGrid Documentation
Column Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > CustomAggregateArgs Class : Column Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Column As WebGridColumn
Visual Basic (Usage) Copy Code
Dim instance As CustomAggregateArgs
Dim value As WebGridColumn

value = instance.Column
C#
public WebGridColumn Column {get;}
Delphi
public read-only property Column: WebGridColumn;
JScript
public function get Column : WebGridColumn
Managed Extensions for C++
public: __property WebGridColumn* get_Column();
C++/CLI
public:
property WebGridColumn^ Column {
   WebGridColumn^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CustomAggregateArgs Class
CustomAggregateArgs Members


Rows Property

[image]
Intersoft WebGrid Documentation
Rows Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > CustomAggregateArgs Class : Rows Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Rows As WebGridRowCollection
Visual Basic (Usage) Copy Code
Dim instance As CustomAggregateArgs
Dim value As WebGridRowCollection

value = instance.Rows
C#
public WebGridRowCollection Rows {get;}
Delphi
public read-only property Rows: WebGridRowCollection;
JScript
public function get Rows : WebGridRowCollection
Managed Extensions for C++
public: __property WebGridRowCollection* get_Rows();
C++/CLI
public:
property WebGridRowCollection^ Rows {
   WebGridRowCollection^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CustomAggregateArgs Class
CustomAggregateArgs Members


Type Property

[image]
Intersoft WebGrid Documentation
Type Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > CustomAggregateArgs Class : Type Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Type As System.String
Visual Basic (Usage) Copy Code
Dim instance As CustomAggregateArgs
Dim value As System.String

value = instance.Type
C#
public System.string Type {get;}
Delphi
public read-only property Type: System.String;
JScript
public function get Type : System.String
Managed Extensions for C++
public: __property System.string* get_Type();
C++/CLI
public:
property System.String^ Type {
   System.String^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CustomAggregateArgs Class
CustomAggregateArgs Members


CustomEditorEditor Class

[image]
Intersoft WebGrid Documentation
CustomEditorEditor Class
Members See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : CustomEditorEditor Class

Glossary Item Box

Object Model

CustomEditorEditor Class

Syntax

Visual Basic (Declaration)
Public Class CustomEditorEditor
   Inherits System.Drawing.Design.UITypeEditor
Visual Basic (Usage) Copy Code
Dim instance As CustomEditorEditor
C#
public class CustomEditorEditor : System.Drawing.Design.UITypeEditor
Delphi
public class CustomEditorEditor = class(System.Drawing.Design.UITypeEditor)
JScript
public class CustomEditorEditor extends System.Drawing.Design.UITypeEditor
Managed Extensions for C++
public __gc class CustomEditorEditor : public System.Drawing.Design.UITypeEditor
C++/CLI
public ref class CustomEditorEditor : public System.Drawing.Design.UITypeEditor

Inheritance Hierarchy

System.Object
System.Drawing.Design.UITypeEditor
ISNet.WebUI.WebGrid.CustomEditorEditor

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CustomEditorEditor Members
ISNet.WebUI.WebGrid Namespace


CustomEditorEditor Class Members

[image]
Intersoft WebGrid Documentation
CustomEditorEditor Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebGrid Namespace : CustomEditorEditor Class

Glossary Item Box

The following tables list the members exposed by CustomEditorEditor.

Public Constructors

 | Name | Description
Public Constructor | CustomEditorEditor Constructor |
Top

Public Properties

 | Name | Description
Public Property | IsDropDownResizable | (Inherited from System.Drawing.Design.UITypeEditor)
Top

Public Methods

 | Name | Description
Public Method | EditValue | Overloaded. Overridden.
Public Method | GetEditStyle | Overloaded. Overridden.
Public Method | GetPaintValueSupported | Overloaded. Overridden.
Public Method | PaintValue | Overloaded. (Inherited from System.Drawing.Design.UITypeEditor)
Top

See Also

Reference

CustomEditorEditor Class
ISNet.WebUI.WebGrid Namespace


CustomEditorEditor Constructor

[image]
Intersoft WebGrid Documentation
CustomEditorEditor Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > CustomEditorEditor Class : CustomEditorEditor Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New CustomEditorEditor()
C#
public CustomEditorEditor()
Delphi
public CustomEditorEditor();
JScript
public function CustomEditorEditor();
Managed Extensions for C++
public: CustomEditorEditor();
C++/CLI
public:
CustomEditorEditor();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CustomEditorEditor Class
CustomEditorEditor Members


CustomEditorEditor Class Methods

[image]
Intersoft WebGrid Documentation
CustomEditorEditor Class Methods
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : CustomEditorEditor Class

Glossary Item Box

For a list of all members of this type, see CustomEditorEditor members.

Public Methods

 | Name | Description
Public Method | EditValue | Overloaded. Overridden.
Public Method | GetEditStyle | Overloaded. Overridden.
Public Method | GetPaintValueSupported | Overloaded. Overridden.
Public Method | PaintValue | Overloaded. (Inherited from System.Drawing.Design.UITypeEditor)
Top

See Also

Reference

CustomEditorEditor Class
ISNet.WebUI.WebGrid Namespace


CustomEditorEditor Class Properties

[image]
Intersoft WebGrid Documentation
CustomEditorEditor Class Properties
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : CustomEditorEditor Class

Glossary Item Box

For a list of all members of this type, see CustomEditorEditor members.

Public Properties

 | Name | Description
Public Property | IsDropDownResizable | (Inherited from System.Drawing.Design.UITypeEditor)
Top

See Also

Reference

CustomEditorEditor Class
ISNet.WebUI.WebGrid Namespace


EditValue Method

[image]
Intersoft WebGrid Documentation
EditValue Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > CustomEditorEditor Class : EditValue Method

Glossary Item Box

Overload List

Overload | Description
EditValue(ITypeDescriptorContext,IServiceProvider,Object) |
EditValue(IServiceProvider,Object) | (Inherited from System.Drawing.Design.UITypeEditor)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CustomEditorEditor Class
CustomEditorEditor Members


EditValue(ITypeDescriptorContext,IServiceProvider,Object) Method

[image]
Intersoft WebGrid Documentation
EditValue(ITypeDescriptorContext,IServiceProvider,Object) Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > CustomEditorEditor Class > EditValue Method : EditValue(ITypeDescriptorContext,IServiceProvider,Object) Method

context
provider
value

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Function EditValue( _
   ByVal context As System.ComponentModel.ITypeDescriptorContext, _
   ByVal provider As System.IServiceProvider, _
   ByVal value As System.Object _
) As System.Object
Visual Basic (Usage) Copy Code
Dim instance As CustomEditorEditor
Dim context As System.ComponentModel.ITypeDescriptorContext
Dim provider As System.IServiceProvider
Dim value As System.Object
Dim value As System.Object

value = instance.EditValue(context, provider, value)
C#
public override System.object EditValue(
   System.ComponentModel.ITypeDescriptorContext context,
   System.IServiceProvider provider,
   System.object value
)
Delphi
public function EditValue(
    context: System.ComponentModel.ITypeDescriptorContext;
    provider: System.IServiceProvider;
    value: System.TObject
): System.TObject; override;
JScript
public override function EditValue(
   context : System.ComponentModel.ITypeDescriptorContext,
   provider : System.IServiceProvider,
   value : System.Object
) : System.Object;
Managed Extensions for C++
public: System.Object* EditValue(
   System.ComponentModel.ITypeDescriptorContext* context,
   System.IServiceProvider* provider,
   System.Object* value
) override
C++/CLI
public:
System.Object^ EditValue(
   System.ComponentModel.ITypeDescriptorContext^ context,
   System.IServiceProvider^ provider,
   System.Object^ value
) override

Parameters

context
provider
value

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CustomEditorEditor Class
CustomEditorEditor Members
Overload List


EditValue(IServiceProvider,Object) Method

[image]
Intersoft WebGrid Documentation
EditValue(IServiceProvider,Object) Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > CustomEditorEditor Class > EditValue Method : EditValue(IServiceProvider,Object) Method

provider
value

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")>
Public Overloads Function EditValue( _
   ByVal provider As System.IServiceProvider, _
   ByVal value As System.Object _
) As System.Object
Visual Basic (Usage) Copy Code
Dim instance As CustomEditorEditor
Dim provider As System.IServiceProvider
Dim value As System.Object
Dim value As System.Object

value = instance.EditValue(provider, value)
C#
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public System.object EditValue(
   System.IServiceProvider provider,
   System.object value
)
Delphi
public function EditValue(
    provider: System.IServiceProvider;
    value: System.TObject
): System.TObject;
JScript
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")
public function EditValue(
   provider : System.IServiceProvider,
   value : System.Object
) : System.Object;
Managed Extensions for C++
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public: System.Object* EditValue(
   System.IServiceProvider* provider,
   System.Object* value
)
C++/CLI
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public:
System.Object^ EditValue(
   System.IServiceProvider^ provider,
   System.Object^ value
)

Parameters

provider
value

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CustomEditorEditor Class
CustomEditorEditor Members
Overload List


GetEditStyle Method

[image]
Intersoft WebGrid Documentation
GetEditStyle Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > CustomEditorEditor Class : GetEditStyle Method

Glossary Item Box

Overload List

Overload | Description
GetEditStyle(ITypeDescriptorContext) |
GetEditStyle() | (Inherited from System.Drawing.Design.UITypeEditor)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CustomEditorEditor Class
CustomEditorEditor Members


GetEditStyle(ITypeDescriptorContext) Method

[image]
Intersoft WebGrid Documentation
GetEditStyle(ITypeDescriptorContext) Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > CustomEditorEditor Class > GetEditStyle Method : GetEditStyle(ITypeDescriptorContext) Method

context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Function GetEditStyle( _
   ByVal context As System.ComponentModel.ITypeDescriptorContext _
) As System.Drawing.Design.UITypeEditorEditStyle
Visual Basic (Usage) Copy Code
Dim instance As CustomEditorEditor
Dim context As System.ComponentModel.ITypeDescriptorContext
Dim value As System.Drawing.Design.UITypeEditorEditStyle

value = instance.GetEditStyle(context)
C#
public override System.Drawing.Design.UITypeEditorEditStyle GetEditStyle(
   System.ComponentModel.ITypeDescriptorContext context
)
Delphi
public function GetEditStyle(
    context: System.ComponentModel.ITypeDescriptorContext
): System.Drawing.Design.UITypeEditorEditStyle; override;
JScript
public override function GetEditStyle(
   context : System.ComponentModel.ITypeDescriptorContext
) : System.Drawing.Design.UITypeEditorEditStyle;
Managed Extensions for C++
public: System.Drawing.Design.UITypeEditorEditStyle GetEditStyle(
   System.ComponentModel.ITypeDescriptorContext* context
) override
C++/CLI
public:
System.Drawing.Design.UITypeEditorEditStyle GetEditStyle(
   System.ComponentModel.ITypeDescriptorContext^ context
) override

Parameters

context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CustomEditorEditor Class
CustomEditorEditor Members
Overload List


GetEditStyle() Method

[image]
Intersoft WebGrid Documentation
GetEditStyle() Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > CustomEditorEditor Class > GetEditStyle Method : GetEditStyle() Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")>
Public Overloads Function GetEditStyle() As System.Drawing.Design.UITypeEditorEditStyle
Visual Basic (Usage) Copy Code
Dim instance As CustomEditorEditor
Dim value As System.Drawing.Design.UITypeEditorEditStyle

value = instance.GetEditStyle()
C#
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public System.Drawing.Design.UITypeEditorEditStyle GetEditStyle()
Delphi
public function GetEditStyle(): System.Drawing.Design.UITypeEditorEditStyle;
JScript
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")
public function GetEditStyle() : System.Drawing.Design.UITypeEditorEditStyle;
Managed Extensions for C++
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public: System.Drawing.Design.UITypeEditorEditStyle GetEditStyle();
C++/CLI
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public:
System.Drawing.Design.UITypeEditorEditStyle GetEditStyle();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CustomEditorEditor Class
CustomEditorEditor Members
Overload List


GetPaintValueSupported Method

[image]
Intersoft WebGrid Documentation
GetPaintValueSupported Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > CustomEditorEditor Class : GetPaintValueSupported Method

Glossary Item Box

Overload List

Overload | Description
GetPaintValueSupported(ITypeDescriptorContext) |
GetPaintValueSupported() | (Inherited from System.Drawing.Design.UITypeEditor)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CustomEditorEditor Class
CustomEditorEditor Members


GetPaintValueSupported(ITypeDescriptorContext) Method

[image]
Intersoft WebGrid Documentation
GetPaintValueSupported(ITypeDescriptorContext) Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > CustomEditorEditor Class > GetPaintValueSupported Method : GetPaintValueSupported(ITypeDescriptorContext) Method

context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Function GetPaintValueSupported( _
   ByVal context As System.ComponentModel.ITypeDescriptorContext _
) As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As CustomEditorEditor
Dim context As System.ComponentModel.ITypeDescriptorContext
Dim value As System.Boolean

value = instance.GetPaintValueSupported(context)
C#
public override System.bool GetPaintValueSupported(
   System.ComponentModel.ITypeDescriptorContext context
)
Delphi
public function GetPaintValueSupported(
    context: System.ComponentModel.ITypeDescriptorContext
): System.Boolean; override;
JScript
public override function GetPaintValueSupported(
   context : System.ComponentModel.ITypeDescriptorContext
) : System.boolean;
Managed Extensions for C++
public: System.bool GetPaintValueSupported(
   System.ComponentModel.ITypeDescriptorContext* context
) override
C++/CLI
public:
System.bool GetPaintValueSupported(
   System.ComponentModel.ITypeDescriptorContext^ context
) override

Parameters

context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CustomEditorEditor Class
CustomEditorEditor Members
Overload List


GetPaintValueSupported() Method

[image]
Intersoft WebGrid Documentation
GetPaintValueSupported() Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > CustomEditorEditor Class > GetPaintValueSupported Method : GetPaintValueSupported() Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")>
Public Overloads Function GetPaintValueSupported() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As CustomEditorEditor
Dim value As System.Boolean

value = instance.GetPaintValueSupported()
C#
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public System.bool GetPaintValueSupported()
Delphi
public function GetPaintValueSupported(): System.Boolean;
JScript
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")
public function GetPaintValueSupported() : System.boolean;
Managed Extensions for C++
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public: System.bool GetPaintValueSupported();
C++/CLI
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public:
System.bool GetPaintValueSupported();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CustomEditorEditor Class
CustomEditorEditor Members
Overload List


PaintValue Method

[image]
Intersoft WebGrid Documentation
PaintValue Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > CustomEditorEditor Class : PaintValue Method

Glossary Item Box

Overload List

Overload | Description
PaintValue(Object,Graphics,Rectangle) | (Inherited from System.Drawing.Design.UITypeEditor)
PaintValue(PaintValueEventArgs) | (Inherited from System.Drawing.Design.UITypeEditor)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CustomEditorEditor Class
CustomEditorEditor Members


PaintValue(Object,Graphics,Rectangle) Method

[image]
Intersoft WebGrid Documentation
PaintValue(Object,Graphics,Rectangle) Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > CustomEditorEditor Class > PaintValue Method : PaintValue(Object,Graphics,Rectangle) Method

value
canvas
rectangle

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Sub PaintValue( _
   ByVal value As System.Object, _
   ByVal canvas As System.Drawing.Graphics, _
   ByVal rectangle As System.Drawing.Rectangle _
)
Visual Basic (Usage) Copy Code
Dim instance As CustomEditorEditor
Dim value As System.Object
Dim canvas As System.Drawing.Graphics
Dim rectangle As System.Drawing.Rectangle

instance.PaintValue(value, canvas, rectangle)
C#
public void PaintValue(
   System.object value,
   System.Drawing.Graphics canvas,
   System.Drawing.Rectangle rectangle
)
Delphi
public procedure PaintValue(
    value: System.TObject;
    canvas: System.Drawing.Graphics;
    rectangle: System.Drawing.Rectangle
);
JScript
public function PaintValue(
   value : System.Object,
   canvas : System.Drawing.Graphics,
   rectangle : System.Drawing.Rectangle
);
Managed Extensions for C++
public: void PaintValue(
   System.Object* value,
   System.Drawing.Graphics* canvas,
   System.Drawing.Rectangle rectangle
)
C++/CLI
public:
void PaintValue(
   System.Object^ value,
   System.Drawing.Graphics^ canvas,
   System.Drawing.Rectangle rectangle
)

Parameters

value
canvas
rectangle

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CustomEditorEditor Class
CustomEditorEditor Members
Overload List


PaintValue(PaintValueEventArgs) Method

[image]
Intersoft WebGrid Documentation
PaintValue(PaintValueEventArgs) Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > CustomEditorEditor Class > PaintValue Method : PaintValue(PaintValueEventArgs) Method

e

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub PaintValue( _
   ByVal e As System.Drawing.Design.PaintValueEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As CustomEditorEditor
Dim e As System.Drawing.Design.PaintValueEventArgs

instance.PaintValue(e)
C#
public virtual void PaintValue(
   System.Drawing.Design.PaintValueEventArgs e
)
Delphi
public procedure PaintValue(
    e: System.Drawing.Design.PaintValueEventArgs
); virtual;
JScript
public function PaintValue(
   e : System.Drawing.Design.PaintValueEventArgs
);
Managed Extensions for C++
public: virtual void PaintValue(
   System.Drawing.Design.PaintValueEventArgs* e
)
C++/CLI
public:
virtual void PaintValue(
   System.Drawing.Design.PaintValueEventArgs^ e
)

Parameters

e

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CustomEditorEditor Class
CustomEditorEditor Members
Overload List


IsDropDownResizable Property

[image]
Intersoft WebGrid Documentation
IsDropDownResizable Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > CustomEditorEditor Class : IsDropDownResizable Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property IsDropDownResizable As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As CustomEditorEditor
Dim value As System.Boolean

value = instance.IsDropDownResizable
C#
public virtual System.bool IsDropDownResizable {get;}
Delphi
public read-only property IsDropDownResizable: System.Boolean; virtual;
JScript
public function get IsDropDownResizable : System.boolean
Managed Extensions for C++
public: __property virtual System.bool get_IsDropDownResizable();
C++/CLI
public:
virtual property System.bool IsDropDownResizable {
   System.bool get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CustomEditorEditor Class
CustomEditorEditor Members


CustomEditorNameEditor Class

[image]
Intersoft WebGrid Documentation
CustomEditorNameEditor Class
Members See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : CustomEditorNameEditor Class

Glossary Item Box

Object Model

CustomEditorNameEditor Class

Syntax

Visual Basic (Declaration)
Public Class CustomEditorNameEditor
   Inherits System.Drawing.Design.UITypeEditor
Visual Basic (Usage) Copy Code
Dim instance As CustomEditorNameEditor
C#
public class CustomEditorNameEditor : System.Drawing.Design.UITypeEditor
Delphi
public class CustomEditorNameEditor = class(System.Drawing.Design.UITypeEditor)
JScript
public class CustomEditorNameEditor extends System.Drawing.Design.UITypeEditor
Managed Extensions for C++
public __gc class CustomEditorNameEditor : public System.Drawing.Design.UITypeEditor
C++/CLI
public ref class CustomEditorNameEditor : public System.Drawing.Design.UITypeEditor

Inheritance Hierarchy

System.Object
System.Drawing.Design.UITypeEditor
ISNet.WebUI.WebGrid.CustomEditorNameEditor

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CustomEditorNameEditor Members
ISNet.WebUI.WebGrid Namespace


CustomEditorNameEditor Class Members

[image]
Intersoft WebGrid Documentation
CustomEditorNameEditor Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebGrid Namespace : CustomEditorNameEditor Class

Glossary Item Box

The following tables list the members exposed by CustomEditorNameEditor.

Public Constructors

 | Name | Description
Public Constructor | CustomEditorNameEditor Constructor |
Top

Public Properties

 | Name | Description
Public Property | IsDropDownResizable | (Inherited from System.Drawing.Design.UITypeEditor)
Top

Public Methods

 | Name | Description
Public Method | EditValue | Overloaded. Overridden.
Public Method | GetEditStyle | Overloaded. Overridden.
Public Method | GetPaintValueSupported | Overloaded. Overridden.
Public Method | PaintValue | Overloaded. (Inherited from System.Drawing.Design.UITypeEditor)
Top

See Also

Reference

CustomEditorNameEditor Class
ISNet.WebUI.WebGrid Namespace


CustomEditorNameEditor Constructor

[image]
Intersoft WebGrid Documentation
CustomEditorNameEditor Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > CustomEditorNameEditor Class : CustomEditorNameEditor Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New CustomEditorNameEditor()
C#
public CustomEditorNameEditor()
Delphi
public CustomEditorNameEditor();
JScript
public function CustomEditorNameEditor();
Managed Extensions for C++
public: CustomEditorNameEditor();
C++/CLI
public:
CustomEditorNameEditor();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CustomEditorNameEditor Class
CustomEditorNameEditor Members


CustomEditorNameEditor Class Methods

[image]
Intersoft WebGrid Documentation
CustomEditorNameEditor Class Methods
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : CustomEditorNameEditor Class

Glossary Item Box

For a list of all members of this type, see CustomEditorNameEditor members.

Public Methods

 | Name | Description
Public Method | EditValue | Overloaded. Overridden.
Public Method | GetEditStyle | Overloaded. Overridden.
Public Method | GetPaintValueSupported | Overloaded. Overridden.
Public Method | PaintValue | Overloaded. (Inherited from System.Drawing.Design.UITypeEditor)
Top

See Also

Reference

CustomEditorNameEditor Class
ISNet.WebUI.WebGrid Namespace


CustomEditorNameEditor Class Properties

[image]
Intersoft WebGrid Documentation
CustomEditorNameEditor Class Properties
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : CustomEditorNameEditor Class

Glossary Item Box

For a list of all members of this type, see CustomEditorNameEditor members.

Public Properties

 | Name | Description
Public Property | IsDropDownResizable | (Inherited from System.Drawing.Design.UITypeEditor)
Top

See Also

Reference

CustomEditorNameEditor Class
ISNet.WebUI.WebGrid Namespace


EditValue Method

[image]
Intersoft WebGrid Documentation
EditValue Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > CustomEditorNameEditor Class : EditValue Method

Glossary Item Box

Overload List

Overload | Description
EditValue(ITypeDescriptorContext,IServiceProvider,Object) |
EditValue(IServiceProvider,Object) | (Inherited from System.Drawing.Design.UITypeEditor)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CustomEditorNameEditor Class
CustomEditorNameEditor Members


EditValue(ITypeDescriptorContext,IServiceProvider,Object) Method

[image]
Intersoft WebGrid Documentation
EditValue(ITypeDescriptorContext,IServiceProvider,Object) Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > CustomEditorNameEditor Class > EditValue Method : EditValue(ITypeDescriptorContext,IServiceProvider,Object) Method

context
provider
value

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Function EditValue( _
   ByVal context As System.ComponentModel.ITypeDescriptorContext, _
   ByVal provider As System.IServiceProvider, _
   ByVal value As System.Object _
) As System.Object
Visual Basic (Usage) Copy Code
Dim instance As CustomEditorNameEditor
Dim context As System.ComponentModel.ITypeDescriptorContext
Dim provider As System.IServiceProvider
Dim value As System.Object
Dim value As System.Object

value = instance.EditValue(context, provider, value)
C#
public override System.object EditValue(
   System.ComponentModel.ITypeDescriptorContext context,
   System.IServiceProvider provider,
   System.object value
)
Delphi
public function EditValue(
    context: System.ComponentModel.ITypeDescriptorContext;
    provider: System.IServiceProvider;
    value: System.TObject
): System.TObject; override;
JScript
public override function EditValue(
   context : System.ComponentModel.ITypeDescriptorContext,
   provider : System.IServiceProvider,
   value : System.Object
) : System.Object;
Managed Extensions for C++
public: System.Object* EditValue(
   System.ComponentModel.ITypeDescriptorContext* context,
   System.IServiceProvider* provider,
   System.Object* value
) override
C++/CLI
public:
System.Object^ EditValue(
   System.ComponentModel.ITypeDescriptorContext^ context,
   System.IServiceProvider^ provider,
   System.Object^ value
) override

Parameters

context
provider
value

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CustomEditorNameEditor Class
CustomEditorNameEditor Members
Overload List


EditValue(IServiceProvider,Object) Method

[image]
Intersoft WebGrid Documentation
EditValue(IServiceProvider,Object) Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > CustomEditorNameEditor Class > EditValue Method : EditValue(IServiceProvider,Object) Method

provider
value

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")>
Public Overloads Function EditValue( _
   ByVal provider As System.IServiceProvider, _
   ByVal value As System.Object _
) As System.Object
Visual Basic (Usage) Copy Code
Dim instance As CustomEditorNameEditor
Dim provider As System.IServiceProvider
Dim value As System.Object
Dim value As System.Object

value = instance.EditValue(provider, value)
C#
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public System.object EditValue(
   System.IServiceProvider provider,
   System.object value
)
Delphi
public function EditValue(
    provider: System.IServiceProvider;
    value: System.TObject
): System.TObject;
JScript
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")
public function EditValue(
   provider : System.IServiceProvider,
   value : System.Object
) : System.Object;
Managed Extensions for C++
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public: System.Object* EditValue(
   System.IServiceProvider* provider,
   System.Object* value
)
C++/CLI
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public:
System.Object^ EditValue(
   System.IServiceProvider^ provider,
   System.Object^ value
)

Parameters

provider
value

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CustomEditorNameEditor Class
CustomEditorNameEditor Members
Overload List


GetEditStyle Method

[image]
Intersoft WebGrid Documentation
GetEditStyle Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > CustomEditorNameEditor Class : GetEditStyle Method

Glossary Item Box

Overload List

Overload | Description
GetEditStyle(ITypeDescriptorContext) |
GetEditStyle() | (Inherited from System.Drawing.Design.UITypeEditor)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CustomEditorNameEditor Class
CustomEditorNameEditor Members


GetEditStyle(ITypeDescriptorContext) Method

[image]
Intersoft WebGrid Documentation
GetEditStyle(ITypeDescriptorContext) Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > CustomEditorNameEditor Class > GetEditStyle Method : GetEditStyle(ITypeDescriptorContext) Method

context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Function GetEditStyle( _
   ByVal context As System.ComponentModel.ITypeDescriptorContext _
) As System.Drawing.Design.UITypeEditorEditStyle
Visual Basic (Usage) Copy Code
Dim instance As CustomEditorNameEditor
Dim context As System.ComponentModel.ITypeDescriptorContext
Dim value As System.Drawing.Design.UITypeEditorEditStyle

value = instance.GetEditStyle(context)
C#
public override System.Drawing.Design.UITypeEditorEditStyle GetEditStyle(
   System.ComponentModel.ITypeDescriptorContext context
)
Delphi
public function GetEditStyle(
    context: System.ComponentModel.ITypeDescriptorContext
): System.Drawing.Design.UITypeEditorEditStyle; override;
JScript
public override function GetEditStyle(
   context : System.ComponentModel.ITypeDescriptorContext
) : System.Drawing.Design.UITypeEditorEditStyle;
Managed Extensions for C++
public: System.Drawing.Design.UITypeEditorEditStyle GetEditStyle(
   System.ComponentModel.ITypeDescriptorContext* context
) override
C++/CLI
public:
System.Drawing.Design.UITypeEditorEditStyle GetEditStyle(
   System.ComponentModel.ITypeDescriptorContext^ context
) override

Parameters

context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CustomEditorNameEditor Class
CustomEditorNameEditor Members
Overload List


GetEditStyle() Method

[image]
Intersoft WebGrid Documentation
GetEditStyle() Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > CustomEditorNameEditor Class > GetEditStyle Method : GetEditStyle() Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")>
Public Overloads Function GetEditStyle() As System.Drawing.Design.UITypeEditorEditStyle
Visual Basic (Usage) Copy Code
Dim instance As CustomEditorNameEditor
Dim value As System.Drawing.Design.UITypeEditorEditStyle

value = instance.GetEditStyle()
C#
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public System.Drawing.Design.UITypeEditorEditStyle GetEditStyle()
Delphi
public function GetEditStyle(): System.Drawing.Design.UITypeEditorEditStyle;
JScript
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")
public function GetEditStyle() : System.Drawing.Design.UITypeEditorEditStyle;
Managed Extensions for C++
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public: System.Drawing.Design.UITypeEditorEditStyle GetEditStyle();
C++/CLI
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public:
System.Drawing.Design.UITypeEditorEditStyle GetEditStyle();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CustomEditorNameEditor Class
CustomEditorNameEditor Members
Overload List


GetPaintValueSupported Method

[image]
Intersoft WebGrid Documentation
GetPaintValueSupported Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > CustomEditorNameEditor Class : GetPaintValueSupported Method

Glossary Item Box

Overload List

Overload | Description
GetPaintValueSupported(ITypeDescriptorContext) |
GetPaintValueSupported() | (Inherited from System.Drawing.Design.UITypeEditor)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CustomEditorNameEditor Class
CustomEditorNameEditor Members


GetPaintValueSupported(ITypeDescriptorContext) Method

[image]
Intersoft WebGrid Documentation
GetPaintValueSupported(ITypeDescriptorContext) Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > CustomEditorNameEditor Class > GetPaintValueSupported Method : GetPaintValueSupported(ITypeDescriptorContext) Method

context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Function GetPaintValueSupported( _
   ByVal context As System.ComponentModel.ITypeDescriptorContext _
) As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As CustomEditorNameEditor
Dim context As System.ComponentModel.ITypeDescriptorContext
Dim value As System.Boolean

value = instance.GetPaintValueSupported(context)
C#
public override System.bool GetPaintValueSupported(
   System.ComponentModel.ITypeDescriptorContext context
)
Delphi
public function GetPaintValueSupported(
    context: System.ComponentModel.ITypeDescriptorContext
): System.Boolean; override;
JScript
public override function GetPaintValueSupported(
   context : System.ComponentModel.ITypeDescriptorContext
) : System.boolean;
Managed Extensions for C++
public: System.bool GetPaintValueSupported(
   System.ComponentModel.ITypeDescriptorContext* context
) override
C++/CLI
public:
System.bool GetPaintValueSupported(
   System.ComponentModel.ITypeDescriptorContext^ context
) override

Parameters

context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CustomEditorNameEditor Class
CustomEditorNameEditor Members
Overload List


GetPaintValueSupported() Method

[image]
Intersoft WebGrid Documentation
GetPaintValueSupported() Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > CustomEditorNameEditor Class > GetPaintValueSupported Method : GetPaintValueSupported() Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")>
Public Overloads Function GetPaintValueSupported() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As CustomEditorNameEditor
Dim value As System.Boolean

value = instance.GetPaintValueSupported()
C#
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public System.bool GetPaintValueSupported()
Delphi
public function GetPaintValueSupported(): System.Boolean;
JScript
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")
public function GetPaintValueSupported() : System.boolean;
Managed Extensions for C++
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public: System.bool GetPaintValueSupported();
C++/CLI
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public:
System.bool GetPaintValueSupported();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CustomEditorNameEditor Class
CustomEditorNameEditor Members
Overload List


PaintValue Method

[image]
Intersoft WebGrid Documentation
PaintValue Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > CustomEditorNameEditor Class : PaintValue Method

Glossary Item Box

Overload List

Overload | Description
PaintValue(Object,Graphics,Rectangle) | (Inherited from System.Drawing.Design.UITypeEditor)
PaintValue(PaintValueEventArgs) | (Inherited from System.Drawing.Design.UITypeEditor)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CustomEditorNameEditor Class
CustomEditorNameEditor Members


PaintValue(Object,Graphics,Rectangle) Method

[image]
Intersoft WebGrid Documentation
PaintValue(Object,Graphics,Rectangle) Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > CustomEditorNameEditor Class > PaintValue Method : PaintValue(Object,Graphics,Rectangle) Method

value
canvas
rectangle

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Sub PaintValue( _
   ByVal value As System.Object, _
   ByVal canvas As System.Drawing.Graphics, _
   ByVal rectangle As System.Drawing.Rectangle _
)
Visual Basic (Usage) Copy Code
Dim instance As CustomEditorNameEditor
Dim value As System.Object
Dim canvas As System.Drawing.Graphics
Dim rectangle As System.Drawing.Rectangle

instance.PaintValue(value, canvas, rectangle)
C#
public void PaintValue(
   System.object value,
   System.Drawing.Graphics canvas,
   System.Drawing.Rectangle rectangle
)
Delphi
public procedure PaintValue(
    value: System.TObject;
    canvas: System.Drawing.Graphics;
    rectangle: System.Drawing.Rectangle
);
JScript
public function PaintValue(
   value : System.Object,
   canvas : System.Drawing.Graphics,
   rectangle : System.Drawing.Rectangle
);
Managed Extensions for C++
public: void PaintValue(
   System.Object* value,
   System.Drawing.Graphics* canvas,
   System.Drawing.Rectangle rectangle
)
C++/CLI
public:
void PaintValue(
   System.Object^ value,
   System.Drawing.Graphics^ canvas,
   System.Drawing.Rectangle rectangle
)

Parameters

value
canvas
rectangle

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CustomEditorNameEditor Class
CustomEditorNameEditor Members
Overload List


PaintValue(PaintValueEventArgs) Method

[image]
Intersoft WebGrid Documentation
PaintValue(PaintValueEventArgs) Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > CustomEditorNameEditor Class > PaintValue Method : PaintValue(PaintValueEventArgs) Method

e

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub PaintValue( _
   ByVal e As System.Drawing.Design.PaintValueEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As CustomEditorNameEditor
Dim e As System.Drawing.Design.PaintValueEventArgs

instance.PaintValue(e)
C#
public virtual void PaintValue(
   System.Drawing.Design.PaintValueEventArgs e
)
Delphi
public procedure PaintValue(
    e: System.Drawing.Design.PaintValueEventArgs
); virtual;
JScript
public function PaintValue(
   e : System.Drawing.Design.PaintValueEventArgs
);
Managed Extensions for C++
public: virtual void PaintValue(
   System.Drawing.Design.PaintValueEventArgs* e
)
C++/CLI
public:
virtual void PaintValue(
   System.Drawing.Design.PaintValueEventArgs^ e
)

Parameters

e

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CustomEditorNameEditor Class
CustomEditorNameEditor Members
Overload List


IsDropDownResizable Property

[image]
Intersoft WebGrid Documentation
IsDropDownResizable Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > CustomEditorNameEditor Class : IsDropDownResizable Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property IsDropDownResizable As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As CustomEditorNameEditor
Dim value As System.Boolean

value = instance.IsDropDownResizable
C#
public virtual System.bool IsDropDownResizable {get;}
Delphi
public read-only property IsDropDownResizable: System.Boolean; virtual;
JScript
public function get IsDropDownResizable : System.boolean
Managed Extensions for C++
public: __property virtual System.bool get_IsDropDownResizable();
C++/CLI
public:
virtual property System.bool IsDropDownResizable {
   System.bool get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CustomEditorNameEditor Class
CustomEditorNameEditor Members


CustomVirtualLoad Class

[image]
Intersoft WebGrid Documentation
CustomVirtualLoad Class
Members See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : CustomVirtualLoad Class

Glossary Item Box

Object Model

CustomVirtualLoad Class

Syntax

Visual Basic (Declaration)
Public Class CustomVirtualLoad
Visual Basic (Usage) Copy Code
Dim instance As CustomVirtualLoad
C#
public class CustomVirtualLoad
Delphi
public class CustomVirtualLoad
JScript
public class CustomVirtualLoad
Managed Extensions for C++
public __gc class CustomVirtualLoad
C++/CLI
public ref class CustomVirtualLoad

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebGrid.CustomVirtualLoad

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CustomVirtualLoad Members
ISNet.WebUI.WebGrid Namespace


CustomVirtualLoad Class Members

[image]
Intersoft WebGrid Documentation
CustomVirtualLoad Class Members
See Also Fields Send Feedback
ISNet.WebUI.WebGrid Namespace : CustomVirtualLoad Class

Glossary Item Box

The following tables list the members exposed by CustomVirtualLoad.

Public Constructors

 | Name | Description
Public Constructor | CustomVirtualLoad Constructor |
Top

Public Fields

 | Name | Description
Public Field | RequestedRows |
Public Field | TotalDataSourceRows |
Top

See Also

Reference

CustomVirtualLoad Class
ISNet.WebUI.WebGrid Namespace


CustomVirtualLoad Constructor

[image]
Intersoft WebGrid Documentation
CustomVirtualLoad Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > CustomVirtualLoad Class : CustomVirtualLoad Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New CustomVirtualLoad()
C#
public CustomVirtualLoad()
Delphi
public CustomVirtualLoad();
JScript
public function CustomVirtualLoad();
Managed Extensions for C++
public: CustomVirtualLoad();
C++/CLI
public:
CustomVirtualLoad();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CustomVirtualLoad Class
CustomVirtualLoad Members


CustomVirtualLoad Class Fields

[image]
Intersoft WebGrid Documentation
CustomVirtualLoad Class Fields
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : CustomVirtualLoad Class

Glossary Item Box

For a list of all members of this type, see CustomVirtualLoad members.

Public Fields

 | Name | Description
Public Field | RequestedRows |
Public Field | TotalDataSourceRows |
Top

See Also

Reference

CustomVirtualLoad Class
ISNet.WebUI.WebGrid Namespace


RequestedRows Field

[image]
Intersoft WebGrid Documentation
RequestedRows Field
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > CustomVirtualLoad Class : RequestedRows Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public RequestedRows As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As CustomVirtualLoad
Dim value As System.Integer

value = instance.RequestedRows

instance.RequestedRows = value
C#
public System.int RequestedRows
Delphi
public field RequestedRows: System.Integer;
JScript
public var RequestedRows : System.int;
Managed Extensions for C++
public: System.int RequestedRows
C++/CLI
public:
System.int RequestedRows

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CustomVirtualLoad Class
CustomVirtualLoad Members


TotalDataSourceRows Field

[image]
Intersoft WebGrid Documentation
TotalDataSourceRows Field
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > CustomVirtualLoad Class : TotalDataSourceRows Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public TotalDataSourceRows As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As CustomVirtualLoad
Dim value As System.Integer

value = instance.TotalDataSourceRows

instance.TotalDataSourceRows = value
C#
public System.int TotalDataSourceRows
Delphi
public field TotalDataSourceRows: System.Integer;
JScript
public var TotalDataSourceRows : System.int;
Managed Extensions for C++
public: System.int TotalDataSourceRows
C++/CLI
public:
System.int TotalDataSourceRows

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CustomVirtualLoad Class
CustomVirtualLoad Members


DataFieldEditor Class

[image]
Intersoft WebGrid Documentation
DataFieldEditor Class
Members See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : DataFieldEditor Class

Glossary Item Box

Object Model

DataFieldEditor Class

Syntax

Visual Basic (Declaration)
Public Class DataFieldEditor
   Inherits System.Drawing.Design.UITypeEditor
Visual Basic (Usage) Copy Code
Dim instance As DataFieldEditor
C#
public class DataFieldEditor : System.Drawing.Design.UITypeEditor
Delphi
public class DataFieldEditor = class(System.Drawing.Design.UITypeEditor)
JScript
public class DataFieldEditor extends System.Drawing.Design.UITypeEditor
Managed Extensions for C++
public __gc class DataFieldEditor : public System.Drawing.Design.UITypeEditor
C++/CLI
public ref class DataFieldEditor : public System.Drawing.Design.UITypeEditor

Inheritance Hierarchy

System.Object
System.Drawing.Design.UITypeEditor
ISNet.WebUI.WebGrid.DataFieldEditor

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataFieldEditor Members
ISNet.WebUI.WebGrid Namespace


DataFieldEditor Class Members

[image]
Intersoft WebGrid Documentation
DataFieldEditor Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebGrid Namespace : DataFieldEditor Class

Glossary Item Box

The following tables list the members exposed by DataFieldEditor.

Public Constructors

 | Name | Description
Public Constructor | DataFieldEditor Constructor |
Top

Public Properties

 | Name | Description
Public Property | IsDropDownResizable | (Inherited from System.Drawing.Design.UITypeEditor)
Top

Public Methods

 | Name | Description
Public Method | EditValue | Overloaded. Overridden.
Public Method | GetEditStyle | Overloaded. Overridden.
Public Method | GetPaintValueSupported | Overloaded. Overridden.
Public Method | PaintValue | Overloaded. (Inherited from System.Drawing.Design.UITypeEditor)
Top

See Also

Reference

DataFieldEditor Class
ISNet.WebUI.WebGrid Namespace


DataFieldEditor Constructor

[image]
Intersoft WebGrid Documentation
DataFieldEditor Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > DataFieldEditor Class : DataFieldEditor Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New DataFieldEditor()
C#
public DataFieldEditor()
Delphi
public DataFieldEditor();
JScript
public function DataFieldEditor();
Managed Extensions for C++
public: DataFieldEditor();
C++/CLI
public:
DataFieldEditor();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataFieldEditor Class
DataFieldEditor Members


DataFieldEditor Class Methods

[image]
Intersoft WebGrid Documentation
DataFieldEditor Class Methods
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : DataFieldEditor Class

Glossary Item Box

For a list of all members of this type, see DataFieldEditor members.

Public Methods

 | Name | Description
Public Method | EditValue | Overloaded. Overridden.
Public Method | GetEditStyle | Overloaded. Overridden.
Public Method | GetPaintValueSupported | Overloaded. Overridden.
Public Method | PaintValue | Overloaded. (Inherited from System.Drawing.Design.UITypeEditor)
Top

See Also

Reference

DataFieldEditor Class
ISNet.WebUI.WebGrid Namespace


DataFieldEditor Class Properties

[image]
Intersoft WebGrid Documentation
DataFieldEditor Class Properties
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : DataFieldEditor Class

Glossary Item Box

For a list of all members of this type, see DataFieldEditor members.

Public Properties

 | Name | Description
Public Property | IsDropDownResizable | (Inherited from System.Drawing.Design.UITypeEditor)
Top

See Also

Reference

DataFieldEditor Class
ISNet.WebUI.WebGrid Namespace


EditValue Method

[image]
Intersoft WebGrid Documentation
EditValue Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > DataFieldEditor Class : EditValue Method

Glossary Item Box

Overload List

Overload | Description
EditValue(ITypeDescriptorContext,IServiceProvider,Object) |
EditValue(IServiceProvider,Object) | (Inherited from System.Drawing.Design.UITypeEditor)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataFieldEditor Class
DataFieldEditor Members


EditValue(ITypeDescriptorContext,IServiceProvider,Object) Method

[image]
Intersoft WebGrid Documentation
EditValue(ITypeDescriptorContext,IServiceProvider,Object) Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > DataFieldEditor Class > EditValue Method : EditValue(ITypeDescriptorContext,IServiceProvider,Object) Method

context
provider
value

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Function EditValue( _
   ByVal context As System.ComponentModel.ITypeDescriptorContext, _
   ByVal provider As System.IServiceProvider, _
   ByVal value As System.Object _
) As System.Object
Visual Basic (Usage) Copy Code
Dim instance As DataFieldEditor
Dim context As System.ComponentModel.ITypeDescriptorContext
Dim provider As System.IServiceProvider
Dim value As System.Object
Dim value As System.Object

value = instance.EditValue(context, provider, value)
C#
public override System.object EditValue(
   System.ComponentModel.ITypeDescriptorContext context,
   System.IServiceProvider provider,
   System.object value
)
Delphi
public function EditValue(
    context: System.ComponentModel.ITypeDescriptorContext;
    provider: System.IServiceProvider;
    value: System.TObject
): System.TObject; override;
JScript
public override function EditValue(
   context : System.ComponentModel.ITypeDescriptorContext,
   provider : System.IServiceProvider,
   value : System.Object
) : System.Object;
Managed Extensions for C++
public: System.Object* EditValue(
   System.ComponentModel.ITypeDescriptorContext* context,
   System.IServiceProvider* provider,
   System.Object* value
) override
C++/CLI
public:
System.Object^ EditValue(
   System.ComponentModel.ITypeDescriptorContext^ context,
   System.IServiceProvider^ provider,
   System.Object^ value
) override

Parameters

context
provider
value

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataFieldEditor Class
DataFieldEditor Members
Overload List


EditValue(IServiceProvider,Object) Method

[image]
Intersoft WebGrid Documentation
EditValue(IServiceProvider,Object) Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > DataFieldEditor Class > EditValue Method : EditValue(IServiceProvider,Object) Method

provider
value

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")>
Public Overloads Function EditValue( _
   ByVal provider As System.IServiceProvider, _
   ByVal value As System.Object _
) As System.Object
Visual Basic (Usage) Copy Code
Dim instance As DataFieldEditor
Dim provider As System.IServiceProvider
Dim value As System.Object
Dim value As System.Object

value = instance.EditValue(provider, value)
C#
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public System.object EditValue(
   System.IServiceProvider provider,
   System.object value
)
Delphi
public function EditValue(
    provider: System.IServiceProvider;
    value: System.TObject
): System.TObject;
JScript
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")
public function EditValue(
   provider : System.IServiceProvider,
   value : System.Object
) : System.Object;
Managed Extensions for C++
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public: System.Object* EditValue(
   System.IServiceProvider* provider,
   System.Object* value
)
C++/CLI
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public:
System.Object^ EditValue(
   System.IServiceProvider^ provider,
   System.Object^ value
)

Parameters

provider
value

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataFieldEditor Class
DataFieldEditor Members
Overload List


GetEditStyle Method

[image]
Intersoft WebGrid Documentation
GetEditStyle Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > DataFieldEditor Class : GetEditStyle Method

Glossary Item Box

Overload List

Overload | Description
GetEditStyle(ITypeDescriptorContext) |
GetEditStyle() | (Inherited from System.Drawing.Design.UITypeEditor)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataFieldEditor Class
DataFieldEditor Members


GetEditStyle(ITypeDescriptorContext) Method

[image]
Intersoft WebGrid Documentation
GetEditStyle(ITypeDescriptorContext) Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > DataFieldEditor Class > GetEditStyle Method : GetEditStyle(ITypeDescriptorContext) Method

context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Function GetEditStyle( _
   ByVal context As System.ComponentModel.ITypeDescriptorContext _
) As System.Drawing.Design.UITypeEditorEditStyle
Visual Basic (Usage) Copy Code
Dim instance As DataFieldEditor
Dim context As System.ComponentModel.ITypeDescriptorContext
Dim value As System.Drawing.Design.UITypeEditorEditStyle

value = instance.GetEditStyle(context)
C#
public override System.Drawing.Design.UITypeEditorEditStyle GetEditStyle(
   System.ComponentModel.ITypeDescriptorContext context
)
Delphi
public function GetEditStyle(
    context: System.ComponentModel.ITypeDescriptorContext
): System.Drawing.Design.UITypeEditorEditStyle; override;
JScript
public override function GetEditStyle(
   context : System.ComponentModel.ITypeDescriptorContext
) : System.Drawing.Design.UITypeEditorEditStyle;
Managed Extensions for C++
public: System.Drawing.Design.UITypeEditorEditStyle GetEditStyle(
   System.ComponentModel.ITypeDescriptorContext* context
) override
C++/CLI
public:
System.Drawing.Design.UITypeEditorEditStyle GetEditStyle(
   System.ComponentModel.ITypeDescriptorContext^ context
) override

Parameters

context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataFieldEditor Class
DataFieldEditor Members
Overload List


GetEditStyle() Method

[image]
Intersoft WebGrid Documentation
GetEditStyle() Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > DataFieldEditor Class > GetEditStyle Method : GetEditStyle() Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")>
Public Overloads Function GetEditStyle() As System.Drawing.Design.UITypeEditorEditStyle
Visual Basic (Usage) Copy Code
Dim instance As DataFieldEditor
Dim value As System.Drawing.Design.UITypeEditorEditStyle

value = instance.GetEditStyle()
C#
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public System.Drawing.Design.UITypeEditorEditStyle GetEditStyle()
Delphi
public function GetEditStyle(): System.Drawing.Design.UITypeEditorEditStyle;
JScript
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")
public function GetEditStyle() : System.Drawing.Design.UITypeEditorEditStyle;
Managed Extensions for C++
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public: System.Drawing.Design.UITypeEditorEditStyle GetEditStyle();
C++/CLI
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public:
System.Drawing.Design.UITypeEditorEditStyle GetEditStyle();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataFieldEditor Class
DataFieldEditor Members
Overload List


GetPaintValueSupported Method

[image]
Intersoft WebGrid Documentation
GetPaintValueSupported Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > DataFieldEditor Class : GetPaintValueSupported Method

Glossary Item Box

Overload List

Overload | Description
GetPaintValueSupported(ITypeDescriptorContext) |
GetPaintValueSupported() | (Inherited from System.Drawing.Design.UITypeEditor)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataFieldEditor Class
DataFieldEditor Members


GetPaintValueSupported(ITypeDescriptorContext) Method

[image]
Intersoft WebGrid Documentation
GetPaintValueSupported(ITypeDescriptorContext) Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > DataFieldEditor Class > GetPaintValueSupported Method : GetPaintValueSupported(ITypeDescriptorContext) Method

context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Function GetPaintValueSupported( _
   ByVal context As System.ComponentModel.ITypeDescriptorContext _
) As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As DataFieldEditor
Dim context As System.ComponentModel.ITypeDescriptorContext
Dim value As System.Boolean

value = instance.GetPaintValueSupported(context)
C#
public override System.bool GetPaintValueSupported(
   System.ComponentModel.ITypeDescriptorContext context
)
Delphi
public function GetPaintValueSupported(
    context: System.ComponentModel.ITypeDescriptorContext
): System.Boolean; override;
JScript
public override function GetPaintValueSupported(
   context : System.ComponentModel.ITypeDescriptorContext
) : System.boolean;
Managed Extensions for C++
public: System.bool GetPaintValueSupported(
   System.ComponentModel.ITypeDescriptorContext* context
) override
C++/CLI
public:
System.bool GetPaintValueSupported(
   System.ComponentModel.ITypeDescriptorContext^ context
) override

Parameters

context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataFieldEditor Class
DataFieldEditor Members
Overload List


GetPaintValueSupported() Method

[image]
Intersoft WebGrid Documentation
GetPaintValueSupported() Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > DataFieldEditor Class > GetPaintValueSupported Method : GetPaintValueSupported() Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")>
Public Overloads Function GetPaintValueSupported() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As DataFieldEditor
Dim value As System.Boolean

value = instance.GetPaintValueSupported()
C#
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public System.bool GetPaintValueSupported()
Delphi
public function GetPaintValueSupported(): System.Boolean;
JScript
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")
public function GetPaintValueSupported() : System.boolean;
Managed Extensions for C++
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public: System.bool GetPaintValueSupported();
C++/CLI
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public:
System.bool GetPaintValueSupported();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataFieldEditor Class
DataFieldEditor Members
Overload List


PaintValue Method

[image]
Intersoft WebGrid Documentation
PaintValue Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > DataFieldEditor Class : PaintValue Method

Glossary Item Box

Overload List

Overload | Description
PaintValue(Object,Graphics,Rectangle) | (Inherited from System.Drawing.Design.UITypeEditor)
PaintValue(PaintValueEventArgs) | (Inherited from System.Drawing.Design.UITypeEditor)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataFieldEditor Class
DataFieldEditor Members


PaintValue(Object,Graphics,Rectangle) Method

[image]
Intersoft WebGrid Documentation
PaintValue(Object,Graphics,Rectangle) Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > DataFieldEditor Class > PaintValue Method : PaintValue(Object,Graphics,Rectangle) Method

value
canvas
rectangle

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Sub PaintValue( _
   ByVal value As System.Object, _
   ByVal canvas As System.Drawing.Graphics, _
   ByVal rectangle As System.Drawing.Rectangle _
)
Visual Basic (Usage) Copy Code
Dim instance As DataFieldEditor
Dim value As System.Object
Dim canvas As System.Drawing.Graphics
Dim rectangle As System.Drawing.Rectangle

instance.PaintValue(value, canvas, rectangle)
C#
public void PaintValue(
   System.object value,
   System.Drawing.Graphics canvas,
   System.Drawing.Rectangle rectangle
)
Delphi
public procedure PaintValue(
    value: System.TObject;
    canvas: System.Drawing.Graphics;
    rectangle: System.Drawing.Rectangle
);
JScript
public function PaintValue(
   value : System.Object,
   canvas : System.Drawing.Graphics,
   rectangle : System.Drawing.Rectangle
);
Managed Extensions for C++
public: void PaintValue(
   System.Object* value,
   System.Drawing.Graphics* canvas,
   System.Drawing.Rectangle rectangle
)
C++/CLI
public:
void PaintValue(
   System.Object^ value,
   System.Drawing.Graphics^ canvas,
   System.Drawing.Rectangle rectangle
)

Parameters

value
canvas
rectangle

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataFieldEditor Class
DataFieldEditor Members
Overload List


PaintValue(PaintValueEventArgs) Method

[image]
Intersoft WebGrid Documentation
PaintValue(PaintValueEventArgs) Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > DataFieldEditor Class > PaintValue Method : PaintValue(PaintValueEventArgs) Method

e

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub PaintValue( _
   ByVal e As System.Drawing.Design.PaintValueEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As DataFieldEditor
Dim e As System.Drawing.Design.PaintValueEventArgs

instance.PaintValue(e)
C#
public virtual void PaintValue(
   System.Drawing.Design.PaintValueEventArgs e
)
Delphi
public procedure PaintValue(
    e: System.Drawing.Design.PaintValueEventArgs
); virtual;
JScript
public function PaintValue(
   e : System.Drawing.Design.PaintValueEventArgs
);
Managed Extensions for C++
public: virtual void PaintValue(
   System.Drawing.Design.PaintValueEventArgs* e
)
C++/CLI
public:
virtual void PaintValue(
   System.Drawing.Design.PaintValueEventArgs^ e
)

Parameters

e

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataFieldEditor Class
DataFieldEditor Members
Overload List


IsDropDownResizable Property

[image]
Intersoft WebGrid Documentation
IsDropDownResizable Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > DataFieldEditor Class : IsDropDownResizable Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property IsDropDownResizable As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As DataFieldEditor
Dim value As System.Boolean

value = instance.IsDropDownResizable
C#
public virtual System.bool IsDropDownResizable {get;}
Delphi
public read-only property IsDropDownResizable: System.Boolean; virtual;
JScript
public function get IsDropDownResizable : System.boolean
Managed Extensions for C++
public: __property virtual System.bool get_IsDropDownResizable();
C++/CLI
public:
virtual property System.bool IsDropDownResizable {
   System.bool get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataFieldEditor Class
DataFieldEditor Members


DataSourceEventArgs Class

[image]
Intersoft WebGrid Documentation
DataSourceEventArgs Class
Members See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : DataSourceEventArgs Class

Glossary Item Box

Object Model

DataSourceEventArgs Class

Syntax

Visual Basic (Declaration)
Public Class DataSourceEventArgs
   Inherits BaseEventArgs
Visual Basic (Usage) Copy Code
Dim instance As DataSourceEventArgs
C#
public class DataSourceEventArgs : BaseEventArgs
Delphi
public class DataSourceEventArgs = class(BaseEventArgs)
JScript
public class DataSourceEventArgs extends BaseEventArgs
Managed Extensions for C++
public __gc class DataSourceEventArgs : public BaseEventArgs
C++/CLI
public ref class DataSourceEventArgs : public BaseEventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
ISNet.WebUI.WebGrid.BaseEventArgs
ISNet.WebUI.WebGrid.DataSourceEventArgs

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataSourceEventArgs Members
ISNet.WebUI.WebGrid Namespace


DataSourceEventArgs Class Members

[image]
Intersoft WebGrid Documentation
DataSourceEventArgs Class Members
See Also Properties Send Feedback
ISNet.WebUI.WebGrid Namespace : DataSourceEventArgs Class

Glossary Item Box

The following tables list the members exposed by DataSourceEventArgs.

Public Properties

 | Name | Description
Public Property | DataSource |
Public Property | ReturnValue | (Inherited from ISNet.WebUI.WebGrid.BaseEventArgs)
Top

See Also

Reference

DataSourceEventArgs Class
ISNet.WebUI.WebGrid Namespace


DataSourceEventArgs Class Properties

[image]
Intersoft WebGrid Documentation
DataSourceEventArgs Class Properties
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : DataSourceEventArgs Class

Glossary Item Box

For a list of all members of this type, see DataSourceEventArgs members.

Public Properties

 | Name | Description
Public Property | DataSource |
Public Property | ReturnValue | (Inherited from ISNet.WebUI.WebGrid.BaseEventArgs)
Top

See Also

Reference

DataSourceEventArgs Class
ISNet.WebUI.WebGrid Namespace


DataSource Property

[image]
Intersoft WebGrid Documentation
DataSource Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > DataSourceEventArgs Class : DataSource Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property DataSource As System.Object
Visual Basic (Usage) Copy Code
Dim instance As DataSourceEventArgs
Dim value As System.Object

instance.DataSource = value

value = instance.DataSource
C#
public System.object DataSource {get; set;}
Delphi
public read-write property DataSource: System.TObject;
JScript
public function get,set DataSource : System.Object
Managed Extensions for C++
public: __property System.Object* get_DataSource();
public: __property void set_DataSource(
   System.Object* value
);
C++/CLI
public:
property System.Object^ DataSource {
   System.Object^ get();
   void set (    System.Object^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataSourceEventArgs Class
DataSourceEventArgs Members


DynARInfo Class

[image]
Intersoft WebGrid Documentation
DynARInfo Class
Members See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : DynARInfo Class

Glossary Item Box

Object Model

DynARInfo Class

Syntax

Visual Basic (Declaration)
Public Class DynARInfo
Visual Basic (Usage) Copy Code
Dim instance As DynARInfo
C#
public class DynARInfo
Delphi
public class DynARInfo
JScript
public class DynARInfo
Managed Extensions for C++
public __gc class DynARInfo
C++/CLI
public ref class DynARInfo

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebGrid.DynARInfo

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DynARInfo Members
ISNet.WebUI.WebGrid Namespace


DynARInfo Class Members

[image]
Intersoft WebGrid Documentation
DynARInfo Class Members
See Also Fields Properties Send Feedback
ISNet.WebUI.WebGrid Namespace : DynARInfo Class

Glossary Item Box

The following tables list the members exposed by DynARInfo.

Public Constructors

 | Name | Description
Public Constructor | DynARInfo Constructor | Overloaded.
Top

Public Fields

 | Name | Description
Public Field | ApplicationPath |
Public Field | DeleteOutputFileTime |
Public Field | DynMargins |
Public Field | DynPageOrientation |
Public Field | DynPaperKind |
Public Field | DynReportCaptions |
Public Field | EnableValueList |
Public Field | HtmlTitle |
Public Field | IISReportPath |
Public Field | IsAlwaysShowTime |
Public Field | IsAlwaysShowTotalPage |
Public Field | IsEnableDataFormatString |
Public Field | IsShowParent |
Public Field | OutputFileFormat |
Public Field | ReportPath |
Public Field | UseCellMergingForExcelReport |
Top

Public Properties

 | Name | Description
Public Property | CacheToDisk |
Public Property | CacheToDiskLocation |
Public Property | DisablePaging |
Public Property | DynFonts |
Public Property | ExportAllSelfReferencingRows |
Public Property | ReportName |
Public Property | ReportType |
Public Property | ReportTypeExtension |
Top

See Also

Reference

DynARInfo Class
ISNet.WebUI.WebGrid Namespace


DynARInfo Constructor

[image]
Intersoft WebGrid Documentation
DynARInfo Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > DynARInfo Class : DynARInfo Constructor

Glossary Item Box

Overload List

Overload | Description
DynARInfo Constructor(PaperKind,PageOrientation,Margins,DynARFonts,String,String,String,Boolean,Boolean,Boolean) |
DynARInfo Constructor(String,String,String) |
DynARInfo Constructor(String,String) |
DynARInfo Constructor(String) |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DynARInfo Class
DynARInfo Members


DynARInfo Constructor(PaperKind,PageOrientation,Margins,DynARFonts,String,String,String,Boolean,Boolean,Boolean)

[image]
Intersoft WebGrid Documentation
DynARInfo Constructor(PaperKind,PageOrientation,Margins,DynARFonts,String,String,String,Boolean,Boolean,Boolean)
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > DynARInfo Class > DynARInfo Constructor : DynARInfo Constructor(PaperKind,PageOrientation,Margins,DynARFonts,String,String,String,Boolean,Boolean,Boolean)

paperKind
pageOrientation
margins
dynARFonts
reportType
reportPath
reportName
isShowParent
isAlwaysShowTime
isAlwaysShowTotalPage

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal paperKind As System.Drawing.Printing.PaperKind, _
   ByVal pageOrientation As PageOrientation, _
   ByVal margins As Margins, _
   ByVal dynARFonts As DynARFonts, _
   ByVal reportType As System.String, _
   ByVal reportPath As System.String, _
   ByVal reportName As System.String, _
   ByVal isShowParent As System.Boolean, _
   ByVal isAlwaysShowTime As System.Boolean, _
   ByVal isAlwaysShowTotalPage As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim paperKind As System.Drawing.Printing.PaperKind
Dim pageOrientation As PageOrientation
Dim margins As Margins
Dim dynARFonts As DynARFonts
Dim reportType As System.String
Dim reportPath As System.String
Dim reportName As System.String
Dim isShowParent As System.Boolean
Dim isAlwaysShowTime As System.Boolean
Dim isAlwaysShowTotalPage As System.Boolean

Dim instance As New DynARInfo(paperKind, pageOrientation, margins, dynARFonts, reportType, reportPath, reportName, isShowParent, isAlwaysShowTime, isAlwaysShowTotalPage)
C#
public DynARInfo(
   System.Drawing.Printing.PaperKind paperKind,
   PageOrientation pageOrientation,
   Margins margins,
   DynARFonts dynARFonts,
   System.string reportType,
   System.string reportPath,
   System.string reportName,
   System.bool isShowParent,
   System.bool isAlwaysShowTime,
   System.bool isAlwaysShowTotalPage
)
Delphi
public DynARInfo(
    paperKind: System.Drawing.Printing.PaperKind;
    pageOrientation: PageOrientation;
    margins: Margins;
    dynARFonts: DynARFonts;
    reportType: System.String;
    reportPath: System.String;
    reportName: System.String;
    isShowParent: System.Boolean;
    isAlwaysShowTime: System.Boolean;
    isAlwaysShowTotalPage: System.Boolean
);
JScript
public function DynARInfo(
   paperKind : System.Drawing.Printing.PaperKind,
   pageOrientation : PageOrientation,
   margins : Margins,
   dynARFonts : DynARFonts,
   reportType : System.String,
   reportPath : System.String,
   reportName : System.String,
   isShowParent : System.boolean,
   isAlwaysShowTime : System.boolean,
   isAlwaysShowTotalPage : System.boolean
);
Managed Extensions for C++
public: DynARInfo(
   System.Drawing.Printing.PaperKind paperKind,
   PageOrientation pageOrientation,
   Margins* margins,
   DynARFonts dynARFonts,
   System.string* reportType,
   System.string* reportPath,
   System.string* reportName,
   System.bool isShowParent,
   System.bool isAlwaysShowTime,
   System.bool isAlwaysShowTotalPage
)
C++/CLI
public:
DynARInfo(
   System.Drawing.Printing.PaperKind paperKind,
   PageOrientation pageOrientation,
   Margins^ margins,
   DynARFonts dynARFonts,
   System.String^ reportType,
   System.String^ reportPath,
   System.String^ reportName,
   System.bool isShowParent,
   System.bool isAlwaysShowTime,
   System.bool isAlwaysShowTotalPage
)

Parameters

paperKind
pageOrientation
margins
dynARFonts
reportType
reportPath
reportName
isShowParent
isAlwaysShowTime
isAlwaysShowTotalPage

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DynARInfo Class
DynARInfo Members
Overload List


DynARInfo Constructor(String,String,String)

[image]
Intersoft WebGrid Documentation
DynARInfo Constructor(String,String,String)
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > DynARInfo Class > DynARInfo Constructor : DynARInfo Constructor(String,String,String)

reportType
reportPath
reportName

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal reportType As System.String, _
   ByVal reportPath As System.String, _
   ByVal reportName As System.String _
)
Visual Basic (Usage) Copy Code
Dim reportType As System.String
Dim reportPath As System.String
Dim reportName As System.String

Dim instance As New DynARInfo(reportType, reportPath, reportName)
C#
public DynARInfo(
   System.string reportType,
   System.string reportPath,
   System.string reportName
)
Delphi
public DynARInfo(
    reportType: System.String;
    reportPath: System.String;
    reportName: System.String
);
JScript
public function DynARInfo(
   reportType : System.String,
   reportPath : System.String,
   reportName : System.String
);
Managed Extensions for C++
public: DynARInfo(
   System.string* reportType,
   System.string* reportPath,
   System.string* reportName
)
C++/CLI
public:
DynARInfo(
   System.String^ reportType,
   System.String^ reportPath,
   System.String^ reportName
)

Parameters

reportType
reportPath
reportName

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DynARInfo Class
DynARInfo Members
Overload List


DynARInfo Constructor(String,String)

[image]
Intersoft WebGrid Documentation
DynARInfo Constructor(String,String)
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > DynARInfo Class > DynARInfo Constructor : DynARInfo Constructor(String,String)

reportType
reportPath

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal reportType As System.String, _
   ByVal reportPath As System.String _
)
Visual Basic (Usage) Copy Code
Dim reportType As System.String
Dim reportPath As System.String

Dim instance As New DynARInfo(reportType, reportPath)
C#
public DynARInfo(
   System.string reportType,
   System.string reportPath
)
Delphi
public DynARInfo(
    reportType: System.String;
    reportPath: System.String
);
JScript
public function DynARInfo(
   reportType : System.String,
   reportPath : System.String
);
Managed Extensions for C++
public: DynARInfo(
   System.string* reportType,
   System.string* reportPath
)
C++/CLI
public:
DynARInfo(
   System.String^ reportType,
   System.String^ reportPath
)

Parameters

reportType
reportPath

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DynARInfo Class
DynARInfo Members
Overload List


DynARInfo Constructor(String)

[image]
Intersoft WebGrid Documentation
DynARInfo Constructor(String)
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > DynARInfo Class > DynARInfo Constructor : DynARInfo Constructor(String)

reportPath

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal reportPath As System.String _
)
Visual Basic (Usage) Copy Code
Dim reportPath As System.String

Dim instance As New DynARInfo(reportPath)
C#
public DynARInfo(
   System.string reportPath
)
Delphi
public DynARInfo(
    reportPath: System.String
);
JScript
public function DynARInfo(
   reportPath : System.String
);
Managed Extensions for C++
public: DynARInfo(
   System.string* reportPath
)
C++/CLI
public:
DynARInfo(
   System.String^ reportPath
)

Parameters

reportPath

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DynARInfo Class
DynARInfo Members
Overload List


DynARInfo Class Properties

[image]
Intersoft WebGrid Documentation
DynARInfo Class Properties
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : DynARInfo Class

Glossary Item Box

For a list of all members of this type, see DynARInfo members.

Public Properties

 | Name | Description
Public Property | CacheToDisk |
Public Property | CacheToDiskLocation |
Public Property | DisablePaging |
Public Property | DynFonts |
Public Property | ExportAllSelfReferencingRows |
Public Property | ReportName |
Public Property | ReportType |
Public Property | ReportTypeExtension |
Top

See Also

Reference

DynARInfo Class
ISNet.WebUI.WebGrid Namespace


CacheToDisk Property

[image]
Intersoft WebGrid Documentation
CacheToDisk Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > DynARInfo Class : CacheToDisk Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property CacheToDisk As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As DynARInfo
Dim value As System.Boolean

instance.CacheToDisk = value

value = instance.CacheToDisk
C#
public System.bool CacheToDisk {get; set;}
Delphi
public read-write property CacheToDisk: System.Boolean;
JScript
public function get,set CacheToDisk : System.boolean
Managed Extensions for C++
public: __property System.bool get_CacheToDisk();
public: __property void set_CacheToDisk(
   System.bool value
);
C++/CLI
public:
property System.bool CacheToDisk {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DynARInfo Class
DynARInfo Members


CacheToDiskLocation Property

[image]
Intersoft WebGrid Documentation
CacheToDiskLocation Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > DynARInfo Class : CacheToDiskLocation Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property CacheToDiskLocation As System.String
Visual Basic (Usage) Copy Code
Dim instance As DynARInfo
Dim value As System.String

instance.CacheToDiskLocation = value

value = instance.CacheToDiskLocation
C#
public System.string CacheToDiskLocation {get; set;}
Delphi
public read-write property CacheToDiskLocation: System.String;
JScript
public function get,set CacheToDiskLocation : System.String
Managed Extensions for C++
public: __property System.string* get_CacheToDiskLocation();
public: __property void set_CacheToDiskLocation(
   System.string* value
);
C++/CLI
public:
property System.String^ CacheToDiskLocation {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DynARInfo Class
DynARInfo Members


DisablePaging Property

[image]
Intersoft WebGrid Documentation
DisablePaging Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > DynARInfo Class : DisablePaging Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property DisablePaging As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As DynARInfo
Dim value As System.Boolean

instance.DisablePaging = value

value = instance.DisablePaging
C#
public System.bool DisablePaging {get; set;}
Delphi
public read-write property DisablePaging: System.Boolean;
JScript
public function get,set DisablePaging : System.boolean
Managed Extensions for C++
public: __property System.bool get_DisablePaging();
public: __property void set_DisablePaging(
   System.bool value
);
C++/CLI
public:
property System.bool DisablePaging {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DynARInfo Class
DynARInfo Members


DynFonts Property

[image]
Intersoft WebGrid Documentation
DynFonts Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > DynARInfo Class : DynFonts Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property DynFonts As DynARFonts
Visual Basic (Usage) Copy Code
Dim instance As DynARInfo
Dim value As DynARFonts

instance.DynFonts = value

value = instance.DynFonts
C#
public DynARFonts DynFonts {get; set;}
Delphi
public read-write property DynFonts: DynARFonts;
JScript
public function get,set DynFonts : DynARFonts
Managed Extensions for C++
public: __property DynARFonts get_DynFonts();
public: __property void set_DynFonts(
   DynARFonts value
);
C++/CLI
public:
property DynARFonts DynFonts {
   DynARFonts get();
   void set (    DynARFonts value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DynARInfo Class
DynARInfo Members


ExportAllSelfReferencingRows Property

[image]
Intersoft WebGrid Documentation
ExportAllSelfReferencingRows Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > DynARInfo Class : ExportAllSelfReferencingRows Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property ExportAllSelfReferencingRows As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As DynARInfo
Dim value As System.Boolean

instance.ExportAllSelfReferencingRows = value

value = instance.ExportAllSelfReferencingRows
C#
public System.bool ExportAllSelfReferencingRows {get; set;}
Delphi
public read-write property ExportAllSelfReferencingRows: System.Boolean;
JScript
public function get,set ExportAllSelfReferencingRows : System.boolean
Managed Extensions for C++
public: __property System.bool get_ExportAllSelfReferencingRows();
public: __property void set_ExportAllSelfReferencingRows(
   System.bool value
);
C++/CLI
public:
property System.bool ExportAllSelfReferencingRows {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DynARInfo Class
DynARInfo Members


ReportName Property

[image]
Intersoft WebGrid Documentation
ReportName Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > DynARInfo Class : ReportName Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property ReportName As System.String
Visual Basic (Usage) Copy Code
Dim instance As DynARInfo
Dim value As System.String

instance.ReportName = value

value = instance.ReportName
C#
public System.string ReportName {get; set;}
Delphi
public read-write property ReportName: System.String;
JScript
public function get,set ReportName : System.String
Managed Extensions for C++
public: __property System.string* get_ReportName();
public: __property void set_ReportName(
   System.string* value
);
C++/CLI
public:
property System.String^ ReportName {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DynARInfo Class
DynARInfo Members


ReportType Property

[image]
Intersoft WebGrid Documentation
ReportType Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > DynARInfo Class : ReportType Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property ReportType As System.String
Visual Basic (Usage) Copy Code
Dim instance As DynARInfo
Dim value As System.String

instance.ReportType = value

value = instance.ReportType
C#
public System.string ReportType {get; set;}
Delphi
public read-write property ReportType: System.String;
JScript
public function get,set ReportType : System.String
Managed Extensions for C++
public: __property System.string* get_ReportType();
public: __property void set_ReportType(
   System.string* value
);
C++/CLI
public:
property System.String^ ReportType {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DynARInfo Class
DynARInfo Members


ReportTypeExtension Property

[image]
Intersoft WebGrid Documentation
ReportTypeExtension Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > DynARInfo Class : ReportTypeExtension Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property ReportTypeExtension As System.String
Visual Basic (Usage) Copy Code
Dim instance As DynARInfo
Dim value As System.String

instance.ReportTypeExtension = value

value = instance.ReportTypeExtension
C#
public System.string ReportTypeExtension {get; set;}
Delphi
public read-write property ReportTypeExtension: System.String;
JScript
public function get,set ReportTypeExtension : System.String
Managed Extensions for C++
public: __property System.string* get_ReportTypeExtension();
public: __property void set_ReportTypeExtension(
   System.string* value
);
C++/CLI
public:
property System.String^ ReportTypeExtension {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DynARInfo Class
DynARInfo Members


DynARInfo Class Fields

[image]
Intersoft WebGrid Documentation
DynARInfo Class Fields
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : DynARInfo Class

Glossary Item Box

For a list of all members of this type, see DynARInfo members.

Public Fields

 | Name | Description
Public Field | ApplicationPath |
Public Field | DeleteOutputFileTime |
Public Field | DynMargins |
Public Field | DynPageOrientation |
Public Field | DynPaperKind |
Public Field | DynReportCaptions |
Public Field | EnableValueList |
Public Field | HtmlTitle |
Public Field | IISReportPath |
Public Field | IsAlwaysShowTime |
Public Field | IsAlwaysShowTotalPage |
Public Field | IsEnableDataFormatString |
Public Field | IsShowParent |
Public Field | OutputFileFormat |
Public Field | ReportPath |
Public Field | UseCellMergingForExcelReport |
Top

See Also

Reference

DynARInfo Class
ISNet.WebUI.WebGrid Namespace


ApplicationPath Field

[image]
Intersoft WebGrid Documentation
ApplicationPath Field
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > DynARInfo Class : ApplicationPath Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ApplicationPath As System.String
Visual Basic (Usage) Copy Code
Dim instance As DynARInfo
Dim value As System.String

value = instance.ApplicationPath

instance.ApplicationPath = value
C#
public System.string ApplicationPath
Delphi
public field ApplicationPath: System.String;
JScript
public var ApplicationPath : System.String;
Managed Extensions for C++
public: System.string* ApplicationPath
C++/CLI
public:
System.String^ ApplicationPath

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DynARInfo Class
DynARInfo Members


DeleteOutputFileTime Field

[image]
Intersoft WebGrid Documentation
DeleteOutputFileTime Field
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > DynARInfo Class : DeleteOutputFileTime Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public DeleteOutputFileTime As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As DynARInfo
Dim value As System.Integer

value = instance.DeleteOutputFileTime

instance.DeleteOutputFileTime = value
C#
public System.int DeleteOutputFileTime
Delphi
public field DeleteOutputFileTime: System.Integer;
JScript
public var DeleteOutputFileTime : System.int;
Managed Extensions for C++
public: System.int DeleteOutputFileTime
C++/CLI
public:
System.int DeleteOutputFileTime

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DynARInfo Class
DynARInfo Members


DynMargins Field

[image]
Intersoft WebGrid Documentation
DynMargins Field
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > DynARInfo Class : DynMargins Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public DynMargins As Margins
Visual Basic (Usage) Copy Code
Dim instance As DynARInfo
Dim value As Margins

value = instance.DynMargins

instance.DynMargins = value
C#
public Margins DynMargins
Delphi
public field DynMargins: Margins;
JScript
public var DynMargins : Margins;
Managed Extensions for C++
public: Margins* DynMargins
C++/CLI
public:
Margins^ DynMargins

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DynARInfo Class
DynARInfo Members


DynPageOrientation Field

[image]
Intersoft WebGrid Documentation
DynPageOrientation Field
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > DynARInfo Class : DynPageOrientation Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public DynPageOrientation As PageOrientation
Visual Basic (Usage) Copy Code
Dim instance As DynARInfo
Dim value As PageOrientation

value = instance.DynPageOrientation

instance.DynPageOrientation = value
C#
public PageOrientation DynPageOrientation
Delphi
public field DynPageOrientation: PageOrientation;
JScript
public var DynPageOrientation : PageOrientation;
Managed Extensions for C++
public: PageOrientation DynPageOrientation
C++/CLI
public:
PageOrientation DynPageOrientation

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DynARInfo Class
DynARInfo Members


DynPaperKind Field

[image]
Intersoft WebGrid Documentation
DynPaperKind Field
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > DynARInfo Class : DynPaperKind Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public DynPaperKind As System.Drawing.Printing.PaperKind
Visual Basic (Usage) Copy Code
Dim instance As DynARInfo
Dim value As System.Drawing.Printing.PaperKind

value = instance.DynPaperKind

instance.DynPaperKind = value
C#
public System.Drawing.Printing.PaperKind DynPaperKind
Delphi
public field DynPaperKind: System.Drawing.Printing.PaperKind;
JScript
public var DynPaperKind : System.Drawing.Printing.PaperKind;
Managed Extensions for C++
public: System.Drawing.Printing.PaperKind DynPaperKind
C++/CLI
public:
System.Drawing.Printing.PaperKind DynPaperKind

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DynARInfo Class
DynARInfo Members


DynReportCaptions Field

[image]
Intersoft WebGrid Documentation
DynReportCaptions Field
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > DynARInfo Class : DynReportCaptions Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public DynReportCaptions As DynRptCaptions
Visual Basic (Usage) Copy Code
Dim instance As DynARInfo
Dim value As DynRptCaptions

value = instance.DynReportCaptions

instance.DynReportCaptions = value
C#
public DynRptCaptions DynReportCaptions
Delphi
public field DynReportCaptions: DynRptCaptions;
JScript
public var DynReportCaptions : DynRptCaptions;
Managed Extensions for C++
public: DynRptCaptions DynReportCaptions
C++/CLI
public:
DynRptCaptions DynReportCaptions

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DynARInfo Class
DynARInfo Members


EnableValueList Field

[image]
Intersoft WebGrid Documentation
EnableValueList Field
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > DynARInfo Class : EnableValueList Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public EnableValueList As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As DynARInfo
Dim value As System.Boolean

value = instance.EnableValueList

instance.EnableValueList = value
C#
public System.bool EnableValueList
Delphi
public field EnableValueList: System.Boolean;
JScript
public var EnableValueList : System.boolean;
Managed Extensions for C++
public: System.bool EnableValueList
C++/CLI
public:
System.bool EnableValueList

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DynARInfo Class
DynARInfo Members


HtmlTitle Field

[image]
Intersoft WebGrid Documentation
HtmlTitle Field
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > DynARInfo Class : HtmlTitle Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public HtmlTitle As System.String
Visual Basic (Usage) Copy Code
Dim instance As DynARInfo
Dim value As System.String

value = instance.HtmlTitle

instance.HtmlTitle = value
C#
public System.string HtmlTitle
Delphi
public field HtmlTitle: System.String;
JScript
public var HtmlTitle : System.String;
Managed Extensions for C++
public: System.string* HtmlTitle
C++/CLI
public:
System.String^ HtmlTitle

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DynARInfo Class
DynARInfo Members


IISReportPath Field

[image]
Intersoft WebGrid Documentation
IISReportPath Field
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > DynARInfo Class : IISReportPath Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public IISReportPath As System.String
Visual Basic (Usage) Copy Code
Dim instance As DynARInfo
Dim value As System.String

value = instance.IISReportPath

instance.IISReportPath = value
C#
public System.string IISReportPath
Delphi
public field IISReportPath: System.String;
JScript
public var IISReportPath : System.String;
Managed Extensions for C++
public: System.string* IISReportPath
C++/CLI
public:
System.String^ IISReportPath

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DynARInfo Class
DynARInfo Members


IsAlwaysShowTime Field

[image]
Intersoft WebGrid Documentation
IsAlwaysShowTime Field
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > DynARInfo Class : IsAlwaysShowTime Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public IsAlwaysShowTime As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As DynARInfo
Dim value As System.Boolean

value = instance.IsAlwaysShowTime

instance.IsAlwaysShowTime = value
C#
public System.bool IsAlwaysShowTime
Delphi
public field IsAlwaysShowTime: System.Boolean;
JScript
public var IsAlwaysShowTime : System.boolean;
Managed Extensions for C++
public: System.bool IsAlwaysShowTime
C++/CLI
public:
System.bool IsAlwaysShowTime

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DynARInfo Class
DynARInfo Members


IsAlwaysShowTotalPage Field

[image]
Intersoft WebGrid Documentation
IsAlwaysShowTotalPage Field
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > DynARInfo Class : IsAlwaysShowTotalPage Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public IsAlwaysShowTotalPage As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As DynARInfo
Dim value As System.Boolean

value = instance.IsAlwaysShowTotalPage

instance.IsAlwaysShowTotalPage = value
C#
public System.bool IsAlwaysShowTotalPage
Delphi
public field IsAlwaysShowTotalPage: System.Boolean;
JScript
public var IsAlwaysShowTotalPage : System.boolean;
Managed Extensions for C++
public: System.bool IsAlwaysShowTotalPage
C++/CLI
public:
System.bool IsAlwaysShowTotalPage

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DynARInfo Class
DynARInfo Members


IsEnableDataFormatString Field

[image]
Intersoft WebGrid Documentation
IsEnableDataFormatString Field
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > DynARInfo Class : IsEnableDataFormatString Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public IsEnableDataFormatString As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As DynARInfo
Dim value As System.Boolean

value = instance.IsEnableDataFormatString

instance.IsEnableDataFormatString = value
C#
public System.bool IsEnableDataFormatString
Delphi
public field IsEnableDataFormatString: System.Boolean;
JScript
public var IsEnableDataFormatString : System.boolean;
Managed Extensions for C++
public: System.bool IsEnableDataFormatString
C++/CLI
public:
System.bool IsEnableDataFormatString

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DynARInfo Class
DynARInfo Members


IsShowParent Field

[image]
Intersoft WebGrid Documentation
IsShowParent Field
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > DynARInfo Class : IsShowParent Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public IsShowParent As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As DynARInfo
Dim value As System.Boolean

value = instance.IsShowParent

instance.IsShowParent = value
C#
public System.bool IsShowParent
Delphi
public field IsShowParent: System.Boolean;
JScript
public var IsShowParent : System.boolean;
Managed Extensions for C++
public: System.bool IsShowParent
C++/CLI
public:
System.bool IsShowParent

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DynARInfo Class
DynARInfo Members


OutputFileFormat Field

[image]
Intersoft WebGrid Documentation
OutputFileFormat Field
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > DynARInfo Class : OutputFileFormat Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public OutputFileFormat As ReportFileFormat
Visual Basic (Usage) Copy Code
Dim instance As DynARInfo
Dim value As ReportFileFormat

value = instance.OutputFileFormat

instance.OutputFileFormat = value
C#
public ReportFileFormat OutputFileFormat
Delphi
public field OutputFileFormat: ReportFileFormat;
JScript
public var OutputFileFormat : ReportFileFormat;
Managed Extensions for C++
public: ReportFileFormat OutputFileFormat
C++/CLI
public:
ReportFileFormat OutputFileFormat

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DynARInfo Class
DynARInfo Members


ReportPath Field

[image]
Intersoft WebGrid Documentation
ReportPath Field
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > DynARInfo Class : ReportPath Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReportPath As System.String
Visual Basic (Usage) Copy Code
Dim instance As DynARInfo
Dim value As System.String

value = instance.ReportPath

instance.ReportPath = value
C#
public System.string ReportPath
Delphi
public field ReportPath: System.String;
JScript
public var ReportPath : System.String;
Managed Extensions for C++
public: System.string* ReportPath
C++/CLI
public:
System.String^ ReportPath

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DynARInfo Class
DynARInfo Members


UseCellMergingForExcelReport Field

[image]
Intersoft WebGrid Documentation
UseCellMergingForExcelReport Field
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > DynARInfo Class : UseCellMergingForExcelReport Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public UseCellMergingForExcelReport As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As DynARInfo
Dim value As System.Boolean

value = instance.UseCellMergingForExcelReport

instance.UseCellMergingForExcelReport = value
C#
public System.bool UseCellMergingForExcelReport
Delphi
public field UseCellMergingForExcelReport: System.Boolean;
JScript
public var UseCellMergingForExcelReport : System.boolean;
Managed Extensions for C++
public: System.bool UseCellMergingForExcelReport
C++/CLI
public:
System.bool UseCellMergingForExcelReport

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DynARInfo Class
DynARInfo Members


ExportCompletedEventArgs Class

[image]
Intersoft WebGrid Documentation
ExportCompletedEventArgs Class
Members See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : ExportCompletedEventArgs Class

Glossary Item Box

Object Model

ExportCompletedEventArgs Class

Syntax

Visual Basic (Declaration)
Public Class ExportCompletedEventArgs
   Inherits BaseEventArgs
Visual Basic (Usage) Copy Code
Dim instance As ExportCompletedEventArgs
C#
public class ExportCompletedEventArgs : BaseEventArgs
Delphi
public class ExportCompletedEventArgs = class(BaseEventArgs)
JScript
public class ExportCompletedEventArgs extends BaseEventArgs
Managed Extensions for C++
public __gc class ExportCompletedEventArgs : public BaseEventArgs
C++/CLI
public ref class ExportCompletedEventArgs : public BaseEventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
ISNet.WebUI.WebGrid.BaseEventArgs
ISNet.WebUI.WebGrid.ExportCompletedEventArgs

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ExportCompletedEventArgs Members
ISNet.WebUI.WebGrid Namespace


ExportCompletedEventArgs Class Members

[image]
Intersoft WebGrid Documentation
ExportCompletedEventArgs Class Members
See Also Properties Send Feedback
ISNet.WebUI.WebGrid Namespace : ExportCompletedEventArgs Class

Glossary Item Box

The following tables list the members exposed by ExportCompletedEventArgs.

Public Constructors

 | Name | Description
Public Constructor | ExportCompletedEventArgs Constructor |
Top

Public Properties

 | Name | Description
Public Property | OutputException |
Public Property | OutputFile |
Public Property | OutputStream |
Public Property | ReturnValue | (Inherited from ISNet.WebUI.WebGrid.BaseEventArgs)
Top

See Also

Reference

ExportCompletedEventArgs Class
ISNet.WebUI.WebGrid Namespace


ExportCompletedEventArgs Constructor

[image]
Intersoft WebGrid Documentation
ExportCompletedEventArgs Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ExportCompletedEventArgs Class : ExportCompletedEventArgs Constructor

outputFile
outputStream
exp

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal outputFile As System.String, _
   ByVal outputStream As System.IO.Stream, _
   ByVal exp As System.Exception _
)
Visual Basic (Usage) Copy Code
Dim outputFile As System.String
Dim outputStream As System.IO.Stream
Dim exp As System.Exception

Dim instance As New ExportCompletedEventArgs(outputFile, outputStream, exp)
C#
public ExportCompletedEventArgs(
   System.string outputFile,
   System.IO.Stream outputStream,
   System.Exception exp
)
Delphi
public ExportCompletedEventArgs(
    outputFile: System.String;
    outputStream: System.IO.Stream;
    exp: System.Exception
);
JScript
public function ExportCompletedEventArgs(
   outputFile : System.String,
   outputStream : System.IO.Stream,
   exp : System.Exception
);
Managed Extensions for C++
public: ExportCompletedEventArgs(
   System.string* outputFile,
   System.IO.Stream* outputStream,
   System.Exception* exp
)
C++/CLI
public:
ExportCompletedEventArgs(
   System.String^ outputFile,
   System.IO.Stream^ outputStream,
   System.Exception^ exp
)

Parameters

outputFile
outputStream
exp

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ExportCompletedEventArgs Class
ExportCompletedEventArgs Members


ExportCompletedEventArgs Class Properties

[image]
Intersoft WebGrid Documentation
ExportCompletedEventArgs Class Properties
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : ExportCompletedEventArgs Class

Glossary Item Box

For a list of all members of this type, see ExportCompletedEventArgs members.

Public Properties

 | Name | Description
Public Property | OutputException |
Public Property | OutputFile |
Public Property | OutputStream |
Public Property | ReturnValue | (Inherited from ISNet.WebUI.WebGrid.BaseEventArgs)
Top

See Also

Reference

ExportCompletedEventArgs Class
ISNet.WebUI.WebGrid Namespace


OutputException Property

[image]
Intersoft WebGrid Documentation
OutputException Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ExportCompletedEventArgs Class : OutputException Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property OutputException As System.Exception
Visual Basic (Usage) Copy Code
Dim instance As ExportCompletedEventArgs
Dim value As System.Exception

value = instance.OutputException
C#
public System.Exception OutputException {get;}
Delphi
public read-only property OutputException: System.Exception;
JScript
public function get OutputException : System.Exception
Managed Extensions for C++
public: __property System.Exception* get_OutputException();
C++/CLI
public:
property System.Exception^ OutputException {
   System.Exception^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ExportCompletedEventArgs Class
ExportCompletedEventArgs Members


OutputFile Property

[image]
Intersoft WebGrid Documentation
OutputFile Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ExportCompletedEventArgs Class : OutputFile Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property OutputFile As System.String
Visual Basic (Usage) Copy Code
Dim instance As ExportCompletedEventArgs
Dim value As System.String

value = instance.OutputFile
C#
public System.string OutputFile {get;}
Delphi
public read-only property OutputFile: System.String;
JScript
public function get OutputFile : System.String
Managed Extensions for C++
public: __property System.string* get_OutputFile();
C++/CLI
public:
property System.String^ OutputFile {
   System.String^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ExportCompletedEventArgs Class
ExportCompletedEventArgs Members


OutputStream Property

[image]
Intersoft WebGrid Documentation
OutputStream Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ExportCompletedEventArgs Class : OutputStream Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property OutputStream As System.IO.Stream
Visual Basic (Usage) Copy Code
Dim instance As ExportCompletedEventArgs
Dim value As System.IO.Stream

value = instance.OutputStream
C#
public System.IO.Stream OutputStream {get;}
Delphi
public read-only property OutputStream: System.IO.Stream;
JScript
public function get OutputStream : System.IO.Stream
Managed Extensions for C++
public: __property System.IO.Stream* get_OutputStream();
C++/CLI
public:
property System.IO.Stream^ OutputStream {
   System.IO.Stream^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ExportCompletedEventArgs Class
ExportCompletedEventArgs Members


ExportEventArgs Class

[image]
Intersoft WebGrid Documentation
ExportEventArgs Class
Members See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : ExportEventArgs Class

Glossary Item Box

Object Model

ExportEventArgs Class

Syntax

Visual Basic (Declaration)
Public Class ExportEventArgs
   Inherits BaseEventArgs
Visual Basic (Usage) Copy Code
Dim instance As ExportEventArgs
C#
public class ExportEventArgs : BaseEventArgs
Delphi
public class ExportEventArgs = class(BaseEventArgs)
JScript
public class ExportEventArgs extends BaseEventArgs
Managed Extensions for C++
public __gc class ExportEventArgs : public BaseEventArgs
C++/CLI
public ref class ExportEventArgs : public BaseEventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
ISNet.WebUI.WebGrid.BaseEventArgs
ISNet.WebUI.WebGrid.ExportEventArgs

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ExportEventArgs Members
ISNet.WebUI.WebGrid Namespace


ExportEventArgs Class Members

[image]
Intersoft WebGrid Documentation
ExportEventArgs Class Members
See Also Properties Send Feedback
ISNet.WebUI.WebGrid Namespace : ExportEventArgs Class

Glossary Item Box

The following tables list the members exposed by ExportEventArgs.

Public Properties

 | Name | Description
Public Property | DataSource |
Public Property | OutputFileName |
Public Property | ReportInfo |
Public Property | ReturnValue | (Inherited from ISNet.WebUI.WebGrid.BaseEventArgs)
Public Property | Table |
Top

See Also

Reference

ExportEventArgs Class
ISNet.WebUI.WebGrid Namespace


ExportEventArgs Class Properties

[image]
Intersoft WebGrid Documentation
ExportEventArgs Class Properties
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : ExportEventArgs Class

Glossary Item Box

For a list of all members of this type, see ExportEventArgs members.

Public Properties

 | Name | Description
Public Property | DataSource |
Public Property | OutputFileName |
Public Property | ReportInfo |
Public Property | ReturnValue | (Inherited from ISNet.WebUI.WebGrid.BaseEventArgs)
Public Property | Table |
Top

See Also

Reference

ExportEventArgs Class
ISNet.WebUI.WebGrid Namespace


DataSource Property

[image]
Intersoft WebGrid Documentation
DataSource Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ExportEventArgs Class : DataSource Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property DataSource As System.Object
Visual Basic (Usage) Copy Code
Dim instance As ExportEventArgs
Dim value As System.Object

value = instance.DataSource
C#
public System.object DataSource {get;}
Delphi
public read-only property DataSource: System.TObject;
JScript
public function get DataSource : System.Object
Managed Extensions for C++
public: __property System.Object* get_DataSource();
C++/CLI
public:
property System.Object^ DataSource {
   System.Object^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ExportEventArgs Class
ExportEventArgs Members


OutputFileName Property

[image]
Intersoft WebGrid Documentation
OutputFileName Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ExportEventArgs Class : OutputFileName Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property OutputFileName As System.String
Visual Basic (Usage) Copy Code
Dim instance As ExportEventArgs
Dim value As System.String

instance.OutputFileName = value

value = instance.OutputFileName
C#
public System.string OutputFileName {get; set;}
Delphi
public read-write property OutputFileName: System.String;
JScript
public function get,set OutputFileName : System.String
Managed Extensions for C++
public: __property System.string* get_OutputFileName();
public: __property void set_OutputFileName(
   System.string* value
);
C++/CLI
public:
property System.String^ OutputFileName {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ExportEventArgs Class
ExportEventArgs Members


ReportInfo Property

[image]
Intersoft WebGrid Documentation
ReportInfo Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ExportEventArgs Class : ReportInfo Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ReportInfo As DynARInfo
Visual Basic (Usage) Copy Code
Dim instance As ExportEventArgs
Dim value As DynARInfo

value = instance.ReportInfo
C#
public DynARInfo ReportInfo {get;}
Delphi
public read-only property ReportInfo: DynARInfo;
JScript
public function get ReportInfo : DynARInfo
Managed Extensions for C++
public: __property DynARInfo* get_ReportInfo();
C++/CLI
public:
property DynARInfo^ ReportInfo {
   DynARInfo^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ExportEventArgs Class
ExportEventArgs Members


Table Property

[image]
Intersoft WebGrid Documentation
Table Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ExportEventArgs Class : Table Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Table As WebGridTable
Visual Basic (Usage) Copy Code
Dim instance As ExportEventArgs
Dim value As WebGridTable

value = instance.Table
C#
public WebGridTable Table {get;}
Delphi
public read-only property Table: WebGridTable;
JScript
public function get Table : WebGridTable
Managed Extensions for C++
public: __property WebGridTable* get_Table();
C++/CLI
public:
property WebGridTable^ Table {
   WebGridTable^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ExportEventArgs Class
ExportEventArgs Members


FieldTypeEditor Class

[image]
Intersoft WebGrid Documentation
FieldTypeEditor Class
Members See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : FieldTypeEditor Class

Glossary Item Box

Object Model

FieldTypeEditor Class

Syntax

Visual Basic (Declaration)
Public Class FieldTypeEditor
   Inherits System.Drawing.Design.UITypeEditor
Visual Basic (Usage) Copy Code
Dim instance As FieldTypeEditor
C#
public class FieldTypeEditor : System.Drawing.Design.UITypeEditor
Delphi
public class FieldTypeEditor = class(System.Drawing.Design.UITypeEditor)
JScript
public class FieldTypeEditor extends System.Drawing.Design.UITypeEditor
Managed Extensions for C++
public __gc class FieldTypeEditor : public System.Drawing.Design.UITypeEditor
C++/CLI
public ref class FieldTypeEditor : public System.Drawing.Design.UITypeEditor

Inheritance Hierarchy

System.Object
System.Drawing.Design.UITypeEditor
ISNet.WebUI.WebGrid.FieldTypeEditor

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FieldTypeEditor Members
ISNet.WebUI.WebGrid Namespace


FieldTypeEditor Class Members

[image]
Intersoft WebGrid Documentation
FieldTypeEditor Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebGrid Namespace : FieldTypeEditor Class

Glossary Item Box

The following tables list the members exposed by FieldTypeEditor.

Public Constructors

 | Name | Description
Public Constructor | FieldTypeEditor Constructor |
Top

Public Properties

 | Name | Description
Public Property | IsDropDownResizable | (Inherited from System.Drawing.Design.UITypeEditor)
Top

Public Methods

 | Name | Description
Public Method | EditValue | Overloaded. Overridden.
Public Method | GetEditStyle | Overloaded. Overridden.
Public Method | GetPaintValueSupported | Overloaded. Overridden.
Public Method | PaintValue | Overloaded. (Inherited from System.Drawing.Design.UITypeEditor)
Top

See Also

Reference

FieldTypeEditor Class
ISNet.WebUI.WebGrid Namespace


FieldTypeEditor Constructor

[image]
Intersoft WebGrid Documentation
FieldTypeEditor Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > FieldTypeEditor Class : FieldTypeEditor Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New FieldTypeEditor()
C#
public FieldTypeEditor()
Delphi
public FieldTypeEditor();
JScript
public function FieldTypeEditor();
Managed Extensions for C++
public: FieldTypeEditor();
C++/CLI
public:
FieldTypeEditor();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FieldTypeEditor Class
FieldTypeEditor Members


FieldTypeEditor Class Methods

[image]
Intersoft WebGrid Documentation
FieldTypeEditor Class Methods
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : FieldTypeEditor Class

Glossary Item Box

For a list of all members of this type, see FieldTypeEditor members.

Public Methods

 | Name | Description
Public Method | EditValue | Overloaded. Overridden.
Public Method | GetEditStyle | Overloaded. Overridden.
Public Method | GetPaintValueSupported | Overloaded. Overridden.
Public Method | PaintValue | Overloaded. (Inherited from System.Drawing.Design.UITypeEditor)
Top

See Also

Reference

FieldTypeEditor Class
ISNet.WebUI.WebGrid Namespace


FieldTypeEditor Class Properties

[image]
Intersoft WebGrid Documentation
FieldTypeEditor Class Properties
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : FieldTypeEditor Class

Glossary Item Box

For a list of all members of this type, see FieldTypeEditor members.

Public Properties

 | Name | Description
Public Property | IsDropDownResizable | (Inherited from System.Drawing.Design.UITypeEditor)
Top

See Also

Reference

FieldTypeEditor Class
ISNet.WebUI.WebGrid Namespace


EditValue Method

[image]
Intersoft WebGrid Documentation
EditValue Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > FieldTypeEditor Class : EditValue Method

Glossary Item Box

Overload List

Overload | Description
EditValue(ITypeDescriptorContext,IServiceProvider,Object) |
EditValue(IServiceProvider,Object) | (Inherited from System.Drawing.Design.UITypeEditor)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FieldTypeEditor Class
FieldTypeEditor Members


EditValue(ITypeDescriptorContext,IServiceProvider,Object) Method

[image]
Intersoft WebGrid Documentation
EditValue(ITypeDescriptorContext,IServiceProvider,Object) Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > FieldTypeEditor Class > EditValue Method : EditValue(ITypeDescriptorContext,IServiceProvider,Object) Method

context
provider
value

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Function EditValue( _
   ByVal context As System.ComponentModel.ITypeDescriptorContext, _
   ByVal provider As System.IServiceProvider, _
   ByVal value As System.Object _
) As System.Object
Visual Basic (Usage) Copy Code
Dim instance As FieldTypeEditor
Dim context As System.ComponentModel.ITypeDescriptorContext
Dim provider As System.IServiceProvider
Dim value As System.Object
Dim value As System.Object

value = instance.EditValue(context, provider, value)
C#
public override System.object EditValue(
   System.ComponentModel.ITypeDescriptorContext context,
   System.IServiceProvider provider,
   System.object value
)
Delphi
public function EditValue(
    context: System.ComponentModel.ITypeDescriptorContext;
    provider: System.IServiceProvider;
    value: System.TObject
): System.TObject; override;
JScript
public override function EditValue(
   context : System.ComponentModel.ITypeDescriptorContext,
   provider : System.IServiceProvider,
   value : System.Object
) : System.Object;
Managed Extensions for C++
public: System.Object* EditValue(
   System.ComponentModel.ITypeDescriptorContext* context,
   System.IServiceProvider* provider,
   System.Object* value
) override
C++/CLI
public:
System.Object^ EditValue(
   System.ComponentModel.ITypeDescriptorContext^ context,
   System.IServiceProvider^ provider,
   System.Object^ value
) override

Parameters

context
provider
value

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FieldTypeEditor Class
FieldTypeEditor Members
Overload List


EditValue(IServiceProvider,Object) Method

[image]
Intersoft WebGrid Documentation
EditValue(IServiceProvider,Object) Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > FieldTypeEditor Class > EditValue Method : EditValue(IServiceProvider,Object) Method

provider
value

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")>
Public Overloads Function EditValue( _
   ByVal provider As System.IServiceProvider, _
   ByVal value As System.Object _
) As System.Object
Visual Basic (Usage) Copy Code
Dim instance As FieldTypeEditor
Dim provider As System.IServiceProvider
Dim value As System.Object
Dim value As System.Object

value = instance.EditValue(provider, value)
C#
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public System.object EditValue(
   System.IServiceProvider provider,
   System.object value
)
Delphi
public function EditValue(
    provider: System.IServiceProvider;
    value: System.TObject
): System.TObject;
JScript
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")
public function EditValue(
   provider : System.IServiceProvider,
   value : System.Object
) : System.Object;
Managed Extensions for C++
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public: System.Object* EditValue(
   System.IServiceProvider* provider,
   System.Object* value
)
C++/CLI
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public:
System.Object^ EditValue(
   System.IServiceProvider^ provider,
   System.Object^ value
)

Parameters

provider
value

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FieldTypeEditor Class
FieldTypeEditor Members
Overload List


GetEditStyle Method

[image]
Intersoft WebGrid Documentation
GetEditStyle Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > FieldTypeEditor Class : GetEditStyle Method

Glossary Item Box

Overload List

Overload | Description
GetEditStyle(ITypeDescriptorContext) |
GetEditStyle() | (Inherited from System.Drawing.Design.UITypeEditor)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FieldTypeEditor Class
FieldTypeEditor Members


GetEditStyle(ITypeDescriptorContext) Method

[image]
Intersoft WebGrid Documentation
GetEditStyle(ITypeDescriptorContext) Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > FieldTypeEditor Class > GetEditStyle Method : GetEditStyle(ITypeDescriptorContext) Method

context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Function GetEditStyle( _
   ByVal context As System.ComponentModel.ITypeDescriptorContext _
) As System.Drawing.Design.UITypeEditorEditStyle
Visual Basic (Usage) Copy Code
Dim instance As FieldTypeEditor
Dim context As System.ComponentModel.ITypeDescriptorContext
Dim value As System.Drawing.Design.UITypeEditorEditStyle

value = instance.GetEditStyle(context)
C#
public override System.Drawing.Design.UITypeEditorEditStyle GetEditStyle(
   System.ComponentModel.ITypeDescriptorContext context
)
Delphi
public function GetEditStyle(
    context: System.ComponentModel.ITypeDescriptorContext
): System.Drawing.Design.UITypeEditorEditStyle; override;
JScript
public override function GetEditStyle(
   context : System.ComponentModel.ITypeDescriptorContext
) : System.Drawing.Design.UITypeEditorEditStyle;
Managed Extensions for C++
public: System.Drawing.Design.UITypeEditorEditStyle GetEditStyle(
   System.ComponentModel.ITypeDescriptorContext* context
) override
C++/CLI
public:
System.Drawing.Design.UITypeEditorEditStyle GetEditStyle(
   System.ComponentModel.ITypeDescriptorContext^ context
) override

Parameters

context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FieldTypeEditor Class
FieldTypeEditor Members
Overload List


GetEditStyle() Method

[image]
Intersoft WebGrid Documentation
GetEditStyle() Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > FieldTypeEditor Class > GetEditStyle Method : GetEditStyle() Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")>
Public Overloads Function GetEditStyle() As System.Drawing.Design.UITypeEditorEditStyle
Visual Basic (Usage) Copy Code
Dim instance As FieldTypeEditor
Dim value As System.Drawing.Design.UITypeEditorEditStyle

value = instance.GetEditStyle()
C#
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public System.Drawing.Design.UITypeEditorEditStyle GetEditStyle()
Delphi
public function GetEditStyle(): System.Drawing.Design.UITypeEditorEditStyle;
JScript
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")
public function GetEditStyle() : System.Drawing.Design.UITypeEditorEditStyle;
Managed Extensions for C++
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public: System.Drawing.Design.UITypeEditorEditStyle GetEditStyle();
C++/CLI
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public:
System.Drawing.Design.UITypeEditorEditStyle GetEditStyle();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FieldTypeEditor Class
FieldTypeEditor Members
Overload List


GetPaintValueSupported Method

[image]
Intersoft WebGrid Documentation
GetPaintValueSupported Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > FieldTypeEditor Class : GetPaintValueSupported Method

Glossary Item Box

Overload List

Overload | Description
GetPaintValueSupported(ITypeDescriptorContext) |
GetPaintValueSupported() | (Inherited from System.Drawing.Design.UITypeEditor)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FieldTypeEditor Class
FieldTypeEditor Members


GetPaintValueSupported(ITypeDescriptorContext) Method

[image]
Intersoft WebGrid Documentation
GetPaintValueSupported(ITypeDescriptorContext) Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > FieldTypeEditor Class > GetPaintValueSupported Method : GetPaintValueSupported(ITypeDescriptorContext) Method

context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Function GetPaintValueSupported( _
   ByVal context As System.ComponentModel.ITypeDescriptorContext _
) As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As FieldTypeEditor
Dim context As System.ComponentModel.ITypeDescriptorContext
Dim value As System.Boolean

value = instance.GetPaintValueSupported(context)
C#
public override System.bool GetPaintValueSupported(
   System.ComponentModel.ITypeDescriptorContext context
)
Delphi
public function GetPaintValueSupported(
    context: System.ComponentModel.ITypeDescriptorContext
): System.Boolean; override;
JScript
public override function GetPaintValueSupported(
   context : System.ComponentModel.ITypeDescriptorContext
) : System.boolean;
Managed Extensions for C++
public: System.bool GetPaintValueSupported(
   System.ComponentModel.ITypeDescriptorContext* context
) override
C++/CLI
public:
System.bool GetPaintValueSupported(
   System.ComponentModel.ITypeDescriptorContext^ context
) override

Parameters

context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FieldTypeEditor Class
FieldTypeEditor Members
Overload List


GetPaintValueSupported() Method

[image]
Intersoft WebGrid Documentation
GetPaintValueSupported() Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > FieldTypeEditor Class > GetPaintValueSupported Method : GetPaintValueSupported() Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")>
Public Overloads Function GetPaintValueSupported() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As FieldTypeEditor
Dim value As System.Boolean

value = instance.GetPaintValueSupported()
C#
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public System.bool GetPaintValueSupported()
Delphi
public function GetPaintValueSupported(): System.Boolean;
JScript
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")
public function GetPaintValueSupported() : System.boolean;
Managed Extensions for C++
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public: System.bool GetPaintValueSupported();
C++/CLI
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public:
System.bool GetPaintValueSupported();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FieldTypeEditor Class
FieldTypeEditor Members
Overload List


PaintValue Method

[image]
Intersoft WebGrid Documentation
PaintValue Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > FieldTypeEditor Class : PaintValue Method

Glossary Item Box

Overload List

Overload | Description
PaintValue(Object,Graphics,Rectangle) | (Inherited from System.Drawing.Design.UITypeEditor)
PaintValue(PaintValueEventArgs) | (Inherited from System.Drawing.Design.UITypeEditor)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FieldTypeEditor Class
FieldTypeEditor Members


PaintValue(Object,Graphics,Rectangle) Method

[image]
Intersoft WebGrid Documentation
PaintValue(Object,Graphics,Rectangle) Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > FieldTypeEditor Class > PaintValue Method : PaintValue(Object,Graphics,Rectangle) Method

value
canvas
rectangle

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Sub PaintValue( _
   ByVal value As System.Object, _
   ByVal canvas As System.Drawing.Graphics, _
   ByVal rectangle As System.Drawing.Rectangle _
)
Visual Basic (Usage) Copy Code
Dim instance As FieldTypeEditor
Dim value As System.Object
Dim canvas As System.Drawing.Graphics
Dim rectangle As System.Drawing.Rectangle

instance.PaintValue(value, canvas, rectangle)
C#
public void PaintValue(
   System.object value,
   System.Drawing.Graphics canvas,
   System.Drawing.Rectangle rectangle
)
Delphi
public procedure PaintValue(
    value: System.TObject;
    canvas: System.Drawing.Graphics;
    rectangle: System.Drawing.Rectangle
);
JScript
public function PaintValue(
   value : System.Object,
   canvas : System.Drawing.Graphics,
   rectangle : System.Drawing.Rectangle
);
Managed Extensions for C++
public: void PaintValue(
   System.Object* value,
   System.Drawing.Graphics* canvas,
   System.Drawing.Rectangle rectangle
)
C++/CLI
public:
void PaintValue(
   System.Object^ value,
   System.Drawing.Graphics^ canvas,
   System.Drawing.Rectangle rectangle
)

Parameters

value
canvas
rectangle

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FieldTypeEditor Class
FieldTypeEditor Members
Overload List


PaintValue(PaintValueEventArgs) Method

[image]
Intersoft WebGrid Documentation
PaintValue(PaintValueEventArgs) Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > FieldTypeEditor Class > PaintValue Method : PaintValue(PaintValueEventArgs) Method

e

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub PaintValue( _
   ByVal e As System.Drawing.Design.PaintValueEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As FieldTypeEditor
Dim e As System.Drawing.Design.PaintValueEventArgs

instance.PaintValue(e)
C#
public virtual void PaintValue(
   System.Drawing.Design.PaintValueEventArgs e
)
Delphi
public procedure PaintValue(
    e: System.Drawing.Design.PaintValueEventArgs
); virtual;
JScript
public function PaintValue(
   e : System.Drawing.Design.PaintValueEventArgs
);
Managed Extensions for C++
public: virtual void PaintValue(
   System.Drawing.Design.PaintValueEventArgs* e
)
C++/CLI
public:
virtual void PaintValue(
   System.Drawing.Design.PaintValueEventArgs^ e
)

Parameters

e

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FieldTypeEditor Class
FieldTypeEditor Members
Overload List


IsDropDownResizable Property

[image]
Intersoft WebGrid Documentation
IsDropDownResizable Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > FieldTypeEditor Class : IsDropDownResizable Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property IsDropDownResizable As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As FieldTypeEditor
Dim value As System.Boolean

value = instance.IsDropDownResizable
C#
public virtual System.bool IsDropDownResizable {get;}
Delphi
public read-only property IsDropDownResizable: System.Boolean; virtual;
JScript
public function get IsDropDownResizable : System.boolean
Managed Extensions for C++
public: __property virtual System.bool get_IsDropDownResizable();
C++/CLI
public:
virtual property System.bool IsDropDownResizable {
   System.bool get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FieldTypeEditor Class
FieldTypeEditor Members


FilterEventArgs Class

[image]
Intersoft WebGrid Documentation
FilterEventArgs Class
Members See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : FilterEventArgs Class

Glossary Item Box

Object Model

FilterEventArgs Class

Syntax

Visual Basic (Declaration)
Public Class FilterEventArgs
   Inherits BaseEventArgs
Visual Basic (Usage) Copy Code
Dim instance As FilterEventArgs
C#
public class FilterEventArgs : BaseEventArgs
Delphi
public class FilterEventArgs = class(BaseEventArgs)
JScript
public class FilterEventArgs extends BaseEventArgs
Managed Extensions for C++
public __gc class FilterEventArgs : public BaseEventArgs
C++/CLI
public ref class FilterEventArgs : public BaseEventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
ISNet.WebUI.WebGrid.BaseEventArgs
ISNet.WebUI.WebGrid.FilterEventArgs

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FilterEventArgs Members
ISNet.WebUI.WebGrid Namespace


FilterEventArgs Class Members

[image]
Intersoft WebGrid Documentation
FilterEventArgs Class Members
See Also Properties Send Feedback
ISNet.WebUI.WebGrid Namespace : FilterEventArgs Class

Glossary Item Box

The following tables list the members exposed by FilterEventArgs.

Public Properties

 | Name | Description
Public Property | DataSource |
Public Property | FilterColumns |
Public Property | ReturnValue | (Inherited from ISNet.WebUI.WebGrid.BaseEventArgs)
Public Property | Table |
Top

See Also

Reference

FilterEventArgs Class
ISNet.WebUI.WebGrid Namespace


FilterEventArgs Class Properties

[image]
Intersoft WebGrid Documentation
FilterEventArgs Class Properties
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : FilterEventArgs Class

Glossary Item Box

For a list of all members of this type, see FilterEventArgs members.

Public Properties

 | Name | Description
Public Property | DataSource |
Public Property | FilterColumns |
Public Property | ReturnValue | (Inherited from ISNet.WebUI.WebGrid.BaseEventArgs)
Public Property | Table |
Top

See Also

Reference

FilterEventArgs Class
ISNet.WebUI.WebGrid Namespace


DataSource Property

[image]
Intersoft WebGrid Documentation
DataSource Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > FilterEventArgs Class : DataSource Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property DataSource As System.Object
Visual Basic (Usage) Copy Code
Dim instance As FilterEventArgs
Dim value As System.Object

value = instance.DataSource
C#
public System.object DataSource {get;}
Delphi
public read-only property DataSource: System.TObject;
JScript
public function get DataSource : System.Object
Managed Extensions for C++
public: __property System.Object* get_DataSource();
C++/CLI
public:
property System.Object^ DataSource {
   System.Object^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FilterEventArgs Class
FilterEventArgs Members


FilterColumns Property

[image]
Intersoft WebGrid Documentation
FilterColumns Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > FilterEventArgs Class : FilterColumns Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property FilterColumns As WebGridFilterCollection
Visual Basic (Usage) Copy Code
Dim instance As FilterEventArgs
Dim value As WebGridFilterCollection

value = instance.FilterColumns
C#
public WebGridFilterCollection FilterColumns {get;}
Delphi
public read-only property FilterColumns: WebGridFilterCollection;
JScript
public function get FilterColumns : WebGridFilterCollection
Managed Extensions for C++
public: __property WebGridFilterCollection* get_FilterColumns();
C++/CLI
public:
property WebGridFilterCollection^ FilterColumns {
   WebGridFilterCollection^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FilterEventArgs Class
FilterEventArgs Members


Table Property

[image]
Intersoft WebGrid Documentation
Table Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > FilterEventArgs Class : Table Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Table As WebGridTable
Visual Basic (Usage) Copy Code
Dim instance As FilterEventArgs
Dim value As WebGridTable

value = instance.Table
C#
public WebGridTable Table {get;}
Delphi
public read-only property Table: WebGridTable;
JScript
public function get Table : WebGridTable
Managed Extensions for C++
public: __property WebGridTable* get_Table();
C++/CLI
public:
property WebGridTable^ Table {
   WebGridTable^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FilterEventArgs Class
FilterEventArgs Members


FocusStyle Class

[image]
Intersoft WebGrid Documentation
FocusStyle Class
Members See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : FocusStyle Class

Glossary Item Box

Object Model

FocusStyle Class

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute()>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.SerializableAttribute()>
Public Class FocusStyle
   Inherits ISNet.WebUI.WebUIBaseClass
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.Serialization.XmlSerialization.ICustomXmlSerializer
Visual Basic (Usage) Copy Code
Dim instance As FocusStyle
C#
[System.ComponentModel.DescriptionAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public class FocusStyle : ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.Serialization.XmlSerialization.ICustomXmlSerializer
Delphi
public class FocusStyle = class(ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.Serialization.XmlSerialization.ICustomXmlSerializer)
JScript
System.ComponentModel.DescriptionAttribute()
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.SerializableAttribute()
public class FocusStyle extends ISNet.WebUI.WebUIBaseClass implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.Serialization.XmlSerialization.ICustomXmlSerializer
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public __gc class FocusStyle : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.Serialization.XmlSerialization.ICustomXmlSerializer
C++/CLI
[System.ComponentModel.DescriptionAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public ref class FocusStyle : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.Serialization.XmlSerialization.ICustomXmlSerializer

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.WebGrid.FocusStyle

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FocusStyle Members
ISNet.WebUI.WebGrid Namespace


FocusStyle Class Members

[image]
Intersoft WebGrid Documentation
FocusStyle Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebGrid Namespace : FocusStyle Class

Glossary Item Box

The following tables list the members exposed by FocusStyle.

Public Constructors

 | Name | Description
Public Constructor | FocusStyle Constructor |
Top

Public Properties

 | Name | Description
Public Property | BorderColor |
Public Property | BorderStyle |
Public Property | BorderWidth |
Public Property | CssClass |
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CustomDeserialize |
Public Method | CustomSerialize |
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString |
Top

See Also

Reference

FocusStyle Class
ISNet.WebUI.WebGrid Namespace


FocusStyle Constructor

[image]
Intersoft WebGrid Documentation
FocusStyle Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > FocusStyle Class : FocusStyle Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New FocusStyle()
C#
public FocusStyle()
Delphi
public FocusStyle();
JScript
public function FocusStyle();
Managed Extensions for C++
public: FocusStyle();
C++/CLI
public:
FocusStyle();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FocusStyle Class
FocusStyle Members


Clone Method

[image]
Intersoft WebGrid Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > FocusStyle Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As System.Object
Visual Basic (Usage) Copy Code
Dim instance As FocusStyle
Dim value As System.Object

value = instance.Clone()
C#
public virtual System.object Clone()
Delphi
public function Clone(): System.TObject; virtual;
JScript
public function Clone() : System.Object;
Managed Extensions for C++
public: virtual System.Object* Clone();
C++/CLI
public:
virtual System.Object^ Clone();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FocusStyle Class
FocusStyle Members


CopyFrom Method

[image]
Intersoft WebGrid Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > FocusStyle Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FocusStyle Class
FocusStyle Members


CopyFrom(Object) Method

[image]
Intersoft WebGrid Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > FocusStyle Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As FocusStyle
Dim objSource As System.Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   System.object objSource
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FocusStyle Class
FocusStyle Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebGrid Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > FocusStyle Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object, _
   ByVal cloneSourceValue As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As FocusStyle
Dim objSource As System.Object
Dim cloneSourceValue As System.Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   System.object objSource,
   System.bool cloneSourceValue
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject;
    cloneSourceValue: System.Boolean
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object,
   cloneSourceValue : System.boolean
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource,
   System.bool cloneSourceValue
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource,
   System.bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FocusStyle Class
FocusStyle Members
Overload List


FocusStyle Class Methods

[image]
Intersoft WebGrid Documentation
FocusStyle Class Methods
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : FocusStyle Class

Glossary Item Box

For a list of all members of this type, see FocusStyle members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CustomDeserialize |
Public Method | CustomSerialize |
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString |
Top

See Also

Reference

FocusStyle Class
ISNet.WebUI.WebGrid Namespace


CustomDeserialize Method

[image]
Intersoft WebGrid Documentation
CustomDeserialize Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > FocusStyle Class : CustomDeserialize Method

mi
currentObj
parentNode
currentNode

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub CustomDeserialize( _
   ByVal mi As System.Reflection.MemberInfo, _
   ByVal currentObj As System.Object, _
   ByVal parentNode As System.Xml.XmlNode, _
   ByVal currentNode As System.Xml.XmlNode _
)
Visual Basic (Usage) Copy Code
Dim instance As FocusStyle
Dim mi As System.Reflection.MemberInfo
Dim currentObj As System.Object
Dim parentNode As System.Xml.XmlNode
Dim currentNode As System.Xml.XmlNode

instance.CustomDeserialize(mi, currentObj, parentNode, currentNode)
C#
public void CustomDeserialize(
   System.Reflection.MemberInfo mi,
   System.object currentObj,
   System.Xml.XmlNode parentNode,
   System.Xml.XmlNode currentNode
)
Delphi
public procedure CustomDeserialize(
    mi: System.Reflection.MemberInfo;
    currentObj: System.TObject;
    parentNode: System.Xml.XmlNode;
    currentNode: System.Xml.XmlNode
);
JScript
public function CustomDeserialize(
   mi : System.Reflection.MemberInfo,
   currentObj : System.Object,
   parentNode : System.Xml.XmlNode,
   currentNode : System.Xml.XmlNode
);
Managed Extensions for C++
public: void CustomDeserialize(
   System.Reflection.MemberInfo* mi,
   System.Object* currentObj,
   System.Xml.XmlNode* parentNode,
   System.Xml.XmlNode* currentNode
)
C++/CLI
public:
void CustomDeserialize(
   System.Reflection.MemberInfo^ mi,
   System.Object^ currentObj,
   System.Xml.XmlNode^ parentNode,
   System.Xml.XmlNode^ currentNode
)

Parameters

mi
currentObj
parentNode
currentNode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FocusStyle Class
FocusStyle Members


CustomSerialize Method

[image]
Intersoft WebGrid Documentation
CustomSerialize Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > FocusStyle Class : CustomSerialize Method

doc
node

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub CustomSerialize( _
   ByVal doc As System.Xml.XmlDocument, _
   ByVal node As System.Xml.XmlNode _
)
Visual Basic (Usage) Copy Code
Dim instance As FocusStyle
Dim doc As System.Xml.XmlDocument
Dim node As System.Xml.XmlNode

instance.CustomSerialize(doc, node)
C#
public void CustomSerialize(
   System.Xml.XmlDocument doc,
   System.Xml.XmlNode node
)
Delphi
public procedure CustomSerialize(
    doc: System.Xml.XmlDocument;
    node: System.Xml.XmlNode
);
JScript
public function CustomSerialize(
   doc : System.Xml.XmlDocument,
   node : System.Xml.XmlNode
);
Managed Extensions for C++
public: void CustomSerialize(
   System.Xml.XmlDocument* doc,
   System.Xml.XmlNode* node
)
C++/CLI
public:
void CustomSerialize(
   System.Xml.XmlDocument^ doc,
   System.Xml.XmlNode^ node
)

Parameters

doc
node

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FocusStyle Class
FocusStyle Members


DeSerializeObjectData Method

[image]
Intersoft WebGrid Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > FocusStyle Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As FocusStyle
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure DeSerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function DeSerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void DeSerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void DeSerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FocusStyle Class
FocusStyle Members


GetHashCode Method

[image]
Intersoft WebGrid Documentation
GetHashCode Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > FocusStyle Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As FocusStyle
Dim value As System.Integer

value = instance.GetHashCode()
C#
public virtual System.int GetHashCode()
Delphi
public function GetHashCode(): System.Integer; virtual;
JScript
public function GetHashCode() : System.int;
Managed Extensions for C++
public: virtual System.int GetHashCode();
C++/CLI
public:
virtual System.int GetHashCode();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FocusStyle Class
FocusStyle Members


GetObjectData Method

[image]
Intersoft WebGrid Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > FocusStyle Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As FocusStyle
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure GetObjectData(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
); override;
JScript
public override function GetObjectData(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void GetObjectData(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
) override
C++/CLI
public:
void GetObjectData(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
) override

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FocusStyle Class
FocusStyle Members


IsEmpty Method

[image]
Intersoft WebGrid Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > FocusStyle Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As FocusStyle
Dim value As System.Boolean

value = instance.IsEmpty()
C#
public virtual System.bool IsEmpty()
Delphi
public function IsEmpty(): System.Boolean; virtual;
JScript
public function IsEmpty() : System.boolean;
Managed Extensions for C++
public: virtual System.bool IsEmpty();
C++/CLI
public:
virtual System.bool IsEmpty();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FocusStyle Class
FocusStyle Members


Reset Method

[image]
Intersoft WebGrid Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > FocusStyle Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As FocusStyle

instance.Reset()
C#
public virtual void Reset()
Delphi
public procedure Reset(); virtual;
JScript
public function Reset();
Managed Extensions for C++
public: virtual void Reset();
C++/CLI
public:
virtual void Reset();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FocusStyle Class
FocusStyle Members


SerializeObjectData Method

[image]
Intersoft WebGrid Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > FocusStyle Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As FocusStyle
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure SerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function SerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void SerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void SerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FocusStyle Class
FocusStyle Members


ToString Method

[image]
Intersoft WebGrid Documentation
ToString Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > FocusStyle Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString() As System.String
Visual Basic (Usage) Copy Code
Dim instance As FocusStyle
Dim value As System.String

value = instance.ToString()
C#
public override System.string ToString()
Delphi
public function ToString(): System.String; override;
JScript
public override function ToString() : System.String;
Managed Extensions for C++
public: System.string* ToString(); override
C++/CLI
public:
System.String^ ToString(); override

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FocusStyle Class
FocusStyle Members


FocusStyle Class Properties

[image]
Intersoft WebGrid Documentation
FocusStyle Class Properties
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : FocusStyle Class

Glossary Item Box

For a list of all members of this type, see FocusStyle members.

Public Properties

 | Name | Description
Public Property | BorderColor |
Public Property | BorderStyle |
Public Property | BorderWidth |
Public Property | CssClass |
Top

See Also

Reference

FocusStyle Class
ISNet.WebUI.WebGrid Namespace


FocusStyle Constructor

[image]
Intersoft WebGrid Documentation
FocusStyle Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > FocusStyle Class : FocusStyle Constructor

Glossary Item Box

Overload List

Overload | Description
FocusStyle Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FocusStyle Class
FocusStyle Members


BorderColor Property

[image]
Intersoft WebGrid Documentation
BorderColor Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > FocusStyle Class : BorderColor Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Gets or sets the border's color of the focused row.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.MarkAsStyleAttribute(True)>
Public Property BorderColor As System.Drawing.Color
Visual Basic (Usage) Copy Code
Dim instance As FocusStyle
Dim value As System.Drawing.Color

instance.BorderColor = value

value = instance.BorderColor
C#
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the border's color of the focused row.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.MarkAsStyleAttribute(true)]
public System.Drawing.Color BorderColor {get; set;}
Delphi
public read-write property BorderColor: System.Drawing.Color;
JScript
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the border's color of the focused row.")
ISNet.Serialization.BinarySerializableAttribute()
ISNet.MarkAsStyleAttribute()
public function get,set BorderColor : System.Drawing.Color
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the border's color of the focused row.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.MarkAsStyleAttribute(true)]
public: __property System.Drawing.Color get_BorderColor();
public: __property void set_BorderColor(
   System.Drawing.Color value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the border's color of the focused row.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.MarkAsStyleAttribute(true)]
public:
property System.Drawing.Color BorderColor {
   System.Drawing.Color get();
   void set (    System.Drawing.Color value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FocusStyle Class
FocusStyle Members


BorderStyle Property

[image]
Intersoft WebGrid Documentation
BorderStyle Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > FocusStyle Class : BorderStyle Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.MarkAsStyleAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Gets or sets the borderstyle of the focused row.")>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Property BorderStyle As System.Web.UI.WebControls.BorderStyle
Visual Basic (Usage) Copy Code
Dim instance As FocusStyle
Dim value As System.Web.UI.WebControls.BorderStyle

instance.BorderStyle = value

value = instance.BorderStyle
C#
[ISNet.MarkAsStyleAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the borderstyle of the focused row.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public System.Web.UI.WebControls.BorderStyle BorderStyle {get; set;}
Delphi
public read-write property BorderStyle: System.Web.UI.WebControls.BorderStyle;
JScript
ISNet.MarkAsStyleAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the borderstyle of the focused row.")
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute()
public function get,set BorderStyle : System.Web.UI.WebControls.BorderStyle
Managed Extensions for C++
[ISNet.MarkAsStyleAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the borderstyle of the focused row.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property System.Web.UI.WebControls.BorderStyle get_BorderStyle();
public: __property void set_BorderStyle(
   System.Web.UI.WebControls.BorderStyle value
);
C++/CLI
[ISNet.MarkAsStyleAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the borderstyle of the focused row.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property System.Web.UI.WebControls.BorderStyle BorderStyle {
   System.Web.UI.WebControls.BorderStyle get();
   void set (    System.Web.UI.WebControls.BorderStyle value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FocusStyle Class
FocusStyle Members


BorderWidth Property

[image]
Intersoft WebGrid Documentation
BorderWidth Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > FocusStyle Class : BorderWidth Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.MarkAsStyleAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Gets or sets the borderwidth of the focused row.")>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property BorderWidth As System.Web.UI.WebControls.Unit
Visual Basic (Usage) Copy Code
Dim instance As FocusStyle
Dim value As System.Web.UI.WebControls.Unit

instance.BorderWidth = value

value = instance.BorderWidth
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.MarkAsStyleAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the borderwidth of the focused row.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public System.Web.UI.WebControls.Unit BorderWidth {get; set;}
Delphi
public read-write property BorderWidth: System.Web.UI.WebControls.Unit;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.MarkAsStyleAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the borderwidth of the focused row.")
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get,set BorderWidth : System.Web.UI.WebControls.Unit
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.MarkAsStyleAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the borderwidth of the focused row.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.Web.UI.WebControls.Unit get_BorderWidth();
public: __property void set_BorderWidth(
   System.Web.UI.WebControls.Unit value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.MarkAsStyleAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the borderwidth of the focused row.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.Web.UI.WebControls.Unit BorderWidth {
   System.Web.UI.WebControls.Unit get();
   void set (    System.Web.UI.WebControls.Unit value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FocusStyle Class
FocusStyle Members


CssClass Property

[image]
Intersoft WebGrid Documentation
CssClass Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > FocusStyle Class : CssClass Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Gets or sets the Css Class for FocusCellStyle.")>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property CssClass As System.String
Visual Basic (Usage) Copy Code
Dim instance As FocusStyle
Dim value As System.String

instance.CssClass = value

value = instance.CssClass
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the Css Class for FocusCellStyle.")]
[ISNet.Serialization.BinarySerializableAttribute()]
public System.string CssClass {get; set;}
Delphi
public read-write property CssClass: System.String;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the Css Class for FocusCellStyle.")
ISNet.Serialization.BinarySerializableAttribute()
public function get,set CssClass : System.String
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the Css Class for FocusCellStyle.")]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.string* get_CssClass();
public: __property void set_CssClass(
   System.string* value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the Css Class for FocusCellStyle.")]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.String^ CssClass {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FocusStyle Class
FocusStyle Members


GenericContainerTemplate Class

[image]
Intersoft WebGrid Documentation
GenericContainerTemplate Class
Members See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : GenericContainerTemplate Class

Glossary Item Box

Object Model

GenericContainerTemplate Class

Syntax

Visual Basic (Declaration)
Public Class GenericContainerTemplate
Visual Basic (Usage) Copy Code
Dim instance As GenericContainerTemplate
C#
public class GenericContainerTemplate
Delphi
public class GenericContainerTemplate
JScript
public class GenericContainerTemplate
Managed Extensions for C++
public __gc class GenericContainerTemplate
C++/CLI
public ref class GenericContainerTemplate

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebGrid.GenericContainerTemplate

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GenericContainerTemplate Members
ISNet.WebUI.WebGrid Namespace


GenericContainerTemplate Class Members

[image]
Intersoft WebGrid Documentation
GenericContainerTemplate Class Members
See Also Methods Send Feedback
ISNet.WebUI.WebGrid Namespace : GenericContainerTemplate Class

Glossary Item Box

The following tables list the members exposed by GenericContainerTemplate.

Public Constructors

 | Name | Description
Public Constructor | GenericContainerTemplate Constructor |
Top

Public Methods

 | Name | Description
Public Method | InstantiateIn |
Top

See Also

Reference

GenericContainerTemplate Class
ISNet.WebUI.WebGrid Namespace


GenericContainerTemplate Constructor

[image]
Intersoft WebGrid Documentation
GenericContainerTemplate Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > GenericContainerTemplate Class : GenericContainerTemplate Constructor

text

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal text As System.String _
)
Visual Basic (Usage) Copy Code
Dim text As System.String

Dim instance As New GenericContainerTemplate(text)
C#
public GenericContainerTemplate(
   System.string text
)
Delphi
public GenericContainerTemplate(
    text: System.String
);
JScript
public function GenericContainerTemplate(
   text : System.String
);
Managed Extensions for C++
public: GenericContainerTemplate(
   System.string* text
)
C++/CLI
public:
GenericContainerTemplate(
   System.String^ text
)

Parameters

text

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GenericContainerTemplate Class
GenericContainerTemplate Members


GenericContainerTemplate Class Methods

[image]
Intersoft WebGrid Documentation
GenericContainerTemplate Class Methods
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : GenericContainerTemplate Class

Glossary Item Box

For a list of all members of this type, see GenericContainerTemplate members.

Public Methods

 | Name | Description
Public Method | InstantiateIn |
Top

See Also

Reference

GenericContainerTemplate Class
ISNet.WebUI.WebGrid Namespace


InstantiateIn Method

[image]
Intersoft WebGrid Documentation
InstantiateIn Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > GenericContainerTemplate Class : InstantiateIn Method

container

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub InstantiateIn( _
   ByVal container As System.Web.UI.Control _
)
Visual Basic (Usage) Copy Code
Dim instance As GenericContainerTemplate
Dim container As System.Web.UI.Control

instance.InstantiateIn(container)
C#
public void InstantiateIn(
   System.Web.UI.Control container
)
Delphi
public procedure InstantiateIn(
    container: System.Web.UI.Control
);
JScript
public function InstantiateIn(
   container : System.Web.UI.Control
);
Managed Extensions for C++
public: void InstantiateIn(
   System.Web.UI.Control* container
)
C++/CLI
public:
void InstantiateIn(
   System.Web.UI.Control^ container
)

Parameters

container

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GenericContainerTemplate Class
GenericContainerTemplate Members


GenericDataSourceTableSchema Class

[image]
Intersoft WebGrid Documentation
GenericDataSourceTableSchema Class
Members See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : GenericDataSourceTableSchema Class

Glossary Item Box

Object Model

GenericDataSourceTableSchema Class

Syntax

Visual Basic (Declaration)
Public Class GenericDataSourceTableSchema
   Implements ISNet.WebUI.IDataSourceTableSchema
Visual Basic (Usage) Copy Code
Dim instance As GenericDataSourceTableSchema
C#
public class GenericDataSourceTableSchema : ISNet.WebUI.IDataSourceTableSchema
Delphi
public class GenericDataSourceTableSchema = class(ISNet.WebUI.IDataSourceTableSchema)
JScript
public class GenericDataSourceTableSchema implements ISNet.WebUI.IDataSourceTableSchema
Managed Extensions for C++
public __gc class GenericDataSourceTableSchema : public ISNet.WebUI.IDataSourceTableSchema
C++/CLI
public ref class GenericDataSourceTableSchema : public ISNet.WebUI.IDataSourceTableSchema

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebGrid.GenericDataSourceTableSchema

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GenericDataSourceTableSchema Members
ISNet.WebUI.WebGrid Namespace


GenericDataSourceTableSchema Class Members

[image]
Intersoft WebGrid Documentation
GenericDataSourceTableSchema Class Members
See Also Properties Send Feedback
ISNet.WebUI.WebGrid Namespace : GenericDataSourceTableSchema Class

Glossary Item Box

The following tables list the members exposed by GenericDataSourceTableSchema.

Public Constructors

 | Name | Description
Public Constructor | GenericDataSourceTableSchema Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | AutoGeneratedFields |
Public Property | Columns |
Public Property | DataKeyFields |
Public Property | IgnoredFields |
Public Property | TableName |
Top

See Also

Reference

GenericDataSourceTableSchema Class
ISNet.WebUI.WebGrid Namespace


GenericDataSourceTableSchema Constructor

[image]
Intersoft WebGrid Documentation
GenericDataSourceTableSchema Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > GenericDataSourceTableSchema Class : GenericDataSourceTableSchema Constructor

Glossary Item Box

Overload List

Overload | Description
GenericDataSourceTableSchema Constructor(DataTable) |
GenericDataSourceTableSchema Constructor(String,DataSet) |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GenericDataSourceTableSchema Class
GenericDataSourceTableSchema Members


GenericDataSourceTableSchema Constructor(DataTable)

[image]
Intersoft WebGrid Documentation
GenericDataSourceTableSchema Constructor(DataTable)
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > GenericDataSourceTableSchema Class > GenericDataSourceTableSchema Constructor : GenericDataSourceTableSchema Constructor(DataTable)

dataTable

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal dataTable As System.Data.DataTable _
)
Visual Basic (Usage) Copy Code
Dim dataTable As System.Data.DataTable

Dim instance As New GenericDataSourceTableSchema(dataTable)
C#
public GenericDataSourceTableSchema(
   System.Data.DataTable dataTable
)
Delphi
public GenericDataSourceTableSchema(
    dataTable: System.Data.DataTable
);
JScript
public function GenericDataSourceTableSchema(
   dataTable : System.Data.DataTable
);
Managed Extensions for C++
public: GenericDataSourceTableSchema(
   System.Data.DataTable* dataTable
)
C++/CLI
public:
GenericDataSourceTableSchema(
   System.Data.DataTable^ dataTable
)

Parameters

dataTable

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GenericDataSourceTableSchema Class
GenericDataSourceTableSchema Members
Overload List


GenericDataSourceTableSchema Constructor(String,DataSet)

[image]
Intersoft WebGrid Documentation
GenericDataSourceTableSchema Constructor(String,DataSet)
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > GenericDataSourceTableSchema Class > GenericDataSourceTableSchema Constructor : GenericDataSourceTableSchema Constructor(String,DataSet)

tableName
dataSet

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal tableName As System.String, _
   ByVal dataSet As System.Data.DataSet _
)
Visual Basic (Usage) Copy Code
Dim tableName As System.String
Dim dataSet As System.Data.DataSet

Dim instance As New GenericDataSourceTableSchema(tableName, dataSet)
C#
public GenericDataSourceTableSchema(
   System.string tableName,
   System.Data.DataSet dataSet
)
Delphi
public GenericDataSourceTableSchema(
    tableName: System.String;
    dataSet: System.Data.DataSet
);
JScript
public function GenericDataSourceTableSchema(
   tableName : System.String,
   dataSet : System.Data.DataSet
);
Managed Extensions for C++
public: GenericDataSourceTableSchema(
   System.string* tableName,
   System.Data.DataSet* dataSet
)
C++/CLI
public:
GenericDataSourceTableSchema(
   System.String^ tableName,
   System.Data.DataSet^ dataSet
)

Parameters

tableName
dataSet

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GenericDataSourceTableSchema Class
GenericDataSourceTableSchema Members
Overload List


GenericDataSourceTableSchema Class Properties

[image]
Intersoft WebGrid Documentation
GenericDataSourceTableSchema Class Properties
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : GenericDataSourceTableSchema Class

Glossary Item Box

For a list of all members of this type, see GenericDataSourceTableSchema members.

Public Properties

 | Name | Description
Public Property | AutoGeneratedFields |
Public Property | Columns |
Public Property | DataKeyFields |
Public Property | IgnoredFields |
Public Property | TableName |
Top

See Also

Reference

GenericDataSourceTableSchema Class
ISNet.WebUI.WebGrid Namespace


AutoGeneratedFields Property

[image]
Intersoft WebGrid Documentation
AutoGeneratedFields Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > GenericDataSourceTableSchema Class : AutoGeneratedFields Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property AutoGeneratedFields As System.Collections.ObjectModel.Collection(Of String)
Visual Basic (Usage) Copy Code
Dim instance As GenericDataSourceTableSchema
Dim value As System.Collections.ObjectModel.Collection(Of String)

value = instance.AutoGeneratedFields
C#
public System.Collections.ObjectModel.Collection<string> AutoGeneratedFields {get;}
Delphi
public read-only property AutoGeneratedFields: System.Collections.ObjectModel.Collection;
JScript
public function get AutoGeneratedFields : System.Collections.ObjectModel.Collection
Managed Extensions for C++
public: __property System.Collections.ObjectModel.Collection<string*>* get_AutoGeneratedFields();
C++/CLI
public:
property System.Collections.ObjectModel.Collection<String^>^ AutoGeneratedFields {
   System.Collections.ObjectModel.Collection<String^>^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GenericDataSourceTableSchema Class
GenericDataSourceTableSchema Members


Columns Property

[image]
Intersoft WebGrid Documentation
Columns Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > GenericDataSourceTableSchema Class : Columns Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Columns As System.Collections.ObjectModel.Collection(Of DataColumn)
Visual Basic (Usage) Copy Code
Dim instance As GenericDataSourceTableSchema
Dim value As System.Collections.ObjectModel.Collection(Of DataColumn)

value = instance.Columns
C#
public System.Collections.ObjectModel.Collection<DataColumn> Columns {get;}
Delphi
public read-only property Columns: System.Collections.ObjectModel.Collection;
JScript
public function get Columns : System.Collections.ObjectModel.Collection
Managed Extensions for C++
public: __property System.Collections.ObjectModel.Collection<DataColumn*>* get_Columns();
C++/CLI
public:
property System.Collections.ObjectModel.Collection<DataColumn^>^ Columns {
   System.Collections.ObjectModel.Collection<DataColumn^>^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GenericDataSourceTableSchema Class
GenericDataSourceTableSchema Members


DataKeyFields Property

[image]
Intersoft WebGrid Documentation
DataKeyFields Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > GenericDataSourceTableSchema Class : DataKeyFields Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property DataKeyFields As System.Collections.ObjectModel.Collection(Of String)
Visual Basic (Usage) Copy Code
Dim instance As GenericDataSourceTableSchema
Dim value As System.Collections.ObjectModel.Collection(Of String)

value = instance.DataKeyFields
C#
public System.Collections.ObjectModel.Collection<string> DataKeyFields {get;}
Delphi
public read-only property DataKeyFields: System.Collections.ObjectModel.Collection;
JScript
public function get DataKeyFields : System.Collections.ObjectModel.Collection
Managed Extensions for C++
public: __property System.Collections.ObjectModel.Collection<string*>* get_DataKeyFields();
C++/CLI
public:
property System.Collections.ObjectModel.Collection<String^>^ DataKeyFields {
   System.Collections.ObjectModel.Collection<String^>^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GenericDataSourceTableSchema Class
GenericDataSourceTableSchema Members


IgnoredFields Property

[image]
Intersoft WebGrid Documentation
IgnoredFields Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > GenericDataSourceTableSchema Class : IgnoredFields Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IgnoredFields As System.Collections.ObjectModel.Collection(Of String)
Visual Basic (Usage) Copy Code
Dim instance As GenericDataSourceTableSchema
Dim value As System.Collections.ObjectModel.Collection(Of String)

value = instance.IgnoredFields
C#
public System.Collections.ObjectModel.Collection<string> IgnoredFields {get;}
Delphi
public read-only property IgnoredFields: System.Collections.ObjectModel.Collection;
JScript
public function get IgnoredFields : System.Collections.ObjectModel.Collection
Managed Extensions for C++
public: __property System.Collections.ObjectModel.Collection<string*>* get_IgnoredFields();
C++/CLI
public:
property System.Collections.ObjectModel.Collection<String^>^ IgnoredFields {
   System.Collections.ObjectModel.Collection<String^>^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GenericDataSourceTableSchema Class
GenericDataSourceTableSchema Members


TableName Property

[image]
Intersoft WebGrid Documentation
TableName Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > GenericDataSourceTableSchema Class : TableName Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property TableName As System.String
Visual Basic (Usage) Copy Code
Dim instance As GenericDataSourceTableSchema
Dim value As System.String

value = instance.TableName
C#
public System.string TableName {get;}
Delphi
public read-only property TableName: System.String;
JScript
public function get TableName : System.String
Managed Extensions for C++
public: __property System.string* get_TableName();
C++/CLI
public:
property System.String^ TableName {
   System.String^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GenericDataSourceTableSchema Class
GenericDataSourceTableSchema Members


GroupByBoxObject Class

[image]
Intersoft WebGrid Documentation
GroupByBoxObject Class
Members See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : GroupByBoxObject Class

Glossary Item Box

Object Model

GroupByBoxObject Class

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.DescriptionAttribute()>
<System.SerializableAttribute()>
Public Class GroupByBoxObject
   Inherits ISNet.WebUI.WebUIBaseClass
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.Serialization.XmlSerialization.ICustomXmlSerializer
Visual Basic (Usage) Copy Code
Dim instance As GroupByBoxObject
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DescriptionAttribute()]
[System.SerializableAttribute()]
public class GroupByBoxObject : ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.Serialization.XmlSerialization.ICustomXmlSerializer
Delphi
public class GroupByBoxObject = class(ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.Serialization.XmlSerialization.ICustomXmlSerializer)
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.DescriptionAttribute()
System.SerializableAttribute()
public class GroupByBoxObject extends ISNet.WebUI.WebUIBaseClass implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.Serialization.XmlSerialization.ICustomXmlSerializer
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DescriptionAttribute()]
[System.SerializableAttribute()]
public __gc class GroupByBoxObject : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.Serialization.XmlSerialization.ICustomXmlSerializer
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DescriptionAttribute()]
[System.SerializableAttribute()]
public ref class GroupByBoxObject : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.Serialization.XmlSerialization.ICustomXmlSerializer

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.WebGrid.GroupByBoxObject

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GroupByBoxObject Members
ISNet.WebUI.WebGrid Namespace


GroupByBoxObject Class Members

[image]
Intersoft WebGrid Documentation
GroupByBoxObject Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebGrid Namespace : GroupByBoxObject Class

Glossary Item Box

The following tables list the members exposed by GroupByBoxObject.

Public Constructors

 | Name | Description
Public Constructor | GroupByBoxObject Constructor |
Top

Public Properties

 | Name | Description
Public Property | ConnectorLineColor |
Public Property | ConnectorLineStyle |
Public Property | ContextMenu |
Public Property | LabelStyle |
Public Property | Style |
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CustomDeserialize |
Public Method | CustomSerialize |
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString |
Top

See Also

Reference

GroupByBoxObject Class
ISNet.WebUI.WebGrid Namespace


GroupByBoxObject Constructor

[image]
Intersoft WebGrid Documentation
GroupByBoxObject Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > GroupByBoxObject Class : GroupByBoxObject Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New GroupByBoxObject()
C#
public GroupByBoxObject()
Delphi
public GroupByBoxObject();
JScript
public function GroupByBoxObject();
Managed Extensions for C++
public: GroupByBoxObject();
C++/CLI
public:
GroupByBoxObject();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GroupByBoxObject Class
GroupByBoxObject Members


Clone Method

[image]
Intersoft WebGrid Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > GroupByBoxObject Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As System.Object
Visual Basic (Usage) Copy Code
Dim instance As GroupByBoxObject
Dim value As System.Object

value = instance.Clone()
C#
public virtual System.object Clone()
Delphi
public function Clone(): System.TObject; virtual;
JScript
public function Clone() : System.Object;
Managed Extensions for C++
public: virtual System.Object* Clone();
C++/CLI
public:
virtual System.Object^ Clone();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GroupByBoxObject Class
GroupByBoxObject Members


CopyFrom Method

[image]
Intersoft WebGrid Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > GroupByBoxObject Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GroupByBoxObject Class
GroupByBoxObject Members


CopyFrom(Object) Method

[image]
Intersoft WebGrid Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > GroupByBoxObject Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As GroupByBoxObject
Dim objSource As System.Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   System.object objSource
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GroupByBoxObject Class
GroupByBoxObject Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebGrid Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > GroupByBoxObject Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object, _
   ByVal cloneSourceValue As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As GroupByBoxObject
Dim objSource As System.Object
Dim cloneSourceValue As System.Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   System.object objSource,
   System.bool cloneSourceValue
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject;
    cloneSourceValue: System.Boolean
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object,
   cloneSourceValue : System.boolean
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource,
   System.bool cloneSourceValue
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource,
   System.bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GroupByBoxObject Class
GroupByBoxObject Members
Overload List


GroupByBoxObject Class Methods

[image]
Intersoft WebGrid Documentation
GroupByBoxObject Class Methods
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : GroupByBoxObject Class

Glossary Item Box

For a list of all members of this type, see GroupByBoxObject members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CustomDeserialize |
Public Method | CustomSerialize |
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString |
Top

See Also

Reference

GroupByBoxObject Class
ISNet.WebUI.WebGrid Namespace


CustomDeserialize Method

[image]
Intersoft WebGrid Documentation
CustomDeserialize Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > GroupByBoxObject Class : CustomDeserialize Method

mi
currentObj
parentNode
currentNode

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub CustomDeserialize( _
   ByVal mi As System.Reflection.MemberInfo, _
   ByVal currentObj As System.Object, _
   ByVal parentNode As System.Xml.XmlNode, _
   ByVal currentNode As System.Xml.XmlNode _
)
Visual Basic (Usage) Copy Code
Dim instance As GroupByBoxObject
Dim mi As System.Reflection.MemberInfo
Dim currentObj As System.Object
Dim parentNode As System.Xml.XmlNode
Dim currentNode As System.Xml.XmlNode

instance.CustomDeserialize(mi, currentObj, parentNode, currentNode)
C#
public void CustomDeserialize(
   System.Reflection.MemberInfo mi,
   System.object currentObj,
   System.Xml.XmlNode parentNode,
   System.Xml.XmlNode currentNode
)
Delphi
public procedure CustomDeserialize(
    mi: System.Reflection.MemberInfo;
    currentObj: System.TObject;
    parentNode: System.Xml.XmlNode;
    currentNode: System.Xml.XmlNode
);
JScript
public function CustomDeserialize(
   mi : System.Reflection.MemberInfo,
   currentObj : System.Object,
   parentNode : System.Xml.XmlNode,
   currentNode : System.Xml.XmlNode
);
Managed Extensions for C++
public: void CustomDeserialize(
   System.Reflection.MemberInfo* mi,
   System.Object* currentObj,
   System.Xml.XmlNode* parentNode,
   System.Xml.XmlNode* currentNode
)
C++/CLI
public:
void CustomDeserialize(
   System.Reflection.MemberInfo^ mi,
   System.Object^ currentObj,
   System.Xml.XmlNode^ parentNode,
   System.Xml.XmlNode^ currentNode
)

Parameters

mi
currentObj
parentNode
currentNode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GroupByBoxObject Class
GroupByBoxObject Members


CustomSerialize Method

[image]
Intersoft WebGrid Documentation
CustomSerialize Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > GroupByBoxObject Class : CustomSerialize Method

doc
node

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub CustomSerialize( _
   ByVal doc As System.Xml.XmlDocument, _
   ByVal node As System.Xml.XmlNode _
)
Visual Basic (Usage) Copy Code
Dim instance As GroupByBoxObject
Dim doc As System.Xml.XmlDocument
Dim node As System.Xml.XmlNode

instance.CustomSerialize(doc, node)
C#
public void CustomSerialize(
   System.Xml.XmlDocument doc,
   System.Xml.XmlNode node
)
Delphi
public procedure CustomSerialize(
    doc: System.Xml.XmlDocument;
    node: System.Xml.XmlNode
);
JScript
public function CustomSerialize(
   doc : System.Xml.XmlDocument,
   node : System.Xml.XmlNode
);
Managed Extensions for C++
public: void CustomSerialize(
   System.Xml.XmlDocument* doc,
   System.Xml.XmlNode* node
)
C++/CLI
public:
void CustomSerialize(
   System.Xml.XmlDocument^ doc,
   System.Xml.XmlNode^ node
)

Parameters

doc
node

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GroupByBoxObject Class
GroupByBoxObject Members


DeSerializeObjectData Method

[image]
Intersoft WebGrid Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > GroupByBoxObject Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As GroupByBoxObject
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure DeSerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function DeSerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void DeSerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void DeSerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GroupByBoxObject Class
GroupByBoxObject Members


GetHashCode Method

[image]
Intersoft WebGrid Documentation
GetHashCode Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > GroupByBoxObject Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As GroupByBoxObject
Dim value As System.Integer

value = instance.GetHashCode()
C#
public virtual System.int GetHashCode()
Delphi
public function GetHashCode(): System.Integer; virtual;
JScript
public function GetHashCode() : System.int;
Managed Extensions for C++
public: virtual System.int GetHashCode();
C++/CLI
public:
virtual System.int GetHashCode();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GroupByBoxObject Class
GroupByBoxObject Members


GetObjectData Method

[image]
Intersoft WebGrid Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > GroupByBoxObject Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As GroupByBoxObject
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure GetObjectData(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
); override;
JScript
public override function GetObjectData(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void GetObjectData(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
) override
C++/CLI
public:
void GetObjectData(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
) override

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GroupByBoxObject Class
GroupByBoxObject Members


IsEmpty Method

[image]
Intersoft WebGrid Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > GroupByBoxObject Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As GroupByBoxObject
Dim value As System.Boolean

value = instance.IsEmpty()
C#
public virtual System.bool IsEmpty()
Delphi
public function IsEmpty(): System.Boolean; virtual;
JScript
public function IsEmpty() : System.boolean;
Managed Extensions for C++
public: virtual System.bool IsEmpty();
C++/CLI
public:
virtual System.bool IsEmpty();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GroupByBoxObject Class
GroupByBoxObject Members


Reset Method

[image]
Intersoft WebGrid Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > GroupByBoxObject Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As GroupByBoxObject

instance.Reset()
C#
public virtual void Reset()
Delphi
public procedure Reset(); virtual;
JScript
public function Reset();
Managed Extensions for C++
public: virtual void Reset();
C++/CLI
public:
virtual void Reset();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GroupByBoxObject Class
GroupByBoxObject Members


SerializeObjectData Method

[image]
Intersoft WebGrid Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > GroupByBoxObject Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As GroupByBoxObject
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure SerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function SerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void SerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void SerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GroupByBoxObject Class
GroupByBoxObject Members


ToString Method

[image]
Intersoft WebGrid Documentation
ToString Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > GroupByBoxObject Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString() As System.String
Visual Basic (Usage) Copy Code
Dim instance As GroupByBoxObject
Dim value As System.String

value = instance.ToString()
C#
public override System.string ToString()
Delphi
public function ToString(): System.String; override;
JScript
public override function ToString() : System.String;
Managed Extensions for C++
public: System.string* ToString(); override
C++/CLI
public:
System.String^ ToString(); override

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GroupByBoxObject Class
GroupByBoxObject Members


GroupByBoxObject Class Properties

[image]
Intersoft WebGrid Documentation
GroupByBoxObject Class Properties
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : GroupByBoxObject Class

Glossary Item Box

For a list of all members of this type, see GroupByBoxObject members.

Public Properties

 | Name | Description
Public Property | ConnectorLineColor |
Public Property | ConnectorLineStyle |
Public Property | ContextMenu |
Public Property | LabelStyle |
Public Property | Style |
Top

See Also

Reference

GroupByBoxObject Class
ISNet.WebUI.WebGrid Namespace


GroupByBoxObject Constructor

[image]
Intersoft WebGrid Documentation
GroupByBoxObject Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > GroupByBoxObject Class : GroupByBoxObject Constructor

Glossary Item Box

Overload List

Overload | Description
GroupByBoxObject Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GroupByBoxObject Class
GroupByBoxObject Members


ConnectorLineColor Property

[image]
Intersoft WebGrid Documentation
ConnectorLineColor Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > GroupByBoxObject Class : ConnectorLineColor Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.MarkAsStyleAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Specifies the line color of the connector which is used to display link between hierarchical's group columns.")>
Public Property ConnectorLineColor As System.Drawing.Color
Visual Basic (Usage) Copy Code
Dim instance As GroupByBoxObject
Dim value As System.Drawing.Color

instance.ConnectorLineColor = value

value = instance.ConnectorLineColor
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.MarkAsStyleAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the line color of the connector which is used to display link between hierarchical's group columns.")]
public System.Drawing.Color ConnectorLineColor {get; set;}
Delphi
public read-write property ConnectorLineColor: System.Drawing.Color;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
ISNet.MarkAsStyleAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the line color of the connector which is used to display link between hierarchical's group columns.")
public function get,set ConnectorLineColor : System.Drawing.Color
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.MarkAsStyleAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the line color of the connector which is used to display link between hierarchical's group columns.")]
public: __property System.Drawing.Color get_ConnectorLineColor();
public: __property void set_ConnectorLineColor(
   System.Drawing.Color value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.MarkAsStyleAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the line color of the connector which is used to display link between hierarchical's group columns.")]
public:
property System.Drawing.Color ConnectorLineColor {
   System.Drawing.Color get();
   void set (    System.Drawing.Color value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GroupByBoxObject Class
GroupByBoxObject Members


ConnectorLineStyle Property

[image]
Intersoft WebGrid Documentation
ConnectorLineStyle Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > GroupByBoxObject Class : ConnectorLineStyle Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies the line style of the connector which is used to display link between hierarchical's group columns.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property ConnectorLineStyle As System.Web.UI.WebControls.BorderStyle
Visual Basic (Usage) Copy Code
Dim instance As GroupByBoxObject
Dim value As System.Web.UI.WebControls.BorderStyle

instance.ConnectorLineStyle = value

value = instance.ConnectorLineStyle
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the line style of the connector which is used to display link between hierarchical's group columns.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.Web.UI.WebControls.BorderStyle ConnectorLineStyle {get; set;}
Delphi
public read-write property ConnectorLineStyle: System.Web.UI.WebControls.BorderStyle;
JScript
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the line style of the connector which is used to display link between hierarchical's group columns.")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set ConnectorLineStyle : System.Web.UI.WebControls.BorderStyle
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the line style of the connector which is used to display link between hierarchical's group columns.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.Web.UI.WebControls.BorderStyle get_ConnectorLineStyle();
public: __property void set_ConnectorLineStyle(
   System.Web.UI.WebControls.BorderStyle value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the line style of the connector which is used to display link between hierarchical's group columns.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.Web.UI.WebControls.BorderStyle ConnectorLineStyle {
   System.Web.UI.WebControls.BorderStyle get();
   void set (    System.Web.UI.WebControls.BorderStyle value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GroupByBoxObject Class
GroupByBoxObject Members


ContextMenu Property

[image]
Intersoft WebGrid Documentation
ContextMenu Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > GroupByBoxObject Class : ContextMenu Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies whether the GroupByBox menu is enabled or disabled in the column's context menu.")>
Public Property ContextMenu As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As GroupByBoxObject
Dim value As System.Boolean

instance.ContextMenu = value

value = instance.ContextMenu
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether the GroupByBox menu is enabled or disabled in the column's context menu.")]
public System.bool ContextMenu {get; set;}
Delphi
public read-write property ContextMenu: System.Boolean;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Specifies whether the GroupByBox menu is enabled or disabled in the column's context menu.")
public function get,set ContextMenu : System.boolean
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether the GroupByBox menu is enabled or disabled in the column's context menu.")]
public: __property System.bool get_ContextMenu();
public: __property void set_ContextMenu(
   System.bool value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether the GroupByBox menu is enabled or disabled in the column's context menu.")]
public:
property System.bool ContextMenu {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GroupByBoxObject Class
GroupByBoxObject Members


LabelStyle Property

[image]
Intersoft WebGrid Documentation
LabelStyle Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > GroupByBoxObject Class : LabelStyle Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("The style applied to the table caption's label style.")>
Public Property LabelStyle As WebGridFormatStyle
Visual Basic (Usage) Copy Code
Dim instance As GroupByBoxObject
Dim value As WebGridFormatStyle

instance.LabelStyle = value

value = instance.LabelStyle
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("The style applied to the table caption's label style.")]
public WebGridFormatStyle LabelStyle {get; set;}
Delphi
public read-write property LabelStyle: WebGridFormatStyle;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("The style applied to the table caption's label style.")
public function get,set LabelStyle : WebGridFormatStyle
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("The style applied to the table caption's label style.")]
public: __property WebGridFormatStyle* get_LabelStyle();
public: __property void set_LabelStyle(
   WebGridFormatStyle* value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("The style applied to the table caption's label style.")]
public:
property WebGridFormatStyle^ LabelStyle {
   WebGridFormatStyle^ get();
   void set (    WebGridFormatStyle^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GroupByBoxObject Class
GroupByBoxObject Members


Style Property

[image]
Intersoft WebGrid Documentation
Style Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > GroupByBoxObject Class : Style Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("The style applied for the GroupBox appearance.")>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
Public Property Style As WebGridFormatStyle
Visual Basic (Usage) Copy Code
Dim instance As GroupByBoxObject
Dim value As WebGridFormatStyle

instance.Style = value

value = instance.Style
C#
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("The style applied for the GroupBox appearance.")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
public WebGridFormatStyle Style {get; set;}
Delphi
public read-write property Style: WebGridFormatStyle;
JScript
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("The style applied for the GroupBox appearance.")
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
public function get,set Style : WebGridFormatStyle
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("The style applied for the GroupBox appearance.")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
public: __property WebGridFormatStyle* get_Style();
public: __property void set_Style(
   WebGridFormatStyle* value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("The style applied for the GroupBox appearance.")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
public:
property WebGridFormatStyle^ Style {
   WebGridFormatStyle^ get();
   void set (    WebGridFormatStyle^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GroupByBoxObject Class
GroupByBoxObject Members


ImageSettings Class

[image]
Intersoft WebGrid Documentation
ImageSettings Class
Members See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : ImageSettings Class

Glossary Item Box

Object Model

ImageSettings Class

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute()>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<ISNet.MarkAsStyleAttribute(True)>
<System.SerializableAttribute()>
Public Class ImageSettings
   Inherits ISNet.WebUI.WebUIBaseClass
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Visual Basic (Usage) Copy Code
Dim instance As ImageSettings
C#
[System.ComponentModel.DescriptionAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[ISNet.MarkAsStyleAttribute(true)]
[System.SerializableAttribute()]
public class ImageSettings : ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Delphi
public class ImageSettings = class(ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize)
JScript
System.ComponentModel.DescriptionAttribute()
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
ISNet.MarkAsStyleAttribute()
System.SerializableAttribute()
public class ImageSettings extends ISNet.WebUI.WebUIBaseClass implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[ISNet.MarkAsStyleAttribute(true)]
[System.SerializableAttribute()]
public __gc class ImageSettings : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
C++/CLI
[System.ComponentModel.DescriptionAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[ISNet.MarkAsStyleAttribute(true)]
[System.SerializableAttribute()]
public ref class ImageSettings : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.WebGrid.ImageSettings

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageSettings Members
ISNet.WebUI.WebGrid Namespace


ImageSettings Class Members

[image]
Intersoft WebGrid Documentation
ImageSettings Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebGrid Namespace : ImageSettings Class

Glossary Item Box

The following tables list the members exposed by ImageSettings.

Public Constructors

 | Name | Description
Public Constructor | ImageSettings Constructor |
Top

Public Properties

 | Name | Description
Public Property | AcceptChangesImage |
Public Property | AddedRowIndicator |
Public Property | CollapseImage |
Public Property | ColumnActionImage |
Public Property | ColumnPointerImage |
Public Property | CurrentRowImage |
Public Property | DeletedRowIndicator |
Public Property | EditImage |
Public Property | ExpandImage |
Public Property | ExportImage |
Public Property | FailedImage |
Public Property | FilteredImage |
Public Property | FilterImage |
Public Property | Folder |
Public Property | GotoImage |
Public Property | GridViewImage |
Public Property | HelpImage |
Public Property | InProgressImage |
Public Property | ModifiedRowIndicator |
Public Property | MoreDataImage |
Public Property | NewRowImage |
Public Property | PagingDropdown |
Public Property | PagingMoveFirst |
Public Property | PagingMoveLast |
Public Property | PagingMoveNext |
Public Property | PagingMovePrevious |
Public Property | PagingSliderMinus |
Public Property | PagingSliderPlus |
Public Property | PendingChangesImage |
Public Property | PivotChartViewImage |
Public Property | PreviewRowCollapseImage |
Public Property | PreviewRowExpandImage |
Public Property | PrintImage |
Public Property | ReadOnlyImage |
Public Property | RefreshImage |
Public Property | RequiredImage |
Public Property | ReviewChangesImage |
Public Property | SliderThumbImage |
Public Property | SortAscImage |
Public Property | SortDescImage |
Public Property | StatusBarSeparatorImage |
Public Property | SuccessImage |
Public Property | UndoChangesImage |
Public Property | UnfilteredImage |
Public Property | WarningImage |
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString |
Top

See Also

Reference

ImageSettings Class
ISNet.WebUI.WebGrid Namespace


ImageSettings Constructor

[image]
Intersoft WebGrid Documentation
ImageSettings Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ImageSettings Class : ImageSettings Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New ImageSettings()
C#
public ImageSettings()
Delphi
public ImageSettings();
JScript
public function ImageSettings();
Managed Extensions for C++
public: ImageSettings();
C++/CLI
public:
ImageSettings();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageSettings Class
ImageSettings Members


Clone Method

[image]
Intersoft WebGrid Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ImageSettings Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As System.Object
Visual Basic (Usage) Copy Code
Dim instance As ImageSettings
Dim value As System.Object

value = instance.Clone()
C#
public virtual System.object Clone()
Delphi
public function Clone(): System.TObject; virtual;
JScript
public function Clone() : System.Object;
Managed Extensions for C++
public: virtual System.Object* Clone();
C++/CLI
public:
virtual System.Object^ Clone();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageSettings Class
ImageSettings Members


CopyFrom Method

[image]
Intersoft WebGrid Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ImageSettings Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageSettings Class
ImageSettings Members


CopyFrom(Object) Method

[image]
Intersoft WebGrid Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ImageSettings Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As ImageSettings
Dim objSource As System.Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   System.object objSource
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageSettings Class
ImageSettings Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebGrid Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ImageSettings Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object, _
   ByVal cloneSourceValue As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As ImageSettings
Dim objSource As System.Object
Dim cloneSourceValue As System.Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   System.object objSource,
   System.bool cloneSourceValue
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject;
    cloneSourceValue: System.Boolean
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object,
   cloneSourceValue : System.boolean
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource,
   System.bool cloneSourceValue
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource,
   System.bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageSettings Class
ImageSettings Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebGrid Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ImageSettings Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As ImageSettings
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure DeSerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function DeSerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void DeSerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void DeSerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageSettings Class
ImageSettings Members


GetHashCode Method

[image]
Intersoft WebGrid Documentation
GetHashCode Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ImageSettings Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As ImageSettings
Dim value As System.Integer

value = instance.GetHashCode()
C#
public virtual System.int GetHashCode()
Delphi
public function GetHashCode(): System.Integer; virtual;
JScript
public function GetHashCode() : System.int;
Managed Extensions for C++
public: virtual System.int GetHashCode();
C++/CLI
public:
virtual System.int GetHashCode();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageSettings Class
ImageSettings Members


ImageSettings Class Methods

[image]
Intersoft WebGrid Documentation
ImageSettings Class Methods
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : ImageSettings Class

Glossary Item Box

For a list of all members of this type, see ImageSettings members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString |
Top

See Also

Reference

ImageSettings Class
ISNet.WebUI.WebGrid Namespace


GetObjectData Method

[image]
Intersoft WebGrid Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ImageSettings Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As ImageSettings
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure GetObjectData(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
); override;
JScript
public override function GetObjectData(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void GetObjectData(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
) override
C++/CLI
public:
void GetObjectData(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
) override

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageSettings Class
ImageSettings Members


IsEmpty Method

[image]
Intersoft WebGrid Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ImageSettings Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As ImageSettings
Dim value As System.Boolean

value = instance.IsEmpty()
C#
public virtual System.bool IsEmpty()
Delphi
public function IsEmpty(): System.Boolean; virtual;
JScript
public function IsEmpty() : System.boolean;
Managed Extensions for C++
public: virtual System.bool IsEmpty();
C++/CLI
public:
virtual System.bool IsEmpty();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageSettings Class
ImageSettings Members


Reset Method

[image]
Intersoft WebGrid Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ImageSettings Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As ImageSettings

instance.Reset()
C#
public virtual void Reset()
Delphi
public procedure Reset(); virtual;
JScript
public function Reset();
Managed Extensions for C++
public: virtual void Reset();
C++/CLI
public:
virtual void Reset();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageSettings Class
ImageSettings Members


SerializeObjectData Method

[image]
Intersoft WebGrid Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ImageSettings Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As ImageSettings
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure SerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function SerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void SerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void SerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageSettings Class
ImageSettings Members


ToString Method

[image]
Intersoft WebGrid Documentation
ToString Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ImageSettings Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString() As System.String
Visual Basic (Usage) Copy Code
Dim instance As ImageSettings
Dim value As System.String

value = instance.ToString()
C#
public override System.string ToString()
Delphi
public function ToString(): System.String; override;
JScript
public override function ToString() : System.String;
Managed Extensions for C++
public: System.string* ToString(); override
C++/CLI
public:
System.String^ ToString(); override

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageSettings Class
ImageSettings Members


ImageSettings Class Properties

[image]
Intersoft WebGrid Documentation
ImageSettings Class Properties
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : ImageSettings Class

Glossary Item Box

For a list of all members of this type, see ImageSettings members.

Public Properties

 | Name | Description
Public Property | AcceptChangesImage |
Public Property | AddedRowIndicator |
Public Property | CollapseImage |
Public Property | ColumnActionImage |
Public Property | ColumnPointerImage |
Public Property | CurrentRowImage |
Public Property | DeletedRowIndicator |
Public Property | EditImage |
Public Property | ExpandImage |
Public Property | ExportImage |
Public Property | FailedImage |
Public Property | FilteredImage |
Public Property | FilterImage |
Public Property | Folder |
Public Property | GotoImage |
Public Property | GridViewImage |
Public Property | HelpImage |
Public Property | InProgressImage |
Public Property | ModifiedRowIndicator |
Public Property | MoreDataImage |
Public Property | NewRowImage |
Public Property | PagingDropdown |
Public Property | PagingMoveFirst |
Public Property | PagingMoveLast |
Public Property | PagingMoveNext |
Public Property | PagingMovePrevious |
Public Property | PagingSliderMinus |
Public Property | PagingSliderPlus |
Public Property | PendingChangesImage |
Public Property | PivotChartViewImage |
Public Property | PreviewRowCollapseImage |
Public Property | PreviewRowExpandImage |
Public Property | PrintImage |
Public Property | ReadOnlyImage |
Public Property | RefreshImage |
Public Property | RequiredImage |
Public Property | ReviewChangesImage |
Public Property | SliderThumbImage |
Public Property | SortAscImage |
Public Property | SortDescImage |
Public Property | StatusBarSeparatorImage |
Public Property | SuccessImage |
Public Property | UndoChangesImage |
Public Property | UnfilteredImage |
Public Property | WarningImage |
Top

See Also

Reference

ImageSettings Class
ISNet.WebUI.WebGrid Namespace


ImageSettings Constructor

[image]
Intersoft WebGrid Documentation
ImageSettings Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ImageSettings Class : ImageSettings Constructor

Glossary Item Box

Overload List

Overload | Description
ImageSettings Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageSettings Class
ImageSettings Members


AcceptChangesImage Property

[image]
Intersoft WebGrid Documentation
AcceptChangesImage Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ImageSettings Class : AcceptChangesImage Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies the image used to indicate accept changes command.")>
Public Property AcceptChangesImage As System.String
Visual Basic (Usage) Copy Code
Dim instance As ImageSettings
Dim value As System.String

instance.AcceptChangesImage = value

value = instance.AcceptChangesImage
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the image used to indicate accept changes command.")]
public System.string AcceptChangesImage {get; set;}
Delphi
public read-write property AcceptChangesImage: System.String;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the image used to indicate accept changes command.")
public function get,set AcceptChangesImage : System.String
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the image used to indicate accept changes command.")]
public: __property System.string* get_AcceptChangesImage();
public: __property void set_AcceptChangesImage(
   System.string* value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the image used to indicate accept changes command.")]
public:
property System.String^ AcceptChangesImage {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageSettings Class
ImageSettings Members


AddedRowIndicator Property

[image]
Intersoft WebGrid Documentation
AddedRowIndicator Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ImageSettings Class : AddedRowIndicator Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies the image used to indicate added row, when batch update mode is enabled.")>
Public Property AddedRowIndicator As System.String
Visual Basic (Usage) Copy Code
Dim instance As ImageSettings
Dim value As System.String

instance.AddedRowIndicator = value

value = instance.AddedRowIndicator
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the image used to indicate added row, when batch update mode is enabled.")]
public System.string AddedRowIndicator {get; set;}
Delphi
public read-write property AddedRowIndicator: System.String;
JScript
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the image used to indicate added row, when batch update mode is enabled.")
public function get,set AddedRowIndicator : System.String
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the image used to indicate added row, when batch update mode is enabled.")]
public: __property System.string* get_AddedRowIndicator();
public: __property void set_AddedRowIndicator(
   System.string* value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the image used to indicate added row, when batch update mode is enabled.")]
public:
property System.String^ AddedRowIndicator {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageSettings Class
ImageSettings Members


CollapseImage Property

[image]
Intersoft WebGrid Documentation
CollapseImage Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ImageSettings Class : CollapseImage Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies the collapse image file.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property CollapseImage As System.String
Visual Basic (Usage) Copy Code
Dim instance As ImageSettings
Dim value As System.String

instance.CollapseImage = value

value = instance.CollapseImage
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the collapse image file.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public System.string CollapseImage {get; set;}
Delphi
public read-write property CollapseImage: System.String;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the collapse image file.")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get,set CollapseImage : System.String
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the collapse image file.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.string* get_CollapseImage();
public: __property void set_CollapseImage(
   System.string* value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the collapse image file.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.String^ CollapseImage {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageSettings Class
ImageSettings Members


ColumnActionImage Property

[image]
Intersoft WebGrid Documentation
ColumnActionImage Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ImageSettings Class : ColumnActionImage Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies the image used for column action indicator.")>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Property ColumnActionImage As System.String
Visual Basic (Usage) Copy Code
Dim instance As ImageSettings
Dim value As System.String

instance.ColumnActionImage = value

value = instance.ColumnActionImage
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the image used for column action indicator.")]
[ISNet.Serialization.XmlSerializableAttribute()]
public System.string ColumnActionImage {get; set;}
Delphi
public read-write property ColumnActionImage: System.String;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the image used for column action indicator.")
ISNet.Serialization.XmlSerializableAttribute()
public function get,set ColumnActionImage : System.String
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the image used for column action indicator.")]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property System.string* get_ColumnActionImage();
public: __property void set_ColumnActionImage(
   System.string* value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the image used for column action indicator.")]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property System.String^ ColumnActionImage {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageSettings Class
ImageSettings Members


ColumnPointerImage Property

[image]
Intersoft WebGrid Documentation
ColumnPointerImage Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ImageSettings Class : ColumnPointerImage Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies the pointer image used to identify column's position when dragged from column headers or group columns.")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property ColumnPointerImage As System.String
Visual Basic (Usage) Copy Code
Dim instance As ImageSettings
Dim value As System.String

instance.ColumnPointerImage = value

value = instance.ColumnPointerImage
C#
[System.ComponentModel.DescriptionAttribute("Specifies the pointer image used to identify column's position when dragged from column headers or group columns.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public System.string ColumnPointerImage {get; set;}
Delphi
public read-write property ColumnPointerImage: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Specifies the pointer image used to identify column's position when dragged from column headers or group columns.")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get,set ColumnPointerImage : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies the pointer image used to identify column's position when dragged from column headers or group columns.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.string* get_ColumnPointerImage();
public: __property void set_ColumnPointerImage(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies the pointer image used to identify column's position when dragged from column headers or group columns.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.String^ ColumnPointerImage {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageSettings Class
ImageSettings Members


CurrentRowImage Property

[image]
Intersoft WebGrid Documentation
CurrentRowImage Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ImageSettings Class : CurrentRowImage Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies the image that represent the current selected/active row.")>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Property CurrentRowImage As System.String
Visual Basic (Usage) Copy Code
Dim instance As ImageSettings
Dim value As System.String

instance.CurrentRowImage = value

value = instance.CurrentRowImage
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the image that represent the current selected/active row.")]
[ISNet.Serialization.XmlSerializableAttribute()]
public System.string CurrentRowImage {get; set;}
Delphi
public read-write property CurrentRowImage: System.String;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the image that represent the current selected/active row.")
ISNet.Serialization.XmlSerializableAttribute()
public function get,set CurrentRowImage : System.String
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the image that represent the current selected/active row.")]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property System.string* get_CurrentRowImage();
public: __property void set_CurrentRowImage(
   System.string* value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the image that represent the current selected/active row.")]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property System.String^ CurrentRowImage {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageSettings Class
ImageSettings Members


DeletedRowIndicator Property

[image]
Intersoft WebGrid Documentation
DeletedRowIndicator Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ImageSettings Class : DeletedRowIndicator Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies the image used to indicate deleted row, when batch update mode is enabled.")>
Public Property DeletedRowIndicator As System.String
Visual Basic (Usage) Copy Code
Dim instance As ImageSettings
Dim value As System.String

instance.DeletedRowIndicator = value

value = instance.DeletedRowIndicator
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the image used to indicate deleted row, when batch update mode is enabled.")]
public System.string DeletedRowIndicator {get; set;}
Delphi
public read-write property DeletedRowIndicator: System.String;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the image used to indicate deleted row, when batch update mode is enabled.")
public function get,set DeletedRowIndicator : System.String
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the image used to indicate deleted row, when batch update mode is enabled.")]
public: __property System.string* get_DeletedRowIndicator();
public: __property void set_DeletedRowIndicator(
   System.string* value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the image used to indicate deleted row, when batch update mode is enabled.")]
public:
property System.String^ DeletedRowIndicator {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageSettings Class
ImageSettings Members


EditImage Property

[image]
Intersoft WebGrid Documentation
EditImage Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ImageSettings Class : EditImage Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies the image that represent the current row being edited.")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property EditImage As System.String
Visual Basic (Usage) Copy Code
Dim instance As ImageSettings
Dim value As System.String

instance.EditImage = value

value = instance.EditImage
C#
[System.ComponentModel.DescriptionAttribute("Specifies the image that represent the current row being edited.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public System.string EditImage {get; set;}
Delphi
public read-write property EditImage: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Specifies the image that represent the current row being edited.")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get,set EditImage : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies the image that represent the current row being edited.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.string* get_EditImage();
public: __property void set_EditImage(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies the image that represent the current row being edited.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.String^ EditImage {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageSettings Class
ImageSettings Members


ExpandImage Property

[image]
Intersoft WebGrid Documentation
ExpandImage Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ImageSettings Class : ExpandImage Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies the expand image file.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property ExpandImage As System.String
Visual Basic (Usage) Copy Code
Dim instance As ImageSettings
Dim value As System.String

instance.ExpandImage = value

value = instance.ExpandImage
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the expand image file.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public System.string ExpandImage {get; set;}
Delphi
public read-write property ExpandImage: System.String;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the expand image file.")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get,set ExpandImage : System.String
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the expand image file.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.string* get_ExpandImage();
public: __property void set_ExpandImage(
   System.string* value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the expand image file.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.String^ ExpandImage {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageSettings Class
ImageSettings Members


ExportImage Property

[image]
Intersoft WebGrid Documentation
ExportImage Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ImageSettings Class : ExportImage Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies the export image filename.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property ExportImage As System.String
Visual Basic (Usage) Copy Code
Dim instance As ImageSettings
Dim value As System.String

instance.ExportImage = value

value = instance.ExportImage
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the export image filename.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public System.string ExportImage {get; set;}
Delphi
public read-write property ExportImage: System.String;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the export image filename.")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get,set ExportImage : System.String
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the export image filename.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.string* get_ExportImage();
public: __property void set_ExportImage(
   System.string* value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the export image filename.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.String^ ExportImage {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageSettings Class
ImageSettings Members


FailedImage Property

[image]
Intersoft WebGrid Documentation
FailedImage Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ImageSettings Class : FailedImage Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies the image used to indicate unsuccessful operation.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Property FailedImage As System.String
Visual Basic (Usage) Copy Code
Dim instance As ImageSettings
Dim value As System.String

instance.FailedImage = value

value = instance.FailedImage
C#
[System.ComponentModel.DescriptionAttribute("Specifies the image used to indicate unsuccessful operation.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
public System.string FailedImage {get; set;}
Delphi
public read-write property FailedImage: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Specifies the image used to indicate unsuccessful operation.")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.XmlSerializableAttribute()
public function get,set FailedImage : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies the image used to indicate unsuccessful operation.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property System.string* get_FailedImage();
public: __property void set_FailedImage(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies the image used to indicate unsuccessful operation.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property System.String^ FailedImage {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageSettings Class
ImageSettings Members


FilteredImage Property

[image]
Intersoft WebGrid Documentation
FilteredImage Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ImageSettings Class : FilteredImage Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies the image that indicate filtered status.")>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Property FilteredImage As System.String
Visual Basic (Usage) Copy Code
Dim instance As ImageSettings
Dim value As System.String

instance.FilteredImage = value

value = instance.FilteredImage
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the image that indicate filtered status.")]
[ISNet.Serialization.XmlSerializableAttribute()]
public System.string FilteredImage {get; set;}
Delphi
public read-write property FilteredImage: System.String;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the image that indicate filtered status.")
ISNet.Serialization.XmlSerializableAttribute()
public function get,set FilteredImage : System.String
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the image that indicate filtered status.")]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property System.string* get_FilteredImage();
public: __property void set_FilteredImage(
   System.string* value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the image that indicate filtered status.")]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property System.String^ FilteredImage {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageSettings Class
ImageSettings Members


FilterImage Property

[image]
Intersoft WebGrid Documentation
FilterImage Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ImageSettings Class : FilterImage Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies the filter image file.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property FilterImage As System.String
Visual Basic (Usage) Copy Code
Dim instance As ImageSettings
Dim value As System.String

instance.FilterImage = value

value = instance.FilterImage
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the filter image file.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public System.string FilterImage {get; set;}
Delphi
public read-write property FilterImage: System.String;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the filter image file.")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get,set FilterImage : System.String
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the filter image file.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.string* get_FilterImage();
public: __property void set_FilterImage(
   System.string* value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the filter image file.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.String^ FilterImage {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageSettings Class
ImageSettings Members


Folder Property

[image]
Intersoft WebGrid Documentation
Folder Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ImageSettings Class : Folder Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies the folder of all Images.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property Folder As System.String
Visual Basic (Usage) Copy Code
Dim instance As ImageSettings
Dim value As System.String

instance.Folder = value

value = instance.Folder
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the folder of all Images.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
public System.string Folder {get; set;}
Delphi
public read-write property Folder: System.String;
JScript
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the folder of all Images.")
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get,set Folder : System.String
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the folder of all Images.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.string* get_Folder();
public: __property void set_Folder(
   System.string* value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the folder of all Images.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.String^ Folder {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageSettings Class
ImageSettings Members


GotoImage Property

[image]
Intersoft WebGrid Documentation
GotoImage Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ImageSettings Class : GotoImage Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies the image for jump-to-record function.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property GotoImage As System.String
Visual Basic (Usage) Copy Code
Dim instance As ImageSettings
Dim value As System.String

instance.GotoImage = value

value = instance.GotoImage
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the image for jump-to-record function.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public System.string GotoImage {get; set;}
Delphi
public read-write property GotoImage: System.String;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the image for jump-to-record function.")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get,set GotoImage : System.String
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the image for jump-to-record function.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.string* get_GotoImage();
public: __property void set_GotoImage(
   System.string* value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the image for jump-to-record function.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.String^ GotoImage {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageSettings Class
ImageSettings Members


GridViewImage Property

[image]
Intersoft WebGrid Documentation
GridViewImage Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ImageSettings Class : GridViewImage Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Specifies the image used to indicate grid view mode.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property GridViewImage As System.String
Visual Basic (Usage) Copy Code
Dim instance As ImageSettings
Dim value As System.String

instance.GridViewImage = value

value = instance.GridViewImage
C#
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the image used to indicate grid view mode.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public System.string GridViewImage {get; set;}
Delphi
public read-write property GridViewImage: System.String;
JScript
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the image used to indicate grid view mode.")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get,set GridViewImage : System.String
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the image used to indicate grid view mode.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.string* get_GridViewImage();
public: __property void set_GridViewImage(
   System.string* value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the image used to indicate grid view mode.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.String^ GridViewImage {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageSettings Class
ImageSettings Members


HelpImage Property

[image]
Intersoft WebGrid Documentation
HelpImage Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ImageSettings Class : HelpImage Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies the image file for Help command.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property HelpImage As System.String
Visual Basic (Usage) Copy Code
Dim instance As ImageSettings
Dim value As System.String

instance.HelpImage = value

value = instance.HelpImage
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the image file for Help command.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
public System.string HelpImage {get; set;}
Delphi
public read-write property HelpImage: System.String;
JScript
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the image file for Help command.")
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get,set HelpImage : System.String
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the image file for Help command.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.string* get_HelpImage();
public: __property void set_HelpImage(
   System.string* value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the image file for Help command.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.String^ HelpImage {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageSettings Class
ImageSettings Members


InProgressImage Property

[image]
Intersoft WebGrid Documentation
InProgressImage Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ImageSettings Class : InProgressImage Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies the image that will be displayed when WebGrid is in progress processing request.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property InProgressImage As System.String
Visual Basic (Usage) Copy Code
Dim instance As ImageSettings
Dim value As System.String

instance.InProgressImage = value

value = instance.InProgressImage
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the image that will be displayed when WebGrid is in progress processing request.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public System.string InProgressImage {get; set;}
Delphi
public read-write property InProgressImage: System.String;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the image that will be displayed when WebGrid is in progress processing request.")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get,set InProgressImage : System.String
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the image that will be displayed when WebGrid is in progress processing request.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.string* get_InProgressImage();
public: __property void set_InProgressImage(
   System.string* value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the image that will be displayed when WebGrid is in progress processing request.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.String^ InProgressImage {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageSettings Class
ImageSettings Members


ModifiedRowIndicator Property

[image]
Intersoft WebGrid Documentation
ModifiedRowIndicator Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ImageSettings Class : ModifiedRowIndicator Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies the image used to indicate modified row, when batch update mode is enabled.")>
Public Property ModifiedRowIndicator As System.String
Visual Basic (Usage) Copy Code
Dim instance As ImageSettings
Dim value As System.String

instance.ModifiedRowIndicator = value

value = instance.ModifiedRowIndicator
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the image used to indicate modified row, when batch update mode is enabled.")]
public System.string ModifiedRowIndicator {get; set;}
Delphi
public read-write property ModifiedRowIndicator: System.String;
JScript
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the image used to indicate modified row, when batch update mode is enabled.")
public function get,set ModifiedRowIndicator : System.String
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the image used to indicate modified row, when batch update mode is enabled.")]
public: __property System.string* get_ModifiedRowIndicator();
public: __property void set_ModifiedRowIndicator(
   System.string* value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the image used to indicate modified row, when batch update mode is enabled.")]
public:
property System.String^ ModifiedRowIndicator {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageSettings Class
ImageSettings Members


MoreDataImage Property

[image]
Intersoft WebGrid Documentation
MoreDataImage Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ImageSettings Class : MoreDataImage Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies the image that represent the Load more data functionality.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property MoreDataImage As System.String
Visual Basic (Usage) Copy Code
Dim instance As ImageSettings
Dim value As System.String

instance.MoreDataImage = value

value = instance.MoreDataImage
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the image that represent the Load more data functionality.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public System.string MoreDataImage {get; set;}
Delphi
public read-write property MoreDataImage: System.String;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the image that represent the Load more data functionality.")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get,set MoreDataImage : System.String
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the image that represent the Load more data functionality.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.string* get_MoreDataImage();
public: __property void set_MoreDataImage(
   System.string* value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the image that represent the Load more data functionality.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.String^ MoreDataImage {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageSettings Class
ImageSettings Members


NewRowImage Property

[image]
Intersoft WebGrid Documentation
NewRowImage Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ImageSettings Class : NewRowImage Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies the image to represent new row.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property NewRowImage As System.String
Visual Basic (Usage) Copy Code
Dim instance As ImageSettings
Dim value As System.String

instance.NewRowImage = value

value = instance.NewRowImage
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the image to represent new row.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public System.string NewRowImage {get; set;}
Delphi
public read-write property NewRowImage: System.String;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the image to represent new row.")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get,set NewRowImage : System.String
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the image to represent new row.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.string* get_NewRowImage();
public: __property void set_NewRowImage(
   System.string* value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the image to represent new row.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.String^ NewRowImage {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageSettings Class
ImageSettings Members


PagingDropdown Property

[image]
Intersoft WebGrid Documentation
PagingDropdown Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ImageSettings Class : PagingDropdown Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies the image used to indicate dropdown arrow in paging function.")>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Property PagingDropdown As System.String
Visual Basic (Usage) Copy Code
Dim instance As ImageSettings
Dim value As System.String

instance.PagingDropdown = value

value = instance.PagingDropdown
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the image used to indicate dropdown arrow in paging function.")]
[ISNet.Serialization.XmlSerializableAttribute()]
public System.string PagingDropdown {get; set;}
Delphi
public read-write property PagingDropdown: System.String;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the image used to indicate dropdown arrow in paging function.")
ISNet.Serialization.XmlSerializableAttribute()
public function get,set PagingDropdown : System.String
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the image used to indicate dropdown arrow in paging function.")]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property System.string* get_PagingDropdown();
public: __property void set_PagingDropdown(
   System.string* value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the image used to indicate dropdown arrow in paging function.")]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property System.String^ PagingDropdown {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageSettings Class
ImageSettings Members


PagingMoveFirst Property

[image]
Intersoft WebGrid Documentation
PagingMoveFirst Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ImageSettings Class : PagingMoveFirst Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Specifies the image used to indicate move first command in paging function.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property PagingMoveFirst As System.String
Visual Basic (Usage) Copy Code
Dim instance As ImageSettings
Dim value As System.String

instance.PagingMoveFirst = value

value = instance.PagingMoveFirst
C#
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the image used to indicate move first command in paging function.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public System.string PagingMoveFirst {get; set;}
Delphi
public read-write property PagingMoveFirst: System.String;
JScript
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the image used to indicate move first command in paging function.")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get,set PagingMoveFirst : System.String
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the image used to indicate move first command in paging function.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.string* get_PagingMoveFirst();
public: __property void set_PagingMoveFirst(
   System.string* value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the image used to indicate move first command in paging function.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.String^ PagingMoveFirst {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageSettings Class
ImageSettings Members


PagingMoveLast Property

[image]
Intersoft WebGrid Documentation
PagingMoveLast Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ImageSettings Class : PagingMoveLast Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies the image used to indicate last command in paging function.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property PagingMoveLast As System.String
Visual Basic (Usage) Copy Code
Dim instance As ImageSettings
Dim value As System.String

instance.PagingMoveLast = value

value = instance.PagingMoveLast
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the image used to indicate last command in paging function.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.string PagingMoveLast {get; set;}
Delphi
public read-write property PagingMoveLast: System.String;
JScript
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the image used to indicate last command in paging function.")
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set PagingMoveLast : System.String
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the image used to indicate last command in paging function.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.string* get_PagingMoveLast();
public: __property void set_PagingMoveLast(
   System.string* value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the image used to indicate last command in paging function.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.String^ PagingMoveLast {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageSettings Class
ImageSettings Members


PagingMoveNext Property

[image]
Intersoft WebGrid Documentation
PagingMoveNext Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ImageSettings Class : PagingMoveNext Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies the image used to indicate next command in paging function.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property PagingMoveNext As System.String
Visual Basic (Usage) Copy Code
Dim instance As ImageSettings
Dim value As System.String

instance.PagingMoveNext = value

value = instance.PagingMoveNext
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the image used to indicate next command in paging function.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
public System.string PagingMoveNext {get; set;}
Delphi
public read-write property PagingMoveNext: System.String;
JScript
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the image used to indicate next command in paging function.")
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get,set PagingMoveNext : System.String
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the image used to indicate next command in paging function.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.string* get_PagingMoveNext();
public: __property void set_PagingMoveNext(
   System.string* value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the image used to indicate next command in paging function.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.String^ PagingMoveNext {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageSettings Class
ImageSettings Members


PagingMovePrevious Property

[image]
Intersoft WebGrid Documentation
PagingMovePrevious Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ImageSettings Class : PagingMovePrevious Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies the image used to indicate previous command in paging function.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property PagingMovePrevious As System.String
Visual Basic (Usage) Copy Code
Dim instance As ImageSettings
Dim value As System.String

instance.PagingMovePrevious = value

value = instance.PagingMovePrevious
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the image used to indicate previous command in paging function.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.string PagingMovePrevious {get; set;}
Delphi
public read-write property PagingMovePrevious: System.String;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the image used to indicate previous command in paging function.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set PagingMovePrevious : System.String
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the image used to indicate previous command in paging function.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.string* get_PagingMovePrevious();
public: __property void set_PagingMovePrevious(
   System.string* value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the image used to indicate previous command in paging function.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.String^ PagingMovePrevious {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageSettings Class
ImageSettings Members


PagingSliderMinus Property

[image]
Intersoft WebGrid Documentation
PagingSliderMinus Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ImageSettings Class : PagingSliderMinus Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies the image used to display the minus command when paging style is set to Slider.")>
Public Property PagingSliderMinus As System.String
Visual Basic (Usage) Copy Code
Dim instance As ImageSettings
Dim value As System.String

instance.PagingSliderMinus = value

value = instance.PagingSliderMinus
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the image used to display the minus command when paging style is set to Slider.")]
public System.string PagingSliderMinus {get; set;}
Delphi
public read-write property PagingSliderMinus: System.String;
JScript
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the image used to display the minus command when paging style is set to Slider.")
public function get,set PagingSliderMinus : System.String
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the image used to display the minus command when paging style is set to Slider.")]
public: __property System.string* get_PagingSliderMinus();
public: __property void set_PagingSliderMinus(
   System.string* value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the image used to display the minus command when paging style is set to Slider.")]
public:
property System.String^ PagingSliderMinus {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageSettings Class
ImageSettings Members


PagingSliderPlus Property

[image]
Intersoft WebGrid Documentation
PagingSliderPlus Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ImageSettings Class : PagingSliderPlus Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies the image used to display the plus command when paging style is set to Slider.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property PagingSliderPlus As System.String
Visual Basic (Usage) Copy Code
Dim instance As ImageSettings
Dim value As System.String

instance.PagingSliderPlus = value

value = instance.PagingSliderPlus
C#
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the image used to display the plus command when paging style is set to Slider.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public System.string PagingSliderPlus {get; set;}
Delphi
public read-write property PagingSliderPlus: System.String;
JScript
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the image used to display the plus command when paging style is set to Slider.")
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get,set PagingSliderPlus : System.String
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the image used to display the plus command when paging style is set to Slider.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.string* get_PagingSliderPlus();
public: __property void set_PagingSliderPlus(
   System.string* value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the image used to display the plus command when paging style is set to Slider.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.String^ PagingSliderPlus {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageSettings Class
ImageSettings Members


PendingChangesImage Property

[image]
Intersoft WebGrid Documentation
PendingChangesImage Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ImageSettings Class : PendingChangesImage Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies the image used to indicate unsaved pending changes, when batch update mode is enabled.")>
Public Property PendingChangesImage As System.String
Visual Basic (Usage) Copy Code
Dim instance As ImageSettings
Dim value As System.String

instance.PendingChangesImage = value

value = instance.PendingChangesImage
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the image used to indicate unsaved pending changes, when batch update mode is enabled.")]
public System.string PendingChangesImage {get; set;}
Delphi
public read-write property PendingChangesImage: System.String;
JScript
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the image used to indicate unsaved pending changes, when batch update mode is enabled.")
public function get,set PendingChangesImage : System.String
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the image used to indicate unsaved pending changes, when batch update mode is enabled.")]
public: __property System.string* get_PendingChangesImage();
public: __property void set_PendingChangesImage(
   System.string* value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the image used to indicate unsaved pending changes, when batch update mode is enabled.")]
public:
property System.String^ PendingChangesImage {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageSettings Class
ImageSettings Members


PivotChartViewImage Property

[image]
Intersoft WebGrid Documentation
PivotChartViewImage Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ImageSettings Class : PivotChartViewImage Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies the image used to indicate grid view mode.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property PivotChartViewImage As System.String
Visual Basic (Usage) Copy Code
Dim instance As ImageSettings
Dim value As System.String

instance.PivotChartViewImage = value

value = instance.PivotChartViewImage
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the image used to indicate grid view mode.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public System.string PivotChartViewImage {get; set;}
Delphi
public read-write property PivotChartViewImage: System.String;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the image used to indicate grid view mode.")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get,set PivotChartViewImage : System.String
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the image used to indicate grid view mode.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.string* get_PivotChartViewImage();
public: __property void set_PivotChartViewImage(
   System.string* value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the image used to indicate grid view mode.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.String^ PivotChartViewImage {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageSettings Class
ImageSettings Members


PreviewRowCollapseImage Property

[image]
Intersoft WebGrid Documentation
PreviewRowCollapseImage Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ImageSettings Class : PreviewRowCollapseImage Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DescriptionAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Property PreviewRowCollapseImage As System.String
Visual Basic (Usage) Copy Code
Dim instance As ImageSettings
Dim value As System.String

instance.PreviewRowCollapseImage = value

value = instance.PreviewRowCollapseImage
C#
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public System.string PreviewRowCollapseImage {get; set;}
Delphi
public read-write property PreviewRowCollapseImage: System.String;
JScript
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DescriptionAttribute()
ISNet.Serialization.XmlSerializableAttribute()
public function get,set PreviewRowCollapseImage : System.String
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property System.string* get_PreviewRowCollapseImage();
public: __property void set_PreviewRowCollapseImage(
   System.string* value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property System.String^ PreviewRowCollapseImage {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageSettings Class
ImageSettings Members


PreviewRowExpandImage Property

[image]
Intersoft WebGrid Documentation
PreviewRowExpandImage Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ImageSettings Class : PreviewRowExpandImage Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Property PreviewRowExpandImage As System.String
Visual Basic (Usage) Copy Code
Dim instance As ImageSettings
Dim value As System.String

instance.PreviewRowExpandImage = value

value = instance.PreviewRowExpandImage
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public System.string PreviewRowExpandImage {get; set;}
Delphi
public read-write property PreviewRowExpandImage: System.String;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute()
ISNet.Serialization.XmlSerializableAttribute()
public function get,set PreviewRowExpandImage : System.String
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property System.string* get_PreviewRowExpandImage();
public: __property void set_PreviewRowExpandImage(
   System.string* value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property System.String^ PreviewRowExpandImage {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageSettings Class
ImageSettings Members


PrintImage Property

[image]
Intersoft WebGrid Documentation
PrintImage Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ImageSettings Class : PrintImage Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Specifies the print image filename.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property PrintImage As System.String
Visual Basic (Usage) Copy Code
Dim instance As ImageSettings
Dim value As System.String

instance.PrintImage = value

value = instance.PrintImage
C#
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the print image filename.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public System.string PrintImage {get; set;}
Delphi
public read-write property PrintImage: System.String;
JScript
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the print image filename.")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get,set PrintImage : System.String
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the print image filename.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.string* get_PrintImage();
public: __property void set_PrintImage(
   System.string* value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the print image filename.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.String^ PrintImage {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageSettings Class
ImageSettings Members


ReadOnlyImage Property

[image]
Intersoft WebGrid Documentation
ReadOnlyImage Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ImageSettings Class : ReadOnlyImage Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies the image used to indicate readonly cell in editing mode.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property ReadOnlyImage As System.String
Visual Basic (Usage) Copy Code
Dim instance As ImageSettings
Dim value As System.String

instance.ReadOnlyImage = value

value = instance.ReadOnlyImage
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the image used to indicate readonly cell in editing mode.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.string ReadOnlyImage {get; set;}
Delphi
public read-write property ReadOnlyImage: System.String;
JScript
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the image used to indicate readonly cell in editing mode.")
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set ReadOnlyImage : System.String
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the image used to indicate readonly cell in editing mode.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.string* get_ReadOnlyImage();
public: __property void set_ReadOnlyImage(
   System.string* value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the image used to indicate readonly cell in editing mode.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.String^ ReadOnlyImage {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageSettings Class
ImageSettings Members


RefreshImage Property

[image]
Intersoft WebGrid Documentation
RefreshImage Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ImageSettings Class : RefreshImage Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies the refresh image.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.MarkAsStyleAttribute(True)>
Public Property RefreshImage As System.String
Visual Basic (Usage) Copy Code
Dim instance As ImageSettings
Dim value As System.String

instance.RefreshImage = value

value = instance.RefreshImage
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the refresh image.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.MarkAsStyleAttribute(true)]
public System.string RefreshImage {get; set;}
Delphi
public read-write property RefreshImage: System.String;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the refresh image.")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.MarkAsStyleAttribute()
public function get,set RefreshImage : System.String
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the refresh image.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.MarkAsStyleAttribute(true)]
public: __property System.string* get_RefreshImage();
public: __property void set_RefreshImage(
   System.string* value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the refresh image.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.MarkAsStyleAttribute(true)]
public:
property System.String^ RefreshImage {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageSettings Class
ImageSettings Members


RequiredImage Property

[image]
Intersoft WebGrid Documentation
RequiredImage Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ImageSettings Class : RequiredImage Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies the image used to display required user input indicator.")>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Property RequiredImage As System.String
Visual Basic (Usage) Copy Code
Dim instance As ImageSettings
Dim value As System.String

instance.RequiredImage = value

value = instance.RequiredImage
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the image used to display required user input indicator.")]
[ISNet.Serialization.XmlSerializableAttribute()]
public System.string RequiredImage {get; set;}
Delphi
public read-write property RequiredImage: System.String;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the image used to display required user input indicator.")
ISNet.Serialization.XmlSerializableAttribute()
public function get,set RequiredImage : System.String
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the image used to display required user input indicator.")]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property System.string* get_RequiredImage();
public: __property void set_RequiredImage(
   System.string* value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the image used to display required user input indicator.")]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property System.String^ RequiredImage {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageSettings Class
ImageSettings Members


ReviewChangesImage Property

[image]
Intersoft WebGrid Documentation
ReviewChangesImage Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ImageSettings Class : ReviewChangesImage Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Specifies the image used to indicate review changes command.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Property ReviewChangesImage As System.String
Visual Basic (Usage) Copy Code
Dim instance As ImageSettings
Dim value As System.String

instance.ReviewChangesImage = value

value = instance.ReviewChangesImage
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the image used to indicate review changes command.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public System.string ReviewChangesImage {get; set;}
Delphi
public read-write property ReviewChangesImage: System.String;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the image used to indicate review changes command.")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute()
public function get,set ReviewChangesImage : System.String
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the image used to indicate review changes command.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property System.string* get_ReviewChangesImage();
public: __property void set_ReviewChangesImage(
   System.string* value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the image used to indicate review changes command.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property System.String^ ReviewChangesImage {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageSettings Class
ImageSettings Members


SliderThumbImage Property

[image]
Intersoft WebGrid Documentation
SliderThumbImage Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ImageSettings Class : SliderThumbImage Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies the image used to display the slider thumb for classic paging UI.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Property SliderThumbImage As System.String
Visual Basic (Usage) Copy Code
Dim instance As ImageSettings
Dim value As System.String

instance.SliderThumbImage = value

value = instance.SliderThumbImage
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the image used to display the slider thumb for classic paging UI.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public System.string SliderThumbImage {get; set;}
Delphi
public read-write property SliderThumbImage: System.String;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the image used to display the slider thumb for classic paging UI.")
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute()
public function get,set SliderThumbImage : System.String
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the image used to display the slider thumb for classic paging UI.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property System.string* get_SliderThumbImage();
public: __property void set_SliderThumbImage(
   System.string* value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the image used to display the slider thumb for classic paging UI.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property System.String^ SliderThumbImage {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageSettings Class
ImageSettings Members


SortAscImage Property

[image]
Intersoft WebGrid Documentation
SortAscImage Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ImageSettings Class : SortAscImage Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies the sort ascending image.")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property SortAscImage As System.String
Visual Basic (Usage) Copy Code
Dim instance As ImageSettings
Dim value As System.String

instance.SortAscImage = value

value = instance.SortAscImage
C#
[System.ComponentModel.DescriptionAttribute("Specifies the sort ascending image.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public System.string SortAscImage {get; set;}
Delphi
public read-write property SortAscImage: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Specifies the sort ascending image.")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get,set SortAscImage : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies the sort ascending image.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.string* get_SortAscImage();
public: __property void set_SortAscImage(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies the sort ascending image.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.String^ SortAscImage {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageSettings Class
ImageSettings Members


SortDescImage Property

[image]
Intersoft WebGrid Documentation
SortDescImage Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ImageSettings Class : SortDescImage Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies the sort descending image.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property SortDescImage As System.String
Visual Basic (Usage) Copy Code
Dim instance As ImageSettings
Dim value As System.String

instance.SortDescImage = value

value = instance.SortDescImage
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the sort descending image.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public System.string SortDescImage {get; set;}
Delphi
public read-write property SortDescImage: System.String;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the sort descending image.")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get,set SortDescImage : System.String
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the sort descending image.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.string* get_SortDescImage();
public: __property void set_SortDescImage(
   System.string* value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the sort descending image.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.String^ SortDescImage {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageSettings Class
ImageSettings Members


StatusBarSeparatorImage Property

[image]
Intersoft WebGrid Documentation
StatusBarSeparatorImage Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ImageSettings Class : StatusBarSeparatorImage Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies the status bar separator's image.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property StatusBarSeparatorImage As System.String
Visual Basic (Usage) Copy Code
Dim instance As ImageSettings
Dim value As System.String

instance.StatusBarSeparatorImage = value

value = instance.StatusBarSeparatorImage
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the status bar separator's image.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public System.string StatusBarSeparatorImage {get; set;}
Delphi
public read-write property StatusBarSeparatorImage: System.String;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the status bar separator's image.")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get,set StatusBarSeparatorImage : System.String
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the status bar separator's image.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.string* get_StatusBarSeparatorImage();
public: __property void set_StatusBarSeparatorImage(
   System.string* value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the status bar separator's image.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.String^ StatusBarSeparatorImage {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageSettings Class
ImageSettings Members


SuccessImage Property

[image]
Intersoft WebGrid Documentation
SuccessImage Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ImageSettings Class : SuccessImage Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies the image used to indicate successful operation.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property SuccessImage As System.String
Visual Basic (Usage) Copy Code
Dim instance As ImageSettings
Dim value As System.String

instance.SuccessImage = value

value = instance.SuccessImage
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the image used to indicate successful operation.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.string SuccessImage {get; set;}
Delphi
public read-write property SuccessImage: System.String;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the image used to indicate successful operation.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set SuccessImage : System.String
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the image used to indicate successful operation.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.string* get_SuccessImage();
public: __property void set_SuccessImage(
   System.string* value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the image used to indicate successful operation.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.String^ SuccessImage {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageSettings Class
ImageSettings Members


UndoChangesImage Property

[image]
Intersoft WebGrid Documentation
UndoChangesImage Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ImageSettings Class : UndoChangesImage Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies the image used to indicate accept changes command.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
Public Property UndoChangesImage As System.String
Visual Basic (Usage) Copy Code
Dim instance As ImageSettings
Dim value As System.String

instance.UndoChangesImage = value

value = instance.UndoChangesImage
C#
[System.ComponentModel.DescriptionAttribute("Specifies the image used to indicate accept changes command.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public System.string UndoChangesImage {get; set;}
Delphi
public read-write property UndoChangesImage: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Specifies the image used to indicate accept changes command.")
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
public function get,set UndoChangesImage : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies the image used to indicate accept changes command.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.string* get_UndoChangesImage();
public: __property void set_UndoChangesImage(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies the image used to indicate accept changes command.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.String^ UndoChangesImage {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageSettings Class
ImageSettings Members


UnfilteredImage Property

[image]
Intersoft WebGrid Documentation
UnfilteredImage Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ImageSettings Class : UnfilteredImage Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies the image that indicate unfiltered status.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property UnfilteredImage As System.String
Visual Basic (Usage) Copy Code
Dim instance As ImageSettings
Dim value As System.String

instance.UnfilteredImage = value

value = instance.UnfilteredImage
C#
[System.ComponentModel.DescriptionAttribute("Specifies the image that indicate unfiltered status.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.string UnfilteredImage {get; set;}
Delphi
public read-write property UnfilteredImage: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Specifies the image that indicate unfiltered status.")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set UnfilteredImage : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies the image that indicate unfiltered status.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.string* get_UnfilteredImage();
public: __property void set_UnfilteredImage(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies the image that indicate unfiltered status.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.String^ UnfilteredImage {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageSettings Class
ImageSettings Members


WarningImage Property

[image]
Intersoft WebGrid Documentation
WarningImage Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ImageSettings Class : WarningImage Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies the image used to indicate a warning during certain operation.")>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Property WarningImage As System.String
Visual Basic (Usage) Copy Code
Dim instance As ImageSettings
Dim value As System.String

instance.WarningImage = value

value = instance.WarningImage
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the image used to indicate a warning during certain operation.")]
[ISNet.Serialization.XmlSerializableAttribute()]
public System.string WarningImage {get; set;}
Delphi
public read-write property WarningImage: System.String;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the image used to indicate a warning during certain operation.")
ISNet.Serialization.XmlSerializableAttribute()
public function get,set WarningImage : System.String
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the image used to indicate a warning during certain operation.")]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property System.string* get_WarningImage();
public: __property void set_WarningImage(
   System.string* value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the image used to indicate a warning during certain operation.")]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property System.String^ WarningImage {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageSettings Class
ImageSettings Members


LayoutEventArgs Class

[image]
Intersoft WebGrid Documentation
LayoutEventArgs Class
Members See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : LayoutEventArgs Class

Glossary Item Box

Object Model

LayoutEventArgs Class

Syntax

Visual Basic (Declaration)
Public Class LayoutEventArgs
   Inherits BaseEventArgs
Visual Basic (Usage) Copy Code
Dim instance As LayoutEventArgs
C#
public class LayoutEventArgs : BaseEventArgs
Delphi
public class LayoutEventArgs = class(BaseEventArgs)
JScript
public class LayoutEventArgs extends BaseEventArgs
Managed Extensions for C++
public __gc class LayoutEventArgs : public BaseEventArgs
C++/CLI
public ref class LayoutEventArgs : public BaseEventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
ISNet.WebUI.WebGrid.BaseEventArgs
ISNet.WebUI.WebGrid.LayoutEventArgs

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayoutEventArgs Members
ISNet.WebUI.WebGrid Namespace


LayoutEventArgs Class Members

[image]
Intersoft WebGrid Documentation
LayoutEventArgs Class Members
See Also Properties Send Feedback
ISNet.WebUI.WebGrid Namespace : LayoutEventArgs Class

Glossary Item Box

The following tables list the members exposed by LayoutEventArgs.

Public Properties

 | Name | Description
Public Property | Layout |
Public Property | ReturnValue | (Inherited from ISNet.WebUI.WebGrid.BaseEventArgs)
Top

See Also

Reference

LayoutEventArgs Class
ISNet.WebUI.WebGrid Namespace


LayoutEventArgs Class Properties

[image]
Intersoft WebGrid Documentation
LayoutEventArgs Class Properties
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : LayoutEventArgs Class

Glossary Item Box

For a list of all members of this type, see LayoutEventArgs members.

Public Properties

 | Name | Description
Public Property | Layout |
Public Property | ReturnValue | (Inherited from ISNet.WebUI.WebGrid.BaseEventArgs)
Top

See Also

Reference

LayoutEventArgs Class
ISNet.WebUI.WebGrid Namespace


Layout Property

[image]
Intersoft WebGrid Documentation
Layout Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > LayoutEventArgs Class : Layout Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Layout As LayoutSet
Visual Basic (Usage) Copy Code
Dim instance As LayoutEventArgs
Dim value As LayoutSet

value = instance.Layout
C#
public LayoutSet Layout {get;}
Delphi
public read-only property Layout: LayoutSet;
JScript
public function get Layout : LayoutSet
Managed Extensions for C++
public: __property LayoutSet* get_Layout();
C++/CLI
public:
property LayoutSet^ Layout {
   LayoutSet^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayoutEventArgs Class
LayoutEventArgs Members


LayoutSet Class

[image]
Intersoft WebGrid Documentation
LayoutSet Class
Members See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : LayoutSet Class

Glossary Item Box

Object Model

LayoutSet Class

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.SerializableAttribute()>
Public Class LayoutSet
   Inherits ISNet.WebUI.WebUIBaseClass
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.Serialization.XmlSerialization.ICustomXmlSerializer
Visual Basic (Usage) Copy Code
Dim instance As LayoutSet
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public class LayoutSet : ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.Serialization.XmlSerialization.ICustomXmlSerializer
Delphi
public class LayoutSet = class(ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.Serialization.XmlSerialization.ICustomXmlSerializer)
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.SerializableAttribute()
public class LayoutSet extends ISNet.WebUI.WebUIBaseClass implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.Serialization.XmlSerialization.ICustomXmlSerializer
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public __gc class LayoutSet : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.Serialization.XmlSerialization.ICustomXmlSerializer
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public ref class LayoutSet : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.Serialization.XmlSerialization.ICustomXmlSerializer

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.WebGrid.LayoutSet

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayoutSet Members
ISNet.WebUI.WebGrid Namespace


LayoutSet Class Members

[image]
Intersoft WebGrid Documentation
LayoutSet Class Members
See Also Fields Properties Methods Send Feedback
ISNet.WebUI.WebGrid Namespace : LayoutSet Class

Glossary Item Box

The following tables list the members exposed by LayoutSet.

Public Constructors

 | Name | Description
Public Constructor | LayoutSet Constructor |
Top

Public Fields

 | Name | Description
Public Field | IsInitialized |
Top

Public Properties

 | Name | Description
Public Property | AddedRowStyle |
Public Property | AllowAddNew |
Public Property | AllowBatchUpdate |
Public Property | AllowColumnFreezing |
Public Property | AllowColumnMove |
Public Property | AllowColumnSizing |
Public Property | AllowContextMenu |
Public Property | AllowDefaultStyleMerging |
Public Property | AllowDelete |
Public Property | AllowEdit |
Public Property | AllowExport |
Public Property | AllowFilter |
Public Property | AllowGrouping |
Public Property | AllowMultipleSelection |
Public Property | AllowPrint |
Public Property | AllowSelectColumns |
Public Property | AllowSorting |
Public Property | AlternatingColors |
Public Property | AlternatingRowStyle |
Public Property | AlwaysShowHelpButton |
Public Property | AlwaysUseCachedDataOnFirstLoad |
Public Property | ApplyChangesKey |
Public Property | ApplyFiltersKey |
Public Property | AutoColMinWidth |
Public Property | AutoFilterSuggestion |
Public Property | AutoFitColumns |
Public Property | AutoFitColumnsBuffering |
Public Property | AutoHeight |
Public Property | AutoWidth |
Public Property | BatchUpdateSettings |
Public Property | ButtonStyle |
Public Property | CellClickAction |
Public Property | CellPaddingDefault |
Public Property | CellSpacingDefault |
Public Property | ChartCustomContainerId |
Public Property | ChartDisplayPosition |
Public Property | CheckedRowStyle |
Public Property | ChildRowEmptyAction |
Public Property | ChildTableSpacing |
Public Property | ClientSideEvents |
Public Property | ClientVisible |
Public Property | ColumnActionStyle |
Public Property | ColumnFooterAggregateMode |
Public Property | ColumnFooters |
Public Property | ColumnHeaders |
Public Property | ColumnSetHeaders |
Public Property | ContextMenuAnimation |
Public Property | Culture |
Public Property | CustomFilterString |
Public Property | DeletedRowStyle |
Public Property | DisplayDetailsOnUnhandledError |
Public Property | EditFocusCellStyle |
Public Property | EditOnClick |
Public Property | EditTextboxStyle |
Public Property | FilterBarVisible |
Public Property | FilterRowStyle |
Public Property | FocusCellStyle |
Public Property | FocusNewRowOnLastCell |
Public Property | FooterStyle |
Public Property | FrameStyle |
Public Property | FreezePaneSettings |
Public Property | GridLineColor |
Public Property | GridLines |
Public Property | GridLineStyle |
Public Property | GroupByBox |
Public Property | GroupByBoxVisible |
Public Property | GroupRowInfoFormatDefault |
Public Property | GroupRowInfoStyle |
Public Property | HeaderClickAction |
Public Property | HeaderStyle |
Public Property | HeaderWrapDefault |
Public Property | HelpURL |
Public Property | HideColumnsWhenGrouped |
Public Property | Hierarchical |
Public Property | HierarchicalMode |
Public Property | HyperlinkStyle |
Public Property | ImageSettings |
Public Property | InitialView |
Public Property | InProgressUIBehavior |
Public Property | LostFocusRowStyle |
Public Property | MarkDefaultValuesAsDirty |
Public Property | MenuCssFile |
Public Property | ModifiedRowStyle |
Public Property | NewRowLostFocusAction |
Public Property | NewRowStyle |
Public Property | PagingDataRetrievalMode |
Public Property | PagingDetectPartialGroupRows |
Public Property | PagingExportMode |
Public Property | PagingLatencyOnSlide |
Public Property | PagingLoadMode |
Public Property | PagingMode |
Public Property | PagingSize |
Public Property | PagingSliderWidth |
Public Property | PagingStyleUI |
Public Property | PersistRowChecker |
Public Property | PersistValueListOnCopy |
Public Property | PreviewRowStyle |
Public Property | PromptBeforeDelete |
Public Property | QuickFilterBarStyle |
Public Property | ResetNewRowValuesOnError |
Public Property | RestoreExpandedChildRows |
Public Property | RestoreRowSelection |
Public Property | RowChangedAction |
Public Property | RowHeaders |
Public Property | RowHeaderStyle |
Public Property | RowHeaderWidth |
Public Property | RowHeightDefault |
Public Property | RowHighlightType |
Public Property | RowLostFocusAction |
Public Property | RowStyle |
Public Property | ScriptDirectory |
Public Property | ScrollBarStyle |
Public Property | SelectedRowStyle |
Public Property | SelectFirstCellOnAdd |
Public Property | ShowColumnAction |
Public Property | ShowFilterStatus |
Public Property | ShowRefreshButton |
Public Property | SizeHeightBy |
Public Property | SizeWidthBy |
Public Property | SortedColumnStyle |
Public Property | StatusBarCommandStyle |
Public Property | StatusBarStyle |
Public Property | StatusBarVisible |
Public Property | TextSettings |
Public Property | TreeLines |
Public Property | UseRelativePositioning |
Public Property | VerboseEditingInformation |
Public Property | VirtualLoadMode |
Public Property | VirtualPageSize |
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CustomDeserialize |
Public Method | CustomSerialize |
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | GetWebGridCulture |
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString |
Top

See Also

Reference

LayoutSet Class
ISNet.WebUI.WebGrid Namespace


LayoutSet Constructor

[image]
Intersoft WebGrid Documentation
LayoutSet Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > LayoutSet Class : LayoutSet Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New LayoutSet()
C#
public LayoutSet()
Delphi
public LayoutSet();
JScript
public function LayoutSet();
Managed Extensions for C++
public: LayoutSet();
C++/CLI
public:
LayoutSet();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayoutSet Class
LayoutSet Members


Clone Method

[image]
Intersoft WebGrid Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > LayoutSet Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As System.Object
Visual Basic (Usage) Copy Code
Dim instance As LayoutSet
Dim value As System.Object

value = instance.Clone()
C#
public virtual System.object Clone()
Delphi
public function Clone(): System.TObject; virtual;
JScript
public function Clone() : System.Object;
Managed Extensions for C++
public: virtual System.Object* Clone();
C++/CLI
public:
virtual System.Object^ Clone();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayoutSet Class
LayoutSet Members


CopyFrom Method

[image]
Intersoft WebGrid Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > LayoutSet Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayoutSet Class
LayoutSet Members


CopyFrom(Object) Method

[image]
Intersoft WebGrid Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > LayoutSet Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As LayoutSet
Dim objSource As System.Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   System.object objSource
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayoutSet Class
LayoutSet Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebGrid Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > LayoutSet Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object, _
   ByVal cloneSourceValue As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As LayoutSet
Dim objSource As System.Object
Dim cloneSourceValue As System.Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   System.object objSource,
   System.bool cloneSourceValue
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject;
    cloneSourceValue: System.Boolean
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object,
   cloneSourceValue : System.boolean
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource,
   System.bool cloneSourceValue
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource,
   System.bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayoutSet Class
LayoutSet Members
Overload List


LayoutSet Class Methods

[image]
Intersoft WebGrid Documentation
LayoutSet Class Methods
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : LayoutSet Class

Glossary Item Box

For a list of all members of this type, see LayoutSet members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CustomDeserialize |
Public Method | CustomSerialize |
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | GetWebGridCulture |
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString |
Top

See Also

Reference

LayoutSet Class
ISNet.WebUI.WebGrid Namespace


CustomDeserialize Method

[image]
Intersoft WebGrid Documentation
CustomDeserialize Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > LayoutSet Class : CustomDeserialize Method

mi
currentObj
parentNode
currentNode

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub CustomDeserialize( _
   ByVal mi As System.Reflection.MemberInfo, _
   ByVal currentObj As System.Object, _
   ByVal parentNode As System.Xml.XmlNode, _
   ByVal currentNode As System.Xml.XmlNode _
)
Visual Basic (Usage) Copy Code
Dim instance As LayoutSet
Dim mi As System.Reflection.MemberInfo
Dim currentObj As System.Object
Dim parentNode As System.Xml.XmlNode
Dim currentNode As System.Xml.XmlNode

instance.CustomDeserialize(mi, currentObj, parentNode, currentNode)
C#
public void CustomDeserialize(
   System.Reflection.MemberInfo mi,
   System.object currentObj,
   System.Xml.XmlNode parentNode,
   System.Xml.XmlNode currentNode
)
Delphi
public procedure CustomDeserialize(
    mi: System.Reflection.MemberInfo;
    currentObj: System.TObject;
    parentNode: System.Xml.XmlNode;
    currentNode: System.Xml.XmlNode
);
JScript
public function CustomDeserialize(
   mi : System.Reflection.MemberInfo,
   currentObj : System.Object,
   parentNode : System.Xml.XmlNode,
   currentNode : System.Xml.XmlNode
);
Managed Extensions for C++
public: void CustomDeserialize(
   System.Reflection.MemberInfo* mi,
   System.Object* currentObj,
   System.Xml.XmlNode* parentNode,
   System.Xml.XmlNode* currentNode
)
C++/CLI
public:
void CustomDeserialize(
   System.Reflection.MemberInfo^ mi,
   System.Object^ currentObj,
   System.Xml.XmlNode^ parentNode,
   System.Xml.XmlNode^ currentNode
)

Parameters

mi
currentObj
parentNode
currentNode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayoutSet Class
LayoutSet Members


CustomSerialize Method

[image]
Intersoft WebGrid Documentation
CustomSerialize Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > LayoutSet Class : CustomSerialize Method

x
node

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub CustomSerialize( _
   ByVal x As System.Xml.XmlDocument, _
   ByVal node As System.Xml.XmlNode _
)
Visual Basic (Usage) Copy Code
Dim instance As LayoutSet
Dim x As System.Xml.XmlDocument
Dim node As System.Xml.XmlNode

instance.CustomSerialize(x, node)
C#
public void CustomSerialize(
   System.Xml.XmlDocument x,
   System.Xml.XmlNode node
)
Delphi
public procedure CustomSerialize(
    x: System.Xml.XmlDocument;
    node: System.Xml.XmlNode
);
JScript
public function CustomSerialize(
   x : System.Xml.XmlDocument,
   node : System.Xml.XmlNode
);
Managed Extensions for C++
public: void CustomSerialize(
   System.Xml.XmlDocument* x,
   System.Xml.XmlNode* node
)
C++/CLI
public:
void CustomSerialize(
   System.Xml.XmlDocument^ x,
   System.Xml.XmlNode^ node
)

Parameters

x
node

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayoutSet Class
LayoutSet Members


DeSerializeObjectData Method

[image]
Intersoft WebGrid Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > LayoutSet Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As LayoutSet
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure DeSerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function DeSerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void DeSerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void DeSerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayoutSet Class
LayoutSet Members


GetHashCode Method

[image]
Intersoft WebGrid Documentation
GetHashCode Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > LayoutSet Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As LayoutSet
Dim value As System.Integer

value = instance.GetHashCode()
C#
public virtual System.int GetHashCode()
Delphi
public function GetHashCode(): System.Integer; virtual;
JScript
public function GetHashCode() : System.int;
Managed Extensions for C++
public: virtual System.int GetHashCode();
C++/CLI
public:
virtual System.int GetHashCode();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayoutSet Class
LayoutSet Members


GetObjectData Method

[image]
Intersoft WebGrid Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > LayoutSet Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As LayoutSet
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure GetObjectData(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
); override;
JScript
public override function GetObjectData(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void GetObjectData(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
) override
C++/CLI
public:
void GetObjectData(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
) override

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayoutSet Class
LayoutSet Members


GetWebGridCulture Method

[image]
Intersoft WebGrid Documentation
GetWebGridCulture Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > LayoutSet Class : GetWebGridCulture Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetWebGridCulture() As System.Globalization.CultureInfo
Visual Basic (Usage) Copy Code
Dim instance As LayoutSet
Dim value As System.Globalization.CultureInfo

value = instance.GetWebGridCulture()
C#
public System.Globalization.CultureInfo GetWebGridCulture()
Delphi
public function GetWebGridCulture(): System.Globalization.CultureInfo;
JScript
public function GetWebGridCulture() : System.Globalization.CultureInfo;
Managed Extensions for C++
public: System.Globalization.CultureInfo* GetWebGridCulture();
C++/CLI
public:
System.Globalization.CultureInfo^ GetWebGridCulture();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayoutSet Class
LayoutSet Members


IsEmpty Method

[image]
Intersoft WebGrid Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > LayoutSet Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As LayoutSet
Dim value As System.Boolean

value = instance.IsEmpty()
C#
public virtual System.bool IsEmpty()
Delphi
public function IsEmpty(): System.Boolean; virtual;
JScript
public function IsEmpty() : System.boolean;
Managed Extensions for C++
public: virtual System.bool IsEmpty();
C++/CLI
public:
virtual System.bool IsEmpty();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayoutSet Class
LayoutSet Members


Reset Method

[image]
Intersoft WebGrid Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > LayoutSet Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As LayoutSet

instance.Reset()
C#
public virtual void Reset()
Delphi
public procedure Reset(); virtual;
JScript
public function Reset();
Managed Extensions for C++
public: virtual void Reset();
C++/CLI
public:
virtual void Reset();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayoutSet Class
LayoutSet Members


SerializeObjectData Method

[image]
Intersoft WebGrid Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > LayoutSet Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As LayoutSet
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure SerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function SerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void SerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void SerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayoutSet Class
LayoutSet Members


ToString Method

[image]
Intersoft WebGrid Documentation
ToString Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > LayoutSet Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString() As System.String
Visual Basic (Usage) Copy Code
Dim instance As LayoutSet
Dim value As System.String

value = instance.ToString()
C#
public override System.string ToString()
Delphi
public function ToString(): System.String; override;
JScript
public override function ToString() : System.String;
Managed Extensions for C++
public: System.string* ToString(); override
C++/CLI
public:
System.String^ ToString(); override

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayoutSet Class
LayoutSet Members


LayoutSet Class Properties

[image]
Intersoft WebGrid Documentation
LayoutSet Class Properties
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : LayoutSet Class

Glossary Item Box

For a list of all members of this type, see LayoutSet members.

Public Properties

 | Name | Description
Public Property | AddedRowStyle |
Public Property | AllowAddNew |
Public Property | AllowBatchUpdate |
Public Property | AllowColumnFreezing |
Public Property | AllowColumnMove |
Public Property | AllowColumnSizing |
Public Property | AllowContextMenu |
Public Property | AllowDefaultStyleMerging |
Public Property | AllowDelete |
Public Property | AllowEdit |
Public Property | AllowExport |
Public Property | AllowFilter |
Public Property | AllowGrouping |
Public Property | AllowMultipleSelection |
Public Property | AllowPrint |
Public Property | AllowSelectColumns |
Public Property | AllowSorting |
Public Property | AlternatingColors |
Public Property | AlternatingRowStyle |
Public Property | AlwaysShowHelpButton |
Public Property | AlwaysUseCachedDataOnFirstLoad |
Public Property | ApplyChangesKey |
Public Property | ApplyFiltersKey |
Public Property | AutoColMinWidth |
Public Property | AutoFilterSuggestion |
Public Property | AutoFitColumns |
Public Property | AutoFitColumnsBuffering |
Public Property | AutoHeight |
Public Property | AutoWidth |
Public Property | BatchUpdateSettings |
Public Property | ButtonStyle |
Public Property | CellClickAction |
Public Property | CellPaddingDefault |
Public Property | CellSpacingDefault |
Public Property | ChartCustomContainerId |
Public Property | ChartDisplayPosition |
Public Property | CheckedRowStyle |
Public Property | ChildRowEmptyAction |
Public Property | ChildTableSpacing |
Public Property | ClientSideEvents |
Public Property | ClientVisible |
Public Property | ColumnActionStyle |
Public Property | ColumnFooterAggregateMode |
Public Property | ColumnFooters |
Public Property | ColumnHeaders |
Public Property | ColumnSetHeaders |
Public Property | ContextMenuAnimation |
Public Property | Culture |
Public Property | CustomFilterString |
Public Property | DeletedRowStyle |
Public Property | DisplayDetailsOnUnhandledError |
Public Property | EditFocusCellStyle |
Public Property | EditOnClick |
Public Property | EditTextboxStyle |
Public Property | FilterBarVisible |
Public Property | FilterRowStyle |
Public Property | FocusCellStyle |
Public Property | FocusNewRowOnLastCell |
Public Property | FooterStyle |
Public Property | FrameStyle |
Public Property | FreezePaneSettings |
Public Property | GridLineColor |
Public Property | GridLines |
Public Property | GridLineStyle |
Public Property | GroupByBox |
Public Property | GroupByBoxVisible |
Public Property | GroupRowInfoFormatDefault |
Public Property | GroupRowInfoStyle |
Public Property | HeaderClickAction |
Public Property | HeaderStyle |
Public Property | HeaderWrapDefault |
Public Property | HelpURL |
Public Property | HideColumnsWhenGrouped |
Public Property | Hierarchical |
Public Property | HierarchicalMode |
Public Property | HyperlinkStyle |
Public Property | ImageSettings |
Public Property | InitialView |
Public Property | InProgressUIBehavior |
Public Property | LostFocusRowStyle |
Public Property | MarkDefaultValuesAsDirty |
Public Property | MenuCssFile |
Public Property | ModifiedRowStyle |
Public Property | NewRowLostFocusAction |
Public Property | NewRowStyle |
Public Property | PagingDataRetrievalMode |
Public Property | PagingDetectPartialGroupRows |
Public Property | PagingExportMode |
Public Property | PagingLatencyOnSlide |
Public Property | PagingLoadMode |
Public Property | PagingMode |
Public Property | PagingSize |
Public Property | PagingSliderWidth |
Public Property | PagingStyleUI |
Public Property | PersistRowChecker |
Public Property | PersistValueListOnCopy |
Public Property | PreviewRowStyle |
Public Property | PromptBeforeDelete |
Public Property | QuickFilterBarStyle |
Public Property | ResetNewRowValuesOnError |
Public Property | RestoreExpandedChildRows |
Public Property | RestoreRowSelection |
Public Property | RowChangedAction |
Public Property | RowHeaders |
Public Property | RowHeaderStyle |
Public Property | RowHeaderWidth |
Public Property | RowHeightDefault |
Public Property | RowHighlightType |
Public Property | RowLostFocusAction |
Public Property | RowStyle |
Public Property | ScriptDirectory |
Public Property | ScrollBarStyle |
Public Property | SelectedRowStyle |
Public Property | SelectFirstCellOnAdd |
Public Property | ShowColumnAction |
Public Property | ShowFilterStatus |
Public Property | ShowRefreshButton |
Public Property | SizeHeightBy |
Public Property | SizeWidthBy |
Public Property | SortedColumnStyle |
Public Property | StatusBarCommandStyle |
Public Property | StatusBarStyle |
Public Property | StatusBarVisible |
Public Property | TextSettings |
Public Property | TreeLines |
Public Property | UseRelativePositioning |
Public Property | VerboseEditingInformation |
Public Property | VirtualLoadMode |
Public Property | VirtualPageSize |
Top

See Also

Reference

LayoutSet Class
ISNet.WebUI.WebGrid Namespace


LayoutSet Constructor

[image]
Intersoft WebGrid Documentation
LayoutSet Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > LayoutSet Class : LayoutSet Constructor

Glossary Item Box

Overload List

Overload | Description
LayoutSet Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayoutSet Class
LayoutSet Members


AddedRowStyle Property

[image]
Intersoft WebGrid Documentation
AddedRowStyle Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > LayoutSet Class : AddedRowStyle Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("The style applied to added row in batch update mode.")>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
Public Property AddedRowStyle As WebGridFormatStyle
Visual Basic (Usage) Copy Code
Dim instance As LayoutSet
Dim value As WebGridFormatStyle

instance.AddedRowStyle = value

value = instance.AddedRowStyle
C#
[System.ComponentModel.DescriptionAttribute("The style applied to added row in batch update mode.")]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
public WebGridFormatStyle AddedRowStyle {get; set;}
Delphi
public read-write property AddedRowStyle: WebGridFormatStyle;
JScript
System.ComponentModel.DescriptionAttribute("The style applied to added row in batch update mode.")
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
public function get,set AddedRowStyle : WebGridFormatStyle
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("The style applied to added row in batch update mode.")]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
public: __property WebGridFormatStyle* get_AddedRowStyle();
public: __property void set_AddedRowStyle(
   WebGridFormatStyle* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("The style applied to added row in batch update mode.")]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
public:
property WebGridFormatStyle^ AddedRowStyle {
   WebGridFormatStyle^ get();
   void set (    WebGridFormatStyle^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayoutSet Class
LayoutSet Members


AllowAddNew Property

[image]
Intersoft WebGrid Documentation
AllowAddNew Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > LayoutSet Class : AllowAddNew Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Editing")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies whether or not to allow users add new row.")>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property AllowAddNew As AddNew
Visual Basic (Usage) Copy Code
Dim instance As LayoutSet
Dim value As AddNew

instance.AllowAddNew = value

value = instance.AllowAddNew
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Editing")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether or not to allow users add new row.")]
[ISNet.Serialization.BinarySerializableAttribute()]
public AddNew AllowAddNew {get; set;}
Delphi
public read-write property AllowAddNew: AddNew;
JScript
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.CategoryAttribute("Editing")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Specifies whether or not to allow users add new row.")
ISNet.Serialization.BinarySerializableAttribute()
public function get,set AllowAddNew : AddNew
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Editing")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether or not to allow users add new row.")]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property AddNew get_AllowAddNew();
public: __property void set_AllowAddNew(
   AddNew value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Editing")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether or not to allow users add new row.")]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property AddNew AllowAddNew {
   AddNew get();
   void set (    AddNew value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayoutSet Class
LayoutSet Members


AllowBatchUpdate Property

[image]
Intersoft WebGrid Documentation
AllowBatchUpdate Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > LayoutSet Class : AllowBatchUpdate Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Editing")>
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies whether or not to allow users to perform multiple (batch) client side editing.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
Public Property AllowBatchUpdate As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As LayoutSet
Dim value As System.Boolean

instance.AllowBatchUpdate = value

value = instance.AllowBatchUpdate
C#
[System.ComponentModel.CategoryAttribute("Editing")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether or not to allow users to perform multiple (batch) client side editing.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public System.bool AllowBatchUpdate {get; set;}
Delphi
public read-write property AllowBatchUpdate: System.Boolean;
JScript
System.ComponentModel.CategoryAttribute("Editing")
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DescriptionAttribute("Specifies whether or not to allow users to perform multiple (batch) client side editing.")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
public function get,set AllowBatchUpdate : System.boolean
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Editing")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether or not to allow users to perform multiple (batch) client side editing.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.bool get_AllowBatchUpdate();
public: __property void set_AllowBatchUpdate(
   System.bool value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Editing")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether or not to allow users to perform multiple (batch) client side editing.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.bool AllowBatchUpdate {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayoutSet Class
LayoutSet Members


AllowColumnFreezing Property

[image]
Intersoft WebGrid Documentation
AllowColumnFreezing Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > LayoutSet Class : AllowColumnFreezing Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Behaviors")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies whether the user is allowed to freeze column at runtime.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property AllowColumnFreezing As ColumnFreezing
Visual Basic (Usage) Copy Code
Dim instance As LayoutSet
Dim value As ColumnFreezing

instance.AllowColumnFreezing = value

value = instance.AllowColumnFreezing
C#
[System.ComponentModel.CategoryAttribute("Behaviors")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether the user is allowed to freeze column at runtime.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public ColumnFreezing AllowColumnFreezing {get; set;}
Delphi
public read-write property AllowColumnFreezing: ColumnFreezing;
JScript
System.ComponentModel.CategoryAttribute("Behaviors")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Specifies whether the user is allowed to freeze column at runtime.")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get,set AllowColumnFreezing : ColumnFreezing
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Behaviors")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether the user is allowed to freeze column at runtime.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property ColumnFreezing get_AllowColumnFreezing();
public: __property void set_AllowColumnFreezing(
   ColumnFreezing value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Behaviors")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether the user is allowed to freeze column at runtime.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property ColumnFreezing AllowColumnFreezing {
   ColumnFreezing get();
   void set (    ColumnFreezing value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayoutSet Class
LayoutSet Members


AllowColumnMove Property

[image]
Intersoft WebGrid Documentation
AllowColumnMove Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > LayoutSet Class : AllowColumnMove Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies whether or not to allow users move columns.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("Behaviors")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property AllowColumnMove As ColumnMove
Visual Basic (Usage) Copy Code
Dim instance As LayoutSet
Dim value As ColumnMove

instance.AllowColumnMove = value

value = instance.AllowColumnMove
C#
[System.ComponentModel.DescriptionAttribute("Specifies whether or not to allow users move columns.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Behaviors")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public ColumnMove AllowColumnMove {get; set;}
Delphi
public read-write property AllowColumnMove: ColumnMove;
JScript
System.ComponentModel.DescriptionAttribute("Specifies whether or not to allow users move columns.")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("Behaviors")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get,set AllowColumnMove : ColumnMove
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies whether or not to allow users move columns.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Behaviors")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property ColumnMove get_AllowColumnMove();
public: __property void set_AllowColumnMove(
   ColumnMove value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies whether or not to allow users move columns.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Behaviors")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property ColumnMove AllowColumnMove {
   ColumnMove get();
   void set (    ColumnMove value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayoutSet Class
LayoutSet Members


AllowColumnSizing Property

[image]
Intersoft WebGrid Documentation
AllowColumnSizing Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > LayoutSet Class : AllowColumnSizing Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Behaviors")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies whether or not to allow users resize column's width.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property AllowColumnSizing As ColumnSizing
Visual Basic (Usage) Copy Code
Dim instance As LayoutSet
Dim value As ColumnSizing

instance.AllowColumnSizing = value

value = instance.AllowColumnSizing
C#
[System.ComponentModel.CategoryAttribute("Behaviors")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether or not to allow users resize column's width.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public ColumnSizing AllowColumnSizing {get; set;}
Delphi
public read-write property AllowColumnSizing: ColumnSizing;
JScript
System.ComponentModel.CategoryAttribute("Behaviors")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Specifies whether or not to allow users resize column's width.")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get,set AllowColumnSizing : ColumnSizing
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Behaviors")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether or not to allow users resize column's width.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property ColumnSizing get_AllowColumnSizing();
public: __property void set_AllowColumnSizing(
   ColumnSizing value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Behaviors")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether or not to allow users resize column's width.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property ColumnSizing AllowColumnSizing {
   ColumnSizing get();
   void set (    ColumnSizing value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayoutSet Class
LayoutSet Members


AllowContextMenu Property

[image]
Intersoft WebGrid Documentation
AllowContextMenu Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > LayoutSet Class : AllowContextMenu Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("Behaviors")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Gets or sets a value whether WebGrid's context menu is displayed when right clicked to valid object.")>
Public Property AllowContextMenu As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As LayoutSet
Dim value As System.Boolean

instance.AllowContextMenu = value

value = instance.AllowContextMenu
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Behaviors")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets a value whether WebGrid's context menu is displayed when right clicked to valid object.")]
public System.bool AllowContextMenu {get; set;}
Delphi
public read-write property AllowContextMenu: System.Boolean;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("Behaviors")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets a value whether WebGrid's context menu is displayed when right clicked to valid object.")
public function get,set AllowContextMenu : System.boolean
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Behaviors")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets a value whether WebGrid's context menu is displayed when right clicked to valid object.")]
public: __property System.bool get_AllowContextMenu();
public: __property void set_AllowContextMenu(
   System.bool value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Behaviors")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets a value whether WebGrid's context menu is displayed when right clicked to valid object.")]
public:
property System.bool AllowContextMenu {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayoutSet Class
LayoutSet Members


AllowDefaultStyleMerging Property

[image]
Intersoft WebGrid Documentation
AllowDefaultStyleMerging Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > LayoutSet Class : AllowDefaultStyleMerging Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies whether the default styles should be merged with user defined styles.")>
<System.ComponentModel.CategoryAttribute("Behaviors")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property AllowDefaultStyleMerging As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As LayoutSet
Dim value As System.Boolean

instance.AllowDefaultStyleMerging = value

value = instance.AllowDefaultStyleMerging
C#
[System.ComponentModel.DescriptionAttribute("Specifies whether the default styles should be merged with user defined styles.")]
[System.ComponentModel.CategoryAttribute("Behaviors")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public System.bool AllowDefaultStyleMerging {get; set;}
Delphi
public read-write property AllowDefaultStyleMerging: System.Boolean;
JScript
System.ComponentModel.DescriptionAttribute("Specifies whether the default styles should be merged with user defined styles.")
System.ComponentModel.CategoryAttribute("Behaviors")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get,set AllowDefaultStyleMerging : System.boolean
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies whether the default styles should be merged with user defined styles.")]
[System.ComponentModel.CategoryAttribute("Behaviors")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.bool get_AllowDefaultStyleMerging();
public: __property void set_AllowDefaultStyleMerging(
   System.bool value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies whether the default styles should be merged with user defined styles.")]
[System.ComponentModel.CategoryAttribute("Behaviors")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.bool AllowDefaultStyleMerging {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayoutSet Class
LayoutSet Members


AllowDelete Property

[image]
Intersoft WebGrid Documentation
AllowDelete Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > LayoutSet Class : AllowDelete Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Editing")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies whether or not to allow users delete data from within WebGrid.")>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Property AllowDelete As Delete
Visual Basic (Usage) Copy Code
Dim instance As LayoutSet
Dim value As Delete

instance.AllowDelete = value

value = instance.AllowDelete
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Editing")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether or not to allow users delete data from within WebGrid.")]
[ISNet.Serialization.XmlSerializableAttribute()]
public Delete AllowDelete {get; set;}
Delphi
public read-write property AllowDelete: Delete;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Editing")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Specifies whether or not to allow users delete data from within WebGrid.")
ISNet.Serialization.XmlSerializableAttribute()
public function get,set AllowDelete : Delete
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Editing")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether or not to allow users delete data from within WebGrid.")]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property Delete get_AllowDelete();
public: __property void set_AllowDelete(
   Delete value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Editing")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether or not to allow users delete data from within WebGrid.")]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property Delete AllowDelete {
   Delete get();
   void set (    Delete value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayoutSet Class
LayoutSet Members


AllowEdit Property

[image]
Intersoft WebGrid Documentation
AllowEdit Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > LayoutSet Class : AllowEdit Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Editing")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies whether or not to allow users edit and modify data.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property AllowEdit As Edit
Visual Basic (Usage) Copy Code
Dim instance As LayoutSet
Dim value As Edit

instance.AllowEdit = value

value = instance.AllowEdit
C#
[System.ComponentModel.CategoryAttribute("Editing")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether or not to allow users edit and modify data.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public Edit AllowEdit {get; set;}
Delphi
public read-write property AllowEdit: Edit;
JScript
System.ComponentModel.CategoryAttribute("Editing")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Specifies whether or not to allow users edit and modify data.")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get,set AllowEdit : Edit
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Editing")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether or not to allow users edit and modify data.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property Edit get_AllowEdit();
public: __property void set_AllowEdit(
   Edit value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Editing")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether or not to allow users edit and modify data.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property Edit AllowEdit {
   Edit get();
   void set (    Edit value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayoutSet Class
LayoutSet Members


AllowExport Property

[image]
Intersoft WebGrid Documentation
AllowExport Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > LayoutSet Class : AllowExport Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Data")>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Specifies a value whether grid export is allowed in UI.")>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Property AllowExport As Export
Visual Basic (Usage) Copy Code
Dim instance As LayoutSet
Dim value As Export

instance.AllowExport = value

value = instance.AllowExport
C#
[System.ComponentModel.CategoryAttribute("Data")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies a value whether grid export is allowed in UI.")]
[ISNet.Serialization.XmlSerializableAttribute()]
public Export AllowExport {get; set;}
Delphi
public read-write property AllowExport: Export;
JScript
System.ComponentModel.CategoryAttribute("Data")
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Specifies a value whether grid export is allowed in UI.")
ISNet.Serialization.XmlSerializableAttribute()
public function get,set AllowExport : Export
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Data")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies a value whether grid export is allowed in UI.")]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property Export get_AllowExport();
public: __property void set_AllowExport(
   Export value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Data")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies a value whether grid export is allowed in UI.")]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property Export AllowExport {
   Export get();
   void set (    Export value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayoutSet Class
LayoutSet Members


AllowFilter Property

[image]
Intersoft WebGrid Documentation
AllowFilter Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > LayoutSet Class : AllowFilter Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Data")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies whether or not to allow users filtering data from within WebGrid.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property AllowFilter As Filter
Visual Basic (Usage) Copy Code
Dim instance As LayoutSet
Dim value As Filter

instance.AllowFilter = value

value = instance.AllowFilter
C#
[System.ComponentModel.CategoryAttribute("Data")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether or not to allow users filtering data from within WebGrid.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public Filter AllowFilter {get; set;}
Delphi
public read-write property AllowFilter: Filter;
JScript
System.ComponentModel.CategoryAttribute("Data")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Specifies whether or not to allow users filtering data from within WebGrid.")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get,set AllowFilter : Filter
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Data")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether or not to allow users filtering data from within WebGrid.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property Filter get_AllowFilter();
public: __property void set_AllowFilter(
   Filter value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Data")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether or not to allow users filtering data from within WebGrid.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property Filter AllowFilter {
   Filter get();
   void set (    Filter value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayoutSet Class
LayoutSet Members


AllowGrouping Property

[image]
Intersoft WebGrid Documentation
AllowGrouping Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > LayoutSet Class : AllowGrouping Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Data")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Specify whether grouping is allowed in client's UI.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property AllowGrouping As Grouping
Visual Basic (Usage) Copy Code
Dim instance As LayoutSet
Dim value As Grouping

instance.AllowGrouping = value

value = instance.AllowGrouping
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Data")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specify whether grouping is allowed in client's UI.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public Grouping AllowGrouping {get; set;}
Delphi
public read-write property AllowGrouping: Grouping;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Data")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Specify whether grouping is allowed in client's UI.")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get,set AllowGrouping : Grouping
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Data")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specify whether grouping is allowed in client's UI.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property Grouping get_AllowGrouping();
public: __property void set_AllowGrouping(
   Grouping value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Data")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specify whether grouping is allowed in client's UI.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property Grouping AllowGrouping {
   Grouping get();
   void set (    Grouping value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayoutSet Class
LayoutSet Members


AllowMultipleSelection Property

[image]
Intersoft WebGrid Documentation
AllowMultipleSelection Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > LayoutSet Class : AllowMultipleSelection Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies whether user is allowed to perform multiple row selection using combination of Ctrl/Shift keys and mouse click.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("Behaviors")>
Public Property AllowMultipleSelection As MultipleSelection
Visual Basic (Usage) Copy Code
Dim instance As LayoutSet
Dim value As MultipleSelection

instance.AllowMultipleSelection = value

value = instance.AllowMultipleSelection
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether user is allowed to perform multiple row selection using combination of Ctrl/Shift keys and mouse click.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Behaviors")]
public MultipleSelection AllowMultipleSelection {get; set;}
Delphi
public read-write property AllowMultipleSelection: MultipleSelection;
JScript
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DescriptionAttribute("Specifies whether user is allowed to perform multiple row selection using combination of Ctrl/Shift keys and mouse click.")
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("Behaviors")
public function get,set AllowMultipleSelection : MultipleSelection
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether user is allowed to perform multiple row selection using combination of Ctrl/Shift keys and mouse click.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Behaviors")]
public: __property MultipleSelection get_AllowMultipleSelection();
public: __property void set_AllowMultipleSelection(
   MultipleSelection value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether user is allowed to perform multiple row selection using combination of Ctrl/Shift keys and mouse click.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Behaviors")]
public:
property MultipleSelection AllowMultipleSelection {
   MultipleSelection get();
   void set (    MultipleSelection value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayoutSet Class
LayoutSet Members


AllowPrint Property

[image]
Intersoft WebGrid Documentation
AllowPrint Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > LayoutSet Class : AllowPrint Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Data")>
<System.ComponentModel.DescriptionAttribute("Specifies a value whether grid print is allowed in UI.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
Public Property AllowPrint As Print
Visual Basic (Usage) Copy Code
Dim instance As LayoutSet
Dim value As Print

instance.AllowPrint = value

value = instance.AllowPrint
C#
[System.ComponentModel.CategoryAttribute("Data")]
[System.ComponentModel.DescriptionAttribute("Specifies a value whether grid print is allowed in UI.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public Print AllowPrint {get; set;}
Delphi
public read-write property AllowPrint: Print;
JScript
System.ComponentModel.CategoryAttribute("Data")
System.ComponentModel.DescriptionAttribute("Specifies a value whether grid print is allowed in UI.")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
public function get,set AllowPrint : Print
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Data")]
[System.ComponentModel.DescriptionAttribute("Specifies a value whether grid print is allowed in UI.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public: __property Print get_AllowPrint();
public: __property void set_AllowPrint(
   Print value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Data")]
[System.ComponentModel.DescriptionAttribute("Specifies a value whether grid print is allowed in UI.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public:
property Print AllowPrint {
   Print get();
   void set (    Print value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayoutSet Class
LayoutSet Members


AllowSelectColumns Property

[image]
Intersoft WebGrid Documentation
AllowSelectColumns Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > LayoutSet Class : AllowSelectColumns Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Behaviors")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies whether or not to allow users select columns from within WebGrid.")>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Property AllowSelectColumns As SelectColumns
Visual Basic (Usage) Copy Code
Dim instance As LayoutSet
Dim value As SelectColumns

instance.AllowSelectColumns = value

value = instance.AllowSelectColumns
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behaviors")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether or not to allow users select columns from within WebGrid.")]
[ISNet.Serialization.XmlSerializableAttribute()]
public SelectColumns AllowSelectColumns {get; set;}
Delphi
public read-write property AllowSelectColumns: SelectColumns;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Behaviors")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Specifies whether or not to allow users select columns from within WebGrid.")
ISNet.Serialization.XmlSerializableAttribute()
public function get,set AllowSelectColumns : SelectColumns
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behaviors")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether or not to allow users select columns from within WebGrid.")]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property SelectColumns get_AllowSelectColumns();
public: __property void set_AllowSelectColumns(
   SelectColumns value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behaviors")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether or not to allow users select columns from within WebGrid.")]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property SelectColumns AllowSelectColumns {
   SelectColumns get();
   void set (    SelectColumns value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayoutSet Class
LayoutSet Members


AllowSorting Property

[image]
Intersoft WebGrid Documentation
AllowSorting Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > LayoutSet Class : AllowSorting Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Data")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies whether or not to allow users sort columns from within WebGrid.")>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Property AllowSorting As Sorting
Visual Basic (Usage) Copy Code
Dim instance As LayoutSet
Dim value As Sorting

instance.AllowSorting = value

value = instance.AllowSorting
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Data")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether or not to allow users sort columns from within WebGrid.")]
[ISNet.Serialization.XmlSerializableAttribute()]
public Sorting AllowSorting {get; set;}
Delphi
public read-write property AllowSorting: Sorting;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Data")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Specifies whether or not to allow users sort columns from within WebGrid.")
ISNet.Serialization.XmlSerializableAttribute()
public function get,set AllowSorting : Sorting
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Data")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether or not to allow users sort columns from within WebGrid.")]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property Sorting get_AllowSorting();
public: __property void set_AllowSorting(
   Sorting value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Data")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether or not to allow users sort columns from within WebGrid.")]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property Sorting AllowSorting {
   Sorting get();
   void set (    Sorting value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayoutSet Class
LayoutSet Members


AlternatingColors Property

[image]
Intersoft WebGrid Documentation
AlternatingColors Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > LayoutSet Class : AlternatingColors Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Behaviors")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies whether or not to display alternate rows with AlternateRowStyle style.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.MarkAsStyleAttribute(True)>
Public Property AlternatingColors As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As LayoutSet
Dim value As System.Boolean

instance.AlternatingColors = value

value = instance.AlternatingColors
C#
[System.ComponentModel.CategoryAttribute("Behaviors")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether or not to display alternate rows with AlternateRowStyle style.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.MarkAsStyleAttribute(true)]
public System.bool AlternatingColors {get; set;}
Delphi
public read-write property AlternatingColors: System.Boolean;
JScript
System.ComponentModel.CategoryAttribute("Behaviors")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Specifies whether or not to display alternate rows with AlternateRowStyle style.")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
ISNet.MarkAsStyleAttribute()
public function get,set AlternatingColors : System.boolean
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Behaviors")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether or not to display alternate rows with AlternateRowStyle style.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.MarkAsStyleAttribute(true)]
public: __property System.bool get_AlternatingColors();
public: __property void set_AlternatingColors(
   System.bool value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Behaviors")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether or not to display alternate rows with AlternateRowStyle style.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.MarkAsStyleAttribute(true)]
public:
property System.bool AlternatingColors {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayoutSet Class
LayoutSet Members


AlternatingRowStyle Property

[image]
Intersoft WebGrid Documentation
AlternatingRowStyle Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > LayoutSet Class : AlternatingRowStyle Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Gets or sets the style that is used to display altnernate row.")>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property AlternatingRowStyle As WebGridFormatStyle
Visual Basic (Usage) Copy Code
Dim instance As LayoutSet
Dim value As WebGridFormatStyle

instance.AlternatingRowStyle = value

value = instance.AlternatingRowStyle
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the style that is used to display altnernate row.")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.Serialization.BinarySerializableAttribute()]
public WebGridFormatStyle AlternatingRowStyle {get; set;}
Delphi
public read-write property AlternatingRowStyle: WebGridFormatStyle;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the style that is used to display altnernate row.")
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
ISNet.Serialization.BinarySerializableAttribute()
public function get,set AlternatingRowStyle : WebGridFormatStyle
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the style that is used to display altnernate row.")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property WebGridFormatStyle* get_AlternatingRowStyle();
public: __property void set_AlternatingRowStyle(
   WebGridFormatStyle* value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the style that is used to display altnernate row.")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property WebGridFormatStyle^ AlternatingRowStyle {
   WebGridFormatStyle^ get();
   void set (    WebGridFormatStyle^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayoutSet Class
LayoutSet Members


AlwaysShowHelpButton Property

[image]
Intersoft WebGrid Documentation
AlwaysShowHelpButton Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > LayoutSet Class : AlwaysShowHelpButton Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies whether Help button is always shown in WebGrid UI.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Behaviors")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property AlwaysShowHelpButton As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As LayoutSet
Dim value As System.Boolean

instance.AlwaysShowHelpButton = value

value = instance.AlwaysShowHelpButton
C#
[System.ComponentModel.DescriptionAttribute("Specifies whether Help button is always shown in WebGrid UI.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behaviors")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.bool AlwaysShowHelpButton {get; set;}
Delphi
public read-write property AlwaysShowHelpButton: System.Boolean;
JScript
System.ComponentModel.DescriptionAttribute("Specifies whether Help button is always shown in WebGrid UI.")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Behaviors")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set AlwaysShowHelpButton : System.boolean
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies whether Help button is always shown in WebGrid UI.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behaviors")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.bool get_AlwaysShowHelpButton();
public: __property void set_AlwaysShowHelpButton(
   System.bool value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies whether Help button is always shown in WebGrid UI.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behaviors")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.bool AlwaysShowHelpButton {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayoutSet Class
LayoutSet Members


AlwaysUseCachedDataOnFirstLoad Property

[image]
Intersoft WebGrid Documentation
AlwaysUseCachedDataOnFirstLoad Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > LayoutSet Class : AlwaysUseCachedDataOnFirstLoad Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies whether the cached data source will always be used on first page load.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.PersistLayoutAttribute(False)>
<System.ComponentModel.CategoryAttribute("Behaviors")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
Public Property AlwaysUseCachedDataOnFirstLoad As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As LayoutSet
Dim value As System.Boolean

instance.AlwaysUseCachedDataOnFirstLoad = value

value = instance.AlwaysUseCachedDataOnFirstLoad
C#
[System.ComponentModel.DescriptionAttribute("Specifies whether the cached data source will always be used on first page load.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.PersistLayoutAttribute(false)]
[System.ComponentModel.CategoryAttribute("Behaviors")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public System.bool AlwaysUseCachedDataOnFirstLoad {get; set;}
Delphi
public read-write property AlwaysUseCachedDataOnFirstLoad: System.Boolean;
JScript
System.ComponentModel.DescriptionAttribute("Specifies whether the cached data source will always be used on first page load.")
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.PersistLayoutAttribute()
System.ComponentModel.CategoryAttribute("Behaviors")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
public function get,set AlwaysUseCachedDataOnFirstLoad : System.boolean
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies whether the cached data source will always be used on first page load.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.PersistLayoutAttribute(false)]
[System.ComponentModel.CategoryAttribute("Behaviors")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.bool get_AlwaysUseCachedDataOnFirstLoad();
public: __property void set_AlwaysUseCachedDataOnFirstLoad(
   System.bool value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies whether the cached data source will always be used on first page load.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.PersistLayoutAttribute(false)]
[System.ComponentModel.CategoryAttribute("Behaviors")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.bool AlwaysUseCachedDataOnFirstLoad {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayoutSet Class
LayoutSet Members


ApplyChangesKey Property

[image]
Intersoft WebGrid Documentation
ApplyChangesKey Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > LayoutSet Class : ApplyChangesKey Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Gets or sets the key used to apply the row changes during editing")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Behaviors")>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property ApplyChangesKey As EditKeyMode
Visual Basic (Usage) Copy Code
Dim instance As LayoutSet
Dim value As EditKeyMode

instance.ApplyChangesKey = value

value = instance.ApplyChangesKey
C#
[System.ComponentModel.DescriptionAttribute("Gets or sets the key used to apply the row changes during editing")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Behaviors")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public EditKeyMode ApplyChangesKey {get; set;}
Delphi
public read-write property ApplyChangesKey: EditKeyMode;
JScript
System.ComponentModel.DescriptionAttribute("Gets or sets the key used to apply the row changes during editing")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Behaviors")
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get,set ApplyChangesKey : EditKeyMode
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Gets or sets the key used to apply the row changes during editing")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Behaviors")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property EditKeyMode get_ApplyChangesKey();
public: __property void set_ApplyChangesKey(
   EditKeyMode value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Gets or sets the key used to apply the row changes during editing")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Behaviors")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property EditKeyMode ApplyChangesKey {
   EditKeyMode get();
   void set (    EditKeyMode value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayoutSet Class
LayoutSet Members


ApplyFiltersKey Property

[image]
Intersoft WebGrid Documentation
ApplyFiltersKey Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > LayoutSet Class : ApplyFiltersKey Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Gets or sets the key used to apply all filters.")>
<System.ComponentModel.CategoryAttribute("Behaviors")>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property ApplyFiltersKey As FilterKeyMode
Visual Basic (Usage) Copy Code
Dim instance As LayoutSet
Dim value As FilterKeyMode

instance.ApplyFiltersKey = value

value = instance.ApplyFiltersKey
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the key used to apply all filters.")]
[System.ComponentModel.CategoryAttribute("Behaviors")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public FilterKeyMode ApplyFiltersKey {get; set;}
Delphi
public read-write property ApplyFiltersKey: FilterKeyMode;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the key used to apply all filters.")
System.ComponentModel.CategoryAttribute("Behaviors")
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get,set ApplyFiltersKey : FilterKeyMode
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the key used to apply all filters.")]
[System.ComponentModel.CategoryAttribute("Behaviors")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property FilterKeyMode get_ApplyFiltersKey();
public: __property void set_ApplyFiltersKey(
   FilterKeyMode value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the key used to apply all filters.")]
[System.ComponentModel.CategoryAttribute("Behaviors")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property FilterKeyMode ApplyFiltersKey {
   FilterKeyMode get();
   void set (    FilterKeyMode value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayoutSet Class
LayoutSet Members


AutoColMinWidth Property

[image]
Intersoft WebGrid Documentation
AutoColMinWidth Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > LayoutSet Class : AutoColMinWidth Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("The minimum width for WebGridColumn which IsAutoWidth is set to true.")>
<System.ComponentModel.CategoryAttribute("Behaviors")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property AutoColMinWidth As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As LayoutSet
Dim value As System.Integer

instance.AutoColMinWidth = value

value = instance.AutoColMinWidth
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("The minimum width for WebGridColumn which IsAutoWidth is set to true.")]
[System.ComponentModel.CategoryAttribute("Behaviors")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.int AutoColMinWidth {get; set;}
Delphi
public read-write property AutoColMinWidth: System.Integer;
JScript
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DescriptionAttribute("The minimum width for WebGridColumn which IsAutoWidth is set to true.")
System.ComponentModel.CategoryAttribute("Behaviors")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set AutoColMinWidth : System.int
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("The minimum width for WebGridColumn which IsAutoWidth is set to true.")]
[System.ComponentModel.CategoryAttribute("Behaviors")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.int get_AutoColMinWidth();
public: __property void set_AutoColMinWidth(
   System.int value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("The minimum width for WebGridColumn which IsAutoWidth is set to true.")]
[System.ComponentModel.CategoryAttribute("Behaviors")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.int AutoColMinWidth {
   System.int get();
   void set (    System.int value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayoutSet Class
LayoutSet Members


AutoFilterSuggestion Property

[image]
Intersoft WebGrid Documentation
AutoFilterSuggestion Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > LayoutSet Class : AutoFilterSuggestion Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies whether a list of suggested filters based on current selection should be added to the context menu.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Behaviors")>
Public Property AutoFilterSuggestion As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As LayoutSet
Dim value As System.Boolean

instance.AutoFilterSuggestion = value

value = instance.AutoFilterSuggestion
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether a list of suggested filters based on current selection should be added to the context menu.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behaviors")]
public System.bool AutoFilterSuggestion {get; set;}
Delphi
public read-write property AutoFilterSuggestion: System.Boolean;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Specifies whether a list of suggested filters based on current selection should be added to the context menu.")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Behaviors")
public function get,set AutoFilterSuggestion : System.boolean
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether a list of suggested filters based on current selection should be added to the context menu.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behaviors")]
public: __property System.bool get_AutoFilterSuggestion();
public: __property void set_AutoFilterSuggestion(
   System.bool value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether a list of suggested filters based on current selection should be added to the context menu.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behaviors")]
public:
property System.bool AutoFilterSuggestion {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayoutSet Class
LayoutSet Members


AutoFitColumns Property

[image]
Intersoft WebGrid Documentation
AutoFitColumns Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > LayoutSet Class : AutoFitColumns Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Behaviors")>
<System.ComponentModel.DescriptionAttribute("Gets or sets a value indicating whether all displayed columns's width should be fitted to grid.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property AutoFitColumns As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As LayoutSet
Dim value As System.Boolean

instance.AutoFitColumns = value

value = instance.AutoFitColumns
C#
[System.ComponentModel.CategoryAttribute("Behaviors")]
[System.ComponentModel.DescriptionAttribute("Gets or sets a value indicating whether all displayed columns's width should be fitted to grid.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public System.bool AutoFitColumns {get; set;}
Delphi
public read-write property AutoFitColumns: System.Boolean;
JScript
System.ComponentModel.CategoryAttribute("Behaviors")
System.ComponentModel.DescriptionAttribute("Gets or sets a value indicating whether all displayed columns's width should be fitted to grid.")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get,set AutoFitColumns : System.boolean
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Behaviors")]
[System.ComponentModel.DescriptionAttribute("Gets or sets a value indicating whether all displayed columns's width should be fitted to grid.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.bool get_AutoFitColumns();
public: __property void set_AutoFitColumns(
   System.bool value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Behaviors")]
[System.ComponentModel.DescriptionAttribute("Gets or sets a value indicating whether all displayed columns's width should be fitted to grid.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.bool AutoFitColumns {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayoutSet Class
LayoutSet Members


AutoFitColumnsBuffering Property

[image]
Intersoft WebGrid Documentation
AutoFitColumnsBuffering Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > LayoutSet Class : AutoFitColumnsBuffering Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Behaviors")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Gets or sets a boolean value indicating whether the automatic column width calculation should be buffered.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
Public Property AutoFitColumnsBuffering As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As LayoutSet
Dim value As System.Boolean

instance.AutoFitColumnsBuffering = value

value = instance.AutoFitColumnsBuffering
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behaviors")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets a boolean value indicating whether the automatic column width calculation should be buffered.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public System.bool AutoFitColumnsBuffering {get; set;}
Delphi
public read-write property AutoFitColumnsBuffering: System.Boolean;
JScript
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.CategoryAttribute("Behaviors")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets a boolean value indicating whether the automatic column width calculation should be buffered.")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
public function get,set AutoFitColumnsBuffering : System.boolean
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behaviors")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets a boolean value indicating whether the automatic column width calculation should be buffered.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.bool get_AutoFitColumnsBuffering();
public: __property void set_AutoFitColumnsBuffering(
   System.bool value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behaviors")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets a boolean value indicating whether the automatic column width calculation should be buffered.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.bool AutoFitColumnsBuffering {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayoutSet Class
LayoutSet Members


AutoHeight Property

[image]
Intersoft WebGrid Documentation
AutoHeight Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > LayoutSet Class : AutoHeight Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Behaviors")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies whether WebGrid will calculate its height automatically based on available page's height.")>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property AutoHeight As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As LayoutSet
Dim value As System.Boolean

instance.AutoHeight = value

value = instance.AutoHeight
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behaviors")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether WebGrid will calculate its height automatically based on available page's height.")]
[ISNet.Serialization.BinarySerializableAttribute()]
public System.bool AutoHeight {get; set;}
Delphi
public read-write property AutoHeight: System.Boolean;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.CategoryAttribute("Behaviors")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Specifies whether WebGrid will calculate its height automatically based on available page's height.")
ISNet.Serialization.BinarySerializableAttribute()
public function get,set AutoHeight : System.boolean
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behaviors")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether WebGrid will calculate its height automatically based on available page's height.")]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.bool get_AutoHeight();
public: __property void set_AutoHeight(
   System.bool value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behaviors")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether WebGrid will calculate its height automatically based on available page's height.")]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.bool AutoHeight {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayoutSet Class
LayoutSet Members


AutoWidth Property

[image]
Intersoft WebGrid Documentation
AutoWidth Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > LayoutSet Class : AutoWidth Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Behaviors")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Specifies whether WebGrid will calculate its width automatically based on available page's width.")>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Property AutoWidth As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As LayoutSet
Dim value As System.Boolean

instance.AutoWidth = value

value = instance.AutoWidth
C#
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behaviors")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies whether WebGrid will calculate its width automatically based on available page's width.")]
[ISNet.Serialization.XmlSerializableAttribute()]
public System.bool AutoWidth {get; set;}
Delphi
public read-write property AutoWidth: System.Boolean;
JScript
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Behaviors")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Specifies whether WebGrid will calculate its width automatically based on available page's width.")
ISNet.Serialization.XmlSerializableAttribute()
public function get,set AutoWidth : System.boolean
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behaviors")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies whether WebGrid will calculate its width automatically based on available page's width.")]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property System.bool get_AutoWidth();
public: __property void set_AutoWidth(
   System.bool value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behaviors")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies whether WebGrid will calculate its width automatically based on available page's width.")]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property System.bool AutoWidth {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayoutSet Class
LayoutSet Members


BatchUpdateSettings Property

[image]
Intersoft WebGrid Documentation
BatchUpdateSettings Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > LayoutSet Class : BatchUpdateSettings Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Provides settings for batch update feature.")>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)>
<ISNet.Serialization.XmlSerializableAttribute(True)>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Editing")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property BatchUpdateSettings As WebGridBatchUpdateSettings
Visual Basic (Usage) Copy Code
Dim instance As LayoutSet
Dim value As WebGridBatchUpdateSettings

instance.BatchUpdateSettings = value

value = instance.BatchUpdateSettings
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Provides settings for batch update feature.")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Editing")]
[System.ComponentModel.DefaultValueAttribute()]
public WebGridBatchUpdateSettings BatchUpdateSettings {get; set;}
Delphi
public read-write property BatchUpdateSettings: WebGridBatchUpdateSettings;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DescriptionAttribute("Provides settings for batch update feature.")
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Editing")
System.ComponentModel.DefaultValueAttribute()
public function get,set BatchUpdateSettings : WebGridBatchUpdateSettings
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Provides settings for batch update feature.")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Editing")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property WebGridBatchUpdateSettings* get_BatchUpdateSettings();
public: __property void set_BatchUpdateSettings(
   WebGridBatchUpdateSettings* value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Provides settings for batch update feature.")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Editing")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property WebGridBatchUpdateSettings^ BatchUpdateSettings {
   WebGridBatchUpdateSettings^ get();
   void set (    WebGridBatchUpdateSettings^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayoutSet Class
LayoutSet Members


ButtonStyle Property

[image]
Intersoft WebGrid Documentation
ButtonStyle Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > LayoutSet Class : ButtonStyle Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("The style of button object of Button Column.")>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property ButtonStyle As WebGridFormatStyle
Visual Basic (Usage) Copy Code
Dim instance As LayoutSet
Dim value As WebGridFormatStyle

instance.ButtonStyle = value

value = instance.ButtonStyle
C#
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("The style of button object of Button Column.")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[ISNet.Serialization.BinarySerializableAttribute()]
public WebGridFormatStyle ButtonStyle {get; set;}
Delphi
public read-write property ButtonStyle: WebGridFormatStyle;
JScript
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("The style of button object of Button Column.")
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
ISNet.Serialization.BinarySerializableAttribute()
public function get,set ButtonStyle : WebGridFormatStyle
Managed Extensions for C++
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("The style of button object of Button Column.")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property WebGridFormatStyle* get_ButtonStyle();
public: __property void set_ButtonStyle(
   WebGridFormatStyle* value
);
C++/CLI
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("The style of button object of Button Column.")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property WebGridFormatStyle^ ButtonStyle {
   WebGridFormatStyle^ get();
   void set (    WebGridFormatStyle^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayoutSet Class
LayoutSet Members


CellClickAction Property

[image]
Intersoft WebGrid Documentation
CellClickAction Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > LayoutSet Class : CellClickAction Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("Behaviors")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Specifies the action when users click on a cell.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property CellClickAction As CellClick
Visual Basic (Usage) Copy Code
Dim instance As LayoutSet
Dim value As CellClick

instance.CellClickAction = value

value = instance.CellClickAction
C#
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Behaviors")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the action when users click on a cell.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public CellClick CellClickAction {get; set;}
Delphi
public read-write property CellClickAction: CellClick;
JScript
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("Behaviors")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the action when users click on a cell.")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get,set CellClickAction : CellClick
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Behaviors")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the action when users click on a cell.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property CellClick get_CellClickAction();
public: __property void set_CellClickAction(
   CellClick value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Behaviors")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the action when users click on a cell.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property CellClick CellClickAction {
   CellClick get();
   void set (    CellClick value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayoutSet Class
LayoutSet Members


CellPaddingDefault Property

[image]
Intersoft WebGrid Documentation
CellPaddingDefault Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > LayoutSet Class : CellPaddingDefault Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Behaviors")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies the default cell padding that controls all UI element's padding.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.MarkAsStyleAttribute(True)>
Public Property CellPaddingDefault As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As LayoutSet
Dim value As System.Integer

instance.CellPaddingDefault = value

value = instance.CellPaddingDefault
C#
[System.ComponentModel.CategoryAttribute("Behaviors")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the default cell padding that controls all UI element's padding.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.MarkAsStyleAttribute(true)]
public System.int CellPaddingDefault {get; set;}
Delphi
public read-write property CellPaddingDefault: System.Integer;
JScript
System.ComponentModel.CategoryAttribute("Behaviors")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the default cell padding that controls all UI element's padding.")
ISNet.Serialization.BinarySerializableAttribute()
ISNet.MarkAsStyleAttribute()
public function get,set CellPaddingDefault : System.int
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Behaviors")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the default cell padding that controls all UI element's padding.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.MarkAsStyleAttribute(true)]
public: __property System.int get_CellPaddingDefault();
public: __property void set_CellPaddingDefault(
   System.int value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Behaviors")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the default cell padding that controls all UI element's padding.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.MarkAsStyleAttribute(true)]
public:
property System.int CellPaddingDefault {
   System.int get();
   void set (    System.int value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayoutSet Class
LayoutSet Members


CellSpacingDefault Property

[image]
Intersoft WebGrid Documentation
CellSpacingDefault Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > LayoutSet Class : CellSpacingDefault Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.MarkAsStyleAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Behaviors")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies the default cell spacing that controls all UI element's spacing.")>
Public Property CellSpacingDefault As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As LayoutSet
Dim value As System.Integer

instance.CellSpacingDefault = value

value = instance.CellSpacingDefault
C#
[ISNet.MarkAsStyleAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behaviors")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the default cell spacing that controls all UI element's spacing.")]
public System.int CellSpacingDefault {get; set;}
Delphi
public read-write property CellSpacingDefault: System.Integer;
JScript
ISNet.MarkAsStyleAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Behaviors")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the default cell spacing that controls all UI element's spacing.")
public function get,set CellSpacingDefault : System.int
Managed Extensions for C++
[ISNet.MarkAsStyleAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behaviors")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the default cell spacing that controls all UI element's spacing.")]
public: __property System.int get_CellSpacingDefault();
public: __property void set_CellSpacingDefault(
   System.int value
);
C++/CLI
[ISNet.MarkAsStyleAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behaviors")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the default cell spacing that controls all UI element's spacing.")]
public:
property System.int CellSpacingDefault {
   System.int get();
   void set (    System.int value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayoutSet Class
LayoutSet Members


ChartCustomContainerId Property

[image]
Intersoft WebGrid Documentation
ChartCustomContainerId Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > LayoutSet Class : ChartCustomContainerId Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Behaviors")>
<System.ComponentModel.DescriptionAttribute("Specifies the client ID of custom container for Pivot Charting, when ChartDisplayPosition is set to Custom.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property ChartCustomContainerId As System.String
Visual Basic (Usage) Copy Code
Dim instance As LayoutSet
Dim value As System.String

instance.ChartCustomContainerId = value

value = instance.ChartCustomContainerId
C#
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behaviors")]
[System.ComponentModel.DescriptionAttribute("Specifies the client ID of custom container for Pivot Charting, when ChartDisplayPosition is set to Custom.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.string ChartCustomContainerId {get; set;}
Delphi
public read-write property ChartCustomContainerId: System.String;
JScript
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Behaviors")
System.ComponentModel.DescriptionAttribute("Specifies the client ID of custom container for Pivot Charting, when ChartDisplayPosition is set to Custom.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set ChartCustomContainerId : System.String
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behaviors")]
[System.ComponentModel.DescriptionAttribute("Specifies the client ID of custom container for Pivot Charting, when ChartDisplayPosition is set to Custom.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.string* get_ChartCustomContainerId();
public: __property void set_ChartCustomContainerId(
   System.string* value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behaviors")]
[System.ComponentModel.DescriptionAttribute("Specifies the client ID of custom container for Pivot Charting, when ChartDisplayPosition is set to Custom.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.String^ ChartCustomContainerId {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayoutSet Class
LayoutSet Members


ChartDisplayPosition Property

[image]
Intersoft WebGrid Documentation
ChartDisplayPosition Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > LayoutSet Class : ChartDisplayPosition Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Behaviors")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies the display position of the PivotChart relative to the GridView, when InitialView is set to Both.")>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Property ChartDisplayPosition As ChartPosition
Visual Basic (Usage) Copy Code
Dim instance As LayoutSet
Dim value As ChartPosition

instance.ChartDisplayPosition = value

value = instance.ChartDisplayPosition
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behaviors")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the display position of the PivotChart relative to the GridView, when InitialView is set to Both.")]
[ISNet.Serialization.XmlSerializableAttribute()]
public ChartPosition ChartDisplayPosition {get; set;}
Delphi
public read-write property ChartDisplayPosition: ChartPosition;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Behaviors")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the display position of the PivotChart relative to the GridView, when InitialView is set to Both.")
ISNet.Serialization.XmlSerializableAttribute()
public function get,set ChartDisplayPosition : ChartPosition
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behaviors")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the display position of the PivotChart relative to the GridView, when InitialView is set to Both.")]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property ChartPosition get_ChartDisplayPosition();
public: __property void set_ChartDisplayPosition(
   ChartPosition value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behaviors")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the display position of the PivotChart relative to the GridView, when InitialView is set to Both.")]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property ChartPosition ChartDisplayPosition {
   ChartPosition get();
   void set (    ChartPosition value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayoutSet Class
LayoutSet Members


CheckedRowStyle Property

[image]
Intersoft WebGrid Documentation
CheckedRowStyle Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > LayoutSet Class : CheckedRowStyle Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("The style applied to checked row.")>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.DefaultValueAttribute()>
Public Property CheckedRowStyle As WebGridFormatStyle
Visual Basic (Usage) Copy Code
Dim instance As LayoutSet
Dim value As WebGridFormatStyle

instance.CheckedRowStyle = value

value = instance.CheckedRowStyle
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("The style applied to checked row.")]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DefaultValueAttribute()]
public WebGridFormatStyle CheckedRowStyle {get; set;}
Delphi
public read-write property CheckedRowStyle: WebGridFormatStyle;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DescriptionAttribute("The style applied to checked row.")
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
System.ComponentModel.NotifyParentPropertyAttribute()
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.DefaultValueAttribute()
public function get,set CheckedRowStyle : WebGridFormatStyle
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("The style applied to checked row.")]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DefaultValueAttribute()]
public: __property WebGridFormatStyle* get_CheckedRowStyle();
public: __property void set_CheckedRowStyle(
   WebGridFormatStyle* value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("The style applied to checked row.")]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DefaultValueAttribute()]
public:
property WebGridFormatStyle^ CheckedRowStyle {
   WebGridFormatStyle^ get();
   void set (    WebGridFormatStyle^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayoutSet Class
LayoutSet Members


ChildRowEmptyAction Property

[image]
Intersoft WebGrid Documentation
ChildRowEmptyAction Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > LayoutSet Class : ChildRowEmptyAction Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Gets or sets the action when loaded child table is empty (no rows).")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Behaviors")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property ChildRowEmptyAction As ChildRowAction
Visual Basic (Usage) Copy Code
Dim instance As LayoutSet
Dim value As ChildRowAction

instance.ChildRowEmptyAction = value

value = instance.ChildRowEmptyAction
C#
[System.ComponentModel.DescriptionAttribute("Gets or sets the action when loaded child table is empty (no rows).")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behaviors")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public ChildRowAction ChildRowEmptyAction {get; set;}
Delphi
public read-write property ChildRowEmptyAction: ChildRowAction;
JScript
System.ComponentModel.DescriptionAttribute("Gets or sets the action when loaded child table is empty (no rows).")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Behaviors")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set ChildRowEmptyAction : ChildRowAction
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Gets or sets the action when loaded child table is empty (no rows).")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behaviors")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property ChildRowAction get_ChildRowEmptyAction();
public: __property void set_ChildRowEmptyAction(
   ChildRowAction value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Gets or sets the action when loaded child table is empty (no rows).")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behaviors")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property ChildRowAction ChildRowEmptyAction {
   ChildRowAction get();
   void set (    ChildRowAction value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayoutSet Class
LayoutSet Members


ChildTableSpacing Property

[image]
Intersoft WebGrid Documentation
ChildTableSpacing Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > LayoutSet Class : ChildTableSpacing Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Behaviors")>
<System.ComponentModel.DescriptionAttribute("Gets or sets the spacing width between each child table in the same level.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
Public Property ChildTableSpacing As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As LayoutSet
Dim value As System.Integer

instance.ChildTableSpacing = value

value = instance.ChildTableSpacing
C#
[System.ComponentModel.CategoryAttribute("Behaviors")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the spacing width between each child table in the same level.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public System.int ChildTableSpacing {get; set;}
Delphi
public read-write property ChildTableSpacing: System.Integer;
JScript
System.ComponentModel.CategoryAttribute("Behaviors")
System.ComponentModel.DescriptionAttribute("Gets or sets the spacing width between each child table in the same level.")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
public function get,set ChildTableSpacing : System.int
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Behaviors")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the spacing width between each child table in the same level.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.int get_ChildTableSpacing();
public: __property void set_ChildTableSpacing(
   System.int value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Behaviors")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the spacing width between each child table in the same level.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.int ChildTableSpacing {
   System.int get();
   void set (    System.int value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayoutSet Class
LayoutSet Members


ClientSideEvents Property

[image]
Intersoft WebGrid Documentation
ClientSideEvents Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > LayoutSet Class : ClientSideEvents Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Returns ClientEvents object.")>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<ISNet.Serialization.XmlSerializableAttribute(True)>
<ISNet.PersistLayoutAttribute(False)>
<System.ComponentModel.CategoryAttribute("Behaviors")>
Public Property ClientSideEvents As ClientEvents
Visual Basic (Usage) Copy Code
Dim instance As LayoutSet
Dim value As ClientEvents

instance.ClientSideEvents = value

value = instance.ClientSideEvents
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Returns ClientEvents object.")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[ISNet.PersistLayoutAttribute(false)]
[System.ComponentModel.CategoryAttribute("Behaviors")]
public ClientEvents ClientSideEvents {get; set;}
Delphi
public read-write property ClientSideEvents: ClientEvents;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Returns ClientEvents object.")
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.PersistLayoutAttribute()
System.ComponentModel.CategoryAttribute("Behaviors")
public function get,set ClientSideEvents : ClientEvents
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Returns ClientEvents object.")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[ISNet.PersistLayoutAttribute(false)]
[System.ComponentModel.CategoryAttribute("Behaviors")]
public: __property ClientEvents* get_ClientSideEvents();
public: __property void set_ClientSideEvents(
   ClientEvents* value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Returns ClientEvents object.")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[ISNet.PersistLayoutAttribute(false)]
[System.ComponentModel.CategoryAttribute("Behaviors")]
public:
property ClientEvents^ ClientSideEvents {
   ClientEvents^ get();
   void set (    ClientEvents^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayoutSet Class
LayoutSet Members


ClientVisible Property

[image]
Intersoft WebGrid Documentation
ClientVisible Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > LayoutSet Class : ClientVisible Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Behaviors")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies a value indicating grid's visibility in client side.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.PersistLayoutAttribute(False)>
Public Property ClientVisible As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As LayoutSet
Dim value As System.Boolean

instance.ClientVisible = value

value = instance.ClientVisible
C#
[System.ComponentModel.CategoryAttribute("Behaviors")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies a value indicating grid's visibility in client side.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.PersistLayoutAttribute(false)]
public System.bool ClientVisible {get; set;}
Delphi
public read-write property ClientVisible: System.Boolean;
JScript
System.ComponentModel.CategoryAttribute("Behaviors")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Specifies a value indicating grid's visibility in client side.")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
ISNet.PersistLayoutAttribute()
public function get,set ClientVisible : System.boolean
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Behaviors")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies a value indicating grid's visibility in client side.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.PersistLayoutAttribute(false)]
public: __property System.bool get_ClientVisible();
public: __property void set_ClientVisible(
   System.bool value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Behaviors")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies a value indicating grid's visibility in client side.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.PersistLayoutAttribute(false)]
public:
property System.bool ClientVisible {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayoutSet Class
LayoutSet Members


ColumnActionStyle Property

[image]
Intersoft WebGrid Documentation
ColumnActionStyle Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > LayoutSet Class : ColumnActionStyle Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("The style applied to the column action indicator.")>
<System.ComponentModel.CategoryAttribute("Appearance")>
Public Property ColumnActionStyle As ISNet.WebUI.DynamicStyle
Visual Basic (Usage) Copy Code
Dim instance As LayoutSet
Dim value As ISNet.WebUI.DynamicStyle

instance.ColumnActionStyle = value

value = instance.ColumnActionStyle
C#
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("The style applied to the column action indicator.")]
[System.ComponentModel.CategoryAttribute("Appearance")]
public ISNet.WebUI.DynamicStyle ColumnActionStyle {get; set;}
Delphi
public read-write property ColumnActionStyle: ISNet.WebUI.DynamicStyle;
JScript
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("The style applied to the column action indicator.")
System.ComponentModel.CategoryAttribute("Appearance")
public function get,set ColumnActionStyle : ISNet.WebUI.DynamicStyle
Managed Extensions for C++
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("The style applied to the column action indicator.")]
[System.ComponentModel.CategoryAttribute("Appearance")]
public: __property ISNet.WebUI.DynamicStyle* get_ColumnActionStyle();
public: __property void set_ColumnActionStyle(
   ISNet.WebUI.DynamicStyle* value
);
C++/CLI
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("The style applied to the column action indicator.")]
[System.ComponentModel.CategoryAttribute("Appearance")]
public:
property ISNet.WebUI.DynamicStyle^ ColumnActionStyle {
   ISNet.WebUI.DynamicStyle^ get();
   void set (    ISNet.WebUI.DynamicStyle^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayoutSet Class
LayoutSet Members


ColumnFooterAggregateMode Property

[image]
Intersoft WebGrid Documentation
ColumnFooterAggregateMode Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > LayoutSet Class : ColumnFooterAggregateMode Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Behaviors")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Gets or sets the calculation mode for aggregatio function in Column Footer.")>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property ColumnFooterAggregateMode As ColumnFooterAggregateMode
Visual Basic (Usage) Copy Code
Dim instance As LayoutSet
Dim value As ColumnFooterAggregateMode

instance.ColumnFooterAggregateMode = value

value = instance.ColumnFooterAggregateMode
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behaviors")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the calculation mode for aggregatio function in Column Footer.")]
[ISNet.Serialization.BinarySerializableAttribute()]
public ColumnFooterAggregateMode ColumnFooterAggregateMode {get; set;}
Delphi
public read-write property ColumnFooterAggregateMode: ColumnFooterAggregateMode;
JScript
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.CategoryAttribute("Behaviors")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the calculation mode for aggregatio function in Column Footer.")
ISNet.Serialization.BinarySerializableAttribute()
public function get,set ColumnFooterAggregateMode : ColumnFooterAggregateMode
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behaviors")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the calculation mode for aggregatio function in Column Footer.")]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property ColumnFooterAggregateMode get_ColumnFooterAggregateMode();
public: __property void set_ColumnFooterAggregateMode(
   ColumnFooterAggregateMode value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behaviors")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the calculation mode for aggregatio function in Column Footer.")]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property ColumnFooterAggregateMode ColumnFooterAggregateMode {
   ColumnFooterAggregateMode get();
   void set (    ColumnFooterAggregateMode value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayoutSet Class
LayoutSet Members


ColumnFooters Property

[image]
Intersoft WebGrid Documentation
ColumnFooters Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > LayoutSet Class : ColumnFooters Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies whether or not to display column footers.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Behaviors")>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Property ColumnFooters As ColumnVisibility
Visual Basic (Usage) Copy Code
Dim instance As LayoutSet
Dim value As ColumnVisibility

instance.ColumnFooters = value

value = instance.ColumnFooters
C#
[System.ComponentModel.DescriptionAttribute("Specifies whether or not to display column footers.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behaviors")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public ColumnVisibility ColumnFooters {get; set;}
Delphi
public read-write property ColumnFooters: ColumnVisibility;
JScript
System.ComponentModel.DescriptionAttribute("Specifies whether or not to display column footers.")
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Behaviors")
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute()
public function get,set ColumnFooters : ColumnVisibility
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies whether or not to display column footers.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behaviors")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property ColumnVisibility get_ColumnFooters();
public: __property void set_ColumnFooters(
   ColumnVisibility value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies whether or not to display column footers.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behaviors")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property ColumnVisibility ColumnFooters {
   ColumnVisibility get();
   void set (    ColumnVisibility value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayoutSet Class
LayoutSet Members


ColumnHeaders Property

[image]
Intersoft WebGrid Documentation
ColumnHeaders Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > LayoutSet Class : ColumnHeaders Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies whether or not to display column headers.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Behaviors")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
Public Property ColumnHeaders As ColumnVisibility
Visual Basic (Usage) Copy Code
Dim instance As LayoutSet
Dim value As ColumnVisibility

instance.ColumnHeaders = value

value = instance.ColumnHeaders
C#
[System.ComponentModel.DescriptionAttribute("Specifies whether or not to display column headers.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behaviors")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public ColumnVisibility ColumnHeaders {get; set;}
Delphi
public read-write property ColumnHeaders: ColumnVisibility;
JScript
System.ComponentModel.DescriptionAttribute("Specifies whether or not to display column headers.")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Behaviors")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
public function get,set ColumnHeaders : ColumnVisibility
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies whether or not to display column headers.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behaviors")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public: __property ColumnVisibility get_ColumnHeaders();
public: __property void set_ColumnHeaders(
   ColumnVisibility value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies whether or not to display column headers.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behaviors")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public:
property ColumnVisibility ColumnHeaders {
   ColumnVisibility get();
   void set (    ColumnVisibility value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayoutSet Class
LayoutSet Members


ColumnSetHeaders Property

[image]
Intersoft WebGrid Documentation
ColumnSetHeaders Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > LayoutSet Class : ColumnSetHeaders Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Behaviors")>
<System.ComponentModel.DescriptionAttribute("Gets or sets a value whether the columnset's headers is visible or not.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
Public Property ColumnSetHeaders As ColumnVisibility
Visual Basic (Usage) Copy Code
Dim instance As LayoutSet
Dim value As ColumnVisibility

instance.ColumnSetHeaders = value

value = instance.ColumnSetHeaders
C#
[System.ComponentModel.CategoryAttribute("Behaviors")]
[System.ComponentModel.DescriptionAttribute("Gets or sets a value whether the columnset's headers is visible or not.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public ColumnVisibility ColumnSetHeaders {get; set;}
Delphi
public read-write property ColumnSetHeaders: ColumnVisibility;
JScript
System.ComponentModel.CategoryAttribute("Behaviors")
System.ComponentModel.DescriptionAttribute("Gets or sets a value whether the columnset's headers is visible or not.")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
public function get,set ColumnSetHeaders : ColumnVisibility
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Behaviors")]
[System.ComponentModel.DescriptionAttribute("Gets or sets a value whether the columnset's headers is visible or not.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public: __property ColumnVisibility get_ColumnSetHeaders();
public: __property void set_ColumnSetHeaders(
   ColumnVisibility value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Behaviors")]
[System.ComponentModel.DescriptionAttribute("Gets or sets a value whether the columnset's headers is visible or not.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public:
property ColumnVisibility ColumnSetHeaders {
   ColumnVisibility get();
   void set (    ColumnVisibility value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayoutSet Class
LayoutSet Members


ContextMenuAnimation Property

[image]
Intersoft WebGrid Documentation
ContextMenuAnimation Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > LayoutSet Class : ContextMenuAnimation Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Behaviors")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies whether fading animation should be applied during context menu show.")>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Property ContextMenuAnimation As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As LayoutSet
Dim value As System.Boolean

instance.ContextMenuAnimation = value

value = instance.ContextMenuAnimation
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behaviors")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether fading animation should be applied during context menu show.")]
[ISNet.Serialization.XmlSerializableAttribute()]
public System.bool ContextMenuAnimation {get; set;}
Delphi
public read-write property ContextMenuAnimation: System.Boolean;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Behaviors")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Specifies whether fading animation should be applied during context menu show.")
ISNet.Serialization.XmlSerializableAttribute()
public function get,set ContextMenuAnimation : System.boolean
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behaviors")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether fading animation should be applied during context menu show.")]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property System.bool get_ContextMenuAnimation();
public: __property void set_ContextMenuAnimation(
   System.bool value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behaviors")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether fading animation should be applied during context menu show.")]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property System.bool ContextMenuAnimation {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayoutSet Class
LayoutSet Members


Culture Property

[image]
Intersoft WebGrid Documentation
Culture Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > LayoutSet Class : Culture Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Behaviors")>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.PersistLayoutAttribute(False)>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies the culture setting for current WebGrid instance.")>
Public Property Culture As System.Globalization.CultureInfo
Visual Basic (Usage) Copy Code
Dim instance As LayoutSet
Dim value As System.Globalization.CultureInfo

instance.Culture = value

value = instance.Culture
C#
[System.ComponentModel.CategoryAttribute("Behaviors")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.PersistLayoutAttribute(false)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the culture setting for current WebGrid instance.")]
public System.Globalization.CultureInfo Culture {get; set;}
Delphi
public read-write property Culture: System.Globalization.CultureInfo;
JScript
System.ComponentModel.CategoryAttribute("Behaviors")
System.ComponentModel.DefaultValueAttribute()
ISNet.PersistLayoutAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the culture setting for current WebGrid instance.")
public function get,set Culture : System.Globalization.CultureInfo
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Behaviors")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.PersistLayoutAttribute(false)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the culture setting for current WebGrid instance.")]
public: __property System.Globalization.CultureInfo* get_Culture();
public: __property void set_Culture(
   System.Globalization.CultureInfo* value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Behaviors")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.PersistLayoutAttribute(false)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the culture setting for current WebGrid instance.")]
public:
property System.Globalization.CultureInfo^ Culture {
   System.Globalization.CultureInfo^ get();
   void set (    System.Globalization.CultureInfo^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayoutSet Class
LayoutSet Members


CustomFilterString Property

[image]
Intersoft WebGrid Documentation
CustomFilterString Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > LayoutSet Class : CustomFilterString Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Behaviors")>
<System.ComponentModel.DescriptionAttribute("Gets or sets the custom filtering string.")>
<ISNet.PersistLayoutAttribute(False)>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
Public Property CustomFilterString As System.String
Visual Basic (Usage) Copy Code
Dim instance As LayoutSet
Dim value As System.String

instance.CustomFilterString = value

value = instance.CustomFilterString
C#
[System.ComponentModel.CategoryAttribute("Behaviors")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the custom filtering string.")]
[ISNet.PersistLayoutAttribute(false)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public System.string CustomFilterString {get; set;}
Delphi
public read-write property CustomFilterString: System.String;
JScript
System.ComponentModel.CategoryAttribute("Behaviors")
System.ComponentModel.DescriptionAttribute("Gets or sets the custom filtering string.")
ISNet.PersistLayoutAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
public function get,set CustomFilterString : System.String
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Behaviors")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the custom filtering string.")]
[ISNet.PersistLayoutAttribute(false)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.string* get_CustomFilterString();
public: __property void set_CustomFilterString(
   System.string* value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Behaviors")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the custom filtering string.")]
[ISNet.PersistLayoutAttribute(false)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.String^ CustomFilterString {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayoutSet Class
LayoutSet Members


DeletedRowStyle Property

[image]
Intersoft WebGrid Documentation
DeletedRowStyle Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > LayoutSet Class : DeletedRowStyle Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("The style applied to deleted row in batch update mode.")>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
Public Property DeletedRowStyle As WebGridFormatStyle
Visual Basic (Usage) Copy Code
Dim instance As LayoutSet
Dim value As WebGridFormatStyle

instance.DeletedRowStyle = value

value = instance.DeletedRowStyle
C#
[System.ComponentModel.DescriptionAttribute("The style applied to deleted row in batch update mode.")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
public WebGridFormatStyle DeletedRowStyle {get; set;}
Delphi
public read-write property DeletedRowStyle: WebGridFormatStyle;
JScript
System.ComponentModel.DescriptionAttribute("The style applied to deleted row in batch update mode.")
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
public function get,set DeletedRowStyle : WebGridFormatStyle
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("The style applied to deleted row in batch update mode.")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
public: __property WebGridFormatStyle* get_DeletedRowStyle();
public: __property void set_DeletedRowStyle(
   WebGridFormatStyle* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("The style applied to deleted row in batch update mode.")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
public:
property WebGridFormatStyle^ DeletedRowStyle {
   WebGridFormatStyle^ get();
   void set (    WebGridFormatStyle^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayoutSet Class
LayoutSet Members


DisplayDetailsOnUnhandledError Property

[image]
Intersoft WebGrid Documentation
DisplayDetailsOnUnhandledError Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > LayoutSet Class : DisplayDetailsOnUnhandledError Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Behaviors")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Gets or sets a boolean value indicating whether error details message box should be displayed immediately when unhandled error occurred.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property DisplayDetailsOnUnhandledError As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As LayoutSet
Dim value As System.Boolean

instance.DisplayDetailsOnUnhandledError = value

value = instance.DisplayDetailsOnUnhandledError
C#
[System.ComponentModel.CategoryAttribute("Behaviors")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets a boolean value indicating whether error details message box should be displayed immediately when unhandled error occurred.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public System.bool DisplayDetailsOnUnhandledError {get; set;}
Delphi
public read-write property DisplayDetailsOnUnhandledError: System.Boolean;
JScript
System.ComponentModel.CategoryAttribute("Behaviors")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets a boolean value indicating whether error details message box should be displayed immediately when unhandled error occurred.")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get,set DisplayDetailsOnUnhandledError : System.boolean
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Behaviors")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets a boolean value indicating whether error details message box should be displayed immediately when unhandled error occurred.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.bool get_DisplayDetailsOnUnhandledError();
public: __property void set_DisplayDetailsOnUnhandledError(
   System.bool value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Behaviors")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets a boolean value indicating whether error details message box should be displayed immediately when unhandled error occurred.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.bool DisplayDetailsOnUnhandledError {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayoutSet Class
LayoutSet Members


EditFocusCellStyle Property

[image]
Intersoft WebGrid Documentation
EditFocusCellStyle Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > LayoutSet Class : EditFocusCellStyle Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("The style of the focused cell object.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property EditFocusCellStyle As WebGridFormatStyle
Visual Basic (Usage) Copy Code
Dim instance As LayoutSet
Dim value As WebGridFormatStyle

instance.EditFocusCellStyle = value

value = instance.EditFocusCellStyle
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("The style of the focused cell object.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public WebGridFormatStyle EditFocusCellStyle {get; set;}
Delphi
public read-write property EditFocusCellStyle: WebGridFormatStyle;
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DescriptionAttribute("The style of the focused cell object.")
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set EditFocusCellStyle : WebGridFormatStyle
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("The style of the focused cell object.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property WebGridFormatStyle* get_EditFocusCellStyle();
public: __property void set_EditFocusCellStyle(
   WebGridFormatStyle* value
);
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("The style of the focused cell object.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property WebGridFormatStyle^ EditFocusCellStyle {
   WebGridFormatStyle^ get();
   void set (    WebGridFormatStyle^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayoutSet Class
LayoutSet Members


EditOnClick Property

[image]
Intersoft WebGrid Documentation
EditOnClick Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > LayoutSet Class : EditOnClick Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Editing")>
<System.ComponentModel.DescriptionAttribute("Specifies whether edit mode is activated when user click on cell.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Property EditOnClick As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As LayoutSet
Dim value As System.Boolean

instance.EditOnClick = value

value = instance.EditOnClick
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Editing")]
[System.ComponentModel.DescriptionAttribute("Specifies whether edit mode is activated when user click on cell.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public System.bool EditOnClick {get; set;}
Delphi
public read-write property EditOnClick: System.Boolean;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Editing")
System.ComponentModel.DescriptionAttribute("Specifies whether edit mode is activated when user click on cell.")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute()
public function get,set EditOnClick : System.boolean
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Editing")]
[System.ComponentModel.DescriptionAttribute("Specifies whether edit mode is activated when user click on cell.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property System.bool get_EditOnClick();
public: __property void set_EditOnClick(
   System.bool value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Editing")]
[System.ComponentModel.DescriptionAttribute("Specifies whether edit mode is activated when user click on cell.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property System.bool EditOnClick {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayoutSet Class
LayoutSet Members


EditTextboxStyle Property

[image]
Intersoft WebGrid Documentation
EditTextboxStyle Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > LayoutSet Class : EditTextboxStyle Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("The style of the cell object when in edit mode.")>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
Public Property EditTextboxStyle As WebGridFormatStyle
Visual Basic (Usage) Copy Code
Dim instance As LayoutSet
Dim value As WebGridFormatStyle

instance.EditTextboxStyle = value

value = instance.EditTextboxStyle
C#
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("The style of the cell object when in edit mode.")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
public WebGridFormatStyle EditTextboxStyle {get; set;}
Delphi
public read-write property EditTextboxStyle: WebGridFormatStyle;
JScript
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("The style of the cell object when in edit mode.")
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
public function get,set EditTextboxStyle : WebGridFormatStyle
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("The style of the cell object when in edit mode.")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
public: __property WebGridFormatStyle* get_EditTextboxStyle();
public: __property void set_EditTextboxStyle(
   WebGridFormatStyle* value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("The style of the cell object when in edit mode.")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
public:
property WebGridFormatStyle^ EditTextboxStyle {
   WebGridFormatStyle^ get();
   void set (    WebGridFormatStyle^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayoutSet Class
LayoutSet Members


FilterBarVisible Property

[image]
Intersoft WebGrid Documentation
FilterBarVisible Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > LayoutSet Class : FilterBarVisible Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies whether or not the filter bar will be visible initially.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Behaviors")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property FilterBarVisible As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As LayoutSet
Dim value As System.Boolean

instance.FilterBarVisible = value

value = instance.FilterBarVisible
C#
[System.ComponentModel.DescriptionAttribute("Specifies whether or not the filter bar will be visible initially.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behaviors")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.bool FilterBarVisible {get; set;}
Delphi
public read-write property FilterBarVisible: System.Boolean;
JScript
System.ComponentModel.DescriptionAttribute("Specifies whether or not the filter bar will be visible initially.")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Behaviors")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set FilterBarVisible : System.boolean
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies whether or not the filter bar will be visible initially.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behaviors")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.bool get_FilterBarVisible();
public: __property void set_FilterBarVisible(
   System.bool value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies whether or not the filter bar will be visible initially.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behaviors")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.bool FilterBarVisible {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayoutSet Class
LayoutSet Members


FilterRowStyle Property

[image]
Intersoft WebGrid Documentation
FilterRowStyle Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > LayoutSet Class : FilterRowStyle Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("The style applied to the filter row.")>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property FilterRowStyle As WebGridFormatStyle
Visual Basic (Usage) Copy Code
Dim instance As LayoutSet
Dim value As WebGridFormatStyle

instance.FilterRowStyle = value

value = instance.FilterRowStyle
C#
[System.ComponentModel.DescriptionAttribute("The style applied to the filter row.")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public WebGridFormatStyle FilterRowStyle {get; set;}
Delphi
public read-write property FilterRowStyle: WebGridFormatStyle;
JScript
System.ComponentModel.DescriptionAttribute("The style applied to the filter row.")
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set FilterRowStyle : WebGridFormatStyle
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("The style applied to the filter row.")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property WebGridFormatStyle* get_FilterRowStyle();
public: __property void set_FilterRowStyle(
   WebGridFormatStyle* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("The style applied to the filter row.")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property WebGridFormatStyle^ FilterRowStyle {
   WebGridFormatStyle^ get();
   void set (    WebGridFormatStyle^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayoutSet Class
LayoutSet Members


FocusCellStyle Property

[image]
Intersoft WebGrid Documentation
FocusCellStyle Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > LayoutSet Class : FocusCellStyle Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Gets or sets the style used when a row or cell is focused/selected")>
<System.ComponentModel.CategoryAttribute("Appearance")>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property FocusCellStyle As FocusStyle
Visual Basic (Usage) Copy Code
Dim instance As LayoutSet
Dim value As FocusStyle

instance.FocusCellStyle = value

value = instance.FocusCellStyle
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the style used when a row or cell is focused/selected")]
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public FocusStyle FocusCellStyle {get; set;}
Delphi
public read-write property FocusCellStyle: FocusStyle;
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the style used when a row or cell is focused/selected")
System.ComponentModel.CategoryAttribute("Appearance")
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get,set FocusCellStyle : FocusStyle
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the style used when a row or cell is focused/selected")]
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property FocusStyle* get_FocusCellStyle();
public: __property void set_FocusCellStyle(
   FocusStyle* value
);
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the style used when a row or cell is focused/selected")]
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property FocusStyle^ FocusCellStyle {
   FocusStyle^ get();
   void set (    FocusStyle^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayoutSet Class
LayoutSet Members


FocusNewRowOnLastCell Property

[image]
Intersoft WebGrid Documentation
FocusNewRowOnLastCell Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > LayoutSet Class : FocusNewRowOnLastCell Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Behaviors")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Determines whether WebGrid should automatically focus to new row when user pressed Tab or Right arrow key in the last cell of the last row in the table.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property FocusNewRowOnLastCell As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As LayoutSet
Dim value As System.Boolean

instance.FocusNewRowOnLastCell = value

value = instance.FocusNewRowOnLastCell
C#
[System.ComponentModel.CategoryAttribute("Behaviors")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Determines whether WebGrid should automatically focus to new row when user pressed Tab or Right arrow key in the last cell of the last row in the table.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public System.bool FocusNewRowOnLastCell {get; set;}
Delphi
public read-write property FocusNewRowOnLastCell: System.Boolean;
JScript
System.ComponentModel.CategoryAttribute("Behaviors")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Determines whether WebGrid should automatically focus to new row when user pressed Tab or Right arrow key in the last cell of the last row in the table.")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get,set FocusNewRowOnLastCell : System.boolean
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Behaviors")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Determines whether WebGrid should automatically focus to new row when user pressed Tab or Right arrow key in the last cell of the last row in the table.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.bool get_FocusNewRowOnLastCell();
public: __property void set_FocusNewRowOnLastCell(
   System.bool value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Behaviors")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Determines whether WebGrid should automatically focus to new row when user pressed Tab or Right arrow key in the last cell of the last row in the table.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.bool FocusNewRowOnLastCell {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayoutSet Class
LayoutSet Members


FooterStyle Property

[image]
Intersoft WebGrid Documentation
FooterStyle Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > LayoutSet Class : FooterStyle Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("The style applied to the column footers.")>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
Public Property FooterStyle As WebGridFormatStyle
Visual Basic (Usage) Copy Code
Dim instance As LayoutSet
Dim value As WebGridFormatStyle

instance.FooterStyle = value

value = instance.FooterStyle
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("The style applied to the column footers.")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
public WebGridFormatStyle FooterStyle {get; set;}
Delphi
public read-write property FooterStyle: WebGridFormatStyle;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("The style applied to the column footers.")
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
public function get,set FooterStyle : WebGridFormatStyle
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("The style applied to the column footers.")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
public: __property WebGridFormatStyle* get_FooterStyle();
public: __property void set_FooterStyle(
   WebGridFormatStyle* value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("The style applied to the column footers.")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
public:
property WebGridFormatStyle^ FooterStyle {
   WebGridFormatStyle^ get();
   void set (    WebGridFormatStyle^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayoutSet Class
LayoutSet Members


FrameStyle Property

[image]
Intersoft WebGrid Documentation
FrameStyle Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > LayoutSet Class : FrameStyle Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Specifies the style applied to main WebGrid's frame.")>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
Public Property FrameStyle As WebGridFormatStyle
Visual Basic (Usage) Copy Code
Dim instance As LayoutSet
Dim value As WebGridFormatStyle

instance.FrameStyle = value

value = instance.FrameStyle
C#
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the style applied to main WebGrid's frame.")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
public WebGridFormatStyle FrameStyle {get; set;}
Delphi
public read-write property FrameStyle: WebGridFormatStyle;
JScript
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the style applied to main WebGrid's frame.")
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
public function get,set FrameStyle : WebGridFormatStyle
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the style applied to main WebGrid's frame.")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
public: __property WebGridFormatStyle* get_FrameStyle();
public: __property void set_FrameStyle(
   WebGridFormatStyle* value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the style applied to main WebGrid's frame.")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
public:
property WebGridFormatStyle^ FrameStyle {
   WebGridFormatStyle^ get();
   void set (    WebGridFormatStyle^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayoutSet Class
LayoutSet Members


FreezePaneSettings Property

[image]
Intersoft WebGrid Documentation
FreezePaneSettings Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > LayoutSet Class : FreezePaneSettings Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute(True)>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Contains settings related to freeze column feature.")>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Behaviors")>
Public Property FreezePaneSettings As WebGridFreezePaneSettings
Visual Basic (Usage) Copy Code
Dim instance As LayoutSet
Dim value As WebGridFreezePaneSettings

instance.FreezePaneSettings = value

value = instance.FreezePaneSettings
C#
[ISNet.Serialization.XmlSerializableAttribute(true)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Contains settings related to freeze column feature.")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behaviors")]
public WebGridFreezePaneSettings FreezePaneSettings {get; set;}
Delphi
public read-write property FreezePaneSettings: WebGridFreezePaneSettings;
JScript
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Contains settings related to freeze column feature.")
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Behaviors")
public function get,set FreezePaneSettings : WebGridFreezePaneSettings
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute(true)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Contains settings related to freeze column feature.")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behaviors")]
public: __property WebGridFreezePaneSettings* get_FreezePaneSettings();
public: __property void set_FreezePaneSettings(
   WebGridFreezePaneSettings* value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute(true)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Contains settings related to freeze column feature.")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behaviors")]
public:
property WebGridFreezePaneSettings^ FreezePaneSettings {
   WebGridFreezePaneSettings^ get();
   void set (    WebGridFreezePaneSettings^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayoutSet Class
LayoutSet Members


GridLineColor Property

[image]
Intersoft WebGrid Documentation
GridLineColor Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > LayoutSet Class : GridLineColor Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Behaviors")>
<System.ComponentModel.DescriptionAttribute("Specifies the gridline's color.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.MarkAsStyleAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
Public Property GridLineColor As System.Drawing.Color
Visual Basic (Usage) Copy Code
Dim instance As LayoutSet
Dim value As System.Drawing.Color

instance.GridLineColor = value

value = instance.GridLineColor
C#
[System.ComponentModel.CategoryAttribute("Behaviors")]
[System.ComponentModel.DescriptionAttribute("Specifies the gridline's color.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.MarkAsStyleAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public System.Drawing.Color GridLineColor {get; set;}
Delphi
public read-write property GridLineColor: System.Drawing.Color;
JScript
System.ComponentModel.CategoryAttribute("Behaviors")
System.ComponentModel.DescriptionAttribute("Specifies the gridline's color.")
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
ISNet.MarkAsStyleAttribute()
System.ComponentModel.DefaultValueAttribute()
public function get,set GridLineColor : System.Drawing.Color
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Behaviors")]
[System.ComponentModel.DescriptionAttribute("Specifies the gridline's color.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.MarkAsStyleAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.Drawing.Color get_GridLineColor();
public: __property void set_GridLineColor(
   System.Drawing.Color value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Behaviors")]
[System.ComponentModel.DescriptionAttribute("Specifies the gridline's color.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.MarkAsStyleAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.Drawing.Color GridLineColor {
   System.Drawing.Color get();
   void set (    System.Drawing.Color value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayoutSet Class
LayoutSet Members


GridLines Property

[image]
Intersoft WebGrid Documentation
GridLines Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > LayoutSet Class : GridLines Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies the appearance of WebGrid's GridLines that will separate between rows and cells.")>
<System.ComponentModel.CategoryAttribute("Behaviors")>
<ISNet.MarkAsStyleAttribute(True)>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property GridLines As GridLines
Visual Basic (Usage) Copy Code
Dim instance As LayoutSet
Dim value As GridLines

instance.GridLines = value

value = instance.GridLines
C#
[System.ComponentModel.DescriptionAttribute("Specifies the appearance of WebGrid's GridLines that will separate between rows and cells.")]
[System.ComponentModel.CategoryAttribute("Behaviors")]
[ISNet.MarkAsStyleAttribute(true)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public GridLines GridLines {get; set;}
Delphi
public read-write property GridLines: GridLines;
JScript
System.ComponentModel.DescriptionAttribute("Specifies the appearance of WebGrid's GridLines that will separate between rows and cells.")
System.ComponentModel.CategoryAttribute("Behaviors")
ISNet.MarkAsStyleAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get,set GridLines : GridLines
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies the appearance of WebGrid's GridLines that will separate between rows and cells.")]
[System.ComponentModel.CategoryAttribute("Behaviors")]
[ISNet.MarkAsStyleAttribute(true)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property GridLines get_GridLines();
public: __property void set_GridLines(
   GridLines value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies the appearance of WebGrid's GridLines that will separate between rows and cells.")]
[System.ComponentModel.CategoryAttribute("Behaviors")]
[ISNet.MarkAsStyleAttribute(true)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property GridLines GridLines {
   GridLines get();
   void set (    GridLines value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayoutSet Class
LayoutSet Members


GridLineStyle Property

[image]
Intersoft WebGrid Documentation
GridLineStyle Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > LayoutSet Class : GridLineStyle Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Behaviors")>
<ISNet.MarkAsStyleAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies the gridline's style.")>
Public Property GridLineStyle As System.Web.UI.WebControls.BorderStyle
Visual Basic (Usage) Copy Code
Dim instance As LayoutSet
Dim value As System.Web.UI.WebControls.BorderStyle

instance.GridLineStyle = value

value = instance.GridLineStyle
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behaviors")]
[ISNet.MarkAsStyleAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the gridline's style.")]
public System.Web.UI.WebControls.BorderStyle GridLineStyle {get; set;}
Delphi
public read-write property GridLineStyle: System.Web.UI.WebControls.BorderStyle;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Behaviors")
ISNet.MarkAsStyleAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the gridline's style.")
public function get,set GridLineStyle : System.Web.UI.WebControls.BorderStyle
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behaviors")]
[ISNet.MarkAsStyleAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the gridline's style.")]
public: __property System.Web.UI.WebControls.BorderStyle get_GridLineStyle();
public: __property void set_GridLineStyle(
   System.Web.UI.WebControls.BorderStyle value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behaviors")]
[ISNet.MarkAsStyleAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the gridline's style.")]
public:
property System.Web.UI.WebControls.BorderStyle GridLineStyle {
   System.Web.UI.WebControls.BorderStyle get();
   void set (    System.Web.UI.WebControls.BorderStyle value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayoutSet Class
LayoutSet Members


GroupByBox Property

[image]
Intersoft WebGrid Documentation
GroupByBox Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > LayoutSet Class : GroupByBox Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Gets or sets the that is used to control the appearance of GroupBox.")>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Visible)>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Behaviors")>
Public Property GroupByBox As GroupByBoxObject
Visual Basic (Usage) Copy Code
Dim instance As LayoutSet
Dim value As GroupByBoxObject

instance.GroupByBox = value

value = instance.GroupByBox
C#
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the that is used to control the appearance of GroupBox.")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Visible)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behaviors")]
public GroupByBoxObject GroupByBox {get; set;}
Delphi
public read-write property GroupByBox: GroupByBoxObject;
JScript
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the that is used to control the appearance of GroupBox.")
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Visible)
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.CategoryAttribute("Behaviors")
public function get,set GroupByBox : GroupByBoxObject
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the that is used to control the appearance of GroupBox.")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Visible)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behaviors")]
public: __property GroupByBoxObject* get_GroupByBox();
public: __property void set_GroupByBox(
   GroupByBoxObject* value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the that is used to control the appearance of GroupBox.")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Visible)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behaviors")]
public:
property GroupByBoxObject^ GroupByBox {
   GroupByBoxObject^ get();
   void set (    GroupByBoxObject^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayoutSet Class
LayoutSet Members


GroupByBoxVisible Property

[image]
Intersoft WebGrid Documentation
GroupByBoxVisible Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > LayoutSet Class : GroupByBoxVisible Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Behaviors")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies whether or not to show group by box.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property GroupByBoxVisible As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As LayoutSet
Dim value As System.Boolean

instance.GroupByBoxVisible = value

value = instance.GroupByBoxVisible
C#
[System.ComponentModel.CategoryAttribute("Behaviors")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether or not to show group by box.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public System.bool GroupByBoxVisible {get; set;}
Delphi
public read-write property GroupByBoxVisible: System.Boolean;
JScript
System.ComponentModel.CategoryAttribute("Behaviors")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Specifies whether or not to show group by box.")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get,set GroupByBoxVisible : System.boolean
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Behaviors")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether or not to show group by box.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.bool get_GroupByBoxVisible();
public: __property void set_GroupByBoxVisible(
   System.bool value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Behaviors")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether or not to show group by box.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.bool GroupByBoxVisible {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayoutSet Class
LayoutSet Members


GroupRowInfoFormatDefault Property

[image]
Intersoft WebGrid Documentation
GroupRowInfoFormatDefault Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > LayoutSet Class : GroupRowInfoFormatDefault Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Behaviors")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Gets or sets the default group row's format.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.PersistLayoutAttribute(False)>
Public Property GroupRowInfoFormatDefault As System.String
Visual Basic (Usage) Copy Code
Dim instance As LayoutSet
Dim value As System.String

instance.GroupRowInfoFormatDefault = value

value = instance.GroupRowInfoFormatDefault
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Behaviors")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the default group row's format.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.PersistLayoutAttribute(false)]
public System.string GroupRowInfoFormatDefault {get; set;}
Delphi
public read-write property GroupRowInfoFormatDefault: System.String;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Behaviors")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the default group row's format.")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
ISNet.PersistLayoutAttribute()
public function get,set GroupRowInfoFormatDefault : System.String
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Behaviors")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the default group row's format.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.PersistLayoutAttribute(false)]
public: __property System.string* get_GroupRowInfoFormatDefault();
public: __property void set_GroupRowInfoFormatDefault(
   System.string* value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Behaviors")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the default group row's format.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.PersistLayoutAttribute(false)]
public:
property System.String^ GroupRowInfoFormatDefault {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayoutSet Class
LayoutSet Members


GroupRowInfoStyle Property

[image]
Intersoft WebGrid Documentation
GroupRowInfoStyle Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > LayoutSet Class : GroupRowInfoStyle Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Gets or sets the style for GroupRow.")>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property GroupRowInfoStyle As WebGridFormatStyle
Visual Basic (Usage) Copy Code
Dim instance As LayoutSet
Dim value As WebGridFormatStyle

instance.GroupRowInfoStyle = value

value = instance.GroupRowInfoStyle
C#
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the style for GroupRow.")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.Serialization.BinarySerializableAttribute()]
public WebGridFormatStyle GroupRowInfoStyle {get; set;}
Delphi
public read-write property GroupRowInfoStyle: WebGridFormatStyle;
JScript
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the style for GroupRow.")
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
ISNet.Serialization.BinarySerializableAttribute()
public function get,set GroupRowInfoStyle : WebGridFormatStyle
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the style for GroupRow.")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property WebGridFormatStyle* get_GroupRowInfoStyle();
public: __property void set_GroupRowInfoStyle(
   WebGridFormatStyle* value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the style for GroupRow.")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property WebGridFormatStyle^ GroupRowInfoStyle {
   WebGridFormatStyle^ get();
   void set (    WebGridFormatStyle^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayoutSet Class
LayoutSet Members


HeaderClickAction Property

[image]
Intersoft WebGrid Documentation
HeaderClickAction Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > LayoutSet Class : HeaderClickAction Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("Behaviors")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Specifies the action when users click on column's header.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property HeaderClickAction As HeaderClick
Visual Basic (Usage) Copy Code
Dim instance As LayoutSet
Dim value As HeaderClick

instance.HeaderClickAction = value

value = instance.HeaderClickAction
C#
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Behaviors")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the action when users click on column's header.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public HeaderClick HeaderClickAction {get; set;}
Delphi
public read-write property HeaderClickAction: HeaderClick;
JScript
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("Behaviors")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the action when users click on column's header.")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get,set HeaderClickAction : HeaderClick
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Behaviors")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the action when users click on column's header.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property HeaderClick get_HeaderClickAction();
public: __property void set_HeaderClickAction(
   HeaderClick value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Behaviors")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the action when users click on column's header.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property HeaderClick HeaderClickAction {
   HeaderClick get();
   void set (    HeaderClick value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayoutSet Class
LayoutSet Members


HeaderStyle Property

[image]
Intersoft WebGrid Documentation
HeaderStyle Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > LayoutSet Class : HeaderStyle Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("The style applied to the column headers.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
Public Property HeaderStyle As WebGridFormatStyle
Visual Basic (Usage) Copy Code
Dim instance As LayoutSet
Dim value As WebGridFormatStyle

instance.HeaderStyle = value

value = instance.HeaderStyle
C#
[System.ComponentModel.DescriptionAttribute("The style applied to the column headers.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
public WebGridFormatStyle HeaderStyle {get; set;}
Delphi
public read-write property HeaderStyle: WebGridFormatStyle;
JScript
System.ComponentModel.DescriptionAttribute("The style applied to the column headers.")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
public function get,set HeaderStyle : WebGridFormatStyle
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("The style applied to the column headers.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
public: __property WebGridFormatStyle* get_HeaderStyle();
public: __property void set_HeaderStyle(
   WebGridFormatStyle* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("The style applied to the column headers.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
public:
property WebGridFormatStyle^ HeaderStyle {
   WebGridFormatStyle^ get();
   void set (    WebGridFormatStyle^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayoutSet Class
LayoutSet Members


HeaderWrapDefault Property

[image]
Intersoft WebGrid Documentation
HeaderWrapDefault Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > LayoutSet Class : HeaderWrapDefault Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Behaviors")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies whether the column header text should be wrapped when the column width is not sufficient to show the text. ")>
Public Property HeaderWrapDefault As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As LayoutSet
Dim value As System.Boolean

instance.HeaderWrapDefault = value

value = instance.HeaderWrapDefault
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behaviors")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether the column header text should be wrapped when the column width is not sufficient to show the text. ")]
public System.bool HeaderWrapDefault {get; set;}
Delphi
public read-write property HeaderWrapDefault: System.Boolean;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Behaviors")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Specifies whether the column header text should be wrapped when the column width is not sufficient to show the text. ")
public function get,set HeaderWrapDefault : System.boolean
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behaviors")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether the column header text should be wrapped when the column width is not sufficient to show the text. ")]
public: __property System.bool get_HeaderWrapDefault();
public: __property void set_HeaderWrapDefault(
   System.bool value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behaviors")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether the column header text should be wrapped when the column width is not sufficient to show the text. ")]
public:
property System.bool HeaderWrapDefault {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayoutSet Class
LayoutSet Members


HelpURL Property

[image]
Intersoft WebGrid Documentation
HelpURL Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > LayoutSet Class : HelpURL Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Behaviors")>
<System.ComponentModel.DescriptionAttribute("Specifies the client's help URL when user clicked on the Help icon. The default is Intersoft's own help page URL. This property is application-wide configurable.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property HelpURL As System.String
Visual Basic (Usage) Copy Code
Dim instance As LayoutSet
Dim value As System.String

instance.HelpURL = value

value = instance.HelpURL
C#
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behaviors")]
[System.ComponentModel.DescriptionAttribute("Specifies the client's help URL when user clicked on the Help icon. The default is Intersoft's own help page URL. This property is application-wide configurable.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.string HelpURL {get; set;}
Delphi
public read-write property HelpURL: System.String;
JScript
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Behaviors")
System.ComponentModel.DescriptionAttribute("Specifies the client's help URL when user clicked on the Help icon. The default is Intersoft's own help page URL. This property is application-wide configurable.")
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set HelpURL : System.String
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behaviors")]
[System.ComponentModel.DescriptionAttribute("Specifies the client's help URL when user clicked on the Help icon. The default is Intersoft's own help page URL. This property is application-wide configurable.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.string* get_HelpURL();
public: __property void set_HelpURL(
   System.string* value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behaviors")]
[System.ComponentModel.DescriptionAttribute("Specifies the client's help URL when user clicked on the Help icon. The default is Intersoft's own help page URL. This property is application-wide configurable.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.String^ HelpURL {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayoutSet Class
LayoutSet Members


HideColumnsWhenGrouped Property

[image]
Intersoft WebGrid Documentation
HideColumnsWhenGrouped Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > LayoutSet Class : HideColumnsWhenGrouped Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Behaviors")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies whether the column headers of grouped columns is hidden.")>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Property HideColumnsWhenGrouped As HideColumns
Visual Basic (Usage) Copy Code
Dim instance As LayoutSet
Dim value As HideColumns

instance.HideColumnsWhenGrouped = value

value = instance.HideColumnsWhenGrouped
C#
[System.ComponentModel.CategoryAttribute("Behaviors")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether the column headers of grouped columns is hidden.")]
[ISNet.Serialization.XmlSerializableAttribute()]
public HideColumns HideColumnsWhenGrouped {get; set;}
Delphi
public read-write property HideColumnsWhenGrouped: HideColumns;
JScript
System.ComponentModel.CategoryAttribute("Behaviors")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Specifies whether the column headers of grouped columns is hidden.")
ISNet.Serialization.XmlSerializableAttribute()
public function get,set HideColumnsWhenGrouped : HideColumns
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Behaviors")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether the column headers of grouped columns is hidden.")]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property HideColumns get_HideColumnsWhenGrouped();
public: __property void set_HideColumnsWhenGrouped(
   HideColumns value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Behaviors")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether the column headers of grouped columns is hidden.")]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property HideColumns HideColumnsWhenGrouped {
   HideColumns get();
   void set (    HideColumns value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayoutSet Class
LayoutSet Members


Hierarchical Property

[image]
Intersoft WebGrid Documentation
Hierarchical Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > LayoutSet Class : Hierarchical Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Behaviors")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies whether or not WebGrid will display hierarchical data.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.PersistLayoutAttribute(False)>
Public Property Hierarchical As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As LayoutSet
Dim value As System.Boolean

instance.Hierarchical = value

value = instance.Hierarchical
C#
[System.ComponentModel.CategoryAttribute("Behaviors")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether or not WebGrid will display hierarchical data.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.PersistLayoutAttribute(false)]
public System.bool Hierarchical {get; set;}
Delphi
public read-write property Hierarchical: System.Boolean;
JScript
System.ComponentModel.CategoryAttribute("Behaviors")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Specifies whether or not WebGrid will display hierarchical data.")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
ISNet.PersistLayoutAttribute()
public function get,set Hierarchical : System.boolean
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Behaviors")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether or not WebGrid will display hierarchical data.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.PersistLayoutAttribute(false)]
public: __property System.bool get_Hierarchical();
public: __property void set_Hierarchical(
   System.bool value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Behaviors")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether or not WebGrid will display hierarchical data.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.PersistLayoutAttribute(false)]
public:
property System.bool Hierarchical {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayoutSet Class
LayoutSet Members


HierarchicalMode Property

[image]
Intersoft WebGrid Documentation
HierarchicalMode Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > LayoutSet Class : HierarchicalMode Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies the operation mode when the WebGrid is configured to use Hierarchical feature.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("Behaviors")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property HierarchicalMode As HierarchicalOperation
Visual Basic (Usage) Copy Code
Dim instance As LayoutSet
Dim value As HierarchicalOperation

instance.HierarchicalMode = value

value = instance.HierarchicalMode
C#
[System.ComponentModel.DescriptionAttribute("Specifies the operation mode when the WebGrid is configured to use Hierarchical feature.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Behaviors")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public HierarchicalOperation HierarchicalMode {get; set;}
Delphi
public read-write property HierarchicalMode: HierarchicalOperation;
JScript
System.ComponentModel.DescriptionAttribute("Specifies the operation mode when the WebGrid is configured to use Hierarchical feature.")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("Behaviors")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get,set HierarchicalMode : HierarchicalOperation
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies the operation mode when the WebGrid is configured to use Hierarchical feature.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Behaviors")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property HierarchicalOperation get_HierarchicalMode();
public: __property void set_HierarchicalMode(
   HierarchicalOperation value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies the operation mode when the WebGrid is configured to use Hierarchical feature.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Behaviors")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property HierarchicalOperation HierarchicalMode {
   HierarchicalOperation get();
   void set (    HierarchicalOperation value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayoutSet Class
LayoutSet Members


HyperlinkStyle Property

[image]
Intersoft WebGrid Documentation
HyperlinkStyle Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > LayoutSet Class : HyperlinkStyle Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("The style used for hyperlink column type.")>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property HyperlinkStyle As WebGridFormatStyle
Visual Basic (Usage) Copy Code
Dim instance As LayoutSet
Dim value As WebGridFormatStyle

instance.HyperlinkStyle = value

value = instance.HyperlinkStyle
C#
[System.ComponentModel.DescriptionAttribute("The style used for hyperlink column type.")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public WebGridFormatStyle HyperlinkStyle {get; set;}
Delphi
public read-write property HyperlinkStyle: WebGridFormatStyle;
JScript
System.ComponentModel.DescriptionAttribute("The style used for hyperlink column type.")
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set HyperlinkStyle : WebGridFormatStyle
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("The style used for hyperlink column type.")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property WebGridFormatStyle* get_HyperlinkStyle();
public: __property void set_HyperlinkStyle(
   WebGridFormatStyle* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("The style used for hyperlink column type.")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property WebGridFormatStyle^ HyperlinkStyle {
   WebGridFormatStyle^ get();
   void set (    WebGridFormatStyle^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayoutSet Class
LayoutSet Members


ImageSettings Property

[image]
Intersoft WebGrid Documentation
ImageSettings Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > LayoutSet Class : ImageSettings Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Gets or sets the ImageSettings object which is used to store the images used by WebGrid.")>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<ISNet.MarkAsStyleAttribute(True)>
<System.ComponentModel.CategoryAttribute("Behaviors")>
Public Property ImageSettings As ImageSettings
Visual Basic (Usage) Copy Code
Dim instance As LayoutSet
Dim value As ImageSettings

instance.ImageSettings = value

value = instance.ImageSettings
C#
[ISNet.Serialization.XmlSerializableAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the ImageSettings object which is used to store the images used by WebGrid.")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.MarkAsStyleAttribute(true)]
[System.ComponentModel.CategoryAttribute("Behaviors")]
public ImageSettings ImageSettings {get; set;}
Delphi
public read-write property ImageSettings: ImageSettings;
JScript
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the ImageSettings object which is used to store the images used by WebGrid.")
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
ISNet.MarkAsStyleAttribute()
System.ComponentModel.CategoryAttribute("Behaviors")
public function get,set ImageSettings : ImageSettings
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the ImageSettings object which is used to store the images used by WebGrid.")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.MarkAsStyleAttribute(true)]
[System.ComponentModel.CategoryAttribute("Behaviors")]
public: __property ImageSettings* get_ImageSettings();
public: __property void set_ImageSettings(
   ImageSettings* value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the ImageSettings object which is used to store the images used by WebGrid.")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.MarkAsStyleAttribute(true)]
[System.ComponentModel.CategoryAttribute("Behaviors")]
public:
property ImageSettings^ ImageSettings {
   ImageSettings^ get();
   void set (    ImageSettings^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayoutSet Class
LayoutSet Members


InitialView Property

[image]
Intersoft WebGrid Documentation
InitialView Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > LayoutSet Class : InitialView Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("Behaviors")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Specifies the initial view of WebGrid.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property InitialView As GridInitialView
Visual Basic (Usage) Copy Code
Dim instance As LayoutSet
Dim value As GridInitialView

instance.InitialView = value

value = instance.InitialView
C#
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Behaviors")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the initial view of WebGrid.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public GridInitialView InitialView {get; set;}
Delphi
public read-write property InitialView: GridInitialView;
JScript
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("Behaviors")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the initial view of WebGrid.")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get,set InitialView : GridInitialView
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Behaviors")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the initial view of WebGrid.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property GridInitialView get_InitialView();
public: __property void set_InitialView(
   GridInitialView value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Behaviors")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the initial view of WebGrid.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property GridInitialView InitialView {
   GridInitialView get();
   void set (    GridInitialView value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayoutSet Class
LayoutSet Members


InProgressUIBehavior Property

[image]
Intersoft WebGrid Documentation
InProgressUIBehavior Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > LayoutSet Class : InProgressUIBehavior Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Behaviors")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies the user interface behavior when a request is in progress.")>
Public Property InProgressUIBehavior As InProgressUIBehavior
Visual Basic (Usage) Copy Code
Dim instance As LayoutSet
Dim value As InProgressUIBehavior

instance.InProgressUIBehavior = value

value = instance.InProgressUIBehavior
C#
[System.ComponentModel.CategoryAttribute("Behaviors")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the user interface behavior when a request is in progress.")]
public InProgressUIBehavior InProgressUIBehavior {get; set;}
Delphi
public read-write property InProgressUIBehavior: InProgressUIBehavior;
JScript
System.ComponentModel.CategoryAttribute("Behaviors")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the user interface behavior when a request is in progress.")
public function get,set InProgressUIBehavior : InProgressUIBehavior
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Behaviors")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the user interface behavior when a request is in progress.")]
public: __property InProgressUIBehavior get_InProgressUIBehavior();
public: __property void set_InProgressUIBehavior(
   InProgressUIBehavior value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Behaviors")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the user interface behavior when a request is in progress.")]
public:
property InProgressUIBehavior InProgressUIBehavior {
   InProgressUIBehavior get();
   void set (    InProgressUIBehavior value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayoutSet Class
LayoutSet Members


LostFocusRowStyle Property

[image]
Intersoft WebGrid Documentation
LostFocusRowStyle Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > LayoutSet Class : LostFocusRowStyle Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("The style applied to the selected row when the focus is out of the grid's area.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.DefaultValueAttribute()>
Public Property LostFocusRowStyle As WebGridFormatStyle
Visual Basic (Usage) Copy Code
Dim instance As LayoutSet
Dim value As WebGridFormatStyle

instance.LostFocusRowStyle = value

value = instance.LostFocusRowStyle
C#
[System.ComponentModel.DescriptionAttribute("The style applied to the selected row when the focus is out of the grid's area.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DefaultValueAttribute()]
public WebGridFormatStyle LostFocusRowStyle {get; set;}
Delphi
public read-write property LostFocusRowStyle: WebGridFormatStyle;
JScript
System.ComponentModel.DescriptionAttribute("The style applied to the selected row when the focus is out of the grid's area.")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
ISNet.Serialization.BinarySerializableAttribute()
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.DefaultValueAttribute()
public function get,set LostFocusRowStyle : WebGridFormatStyle
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("The style applied to the selected row when the focus is out of the grid's area.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DefaultValueAttribute()]
public: __property WebGridFormatStyle* get_LostFocusRowStyle();
public: __property void set_LostFocusRowStyle(
   WebGridFormatStyle* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("The style applied to the selected row when the focus is out of the grid's area.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DefaultValueAttribute()]
public:
property WebGridFormatStyle^ LostFocusRowStyle {
   WebGridFormatStyle^ get();
   void set (    WebGridFormatStyle^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayoutSet Class
LayoutSet Members


MarkDefaultValuesAsDirty Property

[image]
Intersoft WebGrid Documentation
MarkDefaultValuesAsDirty Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > LayoutSet Class : MarkDefaultValuesAsDirty Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies whether the default values in WebGridColumn should cause the new row to be marked as dirty or not.")>
<System.ComponentModel.CategoryAttribute("Editing")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property MarkDefaultValuesAsDirty As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As LayoutSet
Dim value As System.Boolean

instance.MarkDefaultValuesAsDirty = value

value = instance.MarkDefaultValuesAsDirty
C#
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether the default values in WebGridColumn should cause the new row to be marked as dirty or not.")]
[System.ComponentModel.CategoryAttribute("Editing")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.bool MarkDefaultValuesAsDirty {get; set;}
Delphi
public read-write property MarkDefaultValuesAsDirty: System.Boolean;
JScript
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Specifies whether the default values in WebGridColumn should cause the new row to be marked as dirty or not.")
System.ComponentModel.CategoryAttribute("Editing")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set MarkDefaultValuesAsDirty : System.boolean
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether the default values in WebGridColumn should cause the new row to be marked as dirty or not.")]
[System.ComponentModel.CategoryAttribute("Editing")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.bool get_MarkDefaultValuesAsDirty();
public: __property void set_MarkDefaultValuesAsDirty(
   System.bool value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether the default values in WebGridColumn should cause the new row to be marked as dirty or not.")]
[System.ComponentModel.CategoryAttribute("Editing")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.bool MarkDefaultValuesAsDirty {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayoutSet Class
LayoutSet Members


MenuCssFile Property

[image]
Intersoft WebGrid Documentation
MenuCssFile Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > LayoutSet Class : MenuCssFile Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Behaviors")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Gets or sets the CSS file used to control the appearance of context menu. The property should only contains the file name. The location of the file resides in the same folder as ScriptFolder.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property MenuCssFile As System.String
Visual Basic (Usage) Copy Code
Dim instance As LayoutSet
Dim value As System.String

instance.MenuCssFile = value

value = instance.MenuCssFile
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Behaviors")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the CSS file used to control the appearance of context menu. The property should only contains the file name. The location of the file resides in the same folder as ScriptFolder.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public System.string MenuCssFile {get; set;}
Delphi
public read-write property MenuCssFile: System.String;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Behaviors")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the CSS file used to control the appearance of context menu. The property should only contains the file name. The location of the file resides in the same folder as ScriptFolder.")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get,set MenuCssFile : System.String
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Behaviors")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the CSS file used to control the appearance of context menu. The property should only contains the file name. The location of the file resides in the same folder as ScriptFolder.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.string* get_MenuCssFile();
public: __property void set_MenuCssFile(
   System.string* value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Behaviors")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the CSS file used to control the appearance of context menu. The property should only contains the file name. The location of the file resides in the same folder as ScriptFolder.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.String^ MenuCssFile {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayoutSet Class
LayoutSet Members


ModifiedRowStyle Property

[image]
Intersoft WebGrid Documentation
ModifiedRowStyle Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > LayoutSet Class : ModifiedRowStyle Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("The style applied to modified row in batch update mode.")>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
Public Property ModifiedRowStyle As WebGridFormatStyle
Visual Basic (Usage) Copy Code
Dim instance As LayoutSet
Dim value As WebGridFormatStyle

instance.ModifiedRowStyle = value

value = instance.ModifiedRowStyle
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("The style applied to modified row in batch update mode.")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
public WebGridFormatStyle ModifiedRowStyle {get; set;}
Delphi
public read-write property ModifiedRowStyle: WebGridFormatStyle;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("The style applied to modified row in batch update mode.")
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
public function get,set ModifiedRowStyle : WebGridFormatStyle
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("The style applied to modified row in batch update mode.")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
public: __property WebGridFormatStyle* get_ModifiedRowStyle();
public: __property void set_ModifiedRowStyle(
   WebGridFormatStyle* value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("The style applied to modified row in batch update mode.")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
public:
property WebGridFormatStyle^ ModifiedRowStyle {
   WebGridFormatStyle^ get();
   void set (    WebGridFormatStyle^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayoutSet Class
LayoutSet Members


NewRowLostFocusAction Property

[image]
Intersoft WebGrid Documentation
NewRowLostFocusAction Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > LayoutSet Class : NewRowLostFocusAction Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Behaviors")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies the action when the New Row has lose its focus while the contained cells has been changed.")>
Public Property NewRowLostFocusAction As LostFocusMode
Visual Basic (Usage) Copy Code
Dim instance As LayoutSet
Dim value As LostFocusMode

instance.NewRowLostFocusAction = value

value = instance.NewRowLostFocusAction
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behaviors")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the action when the New Row has lose its focus while the contained cells has been changed.")]
public LostFocusMode NewRowLostFocusAction {get; set;}
Delphi
public read-write property NewRowLostFocusAction: LostFocusMode;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Behaviors")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the action when the New Row has lose its focus while the contained cells has been changed.")
public function get,set NewRowLostFocusAction : LostFocusMode
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behaviors")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the action when the New Row has lose its focus while the contained cells has been changed.")]
public: __property LostFocusMode get_NewRowLostFocusAction();
public: __property void set_NewRowLostFocusAction(
   LostFocusMode value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behaviors")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the action when the New Row has lose its focus while the contained cells has been changed.")]
public:
property LostFocusMode NewRowLostFocusAction {
   LostFocusMode get();
   void set (    LostFocusMode value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayoutSet Class
LayoutSet Members


NewRowStyle Property

[image]
Intersoft WebGrid Documentation
NewRowStyle Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > LayoutSet Class : NewRowStyle Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("The style applied to new row.")>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
Public Property NewRowStyle As WebGridFormatStyle
Visual Basic (Usage) Copy Code
Dim instance As LayoutSet
Dim value As WebGridFormatStyle

instance.NewRowStyle = value

value = instance.NewRowStyle
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("The style applied to new row.")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
public WebGridFormatStyle NewRowStyle {get; set;}
Delphi
public read-write property NewRowStyle: WebGridFormatStyle;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("The style applied to new row.")
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
public function get,set NewRowStyle : WebGridFormatStyle
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("The style applied to new row.")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
public: __property WebGridFormatStyle* get_NewRowStyle();
public: __property void set_NewRowStyle(
   WebGridFormatStyle* value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("The style applied to new row.")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
public:
property WebGridFormatStyle^ NewRowStyle {
   WebGridFormatStyle^ get();
   void set (    WebGridFormatStyle^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayoutSet Class
LayoutSet Members


PagingDataRetrievalMode Property

[image]
Intersoft WebGrid Documentation
PagingDataRetrievalMode Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > LayoutSet Class : PagingDataRetrievalMode Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Gets or sets the data retrieval mode when classic paging is used and paging load mode is set to Custom.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Paging")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property PagingDataRetrievalMode As ClassicPagingRetrievalMode
Visual Basic (Usage) Copy Code
Dim instance As LayoutSet
Dim value As ClassicPagingRetrievalMode

instance.PagingDataRetrievalMode = value

value = instance.PagingDataRetrievalMode
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the data retrieval mode when classic paging is used and paging load mode is set to Custom.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Paging")]
[System.ComponentModel.DefaultValueAttribute()]
public ClassicPagingRetrievalMode PagingDataRetrievalMode {get; set;}
Delphi
public read-write property PagingDataRetrievalMode: ClassicPagingRetrievalMode;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the data retrieval mode when classic paging is used and paging load mode is set to Custom.")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Paging")
System.ComponentModel.DefaultValueAttribute()
public function get,set PagingDataRetrievalMode : ClassicPagingRetrievalMode
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the data retrieval mode when classic paging is used and paging load mode is set to Custom.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Paging")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property ClassicPagingRetrievalMode get_PagingDataRetrievalMode();
public: __property void set_PagingDataRetrievalMode(
   ClassicPagingRetrievalMode value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the data retrieval mode when classic paging is used and paging load mode is set to Custom.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Paging")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property ClassicPagingRetrievalMode PagingDataRetrievalMode {
   ClassicPagingRetrievalMode get();
   void set (    ClassicPagingRetrievalMode value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayoutSet Class
LayoutSet Members


PagingDetectPartialGroupRows Property

[image]
Intersoft WebGrid Documentation
PagingDetectPartialGroupRows Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > LayoutSet Class : PagingDetectPartialGroupRows Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Determines whether WebGrid should detect partial group rows when PagingMode is set to ClassicPaging.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("Paging")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property PagingDetectPartialGroupRows As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As LayoutSet
Dim value As System.Boolean

instance.PagingDetectPartialGroupRows = value

value = instance.PagingDetectPartialGroupRows
C#
[System.ComponentModel.DescriptionAttribute("Determines whether WebGrid should detect partial group rows when PagingMode is set to ClassicPaging.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Paging")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public System.bool PagingDetectPartialGroupRows {get; set;}
Delphi
public read-write property PagingDetectPartialGroupRows: System.Boolean;
JScript
System.ComponentModel.DescriptionAttribute("Determines whether WebGrid should detect partial group rows when PagingMode is set to ClassicPaging.")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("Paging")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get,set PagingDetectPartialGroupRows : System.boolean
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Determines whether WebGrid should detect partial group rows when PagingMode is set to ClassicPaging.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Paging")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.bool get_PagingDetectPartialGroupRows();
public: __property void set_PagingDetectPartialGroupRows(
   System.bool value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Determines whether WebGrid should detect partial group rows when PagingMode is set to ClassicPaging.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Paging")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.bool PagingDetectPartialGroupRows {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayoutSet Class
LayoutSet Members


PagingExportMode Property

[image]
Intersoft WebGrid Documentation
PagingExportMode Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > LayoutSet Class : PagingExportMode Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Paging")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies whether WebGrid should export only the current page view or the entire dataset when PagingMode is set to ClassicPaging.")>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Property PagingExportMode As ClassicPagingExportMode
Visual Basic (Usage) Copy Code
Dim instance As LayoutSet
Dim value As ClassicPagingExportMode

instance.PagingExportMode = value

value = instance.PagingExportMode
C#
[System.ComponentModel.CategoryAttribute("Paging")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether WebGrid should export only the current page view or the entire dataset when PagingMode is set to ClassicPaging.")]
[ISNet.Serialization.XmlSerializableAttribute()]
public ClassicPagingExportMode PagingExportMode {get; set;}
Delphi
public read-write property PagingExportMode: ClassicPagingExportMode;
JScript
System.ComponentModel.CategoryAttribute("Paging")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Specifies whether WebGrid should export only the current page view or the entire dataset when PagingMode is set to ClassicPaging.")
ISNet.Serialization.XmlSerializableAttribute()
public function get,set PagingExportMode : ClassicPagingExportMode
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Paging")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether WebGrid should export only the current page view or the entire dataset when PagingMode is set to ClassicPaging.")]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property ClassicPagingExportMode get_PagingExportMode();
public: __property void set_PagingExportMode(
   ClassicPagingExportMode value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Paging")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether WebGrid should export only the current page view or the entire dataset when PagingMode is set to ClassicPaging.")]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property ClassicPagingExportMode PagingExportMode {
   ClassicPagingExportMode get();
   void set (    ClassicPagingExportMode value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayoutSet Class
LayoutSet Members


PagingLatencyOnSlide Property

[image]
Intersoft WebGrid Documentation
PagingLatencyOnSlide Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > LayoutSet Class : PagingLatencyOnSlide Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies the time to wait (in milliseconds) before data fetching when the slidebar of the paging UI is being dragged (changed). Only applies when PagingMode is set to ClassicPaging and PagingStyleUI is set to Slider.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("Paging")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property PagingLatencyOnSlide As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As LayoutSet
Dim value As System.Integer

instance.PagingLatencyOnSlide = value

value = instance.PagingLatencyOnSlide
C#
[System.ComponentModel.DescriptionAttribute("Specifies the time to wait (in milliseconds) before data fetching when the slidebar of the paging UI is being dragged (changed). Only applies when PagingMode is set to ClassicPaging and PagingStyleUI is set to Slider.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Paging")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public System.int PagingLatencyOnSlide {get; set;}
Delphi
public read-write property PagingLatencyOnSlide: System.Integer;
JScript
System.ComponentModel.DescriptionAttribute("Specifies the time to wait (in milliseconds) before data fetching when the slidebar of the paging UI is being dragged (changed). Only applies when PagingMode is set to ClassicPaging and PagingStyleUI is set to Slider.")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("Paging")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get,set PagingLatencyOnSlide : System.int
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies the time to wait (in milliseconds) before data fetching when the slidebar of the paging UI is being dragged (changed). Only applies when PagingMode is set to ClassicPaging and PagingStyleUI is set to Slider.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Paging")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.int get_PagingLatencyOnSlide();
public: __property void set_PagingLatencyOnSlide(
   System.int value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies the time to wait (in milliseconds) before data fetching when the slidebar of the paging UI is being dragged (changed). Only applies when PagingMode is set to ClassicPaging and PagingStyleUI is set to Slider.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Paging")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.int PagingLatencyOnSlide {
   System.int get();
   void set (    System.int value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayoutSet Class
LayoutSet Members


PagingLoadMode Property

[image]
Intersoft WebGrid Documentation
PagingLoadMode Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > LayoutSet Class : PagingLoadMode Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Paging")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies the data paging mode when PagingMode is set to ClassicPaging. For custom data paging retrieval, please set this property to Custom.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property PagingLoadMode As ClassicPagingLoadMode
Visual Basic (Usage) Copy Code
Dim instance As LayoutSet
Dim value As ClassicPagingLoadMode

instance.PagingLoadMode = value

value = instance.PagingLoadMode
C#
[System.ComponentModel.CategoryAttribute("Paging")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the data paging mode when PagingMode is set to ClassicPaging. For custom data paging retrieval, please set this property to Custom.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public ClassicPagingLoadMode PagingLoadMode {get; set;}
Delphi
public read-write property PagingLoadMode: ClassicPagingLoadMode;
JScript
System.ComponentModel.CategoryAttribute("Paging")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the data paging mode when PagingMode is set to ClassicPaging. For custom data paging retrieval, please set this property to Custom.")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get,set PagingLoadMode : ClassicPagingLoadMode
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Paging")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the data paging mode when PagingMode is set to ClassicPaging. For custom data paging retrieval, please set this property to Custom.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property ClassicPagingLoadMode get_PagingLoadMode();
public: __property void set_PagingLoadMode(
   ClassicPagingLoadMode value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Paging")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the data paging mode when PagingMode is set to ClassicPaging. For custom data paging retrieval, please set this property to Custom.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property ClassicPagingLoadMode PagingLoadMode {
   ClassicPagingLoadMode get();
   void set (    ClassicPagingLoadMode value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayoutSet Class
LayoutSet Members


PagingMode Property

[image]
Intersoft WebGrid Documentation
PagingMode Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > LayoutSet Class : PagingMode Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Paging")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Specified the paging mode that control the rows retrieval behavior in WebGrid.")>
Public Property PagingMode As PagingMode
Visual Basic (Usage) Copy Code
Dim instance As LayoutSet
Dim value As PagingMode

instance.PagingMode = value

value = instance.PagingMode
C#
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Paging")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specified the paging mode that control the rows retrieval behavior in WebGrid.")]
public PagingMode PagingMode {get; set;}
Delphi
public read-write property PagingMode: PagingMode;
JScript
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Paging")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Specified the paging mode that control the rows retrieval behavior in WebGrid.")
public function get,set PagingMode : PagingMode
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Paging")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specified the paging mode that control the rows retrieval behavior in WebGrid.")]
public: __property PagingMode get_PagingMode();
public: __property void set_PagingMode(
   PagingMode value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Paging")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specified the paging mode that control the rows retrieval behavior in WebGrid.")]
public:
property PagingMode PagingMode {
   PagingMode get();
   void set (    PagingMode value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayoutSet Class
LayoutSet Members


PagingSize Property

[image]
Intersoft WebGrid Documentation
PagingSize Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > LayoutSet Class : PagingSize Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Gets or sets the number of viewable records in a page when PagingMode is set to ClassicPaging.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Paging")>
Public Property PagingSize As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As LayoutSet
Dim value As System.Integer

instance.PagingSize = value

value = instance.PagingSize
C#
[System.ComponentModel.DescriptionAttribute("Gets or sets the number of viewable records in a page when PagingMode is set to ClassicPaging.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Paging")]
public System.int PagingSize {get; set;}
Delphi
public read-write property PagingSize: System.Integer;
JScript
System.ComponentModel.DescriptionAttribute("Gets or sets the number of viewable records in a page when PagingMode is set to ClassicPaging.")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Paging")
public function get,set PagingSize : System.int
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Gets or sets the number of viewable records in a page when PagingMode is set to ClassicPaging.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Paging")]
public: __property System.int get_PagingSize();
public: __property void set_PagingSize(
   System.int value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Gets or sets the number of viewable records in a page when PagingMode is set to ClassicPaging.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Paging")]
public:
property System.int PagingSize {
   System.int get();
   void set (    System.int value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayoutSet Class
LayoutSet Members


PagingSliderWidth Property

[image]
Intersoft WebGrid Documentation
PagingSliderWidth Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > LayoutSet Class : PagingSliderWidth Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Paging")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies the slider bar width in pixel, when PagingMode is set to ClassicPaging and PagingStyleUI is set to Slider.")>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Property PagingSliderWidth As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As LayoutSet
Dim value As System.Integer

instance.PagingSliderWidth = value

value = instance.PagingSliderWidth
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Paging")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the slider bar width in pixel, when PagingMode is set to ClassicPaging and PagingStyleUI is set to Slider.")]
[ISNet.Serialization.XmlSerializableAttribute()]
public System.int PagingSliderWidth {get; set;}
Delphi
public read-write property PagingSliderWidth: System.Integer;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Paging")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the slider bar width in pixel, when PagingMode is set to ClassicPaging and PagingStyleUI is set to Slider.")
ISNet.Serialization.XmlSerializableAttribute()
public function get,set PagingSliderWidth : System.int
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Paging")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the slider bar width in pixel, when PagingMode is set to ClassicPaging and PagingStyleUI is set to Slider.")]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property System.int get_PagingSliderWidth();
public: __property void set_PagingSliderWidth(
   System.int value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Paging")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the slider bar width in pixel, when PagingMode is set to ClassicPaging and PagingStyleUI is set to Slider.")]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property System.int PagingSliderWidth {
   System.int get();
   void set (    System.int value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayoutSet Class
LayoutSet Members


PagingStyleUI Property

[image]
Intersoft WebGrid Documentation
PagingStyleUI Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > LayoutSet Class : PagingStyleUI Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Paging")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Gets or sets the user interface style for the paging when PagingMode is set to ClassicPaging.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property PagingStyleUI As ClassicPagingStyle
Visual Basic (Usage) Copy Code
Dim instance As LayoutSet
Dim value As ClassicPagingStyle

instance.PagingStyleUI = value

value = instance.PagingStyleUI
C#
[System.ComponentModel.CategoryAttribute("Paging")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the user interface style for the paging when PagingMode is set to ClassicPaging.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public ClassicPagingStyle PagingStyleUI {get; set;}
Delphi
public read-write property PagingStyleUI: ClassicPagingStyle;
JScript
System.ComponentModel.CategoryAttribute("Paging")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the user interface style for the paging when PagingMode is set to ClassicPaging.")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get,set PagingStyleUI : ClassicPagingStyle
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Paging")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the user interface style for the paging when PagingMode is set to ClassicPaging.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property ClassicPagingStyle get_PagingStyleUI();
public: __property void set_PagingStyleUI(
   ClassicPagingStyle value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Paging")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the user interface style for the paging when PagingMode is set to ClassicPaging.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property ClassicPagingStyle PagingStyleUI {
   ClassicPagingStyle get();
   void set (    ClassicPagingStyle value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayoutSet Class
LayoutSet Members


PersistRowChecker Property

[image]
Intersoft WebGrid Documentation
PersistRowChecker Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > LayoutSet Class : PersistRowChecker Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Behaviors")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies whether the grid should persist the rows' RowChecker state during full postback.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property PersistRowChecker As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As LayoutSet
Dim value As System.Boolean

instance.PersistRowChecker = value

value = instance.PersistRowChecker
C#
[System.ComponentModel.CategoryAttribute("Behaviors")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether the grid should persist the rows' RowChecker state during full postback.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public System.bool PersistRowChecker {get; set;}
Delphi
public read-write property PersistRowChecker: System.Boolean;
JScript
System.ComponentModel.CategoryAttribute("Behaviors")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Specifies whether the grid should persist the rows' RowChecker state during full postback.")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get,set PersistRowChecker : System.boolean
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Behaviors")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether the grid should persist the rows' RowChecker state during full postback.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.bool get_PersistRowChecker();
public: __property void set_PersistRowChecker(
   System.bool value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Behaviors")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether the grid should persist the rows' RowChecker state during full postback.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.bool PersistRowChecker {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayoutSet Class
LayoutSet Members


PersistValueListOnCopy Property

[image]
Intersoft WebGrid Documentation
PersistValueListOnCopy Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > LayoutSet Class : PersistValueListOnCopy Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Behaviors")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies whether the cell's value should be persisted during copy and paste operation.")>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property PersistValueListOnCopy As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As LayoutSet
Dim value As System.Boolean

instance.PersistValueListOnCopy = value

value = instance.PersistValueListOnCopy
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Behaviors")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether the cell's value should be persisted during copy and paste operation.")]
[ISNet.Serialization.BinarySerializableAttribute()]
public System.bool PersistValueListOnCopy {get; set;}
Delphi
public read-write property PersistValueListOnCopy: System.Boolean;
JScript
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Behaviors")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Specifies whether the cell's value should be persisted during copy and paste operation.")
ISNet.Serialization.BinarySerializableAttribute()
public function get,set PersistValueListOnCopy : System.boolean
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Behaviors")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether the cell's value should be persisted during copy and paste operation.")]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.bool get_PersistValueListOnCopy();
public: __property void set_PersistValueListOnCopy(
   System.bool value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Behaviors")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether the cell's value should be persisted during copy and paste operation.")]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.bool PersistValueListOnCopy {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayoutSet Class
LayoutSet Members


PreviewRowStyle Property

[image]
Intersoft WebGrid Documentation
PreviewRowStyle Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > LayoutSet Class : PreviewRowStyle Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("The style applied to preview row area.")>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property PreviewRowStyle As WebGridFormatStyle
Visual Basic (Usage) Copy Code
Dim instance As LayoutSet
Dim value As WebGridFormatStyle

instance.PreviewRowStyle = value

value = instance.PreviewRowStyle
C#
[System.ComponentModel.DescriptionAttribute("The style applied to preview row area.")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public WebGridFormatStyle PreviewRowStyle {get; set;}
Delphi
public read-write property PreviewRowStyle: WebGridFormatStyle;
JScript
System.ComponentModel.DescriptionAttribute("The style applied to preview row area.")
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set PreviewRowStyle : WebGridFormatStyle
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("The style applied to preview row area.")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property WebGridFormatStyle* get_PreviewRowStyle();
public: __property void set_PreviewRowStyle(
   WebGridFormatStyle* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("The style applied to preview row area.")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property WebGridFormatStyle^ PreviewRowStyle {
   WebGridFormatStyle^ get();
   void set (    WebGridFormatStyle^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayoutSet Class
LayoutSet Members


PromptBeforeDelete Property

[image]
Intersoft WebGrid Documentation
PromptBeforeDelete Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > LayoutSet Class : PromptBeforeDelete Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Behaviors")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies whether or not to display a confirmation box before deleting a row.")>
Public Property PromptBeforeDelete As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As LayoutSet
Dim value As System.Boolean

instance.PromptBeforeDelete = value

value = instance.PromptBeforeDelete
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behaviors")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether or not to display a confirmation box before deleting a row.")]
public System.bool PromptBeforeDelete {get; set;}
Delphi
public read-write property PromptBeforeDelete: System.Boolean;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.CategoryAttribute("Behaviors")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Specifies whether or not to display a confirmation box before deleting a row.")
public function get,set PromptBeforeDelete : System.boolean
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behaviors")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether or not to display a confirmation box before deleting a row.")]
public: __property System.bool get_PromptBeforeDelete();
public: __property void set_PromptBeforeDelete(
   System.bool value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behaviors")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether or not to display a confirmation box before deleting a row.")]
public:
property System.bool PromptBeforeDelete {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayoutSet Class
LayoutSet Members


QuickFilterBarStyle Property

[image]
Intersoft WebGrid Documentation
QuickFilterBarStyle Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > LayoutSet Class : QuickFilterBarStyle Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("The style applied to the quick filter bar.")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
Public Property QuickFilterBarStyle As WebGridFormatStyle
Visual Basic (Usage) Copy Code
Dim instance As LayoutSet
Dim value As WebGridFormatStyle

instance.QuickFilterBarStyle = value

value = instance.QuickFilterBarStyle
C#
[System.ComponentModel.DescriptionAttribute("The style applied to the quick filter bar.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
public WebGridFormatStyle QuickFilterBarStyle {get; set;}
Delphi
public read-write property QuickFilterBarStyle: WebGridFormatStyle;
JScript
System.ComponentModel.DescriptionAttribute("The style applied to the quick filter bar.")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
public function get,set QuickFilterBarStyle : WebGridFormatStyle
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("The style applied to the quick filter bar.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
public: __property WebGridFormatStyle* get_QuickFilterBarStyle();
public: __property void set_QuickFilterBarStyle(
   WebGridFormatStyle* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("The style applied to the quick filter bar.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
public:
property WebGridFormatStyle^ QuickFilterBarStyle {
   WebGridFormatStyle^ get();
   void set (    WebGridFormatStyle^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayoutSet Class
LayoutSet Members


ResetNewRowValuesOnError Property

[image]
Intersoft WebGrid Documentation
ResetNewRowValuesOnError Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > LayoutSet Class : ResetNewRowValuesOnError Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Gets or sets the custom filtering string.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Behaviors")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property ResetNewRowValuesOnError As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As LayoutSet
Dim value As System.Boolean

instance.ResetNewRowValuesOnError = value

value = instance.ResetNewRowValuesOnError
C#
[System.ComponentModel.DescriptionAttribute("Gets or sets the custom filtering string.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behaviors")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.bool ResetNewRowValuesOnError {get; set;}
Delphi
public read-write property ResetNewRowValuesOnError: System.Boolean;
JScript
System.ComponentModel.DescriptionAttribute("Gets or sets the custom filtering string.")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Behaviors")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set ResetNewRowValuesOnError : System.boolean
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Gets or sets the custom filtering string.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behaviors")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.bool get_ResetNewRowValuesOnError();
public: __property void set_ResetNewRowValuesOnError(
   System.bool value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Gets or sets the custom filtering string.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behaviors")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.bool ResetNewRowValuesOnError {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayoutSet Class
LayoutSet Members


RestoreExpandedChildRows Property

[image]
Intersoft WebGrid Documentation
RestoreExpandedChildRows Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > LayoutSet Class : RestoreExpandedChildRows Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Behaviors")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies whether expanded child rows should be automatically restored after FlyPostBack/FullPostBack actions.")>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Property RestoreExpandedChildRows As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As LayoutSet
Dim value As System.Boolean

instance.RestoreExpandedChildRows = value

value = instance.RestoreExpandedChildRows
C#
[System.ComponentModel.CategoryAttribute("Behaviors")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether expanded child rows should be automatically restored after FlyPostBack/FullPostBack actions.")]
[ISNet.Serialization.XmlSerializableAttribute()]
public System.bool RestoreExpandedChildRows {get; set;}
Delphi
public read-write property RestoreExpandedChildRows: System.Boolean;
JScript
System.ComponentModel.CategoryAttribute("Behaviors")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Specifies whether expanded child rows should be automatically restored after FlyPostBack/FullPostBack actions.")
ISNet.Serialization.XmlSerializableAttribute()
public function get,set RestoreExpandedChildRows : System.boolean
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Behaviors")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether expanded child rows should be automatically restored after FlyPostBack/FullPostBack actions.")]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property System.bool get_RestoreExpandedChildRows();
public: __property void set_RestoreExpandedChildRows(
   System.bool value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Behaviors")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether expanded child rows should be automatically restored after FlyPostBack/FullPostBack actions.")]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property System.bool RestoreExpandedChildRows {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayoutSet Class
LayoutSet Members


RestoreRowSelection Property

[image]
Intersoft WebGrid Documentation
RestoreRowSelection Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > LayoutSet Class : RestoreRowSelection Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("Behaviors")>
<System.ComponentModel.DescriptionAttribute("Determines whether WebGrid should automatically restore multiple row selection state after FlyPostBack actions.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Property RestoreRowSelection As RestoreSelection
Visual Basic (Usage) Copy Code
Dim instance As LayoutSet
Dim value As RestoreSelection

instance.RestoreRowSelection = value

value = instance.RestoreRowSelection
C#
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Behaviors")]
[System.ComponentModel.DescriptionAttribute("Determines whether WebGrid should automatically restore multiple row selection state after FlyPostBack actions.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
public RestoreSelection RestoreRowSelection {get; set;}
Delphi
public read-write property RestoreRowSelection: RestoreSelection;
JScript
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("Behaviors")
System.ComponentModel.DescriptionAttribute("Determines whether WebGrid should automatically restore multiple row selection state after FlyPostBack actions.")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.XmlSerializableAttribute()
public function get,set RestoreRowSelection : RestoreSelection
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Behaviors")]
[System.ComponentModel.DescriptionAttribute("Determines whether WebGrid should automatically restore multiple row selection state after FlyPostBack actions.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property RestoreSelection get_RestoreRowSelection();
public: __property void set_RestoreRowSelection(
   RestoreSelection value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Behaviors")]
[System.ComponentModel.DescriptionAttribute("Determines whether WebGrid should automatically restore multiple row selection state after FlyPostBack actions.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property RestoreSelection RestoreRowSelection {
   RestoreSelection get();
   void set (    RestoreSelection value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayoutSet Class
LayoutSet Members


RowChangedAction Property

[image]
Intersoft WebGrid Documentation
RowChangedAction Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > LayoutSet Class : RowChangedAction Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Gets or sets the action that should be performed when user changed the selected row in WebGrid.")>
<System.ComponentModel.CategoryAttribute("Behaviors")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property RowChangedAction As RowChangedAction
Visual Basic (Usage) Copy Code
Dim instance As LayoutSet
Dim value As RowChangedAction

instance.RowChangedAction = value

value = instance.RowChangedAction
C#
[System.ComponentModel.DescriptionAttribute("Gets or sets the action that should be performed when user changed the selected row in WebGrid.")]
[System.ComponentModel.CategoryAttribute("Behaviors")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public RowChangedAction RowChangedAction {get; set;}
Delphi
public read-write property RowChangedAction: RowChangedAction;
JScript
System.ComponentModel.DescriptionAttribute("Gets or sets the action that should be performed when user changed the selected row in WebGrid.")
System.ComponentModel.CategoryAttribute("Behaviors")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get,set RowChangedAction : RowChangedAction
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Gets or sets the action that should be performed when user changed the selected row in WebGrid.")]
[System.ComponentModel.CategoryAttribute("Behaviors")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property RowChangedAction get_RowChangedAction();
public: __property void set_RowChangedAction(
   RowChangedAction value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Gets or sets the action that should be performed when user changed the selected row in WebGrid.")]
[System.ComponentModel.CategoryAttribute("Behaviors")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property RowChangedAction RowChangedAction {
   RowChangedAction get();
   void set (    RowChangedAction value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayoutSet Class
LayoutSet Members


RowHeaders Property

[image]
Intersoft WebGrid Documentation
RowHeaders Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > LayoutSet Class : RowHeaders Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies whether or not to display row's header.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Behaviors")>
Public Property RowHeaders As RowHeaders
Visual Basic (Usage) Copy Code
Dim instance As LayoutSet
Dim value As RowHeaders

instance.RowHeaders = value

value = instance.RowHeaders
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether or not to display row's header.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behaviors")]
public RowHeaders RowHeaders {get; set;}
Delphi
public read-write property RowHeaders: RowHeaders;
JScript
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Specifies whether or not to display row's header.")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Behaviors")
public function get,set RowHeaders : RowHeaders
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether or not to display row's header.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behaviors")]
public: __property RowHeaders get_RowHeaders();
public: __property void set_RowHeaders(
   RowHeaders value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether or not to display row's header.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behaviors")]
public:
property RowHeaders RowHeaders {
   RowHeaders get();
   void set (    RowHeaders value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayoutSet Class
LayoutSet Members


RowHeaderStyle Property

[image]
Intersoft WebGrid Documentation
RowHeaderStyle Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > LayoutSet Class : RowHeaderStyle Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("The style applied to the row's header.")>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property RowHeaderStyle As WebGridFormatStyle
Visual Basic (Usage) Copy Code
Dim instance As LayoutSet
Dim value As WebGridFormatStyle

instance.RowHeaderStyle = value

value = instance.RowHeaderStyle
C#
[System.ComponentModel.DescriptionAttribute("The style applied to the row's header.")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public WebGridFormatStyle RowHeaderStyle {get; set;}
Delphi
public read-write property RowHeaderStyle: WebGridFormatStyle;
JScript
System.ComponentModel.DescriptionAttribute("The style applied to the row's header.")
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set RowHeaderStyle : WebGridFormatStyle
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("The style applied to the row's header.")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property WebGridFormatStyle* get_RowHeaderStyle();
public: __property void set_RowHeaderStyle(
   WebGridFormatStyle* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("The style applied to the row's header.")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property WebGridFormatStyle^ RowHeaderStyle {
   WebGridFormatStyle^ get();
   void set (    WebGridFormatStyle^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayoutSet Class
LayoutSet Members


RowHeaderWidth Property

[image]
Intersoft WebGrid Documentation
RowHeaderWidth Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > LayoutSet Class : RowHeaderWidth Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Behaviors")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies the width of RowHeader in pixel.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.MarkAsStyleAttribute(True)>
Public Property RowHeaderWidth As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As LayoutSet
Dim value As System.Integer

instance.RowHeaderWidth = value

value = instance.RowHeaderWidth
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behaviors")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the width of RowHeader in pixel.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.MarkAsStyleAttribute(true)]
public System.int RowHeaderWidth {get; set;}
Delphi
public read-write property RowHeaderWidth: System.Integer;
JScript
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.CategoryAttribute("Behaviors")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the width of RowHeader in pixel.")
ISNet.Serialization.BinarySerializableAttribute()
ISNet.MarkAsStyleAttribute()
public function get,set RowHeaderWidth : System.int
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behaviors")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the width of RowHeader in pixel.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.MarkAsStyleAttribute(true)]
public: __property System.int get_RowHeaderWidth();
public: __property void set_RowHeaderWidth(
   System.int value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behaviors")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the width of RowHeader in pixel.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.MarkAsStyleAttribute(true)]
public:
property System.int RowHeaderWidth {
   System.int get();
   void set (    System.int value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayoutSet Class
LayoutSet Members


RowHeightDefault Property

[image]
Intersoft WebGrid Documentation
RowHeightDefault Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > LayoutSet Class : RowHeightDefault Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Behaviors")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Specifies the default row height in Unit.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.MarkAsStyleAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
Public Property RowHeightDefault As System.Web.UI.WebControls.Unit
Visual Basic (Usage) Copy Code
Dim instance As LayoutSet
Dim value As System.Web.UI.WebControls.Unit

instance.RowHeightDefault = value

value = instance.RowHeightDefault
C#
[System.ComponentModel.CategoryAttribute("Behaviors")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the default row height in Unit.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.MarkAsStyleAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public System.Web.UI.WebControls.Unit RowHeightDefault {get; set;}
Delphi
public read-write property RowHeightDefault: System.Web.UI.WebControls.Unit;
JScript
System.ComponentModel.CategoryAttribute("Behaviors")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the default row height in Unit.")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
ISNet.MarkAsStyleAttribute()
System.ComponentModel.DefaultValueAttribute()
public function get,set RowHeightDefault : System.Web.UI.WebControls.Unit
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Behaviors")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the default row height in Unit.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.MarkAsStyleAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.Web.UI.WebControls.Unit get_RowHeightDefault();
public: __property void set_RowHeightDefault(
   System.Web.UI.WebControls.Unit value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Behaviors")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the default row height in Unit.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.MarkAsStyleAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.Web.UI.WebControls.Unit RowHeightDefault {
   System.Web.UI.WebControls.Unit get();
   void set (    System.Web.UI.WebControls.Unit value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayoutSet Class
LayoutSet Members


RowHighlightType Property

[image]
Intersoft WebGrid Documentation
RowHighlightType Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > LayoutSet Class : RowHighlightType Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Behaviors")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Gets or sets a value that determine the highlight type when a row is selected. This property is only applicable when CellClickAction is set to RowSelect.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property RowHighlightType As RowHighlightType
Visual Basic (Usage) Copy Code
Dim instance As LayoutSet
Dim value As RowHighlightType

instance.RowHighlightType = value

value = instance.RowHighlightType
C#
[System.ComponentModel.CategoryAttribute("Behaviors")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets a value that determine the highlight type when a row is selected. This property is only applicable when CellClickAction is set to RowSelect.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public RowHighlightType RowHighlightType {get; set;}
Delphi
public read-write property RowHighlightType: RowHighlightType;
JScript
System.ComponentModel.CategoryAttribute("Behaviors")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets a value that determine the highlight type when a row is selected. This property is only applicable when CellClickAction is set to RowSelect.")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get,set RowHighlightType : RowHighlightType
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Behaviors")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets a value that determine the highlight type when a row is selected. This property is only applicable when CellClickAction is set to RowSelect.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property RowHighlightType get_RowHighlightType();
public: __property void set_RowHighlightType(
   RowHighlightType value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Behaviors")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets a value that determine the highlight type when a row is selected. This property is only applicable when CellClickAction is set to RowSelect.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property RowHighlightType RowHighlightType {
   RowHighlightType get();
   void set (    RowHighlightType value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayoutSet Class
LayoutSet Members


RowLostFocusAction Property

[image]
Intersoft WebGrid Documentation
RowLostFocusAction Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > LayoutSet Class : RowLostFocusAction Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies the action when the row has lose its focus while the contained cells has been changed.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Behaviors")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property RowLostFocusAction As LostFocusMode
Visual Basic (Usage) Copy Code
Dim instance As LayoutSet
Dim value As LostFocusMode

instance.RowLostFocusAction = value

value = instance.RowLostFocusAction
C#
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the action when the row has lose its focus while the contained cells has been changed.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behaviors")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public LostFocusMode RowLostFocusAction {get; set;}
Delphi
public read-write property RowLostFocusAction: LostFocusMode;
JScript
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the action when the row has lose its focus while the contained cells has been changed.")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Behaviors")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set RowLostFocusAction : LostFocusMode
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the action when the row has lose its focus while the contained cells has been changed.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behaviors")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property LostFocusMode get_RowLostFocusAction();
public: __property void set_RowLostFocusAction(
   LostFocusMode value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the action when the row has lose its focus while the contained cells has been changed.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behaviors")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property LostFocusMode RowLostFocusAction {
   LostFocusMode get();
   void set (    LostFocusMode value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayoutSet Class
LayoutSet Members


RowStyle Property

[image]
Intersoft WebGrid Documentation
RowStyle Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > LayoutSet Class : RowStyle Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("he styles used to display WebGridRow object.")>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
Public Property RowStyle As WebGridFormatStyle
Visual Basic (Usage) Copy Code
Dim instance As LayoutSet
Dim value As WebGridFormatStyle

instance.RowStyle = value

value = instance.RowStyle
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("he styles used to display WebGridRow object.")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
public WebGridFormatStyle RowStyle {get; set;}
Delphi
public read-write property RowStyle: WebGridFormatStyle;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("he styles used to display WebGridRow object.")
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
public function get,set RowStyle : WebGridFormatStyle
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("he styles used to display WebGridRow object.")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
public: __property WebGridFormatStyle* get_RowStyle();
public: __property void set_RowStyle(
   WebGridFormatStyle* value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("he styles used to display WebGridRow object.")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
public:
property WebGridFormatStyle^ RowStyle {
   WebGridFormatStyle^ get();
   void set (    WebGridFormatStyle^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayoutSet Class
LayoutSet Members


ScriptDirectory Property

[image]
Intersoft WebGrid Documentation
ScriptDirectory Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > LayoutSet Class : ScriptDirectory Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Client Script Directory")>
<ISNet.PersistLayoutAttribute(False)>
<System.ComponentModel.DescriptionAttribute("This property is available for backward compabitility with V3.x only. This property is linked to WebGrid.ScriptDirectory directly.")>
Public Property ScriptDirectory As System.String
Visual Basic (Usage) Copy Code
Dim instance As LayoutSet
Dim value As System.String

instance.ScriptDirectory = value

value = instance.ScriptDirectory
C#
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Client Script Directory")]
[ISNet.PersistLayoutAttribute(false)]
[System.ComponentModel.DescriptionAttribute("This property is available for backward compabitility with V3.x only. This property is linked to WebGrid.ScriptDirectory directly.")]
public System.string ScriptDirectory {get; set;}
Delphi
public read-write property ScriptDirectory: System.String;
JScript
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Client Script Directory")
ISNet.PersistLayoutAttribute()
System.ComponentModel.DescriptionAttribute("This property is available for backward compabitility with V3.x only. This property is linked to WebGrid.ScriptDirectory directly.")
public function get,set ScriptDirectory : System.String
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Client Script Directory")]
[ISNet.PersistLayoutAttribute(false)]
[System.ComponentModel.DescriptionAttribute("This property is available for backward compabitility with V3.x only. This property is linked to WebGrid.ScriptDirectory directly.")]
public: __property System.string* get_ScriptDirectory();
public: __property void set_ScriptDirectory(
   System.string* value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Client Script Directory")]
[ISNet.PersistLayoutAttribute(false)]
[System.ComponentModel.DescriptionAttribute("This property is available for backward compabitility with V3.x only. This property is linked to WebGrid.ScriptDirectory directly.")]
public:
property System.String^ ScriptDirectory {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayoutSet Class
LayoutSet Members


ScrollBarStyle Property

[image]
Intersoft WebGrid Documentation
ScrollBarStyle Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > LayoutSet Class : ScrollBarStyle Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.CategoryAttribute("Appearance")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("The style of the grid's scrollbar.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
Public Property ScrollBarStyle As WebGridScrollBarStyle
Visual Basic (Usage) Copy Code
Dim instance As LayoutSet
Dim value As WebGridScrollBarStyle

instance.ScrollBarStyle = value

value = instance.ScrollBarStyle
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.CategoryAttribute("Appearance")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("The style of the grid's scrollbar.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
public WebGridScrollBarStyle ScrollBarStyle {get; set;}
Delphi
public read-write property ScrollBarStyle: WebGridScrollBarStyle;
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.CategoryAttribute("Appearance")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("The style of the grid's scrollbar.")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
public function get,set ScrollBarStyle : WebGridScrollBarStyle
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.CategoryAttribute("Appearance")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("The style of the grid's scrollbar.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
public: __property WebGridScrollBarStyle* get_ScrollBarStyle();
public: __property void set_ScrollBarStyle(
   WebGridScrollBarStyle* value
);
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.CategoryAttribute("Appearance")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("The style of the grid's scrollbar.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
public:
property WebGridScrollBarStyle^ ScrollBarStyle {
   WebGridScrollBarStyle^ get();
   void set (    WebGridScrollBarStyle^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayoutSet Class
LayoutSet Members


SelectedRowStyle Property

[image]
Intersoft WebGrid Documentation
SelectedRowStyle Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > LayoutSet Class : SelectedRowStyle Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("The style used to highlight selected row or cell.")>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
Public Property SelectedRowStyle As WebGridFormatStyle
Visual Basic (Usage) Copy Code
Dim instance As LayoutSet
Dim value As WebGridFormatStyle

instance.SelectedRowStyle = value

value = instance.SelectedRowStyle
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("The style used to highlight selected row or cell.")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
public WebGridFormatStyle SelectedRowStyle {get; set;}
Delphi
public read-write property SelectedRowStyle: WebGridFormatStyle;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("The style used to highlight selected row or cell.")
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
public function get,set SelectedRowStyle : WebGridFormatStyle
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("The style used to highlight selected row or cell.")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
public: __property WebGridFormatStyle* get_SelectedRowStyle();
public: __property void set_SelectedRowStyle(
   WebGridFormatStyle* value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("The style used to highlight selected row or cell.")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
public:
property WebGridFormatStyle^ SelectedRowStyle {
   WebGridFormatStyle^ get();
   void set (    WebGridFormatStyle^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayoutSet Class
LayoutSet Members


SelectFirstCellOnAdd Property

[image]
Intersoft WebGrid Documentation
SelectFirstCellOnAdd Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > LayoutSet Class : SelectFirstCellOnAdd Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Editing")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies whether the first editable cell should be focused after a successful add operation.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property SelectFirstCellOnAdd As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As LayoutSet
Dim value As System.Boolean

instance.SelectFirstCellOnAdd = value

value = instance.SelectFirstCellOnAdd
C#
[System.ComponentModel.CategoryAttribute("Editing")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether the first editable cell should be focused after a successful add operation.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public System.bool SelectFirstCellOnAdd {get; set;}
Delphi
public read-write property SelectFirstCellOnAdd: System.Boolean;
JScript
System.ComponentModel.CategoryAttribute("Editing")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Specifies whether the first editable cell should be focused after a successful add operation.")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get,set SelectFirstCellOnAdd : System.boolean
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Editing")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether the first editable cell should be focused after a successful add operation.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.bool get_SelectFirstCellOnAdd();
public: __property void set_SelectFirstCellOnAdd(
   System.bool value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Editing")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether the first editable cell should be focused after a successful add operation.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.bool SelectFirstCellOnAdd {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayoutSet Class
LayoutSet Members


ShowColumnAction Property

[image]
Intersoft WebGrid Documentation
ShowColumnAction Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > LayoutSet Class : ShowColumnAction Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies whether the action indicator should be displayed when the column is hovered.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Behaviors")>
Public Property ShowColumnAction As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As LayoutSet
Dim value As System.Boolean

instance.ShowColumnAction = value

value = instance.ShowColumnAction
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether the action indicator should be displayed when the column is hovered.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behaviors")]
public System.bool ShowColumnAction {get; set;}
Delphi
public read-write property ShowColumnAction: System.Boolean;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Specifies whether the action indicator should be displayed when the column is hovered.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.CategoryAttribute("Behaviors")
public function get,set ShowColumnAction : System.boolean
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether the action indicator should be displayed when the column is hovered.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behaviors")]
public: __property System.bool get_ShowColumnAction();
public: __property void set_ShowColumnAction(
   System.bool value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether the action indicator should be displayed when the column is hovered.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behaviors")]
public:
property System.bool ShowColumnAction {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayoutSet Class
LayoutSet Members


ShowFilterStatus Property

[image]
Intersoft WebGrid Documentation
ShowFilterStatus Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > LayoutSet Class : ShowFilterStatus Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies whether current filter status should be displayed in Grid's status bar.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Behaviors")>
Public Property ShowFilterStatus As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As LayoutSet
Dim value As System.Boolean

instance.ShowFilterStatus = value

value = instance.ShowFilterStatus
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether current filter status should be displayed in Grid's status bar.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behaviors")]
public System.bool ShowFilterStatus {get; set;}
Delphi
public read-write property ShowFilterStatus: System.Boolean;
JScript
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Specifies whether current filter status should be displayed in Grid's status bar.")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Behaviors")
public function get,set ShowFilterStatus : System.boolean
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether current filter status should be displayed in Grid's status bar.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behaviors")]
public: __property System.bool get_ShowFilterStatus();
public: __property void set_ShowFilterStatus(
   System.bool value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether current filter status should be displayed in Grid's status bar.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behaviors")]
public:
property System.bool ShowFilterStatus {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayoutSet Class
LayoutSet Members


ShowRefreshButton Property

[image]
Intersoft WebGrid Documentation
ShowRefreshButton Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > LayoutSet Class : ShowRefreshButton Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Behaviors")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies whether the grid should display Refresh button in status bar.")>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property ShowRefreshButton As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As LayoutSet
Dim value As System.Boolean

instance.ShowRefreshButton = value

value = instance.ShowRefreshButton
C#
[System.ComponentModel.CategoryAttribute("Behaviors")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether the grid should display Refresh button in status bar.")]
[ISNet.Serialization.BinarySerializableAttribute()]
public System.bool ShowRefreshButton {get; set;}
Delphi
public read-write property ShowRefreshButton: System.Boolean;
JScript
System.ComponentModel.CategoryAttribute("Behaviors")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Specifies whether the grid should display Refresh button in status bar.")
ISNet.Serialization.BinarySerializableAttribute()
public function get,set ShowRefreshButton : System.boolean
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Behaviors")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether the grid should display Refresh button in status bar.")]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.bool get_ShowRefreshButton();
public: __property void set_ShowRefreshButton(
   System.bool value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Behaviors")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether the grid should display Refresh button in status bar.")]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.bool ShowRefreshButton {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayoutSet Class
LayoutSet Members


SizeHeightBy Property

[image]
Intersoft WebGrid Documentation
SizeHeightBy Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > LayoutSet Class : SizeHeightBy Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Behaviors")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies the WebGrid height's adjustment")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property SizeHeightBy As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As LayoutSet
Dim value As System.Integer

instance.SizeHeightBy = value

value = instance.SizeHeightBy
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Behaviors")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the WebGrid height's adjustment")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public System.int SizeHeightBy {get; set;}
Delphi
public read-write property SizeHeightBy: System.Integer;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Behaviors")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the WebGrid height's adjustment")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get,set SizeHeightBy : System.int
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Behaviors")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the WebGrid height's adjustment")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.int get_SizeHeightBy();
public: __property void set_SizeHeightBy(
   System.int value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Behaviors")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the WebGrid height's adjustment")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.int SizeHeightBy {
   System.int get();
   void set (    System.int value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayoutSet Class
LayoutSet Members


SizeWidthBy Property

[image]
Intersoft WebGrid Documentation
SizeWidthBy Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > LayoutSet Class : SizeWidthBy Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Behaviors")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies the WebGrid width's adjustment.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property SizeWidthBy As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As LayoutSet
Dim value As System.Integer

instance.SizeWidthBy = value

value = instance.SizeWidthBy
C#
[System.ComponentModel.CategoryAttribute("Behaviors")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the WebGrid width's adjustment.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public System.int SizeWidthBy {get; set;}
Delphi
public read-write property SizeWidthBy: System.Integer;
JScript
System.ComponentModel.CategoryAttribute("Behaviors")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the WebGrid width's adjustment.")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get,set SizeWidthBy : System.int
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Behaviors")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the WebGrid width's adjustment.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.int get_SizeWidthBy();
public: __property void set_SizeWidthBy(
   System.int value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Behaviors")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the WebGrid width's adjustment.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.int SizeWidthBy {
   System.int get();
   void set (    System.int value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayoutSet Class
LayoutSet Members


SortedColumnStyle Property

[image]
Intersoft WebGrid Documentation
SortedColumnStyle Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > LayoutSet Class : SortedColumnStyle Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("The style applied to the cell which column is sorted.")>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.DefaultValueAttribute()>
Public Property SortedColumnStyle As WebGridFormatStyle
Visual Basic (Usage) Copy Code
Dim instance As LayoutSet
Dim value As WebGridFormatStyle

instance.SortedColumnStyle = value

value = instance.SortedColumnStyle
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("The style applied to the cell which column is sorted.")]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DefaultValueAttribute()]
public WebGridFormatStyle SortedColumnStyle {get; set;}
Delphi
public read-write property SortedColumnStyle: WebGridFormatStyle;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DescriptionAttribute("The style applied to the cell which column is sorted.")
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
System.ComponentModel.NotifyParentPropertyAttribute()
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.DefaultValueAttribute()
public function get,set SortedColumnStyle : WebGridFormatStyle
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("The style applied to the cell which column is sorted.")]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DefaultValueAttribute()]
public: __property WebGridFormatStyle* get_SortedColumnStyle();
public: __property void set_SortedColumnStyle(
   WebGridFormatStyle* value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("The style applied to the cell which column is sorted.")]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DefaultValueAttribute()]
public:
property WebGridFormatStyle^ SortedColumnStyle {
   WebGridFormatStyle^ get();
   void set (    WebGridFormatStyle^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayoutSet Class
LayoutSet Members


StatusBarCommandStyle Property

[image]
Intersoft WebGrid Documentation
StatusBarCommandStyle Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > LayoutSet Class : StatusBarCommandStyle Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.DescriptionAttribute("The normal, hover and active style for the command item in status bar.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Appearance")>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
Public Property StatusBarCommandStyle As ISNet.WebUI.DynamicStyle
Visual Basic (Usage) Copy Code
Dim instance As LayoutSet
Dim value As ISNet.WebUI.DynamicStyle

instance.StatusBarCommandStyle = value

value = instance.StatusBarCommandStyle
C#
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DescriptionAttribute("The normal, hover and active style for the command item in status bar.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
public ISNet.WebUI.DynamicStyle StatusBarCommandStyle {get; set;}
Delphi
public read-write property StatusBarCommandStyle: ISNet.WebUI.DynamicStyle;
JScript
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)
System.ComponentModel.NotifyParentPropertyAttribute()
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.DescriptionAttribute("The normal, hover and active style for the command item in status bar.")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Appearance")
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
public function get,set StatusBarCommandStyle : ISNet.WebUI.DynamicStyle
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DescriptionAttribute("The normal, hover and active style for the command item in status bar.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
public: __property ISNet.WebUI.DynamicStyle* get_StatusBarCommandStyle();
public: __property void set_StatusBarCommandStyle(
   ISNet.WebUI.DynamicStyle* value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DescriptionAttribute("The normal, hover and active style for the command item in status bar.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
public:
property ISNet.WebUI.DynamicStyle^ StatusBarCommandStyle {
   ISNet.WebUI.DynamicStyle^ get();
   void set (    ISNet.WebUI.DynamicStyle^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayoutSet Class
LayoutSet Members


StatusBarStyle Property

[image]
Intersoft WebGrid Documentation
StatusBarStyle Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > LayoutSet Class : StatusBarStyle Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("The style applied to the status bar.")>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property StatusBarStyle As WebGridFormatStyle
Visual Basic (Usage) Copy Code
Dim instance As LayoutSet
Dim value As WebGridFormatStyle

instance.StatusBarStyle = value

value = instance.StatusBarStyle
C#
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("The style applied to the status bar.")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public WebGridFormatStyle StatusBarStyle {get; set;}
Delphi
public read-write property StatusBarStyle: WebGridFormatStyle;
JScript
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DescriptionAttribute("The style applied to the status bar.")
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set StatusBarStyle : WebGridFormatStyle
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("The style applied to the status bar.")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property WebGridFormatStyle* get_StatusBarStyle();
public: __property void set_StatusBarStyle(
   WebGridFormatStyle* value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("The style applied to the status bar.")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property WebGridFormatStyle^ StatusBarStyle {
   WebGridFormatStyle^ get();
   void set (    WebGridFormatStyle^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayoutSet Class
LayoutSet Members


StatusBarVisible Property

[image]
Intersoft WebGrid Documentation
StatusBarVisible Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > LayoutSet Class : StatusBarVisible Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Behaviors")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies whether the status bar is visible.")>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Property StatusBarVisible As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As LayoutSet
Dim value As System.Boolean

instance.StatusBarVisible = value

value = instance.StatusBarVisible
C#
[System.ComponentModel.CategoryAttribute("Behaviors")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether the status bar is visible.")]
[ISNet.Serialization.XmlSerializableAttribute()]
public System.bool StatusBarVisible {get; set;}
Delphi
public read-write property StatusBarVisible: System.Boolean;
JScript
System.ComponentModel.CategoryAttribute("Behaviors")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Specifies whether the status bar is visible.")
ISNet.Serialization.XmlSerializableAttribute()
public function get,set StatusBarVisible : System.boolean
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Behaviors")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether the status bar is visible.")]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property System.bool get_StatusBarVisible();
public: __property void set_StatusBarVisible(
   System.bool value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Behaviors")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether the status bar is visible.")]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property System.bool StatusBarVisible {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayoutSet Class
LayoutSet Members


TextSettings Property

[image]
Intersoft WebGrid Documentation
TextSettings Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > LayoutSet Class : TextSettings Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<ISNet.Serialization.XmlSerializableAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Behaviors")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Returns TextSettings object. Properties that left blank will use default text.")>
Public Property TextSettings As TextSettings
Visual Basic (Usage) Copy Code
Dim instance As LayoutSet
Dim value As TextSettings

instance.TextSettings = value

value = instance.TextSettings
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behaviors")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Returns TextSettings object. Properties that left blank will use default text.")]
public TextSettings TextSettings {get; set;}
Delphi
public read-write property TextSettings: TextSettings;
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Behaviors")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Returns TextSettings object. Properties that left blank will use default text.")
public function get,set TextSettings : TextSettings
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behaviors")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Returns TextSettings object. Properties that left blank will use default text.")]
public: __property TextSettings* get_TextSettings();
public: __property void set_TextSettings(
   TextSettings* value
);
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behaviors")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Returns TextSettings object. Properties that left blank will use default text.")]
public:
property TextSettings^ TextSettings {
   TextSettings^ get();
   void set (    TextSettings^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayoutSet Class
LayoutSet Members


TreeLines Property

[image]
Intersoft WebGrid Documentation
TreeLines Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > LayoutSet Class : TreeLines Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies whether the tree lines is shown for Hierarchical mode.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Behaviors")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
Public Property TreeLines As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As LayoutSet
Dim value As System.Boolean

instance.TreeLines = value

value = instance.TreeLines
C#
[System.ComponentModel.DescriptionAttribute("Specifies whether the tree lines is shown for Hierarchical mode.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behaviors")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public System.bool TreeLines {get; set;}
Delphi
public read-write property TreeLines: System.Boolean;
JScript
System.ComponentModel.DescriptionAttribute("Specifies whether the tree lines is shown for Hierarchical mode.")
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Behaviors")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
public function get,set TreeLines : System.boolean
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies whether the tree lines is shown for Hierarchical mode.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behaviors")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.bool get_TreeLines();
public: __property void set_TreeLines(
   System.bool value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies whether the tree lines is shown for Hierarchical mode.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behaviors")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.bool TreeLines {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayoutSet Class
LayoutSet Members


UseRelativePositioning Property

[image]
Intersoft WebGrid Documentation
UseRelativePositioning Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > LayoutSet Class : UseRelativePositioning Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Behaviors")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies whether the Grid should use relative positioning. Enable this setting if the Grid is contained within complex container.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property UseRelativePositioning As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As LayoutSet
Dim value As System.Boolean

instance.UseRelativePositioning = value

value = instance.UseRelativePositioning
C#
[System.ComponentModel.CategoryAttribute("Behaviors")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether the Grid should use relative positioning. Enable this setting if the Grid is contained within complex container.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public System.bool UseRelativePositioning {get; set;}
Delphi
public read-write property UseRelativePositioning: System.Boolean;
JScript
System.ComponentModel.CategoryAttribute("Behaviors")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Specifies whether the Grid should use relative positioning. Enable this setting if the Grid is contained within complex container.")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get,set UseRelativePositioning : System.boolean
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Behaviors")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether the Grid should use relative positioning. Enable this setting if the Grid is contained within complex container.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.bool get_UseRelativePositioning();
public: __property void set_UseRelativePositioning(
   System.bool value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Behaviors")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether the Grid should use relative positioning. Enable this setting if the Grid is contained within complex container.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.bool UseRelativePositioning {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayoutSet Class
LayoutSet Members


VerboseEditingInformation Property

[image]
Intersoft WebGrid Documentation
VerboseEditingInformation Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > LayoutSet Class : VerboseEditingInformation Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Gets or sets a boolean value indicating whether detailed information should be shown in status bar during editing.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("Behaviors")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property VerboseEditingInformation As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As LayoutSet
Dim value As System.Boolean

instance.VerboseEditingInformation = value

value = instance.VerboseEditingInformation
C#
[System.ComponentModel.DescriptionAttribute("Gets or sets a boolean value indicating whether detailed information should be shown in status bar during editing.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Behaviors")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public System.bool VerboseEditingInformation {get; set;}
Delphi
public read-write property VerboseEditingInformation: System.Boolean;
JScript
System.ComponentModel.DescriptionAttribute("Gets or sets a boolean value indicating whether detailed information should be shown in status bar during editing.")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("Behaviors")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get,set VerboseEditingInformation : System.boolean
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Gets or sets a boolean value indicating whether detailed information should be shown in status bar during editing.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Behaviors")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.bool get_VerboseEditingInformation();
public: __property void set_VerboseEditingInformation(
   System.bool value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Gets or sets a boolean value indicating whether detailed information should be shown in status bar during editing.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Behaviors")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.bool VerboseEditingInformation {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayoutSet Class
LayoutSet Members


VirtualLoadMode Property

[image]
Intersoft WebGrid Documentation
VirtualLoadMode Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > LayoutSet Class : VirtualLoadMode Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Paging")>
<System.ComponentModel.DescriptionAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
Public Property VirtualLoadMode As VirtualLoadMode
Visual Basic (Usage) Copy Code
Dim instance As LayoutSet
Dim value As VirtualLoadMode

instance.VirtualLoadMode = value

value = instance.VirtualLoadMode
C#
[System.ComponentModel.CategoryAttribute("Paging")]
[System.ComponentModel.DescriptionAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public VirtualLoadMode VirtualLoadMode {get; set;}
Delphi
public read-write property VirtualLoadMode: VirtualLoadMode;
JScript
System.ComponentModel.CategoryAttribute("Paging")
System.ComponentModel.DescriptionAttribute()
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
public function get,set VirtualLoadMode : VirtualLoadMode
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Paging")]
[System.ComponentModel.DescriptionAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public: __property VirtualLoadMode get_VirtualLoadMode();
public: __property void set_VirtualLoadMode(
   VirtualLoadMode value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Paging")]
[System.ComponentModel.DescriptionAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public:
property VirtualLoadMode VirtualLoadMode {
   VirtualLoadMode get();
   void set (    VirtualLoadMode value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayoutSet Class
LayoutSet Members


VirtualPageSize Property

[image]
Intersoft WebGrid Documentation
VirtualPageSize Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > LayoutSet Class : VirtualPageSize Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Specify the number of rows to retrieve when PagingMode is set to VirtualLoad")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Paging")>
Public Property VirtualPageSize As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As LayoutSet
Dim value As System.Integer

instance.VirtualPageSize = value

value = instance.VirtualPageSize
C#
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specify the number of rows to retrieve when PagingMode is set to VirtualLoad")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Paging")]
public System.int VirtualPageSize {get; set;}
Delphi
public read-write property VirtualPageSize: System.Integer;
JScript
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Specify the number of rows to retrieve when PagingMode is set to VirtualLoad")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Paging")
public function get,set VirtualPageSize : System.int
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specify the number of rows to retrieve when PagingMode is set to VirtualLoad")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Paging")]
public: __property System.int get_VirtualPageSize();
public: __property void set_VirtualPageSize(
   System.int value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specify the number of rows to retrieve when PagingMode is set to VirtualLoad")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Paging")]
public:
property System.int VirtualPageSize {
   System.int get();
   void set (    System.int value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayoutSet Class
LayoutSet Members


LayoutSet Class Fields

[image]
Intersoft WebGrid Documentation
LayoutSet Class Fields
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : LayoutSet Class

Glossary Item Box

For a list of all members of this type, see LayoutSet members.

Public Fields

 | Name | Description
Public Field | IsInitialized |
Top

See Also

Reference

LayoutSet Class
ISNet.WebUI.WebGrid Namespace


IsInitialized Field

[image]
Intersoft WebGrid Documentation
IsInitialized Field
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > LayoutSet Class : IsInitialized Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public IsInitialized As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As LayoutSet
Dim value As System.Boolean

value = instance.IsInitialized

instance.IsInitialized = value
C#
public System.bool IsInitialized
Delphi
public field IsInitialized: System.Boolean;
JScript
public var IsInitialized : System.boolean;
Managed Extensions for C++
public: System.bool IsInitialized
C++/CLI
public:
System.bool IsInitialized

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayoutSet Class
LayoutSet Members


Margins Class

[image]
Intersoft WebGrid Documentation
Margins Class
Members See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : Margins Class

Glossary Item Box

Object Model

Margins Class

Syntax

Visual Basic (Declaration)
Public Class Margins
Visual Basic (Usage) Copy Code
Dim instance As Margins
C#
public class Margins
Delphi
public class Margins
JScript
public class Margins
Managed Extensions for C++
public __gc class Margins
C++/CLI
public ref class Margins

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebGrid.Margins

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Margins Members
ISNet.WebUI.WebGrid Namespace


Margins Class Members

[image]
Intersoft WebGrid Documentation
Margins Class Members
See Also Fields Send Feedback
ISNet.WebUI.WebGrid Namespace : Margins Class

Glossary Item Box

The following tables list the members exposed by Margins.

Public Constructors

 | Name | Description
Public Constructor | Margins Constructor |
Top

Public Fields

 | Name | Description
Public Field | Bottom |
Public Field | Left |
Public Field | Right |
Public Field | Top |
Top

See Also

Reference

Margins Class
ISNet.WebUI.WebGrid Namespace


Margins Constructor

[image]
Intersoft WebGrid Documentation
Margins Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > Margins Class : Margins Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New Margins()
C#
public Margins()
Delphi
public Margins();
JScript
public function Margins();
Managed Extensions for C++
public: Margins();
C++/CLI
public:
Margins();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Margins Class
Margins Members


Margins Class Fields

[image]
Intersoft WebGrid Documentation
Margins Class Fields
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : Margins Class

Glossary Item Box

For a list of all members of this type, see Margins members.

Public Fields

 | Name | Description
Public Field | Bottom |
Public Field | Left |
Public Field | Right |
Public Field | Top |
Top

See Also

Reference

Margins Class
ISNet.WebUI.WebGrid Namespace


Bottom Field

[image]
Intersoft WebGrid Documentation
Bottom Field
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > Margins Class : Bottom Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Bottom As System.Single
Visual Basic (Usage) Copy Code
Dim instance As Margins
Dim value As System.Single

value = instance.Bottom

instance.Bottom = value
C#
public System.float Bottom
Delphi
public field Bottom: System.Single;
JScript
public var Bottom : System.float;
Managed Extensions for C++
public: System.float Bottom
C++/CLI
public:
System.float Bottom

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Margins Class
Margins Members


Left Field

[image]
Intersoft WebGrid Documentation
Left Field
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > Margins Class : Left Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Left As System.Single
Visual Basic (Usage) Copy Code
Dim instance As Margins
Dim value As System.Single

value = instance.Left

instance.Left = value
C#
public System.float Left
Delphi
public field Left: System.Single;
JScript
public var Left : System.float;
Managed Extensions for C++
public: System.float Left
C++/CLI
public:
System.float Left

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Margins Class
Margins Members


Right Field

[image]
Intersoft WebGrid Documentation
Right Field
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > Margins Class : Right Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Right As System.Single
Visual Basic (Usage) Copy Code
Dim instance As Margins
Dim value As System.Single

value = instance.Right

instance.Right = value
C#
public System.float Right
Delphi
public field Right: System.Single;
JScript
public var Right : System.float;
Managed Extensions for C++
public: System.float Right
C++/CLI
public:
System.float Right

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Margins Class
Margins Members


Top Field

[image]
Intersoft WebGrid Documentation
Top Field
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > Margins Class : Top Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Top As System.Single
Visual Basic (Usage) Copy Code
Dim instance As Margins
Dim value As System.Single

value = instance.Top

instance.Top = value
C#
public System.float Top
Delphi
public field Top: System.Single;
JScript
public var Top : System.float;
Managed Extensions for C++
public: System.float Top
C++/CLI
public:
System.float Top

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Margins Class
Margins Members


NonRetrievableAttribute Class

[image]
Intersoft WebGrid Documentation
NonRetrievableAttribute Class
Members See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : NonRetrievableAttribute Class

Glossary Item Box

Object Model

NonRetrievableAttribute Class

Syntax

Visual Basic (Declaration)
<System.AttributeUsageAttribute(ValidOn=AttributeTargets.Assembly Or  _
    AttributeTargets.Module Or  _
    AttributeTargets.Class Or  _
    AttributeTargets.Struct Or  _
    AttributeTargets.Enum Or  _
    AttributeTargets.Constructor Or  _
    AttributeTargets.Method Or  _
    AttributeTargets.Property Or  _
    AttributeTargets.Field Or  _
    AttributeTargets.Event Or  _
    AttributeTargets.Interface Or  _
    AttributeTargets.Parameter Or  _
    AttributeTargets.Delegate Or  _
    AttributeTargets.ReturnValue Or  _
    AttributeTargets.GenericParameter Or  _
    AttributeTargets.All,
   AllowMultiple=False,
   Inherited=True)>
Public Class NonRetrievableAttribute
   Inherits System.Attribute
Visual Basic (Usage) Copy Code
Dim instance As NonRetrievableAttribute
C#
[System.AttributeUsageAttribute(ValidOn=AttributeTargets.Assembly |
    AttributeTargets.Module |
    AttributeTargets.Class |
    AttributeTargets.Struct |
    AttributeTargets.Enum |
    AttributeTargets.Constructor |
    AttributeTargets.Method |
    AttributeTargets.Property |
    AttributeTargets.Field |
    AttributeTargets.Event |
    AttributeTargets.Interface |
    AttributeTargets.Parameter |
    AttributeTargets.Delegate |
    AttributeTargets.ReturnValue |
    AttributeTargets.GenericParameter |
    AttributeTargets.All,
   AllowMultiple=false,
   Inherited=true)]
public class NonRetrievableAttribute : System.Attribute
Delphi
public class NonRetrievableAttribute = class(System.Attribute)
JScript
System.AttributeUsageAttribute(ValidOn=AttributeTargets.Assembly |
    AttributeTargets.Module |
    AttributeTargets.Class |
    AttributeTargets.Struct |
    AttributeTargets.Enum |
    AttributeTargets.Constructor |
    AttributeTargets.Method |
    AttributeTargets.Property |
    AttributeTargets.Field |
    AttributeTargets.Event |
    AttributeTargets.Interface |
    AttributeTargets.Parameter |
    AttributeTargets.Delegate |
    AttributeTargets.ReturnValue |
    AttributeTargets.GenericParameter |
    AttributeTargets.All,
   AllowMultiple=,
   Inherited=)
public class NonRetrievableAttribute extends System.Attribute
Managed Extensions for C++
[System.AttributeUsageAttribute(ValidOn=AttributeTargets.Assembly |
    AttributeTargets.Module |
    AttributeTargets.Class |
    AttributeTargets.Struct |
    AttributeTargets.Enum |
    AttributeTargets.Constructor |
    AttributeTargets.Method |
    AttributeTargets.Property |
    AttributeTargets.Field |
    AttributeTargets.Event |
    AttributeTargets.Interface |
    AttributeTargets.Parameter |
    AttributeTargets.Delegate |
    AttributeTargets.ReturnValue |
    AttributeTargets.GenericParameter |
    AttributeTargets.All,
   AllowMultiple=false,
   Inherited=true)]
public __gc class NonRetrievableAttribute : public System.Attribute
C++/CLI
[System.AttributeUsageAttribute(ValidOn=AttributeTargets.Assembly |
    AttributeTargets.Module |
    AttributeTargets.Class |
    AttributeTargets.Struct |
    AttributeTargets.Enum |
    AttributeTargets.Constructor |
    AttributeTargets.Method |
    AttributeTargets.Property |
    AttributeTargets.Field |
    AttributeTargets.Event |
    AttributeTargets.Interface |
    AttributeTargets.Parameter |
    AttributeTargets.Delegate |
    AttributeTargets.ReturnValue |
    AttributeTargets.GenericParameter |
    AttributeTargets.All,
   AllowMultiple=false,
   Inherited=true)]
public ref class NonRetrievableAttribute : public System.Attribute

Inheritance Hierarchy

System.Object
System.Attribute
ISNet.WebUI.WebGrid.NonRetrievableAttribute

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

NonRetrievableAttribute Members
ISNet.WebUI.WebGrid Namespace


NonRetrievableAttribute Class Members

[image]
Intersoft WebGrid Documentation
NonRetrievableAttribute Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebGrid Namespace : NonRetrievableAttribute Class

Glossary Item Box

The following tables list the members exposed by NonRetrievableAttribute.

Public Constructors

 | Name | Description
Public Constructor | NonRetrievableAttribute Constructor |
Top

Public Properties

 | Name | Description
Public Property | TypeId | (Inherited from System.Attribute)
Top

Public Methods

 | Name | Description
Public Method | Equals | (Inherited from System.Attribute)
Public Method | GetHashCode | (Inherited from System.Attribute)
Public Method | IsDefaultAttribute | (Inherited from System.Attribute)
Public Method | Match | (Inherited from System.Attribute)
Top

See Also

Reference

NonRetrievableAttribute Class
ISNet.WebUI.WebGrid Namespace


NonRetrievableAttribute Class Methods

[image]
Intersoft WebGrid Documentation
NonRetrievableAttribute Class Methods
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : NonRetrievableAttribute Class

Glossary Item Box

For a list of all members of this type, see NonRetrievableAttribute members.

Public Methods

 | Name | Description
Public Method | Equals | (Inherited from System.Attribute)
Public Method | GetHashCode | (Inherited from System.Attribute)
Public Method | IsDefaultAttribute | (Inherited from System.Attribute)
Public Method | Match | (Inherited from System.Attribute)
Top

See Also

Reference

NonRetrievableAttribute Class
ISNet.WebUI.WebGrid Namespace


NonRetrievableAttribute Class Properties

[image]
Intersoft WebGrid Documentation
NonRetrievableAttribute Class Properties
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : NonRetrievableAttribute Class

Glossary Item Box

For a list of all members of this type, see NonRetrievableAttribute members.

Public Properties

 | Name | Description
Public Property | TypeId | (Inherited from System.Attribute)
Top

See Also

Reference

NonRetrievableAttribute Class
ISNet.WebUI.WebGrid Namespace


NonRetrievableAttribute Constructor

[image]
Intersoft WebGrid Documentation
NonRetrievableAttribute Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > NonRetrievableAttribute Class : NonRetrievableAttribute Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New NonRetrievableAttribute()
C#
public NonRetrievableAttribute()
Delphi
public NonRetrievableAttribute();
JScript
public function NonRetrievableAttribute();
Managed Extensions for C++
public: NonRetrievableAttribute();
C++/CLI
public:
NonRetrievableAttribute();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

NonRetrievableAttribute Class
NonRetrievableAttribute Members


Equals Method

[image]
Intersoft WebGrid Documentation
Equals Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > NonRetrievableAttribute Class : Equals Method

obj

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Security.SecuritySafeCriticalAttribute()>
<__DynamicallyInvokableAttribute()>
Public Overridable Function Equals( _
   ByVal obj As System.Object _
) As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As NonRetrievableAttribute
Dim obj As System.Object
Dim value As System.Boolean

value = instance.Equals(obj)
C#
[System.Security.SecuritySafeCriticalAttribute()]
[__DynamicallyInvokableAttribute()]
public virtual System.bool Equals(
   System.object obj
)
Delphi
public function Equals(
    obj: System.TObject
): System.Boolean; virtual;
JScript
System.Security.SecuritySafeCriticalAttribute()
__DynamicallyInvokableAttribute()
public function Equals(
   obj : System.Object
) : System.boolean;
Managed Extensions for C++
[System.Security.SecuritySafeCriticalAttribute()]
[__DynamicallyInvokableAttribute()]
public: virtual System.bool Equals(
   System.Object* obj
)
C++/CLI
[System.Security.SecuritySafeCriticalAttribute()]
[__DynamicallyInvokableAttribute()]
public:
virtual System.bool Equals(
   System.Object^ obj
)

Parameters

obj

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

NonRetrievableAttribute Class
NonRetrievableAttribute Members


GetHashCode Method

[image]
Intersoft WebGrid Documentation
GetHashCode Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > NonRetrievableAttribute Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Security.SecuritySafeCriticalAttribute()>
<__DynamicallyInvokableAttribute()>
Public Overridable Function GetHashCode() As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As NonRetrievableAttribute
Dim value As System.Integer

value = instance.GetHashCode()
C#
[System.Security.SecuritySafeCriticalAttribute()]
[__DynamicallyInvokableAttribute()]
public virtual System.int GetHashCode()
Delphi
public function GetHashCode(): System.Integer; virtual;
JScript
System.Security.SecuritySafeCriticalAttribute()
__DynamicallyInvokableAttribute()
public function GetHashCode() : System.int;
Managed Extensions for C++
[System.Security.SecuritySafeCriticalAttribute()]
[__DynamicallyInvokableAttribute()]
public: virtual System.int GetHashCode();
C++/CLI
[System.Security.SecuritySafeCriticalAttribute()]
[__DynamicallyInvokableAttribute()]
public:
virtual System.int GetHashCode();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

NonRetrievableAttribute Class
NonRetrievableAttribute Members


IsDefaultAttribute Method

[image]
Intersoft WebGrid Documentation
IsDefaultAttribute Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > NonRetrievableAttribute Class : IsDefaultAttribute Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsDefaultAttribute() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As NonRetrievableAttribute
Dim value As System.Boolean

value = instance.IsDefaultAttribute()
C#
public virtual System.bool IsDefaultAttribute()
Delphi
public function IsDefaultAttribute(): System.Boolean; virtual;
JScript
public function IsDefaultAttribute() : System.boolean;
Managed Extensions for C++
public: virtual System.bool IsDefaultAttribute();
C++/CLI
public:
virtual System.bool IsDefaultAttribute();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

NonRetrievableAttribute Class
NonRetrievableAttribute Members


Match Method

[image]
Intersoft WebGrid Documentation
Match Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > NonRetrievableAttribute Class : Match Method

obj

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Match( _
   ByVal obj As System.Object _
) As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As NonRetrievableAttribute
Dim obj As System.Object
Dim value As System.Boolean

value = instance.Match(obj)
C#
public virtual System.bool Match(
   System.object obj
)
Delphi
public function Match(
    obj: System.TObject
): System.Boolean; virtual;
JScript
public function Match(
   obj : System.Object
) : System.boolean;
Managed Extensions for C++
public: virtual System.bool Match(
   System.Object* obj
)
C++/CLI
public:
virtual System.bool Match(
   System.Object^ obj
)

Parameters

obj

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

NonRetrievableAttribute Class
NonRetrievableAttribute Members


TypeId Property

[image]
Intersoft WebGrid Documentation
TypeId Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > NonRetrievableAttribute Class : TypeId Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property TypeId As System.Object
Visual Basic (Usage) Copy Code
Dim instance As NonRetrievableAttribute
Dim value As System.Object

value = instance.TypeId
C#
public virtual System.object TypeId {get;}
Delphi
public read-only property TypeId: System.TObject; virtual;
JScript
public function get TypeId : System.Object
Managed Extensions for C++
public: __property virtual System.Object* get_TypeId();
C++/CLI
public:
virtual property System.Object^ TypeId {
   System.Object^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

NonRetrievableAttribute Class
NonRetrievableAttribute Members


ObjectRow Class

[image]
Intersoft WebGrid Documentation
ObjectRow Class
Members See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : ObjectRow Class

Glossary Item Box

Object Model

ObjectRow Class

Syntax

Visual Basic (Declaration)
Public Class ObjectRow
   Inherits System.Data.DataRow
Visual Basic (Usage) Copy Code
Dim instance As ObjectRow
C#
public class ObjectRow : System.Data.DataRow
Delphi
public class ObjectRow = class(System.Data.DataRow)
JScript
public class ObjectRow extends System.Data.DataRow
Managed Extensions for C++
public __gc class ObjectRow : public System.Data.DataRow
C++/CLI
public ref class ObjectRow : public System.Data.DataRow

Inheritance Hierarchy

System.Object
System.Data.DataRow
ISNet.WebUI.WebGrid.ObjectRow

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ObjectRow Members
ISNet.WebUI.WebGrid Namespace


ObjectRow Class Members

[image]
Intersoft WebGrid Documentation
ObjectRow Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebGrid Namespace : ObjectRow Class

Glossary Item Box

The following tables list the members exposed by ObjectRow.

Public Constructors

 | Name | Description
Public Constructor | ObjectRow Constructor |
Top

Public Properties

 | Name | Description
Public Property | HasErrors | (Inherited from System.Data.DataRow)
Public Property | Item | Overloaded. (Inherited from System.Data.DataRow)
Public Property | ItemArray | (Inherited from System.Data.DataRow)
Public Property | Row |
Public Property | RowError | (Inherited from System.Data.DataRow)
Public Property | RowState | (Inherited from System.Data.DataRow)
Public Property | Table | (Inherited from System.Data.DataRow)
Top

Public Methods

 | Name | Description
Public Method | AcceptChanges | (Inherited from System.Data.DataRow)
Public Method | BeginEdit | (Inherited from System.Data.DataRow)
Public Method | CancelEdit | (Inherited from System.Data.DataRow)
Public Method | ClearErrors | (Inherited from System.Data.DataRow)
Public Method | Delete | (Inherited from System.Data.DataRow)
Public Method | EndEdit | (Inherited from System.Data.DataRow)
Public Method | GetChildRows | Overloaded. (Inherited from System.Data.DataRow)
Public Method | GetColumnError | Overloaded. (Inherited from System.Data.DataRow)
Public Method | GetColumnsInError | (Inherited from System.Data.DataRow)
Public Method | GetParentRow | Overloaded. (Inherited from System.Data.DataRow)
Public Method | GetParentRows | Overloaded. (Inherited from System.Data.DataRow)
Public Method | HasVersion | (Inherited from System.Data.DataRow)
Public Method | IsNull | Overloaded. (Inherited from System.Data.DataRow)
Public Method | RejectChanges | (Inherited from System.Data.DataRow)
Public Method | SetAdded | (Inherited from System.Data.DataRow)
Public Method | SetColumnError | Overloaded. (Inherited from System.Data.DataRow)
Public Method | SetModified | (Inherited from System.Data.DataRow)
Public Method | SetParentRow | Overloaded. (Inherited from System.Data.DataRow)
Top

See Also

Reference

ObjectRow Class
ISNet.WebUI.WebGrid Namespace


ObjectRow Class Methods

[image]
Intersoft WebGrid Documentation
ObjectRow Class Methods
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : ObjectRow Class

Glossary Item Box

For a list of all members of this type, see ObjectRow members.

Public Methods

 | Name | Description
Public Method | AcceptChanges | (Inherited from System.Data.DataRow)
Public Method | BeginEdit | (Inherited from System.Data.DataRow)
Public Method | CancelEdit | (Inherited from System.Data.DataRow)
Public Method | ClearErrors | (Inherited from System.Data.DataRow)
Public Method | Delete | (Inherited from System.Data.DataRow)
Public Method | EndEdit | (Inherited from System.Data.DataRow)
Public Method | GetChildRows | Overloaded. (Inherited from System.Data.DataRow)
Public Method | GetColumnError | Overloaded. (Inherited from System.Data.DataRow)
Public Method | GetColumnsInError | (Inherited from System.Data.DataRow)
Public Method | GetParentRow | Overloaded. (Inherited from System.Data.DataRow)
Public Method | GetParentRows | Overloaded. (Inherited from System.Data.DataRow)
Public Method | HasVersion | (Inherited from System.Data.DataRow)
Public Method | IsNull | Overloaded. (Inherited from System.Data.DataRow)
Public Method | RejectChanges | (Inherited from System.Data.DataRow)
Public Method | SetAdded | (Inherited from System.Data.DataRow)
Public Method | SetColumnError | Overloaded. (Inherited from System.Data.DataRow)
Public Method | SetModified | (Inherited from System.Data.DataRow)
Public Method | SetParentRow | Overloaded. (Inherited from System.Data.DataRow)
Top

See Also

Reference

ObjectRow Class
ISNet.WebUI.WebGrid Namespace


ObjectRow Constructor

[image]
Intersoft WebGrid Documentation
ObjectRow Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ObjectRow Class : ObjectRow Constructor

rb

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal rb As System.Data.DataRowBuilder _
)
Visual Basic (Usage) Copy Code
Dim rb As System.Data.DataRowBuilder

Dim instance As New ObjectRow(rb)
C#
public ObjectRow(
   System.Data.DataRowBuilder rb
)
Delphi
public ObjectRow(
    rb: System.Data.DataRowBuilder
);
JScript
public function ObjectRow(
   rb : System.Data.DataRowBuilder
);
Managed Extensions for C++
public: ObjectRow(
   System.Data.DataRowBuilder* rb
)
C++/CLI
public:
ObjectRow(
   System.Data.DataRowBuilder^ rb
)

Parameters

rb

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ObjectRow Class
ObjectRow Members


AcceptChanges Method

[image]
Intersoft WebGrid Documentation
AcceptChanges Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ObjectRow Class : AcceptChanges Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub AcceptChanges()
Visual Basic (Usage) Copy Code
Dim instance As ObjectRow

instance.AcceptChanges()
C#
public void AcceptChanges()
Delphi
public procedure AcceptChanges();
JScript
public function AcceptChanges();
Managed Extensions for C++
public: void AcceptChanges();
C++/CLI
public:
void AcceptChanges();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ObjectRow Class
ObjectRow Members


BeginEdit Method

[image]
Intersoft WebGrid Documentation
BeginEdit Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ObjectRow Class : BeginEdit Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Public Sub BeginEdit()
Visual Basic (Usage) Copy Code
Dim instance As ObjectRow

instance.BeginEdit()
C#
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public void BeginEdit()
Delphi
public procedure BeginEdit();
JScript
System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)
public function BeginEdit();
Managed Extensions for C++
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public: void BeginEdit();
C++/CLI
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public:
void BeginEdit();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ObjectRow Class
ObjectRow Members


CancelEdit Method

[image]
Intersoft WebGrid Documentation
CancelEdit Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ObjectRow Class : CancelEdit Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Public Sub CancelEdit()
Visual Basic (Usage) Copy Code
Dim instance As ObjectRow

instance.CancelEdit()
C#
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public void CancelEdit()
Delphi
public procedure CancelEdit();
JScript
System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)
public function CancelEdit();
Managed Extensions for C++
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public: void CancelEdit();
C++/CLI
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public:
void CancelEdit();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ObjectRow Class
ObjectRow Members


ClearErrors Method

[image]
Intersoft WebGrid Documentation
ClearErrors Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ObjectRow Class : ClearErrors Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub ClearErrors()
Visual Basic (Usage) Copy Code
Dim instance As ObjectRow

instance.ClearErrors()
C#
public void ClearErrors()
Delphi
public procedure ClearErrors();
JScript
public function ClearErrors();
Managed Extensions for C++
public: void ClearErrors();
C++/CLI
public:
void ClearErrors();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ObjectRow Class
ObjectRow Members


Delete Method

[image]
Intersoft WebGrid Documentation
Delete Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ObjectRow Class : Delete Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub Delete()
Visual Basic (Usage) Copy Code
Dim instance As ObjectRow

instance.Delete()
C#
public void Delete()
Delphi
public procedure Delete();
JScript
public function Delete();
Managed Extensions for C++
public: void Delete();
C++/CLI
public:
void Delete();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ObjectRow Class
ObjectRow Members


EndEdit Method

[image]
Intersoft WebGrid Documentation
EndEdit Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ObjectRow Class : EndEdit Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Public Sub EndEdit()
Visual Basic (Usage) Copy Code
Dim instance As ObjectRow

instance.EndEdit()
C#
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public void EndEdit()
Delphi
public procedure EndEdit();
JScript
System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)
public function EndEdit();
Managed Extensions for C++
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public: void EndEdit();
C++/CLI
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public:
void EndEdit();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ObjectRow Class
ObjectRow Members


GetChildRows Method

[image]
Intersoft WebGrid Documentation
GetChildRows Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ObjectRow Class : GetChildRows Method

Glossary Item Box

Overload List

Overload | Description
GetChildRows(String) | (Inherited from System.Data.DataRow)
GetChildRows(String,DataRowVersion) | (Inherited from System.Data.DataRow)
GetChildRows(DataRelation) | (Inherited from System.Data.DataRow)
GetChildRows(DataRelation,DataRowVersion) | (Inherited from System.Data.DataRow)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ObjectRow Class
ObjectRow Members


GetChildRows(String) Method

[image]
Intersoft WebGrid Documentation
GetChildRows(String) Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ObjectRow Class > GetChildRows Method : GetChildRows(String) Method

relationName

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function GetChildRows( _
   ByVal relationName As System.String _
) As System.Data.DataRow()
Visual Basic (Usage) Copy Code
Dim instance As ObjectRow
Dim relationName As System.String
Dim value() As System.Data.DataRow

value = instance.GetChildRows(relationName)
C#
public System.Data.DataRow[] GetChildRows(
   System.string relationName
)
Delphi
public function GetChildRows(
    relationName: System.String
): System.Data.array of DataRow;
JScript
public function GetChildRows(
   relationName : System.String
) : System.Data.DataRow[];
Managed Extensions for C++
public: System.Data.DataRow*[]* GetChildRows(
   System.string* relationName
)
C++/CLI
public:
System.Data.array<DataRow^>^ GetChildRows(
   System.String^ relationName
)

Parameters

relationName

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ObjectRow Class
ObjectRow Members
Overload List


GetChildRows(String,DataRowVersion) Method

[image]
Intersoft WebGrid Documentation
GetChildRows(String,DataRowVersion) Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ObjectRow Class > GetChildRows Method : GetChildRows(String,DataRowVersion) Method

relationName
version

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function GetChildRows( _
   ByVal relationName As System.String, _
   ByVal version As System.Data.DataRowVersion _
) As System.Data.DataRow()
Visual Basic (Usage) Copy Code
Dim instance As ObjectRow
Dim relationName As System.String
Dim version As System.Data.DataRowVersion
Dim value() As System.Data.DataRow

value = instance.GetChildRows(relationName, version)
C#
public System.Data.DataRow[] GetChildRows(
   System.string relationName,
   System.Data.DataRowVersion version
)
Delphi
public function GetChildRows(
    relationName: System.String;
    version: System.Data.DataRowVersion
): System.Data.array of DataRow;
JScript
public function GetChildRows(
   relationName : System.String,
   version : System.Data.DataRowVersion
) : System.Data.DataRow[];
Managed Extensions for C++
public: System.Data.DataRow*[]* GetChildRows(
   System.string* relationName,
   System.Data.DataRowVersion version
)
C++/CLI
public:
System.Data.array<DataRow^>^ GetChildRows(
   System.String^ relationName,
   System.Data.DataRowVersion version
)

Parameters

relationName
version

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ObjectRow Class
ObjectRow Members
Overload List


GetChildRows(DataRelation) Method

[image]
Intersoft WebGrid Documentation
GetChildRows(DataRelation) Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ObjectRow Class > GetChildRows Method : GetChildRows(DataRelation) Method

relation

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function GetChildRows( _
   ByVal relation As System.Data.DataRelation _
) As System.Data.DataRow()
Visual Basic (Usage) Copy Code
Dim instance As ObjectRow
Dim relation As System.Data.DataRelation
Dim value() As System.Data.DataRow

value = instance.GetChildRows(relation)
C#
public System.Data.DataRow[] GetChildRows(
   System.Data.DataRelation relation
)
Delphi
public function GetChildRows(
    relation: System.Data.DataRelation
): System.Data.array of DataRow;
JScript
public function GetChildRows(
   relation : System.Data.DataRelation
) : System.Data.DataRow[];
Managed Extensions for C++
public: System.Data.DataRow*[]* GetChildRows(
   System.Data.DataRelation* relation
)
C++/CLI
public:
System.Data.array<DataRow^>^ GetChildRows(
   System.Data.DataRelation^ relation
)

Parameters

relation

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ObjectRow Class
ObjectRow Members
Overload List


GetChildRows(DataRelation,DataRowVersion) Method

[image]
Intersoft WebGrid Documentation
GetChildRows(DataRelation,DataRowVersion) Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ObjectRow Class > GetChildRows Method : GetChildRows(DataRelation,DataRowVersion) Method

relation
version

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function GetChildRows( _
   ByVal relation As System.Data.DataRelation, _
   ByVal version As System.Data.DataRowVersion _
) As System.Data.DataRow()
Visual Basic (Usage) Copy Code
Dim instance As ObjectRow
Dim relation As System.Data.DataRelation
Dim version As System.Data.DataRowVersion
Dim value() As System.Data.DataRow

value = instance.GetChildRows(relation, version)
C#
public System.Data.DataRow[] GetChildRows(
   System.Data.DataRelation relation,
   System.Data.DataRowVersion version
)
Delphi
public function GetChildRows(
    relation: System.Data.DataRelation;
    version: System.Data.DataRowVersion
): System.Data.array of DataRow;
JScript
public function GetChildRows(
   relation : System.Data.DataRelation,
   version : System.Data.DataRowVersion
) : System.Data.DataRow[];
Managed Extensions for C++
public: System.Data.DataRow*[]* GetChildRows(
   System.Data.DataRelation* relation,
   System.Data.DataRowVersion version
)
C++/CLI
public:
System.Data.array<DataRow^>^ GetChildRows(
   System.Data.DataRelation^ relation,
   System.Data.DataRowVersion version
)

Parameters

relation
version

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ObjectRow Class
ObjectRow Members
Overload List


GetColumnError Method

[image]
Intersoft WebGrid Documentation
GetColumnError Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ObjectRow Class : GetColumnError Method

Glossary Item Box

Overload List

Overload | Description
GetColumnError(Int32) | (Inherited from System.Data.DataRow)
GetColumnError(String) | (Inherited from System.Data.DataRow)
GetColumnError(DataColumn) | (Inherited from System.Data.DataRow)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ObjectRow Class
ObjectRow Members


GetColumnError(Int32) Method

[image]
Intersoft WebGrid Documentation
GetColumnError(Int32) Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ObjectRow Class > GetColumnError Method : GetColumnError(Int32) Method

columnIndex

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function GetColumnError( _
   ByVal columnIndex As System.Integer _
) As System.String
Visual Basic (Usage) Copy Code
Dim instance As ObjectRow
Dim columnIndex As System.Integer
Dim value As System.String

value = instance.GetColumnError(columnIndex)
C#
public System.string GetColumnError(
   System.int columnIndex
)
Delphi
public function GetColumnError(
    columnIndex: System.Integer
): System.String;
JScript
public function GetColumnError(
   columnIndex : System.int
) : System.String;
Managed Extensions for C++
public: System.string* GetColumnError(
   System.int columnIndex
)
C++/CLI
public:
System.String^ GetColumnError(
   System.int columnIndex
)

Parameters

columnIndex

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ObjectRow Class
ObjectRow Members
Overload List


GetColumnError(String) Method

[image]
Intersoft WebGrid Documentation
GetColumnError(String) Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ObjectRow Class > GetColumnError Method : GetColumnError(String) Method

columnName

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function GetColumnError( _
   ByVal columnName As System.String _
) As System.String
Visual Basic (Usage) Copy Code
Dim instance As ObjectRow
Dim columnName As System.String
Dim value As System.String

value = instance.GetColumnError(columnName)
C#
public System.string GetColumnError(
   System.string columnName
)
Delphi
public function GetColumnError(
    columnName: System.String
): System.String;
JScript
public function GetColumnError(
   columnName : System.String
) : System.String;
Managed Extensions for C++
public: System.string* GetColumnError(
   System.string* columnName
)
C++/CLI
public:
System.String^ GetColumnError(
   System.String^ columnName
)

Parameters

columnName

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ObjectRow Class
ObjectRow Members
Overload List


GetColumnError(DataColumn) Method

[image]
Intersoft WebGrid Documentation
GetColumnError(DataColumn) Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ObjectRow Class > GetColumnError Method : GetColumnError(DataColumn) Method

column

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function GetColumnError( _
   ByVal column As System.Data.DataColumn _
) As System.String
Visual Basic (Usage) Copy Code
Dim instance As ObjectRow
Dim column As System.Data.DataColumn
Dim value As System.String

value = instance.GetColumnError(column)
C#
public System.string GetColumnError(
   System.Data.DataColumn column
)
Delphi
public function GetColumnError(
    column: System.Data.DataColumn
): System.String;
JScript
public function GetColumnError(
   column : System.Data.DataColumn
) : System.String;
Managed Extensions for C++
public: System.string* GetColumnError(
   System.Data.DataColumn* column
)
C++/CLI
public:
System.String^ GetColumnError(
   System.Data.DataColumn^ column
)

Parameters

column

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ObjectRow Class
ObjectRow Members
Overload List


GetColumnsInError Method

[image]
Intersoft WebGrid Documentation
GetColumnsInError Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ObjectRow Class : GetColumnsInError Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetColumnsInError() As System.Data.DataColumn()
Visual Basic (Usage) Copy Code
Dim instance As ObjectRow
Dim value() As System.Data.DataColumn

value = instance.GetColumnsInError()
C#
public System.Data.DataColumn[] GetColumnsInError()
Delphi
public function GetColumnsInError(): System.Data.array of DataColumn;
JScript
public function GetColumnsInError() : System.Data.DataColumn[];
Managed Extensions for C++
public: System.Data.DataColumn*[]* GetColumnsInError();
C++/CLI
public:
System.Data.array<DataColumn^>^ GetColumnsInError();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ObjectRow Class
ObjectRow Members


GetParentRow Method

[image]
Intersoft WebGrid Documentation
GetParentRow Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ObjectRow Class : GetParentRow Method

Glossary Item Box

Overload List

Overload | Description
GetParentRow(String) | (Inherited from System.Data.DataRow)
GetParentRow(String,DataRowVersion) | (Inherited from System.Data.DataRow)
GetParentRow(DataRelation) | (Inherited from System.Data.DataRow)
GetParentRow(DataRelation,DataRowVersion) | (Inherited from System.Data.DataRow)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ObjectRow Class
ObjectRow Members


GetParentRow(String) Method

[image]
Intersoft WebGrid Documentation
GetParentRow(String) Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ObjectRow Class > GetParentRow Method : GetParentRow(String) Method

relationName

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function GetParentRow( _
   ByVal relationName As System.String _
) As System.Data.DataRow
Visual Basic (Usage) Copy Code
Dim instance As ObjectRow
Dim relationName As System.String
Dim value As System.Data.DataRow

value = instance.GetParentRow(relationName)
C#
public System.Data.DataRow GetParentRow(
   System.string relationName
)
Delphi
public function GetParentRow(
    relationName: System.String
): System.Data.DataRow;
JScript
public function GetParentRow(
   relationName : System.String
) : System.Data.DataRow;
Managed Extensions for C++
public: System.Data.DataRow* GetParentRow(
   System.string* relationName
)
C++/CLI
public:
System.Data.DataRow^ GetParentRow(
   System.String^ relationName
)

Parameters

relationName

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ObjectRow Class
ObjectRow Members
Overload List


GetParentRow(String,DataRowVersion) Method

[image]
Intersoft WebGrid Documentation
GetParentRow(String,DataRowVersion) Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ObjectRow Class > GetParentRow Method : GetParentRow(String,DataRowVersion) Method

relationName
version

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function GetParentRow( _
   ByVal relationName As System.String, _
   ByVal version As System.Data.DataRowVersion _
) As System.Data.DataRow
Visual Basic (Usage) Copy Code
Dim instance As ObjectRow
Dim relationName As System.String
Dim version As System.Data.DataRowVersion
Dim value As System.Data.DataRow

value = instance.GetParentRow(relationName, version)
C#
public System.Data.DataRow GetParentRow(
   System.string relationName,
   System.Data.DataRowVersion version
)
Delphi
public function GetParentRow(
    relationName: System.String;
    version: System.Data.DataRowVersion
): System.Data.DataRow;
JScript
public function GetParentRow(
   relationName : System.String,
   version : System.Data.DataRowVersion
) : System.Data.DataRow;
Managed Extensions for C++
public: System.Data.DataRow* GetParentRow(
   System.string* relationName,
   System.Data.DataRowVersion version
)
C++/CLI
public:
System.Data.DataRow^ GetParentRow(
   System.String^ relationName,
   System.Data.DataRowVersion version
)

Parameters

relationName
version

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ObjectRow Class
ObjectRow Members
Overload List


GetParentRow(DataRelation) Method

[image]
Intersoft WebGrid Documentation
GetParentRow(DataRelation) Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ObjectRow Class > GetParentRow Method : GetParentRow(DataRelation) Method

relation

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function GetParentRow( _
   ByVal relation As System.Data.DataRelation _
) As System.Data.DataRow
Visual Basic (Usage) Copy Code
Dim instance As ObjectRow
Dim relation As System.Data.DataRelation
Dim value As System.Data.DataRow

value = instance.GetParentRow(relation)
C#
public System.Data.DataRow GetParentRow(
   System.Data.DataRelation relation
)
Delphi
public function GetParentRow(
    relation: System.Data.DataRelation
): System.Data.DataRow;
JScript
public function GetParentRow(
   relation : System.Data.DataRelation
) : System.Data.DataRow;
Managed Extensions for C++
public: System.Data.DataRow* GetParentRow(
   System.Data.DataRelation* relation
)
C++/CLI
public:
System.Data.DataRow^ GetParentRow(
   System.Data.DataRelation^ relation
)

Parameters

relation

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ObjectRow Class
ObjectRow Members
Overload List


GetParentRow(DataRelation,DataRowVersion) Method

[image]
Intersoft WebGrid Documentation
GetParentRow(DataRelation,DataRowVersion) Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ObjectRow Class > GetParentRow Method : GetParentRow(DataRelation,DataRowVersion) Method

relation
version

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function GetParentRow( _
   ByVal relation As System.Data.DataRelation, _
   ByVal version As System.Data.DataRowVersion _
) As System.Data.DataRow
Visual Basic (Usage) Copy Code
Dim instance As ObjectRow
Dim relation As System.Data.DataRelation
Dim version As System.Data.DataRowVersion
Dim value As System.Data.DataRow

value = instance.GetParentRow(relation, version)
C#
public System.Data.DataRow GetParentRow(
   System.Data.DataRelation relation,
   System.Data.DataRowVersion version
)
Delphi
public function GetParentRow(
    relation: System.Data.DataRelation;
    version: System.Data.DataRowVersion
): System.Data.DataRow;
JScript
public function GetParentRow(
   relation : System.Data.DataRelation,
   version : System.Data.DataRowVersion
) : System.Data.DataRow;
Managed Extensions for C++
public: System.Data.DataRow* GetParentRow(
   System.Data.DataRelation* relation,
   System.Data.DataRowVersion version
)
C++/CLI
public:
System.Data.DataRow^ GetParentRow(
   System.Data.DataRelation^ relation,
   System.Data.DataRowVersion version
)

Parameters

relation
version

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ObjectRow Class
ObjectRow Members
Overload List


GetParentRows Method

[image]
Intersoft WebGrid Documentation
GetParentRows Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ObjectRow Class : GetParentRows Method

Glossary Item Box

Overload List

Overload | Description
GetParentRows(String) | (Inherited from System.Data.DataRow)
GetParentRows(String,DataRowVersion) | (Inherited from System.Data.DataRow)
GetParentRows(DataRelation) | (Inherited from System.Data.DataRow)
GetParentRows(DataRelation,DataRowVersion) | (Inherited from System.Data.DataRow)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ObjectRow Class
ObjectRow Members


GetParentRows(String) Method

[image]
Intersoft WebGrid Documentation
GetParentRows(String) Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ObjectRow Class > GetParentRows Method : GetParentRows(String) Method

relationName

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function GetParentRows( _
   ByVal relationName As System.String _
) As System.Data.DataRow()
Visual Basic (Usage) Copy Code
Dim instance As ObjectRow
Dim relationName As System.String
Dim value() As System.Data.DataRow

value = instance.GetParentRows(relationName)
C#
public System.Data.DataRow[] GetParentRows(
   System.string relationName
)
Delphi
public function GetParentRows(
    relationName: System.String
): System.Data.array of DataRow;
JScript
public function GetParentRows(
   relationName : System.String
) : System.Data.DataRow[];
Managed Extensions for C++
public: System.Data.DataRow*[]* GetParentRows(
   System.string* relationName
)
C++/CLI
public:
System.Data.array<DataRow^>^ GetParentRows(
   System.String^ relationName
)

Parameters

relationName

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ObjectRow Class
ObjectRow Members
Overload List


GetParentRows(String,DataRowVersion) Method

[image]
Intersoft WebGrid Documentation
GetParentRows(String,DataRowVersion) Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ObjectRow Class > GetParentRows Method : GetParentRows(String,DataRowVersion) Method

relationName
version

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function GetParentRows( _
   ByVal relationName As System.String, _
   ByVal version As System.Data.DataRowVersion _
) As System.Data.DataRow()
Visual Basic (Usage) Copy Code
Dim instance As ObjectRow
Dim relationName As System.String
Dim version As System.Data.DataRowVersion
Dim value() As System.Data.DataRow

value = instance.GetParentRows(relationName, version)
C#
public System.Data.DataRow[] GetParentRows(
   System.string relationName,
   System.Data.DataRowVersion version
)
Delphi
public function GetParentRows(
    relationName: System.String;
    version: System.Data.DataRowVersion
): System.Data.array of DataRow;
JScript
public function GetParentRows(
   relationName : System.String,
   version : System.Data.DataRowVersion
) : System.Data.DataRow[];
Managed Extensions for C++
public: System.Data.DataRow*[]* GetParentRows(
   System.string* relationName,
   System.Data.DataRowVersion version
)
C++/CLI
public:
System.Data.array<DataRow^>^ GetParentRows(
   System.String^ relationName,
   System.Data.DataRowVersion version
)

Parameters

relationName
version

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ObjectRow Class
ObjectRow Members
Overload List


GetParentRows(DataRelation) Method

[image]
Intersoft WebGrid Documentation
GetParentRows(DataRelation) Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ObjectRow Class > GetParentRows Method : GetParentRows(DataRelation) Method

relation

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function GetParentRows( _
   ByVal relation As System.Data.DataRelation _
) As System.Data.DataRow()
Visual Basic (Usage) Copy Code
Dim instance As ObjectRow
Dim relation As System.Data.DataRelation
Dim value() As System.Data.DataRow

value = instance.GetParentRows(relation)
C#
public System.Data.DataRow[] GetParentRows(
   System.Data.DataRelation relation
)
Delphi
public function GetParentRows(
    relation: System.Data.DataRelation
): System.Data.array of DataRow;
JScript
public function GetParentRows(
   relation : System.Data.DataRelation
) : System.Data.DataRow[];
Managed Extensions for C++
public: System.Data.DataRow*[]* GetParentRows(
   System.Data.DataRelation* relation
)
C++/CLI
public:
System.Data.array<DataRow^>^ GetParentRows(
   System.Data.DataRelation^ relation
)

Parameters

relation

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ObjectRow Class
ObjectRow Members
Overload List


GetParentRows(DataRelation,DataRowVersion) Method

[image]
Intersoft WebGrid Documentation
GetParentRows(DataRelation,DataRowVersion) Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ObjectRow Class > GetParentRows Method : GetParentRows(DataRelation,DataRowVersion) Method

relation
version

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function GetParentRows( _
   ByVal relation As System.Data.DataRelation, _
   ByVal version As System.Data.DataRowVersion _
) As System.Data.DataRow()
Visual Basic (Usage) Copy Code
Dim instance As ObjectRow
Dim relation As System.Data.DataRelation
Dim version As System.Data.DataRowVersion
Dim value() As System.Data.DataRow

value = instance.GetParentRows(relation, version)
C#
public System.Data.DataRow[] GetParentRows(
   System.Data.DataRelation relation,
   System.Data.DataRowVersion version
)
Delphi
public function GetParentRows(
    relation: System.Data.DataRelation;
    version: System.Data.DataRowVersion
): System.Data.array of DataRow;
JScript
public function GetParentRows(
   relation : System.Data.DataRelation,
   version : System.Data.DataRowVersion
) : System.Data.DataRow[];
Managed Extensions for C++
public: System.Data.DataRow*[]* GetParentRows(
   System.Data.DataRelation* relation,
   System.Data.DataRowVersion version
)
C++/CLI
public:
System.Data.array<DataRow^>^ GetParentRows(
   System.Data.DataRelation^ relation,
   System.Data.DataRowVersion version
)

Parameters

relation
version

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ObjectRow Class
ObjectRow Members
Overload List


HasVersion Method

[image]
Intersoft WebGrid Documentation
HasVersion Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ObjectRow Class : HasVersion Method

version

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function HasVersion( _
   ByVal version As System.Data.DataRowVersion _
) As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As ObjectRow
Dim version As System.Data.DataRowVersion
Dim value As System.Boolean

value = instance.HasVersion(version)
C#
public System.bool HasVersion(
   System.Data.DataRowVersion version
)
Delphi
public function HasVersion(
    version: System.Data.DataRowVersion
): System.Boolean;
JScript
public function HasVersion(
   version : System.Data.DataRowVersion
) : System.boolean;
Managed Extensions for C++
public: System.bool HasVersion(
   System.Data.DataRowVersion version
)
C++/CLI
public:
System.bool HasVersion(
   System.Data.DataRowVersion version
)

Parameters

version

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ObjectRow Class
ObjectRow Members


IsNull Method

[image]
Intersoft WebGrid Documentation
IsNull Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ObjectRow Class : IsNull Method

Glossary Item Box

Overload List

Overload | Description
IsNull(Int32) | (Inherited from System.Data.DataRow)
IsNull(String) | (Inherited from System.Data.DataRow)
IsNull(DataColumn) | (Inherited from System.Data.DataRow)
IsNull(DataColumn,DataRowVersion) | (Inherited from System.Data.DataRow)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ObjectRow Class
ObjectRow Members


IsNull(Int32) Method

[image]
Intersoft WebGrid Documentation
IsNull(Int32) Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ObjectRow Class > IsNull Method : IsNull(Int32) Method

columnIndex

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function IsNull( _
   ByVal columnIndex As System.Integer _
) As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As ObjectRow
Dim columnIndex As System.Integer
Dim value As System.Boolean

value = instance.IsNull(columnIndex)
C#
public System.bool IsNull(
   System.int columnIndex
)
Delphi
public function IsNull(
    columnIndex: System.Integer
): System.Boolean;
JScript
public function IsNull(
   columnIndex : System.int
) : System.boolean;
Managed Extensions for C++
public: System.bool IsNull(
   System.int columnIndex
)
C++/CLI
public:
System.bool IsNull(
   System.int columnIndex
)

Parameters

columnIndex

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ObjectRow Class
ObjectRow Members
Overload List


IsNull(String) Method

[image]
Intersoft WebGrid Documentation
IsNull(String) Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ObjectRow Class > IsNull Method : IsNull(String) Method

columnName

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function IsNull( _
   ByVal columnName As System.String _
) As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As ObjectRow
Dim columnName As System.String
Dim value As System.Boolean

value = instance.IsNull(columnName)
C#
public System.bool IsNull(
   System.string columnName
)
Delphi
public function IsNull(
    columnName: System.String
): System.Boolean;
JScript
public function IsNull(
   columnName : System.String
) : System.boolean;
Managed Extensions for C++
public: System.bool IsNull(
   System.string* columnName
)
C++/CLI
public:
System.bool IsNull(
   System.String^ columnName
)

Parameters

columnName

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ObjectRow Class
ObjectRow Members
Overload List


IsNull(DataColumn) Method

[image]
Intersoft WebGrid Documentation
IsNull(DataColumn) Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ObjectRow Class > IsNull Method : IsNull(DataColumn) Method

column

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function IsNull( _
   ByVal column As System.Data.DataColumn _
) As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As ObjectRow
Dim column As System.Data.DataColumn
Dim value As System.Boolean

value = instance.IsNull(column)
C#
public System.bool IsNull(
   System.Data.DataColumn column
)
Delphi
public function IsNull(
    column: System.Data.DataColumn
): System.Boolean;
JScript
public function IsNull(
   column : System.Data.DataColumn
) : System.boolean;
Managed Extensions for C++
public: System.bool IsNull(
   System.Data.DataColumn* column
)
C++/CLI
public:
System.bool IsNull(
   System.Data.DataColumn^ column
)

Parameters

column

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ObjectRow Class
ObjectRow Members
Overload List


IsNull(DataColumn,DataRowVersion) Method

[image]
Intersoft WebGrid Documentation
IsNull(DataColumn,DataRowVersion) Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ObjectRow Class > IsNull Method : IsNull(DataColumn,DataRowVersion) Method

column
version

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function IsNull( _
   ByVal column As System.Data.DataColumn, _
   ByVal version As System.Data.DataRowVersion _
) As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As ObjectRow
Dim column As System.Data.DataColumn
Dim version As System.Data.DataRowVersion
Dim value As System.Boolean

value = instance.IsNull(column, version)
C#
public System.bool IsNull(
   System.Data.DataColumn column,
   System.Data.DataRowVersion version
)
Delphi
public function IsNull(
    column: System.Data.DataColumn;
    version: System.Data.DataRowVersion
): System.Boolean;
JScript
public function IsNull(
   column : System.Data.DataColumn,
   version : System.Data.DataRowVersion
) : System.boolean;
Managed Extensions for C++
public: System.bool IsNull(
   System.Data.DataColumn* column,
   System.Data.DataRowVersion version
)
C++/CLI
public:
System.bool IsNull(
   System.Data.DataColumn^ column,
   System.Data.DataRowVersion version
)

Parameters

column
version

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ObjectRow Class
ObjectRow Members
Overload List


RejectChanges Method

[image]
Intersoft WebGrid Documentation
RejectChanges Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ObjectRow Class : RejectChanges Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub RejectChanges()
Visual Basic (Usage) Copy Code
Dim instance As ObjectRow

instance.RejectChanges()
C#
public void RejectChanges()
Delphi
public procedure RejectChanges();
JScript
public function RejectChanges();
Managed Extensions for C++
public: void RejectChanges();
C++/CLI
public:
void RejectChanges();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ObjectRow Class
ObjectRow Members


SetAdded Method

[image]
Intersoft WebGrid Documentation
SetAdded Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ObjectRow Class : SetAdded Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SetAdded()
Visual Basic (Usage) Copy Code
Dim instance As ObjectRow

instance.SetAdded()
C#
public void SetAdded()
Delphi
public procedure SetAdded();
JScript
public function SetAdded();
Managed Extensions for C++
public: void SetAdded();
C++/CLI
public:
void SetAdded();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ObjectRow Class
ObjectRow Members


SetColumnError Method

[image]
Intersoft WebGrid Documentation
SetColumnError Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ObjectRow Class : SetColumnError Method

Glossary Item Box

Overload List

Overload | Description
SetColumnError(Int32,String) | (Inherited from System.Data.DataRow)
SetColumnError(String,String) | (Inherited from System.Data.DataRow)
SetColumnError(DataColumn,String) | (Inherited from System.Data.DataRow)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ObjectRow Class
ObjectRow Members


SetColumnError(Int32,String) Method

[image]
Intersoft WebGrid Documentation
SetColumnError(Int32,String) Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ObjectRow Class > SetColumnError Method : SetColumnError(Int32,String) Method

columnIndex
error

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Sub SetColumnError( _
   ByVal columnIndex As System.Integer, _
   ByVal error As System.String _
)
Visual Basic (Usage) Copy Code
Dim instance As ObjectRow
Dim columnIndex As System.Integer
Dim error As System.String

instance.SetColumnError(columnIndex, error)
C#
public void SetColumnError(
   System.int columnIndex,
   System.string error
)
Delphi
public procedure SetColumnError(
    columnIndex: System.Integer;
    error: System.String
);
JScript
public function SetColumnError(
   columnIndex : System.int,
   error : System.String
);
Managed Extensions for C++
public: void SetColumnError(
   System.int columnIndex,
   System.string* error
)
C++/CLI
public:
void SetColumnError(
   System.int columnIndex,
   System.String^ error
)

Parameters

columnIndex
error

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ObjectRow Class
ObjectRow Members
Overload List


SetColumnError(String,String) Method

[image]
Intersoft WebGrid Documentation
SetColumnError(String,String) Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ObjectRow Class > SetColumnError Method : SetColumnError(String,String) Method

columnName
error

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Sub SetColumnError( _
   ByVal columnName As System.String, _
   ByVal error As System.String _
)
Visual Basic (Usage) Copy Code
Dim instance As ObjectRow
Dim columnName As System.String
Dim error As System.String

instance.SetColumnError(columnName, error)
C#
public void SetColumnError(
   System.string columnName,
   System.string error
)
Delphi
public procedure SetColumnError(
    columnName: System.String;
    error: System.String
);
JScript
public function SetColumnError(
   columnName : System.String,
   error : System.String
);
Managed Extensions for C++
public: void SetColumnError(
   System.string* columnName,
   System.string* error
)
C++/CLI
public:
void SetColumnError(
   System.String^ columnName,
   System.String^ error
)

Parameters

columnName
error

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ObjectRow Class
ObjectRow Members
Overload List


SetColumnError(DataColumn,String) Method

[image]
Intersoft WebGrid Documentation
SetColumnError(DataColumn,String) Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ObjectRow Class > SetColumnError Method : SetColumnError(DataColumn,String) Method

column
error

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Sub SetColumnError( _
   ByVal column As System.Data.DataColumn, _
   ByVal error As System.String _
)
Visual Basic (Usage) Copy Code
Dim instance As ObjectRow
Dim column As System.Data.DataColumn
Dim error As System.String

instance.SetColumnError(column, error)
C#
public void SetColumnError(
   System.Data.DataColumn column,
   System.string error
)
Delphi
public procedure SetColumnError(
    column: System.Data.DataColumn;
    error: System.String
);
JScript
public function SetColumnError(
   column : System.Data.DataColumn,
   error : System.String
);
Managed Extensions for C++
public: void SetColumnError(
   System.Data.DataColumn* column,
   System.string* error
)
C++/CLI
public:
void SetColumnError(
   System.Data.DataColumn^ column,
   System.String^ error
)

Parameters

column
error

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ObjectRow Class
ObjectRow Members
Overload List


SetModified Method

[image]
Intersoft WebGrid Documentation
SetModified Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ObjectRow Class : SetModified Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SetModified()
Visual Basic (Usage) Copy Code
Dim instance As ObjectRow

instance.SetModified()
C#
public void SetModified()
Delphi
public procedure SetModified();
JScript
public function SetModified();
Managed Extensions for C++
public: void SetModified();
C++/CLI
public:
void SetModified();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ObjectRow Class
ObjectRow Members


SetParentRow Method

[image]
Intersoft WebGrid Documentation
SetParentRow Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ObjectRow Class : SetParentRow Method

Glossary Item Box

Overload List

Overload | Description
SetParentRow(DataRow) | (Inherited from System.Data.DataRow)
SetParentRow(DataRow,DataRelation) | (Inherited from System.Data.DataRow)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ObjectRow Class
ObjectRow Members


SetParentRow(DataRow) Method

[image]
Intersoft WebGrid Documentation
SetParentRow(DataRow) Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ObjectRow Class > SetParentRow Method : SetParentRow(DataRow) Method

parentRow

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Sub SetParentRow( _
   ByVal parentRow As System.Data.DataRow _
)
Visual Basic (Usage) Copy Code
Dim instance As ObjectRow
Dim parentRow As System.Data.DataRow

instance.SetParentRow(parentRow)
C#
public void SetParentRow(
   System.Data.DataRow parentRow
)
Delphi
public procedure SetParentRow(
    parentRow: System.Data.DataRow
);
JScript
public function SetParentRow(
   parentRow : System.Data.DataRow
);
Managed Extensions for C++
public: void SetParentRow(
   System.Data.DataRow* parentRow
)
C++/CLI
public:
void SetParentRow(
   System.Data.DataRow^ parentRow
)

Parameters

parentRow

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ObjectRow Class
ObjectRow Members
Overload List


SetParentRow(DataRow,DataRelation) Method

[image]
Intersoft WebGrid Documentation
SetParentRow(DataRow,DataRelation) Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ObjectRow Class > SetParentRow Method : SetParentRow(DataRow,DataRelation) Method

parentRow
relation

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Sub SetParentRow( _
   ByVal parentRow As System.Data.DataRow, _
   ByVal relation As System.Data.DataRelation _
)
Visual Basic (Usage) Copy Code
Dim instance As ObjectRow
Dim parentRow As System.Data.DataRow
Dim relation As System.Data.DataRelation

instance.SetParentRow(parentRow, relation)
C#
public void SetParentRow(
   System.Data.DataRow parentRow,
   System.Data.DataRelation relation
)
Delphi
public procedure SetParentRow(
    parentRow: System.Data.DataRow;
    relation: System.Data.DataRelation
);
JScript
public function SetParentRow(
   parentRow : System.Data.DataRow,
   relation : System.Data.DataRelation
);
Managed Extensions for C++
public: void SetParentRow(
   System.Data.DataRow* parentRow,
   System.Data.DataRelation* relation
)
C++/CLI
public:
void SetParentRow(
   System.Data.DataRow^ parentRow,
   System.Data.DataRelation^ relation
)

Parameters

parentRow
relation

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ObjectRow Class
ObjectRow Members
Overload List


HasErrors Property

[image]
Intersoft WebGrid Documentation
HasErrors Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ObjectRow Class : HasErrors Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property HasErrors As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As ObjectRow
Dim value As System.Boolean

value = instance.HasErrors
C#
public System.bool HasErrors {get;}
Delphi
public read-only property HasErrors: System.Boolean;
JScript
public function get HasErrors : System.boolean
Managed Extensions for C++
public: __property System.bool get_HasErrors();
C++/CLI
public:
property System.bool HasErrors {
   System.bool get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ObjectRow Class
ObjectRow Members


Item Property

[image]
Intersoft WebGrid Documentation
Item Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ObjectRow Class : Item Property

Glossary Item Box

Overload List

Overload | Description
Item(Int32) | (Inherited from System.Data.DataRow)
Item(String) | (Inherited from System.Data.DataRow)
Item(DataColumn) | (Inherited from System.Data.DataRow)
Item(Int32,DataRowVersion) | (Inherited from System.Data.DataRow)
Item(String,DataRowVersion) | (Inherited from System.Data.DataRow)
Item(DataColumn,DataRowVersion) | (Inherited from System.Data.DataRow)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ObjectRow Class
ObjectRow Members


Item(Int32) Property

[image]
Intersoft WebGrid Documentation
Item(Int32) Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ObjectRow Class > Item Property : Item(Int32) Property

columnIndex

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Property Item( _
   ByVal columnIndex As System.Integer _
) As System.Object
Visual Basic (Usage) Copy Code
Dim instance As ObjectRow
Dim columnIndex As System.Integer
Dim value As System.Object

instance.Item(columnIndex) = value

value = instance.Item(columnIndex)
C#
public System.object Item(
   System.int columnIndex
) {get; set;}
Delphi
public read-write property Item(
    columnIndex: System.Integer
): System.TObject;
JScript
public function get,set Item(
   columnIndex : System.int
) : System.Object
Managed Extensions for C++
public: __property System.Object* get_Item(
   System.int columnIndex
);
public: __property void set_Item(
   System.int columnIndex,
   System.Object* value
);
C++/CLI
public:
property System.Object^ Item {
   System.Object^ get(System.int columnIndex);
   void set (System.int columnIndex, System.Object^ value);
}

Parameters

columnIndex

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ObjectRow Class
ObjectRow Members
Overload List


Item(String) Property

[image]
Intersoft WebGrid Documentation
Item(String) Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ObjectRow Class > Item Property : Item(String) Property

columnName

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Property Item( _
   ByVal columnName As System.String _
) As System.Object
Visual Basic (Usage) Copy Code
Dim instance As ObjectRow
Dim columnName As System.String
Dim value As System.Object

instance.Item(columnName) = value

value = instance.Item(columnName)
C#
public System.object Item(
   System.string columnName
) {get; set;}
Delphi
public read-write property Item(
    columnName: System.String
): System.TObject;
JScript
public function get,set Item(
   columnName : System.String
) : System.Object
Managed Extensions for C++
public: __property System.Object* get_Item(
   System.string* columnName
);
public: __property void set_Item(
   System.string* columnName,
   System.Object* value
);
C++/CLI
public:
property System.Object^ Item {
   System.Object^ get(System.String^ columnName);
   void set (System.String^ columnName, System.Object^ value);
}

Parameters

columnName

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ObjectRow Class
ObjectRow Members
Overload List


Item(DataColumn) Property

[image]
Intersoft WebGrid Documentation
Item(DataColumn) Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ObjectRow Class > Item Property : Item(DataColumn) Property

column

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Property Item( _
   ByVal column As System.Data.DataColumn _
) As System.Object
Visual Basic (Usage) Copy Code
Dim instance As ObjectRow
Dim column As System.Data.DataColumn
Dim value As System.Object

instance.Item(column) = value

value = instance.Item(column)
C#
public System.object Item(
   System.Data.DataColumn column
) {get; set;}
Delphi
public read-write property Item(
    column: System.Data.DataColumn
): System.TObject;
JScript
public function get,set Item(
   column : System.Data.DataColumn
) : System.Object
Managed Extensions for C++
public: __property System.Object* get_Item(
   System.Data.DataColumn* column
);
public: __property void set_Item(
   System.Data.DataColumn* column,
   System.Object* value
);
C++/CLI
public:
property System.Object^ Item {
   System.Object^ get(System.Data.DataColumn^ column);
   void set (System.Data.DataColumn^ column, System.Object^ value);
}

Parameters

column

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ObjectRow Class
ObjectRow Members
Overload List


Item(Int32,DataRowVersion) Property

[image]
Intersoft WebGrid Documentation
Item(Int32,DataRowVersion) Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ObjectRow Class > Item Property : Item(Int32,DataRowVersion) Property

columnIndex
version

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads ReadOnly Property Item( _
   ByVal columnIndex As System.Integer, _
   ByVal version As System.Data.DataRowVersion _
) As System.Object
Visual Basic (Usage) Copy Code
Dim instance As ObjectRow
Dim columnIndex As System.Integer
Dim version As System.Data.DataRowVersion
Dim value As System.Object

value = instance.Item(columnIndex, version)
C#
public System.object Item(
   System.int columnIndex,
   System.Data.DataRowVersion version
) {get;}
Delphi
public read-only property Item(
    columnIndex: System.Integer;
    version: System.Data.DataRowVersion
): System.TObject;
JScript
public function get Item(
   columnIndex : System.int,
   version : System.Data.DataRowVersion
) : System.Object
Managed Extensions for C++
public: __property System.Object* get_Item(
   System.int columnIndex,
   System.Data.DataRowVersion version
);
C++/CLI
public:
property System.Object^ Item {
   System.Object^ get(System.int columnIndex, System.Data.DataRowVersion version);
}

Parameters

columnIndex
version

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ObjectRow Class
ObjectRow Members
Overload List


Item(String,DataRowVersion) Property

[image]
Intersoft WebGrid Documentation
Item(String,DataRowVersion) Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ObjectRow Class > Item Property : Item(String,DataRowVersion) Property

columnName
version

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads ReadOnly Property Item( _
   ByVal columnName As System.String, _
   ByVal version As System.Data.DataRowVersion _
) As System.Object
Visual Basic (Usage) Copy Code
Dim instance As ObjectRow
Dim columnName As System.String
Dim version As System.Data.DataRowVersion
Dim value As System.Object

value = instance.Item(columnName, version)
C#
public System.object Item(
   System.string columnName,
   System.Data.DataRowVersion version
) {get;}
Delphi
public read-only property Item(
    columnName: System.String;
    version: System.Data.DataRowVersion
): System.TObject;
JScript
public function get Item(
   columnName : System.String,
   version : System.Data.DataRowVersion
) : System.Object
Managed Extensions for C++
public: __property System.Object* get_Item(
   System.string* columnName,
   System.Data.DataRowVersion version
);
C++/CLI
public:
property System.Object^ Item {
   System.Object^ get(System.String^ columnName, System.Data.DataRowVersion version);
}

Parameters

columnName
version

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ObjectRow Class
ObjectRow Members
Overload List


Item(DataColumn,DataRowVersion) Property

[image]
Intersoft WebGrid Documentation
Item(DataColumn,DataRowVersion) Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ObjectRow Class > Item Property : Item(DataColumn,DataRowVersion) Property

column
version

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads ReadOnly Property Item( _
   ByVal column As System.Data.DataColumn, _
   ByVal version As System.Data.DataRowVersion _
) As System.Object
Visual Basic (Usage) Copy Code
Dim instance As ObjectRow
Dim column As System.Data.DataColumn
Dim version As System.Data.DataRowVersion
Dim value As System.Object

value = instance.Item(column, version)
C#
public System.object Item(
   System.Data.DataColumn column,
   System.Data.DataRowVersion version
) {get;}
Delphi
public read-only property Item(
    column: System.Data.DataColumn;
    version: System.Data.DataRowVersion
): System.TObject;
JScript
public function get Item(
   column : System.Data.DataColumn,
   version : System.Data.DataRowVersion
) : System.Object
Managed Extensions for C++
public: __property System.Object* get_Item(
   System.Data.DataColumn* column,
   System.Data.DataRowVersion version
);
C++/CLI
public:
property System.Object^ Item {
   System.Object^ get(System.Data.DataColumn^ column, System.Data.DataRowVersion version);
}

Parameters

column
version

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ObjectRow Class
ObjectRow Members
Overload List


ItemArray Property

[image]
Intersoft WebGrid Documentation
ItemArray Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ObjectRow Class : ItemArray Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property ItemArray As System.Object()
Visual Basic (Usage) Copy Code
Dim instance As ObjectRow
Dim value() As System.Object

instance.ItemArray = value

value = instance.ItemArray
C#
public System.object[] ItemArray {get; set;}
Delphi
public read-write property ItemArray: System.array of TObject;
JScript
public function get,set ItemArray : System.Object[]
Managed Extensions for C++
public: __property System.Object*[]* get_ItemArray();
public: __property void set_ItemArray(
   System.Object*[]* value
);
C++/CLI
public:
property System.array<Object^>^ ItemArray {
   System.array<Object^>^ get();
   void set (    System.array<Object^>^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ObjectRow Class
ObjectRow Members


ObjectRow Class Properties

[image]
Intersoft WebGrid Documentation
ObjectRow Class Properties
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : ObjectRow Class

Glossary Item Box

For a list of all members of this type, see ObjectRow members.

Public Properties

 | Name | Description
Public Property | HasErrors | (Inherited from System.Data.DataRow)
Public Property | Item | Overloaded. (Inherited from System.Data.DataRow)
Public Property | ItemArray | (Inherited from System.Data.DataRow)
Public Property | Row |
Public Property | RowError | (Inherited from System.Data.DataRow)
Public Property | RowState | (Inherited from System.Data.DataRow)
Public Property | Table | (Inherited from System.Data.DataRow)
Top

See Also

Reference

ObjectRow Class
ISNet.WebUI.WebGrid Namespace


Row Property

[image]
Intersoft WebGrid Documentation
Row Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ObjectRow Class : Row Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Row As System.Object
Visual Basic (Usage) Copy Code
Dim instance As ObjectRow
Dim value As System.Object

instance.Row = value

value = instance.Row
C#
public System.object Row {get; set;}
Delphi
public read-write property Row: System.TObject;
JScript
public function get,set Row : System.Object
Managed Extensions for C++
public: __property System.Object* get_Row();
public: __property void set_Row(
   System.Object* value
);
C++/CLI
public:
property System.Object^ Row {
   System.Object^ get();
   void set (    System.Object^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ObjectRow Class
ObjectRow Members


RowError Property

[image]
Intersoft WebGrid Documentation
RowError Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ObjectRow Class : RowError Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property RowError As System.String
Visual Basic (Usage) Copy Code
Dim instance As ObjectRow
Dim value As System.String

instance.RowError = value

value = instance.RowError
C#
public System.string RowError {get; set;}
Delphi
public read-write property RowError: System.String;
JScript
public function get,set RowError : System.String
Managed Extensions for C++
public: __property System.string* get_RowError();
public: __property void set_RowError(
   System.string* value
);
C++/CLI
public:
property System.String^ RowError {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ObjectRow Class
ObjectRow Members


RowState Property

[image]
Intersoft WebGrid Documentation
RowState Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ObjectRow Class : RowState Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property RowState As System.Data.DataRowState
Visual Basic (Usage) Copy Code
Dim instance As ObjectRow
Dim value As System.Data.DataRowState

value = instance.RowState
C#
public System.Data.DataRowState RowState {get;}
Delphi
public read-only property RowState: System.Data.DataRowState;
JScript
public function get RowState : System.Data.DataRowState
Managed Extensions for C++
public: __property System.Data.DataRowState get_RowState();
C++/CLI
public:
property System.Data.DataRowState RowState {
   System.Data.DataRowState get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ObjectRow Class
ObjectRow Members


Table Property

[image]
Intersoft WebGrid Documentation
Table Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > ObjectRow Class : Table Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Table As System.Data.DataTable
Visual Basic (Usage) Copy Code
Dim instance As ObjectRow
Dim value As System.Data.DataTable

value = instance.Table
C#
public System.Data.DataTable Table {get;}
Delphi
public read-only property Table: System.Data.DataTable;
JScript
public function get Table : System.Data.DataTable
Managed Extensions for C++
public: __property System.Data.DataTable* get_Table();
C++/CLI
public:
property System.Data.DataTable^ Table {
   System.Data.DataTable^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ObjectRow Class
ObjectRow Members


PostBackAction Class

[image]
Intersoft WebGrid Documentation
PostBackAction Class
Members See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : PostBackAction Class

Glossary Item Box

Object Model

PostBackAction Class

Syntax

Visual Basic (Declaration)
Public Class PostBackAction
Visual Basic (Usage) Copy Code
Dim instance As PostBackAction
C#
public class PostBackAction
Delphi
public class PostBackAction
JScript
public class PostBackAction
Managed Extensions for C++
public __gc class PostBackAction
C++/CLI
public ref class PostBackAction

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebGrid.PostBackAction

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PostBackAction Members
ISNet.WebUI.WebGrid Namespace


PostBackAction Class Members

[image]
Intersoft WebGrid Documentation
PostBackAction Class Members
See Also Fields Send Feedback
ISNet.WebUI.WebGrid Namespace : PostBackAction Class

Glossary Item Box

The following tables list the members exposed by PostBackAction.

Public Constructors

 | Name | Description
Public Constructor | PostBackAction Constructor |
Top

Public Fields

 | Name | Description
Public Field | AddRow |
Public Field | BatchUpdate |
Public Field | ButtonClick |
Public Field | ChartLoading |
Public Field | ChartRetrievePivotData |
Public Field | ChildTableRefresh |
Public Field | ColumnChange |
Public Field | ColumnFilter |
Public Field | ColumnGroup |
Public Field | ColumnGroupChange |
Public Field | ColumnSort |
Public Field | ColumnUngroup |
Public Field | Custom |
Public Field | Delete |
Public Field | Export |
Public Field | LoadChildTable |
Public Field | LoadData |
Public Field | LoadGroup |
Public Field | LoadPreviewRow |
Public Field | LoadSelfRefChild |
Public Field | MoreData |
Public Field | Paging |
Public Field | RefreshAll |
Public Field | RefreshData |
Public Field | RowChanged |
Public Field | Update |
Top

See Also

Reference

PostBackAction Class
ISNet.WebUI.WebGrid Namespace


PostBackAction Constructor

[image]
Intersoft WebGrid Documentation
PostBackAction Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > PostBackAction Class : PostBackAction Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New PostBackAction()
C#
public PostBackAction()
Delphi
public PostBackAction();
JScript
public function PostBackAction();
Managed Extensions for C++
public: PostBackAction();
C++/CLI
public:
PostBackAction();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PostBackAction Class
PostBackAction Members


PostBackAction Class Fields

[image]
Intersoft WebGrid Documentation
PostBackAction Class Fields
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : PostBackAction Class

Glossary Item Box

For a list of all members of this type, see PostBackAction members.

Public Fields

 | Name | Description
Public Field | AddRow |
Public Field | BatchUpdate |
Public Field | ButtonClick |
Public Field | ChartLoading |
Public Field | ChartRetrievePivotData |
Public Field | ChildTableRefresh |
Public Field | ColumnChange |
Public Field | ColumnFilter |
Public Field | ColumnGroup |
Public Field | ColumnGroupChange |
Public Field | ColumnSort |
Public Field | ColumnUngroup |
Public Field | Custom |
Public Field | Delete |
Public Field | Export |
Public Field | LoadChildTable |
Public Field | LoadData |
Public Field | LoadGroup |
Public Field | LoadPreviewRow |
Public Field | LoadSelfRefChild |
Public Field | MoreData |
Public Field | Paging |
Public Field | RefreshAll |
Public Field | RefreshData |
Public Field | RowChanged |
Public Field | Update |
Top

See Also

Reference

PostBackAction Class
ISNet.WebUI.WebGrid Namespace


AddRow Field

[image]
Intersoft WebGrid Documentation
AddRow Field
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > PostBackAction Class : AddRow Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Const AddRow As System.String
Visual Basic (Usage) Copy Code
Dim value As System.String

value = PostBackAction.AddRow
C#
public const System.string AddRow
Delphi
public field AddRow: System.String; Const
JScript
public constvar AddRow : System.String;
Managed Extensions for C++
public: const System.string* AddRow
C++/CLI
public:
const System.String^ AddRow

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PostBackAction Class
PostBackAction Members


BatchUpdate Field

[image]
Intersoft WebGrid Documentation
BatchUpdate Field
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > PostBackAction Class : BatchUpdate Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Const BatchUpdate As System.String
Visual Basic (Usage) Copy Code
Dim value As System.String

value = PostBackAction.BatchUpdate
C#
public const System.string BatchUpdate
Delphi
public field BatchUpdate: System.String; Const
JScript
public constvar BatchUpdate : System.String;
Managed Extensions for C++
public: const System.string* BatchUpdate
C++/CLI
public:
const System.String^ BatchUpdate

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PostBackAction Class
PostBackAction Members


ButtonClick Field

[image]
Intersoft WebGrid Documentation
ButtonClick Field
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > PostBackAction Class : ButtonClick Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Const ButtonClick As System.String
Visual Basic (Usage) Copy Code
Dim value As System.String

value = PostBackAction.ButtonClick
C#
public const System.string ButtonClick
Delphi
public field ButtonClick: System.String; Const
JScript
public constvar ButtonClick : System.String;
Managed Extensions for C++
public: const System.string* ButtonClick
C++/CLI
public:
const System.String^ ButtonClick

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PostBackAction Class
PostBackAction Members


ChartLoading Field

[image]
Intersoft WebGrid Documentation
ChartLoading Field
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > PostBackAction Class : ChartLoading Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Const ChartLoading As System.String
Visual Basic (Usage) Copy Code
Dim value As System.String

value = PostBackAction.ChartLoading
C#
public const System.string ChartLoading
Delphi
public field ChartLoading: System.String; Const
JScript
public constvar ChartLoading : System.String;
Managed Extensions for C++
public: const System.string* ChartLoading
C++/CLI
public:
const System.String^ ChartLoading

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PostBackAction Class
PostBackAction Members


ChartRetrievePivotData Field

[image]
Intersoft WebGrid Documentation
ChartRetrievePivotData Field
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > PostBackAction Class : ChartRetrievePivotData Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Const ChartRetrievePivotData As System.String
Visual Basic (Usage) Copy Code
Dim value As System.String

value = PostBackAction.ChartRetrievePivotData
C#
public const System.string ChartRetrievePivotData
Delphi
public field ChartRetrievePivotData: System.String; Const
JScript
public constvar ChartRetrievePivotData : System.String;
Managed Extensions for C++
public: const System.string* ChartRetrievePivotData
C++/CLI
public:
const System.String^ ChartRetrievePivotData

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PostBackAction Class
PostBackAction Members


ChildTableRefresh Field

[image]
Intersoft WebGrid Documentation
ChildTableRefresh Field
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > PostBackAction Class : ChildTableRefresh Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Const ChildTableRefresh As System.String
Visual Basic (Usage) Copy Code
Dim value As System.String

value = PostBackAction.ChildTableRefresh
C#
public const System.string ChildTableRefresh
Delphi
public field ChildTableRefresh: System.String; Const
JScript
public constvar ChildTableRefresh : System.String;
Managed Extensions for C++
public: const System.string* ChildTableRefresh
C++/CLI
public:
const System.String^ ChildTableRefresh

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PostBackAction Class
PostBackAction Members


ColumnChange Field

[image]
Intersoft WebGrid Documentation
ColumnChange Field
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > PostBackAction Class : ColumnChange Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Const ColumnChange As System.String
Visual Basic (Usage) Copy Code
Dim value As System.String

value = PostBackAction.ColumnChange
C#
public const System.string ColumnChange
Delphi
public field ColumnChange: System.String; Const
JScript
public constvar ColumnChange : System.String;
Managed Extensions for C++
public: const System.string* ColumnChange
C++/CLI
public:
const System.String^ ColumnChange

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PostBackAction Class
PostBackAction Members


ColumnFilter Field

[image]
Intersoft WebGrid Documentation
ColumnFilter Field
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > PostBackAction Class : ColumnFilter Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Const ColumnFilter As System.String
Visual Basic (Usage) Copy Code
Dim value As System.String

value = PostBackAction.ColumnFilter
C#
public const System.string ColumnFilter
Delphi
public field ColumnFilter: System.String; Const
JScript
public constvar ColumnFilter : System.String;
Managed Extensions for C++
public: const System.string* ColumnFilter
C++/CLI
public:
const System.String^ ColumnFilter

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PostBackAction Class
PostBackAction Members


ColumnGroup Field

[image]
Intersoft WebGrid Documentation
ColumnGroup Field
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > PostBackAction Class : ColumnGroup Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Const ColumnGroup As System.String
Visual Basic (Usage) Copy Code
Dim value As System.String

value = PostBackAction.ColumnGroup
C#
public const System.string ColumnGroup
Delphi
public field ColumnGroup: System.String; Const
JScript
public constvar ColumnGroup : System.String;
Managed Extensions for C++
public: const System.string* ColumnGroup
C++/CLI
public:
const System.String^ ColumnGroup

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PostBackAction Class
PostBackAction Members


ColumnGroupChange Field

[image]
Intersoft WebGrid Documentation
ColumnGroupChange Field
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > PostBackAction Class : ColumnGroupChange Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Const ColumnGroupChange As System.String
Visual Basic (Usage) Copy Code
Dim value As System.String

value = PostBackAction.ColumnGroupChange
C#
public const System.string ColumnGroupChange
Delphi
public field ColumnGroupChange: System.String; Const
JScript
public constvar ColumnGroupChange : System.String;
Managed Extensions for C++
public: const System.string* ColumnGroupChange
C++/CLI
public:
const System.String^ ColumnGroupChange

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PostBackAction Class
PostBackAction Members


ColumnSort Field

[image]
Intersoft WebGrid Documentation
ColumnSort Field
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > PostBackAction Class : ColumnSort Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Const ColumnSort As System.String
Visual Basic (Usage) Copy Code
Dim value As System.String

value = PostBackAction.ColumnSort
C#
public const System.string ColumnSort
Delphi
public field ColumnSort: System.String; Const
JScript
public constvar ColumnSort : System.String;
Managed Extensions for C++
public: const System.string* ColumnSort
C++/CLI
public:
const System.String^ ColumnSort

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PostBackAction Class
PostBackAction Members


ColumnUngroup Field

[image]
Intersoft WebGrid Documentation
ColumnUngroup Field
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > PostBackAction Class : ColumnUngroup Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Const ColumnUngroup As System.String
Visual Basic (Usage) Copy Code
Dim value As System.String

value = PostBackAction.ColumnUngroup
C#
public const System.string ColumnUngroup
Delphi
public field ColumnUngroup: System.String; Const
JScript
public constvar ColumnUngroup : System.String;
Managed Extensions for C++
public: const System.string* ColumnUngroup
C++/CLI
public:
const System.String^ ColumnUngroup

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PostBackAction Class
PostBackAction Members


Custom Field

[image]
Intersoft WebGrid Documentation
Custom Field
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > PostBackAction Class : Custom Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Const Custom As System.String
Visual Basic (Usage) Copy Code
Dim value As System.String

value = PostBackAction.Custom
C#
public const System.string Custom
Delphi
public field Custom: System.String; Const
JScript
public constvar Custom : System.String;
Managed Extensions for C++
public: const System.string* Custom
C++/CLI
public:
const System.String^ Custom

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PostBackAction Class
PostBackAction Members


Delete Field

[image]
Intersoft WebGrid Documentation
Delete Field
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > PostBackAction Class : Delete Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Const Delete As System.String
Visual Basic (Usage) Copy Code
Dim value As System.String

value = PostBackAction.Delete
C#
public const System.string Delete
Delphi
public field Delete: System.String; Const
JScript
public constvar Delete : System.String;
Managed Extensions for C++
public: const System.string* Delete
C++/CLI
public:
const System.String^ Delete

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PostBackAction Class
PostBackAction Members


Export Field

[image]
Intersoft WebGrid Documentation
Export Field
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > PostBackAction Class : Export Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Const Export As System.String
Visual Basic (Usage) Copy Code
Dim value As System.String

value = PostBackAction.Export
C#
public const System.string Export
Delphi
public field Export: System.String; Const
JScript
public constvar Export : System.String;
Managed Extensions for C++
public: const System.string* Export
C++/CLI
public:
const System.String^ Export

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PostBackAction Class
PostBackAction Members


LoadChildTable Field

[image]
Intersoft WebGrid Documentation
LoadChildTable Field
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > PostBackAction Class : LoadChildTable Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Const LoadChildTable As System.String
Visual Basic (Usage) Copy Code
Dim value As System.String

value = PostBackAction.LoadChildTable
C#
public const System.string LoadChildTable
Delphi
public field LoadChildTable: System.String; Const
JScript
public constvar LoadChildTable : System.String;
Managed Extensions for C++
public: const System.string* LoadChildTable
C++/CLI
public:
const System.String^ LoadChildTable

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PostBackAction Class
PostBackAction Members


LoadData Field

[image]
Intersoft WebGrid Documentation
LoadData Field
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > PostBackAction Class : LoadData Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Const LoadData As System.String
Visual Basic (Usage) Copy Code
Dim value As System.String

value = PostBackAction.LoadData
C#
public const System.string LoadData
Delphi
public field LoadData: System.String; Const
JScript
public constvar LoadData : System.String;
Managed Extensions for C++
public: const System.string* LoadData
C++/CLI
public:
const System.String^ LoadData

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PostBackAction Class
PostBackAction Members


LoadGroup Field

[image]
Intersoft WebGrid Documentation
LoadGroup Field
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > PostBackAction Class : LoadGroup Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Const LoadGroup As System.String
Visual Basic (Usage) Copy Code
Dim value As System.String

value = PostBackAction.LoadGroup
C#
public const System.string LoadGroup
Delphi
public field LoadGroup: System.String; Const
JScript
public constvar LoadGroup : System.String;
Managed Extensions for C++
public: const System.string* LoadGroup
C++/CLI
public:
const System.String^ LoadGroup

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PostBackAction Class
PostBackAction Members


LoadPreviewRow Field

[image]
Intersoft WebGrid Documentation
LoadPreviewRow Field
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > PostBackAction Class : LoadPreviewRow Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Const LoadPreviewRow As System.String
Visual Basic (Usage) Copy Code
Dim value As System.String

value = PostBackAction.LoadPreviewRow
C#
public const System.string LoadPreviewRow
Delphi
public field LoadPreviewRow: System.String; Const
JScript
public constvar LoadPreviewRow : System.String;
Managed Extensions for C++
public: const System.string* LoadPreviewRow
C++/CLI
public:
const System.String^ LoadPreviewRow

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PostBackAction Class
PostBackAction Members


LoadSelfRefChild Field

[image]
Intersoft WebGrid Documentation
LoadSelfRefChild Field
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > PostBackAction Class : LoadSelfRefChild Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Const LoadSelfRefChild As System.String
Visual Basic (Usage) Copy Code
Dim value As System.String

value = PostBackAction.LoadSelfRefChild
C#
public const System.string LoadSelfRefChild
Delphi
public field LoadSelfRefChild: System.String; Const
JScript
public constvar LoadSelfRefChild : System.String;
Managed Extensions for C++
public: const System.string* LoadSelfRefChild
C++/CLI
public:
const System.String^ LoadSelfRefChild

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PostBackAction Class
PostBackAction Members


MoreData Field

[image]
Intersoft WebGrid Documentation
MoreData Field
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > PostBackAction Class : MoreData Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Const MoreData As System.String
Visual Basic (Usage) Copy Code
Dim value As System.String

value = PostBackAction.MoreData
C#
public const System.string MoreData
Delphi
public field MoreData: System.String; Const
JScript
public constvar MoreData : System.String;
Managed Extensions for C++
public: const System.string* MoreData
C++/CLI
public:
const System.String^ MoreData

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PostBackAction Class
PostBackAction Members


Paging Field

[image]
Intersoft WebGrid Documentation
Paging Field
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > PostBackAction Class : Paging Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Const Paging As System.String
Visual Basic (Usage) Copy Code
Dim value As System.String

value = PostBackAction.Paging
C#
public const System.string Paging
Delphi
public field Paging: System.String; Const
JScript
public constvar Paging : System.String;
Managed Extensions for C++
public: const System.string* Paging
C++/CLI
public:
const System.String^ Paging

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PostBackAction Class
PostBackAction Members


RefreshAll Field

[image]
Intersoft WebGrid Documentation
RefreshAll Field
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > PostBackAction Class : RefreshAll Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Const RefreshAll As System.String
Visual Basic (Usage) Copy Code
Dim value As System.String

value = PostBackAction.RefreshAll
C#
public const System.string RefreshAll
Delphi
public field RefreshAll: System.String; Const
JScript
public constvar RefreshAll : System.String;
Managed Extensions for C++
public: const System.string* RefreshAll
C++/CLI
public:
const System.String^ RefreshAll

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PostBackAction Class
PostBackAction Members


RefreshData Field

[image]
Intersoft WebGrid Documentation
RefreshData Field
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > PostBackAction Class : RefreshData Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Const RefreshData As System.String
Visual Basic (Usage) Copy Code
Dim value As System.String

value = PostBackAction.RefreshData
C#
public const System.string RefreshData
Delphi
public field RefreshData: System.String; Const
JScript
public constvar RefreshData : System.String;
Managed Extensions for C++
public: const System.string* RefreshData
C++/CLI
public:
const System.String^ RefreshData

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PostBackAction Class
PostBackAction Members


RowChanged Field

[image]
Intersoft WebGrid Documentation
RowChanged Field
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > PostBackAction Class : RowChanged Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Const RowChanged As System.String
Visual Basic (Usage) Copy Code
Dim value As System.String

value = PostBackAction.RowChanged
C#
public const System.string RowChanged
Delphi
public field RowChanged: System.String; Const
JScript
public constvar RowChanged : System.String;
Managed Extensions for C++
public: const System.string* RowChanged
C++/CLI
public:
const System.String^ RowChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PostBackAction Class
PostBackAction Members


Update Field

[image]
Intersoft WebGrid Documentation
Update Field
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > PostBackAction Class : Update Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Const Update As System.String
Visual Basic (Usage) Copy Code
Dim value As System.String

value = PostBackAction.Update
C#
public const System.string Update
Delphi
public field Update: System.String; Const
JScript
public constvar Update : System.String;
Managed Extensions for C++
public: const System.string* Update
C++/CLI
public:
const System.String^ Update

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PostBackAction Class
PostBackAction Members


PostbackEventArgs Class

[image]
Intersoft WebGrid Documentation
PostbackEventArgs Class
Members See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : PostbackEventArgs Class

Glossary Item Box

Object Model

PostbackEventArgs Class

Syntax

Visual Basic (Declaration)
Public Class PostbackEventArgs
   Inherits BaseEventArgs
Visual Basic (Usage) Copy Code
Dim instance As PostbackEventArgs
C#
public class PostbackEventArgs : BaseEventArgs
Delphi
public class PostbackEventArgs = class(BaseEventArgs)
JScript
public class PostbackEventArgs extends BaseEventArgs
Managed Extensions for C++
public __gc class PostbackEventArgs : public BaseEventArgs
C++/CLI
public ref class PostbackEventArgs : public BaseEventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
ISNet.WebUI.WebGrid.BaseEventArgs
ISNet.WebUI.WebGrid.PostbackEventArgs

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PostbackEventArgs Members
ISNet.WebUI.WebGrid Namespace


PostbackEventArgs Class Members

[image]
Intersoft WebGrid Documentation
PostbackEventArgs Class Members
See Also Properties Send Feedback
ISNet.WebUI.WebGrid Namespace : PostbackEventArgs Class

Glossary Item Box

The following tables list the members exposed by PostbackEventArgs.

Public Properties

 | Name | Description
Public Property | Action |
Public Property | CustomActionData |
Public Property | DataSource |
Public Property | Grid |
Public Property | ReturnValue | (Inherited from ISNet.WebUI.WebGrid.BaseEventArgs)
Public Property | XmlRequest |
Top

See Also

Reference

PostbackEventArgs Class
ISNet.WebUI.WebGrid Namespace


PostbackEventArgs Class Properties

[image]
Intersoft WebGrid Documentation
PostbackEventArgs Class Properties
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : PostbackEventArgs Class

Glossary Item Box

For a list of all members of this type, see PostbackEventArgs members.

Public Properties

 | Name | Description
Public Property | Action |
Public Property | CustomActionData |
Public Property | DataSource |
Public Property | Grid |
Public Property | ReturnValue | (Inherited from ISNet.WebUI.WebGrid.BaseEventArgs)
Public Property | XmlRequest |
Top

See Also

Reference

PostbackEventArgs Class
ISNet.WebUI.WebGrid Namespace


Action Property

[image]
Intersoft WebGrid Documentation
Action Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > PostbackEventArgs Class : Action Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Action As System.String
Visual Basic (Usage) Copy Code
Dim instance As PostbackEventArgs
Dim value As System.String

value = instance.Action
C#
public System.string Action {get;}
Delphi
public read-only property Action: System.String;
JScript
public function get Action : System.String
Managed Extensions for C++
public: __property System.string* get_Action();
C++/CLI
public:
property System.String^ Action {
   System.String^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PostbackEventArgs Class
PostbackEventArgs Members


CustomActionData Property

[image]
Intersoft WebGrid Documentation
CustomActionData Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > PostbackEventArgs Class : CustomActionData Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property CustomActionData As System.String
Visual Basic (Usage) Copy Code
Dim instance As PostbackEventArgs
Dim value As System.String

instance.CustomActionData = value

value = instance.CustomActionData
C#
public System.string CustomActionData {get; set;}
Delphi
public read-write property CustomActionData: System.String;
JScript
public function get,set CustomActionData : System.String
Managed Extensions for C++
public: __property System.string* get_CustomActionData();
public: __property void set_CustomActionData(
   System.string* value
);
C++/CLI
public:
property System.String^ CustomActionData {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PostbackEventArgs Class
PostbackEventArgs Members


DataSource Property

[image]
Intersoft WebGrid Documentation
DataSource Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > PostbackEventArgs Class : DataSource Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property DataSource As System.Object
Visual Basic (Usage) Copy Code
Dim instance As PostbackEventArgs
Dim value As System.Object

value = instance.DataSource
C#
public System.object DataSource {get;}
Delphi
public read-only property DataSource: System.TObject;
JScript
public function get DataSource : System.Object
Managed Extensions for C++
public: __property System.Object* get_DataSource();
C++/CLI
public:
property System.Object^ DataSource {
   System.Object^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PostbackEventArgs Class
PostbackEventArgs Members


Grid Property

[image]
Intersoft WebGrid Documentation
Grid Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > PostbackEventArgs Class : Grid Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Grid As WebGrid
Visual Basic (Usage) Copy Code
Dim instance As PostbackEventArgs
Dim value As WebGrid

value = instance.Grid
C#
public WebGrid Grid {get;}
Delphi
public read-only property Grid: WebGrid;
JScript
public function get Grid : WebGrid
Managed Extensions for C++
public: __property WebGrid* get_Grid();
C++/CLI
public:
property WebGrid^ Grid {
   WebGrid^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PostbackEventArgs Class
PostbackEventArgs Members


XmlRequest Property

[image]
Intersoft WebGrid Documentation
XmlRequest Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > PostbackEventArgs Class : XmlRequest Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property XmlRequest As System.Xml.XmlDocument
Visual Basic (Usage) Copy Code
Dim instance As PostbackEventArgs
Dim value As System.Xml.XmlDocument

value = instance.XmlRequest
C#
public System.Xml.XmlDocument XmlRequest {get;}
Delphi
public read-only property XmlRequest: System.Xml.XmlDocument;
JScript
public function get XmlRequest : System.Xml.XmlDocument
Managed Extensions for C++
public: __property System.Xml.XmlDocument* get_XmlRequest();
C++/CLI
public:
property System.Xml.XmlDocument^ XmlRequest {
   System.Xml.XmlDocument^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PostbackEventArgs Class
PostbackEventArgs Members


PrepareExportExecuteEventArgs Class

[image]
Intersoft WebGrid Documentation
PrepareExportExecuteEventArgs Class
Members See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : PrepareExportExecuteEventArgs Class

Glossary Item Box

Object Model

PrepareExportExecuteEventArgs Class

Syntax

Visual Basic (Declaration)
Public Class PrepareExportExecuteEventArgs
   Inherits BaseEventArgs
Visual Basic (Usage) Copy Code
Dim instance As PrepareExportExecuteEventArgs
C#
public class PrepareExportExecuteEventArgs : BaseEventArgs
Delphi
public class PrepareExportExecuteEventArgs = class(BaseEventArgs)
JScript
public class PrepareExportExecuteEventArgs extends BaseEventArgs
Managed Extensions for C++
public __gc class PrepareExportExecuteEventArgs : public BaseEventArgs
C++/CLI
public ref class PrepareExportExecuteEventArgs : public BaseEventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
ISNet.WebUI.WebGrid.BaseEventArgs
ISNet.WebUI.WebGrid.PrepareExportExecuteEventArgs

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PrepareExportExecuteEventArgs Members
ISNet.WebUI.WebGrid Namespace


PrepareExportExecuteEventArgs Class Members

[image]
Intersoft WebGrid Documentation
PrepareExportExecuteEventArgs Class Members
See Also Properties Send Feedback
ISNet.WebUI.WebGrid Namespace : PrepareExportExecuteEventArgs Class

Glossary Item Box

The following tables list the members exposed by PrepareExportExecuteEventArgs.

Public Constructors

 | Name | Description
Public Constructor | PrepareExportExecuteEventArgs Constructor |
Top

Public Properties

 | Name | Description
Public Property | ReportObject |
Public Property | ReturnValue | (Inherited from ISNet.WebUI.WebGrid.BaseEventArgs)
Top

See Also

Reference

PrepareExportExecuteEventArgs Class
ISNet.WebUI.WebGrid Namespace


PrepareExportExecuteEventArgs Constructor

[image]
Intersoft WebGrid Documentation
PrepareExportExecuteEventArgs Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > PrepareExportExecuteEventArgs Class : PrepareExportExecuteEventArgs Constructor

report

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal report As DataDynamics.ActiveReports.ActiveReport3 _
)
Visual Basic (Usage) Copy Code
Dim report As DataDynamics.ActiveReports.ActiveReport3

Dim instance As New PrepareExportExecuteEventArgs(report)
C#
public PrepareExportExecuteEventArgs(
   DataDynamics.ActiveReports.ActiveReport3 report
)
Delphi
public PrepareExportExecuteEventArgs(
    report: DataDynamics.ActiveReports.ActiveReport3
);
JScript
public function PrepareExportExecuteEventArgs(
   report : DataDynamics.ActiveReports.ActiveReport3
);
Managed Extensions for C++
public: PrepareExportExecuteEventArgs(
   DataDynamics.ActiveReports.ActiveReport3* report
)
C++/CLI
public:
PrepareExportExecuteEventArgs(
   DataDynamics.ActiveReports.ActiveReport3^ report
)

Parameters

report

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PrepareExportExecuteEventArgs Class
PrepareExportExecuteEventArgs Members


PrepareExportExecuteEventArgs Class Properties

[image]
Intersoft WebGrid Documentation
PrepareExportExecuteEventArgs Class Properties
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : PrepareExportExecuteEventArgs Class

Glossary Item Box

For a list of all members of this type, see PrepareExportExecuteEventArgs members.

Public Properties

 | Name | Description
Public Property | ReportObject |
Public Property | ReturnValue | (Inherited from ISNet.WebUI.WebGrid.BaseEventArgs)
Top

See Also

Reference

PrepareExportExecuteEventArgs Class
ISNet.WebUI.WebGrid Namespace


ReportObject Property

[image]
Intersoft WebGrid Documentation
ReportObject Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > PrepareExportExecuteEventArgs Class : ReportObject Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ReportObject As DataDynamics.ActiveReports.ActiveReport3
Visual Basic (Usage) Copy Code
Dim instance As PrepareExportExecuteEventArgs
Dim value As DataDynamics.ActiveReports.ActiveReport3

value = instance.ReportObject
C#
public DataDynamics.ActiveReports.ActiveReport3 ReportObject {get;}
Delphi
public read-only property ReportObject: DataDynamics.ActiveReports.ActiveReport3;
JScript
public function get ReportObject : DataDynamics.ActiveReports.ActiveReport3
Managed Extensions for C++
public: __property DataDynamics.ActiveReports.ActiveReport3* get_ReportObject();
C++/CLI
public:
property DataDynamics.ActiveReports.ActiveReport3^ ReportObject {
   DataDynamics.ActiveReports.ActiveReport3^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PrepareExportExecuteEventArgs Class
PrepareExportExecuteEventArgs Members


PreviewRowSettings Class

[image]
Intersoft WebGrid Documentation
PreviewRowSettings Class
Members See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : PreviewRowSettings Class

Glossary Item Box

Object Model

PreviewRowSettings Class

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.DescriptionAttribute()>
<System.SerializableAttribute()>
Public Class PreviewRowSettings
   Inherits ISNet.WebUI.WebUIBaseClass
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Visual Basic (Usage) Copy Code
Dim instance As PreviewRowSettings
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DescriptionAttribute()]
[System.SerializableAttribute()]
public class PreviewRowSettings : ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Delphi
public class PreviewRowSettings = class(ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize)
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.DescriptionAttribute()
System.SerializableAttribute()
public class PreviewRowSettings extends ISNet.WebUI.WebUIBaseClass implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DescriptionAttribute()]
[System.SerializableAttribute()]
public __gc class PreviewRowSettings : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DescriptionAttribute()]
[System.SerializableAttribute()]
public ref class PreviewRowSettings : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.WebGrid.PreviewRowSettings

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PreviewRowSettings Members
ISNet.WebUI.WebGrid Namespace


PreviewRowSettings Class Members

[image]
Intersoft WebGrid Documentation
PreviewRowSettings Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebGrid Namespace : PreviewRowSettings Class

Glossary Item Box

The following tables list the members exposed by PreviewRowSettings.

Public Constructors

 | Name | Description
Public Constructor | PreviewRowSettings Constructor |
Top

Public Properties

 | Name | Description
Public Property | DataMember |
Public Property | DefaultExpanded |
Public Property | Expandable |
Public Property | Height |
Public Property | Indentation |
Public Property | LoadOnDemand |
Public Property | Style |
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString |
Top

See Also

Reference

PreviewRowSettings Class
ISNet.WebUI.WebGrid Namespace


PreviewRowSettings Constructor

[image]
Intersoft WebGrid Documentation
PreviewRowSettings Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > PreviewRowSettings Class : PreviewRowSettings Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New PreviewRowSettings()
C#
public PreviewRowSettings()
Delphi
public PreviewRowSettings();
JScript
public function PreviewRowSettings();
Managed Extensions for C++
public: PreviewRowSettings();
C++/CLI
public:
PreviewRowSettings();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PreviewRowSettings Class
PreviewRowSettings Members


Clone Method

[image]
Intersoft WebGrid Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > PreviewRowSettings Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As System.Object
Visual Basic (Usage) Copy Code
Dim instance As PreviewRowSettings
Dim value As System.Object

value = instance.Clone()
C#
public virtual System.object Clone()
Delphi
public function Clone(): System.TObject; virtual;
JScript
public function Clone() : System.Object;
Managed Extensions for C++
public: virtual System.Object* Clone();
C++/CLI
public:
virtual System.Object^ Clone();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PreviewRowSettings Class
PreviewRowSettings Members


CopyFrom Method

[image]
Intersoft WebGrid Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > PreviewRowSettings Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PreviewRowSettings Class
PreviewRowSettings Members


CopyFrom(Object) Method

[image]
Intersoft WebGrid Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > PreviewRowSettings Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As PreviewRowSettings
Dim objSource As System.Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   System.object objSource
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PreviewRowSettings Class
PreviewRowSettings Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebGrid Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > PreviewRowSettings Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object, _
   ByVal cloneSourceValue As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As PreviewRowSettings
Dim objSource As System.Object
Dim cloneSourceValue As System.Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   System.object objSource,
   System.bool cloneSourceValue
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject;
    cloneSourceValue: System.Boolean
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object,
   cloneSourceValue : System.boolean
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource,
   System.bool cloneSourceValue
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource,
   System.bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PreviewRowSettings Class
PreviewRowSettings Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebGrid Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > PreviewRowSettings Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As PreviewRowSettings
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure DeSerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function DeSerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void DeSerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void DeSerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PreviewRowSettings Class
PreviewRowSettings Members


GetHashCode Method

[image]
Intersoft WebGrid Documentation
GetHashCode Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > PreviewRowSettings Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As PreviewRowSettings
Dim value As System.Integer

value = instance.GetHashCode()
C#
public virtual System.int GetHashCode()
Delphi
public function GetHashCode(): System.Integer; virtual;
JScript
public function GetHashCode() : System.int;
Managed Extensions for C++
public: virtual System.int GetHashCode();
C++/CLI
public:
virtual System.int GetHashCode();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PreviewRowSettings Class
PreviewRowSettings Members


PreviewRowSettings Class Methods

[image]
Intersoft WebGrid Documentation
PreviewRowSettings Class Methods
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : PreviewRowSettings Class

Glossary Item Box

For a list of all members of this type, see PreviewRowSettings members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString |
Top

See Also

Reference

PreviewRowSettings Class
ISNet.WebUI.WebGrid Namespace


GetObjectData Method

[image]
Intersoft WebGrid Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > PreviewRowSettings Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As PreviewRowSettings
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure GetObjectData(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
); override;
JScript
public override function GetObjectData(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void GetObjectData(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
) override
C++/CLI
public:
void GetObjectData(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
) override

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PreviewRowSettings Class
PreviewRowSettings Members


IsEmpty Method

[image]
Intersoft WebGrid Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > PreviewRowSettings Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As PreviewRowSettings
Dim value As System.Boolean

value = instance.IsEmpty()
C#
public virtual System.bool IsEmpty()
Delphi
public function IsEmpty(): System.Boolean; virtual;
JScript
public function IsEmpty() : System.boolean;
Managed Extensions for C++
public: virtual System.bool IsEmpty();
C++/CLI
public:
virtual System.bool IsEmpty();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PreviewRowSettings Class
PreviewRowSettings Members


Reset Method

[image]
Intersoft WebGrid Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > PreviewRowSettings Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As PreviewRowSettings

instance.Reset()
C#
public virtual void Reset()
Delphi
public procedure Reset(); virtual;
JScript
public function Reset();
Managed Extensions for C++
public: virtual void Reset();
C++/CLI
public:
virtual void Reset();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PreviewRowSettings Class
PreviewRowSettings Members


SerializeObjectData Method

[image]
Intersoft WebGrid Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > PreviewRowSettings Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As PreviewRowSettings
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure SerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function SerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void SerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void SerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PreviewRowSettings Class
PreviewRowSettings Members


ToString Method

[image]
Intersoft WebGrid Documentation
ToString Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > PreviewRowSettings Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString() As System.String
Visual Basic (Usage) Copy Code
Dim instance As PreviewRowSettings
Dim value As System.String

value = instance.ToString()
C#
public override System.string ToString()
Delphi
public function ToString(): System.String; override;
JScript
public override function ToString() : System.String;
Managed Extensions for C++
public: System.string* ToString(); override
C++/CLI
public:
System.String^ ToString(); override

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PreviewRowSettings Class
PreviewRowSettings Members


PreviewRowSettings Class Properties

[image]
Intersoft WebGrid Documentation
PreviewRowSettings Class Properties
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : PreviewRowSettings Class

Glossary Item Box

For a list of all members of this type, see PreviewRowSettings members.

Public Properties

 | Name | Description
Public Property | DataMember |
Public Property | DefaultExpanded |
Public Property | Expandable |
Public Property | Height |
Public Property | Indentation |
Public Property | LoadOnDemand |
Public Property | Style |
Top

See Also

Reference

PreviewRowSettings Class
ISNet.WebUI.WebGrid Namespace


PreviewRowSettings Constructor

[image]
Intersoft WebGrid Documentation
PreviewRowSettings Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > PreviewRowSettings Class : PreviewRowSettings Constructor

Glossary Item Box

Overload List

Overload | Description
PreviewRowSettings Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PreviewRowSettings Class
PreviewRowSettings Members


DataMember Property

[image]
Intersoft WebGrid Documentation
DataMember Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > PreviewRowSettings Class : DataMember Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebGrid.DataFieldEditor, ISNet.WebUI.WebGrid, Version=9.0.7200.1, Culture=neutral, PublicKeyToken=3e60b85fb8502d5e")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute()>
Public Property DataMember As System.String
Visual Basic (Usage) Copy Code
Dim instance As PreviewRowSettings
Dim value As System.String

instance.DataMember = value

value = instance.DataMember
C#
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebGrid.DataFieldEditor, ISNet.WebUI.WebGrid, Version=9.0.7200.1, Culture=neutral, PublicKeyToken=3e60b85fb8502d5e")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute()]
public System.string DataMember {get; set;}
Delphi
public read-write property DataMember: System.String;
JScript
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebGrid.DataFieldEditor, ISNet.WebUI.WebGrid, Version=9.0.7200.1, Culture=neutral, PublicKeyToken=3e60b85fb8502d5e")
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute()
public function get,set DataMember : System.String
Managed Extensions for C++
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebGrid.DataFieldEditor, ISNet.WebUI.WebGrid, Version=9.0.7200.1, Culture=neutral, PublicKeyToken=3e60b85fb8502d5e")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute()]
public: __property System.string* get_DataMember();
public: __property void set_DataMember(
   System.string* value
);
C++/CLI
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebGrid.DataFieldEditor, ISNet.WebUI.WebGrid, Version=9.0.7200.1, Culture=neutral, PublicKeyToken=3e60b85fb8502d5e")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute()]
public:
property System.String^ DataMember {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PreviewRowSettings Class
PreviewRowSettings Members


DefaultExpanded Property

[image]
Intersoft WebGrid Documentation
DefaultExpanded Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > PreviewRowSettings Class : DefaultExpanded Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property DefaultExpanded As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As PreviewRowSettings
Dim value As System.Boolean

instance.DefaultExpanded = value

value = instance.DefaultExpanded
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.bool DefaultExpanded {get; set;}
Delphi
public read-write property DefaultExpanded: System.Boolean;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set DefaultExpanded : System.boolean
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.bool get_DefaultExpanded();
public: __property void set_DefaultExpanded(
   System.bool value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.bool DefaultExpanded {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PreviewRowSettings Class
PreviewRowSettings Members


Expandable Property

[image]
Intersoft WebGrid Documentation
Expandable Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > PreviewRowSettings Class : Expandable Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Property Expandable As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As PreviewRowSettings
Dim value As System.Boolean

instance.Expandable = value

value = instance.Expandable
C#
[System.ComponentModel.DescriptionAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
public System.bool Expandable {get; set;}
Delphi
public read-write property Expandable: System.Boolean;
JScript
System.ComponentModel.DescriptionAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.XmlSerializableAttribute()
public function get,set Expandable : System.boolean
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property System.bool get_Expandable();
public: __property void set_Expandable(
   System.bool value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property System.bool Expandable {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PreviewRowSettings Class
PreviewRowSettings Members


Height Property

[image]
Intersoft WebGrid Documentation
Height Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > PreviewRowSettings Class : Height Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DescriptionAttribute()>
Public Property Height As System.Web.UI.WebControls.Unit
Visual Basic (Usage) Copy Code
Dim instance As PreviewRowSettings
Dim value As System.Web.UI.WebControls.Unit

instance.Height = value

value = instance.Height
C#
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute()]
public System.Web.UI.WebControls.Unit Height {get; set;}
Delphi
public read-write property Height: System.Web.UI.WebControls.Unit;
JScript
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DescriptionAttribute()
public function get,set Height : System.Web.UI.WebControls.Unit
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute()]
public: __property System.Web.UI.WebControls.Unit get_Height();
public: __property void set_Height(
   System.Web.UI.WebControls.Unit value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute()]
public:
property System.Web.UI.WebControls.Unit Height {
   System.Web.UI.WebControls.Unit get();
   void set (    System.Web.UI.WebControls.Unit value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PreviewRowSettings Class
PreviewRowSettings Members


Indentation Property

[image]
Intersoft WebGrid Documentation
Indentation Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > PreviewRowSettings Class : Indentation Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DescriptionAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Property Indentation As System.Web.UI.WebControls.Unit
Visual Basic (Usage) Copy Code
Dim instance As PreviewRowSettings
Dim value As System.Web.UI.WebControls.Unit

instance.Indentation = value

value = instance.Indentation
C#
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
public System.Web.UI.WebControls.Unit Indentation {get; set;}
Delphi
public read-write property Indentation: System.Web.UI.WebControls.Unit;
JScript
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DescriptionAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.XmlSerializableAttribute()
public function get,set Indentation : System.Web.UI.WebControls.Unit
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property System.Web.UI.WebControls.Unit get_Indentation();
public: __property void set_Indentation(
   System.Web.UI.WebControls.Unit value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property System.Web.UI.WebControls.Unit Indentation {
   System.Web.UI.WebControls.Unit get();
   void set (    System.Web.UI.WebControls.Unit value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PreviewRowSettings Class
PreviewRowSettings Members


LoadOnDemand Property

[image]
Intersoft WebGrid Documentation
LoadOnDemand Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > PreviewRowSettings Class : LoadOnDemand Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies whether the preview row should be loaded on demand.")>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Property LoadOnDemand As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As PreviewRowSettings
Dim value As System.Boolean

instance.LoadOnDemand = value

value = instance.LoadOnDemand
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether the preview row should be loaded on demand.")]
[ISNet.Serialization.XmlSerializableAttribute()]
public System.bool LoadOnDemand {get; set;}
Delphi
public read-write property LoadOnDemand: System.Boolean;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Specifies whether the preview row should be loaded on demand.")
ISNet.Serialization.XmlSerializableAttribute()
public function get,set LoadOnDemand : System.boolean
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether the preview row should be loaded on demand.")]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property System.bool get_LoadOnDemand();
public: __property void set_LoadOnDemand(
   System.bool value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether the preview row should be loaded on demand.")]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property System.bool LoadOnDemand {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PreviewRowSettings Class
PreviewRowSettings Members


Style Property

[image]
Intersoft WebGrid Documentation
Style Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > PreviewRowSettings Class : Style Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("The style applied to the preview row area.")>
Public Property Style As WebGridFormatStyle
Visual Basic (Usage) Copy Code
Dim instance As PreviewRowSettings
Dim value As WebGridFormatStyle

instance.Style = value

value = instance.Style
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("The style applied to the preview row area.")]
public WebGridFormatStyle Style {get; set;}
Delphi
public read-write property Style: WebGridFormatStyle;
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("The style applied to the preview row area.")
public function get,set Style : WebGridFormatStyle
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("The style applied to the preview row area.")]
public: __property WebGridFormatStyle* get_Style();
public: __property void set_Style(
   WebGridFormatStyle* value
);
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("The style applied to the preview row area.")]
public:
property WebGridFormatStyle^ Style {
   WebGridFormatStyle^ get();
   void set (    WebGridFormatStyle^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PreviewRowSettings Class
PreviewRowSettings Members


PrimaryKeyAttribute Class

[image]
Intersoft WebGrid Documentation
PrimaryKeyAttribute Class
Members See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : PrimaryKeyAttribute Class

Glossary Item Box

Object Model

PrimaryKeyAttribute Class

Syntax

Visual Basic (Declaration)
<System.AttributeUsageAttribute(ValidOn=AttributeTargets.Assembly Or  _
    AttributeTargets.Module Or  _
    AttributeTargets.Class Or  _
    AttributeTargets.Struct Or  _
    AttributeTargets.Enum Or  _
    AttributeTargets.Constructor Or  _
    AttributeTargets.Method Or  _
    AttributeTargets.Property Or  _
    AttributeTargets.Field Or  _
    AttributeTargets.Event Or  _
    AttributeTargets.Interface Or  _
    AttributeTargets.Parameter Or  _
    AttributeTargets.Delegate Or  _
    AttributeTargets.ReturnValue Or  _
    AttributeTargets.GenericParameter Or  _
    AttributeTargets.All,
   AllowMultiple=False,
   Inherited=True)>
Public Class PrimaryKeyAttribute
   Inherits System.Attribute
Visual Basic (Usage) Copy Code
Dim instance As PrimaryKeyAttribute
C#
[System.AttributeUsageAttribute(ValidOn=AttributeTargets.Assembly |
    AttributeTargets.Module |
    AttributeTargets.Class |
    AttributeTargets.Struct |
    AttributeTargets.Enum |
    AttributeTargets.Constructor |
    AttributeTargets.Method |
    AttributeTargets.Property |
    AttributeTargets.Field |
    AttributeTargets.Event |
    AttributeTargets.Interface |
    AttributeTargets.Parameter |
    AttributeTargets.Delegate |
    AttributeTargets.ReturnValue |
    AttributeTargets.GenericParameter |
    AttributeTargets.All,
   AllowMultiple=false,
   Inherited=true)]
public class PrimaryKeyAttribute : System.Attribute
Delphi
public class PrimaryKeyAttribute = class(System.Attribute)
JScript
System.AttributeUsageAttribute(ValidOn=AttributeTargets.Assembly |
    AttributeTargets.Module |
    AttributeTargets.Class |
    AttributeTargets.Struct |
    AttributeTargets.Enum |
    AttributeTargets.Constructor |
    AttributeTargets.Method |
    AttributeTargets.Property |
    AttributeTargets.Field |
    AttributeTargets.Event |
    AttributeTargets.Interface |
    AttributeTargets.Parameter |
    AttributeTargets.Delegate |
    AttributeTargets.ReturnValue |
    AttributeTargets.GenericParameter |
    AttributeTargets.All,
   AllowMultiple=,
   Inherited=)
public class PrimaryKeyAttribute extends System.Attribute
Managed Extensions for C++
[System.AttributeUsageAttribute(ValidOn=AttributeTargets.Assembly |
    AttributeTargets.Module |
    AttributeTargets.Class |
    AttributeTargets.Struct |
    AttributeTargets.Enum |
    AttributeTargets.Constructor |
    AttributeTargets.Method |
    AttributeTargets.Property |
    AttributeTargets.Field |
    AttributeTargets.Event |
    AttributeTargets.Interface |
    AttributeTargets.Parameter |
    AttributeTargets.Delegate |
    AttributeTargets.ReturnValue |
    AttributeTargets.GenericParameter |
    AttributeTargets.All,
   AllowMultiple=false,
   Inherited=true)]
public __gc class PrimaryKeyAttribute : public System.Attribute
C++/CLI
[System.AttributeUsageAttribute(ValidOn=AttributeTargets.Assembly |
    AttributeTargets.Module |
    AttributeTargets.Class |
    AttributeTargets.Struct |
    AttributeTargets.Enum |
    AttributeTargets.Constructor |
    AttributeTargets.Method |
    AttributeTargets.Property |
    AttributeTargets.Field |
    AttributeTargets.Event |
    AttributeTargets.Interface |
    AttributeTargets.Parameter |
    AttributeTargets.Delegate |
    AttributeTargets.ReturnValue |
    AttributeTargets.GenericParameter |
    AttributeTargets.All,
   AllowMultiple=false,
   Inherited=true)]
public ref class PrimaryKeyAttribute : public System.Attribute

Inheritance Hierarchy

System.Object
System.Attribute
ISNet.WebUI.WebGrid.PrimaryKeyAttribute

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PrimaryKeyAttribute Members
ISNet.WebUI.WebGrid Namespace


PrimaryKeyAttribute Class Members

[image]
Intersoft WebGrid Documentation
PrimaryKeyAttribute Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebGrid Namespace : PrimaryKeyAttribute Class

Glossary Item Box

The following tables list the members exposed by PrimaryKeyAttribute.

Public Constructors

 | Name | Description
Public Constructor | PrimaryKeyAttribute Constructor |
Top

Public Properties

 | Name | Description
Public Property | TypeId | (Inherited from System.Attribute)
Top

Public Methods

 | Name | Description
Public Method | Equals | (Inherited from System.Attribute)
Public Method | GetHashCode | (Inherited from System.Attribute)
Public Method | IsDefaultAttribute | (Inherited from System.Attribute)
Public Method | Match | (Inherited from System.Attribute)
Top

See Also

Reference

PrimaryKeyAttribute Class
ISNet.WebUI.WebGrid Namespace


PrimaryKeyAttribute Class Methods

[image]
Intersoft WebGrid Documentation
PrimaryKeyAttribute Class Methods
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : PrimaryKeyAttribute Class

Glossary Item Box

For a list of all members of this type, see PrimaryKeyAttribute members.

Public Methods

 | Name | Description
Public Method | Equals | (Inherited from System.Attribute)
Public Method | GetHashCode | (Inherited from System.Attribute)
Public Method | IsDefaultAttribute | (Inherited from System.Attribute)
Public Method | Match | (Inherited from System.Attribute)
Top

See Also

Reference

PrimaryKeyAttribute Class
ISNet.WebUI.WebGrid Namespace


PrimaryKeyAttribute Class Properties

[image]
Intersoft WebGrid Documentation
PrimaryKeyAttribute Class Properties
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : PrimaryKeyAttribute Class

Glossary Item Box

For a list of all members of this type, see PrimaryKeyAttribute members.

Public Properties

 | Name | Description
Public Property | TypeId | (Inherited from System.Attribute)
Top

See Also

Reference

PrimaryKeyAttribute Class
ISNet.WebUI.WebGrid Namespace


PrimaryKeyAttribute Constructor

[image]
Intersoft WebGrid Documentation
PrimaryKeyAttribute Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > PrimaryKeyAttribute Class : PrimaryKeyAttribute Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New PrimaryKeyAttribute()
C#
public PrimaryKeyAttribute()
Delphi
public PrimaryKeyAttribute();
JScript
public function PrimaryKeyAttribute();
Managed Extensions for C++
public: PrimaryKeyAttribute();
C++/CLI
public:
PrimaryKeyAttribute();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PrimaryKeyAttribute Class
PrimaryKeyAttribute Members


Equals Method

[image]
Intersoft WebGrid Documentation
Equals Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > PrimaryKeyAttribute Class : Equals Method

obj

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Security.SecuritySafeCriticalAttribute()>
<__DynamicallyInvokableAttribute()>
Public Overridable Function Equals( _
   ByVal obj As System.Object _
) As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As PrimaryKeyAttribute
Dim obj As System.Object
Dim value As System.Boolean

value = instance.Equals(obj)
C#
[System.Security.SecuritySafeCriticalAttribute()]
[__DynamicallyInvokableAttribute()]
public virtual System.bool Equals(
   System.object obj
)
Delphi
public function Equals(
    obj: System.TObject
): System.Boolean; virtual;
JScript
System.Security.SecuritySafeCriticalAttribute()
__DynamicallyInvokableAttribute()
public function Equals(
   obj : System.Object
) : System.boolean;
Managed Extensions for C++
[System.Security.SecuritySafeCriticalAttribute()]
[__DynamicallyInvokableAttribute()]
public: virtual System.bool Equals(
   System.Object* obj
)
C++/CLI
[System.Security.SecuritySafeCriticalAttribute()]
[__DynamicallyInvokableAttribute()]
public:
virtual System.bool Equals(
   System.Object^ obj
)

Parameters

obj

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PrimaryKeyAttribute Class
PrimaryKeyAttribute Members


GetHashCode Method

[image]
Intersoft WebGrid Documentation
GetHashCode Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > PrimaryKeyAttribute Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Security.SecuritySafeCriticalAttribute()>
<__DynamicallyInvokableAttribute()>
Public Overridable Function GetHashCode() As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As PrimaryKeyAttribute
Dim value As System.Integer

value = instance.GetHashCode()
C#
[System.Security.SecuritySafeCriticalAttribute()]
[__DynamicallyInvokableAttribute()]
public virtual System.int GetHashCode()
Delphi
public function GetHashCode(): System.Integer; virtual;
JScript
System.Security.SecuritySafeCriticalAttribute()
__DynamicallyInvokableAttribute()
public function GetHashCode() : System.int;
Managed Extensions for C++
[System.Security.SecuritySafeCriticalAttribute()]
[__DynamicallyInvokableAttribute()]
public: virtual System.int GetHashCode();
C++/CLI
[System.Security.SecuritySafeCriticalAttribute()]
[__DynamicallyInvokableAttribute()]
public:
virtual System.int GetHashCode();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PrimaryKeyAttribute Class
PrimaryKeyAttribute Members


IsDefaultAttribute Method

[image]
Intersoft WebGrid Documentation
IsDefaultAttribute Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > PrimaryKeyAttribute Class : IsDefaultAttribute Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsDefaultAttribute() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As PrimaryKeyAttribute
Dim value As System.Boolean

value = instance.IsDefaultAttribute()
C#
public virtual System.bool IsDefaultAttribute()
Delphi
public function IsDefaultAttribute(): System.Boolean; virtual;
JScript
public function IsDefaultAttribute() : System.boolean;
Managed Extensions for C++
public: virtual System.bool IsDefaultAttribute();
C++/CLI
public:
virtual System.bool IsDefaultAttribute();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PrimaryKeyAttribute Class
PrimaryKeyAttribute Members


Match Method

[image]
Intersoft WebGrid Documentation
Match Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > PrimaryKeyAttribute Class : Match Method

obj

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Match( _
   ByVal obj As System.Object _
) As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As PrimaryKeyAttribute
Dim obj As System.Object
Dim value As System.Boolean

value = instance.Match(obj)
C#
public virtual System.bool Match(
   System.object obj
)
Delphi
public function Match(
    obj: System.TObject
): System.Boolean; virtual;
JScript
public function Match(
   obj : System.Object
) : System.boolean;
Managed Extensions for C++
public: virtual System.bool Match(
   System.Object* obj
)
C++/CLI
public:
virtual System.bool Match(
   System.Object^ obj
)

Parameters

obj

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PrimaryKeyAttribute Class
PrimaryKeyAttribute Members


TypeId Property

[image]
Intersoft WebGrid Documentation
TypeId Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > PrimaryKeyAttribute Class : TypeId Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property TypeId As System.Object
Visual Basic (Usage) Copy Code
Dim instance As PrimaryKeyAttribute
Dim value As System.Object

value = instance.TypeId
C#
public virtual System.object TypeId {get;}
Delphi
public read-only property TypeId: System.TObject; virtual;
JScript
public function get TypeId : System.Object
Managed Extensions for C++
public: __property virtual System.Object* get_TypeId();
C++/CLI
public:
virtual property System.Object^ TypeId {
   System.Object^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PrimaryKeyAttribute Class
PrimaryKeyAttribute Members


RowChangedEventArgs Class

[image]
Intersoft WebGrid Documentation
RowChangedEventArgs Class
Members See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : RowChangedEventArgs Class

Glossary Item Box

Object Model

RowChangedEventArgs Class

Syntax

Visual Basic (Declaration)
Public Class RowChangedEventArgs
   Inherits RowEventArgs
Visual Basic (Usage) Copy Code
Dim instance As RowChangedEventArgs
C#
public class RowChangedEventArgs : RowEventArgs
Delphi
public class RowChangedEventArgs = class(RowEventArgs)
JScript
public class RowChangedEventArgs extends RowEventArgs
Managed Extensions for C++
public __gc class RowChangedEventArgs : public RowEventArgs
C++/CLI
public ref class RowChangedEventArgs : public RowEventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
ISNet.WebUI.WebGrid.BaseEventArgs
ISNet.WebUI.WebGrid.RowEventArgs
ISNet.WebUI.WebGrid.RowChangedEventArgs

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RowChangedEventArgs Members
ISNet.WebUI.WebGrid Namespace


RowChangedEventArgs Class Members

[image]
Intersoft WebGrid Documentation
RowChangedEventArgs Class Members
See Also Properties Send Feedback
ISNet.WebUI.WebGrid Namespace : RowChangedEventArgs Class

Glossary Item Box

The following tables list the members exposed by RowChangedEventArgs.

Public Properties

 | Name | Description
Public Property | KeyValue |
Public Property | ReturnValue | (Inherited from ISNet.WebUI.WebGrid.BaseEventArgs)
Public Property | Row | (Inherited from ISNet.WebUI.WebGrid.RowEventArgs)
Public Property | Table |
Top

See Also

Reference

RowChangedEventArgs Class
ISNet.WebUI.WebGrid Namespace


RowChangedEventArgs Class Properties

[image]
Intersoft WebGrid Documentation
RowChangedEventArgs Class Properties
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : RowChangedEventArgs Class

Glossary Item Box

For a list of all members of this type, see RowChangedEventArgs members.

Public Properties

 | Name | Description
Public Property | KeyValue |
Public Property | ReturnValue | (Inherited from ISNet.WebUI.WebGrid.BaseEventArgs)
Public Property | Row | (Inherited from ISNet.WebUI.WebGrid.RowEventArgs)
Public Property | Table |
Top

See Also

Reference

RowChangedEventArgs Class
ISNet.WebUI.WebGrid Namespace


KeyValue Property

[image]
Intersoft WebGrid Documentation
KeyValue Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > RowChangedEventArgs Class : KeyValue Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property KeyValue As System.String
Visual Basic (Usage) Copy Code
Dim instance As RowChangedEventArgs
Dim value As System.String

value = instance.KeyValue
C#
public System.string KeyValue {get;}
Delphi
public read-only property KeyValue: System.String;
JScript
public function get KeyValue : System.String
Managed Extensions for C++
public: __property System.string* get_KeyValue();
C++/CLI
public:
property System.String^ KeyValue {
   System.String^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RowChangedEventArgs Class
RowChangedEventArgs Members


Table Property

[image]
Intersoft WebGrid Documentation
Table Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > RowChangedEventArgs Class : Table Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Table As WebGridTable
Visual Basic (Usage) Copy Code
Dim instance As RowChangedEventArgs
Dim value As WebGridTable

value = instance.Table
C#
public WebGridTable Table {get;}
Delphi
public read-only property Table: WebGridTable;
JScript
public function get Table : WebGridTable
Managed Extensions for C++
public: __property WebGridTable* get_Table();
C++/CLI
public:
property WebGridTable^ Table {
   WebGridTable^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RowChangedEventArgs Class
RowChangedEventArgs Members


RowEventArgs Class

[image]
Intersoft WebGrid Documentation
RowEventArgs Class
Members See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : RowEventArgs Class

Glossary Item Box

Object Model

RowEventArgs Class

Syntax

Visual Basic (Declaration)
Public Class RowEventArgs
   Inherits BaseEventArgs
Visual Basic (Usage) Copy Code
Dim instance As RowEventArgs
C#
public class RowEventArgs : BaseEventArgs
Delphi
public class RowEventArgs = class(BaseEventArgs)
JScript
public class RowEventArgs extends BaseEventArgs
Managed Extensions for C++
public __gc class RowEventArgs : public BaseEventArgs
C++/CLI
public ref class RowEventArgs : public BaseEventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
ISNet.WebUI.WebGrid.BaseEventArgs
ISNet.WebUI.WebGrid.RowEventArgs
ISNet.WebUI.WebGrid.RowChangedEventArgs

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RowEventArgs Members
ISNet.WebUI.WebGrid Namespace


RowEventArgs Class Members

[image]
Intersoft WebGrid Documentation
RowEventArgs Class Members
See Also Properties Send Feedback
ISNet.WebUI.WebGrid Namespace : RowEventArgs Class

Glossary Item Box

The following tables list the members exposed by RowEventArgs.

Public Properties

 | Name | Description
Public Property | ReturnValue | (Inherited from ISNet.WebUI.WebGrid.BaseEventArgs)
Public Property | Row |
Top

See Also

Reference

RowEventArgs Class
ISNet.WebUI.WebGrid Namespace


RowEventArgs Class Properties

[image]
Intersoft WebGrid Documentation
RowEventArgs Class Properties
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : RowEventArgs Class

Glossary Item Box

For a list of all members of this type, see RowEventArgs members.

Public Properties

 | Name | Description
Public Property | ReturnValue | (Inherited from ISNet.WebUI.WebGrid.BaseEventArgs)
Public Property | Row |
Top

See Also

Reference

RowEventArgs Class
ISNet.WebUI.WebGrid Namespace


Row Property

[image]
Intersoft WebGrid Documentation
Row Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > RowEventArgs Class : Row Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Row As WebGridRow
Visual Basic (Usage) Copy Code
Dim instance As RowEventArgs
Dim value As WebGridRow

value = instance.Row
C#
public WebGridRow Row {get;}
Delphi
public read-only property Row: WebGridRow;
JScript
public function get Row : WebGridRow
Managed Extensions for C++
public: __property WebGridRow* get_Row();
C++/CLI
public:
property WebGridRow^ Row {
   WebGridRow^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RowEventArgs Class
RowEventArgs Members


SelectedObject Class

[image]
Intersoft WebGrid Documentation
SelectedObject Class
Members See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : SelectedObject Class

Glossary Item Box

Object Model

SelectedObject Class

Syntax

Visual Basic (Declaration)
Public Class SelectedObject
Visual Basic (Usage) Copy Code
Dim instance As SelectedObject
C#
public class SelectedObject
Delphi
public class SelectedObject
JScript
public class SelectedObject
Managed Extensions for C++
public __gc class SelectedObject
C++/CLI
public ref class SelectedObject

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebGrid.SelectedObject

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SelectedObject Members
ISNet.WebUI.WebGrid Namespace


SelectedObject Class Members

[image]
Intersoft WebGrid Documentation
SelectedObject Class Members
See Also Fields Properties Methods Send Feedback
ISNet.WebUI.WebGrid Namespace : SelectedObject Class

Glossary Item Box

The following tables list the members exposed by SelectedObject.

Public Constructors

 | Name | Description
Public Constructor | SelectedObject Constructor | Overloaded.
Top

Public Fields

 | Name | Description
Public Field | CellIndex |
Public Field | Element |
Public Field | ParentRowIndex |
Public Field | RowIndex |
Public Field | Type |
Top

Public Properties

 | Name | Description
Public Property | Grid |
Public Property | KeyValue |
Public Property | KeyValues |
Public Property | Table |
Top

Public Methods

 | Name | Description
Public Method | GetElement |
Top

See Also

Reference

SelectedObject Class
ISNet.WebUI.WebGrid Namespace


SelectedObject Constructor

[image]
Intersoft WebGrid Documentation
SelectedObject Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > SelectedObject Class : SelectedObject Constructor

Glossary Item Box

Overload List

Overload | Description
SelectedObject Constructor() |
SelectedObject Constructor(WebGridTable,Int32) |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SelectedObject Class
SelectedObject Members


SelectedObject Constructor()

[image]
Intersoft WebGrid Documentation
SelectedObject Constructor()
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > SelectedObject Class > SelectedObject Constructor : SelectedObject Constructor()

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New SelectedObject()
C#
public SelectedObject()
Delphi
public SelectedObject();
JScript
public function SelectedObject();
Managed Extensions for C++
public: SelectedObject();
C++/CLI
public:
SelectedObject();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SelectedObject Class
SelectedObject Members
Overload List


SelectedObject Constructor(WebGridTable,Int32)

[image]
Intersoft WebGrid Documentation
SelectedObject Constructor(WebGridTable,Int32)
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > SelectedObject Class > SelectedObject Constructor : SelectedObject Constructor(WebGridTable,Int32)

table
rowIndex

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal table As WebGridTable, _
   ByVal rowIndex As System.Integer _
)
Visual Basic (Usage) Copy Code
Dim table As WebGridTable
Dim rowIndex As System.Integer

Dim instance As New SelectedObject(table, rowIndex)
C#
public SelectedObject(
   WebGridTable table,
   System.int rowIndex
)
Delphi
public SelectedObject(
    table: WebGridTable;
    rowIndex: System.Integer
);
JScript
public function SelectedObject(
   table : WebGridTable,
   rowIndex : System.int
);
Managed Extensions for C++
public: SelectedObject(
   WebGridTable* table,
   System.int rowIndex
)
C++/CLI
public:
SelectedObject(
   WebGridTable^ table,
   System.int rowIndex
)

Parameters

table
rowIndex

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SelectedObject Class
SelectedObject Members
Overload List


SelectedObject Class Methods

[image]
Intersoft WebGrid Documentation
SelectedObject Class Methods
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : SelectedObject Class

Glossary Item Box

For a list of all members of this type, see SelectedObject members.

Public Methods

 | Name | Description
Public Method | GetElement |
Top

See Also

Reference

SelectedObject Class
ISNet.WebUI.WebGrid Namespace


GetElement Method

[image]
Intersoft WebGrid Documentation
GetElement Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > SelectedObject Class : GetElement Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetElement() As System.Object
Visual Basic (Usage) Copy Code
Dim instance As SelectedObject
Dim value As System.Object

value = instance.GetElement()
C#
public System.object GetElement()
Delphi
public function GetElement(): System.TObject;
JScript
public function GetElement() : System.Object;
Managed Extensions for C++
public: System.Object* GetElement();
C++/CLI
public:
System.Object^ GetElement();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SelectedObject Class
SelectedObject Members


SelectedObject Class Properties

[image]
Intersoft WebGrid Documentation
SelectedObject Class Properties
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : SelectedObject Class

Glossary Item Box

For a list of all members of this type, see SelectedObject members.

Public Properties

 | Name | Description
Public Property | Grid |
Public Property | KeyValue |
Public Property | KeyValues |
Public Property | Table |
Top

See Also

Reference

SelectedObject Class
ISNet.WebUI.WebGrid Namespace


Grid Property

[image]
Intersoft WebGrid Documentation
Grid Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > SelectedObject Class : Grid Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Grid As WebGrid
Visual Basic (Usage) Copy Code
Dim instance As SelectedObject
Dim value As WebGrid

value = instance.Grid
C#
public WebGrid Grid {get;}
Delphi
public read-only property Grid: WebGrid;
JScript
public function get Grid : WebGrid
Managed Extensions for C++
public: __property WebGrid* get_Grid();
C++/CLI
public:
property WebGrid^ Grid {
   WebGrid^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SelectedObject Class
SelectedObject Members


KeyValue Property

[image]
Intersoft WebGrid Documentation
KeyValue Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > SelectedObject Class : KeyValue Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property KeyValue As System.String
Visual Basic (Usage) Copy Code
Dim instance As SelectedObject
Dim value As System.String

value = instance.KeyValue
C#
public System.string KeyValue {get;}
Delphi
public read-only property KeyValue: System.String;
JScript
public function get KeyValue : System.String
Managed Extensions for C++
public: __property System.string* get_KeyValue();
C++/CLI
public:
property System.String^ KeyValue {
   System.String^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SelectedObject Class
SelectedObject Members


KeyValues Property

[image]
Intersoft WebGrid Documentation
KeyValues Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > SelectedObject Class : KeyValues Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property KeyValues As System.Collections.ArrayList
Visual Basic (Usage) Copy Code
Dim instance As SelectedObject
Dim value As System.Collections.ArrayList

value = instance.KeyValues
C#
public System.Collections.ArrayList KeyValues {get;}
Delphi
public read-only property KeyValues: System.Collections.ArrayList;
JScript
public function get KeyValues : System.Collections.ArrayList
Managed Extensions for C++
public: __property System.Collections.ArrayList* get_KeyValues();
C++/CLI
public:
property System.Collections.ArrayList^ KeyValues {
   System.Collections.ArrayList^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SelectedObject Class
SelectedObject Members


Table Property

[image]
Intersoft WebGrid Documentation
Table Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > SelectedObject Class : Table Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Table As WebGridTable
Visual Basic (Usage) Copy Code
Dim instance As SelectedObject
Dim value As WebGridTable

instance.Table = value

value = instance.Table
C#
public WebGridTable Table {get; set;}
Delphi
public read-write property Table: WebGridTable;
JScript
public function get,set Table : WebGridTable
Managed Extensions for C++
public: __property WebGridTable* get_Table();
public: __property void set_Table(
   WebGridTable* value
);
C++/CLI
public:
property WebGridTable^ Table {
   WebGridTable^ get();
   void set (    WebGridTable^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SelectedObject Class
SelectedObject Members


SelectedObject Class Fields

[image]
Intersoft WebGrid Documentation
SelectedObject Class Fields
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : SelectedObject Class

Glossary Item Box

For a list of all members of this type, see SelectedObject members.

Public Fields

 | Name | Description
Public Field | CellIndex |
Public Field | Element |
Public Field | ParentRowIndex |
Public Field | RowIndex |
Public Field | Type |
Top

See Also

Reference

SelectedObject Class
ISNet.WebUI.WebGrid Namespace


CellIndex Field

[image]
Intersoft WebGrid Documentation
CellIndex Field
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > SelectedObject Class : CellIndex Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public CellIndex As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As SelectedObject
Dim value As System.Integer

value = instance.CellIndex

instance.CellIndex = value
C#
public System.int CellIndex
Delphi
public field CellIndex: System.Integer;
JScript
public var CellIndex : System.int;
Managed Extensions for C++
public: System.int CellIndex
C++/CLI
public:
System.int CellIndex

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SelectedObject Class
SelectedObject Members


Element Field

[image]
Intersoft WebGrid Documentation
Element Field
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > SelectedObject Class : Element Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Element As System.Object
Visual Basic (Usage) Copy Code
Dim instance As SelectedObject
Dim value As System.Object

value = instance.Element

instance.Element = value
C#
public System.object Element
Delphi
public field Element: System.TObject;
JScript
public var Element : System.Object;
Managed Extensions for C++
public: System.Object* Element
C++/CLI
public:
System.Object^ Element

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SelectedObject Class
SelectedObject Members


ParentRowIndex Field

[image]
Intersoft WebGrid Documentation
ParentRowIndex Field
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > SelectedObject Class : ParentRowIndex Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ParentRowIndex As System.String
Visual Basic (Usage) Copy Code
Dim instance As SelectedObject
Dim value As System.String

value = instance.ParentRowIndex

instance.ParentRowIndex = value
C#
public System.string ParentRowIndex
Delphi
public field ParentRowIndex: System.String;
JScript
public var ParentRowIndex : System.String;
Managed Extensions for C++
public: System.string* ParentRowIndex
C++/CLI
public:
System.String^ ParentRowIndex

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SelectedObject Class
SelectedObject Members


RowIndex Field

[image]
Intersoft WebGrid Documentation
RowIndex Field
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > SelectedObject Class : RowIndex Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public RowIndex As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As SelectedObject
Dim value As System.Integer

value = instance.RowIndex

instance.RowIndex = value
C#
public System.int RowIndex
Delphi
public field RowIndex: System.Integer;
JScript
public var RowIndex : System.int;
Managed Extensions for C++
public: System.int RowIndex
C++/CLI
public:
System.int RowIndex

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SelectedObject Class
SelectedObject Members


Type Field

[image]
Intersoft WebGrid Documentation
Type Field
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > SelectedObject Class : Type Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Type As System.String
Visual Basic (Usage) Copy Code
Dim instance As SelectedObject
Dim value As System.String

value = instance.Type

instance.Type = value
C#
public System.string Type
Delphi
public field Type: System.String;
JScript
public var Type : System.String;
Managed Extensions for C++
public: System.string* Type
C++/CLI
public:
System.String^ Type

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SelectedObject Class
SelectedObject Members


SelfReferencingSettings Class

[image]
Intersoft WebGrid Documentation
SelfReferencingSettings Class
Members See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : SelfReferencingSettings Class

Glossary Item Box

Object Model

SelfReferencingSettings Class

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute()>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.SerializableAttribute()>
Public Class SelfReferencingSettings
   Inherits ISNet.WebUI.WebUIBaseClass
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Visual Basic (Usage) Copy Code
Dim instance As SelfReferencingSettings
C#
[System.ComponentModel.DescriptionAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public class SelfReferencingSettings : ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Delphi
public class SelfReferencingSettings = class(ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize)
JScript
System.ComponentModel.DescriptionAttribute()
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.SerializableAttribute()
public class SelfReferencingSettings extends ISNet.WebUI.WebUIBaseClass implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public __gc class SelfReferencingSettings : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
C++/CLI
[System.ComponentModel.DescriptionAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public ref class SelfReferencingSettings : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.WebGrid.SelfReferencingSettings

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SelfReferencingSettings Members
ISNet.WebUI.WebGrid Namespace


SelfReferencingSettings Class Members

[image]
Intersoft WebGrid Documentation
SelfReferencingSettings Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebGrid Namespace : SelfReferencingSettings Class

Glossary Item Box

The following tables list the members exposed by SelfReferencingSettings.

Public Constructors

 | Name | Description
Public Constructor | SelfReferencingSettings Constructor |
Top

Public Properties

 | Name | Description
Public Property | ApplyChildSorting |
Public Property | ChildDataMember |
Public Property | Enabled |
Public Property | ExpandColumnInnerTextPadding |
Public Property | ExpandColumnMember |
Public Property | FitColumnOnExpand |
Public Property | IsTreeViewSelectionMode |
Public Property | LoadOnDemand |
Public Property | ParentDataMember |
Public Property | ParentRootMode |
Public Property | ParentRootValue |
Public Property | TreatOrphanRecordsAsRoot |
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString |
Top

See Also

Reference

SelfReferencingSettings Class
ISNet.WebUI.WebGrid Namespace


SelfReferencingSettings Constructor

[image]
Intersoft WebGrid Documentation
SelfReferencingSettings Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > SelfReferencingSettings Class : SelfReferencingSettings Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New SelfReferencingSettings()
C#
public SelfReferencingSettings()
Delphi
public SelfReferencingSettings();
JScript
public function SelfReferencingSettings();
Managed Extensions for C++
public: SelfReferencingSettings();
C++/CLI
public:
SelfReferencingSettings();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SelfReferencingSettings Class
SelfReferencingSettings Members


Clone Method

[image]
Intersoft WebGrid Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > SelfReferencingSettings Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As System.Object
Visual Basic (Usage) Copy Code
Dim instance As SelfReferencingSettings
Dim value As System.Object

value = instance.Clone()
C#
public virtual System.object Clone()
Delphi
public function Clone(): System.TObject; virtual;
JScript
public function Clone() : System.Object;
Managed Extensions for C++
public: virtual System.Object* Clone();
C++/CLI
public:
virtual System.Object^ Clone();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SelfReferencingSettings Class
SelfReferencingSettings Members


CopyFrom Method

[image]
Intersoft WebGrid Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > SelfReferencingSettings Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SelfReferencingSettings Class
SelfReferencingSettings Members


CopyFrom(Object) Method

[image]
Intersoft WebGrid Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > SelfReferencingSettings Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As SelfReferencingSettings
Dim objSource As System.Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   System.object objSource
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SelfReferencingSettings Class
SelfReferencingSettings Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebGrid Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > SelfReferencingSettings Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object, _
   ByVal cloneSourceValue As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As SelfReferencingSettings
Dim objSource As System.Object
Dim cloneSourceValue As System.Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   System.object objSource,
   System.bool cloneSourceValue
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject;
    cloneSourceValue: System.Boolean
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object,
   cloneSourceValue : System.boolean
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource,
   System.bool cloneSourceValue
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource,
   System.bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SelfReferencingSettings Class
SelfReferencingSettings Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebGrid Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > SelfReferencingSettings Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As SelfReferencingSettings
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure DeSerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function DeSerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void DeSerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void DeSerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SelfReferencingSettings Class
SelfReferencingSettings Members


GetHashCode Method

[image]
Intersoft WebGrid Documentation
GetHashCode Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > SelfReferencingSettings Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As SelfReferencingSettings
Dim value As System.Integer

value = instance.GetHashCode()
C#
public virtual System.int GetHashCode()
Delphi
public function GetHashCode(): System.Integer; virtual;
JScript
public function GetHashCode() : System.int;
Managed Extensions for C++
public: virtual System.int GetHashCode();
C++/CLI
public:
virtual System.int GetHashCode();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SelfReferencingSettings Class
SelfReferencingSettings Members


SelfReferencingSettings Class Methods

[image]
Intersoft WebGrid Documentation
SelfReferencingSettings Class Methods
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : SelfReferencingSettings Class

Glossary Item Box

For a list of all members of this type, see SelfReferencingSettings members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString |
Top

See Also

Reference

SelfReferencingSettings Class
ISNet.WebUI.WebGrid Namespace


GetObjectData Method

[image]
Intersoft WebGrid Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > SelfReferencingSettings Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As SelfReferencingSettings
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure GetObjectData(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
); override;
JScript
public override function GetObjectData(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void GetObjectData(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
) override
C++/CLI
public:
void GetObjectData(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
) override

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SelfReferencingSettings Class
SelfReferencingSettings Members


IsEmpty Method

[image]
Intersoft WebGrid Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > SelfReferencingSettings Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As SelfReferencingSettings
Dim value As System.Boolean

value = instance.IsEmpty()
C#
public virtual System.bool IsEmpty()
Delphi
public function IsEmpty(): System.Boolean; virtual;
JScript
public function IsEmpty() : System.boolean;
Managed Extensions for C++
public: virtual System.bool IsEmpty();
C++/CLI
public:
virtual System.bool IsEmpty();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SelfReferencingSettings Class
SelfReferencingSettings Members


Reset Method

[image]
Intersoft WebGrid Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > SelfReferencingSettings Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As SelfReferencingSettings

instance.Reset()
C#
public virtual void Reset()
Delphi
public procedure Reset(); virtual;
JScript
public function Reset();
Managed Extensions for C++
public: virtual void Reset();
C++/CLI
public:
virtual void Reset();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SelfReferencingSettings Class
SelfReferencingSettings Members


SerializeObjectData Method

[image]
Intersoft WebGrid Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > SelfReferencingSettings Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As SelfReferencingSettings
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure SerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function SerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void SerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void SerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SelfReferencingSettings Class
SelfReferencingSettings Members


ToString Method

[image]
Intersoft WebGrid Documentation
ToString Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > SelfReferencingSettings Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString() As System.String
Visual Basic (Usage) Copy Code
Dim instance As SelfReferencingSettings
Dim value As System.String

value = instance.ToString()
C#
public override System.string ToString()
Delphi
public function ToString(): System.String; override;
JScript
public override function ToString() : System.String;
Managed Extensions for C++
public: System.string* ToString(); override
C++/CLI
public:
System.String^ ToString(); override

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SelfReferencingSettings Class
SelfReferencingSettings Members


SelfReferencingSettings Class Properties

[image]
Intersoft WebGrid Documentation
SelfReferencingSettings Class Properties
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : SelfReferencingSettings Class

Glossary Item Box

For a list of all members of this type, see SelfReferencingSettings members.

Public Properties

 | Name | Description
Public Property | ApplyChildSorting |
Public Property | ChildDataMember |
Public Property | Enabled |
Public Property | ExpandColumnInnerTextPadding |
Public Property | ExpandColumnMember |
Public Property | FitColumnOnExpand |
Public Property | IsTreeViewSelectionMode |
Public Property | LoadOnDemand |
Public Property | ParentDataMember |
Public Property | ParentRootMode |
Public Property | ParentRootValue |
Public Property | TreatOrphanRecordsAsRoot |
Top

See Also

Reference

SelfReferencingSettings Class
ISNet.WebUI.WebGrid Namespace


SelfReferencingSettings Constructor

[image]
Intersoft WebGrid Documentation
SelfReferencingSettings Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > SelfReferencingSettings Class : SelfReferencingSettings Constructor

Glossary Item Box

Overload List

Overload | Description
SelfReferencingSettings Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SelfReferencingSettings Class
SelfReferencingSettings Members


ApplyChildSorting Property

[image]
Intersoft WebGrid Documentation
ApplyChildSorting Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > SelfReferencingSettings Class : ApplyChildSorting Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Specifies whether the self referencing children should be sorted according to the SortedColumns of the table.")>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property ApplyChildSorting As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As SelfReferencingSettings
Dim value As System.Boolean

instance.ApplyChildSorting = value

value = instance.ApplyChildSorting
C#
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies whether the self referencing children should be sorted according to the SortedColumns of the table.")]
[ISNet.Serialization.BinarySerializableAttribute()]
public System.bool ApplyChildSorting {get; set;}
Delphi
public read-write property ApplyChildSorting: System.Boolean;
JScript
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Specifies whether the self referencing children should be sorted according to the SortedColumns of the table.")
ISNet.Serialization.BinarySerializableAttribute()
public function get,set ApplyChildSorting : System.boolean
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies whether the self referencing children should be sorted according to the SortedColumns of the table.")]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.bool get_ApplyChildSorting();
public: __property void set_ApplyChildSorting(
   System.bool value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies whether the self referencing children should be sorted according to the SortedColumns of the table.")]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.bool ApplyChildSorting {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SelfReferencingSettings Class
SelfReferencingSettings Members


ChildDataMember Property

[image]
Intersoft WebGrid Documentation
ChildDataMember Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > SelfReferencingSettings Class : ChildDataMember Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies the data member which value is used to query child rows.")>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebGrid.DataFieldEditor, ISNet.WebUI.WebGrid, Version=9.0.7200.1, Culture=neutral, PublicKeyToken=3e60b85fb8502d5e")>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property ChildDataMember As System.String
Visual Basic (Usage) Copy Code
Dim instance As SelfReferencingSettings
Dim value As System.String

instance.ChildDataMember = value

value = instance.ChildDataMember
C#
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the data member which value is used to query child rows.")]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebGrid.DataFieldEditor, ISNet.WebUI.WebGrid, Version=9.0.7200.1, Culture=neutral, PublicKeyToken=3e60b85fb8502d5e")]
[ISNet.Serialization.BinarySerializableAttribute()]
public System.string ChildDataMember {get; set;}
Delphi
public read-write property ChildDataMember: System.String;
JScript
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the data member which value is used to query child rows.")
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebGrid.DataFieldEditor, ISNet.WebUI.WebGrid, Version=9.0.7200.1, Culture=neutral, PublicKeyToken=3e60b85fb8502d5e")
ISNet.Serialization.BinarySerializableAttribute()
public function get,set ChildDataMember : System.String
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the data member which value is used to query child rows.")]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebGrid.DataFieldEditor, ISNet.WebUI.WebGrid, Version=9.0.7200.1, Culture=neutral, PublicKeyToken=3e60b85fb8502d5e")]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.string* get_ChildDataMember();
public: __property void set_ChildDataMember(
   System.string* value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the data member which value is used to query child rows.")]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebGrid.DataFieldEditor, ISNet.WebUI.WebGrid, Version=9.0.7200.1, Culture=neutral, PublicKeyToken=3e60b85fb8502d5e")]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.String^ ChildDataMember {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SelfReferencingSettings Class
SelfReferencingSettings Members


Enabled Property

[image]
Intersoft WebGrid Documentation
Enabled Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > SelfReferencingSettings Class : Enabled Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("When set to True, this table will display self referencing data.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property Enabled As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As SelfReferencingSettings
Dim value As System.Boolean

instance.Enabled = value

value = instance.Enabled
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("When set to True, this table will display self referencing data.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.bool Enabled {get; set;}
Delphi
public read-write property Enabled: System.Boolean;
JScript
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("When set to True, this table will display self referencing data.")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set Enabled : System.boolean
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("When set to True, this table will display self referencing data.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.bool get_Enabled();
public: __property void set_Enabled(
   System.bool value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("When set to True, this table will display self referencing data.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.bool Enabled {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SelfReferencingSettings Class
SelfReferencingSettings Members


ExpandColumnInnerTextPadding Property

[image]
Intersoft WebGrid Documentation
ExpandColumnInnerTextPadding Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > SelfReferencingSettings Class : ExpandColumnInnerTextPadding Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies the padding width that applied in the inner text of the expand column member.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property ExpandColumnInnerTextPadding As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As SelfReferencingSettings
Dim value As System.Integer

instance.ExpandColumnInnerTextPadding = value

value = instance.ExpandColumnInnerTextPadding
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the padding width that applied in the inner text of the expand column member.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.int ExpandColumnInnerTextPadding {get; set;}
Delphi
public read-write property ExpandColumnInnerTextPadding: System.Integer;
JScript
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the padding width that applied in the inner text of the expand column member.")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set ExpandColumnInnerTextPadding : System.int
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the padding width that applied in the inner text of the expand column member.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.int get_ExpandColumnInnerTextPadding();
public: __property void set_ExpandColumnInnerTextPadding(
   System.int value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the padding width that applied in the inner text of the expand column member.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.int ExpandColumnInnerTextPadding {
   System.int get();
   void set (    System.int value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SelfReferencingSettings Class
SelfReferencingSettings Members


ExpandColumnMember Property

[image]
Intersoft WebGrid Documentation
ExpandColumnMember Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > SelfReferencingSettings Class : ExpandColumnMember Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies the column member where expand/collapse image should appear.")>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebGrid.FieldTypeEditor, ISNet.WebUI.WebGrid, Version=9.0.7200.1, Culture=neutral, PublicKeyToken=3e60b85fb8502d5e")>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property ExpandColumnMember As System.String
Visual Basic (Usage) Copy Code
Dim instance As SelfReferencingSettings
Dim value As System.String

instance.ExpandColumnMember = value

value = instance.ExpandColumnMember
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the column member where expand/collapse image should appear.")]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebGrid.FieldTypeEditor, ISNet.WebUI.WebGrid, Version=9.0.7200.1, Culture=neutral, PublicKeyToken=3e60b85fb8502d5e")]
[ISNet.Serialization.BinarySerializableAttribute()]
public System.string ExpandColumnMember {get; set;}
Delphi
public read-write property ExpandColumnMember: System.String;
JScript
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the column member where expand/collapse image should appear.")
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebGrid.FieldTypeEditor, ISNet.WebUI.WebGrid, Version=9.0.7200.1, Culture=neutral, PublicKeyToken=3e60b85fb8502d5e")
ISNet.Serialization.BinarySerializableAttribute()
public function get,set ExpandColumnMember : System.String
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the column member where expand/collapse image should appear.")]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebGrid.FieldTypeEditor, ISNet.WebUI.WebGrid, Version=9.0.7200.1, Culture=neutral, PublicKeyToken=3e60b85fb8502d5e")]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.string* get_ExpandColumnMember();
public: __property void set_ExpandColumnMember(
   System.string* value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the column member where expand/collapse image should appear.")]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebGrid.FieldTypeEditor, ISNet.WebUI.WebGrid, Version=9.0.7200.1, Culture=neutral, PublicKeyToken=3e60b85fb8502d5e")]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.String^ ExpandColumnMember {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SelfReferencingSettings Class
SelfReferencingSettings Members


FitColumnOnExpand Property

[image]
Intersoft WebGrid Documentation
FitColumnOnExpand Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > SelfReferencingSettings Class : FitColumnOnExpand Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Determines whether the expanded column should be automatically resized to fit the column's width.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Property FitColumnOnExpand As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As SelfReferencingSettings
Dim value As System.Boolean

instance.FitColumnOnExpand = value

value = instance.FitColumnOnExpand
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Determines whether the expanded column should be automatically resized to fit the column's width.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public System.bool FitColumnOnExpand {get; set;}
Delphi
public read-write property FitColumnOnExpand: System.Boolean;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Determines whether the expanded column should be automatically resized to fit the column's width.")
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute()
public function get,set FitColumnOnExpand : System.boolean
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Determines whether the expanded column should be automatically resized to fit the column's width.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property System.bool get_FitColumnOnExpand();
public: __property void set_FitColumnOnExpand(
   System.bool value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Determines whether the expanded column should be automatically resized to fit the column's width.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property System.bool FitColumnOnExpand {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SelfReferencingSettings Class
SelfReferencingSettings Members


IsTreeViewSelectionMode Property

[image]
Intersoft WebGrid Documentation
IsTreeViewSelectionMode Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > SelfReferencingSettings Class : IsTreeViewSelectionMode Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies whether the selection mode will use TreeView-like selection.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Property IsTreeViewSelectionMode As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As SelfReferencingSettings
Dim value As System.Boolean

instance.IsTreeViewSelectionMode = value

value = instance.IsTreeViewSelectionMode
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether the selection mode will use TreeView-like selection.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public System.bool IsTreeViewSelectionMode {get; set;}
Delphi
public read-write property IsTreeViewSelectionMode: System.Boolean;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Specifies whether the selection mode will use TreeView-like selection.")
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute()
public function get,set IsTreeViewSelectionMode : System.boolean
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether the selection mode will use TreeView-like selection.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property System.bool get_IsTreeViewSelectionMode();
public: __property void set_IsTreeViewSelectionMode(
   System.bool value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether the selection mode will use TreeView-like selection.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property System.bool IsTreeViewSelectionMode {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SelfReferencingSettings Class
SelfReferencingSettings Members


LoadOnDemand Property

[image]
Intersoft WebGrid Documentation
LoadOnDemand Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > SelfReferencingSettings Class : LoadOnDemand Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Determines whether the child rows should be loaded on demand, instead of loaded at once in first request.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property LoadOnDemand As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As SelfReferencingSettings
Dim value As System.Boolean

instance.LoadOnDemand = value

value = instance.LoadOnDemand
C#
[System.ComponentModel.DescriptionAttribute("Determines whether the child rows should be loaded on demand, instead of loaded at once in first request.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
public System.bool LoadOnDemand {get; set;}
Delphi
public read-write property LoadOnDemand: System.Boolean;
JScript
System.ComponentModel.DescriptionAttribute("Determines whether the child rows should be loaded on demand, instead of loaded at once in first request.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get,set LoadOnDemand : System.boolean
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Determines whether the child rows should be loaded on demand, instead of loaded at once in first request.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.bool get_LoadOnDemand();
public: __property void set_LoadOnDemand(
   System.bool value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Determines whether the child rows should be loaded on demand, instead of loaded at once in first request.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.bool LoadOnDemand {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SelfReferencingSettings Class
SelfReferencingSettings Members


ParentDataMember Property

[image]
Intersoft WebGrid Documentation
ParentDataMember Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > SelfReferencingSettings Class : ParentDataMember Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebGrid.DataFieldEditor, ISNet.WebUI.WebGrid, Version=9.0.7200.1, Culture=neutral, PublicKeyToken=3e60b85fb8502d5e")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies the data member which value is used as parent condition while retrieving child rows.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Property ParentDataMember As System.String
Visual Basic (Usage) Copy Code
Dim instance As SelfReferencingSettings
Dim value As System.String

instance.ParentDataMember = value

value = instance.ParentDataMember
C#
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebGrid.DataFieldEditor, ISNet.WebUI.WebGrid, Version=9.0.7200.1, Culture=neutral, PublicKeyToken=3e60b85fb8502d5e")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the data member which value is used as parent condition while retrieving child rows.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public System.string ParentDataMember {get; set;}
Delphi
public read-write property ParentDataMember: System.String;
JScript
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebGrid.DataFieldEditor, ISNet.WebUI.WebGrid, Version=9.0.7200.1, Culture=neutral, PublicKeyToken=3e60b85fb8502d5e")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the data member which value is used as parent condition while retrieving child rows.")
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute()
public function get,set ParentDataMember : System.String
Managed Extensions for C++
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebGrid.DataFieldEditor, ISNet.WebUI.WebGrid, Version=9.0.7200.1, Culture=neutral, PublicKeyToken=3e60b85fb8502d5e")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the data member which value is used as parent condition while retrieving child rows.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property System.string* get_ParentDataMember();
public: __property void set_ParentDataMember(
   System.string* value
);
C++/CLI
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebGrid.DataFieldEditor, ISNet.WebUI.WebGrid, Version=9.0.7200.1, Culture=neutral, PublicKeyToken=3e60b85fb8502d5e")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the data member which value is used as parent condition while retrieving child rows.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property System.String^ ParentDataMember {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SelfReferencingSettings Class
SelfReferencingSettings Members


ParentRootMode Property

[image]
Intersoft WebGrid Documentation
ParentRootMode Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > SelfReferencingSettings Class : ParentRootMode Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies the behavior that used by WebGrid to determine root/parent.")>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Property ParentRootMode As ParentRootMode
Visual Basic (Usage) Copy Code
Dim instance As SelfReferencingSettings
Dim value As ParentRootMode

instance.ParentRootMode = value

value = instance.ParentRootMode
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the behavior that used by WebGrid to determine root/parent.")]
[ISNet.Serialization.XmlSerializableAttribute()]
public ParentRootMode ParentRootMode {get; set;}
Delphi
public read-write property ParentRootMode: ParentRootMode;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the behavior that used by WebGrid to determine root/parent.")
ISNet.Serialization.XmlSerializableAttribute()
public function get,set ParentRootMode : ParentRootMode
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the behavior that used by WebGrid to determine root/parent.")]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property ParentRootMode get_ParentRootMode();
public: __property void set_ParentRootMode(
   ParentRootMode value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the behavior that used by WebGrid to determine root/parent.")]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property ParentRootMode ParentRootMode {
   ParentRootMode get();
   void set (    ParentRootMode value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SelfReferencingSettings Class
SelfReferencingSettings Members


ParentRootValue Property

[image]
Intersoft WebGrid Documentation
ParentRootValue Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > SelfReferencingSettings Class : ParentRootValue Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies a value that determines root/parent rows when ParentRootMode is set to UseParentRootValue.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
Public Property ParentRootValue As System.Object
Visual Basic (Usage) Copy Code
Dim instance As SelfReferencingSettings
Dim value As System.Object

instance.ParentRootValue = value

value = instance.ParentRootValue
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies a value that determines root/parent rows when ParentRootMode is set to UseParentRootValue.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public System.object ParentRootValue {get; set;}
Delphi
public read-write property ParentRootValue: System.TObject;
JScript
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DescriptionAttribute("Specifies a value that determines root/parent rows when ParentRootMode is set to UseParentRootValue.")
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
public function get,set ParentRootValue : System.Object
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies a value that determines root/parent rows when ParentRootMode is set to UseParentRootValue.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.Object* get_ParentRootValue();
public: __property void set_ParentRootValue(
   System.Object* value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies a value that determines root/parent rows when ParentRootMode is set to UseParentRootValue.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.Object^ ParentRootValue {
   System.Object^ get();
   void set (    System.Object^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SelfReferencingSettings Class
SelfReferencingSettings Members


TreatOrphanRecordsAsRoot Property

[image]
Intersoft WebGrid Documentation
TreatOrphanRecordsAsRoot Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > SelfReferencingSettings Class : TreatOrphanRecordsAsRoot Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Determines whether orphan records should be treated as root.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property TreatOrphanRecordsAsRoot As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As SelfReferencingSettings
Dim value As System.Boolean

instance.TreatOrphanRecordsAsRoot = value

value = instance.TreatOrphanRecordsAsRoot
C#
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Determines whether orphan records should be treated as root.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.bool TreatOrphanRecordsAsRoot {get; set;}
Delphi
public read-write property TreatOrphanRecordsAsRoot: System.Boolean;
JScript
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Determines whether orphan records should be treated as root.")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set TreatOrphanRecordsAsRoot : System.boolean
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Determines whether orphan records should be treated as root.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.bool get_TreatOrphanRecordsAsRoot();
public: __property void set_TreatOrphanRecordsAsRoot(
   System.bool value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Determines whether orphan records should be treated as root.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.bool TreatOrphanRecordsAsRoot {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SelfReferencingSettings Class
SelfReferencingSettings Members


SortEventArgs Class

[image]
Intersoft WebGrid Documentation
SortEventArgs Class
Members See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : SortEventArgs Class

Glossary Item Box

Object Model

SortEventArgs Class

Syntax

Visual Basic (Declaration)
Public Class SortEventArgs
   Inherits BaseEventArgs
Visual Basic (Usage) Copy Code
Dim instance As SortEventArgs
C#
public class SortEventArgs : BaseEventArgs
Delphi
public class SortEventArgs = class(BaseEventArgs)
JScript
public class SortEventArgs extends BaseEventArgs
Managed Extensions for C++
public __gc class SortEventArgs : public BaseEventArgs
C++/CLI
public ref class SortEventArgs : public BaseEventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
ISNet.WebUI.WebGrid.BaseEventArgs
ISNet.WebUI.WebGrid.SortEventArgs

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SortEventArgs Members
ISNet.WebUI.WebGrid Namespace


SortEventArgs Class Members

[image]
Intersoft WebGrid Documentation
SortEventArgs Class Members
See Also Properties Send Feedback
ISNet.WebUI.WebGrid Namespace : SortEventArgs Class

Glossary Item Box

The following tables list the members exposed by SortEventArgs.

Public Properties

 | Name | Description
Public Property | DataSource |
Public Property | ReturnValue | (Inherited from ISNet.WebUI.WebGrid.BaseEventArgs)
Public Property | SortColumns |
Public Property | Table |
Top

See Also

Reference

SortEventArgs Class
ISNet.WebUI.WebGrid Namespace


SortEventArgs Class Properties

[image]
Intersoft WebGrid Documentation
SortEventArgs Class Properties
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : SortEventArgs Class

Glossary Item Box

For a list of all members of this type, see SortEventArgs members.

Public Properties

 | Name | Description
Public Property | DataSource |
Public Property | ReturnValue | (Inherited from ISNet.WebUI.WebGrid.BaseEventArgs)
Public Property | SortColumns |
Public Property | Table |
Top

See Also

Reference

SortEventArgs Class
ISNet.WebUI.WebGrid Namespace


DataSource Property

[image]
Intersoft WebGrid Documentation
DataSource Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > SortEventArgs Class : DataSource Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property DataSource As System.Object
Visual Basic (Usage) Copy Code
Dim instance As SortEventArgs
Dim value As System.Object

value = instance.DataSource
C#
public System.object DataSource {get;}
Delphi
public read-only property DataSource: System.TObject;
JScript
public function get DataSource : System.Object
Managed Extensions for C++
public: __property System.Object* get_DataSource();
C++/CLI
public:
property System.Object^ DataSource {
   System.Object^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SortEventArgs Class
SortEventArgs Members


SortColumns Property

[image]
Intersoft WebGrid Documentation
SortColumns Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > SortEventArgs Class : SortColumns Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property SortColumns As WebGridGroupCollection
Visual Basic (Usage) Copy Code
Dim instance As SortEventArgs
Dim value As WebGridGroupCollection

value = instance.SortColumns
C#
public WebGridGroupCollection SortColumns {get;}
Delphi
public read-only property SortColumns: WebGridGroupCollection;
JScript
public function get SortColumns : WebGridGroupCollection
Managed Extensions for C++
public: __property WebGridGroupCollection* get_SortColumns();
C++/CLI
public:
property WebGridGroupCollection^ SortColumns {
   WebGridGroupCollection^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SortEventArgs Class
SortEventArgs Members


Table Property

[image]
Intersoft WebGrid Documentation
Table Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > SortEventArgs Class : Table Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Table As WebGridTable
Visual Basic (Usage) Copy Code
Dim instance As SortEventArgs
Dim value As WebGridTable

value = instance.Table
C#
public WebGridTable Table {get;}
Delphi
public read-only property Table: WebGridTable;
JScript
public function get Table : WebGridTable
Managed Extensions for C++
public: __property WebGridTable* get_Table();
C++/CLI
public:
property WebGridTable^ Table {
   WebGridTable^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SortEventArgs Class
SortEventArgs Members


SpanEventArgs Class

[image]
Intersoft WebGrid Documentation
SpanEventArgs Class
Members See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : SpanEventArgs Class

Glossary Item Box

Object Model

SpanEventArgs Class

Syntax

Visual Basic (Declaration)
Public Class SpanEventArgs
   Inherits System.EventArgs
Visual Basic (Usage) Copy Code
Dim instance As SpanEventArgs
C#
public class SpanEventArgs : System.EventArgs
Delphi
public class SpanEventArgs = class(System.EventArgs)
JScript
public class SpanEventArgs extends System.EventArgs
Managed Extensions for C++
public __gc class SpanEventArgs : public System.EventArgs
C++/CLI
public ref class SpanEventArgs : public System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
ISNet.WebUI.WebGrid.SpanEventArgs

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SpanEventArgs Members
ISNet.WebUI.WebGrid Namespace


SpanEventArgs Class Members

[image]
Intersoft WebGrid Documentation
SpanEventArgs Class Members
See Also Properties Send Feedback
ISNet.WebUI.WebGrid Namespace : SpanEventArgs Class

Glossary Item Box

The following tables list the members exposed by SpanEventArgs.

Public Constructors

 | Name | Description
Public Constructor | SpanEventArgs Constructor |
Top

Public Properties

 | Name | Description
Public Property | NewValue |
Top

See Also

Reference

SpanEventArgs Class
ISNet.WebUI.WebGrid Namespace


SpanEventArgs Constructor

[image]
Intersoft WebGrid Documentation
SpanEventArgs Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > SpanEventArgs Class : SpanEventArgs Constructor

newValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal newValue As System.Integer _
)
Visual Basic (Usage) Copy Code
Dim newValue As System.Integer

Dim instance As New SpanEventArgs(newValue)
C#
public SpanEventArgs(
   System.int newValue
)
Delphi
public SpanEventArgs(
    newValue: System.Integer
);
JScript
public function SpanEventArgs(
   newValue : System.int
);
Managed Extensions for C++
public: SpanEventArgs(
   System.int newValue
)
C++/CLI
public:
SpanEventArgs(
   System.int newValue
)

Parameters

newValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SpanEventArgs Class
SpanEventArgs Members


SpanEventArgs Class Properties

[image]
Intersoft WebGrid Documentation
SpanEventArgs Class Properties
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : SpanEventArgs Class

Glossary Item Box

For a list of all members of this type, see SpanEventArgs members.

Public Properties

 | Name | Description
Public Property | NewValue |
Top

See Also

Reference

SpanEventArgs Class
ISNet.WebUI.WebGrid Namespace


NewValue Property

[image]
Intersoft WebGrid Documentation
NewValue Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > SpanEventArgs Class : NewValue Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property NewValue As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As SpanEventArgs
Dim value As System.Integer

value = instance.NewValue
C#
public System.int NewValue {get;}
Delphi
public read-only property NewValue: System.Integer;
JScript
public function get NewValue : System.int
Managed Extensions for C++
public: __property System.int get_NewValue();
C++/CLI
public:
property System.int NewValue {
   System.int get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SpanEventArgs Class
SpanEventArgs Members


TableEventArgs Class

[image]
Intersoft WebGrid Documentation
TableEventArgs Class
Members See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : TableEventArgs Class

Glossary Item Box

Object Model

TableEventArgs Class

Syntax

Visual Basic (Declaration)
Public Class TableEventArgs
   Inherits BaseEventArgs
Visual Basic (Usage) Copy Code
Dim instance As TableEventArgs
C#
public class TableEventArgs : BaseEventArgs
Delphi
public class TableEventArgs = class(BaseEventArgs)
JScript
public class TableEventArgs extends BaseEventArgs
Managed Extensions for C++
public __gc class TableEventArgs : public BaseEventArgs
C++/CLI
public ref class TableEventArgs : public BaseEventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
ISNet.WebUI.WebGrid.BaseEventArgs
ISNet.WebUI.WebGrid.TableEventArgs

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TableEventArgs Members
ISNet.WebUI.WebGrid Namespace


TableEventArgs Class Members

[image]
Intersoft WebGrid Documentation
TableEventArgs Class Members
See Also Properties Send Feedback
ISNet.WebUI.WebGrid Namespace : TableEventArgs Class

Glossary Item Box

The following tables list the members exposed by TableEventArgs.

Public Properties

 | Name | Description
Public Property | ReturnValue | (Inherited from ISNet.WebUI.WebGrid.BaseEventArgs)
Public Property | Table |
Top

See Also

Reference

TableEventArgs Class
ISNet.WebUI.WebGrid Namespace


TableEventArgs Class Properties

[image]
Intersoft WebGrid Documentation
TableEventArgs Class Properties
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : TableEventArgs Class

Glossary Item Box

For a list of all members of this type, see TableEventArgs members.

Public Properties

 | Name | Description
Public Property | ReturnValue | (Inherited from ISNet.WebUI.WebGrid.BaseEventArgs)
Public Property | Table |
Top

See Also

Reference

TableEventArgs Class
ISNet.WebUI.WebGrid Namespace


Table Property

[image]
Intersoft WebGrid Documentation
Table Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > TableEventArgs Class : Table Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Table As WebGridTable
Visual Basic (Usage) Copy Code
Dim instance As TableEventArgs
Dim value As WebGridTable

value = instance.Table
C#
public WebGridTable Table {get;}
Delphi
public read-only property Table: WebGridTable;
JScript
public function get Table : WebGridTable
Managed Extensions for C++
public: __property WebGridTable* get_Table();
C++/CLI
public:
property WebGridTable^ Table {
   WebGridTable^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TableEventArgs Class
TableEventArgs Members


TextItemEditor Class

[image]
Intersoft WebGrid Documentation
TextItemEditor Class
Members See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : TextItemEditor Class

Glossary Item Box

Object Model

TextItemEditor Class

Syntax

Visual Basic (Declaration)
Public Class TextItemEditor
   Inherits System.Drawing.Design.UITypeEditor
Visual Basic (Usage) Copy Code
Dim instance As TextItemEditor
C#
public class TextItemEditor : System.Drawing.Design.UITypeEditor
Delphi
public class TextItemEditor = class(System.Drawing.Design.UITypeEditor)
JScript
public class TextItemEditor extends System.Drawing.Design.UITypeEditor
Managed Extensions for C++
public __gc class TextItemEditor : public System.Drawing.Design.UITypeEditor
C++/CLI
public ref class TextItemEditor : public System.Drawing.Design.UITypeEditor

Inheritance Hierarchy

System.Object
System.Drawing.Design.UITypeEditor
ISNet.WebUI.WebGrid.TextItemEditor

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TextItemEditor Members
ISNet.WebUI.WebGrid Namespace


TextItemEditor Class Members

[image]
Intersoft WebGrid Documentation
TextItemEditor Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebGrid Namespace : TextItemEditor Class

Glossary Item Box

The following tables list the members exposed by TextItemEditor.

Public Constructors

 | Name | Description
Public Constructor | TextItemEditor Constructor |
Top

Public Properties

 | Name | Description
Public Property | IsDropDownResizable | (Inherited from System.Drawing.Design.UITypeEditor)
Top

Public Methods

 | Name | Description
Public Method | EditValue | Overloaded. Overridden.
Public Method | GetEditStyle | Overloaded. Overridden.
Public Method | GetPaintValueSupported | Overloaded. Overridden.
Public Method | PaintValue | Overloaded. (Inherited from System.Drawing.Design.UITypeEditor)
Top

See Also

Reference

TextItemEditor Class
ISNet.WebUI.WebGrid Namespace


TextItemEditor Constructor

[image]
Intersoft WebGrid Documentation
TextItemEditor Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > TextItemEditor Class : TextItemEditor Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New TextItemEditor()
C#
public TextItemEditor()
Delphi
public TextItemEditor();
JScript
public function TextItemEditor();
Managed Extensions for C++
public: TextItemEditor();
C++/CLI
public:
TextItemEditor();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TextItemEditor Class
TextItemEditor Members


TextItemEditor Class Methods

[image]
Intersoft WebGrid Documentation
TextItemEditor Class Methods
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : TextItemEditor Class

Glossary Item Box

For a list of all members of this type, see TextItemEditor members.

Public Methods

 | Name | Description
Public Method | EditValue | Overloaded. Overridden.
Public Method | GetEditStyle | Overloaded. Overridden.
Public Method | GetPaintValueSupported | Overloaded. Overridden.
Public Method | PaintValue | Overloaded. (Inherited from System.Drawing.Design.UITypeEditor)
Top

See Also

Reference

TextItemEditor Class
ISNet.WebUI.WebGrid Namespace


TextItemEditor Class Properties

[image]
Intersoft WebGrid Documentation
TextItemEditor Class Properties
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : TextItemEditor Class

Glossary Item Box

For a list of all members of this type, see TextItemEditor members.

Public Properties

 | Name | Description
Public Property | IsDropDownResizable | (Inherited from System.Drawing.Design.UITypeEditor)
Top

See Also

Reference

TextItemEditor Class
ISNet.WebUI.WebGrid Namespace


EditValue Method

[image]
Intersoft WebGrid Documentation
EditValue Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > TextItemEditor Class : EditValue Method

Glossary Item Box

Overload List

Overload | Description
EditValue(ITypeDescriptorContext,IServiceProvider,Object) |
EditValue(IServiceProvider,Object) | (Inherited from System.Drawing.Design.UITypeEditor)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TextItemEditor Class
TextItemEditor Members


EditValue(ITypeDescriptorContext,IServiceProvider,Object) Method

[image]
Intersoft WebGrid Documentation
EditValue(ITypeDescriptorContext,IServiceProvider,Object) Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > TextItemEditor Class > EditValue Method : EditValue(ITypeDescriptorContext,IServiceProvider,Object) Method

context
provider
value

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Function EditValue( _
   ByVal context As System.ComponentModel.ITypeDescriptorContext, _
   ByVal provider As System.IServiceProvider, _
   ByVal value As System.Object _
) As System.Object
Visual Basic (Usage) Copy Code
Dim instance As TextItemEditor
Dim context As System.ComponentModel.ITypeDescriptorContext
Dim provider As System.IServiceProvider
Dim value As System.Object
Dim value As System.Object

value = instance.EditValue(context, provider, value)
C#
public override System.object EditValue(
   System.ComponentModel.ITypeDescriptorContext context,
   System.IServiceProvider provider,
   System.object value
)
Delphi
public function EditValue(
    context: System.ComponentModel.ITypeDescriptorContext;
    provider: System.IServiceProvider;
    value: System.TObject
): System.TObject; override;
JScript
public override function EditValue(
   context : System.ComponentModel.ITypeDescriptorContext,
   provider : System.IServiceProvider,
   value : System.Object
) : System.Object;
Managed Extensions for C++
public: System.Object* EditValue(
   System.ComponentModel.ITypeDescriptorContext* context,
   System.IServiceProvider* provider,
   System.Object* value
) override
C++/CLI
public:
System.Object^ EditValue(
   System.ComponentModel.ITypeDescriptorContext^ context,
   System.IServiceProvider^ provider,
   System.Object^ value
) override

Parameters

context
provider
value

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TextItemEditor Class
TextItemEditor Members
Overload List


EditValue(IServiceProvider,Object) Method

[image]
Intersoft WebGrid Documentation
EditValue(IServiceProvider,Object) Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > TextItemEditor Class > EditValue Method : EditValue(IServiceProvider,Object) Method

provider
value

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")>
Public Overloads Function EditValue( _
   ByVal provider As System.IServiceProvider, _
   ByVal value As System.Object _
) As System.Object
Visual Basic (Usage) Copy Code
Dim instance As TextItemEditor
Dim provider As System.IServiceProvider
Dim value As System.Object
Dim value As System.Object

value = instance.EditValue(provider, value)
C#
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public System.object EditValue(
   System.IServiceProvider provider,
   System.object value
)
Delphi
public function EditValue(
    provider: System.IServiceProvider;
    value: System.TObject
): System.TObject;
JScript
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")
public function EditValue(
   provider : System.IServiceProvider,
   value : System.Object
) : System.Object;
Managed Extensions for C++
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public: System.Object* EditValue(
   System.IServiceProvider* provider,
   System.Object* value
)
C++/CLI
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public:
System.Object^ EditValue(
   System.IServiceProvider^ provider,
   System.Object^ value
)

Parameters

provider
value

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TextItemEditor Class
TextItemEditor Members
Overload List


GetEditStyle Method

[image]
Intersoft WebGrid Documentation
GetEditStyle Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > TextItemEditor Class : GetEditStyle Method

Glossary Item Box

Overload List

Overload | Description
GetEditStyle(ITypeDescriptorContext) |
GetEditStyle() | (Inherited from System.Drawing.Design.UITypeEditor)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TextItemEditor Class
TextItemEditor Members


GetEditStyle(ITypeDescriptorContext) Method

[image]
Intersoft WebGrid Documentation
GetEditStyle(ITypeDescriptorContext) Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > TextItemEditor Class > GetEditStyle Method : GetEditStyle(ITypeDescriptorContext) Method

context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Function GetEditStyle( _
   ByVal context As System.ComponentModel.ITypeDescriptorContext _
) As System.Drawing.Design.UITypeEditorEditStyle
Visual Basic (Usage) Copy Code
Dim instance As TextItemEditor
Dim context As System.ComponentModel.ITypeDescriptorContext
Dim value As System.Drawing.Design.UITypeEditorEditStyle

value = instance.GetEditStyle(context)
C#
public override System.Drawing.Design.UITypeEditorEditStyle GetEditStyle(
   System.ComponentModel.ITypeDescriptorContext context
)
Delphi
public function GetEditStyle(
    context: System.ComponentModel.ITypeDescriptorContext
): System.Drawing.Design.UITypeEditorEditStyle; override;
JScript
public override function GetEditStyle(
   context : System.ComponentModel.ITypeDescriptorContext
) : System.Drawing.Design.UITypeEditorEditStyle;
Managed Extensions for C++
public: System.Drawing.Design.UITypeEditorEditStyle GetEditStyle(
   System.ComponentModel.ITypeDescriptorContext* context
) override
C++/CLI
public:
System.Drawing.Design.UITypeEditorEditStyle GetEditStyle(
   System.ComponentModel.ITypeDescriptorContext^ context
) override

Parameters

context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TextItemEditor Class
TextItemEditor Members
Overload List


GetEditStyle() Method

[image]
Intersoft WebGrid Documentation
GetEditStyle() Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > TextItemEditor Class > GetEditStyle Method : GetEditStyle() Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")>
Public Overloads Function GetEditStyle() As System.Drawing.Design.UITypeEditorEditStyle
Visual Basic (Usage) Copy Code
Dim instance As TextItemEditor
Dim value As System.Drawing.Design.UITypeEditorEditStyle

value = instance.GetEditStyle()
C#
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public System.Drawing.Design.UITypeEditorEditStyle GetEditStyle()
Delphi
public function GetEditStyle(): System.Drawing.Design.UITypeEditorEditStyle;
JScript
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")
public function GetEditStyle() : System.Drawing.Design.UITypeEditorEditStyle;
Managed Extensions for C++
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public: System.Drawing.Design.UITypeEditorEditStyle GetEditStyle();
C++/CLI
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public:
System.Drawing.Design.UITypeEditorEditStyle GetEditStyle();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TextItemEditor Class
TextItemEditor Members
Overload List


GetPaintValueSupported Method

[image]
Intersoft WebGrid Documentation
GetPaintValueSupported Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > TextItemEditor Class : GetPaintValueSupported Method

Glossary Item Box

Overload List

Overload | Description
GetPaintValueSupported(ITypeDescriptorContext) |
GetPaintValueSupported() | (Inherited from System.Drawing.Design.UITypeEditor)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TextItemEditor Class
TextItemEditor Members


GetPaintValueSupported(ITypeDescriptorContext) Method

[image]
Intersoft WebGrid Documentation
GetPaintValueSupported(ITypeDescriptorContext) Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > TextItemEditor Class > GetPaintValueSupported Method : GetPaintValueSupported(ITypeDescriptorContext) Method

context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Function GetPaintValueSupported( _
   ByVal context As System.ComponentModel.ITypeDescriptorContext _
) As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As TextItemEditor
Dim context As System.ComponentModel.ITypeDescriptorContext
Dim value As System.Boolean

value = instance.GetPaintValueSupported(context)
C#
public override System.bool GetPaintValueSupported(
   System.ComponentModel.ITypeDescriptorContext context
)
Delphi
public function GetPaintValueSupported(
    context: System.ComponentModel.ITypeDescriptorContext
): System.Boolean; override;
JScript
public override function GetPaintValueSupported(
   context : System.ComponentModel.ITypeDescriptorContext
) : System.boolean;
Managed Extensions for C++
public: System.bool GetPaintValueSupported(
   System.ComponentModel.ITypeDescriptorContext* context
) override
C++/CLI
public:
System.bool GetPaintValueSupported(
   System.ComponentModel.ITypeDescriptorContext^ context
) override

Parameters

context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TextItemEditor Class
TextItemEditor Members
Overload List


GetPaintValueSupported() Method

[image]
Intersoft WebGrid Documentation
GetPaintValueSupported() Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > TextItemEditor Class > GetPaintValueSupported Method : GetPaintValueSupported() Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")>
Public Overloads Function GetPaintValueSupported() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As TextItemEditor
Dim value As System.Boolean

value = instance.GetPaintValueSupported()
C#
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public System.bool GetPaintValueSupported()
Delphi
public function GetPaintValueSupported(): System.Boolean;
JScript
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")
public function GetPaintValueSupported() : System.boolean;
Managed Extensions for C++
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public: System.bool GetPaintValueSupported();
C++/CLI
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public:
System.bool GetPaintValueSupported();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TextItemEditor Class
TextItemEditor Members
Overload List


PaintValue Method

[image]
Intersoft WebGrid Documentation
PaintValue Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > TextItemEditor Class : PaintValue Method

Glossary Item Box

Overload List

Overload | Description
PaintValue(Object,Graphics,Rectangle) | (Inherited from System.Drawing.Design.UITypeEditor)
PaintValue(PaintValueEventArgs) | (Inherited from System.Drawing.Design.UITypeEditor)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TextItemEditor Class
TextItemEditor Members


PaintValue(Object,Graphics,Rectangle) Method

[image]
Intersoft WebGrid Documentation
PaintValue(Object,Graphics,Rectangle) Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > TextItemEditor Class > PaintValue Method : PaintValue(Object,Graphics,Rectangle) Method

value
canvas
rectangle

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Sub PaintValue( _
   ByVal value As System.Object, _
   ByVal canvas As System.Drawing.Graphics, _
   ByVal rectangle As System.Drawing.Rectangle _
)
Visual Basic (Usage) Copy Code
Dim instance As TextItemEditor
Dim value As System.Object
Dim canvas As System.Drawing.Graphics
Dim rectangle As System.Drawing.Rectangle

instance.PaintValue(value, canvas, rectangle)
C#
public void PaintValue(
   System.object value,
   System.Drawing.Graphics canvas,
   System.Drawing.Rectangle rectangle
)
Delphi
public procedure PaintValue(
    value: System.TObject;
    canvas: System.Drawing.Graphics;
    rectangle: System.Drawing.Rectangle
);
JScript
public function PaintValue(
   value : System.Object,
   canvas : System.Drawing.Graphics,
   rectangle : System.Drawing.Rectangle
);
Managed Extensions for C++
public: void PaintValue(
   System.Object* value,
   System.Drawing.Graphics* canvas,
   System.Drawing.Rectangle rectangle
)
C++/CLI
public:
void PaintValue(
   System.Object^ value,
   System.Drawing.Graphics^ canvas,
   System.Drawing.Rectangle rectangle
)

Parameters

value
canvas
rectangle

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TextItemEditor Class
TextItemEditor Members
Overload List


PaintValue(PaintValueEventArgs) Method

[image]
Intersoft WebGrid Documentation
PaintValue(PaintValueEventArgs) Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > TextItemEditor Class > PaintValue Method : PaintValue(PaintValueEventArgs) Method

e

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub PaintValue( _
   ByVal e As System.Drawing.Design.PaintValueEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As TextItemEditor
Dim e As System.Drawing.Design.PaintValueEventArgs

instance.PaintValue(e)
C#
public virtual void PaintValue(
   System.Drawing.Design.PaintValueEventArgs e
)
Delphi
public procedure PaintValue(
    e: System.Drawing.Design.PaintValueEventArgs
); virtual;
JScript
public function PaintValue(
   e : System.Drawing.Design.PaintValueEventArgs
);
Managed Extensions for C++
public: virtual void PaintValue(
   System.Drawing.Design.PaintValueEventArgs* e
)
C++/CLI
public:
virtual void PaintValue(
   System.Drawing.Design.PaintValueEventArgs^ e
)

Parameters

e

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TextItemEditor Class
TextItemEditor Members
Overload List


IsDropDownResizable Property

[image]
Intersoft WebGrid Documentation
IsDropDownResizable Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > TextItemEditor Class : IsDropDownResizable Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property IsDropDownResizable As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As TextItemEditor
Dim value As System.Boolean

value = instance.IsDropDownResizable
C#
public virtual System.bool IsDropDownResizable {get;}
Delphi
public read-only property IsDropDownResizable: System.Boolean; virtual;
JScript
public function get IsDropDownResizable : System.boolean
Managed Extensions for C++
public: __property virtual System.bool get_IsDropDownResizable();
C++/CLI
public:
virtual property System.bool IsDropDownResizable {
   System.bool get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TextItemEditor Class
TextItemEditor Members


TextSettings Class

[image]
Intersoft WebGrid Documentation
TextSettings Class
Members See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : TextSettings Class

Glossary Item Box

Object Model

TextSettings Class

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.DescriptionAttribute()>
<System.SerializableAttribute()>
Public Class TextSettings
   Inherits ISNet.WebUI.WebUIBaseClass
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Visual Basic (Usage) Copy Code
Dim instance As TextSettings
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DescriptionAttribute()]
[System.SerializableAttribute()]
public class TextSettings : ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Delphi
public class TextSettings = class(ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize)
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.DescriptionAttribute()
System.SerializableAttribute()
public class TextSettings extends ISNet.WebUI.WebUIBaseClass implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DescriptionAttribute()]
[System.SerializableAttribute()]
public __gc class TextSettings : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DescriptionAttribute()]
[System.SerializableAttribute()]
public ref class TextSettings : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.WebGrid.TextSettings

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TextSettings Members
ISNet.WebUI.WebGrid Namespace


TextSettings Class Members

[image]
Intersoft WebGrid Documentation
TextSettings Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebGrid Namespace : TextSettings Class

Glossary Item Box

The following tables list the members exposed by TextSettings.

Public Constructors

 | Name | Description
Public Constructor | TextSettings Constructor |
Top

Public Properties

 | Name | Description
Public Property | Language |
Public Property | LocalizationFolder |
Public Property | UseLanguage |
Public Property | UseWebResources |
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString |
Top

See Also

Reference

TextSettings Class
ISNet.WebUI.WebGrid Namespace


TextSettings Constructor

[image]
Intersoft WebGrid Documentation
TextSettings Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > TextSettings Class : TextSettings Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New TextSettings()
C#
public TextSettings()
Delphi
public TextSettings();
JScript
public function TextSettings();
Managed Extensions for C++
public: TextSettings();
C++/CLI
public:
TextSettings();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TextSettings Class
TextSettings Members


Clone Method

[image]
Intersoft WebGrid Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > TextSettings Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As System.Object
Visual Basic (Usage) Copy Code
Dim instance As TextSettings
Dim value As System.Object

value = instance.Clone()
C#
public virtual System.object Clone()
Delphi
public function Clone(): System.TObject; virtual;
JScript
public function Clone() : System.Object;
Managed Extensions for C++
public: virtual System.Object* Clone();
C++/CLI
public:
virtual System.Object^ Clone();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TextSettings Class
TextSettings Members


CopyFrom Method

[image]
Intersoft WebGrid Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > TextSettings Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TextSettings Class
TextSettings Members


CopyFrom(Object) Method

[image]
Intersoft WebGrid Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > TextSettings Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As TextSettings
Dim objSource As System.Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   System.object objSource
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TextSettings Class
TextSettings Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebGrid Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > TextSettings Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object, _
   ByVal cloneSourceValue As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As TextSettings
Dim objSource As System.Object
Dim cloneSourceValue As System.Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   System.object objSource,
   System.bool cloneSourceValue
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject;
    cloneSourceValue: System.Boolean
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object,
   cloneSourceValue : System.boolean
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource,
   System.bool cloneSourceValue
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource,
   System.bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TextSettings Class
TextSettings Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebGrid Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > TextSettings Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As TextSettings
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure DeSerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function DeSerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void DeSerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void DeSerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TextSettings Class
TextSettings Members


GetHashCode Method

[image]
Intersoft WebGrid Documentation
GetHashCode Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > TextSettings Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As TextSettings
Dim value As System.Integer

value = instance.GetHashCode()
C#
public virtual System.int GetHashCode()
Delphi
public function GetHashCode(): System.Integer; virtual;
JScript
public function GetHashCode() : System.int;
Managed Extensions for C++
public: virtual System.int GetHashCode();
C++/CLI
public:
virtual System.int GetHashCode();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TextSettings Class
TextSettings Members


TextSettings Class Methods

[image]
Intersoft WebGrid Documentation
TextSettings Class Methods
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : TextSettings Class

Glossary Item Box

For a list of all members of this type, see TextSettings members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString |
Top

See Also

Reference

TextSettings Class
ISNet.WebUI.WebGrid Namespace


GetObjectData Method

[image]
Intersoft WebGrid Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > TextSettings Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As TextSettings
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure GetObjectData(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
); override;
JScript
public override function GetObjectData(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void GetObjectData(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
) override
C++/CLI
public:
void GetObjectData(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
) override

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TextSettings Class
TextSettings Members


IsEmpty Method

[image]
Intersoft WebGrid Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > TextSettings Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As TextSettings
Dim value As System.Boolean

value = instance.IsEmpty()
C#
public virtual System.bool IsEmpty()
Delphi
public function IsEmpty(): System.Boolean; virtual;
JScript
public function IsEmpty() : System.boolean;
Managed Extensions for C++
public: virtual System.bool IsEmpty();
C++/CLI
public:
virtual System.bool IsEmpty();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TextSettings Class
TextSettings Members


Reset Method

[image]
Intersoft WebGrid Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > TextSettings Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As TextSettings

instance.Reset()
C#
public virtual void Reset()
Delphi
public procedure Reset(); virtual;
JScript
public function Reset();
Managed Extensions for C++
public: virtual void Reset();
C++/CLI
public:
virtual void Reset();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TextSettings Class
TextSettings Members


SerializeObjectData Method

[image]
Intersoft WebGrid Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > TextSettings Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As TextSettings
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure SerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function SerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void SerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void SerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TextSettings Class
TextSettings Members


ToString Method

[image]
Intersoft WebGrid Documentation
ToString Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > TextSettings Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString() As System.String
Visual Basic (Usage) Copy Code
Dim instance As TextSettings
Dim value As System.String

value = instance.ToString()
C#
public override System.string ToString()
Delphi
public function ToString(): System.String; override;
JScript
public override function ToString() : System.String;
Managed Extensions for C++
public: System.string* ToString(); override
C++/CLI
public:
System.String^ ToString(); override

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TextSettings Class
TextSettings Members


TextSettings Class Properties

[image]
Intersoft WebGrid Documentation
TextSettings Class Properties
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : TextSettings Class

Glossary Item Box

For a list of all members of this type, see TextSettings members.

Public Properties

 | Name | Description
Public Property | Language |
Public Property | LocalizationFolder |
Public Property | UseLanguage |
Public Property | UseWebResources |
Top

See Also

Reference

TextSettings Class
ISNet.WebUI.WebGrid Namespace


TextSettings Constructor

[image]
Intersoft WebGrid Documentation
TextSettings Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > TextSettings Class : TextSettings Constructor

Glossary Item Box

Overload List

Overload | Description
TextSettings Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TextSettings Class
TextSettings Members


Language Property

[image]
Intersoft WebGrid Documentation
Language Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > TextSettings Class : Language Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Property Language As LanguageMode
Visual Basic (Usage) Copy Code
Dim instance As TextSettings
Dim value As LanguageMode

instance.Language = value

value = instance.Language
C#
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public LanguageMode Language {get; set;}
Delphi
public read-write property Language: LanguageMode;
JScript
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute()
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute()
public function get,set Language : LanguageMode
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property LanguageMode get_Language();
public: __property void set_Language(
   LanguageMode value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property LanguageMode Language {
   LanguageMode get();
   void set (    LanguageMode value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TextSettings Class
TextSettings Members


LocalizationFolder Property

[image]
Intersoft WebGrid Documentation
LocalizationFolder Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > TextSettings Class : LocalizationFolder Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute()>
Public Property LocalizationFolder As System.String
Visual Basic (Usage) Copy Code
Dim instance As TextSettings
Dim value As System.String

instance.LocalizationFolder = value

value = instance.LocalizationFolder
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute()]
public System.string LocalizationFolder {get; set;}
Delphi
public read-write property LocalizationFolder: System.String;
JScript
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute()
public function get,set LocalizationFolder : System.String
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute()]
public: __property System.string* get_LocalizationFolder();
public: __property void set_LocalizationFolder(
   System.string* value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute()]
public:
property System.String^ LocalizationFolder {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TextSettings Class
TextSettings Members


UseLanguage Property

[image]
Intersoft WebGrid Documentation
UseLanguage Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > TextSettings Class : UseLanguage Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property UseLanguage As System.String
Visual Basic (Usage) Copy Code
Dim instance As TextSettings
Dim value As System.String

instance.UseLanguage = value

value = instance.UseLanguage
C#
[System.ComponentModel.DescriptionAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.string UseLanguage {get; set;}
Delphi
public read-write property UseLanguage: System.String;
JScript
System.ComponentModel.DescriptionAttribute()
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set UseLanguage : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.string* get_UseLanguage();
public: __property void set_UseLanguage(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.String^ UseLanguage {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TextSettings Class
TextSettings Members


UseWebResources Property

[image]
Intersoft WebGrid Documentation
UseWebResources Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > TextSettings Class : UseWebResources Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Determines whether the language xml files should be retrieved from web resources whenever possible.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property UseWebResources As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As TextSettings
Dim value As System.Boolean

instance.UseWebResources = value

value = instance.UseWebResources
C#
[System.ComponentModel.DescriptionAttribute("Determines whether the language xml files should be retrieved from web resources whenever possible.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.bool UseWebResources {get; set;}
Delphi
public read-write property UseWebResources: System.Boolean;
JScript
System.ComponentModel.DescriptionAttribute("Determines whether the language xml files should be retrieved from web resources whenever possible.")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set UseWebResources : System.boolean
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Determines whether the language xml files should be retrieved from web resources whenever possible.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.bool get_UseWebResources();
public: __property void set_UseWebResources(
   System.bool value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Determines whether the language xml files should be retrieved from web resources whenever possible.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.bool UseWebResources {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TextSettings Class
TextSettings Members


WebComboEditor Class

[image]
Intersoft WebGrid Documentation
WebComboEditor Class
Members See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : WebComboEditor Class

Glossary Item Box

Object Model

WebComboEditor Class

Syntax

Visual Basic (Declaration)
Public Class WebComboEditor
   Inherits System.Drawing.Design.UITypeEditor
Visual Basic (Usage) Copy Code
Dim instance As WebComboEditor
C#
public class WebComboEditor : System.Drawing.Design.UITypeEditor
Delphi
public class WebComboEditor = class(System.Drawing.Design.UITypeEditor)
JScript
public class WebComboEditor extends System.Drawing.Design.UITypeEditor
Managed Extensions for C++
public __gc class WebComboEditor : public System.Drawing.Design.UITypeEditor
C++/CLI
public ref class WebComboEditor : public System.Drawing.Design.UITypeEditor

Inheritance Hierarchy

System.Object
System.Drawing.Design.UITypeEditor
ISNet.WebUI.WebGrid.WebComboEditor

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebComboEditor Members
ISNet.WebUI.WebGrid Namespace


WebComboEditor Class Members

[image]
Intersoft WebGrid Documentation
WebComboEditor Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebGrid Namespace : WebComboEditor Class

Glossary Item Box

The following tables list the members exposed by WebComboEditor.

Public Constructors

 | Name | Description
Public Constructor | WebComboEditor Constructor |
Top

Public Properties

 | Name | Description
Public Property | IsDropDownResizable | (Inherited from System.Drawing.Design.UITypeEditor)
Top

Public Methods

 | Name | Description
Public Method | EditValue | Overloaded. Overridden.
Public Method | GetEditStyle | Overloaded. Overridden.
Public Method | GetPaintValueSupported | Overloaded. Overridden.
Public Method | PaintValue | Overloaded. (Inherited from System.Drawing.Design.UITypeEditor)
Top

See Also

Reference

WebComboEditor Class
ISNet.WebUI.WebGrid Namespace


WebComboEditor Constructor

[image]
Intersoft WebGrid Documentation
WebComboEditor Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebComboEditor Class : WebComboEditor Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebComboEditor()
C#
public WebComboEditor()
Delphi
public WebComboEditor();
JScript
public function WebComboEditor();
Managed Extensions for C++
public: WebComboEditor();
C++/CLI
public:
WebComboEditor();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebComboEditor Class
WebComboEditor Members


WebComboEditor Class Methods

[image]
Intersoft WebGrid Documentation
WebComboEditor Class Methods
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : WebComboEditor Class

Glossary Item Box

For a list of all members of this type, see WebComboEditor members.

Public Methods

 | Name | Description
Public Method | EditValue | Overloaded. Overridden.
Public Method | GetEditStyle | Overloaded. Overridden.
Public Method | GetPaintValueSupported | Overloaded. Overridden.
Public Method | PaintValue | Overloaded. (Inherited from System.Drawing.Design.UITypeEditor)
Top

See Also

Reference

WebComboEditor Class
ISNet.WebUI.WebGrid Namespace


WebComboEditor Class Properties

[image]
Intersoft WebGrid Documentation
WebComboEditor Class Properties
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : WebComboEditor Class

Glossary Item Box

For a list of all members of this type, see WebComboEditor members.

Public Properties

 | Name | Description
Public Property | IsDropDownResizable | (Inherited from System.Drawing.Design.UITypeEditor)
Top

See Also

Reference

WebComboEditor Class
ISNet.WebUI.WebGrid Namespace


EditValue Method

[image]
Intersoft WebGrid Documentation
EditValue Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebComboEditor Class : EditValue Method

Glossary Item Box

Overload List

Overload | Description
EditValue(ITypeDescriptorContext,IServiceProvider,Object) |
EditValue(IServiceProvider,Object) | (Inherited from System.Drawing.Design.UITypeEditor)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebComboEditor Class
WebComboEditor Members


EditValue(ITypeDescriptorContext,IServiceProvider,Object) Method

[image]
Intersoft WebGrid Documentation
EditValue(ITypeDescriptorContext,IServiceProvider,Object) Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebComboEditor Class > EditValue Method : EditValue(ITypeDescriptorContext,IServiceProvider,Object) Method

context
provider
value

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Function EditValue( _
   ByVal context As System.ComponentModel.ITypeDescriptorContext, _
   ByVal provider As System.IServiceProvider, _
   ByVal value As System.Object _
) As System.Object
Visual Basic (Usage) Copy Code
Dim instance As WebComboEditor
Dim context As System.ComponentModel.ITypeDescriptorContext
Dim provider As System.IServiceProvider
Dim value As System.Object
Dim value As System.Object

value = instance.EditValue(context, provider, value)
C#
public override System.object EditValue(
   System.ComponentModel.ITypeDescriptorContext context,
   System.IServiceProvider provider,
   System.object value
)
Delphi
public function EditValue(
    context: System.ComponentModel.ITypeDescriptorContext;
    provider: System.IServiceProvider;
    value: System.TObject
): System.TObject; override;
JScript
public override function EditValue(
   context : System.ComponentModel.ITypeDescriptorContext,
   provider : System.IServiceProvider,
   value : System.Object
) : System.Object;
Managed Extensions for C++
public: System.Object* EditValue(
   System.ComponentModel.ITypeDescriptorContext* context,
   System.IServiceProvider* provider,
   System.Object* value
) override
C++/CLI
public:
System.Object^ EditValue(
   System.ComponentModel.ITypeDescriptorContext^ context,
   System.IServiceProvider^ provider,
   System.Object^ value
) override

Parameters

context
provider
value

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebComboEditor Class
WebComboEditor Members
Overload List


EditValue(IServiceProvider,Object) Method

[image]
Intersoft WebGrid Documentation
EditValue(IServiceProvider,Object) Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebComboEditor Class > EditValue Method : EditValue(IServiceProvider,Object) Method

provider
value

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")>
Public Overloads Function EditValue( _
   ByVal provider As System.IServiceProvider, _
   ByVal value As System.Object _
) As System.Object
Visual Basic (Usage) Copy Code
Dim instance As WebComboEditor
Dim provider As System.IServiceProvider
Dim value As System.Object
Dim value As System.Object

value = instance.EditValue(provider, value)
C#
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public System.object EditValue(
   System.IServiceProvider provider,
   System.object value
)
Delphi
public function EditValue(
    provider: System.IServiceProvider;
    value: System.TObject
): System.TObject;
JScript
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")
public function EditValue(
   provider : System.IServiceProvider,
   value : System.Object
) : System.Object;
Managed Extensions for C++
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public: System.Object* EditValue(
   System.IServiceProvider* provider,
   System.Object* value
)
C++/CLI
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public:
System.Object^ EditValue(
   System.IServiceProvider^ provider,
   System.Object^ value
)

Parameters

provider
value

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebComboEditor Class
WebComboEditor Members
Overload List


GetEditStyle Method

[image]
Intersoft WebGrid Documentation
GetEditStyle Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebComboEditor Class : GetEditStyle Method

Glossary Item Box

Overload List

Overload | Description
GetEditStyle(ITypeDescriptorContext) |
GetEditStyle() | (Inherited from System.Drawing.Design.UITypeEditor)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebComboEditor Class
WebComboEditor Members


GetEditStyle(ITypeDescriptorContext) Method

[image]
Intersoft WebGrid Documentation
GetEditStyle(ITypeDescriptorContext) Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebComboEditor Class > GetEditStyle Method : GetEditStyle(ITypeDescriptorContext) Method

context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Function GetEditStyle( _
   ByVal context As System.ComponentModel.ITypeDescriptorContext _
) As System.Drawing.Design.UITypeEditorEditStyle
Visual Basic (Usage) Copy Code
Dim instance As WebComboEditor
Dim context As System.ComponentModel.ITypeDescriptorContext
Dim value As System.Drawing.Design.UITypeEditorEditStyle

value = instance.GetEditStyle(context)
C#
public override System.Drawing.Design.UITypeEditorEditStyle GetEditStyle(
   System.ComponentModel.ITypeDescriptorContext context
)
Delphi
public function GetEditStyle(
    context: System.ComponentModel.ITypeDescriptorContext
): System.Drawing.Design.UITypeEditorEditStyle; override;
JScript
public override function GetEditStyle(
   context : System.ComponentModel.ITypeDescriptorContext
) : System.Drawing.Design.UITypeEditorEditStyle;
Managed Extensions for C++
public: System.Drawing.Design.UITypeEditorEditStyle GetEditStyle(
   System.ComponentModel.ITypeDescriptorContext* context
) override
C++/CLI
public:
System.Drawing.Design.UITypeEditorEditStyle GetEditStyle(
   System.ComponentModel.ITypeDescriptorContext^ context
) override

Parameters

context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebComboEditor Class
WebComboEditor Members
Overload List


GetEditStyle() Method

[image]
Intersoft WebGrid Documentation
GetEditStyle() Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebComboEditor Class > GetEditStyle Method : GetEditStyle() Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")>
Public Overloads Function GetEditStyle() As System.Drawing.Design.UITypeEditorEditStyle
Visual Basic (Usage) Copy Code
Dim instance As WebComboEditor
Dim value As System.Drawing.Design.UITypeEditorEditStyle

value = instance.GetEditStyle()
C#
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public System.Drawing.Design.UITypeEditorEditStyle GetEditStyle()
Delphi
public function GetEditStyle(): System.Drawing.Design.UITypeEditorEditStyle;
JScript
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")
public function GetEditStyle() : System.Drawing.Design.UITypeEditorEditStyle;
Managed Extensions for C++
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public: System.Drawing.Design.UITypeEditorEditStyle GetEditStyle();
C++/CLI
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public:
System.Drawing.Design.UITypeEditorEditStyle GetEditStyle();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebComboEditor Class
WebComboEditor Members
Overload List


GetPaintValueSupported Method

[image]
Intersoft WebGrid Documentation
GetPaintValueSupported Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebComboEditor Class : GetPaintValueSupported Method

Glossary Item Box

Overload List

Overload | Description
GetPaintValueSupported(ITypeDescriptorContext) |
GetPaintValueSupported() | (Inherited from System.Drawing.Design.UITypeEditor)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebComboEditor Class
WebComboEditor Members


GetPaintValueSupported(ITypeDescriptorContext) Method

[image]
Intersoft WebGrid Documentation
GetPaintValueSupported(ITypeDescriptorContext) Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebComboEditor Class > GetPaintValueSupported Method : GetPaintValueSupported(ITypeDescriptorContext) Method

context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Function GetPaintValueSupported( _
   ByVal context As System.ComponentModel.ITypeDescriptorContext _
) As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebComboEditor
Dim context As System.ComponentModel.ITypeDescriptorContext
Dim value As System.Boolean

value = instance.GetPaintValueSupported(context)
C#
public override System.bool GetPaintValueSupported(
   System.ComponentModel.ITypeDescriptorContext context
)
Delphi
public function GetPaintValueSupported(
    context: System.ComponentModel.ITypeDescriptorContext
): System.Boolean; override;
JScript
public override function GetPaintValueSupported(
   context : System.ComponentModel.ITypeDescriptorContext
) : System.boolean;
Managed Extensions for C++
public: System.bool GetPaintValueSupported(
   System.ComponentModel.ITypeDescriptorContext* context
) override
C++/CLI
public:
System.bool GetPaintValueSupported(
   System.ComponentModel.ITypeDescriptorContext^ context
) override

Parameters

context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebComboEditor Class
WebComboEditor Members
Overload List


GetPaintValueSupported() Method

[image]
Intersoft WebGrid Documentation
GetPaintValueSupported() Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebComboEditor Class > GetPaintValueSupported Method : GetPaintValueSupported() Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")>
Public Overloads Function GetPaintValueSupported() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebComboEditor
Dim value As System.Boolean

value = instance.GetPaintValueSupported()
C#
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public System.bool GetPaintValueSupported()
Delphi
public function GetPaintValueSupported(): System.Boolean;
JScript
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")
public function GetPaintValueSupported() : System.boolean;
Managed Extensions for C++
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public: System.bool GetPaintValueSupported();
C++/CLI
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public:
System.bool GetPaintValueSupported();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebComboEditor Class
WebComboEditor Members
Overload List


PaintValue Method

[image]
Intersoft WebGrid Documentation
PaintValue Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebComboEditor Class : PaintValue Method

Glossary Item Box

Overload List

Overload | Description
PaintValue(Object,Graphics,Rectangle) | (Inherited from System.Drawing.Design.UITypeEditor)
PaintValue(PaintValueEventArgs) | (Inherited from System.Drawing.Design.UITypeEditor)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebComboEditor Class
WebComboEditor Members


PaintValue(Object,Graphics,Rectangle) Method

[image]
Intersoft WebGrid Documentation
PaintValue(Object,Graphics,Rectangle) Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebComboEditor Class > PaintValue Method : PaintValue(Object,Graphics,Rectangle) Method

value
canvas
rectangle

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Sub PaintValue( _
   ByVal value As System.Object, _
   ByVal canvas As System.Drawing.Graphics, _
   ByVal rectangle As System.Drawing.Rectangle _
)
Visual Basic (Usage) Copy Code
Dim instance As WebComboEditor
Dim value As System.Object
Dim canvas As System.Drawing.Graphics
Dim rectangle As System.Drawing.Rectangle

instance.PaintValue(value, canvas, rectangle)
C#
public void PaintValue(
   System.object value,
   System.Drawing.Graphics canvas,
   System.Drawing.Rectangle rectangle
)
Delphi
public procedure PaintValue(
    value: System.TObject;
    canvas: System.Drawing.Graphics;
    rectangle: System.Drawing.Rectangle
);
JScript
public function PaintValue(
   value : System.Object,
   canvas : System.Drawing.Graphics,
   rectangle : System.Drawing.Rectangle
);
Managed Extensions for C++
public: void PaintValue(
   System.Object* value,
   System.Drawing.Graphics* canvas,
   System.Drawing.Rectangle rectangle
)
C++/CLI
public:
void PaintValue(
   System.Object^ value,
   System.Drawing.Graphics^ canvas,
   System.Drawing.Rectangle rectangle
)

Parameters

value
canvas
rectangle

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebComboEditor Class
WebComboEditor Members
Overload List


PaintValue(PaintValueEventArgs) Method

[image]
Intersoft WebGrid Documentation
PaintValue(PaintValueEventArgs) Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebComboEditor Class > PaintValue Method : PaintValue(PaintValueEventArgs) Method

e

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub PaintValue( _
   ByVal e As System.Drawing.Design.PaintValueEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As WebComboEditor
Dim e As System.Drawing.Design.PaintValueEventArgs

instance.PaintValue(e)
C#
public virtual void PaintValue(
   System.Drawing.Design.PaintValueEventArgs e
)
Delphi
public procedure PaintValue(
    e: System.Drawing.Design.PaintValueEventArgs
); virtual;
JScript
public function PaintValue(
   e : System.Drawing.Design.PaintValueEventArgs
);
Managed Extensions for C++
public: virtual void PaintValue(
   System.Drawing.Design.PaintValueEventArgs* e
)
C++/CLI
public:
virtual void PaintValue(
   System.Drawing.Design.PaintValueEventArgs^ e
)

Parameters

e

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebComboEditor Class
WebComboEditor Members
Overload List


IsDropDownResizable Property

[image]
Intersoft WebGrid Documentation
IsDropDownResizable Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebComboEditor Class : IsDropDownResizable Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property IsDropDownResizable As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebComboEditor
Dim value As System.Boolean

value = instance.IsDropDownResizable
C#
public virtual System.bool IsDropDownResizable {get;}
Delphi
public read-only property IsDropDownResizable: System.Boolean; virtual;
JScript
public function get IsDropDownResizable : System.boolean
Managed Extensions for C++
public: __property virtual System.bool get_IsDropDownResizable();
C++/CLI
public:
virtual property System.bool IsDropDownResizable {
   System.bool get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebComboEditor Class
WebComboEditor Members


WebGrid Class

[image]
Intersoft WebGrid Documentation
WebGrid Class
Members See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : WebGrid Class

Glossary Item Box

Object Model

WebGrid Class

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultPropertyAttribute("LayoutSettings")>
<System.ComponentModel.DefaultEventAttribute("InitializeDataSource")>
<ISNet.Serialization.XmlSerializableAttribute("WebGrid_Core.js;WebGrid_UI.js;WebGrid_Events.js")>
<System.ComponentModel.DesignerAttribute(DesignerBaseTypeName="System.ComponentModel.Design.IDesigner", DesignerTypeName="ISNet.WebUI.WebGrid.WebGridDesigner, ISNet.WebUI.WebGrid, Version=9.0.7200.1, Culture=neutral, PublicKeyToken=3e60b85fb8502d5e")>
<System.Web.UI.ToolboxDataAttribute("<{0}:WebGrid runat="server" UseDefaultStyle="true" Width="500px" Height="250px"></{0}:WebGrid>")>
<System.SerializableAttribute()>
<System.Web.AspNetHostingPermissionAttribute(Level=AspNetHostingPermissionLevel.Minimal,
   Action=SecurityAction.Demand Or  _
    SecurityAction.Deny Or  _
    SecurityAction.LinkDemand,
   Unrestricted=False)>
<System.Web.AspNetHostingPermissionAttribute(Level=AspNetHostingPermissionLevel.Minimal,
   Action=SecurityAction.Demand Or  _
    SecurityAction.Assert Or  _
    SecurityAction.Deny Or  _
    SecurityAction.PermitOnly Or  _
    SecurityAction.LinkDemand Or  _
    SecurityAction.InheritanceDemand,
   Unrestricted=False)>
Public Class WebGrid
   Inherits ISNet.WebUI.ISNetControl
   Implements ISNet.ICopyable, ISNet.IObjectState, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.Serialization.XmlSerialization.ICustomXmlSerializer, ISNet.Serialization.XmlSerialization.IXmlSerialize, ISNet.WebUI.IAutoDataCache, ISNet.WebUI.IBaseISNetControl, ISNet.WebUI.IClientAction, ISNet.WebUI.IClientBinding, ISNet.WebUI.IDataSourceControlSupport, ISNet.WebUI.IFlyPostBack, ISNet.WebUI.IInfo, ISNet.WebUI.ILayoutSettings, ISNet.WebUI.ISDataSource, ISNet.WebUI.ITemplateSync
Visual Basic (Usage) Copy Code
Dim instance As WebGrid
C#
[System.ComponentModel.DefaultPropertyAttribute("LayoutSettings")]
[System.ComponentModel.DefaultEventAttribute("InitializeDataSource")]
[ISNet.Serialization.XmlSerializableAttribute("WebGrid_Core.js;WebGrid_UI.js;WebGrid_Events.js")]
[System.ComponentModel.DesignerAttribute(DesignerBaseTypeName="System.ComponentModel.Design.IDesigner", DesignerTypeName="ISNet.WebUI.WebGrid.WebGridDesigner, ISNet.WebUI.WebGrid, Version=9.0.7200.1, Culture=neutral, PublicKeyToken=3e60b85fb8502d5e")]
[System.Web.UI.ToolboxDataAttribute("<{0}:WebGrid runat="server" UseDefaultStyle="true" Width="500px" Height="250px"></{0}:WebGrid>")]
[System.SerializableAttribute()]
[System.Web.AspNetHostingPermissionAttribute(Level=AspNetHostingPermissionLevel.Minimal,
   Action=SecurityAction.Demand |
    SecurityAction.Deny |
    SecurityAction.LinkDemand,
   Unrestricted=false)]
[System.Web.AspNetHostingPermissionAttribute(Level=AspNetHostingPermissionLevel.Minimal,
   Action=SecurityAction.Demand |
    SecurityAction.Assert |
    SecurityAction.Deny |
    SecurityAction.PermitOnly |
    SecurityAction.LinkDemand |
    SecurityAction.InheritanceDemand,
   Unrestricted=false)]
public class WebGrid : ISNet.WebUI.ISNetControl, ISNet.ICopyable, ISNet.IObjectState, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.Serialization.XmlSerialization.ICustomXmlSerializer, ISNet.Serialization.XmlSerialization.IXmlSerialize, ISNet.WebUI.IAutoDataCache, ISNet.WebUI.IBaseISNetControl, ISNet.WebUI.IClientAction, ISNet.WebUI.IClientBinding, ISNet.WebUI.IDataSourceControlSupport, ISNet.WebUI.IFlyPostBack, ISNet.WebUI.IInfo, ISNet.WebUI.ILayoutSettings, ISNet.WebUI.ISDataSource, ISNet.WebUI.ITemplateSync
Delphi
public class WebGrid = class(ISNet.WebUI.ISNetControl, ISNet.ICopyable, ISNet.IObjectState, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.Serialization.XmlSerialization.ICustomXmlSerializer, ISNet.Serialization.XmlSerialization.IXmlSerialize, ISNet.WebUI.IAutoDataCache, ISNet.WebUI.IBaseISNetControl, ISNet.WebUI.IClientAction, ISNet.WebUI.IClientBinding, ISNet.WebUI.IDataSourceControlSupport, ISNet.WebUI.IFlyPostBack, ISNet.WebUI.IInfo, ISNet.WebUI.ILayoutSettings, ISNet.WebUI.ISDataSource, ISNet.WebUI.ITemplateSync)
JScript
System.ComponentModel.DefaultPropertyAttribute("LayoutSettings")
System.ComponentModel.DefaultEventAttribute("InitializeDataSource")
ISNet.Serialization.XmlSerializableAttribute("WebGrid_Core.js;WebGrid_UI.js;WebGrid_Events.js")
System.ComponentModel.DesignerAttribute(DesignerBaseTypeName="System.ComponentModel.Design.IDesigner", DesignerTypeName="ISNet.WebUI.WebGrid.WebGridDesigner, ISNet.WebUI.WebGrid, Version=9.0.7200.1, Culture=neutral, PublicKeyToken=3e60b85fb8502d5e")
System.Web.UI.ToolboxDataAttribute("<{0}:WebGrid runat="server" UseDefaultStyle="true" Width="500px" Height="250px"></{0}:WebGrid>")
System.SerializableAttribute()
System.Web.AspNetHostingPermissionAttribute(Level=AspNetHostingPermissionLevel.Minimal,
   Action=SecurityAction.Demand |
    SecurityAction.Deny |
    SecurityAction.LinkDemand,
   Unrestricted=)
System.Web.AspNetHostingPermissionAttribute(Level=AspNetHostingPermissionLevel.Minimal,
   Action=SecurityAction.Demand |
    SecurityAction.Assert |
    SecurityAction.Deny |
    SecurityAction.PermitOnly |
    SecurityAction.LinkDemand |
    SecurityAction.InheritanceDemand,
   Unrestricted=)
public class WebGrid extends ISNet.WebUI.ISNetControl implements ISNet.ICopyable, ISNet.IObjectState, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.Serialization.XmlSerialization.ICustomXmlSerializer, ISNet.Serialization.XmlSerialization.IXmlSerialize, ISNet.WebUI.IAutoDataCache, ISNet.WebUI.IBaseISNetControl, ISNet.WebUI.IClientAction, ISNet.WebUI.IClientBinding, ISNet.WebUI.IDataSourceControlSupport, ISNet.WebUI.IFlyPostBack, ISNet.WebUI.IInfo, ISNet.WebUI.ILayoutSettings, ISNet.WebUI.ISDataSource, ISNet.WebUI.ITemplateSync
Managed Extensions for C++
[System.ComponentModel.DefaultPropertyAttribute("LayoutSettings")]
[System.ComponentModel.DefaultEventAttribute("InitializeDataSource")]
[ISNet.Serialization.XmlSerializableAttribute("WebGrid_Core.js;WebGrid_UI.js;WebGrid_Events.js")]
[System.ComponentModel.DesignerAttribute(DesignerBaseTypeName="System.ComponentModel.Design.IDesigner", DesignerTypeName="ISNet.WebUI.WebGrid.WebGridDesigner, ISNet.WebUI.WebGrid, Version=9.0.7200.1, Culture=neutral, PublicKeyToken=3e60b85fb8502d5e")]
[System.Web.UI.ToolboxDataAttribute("<{0}:WebGrid runat="server" UseDefaultStyle="true" Width="500px" Height="250px"></{0}:WebGrid>")]
[System.SerializableAttribute()]
[System.Web.AspNetHostingPermissionAttribute(Level=AspNetHostingPermissionLevel.Minimal,
   Action=SecurityAction.Demand |
    SecurityAction.Deny |
    SecurityAction.LinkDemand,
   Unrestricted=false)]
[System.Web.AspNetHostingPermissionAttribute(Level=AspNetHostingPermissionLevel.Minimal,
   Action=SecurityAction.Demand |
    SecurityAction.Assert |
    SecurityAction.Deny |
    SecurityAction.PermitOnly |
    SecurityAction.LinkDemand |
    SecurityAction.InheritanceDemand,
   Unrestricted=false)]
public __gc class WebGrid : public ISNet.WebUI.ISNetControl, ISNet.ICopyable, ISNet.IObjectState, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.Serialization.XmlSerialization.ICustomXmlSerializer, ISNet.Serialization.XmlSerialization.IXmlSerialize, ISNet.WebUI.IAutoDataCache, ISNet.WebUI.IBaseISNetControl, ISNet.WebUI.IClientAction, ISNet.WebUI.IClientBinding, ISNet.WebUI.IDataSourceControlSupport, ISNet.WebUI.IFlyPostBack, ISNet.WebUI.IInfo, ISNet.WebUI.ILayoutSettings, ISNet.WebUI.ISDataSource, ISNet.WebUI.ITemplateSync
C++/CLI
[System.ComponentModel.DefaultPropertyAttribute("LayoutSettings")]
[System.ComponentModel.DefaultEventAttribute("InitializeDataSource")]
[ISNet.Serialization.XmlSerializableAttribute("WebGrid_Core.js;WebGrid_UI.js;WebGrid_Events.js")]
[System.ComponentModel.DesignerAttribute(DesignerBaseTypeName="System.ComponentModel.Design.IDesigner", DesignerTypeName="ISNet.WebUI.WebGrid.WebGridDesigner, ISNet.WebUI.WebGrid, Version=9.0.7200.1, Culture=neutral, PublicKeyToken=3e60b85fb8502d5e")]
[System.Web.UI.ToolboxDataAttribute("<{0}:WebGrid runat="server" UseDefaultStyle="true" Width="500px" Height="250px"></{0}:WebGrid>")]
[System.SerializableAttribute()]
[System.Web.AspNetHostingPermissionAttribute(Level=AspNetHostingPermissionLevel.Minimal,
   Action=SecurityAction.Demand |
    SecurityAction.Deny |
    SecurityAction.LinkDemand,
   Unrestricted=false)]
[System.Web.AspNetHostingPermissionAttribute(Level=AspNetHostingPermissionLevel.Minimal,
   Action=SecurityAction.Demand |
    SecurityAction.Assert |
    SecurityAction.Deny |
    SecurityAction.PermitOnly |
    SecurityAction.LinkDemand |
    SecurityAction.InheritanceDemand,
   Unrestricted=false)]
public ref class WebGrid : public ISNet.WebUI.ISNetControl, ISNet.ICopyable, ISNet.IObjectState, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.Serialization.XmlSerialization.ICustomXmlSerializer, ISNet.Serialization.XmlSerialization.IXmlSerialize, ISNet.WebUI.IAutoDataCache, ISNet.WebUI.IBaseISNetControl, ISNet.WebUI.IClientAction, ISNet.WebUI.IClientBinding, ISNet.WebUI.IDataSourceControlSupport, ISNet.WebUI.IFlyPostBack, ISNet.WebUI.IInfo, ISNet.WebUI.ILayoutSettings, ISNet.WebUI.ISDataSource, ISNet.WebUI.ITemplateSync

Inheritance Hierarchy

System.Object
System.Web.UI.Control
System.Web.UI.WebControls.WebControl
ISNet.WebUI.ISNetControl
ISNet.WebUI.WebGrid.WebGrid

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Members
ISNet.WebUI.WebGrid Namespace


WebGrid Class Members

[image]
Intersoft WebGrid Documentation
WebGrid Class Members
See Also Fields Properties Methods Events Send Feedback
ISNet.WebUI.WebGrid Namespace : WebGrid Class

Glossary Item Box

The following tables list the members exposed by WebGrid.

Public Constructors

 | Name | Description
Public Constructor | WebGrid Constructor | Overloaded.
Top

Public Fields

 | Name | Description
Public Field | VirtualLoadArgs |
Top

Public Properties

 | Name | Description
Public Property | AccessKey | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | AllowAutoDataCaching |
Public Property | AllowPivotCharting |
Public Property | BackColor | Overridden.
Public Property | BindingOperationMode |
Public Property | BorderColor | Overridden.
Public Property | BorderStyle | Overridden.
Public Property | BorderWidth | Overridden.
Public Property | BrowserPrintSettings |
Public Property | CacheServerConnection |
Public Property | CellPadding |
Public Property | ChartCategoryCollection |
Public Property | ChartDataCollection |
Public Property | ChartFilterCollection |
Public Property | ChartInteractiveUI |
Public Property | ChartMode |
Public Property | ChartSeriesCollection |
Public Property | ClientBindingSettings |
Public Property | ClientIDMode | (Inherited from System.Web.UI.Control)
Public Property | ControlDataTransferFormat | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | CustomSchemaRetrieval |
Public Property | DataCacheStorage |
Public Property | DataMember |
Public Property | DataSource |
Public Property | DataSourceID |
Public Property | DataSourceManager | Overridden.
Public Property | DefaultStyleMode |
Public Property | DisableFileSystemChecking |
Public Property | Enabled | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | EnableManagedTheming | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | EnableSection508Standards |
Public Property | EnableTheming | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | EnableV3XAPISupport |
Public Property | EnableViewState | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | EnableWebResources | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | FlyPostBackSettings |
Public Property | Font | Overridden.
Public Property | ForeColor | Overridden.
Public Property | GridLines |
Public Property | Height | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | ID | (Inherited from System.Web.UI.Control)
Public Property | ImageFileServer |
Public Property | LayoutSettings |
Public Property | Page | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | RenderingMode | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | RuntimeLicenseKey | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | ScriptDirectory | Overridden.
Public Property | SerializeTagToClient |
Public Property | Settings |
Public Property | SharedScriptDirectory | Overridden.
Public Property | SkinID | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | StateRestorationLevel |
Public Property | TabIndex | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | ToolTip | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | UseDefaultStyle |
Public Property | ValidateRequestMode | (Inherited from System.Web.UI.Control)
Public Property | ViewStateItems | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | ViewStateMode | (Inherited from System.Web.UI.Control)
Public Property | ViewStateServerConnection | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | ViewStateStorage | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | Visible | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | WebDesktopScriptDirectory |
Public Property | Width | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | XmlCompressionEnabled | (Inherited from ISNet.WebUI.ISNetControl)
Top

Public Methods

 | Name | Description
Public Method | AddBatchUpdateException |
Public Method | AddDataSourceToCache |
Public Method | ApplyStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | ApplyStyleSheetSkin | (Inherited from System.Web.UI.Control)
Public Method | CanUseWebResources | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | CheckConstrains | Overridden.
Public Method | ClearCachedDataSource |
Public Method | Clone | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ConfigureTreeViewFromXml |
Public Method | CopyBaseAttributes | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.ISNetControl)
Public Method | CustomDeserialize |
Public Method | CustomSerialize |
Public Method | DataBind | Overridden.
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | Dispose | (Inherited from System.Web.UI.Control)
Public Method | ExportGrid | Overloaded.
Public Method | FindControl | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | Focus | (Inherited from System.Web.UI.Control)
Public Method | ForceDisableXmlCompression | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetAllCustomEditors |
Public Method | GetBatchUpdateExceptions |
Public Method | GetCachedDataSource |
Public Method | GetChanges | Overloaded.
Public Method | GetClientAction |
Public Method | GetCurrentControlLifeCycle | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetCurrentPageIndex |
Public Method | GetCurrentTheme | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetCustomEditorByName |
Public Method | GetDefaultReportInfo |
Public Method | GetDesignerLevelCustomEditors |
Public Method | GetFrameworkDataFolder | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetFrameworkFolder | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetFrameworkVersion | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetGridLevelCustomEditors |
Public Method | GetInstalledCustomEditors |
Public Method | GetIntersoftFolder | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetLayoutFolder | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetObjectData | Overridden.
Public Method | GetPostedXMLData | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetProductInfoKey | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetProductSimpleName | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetPropertyValue | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetResourceStream | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetRouteUrl | Overloaded. (Inherited from System.Web.UI.Control)
Public Method | GetTableByName |
Public Method | GetTotalPages |
Public Method | GetUniqueIDRelativeTo | (Inherited from System.Web.UI.Control)
Public Method | GetUtilizedCustomEditors |
Public Method | GetXMLCultureInfo | Overridden.
Public Method | HasControls | (Inherited from System.Web.UI.Control)
Public Method | IsAtlasCallback | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsBetaRelease | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsChromeBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsDataCached |
Public Method | IsEmpty | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsFlyPostBackControl | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsFlyPostBackRequest | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsGeckoBasedBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsGeckoVersion18 | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsInDesignMode | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsInternetExplorer11Browser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsInternetExplorer8Browser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsInternetExplorerBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsKeyValuesEqual |
Public Method | IsOperaBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsSafariBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsValidC1DataSource |
Public Method | IsW3CStandardBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadChartFromXml | Overloaded.
Public Method | LoadLayout | Overloaded.
Public Method | LoadLayoutFromFile | Overridden.
Public Method | LoadLayoutFromPredefinedName | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadLayoutFromStream | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadLayoutFromXml | Overloaded.
Public Method | LoadPostData | Overridden.
Public Method | LoadTablesStructure | Overloaded.
Public Method | LoadTablesStructureFromXml | Overloaded.
Public Method | MergeStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | OnAddRow |
Public Method | OnBatchUpdate |
Public Method | OnButtonClick |
Public Method | OnChartImageProcessed |
Public Method | OnChartImageProcessing |
Public Method | OnCustomAggregate |
Public Method | OnCustomFilter |
Public Method | OnCustomSort |
Public Method | OnDeleteRow |
Public Method | OnExport |
Public Method | OnExportCompleted |
Public Method | OnInfoChanged | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | OnInitializeCell |
Public Method | OnInitializeChildTableDataSource |
Public Method | OnInitializeColumn |
Public Method | OnInitializeDataSource |
Public Method | OnInitializeJsonRow |
Public Method | OnInitializeLayout |
Public Method | OnInitializePostBack |
Public Method | OnInitializeRow |
Public Method | OnInitializeSelfReferenceDataSource |
Public Method | OnInitializeTable |
Public Method | OnLoadPreviewRow |
Public Method | OnPreInitialize | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | OnPrepareDataBinding |
Public Method | OnPrepareExportExecute |
Public Method | OnRowChanged |
Public Method | OnUpdateRow |
Public Method | PerformBatchUpdate | Overloaded.
Public Method | RaisePostBackEvent |
Public Method | RaisePostDataChangedEvent | Overridden.
Public Method | ReadWebConfigValue | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RebindDataSource |
Public Method | RegisterBoxSizing | Overloaded. (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterGlobalStyle | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterLink | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterOptimizedCssClasses | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterPreloadImage | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterScript | Overridden.
Public Method | RegisterSharePointHandler | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RenderBeginTag | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RenderControl | (Inherited from System.Web.UI.Control)
Public Method | RenderEndTag | Overridden.
Public Method | Reset | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ResetDefaultStylePreset |
Public Method | ResetStyleToDefault |
Public Method | ResolveClientUrl | (Inherited from System.Web.UI.Control)
Public Method | ResolveImagePath | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ResolveRelativeURL | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ResolveResourceUrl | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ResolveUrl | (Inherited from System.Web.UI.Control)
Public Method | RetrieveClientLastSelectedObject |
Public Method | RetrieveHierarchicalStructure |
Public Method | RetrieveStructure |
Public Method | SaveChartToXml | Overloaded.
Public Method | SaveLayout | Overloaded.
Public Method | SaveLayoutToFile | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | SaveLayoutToStream | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | SaveLayoutToXml | Overloaded.
Public Method | SaveTablesStructure | Overloaded.
Public Method | SaveTablesStructureToXml | Overloaded.
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | SetCacheControl |
Public Method | SetCurrentPageIndex |
Public Method | SetFocus |
Public Method | SetObjectRelations |
Public Method | SetOutputParameters |
Public Method | SetRenderMethodDelegate | (Inherited from System.Web.UI.Control)
Public Method | SetSelectedObject |
Public Method | SetSessionTheme | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ShouldReturnJson | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | SynchronizeTemplatesFrom |
Public Method | UpdateFileServerCache |
Top

Public Events

 | Name | Description
Public Event | AddRow |
Public Event | BatchUpdate |
Public Event | ButtonClick |
Public Event | ChartImageProcessed |
Public Event | ChartImageProcessing |
Public Event | CustomAggregate |
Public Event | CustomFilter |
Public Event | CustomSort |
Public Event | DataBinding | (Inherited from System.Web.UI.Control)
Public Event | DeleteRow |
Public Event | Disposed | (Inherited from System.Web.UI.Control)
Public Event | Export |
Public Event | ExportCompleted |
Public Event | Init | (Inherited from System.Web.UI.Control)
Public Event | InitializeCell |
Public Event | InitializeChildTableDataSource |
Public Event | InitializeColumn |
Public Event | InitializeDataSource |
Public Event | InitializeJsonRow |
Public Event | InitializeLayout |
Public Event | InitializePostBack |
Public Event | InitializeRow |
Public Event | InitializeSelfReferenceDataSource |
Public Event | InitializeTable |
Public Event | Load | (Inherited from System.Web.UI.Control)
Public Event | LoadPreviewRow |
Public Event | PreInitialize | (Inherited from ISNet.WebUI.ISNetControl)
Public Event | PrepareDataBinding |
Public Event | PrepareExportExecute |
Public Event | PreRender | (Inherited from System.Web.UI.Control)
Public Event | RowChanged |
Public Event | Unload | (Inherited from System.Web.UI.Control)
Public Event | UpdateRow |
Top

See Also

Reference

WebGrid Class
ISNet.WebUI.WebGrid Namespace


WebGrid Constructor

[image]
Intersoft WebGrid Documentation
WebGrid Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class : WebGrid Constructor

Glossary Item Box

Overload List

Overload | Description
WebGrid Constructor() |
WebGrid Constructor(String) |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members


WebGrid Constructor()

[image]
Intersoft WebGrid Documentation
WebGrid Constructor()
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class > WebGrid Constructor : WebGrid Constructor()

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebGrid()
C#
public WebGrid()
Delphi
public WebGrid();
JScript
public function WebGrid();
Managed Extensions for C++
public: WebGrid();
C++/CLI
public:
WebGrid();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members
Overload List


WebGrid Constructor(String)

[image]
Intersoft WebGrid Documentation
WebGrid Constructor(String)
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class > WebGrid Constructor : WebGrid Constructor(String)

id

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal id As System.String _
)
Visual Basic (Usage) Copy Code
Dim id As System.String

Dim instance As New WebGrid(id)
C#
public WebGrid(
   System.string id
)
Delphi
public WebGrid(
    id: System.String
);
JScript
public function WebGrid(
   id : System.String
);
Managed Extensions for C++
public: WebGrid(
   System.string* id
)
C++/CLI
public:
WebGrid(
   System.String^ id
)

Parameters

id

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members
Overload List


WebGrid Class Methods

[image]
Intersoft WebGrid Documentation
WebGrid Class Methods
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : WebGrid Class

Glossary Item Box

For a list of all members of this type, see WebGrid members.

Public Methods

 | Name | Description
Public Method | AddBatchUpdateException |
Public Method | AddDataSourceToCache |
Public Method | ApplyStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | ApplyStyleSheetSkin | (Inherited from System.Web.UI.Control)
Public Method | CanUseWebResources | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | CheckConstrains | Overridden.
Public Method | ClearCachedDataSource |
Public Method | Clone | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ConfigureTreeViewFromXml |
Public Method | CopyBaseAttributes | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.ISNetControl)
Public Method | CustomDeserialize |
Public Method | CustomSerialize |
Public Method | DataBind | Overridden.
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | Dispose | (Inherited from System.Web.UI.Control)
Public Method | ExportGrid | Overloaded.
Public Method | FindControl | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | Focus | (Inherited from System.Web.UI.Control)
Public Method | ForceDisableXmlCompression | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetAllCustomEditors |
Public Method | GetBatchUpdateExceptions |
Public Method | GetCachedDataSource |
Public Method | GetChanges | Overloaded.
Public Method | GetClientAction |
Public Method | GetCurrentControlLifeCycle | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetCurrentPageIndex |
Public Method | GetCurrentTheme | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetCustomEditorByName |
Public Method | GetDefaultReportInfo |
Public Method | GetDesignerLevelCustomEditors |
Public Method | GetFrameworkDataFolder | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetFrameworkFolder | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetFrameworkVersion | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetGridLevelCustomEditors |
Public Method | GetInstalledCustomEditors |
Public Method | GetIntersoftFolder | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetLayoutFolder | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetObjectData | Overridden.
Public Method | GetPostedXMLData | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetProductInfoKey | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetProductSimpleName | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetPropertyValue | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetResourceStream | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetRouteUrl | Overloaded. (Inherited from System.Web.UI.Control)
Public Method | GetTableByName |
Public Method | GetTotalPages |
Public Method | GetUniqueIDRelativeTo | (Inherited from System.Web.UI.Control)
Public Method | GetUtilizedCustomEditors |
Public Method | GetXMLCultureInfo | Overridden.
Public Method | HasControls | (Inherited from System.Web.UI.Control)
Public Method | IsAtlasCallback | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsBetaRelease | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsChromeBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsDataCached |
Public Method | IsEmpty | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsFlyPostBackControl | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsFlyPostBackRequest | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsGeckoBasedBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsGeckoVersion18 | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsInDesignMode | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsInternetExplorer11Browser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsInternetExplorer8Browser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsInternetExplorerBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsKeyValuesEqual |
Public Method | IsOperaBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsSafariBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsValidC1DataSource |
Public Method | IsW3CStandardBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadChartFromXml | Overloaded.
Public Method | LoadLayout | Overloaded.
Public Method | LoadLayoutFromFile | Overridden.
Public Method | LoadLayoutFromPredefinedName | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadLayoutFromStream | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadLayoutFromXml | Overloaded.
Public Method | LoadPostData | Overridden.
Public Method | LoadTablesStructure | Overloaded.
Public Method | LoadTablesStructureFromXml | Overloaded.
Public Method | MergeStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | OnAddRow |
Public Method | OnBatchUpdate |
Public Method | OnButtonClick |
Public Method | OnChartImageProcessed |
Public Method | OnChartImageProcessing |
Public Method | OnCustomAggregate |
Public Method | OnCustomFilter |
Public Method | OnCustomSort |
Public Method | OnDeleteRow |
Public Method | OnExport |
Public Method | OnExportCompleted |
Public Method | OnInfoChanged | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | OnInitializeCell |
Public Method | OnInitializeChildTableDataSource |
Public Method | OnInitializeColumn |
Public Method | OnInitializeDataSource |
Public Method | OnInitializeJsonRow |
Public Method | OnInitializeLayout |
Public Method | OnInitializePostBack |
Public Method | OnInitializeRow |
Public Method | OnInitializeSelfReferenceDataSource |
Public Method | OnInitializeTable |
Public Method | OnLoadPreviewRow |
Public Method | OnPreInitialize | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | OnPrepareDataBinding |
Public Method | OnPrepareExportExecute |
Public Method | OnRowChanged |
Public Method | OnUpdateRow |
Public Method | PerformBatchUpdate | Overloaded.
Public Method | RaisePostBackEvent |
Public Method | RaisePostDataChangedEvent | Overridden.
Public Method | ReadWebConfigValue | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RebindDataSource |
Public Method | RegisterBoxSizing | Overloaded. (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterGlobalStyle | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterLink | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterOptimizedCssClasses | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterPreloadImage | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterScript | Overridden.
Public Method | RegisterSharePointHandler | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RenderBeginTag | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RenderControl | (Inherited from System.Web.UI.Control)
Public Method | RenderEndTag | Overridden.
Public Method | Reset | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ResetDefaultStylePreset |
Public Method | ResetStyleToDefault |
Public Method | ResolveClientUrl | (Inherited from System.Web.UI.Control)
Public Method | ResolveImagePath | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ResolveRelativeURL | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ResolveResourceUrl | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ResolveUrl | (Inherited from System.Web.UI.Control)
Public Method | RetrieveClientLastSelectedObject |
Public Method | RetrieveHierarchicalStructure |
Public Method | RetrieveStructure |
Public Method | SaveChartToXml | Overloaded.
Public Method | SaveLayout | Overloaded.
Public Method | SaveLayoutToFile | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | SaveLayoutToStream | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | SaveLayoutToXml | Overloaded.
Public Method | SaveTablesStructure | Overloaded.
Public Method | SaveTablesStructureToXml | Overloaded.
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | SetCacheControl |
Public Method | SetCurrentPageIndex |
Public Method | SetFocus |
Public Method | SetObjectRelations |
Public Method | SetOutputParameters |
Public Method | SetRenderMethodDelegate | (Inherited from System.Web.UI.Control)
Public Method | SetSelectedObject |
Public Method | SetSessionTheme | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ShouldReturnJson | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | SynchronizeTemplatesFrom |
Public Method | UpdateFileServerCache |
Top

See Also

Reference

WebGrid Class
ISNet.WebUI.WebGrid Namespace


AddBatchUpdateException Method

[image]
Intersoft WebGrid Documentation
AddBatchUpdateException Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class : AddBatchUpdateException Method

exception

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub AddBatchUpdateException( _
   ByVal exception As WebGridBatchUpdateException _
)
Visual Basic (Usage) Copy Code
Dim instance As WebGrid
Dim exception As WebGridBatchUpdateException

instance.AddBatchUpdateException(exception)
C#
public void AddBatchUpdateException(
   WebGridBatchUpdateException exception
)
Delphi
public procedure AddBatchUpdateException(
    exception: WebGridBatchUpdateException
);
JScript
public function AddBatchUpdateException(
   exception : WebGridBatchUpdateException
);
Managed Extensions for C++
public: void AddBatchUpdateException(
   WebGridBatchUpdateException* exception
)
C++/CLI
public:
void AddBatchUpdateException(
   WebGridBatchUpdateException^ exception
)

Parameters

exception

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members


AddDataSourceToCache Method

[image]
Intersoft WebGrid Documentation
AddDataSourceToCache Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class : AddDataSourceToCache Method

dataSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub AddDataSourceToCache( _
   ByVal dataSource As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebGrid
Dim dataSource As System.Object

instance.AddDataSourceToCache(dataSource)
C#
public void AddDataSourceToCache(
   System.object dataSource
)
Delphi
public procedure AddDataSourceToCache(
    dataSource: System.TObject
);
JScript
public function AddDataSourceToCache(
   dataSource : System.Object
);
Managed Extensions for C++
public: void AddDataSourceToCache(
   System.Object* dataSource
)
C++/CLI
public:
void AddDataSourceToCache(
   System.Object^ dataSource
)

Parameters

dataSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members


ApplyStyle Method

[image]
Intersoft WebGrid Documentation
ApplyStyle Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class : ApplyStyle Method

s

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub ApplyStyle( _
   ByVal s As System.Web.UI.WebControls.Style _
)
Visual Basic (Usage) Copy Code
Dim instance As WebGrid
Dim s As System.Web.UI.WebControls.Style

instance.ApplyStyle(s)
C#
public void ApplyStyle(
   System.Web.UI.WebControls.Style s
)
Delphi
public procedure ApplyStyle(
    s: System.Web.UI.WebControls.Style
);
JScript
public function ApplyStyle(
   s : System.Web.UI.WebControls.Style
);
Managed Extensions for C++
public: void ApplyStyle(
   System.Web.UI.WebControls.Style* s
)
C++/CLI
public:
void ApplyStyle(
   System.Web.UI.WebControls.Style^ s
)

Parameters

s

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members


ApplyStyleSheetSkin Method

[image]
Intersoft WebGrid Documentation
ApplyStyleSheetSkin Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class : ApplyStyleSheetSkin Method

page

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Public Overridable Sub ApplyStyleSheetSkin( _
   ByVal page As System.Web.UI.Page _
)
Visual Basic (Usage) Copy Code
Dim instance As WebGrid
Dim page As System.Web.UI.Page

instance.ApplyStyleSheetSkin(page)
C#
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public virtual void ApplyStyleSheetSkin(
   System.Web.UI.Page page
)
Delphi
public procedure ApplyStyleSheetSkin(
    page: System.Web.UI.Page
); virtual;
JScript
System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)
public function ApplyStyleSheetSkin(
   page : System.Web.UI.Page
);
Managed Extensions for C++
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public: virtual void ApplyStyleSheetSkin(
   System.Web.UI.Page* page
)
C++/CLI
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public:
virtual void ApplyStyleSheetSkin(
   System.Web.UI.Page^ page
)

Parameters

page

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members


CanUseWebResources Method

[image]
Intersoft WebGrid Documentation
CanUseWebResources Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class : CanUseWebResources Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function CanUseWebResources() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebGrid
Dim value As System.Boolean

value = instance.CanUseWebResources()
C#
public System.bool CanUseWebResources()
Delphi
public function CanUseWebResources(): System.Boolean;
JScript
public function CanUseWebResources() : System.boolean;
Managed Extensions for C++
public: System.bool CanUseWebResources();
C++/CLI
public:
System.bool CanUseWebResources();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members


CheckConstrains Method

[image]
Intersoft WebGrid Documentation
CheckConstrains Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class : CheckConstrains Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Sub CheckConstrains()
Visual Basic (Usage) Copy Code
Dim instance As WebGrid

instance.CheckConstrains()
C#
public override void CheckConstrains()
Delphi
public procedure CheckConstrains(); override;
JScript
public override function CheckConstrains();
Managed Extensions for C++
public: void CheckConstrains(); override
C++/CLI
public:
void CheckConstrains(); override

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members


ClearCachedDataSource Method

[image]
Intersoft WebGrid Documentation
ClearCachedDataSource Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class : ClearCachedDataSource Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub ClearCachedDataSource()
Visual Basic (Usage) Copy Code
Dim instance As WebGrid

instance.ClearCachedDataSource()
C#
public void ClearCachedDataSource()
Delphi
public procedure ClearCachedDataSource();
JScript
public function ClearCachedDataSource();
Managed Extensions for C++
public: void ClearCachedDataSource();
C++/CLI
public:
void ClearCachedDataSource();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members


Clone Method

[image]
Intersoft WebGrid Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As System.Object
Visual Basic (Usage) Copy Code
Dim instance As WebGrid
Dim value As System.Object

value = instance.Clone()
C#
public virtual System.object Clone()
Delphi
public function Clone(): System.TObject; virtual;
JScript
public function Clone() : System.Object;
Managed Extensions for C++
public: virtual System.Object* Clone();
C++/CLI
public:
virtual System.Object^ Clone();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members


ConfigureTreeViewFromXml Method

[image]
Intersoft WebGrid Documentation
ConfigureTreeViewFromXml Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class : ConfigureTreeViewFromXml Method

xmlDocument
xPath
retrieveXmlSchema
isTreeViewMode

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub ConfigureTreeViewFromXml( _
   ByVal xmlDocument As System.Xml.XmlDocument, _
   ByVal xPath As System.String, _
   ByVal retrieveXmlSchema As System.Boolean, _
   ByVal isTreeViewMode As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebGrid
Dim xmlDocument As System.Xml.XmlDocument
Dim xPath As System.String
Dim retrieveXmlSchema As System.Boolean
Dim isTreeViewMode As System.Boolean

instance.ConfigureTreeViewFromXml(xmlDocument, xPath, retrieveXmlSchema, isTreeViewMode)
C#
public void ConfigureTreeViewFromXml(
   System.Xml.XmlDocument xmlDocument,
   System.string xPath,
   System.bool retrieveXmlSchema,
   System.bool isTreeViewMode
)
Delphi
public procedure ConfigureTreeViewFromXml(
    xmlDocument: System.Xml.XmlDocument;
    xPath: System.String;
    retrieveXmlSchema: System.Boolean;
    isTreeViewMode: System.Boolean
);
JScript
public function ConfigureTreeViewFromXml(
   xmlDocument : System.Xml.XmlDocument,
   xPath : System.String,
   retrieveXmlSchema : System.boolean,
   isTreeViewMode : System.boolean
);
Managed Extensions for C++
public: void ConfigureTreeViewFromXml(
   System.Xml.XmlDocument* xmlDocument,
   System.string* xPath,
   System.bool retrieveXmlSchema,
   System.bool isTreeViewMode
)
C++/CLI
public:
void ConfigureTreeViewFromXml(
   System.Xml.XmlDocument^ xmlDocument,
   System.String^ xPath,
   System.bool retrieveXmlSchema,
   System.bool isTreeViewMode
)

Parameters

xmlDocument
xPath
retrieveXmlSchema
isTreeViewMode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members


CopyBaseAttributes Method

[image]
Intersoft WebGrid Documentation
CopyBaseAttributes Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class : CopyBaseAttributes Method

controlSrc

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub CopyBaseAttributes( _
   ByVal controlSrc As System.Web.UI.WebControls.WebControl _
)
Visual Basic (Usage) Copy Code
Dim instance As WebGrid
Dim controlSrc As System.Web.UI.WebControls.WebControl

instance.CopyBaseAttributes(controlSrc)
C#
public void CopyBaseAttributes(
   System.Web.UI.WebControls.WebControl controlSrc
)
Delphi
public procedure CopyBaseAttributes(
    controlSrc: System.Web.UI.WebControls.WebControl
);
JScript
public function CopyBaseAttributes(
   controlSrc : System.Web.UI.WebControls.WebControl
);
Managed Extensions for C++
public: void CopyBaseAttributes(
   System.Web.UI.WebControls.WebControl* controlSrc
)
C++/CLI
public:
void CopyBaseAttributes(
   System.Web.UI.WebControls.WebControl^ controlSrc
)

Parameters

controlSrc

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members


CopyFrom Method

[image]
Intersoft WebGrid Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.ISNetControl)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.ISNetControl)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members


CopyFrom(Object) Method

[image]
Intersoft WebGrid Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebGrid
Dim objSource As System.Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   System.object objSource
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebGrid Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object, _
   ByVal cloneSourceValue As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebGrid
Dim objSource As System.Object
Dim cloneSourceValue As System.Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   System.object objSource,
   System.bool cloneSourceValue
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject;
    cloneSourceValue: System.Boolean
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object,
   cloneSourceValue : System.boolean
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource,
   System.bool cloneSourceValue
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource,
   System.bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members
Overload List


CustomDeserialize Method

[image]
Intersoft WebGrid Documentation
CustomDeserialize Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class : CustomDeserialize Method

mi
currentObj
parentNode
currentNode

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub CustomDeserialize( _
   ByVal mi As System.Reflection.MemberInfo, _
   ByVal currentObj As System.Object, _
   ByVal parentNode As System.Xml.XmlNode, _
   ByVal currentNode As System.Xml.XmlNode _
)
Visual Basic (Usage) Copy Code
Dim instance As WebGrid
Dim mi As System.Reflection.MemberInfo
Dim currentObj As System.Object
Dim parentNode As System.Xml.XmlNode
Dim currentNode As System.Xml.XmlNode

instance.CustomDeserialize(mi, currentObj, parentNode, currentNode)
C#
public void CustomDeserialize(
   System.Reflection.MemberInfo mi,
   System.object currentObj,
   System.Xml.XmlNode parentNode,
   System.Xml.XmlNode currentNode
)
Delphi
public procedure CustomDeserialize(
    mi: System.Reflection.MemberInfo;
    currentObj: System.TObject;
    parentNode: System.Xml.XmlNode;
    currentNode: System.Xml.XmlNode
);
JScript
public function CustomDeserialize(
   mi : System.Reflection.MemberInfo,
   currentObj : System.Object,
   parentNode : System.Xml.XmlNode,
   currentNode : System.Xml.XmlNode
);
Managed Extensions for C++
public: void CustomDeserialize(
   System.Reflection.MemberInfo* mi,
   System.Object* currentObj,
   System.Xml.XmlNode* parentNode,
   System.Xml.XmlNode* currentNode
)
C++/CLI
public:
void CustomDeserialize(
   System.Reflection.MemberInfo^ mi,
   System.Object^ currentObj,
   System.Xml.XmlNode^ parentNode,
   System.Xml.XmlNode^ currentNode
)

Parameters

mi
currentObj
parentNode
currentNode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members


CustomSerialize Method

[image]
Intersoft WebGrid Documentation
CustomSerialize Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class : CustomSerialize Method

doc
node

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub CustomSerialize( _
   ByVal doc As System.Xml.XmlDocument, _
   ByVal node As System.Xml.XmlNode _
)
Visual Basic (Usage) Copy Code
Dim instance As WebGrid
Dim doc As System.Xml.XmlDocument
Dim node As System.Xml.XmlNode

instance.CustomSerialize(doc, node)
C#
public void CustomSerialize(
   System.Xml.XmlDocument doc,
   System.Xml.XmlNode node
)
Delphi
public procedure CustomSerialize(
    doc: System.Xml.XmlDocument;
    node: System.Xml.XmlNode
);
JScript
public function CustomSerialize(
   doc : System.Xml.XmlDocument,
   node : System.Xml.XmlNode
);
Managed Extensions for C++
public: void CustomSerialize(
   System.Xml.XmlDocument* doc,
   System.Xml.XmlNode* node
)
C++/CLI
public:
void CustomSerialize(
   System.Xml.XmlDocument^ doc,
   System.Xml.XmlNode^ node
)

Parameters

doc
node

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members


DataBind Method

[image]
Intersoft WebGrid Documentation
DataBind Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class : DataBind Method

Glossary Item Box

Overload List

Overload | Description
DataBind |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members


DataBind() Method

[image]
Intersoft WebGrid Documentation
DataBind() Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class : DataBind() Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Sub DataBind()
Visual Basic (Usage) Copy Code
Dim instance As WebGrid

instance.DataBind()
C#
public override void DataBind()
Delphi
public procedure DataBind(); override;
JScript
public override function DataBind();
Managed Extensions for C++
public: void DataBind(); override
C++/CLI
public:
void DataBind(); override

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members


DeSerializeObjectData Method

[image]
Intersoft WebGrid Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebGrid
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure DeSerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function DeSerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void DeSerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void DeSerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members


Dispose Method

[image]
Intersoft WebGrid Documentation
Dispose Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class : Dispose Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Dispose()
Visual Basic (Usage) Copy Code
Dim instance As WebGrid

instance.Dispose()
C#
public virtual void Dispose()
Delphi
public procedure Dispose(); virtual;
JScript
public function Dispose();
Managed Extensions for C++
public: virtual void Dispose();
C++/CLI
public:
virtual void Dispose();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members


ExportGrid Method

[image]
Intersoft WebGrid Documentation
ExportGrid Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class : ExportGrid Method

Glossary Item Box

Overload List

Overload | Description
ExportGrid() |
ExportGrid(DynARInfo) |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members


ExportGrid() Method

[image]
Intersoft WebGrid Documentation
ExportGrid() Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class > ExportGrid Method : ExportGrid() Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function ExportGrid() As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebGrid
Dim value As System.String

value = instance.ExportGrid()
C#
public System.string ExportGrid()
Delphi
public function ExportGrid(): System.String;
JScript
public function ExportGrid() : System.String;
Managed Extensions for C++
public: System.string* ExportGrid();
C++/CLI
public:
System.String^ ExportGrid();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members
Overload List


ExportGrid(DynARInfo) Method

[image]
Intersoft WebGrid Documentation
ExportGrid(DynARInfo) Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class > ExportGrid Method : ExportGrid(DynARInfo) Method

reportInfo

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function ExportGrid( _
   ByVal reportInfo As DynARInfo _
) As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebGrid
Dim reportInfo As DynARInfo
Dim value As System.String

value = instance.ExportGrid(reportInfo)
C#
public System.string ExportGrid(
   DynARInfo reportInfo
)
Delphi
public function ExportGrid(
    reportInfo: DynARInfo
): System.String;
JScript
public function ExportGrid(
   reportInfo : DynARInfo
) : System.String;
Managed Extensions for C++
public: System.string* ExportGrid(
   DynARInfo* reportInfo
)
C++/CLI
public:
System.String^ ExportGrid(
   DynARInfo^ reportInfo
)

Parameters

reportInfo

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members
Overload List


FindControl Method

[image]
Intersoft WebGrid Documentation
FindControl Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class : FindControl Method

Glossary Item Box

Overload List

Overload | Description
FindControl | (Inherited from ISNet.WebUI.ISNetControl)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members


FindControl(String) Method

[image]
Intersoft WebGrid Documentation
FindControl(String) Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class : FindControl(String) Method

id

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function FindControl( _
   ByVal id As System.String _
) As System.Web.UI.Control
Visual Basic (Usage) Copy Code
Dim instance As WebGrid
Dim id As System.String
Dim value As System.Web.UI.Control

value = instance.FindControl(id)
C#
public virtual System.Web.UI.Control FindControl(
   System.string id
)
Delphi
public function FindControl(
    id: System.String
): System.Web.UI.Control; virtual;
JScript
public function FindControl(
   id : System.String
) : System.Web.UI.Control;
Managed Extensions for C++
public: virtual System.Web.UI.Control* FindControl(
   System.string* id
)
C++/CLI
public:
virtual System.Web.UI.Control^ FindControl(
   System.String^ id
)

Parameters

id

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members


Focus Method

[image]
Intersoft WebGrid Documentation
Focus Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class : Focus Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Focus()
Visual Basic (Usage) Copy Code
Dim instance As WebGrid

instance.Focus()
C#
public virtual void Focus()
Delphi
public procedure Focus(); virtual;
JScript
public function Focus();
Managed Extensions for C++
public: virtual void Focus();
C++/CLI
public:
virtual void Focus();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members


ForceDisableXmlCompression Method

[image]
Intersoft WebGrid Documentation
ForceDisableXmlCompression Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class : ForceDisableXmlCompression Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub ForceDisableXmlCompression()
Visual Basic (Usage) Copy Code
Dim instance As WebGrid

instance.ForceDisableXmlCompression()
C#
public void ForceDisableXmlCompression()
Delphi
public procedure ForceDisableXmlCompression();
JScript
public function ForceDisableXmlCompression();
Managed Extensions for C++
public: void ForceDisableXmlCompression();
C++/CLI
public:
void ForceDisableXmlCompression();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members


GetAllCustomEditors Method

[image]
Intersoft WebGrid Documentation
GetAllCustomEditors Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class : GetAllCustomEditors Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetAllCustomEditors() As WebGridCustomEditorCollection
Visual Basic (Usage) Copy Code
Dim instance As WebGrid
Dim value As WebGridCustomEditorCollection

value = instance.GetAllCustomEditors()
C#
public WebGridCustomEditorCollection GetAllCustomEditors()
Delphi
public function GetAllCustomEditors(): WebGridCustomEditorCollection;
JScript
public function GetAllCustomEditors() : WebGridCustomEditorCollection;
Managed Extensions for C++
public: WebGridCustomEditorCollection* GetAllCustomEditors();
C++/CLI
public:
WebGridCustomEditorCollection^ GetAllCustomEditors();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members


GetBatchUpdateExceptions Method

[image]
Intersoft WebGrid Documentation
GetBatchUpdateExceptions Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class : GetBatchUpdateExceptions Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetBatchUpdateExceptions() As System.Collections.Generic.List(Of WebGridBatchUpdateException)
Visual Basic (Usage) Copy Code
Dim instance As WebGrid
Dim value As System.Collections.Generic.List(Of WebGridBatchUpdateException)

value = instance.GetBatchUpdateExceptions()
C#
public System.Collections.Generic.List<WebGridBatchUpdateException> GetBatchUpdateExceptions()
Delphi
public function GetBatchUpdateExceptions(): System.Collections.Generic.List;
JScript
public function GetBatchUpdateExceptions() : System.Collections.Generic.List;
Managed Extensions for C++
public: System.Collections.Generic.List<WebGridBatchUpdateException*>* GetBatchUpdateExceptions();
C++/CLI
public:
System.Collections.Generic.List<WebGridBatchUpdateException^>^ GetBatchUpdateExceptions();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members


GetCachedDataSource Method

[image]
Intersoft WebGrid Documentation
GetCachedDataSource Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class : GetCachedDataSource Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetCachedDataSource() As System.Object
Visual Basic (Usage) Copy Code
Dim instance As WebGrid
Dim value As System.Object

value = instance.GetCachedDataSource()
C#
public System.object GetCachedDataSource()
Delphi
public function GetCachedDataSource(): System.TObject;
JScript
public function GetCachedDataSource() : System.Object;
Managed Extensions for C++
public: System.Object* GetCachedDataSource();
C++/CLI
public:
System.Object^ GetCachedDataSource();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members


GetChanges Method

[image]
Intersoft WebGrid Documentation
GetChanges Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class : GetChanges Method

Glossary Item Box

Overload List

Overload | Description
GetChanges() |
GetChanges(RowState) |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members


GetChanges() Method

[image]
Intersoft WebGrid Documentation
GetChanges() Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class > GetChanges Method : GetChanges() Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function GetChanges() As System.Collections.Generic.List(Of WebGridRowChanges)
Visual Basic (Usage) Copy Code
Dim instance As WebGrid
Dim value As System.Collections.Generic.List(Of WebGridRowChanges)

value = instance.GetChanges()
C#
public System.Collections.Generic.List<WebGridRowChanges> GetChanges()
Delphi
public function GetChanges(): System.Collections.Generic.List;
JScript
public function GetChanges() : System.Collections.Generic.List;
Managed Extensions for C++
public: System.Collections.Generic.List<WebGridRowChanges*>* GetChanges();
C++/CLI
public:
System.Collections.Generic.List<WebGridRowChanges^>^ GetChanges();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members
Overload List


GetChanges(RowState) Method

[image]
Intersoft WebGrid Documentation
GetChanges(RowState) Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class > GetChanges Method : GetChanges(RowState) Method

state

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function GetChanges( _
   ByVal state As RowState _
) As System.Collections.Generic.List(Of WebGridRowChanges)
Visual Basic (Usage) Copy Code
Dim instance As WebGrid
Dim state As RowState
Dim value As System.Collections.Generic.List(Of WebGridRowChanges)

value = instance.GetChanges(state)
C#
public System.Collections.Generic.List<WebGridRowChanges> GetChanges(
   RowState state
)
Delphi
public function GetChanges(
    state: RowState
): System.Collections.Generic.List;
JScript
public function GetChanges(
   state : RowState
) : System.Collections.Generic.List;
Managed Extensions for C++
public: System.Collections.Generic.List<WebGridRowChanges*>* GetChanges(
   RowState state
)
C++/CLI
public:
System.Collections.Generic.List<WebGridRowChanges^>^ GetChanges(
   RowState state
)

Parameters

state

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members
Overload List


GetClientAction Method

[image]
Intersoft WebGrid Documentation
GetClientAction Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class : GetClientAction Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetClientAction() As ISNet.WebUI.BaseClientSideAction
Visual Basic (Usage) Copy Code
Dim instance As WebGrid
Dim value As ISNet.WebUI.BaseClientSideAction

value = instance.GetClientAction()
C#
public ISNet.WebUI.BaseClientSideAction GetClientAction()
Delphi
public function GetClientAction(): ISNet.WebUI.BaseClientSideAction;
JScript
public function GetClientAction() : ISNet.WebUI.BaseClientSideAction;
Managed Extensions for C++
public: ISNet.WebUI.BaseClientSideAction* GetClientAction();
C++/CLI
public:
ISNet.WebUI.BaseClientSideAction^ GetClientAction();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members


GetCurrentControlLifeCycle Method

[image]
Intersoft WebGrid Documentation
GetCurrentControlLifeCycle Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class : GetCurrentControlLifeCycle Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetCurrentControlLifeCycle() As ISNet.WebUI.ControlLifeCycle
Visual Basic (Usage) Copy Code
Dim instance As WebGrid
Dim value As ISNet.WebUI.ControlLifeCycle

value = instance.GetCurrentControlLifeCycle()
C#
public ISNet.WebUI.ControlLifeCycle GetCurrentControlLifeCycle()
Delphi
public function GetCurrentControlLifeCycle(): ISNet.WebUI.ControlLifeCycle;
JScript
public function GetCurrentControlLifeCycle() : ISNet.WebUI.ControlLifeCycle;
Managed Extensions for C++
public: ISNet.WebUI.ControlLifeCycle GetCurrentControlLifeCycle();
C++/CLI
public:
ISNet.WebUI.ControlLifeCycle GetCurrentControlLifeCycle();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members


GetCurrentPageIndex Method

[image]
Intersoft WebGrid Documentation
GetCurrentPageIndex Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class : GetCurrentPageIndex Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetCurrentPageIndex() As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebGrid
Dim value As System.Integer

value = instance.GetCurrentPageIndex()
C#
public System.int GetCurrentPageIndex()
Delphi
public function GetCurrentPageIndex(): System.Integer;
JScript
public function GetCurrentPageIndex() : System.int;
Managed Extensions for C++
public: System.int GetCurrentPageIndex();
C++/CLI
public:
System.int GetCurrentPageIndex();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members


GetCurrentTheme Method

[image]
Intersoft WebGrid Documentation
GetCurrentTheme Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class : GetCurrentTheme Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetCurrentTheme() As ISNet.WebUI.ThemeInfo
Visual Basic (Usage) Copy Code
Dim instance As WebGrid
Dim value As ISNet.WebUI.ThemeInfo

value = instance.GetCurrentTheme()
C#
public ISNet.WebUI.ThemeInfo GetCurrentTheme()
Delphi
public function GetCurrentTheme(): ISNet.WebUI.ThemeInfo;
JScript
public function GetCurrentTheme() : ISNet.WebUI.ThemeInfo;
Managed Extensions for C++
public: ISNet.WebUI.ThemeInfo* GetCurrentTheme();
C++/CLI
public:
ISNet.WebUI.ThemeInfo^ GetCurrentTheme();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members


GetCustomEditorByName Method

[image]
Intersoft WebGrid Documentation
GetCustomEditorByName Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class : GetCustomEditorByName Method

name

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetCustomEditorByName( _
   ByVal name As System.String _
) As WebGridCustomEditor
Visual Basic (Usage) Copy Code
Dim instance As WebGrid
Dim name As System.String
Dim value As WebGridCustomEditor

value = instance.GetCustomEditorByName(name)
C#
public WebGridCustomEditor GetCustomEditorByName(
   System.string name
)
Delphi
public function GetCustomEditorByName(
    name: System.String
): WebGridCustomEditor;
JScript
public function GetCustomEditorByName(
   name : System.String
) : WebGridCustomEditor;
Managed Extensions for C++
public: WebGridCustomEditor* GetCustomEditorByName(
   System.string* name
)
C++/CLI
public:
WebGridCustomEditor^ GetCustomEditorByName(
   System.String^ name
)

Parameters

name

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members


GetDefaultReportInfo Method

[image]
Intersoft WebGrid Documentation
GetDefaultReportInfo Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class : GetDefaultReportInfo Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetDefaultReportInfo() As DynARInfo
Visual Basic (Usage) Copy Code
Dim instance As WebGrid
Dim value As DynARInfo

value = instance.GetDefaultReportInfo()
C#
public DynARInfo GetDefaultReportInfo()
Delphi
public function GetDefaultReportInfo(): DynARInfo;
JScript
public function GetDefaultReportInfo() : DynARInfo;
Managed Extensions for C++
public: DynARInfo* GetDefaultReportInfo();
C++/CLI
public:
DynARInfo^ GetDefaultReportInfo();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members


GetDesignerLevelCustomEditors Method

[image]
Intersoft WebGrid Documentation
GetDesignerLevelCustomEditors Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class : GetDesignerLevelCustomEditors Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetDesignerLevelCustomEditors() As WebGridCustomEditorCollection
Visual Basic (Usage) Copy Code
Dim instance As WebGrid
Dim value As WebGridCustomEditorCollection

value = instance.GetDesignerLevelCustomEditors()
C#
public WebGridCustomEditorCollection GetDesignerLevelCustomEditors()
Delphi
public function GetDesignerLevelCustomEditors(): WebGridCustomEditorCollection;
JScript
public function GetDesignerLevelCustomEditors() : WebGridCustomEditorCollection;
Managed Extensions for C++
public: WebGridCustomEditorCollection* GetDesignerLevelCustomEditors();
C++/CLI
public:
WebGridCustomEditorCollection^ GetDesignerLevelCustomEditors();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members


GetFrameworkDataFolder Method

[image]
Intersoft WebGrid Documentation
GetFrameworkDataFolder Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class : GetFrameworkDataFolder Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetFrameworkDataFolder() As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebGrid
Dim value As System.String

value = instance.GetFrameworkDataFolder()
C#
public System.string GetFrameworkDataFolder()
Delphi
public function GetFrameworkDataFolder(): System.String;
JScript
public function GetFrameworkDataFolder() : System.String;
Managed Extensions for C++
public: System.string* GetFrameworkDataFolder();
C++/CLI
public:
System.String^ GetFrameworkDataFolder();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members


GetFrameworkFolder Method

[image]
Intersoft WebGrid Documentation
GetFrameworkFolder Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class : GetFrameworkFolder Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetFrameworkFolder() As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebGrid
Dim value As System.String

value = instance.GetFrameworkFolder()
C#
public System.string GetFrameworkFolder()
Delphi
public function GetFrameworkFolder(): System.String;
JScript
public function GetFrameworkFolder() : System.String;
Managed Extensions for C++
public: System.string* GetFrameworkFolder();
C++/CLI
public:
System.String^ GetFrameworkFolder();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members


GetFrameworkVersion Method

[image]
Intersoft WebGrid Documentation
GetFrameworkVersion Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class : GetFrameworkVersion Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetFrameworkVersion() As System.Version
Visual Basic (Usage) Copy Code
Dim instance As WebGrid
Dim value As System.Version

value = instance.GetFrameworkVersion()
C#
public System.Version GetFrameworkVersion()
Delphi
public function GetFrameworkVersion(): System.Version;
JScript
public function GetFrameworkVersion() : System.Version;
Managed Extensions for C++
public: System.Version* GetFrameworkVersion();
C++/CLI
public:
System.Version^ GetFrameworkVersion();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members


GetGridLevelCustomEditors Method

[image]
Intersoft WebGrid Documentation
GetGridLevelCustomEditors Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class : GetGridLevelCustomEditors Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetGridLevelCustomEditors() As WebGridCustomEditorCollection
Visual Basic (Usage) Copy Code
Dim instance As WebGrid
Dim value As WebGridCustomEditorCollection

value = instance.GetGridLevelCustomEditors()
C#
public WebGridCustomEditorCollection GetGridLevelCustomEditors()
Delphi
public function GetGridLevelCustomEditors(): WebGridCustomEditorCollection;
JScript
public function GetGridLevelCustomEditors() : WebGridCustomEditorCollection;
Managed Extensions for C++
public: WebGridCustomEditorCollection* GetGridLevelCustomEditors();
C++/CLI
public:
WebGridCustomEditorCollection^ GetGridLevelCustomEditors();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members


GetInstalledCustomEditors Method

[image]
Intersoft WebGrid Documentation
GetInstalledCustomEditors Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class : GetInstalledCustomEditors Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetInstalledCustomEditors() As WebGridCustomEditorCollection
Visual Basic (Usage) Copy Code
Dim instance As WebGrid
Dim value As WebGridCustomEditorCollection

value = instance.GetInstalledCustomEditors()
C#
public WebGridCustomEditorCollection GetInstalledCustomEditors()
Delphi
public function GetInstalledCustomEditors(): WebGridCustomEditorCollection;
JScript
public function GetInstalledCustomEditors() : WebGridCustomEditorCollection;
Managed Extensions for C++
public: WebGridCustomEditorCollection* GetInstalledCustomEditors();
C++/CLI
public:
WebGridCustomEditorCollection^ GetInstalledCustomEditors();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members


GetIntersoftFolder Method

[image]
Intersoft WebGrid Documentation
GetIntersoftFolder Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class : GetIntersoftFolder Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetIntersoftFolder() As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebGrid
Dim value As System.String

value = instance.GetIntersoftFolder()
C#
public System.string GetIntersoftFolder()
Delphi
public function GetIntersoftFolder(): System.String;
JScript
public function GetIntersoftFolder() : System.String;
Managed Extensions for C++
public: System.string* GetIntersoftFolder();
C++/CLI
public:
System.String^ GetIntersoftFolder();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members


GetLayoutFolder Method

[image]
Intersoft WebGrid Documentation
GetLayoutFolder Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class : GetLayoutFolder Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetLayoutFolder() As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebGrid
Dim value As System.String

value = instance.GetLayoutFolder()
C#
public System.string GetLayoutFolder()
Delphi
public function GetLayoutFolder(): System.String;
JScript
public function GetLayoutFolder() : System.String;
Managed Extensions for C++
public: System.string* GetLayoutFolder();
C++/CLI
public:
System.String^ GetLayoutFolder();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members


GetObjectData Method

[image]
Intersoft WebGrid Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebGrid
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure GetObjectData(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
); override;
JScript
public override function GetObjectData(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void GetObjectData(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
) override
C++/CLI
public:
void GetObjectData(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
) override

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members


GetPostedXMLData Method

[image]
Intersoft WebGrid Documentation
GetPostedXMLData Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class : GetPostedXMLData Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetPostedXMLData() As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebGrid
Dim value As System.String

value = instance.GetPostedXMLData()
C#
public System.string GetPostedXMLData()
Delphi
public function GetPostedXMLData(): System.String;
JScript
public function GetPostedXMLData() : System.String;
Managed Extensions for C++
public: System.string* GetPostedXMLData();
C++/CLI
public:
System.String^ GetPostedXMLData();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members


GetProductInfoKey Method

[image]
Intersoft WebGrid Documentation
GetProductInfoKey Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class : GetProductInfoKey Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetProductInfoKey() As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebGrid
Dim value As System.String

value = instance.GetProductInfoKey()
C#
public System.string GetProductInfoKey()
Delphi
public function GetProductInfoKey(): System.String;
JScript
public function GetProductInfoKey() : System.String;
Managed Extensions for C++
public: System.string* GetProductInfoKey();
C++/CLI
public:
System.String^ GetProductInfoKey();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members


GetProductSimpleName Method

[image]
Intersoft WebGrid Documentation
GetProductSimpleName Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class : GetProductSimpleName Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetProductSimpleName() As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebGrid
Dim value As System.String

value = instance.GetProductSimpleName()
C#
public System.string GetProductSimpleName()
Delphi
public function GetProductSimpleName(): System.String;
JScript
public function GetProductSimpleName() : System.String;
Managed Extensions for C++
public: System.string* GetProductSimpleName();
C++/CLI
public:
System.String^ GetProductSimpleName();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members


GetPropertyValue Method

[image]
Intersoft WebGrid Documentation
GetPropertyValue Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class : GetPropertyValue Method

defValue
propValue
webConfigKey

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetPropertyValue( _
   ByVal defValue As System.String, _
   ByVal propValue As System.String, _
   ByVal webConfigKey As System.String _
) As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebGrid
Dim defValue As System.String
Dim propValue As System.String
Dim webConfigKey As System.String
Dim value As System.String

value = instance.GetPropertyValue(defValue, propValue, webConfigKey)
C#
public System.string GetPropertyValue(
   System.string defValue,
   System.string propValue,
   System.string webConfigKey
)
Delphi
public function GetPropertyValue(
    defValue: System.String;
    propValue: System.String;
    webConfigKey: System.String
): System.String;
JScript
public function GetPropertyValue(
   defValue : System.String,
   propValue : System.String,
   webConfigKey : System.String
) : System.String;
Managed Extensions for C++
public: System.string* GetPropertyValue(
   System.string* defValue,
   System.string* propValue,
   System.string* webConfigKey
)
C++/CLI
public:
System.String^ GetPropertyValue(
   System.String^ defValue,
   System.String^ propValue,
   System.String^ webConfigKey
)

Parameters

defValue
propValue
webConfigKey

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members


GetResourceStream Method

[image]
Intersoft WebGrid Documentation
GetResourceStream Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class : GetResourceStream Method

resourceUrl

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetResourceStream( _
   ByVal resourceUrl As System.String _
) As System.IO.Stream
Visual Basic (Usage) Copy Code
Dim instance As WebGrid
Dim resourceUrl As System.String
Dim value As System.IO.Stream

value = instance.GetResourceStream(resourceUrl)
C#
public System.IO.Stream GetResourceStream(
   System.string resourceUrl
)
Delphi
public function GetResourceStream(
    resourceUrl: System.String
): System.IO.Stream;
JScript
public function GetResourceStream(
   resourceUrl : System.String
) : System.IO.Stream;
Managed Extensions for C++
public: System.IO.Stream* GetResourceStream(
   System.string* resourceUrl
)
C++/CLI
public:
System.IO.Stream^ GetResourceStream(
   System.String^ resourceUrl
)

Parameters

resourceUrl

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members


GetRouteUrl Method

[image]
Intersoft WebGrid Documentation
GetRouteUrl Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class : GetRouteUrl Method

Glossary Item Box

Overload List

Overload | Description
GetRouteUrl(Object) | (Inherited from System.Web.UI.Control)
GetRouteUrl(String,Object) | (Inherited from System.Web.UI.Control)
GetRouteUrl(RouteValueDictionary) | (Inherited from System.Web.UI.Control)
GetRouteUrl(String,RouteValueDictionary) | (Inherited from System.Web.UI.Control)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members


GetRouteUrl(Object) Method

[image]
Intersoft WebGrid Documentation
GetRouteUrl(Object) Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class > GetRouteUrl Method : GetRouteUrl(Object) Method

routeParameters

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function GetRouteUrl( _
   ByVal routeParameters As System.Object _
) As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebGrid
Dim routeParameters As System.Object
Dim value As System.String

value = instance.GetRouteUrl(routeParameters)
C#
public System.string GetRouteUrl(
   System.object routeParameters
)
Delphi
public function GetRouteUrl(
    routeParameters: System.TObject
): System.String;
JScript
public function GetRouteUrl(
   routeParameters : System.Object
) : System.String;
Managed Extensions for C++
public: System.string* GetRouteUrl(
   System.Object* routeParameters
)
C++/CLI
public:
System.String^ GetRouteUrl(
   System.Object^ routeParameters
)

Parameters

routeParameters

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members
Overload List


GetRouteUrl(String,Object) Method

[image]
Intersoft WebGrid Documentation
GetRouteUrl(String,Object) Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class > GetRouteUrl Method : GetRouteUrl(String,Object) Method

routeName
routeParameters

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function GetRouteUrl( _
   ByVal routeName As System.String, _
   ByVal routeParameters As System.Object _
) As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebGrid
Dim routeName As System.String
Dim routeParameters As System.Object
Dim value As System.String

value = instance.GetRouteUrl(routeName, routeParameters)
C#
public System.string GetRouteUrl(
   System.string routeName,
   System.object routeParameters
)
Delphi
public function GetRouteUrl(
    routeName: System.String;
    routeParameters: System.TObject
): System.String;
JScript
public function GetRouteUrl(
   routeName : System.String,
   routeParameters : System.Object
) : System.String;
Managed Extensions for C++
public: System.string* GetRouteUrl(
   System.string* routeName,
   System.Object* routeParameters
)
C++/CLI
public:
System.String^ GetRouteUrl(
   System.String^ routeName,
   System.Object^ routeParameters
)

Parameters

routeName
routeParameters

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members
Overload List


GetRouteUrl(RouteValueDictionary) Method

[image]
Intersoft WebGrid Documentation
GetRouteUrl(RouteValueDictionary) Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class > GetRouteUrl Method : GetRouteUrl(RouteValueDictionary) Method

routeParameters

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")>
Public Overloads Function GetRouteUrl( _
   ByVal routeParameters As System.Web.Routing.RouteValueDictionary _
) As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebGrid
Dim routeParameters As System.Web.Routing.RouteValueDictionary
Dim value As System.String

value = instance.GetRouteUrl(routeParameters)
C#
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public System.string GetRouteUrl(
   System.Web.Routing.RouteValueDictionary routeParameters
)
Delphi
public function GetRouteUrl(
    routeParameters: System.Web.Routing.RouteValueDictionary
): System.String;
JScript
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")
public function GetRouteUrl(
   routeParameters : System.Web.Routing.RouteValueDictionary
) : System.String;
Managed Extensions for C++
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public: System.string* GetRouteUrl(
   System.Web.Routing.RouteValueDictionary* routeParameters
)
C++/CLI
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public:
System.String^ GetRouteUrl(
   System.Web.Routing.RouteValueDictionary^ routeParameters
)

Parameters

routeParameters

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members
Overload List


GetRouteUrl(String,RouteValueDictionary) Method

[image]
Intersoft WebGrid Documentation
GetRouteUrl(String,RouteValueDictionary) Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class > GetRouteUrl Method : GetRouteUrl(String,RouteValueDictionary) Method

routeName
routeParameters

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function GetRouteUrl( _
   ByVal routeName As System.String, _
   ByVal routeParameters As System.Web.Routing.RouteValueDictionary _
) As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebGrid
Dim routeName As System.String
Dim routeParameters As System.Web.Routing.RouteValueDictionary
Dim value As System.String

value = instance.GetRouteUrl(routeName, routeParameters)
C#
public System.string GetRouteUrl(
   System.string routeName,
   System.Web.Routing.RouteValueDictionary routeParameters
)
Delphi
public function GetRouteUrl(
    routeName: System.String;
    routeParameters: System.Web.Routing.RouteValueDictionary
): System.String;
JScript
public function GetRouteUrl(
   routeName : System.String,
   routeParameters : System.Web.Routing.RouteValueDictionary
) : System.String;
Managed Extensions for C++
public: System.string* GetRouteUrl(
   System.string* routeName,
   System.Web.Routing.RouteValueDictionary* routeParameters
)
C++/CLI
public:
System.String^ GetRouteUrl(
   System.String^ routeName,
   System.Web.Routing.RouteValueDictionary^ routeParameters
)

Parameters

routeName
routeParameters

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members
Overload List


GetTableByName Method

[image]
Intersoft WebGrid Documentation
GetTableByName Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class : GetTableByName Method

name

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetTableByName( _
   ByVal name As System.String _
) As WebGridTable
Visual Basic (Usage) Copy Code
Dim instance As WebGrid
Dim name As System.String
Dim value As WebGridTable

value = instance.GetTableByName(name)
C#
public WebGridTable GetTableByName(
   System.string name
)
Delphi
public function GetTableByName(
    name: System.String
): WebGridTable;
JScript
public function GetTableByName(
   name : System.String
) : WebGridTable;
Managed Extensions for C++
public: WebGridTable* GetTableByName(
   System.string* name
)
C++/CLI
public:
WebGridTable^ GetTableByName(
   System.String^ name
)

Parameters

name

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members


GetTotalPages Method

[image]
Intersoft WebGrid Documentation
GetTotalPages Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class : GetTotalPages Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetTotalPages() As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebGrid
Dim value As System.Integer

value = instance.GetTotalPages()
C#
public System.int GetTotalPages()
Delphi
public function GetTotalPages(): System.Integer;
JScript
public function GetTotalPages() : System.int;
Managed Extensions for C++
public: System.int GetTotalPages();
C++/CLI
public:
System.int GetTotalPages();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members


GetUniqueIDRelativeTo Method

[image]
Intersoft WebGrid Documentation
GetUniqueIDRelativeTo Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class : GetUniqueIDRelativeTo Method

control

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetUniqueIDRelativeTo( _
   ByVal control As System.Web.UI.Control _
) As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebGrid
Dim control As System.Web.UI.Control
Dim value As System.String

value = instance.GetUniqueIDRelativeTo(control)
C#
public System.string GetUniqueIDRelativeTo(
   System.Web.UI.Control control
)
Delphi
public function GetUniqueIDRelativeTo(
    control: System.Web.UI.Control
): System.String;
JScript
public function GetUniqueIDRelativeTo(
   control : System.Web.UI.Control
) : System.String;
Managed Extensions for C++
public: System.string* GetUniqueIDRelativeTo(
   System.Web.UI.Control* control
)
C++/CLI
public:
System.String^ GetUniqueIDRelativeTo(
   System.Web.UI.Control^ control
)

Parameters

control

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members


GetUtilizedCustomEditors Method

[image]
Intersoft WebGrid Documentation
GetUtilizedCustomEditors Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class : GetUtilizedCustomEditors Method

table

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetUtilizedCustomEditors( _
   ByVal table As WebGridTable _
) As WebGridCustomEditorCollection
Visual Basic (Usage) Copy Code
Dim instance As WebGrid
Dim table As WebGridTable
Dim value As WebGridCustomEditorCollection

value = instance.GetUtilizedCustomEditors(table)
C#
public WebGridCustomEditorCollection GetUtilizedCustomEditors(
   WebGridTable table
)
Delphi
public function GetUtilizedCustomEditors(
    table: WebGridTable
): WebGridCustomEditorCollection;
JScript
public function GetUtilizedCustomEditors(
   table : WebGridTable
) : WebGridCustomEditorCollection;
Managed Extensions for C++
public: WebGridCustomEditorCollection* GetUtilizedCustomEditors(
   WebGridTable* table
)
C++/CLI
public:
WebGridCustomEditorCollection^ GetUtilizedCustomEditors(
   WebGridTable^ table
)

Parameters

table

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members


GetXMLCultureInfo Method

[image]
Intersoft WebGrid Documentation
GetXMLCultureInfo Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class : GetXMLCultureInfo Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Function GetXMLCultureInfo() As System.Object
Visual Basic (Usage) Copy Code
Dim instance As WebGrid
Dim value As System.Object

value = instance.GetXMLCultureInfo()
C#
public override System.object GetXMLCultureInfo()
Delphi
public function GetXMLCultureInfo(): System.TObject; override;
JScript
public override function GetXMLCultureInfo() : System.Object;
Managed Extensions for C++
public: System.Object* GetXMLCultureInfo(); override
C++/CLI
public:
System.Object^ GetXMLCultureInfo(); override

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members


HasControls Method

[image]
Intersoft WebGrid Documentation
HasControls Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class : HasControls Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function HasControls() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebGrid
Dim value As System.Boolean

value = instance.HasControls()
C#
public virtual System.bool HasControls()
Delphi
public function HasControls(): System.Boolean; virtual;
JScript
public function HasControls() : System.boolean;
Managed Extensions for C++
public: virtual System.bool HasControls();
C++/CLI
public:
virtual System.bool HasControls();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members


IsAtlasCallback Method

[image]
Intersoft WebGrid Documentation
IsAtlasCallback Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class : IsAtlasCallback Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsAtlasCallback() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebGrid
Dim value As System.Boolean

value = instance.IsAtlasCallback()
C#
public System.bool IsAtlasCallback()
Delphi
public function IsAtlasCallback(): System.Boolean;
JScript
public function IsAtlasCallback() : System.boolean;
Managed Extensions for C++
public: System.bool IsAtlasCallback();
C++/CLI
public:
System.bool IsAtlasCallback();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members


IsBetaRelease Method

[image]
Intersoft WebGrid Documentation
IsBetaRelease Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class : IsBetaRelease Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsBetaRelease() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebGrid
Dim value As System.Boolean

value = instance.IsBetaRelease()
C#
public System.bool IsBetaRelease()
Delphi
public function IsBetaRelease(): System.Boolean;
JScript
public function IsBetaRelease() : System.boolean;
Managed Extensions for C++
public: System.bool IsBetaRelease();
C++/CLI
public:
System.bool IsBetaRelease();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members


IsChromeBrowser Method

[image]
Intersoft WebGrid Documentation
IsChromeBrowser Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class : IsChromeBrowser Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsChromeBrowser() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebGrid
Dim value As System.Boolean

value = instance.IsChromeBrowser()
C#
public System.bool IsChromeBrowser()
Delphi
public function IsChromeBrowser(): System.Boolean;
JScript
public function IsChromeBrowser() : System.boolean;
Managed Extensions for C++
public: System.bool IsChromeBrowser();
C++/CLI
public:
System.bool IsChromeBrowser();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members


IsDataCached Method

[image]
Intersoft WebGrid Documentation
IsDataCached Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class : IsDataCached Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsDataCached() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebGrid
Dim value As System.Boolean

value = instance.IsDataCached()
C#
public System.bool IsDataCached()
Delphi
public function IsDataCached(): System.Boolean;
JScript
public function IsDataCached() : System.boolean;
Managed Extensions for C++
public: System.bool IsDataCached();
C++/CLI
public:
System.bool IsDataCached();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members


IsEmpty Method

[image]
Intersoft WebGrid Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebGrid
Dim value As System.Boolean

value = instance.IsEmpty()
C#
public virtual System.bool IsEmpty()
Delphi
public function IsEmpty(): System.Boolean; virtual;
JScript
public function IsEmpty() : System.boolean;
Managed Extensions for C++
public: virtual System.bool IsEmpty();
C++/CLI
public:
virtual System.bool IsEmpty();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members


IsFlyPostBackControl Method

[image]
Intersoft WebGrid Documentation
IsFlyPostBackControl Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class : IsFlyPostBackControl Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsFlyPostBackControl() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebGrid
Dim value As System.Boolean

value = instance.IsFlyPostBackControl()
C#
public virtual System.bool IsFlyPostBackControl()
Delphi
public function IsFlyPostBackControl(): System.Boolean; virtual;
JScript
public function IsFlyPostBackControl() : System.boolean;
Managed Extensions for C++
public: virtual System.bool IsFlyPostBackControl();
C++/CLI
public:
virtual System.bool IsFlyPostBackControl();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members


IsFlyPostBackRequest Method

[image]
Intersoft WebGrid Documentation
IsFlyPostBackRequest Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class : IsFlyPostBackRequest Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsFlyPostBackRequest() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebGrid
Dim value As System.Boolean

value = instance.IsFlyPostBackRequest()
C#
public virtual System.bool IsFlyPostBackRequest()
Delphi
public function IsFlyPostBackRequest(): System.Boolean; virtual;
JScript
public function IsFlyPostBackRequest() : System.boolean;
Managed Extensions for C++
public: virtual System.bool IsFlyPostBackRequest();
C++/CLI
public:
virtual System.bool IsFlyPostBackRequest();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members


IsGeckoBasedBrowser Method

[image]
Intersoft WebGrid Documentation
IsGeckoBasedBrowser Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class : IsGeckoBasedBrowser Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsGeckoBasedBrowser() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebGrid
Dim value As System.Boolean

value = instance.IsGeckoBasedBrowser()
C#
public System.bool IsGeckoBasedBrowser()
Delphi
public function IsGeckoBasedBrowser(): System.Boolean;
JScript
public function IsGeckoBasedBrowser() : System.boolean;
Managed Extensions for C++
public: System.bool IsGeckoBasedBrowser();
C++/CLI
public:
System.bool IsGeckoBasedBrowser();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members


IsGeckoVersion18 Method

[image]
Intersoft WebGrid Documentation
IsGeckoVersion18 Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class : IsGeckoVersion18 Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsGeckoVersion18() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebGrid
Dim value As System.Boolean

value = instance.IsGeckoVersion18()
C#
public System.bool IsGeckoVersion18()
Delphi
public function IsGeckoVersion18(): System.Boolean;
JScript
public function IsGeckoVersion18() : System.boolean;
Managed Extensions for C++
public: System.bool IsGeckoVersion18();
C++/CLI
public:
System.bool IsGeckoVersion18();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members


IsInDesignMode Method

[image]
Intersoft WebGrid Documentation
IsInDesignMode Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class : IsInDesignMode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsInDesignMode() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebGrid
Dim value As System.Boolean

value = instance.IsInDesignMode()
C#
public System.bool IsInDesignMode()
Delphi
public function IsInDesignMode(): System.Boolean;
JScript
public function IsInDesignMode() : System.boolean;
Managed Extensions for C++
public: System.bool IsInDesignMode();
C++/CLI
public:
System.bool IsInDesignMode();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members


IsInternetExplorer11Browser Method

[image]
Intersoft WebGrid Documentation
IsInternetExplorer11Browser Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class : IsInternetExplorer11Browser Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsInternetExplorer11Browser() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebGrid
Dim value As System.Boolean

value = instance.IsInternetExplorer11Browser()
C#
public System.bool IsInternetExplorer11Browser()
Delphi
public function IsInternetExplorer11Browser(): System.Boolean;
JScript
public function IsInternetExplorer11Browser() : System.boolean;
Managed Extensions for C++
public: System.bool IsInternetExplorer11Browser();
C++/CLI
public:
System.bool IsInternetExplorer11Browser();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members


IsInternetExplorer8Browser Method

[image]
Intersoft WebGrid Documentation
IsInternetExplorer8Browser Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class : IsInternetExplorer8Browser Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsInternetExplorer8Browser() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebGrid
Dim value As System.Boolean

value = instance.IsInternetExplorer8Browser()
C#
public System.bool IsInternetExplorer8Browser()
Delphi
public function IsInternetExplorer8Browser(): System.Boolean;
JScript
public function IsInternetExplorer8Browser() : System.boolean;
Managed Extensions for C++
public: System.bool IsInternetExplorer8Browser();
C++/CLI
public:
System.bool IsInternetExplorer8Browser();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members


IsInternetExplorerBrowser Method

[image]
Intersoft WebGrid Documentation
IsInternetExplorerBrowser Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class : IsInternetExplorerBrowser Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsInternetExplorerBrowser() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebGrid
Dim value As System.Boolean

value = instance.IsInternetExplorerBrowser()
C#
public System.bool IsInternetExplorerBrowser()
Delphi
public function IsInternetExplorerBrowser(): System.Boolean;
JScript
public function IsInternetExplorerBrowser() : System.boolean;
Managed Extensions for C++
public: System.bool IsInternetExplorerBrowser();
C++/CLI
public:
System.bool IsInternetExplorerBrowser();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members


IsKeyValuesEqual Method

[image]
Intersoft WebGrid Documentation
IsKeyValuesEqual Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class : IsKeyValuesEqual Method

keyValues1
keyValues2

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsKeyValuesEqual( _
   ByVal keyValues1 As System.Collections.ArrayList, _
   ByVal keyValues2 As System.Collections.ArrayList _
) As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebGrid
Dim keyValues1 As System.Collections.ArrayList
Dim keyValues2 As System.Collections.ArrayList
Dim value As System.Boolean

value = instance.IsKeyValuesEqual(keyValues1, keyValues2)
C#
public System.bool IsKeyValuesEqual(
   System.Collections.ArrayList keyValues1,
   System.Collections.ArrayList keyValues2
)
Delphi
public function IsKeyValuesEqual(
    keyValues1: System.Collections.ArrayList;
    keyValues2: System.Collections.ArrayList
): System.Boolean;
JScript
public function IsKeyValuesEqual(
   keyValues1 : System.Collections.ArrayList,
   keyValues2 : System.Collections.ArrayList
) : System.boolean;
Managed Extensions for C++
public: System.bool IsKeyValuesEqual(
   System.Collections.ArrayList* keyValues1,
   System.Collections.ArrayList* keyValues2
)
C++/CLI
public:
System.bool IsKeyValuesEqual(
   System.Collections.ArrayList^ keyValues1,
   System.Collections.ArrayList^ keyValues2
)

Parameters

keyValues1
keyValues2

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members


IsOperaBrowser Method

[image]
Intersoft WebGrid Documentation
IsOperaBrowser Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class : IsOperaBrowser Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsOperaBrowser() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebGrid
Dim value As System.Boolean

value = instance.IsOperaBrowser()
C#
public System.bool IsOperaBrowser()
Delphi
public function IsOperaBrowser(): System.Boolean;
JScript
public function IsOperaBrowser() : System.boolean;
Managed Extensions for C++
public: System.bool IsOperaBrowser();
C++/CLI
public:
System.bool IsOperaBrowser();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members


IsSafariBrowser Method

[image]
Intersoft WebGrid Documentation
IsSafariBrowser Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class : IsSafariBrowser Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsSafariBrowser() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebGrid
Dim value As System.Boolean

value = instance.IsSafariBrowser()
C#
public System.bool IsSafariBrowser()
Delphi
public function IsSafariBrowser(): System.Boolean;
JScript
public function IsSafariBrowser() : System.boolean;
Managed Extensions for C++
public: System.bool IsSafariBrowser();
C++/CLI
public:
System.bool IsSafariBrowser();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members


IsValidC1DataSource Method

[image]
Intersoft WebGrid Documentation
IsValidC1DataSource Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class : IsValidC1DataSource Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsValidC1DataSource() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebGrid
Dim value As System.Boolean

value = instance.IsValidC1DataSource()
C#
public System.bool IsValidC1DataSource()
Delphi
public function IsValidC1DataSource(): System.Boolean;
JScript
public function IsValidC1DataSource() : System.boolean;
Managed Extensions for C++
public: System.bool IsValidC1DataSource();
C++/CLI
public:
System.bool IsValidC1DataSource();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members


IsW3CStandardBrowser Method

[image]
Intersoft WebGrid Documentation
IsW3CStandardBrowser Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class : IsW3CStandardBrowser Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsW3CStandardBrowser() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebGrid
Dim value As System.Boolean

value = instance.IsW3CStandardBrowser()
C#
public System.bool IsW3CStandardBrowser()
Delphi
public function IsW3CStandardBrowser(): System.Boolean;
JScript
public function IsW3CStandardBrowser() : System.boolean;
Managed Extensions for C++
public: System.bool IsW3CStandardBrowser();
C++/CLI
public:
System.bool IsW3CStandardBrowser();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members


LoadChartFromXml Method

[image]
Intersoft WebGrid Documentation
LoadChartFromXml Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class : LoadChartFromXml Method

Glossary Item Box

Overload List

Overload | Description
LoadChartFromXml(String) |
LoadChartFromXml(XmlDocument) |
LoadChartFromXml(Stream) |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members


LoadChartFromXml(String) Method

[image]
Intersoft WebGrid Documentation
LoadChartFromXml(String) Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class > LoadChartFromXml Method : LoadChartFromXml(String) Method

fileName

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Sub LoadChartFromXml( _
   ByVal fileName As System.String _
)
Visual Basic (Usage) Copy Code
Dim instance As WebGrid
Dim fileName As System.String

instance.LoadChartFromXml(fileName)
C#
public void LoadChartFromXml(
   System.string fileName
)
Delphi
public procedure LoadChartFromXml(
    fileName: System.String
);
JScript
public function LoadChartFromXml(
   fileName : System.String
);
Managed Extensions for C++
public: void LoadChartFromXml(
   System.string* fileName
)
C++/CLI
public:
void LoadChartFromXml(
   System.String^ fileName
)

Parameters

fileName

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members
Overload List


LoadChartFromXml(XmlDocument) Method

[image]
Intersoft WebGrid Documentation
LoadChartFromXml(XmlDocument) Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class > LoadChartFromXml Method : LoadChartFromXml(XmlDocument) Method

document

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Sub LoadChartFromXml( _
   ByVal document As System.Xml.XmlDocument _
)
Visual Basic (Usage) Copy Code
Dim instance As WebGrid
Dim document As System.Xml.XmlDocument

instance.LoadChartFromXml(document)
C#
public void LoadChartFromXml(
   System.Xml.XmlDocument document
)
Delphi
public procedure LoadChartFromXml(
    document: System.Xml.XmlDocument
);
JScript
public function LoadChartFromXml(
   document : System.Xml.XmlDocument
);
Managed Extensions for C++
public: void LoadChartFromXml(
   System.Xml.XmlDocument* document
)
C++/CLI
public:
void LoadChartFromXml(
   System.Xml.XmlDocument^ document
)

Parameters

document

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members
Overload List


LoadChartFromXml(Stream) Method

[image]
Intersoft WebGrid Documentation
LoadChartFromXml(Stream) Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class > LoadChartFromXml Method : LoadChartFromXml(Stream) Method

stream

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Sub LoadChartFromXml( _
   ByVal stream As System.IO.Stream _
)
Visual Basic (Usage) Copy Code
Dim instance As WebGrid
Dim stream As System.IO.Stream

instance.LoadChartFromXml(stream)
C#
public void LoadChartFromXml(
   System.IO.Stream stream
)
Delphi
public procedure LoadChartFromXml(
    stream: System.IO.Stream
);
JScript
public function LoadChartFromXml(
   stream : System.IO.Stream
);
Managed Extensions for C++
public: void LoadChartFromXml(
   System.IO.Stream* stream
)
C++/CLI
public:
void LoadChartFromXml(
   System.IO.Stream^ stream
)

Parameters

stream

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members
Overload List


LoadLayout Method

[image]
Intersoft WebGrid Documentation
LoadLayout Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class : LoadLayout Method

Glossary Item Box

Overload List

Overload | Description
LoadLayout(String) |
LoadLayout(Stream) |
LoadLayout(LayoutInfo) | (Inherited from ISNet.WebUI.ISNetControl)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members


LoadLayout(String) Method

[image]
Intersoft WebGrid Documentation
LoadLayout(String) Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class > LoadLayout Method : LoadLayout(String) Method

fileName

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Sub LoadLayout( _
   ByVal fileName As System.String _
)
Visual Basic (Usage) Copy Code
Dim instance As WebGrid
Dim fileName As System.String

instance.LoadLayout(fileName)
C#
public void LoadLayout(
   System.string fileName
)
Delphi
public procedure LoadLayout(
    fileName: System.String
);
JScript
public function LoadLayout(
   fileName : System.String
);
Managed Extensions for C++
public: void LoadLayout(
   System.string* fileName
)
C++/CLI
public:
void LoadLayout(
   System.String^ fileName
)

Parameters

fileName

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members
Overload List


LoadLayout(Stream) Method

[image]
Intersoft WebGrid Documentation
LoadLayout(Stream) Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class > LoadLayout Method : LoadLayout(Stream) Method

stream

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Sub LoadLayout( _
   ByVal stream As System.IO.Stream _
)
Visual Basic (Usage) Copy Code
Dim instance As WebGrid
Dim stream As System.IO.Stream

instance.LoadLayout(stream)
C#
public void LoadLayout(
   System.IO.Stream stream
)
Delphi
public procedure LoadLayout(
    stream: System.IO.Stream
);
JScript
public function LoadLayout(
   stream : System.IO.Stream
);
Managed Extensions for C++
public: void LoadLayout(
   System.IO.Stream* stream
)
C++/CLI
public:
void LoadLayout(
   System.IO.Stream^ stream
)

Parameters

stream

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members
Overload List


LoadLayout(LayoutInfo) Method

[image]
Intersoft WebGrid Documentation
LoadLayout(LayoutInfo) Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class > LoadLayout Method : LoadLayout(LayoutInfo) Method

settings

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub LoadLayout( _
   ByVal settings As ISNet.WebUI.LayoutInfo _
)
Visual Basic (Usage) Copy Code
Dim instance As WebGrid
Dim settings As ISNet.WebUI.LayoutInfo

instance.LoadLayout(settings)
C#
public virtual void LoadLayout(
   ISNet.WebUI.LayoutInfo settings
)
Delphi
public procedure LoadLayout(
    settings: ISNet.WebUI.LayoutInfo
); virtual;
JScript
public function LoadLayout(
   settings : ISNet.WebUI.LayoutInfo
);
Managed Extensions for C++
public: virtual void LoadLayout(
   ISNet.WebUI.LayoutInfo* settings
)
C++/CLI
public:
virtual void LoadLayout(
   ISNet.WebUI.LayoutInfo^ settings
)

Parameters

settings

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members
Overload List


LoadLayoutFromFile Method

[image]
Intersoft WebGrid Documentation
LoadLayoutFromFile Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class : LoadLayoutFromFile Method

filePath

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Sub LoadLayoutFromFile( _
   ByVal filePath As System.String _
)
Visual Basic (Usage) Copy Code
Dim instance As WebGrid
Dim filePath As System.String

instance.LoadLayoutFromFile(filePath)
C#
public override void LoadLayoutFromFile(
   System.string filePath
)
Delphi
public procedure LoadLayoutFromFile(
    filePath: System.String
); override;
JScript
public override function LoadLayoutFromFile(
   filePath : System.String
);
Managed Extensions for C++
public: void LoadLayoutFromFile(
   System.string* filePath
) override
C++/CLI
public:
void LoadLayoutFromFile(
   System.String^ filePath
) override

Parameters

filePath

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members


LoadLayoutFromPredefinedName Method

[image]
Intersoft WebGrid Documentation
LoadLayoutFromPredefinedName Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class : LoadLayoutFromPredefinedName Method

predefinedName

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub LoadLayoutFromPredefinedName( _
   ByVal predefinedName As System.String _
)
Visual Basic (Usage) Copy Code
Dim instance As WebGrid
Dim predefinedName As System.String

instance.LoadLayoutFromPredefinedName(predefinedName)
C#
public virtual void LoadLayoutFromPredefinedName(
   System.string predefinedName
)
Delphi
public procedure LoadLayoutFromPredefinedName(
    predefinedName: System.String
); virtual;
JScript
public function LoadLayoutFromPredefinedName(
   predefinedName : System.String
);
Managed Extensions for C++
public: virtual void LoadLayoutFromPredefinedName(
   System.string* predefinedName
)
C++/CLI
public:
virtual void LoadLayoutFromPredefinedName(
   System.String^ predefinedName
)

Parameters

predefinedName

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members


LoadLayoutFromStream Method

[image]
Intersoft WebGrid Documentation
LoadLayoutFromStream Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class : LoadLayoutFromStream Method

stream

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub LoadLayoutFromStream( _
   ByVal stream As System.IO.Stream _
)
Visual Basic (Usage) Copy Code
Dim instance As WebGrid
Dim stream As System.IO.Stream

instance.LoadLayoutFromStream(stream)
C#
public virtual void LoadLayoutFromStream(
   System.IO.Stream stream
)
Delphi
public procedure LoadLayoutFromStream(
    stream: System.IO.Stream
); virtual;
JScript
public function LoadLayoutFromStream(
   stream : System.IO.Stream
);
Managed Extensions for C++
public: virtual void LoadLayoutFromStream(
   System.IO.Stream* stream
)
C++/CLI
public:
virtual void LoadLayoutFromStream(
   System.IO.Stream^ stream
)

Parameters

stream

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members


LoadLayoutFromXml Method

[image]
Intersoft WebGrid Documentation
LoadLayoutFromXml Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class : LoadLayoutFromXml Method

Glossary Item Box

Overload List

Overload | Description
LoadLayoutFromXml(String) |
LoadLayoutFromXml(Stream) |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members


LoadLayoutFromXml(String) Method

[image]
Intersoft WebGrid Documentation
LoadLayoutFromXml(String) Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class > LoadLayoutFromXml Method : LoadLayoutFromXml(String) Method

fileName

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Sub LoadLayoutFromXml( _
   ByVal fileName As System.String _
)
Visual Basic (Usage) Copy Code
Dim instance As WebGrid
Dim fileName As System.String

instance.LoadLayoutFromXml(fileName)
C#
public void LoadLayoutFromXml(
   System.string fileName
)
Delphi
public procedure LoadLayoutFromXml(
    fileName: System.String
);
JScript
public function LoadLayoutFromXml(
   fileName : System.String
);
Managed Extensions for C++
public: void LoadLayoutFromXml(
   System.string* fileName
)
C++/CLI
public:
void LoadLayoutFromXml(
   System.String^ fileName
)

Parameters

fileName

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members
Overload List


LoadLayoutFromXml(Stream) Method

[image]
Intersoft WebGrid Documentation
LoadLayoutFromXml(Stream) Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class > LoadLayoutFromXml Method : LoadLayoutFromXml(Stream) Method

stream

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Sub LoadLayoutFromXml( _
   ByVal stream As System.IO.Stream _
)
Visual Basic (Usage) Copy Code
Dim instance As WebGrid
Dim stream As System.IO.Stream

instance.LoadLayoutFromXml(stream)
C#
public void LoadLayoutFromXml(
   System.IO.Stream stream
)
Delphi
public procedure LoadLayoutFromXml(
    stream: System.IO.Stream
);
JScript
public function LoadLayoutFromXml(
   stream : System.IO.Stream
);
Managed Extensions for C++
public: void LoadLayoutFromXml(
   System.IO.Stream* stream
)
C++/CLI
public:
void LoadLayoutFromXml(
   System.IO.Stream^ stream
)

Parameters

stream

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members
Overload List


LoadPostData Method

[image]
Intersoft WebGrid Documentation
LoadPostData Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class : LoadPostData Method

postDataKey
values

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Function LoadPostData( _
   ByVal postDataKey As System.String, _
   ByVal values As System.Collections.Specialized.NameValueCollection _
) As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebGrid
Dim postDataKey As System.String
Dim values As System.Collections.Specialized.NameValueCollection
Dim value As System.Boolean

value = instance.LoadPostData(postDataKey, values)
C#
public override System.bool LoadPostData(
   System.string postDataKey,
   System.Collections.Specialized.NameValueCollection values
)
Delphi
public function LoadPostData(
    postDataKey: System.String;
    values: System.Collections.Specialized.NameValueCollection
): System.Boolean; override;
JScript
public override function LoadPostData(
   postDataKey : System.String,
   values : System.Collections.Specialized.NameValueCollection
) : System.boolean;
Managed Extensions for C++
public: System.bool LoadPostData(
   System.string* postDataKey,
   System.Collections.Specialized.NameValueCollection* values
) override
C++/CLI
public:
System.bool LoadPostData(
   System.String^ postDataKey,
   System.Collections.Specialized.NameValueCollection^ values
) override

Parameters

postDataKey
values

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members


LoadTablesStructure Method

[image]
Intersoft WebGrid Documentation
LoadTablesStructure Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class : LoadTablesStructure Method

Glossary Item Box

Overload List

Overload | Description
LoadTablesStructure(Stream) |
LoadTablesStructure(String) |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members


LoadTablesStructure(Stream) Method

[image]
Intersoft WebGrid Documentation
LoadTablesStructure(Stream) Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class > LoadTablesStructure Method : LoadTablesStructure(Stream) Method

stream

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Sub LoadTablesStructure( _
   ByVal stream As System.IO.Stream _
)
Visual Basic (Usage) Copy Code
Dim instance As WebGrid
Dim stream As System.IO.Stream

instance.LoadTablesStructure(stream)
C#
public void LoadTablesStructure(
   System.IO.Stream stream
)
Delphi
public procedure LoadTablesStructure(
    stream: System.IO.Stream
);
JScript
public function LoadTablesStructure(
   stream : System.IO.Stream
);
Managed Extensions for C++
public: void LoadTablesStructure(
   System.IO.Stream* stream
)
C++/CLI
public:
void LoadTablesStructure(
   System.IO.Stream^ stream
)

Parameters

stream

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members
Overload List


LoadTablesStructure(String) Method

[image]
Intersoft WebGrid Documentation
LoadTablesStructure(String) Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class > LoadTablesStructure Method : LoadTablesStructure(String) Method

fileName

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Sub LoadTablesStructure( _
   ByVal fileName As System.String _
)
Visual Basic (Usage) Copy Code
Dim instance As WebGrid
Dim fileName As System.String

instance.LoadTablesStructure(fileName)
C#
public void LoadTablesStructure(
   System.string fileName
)
Delphi
public procedure LoadTablesStructure(
    fileName: System.String
);
JScript
public function LoadTablesStructure(
   fileName : System.String
);
Managed Extensions for C++
public: void LoadTablesStructure(
   System.string* fileName
)
C++/CLI
public:
void LoadTablesStructure(
   System.String^ fileName
)

Parameters

fileName

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members
Overload List


LoadTablesStructureFromXml Method

[image]
Intersoft WebGrid Documentation
LoadTablesStructureFromXml Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class : LoadTablesStructureFromXml Method

Glossary Item Box

Overload List

Overload | Description
LoadTablesStructureFromXml(String) |
LoadTablesStructureFromXml(Stream) |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members


LoadTablesStructureFromXml(String) Method

[image]
Intersoft WebGrid Documentation
LoadTablesStructureFromXml(String) Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class > LoadTablesStructureFromXml Method : LoadTablesStructureFromXml(String) Method

fileName

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Sub LoadTablesStructureFromXml( _
   ByVal fileName As System.String _
)
Visual Basic (Usage) Copy Code
Dim instance As WebGrid
Dim fileName As System.String

instance.LoadTablesStructureFromXml(fileName)
C#
public void LoadTablesStructureFromXml(
   System.string fileName
)
Delphi
public procedure LoadTablesStructureFromXml(
    fileName: System.String
);
JScript
public function LoadTablesStructureFromXml(
   fileName : System.String
);
Managed Extensions for C++
public: void LoadTablesStructureFromXml(
   System.string* fileName
)
C++/CLI
public:
void LoadTablesStructureFromXml(
   System.String^ fileName
)

Parameters

fileName

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members
Overload List


LoadTablesStructureFromXml(Stream) Method

[image]
Intersoft WebGrid Documentation
LoadTablesStructureFromXml(Stream) Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class > LoadTablesStructureFromXml Method : LoadTablesStructureFromXml(Stream) Method

stream

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Sub LoadTablesStructureFromXml( _
   ByVal stream As System.IO.Stream _
)
Visual Basic (Usage) Copy Code
Dim instance As WebGrid
Dim stream As System.IO.Stream

instance.LoadTablesStructureFromXml(stream)
C#
public void LoadTablesStructureFromXml(
   System.IO.Stream stream
)
Delphi
public procedure LoadTablesStructureFromXml(
    stream: System.IO.Stream
);
JScript
public function LoadTablesStructureFromXml(
   stream : System.IO.Stream
);
Managed Extensions for C++
public: void LoadTablesStructureFromXml(
   System.IO.Stream* stream
)
C++/CLI
public:
void LoadTablesStructureFromXml(
   System.IO.Stream^ stream
)

Parameters

stream

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members
Overload List


MergeStyle Method

[image]
Intersoft WebGrid Documentation
MergeStyle Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class : MergeStyle Method

s

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub MergeStyle( _
   ByVal s As System.Web.UI.WebControls.Style _
)
Visual Basic (Usage) Copy Code
Dim instance As WebGrid
Dim s As System.Web.UI.WebControls.Style

instance.MergeStyle(s)
C#
public void MergeStyle(
   System.Web.UI.WebControls.Style s
)
Delphi
public procedure MergeStyle(
    s: System.Web.UI.WebControls.Style
);
JScript
public function MergeStyle(
   s : System.Web.UI.WebControls.Style
);
Managed Extensions for C++
public: void MergeStyle(
   System.Web.UI.WebControls.Style* s
)
C++/CLI
public:
void MergeStyle(
   System.Web.UI.WebControls.Style^ s
)

Parameters

s

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members


OnAddRow Method

[image]
Intersoft WebGrid Documentation
OnAddRow Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class : OnAddRow Method

row

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function OnAddRow( _
   ByVal row As WebGridRow _
) As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebGrid
Dim row As WebGridRow
Dim value As System.Boolean

value = instance.OnAddRow(row)
C#
public virtual System.bool OnAddRow(
   WebGridRow row
)
Delphi
public function OnAddRow(
    row: WebGridRow
): System.Boolean; virtual;
JScript
public function OnAddRow(
   row : WebGridRow
) : System.boolean;
Managed Extensions for C++
public: virtual System.bool OnAddRow(
   WebGridRow* row
)
C++/CLI
public:
virtual System.bool OnAddRow(
   WebGridRow^ row
)

Parameters

row

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members


OnBatchUpdate Method

[image]
Intersoft WebGrid Documentation
OnBatchUpdate Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class : OnBatchUpdate Method

pendingChanges

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function OnBatchUpdate( _
   ByVal pendingChanges As System.Collections.Generic.List(Of WebGridRowChanges) _
) As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebGrid
Dim pendingChanges As System.Collections.Generic.List(Of WebGridRowChanges)
Dim value As System.Boolean

value = instance.OnBatchUpdate(pendingChanges)
C#
public virtual System.bool OnBatchUpdate(
   System.Collections.Generic.List<WebGridRowChanges> pendingChanges
)
Delphi
public function OnBatchUpdate(
    pendingChanges: System.Collections.Generic.List
): System.Boolean; virtual;
JScript
public function OnBatchUpdate(
   pendingChanges : System.Collections.Generic.List
) : System.boolean;
Managed Extensions for C++
public: virtual System.bool OnBatchUpdate(
   System.Collections.Generic.List<WebGridRowChanges*>* pendingChanges
)
C++/CLI
public:
virtual System.bool OnBatchUpdate(
   System.Collections.Generic.List<WebGridRowChanges^>^ pendingChanges
)

Parameters

pendingChanges

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members


OnButtonClick Method

[image]
Intersoft WebGrid Documentation
OnButtonClick Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class : OnButtonClick Method

table
column
cellValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function OnButtonClick( _
   ByVal table As WebGridTable, _
   ByVal column As WebGridColumn, _
   ByVal cellValue As System.String _
) As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebGrid
Dim table As WebGridTable
Dim column As WebGridColumn
Dim cellValue As System.String
Dim value As System.Boolean

value = instance.OnButtonClick(table, column, cellValue)
C#
public virtual System.bool OnButtonClick(
   WebGridTable table,
   WebGridColumn column,
   System.string cellValue
)
Delphi
public function OnButtonClick(
    table: WebGridTable;
    column: WebGridColumn;
    cellValue: System.String
): System.Boolean; virtual;
JScript
public function OnButtonClick(
   table : WebGridTable,
   column : WebGridColumn,
   cellValue : System.String
) : System.boolean;
Managed Extensions for C++
public: virtual System.bool OnButtonClick(
   WebGridTable* table,
   WebGridColumn* column,
   System.string* cellValue
)
C++/CLI
public:
virtual System.bool OnButtonClick(
   WebGridTable^ table,
   WebGridColumn^ column,
   System.String^ cellValue
)

Parameters

table
column
cellValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members


OnChartImageProcessed Method

[image]
Intersoft WebGrid Documentation
OnChartImageProcessed Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class : OnChartImageProcessed Method

e

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function OnChartImageProcessed( _
   ByVal e As WebGridChartStatusArgs _
) As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebGrid
Dim e As WebGridChartStatusArgs
Dim value As System.Boolean

value = instance.OnChartImageProcessed(e)
C#
public virtual System.bool OnChartImageProcessed(
   WebGridChartStatusArgs e
)
Delphi
public function OnChartImageProcessed(
    e: WebGridChartStatusArgs
): System.Boolean; virtual;
JScript
public function OnChartImageProcessed(
   e : WebGridChartStatusArgs
) : System.boolean;
Managed Extensions for C++
public: virtual System.bool OnChartImageProcessed(
   WebGridChartStatusArgs* e
)
C++/CLI
public:
virtual System.bool OnChartImageProcessed(
   WebGridChartStatusArgs^ e
)

Parameters

e

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members


OnChartImageProcessing Method

[image]
Intersoft WebGrid Documentation
OnChartImageProcessing Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class : OnChartImageProcessing Method

e

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function OnChartImageProcessing( _
   ByVal e As WebGridChartEventArgs _
) As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebGrid
Dim e As WebGridChartEventArgs
Dim value As System.Boolean

value = instance.OnChartImageProcessing(e)
C#
public virtual System.bool OnChartImageProcessing(
   WebGridChartEventArgs e
)
Delphi
public function OnChartImageProcessing(
    e: WebGridChartEventArgs
): System.Boolean; virtual;
JScript
public function OnChartImageProcessing(
   e : WebGridChartEventArgs
) : System.boolean;
Managed Extensions for C++
public: virtual System.bool OnChartImageProcessing(
   WebGridChartEventArgs* e
)
C++/CLI
public:
virtual System.bool OnChartImageProcessing(
   WebGridChartEventArgs^ e
)

Parameters

e

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members


OnCustomAggregate Method

[image]
Intersoft WebGrid Documentation
OnCustomAggregate Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class : OnCustomAggregate Method

col
rows
type

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function OnCustomAggregate( _
   ByVal col As WebGridColumn, _
   ByVal rows As WebGridRowCollection, _
   ByVal type As System.String _
) As System.Object
Visual Basic (Usage) Copy Code
Dim instance As WebGrid
Dim col As WebGridColumn
Dim rows As WebGridRowCollection
Dim type As System.String
Dim value As System.Object

value = instance.OnCustomAggregate(col, rows, type)
C#
public virtual System.object OnCustomAggregate(
   WebGridColumn col,
   WebGridRowCollection rows,
   System.string type
)
Delphi
public function OnCustomAggregate(
    col: WebGridColumn;
    rows: WebGridRowCollection;
    type: System.String
): System.TObject; virtual;
JScript
public function OnCustomAggregate(
   col : WebGridColumn,
   rows : WebGridRowCollection,
   type : System.String
) : System.Object;
Managed Extensions for C++
public: virtual System.Object* OnCustomAggregate(
   WebGridColumn* col,
   WebGridRowCollection* rows,
   System.string* type
)
C++/CLI
public:
virtual System.Object^ OnCustomAggregate(
   WebGridColumn^ col,
   WebGridRowCollection^ rows,
   System.String^ type
)

Parameters

col
rows
type

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members


OnCustomFilter Method

[image]
Intersoft WebGrid Documentation
OnCustomFilter Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class : OnCustomFilter Method

table
dataSource
filters

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function OnCustomFilter( _
   ByVal table As WebGridTable, _
   ByVal dataSource As System.Object, _
   ByVal filters As WebGridFilterCollection _
) As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebGrid
Dim table As WebGridTable
Dim dataSource As System.Object
Dim filters As WebGridFilterCollection
Dim value As System.Boolean

value = instance.OnCustomFilter(table, dataSource, filters)
C#
public virtual System.bool OnCustomFilter(
   WebGridTable table,
   System.object dataSource,
   WebGridFilterCollection filters
)
Delphi
public function OnCustomFilter(
    table: WebGridTable;
    dataSource: System.TObject;
    filters: WebGridFilterCollection
): System.Boolean; virtual;
JScript
public function OnCustomFilter(
   table : WebGridTable,
   dataSource : System.Object,
   filters : WebGridFilterCollection
) : System.boolean;
Managed Extensions for C++
public: virtual System.bool OnCustomFilter(
   WebGridTable* table,
   System.Object* dataSource,
   WebGridFilterCollection* filters
)
C++/CLI
public:
virtual System.bool OnCustomFilter(
   WebGridTable^ table,
   System.Object^ dataSource,
   WebGridFilterCollection^ filters
)

Parameters

table
dataSource
filters

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members


OnCustomSort Method

[image]
Intersoft WebGrid Documentation
OnCustomSort Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class : OnCustomSort Method

table
dataSource
sorts

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function OnCustomSort( _
   ByVal table As WebGridTable, _
   ByVal dataSource As System.Object, _
   ByVal sorts As WebGridGroupCollection _
) As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebGrid
Dim table As WebGridTable
Dim dataSource As System.Object
Dim sorts As WebGridGroupCollection
Dim value As System.Boolean

value = instance.OnCustomSort(table, dataSource, sorts)
C#
public virtual System.bool OnCustomSort(
   WebGridTable table,
   System.object dataSource,
   WebGridGroupCollection sorts
)
Delphi
public function OnCustomSort(
    table: WebGridTable;
    dataSource: System.TObject;
    sorts: WebGridGroupCollection
): System.Boolean; virtual;
JScript
public function OnCustomSort(
   table : WebGridTable,
   dataSource : System.Object,
   sorts : WebGridGroupCollection
) : System.boolean;
Managed Extensions for C++
public: virtual System.bool OnCustomSort(
   WebGridTable* table,
   System.Object* dataSource,
   WebGridGroupCollection* sorts
)
C++/CLI
public:
virtual System.bool OnCustomSort(
   WebGridTable^ table,
   System.Object^ dataSource,
   WebGridGroupCollection^ sorts
)

Parameters

table
dataSource
sorts

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members


OnDeleteRow Method

[image]
Intersoft WebGrid Documentation
OnDeleteRow Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class : OnDeleteRow Method

row

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function OnDeleteRow( _
   ByVal row As WebGridRow _
) As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebGrid
Dim row As WebGridRow
Dim value As System.Boolean

value = instance.OnDeleteRow(row)
C#
public virtual System.bool OnDeleteRow(
   WebGridRow row
)
Delphi
public function OnDeleteRow(
    row: WebGridRow
): System.Boolean; virtual;
JScript
public function OnDeleteRow(
   row : WebGridRow
) : System.boolean;
Managed Extensions for C++
public: virtual System.bool OnDeleteRow(
   WebGridRow* row
)
C++/CLI
public:
virtual System.bool OnDeleteRow(
   WebGridRow^ row
)

Parameters

row

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members


OnExport Method

[image]
Intersoft WebGrid Documentation
OnExport Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class : OnExport Method

table
dataSource
reportInfo
outputFile

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function OnExport( _
   ByVal table As WebGridTable, _
   ByVal dataSource As System.Object, _
   ByVal reportInfo As DynARInfo, _
   ByRef outputFile As System.String _
) As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebGrid
Dim table As WebGridTable
Dim dataSource As System.Object
Dim reportInfo As DynARInfo
Dim outputFile As System.String
Dim value As System.Boolean

value = instance.OnExport(table, dataSource, reportInfo, outputFile)
C#
public virtual System.bool OnExport(
   WebGridTable table,
   System.object dataSource,
   DynARInfo reportInfo,
   ref System.string outputFile
)
Delphi
public function OnExport(
    table: WebGridTable;
    dataSource: System.TObject;
    reportInfo: DynARInfo;
   var  outputFile: System.String
): System.Boolean; virtual;
JScript
public function OnExport(
   table : WebGridTable,
   dataSource : System.Object,
   reportInfo : DynARInfo,
   outputFile : System.String
) : System.boolean;
Managed Extensions for C++
public: virtual System.bool OnExport(
   WebGridTable* table,
   System.Object* dataSource,
   DynARInfo* reportInfo,
   ref System.string* outputFile
)
C++/CLI
public:
virtual System.bool OnExport(
   WebGridTable^ table,
   System.Object^ dataSource,
   DynARInfo^ reportInfo,
   System.String^% outputFile
)

Parameters

table
dataSource
reportInfo
outputFile

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members


OnExportCompleted Method

[image]
Intersoft WebGrid Documentation
OnExportCompleted Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class : OnExportCompleted Method

outputFile
outputStream
exp

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function OnExportCompleted( _
   ByVal outputFile As System.String, _
   ByVal outputStream As System.IO.Stream, _
   ByVal exp As System.Exception _
) As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebGrid
Dim outputFile As System.String
Dim outputStream As System.IO.Stream
Dim exp As System.Exception
Dim value As System.Boolean

value = instance.OnExportCompleted(outputFile, outputStream, exp)
C#
public virtual System.bool OnExportCompleted(
   System.string outputFile,
   System.IO.Stream outputStream,
   System.Exception exp
)
Delphi
public function OnExportCompleted(
    outputFile: System.String;
    outputStream: System.IO.Stream;
    exp: System.Exception
): System.Boolean; virtual;
JScript
public function OnExportCompleted(
   outputFile : System.String,
   outputStream : System.IO.Stream,
   exp : System.Exception
) : System.boolean;
Managed Extensions for C++
public: virtual System.bool OnExportCompleted(
   System.string* outputFile,
   System.IO.Stream* outputStream,
   System.Exception* exp
)
C++/CLI
public:
virtual System.bool OnExportCompleted(
   System.String^ outputFile,
   System.IO.Stream^ outputStream,
   System.Exception^ exp
)

Parameters

outputFile
outputStream
exp

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members


OnInfoChanged Method

[image]
Intersoft WebGrid Documentation
OnInfoChanged Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class : OnInfoChanged Method

e

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub OnInfoChanged( _
   ByVal e As ISNet.WebUI.SynchronizeEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As WebGrid
Dim e As ISNet.WebUI.SynchronizeEventArgs

instance.OnInfoChanged(e)
C#
public void OnInfoChanged(
   ISNet.WebUI.SynchronizeEventArgs e
)
Delphi
public procedure OnInfoChanged(
    e: ISNet.WebUI.SynchronizeEventArgs
);
JScript
public function OnInfoChanged(
   e : ISNet.WebUI.SynchronizeEventArgs
);
Managed Extensions for C++
public: void OnInfoChanged(
   ISNet.WebUI.SynchronizeEventArgs* e
)
C++/CLI
public:
void OnInfoChanged(
   ISNet.WebUI.SynchronizeEventArgs^ e
)

Parameters

e

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members


OnInitializeCell Method

[image]
Intersoft WebGrid Documentation
OnInitializeCell Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class : OnInitializeCell Method

cell

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function OnInitializeCell( _
   ByVal cell As WebGridCell _
) As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebGrid
Dim cell As WebGridCell
Dim value As System.Boolean

value = instance.OnInitializeCell(cell)
C#
public virtual System.bool OnInitializeCell(
   WebGridCell cell
)
Delphi
public function OnInitializeCell(
    cell: WebGridCell
): System.Boolean; virtual;
JScript
public function OnInitializeCell(
   cell : WebGridCell
) : System.boolean;
Managed Extensions for C++
public: virtual System.bool OnInitializeCell(
   WebGridCell* cell
)
C++/CLI
public:
virtual System.bool OnInitializeCell(
   WebGridCell^ cell
)

Parameters

cell

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members


OnInitializeChildTableDataSource Method

[image]
Intersoft WebGrid Documentation
OnInitializeChildTableDataSource Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class : OnInitializeChildTableDataSource Method

childTable
dataSource
parentConstraints
customReqData

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function OnInitializeChildTableDataSource( _
   ByVal childTable As WebGridTable, _
   ByVal dataSource As System.Object, _
   ByVal parentConstraints As System.String, _
   ByVal customReqData As System.String _
) As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebGrid
Dim childTable As WebGridTable
Dim dataSource As System.Object
Dim parentConstraints As System.String
Dim customReqData As System.String
Dim value As System.Boolean

value = instance.OnInitializeChildTableDataSource(childTable, dataSource, parentConstraints, customReqData)
C#
public virtual System.bool OnInitializeChildTableDataSource(
   WebGridTable childTable,
   System.object dataSource,
   System.string parentConstraints,
   System.string customReqData
)
Delphi
public function OnInitializeChildTableDataSource(
    childTable: WebGridTable;
    dataSource: System.TObject;
    parentConstraints: System.String;
    customReqData: System.String
): System.Boolean; virtual;
JScript
public function OnInitializeChildTableDataSource(
   childTable : WebGridTable,
   dataSource : System.Object,
   parentConstraints : System.String,
   customReqData : System.String
) : System.boolean;
Managed Extensions for C++
public: virtual System.bool OnInitializeChildTableDataSource(
   WebGridTable* childTable,
   System.Object* dataSource,
   System.string* parentConstraints,
   System.string* customReqData
)
C++/CLI
public:
virtual System.bool OnInitializeChildTableDataSource(
   WebGridTable^ childTable,
   System.Object^ dataSource,
   System.String^ parentConstraints,
   System.String^ customReqData
)

Parameters

childTable
dataSource
parentConstraints
customReqData

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members


OnInitializeColumn Method

[image]
Intersoft WebGrid Documentation
OnInitializeColumn Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class : OnInitializeColumn Method

col

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function OnInitializeColumn( _
   ByVal col As WebGridColumn _
) As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebGrid
Dim col As WebGridColumn
Dim value As System.Boolean

value = instance.OnInitializeColumn(col)
C#
public virtual System.bool OnInitializeColumn(
   WebGridColumn col
)
Delphi
public function OnInitializeColumn(
    col: WebGridColumn
): System.Boolean; virtual;
JScript
public function OnInitializeColumn(
   col : WebGridColumn
) : System.boolean;
Managed Extensions for C++
public: virtual System.bool OnInitializeColumn(
   WebGridColumn* col
)
C++/CLI
public:
virtual System.bool OnInitializeColumn(
   WebGridColumn^ col
)

Parameters

col

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members


OnInitializeDataSource Method

[image]
Intersoft WebGrid Documentation
OnInitializeDataSource Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class : OnInitializeDataSource Method

dataSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function OnInitializeDataSource( _
   ByVal dataSource As System.Object _
) As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebGrid
Dim dataSource As System.Object
Dim value As System.Boolean

value = instance.OnInitializeDataSource(dataSource)
C#
public virtual System.bool OnInitializeDataSource(
   System.object dataSource
)
Delphi
public function OnInitializeDataSource(
    dataSource: System.TObject
): System.Boolean; virtual;
JScript
public function OnInitializeDataSource(
   dataSource : System.Object
) : System.boolean;
Managed Extensions for C++
public: virtual System.bool OnInitializeDataSource(
   System.Object* dataSource
)
C++/CLI
public:
virtual System.bool OnInitializeDataSource(
   System.Object^ dataSource
)

Parameters

dataSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members


OnInitializeJsonRow Method

[image]
Intersoft WebGrid Documentation
OnInitializeJsonRow Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class : OnInitializeJsonRow Method

row

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function OnInitializeJsonRow( _
   ByVal row As WebGridRow _
) As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebGrid
Dim row As WebGridRow
Dim value As System.Boolean

value = instance.OnInitializeJsonRow(row)
C#
public virtual System.bool OnInitializeJsonRow(
   WebGridRow row
)
Delphi
public function OnInitializeJsonRow(
    row: WebGridRow
): System.Boolean; virtual;
JScript
public function OnInitializeJsonRow(
   row : WebGridRow
) : System.boolean;
Managed Extensions for C++
public: virtual System.bool OnInitializeJsonRow(
   WebGridRow* row
)
C++/CLI
public:
virtual System.bool OnInitializeJsonRow(
   WebGridRow^ row
)

Parameters

row

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members


OnInitializeLayout Method

[image]
Intersoft WebGrid Documentation
OnInitializeLayout Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class : OnInitializeLayout Method

layout

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function OnInitializeLayout( _
   ByVal layout As LayoutSet _
) As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebGrid
Dim layout As LayoutSet
Dim value As System.Boolean

value = instance.OnInitializeLayout(layout)
C#
public virtual System.bool OnInitializeLayout(
   LayoutSet layout
)
Delphi
public function OnInitializeLayout(
    layout: LayoutSet
): System.Boolean; virtual;
JScript
public function OnInitializeLayout(
   layout : LayoutSet
) : System.boolean;
Managed Extensions for C++
public: virtual System.bool OnInitializeLayout(
   LayoutSet* layout
)
C++/CLI
public:
virtual System.bool OnInitializeLayout(
   LayoutSet^ layout
)

Parameters

layout

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members


OnInitializePostBack Method

[image]
Intersoft WebGrid Documentation
OnInitializePostBack Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class : OnInitializePostBack Method

grid
dataSource
request
action

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function OnInitializePostBack( _
   ByVal grid As WebGrid, _
   ByVal dataSource As System.Object, _
   ByVal request As System.Xml.XmlDocument, _
   ByVal action As System.String _
) As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebGrid
Dim grid As WebGrid
Dim dataSource As System.Object
Dim request As System.Xml.XmlDocument
Dim action As System.String
Dim value As System.Boolean

value = instance.OnInitializePostBack(grid, dataSource, request, action)
C#
public virtual System.bool OnInitializePostBack(
   WebGrid grid,
   System.object dataSource,
   System.Xml.XmlDocument request,
   System.string action
)
Delphi
public function OnInitializePostBack(
    grid: WebGrid;
    dataSource: System.TObject;
    request: System.Xml.XmlDocument;
    action: System.String
): System.Boolean; virtual;
JScript
public function OnInitializePostBack(
   grid : WebGrid,
   dataSource : System.Object,
   request : System.Xml.XmlDocument,
   action : System.String
) : System.boolean;
Managed Extensions for C++
public: virtual System.bool OnInitializePostBack(
   WebGrid* grid,
   System.Object* dataSource,
   System.Xml.XmlDocument* request,
   System.string* action
)
C++/CLI
public:
virtual System.bool OnInitializePostBack(
   WebGrid^ grid,
   System.Object^ dataSource,
   System.Xml.XmlDocument^ request,
   System.String^ action
)

Parameters

grid
dataSource
request
action

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members


OnInitializeRow Method

[image]
Intersoft WebGrid Documentation
OnInitializeRow Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class : OnInitializeRow Method

row

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function OnInitializeRow( _
   ByVal row As WebGridRow _
) As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebGrid
Dim row As WebGridRow
Dim value As System.Boolean

value = instance.OnInitializeRow(row)
C#
public virtual System.bool OnInitializeRow(
   WebGridRow row
)
Delphi
public function OnInitializeRow(
    row: WebGridRow
): System.Boolean; virtual;
JScript
public function OnInitializeRow(
   row : WebGridRow
) : System.boolean;
Managed Extensions for C++
public: virtual System.bool OnInitializeRow(
   WebGridRow* row
)
C++/CLI
public:
virtual System.bool OnInitializeRow(
   WebGridRow^ row
)

Parameters

row

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members


OnInitializeSelfReferenceDataSource Method

[image]
Intersoft WebGrid Documentation
OnInitializeSelfReferenceDataSource Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class : OnInitializeSelfReferenceDataSource Method

table
dataSource
parentConstraints
customReqData

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function OnInitializeSelfReferenceDataSource( _
   ByVal table As WebGridTable, _
   ByVal dataSource As System.Object, _
   ByVal parentConstraints As System.String, _
   ByVal customReqData As System.String _
) As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebGrid
Dim table As WebGridTable
Dim dataSource As System.Object
Dim parentConstraints As System.String
Dim customReqData As System.String
Dim value As System.Boolean

value = instance.OnInitializeSelfReferenceDataSource(table, dataSource, parentConstraints, customReqData)
C#
public virtual System.bool OnInitializeSelfReferenceDataSource(
   WebGridTable table,
   System.object dataSource,
   System.string parentConstraints,
   System.string customReqData
)
Delphi
public function OnInitializeSelfReferenceDataSource(
    table: WebGridTable;
    dataSource: System.TObject;
    parentConstraints: System.String;
    customReqData: System.String
): System.Boolean; virtual;
JScript
public function OnInitializeSelfReferenceDataSource(
   table : WebGridTable,
   dataSource : System.Object,
   parentConstraints : System.String,
   customReqData : System.String
) : System.boolean;
Managed Extensions for C++
public: virtual System.bool OnInitializeSelfReferenceDataSource(
   WebGridTable* table,
   System.Object* dataSource,
   System.string* parentConstraints,
   System.string* customReqData
)
C++/CLI
public:
virtual System.bool OnInitializeSelfReferenceDataSource(
   WebGridTable^ table,
   System.Object^ dataSource,
   System.String^ parentConstraints,
   System.String^ customReqData
)

Parameters

table
dataSource
parentConstraints
customReqData

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members


OnInitializeTable Method

[image]
Intersoft WebGrid Documentation
OnInitializeTable Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class : OnInitializeTable Method

table

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function OnInitializeTable( _
   ByVal table As WebGridTable _
) As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebGrid
Dim table As WebGridTable
Dim value As System.Boolean

value = instance.OnInitializeTable(table)
C#
public virtual System.bool OnInitializeTable(
   WebGridTable table
)
Delphi
public function OnInitializeTable(
    table: WebGridTable
): System.Boolean; virtual;
JScript
public function OnInitializeTable(
   table : WebGridTable
) : System.boolean;
Managed Extensions for C++
public: virtual System.bool OnInitializeTable(
   WebGridTable* table
)
C++/CLI
public:
virtual System.bool OnInitializeTable(
   WebGridTable^ table
)

Parameters

table

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members


OnLoadPreviewRow Method

[image]
Intersoft WebGrid Documentation
OnLoadPreviewRow Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class : OnLoadPreviewRow Method

row

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function OnLoadPreviewRow( _
   ByVal row As WebGridRow _
) As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebGrid
Dim row As WebGridRow
Dim value As System.Boolean

value = instance.OnLoadPreviewRow(row)
C#
public virtual System.bool OnLoadPreviewRow(
   WebGridRow row
)
Delphi
public function OnLoadPreviewRow(
    row: WebGridRow
): System.Boolean; virtual;
JScript
public function OnLoadPreviewRow(
   row : WebGridRow
) : System.boolean;
Managed Extensions for C++
public: virtual System.bool OnLoadPreviewRow(
   WebGridRow* row
)
C++/CLI
public:
virtual System.bool OnLoadPreviewRow(
   WebGridRow^ row
)

Parameters

row

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members


OnPreInitialize Method

[image]
Intersoft WebGrid Documentation
OnPreInitialize Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class : OnPreInitialize Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub OnPreInitialize()
Visual Basic (Usage) Copy Code
Dim instance As WebGrid

instance.OnPreInitialize()
C#
public virtual void OnPreInitialize()
Delphi
public procedure OnPreInitialize(); virtual;
JScript
public function OnPreInitialize();
Managed Extensions for C++
public: virtual void OnPreInitialize();
C++/CLI
public:
virtual void OnPreInitialize();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members


OnPrepareDataBinding Method

[image]
Intersoft WebGrid Documentation
OnPrepareDataBinding Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class : OnPrepareDataBinding Method

dataSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function OnPrepareDataBinding( _
   ByVal dataSource As System.Object _
) As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebGrid
Dim dataSource As System.Object
Dim value As System.Boolean

value = instance.OnPrepareDataBinding(dataSource)
C#
public virtual System.bool OnPrepareDataBinding(
   System.object dataSource
)
Delphi
public function OnPrepareDataBinding(
    dataSource: System.TObject
): System.Boolean; virtual;
JScript
public function OnPrepareDataBinding(
   dataSource : System.Object
) : System.boolean;
Managed Extensions for C++
public: virtual System.bool OnPrepareDataBinding(
   System.Object* dataSource
)
C++/CLI
public:
virtual System.bool OnPrepareDataBinding(
   System.Object^ dataSource
)

Parameters

dataSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members


OnPrepareExportExecute Method

[image]
Intersoft WebGrid Documentation
OnPrepareExportExecute Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class : OnPrepareExportExecute Method

report

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function OnPrepareExportExecute( _
   ByVal report As DataDynamics.ActiveReports.ActiveReport3 _
) As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebGrid
Dim report As DataDynamics.ActiveReports.ActiveReport3
Dim value As System.Boolean

value = instance.OnPrepareExportExecute(report)
C#
public virtual System.bool OnPrepareExportExecute(
   DataDynamics.ActiveReports.ActiveReport3 report
)
Delphi
public function OnPrepareExportExecute(
    report: DataDynamics.ActiveReports.ActiveReport3
): System.Boolean; virtual;
JScript
public function OnPrepareExportExecute(
   report : DataDynamics.ActiveReports.ActiveReport3
) : System.boolean;
Managed Extensions for C++
public: virtual System.bool OnPrepareExportExecute(
   DataDynamics.ActiveReports.ActiveReport3* report
)
C++/CLI
public:
virtual System.bool OnPrepareExportExecute(
   DataDynamics.ActiveReports.ActiveReport3^ report
)

Parameters

report

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members


OnRowChanged Method

[image]
Intersoft WebGrid Documentation
OnRowChanged Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class : OnRowChanged Method

keyValue
row
table

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function OnRowChanged( _
   ByVal keyValue As System.String, _
   ByVal row As WebGridRow, _
   ByVal table As WebGridTable _
) As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebGrid
Dim keyValue As System.String
Dim row As WebGridRow
Dim table As WebGridTable
Dim value As System.Boolean

value = instance.OnRowChanged(keyValue, row, table)
C#
public virtual System.bool OnRowChanged(
   System.string keyValue,
   WebGridRow row,
   WebGridTable table
)
Delphi
public function OnRowChanged(
    keyValue: System.String;
    row: WebGridRow;
    table: WebGridTable
): System.Boolean; virtual;
JScript
public function OnRowChanged(
   keyValue : System.String,
   row : WebGridRow,
   table : WebGridTable
) : System.boolean;
Managed Extensions for C++
public: virtual System.bool OnRowChanged(
   System.string* keyValue,
   WebGridRow* row,
   WebGridTable* table
)
C++/CLI
public:
virtual System.bool OnRowChanged(
   System.String^ keyValue,
   WebGridRow^ row,
   WebGridTable^ table
)

Parameters

keyValue
row
table

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members


OnUpdateRow Method

[image]
Intersoft WebGrid Documentation
OnUpdateRow Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class : OnUpdateRow Method

row

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function OnUpdateRow( _
   ByVal row As WebGridRow _
) As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebGrid
Dim row As WebGridRow
Dim value As System.Boolean

value = instance.OnUpdateRow(row)
C#
public virtual System.bool OnUpdateRow(
   WebGridRow row
)
Delphi
public function OnUpdateRow(
    row: WebGridRow
): System.Boolean; virtual;
JScript
public function OnUpdateRow(
   row : WebGridRow
) : System.boolean;
Managed Extensions for C++
public: virtual System.bool OnUpdateRow(
   WebGridRow* row
)
C++/CLI
public:
virtual System.bool OnUpdateRow(
   WebGridRow^ row
)

Parameters

row

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members


PerformBatchUpdate Method

[image]
Intersoft WebGrid Documentation
PerformBatchUpdate Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class : PerformBatchUpdate Method

Glossary Item Box

Overload List

Overload | Description
PerformBatchUpdate(Boolean) |
PerformBatchUpdate(Boolean,Boolean) |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members


PerformBatchUpdate(Boolean) Method

[image]
Intersoft WebGrid Documentation
PerformBatchUpdate(Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class > PerformBatchUpdate Method : PerformBatchUpdate(Boolean) Method

throwExceptionOnError

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function PerformBatchUpdate( _
   ByVal throwExceptionOnError As System.Boolean _
) As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebGrid
Dim throwExceptionOnError As System.Boolean
Dim value As System.Boolean

value = instance.PerformBatchUpdate(throwExceptionOnError)
C#
public System.bool PerformBatchUpdate(
   System.bool throwExceptionOnError
)
Delphi
public function PerformBatchUpdate(
    throwExceptionOnError: System.Boolean
): System.Boolean;
JScript
public function PerformBatchUpdate(
   throwExceptionOnError : System.boolean
) : System.boolean;
Managed Extensions for C++
public: System.bool PerformBatchUpdate(
   System.bool throwExceptionOnError
)
C++/CLI
public:
System.bool PerformBatchUpdate(
   System.bool throwExceptionOnError
)

Parameters

throwExceptionOnError

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members
Overload List


PerformBatchUpdate(Boolean,Boolean) Method

[image]
Intersoft WebGrid Documentation
PerformBatchUpdate(Boolean,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class > PerformBatchUpdate Method : PerformBatchUpdate(Boolean,Boolean) Method

throwExceptionOnError
updateUI

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function PerformBatchUpdate( _
   ByVal throwExceptionOnError As System.Boolean, _
   ByVal updateUI As System.Boolean _
) As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebGrid
Dim throwExceptionOnError As System.Boolean
Dim updateUI As System.Boolean
Dim value As System.Boolean

value = instance.PerformBatchUpdate(throwExceptionOnError, updateUI)
C#
public System.bool PerformBatchUpdate(
   System.bool throwExceptionOnError,
   System.bool updateUI
)
Delphi
public function PerformBatchUpdate(
    throwExceptionOnError: System.Boolean;
    updateUI: System.Boolean
): System.Boolean;
JScript
public function PerformBatchUpdate(
   throwExceptionOnError : System.boolean,
   updateUI : System.boolean
) : System.boolean;
Managed Extensions for C++
public: System.bool PerformBatchUpdate(
   System.bool throwExceptionOnError,
   System.bool updateUI
)
C++/CLI
public:
System.bool PerformBatchUpdate(
   System.bool throwExceptionOnError,
   System.bool updateUI
)

Parameters

throwExceptionOnError
updateUI

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members
Overload List


RaisePostBackEvent Method

[image]
Intersoft WebGrid Documentation
RaisePostBackEvent Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class : RaisePostBackEvent Method

eventArgument

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub RaisePostBackEvent( _
   ByVal eventArgument As System.String _
)
Visual Basic (Usage) Copy Code
Dim instance As WebGrid
Dim eventArgument As System.String

instance.RaisePostBackEvent(eventArgument)
C#
public void RaisePostBackEvent(
   System.string eventArgument
)
Delphi
public procedure RaisePostBackEvent(
    eventArgument: System.String
);
JScript
public function RaisePostBackEvent(
   eventArgument : System.String
);
Managed Extensions for C++
public: void RaisePostBackEvent(
   System.string* eventArgument
)
C++/CLI
public:
void RaisePostBackEvent(
   System.String^ eventArgument
)

Parameters

eventArgument

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members


RaisePostDataChangedEvent Method

[image]
Intersoft WebGrid Documentation
RaisePostDataChangedEvent Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class : RaisePostDataChangedEvent Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Sub RaisePostDataChangedEvent()
Visual Basic (Usage) Copy Code
Dim instance As WebGrid

instance.RaisePostDataChangedEvent()
C#
public override void RaisePostDataChangedEvent()
Delphi
public procedure RaisePostDataChangedEvent(); override;
JScript
public override function RaisePostDataChangedEvent();
Managed Extensions for C++
public: void RaisePostDataChangedEvent(); override
C++/CLI
public:
void RaisePostDataChangedEvent(); override

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members


ReadWebConfigValue Method

[image]
Intersoft WebGrid Documentation
ReadWebConfigValue Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class : ReadWebConfigValue Method

key

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function ReadWebConfigValue( _
   ByVal key As System.String _
) As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebGrid
Dim key As System.String
Dim value As System.String

value = instance.ReadWebConfigValue(key)
C#
public System.string ReadWebConfigValue(
   System.string key
)
Delphi
public function ReadWebConfigValue(
    key: System.String
): System.String;
JScript
public function ReadWebConfigValue(
   key : System.String
) : System.String;
Managed Extensions for C++
public: System.string* ReadWebConfigValue(
   System.string* key
)
C++/CLI
public:
System.String^ ReadWebConfigValue(
   System.String^ key
)

Parameters

key

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members


RebindDataSource Method

[image]
Intersoft WebGrid Documentation
RebindDataSource Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class : RebindDataSource Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub RebindDataSource()
Visual Basic (Usage) Copy Code
Dim instance As WebGrid

instance.RebindDataSource()
C#
public void RebindDataSource()
Delphi
public procedure RebindDataSource();
JScript
public function RebindDataSource();
Managed Extensions for C++
public: void RebindDataSource();
C++/CLI
public:
void RebindDataSource();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members


RegisterBoxSizing Method

[image]
Intersoft WebGrid Documentation
RegisterBoxSizing Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class : RegisterBoxSizing Method

Glossary Item Box

Overload List

Overload | Description
RegisterBoxSizing(Boolean) | (Inherited from ISNet.WebUI.ISNetControl)
RegisterBoxSizing() | (Inherited from ISNet.WebUI.ISNetControl)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members


RegisterBoxSizing(Boolean) Method

[image]
Intersoft WebGrid Documentation
RegisterBoxSizing(Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class > RegisterBoxSizing Method : RegisterBoxSizing(Boolean) Method

forceAll

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Sub RegisterBoxSizing( _
   ByVal forceAll As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebGrid
Dim forceAll As System.Boolean

instance.RegisterBoxSizing(forceAll)
C#
public void RegisterBoxSizing(
   System.bool forceAll
)
Delphi
public procedure RegisterBoxSizing(
    forceAll: System.Boolean
);
JScript
public function RegisterBoxSizing(
   forceAll : System.boolean
);
Managed Extensions for C++
public: void RegisterBoxSizing(
   System.bool forceAll
)
C++/CLI
public:
void RegisterBoxSizing(
   System.bool forceAll
)

Parameters

forceAll

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members
Overload List


RegisterBoxSizing() Method

[image]
Intersoft WebGrid Documentation
RegisterBoxSizing() Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class > RegisterBoxSizing Method : RegisterBoxSizing() Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Sub RegisterBoxSizing()
Visual Basic (Usage) Copy Code
Dim instance As WebGrid

instance.RegisterBoxSizing()
C#
public void RegisterBoxSizing()
Delphi
public procedure RegisterBoxSizing();
JScript
public function RegisterBoxSizing();
Managed Extensions for C++
public: void RegisterBoxSizing();
C++/CLI
public:
void RegisterBoxSizing();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members
Overload List


RegisterGlobalStyle Method

[image]
Intersoft WebGrid Documentation
RegisterGlobalStyle Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class : RegisterGlobalStyle Method

style

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub RegisterGlobalStyle( _
   ByVal style As ISNet.WebUI.WebStyle _
)
Visual Basic (Usage) Copy Code
Dim instance As WebGrid
Dim style As ISNet.WebUI.WebStyle

instance.RegisterGlobalStyle(style)
C#
public void RegisterGlobalStyle(
   ISNet.WebUI.WebStyle style
)
Delphi
public procedure RegisterGlobalStyle(
    style: ISNet.WebUI.WebStyle
);
JScript
public function RegisterGlobalStyle(
   style : ISNet.WebUI.WebStyle
);
Managed Extensions for C++
public: void RegisterGlobalStyle(
   ISNet.WebUI.WebStyle* style
)
C++/CLI
public:
void RegisterGlobalStyle(
   ISNet.WebUI.WebStyle^ style
)

Parameters

style

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members


RegisterLink Method

[image]
Intersoft WebGrid Documentation
RegisterLink Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class : RegisterLink Method

name
url

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub RegisterLink( _
   ByVal name As System.String, _
   ByVal url As System.String _
)
Visual Basic (Usage) Copy Code
Dim instance As WebGrid
Dim name As System.String
Dim url As System.String

instance.RegisterLink(name, url)
C#
public void RegisterLink(
   System.string name,
   System.string url
)
Delphi
public procedure RegisterLink(
    name: System.String;
    url: System.String
);
JScript
public function RegisterLink(
   name : System.String,
   url : System.String
);
Managed Extensions for C++
public: void RegisterLink(
   System.string* name,
   System.string* url
)
C++/CLI
public:
void RegisterLink(
   System.String^ name,
   System.String^ url
)

Parameters

name
url

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members


RegisterOptimizedCssClasses Method

[image]
Intersoft WebGrid Documentation
RegisterOptimizedCssClasses Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class : RegisterOptimizedCssClasses Method

runtimeStyleOnly

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub RegisterOptimizedCssClasses( _
   ByVal runtimeStyleOnly As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebGrid
Dim runtimeStyleOnly As System.Boolean

instance.RegisterOptimizedCssClasses(runtimeStyleOnly)
C#
public void RegisterOptimizedCssClasses(
   System.bool runtimeStyleOnly
)
Delphi
public procedure RegisterOptimizedCssClasses(
    runtimeStyleOnly: System.Boolean
);
JScript
public function RegisterOptimizedCssClasses(
   runtimeStyleOnly : System.boolean
);
Managed Extensions for C++
public: void RegisterOptimizedCssClasses(
   System.bool runtimeStyleOnly
)
C++/CLI
public:
void RegisterOptimizedCssClasses(
   System.bool runtimeStyleOnly
)

Parameters

runtimeStyleOnly

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members


RegisterPreloadImage Method

[image]
Intersoft WebGrid Documentation
RegisterPreloadImage Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class : RegisterPreloadImage Method

image

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub RegisterPreloadImage( _
   ByVal image As System.String _
)
Visual Basic (Usage) Copy Code
Dim instance As WebGrid
Dim image As System.String

instance.RegisterPreloadImage(image)
C#
public void RegisterPreloadImage(
   System.string image
)
Delphi
public procedure RegisterPreloadImage(
    image: System.String
);
JScript
public function RegisterPreloadImage(
   image : System.String
);
Managed Extensions for C++
public: void RegisterPreloadImage(
   System.string* image
)
C++/CLI
public:
void RegisterPreloadImage(
   System.String^ image
)

Parameters

image

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members


RegisterScript Method

[image]
Intersoft WebGrid Documentation
RegisterScript Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class : RegisterScript Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Sub RegisterScript()
Visual Basic (Usage) Copy Code
Dim instance As WebGrid

instance.RegisterScript()
C#
public override void RegisterScript()
Delphi
public procedure RegisterScript(); override;
JScript
public override function RegisterScript();
Managed Extensions for C++
public: void RegisterScript(); override
C++/CLI
public:
void RegisterScript(); override

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members


RegisterSharePointHandler Method

[image]
Intersoft WebGrid Documentation
RegisterSharePointHandler Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class : RegisterSharePointHandler Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub RegisterSharePointHandler()
Visual Basic (Usage) Copy Code
Dim instance As WebGrid

instance.RegisterSharePointHandler()
C#
public virtual void RegisterSharePointHandler()
Delphi
public procedure RegisterSharePointHandler(); virtual;
JScript
public function RegisterSharePointHandler();
Managed Extensions for C++
public: virtual void RegisterSharePointHandler();
C++/CLI
public:
virtual void RegisterSharePointHandler();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members


RenderBeginTag Method

[image]
Intersoft WebGrid Documentation
RenderBeginTag Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class : RenderBeginTag Method

writer

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub RenderBeginTag( _
   ByVal writer As System.Web.UI.HtmlTextWriter _
)
Visual Basic (Usage) Copy Code
Dim instance As WebGrid
Dim writer As System.Web.UI.HtmlTextWriter

instance.RenderBeginTag(writer)
C#
public virtual void RenderBeginTag(
   System.Web.UI.HtmlTextWriter writer
)
Delphi
public procedure RenderBeginTag(
    writer: System.Web.UI.HtmlTextWriter
); virtual;
JScript
public function RenderBeginTag(
   writer : System.Web.UI.HtmlTextWriter
);
Managed Extensions for C++
public: virtual void RenderBeginTag(
   System.Web.UI.HtmlTextWriter* writer
)
C++/CLI
public:
virtual void RenderBeginTag(
   System.Web.UI.HtmlTextWriter^ writer
)

Parameters

writer

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members


RenderControl Method

[image]
Intersoft WebGrid Documentation
RenderControl Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class : RenderControl Method

Glossary Item Box

Overload List

Overload | Description
RenderControl | (Inherited from System.Web.UI.Control)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members


RenderControl(HtmlTextWriter) Method

[image]
Intersoft WebGrid Documentation
RenderControl(HtmlTextWriter) Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class : RenderControl(HtmlTextWriter) Method

writer

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")>
Public Overridable Sub RenderControl( _
   ByVal writer As System.Web.UI.HtmlTextWriter _
)
Visual Basic (Usage) Copy Code
Dim instance As WebGrid
Dim writer As System.Web.UI.HtmlTextWriter

instance.RenderControl(writer)
C#
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public virtual void RenderControl(
   System.Web.UI.HtmlTextWriter writer
)
Delphi
public procedure RenderControl(
    writer: System.Web.UI.HtmlTextWriter
); virtual;
JScript
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")
public function RenderControl(
   writer : System.Web.UI.HtmlTextWriter
);
Managed Extensions for C++
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public: virtual void RenderControl(
   System.Web.UI.HtmlTextWriter* writer
)
C++/CLI
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public:
virtual void RenderControl(
   System.Web.UI.HtmlTextWriter^ writer
)

Parameters

writer

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members


RenderEndTag Method

[image]
Intersoft WebGrid Documentation
RenderEndTag Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class : RenderEndTag Method

writer

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Sub RenderEndTag( _
   ByVal writer As System.Web.UI.HtmlTextWriter _
)
Visual Basic (Usage) Copy Code
Dim instance As WebGrid
Dim writer As System.Web.UI.HtmlTextWriter

instance.RenderEndTag(writer)
C#
public override void RenderEndTag(
   System.Web.UI.HtmlTextWriter writer
)
Delphi
public procedure RenderEndTag(
    writer: System.Web.UI.HtmlTextWriter
); override;
JScript
public override function RenderEndTag(
   writer : System.Web.UI.HtmlTextWriter
);
Managed Extensions for C++
public: void RenderEndTag(
   System.Web.UI.HtmlTextWriter* writer
) override
C++/CLI
public:
void RenderEndTag(
   System.Web.UI.HtmlTextWriter^ writer
) override

Parameters

writer

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members


Reset Method

[image]
Intersoft WebGrid Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As WebGrid

instance.Reset()
C#
public virtual void Reset()
Delphi
public procedure Reset(); virtual;
JScript
public function Reset();
Managed Extensions for C++
public: virtual void Reset();
C++/CLI
public:
virtual void Reset();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members


ResetDefaultStylePreset Method

[image]
Intersoft WebGrid Documentation
ResetDefaultStylePreset Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class : ResetDefaultStylePreset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub ResetDefaultStylePreset()
Visual Basic (Usage) Copy Code
Dim instance As WebGrid

instance.ResetDefaultStylePreset()
C#
public void ResetDefaultStylePreset()
Delphi
public procedure ResetDefaultStylePreset();
JScript
public function ResetDefaultStylePreset();
Managed Extensions for C++
public: void ResetDefaultStylePreset();
C++/CLI
public:
void ResetDefaultStylePreset();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members


ResetStyleToDefault Method

[image]
Intersoft WebGrid Documentation
ResetStyleToDefault Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class : ResetStyleToDefault Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub ResetStyleToDefault()
Visual Basic (Usage) Copy Code
Dim instance As WebGrid

instance.ResetStyleToDefault()
C#
public void ResetStyleToDefault()
Delphi
public procedure ResetStyleToDefault();
JScript
public function ResetStyleToDefault();
Managed Extensions for C++
public: void ResetStyleToDefault();
C++/CLI
public:
void ResetStyleToDefault();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members


ResolveClientUrl Method

[image]
Intersoft WebGrid Documentation
ResolveClientUrl Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class : ResolveClientUrl Method

relativeUrl

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function ResolveClientUrl( _
   ByVal relativeUrl As System.String _
) As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebGrid
Dim relativeUrl As System.String
Dim value As System.String

value = instance.ResolveClientUrl(relativeUrl)
C#
public System.string ResolveClientUrl(
   System.string relativeUrl
)
Delphi
public function ResolveClientUrl(
    relativeUrl: System.String
): System.String;
JScript
public function ResolveClientUrl(
   relativeUrl : System.String
) : System.String;
Managed Extensions for C++
public: System.string* ResolveClientUrl(
   System.string* relativeUrl
)
C++/CLI
public:
System.String^ ResolveClientUrl(
   System.String^ relativeUrl
)

Parameters

relativeUrl

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members


ResolveImagePath Method

[image]
Intersoft WebGrid Documentation
ResolveImagePath Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class : ResolveImagePath Method

folder
image

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function ResolveImagePath( _
   ByVal folder As System.String, _
   ByVal image As System.String _
) As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebGrid
Dim folder As System.String
Dim image As System.String
Dim value As System.String

value = instance.ResolveImagePath(folder, image)
C#
public System.string ResolveImagePath(
   System.string folder,
   System.string image
)
Delphi
public function ResolveImagePath(
    folder: System.String;
    image: System.String
): System.String;
JScript
public function ResolveImagePath(
   folder : System.String,
   image : System.String
) : System.String;
Managed Extensions for C++
public: System.string* ResolveImagePath(
   System.string* folder,
   System.string* image
)
C++/CLI
public:
System.String^ ResolveImagePath(
   System.String^ folder,
   System.String^ image
)

Parameters

folder
image

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members


ResolveRelativeURL Method

[image]
Intersoft WebGrid Documentation
ResolveRelativeURL Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class : ResolveRelativeURL Method

url

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ResolveRelativeURL( _
   ByVal url As System.String _
) As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebGrid
Dim url As System.String
Dim value As System.String

value = instance.ResolveRelativeURL(url)
C#
public virtual System.string ResolveRelativeURL(
   System.string url
)
Delphi
public function ResolveRelativeURL(
    url: System.String
): System.String; virtual;
JScript
public function ResolveRelativeURL(
   url : System.String
) : System.String;
Managed Extensions for C++
public: virtual System.string* ResolveRelativeURL(
   System.string* url
)
C++/CLI
public:
virtual System.String^ ResolveRelativeURL(
   System.String^ url
)

Parameters

url

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members


ResolveResourceUrl Method

[image]
Intersoft WebGrid Documentation
ResolveResourceUrl Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class : ResolveResourceUrl Method

kind
defaultFolder
currentFolder
resourceName

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function ResolveResourceUrl( _
   ByVal kind As ISNet.WebUI.ResourceKind, _
   ByVal defaultFolder As System.String, _
   ByVal currentFolder As System.String, _
   ByVal resourceName As System.String _
) As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebGrid
Dim kind As ISNet.WebUI.ResourceKind
Dim defaultFolder As System.String
Dim currentFolder As System.String
Dim resourceName As System.String
Dim value As System.String

value = instance.ResolveResourceUrl(kind, defaultFolder, currentFolder, resourceName)
C#
public System.string ResolveResourceUrl(
   ISNet.WebUI.ResourceKind kind,
   System.string defaultFolder,
   System.string currentFolder,
   System.string resourceName
)
Delphi
public function ResolveResourceUrl(
    kind: ISNet.WebUI.ResourceKind;
    defaultFolder: System.String;
    currentFolder: System.String;
    resourceName: System.String
): System.String;
JScript
public function ResolveResourceUrl(
   kind : ISNet.WebUI.ResourceKind,
   defaultFolder : System.String,
   currentFolder : System.String,
   resourceName : System.String
) : System.String;
Managed Extensions for C++
public: System.string* ResolveResourceUrl(
   ISNet.WebUI.ResourceKind kind,
   System.string* defaultFolder,
   System.string* currentFolder,
   System.string* resourceName
)
C++/CLI
public:
System.String^ ResolveResourceUrl(
   ISNet.WebUI.ResourceKind kind,
   System.String^ defaultFolder,
   System.String^ currentFolder,
   System.String^ resourceName
)

Parameters

kind
defaultFolder
currentFolder
resourceName

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members


ResolveUrl Method

[image]
Intersoft WebGrid Documentation
ResolveUrl Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class : ResolveUrl Method

relativeUrl

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function ResolveUrl( _
   ByVal relativeUrl As System.String _
) As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebGrid
Dim relativeUrl As System.String
Dim value As System.String

value = instance.ResolveUrl(relativeUrl)
C#
public System.string ResolveUrl(
   System.string relativeUrl
)
Delphi
public function ResolveUrl(
    relativeUrl: System.String
): System.String;
JScript
public function ResolveUrl(
   relativeUrl : System.String
) : System.String;
Managed Extensions for C++
public: System.string* ResolveUrl(
   System.string* relativeUrl
)
C++/CLI
public:
System.String^ ResolveUrl(
   System.String^ relativeUrl
)

Parameters

relativeUrl

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members


RetrieveClientLastSelectedObject Method

[image]
Intersoft WebGrid Documentation
RetrieveClientLastSelectedObject Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class : RetrieveClientLastSelectedObject Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function RetrieveClientLastSelectedObject() As SelectedObject
Visual Basic (Usage) Copy Code
Dim instance As WebGrid
Dim value As SelectedObject

value = instance.RetrieveClientLastSelectedObject()
C#
public SelectedObject RetrieveClientLastSelectedObject()
Delphi
public function RetrieveClientLastSelectedObject(): SelectedObject;
JScript
public function RetrieveClientLastSelectedObject() : SelectedObject;
Managed Extensions for C++
public: SelectedObject* RetrieveClientLastSelectedObject();
C++/CLI
public:
SelectedObject^ RetrieveClientLastSelectedObject();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members


RetrieveHierarchicalStructure Method

[image]
Intersoft WebGrid Documentation
RetrieveHierarchicalStructure Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class : RetrieveHierarchicalStructure Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub RetrieveHierarchicalStructure()
Visual Basic (Usage) Copy Code
Dim instance As WebGrid

instance.RetrieveHierarchicalStructure()
C#
public void RetrieveHierarchicalStructure()
Delphi
public procedure RetrieveHierarchicalStructure();
JScript
public function RetrieveHierarchicalStructure();
Managed Extensions for C++
public: void RetrieveHierarchicalStructure();
C++/CLI
public:
void RetrieveHierarchicalStructure();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members


RetrieveStructure Method

[image]
Intersoft WebGrid Documentation
RetrieveStructure Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class : RetrieveStructure Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub RetrieveStructure()
Visual Basic (Usage) Copy Code
Dim instance As WebGrid

instance.RetrieveStructure()
C#
public void RetrieveStructure()
Delphi
public procedure RetrieveStructure();
JScript
public function RetrieveStructure();
Managed Extensions for C++
public: void RetrieveStructure();
C++/CLI
public:
void RetrieveStructure();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members


SaveChartToXml Method

[image]
Intersoft WebGrid Documentation
SaveChartToXml Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class : SaveChartToXml Method

Glossary Item Box

Overload List

Overload | Description
SaveChartToXml() |
SaveChartToXml(String) |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members


SaveChartToXml() Method

[image]
Intersoft WebGrid Documentation
SaveChartToXml() Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class > SaveChartToXml Method : SaveChartToXml() Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function SaveChartToXml() As System.Xml.XmlDocument
Visual Basic (Usage) Copy Code
Dim instance As WebGrid
Dim value As System.Xml.XmlDocument

value = instance.SaveChartToXml()
C#
public System.Xml.XmlDocument SaveChartToXml()
Delphi
public function SaveChartToXml(): System.Xml.XmlDocument;
JScript
public function SaveChartToXml() : System.Xml.XmlDocument;
Managed Extensions for C++
public: System.Xml.XmlDocument* SaveChartToXml();
C++/CLI
public:
System.Xml.XmlDocument^ SaveChartToXml();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members
Overload List


SaveChartToXml(String) Method

[image]
Intersoft WebGrid Documentation
SaveChartToXml(String) Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class > SaveChartToXml Method : SaveChartToXml(String) Method

fileName

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Sub SaveChartToXml( _
   ByVal fileName As System.String _
)
Visual Basic (Usage) Copy Code
Dim instance As WebGrid
Dim fileName As System.String

instance.SaveChartToXml(fileName)
C#
public void SaveChartToXml(
   System.string fileName
)
Delphi
public procedure SaveChartToXml(
    fileName: System.String
);
JScript
public function SaveChartToXml(
   fileName : System.String
);
Managed Extensions for C++
public: void SaveChartToXml(
   System.string* fileName
)
C++/CLI
public:
void SaveChartToXml(
   System.String^ fileName
)

Parameters

fileName

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members
Overload List


SaveLayout Method

[image]
Intersoft WebGrid Documentation
SaveLayout Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class : SaveLayout Method

Glossary Item Box

Overload List

Overload | Description
SaveLayout(String) |
SaveLayout(Stream) |
SaveLayout(LayoutInfo) | (Inherited from ISNet.WebUI.ISNetControl)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members


SaveLayout(String) Method

[image]
Intersoft WebGrid Documentation
SaveLayout(String) Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class > SaveLayout Method : SaveLayout(String) Method

fileName

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Sub SaveLayout( _
   ByVal fileName As System.String _
)
Visual Basic (Usage) Copy Code
Dim instance As WebGrid
Dim fileName As System.String

instance.SaveLayout(fileName)
C#
public void SaveLayout(
   System.string fileName
)
Delphi
public procedure SaveLayout(
    fileName: System.String
);
JScript
public function SaveLayout(
   fileName : System.String
);
Managed Extensions for C++
public: void SaveLayout(
   System.string* fileName
)
C++/CLI
public:
void SaveLayout(
   System.String^ fileName
)

Parameters

fileName

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members
Overload List


SaveLayout(Stream) Method

[image]
Intersoft WebGrid Documentation
SaveLayout(Stream) Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class > SaveLayout Method : SaveLayout(Stream) Method

stream

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Sub SaveLayout( _
   ByVal stream As System.IO.Stream _
)
Visual Basic (Usage) Copy Code
Dim instance As WebGrid
Dim stream As System.IO.Stream

instance.SaveLayout(stream)
C#
public void SaveLayout(
   System.IO.Stream stream
)
Delphi
public procedure SaveLayout(
    stream: System.IO.Stream
);
JScript
public function SaveLayout(
   stream : System.IO.Stream
);
Managed Extensions for C++
public: void SaveLayout(
   System.IO.Stream* stream
)
C++/CLI
public:
void SaveLayout(
   System.IO.Stream^ stream
)

Parameters

stream

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members
Overload List


SaveLayout(LayoutInfo) Method

[image]
Intersoft WebGrid Documentation
SaveLayout(LayoutInfo) Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class > SaveLayout Method : SaveLayout(LayoutInfo) Method

settings

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub SaveLayout( _
   ByVal settings As ISNet.WebUI.LayoutInfo _
)
Visual Basic (Usage) Copy Code
Dim instance As WebGrid
Dim settings As ISNet.WebUI.LayoutInfo

instance.SaveLayout(settings)
C#
public virtual void SaveLayout(
   ISNet.WebUI.LayoutInfo settings
)
Delphi
public procedure SaveLayout(
    settings: ISNet.WebUI.LayoutInfo
); virtual;
JScript
public function SaveLayout(
   settings : ISNet.WebUI.LayoutInfo
);
Managed Extensions for C++
public: virtual void SaveLayout(
   ISNet.WebUI.LayoutInfo* settings
)
C++/CLI
public:
virtual void SaveLayout(
   ISNet.WebUI.LayoutInfo^ settings
)

Parameters

settings

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members
Overload List


SaveLayoutToFile Method

[image]
Intersoft WebGrid Documentation
SaveLayoutToFile Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class : SaveLayoutToFile Method

filePath
saveOptions

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub SaveLayoutToFile( _
   ByVal filePath As System.String, _
   ByVal saveOptions As ISNet.WebUI.SaveLayoutOptions _
)
Visual Basic (Usage) Copy Code
Dim instance As WebGrid
Dim filePath As System.String
Dim saveOptions As ISNet.WebUI.SaveLayoutOptions

instance.SaveLayoutToFile(filePath, saveOptions)
C#
public virtual void SaveLayoutToFile(
   System.string filePath,
   ISNet.WebUI.SaveLayoutOptions saveOptions
)
Delphi
public procedure SaveLayoutToFile(
    filePath: System.String;
    saveOptions: ISNet.WebUI.SaveLayoutOptions
); virtual;
JScript
public function SaveLayoutToFile(
   filePath : System.String,
   saveOptions : ISNet.WebUI.SaveLayoutOptions
);
Managed Extensions for C++
public: virtual void SaveLayoutToFile(
   System.string* filePath,
   ISNet.WebUI.SaveLayoutOptions saveOptions
)
C++/CLI
public:
virtual void SaveLayoutToFile(
   System.String^ filePath,
   ISNet.WebUI.SaveLayoutOptions saveOptions
)

Parameters

filePath
saveOptions

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members


SaveLayoutToStream Method

[image]
Intersoft WebGrid Documentation
SaveLayoutToStream Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class : SaveLayoutToStream Method

stream
saveOptions

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub SaveLayoutToStream( _
   ByVal stream As System.IO.Stream, _
   ByVal saveOptions As ISNet.WebUI.SaveLayoutOptions _
)
Visual Basic (Usage) Copy Code
Dim instance As WebGrid
Dim stream As System.IO.Stream
Dim saveOptions As ISNet.WebUI.SaveLayoutOptions

instance.SaveLayoutToStream(stream, saveOptions)
C#
public virtual void SaveLayoutToStream(
   System.IO.Stream stream,
   ISNet.WebUI.SaveLayoutOptions saveOptions
)
Delphi
public procedure SaveLayoutToStream(
    stream: System.IO.Stream;
    saveOptions: ISNet.WebUI.SaveLayoutOptions
); virtual;
JScript
public function SaveLayoutToStream(
   stream : System.IO.Stream,
   saveOptions : ISNet.WebUI.SaveLayoutOptions
);
Managed Extensions for C++
public: virtual void SaveLayoutToStream(
   System.IO.Stream* stream,
   ISNet.WebUI.SaveLayoutOptions saveOptions
)
C++/CLI
public:
virtual void SaveLayoutToStream(
   System.IO.Stream^ stream,
   ISNet.WebUI.SaveLayoutOptions saveOptions
)

Parameters

stream
saveOptions

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members


SaveLayoutToXml Method

[image]
Intersoft WebGrid Documentation
SaveLayoutToXml Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class : SaveLayoutToXml Method

Glossary Item Box

Overload List

Overload | Description
SaveLayoutToXml(String,SaveLayoutOptions) |
SaveLayoutToXml(Stream,SaveLayoutOptions) |
SaveLayoutToXml(String) |
SaveLayoutToXml(Stream) |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members


SaveLayoutToXml(String,SaveLayoutOptions) Method

[image]
Intersoft WebGrid Documentation
SaveLayoutToXml(String,SaveLayoutOptions) Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class > SaveLayoutToXml Method : SaveLayoutToXml(String,SaveLayoutOptions) Method

fileName
saveOptions

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Sub SaveLayoutToXml( _
   ByVal fileName As System.String, _
   ByVal saveOptions As ISNet.WebUI.SaveLayoutOptions _
)
Visual Basic (Usage) Copy Code
Dim instance As WebGrid
Dim fileName As System.String
Dim saveOptions As ISNet.WebUI.SaveLayoutOptions

instance.SaveLayoutToXml(fileName, saveOptions)
C#
public void SaveLayoutToXml(
   System.string fileName,
   ISNet.WebUI.SaveLayoutOptions saveOptions
)
Delphi
public procedure SaveLayoutToXml(
    fileName: System.String;
    saveOptions: ISNet.WebUI.SaveLayoutOptions
);
JScript
public function SaveLayoutToXml(
   fileName : System.String,
   saveOptions : ISNet.WebUI.SaveLayoutOptions
);
Managed Extensions for C++
public: void SaveLayoutToXml(
   System.string* fileName,
   ISNet.WebUI.SaveLayoutOptions saveOptions
)
C++/CLI
public:
void SaveLayoutToXml(
   System.String^ fileName,
   ISNet.WebUI.SaveLayoutOptions saveOptions
)

Parameters

fileName
saveOptions

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members
Overload List


SaveLayoutToXml(Stream,SaveLayoutOptions) Method

[image]
Intersoft WebGrid Documentation
SaveLayoutToXml(Stream,SaveLayoutOptions) Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class > SaveLayoutToXml Method : SaveLayoutToXml(Stream,SaveLayoutOptions) Method

stream
saveOptions

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Sub SaveLayoutToXml( _
   ByVal stream As System.IO.Stream, _
   ByVal saveOptions As ISNet.WebUI.SaveLayoutOptions _
)
Visual Basic (Usage) Copy Code
Dim instance As WebGrid
Dim stream As System.IO.Stream
Dim saveOptions As ISNet.WebUI.SaveLayoutOptions

instance.SaveLayoutToXml(stream, saveOptions)
C#
public void SaveLayoutToXml(
   System.IO.Stream stream,
   ISNet.WebUI.SaveLayoutOptions saveOptions
)
Delphi
public procedure SaveLayoutToXml(
    stream: System.IO.Stream;
    saveOptions: ISNet.WebUI.SaveLayoutOptions
);
JScript
public function SaveLayoutToXml(
   stream : System.IO.Stream,
   saveOptions : ISNet.WebUI.SaveLayoutOptions
);
Managed Extensions for C++
public: void SaveLayoutToXml(
   System.IO.Stream* stream,
   ISNet.WebUI.SaveLayoutOptions saveOptions
)
C++/CLI
public:
void SaveLayoutToXml(
   System.IO.Stream^ stream,
   ISNet.WebUI.SaveLayoutOptions saveOptions
)

Parameters

stream
saveOptions

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members
Overload List


SaveLayoutToXml(String) Method

[image]
Intersoft WebGrid Documentation
SaveLayoutToXml(String) Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class > SaveLayoutToXml Method : SaveLayoutToXml(String) Method

fileName

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Sub SaveLayoutToXml( _
   ByVal fileName As System.String _
)
Visual Basic (Usage) Copy Code
Dim instance As WebGrid
Dim fileName As System.String

instance.SaveLayoutToXml(fileName)
C#
public void SaveLayoutToXml(
   System.string fileName
)
Delphi
public procedure SaveLayoutToXml(
    fileName: System.String
);
JScript
public function SaveLayoutToXml(
   fileName : System.String
);
Managed Extensions for C++
public: void SaveLayoutToXml(
   System.string* fileName
)
C++/CLI
public:
void SaveLayoutToXml(
   System.String^ fileName
)

Parameters

fileName

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members
Overload List


SaveLayoutToXml(Stream) Method

[image]
Intersoft WebGrid Documentation
SaveLayoutToXml(Stream) Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class > SaveLayoutToXml Method : SaveLayoutToXml(Stream) Method

stream

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Sub SaveLayoutToXml( _
   ByVal stream As System.IO.Stream _
)
Visual Basic (Usage) Copy Code
Dim instance As WebGrid
Dim stream As System.IO.Stream

instance.SaveLayoutToXml(stream)
C#
public void SaveLayoutToXml(
   System.IO.Stream stream
)
Delphi
public procedure SaveLayoutToXml(
    stream: System.IO.Stream
);
JScript
public function SaveLayoutToXml(
   stream : System.IO.Stream
);
Managed Extensions for C++
public: void SaveLayoutToXml(
   System.IO.Stream* stream
)
C++/CLI
public:
void SaveLayoutToXml(
   System.IO.Stream^ stream
)

Parameters

stream

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members
Overload List


SaveTablesStructure Method

[image]
Intersoft WebGrid Documentation
SaveTablesStructure Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class : SaveTablesStructure Method

Glossary Item Box

Overload List

Overload | Description
SaveTablesStructure(String) |
SaveTablesStructure(Stream) |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members


SaveTablesStructure(String) Method

[image]
Intersoft WebGrid Documentation
SaveTablesStructure(String) Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class > SaveTablesStructure Method : SaveTablesStructure(String) Method

fileName

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Sub SaveTablesStructure( _
   ByVal fileName As System.String _
)
Visual Basic (Usage) Copy Code
Dim instance As WebGrid
Dim fileName As System.String

instance.SaveTablesStructure(fileName)
C#
public void SaveTablesStructure(
   System.string fileName
)
Delphi
public procedure SaveTablesStructure(
    fileName: System.String
);
JScript
public function SaveTablesStructure(
   fileName : System.String
);
Managed Extensions for C++
public: void SaveTablesStructure(
   System.string* fileName
)
C++/CLI
public:
void SaveTablesStructure(
   System.String^ fileName
)

Parameters

fileName

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members
Overload List


SaveTablesStructure(Stream) Method

[image]
Intersoft WebGrid Documentation
SaveTablesStructure(Stream) Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class > SaveTablesStructure Method : SaveTablesStructure(Stream) Method

stream

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Sub SaveTablesStructure( _
   ByVal stream As System.IO.Stream _
)
Visual Basic (Usage) Copy Code
Dim instance As WebGrid
Dim stream As System.IO.Stream

instance.SaveTablesStructure(stream)
C#
public void SaveTablesStructure(
   System.IO.Stream stream
)
Delphi
public procedure SaveTablesStructure(
    stream: System.IO.Stream
);
JScript
public function SaveTablesStructure(
   stream : System.IO.Stream
);
Managed Extensions for C++
public: void SaveTablesStructure(
   System.IO.Stream* stream
)
C++/CLI
public:
void SaveTablesStructure(
   System.IO.Stream^ stream
)

Parameters

stream

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members
Overload List


SaveTablesStructureToXml Method

[image]
Intersoft WebGrid Documentation
SaveTablesStructureToXml Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class : SaveTablesStructureToXml Method

Glossary Item Box

Overload List

Overload | Description
SaveTablesStructureToXml(String) |
SaveTablesStructureToXml() |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members


SaveTablesStructureToXml(String) Method

[image]
Intersoft WebGrid Documentation
SaveTablesStructureToXml(String) Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class > SaveTablesStructureToXml Method : SaveTablesStructureToXml(String) Method

fileName

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Sub SaveTablesStructureToXml( _
   ByVal fileName As System.String _
)
Visual Basic (Usage) Copy Code
Dim instance As WebGrid
Dim fileName As System.String

instance.SaveTablesStructureToXml(fileName)
C#
public void SaveTablesStructureToXml(
   System.string fileName
)
Delphi
public procedure SaveTablesStructureToXml(
    fileName: System.String
);
JScript
public function SaveTablesStructureToXml(
   fileName : System.String
);
Managed Extensions for C++
public: void SaveTablesStructureToXml(
   System.string* fileName
)
C++/CLI
public:
void SaveTablesStructureToXml(
   System.String^ fileName
)

Parameters

fileName

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members
Overload List


SaveTablesStructureToXml() Method

[image]
Intersoft WebGrid Documentation
SaveTablesStructureToXml() Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class > SaveTablesStructureToXml Method : SaveTablesStructureToXml() Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function SaveTablesStructureToXml() As System.Xml.XmlDocument
Visual Basic (Usage) Copy Code
Dim instance As WebGrid
Dim value As System.Xml.XmlDocument

value = instance.SaveTablesStructureToXml()
C#
public System.Xml.XmlDocument SaveTablesStructureToXml()
Delphi
public function SaveTablesStructureToXml(): System.Xml.XmlDocument;
JScript
public function SaveTablesStructureToXml() : System.Xml.XmlDocument;
Managed Extensions for C++
public: System.Xml.XmlDocument* SaveTablesStructureToXml();
C++/CLI
public:
System.Xml.XmlDocument^ SaveTablesStructureToXml();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members
Overload List


SerializeObjectData Method

[image]
Intersoft WebGrid Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebGrid
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure SerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function SerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void SerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void SerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members


SetCacheControl Method

[image]
Intersoft WebGrid Documentation
SetCacheControl Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class : SetCacheControl Method

duration
priority

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SetCacheControl( _
   ByVal duration As System.TimeSpan, _
   ByVal priority As System.Web.Caching.CacheItemPriority _
)
Visual Basic (Usage) Copy Code
Dim instance As WebGrid
Dim duration As System.TimeSpan
Dim priority As System.Web.Caching.CacheItemPriority

instance.SetCacheControl(duration, priority)
C#
public void SetCacheControl(
   System.TimeSpan duration,
   System.Web.Caching.CacheItemPriority priority
)
Delphi
public procedure SetCacheControl(
    duration: System.TimeSpan;
    priority: System.Web.Caching.CacheItemPriority
);
JScript
public function SetCacheControl(
   duration : System.TimeSpan,
   priority : System.Web.Caching.CacheItemPriority
);
Managed Extensions for C++
public: void SetCacheControl(
   System.TimeSpan duration,
   System.Web.Caching.CacheItemPriority priority
)
C++/CLI
public:
void SetCacheControl(
   System.TimeSpan duration,
   System.Web.Caching.CacheItemPriority priority
)

Parameters

duration
priority

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members


SetCurrentPageIndex Method

[image]
Intersoft WebGrid Documentation
SetCurrentPageIndex Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class : SetCurrentPageIndex Method

pageIndex

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SetCurrentPageIndex( _
   ByVal pageIndex As System.Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As WebGrid
Dim pageIndex As System.Integer

instance.SetCurrentPageIndex(pageIndex)
C#
public void SetCurrentPageIndex(
   System.int pageIndex
)
Delphi
public procedure SetCurrentPageIndex(
    pageIndex: System.Integer
);
JScript
public function SetCurrentPageIndex(
   pageIndex : System.int
);
Managed Extensions for C++
public: void SetCurrentPageIndex(
   System.int pageIndex
)
C++/CLI
public:
void SetCurrentPageIndex(
   System.int pageIndex
)

Parameters

pageIndex

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members


SetFocus Method

[image]
Intersoft WebGrid Documentation
SetFocus Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class : SetFocus Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SetFocus()
Visual Basic (Usage) Copy Code
Dim instance As WebGrid

instance.SetFocus()
C#
public void SetFocus()
Delphi
public procedure SetFocus();
JScript
public function SetFocus();
Managed Extensions for C++
public: void SetFocus();
C++/CLI
public:
void SetFocus();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members


SetObjectRelations Method

[image]
Intersoft WebGrid Documentation
SetObjectRelations Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class : SetObjectRelations Method

objectRelations
objectTypesInfo

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SetObjectRelations( _
   ByVal objectRelations As System.Collections.ArrayList, _
   ByVal objectTypesInfo As System.Collections.ArrayList _
)
Visual Basic (Usage) Copy Code
Dim instance As WebGrid
Dim objectRelations As System.Collections.ArrayList
Dim objectTypesInfo As System.Collections.ArrayList

instance.SetObjectRelations(objectRelations, objectTypesInfo)
C#
public void SetObjectRelations(
   System.Collections.ArrayList objectRelations,
   System.Collections.ArrayList objectTypesInfo
)
Delphi
public procedure SetObjectRelations(
    objectRelations: System.Collections.ArrayList;
    objectTypesInfo: System.Collections.ArrayList
);
JScript
public function SetObjectRelations(
   objectRelations : System.Collections.ArrayList,
   objectTypesInfo : System.Collections.ArrayList
);
Managed Extensions for C++
public: void SetObjectRelations(
   System.Collections.ArrayList* objectRelations,
   System.Collections.ArrayList* objectTypesInfo
)
C++/CLI
public:
void SetObjectRelations(
   System.Collections.ArrayList^ objectRelations,
   System.Collections.ArrayList^ objectTypesInfo
)

Parameters

objectRelations
objectTypesInfo

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members


SetOutputParameters Method

[image]
Intersoft WebGrid Documentation
SetOutputParameters Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class : SetOutputParameters Method

outputParameters

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SetOutputParameters( _
   ByVal outputParameters As System.Collections.IDictionary _
)
Visual Basic (Usage) Copy Code
Dim instance As WebGrid
Dim outputParameters As System.Collections.IDictionary

instance.SetOutputParameters(outputParameters)
C#
public void SetOutputParameters(
   System.Collections.IDictionary outputParameters
)
Delphi
public procedure SetOutputParameters(
    outputParameters: System.Collections.IDictionary
);
JScript
public function SetOutputParameters(
   outputParameters : System.Collections.IDictionary
);
Managed Extensions for C++
public: void SetOutputParameters(
   System.Collections.IDictionary* outputParameters
)
C++/CLI
public:
void SetOutputParameters(
   System.Collections.IDictionary^ outputParameters
)

Parameters

outputParameters

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members


SetRenderMethodDelegate Method

[image]
Intersoft WebGrid Documentation
SetRenderMethodDelegate Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class : SetRenderMethodDelegate Method

renderMethod

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Public Sub SetRenderMethodDelegate( _
   ByVal renderMethod As System.Web.UI.RenderMethod _
)
Visual Basic (Usage) Copy Code
Dim instance As WebGrid
Dim renderMethod As System.Web.UI.RenderMethod

instance.SetRenderMethodDelegate(renderMethod)
C#
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public void SetRenderMethodDelegate(
   System.Web.UI.RenderMethod renderMethod
)
Delphi
public procedure SetRenderMethodDelegate(
    renderMethod: System.Web.UI.RenderMethod
);
JScript
System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)
public function SetRenderMethodDelegate(
   renderMethod : System.Web.UI.RenderMethod
);
Managed Extensions for C++
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public: void SetRenderMethodDelegate(
   System.Web.UI.RenderMethod* renderMethod
)
C++/CLI
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public:
void SetRenderMethodDelegate(
   System.Web.UI.RenderMethod^ renderMethod
)

Parameters

renderMethod

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members


SetSelectedObject Method

[image]
Intersoft WebGrid Documentation
SetSelectedObject Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class : SetSelectedObject Method

selObj

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SetSelectedObject( _
   ByVal selObj As SelectedObject _
)
Visual Basic (Usage) Copy Code
Dim instance As WebGrid
Dim selObj As SelectedObject

instance.SetSelectedObject(selObj)
C#
public void SetSelectedObject(
   SelectedObject selObj
)
Delphi
public procedure SetSelectedObject(
    selObj: SelectedObject
);
JScript
public function SetSelectedObject(
   selObj : SelectedObject
);
Managed Extensions for C++
public: void SetSelectedObject(
   SelectedObject* selObj
)
C++/CLI
public:
void SetSelectedObject(
   SelectedObject^ selObj
)

Parameters

selObj

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members


SetSessionTheme Method

[image]
Intersoft WebGrid Documentation
SetSessionTheme Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class : SetSessionTheme Method

themeInfo

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SetSessionTheme( _
   ByVal themeInfo As ISNet.WebUI.ThemeInfo _
)
Visual Basic (Usage) Copy Code
Dim instance As WebGrid
Dim themeInfo As ISNet.WebUI.ThemeInfo

instance.SetSessionTheme(themeInfo)
C#
public void SetSessionTheme(
   ISNet.WebUI.ThemeInfo themeInfo
)
Delphi
public procedure SetSessionTheme(
    themeInfo: ISNet.WebUI.ThemeInfo
);
JScript
public function SetSessionTheme(
   themeInfo : ISNet.WebUI.ThemeInfo
);
Managed Extensions for C++
public: void SetSessionTheme(
   ISNet.WebUI.ThemeInfo* themeInfo
)
C++/CLI
public:
void SetSessionTheme(
   ISNet.WebUI.ThemeInfo^ themeInfo
)

Parameters

themeInfo

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members


ShouldReturnJson Method

[image]
Intersoft WebGrid Documentation
ShouldReturnJson Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class : ShouldReturnJson Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ShouldReturnJson() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebGrid
Dim value As System.Boolean

value = instance.ShouldReturnJson()
C#
public virtual System.bool ShouldReturnJson()
Delphi
public function ShouldReturnJson(): System.Boolean; virtual;
JScript
public function ShouldReturnJson() : System.boolean;
Managed Extensions for C++
public: virtual System.bool ShouldReturnJson();
C++/CLI
public:
virtual System.bool ShouldReturnJson();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members


SynchronizeTemplatesFrom Method

[image]
Intersoft WebGrid Documentation
SynchronizeTemplatesFrom Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class : SynchronizeTemplatesFrom Method

source

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SynchronizeTemplatesFrom( _
   ByVal source As ISNet.WebUI.ISNetControl _
)
Visual Basic (Usage) Copy Code
Dim instance As WebGrid
Dim source As ISNet.WebUI.ISNetControl

instance.SynchronizeTemplatesFrom(source)
C#
public void SynchronizeTemplatesFrom(
   ISNet.WebUI.ISNetControl source
)
Delphi
public procedure SynchronizeTemplatesFrom(
    source: ISNet.WebUI.ISNetControl
);
JScript
public function SynchronizeTemplatesFrom(
   source : ISNet.WebUI.ISNetControl
);
Managed Extensions for C++
public: void SynchronizeTemplatesFrom(
   ISNet.WebUI.ISNetControl* source
)
C++/CLI
public:
void SynchronizeTemplatesFrom(
   ISNet.WebUI.ISNetControl^ source
)

Parameters

source

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members


UpdateFileServerCache Method

[image]
Intersoft WebGrid Documentation
UpdateFileServerCache Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class : UpdateFileServerCache Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub UpdateFileServerCache()
Visual Basic (Usage) Copy Code
Dim instance As WebGrid

instance.UpdateFileServerCache()
C#
public void UpdateFileServerCache()
Delphi
public procedure UpdateFileServerCache();
JScript
public function UpdateFileServerCache();
Managed Extensions for C++
public: void UpdateFileServerCache();
C++/CLI
public:
void UpdateFileServerCache();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members


AccessKey Property

[image]
Intersoft WebGrid Documentation
AccessKey Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class : AccessKey Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Behavior")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
Public Overridable Property AccessKey As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebGrid
Dim value As System.String

instance.AccessKey = value

value = instance.AccessKey
C#
[System.ComponentModel.CategoryAttribute("Behavior")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public virtual System.string AccessKey {get; set;}
Delphi
public read-write property AccessKey: System.String; virtual;
JScript
System.ComponentModel.CategoryAttribute("Behavior")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
public function get,set AccessKey : System.String
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Behavior")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public: __property virtual System.string* get_AccessKey();
public: __property virtual void set_AccessKey(
   System.string* value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Behavior")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public:
virtual property System.String^ AccessKey {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members


WebGrid Class Properties

[image]
Intersoft WebGrid Documentation
WebGrid Class Properties
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : WebGrid Class

Glossary Item Box

For a list of all members of this type, see WebGrid members.

Public Properties

 | Name | Description
Public Property | AccessKey | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | AllowAutoDataCaching |
Public Property | AllowPivotCharting |
Public Property | BackColor | Overridden.
Public Property | BindingOperationMode |
Public Property | BorderColor | Overridden.
Public Property | BorderStyle | Overridden.
Public Property | BorderWidth | Overridden.
Public Property | BrowserPrintSettings |
Public Property | CacheServerConnection |
Public Property | CellPadding |
Public Property | ChartCategoryCollection |
Public Property | ChartDataCollection |
Public Property | ChartFilterCollection |
Public Property | ChartInteractiveUI |
Public Property | ChartMode |
Public Property | ChartSeriesCollection |
Public Property | ClientBindingSettings |
Public Property | ClientIDMode | (Inherited from System.Web.UI.Control)
Public Property | ControlDataTransferFormat | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | CustomSchemaRetrieval |
Public Property | DataCacheStorage |
Public Property | DataMember |
Public Property | DataSource |
Public Property | DataSourceID |
Public Property | DataSourceManager | Overridden.
Public Property | DefaultStyleMode |
Public Property | DisableFileSystemChecking |
Public Property | Enabled | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | EnableManagedTheming | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | EnableSection508Standards |
Public Property | EnableTheming | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | EnableV3XAPISupport |
Public Property | EnableViewState | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | EnableWebResources | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | FlyPostBackSettings |
Public Property | Font | Overridden.
Public Property | ForeColor | Overridden.
Public Property | GridLines |
Public Property | Height | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | ID | (Inherited from System.Web.UI.Control)
Public Property | ImageFileServer |
Public Property | LayoutSettings |
Public Property | Page | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | RenderingMode | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | RuntimeLicenseKey | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | ScriptDirectory | Overridden.
Public Property | SerializeTagToClient |
Public Property | Settings |
Public Property | SharedScriptDirectory | Overridden.
Public Property | SkinID | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | StateRestorationLevel |
Public Property | TabIndex | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | ToolTip | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | UseDefaultStyle |
Public Property | ValidateRequestMode | (Inherited from System.Web.UI.Control)
Public Property | ViewStateItems | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | ViewStateMode | (Inherited from System.Web.UI.Control)
Public Property | ViewStateServerConnection | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | ViewStateStorage | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | Visible | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | WebDesktopScriptDirectory |
Public Property | Width | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | XmlCompressionEnabled | (Inherited from ISNet.WebUI.ISNetControl)
Top

See Also

Reference

WebGrid Class
ISNet.WebUI.WebGrid Namespace


AllowAutoDataCaching Property

[image]
Intersoft WebGrid Documentation
AllowAutoDataCaching Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class : AllowAutoDataCaching Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies whether data caching is automatically handled by the control.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("Data")>
Public Property AllowAutoDataCaching As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebGrid
Dim value As System.Boolean

instance.AllowAutoDataCaching = value

value = instance.AllowAutoDataCaching
C#
[System.ComponentModel.DescriptionAttribute("Specifies whether data caching is automatically handled by the control.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Data")]
public System.bool AllowAutoDataCaching {get; set;}
Delphi
public read-write property AllowAutoDataCaching: System.Boolean;
JScript
System.ComponentModel.DescriptionAttribute("Specifies whether data caching is automatically handled by the control.")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("Data")
public function get,set AllowAutoDataCaching : System.boolean
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies whether data caching is automatically handled by the control.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Data")]
public: __property System.bool get_AllowAutoDataCaching();
public: __property void set_AllowAutoDataCaching(
   System.bool value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies whether data caching is automatically handled by the control.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Data")]
public:
property System.bool AllowAutoDataCaching {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members


AllowPivotCharting Property

[image]
Intersoft WebGrid Documentation
AllowPivotCharting Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class : AllowPivotCharting Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies whether users are allowed to switch to PivotChart View at runtime.")>
<System.ComponentModel.CategoryAttribute("Charting")>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Property AllowPivotCharting As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebGrid
Dim value As System.Boolean

instance.AllowPivotCharting = value

value = instance.AllowPivotCharting
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether users are allowed to switch to PivotChart View at runtime.")]
[System.ComponentModel.CategoryAttribute("Charting")]
[ISNet.Serialization.XmlSerializableAttribute()]
public System.bool AllowPivotCharting {get; set;}
Delphi
public read-write property AllowPivotCharting: System.Boolean;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Specifies whether users are allowed to switch to PivotChart View at runtime.")
System.ComponentModel.CategoryAttribute("Charting")
ISNet.Serialization.XmlSerializableAttribute()
public function get,set AllowPivotCharting : System.boolean
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether users are allowed to switch to PivotChart View at runtime.")]
[System.ComponentModel.CategoryAttribute("Charting")]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property System.bool get_AllowPivotCharting();
public: __property void set_AllowPivotCharting(
   System.bool value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether users are allowed to switch to PivotChart View at runtime.")]
[System.ComponentModel.CategoryAttribute("Charting")]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property System.bool AllowPivotCharting {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members


BackColor Property

[image]
Intersoft WebGrid Documentation
BackColor Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class : BackColor Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Appearance")>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
Public Overrides Property BackColor As System.Drawing.Color
Visual Basic (Usage) Copy Code
Dim instance As WebGrid
Dim value As System.Drawing.Color

instance.BackColor = value

value = instance.BackColor
C#
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
public override System.Drawing.Color BackColor {get; set;}
Delphi
public read-write property BackColor: System.Drawing.Color; override;
JScript
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Appearance")
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
public override function get,set BackColor : System.Drawing.Color
Managed Extensions for C++
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
public: __property System.Drawing.Color get_BackColor() override;
public: __property void set_BackColor(
   System.Drawing.Color value
) override;
C++/CLI
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
public:
property System.Drawing.Color BackColor {
   System.Drawing.Color get() override;
   void set (    System.Drawing.Color value) override;
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members


BindingOperationMode Property

[image]
Intersoft WebGrid Documentation
BindingOperationMode Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class : BindingOperationMode Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Data")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Gets or sets the control operation mode for data binding.")>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Property BindingOperationMode As ISNet.WebUI.BindingMode
Visual Basic (Usage) Copy Code
Dim instance As WebGrid
Dim value As ISNet.WebUI.BindingMode

instance.BindingOperationMode = value

value = instance.BindingOperationMode
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Data")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the control operation mode for data binding.")]
[ISNet.Serialization.XmlSerializableAttribute()]
public ISNet.WebUI.BindingMode BindingOperationMode {get; set;}
Delphi
public read-write property BindingOperationMode: ISNet.WebUI.BindingMode;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Data")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the control operation mode for data binding.")
ISNet.Serialization.XmlSerializableAttribute()
public function get,set BindingOperationMode : ISNet.WebUI.BindingMode
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Data")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the control operation mode for data binding.")]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property ISNet.WebUI.BindingMode get_BindingOperationMode();
public: __property void set_BindingOperationMode(
   ISNet.WebUI.BindingMode value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Data")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the control operation mode for data binding.")]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property ISNet.WebUI.BindingMode BindingOperationMode {
   ISNet.WebUI.BindingMode get();
   void set (    ISNet.WebUI.BindingMode value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members


BorderColor Property

[image]
Intersoft WebGrid Documentation
BorderColor Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class : BorderColor Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<System.ComponentModel.CategoryAttribute("Appearance")>
Public Overrides Property BorderColor As System.Drawing.Color
Visual Basic (Usage) Copy Code
Dim instance As WebGrid
Dim value As System.Drawing.Color

instance.BorderColor = value

value = instance.BorderColor
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.CategoryAttribute("Appearance")]
public override System.Drawing.Color BorderColor {get; set;}
Delphi
public read-write property BorderColor: System.Drawing.Color; override;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
System.ComponentModel.CategoryAttribute("Appearance")
public override function get,set BorderColor : System.Drawing.Color
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.CategoryAttribute("Appearance")]
public: __property System.Drawing.Color get_BorderColor() override;
public: __property void set_BorderColor(
   System.Drawing.Color value
) override;
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.CategoryAttribute("Appearance")]
public:
property System.Drawing.Color BorderColor {
   System.Drawing.Color get() override;
   void set (    System.Drawing.Color value) override;
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members


BorderStyle Property

[image]
Intersoft WebGrid Documentation
BorderStyle Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class : BorderStyle Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Appearance")>
Public Overrides Property BorderStyle As System.Web.UI.WebControls.BorderStyle
Visual Basic (Usage) Copy Code
Dim instance As WebGrid
Dim value As System.Web.UI.WebControls.BorderStyle

instance.BorderStyle = value

value = instance.BorderStyle
C#
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Appearance")]
public override System.Web.UI.WebControls.BorderStyle BorderStyle {get; set;}
Delphi
public read-write property BorderStyle: System.Web.UI.WebControls.BorderStyle; override;
JScript
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Appearance")
public override function get,set BorderStyle : System.Web.UI.WebControls.BorderStyle
Managed Extensions for C++
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Appearance")]
public: __property System.Web.UI.WebControls.BorderStyle get_BorderStyle() override;
public: __property void set_BorderStyle(
   System.Web.UI.WebControls.BorderStyle value
) override;
C++/CLI
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Appearance")]
public:
property System.Web.UI.WebControls.BorderStyle BorderStyle {
   System.Web.UI.WebControls.BorderStyle get() override;
   void set (    System.Web.UI.WebControls.BorderStyle value) override;
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members


BorderWidth Property

[image]
Intersoft WebGrid Documentation
BorderWidth Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class : BorderWidth Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Appearance")>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Overrides Property BorderWidth As System.Web.UI.WebControls.Unit
Visual Basic (Usage) Copy Code
Dim instance As WebGrid
Dim value As System.Web.UI.WebControls.Unit

instance.BorderWidth = value

value = instance.BorderWidth
C#
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public override System.Web.UI.WebControls.Unit BorderWidth {get; set;}
Delphi
public read-write property BorderWidth: System.Web.UI.WebControls.Unit; override;
JScript
System.ComponentModel.CategoryAttribute("Appearance")
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
System.ComponentModel.NotifyParentPropertyAttribute()
public override function get,set BorderWidth : System.Web.UI.WebControls.Unit
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.Web.UI.WebControls.Unit get_BorderWidth() override;
public: __property void set_BorderWidth(
   System.Web.UI.WebControls.Unit value
) override;
C++/CLI
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.Web.UI.WebControls.Unit BorderWidth {
   System.Web.UI.WebControls.Unit get() override;
   void set (    System.Web.UI.WebControls.Unit value) override;
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members


BrowserPrintSettings Property

[image]
Intersoft WebGrid Documentation
BrowserPrintSettings Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class : BrowserPrintSettings Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Contains settings applied to the Grid when printed directly from browser.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.CategoryAttribute("Behavior")>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)>
<ISNet.Serialization.XmlSerializableAttribute(True)>
Public Property BrowserPrintSettings As BrowserPrintSettings
Visual Basic (Usage) Copy Code
Dim instance As WebGrid
Dim value As BrowserPrintSettings

instance.BrowserPrintSettings = value

value = instance.BrowserPrintSettings
C#
[System.ComponentModel.DescriptionAttribute("Contains settings applied to the Grid when printed directly from browser.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[ISNet.Serialization.XmlSerializableAttribute(true)]
public BrowserPrintSettings BrowserPrintSettings {get; set;}
Delphi
public read-write property BrowserPrintSettings: BrowserPrintSettings;
JScript
System.ComponentModel.DescriptionAttribute("Contains settings applied to the Grid when printed directly from browser.")
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.CategoryAttribute("Behavior")
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)
ISNet.Serialization.XmlSerializableAttribute()
public function get,set BrowserPrintSettings : BrowserPrintSettings
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Contains settings applied to the Grid when printed directly from browser.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[ISNet.Serialization.XmlSerializableAttribute(true)]
public: __property BrowserPrintSettings* get_BrowserPrintSettings();
public: __property void set_BrowserPrintSettings(
   BrowserPrintSettings* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Contains settings applied to the Grid when printed directly from browser.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[ISNet.Serialization.XmlSerializableAttribute(true)]
public:
property BrowserPrintSettings^ BrowserPrintSettings {
   BrowserPrintSettings^ get();
   void set (    BrowserPrintSettings^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members


CacheServerConnection Property

[image]
Intersoft WebGrid Documentation
CacheServerConnection Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class : CacheServerConnection Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies the file server connection string to store data cache.")>
<System.ComponentModel.CategoryAttribute("Data")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
Public Property CacheServerConnection As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebGrid
Dim value As System.String

instance.CacheServerConnection = value

value = instance.CacheServerConnection
C#
[System.ComponentModel.DescriptionAttribute("Specifies the file server connection string to store data cache.")]
[System.ComponentModel.CategoryAttribute("Data")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public System.string CacheServerConnection {get; set;}
Delphi
public read-write property CacheServerConnection: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Specifies the file server connection string to store data cache.")
System.ComponentModel.CategoryAttribute("Data")
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
public function get,set CacheServerConnection : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies the file server connection string to store data cache.")]
[System.ComponentModel.CategoryAttribute("Data")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.string* get_CacheServerConnection();
public: __property void set_CacheServerConnection(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies the file server connection string to store data cache.")]
[System.ComponentModel.CategoryAttribute("Data")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.String^ CacheServerConnection {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members


CellPadding Property

[image]
Intersoft WebGrid Documentation
CellPadding Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class : CellPadding Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("Appearance")>
Public Property CellPadding As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebGrid
Dim value As System.Integer

instance.CellPadding = value

value = instance.CellPadding
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Appearance")]
public System.int CellPadding {get; set;}
Delphi
public read-write property CellPadding: System.Integer;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("Appearance")
public function get,set CellPadding : System.int
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Appearance")]
public: __property System.int get_CellPadding();
public: __property void set_CellPadding(
   System.int value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Appearance")]
public:
property System.int CellPadding {
   System.int get();
   void set (    System.int value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members


ChartCategoryCollection Property

[image]
Intersoft WebGrid Documentation
ChartCategoryCollection Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class : ChartCategoryCollection Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("The category collection used by Pivot Charting.")>
<System.ComponentModel.CategoryAttribute("Charting")>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute("setChartCategoryCollection")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
Public ReadOnly Property ChartCategoryCollection As ChartPivotFilterConfigCollection
Visual Basic (Usage) Copy Code
Dim instance As WebGrid
Dim value As ChartPivotFilterConfigCollection

value = instance.ChartCategoryCollection
C#
[System.ComponentModel.DescriptionAttribute("The category collection used by Pivot Charting.")]
[System.ComponentModel.CategoryAttribute("Charting")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute("setChartCategoryCollection")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
public ChartPivotFilterConfigCollection ChartCategoryCollection {get;}
Delphi
public read-only property ChartCategoryCollection: ChartPivotFilterConfigCollection;
JScript
System.ComponentModel.DescriptionAttribute("The category collection used by Pivot Charting.")
System.ComponentModel.CategoryAttribute("Charting")
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute("setChartCategoryCollection")
System.ComponentModel.NotifyParentPropertyAttribute()
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
public function get ChartCategoryCollection : ChartPivotFilterConfigCollection
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("The category collection used by Pivot Charting.")]
[System.ComponentModel.CategoryAttribute("Charting")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute("setChartCategoryCollection")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
public: __property ChartPivotFilterConfigCollection* get_ChartCategoryCollection();
C++/CLI
[System.ComponentModel.DescriptionAttribute("The category collection used by Pivot Charting.")]
[System.ComponentModel.CategoryAttribute("Charting")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute("setChartCategoryCollection")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
public:
property ChartPivotFilterConfigCollection^ ChartCategoryCollection {
   ChartPivotFilterConfigCollection^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members


ChartDataCollection Property

[image]
Intersoft WebGrid Documentation
ChartDataCollection Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class : ChartDataCollection Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("The data collection used by Pivot Charting.")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("Charting")>
<ISNet.Serialization.XmlSerializableAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute("setChartDataCollection")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
Public ReadOnly Property ChartDataCollection As ChartPivotDataConfigCollection
Visual Basic (Usage) Copy Code
Dim instance As WebGrid
Dim value As ChartPivotDataConfigCollection

value = instance.ChartDataCollection
C#
[System.ComponentModel.DescriptionAttribute("The data collection used by Pivot Charting.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Charting")]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute("setChartDataCollection")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
public ChartPivotDataConfigCollection ChartDataCollection {get;}
Delphi
public read-only property ChartDataCollection: ChartPivotDataConfigCollection;
JScript
System.ComponentModel.DescriptionAttribute("The data collection used by Pivot Charting.")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("Charting")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute("setChartDataCollection")
System.ComponentModel.NotifyParentPropertyAttribute()
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
public function get ChartDataCollection : ChartPivotDataConfigCollection
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("The data collection used by Pivot Charting.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Charting")]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute("setChartDataCollection")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
public: __property ChartPivotDataConfigCollection* get_ChartDataCollection();
C++/CLI
[System.ComponentModel.DescriptionAttribute("The data collection used by Pivot Charting.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Charting")]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute("setChartDataCollection")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
public:
property ChartPivotDataConfigCollection^ ChartDataCollection {
   ChartPivotDataConfigCollection^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members


ChartFilterCollection Property

[image]
Intersoft WebGrid Documentation
ChartFilterCollection Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class : ChartFilterCollection Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("The filter collection used by Pivot Charting.")>
<ISNet.Serialization.XmlSerializableAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute("setChartFilterCollection")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.CategoryAttribute("Charting")>
Public ReadOnly Property ChartFilterCollection As ChartPivotFilterConfigCollection
Visual Basic (Usage) Copy Code
Dim instance As WebGrid
Dim value As ChartPivotFilterConfigCollection

value = instance.ChartFilterCollection
C#
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("The filter collection used by Pivot Charting.")]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute("setChartFilterCollection")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.CategoryAttribute("Charting")]
public ChartPivotFilterConfigCollection ChartFilterCollection {get;}
Delphi
public read-only property ChartFilterCollection: ChartPivotFilterConfigCollection;
JScript
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("The filter collection used by Pivot Charting.")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute("setChartFilterCollection")
System.ComponentModel.NotifyParentPropertyAttribute()
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.CategoryAttribute("Charting")
public function get ChartFilterCollection : ChartPivotFilterConfigCollection
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("The filter collection used by Pivot Charting.")]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute("setChartFilterCollection")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.CategoryAttribute("Charting")]
public: __property ChartPivotFilterConfigCollection* get_ChartFilterCollection();
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("The filter collection used by Pivot Charting.")]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute("setChartFilterCollection")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.CategoryAttribute("Charting")]
public:
property ChartPivotFilterConfigCollection^ ChartFilterCollection {
   ChartPivotFilterConfigCollection^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members


ChartInteractiveUI Property

[image]
Intersoft WebGrid Documentation
ChartInteractiveUI Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class : ChartInteractiveUI Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute("setChartInteractiveUI")>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.CategoryAttribute("Charting")>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)>
<ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Contains the settings for Charting Interactive UI")>
<System.ComponentModel.DefaultValueAttribute()>
Public ReadOnly Property ChartInteractiveUI As ChartInteractiveUISettings
Visual Basic (Usage) Copy Code
Dim instance As WebGrid
Dim value As ChartInteractiveUISettings

value = instance.ChartInteractiveUI
C#
[ISNet.Serialization.BinarySerializableAttribute("setChartInteractiveUI")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.CategoryAttribute("Charting")]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Contains the settings for Charting Interactive UI")]
[System.ComponentModel.DefaultValueAttribute()]
public ChartInteractiveUISettings ChartInteractiveUI {get;}
Delphi
public read-only property ChartInteractiveUI: ChartInteractiveUISettings;
JScript
ISNet.Serialization.BinarySerializableAttribute("setChartInteractiveUI")
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.CategoryAttribute("Charting")
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)
ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Contains the settings for Charting Interactive UI")
System.ComponentModel.DefaultValueAttribute()
public function get ChartInteractiveUI : ChartInteractiveUISettings
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute("setChartInteractiveUI")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.CategoryAttribute("Charting")]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Contains the settings for Charting Interactive UI")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property ChartInteractiveUISettings* get_ChartInteractiveUI();
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute("setChartInteractiveUI")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.CategoryAttribute("Charting")]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Contains the settings for Charting Interactive UI")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property ChartInteractiveUISettings^ ChartInteractiveUI {
   ChartInteractiveUISettings^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members


ChartMode Property

[image]
Intersoft WebGrid Documentation
ChartMode Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class : ChartMode Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies the mode of the Pivot Charting.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Charting")>
Public Property ChartMode As ChartMode
Visual Basic (Usage) Copy Code
Dim instance As WebGrid
Dim value As ChartMode

instance.ChartMode = value

value = instance.ChartMode
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the mode of the Pivot Charting.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Charting")]
public ChartMode ChartMode {get; set;}
Delphi
public read-write property ChartMode: ChartMode;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the mode of the Pivot Charting.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Charting")
public function get,set ChartMode : ChartMode
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the mode of the Pivot Charting.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Charting")]
public: __property ChartMode get_ChartMode();
public: __property void set_ChartMode(
   ChartMode value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the mode of the Pivot Charting.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Charting")]
public:
property ChartMode ChartMode {
   ChartMode get();
   void set (    ChartMode value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members


ChartSeriesCollection Property

[image]
Intersoft WebGrid Documentation
ChartSeriesCollection Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class : ChartSeriesCollection Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("The series collection used by Pivot Charting.")>
<ISNet.Serialization.XmlSerializableAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute("setChartSeriesCollection")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.CategoryAttribute("Charting")>
<System.ComponentModel.DefaultValueAttribute()>
Public ReadOnly Property ChartSeriesCollection As ChartPivotFilterConfigCollection
Visual Basic (Usage) Copy Code
Dim instance As WebGrid
Dim value As ChartPivotFilterConfigCollection

value = instance.ChartSeriesCollection
C#
[System.ComponentModel.DescriptionAttribute("The series collection used by Pivot Charting.")]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute("setChartSeriesCollection")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.CategoryAttribute("Charting")]
[System.ComponentModel.DefaultValueAttribute()]
public ChartPivotFilterConfigCollection ChartSeriesCollection {get;}
Delphi
public read-only property ChartSeriesCollection: ChartPivotFilterConfigCollection;
JScript
System.ComponentModel.DescriptionAttribute("The series collection used by Pivot Charting.")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute("setChartSeriesCollection")
System.ComponentModel.NotifyParentPropertyAttribute()
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.CategoryAttribute("Charting")
System.ComponentModel.DefaultValueAttribute()
public function get ChartSeriesCollection : ChartPivotFilterConfigCollection
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("The series collection used by Pivot Charting.")]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute("setChartSeriesCollection")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.CategoryAttribute("Charting")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property ChartPivotFilterConfigCollection* get_ChartSeriesCollection();
C++/CLI
[System.ComponentModel.DescriptionAttribute("The series collection used by Pivot Charting.")]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute("setChartSeriesCollection")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.CategoryAttribute("Charting")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property ChartPivotFilterConfigCollection^ ChartSeriesCollection {
   ChartPivotFilterConfigCollection^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members


ClientBindingSettings Property

[image]
Intersoft WebGrid Documentation
ClientBindingSettings Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class : ClientBindingSettings Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Provides settings for client data binding.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute("setClientBindingSettings")>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.CategoryAttribute("Data")>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<ISNet.Serialization.XmlSerializableAttribute(Type=XmlSerializationType.ClientAndLayout, DiscardEmptyObject=True)>
Public ReadOnly Property ClientBindingSettings As WebGridClientBindingSettings
Visual Basic (Usage) Copy Code
Dim instance As WebGrid
Dim value As WebGridClientBindingSettings

value = instance.ClientBindingSettings
C#
[System.ComponentModel.DescriptionAttribute("Provides settings for client data binding.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute("setClientBindingSettings")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.CategoryAttribute("Data")]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.Serialization.XmlSerializableAttribute(Type=XmlSerializationType.ClientAndLayout, DiscardEmptyObject=true)]
public WebGridClientBindingSettings ClientBindingSettings {get;}
Delphi
public read-only property ClientBindingSettings: WebGridClientBindingSettings;
JScript
System.ComponentModel.DescriptionAttribute("Provides settings for client data binding.")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute("setClientBindingSettings")
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.CategoryAttribute("Data")
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
ISNet.Serialization.XmlSerializableAttribute(Type=XmlSerializationType.ClientAndLayout, DiscardEmptyObject=)
public function get ClientBindingSettings : WebGridClientBindingSettings
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Provides settings for client data binding.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute("setClientBindingSettings")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.CategoryAttribute("Data")]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.Serialization.XmlSerializableAttribute(Type=XmlSerializationType.ClientAndLayout, DiscardEmptyObject=true)]
public: __property WebGridClientBindingSettings* get_ClientBindingSettings();
C++/CLI
[System.ComponentModel.DescriptionAttribute("Provides settings for client data binding.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute("setClientBindingSettings")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.CategoryAttribute("Data")]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.Serialization.XmlSerializableAttribute(Type=XmlSerializationType.ClientAndLayout, DiscardEmptyObject=true)]
public:
property WebGridClientBindingSettings^ ClientBindingSettings {
   WebGridClientBindingSettings^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members


ClientIDMode Property

[image]
Intersoft WebGrid Documentation
ClientIDMode Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class : ClientIDMode Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Web.UI.ThemeableAttribute(False)>
<System.ComponentModel.DefaultValueAttribute()>
<WebCategoryAttribute("Behavior")>
<WebSysDescriptionAttribute("Indicates how the ClientID should be generated for the control.")>
Public Overridable Property ClientIDMode As System.Web.UI.ClientIDMode
Visual Basic (Usage) Copy Code
Dim instance As WebGrid
Dim value As System.Web.UI.ClientIDMode

instance.ClientIDMode = value

value = instance.ClientIDMode
C#
[System.Web.UI.ThemeableAttribute(false)]
[System.ComponentModel.DefaultValueAttribute()]
[WebCategoryAttribute("Behavior")]
[WebSysDescriptionAttribute("Indicates how the ClientID should be generated for the control.")]
public virtual System.Web.UI.ClientIDMode ClientIDMode {get; set;}
Delphi
public read-write property ClientIDMode: System.Web.UI.ClientIDMode; virtual;
JScript
System.Web.UI.ThemeableAttribute()
System.ComponentModel.DefaultValueAttribute()
WebCategoryAttribute("Behavior")
WebSysDescriptionAttribute("Indicates how the ClientID should be generated for the control.")
public function get,set ClientIDMode : System.Web.UI.ClientIDMode
Managed Extensions for C++
[System.Web.UI.ThemeableAttribute(false)]
[System.ComponentModel.DefaultValueAttribute()]
[WebCategoryAttribute("Behavior")]
[WebSysDescriptionAttribute("Indicates how the ClientID should be generated for the control.")]
public: __property virtual System.Web.UI.ClientIDMode get_ClientIDMode();
public: __property virtual void set_ClientIDMode(
   System.Web.UI.ClientIDMode value
);
C++/CLI
[System.Web.UI.ThemeableAttribute(false)]
[System.ComponentModel.DefaultValueAttribute()]
[WebCategoryAttribute("Behavior")]
[WebSysDescriptionAttribute("Indicates how the ClientID should be generated for the control.")]
public:
virtual property System.Web.UI.ClientIDMode ClientIDMode {
   System.Web.UI.ClientIDMode get();
   void set (    System.Web.UI.ClientIDMode value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members


ControlDataTransferFormat Property

[image]
Intersoft WebGrid Documentation
ControlDataTransferFormat Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class : ControlDataTransferFormat Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Gets or sets a value that determines the format used to exchange the control's data across client and server.")>
<System.ComponentModel.CategoryAttribute("Behavior")>
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Overridable Property ControlDataTransferFormat As ISNet.WebUI.DataTransferFormat
Visual Basic (Usage) Copy Code
Dim instance As WebGrid
Dim value As ISNet.WebUI.DataTransferFormat

instance.ControlDataTransferFormat = value

value = instance.ControlDataTransferFormat
C#
[System.ComponentModel.DescriptionAttribute("Gets or sets a value that determines the format used to exchange the control's data across client and server.")]
[System.ComponentModel.CategoryAttribute("Behavior")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public virtual ISNet.WebUI.DataTransferFormat ControlDataTransferFormat {get; set;}
Delphi
public read-write property ControlDataTransferFormat: ISNet.WebUI.DataTransferFormat; virtual;
JScript
System.ComponentModel.DescriptionAttribute("Gets or sets a value that determines the format used to exchange the control's data across client and server.")
System.ComponentModel.CategoryAttribute("Behavior")
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set ControlDataTransferFormat : ISNet.WebUI.DataTransferFormat
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Gets or sets a value that determines the format used to exchange the control's data across client and server.")]
[System.ComponentModel.CategoryAttribute("Behavior")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property virtual ISNet.WebUI.DataTransferFormat get_ControlDataTransferFormat();
public: __property virtual void set_ControlDataTransferFormat(
   ISNet.WebUI.DataTransferFormat value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Gets or sets a value that determines the format used to exchange the control's data across client and server.")]
[System.ComponentModel.CategoryAttribute("Behavior")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
virtual property ISNet.WebUI.DataTransferFormat ControlDataTransferFormat {
   ISNet.WebUI.DataTransferFormat get();
   void set (    ISNet.WebUI.DataTransferFormat value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members


CustomSchemaRetrieval Property

[image]
Intersoft WebGrid Documentation
CustomSchemaRetrieval Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class : CustomSchemaRetrieval Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Data")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("When DataSourceID is connected to custom object via ISDataSource, this property determines how the custom object's schema should be retrieved.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property CustomSchemaRetrieval As SchemaRetrievalMode
Visual Basic (Usage) Copy Code
Dim instance As WebGrid
Dim value As SchemaRetrievalMode

instance.CustomSchemaRetrieval = value

value = instance.CustomSchemaRetrieval
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Data")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("When DataSourceID is connected to custom object via ISDataSource, this property determines how the custom object's schema should be retrieved.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public SchemaRetrievalMode CustomSchemaRetrieval {get; set;}
Delphi
public read-write property CustomSchemaRetrieval: SchemaRetrievalMode;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Data")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("When DataSourceID is connected to custom object via ISDataSource, this property determines how the custom object's schema should be retrieved.")
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set CustomSchemaRetrieval : SchemaRetrievalMode
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Data")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("When DataSourceID is connected to custom object via ISDataSource, this property determines how the custom object's schema should be retrieved.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property SchemaRetrievalMode get_CustomSchemaRetrieval();
public: __property void set_CustomSchemaRetrieval(
   SchemaRetrievalMode value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Data")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("When DataSourceID is connected to custom object via ISDataSource, this property determines how the custom object's schema should be retrieved.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property SchemaRetrievalMode CustomSchemaRetrieval {
   SchemaRetrievalMode get();
   void set (    SchemaRetrievalMode value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members


DataCacheStorage Property

[image]
Intersoft WebGrid Documentation
DataCacheStorage Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class : DataCacheStorage Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Data")>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies where to store the data cache.")>
Public Property DataCacheStorage As ISNet.WebUI.CacheStorage
Visual Basic (Usage) Copy Code
Dim instance As WebGrid
Dim value As ISNet.WebUI.CacheStorage

instance.DataCacheStorage = value

value = instance.DataCacheStorage
C#
[System.ComponentModel.CategoryAttribute("Data")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies where to store the data cache.")]
public ISNet.WebUI.CacheStorage DataCacheStorage {get; set;}
Delphi
public read-write property DataCacheStorage: ISNet.WebUI.CacheStorage;
JScript
System.ComponentModel.CategoryAttribute("Data")
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DescriptionAttribute("Specifies where to store the data cache.")
public function get,set DataCacheStorage : ISNet.WebUI.CacheStorage
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Data")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies where to store the data cache.")]
public: __property ISNet.WebUI.CacheStorage get_DataCacheStorage();
public: __property void set_DataCacheStorage(
   ISNet.WebUI.CacheStorage value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Data")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies where to store the data cache.")]
public:
property ISNet.WebUI.CacheStorage DataCacheStorage {
   ISNet.WebUI.CacheStorage get();
   void set (    ISNet.WebUI.CacheStorage value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members


DataMember Property

[image]
Intersoft WebGrid Documentation
DataMember Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class : DataMember Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.PersistLayoutAttribute(False)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Data")>
<System.ComponentModel.DescriptionAttribute("Gets or sets the datamember of the grid.")>
Public Property DataMember As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebGrid
Dim value As System.String

instance.DataMember = value

value = instance.DataMember
C#
[ISNet.PersistLayoutAttribute(false)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Data")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the datamember of the grid.")]
public System.string DataMember {get; set;}
Delphi
public read-write property DataMember: System.String;
JScript
ISNet.PersistLayoutAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Data")
System.ComponentModel.DescriptionAttribute("Gets or sets the datamember of the grid.")
public function get,set DataMember : System.String
Managed Extensions for C++
[ISNet.PersistLayoutAttribute(false)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Data")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the datamember of the grid.")]
public: __property System.string* get_DataMember();
public: __property void set_DataMember(
   System.string* value
);
C++/CLI
[ISNet.PersistLayoutAttribute(false)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Data")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the datamember of the grid.")]
public:
property System.String^ DataMember {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members


DataSource Property

[image]
Intersoft WebGrid Documentation
DataSource Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class : DataSource Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Data")>
<System.ComponentModel.DescriptionAttribute("Gets or sets the datasource of the grid")>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
<System.ComponentModel.DefaultValueAttribute()>
Public Overridable Property DataSource As System.Object
Visual Basic (Usage) Copy Code
Dim instance As WebGrid
Dim value As System.Object

instance.DataSource = value

value = instance.DataSource
C#
[System.ComponentModel.CategoryAttribute("Data")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the datasource of the grid")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.DefaultValueAttribute()]
public virtual System.object DataSource {get; set;}
Delphi
public read-write property DataSource: System.TObject; virtual;
JScript
System.ComponentModel.CategoryAttribute("Data")
System.ComponentModel.DescriptionAttribute("Gets or sets the datasource of the grid")
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
System.ComponentModel.DefaultValueAttribute()
public function get,set DataSource : System.Object
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Data")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the datasource of the grid")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.DefaultValueAttribute()]
public: __property virtual System.Object* get_DataSource();
public: __property virtual void set_DataSource(
   System.Object* value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Data")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the datasource of the grid")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.DefaultValueAttribute()]
public:
virtual property System.Object^ DataSource {
   System.Object^ get();
   void set (    System.Object^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members


DataSourceID Property

[image]
Intersoft WebGrid Documentation
DataSourceID Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class : DataSourceID Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Data")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Gets or sets the ID of the control from which the WebGrid control retrieves its list of data rows.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.Web.UI.IDReferencePropertyAttribute(System.Web.UI.DataSourceControl)>
Public Property DataSourceID As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebGrid
Dim value As System.String

instance.DataSourceID = value

value = instance.DataSourceID
C#
[System.ComponentModel.CategoryAttribute("Data")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the ID of the control from which the WebGrid control retrieves its list of data rows.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.Web.UI.IDReferencePropertyAttribute(System.Web.UI.DataSourceControl)]
public System.string DataSourceID {get; set;}
Delphi
public read-write property DataSourceID: System.String;
JScript
System.ComponentModel.CategoryAttribute("Data")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the ID of the control from which the WebGrid control retrieves its list of data rows.")
ISNet.Serialization.BinarySerializableAttribute()
System.Web.UI.IDReferencePropertyAttribute(System.Web.UI.DataSourceControl)
public function get,set DataSourceID : System.String
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Data")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the ID of the control from which the WebGrid control retrieves its list of data rows.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.Web.UI.IDReferencePropertyAttribute(System.Web.UI.DataSourceControl)]
public: __property System.string* get_DataSourceID();
public: __property void set_DataSourceID(
   System.string* value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Data")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the ID of the control from which the WebGrid control retrieves its list of data rows.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.Web.UI.IDReferencePropertyAttribute(System.Web.UI.DataSourceControl)]
public:
property System.String^ DataSourceID {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members


DataSourceManager Property

[image]
Intersoft WebGrid Documentation
DataSourceManager Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class : DataSourceManager Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property DataSourceManager As ISNet.WebUI.DataSourceInfo
Visual Basic (Usage) Copy Code
Dim instance As WebGrid
Dim value As ISNet.WebUI.DataSourceInfo

value = instance.DataSourceManager
C#
public override ISNet.WebUI.DataSourceInfo DataSourceManager {get;}
Delphi
public read-only property DataSourceManager: ISNet.WebUI.DataSourceInfo; override;
JScript
public override function get DataSourceManager : ISNet.WebUI.DataSourceInfo
Managed Extensions for C++
public: __property ISNet.WebUI.DataSourceInfo* get_DataSourceManager() override;
C++/CLI
public:
property ISNet.WebUI.DataSourceInfo^ DataSourceManager {
   ISNet.WebUI.DataSourceInfo^ get() override;
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members


DefaultStyleMode Property

[image]
Intersoft WebGrid Documentation
DefaultStyleMode Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class : DefaultStyleMode Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Gets or sets a value that determine the mode of the default style when UseDefaultStyle is enabled.")>
<System.ComponentModel.CategoryAttribute("Appearance")>
Public Property DefaultStyleMode As DefaultStyleKind
Visual Basic (Usage) Copy Code
Dim instance As WebGrid
Dim value As DefaultStyleKind

instance.DefaultStyleMode = value

value = instance.DefaultStyleMode
C#
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets a value that determine the mode of the default style when UseDefaultStyle is enabled.")]
[System.ComponentModel.CategoryAttribute("Appearance")]
public DefaultStyleKind DefaultStyleMode {get; set;}
Delphi
public read-write property DefaultStyleMode: DefaultStyleKind;
JScript
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets a value that determine the mode of the default style when UseDefaultStyle is enabled.")
System.ComponentModel.CategoryAttribute("Appearance")
public function get,set DefaultStyleMode : DefaultStyleKind
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets a value that determine the mode of the default style when UseDefaultStyle is enabled.")]
[System.ComponentModel.CategoryAttribute("Appearance")]
public: __property DefaultStyleKind get_DefaultStyleMode();
public: __property void set_DefaultStyleMode(
   DefaultStyleKind value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets a value that determine the mode of the default style when UseDefaultStyle is enabled.")]
[System.ComponentModel.CategoryAttribute("Appearance")]
public:
property DefaultStyleKind DefaultStyleMode {
   DefaultStyleKind get();
   void set (    DefaultStyleKind value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members


DisableFileSystemChecking Property

[image]
Intersoft WebGrid Documentation
DisableFileSystemChecking Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class : DisableFileSystemChecking Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Specifies whether file system constraint checking should be disabled. This is an advanced setting, please consider to use this option carefully.")>
<System.ComponentModel.CategoryAttribute("Web Resources")>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Property DisableFileSystemChecking As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebGrid
Dim value As System.Boolean

instance.DisableFileSystemChecking = value

value = instance.DisableFileSystemChecking
C#
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies whether file system constraint checking should be disabled. This is an advanced setting, please consider to use this option carefully.")]
[System.ComponentModel.CategoryAttribute("Web Resources")]
[ISNet.Serialization.XmlSerializableAttribute()]
public System.bool DisableFileSystemChecking {get; set;}
Delphi
public read-write property DisableFileSystemChecking: System.Boolean;
JScript
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Specifies whether file system constraint checking should be disabled. This is an advanced setting, please consider to use this option carefully.")
System.ComponentModel.CategoryAttribute("Web Resources")
ISNet.Serialization.XmlSerializableAttribute()
public function get,set DisableFileSystemChecking : System.boolean
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies whether file system constraint checking should be disabled. This is an advanced setting, please consider to use this option carefully.")]
[System.ComponentModel.CategoryAttribute("Web Resources")]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property System.bool get_DisableFileSystemChecking();
public: __property void set_DisableFileSystemChecking(
   System.bool value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies whether file system constraint checking should be disabled. This is an advanced setting, please consider to use this option carefully.")]
[System.ComponentModel.CategoryAttribute("Web Resources")]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property System.bool DisableFileSystemChecking {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members


Enabled Property

[image]
Intersoft WebGrid Documentation
Enabled Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class : Enabled Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Behavior")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Overridable Property Enabled As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebGrid
Dim value As System.Boolean

instance.Enabled = value

value = instance.Enabled
C#
[System.ComponentModel.CategoryAttribute("Behavior")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[ISNet.Serialization.XmlSerializableAttribute()]
public virtual System.bool Enabled {get; set;}
Delphi
public read-write property Enabled: System.Boolean; virtual;
JScript
System.ComponentModel.CategoryAttribute("Behavior")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
ISNet.Serialization.XmlSerializableAttribute()
public function get,set Enabled : System.boolean
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Behavior")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property virtual System.bool get_Enabled();
public: __property virtual void set_Enabled(
   System.bool value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Behavior")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
virtual property System.bool Enabled {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members


EnableManagedTheming Property

[image]
Intersoft WebGrid Documentation
EnableManagedTheming Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class : EnableManagedTheming Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Behavior")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies whether the theming for this control should be managed by Intersoft Theme Architecture. When set to false, this control will not apply the style defined in Theme Architecture.")>
Public Overridable Property EnableManagedTheming As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebGrid
Dim value As System.Boolean

instance.EnableManagedTheming = value

value = instance.EnableManagedTheming
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Behavior")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether the theming for this control should be managed by Intersoft Theme Architecture. When set to false, this control will not apply the style defined in Theme Architecture.")]
public virtual System.bool EnableManagedTheming {get; set;}
Delphi
public read-write property EnableManagedTheming: System.Boolean; virtual;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Behavior")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Specifies whether the theming for this control should be managed by Intersoft Theme Architecture. When set to false, this control will not apply the style defined in Theme Architecture.")
public function get,set EnableManagedTheming : System.boolean
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Behavior")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether the theming for this control should be managed by Intersoft Theme Architecture. When set to false, this control will not apply the style defined in Theme Architecture.")]
public: __property virtual System.bool get_EnableManagedTheming();
public: __property virtual void set_EnableManagedTheming(
   System.bool value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Behavior")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether the theming for this control should be managed by Intersoft Theme Architecture. When set to false, this control will not apply the style defined in Theme Architecture.")]
public:
virtual property System.bool EnableManagedTheming {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members


EnableSection508Standards Property

[image]
Intersoft WebGrid Documentation
EnableSection508Standards Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class : EnableSection508Standards Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies whether the WebGrid instance should operate in compliance with U.S. Section 508 Standards.")>
<System.ComponentModel.CategoryAttribute("Behavior")>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Property EnableSection508Standards As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebGrid
Dim value As System.Boolean

instance.EnableSection508Standards = value

value = instance.EnableSection508Standards
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether the WebGrid instance should operate in compliance with U.S. Section 508 Standards.")]
[System.ComponentModel.CategoryAttribute("Behavior")]
[ISNet.Serialization.XmlSerializableAttribute()]
public System.bool EnableSection508Standards {get; set;}
Delphi
public read-write property EnableSection508Standards: System.Boolean;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Specifies whether the WebGrid instance should operate in compliance with U.S. Section 508 Standards.")
System.ComponentModel.CategoryAttribute("Behavior")
ISNet.Serialization.XmlSerializableAttribute()
public function get,set EnableSection508Standards : System.boolean
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether the WebGrid instance should operate in compliance with U.S. Section 508 Standards.")]
[System.ComponentModel.CategoryAttribute("Behavior")]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property System.bool get_EnableSection508Standards();
public: __property void set_EnableSection508Standards(
   System.bool value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether the WebGrid instance should operate in compliance with U.S. Section 508 Standards.")]
[System.ComponentModel.CategoryAttribute("Behavior")]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property System.bool EnableSection508Standards {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members


EnableTheming Property

[image]
Intersoft WebGrid Documentation
EnableTheming Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class : EnableTheming Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.BrowsableAttribute(True)>
Public Overridable Property EnableTheming As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebGrid
Dim value As System.Boolean

instance.EnableTheming = value

value = instance.EnableTheming
C#
[System.ComponentModel.BrowsableAttribute(true)]
public virtual System.bool EnableTheming {get; set;}
Delphi
public read-write property EnableTheming: System.Boolean; virtual;
JScript
System.ComponentModel.BrowsableAttribute()
public function get,set EnableTheming : System.boolean
Managed Extensions for C++
[System.ComponentModel.BrowsableAttribute(true)]
public: __property virtual System.bool get_EnableTheming();
public: __property virtual void set_EnableTheming(
   System.bool value
);
C++/CLI
[System.ComponentModel.BrowsableAttribute(true)]
public:
virtual property System.bool EnableTheming {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members


EnableV3XAPISupport Property

[image]
Intersoft WebGrid Documentation
EnableV3XAPISupport Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class : EnableV3XAPISupport Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Enables backward compatibility with V3.x client side API.")>
<System.ComponentModel.CategoryAttribute("Behavior")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property EnableV3XAPISupport As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebGrid
Dim value As System.Boolean

instance.EnableV3XAPISupport = value

value = instance.EnableV3XAPISupport
C#
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Enables backward compatibility with V3.x client side API.")]
[System.ComponentModel.CategoryAttribute("Behavior")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public System.bool EnableV3XAPISupport {get; set;}
Delphi
public read-write property EnableV3XAPISupport: System.Boolean;
JScript
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Enables backward compatibility with V3.x client side API.")
System.ComponentModel.CategoryAttribute("Behavior")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get,set EnableV3XAPISupport : System.boolean
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Enables backward compatibility with V3.x client side API.")]
[System.ComponentModel.CategoryAttribute("Behavior")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.bool get_EnableV3XAPISupport();
public: __property void set_EnableV3XAPISupport(
   System.bool value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Enables backward compatibility with V3.x client side API.")]
[System.ComponentModel.CategoryAttribute("Behavior")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.bool EnableV3XAPISupport {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members


EnableViewState Property

[image]
Intersoft WebGrid Documentation
EnableViewState Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class : EnableViewState Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Behavior")>
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
Public Overridable Property EnableViewState As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebGrid
Dim value As System.Boolean

instance.EnableViewState = value

value = instance.EnableViewState
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public virtual System.bool EnableViewState {get; set;}
Delphi
public read-write property EnableViewState: System.Boolean; virtual;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Behavior")
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
public function get,set EnableViewState : System.boolean
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public: __property virtual System.bool get_EnableViewState();
public: __property virtual void set_EnableViewState(
   System.bool value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public:
virtual property System.bool EnableViewState {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members


EnableWebResources Property

[image]
Intersoft WebGrid Documentation
EnableWebResources Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class : EnableWebResources Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("Web Resources")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Specifies the option for use with web resources feature. When enabled, the component will retrieve scripts and client resources from web resources instead of external script location (IIS virtual directory). See help for more information and remarks.")>
Public Property EnableWebResources As ISNet.WebUI.WebResourceType
Visual Basic (Usage) Copy Code
Dim instance As WebGrid
Dim value As ISNet.WebUI.WebResourceType

instance.EnableWebResources = value

value = instance.EnableWebResources
C#
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Web Resources")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the option for use with web resources feature. When enabled, the component will retrieve scripts and client resources from web resources instead of external script location (IIS virtual directory). See help for more information and remarks.")]
public ISNet.WebUI.WebResourceType EnableWebResources {get; set;}
Delphi
public read-write property EnableWebResources: ISNet.WebUI.WebResourceType;
JScript
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("Web Resources")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the option for use with web resources feature. When enabled, the component will retrieve scripts and client resources from web resources instead of external script location (IIS virtual directory). See help for more information and remarks.")
public function get,set EnableWebResources : ISNet.WebUI.WebResourceType
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Web Resources")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the option for use with web resources feature. When enabled, the component will retrieve scripts and client resources from web resources instead of external script location (IIS virtual directory). See help for more information and remarks.")]
public: __property ISNet.WebUI.WebResourceType get_EnableWebResources();
public: __property void set_EnableWebResources(
   ISNet.WebUI.WebResourceType value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Web Resources")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the option for use with web resources feature. When enabled, the component will retrieve scripts and client resources from web resources instead of external script location (IIS virtual directory). See help for more information and remarks.")]
public:
property ISNet.WebUI.WebResourceType EnableWebResources {
   ISNet.WebUI.WebResourceType get();
   void set (    ISNet.WebUI.WebResourceType value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members


FlyPostBackSettings Property

[image]
Intersoft WebGrid Documentation
FlyPostBackSettings Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class : FlyPostBackSettings Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.XmlSerializableAttribute(Type=XmlSerializationType.ClientAndLayout, DiscardEmptyObject=True)>
<ISNet.Serialization.BinarySerializableAttribute("setFlyPostBackSettings")>
<System.ComponentModel.CategoryAttribute("Behavior")>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Configures the settings used by the control when performing OnTheFly postback.")>
Public ReadOnly Property FlyPostBackSettings As ISNet.WebUI.FlyPostBackSettings
Visual Basic (Usage) Copy Code
Dim instance As WebGrid
Dim value As ISNet.WebUI.FlyPostBackSettings

value = instance.FlyPostBackSettings
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute(Type=XmlSerializationType.ClientAndLayout, DiscardEmptyObject=true)]
[ISNet.Serialization.BinarySerializableAttribute("setFlyPostBackSettings")]
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Configures the settings used by the control when performing OnTheFly postback.")]
public ISNet.WebUI.FlyPostBackSettings FlyPostBackSettings {get;}
Delphi
public read-only property FlyPostBackSettings: ISNet.WebUI.FlyPostBackSettings;
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.XmlSerializableAttribute(Type=XmlSerializationType.ClientAndLayout, DiscardEmptyObject=)
ISNet.Serialization.BinarySerializableAttribute("setFlyPostBackSettings")
System.ComponentModel.CategoryAttribute("Behavior")
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Configures the settings used by the control when performing OnTheFly postback.")
public function get FlyPostBackSettings : ISNet.WebUI.FlyPostBackSettings
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute(Type=XmlSerializationType.ClientAndLayout, DiscardEmptyObject=true)]
[ISNet.Serialization.BinarySerializableAttribute("setFlyPostBackSettings")]
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Configures the settings used by the control when performing OnTheFly postback.")]
public: __property ISNet.WebUI.FlyPostBackSettings* get_FlyPostBackSettings();
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute(Type=XmlSerializationType.ClientAndLayout, DiscardEmptyObject=true)]
[ISNet.Serialization.BinarySerializableAttribute("setFlyPostBackSettings")]
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Configures the settings used by the control when performing OnTheFly postback.")]
public:
property ISNet.WebUI.FlyPostBackSettings^ FlyPostBackSettings {
   ISNet.WebUI.FlyPostBackSettings^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members


Font Property

[image]
Intersoft WebGrid Documentation
Font Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class : Font Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Appearance")>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
Public Overrides ReadOnly Property Font As System.Web.UI.WebControls.FontInfo
Visual Basic (Usage) Copy Code
Dim instance As WebGrid
Dim value As System.Web.UI.WebControls.FontInfo

value = instance.Font
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public override System.Web.UI.WebControls.FontInfo Font {get;}
Delphi
public read-only property Font: System.Web.UI.WebControls.FontInfo; override;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Appearance")
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
public override function get Font : System.Web.UI.WebControls.FontInfo
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public: __property System.Web.UI.WebControls.FontInfo* get_Font() override;
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public:
property System.Web.UI.WebControls.FontInfo^ Font {
   System.Web.UI.WebControls.FontInfo^ get() override;
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members


ForeColor Property

[image]
Intersoft WebGrid Documentation
ForeColor Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class : ForeColor Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<System.ComponentModel.CategoryAttribute("Appearance")>
Public Overrides Property ForeColor As System.Drawing.Color
Visual Basic (Usage) Copy Code
Dim instance As WebGrid
Dim value As System.Drawing.Color

instance.ForeColor = value

value = instance.ForeColor
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.CategoryAttribute("Appearance")]
public override System.Drawing.Color ForeColor {get; set;}
Delphi
public read-write property ForeColor: System.Drawing.Color; override;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
System.ComponentModel.CategoryAttribute("Appearance")
public override function get,set ForeColor : System.Drawing.Color
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.CategoryAttribute("Appearance")]
public: __property System.Drawing.Color get_ForeColor() override;
public: __property void set_ForeColor(
   System.Drawing.Color value
) override;
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.CategoryAttribute("Appearance")]
public:
property System.Drawing.Color ForeColor {
   System.Drawing.Color get() override;
   void set (    System.Drawing.Color value) override;
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members


GridLines Property

[image]
Intersoft WebGrid Documentation
GridLines Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class : GridLines Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<System.ComponentModel.CategoryAttribute("Appearance")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property GridLines As GridLines
Visual Basic (Usage) Copy Code
Dim instance As WebGrid
Dim value As GridLines

instance.GridLines = value

value = instance.GridLines
C#
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public GridLines GridLines {get; set;}
Delphi
public read-write property GridLines: GridLines;
JScript
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
System.ComponentModel.CategoryAttribute("Appearance")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set GridLines : GridLines
Managed Extensions for C++
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property GridLines get_GridLines();
public: __property void set_GridLines(
   GridLines value
);
C++/CLI
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property GridLines GridLines {
   GridLines get();
   void set (    GridLines value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members


Height Property

[image]
Intersoft WebGrid Documentation
Height Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class : Height Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Layout")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
Public Overridable Property Height As System.Web.UI.WebControls.Unit
Visual Basic (Usage) Copy Code
Dim instance As WebGrid
Dim value As System.Web.UI.WebControls.Unit

instance.Height = value

value = instance.Height
C#
[System.ComponentModel.CategoryAttribute("Layout")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public virtual System.Web.UI.WebControls.Unit Height {get; set;}
Delphi
public read-write property Height: System.Web.UI.WebControls.Unit; virtual;
JScript
System.ComponentModel.CategoryAttribute("Layout")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
public function get,set Height : System.Web.UI.WebControls.Unit
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Layout")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public: __property virtual System.Web.UI.WebControls.Unit get_Height();
public: __property virtual void set_Height(
   System.Web.UI.WebControls.Unit value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Layout")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public:
virtual property System.Web.UI.WebControls.Unit Height {
   System.Web.UI.WebControls.Unit get();
   void set (    System.Web.UI.WebControls.Unit value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members


ID Property

[image]
Intersoft WebGrid Documentation
ID Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class : ID Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Web.UI.FilterableAttribute(False)>
<System.ComponentModel.ParenthesizePropertyNameAttribute(True)>
<System.ComponentModel.MergablePropertyAttribute(False)>
<System.Web.UI.ThemeableAttribute(False)>
<WebSysDescriptionAttribute("Programmatic name of the control.")>
Public Overridable Property ID As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebGrid
Dim value As System.String

instance.ID = value

value = instance.ID
C#
[System.Web.UI.FilterableAttribute(false)]
[System.ComponentModel.ParenthesizePropertyNameAttribute(true)]
[System.ComponentModel.MergablePropertyAttribute(false)]
[System.Web.UI.ThemeableAttribute(false)]
[WebSysDescriptionAttribute("Programmatic name of the control.")]
public virtual System.string ID {get; set;}
Delphi
public read-write property ID: System.String; virtual;
JScript
System.Web.UI.FilterableAttribute()
System.ComponentModel.ParenthesizePropertyNameAttribute()
System.ComponentModel.MergablePropertyAttribute()
System.Web.UI.ThemeableAttribute()
WebSysDescriptionAttribute("Programmatic name of the control.")
public function get,set ID : System.String
Managed Extensions for C++
[System.Web.UI.FilterableAttribute(false)]
[System.ComponentModel.ParenthesizePropertyNameAttribute(true)]
[System.ComponentModel.MergablePropertyAttribute(false)]
[System.Web.UI.ThemeableAttribute(false)]
[WebSysDescriptionAttribute("Programmatic name of the control.")]
public: __property virtual System.string* get_ID();
public: __property virtual void set_ID(
   System.string* value
);
C++/CLI
[System.Web.UI.FilterableAttribute(false)]
[System.ComponentModel.ParenthesizePropertyNameAttribute(true)]
[System.ComponentModel.MergablePropertyAttribute(false)]
[System.Web.UI.ThemeableAttribute(false)]
[WebSysDescriptionAttribute("Programmatic name of the control.")]
public:
virtual property System.String^ ID {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members


ImageFileServer Property

[image]
Intersoft WebGrid Documentation
ImageFileServer Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class : ImageFileServer Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Charting")>
<System.ComponentModel.DescriptionAttribute("Specifies the file server connection used to store the temporary images of Pivot Charting.")>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property ImageFileServer As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebGrid
Dim value As System.String

instance.ImageFileServer = value

value = instance.ImageFileServer
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Charting")]
[System.ComponentModel.DescriptionAttribute("Specifies the file server connection used to store the temporary images of Pivot Charting.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.string ImageFileServer {get; set;}
Delphi
public read-write property ImageFileServer: System.String;
JScript
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.CategoryAttribute("Charting")
System.ComponentModel.DescriptionAttribute("Specifies the file server connection used to store the temporary images of Pivot Charting.")
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set ImageFileServer : System.String
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Charting")]
[System.ComponentModel.DescriptionAttribute("Specifies the file server connection used to store the temporary images of Pivot Charting.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.string* get_ImageFileServer();
public: __property void set_ImageFileServer(
   System.string* value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Charting")]
[System.ComponentModel.DescriptionAttribute("Specifies the file server connection used to store the temporary images of Pivot Charting.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.String^ ImageFileServer {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members


LayoutSettings Property

[image]
Intersoft WebGrid Documentation
LayoutSettings Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class : LayoutSettings Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.CategoryAttribute("Appearance")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute()>
Public Property LayoutSettings As LayoutSet
Visual Basic (Usage) Copy Code
Dim instance As WebGrid
Dim value As LayoutSet

instance.LayoutSettings = value

value = instance.LayoutSettings
C#
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute()]
public LayoutSet LayoutSettings {get; set;}
Delphi
public read-write property LayoutSettings: LayoutSet;
JScript
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.CategoryAttribute("Appearance")
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute()
public function get,set LayoutSettings : LayoutSet
Managed Extensions for C++
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute()]
public: __property LayoutSet* get_LayoutSettings();
public: __property void set_LayoutSettings(
   LayoutSet* value
);
C++/CLI
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute()]
public:
property LayoutSet^ LayoutSettings {
   LayoutSet^ get();
   void set (    LayoutSet^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members


Page Property

[image]
Intersoft WebGrid Documentation
Page Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class : Page Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Property Page As System.Web.UI.Page
Visual Basic (Usage) Copy Code
Dim instance As WebGrid
Dim value As System.Web.UI.Page

instance.Page = value

value = instance.Page
C#
public virtual System.Web.UI.Page Page {get; set;}
Delphi
public read-write property Page: System.Web.UI.Page; virtual;
JScript
public function get,set Page : System.Web.UI.Page
Managed Extensions for C++
public: __property virtual System.Web.UI.Page* get_Page();
public: __property virtual void set_Page(
   System.Web.UI.Page* value
);
C++/CLI
public:
virtual property System.Web.UI.Page^ Page {
   System.Web.UI.Page^ get();
   void set (    System.Web.UI.Page^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members


RenderingMode Property

[image]
Intersoft WebGrid Documentation
RenderingMode Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class : RenderingMode Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Behavior")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Gets or sets a value that specifies the HTML rendering behavior applied in this control.")>
Public Overridable Property RenderingMode As ISNet.WebUI.RenderMode
Visual Basic (Usage) Copy Code
Dim instance As WebGrid
Dim value As ISNet.WebUI.RenderMode

instance.RenderingMode = value

value = instance.RenderingMode
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets a value that specifies the HTML rendering behavior applied in this control.")]
public virtual ISNet.WebUI.RenderMode RenderingMode {get; set;}
Delphi
public read-write property RenderingMode: ISNet.WebUI.RenderMode; virtual;
JScript
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.CategoryAttribute("Behavior")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets a value that specifies the HTML rendering behavior applied in this control.")
public function get,set RenderingMode : ISNet.WebUI.RenderMode
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets a value that specifies the HTML rendering behavior applied in this control.")]
public: __property virtual ISNet.WebUI.RenderMode get_RenderingMode();
public: __property virtual void set_RenderingMode(
   ISNet.WebUI.RenderMode value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets a value that specifies the HTML rendering behavior applied in this control.")]
public:
virtual property ISNet.WebUI.RenderMode RenderingMode {
   ISNet.WebUI.RenderMode get();
   void set (    ISNet.WebUI.RenderMode value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members


RuntimeLicenseKey Property

[image]
Intersoft WebGrid Documentation
RuntimeLicenseKey Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class : RuntimeLicenseKey Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("The runtime license key for xcopy deployment. Registered customers please obtain the key through Intersoft Developer Network.")>
<ISNet.PersistLayoutAttribute(False)>
Public Overridable Property RuntimeLicenseKey As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebGrid
Dim value As System.String

instance.RuntimeLicenseKey = value

value = instance.RuntimeLicenseKey
C#
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("The runtime license key for xcopy deployment. Registered customers please obtain the key through Intersoft Developer Network.")]
[ISNet.PersistLayoutAttribute(false)]
public virtual System.string RuntimeLicenseKey {get; set;}
Delphi
public read-write property RuntimeLicenseKey: System.String; virtual;
JScript
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("The runtime license key for xcopy deployment. Registered customers please obtain the key through Intersoft Developer Network.")
ISNet.PersistLayoutAttribute()
public function get,set RuntimeLicenseKey : System.String
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("The runtime license key for xcopy deployment. Registered customers please obtain the key through Intersoft Developer Network.")]
[ISNet.PersistLayoutAttribute(false)]
public: __property virtual System.string* get_RuntimeLicenseKey();
public: __property virtual void set_RuntimeLicenseKey(
   System.string* value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("The runtime license key for xcopy deployment. Registered customers please obtain the key through Intersoft Developer Network.")]
[ISNet.PersistLayoutAttribute(false)]
public:
virtual property System.String^ RuntimeLicenseKey {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members


ScriptDirectory Property

[image]
Intersoft WebGrid Documentation
ScriptDirectory Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class : ScriptDirectory Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("Client Script Directory")>
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
Public Overrides Property ScriptDirectory As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebGrid
Dim value As System.String

instance.ScriptDirectory = value

value = instance.ScriptDirectory
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Client Script Directory")]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public override System.string ScriptDirectory {get; set;}
Delphi
public read-write property ScriptDirectory: System.String; override;
JScript
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("Client Script Directory")
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
public override function get,set ScriptDirectory : System.String
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Client Script Directory")]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public: __property System.string* get_ScriptDirectory() override;
public: __property void set_ScriptDirectory(
   System.string* value
) override;
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Client Script Directory")]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public:
property System.String^ ScriptDirectory {
   System.String^ get() override;
   void set (    System.String^ value) override;
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members


SerializeTagToClient Property

[image]
Intersoft WebGrid Documentation
SerializeTagToClient Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class : SerializeTagToClient Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Data")>
<System.ComponentModel.DescriptionAttribute("Specifies whether the row's tag should be serialized to client side, when client binding is enabled.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Property SerializeTagToClient As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebGrid
Dim value As System.Boolean

instance.SerializeTagToClient = value

value = instance.SerializeTagToClient
C#
[System.ComponentModel.CategoryAttribute("Data")]
[System.ComponentModel.DescriptionAttribute("Specifies whether the row's tag should be serialized to client side, when client binding is enabled.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public System.bool SerializeTagToClient {get; set;}
Delphi
public read-write property SerializeTagToClient: System.Boolean;
JScript
System.ComponentModel.CategoryAttribute("Data")
System.ComponentModel.DescriptionAttribute("Specifies whether the row's tag should be serialized to client side, when client binding is enabled.")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute()
public function get,set SerializeTagToClient : System.boolean
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Data")]
[System.ComponentModel.DescriptionAttribute("Specifies whether the row's tag should be serialized to client side, when client binding is enabled.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property System.bool get_SerializeTagToClient();
public: __property void set_SerializeTagToClient(
   System.bool value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Data")]
[System.ComponentModel.DescriptionAttribute("Specifies whether the row's tag should be serialized to client side, when client binding is enabled.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property System.bool SerializeTagToClient {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members


Settings Property

[image]
Intersoft WebGrid Documentation
Settings Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class : Settings Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="., ISNet.WebUI.WebGrid, Version=9.0.7200.1, Culture=neutral, PublicKeyToken=3e60b85fb8502d5e")>
<System.ComponentModel.CategoryAttribute("Charting")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property Settings As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebGrid
Dim value As System.String

instance.Settings = value

value = instance.Settings
C#
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="., ISNet.WebUI.WebGrid, Version=9.0.7200.1, Culture=neutral, PublicKeyToken=3e60b85fb8502d5e")]
[System.ComponentModel.CategoryAttribute("Charting")]
[System.ComponentModel.DefaultValueAttribute()]
public System.string Settings {get; set;}
Delphi
public read-write property Settings: System.String;
JScript
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="., ISNet.WebUI.WebGrid, Version=9.0.7200.1, Culture=neutral, PublicKeyToken=3e60b85fb8502d5e")
System.ComponentModel.CategoryAttribute("Charting")
System.ComponentModel.DefaultValueAttribute()
public function get,set Settings : System.String
Managed Extensions for C++
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="., ISNet.WebUI.WebGrid, Version=9.0.7200.1, Culture=neutral, PublicKeyToken=3e60b85fb8502d5e")]
[System.ComponentModel.CategoryAttribute("Charting")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.string* get_Settings();
public: __property void set_Settings(
   System.string* value
);
C++/CLI
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="., ISNet.WebUI.WebGrid, Version=9.0.7200.1, Culture=neutral, PublicKeyToken=3e60b85fb8502d5e")]
[System.ComponentModel.CategoryAttribute("Charting")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.String^ Settings {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members


SharedScriptDirectory Property

[image]
Intersoft WebGrid Documentation
SharedScriptDirectory Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class : SharedScriptDirectory Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Client Script Directory")>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Gets or sets the directory where all required framework scripts for the control are stored.")>
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
Public Overrides Property SharedScriptDirectory As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebGrid
Dim value As System.String

instance.SharedScriptDirectory = value

value = instance.SharedScriptDirectory
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Client Script Directory")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the directory where all required framework scripts for the control are stored.")]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public override System.string SharedScriptDirectory {get; set;}
Delphi
public read-write property SharedScriptDirectory: System.String; override;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Client Script Directory")
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the directory where all required framework scripts for the control are stored.")
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
public override function get,set SharedScriptDirectory : System.String
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Client Script Directory")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the directory where all required framework scripts for the control are stored.")]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public: __property System.string* get_SharedScriptDirectory() override;
public: __property void set_SharedScriptDirectory(
   System.string* value
) override;
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Client Script Directory")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the directory where all required framework scripts for the control are stored.")]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public:
property System.String^ SharedScriptDirectory {
   System.String^ get() override;
   void set (    System.String^ value) override;
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members


SkinID Property

[image]
Intersoft WebGrid Documentation
SkinID Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class : SkinID Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.BrowsableAttribute(True)>
Public Overridable Property SkinID As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebGrid
Dim value As System.String

instance.SkinID = value

value = instance.SkinID
C#
[System.ComponentModel.BrowsableAttribute(true)]
public virtual System.string SkinID {get; set;}
Delphi
public read-write property SkinID: System.String; virtual;
JScript
System.ComponentModel.BrowsableAttribute()
public function get,set SkinID : System.String
Managed Extensions for C++
[System.ComponentModel.BrowsableAttribute(true)]
public: __property virtual System.string* get_SkinID();
public: __property virtual void set_SkinID(
   System.string* value
);
C++/CLI
[System.ComponentModel.BrowsableAttribute(true)]
public:
virtual property System.String^ SkinID {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members


StateRestorationLevel Property

[image]
Intersoft WebGrid Documentation
StateRestorationLevel Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class : StateRestorationLevel Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies the level of control's state restoration. See help for more information.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Behavior")>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Property StateRestorationLevel As RestorationLevel
Visual Basic (Usage) Copy Code
Dim instance As WebGrid
Dim value As RestorationLevel

instance.StateRestorationLevel = value

value = instance.StateRestorationLevel
C#
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the level of control's state restoration. See help for more information.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Behavior")]
[ISNet.Serialization.XmlSerializableAttribute()]
public RestorationLevel StateRestorationLevel {get; set;}
Delphi
public read-write property StateRestorationLevel: RestorationLevel;
JScript
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the level of control's state restoration. See help for more information.")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Behavior")
ISNet.Serialization.XmlSerializableAttribute()
public function get,set StateRestorationLevel : RestorationLevel
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the level of control's state restoration. See help for more information.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Behavior")]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property RestorationLevel get_StateRestorationLevel();
public: __property void set_StateRestorationLevel(
   RestorationLevel value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the level of control's state restoration. See help for more information.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Behavior")]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property RestorationLevel StateRestorationLevel {
   RestorationLevel get();
   void set (    RestorationLevel value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members


TabIndex Property

[image]
Intersoft WebGrid Documentation
TabIndex Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class : TabIndex Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Behavior")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
Public Overridable Property TabIndex As System.Short
Visual Basic (Usage) Copy Code
Dim instance As WebGrid
Dim value As System.Short

instance.TabIndex = value

value = instance.TabIndex
C#
[System.ComponentModel.CategoryAttribute("Behavior")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public virtual System.short TabIndex {get; set;}
Delphi
public read-write property TabIndex: System.Int16; virtual;
JScript
System.ComponentModel.CategoryAttribute("Behavior")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
public function get,set TabIndex : System.short
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Behavior")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public: __property virtual System.short get_TabIndex();
public: __property virtual void set_TabIndex(
   System.short value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Behavior")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public:
virtual property System.short TabIndex {
   System.short get();
   void set (    System.short value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members


ToolTip Property

[image]
Intersoft WebGrid Documentation
ToolTip Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class : ToolTip Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Behavior")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
Public Overridable Property ToolTip As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebGrid
Dim value As System.String

instance.ToolTip = value

value = instance.ToolTip
C#
[System.ComponentModel.CategoryAttribute("Behavior")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public virtual System.string ToolTip {get; set;}
Delphi
public read-write property ToolTip: System.String; virtual;
JScript
System.ComponentModel.CategoryAttribute("Behavior")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
public function get,set ToolTip : System.String
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Behavior")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public: __property virtual System.string* get_ToolTip();
public: __property virtual void set_ToolTip(
   System.string* value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Behavior")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public:
virtual property System.String^ ToolTip {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members


UseDefaultStyle Property

[image]
Intersoft WebGrid Documentation
UseDefaultStyle Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class : UseDefaultStyle Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Appearance")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies whether WebGrid should apply embedded default style for its appearance.")>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Property UseDefaultStyle As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebGrid
Dim value As System.Boolean

instance.UseDefaultStyle = value

value = instance.UseDefaultStyle
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether WebGrid should apply embedded default style for its appearance.")]
[ISNet.Serialization.XmlSerializableAttribute()]
public System.bool UseDefaultStyle {get; set;}
Delphi
public read-write property UseDefaultStyle: System.Boolean;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Appearance")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Specifies whether WebGrid should apply embedded default style for its appearance.")
ISNet.Serialization.XmlSerializableAttribute()
public function get,set UseDefaultStyle : System.boolean
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether WebGrid should apply embedded default style for its appearance.")]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property System.bool get_UseDefaultStyle();
public: __property void set_UseDefaultStyle(
   System.bool value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether WebGrid should apply embedded default style for its appearance.")]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property System.bool UseDefaultStyle {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members


ValidateRequestMode Property

[image]
Intersoft WebGrid Documentation
ValidateRequestMode Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class : ValidateRequestMode Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<WebSysDescriptionAttribute("Determines whether the control validates client input or not. Defaults to inherit from parent.")>
<WebCategoryAttribute("Behavior")>
Public Overridable Property ValidateRequestMode As System.Web.UI.ValidateRequestMode
Visual Basic (Usage) Copy Code
Dim instance As WebGrid
Dim value As System.Web.UI.ValidateRequestMode

instance.ValidateRequestMode = value

value = instance.ValidateRequestMode
C#
[System.ComponentModel.DefaultValueAttribute()]
[WebSysDescriptionAttribute("Determines whether the control validates client input or not. Defaults to inherit from parent.")]
[WebCategoryAttribute("Behavior")]
public virtual System.Web.UI.ValidateRequestMode ValidateRequestMode {get; set;}
Delphi
public read-write property ValidateRequestMode: System.Web.UI.ValidateRequestMode; virtual;
JScript
System.ComponentModel.DefaultValueAttribute()
WebSysDescriptionAttribute("Determines whether the control validates client input or not. Defaults to inherit from parent.")
WebCategoryAttribute("Behavior")
public function get,set ValidateRequestMode : System.Web.UI.ValidateRequestMode
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[WebSysDescriptionAttribute("Determines whether the control validates client input or not. Defaults to inherit from parent.")]
[WebCategoryAttribute("Behavior")]
public: __property virtual System.Web.UI.ValidateRequestMode get_ValidateRequestMode();
public: __property virtual void set_ValidateRequestMode(
   System.Web.UI.ValidateRequestMode value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[WebSysDescriptionAttribute("Determines whether the control validates client input or not. Defaults to inherit from parent.")]
[WebCategoryAttribute("Behavior")]
public:
virtual property System.Web.UI.ValidateRequestMode ValidateRequestMode {
   System.Web.UI.ValidateRequestMode get();
   void set (    System.Web.UI.ValidateRequestMode value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members


ViewStateItems Property

[image]
Intersoft WebGrid Documentation
ViewStateItems Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class : ViewStateItems Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
<System.ComponentModel.CategoryAttribute("View State Settings")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Gets or sets the items to be stored in view state storage.")>
Public Overridable Property ViewStateItems As ISNet.WebUI.ViewStateItem
Visual Basic (Usage) Copy Code
Dim instance As WebGrid
Dim value As ISNet.WebUI.ViewStateItem

instance.ViewStateItems = value

value = instance.ViewStateItems
C#
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.CategoryAttribute("View State Settings")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the items to be stored in view state storage.")]
public virtual ISNet.WebUI.ViewStateItem ViewStateItems {get; set;}
Delphi
public read-write property ViewStateItems: ISNet.WebUI.ViewStateItem; virtual;
JScript
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
System.ComponentModel.CategoryAttribute("View State Settings")
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the items to be stored in view state storage.")
public function get,set ViewStateItems : ISNet.WebUI.ViewStateItem
Managed Extensions for C++
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.CategoryAttribute("View State Settings")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the items to be stored in view state storage.")]
public: __property virtual ISNet.WebUI.ViewStateItem get_ViewStateItems();
public: __property virtual void set_ViewStateItems(
   ISNet.WebUI.ViewStateItem value
);
C++/CLI
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.CategoryAttribute("View State Settings")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the items to be stored in view state storage.")]
public:
virtual property ISNet.WebUI.ViewStateItem ViewStateItems {
   ISNet.WebUI.ViewStateItem get();
   void set (    ISNet.WebUI.ViewStateItem value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members


ViewStateMode Property

[image]
Intersoft WebGrid Documentation
ViewStateMode Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class : ViewStateMode Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Web.UI.ThemeableAttribute(False)>
<System.ComponentModel.DefaultValueAttribute()>
<WebSysDescriptionAttribute("Determines whether the control has viewstate enabled or not, defaults to inherit from parent.")>
<WebCategoryAttribute("Behavior")>
Public Overridable Property ViewStateMode As System.Web.UI.ViewStateMode
Visual Basic (Usage) Copy Code
Dim instance As WebGrid
Dim value As System.Web.UI.ViewStateMode

instance.ViewStateMode = value

value = instance.ViewStateMode
C#
[System.Web.UI.ThemeableAttribute(false)]
[System.ComponentModel.DefaultValueAttribute()]
[WebSysDescriptionAttribute("Determines whether the control has viewstate enabled or not, defaults to inherit from parent.")]
[WebCategoryAttribute("Behavior")]
public virtual System.Web.UI.ViewStateMode ViewStateMode {get; set;}
Delphi
public read-write property ViewStateMode: System.Web.UI.ViewStateMode; virtual;
JScript
System.Web.UI.ThemeableAttribute()
System.ComponentModel.DefaultValueAttribute()
WebSysDescriptionAttribute("Determines whether the control has viewstate enabled or not, defaults to inherit from parent.")
WebCategoryAttribute("Behavior")
public function get,set ViewStateMode : System.Web.UI.ViewStateMode
Managed Extensions for C++
[System.Web.UI.ThemeableAttribute(false)]
[System.ComponentModel.DefaultValueAttribute()]
[WebSysDescriptionAttribute("Determines whether the control has viewstate enabled or not, defaults to inherit from parent.")]
[WebCategoryAttribute("Behavior")]
public: __property virtual System.Web.UI.ViewStateMode get_ViewStateMode();
public: __property virtual void set_ViewStateMode(
   System.Web.UI.ViewStateMode value
);
C++/CLI
[System.Web.UI.ThemeableAttribute(false)]
[System.ComponentModel.DefaultValueAttribute()]
[WebSysDescriptionAttribute("Determines whether the control has viewstate enabled or not, defaults to inherit from parent.")]
[WebCategoryAttribute("Behavior")]
public:
virtual property System.Web.UI.ViewStateMode ViewStateMode {
   System.Web.UI.ViewStateMode get();
   void set (    System.Web.UI.ViewStateMode value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members


ViewStateServerConnection Property

[image]
Intersoft WebGrid Documentation
ViewStateServerConnection Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class : ViewStateServerConnection Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("View State Settings")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Gets or sets the server connection string for file server-based viewstate storage.")>
Public Overridable Property ViewStateServerConnection As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebGrid
Dim value As System.String

instance.ViewStateServerConnection = value

value = instance.ViewStateServerConnection
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("View State Settings")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the server connection string for file server-based viewstate storage.")]
public virtual System.string ViewStateServerConnection {get; set;}
Delphi
public read-write property ViewStateServerConnection: System.String; virtual;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("View State Settings")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the server connection string for file server-based viewstate storage.")
public function get,set ViewStateServerConnection : System.String
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("View State Settings")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the server connection string for file server-based viewstate storage.")]
public: __property virtual System.string* get_ViewStateServerConnection();
public: __property virtual void set_ViewStateServerConnection(
   System.string* value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("View State Settings")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the server connection string for file server-based viewstate storage.")]
public:
virtual property System.String^ ViewStateServerConnection {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members


ViewStateStorage Property

[image]
Intersoft WebGrid Documentation
ViewStateStorage Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class : ViewStateStorage Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Gets or sets the location to store the viewstate of this control.")>
<System.ComponentModel.CategoryAttribute("View State Settings")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
<System.ComponentModel.DefaultValueAttribute()>
Public Overridable Property ViewStateStorage As ISNet.WebUI.StateCacheStorage
Visual Basic (Usage) Copy Code
Dim instance As WebGrid
Dim value As ISNet.WebUI.StateCacheStorage

instance.ViewStateStorage = value

value = instance.ViewStateStorage
C#
[System.ComponentModel.DescriptionAttribute("Gets or sets the location to store the viewstate of this control.")]
[System.ComponentModel.CategoryAttribute("View State Settings")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.DefaultValueAttribute()]
public virtual ISNet.WebUI.StateCacheStorage ViewStateStorage {get; set;}
Delphi
public read-write property ViewStateStorage: ISNet.WebUI.StateCacheStorage; virtual;
JScript
System.ComponentModel.DescriptionAttribute("Gets or sets the location to store the viewstate of this control.")
System.ComponentModel.CategoryAttribute("View State Settings")
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
System.ComponentModel.DefaultValueAttribute()
public function get,set ViewStateStorage : ISNet.WebUI.StateCacheStorage
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Gets or sets the location to store the viewstate of this control.")]
[System.ComponentModel.CategoryAttribute("View State Settings")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.DefaultValueAttribute()]
public: __property virtual ISNet.WebUI.StateCacheStorage get_ViewStateStorage();
public: __property virtual void set_ViewStateStorage(
   ISNet.WebUI.StateCacheStorage value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Gets or sets the location to store the viewstate of this control.")]
[System.ComponentModel.CategoryAttribute("View State Settings")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.DefaultValueAttribute()]
public:
virtual property ISNet.WebUI.StateCacheStorage ViewStateStorage {
   ISNet.WebUI.StateCacheStorage get();
   void set (    ISNet.WebUI.StateCacheStorage value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members


Visible Property

[image]
Intersoft WebGrid Documentation
Visible Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class : Visible Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
<System.ComponentModel.CategoryAttribute("Behavior")>
Public Overridable Property Visible As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebGrid
Dim value As System.Boolean

instance.Visible = value

value = instance.Visible
C#
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.CategoryAttribute("Behavior")]
public virtual System.bool Visible {get; set;}
Delphi
public read-write property Visible: System.Boolean; virtual;
JScript
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
System.ComponentModel.CategoryAttribute("Behavior")
public function get,set Visible : System.boolean
Managed Extensions for C++
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.CategoryAttribute("Behavior")]
public: __property virtual System.bool get_Visible();
public: __property virtual void set_Visible(
   System.bool value
);
C++/CLI
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.CategoryAttribute("Behavior")]
public:
virtual property System.bool Visible {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members


WebDesktopScriptDirectory Property

[image]
Intersoft WebGrid Documentation
WebDesktopScriptDirectory Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class : WebDesktopScriptDirectory Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Client Script Directory")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Gets or sets the IIS path to locate WebDesktop's script directory. This property is only applicable when SmartWebResources is not enabled.")>
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Property WebDesktopScriptDirectory As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebGrid
Dim value As System.String

instance.WebDesktopScriptDirectory = value

value = instance.WebDesktopScriptDirectory
C#
[System.ComponentModel.CategoryAttribute("Client Script Directory")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the IIS path to locate WebDesktop's script directory. This property is only applicable when SmartWebResources is not enabled.")]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[ISNet.Serialization.XmlSerializableAttribute()]
public System.string WebDesktopScriptDirectory {get; set;}
Delphi
public read-write property WebDesktopScriptDirectory: System.String;
JScript
System.ComponentModel.CategoryAttribute("Client Script Directory")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the IIS path to locate WebDesktop's script directory. This property is only applicable when SmartWebResources is not enabled.")
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
ISNet.Serialization.XmlSerializableAttribute()
public function get,set WebDesktopScriptDirectory : System.String
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Client Script Directory")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the IIS path to locate WebDesktop's script directory. This property is only applicable when SmartWebResources is not enabled.")]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property System.string* get_WebDesktopScriptDirectory();
public: __property void set_WebDesktopScriptDirectory(
   System.string* value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Client Script Directory")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the IIS path to locate WebDesktop's script directory. This property is only applicable when SmartWebResources is not enabled.")]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property System.String^ WebDesktopScriptDirectory {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members


Width Property

[image]
Intersoft WebGrid Documentation
Width Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class : Width Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Layout")>
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
Public Overridable Property Width As System.Web.UI.WebControls.Unit
Visual Basic (Usage) Copy Code
Dim instance As WebGrid
Dim value As System.Web.UI.WebControls.Unit

instance.Width = value

value = instance.Width
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Layout")]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public virtual System.Web.UI.WebControls.Unit Width {get; set;}
Delphi
public read-write property Width: System.Web.UI.WebControls.Unit; virtual;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Layout")
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
public function get,set Width : System.Web.UI.WebControls.Unit
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Layout")]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public: __property virtual System.Web.UI.WebControls.Unit get_Width();
public: __property virtual void set_Width(
   System.Web.UI.WebControls.Unit value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Layout")]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public:
virtual property System.Web.UI.WebControls.Unit Width {
   System.Web.UI.WebControls.Unit get();
   void set (    System.Web.UI.WebControls.Unit value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members


XmlCompressionEnabled Property

[image]
Intersoft WebGrid Documentation
XmlCompressionEnabled Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class : XmlCompressionEnabled Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Behavior")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies whether the Xml used for clientside state storage should be compressed.")>
Public Overridable Property XmlCompressionEnabled As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebGrid
Dim value As System.Boolean

instance.XmlCompressionEnabled = value

value = instance.XmlCompressionEnabled
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether the Xml used for clientside state storage should be compressed.")]
public virtual System.bool XmlCompressionEnabled {get; set;}
Delphi
public read-write property XmlCompressionEnabled: System.Boolean; virtual;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.CategoryAttribute("Behavior")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Specifies whether the Xml used for clientside state storage should be compressed.")
public function get,set XmlCompressionEnabled : System.boolean
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether the Xml used for clientside state storage should be compressed.")]
public: __property virtual System.bool get_XmlCompressionEnabled();
public: __property virtual void set_XmlCompressionEnabled(
   System.bool value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether the Xml used for clientside state storage should be compressed.")]
public:
virtual property System.bool XmlCompressionEnabled {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members


WebGrid Class Fields

[image]
Intersoft WebGrid Documentation
WebGrid Class Fields
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : WebGrid Class

Glossary Item Box

For a list of all members of this type, see WebGrid members.

Public Fields

 | Name | Description
Public Field | VirtualLoadArgs |
Top

See Also

Reference

WebGrid Class
ISNet.WebUI.WebGrid Namespace


VirtualLoadArgs Field

[image]
Intersoft WebGrid Documentation
VirtualLoadArgs Field
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class : VirtualLoadArgs Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public VirtualLoadArgs As CustomVirtualLoad
Visual Basic (Usage) Copy Code
Dim instance As WebGrid
Dim value As CustomVirtualLoad

value = instance.VirtualLoadArgs

instance.VirtualLoadArgs = value
C#
public CustomVirtualLoad VirtualLoadArgs
Delphi
public field VirtualLoadArgs: CustomVirtualLoad;
JScript
public var VirtualLoadArgs : CustomVirtualLoad;
Managed Extensions for C++
public: CustomVirtualLoad* VirtualLoadArgs
C++/CLI
public:
CustomVirtualLoad^ VirtualLoadArgs

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members


WebGrid Class Events

[image]
Intersoft WebGrid Documentation
WebGrid Class Events
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : WebGrid Class

Glossary Item Box

For a list of all members of this type, see WebGrid members.

Public Events

 | Name | Description
Public Event | AddRow |
Public Event | BatchUpdate |
Public Event | ButtonClick |
Public Event | ChartImageProcessed |
Public Event | ChartImageProcessing |
Public Event | CustomAggregate |
Public Event | CustomFilter |
Public Event | CustomSort |
Public Event | DataBinding | (Inherited from System.Web.UI.Control)
Public Event | DeleteRow |
Public Event | Disposed | (Inherited from System.Web.UI.Control)
Public Event | Export |
Public Event | ExportCompleted |
Public Event | Init | (Inherited from System.Web.UI.Control)
Public Event | InitializeCell |
Public Event | InitializeChildTableDataSource |
Public Event | InitializeColumn |
Public Event | InitializeDataSource |
Public Event | InitializeJsonRow |
Public Event | InitializeLayout |
Public Event | InitializePostBack |
Public Event | InitializeRow |
Public Event | InitializeSelfReferenceDataSource |
Public Event | InitializeTable |
Public Event | Load | (Inherited from System.Web.UI.Control)
Public Event | LoadPreviewRow |
Public Event | PreInitialize | (Inherited from ISNet.WebUI.ISNetControl)
Public Event | PrepareDataBinding |
Public Event | PrepareExportExecute |
Public Event | PreRender | (Inherited from System.Web.UI.Control)
Public Event | RowChanged |
Public Event | Unload | (Inherited from System.Web.UI.Control)
Public Event | UpdateRow |
Top

See Also

Reference

WebGrid Class
ISNet.WebUI.WebGrid Namespace


AddRow Event

[image]
Intersoft WebGrid Documentation
AddRow Event
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class : AddRow Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute()>
<System.ComponentModel.CategoryAttribute("Behavior")>
Public Event AddRow As AddRowEventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebGrid
Dim handler As AddRowEventHandler

AddHandler instance.AddRow, handler
C#
[System.ComponentModel.DescriptionAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
public event AddRowEventHandler AddRow
Delphi
public event AddRow: AddRowEventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
public: __event AddRowEventHandler* AddRow
C++/CLI
[System.ComponentModel.DescriptionAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
public:
event AddRowEventHandler^ AddRow

Event Data

The event handler receives an argument of type RowEventArgs containing data related to this event. The following RowEventArgs properties provide information specific to this event.

Property | Description
ReturnValue (Inherited from ISNet.WebUI.WebGrid.BaseEventArgs) |
Row |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members


BatchUpdate Event

[image]
Intersoft WebGrid Documentation
BatchUpdate Event
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class : BatchUpdate Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute()>
<System.ComponentModel.CategoryAttribute("Behavior")>
Public Event BatchUpdate As System.EventHandler(Of BatchUpdateEventArgs)
Visual Basic (Usage) Copy Code
Dim instance As WebGrid
Dim handler As System.EventHandler(Of BatchUpdateEventArgs)

AddHandler instance.BatchUpdate, handler
C#
[System.ComponentModel.DescriptionAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
public event System.EventHandler<BatchUpdateEventArgs> BatchUpdate
Delphi
public event BatchUpdate: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
public: __event System.EventHandler<BatchUpdateEventArgs*>* BatchUpdate
C++/CLI
[System.ComponentModel.DescriptionAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
public:
event System.EventHandler<BatchUpdateEventArgs^>^ BatchUpdate

Event Data

The event handler receives an argument of type BatchUpdateEventArgs containing data related to this event. The following BatchUpdateEventArgs properties provide information specific to this event.

Property | Description
PendingChanges |
ReturnValue (Inherited from ISNet.WebUI.WebGrid.BaseEventArgs) |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members


ButtonClick Event

[image]
Intersoft WebGrid Documentation
ButtonClick Event
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class : ButtonClick Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Behavior")>
<System.ComponentModel.DescriptionAttribute()>
Public Event ButtonClick As ButtonClickEventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebGrid
Dim handler As ButtonClickEventHandler

AddHandler instance.ButtonClick, handler
C#
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.DescriptionAttribute()]
public event ButtonClickEventHandler ButtonClick
Delphi
public event ButtonClick: ButtonClickEventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.DescriptionAttribute()]
public: __event ButtonClickEventHandler* ButtonClick
C++/CLI
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.DescriptionAttribute()]
public:
event ButtonClickEventHandler^ ButtonClick

Event Data

The event handler receives an argument of type ButtonEventArgs containing data related to this event. The following ButtonEventArgs properties provide information specific to this event.

Property | Description
CellValue |
Column |
ReturnValue (Inherited from ISNet.WebUI.WebGrid.BaseEventArgs) |
Table |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members


ChartImageProcessed Event

[image]
Intersoft WebGrid Documentation
ChartImageProcessed Event
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class : ChartImageProcessed Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Event ChartImageProcessed As WebGridChartProcessedEventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebGrid
Dim handler As WebGridChartProcessedEventHandler

AddHandler instance.ChartImageProcessed, handler
C#
public event WebGridChartProcessedEventHandler ChartImageProcessed
Delphi
public event ChartImageProcessed: WebGridChartProcessedEventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
public: __event WebGridChartProcessedEventHandler* ChartImageProcessed
C++/CLI
public:
event WebGridChartProcessedEventHandler^ ChartImageProcessed

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members


ChartImageProcessing Event

[image]
Intersoft WebGrid Documentation
ChartImageProcessing Event
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class : ChartImageProcessing Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Event ChartImageProcessing As WebGridChartProcessingEventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebGrid
Dim handler As WebGridChartProcessingEventHandler

AddHandler instance.ChartImageProcessing, handler
C#
public event WebGridChartProcessingEventHandler ChartImageProcessing
Delphi
public event ChartImageProcessing: WebGridChartProcessingEventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
public: __event WebGridChartProcessingEventHandler* ChartImageProcessing
C++/CLI
public:
event WebGridChartProcessingEventHandler^ ChartImageProcessing

Event Data

The event handler receives an argument of type WebGridChartEventArgs containing data related to this event. The following WebGridChartEventArgs properties provide information specific to this event.

Property | Description
AlternativeChartEngine |
ChartConfig |
ReturnValue (Inherited from ISNet.WebUI.WebGrid.BaseEventArgs) |
Table |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members


CustomAggregate Event

[image]
Intersoft WebGrid Documentation
CustomAggregate Event
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class : CustomAggregate Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Behavior")>
<System.ComponentModel.DescriptionAttribute()>
Public Event CustomAggregate As CustomAggregateEventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebGrid
Dim handler As CustomAggregateEventHandler

AddHandler instance.CustomAggregate, handler
C#
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.DescriptionAttribute()]
public event CustomAggregateEventHandler CustomAggregate
Delphi
public event CustomAggregate: CustomAggregateEventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.DescriptionAttribute()]
public: __event CustomAggregateEventHandler* CustomAggregate
C++/CLI
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.DescriptionAttribute()]
public:
event CustomAggregateEventHandler^ CustomAggregate

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members


CustomFilter Event

[image]
Intersoft WebGrid Documentation
CustomFilter Event
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class : CustomFilter Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Behavior")>
<System.ComponentModel.DescriptionAttribute()>
Public Event CustomFilter As CustomFilterEventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebGrid
Dim handler As CustomFilterEventHandler

AddHandler instance.CustomFilter, handler
C#
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.DescriptionAttribute()]
public event CustomFilterEventHandler CustomFilter
Delphi
public event CustomFilter: CustomFilterEventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.DescriptionAttribute()]
public: __event CustomFilterEventHandler* CustomFilter
C++/CLI
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.DescriptionAttribute()]
public:
event CustomFilterEventHandler^ CustomFilter

Event Data

The event handler receives an argument of type FilterEventArgs containing data related to this event. The following FilterEventArgs properties provide information specific to this event.

Property | Description
DataSource |
FilterColumns |
ReturnValue (Inherited from ISNet.WebUI.WebGrid.BaseEventArgs) |
Table |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members


CustomSort Event

[image]
Intersoft WebGrid Documentation
CustomSort Event
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class : CustomSort Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Behavior")>
<System.ComponentModel.DescriptionAttribute()>
Public Event CustomSort As CustomSortEventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebGrid
Dim handler As CustomSortEventHandler

AddHandler instance.CustomSort, handler
C#
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.DescriptionAttribute()]
public event CustomSortEventHandler CustomSort
Delphi
public event CustomSort: CustomSortEventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.DescriptionAttribute()]
public: __event CustomSortEventHandler* CustomSort
C++/CLI
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.DescriptionAttribute()]
public:
event CustomSortEventHandler^ CustomSort

Event Data

The event handler receives an argument of type SortEventArgs containing data related to this event. The following SortEventArgs properties provide information specific to this event.

Property | Description
DataSource |
ReturnValue (Inherited from ISNet.WebUI.WebGrid.BaseEventArgs) |
SortColumns |
Table |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members


DataBinding Event

[image]
Intersoft WebGrid Documentation
DataBinding Event
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class : DataBinding Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<WebSysDescriptionAttribute("Fires when the control's data binding expressions are to be evaluated.")>
<WebCategoryAttribute("Data")>
Public Event DataBinding As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebGrid
Dim handler As System.EventHandler

AddHandler instance.DataBinding, handler
C#
[WebSysDescriptionAttribute("Fires when the control's data binding expressions are to be evaluated.")]
[WebCategoryAttribute("Data")]
public event System.EventHandler DataBinding
Delphi
public event DataBinding: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[WebSysDescriptionAttribute("Fires when the control's data binding expressions are to be evaluated.")]
[WebCategoryAttribute("Data")]
public: __event System.EventHandler* DataBinding
C++/CLI
[WebSysDescriptionAttribute("Fires when the control's data binding expressions are to be evaluated.")]
[WebCategoryAttribute("Data")]
public:
event System.EventHandler^ DataBinding

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members


DeleteRow Event

[image]
Intersoft WebGrid Documentation
DeleteRow Event
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class : DeleteRow Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute()>
<System.ComponentModel.CategoryAttribute("Behavior")>
Public Event DeleteRow As DeleteRowEventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebGrid
Dim handler As DeleteRowEventHandler

AddHandler instance.DeleteRow, handler
C#
[System.ComponentModel.DescriptionAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
public event DeleteRowEventHandler DeleteRow
Delphi
public event DeleteRow: DeleteRowEventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
public: __event DeleteRowEventHandler* DeleteRow
C++/CLI
[System.ComponentModel.DescriptionAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
public:
event DeleteRowEventHandler^ DeleteRow

Event Data

The event handler receives an argument of type RowEventArgs containing data related to this event. The following RowEventArgs properties provide information specific to this event.

Property | Description
ReturnValue (Inherited from ISNet.WebUI.WebGrid.BaseEventArgs) |
Row |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members


Disposed Event

[image]
Intersoft WebGrid Documentation
Disposed Event
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class : Disposed Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<WebSysDescriptionAttribute("Fires when the control has been disposed.")>
Public Event Disposed As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebGrid
Dim handler As System.EventHandler

AddHandler instance.Disposed, handler
C#
[WebSysDescriptionAttribute("Fires when the control has been disposed.")]
public event System.EventHandler Disposed
Delphi
public event Disposed: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[WebSysDescriptionAttribute("Fires when the control has been disposed.")]
public: __event System.EventHandler* Disposed
C++/CLI
[WebSysDescriptionAttribute("Fires when the control has been disposed.")]
public:
event System.EventHandler^ Disposed

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members


Export Event

[image]
Intersoft WebGrid Documentation
Export Event
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class : Export Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Behavior")>
<System.ComponentModel.DescriptionAttribute()>
Public Event Export As ExportEventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebGrid
Dim handler As ExportEventHandler

AddHandler instance.Export, handler
C#
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.DescriptionAttribute()]
public event ExportEventHandler Export
Delphi
public event Export: ExportEventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.DescriptionAttribute()]
public: __event ExportEventHandler* Export
C++/CLI
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.DescriptionAttribute()]
public:
event ExportEventHandler^ Export

Event Data

The event handler receives an argument of type ExportEventArgs containing data related to this event. The following ExportEventArgs properties provide information specific to this event.

Property | Description
DataSource |
OutputFileName |
ReportInfo |
ReturnValue (Inherited from ISNet.WebUI.WebGrid.BaseEventArgs) |
Table |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members


ExportCompleted Event

[image]
Intersoft WebGrid Documentation
ExportCompleted Event
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class : ExportCompleted Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Behavior")>
<System.ComponentModel.DescriptionAttribute()>
Public Event ExportCompleted As ExportCompletedEventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebGrid
Dim handler As ExportCompletedEventHandler

AddHandler instance.ExportCompleted, handler
C#
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.DescriptionAttribute()]
public event ExportCompletedEventHandler ExportCompleted
Delphi
public event ExportCompleted: ExportCompletedEventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.DescriptionAttribute()]
public: __event ExportCompletedEventHandler* ExportCompleted
C++/CLI
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.DescriptionAttribute()]
public:
event ExportCompletedEventHandler^ ExportCompleted

Event Data

The event handler receives an argument of type ExportCompletedEventArgs containing data related to this event. The following ExportCompletedEventArgs properties provide information specific to this event.

Property | Description
OutputException |
OutputFile |
OutputStream |
ReturnValue (Inherited from ISNet.WebUI.WebGrid.BaseEventArgs) |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members


Init Event

[image]
Intersoft WebGrid Documentation
Init Event
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class : Init Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<WebSysDescriptionAttribute("Fires when the page has been initialized.")>
Public Event Init As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebGrid
Dim handler As System.EventHandler

AddHandler instance.Init, handler
C#
[WebSysDescriptionAttribute("Fires when the page has been initialized.")]
public event System.EventHandler Init
Delphi
public event Init: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[WebSysDescriptionAttribute("Fires when the page has been initialized.")]
public: __event System.EventHandler* Init
C++/CLI
[WebSysDescriptionAttribute("Fires when the page has been initialized.")]
public:
event System.EventHandler^ Init

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members


InitializeCell Event

[image]
Intersoft WebGrid Documentation
InitializeCell Event
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class : InitializeCell Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute()>
<System.ComponentModel.CategoryAttribute("Behavior")>
Public Event InitializeCell As CellEventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebGrid
Dim handler As CellEventHandler

AddHandler instance.InitializeCell, handler
C#
[System.ComponentModel.DescriptionAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
public event CellEventHandler InitializeCell
Delphi
public event InitializeCell: CellEventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
public: __event CellEventHandler* InitializeCell
C++/CLI
[System.ComponentModel.DescriptionAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
public:
event CellEventHandler^ InitializeCell

Event Data

The event handler receives an argument of type CellEventArgs containing data related to this event. The following CellEventArgs properties provide information specific to this event.

Property | Description
Cell |
ReturnValue (Inherited from ISNet.WebUI.WebGrid.BaseEventArgs) |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members


InitializeChildTableDataSource Event

[image]
Intersoft WebGrid Documentation
InitializeChildTableDataSource Event
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class : InitializeChildTableDataSource Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute()>
<System.ComponentModel.CategoryAttribute("Behavior")>
Public Event InitializeChildTableDataSource As ChildTableDataSourceEventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebGrid
Dim handler As ChildTableDataSourceEventHandler

AddHandler instance.InitializeChildTableDataSource, handler
C#
[System.ComponentModel.DescriptionAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
public event ChildTableDataSourceEventHandler InitializeChildTableDataSource
Delphi
public event InitializeChildTableDataSource: ChildTableDataSourceEventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
public: __event ChildTableDataSourceEventHandler* InitializeChildTableDataSource
C++/CLI
[System.ComponentModel.DescriptionAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
public:
event ChildTableDataSourceEventHandler^ InitializeChildTableDataSource

Event Data

The event handler receives an argument of type ChildTableDataSourceEventArgs containing data related to this event. The following ChildTableDataSourceEventArgs properties provide information specific to this event.

Property | Description
CustomRequestData |
DataSource |
ParentConstraints |
ParentKeyValues |
ParentObject |
ReturnValue (Inherited from ISNet.WebUI.WebGrid.BaseEventArgs) |
Table |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members


InitializeColumn Event

[image]
Intersoft WebGrid Documentation
InitializeColumn Event
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class : InitializeColumn Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute()>
<System.ComponentModel.CategoryAttribute("Behavior")>
Public Event InitializeColumn As ColumnEventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebGrid
Dim handler As ColumnEventHandler

AddHandler instance.InitializeColumn, handler
C#
[System.ComponentModel.DescriptionAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
public event ColumnEventHandler InitializeColumn
Delphi
public event InitializeColumn: ColumnEventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
public: __event ColumnEventHandler* InitializeColumn
C++/CLI
[System.ComponentModel.DescriptionAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
public:
event ColumnEventHandler^ InitializeColumn

Event Data

The event handler receives an argument of type ColumnEventArgs containing data related to this event. The following ColumnEventArgs properties provide information specific to this event.

Property | Description
Column |
ReturnValue (Inherited from ISNet.WebUI.WebGrid.BaseEventArgs) |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members


InitializeDataSource Event

[image]
Intersoft WebGrid Documentation
InitializeDataSource Event
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class : InitializeDataSource Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute()>
<System.ComponentModel.CategoryAttribute("Behavior")>
Public Event InitializeDataSource As DataSourceEventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebGrid
Dim handler As DataSourceEventHandler

AddHandler instance.InitializeDataSource, handler
C#
[System.ComponentModel.DescriptionAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
public event DataSourceEventHandler InitializeDataSource
Delphi
public event InitializeDataSource: DataSourceEventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
public: __event DataSourceEventHandler* InitializeDataSource
C++/CLI
[System.ComponentModel.DescriptionAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
public:
event DataSourceEventHandler^ InitializeDataSource

Event Data

The event handler receives an argument of type DataSourceEventArgs containing data related to this event. The following DataSourceEventArgs properties provide information specific to this event.

Property | Description
DataSource |
ReturnValue (Inherited from ISNet.WebUI.WebGrid.BaseEventArgs) |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members


InitializeJsonRow Event

[image]
Intersoft WebGrid Documentation
InitializeJsonRow Event
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class : InitializeJsonRow Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute()>
<System.ComponentModel.CategoryAttribute("Behavior")>
Public Event InitializeJsonRow As RowEventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebGrid
Dim handler As RowEventHandler

AddHandler instance.InitializeJsonRow, handler
C#
[System.ComponentModel.DescriptionAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
public event RowEventHandler InitializeJsonRow
Delphi
public event InitializeJsonRow: RowEventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
public: __event RowEventHandler* InitializeJsonRow
C++/CLI
[System.ComponentModel.DescriptionAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
public:
event RowEventHandler^ InitializeJsonRow

Event Data

The event handler receives an argument of type RowEventArgs containing data related to this event. The following RowEventArgs properties provide information specific to this event.

Property | Description
ReturnValue (Inherited from ISNet.WebUI.WebGrid.BaseEventArgs) |
Row |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members


InitializeLayout Event

[image]
Intersoft WebGrid Documentation
InitializeLayout Event
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class : InitializeLayout Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Behavior")>
<System.ComponentModel.DescriptionAttribute()>
Public Event InitializeLayout As LayoutEventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebGrid
Dim handler As LayoutEventHandler

AddHandler instance.InitializeLayout, handler
C#
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.DescriptionAttribute()]
public event LayoutEventHandler InitializeLayout
Delphi
public event InitializeLayout: LayoutEventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.DescriptionAttribute()]
public: __event LayoutEventHandler* InitializeLayout
C++/CLI
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.DescriptionAttribute()]
public:
event LayoutEventHandler^ InitializeLayout

Event Data

The event handler receives an argument of type LayoutEventArgs containing data related to this event. The following LayoutEventArgs properties provide information specific to this event.

Property | Description
Layout |
ReturnValue (Inherited from ISNet.WebUI.WebGrid.BaseEventArgs) |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members


InitializePostBack Event

[image]
Intersoft WebGrid Documentation
InitializePostBack Event
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class : InitializePostBack Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute()>
<System.ComponentModel.CategoryAttribute("Behavior")>
Public Event InitializePostBack As PostBackEventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebGrid
Dim handler As PostBackEventHandler

AddHandler instance.InitializePostBack, handler
C#
[System.ComponentModel.DescriptionAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
public event PostBackEventHandler InitializePostBack
Delphi
public event InitializePostBack: PostBackEventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
public: __event PostBackEventHandler* InitializePostBack
C++/CLI
[System.ComponentModel.DescriptionAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
public:
event PostBackEventHandler^ InitializePostBack

Event Data

The event handler receives an argument of type PostbackEventArgs containing data related to this event. The following PostbackEventArgs properties provide information specific to this event.

Property | Description
Action |
CustomActionData |
DataSource |
Grid |
ReturnValue (Inherited from ISNet.WebUI.WebGrid.BaseEventArgs) |
XmlRequest |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members


InitializeRow Event

[image]
Intersoft WebGrid Documentation
InitializeRow Event
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class : InitializeRow Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Behavior")>
<System.ComponentModel.DescriptionAttribute()>
Public Event InitializeRow As RowEventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebGrid
Dim handler As RowEventHandler

AddHandler instance.InitializeRow, handler
C#
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.DescriptionAttribute()]
public event RowEventHandler InitializeRow
Delphi
public event InitializeRow: RowEventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.DescriptionAttribute()]
public: __event RowEventHandler* InitializeRow
C++/CLI
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.DescriptionAttribute()]
public:
event RowEventHandler^ InitializeRow

Event Data

The event handler receives an argument of type RowEventArgs containing data related to this event. The following RowEventArgs properties provide information specific to this event.

Property | Description
ReturnValue (Inherited from ISNet.WebUI.WebGrid.BaseEventArgs) |
Row |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members


InitializeSelfReferenceDataSource Event

[image]
Intersoft WebGrid Documentation
InitializeSelfReferenceDataSource Event
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class : InitializeSelfReferenceDataSource Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute()>
<System.ComponentModel.CategoryAttribute("Behavior")>
Public Event InitializeSelfReferenceDataSource As ChildTableDataSourceEventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebGrid
Dim handler As ChildTableDataSourceEventHandler

AddHandler instance.InitializeSelfReferenceDataSource, handler
C#
[System.ComponentModel.DescriptionAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
public event ChildTableDataSourceEventHandler InitializeSelfReferenceDataSource
Delphi
public event InitializeSelfReferenceDataSource: ChildTableDataSourceEventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
public: __event ChildTableDataSourceEventHandler* InitializeSelfReferenceDataSource
C++/CLI
[System.ComponentModel.DescriptionAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
public:
event ChildTableDataSourceEventHandler^ InitializeSelfReferenceDataSource

Event Data

The event handler receives an argument of type ChildTableDataSourceEventArgs containing data related to this event. The following ChildTableDataSourceEventArgs properties provide information specific to this event.

Property | Description
CustomRequestData |
DataSource |
ParentConstraints |
ParentKeyValues |
ParentObject |
ReturnValue (Inherited from ISNet.WebUI.WebGrid.BaseEventArgs) |
Table |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members


InitializeTable Event

[image]
Intersoft WebGrid Documentation
InitializeTable Event
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class : InitializeTable Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Behavior")>
<System.ComponentModel.DescriptionAttribute()>
Public Event InitializeTable As TableEventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebGrid
Dim handler As TableEventHandler

AddHandler instance.InitializeTable, handler
C#
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.DescriptionAttribute()]
public event TableEventHandler InitializeTable
Delphi
public event InitializeTable: TableEventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.DescriptionAttribute()]
public: __event TableEventHandler* InitializeTable
C++/CLI
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.DescriptionAttribute()]
public:
event TableEventHandler^ InitializeTable

Event Data

The event handler receives an argument of type TableEventArgs containing data related to this event. The following TableEventArgs properties provide information specific to this event.

Property | Description
ReturnValue (Inherited from ISNet.WebUI.WebGrid.BaseEventArgs) |
Table |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members


Load Event

[image]
Intersoft WebGrid Documentation
Load Event
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class : Load Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<WebSysDescriptionAttribute("Fires when the page has been loaded.")>
Public Event Load As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebGrid
Dim handler As System.EventHandler

AddHandler instance.Load, handler
C#
[WebSysDescriptionAttribute("Fires when the page has been loaded.")]
public event System.EventHandler Load
Delphi
public event Load: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[WebSysDescriptionAttribute("Fires when the page has been loaded.")]
public: __event System.EventHandler* Load
C++/CLI
[WebSysDescriptionAttribute("Fires when the page has been loaded.")]
public:
event System.EventHandler^ Load

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members


LoadPreviewRow Event

[image]
Intersoft WebGrid Documentation
LoadPreviewRow Event
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class : LoadPreviewRow Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Behavior")>
<System.ComponentModel.DescriptionAttribute()>
Public Event LoadPreviewRow As RowEventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebGrid
Dim handler As RowEventHandler

AddHandler instance.LoadPreviewRow, handler
C#
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.DescriptionAttribute()]
public event RowEventHandler LoadPreviewRow
Delphi
public event LoadPreviewRow: RowEventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.DescriptionAttribute()]
public: __event RowEventHandler* LoadPreviewRow
C++/CLI
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.DescriptionAttribute()]
public:
event RowEventHandler^ LoadPreviewRow

Event Data

The event handler receives an argument of type RowEventArgs containing data related to this event. The following RowEventArgs properties provide information specific to this event.

Property | Description
ReturnValue (Inherited from ISNet.WebUI.WebGrid.BaseEventArgs) |
Row |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members


PreInitialize Event

[image]
Intersoft WebGrid Documentation
PreInitialize Event
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class : PreInitialize Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Event PreInitialize As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebGrid
Dim handler As System.EventHandler

AddHandler instance.PreInitialize, handler
C#
public event System.EventHandler PreInitialize
Delphi
public event PreInitialize: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
public: __event System.EventHandler* PreInitialize
C++/CLI
public:
event System.EventHandler^ PreInitialize

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members


PrepareDataBinding Event

[image]
Intersoft WebGrid Documentation
PrepareDataBinding Event
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class : PrepareDataBinding Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Behavior")>
<System.ComponentModel.DescriptionAttribute()>
Public Event PrepareDataBinding As DataSourceEventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebGrid
Dim handler As DataSourceEventHandler

AddHandler instance.PrepareDataBinding, handler
C#
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.DescriptionAttribute()]
public event DataSourceEventHandler PrepareDataBinding
Delphi
public event PrepareDataBinding: DataSourceEventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.DescriptionAttribute()]
public: __event DataSourceEventHandler* PrepareDataBinding
C++/CLI
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.DescriptionAttribute()]
public:
event DataSourceEventHandler^ PrepareDataBinding

Event Data

The event handler receives an argument of type DataSourceEventArgs containing data related to this event. The following DataSourceEventArgs properties provide information specific to this event.

Property | Description
DataSource |
ReturnValue (Inherited from ISNet.WebUI.WebGrid.BaseEventArgs) |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members


PrepareExportExecute Event

[image]
Intersoft WebGrid Documentation
PrepareExportExecute Event
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class : PrepareExportExecute Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute()>
<System.ComponentModel.CategoryAttribute("Behavior")>
Public Event PrepareExportExecute As PrepareExportExecuteEventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebGrid
Dim handler As PrepareExportExecuteEventHandler

AddHandler instance.PrepareExportExecute, handler
C#
[System.ComponentModel.DescriptionAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
public event PrepareExportExecuteEventHandler PrepareExportExecute
Delphi
public event PrepareExportExecute: PrepareExportExecuteEventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
public: __event PrepareExportExecuteEventHandler* PrepareExportExecute
C++/CLI
[System.ComponentModel.DescriptionAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
public:
event PrepareExportExecuteEventHandler^ PrepareExportExecute

Event Data

The event handler receives an argument of type PrepareExportExecuteEventArgs containing data related to this event. The following PrepareExportExecuteEventArgs properties provide information specific to this event.

Property | Description
ReportObject |
ReturnValue (Inherited from ISNet.WebUI.WebGrid.BaseEventArgs) |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members


PreRender Event

[image]
Intersoft WebGrid Documentation
PreRender Event
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class : PreRender Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<WebSysDescriptionAttribute("Fires before the page is rendered.")>
Public Event PreRender As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebGrid
Dim handler As System.EventHandler

AddHandler instance.PreRender, handler
C#
[WebSysDescriptionAttribute("Fires before the page is rendered.")]
public event System.EventHandler PreRender
Delphi
public event PreRender: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[WebSysDescriptionAttribute("Fires before the page is rendered.")]
public: __event System.EventHandler* PreRender
C++/CLI
[WebSysDescriptionAttribute("Fires before the page is rendered.")]
public:
event System.EventHandler^ PreRender

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members


RowChanged Event

[image]
Intersoft WebGrid Documentation
RowChanged Event
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class : RowChanged Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Behavior")>
<System.ComponentModel.DescriptionAttribute()>
Public Event RowChanged As System.EventHandler(Of RowChangedEventArgs)
Visual Basic (Usage) Copy Code
Dim instance As WebGrid
Dim handler As System.EventHandler(Of RowChangedEventArgs)

AddHandler instance.RowChanged, handler
C#
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.DescriptionAttribute()]
public event System.EventHandler<RowChangedEventArgs> RowChanged
Delphi
public event RowChanged: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.DescriptionAttribute()]
public: __event System.EventHandler<RowChangedEventArgs*>* RowChanged
C++/CLI
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.DescriptionAttribute()]
public:
event System.EventHandler<RowChangedEventArgs^>^ RowChanged

Event Data

The event handler receives an argument of type RowChangedEventArgs containing data related to this event. The following RowChangedEventArgs properties provide information specific to this event.

Property | Description
KeyValue |
ReturnValue (Inherited from ISNet.WebUI.WebGrid.BaseEventArgs) |
Row (Inherited from ISNet.WebUI.WebGrid.RowEventArgs) |
Table |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members


Unload Event

[image]
Intersoft WebGrid Documentation
Unload Event
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class : Unload Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<WebSysDescriptionAttribute("Fires when the page is unloaded.")>
Public Event Unload As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebGrid
Dim handler As System.EventHandler

AddHandler instance.Unload, handler
C#
[WebSysDescriptionAttribute("Fires when the page is unloaded.")]
public event System.EventHandler Unload
Delphi
public event Unload: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[WebSysDescriptionAttribute("Fires when the page is unloaded.")]
public: __event System.EventHandler* Unload
C++/CLI
[WebSysDescriptionAttribute("Fires when the page is unloaded.")]
public:
event System.EventHandler^ Unload

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members


UpdateRow Event

[image]
Intersoft WebGrid Documentation
UpdateRow Event
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGrid Class : UpdateRow Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute()>
<System.ComponentModel.CategoryAttribute("Behavior")>
Public Event UpdateRow As UpdateRowEventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebGrid
Dim handler As UpdateRowEventHandler

AddHandler instance.UpdateRow, handler
C#
[System.ComponentModel.DescriptionAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
public event UpdateRowEventHandler UpdateRow
Delphi
public event UpdateRow: UpdateRowEventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
public: __event UpdateRowEventHandler* UpdateRow
C++/CLI
[System.ComponentModel.DescriptionAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
public:
event UpdateRowEventHandler^ UpdateRow

Event Data

The event handler receives an argument of type RowEventArgs containing data related to this event. The following RowEventArgs properties provide information specific to this event.

Property | Description
ReturnValue (Inherited from ISNet.WebUI.WebGrid.BaseEventArgs) |
Row |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGrid Class
WebGrid Members


WebGridBatchUpdateException Class

[image]
Intersoft WebGrid Documentation
WebGridBatchUpdateException Class
Members See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : WebGridBatchUpdateException Class

Glossary Item Box

Object Model

WebGridBatchUpdateException Class

Syntax

Visual Basic (Declaration)
Public Class WebGridBatchUpdateException
   Inherits System.Exception
Visual Basic (Usage) Copy Code
Dim instance As WebGridBatchUpdateException
C#
public class WebGridBatchUpdateException : System.Exception
Delphi
public class WebGridBatchUpdateException = class(System.Exception)
JScript
public class WebGridBatchUpdateException extends System.Exception
Managed Extensions for C++
public __gc class WebGridBatchUpdateException : public System.Exception
C++/CLI
public ref class WebGridBatchUpdateException : public System.Exception

Inheritance Hierarchy

System.Object
System.Exception
ISNet.WebUI.WebGrid.WebGridBatchUpdateException

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridBatchUpdateException Members
ISNet.WebUI.WebGrid Namespace


WebGridBatchUpdateException Class Members

[image]
Intersoft WebGrid Documentation
WebGridBatchUpdateException Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebGrid Namespace : WebGridBatchUpdateException Class

Glossary Item Box

The following tables list the members exposed by WebGridBatchUpdateException.

Public Constructors

 | Name | Description
Public Constructor | WebGridBatchUpdateException Constructor |
Top

Public Properties

 | Name | Description
Public Property | Data | (Inherited from System.Exception)
Public Property | Exception |
Public Property | HelpLink | (Inherited from System.Exception)
Public Property | HResult | (Inherited from System.Exception)
Public Property | InnerException | (Inherited from System.Exception)
Public Property | Message | (Inherited from System.Exception)
Public Property | RowChanges |
Public Property | Source | (Inherited from System.Exception)
Public Property | StackTrace | (Inherited from System.Exception)
Public Property | TargetSite | (Inherited from System.Exception)
Top

Public Methods

 | Name | Description
Public Method | GetBaseException | (Inherited from System.Exception)
Public Method | GetObjectData | (Inherited from System.Exception)
Public Method | GetType | (Inherited from System.Exception)
Public Method | ToString | (Inherited from System.Exception)
Top

See Also

Reference

WebGridBatchUpdateException Class
ISNet.WebUI.WebGrid Namespace


WebGridBatchUpdateException Class Methods

[image]
Intersoft WebGrid Documentation
WebGridBatchUpdateException Class Methods
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : WebGridBatchUpdateException Class

Glossary Item Box

For a list of all members of this type, see WebGridBatchUpdateException members.

Public Methods

 | Name | Description
Public Method | GetBaseException | (Inherited from System.Exception)
Public Method | GetObjectData | (Inherited from System.Exception)
Public Method | GetType | (Inherited from System.Exception)
Public Method | ToString | (Inherited from System.Exception)
Top

See Also

Reference

WebGridBatchUpdateException Class
ISNet.WebUI.WebGrid Namespace


WebGridBatchUpdateException Constructor

[image]
Intersoft WebGrid Documentation
WebGridBatchUpdateException Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridBatchUpdateException Class : WebGridBatchUpdateException Constructor

changes
exception

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal changes As WebGridRowChanges, _
   ByVal exception As System.Exception _
)
Visual Basic (Usage) Copy Code
Dim changes As WebGridRowChanges
Dim exception As System.Exception

Dim instance As New WebGridBatchUpdateException(changes, exception)
C#
public WebGridBatchUpdateException(
   WebGridRowChanges changes,
   System.Exception exception
)
Delphi
public WebGridBatchUpdateException(
    changes: WebGridRowChanges;
    exception: System.Exception
);
JScript
public function WebGridBatchUpdateException(
   changes : WebGridRowChanges,
   exception : System.Exception
);
Managed Extensions for C++
public: WebGridBatchUpdateException(
   WebGridRowChanges* changes,
   System.Exception* exception
)
C++/CLI
public:
WebGridBatchUpdateException(
   WebGridRowChanges^ changes,
   System.Exception^ exception
)

Parameters

changes
exception

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridBatchUpdateException Class
WebGridBatchUpdateException Members


GetBaseException Method

[image]
Intersoft WebGrid Documentation
GetBaseException Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridBatchUpdateException Class : GetBaseException Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
<__DynamicallyInvokableAttribute()>
Public Overridable Function GetBaseException() As System.Exception
Visual Basic (Usage) Copy Code
Dim instance As WebGridBatchUpdateException
Dim value As System.Exception

value = instance.GetBaseException()
C#
[__DynamicallyInvokableAttribute()]
public virtual System.Exception GetBaseException()
Delphi
public function GetBaseException(): System.Exception; virtual;
JScript
__DynamicallyInvokableAttribute()
public function GetBaseException() : System.Exception;
Managed Extensions for C++
[__DynamicallyInvokableAttribute()]
public: virtual System.Exception* GetBaseException();
C++/CLI
[__DynamicallyInvokableAttribute()]
public:
virtual System.Exception^ GetBaseException();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridBatchUpdateException Class
WebGridBatchUpdateException Members


GetObjectData Method

[image]
Intersoft WebGrid Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridBatchUpdateException Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Security.SecurityCriticalAttribute()>
Public Overridable Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebGridBatchUpdateException
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
[System.Security.SecurityCriticalAttribute()]
public virtual void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure GetObjectData(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
); virtual;
JScript
System.Security.SecurityCriticalAttribute()
public function GetObjectData(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
[System.Security.SecurityCriticalAttribute()]
public: virtual void GetObjectData(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
[System.Security.SecurityCriticalAttribute()]
public:
virtual void GetObjectData(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridBatchUpdateException Class
WebGridBatchUpdateException Members


GetType Method

[image]
Intersoft WebGrid Documentation
GetType Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridBatchUpdateException Class : GetType Method

Glossary Item Box

Overload List

Overload | Description
GetType | (Inherited from System.Exception)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridBatchUpdateException Class
WebGridBatchUpdateException Members


GetType() Method

[image]
Intersoft WebGrid Documentation
GetType() Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridBatchUpdateException Class : GetType() Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
<__DynamicallyInvokableAttribute()>
Public Function GetType() As System.Type
Visual Basic (Usage) Copy Code
Dim instance As WebGridBatchUpdateException
Dim value As System.Type

value = instance.GetType()
C#
[__DynamicallyInvokableAttribute()]
public System.Type GetType()
Delphi
public function GetType(): System.Type;
JScript
__DynamicallyInvokableAttribute()
public function GetType() : System.Type;
Managed Extensions for C++
[__DynamicallyInvokableAttribute()]
public: System.Type* GetType();
C++/CLI
[__DynamicallyInvokableAttribute()]
public:
System.Type^ GetType();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridBatchUpdateException Class
WebGridBatchUpdateException Members


ToString Method

[image]
Intersoft WebGrid Documentation
ToString Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridBatchUpdateException Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
<__DynamicallyInvokableAttribute()>
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")>
Public Overridable Function ToString() As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebGridBatchUpdateException
Dim value As System.String

value = instance.ToString()
C#
[__DynamicallyInvokableAttribute()]
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public virtual System.string ToString()
Delphi
public function ToString(): System.String; virtual;
JScript
__DynamicallyInvokableAttribute()
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")
public function ToString() : System.String;
Managed Extensions for C++
[__DynamicallyInvokableAttribute()]
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public: virtual System.string* ToString();
C++/CLI
[__DynamicallyInvokableAttribute()]
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public:
virtual System.String^ ToString();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridBatchUpdateException Class
WebGridBatchUpdateException Members


Data Property

[image]
Intersoft WebGrid Documentation
Data Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridBatchUpdateException Class : Data Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<__DynamicallyInvokableAttribute()>
Public Overridable ReadOnly Property Data As System.Collections.IDictionary
Visual Basic (Usage) Copy Code
Dim instance As WebGridBatchUpdateException
Dim value As System.Collections.IDictionary

value = instance.Data
C#
[__DynamicallyInvokableAttribute()]
public virtual System.Collections.IDictionary Data {get;}
Delphi
public read-only property Data: System.Collections.IDictionary; virtual;
JScript
__DynamicallyInvokableAttribute()
public function get Data : System.Collections.IDictionary
Managed Extensions for C++
[__DynamicallyInvokableAttribute()]
public: __property virtual System.Collections.IDictionary* get_Data();
C++/CLI
[__DynamicallyInvokableAttribute()]
public:
virtual property System.Collections.IDictionary^ Data {
   System.Collections.IDictionary^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridBatchUpdateException Class
WebGridBatchUpdateException Members


WebGridBatchUpdateException Class Properties

[image]
Intersoft WebGrid Documentation
WebGridBatchUpdateException Class Properties
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : WebGridBatchUpdateException Class

Glossary Item Box

For a list of all members of this type, see WebGridBatchUpdateException members.

Public Properties

 | Name | Description
Public Property | Data | (Inherited from System.Exception)
Public Property | Exception |
Public Property | HelpLink | (Inherited from System.Exception)
Public Property | HResult | (Inherited from System.Exception)
Public Property | InnerException | (Inherited from System.Exception)
Public Property | Message | (Inherited from System.Exception)
Public Property | RowChanges |
Public Property | Source | (Inherited from System.Exception)
Public Property | StackTrace | (Inherited from System.Exception)
Public Property | TargetSite | (Inherited from System.Exception)
Top

See Also

Reference

WebGridBatchUpdateException Class
ISNet.WebUI.WebGrid Namespace


Exception Property

[image]
Intersoft WebGrid Documentation
Exception Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridBatchUpdateException Class : Exception Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Exception As System.Exception
Visual Basic (Usage) Copy Code
Dim instance As WebGridBatchUpdateException
Dim value As System.Exception

value = instance.Exception
C#
public System.Exception Exception {get;}
Delphi
public read-only property Exception: System.Exception;
JScript
public function get Exception : System.Exception
Managed Extensions for C++
public: __property System.Exception* get_Exception();
C++/CLI
public:
property System.Exception^ Exception {
   System.Exception^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridBatchUpdateException Class
WebGridBatchUpdateException Members


HelpLink Property

[image]
Intersoft WebGrid Documentation
HelpLink Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridBatchUpdateException Class : HelpLink Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<__DynamicallyInvokableAttribute()>
Public Overridable Property HelpLink As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebGridBatchUpdateException
Dim value As System.String

instance.HelpLink = value

value = instance.HelpLink
C#
[__DynamicallyInvokableAttribute()]
public virtual System.string HelpLink {get; set;}
Delphi
public read-write property HelpLink: System.String; virtual;
JScript
__DynamicallyInvokableAttribute()
public function get,set HelpLink : System.String
Managed Extensions for C++
[__DynamicallyInvokableAttribute()]
public: __property virtual System.string* get_HelpLink();
public: __property virtual void set_HelpLink(
   System.string* value
);
C++/CLI
[__DynamicallyInvokableAttribute()]
public:
virtual property System.String^ HelpLink {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridBatchUpdateException Class
WebGridBatchUpdateException Members


HResult Property

[image]
Intersoft WebGrid Documentation
HResult Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridBatchUpdateException Class : HResult Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<__DynamicallyInvokableAttribute()>
Public ReadOnly Property HResult As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebGridBatchUpdateException
Dim value As System.Integer

value = instance.HResult
C#
[__DynamicallyInvokableAttribute()]
public System.int HResult {get;}
Delphi
public read-only property HResult: System.Integer;
JScript
__DynamicallyInvokableAttribute()
public function get HResult : System.int
Managed Extensions for C++
[__DynamicallyInvokableAttribute()]
public: __property System.int get_HResult();
C++/CLI
[__DynamicallyInvokableAttribute()]
public:
property System.int HResult {
   System.int get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridBatchUpdateException Class
WebGridBatchUpdateException Members


InnerException Property

[image]
Intersoft WebGrid Documentation
InnerException Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridBatchUpdateException Class : InnerException Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<__DynamicallyInvokableAttribute()>
Public ReadOnly Property InnerException As System.Exception
Visual Basic (Usage) Copy Code
Dim instance As WebGridBatchUpdateException
Dim value As System.Exception

value = instance.InnerException
C#
[__DynamicallyInvokableAttribute()]
public System.Exception InnerException {get;}
Delphi
public read-only property InnerException: System.Exception;
JScript
__DynamicallyInvokableAttribute()
public function get InnerException : System.Exception
Managed Extensions for C++
[__DynamicallyInvokableAttribute()]
public: __property System.Exception* get_InnerException();
C++/CLI
[__DynamicallyInvokableAttribute()]
public:
property System.Exception^ InnerException {
   System.Exception^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridBatchUpdateException Class
WebGridBatchUpdateException Members


Message Property

[image]
Intersoft WebGrid Documentation
Message Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridBatchUpdateException Class : Message Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<__DynamicallyInvokableAttribute()>
Public Overridable ReadOnly Property Message As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebGridBatchUpdateException
Dim value As System.String

value = instance.Message
C#
[__DynamicallyInvokableAttribute()]
public virtual System.string Message {get;}
Delphi
public read-only property Message: System.String; virtual;
JScript
__DynamicallyInvokableAttribute()
public function get Message : System.String
Managed Extensions for C++
[__DynamicallyInvokableAttribute()]
public: __property virtual System.string* get_Message();
C++/CLI
[__DynamicallyInvokableAttribute()]
public:
virtual property System.String^ Message {
   System.String^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridBatchUpdateException Class
WebGridBatchUpdateException Members


RowChanges Property

[image]
Intersoft WebGrid Documentation
RowChanges Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridBatchUpdateException Class : RowChanges Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property RowChanges As WebGridRowChanges
Visual Basic (Usage) Copy Code
Dim instance As WebGridBatchUpdateException
Dim value As WebGridRowChanges

value = instance.RowChanges
C#
public WebGridRowChanges RowChanges {get;}
Delphi
public read-only property RowChanges: WebGridRowChanges;
JScript
public function get RowChanges : WebGridRowChanges
Managed Extensions for C++
public: __property WebGridRowChanges* get_RowChanges();
C++/CLI
public:
property WebGridRowChanges^ RowChanges {
   WebGridRowChanges^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridBatchUpdateException Class
WebGridBatchUpdateException Members


Source Property

[image]
Intersoft WebGrid Documentation
Source Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridBatchUpdateException Class : Source Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<__DynamicallyInvokableAttribute()>
Public Overridable Property Source As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebGridBatchUpdateException
Dim value As System.String

instance.Source = value

value = instance.Source
C#
[__DynamicallyInvokableAttribute()]
public virtual System.string Source {get; set;}
Delphi
public read-write property Source: System.String; virtual;
JScript
__DynamicallyInvokableAttribute()
public function get,set Source : System.String
Managed Extensions for C++
[__DynamicallyInvokableAttribute()]
public: __property virtual System.string* get_Source();
public: __property virtual void set_Source(
   System.string* value
);
C++/CLI
[__DynamicallyInvokableAttribute()]
public:
virtual property System.String^ Source {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridBatchUpdateException Class
WebGridBatchUpdateException Members


StackTrace Property

[image]
Intersoft WebGrid Documentation
StackTrace Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridBatchUpdateException Class : StackTrace Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<__DynamicallyInvokableAttribute()>
Public Overridable ReadOnly Property StackTrace As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebGridBatchUpdateException
Dim value As System.String

value = instance.StackTrace
C#
[__DynamicallyInvokableAttribute()]
public virtual System.string StackTrace {get;}
Delphi
public read-only property StackTrace: System.String; virtual;
JScript
__DynamicallyInvokableAttribute()
public function get StackTrace : System.String
Managed Extensions for C++
[__DynamicallyInvokableAttribute()]
public: __property virtual System.string* get_StackTrace();
C++/CLI
[__DynamicallyInvokableAttribute()]
public:
virtual property System.String^ StackTrace {
   System.String^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridBatchUpdateException Class
WebGridBatchUpdateException Members


TargetSite Property

[image]
Intersoft WebGrid Documentation
TargetSite Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridBatchUpdateException Class : TargetSite Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property TargetSite As System.Reflection.MethodBase
Visual Basic (Usage) Copy Code
Dim instance As WebGridBatchUpdateException
Dim value As System.Reflection.MethodBase

value = instance.TargetSite
C#
public System.Reflection.MethodBase TargetSite {get;}
Delphi
public read-only property TargetSite: System.Reflection.MethodBase;
JScript
public function get TargetSite : System.Reflection.MethodBase
Managed Extensions for C++
public: __property System.Reflection.MethodBase* get_TargetSite();
C++/CLI
public:
property System.Reflection.MethodBase^ TargetSite {
   System.Reflection.MethodBase^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridBatchUpdateException Class
WebGridBatchUpdateException Members


WebGridBatchUpdateSettings Class

[image]
Intersoft WebGrid Documentation
WebGridBatchUpdateSettings Class
Members See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : WebGridBatchUpdateSettings Class

Glossary Item Box

Object Model

WebGridBatchUpdateSettings Class

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DescriptionAttribute()>
<System.SerializableAttribute()>
Public Class WebGridBatchUpdateSettings
   Inherits ISNet.WebUI.WebUIBaseClass
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Visual Basic (Usage) Copy Code
Dim instance As WebGridBatchUpdateSettings
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute()]
[System.SerializableAttribute()]
public class WebGridBatchUpdateSettings : ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Delphi
public class WebGridBatchUpdateSettings = class(ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize)
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DescriptionAttribute()
System.SerializableAttribute()
public class WebGridBatchUpdateSettings extends ISNet.WebUI.WebUIBaseClass implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute()]
[System.SerializableAttribute()]
public __gc class WebGridBatchUpdateSettings : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute()]
[System.SerializableAttribute()]
public ref class WebGridBatchUpdateSettings : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.WebGrid.WebGridBatchUpdateSettings

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridBatchUpdateSettings Members
ISNet.WebUI.WebGrid Namespace


WebGridBatchUpdateSettings Class Members

[image]
Intersoft WebGrid Documentation
WebGridBatchUpdateSettings Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebGrid Namespace : WebGridBatchUpdateSettings Class

Glossary Item Box

The following tables list the members exposed by WebGridBatchUpdateSettings.

Public Constructors

 | Name | Description
Public Constructor | WebGridBatchUpdateSettings Constructor |
Top

Public Properties

 | Name | Description
Public Property | AllowReviewChanges |
Public Property | AllowUndoChanges |
Public Property | AutomaticObjectUpdate |
Public Property | HighlightChanges |
Public Property | NotifyOnLostFocus |
Public Property | PromptOnUndoAllChanges |
Public Property | PromptUnsavedChanges |
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebGridBatchUpdateSettings Class
ISNet.WebUI.WebGrid Namespace


WebGridBatchUpdateSettings Constructor

[image]
Intersoft WebGrid Documentation
WebGridBatchUpdateSettings Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridBatchUpdateSettings Class : WebGridBatchUpdateSettings Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebGridBatchUpdateSettings()
C#
public WebGridBatchUpdateSettings()
Delphi
public WebGridBatchUpdateSettings();
JScript
public function WebGridBatchUpdateSettings();
Managed Extensions for C++
public: WebGridBatchUpdateSettings();
C++/CLI
public:
WebGridBatchUpdateSettings();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridBatchUpdateSettings Class
WebGridBatchUpdateSettings Members


Clone Method

[image]
Intersoft WebGrid Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridBatchUpdateSettings Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As System.Object
Visual Basic (Usage) Copy Code
Dim instance As WebGridBatchUpdateSettings
Dim value As System.Object

value = instance.Clone()
C#
public virtual System.object Clone()
Delphi
public function Clone(): System.TObject; virtual;
JScript
public function Clone() : System.Object;
Managed Extensions for C++
public: virtual System.Object* Clone();
C++/CLI
public:
virtual System.Object^ Clone();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridBatchUpdateSettings Class
WebGridBatchUpdateSettings Members


CopyFrom Method

[image]
Intersoft WebGrid Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridBatchUpdateSettings Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridBatchUpdateSettings Class
WebGridBatchUpdateSettings Members


CopyFrom(Object) Method

[image]
Intersoft WebGrid Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridBatchUpdateSettings Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebGridBatchUpdateSettings
Dim objSource As System.Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   System.object objSource
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridBatchUpdateSettings Class
WebGridBatchUpdateSettings Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebGrid Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridBatchUpdateSettings Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object, _
   ByVal cloneSourceValue As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebGridBatchUpdateSettings
Dim objSource As System.Object
Dim cloneSourceValue As System.Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   System.object objSource,
   System.bool cloneSourceValue
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject;
    cloneSourceValue: System.Boolean
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object,
   cloneSourceValue : System.boolean
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource,
   System.bool cloneSourceValue
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource,
   System.bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridBatchUpdateSettings Class
WebGridBatchUpdateSettings Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebGrid Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridBatchUpdateSettings Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebGridBatchUpdateSettings
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure DeSerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function DeSerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void DeSerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void DeSerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridBatchUpdateSettings Class
WebGridBatchUpdateSettings Members


GetHashCode Method

[image]
Intersoft WebGrid Documentation
GetHashCode Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridBatchUpdateSettings Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebGridBatchUpdateSettings
Dim value As System.Integer

value = instance.GetHashCode()
C#
public virtual System.int GetHashCode()
Delphi
public function GetHashCode(): System.Integer; virtual;
JScript
public function GetHashCode() : System.int;
Managed Extensions for C++
public: virtual System.int GetHashCode();
C++/CLI
public:
virtual System.int GetHashCode();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridBatchUpdateSettings Class
WebGridBatchUpdateSettings Members


WebGridBatchUpdateSettings Class Methods

[image]
Intersoft WebGrid Documentation
WebGridBatchUpdateSettings Class Methods
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : WebGridBatchUpdateSettings Class

Glossary Item Box

For a list of all members of this type, see WebGridBatchUpdateSettings members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebGridBatchUpdateSettings Class
ISNet.WebUI.WebGrid Namespace


GetObjectData Method

[image]
Intersoft WebGrid Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridBatchUpdateSettings Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebGridBatchUpdateSettings
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure GetObjectData(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
); override;
JScript
public override function GetObjectData(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void GetObjectData(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
) override
C++/CLI
public:
void GetObjectData(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
) override

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridBatchUpdateSettings Class
WebGridBatchUpdateSettings Members


IsEmpty Method

[image]
Intersoft WebGrid Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridBatchUpdateSettings Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebGridBatchUpdateSettings
Dim value As System.Boolean

value = instance.IsEmpty()
C#
public virtual System.bool IsEmpty()
Delphi
public function IsEmpty(): System.Boolean; virtual;
JScript
public function IsEmpty() : System.boolean;
Managed Extensions for C++
public: virtual System.bool IsEmpty();
C++/CLI
public:
virtual System.bool IsEmpty();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridBatchUpdateSettings Class
WebGridBatchUpdateSettings Members


Reset Method

[image]
Intersoft WebGrid Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridBatchUpdateSettings Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As WebGridBatchUpdateSettings

instance.Reset()
C#
public virtual void Reset()
Delphi
public procedure Reset(); virtual;
JScript
public function Reset();
Managed Extensions for C++
public: virtual void Reset();
C++/CLI
public:
virtual void Reset();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridBatchUpdateSettings Class
WebGridBatchUpdateSettings Members


SerializeObjectData Method

[image]
Intersoft WebGrid Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridBatchUpdateSettings Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebGridBatchUpdateSettings
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure SerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function SerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void SerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void SerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridBatchUpdateSettings Class
WebGridBatchUpdateSettings Members


ToString Method

[image]
Intersoft WebGrid Documentation
ToString Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridBatchUpdateSettings Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebGridBatchUpdateSettings
Dim value As System.String

value = instance.ToString()
C#
public virtual System.string ToString()
Delphi
public function ToString(): System.String; virtual;
JScript
public function ToString() : System.String;
Managed Extensions for C++
public: virtual System.string* ToString();
C++/CLI
public:
virtual System.String^ ToString();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridBatchUpdateSettings Class
WebGridBatchUpdateSettings Members


WebGridBatchUpdateSettings Class Properties

[image]
Intersoft WebGrid Documentation
WebGridBatchUpdateSettings Class Properties
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : WebGridBatchUpdateSettings Class

Glossary Item Box

For a list of all members of this type, see WebGridBatchUpdateSettings members.

Public Properties

 | Name | Description
Public Property | AllowReviewChanges |
Public Property | AllowUndoChanges |
Public Property | AutomaticObjectUpdate |
Public Property | HighlightChanges |
Public Property | NotifyOnLostFocus |
Public Property | PromptOnUndoAllChanges |
Public Property | PromptUnsavedChanges |
Top

See Also

Reference

WebGridBatchUpdateSettings Class
ISNet.WebUI.WebGrid Namespace


WebGridBatchUpdateSettings Constructor

[image]
Intersoft WebGrid Documentation
WebGridBatchUpdateSettings Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridBatchUpdateSettings Class : WebGridBatchUpdateSettings Constructor

Glossary Item Box

Overload List

Overload | Description
WebGridBatchUpdateSettings Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridBatchUpdateSettings Class
WebGridBatchUpdateSettings Members


AllowReviewChanges Property

[image]
Intersoft WebGrid Documentation
AllowReviewChanges Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridBatchUpdateSettings Class : AllowReviewChanges Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies whether or not user is allowed to review pending changes.")>
Public Property AllowReviewChanges As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebGridBatchUpdateSettings
Dim value As System.Boolean

instance.AllowReviewChanges = value

value = instance.AllowReviewChanges
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether or not user is allowed to review pending changes.")]
public System.bool AllowReviewChanges {get; set;}
Delphi
public read-write property AllowReviewChanges: System.Boolean;
JScript
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Specifies whether or not user is allowed to review pending changes.")
public function get,set AllowReviewChanges : System.boolean
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether or not user is allowed to review pending changes.")]
public: __property System.bool get_AllowReviewChanges();
public: __property void set_AllowReviewChanges(
   System.bool value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether or not user is allowed to review pending changes.")]
public:
property System.bool AllowReviewChanges {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridBatchUpdateSettings Class
WebGridBatchUpdateSettings Members


AllowUndoChanges Property

[image]
Intersoft WebGrid Documentation
AllowUndoChanges Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridBatchUpdateSettings Class : AllowUndoChanges Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies whether or not user is allowed to undo pending changes.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property AllowUndoChanges As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebGridBatchUpdateSettings
Dim value As System.Boolean

instance.AllowUndoChanges = value

value = instance.AllowUndoChanges
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether or not user is allowed to undo pending changes.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.bool AllowUndoChanges {get; set;}
Delphi
public read-write property AllowUndoChanges: System.Boolean;
JScript
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Specifies whether or not user is allowed to undo pending changes.")
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set AllowUndoChanges : System.boolean
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether or not user is allowed to undo pending changes.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.bool get_AllowUndoChanges();
public: __property void set_AllowUndoChanges(
   System.bool value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether or not user is allowed to undo pending changes.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.bool AllowUndoChanges {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridBatchUpdateSettings Class
WebGridBatchUpdateSettings Members


AutomaticObjectUpdate Property

[image]
Intersoft WebGrid Documentation
AutomaticObjectUpdate Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridBatchUpdateSettings Class : AutomaticObjectUpdate Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Indicates whether WebGrid should automatically update all pending changes to data objects whenever possible.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property AutomaticObjectUpdate As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebGridBatchUpdateSettings
Dim value As System.Boolean

instance.AutomaticObjectUpdate = value

value = instance.AutomaticObjectUpdate
C#
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Indicates whether WebGrid should automatically update all pending changes to data objects whenever possible.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.bool AutomaticObjectUpdate {get; set;}
Delphi
public read-write property AutomaticObjectUpdate: System.Boolean;
JScript
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Indicates whether WebGrid should automatically update all pending changes to data objects whenever possible.")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set AutomaticObjectUpdate : System.boolean
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Indicates whether WebGrid should automatically update all pending changes to data objects whenever possible.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.bool get_AutomaticObjectUpdate();
public: __property void set_AutomaticObjectUpdate(
   System.bool value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Indicates whether WebGrid should automatically update all pending changes to data objects whenever possible.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.bool AutomaticObjectUpdate {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridBatchUpdateSettings Class
WebGridBatchUpdateSettings Members


HighlightChanges Property

[image]
Intersoft WebGrid Documentation
HighlightChanges Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridBatchUpdateSettings Class : HighlightChanges Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies whether pending changes rows should be highlighted.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property HighlightChanges As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebGridBatchUpdateSettings
Dim value As System.Boolean

instance.HighlightChanges = value

value = instance.HighlightChanges
C#
[System.ComponentModel.DescriptionAttribute("Specifies whether pending changes rows should be highlighted.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.bool HighlightChanges {get; set;}
Delphi
public read-write property HighlightChanges: System.Boolean;
JScript
System.ComponentModel.DescriptionAttribute("Specifies whether pending changes rows should be highlighted.")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set HighlightChanges : System.boolean
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies whether pending changes rows should be highlighted.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.bool get_HighlightChanges();
public: __property void set_HighlightChanges(
   System.bool value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies whether pending changes rows should be highlighted.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.bool HighlightChanges {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridBatchUpdateSettings Class
WebGridBatchUpdateSettings Members


NotifyOnLostFocus Property

[image]
Intersoft WebGrid Documentation
NotifyOnLostFocus Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridBatchUpdateSettings Class : NotifyOnLostFocus Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies whether WebGrid should notify users when the Grid is losing its focus and there are unsaved pending changes.")>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Property NotifyOnLostFocus As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebGridBatchUpdateSettings
Dim value As System.Boolean

instance.NotifyOnLostFocus = value

value = instance.NotifyOnLostFocus
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether WebGrid should notify users when the Grid is losing its focus and there are unsaved pending changes.")]
[ISNet.Serialization.XmlSerializableAttribute()]
public System.bool NotifyOnLostFocus {get; set;}
Delphi
public read-write property NotifyOnLostFocus: System.Boolean;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Specifies whether WebGrid should notify users when the Grid is losing its focus and there are unsaved pending changes.")
ISNet.Serialization.XmlSerializableAttribute()
public function get,set NotifyOnLostFocus : System.boolean
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether WebGrid should notify users when the Grid is losing its focus and there are unsaved pending changes.")]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property System.bool get_NotifyOnLostFocus();
public: __property void set_NotifyOnLostFocus(
   System.bool value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether WebGrid should notify users when the Grid is losing its focus and there are unsaved pending changes.")]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property System.bool NotifyOnLostFocus {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridBatchUpdateSettings Class
WebGridBatchUpdateSettings Members


PromptOnUndoAllChanges Property

[image]
Intersoft WebGrid Documentation
PromptOnUndoAllChanges Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridBatchUpdateSettings Class : PromptOnUndoAllChanges Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies whether WebGrid should prompt users when undo all changes operation is being invoked.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property PromptOnUndoAllChanges As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebGridBatchUpdateSettings
Dim value As System.Boolean

instance.PromptOnUndoAllChanges = value

value = instance.PromptOnUndoAllChanges
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether WebGrid should prompt users when undo all changes operation is being invoked.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.bool PromptOnUndoAllChanges {get; set;}
Delphi
public read-write property PromptOnUndoAllChanges: System.Boolean;
JScript
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Specifies whether WebGrid should prompt users when undo all changes operation is being invoked.")
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set PromptOnUndoAllChanges : System.boolean
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether WebGrid should prompt users when undo all changes operation is being invoked.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.bool get_PromptOnUndoAllChanges();
public: __property void set_PromptOnUndoAllChanges(
   System.bool value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether WebGrid should prompt users when undo all changes operation is being invoked.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.bool PromptOnUndoAllChanges {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridBatchUpdateSettings Class
WebGridBatchUpdateSettings Members


PromptUnsavedChanges Property

[image]
Intersoft WebGrid Documentation
PromptUnsavedChanges Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridBatchUpdateSettings Class : PromptUnsavedChanges Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies whether users should be prompted during page unload (due to navigation or window close) while there are unsaved changes in WebGrid.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Property PromptUnsavedChanges As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebGridBatchUpdateSettings
Dim value As System.Boolean

instance.PromptUnsavedChanges = value

value = instance.PromptUnsavedChanges
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether users should be prompted during page unload (due to navigation or window close) while there are unsaved changes in WebGrid.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public System.bool PromptUnsavedChanges {get; set;}
Delphi
public read-write property PromptUnsavedChanges: System.Boolean;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DescriptionAttribute("Specifies whether users should be prompted during page unload (due to navigation or window close) while there are unsaved changes in WebGrid.")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute()
public function get,set PromptUnsavedChanges : System.boolean
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether users should be prompted during page unload (due to navigation or window close) while there are unsaved changes in WebGrid.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property System.bool get_PromptUnsavedChanges();
public: __property void set_PromptUnsavedChanges(
   System.bool value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether users should be prompted during page unload (due to navigation or window close) while there are unsaved changes in WebGrid.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property System.bool PromptUnsavedChanges {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridBatchUpdateSettings Class
WebGridBatchUpdateSettings Members


WebGridCell Class

[image]
Intersoft WebGrid Documentation
WebGridCell Class
Members See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : WebGridCell Class

Glossary Item Box

Object Model

WebGridCell Class

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute()>
<System.SerializableAttribute()>
Public Class WebGridCell
   Inherits ISNet.WebUI.NamedObjectBase
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject
Visual Basic (Usage) Copy Code
Dim instance As WebGridCell
C#
[System.ComponentModel.DescriptionAttribute()]
[System.SerializableAttribute()]
public class WebGridCell : ISNet.WebUI.NamedObjectBase, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject
Delphi
public class WebGridCell = class(ISNet.WebUI.NamedObjectBase, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject)
JScript
System.ComponentModel.DescriptionAttribute()
System.SerializableAttribute()
public class WebGridCell extends ISNet.WebUI.NamedObjectBase implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute()]
[System.SerializableAttribute()]
public __gc class WebGridCell : public ISNet.WebUI.NamedObjectBase, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject
C++/CLI
[System.ComponentModel.DescriptionAttribute()]
[System.SerializableAttribute()]
public ref class WebGridCell : public ISNet.WebUI.NamedObjectBase, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.NamedObjectBase
ISNet.WebUI.WebGrid.WebGridCell

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridCell Members
ISNet.WebUI.WebGrid Namespace


WebGridCell Class Members

[image]
Intersoft WebGrid Documentation
WebGridCell Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebGrid Namespace : WebGridCell Class

Glossary Item Box

The following tables list the members exposed by WebGridCell.

Public Constructors

 | Name | Description
Public Constructor | WebGridCell Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | ButtonImage |
Public Property | ForceNoEdit |
Public Property | GroupRowInfoText |
Public Property | HtmlHeaders |
Public Property | Image |
Public Property | Style |
Public Property | Tag |
Public Property | Text |
Public Property | TooltipText |
Public Property | Value |
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | GetTemplateContainer |
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | RenderControl |
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString |
Top

See Also

Reference

WebGridCell Class
ISNet.WebUI.WebGrid Namespace


WebGridCell Constructor

[image]
Intersoft WebGrid Documentation
WebGridCell Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridCell Class : WebGridCell Constructor

Glossary Item Box

Overload List

Overload | Description
WebGridCell Constructor() |
WebGridCell Constructor(String) |
WebGridCell Constructor(String,Object) |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridCell Class
WebGridCell Members


WebGridCell Constructor()

[image]
Intersoft WebGrid Documentation
WebGridCell Constructor()
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridCell Class > WebGridCell Constructor : WebGridCell Constructor()

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebGridCell()
C#
public WebGridCell()
Delphi
public WebGridCell();
JScript
public function WebGridCell();
Managed Extensions for C++
public: WebGridCell();
C++/CLI
public:
WebGridCell();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridCell Class
WebGridCell Members
Overload List


WebGridCell Constructor(String)

[image]
Intersoft WebGrid Documentation
WebGridCell Constructor(String)
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridCell Class > WebGridCell Constructor : WebGridCell Constructor(String)

text

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal text As System.String _
)
Visual Basic (Usage) Copy Code
Dim text As System.String

Dim instance As New WebGridCell(text)
C#
public WebGridCell(
   System.string text
)
Delphi
public WebGridCell(
    text: System.String
);
JScript
public function WebGridCell(
   text : System.String
);
Managed Extensions for C++
public: WebGridCell(
   System.string* text
)
C++/CLI
public:
WebGridCell(
   System.String^ text
)

Parameters

text

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridCell Class
WebGridCell Members
Overload List


WebGridCell Constructor(String,Object)

[image]
Intersoft WebGrid Documentation
WebGridCell Constructor(String,Object)
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridCell Class > WebGridCell Constructor : WebGridCell Constructor(String,Object)

text
value

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal text As System.String, _
   ByVal value As System.Object _
)
Visual Basic (Usage) Copy Code
Dim text As System.String
Dim value As System.Object

Dim instance As New WebGridCell(text, value)
C#
public WebGridCell(
   System.string text,
   System.object value
)
Delphi
public WebGridCell(
    text: System.String;
    value: System.TObject
);
JScript
public function WebGridCell(
   text : System.String,
   value : System.Object
);
Managed Extensions for C++
public: WebGridCell(
   System.string* text,
   System.Object* value
)
C++/CLI
public:
WebGridCell(
   System.String^ text,
   System.Object^ value
)

Parameters

text
value

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridCell Class
WebGridCell Members
Overload List


Clone Method

[image]
Intersoft WebGrid Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridCell Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As System.Object
Visual Basic (Usage) Copy Code
Dim instance As WebGridCell
Dim value As System.Object

value = instance.Clone()
C#
public virtual System.object Clone()
Delphi
public function Clone(): System.TObject; virtual;
JScript
public function Clone() : System.Object;
Managed Extensions for C++
public: virtual System.Object* Clone();
C++/CLI
public:
virtual System.Object^ Clone();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridCell Class
WebGridCell Members


CopyFrom Method

[image]
Intersoft WebGrid Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridCell Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridCell Class
WebGridCell Members


CopyFrom(Object) Method

[image]
Intersoft WebGrid Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridCell Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebGridCell
Dim objSource As System.Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   System.object objSource
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridCell Class
WebGridCell Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebGrid Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridCell Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object, _
   ByVal cloneSourceValue As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebGridCell
Dim objSource As System.Object
Dim cloneSourceValue As System.Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   System.object objSource,
   System.bool cloneSourceValue
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject;
    cloneSourceValue: System.Boolean
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object,
   cloneSourceValue : System.boolean
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource,
   System.bool cloneSourceValue
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource,
   System.bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridCell Class
WebGridCell Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebGrid Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridCell Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebGridCell
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure DeSerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function DeSerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void DeSerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void DeSerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridCell Class
WebGridCell Members


GetHashCode Method

[image]
Intersoft WebGrid Documentation
GetHashCode Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridCell Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebGridCell
Dim value As System.Integer

value = instance.GetHashCode()
C#
public virtual System.int GetHashCode()
Delphi
public function GetHashCode(): System.Integer; virtual;
JScript
public function GetHashCode() : System.int;
Managed Extensions for C++
public: virtual System.int GetHashCode();
C++/CLI
public:
virtual System.int GetHashCode();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridCell Class
WebGridCell Members


WebGridCell Class Methods

[image]
Intersoft WebGrid Documentation
WebGridCell Class Methods
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : WebGridCell Class

Glossary Item Box

For a list of all members of this type, see WebGridCell members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | GetTemplateContainer |
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | RenderControl |
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString |
Top

See Also

Reference

WebGridCell Class
ISNet.WebUI.WebGrid Namespace


GetObjectData Method

[image]
Intersoft WebGrid Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridCell Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebGridCell
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure GetObjectData(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
); override;
JScript
public override function GetObjectData(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void GetObjectData(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
) override
C++/CLI
public:
void GetObjectData(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
) override

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridCell Class
WebGridCell Members


GetTemplateContainer Method

[image]
Intersoft WebGrid Documentation
GetTemplateContainer Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridCell Class : GetTemplateContainer Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetTemplateContainer() As WebGridCellTemplateContainer
Visual Basic (Usage) Copy Code
Dim instance As WebGridCell
Dim value As WebGridCellTemplateContainer

value = instance.GetTemplateContainer()
C#
public WebGridCellTemplateContainer GetTemplateContainer()
Delphi
public function GetTemplateContainer(): WebGridCellTemplateContainer;
JScript
public function GetTemplateContainer() : WebGridCellTemplateContainer;
Managed Extensions for C++
public: WebGridCellTemplateContainer* GetTemplateContainer();
C++/CLI
public:
WebGridCellTemplateContainer^ GetTemplateContainer();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridCell Class
WebGridCell Members


IsEmpty Method

[image]
Intersoft WebGrid Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridCell Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebGridCell
Dim value As System.Boolean

value = instance.IsEmpty()
C#
public virtual System.bool IsEmpty()
Delphi
public function IsEmpty(): System.Boolean; virtual;
JScript
public function IsEmpty() : System.boolean;
Managed Extensions for C++
public: virtual System.bool IsEmpty();
C++/CLI
public:
virtual System.bool IsEmpty();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridCell Class
WebGridCell Members


RenderControl Method

[image]
Intersoft WebGrid Documentation
RenderControl Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridCell Class : RenderControl Method

control

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub RenderControl( _
   ByVal control As System.Web.UI.WebControls.WebControl _
)
Visual Basic (Usage) Copy Code
Dim instance As WebGridCell
Dim control As System.Web.UI.WebControls.WebControl

instance.RenderControl(control)
C#
public void RenderControl(
   System.Web.UI.WebControls.WebControl control
)
Delphi
public procedure RenderControl(
    control: System.Web.UI.WebControls.WebControl
);
JScript
public function RenderControl(
   control : System.Web.UI.WebControls.WebControl
);
Managed Extensions for C++
public: void RenderControl(
   System.Web.UI.WebControls.WebControl* control
)
C++/CLI
public:
void RenderControl(
   System.Web.UI.WebControls.WebControl^ control
)

Parameters

control

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridCell Class
WebGridCell Members


Reset Method

[image]
Intersoft WebGrid Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridCell Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As WebGridCell

instance.Reset()
C#
public virtual void Reset()
Delphi
public procedure Reset(); virtual;
JScript
public function Reset();
Managed Extensions for C++
public: virtual void Reset();
C++/CLI
public:
virtual void Reset();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridCell Class
WebGridCell Members


SerializeObjectData Method

[image]
Intersoft WebGrid Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridCell Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebGridCell
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure SerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function SerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void SerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void SerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridCell Class
WebGridCell Members


ToString Method

[image]
Intersoft WebGrid Documentation
ToString Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridCell Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString() As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebGridCell
Dim value As System.String

value = instance.ToString()
C#
public override System.string ToString()
Delphi
public function ToString(): System.String; override;
JScript
public override function ToString() : System.String;
Managed Extensions for C++
public: System.string* ToString(); override
C++/CLI
public:
System.String^ ToString(); override

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridCell Class
WebGridCell Members


WebGridCell Class Properties

[image]
Intersoft WebGrid Documentation
WebGridCell Class Properties
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : WebGridCell Class

Glossary Item Box

For a list of all members of this type, see WebGridCell members.

Public Properties

 | Name | Description
Public Property | ButtonImage |
Public Property | ForceNoEdit |
Public Property | GroupRowInfoText |
Public Property | HtmlHeaders |
Public Property | Image |
Public Property | Style |
Public Property | Tag |
Public Property | Text |
Public Property | TooltipText |
Public Property | Value |
Top

See Also

Reference

WebGridCell Class
ISNet.WebUI.WebGrid Namespace


ButtonImage Property

[image]
Intersoft WebGrid Documentation
ButtonImage Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridCell Class : ButtonImage Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Gets or sets the image of the button when the ColumnType of the WebGridColumn is set to ButtonImage.")>
Public Property ButtonImage As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebGridCell
Dim value As System.String

instance.ButtonImage = value

value = instance.ButtonImage
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the image of the button when the ColumnType of the WebGridColumn is set to ButtonImage.")]
public System.string ButtonImage {get; set;}
Delphi
public read-write property ButtonImage: System.String;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the image of the button when the ColumnType of the WebGridColumn is set to ButtonImage.")
public function get,set ButtonImage : System.String
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the image of the button when the ColumnType of the WebGridColumn is set to ButtonImage.")]
public: __property System.string* get_ButtonImage();
public: __property void set_ButtonImage(
   System.string* value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the image of the button when the ColumnType of the WebGridColumn is set to ButtonImage.")]
public:
property System.String^ ButtonImage {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridCell Class
WebGridCell Members


ForceNoEdit Property

[image]
Intersoft WebGrid Documentation
ForceNoEdit Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridCell Class : ForceNoEdit Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Determines whether this cell will be forced to not allow editing.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
Public Property ForceNoEdit As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebGridCell
Dim value As System.Boolean

instance.ForceNoEdit = value

value = instance.ForceNoEdit
C#
[System.ComponentModel.DescriptionAttribute("Determines whether this cell will be forced to not allow editing.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public System.bool ForceNoEdit {get; set;}
Delphi
public read-write property ForceNoEdit: System.Boolean;
JScript
System.ComponentModel.DescriptionAttribute("Determines whether this cell will be forced to not allow editing.")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
public function get,set ForceNoEdit : System.boolean
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Determines whether this cell will be forced to not allow editing.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.bool get_ForceNoEdit();
public: __property void set_ForceNoEdit(
   System.bool value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Determines whether this cell will be forced to not allow editing.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.bool ForceNoEdit {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridCell Class
WebGridCell Members


GroupRowInfoText Property

[image]
Intersoft WebGrid Documentation
GroupRowInfoText Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridCell Class : GroupRowInfoText Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Gets or sets the group row info text for this cell. When a value is set, it will override the GroupRowInfoFormat property in higher object's hierarchy.")>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Property GroupRowInfoText As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebGridCell
Dim value As System.String

instance.GroupRowInfoText = value

value = instance.GroupRowInfoText
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the group row info text for this cell. When a value is set, it will override the GroupRowInfoFormat property in higher object's hierarchy.")]
[ISNet.Serialization.XmlSerializableAttribute()]
public System.string GroupRowInfoText {get; set;}
Delphi
public read-write property GroupRowInfoText: System.String;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the group row info text for this cell. When a value is set, it will override the GroupRowInfoFormat property in higher object's hierarchy.")
ISNet.Serialization.XmlSerializableAttribute()
public function get,set GroupRowInfoText : System.String
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the group row info text for this cell. When a value is set, it will override the GroupRowInfoFormat property in higher object's hierarchy.")]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property System.string* get_GroupRowInfoText();
public: __property void set_GroupRowInfoText(
   System.string* value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the group row info text for this cell. When a value is set, it will override the GroupRowInfoFormat property in higher object's hierarchy.")]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property System.String^ GroupRowInfoText {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridCell Class
WebGridCell Members


HtmlHeaders Property

[image]
Intersoft WebGrid Documentation
HtmlHeaders Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridCell Class : HtmlHeaders Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Gets or sets the html headers attribute for this cell.")>
Public Property HtmlHeaders As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebGridCell
Dim value As System.String

instance.HtmlHeaders = value

value = instance.HtmlHeaders
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the html headers attribute for this cell.")]
public System.string HtmlHeaders {get; set;}
Delphi
public read-write property HtmlHeaders: System.String;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the html headers attribute for this cell.")
public function get,set HtmlHeaders : System.String
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the html headers attribute for this cell.")]
public: __property System.string* get_HtmlHeaders();
public: __property void set_HtmlHeaders(
   System.string* value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the html headers attribute for this cell.")]
public:
property System.String^ HtmlHeaders {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridCell Class
WebGridCell Members


Image Property

[image]
Intersoft WebGrid Documentation
Image Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridCell Class : Image Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Gets or sets the image filename that will be used to display image of an Image or ImageAndText Column.")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property Image As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebGridCell
Dim value As System.String

instance.Image = value

value = instance.Image
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the image filename that will be used to display image of an Image or ImageAndText Column.")]
[System.ComponentModel.DefaultValueAttribute()]
public System.string Image {get; set;}
Delphi
public read-write property Image: System.String;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the image filename that will be used to display image of an Image or ImageAndText Column.")
System.ComponentModel.DefaultValueAttribute()
public function get,set Image : System.String
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the image filename that will be used to display image of an Image or ImageAndText Column.")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.string* get_Image();
public: __property void set_Image(
   System.string* value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the image filename that will be used to display image of an Image or ImageAndText Column.")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.String^ Image {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridCell Class
WebGridCell Members


Style Property

[image]
Intersoft WebGrid Documentation
Style Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridCell Class : Style Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<System.ComponentModel.DescriptionAttribute("Gets or sets the style applied to the cell object.")>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
Public Property Style As WebGridFormatStyle
Visual Basic (Usage) Copy Code
Dim instance As WebGridCell
Dim value As WebGridFormatStyle

instance.Style = value

value = instance.Style
C#
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the style applied to the cell object.")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public WebGridFormatStyle Style {get; set;}
Delphi
public read-write property Style: WebGridFormatStyle;
JScript
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
System.ComponentModel.DescriptionAttribute("Gets or sets the style applied to the cell object.")
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
public function get,set Style : WebGridFormatStyle
Managed Extensions for C++
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the style applied to the cell object.")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public: __property WebGridFormatStyle* get_Style();
public: __property void set_Style(
   WebGridFormatStyle* value
);
C++/CLI
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the style applied to the cell object.")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public:
property WebGridFormatStyle^ Style {
   WebGridFormatStyle^ get();
   void set (    WebGridFormatStyle^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridCell Class
WebGridCell Members


Tag Property

[image]
Intersoft WebGrid Documentation
Tag Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridCell Class : Tag Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Gets or sets custom data for the cell object.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
Public Property Tag As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebGridCell
Dim value As System.String

instance.Tag = value

value = instance.Tag
C#
[System.ComponentModel.DescriptionAttribute("Gets or sets custom data for the cell object.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public System.string Tag {get; set;}
Delphi
public read-write property Tag: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Gets or sets custom data for the cell object.")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
public function get,set Tag : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Gets or sets custom data for the cell object.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.string* get_Tag();
public: __property void set_Tag(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Gets or sets custom data for the cell object.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.String^ Tag {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridCell Class
WebGridCell Members


Text Property

[image]
Intersoft WebGrid Documentation
Text Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridCell Class : Text Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Gets or sets the text that will be displayed in cell.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property Text As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebGridCell
Dim value As System.String

instance.Text = value

value = instance.Text
C#
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the text that will be displayed in cell.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.string Text {get; set;}
Delphi
public read-write property Text: System.String;
JScript
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the text that will be displayed in cell.")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set Text : System.String
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the text that will be displayed in cell.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.string* get_Text();
public: __property void set_Text(
   System.string* value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the text that will be displayed in cell.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.String^ Text {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridCell Class
WebGridCell Members


TooltipText Property

[image]
Intersoft WebGrid Documentation
TooltipText Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridCell Class : TooltipText Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Gets or sets the tooltip text of cell object.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property TooltipText As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebGridCell
Dim value As System.String

instance.TooltipText = value

value = instance.TooltipText
C#
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the tooltip text of cell object.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.string TooltipText {get; set;}
Delphi
public read-write property TooltipText: System.String;
JScript
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the tooltip text of cell object.")
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set TooltipText : System.String
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the tooltip text of cell object.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.string* get_TooltipText();
public: __property void set_TooltipText(
   System.string* value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the tooltip text of cell object.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.String^ TooltipText {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridCell Class
WebGridCell Members


Value Property

[image]
Intersoft WebGrid Documentation
Value Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridCell Class : Value Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Gets or sets the cell's value.")>
Public Property Value As System.Object
Visual Basic (Usage) Copy Code
Dim instance As WebGridCell
Dim value As System.Object

instance.Value = value

value = instance.Value
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the cell's value.")]
public System.object Value {get; set;}
Delphi
public read-write property Value: System.TObject;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the cell's value.")
public function get,set Value : System.Object
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the cell's value.")]
public: __property System.Object* get_Value();
public: __property void set_Value(
   System.Object* value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the cell's value.")]
public:
property System.Object^ Value {
   System.Object^ get();
   void set (    System.Object^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridCell Class
WebGridCell Members


WebGridCellCollection Class

[image]
Intersoft WebGrid Documentation
WebGridCellCollection Class
Members See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : WebGridCellCollection Class

Glossary Item Box

Object Model

WebGridCellCollection Class

Syntax

Visual Basic (Declaration)
<System.Reflection.DefaultMemberAttribute("Item")>
<System.SerializableAttribute()>
Public Class WebGridCellCollection
   Inherits ISNet.WebUI.ISCollectionBase
Visual Basic (Usage) Copy Code
Dim instance As WebGridCellCollection
C#
[System.Reflection.DefaultMemberAttribute("Item")]
[System.SerializableAttribute()]
public class WebGridCellCollection : ISNet.WebUI.ISCollectionBase
Delphi
public class WebGridCellCollection = class(ISNet.WebUI.ISCollectionBase)
JScript
System.Reflection.DefaultMemberAttribute("Item")
System.SerializableAttribute()
public class WebGridCellCollection extends ISNet.WebUI.ISCollectionBase
Managed Extensions for C++
[System.Reflection.DefaultMemberAttribute("Item")]
[System.SerializableAttribute()]
public __gc class WebGridCellCollection : public ISNet.WebUI.ISCollectionBase
C++/CLI
[System.Reflection.DefaultMemberAttribute("Item")]
[System.SerializableAttribute()]
public ref class WebGridCellCollection : public ISNet.WebUI.ISCollectionBase

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
ISNet.WebUI.ISCollectionBase
ISNet.WebUI.WebGrid.WebGridCellCollection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridCellCollection Members
ISNet.WebUI.WebGrid Namespace


WebGridCellCollection Class Members

[image]
Intersoft WebGrid Documentation
WebGridCellCollection Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebGrid Namespace : WebGridCellCollection Class

Glossary Item Box

The following tables list the members exposed by WebGridCellCollection.

Public Constructors

 | Name | Description
Public Constructor | WebGridCellCollection Constructor |
Top

Public Properties

 | Name | Description
Public Property | Capacity | (Inherited from System.Collections.CollectionBase)
Public Property | Count | (Inherited from System.Collections.CollectionBase)
Public Property | IsReadOnly | Overridden.
Public Property | Item |
Public Property | Parent | (Inherited from ISNet.WebUI.ISCollectionBase)
Top

Public Methods

 | Name | Description
Public Method | Add | Overloaded.
Public Method | AddRange |
Public Method | Clear |
Public Method | Contains | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | CopyFrom |
Public Method | CopyTo | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | Exists | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | GetEnumerator |
Public Method | GetItem | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | GetNamedItem |
Public Method | IndexOf | Overloaded. (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | Insert |
Public Method | IntInsert | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | Remove |
Public Method | SetItemData | Overloaded.
Public Method | setParent | (Inherited from ISNet.WebUI.ISCollectionBase)
Top

See Also

Reference

WebGridCellCollection Class
ISNet.WebUI.WebGrid Namespace


WebGridCellCollection Constructor

[image]
Intersoft WebGrid Documentation
WebGridCellCollection Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridCellCollection Class : WebGridCellCollection Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebGridCellCollection()
C#
public WebGridCellCollection()
Delphi
public WebGridCellCollection();
JScript
public function WebGridCellCollection();
Managed Extensions for C++
public: WebGridCellCollection();
C++/CLI
public:
WebGridCellCollection();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridCellCollection Class
WebGridCellCollection Members


WebGridCellCollection Class Methods

[image]
Intersoft WebGrid Documentation
WebGridCellCollection Class Methods
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : WebGridCellCollection Class

Glossary Item Box

For a list of all members of this type, see WebGridCellCollection members.

Public Methods

 | Name | Description
Public Method | Add | Overloaded.
Public Method | AddRange |
Public Method | Clear |
Public Method | Contains | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | CopyFrom |
Public Method | CopyTo | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | Exists | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | GetEnumerator |
Public Method | GetItem | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | GetNamedItem |
Public Method | IndexOf | Overloaded. (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | Insert |
Public Method | IntInsert | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | Remove |
Public Method | SetItemData | Overloaded.
Public Method | setParent | (Inherited from ISNet.WebUI.ISCollectionBase)
Top

See Also

Reference

WebGridCellCollection Class
ISNet.WebUI.WebGrid Namespace


Add Method

[image]
Intersoft WebGrid Documentation
Add Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridCellCollection Class : Add Method

Glossary Item Box

Overload List

Overload | Description
Add(WebGridCell) |
Add(String) |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridCellCollection Class
WebGridCellCollection Members


Add(WebGridCell) Method

[image]
Intersoft WebGrid Documentation
Add(WebGridCell) Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridCellCollection Class > Add Method : Add(WebGridCell) Method

webGridCell

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function Add( _
   ByVal webGridCell As WebGridCell _
) As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebGridCellCollection
Dim webGridCell As WebGridCell
Dim value As System.Integer

value = instance.Add(webGridCell)
C#
public virtual System.int Add(
   WebGridCell webGridCell
)
Delphi
public function Add(
    webGridCell: WebGridCell
): System.Integer; virtual;
JScript
public function Add(
   webGridCell : WebGridCell
) : System.int;
Managed Extensions for C++
public: virtual System.int Add(
   WebGridCell* webGridCell
)
C++/CLI
public:
virtual System.int Add(
   WebGridCell^ webGridCell
)

Parameters

webGridCell

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridCellCollection Class
WebGridCellCollection Members
Overload List


Add(String) Method

[image]
Intersoft WebGrid Documentation
Add(String) Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridCellCollection Class > Add Method : Add(String) Method

name

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function Add( _
   ByVal name As System.String _
) As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebGridCellCollection
Dim name As System.String
Dim value As System.Integer

value = instance.Add(name)
C#
public System.int Add(
   System.string name
)
Delphi
public function Add(
    name: System.String
): System.Integer;
JScript
public function Add(
   name : System.String
) : System.int;
Managed Extensions for C++
public: System.int Add(
   System.string* name
)
C++/CLI
public:
System.int Add(
   System.String^ name
)

Parameters

name

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridCellCollection Class
WebGridCellCollection Members
Overload List


AddRange Method

[image]
Intersoft WebGrid Documentation
AddRange Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridCellCollection Class : AddRange Method

cells

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub AddRange( _
   ByVal cells() As WebGridCell _
)
Visual Basic (Usage) Copy Code
Dim instance As WebGridCellCollection
Dim cells() As WebGridCell

instance.AddRange(cells)
C#
public virtual void AddRange(
   WebGridCell[] cells
)
Delphi
public procedure AddRange(
    cells: WebGridCellarray of
); virtual;
JScript
public function AddRange(
   cells : WebGridCell[]
);
Managed Extensions for C++
public: virtual void AddRange(
   WebGridCell*[]* cells
)
C++/CLI
public:
virtual void AddRange(
   array<WebGridCell^>^ cells
)

Parameters

cells

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridCellCollection Class
WebGridCellCollection Members


Clear Method

[image]
Intersoft WebGrid Documentation
Clear Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridCellCollection Class : Clear Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Shadows Sub Clear()
Visual Basic (Usage) Copy Code
Dim instance As WebGridCellCollection

instance.Clear()
C#
public new void Clear()
Delphi
public procedure Clear();
JScript
public hide function Clear();
Managed Extensions for C++
public: new void Clear();
C++/CLI
public:
new void Clear();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridCellCollection Class
WebGridCellCollection Members


Contains Method

[image]
Intersoft WebGrid Documentation
Contains Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridCellCollection Class : Contains Method

value

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function Contains( _
   ByVal value As ISNet.WebUI.INamedObject _
) As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebGridCellCollection
Dim value As ISNet.WebUI.INamedObject
Dim value As System.Boolean

value = instance.Contains(value)
C#
public System.bool Contains(
   ISNet.WebUI.INamedObject value
)
Delphi
public function Contains(
    value: ISNet.WebUI.INamedObject
): System.Boolean;
JScript
public function Contains(
   value : ISNet.WebUI.INamedObject
) : System.boolean;
Managed Extensions for C++
public: System.bool Contains(
   ISNet.WebUI.INamedObject* value
)
C++/CLI
public:
System.bool Contains(
   ISNet.WebUI.INamedObject^ value
)

Parameters

value

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridCellCollection Class
WebGridCellCollection Members


CopyFrom Method

[image]
Intersoft WebGrid Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridCellCollection Class : CopyFrom Method

passIn

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function CopyFrom( _
   ByVal passIn As WebGridCellCollection _
) As WebGridCellCollection
Visual Basic (Usage) Copy Code
Dim instance As WebGridCellCollection
Dim passIn As WebGridCellCollection
Dim value As WebGridCellCollection

value = instance.CopyFrom(passIn)
C#
public WebGridCellCollection CopyFrom(
   WebGridCellCollection passIn
)
Delphi
public function CopyFrom(
    passIn: WebGridCellCollection
): WebGridCellCollection;
JScript
public function CopyFrom(
   passIn : WebGridCellCollection
) : WebGridCellCollection;
Managed Extensions for C++
public: WebGridCellCollection* CopyFrom(
   WebGridCellCollection* passIn
)
C++/CLI
public:
WebGridCellCollection^ CopyFrom(
   WebGridCellCollection^ passIn
)

Parameters

passIn

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridCellCollection Class
WebGridCellCollection Members


CopyTo Method

[image]
Intersoft WebGrid Documentation
CopyTo Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridCellCollection Class : CopyTo Method

array
index

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub CopyTo( _
   ByVal array() As ISNet.WebUI.INamedObject, _
   ByVal index As System.Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As WebGridCellCollection
Dim array() As ISNet.WebUI.INamedObject
Dim index As System.Integer

instance.CopyTo(array, index)
C#
public void CopyTo(
   ISNet.WebUI.INamedObject[] array,
   System.int index
)
Delphi
public procedure CopyTo(
    array: ISNet.WebUI.INamedObjectarray of;
    index: System.Integer
);
JScript
public function CopyTo(
   array : ISNet.WebUI.INamedObject[],
   index : System.int
);
Managed Extensions for C++
public: void CopyTo(
   ISNet.WebUI.INamedObject*[]* array,
   System.int index
)
C++/CLI
public:
void CopyTo(
   ISNet.WebUI.array<INamedObject^>^ array,
   System.int index
)

Parameters

array
index

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridCellCollection Class
WebGridCellCollection Members


Exists Method

[image]
Intersoft WebGrid Documentation
Exists Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridCellCollection Class : Exists Method

name

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function Exists( _
   ByVal name As System.String _
) As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebGridCellCollection
Dim name As System.String
Dim value As System.Boolean

value = instance.Exists(name)
C#
public System.bool Exists(
   System.string name
)
Delphi
public function Exists(
    name: System.String
): System.Boolean;
JScript
public function Exists(
   name : System.String
) : System.boolean;
Managed Extensions for C++
public: System.bool Exists(
   System.string* name
)
C++/CLI
public:
System.bool Exists(
   System.String^ name
)

Parameters

name

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridCellCollection Class
WebGridCellCollection Members


GetEnumerator Method

[image]
Intersoft WebGrid Documentation
GetEnumerator Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridCellCollection Class : GetEnumerator Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Shadows Function GetEnumerator() As System.Collections.IEnumerator
Visual Basic (Usage) Copy Code
Dim instance As WebGridCellCollection
Dim value As System.Collections.IEnumerator

value = instance.GetEnumerator()
C#
public new System.Collections.IEnumerator GetEnumerator()
Delphi
public function GetEnumerator(): System.Collections.IEnumerator;
JScript
public hide function GetEnumerator() : System.Collections.IEnumerator;
Managed Extensions for C++
public: new System.Collections.IEnumerator* GetEnumerator();
C++/CLI
public:
new System.Collections.IEnumerator^ GetEnumerator();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridCellCollection Class
WebGridCellCollection Members


GetItem Method

[image]
Intersoft WebGrid Documentation
GetItem Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridCellCollection Class : GetItem Method

Glossary Item Box

Overload List

Overload | Description
GetItem | (Inherited from ISNet.WebUI.ISCollectionBase)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridCellCollection Class
WebGridCellCollection Members


GetItem(Int32) Method

[image]
Intersoft WebGrid Documentation
GetItem(Int32) Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridCellCollection Class : GetItem(Int32) Method

index

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetItem( _
   ByVal index As System.Integer _
) As ISNet.WebUI.INamedObject
Visual Basic (Usage) Copy Code
Dim instance As WebGridCellCollection
Dim index As System.Integer
Dim value As ISNet.WebUI.INamedObject

value = instance.GetItem(index)
C#
public virtual ISNet.WebUI.INamedObject GetItem(
   System.int index
)
Delphi
public function GetItem(
    index: System.Integer
): ISNet.WebUI.INamedObject; virtual;
JScript
public function GetItem(
   index : System.int
) : ISNet.WebUI.INamedObject;
Managed Extensions for C++
public: virtual ISNet.WebUI.INamedObject* GetItem(
   System.int index
)
C++/CLI
public:
virtual ISNet.WebUI.INamedObject^ GetItem(
   System.int index
)

Parameters

index

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridCellCollection Class
WebGridCellCollection Members


GetNamedItem Method

[image]
Intersoft WebGrid Documentation
GetNamedItem Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridCellCollection Class : GetNamedItem Method

name

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetNamedItem( _
   ByVal name As System.String _
) As WebGridCell
Visual Basic (Usage) Copy Code
Dim instance As WebGridCellCollection
Dim name As System.String
Dim value As WebGridCell

value = instance.GetNamedItem(name)
C#
public WebGridCell GetNamedItem(
   System.string name
)
Delphi
public function GetNamedItem(
    name: System.String
): WebGridCell;
JScript
public function GetNamedItem(
   name : System.String
) : WebGridCell;
Managed Extensions for C++
public: WebGridCell* GetNamedItem(
   System.string* name
)
C++/CLI
public:
WebGridCell^ GetNamedItem(
   System.String^ name
)

Parameters

name

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridCellCollection Class
WebGridCellCollection Members


IndexOf Method

[image]
Intersoft WebGrid Documentation
IndexOf Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridCellCollection Class : IndexOf Method

Glossary Item Box

Overload List

Overload | Description
IndexOf(String) | (Inherited from ISNet.WebUI.ISCollectionBase)
IndexOf(INamedObject) | (Inherited from ISNet.WebUI.ISCollectionBase)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridCellCollection Class
WebGridCellCollection Members


IndexOf(String) Method

[image]
Intersoft WebGrid Documentation
IndexOf(String) Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridCellCollection Class > IndexOf Method : IndexOf(String) Method

name

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function IndexOf( _
   ByVal name As System.String _
) As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebGridCellCollection
Dim name As System.String
Dim value As System.Integer

value = instance.IndexOf(name)
C#
public virtual System.int IndexOf(
   System.string name
)
Delphi
public function IndexOf(
    name: System.String
): System.Integer; virtual;
JScript
public function IndexOf(
   name : System.String
) : System.int;
Managed Extensions for C++
public: virtual System.int IndexOf(
   System.string* name
)
C++/CLI
public:
virtual System.int IndexOf(
   System.String^ name
)

Parameters

name

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridCellCollection Class
WebGridCellCollection Members
Overload List


IndexOf(INamedObject) Method

[image]
Intersoft WebGrid Documentation
IndexOf(INamedObject) Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridCellCollection Class > IndexOf Method : IndexOf(INamedObject) Method

value

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function IndexOf( _
   ByVal value As ISNet.WebUI.INamedObject _
) As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebGridCellCollection
Dim value As ISNet.WebUI.INamedObject
Dim value As System.Integer

value = instance.IndexOf(value)
C#
public System.int IndexOf(
   ISNet.WebUI.INamedObject value
)
Delphi
public function IndexOf(
    value: ISNet.WebUI.INamedObject
): System.Integer;
JScript
public function IndexOf(
   value : ISNet.WebUI.INamedObject
) : System.int;
Managed Extensions for C++
public: System.int IndexOf(
   ISNet.WebUI.INamedObject* value
)
C++/CLI
public:
System.int IndexOf(
   ISNet.WebUI.INamedObject^ value
)

Parameters

value

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridCellCollection Class
WebGridCellCollection Members
Overload List


Insert Method

[image]
Intersoft WebGrid Documentation
Insert Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridCellCollection Class : Insert Method

index
webGridCell

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub Insert( _
   ByVal index As System.Integer, _
   ByVal webGridCell As WebGridCell _
)
Visual Basic (Usage) Copy Code
Dim instance As WebGridCellCollection
Dim index As System.Integer
Dim webGridCell As WebGridCell

instance.Insert(index, webGridCell)
C#
public void Insert(
   System.int index,
   WebGridCell webGridCell
)
Delphi
public procedure Insert(
    index: System.Integer;
    webGridCell: WebGridCell
);
JScript
public function Insert(
   index : System.int,
   webGridCell : WebGridCell
);
Managed Extensions for C++
public: void Insert(
   System.int index,
   WebGridCell* webGridCell
)
C++/CLI
public:
void Insert(
   System.int index,
   WebGridCell^ webGridCell
)

Parameters

index
webGridCell

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridCellCollection Class
WebGridCellCollection Members


IntInsert Method

[image]
Intersoft WebGrid Documentation
IntInsert Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridCellCollection Class : IntInsert Method

index
value

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub IntInsert( _
   ByVal index As System.Integer, _
   ByVal value As ISNet.WebUI.INamedObject _
)
Visual Basic (Usage) Copy Code
Dim instance As WebGridCellCollection
Dim index As System.Integer
Dim value As ISNet.WebUI.INamedObject

instance.IntInsert(index, value)
C#
public void IntInsert(
   System.int index,
   ISNet.WebUI.INamedObject value
)
Delphi
public procedure IntInsert(
    index: System.Integer;
    value: ISNet.WebUI.INamedObject
);
JScript
public function IntInsert(
   index : System.int,
   value : ISNet.WebUI.INamedObject
);
Managed Extensions for C++
public: void IntInsert(
   System.int index,
   ISNet.WebUI.INamedObject* value
)
C++/CLI
public:
void IntInsert(
   System.int index,
   ISNet.WebUI.INamedObject^ value
)

Parameters

index
value

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridCellCollection Class
WebGridCellCollection Members


Remove Method

[image]
Intersoft WebGrid Documentation
Remove Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridCellCollection Class : Remove Method

webGridCell

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub Remove( _
   ByVal webGridCell As WebGridCell _
)
Visual Basic (Usage) Copy Code
Dim instance As WebGridCellCollection
Dim webGridCell As WebGridCell

instance.Remove(webGridCell)
C#
public void Remove(
   WebGridCell webGridCell
)
Delphi
public procedure Remove(
    webGridCell: WebGridCell
);
JScript
public function Remove(
   webGridCell : WebGridCell
);
Managed Extensions for C++
public: void Remove(
   WebGridCell* webGridCell
)
C++/CLI
public:
void Remove(
   WebGridCell^ webGridCell
)

Parameters

webGridCell

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridCellCollection Class
WebGridCellCollection Members


SetItemData Method

[image]
Intersoft WebGrid Documentation
SetItemData Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridCellCollection Class : SetItemData Method

Glossary Item Box

Overload List

Overload | Description
SetItemData(String[]) |
SetItemData(Object[]) |
SetItemData(String[],Object[]) |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridCellCollection Class
WebGridCellCollection Members


SetItemData(String[]) Method

[image]
Intersoft WebGrid Documentation
SetItemData(String[]) Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridCellCollection Class > SetItemData Method : SetItemData(String[]) Method

cellText

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Sub SetItemData( _
   ByVal cellText() As System.String _
)
Visual Basic (Usage) Copy Code
Dim instance As WebGridCellCollection
Dim cellText() As System.String

instance.SetItemData(cellText)
C#
public void SetItemData(
   System.string[] cellText
)
Delphi
public procedure SetItemData(
    cellText: System.Stringarray of
);
JScript
public function SetItemData(
   cellText : System.String[]
);
Managed Extensions for C++
public: void SetItemData(
   System.string*[]* cellText
)
C++/CLI
public:
void SetItemData(
   System.array<String^>^ cellText
)

Parameters

cellText

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridCellCollection Class
WebGridCellCollection Members
Overload List


SetItemData(Object[]) Method

[image]
Intersoft WebGrid Documentation
SetItemData(Object[]) Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridCellCollection Class > SetItemData Method : SetItemData(Object[]) Method

cellValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Sub SetItemData( _
   ByVal cellValue() As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebGridCellCollection
Dim cellValue() As System.Object

instance.SetItemData(cellValue)
C#
public void SetItemData(
   System.object[] cellValue
)
Delphi
public procedure SetItemData(
    cellValue: System.TObjectarray of
);
JScript
public function SetItemData(
   cellValue : System.Object[]
);
Managed Extensions for C++
public: void SetItemData(
   System.Object*[]* cellValue
)
C++/CLI
public:
void SetItemData(
   System.array<Object^>^ cellValue
)

Parameters

cellValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridCellCollection Class
WebGridCellCollection Members
Overload List


SetItemData(String[],Object[]) Method

[image]
Intersoft WebGrid Documentation
SetItemData(String[],Object[]) Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridCellCollection Class > SetItemData Method : SetItemData(String[],Object[]) Method

cellText
cellValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Sub SetItemData( _
   ByVal cellText() As System.String, _
   ByVal cellValue() As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebGridCellCollection
Dim cellText() As System.String
Dim cellValue() As System.Object

instance.SetItemData(cellText, cellValue)
C#
public void SetItemData(
   System.string[] cellText,
   System.object[] cellValue
)
Delphi
public procedure SetItemData(
    cellText: System.Stringarray of;
    cellValue: System.TObjectarray of
);
JScript
public function SetItemData(
   cellText : System.String[],
   cellValue : System.Object[]
);
Managed Extensions for C++
public: void SetItemData(
   System.string*[]* cellText,
   System.Object*[]* cellValue
)
C++/CLI
public:
void SetItemData(
   System.array<String^>^ cellText,
   System.array<Object^>^ cellValue
)

Parameters

cellText
cellValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridCellCollection Class
WebGridCellCollection Members
Overload List


setParent Method

[image]
Intersoft WebGrid Documentation
setParent Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridCellCollection Class : setParent Method

parent

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub setParent( _
   ByVal parent As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebGridCellCollection
Dim parent As System.Object

instance.setParent(parent)
C#
public virtual void setParent(
   System.object parent
)
Delphi
public procedure setParent(
    parent: System.TObject
); virtual;
JScript
public function setParent(
   parent : System.Object
);
Managed Extensions for C++
public: virtual void setParent(
   System.Object* parent
)
C++/CLI
public:
virtual void setParent(
   System.Object^ parent
)

Parameters

parent

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridCellCollection Class
WebGridCellCollection Members


Capacity Property

[image]
Intersoft WebGrid Documentation
Capacity Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridCellCollection Class : Capacity Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Runtime.InteropServices.ComVisibleAttribute(False)>
Public Property Capacity As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebGridCellCollection
Dim value As System.Integer

instance.Capacity = value

value = instance.Capacity
C#
[System.Runtime.InteropServices.ComVisibleAttribute(false)]
public System.int Capacity {get; set;}
Delphi
public read-write property Capacity: System.Integer;
JScript
System.Runtime.InteropServices.ComVisibleAttribute()
public function get,set Capacity : System.int
Managed Extensions for C++
[System.Runtime.InteropServices.ComVisibleAttribute(false)]
public: __property System.int get_Capacity();
public: __property void set_Capacity(
   System.int value
);
C++/CLI
[System.Runtime.InteropServices.ComVisibleAttribute(false)]
public:
property System.int Capacity {
   System.int get();
   void set (    System.int value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridCellCollection Class
WebGridCellCollection Members


Count Property

[image]
Intersoft WebGrid Documentation
Count Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridCellCollection Class : Count Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Count As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebGridCellCollection
Dim value As System.Integer

value = instance.Count
C#
public System.int Count {get;}
Delphi
public read-only property Count: System.Integer;
JScript
public function get Count : System.int
Managed Extensions for C++
public: __property System.int get_Count();
C++/CLI
public:
property System.int Count {
   System.int get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridCellCollection Class
WebGridCellCollection Members


WebGridCellCollection Class Properties

[image]
Intersoft WebGrid Documentation
WebGridCellCollection Class Properties
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : WebGridCellCollection Class

Glossary Item Box

For a list of all members of this type, see WebGridCellCollection members.

Public Properties

 | Name | Description
Public Property | Capacity | (Inherited from System.Collections.CollectionBase)
Public Property | Count | (Inherited from System.Collections.CollectionBase)
Public Property | IsReadOnly | Overridden.
Public Property | Item |
Public Property | Parent | (Inherited from ISNet.WebUI.ISCollectionBase)
Top

See Also

Reference

WebGridCellCollection Class
ISNet.WebUI.WebGrid Namespace


WebGridCellCollection Constructor

[image]
Intersoft WebGrid Documentation
WebGridCellCollection Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridCellCollection Class : WebGridCellCollection Constructor

Glossary Item Box

Overload List

Overload | Description
WebGridCellCollection Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridCellCollection Class
WebGridCellCollection Members


IsReadOnly Property

[image]
Intersoft WebGrid Documentation
IsReadOnly Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridCellCollection Class : IsReadOnly Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property IsReadOnly As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebGridCellCollection
Dim value As System.Boolean

value = instance.IsReadOnly
C#
public override System.bool IsReadOnly {get;}
Delphi
public read-only property IsReadOnly: System.Boolean; override;
JScript
public override function get IsReadOnly : System.boolean
Managed Extensions for C++
public: __property System.bool get_IsReadOnly() override;
C++/CLI
public:
property System.bool IsReadOnly {
   System.bool get() override;
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridCellCollection Class
WebGridCellCollection Members


Item Property

[image]
Intersoft WebGrid Documentation
Item Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridCellCollection Class : Item Property

index

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Default Property Item( _
   ByVal index As System.Integer _
) As WebGridCell
Visual Basic (Usage) Copy Code
Dim instance As WebGridCellCollection
Dim index As System.Integer
Dim value As WebGridCell

value = instance.Item(index)
C#
public WebGridCell this[
   System.int index
]; {get;}
Delphi
public  this: : WebGridCell;[
    index: System.Integer
]; read-only
JScript
public  this[
   index : System.int
] get : WebGridCell
Managed Extensions for C++
public: __property WebGridCell* get_Item   System.int index
;
C++/CLI
public:
property WebGridCell^ default [int] {
   WebGridCell^ get(System.int index);
}

Parameters

index

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridCellCollection Class
WebGridCellCollection Members


Parent Property

[image]
Intersoft WebGrid Documentation
Parent Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridCellCollection Class : Parent Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Parent As System.Object
Visual Basic (Usage) Copy Code
Dim instance As WebGridCellCollection
Dim value As System.Object

value = instance.Parent
C#
public System.object Parent {get;}
Delphi
public read-only property Parent: System.TObject;
JScript
public function get Parent : System.Object
Managed Extensions for C++
public: __property System.Object* get_Parent();
C++/CLI
public:
property System.Object^ Parent {
   System.Object^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridCellCollection Class
WebGridCellCollection Members


WebGridCellData Class

[image]
Intersoft WebGrid Documentation
WebGridCellData Class
Members See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : WebGridCellData Class

Glossary Item Box

Object Model

WebGridCellData Class

Syntax

Visual Basic (Declaration)
Public Class WebGridCellData
Visual Basic (Usage) Copy Code
Dim instance As WebGridCellData
C#
public class WebGridCellData
Delphi
public class WebGridCellData
JScript
public class WebGridCellData
Managed Extensions for C++
public __gc class WebGridCellData
C++/CLI
public ref class WebGridCellData

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebGrid.WebGridCellData

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridCellData Members
ISNet.WebUI.WebGrid Namespace


WebGridCellData Class Members

[image]
Intersoft WebGrid Documentation
WebGridCellData Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebGrid Namespace : WebGridCellData Class

Glossary Item Box

The following tables list the members exposed by WebGridCellData.

Public Constructors

 | Name | Description
Public Constructor | WebGridCellData Constructor |
Top

Public Properties

 | Name | Description
Public Property | Column |
Public Property | NewText |
Public Property | NewValue |
Public Property | OldText |
Public Property | OldValue |
Top

Public Methods

 | Name | Description
Public Method | GetParsedValue |
Top

See Also

Reference

WebGridCellData Class
ISNet.WebUI.WebGrid Namespace


WebGridCellData Constructor

[image]
Intersoft WebGrid Documentation
WebGridCellData Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridCellData Class : WebGridCellData Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebGridCellData()
C#
public WebGridCellData()
Delphi
public WebGridCellData();
JScript
public function WebGridCellData();
Managed Extensions for C++
public: WebGridCellData();
C++/CLI
public:
WebGridCellData();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridCellData Class
WebGridCellData Members


WebGridCellData Class Methods

[image]
Intersoft WebGrid Documentation
WebGridCellData Class Methods
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : WebGridCellData Class

Glossary Item Box

For a list of all members of this type, see WebGridCellData members.

Public Methods

 | Name | Description
Public Method | GetParsedValue |
Top

See Also

Reference

WebGridCellData Class
ISNet.WebUI.WebGrid Namespace


GetParsedValue Method

[image]
Intersoft WebGrid Documentation
GetParsedValue Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridCellData Class : GetParsedValue Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetParsedValue() As System.Object
Visual Basic (Usage) Copy Code
Dim instance As WebGridCellData
Dim value As System.Object

value = instance.GetParsedValue()
C#
public System.object GetParsedValue()
Delphi
public function GetParsedValue(): System.TObject;
JScript
public function GetParsedValue() : System.Object;
Managed Extensions for C++
public: System.Object* GetParsedValue();
C++/CLI
public:
System.Object^ GetParsedValue();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridCellData Class
WebGridCellData Members


WebGridCellData Class Properties

[image]
Intersoft WebGrid Documentation
WebGridCellData Class Properties
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : WebGridCellData Class

Glossary Item Box

For a list of all members of this type, see WebGridCellData members.

Public Properties

 | Name | Description
Public Property | Column |
Public Property | NewText |
Public Property | NewValue |
Public Property | OldText |
Public Property | OldValue |
Top

See Also

Reference

WebGridCellData Class
ISNet.WebUI.WebGrid Namespace


Column Property

[image]
Intersoft WebGrid Documentation
Column Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridCellData Class : Column Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Column As WebGridColumn
Visual Basic (Usage) Copy Code
Dim instance As WebGridCellData
Dim value As WebGridColumn

value = instance.Column
C#
public WebGridColumn Column {get;}
Delphi
public read-only property Column: WebGridColumn;
JScript
public function get Column : WebGridColumn
Managed Extensions for C++
public: __property WebGridColumn* get_Column();
C++/CLI
public:
property WebGridColumn^ Column {
   WebGridColumn^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridCellData Class
WebGridCellData Members


NewText Property

[image]
Intersoft WebGrid Documentation
NewText Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridCellData Class : NewText Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property NewText As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebGridCellData
Dim value As System.String

value = instance.NewText
C#
public System.string NewText {get;}
Delphi
public read-only property NewText: System.String;
JScript
public function get NewText : System.String
Managed Extensions for C++
public: __property System.string* get_NewText();
C++/CLI
public:
property System.String^ NewText {
   System.String^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridCellData Class
WebGridCellData Members


NewValue Property

[image]
Intersoft WebGrid Documentation
NewValue Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridCellData Class : NewValue Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property NewValue As System.Object
Visual Basic (Usage) Copy Code
Dim instance As WebGridCellData
Dim value As System.Object

value = instance.NewValue
C#
public System.object NewValue {get;}
Delphi
public read-only property NewValue: System.TObject;
JScript
public function get NewValue : System.Object
Managed Extensions for C++
public: __property System.Object* get_NewValue();
C++/CLI
public:
property System.Object^ NewValue {
   System.Object^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridCellData Class
WebGridCellData Members


OldText Property

[image]
Intersoft WebGrid Documentation
OldText Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridCellData Class : OldText Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property OldText As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebGridCellData
Dim value As System.String

value = instance.OldText
C#
public System.string OldText {get;}
Delphi
public read-only property OldText: System.String;
JScript
public function get OldText : System.String
Managed Extensions for C++
public: __property System.string* get_OldText();
C++/CLI
public:
property System.String^ OldText {
   System.String^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridCellData Class
WebGridCellData Members


OldValue Property

[image]
Intersoft WebGrid Documentation
OldValue Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridCellData Class : OldValue Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property OldValue As System.Object
Visual Basic (Usage) Copy Code
Dim instance As WebGridCellData
Dim value As System.Object

value = instance.OldValue
C#
public System.object OldValue {get;}
Delphi
public read-only property OldValue: System.TObject;
JScript
public function get OldValue : System.Object
Managed Extensions for C++
public: __property System.Object* get_OldValue();
C++/CLI
public:
property System.Object^ OldValue {
   System.Object^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridCellData Class
WebGridCellData Members


WebGridCellTemplateContainer Class

[image]
Intersoft WebGrid Documentation
WebGridCellTemplateContainer Class
Members See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : WebGridCellTemplateContainer Class

Glossary Item Box

Object Model

WebGridCellTemplateContainer Class

Syntax

Visual Basic (Declaration)
<System.ComponentModel.ToolboxItemAttribute(ToolboxItemType=, ToolboxItemTypeName="")>
Public Class WebGridCellTemplateContainer
   Inherits System.Web.UI.WebControls.Panel
Visual Basic (Usage) Copy Code
Dim instance As WebGridCellTemplateContainer
C#
[System.ComponentModel.ToolboxItemAttribute(ToolboxItemType=, ToolboxItemTypeName="")]
public class WebGridCellTemplateContainer : System.Web.UI.WebControls.Panel
Delphi
public class WebGridCellTemplateContainer = class(System.Web.UI.WebControls.Panel)
JScript
System.ComponentModel.ToolboxItemAttribute(ToolboxItemType=, ToolboxItemTypeName="")
public class WebGridCellTemplateContainer extends System.Web.UI.WebControls.Panel
Managed Extensions for C++
[System.ComponentModel.ToolboxItemAttribute(ToolboxItemType=, ToolboxItemTypeName="")]
public __gc class WebGridCellTemplateContainer : public System.Web.UI.WebControls.Panel
C++/CLI
[System.ComponentModel.ToolboxItemAttribute(ToolboxItemType=, ToolboxItemTypeName="")]
public ref class WebGridCellTemplateContainer : public System.Web.UI.WebControls.Panel

Inheritance Hierarchy

System.Object
System.Web.UI.Control
System.Web.UI.WebControls.WebControl
System.Web.UI.WebControls.Panel
ISNet.WebUI.WebGrid.WebGridCellTemplateContainer

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridCellTemplateContainer Members
ISNet.WebUI.WebGrid Namespace


WebGridCellTemplateContainer Class Members

[image]
Intersoft WebGrid Documentation
WebGridCellTemplateContainer Class Members
See Also Properties Methods Events Send Feedback
ISNet.WebUI.WebGrid Namespace : WebGridCellTemplateContainer Class

Glossary Item Box

The following tables list the members exposed by WebGridCellTemplateContainer.

Public Constructors

 | Name | Description
Public Constructor | WebGridCellTemplateContainer Constructor |
Top

Public Properties

 | Name | Description
Public Property | AccessKey | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | BackColor | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | BackImageUrl | (Inherited from System.Web.UI.WebControls.Panel)
Public Property | BorderColor | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | BorderStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | BorderWidth | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | ClientIDMode | (Inherited from System.Web.UI.Control)
Public Property | CssClass | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | DataItem |
Public Property | DataItemIndex |
Public Property | DefaultButton | (Inherited from System.Web.UI.WebControls.Panel)
Public Property | Direction | (Inherited from System.Web.UI.WebControls.Panel)
Public Property | DisplayIndex |
Public Property | Enabled | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | EnableTheming | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | EnableViewState | (Inherited from System.Web.UI.Control)
Public Property | Font | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | ForeColor | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | GroupingText | (Inherited from System.Web.UI.WebControls.Panel)
Public Property | Height | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | HorizontalAlign | (Inherited from System.Web.UI.WebControls.Panel)
Public Property | ID | (Inherited from System.Web.UI.Control)
Public Property | ScrollBars | (Inherited from System.Web.UI.WebControls.Panel)
Public Property | SkinID | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | SupportsDisabledAttribute | (Inherited from System.Web.UI.WebControls.Panel)
Public Property | TabIndex | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | ToolTip | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | ValidateRequestMode | (Inherited from System.Web.UI.Control)
Public Property | ViewStateMode | (Inherited from System.Web.UI.Control)
Public Property | Visible | (Inherited from System.Web.UI.Control)
Public Property | Width | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | Wrap | (Inherited from System.Web.UI.WebControls.Panel)
Top

Public Methods

 | Name | Description
Public Method | ApplyStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | ApplyStyleSheetSkin | (Inherited from System.Web.UI.Control)
Public Method | CopyBaseAttributes | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | DataBind | (Inherited from System.Web.UI.Control)
Public Method | Dispose | (Inherited from System.Web.UI.Control)
Public Method | FindControl | (Inherited from System.Web.UI.Control)
Public Method | Focus | (Inherited from System.Web.UI.Control)
Public Method | GetRouteUrl | Overloaded. (Inherited from System.Web.UI.Control)
Public Method | GetUniqueIDRelativeTo | (Inherited from System.Web.UI.Control)
Public Method | HasControls | (Inherited from System.Web.UI.Control)
Public Method | MergeStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | RenderBeginTag | Overridden.
Public Method | RenderControl | (Inherited from System.Web.UI.Control)
Public Method | RenderEndTag | Overridden.
Public Method | ResolveClientUrl | (Inherited from System.Web.UI.Control)
Public Method | ResolveUrl | (Inherited from System.Web.UI.Control)
Public Method | SetRenderMethodDelegate | (Inherited from System.Web.UI.Control)
Top

Public Events

 | Name | Description
Public Event | DataBinding | (Inherited from System.Web.UI.Control)
Public Event | Disposed | (Inherited from System.Web.UI.Control)
Public Event | Init | (Inherited from System.Web.UI.Control)
Public Event | Load | (Inherited from System.Web.UI.Control)
Public Event | PreRender | (Inherited from System.Web.UI.Control)
Public Event | Unload | (Inherited from System.Web.UI.Control)
Top

See Also

Reference

WebGridCellTemplateContainer Class
ISNet.WebUI.WebGrid Namespace


WebGridCellTemplateContainer Class Events

[image]
Intersoft WebGrid Documentation
WebGridCellTemplateContainer Class Events
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : WebGridCellTemplateContainer Class

Glossary Item Box

For a list of all members of this type, see WebGridCellTemplateContainer members.

Public Events

 | Name | Description
Public Event | DataBinding | (Inherited from System.Web.UI.Control)
Public Event | Disposed | (Inherited from System.Web.UI.Control)
Public Event | Init | (Inherited from System.Web.UI.Control)
Public Event | Load | (Inherited from System.Web.UI.Control)
Public Event | PreRender | (Inherited from System.Web.UI.Control)
Public Event | Unload | (Inherited from System.Web.UI.Control)
Top

See Also

Reference

WebGridCellTemplateContainer Class
ISNet.WebUI.WebGrid Namespace


WebGridCellTemplateContainer Constructor

[image]
Intersoft WebGrid Documentation
WebGridCellTemplateContainer Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridCellTemplateContainer Class : WebGridCellTemplateContainer Constructor

dataItem
dataItemIndex
displayIndex

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal dataItem As System.Object, _
   ByVal dataItemIndex As System.Integer, _
   ByVal displayIndex As System.Integer _
)
Visual Basic (Usage) Copy Code
Dim dataItem As System.Object
Dim dataItemIndex As System.Integer
Dim displayIndex As System.Integer

Dim instance As New WebGridCellTemplateContainer(dataItem, dataItemIndex, displayIndex)
C#
public WebGridCellTemplateContainer(
   System.object dataItem,
   System.int dataItemIndex,
   System.int displayIndex
)
Delphi
public WebGridCellTemplateContainer(
    dataItem: System.TObject;
    dataItemIndex: System.Integer;
    displayIndex: System.Integer
);
JScript
public function WebGridCellTemplateContainer(
   dataItem : System.Object,
   dataItemIndex : System.int,
   displayIndex : System.int
);
Managed Extensions for C++
public: WebGridCellTemplateContainer(
   System.Object* dataItem,
   System.int dataItemIndex,
   System.int displayIndex
)
C++/CLI
public:
WebGridCellTemplateContainer(
   System.Object^ dataItem,
   System.int dataItemIndex,
   System.int displayIndex
)

Parameters

dataItem
dataItemIndex
displayIndex

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridCellTemplateContainer Class
WebGridCellTemplateContainer Members


ApplyStyle Method

[image]
Intersoft WebGrid Documentation
ApplyStyle Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridCellTemplateContainer Class : ApplyStyle Method

s

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub ApplyStyle( _
   ByVal s As System.Web.UI.WebControls.Style _
)
Visual Basic (Usage) Copy Code
Dim instance As WebGridCellTemplateContainer
Dim s As System.Web.UI.WebControls.Style

instance.ApplyStyle(s)
C#
public void ApplyStyle(
   System.Web.UI.WebControls.Style s
)
Delphi
public procedure ApplyStyle(
    s: System.Web.UI.WebControls.Style
);
JScript
public function ApplyStyle(
   s : System.Web.UI.WebControls.Style
);
Managed Extensions for C++
public: void ApplyStyle(
   System.Web.UI.WebControls.Style* s
)
C++/CLI
public:
void ApplyStyle(
   System.Web.UI.WebControls.Style^ s
)

Parameters

s

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridCellTemplateContainer Class
WebGridCellTemplateContainer Members


ApplyStyleSheetSkin Method

[image]
Intersoft WebGrid Documentation
ApplyStyleSheetSkin Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridCellTemplateContainer Class : ApplyStyleSheetSkin Method

page

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Public Overridable Sub ApplyStyleSheetSkin( _
   ByVal page As System.Web.UI.Page _
)
Visual Basic (Usage) Copy Code
Dim instance As WebGridCellTemplateContainer
Dim page As System.Web.UI.Page

instance.ApplyStyleSheetSkin(page)
C#
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public virtual void ApplyStyleSheetSkin(
   System.Web.UI.Page page
)
Delphi
public procedure ApplyStyleSheetSkin(
    page: System.Web.UI.Page
); virtual;
JScript
System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)
public function ApplyStyleSheetSkin(
   page : System.Web.UI.Page
);
Managed Extensions for C++
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public: virtual void ApplyStyleSheetSkin(
   System.Web.UI.Page* page
)
C++/CLI
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public:
virtual void ApplyStyleSheetSkin(
   System.Web.UI.Page^ page
)

Parameters

page

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridCellTemplateContainer Class
WebGridCellTemplateContainer Members


CopyBaseAttributes Method

[image]
Intersoft WebGrid Documentation
CopyBaseAttributes Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridCellTemplateContainer Class : CopyBaseAttributes Method

controlSrc

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub CopyBaseAttributes( _
   ByVal controlSrc As System.Web.UI.WebControls.WebControl _
)
Visual Basic (Usage) Copy Code
Dim instance As WebGridCellTemplateContainer
Dim controlSrc As System.Web.UI.WebControls.WebControl

instance.CopyBaseAttributes(controlSrc)
C#
public void CopyBaseAttributes(
   System.Web.UI.WebControls.WebControl controlSrc
)
Delphi
public procedure CopyBaseAttributes(
    controlSrc: System.Web.UI.WebControls.WebControl
);
JScript
public function CopyBaseAttributes(
   controlSrc : System.Web.UI.WebControls.WebControl
);
Managed Extensions for C++
public: void CopyBaseAttributes(
   System.Web.UI.WebControls.WebControl* controlSrc
)
C++/CLI
public:
void CopyBaseAttributes(
   System.Web.UI.WebControls.WebControl^ controlSrc
)

Parameters

controlSrc

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridCellTemplateContainer Class
WebGridCellTemplateContainer Members


DataBind Method

[image]
Intersoft WebGrid Documentation
DataBind Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridCellTemplateContainer Class : DataBind Method

Glossary Item Box

Overload List

Overload | Description
DataBind | (Inherited from System.Web.UI.Control)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridCellTemplateContainer Class
WebGridCellTemplateContainer Members


DataBind() Method

[image]
Intersoft WebGrid Documentation
DataBind() Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridCellTemplateContainer Class : DataBind() Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")>
Public Overridable Sub DataBind()
Visual Basic (Usage) Copy Code
Dim instance As WebGridCellTemplateContainer

instance.DataBind()
C#
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public virtual void DataBind()
Delphi
public procedure DataBind(); virtual;
JScript
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")
public function DataBind();
Managed Extensions for C++
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public: virtual void DataBind();
C++/CLI
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public:
virtual void DataBind();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridCellTemplateContainer Class
WebGridCellTemplateContainer Members


Dispose Method

[image]
Intersoft WebGrid Documentation
Dispose Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridCellTemplateContainer Class : Dispose Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Dispose()
Visual Basic (Usage) Copy Code
Dim instance As WebGridCellTemplateContainer

instance.Dispose()
C#
public virtual void Dispose()
Delphi
public procedure Dispose(); virtual;
JScript
public function Dispose();
Managed Extensions for C++
public: virtual void Dispose();
C++/CLI
public:
virtual void Dispose();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridCellTemplateContainer Class
WebGridCellTemplateContainer Members


FindControl Method

[image]
Intersoft WebGrid Documentation
FindControl Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridCellTemplateContainer Class : FindControl Method

Glossary Item Box

Overload List

Overload | Description
FindControl | (Inherited from System.Web.UI.Control)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridCellTemplateContainer Class
WebGridCellTemplateContainer Members


FindControl(String) Method

[image]
Intersoft WebGrid Documentation
FindControl(String) Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridCellTemplateContainer Class : FindControl(String) Method

id

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")>
Public Overridable Function FindControl( _
   ByVal id As System.String _
) As System.Web.UI.Control
Visual Basic (Usage) Copy Code
Dim instance As WebGridCellTemplateContainer
Dim id As System.String
Dim value As System.Web.UI.Control

value = instance.FindControl(id)
C#
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public virtual System.Web.UI.Control FindControl(
   System.string id
)
Delphi
public function FindControl(
    id: System.String
): System.Web.UI.Control; virtual;
JScript
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")
public function FindControl(
   id : System.String
) : System.Web.UI.Control;
Managed Extensions for C++
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public: virtual System.Web.UI.Control* FindControl(
   System.string* id
)
C++/CLI
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public:
virtual System.Web.UI.Control^ FindControl(
   System.String^ id
)

Parameters

id

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridCellTemplateContainer Class
WebGridCellTemplateContainer Members


Focus Method

[image]
Intersoft WebGrid Documentation
Focus Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridCellTemplateContainer Class : Focus Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Focus()
Visual Basic (Usage) Copy Code
Dim instance As WebGridCellTemplateContainer

instance.Focus()
C#
public virtual void Focus()
Delphi
public procedure Focus(); virtual;
JScript
public function Focus();
Managed Extensions for C++
public: virtual void Focus();
C++/CLI
public:
virtual void Focus();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridCellTemplateContainer Class
WebGridCellTemplateContainer Members


GetRouteUrl Method

[image]
Intersoft WebGrid Documentation
GetRouteUrl Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridCellTemplateContainer Class : GetRouteUrl Method

Glossary Item Box

Overload List

Overload | Description
GetRouteUrl(Object) | (Inherited from System.Web.UI.Control)
GetRouteUrl(String,Object) | (Inherited from System.Web.UI.Control)
GetRouteUrl(RouteValueDictionary) | (Inherited from System.Web.UI.Control)
GetRouteUrl(String,RouteValueDictionary) | (Inherited from System.Web.UI.Control)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridCellTemplateContainer Class
WebGridCellTemplateContainer Members


GetRouteUrl(Object) Method

[image]
Intersoft WebGrid Documentation
GetRouteUrl(Object) Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridCellTemplateContainer Class > GetRouteUrl Method : GetRouteUrl(Object) Method

routeParameters

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function GetRouteUrl( _
   ByVal routeParameters As System.Object _
) As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebGridCellTemplateContainer
Dim routeParameters As System.Object
Dim value As System.String

value = instance.GetRouteUrl(routeParameters)
C#
public System.string GetRouteUrl(
   System.object routeParameters
)
Delphi
public function GetRouteUrl(
    routeParameters: System.TObject
): System.String;
JScript
public function GetRouteUrl(
   routeParameters : System.Object
) : System.String;
Managed Extensions for C++
public: System.string* GetRouteUrl(
   System.Object* routeParameters
)
C++/CLI
public:
System.String^ GetRouteUrl(
   System.Object^ routeParameters
)

Parameters

routeParameters

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridCellTemplateContainer Class
WebGridCellTemplateContainer Members
Overload List


GetRouteUrl(String,Object) Method

[image]
Intersoft WebGrid Documentation
GetRouteUrl(String,Object) Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridCellTemplateContainer Class > GetRouteUrl Method : GetRouteUrl(String,Object) Method

routeName
routeParameters

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function GetRouteUrl( _
   ByVal routeName As System.String, _
   ByVal routeParameters As System.Object _
) As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebGridCellTemplateContainer
Dim routeName As System.String
Dim routeParameters As System.Object
Dim value As System.String

value = instance.GetRouteUrl(routeName, routeParameters)
C#
public System.string GetRouteUrl(
   System.string routeName,
   System.object routeParameters
)
Delphi
public function GetRouteUrl(
    routeName: System.String;
    routeParameters: System.TObject
): System.String;
JScript
public function GetRouteUrl(
   routeName : System.String,
   routeParameters : System.Object
) : System.String;
Managed Extensions for C++
public: System.string* GetRouteUrl(
   System.string* routeName,
   System.Object* routeParameters
)
C++/CLI
public:
System.String^ GetRouteUrl(
   System.String^ routeName,
   System.Object^ routeParameters
)

Parameters

routeName
routeParameters

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridCellTemplateContainer Class
WebGridCellTemplateContainer Members
Overload List


GetRouteUrl(RouteValueDictionary) Method

[image]
Intersoft WebGrid Documentation
GetRouteUrl(RouteValueDictionary) Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridCellTemplateContainer Class > GetRouteUrl Method : GetRouteUrl(RouteValueDictionary) Method

routeParameters

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")>
Public Overloads Function GetRouteUrl( _
   ByVal routeParameters As System.Web.Routing.RouteValueDictionary _
) As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebGridCellTemplateContainer
Dim routeParameters As System.Web.Routing.RouteValueDictionary
Dim value As System.String

value = instance.GetRouteUrl(routeParameters)
C#
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public System.string GetRouteUrl(
   System.Web.Routing.RouteValueDictionary routeParameters
)
Delphi
public function GetRouteUrl(
    routeParameters: System.Web.Routing.RouteValueDictionary
): System.String;
JScript
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")
public function GetRouteUrl(
   routeParameters : System.Web.Routing.RouteValueDictionary
) : System.String;
Managed Extensions for C++
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public: System.string* GetRouteUrl(
   System.Web.Routing.RouteValueDictionary* routeParameters
)
C++/CLI
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public:
System.String^ GetRouteUrl(
   System.Web.Routing.RouteValueDictionary^ routeParameters
)

Parameters

routeParameters

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridCellTemplateContainer Class
WebGridCellTemplateContainer Members
Overload List


GetRouteUrl(String,RouteValueDictionary) Method

[image]
Intersoft WebGrid Documentation
GetRouteUrl(String,RouteValueDictionary) Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridCellTemplateContainer Class > GetRouteUrl Method : GetRouteUrl(String,RouteValueDictionary) Method

routeName
routeParameters

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function GetRouteUrl( _
   ByVal routeName As System.String, _
   ByVal routeParameters As System.Web.Routing.RouteValueDictionary _
) As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebGridCellTemplateContainer
Dim routeName As System.String
Dim routeParameters As System.Web.Routing.RouteValueDictionary
Dim value As System.String

value = instance.GetRouteUrl(routeName, routeParameters)
C#
public System.string GetRouteUrl(
   System.string routeName,
   System.Web.Routing.RouteValueDictionary routeParameters
)
Delphi
public function GetRouteUrl(
    routeName: System.String;
    routeParameters: System.Web.Routing.RouteValueDictionary
): System.String;
JScript
public function GetRouteUrl(
   routeName : System.String,
   routeParameters : System.Web.Routing.RouteValueDictionary
) : System.String;
Managed Extensions for C++
public: System.string* GetRouteUrl(
   System.string* routeName,
   System.Web.Routing.RouteValueDictionary* routeParameters
)
C++/CLI
public:
System.String^ GetRouteUrl(
   System.String^ routeName,
   System.Web.Routing.RouteValueDictionary^ routeParameters
)

Parameters

routeName
routeParameters

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridCellTemplateContainer Class
WebGridCellTemplateContainer Members
Overload List


GetUniqueIDRelativeTo Method

[image]
Intersoft WebGrid Documentation
GetUniqueIDRelativeTo Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridCellTemplateContainer Class : GetUniqueIDRelativeTo Method

control

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetUniqueIDRelativeTo( _
   ByVal control As System.Web.UI.Control _
) As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebGridCellTemplateContainer
Dim control As System.Web.UI.Control
Dim value As System.String

value = instance.GetUniqueIDRelativeTo(control)
C#
public System.string GetUniqueIDRelativeTo(
   System.Web.UI.Control control
)
Delphi
public function GetUniqueIDRelativeTo(
    control: System.Web.UI.Control
): System.String;
JScript
public function GetUniqueIDRelativeTo(
   control : System.Web.UI.Control
) : System.String;
Managed Extensions for C++
public: System.string* GetUniqueIDRelativeTo(
   System.Web.UI.Control* control
)
C++/CLI
public:
System.String^ GetUniqueIDRelativeTo(
   System.Web.UI.Control^ control
)

Parameters

control

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridCellTemplateContainer Class
WebGridCellTemplateContainer Members


HasControls Method

[image]
Intersoft WebGrid Documentation
HasControls Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridCellTemplateContainer Class : HasControls Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function HasControls() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebGridCellTemplateContainer
Dim value As System.Boolean

value = instance.HasControls()
C#
public virtual System.bool HasControls()
Delphi
public function HasControls(): System.Boolean; virtual;
JScript
public function HasControls() : System.boolean;
Managed Extensions for C++
public: virtual System.bool HasControls();
C++/CLI
public:
virtual System.bool HasControls();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridCellTemplateContainer Class
WebGridCellTemplateContainer Members


MergeStyle Method

[image]
Intersoft WebGrid Documentation
MergeStyle Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridCellTemplateContainer Class : MergeStyle Method

s

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub MergeStyle( _
   ByVal s As System.Web.UI.WebControls.Style _
)
Visual Basic (Usage) Copy Code
Dim instance As WebGridCellTemplateContainer
Dim s As System.Web.UI.WebControls.Style

instance.MergeStyle(s)
C#
public void MergeStyle(
   System.Web.UI.WebControls.Style s
)
Delphi
public procedure MergeStyle(
    s: System.Web.UI.WebControls.Style
);
JScript
public function MergeStyle(
   s : System.Web.UI.WebControls.Style
);
Managed Extensions for C++
public: void MergeStyle(
   System.Web.UI.WebControls.Style* s
)
C++/CLI
public:
void MergeStyle(
   System.Web.UI.WebControls.Style^ s
)

Parameters

s

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridCellTemplateContainer Class
WebGridCellTemplateContainer Members


WebGridCellTemplateContainer Class Methods

[image]
Intersoft WebGrid Documentation
WebGridCellTemplateContainer Class Methods
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : WebGridCellTemplateContainer Class

Glossary Item Box

For a list of all members of this type, see WebGridCellTemplateContainer members.

Public Methods

 | Name | Description
Public Method | ApplyStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | ApplyStyleSheetSkin | (Inherited from System.Web.UI.Control)
Public Method | CopyBaseAttributes | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | DataBind | (Inherited from System.Web.UI.Control)
Public Method | Dispose | (Inherited from System.Web.UI.Control)
Public Method | FindControl | (Inherited from System.Web.UI.Control)
Public Method | Focus | (Inherited from System.Web.UI.Control)
Public Method | GetRouteUrl | Overloaded. (Inherited from System.Web.UI.Control)
Public Method | GetUniqueIDRelativeTo | (Inherited from System.Web.UI.Control)
Public Method | HasControls | (Inherited from System.Web.UI.Control)
Public Method | MergeStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | RenderBeginTag | Overridden.
Public Method | RenderControl | (Inherited from System.Web.UI.Control)
Public Method | RenderEndTag | Overridden.
Public Method | ResolveClientUrl | (Inherited from System.Web.UI.Control)
Public Method | ResolveUrl | (Inherited from System.Web.UI.Control)
Public Method | SetRenderMethodDelegate | (Inherited from System.Web.UI.Control)
Top

See Also

Reference

WebGridCellTemplateContainer Class
ISNet.WebUI.WebGrid Namespace


RenderBeginTag Method

[image]
Intersoft WebGrid Documentation
RenderBeginTag Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridCellTemplateContainer Class : RenderBeginTag Method

writer

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Sub RenderBeginTag( _
   ByVal writer As System.Web.UI.HtmlTextWriter _
)
Visual Basic (Usage) Copy Code
Dim instance As WebGridCellTemplateContainer
Dim writer As System.Web.UI.HtmlTextWriter

instance.RenderBeginTag(writer)
C#
public override void RenderBeginTag(
   System.Web.UI.HtmlTextWriter writer
)
Delphi
public procedure RenderBeginTag(
    writer: System.Web.UI.HtmlTextWriter
); override;
JScript
public override function RenderBeginTag(
   writer : System.Web.UI.HtmlTextWriter
);
Managed Extensions for C++
public: void RenderBeginTag(
   System.Web.UI.HtmlTextWriter* writer
) override
C++/CLI
public:
void RenderBeginTag(
   System.Web.UI.HtmlTextWriter^ writer
) override

Parameters

writer

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridCellTemplateContainer Class
WebGridCellTemplateContainer Members


RenderControl Method

[image]
Intersoft WebGrid Documentation
RenderControl Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridCellTemplateContainer Class : RenderControl Method

Glossary Item Box

Overload List

Overload | Description
RenderControl | (Inherited from System.Web.UI.Control)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridCellTemplateContainer Class
WebGridCellTemplateContainer Members


RenderControl(HtmlTextWriter) Method

[image]
Intersoft WebGrid Documentation
RenderControl(HtmlTextWriter) Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridCellTemplateContainer Class : RenderControl(HtmlTextWriter) Method

writer

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")>
Public Overridable Sub RenderControl( _
   ByVal writer As System.Web.UI.HtmlTextWriter _
)
Visual Basic (Usage) Copy Code
Dim instance As WebGridCellTemplateContainer
Dim writer As System.Web.UI.HtmlTextWriter

instance.RenderControl(writer)
C#
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public virtual void RenderControl(
   System.Web.UI.HtmlTextWriter writer
)
Delphi
public procedure RenderControl(
    writer: System.Web.UI.HtmlTextWriter
); virtual;
JScript
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")
public function RenderControl(
   writer : System.Web.UI.HtmlTextWriter
);
Managed Extensions for C++
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public: virtual void RenderControl(
   System.Web.UI.HtmlTextWriter* writer
)
C++/CLI
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public:
virtual void RenderControl(
   System.Web.UI.HtmlTextWriter^ writer
)

Parameters

writer

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridCellTemplateContainer Class
WebGridCellTemplateContainer Members


RenderEndTag Method

[image]
Intersoft WebGrid Documentation
RenderEndTag Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridCellTemplateContainer Class : RenderEndTag Method

writer

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Sub RenderEndTag( _
   ByVal writer As System.Web.UI.HtmlTextWriter _
)
Visual Basic (Usage) Copy Code
Dim instance As WebGridCellTemplateContainer
Dim writer As System.Web.UI.HtmlTextWriter

instance.RenderEndTag(writer)
C#
public override void RenderEndTag(
   System.Web.UI.HtmlTextWriter writer
)
Delphi
public procedure RenderEndTag(
    writer: System.Web.UI.HtmlTextWriter
); override;
JScript
public override function RenderEndTag(
   writer : System.Web.UI.HtmlTextWriter
);
Managed Extensions for C++
public: void RenderEndTag(
   System.Web.UI.HtmlTextWriter* writer
) override
C++/CLI
public:
void RenderEndTag(
   System.Web.UI.HtmlTextWriter^ writer
) override

Parameters

writer

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridCellTemplateContainer Class
WebGridCellTemplateContainer Members


ResolveClientUrl Method

[image]
Intersoft WebGrid Documentation
ResolveClientUrl Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridCellTemplateContainer Class : ResolveClientUrl Method

relativeUrl

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function ResolveClientUrl( _
   ByVal relativeUrl As System.String _
) As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebGridCellTemplateContainer
Dim relativeUrl As System.String
Dim value As System.String

value = instance.ResolveClientUrl(relativeUrl)
C#
public System.string ResolveClientUrl(
   System.string relativeUrl
)
Delphi
public function ResolveClientUrl(
    relativeUrl: System.String
): System.String;
JScript
public function ResolveClientUrl(
   relativeUrl : System.String
) : System.String;
Managed Extensions for C++
public: System.string* ResolveClientUrl(
   System.string* relativeUrl
)
C++/CLI
public:
System.String^ ResolveClientUrl(
   System.String^ relativeUrl
)

Parameters

relativeUrl

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridCellTemplateContainer Class
WebGridCellTemplateContainer Members


ResolveUrl Method

[image]
Intersoft WebGrid Documentation
ResolveUrl Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridCellTemplateContainer Class : ResolveUrl Method

relativeUrl

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function ResolveUrl( _
   ByVal relativeUrl As System.String _
) As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebGridCellTemplateContainer
Dim relativeUrl As System.String
Dim value As System.String

value = instance.ResolveUrl(relativeUrl)
C#
public System.string ResolveUrl(
   System.string relativeUrl
)
Delphi
public function ResolveUrl(
    relativeUrl: System.String
): System.String;
JScript
public function ResolveUrl(
   relativeUrl : System.String
) : System.String;
Managed Extensions for C++
public: System.string* ResolveUrl(
   System.string* relativeUrl
)
C++/CLI
public:
System.String^ ResolveUrl(
   System.String^ relativeUrl
)

Parameters

relativeUrl

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridCellTemplateContainer Class
WebGridCellTemplateContainer Members


SetRenderMethodDelegate Method

[image]
Intersoft WebGrid Documentation
SetRenderMethodDelegate Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridCellTemplateContainer Class : SetRenderMethodDelegate Method

renderMethod

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Public Sub SetRenderMethodDelegate( _
   ByVal renderMethod As System.Web.UI.RenderMethod _
)
Visual Basic (Usage) Copy Code
Dim instance As WebGridCellTemplateContainer
Dim renderMethod As System.Web.UI.RenderMethod

instance.SetRenderMethodDelegate(renderMethod)
C#
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public void SetRenderMethodDelegate(
   System.Web.UI.RenderMethod renderMethod
)
Delphi
public procedure SetRenderMethodDelegate(
    renderMethod: System.Web.UI.RenderMethod
);
JScript
System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)
public function SetRenderMethodDelegate(
   renderMethod : System.Web.UI.RenderMethod
);
Managed Extensions for C++
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public: void SetRenderMethodDelegate(
   System.Web.UI.RenderMethod* renderMethod
)
C++/CLI
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public:
void SetRenderMethodDelegate(
   System.Web.UI.RenderMethod^ renderMethod
)

Parameters

renderMethod

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridCellTemplateContainer Class
WebGridCellTemplateContainer Members


AccessKey Property

[image]
Intersoft WebGrid Documentation
AccessKey Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridCellTemplateContainer Class : AccessKey Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<WebSysDescriptionAttribute("Keyboard shortcut used by the control.")>
<WebCategoryAttribute("Accessibility")>
<System.ComponentModel.DefaultValueAttribute()>
Public Overridable Property AccessKey As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebGridCellTemplateContainer
Dim value As System.String

instance.AccessKey = value

value = instance.AccessKey
C#
[WebSysDescriptionAttribute("Keyboard shortcut used by the control.")]
[WebCategoryAttribute("Accessibility")]
[System.ComponentModel.DefaultValueAttribute()]
public virtual System.string AccessKey {get; set;}
Delphi
public read-write property AccessKey: System.String; virtual;
JScript
WebSysDescriptionAttribute("Keyboard shortcut used by the control.")
WebCategoryAttribute("Accessibility")
System.ComponentModel.DefaultValueAttribute()
public function get,set AccessKey : System.String
Managed Extensions for C++
[WebSysDescriptionAttribute("Keyboard shortcut used by the control.")]
[WebCategoryAttribute("Accessibility")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property virtual System.string* get_AccessKey();
public: __property virtual void set_AccessKey(
   System.string* value
);
C++/CLI
[WebSysDescriptionAttribute("Keyboard shortcut used by the control.")]
[WebCategoryAttribute("Accessibility")]
[System.ComponentModel.DefaultValueAttribute()]
public:
virtual property System.String^ AccessKey {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridCellTemplateContainer Class
WebGridCellTemplateContainer Members


BackColor Property

[image]
Intersoft WebGrid Documentation
BackColor Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridCellTemplateContainer Class : BackColor Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<WebCategoryAttribute("Appearance")>
<WebSysDescriptionAttribute("Color of the background of the control.")>
<System.ComponentModel.TypeConverterAttribute("System.Web.UI.WebControls.WebColorConverter, System.Web, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")>
<System.ComponentModel.DefaultValueAttribute()>
Public Overridable Property BackColor As System.Drawing.Color
Visual Basic (Usage) Copy Code
Dim instance As WebGridCellTemplateContainer
Dim value As System.Drawing.Color

instance.BackColor = value

value = instance.BackColor
C#
[WebCategoryAttribute("Appearance")]
[WebSysDescriptionAttribute("Color of the background of the control.")]
[System.ComponentModel.TypeConverterAttribute("System.Web.UI.WebControls.WebColorConverter, System.Web, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[System.ComponentModel.DefaultValueAttribute()]
public virtual System.Drawing.Color BackColor {get; set;}
Delphi
public read-write property BackColor: System.Drawing.Color; virtual;
JScript
WebCategoryAttribute("Appearance")
WebSysDescriptionAttribute("Color of the background of the control.")
System.ComponentModel.TypeConverterAttribute("System.Web.UI.WebControls.WebColorConverter, System.Web, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")
System.ComponentModel.DefaultValueAttribute()
public function get,set BackColor : System.Drawing.Color
Managed Extensions for C++
[WebCategoryAttribute("Appearance")]
[WebSysDescriptionAttribute("Color of the background of the control.")]
[System.ComponentModel.TypeConverterAttribute("System.Web.UI.WebControls.WebColorConverter, System.Web, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property virtual System.Drawing.Color get_BackColor();
public: __property virtual void set_BackColor(
   System.Drawing.Color value
);
C++/CLI
[WebCategoryAttribute("Appearance")]
[WebSysDescriptionAttribute("Color of the background of the control.")]
[System.ComponentModel.TypeConverterAttribute("System.Web.UI.WebControls.WebColorConverter, System.Web, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[System.ComponentModel.DefaultValueAttribute()]
public:
virtual property System.Drawing.Color BackColor {
   System.Drawing.Color get();
   void set (    System.Drawing.Color value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridCellTemplateContainer Class
WebGridCellTemplateContainer Members


BackImageUrl Property

[image]
Intersoft WebGrid Documentation
BackImageUrl Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridCellTemplateContainer Class : BackImageUrl Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<WebCategoryAttribute("Appearance")>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="System.Web.UI.Design.ImageUrlEditor, System.Design, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")>
<WebSysDescriptionAttribute("The background image of the panel.")>
<System.Web.UI.UrlPropertyAttribute()>
Public Overridable Property BackImageUrl As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebGridCellTemplateContainer
Dim value As System.String

instance.BackImageUrl = value

value = instance.BackImageUrl
C#
[System.ComponentModel.DefaultValueAttribute()]
[WebCategoryAttribute("Appearance")]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="System.Web.UI.Design.ImageUrlEditor, System.Design, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[WebSysDescriptionAttribute("The background image of the panel.")]
[System.Web.UI.UrlPropertyAttribute()]
public virtual System.string BackImageUrl {get; set;}
Delphi
public read-write property BackImageUrl: System.String; virtual;
JScript
System.ComponentModel.DefaultValueAttribute()
WebCategoryAttribute("Appearance")
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="System.Web.UI.Design.ImageUrlEditor, System.Design, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")
WebSysDescriptionAttribute("The background image of the panel.")
System.Web.UI.UrlPropertyAttribute()
public function get,set BackImageUrl : System.String
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[WebCategoryAttribute("Appearance")]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="System.Web.UI.Design.ImageUrlEditor, System.Design, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[WebSysDescriptionAttribute("The background image of the panel.")]
[System.Web.UI.UrlPropertyAttribute()]
public: __property virtual System.string* get_BackImageUrl();
public: __property virtual void set_BackImageUrl(
   System.string* value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[WebCategoryAttribute("Appearance")]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="System.Web.UI.Design.ImageUrlEditor, System.Design, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[WebSysDescriptionAttribute("The background image of the panel.")]
[System.Web.UI.UrlPropertyAttribute()]
public:
virtual property System.String^ BackImageUrl {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridCellTemplateContainer Class
WebGridCellTemplateContainer Members


BorderColor Property

[image]
Intersoft WebGrid Documentation
BorderColor Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridCellTemplateContainer Class : BorderColor Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.TypeConverterAttribute("System.Web.UI.WebControls.WebColorConverter, System.Web, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")>
<WebCategoryAttribute("Appearance")>
<WebSysDescriptionAttribute("Color of the border around the control.")>
Public Overridable Property BorderColor As System.Drawing.Color
Visual Basic (Usage) Copy Code
Dim instance As WebGridCellTemplateContainer
Dim value As System.Drawing.Color

instance.BorderColor = value

value = instance.BorderColor
C#
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.TypeConverterAttribute("System.Web.UI.WebControls.WebColorConverter, System.Web, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[WebCategoryAttribute("Appearance")]
[WebSysDescriptionAttribute("Color of the border around the control.")]
public virtual System.Drawing.Color BorderColor {get; set;}
Delphi
public read-write property BorderColor: System.Drawing.Color; virtual;
JScript
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.TypeConverterAttribute("System.Web.UI.WebControls.WebColorConverter, System.Web, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")
WebCategoryAttribute("Appearance")
WebSysDescriptionAttribute("Color of the border around the control.")
public function get,set BorderColor : System.Drawing.Color
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.TypeConverterAttribute("System.Web.UI.WebControls.WebColorConverter, System.Web, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[WebCategoryAttribute("Appearance")]
[WebSysDescriptionAttribute("Color of the border around the control.")]
public: __property virtual System.Drawing.Color get_BorderColor();
public: __property virtual void set_BorderColor(
   System.Drawing.Color value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.TypeConverterAttribute("System.Web.UI.WebControls.WebColorConverter, System.Web, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[WebCategoryAttribute("Appearance")]
[WebSysDescriptionAttribute("Color of the border around the control.")]
public:
virtual property System.Drawing.Color BorderColor {
   System.Drawing.Color get();
   void set (    System.Drawing.Color value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridCellTemplateContainer Class
WebGridCellTemplateContainer Members


BorderStyle Property

[image]
Intersoft WebGrid Documentation
BorderStyle Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridCellTemplateContainer Class : BorderStyle Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<WebSysDescriptionAttribute("Style of the border around the control.")>
<WebCategoryAttribute("Appearance")>
<System.ComponentModel.DefaultValueAttribute()>
Public Overridable Property BorderStyle As System.Web.UI.WebControls.BorderStyle
Visual Basic (Usage) Copy Code
Dim instance As WebGridCellTemplateContainer
Dim value As System.Web.UI.WebControls.BorderStyle

instance.BorderStyle = value

value = instance.BorderStyle
C#
[WebSysDescriptionAttribute("Style of the border around the control.")]
[WebCategoryAttribute("Appearance")]
[System.ComponentModel.DefaultValueAttribute()]
public virtual System.Web.UI.WebControls.BorderStyle BorderStyle {get; set;}
Delphi
public read-write property BorderStyle: System.Web.UI.WebControls.BorderStyle; virtual;
JScript
WebSysDescriptionAttribute("Style of the border around the control.")
WebCategoryAttribute("Appearance")
System.ComponentModel.DefaultValueAttribute()
public function get,set BorderStyle : System.Web.UI.WebControls.BorderStyle
Managed Extensions for C++
[WebSysDescriptionAttribute("Style of the border around the control.")]
[WebCategoryAttribute("Appearance")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property virtual System.Web.UI.WebControls.BorderStyle get_BorderStyle();
public: __property virtual void set_BorderStyle(
   System.Web.UI.WebControls.BorderStyle value
);
C++/CLI
[WebSysDescriptionAttribute("Style of the border around the control.")]
[WebCategoryAttribute("Appearance")]
[System.ComponentModel.DefaultValueAttribute()]
public:
virtual property System.Web.UI.WebControls.BorderStyle BorderStyle {
   System.Web.UI.WebControls.BorderStyle get();
   void set (    System.Web.UI.WebControls.BorderStyle value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridCellTemplateContainer Class
WebGridCellTemplateContainer Members


BorderWidth Property

[image]
Intersoft WebGrid Documentation
BorderWidth Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridCellTemplateContainer Class : BorderWidth Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<WebCategoryAttribute("Appearance")>
<WebSysDescriptionAttribute("Width of the border around the control.")>
Public Overridable Property BorderWidth As System.Web.UI.WebControls.Unit
Visual Basic (Usage) Copy Code
Dim instance As WebGridCellTemplateContainer
Dim value As System.Web.UI.WebControls.Unit

instance.BorderWidth = value

value = instance.BorderWidth
C#
[System.ComponentModel.DefaultValueAttribute()]
[WebCategoryAttribute("Appearance")]
[WebSysDescriptionAttribute("Width of the border around the control.")]
public virtual System.Web.UI.WebControls.Unit BorderWidth {get; set;}
Delphi
public read-write property BorderWidth: System.Web.UI.WebControls.Unit; virtual;
JScript
System.ComponentModel.DefaultValueAttribute()
WebCategoryAttribute("Appearance")
WebSysDescriptionAttribute("Width of the border around the control.")
public function get,set BorderWidth : System.Web.UI.WebControls.Unit
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[WebCategoryAttribute("Appearance")]
[WebSysDescriptionAttribute("Width of the border around the control.")]
public: __property virtual System.Web.UI.WebControls.Unit get_BorderWidth();
public: __property virtual void set_BorderWidth(
   System.Web.UI.WebControls.Unit value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[WebCategoryAttribute("Appearance")]
[WebSysDescriptionAttribute("Width of the border around the control.")]
public:
virtual property System.Web.UI.WebControls.Unit BorderWidth {
   System.Web.UI.WebControls.Unit get();
   void set (    System.Web.UI.WebControls.Unit value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridCellTemplateContainer Class
WebGridCellTemplateContainer Members


ClientIDMode Property

[image]
Intersoft WebGrid Documentation
ClientIDMode Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridCellTemplateContainer Class : ClientIDMode Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Web.UI.ThemeableAttribute(False)>
<System.ComponentModel.DefaultValueAttribute()>
<WebCategoryAttribute("Behavior")>
<WebSysDescriptionAttribute("Indicates how the ClientID should be generated for the control.")>
Public Overridable Property ClientIDMode As System.Web.UI.ClientIDMode
Visual Basic (Usage) Copy Code
Dim instance As WebGridCellTemplateContainer
Dim value As System.Web.UI.ClientIDMode

instance.ClientIDMode = value

value = instance.ClientIDMode
C#
[System.Web.UI.ThemeableAttribute(false)]
[System.ComponentModel.DefaultValueAttribute()]
[WebCategoryAttribute("Behavior")]
[WebSysDescriptionAttribute("Indicates how the ClientID should be generated for the control.")]
public virtual System.Web.UI.ClientIDMode ClientIDMode {get; set;}
Delphi
public read-write property ClientIDMode: System.Web.UI.ClientIDMode; virtual;
JScript
System.Web.UI.ThemeableAttribute()
System.ComponentModel.DefaultValueAttribute()
WebCategoryAttribute("Behavior")
WebSysDescriptionAttribute("Indicates how the ClientID should be generated for the control.")
public function get,set ClientIDMode : System.Web.UI.ClientIDMode
Managed Extensions for C++
[System.Web.UI.ThemeableAttribute(false)]
[System.ComponentModel.DefaultValueAttribute()]
[WebCategoryAttribute("Behavior")]
[WebSysDescriptionAttribute("Indicates how the ClientID should be generated for the control.")]
public: __property virtual System.Web.UI.ClientIDMode get_ClientIDMode();
public: __property virtual void set_ClientIDMode(
   System.Web.UI.ClientIDMode value
);
C++/CLI
[System.Web.UI.ThemeableAttribute(false)]
[System.ComponentModel.DefaultValueAttribute()]
[WebCategoryAttribute("Behavior")]
[WebSysDescriptionAttribute("Indicates how the ClientID should be generated for the control.")]
public:
virtual property System.Web.UI.ClientIDMode ClientIDMode {
   System.Web.UI.ClientIDMode get();
   void set (    System.Web.UI.ClientIDMode value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridCellTemplateContainer Class
WebGridCellTemplateContainer Members


CssClass Property

[image]
Intersoft WebGrid Documentation
CssClass Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridCellTemplateContainer Class : CssClass Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<WebSysDescriptionAttribute("CSS Class name applied to the control.")>
<System.Web.UI.CssClassPropertyAttribute()>
<WebCategoryAttribute("Appearance")>
<System.ComponentModel.DefaultValueAttribute()>
Public Overridable Property CssClass As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebGridCellTemplateContainer
Dim value As System.String

instance.CssClass = value

value = instance.CssClass
C#
[WebSysDescriptionAttribute("CSS Class name applied to the control.")]
[System.Web.UI.CssClassPropertyAttribute()]
[WebCategoryAttribute("Appearance")]
[System.ComponentModel.DefaultValueAttribute()]
public virtual System.string CssClass {get; set;}
Delphi
public read-write property CssClass: System.String; virtual;
JScript
WebSysDescriptionAttribute("CSS Class name applied to the control.")
System.Web.UI.CssClassPropertyAttribute()
WebCategoryAttribute("Appearance")
System.ComponentModel.DefaultValueAttribute()
public function get,set CssClass : System.String
Managed Extensions for C++
[WebSysDescriptionAttribute("CSS Class name applied to the control.")]
[System.Web.UI.CssClassPropertyAttribute()]
[WebCategoryAttribute("Appearance")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property virtual System.string* get_CssClass();
public: __property virtual void set_CssClass(
   System.string* value
);
C++/CLI
[WebSysDescriptionAttribute("CSS Class name applied to the control.")]
[System.Web.UI.CssClassPropertyAttribute()]
[WebCategoryAttribute("Appearance")]
[System.ComponentModel.DefaultValueAttribute()]
public:
virtual property System.String^ CssClass {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridCellTemplateContainer Class
WebGridCellTemplateContainer Members


WebGridCellTemplateContainer Class Properties

[image]
Intersoft WebGrid Documentation
WebGridCellTemplateContainer Class Properties
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : WebGridCellTemplateContainer Class

Glossary Item Box

For a list of all members of this type, see WebGridCellTemplateContainer members.

Public Properties

 | Name | Description
Public Property | AccessKey | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | BackColor | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | BackImageUrl | (Inherited from System.Web.UI.WebControls.Panel)
Public Property | BorderColor | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | BorderStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | BorderWidth | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | ClientIDMode | (Inherited from System.Web.UI.Control)
Public Property | CssClass | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | DataItem |
Public Property | DataItemIndex |
Public Property | DefaultButton | (Inherited from System.Web.UI.WebControls.Panel)
Public Property | Direction | (Inherited from System.Web.UI.WebControls.Panel)
Public Property | DisplayIndex |
Public Property | Enabled | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | EnableTheming | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | EnableViewState | (Inherited from System.Web.UI.Control)
Public Property | Font | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | ForeColor | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | GroupingText | (Inherited from System.Web.UI.WebControls.Panel)
Public Property | Height | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | HorizontalAlign | (Inherited from System.Web.UI.WebControls.Panel)
Public Property | ID | (Inherited from System.Web.UI.Control)
Public Property | ScrollBars | (Inherited from System.Web.UI.WebControls.Panel)
Public Property | SkinID | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | SupportsDisabledAttribute | (Inherited from System.Web.UI.WebControls.Panel)
Public Property | TabIndex | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | ToolTip | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | ValidateRequestMode | (Inherited from System.Web.UI.Control)
Public Property | ViewStateMode | (Inherited from System.Web.UI.Control)
Public Property | Visible | (Inherited from System.Web.UI.Control)
Public Property | Width | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | Wrap | (Inherited from System.Web.UI.WebControls.Panel)
Top

See Also

Reference

WebGridCellTemplateContainer Class
ISNet.WebUI.WebGrid Namespace


DataItem Property

[image]
Intersoft WebGrid Documentation
DataItem Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridCellTemplateContainer Class : DataItem Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property DataItem As System.Object
Visual Basic (Usage) Copy Code
Dim instance As WebGridCellTemplateContainer
Dim value As System.Object

value = instance.DataItem
C#
public System.object DataItem {get;}
Delphi
public read-only property DataItem: System.TObject;
JScript
public function get DataItem : System.Object
Managed Extensions for C++
public: __property System.Object* get_DataItem();
C++/CLI
public:
property System.Object^ DataItem {
   System.Object^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridCellTemplateContainer Class
WebGridCellTemplateContainer Members


DataItemIndex Property

[image]
Intersoft WebGrid Documentation
DataItemIndex Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridCellTemplateContainer Class : DataItemIndex Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property DataItemIndex As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebGridCellTemplateContainer
Dim value As System.Integer

value = instance.DataItemIndex
C#
public System.int DataItemIndex {get;}
Delphi
public read-only property DataItemIndex: System.Integer;
JScript
public function get DataItemIndex : System.int
Managed Extensions for C++
public: __property System.int get_DataItemIndex();
C++/CLI
public:
property System.int DataItemIndex {
   System.int get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridCellTemplateContainer Class
WebGridCellTemplateContainer Members


DefaultButton Property

[image]
Intersoft WebGrid Documentation
DefaultButton Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridCellTemplateContainer Class : DefaultButton Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<WebSysDescriptionAttribute("The default button for the panel.")>
<System.Web.UI.ThemeableAttribute(False)>
<WebCategoryAttribute("Behavior")>
Public Overridable Property DefaultButton As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebGridCellTemplateContainer
Dim value As System.String

instance.DefaultButton = value

value = instance.DefaultButton
C#
[System.ComponentModel.DefaultValueAttribute()]
[WebSysDescriptionAttribute("The default button for the panel.")]
[System.Web.UI.ThemeableAttribute(false)]
[WebCategoryAttribute("Behavior")]
public virtual System.string DefaultButton {get; set;}
Delphi
public read-write property DefaultButton: System.String; virtual;
JScript
System.ComponentModel.DefaultValueAttribute()
WebSysDescriptionAttribute("The default button for the panel.")
System.Web.UI.ThemeableAttribute()
WebCategoryAttribute("Behavior")
public function get,set DefaultButton : System.String
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[WebSysDescriptionAttribute("The default button for the panel.")]
[System.Web.UI.ThemeableAttribute(false)]
[WebCategoryAttribute("Behavior")]
public: __property virtual System.string* get_DefaultButton();
public: __property virtual void set_DefaultButton(
   System.string* value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[WebSysDescriptionAttribute("The default button for the panel.")]
[System.Web.UI.ThemeableAttribute(false)]
[WebCategoryAttribute("Behavior")]
public:
virtual property System.String^ DefaultButton {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridCellTemplateContainer Class
WebGridCellTemplateContainer Members


Direction Property

[image]
Intersoft WebGrid Documentation
Direction Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridCellTemplateContainer Class : Direction Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<WebCategoryAttribute("Layout")>
<WebSysDescriptionAttribute("The direction of text in the panel.")>
Public Overridable Property Direction As System.Web.UI.WebControls.ContentDirection
Visual Basic (Usage) Copy Code
Dim instance As WebGridCellTemplateContainer
Dim value As System.Web.UI.WebControls.ContentDirection

instance.Direction = value

value = instance.Direction
C#
[System.ComponentModel.DefaultValueAttribute()]
[WebCategoryAttribute("Layout")]
[WebSysDescriptionAttribute("The direction of text in the panel.")]
public virtual System.Web.UI.WebControls.ContentDirection Direction {get; set;}
Delphi
public read-write property Direction: System.Web.UI.WebControls.ContentDirection; virtual;
JScript
System.ComponentModel.DefaultValueAttribute()
WebCategoryAttribute("Layout")
WebSysDescriptionAttribute("The direction of text in the panel.")
public function get,set Direction : System.Web.UI.WebControls.ContentDirection
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[WebCategoryAttribute("Layout")]
[WebSysDescriptionAttribute("The direction of text in the panel.")]
public: __property virtual System.Web.UI.WebControls.ContentDirection get_Direction();
public: __property virtual void set_Direction(
   System.Web.UI.WebControls.ContentDirection value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[WebCategoryAttribute("Layout")]
[WebSysDescriptionAttribute("The direction of text in the panel.")]
public:
virtual property System.Web.UI.WebControls.ContentDirection Direction {
   System.Web.UI.WebControls.ContentDirection get();
   void set (    System.Web.UI.WebControls.ContentDirection value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridCellTemplateContainer Class
WebGridCellTemplateContainer Members


DisplayIndex Property

[image]
Intersoft WebGrid Documentation
DisplayIndex Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridCellTemplateContainer Class : DisplayIndex Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property DisplayIndex As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebGridCellTemplateContainer
Dim value As System.Integer

value = instance.DisplayIndex
C#
public System.int DisplayIndex {get;}
Delphi
public read-only property DisplayIndex: System.Integer;
JScript
public function get DisplayIndex : System.int
Managed Extensions for C++
public: __property System.int get_DisplayIndex();
C++/CLI
public:
property System.int DisplayIndex {
   System.int get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridCellTemplateContainer Class
WebGridCellTemplateContainer Members


Enabled Property

[image]
Intersoft WebGrid Documentation
Enabled Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridCellTemplateContainer Class : Enabled Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
<WebSysDescriptionAttribute("Enabled state of the control.")>
<WebCategoryAttribute("Behavior")>
<System.Web.UI.ThemeableAttribute(False)>
<System.ComponentModel.DefaultValueAttribute()>
Public Overridable Property Enabled As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebGridCellTemplateContainer
Dim value As System.Boolean

instance.Enabled = value

value = instance.Enabled
C#
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[WebSysDescriptionAttribute("Enabled state of the control.")]
[WebCategoryAttribute("Behavior")]
[System.Web.UI.ThemeableAttribute(false)]
[System.ComponentModel.DefaultValueAttribute()]
public virtual System.bool Enabled {get; set;}
Delphi
public read-write property Enabled: System.Boolean; virtual;
JScript
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
WebSysDescriptionAttribute("Enabled state of the control.")
WebCategoryAttribute("Behavior")
System.Web.UI.ThemeableAttribute()
System.ComponentModel.DefaultValueAttribute()
public function get,set Enabled : System.boolean
Managed Extensions for C++
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[WebSysDescriptionAttribute("Enabled state of the control.")]
[WebCategoryAttribute("Behavior")]
[System.Web.UI.ThemeableAttribute(false)]
[System.ComponentModel.DefaultValueAttribute()]
public: __property virtual System.bool get_Enabled();
public: __property virtual void set_Enabled(
   System.bool value
);
C++/CLI
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[WebSysDescriptionAttribute("Enabled state of the control.")]
[WebCategoryAttribute("Behavior")]
[System.Web.UI.ThemeableAttribute(false)]
[System.ComponentModel.DefaultValueAttribute()]
public:
virtual property System.bool Enabled {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridCellTemplateContainer Class
WebGridCellTemplateContainer Members


EnableTheming Property

[image]
Intersoft WebGrid Documentation
EnableTheming Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridCellTemplateContainer Class : EnableTheming Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.BrowsableAttribute(True)>
Public Overridable Property EnableTheming As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebGridCellTemplateContainer
Dim value As System.Boolean

instance.EnableTheming = value

value = instance.EnableTheming
C#
[System.ComponentModel.BrowsableAttribute(true)]
public virtual System.bool EnableTheming {get; set;}
Delphi
public read-write property EnableTheming: System.Boolean; virtual;
JScript
System.ComponentModel.BrowsableAttribute()
public function get,set EnableTheming : System.boolean
Managed Extensions for C++
[System.ComponentModel.BrowsableAttribute(true)]
public: __property virtual System.bool get_EnableTheming();
public: __property virtual void set_EnableTheming(
   System.bool value
);
C++/CLI
[System.ComponentModel.BrowsableAttribute(true)]
public:
virtual property System.bool EnableTheming {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridCellTemplateContainer Class
WebGridCellTemplateContainer Members


EnableViewState Property

[image]
Intersoft WebGrid Documentation
EnableViewState Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridCellTemplateContainer Class : EnableViewState Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<WebCategoryAttribute("Behavior")>
<System.Web.UI.ThemeableAttribute(False)>
<WebSysDescriptionAttribute("Whether the control automatically saves its state for use in round-trips.")>
Public Overridable Property EnableViewState As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebGridCellTemplateContainer
Dim value As System.Boolean

instance.EnableViewState = value

value = instance.EnableViewState
C#
[System.ComponentModel.DefaultValueAttribute()]
[WebCategoryAttribute("Behavior")]
[System.Web.UI.ThemeableAttribute(false)]
[WebSysDescriptionAttribute("Whether the control automatically saves its state for use in round-trips.")]
public virtual System.bool EnableViewState {get; set;}
Delphi
public read-write property EnableViewState: System.Boolean; virtual;
JScript
System.ComponentModel.DefaultValueAttribute()
WebCategoryAttribute("Behavior")
System.Web.UI.ThemeableAttribute()
WebSysDescriptionAttribute("Whether the control automatically saves its state for use in round-trips.")
public function get,set EnableViewState : System.boolean
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[WebCategoryAttribute("Behavior")]
[System.Web.UI.ThemeableAttribute(false)]
[WebSysDescriptionAttribute("Whether the control automatically saves its state for use in round-trips.")]
public: __property virtual System.bool get_EnableViewState();
public: __property virtual void set_EnableViewState(
   System.bool value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[WebCategoryAttribute("Behavior")]
[System.Web.UI.ThemeableAttribute(false)]
[WebSysDescriptionAttribute("Whether the control automatically saves its state for use in round-trips.")]
public:
virtual property System.bool EnableViewState {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridCellTemplateContainer Class
WebGridCellTemplateContainer Members


Font Property

[image]
Intersoft WebGrid Documentation
Font Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridCellTemplateContainer Class : Font Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)>
<WebSysDescriptionAttribute("The font used for text within the control.")>
<WebCategoryAttribute("Appearance")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Overridable ReadOnly Property Font As System.Web.UI.WebControls.FontInfo
Visual Basic (Usage) Copy Code
Dim instance As WebGridCellTemplateContainer
Dim value As System.Web.UI.WebControls.FontInfo

value = instance.Font
C#
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[WebSysDescriptionAttribute("The font used for text within the control.")]
[WebCategoryAttribute("Appearance")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public virtual System.Web.UI.WebControls.FontInfo Font {get;}
Delphi
public read-only property Font: System.Web.UI.WebControls.FontInfo; virtual;
JScript
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)
WebSysDescriptionAttribute("The font used for text within the control.")
WebCategoryAttribute("Appearance")
System.ComponentModel.NotifyParentPropertyAttribute()
public function get Font : System.Web.UI.WebControls.FontInfo
Managed Extensions for C++
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[WebSysDescriptionAttribute("The font used for text within the control.")]
[WebCategoryAttribute("Appearance")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property virtual System.Web.UI.WebControls.FontInfo* get_Font();
C++/CLI
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[WebSysDescriptionAttribute("The font used for text within the control.")]
[WebCategoryAttribute("Appearance")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
virtual property System.Web.UI.WebControls.FontInfo^ Font {
   System.Web.UI.WebControls.FontInfo^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridCellTemplateContainer Class
WebGridCellTemplateContainer Members


ForeColor Property

[image]
Intersoft WebGrid Documentation
ForeColor Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridCellTemplateContainer Class : ForeColor Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.TypeConverterAttribute("System.Web.UI.WebControls.WebColorConverter, System.Web, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")>
<WebCategoryAttribute("Appearance")>
<System.ComponentModel.DefaultValueAttribute()>
<WebSysDescriptionAttribute("Color of the text within the control.")>
Public Overridable Property ForeColor As System.Drawing.Color
Visual Basic (Usage) Copy Code
Dim instance As WebGridCellTemplateContainer
Dim value As System.Drawing.Color

instance.ForeColor = value

value = instance.ForeColor
C#
[System.ComponentModel.TypeConverterAttribute("System.Web.UI.WebControls.WebColorConverter, System.Web, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[WebCategoryAttribute("Appearance")]
[System.ComponentModel.DefaultValueAttribute()]
[WebSysDescriptionAttribute("Color of the text within the control.")]
public virtual System.Drawing.Color ForeColor {get; set;}
Delphi
public read-write property ForeColor: System.Drawing.Color; virtual;
JScript
System.ComponentModel.TypeConverterAttribute("System.Web.UI.WebControls.WebColorConverter, System.Web, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")
WebCategoryAttribute("Appearance")
System.ComponentModel.DefaultValueAttribute()
WebSysDescriptionAttribute("Color of the text within the control.")
public function get,set ForeColor : System.Drawing.Color
Managed Extensions for C++
[System.ComponentModel.TypeConverterAttribute("System.Web.UI.WebControls.WebColorConverter, System.Web, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[WebCategoryAttribute("Appearance")]
[System.ComponentModel.DefaultValueAttribute()]
[WebSysDescriptionAttribute("Color of the text within the control.")]
public: __property virtual System.Drawing.Color get_ForeColor();
public: __property virtual void set_ForeColor(
   System.Drawing.Color value
);
C++/CLI
[System.ComponentModel.TypeConverterAttribute("System.Web.UI.WebControls.WebColorConverter, System.Web, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[WebCategoryAttribute("Appearance")]
[System.ComponentModel.DefaultValueAttribute()]
[WebSysDescriptionAttribute("Color of the text within the control.")]
public:
virtual property System.Drawing.Color ForeColor {
   System.Drawing.Color get();
   void set (    System.Drawing.Color value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridCellTemplateContainer Class
WebGridCellTemplateContainer Members


GroupingText Property

[image]
Intersoft WebGrid Documentation
GroupingText Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridCellTemplateContainer Class : GroupingText Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.LocalizableAttribute(True)>
<WebCategoryAttribute("Appearance")>
<WebSysDescriptionAttribute("The text of group box around this control's contents.")>
<System.ComponentModel.DefaultValueAttribute()>
Public Overridable Property GroupingText As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebGridCellTemplateContainer
Dim value As System.String

instance.GroupingText = value

value = instance.GroupingText
C#
[System.ComponentModel.LocalizableAttribute(true)]
[WebCategoryAttribute("Appearance")]
[WebSysDescriptionAttribute("The text of group box around this control's contents.")]
[System.ComponentModel.DefaultValueAttribute()]
public virtual System.string GroupingText {get; set;}
Delphi
public read-write property GroupingText: System.String; virtual;
JScript
System.ComponentModel.LocalizableAttribute()
WebCategoryAttribute("Appearance")
WebSysDescriptionAttribute("The text of group box around this control's contents.")
System.ComponentModel.DefaultValueAttribute()
public function get,set GroupingText : System.String
Managed Extensions for C++
[System.ComponentModel.LocalizableAttribute(true)]
[WebCategoryAttribute("Appearance")]
[WebSysDescriptionAttribute("The text of group box around this control's contents.")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property virtual System.string* get_GroupingText();
public: __property virtual void set_GroupingText(
   System.string* value
);
C++/CLI
[System.ComponentModel.LocalizableAttribute(true)]
[WebCategoryAttribute("Appearance")]
[WebSysDescriptionAttribute("The text of group box around this control's contents.")]
[System.ComponentModel.DefaultValueAttribute()]
public:
virtual property System.String^ GroupingText {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridCellTemplateContainer Class
WebGridCellTemplateContainer Members


Height Property

[image]
Intersoft WebGrid Documentation
Height Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridCellTemplateContainer Class : Height Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<WebCategoryAttribute("Layout")>
<WebSysDescriptionAttribute("The height of the control.")>
<System.ComponentModel.DefaultValueAttribute()>
Public Overridable Property Height As System.Web.UI.WebControls.Unit
Visual Basic (Usage) Copy Code
Dim instance As WebGridCellTemplateContainer
Dim value As System.Web.UI.WebControls.Unit

instance.Height = value

value = instance.Height
C#
[WebCategoryAttribute("Layout")]
[WebSysDescriptionAttribute("The height of the control.")]
[System.ComponentModel.DefaultValueAttribute()]
public virtual System.Web.UI.WebControls.Unit Height {get; set;}
Delphi
public read-write property Height: System.Web.UI.WebControls.Unit; virtual;
JScript
WebCategoryAttribute("Layout")
WebSysDescriptionAttribute("The height of the control.")
System.ComponentModel.DefaultValueAttribute()
public function get,set Height : System.Web.UI.WebControls.Unit
Managed Extensions for C++
[WebCategoryAttribute("Layout")]
[WebSysDescriptionAttribute("The height of the control.")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property virtual System.Web.UI.WebControls.Unit get_Height();
public: __property virtual void set_Height(
   System.Web.UI.WebControls.Unit value
);
C++/CLI
[WebCategoryAttribute("Layout")]
[WebSysDescriptionAttribute("The height of the control.")]
[System.ComponentModel.DefaultValueAttribute()]
public:
virtual property System.Web.UI.WebControls.Unit Height {
   System.Web.UI.WebControls.Unit get();
   void set (    System.Web.UI.WebControls.Unit value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridCellTemplateContainer Class
WebGridCellTemplateContainer Members


HorizontalAlign Property

[image]
Intersoft WebGrid Documentation
HorizontalAlign Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridCellTemplateContainer Class : HorizontalAlign Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<WebCategoryAttribute("Layout")>
<WebSysDescriptionAttribute("The horizontal alignment of the content.")>
Public Overridable Property HorizontalAlign As System.Web.UI.WebControls.HorizontalAlign
Visual Basic (Usage) Copy Code
Dim instance As WebGridCellTemplateContainer
Dim value As System.Web.UI.WebControls.HorizontalAlign

instance.HorizontalAlign = value

value = instance.HorizontalAlign
C#
[System.ComponentModel.DefaultValueAttribute()]
[WebCategoryAttribute("Layout")]
[WebSysDescriptionAttribute("The horizontal alignment of the content.")]
public virtual System.Web.UI.WebControls.HorizontalAlign HorizontalAlign {get; set;}
Delphi
public read-write property HorizontalAlign: System.Web.UI.WebControls.HorizontalAlign; virtual;
JScript
System.ComponentModel.DefaultValueAttribute()
WebCategoryAttribute("Layout")
WebSysDescriptionAttribute("The horizontal alignment of the content.")
public function get,set HorizontalAlign : System.Web.UI.WebControls.HorizontalAlign
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[WebCategoryAttribute("Layout")]
[WebSysDescriptionAttribute("The horizontal alignment of the content.")]
public: __property virtual System.Web.UI.WebControls.HorizontalAlign get_HorizontalAlign();
public: __property virtual void set_HorizontalAlign(
   System.Web.UI.WebControls.HorizontalAlign value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[WebCategoryAttribute("Layout")]
[WebSysDescriptionAttribute("The horizontal alignment of the content.")]
public:
virtual property System.Web.UI.WebControls.HorizontalAlign HorizontalAlign {
   System.Web.UI.WebControls.HorizontalAlign get();
   void set (    System.Web.UI.WebControls.HorizontalAlign value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridCellTemplateContainer Class
WebGridCellTemplateContainer Members


ID Property

[image]
Intersoft WebGrid Documentation
ID Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridCellTemplateContainer Class : ID Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Web.UI.FilterableAttribute(False)>
<System.ComponentModel.ParenthesizePropertyNameAttribute(True)>
<System.ComponentModel.MergablePropertyAttribute(False)>
<System.Web.UI.ThemeableAttribute(False)>
<WebSysDescriptionAttribute("Programmatic name of the control.")>
Public Overridable Property ID As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebGridCellTemplateContainer
Dim value As System.String

instance.ID = value

value = instance.ID
C#
[System.Web.UI.FilterableAttribute(false)]
[System.ComponentModel.ParenthesizePropertyNameAttribute(true)]
[System.ComponentModel.MergablePropertyAttribute(false)]
[System.Web.UI.ThemeableAttribute(false)]
[WebSysDescriptionAttribute("Programmatic name of the control.")]
public virtual System.string ID {get; set;}
Delphi
public read-write property ID: System.String; virtual;
JScript
System.Web.UI.FilterableAttribute()
System.ComponentModel.ParenthesizePropertyNameAttribute()
System.ComponentModel.MergablePropertyAttribute()
System.Web.UI.ThemeableAttribute()
WebSysDescriptionAttribute("Programmatic name of the control.")
public function get,set ID : System.String
Managed Extensions for C++
[System.Web.UI.FilterableAttribute(false)]
[System.ComponentModel.ParenthesizePropertyNameAttribute(true)]
[System.ComponentModel.MergablePropertyAttribute(false)]
[System.Web.UI.ThemeableAttribute(false)]
[WebSysDescriptionAttribute("Programmatic name of the control.")]
public: __property virtual System.string* get_ID();
public: __property virtual void set_ID(
   System.string* value
);
C++/CLI
[System.Web.UI.FilterableAttribute(false)]
[System.ComponentModel.ParenthesizePropertyNameAttribute(true)]
[System.ComponentModel.MergablePropertyAttribute(false)]
[System.Web.UI.ThemeableAttribute(false)]
[WebSysDescriptionAttribute("Programmatic name of the control.")]
public:
virtual property System.String^ ID {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridCellTemplateContainer Class
WebGridCellTemplateContainer Members


ScrollBars Property

[image]
Intersoft WebGrid Documentation
ScrollBars Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridCellTemplateContainer Class : ScrollBars Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<WebCategoryAttribute("Layout")>
<WebSysDescriptionAttribute("The appearance of scrollbars for the panel.")>
<System.ComponentModel.DefaultValueAttribute()>
Public Overridable Property ScrollBars As System.Web.UI.WebControls.ScrollBars
Visual Basic (Usage) Copy Code
Dim instance As WebGridCellTemplateContainer
Dim value As System.Web.UI.WebControls.ScrollBars

instance.ScrollBars = value

value = instance.ScrollBars
C#
[WebCategoryAttribute("Layout")]
[WebSysDescriptionAttribute("The appearance of scrollbars for the panel.")]
[System.ComponentModel.DefaultValueAttribute()]
public virtual System.Web.UI.WebControls.ScrollBars ScrollBars {get; set;}
Delphi
public read-write property ScrollBars: System.Web.UI.WebControls.ScrollBars; virtual;
JScript
WebCategoryAttribute("Layout")
WebSysDescriptionAttribute("The appearance of scrollbars for the panel.")
System.ComponentModel.DefaultValueAttribute()
public function get,set ScrollBars : System.Web.UI.WebControls.ScrollBars
Managed Extensions for C++
[WebCategoryAttribute("Layout")]
[WebSysDescriptionAttribute("The appearance of scrollbars for the panel.")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property virtual System.Web.UI.WebControls.ScrollBars get_ScrollBars();
public: __property virtual void set_ScrollBars(
   System.Web.UI.WebControls.ScrollBars value
);
C++/CLI
[WebCategoryAttribute("Layout")]
[WebSysDescriptionAttribute("The appearance of scrollbars for the panel.")]
[System.ComponentModel.DefaultValueAttribute()]
public:
virtual property System.Web.UI.WebControls.ScrollBars ScrollBars {
   System.Web.UI.WebControls.ScrollBars get();
   void set (    System.Web.UI.WebControls.ScrollBars value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridCellTemplateContainer Class
WebGridCellTemplateContainer Members


SkinID Property

[image]
Intersoft WebGrid Documentation
SkinID Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridCellTemplateContainer Class : SkinID Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.BrowsableAttribute(True)>
Public Overridable Property SkinID As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebGridCellTemplateContainer
Dim value As System.String

instance.SkinID = value

value = instance.SkinID
C#
[System.ComponentModel.BrowsableAttribute(true)]
public virtual System.string SkinID {get; set;}
Delphi
public read-write property SkinID: System.String; virtual;
JScript
System.ComponentModel.BrowsableAttribute()
public function get,set SkinID : System.String
Managed Extensions for C++
[System.ComponentModel.BrowsableAttribute(true)]
public: __property virtual System.string* get_SkinID();
public: __property virtual void set_SkinID(
   System.string* value
);
C++/CLI
[System.ComponentModel.BrowsableAttribute(true)]
public:
virtual property System.String^ SkinID {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridCellTemplateContainer Class
WebGridCellTemplateContainer Members


SupportsDisabledAttribute Property

[image]
Intersoft WebGrid Documentation
SupportsDisabledAttribute Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridCellTemplateContainer Class : SupportsDisabledAttribute Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property SupportsDisabledAttribute As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebGridCellTemplateContainer
Dim value As System.Boolean

value = instance.SupportsDisabledAttribute
C#
public virtual System.bool SupportsDisabledAttribute {get;}
Delphi
public read-only property SupportsDisabledAttribute: System.Boolean; virtual;
JScript
public function get SupportsDisabledAttribute : System.boolean
Managed Extensions for C++
public: __property virtual System.bool get_SupportsDisabledAttribute();
C++/CLI
public:
virtual property System.bool SupportsDisabledAttribute {
   System.bool get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridCellTemplateContainer Class
WebGridCellTemplateContainer Members


TabIndex Property

[image]
Intersoft WebGrid Documentation
TabIndex Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridCellTemplateContainer Class : TabIndex Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<WebSysDescriptionAttribute("The tab order of the control.")>
<WebCategoryAttribute("Accessibility")>
Public Overridable Property TabIndex As System.Short
Visual Basic (Usage) Copy Code
Dim instance As WebGridCellTemplateContainer
Dim value As System.Short

instance.TabIndex = value

value = instance.TabIndex
C#
[System.ComponentModel.DefaultValueAttribute()]
[WebSysDescriptionAttribute("The tab order of the control.")]
[WebCategoryAttribute("Accessibility")]
public virtual System.short TabIndex {get; set;}
Delphi
public read-write property TabIndex: System.Int16; virtual;
JScript
System.ComponentModel.DefaultValueAttribute()
WebSysDescriptionAttribute("The tab order of the control.")
WebCategoryAttribute("Accessibility")
public function get,set TabIndex : System.short
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[WebSysDescriptionAttribute("The tab order of the control.")]
[WebCategoryAttribute("Accessibility")]
public: __property virtual System.short get_TabIndex();
public: __property virtual void set_TabIndex(
   System.short value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[WebSysDescriptionAttribute("The tab order of the control.")]
[WebCategoryAttribute("Accessibility")]
public:
virtual property System.short TabIndex {
   System.short get();
   void set (    System.short value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridCellTemplateContainer Class
WebGridCellTemplateContainer Members


ToolTip Property

[image]
Intersoft WebGrid Documentation
ToolTip Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridCellTemplateContainer Class : ToolTip Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.LocalizableAttribute(True)>
<WebCategoryAttribute("Behavior")>
<WebSysDescriptionAttribute("The tooltip displayed when the mouse is over the control.")>
<System.ComponentModel.DefaultValueAttribute()>
Public Overridable Property ToolTip As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebGridCellTemplateContainer
Dim value As System.String

instance.ToolTip = value

value = instance.ToolTip
C#
[System.ComponentModel.LocalizableAttribute(true)]
[WebCategoryAttribute("Behavior")]
[WebSysDescriptionAttribute("The tooltip displayed when the mouse is over the control.")]
[System.ComponentModel.DefaultValueAttribute()]
public virtual System.string ToolTip {get; set;}
Delphi
public read-write property ToolTip: System.String; virtual;
JScript
System.ComponentModel.LocalizableAttribute()
WebCategoryAttribute("Behavior")
WebSysDescriptionAttribute("The tooltip displayed when the mouse is over the control.")
System.ComponentModel.DefaultValueAttribute()
public function get,set ToolTip : System.String
Managed Extensions for C++
[System.ComponentModel.LocalizableAttribute(true)]
[WebCategoryAttribute("Behavior")]
[WebSysDescriptionAttribute("The tooltip displayed when the mouse is over the control.")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property virtual System.string* get_ToolTip();
public: __property virtual void set_ToolTip(
   System.string* value
);
C++/CLI
[System.ComponentModel.LocalizableAttribute(true)]
[WebCategoryAttribute("Behavior")]
[WebSysDescriptionAttribute("The tooltip displayed when the mouse is over the control.")]
[System.ComponentModel.DefaultValueAttribute()]
public:
virtual property System.String^ ToolTip {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridCellTemplateContainer Class
WebGridCellTemplateContainer Members


ValidateRequestMode Property

[image]
Intersoft WebGrid Documentation
ValidateRequestMode Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridCellTemplateContainer Class : ValidateRequestMode Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<WebSysDescriptionAttribute("Determines whether the control validates client input or not. Defaults to inherit from parent.")>
<WebCategoryAttribute("Behavior")>
Public Overridable Property ValidateRequestMode As System.Web.UI.ValidateRequestMode
Visual Basic (Usage) Copy Code
Dim instance As WebGridCellTemplateContainer
Dim value As System.Web.UI.ValidateRequestMode

instance.ValidateRequestMode = value

value = instance.ValidateRequestMode
C#
[System.ComponentModel.DefaultValueAttribute()]
[WebSysDescriptionAttribute("Determines whether the control validates client input or not. Defaults to inherit from parent.")]
[WebCategoryAttribute("Behavior")]
public virtual System.Web.UI.ValidateRequestMode ValidateRequestMode {get; set;}
Delphi
public read-write property ValidateRequestMode: System.Web.UI.ValidateRequestMode; virtual;
JScript
System.ComponentModel.DefaultValueAttribute()
WebSysDescriptionAttribute("Determines whether the control validates client input or not. Defaults to inherit from parent.")
WebCategoryAttribute("Behavior")
public function get,set ValidateRequestMode : System.Web.UI.ValidateRequestMode
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[WebSysDescriptionAttribute("Determines whether the control validates client input or not. Defaults to inherit from parent.")]
[WebCategoryAttribute("Behavior")]
public: __property virtual System.Web.UI.ValidateRequestMode get_ValidateRequestMode();
public: __property virtual void set_ValidateRequestMode(
   System.Web.UI.ValidateRequestMode value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[WebSysDescriptionAttribute("Determines whether the control validates client input or not. Defaults to inherit from parent.")]
[WebCategoryAttribute("Behavior")]
public:
virtual property System.Web.UI.ValidateRequestMode ValidateRequestMode {
   System.Web.UI.ValidateRequestMode get();
   void set (    System.Web.UI.ValidateRequestMode value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridCellTemplateContainer Class
WebGridCellTemplateContainer Members


ViewStateMode Property

[image]
Intersoft WebGrid Documentation
ViewStateMode Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridCellTemplateContainer Class : ViewStateMode Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Web.UI.ThemeableAttribute(False)>
<System.ComponentModel.DefaultValueAttribute()>
<WebSysDescriptionAttribute("Determines whether the control has viewstate enabled or not, defaults to inherit from parent.")>
<WebCategoryAttribute("Behavior")>
Public Overridable Property ViewStateMode As System.Web.UI.ViewStateMode
Visual Basic (Usage) Copy Code
Dim instance As WebGridCellTemplateContainer
Dim value As System.Web.UI.ViewStateMode

instance.ViewStateMode = value

value = instance.ViewStateMode
C#
[System.Web.UI.ThemeableAttribute(false)]
[System.ComponentModel.DefaultValueAttribute()]
[WebSysDescriptionAttribute("Determines whether the control has viewstate enabled or not, defaults to inherit from parent.")]
[WebCategoryAttribute("Behavior")]
public virtual System.Web.UI.ViewStateMode ViewStateMode {get; set;}
Delphi
public read-write property ViewStateMode: System.Web.UI.ViewStateMode; virtual;
JScript
System.Web.UI.ThemeableAttribute()
System.ComponentModel.DefaultValueAttribute()
WebSysDescriptionAttribute("Determines whether the control has viewstate enabled or not, defaults to inherit from parent.")
WebCategoryAttribute("Behavior")
public function get,set ViewStateMode : System.Web.UI.ViewStateMode
Managed Extensions for C++
[System.Web.UI.ThemeableAttribute(false)]
[System.ComponentModel.DefaultValueAttribute()]
[WebSysDescriptionAttribute("Determines whether the control has viewstate enabled or not, defaults to inherit from parent.")]
[WebCategoryAttribute("Behavior")]
public: __property virtual System.Web.UI.ViewStateMode get_ViewStateMode();
public: __property virtual void set_ViewStateMode(
   System.Web.UI.ViewStateMode value
);
C++/CLI
[System.Web.UI.ThemeableAttribute(false)]
[System.ComponentModel.DefaultValueAttribute()]
[WebSysDescriptionAttribute("Determines whether the control has viewstate enabled or not, defaults to inherit from parent.")]
[WebCategoryAttribute("Behavior")]
public:
virtual property System.Web.UI.ViewStateMode ViewStateMode {
   System.Web.UI.ViewStateMode get();
   void set (    System.Web.UI.ViewStateMode value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridCellTemplateContainer Class
WebGridCellTemplateContainer Members


Visible Property

[image]
Intersoft WebGrid Documentation
Visible Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridCellTemplateContainer Class : Visible Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<WebCategoryAttribute("Behavior")>
<WebSysDescriptionAttribute("Indicates whether the control is visible and rendered.")>
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
<System.ComponentModel.DefaultValueAttribute()>
Public Overridable Property Visible As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebGridCellTemplateContainer
Dim value As System.Boolean

instance.Visible = value

value = instance.Visible
C#
[WebCategoryAttribute("Behavior")]
[WebSysDescriptionAttribute("Indicates whether the control is visible and rendered.")]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.DefaultValueAttribute()]
public virtual System.bool Visible {get; set;}
Delphi
public read-write property Visible: System.Boolean; virtual;
JScript
WebCategoryAttribute("Behavior")
WebSysDescriptionAttribute("Indicates whether the control is visible and rendered.")
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
System.ComponentModel.DefaultValueAttribute()
public function get,set Visible : System.boolean
Managed Extensions for C++
[WebCategoryAttribute("Behavior")]
[WebSysDescriptionAttribute("Indicates whether the control is visible and rendered.")]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.DefaultValueAttribute()]
public: __property virtual System.bool get_Visible();
public: __property virtual void set_Visible(
   System.bool value
);
C++/CLI
[WebCategoryAttribute("Behavior")]
[WebSysDescriptionAttribute("Indicates whether the control is visible and rendered.")]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.DefaultValueAttribute()]
public:
virtual property System.bool Visible {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridCellTemplateContainer Class
WebGridCellTemplateContainer Members


Width Property

[image]
Intersoft WebGrid Documentation
Width Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridCellTemplateContainer Class : Width Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<WebSysDescriptionAttribute("The width of the control.")>
<WebCategoryAttribute("Layout")>
<System.ComponentModel.DefaultValueAttribute()>
Public Overridable Property Width As System.Web.UI.WebControls.Unit
Visual Basic (Usage) Copy Code
Dim instance As WebGridCellTemplateContainer
Dim value As System.Web.UI.WebControls.Unit

instance.Width = value

value = instance.Width
C#
[WebSysDescriptionAttribute("The width of the control.")]
[WebCategoryAttribute("Layout")]
[System.ComponentModel.DefaultValueAttribute()]
public virtual System.Web.UI.WebControls.Unit Width {get; set;}
Delphi
public read-write property Width: System.Web.UI.WebControls.Unit; virtual;
JScript
WebSysDescriptionAttribute("The width of the control.")
WebCategoryAttribute("Layout")
System.ComponentModel.DefaultValueAttribute()
public function get,set Width : System.Web.UI.WebControls.Unit
Managed Extensions for C++
[WebSysDescriptionAttribute("The width of the control.")]
[WebCategoryAttribute("Layout")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property virtual System.Web.UI.WebControls.Unit get_Width();
public: __property virtual void set_Width(
   System.Web.UI.WebControls.Unit value
);
C++/CLI
[WebSysDescriptionAttribute("The width of the control.")]
[WebCategoryAttribute("Layout")]
[System.ComponentModel.DefaultValueAttribute()]
public:
virtual property System.Web.UI.WebControls.Unit Width {
   System.Web.UI.WebControls.Unit get();
   void set (    System.Web.UI.WebControls.Unit value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridCellTemplateContainer Class
WebGridCellTemplateContainer Members


Wrap Property

[image]
Intersoft WebGrid Documentation
Wrap Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridCellTemplateContainer Class : Wrap Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<WebSysDescriptionAttribute("Whether the content should wrap or not.")>
<WebCategoryAttribute("Layout")>
Public Overridable Property Wrap As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebGridCellTemplateContainer
Dim value As System.Boolean

instance.Wrap = value

value = instance.Wrap
C#
[System.ComponentModel.DefaultValueAttribute()]
[WebSysDescriptionAttribute("Whether the content should wrap or not.")]
[WebCategoryAttribute("Layout")]
public virtual System.bool Wrap {get; set;}
Delphi
public read-write property Wrap: System.Boolean; virtual;
JScript
System.ComponentModel.DefaultValueAttribute()
WebSysDescriptionAttribute("Whether the content should wrap or not.")
WebCategoryAttribute("Layout")
public function get,set Wrap : System.boolean
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[WebSysDescriptionAttribute("Whether the content should wrap or not.")]
[WebCategoryAttribute("Layout")]
public: __property virtual System.bool get_Wrap();
public: __property virtual void set_Wrap(
   System.bool value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[WebSysDescriptionAttribute("Whether the content should wrap or not.")]
[WebCategoryAttribute("Layout")]
public:
virtual property System.bool Wrap {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridCellTemplateContainer Class
WebGridCellTemplateContainer Members


DataBinding Event

[image]
Intersoft WebGrid Documentation
DataBinding Event
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridCellTemplateContainer Class : DataBinding Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<WebSysDescriptionAttribute("Fires when the control's data binding expressions are to be evaluated.")>
<WebCategoryAttribute("Data")>
Public Event DataBinding As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebGridCellTemplateContainer
Dim handler As System.EventHandler

AddHandler instance.DataBinding, handler
C#
[WebSysDescriptionAttribute("Fires when the control's data binding expressions are to be evaluated.")]
[WebCategoryAttribute("Data")]
public event System.EventHandler DataBinding
Delphi
public event DataBinding: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[WebSysDescriptionAttribute("Fires when the control's data binding expressions are to be evaluated.")]
[WebCategoryAttribute("Data")]
public: __event System.EventHandler* DataBinding
C++/CLI
[WebSysDescriptionAttribute("Fires when the control's data binding expressions are to be evaluated.")]
[WebCategoryAttribute("Data")]
public:
event System.EventHandler^ DataBinding

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridCellTemplateContainer Class
WebGridCellTemplateContainer Members


Disposed Event

[image]
Intersoft WebGrid Documentation
Disposed Event
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridCellTemplateContainer Class : Disposed Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<WebSysDescriptionAttribute("Fires when the control has been disposed.")>
Public Event Disposed As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebGridCellTemplateContainer
Dim handler As System.EventHandler

AddHandler instance.Disposed, handler
C#
[WebSysDescriptionAttribute("Fires when the control has been disposed.")]
public event System.EventHandler Disposed
Delphi
public event Disposed: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[WebSysDescriptionAttribute("Fires when the control has been disposed.")]
public: __event System.EventHandler* Disposed
C++/CLI
[WebSysDescriptionAttribute("Fires when the control has been disposed.")]
public:
event System.EventHandler^ Disposed

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridCellTemplateContainer Class
WebGridCellTemplateContainer Members


Init Event

[image]
Intersoft WebGrid Documentation
Init Event
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridCellTemplateContainer Class : Init Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<WebSysDescriptionAttribute("Fires when the page has been initialized.")>
Public Event Init As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebGridCellTemplateContainer
Dim handler As System.EventHandler

AddHandler instance.Init, handler
C#
[WebSysDescriptionAttribute("Fires when the page has been initialized.")]
public event System.EventHandler Init
Delphi
public event Init: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[WebSysDescriptionAttribute("Fires when the page has been initialized.")]
public: __event System.EventHandler* Init
C++/CLI
[WebSysDescriptionAttribute("Fires when the page has been initialized.")]
public:
event System.EventHandler^ Init

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridCellTemplateContainer Class
WebGridCellTemplateContainer Members


Load Event

[image]
Intersoft WebGrid Documentation
Load Event
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridCellTemplateContainer Class : Load Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<WebSysDescriptionAttribute("Fires when the page has been loaded.")>
Public Event Load As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebGridCellTemplateContainer
Dim handler As System.EventHandler

AddHandler instance.Load, handler
C#
[WebSysDescriptionAttribute("Fires when the page has been loaded.")]
public event System.EventHandler Load
Delphi
public event Load: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[WebSysDescriptionAttribute("Fires when the page has been loaded.")]
public: __event System.EventHandler* Load
C++/CLI
[WebSysDescriptionAttribute("Fires when the page has been loaded.")]
public:
event System.EventHandler^ Load

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridCellTemplateContainer Class
WebGridCellTemplateContainer Members


PreRender Event

[image]
Intersoft WebGrid Documentation
PreRender Event
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridCellTemplateContainer Class : PreRender Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<WebSysDescriptionAttribute("Fires before the page is rendered.")>
Public Event PreRender As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebGridCellTemplateContainer
Dim handler As System.EventHandler

AddHandler instance.PreRender, handler
C#
[WebSysDescriptionAttribute("Fires before the page is rendered.")]
public event System.EventHandler PreRender
Delphi
public event PreRender: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[WebSysDescriptionAttribute("Fires before the page is rendered.")]
public: __event System.EventHandler* PreRender
C++/CLI
[WebSysDescriptionAttribute("Fires before the page is rendered.")]
public:
event System.EventHandler^ PreRender

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridCellTemplateContainer Class
WebGridCellTemplateContainer Members


Unload Event

[image]
Intersoft WebGrid Documentation
Unload Event
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridCellTemplateContainer Class : Unload Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<WebSysDescriptionAttribute("Fires when the page is unloaded.")>
Public Event Unload As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebGridCellTemplateContainer
Dim handler As System.EventHandler

AddHandler instance.Unload, handler
C#
[WebSysDescriptionAttribute("Fires when the page is unloaded.")]
public event System.EventHandler Unload
Delphi
public event Unload: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[WebSysDescriptionAttribute("Fires when the page is unloaded.")]
public: __event System.EventHandler* Unload
C++/CLI
[WebSysDescriptionAttribute("Fires when the page is unloaded.")]
public:
event System.EventHandler^ Unload

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridCellTemplateContainer Class
WebGridCellTemplateContainer Members


WebGridClientBindingSettings Class

[image]
Intersoft WebGrid Documentation
WebGridClientBindingSettings Class
Members See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : WebGridClientBindingSettings Class

Glossary Item Box

Object Model

WebGridClientBindingSettings Class

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute()>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.SerializableAttribute()>
Public Class WebGridClientBindingSettings
   Inherits ISNet.WebUI.ClientBindingSettings
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Visual Basic (Usage) Copy Code
Dim instance As WebGridClientBindingSettings
C#
[System.ComponentModel.DescriptionAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public class WebGridClientBindingSettings : ISNet.WebUI.ClientBindingSettings, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Delphi
public class WebGridClientBindingSettings = class(ISNet.WebUI.ClientBindingSettings, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize)
JScript
System.ComponentModel.DescriptionAttribute()
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.SerializableAttribute()
public class WebGridClientBindingSettings extends ISNet.WebUI.ClientBindingSettings implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public __gc class WebGridClientBindingSettings : public ISNet.WebUI.ClientBindingSettings, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
C++/CLI
[System.ComponentModel.DescriptionAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public ref class WebGridClientBindingSettings : public ISNet.WebUI.ClientBindingSettings, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.ClientBindingSettings
ISNet.WebUI.WebGrid.WebGridClientBindingSettings

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridClientBindingSettings Members
ISNet.WebUI.WebGrid Namespace


WebGridClientBindingSettings Class Members

[image]
Intersoft WebGrid Documentation
WebGridClientBindingSettings Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebGrid Namespace : WebGridClientBindingSettings Class

Glossary Item Box

The following tables list the members exposed by WebGridClientBindingSettings.

Public Constructors

 | Name | Description
Public Constructor | WebGridClientBindingSettings Constructor |
Top

Public Properties

 | Name | Description
Public Property | DataLoadMode | (Inherited from ISNet.WebUI.ClientBindingSettings)
Public Property | DataSourceType | (Inherited from ISNet.WebUI.ClientBindingSettings)
Public Property | EnableGroupRowPaging |
Public Property | FetchDataOnPageLoad | (Inherited from ISNet.WebUI.ClientBindingSettings)
Public Property | GroupRowPageSize |
Public Property | ItemTypeName | (Inherited from ISNet.WebUI.ClientBindingSettings)
Public Property | PreloadGroupTotals |
Public Property | ServiceEvents | (Inherited from ISNet.WebUI.ClientBindingSettings)
Public Property | ServiceMethods | (Inherited from ISNet.WebUI.ClientBindingSettings)
Public Property | ServiceUrl | (Inherited from ISNet.WebUI.ClientBindingSettings)
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebGridClientBindingSettings Class
ISNet.WebUI.WebGrid Namespace


WebGridClientBindingSettings Constructor

[image]
Intersoft WebGrid Documentation
WebGridClientBindingSettings Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridClientBindingSettings Class : WebGridClientBindingSettings Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebGridClientBindingSettings()
C#
public WebGridClientBindingSettings()
Delphi
public WebGridClientBindingSettings();
JScript
public function WebGridClientBindingSettings();
Managed Extensions for C++
public: WebGridClientBindingSettings();
C++/CLI
public:
WebGridClientBindingSettings();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridClientBindingSettings Class
WebGridClientBindingSettings Members


Clone Method

[image]
Intersoft WebGrid Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridClientBindingSettings Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As System.Object
Visual Basic (Usage) Copy Code
Dim instance As WebGridClientBindingSettings
Dim value As System.Object

value = instance.Clone()
C#
public virtual System.object Clone()
Delphi
public function Clone(): System.TObject; virtual;
JScript
public function Clone() : System.Object;
Managed Extensions for C++
public: virtual System.Object* Clone();
C++/CLI
public:
virtual System.Object^ Clone();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridClientBindingSettings Class
WebGridClientBindingSettings Members


CopyFrom Method

[image]
Intersoft WebGrid Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridClientBindingSettings Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridClientBindingSettings Class
WebGridClientBindingSettings Members


CopyFrom(Object) Method

[image]
Intersoft WebGrid Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridClientBindingSettings Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebGridClientBindingSettings
Dim objSource As System.Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   System.object objSource
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridClientBindingSettings Class
WebGridClientBindingSettings Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebGrid Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridClientBindingSettings Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object, _
   ByVal cloneSourceValue As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebGridClientBindingSettings
Dim objSource As System.Object
Dim cloneSourceValue As System.Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   System.object objSource,
   System.bool cloneSourceValue
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject;
    cloneSourceValue: System.Boolean
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object,
   cloneSourceValue : System.boolean
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource,
   System.bool cloneSourceValue
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource,
   System.bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridClientBindingSettings Class
WebGridClientBindingSettings Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebGrid Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridClientBindingSettings Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebGridClientBindingSettings
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure DeSerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function DeSerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void DeSerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void DeSerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridClientBindingSettings Class
WebGridClientBindingSettings Members


GetHashCode Method

[image]
Intersoft WebGrid Documentation
GetHashCode Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridClientBindingSettings Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebGridClientBindingSettings
Dim value As System.Integer

value = instance.GetHashCode()
C#
public virtual System.int GetHashCode()
Delphi
public function GetHashCode(): System.Integer; virtual;
JScript
public function GetHashCode() : System.int;
Managed Extensions for C++
public: virtual System.int GetHashCode();
C++/CLI
public:
virtual System.int GetHashCode();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridClientBindingSettings Class
WebGridClientBindingSettings Members


WebGridClientBindingSettings Class Methods

[image]
Intersoft WebGrid Documentation
WebGridClientBindingSettings Class Methods
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : WebGridClientBindingSettings Class

Glossary Item Box

For a list of all members of this type, see WebGridClientBindingSettings members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebGridClientBindingSettings Class
ISNet.WebUI.WebGrid Namespace


GetObjectData Method

[image]
Intersoft WebGrid Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridClientBindingSettings Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebGridClientBindingSettings
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure GetObjectData(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
); override;
JScript
public override function GetObjectData(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void GetObjectData(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
) override
C++/CLI
public:
void GetObjectData(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
) override

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridClientBindingSettings Class
WebGridClientBindingSettings Members


IsEmpty Method

[image]
Intersoft WebGrid Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridClientBindingSettings Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebGridClientBindingSettings
Dim value As System.Boolean

value = instance.IsEmpty()
C#
public virtual System.bool IsEmpty()
Delphi
public function IsEmpty(): System.Boolean; virtual;
JScript
public function IsEmpty() : System.boolean;
Managed Extensions for C++
public: virtual System.bool IsEmpty();
C++/CLI
public:
virtual System.bool IsEmpty();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridClientBindingSettings Class
WebGridClientBindingSettings Members


Reset Method

[image]
Intersoft WebGrid Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridClientBindingSettings Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As WebGridClientBindingSettings

instance.Reset()
C#
public virtual void Reset()
Delphi
public procedure Reset(); virtual;
JScript
public function Reset();
Managed Extensions for C++
public: virtual void Reset();
C++/CLI
public:
virtual void Reset();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridClientBindingSettings Class
WebGridClientBindingSettings Members


SerializeObjectData Method

[image]
Intersoft WebGrid Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridClientBindingSettings Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebGridClientBindingSettings
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure SerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function SerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void SerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void SerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridClientBindingSettings Class
WebGridClientBindingSettings Members


ToString Method

[image]
Intersoft WebGrid Documentation
ToString Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridClientBindingSettings Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebGridClientBindingSettings
Dim value As System.String

value = instance.ToString()
C#
public virtual System.string ToString()
Delphi
public function ToString(): System.String; virtual;
JScript
public function ToString() : System.String;
Managed Extensions for C++
public: virtual System.string* ToString();
C++/CLI
public:
virtual System.String^ ToString();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridClientBindingSettings Class
WebGridClientBindingSettings Members


DataLoadMode Property

[image]
Intersoft WebGrid Documentation
DataLoadMode Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridClientBindingSettings Class : DataLoadMode Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Gets or sets the client data load behavior.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
Public Property DataLoadMode As ISNet.WebUI.ClientDataLoadMode
Visual Basic (Usage) Copy Code
Dim instance As WebGridClientBindingSettings
Dim value As ISNet.WebUI.ClientDataLoadMode

instance.DataLoadMode = value

value = instance.DataLoadMode
C#
[System.ComponentModel.DescriptionAttribute("Gets or sets the client data load behavior.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public ISNet.WebUI.ClientDataLoadMode DataLoadMode {get; set;}
Delphi
public read-write property DataLoadMode: ISNet.WebUI.ClientDataLoadMode;
JScript
System.ComponentModel.DescriptionAttribute("Gets or sets the client data load behavior.")
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
public function get,set DataLoadMode : ISNet.WebUI.ClientDataLoadMode
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Gets or sets the client data load behavior.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public: __property ISNet.WebUI.ClientDataLoadMode get_DataLoadMode();
public: __property void set_DataLoadMode(
   ISNet.WebUI.ClientDataLoadMode value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Gets or sets the client data load behavior.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public:
property ISNet.WebUI.ClientDataLoadMode DataLoadMode {
   ISNet.WebUI.ClientDataLoadMode get();
   void set (    ISNet.WebUI.ClientDataLoadMode value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridClientBindingSettings Class
WebGridClientBindingSettings Members


DataSourceType Property

[image]
Intersoft WebGrid Documentation
DataSourceType Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridClientBindingSettings Class : DataSourceType Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Gets or sets the client datasource type.")>
Public Property DataSourceType As ISNet.WebUI.ClientDataSourceType
Visual Basic (Usage) Copy Code
Dim instance As WebGridClientBindingSettings
Dim value As ISNet.WebUI.ClientDataSourceType

instance.DataSourceType = value

value = instance.DataSourceType
C#
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the client datasource type.")]
public ISNet.WebUI.ClientDataSourceType DataSourceType {get; set;}
Delphi
public read-write property DataSourceType: ISNet.WebUI.ClientDataSourceType;
JScript
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the client datasource type.")
public function get,set DataSourceType : ISNet.WebUI.ClientDataSourceType
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the client datasource type.")]
public: __property ISNet.WebUI.ClientDataSourceType get_DataSourceType();
public: __property void set_DataSourceType(
   ISNet.WebUI.ClientDataSourceType value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the client datasource type.")]
public:
property ISNet.WebUI.ClientDataSourceType DataSourceType {
   ISNet.WebUI.ClientDataSourceType get();
   void set (    ISNet.WebUI.ClientDataSourceType value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridClientBindingSettings Class
WebGridClientBindingSettings Members


WebGridClientBindingSettings Class Properties

[image]
Intersoft WebGrid Documentation
WebGridClientBindingSettings Class Properties
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : WebGridClientBindingSettings Class

Glossary Item Box

For a list of all members of this type, see WebGridClientBindingSettings members.

Public Properties

 | Name | Description
Public Property | DataLoadMode | (Inherited from ISNet.WebUI.ClientBindingSettings)
Public Property | DataSourceType | (Inherited from ISNet.WebUI.ClientBindingSettings)
Public Property | EnableGroupRowPaging |
Public Property | FetchDataOnPageLoad | (Inherited from ISNet.WebUI.ClientBindingSettings)
Public Property | GroupRowPageSize |
Public Property | ItemTypeName | (Inherited from ISNet.WebUI.ClientBindingSettings)
Public Property | PreloadGroupTotals |
Public Property | ServiceEvents | (Inherited from ISNet.WebUI.ClientBindingSettings)
Public Property | ServiceMethods | (Inherited from ISNet.WebUI.ClientBindingSettings)
Public Property | ServiceUrl | (Inherited from ISNet.WebUI.ClientBindingSettings)
Top

See Also

Reference

WebGridClientBindingSettings Class
ISNet.WebUI.WebGrid Namespace


WebGridClientBindingSettings Constructor

[image]
Intersoft WebGrid Documentation
WebGridClientBindingSettings Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridClientBindingSettings Class : WebGridClientBindingSettings Constructor

Glossary Item Box

Overload List

Overload | Description
WebGridClientBindingSettings Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridClientBindingSettings Class
WebGridClientBindingSettings Members


EnableGroupRowPaging Property

[image]
Intersoft WebGrid Documentation
EnableGroupRowPaging Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridClientBindingSettings Class : EnableGroupRowPaging Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies whether the rows within groups should be paged to improve virtual load performance. ")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
Public Property EnableGroupRowPaging As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebGridClientBindingSettings
Dim value As System.Boolean

instance.EnableGroupRowPaging = value

value = instance.EnableGroupRowPaging
C#
[System.ComponentModel.DescriptionAttribute("Specifies whether the rows within groups should be paged to improve virtual load performance. ")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public System.bool EnableGroupRowPaging {get; set;}
Delphi
public read-write property EnableGroupRowPaging: System.Boolean;
JScript
System.ComponentModel.DescriptionAttribute("Specifies whether the rows within groups should be paged to improve virtual load performance. ")
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
public function get,set EnableGroupRowPaging : System.boolean
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies whether the rows within groups should be paged to improve virtual load performance. ")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.bool get_EnableGroupRowPaging();
public: __property void set_EnableGroupRowPaging(
   System.bool value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies whether the rows within groups should be paged to improve virtual load performance. ")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.bool EnableGroupRowPaging {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridClientBindingSettings Class
WebGridClientBindingSettings Members


FetchDataOnPageLoad Property

[image]
Intersoft WebGrid Documentation
FetchDataOnPageLoad Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridClientBindingSettings Class : FetchDataOnPageLoad Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Specifies whether the control should automatically fetch data after the page is loaded.")>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Property FetchDataOnPageLoad As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebGridClientBindingSettings
Dim value As System.Boolean

instance.FetchDataOnPageLoad = value

value = instance.FetchDataOnPageLoad
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies whether the control should automatically fetch data after the page is loaded.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public System.bool FetchDataOnPageLoad {get; set;}
Delphi
public read-write property FetchDataOnPageLoad: System.Boolean;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Specifies whether the control should automatically fetch data after the page is loaded.")
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute()
public function get,set FetchDataOnPageLoad : System.boolean
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies whether the control should automatically fetch data after the page is loaded.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property System.bool get_FetchDataOnPageLoad();
public: __property void set_FetchDataOnPageLoad(
   System.bool value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies whether the control should automatically fetch data after the page is loaded.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property System.bool FetchDataOnPageLoad {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridClientBindingSettings Class
WebGridClientBindingSettings Members


GroupRowPageSize Property

[image]
Intersoft WebGrid Documentation
GroupRowPageSize Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridClientBindingSettings Class : GroupRowPageSize Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Gets or sets the number of rows to be retrieved during load group process. ")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
Public Property GroupRowPageSize As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebGridClientBindingSettings
Dim value As System.Integer

instance.GroupRowPageSize = value

value = instance.GroupRowPageSize
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the number of rows to be retrieved during load group process. ")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public System.int GroupRowPageSize {get; set;}
Delphi
public read-write property GroupRowPageSize: System.Integer;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the number of rows to be retrieved during load group process. ")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
public function get,set GroupRowPageSize : System.int
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the number of rows to be retrieved during load group process. ")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.int get_GroupRowPageSize();
public: __property void set_GroupRowPageSize(
   System.int value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the number of rows to be retrieved during load group process. ")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.int GroupRowPageSize {
   System.int get();
   void set (    System.int value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridClientBindingSettings Class
WebGridClientBindingSettings Members


ItemTypeName Property

[image]
Intersoft WebGrid Documentation
ItemTypeName Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridClientBindingSettings Class : ItemTypeName Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Gets or sets the javascript function name that represents the data item type. This property is required for editing operation.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property ItemTypeName As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebGridClientBindingSettings
Dim value As System.String

instance.ItemTypeName = value

value = instance.ItemTypeName
C#
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the javascript function name that represents the data item type. This property is required for editing operation.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public System.string ItemTypeName {get; set;}
Delphi
public read-write property ItemTypeName: System.String;
JScript
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the javascript function name that represents the data item type. This property is required for editing operation.")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get,set ItemTypeName : System.String
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the javascript function name that represents the data item type. This property is required for editing operation.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.string* get_ItemTypeName();
public: __property void set_ItemTypeName(
   System.string* value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the javascript function name that represents the data item type. This property is required for editing operation.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.String^ ItemTypeName {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridClientBindingSettings Class
WebGridClientBindingSettings Members


PreloadGroupTotals Property

[image]
Intersoft WebGrid Documentation
PreloadGroupTotals Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridClientBindingSettings Class : PreloadGroupTotals Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Indicates whether the group totals should be calculated during virtual load process.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property PreloadGroupTotals As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebGridClientBindingSettings
Dim value As System.Boolean

instance.PreloadGroupTotals = value

value = instance.PreloadGroupTotals
C#
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Indicates whether the group totals should be calculated during virtual load process.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.bool PreloadGroupTotals {get; set;}
Delphi
public read-write property PreloadGroupTotals: System.Boolean;
JScript
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Indicates whether the group totals should be calculated during virtual load process.")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set PreloadGroupTotals : System.boolean
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Indicates whether the group totals should be calculated during virtual load process.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.bool get_PreloadGroupTotals();
public: __property void set_PreloadGroupTotals(
   System.bool value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Indicates whether the group totals should be calculated during virtual load process.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.bool PreloadGroupTotals {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridClientBindingSettings Class
WebGridClientBindingSettings Members


ServiceEvents Property

[image]
Intersoft WebGrid Documentation
ServiceEvents Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridClientBindingSettings Class : ServiceEvents Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute("setServiceEvents")>
<System.ComponentModel.DescriptionAttribute("Provides settings for service events, when DataSourceType is set to either WebService, WcfService or AdoDataService")>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<ISNet.Serialization.XmlSerializableAttribute(True)>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
Public ReadOnly Property ServiceEvents As ISNet.WebUI.ClientServiceEvents
Visual Basic (Usage) Copy Code
Dim instance As WebGridClientBindingSettings
Dim value As ISNet.WebUI.ClientServiceEvents

value = instance.ServiceEvents
C#
[ISNet.Serialization.BinarySerializableAttribute("setServiceEvents")]
[System.ComponentModel.DescriptionAttribute("Provides settings for service events, when DataSourceType is set to either WebService, WcfService or AdoDataService")]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public ISNet.WebUI.ClientServiceEvents ServiceEvents {get;}
Delphi
public read-only property ServiceEvents: ISNet.WebUI.ClientServiceEvents;
JScript
ISNet.Serialization.BinarySerializableAttribute("setServiceEvents")
System.ComponentModel.DescriptionAttribute("Provides settings for service events, when DataSourceType is set to either WebService, WcfService or AdoDataService")
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
ISNet.Serialization.XmlSerializableAttribute()
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
public function get ServiceEvents : ISNet.WebUI.ClientServiceEvents
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute("setServiceEvents")]
[System.ComponentModel.DescriptionAttribute("Provides settings for service events, when DataSourceType is set to either WebService, WcfService or AdoDataService")]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public: __property ISNet.WebUI.ClientServiceEvents* get_ServiceEvents();
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute("setServiceEvents")]
[System.ComponentModel.DescriptionAttribute("Provides settings for service events, when DataSourceType is set to either WebService, WcfService or AdoDataService")]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public:
property ISNet.WebUI.ClientServiceEvents^ ServiceEvents {
   ISNet.WebUI.ClientServiceEvents^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridClientBindingSettings Class
WebGridClientBindingSettings Members


ServiceMethods Property

[image]
Intersoft WebGrid Documentation
ServiceMethods Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridClientBindingSettings Class : ServiceMethods Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute("setServiceCommands")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Provides settings for service methods, when DataSourceType is set to either WebService, WcfService or AdoDataService")>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<ISNet.Serialization.XmlSerializableAttribute(True)>
Public ReadOnly Property ServiceMethods As ISNet.WebUI.ClientServiceMethods
Visual Basic (Usage) Copy Code
Dim instance As WebGridClientBindingSettings
Dim value As ISNet.WebUI.ClientServiceMethods

value = instance.ServiceMethods
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute("setServiceCommands")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Provides settings for service methods, when DataSourceType is set to either WebService, WcfService or AdoDataService")]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[ISNet.Serialization.XmlSerializableAttribute(true)]
public ISNet.WebUI.ClientServiceMethods ServiceMethods {get;}
Delphi
public read-only property ServiceMethods: ISNet.WebUI.ClientServiceMethods;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute("setServiceCommands")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Provides settings for service methods, when DataSourceType is set to either WebService, WcfService or AdoDataService")
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
ISNet.Serialization.XmlSerializableAttribute()
public function get ServiceMethods : ISNet.WebUI.ClientServiceMethods
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute("setServiceCommands")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Provides settings for service methods, when DataSourceType is set to either WebService, WcfService or AdoDataService")]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[ISNet.Serialization.XmlSerializableAttribute(true)]
public: __property ISNet.WebUI.ClientServiceMethods* get_ServiceMethods();
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute("setServiceCommands")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Provides settings for service methods, when DataSourceType is set to either WebService, WcfService or AdoDataService")]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[ISNet.Serialization.XmlSerializableAttribute(true)]
public:
property ISNet.WebUI.ClientServiceMethods^ ServiceMethods {
   ISNet.WebUI.ClientServiceMethods^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridClientBindingSettings Class
WebGridClientBindingSettings Members


ServiceUrl Property

[image]
Intersoft WebGrid Documentation
ServiceUrl Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridClientBindingSettings Class : ServiceUrl Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="System.Web.UI.Design.UrlEditor, System.Design, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Gets or sets the web service url that provides data source when invoked from client.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.Web.UI.UrlPropertyAttribute()>
Public Property ServiceUrl As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebGridClientBindingSettings
Dim value As System.String

instance.ServiceUrl = value

value = instance.ServiceUrl
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="System.Web.UI.Design.UrlEditor, System.Design, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the web service url that provides data source when invoked from client.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.Web.UI.UrlPropertyAttribute()]
public System.string ServiceUrl {get; set;}
Delphi
public read-write property ServiceUrl: System.String;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="System.Web.UI.Design.UrlEditor, System.Design, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the web service url that provides data source when invoked from client.")
ISNet.Serialization.XmlSerializableAttribute()
System.Web.UI.UrlPropertyAttribute()
public function get,set ServiceUrl : System.String
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="System.Web.UI.Design.UrlEditor, System.Design, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the web service url that provides data source when invoked from client.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.Web.UI.UrlPropertyAttribute()]
public: __property System.string* get_ServiceUrl();
public: __property void set_ServiceUrl(
   System.string* value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="System.Web.UI.Design.UrlEditor, System.Design, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the web service url that provides data source when invoked from client.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.Web.UI.UrlPropertyAttribute()]
public:
property System.String^ ServiceUrl {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridClientBindingSettings Class
WebGridClientBindingSettings Members


WebGridColumn Class

[image]
Intersoft WebGrid Documentation
WebGridColumn Class
Members See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : WebGridColumn Class

Glossary Item Box

Object Model

WebGridColumn Class

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.DescriptionAttribute()>
<System.SerializableAttribute()>
Public Class WebGridColumn
   Inherits ISNet.WebUI.NamedObjectBase
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.Serialization.XmlSerialization.ICustomXmlSerializer, ISNet.WebUI.INamedObject
Visual Basic (Usage) Copy Code
Dim instance As WebGridColumn
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DescriptionAttribute()]
[System.SerializableAttribute()]
public class WebGridColumn : ISNet.WebUI.NamedObjectBase, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.Serialization.XmlSerialization.ICustomXmlSerializer, ISNet.WebUI.INamedObject
Delphi
public class WebGridColumn = class(ISNet.WebUI.NamedObjectBase, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.Serialization.XmlSerialization.ICustomXmlSerializer, ISNet.WebUI.INamedObject)
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.DescriptionAttribute()
System.SerializableAttribute()
public class WebGridColumn extends ISNet.WebUI.NamedObjectBase implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.Serialization.XmlSerialization.ICustomXmlSerializer, ISNet.WebUI.INamedObject
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DescriptionAttribute()]
[System.SerializableAttribute()]
public __gc class WebGridColumn : public ISNet.WebUI.NamedObjectBase, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.Serialization.XmlSerialization.ICustomXmlSerializer, ISNet.WebUI.INamedObject
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DescriptionAttribute()]
[System.SerializableAttribute()]
public ref class WebGridColumn : public ISNet.WebUI.NamedObjectBase, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.Serialization.XmlSerialization.ICustomXmlSerializer, ISNet.WebUI.INamedObject

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.NamedObjectBase
ISNet.WebUI.WebGrid.WebGridColumn

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridColumn Members
ISNet.WebUI.WebGrid Namespace


WebGridColumn Class Members

[image]
Intersoft WebGrid Documentation
WebGridColumn Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebGrid Namespace : WebGridColumn Class

Glossary Item Box

The following tables list the members exposed by WebGridColumn.

Public Constructors

 | Name | Description
Public Constructor | WebGridColumn Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | AggregateFunction |
Public Property | AllowGrouping |
Public Property | AllowMultiLine |
Public Property | AllowSizing |
Public Property | AllowSorting |
Public Property | Bound |
Public Property | ButtonAutoPostback |
Public Property | ButtonImage |
Public Property | ButtonPostbackMode |
Public Property | ButtonStyle |
Public Property | ButtonText |
Public Property | CanAddToChartCategories |
Public Property | CanAddToChartData |
Public Property | CanAddToChartFilter |
Public Property | CanAddToChartSeries |
Public Property | Caption |
Public Property | CaseSensitiveGrouping |
Public Property | CellImage |
Public Property | CellStyle |
Public Property | ClipboardCopyMode |
Public Property | ColumnType |
Public Property | CustomEditorName |
Public Property | CustomEditorProperties |
Public Property | CustomEditorServerId |
Public Property | DataFormatString |
Public Property | DataMember |
Public Property | DefaultFilterType |
Public Property | DefaultText |
Public Property | DefaultValue |
Public Property | EditInfoImage |
Public Property | EditInfoText |
Public Property | EditType |
Public Property | FilterEditType |
Public Property | FilterKeyField |
Public Property | FooterStyle |
Public Property | FooterText |
Public Property | GroupEmptyString |
Public Property | GroupInterval |
Public Property | GroupRowInfoFormat |
Public Property | GroupRowValueFormatString |
Public Property | HeaderImage |
Public Property | HeaderStyle |
Public Property | HeaderTooltip |
Public Property | HiddenDataMember |
Public Property | HtmlHeaders |
Public Property | HtmlScope |
Public Property | HtmlUniqueId |
Public Property | HyperlinkCustomTarget |
Public Property | HyperlinkDisplayText |
Public Property | HyperlinkFormatString |
Public Property | HyperlinkTarget |
Public Property | ImageFormatString |
Public Property | InputRequired |
Public Property | InputRequiredErrorText |
Public Property | IsAutoIncrement |
Public Property | IsAutoWidth |
Public Property | IsRowChecker |
Public Property | IsRowHeader |
Public Property | MaxHeight |
Public Property | Name | Overridden.
Public Property | NewRowEditType |
Public Property | NullText |
Public Property | PreserveWhitespace |
Public Property | ShowInChartFieldList |
Public Property | ShowInSelectColumns |
Public Property | SortKeyField |
Public Property | Tag |
Public Property | TextboxMaxlength |
Public Property | TreatMarkupAsLiteralText |
Public Property | UseValueListForFilter |
Public Property | UseValueListForSorting |
Public Property | ValueList |
Public Property | Visible |
Public Property | WebComboID |
Public Property | Width |
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CustomDeserialize |
Public Method | CustomSerialize |
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString |
Top

See Also

Reference

WebGridColumn Class
ISNet.WebUI.WebGrid Namespace


WebGridColumn Constructor

[image]
Intersoft WebGrid Documentation
WebGridColumn Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridColumn Class : WebGridColumn Constructor

Glossary Item Box

Overload List

Overload | Description
WebGridColumn Constructor() |
WebGridColumn Constructor(String,String) |
WebGridColumn Constructor(String,String,String) |
WebGridColumn Constructor(String,String,String,Unit) |
WebGridColumn Constructor(String,String,String,Unit,ColumnType,EditType,String) |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridColumn Class
WebGridColumn Members


WebGridColumn Constructor()

[image]
Intersoft WebGrid Documentation
WebGridColumn Constructor()
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridColumn Class > WebGridColumn Constructor : WebGridColumn Constructor()

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebGridColumn()
C#
public WebGridColumn()
Delphi
public WebGridColumn();
JScript
public function WebGridColumn();
Managed Extensions for C++
public: WebGridColumn();
C++/CLI
public:
WebGridColumn();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridColumn Class
WebGridColumn Members
Overload List


WebGridColumn Constructor(String,String)

[image]
Intersoft WebGrid Documentation
WebGridColumn Constructor(String,String)
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridColumn Class > WebGridColumn Constructor : WebGridColumn Constructor(String,String)

name
caption

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal name As System.String, _
   ByVal caption As System.String _
)
Visual Basic (Usage) Copy Code
Dim name As System.String
Dim caption As System.String

Dim instance As New WebGridColumn(name, caption)
C#
public WebGridColumn(
   System.string name,
   System.string caption
)
Delphi
public WebGridColumn(
    name: System.String;
    caption: System.String
);
JScript
public function WebGridColumn(
   name : System.String,
   caption : System.String
);
Managed Extensions for C++
public: WebGridColumn(
   System.string* name,
   System.string* caption
)
C++/CLI
public:
WebGridColumn(
   System.String^ name,
   System.String^ caption
)

Parameters

name
caption

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridColumn Class
WebGridColumn Members
Overload List


WebGridColumn Constructor(String,String,String)

[image]
Intersoft WebGrid Documentation
WebGridColumn Constructor(String,String,String)
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridColumn Class > WebGridColumn Constructor : WebGridColumn Constructor(String,String,String)

name
dataMember
caption

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal name As System.String, _
   ByVal dataMember As System.String, _
   ByVal caption As System.String _
)
Visual Basic (Usage) Copy Code
Dim name As System.String
Dim dataMember As System.String
Dim caption As System.String

Dim instance As New WebGridColumn(name, dataMember, caption)
C#
public WebGridColumn(
   System.string name,
   System.string dataMember,
   System.string caption
)
Delphi
public WebGridColumn(
    name: System.String;
    dataMember: System.String;
    caption: System.String
);
JScript
public function WebGridColumn(
   name : System.String,
   dataMember : System.String,
   caption : System.String
);
Managed Extensions for C++
public: WebGridColumn(
   System.string* name,
   System.string* dataMember,
   System.string* caption
)
C++/CLI
public:
WebGridColumn(
   System.String^ name,
   System.String^ dataMember,
   System.String^ caption
)

Parameters

name
dataMember
caption

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridColumn Class
WebGridColumn Members
Overload List


WebGridColumn Constructor(String,String,String,Unit)

[image]
Intersoft WebGrid Documentation
WebGridColumn Constructor(String,String,String,Unit)
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridColumn Class > WebGridColumn Constructor : WebGridColumn Constructor(String,String,String,Unit)

name
dataMember
caption
width

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal name As System.String, _
   ByVal dataMember As System.String, _
   ByVal caption As System.String, _
   ByVal width As System.Web.UI.WebControls.Unit _
)
Visual Basic (Usage) Copy Code
Dim name As System.String
Dim dataMember As System.String
Dim caption As System.String
Dim width As System.Web.UI.WebControls.Unit

Dim instance As New WebGridColumn(name, dataMember, caption, width)
C#
public WebGridColumn(
   System.string name,
   System.string dataMember,
   System.string caption,
   System.Web.UI.WebControls.Unit width
)
Delphi
public WebGridColumn(
    name: System.String;
    dataMember: System.String;
    caption: System.String;
    width: System.Web.UI.WebControls.Unit
);
JScript
public function WebGridColumn(
   name : System.String,
   dataMember : System.String,
   caption : System.String,
   width : System.Web.UI.WebControls.Unit
);
Managed Extensions for C++
public: WebGridColumn(
   System.string* name,
   System.string* dataMember,
   System.string* caption,
   System.Web.UI.WebControls.Unit width
)
C++/CLI
public:
WebGridColumn(
   System.String^ name,
   System.String^ dataMember,
   System.String^ caption,
   System.Web.UI.WebControls.Unit width
)

Parameters

name
dataMember
caption
width

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridColumn Class
WebGridColumn Members
Overload List


WebGridColumn Constructor(String,String,String,Unit,ColumnType,EditType,String)

[image]
Intersoft WebGrid Documentation
WebGridColumn Constructor(String,String,String,Unit,ColumnType,EditType,String)
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridColumn Class > WebGridColumn Constructor : WebGridColumn Constructor(String,String,String,Unit,ColumnType,EditType,String)

name
dataMember
caption
width
columnType
editType
dataFormatString

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal name As System.String, _
   ByVal dataMember As System.String, _
   ByVal caption As System.String, _
   ByVal width As System.Web.UI.WebControls.Unit, _
   ByVal columnType As ColumnType, _
   ByVal editType As EditType, _
   ByVal dataFormatString As System.String _
)
Visual Basic (Usage) Copy Code
Dim name As System.String
Dim dataMember As System.String
Dim caption As System.String
Dim width As System.Web.UI.WebControls.Unit
Dim columnType As ColumnType
Dim editType As EditType
Dim dataFormatString As System.String

Dim instance As New WebGridColumn(name, dataMember, caption, width, columnType, editType, dataFormatString)
C#
public WebGridColumn(
   System.string name,
   System.string dataMember,
   System.string caption,
   System.Web.UI.WebControls.Unit width,
   ColumnType columnType,
   EditType editType,
   System.string dataFormatString
)
Delphi
public WebGridColumn(
    name: System.String;
    dataMember: System.String;
    caption: System.String;
    width: System.Web.UI.WebControls.Unit;
    columnType: ColumnType;
    editType: EditType;
    dataFormatString: System.String
);
JScript
public function WebGridColumn(
   name : System.String,
   dataMember : System.String,
   caption : System.String,
   width : System.Web.UI.WebControls.Unit,
   columnType : ColumnType,
   editType : EditType,
   dataFormatString : System.String
);
Managed Extensions for C++
public: WebGridColumn(
   System.string* name,
   System.string* dataMember,
   System.string* caption,
   System.Web.UI.WebControls.Unit width,
   ColumnType columnType,
   EditType editType,
   System.string* dataFormatString
)
C++/CLI
public:
WebGridColumn(
   System.String^ name,
   System.String^ dataMember,
   System.String^ caption,
   System.Web.UI.WebControls.Unit width,
   ColumnType columnType,
   EditType editType,
   System.String^ dataFormatString
)

Parameters

name
dataMember
caption
width
columnType
editType
dataFormatString

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridColumn Class
WebGridColumn Members
Overload List


Clone Method

[image]
Intersoft WebGrid Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridColumn Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As System.Object
Visual Basic (Usage) Copy Code
Dim instance As WebGridColumn
Dim value As System.Object

value = instance.Clone()
C#
public virtual System.object Clone()
Delphi
public function Clone(): System.TObject; virtual;
JScript
public function Clone() : System.Object;
Managed Extensions for C++
public: virtual System.Object* Clone();
C++/CLI
public:
virtual System.Object^ Clone();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridColumn Class
WebGridColumn Members


CopyFrom Method

[image]
Intersoft WebGrid Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridColumn Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridColumn Class
WebGridColumn Members


CopyFrom(Object) Method

[image]
Intersoft WebGrid Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridColumn Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebGridColumn
Dim objSource As System.Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   System.object objSource
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridColumn Class
WebGridColumn Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebGrid Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridColumn Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object, _
   ByVal cloneSourceValue As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebGridColumn
Dim objSource As System.Object
Dim cloneSourceValue As System.Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   System.object objSource,
   System.bool cloneSourceValue
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject;
    cloneSourceValue: System.Boolean
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object,
   cloneSourceValue : System.boolean
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource,
   System.bool cloneSourceValue
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource,
   System.bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridColumn Class
WebGridColumn Members
Overload List


WebGridColumn Class Methods

[image]
Intersoft WebGrid Documentation
WebGridColumn Class Methods
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : WebGridColumn Class

Glossary Item Box

For a list of all members of this type, see WebGridColumn members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CustomDeserialize |
Public Method | CustomSerialize |
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString |
Top

See Also

Reference

WebGridColumn Class
ISNet.WebUI.WebGrid Namespace


CustomDeserialize Method

[image]
Intersoft WebGrid Documentation
CustomDeserialize Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridColumn Class : CustomDeserialize Method

mi
currentObj
parentNode
currentNode

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub CustomDeserialize( _
   ByVal mi As System.Reflection.MemberInfo, _
   ByVal currentObj As System.Object, _
   ByVal parentNode As System.Xml.XmlNode, _
   ByVal currentNode As System.Xml.XmlNode _
)
Visual Basic (Usage) Copy Code
Dim instance As WebGridColumn
Dim mi As System.Reflection.MemberInfo
Dim currentObj As System.Object
Dim parentNode As System.Xml.XmlNode
Dim currentNode As System.Xml.XmlNode

instance.CustomDeserialize(mi, currentObj, parentNode, currentNode)
C#
public void CustomDeserialize(
   System.Reflection.MemberInfo mi,
   System.object currentObj,
   System.Xml.XmlNode parentNode,
   System.Xml.XmlNode currentNode
)
Delphi
public procedure CustomDeserialize(
    mi: System.Reflection.MemberInfo;
    currentObj: System.TObject;
    parentNode: System.Xml.XmlNode;
    currentNode: System.Xml.XmlNode
);
JScript
public function CustomDeserialize(
   mi : System.Reflection.MemberInfo,
   currentObj : System.Object,
   parentNode : System.Xml.XmlNode,
   currentNode : System.Xml.XmlNode
);
Managed Extensions for C++
public: void CustomDeserialize(
   System.Reflection.MemberInfo* mi,
   System.Object* currentObj,
   System.Xml.XmlNode* parentNode,
   System.Xml.XmlNode* currentNode
)
C++/CLI
public:
void CustomDeserialize(
   System.Reflection.MemberInfo^ mi,
   System.Object^ currentObj,
   System.Xml.XmlNode^ parentNode,
   System.Xml.XmlNode^ currentNode
)

Parameters

mi
currentObj
parentNode
currentNode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridColumn Class
WebGridColumn Members


CustomSerialize Method

[image]
Intersoft WebGrid Documentation
CustomSerialize Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridColumn Class : CustomSerialize Method

doc
node

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub CustomSerialize( _
   ByVal doc As System.Xml.XmlDocument, _
   ByVal node As System.Xml.XmlNode _
)
Visual Basic (Usage) Copy Code
Dim instance As WebGridColumn
Dim doc As System.Xml.XmlDocument
Dim node As System.Xml.XmlNode

instance.CustomSerialize(doc, node)
C#
public void CustomSerialize(
   System.Xml.XmlDocument doc,
   System.Xml.XmlNode node
)
Delphi
public procedure CustomSerialize(
    doc: System.Xml.XmlDocument;
    node: System.Xml.XmlNode
);
JScript
public function CustomSerialize(
   doc : System.Xml.XmlDocument,
   node : System.Xml.XmlNode
);
Managed Extensions for C++
public: void CustomSerialize(
   System.Xml.XmlDocument* doc,
   System.Xml.XmlNode* node
)
C++/CLI
public:
void CustomSerialize(
   System.Xml.XmlDocument^ doc,
   System.Xml.XmlNode^ node
)

Parameters

doc
node

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridColumn Class
WebGridColumn Members


DeSerializeObjectData Method

[image]
Intersoft WebGrid Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridColumn Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebGridColumn
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure DeSerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function DeSerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void DeSerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void DeSerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridColumn Class
WebGridColumn Members


GetHashCode Method

[image]
Intersoft WebGrid Documentation
GetHashCode Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridColumn Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebGridColumn
Dim value As System.Integer

value = instance.GetHashCode()
C#
public virtual System.int GetHashCode()
Delphi
public function GetHashCode(): System.Integer; virtual;
JScript
public function GetHashCode() : System.int;
Managed Extensions for C++
public: virtual System.int GetHashCode();
C++/CLI
public:
virtual System.int GetHashCode();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridColumn Class
WebGridColumn Members


GetObjectData Method

[image]
Intersoft WebGrid Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridColumn Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebGridColumn
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure GetObjectData(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
); override;
JScript
public override function GetObjectData(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void GetObjectData(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
) override
C++/CLI
public:
void GetObjectData(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
) override

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridColumn Class
WebGridColumn Members


IsEmpty Method

[image]
Intersoft WebGrid Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridColumn Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebGridColumn
Dim value As System.Boolean

value = instance.IsEmpty()
C#
public virtual System.bool IsEmpty()
Delphi
public function IsEmpty(): System.Boolean; virtual;
JScript
public function IsEmpty() : System.boolean;
Managed Extensions for C++
public: virtual System.bool IsEmpty();
C++/CLI
public:
virtual System.bool IsEmpty();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridColumn Class
WebGridColumn Members


Reset Method

[image]
Intersoft WebGrid Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridColumn Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As WebGridColumn

instance.Reset()
C#
public virtual void Reset()
Delphi
public procedure Reset(); virtual;
JScript
public function Reset();
Managed Extensions for C++
public: virtual void Reset();
C++/CLI
public:
virtual void Reset();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridColumn Class
WebGridColumn Members


SerializeObjectData Method

[image]
Intersoft WebGrid Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridColumn Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebGridColumn
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure SerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function SerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void SerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void SerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridColumn Class
WebGridColumn Members


ToString Method

[image]
Intersoft WebGrid Documentation
ToString Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridColumn Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString() As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebGridColumn
Dim value As System.String

value = instance.ToString()
C#
public override System.string ToString()
Delphi
public function ToString(): System.String; override;
JScript
public override function ToString() : System.String;
Managed Extensions for C++
public: System.string* ToString(); override
C++/CLI
public:
System.String^ ToString(); override

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridColumn Class
WebGridColumn Members


WebGridColumn Class Properties

[image]
Intersoft WebGrid Documentation
WebGridColumn Class Properties
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : WebGridColumn Class

Glossary Item Box

For a list of all members of this type, see WebGridColumn members.

Public Properties

 | Name | Description
Public Property | AggregateFunction |
Public Property | AllowGrouping |
Public Property | AllowMultiLine |
Public Property | AllowSizing |
Public Property | AllowSorting |
Public Property | Bound |
Public Property | ButtonAutoPostback |
Public Property | ButtonImage |
Public Property | ButtonPostbackMode |
Public Property | ButtonStyle |
Public Property | ButtonText |
Public Property | CanAddToChartCategories |
Public Property | CanAddToChartData |
Public Property | CanAddToChartFilter |
Public Property | CanAddToChartSeries |
Public Property | Caption |
Public Property | CaseSensitiveGrouping |
Public Property | CellImage |
Public Property | CellStyle |
Public Property | ClipboardCopyMode |
Public Property | ColumnType |
Public Property | CustomEditorName |
Public Property | CustomEditorProperties |
Public Property | CustomEditorServerId |
Public Property | DataFormatString |
Public Property | DataMember |
Public Property | DefaultFilterType |
Public Property | DefaultText |
Public Property | DefaultValue |
Public Property | EditInfoImage |
Public Property | EditInfoText |
Public Property | EditType |
Public Property | FilterEditType |
Public Property | FilterKeyField |
Public Property | FooterStyle |
Public Property | FooterText |
Public Property | GroupEmptyString |
Public Property | GroupInterval |
Public Property | GroupRowInfoFormat |
Public Property | GroupRowValueFormatString |
Public Property | HeaderImage |
Public Property | HeaderStyle |
Public Property | HeaderTooltip |
Public Property | HiddenDataMember |
Public Property | HtmlHeaders |
Public Property | HtmlScope |
Public Property | HtmlUniqueId |
Public Property | HyperlinkCustomTarget |
Public Property | HyperlinkDisplayText |
Public Property | HyperlinkFormatString |
Public Property | HyperlinkTarget |
Public Property | ImageFormatString |
Public Property | InputRequired |
Public Property | InputRequiredErrorText |
Public Property | IsAutoIncrement |
Public Property | IsAutoWidth |
Public Property | IsRowChecker |
Public Property | IsRowHeader |
Public Property | MaxHeight |
Public Property | Name | Overridden.
Public Property | NewRowEditType |
Public Property | NullText |
Public Property | PreserveWhitespace |
Public Property | ShowInChartFieldList |
Public Property | ShowInSelectColumns |
Public Property | SortKeyField |
Public Property | Tag |
Public Property | TextboxMaxlength |
Public Property | TreatMarkupAsLiteralText |
Public Property | UseValueListForFilter |
Public Property | UseValueListForSorting |
Public Property | ValueList |
Public Property | Visible |
Public Property | WebComboID |
Public Property | Width |
Top

See Also

Reference

WebGridColumn Class
ISNet.WebUI.WebGrid Namespace


AggregateFunction Property

[image]
Intersoft WebGrid Documentation
AggregateFunction Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridColumn Class : AggregateFunction Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Gets or sets the aggregate function which result will be shown in total rows or group total rows for a column.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property AggregateFunction As AggregateFunctions
Visual Basic (Usage) Copy Code
Dim instance As WebGridColumn
Dim value As AggregateFunctions

instance.AggregateFunction = value

value = instance.AggregateFunction
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the aggregate function which result will be shown in total rows or group total rows for a column.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
public AggregateFunctions AggregateFunction {get; set;}
Delphi
public read-write property AggregateFunction: AggregateFunctions;
JScript
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the aggregate function which result will be shown in total rows or group total rows for a column.")
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get,set AggregateFunction : AggregateFunctions
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the aggregate function which result will be shown in total rows or group total rows for a column.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property AggregateFunctions get_AggregateFunction();
public: __property void set_AggregateFunction(
   AggregateFunctions value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the aggregate function which result will be shown in total rows or group total rows for a column.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property AggregateFunctions AggregateFunction {
   AggregateFunctions get();
   void set (    AggregateFunctions value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridColumn Class
WebGridColumn Members


AllowGrouping Property

[image]
Intersoft WebGrid Documentation
AllowGrouping Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridColumn Class : AllowGrouping Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies whether or not to allow users group columns from within WebGrid.")>
Public Property AllowGrouping As Grouping
Visual Basic (Usage) Copy Code
Dim instance As WebGridColumn
Dim value As Grouping

instance.AllowGrouping = value

value = instance.AllowGrouping
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether or not to allow users group columns from within WebGrid.")]
public Grouping AllowGrouping {get; set;}
Delphi
public read-write property AllowGrouping: Grouping;
JScript
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Specifies whether or not to allow users group columns from within WebGrid.")
public function get,set AllowGrouping : Grouping
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether or not to allow users group columns from within WebGrid.")]
public: __property Grouping get_AllowGrouping();
public: __property void set_AllowGrouping(
   Grouping value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether or not to allow users group columns from within WebGrid.")]
public:
property Grouping AllowGrouping {
   Grouping get();
   void set (    Grouping value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridColumn Class
WebGridColumn Members


AllowMultiLine Property

[image]
Intersoft WebGrid Documentation
AllowMultiLine Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridColumn Class : AllowMultiLine Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Specifies whether cells that belong to this column can display multiple lines of data.")>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Property AllowMultiLine As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebGridColumn
Dim value As System.Boolean

instance.AllowMultiLine = value

value = instance.AllowMultiLine
C#
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies whether cells that belong to this column can display multiple lines of data.")]
[ISNet.Serialization.XmlSerializableAttribute()]
public System.bool AllowMultiLine {get; set;}
Delphi
public read-write property AllowMultiLine: System.Boolean;
JScript
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Specifies whether cells that belong to this column can display multiple lines of data.")
ISNet.Serialization.XmlSerializableAttribute()
public function get,set AllowMultiLine : System.boolean
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies whether cells that belong to this column can display multiple lines of data.")]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property System.bool get_AllowMultiLine();
public: __property void set_AllowMultiLine(
   System.bool value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies whether cells that belong to this column can display multiple lines of data.")]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property System.bool AllowMultiLine {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridColumn Class
WebGridColumn Members


AllowSizing Property

[image]
Intersoft WebGrid Documentation
AllowSizing Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridColumn Class : AllowSizing Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies whether or not to allow users resize the column's width.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property AllowSizing As ColumnSizing
Visual Basic (Usage) Copy Code
Dim instance As WebGridColumn
Dim value As ColumnSizing

instance.AllowSizing = value

value = instance.AllowSizing
C#
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether or not to allow users resize the column's width.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public ColumnSizing AllowSizing {get; set;}
Delphi
public read-write property AllowSizing: ColumnSizing;
JScript
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Specifies whether or not to allow users resize the column's width.")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set AllowSizing : ColumnSizing
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether or not to allow users resize the column's width.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property ColumnSizing get_AllowSizing();
public: __property void set_AllowSizing(
   ColumnSizing value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether or not to allow users resize the column's width.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property ColumnSizing AllowSizing {
   ColumnSizing get();
   void set (    ColumnSizing value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridColumn Class
WebGridColumn Members


AllowSorting Property

[image]
Intersoft WebGrid Documentation
AllowSorting Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridColumn Class : AllowSorting Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies whether or not to allow users sort columns from within WebGrid.")>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Property AllowSorting As Sorting
Visual Basic (Usage) Copy Code
Dim instance As WebGridColumn
Dim value As Sorting

instance.AllowSorting = value

value = instance.AllowSorting
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether or not to allow users sort columns from within WebGrid.")]
[ISNet.Serialization.XmlSerializableAttribute()]
public Sorting AllowSorting {get; set;}
Delphi
public read-write property AllowSorting: Sorting;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Specifies whether or not to allow users sort columns from within WebGrid.")
ISNet.Serialization.XmlSerializableAttribute()
public function get,set AllowSorting : Sorting
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether or not to allow users sort columns from within WebGrid.")]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property Sorting get_AllowSorting();
public: __property void set_AllowSorting(
   Sorting value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether or not to allow users sort columns from within WebGrid.")]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property Sorting AllowSorting {
   Sorting get();
   void set (    Sorting value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridColumn Class
WebGridColumn Members


Bound Property

[image]
Intersoft WebGrid Documentation
Bound Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridColumn Class : Bound Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies whether the column is bound to the DataColumn of DataSource.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
Public Property Bound As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebGridColumn
Dim value As System.Boolean

instance.Bound = value

value = instance.Bound
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether the column is bound to the DataColumn of DataSource.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public System.bool Bound {get; set;}
Delphi
public read-write property Bound: System.Boolean;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DescriptionAttribute("Specifies whether the column is bound to the DataColumn of DataSource.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
public function get,set Bound : System.boolean
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether the column is bound to the DataColumn of DataSource.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.bool get_Bound();
public: __property void set_Bound(
   System.bool value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether the column is bound to the DataColumn of DataSource.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.bool Bound {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridColumn Class
WebGridColumn Members


ButtonAutoPostback Property

[image]
Intersoft WebGrid Documentation
ButtonAutoPostback Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridColumn Class : ButtonAutoPostback Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Gets or sets whether postback should be automatically performed on button click.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
Public Property ButtonAutoPostback As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebGridColumn
Dim value As System.Boolean

instance.ButtonAutoPostback = value

value = instance.ButtonAutoPostback
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets whether postback should be automatically performed on button click.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public System.bool ButtonAutoPostback {get; set;}
Delphi
public read-write property ButtonAutoPostback: System.Boolean;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets whether postback should be automatically performed on button click.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
public function get,set ButtonAutoPostback : System.boolean
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets whether postback should be automatically performed on button click.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.bool get_ButtonAutoPostback();
public: __property void set_ButtonAutoPostback(
   System.bool value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets whether postback should be automatically performed on button click.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.bool ButtonAutoPostback {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridColumn Class
WebGridColumn Members


ButtonImage Property

[image]
Intersoft WebGrid Documentation
ButtonImage Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridColumn Class : ButtonImage Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Gets or sets the image of the button when the ColumnType of the WebGridColumn is set to ButtonImage.")>
Public Property ButtonImage As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebGridColumn
Dim value As System.String

instance.ButtonImage = value

value = instance.ButtonImage
C#
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the image of the button when the ColumnType of the WebGridColumn is set to ButtonImage.")]
public System.string ButtonImage {get; set;}
Delphi
public read-write property ButtonImage: System.String;
JScript
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the image of the button when the ColumnType of the WebGridColumn is set to ButtonImage.")
public function get,set ButtonImage : System.String
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the image of the button when the ColumnType of the WebGridColumn is set to ButtonImage.")]
public: __property System.string* get_ButtonImage();
public: __property void set_ButtonImage(
   System.string* value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the image of the button when the ColumnType of the WebGridColumn is set to ButtonImage.")]
public:
property System.String^ ButtonImage {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridColumn Class
WebGridColumn Members


ButtonPostbackMode Property

[image]
Intersoft WebGrid Documentation
ButtonPostbackMode Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridColumn Class : ButtonPostbackMode Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Gets or sets whether the postback should be performed by using OnTheFly or FullPagePostback mode when a button is clicked.")>
Public Property ButtonPostbackMode As PostbackMode
Visual Basic (Usage) Copy Code
Dim instance As WebGridColumn
Dim value As PostbackMode

instance.ButtonPostbackMode = value

value = instance.ButtonPostbackMode
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets whether the postback should be performed by using OnTheFly or FullPagePostback mode when a button is clicked.")]
public PostbackMode ButtonPostbackMode {get; set;}
Delphi
public read-write property ButtonPostbackMode: PostbackMode;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets whether the postback should be performed by using OnTheFly or FullPagePostback mode when a button is clicked.")
public function get,set ButtonPostbackMode : PostbackMode
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets whether the postback should be performed by using OnTheFly or FullPagePostback mode when a button is clicked.")]
public: __property PostbackMode get_ButtonPostbackMode();
public: __property void set_ButtonPostbackMode(
   PostbackMode value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets whether the postback should be performed by using OnTheFly or FullPagePostback mode when a button is clicked.")]
public:
property PostbackMode ButtonPostbackMode {
   PostbackMode get();
   void set (    PostbackMode value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridColumn Class
WebGridColumn Members


ButtonStyle Property

[image]
Intersoft WebGrid Documentation
ButtonStyle Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridColumn Class : ButtonStyle Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("The style of button object of Button Column.")>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
Public Property ButtonStyle As WebGridFormatStyle
Visual Basic (Usage) Copy Code
Dim instance As WebGridColumn
Dim value As WebGridFormatStyle

instance.ButtonStyle = value

value = instance.ButtonStyle
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("The style of button object of Button Column.")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
public WebGridFormatStyle ButtonStyle {get; set;}
Delphi
public read-write property ButtonStyle: WebGridFormatStyle;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("The style of button object of Button Column.")
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
public function get,set ButtonStyle : WebGridFormatStyle
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("The style of button object of Button Column.")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
public: __property WebGridFormatStyle* get_ButtonStyle();
public: __property void set_ButtonStyle(
   WebGridFormatStyle* value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("The style of button object of Button Column.")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
public:
property WebGridFormatStyle^ ButtonStyle {
   WebGridFormatStyle^ get();
   void set (    WebGridFormatStyle^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridColumn Class
WebGridColumn Members


ButtonText Property

[image]
Intersoft WebGrid Documentation
ButtonText Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridColumn Class : ButtonText Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Gets or sets the default button's text of column which ColumnType is Button.")>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property ButtonText As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebGridColumn
Dim value As System.String

instance.ButtonText = value

value = instance.ButtonText
C#
[System.ComponentModel.DescriptionAttribute("Gets or sets the default button's text of column which ColumnType is Button.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.string ButtonText {get; set;}
Delphi
public read-write property ButtonText: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Gets or sets the default button's text of column which ColumnType is Button.")
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set ButtonText : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Gets or sets the default button's text of column which ColumnType is Button.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.string* get_ButtonText();
public: __property void set_ButtonText(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Gets or sets the default button's text of column which ColumnType is Button.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.String^ ButtonText {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridColumn Class
WebGridColumn Members


CanAddToChartCategories Property

[image]
Intersoft WebGrid Documentation
CanAddToChartCategories Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridColumn Class : CanAddToChartCategories Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Determines whether this column can be added to Chart Categories Zone.")>
<System.ComponentModel.CategoryAttribute("Pivot Charting")>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Property CanAddToChartCategories As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebGridColumn
Dim value As System.Boolean

instance.CanAddToChartCategories = value

value = instance.CanAddToChartCategories
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Determines whether this column can be added to Chart Categories Zone.")]
[System.ComponentModel.CategoryAttribute("Pivot Charting")]
[ISNet.Serialization.XmlSerializableAttribute()]
public System.bool CanAddToChartCategories {get; set;}
Delphi
public read-write property CanAddToChartCategories: System.Boolean;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Determines whether this column can be added to Chart Categories Zone.")
System.ComponentModel.CategoryAttribute("Pivot Charting")
ISNet.Serialization.XmlSerializableAttribute()
public function get,set CanAddToChartCategories : System.boolean
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Determines whether this column can be added to Chart Categories Zone.")]
[System.ComponentModel.CategoryAttribute("Pivot Charting")]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property System.bool get_CanAddToChartCategories();
public: __property void set_CanAddToChartCategories(
   System.bool value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Determines whether this column can be added to Chart Categories Zone.")]
[System.ComponentModel.CategoryAttribute("Pivot Charting")]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property System.bool CanAddToChartCategories {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridColumn Class
WebGridColumn Members


CanAddToChartData Property

[image]
Intersoft WebGrid Documentation
CanAddToChartData Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridColumn Class : CanAddToChartData Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Determines whether this column can be added to Chart Data Zone.")>
<System.ComponentModel.CategoryAttribute("Pivot Charting")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property CanAddToChartData As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebGridColumn
Dim value As System.Boolean

instance.CanAddToChartData = value

value = instance.CanAddToChartData
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Determines whether this column can be added to Chart Data Zone.")]
[System.ComponentModel.CategoryAttribute("Pivot Charting")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.bool CanAddToChartData {get; set;}
Delphi
public read-write property CanAddToChartData: System.Boolean;
JScript
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DescriptionAttribute("Determines whether this column can be added to Chart Data Zone.")
System.ComponentModel.CategoryAttribute("Pivot Charting")
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set CanAddToChartData : System.boolean
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Determines whether this column can be added to Chart Data Zone.")]
[System.ComponentModel.CategoryAttribute("Pivot Charting")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.bool get_CanAddToChartData();
public: __property void set_CanAddToChartData(
   System.bool value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Determines whether this column can be added to Chart Data Zone.")]
[System.ComponentModel.CategoryAttribute("Pivot Charting")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.bool CanAddToChartData {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridColumn Class
WebGridColumn Members


CanAddToChartFilter Property

[image]
Intersoft WebGrid Documentation
CanAddToChartFilter Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridColumn Class : CanAddToChartFilter Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Determines whether this column can be added to Chart Filter Zone.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Pivot Charting")>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Property CanAddToChartFilter As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebGridColumn
Dim value As System.Boolean

instance.CanAddToChartFilter = value

value = instance.CanAddToChartFilter
C#
[System.ComponentModel.DescriptionAttribute("Determines whether this column can be added to Chart Filter Zone.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Pivot Charting")]
[ISNet.Serialization.XmlSerializableAttribute()]
public System.bool CanAddToChartFilter {get; set;}
Delphi
public read-write property CanAddToChartFilter: System.Boolean;
JScript
System.ComponentModel.DescriptionAttribute("Determines whether this column can be added to Chart Filter Zone.")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Pivot Charting")
ISNet.Serialization.XmlSerializableAttribute()
public function get,set CanAddToChartFilter : System.boolean
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Determines whether this column can be added to Chart Filter Zone.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Pivot Charting")]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property System.bool get_CanAddToChartFilter();
public: __property void set_CanAddToChartFilter(
   System.bool value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Determines whether this column can be added to Chart Filter Zone.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Pivot Charting")]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property System.bool CanAddToChartFilter {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridColumn Class
WebGridColumn Members


CanAddToChartSeries Property

[image]
Intersoft WebGrid Documentation
CanAddToChartSeries Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridColumn Class : CanAddToChartSeries Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Determines whether this column can be added to Chart Series Zone.")>
<System.ComponentModel.CategoryAttribute("Pivot Charting")>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Property CanAddToChartSeries As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebGridColumn
Dim value As System.Boolean

instance.CanAddToChartSeries = value

value = instance.CanAddToChartSeries
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Determines whether this column can be added to Chart Series Zone.")]
[System.ComponentModel.CategoryAttribute("Pivot Charting")]
[ISNet.Serialization.XmlSerializableAttribute()]
public System.bool CanAddToChartSeries {get; set;}
Delphi
public read-write property CanAddToChartSeries: System.Boolean;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Determines whether this column can be added to Chart Series Zone.")
System.ComponentModel.CategoryAttribute("Pivot Charting")
ISNet.Serialization.XmlSerializableAttribute()
public function get,set CanAddToChartSeries : System.boolean
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Determines whether this column can be added to Chart Series Zone.")]
[System.ComponentModel.CategoryAttribute("Pivot Charting")]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property System.bool get_CanAddToChartSeries();
public: __property void set_CanAddToChartSeries(
   System.bool value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Determines whether this column can be added to Chart Series Zone.")]
[System.ComponentModel.CategoryAttribute("Pivot Charting")]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property System.bool CanAddToChartSeries {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridColumn Class
WebGridColumn Members


Caption Property

[image]
Intersoft WebGrid Documentation
Caption Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridColumn Class : Caption Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Gets or sets the text displayed in the column's heading area.")>
Public Property Caption As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebGridColumn
Dim value As System.String

instance.Caption = value

value = instance.Caption
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the text displayed in the column's heading area.")]
public System.string Caption {get; set;}
Delphi
public read-write property Caption: System.String;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the text displayed in the column's heading area.")
public function get,set Caption : System.String
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the text displayed in the column's heading area.")]
public: __property System.string* get_Caption();
public: __property void set_Caption(
   System.string* value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the text displayed in the column's heading area.")]
public:
property System.String^ Caption {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridColumn Class
WebGridColumn Members


CaseSensitiveGrouping Property

[image]
Intersoft WebGrid Documentation
CaseSensitiveGrouping Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridColumn Class : CaseSensitiveGrouping Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies whether the grouping should be case sensitive when comparing text values.")>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Property CaseSensitiveGrouping As CaseSensitive
Visual Basic (Usage) Copy Code
Dim instance As WebGridColumn
Dim value As CaseSensitive

instance.CaseSensitiveGrouping = value

value = instance.CaseSensitiveGrouping
C#
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether the grouping should be case sensitive when comparing text values.")]
[ISNet.Serialization.XmlSerializableAttribute()]
public CaseSensitive CaseSensitiveGrouping {get; set;}
Delphi
public read-write property CaseSensitiveGrouping: CaseSensitive;
JScript
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DescriptionAttribute("Specifies whether the grouping should be case sensitive when comparing text values.")
ISNet.Serialization.XmlSerializableAttribute()
public function get,set CaseSensitiveGrouping : CaseSensitive
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether the grouping should be case sensitive when comparing text values.")]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property CaseSensitive get_CaseSensitiveGrouping();
public: __property void set_CaseSensitiveGrouping(
   CaseSensitive value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether the grouping should be case sensitive when comparing text values.")]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property CaseSensitive CaseSensitiveGrouping {
   CaseSensitive get();
   void set (    CaseSensitive value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridColumn Class
WebGridColumn Members


CellImage Property

[image]
Intersoft WebGrid Documentation
CellImage Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridColumn Class : CellImage Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Gets or sets the image filename that will be displayed in cells that belong to this column.")>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property CellImage As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebGridColumn
Dim value As System.String

instance.CellImage = value

value = instance.CellImage
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the image filename that will be displayed in cells that belong to this column.")]
[ISNet.Serialization.BinarySerializableAttribute()]
public System.string CellImage {get; set;}
Delphi
public read-write property CellImage: System.String;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the image filename that will be displayed in cells that belong to this column.")
ISNet.Serialization.BinarySerializableAttribute()
public function get,set CellImage : System.String
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the image filename that will be displayed in cells that belong to this column.")]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.string* get_CellImage();
public: __property void set_CellImage(
   System.string* value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the image filename that will be displayed in cells that belong to this column.")]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.String^ CellImage {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridColumn Class
WebGridColumn Members


CellStyle Property

[image]
Intersoft WebGrid Documentation
CellStyle Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridColumn Class : CellStyle Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Gets or sets the style applied to the cells of this column.")>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property CellStyle As WebGridFormatStyle
Visual Basic (Usage) Copy Code
Dim instance As WebGridColumn
Dim value As WebGridFormatStyle

instance.CellStyle = value

value = instance.CellStyle
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the style applied to the cells of this column.")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.Serialization.BinarySerializableAttribute()]
public WebGridFormatStyle CellStyle {get; set;}
Delphi
public read-write property CellStyle: WebGridFormatStyle;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the style applied to the cells of this column.")
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
ISNet.Serialization.BinarySerializableAttribute()
public function get,set CellStyle : WebGridFormatStyle
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the style applied to the cells of this column.")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property WebGridFormatStyle* get_CellStyle();
public: __property void set_CellStyle(
   WebGridFormatStyle* value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the style applied to the cells of this column.")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property WebGridFormatStyle^ CellStyle {
   WebGridFormatStyle^ get();
   void set (    WebGridFormatStyle^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridColumn Class
WebGridColumn Members


ClipboardCopyMode Property

[image]
Intersoft WebGrid Documentation
ClipboardCopyMode Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridColumn Class : ClipboardCopyMode Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Specifies whether text or value should be copied in ClipboardCopyMode.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property ClipboardCopyMode As ClipboardCopyMode
Visual Basic (Usage) Copy Code
Dim instance As WebGridColumn
Dim value As ClipboardCopyMode

instance.ClipboardCopyMode = value

value = instance.ClipboardCopyMode
C#
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies whether text or value should be copied in ClipboardCopyMode.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public ClipboardCopyMode ClipboardCopyMode {get; set;}
Delphi
public read-write property ClipboardCopyMode: ClipboardCopyMode;
JScript
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Specifies whether text or value should be copied in ClipboardCopyMode.")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get,set ClipboardCopyMode : ClipboardCopyMode
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies whether text or value should be copied in ClipboardCopyMode.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property ClipboardCopyMode get_ClipboardCopyMode();
public: __property void set_ClipboardCopyMode(
   ClipboardCopyMode value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies whether text or value should be copied in ClipboardCopyMode.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property ClipboardCopyMode ClipboardCopyMode {
   ClipboardCopyMode get();
   void set (    ClipboardCopyMode value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridColumn Class
WebGridColumn Members


ColumnType Property

[image]
Intersoft WebGrid Documentation
ColumnType Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridColumn Class : ColumnType Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Gets or sets the type of the column.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Property ColumnType As ColumnType
Visual Basic (Usage) Copy Code
Dim instance As WebGridColumn
Dim value As ColumnType

instance.ColumnType = value

value = instance.ColumnType
C#
[System.ComponentModel.DescriptionAttribute("Gets or sets the type of the column.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
public ColumnType ColumnType {get; set;}
Delphi
public read-write property ColumnType: ColumnType;
JScript
System.ComponentModel.DescriptionAttribute("Gets or sets the type of the column.")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.XmlSerializableAttribute()
public function get,set ColumnType : ColumnType
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Gets or sets the type of the column.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property ColumnType get_ColumnType();
public: __property void set_ColumnType(
   ColumnType value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Gets or sets the type of the column.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property ColumnType ColumnType {
   ColumnType get();
   void set (    ColumnType value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridColumn Class
WebGridColumn Members


CustomEditorName Property

[image]
Intersoft WebGrid Documentation
CustomEditorName Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridColumn Class : CustomEditorName Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute()>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebGrid.CustomEditorNameEditor, ISNet.WebUI.WebGrid, Version=9.0.7200.1, Culture=neutral, PublicKeyToken=3e60b85fb8502d5e")>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Property CustomEditorName As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebGridColumn
Dim value As System.String

instance.CustomEditorName = value

value = instance.CustomEditorName
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebGrid.CustomEditorNameEditor, ISNet.WebUI.WebGrid, Version=9.0.7200.1, Culture=neutral, PublicKeyToken=3e60b85fb8502d5e")]
[ISNet.Serialization.XmlSerializableAttribute()]
public System.string CustomEditorName {get; set;}
Delphi
public read-write property CustomEditorName: System.String;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute()
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebGrid.CustomEditorNameEditor, ISNet.WebUI.WebGrid, Version=9.0.7200.1, Culture=neutral, PublicKeyToken=3e60b85fb8502d5e")
ISNet.Serialization.XmlSerializableAttribute()
public function get,set CustomEditorName : System.String
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebGrid.CustomEditorNameEditor, ISNet.WebUI.WebGrid, Version=9.0.7200.1, Culture=neutral, PublicKeyToken=3e60b85fb8502d5e")]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property System.string* get_CustomEditorName();
public: __property void set_CustomEditorName(
   System.string* value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebGrid.CustomEditorNameEditor, ISNet.WebUI.WebGrid, Version=9.0.7200.1, Culture=neutral, PublicKeyToken=3e60b85fb8502d5e")]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property System.String^ CustomEditorName {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridColumn Class
WebGridColumn Members


CustomEditorProperties Property

[image]
Intersoft WebGrid Documentation
CustomEditorProperties Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridColumn Class : CustomEditorProperties Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property CustomEditorProperties As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebGridColumn
Dim value As System.String

instance.CustomEditorProperties = value

value = instance.CustomEditorProperties
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public System.string CustomEditorProperties {get; set;}
Delphi
public read-write property CustomEditorProperties: System.String;
JScript
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get,set CustomEditorProperties : System.String
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.string* get_CustomEditorProperties();
public: __property void set_CustomEditorProperties(
   System.string* value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.String^ CustomEditorProperties {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridColumn Class
WebGridColumn Members


CustomEditorServerId Property

[image]
Intersoft WebGrid Documentation
CustomEditorServerId Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridColumn Class : CustomEditorServerId Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute()>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebGrid.CustomEditorEditor, ISNet.WebUI.WebGrid, Version=9.0.7200.1, Culture=neutral, PublicKeyToken=3e60b85fb8502d5e")>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Property CustomEditorServerId As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebGridColumn
Dim value As System.String

instance.CustomEditorServerId = value

value = instance.CustomEditorServerId
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebGrid.CustomEditorEditor, ISNet.WebUI.WebGrid, Version=9.0.7200.1, Culture=neutral, PublicKeyToken=3e60b85fb8502d5e")]
[ISNet.Serialization.XmlSerializableAttribute()]
public System.string CustomEditorServerId {get; set;}
Delphi
public read-write property CustomEditorServerId: System.String;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute()
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebGrid.CustomEditorEditor, ISNet.WebUI.WebGrid, Version=9.0.7200.1, Culture=neutral, PublicKeyToken=3e60b85fb8502d5e")
ISNet.Serialization.XmlSerializableAttribute()
public function get,set CustomEditorServerId : System.String
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebGrid.CustomEditorEditor, ISNet.WebUI.WebGrid, Version=9.0.7200.1, Culture=neutral, PublicKeyToken=3e60b85fb8502d5e")]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property System.string* get_CustomEditorServerId();
public: __property void set_CustomEditorServerId(
   System.string* value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebGrid.CustomEditorEditor, ISNet.WebUI.WebGrid, Version=9.0.7200.1, Culture=neutral, PublicKeyToken=3e60b85fb8502d5e")]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property System.String^ CustomEditorServerId {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridColumn Class
WebGridColumn Members


DataFormatString Property

[image]
Intersoft WebGrid Documentation
DataFormatString Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridColumn Class : DataFormatString Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Gets or sets the format to use when rendering values.")>
Public Property DataFormatString As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebGridColumn
Dim value As System.String

instance.DataFormatString = value

value = instance.DataFormatString
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the format to use when rendering values.")]
public System.string DataFormatString {get; set;}
Delphi
public read-write property DataFormatString: System.String;
JScript
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the format to use when rendering values.")
public function get,set DataFormatString : System.String
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the format to use when rendering values.")]
public: __property System.string* get_DataFormatString();
public: __property void set_DataFormatString(
   System.string* value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the format to use when rendering values.")]
public:
property System.String^ DataFormatString {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridColumn Class
WebGridColumn Members


DataMember Property

[image]
Intersoft WebGrid Documentation
DataMember Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridColumn Class : DataMember Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Gets or sets the name of the data column for which its data value will be displayed.")>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebGrid.DataFieldEditor, ISNet.WebUI.WebGrid, Version=9.0.7200.1, Culture=neutral, PublicKeyToken=3e60b85fb8502d5e")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property DataMember As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebGridColumn
Dim value As System.String

instance.DataMember = value

value = instance.DataMember
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the name of the data column for which its data value will be displayed.")]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebGrid.DataFieldEditor, ISNet.WebUI.WebGrid, Version=9.0.7200.1, Culture=neutral, PublicKeyToken=3e60b85fb8502d5e")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.string DataMember {get; set;}
Delphi
public read-write property DataMember: System.String;
JScript
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the name of the data column for which its data value will be displayed.")
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebGrid.DataFieldEditor, ISNet.WebUI.WebGrid, Version=9.0.7200.1, Culture=neutral, PublicKeyToken=3e60b85fb8502d5e")
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set DataMember : System.String
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the name of the data column for which its data value will be displayed.")]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebGrid.DataFieldEditor, ISNet.WebUI.WebGrid, Version=9.0.7200.1, Culture=neutral, PublicKeyToken=3e60b85fb8502d5e")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.string* get_DataMember();
public: __property void set_DataMember(
   System.string* value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the name of the data column for which its data value will be displayed.")]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebGrid.DataFieldEditor, ISNet.WebUI.WebGrid, Version=9.0.7200.1, Culture=neutral, PublicKeyToken=3e60b85fb8502d5e")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.String^ DataMember {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridColumn Class
WebGridColumn Members


DefaultFilterType Property

[image]
Intersoft WebGrid Documentation
DefaultFilterType Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridColumn Class : DefaultFilterType Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Gets or sets the default filter type of this column.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property DefaultFilterType As ColumnFilterType
Visual Basic (Usage) Copy Code
Dim instance As WebGridColumn
Dim value As ColumnFilterType

instance.DefaultFilterType = value

value = instance.DefaultFilterType
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the default filter type of this column.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public ColumnFilterType DefaultFilterType {get; set;}
Delphi
public read-write property DefaultFilterType: ColumnFilterType;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the default filter type of this column.")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get,set DefaultFilterType : ColumnFilterType
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the default filter type of this column.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property ColumnFilterType get_DefaultFilterType();
public: __property void set_DefaultFilterType(
   ColumnFilterType value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the default filter type of this column.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property ColumnFilterType DefaultFilterType {
   ColumnFilterType get();
   void set (    ColumnFilterType value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridColumn Class
WebGridColumn Members


DefaultText Property

[image]
Intersoft WebGrid Documentation
DefaultText Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridColumn Class : DefaultText Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies the default text of this column when new row is added.")>
Public Property DefaultText As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebGridColumn
Dim value As System.String

instance.DefaultText = value

value = instance.DefaultText
C#
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the default text of this column when new row is added.")]
public System.string DefaultText {get; set;}
Delphi
public read-write property DefaultText: System.String;
JScript
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the default text of this column when new row is added.")
public function get,set DefaultText : System.String
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the default text of this column when new row is added.")]
public: __property System.string* get_DefaultText();
public: __property void set_DefaultText(
   System.string* value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the default text of this column when new row is added.")]
public:
property System.String^ DefaultText {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridColumn Class
WebGridColumn Members


DefaultValue Property

[image]
Intersoft WebGrid Documentation
DefaultValue Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridColumn Class : DefaultValue Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Gets or sets the default value of the column when new row is added.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Property DefaultValue As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebGridColumn
Dim value As System.String

instance.DefaultValue = value

value = instance.DefaultValue
C#
[System.ComponentModel.DescriptionAttribute("Gets or sets the default value of the column when new row is added.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public System.string DefaultValue {get; set;}
Delphi
public read-write property DefaultValue: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Gets or sets the default value of the column when new row is added.")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute()
public function get,set DefaultValue : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Gets or sets the default value of the column when new row is added.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property System.string* get_DefaultValue();
public: __property void set_DefaultValue(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Gets or sets the default value of the column when new row is added.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property System.String^ DefaultValue {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridColumn Class
WebGridColumn Members


EditInfoImage Property

[image]
Intersoft WebGrid Documentation
EditInfoImage Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridColumn Class : EditInfoImage Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Gets or sets the image to be displayed in status bar when the cell of this column is being edited.")>
Public Property EditInfoImage As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebGridColumn
Dim value As System.String

instance.EditInfoImage = value

value = instance.EditInfoImage
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the image to be displayed in status bar when the cell of this column is being edited.")]
public System.string EditInfoImage {get; set;}
Delphi
public read-write property EditInfoImage: System.String;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the image to be displayed in status bar when the cell of this column is being edited.")
public function get,set EditInfoImage : System.String
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the image to be displayed in status bar when the cell of this column is being edited.")]
public: __property System.string* get_EditInfoImage();
public: __property void set_EditInfoImage(
   System.string* value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the image to be displayed in status bar when the cell of this column is being edited.")]
public:
property System.String^ EditInfoImage {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridColumn Class
WebGridColumn Members


EditInfoText Property

[image]
Intersoft WebGrid Documentation
EditInfoText Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridColumn Class : EditInfoText Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Gets or sets the text to be displayed in status bar when the cell of this column is being edited.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property EditInfoText As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebGridColumn
Dim value As System.String

instance.EditInfoText = value

value = instance.EditInfoText
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the text to be displayed in status bar when the cell of this column is being edited.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public System.string EditInfoText {get; set;}
Delphi
public read-write property EditInfoText: System.String;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the text to be displayed in status bar when the cell of this column is being edited.")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get,set EditInfoText : System.String
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the text to be displayed in status bar when the cell of this column is being edited.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.string* get_EditInfoText();
public: __property void set_EditInfoText(
   System.string* value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the text to be displayed in status bar when the cell of this column is being edited.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.String^ EditInfoText {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridColumn Class
WebGridColumn Members


EditType Property

[image]
Intersoft WebGrid Documentation
EditType Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridColumn Class : EditType Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Gets or sets the edit control for the column.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
Public Property EditType As EditType
Visual Basic (Usage) Copy Code
Dim instance As WebGridColumn
Dim value As EditType

instance.EditType = value

value = instance.EditType
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the edit control for the column.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public EditType EditType {get; set;}
Delphi
public read-write property EditType: EditType;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the edit control for the column.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
public function get,set EditType : EditType
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the edit control for the column.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public: __property EditType get_EditType();
public: __property void set_EditType(
   EditType value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the edit control for the column.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public:
property EditType EditType {
   EditType get();
   void set (    EditType value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridColumn Class
WebGridColumn Members


FilterEditType Property

[image]
Intersoft WebGrid Documentation
FilterEditType Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridColumn Class : FilterEditType Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Gets or sets the filter edit type for this column.")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property FilterEditType As FilterEditType
Visual Basic (Usage) Copy Code
Dim instance As WebGridColumn
Dim value As FilterEditType

instance.FilterEditType = value

value = instance.FilterEditType
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the filter edit type for this column.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public FilterEditType FilterEditType {get; set;}
Delphi
public read-write property FilterEditType: FilterEditType;
JScript
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the filter edit type for this column.")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set FilterEditType : FilterEditType
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the filter edit type for this column.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property FilterEditType get_FilterEditType();
public: __property void set_FilterEditType(
   FilterEditType value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the filter edit type for this column.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property FilterEditType FilterEditType {
   FilterEditType get();
   void set (    FilterEditType value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridColumn Class
WebGridColumn Members


FilterKeyField Property

[image]
Intersoft WebGrid Documentation
FilterKeyField Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridColumn Class : FilterKeyField Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Gets or sets the filter key field for WebGridFilter object.")>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebGrid.DataFieldEditor, ISNet.WebUI.WebGrid, Version=9.0.7200.1, Culture=neutral, PublicKeyToken=3e60b85fb8502d5e")>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property FilterKeyField As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebGridColumn
Dim value As System.String

instance.FilterKeyField = value

value = instance.FilterKeyField
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the filter key field for WebGridFilter object.")]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebGrid.DataFieldEditor, ISNet.WebUI.WebGrid, Version=9.0.7200.1, Culture=neutral, PublicKeyToken=3e60b85fb8502d5e")]
[ISNet.Serialization.BinarySerializableAttribute()]
public System.string FilterKeyField {get; set;}
Delphi
public read-write property FilterKeyField: System.String;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the filter key field for WebGridFilter object.")
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebGrid.DataFieldEditor, ISNet.WebUI.WebGrid, Version=9.0.7200.1, Culture=neutral, PublicKeyToken=3e60b85fb8502d5e")
ISNet.Serialization.BinarySerializableAttribute()
public function get,set FilterKeyField : System.String
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the filter key field for WebGridFilter object.")]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebGrid.DataFieldEditor, ISNet.WebUI.WebGrid, Version=9.0.7200.1, Culture=neutral, PublicKeyToken=3e60b85fb8502d5e")]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.string* get_FilterKeyField();
public: __property void set_FilterKeyField(
   System.string* value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the filter key field for WebGridFilter object.")]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebGrid.DataFieldEditor, ISNet.WebUI.WebGrid, Version=9.0.7200.1, Culture=neutral, PublicKeyToken=3e60b85fb8502d5e")]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.String^ FilterKeyField {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridColumn Class
WebGridColumn Members


FooterStyle Property

[image]
Intersoft WebGrid Documentation
FooterStyle Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridColumn Class : FooterStyle Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Gets or sets the style applied to the column's footer.")>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property FooterStyle As WebGridFormatStyle
Visual Basic (Usage) Copy Code
Dim instance As WebGridColumn
Dim value As WebGridFormatStyle

instance.FooterStyle = value

value = instance.FooterStyle
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the style applied to the column's footer.")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.Serialization.BinarySerializableAttribute()]
public WebGridFormatStyle FooterStyle {get; set;}
Delphi
public read-write property FooterStyle: WebGridFormatStyle;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the style applied to the column's footer.")
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
ISNet.Serialization.BinarySerializableAttribute()
public function get,set FooterStyle : WebGridFormatStyle
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the style applied to the column's footer.")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property WebGridFormatStyle* get_FooterStyle();
public: __property void set_FooterStyle(
   WebGridFormatStyle* value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the style applied to the column's footer.")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property WebGridFormatStyle^ FooterStyle {
   WebGridFormatStyle^ get();
   void set (    WebGridFormatStyle^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridColumn Class
WebGridColumn Members


FooterText Property

[image]
Intersoft WebGrid Documentation
FooterText Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridColumn Class : FooterText Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Gets or sets the text that will be displayed in column's footer.")>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property FooterText As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebGridColumn
Dim value As System.String

instance.FooterText = value

value = instance.FooterText
C#
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the text that will be displayed in column's footer.")]
[ISNet.Serialization.BinarySerializableAttribute()]
public System.string FooterText {get; set;}
Delphi
public read-write property FooterText: System.String;
JScript
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the text that will be displayed in column's footer.")
ISNet.Serialization.BinarySerializableAttribute()
public function get,set FooterText : System.String
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the text that will be displayed in column's footer.")]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.string* get_FooterText();
public: __property void set_FooterText(
   System.string* value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the text that will be displayed in column's footer.")]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.String^ FooterText {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridColumn Class
WebGridColumn Members


GroupEmptyString Property

[image]
Intersoft WebGrid Documentation
GroupEmptyString Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridColumn Class : GroupEmptyString Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Gets or sets the text displayed in a group row when the value grouped is an empty string or null.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
Public Property GroupEmptyString As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebGridColumn
Dim value As System.String

instance.GroupEmptyString = value

value = instance.GroupEmptyString
C#
[System.ComponentModel.DescriptionAttribute("Gets or sets the text displayed in a group row when the value grouped is an empty string or null.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public System.string GroupEmptyString {get; set;}
Delphi
public read-write property GroupEmptyString: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Gets or sets the text displayed in a group row when the value grouped is an empty string or null.")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
public function get,set GroupEmptyString : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Gets or sets the text displayed in a group row when the value grouped is an empty string or null.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.string* get_GroupEmptyString();
public: __property void set_GroupEmptyString(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Gets or sets the text displayed in a group row when the value grouped is an empty string or null.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.String^ GroupEmptyString {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridColumn Class
WebGridColumn Members


GroupInterval Property

[image]
Intersoft WebGrid Documentation
GroupInterval Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridColumn Class : GroupInterval Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Gets or sets a value that determines how groups should be calculated.")>
Public Property GroupInterval As GroupInterval
Visual Basic (Usage) Copy Code
Dim instance As WebGridColumn
Dim value As GroupInterval

instance.GroupInterval = value

value = instance.GroupInterval
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets a value that determines how groups should be calculated.")]
public GroupInterval GroupInterval {get; set;}
Delphi
public read-write property GroupInterval: GroupInterval;
JScript
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets a value that determines how groups should be calculated.")
public function get,set GroupInterval : GroupInterval
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets a value that determines how groups should be calculated.")]
public: __property GroupInterval get_GroupInterval();
public: __property void set_GroupInterval(
   GroupInterval value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets a value that determines how groups should be calculated.")]
public:
property GroupInterval GroupInterval {
   GroupInterval get();
   void set (    GroupInterval value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridColumn Class
WebGridColumn Members


GroupRowInfoFormat Property

[image]
Intersoft WebGrid Documentation
GroupRowInfoFormat Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridColumn Class : GroupRowInfoFormat Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Gets or sets the string format for the groupRow's info.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property GroupRowInfoFormat As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebGridColumn
Dim value As System.String

instance.GroupRowInfoFormat = value

value = instance.GroupRowInfoFormat
C#
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the string format for the groupRow's info.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
public System.string GroupRowInfoFormat {get; set;}
Delphi
public read-write property GroupRowInfoFormat: System.String;
JScript
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the string format for the groupRow's info.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get,set GroupRowInfoFormat : System.String
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the string format for the groupRow's info.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.string* get_GroupRowInfoFormat();
public: __property void set_GroupRowInfoFormat(
   System.string* value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the string format for the groupRow's info.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.String^ GroupRowInfoFormat {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridColumn Class
WebGridColumn Members


GroupRowValueFormatString Property

[image]
Intersoft WebGrid Documentation
GroupRowValueFormatString Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridColumn Class : GroupRowValueFormatString Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Gets or sets the string format for the group row's value.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
Public Property GroupRowValueFormatString As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebGridColumn
Dim value As System.String

instance.GroupRowValueFormatString = value

value = instance.GroupRowValueFormatString
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the string format for the group row's value.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public System.string GroupRowValueFormatString {get; set;}
Delphi
public read-write property GroupRowValueFormatString: System.String;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the string format for the group row's value.")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
public function get,set GroupRowValueFormatString : System.String
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the string format for the group row's value.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.string* get_GroupRowValueFormatString();
public: __property void set_GroupRowValueFormatString(
   System.string* value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the string format for the group row's value.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.String^ GroupRowValueFormatString {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridColumn Class
WebGridColumn Members


HeaderImage Property

[image]
Intersoft WebGrid Documentation
HeaderImage Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridColumn Class : HeaderImage Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Gets or sets the image that will be displayed in column heading's area, before the Caption.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property HeaderImage As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebGridColumn
Dim value As System.String

instance.HeaderImage = value

value = instance.HeaderImage
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the image that will be displayed in column heading's area, before the Caption.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.string HeaderImage {get; set;}
Delphi
public read-write property HeaderImage: System.String;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the image that will be displayed in column heading's area, before the Caption.")
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set HeaderImage : System.String
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the image that will be displayed in column heading's area, before the Caption.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.string* get_HeaderImage();
public: __property void set_HeaderImage(
   System.string* value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the image that will be displayed in column heading's area, before the Caption.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.String^ HeaderImage {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridColumn Class
WebGridColumn Members


HeaderStyle Property

[image]
Intersoft WebGrid Documentation
HeaderStyle Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridColumn Class : HeaderStyle Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Gets or sets the style applied to the row.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
Public Property HeaderStyle As WebGridFormatStyle
Visual Basic (Usage) Copy Code
Dim instance As WebGridColumn
Dim value As WebGridFormatStyle

instance.HeaderStyle = value

value = instance.HeaderStyle
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the style applied to the row.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
public WebGridFormatStyle HeaderStyle {get; set;}
Delphi
public read-write property HeaderStyle: WebGridFormatStyle;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the style applied to the row.")
System.ComponentModel.NotifyParentPropertyAttribute()
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
public function get,set HeaderStyle : WebGridFormatStyle
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the style applied to the row.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
public: __property WebGridFormatStyle* get_HeaderStyle();
public: __property void set_HeaderStyle(
   WebGridFormatStyle* value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the style applied to the row.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
public:
property WebGridFormatStyle^ HeaderStyle {
   WebGridFormatStyle^ get();
   void set (    WebGridFormatStyle^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridColumn Class
WebGridColumn Members


HeaderTooltip Property

[image]
Intersoft WebGrid Documentation
HeaderTooltip Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridColumn Class : HeaderTooltip Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Gets or sets the tool tip text that will be displayed when users hover on column heading's area.")>
Public Property HeaderTooltip As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebGridColumn
Dim value As System.String

instance.HeaderTooltip = value

value = instance.HeaderTooltip
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the tool tip text that will be displayed when users hover on column heading's area.")]
public System.string HeaderTooltip {get; set;}
Delphi
public read-write property HeaderTooltip: System.String;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the tool tip text that will be displayed when users hover on column heading's area.")
public function get,set HeaderTooltip : System.String
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the tool tip text that will be displayed when users hover on column heading's area.")]
public: __property System.string* get_HeaderTooltip();
public: __property void set_HeaderTooltip(
   System.string* value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the tool tip text that will be displayed when users hover on column heading's area.")]
public:
property System.String^ HeaderTooltip {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridColumn Class
WebGridColumn Members


HiddenDataMember Property

[image]
Intersoft WebGrid Documentation
HiddenDataMember Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridColumn Class : HiddenDataMember Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Gets or sets the hidden data member to be rendered along with this column.")>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebGrid.DataFieldEditor, ISNet.WebUI.WebGrid, Version=9.0.7200.1, Culture=neutral, PublicKeyToken=3e60b85fb8502d5e")>
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property HiddenDataMember As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebGridColumn
Dim value As System.String

instance.HiddenDataMember = value

value = instance.HiddenDataMember
C#
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the hidden data member to be rendered along with this column.")]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebGrid.DataFieldEditor, ISNet.WebUI.WebGrid, Version=9.0.7200.1, Culture=neutral, PublicKeyToken=3e60b85fb8502d5e")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.string HiddenDataMember {get; set;}
Delphi
public read-write property HiddenDataMember: System.String;
JScript
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the hidden data member to be rendered along with this column.")
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebGrid.DataFieldEditor, ISNet.WebUI.WebGrid, Version=9.0.7200.1, Culture=neutral, PublicKeyToken=3e60b85fb8502d5e")
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set HiddenDataMember : System.String
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the hidden data member to be rendered along with this column.")]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebGrid.DataFieldEditor, ISNet.WebUI.WebGrid, Version=9.0.7200.1, Culture=neutral, PublicKeyToken=3e60b85fb8502d5e")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.string* get_HiddenDataMember();
public: __property void set_HiddenDataMember(
   System.string* value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the hidden data member to be rendered along with this column.")]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebGrid.DataFieldEditor, ISNet.WebUI.WebGrid, Version=9.0.7200.1, Culture=neutral, PublicKeyToken=3e60b85fb8502d5e")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.String^ HiddenDataMember {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridColumn Class
WebGridColumn Members


HtmlHeaders Property

[image]
Intersoft WebGrid Documentation
HtmlHeaders Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridColumn Class : HtmlHeaders Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Gets or sets the headers attribute of this column. Applicable only in 508 Standards mode.")>
Public Property HtmlHeaders As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebGridColumn
Dim value As System.String

instance.HtmlHeaders = value

value = instance.HtmlHeaders
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the headers attribute of this column. Applicable only in 508 Standards mode.")]
public System.string HtmlHeaders {get; set;}
Delphi
public read-write property HtmlHeaders: System.String;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the headers attribute of this column. Applicable only in 508 Standards mode.")
public function get,set HtmlHeaders : System.String
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the headers attribute of this column. Applicable only in 508 Standards mode.")]
public: __property System.string* get_HtmlHeaders();
public: __property void set_HtmlHeaders(
   System.string* value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the headers attribute of this column. Applicable only in 508 Standards mode.")]
public:
property System.String^ HtmlHeaders {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridColumn Class
WebGridColumn Members


HtmlScope Property

[image]
Intersoft WebGrid Documentation
HtmlScope Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridColumn Class : HtmlScope Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Gets or sets the scope attribute for the header of this column. Applicable only in 508 Standards mode.")>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Property HtmlScope As HtmlHeaderScope
Visual Basic (Usage) Copy Code
Dim instance As WebGridColumn
Dim value As HtmlHeaderScope

instance.HtmlScope = value

value = instance.HtmlScope
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the scope attribute for the header of this column. Applicable only in 508 Standards mode.")]
[ISNet.Serialization.XmlSerializableAttribute()]
public HtmlHeaderScope HtmlScope {get; set;}
Delphi
public read-write property HtmlScope: HtmlHeaderScope;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the scope attribute for the header of this column. Applicable only in 508 Standards mode.")
ISNet.Serialization.XmlSerializableAttribute()
public function get,set HtmlScope : HtmlHeaderScope
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the scope attribute for the header of this column. Applicable only in 508 Standards mode.")]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property HtmlHeaderScope get_HtmlScope();
public: __property void set_HtmlScope(
   HtmlHeaderScope value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the scope attribute for the header of this column. Applicable only in 508 Standards mode.")]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property HtmlHeaderScope HtmlScope {
   HtmlHeaderScope get();
   void set (    HtmlHeaderScope value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridColumn Class
WebGridColumn Members


HtmlUniqueId Property

[image]
Intersoft WebGrid Documentation
HtmlUniqueId Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridColumn Class : HtmlUniqueId Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Gets or sets the unique id of this column. Applicable only in 508 Standards mode.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
Public Property HtmlUniqueId As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebGridColumn
Dim value As System.String

instance.HtmlUniqueId = value

value = instance.HtmlUniqueId
C#
[System.ComponentModel.DescriptionAttribute("Gets or sets the unique id of this column. Applicable only in 508 Standards mode.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public System.string HtmlUniqueId {get; set;}
Delphi
public read-write property HtmlUniqueId: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Gets or sets the unique id of this column. Applicable only in 508 Standards mode.")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
public function get,set HtmlUniqueId : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Gets or sets the unique id of this column. Applicable only in 508 Standards mode.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.string* get_HtmlUniqueId();
public: __property void set_HtmlUniqueId(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Gets or sets the unique id of this column. Applicable only in 508 Standards mode.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.String^ HtmlUniqueId {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridColumn Class
WebGridColumn Members


HyperlinkCustomTarget Property

[image]
Intersoft WebGrid Documentation
HyperlinkCustomTarget Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridColumn Class : HyperlinkCustomTarget Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Gets or sets the custom window/frame name used for the hyperlink target.")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property HyperlinkCustomTarget As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebGridColumn
Dim value As System.String

instance.HyperlinkCustomTarget = value

value = instance.HyperlinkCustomTarget
C#
[System.ComponentModel.DescriptionAttribute("Gets or sets the custom window/frame name used for the hyperlink target.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
public System.string HyperlinkCustomTarget {get; set;}
Delphi
public read-write property HyperlinkCustomTarget: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Gets or sets the custom window/frame name used for the hyperlink target.")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get,set HyperlinkCustomTarget : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Gets or sets the custom window/frame name used for the hyperlink target.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.string* get_HyperlinkCustomTarget();
public: __property void set_HyperlinkCustomTarget(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Gets or sets the custom window/frame name used for the hyperlink target.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.String^ HyperlinkCustomTarget {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridColumn Class
WebGridColumn Members


HyperlinkDisplayText Property

[image]
Intersoft WebGrid Documentation
HyperlinkDisplayText Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridColumn Class : HyperlinkDisplayText Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Gets or sets the text used for the hyperlink's display.")>
Public Property HyperlinkDisplayText As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebGridColumn
Dim value As System.String

instance.HyperlinkDisplayText = value

value = instance.HyperlinkDisplayText
C#
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the text used for the hyperlink's display.")]
public System.string HyperlinkDisplayText {get; set;}
Delphi
public read-write property HyperlinkDisplayText: System.String;
JScript
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the text used for the hyperlink's display.")
public function get,set HyperlinkDisplayText : System.String
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the text used for the hyperlink's display.")]
public: __property System.string* get_HyperlinkDisplayText();
public: __property void set_HyperlinkDisplayText(
   System.string* value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the text used for the hyperlink's display.")]
public:
property System.String^ HyperlinkDisplayText {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridColumn Class
WebGridColumn Members


HyperlinkFormatString Property

[image]
Intersoft WebGrid Documentation
HyperlinkFormatString Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridColumn Class : HyperlinkFormatString Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property HyperlinkFormatString As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebGridColumn
Dim value As System.String

instance.HyperlinkFormatString = value

value = instance.HyperlinkFormatString
C#
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.string HyperlinkFormatString {get; set;}
Delphi
public read-write property HyperlinkFormatString: System.String;
JScript
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set HyperlinkFormatString : System.String
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.string* get_HyperlinkFormatString();
public: __property void set_HyperlinkFormatString(
   System.string* value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.String^ HyperlinkFormatString {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridColumn Class
WebGridColumn Members


HyperlinkTarget Property

[image]
Intersoft WebGrid Documentation
HyperlinkTarget Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridColumn Class : HyperlinkTarget Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Gets or sets the target of this hyperlink column.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property HyperlinkTarget As HyperlinkTarget
Visual Basic (Usage) Copy Code
Dim instance As WebGridColumn
Dim value As HyperlinkTarget

instance.HyperlinkTarget = value

value = instance.HyperlinkTarget
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the target of this hyperlink column.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public HyperlinkTarget HyperlinkTarget {get; set;}
Delphi
public read-write property HyperlinkTarget: HyperlinkTarget;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the target of this hyperlink column.")
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set HyperlinkTarget : HyperlinkTarget
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the target of this hyperlink column.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property HyperlinkTarget get_HyperlinkTarget();
public: __property void set_HyperlinkTarget(
   HyperlinkTarget value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the target of this hyperlink column.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property HyperlinkTarget HyperlinkTarget {
   HyperlinkTarget get();
   void set (    HyperlinkTarget value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridColumn Class
WebGridColumn Members


ImageFormatString Property

[image]
Intersoft WebGrid Documentation
ImageFormatString Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridColumn Class : ImageFormatString Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Gets or sets the formatting string used to render the image's src.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property ImageFormatString As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebGridColumn
Dim value As System.String

instance.ImageFormatString = value

value = instance.ImageFormatString
C#
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the formatting string used to render the image's src.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.string ImageFormatString {get; set;}
Delphi
public read-write property ImageFormatString: System.String;
JScript
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the formatting string used to render the image's src.")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set ImageFormatString : System.String
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the formatting string used to render the image's src.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.string* get_ImageFormatString();
public: __property void set_ImageFormatString(
   System.string* value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the formatting string used to render the image's src.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.String^ ImageFormatString {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridColumn Class
WebGridColumn Members


InputRequired Property

[image]
Intersoft WebGrid Documentation
InputRequired Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridColumn Class : InputRequired Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies whether user input is required for the cell of this column during editing mode.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property InputRequired As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebGridColumn
Dim value As System.Boolean

instance.InputRequired = value

value = instance.InputRequired
C#
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether user input is required for the cell of this column during editing mode.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.bool InputRequired {get; set;}
Delphi
public read-write property InputRequired: System.Boolean;
JScript
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Specifies whether user input is required for the cell of this column during editing mode.")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set InputRequired : System.boolean
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether user input is required for the cell of this column during editing mode.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.bool get_InputRequired();
public: __property void set_InputRequired(
   System.bool value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether user input is required for the cell of this column during editing mode.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.bool InputRequired {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridColumn Class
WebGridColumn Members


InputRequiredErrorText Property

[image]
Intersoft WebGrid Documentation
InputRequiredErrorText Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridColumn Class : InputRequiredErrorText Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Gets or sets the error message text that displayed in error image's tooltip when input is required.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property InputRequiredErrorText As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebGridColumn
Dim value As System.String

instance.InputRequiredErrorText = value

value = instance.InputRequiredErrorText
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the error message text that displayed in error image's tooltip when input is required.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.string InputRequiredErrorText {get; set;}
Delphi
public read-write property InputRequiredErrorText: System.String;
JScript
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the error message text that displayed in error image's tooltip when input is required.")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set InputRequiredErrorText : System.String
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the error message text that displayed in error image's tooltip when input is required.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.string* get_InputRequiredErrorText();
public: __property void set_InputRequiredErrorText(
   System.string* value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the error message text that displayed in error image's tooltip when input is required.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.String^ InputRequiredErrorText {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridColumn Class
WebGridColumn Members


IsAutoIncrement Property

[image]
Intersoft WebGrid Documentation
IsAutoIncrement Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridColumn Class : IsAutoIncrement Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies whether this column is an identity field with auto increment attribute.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
Public Property IsAutoIncrement As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebGridColumn
Dim value As System.Boolean

instance.IsAutoIncrement = value

value = instance.IsAutoIncrement
C#
[System.ComponentModel.DescriptionAttribute("Specifies whether this column is an identity field with auto increment attribute.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public System.bool IsAutoIncrement {get; set;}
Delphi
public read-write property IsAutoIncrement: System.Boolean;
JScript
System.ComponentModel.DescriptionAttribute("Specifies whether this column is an identity field with auto increment attribute.")
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
public function get,set IsAutoIncrement : System.boolean
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies whether this column is an identity field with auto increment attribute.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.bool get_IsAutoIncrement();
public: __property void set_IsAutoIncrement(
   System.bool value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies whether this column is an identity field with auto increment attribute.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.bool IsAutoIncrement {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridColumn Class
WebGridColumn Members


IsAutoWidth Property

[image]
Intersoft WebGrid Documentation
IsAutoWidth Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridColumn Class : IsAutoWidth Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Gets or sets whether this column is an auto width column.")>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Property IsAutoWidth As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebGridColumn
Dim value As System.Boolean

instance.IsAutoWidth = value

value = instance.IsAutoWidth
C#
[System.ComponentModel.DescriptionAttribute("Gets or sets whether this column is an auto width column.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
public System.bool IsAutoWidth {get; set;}
Delphi
public read-write property IsAutoWidth: System.Boolean;
JScript
System.ComponentModel.DescriptionAttribute("Gets or sets whether this column is an auto width column.")
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.XmlSerializableAttribute()
public function get,set IsAutoWidth : System.boolean
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Gets or sets whether this column is an auto width column.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property System.bool get_IsAutoWidth();
public: __property void set_IsAutoWidth(
   System.bool value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Gets or sets whether this column is an auto width column.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property System.bool IsAutoWidth {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridColumn Class
WebGridColumn Members


IsRowChecker Property

[image]
Intersoft WebGrid Documentation
IsRowChecker Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridColumn Class : IsRowChecker Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Gets or sets whether this column should act as row checker.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property IsRowChecker As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebGridColumn
Dim value As System.Boolean

instance.IsRowChecker = value

value = instance.IsRowChecker
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets whether this column should act as row checker.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public System.bool IsRowChecker {get; set;}
Delphi
public read-write property IsRowChecker: System.Boolean;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets whether this column should act as row checker.")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get,set IsRowChecker : System.boolean
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets whether this column should act as row checker.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.bool get_IsRowChecker();
public: __property void set_IsRowChecker(
   System.bool value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets whether this column should act as row checker.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.bool IsRowChecker {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridColumn Class
WebGridColumn Members


IsRowHeader Property

[image]
Intersoft WebGrid Documentation
IsRowHeader Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridColumn Class : IsRowHeader Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Gets or sets whether this column is the row header of the table. Applicable when Section 508 mode is enabled.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property IsRowHeader As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebGridColumn
Dim value As System.Boolean

instance.IsRowHeader = value

value = instance.IsRowHeader
C#
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets whether this column is the row header of the table. Applicable when Section 508 mode is enabled.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.bool IsRowHeader {get; set;}
Delphi
public read-write property IsRowHeader: System.Boolean;
JScript
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets whether this column is the row header of the table. Applicable when Section 508 mode is enabled.")
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set IsRowHeader : System.boolean
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets whether this column is the row header of the table. Applicable when Section 508 mode is enabled.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.bool get_IsRowHeader();
public: __property void set_IsRowHeader(
   System.bool value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets whether this column is the row header of the table. Applicable when Section 508 mode is enabled.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.bool IsRowHeader {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridColumn Class
WebGridColumn Members


MaxHeight Property

[image]
Intersoft WebGrid Documentation
MaxHeight Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridColumn Class : MaxHeight Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Gets or sets the maximum height for this column.")>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property MaxHeight As System.Web.UI.WebControls.Unit
Visual Basic (Usage) Copy Code
Dim instance As WebGridColumn
Dim value As System.Web.UI.WebControls.Unit

instance.MaxHeight = value

value = instance.MaxHeight
C#
[System.ComponentModel.DescriptionAttribute("Gets or sets the maximum height for this column.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.Web.UI.WebControls.Unit MaxHeight {get; set;}
Delphi
public read-write property MaxHeight: System.Web.UI.WebControls.Unit;
JScript
System.ComponentModel.DescriptionAttribute("Gets or sets the maximum height for this column.")
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set MaxHeight : System.Web.UI.WebControls.Unit
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Gets or sets the maximum height for this column.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.Web.UI.WebControls.Unit get_MaxHeight();
public: __property void set_MaxHeight(
   System.Web.UI.WebControls.Unit value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Gets or sets the maximum height for this column.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.Web.UI.WebControls.Unit MaxHeight {
   System.Web.UI.WebControls.Unit get();
   void set (    System.Web.UI.WebControls.Unit value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridColumn Class
WebGridColumn Members


Name Property

[image]
Intersoft WebGrid Documentation
Name Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridColumn Class : Name Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.BrowsableAttribute(True)>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Visible)>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Overrides Property Name As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebGridColumn
Dim value As System.String

instance.Name = value

value = instance.Name
C#
[System.ComponentModel.BrowsableAttribute(true)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Visible)]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public override System.string Name {get; set;}
Delphi
public read-write property Name: System.String; override;
JScript
System.ComponentModel.BrowsableAttribute()
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Visible)
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public override function get,set Name : System.String
Managed Extensions for C++
[System.ComponentModel.BrowsableAttribute(true)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Visible)]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.string* get_Name() override;
public: __property void set_Name(
   System.string* value
) override;
C++/CLI
[System.ComponentModel.BrowsableAttribute(true)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Visible)]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.String^ Name {
   System.String^ get() override;
   void set (    System.String^ value) override;
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridColumn Class
WebGridColumn Members


NewRowEditType Property

[image]
Intersoft WebGrid Documentation
NewRowEditType Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridColumn Class : NewRowEditType Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Gets or sets the edit type used in new row for this column.")>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Property NewRowEditType As NewRowEditType
Visual Basic (Usage) Copy Code
Dim instance As WebGridColumn
Dim value As NewRowEditType

instance.NewRowEditType = value

value = instance.NewRowEditType
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the edit type used in new row for this column.")]
[ISNet.Serialization.XmlSerializableAttribute()]
public NewRowEditType NewRowEditType {get; set;}
Delphi
public read-write property NewRowEditType: NewRowEditType;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the edit type used in new row for this column.")
ISNet.Serialization.XmlSerializableAttribute()
public function get,set NewRowEditType : NewRowEditType
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the edit type used in new row for this column.")]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property NewRowEditType get_NewRowEditType();
public: __property void set_NewRowEditType(
   NewRowEditType value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the edit type used in new row for this column.")]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property NewRowEditType NewRowEditType {
   NewRowEditType get();
   void set (    NewRowEditType value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridColumn Class
WebGridColumn Members


NullText Property

[image]
Intersoft WebGrid Documentation
NullText Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridColumn Class : NullText Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Gets or sets the text that will be displayed when a cell value is null or System.DBNull.")>
Public Property NullText As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebGridColumn
Dim value As System.String

instance.NullText = value

value = instance.NullText
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the text that will be displayed when a cell value is null or System.DBNull.")]
public System.string NullText {get; set;}
Delphi
public read-write property NullText: System.String;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the text that will be displayed when a cell value is null or System.DBNull.")
public function get,set NullText : System.String
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the text that will be displayed when a cell value is null or System.DBNull.")]
public: __property System.string* get_NullText();
public: __property void set_NullText(
   System.string* value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the text that will be displayed when a cell value is null or System.DBNull.")]
public:
property System.String^ NullText {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridColumn Class
WebGridColumn Members


PreserveWhitespace Property

[image]
Intersoft WebGrid Documentation
PreserveWhitespace Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridColumn Class : PreserveWhitespace Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies whether whitespace should be persisted in data display and editing of this column")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Property PreserveWhitespace As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebGridColumn
Dim value As System.Boolean

instance.PreserveWhitespace = value

value = instance.PreserveWhitespace
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether whitespace should be persisted in data display and editing of this column")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
public System.bool PreserveWhitespace {get; set;}
Delphi
public read-write property PreserveWhitespace: System.Boolean;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Specifies whether whitespace should be persisted in data display and editing of this column")
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.XmlSerializableAttribute()
public function get,set PreserveWhitespace : System.boolean
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether whitespace should be persisted in data display and editing of this column")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property System.bool get_PreserveWhitespace();
public: __property void set_PreserveWhitespace(
   System.bool value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether whitespace should be persisted in data display and editing of this column")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property System.bool PreserveWhitespace {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridColumn Class
WebGridColumn Members


ShowInChartFieldList Property

[image]
Intersoft WebGrid Documentation
ShowInChartFieldList Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridColumn Class : ShowInChartFieldList Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Gets or sets a boolean value indicating whether this field should be displayed in Field List.")>
<System.ComponentModel.CategoryAttribute("Pivot Charting")>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Property ShowInChartFieldList As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebGridColumn
Dim value As System.Boolean

instance.ShowInChartFieldList = value

value = instance.ShowInChartFieldList
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets a boolean value indicating whether this field should be displayed in Field List.")]
[System.ComponentModel.CategoryAttribute("Pivot Charting")]
[ISNet.Serialization.XmlSerializableAttribute()]
public System.bool ShowInChartFieldList {get; set;}
Delphi
public read-write property ShowInChartFieldList: System.Boolean;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets a boolean value indicating whether this field should be displayed in Field List.")
System.ComponentModel.CategoryAttribute("Pivot Charting")
ISNet.Serialization.XmlSerializableAttribute()
public function get,set ShowInChartFieldList : System.boolean
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets a boolean value indicating whether this field should be displayed in Field List.")]
[System.ComponentModel.CategoryAttribute("Pivot Charting")]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property System.bool get_ShowInChartFieldList();
public: __property void set_ShowInChartFieldList(
   System.bool value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets a boolean value indicating whether this field should be displayed in Field List.")]
[System.ComponentModel.CategoryAttribute("Pivot Charting")]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property System.bool ShowInChartFieldList {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridColumn Class
WebGridColumn Members


ShowInSelectColumns Property

[image]
Intersoft WebGrid Documentation
ShowInSelectColumns Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridColumn Class : ShowInSelectColumns Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies whether the column will be shown in Select Columns menu.")>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Property ShowInSelectColumns As SelectColumns
Visual Basic (Usage) Copy Code
Dim instance As WebGridColumn
Dim value As SelectColumns

instance.ShowInSelectColumns = value

value = instance.ShowInSelectColumns
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether the column will be shown in Select Columns menu.")]
[ISNet.Serialization.XmlSerializableAttribute()]
public SelectColumns ShowInSelectColumns {get; set;}
Delphi
public read-write property ShowInSelectColumns: SelectColumns;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Specifies whether the column will be shown in Select Columns menu.")
ISNet.Serialization.XmlSerializableAttribute()
public function get,set ShowInSelectColumns : SelectColumns
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether the column will be shown in Select Columns menu.")]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property SelectColumns get_ShowInSelectColumns();
public: __property void set_ShowInSelectColumns(
   SelectColumns value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether the column will be shown in Select Columns menu.")]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property SelectColumns ShowInSelectColumns {
   SelectColumns get();
   void set (    SelectColumns value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridColumn Class
WebGridColumn Members


SortKeyField Property

[image]
Intersoft WebGrid Documentation
SortKeyField Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridColumn Class : SortKeyField Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebGrid.DataFieldEditor, ISNet.WebUI.WebGrid, Version=9.0.7200.1, Culture=neutral, PublicKeyToken=3e60b85fb8502d5e")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Gets or sets the sort key field for SortedColumn.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property SortKeyField As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebGridColumn
Dim value As System.String

instance.SortKeyField = value

value = instance.SortKeyField
C#
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebGrid.DataFieldEditor, ISNet.WebUI.WebGrid, Version=9.0.7200.1, Culture=neutral, PublicKeyToken=3e60b85fb8502d5e")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the sort key field for SortedColumn.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
public System.string SortKeyField {get; set;}
Delphi
public read-write property SortKeyField: System.String;
JScript
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebGrid.DataFieldEditor, ISNet.WebUI.WebGrid, Version=9.0.7200.1, Culture=neutral, PublicKeyToken=3e60b85fb8502d5e")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the sort key field for SortedColumn.")
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get,set SortKeyField : System.String
Managed Extensions for C++
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebGrid.DataFieldEditor, ISNet.WebUI.WebGrid, Version=9.0.7200.1, Culture=neutral, PublicKeyToken=3e60b85fb8502d5e")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the sort key field for SortedColumn.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.string* get_SortKeyField();
public: __property void set_SortKeyField(
   System.string* value
);
C++/CLI
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebGrid.DataFieldEditor, ISNet.WebUI.WebGrid, Version=9.0.7200.1, Culture=neutral, PublicKeyToken=3e60b85fb8502d5e")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the sort key field for SortedColumn.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.String^ SortKeyField {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridColumn Class
WebGridColumn Members


Tag Property

[image]
Intersoft WebGrid Documentation
Tag Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridColumn Class : Tag Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Gets or sets custom data associated for this column.")>
Public Property Tag As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebGridColumn
Dim value As System.String

instance.Tag = value

value = instance.Tag
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets custom data associated for this column.")]
public System.string Tag {get; set;}
Delphi
public read-write property Tag: System.String;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets custom data associated for this column.")
public function get,set Tag : System.String
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets custom data associated for this column.")]
public: __property System.string* get_Tag();
public: __property void set_Tag(
   System.string* value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets custom data associated for this column.")]
public:
property System.String^ Tag {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridColumn Class
WebGridColumn Members


TextboxMaxlength Property

[image]
Intersoft WebGrid Documentation
TextboxMaxlength Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridColumn Class : TextboxMaxlength Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Gets or sets the maximum length of the TextBox Edit control.")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property TextboxMaxlength As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebGridColumn
Dim value As System.Integer

instance.TextboxMaxlength = value

value = instance.TextboxMaxlength
C#
[System.ComponentModel.DescriptionAttribute("Gets or sets the maximum length of the TextBox Edit control.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public System.int TextboxMaxlength {get; set;}
Delphi
public read-write property TextboxMaxlength: System.Integer;
JScript
System.ComponentModel.DescriptionAttribute("Gets or sets the maximum length of the TextBox Edit control.")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get,set TextboxMaxlength : System.int
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Gets or sets the maximum length of the TextBox Edit control.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.int get_TextboxMaxlength();
public: __property void set_TextboxMaxlength(
   System.int value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Gets or sets the maximum length of the TextBox Edit control.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.int TextboxMaxlength {
   System.int get();
   void set (    System.int value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridColumn Class
WebGridColumn Members


TreatMarkupAsLiteralText Property

[image]
Intersoft WebGrid Documentation
TreatMarkupAsLiteralText Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridColumn Class : TreatMarkupAsLiteralText Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Gets or sets whether markups such as HTML or XML should be treated as literal text.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property TreatMarkupAsLiteralText As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebGridColumn
Dim value As System.Boolean

instance.TreatMarkupAsLiteralText = value

value = instance.TreatMarkupAsLiteralText
C#
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets whether markups such as HTML or XML should be treated as literal text.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.bool TreatMarkupAsLiteralText {get; set;}
Delphi
public read-write property TreatMarkupAsLiteralText: System.Boolean;
JScript
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets whether markups such as HTML or XML should be treated as literal text.")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set TreatMarkupAsLiteralText : System.boolean
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets whether markups such as HTML or XML should be treated as literal text.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.bool get_TreatMarkupAsLiteralText();
public: __property void set_TreatMarkupAsLiteralText(
   System.bool value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets whether markups such as HTML or XML should be treated as literal text.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.bool TreatMarkupAsLiteralText {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridColumn Class
WebGridColumn Members


UseValueListForFilter Property

[image]
Intersoft WebGrid Documentation
UseValueListForFilter Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridColumn Class : UseValueListForFilter Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Indicates whether the value list data should be used for filtering a column.")>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property UseValueListForFilter As ValueListFilter
Visual Basic (Usage) Copy Code
Dim instance As WebGridColumn
Dim value As ValueListFilter

instance.UseValueListForFilter = value

value = instance.UseValueListForFilter
C#
[System.ComponentModel.DescriptionAttribute("Indicates whether the value list data should be used for filtering a column.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public ValueListFilter UseValueListForFilter {get; set;}
Delphi
public read-write property UseValueListForFilter: ValueListFilter;
JScript
System.ComponentModel.DescriptionAttribute("Indicates whether the value list data should be used for filtering a column.")
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set UseValueListForFilter : ValueListFilter
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Indicates whether the value list data should be used for filtering a column.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property ValueListFilter get_UseValueListForFilter();
public: __property void set_UseValueListForFilter(
   ValueListFilter value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Indicates whether the value list data should be used for filtering a column.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property ValueListFilter UseValueListForFilter {
   ValueListFilter get();
   void set (    ValueListFilter value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridColumn Class
WebGridColumn Members


UseValueListForSorting Property

[image]
Intersoft WebGrid Documentation
UseValueListForSorting Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridColumn Class : UseValueListForSorting Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Indicates whether the value list data should be used for sorting a column.")>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Property UseValueListForSorting As ValueListSorting
Visual Basic (Usage) Copy Code
Dim instance As WebGridColumn
Dim value As ValueListSorting

instance.UseValueListForSorting = value

value = instance.UseValueListForSorting
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Indicates whether the value list data should be used for sorting a column.")]
[ISNet.Serialization.XmlSerializableAttribute()]
public ValueListSorting UseValueListForSorting {get; set;}
Delphi
public read-write property UseValueListForSorting: ValueListSorting;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Indicates whether the value list data should be used for sorting a column.")
ISNet.Serialization.XmlSerializableAttribute()
public function get,set UseValueListForSorting : ValueListSorting
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Indicates whether the value list data should be used for sorting a column.")]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property ValueListSorting get_UseValueListForSorting();
public: __property void set_UseValueListForSorting(
   ValueListSorting value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Indicates whether the value list data should be used for sorting a column.")]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property ValueListSorting UseValueListForSorting {
   ValueListSorting get();
   void set (    ValueListSorting value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridColumn Class
WebGridColumn Members


ValueList Property

[image]
Intersoft WebGrid Documentation
ValueList Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridColumn Class : ValueList Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Gets or sets the WebValueList object of the column.")>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)>
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute(True)>
Public Property ValueList As WebValueList
Visual Basic (Usage) Copy Code
Dim instance As WebGridColumn
Dim value As WebValueList

instance.ValueList = value

value = instance.ValueList
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the WebValueList object of the column.")]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute(true)]
public WebValueList ValueList {get; set;}
Delphi
public read-write property ValueList: WebValueList;
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the WebValueList object of the column.")
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute()
public function get,set ValueList : WebValueList
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the WebValueList object of the column.")]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute(true)]
public: __property WebValueList* get_ValueList();
public: __property void set_ValueList(
   WebValueList* value
);
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the WebValueList object of the column.")]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute(true)]
public:
property WebValueList^ ValueList {
   WebValueList^ get();
   void set (    WebValueList^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridColumn Class
WebGridColumn Members


Visible Property

[image]
Intersoft WebGrid Documentation
Visible Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridColumn Class : Visible Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Gets or sets whether the column will be rendered.")>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Property Visible As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebGridColumn
Dim value As System.Boolean

instance.Visible = value

value = instance.Visible
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets whether the column will be rendered.")]
[ISNet.Serialization.XmlSerializableAttribute()]
public System.bool Visible {get; set;}
Delphi
public read-write property Visible: System.Boolean;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets whether the column will be rendered.")
ISNet.Serialization.XmlSerializableAttribute()
public function get,set Visible : System.boolean
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets whether the column will be rendered.")]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property System.bool get_Visible();
public: __property void set_Visible(
   System.bool value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets whether the column will be rendered.")]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property System.bool Visible {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridColumn Class
WebGridColumn Members


WebComboID Property

[image]
Intersoft WebGrid Documentation
WebComboID Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridColumn Class : WebComboID Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Gets or sets the WebCombo.NET(tm) instance associated with this column.")>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebGrid.WebComboEditor, ISNet.WebUI.WebGrid, Version=9.0.7200.1, Culture=neutral, PublicKeyToken=3e60b85fb8502d5e")>
Public Property WebComboID As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebGridColumn
Dim value As System.String

instance.WebComboID = value

value = instance.WebComboID
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the WebCombo.NET(tm) instance associated with this column.")]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebGrid.WebComboEditor, ISNet.WebUI.WebGrid, Version=9.0.7200.1, Culture=neutral, PublicKeyToken=3e60b85fb8502d5e")]
public System.string WebComboID {get; set;}
Delphi
public read-write property WebComboID: System.String;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the WebCombo.NET(tm) instance associated with this column.")
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebGrid.WebComboEditor, ISNet.WebUI.WebGrid, Version=9.0.7200.1, Culture=neutral, PublicKeyToken=3e60b85fb8502d5e")
public function get,set WebComboID : System.String
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the WebCombo.NET(tm) instance associated with this column.")]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebGrid.WebComboEditor, ISNet.WebUI.WebGrid, Version=9.0.7200.1, Culture=neutral, PublicKeyToken=3e60b85fb8502d5e")]
public: __property System.string* get_WebComboID();
public: __property void set_WebComboID(
   System.string* value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the WebCombo.NET(tm) instance associated with this column.")]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebGrid.WebComboEditor, ISNet.WebUI.WebGrid, Version=9.0.7200.1, Culture=neutral, PublicKeyToken=3e60b85fb8502d5e")]
public:
property System.String^ WebComboID {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridColumn Class
WebGridColumn Members


Width Property

[image]
Intersoft WebGrid Documentation
Width Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridColumn Class : Width Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Gets or sets the width of the column in Unit.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property Width As System.Web.UI.WebControls.Unit
Visual Basic (Usage) Copy Code
Dim instance As WebGridColumn
Dim value As System.Web.UI.WebControls.Unit

instance.Width = value

value = instance.Width
C#
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the width of the column in Unit.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.Web.UI.WebControls.Unit Width {get; set;}
Delphi
public read-write property Width: System.Web.UI.WebControls.Unit;
JScript
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the width of the column in Unit.")
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set Width : System.Web.UI.WebControls.Unit
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the width of the column in Unit.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.Web.UI.WebControls.Unit get_Width();
public: __property void set_Width(
   System.Web.UI.WebControls.Unit value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the width of the column in Unit.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.Web.UI.WebControls.Unit Width {
   System.Web.UI.WebControls.Unit get();
   void set (    System.Web.UI.WebControls.Unit value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridColumn Class
WebGridColumn Members


WebGridColumnCollection Class

[image]
Intersoft WebGrid Documentation
WebGridColumnCollection Class
Members See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : WebGridColumnCollection Class

Glossary Item Box

Object Model

WebGridColumnCollection Class

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.Reflection.DefaultMemberAttribute("Item")>
<System.SerializableAttribute()>
Public Class WebGridColumnCollection
   Inherits ISNet.WebUI.ISCollectionBase
Visual Basic (Usage) Copy Code
Dim instance As WebGridColumnCollection
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.Reflection.DefaultMemberAttribute("Item")]
[System.SerializableAttribute()]
public class WebGridColumnCollection : ISNet.WebUI.ISCollectionBase
Delphi
public class WebGridColumnCollection = class(ISNet.WebUI.ISCollectionBase)
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.Reflection.DefaultMemberAttribute("Item")
System.SerializableAttribute()
public class WebGridColumnCollection extends ISNet.WebUI.ISCollectionBase
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.Reflection.DefaultMemberAttribute("Item")]
[System.SerializableAttribute()]
public __gc class WebGridColumnCollection : public ISNet.WebUI.ISCollectionBase
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.Reflection.DefaultMemberAttribute("Item")]
[System.SerializableAttribute()]
public ref class WebGridColumnCollection : public ISNet.WebUI.ISCollectionBase

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
ISNet.WebUI.ISCollectionBase
ISNet.WebUI.WebGrid.WebGridColumnCollection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridColumnCollection Members
ISNet.WebUI.WebGrid Namespace


WebGridColumnCollection Class Members

[image]
Intersoft WebGrid Documentation
WebGridColumnCollection Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebGrid Namespace : WebGridColumnCollection Class

Glossary Item Box

The following tables list the members exposed by WebGridColumnCollection.

Public Constructors

 | Name | Description
Public Constructor | WebGridColumnCollection Constructor |
Top

Public Properties

 | Name | Description
Public Property | Capacity | (Inherited from System.Collections.CollectionBase)
Public Property | Count | (Inherited from System.Collections.CollectionBase)
Public Property | IsReadOnly | Overridden.
Public Property | Item |
Public Property | Parent | (Inherited from ISNet.WebUI.ISCollectionBase)
Top

Public Methods

 | Name | Description
Public Method | Add | Overloaded.
Public Method | AddRange | Overloaded.
Public Method | Clear |
Public Method | Contains | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | CopyFrom |
Public Method | CopyTo | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | Exists | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | GetEnumerator |
Public Method | GetItem | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | GetNamedItem |
Public Method | GetVisibleColumnsCount |
Public Method | IndexOf | Overloaded. (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | Insert |
Public Method | IntInsert | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | Remove |
Public Method | setParent | (Inherited from ISNet.WebUI.ISCollectionBase)
Top

See Also

Reference

WebGridColumnCollection Class
ISNet.WebUI.WebGrid Namespace


WebGridColumnCollection Constructor

[image]
Intersoft WebGrid Documentation
WebGridColumnCollection Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridColumnCollection Class : WebGridColumnCollection Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebGridColumnCollection()
C#
public WebGridColumnCollection()
Delphi
public WebGridColumnCollection();
JScript
public function WebGridColumnCollection();
Managed Extensions for C++
public: WebGridColumnCollection();
C++/CLI
public:
WebGridColumnCollection();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridColumnCollection Class
WebGridColumnCollection Members


WebGridColumnCollection Class Methods

[image]
Intersoft WebGrid Documentation
WebGridColumnCollection Class Methods
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : WebGridColumnCollection Class

Glossary Item Box

For a list of all members of this type, see WebGridColumnCollection members.

Public Methods

 | Name | Description
Public Method | Add | Overloaded.
Public Method | AddRange | Overloaded.
Public Method | Clear |
Public Method | Contains | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | CopyFrom |
Public Method | CopyTo | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | Exists | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | GetEnumerator |
Public Method | GetItem | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | GetNamedItem |
Public Method | GetVisibleColumnsCount |
Public Method | IndexOf | Overloaded. (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | Insert |
Public Method | IntInsert | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | Remove |
Public Method | setParent | (Inherited from ISNet.WebUI.ISCollectionBase)
Top

See Also

Reference

WebGridColumnCollection Class
ISNet.WebUI.WebGrid Namespace


Add Method

[image]
Intersoft WebGrid Documentation
Add Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridColumnCollection Class : Add Method

Glossary Item Box

Overload List

Overload | Description
Add(WebGridColumn) |
Add(String) |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridColumnCollection Class
WebGridColumnCollection Members


Add(WebGridColumn) Method

[image]
Intersoft WebGrid Documentation
Add(WebGridColumn) Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridColumnCollection Class > Add Method : Add(WebGridColumn) Method

webGridColumn

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function Add( _
   ByVal webGridColumn As WebGridColumn _
) As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebGridColumnCollection
Dim webGridColumn As WebGridColumn
Dim value As System.Integer

value = instance.Add(webGridColumn)
C#
public virtual System.int Add(
   WebGridColumn webGridColumn
)
Delphi
public function Add(
    webGridColumn: WebGridColumn
): System.Integer; virtual;
JScript
public function Add(
   webGridColumn : WebGridColumn
) : System.int;
Managed Extensions for C++
public: virtual System.int Add(
   WebGridColumn* webGridColumn
)
C++/CLI
public:
virtual System.int Add(
   WebGridColumn^ webGridColumn
)

Parameters

webGridColumn

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridColumnCollection Class
WebGridColumnCollection Members
Overload List


Add(String) Method

[image]
Intersoft WebGrid Documentation
Add(String) Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridColumnCollection Class > Add Method : Add(String) Method

name

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function Add( _
   ByVal name As System.String _
) As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebGridColumnCollection
Dim name As System.String
Dim value As System.Integer

value = instance.Add(name)
C#
public System.int Add(
   System.string name
)
Delphi
public function Add(
    name: System.String
): System.Integer;
JScript
public function Add(
   name : System.String
) : System.int;
Managed Extensions for C++
public: System.int Add(
   System.string* name
)
C++/CLI
public:
System.int Add(
   System.String^ name
)

Parameters

name

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridColumnCollection Class
WebGridColumnCollection Members
Overload List


AddRange Method

[image]
Intersoft WebGrid Documentation
AddRange Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridColumnCollection Class : AddRange Method

Glossary Item Box

Overload List

Overload | Description
AddRange(String[]) |
AddRange(WebGridColumn[]) |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridColumnCollection Class
WebGridColumnCollection Members


AddRange(String[]) Method

[image]
Intersoft WebGrid Documentation
AddRange(String[]) Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridColumnCollection Class > AddRange Method : AddRange(String[]) Method

columns

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Sub AddRange( _
   ByVal columns() As System.String _
)
Visual Basic (Usage) Copy Code
Dim instance As WebGridColumnCollection
Dim columns() As System.String

instance.AddRange(columns)
C#
public void AddRange(
   System.string[] columns
)
Delphi
public procedure AddRange(
    columns: System.Stringarray of
);
JScript
public function AddRange(
   columns : System.String[]
);
Managed Extensions for C++
public: void AddRange(
   System.string*[]* columns
)
C++/CLI
public:
void AddRange(
   System.array<String^>^ columns
)

Parameters

columns

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridColumnCollection Class
WebGridColumnCollection Members
Overload List


AddRange(WebGridColumn[]) Method

[image]
Intersoft WebGrid Documentation
AddRange(WebGridColumn[]) Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridColumnCollection Class > AddRange Method : AddRange(WebGridColumn[]) Method

columns

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Sub AddRange( _
   ByVal columns() As WebGridColumn _
)
Visual Basic (Usage) Copy Code
Dim instance As WebGridColumnCollection
Dim columns() As WebGridColumn

instance.AddRange(columns)
C#
public void AddRange(
   WebGridColumn[] columns
)
Delphi
public procedure AddRange(
    columns: WebGridColumnarray of
);
JScript
public function AddRange(
   columns : WebGridColumn[]
);
Managed Extensions for C++
public: void AddRange(
   WebGridColumn*[]* columns
)
C++/CLI
public:
void AddRange(
   array<WebGridColumn^>^ columns
)

Parameters

columns

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridColumnCollection Class
WebGridColumnCollection Members
Overload List


Clear Method

[image]
Intersoft WebGrid Documentation
Clear Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridColumnCollection Class : Clear Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Shadows Sub Clear()
Visual Basic (Usage) Copy Code
Dim instance As WebGridColumnCollection

instance.Clear()
C#
public new void Clear()
Delphi
public procedure Clear();
JScript
public hide function Clear();
Managed Extensions for C++
public: new void Clear();
C++/CLI
public:
new void Clear();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridColumnCollection Class
WebGridColumnCollection Members


Contains Method

[image]
Intersoft WebGrid Documentation
Contains Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridColumnCollection Class : Contains Method

value

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function Contains( _
   ByVal value As ISNet.WebUI.INamedObject _
) As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebGridColumnCollection
Dim value As ISNet.WebUI.INamedObject
Dim value As System.Boolean

value = instance.Contains(value)
C#
public System.bool Contains(
   ISNet.WebUI.INamedObject value
)
Delphi
public function Contains(
    value: ISNet.WebUI.INamedObject
): System.Boolean;
JScript
public function Contains(
   value : ISNet.WebUI.INamedObject
) : System.boolean;
Managed Extensions for C++
public: System.bool Contains(
   ISNet.WebUI.INamedObject* value
)
C++/CLI
public:
System.bool Contains(
   ISNet.WebUI.INamedObject^ value
)

Parameters

value

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridColumnCollection Class
WebGridColumnCollection Members


CopyFrom Method

[image]
Intersoft WebGrid Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridColumnCollection Class : CopyFrom Method

passIn

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function CopyFrom( _
   ByVal passIn As WebGridColumnCollection _
) As WebGridColumnCollection
Visual Basic (Usage) Copy Code
Dim instance As WebGridColumnCollection
Dim passIn As WebGridColumnCollection
Dim value As WebGridColumnCollection

value = instance.CopyFrom(passIn)
C#
public WebGridColumnCollection CopyFrom(
   WebGridColumnCollection passIn
)
Delphi
public function CopyFrom(
    passIn: WebGridColumnCollection
): WebGridColumnCollection;
JScript
public function CopyFrom(
   passIn : WebGridColumnCollection
) : WebGridColumnCollection;
Managed Extensions for C++
public: WebGridColumnCollection* CopyFrom(
   WebGridColumnCollection* passIn
)
C++/CLI
public:
WebGridColumnCollection^ CopyFrom(
   WebGridColumnCollection^ passIn
)

Parameters

passIn

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridColumnCollection Class
WebGridColumnCollection Members


CopyTo Method

[image]
Intersoft WebGrid Documentation
CopyTo Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridColumnCollection Class : CopyTo Method

array
index

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub CopyTo( _
   ByVal array() As ISNet.WebUI.INamedObject, _
   ByVal index As System.Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As WebGridColumnCollection
Dim array() As ISNet.WebUI.INamedObject
Dim index As System.Integer

instance.CopyTo(array, index)
C#
public void CopyTo(
   ISNet.WebUI.INamedObject[] array,
   System.int index
)
Delphi
public procedure CopyTo(
    array: ISNet.WebUI.INamedObjectarray of;
    index: System.Integer
);
JScript
public function CopyTo(
   array : ISNet.WebUI.INamedObject[],
   index : System.int
);
Managed Extensions for C++
public: void CopyTo(
   ISNet.WebUI.INamedObject*[]* array,
   System.int index
)
C++/CLI
public:
void CopyTo(
   ISNet.WebUI.array<INamedObject^>^ array,
   System.int index
)

Parameters

array
index

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridColumnCollection Class
WebGridColumnCollection Members


Exists Method

[image]
Intersoft WebGrid Documentation
Exists Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridColumnCollection Class : Exists Method

name

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function Exists( _
   ByVal name As System.String _
) As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebGridColumnCollection
Dim name As System.String
Dim value As System.Boolean

value = instance.Exists(name)
C#
public System.bool Exists(
   System.string name
)
Delphi
public function Exists(
    name: System.String
): System.Boolean;
JScript
public function Exists(
   name : System.String
) : System.boolean;
Managed Extensions for C++
public: System.bool Exists(
   System.string* name
)
C++/CLI
public:
System.bool Exists(
   System.String^ name
)

Parameters

name

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridColumnCollection Class
WebGridColumnCollection Members


GetEnumerator Method

[image]
Intersoft WebGrid Documentation
GetEnumerator Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridColumnCollection Class : GetEnumerator Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Shadows Function GetEnumerator() As System.Collections.IEnumerator
Visual Basic (Usage) Copy Code
Dim instance As WebGridColumnCollection
Dim value As System.Collections.IEnumerator

value = instance.GetEnumerator()
C#
public new System.Collections.IEnumerator GetEnumerator()
Delphi
public function GetEnumerator(): System.Collections.IEnumerator;
JScript
public hide function GetEnumerator() : System.Collections.IEnumerator;
Managed Extensions for C++
public: new System.Collections.IEnumerator* GetEnumerator();
C++/CLI
public:
new System.Collections.IEnumerator^ GetEnumerator();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridColumnCollection Class
WebGridColumnCollection Members


GetItem Method

[image]
Intersoft WebGrid Documentation
GetItem Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridColumnCollection Class : GetItem Method

Glossary Item Box

Overload List

Overload | Description
GetItem | (Inherited from ISNet.WebUI.ISCollectionBase)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridColumnCollection Class
WebGridColumnCollection Members


GetItem(Int32) Method

[image]
Intersoft WebGrid Documentation
GetItem(Int32) Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridColumnCollection Class : GetItem(Int32) Method

index

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetItem( _
   ByVal index As System.Integer _
) As ISNet.WebUI.INamedObject
Visual Basic (Usage) Copy Code
Dim instance As WebGridColumnCollection
Dim index As System.Integer
Dim value As ISNet.WebUI.INamedObject

value = instance.GetItem(index)
C#
public virtual ISNet.WebUI.INamedObject GetItem(
   System.int index
)
Delphi
public function GetItem(
    index: System.Integer
): ISNet.WebUI.INamedObject; virtual;
JScript
public function GetItem(
   index : System.int
) : ISNet.WebUI.INamedObject;
Managed Extensions for C++
public: virtual ISNet.WebUI.INamedObject* GetItem(
   System.int index
)
C++/CLI
public:
virtual ISNet.WebUI.INamedObject^ GetItem(
   System.int index
)

Parameters

index

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridColumnCollection Class
WebGridColumnCollection Members


GetNamedItem Method

[image]
Intersoft WebGrid Documentation
GetNamedItem Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridColumnCollection Class : GetNamedItem Method

name

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetNamedItem( _
   ByVal name As System.String _
) As WebGridColumn
Visual Basic (Usage) Copy Code
Dim instance As WebGridColumnCollection
Dim name As System.String
Dim value As WebGridColumn

value = instance.GetNamedItem(name)
C#
public WebGridColumn GetNamedItem(
   System.string name
)
Delphi
public function GetNamedItem(
    name: System.String
): WebGridColumn;
JScript
public function GetNamedItem(
   name : System.String
) : WebGridColumn;
Managed Extensions for C++
public: WebGridColumn* GetNamedItem(
   System.string* name
)
C++/CLI
public:
WebGridColumn^ GetNamedItem(
   System.String^ name
)

Parameters

name

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridColumnCollection Class
WebGridColumnCollection Members


GetVisibleColumnsCount Method

[image]
Intersoft WebGrid Documentation
GetVisibleColumnsCount Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridColumnCollection Class : GetVisibleColumnsCount Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetVisibleColumnsCount() As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebGridColumnCollection
Dim value As System.Integer

value = instance.GetVisibleColumnsCount()
C#
public System.int GetVisibleColumnsCount()
Delphi
public function GetVisibleColumnsCount(): System.Integer;
JScript
public function GetVisibleColumnsCount() : System.int;
Managed Extensions for C++
public: System.int GetVisibleColumnsCount();
C++/CLI
public:
System.int GetVisibleColumnsCount();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridColumnCollection Class
WebGridColumnCollection Members


IndexOf Method

[image]
Intersoft WebGrid Documentation
IndexOf Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridColumnCollection Class : IndexOf Method

Glossary Item Box

Overload List

Overload | Description
IndexOf(String) | (Inherited from ISNet.WebUI.ISCollectionBase)
IndexOf(INamedObject) | (Inherited from ISNet.WebUI.ISCollectionBase)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridColumnCollection Class
WebGridColumnCollection Members


IndexOf(String) Method

[image]
Intersoft WebGrid Documentation
IndexOf(String) Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridColumnCollection Class > IndexOf Method : IndexOf(String) Method

name

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function IndexOf( _
   ByVal name As System.String _
) As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebGridColumnCollection
Dim name As System.String
Dim value As System.Integer

value = instance.IndexOf(name)
C#
public virtual System.int IndexOf(
   System.string name
)
Delphi
public function IndexOf(
    name: System.String
): System.Integer; virtual;
JScript
public function IndexOf(
   name : System.String
) : System.int;
Managed Extensions for C++
public: virtual System.int IndexOf(
   System.string* name
)
C++/CLI
public:
virtual System.int IndexOf(
   System.String^ name
)

Parameters

name

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridColumnCollection Class
WebGridColumnCollection Members
Overload List


IndexOf(INamedObject) Method

[image]
Intersoft WebGrid Documentation
IndexOf(INamedObject) Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridColumnCollection Class > IndexOf Method : IndexOf(INamedObject) Method

value

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function IndexOf( _
   ByVal value As ISNet.WebUI.INamedObject _
) As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebGridColumnCollection
Dim value As ISNet.WebUI.INamedObject
Dim value As System.Integer

value = instance.IndexOf(value)
C#
public System.int IndexOf(
   ISNet.WebUI.INamedObject value
)
Delphi
public function IndexOf(
    value: ISNet.WebUI.INamedObject
): System.Integer;
JScript
public function IndexOf(
   value : ISNet.WebUI.INamedObject
) : System.int;
Managed Extensions for C++
public: System.int IndexOf(
   ISNet.WebUI.INamedObject* value
)
C++/CLI
public:
System.int IndexOf(
   ISNet.WebUI.INamedObject^ value
)

Parameters

value

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridColumnCollection Class
WebGridColumnCollection Members
Overload List


Insert Method

[image]
Intersoft WebGrid Documentation
Insert Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridColumnCollection Class : Insert Method

index
webGridColumn

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub Insert( _
   ByVal index As System.Integer, _
   ByVal webGridColumn As WebGridColumn _
)
Visual Basic (Usage) Copy Code
Dim instance As WebGridColumnCollection
Dim index As System.Integer
Dim webGridColumn As WebGridColumn

instance.Insert(index, webGridColumn)
C#
public void Insert(
   System.int index,
   WebGridColumn webGridColumn
)
Delphi
public procedure Insert(
    index: System.Integer;
    webGridColumn: WebGridColumn
);
JScript
public function Insert(
   index : System.int,
   webGridColumn : WebGridColumn
);
Managed Extensions for C++
public: void Insert(
   System.int index,
   WebGridColumn* webGridColumn
)
C++/CLI
public:
void Insert(
   System.int index,
   WebGridColumn^ webGridColumn
)

Parameters

index
webGridColumn

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridColumnCollection Class
WebGridColumnCollection Members


IntInsert Method

[image]
Intersoft WebGrid Documentation
IntInsert Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridColumnCollection Class : IntInsert Method

index
value

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub IntInsert( _
   ByVal index As System.Integer, _
   ByVal value As ISNet.WebUI.INamedObject _
)
Visual Basic (Usage) Copy Code
Dim instance As WebGridColumnCollection
Dim index As System.Integer
Dim value As ISNet.WebUI.INamedObject

instance.IntInsert(index, value)
C#
public void IntInsert(
   System.int index,
   ISNet.WebUI.INamedObject value
)
Delphi
public procedure IntInsert(
    index: System.Integer;
    value: ISNet.WebUI.INamedObject
);
JScript
public function IntInsert(
   index : System.int,
   value : ISNet.WebUI.INamedObject
);
Managed Extensions for C++
public: void IntInsert(
   System.int index,
   ISNet.WebUI.INamedObject* value
)
C++/CLI
public:
void IntInsert(
   System.int index,
   ISNet.WebUI.INamedObject^ value
)

Parameters

index
value

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridColumnCollection Class
WebGridColumnCollection Members


Remove Method

[image]
Intersoft WebGrid Documentation
Remove Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridColumnCollection Class : Remove Method

webGridColumn

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub Remove( _
   ByVal webGridColumn As WebGridColumn _
)
Visual Basic (Usage) Copy Code
Dim instance As WebGridColumnCollection
Dim webGridColumn As WebGridColumn

instance.Remove(webGridColumn)
C#
public void Remove(
   WebGridColumn webGridColumn
)
Delphi
public procedure Remove(
    webGridColumn: WebGridColumn
);
JScript
public function Remove(
   webGridColumn : WebGridColumn
);
Managed Extensions for C++
public: void Remove(
   WebGridColumn* webGridColumn
)
C++/CLI
public:
void Remove(
   WebGridColumn^ webGridColumn
)

Parameters

webGridColumn

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridColumnCollection Class
WebGridColumnCollection Members


setParent Method

[image]
Intersoft WebGrid Documentation
setParent Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridColumnCollection Class : setParent Method

parent

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub setParent( _
   ByVal parent As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebGridColumnCollection
Dim parent As System.Object

instance.setParent(parent)
C#
public virtual void setParent(
   System.object parent
)
Delphi
public procedure setParent(
    parent: System.TObject
); virtual;
JScript
public function setParent(
   parent : System.Object
);
Managed Extensions for C++
public: virtual void setParent(
   System.Object* parent
)
C++/CLI
public:
virtual void setParent(
   System.Object^ parent
)

Parameters

parent

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridColumnCollection Class
WebGridColumnCollection Members


Capacity Property

[image]
Intersoft WebGrid Documentation
Capacity Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridColumnCollection Class : Capacity Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Runtime.InteropServices.ComVisibleAttribute(False)>
Public Property Capacity As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebGridColumnCollection
Dim value As System.Integer

instance.Capacity = value

value = instance.Capacity
C#
[System.Runtime.InteropServices.ComVisibleAttribute(false)]
public System.int Capacity {get; set;}
Delphi
public read-write property Capacity: System.Integer;
JScript
System.Runtime.InteropServices.ComVisibleAttribute()
public function get,set Capacity : System.int
Managed Extensions for C++
[System.Runtime.InteropServices.ComVisibleAttribute(false)]
public: __property System.int get_Capacity();
public: __property void set_Capacity(
   System.int value
);
C++/CLI
[System.Runtime.InteropServices.ComVisibleAttribute(false)]
public:
property System.int Capacity {
   System.int get();
   void set (    System.int value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridColumnCollection Class
WebGridColumnCollection Members


Count Property

[image]
Intersoft WebGrid Documentation
Count Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridColumnCollection Class : Count Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Count As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebGridColumnCollection
Dim value As System.Integer

value = instance.Count
C#
public System.int Count {get;}
Delphi
public read-only property Count: System.Integer;
JScript
public function get Count : System.int
Managed Extensions for C++
public: __property System.int get_Count();
C++/CLI
public:
property System.int Count {
   System.int get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridColumnCollection Class
WebGridColumnCollection Members


WebGridColumnCollection Class Properties

[image]
Intersoft WebGrid Documentation
WebGridColumnCollection Class Properties
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : WebGridColumnCollection Class

Glossary Item Box

For a list of all members of this type, see WebGridColumnCollection members.

Public Properties

 | Name | Description
Public Property | Capacity | (Inherited from System.Collections.CollectionBase)
Public Property | Count | (Inherited from System.Collections.CollectionBase)
Public Property | IsReadOnly | Overridden.
Public Property | Item |
Public Property | Parent | (Inherited from ISNet.WebUI.ISCollectionBase)
Top

See Also

Reference

WebGridColumnCollection Class
ISNet.WebUI.WebGrid Namespace


WebGridColumnCollection Constructor

[image]
Intersoft WebGrid Documentation
WebGridColumnCollection Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridColumnCollection Class : WebGridColumnCollection Constructor

Glossary Item Box

Overload List

Overload | Description
WebGridColumnCollection Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridColumnCollection Class
WebGridColumnCollection Members


IsReadOnly Property

[image]
Intersoft WebGrid Documentation
IsReadOnly Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridColumnCollection Class : IsReadOnly Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property IsReadOnly As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebGridColumnCollection
Dim value As System.Boolean

value = instance.IsReadOnly
C#
public override System.bool IsReadOnly {get;}
Delphi
public read-only property IsReadOnly: System.Boolean; override;
JScript
public override function get IsReadOnly : System.boolean
Managed Extensions for C++
public: __property System.bool get_IsReadOnly() override;
C++/CLI
public:
property System.bool IsReadOnly {
   System.bool get() override;
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridColumnCollection Class
WebGridColumnCollection Members


Item Property

[image]
Intersoft WebGrid Documentation
Item Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridColumnCollection Class : Item Property

index

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Default Property Item( _
   ByVal index As System.Integer _
) As WebGridColumn
Visual Basic (Usage) Copy Code
Dim instance As WebGridColumnCollection
Dim index As System.Integer
Dim value As WebGridColumn

value = instance.Item(index)
C#
public WebGridColumn this[
   System.int index
]; {get;}
Delphi
public  this: : WebGridColumn;[
    index: System.Integer
]; read-only
JScript
public  this[
   index : System.int
] get : WebGridColumn
Managed Extensions for C++
public: __property WebGridColumn* get_Item   System.int index
;
C++/CLI
public:
property WebGridColumn^ default [int] {
   WebGridColumn^ get(System.int index);
}

Parameters

index

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridColumnCollection Class
WebGridColumnCollection Members


Parent Property

[image]
Intersoft WebGrid Documentation
Parent Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridColumnCollection Class : Parent Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Parent As System.Object
Visual Basic (Usage) Copy Code
Dim instance As WebGridColumnCollection
Dim value As System.Object

value = instance.Parent
C#
public System.object Parent {get;}
Delphi
public read-only property Parent: System.TObject;
JScript
public function get Parent : System.Object
Managed Extensions for C++
public: __property System.Object* get_Parent();
C++/CLI
public:
property System.Object^ Parent {
   System.Object^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridColumnCollection Class
WebGridColumnCollection Members


WebGridColumnSet Class

[image]
Intersoft WebGrid Documentation
WebGridColumnSet Class
Members See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : WebGridColumnSet Class

Glossary Item Box

Object Model

WebGridColumnSet Class

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute()>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.SerializableAttribute()>
Public Class WebGridColumnSet
   Inherits ISNet.WebUI.NamedObjectBase
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject
Visual Basic (Usage) Copy Code
Dim instance As WebGridColumnSet
C#
[System.ComponentModel.DescriptionAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public class WebGridColumnSet : ISNet.WebUI.NamedObjectBase, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject
Delphi
public class WebGridColumnSet = class(ISNet.WebUI.NamedObjectBase, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject)
JScript
System.ComponentModel.DescriptionAttribute()
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.SerializableAttribute()
public class WebGridColumnSet extends ISNet.WebUI.NamedObjectBase implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public __gc class WebGridColumnSet : public ISNet.WebUI.NamedObjectBase, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject
C++/CLI
[System.ComponentModel.DescriptionAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public ref class WebGridColumnSet : public ISNet.WebUI.NamedObjectBase, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.NamedObjectBase
ISNet.WebUI.WebGrid.WebGridColumnSet

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridColumnSet Members
ISNet.WebUI.WebGrid Namespace


WebGridColumnSet Class Members

[image]
Intersoft WebGrid Documentation
WebGridColumnSet Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebGrid Namespace : WebGridColumnSet Class

Glossary Item Box

The following tables list the members exposed by WebGridColumnSet.

Public Constructors

 | Name | Description
Public Constructor | WebGridColumnSet Constructor |
Top

Public Properties

 | Name | Description
Public Property | AllowSizing |
Public Property | Caption |
Public Property | CaptionImage |
Public Property | ColumnCount |
Public Property | HeaderStyle |
Public Property | Name | Overridden.
Public Property | Visible |
Public Property | Width |
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | OnCaptionChanged |
Public Method | OnCaptionImageChanged |
Public Method | OnColumnCountChanged |
Public Method | OnHeaderVisibleChanged |
Public Method | OnHeightChanged |
Public Method | OnPropertyChanged |
Public Method | OnVisibleChanged |
Public Method | OnWidthChanged |
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString |
Top

See Also

Reference

WebGridColumnSet Class
ISNet.WebUI.WebGrid Namespace


WebGridColumnSet Constructor

[image]
Intersoft WebGrid Documentation
WebGridColumnSet Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridColumnSet Class : WebGridColumnSet Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebGridColumnSet()
C#
public WebGridColumnSet()
Delphi
public WebGridColumnSet();
JScript
public function WebGridColumnSet();
Managed Extensions for C++
public: WebGridColumnSet();
C++/CLI
public:
WebGridColumnSet();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridColumnSet Class
WebGridColumnSet Members


Clone Method

[image]
Intersoft WebGrid Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridColumnSet Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As System.Object
Visual Basic (Usage) Copy Code
Dim instance As WebGridColumnSet
Dim value As System.Object

value = instance.Clone()
C#
public virtual System.object Clone()
Delphi
public function Clone(): System.TObject; virtual;
JScript
public function Clone() : System.Object;
Managed Extensions for C++
public: virtual System.Object* Clone();
C++/CLI
public:
virtual System.Object^ Clone();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridColumnSet Class
WebGridColumnSet Members


CopyFrom Method

[image]
Intersoft WebGrid Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridColumnSet Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridColumnSet Class
WebGridColumnSet Members


CopyFrom(Object) Method

[image]
Intersoft WebGrid Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridColumnSet Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebGridColumnSet
Dim objSource As System.Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   System.object objSource
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridColumnSet Class
WebGridColumnSet Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebGrid Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridColumnSet Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object, _
   ByVal cloneSourceValue As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebGridColumnSet
Dim objSource As System.Object
Dim cloneSourceValue As System.Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   System.object objSource,
   System.bool cloneSourceValue
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject;
    cloneSourceValue: System.Boolean
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object,
   cloneSourceValue : System.boolean
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource,
   System.bool cloneSourceValue
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource,
   System.bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridColumnSet Class
WebGridColumnSet Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebGrid Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridColumnSet Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebGridColumnSet
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure DeSerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function DeSerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void DeSerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void DeSerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridColumnSet Class
WebGridColumnSet Members


GetHashCode Method

[image]
Intersoft WebGrid Documentation
GetHashCode Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridColumnSet Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebGridColumnSet
Dim value As System.Integer

value = instance.GetHashCode()
C#
public virtual System.int GetHashCode()
Delphi
public function GetHashCode(): System.Integer; virtual;
JScript
public function GetHashCode() : System.int;
Managed Extensions for C++
public: virtual System.int GetHashCode();
C++/CLI
public:
virtual System.int GetHashCode();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridColumnSet Class
WebGridColumnSet Members


WebGridColumnSet Class Methods

[image]
Intersoft WebGrid Documentation
WebGridColumnSet Class Methods
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : WebGridColumnSet Class

Glossary Item Box

For a list of all members of this type, see WebGridColumnSet members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | OnCaptionChanged |
Public Method | OnCaptionImageChanged |
Public Method | OnColumnCountChanged |
Public Method | OnHeaderVisibleChanged |
Public Method | OnHeightChanged |
Public Method | OnPropertyChanged |
Public Method | OnVisibleChanged |
Public Method | OnWidthChanged |
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString |
Top

See Also

Reference

WebGridColumnSet Class
ISNet.WebUI.WebGrid Namespace


GetObjectData Method

[image]
Intersoft WebGrid Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridColumnSet Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebGridColumnSet
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure GetObjectData(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
); override;
JScript
public override function GetObjectData(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void GetObjectData(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
) override
C++/CLI
public:
void GetObjectData(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
) override

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridColumnSet Class
WebGridColumnSet Members


IsEmpty Method

[image]
Intersoft WebGrid Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridColumnSet Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebGridColumnSet
Dim value As System.Boolean

value = instance.IsEmpty()
C#
public virtual System.bool IsEmpty()
Delphi
public function IsEmpty(): System.Boolean; virtual;
JScript
public function IsEmpty() : System.boolean;
Managed Extensions for C++
public: virtual System.bool IsEmpty();
C++/CLI
public:
virtual System.bool IsEmpty();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridColumnSet Class
WebGridColumnSet Members


OnCaptionChanged Method

[image]
Intersoft WebGrid Documentation
OnCaptionChanged Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridColumnSet Class : OnCaptionChanged Method

e

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub OnCaptionChanged( _
   ByVal e As System.EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As WebGridColumnSet
Dim e As System.EventArgs

instance.OnCaptionChanged(e)
C#
public void OnCaptionChanged(
   System.EventArgs e
)
Delphi
public procedure OnCaptionChanged(
    e: System.EventArgs
);
JScript
public function OnCaptionChanged(
   e : System.EventArgs
);
Managed Extensions for C++
public: void OnCaptionChanged(
   System.EventArgs* e
)
C++/CLI
public:
void OnCaptionChanged(
   System.EventArgs^ e
)

Parameters

e

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridColumnSet Class
WebGridColumnSet Members


OnCaptionImageChanged Method

[image]
Intersoft WebGrid Documentation
OnCaptionImageChanged Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridColumnSet Class : OnCaptionImageChanged Method

e

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub OnCaptionImageChanged( _
   ByVal e As System.EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As WebGridColumnSet
Dim e As System.EventArgs

instance.OnCaptionImageChanged(e)
C#
public void OnCaptionImageChanged(
   System.EventArgs e
)
Delphi
public procedure OnCaptionImageChanged(
    e: System.EventArgs
);
JScript
public function OnCaptionImageChanged(
   e : System.EventArgs
);
Managed Extensions for C++
public: void OnCaptionImageChanged(
   System.EventArgs* e
)
C++/CLI
public:
void OnCaptionImageChanged(
   System.EventArgs^ e
)

Parameters

e

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridColumnSet Class
WebGridColumnSet Members


OnColumnCountChanged Method

[image]
Intersoft WebGrid Documentation
OnColumnCountChanged Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridColumnSet Class : OnColumnCountChanged Method

e

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub OnColumnCountChanged( _
   ByVal e As System.EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As WebGridColumnSet
Dim e As System.EventArgs

instance.OnColumnCountChanged(e)
C#
public void OnColumnCountChanged(
   System.EventArgs e
)
Delphi
public procedure OnColumnCountChanged(
    e: System.EventArgs
);
JScript
public function OnColumnCountChanged(
   e : System.EventArgs
);
Managed Extensions for C++
public: void OnColumnCountChanged(
   System.EventArgs* e
)
C++/CLI
public:
void OnColumnCountChanged(
   System.EventArgs^ e
)

Parameters

e

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridColumnSet Class
WebGridColumnSet Members


OnHeaderVisibleChanged Method

[image]
Intersoft WebGrid Documentation
OnHeaderVisibleChanged Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridColumnSet Class : OnHeaderVisibleChanged Method

e

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub OnHeaderVisibleChanged( _
   ByVal e As System.EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As WebGridColumnSet
Dim e As System.EventArgs

instance.OnHeaderVisibleChanged(e)
C#
public void OnHeaderVisibleChanged(
   System.EventArgs e
)
Delphi
public procedure OnHeaderVisibleChanged(
    e: System.EventArgs
);
JScript
public function OnHeaderVisibleChanged(
   e : System.EventArgs
);
Managed Extensions for C++
public: void OnHeaderVisibleChanged(
   System.EventArgs* e
)
C++/CLI
public:
void OnHeaderVisibleChanged(
   System.EventArgs^ e
)

Parameters

e

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridColumnSet Class
WebGridColumnSet Members


OnHeightChanged Method

[image]
Intersoft WebGrid Documentation
OnHeightChanged Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridColumnSet Class : OnHeightChanged Method

e

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub OnHeightChanged( _
   ByVal e As System.EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As WebGridColumnSet
Dim e As System.EventArgs

instance.OnHeightChanged(e)
C#
public void OnHeightChanged(
   System.EventArgs e
)
Delphi
public procedure OnHeightChanged(
    e: System.EventArgs
);
JScript
public function OnHeightChanged(
   e : System.EventArgs
);
Managed Extensions for C++
public: void OnHeightChanged(
   System.EventArgs* e
)
C++/CLI
public:
void OnHeightChanged(
   System.EventArgs^ e
)

Parameters

e

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridColumnSet Class
WebGridColumnSet Members


OnPropertyChanged Method

[image]
Intersoft WebGrid Documentation
OnPropertyChanged Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridColumnSet Class : OnPropertyChanged Method

e

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub OnPropertyChanged( _
   ByVal e As System.EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As WebGridColumnSet
Dim e As System.EventArgs

instance.OnPropertyChanged(e)
C#
public void OnPropertyChanged(
   System.EventArgs e
)
Delphi
public procedure OnPropertyChanged(
    e: System.EventArgs
);
JScript
public function OnPropertyChanged(
   e : System.EventArgs
);
Managed Extensions for C++
public: void OnPropertyChanged(
   System.EventArgs* e
)
C++/CLI
public:
void OnPropertyChanged(
   System.EventArgs^ e
)

Parameters

e

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridColumnSet Class
WebGridColumnSet Members


OnVisibleChanged Method

[image]
Intersoft WebGrid Documentation
OnVisibleChanged Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridColumnSet Class : OnVisibleChanged Method

e

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub OnVisibleChanged( _
   ByVal e As System.EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As WebGridColumnSet
Dim e As System.EventArgs

instance.OnVisibleChanged(e)
C#
public void OnVisibleChanged(
   System.EventArgs e
)
Delphi
public procedure OnVisibleChanged(
    e: System.EventArgs
);
JScript
public function OnVisibleChanged(
   e : System.EventArgs
);
Managed Extensions for C++
public: void OnVisibleChanged(
   System.EventArgs* e
)
C++/CLI
public:
void OnVisibleChanged(
   System.EventArgs^ e
)

Parameters

e

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridColumnSet Class
WebGridColumnSet Members


OnWidthChanged Method

[image]
Intersoft WebGrid Documentation
OnWidthChanged Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridColumnSet Class : OnWidthChanged Method

e

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub OnWidthChanged( _
   ByVal e As System.EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As WebGridColumnSet
Dim e As System.EventArgs

instance.OnWidthChanged(e)
C#
public void OnWidthChanged(
   System.EventArgs e
)
Delphi
public procedure OnWidthChanged(
    e: System.EventArgs
);
JScript
public function OnWidthChanged(
   e : System.EventArgs
);
Managed Extensions for C++
public: void OnWidthChanged(
   System.EventArgs* e
)
C++/CLI
public:
void OnWidthChanged(
   System.EventArgs^ e
)

Parameters

e

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridColumnSet Class
WebGridColumnSet Members


Reset Method

[image]
Intersoft WebGrid Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridColumnSet Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As WebGridColumnSet

instance.Reset()
C#
public virtual void Reset()
Delphi
public procedure Reset(); virtual;
JScript
public function Reset();
Managed Extensions for C++
public: virtual void Reset();
C++/CLI
public:
virtual void Reset();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridColumnSet Class
WebGridColumnSet Members


SerializeObjectData Method

[image]
Intersoft WebGrid Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridColumnSet Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebGridColumnSet
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure SerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function SerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void SerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void SerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridColumnSet Class
WebGridColumnSet Members


ToString Method

[image]
Intersoft WebGrid Documentation
ToString Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridColumnSet Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString() As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebGridColumnSet
Dim value As System.String

value = instance.ToString()
C#
public override System.string ToString()
Delphi
public function ToString(): System.String; override;
JScript
public override function ToString() : System.String;
Managed Extensions for C++
public: System.string* ToString(); override
C++/CLI
public:
System.String^ ToString(); override

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridColumnSet Class
WebGridColumnSet Members


WebGridColumnSet Class Properties

[image]
Intersoft WebGrid Documentation
WebGridColumnSet Class Properties
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : WebGridColumnSet Class

Glossary Item Box

For a list of all members of this type, see WebGridColumnSet members.

Public Properties

 | Name | Description
Public Property | AllowSizing |
Public Property | Caption |
Public Property | CaptionImage |
Public Property | ColumnCount |
Public Property | HeaderStyle |
Public Property | Name | Overridden.
Public Property | Visible |
Public Property | Width |
Top

See Also

Reference

WebGridColumnSet Class
ISNet.WebUI.WebGrid Namespace


WebGridColumnSet Constructor

[image]
Intersoft WebGrid Documentation
WebGridColumnSet Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridColumnSet Class : WebGridColumnSet Constructor

Glossary Item Box

Overload List

Overload | Description
WebGridColumnSet Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridColumnSet Class
WebGridColumnSet Members


AllowSizing Property

[image]
Intersoft WebGrid Documentation
AllowSizing Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridColumnSet Class : AllowSizing Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies whether the columnset allows sizing in the UI.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
Public Property AllowSizing As ColumnSizing
Visual Basic (Usage) Copy Code
Dim instance As WebGridColumnSet
Dim value As ColumnSizing

instance.AllowSizing = value

value = instance.AllowSizing
C#
[System.ComponentModel.DescriptionAttribute("Specifies whether the columnset allows sizing in the UI.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public ColumnSizing AllowSizing {get; set;}
Delphi
public read-write property AllowSizing: ColumnSizing;
JScript
System.ComponentModel.DescriptionAttribute("Specifies whether the columnset allows sizing in the UI.")
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
public function get,set AllowSizing : ColumnSizing
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies whether the columnset allows sizing in the UI.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public: __property ColumnSizing get_AllowSizing();
public: __property void set_AllowSizing(
   ColumnSizing value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies whether the columnset allows sizing in the UI.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public:
property ColumnSizing AllowSizing {
   ColumnSizing get();
   void set (    ColumnSizing value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridColumnSet Class
WebGridColumnSet Members


Caption Property

[image]
Intersoft WebGrid Documentation
Caption Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridColumnSet Class : Caption Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("The caption of the columnset.")>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property Caption As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebGridColumnSet
Dim value As System.String

instance.Caption = value

value = instance.Caption
C#
[System.ComponentModel.DescriptionAttribute("The caption of the columnset.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.string Caption {get; set;}
Delphi
public read-write property Caption: System.String;
JScript
System.ComponentModel.DescriptionAttribute("The caption of the columnset.")
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set Caption : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("The caption of the columnset.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.string* get_Caption();
public: __property void set_Caption(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("The caption of the columnset.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.String^ Caption {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridColumnSet Class
WebGridColumnSet Members


CaptionImage Property

[image]
Intersoft WebGrid Documentation
CaptionImage Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridColumnSet Class : CaptionImage Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Whether or not an image should appear in the caption, in the left of caption text.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property CaptionImage As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebGridColumnSet
Dim value As System.String

instance.CaptionImage = value

value = instance.CaptionImage
C#
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Whether or not an image should appear in the caption, in the left of caption text.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.string CaptionImage {get; set;}
Delphi
public read-write property CaptionImage: System.String;
JScript
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Whether or not an image should appear in the caption, in the left of caption text.")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set CaptionImage : System.String
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Whether or not an image should appear in the caption, in the left of caption text.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.string* get_CaptionImage();
public: __property void set_CaptionImage(
   System.string* value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Whether or not an image should appear in the caption, in the left of caption text.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.String^ CaptionImage {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridColumnSet Class
WebGridColumnSet Members


ColumnCount Property

[image]
Intersoft WebGrid Documentation
ColumnCount Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridColumnSet Class : ColumnCount Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("The number of columns in this ColumnSet.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property ColumnCount As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebGridColumnSet
Dim value As System.Integer

instance.ColumnCount = value

value = instance.ColumnCount
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("The number of columns in this ColumnSet.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.int ColumnCount {get; set;}
Delphi
public read-write property ColumnCount: System.Integer;
JScript
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("The number of columns in this ColumnSet.")
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set ColumnCount : System.int
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("The number of columns in this ColumnSet.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.int get_ColumnCount();
public: __property void set_ColumnCount(
   System.int value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("The number of columns in this ColumnSet.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.int ColumnCount {
   System.int get();
   void set (    System.int value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridColumnSet Class
WebGridColumnSet Members


HeaderStyle Property

[image]
Intersoft WebGrid Documentation
HeaderStyle Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridColumnSet Class : HeaderStyle Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("The column's header style of the columnset.")>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
Public Property HeaderStyle As WebGridFormatStyle
Visual Basic (Usage) Copy Code
Dim instance As WebGridColumnSet
Dim value As WebGridFormatStyle

instance.HeaderStyle = value

value = instance.HeaderStyle
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("The column's header style of the columnset.")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
public WebGridFormatStyle HeaderStyle {get; set;}
Delphi
public read-write property HeaderStyle: WebGridFormatStyle;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("The column's header style of the columnset.")
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
public function get,set HeaderStyle : WebGridFormatStyle
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("The column's header style of the columnset.")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
public: __property WebGridFormatStyle* get_HeaderStyle();
public: __property void set_HeaderStyle(
   WebGridFormatStyle* value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("The column's header style of the columnset.")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
public:
property WebGridFormatStyle^ HeaderStyle {
   WebGridFormatStyle^ get();
   void set (    WebGridFormatStyle^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridColumnSet Class
WebGridColumnSet Members


Name Property

[image]
Intersoft WebGrid Documentation
Name Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridColumnSet Class : Name Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.BrowsableAttribute(True)>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Visible)>
Public Overrides Property Name As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebGridColumnSet
Dim value As System.String

instance.Name = value

value = instance.Name
C#
[System.ComponentModel.BrowsableAttribute(true)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Visible)]
public override System.string Name {get; set;}
Delphi
public read-write property Name: System.String; override;
JScript
System.ComponentModel.BrowsableAttribute()
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Visible)
public override function get,set Name : System.String
Managed Extensions for C++
[System.ComponentModel.BrowsableAttribute(true)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Visible)]
public: __property System.string* get_Name() override;
public: __property void set_Name(
   System.string* value
) override;
C++/CLI
[System.ComponentModel.BrowsableAttribute(true)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Visible)]
public:
property System.String^ Name {
   System.String^ get() override;
   void set (    System.String^ value) override;
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridColumnSet Class
WebGridColumnSet Members


Visible Property

[image]
Intersoft WebGrid Documentation
Visible Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridColumnSet Class : Visible Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("The visibility of the columnset.")>
Public Property Visible As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebGridColumnSet
Dim value As System.Boolean

instance.Visible = value

value = instance.Visible
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("The visibility of the columnset.")]
public System.bool Visible {get; set;}
Delphi
public read-write property Visible: System.Boolean;
JScript
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("The visibility of the columnset.")
public function get,set Visible : System.boolean
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("The visibility of the columnset.")]
public: __property System.bool get_Visible();
public: __property void set_Visible(
   System.bool value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("The visibility of the columnset.")]
public:
property System.bool Visible {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridColumnSet Class
WebGridColumnSet Members


Width Property

[image]
Intersoft WebGrid Documentation
Width Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridColumnSet Class : Width Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("The total width of the columnset.")>
Public Property Width As System.Web.UI.WebControls.Unit
Visual Basic (Usage) Copy Code
Dim instance As WebGridColumnSet
Dim value As System.Web.UI.WebControls.Unit

instance.Width = value

value = instance.Width
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("The total width of the columnset.")]
public System.Web.UI.WebControls.Unit Width {get; set;}
Delphi
public read-write property Width: System.Web.UI.WebControls.Unit;
JScript
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("The total width of the columnset.")
public function get,set Width : System.Web.UI.WebControls.Unit
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("The total width of the columnset.")]
public: __property System.Web.UI.WebControls.Unit get_Width();
public: __property void set_Width(
   System.Web.UI.WebControls.Unit value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("The total width of the columnset.")]
public:
property System.Web.UI.WebControls.Unit Width {
   System.Web.UI.WebControls.Unit get();
   void set (    System.Web.UI.WebControls.Unit value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridColumnSet Class
WebGridColumnSet Members


WebGridColumnSetCollection Class

[image]
Intersoft WebGrid Documentation
WebGridColumnSetCollection Class
Members See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : WebGridColumnSetCollection Class

Glossary Item Box

Object Model

WebGridColumnSetCollection Class

Syntax

Visual Basic (Declaration)
<System.Reflection.DefaultMemberAttribute("Item")>
<System.SerializableAttribute()>
Public Class WebGridColumnSetCollection
   Inherits ISNet.WebUI.ISCollectionBase
Visual Basic (Usage) Copy Code
Dim instance As WebGridColumnSetCollection
C#
[System.Reflection.DefaultMemberAttribute("Item")]
[System.SerializableAttribute()]
public class WebGridColumnSetCollection : ISNet.WebUI.ISCollectionBase
Delphi
public class WebGridColumnSetCollection = class(ISNet.WebUI.ISCollectionBase)
JScript
System.Reflection.DefaultMemberAttribute("Item")
System.SerializableAttribute()
public class WebGridColumnSetCollection extends ISNet.WebUI.ISCollectionBase
Managed Extensions for C++
[System.Reflection.DefaultMemberAttribute("Item")]
[System.SerializableAttribute()]
public __gc class WebGridColumnSetCollection : public ISNet.WebUI.ISCollectionBase
C++/CLI
[System.Reflection.DefaultMemberAttribute("Item")]
[System.SerializableAttribute()]
public ref class WebGridColumnSetCollection : public ISNet.WebUI.ISCollectionBase

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
ISNet.WebUI.ISCollectionBase
ISNet.WebUI.WebGrid.WebGridColumnSetCollection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridColumnSetCollection Members
ISNet.WebUI.WebGrid Namespace


WebGridColumnSetCollection Class Members

[image]
Intersoft WebGrid Documentation
WebGridColumnSetCollection Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebGrid Namespace : WebGridColumnSetCollection Class

Glossary Item Box

The following tables list the members exposed by WebGridColumnSetCollection.

Public Constructors

 | Name | Description
Public Constructor | WebGridColumnSetCollection Constructor |
Top

Public Properties

 | Name | Description
Public Property | Capacity | (Inherited from System.Collections.CollectionBase)
Public Property | Count | (Inherited from System.Collections.CollectionBase)
Public Property | IsReadOnly | Overridden.
Public Property | Item |
Public Property | Parent | (Inherited from ISNet.WebUI.ISCollectionBase)
Top

Public Methods

 | Name | Description
Public Method | Add | Overloaded.
Public Method | Clear |
Public Method | Contains | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | CopyFrom |
Public Method | CopyTo | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | Exists | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | GetEnumerator |
Public Method | GetItem | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | GetNamedItem |
Public Method | IndexOf | Overloaded. (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | Insert |
Public Method | IntInsert | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | Remove |
Public Method | Reorder |
Public Method | setParent | (Inherited from ISNet.WebUI.ISCollectionBase)
Top

See Also

Reference

WebGridColumnSetCollection Class
ISNet.WebUI.WebGrid Namespace


WebGridColumnSetCollection Constructor

[image]
Intersoft WebGrid Documentation
WebGridColumnSetCollection Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridColumnSetCollection Class : WebGridColumnSetCollection Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebGridColumnSetCollection()
C#
public WebGridColumnSetCollection()
Delphi
public WebGridColumnSetCollection();
JScript
public function WebGridColumnSetCollection();
Managed Extensions for C++
public: WebGridColumnSetCollection();
C++/CLI
public:
WebGridColumnSetCollection();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridColumnSetCollection Class
WebGridColumnSetCollection Members


WebGridColumnSetCollection Class Methods

[image]
Intersoft WebGrid Documentation
WebGridColumnSetCollection Class Methods
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : WebGridColumnSetCollection Class

Glossary Item Box

For a list of all members of this type, see WebGridColumnSetCollection members.

Public Methods

 | Name | Description
Public Method | Add | Overloaded.
Public Method | Clear |
Public Method | Contains | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | CopyFrom |
Public Method | CopyTo | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | Exists | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | GetEnumerator |
Public Method | GetItem | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | GetNamedItem |
Public Method | IndexOf | Overloaded. (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | Insert |
Public Method | IntInsert | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | Remove |
Public Method | Reorder |
Public Method | setParent | (Inherited from ISNet.WebUI.ISCollectionBase)
Top

See Also

Reference

WebGridColumnSetCollection Class
ISNet.WebUI.WebGrid Namespace


Add Method

[image]
Intersoft WebGrid Documentation
Add Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridColumnSetCollection Class : Add Method

Glossary Item Box

Overload List

Overload | Description
Add(WebGridColumnSet) |
Add(String) |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridColumnSetCollection Class
WebGridColumnSetCollection Members


Add(WebGridColumnSet) Method

[image]
Intersoft WebGrid Documentation
Add(WebGridColumnSet) Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridColumnSetCollection Class > Add Method : Add(WebGridColumnSet) Method

webGridColumnSet

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function Add( _
   ByVal webGridColumnSet As WebGridColumnSet _
) As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebGridColumnSetCollection
Dim webGridColumnSet As WebGridColumnSet
Dim value As System.Integer

value = instance.Add(webGridColumnSet)
C#
public virtual System.int Add(
   WebGridColumnSet webGridColumnSet
)
Delphi
public function Add(
    webGridColumnSet: WebGridColumnSet
): System.Integer; virtual;
JScript
public function Add(
   webGridColumnSet : WebGridColumnSet
) : System.int;
Managed Extensions for C++
public: virtual System.int Add(
   WebGridColumnSet* webGridColumnSet
)
C++/CLI
public:
virtual System.int Add(
   WebGridColumnSet^ webGridColumnSet
)

Parameters

webGridColumnSet

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridColumnSetCollection Class
WebGridColumnSetCollection Members
Overload List


Add(String) Method

[image]
Intersoft WebGrid Documentation
Add(String) Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridColumnSetCollection Class > Add Method : Add(String) Method

name

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function Add( _
   ByVal name As System.String _
) As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebGridColumnSetCollection
Dim name As System.String
Dim value As System.Integer

value = instance.Add(name)
C#
public System.int Add(
   System.string name
)
Delphi
public function Add(
    name: System.String
): System.Integer;
JScript
public function Add(
   name : System.String
) : System.int;
Managed Extensions for C++
public: System.int Add(
   System.string* name
)
C++/CLI
public:
System.int Add(
   System.String^ name
)

Parameters

name

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridColumnSetCollection Class
WebGridColumnSetCollection Members
Overload List


Clear Method

[image]
Intersoft WebGrid Documentation
Clear Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridColumnSetCollection Class : Clear Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Shadows Sub Clear()
Visual Basic (Usage) Copy Code
Dim instance As WebGridColumnSetCollection

instance.Clear()
C#
public new void Clear()
Delphi
public procedure Clear();
JScript
public hide function Clear();
Managed Extensions for C++
public: new void Clear();
C++/CLI
public:
new void Clear();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridColumnSetCollection Class
WebGridColumnSetCollection Members


Contains Method

[image]
Intersoft WebGrid Documentation
Contains Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridColumnSetCollection Class : Contains Method

value

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function Contains( _
   ByVal value As ISNet.WebUI.INamedObject _
) As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebGridColumnSetCollection
Dim value As ISNet.WebUI.INamedObject
Dim value As System.Boolean

value = instance.Contains(value)
C#
public System.bool Contains(
   ISNet.WebUI.INamedObject value
)
Delphi
public function Contains(
    value: ISNet.WebUI.INamedObject
): System.Boolean;
JScript
public function Contains(
   value : ISNet.WebUI.INamedObject
) : System.boolean;
Managed Extensions for C++
public: System.bool Contains(
   ISNet.WebUI.INamedObject* value
)
C++/CLI
public:
System.bool Contains(
   ISNet.WebUI.INamedObject^ value
)

Parameters

value

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridColumnSetCollection Class
WebGridColumnSetCollection Members


CopyFrom Method

[image]
Intersoft WebGrid Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridColumnSetCollection Class : CopyFrom Method

passIn

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function CopyFrom( _
   ByVal passIn As WebGridColumnSetCollection _
) As WebGridColumnSetCollection
Visual Basic (Usage) Copy Code
Dim instance As WebGridColumnSetCollection
Dim passIn As WebGridColumnSetCollection
Dim value As WebGridColumnSetCollection

value = instance.CopyFrom(passIn)
C#
public WebGridColumnSetCollection CopyFrom(
   WebGridColumnSetCollection passIn
)
Delphi
public function CopyFrom(
    passIn: WebGridColumnSetCollection
): WebGridColumnSetCollection;
JScript
public function CopyFrom(
   passIn : WebGridColumnSetCollection
) : WebGridColumnSetCollection;
Managed Extensions for C++
public: WebGridColumnSetCollection* CopyFrom(
   WebGridColumnSetCollection* passIn
)
C++/CLI
public:
WebGridColumnSetCollection^ CopyFrom(
   WebGridColumnSetCollection^ passIn
)

Parameters

passIn

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridColumnSetCollection Class
WebGridColumnSetCollection Members


CopyTo Method

[image]
Intersoft WebGrid Documentation
CopyTo Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridColumnSetCollection Class : CopyTo Method

array
index

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub CopyTo( _
   ByVal array() As ISNet.WebUI.INamedObject, _
   ByVal index As System.Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As WebGridColumnSetCollection
Dim array() As ISNet.WebUI.INamedObject
Dim index As System.Integer

instance.CopyTo(array, index)
C#
public void CopyTo(
   ISNet.WebUI.INamedObject[] array,
   System.int index
)
Delphi
public procedure CopyTo(
    array: ISNet.WebUI.INamedObjectarray of;
    index: System.Integer
);
JScript
public function CopyTo(
   array : ISNet.WebUI.INamedObject[],
   index : System.int
);
Managed Extensions for C++
public: void CopyTo(
   ISNet.WebUI.INamedObject*[]* array,
   System.int index
)
C++/CLI
public:
void CopyTo(
   ISNet.WebUI.array<INamedObject^>^ array,
   System.int index
)

Parameters

array
index

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridColumnSetCollection Class
WebGridColumnSetCollection Members


Exists Method

[image]
Intersoft WebGrid Documentation
Exists Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridColumnSetCollection Class : Exists Method

name

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function Exists( _
   ByVal name As System.String _
) As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebGridColumnSetCollection
Dim name As System.String
Dim value As System.Boolean

value = instance.Exists(name)
C#
public System.bool Exists(
   System.string name
)
Delphi
public function Exists(
    name: System.String
): System.Boolean;
JScript
public function Exists(
   name : System.String
) : System.boolean;
Managed Extensions for C++
public: System.bool Exists(
   System.string* name
)
C++/CLI
public:
System.bool Exists(
   System.String^ name
)

Parameters

name

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridColumnSetCollection Class
WebGridColumnSetCollection Members


GetEnumerator Method

[image]
Intersoft WebGrid Documentation
GetEnumerator Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridColumnSetCollection Class : GetEnumerator Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Shadows Function GetEnumerator() As System.Collections.IEnumerator
Visual Basic (Usage) Copy Code
Dim instance As WebGridColumnSetCollection
Dim value As System.Collections.IEnumerator

value = instance.GetEnumerator()
C#
public new System.Collections.IEnumerator GetEnumerator()
Delphi
public function GetEnumerator(): System.Collections.IEnumerator;
JScript
public hide function GetEnumerator() : System.Collections.IEnumerator;
Managed Extensions for C++
public: new System.Collections.IEnumerator* GetEnumerator();
C++/CLI
public:
new System.Collections.IEnumerator^ GetEnumerator();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridColumnSetCollection Class
WebGridColumnSetCollection Members


GetItem Method

[image]
Intersoft WebGrid Documentation
GetItem Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridColumnSetCollection Class : GetItem Method

Glossary Item Box

Overload List

Overload | Description
GetItem | (Inherited from ISNet.WebUI.ISCollectionBase)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridColumnSetCollection Class
WebGridColumnSetCollection Members


GetItem(Int32) Method

[image]
Intersoft WebGrid Documentation
GetItem(Int32) Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridColumnSetCollection Class : GetItem(Int32) Method

index

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetItem( _
   ByVal index As System.Integer _
) As ISNet.WebUI.INamedObject
Visual Basic (Usage) Copy Code
Dim instance As WebGridColumnSetCollection
Dim index As System.Integer
Dim value As ISNet.WebUI.INamedObject

value = instance.GetItem(index)
C#
public virtual ISNet.WebUI.INamedObject GetItem(
   System.int index
)
Delphi
public function GetItem(
    index: System.Integer
): ISNet.WebUI.INamedObject; virtual;
JScript
public function GetItem(
   index : System.int
) : ISNet.WebUI.INamedObject;
Managed Extensions for C++
public: virtual ISNet.WebUI.INamedObject* GetItem(
   System.int index
)
C++/CLI
public:
virtual ISNet.WebUI.INamedObject^ GetItem(
   System.int index
)

Parameters

index

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridColumnSetCollection Class
WebGridColumnSetCollection Members


GetNamedItem Method

[image]
Intersoft WebGrid Documentation
GetNamedItem Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridColumnSetCollection Class : GetNamedItem Method

name

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetNamedItem( _
   ByVal name As System.String _
) As WebGridColumnSet
Visual Basic (Usage) Copy Code
Dim instance As WebGridColumnSetCollection
Dim name As System.String
Dim value As WebGridColumnSet

value = instance.GetNamedItem(name)
C#
public WebGridColumnSet GetNamedItem(
   System.string name
)
Delphi
public function GetNamedItem(
    name: System.String
): WebGridColumnSet;
JScript
public function GetNamedItem(
   name : System.String
) : WebGridColumnSet;
Managed Extensions for C++
public: WebGridColumnSet* GetNamedItem(
   System.string* name
)
C++/CLI
public:
WebGridColumnSet^ GetNamedItem(
   System.String^ name
)

Parameters

name

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridColumnSetCollection Class
WebGridColumnSetCollection Members


IndexOf Method

[image]
Intersoft WebGrid Documentation
IndexOf Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridColumnSetCollection Class : IndexOf Method

Glossary Item Box

Overload List

Overload | Description
IndexOf(String) | (Inherited from ISNet.WebUI.ISCollectionBase)
IndexOf(INamedObject) | (Inherited from ISNet.WebUI.ISCollectionBase)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridColumnSetCollection Class
WebGridColumnSetCollection Members


IndexOf(String) Method

[image]
Intersoft WebGrid Documentation
IndexOf(String) Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridColumnSetCollection Class > IndexOf Method : IndexOf(String) Method

name

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function IndexOf( _
   ByVal name As System.String _
) As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebGridColumnSetCollection
Dim name As System.String
Dim value As System.Integer

value = instance.IndexOf(name)
C#
public virtual System.int IndexOf(
   System.string name
)
Delphi
public function IndexOf(
    name: System.String
): System.Integer; virtual;
JScript
public function IndexOf(
   name : System.String
) : System.int;
Managed Extensions for C++
public: virtual System.int IndexOf(
   System.string* name
)
C++/CLI
public:
virtual System.int IndexOf(
   System.String^ name
)

Parameters

name

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridColumnSetCollection Class
WebGridColumnSetCollection Members
Overload List


IndexOf(INamedObject) Method

[image]
Intersoft WebGrid Documentation
IndexOf(INamedObject) Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridColumnSetCollection Class > IndexOf Method : IndexOf(INamedObject) Method

value

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function IndexOf( _
   ByVal value As ISNet.WebUI.INamedObject _
) As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebGridColumnSetCollection
Dim value As ISNet.WebUI.INamedObject
Dim value As System.Integer

value = instance.IndexOf(value)
C#
public System.int IndexOf(
   ISNet.WebUI.INamedObject value
)
Delphi
public function IndexOf(
    value: ISNet.WebUI.INamedObject
): System.Integer;
JScript
public function IndexOf(
   value : ISNet.WebUI.INamedObject
) : System.int;
Managed Extensions for C++
public: System.int IndexOf(
   ISNet.WebUI.INamedObject* value
)
C++/CLI
public:
System.int IndexOf(
   ISNet.WebUI.INamedObject^ value
)

Parameters

value

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridColumnSetCollection Class
WebGridColumnSetCollection Members
Overload List


Insert Method

[image]
Intersoft WebGrid Documentation
Insert Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridColumnSetCollection Class : Insert Method

index
webGridColumnSet

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub Insert( _
   ByVal index As System.Integer, _
   ByVal webGridColumnSet As WebGridColumnSet _
)
Visual Basic (Usage) Copy Code
Dim instance As WebGridColumnSetCollection
Dim index As System.Integer
Dim webGridColumnSet As WebGridColumnSet

instance.Insert(index, webGridColumnSet)
C#
public void Insert(
   System.int index,
   WebGridColumnSet webGridColumnSet
)
Delphi
public procedure Insert(
    index: System.Integer;
    webGridColumnSet: WebGridColumnSet
);
JScript
public function Insert(
   index : System.int,
   webGridColumnSet : WebGridColumnSet
);
Managed Extensions for C++
public: void Insert(
   System.int index,
   WebGridColumnSet* webGridColumnSet
)
C++/CLI
public:
void Insert(
   System.int index,
   WebGridColumnSet^ webGridColumnSet
)

Parameters

index
webGridColumnSet

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridColumnSetCollection Class
WebGridColumnSetCollection Members


IntInsert Method

[image]
Intersoft WebGrid Documentation
IntInsert Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridColumnSetCollection Class : IntInsert Method

index
value

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub IntInsert( _
   ByVal index As System.Integer, _
   ByVal value As ISNet.WebUI.INamedObject _
)
Visual Basic (Usage) Copy Code
Dim instance As WebGridColumnSetCollection
Dim index As System.Integer
Dim value As ISNet.WebUI.INamedObject

instance.IntInsert(index, value)
C#
public void IntInsert(
   System.int index,
   ISNet.WebUI.INamedObject value
)
Delphi
public procedure IntInsert(
    index: System.Integer;
    value: ISNet.WebUI.INamedObject
);
JScript
public function IntInsert(
   index : System.int,
   value : ISNet.WebUI.INamedObject
);
Managed Extensions for C++
public: void IntInsert(
   System.int index,
   ISNet.WebUI.INamedObject* value
)
C++/CLI
public:
void IntInsert(
   System.int index,
   ISNet.WebUI.INamedObject^ value
)

Parameters

index
value

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridColumnSetCollection Class
WebGridColumnSetCollection Members


Remove Method

[image]
Intersoft WebGrid Documentation
Remove Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridColumnSetCollection Class : Remove Method

webGridColumnSet

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub Remove( _
   ByVal webGridColumnSet As WebGridColumnSet _
)
Visual Basic (Usage) Copy Code
Dim instance As WebGridColumnSetCollection
Dim webGridColumnSet As WebGridColumnSet

instance.Remove(webGridColumnSet)
C#
public void Remove(
   WebGridColumnSet webGridColumnSet
)
Delphi
public procedure Remove(
    webGridColumnSet: WebGridColumnSet
);
JScript
public function Remove(
   webGridColumnSet : WebGridColumnSet
);
Managed Extensions for C++
public: void Remove(
   WebGridColumnSet* webGridColumnSet
)
C++/CLI
public:
void Remove(
   WebGridColumnSet^ webGridColumnSet
)

Parameters

webGridColumnSet

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridColumnSetCollection Class
WebGridColumnSetCollection Members


Reorder Method

[image]
Intersoft WebGrid Documentation
Reorder Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridColumnSetCollection Class : Reorder Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub Reorder()
Visual Basic (Usage) Copy Code
Dim instance As WebGridColumnSetCollection

instance.Reorder()
C#
public void Reorder()
Delphi
public procedure Reorder();
JScript
public function Reorder();
Managed Extensions for C++
public: void Reorder();
C++/CLI
public:
void Reorder();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridColumnSetCollection Class
WebGridColumnSetCollection Members


setParent Method

[image]
Intersoft WebGrid Documentation
setParent Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridColumnSetCollection Class : setParent Method

parent

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub setParent( _
   ByVal parent As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebGridColumnSetCollection
Dim parent As System.Object

instance.setParent(parent)
C#
public virtual void setParent(
   System.object parent
)
Delphi
public procedure setParent(
    parent: System.TObject
); virtual;
JScript
public function setParent(
   parent : System.Object
);
Managed Extensions for C++
public: virtual void setParent(
   System.Object* parent
)
C++/CLI
public:
virtual void setParent(
   System.Object^ parent
)

Parameters

parent

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridColumnSetCollection Class
WebGridColumnSetCollection Members


Capacity Property

[image]
Intersoft WebGrid Documentation
Capacity Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridColumnSetCollection Class : Capacity Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Runtime.InteropServices.ComVisibleAttribute(False)>
Public Property Capacity As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebGridColumnSetCollection
Dim value As System.Integer

instance.Capacity = value

value = instance.Capacity
C#
[System.Runtime.InteropServices.ComVisibleAttribute(false)]
public System.int Capacity {get; set;}
Delphi
public read-write property Capacity: System.Integer;
JScript
System.Runtime.InteropServices.ComVisibleAttribute()
public function get,set Capacity : System.int
Managed Extensions for C++
[System.Runtime.InteropServices.ComVisibleAttribute(false)]
public: __property System.int get_Capacity();
public: __property void set_Capacity(
   System.int value
);
C++/CLI
[System.Runtime.InteropServices.ComVisibleAttribute(false)]
public:
property System.int Capacity {
   System.int get();
   void set (    System.int value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridColumnSetCollection Class
WebGridColumnSetCollection Members


Count Property

[image]
Intersoft WebGrid Documentation
Count Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridColumnSetCollection Class : Count Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Count As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebGridColumnSetCollection
Dim value As System.Integer

value = instance.Count
C#
public System.int Count {get;}
Delphi
public read-only property Count: System.Integer;
JScript
public function get Count : System.int
Managed Extensions for C++
public: __property System.int get_Count();
C++/CLI
public:
property System.int Count {
   System.int get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridColumnSetCollection Class
WebGridColumnSetCollection Members


WebGridColumnSetCollection Class Properties

[image]
Intersoft WebGrid Documentation
WebGridColumnSetCollection Class Properties
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : WebGridColumnSetCollection Class

Glossary Item Box

For a list of all members of this type, see WebGridColumnSetCollection members.

Public Properties

 | Name | Description
Public Property | Capacity | (Inherited from System.Collections.CollectionBase)
Public Property | Count | (Inherited from System.Collections.CollectionBase)
Public Property | IsReadOnly | Overridden.
Public Property | Item |
Public Property | Parent | (Inherited from ISNet.WebUI.ISCollectionBase)
Top

See Also

Reference

WebGridColumnSetCollection Class
ISNet.WebUI.WebGrid Namespace


WebGridColumnSetCollection Constructor

[image]
Intersoft WebGrid Documentation
WebGridColumnSetCollection Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridColumnSetCollection Class : WebGridColumnSetCollection Constructor

Glossary Item Box

Overload List

Overload | Description
WebGridColumnSetCollection Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridColumnSetCollection Class
WebGridColumnSetCollection Members


IsReadOnly Property

[image]
Intersoft WebGrid Documentation
IsReadOnly Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridColumnSetCollection Class : IsReadOnly Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property IsReadOnly As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebGridColumnSetCollection
Dim value As System.Boolean

value = instance.IsReadOnly
C#
public override System.bool IsReadOnly {get;}
Delphi
public read-only property IsReadOnly: System.Boolean; override;
JScript
public override function get IsReadOnly : System.boolean
Managed Extensions for C++
public: __property System.bool get_IsReadOnly() override;
C++/CLI
public:
property System.bool IsReadOnly {
   System.bool get() override;
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridColumnSetCollection Class
WebGridColumnSetCollection Members


Item Property

[image]
Intersoft WebGrid Documentation
Item Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridColumnSetCollection Class : Item Property

index

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Default Property Item( _
   ByVal index As System.Integer _
) As WebGridColumnSet
Visual Basic (Usage) Copy Code
Dim instance As WebGridColumnSetCollection
Dim index As System.Integer
Dim value As WebGridColumnSet

value = instance.Item(index)
C#
public WebGridColumnSet this[
   System.int index
]; {get;}
Delphi
public  this: : WebGridColumnSet;[
    index: System.Integer
]; read-only
JScript
public  this[
   index : System.int
] get : WebGridColumnSet
Managed Extensions for C++
public: __property WebGridColumnSet* get_Item   System.int index
;
C++/CLI
public:
property WebGridColumnSet^ default [int] {
   WebGridColumnSet^ get(System.int index);
}

Parameters

index

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridColumnSetCollection Class
WebGridColumnSetCollection Members


Parent Property

[image]
Intersoft WebGrid Documentation
Parent Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridColumnSetCollection Class : Parent Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Parent As System.Object
Visual Basic (Usage) Copy Code
Dim instance As WebGridColumnSetCollection
Dim value As System.Object

value = instance.Parent
C#
public System.object Parent {get;}
Delphi
public read-only property Parent: System.TObject;
JScript
public function get Parent : System.Object
Managed Extensions for C++
public: __property System.Object* get_Parent();
C++/CLI
public:
property System.Object^ Parent {
   System.Object^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridColumnSetCollection Class
WebGridColumnSetCollection Members


WebGridCommandItem Class

[image]
Intersoft WebGrid Documentation
WebGridCommandItem Class
Members See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : WebGridCommandItem Class

Glossary Item Box

Object Model

WebGridCommandItem Class

Syntax

Visual Basic (Declaration)
Public Class WebGridCommandItem
Visual Basic (Usage) Copy Code
Dim instance As WebGridCommandItem
C#
public class WebGridCommandItem
Delphi
public class WebGridCommandItem
JScript
public class WebGridCommandItem
Managed Extensions for C++
public __gc class WebGridCommandItem
C++/CLI
public ref class WebGridCommandItem

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebGrid.WebGridCommandItem

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridCommandItem Members
ISNet.WebUI.WebGrid Namespace


WebGridCommandItem Class Members

[image]
Intersoft WebGrid Documentation
WebGridCommandItem Class Members
See Also Properties Send Feedback
ISNet.WebUI.WebGrid Namespace : WebGridCommandItem Class

Glossary Item Box

The following tables list the members exposed by WebGridCommandItem.

Public Constructors

 | Name | Description
Public Constructor | WebGridCommandItem Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | Enabled |
Public Property | FunctionText |
Public Property | ImageUrl |
Public Property | IsToggle |
Public Property | Pushed |
Public Property | Text |
Public Property | TooltipText |
Public Property | Width |
Top

See Also

Reference

WebGridCommandItem Class
ISNet.WebUI.WebGrid Namespace


WebGridCommandItem Constructor

[image]
Intersoft WebGrid Documentation
WebGridCommandItem Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridCommandItem Class : WebGridCommandItem Constructor

Glossary Item Box

Overload List

Overload | Description
WebGridCommandItem Constructor() |
WebGridCommandItem Constructor(String,String,String,String) |
WebGridCommandItem Constructor(String,String,String,String,Boolean) |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridCommandItem Class
WebGridCommandItem Members


WebGridCommandItem Constructor()

[image]
Intersoft WebGrid Documentation
WebGridCommandItem Constructor()
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridCommandItem Class > WebGridCommandItem Constructor : WebGridCommandItem Constructor()

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebGridCommandItem()
C#
public WebGridCommandItem()
Delphi
public WebGridCommandItem();
JScript
public function WebGridCommandItem();
Managed Extensions for C++
public: WebGridCommandItem();
C++/CLI
public:
WebGridCommandItem();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridCommandItem Class
WebGridCommandItem Members
Overload List


WebGridCommandItem Constructor(String,String,String,String)

[image]
Intersoft WebGrid Documentation
WebGridCommandItem Constructor(String,String,String,String)
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridCommandItem Class > WebGridCommandItem Constructor : WebGridCommandItem Constructor(String,String,String,String)

function
tooltip
imageUrl
textLabel

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal function As System.String, _
   ByVal tooltip As System.String, _
   ByVal imageUrl As System.String, _
   ByVal textLabel As System.String _
)
Visual Basic (Usage) Copy Code
Dim function As System.String
Dim tooltip As System.String
Dim imageUrl As System.String
Dim textLabel As System.String

Dim instance As New WebGridCommandItem(function, tooltip, imageUrl, textLabel)
C#
public WebGridCommandItem(
   System.string function,
   System.string tooltip,
   System.string imageUrl,
   System.string textLabel
)
Delphi
public WebGridCommandItem(
    function: System.String;
    tooltip: System.String;
    imageUrl: System.String;
    textLabel: System.String
);
JScript
public function WebGridCommandItem(
   function : System.String,
   tooltip : System.String,
   imageUrl : System.String,
   textLabel : System.String
);
Managed Extensions for C++
public: WebGridCommandItem(
   System.string* function,
   System.string* tooltip,
   System.string* imageUrl,
   System.string* textLabel
)
C++/CLI
public:
WebGridCommandItem(
   System.String^ function,
   System.String^ tooltip,
   System.String^ imageUrl,
   System.String^ textLabel
)

Parameters

function
tooltip
imageUrl
textLabel

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridCommandItem Class
WebGridCommandItem Members
Overload List


WebGridCommandItem Constructor(String,String,String,String,Boolean)

[image]
Intersoft WebGrid Documentation
WebGridCommandItem Constructor(String,String,String,String,Boolean)
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridCommandItem Class > WebGridCommandItem Constructor : WebGridCommandItem Constructor(String,String,String,String,Boolean)

function
tooltip
imageUrl
textLabel
enabled

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal function As System.String, _
   ByVal tooltip As System.String, _
   ByVal imageUrl As System.String, _
   ByVal textLabel As System.String, _
   ByVal enabled As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim function As System.String
Dim tooltip As System.String
Dim imageUrl As System.String
Dim textLabel As System.String
Dim enabled As System.Boolean

Dim instance As New WebGridCommandItem(function, tooltip, imageUrl, textLabel, enabled)
C#
public WebGridCommandItem(
   System.string function,
   System.string tooltip,
   System.string imageUrl,
   System.string textLabel,
   System.bool enabled
)
Delphi
public WebGridCommandItem(
    function: System.String;
    tooltip: System.String;
    imageUrl: System.String;
    textLabel: System.String;
    enabled: System.Boolean
);
JScript
public function WebGridCommandItem(
   function : System.String,
   tooltip : System.String,
   imageUrl : System.String,
   textLabel : System.String,
   enabled : System.boolean
);
Managed Extensions for C++
public: WebGridCommandItem(
   System.string* function,
   System.string* tooltip,
   System.string* imageUrl,
   System.string* textLabel,
   System.bool enabled
)
C++/CLI
public:
WebGridCommandItem(
   System.String^ function,
   System.String^ tooltip,
   System.String^ imageUrl,
   System.String^ textLabel,
   System.bool enabled
)

Parameters

function
tooltip
imageUrl
textLabel
enabled

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridCommandItem Class
WebGridCommandItem Members
Overload List


WebGridCommandItem Class Properties

[image]
Intersoft WebGrid Documentation
WebGridCommandItem Class Properties
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : WebGridCommandItem Class

Glossary Item Box

For a list of all members of this type, see WebGridCommandItem members.

Public Properties

 | Name | Description
Public Property | Enabled |
Public Property | FunctionText |
Public Property | ImageUrl |
Public Property | IsToggle |
Public Property | Pushed |
Public Property | Text |
Public Property | TooltipText |
Public Property | Width |
Top

See Also

Reference

WebGridCommandItem Class
ISNet.WebUI.WebGrid Namespace


Enabled Property

[image]
Intersoft WebGrid Documentation
Enabled Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridCommandItem Class : Enabled Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Enabled As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebGridCommandItem
Dim value As System.Boolean

instance.Enabled = value

value = instance.Enabled
C#
public System.bool Enabled {get; set;}
Delphi
public read-write property Enabled: System.Boolean;
JScript
public function get,set Enabled : System.boolean
Managed Extensions for C++
public: __property System.bool get_Enabled();
public: __property void set_Enabled(
   System.bool value
);
C++/CLI
public:
property System.bool Enabled {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridCommandItem Class
WebGridCommandItem Members


FunctionText Property

[image]
Intersoft WebGrid Documentation
FunctionText Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridCommandItem Class : FunctionText Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property FunctionText As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebGridCommandItem
Dim value As System.String

instance.FunctionText = value

value = instance.FunctionText
C#
public System.string FunctionText {get; set;}
Delphi
public read-write property FunctionText: System.String;
JScript
public function get,set FunctionText : System.String
Managed Extensions for C++
public: __property System.string* get_FunctionText();
public: __property void set_FunctionText(
   System.string* value
);
C++/CLI
public:
property System.String^ FunctionText {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridCommandItem Class
WebGridCommandItem Members


ImageUrl Property

[image]
Intersoft WebGrid Documentation
ImageUrl Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridCommandItem Class : ImageUrl Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property ImageUrl As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebGridCommandItem
Dim value As System.String

instance.ImageUrl = value

value = instance.ImageUrl
C#
public System.string ImageUrl {get; set;}
Delphi
public read-write property ImageUrl: System.String;
JScript
public function get,set ImageUrl : System.String
Managed Extensions for C++
public: __property System.string* get_ImageUrl();
public: __property void set_ImageUrl(
   System.string* value
);
C++/CLI
public:
property System.String^ ImageUrl {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridCommandItem Class
WebGridCommandItem Members


IsToggle Property

[image]
Intersoft WebGrid Documentation
IsToggle Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridCommandItem Class : IsToggle Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property IsToggle As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebGridCommandItem
Dim value As System.Boolean

instance.IsToggle = value

value = instance.IsToggle
C#
public System.bool IsToggle {get; set;}
Delphi
public read-write property IsToggle: System.Boolean;
JScript
public function get,set IsToggle : System.boolean
Managed Extensions for C++
public: __property System.bool get_IsToggle();
public: __property void set_IsToggle(
   System.bool value
);
C++/CLI
public:
property System.bool IsToggle {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridCommandItem Class
WebGridCommandItem Members


Pushed Property

[image]
Intersoft WebGrid Documentation
Pushed Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridCommandItem Class : Pushed Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Pushed As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebGridCommandItem
Dim value As System.Boolean

instance.Pushed = value

value = instance.Pushed
C#
public System.bool Pushed {get; set;}
Delphi
public read-write property Pushed: System.Boolean;
JScript
public function get,set Pushed : System.boolean
Managed Extensions for C++
public: __property System.bool get_Pushed();
public: __property void set_Pushed(
   System.bool value
);
C++/CLI
public:
property System.bool Pushed {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridCommandItem Class
WebGridCommandItem Members


Text Property

[image]
Intersoft WebGrid Documentation
Text Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridCommandItem Class : Text Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Text As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebGridCommandItem
Dim value As System.String

instance.Text = value

value = instance.Text
C#
public System.string Text {get; set;}
Delphi
public read-write property Text: System.String;
JScript
public function get,set Text : System.String
Managed Extensions for C++
public: __property System.string* get_Text();
public: __property void set_Text(
   System.string* value
);
C++/CLI
public:
property System.String^ Text {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridCommandItem Class
WebGridCommandItem Members


TooltipText Property

[image]
Intersoft WebGrid Documentation
TooltipText Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridCommandItem Class : TooltipText Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property TooltipText As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebGridCommandItem
Dim value As System.String

instance.TooltipText = value

value = instance.TooltipText
C#
public System.string TooltipText {get; set;}
Delphi
public read-write property TooltipText: System.String;
JScript
public function get,set TooltipText : System.String
Managed Extensions for C++
public: __property System.string* get_TooltipText();
public: __property void set_TooltipText(
   System.string* value
);
C++/CLI
public:
property System.String^ TooltipText {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridCommandItem Class
WebGridCommandItem Members


Width Property

[image]
Intersoft WebGrid Documentation
Width Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridCommandItem Class : Width Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Width As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebGridCommandItem
Dim value As System.Integer

instance.Width = value

value = instance.Width
C#
public System.int Width {get; set;}
Delphi
public read-write property Width: System.Integer;
JScript
public function get,set Width : System.int
Managed Extensions for C++
public: __property System.int get_Width();
public: __property void set_Width(
   System.int value
);
C++/CLI
public:
property System.int Width {
   System.int get();
   void set (    System.int value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridCommandItem Class
WebGridCommandItem Members


WebGridComponentEditor Class

[image]
Intersoft WebGrid Documentation
WebGridComponentEditor Class
Members See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : WebGridComponentEditor Class

Glossary Item Box

Object Model

WebGridComponentEditor Class

Syntax

Visual Basic (Declaration)
Public Class WebGridComponentEditor
   Inherits System.Windows.Forms.Design.WindowsFormsComponentEditor
Visual Basic (Usage) Copy Code
Dim instance As WebGridComponentEditor
C#
public class WebGridComponentEditor : System.Windows.Forms.Design.WindowsFormsComponentEditor
Delphi
public class WebGridComponentEditor = class(System.Windows.Forms.Design.WindowsFormsComponentEditor)
JScript
public class WebGridComponentEditor extends System.Windows.Forms.Design.WindowsFormsComponentEditor
Managed Extensions for C++
public __gc class WebGridComponentEditor : public System.Windows.Forms.Design.WindowsFormsComponentEditor
C++/CLI
public ref class WebGridComponentEditor : public System.Windows.Forms.Design.WindowsFormsComponentEditor

Inheritance Hierarchy

System.Object
System.ComponentModel.ComponentEditor
System.Windows.Forms.Design.WindowsFormsComponentEditor
ISNet.WebUI.WebGrid.WebGridComponentEditor

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridComponentEditor Members
ISNet.WebUI.WebGrid Namespace


WebGridComponentEditor Class Members

[image]
Intersoft WebGrid Documentation
WebGridComponentEditor Class Members
See Also Methods Send Feedback
ISNet.WebUI.WebGrid Namespace : WebGridComponentEditor Class

Glossary Item Box

The following tables list the members exposed by WebGridComponentEditor.

Public Constructors

 | Name | Description
Public Constructor | WebGridComponentEditor Constructor |
Top

Public Methods

 | Name | Description
Public Method | EditComponent | Overloaded. Overridden.
Top

See Also

Reference

WebGridComponentEditor Class
ISNet.WebUI.WebGrid Namespace


WebGridComponentEditor Constructor

[image]
Intersoft WebGrid Documentation
WebGridComponentEditor Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridComponentEditor Class : WebGridComponentEditor Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebGridComponentEditor()
C#
public WebGridComponentEditor()
Delphi
public WebGridComponentEditor();
JScript
public function WebGridComponentEditor();
Managed Extensions for C++
public: WebGridComponentEditor();
C++/CLI
public:
WebGridComponentEditor();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridComponentEditor Class
WebGridComponentEditor Members


WebGridComponentEditor Class Methods

[image]
Intersoft WebGrid Documentation
WebGridComponentEditor Class Methods
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : WebGridComponentEditor Class

Glossary Item Box

For a list of all members of this type, see WebGridComponentEditor members.

Public Methods

 | Name | Description
Public Method | EditComponent | Overloaded. Overridden.
Top

See Also

Reference

WebGridComponentEditor Class
ISNet.WebUI.WebGrid Namespace


EditComponent Method

[image]
Intersoft WebGrid Documentation
EditComponent Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridComponentEditor Class : EditComponent Method

Glossary Item Box

Overload List

Overload | Description
EditComponent(ITypeDescriptorContext,Object,IWin32Window) |
EditComponent(ITypeDescriptorContext,Object) | (Inherited from System.Windows.Forms.Design.WindowsFormsComponentEditor)
EditComponent(Object,IWin32Window) | (Inherited from System.Windows.Forms.Design.WindowsFormsComponentEditor)
EditComponent(Object) | (Inherited from System.ComponentModel.ComponentEditor)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridComponentEditor Class
WebGridComponentEditor Members


EditComponent(ITypeDescriptorContext,Object,IWin32Window) Method

[image]
Intersoft WebGrid Documentation
EditComponent(ITypeDescriptorContext,Object,IWin32Window) Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridComponentEditor Class > EditComponent Method : EditComponent(ITypeDescriptorContext,Object,IWin32Window) Method

context
component
owner

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Function EditComponent( _
   ByVal context As System.ComponentModel.ITypeDescriptorContext, _
   ByVal component As System.Object, _
   ByVal owner As System.Windows.Forms.IWin32Window _
) As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebGridComponentEditor
Dim context As System.ComponentModel.ITypeDescriptorContext
Dim component As System.Object
Dim owner As System.Windows.Forms.IWin32Window
Dim value As System.Boolean

value = instance.EditComponent(context, component, owner)
C#
public override System.bool EditComponent(
   System.ComponentModel.ITypeDescriptorContext context,
   System.object component,
   System.Windows.Forms.IWin32Window owner
)
Delphi
public function EditComponent(
    context: System.ComponentModel.ITypeDescriptorContext;
    component: System.TObject;
    owner: System.Windows.Forms.IWin32Window
): System.Boolean; override;
JScript
public override function EditComponent(
   context : System.ComponentModel.ITypeDescriptorContext,
   component : System.Object,
   owner : System.Windows.Forms.IWin32Window
) : System.boolean;
Managed Extensions for C++
public: System.bool EditComponent(
   System.ComponentModel.ITypeDescriptorContext* context,
   System.Object* component,
   System.Windows.Forms.IWin32Window* owner
) override
C++/CLI
public:
System.bool EditComponent(
   System.ComponentModel.ITypeDescriptorContext^ context,
   System.Object^ component,
   System.Windows.Forms.IWin32Window^ owner
) override

Parameters

context
component
owner

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridComponentEditor Class
WebGridComponentEditor Members
Overload List


EditComponent(ITypeDescriptorContext,Object) Method

[image]
Intersoft WebGrid Documentation
EditComponent(ITypeDescriptorContext,Object) Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridComponentEditor Class > EditComponent Method : EditComponent(ITypeDescriptorContext,Object) Method

context
component

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")>
Public Overloads Overridable Function EditComponent( _
   ByVal context As System.ComponentModel.ITypeDescriptorContext, _
   ByVal component As System.Object _
) As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebGridComponentEditor
Dim context As System.ComponentModel.ITypeDescriptorContext
Dim component As System.Object
Dim value As System.Boolean

value = instance.EditComponent(context, component)
C#
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public virtual System.bool EditComponent(
   System.ComponentModel.ITypeDescriptorContext context,
   System.object component
)
Delphi
public function EditComponent(
    context: System.ComponentModel.ITypeDescriptorContext;
    component: System.TObject
): System.Boolean; virtual;
JScript
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")
public function EditComponent(
   context : System.ComponentModel.ITypeDescriptorContext,
   component : System.Object
) : System.boolean;
Managed Extensions for C++
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public: virtual System.bool EditComponent(
   System.ComponentModel.ITypeDescriptorContext* context,
   System.Object* component
)
C++/CLI
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public:
virtual System.bool EditComponent(
   System.ComponentModel.ITypeDescriptorContext^ context,
   System.Object^ component
)

Parameters

context
component

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridComponentEditor Class
WebGridComponentEditor Members
Overload List


EditComponent(Object,IWin32Window) Method

[image]
Intersoft WebGrid Documentation
EditComponent(Object,IWin32Window) Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridComponentEditor Class > EditComponent Method : EditComponent(Object,IWin32Window) Method

component
owner

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")>
Public Overloads Function EditComponent( _
   ByVal component As System.Object, _
   ByVal owner As System.Windows.Forms.IWin32Window _
) As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebGridComponentEditor
Dim component As System.Object
Dim owner As System.Windows.Forms.IWin32Window
Dim value As System.Boolean

value = instance.EditComponent(component, owner)
C#
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public System.bool EditComponent(
   System.object component,
   System.Windows.Forms.IWin32Window owner
)
Delphi
public function EditComponent(
    component: System.TObject;
    owner: System.Windows.Forms.IWin32Window
): System.Boolean;
JScript
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")
public function EditComponent(
   component : System.Object,
   owner : System.Windows.Forms.IWin32Window
) : System.boolean;
Managed Extensions for C++
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public: System.bool EditComponent(
   System.Object* component,
   System.Windows.Forms.IWin32Window* owner
)
C++/CLI
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public:
System.bool EditComponent(
   System.Object^ component,
   System.Windows.Forms.IWin32Window^ owner
)

Parameters

component
owner

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridComponentEditor Class
WebGridComponentEditor Members
Overload List


EditComponent(Object) Method

[image]
Intersoft WebGrid Documentation
EditComponent(Object) Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridComponentEditor Class > EditComponent Method : EditComponent(Object) Method

component

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")>
Public Overloads Function EditComponent( _
   ByVal component As System.Object _
) As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebGridComponentEditor
Dim component As System.Object
Dim value As System.Boolean

value = instance.EditComponent(component)
C#
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public System.bool EditComponent(
   System.object component
)
Delphi
public function EditComponent(
    component: System.TObject
): System.Boolean;
JScript
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")
public function EditComponent(
   component : System.Object
) : System.boolean;
Managed Extensions for C++
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public: System.bool EditComponent(
   System.Object* component
)
C++/CLI
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public:
System.bool EditComponent(
   System.Object^ component
)

Parameters

component

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridComponentEditor Class
WebGridComponentEditor Members
Overload List


WebGridCustomEditor Class

[image]
Intersoft WebGrid Documentation
WebGridCustomEditor Class
Members See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : WebGridCustomEditor Class

Glossary Item Box

Object Model

WebGridCustomEditor Class

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.DescriptionAttribute()>
<System.SerializableAttribute()>
Public Class WebGridCustomEditor
   Inherits ISNet.WebUI.NamedObjectBase
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject
Visual Basic (Usage) Copy Code
Dim instance As WebGridCustomEditor
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DescriptionAttribute()]
[System.SerializableAttribute()]
public class WebGridCustomEditor : ISNet.WebUI.NamedObjectBase, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject
Delphi
public class WebGridCustomEditor = class(ISNet.WebUI.NamedObjectBase, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject)
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.DescriptionAttribute()
System.SerializableAttribute()
public class WebGridCustomEditor extends ISNet.WebUI.NamedObjectBase implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DescriptionAttribute()]
[System.SerializableAttribute()]
public __gc class WebGridCustomEditor : public ISNet.WebUI.NamedObjectBase, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DescriptionAttribute()]
[System.SerializableAttribute()]
public ref class WebGridCustomEditor : public ISNet.WebUI.NamedObjectBase, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.NamedObjectBase
ISNet.WebUI.WebGrid.WebGridCustomEditor

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridCustomEditor Members
ISNet.WebUI.WebGrid Namespace


WebGridCustomEditor Class Members

[image]
Intersoft WebGrid Documentation
WebGridCustomEditor Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebGrid Namespace : WebGridCustomEditor Class

Glossary Item Box

The following tables list the members exposed by WebGridCustomEditor.

Public Constructors

 | Name | Description
Public Constructor | WebGridCustomEditor Constructor |
Top

Public Properties

 | Name | Description
Public Property | Behavior |
Public Property | ControlType |
Public Property | DependencyFiles |
Public Property | DependencyFolder |
Public Property | JavascriptEncoded |
Public Property | JavascriptFiles |
Public Property | Name | Overridden.
Public Property | Persistence |
Public Property | ScriptFolder |
Public Property | ServerControlFullName |
Public Property | UseWebResources |
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | LoadFromControlFile |
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SaveControlFile |
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString |
Top

See Also

Reference

WebGridCustomEditor Class
ISNet.WebUI.WebGrid Namespace


WebGridCustomEditor Constructor

[image]
Intersoft WebGrid Documentation
WebGridCustomEditor Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridCustomEditor Class : WebGridCustomEditor Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebGridCustomEditor()
C#
public WebGridCustomEditor()
Delphi
public WebGridCustomEditor();
JScript
public function WebGridCustomEditor();
Managed Extensions for C++
public: WebGridCustomEditor();
C++/CLI
public:
WebGridCustomEditor();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridCustomEditor Class
WebGridCustomEditor Members


Clone Method

[image]
Intersoft WebGrid Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridCustomEditor Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As System.Object
Visual Basic (Usage) Copy Code
Dim instance As WebGridCustomEditor
Dim value As System.Object

value = instance.Clone()
C#
public virtual System.object Clone()
Delphi
public function Clone(): System.TObject; virtual;
JScript
public function Clone() : System.Object;
Managed Extensions for C++
public: virtual System.Object* Clone();
C++/CLI
public:
virtual System.Object^ Clone();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridCustomEditor Class
WebGridCustomEditor Members


CopyFrom Method

[image]
Intersoft WebGrid Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridCustomEditor Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridCustomEditor Class
WebGridCustomEditor Members


CopyFrom(Object) Method

[image]
Intersoft WebGrid Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridCustomEditor Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebGridCustomEditor
Dim objSource As System.Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   System.object objSource
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridCustomEditor Class
WebGridCustomEditor Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebGrid Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridCustomEditor Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object, _
   ByVal cloneSourceValue As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebGridCustomEditor
Dim objSource As System.Object
Dim cloneSourceValue As System.Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   System.object objSource,
   System.bool cloneSourceValue
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject;
    cloneSourceValue: System.Boolean
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object,
   cloneSourceValue : System.boolean
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource,
   System.bool cloneSourceValue
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource,
   System.bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridCustomEditor Class
WebGridCustomEditor Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebGrid Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridCustomEditor Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebGridCustomEditor
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure DeSerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function DeSerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void DeSerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void DeSerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridCustomEditor Class
WebGridCustomEditor Members


GetHashCode Method

[image]
Intersoft WebGrid Documentation
GetHashCode Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridCustomEditor Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebGridCustomEditor
Dim value As System.Integer

value = instance.GetHashCode()
C#
public virtual System.int GetHashCode()
Delphi
public function GetHashCode(): System.Integer; virtual;
JScript
public function GetHashCode() : System.int;
Managed Extensions for C++
public: virtual System.int GetHashCode();
C++/CLI
public:
virtual System.int GetHashCode();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridCustomEditor Class
WebGridCustomEditor Members


WebGridCustomEditor Class Methods

[image]
Intersoft WebGrid Documentation
WebGridCustomEditor Class Methods
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : WebGridCustomEditor Class

Glossary Item Box

For a list of all members of this type, see WebGridCustomEditor members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | LoadFromControlFile |
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SaveControlFile |
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString |
Top

See Also

Reference

WebGridCustomEditor Class
ISNet.WebUI.WebGrid Namespace


GetObjectData Method

[image]
Intersoft WebGrid Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridCustomEditor Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebGridCustomEditor
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure GetObjectData(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
); override;
JScript
public override function GetObjectData(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void GetObjectData(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
) override
C++/CLI
public:
void GetObjectData(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
) override

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridCustomEditor Class
WebGridCustomEditor Members


IsEmpty Method

[image]
Intersoft WebGrid Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridCustomEditor Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebGridCustomEditor
Dim value As System.Boolean

value = instance.IsEmpty()
C#
public virtual System.bool IsEmpty()
Delphi
public function IsEmpty(): System.Boolean; virtual;
JScript
public function IsEmpty() : System.boolean;
Managed Extensions for C++
public: virtual System.bool IsEmpty();
C++/CLI
public:
virtual System.bool IsEmpty();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridCustomEditor Class
WebGridCustomEditor Members


LoadFromControlFile Method

[image]
Intersoft WebGrid Documentation
LoadFromControlFile Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridCustomEditor Class : LoadFromControlFile Method

fileName

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub LoadFromControlFile( _
   ByVal fileName As System.String _
)
Visual Basic (Usage) Copy Code
Dim instance As WebGridCustomEditor
Dim fileName As System.String

instance.LoadFromControlFile(fileName)
C#
public void LoadFromControlFile(
   System.string fileName
)
Delphi
public procedure LoadFromControlFile(
    fileName: System.String
);
JScript
public function LoadFromControlFile(
   fileName : System.String
);
Managed Extensions for C++
public: void LoadFromControlFile(
   System.string* fileName
)
C++/CLI
public:
void LoadFromControlFile(
   System.String^ fileName
)

Parameters

fileName

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridCustomEditor Class
WebGridCustomEditor Members


Reset Method

[image]
Intersoft WebGrid Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridCustomEditor Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As WebGridCustomEditor

instance.Reset()
C#
public virtual void Reset()
Delphi
public procedure Reset(); virtual;
JScript
public function Reset();
Managed Extensions for C++
public: virtual void Reset();
C++/CLI
public:
virtual void Reset();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridCustomEditor Class
WebGridCustomEditor Members


SaveControlFile Method

[image]
Intersoft WebGrid Documentation
SaveControlFile Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridCustomEditor Class : SaveControlFile Method

fileName

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SaveControlFile( _
   ByVal fileName As System.String _
)
Visual Basic (Usage) Copy Code
Dim instance As WebGridCustomEditor
Dim fileName As System.String

instance.SaveControlFile(fileName)
C#
public void SaveControlFile(
   System.string fileName
)
Delphi
public procedure SaveControlFile(
    fileName: System.String
);
JScript
public function SaveControlFile(
   fileName : System.String
);
Managed Extensions for C++
public: void SaveControlFile(
   System.string* fileName
)
C++/CLI
public:
void SaveControlFile(
   System.String^ fileName
)

Parameters

fileName

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridCustomEditor Class
WebGridCustomEditor Members


SerializeObjectData Method

[image]
Intersoft WebGrid Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridCustomEditor Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebGridCustomEditor
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure SerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function SerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void SerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void SerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridCustomEditor Class
WebGridCustomEditor Members


ToString Method

[image]
Intersoft WebGrid Documentation
ToString Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridCustomEditor Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString() As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebGridCustomEditor
Dim value As System.String

value = instance.ToString()
C#
public override System.string ToString()
Delphi
public function ToString(): System.String; override;
JScript
public override function ToString() : System.String;
Managed Extensions for C++
public: System.string* ToString(); override
C++/CLI
public:
System.String^ ToString(); override

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridCustomEditor Class
WebGridCustomEditor Members


WebGridCustomEditor Class Properties

[image]
Intersoft WebGrid Documentation
WebGridCustomEditor Class Properties
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : WebGridCustomEditor Class

Glossary Item Box

For a list of all members of this type, see WebGridCustomEditor members.

Public Properties

 | Name | Description
Public Property | Behavior |
Public Property | ControlType |
Public Property | DependencyFiles |
Public Property | DependencyFolder |
Public Property | JavascriptEncoded |
Public Property | JavascriptFiles |
Public Property | Name | Overridden.
Public Property | Persistence |
Public Property | ScriptFolder |
Public Property | ServerControlFullName |
Public Property | UseWebResources |
Top

See Also

Reference

WebGridCustomEditor Class
ISNet.WebUI.WebGrid Namespace


WebGridCustomEditor Constructor

[image]
Intersoft WebGrid Documentation
WebGridCustomEditor Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridCustomEditor Class : WebGridCustomEditor Constructor

Glossary Item Box

Overload List

Overload | Description
WebGridCustomEditor Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridCustomEditor Class
WebGridCustomEditor Members


Behavior Property

[image]
Intersoft WebGrid Documentation
Behavior Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridCustomEditor Class : Behavior Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Contains settings for custom editor behaviors.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
Public Property Behavior As WebGridCustomEditorBehavior
Visual Basic (Usage) Copy Code
Dim instance As WebGridCustomEditor
Dim value As WebGridCustomEditorBehavior

instance.Behavior = value

value = instance.Behavior
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Contains settings for custom editor behaviors.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
public WebGridCustomEditorBehavior Behavior {get; set;}
Delphi
public read-write property Behavior: WebGridCustomEditorBehavior;
JScript
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DescriptionAttribute("Contains settings for custom editor behaviors.")
System.ComponentModel.NotifyParentPropertyAttribute()
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
public function get,set Behavior : WebGridCustomEditorBehavior
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Contains settings for custom editor behaviors.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
public: __property WebGridCustomEditorBehavior* get_Behavior();
public: __property void set_Behavior(
   WebGridCustomEditorBehavior* value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Contains settings for custom editor behaviors.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
public:
property WebGridCustomEditorBehavior^ Behavior {
   WebGridCustomEditorBehavior^ get();
   void set (    WebGridCustomEditorBehavior^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridCustomEditor Class
WebGridCustomEditor Members


ControlType Property

[image]
Intersoft WebGrid Documentation
ControlType Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridCustomEditor Class : ControlType Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Gets or sets the control type for this custom editor.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property ControlType As ControlType
Visual Basic (Usage) Copy Code
Dim instance As WebGridCustomEditor
Dim value As ControlType

instance.ControlType = value

value = instance.ControlType
C#
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the control type for this custom editor.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public ControlType ControlType {get; set;}
Delphi
public read-write property ControlType: ControlType;
JScript
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the control type for this custom editor.")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get,set ControlType : ControlType
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the control type for this custom editor.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property ControlType get_ControlType();
public: __property void set_ControlType(
   ControlType value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the control type for this custom editor.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property ControlType ControlType {
   ControlType get();
   void set (    ControlType value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridCustomEditor Class
WebGridCustomEditor Members


DependencyFiles Property

[image]
Intersoft WebGrid Documentation
DependencyFiles Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridCustomEditor Class : DependencyFiles Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Gets or sets the dependency resources files required by the custom editor. Separate each file with ; character.")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property DependencyFiles As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebGridCustomEditor
Dim value As System.String

instance.DependencyFiles = value

value = instance.DependencyFiles
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the dependency resources files required by the custom editor. Separate each file with ; character.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.string DependencyFiles {get; set;}
Delphi
public read-write property DependencyFiles: System.String;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the dependency resources files required by the custom editor. Separate each file with ; character.")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set DependencyFiles : System.String
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the dependency resources files required by the custom editor. Separate each file with ; character.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.string* get_DependencyFiles();
public: __property void set_DependencyFiles(
   System.string* value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the dependency resources files required by the custom editor. Separate each file with ; character.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.String^ DependencyFiles {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridCustomEditor Class
WebGridCustomEditor Members


DependencyFolder Property

[image]
Intersoft WebGrid Documentation
DependencyFolder Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridCustomEditor Class : DependencyFolder Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Gets or sets the dependency folder for this custom editor. Leave the property blank will automatically retrieve the dependencies from SmartWebResources.")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property DependencyFolder As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebGridCustomEditor
Dim value As System.String

instance.DependencyFolder = value

value = instance.DependencyFolder
C#
[System.ComponentModel.DescriptionAttribute("Gets or sets the dependency folder for this custom editor. Leave the property blank will automatically retrieve the dependencies from SmartWebResources.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public System.string DependencyFolder {get; set;}
Delphi
public read-write property DependencyFolder: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Gets or sets the dependency folder for this custom editor. Leave the property blank will automatically retrieve the dependencies from SmartWebResources.")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get,set DependencyFolder : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Gets or sets the dependency folder for this custom editor. Leave the property blank will automatically retrieve the dependencies from SmartWebResources.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.string* get_DependencyFolder();
public: __property void set_DependencyFolder(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Gets or sets the dependency folder for this custom editor. Leave the property blank will automatically retrieve the dependencies from SmartWebResources.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.String^ DependencyFolder {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridCustomEditor Class
WebGridCustomEditor Members


JavascriptEncoded Property

[image]
Intersoft WebGrid Documentation
JavascriptEncoded Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridCustomEditor Class : JavascriptEncoded Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Determines whether the javascript files used in this custom editor are encoded.")>
Public Property JavascriptEncoded As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebGridCustomEditor
Dim value As System.Boolean

instance.JavascriptEncoded = value

value = instance.JavascriptEncoded
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Determines whether the javascript files used in this custom editor are encoded.")]
public System.bool JavascriptEncoded {get; set;}
Delphi
public read-write property JavascriptEncoded: System.Boolean;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Determines whether the javascript files used in this custom editor are encoded.")
public function get,set JavascriptEncoded : System.boolean
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Determines whether the javascript files used in this custom editor are encoded.")]
public: __property System.bool get_JavascriptEncoded();
public: __property void set_JavascriptEncoded(
   System.bool value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Determines whether the javascript files used in this custom editor are encoded.")]
public:
property System.bool JavascriptEncoded {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridCustomEditor Class
WebGridCustomEditor Members


JavascriptFiles Property

[image]
Intersoft WebGrid Documentation
JavascriptFiles Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridCustomEditor Class : JavascriptFiles Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Gets or sets the javascript files used in this custom editor. Separate each file with ; character.")>
Public Property JavascriptFiles As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebGridCustomEditor
Dim value As System.String

instance.JavascriptFiles = value

value = instance.JavascriptFiles
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the javascript files used in this custom editor. Separate each file with ; character.")]
public System.string JavascriptFiles {get; set;}
Delphi
public read-write property JavascriptFiles: System.String;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the javascript files used in this custom editor. Separate each file with ; character.")
public function get,set JavascriptFiles : System.String
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the javascript files used in this custom editor. Separate each file with ; character.")]
public: __property System.string* get_JavascriptFiles();
public: __property void set_JavascriptFiles(
   System.string* value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the javascript files used in this custom editor. Separate each file with ; character.")]
public:
property System.String^ JavascriptFiles {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridCustomEditor Class
WebGridCustomEditor Members


Name Property

[image]
Intersoft WebGrid Documentation
Name Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridCustomEditor Class : Name Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.BrowsableAttribute(True)>
<System.ComponentModel.DescriptionAttribute()>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Visible)>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Overrides Property Name As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebGridCustomEditor
Dim value As System.String

instance.Name = value

value = instance.Name
C#
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.BrowsableAttribute(true)]
[System.ComponentModel.DescriptionAttribute()]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Visible)]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public override System.string Name {get; set;}
Delphi
public read-write property Name: System.String; override;
JScript
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.BrowsableAttribute()
System.ComponentModel.DescriptionAttribute()
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Visible)
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public override function get,set Name : System.String
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.BrowsableAttribute(true)]
[System.ComponentModel.DescriptionAttribute()]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Visible)]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.string* get_Name() override;
public: __property void set_Name(
   System.string* value
) override;
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.BrowsableAttribute(true)]
[System.ComponentModel.DescriptionAttribute()]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Visible)]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.String^ Name {
   System.String^ get() override;
   void set (    System.String^ value) override;
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridCustomEditor Class
WebGridCustomEditor Members


Persistence Property

[image]
Intersoft WebGrid Documentation
Persistence Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridCustomEditor Class : Persistence Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Determines the persistence level where the custom editor definition should be stored. This feature is obsolete in version 5.0.")>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property Persistence As PersistenceType
Visual Basic (Usage) Copy Code
Dim instance As WebGridCustomEditor
Dim value As PersistenceType

instance.Persistence = value

value = instance.Persistence
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Determines the persistence level where the custom editor definition should be stored. This feature is obsolete in version 5.0.")]
[ISNet.Serialization.BinarySerializableAttribute()]
public PersistenceType Persistence {get; set;}
Delphi
public read-write property Persistence: PersistenceType;
JScript
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Determines the persistence level where the custom editor definition should be stored. This feature is obsolete in version 5.0.")
ISNet.Serialization.BinarySerializableAttribute()
public function get,set Persistence : PersistenceType
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Determines the persistence level where the custom editor definition should be stored. This feature is obsolete in version 5.0.")]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property PersistenceType get_Persistence();
public: __property void set_Persistence(
   PersistenceType value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Determines the persistence level where the custom editor definition should be stored. This feature is obsolete in version 5.0.")]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property PersistenceType Persistence {
   PersistenceType get();
   void set (    PersistenceType value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridCustomEditor Class
WebGridCustomEditor Members


ScriptFolder Property

[image]
Intersoft WebGrid Documentation
ScriptFolder Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridCustomEditor Class : ScriptFolder Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Gets or sets the script folder for this custom editor.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
Public Property ScriptFolder As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebGridCustomEditor
Dim value As System.String

instance.ScriptFolder = value

value = instance.ScriptFolder
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the script folder for this custom editor.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public System.string ScriptFolder {get; set;}
Delphi
public read-write property ScriptFolder: System.String;
JScript
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the script folder for this custom editor.")
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
public function get,set ScriptFolder : System.String
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the script folder for this custom editor.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.string* get_ScriptFolder();
public: __property void set_ScriptFolder(
   System.string* value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the script folder for this custom editor.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.String^ ScriptFolder {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridCustomEditor Class
WebGridCustomEditor Members


ServerControlFullName Property

[image]
Intersoft WebGrid Documentation
ServerControlFullName Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridCustomEditor Class : ServerControlFullName Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Gets or sets the full qualified name of server control used in this custom editor.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
Public Property ServerControlFullName As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebGridCustomEditor
Dim value As System.String

instance.ServerControlFullName = value

value = instance.ServerControlFullName
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the full qualified name of server control used in this custom editor.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public System.string ServerControlFullName {get; set;}
Delphi
public read-write property ServerControlFullName: System.String;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the full qualified name of server control used in this custom editor.")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
public function get,set ServerControlFullName : System.String
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the full qualified name of server control used in this custom editor.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.string* get_ServerControlFullName();
public: __property void set_ServerControlFullName(
   System.string* value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the full qualified name of server control used in this custom editor.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.String^ ServerControlFullName {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridCustomEditor Class
WebGridCustomEditor Members


UseWebResources Property

[image]
Intersoft WebGrid Documentation
UseWebResources Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridCustomEditor Class : UseWebResources Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Determines whether the scripts and images for this custom editor should be retrieved from SmartWebResources.")>
Public Property UseWebResources As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebGridCustomEditor
Dim value As System.Boolean

instance.UseWebResources = value

value = instance.UseWebResources
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Determines whether the scripts and images for this custom editor should be retrieved from SmartWebResources.")]
public System.bool UseWebResources {get; set;}
Delphi
public read-write property UseWebResources: System.Boolean;
JScript
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Determines whether the scripts and images for this custom editor should be retrieved from SmartWebResources.")
public function get,set UseWebResources : System.boolean
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Determines whether the scripts and images for this custom editor should be retrieved from SmartWebResources.")]
public: __property System.bool get_UseWebResources();
public: __property void set_UseWebResources(
   System.bool value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Determines whether the scripts and images for this custom editor should be retrieved from SmartWebResources.")]
public:
property System.bool UseWebResources {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridCustomEditor Class
WebGridCustomEditor Members


WebGridCustomEditorBehavior Class

[image]
Intersoft WebGrid Documentation
WebGridCustomEditorBehavior Class
Members See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : WebGridCustomEditorBehavior Class

Glossary Item Box

Object Model

WebGridCustomEditorBehavior Class

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.DescriptionAttribute()>
<System.SerializableAttribute()>
Public Class WebGridCustomEditorBehavior
   Inherits ISNet.WebUI.WebUIBaseClass
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Visual Basic (Usage) Copy Code
Dim instance As WebGridCustomEditorBehavior
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DescriptionAttribute()]
[System.SerializableAttribute()]
public class WebGridCustomEditorBehavior : ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Delphi
public class WebGridCustomEditorBehavior = class(ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize)
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.DescriptionAttribute()
System.SerializableAttribute()
public class WebGridCustomEditorBehavior extends ISNet.WebUI.WebUIBaseClass implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DescriptionAttribute()]
[System.SerializableAttribute()]
public __gc class WebGridCustomEditorBehavior : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DescriptionAttribute()]
[System.SerializableAttribute()]
public ref class WebGridCustomEditorBehavior : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.WebGrid.WebGridCustomEditorBehavior

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridCustomEditorBehavior Members
ISNet.WebUI.WebGrid Namespace


WebGridCustomEditorBehavior Class Members

[image]
Intersoft WebGrid Documentation
WebGridCustomEditorBehavior Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebGrid Namespace : WebGridCustomEditorBehavior Class

Glossary Item Box

The following tables list the members exposed by WebGridCustomEditorBehavior.

Public Constructors

 | Name | Description
Public Constructor | WebGridCustomEditorBehavior Constructor |
Top

Public Properties

 | Name | Description
Public Property | BaseEditorType |
Public Property | DropdownButtonImageFile |
Public Property | DropdownButtonType |
Public Property | DropdownButtonWidth |
Public Property | HasDropdownButton |
Public Property | SupportElegantStyles |
Public Property | Tag |
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString |
Top

See Also

Reference

WebGridCustomEditorBehavior Class
ISNet.WebUI.WebGrid Namespace


WebGridCustomEditorBehavior Constructor

[image]
Intersoft WebGrid Documentation
WebGridCustomEditorBehavior Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridCustomEditorBehavior Class : WebGridCustomEditorBehavior Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebGridCustomEditorBehavior()
C#
public WebGridCustomEditorBehavior()
Delphi
public WebGridCustomEditorBehavior();
JScript
public function WebGridCustomEditorBehavior();
Managed Extensions for C++
public: WebGridCustomEditorBehavior();
C++/CLI
public:
WebGridCustomEditorBehavior();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridCustomEditorBehavior Class
WebGridCustomEditorBehavior Members


Clone Method

[image]
Intersoft WebGrid Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridCustomEditorBehavior Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As System.Object
Visual Basic (Usage) Copy Code
Dim instance As WebGridCustomEditorBehavior
Dim value As System.Object

value = instance.Clone()
C#
public virtual System.object Clone()
Delphi
public function Clone(): System.TObject; virtual;
JScript
public function Clone() : System.Object;
Managed Extensions for C++
public: virtual System.Object* Clone();
C++/CLI
public:
virtual System.Object^ Clone();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridCustomEditorBehavior Class
WebGridCustomEditorBehavior Members


CopyFrom Method

[image]
Intersoft WebGrid Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridCustomEditorBehavior Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridCustomEditorBehavior Class
WebGridCustomEditorBehavior Members


CopyFrom(Object) Method

[image]
Intersoft WebGrid Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridCustomEditorBehavior Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebGridCustomEditorBehavior
Dim objSource As System.Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   System.object objSource
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridCustomEditorBehavior Class
WebGridCustomEditorBehavior Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebGrid Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridCustomEditorBehavior Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object, _
   ByVal cloneSourceValue As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebGridCustomEditorBehavior
Dim objSource As System.Object
Dim cloneSourceValue As System.Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   System.object objSource,
   System.bool cloneSourceValue
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject;
    cloneSourceValue: System.Boolean
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object,
   cloneSourceValue : System.boolean
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource,
   System.bool cloneSourceValue
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource,
   System.bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridCustomEditorBehavior Class
WebGridCustomEditorBehavior Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebGrid Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridCustomEditorBehavior Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebGridCustomEditorBehavior
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure DeSerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function DeSerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void DeSerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void DeSerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridCustomEditorBehavior Class
WebGridCustomEditorBehavior Members


GetHashCode Method

[image]
Intersoft WebGrid Documentation
GetHashCode Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridCustomEditorBehavior Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebGridCustomEditorBehavior
Dim value As System.Integer

value = instance.GetHashCode()
C#
public virtual System.int GetHashCode()
Delphi
public function GetHashCode(): System.Integer; virtual;
JScript
public function GetHashCode() : System.int;
Managed Extensions for C++
public: virtual System.int GetHashCode();
C++/CLI
public:
virtual System.int GetHashCode();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridCustomEditorBehavior Class
WebGridCustomEditorBehavior Members


WebGridCustomEditorBehavior Class Methods

[image]
Intersoft WebGrid Documentation
WebGridCustomEditorBehavior Class Methods
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : WebGridCustomEditorBehavior Class

Glossary Item Box

For a list of all members of this type, see WebGridCustomEditorBehavior members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString |
Top

See Also

Reference

WebGridCustomEditorBehavior Class
ISNet.WebUI.WebGrid Namespace


GetObjectData Method

[image]
Intersoft WebGrid Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridCustomEditorBehavior Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebGridCustomEditorBehavior
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure GetObjectData(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
); override;
JScript
public override function GetObjectData(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void GetObjectData(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
) override
C++/CLI
public:
void GetObjectData(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
) override

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridCustomEditorBehavior Class
WebGridCustomEditorBehavior Members


IsEmpty Method

[image]
Intersoft WebGrid Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridCustomEditorBehavior Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebGridCustomEditorBehavior
Dim value As System.Boolean

value = instance.IsEmpty()
C#
public virtual System.bool IsEmpty()
Delphi
public function IsEmpty(): System.Boolean; virtual;
JScript
public function IsEmpty() : System.boolean;
Managed Extensions for C++
public: virtual System.bool IsEmpty();
C++/CLI
public:
virtual System.bool IsEmpty();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridCustomEditorBehavior Class
WebGridCustomEditorBehavior Members


Reset Method

[image]
Intersoft WebGrid Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridCustomEditorBehavior Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As WebGridCustomEditorBehavior

instance.Reset()
C#
public virtual void Reset()
Delphi
public procedure Reset(); virtual;
JScript
public function Reset();
Managed Extensions for C++
public: virtual void Reset();
C++/CLI
public:
virtual void Reset();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridCustomEditorBehavior Class
WebGridCustomEditorBehavior Members


SerializeObjectData Method

[image]
Intersoft WebGrid Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridCustomEditorBehavior Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebGridCustomEditorBehavior
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure SerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function SerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void SerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void SerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridCustomEditorBehavior Class
WebGridCustomEditorBehavior Members


ToString Method

[image]
Intersoft WebGrid Documentation
ToString Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridCustomEditorBehavior Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString() As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebGridCustomEditorBehavior
Dim value As System.String

value = instance.ToString()
C#
public override System.string ToString()
Delphi
public function ToString(): System.String; override;
JScript
public override function ToString() : System.String;
Managed Extensions for C++
public: System.string* ToString(); override
C++/CLI
public:
System.String^ ToString(); override

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridCustomEditorBehavior Class
WebGridCustomEditorBehavior Members


WebGridCustomEditorBehavior Class Properties

[image]
Intersoft WebGrid Documentation
WebGridCustomEditorBehavior Class Properties
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : WebGridCustomEditorBehavior Class

Glossary Item Box

For a list of all members of this type, see WebGridCustomEditorBehavior members.

Public Properties

 | Name | Description
Public Property | BaseEditorType |
Public Property | DropdownButtonImageFile |
Public Property | DropdownButtonType |
Public Property | DropdownButtonWidth |
Public Property | HasDropdownButton |
Public Property | SupportElegantStyles |
Public Property | Tag |
Top

See Also

Reference

WebGridCustomEditorBehavior Class
ISNet.WebUI.WebGrid Namespace


WebGridCustomEditorBehavior Constructor

[image]
Intersoft WebGrid Documentation
WebGridCustomEditorBehavior Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridCustomEditorBehavior Class : WebGridCustomEditorBehavior Constructor

Glossary Item Box

Overload List

Overload | Description
WebGridCustomEditorBehavior Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridCustomEditorBehavior Class
WebGridCustomEditorBehavior Members


BaseEditorType Property

[image]
Intersoft WebGrid Documentation
BaseEditorType Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridCustomEditorBehavior Class : BaseEditorType Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DescriptionAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
Public Property BaseEditorType As BaseEditorType
Visual Basic (Usage) Copy Code
Dim instance As WebGridCustomEditorBehavior
Dim value As BaseEditorType

instance.BaseEditorType = value

value = instance.BaseEditorType
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public BaseEditorType BaseEditorType {get; set;}
Delphi
public read-write property BaseEditorType: BaseEditorType;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DescriptionAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
public function get,set BaseEditorType : BaseEditorType
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public: __property BaseEditorType get_BaseEditorType();
public: __property void set_BaseEditorType(
   BaseEditorType value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public:
property BaseEditorType BaseEditorType {
   BaseEditorType get();
   void set (    BaseEditorType value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridCustomEditorBehavior Class
WebGridCustomEditorBehavior Members


DropdownButtonImageFile Property

[image]
Intersoft WebGrid Documentation
DropdownButtonImageFile Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridCustomEditorBehavior Class : DropdownButtonImageFile Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property DropdownButtonImageFile As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebGridCustomEditorBehavior
Dim value As System.String

instance.DropdownButtonImageFile = value

value = instance.DropdownButtonImageFile
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.string DropdownButtonImageFile {get; set;}
Delphi
public read-write property DropdownButtonImageFile: System.String;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set DropdownButtonImageFile : System.String
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.string* get_DropdownButtonImageFile();
public: __property void set_DropdownButtonImageFile(
   System.string* value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.String^ DropdownButtonImageFile {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridCustomEditorBehavior Class
WebGridCustomEditorBehavior Members


DropdownButtonType Property

[image]
Intersoft WebGrid Documentation
DropdownButtonType Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridCustomEditorBehavior Class : DropdownButtonType Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property DropdownButtonType As DropdownButtonType
Visual Basic (Usage) Copy Code
Dim instance As WebGridCustomEditorBehavior
Dim value As DropdownButtonType

instance.DropdownButtonType = value

value = instance.DropdownButtonType
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public DropdownButtonType DropdownButtonType {get; set;}
Delphi
public read-write property DropdownButtonType: DropdownButtonType;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute()
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get,set DropdownButtonType : DropdownButtonType
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property DropdownButtonType get_DropdownButtonType();
public: __property void set_DropdownButtonType(
   DropdownButtonType value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property DropdownButtonType DropdownButtonType {
   DropdownButtonType get();
   void set (    DropdownButtonType value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridCustomEditorBehavior Class
WebGridCustomEditorBehavior Members


DropdownButtonWidth Property

[image]
Intersoft WebGrid Documentation
DropdownButtonWidth Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridCustomEditorBehavior Class : DropdownButtonWidth Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DescriptionAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
Public Property DropdownButtonWidth As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebGridCustomEditorBehavior
Dim value As System.Integer

instance.DropdownButtonWidth = value

value = instance.DropdownButtonWidth
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public System.int DropdownButtonWidth {get; set;}
Delphi
public read-write property DropdownButtonWidth: System.Integer;
JScript
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DescriptionAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
public function get,set DropdownButtonWidth : System.int
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.int get_DropdownButtonWidth();
public: __property void set_DropdownButtonWidth(
   System.int value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.int DropdownButtonWidth {
   System.int get();
   void set (    System.int value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridCustomEditorBehavior Class
WebGridCustomEditorBehavior Members


HasDropdownButton Property

[image]
Intersoft WebGrid Documentation
HasDropdownButton Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridCustomEditorBehavior Class : HasDropdownButton Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DescriptionAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Property HasDropdownButton As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebGridCustomEditorBehavior
Dim value As System.Boolean

instance.HasDropdownButton = value

value = instance.HasDropdownButton
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public System.bool HasDropdownButton {get; set;}
Delphi
public read-write property HasDropdownButton: System.Boolean;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DescriptionAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute()
public function get,set HasDropdownButton : System.boolean
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property System.bool get_HasDropdownButton();
public: __property void set_HasDropdownButton(
   System.bool value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property System.bool HasDropdownButton {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridCustomEditorBehavior Class
WebGridCustomEditorBehavior Members


SupportElegantStyles Property

[image]
Intersoft WebGrid Documentation
SupportElegantStyles Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridCustomEditorBehavior Class : SupportElegantStyles Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies whether the custom editor is designed to support elegant default styles.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property SupportElegantStyles As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebGridCustomEditorBehavior
Dim value As System.Boolean

instance.SupportElegantStyles = value

value = instance.SupportElegantStyles
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether the custom editor is designed to support elegant default styles.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.bool SupportElegantStyles {get; set;}
Delphi
public read-write property SupportElegantStyles: System.Boolean;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Specifies whether the custom editor is designed to support elegant default styles.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set SupportElegantStyles : System.boolean
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether the custom editor is designed to support elegant default styles.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.bool get_SupportElegantStyles();
public: __property void set_SupportElegantStyles(
   System.bool value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether the custom editor is designed to support elegant default styles.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.bool SupportElegantStyles {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridCustomEditorBehavior Class
WebGridCustomEditorBehavior Members


Tag Property

[image]
Intersoft WebGrid Documentation
Tag Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridCustomEditorBehavior Class : Tag Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
Public Property Tag As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebGridCustomEditorBehavior
Dim value As System.String

instance.Tag = value

value = instance.Tag
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public System.string Tag {get; set;}
Delphi
public read-write property Tag: System.String;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute()
System.ComponentModel.DefaultValueAttribute()
public function get,set Tag : System.String
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.string* get_Tag();
public: __property void set_Tag(
   System.string* value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.String^ Tag {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridCustomEditorBehavior Class
WebGridCustomEditorBehavior Members


WebGridCustomEditorCollection Class

[image]
Intersoft WebGrid Documentation
WebGridCustomEditorCollection Class
Members See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : WebGridCustomEditorCollection Class

Glossary Item Box

Object Model

WebGridCustomEditorCollection Class

Syntax

Visual Basic (Declaration)
<System.Reflection.DefaultMemberAttribute("Item")>
<System.SerializableAttribute()>
Public Class WebGridCustomEditorCollection
   Inherits ISNet.WebUI.ISCollectionBase
Visual Basic (Usage) Copy Code
Dim instance As WebGridCustomEditorCollection
C#
[System.Reflection.DefaultMemberAttribute("Item")]
[System.SerializableAttribute()]
public class WebGridCustomEditorCollection : ISNet.WebUI.ISCollectionBase
Delphi
public class WebGridCustomEditorCollection = class(ISNet.WebUI.ISCollectionBase)
JScript
System.Reflection.DefaultMemberAttribute("Item")
System.SerializableAttribute()
public class WebGridCustomEditorCollection extends ISNet.WebUI.ISCollectionBase
Managed Extensions for C++
[System.Reflection.DefaultMemberAttribute("Item")]
[System.SerializableAttribute()]
public __gc class WebGridCustomEditorCollection : public ISNet.WebUI.ISCollectionBase
C++/CLI
[System.Reflection.DefaultMemberAttribute("Item")]
[System.SerializableAttribute()]
public ref class WebGridCustomEditorCollection : public ISNet.WebUI.ISCollectionBase

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
ISNet.WebUI.ISCollectionBase
ISNet.WebUI.WebGrid.WebGridCustomEditorCollection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridCustomEditorCollection Members
ISNet.WebUI.WebGrid Namespace


WebGridCustomEditorCollection Class Members

[image]
Intersoft WebGrid Documentation
WebGridCustomEditorCollection Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebGrid Namespace : WebGridCustomEditorCollection Class

Glossary Item Box

The following tables list the members exposed by WebGridCustomEditorCollection.

Public Constructors

 | Name | Description
Public Constructor | WebGridCustomEditorCollection Constructor |
Top

Public Properties

 | Name | Description
Public Property | Capacity | (Inherited from System.Collections.CollectionBase)
Public Property | Count | (Inherited from System.Collections.CollectionBase)
Public Property | IsReadOnly | Overridden.
Public Property | Item |
Public Property | Parent | (Inherited from ISNet.WebUI.ISCollectionBase)
Top

Public Methods

 | Name | Description
Public Method | Add | Overloaded.
Public Method | AddFromCollection |
Public Method | Clear |
Public Method | Contains | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | CopyFrom |
Public Method | CopyTo | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | Exists | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | GetEnumerator |
Public Method | GetItem | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | GetNamedItem |
Public Method | IndexOf | Overloaded. (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | Insert |
Public Method | IntInsert | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | Remove |
Public Method | setParent | (Inherited from ISNet.WebUI.ISCollectionBase)
Top

See Also

Reference

WebGridCustomEditorCollection Class
ISNet.WebUI.WebGrid Namespace


WebGridCustomEditorCollection Constructor

[image]
Intersoft WebGrid Documentation
WebGridCustomEditorCollection Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridCustomEditorCollection Class : WebGridCustomEditorCollection Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebGridCustomEditorCollection()
C#
public WebGridCustomEditorCollection()
Delphi
public WebGridCustomEditorCollection();
JScript
public function WebGridCustomEditorCollection();
Managed Extensions for C++
public: WebGridCustomEditorCollection();
C++/CLI
public:
WebGridCustomEditorCollection();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridCustomEditorCollection Class
WebGridCustomEditorCollection Members


WebGridCustomEditorCollection Class Methods

[image]
Intersoft WebGrid Documentation
WebGridCustomEditorCollection Class Methods
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : WebGridCustomEditorCollection Class

Glossary Item Box

For a list of all members of this type, see WebGridCustomEditorCollection members.

Public Methods

 | Name | Description
Public Method | Add | Overloaded.
Public Method | AddFromCollection |
Public Method | Clear |
Public Method | Contains | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | CopyFrom |
Public Method | CopyTo | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | Exists | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | GetEnumerator |
Public Method | GetItem | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | GetNamedItem |
Public Method | IndexOf | Overloaded. (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | Insert |
Public Method | IntInsert | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | Remove |
Public Method | setParent | (Inherited from ISNet.WebUI.ISCollectionBase)
Top

See Also

Reference

WebGridCustomEditorCollection Class
ISNet.WebUI.WebGrid Namespace


Add Method

[image]
Intersoft WebGrid Documentation
Add Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridCustomEditorCollection Class : Add Method

Glossary Item Box

Overload List

Overload | Description
Add(WebGridCustomEditor) |
Add(String) |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridCustomEditorCollection Class
WebGridCustomEditorCollection Members


Add(WebGridCustomEditor) Method

[image]
Intersoft WebGrid Documentation
Add(WebGridCustomEditor) Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridCustomEditorCollection Class > Add Method : Add(WebGridCustomEditor) Method

webGridCustomEditor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function Add( _
   ByVal webGridCustomEditor As WebGridCustomEditor _
) As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebGridCustomEditorCollection
Dim webGridCustomEditor As WebGridCustomEditor
Dim value As System.Integer

value = instance.Add(webGridCustomEditor)
C#
public virtual System.int Add(
   WebGridCustomEditor webGridCustomEditor
)
Delphi
public function Add(
    webGridCustomEditor: WebGridCustomEditor
): System.Integer; virtual;
JScript
public function Add(
   webGridCustomEditor : WebGridCustomEditor
) : System.int;
Managed Extensions for C++
public: virtual System.int Add(
   WebGridCustomEditor* webGridCustomEditor
)
C++/CLI
public:
virtual System.int Add(
   WebGridCustomEditor^ webGridCustomEditor
)

Parameters

webGridCustomEditor

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridCustomEditorCollection Class
WebGridCustomEditorCollection Members
Overload List


Add(String) Method

[image]
Intersoft WebGrid Documentation
Add(String) Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridCustomEditorCollection Class > Add Method : Add(String) Method

name

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function Add( _
   ByVal name As System.String _
) As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebGridCustomEditorCollection
Dim name As System.String
Dim value As System.Integer

value = instance.Add(name)
C#
public System.int Add(
   System.string name
)
Delphi
public function Add(
    name: System.String
): System.Integer;
JScript
public function Add(
   name : System.String
) : System.int;
Managed Extensions for C++
public: System.int Add(
   System.string* name
)
C++/CLI
public:
System.int Add(
   System.String^ name
)

Parameters

name

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridCustomEditorCollection Class
WebGridCustomEditorCollection Members
Overload List


AddFromCollection Method

[image]
Intersoft WebGrid Documentation
AddFromCollection Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridCustomEditorCollection Class : AddFromCollection Method

passIn

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub AddFromCollection( _
   ByVal passIn As WebGridCustomEditorCollection _
)
Visual Basic (Usage) Copy Code
Dim instance As WebGridCustomEditorCollection
Dim passIn As WebGridCustomEditorCollection

instance.AddFromCollection(passIn)
C#
public void AddFromCollection(
   WebGridCustomEditorCollection passIn
)
Delphi
public procedure AddFromCollection(
    passIn: WebGridCustomEditorCollection
);
JScript
public function AddFromCollection(
   passIn : WebGridCustomEditorCollection
);
Managed Extensions for C++
public: void AddFromCollection(
   WebGridCustomEditorCollection* passIn
)
C++/CLI
public:
void AddFromCollection(
   WebGridCustomEditorCollection^ passIn
)

Parameters

passIn

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridCustomEditorCollection Class
WebGridCustomEditorCollection Members


Clear Method

[image]
Intersoft WebGrid Documentation
Clear Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridCustomEditorCollection Class : Clear Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Shadows Sub Clear()
Visual Basic (Usage) Copy Code
Dim instance As WebGridCustomEditorCollection

instance.Clear()
C#
public new void Clear()
Delphi
public procedure Clear();
JScript
public hide function Clear();
Managed Extensions for C++
public: new void Clear();
C++/CLI
public:
new void Clear();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridCustomEditorCollection Class
WebGridCustomEditorCollection Members


Contains Method

[image]
Intersoft WebGrid Documentation
Contains Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridCustomEditorCollection Class : Contains Method

value

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function Contains( _
   ByVal value As ISNet.WebUI.INamedObject _
) As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebGridCustomEditorCollection
Dim value As ISNet.WebUI.INamedObject
Dim value As System.Boolean

value = instance.Contains(value)
C#
public System.bool Contains(
   ISNet.WebUI.INamedObject value
)
Delphi
public function Contains(
    value: ISNet.WebUI.INamedObject
): System.Boolean;
JScript
public function Contains(
   value : ISNet.WebUI.INamedObject
) : System.boolean;
Managed Extensions for C++
public: System.bool Contains(
   ISNet.WebUI.INamedObject* value
)
C++/CLI
public:
System.bool Contains(
   ISNet.WebUI.INamedObject^ value
)

Parameters

value

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridCustomEditorCollection Class
WebGridCustomEditorCollection Members


CopyFrom Method

[image]
Intersoft WebGrid Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridCustomEditorCollection Class : CopyFrom Method

passIn

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function CopyFrom( _
   ByVal passIn As WebGridCustomEditorCollection _
) As WebGridCustomEditorCollection
Visual Basic (Usage) Copy Code
Dim instance As WebGridCustomEditorCollection
Dim passIn As WebGridCustomEditorCollection
Dim value As WebGridCustomEditorCollection

value = instance.CopyFrom(passIn)
C#
public WebGridCustomEditorCollection CopyFrom(
   WebGridCustomEditorCollection passIn
)
Delphi
public function CopyFrom(
    passIn: WebGridCustomEditorCollection
): WebGridCustomEditorCollection;
JScript
public function CopyFrom(
   passIn : WebGridCustomEditorCollection
) : WebGridCustomEditorCollection;
Managed Extensions for C++
public: WebGridCustomEditorCollection* CopyFrom(
   WebGridCustomEditorCollection* passIn
)
C++/CLI
public:
WebGridCustomEditorCollection^ CopyFrom(
   WebGridCustomEditorCollection^ passIn
)

Parameters

passIn

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridCustomEditorCollection Class
WebGridCustomEditorCollection Members


CopyTo Method

[image]
Intersoft WebGrid Documentation
CopyTo Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridCustomEditorCollection Class : CopyTo Method

array
index

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub CopyTo( _
   ByVal array() As ISNet.WebUI.INamedObject, _
   ByVal index As System.Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As WebGridCustomEditorCollection
Dim array() As ISNet.WebUI.INamedObject
Dim index As System.Integer

instance.CopyTo(array, index)
C#
public void CopyTo(
   ISNet.WebUI.INamedObject[] array,
   System.int index
)
Delphi
public procedure CopyTo(
    array: ISNet.WebUI.INamedObjectarray of;
    index: System.Integer
);
JScript
public function CopyTo(
   array : ISNet.WebUI.INamedObject[],
   index : System.int
);
Managed Extensions for C++
public: void CopyTo(
   ISNet.WebUI.INamedObject*[]* array,
   System.int index
)
C++/CLI
public:
void CopyTo(
   ISNet.WebUI.array<INamedObject^>^ array,
   System.int index
)

Parameters

array
index

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridCustomEditorCollection Class
WebGridCustomEditorCollection Members


Exists Method

[image]
Intersoft WebGrid Documentation
Exists Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridCustomEditorCollection Class : Exists Method

name

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function Exists( _
   ByVal name As System.String _
) As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebGridCustomEditorCollection
Dim name As System.String
Dim value As System.Boolean

value = instance.Exists(name)
C#
public System.bool Exists(
   System.string name
)
Delphi
public function Exists(
    name: System.String
): System.Boolean;
JScript
public function Exists(
   name : System.String
) : System.boolean;
Managed Extensions for C++
public: System.bool Exists(
   System.string* name
)
C++/CLI
public:
System.bool Exists(
   System.String^ name
)

Parameters

name

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridCustomEditorCollection Class
WebGridCustomEditorCollection Members


GetEnumerator Method

[image]
Intersoft WebGrid Documentation
GetEnumerator Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridCustomEditorCollection Class : GetEnumerator Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Shadows Function GetEnumerator() As System.Collections.IEnumerator
Visual Basic (Usage) Copy Code
Dim instance As WebGridCustomEditorCollection
Dim value As System.Collections.IEnumerator

value = instance.GetEnumerator()
C#
public new System.Collections.IEnumerator GetEnumerator()
Delphi
public function GetEnumerator(): System.Collections.IEnumerator;
JScript
public hide function GetEnumerator() : System.Collections.IEnumerator;
Managed Extensions for C++
public: new System.Collections.IEnumerator* GetEnumerator();
C++/CLI
public:
new System.Collections.IEnumerator^ GetEnumerator();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridCustomEditorCollection Class
WebGridCustomEditorCollection Members


GetItem Method

[image]
Intersoft WebGrid Documentation
GetItem Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridCustomEditorCollection Class : GetItem Method

Glossary Item Box

Overload List

Overload | Description
GetItem | (Inherited from ISNet.WebUI.ISCollectionBase)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridCustomEditorCollection Class
WebGridCustomEditorCollection Members


GetItem(Int32) Method

[image]
Intersoft WebGrid Documentation
GetItem(Int32) Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridCustomEditorCollection Class : GetItem(Int32) Method

index

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetItem( _
   ByVal index As System.Integer _
) As ISNet.WebUI.INamedObject
Visual Basic (Usage) Copy Code
Dim instance As WebGridCustomEditorCollection
Dim index As System.Integer
Dim value As ISNet.WebUI.INamedObject

value = instance.GetItem(index)
C#
public virtual ISNet.WebUI.INamedObject GetItem(
   System.int index
)
Delphi
public function GetItem(
    index: System.Integer
): ISNet.WebUI.INamedObject; virtual;
JScript
public function GetItem(
   index : System.int
) : ISNet.WebUI.INamedObject;
Managed Extensions for C++
public: virtual ISNet.WebUI.INamedObject* GetItem(
   System.int index
)
C++/CLI
public:
virtual ISNet.WebUI.INamedObject^ GetItem(
   System.int index
)

Parameters

index

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridCustomEditorCollection Class
WebGridCustomEditorCollection Members


GetNamedItem Method

[image]
Intersoft WebGrid Documentation
GetNamedItem Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridCustomEditorCollection Class : GetNamedItem Method

name

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetNamedItem( _
   ByVal name As System.String _
) As WebGridCustomEditor
Visual Basic (Usage) Copy Code
Dim instance As WebGridCustomEditorCollection
Dim name As System.String
Dim value As WebGridCustomEditor

value = instance.GetNamedItem(name)
C#
public WebGridCustomEditor GetNamedItem(
   System.string name
)
Delphi
public function GetNamedItem(
    name: System.String
): WebGridCustomEditor;
JScript
public function GetNamedItem(
   name : System.String
) : WebGridCustomEditor;
Managed Extensions for C++
public: WebGridCustomEditor* GetNamedItem(
   System.string* name
)
C++/CLI
public:
WebGridCustomEditor^ GetNamedItem(
   System.String^ name
)

Parameters

name

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridCustomEditorCollection Class
WebGridCustomEditorCollection Members


IndexOf Method

[image]
Intersoft WebGrid Documentation
IndexOf Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridCustomEditorCollection Class : IndexOf Method

Glossary Item Box

Overload List

Overload | Description
IndexOf(String) | (Inherited from ISNet.WebUI.ISCollectionBase)
IndexOf(INamedObject) | (Inherited from ISNet.WebUI.ISCollectionBase)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridCustomEditorCollection Class
WebGridCustomEditorCollection Members


IndexOf(String) Method

[image]
Intersoft WebGrid Documentation
IndexOf(String) Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridCustomEditorCollection Class > IndexOf Method : IndexOf(String) Method

name

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function IndexOf( _
   ByVal name As System.String _
) As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebGridCustomEditorCollection
Dim name As System.String
Dim value As System.Integer

value = instance.IndexOf(name)
C#
public virtual System.int IndexOf(
   System.string name
)
Delphi
public function IndexOf(
    name: System.String
): System.Integer; virtual;
JScript
public function IndexOf(
   name : System.String
) : System.int;
Managed Extensions for C++
public: virtual System.int IndexOf(
   System.string* name
)
C++/CLI
public:
virtual System.int IndexOf(
   System.String^ name
)

Parameters

name

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridCustomEditorCollection Class
WebGridCustomEditorCollection Members
Overload List


IndexOf(INamedObject) Method

[image]
Intersoft WebGrid Documentation
IndexOf(INamedObject) Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridCustomEditorCollection Class > IndexOf Method : IndexOf(INamedObject) Method

value

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function IndexOf( _
   ByVal value As ISNet.WebUI.INamedObject _
) As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebGridCustomEditorCollection
Dim value As ISNet.WebUI.INamedObject
Dim value As System.Integer

value = instance.IndexOf(value)
C#
public System.int IndexOf(
   ISNet.WebUI.INamedObject value
)
Delphi
public function IndexOf(
    value: ISNet.WebUI.INamedObject
): System.Integer;
JScript
public function IndexOf(
   value : ISNet.WebUI.INamedObject
) : System.int;
Managed Extensions for C++
public: System.int IndexOf(
   ISNet.WebUI.INamedObject* value
)
C++/CLI
public:
System.int IndexOf(
   ISNet.WebUI.INamedObject^ value
)

Parameters

value

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridCustomEditorCollection Class
WebGridCustomEditorCollection Members
Overload List


Insert Method

[image]
Intersoft WebGrid Documentation
Insert Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridCustomEditorCollection Class : Insert Method

index
webGridCustomEditor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub Insert( _
   ByVal index As System.Integer, _
   ByVal webGridCustomEditor As WebGridCustomEditor _
)
Visual Basic (Usage) Copy Code
Dim instance As WebGridCustomEditorCollection
Dim index As System.Integer
Dim webGridCustomEditor As WebGridCustomEditor

instance.Insert(index, webGridCustomEditor)
C#
public void Insert(
   System.int index,
   WebGridCustomEditor webGridCustomEditor
)
Delphi
public procedure Insert(
    index: System.Integer;
    webGridCustomEditor: WebGridCustomEditor
);
JScript
public function Insert(
   index : System.int,
   webGridCustomEditor : WebGridCustomEditor
);
Managed Extensions for C++
public: void Insert(
   System.int index,
   WebGridCustomEditor* webGridCustomEditor
)
C++/CLI
public:
void Insert(
   System.int index,
   WebGridCustomEditor^ webGridCustomEditor
)

Parameters

index
webGridCustomEditor

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridCustomEditorCollection Class
WebGridCustomEditorCollection Members


IntInsert Method

[image]
Intersoft WebGrid Documentation
IntInsert Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridCustomEditorCollection Class : IntInsert Method

index
value

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub IntInsert( _
   ByVal index As System.Integer, _
   ByVal value As ISNet.WebUI.INamedObject _
)
Visual Basic (Usage) Copy Code
Dim instance As WebGridCustomEditorCollection
Dim index As System.Integer
Dim value As ISNet.WebUI.INamedObject

instance.IntInsert(index, value)
C#
public void IntInsert(
   System.int index,
   ISNet.WebUI.INamedObject value
)
Delphi
public procedure IntInsert(
    index: System.Integer;
    value: ISNet.WebUI.INamedObject
);
JScript
public function IntInsert(
   index : System.int,
   value : ISNet.WebUI.INamedObject
);
Managed Extensions for C++
public: void IntInsert(
   System.int index,
   ISNet.WebUI.INamedObject* value
)
C++/CLI
public:
void IntInsert(
   System.int index,
   ISNet.WebUI.INamedObject^ value
)

Parameters

index
value

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridCustomEditorCollection Class
WebGridCustomEditorCollection Members


Remove Method

[image]
Intersoft WebGrid Documentation
Remove Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridCustomEditorCollection Class : Remove Method

webGridCustomEditor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub Remove( _
   ByVal webGridCustomEditor As WebGridCustomEditor _
)
Visual Basic (Usage) Copy Code
Dim instance As WebGridCustomEditorCollection
Dim webGridCustomEditor As WebGridCustomEditor

instance.Remove(webGridCustomEditor)
C#
public void Remove(
   WebGridCustomEditor webGridCustomEditor
)
Delphi
public procedure Remove(
    webGridCustomEditor: WebGridCustomEditor
);
JScript
public function Remove(
   webGridCustomEditor : WebGridCustomEditor
);
Managed Extensions for C++
public: void Remove(
   WebGridCustomEditor* webGridCustomEditor
)
C++/CLI
public:
void Remove(
   WebGridCustomEditor^ webGridCustomEditor
)

Parameters

webGridCustomEditor

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridCustomEditorCollection Class
WebGridCustomEditorCollection Members


setParent Method

[image]
Intersoft WebGrid Documentation
setParent Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridCustomEditorCollection Class : setParent Method

parent

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub setParent( _
   ByVal parent As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebGridCustomEditorCollection
Dim parent As System.Object

instance.setParent(parent)
C#
public virtual void setParent(
   System.object parent
)
Delphi
public procedure setParent(
    parent: System.TObject
); virtual;
JScript
public function setParent(
   parent : System.Object
);
Managed Extensions for C++
public: virtual void setParent(
   System.Object* parent
)
C++/CLI
public:
virtual void setParent(
   System.Object^ parent
)

Parameters

parent

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridCustomEditorCollection Class
WebGridCustomEditorCollection Members


Capacity Property

[image]
Intersoft WebGrid Documentation
Capacity Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridCustomEditorCollection Class : Capacity Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Runtime.InteropServices.ComVisibleAttribute(False)>
Public Property Capacity As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebGridCustomEditorCollection
Dim value As System.Integer

instance.Capacity = value

value = instance.Capacity
C#
[System.Runtime.InteropServices.ComVisibleAttribute(false)]
public System.int Capacity {get; set;}
Delphi
public read-write property Capacity: System.Integer;
JScript
System.Runtime.InteropServices.ComVisibleAttribute()
public function get,set Capacity : System.int
Managed Extensions for C++
[System.Runtime.InteropServices.ComVisibleAttribute(false)]
public: __property System.int get_Capacity();
public: __property void set_Capacity(
   System.int value
);
C++/CLI
[System.Runtime.InteropServices.ComVisibleAttribute(false)]
public:
property System.int Capacity {
   System.int get();
   void set (    System.int value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridCustomEditorCollection Class
WebGridCustomEditorCollection Members


Count Property

[image]
Intersoft WebGrid Documentation
Count Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridCustomEditorCollection Class : Count Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Count As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebGridCustomEditorCollection
Dim value As System.Integer

value = instance.Count
C#
public System.int Count {get;}
Delphi
public read-only property Count: System.Integer;
JScript
public function get Count : System.int
Managed Extensions for C++
public: __property System.int get_Count();
C++/CLI
public:
property System.int Count {
   System.int get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridCustomEditorCollection Class
WebGridCustomEditorCollection Members


WebGridCustomEditorCollection Class Properties

[image]
Intersoft WebGrid Documentation
WebGridCustomEditorCollection Class Properties
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : WebGridCustomEditorCollection Class

Glossary Item Box

For a list of all members of this type, see WebGridCustomEditorCollection members.

Public Properties

 | Name | Description
Public Property | Capacity | (Inherited from System.Collections.CollectionBase)
Public Property | Count | (Inherited from System.Collections.CollectionBase)
Public Property | IsReadOnly | Overridden.
Public Property | Item |
Public Property | Parent | (Inherited from ISNet.WebUI.ISCollectionBase)
Top

See Also

Reference

WebGridCustomEditorCollection Class
ISNet.WebUI.WebGrid Namespace


WebGridCustomEditorCollection Constructor

[image]
Intersoft WebGrid Documentation
WebGridCustomEditorCollection Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridCustomEditorCollection Class : WebGridCustomEditorCollection Constructor

Glossary Item Box

Overload List

Overload | Description
WebGridCustomEditorCollection Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridCustomEditorCollection Class
WebGridCustomEditorCollection Members


IsReadOnly Property

[image]
Intersoft WebGrid Documentation
IsReadOnly Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridCustomEditorCollection Class : IsReadOnly Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property IsReadOnly As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebGridCustomEditorCollection
Dim value As System.Boolean

value = instance.IsReadOnly
C#
public override System.bool IsReadOnly {get;}
Delphi
public read-only property IsReadOnly: System.Boolean; override;
JScript
public override function get IsReadOnly : System.boolean
Managed Extensions for C++
public: __property System.bool get_IsReadOnly() override;
C++/CLI
public:
property System.bool IsReadOnly {
   System.bool get() override;
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridCustomEditorCollection Class
WebGridCustomEditorCollection Members


Item Property

[image]
Intersoft WebGrid Documentation
Item Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridCustomEditorCollection Class : Item Property

index

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Default Property Item( _
   ByVal index As System.Integer _
) As WebGridCustomEditor
Visual Basic (Usage) Copy Code
Dim instance As WebGridCustomEditorCollection
Dim index As System.Integer
Dim value As WebGridCustomEditor

value = instance.Item(index)
C#
public WebGridCustomEditor this[
   System.int index
]; {get;}
Delphi
public  this: : WebGridCustomEditor;[
    index: System.Integer
]; read-only
JScript
public  this[
   index : System.int
] get : WebGridCustomEditor
Managed Extensions for C++
public: __property WebGridCustomEditor* get_Item   System.int index
;
C++/CLI
public:
property WebGridCustomEditor^ default [int] {
   WebGridCustomEditor^ get(System.int index);
}

Parameters

index

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridCustomEditorCollection Class
WebGridCustomEditorCollection Members


Parent Property

[image]
Intersoft WebGrid Documentation
Parent Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridCustomEditorCollection Class : Parent Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Parent As System.Object
Visual Basic (Usage) Copy Code
Dim instance As WebGridCustomEditorCollection
Dim value As System.Object

value = instance.Parent
C#
public System.object Parent {get;}
Delphi
public read-only property Parent: System.TObject;
JScript
public function get Parent : System.Object
Managed Extensions for C++
public: __property System.Object* get_Parent();
C++/CLI
public:
property System.Object^ Parent {
   System.Object^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridCustomEditorCollection Class
WebGridCustomEditorCollection Members


WebGridDataSourceInfo Class

[image]
Intersoft WebGrid Documentation
WebGridDataSourceInfo Class
Members See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : WebGridDataSourceInfo Class

Glossary Item Box

Object Model

WebGridDataSourceInfo Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class WebGridDataSourceInfo
   Inherits ISNet.WebUI.DataSourceInfo
Visual Basic (Usage) Copy Code
Dim instance As WebGridDataSourceInfo
C#
public sealed class WebGridDataSourceInfo : ISNet.WebUI.DataSourceInfo
Delphi
public class WebGridDataSourceInfo = class(ISNet.WebUI.DataSourceInfo)sealed;
JScript
public sealed class WebGridDataSourceInfo extends ISNet.WebUI.DataSourceInfo
Managed Extensions for C++
public __gc __sealed class WebGridDataSourceInfo : public ISNet.WebUI.DataSourceInfo
C++/CLI
public ref class WebGridDataSourceInfo sealed : public ISNet.WebUI.DataSourceInfo

Inheritance Hierarchy

System.Object
ISNet.WebUI.DataSourceInfo
ISNet.WebUI.WebGrid.WebGridDataSourceInfo

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridDataSourceInfo Members
ISNet.WebUI.WebGrid Namespace


WebGridDataSourceInfo Class Members

[image]
Intersoft WebGrid Documentation
WebGridDataSourceInfo Class Members
See Also Properties Methods Events Send Feedback
ISNet.WebUI.WebGrid Namespace : WebGridDataSourceInfo Class

Glossary Item Box

The following tables list the members exposed by WebGridDataSourceInfo.

Public Properties

 | Name | Description
Public Property | Control | (Inherited from ISNet.WebUI.DataSourceInfo)
Public Property | CurrentDataSource | (Inherited from ISNet.WebUI.DataSourceInfo)
Public Property | IgnoreDataSourceViewChanged | (Inherited from ISNet.WebUI.DataSourceInfo)
Public Property | IsBoundUsingDataSourceID | (Inherited from ISNet.WebUI.DataSourceInfo)
Public Property | IsDataSourceViewValid | (Inherited from ISNet.WebUI.DataSourceInfo)
Public Property | RequiresDataBinding | (Inherited from ISNet.WebUI.DataSourceInfo)
Public Property | SelectArguments | (Inherited from ISNet.WebUI.DataSourceInfo)
Top

Public Methods

 | Name | Description
Public Method | DataBind | (Inherited from ISNet.WebUI.DataSourceInfo)
Public Method | EnsureDataBound | (Inherited from ISNet.WebUI.DataSourceInfo)
Public Method | FindControl | (Inherited from ISNet.WebUI.DataSourceInfo)
Public Method | GetData | Overloaded. (Inherited from ISNet.WebUI.DataSourceInfo)
Public Method | GetDataSourceControl | (Inherited from ISNet.WebUI.DataSourceInfo)
Public Method | GetDataSourceID | (Inherited from ISNet.WebUI.DataSourceInfo)
Public Method | GetSelectParameters | (Inherited from ISNet.WebUI.DataSourceInfo)
Public Method | GetTable | (Inherited from ISNet.WebUI.DataSourceInfo)
Public Method | IsIntersoftDataSourceControl | (Inherited from ISNet.WebUI.DataSourceInfo)
Public Method | SetViewValid | (Inherited from ISNet.WebUI.DataSourceInfo)
Public Method | ValidateDataSource | (Inherited from ISNet.WebUI.DataSourceInfo)
Top

Public Events

 | Name | Description
Public Event | DataBinding | (Inherited from ISNet.WebUI.DataSourceInfo)
Public Event | DataBound | (Inherited from ISNet.WebUI.DataSourceInfo)
Top

See Also

Reference

WebGridDataSourceInfo Class
ISNet.WebUI.WebGrid Namespace


WebGridDataSourceInfo Class Events

[image]
Intersoft WebGrid Documentation
WebGridDataSourceInfo Class Events
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : WebGridDataSourceInfo Class

Glossary Item Box

For a list of all members of this type, see WebGridDataSourceInfo members.

Public Events

 | Name | Description
Public Event | DataBinding | (Inherited from ISNet.WebUI.DataSourceInfo)
Public Event | DataBound | (Inherited from ISNet.WebUI.DataSourceInfo)
Top

See Also

Reference

WebGridDataSourceInfo Class
ISNet.WebUI.WebGrid Namespace


WebGridDataSourceInfo Class Methods

[image]
Intersoft WebGrid Documentation
WebGridDataSourceInfo Class Methods
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : WebGridDataSourceInfo Class

Glossary Item Box

For a list of all members of this type, see WebGridDataSourceInfo members.

Public Methods

 | Name | Description
Public Method | DataBind | (Inherited from ISNet.WebUI.DataSourceInfo)
Public Method | EnsureDataBound | (Inherited from ISNet.WebUI.DataSourceInfo)
Public Method | FindControl | (Inherited from ISNet.WebUI.DataSourceInfo)
Public Method | GetData | Overloaded. (Inherited from ISNet.WebUI.DataSourceInfo)
Public Method | GetDataSourceControl | (Inherited from ISNet.WebUI.DataSourceInfo)
Public Method | GetDataSourceID | (Inherited from ISNet.WebUI.DataSourceInfo)
Public Method | GetSelectParameters | (Inherited from ISNet.WebUI.DataSourceInfo)
Public Method | GetTable | (Inherited from ISNet.WebUI.DataSourceInfo)
Public Method | IsIntersoftDataSourceControl | (Inherited from ISNet.WebUI.DataSourceInfo)
Public Method | SetViewValid | (Inherited from ISNet.WebUI.DataSourceInfo)
Public Method | ValidateDataSource | (Inherited from ISNet.WebUI.DataSourceInfo)
Top

See Also

Reference

WebGridDataSourceInfo Class
ISNet.WebUI.WebGrid Namespace


WebGridDataSourceInfo Class Properties

[image]
Intersoft WebGrid Documentation
WebGridDataSourceInfo Class Properties
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : WebGridDataSourceInfo Class

Glossary Item Box

For a list of all members of this type, see WebGridDataSourceInfo members.

Public Properties

 | Name | Description
Public Property | Control | (Inherited from ISNet.WebUI.DataSourceInfo)
Public Property | CurrentDataSource | (Inherited from ISNet.WebUI.DataSourceInfo)
Public Property | IgnoreDataSourceViewChanged | (Inherited from ISNet.WebUI.DataSourceInfo)
Public Property | IsBoundUsingDataSourceID | (Inherited from ISNet.WebUI.DataSourceInfo)
Public Property | IsDataSourceViewValid | (Inherited from ISNet.WebUI.DataSourceInfo)
Public Property | RequiresDataBinding | (Inherited from ISNet.WebUI.DataSourceInfo)
Public Property | SelectArguments | (Inherited from ISNet.WebUI.DataSourceInfo)
Top

See Also

Reference

WebGridDataSourceInfo Class
ISNet.WebUI.WebGrid Namespace


DataBind Method

[image]
Intersoft WebGrid Documentation
DataBind Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridDataSourceInfo Class : DataBind Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DataBind()
Visual Basic (Usage) Copy Code
Dim instance As WebGridDataSourceInfo

instance.DataBind()
C#
public void DataBind()
Delphi
public procedure DataBind();
JScript
public function DataBind();
Managed Extensions for C++
public: void DataBind();
C++/CLI
public:
void DataBind();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridDataSourceInfo Class
WebGridDataSourceInfo Members


EnsureDataBound Method

[image]
Intersoft WebGrid Documentation
EnsureDataBound Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridDataSourceInfo Class : EnsureDataBound Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub EnsureDataBound()
Visual Basic (Usage) Copy Code
Dim instance As WebGridDataSourceInfo

instance.EnsureDataBound()
C#
public void EnsureDataBound()
Delphi
public procedure EnsureDataBound();
JScript
public function EnsureDataBound();
Managed Extensions for C++
public: void EnsureDataBound();
C++/CLI
public:
void EnsureDataBound();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridDataSourceInfo Class
WebGridDataSourceInfo Members


FindControl Method

[image]
Intersoft WebGrid Documentation
FindControl Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridDataSourceInfo Class : FindControl Method

control
controlID

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function FindControl( _
   ByVal control As System.Web.UI.Control, _
   ByVal controlID As System.String _
) As System.Web.UI.Control
Visual Basic (Usage) Copy Code
Dim instance As WebGridDataSourceInfo
Dim control As System.Web.UI.Control
Dim controlID As System.String
Dim value As System.Web.UI.Control

value = instance.FindControl(control, controlID)
C#
public System.Web.UI.Control FindControl(
   System.Web.UI.Control control,
   System.string controlID
)
Delphi
public function FindControl(
    control: System.Web.UI.Control;
    controlID: System.String
): System.Web.UI.Control;
JScript
public function FindControl(
   control : System.Web.UI.Control,
   controlID : System.String
) : System.Web.UI.Control;
Managed Extensions for C++
public: System.Web.UI.Control* FindControl(
   System.Web.UI.Control* control,
   System.string* controlID
)
C++/CLI
public:
System.Web.UI.Control^ FindControl(
   System.Web.UI.Control^ control,
   System.String^ controlID
)

Parameters

control
controlID

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridDataSourceInfo Class
WebGridDataSourceInfo Members


GetData Method

[image]
Intersoft WebGrid Documentation
GetData Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridDataSourceInfo Class : GetData Method

Glossary Item Box

Overload List

Overload | Description
GetData() | (Inherited from ISNet.WebUI.DataSourceInfo)
GetData(String) | (Inherited from ISNet.WebUI.DataSourceInfo)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridDataSourceInfo Class
WebGridDataSourceInfo Members


GetData() Method

[image]
Intersoft WebGrid Documentation
GetData() Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridDataSourceInfo Class > GetData Method : GetData() Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function GetData() As System.Web.UI.DataSourceView
Visual Basic (Usage) Copy Code
Dim instance As WebGridDataSourceInfo
Dim value As System.Web.UI.DataSourceView

value = instance.GetData()
C#
public System.Web.UI.DataSourceView GetData()
Delphi
public function GetData(): System.Web.UI.DataSourceView;
JScript
public function GetData() : System.Web.UI.DataSourceView;
Managed Extensions for C++
public: System.Web.UI.DataSourceView* GetData();
C++/CLI
public:
System.Web.UI.DataSourceView^ GetData();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridDataSourceInfo Class
WebGridDataSourceInfo Members
Overload List


GetData(String) Method

[image]
Intersoft WebGrid Documentation
GetData(String) Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridDataSourceInfo Class > GetData Method : GetData(String) Method

viewName

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function GetData( _
   ByVal viewName As System.String _
) As System.Web.UI.DataSourceView
Visual Basic (Usage) Copy Code
Dim instance As WebGridDataSourceInfo
Dim viewName As System.String
Dim value As System.Web.UI.DataSourceView

value = instance.GetData(viewName)
C#
public System.Web.UI.DataSourceView GetData(
   System.string viewName
)
Delphi
public function GetData(
    viewName: System.String
): System.Web.UI.DataSourceView;
JScript
public function GetData(
   viewName : System.String
) : System.Web.UI.DataSourceView;
Managed Extensions for C++
public: System.Web.UI.DataSourceView* GetData(
   System.string* viewName
)
C++/CLI
public:
System.Web.UI.DataSourceView^ GetData(
   System.String^ viewName
)

Parameters

viewName

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridDataSourceInfo Class
WebGridDataSourceInfo Members
Overload List


GetDataSourceControl Method

[image]
Intersoft WebGrid Documentation
GetDataSourceControl Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridDataSourceInfo Class : GetDataSourceControl Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetDataSourceControl() As System.Web.UI.Control
Visual Basic (Usage) Copy Code
Dim instance As WebGridDataSourceInfo
Dim value As System.Web.UI.Control

value = instance.GetDataSourceControl()
C#
public System.Web.UI.Control GetDataSourceControl()
Delphi
public function GetDataSourceControl(): System.Web.UI.Control;
JScript
public function GetDataSourceControl() : System.Web.UI.Control;
Managed Extensions for C++
public: System.Web.UI.Control* GetDataSourceControl();
C++/CLI
public:
System.Web.UI.Control^ GetDataSourceControl();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridDataSourceInfo Class
WebGridDataSourceInfo Members


GetDataSourceID Method

[image]
Intersoft WebGrid Documentation
GetDataSourceID Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridDataSourceInfo Class : GetDataSourceID Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetDataSourceID() As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebGridDataSourceInfo
Dim value As System.String

value = instance.GetDataSourceID()
C#
public System.string GetDataSourceID()
Delphi
public function GetDataSourceID(): System.String;
JScript
public function GetDataSourceID() : System.String;
Managed Extensions for C++
public: System.string* GetDataSourceID();
C++/CLI
public:
System.String^ GetDataSourceID();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridDataSourceInfo Class
WebGridDataSourceInfo Members


GetSelectParameters Method

[image]
Intersoft WebGrid Documentation
GetSelectParameters Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridDataSourceInfo Class : GetSelectParameters Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetSelectParameters() As System.Web.UI.WebControls.ParameterCollection
Visual Basic (Usage) Copy Code
Dim instance As WebGridDataSourceInfo
Dim value As System.Web.UI.WebControls.ParameterCollection

value = instance.GetSelectParameters()
C#
public System.Web.UI.WebControls.ParameterCollection GetSelectParameters()
Delphi
public function GetSelectParameters(): System.Web.UI.WebControls.ParameterCollection;
JScript
public function GetSelectParameters() : System.Web.UI.WebControls.ParameterCollection;
Managed Extensions for C++
public: System.Web.UI.WebControls.ParameterCollection* GetSelectParameters();
C++/CLI
public:
System.Web.UI.WebControls.ParameterCollection^ GetSelectParameters();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridDataSourceInfo Class
WebGridDataSourceInfo Members


GetTable Method

[image]
Intersoft WebGrid Documentation
GetTable Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridDataSourceInfo Class : GetTable Method

name

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetTable( _
   ByVal name As System.String _
) As ISNet.WebUI.IDataSourceTable
Visual Basic (Usage) Copy Code
Dim instance As WebGridDataSourceInfo
Dim name As System.String
Dim value As ISNet.WebUI.IDataSourceTable

value = instance.GetTable(name)
C#
public ISNet.WebUI.IDataSourceTable GetTable(
   System.string name
)
Delphi
public function GetTable(
    name: System.String
): ISNet.WebUI.IDataSourceTable;
JScript
public function GetTable(
   name : System.String
) : ISNet.WebUI.IDataSourceTable;
Managed Extensions for C++
public: ISNet.WebUI.IDataSourceTable* GetTable(
   System.string* name
)
C++/CLI
public:
ISNet.WebUI.IDataSourceTable^ GetTable(
   System.String^ name
)

Parameters

name

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridDataSourceInfo Class
WebGridDataSourceInfo Members


IsIntersoftDataSourceControl Method

[image]
Intersoft WebGrid Documentation
IsIntersoftDataSourceControl Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridDataSourceInfo Class : IsIntersoftDataSourceControl Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsIntersoftDataSourceControl() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebGridDataSourceInfo
Dim value As System.Boolean

value = instance.IsIntersoftDataSourceControl()
C#
public System.bool IsIntersoftDataSourceControl()
Delphi
public function IsIntersoftDataSourceControl(): System.Boolean;
JScript
public function IsIntersoftDataSourceControl() : System.boolean;
Managed Extensions for C++
public: System.bool IsIntersoftDataSourceControl();
C++/CLI
public:
System.bool IsIntersoftDataSourceControl();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridDataSourceInfo Class
WebGridDataSourceInfo Members


SetViewValid Method

[image]
Intersoft WebGrid Documentation
SetViewValid Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridDataSourceInfo Class : SetViewValid Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SetViewValid()
Visual Basic (Usage) Copy Code
Dim instance As WebGridDataSourceInfo

instance.SetViewValid()
C#
public void SetViewValid()
Delphi
public procedure SetViewValid();
JScript
public function SetViewValid();
Managed Extensions for C++
public: void SetViewValid();
C++/CLI
public:
void SetViewValid();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridDataSourceInfo Class
WebGridDataSourceInfo Members


ValidateDataSource Method

[image]
Intersoft WebGrid Documentation
ValidateDataSource Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridDataSourceInfo Class : ValidateDataSource Method

dataSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub ValidateDataSource( _
   ByVal dataSource As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebGridDataSourceInfo
Dim dataSource As System.Object

instance.ValidateDataSource(dataSource)
C#
public void ValidateDataSource(
   System.object dataSource
)
Delphi
public procedure ValidateDataSource(
    dataSource: System.TObject
);
JScript
public function ValidateDataSource(
   dataSource : System.Object
);
Managed Extensions for C++
public: void ValidateDataSource(
   System.Object* dataSource
)
C++/CLI
public:
void ValidateDataSource(
   System.Object^ dataSource
)

Parameters

dataSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridDataSourceInfo Class
WebGridDataSourceInfo Members


Control Property

[image]
Intersoft WebGrid Documentation
Control Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridDataSourceInfo Class : Control Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Control As ISNet.WebUI.ISNetControl
Visual Basic (Usage) Copy Code
Dim instance As WebGridDataSourceInfo
Dim value As ISNet.WebUI.ISNetControl

value = instance.Control
C#
public ISNet.WebUI.ISNetControl Control {get;}
Delphi
public read-only property Control: ISNet.WebUI.ISNetControl;
JScript
public function get Control : ISNet.WebUI.ISNetControl
Managed Extensions for C++
public: __property ISNet.WebUI.ISNetControl* get_Control();
C++/CLI
public:
property ISNet.WebUI.ISNetControl^ Control {
   ISNet.WebUI.ISNetControl^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridDataSourceInfo Class
WebGridDataSourceInfo Members


CurrentDataSource Property

[image]
Intersoft WebGrid Documentation
CurrentDataSource Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridDataSourceInfo Class : CurrentDataSource Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property CurrentDataSource As System.Collections.IEnumerable
Visual Basic (Usage) Copy Code
Dim instance As WebGridDataSourceInfo
Dim value As System.Collections.IEnumerable

value = instance.CurrentDataSource
C#
public System.Collections.IEnumerable CurrentDataSource {get;}
Delphi
public read-only property CurrentDataSource: System.Collections.IEnumerable;
JScript
public function get CurrentDataSource : System.Collections.IEnumerable
Managed Extensions for C++
public: __property System.Collections.IEnumerable* get_CurrentDataSource();
C++/CLI
public:
property System.Collections.IEnumerable^ CurrentDataSource {
   System.Collections.IEnumerable^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridDataSourceInfo Class
WebGridDataSourceInfo Members


IgnoreDataSourceViewChanged Property

[image]
Intersoft WebGrid Documentation
IgnoreDataSourceViewChanged Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridDataSourceInfo Class : IgnoreDataSourceViewChanged Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public WriteOnly Property IgnoreDataSourceViewChanged As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebGridDataSourceInfo

instance.IgnoreDataSourceViewChanged = value
C#
public System.bool IgnoreDataSourceViewChanged {set;}
Delphi
public write-only property IgnoreDataSourceViewChanged: System.Boolean;
JScript
public function set IgnoreDataSourceViewChanged : System.boolean
Managed Extensions for C++
public: __property void set_IgnoreDataSourceViewChanged(
   System.bool value
);
C++/CLI
public:
property System.bool IgnoreDataSourceViewChanged {
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridDataSourceInfo Class
WebGridDataSourceInfo Members


IsBoundUsingDataSourceID Property

[image]
Intersoft WebGrid Documentation
IsBoundUsingDataSourceID Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridDataSourceInfo Class : IsBoundUsingDataSourceID Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsBoundUsingDataSourceID As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebGridDataSourceInfo
Dim value As System.Boolean

value = instance.IsBoundUsingDataSourceID
C#
public System.bool IsBoundUsingDataSourceID {get;}
Delphi
public read-only property IsBoundUsingDataSourceID: System.Boolean;
JScript
public function get IsBoundUsingDataSourceID : System.boolean
Managed Extensions for C++
public: __property System.bool get_IsBoundUsingDataSourceID();
C++/CLI
public:
property System.bool IsBoundUsingDataSourceID {
   System.bool get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridDataSourceInfo Class
WebGridDataSourceInfo Members


IsDataSourceViewValid Property

[image]
Intersoft WebGrid Documentation
IsDataSourceViewValid Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridDataSourceInfo Class : IsDataSourceViewValid Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsDataSourceViewValid As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebGridDataSourceInfo
Dim value As System.Boolean

value = instance.IsDataSourceViewValid
C#
public System.bool IsDataSourceViewValid {get;}
Delphi
public read-only property IsDataSourceViewValid: System.Boolean;
JScript
public function get IsDataSourceViewValid : System.boolean
Managed Extensions for C++
public: __property System.bool get_IsDataSourceViewValid();
C++/CLI
public:
property System.bool IsDataSourceViewValid {
   System.bool get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridDataSourceInfo Class
WebGridDataSourceInfo Members


RequiresDataBinding Property

[image]
Intersoft WebGrid Documentation
RequiresDataBinding Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridDataSourceInfo Class : RequiresDataBinding Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property RequiresDataBinding As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebGridDataSourceInfo
Dim value As System.Boolean

instance.RequiresDataBinding = value

value = instance.RequiresDataBinding
C#
public System.bool RequiresDataBinding {get; set;}
Delphi
public read-write property RequiresDataBinding: System.Boolean;
JScript
public function get,set RequiresDataBinding : System.boolean
Managed Extensions for C++
public: __property System.bool get_RequiresDataBinding();
public: __property void set_RequiresDataBinding(
   System.bool value
);
C++/CLI
public:
property System.bool RequiresDataBinding {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridDataSourceInfo Class
WebGridDataSourceInfo Members


SelectArguments Property

[image]
Intersoft WebGrid Documentation
SelectArguments Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridDataSourceInfo Class : SelectArguments Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property SelectArguments As System.Web.UI.DataSourceSelectArguments
Visual Basic (Usage) Copy Code
Dim instance As WebGridDataSourceInfo
Dim value As System.Web.UI.DataSourceSelectArguments

value = instance.SelectArguments
C#
public System.Web.UI.DataSourceSelectArguments SelectArguments {get;}
Delphi
public read-only property SelectArguments: System.Web.UI.DataSourceSelectArguments;
JScript
public function get SelectArguments : System.Web.UI.DataSourceSelectArguments
Managed Extensions for C++
public: __property System.Web.UI.DataSourceSelectArguments* get_SelectArguments();
C++/CLI
public:
property System.Web.UI.DataSourceSelectArguments^ SelectArguments {
   System.Web.UI.DataSourceSelectArguments^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridDataSourceInfo Class
WebGridDataSourceInfo Members


DataBinding Event

[image]
Intersoft WebGrid Documentation
DataBinding Event
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridDataSourceInfo Class : DataBinding Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Event DataBinding As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebGridDataSourceInfo
Dim handler As System.EventHandler

AddHandler instance.DataBinding, handler
C#
public event System.EventHandler DataBinding
Delphi
public event DataBinding: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
public: __event System.EventHandler* DataBinding
C++/CLI
public:
event System.EventHandler^ DataBinding

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridDataSourceInfo Class
WebGridDataSourceInfo Members


DataBound Event

[image]
Intersoft WebGrid Documentation
DataBound Event
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridDataSourceInfo Class : DataBound Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Event DataBound As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebGridDataSourceInfo
Dim handler As System.EventHandler

AddHandler instance.DataBound, handler
C#
public event System.EventHandler DataBound
Delphi
public event DataBound: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
public: __event System.EventHandler* DataBound
C++/CLI
public:
event System.EventHandler^ DataBound

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridDataSourceInfo Class
WebGridDataSourceInfo Members


WebGridDesigner Class

[image]
Intersoft WebGrid Documentation
WebGridDesigner Class
Members See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : WebGridDesigner Class

Glossary Item Box

Object Model

WebGridDesigner Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class WebGridDesigner
   Inherits ISNet.WebUI.ISDataBoundDesignerBase
Visual Basic (Usage) Copy Code
Dim instance As WebGridDesigner
C#
public sealed class WebGridDesigner : ISNet.WebUI.ISDataBoundDesignerBase
Delphi
public class WebGridDesigner = class(ISNet.WebUI.ISDataBoundDesignerBase)sealed;
JScript
public sealed class WebGridDesigner extends ISNet.WebUI.ISDataBoundDesignerBase
Managed Extensions for C++
public __gc __sealed class WebGridDesigner : public ISNet.WebUI.ISDataBoundDesignerBase
C++/CLI
public ref class WebGridDesigner sealed : public ISNet.WebUI.ISDataBoundDesignerBase

Inheritance Hierarchy

System.Object
System.ComponentModel.Design.ComponentDesigner
System.Web.UI.Design.HtmlControlDesigner
System.Web.UI.Design.ControlDesigner
ISNet.WebUI.ISDesignerBase
ISNet.WebUI.ISDataBoundDesignerBase
ISNet.WebUI.WebGrid.WebGridDesigner

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridDesigner Members
ISNet.WebUI.WebGrid Namespace


WebGridDesigner Class Members

[image]
Intersoft WebGrid Documentation
WebGridDesigner Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebGrid Namespace : WebGridDesigner Class

Glossary Item Box

The following tables list the members exposed by WebGridDesigner.

Public Constructors

 | Name | Description
Public Constructor | WebGridDesigner Constructor |
Top

Public Properties

 | Name | Description
Public Property | ActionLists | Overridden.
Public Property | AllowResize | Overridden.
Public Property | AssociatedComponents | (Inherited from System.ComponentModel.Design.ComponentDesigner)
Public Property | AutoFormats | (Inherited from System.Web.UI.Design.ControlDesigner)
Public Property | Behavior | (Inherited from System.Web.UI.Design.HtmlControlDesigner)
Public Property | CanRefreshSchema | (Inherited from ISNet.WebUI.ISDataBoundDesignerBase)
Public Property | Component | (Inherited from System.ComponentModel.Design.ComponentDesigner)
Public Property | Control | (Inherited from ISNet.WebUI.ISDesignerBase)
Public Property | DataBindings | (Inherited from System.Web.UI.Design.HtmlControlDesigner)
Public Property | DataMember | (Inherited from ISNet.WebUI.ISDataBoundDesignerBase)
Public Property | DataSource | (Inherited from ISNet.WebUI.ISDataBoundDesignerBase)
Public Property | DataSourceDesigner | (Inherited from ISNet.WebUI.ISDataBoundDesignerBase)
Public Property | DataSourceID | (Inherited from ISNet.WebUI.ISDataBoundDesignerBase)
Public Property | DesignerView | (Inherited from ISNet.WebUI.ISDataBoundDesignerBase)
Public Property | DesignTimeHtmlRequiresLoadComplete | (Inherited from System.Web.UI.Design.ControlDesigner)
Public Property | Expressions | (Inherited from System.Web.UI.Design.HtmlControlDesigner)
Public Property | ID | (Inherited from System.Web.UI.Design.ControlDesigner)
Public Property | InitialDialog |
Public Property | IsDirty | (Inherited from System.Web.UI.Design.ControlDesigner)
Public Property | IsStandalone | (Inherited from ISNet.WebUI.ISDesignerBase)
Public Property | PivotChartingChanged |
Public Property | ReadOnly | (Inherited from System.Web.UI.Design.ControlDesigner)
Public Property | Schema | (Inherited from ISNet.WebUI.ISDataBoundDesignerBase)
Public Property | ShouldCodeSerialize | (Inherited from System.Web.UI.Design.HtmlControlDesigner)
Public Property | TemplateGroups | Overridden.
Public Property | Verbs | Overridden.
Public Property | ViewControl | (Inherited from System.Web.UI.Design.ControlDesigner)
Public Property | ViewControlCreated | (Inherited from System.Web.UI.Design.ControlDesigner)
Top

Public Methods

 | Name | Description
Public Method | Dispose | (Inherited from System.ComponentModel.Design.ComponentDesigner)
Public Method | DoDefaultAction | (Inherited from System.ComponentModel.Design.ComponentDesigner)
Public Method | GetBounds | (Inherited from System.Web.UI.Design.ControlDesigner)
Public Method | GetDesignTimeHierarchicalDataSource |
Public Method | GetDesignTimeHtml | Overloaded. Overridden.
Public Method | GetEditableDesignerRegionContent | (Inherited from System.Web.UI.Design.ControlDesigner)
Public Method | GetPersistenceContent | (Inherited from System.Web.UI.Design.ControlDesigner)
Public Method | GetPersistInnerHtml | (Inherited from System.Web.UI.Design.ControlDesigner)
Public Method | GetResolvedSelectedDataSource | (Inherited from ISNet.WebUI.ISDataBoundDesignerBase)
Public Method | GetSelectedDataSource | (Inherited from ISNet.WebUI.ISDataBoundDesignerBase)
Public Method | GetViewRendering | (Inherited from System.Web.UI.Design.ControlDesigner)
Public Method | GetVisualStudioVersion | (Inherited from ISNet.WebUI.ISDesignerBase)
Public Method | Initialize | Overridden.
Public Method | InitializeExistingComponent | (Inherited from System.ComponentModel.Design.ComponentDesigner)
Public Method | InitializeNewComponent | (Inherited from System.ComponentModel.Design.ComponentDesigner)
Public Method | InitializeNonDefault | (Inherited from System.ComponentModel.Design.ComponentDesigner)
Public Method | Invalidate | Overloaded. (Inherited from System.Web.UI.Design.ControlDesigner)
Public Method | IsPropertyBound | (Inherited from System.Web.UI.Design.ControlDesigner)
Public Method | IsVisualStudio2008Plus | (Inherited from ISNet.WebUI.ISDesignerBase)
Public Method | LaunchDesigner |
Public Method | LaunchFromEditor |
Public Method | Localize | (Inherited from System.Web.UI.Design.ControlDesigner)
Public Method | OnAboutClick | (Inherited from ISNet.WebUI.ISDesignerBase)
Public Method | OnAutoFormatApplied | (Inherited from System.Web.UI.Design.ControlDesigner)
Public Method | OnComponentChanged | (Inherited from System.Web.UI.Design.ControlDesigner)
Public Method | OnComponentChanging | (Inherited from System.Web.UI.Design.ControlDesigner)
Public Method | OnGridDesigner |
Public Method | OnRetrieveHierarchicalStructure | Overloaded.
Public Method | OnRetrieveStructure | Overloaded.
Public Method | OnSetComponentDefaults | (Inherited from System.ComponentModel.Design.ComponentDesigner)
Public Method | OnSetParent | (Inherited from ISNet.WebUI.ISDesignerBase)
Public Method | RaiseResizeEvent | (Inherited from System.Web.UI.Design.ControlDesigner)
Public Method | RefreshSchema | (Inherited from ISNet.WebUI.ISDataBoundDesignerBase)
Public Method | RegisterClone | (Inherited from System.Web.UI.Design.ControlDesigner)
Public Method | RegisterSmartWebResources | (Inherited from ISNet.WebUI.ISDesignerBase)
Public Method | ResolveDesignTimeRelativeURL | (Inherited from ISNet.WebUI.ISDesignerBase)
Public Method | SetComponent |
Public Method | SetDirty | (Inherited from ISNet.WebUI.ISDesignerBase)
Public Method | SetEditableDesignerRegionContent | (Inherited from System.Web.UI.Design.ControlDesigner)
Public Method | UpdateDesignTimeHtml | (Inherited from System.Web.UI.Design.ControlDesigner)
Top

See Also

Reference

WebGridDesigner Class
ISNet.WebUI.WebGrid Namespace


WebGridDesigner Constructor

[image]
Intersoft WebGrid Documentation
WebGridDesigner Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridDesigner Class : WebGridDesigner Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebGridDesigner()
C#
public WebGridDesigner()
Delphi
public WebGridDesigner();
JScript
public function WebGridDesigner();
Managed Extensions for C++
public: WebGridDesigner();
C++/CLI
public:
WebGridDesigner();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridDesigner Class
WebGridDesigner Members


Dispose Method

[image]
Intersoft WebGrid Documentation
Dispose Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridDesigner Class : Dispose Method

Glossary Item Box

Overload List

Overload | Description
Dispose | (Inherited from System.ComponentModel.Design.ComponentDesigner)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridDesigner Class
WebGridDesigner Members


Dispose() Method

[image]
Intersoft WebGrid Documentation
Dispose() Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridDesigner Class : Dispose() Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub Dispose()
Visual Basic (Usage) Copy Code
Dim instance As WebGridDesigner

instance.Dispose()
C#
public void Dispose()
Delphi
public procedure Dispose();
JScript
public function Dispose();
Managed Extensions for C++
public: void Dispose();
C++/CLI
public:
void Dispose();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridDesigner Class
WebGridDesigner Members


DoDefaultAction Method

[image]
Intersoft WebGrid Documentation
DoDefaultAction Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridDesigner Class : DoDefaultAction Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DoDefaultAction()
Visual Basic (Usage) Copy Code
Dim instance As WebGridDesigner

instance.DoDefaultAction()
C#
public void DoDefaultAction()
Delphi
public procedure DoDefaultAction();
JScript
public function DoDefaultAction();
Managed Extensions for C++
public: void DoDefaultAction();
C++/CLI
public:
void DoDefaultAction();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridDesigner Class
WebGridDesigner Members


GetBounds Method

[image]
Intersoft WebGrid Documentation
GetBounds Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridDesigner Class : GetBounds Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetBounds() As System.Drawing.Rectangle
Visual Basic (Usage) Copy Code
Dim instance As WebGridDesigner
Dim value As System.Drawing.Rectangle

value = instance.GetBounds()
C#
public System.Drawing.Rectangle GetBounds()
Delphi
public function GetBounds(): System.Drawing.Rectangle;
JScript
public function GetBounds() : System.Drawing.Rectangle;
Managed Extensions for C++
public: System.Drawing.Rectangle GetBounds();
C++/CLI
public:
System.Drawing.Rectangle GetBounds();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridDesigner Class
WebGridDesigner Members


WebGridDesigner Class Methods

[image]
Intersoft WebGrid Documentation
WebGridDesigner Class Methods
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : WebGridDesigner Class

Glossary Item Box

For a list of all members of this type, see WebGridDesigner members.

Public Methods

 | Name | Description
Public Method | Dispose | (Inherited from System.ComponentModel.Design.ComponentDesigner)
Public Method | DoDefaultAction | (Inherited from System.ComponentModel.Design.ComponentDesigner)
Public Method | GetBounds | (Inherited from System.Web.UI.Design.ControlDesigner)
Public Method | GetDesignTimeHierarchicalDataSource |
Public Method | GetDesignTimeHtml | Overloaded. Overridden.
Public Method | GetEditableDesignerRegionContent | (Inherited from System.Web.UI.Design.ControlDesigner)
Public Method | GetPersistenceContent | (Inherited from System.Web.UI.Design.ControlDesigner)
Public Method | GetPersistInnerHtml | (Inherited from System.Web.UI.Design.ControlDesigner)
Public Method | GetResolvedSelectedDataSource | (Inherited from ISNet.WebUI.ISDataBoundDesignerBase)
Public Method | GetSelectedDataSource | (Inherited from ISNet.WebUI.ISDataBoundDesignerBase)
Public Method | GetViewRendering | (Inherited from System.Web.UI.Design.ControlDesigner)
Public Method | GetVisualStudioVersion | (Inherited from ISNet.WebUI.ISDesignerBase)
Public Method | Initialize | Overridden.
Public Method | InitializeExistingComponent | (Inherited from System.ComponentModel.Design.ComponentDesigner)
Public Method | InitializeNewComponent | (Inherited from System.ComponentModel.Design.ComponentDesigner)
Public Method | InitializeNonDefault | (Inherited from System.ComponentModel.Design.ComponentDesigner)
Public Method | Invalidate | Overloaded. (Inherited from System.Web.UI.Design.ControlDesigner)
Public Method | IsPropertyBound | (Inherited from System.Web.UI.Design.ControlDesigner)
Public Method | IsVisualStudio2008Plus | (Inherited from ISNet.WebUI.ISDesignerBase)
Public Method | LaunchDesigner |
Public Method | LaunchFromEditor |
Public Method | Localize | (Inherited from System.Web.UI.Design.ControlDesigner)
Public Method | OnAboutClick | (Inherited from ISNet.WebUI.ISDesignerBase)
Public Method | OnAutoFormatApplied | (Inherited from System.Web.UI.Design.ControlDesigner)
Public Method | OnComponentChanged | (Inherited from System.Web.UI.Design.ControlDesigner)
Public Method | OnComponentChanging | (Inherited from System.Web.UI.Design.ControlDesigner)
Public Method | OnGridDesigner |
Public Method | OnRetrieveHierarchicalStructure | Overloaded.
Public Method | OnRetrieveStructure | Overloaded.
Public Method | OnSetComponentDefaults | (Inherited from System.ComponentModel.Design.ComponentDesigner)
Public Method | OnSetParent | (Inherited from ISNet.WebUI.ISDesignerBase)
Public Method | RaiseResizeEvent | (Inherited from System.Web.UI.Design.ControlDesigner)
Public Method | RefreshSchema | (Inherited from ISNet.WebUI.ISDataBoundDesignerBase)
Public Method | RegisterClone | (Inherited from System.Web.UI.Design.ControlDesigner)
Public Method | RegisterSmartWebResources | (Inherited from ISNet.WebUI.ISDesignerBase)
Public Method | ResolveDesignTimeRelativeURL | (Inherited from ISNet.WebUI.ISDesignerBase)
Public Method | SetComponent |
Public Method | SetDirty | (Inherited from ISNet.WebUI.ISDesignerBase)
Public Method | SetEditableDesignerRegionContent | (Inherited from System.Web.UI.Design.ControlDesigner)
Public Method | UpdateDesignTimeHtml | (Inherited from System.Web.UI.Design.ControlDesigner)
Top

See Also

Reference

WebGridDesigner Class
ISNet.WebUI.WebGrid Namespace


GetDesignTimeHierarchicalDataSource Method

[image]
Intersoft WebGrid Documentation
GetDesignTimeHierarchicalDataSource Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridDesigner Class : GetDesignTimeHierarchicalDataSource Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetDesignTimeHierarchicalDataSource() As System.Data.DataSet
Visual Basic (Usage) Copy Code
Dim instance As WebGridDesigner
Dim value As System.Data.DataSet

value = instance.GetDesignTimeHierarchicalDataSource()
C#
public System.Data.DataSet GetDesignTimeHierarchicalDataSource()
Delphi
public function GetDesignTimeHierarchicalDataSource(): System.Data.DataSet;
JScript
public function GetDesignTimeHierarchicalDataSource() : System.Data.DataSet;
Managed Extensions for C++
public: System.Data.DataSet* GetDesignTimeHierarchicalDataSource();
C++/CLI
public:
System.Data.DataSet^ GetDesignTimeHierarchicalDataSource();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridDesigner Class
WebGridDesigner Members


GetDesignTimeHtml Method

[image]
Intersoft WebGrid Documentation
GetDesignTimeHtml Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridDesigner Class : GetDesignTimeHtml Method

Glossary Item Box

Overload List

Overload | Description
GetDesignTimeHtml() |
GetDesignTimeHtml(DesignerRegionCollection) | (Inherited from ISNet.WebUI.ISDesignerBase)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridDesigner Class
WebGridDesigner Members


GetDesignTimeHtml() Method

[image]
Intersoft WebGrid Documentation
GetDesignTimeHtml() Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridDesigner Class > GetDesignTimeHtml Method : GetDesignTimeHtml() Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overrides NotOverridable Function GetDesignTimeHtml() As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebGridDesigner
Dim value As System.String

value = instance.GetDesignTimeHtml()
C#
public override System.string GetDesignTimeHtml()
Delphi
public function GetDesignTimeHtml(): System.String; override;
JScript
public override function GetDesignTimeHtml() : System.String;
Managed Extensions for C++
public: System.string* GetDesignTimeHtml(); override
C++/CLI
public:
System.String^ GetDesignTimeHtml(); override

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridDesigner Class
WebGridDesigner Members
Overload List


GetDesignTimeHtml(DesignerRegionCollection) Method

[image]
Intersoft WebGrid Documentation
GetDesignTimeHtml(DesignerRegionCollection) Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridDesigner Class > GetDesignTimeHtml Method : GetDesignTimeHtml(DesignerRegionCollection) Method

regions

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function GetDesignTimeHtml( _
   ByVal regions As System.Web.UI.Design.DesignerRegionCollection _
) As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebGridDesigner
Dim regions As System.Web.UI.Design.DesignerRegionCollection
Dim value As System.String

value = instance.GetDesignTimeHtml(regions)
C#
public System.string GetDesignTimeHtml(
   System.Web.UI.Design.DesignerRegionCollection regions
)
Delphi
public function GetDesignTimeHtml(
    regions: System.Web.UI.Design.DesignerRegionCollection
): System.String;
JScript
public function GetDesignTimeHtml(
   regions : System.Web.UI.Design.DesignerRegionCollection
) : System.String;
Managed Extensions for C++
public: System.string* GetDesignTimeHtml(
   System.Web.UI.Design.DesignerRegionCollection* regions
)
C++/CLI
public:
System.String^ GetDesignTimeHtml(
   System.Web.UI.Design.DesignerRegionCollection^ regions
)

Parameters

regions

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridDesigner Class
WebGridDesigner Members
Overload List


GetEditableDesignerRegionContent Method

[image]
Intersoft WebGrid Documentation
GetEditableDesignerRegionContent Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridDesigner Class : GetEditableDesignerRegionContent Method

region

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetEditableDesignerRegionContent( _
   ByVal region As System.Web.UI.Design.EditableDesignerRegion _
) As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebGridDesigner
Dim region As System.Web.UI.Design.EditableDesignerRegion
Dim value As System.String

value = instance.GetEditableDesignerRegionContent(region)
C#
public System.string GetEditableDesignerRegionContent(
   System.Web.UI.Design.EditableDesignerRegion region
)
Delphi
public function GetEditableDesignerRegionContent(
    region: System.Web.UI.Design.EditableDesignerRegion
): System.String;
JScript
public function GetEditableDesignerRegionContent(
   region : System.Web.UI.Design.EditableDesignerRegion
) : System.String;
Managed Extensions for C++
public: System.string* GetEditableDesignerRegionContent(
   System.Web.UI.Design.EditableDesignerRegion* region
)
C++/CLI
public:
System.String^ GetEditableDesignerRegionContent(
   System.Web.UI.Design.EditableDesignerRegion^ region
)

Parameters

region

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridDesigner Class
WebGridDesigner Members


GetPersistenceContent Method

[image]
Intersoft WebGrid Documentation
GetPersistenceContent Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridDesigner Class : GetPersistenceContent Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")>
Public Function GetPersistenceContent() As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebGridDesigner
Dim value As System.String

value = instance.GetPersistenceContent()
C#
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public System.string GetPersistenceContent()
Delphi
public function GetPersistenceContent(): System.String;
JScript
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")
public function GetPersistenceContent() : System.String;
Managed Extensions for C++
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public: System.string* GetPersistenceContent();
C++/CLI
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public:
System.String^ GetPersistenceContent();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridDesigner Class
WebGridDesigner Members


GetPersistInnerHtml Method

[image]
Intersoft WebGrid Documentation
GetPersistInnerHtml Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridDesigner Class : GetPersistInnerHtml Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ObsoleteAttribute("The recommended alternative is GetPersistenceContent(). http://go.microsoft.com/fwlink/?linkid=14202")>
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")>
Public Function GetPersistInnerHtml() As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebGridDesigner
Dim value As System.String

value = instance.GetPersistInnerHtml()
C#
[System.ObsoleteAttribute("The recommended alternative is GetPersistenceContent(). http://go.microsoft.com/fwlink/?linkid=14202")]
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public System.string GetPersistInnerHtml()
Delphi
public function GetPersistInnerHtml(): System.String;
JScript
System.ObsoleteAttribute("The recommended alternative is GetPersistenceContent(). http://go.microsoft.com/fwlink/?linkid=14202")
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")
public function GetPersistInnerHtml() : System.String;
Managed Extensions for C++
[System.ObsoleteAttribute("The recommended alternative is GetPersistenceContent(). http://go.microsoft.com/fwlink/?linkid=14202")]
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public: System.string* GetPersistInnerHtml();
C++/CLI
[System.ObsoleteAttribute("The recommended alternative is GetPersistenceContent(). http://go.microsoft.com/fwlink/?linkid=14202")]
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public:
System.String^ GetPersistInnerHtml();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridDesigner Class
WebGridDesigner Members


GetResolvedSelectedDataSource Method

[image]
Intersoft WebGrid Documentation
GetResolvedSelectedDataSource Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridDesigner Class : GetResolvedSelectedDataSource Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetResolvedSelectedDataSource() As System.Collections.IEnumerable
Visual Basic (Usage) Copy Code
Dim instance As WebGridDesigner
Dim value As System.Collections.IEnumerable

value = instance.GetResolvedSelectedDataSource()
C#
public System.Collections.IEnumerable GetResolvedSelectedDataSource()
Delphi
public function GetResolvedSelectedDataSource(): System.Collections.IEnumerable;
JScript
public function GetResolvedSelectedDataSource() : System.Collections.IEnumerable;
Managed Extensions for C++
public: System.Collections.IEnumerable* GetResolvedSelectedDataSource();
C++/CLI
public:
System.Collections.IEnumerable^ GetResolvedSelectedDataSource();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridDesigner Class
WebGridDesigner Members


GetSelectedDataSource Method

[image]
Intersoft WebGrid Documentation
GetSelectedDataSource Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridDesigner Class : GetSelectedDataSource Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetSelectedDataSource() As System.Object
Visual Basic (Usage) Copy Code
Dim instance As WebGridDesigner
Dim value As System.Object

value = instance.GetSelectedDataSource()
C#
public System.object GetSelectedDataSource()
Delphi
public function GetSelectedDataSource(): System.TObject;
JScript
public function GetSelectedDataSource() : System.Object;
Managed Extensions for C++
public: System.Object* GetSelectedDataSource();
C++/CLI
public:
System.Object^ GetSelectedDataSource();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridDesigner Class
WebGridDesigner Members


GetViewRendering Method

[image]
Intersoft WebGrid Documentation
GetViewRendering Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridDesigner Class : GetViewRendering Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetViewRendering() As System.Web.UI.Design.ViewRendering
Visual Basic (Usage) Copy Code
Dim instance As WebGridDesigner
Dim value As System.Web.UI.Design.ViewRendering

value = instance.GetViewRendering()
C#
public System.Web.UI.Design.ViewRendering GetViewRendering()
Delphi
public function GetViewRendering(): System.Web.UI.Design.ViewRendering;
JScript
public function GetViewRendering() : System.Web.UI.Design.ViewRendering;
Managed Extensions for C++
public: System.Web.UI.Design.ViewRendering* GetViewRendering();
C++/CLI
public:
System.Web.UI.Design.ViewRendering^ GetViewRendering();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridDesigner Class
WebGridDesigner Members


GetVisualStudioVersion Method

[image]
Intersoft WebGrid Documentation
GetVisualStudioVersion Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridDesigner Class : GetVisualStudioVersion Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetVisualStudioVersion() As ISNet.WebUI.ISDesignerBase.VisualStudioVersion
Visual Basic (Usage) Copy Code
Dim instance As WebGridDesigner
Dim value As ISNet.WebUI.ISDesignerBase.VisualStudioVersion

value = instance.GetVisualStudioVersion()
C#
public ISNet.WebUI.ISDesignerBase.VisualStudioVersion GetVisualStudioVersion()
Delphi
public function GetVisualStudioVersion(): ISNet.WebUI.ISDesignerBase.VisualStudioVersion;
JScript
public function GetVisualStudioVersion() : ISNet.WebUI.ISDesignerBase.VisualStudioVersion;
Managed Extensions for C++
public: ISNet.WebUI.ISDesignerBase.VisualStudioVersion GetVisualStudioVersion();
C++/CLI
public:
ISNet.WebUI.ISDesignerBase.VisualStudioVersion GetVisualStudioVersion();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridDesigner Class
WebGridDesigner Members


Initialize Method

[image]
Intersoft WebGrid Documentation
Initialize Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridDesigner Class : Initialize Method

component

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Sub Initialize( _
   ByVal component As System.ComponentModel.IComponent _
)
Visual Basic (Usage) Copy Code
Dim instance As WebGridDesigner
Dim component As System.ComponentModel.IComponent

instance.Initialize(component)
C#
public override void Initialize(
   System.ComponentModel.IComponent component
)
Delphi
public procedure Initialize(
    component: System.ComponentModel.IComponent
); override;
JScript
public override function Initialize(
   component : System.ComponentModel.IComponent
);
Managed Extensions for C++
public: void Initialize(
   System.ComponentModel.IComponent* component
) override
C++/CLI
public:
void Initialize(
   System.ComponentModel.IComponent^ component
) override

Parameters

component

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridDesigner Class
WebGridDesigner Members


InitializeExistingComponent Method

[image]
Intersoft WebGrid Documentation
InitializeExistingComponent Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridDesigner Class : InitializeExistingComponent Method

defaultValues

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")>
Public Sub InitializeExistingComponent( _
   ByVal defaultValues As System.Collections.IDictionary _
)
Visual Basic (Usage) Copy Code
Dim instance As WebGridDesigner
Dim defaultValues As System.Collections.IDictionary

instance.InitializeExistingComponent(defaultValues)
C#
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public void InitializeExistingComponent(
   System.Collections.IDictionary defaultValues
)
Delphi
public procedure InitializeExistingComponent(
    defaultValues: System.Collections.IDictionary
);
JScript
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")
public function InitializeExistingComponent(
   defaultValues : System.Collections.IDictionary
);
Managed Extensions for C++
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public: void InitializeExistingComponent(
   System.Collections.IDictionary* defaultValues
)
C++/CLI
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public:
void InitializeExistingComponent(
   System.Collections.IDictionary^ defaultValues
)

Parameters

defaultValues

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridDesigner Class
WebGridDesigner Members


InitializeNewComponent Method

[image]
Intersoft WebGrid Documentation
InitializeNewComponent Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridDesigner Class : InitializeNewComponent Method

defaultValues

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub InitializeNewComponent( _
   ByVal defaultValues As System.Collections.IDictionary _
)
Visual Basic (Usage) Copy Code
Dim instance As WebGridDesigner
Dim defaultValues As System.Collections.IDictionary

instance.InitializeNewComponent(defaultValues)
C#
public void InitializeNewComponent(
   System.Collections.IDictionary defaultValues
)
Delphi
public procedure InitializeNewComponent(
    defaultValues: System.Collections.IDictionary
);
JScript
public function InitializeNewComponent(
   defaultValues : System.Collections.IDictionary
);
Managed Extensions for C++
public: void InitializeNewComponent(
   System.Collections.IDictionary* defaultValues
)
C++/CLI
public:
void InitializeNewComponent(
   System.Collections.IDictionary^ defaultValues
)

Parameters

defaultValues

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridDesigner Class
WebGridDesigner Members


InitializeNonDefault Method

[image]
Intersoft WebGrid Documentation
InitializeNonDefault Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridDesigner Class : InitializeNonDefault Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ObsoleteAttribute("This method has been deprecated. Use InitializeExistingComponent instead.  http://go.microsoft.com/fwlink/?linkid=14202")>
Public Sub InitializeNonDefault()
Visual Basic (Usage) Copy Code
Dim instance As WebGridDesigner

instance.InitializeNonDefault()
C#
[System.ObsoleteAttribute("This method has been deprecated. Use InitializeExistingComponent instead.  http://go.microsoft.com/fwlink/?linkid=14202")]
public void InitializeNonDefault()
Delphi
public procedure InitializeNonDefault();
JScript
System.ObsoleteAttribute("This method has been deprecated. Use InitializeExistingComponent instead.  http://go.microsoft.com/fwlink/?linkid=14202")
public function InitializeNonDefault();
Managed Extensions for C++
[System.ObsoleteAttribute("This method has been deprecated. Use InitializeExistingComponent instead.  http://go.microsoft.com/fwlink/?linkid=14202")]
public: void InitializeNonDefault();
C++/CLI
[System.ObsoleteAttribute("This method has been deprecated. Use InitializeExistingComponent instead.  http://go.microsoft.com/fwlink/?linkid=14202")]
public:
void InitializeNonDefault();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridDesigner Class
WebGridDesigner Members


Invalidate Method

[image]
Intersoft WebGrid Documentation
Invalidate Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridDesigner Class : Invalidate Method

Glossary Item Box

Overload List

Overload | Description
Invalidate() | (Inherited from System.Web.UI.Design.ControlDesigner)
Invalidate(Rectangle) | (Inherited from System.Web.UI.Design.ControlDesigner)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridDesigner Class
WebGridDesigner Members


Invalidate() Method

[image]
Intersoft WebGrid Documentation
Invalidate() Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridDesigner Class > Invalidate Method : Invalidate() Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Sub Invalidate()
Visual Basic (Usage) Copy Code
Dim instance As WebGridDesigner

instance.Invalidate()
C#
public void Invalidate()
Delphi
public procedure Invalidate();
JScript
public function Invalidate();
Managed Extensions for C++
public: void Invalidate();
C++/CLI
public:
void Invalidate();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridDesigner Class
WebGridDesigner Members
Overload List


Invalidate(Rectangle) Method

[image]
Intersoft WebGrid Documentation
Invalidate(Rectangle) Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridDesigner Class > Invalidate Method : Invalidate(Rectangle) Method

rectangle

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Sub Invalidate( _
   ByVal rectangle As System.Drawing.Rectangle _
)
Visual Basic (Usage) Copy Code
Dim instance As WebGridDesigner
Dim rectangle As System.Drawing.Rectangle

instance.Invalidate(rectangle)
C#
public void Invalidate(
   System.Drawing.Rectangle rectangle
)
Delphi
public procedure Invalidate(
    rectangle: System.Drawing.Rectangle
);
JScript
public function Invalidate(
   rectangle : System.Drawing.Rectangle
);
Managed Extensions for C++
public: void Invalidate(
   System.Drawing.Rectangle rectangle
)
C++/CLI
public:
void Invalidate(
   System.Drawing.Rectangle rectangle
)

Parameters

rectangle

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridDesigner Class
WebGridDesigner Members
Overload List


IsPropertyBound Method

[image]
Intersoft WebGrid Documentation
IsPropertyBound Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridDesigner Class : IsPropertyBound Method

propName

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ObsoleteAttribute("The recommended alternative is DataBindings.Contains(string). The DataBindings collection allows more control of the databindings associated with the control. http://go.microsoft.com/fwlink/?linkid=14202")>
Public Function IsPropertyBound( _
   ByVal propName As System.String _
) As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebGridDesigner
Dim propName As System.String
Dim value As System.Boolean

value = instance.IsPropertyBound(propName)
C#
[System.ObsoleteAttribute("The recommended alternative is DataBindings.Contains(string). The DataBindings collection allows more control of the databindings associated with the control. http://go.microsoft.com/fwlink/?linkid=14202")]
public System.bool IsPropertyBound(
   System.string propName
)
Delphi
public function IsPropertyBound(
    propName: System.String
): System.Boolean;
JScript
System.ObsoleteAttribute("The recommended alternative is DataBindings.Contains(string). The DataBindings collection allows more control of the databindings associated with the control. http://go.microsoft.com/fwlink/?linkid=14202")
public function IsPropertyBound(
   propName : System.String
) : System.boolean;
Managed Extensions for C++
[System.ObsoleteAttribute("The recommended alternative is DataBindings.Contains(string). The DataBindings collection allows more control of the databindings associated with the control. http://go.microsoft.com/fwlink/?linkid=14202")]
public: System.bool IsPropertyBound(
   System.string* propName
)
C++/CLI
[System.ObsoleteAttribute("The recommended alternative is DataBindings.Contains(string). The DataBindings collection allows more control of the databindings associated with the control. http://go.microsoft.com/fwlink/?linkid=14202")]
public:
System.bool IsPropertyBound(
   System.String^ propName
)

Parameters

propName

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridDesigner Class
WebGridDesigner Members


IsVisualStudio2008Plus Method

[image]
Intersoft WebGrid Documentation
IsVisualStudio2008Plus Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridDesigner Class : IsVisualStudio2008Plus Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsVisualStudio2008Plus() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebGridDesigner
Dim value As System.Boolean

value = instance.IsVisualStudio2008Plus()
C#
public System.bool IsVisualStudio2008Plus()
Delphi
public function IsVisualStudio2008Plus(): System.Boolean;
JScript
public function IsVisualStudio2008Plus() : System.boolean;
Managed Extensions for C++
public: System.bool IsVisualStudio2008Plus();
C++/CLI
public:
System.bool IsVisualStudio2008Plus();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridDesigner Class
WebGridDesigner Members


LaunchDesigner Method

[image]
Intersoft WebGrid Documentation
LaunchDesigner Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridDesigner Class : LaunchDesigner Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function LaunchDesigner() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebGridDesigner
Dim value As System.Boolean

value = instance.LaunchDesigner()
C#
public System.bool LaunchDesigner()
Delphi
public function LaunchDesigner(): System.Boolean;
JScript
public function LaunchDesigner() : System.boolean;
Managed Extensions for C++
public: System.bool LaunchDesigner();
C++/CLI
public:
System.bool LaunchDesigner();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridDesigner Class
WebGridDesigner Members


LaunchFromEditor Method

[image]
Intersoft WebGrid Documentation
LaunchFromEditor Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridDesigner Class : LaunchFromEditor Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub LaunchFromEditor()
Visual Basic (Usage) Copy Code
Dim instance As WebGridDesigner

instance.LaunchFromEditor()
C#
public void LaunchFromEditor()
Delphi
public procedure LaunchFromEditor();
JScript
public function LaunchFromEditor();
Managed Extensions for C++
public: void LaunchFromEditor();
C++/CLI
public:
void LaunchFromEditor();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridDesigner Class
WebGridDesigner Members


Localize Method

[image]
Intersoft WebGrid Documentation
Localize Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridDesigner Class : Localize Method

resourceWriter

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub Localize( _
   ByVal resourceWriter As System.Web.UI.Design.IDesignTimeResourceWriter _
)
Visual Basic (Usage) Copy Code
Dim instance As WebGridDesigner
Dim resourceWriter As System.Web.UI.Design.IDesignTimeResourceWriter

instance.Localize(resourceWriter)
C#
public void Localize(
   System.Web.UI.Design.IDesignTimeResourceWriter resourceWriter
)
Delphi
public procedure Localize(
    resourceWriter: System.Web.UI.Design.IDesignTimeResourceWriter
);
JScript
public function Localize(
   resourceWriter : System.Web.UI.Design.IDesignTimeResourceWriter
);
Managed Extensions for C++
public: void Localize(
   System.Web.UI.Design.IDesignTimeResourceWriter* resourceWriter
)
C++/CLI
public:
void Localize(
   System.Web.UI.Design.IDesignTimeResourceWriter^ resourceWriter
)

Parameters

resourceWriter

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridDesigner Class
WebGridDesigner Members


OnAboutClick Method

[image]
Intersoft WebGrid Documentation
OnAboutClick Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridDesigner Class : OnAboutClick Method

sender
e

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub OnAboutClick( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As WebGridDesigner
Dim sender As System.Object
Dim e As System.EventArgs

instance.OnAboutClick(sender, e)
C#
public void OnAboutClick(
   System.object sender,
   System.EventArgs e
)
Delphi
public procedure OnAboutClick(
    sender: System.TObject;
    e: System.EventArgs
);
JScript
public function OnAboutClick(
   sender : System.Object,
   e : System.EventArgs
);
Managed Extensions for C++
public: void OnAboutClick(
   System.Object* sender,
   System.EventArgs* e
)
C++/CLI
public:
void OnAboutClick(
   System.Object^ sender,
   System.EventArgs^ e
)

Parameters

sender
e

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridDesigner Class
WebGridDesigner Members


OnAutoFormatApplied Method

[image]
Intersoft WebGrid Documentation
OnAutoFormatApplied Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridDesigner Class : OnAutoFormatApplied Method

appliedAutoFormat

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub OnAutoFormatApplied( _
   ByVal appliedAutoFormat As System.Web.UI.Design.DesignerAutoFormat _
)
Visual Basic (Usage) Copy Code
Dim instance As WebGridDesigner
Dim appliedAutoFormat As System.Web.UI.Design.DesignerAutoFormat

instance.OnAutoFormatApplied(appliedAutoFormat)
C#
public void OnAutoFormatApplied(
   System.Web.UI.Design.DesignerAutoFormat appliedAutoFormat
)
Delphi
public procedure OnAutoFormatApplied(
    appliedAutoFormat: System.Web.UI.Design.DesignerAutoFormat
);
JScript
public function OnAutoFormatApplied(
   appliedAutoFormat : System.Web.UI.Design.DesignerAutoFormat
);
Managed Extensions for C++
public: void OnAutoFormatApplied(
   System.Web.UI.Design.DesignerAutoFormat* appliedAutoFormat
)
C++/CLI
public:
void OnAutoFormatApplied(
   System.Web.UI.Design.DesignerAutoFormat^ appliedAutoFormat
)

Parameters

appliedAutoFormat

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridDesigner Class
WebGridDesigner Members


OnComponentChanged Method

[image]
Intersoft WebGrid Documentation
OnComponentChanged Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridDesigner Class : OnComponentChanged Method

sender
ce

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub OnComponentChanged( _
   ByVal sender As System.Object, _
   ByVal ce As System.ComponentModel.Design.ComponentChangedEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As WebGridDesigner
Dim sender As System.Object
Dim ce As System.ComponentModel.Design.ComponentChangedEventArgs

instance.OnComponentChanged(sender, ce)
C#
public void OnComponentChanged(
   System.object sender,
   System.ComponentModel.Design.ComponentChangedEventArgs ce
)
Delphi
public procedure OnComponentChanged(
    sender: System.TObject;
    ce: System.ComponentModel.Design.ComponentChangedEventArgs
);
JScript
public function OnComponentChanged(
   sender : System.Object,
   ce : System.ComponentModel.Design.ComponentChangedEventArgs
);
Managed Extensions for C++
public: void OnComponentChanged(
   System.Object* sender,
   System.ComponentModel.Design.ComponentChangedEventArgs* ce
)
C++/CLI
public:
void OnComponentChanged(
   System.Object^ sender,
   System.ComponentModel.Design.ComponentChangedEventArgs^ ce
)

Parameters

sender
ce

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridDesigner Class
WebGridDesigner Members


OnComponentChanging Method

[image]
Intersoft WebGrid Documentation
OnComponentChanging Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridDesigner Class : OnComponentChanging Method

sender
ce

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub OnComponentChanging( _
   ByVal sender As System.Object, _
   ByVal ce As System.ComponentModel.Design.ComponentChangingEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As WebGridDesigner
Dim sender As System.Object
Dim ce As System.ComponentModel.Design.ComponentChangingEventArgs

instance.OnComponentChanging(sender, ce)
C#
public void OnComponentChanging(
   System.object sender,
   System.ComponentModel.Design.ComponentChangingEventArgs ce
)
Delphi
public procedure OnComponentChanging(
    sender: System.TObject;
    ce: System.ComponentModel.Design.ComponentChangingEventArgs
);
JScript
public function OnComponentChanging(
   sender : System.Object,
   ce : System.ComponentModel.Design.ComponentChangingEventArgs
);
Managed Extensions for C++
public: void OnComponentChanging(
   System.Object* sender,
   System.ComponentModel.Design.ComponentChangingEventArgs* ce
)
C++/CLI
public:
void OnComponentChanging(
   System.Object^ sender,
   System.ComponentModel.Design.ComponentChangingEventArgs^ ce
)

Parameters

sender
ce

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridDesigner Class
WebGridDesigner Members


OnGridDesigner Method

[image]
Intersoft WebGrid Documentation
OnGridDesigner Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridDesigner Class : OnGridDesigner Method

sender
e

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub OnGridDesigner( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As WebGridDesigner
Dim sender As System.Object
Dim e As System.EventArgs

instance.OnGridDesigner(sender, e)
C#
public void OnGridDesigner(
   System.object sender,
   System.EventArgs e
)
Delphi
public procedure OnGridDesigner(
    sender: System.TObject;
    e: System.EventArgs
);
JScript
public function OnGridDesigner(
   sender : System.Object,
   e : System.EventArgs
);
Managed Extensions for C++
public: void OnGridDesigner(
   System.Object* sender,
   System.EventArgs* e
)
C++/CLI
public:
void OnGridDesigner(
   System.Object^ sender,
   System.EventArgs^ e
)

Parameters

sender
e

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridDesigner Class
WebGridDesigner Members


OnRetrieveHierarchicalStructure Method

[image]
Intersoft WebGrid Documentation
OnRetrieveHierarchicalStructure Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridDesigner Class : OnRetrieveHierarchicalStructure Method

Glossary Item Box

Overload List

Overload | Description
OnRetrieveHierarchicalStructure(Object,EventArgs) |
OnRetrieveHierarchicalStructure(Object,EventArgs,WebGrid) |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridDesigner Class
WebGridDesigner Members


OnRetrieveHierarchicalStructure(Object,EventArgs) Method

[image]
Intersoft WebGrid Documentation
OnRetrieveHierarchicalStructure(Object,EventArgs) Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridDesigner Class > OnRetrieveHierarchicalStructure Method : OnRetrieveHierarchicalStructure(Object,EventArgs) Method

sender
e

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Sub OnRetrieveHierarchicalStructure( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As WebGridDesigner
Dim sender As System.Object
Dim e As System.EventArgs

instance.OnRetrieveHierarchicalStructure(sender, e)
C#
public void OnRetrieveHierarchicalStructure(
   System.object sender,
   System.EventArgs e
)
Delphi
public procedure OnRetrieveHierarchicalStructure(
    sender: System.TObject;
    e: System.EventArgs
);
JScript
public function OnRetrieveHierarchicalStructure(
   sender : System.Object,
   e : System.EventArgs
);
Managed Extensions for C++
public: void OnRetrieveHierarchicalStructure(
   System.Object* sender,
   System.EventArgs* e
)
C++/CLI
public:
void OnRetrieveHierarchicalStructure(
   System.Object^ sender,
   System.EventArgs^ e
)

Parameters

sender
e

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridDesigner Class
WebGridDesigner Members
Overload List


OnRetrieveHierarchicalStructure(Object,EventArgs,WebGrid) Method

[image]
Intersoft WebGrid Documentation
OnRetrieveHierarchicalStructure(Object,EventArgs,WebGrid) Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridDesigner Class > OnRetrieveHierarchicalStructure Method : OnRetrieveHierarchicalStructure(Object,EventArgs,WebGrid) Method

sender
e
grid

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Sub OnRetrieveHierarchicalStructure( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs, _
   ByVal grid As WebGrid _
)
Visual Basic (Usage) Copy Code
Dim instance As WebGridDesigner
Dim sender As System.Object
Dim e As System.EventArgs
Dim grid As WebGrid

instance.OnRetrieveHierarchicalStructure(sender, e, grid)
C#
public void OnRetrieveHierarchicalStructure(
   System.object sender,
   System.EventArgs e,
   WebGrid grid
)
Delphi
public procedure OnRetrieveHierarchicalStructure(
    sender: System.TObject;
    e: System.EventArgs;
    grid: WebGrid
);
JScript
public function OnRetrieveHierarchicalStructure(
   sender : System.Object,
   e : System.EventArgs,
   grid : WebGrid
);
Managed Extensions for C++
public: void OnRetrieveHierarchicalStructure(
   System.Object* sender,
   System.EventArgs* e,
   WebGrid* grid
)
C++/CLI
public:
void OnRetrieveHierarchicalStructure(
   System.Object^ sender,
   System.EventArgs^ e,
   WebGrid^ grid
)

Parameters

sender
e
grid

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridDesigner Class
WebGridDesigner Members
Overload List


OnRetrieveStructure Method

[image]
Intersoft WebGrid Documentation
OnRetrieveStructure Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridDesigner Class : OnRetrieveStructure Method

Glossary Item Box

Overload List

Overload | Description
OnRetrieveStructure(Object,EventArgs) |
OnRetrieveStructure(Object,EventArgs,WebGrid) |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridDesigner Class
WebGridDesigner Members


OnRetrieveStructure(Object,EventArgs) Method

[image]
Intersoft WebGrid Documentation
OnRetrieveStructure(Object,EventArgs) Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridDesigner Class > OnRetrieveStructure Method : OnRetrieveStructure(Object,EventArgs) Method

sender
e

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Sub OnRetrieveStructure( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As WebGridDesigner
Dim sender As System.Object
Dim e As System.EventArgs

instance.OnRetrieveStructure(sender, e)
C#
public void OnRetrieveStructure(
   System.object sender,
   System.EventArgs e
)
Delphi
public procedure OnRetrieveStructure(
    sender: System.TObject;
    e: System.EventArgs
);
JScript
public function OnRetrieveStructure(
   sender : System.Object,
   e : System.EventArgs
);
Managed Extensions for C++
public: void OnRetrieveStructure(
   System.Object* sender,
   System.EventArgs* e
)
C++/CLI
public:
void OnRetrieveStructure(
   System.Object^ sender,
   System.EventArgs^ e
)

Parameters

sender
e

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridDesigner Class
WebGridDesigner Members
Overload List


OnRetrieveStructure(Object,EventArgs,WebGrid) Method

[image]
Intersoft WebGrid Documentation
OnRetrieveStructure(Object,EventArgs,WebGrid) Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridDesigner Class > OnRetrieveStructure Method : OnRetrieveStructure(Object,EventArgs,WebGrid) Method

sender
e
grid

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Sub OnRetrieveStructure( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs, _
   ByVal grid As WebGrid _
)
Visual Basic (Usage) Copy Code
Dim instance As WebGridDesigner
Dim sender As System.Object
Dim e As System.EventArgs
Dim grid As WebGrid

instance.OnRetrieveStructure(sender, e, grid)
C#
public void OnRetrieveStructure(
   System.object sender,
   System.EventArgs e,
   WebGrid grid
)
Delphi
public procedure OnRetrieveStructure(
    sender: System.TObject;
    e: System.EventArgs;
    grid: WebGrid
);
JScript
public function OnRetrieveStructure(
   sender : System.Object,
   e : System.EventArgs,
   grid : WebGrid
);
Managed Extensions for C++
public: void OnRetrieveStructure(
   System.Object* sender,
   System.EventArgs* e,
   WebGrid* grid
)
C++/CLI
public:
void OnRetrieveStructure(
   System.Object^ sender,
   System.EventArgs^ e,
   WebGrid^ grid
)

Parameters

sender
e
grid

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridDesigner Class
WebGridDesigner Members
Overload List


OnSetComponentDefaults Method

[image]
Intersoft WebGrid Documentation
OnSetComponentDefaults Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridDesigner Class : OnSetComponentDefaults Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ObsoleteAttribute("This method has been deprecated. Use InitializeNewComponent instead.  http://go.microsoft.com/fwlink/?linkid=14202")>
Public Sub OnSetComponentDefaults()
Visual Basic (Usage) Copy Code
Dim instance As WebGridDesigner

instance.OnSetComponentDefaults()
C#
[System.ObsoleteAttribute("This method has been deprecated. Use InitializeNewComponent instead.  http://go.microsoft.com/fwlink/?linkid=14202")]
public void OnSetComponentDefaults()
Delphi
public procedure OnSetComponentDefaults();
JScript
System.ObsoleteAttribute("This method has been deprecated. Use InitializeNewComponent instead.  http://go.microsoft.com/fwlink/?linkid=14202")
public function OnSetComponentDefaults();
Managed Extensions for C++
[System.ObsoleteAttribute("This method has been deprecated. Use InitializeNewComponent instead.  http://go.microsoft.com/fwlink/?linkid=14202")]
public: void OnSetComponentDefaults();
C++/CLI
[System.ObsoleteAttribute("This method has been deprecated. Use InitializeNewComponent instead.  http://go.microsoft.com/fwlink/?linkid=14202")]
public:
void OnSetComponentDefaults();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridDesigner Class
WebGridDesigner Members


OnSetParent Method

[image]
Intersoft WebGrid Documentation
OnSetParent Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridDesigner Class : OnSetParent Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub OnSetParent()
Visual Basic (Usage) Copy Code
Dim instance As WebGridDesigner

instance.OnSetParent()
C#
public void OnSetParent()
Delphi
public procedure OnSetParent();
JScript
public function OnSetParent();
Managed Extensions for C++
public: void OnSetParent();
C++/CLI
public:
void OnSetParent();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridDesigner Class
WebGridDesigner Members


RaiseResizeEvent Method

[image]
Intersoft WebGrid Documentation
RaiseResizeEvent Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridDesigner Class : RaiseResizeEvent Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ObsoleteAttribute("Use of this method is not recommended because resizing is handled by the OnComponentChanged() method. http://go.microsoft.com/fwlink/?linkid=14202")>
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")>
Public Sub RaiseResizeEvent()
Visual Basic (Usage) Copy Code
Dim instance As WebGridDesigner

instance.RaiseResizeEvent()
C#
[System.ObsoleteAttribute("Use of this method is not recommended because resizing is handled by the OnComponentChanged() method. http://go.microsoft.com/fwlink/?linkid=14202")]
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public void RaiseResizeEvent()
Delphi
public procedure RaiseResizeEvent();
JScript
System.ObsoleteAttribute("Use of this method is not recommended because resizing is handled by the OnComponentChanged() method. http://go.microsoft.com/fwlink/?linkid=14202")
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")
public function RaiseResizeEvent();
Managed Extensions for C++
[System.ObsoleteAttribute("Use of this method is not recommended because resizing is handled by the OnComponentChanged() method. http://go.microsoft.com/fwlink/?linkid=14202")]
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public: void RaiseResizeEvent();
C++/CLI
[System.ObsoleteAttribute("Use of this method is not recommended because resizing is handled by the OnComponentChanged() method. http://go.microsoft.com/fwlink/?linkid=14202")]
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public:
void RaiseResizeEvent();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridDesigner Class
WebGridDesigner Members


RefreshSchema Method

[image]
Intersoft WebGrid Documentation
RefreshSchema Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridDesigner Class : RefreshSchema Method

preferSilent

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub RefreshSchema( _
   ByVal preferSilent As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebGridDesigner
Dim preferSilent As System.Boolean

instance.RefreshSchema(preferSilent)
C#
public void RefreshSchema(
   System.bool preferSilent
)
Delphi
public procedure RefreshSchema(
    preferSilent: System.Boolean
);
JScript
public function RefreshSchema(
   preferSilent : System.boolean
);
Managed Extensions for C++
public: void RefreshSchema(
   System.bool preferSilent
)
C++/CLI
public:
void RefreshSchema(
   System.bool preferSilent
)

Parameters

preferSilent

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridDesigner Class
WebGridDesigner Members


RegisterClone Method

[image]
Intersoft WebGrid Documentation
RegisterClone Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridDesigner Class : RegisterClone Method

original
clone

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub RegisterClone( _
   ByVal original As System.Object, _
   ByVal clone As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebGridDesigner
Dim original As System.Object
Dim clone As System.Object

instance.RegisterClone(original, clone)
C#
public void RegisterClone(
   System.object original,
   System.object clone
)
Delphi
public procedure RegisterClone(
    original: System.TObject;
    clone: System.TObject
);
JScript
public function RegisterClone(
   original : System.Object,
   clone : System.Object
);
Managed Extensions for C++
public: void RegisterClone(
   System.Object* original,
   System.Object* clone
)
C++/CLI
public:
void RegisterClone(
   System.Object^ original,
   System.Object^ clone
)

Parameters

original
clone

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridDesigner Class
WebGridDesigner Members


RegisterSmartWebResources Method

[image]
Intersoft WebGrid Documentation
RegisterSmartWebResources Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridDesigner Class : RegisterSmartWebResources Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub RegisterSmartWebResources()
Visual Basic (Usage) Copy Code
Dim instance As WebGridDesigner

instance.RegisterSmartWebResources()
C#
public void RegisterSmartWebResources()
Delphi
public procedure RegisterSmartWebResources();
JScript
public function RegisterSmartWebResources();
Managed Extensions for C++
public: void RegisterSmartWebResources();
C++/CLI
public:
void RegisterSmartWebResources();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridDesigner Class
WebGridDesigner Members


ResolveDesignTimeRelativeURL Method

[image]
Intersoft WebGrid Documentation
ResolveDesignTimeRelativeURL Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridDesigner Class : ResolveDesignTimeRelativeURL Method

relativeURL

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function ResolveDesignTimeRelativeURL( _
   ByVal relativeURL As System.String _
) As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebGridDesigner
Dim relativeURL As System.String
Dim value As System.String

value = instance.ResolveDesignTimeRelativeURL(relativeURL)
C#
public System.string ResolveDesignTimeRelativeURL(
   System.string relativeURL
)
Delphi
public function ResolveDesignTimeRelativeURL(
    relativeURL: System.String
): System.String;
JScript
public function ResolveDesignTimeRelativeURL(
   relativeURL : System.String
) : System.String;
Managed Extensions for C++
public: System.string* ResolveDesignTimeRelativeURL(
   System.string* relativeURL
)
C++/CLI
public:
System.String^ ResolveDesignTimeRelativeURL(
   System.String^ relativeURL
)

Parameters

relativeURL

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridDesigner Class
WebGridDesigner Members


SetComponent Method

[image]
Intersoft WebGrid Documentation
SetComponent Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridDesigner Class : SetComponent Method

grid

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SetComponent( _
   ByVal grid As WebGrid _
)
Visual Basic (Usage) Copy Code
Dim instance As WebGridDesigner
Dim grid As WebGrid

instance.SetComponent(grid)
C#
public void SetComponent(
   WebGrid grid
)
Delphi
public procedure SetComponent(
    grid: WebGrid
);
JScript
public function SetComponent(
   grid : WebGrid
);
Managed Extensions for C++
public: void SetComponent(
   WebGrid* grid
)
C++/CLI
public:
void SetComponent(
   WebGrid^ grid
)

Parameters

grid

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridDesigner Class
WebGridDesigner Members


SetDirty Method

[image]
Intersoft WebGrid Documentation
SetDirty Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridDesigner Class : SetDirty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SetDirty()
Visual Basic (Usage) Copy Code
Dim instance As WebGridDesigner

instance.SetDirty()
C#
public void SetDirty()
Delphi
public procedure SetDirty();
JScript
public function SetDirty();
Managed Extensions for C++
public: void SetDirty();
C++/CLI
public:
void SetDirty();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridDesigner Class
WebGridDesigner Members


SetEditableDesignerRegionContent Method

[image]
Intersoft WebGrid Documentation
SetEditableDesignerRegionContent Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridDesigner Class : SetEditableDesignerRegionContent Method

region
content

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SetEditableDesignerRegionContent( _
   ByVal region As System.Web.UI.Design.EditableDesignerRegion, _
   ByVal content As System.String _
)
Visual Basic (Usage) Copy Code
Dim instance As WebGridDesigner
Dim region As System.Web.UI.Design.EditableDesignerRegion
Dim content As System.String

instance.SetEditableDesignerRegionContent(region, content)
C#
public void SetEditableDesignerRegionContent(
   System.Web.UI.Design.EditableDesignerRegion region,
   System.string content
)
Delphi
public procedure SetEditableDesignerRegionContent(
    region: System.Web.UI.Design.EditableDesignerRegion;
    content: System.String
);
JScript
public function SetEditableDesignerRegionContent(
   region : System.Web.UI.Design.EditableDesignerRegion,
   content : System.String
);
Managed Extensions for C++
public: void SetEditableDesignerRegionContent(
   System.Web.UI.Design.EditableDesignerRegion* region,
   System.string* content
)
C++/CLI
public:
void SetEditableDesignerRegionContent(
   System.Web.UI.Design.EditableDesignerRegion^ region,
   System.String^ content
)

Parameters

region
content

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridDesigner Class
WebGridDesigner Members


UpdateDesignTimeHtml Method

[image]
Intersoft WebGrid Documentation
UpdateDesignTimeHtml Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridDesigner Class : UpdateDesignTimeHtml Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub UpdateDesignTimeHtml()
Visual Basic (Usage) Copy Code
Dim instance As WebGridDesigner

instance.UpdateDesignTimeHtml()
C#
public void UpdateDesignTimeHtml()
Delphi
public procedure UpdateDesignTimeHtml();
JScript
public function UpdateDesignTimeHtml();
Managed Extensions for C++
public: void UpdateDesignTimeHtml();
C++/CLI
public:
void UpdateDesignTimeHtml();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridDesigner Class
WebGridDesigner Members


WebGridDesigner Class Properties

[image]
Intersoft WebGrid Documentation
WebGridDesigner Class Properties
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : WebGridDesigner Class

Glossary Item Box

For a list of all members of this type, see WebGridDesigner members.

Public Properties

 | Name | Description
Public Property | ActionLists | Overridden.
Public Property | AllowResize | Overridden.
Public Property | AssociatedComponents | (Inherited from System.ComponentModel.Design.ComponentDesigner)
Public Property | AutoFormats | (Inherited from System.Web.UI.Design.ControlDesigner)
Public Property | Behavior | (Inherited from System.Web.UI.Design.HtmlControlDesigner)
Public Property | CanRefreshSchema | (Inherited from ISNet.WebUI.ISDataBoundDesignerBase)
Public Property | Component | (Inherited from System.ComponentModel.Design.ComponentDesigner)
Public Property | Control | (Inherited from ISNet.WebUI.ISDesignerBase)
Public Property | DataBindings | (Inherited from System.Web.UI.Design.HtmlControlDesigner)
Public Property | DataMember | (Inherited from ISNet.WebUI.ISDataBoundDesignerBase)
Public Property | DataSource | (Inherited from ISNet.WebUI.ISDataBoundDesignerBase)
Public Property | DataSourceDesigner | (Inherited from ISNet.WebUI.ISDataBoundDesignerBase)
Public Property | DataSourceID | (Inherited from ISNet.WebUI.ISDataBoundDesignerBase)
Public Property | DesignerView | (Inherited from ISNet.WebUI.ISDataBoundDesignerBase)
Public Property | DesignTimeHtmlRequiresLoadComplete | (Inherited from System.Web.UI.Design.ControlDesigner)
Public Property | Expressions | (Inherited from System.Web.UI.Design.HtmlControlDesigner)
Public Property | ID | (Inherited from System.Web.UI.Design.ControlDesigner)
Public Property | InitialDialog |
Public Property | IsDirty | (Inherited from System.Web.UI.Design.ControlDesigner)
Public Property | IsStandalone | (Inherited from ISNet.WebUI.ISDesignerBase)
Public Property | PivotChartingChanged |
Public Property | ReadOnly | (Inherited from System.Web.UI.Design.ControlDesigner)
Public Property | Schema | (Inherited from ISNet.WebUI.ISDataBoundDesignerBase)
Public Property | ShouldCodeSerialize | (Inherited from System.Web.UI.Design.HtmlControlDesigner)
Public Property | TemplateGroups | Overridden.
Public Property | Verbs | Overridden.
Public Property | ViewControl | (Inherited from System.Web.UI.Design.ControlDesigner)
Public Property | ViewControlCreated | (Inherited from System.Web.UI.Design.ControlDesigner)
Top

See Also

Reference

WebGridDesigner Class
ISNet.WebUI.WebGrid Namespace


ActionLists Property

[image]
Intersoft WebGrid Documentation
ActionLists Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridDesigner Class : ActionLists Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable ReadOnly Property ActionLists As System.ComponentModel.Design.DesignerActionListCollection
Visual Basic (Usage) Copy Code
Dim instance As WebGridDesigner
Dim value As System.ComponentModel.Design.DesignerActionListCollection

value = instance.ActionLists
C#
public override System.ComponentModel.Design.DesignerActionListCollection ActionLists {get;}
Delphi
public read-only property ActionLists: System.ComponentModel.Design.DesignerActionListCollection; override;
JScript
public override function get ActionLists : System.ComponentModel.Design.DesignerActionListCollection
Managed Extensions for C++
public: __property System.ComponentModel.Design.DesignerActionListCollection* get_ActionLists() override;
C++/CLI
public:
property System.ComponentModel.Design.DesignerActionListCollection^ ActionLists {
   System.ComponentModel.Design.DesignerActionListCollection^ get() override;
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridDesigner Class
WebGridDesigner Members


AllowResize Property

[image]
Intersoft WebGrid Documentation
AllowResize Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridDesigner Class : AllowResize Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable ReadOnly Property AllowResize As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebGridDesigner
Dim value As System.Boolean

value = instance.AllowResize
C#
public override System.bool AllowResize {get;}
Delphi
public read-only property AllowResize: System.Boolean; override;
JScript
public override function get AllowResize : System.boolean
Managed Extensions for C++
public: __property System.bool get_AllowResize() override;
C++/CLI
public:
property System.bool AllowResize {
   System.bool get() override;
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridDesigner Class
WebGridDesigner Members


AssociatedComponents Property

[image]
Intersoft WebGrid Documentation
AssociatedComponents Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridDesigner Class : AssociatedComponents Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property AssociatedComponents As System.Collections.ICollection
Visual Basic (Usage) Copy Code
Dim instance As WebGridDesigner
Dim value As System.Collections.ICollection

value = instance.AssociatedComponents
C#
public System.Collections.ICollection AssociatedComponents {get;}
Delphi
public read-only property AssociatedComponents: System.Collections.ICollection;
JScript
public function get AssociatedComponents : System.Collections.ICollection
Managed Extensions for C++
public: __property System.Collections.ICollection* get_AssociatedComponents();
C++/CLI
public:
property System.Collections.ICollection^ AssociatedComponents {
   System.Collections.ICollection^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridDesigner Class
WebGridDesigner Members


AutoFormats Property

[image]
Intersoft WebGrid Documentation
AutoFormats Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridDesigner Class : AutoFormats Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property AutoFormats As System.Web.UI.Design.DesignerAutoFormatCollection
Visual Basic (Usage) Copy Code
Dim instance As WebGridDesigner
Dim value As System.Web.UI.Design.DesignerAutoFormatCollection

value = instance.AutoFormats
C#
public System.Web.UI.Design.DesignerAutoFormatCollection AutoFormats {get;}
Delphi
public read-only property AutoFormats: System.Web.UI.Design.DesignerAutoFormatCollection;
JScript
public function get AutoFormats : System.Web.UI.Design.DesignerAutoFormatCollection
Managed Extensions for C++
public: __property System.Web.UI.Design.DesignerAutoFormatCollection* get_AutoFormats();
C++/CLI
public:
property System.Web.UI.Design.DesignerAutoFormatCollection^ AutoFormats {
   System.Web.UI.Design.DesignerAutoFormatCollection^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridDesigner Class
WebGridDesigner Members


Behavior Property

[image]
Intersoft WebGrid Documentation
Behavior Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridDesigner Class : Behavior Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ObsoleteAttribute("The recommended alternative is ControlDesigner.Tag. http://go.microsoft.com/fwlink/?linkid=14202")>
Public Property Behavior As System.Web.UI.Design.IHtmlControlDesignerBehavior
Visual Basic (Usage) Copy Code
Dim instance As WebGridDesigner
Dim value As System.Web.UI.Design.IHtmlControlDesignerBehavior

instance.Behavior = value

value = instance.Behavior
C#
[System.ObsoleteAttribute("The recommended alternative is ControlDesigner.Tag. http://go.microsoft.com/fwlink/?linkid=14202")]
public System.Web.UI.Design.IHtmlControlDesignerBehavior Behavior {get; set;}
Delphi
public read-write property Behavior: System.Web.UI.Design.IHtmlControlDesignerBehavior;
JScript
System.ObsoleteAttribute("The recommended alternative is ControlDesigner.Tag. http://go.microsoft.com/fwlink/?linkid=14202")
public function get,set Behavior : System.Web.UI.Design.IHtmlControlDesignerBehavior
Managed Extensions for C++
[System.ObsoleteAttribute("The recommended alternative is ControlDesigner.Tag. http://go.microsoft.com/fwlink/?linkid=14202")]
public: __property System.Web.UI.Design.IHtmlControlDesignerBehavior* get_Behavior();
public: __property void set_Behavior(
   System.Web.UI.Design.IHtmlControlDesignerBehavior* value
);
C++/CLI
[System.ObsoleteAttribute("The recommended alternative is ControlDesigner.Tag. http://go.microsoft.com/fwlink/?linkid=14202")]
public:
property System.Web.UI.Design.IHtmlControlDesignerBehavior^ Behavior {
   System.Web.UI.Design.IHtmlControlDesignerBehavior^ get();
   void set (    System.Web.UI.Design.IHtmlControlDesignerBehavior^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridDesigner Class
WebGridDesigner Members


CanRefreshSchema Property

[image]
Intersoft WebGrid Documentation
CanRefreshSchema Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridDesigner Class : CanRefreshSchema Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property CanRefreshSchema As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebGridDesigner
Dim value As System.Boolean

value = instance.CanRefreshSchema
C#
public System.bool CanRefreshSchema {get;}
Delphi
public read-only property CanRefreshSchema: System.Boolean;
JScript
public function get CanRefreshSchema : System.boolean
Managed Extensions for C++
public: __property System.bool get_CanRefreshSchema();
C++/CLI
public:
property System.bool CanRefreshSchema {
   System.bool get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridDesigner Class
WebGridDesigner Members


Component Property

[image]
Intersoft WebGrid Documentation
Component Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridDesigner Class : Component Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Component As System.ComponentModel.IComponent
Visual Basic (Usage) Copy Code
Dim instance As WebGridDesigner
Dim value As System.ComponentModel.IComponent

value = instance.Component
C#
public System.ComponentModel.IComponent Component {get;}
Delphi
public read-only property Component: System.ComponentModel.IComponent;
JScript
public function get Component : System.ComponentModel.IComponent
Managed Extensions for C++
public: __property System.ComponentModel.IComponent* get_Component();
C++/CLI
public:
property System.ComponentModel.IComponent^ Component {
   System.ComponentModel.IComponent^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridDesigner Class
WebGridDesigner Members


Control Property

[image]
Intersoft WebGrid Documentation
Control Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridDesigner Class : Control Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Control As ISNet.WebUI.ISNetControl
Visual Basic (Usage) Copy Code
Dim instance As WebGridDesigner
Dim value As ISNet.WebUI.ISNetControl

value = instance.Control
C#
public ISNet.WebUI.ISNetControl Control {get;}
Delphi
public read-only property Control: ISNet.WebUI.ISNetControl;
JScript
public function get Control : ISNet.WebUI.ISNetControl
Managed Extensions for C++
public: __property ISNet.WebUI.ISNetControl* get_Control();
C++/CLI
public:
property ISNet.WebUI.ISNetControl^ Control {
   ISNet.WebUI.ISNetControl^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridDesigner Class
WebGridDesigner Members


DataBindings Property

[image]
Intersoft WebGrid Documentation
DataBindings Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridDesigner Class : DataBindings Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property DataBindings As System.Web.UI.DataBindingCollection
Visual Basic (Usage) Copy Code
Dim instance As WebGridDesigner
Dim value As System.Web.UI.DataBindingCollection

value = instance.DataBindings
C#
public System.Web.UI.DataBindingCollection DataBindings {get;}
Delphi
public read-only property DataBindings: System.Web.UI.DataBindingCollection;
JScript
public function get DataBindings : System.Web.UI.DataBindingCollection
Managed Extensions for C++
public: __property System.Web.UI.DataBindingCollection* get_DataBindings();
C++/CLI
public:
property System.Web.UI.DataBindingCollection^ DataBindings {
   System.Web.UI.DataBindingCollection^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridDesigner Class
WebGridDesigner Members


DataMember Property

[image]
Intersoft WebGrid Documentation
DataMember Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridDesigner Class : DataMember Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property DataMember As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebGridDesigner
Dim value As System.String

instance.DataMember = value

value = instance.DataMember
C#
public System.string DataMember {get; set;}
Delphi
public read-write property DataMember: System.String;
JScript
public function get,set DataMember : System.String
Managed Extensions for C++
public: __property System.string* get_DataMember();
public: __property void set_DataMember(
   System.string* value
);
C++/CLI
public:
property System.String^ DataMember {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridDesigner Class
WebGridDesigner Members


DataSource Property

[image]
Intersoft WebGrid Documentation
DataSource Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridDesigner Class : DataSource Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property DataSource As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebGridDesigner
Dim value As System.String

instance.DataSource = value

value = instance.DataSource
C#
public System.string DataSource {get; set;}
Delphi
public read-write property DataSource: System.String;
JScript
public function get,set DataSource : System.String
Managed Extensions for C++
public: __property System.string* get_DataSource();
public: __property void set_DataSource(
   System.string* value
);
C++/CLI
public:
property System.String^ DataSource {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridDesigner Class
WebGridDesigner Members


DataSourceDesigner Property

[image]
Intersoft WebGrid Documentation
DataSourceDesigner Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridDesigner Class : DataSourceDesigner Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property DataSourceDesigner As System.Web.UI.Design.IDataSourceDesigner
Visual Basic (Usage) Copy Code
Dim instance As WebGridDesigner
Dim value As System.Web.UI.Design.IDataSourceDesigner

value = instance.DataSourceDesigner
C#
public System.Web.UI.Design.IDataSourceDesigner DataSourceDesigner {get;}
Delphi
public read-only property DataSourceDesigner: System.Web.UI.Design.IDataSourceDesigner;
JScript
public function get DataSourceDesigner : System.Web.UI.Design.IDataSourceDesigner
Managed Extensions for C++
public: __property System.Web.UI.Design.IDataSourceDesigner* get_DataSourceDesigner();
C++/CLI
public:
property System.Web.UI.Design.IDataSourceDesigner^ DataSourceDesigner {
   System.Web.UI.Design.IDataSourceDesigner^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridDesigner Class
WebGridDesigner Members


DataSourceID Property

[image]
Intersoft WebGrid Documentation
DataSourceID Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridDesigner Class : DataSourceID Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property DataSourceID As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebGridDesigner
Dim value As System.String

instance.DataSourceID = value

value = instance.DataSourceID
C#
public System.string DataSourceID {get; set;}
Delphi
public read-write property DataSourceID: System.String;
JScript
public function get,set DataSourceID : System.String
Managed Extensions for C++
public: __property System.string* get_DataSourceID();
public: __property void set_DataSourceID(
   System.string* value
);
C++/CLI
public:
property System.String^ DataSourceID {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridDesigner Class
WebGridDesigner Members


DesignerView Property

[image]
Intersoft WebGrid Documentation
DesignerView Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridDesigner Class : DesignerView Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property DesignerView As System.Web.UI.Design.DesignerDataSourceView
Visual Basic (Usage) Copy Code
Dim instance As WebGridDesigner
Dim value As System.Web.UI.Design.DesignerDataSourceView

value = instance.DesignerView
C#
public System.Web.UI.Design.DesignerDataSourceView DesignerView {get;}
Delphi
public read-only property DesignerView: System.Web.UI.Design.DesignerDataSourceView;
JScript
public function get DesignerView : System.Web.UI.Design.DesignerDataSourceView
Managed Extensions for C++
public: __property System.Web.UI.Design.DesignerDataSourceView* get_DesignerView();
C++/CLI
public:
property System.Web.UI.Design.DesignerDataSourceView^ DesignerView {
   System.Web.UI.Design.DesignerDataSourceView^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridDesigner Class
WebGridDesigner Members


DesignTimeHtmlRequiresLoadComplete Property

[image]
Intersoft WebGrid Documentation
DesignTimeHtmlRequiresLoadComplete Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridDesigner Class : DesignTimeHtmlRequiresLoadComplete Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ObsoleteAttribute("The recommended alternative is SetViewFlags(ViewFlags.DesignTimeHtmlRequiresLoadComplete, true). http://go.microsoft.com/fwlink/?linkid=14202")>
Public ReadOnly Property DesignTimeHtmlRequiresLoadComplete As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebGridDesigner
Dim value As System.Boolean

value = instance.DesignTimeHtmlRequiresLoadComplete
C#
[System.ObsoleteAttribute("The recommended alternative is SetViewFlags(ViewFlags.DesignTimeHtmlRequiresLoadComplete, true). http://go.microsoft.com/fwlink/?linkid=14202")]
public System.bool DesignTimeHtmlRequiresLoadComplete {get;}
Delphi
public read-only property DesignTimeHtmlRequiresLoadComplete: System.Boolean;
JScript
System.ObsoleteAttribute("The recommended alternative is SetViewFlags(ViewFlags.DesignTimeHtmlRequiresLoadComplete, true). http://go.microsoft.com/fwlink/?linkid=14202")
public function get DesignTimeHtmlRequiresLoadComplete : System.boolean
Managed Extensions for C++
[System.ObsoleteAttribute("The recommended alternative is SetViewFlags(ViewFlags.DesignTimeHtmlRequiresLoadComplete, true). http://go.microsoft.com/fwlink/?linkid=14202")]
public: __property System.bool get_DesignTimeHtmlRequiresLoadComplete();
C++/CLI
[System.ObsoleteAttribute("The recommended alternative is SetViewFlags(ViewFlags.DesignTimeHtmlRequiresLoadComplete, true). http://go.microsoft.com/fwlink/?linkid=14202")]
public:
property System.bool DesignTimeHtmlRequiresLoadComplete {
   System.bool get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridDesigner Class
WebGridDesigner Members


Expressions Property

[image]
Intersoft WebGrid Documentation
Expressions Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridDesigner Class : Expressions Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Expressions As System.Web.UI.ExpressionBindingCollection
Visual Basic (Usage) Copy Code
Dim instance As WebGridDesigner
Dim value As System.Web.UI.ExpressionBindingCollection

value = instance.Expressions
C#
public System.Web.UI.ExpressionBindingCollection Expressions {get;}
Delphi
public read-only property Expressions: System.Web.UI.ExpressionBindingCollection;
JScript
public function get Expressions : System.Web.UI.ExpressionBindingCollection
Managed Extensions for C++
public: __property System.Web.UI.ExpressionBindingCollection* get_Expressions();
C++/CLI
public:
property System.Web.UI.ExpressionBindingCollection^ Expressions {
   System.Web.UI.ExpressionBindingCollection^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridDesigner Class
WebGridDesigner Members


ID Property

[image]
Intersoft WebGrid Documentation
ID Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridDesigner Class : ID Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property ID As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebGridDesigner
Dim value As System.String

instance.ID = value

value = instance.ID
C#
public System.string ID {get; set;}
Delphi
public read-write property ID: System.String;
JScript
public function get,set ID : System.String
Managed Extensions for C++
public: __property System.string* get_ID();
public: __property void set_ID(
   System.string* value
);
C++/CLI
public:
property System.String^ ID {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridDesigner Class
WebGridDesigner Members


InitialDialog Property

[image]
Intersoft WebGrid Documentation
InitialDialog Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridDesigner Class : InitialDialog Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property InitialDialog As WebGridDesigner.DialogType
Visual Basic (Usage) Copy Code
Dim instance As WebGridDesigner
Dim value As WebGridDesigner.DialogType

instance.InitialDialog = value

value = instance.InitialDialog
C#
public WebGridDesigner.DialogType InitialDialog {get; set;}
Delphi
public read-write property InitialDialog: WebGridDesigner.DialogType;
JScript
public function get,set InitialDialog : WebGridDesigner.DialogType
Managed Extensions for C++
public: __property WebGridDesigner.DialogType get_InitialDialog();
public: __property void set_InitialDialog(
   WebGridDesigner.DialogType value
);
C++/CLI
public:
property WebGridDesigner.DialogType InitialDialog {
   WebGridDesigner.DialogType get();
   void set (    WebGridDesigner.DialogType value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridDesigner Class
WebGridDesigner Members


IsDirty Property

[image]
Intersoft WebGrid Documentation
IsDirty Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridDesigner Class : IsDirty Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ObsoleteAttribute("The recommended alternative is to use Tag.SetDirty() and Tag.IsDirty. http://go.microsoft.com/fwlink/?linkid=14202")>
Public Property IsDirty As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebGridDesigner
Dim value As System.Boolean

instance.IsDirty = value

value = instance.IsDirty
C#
[System.ObsoleteAttribute("The recommended alternative is to use Tag.SetDirty() and Tag.IsDirty. http://go.microsoft.com/fwlink/?linkid=14202")]
public System.bool IsDirty {get; set;}
Delphi
public read-write property IsDirty: System.Boolean;
JScript
System.ObsoleteAttribute("The recommended alternative is to use Tag.SetDirty() and Tag.IsDirty. http://go.microsoft.com/fwlink/?linkid=14202")
public function get,set IsDirty : System.boolean
Managed Extensions for C++
[System.ObsoleteAttribute("The recommended alternative is to use Tag.SetDirty() and Tag.IsDirty. http://go.microsoft.com/fwlink/?linkid=14202")]
public: __property System.bool get_IsDirty();
public: __property void set_IsDirty(
   System.bool value
);
C++/CLI
[System.ObsoleteAttribute("The recommended alternative is to use Tag.SetDirty() and Tag.IsDirty. http://go.microsoft.com/fwlink/?linkid=14202")]
public:
property System.bool IsDirty {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridDesigner Class
WebGridDesigner Members


IsStandalone Property

[image]
Intersoft WebGrid Documentation
IsStandalone Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridDesigner Class : IsStandalone Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property IsStandalone As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebGridDesigner
Dim value As System.Boolean

instance.IsStandalone = value

value = instance.IsStandalone
C#
public System.bool IsStandalone {get; set;}
Delphi
public read-write property IsStandalone: System.Boolean;
JScript
public function get,set IsStandalone : System.boolean
Managed Extensions for C++
public: __property System.bool get_IsStandalone();
public: __property void set_IsStandalone(
   System.bool value
);
C++/CLI
public:
property System.bool IsStandalone {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridDesigner Class
WebGridDesigner Members


PivotChartingChanged Property

[image]
Intersoft WebGrid Documentation
PivotChartingChanged Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridDesigner Class : PivotChartingChanged Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property PivotChartingChanged As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebGridDesigner
Dim value As System.Boolean

instance.PivotChartingChanged = value

value = instance.PivotChartingChanged
C#
public System.bool PivotChartingChanged {get; set;}
Delphi
public read-write property PivotChartingChanged: System.Boolean;
JScript
public function get,set PivotChartingChanged : System.boolean
Managed Extensions for C++
public: __property System.bool get_PivotChartingChanged();
public: __property void set_PivotChartingChanged(
   System.bool value
);
C++/CLI
public:
property System.bool PivotChartingChanged {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridDesigner Class
WebGridDesigner Members


ReadOnly Property

[image]
Intersoft WebGrid Documentation
ReadOnly Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridDesigner Class : ReadOnly Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ObsoleteAttribute("The recommended alternative is to inherit from ContainerControlDesigner instead and to use an EditableDesignerRegion. Regions allow for better control of the content in the designer. http://go.microsoft.com/fwlink/?linkid=14202")>
Public Property ReadOnly As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebGridDesigner
Dim value As System.Boolean

instance.ReadOnly = value

value = instance.ReadOnly
C#
[System.ObsoleteAttribute("The recommended alternative is to inherit from ContainerControlDesigner instead and to use an EditableDesignerRegion. Regions allow for better control of the content in the designer. http://go.microsoft.com/fwlink/?linkid=14202")]
public System.bool ReadOnly {get; set;}
Delphi
public read-write property ReadOnly: System.Boolean;
JScript
System.ObsoleteAttribute("The recommended alternative is to inherit from ContainerControlDesigner instead and to use an EditableDesignerRegion. Regions allow for better control of the content in the designer. http://go.microsoft.com/fwlink/?linkid=14202")
public function get,set ReadOnly : System.boolean
Managed Extensions for C++
[System.ObsoleteAttribute("The recommended alternative is to inherit from ContainerControlDesigner instead and to use an EditableDesignerRegion. Regions allow for better control of the content in the designer. http://go.microsoft.com/fwlink/?linkid=14202")]
public: __property System.bool get_ReadOnly();
public: __property void set_ReadOnly(
   System.bool value
);
C++/CLI
[System.ObsoleteAttribute("The recommended alternative is to inherit from ContainerControlDesigner instead and to use an EditableDesignerRegion. Regions allow for better control of the content in the designer. http://go.microsoft.com/fwlink/?linkid=14202")]
public:
property System.bool ReadOnly {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridDesigner Class
WebGridDesigner Members


Schema Property

[image]
Intersoft WebGrid Documentation
Schema Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridDesigner Class : Schema Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Schema As System.Web.UI.Design.IDataSourceViewSchema
Visual Basic (Usage) Copy Code
Dim instance As WebGridDesigner
Dim value As System.Web.UI.Design.IDataSourceViewSchema

value = instance.Schema
C#
public System.Web.UI.Design.IDataSourceViewSchema Schema {get;}
Delphi
public read-only property Schema: System.Web.UI.Design.IDataSourceViewSchema;
JScript
public function get Schema : System.Web.UI.Design.IDataSourceViewSchema
Managed Extensions for C++
public: __property System.Web.UI.Design.IDataSourceViewSchema* get_Schema();
C++/CLI
public:
property System.Web.UI.Design.IDataSourceViewSchema^ Schema {
   System.Web.UI.Design.IDataSourceViewSchema^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridDesigner Class
WebGridDesigner Members


ShouldCodeSerialize Property

[image]
Intersoft WebGrid Documentation
ShouldCodeSerialize Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridDesigner Class : ShouldCodeSerialize Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ObsoleteAttribute("Use of this property is not recommended because code serialization is not supported. http://go.microsoft.com/fwlink/?linkid=14202")>
Public Property ShouldCodeSerialize As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebGridDesigner
Dim value As System.Boolean

instance.ShouldCodeSerialize = value

value = instance.ShouldCodeSerialize
C#
[System.ObsoleteAttribute("Use of this property is not recommended because code serialization is not supported. http://go.microsoft.com/fwlink/?linkid=14202")]
public System.bool ShouldCodeSerialize {get; set;}
Delphi
public read-write property ShouldCodeSerialize: System.Boolean;
JScript
System.ObsoleteAttribute("Use of this property is not recommended because code serialization is not supported. http://go.microsoft.com/fwlink/?linkid=14202")
public function get,set ShouldCodeSerialize : System.boolean
Managed Extensions for C++
[System.ObsoleteAttribute("Use of this property is not recommended because code serialization is not supported. http://go.microsoft.com/fwlink/?linkid=14202")]
public: __property System.bool get_ShouldCodeSerialize();
public: __property void set_ShouldCodeSerialize(
   System.bool value
);
C++/CLI
[System.ObsoleteAttribute("Use of this property is not recommended because code serialization is not supported. http://go.microsoft.com/fwlink/?linkid=14202")]
public:
property System.bool ShouldCodeSerialize {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridDesigner Class
WebGridDesigner Members


TemplateGroups Property

[image]
Intersoft WebGrid Documentation
TemplateGroups Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridDesigner Class : TemplateGroups Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable ReadOnly Property TemplateGroups As System.Web.UI.Design.TemplateGroupCollection
Visual Basic (Usage) Copy Code
Dim instance As WebGridDesigner
Dim value As System.Web.UI.Design.TemplateGroupCollection

value = instance.TemplateGroups
C#
public override System.Web.UI.Design.TemplateGroupCollection TemplateGroups {get;}
Delphi
public read-only property TemplateGroups: System.Web.UI.Design.TemplateGroupCollection; override;
JScript
public override function get TemplateGroups : System.Web.UI.Design.TemplateGroupCollection
Managed Extensions for C++
public: __property System.Web.UI.Design.TemplateGroupCollection* get_TemplateGroups() override;
C++/CLI
public:
property System.Web.UI.Design.TemplateGroupCollection^ TemplateGroups {
   System.Web.UI.Design.TemplateGroupCollection^ get() override;
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridDesigner Class
WebGridDesigner Members


Verbs Property

[image]
Intersoft WebGrid Documentation
Verbs Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridDesigner Class : Verbs Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable ReadOnly Property Verbs As System.ComponentModel.Design.DesignerVerbCollection
Visual Basic (Usage) Copy Code
Dim instance As WebGridDesigner
Dim value As System.ComponentModel.Design.DesignerVerbCollection

value = instance.Verbs
C#
public override System.ComponentModel.Design.DesignerVerbCollection Verbs {get;}
Delphi
public read-only property Verbs: System.ComponentModel.Design.DesignerVerbCollection; override;
JScript
public override function get Verbs : System.ComponentModel.Design.DesignerVerbCollection
Managed Extensions for C++
public: __property System.ComponentModel.Design.DesignerVerbCollection* get_Verbs() override;
C++/CLI
public:
property System.ComponentModel.Design.DesignerVerbCollection^ Verbs {
   System.ComponentModel.Design.DesignerVerbCollection^ get() override;
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridDesigner Class
WebGridDesigner Members


ViewControl Property

[image]
Intersoft WebGrid Documentation
ViewControl Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridDesigner Class : ViewControl Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property ViewControl As System.Web.UI.Control
Visual Basic (Usage) Copy Code
Dim instance As WebGridDesigner
Dim value As System.Web.UI.Control

instance.ViewControl = value

value = instance.ViewControl
C#
public System.Web.UI.Control ViewControl {get; set;}
Delphi
public read-write property ViewControl: System.Web.UI.Control;
JScript
public function get,set ViewControl : System.Web.UI.Control
Managed Extensions for C++
public: __property System.Web.UI.Control* get_ViewControl();
public: __property void set_ViewControl(
   System.Web.UI.Control* value
);
C++/CLI
public:
property System.Web.UI.Control^ ViewControl {
   System.Web.UI.Control^ get();
   void set (    System.Web.UI.Control^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridDesigner Class
WebGridDesigner Members


ViewControlCreated Property

[image]
Intersoft WebGrid Documentation
ViewControlCreated Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridDesigner Class : ViewControlCreated Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property ViewControlCreated As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebGridDesigner
Dim value As System.Boolean

instance.ViewControlCreated = value

value = instance.ViewControlCreated
C#
public System.bool ViewControlCreated {get; set;}
Delphi
public read-write property ViewControlCreated: System.Boolean;
JScript
public function get,set ViewControlCreated : System.boolean
Managed Extensions for C++
public: __property System.bool get_ViewControlCreated();
public: __property void set_ViewControlCreated(
   System.bool value
);
C++/CLI
public:
property System.bool ViewControlCreated {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridDesigner Class
WebGridDesigner Members


WebGridFilter Class

[image]
Intersoft WebGrid Documentation
WebGridFilter Class
Members See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : WebGridFilter Class

Glossary Item Box

Object Model

WebGridFilter Class

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute()>
<System.SerializableAttribute()>
Public Class WebGridFilter
   Inherits WebGridGroup
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject
Visual Basic (Usage) Copy Code
Dim instance As WebGridFilter
C#
[System.ComponentModel.DescriptionAttribute()]
[System.SerializableAttribute()]
public class WebGridFilter : WebGridGroup, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject
Delphi
public class WebGridFilter = class(WebGridGroup, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject)
JScript
System.ComponentModel.DescriptionAttribute()
System.SerializableAttribute()
public class WebGridFilter extends WebGridGroup implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute()]
[System.SerializableAttribute()]
public __gc class WebGridFilter : public WebGridGroup, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject
C++/CLI
[System.ComponentModel.DescriptionAttribute()]
[System.SerializableAttribute()]
public ref class WebGridFilter : public WebGridGroup, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.NamedObjectBase
ISNet.WebUI.WebGrid.WebGridGroup
ISNet.WebUI.WebGrid.WebGridFilter

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridFilter Members
ISNet.WebUI.WebGrid Namespace


WebGridFilter Class Members

[image]
Intersoft WebGrid Documentation
WebGridFilter Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebGrid Namespace : WebGridFilter Class

Glossary Item Box

The following tables list the members exposed by WebGridFilter.

Public Constructors

 | Name | Description
Public Constructor | WebGridFilter Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | AdvancedFilterExpression |
Public Property | AdvancedFilterKey |
Public Property | CaseSensitive | (Inherited from ISNet.WebUI.WebGrid.WebGridGroup)
Public Property | ColumnMember | (Inherited from ISNet.WebUI.WebGrid.WebGridGroup)
Public Property | FilterText |
Public Property | FilterType |
Public Property | UseAdvancedFilter |
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebGrid.WebGridGroup)
Top

See Also

Reference

WebGridFilter Class
ISNet.WebUI.WebGrid Namespace


WebGridFilter Constructor

[image]
Intersoft WebGrid Documentation
WebGridFilter Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridFilter Class : WebGridFilter Constructor

Glossary Item Box

Overload List

Overload | Description
WebGridFilter Constructor() |
WebGridFilter Constructor(String,ColumnFilterType,String) |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridFilter Class
WebGridFilter Members


WebGridFilter Constructor()

[image]
Intersoft WebGrid Documentation
WebGridFilter Constructor()
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridFilter Class > WebGridFilter Constructor : WebGridFilter Constructor()

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebGridFilter()
C#
public WebGridFilter()
Delphi
public WebGridFilter();
JScript
public function WebGridFilter();
Managed Extensions for C++
public: WebGridFilter();
C++/CLI
public:
WebGridFilter();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridFilter Class
WebGridFilter Members
Overload List


WebGridFilter Constructor(String,ColumnFilterType,String)

[image]
Intersoft WebGrid Documentation
WebGridFilter Constructor(String,ColumnFilterType,String)
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridFilter Class > WebGridFilter Constructor : WebGridFilter Constructor(String,ColumnFilterType,String)

columnMember
filterType
filterText

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal columnMember As System.String, _
   ByVal filterType As ColumnFilterType, _
   ByVal filterText As System.String _
)
Visual Basic (Usage) Copy Code
Dim columnMember As System.String
Dim filterType As ColumnFilterType
Dim filterText As System.String

Dim instance As New WebGridFilter(columnMember, filterType, filterText)
C#
public WebGridFilter(
   System.string columnMember,
   ColumnFilterType filterType,
   System.string filterText
)
Delphi
public WebGridFilter(
    columnMember: System.String;
    filterType: ColumnFilterType;
    filterText: System.String
);
JScript
public function WebGridFilter(
   columnMember : System.String,
   filterType : ColumnFilterType,
   filterText : System.String
);
Managed Extensions for C++
public: WebGridFilter(
   System.string* columnMember,
   ColumnFilterType filterType,
   System.string* filterText
)
C++/CLI
public:
WebGridFilter(
   System.String^ columnMember,
   ColumnFilterType filterType,
   System.String^ filterText
)

Parameters

columnMember
filterType
filterText

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridFilter Class
WebGridFilter Members
Overload List


Clone Method

[image]
Intersoft WebGrid Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridFilter Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As System.Object
Visual Basic (Usage) Copy Code
Dim instance As WebGridFilter
Dim value As System.Object

value = instance.Clone()
C#
public virtual System.object Clone()
Delphi
public function Clone(): System.TObject; virtual;
JScript
public function Clone() : System.Object;
Managed Extensions for C++
public: virtual System.Object* Clone();
C++/CLI
public:
virtual System.Object^ Clone();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridFilter Class
WebGridFilter Members


CopyFrom Method

[image]
Intersoft WebGrid Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridFilter Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridFilter Class
WebGridFilter Members


CopyFrom(Object) Method

[image]
Intersoft WebGrid Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridFilter Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebGridFilter
Dim objSource As System.Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   System.object objSource
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridFilter Class
WebGridFilter Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebGrid Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridFilter Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object, _
   ByVal cloneSourceValue As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebGridFilter
Dim objSource As System.Object
Dim cloneSourceValue As System.Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   System.object objSource,
   System.bool cloneSourceValue
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject;
    cloneSourceValue: System.Boolean
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object,
   cloneSourceValue : System.boolean
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource,
   System.bool cloneSourceValue
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource,
   System.bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridFilter Class
WebGridFilter Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebGrid Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridFilter Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebGridFilter
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure DeSerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function DeSerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void DeSerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void DeSerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridFilter Class
WebGridFilter Members


GetHashCode Method

[image]
Intersoft WebGrid Documentation
GetHashCode Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridFilter Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebGridFilter
Dim value As System.Integer

value = instance.GetHashCode()
C#
public virtual System.int GetHashCode()
Delphi
public function GetHashCode(): System.Integer; virtual;
JScript
public function GetHashCode() : System.int;
Managed Extensions for C++
public: virtual System.int GetHashCode();
C++/CLI
public:
virtual System.int GetHashCode();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridFilter Class
WebGridFilter Members


WebGridFilter Class Methods

[image]
Intersoft WebGrid Documentation
WebGridFilter Class Methods
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : WebGridFilter Class

Glossary Item Box

For a list of all members of this type, see WebGridFilter members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebGrid.WebGridGroup)
Top

See Also

Reference

WebGridFilter Class
ISNet.WebUI.WebGrid Namespace


GetObjectData Method

[image]
Intersoft WebGrid Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridFilter Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebGridFilter
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure GetObjectData(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
); override;
JScript
public override function GetObjectData(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void GetObjectData(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
) override
C++/CLI
public:
void GetObjectData(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
) override

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridFilter Class
WebGridFilter Members


IsEmpty Method

[image]
Intersoft WebGrid Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridFilter Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebGridFilter
Dim value As System.Boolean

value = instance.IsEmpty()
C#
public virtual System.bool IsEmpty()
Delphi
public function IsEmpty(): System.Boolean; virtual;
JScript
public function IsEmpty() : System.boolean;
Managed Extensions for C++
public: virtual System.bool IsEmpty();
C++/CLI
public:
virtual System.bool IsEmpty();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridFilter Class
WebGridFilter Members


Reset Method

[image]
Intersoft WebGrid Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridFilter Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As WebGridFilter

instance.Reset()
C#
public virtual void Reset()
Delphi
public procedure Reset(); virtual;
JScript
public function Reset();
Managed Extensions for C++
public: virtual void Reset();
C++/CLI
public:
virtual void Reset();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridFilter Class
WebGridFilter Members


SerializeObjectData Method

[image]
Intersoft WebGrid Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridFilter Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebGridFilter
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure SerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function SerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void SerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void SerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridFilter Class
WebGridFilter Members


WebGridFilter Class Properties

[image]
Intersoft WebGrid Documentation
WebGridFilter Class Properties
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : WebGridFilter Class

Glossary Item Box

For a list of all members of this type, see WebGridFilter members.

Public Properties

 | Name | Description
Public Property | AdvancedFilterExpression |
Public Property | AdvancedFilterKey |
Public Property | CaseSensitive | (Inherited from ISNet.WebUI.WebGrid.WebGridGroup)
Public Property | ColumnMember | (Inherited from ISNet.WebUI.WebGrid.WebGridGroup)
Public Property | FilterText |
Public Property | FilterType |
Public Property | UseAdvancedFilter |
Top

See Also

Reference

WebGridFilter Class
ISNet.WebUI.WebGrid Namespace


AdvancedFilterExpression Property

[image]
Intersoft WebGrid Documentation
AdvancedFilterExpression Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridFilter Class : AdvancedFilterExpression Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies the advanced filter expression that compatible with ADO.NET Expression.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Property AdvancedFilterExpression As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebGridFilter
Dim value As System.String

instance.AdvancedFilterExpression = value

value = instance.AdvancedFilterExpression
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the advanced filter expression that compatible with ADO.NET Expression.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public System.string AdvancedFilterExpression {get; set;}
Delphi
public read-write property AdvancedFilterExpression: System.String;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the advanced filter expression that compatible with ADO.NET Expression.")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute()
public function get,set AdvancedFilterExpression : System.String
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the advanced filter expression that compatible with ADO.NET Expression.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property System.string* get_AdvancedFilterExpression();
public: __property void set_AdvancedFilterExpression(
   System.string* value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the advanced filter expression that compatible with ADO.NET Expression.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property System.String^ AdvancedFilterExpression {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridFilter Class
WebGridFilter Members


AdvancedFilterKey Property

[image]
Intersoft WebGrid Documentation
AdvancedFilterKey Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridFilter Class : AdvancedFilterKey Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies the unique key associated with the advanced expression.")>
Public Property AdvancedFilterKey As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebGridFilter
Dim value As System.String

instance.AdvancedFilterKey = value

value = instance.AdvancedFilterKey
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the unique key associated with the advanced expression.")]
public System.string AdvancedFilterKey {get; set;}
Delphi
public read-write property AdvancedFilterKey: System.String;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the unique key associated with the advanced expression.")
public function get,set AdvancedFilterKey : System.String
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the unique key associated with the advanced expression.")]
public: __property System.string* get_AdvancedFilterKey();
public: __property void set_AdvancedFilterKey(
   System.string* value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the unique key associated with the advanced expression.")]
public:
property System.String^ AdvancedFilterKey {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridFilter Class
WebGridFilter Members


FilterText Property

[image]
Intersoft WebGrid Documentation
FilterText Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridFilter Class : FilterText Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.Xml.Serialization.XmlTextAttribute(System.String)>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Gets or sets the filter text used to filter data row for specified column member.")>
Public Property FilterText As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebGridFilter
Dim value As System.String

instance.FilterText = value

value = instance.FilterText
C#
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Xml.Serialization.XmlTextAttribute(System.String)]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the filter text used to filter data row for specified column member.")]
public System.string FilterText {get; set;}
Delphi
public read-write property FilterText: System.String;
JScript
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.Xml.Serialization.XmlTextAttribute(System.String)
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the filter text used to filter data row for specified column member.")
public function get,set FilterText : System.String
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Xml.Serialization.XmlTextAttribute(System.String)]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the filter text used to filter data row for specified column member.")]
public: __property System.string* get_FilterText();
public: __property void set_FilterText(
   System.string* value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Xml.Serialization.XmlTextAttribute(System.String)]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the filter text used to filter data row for specified column member.")]
public:
property System.String^ FilterText {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridFilter Class
WebGridFilter Members


FilterType Property

[image]
Intersoft WebGrid Documentation
FilterType Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridFilter Class : FilterType Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Gets or sets the Filter type for the column")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
Public Property FilterType As ColumnFilterType
Visual Basic (Usage) Copy Code
Dim instance As WebGridFilter
Dim value As ColumnFilterType

instance.FilterType = value

value = instance.FilterType
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the Filter type for the column")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public ColumnFilterType FilterType {get; set;}
Delphi
public read-write property FilterType: ColumnFilterType;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the Filter type for the column")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
public function get,set FilterType : ColumnFilterType
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the Filter type for the column")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public: __property ColumnFilterType get_FilterType();
public: __property void set_FilterType(
   ColumnFilterType value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the Filter type for the column")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public:
property ColumnFilterType FilterType {
   ColumnFilterType get();
   void set (    ColumnFilterType value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridFilter Class
WebGridFilter Members


UseAdvancedFilter Property

[image]
Intersoft WebGrid Documentation
UseAdvancedFilter Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridFilter Class : UseAdvancedFilter Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Gets or sets a value indicating whether the column filter should use the advanced expression.")>
Public Property UseAdvancedFilter As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebGridFilter
Dim value As System.Boolean

instance.UseAdvancedFilter = value

value = instance.UseAdvancedFilter
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets a value indicating whether the column filter should use the advanced expression.")]
public System.bool UseAdvancedFilter {get; set;}
Delphi
public read-write property UseAdvancedFilter: System.Boolean;
JScript
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets a value indicating whether the column filter should use the advanced expression.")
public function get,set UseAdvancedFilter : System.boolean
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets a value indicating whether the column filter should use the advanced expression.")]
public: __property System.bool get_UseAdvancedFilter();
public: __property void set_UseAdvancedFilter(
   System.bool value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets a value indicating whether the column filter should use the advanced expression.")]
public:
property System.bool UseAdvancedFilter {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridFilter Class
WebGridFilter Members


WebGridFilterCollection Class

[image]
Intersoft WebGrid Documentation
WebGridFilterCollection Class
Members See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : WebGridFilterCollection Class

Glossary Item Box

Object Model

WebGridFilterCollection Class

Syntax

Visual Basic (Declaration)
<System.Reflection.DefaultMemberAttribute("Item")>
<System.SerializableAttribute()>
Public Class WebGridFilterCollection
   Inherits ISNet.WebUI.ISCollectionBase
Visual Basic (Usage) Copy Code
Dim instance As WebGridFilterCollection
C#
[System.Reflection.DefaultMemberAttribute("Item")]
[System.SerializableAttribute()]
public class WebGridFilterCollection : ISNet.WebUI.ISCollectionBase
Delphi
public class WebGridFilterCollection = class(ISNet.WebUI.ISCollectionBase)
JScript
System.Reflection.DefaultMemberAttribute("Item")
System.SerializableAttribute()
public class WebGridFilterCollection extends ISNet.WebUI.ISCollectionBase
Managed Extensions for C++
[System.Reflection.DefaultMemberAttribute("Item")]
[System.SerializableAttribute()]
public __gc class WebGridFilterCollection : public ISNet.WebUI.ISCollectionBase
C++/CLI
[System.Reflection.DefaultMemberAttribute("Item")]
[System.SerializableAttribute()]
public ref class WebGridFilterCollection : public ISNet.WebUI.ISCollectionBase

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
ISNet.WebUI.ISCollectionBase
ISNet.WebUI.WebGrid.WebGridFilterCollection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridFilterCollection Members
ISNet.WebUI.WebGrid Namespace


WebGridFilterCollection Class Members

[image]
Intersoft WebGrid Documentation
WebGridFilterCollection Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebGrid Namespace : WebGridFilterCollection Class

Glossary Item Box

The following tables list the members exposed by WebGridFilterCollection.

Public Constructors

 | Name | Description
Public Constructor | WebGridFilterCollection Constructor |
Top

Public Properties

 | Name | Description
Public Property | AdvancedFilterExpression |
Public Property | Capacity | (Inherited from System.Collections.CollectionBase)
Public Property | Count | (Inherited from System.Collections.CollectionBase)
Public Property | IsReadOnly | Overridden.
Public Property | Item |
Public Property | Parent | (Inherited from ISNet.WebUI.ISCollectionBase)
Top

Public Methods

 | Name | Description
Public Method | Add | Overloaded.
Public Method | Clear |
Public Method | Contains | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | CopyFrom |
Public Method | CopyTo | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | Exists | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | GetEnumerator |
Public Method | GetFilterExpression |
Public Method | GetItem | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | GetLinqFilterExpression |
Public Method | GetNamedItem |
Public Method | IndexOf | Overloaded. (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | Insert |
Public Method | IntInsert | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | Remove |
Public Method | setParent | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | SortByIndex |
Top

See Also

Reference

WebGridFilterCollection Class
ISNet.WebUI.WebGrid Namespace


WebGridFilterCollection Constructor

[image]
Intersoft WebGrid Documentation
WebGridFilterCollection Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridFilterCollection Class : WebGridFilterCollection Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebGridFilterCollection()
C#
public WebGridFilterCollection()
Delphi
public WebGridFilterCollection();
JScript
public function WebGridFilterCollection();
Managed Extensions for C++
public: WebGridFilterCollection();
C++/CLI
public:
WebGridFilterCollection();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridFilterCollection Class
WebGridFilterCollection Members


WebGridFilterCollection Class Methods

[image]
Intersoft WebGrid Documentation
WebGridFilterCollection Class Methods
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : WebGridFilterCollection Class

Glossary Item Box

For a list of all members of this type, see WebGridFilterCollection members.

Public Methods

 | Name | Description
Public Method | Add | Overloaded.
Public Method | Clear |
Public Method | Contains | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | CopyFrom |
Public Method | CopyTo | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | Exists | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | GetEnumerator |
Public Method | GetFilterExpression |
Public Method | GetItem | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | GetLinqFilterExpression |
Public Method | GetNamedItem |
Public Method | IndexOf | Overloaded. (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | Insert |
Public Method | IntInsert | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | Remove |
Public Method | setParent | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | SortByIndex |
Top

See Also

Reference

WebGridFilterCollection Class
ISNet.WebUI.WebGrid Namespace


Add Method

[image]
Intersoft WebGrid Documentation
Add Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridFilterCollection Class : Add Method

Glossary Item Box

Overload List

Overload | Description
Add(WebGridFilter) |
Add(String) |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridFilterCollection Class
WebGridFilterCollection Members


Add(WebGridFilter) Method

[image]
Intersoft WebGrid Documentation
Add(WebGridFilter) Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridFilterCollection Class > Add Method : Add(WebGridFilter) Method

WebGridFilter

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function Add( _
   ByVal WebGridFilter As WebGridFilter _
) As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebGridFilterCollection
Dim WebGridFilter As WebGridFilter
Dim value As System.Integer

value = instance.Add(WebGridFilter)
C#
public virtual System.int Add(
   WebGridFilter WebGridFilter
)
Delphi
public function Add(
    WebGridFilter: WebGridFilter
): System.Integer; virtual;
JScript
public function Add(
   WebGridFilter : WebGridFilter
) : System.int;
Managed Extensions for C++
public: virtual System.int Add(
   WebGridFilter* WebGridFilter
)
C++/CLI
public:
virtual System.int Add(
   WebGridFilter^ WebGridFilter
)

Parameters

WebGridFilter

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridFilterCollection Class
WebGridFilterCollection Members
Overload List


Add(String) Method

[image]
Intersoft WebGrid Documentation
Add(String) Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridFilterCollection Class > Add Method : Add(String) Method

name

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function Add( _
   ByVal name As System.String _
) As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebGridFilterCollection
Dim name As System.String
Dim value As System.Integer

value = instance.Add(name)
C#
public System.int Add(
   System.string name
)
Delphi
public function Add(
    name: System.String
): System.Integer;
JScript
public function Add(
   name : System.String
) : System.int;
Managed Extensions for C++
public: System.int Add(
   System.string* name
)
C++/CLI
public:
System.int Add(
   System.String^ name
)

Parameters

name

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridFilterCollection Class
WebGridFilterCollection Members
Overload List


Clear Method

[image]
Intersoft WebGrid Documentation
Clear Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridFilterCollection Class : Clear Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Shadows Sub Clear()
Visual Basic (Usage) Copy Code
Dim instance As WebGridFilterCollection

instance.Clear()
C#
public new void Clear()
Delphi
public procedure Clear();
JScript
public hide function Clear();
Managed Extensions for C++
public: new void Clear();
C++/CLI
public:
new void Clear();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridFilterCollection Class
WebGridFilterCollection Members


Contains Method

[image]
Intersoft WebGrid Documentation
Contains Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridFilterCollection Class : Contains Method

value

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function Contains( _
   ByVal value As ISNet.WebUI.INamedObject _
) As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebGridFilterCollection
Dim value As ISNet.WebUI.INamedObject
Dim value As System.Boolean

value = instance.Contains(value)
C#
public System.bool Contains(
   ISNet.WebUI.INamedObject value
)
Delphi
public function Contains(
    value: ISNet.WebUI.INamedObject
): System.Boolean;
JScript
public function Contains(
   value : ISNet.WebUI.INamedObject
) : System.boolean;
Managed Extensions for C++
public: System.bool Contains(
   ISNet.WebUI.INamedObject* value
)
C++/CLI
public:
System.bool Contains(
   ISNet.WebUI.INamedObject^ value
)

Parameters

value

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridFilterCollection Class
WebGridFilterCollection Members


CopyFrom Method

[image]
Intersoft WebGrid Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridFilterCollection Class : CopyFrom Method

passIn

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function CopyFrom( _
   ByVal passIn As WebGridFilterCollection _
) As WebGridFilterCollection
Visual Basic (Usage) Copy Code
Dim instance As WebGridFilterCollection
Dim passIn As WebGridFilterCollection
Dim value As WebGridFilterCollection

value = instance.CopyFrom(passIn)
C#
public WebGridFilterCollection CopyFrom(
   WebGridFilterCollection passIn
)
Delphi
public function CopyFrom(
    passIn: WebGridFilterCollection
): WebGridFilterCollection;
JScript
public function CopyFrom(
   passIn : WebGridFilterCollection
) : WebGridFilterCollection;
Managed Extensions for C++
public: WebGridFilterCollection* CopyFrom(
   WebGridFilterCollection* passIn
)
C++/CLI
public:
WebGridFilterCollection^ CopyFrom(
   WebGridFilterCollection^ passIn
)

Parameters

passIn

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridFilterCollection Class
WebGridFilterCollection Members


CopyTo Method

[image]
Intersoft WebGrid Documentation
CopyTo Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridFilterCollection Class : CopyTo Method

array
index

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub CopyTo( _
   ByVal array() As ISNet.WebUI.INamedObject, _
   ByVal index As System.Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As WebGridFilterCollection
Dim array() As ISNet.WebUI.INamedObject
Dim index As System.Integer

instance.CopyTo(array, index)
C#
public void CopyTo(
   ISNet.WebUI.INamedObject[] array,
   System.int index
)
Delphi
public procedure CopyTo(
    array: ISNet.WebUI.INamedObjectarray of;
    index: System.Integer
);
JScript
public function CopyTo(
   array : ISNet.WebUI.INamedObject[],
   index : System.int
);
Managed Extensions for C++
public: void CopyTo(
   ISNet.WebUI.INamedObject*[]* array,
   System.int index
)
C++/CLI
public:
void CopyTo(
   ISNet.WebUI.array<INamedObject^>^ array,
   System.int index
)

Parameters

array
index

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridFilterCollection Class
WebGridFilterCollection Members


Exists Method

[image]
Intersoft WebGrid Documentation
Exists Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridFilterCollection Class : Exists Method

name

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function Exists( _
   ByVal name As System.String _
) As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebGridFilterCollection
Dim name As System.String
Dim value As System.Boolean

value = instance.Exists(name)
C#
public System.bool Exists(
   System.string name
)
Delphi
public function Exists(
    name: System.String
): System.Boolean;
JScript
public function Exists(
   name : System.String
) : System.boolean;
Managed Extensions for C++
public: System.bool Exists(
   System.string* name
)
C++/CLI
public:
System.bool Exists(
   System.String^ name
)

Parameters

name

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridFilterCollection Class
WebGridFilterCollection Members


GetEnumerator Method

[image]
Intersoft WebGrid Documentation
GetEnumerator Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridFilterCollection Class : GetEnumerator Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Shadows Function GetEnumerator() As System.Collections.IEnumerator
Visual Basic (Usage) Copy Code
Dim instance As WebGridFilterCollection
Dim value As System.Collections.IEnumerator

value = instance.GetEnumerator()
C#
public new System.Collections.IEnumerator GetEnumerator()
Delphi
public function GetEnumerator(): System.Collections.IEnumerator;
JScript
public hide function GetEnumerator() : System.Collections.IEnumerator;
Managed Extensions for C++
public: new System.Collections.IEnumerator* GetEnumerator();
C++/CLI
public:
new System.Collections.IEnumerator^ GetEnumerator();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridFilterCollection Class
WebGridFilterCollection Members


GetFilterExpression Method

[image]
Intersoft WebGrid Documentation
GetFilterExpression Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridFilterCollection Class : GetFilterExpression Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetFilterExpression() As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebGridFilterCollection
Dim value As System.String

value = instance.GetFilterExpression()
C#
public System.string GetFilterExpression()
Delphi
public function GetFilterExpression(): System.String;
JScript
public function GetFilterExpression() : System.String;
Managed Extensions for C++
public: System.string* GetFilterExpression();
C++/CLI
public:
System.String^ GetFilterExpression();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridFilterCollection Class
WebGridFilterCollection Members


GetItem Method

[image]
Intersoft WebGrid Documentation
GetItem Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridFilterCollection Class : GetItem Method

Glossary Item Box

Overload List

Overload | Description
GetItem | (Inherited from ISNet.WebUI.ISCollectionBase)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridFilterCollection Class
WebGridFilterCollection Members


GetItem(Int32) Method

[image]
Intersoft WebGrid Documentation
GetItem(Int32) Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridFilterCollection Class : GetItem(Int32) Method

index

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetItem( _
   ByVal index As System.Integer _
) As ISNet.WebUI.INamedObject
Visual Basic (Usage) Copy Code
Dim instance As WebGridFilterCollection
Dim index As System.Integer
Dim value As ISNet.WebUI.INamedObject

value = instance.GetItem(index)
C#
public virtual ISNet.WebUI.INamedObject GetItem(
   System.int index
)
Delphi
public function GetItem(
    index: System.Integer
): ISNet.WebUI.INamedObject; virtual;
JScript
public function GetItem(
   index : System.int
) : ISNet.WebUI.INamedObject;
Managed Extensions for C++
public: virtual ISNet.WebUI.INamedObject* GetItem(
   System.int index
)
C++/CLI
public:
virtual ISNet.WebUI.INamedObject^ GetItem(
   System.int index
)

Parameters

index

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridFilterCollection Class
WebGridFilterCollection Members


GetLinqFilterExpression Method

[image]
Intersoft WebGrid Documentation
GetLinqFilterExpression Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridFilterCollection Class : GetLinqFilterExpression Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetLinqFilterExpression() As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebGridFilterCollection
Dim value As System.String

value = instance.GetLinqFilterExpression()
C#
public System.string GetLinqFilterExpression()
Delphi
public function GetLinqFilterExpression(): System.String;
JScript
public function GetLinqFilterExpression() : System.String;
Managed Extensions for C++
public: System.string* GetLinqFilterExpression();
C++/CLI
public:
System.String^ GetLinqFilterExpression();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridFilterCollection Class
WebGridFilterCollection Members


GetNamedItem Method

[image]
Intersoft WebGrid Documentation
GetNamedItem Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridFilterCollection Class : GetNamedItem Method

name

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetNamedItem( _
   ByVal name As System.String _
) As WebGridFilter
Visual Basic (Usage) Copy Code
Dim instance As WebGridFilterCollection
Dim name As System.String
Dim value As WebGridFilter

value = instance.GetNamedItem(name)
C#
public WebGridFilter GetNamedItem(
   System.string name
)
Delphi
public function GetNamedItem(
    name: System.String
): WebGridFilter;
JScript
public function GetNamedItem(
   name : System.String
) : WebGridFilter;
Managed Extensions for C++
public: WebGridFilter* GetNamedItem(
   System.string* name
)
C++/CLI
public:
WebGridFilter^ GetNamedItem(
   System.String^ name
)

Parameters

name

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridFilterCollection Class
WebGridFilterCollection Members


IndexOf Method

[image]
Intersoft WebGrid Documentation
IndexOf Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridFilterCollection Class : IndexOf Method

Glossary Item Box

Overload List

Overload | Description
IndexOf(String) | (Inherited from ISNet.WebUI.ISCollectionBase)
IndexOf(INamedObject) | (Inherited from ISNet.WebUI.ISCollectionBase)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridFilterCollection Class
WebGridFilterCollection Members


IndexOf(String) Method

[image]
Intersoft WebGrid Documentation
IndexOf(String) Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridFilterCollection Class > IndexOf Method : IndexOf(String) Method

name

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function IndexOf( _
   ByVal name As System.String _
) As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebGridFilterCollection
Dim name As System.String
Dim value As System.Integer

value = instance.IndexOf(name)
C#
public virtual System.int IndexOf(
   System.string name
)
Delphi
public function IndexOf(
    name: System.String
): System.Integer; virtual;
JScript
public function IndexOf(
   name : System.String
) : System.int;
Managed Extensions for C++
public: virtual System.int IndexOf(
   System.string* name
)
C++/CLI
public:
virtual System.int IndexOf(
   System.String^ name
)

Parameters

name

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridFilterCollection Class
WebGridFilterCollection Members
Overload List


IndexOf(INamedObject) Method

[image]
Intersoft WebGrid Documentation
IndexOf(INamedObject) Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridFilterCollection Class > IndexOf Method : IndexOf(INamedObject) Method

value

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function IndexOf( _
   ByVal value As ISNet.WebUI.INamedObject _
) As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebGridFilterCollection
Dim value As ISNet.WebUI.INamedObject
Dim value As System.Integer

value = instance.IndexOf(value)
C#
public System.int IndexOf(
   ISNet.WebUI.INamedObject value
)
Delphi
public function IndexOf(
    value: ISNet.WebUI.INamedObject
): System.Integer;
JScript
public function IndexOf(
   value : ISNet.WebUI.INamedObject
) : System.int;
Managed Extensions for C++
public: System.int IndexOf(
   ISNet.WebUI.INamedObject* value
)
C++/CLI
public:
System.int IndexOf(
   ISNet.WebUI.INamedObject^ value
)

Parameters

value

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridFilterCollection Class
WebGridFilterCollection Members
Overload List


Insert Method

[image]
Intersoft WebGrid Documentation
Insert Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridFilterCollection Class : Insert Method

index
WebGridFilter

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub Insert( _
   ByVal index As System.Integer, _
   ByVal WebGridFilter As WebGridFilter _
)
Visual Basic (Usage) Copy Code
Dim instance As WebGridFilterCollection
Dim index As System.Integer
Dim WebGridFilter As WebGridFilter

instance.Insert(index, WebGridFilter)
C#
public void Insert(
   System.int index,
   WebGridFilter WebGridFilter
)
Delphi
public procedure Insert(
    index: System.Integer;
    WebGridFilter: WebGridFilter
);
JScript
public function Insert(
   index : System.int,
   WebGridFilter : WebGridFilter
);
Managed Extensions for C++
public: void Insert(
   System.int index,
   WebGridFilter* WebGridFilter
)
C++/CLI
public:
void Insert(
   System.int index,
   WebGridFilter^ WebGridFilter
)

Parameters

index
WebGridFilter

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridFilterCollection Class
WebGridFilterCollection Members


IntInsert Method

[image]
Intersoft WebGrid Documentation
IntInsert Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridFilterCollection Class : IntInsert Method

index
value

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub IntInsert( _
   ByVal index As System.Integer, _
   ByVal value As ISNet.WebUI.INamedObject _
)
Visual Basic (Usage) Copy Code
Dim instance As WebGridFilterCollection
Dim index As System.Integer
Dim value As ISNet.WebUI.INamedObject

instance.IntInsert(index, value)
C#
public void IntInsert(
   System.int index,
   ISNet.WebUI.INamedObject value
)
Delphi
public procedure IntInsert(
    index: System.Integer;
    value: ISNet.WebUI.INamedObject
);
JScript
public function IntInsert(
   index : System.int,
   value : ISNet.WebUI.INamedObject
);
Managed Extensions for C++
public: void IntInsert(
   System.int index,
   ISNet.WebUI.INamedObject* value
)
C++/CLI
public:
void IntInsert(
   System.int index,
   ISNet.WebUI.INamedObject^ value
)

Parameters

index
value

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridFilterCollection Class
WebGridFilterCollection Members


Remove Method

[image]
Intersoft WebGrid Documentation
Remove Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridFilterCollection Class : Remove Method

WebGridFilter

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub Remove( _
   ByVal WebGridFilter As WebGridFilter _
)
Visual Basic (Usage) Copy Code
Dim instance As WebGridFilterCollection
Dim WebGridFilter As WebGridFilter

instance.Remove(WebGridFilter)
C#
public void Remove(
   WebGridFilter WebGridFilter
)
Delphi
public procedure Remove(
    WebGridFilter: WebGridFilter
);
JScript
public function Remove(
   WebGridFilter : WebGridFilter
);
Managed Extensions for C++
public: void Remove(
   WebGridFilter* WebGridFilter
)
C++/CLI
public:
void Remove(
   WebGridFilter^ WebGridFilter
)

Parameters

WebGridFilter

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridFilterCollection Class
WebGridFilterCollection Members


setParent Method

[image]
Intersoft WebGrid Documentation
setParent Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridFilterCollection Class : setParent Method

parent

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub setParent( _
   ByVal parent As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebGridFilterCollection
Dim parent As System.Object

instance.setParent(parent)
C#
public virtual void setParent(
   System.object parent
)
Delphi
public procedure setParent(
    parent: System.TObject
); virtual;
JScript
public function setParent(
   parent : System.Object
);
Managed Extensions for C++
public: virtual void setParent(
   System.Object* parent
)
C++/CLI
public:
virtual void setParent(
   System.Object^ parent
)

Parameters

parent

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridFilterCollection Class
WebGridFilterCollection Members


SortByIndex Method

[image]
Intersoft WebGrid Documentation
SortByIndex Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridFilterCollection Class : SortByIndex Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SortByIndex()
Visual Basic (Usage) Copy Code
Dim instance As WebGridFilterCollection

instance.SortByIndex()
C#
public void SortByIndex()
Delphi
public procedure SortByIndex();
JScript
public function SortByIndex();
Managed Extensions for C++
public: void SortByIndex();
C++/CLI
public:
void SortByIndex();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridFilterCollection Class
WebGridFilterCollection Members


WebGridFilterCollection Class Properties

[image]
Intersoft WebGrid Documentation
WebGridFilterCollection Class Properties
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : WebGridFilterCollection Class

Glossary Item Box

For a list of all members of this type, see WebGridFilterCollection members.

Public Properties

 | Name | Description
Public Property | AdvancedFilterExpression |
Public Property | Capacity | (Inherited from System.Collections.CollectionBase)
Public Property | Count | (Inherited from System.Collections.CollectionBase)
Public Property | IsReadOnly | Overridden.
Public Property | Item |
Public Property | Parent | (Inherited from ISNet.WebUI.ISCollectionBase)
Top

See Also

Reference

WebGridFilterCollection Class
ISNet.WebUI.WebGrid Namespace


WebGridFilterCollection Constructor

[image]
Intersoft WebGrid Documentation
WebGridFilterCollection Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridFilterCollection Class : WebGridFilterCollection Constructor

Glossary Item Box

Overload List

Overload | Description
WebGridFilterCollection Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridFilterCollection Class
WebGridFilterCollection Members


AdvancedFilterExpression Property

[image]
Intersoft WebGrid Documentation
AdvancedFilterExpression Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridFilterCollection Class : AdvancedFilterExpression Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Gets or sets the advanced filter expression.")>
Public Property AdvancedFilterExpression As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebGridFilterCollection
Dim value As System.String

instance.AdvancedFilterExpression = value

value = instance.AdvancedFilterExpression
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the advanced filter expression.")]
public System.string AdvancedFilterExpression {get; set;}
Delphi
public read-write property AdvancedFilterExpression: System.String;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the advanced filter expression.")
public function get,set AdvancedFilterExpression : System.String
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the advanced filter expression.")]
public: __property System.string* get_AdvancedFilterExpression();
public: __property void set_AdvancedFilterExpression(
   System.string* value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the advanced filter expression.")]
public:
property System.String^ AdvancedFilterExpression {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridFilterCollection Class
WebGridFilterCollection Members


Capacity Property

[image]
Intersoft WebGrid Documentation
Capacity Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridFilterCollection Class : Capacity Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Runtime.InteropServices.ComVisibleAttribute(False)>
Public Property Capacity As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebGridFilterCollection
Dim value As System.Integer

instance.Capacity = value

value = instance.Capacity
C#
[System.Runtime.InteropServices.ComVisibleAttribute(false)]
public System.int Capacity {get; set;}
Delphi
public read-write property Capacity: System.Integer;
JScript
System.Runtime.InteropServices.ComVisibleAttribute()
public function get,set Capacity : System.int
Managed Extensions for C++
[System.Runtime.InteropServices.ComVisibleAttribute(false)]
public: __property System.int get_Capacity();
public: __property void set_Capacity(
   System.int value
);
C++/CLI
[System.Runtime.InteropServices.ComVisibleAttribute(false)]
public:
property System.int Capacity {
   System.int get();
   void set (    System.int value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridFilterCollection Class
WebGridFilterCollection Members


Count Property

[image]
Intersoft WebGrid Documentation
Count Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridFilterCollection Class : Count Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Count As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebGridFilterCollection
Dim value As System.Integer

value = instance.Count
C#
public System.int Count {get;}
Delphi
public read-only property Count: System.Integer;
JScript
public function get Count : System.int
Managed Extensions for C++
public: __property System.int get_Count();
C++/CLI
public:
property System.int Count {
   System.int get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridFilterCollection Class
WebGridFilterCollection Members


IsReadOnly Property

[image]
Intersoft WebGrid Documentation
IsReadOnly Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridFilterCollection Class : IsReadOnly Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property IsReadOnly As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebGridFilterCollection
Dim value As System.Boolean

value = instance.IsReadOnly
C#
public override System.bool IsReadOnly {get;}
Delphi
public read-only property IsReadOnly: System.Boolean; override;
JScript
public override function get IsReadOnly : System.boolean
Managed Extensions for C++
public: __property System.bool get_IsReadOnly() override;
C++/CLI
public:
property System.bool IsReadOnly {
   System.bool get() override;
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridFilterCollection Class
WebGridFilterCollection Members


Item Property

[image]
Intersoft WebGrid Documentation
Item Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridFilterCollection Class : Item Property

index

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Default Property Item( _
   ByVal index As System.Integer _
) As WebGridFilter
Visual Basic (Usage) Copy Code
Dim instance As WebGridFilterCollection
Dim index As System.Integer
Dim value As WebGridFilter

value = instance.Item(index)
C#
public WebGridFilter this[
   System.int index
]; {get;}
Delphi
public  this: : WebGridFilter;[
    index: System.Integer
]; read-only
JScript
public  this[
   index : System.int
] get : WebGridFilter
Managed Extensions for C++
public: __property WebGridFilter* get_Item   System.int index
;
C++/CLI
public:
property WebGridFilter^ default [int] {
   WebGridFilter^ get(System.int index);
}

Parameters

index

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridFilterCollection Class
WebGridFilterCollection Members


Parent Property

[image]
Intersoft WebGrid Documentation
Parent Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridFilterCollection Class : Parent Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Parent As System.Object
Visual Basic (Usage) Copy Code
Dim instance As WebGridFilterCollection
Dim value As System.Object

value = instance.Parent
C#
public System.object Parent {get;}
Delphi
public read-only property Parent: System.TObject;
JScript
public function get Parent : System.Object
Managed Extensions for C++
public: __property System.Object* get_Parent();
C++/CLI
public:
property System.Object^ Parent {
   System.Object^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridFilterCollection Class
WebGridFilterCollection Members


WebGridFormatCondition Class

[image]
Intersoft WebGrid Documentation
WebGridFormatCondition Class
Members See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : WebGridFormatCondition Class

Glossary Item Box

Object Model

WebGridFormatCondition Class

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.DescriptionAttribute()>
<System.SerializableAttribute()>
Public Class WebGridFormatCondition
   Inherits ISNet.WebUI.NamedObjectBase
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject
Visual Basic (Usage) Copy Code
Dim instance As WebGridFormatCondition
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DescriptionAttribute()]
[System.SerializableAttribute()]
public class WebGridFormatCondition : ISNet.WebUI.NamedObjectBase, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject
Delphi
public class WebGridFormatCondition = class(ISNet.WebUI.NamedObjectBase, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject)
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.DescriptionAttribute()
System.SerializableAttribute()
public class WebGridFormatCondition extends ISNet.WebUI.NamedObjectBase implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DescriptionAttribute()]
[System.SerializableAttribute()]
public __gc class WebGridFormatCondition : public ISNet.WebUI.NamedObjectBase, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DescriptionAttribute()]
[System.SerializableAttribute()]
public ref class WebGridFormatCondition : public ISNet.WebUI.NamedObjectBase, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.NamedObjectBase
ISNet.WebUI.WebGrid.WebGridFormatCondition

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridFormatCondition Members
ISNet.WebUI.WebGrid Namespace


WebGridFormatCondition Class Members

[image]
Intersoft WebGrid Documentation
WebGridFormatCondition Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebGrid Namespace : WebGridFormatCondition Class

Glossary Item Box

The following tables list the members exposed by WebGridFormatCondition.

Public Constructors

 | Name | Description
Public Constructor | WebGridFormatCondition Constructor |
Top

Public Properties

 | Name | Description
Public Property | ColumnMember |
Public Property | ConditionText |
Public Property | CustomConditionText |
Public Property | Enabled |
Public Property | FormatStyle |
Public Property | Name | Overridden.
Public Property | Operator |
Public Property | TargetColumnMember |
Public Property | TargetObject |
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString |
Top

See Also

Reference

WebGridFormatCondition Class
ISNet.WebUI.WebGrid Namespace


WebGridFormatCondition Constructor

[image]
Intersoft WebGrid Documentation
WebGridFormatCondition Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridFormatCondition Class : WebGridFormatCondition Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebGridFormatCondition()
C#
public WebGridFormatCondition()
Delphi
public WebGridFormatCondition();
JScript
public function WebGridFormatCondition();
Managed Extensions for C++
public: WebGridFormatCondition();
C++/CLI
public:
WebGridFormatCondition();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridFormatCondition Class
WebGridFormatCondition Members


Clone Method

[image]
Intersoft WebGrid Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridFormatCondition Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As System.Object
Visual Basic (Usage) Copy Code
Dim instance As WebGridFormatCondition
Dim value As System.Object

value = instance.Clone()
C#
public virtual System.object Clone()
Delphi
public function Clone(): System.TObject; virtual;
JScript
public function Clone() : System.Object;
Managed Extensions for C++
public: virtual System.Object* Clone();
C++/CLI
public:
virtual System.Object^ Clone();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridFormatCondition Class
WebGridFormatCondition Members


CopyFrom Method

[image]
Intersoft WebGrid Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridFormatCondition Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridFormatCondition Class
WebGridFormatCondition Members


CopyFrom(Object) Method

[image]
Intersoft WebGrid Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridFormatCondition Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebGridFormatCondition
Dim objSource As System.Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   System.object objSource
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridFormatCondition Class
WebGridFormatCondition Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebGrid Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridFormatCondition Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object, _
   ByVal cloneSourceValue As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebGridFormatCondition
Dim objSource As System.Object
Dim cloneSourceValue As System.Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   System.object objSource,
   System.bool cloneSourceValue
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject;
    cloneSourceValue: System.Boolean
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object,
   cloneSourceValue : System.boolean
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource,
   System.bool cloneSourceValue
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource,
   System.bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridFormatCondition Class
WebGridFormatCondition Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebGrid Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridFormatCondition Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebGridFormatCondition
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure DeSerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function DeSerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void DeSerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void DeSerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridFormatCondition Class
WebGridFormatCondition Members


GetHashCode Method

[image]
Intersoft WebGrid Documentation
GetHashCode Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridFormatCondition Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebGridFormatCondition
Dim value As System.Integer

value = instance.GetHashCode()
C#
public virtual System.int GetHashCode()
Delphi
public function GetHashCode(): System.Integer; virtual;
JScript
public function GetHashCode() : System.int;
Managed Extensions for C++
public: virtual System.int GetHashCode();
C++/CLI
public:
virtual System.int GetHashCode();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridFormatCondition Class
WebGridFormatCondition Members


WebGridFormatCondition Class Methods

[image]
Intersoft WebGrid Documentation
WebGridFormatCondition Class Methods
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : WebGridFormatCondition Class

Glossary Item Box

For a list of all members of this type, see WebGridFormatCondition members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString |
Top

See Also

Reference

WebGridFormatCondition Class
ISNet.WebUI.WebGrid Namespace


GetObjectData Method

[image]
Intersoft WebGrid Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridFormatCondition Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebGridFormatCondition
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure GetObjectData(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
); override;
JScript
public override function GetObjectData(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void GetObjectData(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
) override
C++/CLI
public:
void GetObjectData(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
) override

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridFormatCondition Class
WebGridFormatCondition Members


IsEmpty Method

[image]
Intersoft WebGrid Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridFormatCondition Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebGridFormatCondition
Dim value As System.Boolean

value = instance.IsEmpty()
C#
public virtual System.bool IsEmpty()
Delphi
public function IsEmpty(): System.Boolean; virtual;
JScript
public function IsEmpty() : System.boolean;
Managed Extensions for C++
public: virtual System.bool IsEmpty();
C++/CLI
public:
virtual System.bool IsEmpty();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridFormatCondition Class
WebGridFormatCondition Members


Reset Method

[image]
Intersoft WebGrid Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridFormatCondition Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As WebGridFormatCondition

instance.Reset()
C#
public virtual void Reset()
Delphi
public procedure Reset(); virtual;
JScript
public function Reset();
Managed Extensions for C++
public: virtual void Reset();
C++/CLI
public:
virtual void Reset();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridFormatCondition Class
WebGridFormatCondition Members


SerializeObjectData Method

[image]
Intersoft WebGrid Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridFormatCondition Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebGridFormatCondition
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure SerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function SerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void SerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void SerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridFormatCondition Class
WebGridFormatCondition Members


ToString Method

[image]
Intersoft WebGrid Documentation
ToString Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridFormatCondition Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString() As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebGridFormatCondition
Dim value As System.String

value = instance.ToString()
C#
public override System.string ToString()
Delphi
public function ToString(): System.String; override;
JScript
public override function ToString() : System.String;
Managed Extensions for C++
public: System.string* ToString(); override
C++/CLI
public:
System.String^ ToString(); override

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridFormatCondition Class
WebGridFormatCondition Members


WebGridFormatCondition Class Properties

[image]
Intersoft WebGrid Documentation
WebGridFormatCondition Class Properties
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : WebGridFormatCondition Class

Glossary Item Box

For a list of all members of this type, see WebGridFormatCondition members.

Public Properties

 | Name | Description
Public Property | ColumnMember |
Public Property | ConditionText |
Public Property | CustomConditionText |
Public Property | Enabled |
Public Property | FormatStyle |
Public Property | Name | Overridden.
Public Property | Operator |
Public Property | TargetColumnMember |
Public Property | TargetObject |
Top

See Also

Reference

WebGridFormatCondition Class
ISNet.WebUI.WebGrid Namespace


WebGridFormatCondition Constructor

[image]
Intersoft WebGrid Documentation
WebGridFormatCondition Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridFormatCondition Class : WebGridFormatCondition Constructor

Glossary Item Box

Overload List

Overload | Description
WebGridFormatCondition Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridFormatCondition Class
WebGridFormatCondition Members


ColumnMember Property

[image]
Intersoft WebGrid Documentation
ColumnMember Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridFormatCondition Class : ColumnMember Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebGrid.FieldTypeEditor, ISNet.WebUI.WebGrid, Version=9.0.7200.1, Culture=neutral, PublicKeyToken=3e60b85fb8502d5e")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute()>
Public Property ColumnMember As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebGridFormatCondition
Dim value As System.String

instance.ColumnMember = value

value = instance.ColumnMember
C#
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebGrid.FieldTypeEditor, ISNet.WebUI.WebGrid, Version=9.0.7200.1, Culture=neutral, PublicKeyToken=3e60b85fb8502d5e")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute()]
public System.string ColumnMember {get; set;}
Delphi
public read-write property ColumnMember: System.String;
JScript
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebGrid.FieldTypeEditor, ISNet.WebUI.WebGrid, Version=9.0.7200.1, Culture=neutral, PublicKeyToken=3e60b85fb8502d5e")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute()
public function get,set ColumnMember : System.String
Managed Extensions for C++
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebGrid.FieldTypeEditor, ISNet.WebUI.WebGrid, Version=9.0.7200.1, Culture=neutral, PublicKeyToken=3e60b85fb8502d5e")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute()]
public: __property System.string* get_ColumnMember();
public: __property void set_ColumnMember(
   System.string* value
);
C++/CLI
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebGrid.FieldTypeEditor, ISNet.WebUI.WebGrid, Version=9.0.7200.1, Culture=neutral, PublicKeyToken=3e60b85fb8502d5e")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute()]
public:
property System.String^ ColumnMember {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridFormatCondition Class
WebGridFormatCondition Members


ConditionText Property

[image]
Intersoft WebGrid Documentation
ConditionText Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridFormatCondition Class : ConditionText Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute()>
Public Property ConditionText As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebGridFormatCondition
Dim value As System.String

instance.ConditionText = value

value = instance.ConditionText
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute()]
public System.string ConditionText {get; set;}
Delphi
public read-write property ConditionText: System.String;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute()
public function get,set ConditionText : System.String
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute()]
public: __property System.string* get_ConditionText();
public: __property void set_ConditionText(
   System.string* value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute()]
public:
property System.String^ ConditionText {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridFormatCondition Class
WebGridFormatCondition Members


CustomConditionText Property

[image]
Intersoft WebGrid Documentation
CustomConditionText Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridFormatCondition Class : CustomConditionText Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute()>
Public Property CustomConditionText As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebGridFormatCondition
Dim value As System.String

instance.CustomConditionText = value

value = instance.CustomConditionText
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute()]
public System.string CustomConditionText {get; set;}
Delphi
public read-write property CustomConditionText: System.String;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute()
public function get,set CustomConditionText : System.String
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute()]
public: __property System.string* get_CustomConditionText();
public: __property void set_CustomConditionText(
   System.string* value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute()]
public:
property System.String^ CustomConditionText {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridFormatCondition Class
WebGridFormatCondition Members


Enabled Property

[image]
Intersoft WebGrid Documentation
Enabled Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridFormatCondition Class : Enabled Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property Enabled As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebGridFormatCondition
Dim value As System.Boolean

instance.Enabled = value

value = instance.Enabled
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public System.bool Enabled {get; set;}
Delphi
public read-write property Enabled: System.Boolean;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get,set Enabled : System.boolean
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.bool get_Enabled();
public: __property void set_Enabled(
   System.bool value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.bool Enabled {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridFormatCondition Class
WebGridFormatCondition Members


FormatStyle Property

[image]
Intersoft WebGrid Documentation
FormatStyle Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridFormatCondition Class : FormatStyle Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.DescriptionAttribute()>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
Public Property FormatStyle As WebGridFormatStyle
Visual Basic (Usage) Copy Code
Dim instance As WebGridFormatCondition
Dim value As WebGridFormatStyle

instance.FormatStyle = value

value = instance.FormatStyle
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DescriptionAttribute()]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public WebGridFormatStyle FormatStyle {get; set;}
Delphi
public read-write property FormatStyle: WebGridFormatStyle;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.DescriptionAttribute()
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
public function get,set FormatStyle : WebGridFormatStyle
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DescriptionAttribute()]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public: __property WebGridFormatStyle* get_FormatStyle();
public: __property void set_FormatStyle(
   WebGridFormatStyle* value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DescriptionAttribute()]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public:
property WebGridFormatStyle^ FormatStyle {
   WebGridFormatStyle^ get();
   void set (    WebGridFormatStyle^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridFormatCondition Class
WebGridFormatCondition Members


Name Property

[image]
Intersoft WebGrid Documentation
Name Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridFormatCondition Class : Name Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.BrowsableAttribute(True)>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Visible)>
Public Overrides Property Name As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebGridFormatCondition
Dim value As System.String

instance.Name = value

value = instance.Name
C#
[System.ComponentModel.BrowsableAttribute(true)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Visible)]
public override System.string Name {get; set;}
Delphi
public read-write property Name: System.String; override;
JScript
System.ComponentModel.BrowsableAttribute()
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Visible)
public override function get,set Name : System.String
Managed Extensions for C++
[System.ComponentModel.BrowsableAttribute(true)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Visible)]
public: __property System.string* get_Name() override;
public: __property void set_Name(
   System.string* value
) override;
C++/CLI
[System.ComponentModel.BrowsableAttribute(true)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Visible)]
public:
property System.String^ Name {
   System.String^ get() override;
   void set (    System.String^ value) override;
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridFormatCondition Class
WebGridFormatCondition Members


Operator Property

[image]
Intersoft WebGrid Documentation
Operator Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridFormatCondition Class : Operator Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
Public Property Operator As ColumnFilterType
Visual Basic (Usage) Copy Code
Dim instance As WebGridFormatCondition
Dim value As ColumnFilterType

instance.Operator = value

value = instance.Operator
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public ColumnFilterType Operator {get; set;}
Delphi
public read-write property Operator: ColumnFilterType;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
public function get,set Operator : ColumnFilterType
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public: __property ColumnFilterType get_Operator();
public: __property void set_Operator(
   ColumnFilterType value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public:
property ColumnFilterType Operator {
   ColumnFilterType get();
   void set (    ColumnFilterType value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridFormatCondition Class
WebGridFormatCondition Members


TargetColumnMember Property

[image]
Intersoft WebGrid Documentation
TargetColumnMember Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridFormatCondition Class : TargetColumnMember Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute()>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebGrid.FieldTypeEditor, ISNet.WebUI.WebGrid, Version=9.0.7200.1, Culture=neutral, PublicKeyToken=3e60b85fb8502d5e")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
Public Property TargetColumnMember As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebGridFormatCondition
Dim value As System.String

instance.TargetColumnMember = value

value = instance.TargetColumnMember
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebGrid.FieldTypeEditor, ISNet.WebUI.WebGrid, Version=9.0.7200.1, Culture=neutral, PublicKeyToken=3e60b85fb8502d5e")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public System.string TargetColumnMember {get; set;}
Delphi
public read-write property TargetColumnMember: System.String;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute()
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebGrid.FieldTypeEditor, ISNet.WebUI.WebGrid, Version=9.0.7200.1, Culture=neutral, PublicKeyToken=3e60b85fb8502d5e")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
public function get,set TargetColumnMember : System.String
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebGrid.FieldTypeEditor, ISNet.WebUI.WebGrid, Version=9.0.7200.1, Culture=neutral, PublicKeyToken=3e60b85fb8502d5e")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.string* get_TargetColumnMember();
public: __property void set_TargetColumnMember(
   System.string* value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebGrid.FieldTypeEditor, ISNet.WebUI.WebGrid, Version=9.0.7200.1, Culture=neutral, PublicKeyToken=3e60b85fb8502d5e")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.String^ TargetColumnMember {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridFormatCondition Class
WebGridFormatCondition Members


TargetObject Property

[image]
Intersoft WebGrid Documentation
TargetObject Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridFormatCondition Class : TargetObject Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DescriptionAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property TargetObject As TargetObjectType
Visual Basic (Usage) Copy Code
Dim instance As WebGridFormatCondition
Dim value As TargetObjectType

instance.TargetObject = value

value = instance.TargetObject
C#
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public TargetObjectType TargetObject {get; set;}
Delphi
public read-write property TargetObject: TargetObjectType;
JScript
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DescriptionAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set TargetObject : TargetObjectType
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property TargetObjectType get_TargetObject();
public: __property void set_TargetObject(
   TargetObjectType value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property TargetObjectType TargetObject {
   TargetObjectType get();
   void set (    TargetObjectType value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridFormatCondition Class
WebGridFormatCondition Members


WebGridFormatConditionCollection Class

[image]
Intersoft WebGrid Documentation
WebGridFormatConditionCollection Class
Members See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : WebGridFormatConditionCollection Class

Glossary Item Box

Object Model

WebGridFormatConditionCollection Class

Syntax

Visual Basic (Declaration)
<System.Reflection.DefaultMemberAttribute("Item")>
<System.SerializableAttribute()>
Public Class WebGridFormatConditionCollection
   Inherits ISNet.WebUI.ISCollectionBase
Visual Basic (Usage) Copy Code
Dim instance As WebGridFormatConditionCollection
C#
[System.Reflection.DefaultMemberAttribute("Item")]
[System.SerializableAttribute()]
public class WebGridFormatConditionCollection : ISNet.WebUI.ISCollectionBase
Delphi
public class WebGridFormatConditionCollection = class(ISNet.WebUI.ISCollectionBase)
JScript
System.Reflection.DefaultMemberAttribute("Item")
System.SerializableAttribute()
public class WebGridFormatConditionCollection extends ISNet.WebUI.ISCollectionBase
Managed Extensions for C++
[System.Reflection.DefaultMemberAttribute("Item")]
[System.SerializableAttribute()]
public __gc class WebGridFormatConditionCollection : public ISNet.WebUI.ISCollectionBase
C++/CLI
[System.Reflection.DefaultMemberAttribute("Item")]
[System.SerializableAttribute()]
public ref class WebGridFormatConditionCollection : public ISNet.WebUI.ISCollectionBase

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
ISNet.WebUI.ISCollectionBase
ISNet.WebUI.WebGrid.WebGridFormatConditionCollection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridFormatConditionCollection Members
ISNet.WebUI.WebGrid Namespace


WebGridFormatConditionCollection Class Members

[image]
Intersoft WebGrid Documentation
WebGridFormatConditionCollection Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebGrid Namespace : WebGridFormatConditionCollection Class

Glossary Item Box

The following tables list the members exposed by WebGridFormatConditionCollection.

Public Constructors

 | Name | Description
Public Constructor | WebGridFormatConditionCollection Constructor |
Top

Public Properties

 | Name | Description
Public Property | Capacity | (Inherited from System.Collections.CollectionBase)
Public Property | Count | (Inherited from System.Collections.CollectionBase)
Public Property | IsReadOnly | Overridden.
Public Property | Item |
Public Property | Parent | (Inherited from ISNet.WebUI.ISCollectionBase)
Top

Public Methods

 | Name | Description
Public Method | Add | Overloaded.
Public Method | Clear |
Public Method | Contains | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | CopyFrom |
Public Method | CopyTo | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | Exists | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | GetEnumerator |
Public Method | GetItem | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | GetNamedItem |
Public Method | IndexOf | Overloaded. (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | Insert |
Public Method | IntInsert | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | Remove |
Public Method | setParent | (Inherited from ISNet.WebUI.ISCollectionBase)
Top

See Also

Reference

WebGridFormatConditionCollection Class
ISNet.WebUI.WebGrid Namespace


WebGridFormatConditionCollection Constructor

[image]
Intersoft WebGrid Documentation
WebGridFormatConditionCollection Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridFormatConditionCollection Class : WebGridFormatConditionCollection Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebGridFormatConditionCollection()
C#
public WebGridFormatConditionCollection()
Delphi
public WebGridFormatConditionCollection();
JScript
public function WebGridFormatConditionCollection();
Managed Extensions for C++
public: WebGridFormatConditionCollection();
C++/CLI
public:
WebGridFormatConditionCollection();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridFormatConditionCollection Class
WebGridFormatConditionCollection Members


WebGridFormatConditionCollection Class Methods

[image]
Intersoft WebGrid Documentation
WebGridFormatConditionCollection Class Methods
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : WebGridFormatConditionCollection Class

Glossary Item Box

For a list of all members of this type, see WebGridFormatConditionCollection members.

Public Methods

 | Name | Description
Public Method | Add | Overloaded.
Public Method | Clear |
Public Method | Contains | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | CopyFrom |
Public Method | CopyTo | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | Exists | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | GetEnumerator |
Public Method | GetItem | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | GetNamedItem |
Public Method | IndexOf | Overloaded. (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | Insert |
Public Method | IntInsert | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | Remove |
Public Method | setParent | (Inherited from ISNet.WebUI.ISCollectionBase)
Top

See Also

Reference

WebGridFormatConditionCollection Class
ISNet.WebUI.WebGrid Namespace


Add Method

[image]
Intersoft WebGrid Documentation
Add Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridFormatConditionCollection Class : Add Method

Glossary Item Box

Overload List

Overload | Description
Add(WebGridFormatCondition) |
Add(String) |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridFormatConditionCollection Class
WebGridFormatConditionCollection Members


Add(WebGridFormatCondition) Method

[image]
Intersoft WebGrid Documentation
Add(WebGridFormatCondition) Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridFormatConditionCollection Class > Add Method : Add(WebGridFormatCondition) Method

webGridFormatCondition

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function Add( _
   ByVal webGridFormatCondition As WebGridFormatCondition _
) As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebGridFormatConditionCollection
Dim webGridFormatCondition As WebGridFormatCondition
Dim value As System.Integer

value = instance.Add(webGridFormatCondition)
C#
public virtual System.int Add(
   WebGridFormatCondition webGridFormatCondition
)
Delphi
public function Add(
    webGridFormatCondition: WebGridFormatCondition
): System.Integer; virtual;
JScript
public function Add(
   webGridFormatCondition : WebGridFormatCondition
) : System.int;
Managed Extensions for C++
public: virtual System.int Add(
   WebGridFormatCondition* webGridFormatCondition
)
C++/CLI
public:
virtual System.int Add(
   WebGridFormatCondition^ webGridFormatCondition
)

Parameters

webGridFormatCondition

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridFormatConditionCollection Class
WebGridFormatConditionCollection Members
Overload List


Add(String) Method

[image]
Intersoft WebGrid Documentation
Add(String) Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridFormatConditionCollection Class > Add Method : Add(String) Method

name

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function Add( _
   ByVal name As System.String _
) As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebGridFormatConditionCollection
Dim name As System.String
Dim value As System.Integer

value = instance.Add(name)
C#
public System.int Add(
   System.string name
)
Delphi
public function Add(
    name: System.String
): System.Integer;
JScript
public function Add(
   name : System.String
) : System.int;
Managed Extensions for C++
public: System.int Add(
   System.string* name
)
C++/CLI
public:
System.int Add(
   System.String^ name
)

Parameters

name

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridFormatConditionCollection Class
WebGridFormatConditionCollection Members
Overload List


Clear Method

[image]
Intersoft WebGrid Documentation
Clear Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridFormatConditionCollection Class : Clear Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Shadows Sub Clear()
Visual Basic (Usage) Copy Code
Dim instance As WebGridFormatConditionCollection

instance.Clear()
C#
public new void Clear()
Delphi
public procedure Clear();
JScript
public hide function Clear();
Managed Extensions for C++
public: new void Clear();
C++/CLI
public:
new void Clear();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridFormatConditionCollection Class
WebGridFormatConditionCollection Members


Contains Method

[image]
Intersoft WebGrid Documentation
Contains Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridFormatConditionCollection Class : Contains Method

value

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function Contains( _
   ByVal value As ISNet.WebUI.INamedObject _
) As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebGridFormatConditionCollection
Dim value As ISNet.WebUI.INamedObject
Dim value As System.Boolean

value = instance.Contains(value)
C#
public System.bool Contains(
   ISNet.WebUI.INamedObject value
)
Delphi
public function Contains(
    value: ISNet.WebUI.INamedObject
): System.Boolean;
JScript
public function Contains(
   value : ISNet.WebUI.INamedObject
) : System.boolean;
Managed Extensions for C++
public: System.bool Contains(
   ISNet.WebUI.INamedObject* value
)
C++/CLI
public:
System.bool Contains(
   ISNet.WebUI.INamedObject^ value
)

Parameters

value

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridFormatConditionCollection Class
WebGridFormatConditionCollection Members


CopyFrom Method

[image]
Intersoft WebGrid Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridFormatConditionCollection Class : CopyFrom Method

passIn

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function CopyFrom( _
   ByVal passIn As WebGridFormatConditionCollection _
) As WebGridFormatConditionCollection
Visual Basic (Usage) Copy Code
Dim instance As WebGridFormatConditionCollection
Dim passIn As WebGridFormatConditionCollection
Dim value As WebGridFormatConditionCollection

value = instance.CopyFrom(passIn)
C#
public WebGridFormatConditionCollection CopyFrom(
   WebGridFormatConditionCollection passIn
)
Delphi
public function CopyFrom(
    passIn: WebGridFormatConditionCollection
): WebGridFormatConditionCollection;
JScript
public function CopyFrom(
   passIn : WebGridFormatConditionCollection
) : WebGridFormatConditionCollection;
Managed Extensions for C++
public: WebGridFormatConditionCollection* CopyFrom(
   WebGridFormatConditionCollection* passIn
)
C++/CLI
public:
WebGridFormatConditionCollection^ CopyFrom(
   WebGridFormatConditionCollection^ passIn
)

Parameters

passIn

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridFormatConditionCollection Class
WebGridFormatConditionCollection Members


CopyTo Method

[image]
Intersoft WebGrid Documentation
CopyTo Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridFormatConditionCollection Class : CopyTo Method

array
index

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub CopyTo( _
   ByVal array() As ISNet.WebUI.INamedObject, _
   ByVal index As System.Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As WebGridFormatConditionCollection
Dim array() As ISNet.WebUI.INamedObject
Dim index As System.Integer

instance.CopyTo(array, index)
C#
public void CopyTo(
   ISNet.WebUI.INamedObject[] array,
   System.int index
)
Delphi
public procedure CopyTo(
    array: ISNet.WebUI.INamedObjectarray of;
    index: System.Integer
);
JScript
public function CopyTo(
   array : ISNet.WebUI.INamedObject[],
   index : System.int
);
Managed Extensions for C++
public: void CopyTo(
   ISNet.WebUI.INamedObject*[]* array,
   System.int index
)
C++/CLI
public:
void CopyTo(
   ISNet.WebUI.array<INamedObject^>^ array,
   System.int index
)

Parameters

array
index

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridFormatConditionCollection Class
WebGridFormatConditionCollection Members


Exists Method

[image]
Intersoft WebGrid Documentation
Exists Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridFormatConditionCollection Class : Exists Method

name

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function Exists( _
   ByVal name As System.String _
) As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebGridFormatConditionCollection
Dim name As System.String
Dim value As System.Boolean

value = instance.Exists(name)
C#
public System.bool Exists(
   System.string name
)
Delphi
public function Exists(
    name: System.String
): System.Boolean;
JScript
public function Exists(
   name : System.String
) : System.boolean;
Managed Extensions for C++
public: System.bool Exists(
   System.string* name
)
C++/CLI
public:
System.bool Exists(
   System.String^ name
)

Parameters

name

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridFormatConditionCollection Class
WebGridFormatConditionCollection Members


GetEnumerator Method

[image]
Intersoft WebGrid Documentation
GetEnumerator Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridFormatConditionCollection Class : GetEnumerator Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Shadows Function GetEnumerator() As System.Collections.IEnumerator
Visual Basic (Usage) Copy Code
Dim instance As WebGridFormatConditionCollection
Dim value As System.Collections.IEnumerator

value = instance.GetEnumerator()
C#
public new System.Collections.IEnumerator GetEnumerator()
Delphi
public function GetEnumerator(): System.Collections.IEnumerator;
JScript
public hide function GetEnumerator() : System.Collections.IEnumerator;
Managed Extensions for C++
public: new System.Collections.IEnumerator* GetEnumerator();
C++/CLI
public:
new System.Collections.IEnumerator^ GetEnumerator();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridFormatConditionCollection Class
WebGridFormatConditionCollection Members


GetItem Method

[image]
Intersoft WebGrid Documentation
GetItem Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridFormatConditionCollection Class : GetItem Method

Glossary Item Box

Overload List

Overload | Description
GetItem | (Inherited from ISNet.WebUI.ISCollectionBase)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridFormatConditionCollection Class
WebGridFormatConditionCollection Members


GetItem(Int32) Method

[image]
Intersoft WebGrid Documentation
GetItem(Int32) Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridFormatConditionCollection Class : GetItem(Int32) Method

index

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetItem( _
   ByVal index As System.Integer _
) As ISNet.WebUI.INamedObject
Visual Basic (Usage) Copy Code
Dim instance As WebGridFormatConditionCollection
Dim index As System.Integer
Dim value As ISNet.WebUI.INamedObject

value = instance.GetItem(index)
C#
public virtual ISNet.WebUI.INamedObject GetItem(
   System.int index
)
Delphi
public function GetItem(
    index: System.Integer
): ISNet.WebUI.INamedObject; virtual;
JScript
public function GetItem(
   index : System.int
) : ISNet.WebUI.INamedObject;
Managed Extensions for C++
public: virtual ISNet.WebUI.INamedObject* GetItem(
   System.int index
)
C++/CLI
public:
virtual ISNet.WebUI.INamedObject^ GetItem(
   System.int index
)

Parameters

index

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridFormatConditionCollection Class
WebGridFormatConditionCollection Members


GetNamedItem Method

[image]
Intersoft WebGrid Documentation
GetNamedItem Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridFormatConditionCollection Class : GetNamedItem Method

name

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetNamedItem( _
   ByVal name As System.String _
) As WebGridFormatCondition
Visual Basic (Usage) Copy Code
Dim instance As WebGridFormatConditionCollection
Dim name As System.String
Dim value As WebGridFormatCondition

value = instance.GetNamedItem(name)
C#
public WebGridFormatCondition GetNamedItem(
   System.string name
)
Delphi
public function GetNamedItem(
    name: System.String
): WebGridFormatCondition;
JScript
public function GetNamedItem(
   name : System.String
) : WebGridFormatCondition;
Managed Extensions for C++
public: WebGridFormatCondition* GetNamedItem(
   System.string* name
)
C++/CLI
public:
WebGridFormatCondition^ GetNamedItem(
   System.String^ name
)

Parameters

name

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridFormatConditionCollection Class
WebGridFormatConditionCollection Members


IndexOf Method

[image]
Intersoft WebGrid Documentation
IndexOf Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridFormatConditionCollection Class : IndexOf Method

Glossary Item Box

Overload List

Overload | Description
IndexOf(String) | (Inherited from ISNet.WebUI.ISCollectionBase)
IndexOf(INamedObject) | (Inherited from ISNet.WebUI.ISCollectionBase)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridFormatConditionCollection Class
WebGridFormatConditionCollection Members


IndexOf(String) Method

[image]
Intersoft WebGrid Documentation
IndexOf(String) Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridFormatConditionCollection Class > IndexOf Method : IndexOf(String) Method

name

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function IndexOf( _
   ByVal name As System.String _
) As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebGridFormatConditionCollection
Dim name As System.String
Dim value As System.Integer

value = instance.IndexOf(name)
C#
public virtual System.int IndexOf(
   System.string name
)
Delphi
public function IndexOf(
    name: System.String
): System.Integer; virtual;
JScript
public function IndexOf(
   name : System.String
) : System.int;
Managed Extensions for C++
public: virtual System.int IndexOf(
   System.string* name
)
C++/CLI
public:
virtual System.int IndexOf(
   System.String^ name
)

Parameters

name

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridFormatConditionCollection Class
WebGridFormatConditionCollection Members
Overload List


IndexOf(INamedObject) Method

[image]
Intersoft WebGrid Documentation
IndexOf(INamedObject) Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridFormatConditionCollection Class > IndexOf Method : IndexOf(INamedObject) Method

value

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function IndexOf( _
   ByVal value As ISNet.WebUI.INamedObject _
) As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebGridFormatConditionCollection
Dim value As ISNet.WebUI.INamedObject
Dim value As System.Integer

value = instance.IndexOf(value)
C#
public System.int IndexOf(
   ISNet.WebUI.INamedObject value
)
Delphi
public function IndexOf(
    value: ISNet.WebUI.INamedObject
): System.Integer;
JScript
public function IndexOf(
   value : ISNet.WebUI.INamedObject
) : System.int;
Managed Extensions for C++
public: System.int IndexOf(
   ISNet.WebUI.INamedObject* value
)
C++/CLI
public:
System.int IndexOf(
   ISNet.WebUI.INamedObject^ value
)

Parameters

value

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridFormatConditionCollection Class
WebGridFormatConditionCollection Members
Overload List


Insert Method

[image]
Intersoft WebGrid Documentation
Insert Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridFormatConditionCollection Class : Insert Method

index
webGridFormatCondition

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub Insert( _
   ByVal index As System.Integer, _
   ByVal webGridFormatCondition As WebGridFormatCondition _
)
Visual Basic (Usage) Copy Code
Dim instance As WebGridFormatConditionCollection
Dim index As System.Integer
Dim webGridFormatCondition As WebGridFormatCondition

instance.Insert(index, webGridFormatCondition)
C#
public void Insert(
   System.int index,
   WebGridFormatCondition webGridFormatCondition
)
Delphi
public procedure Insert(
    index: System.Integer;
    webGridFormatCondition: WebGridFormatCondition
);
JScript
public function Insert(
   index : System.int,
   webGridFormatCondition : WebGridFormatCondition
);
Managed Extensions for C++
public: void Insert(
   System.int index,
   WebGridFormatCondition* webGridFormatCondition
)
C++/CLI
public:
void Insert(
   System.int index,
   WebGridFormatCondition^ webGridFormatCondition
)

Parameters

index
webGridFormatCondition

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridFormatConditionCollection Class
WebGridFormatConditionCollection Members


IntInsert Method

[image]
Intersoft WebGrid Documentation
IntInsert Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridFormatConditionCollection Class : IntInsert Method

index
value

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub IntInsert( _
   ByVal index As System.Integer, _
   ByVal value As ISNet.WebUI.INamedObject _
)
Visual Basic (Usage) Copy Code
Dim instance As WebGridFormatConditionCollection
Dim index As System.Integer
Dim value As ISNet.WebUI.INamedObject

instance.IntInsert(index, value)
C#
public void IntInsert(
   System.int index,
   ISNet.WebUI.INamedObject value
)
Delphi
public procedure IntInsert(
    index: System.Integer;
    value: ISNet.WebUI.INamedObject
);
JScript
public function IntInsert(
   index : System.int,
   value : ISNet.WebUI.INamedObject
);
Managed Extensions for C++
public: void IntInsert(
   System.int index,
   ISNet.WebUI.INamedObject* value
)
C++/CLI
public:
void IntInsert(
   System.int index,
   ISNet.WebUI.INamedObject^ value
)

Parameters

index
value

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridFormatConditionCollection Class
WebGridFormatConditionCollection Members


Remove Method

[image]
Intersoft WebGrid Documentation
Remove Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridFormatConditionCollection Class : Remove Method

webGridFormatCondition

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub Remove( _
   ByVal webGridFormatCondition As WebGridFormatCondition _
)
Visual Basic (Usage) Copy Code
Dim instance As WebGridFormatConditionCollection
Dim webGridFormatCondition As WebGridFormatCondition

instance.Remove(webGridFormatCondition)
C#
public void Remove(
   WebGridFormatCondition webGridFormatCondition
)
Delphi
public procedure Remove(
    webGridFormatCondition: WebGridFormatCondition
);
JScript
public function Remove(
   webGridFormatCondition : WebGridFormatCondition
);
Managed Extensions for C++
public: void Remove(
   WebGridFormatCondition* webGridFormatCondition
)
C++/CLI
public:
void Remove(
   WebGridFormatCondition^ webGridFormatCondition
)

Parameters

webGridFormatCondition

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridFormatConditionCollection Class
WebGridFormatConditionCollection Members


setParent Method

[image]
Intersoft WebGrid Documentation
setParent Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridFormatConditionCollection Class : setParent Method

parent

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub setParent( _
   ByVal parent As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebGridFormatConditionCollection
Dim parent As System.Object

instance.setParent(parent)
C#
public virtual void setParent(
   System.object parent
)
Delphi
public procedure setParent(
    parent: System.TObject
); virtual;
JScript
public function setParent(
   parent : System.Object
);
Managed Extensions for C++
public: virtual void setParent(
   System.Object* parent
)
C++/CLI
public:
virtual void setParent(
   System.Object^ parent
)

Parameters

parent

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridFormatConditionCollection Class
WebGridFormatConditionCollection Members


Capacity Property

[image]
Intersoft WebGrid Documentation
Capacity Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridFormatConditionCollection Class : Capacity Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Runtime.InteropServices.ComVisibleAttribute(False)>
Public Property Capacity As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebGridFormatConditionCollection
Dim value As System.Integer

instance.Capacity = value

value = instance.Capacity
C#
[System.Runtime.InteropServices.ComVisibleAttribute(false)]
public System.int Capacity {get; set;}
Delphi
public read-write property Capacity: System.Integer;
JScript
System.Runtime.InteropServices.ComVisibleAttribute()
public function get,set Capacity : System.int
Managed Extensions for C++
[System.Runtime.InteropServices.ComVisibleAttribute(false)]
public: __property System.int get_Capacity();
public: __property void set_Capacity(
   System.int value
);
C++/CLI
[System.Runtime.InteropServices.ComVisibleAttribute(false)]
public:
property System.int Capacity {
   System.int get();
   void set (    System.int value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridFormatConditionCollection Class
WebGridFormatConditionCollection Members


Count Property

[image]
Intersoft WebGrid Documentation
Count Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridFormatConditionCollection Class : Count Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Count As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebGridFormatConditionCollection
Dim value As System.Integer

value = instance.Count
C#
public System.int Count {get;}
Delphi
public read-only property Count: System.Integer;
JScript
public function get Count : System.int
Managed Extensions for C++
public: __property System.int get_Count();
C++/CLI
public:
property System.int Count {
   System.int get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridFormatConditionCollection Class
WebGridFormatConditionCollection Members


WebGridFormatConditionCollection Class Properties

[image]
Intersoft WebGrid Documentation
WebGridFormatConditionCollection Class Properties
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : WebGridFormatConditionCollection Class

Glossary Item Box

For a list of all members of this type, see WebGridFormatConditionCollection members.

Public Properties

 | Name | Description
Public Property | Capacity | (Inherited from System.Collections.CollectionBase)
Public Property | Count | (Inherited from System.Collections.CollectionBase)
Public Property | IsReadOnly | Overridden.
Public Property | Item |
Public Property | Parent | (Inherited from ISNet.WebUI.ISCollectionBase)
Top

See Also

Reference

WebGridFormatConditionCollection Class
ISNet.WebUI.WebGrid Namespace


WebGridFormatConditionCollection Constructor

[image]
Intersoft WebGrid Documentation
WebGridFormatConditionCollection Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridFormatConditionCollection Class : WebGridFormatConditionCollection Constructor

Glossary Item Box

Overload List

Overload | Description
WebGridFormatConditionCollection Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridFormatConditionCollection Class
WebGridFormatConditionCollection Members


IsReadOnly Property

[image]
Intersoft WebGrid Documentation
IsReadOnly Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridFormatConditionCollection Class : IsReadOnly Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property IsReadOnly As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebGridFormatConditionCollection
Dim value As System.Boolean

value = instance.IsReadOnly
C#
public override System.bool IsReadOnly {get;}
Delphi
public read-only property IsReadOnly: System.Boolean; override;
JScript
public override function get IsReadOnly : System.boolean
Managed Extensions for C++
public: __property System.bool get_IsReadOnly() override;
C++/CLI
public:
property System.bool IsReadOnly {
   System.bool get() override;
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridFormatConditionCollection Class
WebGridFormatConditionCollection Members


Item Property

[image]
Intersoft WebGrid Documentation
Item Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridFormatConditionCollection Class : Item Property

index

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Default Property Item( _
   ByVal index As System.Integer _
) As WebGridFormatCondition
Visual Basic (Usage) Copy Code
Dim instance As WebGridFormatConditionCollection
Dim index As System.Integer
Dim value As WebGridFormatCondition

value = instance.Item(index)
C#
public WebGridFormatCondition this[
   System.int index
]; {get;}
Delphi
public  this: : WebGridFormatCondition;[
    index: System.Integer
]; read-only
JScript
public  this[
   index : System.int
] get : WebGridFormatCondition
Managed Extensions for C++
public: __property WebGridFormatCondition* get_Item   System.int index
;
C++/CLI
public:
property WebGridFormatCondition^ default [int] {
   WebGridFormatCondition^ get(System.int index);
}

Parameters

index

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridFormatConditionCollection Class
WebGridFormatConditionCollection Members


Parent Property

[image]
Intersoft WebGrid Documentation
Parent Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridFormatConditionCollection Class : Parent Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Parent As System.Object
Visual Basic (Usage) Copy Code
Dim instance As WebGridFormatConditionCollection
Dim value As System.Object

value = instance.Parent
C#
public System.object Parent {get;}
Delphi
public read-only property Parent: System.TObject;
JScript
public function get Parent : System.Object
Managed Extensions for C++
public: __property System.Object* get_Parent();
C++/CLI
public:
property System.Object^ Parent {
   System.Object^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridFormatConditionCollection Class
WebGridFormatConditionCollection Members


WebGridFormatStyle Class

[image]
Intersoft WebGrid Documentation
WebGridFormatStyle Class
Members See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : WebGridFormatStyle Class

Glossary Item Box

Object Model

WebGridFormatStyle Class

Syntax

Visual Basic (Declaration)
<System.SerializableAttribute()>
Public Class WebGridFormatStyle
   Inherits ISNet.WebUI.WebStyle
   Implements ISNet.ICopyable, ISNet.IEmpty, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.Serialization.XmlSerialization.IXmlLayoutSerialize
Visual Basic (Usage) Copy Code
Dim instance As WebGridFormatStyle
C#
[System.SerializableAttribute()]
public class WebGridFormatStyle : ISNet.WebUI.WebStyle, ISNet.ICopyable, ISNet.IEmpty, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.Serialization.XmlSerialization.IXmlLayoutSerialize
Delphi
public class WebGridFormatStyle = class(ISNet.WebUI.WebStyle, ISNet.ICopyable, ISNet.IEmpty, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.Serialization.XmlSerialization.IXmlLayoutSerialize)
JScript
System.SerializableAttribute()
public class WebGridFormatStyle extends ISNet.WebUI.WebStyle implements ISNet.ICopyable, ISNet.IEmpty, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.Serialization.XmlSerialization.IXmlLayoutSerialize
Managed Extensions for C++
[System.SerializableAttribute()]
public __gc class WebGridFormatStyle : public ISNet.WebUI.WebStyle, ISNet.ICopyable, ISNet.IEmpty, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.Serialization.XmlSerialization.IXmlLayoutSerialize
C++/CLI
[System.SerializableAttribute()]
public ref class WebGridFormatStyle : public ISNet.WebUI.WebStyle, ISNet.ICopyable, ISNet.IEmpty, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.Serialization.XmlSerialization.IXmlLayoutSerialize

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Web.UI.WebControls.Style
ISNet.WebUI.WebStyle
ISNet.WebUI.WebGrid.WebGridFormatStyle

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridFormatStyle Members
ISNet.WebUI.WebGrid Namespace


WebGridFormatStyle Class Members

[image]
Intersoft WebGrid Documentation
WebGridFormatStyle Class Members
See Also Fields Properties Methods Send Feedback
ISNet.WebUI.WebGrid Namespace : WebGridFormatStyle Class

Glossary Item Box

The following tables list the members exposed by WebGridFormatStyle.

Public Constructors

 | Name | Description
Public Constructor | WebGridFormatStyle Constructor |
Top

Public Fields

 | Name | Description
Public Field | dynamicStyle | (Inherited from ISNet.WebUI.WebStyle)
Public Field | layoutKey | (Inherited from ISNet.WebUI.WebStyle)
Public Field | styleState | (Inherited from ISNet.WebUI.WebStyle)
Top

Public Properties

 | Name | Description
Public Property | BackColor | (Inherited from ISNet.WebUI.WebStyle)
Public Property | BackColor2 | (Inherited from ISNet.WebUI.WebStyle)
Public Property | BackgroundImage | (Inherited from ISNet.WebUI.WebStyle)
Public Property | BaseStyle | (Inherited from ISNet.WebUI.WebStyle)
Public Property | BorderColor | (Inherited from ISNet.WebUI.WebStyle)
Public Property | BorderSettings | (Inherited from ISNet.WebUI.WebStyle)
Public Property | BorderStyle | (Inherited from ISNet.WebUI.WebStyle)
Public Property | BorderWidth | (Inherited from ISNet.WebUI.WebStyle)
Public Property | CssClass | (Inherited from ISNet.WebUI.WebStyle)
Public Property | Cursor | (Inherited from ISNet.WebUI.WebStyle)
Public Property | CustomRules | (Inherited from ISNet.WebUI.WebStyle)
Public Property | Font | (Inherited from ISNet.WebUI.WebStyle)
Public Property | ForeColor | (Inherited from ISNet.WebUI.WebStyle)
Public Property | GradientType | (Inherited from ISNet.WebUI.WebStyle)
Public Property | Height | (Inherited from ISNet.WebUI.WebStyle)
Public Property | HorizontalAlign | (Inherited from ISNet.WebUI.WebStyle)
Public Property | Margin | (Inherited from ISNet.WebUI.WebStyle)
Public Property | Overflow | Overridden.
Public Property | OverflowX | Overridden.
Public Property | OverflowY | Overridden.
Public Property | Padding | (Inherited from ISNet.WebUI.WebStyle)
Public Property | VerticalAlign | (Inherited from ISNet.WebUI.WebStyle)
Public Property | Width | (Inherited from ISNet.WebUI.WebStyle)
Public Property | Wrap |
Top

Public Methods

 | Name | Description
Public Method | AddAttributesToRender | Overloaded. (Inherited from System.Web.UI.WebControls.Style)
Public Method | Clone | (Inherited from ISNet.WebUI.WebStyle)
Public Method | CopyFrom | Overloaded. Overridden.
Public Method | CopyFromNative | (Inherited from ISNet.WebUI.WebStyle)
Public Method | CopyMerge | (Inherited from ISNet.WebUI.WebStyle)
Public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebStyle)
Public Method | Dispose | (Inherited from System.ComponentModel.Component)
Public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | GetMergedCssStyleName | (Inherited from ISNet.WebUI.WebStyle)
Public Method | GetObjectData | (Inherited from ISNet.WebUI.WebStyle)
Public Method | GetStyleAttributes | (Inherited from System.Web.UI.WebControls.Style)
Public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | IsEmpty | Overridden.
Public Method | IsFontEmpty | (Inherited from ISNet.WebUI.WebStyle)
Public Method | IsStyleEmpty | Overridden.
Public Method | MergeWith | (Inherited from System.Web.UI.WebControls.Style)
static (Shared in Visual Basic) | Parse |
Public Method | Reset | Overridden.
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebStyle)
Public Method | SetDirty | (Inherited from System.Web.UI.WebControls.Style)
Public Method | ToString | (Inherited from ISNet.WebUI.WebStyle)
Top

See Also

Reference

WebGridFormatStyle Class
ISNet.WebUI.WebGrid Namespace


WebGridFormatStyle Class Fields

[image]
Intersoft WebGrid Documentation
WebGridFormatStyle Class Fields
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : WebGridFormatStyle Class

Glossary Item Box

For a list of all members of this type, see WebGridFormatStyle members.

Public Fields

 | Name | Description
Public Field | dynamicStyle | (Inherited from ISNet.WebUI.WebStyle)
Public Field | layoutKey | (Inherited from ISNet.WebUI.WebStyle)
Public Field | styleState | (Inherited from ISNet.WebUI.WebStyle)
Top

See Also

Reference

WebGridFormatStyle Class
ISNet.WebUI.WebGrid Namespace


WebGridFormatStyle Constructor

[image]
Intersoft WebGrid Documentation
WebGridFormatStyle Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridFormatStyle Class : WebGridFormatStyle Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebGridFormatStyle()
C#
public WebGridFormatStyle()
Delphi
public WebGridFormatStyle();
JScript
public function WebGridFormatStyle();
Managed Extensions for C++
public: WebGridFormatStyle();
C++/CLI
public:
WebGridFormatStyle();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridFormatStyle Class
WebGridFormatStyle Members


AddAttributesToRender Method

[image]
Intersoft WebGrid Documentation
AddAttributesToRender Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridFormatStyle Class : AddAttributesToRender Method

Glossary Item Box

Overload List

Overload | Description
AddAttributesToRender(HtmlTextWriter) | (Inherited from System.Web.UI.WebControls.Style)
AddAttributesToRender(HtmlTextWriter,WebControl) | (Inherited from System.Web.UI.WebControls.Style)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridFormatStyle Class
WebGridFormatStyle Members


AddAttributesToRender(HtmlTextWriter) Method

[image]
Intersoft WebGrid Documentation
AddAttributesToRender(HtmlTextWriter) Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridFormatStyle Class > AddAttributesToRender Method : AddAttributesToRender(HtmlTextWriter) Method

writer

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")>
Public Overloads Sub AddAttributesToRender( _
   ByVal writer As System.Web.UI.HtmlTextWriter _
)
Visual Basic (Usage) Copy Code
Dim instance As WebGridFormatStyle
Dim writer As System.Web.UI.HtmlTextWriter

instance.AddAttributesToRender(writer)
C#
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public void AddAttributesToRender(
   System.Web.UI.HtmlTextWriter writer
)
Delphi
public procedure AddAttributesToRender(
    writer: System.Web.UI.HtmlTextWriter
);
JScript
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")
public function AddAttributesToRender(
   writer : System.Web.UI.HtmlTextWriter
);
Managed Extensions for C++
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public: void AddAttributesToRender(
   System.Web.UI.HtmlTextWriter* writer
)
C++/CLI
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public:
void AddAttributesToRender(
   System.Web.UI.HtmlTextWriter^ writer
)

Parameters

writer

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridFormatStyle Class
WebGridFormatStyle Members
Overload List


AddAttributesToRender(HtmlTextWriter,WebControl) Method

[image]
Intersoft WebGrid Documentation
AddAttributesToRender(HtmlTextWriter,WebControl) Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridFormatStyle Class > AddAttributesToRender Method : AddAttributesToRender(HtmlTextWriter,WebControl) Method

writer
owner

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub AddAttributesToRender( _
   ByVal writer As System.Web.UI.HtmlTextWriter, _
   ByVal owner As System.Web.UI.WebControls.WebControl _
)
Visual Basic (Usage) Copy Code
Dim instance As WebGridFormatStyle
Dim writer As System.Web.UI.HtmlTextWriter
Dim owner As System.Web.UI.WebControls.WebControl

instance.AddAttributesToRender(writer, owner)
C#
public virtual void AddAttributesToRender(
   System.Web.UI.HtmlTextWriter writer,
   System.Web.UI.WebControls.WebControl owner
)
Delphi
public procedure AddAttributesToRender(
    writer: System.Web.UI.HtmlTextWriter;
    owner: System.Web.UI.WebControls.WebControl
); virtual;
JScript
public function AddAttributesToRender(
   writer : System.Web.UI.HtmlTextWriter,
   owner : System.Web.UI.WebControls.WebControl
);
Managed Extensions for C++
public: virtual void AddAttributesToRender(
   System.Web.UI.HtmlTextWriter* writer,
   System.Web.UI.WebControls.WebControl* owner
)
C++/CLI
public:
virtual void AddAttributesToRender(
   System.Web.UI.HtmlTextWriter^ writer,
   System.Web.UI.WebControls.WebControl^ owner
)

Parameters

writer
owner

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridFormatStyle Class
WebGridFormatStyle Members
Overload List


Clone Method

[image]
Intersoft WebGrid Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridFormatStyle Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function Clone() As System.Object
Visual Basic (Usage) Copy Code
Dim instance As WebGridFormatStyle
Dim value As System.Object

value = instance.Clone()
C#
public System.object Clone()
Delphi
public function Clone(): System.TObject;
JScript
public function Clone() : System.Object;
Managed Extensions for C++
public: System.Object* Clone();
C++/CLI
public:
System.Object^ Clone();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridFormatStyle Class
WebGridFormatStyle Members


WebGridFormatStyle Class Methods

[image]
Intersoft WebGrid Documentation
WebGridFormatStyle Class Methods
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : WebGridFormatStyle Class

Glossary Item Box

For a list of all members of this type, see WebGridFormatStyle members.

Public Methods

 | Name | Description
Public Method | AddAttributesToRender | Overloaded. (Inherited from System.Web.UI.WebControls.Style)
Public Method | Clone | (Inherited from ISNet.WebUI.WebStyle)
Public Method | CopyFrom | Overloaded. Overridden.
Public Method | CopyFromNative | (Inherited from ISNet.WebUI.WebStyle)
Public Method | CopyMerge | (Inherited from ISNet.WebUI.WebStyle)
Public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebStyle)
Public Method | Dispose | (Inherited from System.ComponentModel.Component)
Public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | GetMergedCssStyleName | (Inherited from ISNet.WebUI.WebStyle)
Public Method | GetObjectData | (Inherited from ISNet.WebUI.WebStyle)
Public Method | GetStyleAttributes | (Inherited from System.Web.UI.WebControls.Style)
Public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | IsEmpty | Overridden.
Public Method | IsFontEmpty | (Inherited from ISNet.WebUI.WebStyle)
Public Method | IsStyleEmpty | Overridden.
Public Method | MergeWith | (Inherited from System.Web.UI.WebControls.Style)
static (Shared in Visual Basic) | Parse |
Public Method | Reset | Overridden.
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebStyle)
Public Method | SetDirty | (Inherited from System.Web.UI.WebControls.Style)
Public Method | ToString | (Inherited from ISNet.WebUI.WebStyle)
Top

See Also

Reference

WebGridFormatStyle Class
ISNet.WebUI.WebGrid Namespace


CopyFrom Method

[image]
Intersoft WebGrid Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridFormatStyle Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Style) |
CopyFrom(Object) |
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebStyle)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridFormatStyle Class
WebGridFormatStyle Members


CopyFrom(Style) Method

[image]
Intersoft WebGrid Documentation
CopyFrom(Style) Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridFormatStyle Class > CopyFrom Method : CopyFrom(Style) Method

style

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Sub CopyFrom( _
   ByVal style As System.Web.UI.WebControls.Style _
)
Visual Basic (Usage) Copy Code
Dim instance As WebGridFormatStyle
Dim style As System.Web.UI.WebControls.Style

instance.CopyFrom(style)
C#
public override void CopyFrom(
   System.Web.UI.WebControls.Style style
)
Delphi
public procedure CopyFrom(
    style: System.Web.UI.WebControls.Style
); override;
JScript
public override function CopyFrom(
   style : System.Web.UI.WebControls.Style
);
Managed Extensions for C++
public: void CopyFrom(
   System.Web.UI.WebControls.Style* style
) override
C++/CLI
public:
void CopyFrom(
   System.Web.UI.WebControls.Style^ style
) override

Parameters

style

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridFormatStyle Class
WebGridFormatStyle Members
Overload List


CopyFrom(Object) Method

[image]
Intersoft WebGrid Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridFormatStyle Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Sub CopyFrom( _
   ByVal objSource As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebGridFormatStyle
Dim objSource As System.Object

instance.CopyFrom(objSource)
C#
public override void CopyFrom(
   System.object objSource
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject
); override;
JScript
public override function CopyFrom(
   objSource : System.Object
);
Managed Extensions for C++
public: void CopyFrom(
   System.Object* objSource
) override
C++/CLI
public:
void CopyFrom(
   System.Object^ objSource
) override

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridFormatStyle Class
WebGridFormatStyle Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebGrid Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridFormatStyle Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object, _
   ByVal cloneSourceValue As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebGridFormatStyle
Dim objSource As System.Object
Dim cloneSourceValue As System.Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   System.object objSource,
   System.bool cloneSourceValue
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject;
    cloneSourceValue: System.Boolean
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object,
   cloneSourceValue : System.boolean
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource,
   System.bool cloneSourceValue
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource,
   System.bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridFormatStyle Class
WebGridFormatStyle Members
Overload List


CopyFromNative Method

[image]
Intersoft WebGrid Documentation
CopyFromNative Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridFormatStyle Class : CopyFromNative Method

s

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub CopyFromNative( _
   ByVal s As ISNet.WebUI.WebStyle _
)
Visual Basic (Usage) Copy Code
Dim instance As WebGridFormatStyle
Dim s As ISNet.WebUI.WebStyle

instance.CopyFromNative(s)
C#
public virtual void CopyFromNative(
   ISNet.WebUI.WebStyle s
)
Delphi
public procedure CopyFromNative(
    s: ISNet.WebUI.WebStyle
); virtual;
JScript
public function CopyFromNative(
   s : ISNet.WebUI.WebStyle
);
Managed Extensions for C++
public: virtual void CopyFromNative(
   ISNet.WebUI.WebStyle* s
)
C++/CLI
public:
virtual void CopyFromNative(
   ISNet.WebUI.WebStyle^ s
)

Parameters

s

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridFormatStyle Class
WebGridFormatStyle Members


CopyMerge Method

[image]
Intersoft WebGrid Documentation
CopyMerge Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridFormatStyle Class : CopyMerge Method

style

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub CopyMerge( _
   ByVal style As ISNet.WebUI.WebStyle _
)
Visual Basic (Usage) Copy Code
Dim instance As WebGridFormatStyle
Dim style As ISNet.WebUI.WebStyle

instance.CopyMerge(style)
C#
public void CopyMerge(
   ISNet.WebUI.WebStyle style
)
Delphi
public procedure CopyMerge(
    style: ISNet.WebUI.WebStyle
);
JScript
public function CopyMerge(
   style : ISNet.WebUI.WebStyle
);
Managed Extensions for C++
public: void CopyMerge(
   ISNet.WebUI.WebStyle* style
)
C++/CLI
public:
void CopyMerge(
   ISNet.WebUI.WebStyle^ style
)

Parameters

style

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridFormatStyle Class
WebGridFormatStyle Members


CreateObjRef Method

[image]
Intersoft WebGrid Documentation
CreateObjRef Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridFormatStyle Class : CreateObjRef Method

requestedType

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Security.SecurityCriticalAttribute()>
Public Overridable Function CreateObjRef( _
   ByVal requestedType As System.Type _
) As System.Runtime.Remoting.ObjRef
Visual Basic (Usage) Copy Code
Dim instance As WebGridFormatStyle
Dim requestedType As System.Type
Dim value As System.Runtime.Remoting.ObjRef

value = instance.CreateObjRef(requestedType)
C#
[System.Security.SecurityCriticalAttribute()]
public virtual System.Runtime.Remoting.ObjRef CreateObjRef(
   System.Type requestedType
)
Delphi
public function CreateObjRef(
    requestedType: System.Type
): System.Runtime.Remoting.ObjRef; virtual;
JScript
System.Security.SecurityCriticalAttribute()
public function CreateObjRef(
   requestedType : System.Type
) : System.Runtime.Remoting.ObjRef;
Managed Extensions for C++
[System.Security.SecurityCriticalAttribute()]
public: virtual System.Runtime.Remoting.ObjRef* CreateObjRef(
   System.Type* requestedType
)
C++/CLI
[System.Security.SecurityCriticalAttribute()]
public:
virtual System.Runtime.Remoting.ObjRef^ CreateObjRef(
   System.Type^ requestedType
)

Parameters

requestedType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridFormatStyle Class
WebGridFormatStyle Members


DeSerializeObjectData Method

[image]
Intersoft WebGrid Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridFormatStyle Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebGridFormatStyle
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure DeSerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function DeSerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void DeSerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void DeSerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridFormatStyle Class
WebGridFormatStyle Members


Dispose Method

[image]
Intersoft WebGrid Documentation
Dispose Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridFormatStyle Class : Dispose Method

Glossary Item Box

Overload List

Overload | Description
Dispose | (Inherited from System.ComponentModel.Component)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridFormatStyle Class
WebGridFormatStyle Members


Dispose() Method

[image]
Intersoft WebGrid Documentation
Dispose() Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridFormatStyle Class : Dispose() Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub Dispose()
Visual Basic (Usage) Copy Code
Dim instance As WebGridFormatStyle

instance.Dispose()
C#
public void Dispose()
Delphi
public procedure Dispose();
JScript
public function Dispose();
Managed Extensions for C++
public: void Dispose();
C++/CLI
public:
void Dispose();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridFormatStyle Class
WebGridFormatStyle Members


GetLifetimeService Method

[image]
Intersoft WebGrid Documentation
GetLifetimeService Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridFormatStyle Class : GetLifetimeService Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Security.SecurityCriticalAttribute()>
Public Function GetLifetimeService() As System.Object
Visual Basic (Usage) Copy Code
Dim instance As WebGridFormatStyle
Dim value As System.Object

value = instance.GetLifetimeService()
C#
[System.Security.SecurityCriticalAttribute()]
public System.object GetLifetimeService()
Delphi
public function GetLifetimeService(): System.TObject;
JScript
System.Security.SecurityCriticalAttribute()
public function GetLifetimeService() : System.Object;
Managed Extensions for C++
[System.Security.SecurityCriticalAttribute()]
public: System.Object* GetLifetimeService();
C++/CLI
[System.Security.SecurityCriticalAttribute()]
public:
System.Object^ GetLifetimeService();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridFormatStyle Class
WebGridFormatStyle Members


GetMergedCssStyleName Method

[image]
Intersoft WebGrid Documentation
GetMergedCssStyleName Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridFormatStyle Class : GetMergedCssStyleName Method

finalKey

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetMergedCssStyleName( _
   ByVal finalKey As System.String _
) As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebGridFormatStyle
Dim finalKey As System.String
Dim value As System.String

value = instance.GetMergedCssStyleName(finalKey)
C#
public System.string GetMergedCssStyleName(
   System.string finalKey
)
Delphi
public function GetMergedCssStyleName(
    finalKey: System.String
): System.String;
JScript
public function GetMergedCssStyleName(
   finalKey : System.String
) : System.String;
Managed Extensions for C++
public: System.string* GetMergedCssStyleName(
   System.string* finalKey
)
C++/CLI
public:
System.String^ GetMergedCssStyleName(
   System.String^ finalKey
)

Parameters

finalKey

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridFormatStyle Class
WebGridFormatStyle Members


GetObjectData Method

[image]
Intersoft WebGrid Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridFormatStyle Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebGridFormatStyle
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
public virtual void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure GetObjectData(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
); virtual;
JScript
public function GetObjectData(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: virtual void GetObjectData(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
virtual void GetObjectData(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridFormatStyle Class
WebGridFormatStyle Members


GetStyleAttributes Method

[image]
Intersoft WebGrid Documentation
GetStyleAttributes Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridFormatStyle Class : GetStyleAttributes Method

urlResolver

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetStyleAttributes( _
   ByVal urlResolver As System.Web.UI.IUrlResolutionService _
) As System.Web.UI.CssStyleCollection
Visual Basic (Usage) Copy Code
Dim instance As WebGridFormatStyle
Dim urlResolver As System.Web.UI.IUrlResolutionService
Dim value As System.Web.UI.CssStyleCollection

value = instance.GetStyleAttributes(urlResolver)
C#
public System.Web.UI.CssStyleCollection GetStyleAttributes(
   System.Web.UI.IUrlResolutionService urlResolver
)
Delphi
public function GetStyleAttributes(
    urlResolver: System.Web.UI.IUrlResolutionService
): System.Web.UI.CssStyleCollection;
JScript
public function GetStyleAttributes(
   urlResolver : System.Web.UI.IUrlResolutionService
) : System.Web.UI.CssStyleCollection;
Managed Extensions for C++
public: System.Web.UI.CssStyleCollection* GetStyleAttributes(
   System.Web.UI.IUrlResolutionService* urlResolver
)
C++/CLI
public:
System.Web.UI.CssStyleCollection^ GetStyleAttributes(
   System.Web.UI.IUrlResolutionService^ urlResolver
)

Parameters

urlResolver

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridFormatStyle Class
WebGridFormatStyle Members


InitializeLifetimeService Method

[image]
Intersoft WebGrid Documentation
InitializeLifetimeService Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridFormatStyle Class : InitializeLifetimeService Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Security.SecurityCriticalAttribute()>
Public Overridable Function InitializeLifetimeService() As System.Object
Visual Basic (Usage) Copy Code
Dim instance As WebGridFormatStyle
Dim value As System.Object

value = instance.InitializeLifetimeService()
C#
[System.Security.SecurityCriticalAttribute()]
public virtual System.object InitializeLifetimeService()
Delphi
public function InitializeLifetimeService(): System.TObject; virtual;
JScript
System.Security.SecurityCriticalAttribute()
public function InitializeLifetimeService() : System.Object;
Managed Extensions for C++
[System.Security.SecurityCriticalAttribute()]
public: virtual System.Object* InitializeLifetimeService();
C++/CLI
[System.Security.SecurityCriticalAttribute()]
public:
virtual System.Object^ InitializeLifetimeService();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridFormatStyle Class
WebGridFormatStyle Members


IsEmpty Method

[image]
Intersoft WebGrid Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridFormatStyle Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Function IsEmpty() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebGridFormatStyle
Dim value As System.Boolean

value = instance.IsEmpty()
C#
public override System.bool IsEmpty()
Delphi
public function IsEmpty(): System.Boolean; override;
JScript
public override function IsEmpty() : System.boolean;
Managed Extensions for C++
public: System.bool IsEmpty(); override
C++/CLI
public:
System.bool IsEmpty(); override

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridFormatStyle Class
WebGridFormatStyle Members


IsFontEmpty Method

[image]
Intersoft WebGrid Documentation
IsFontEmpty Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridFormatStyle Class : IsFontEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsFontEmpty() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebGridFormatStyle
Dim value As System.Boolean

value = instance.IsFontEmpty()
C#
public virtual System.bool IsFontEmpty()
Delphi
public function IsFontEmpty(): System.Boolean; virtual;
JScript
public function IsFontEmpty() : System.boolean;
Managed Extensions for C++
public: virtual System.bool IsFontEmpty();
C++/CLI
public:
virtual System.bool IsFontEmpty();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridFormatStyle Class
WebGridFormatStyle Members


IsStyleEmpty Method

[image]
Intersoft WebGrid Documentation
IsStyleEmpty Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridFormatStyle Class : IsStyleEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Function IsStyleEmpty() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebGridFormatStyle
Dim value As System.Boolean

value = instance.IsStyleEmpty()
C#
public override System.bool IsStyleEmpty()
Delphi
public function IsStyleEmpty(): System.Boolean; override;
JScript
public override function IsStyleEmpty() : System.boolean;
Managed Extensions for C++
public: System.bool IsStyleEmpty(); override
C++/CLI
public:
System.bool IsStyleEmpty(); override

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridFormatStyle Class
WebGridFormatStyle Members


MergeWith Method

[image]
Intersoft WebGrid Documentation
MergeWith Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridFormatStyle Class : MergeWith Method

s

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub MergeWith( _
   ByVal s As System.Web.UI.WebControls.Style _
)
Visual Basic (Usage) Copy Code
Dim instance As WebGridFormatStyle
Dim s As System.Web.UI.WebControls.Style

instance.MergeWith(s)
C#
public virtual void MergeWith(
   System.Web.UI.WebControls.Style s
)
Delphi
public procedure MergeWith(
    s: System.Web.UI.WebControls.Style
); virtual;
JScript
public function MergeWith(
   s : System.Web.UI.WebControls.Style
);
Managed Extensions for C++
public: virtual void MergeWith(
   System.Web.UI.WebControls.Style* s
)
C++/CLI
public:
virtual void MergeWith(
   System.Web.UI.WebControls.Style^ s
)

Parameters

s

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridFormatStyle Class
WebGridFormatStyle Members


Parse Method

[image]
Intersoft WebGrid Documentation
Parse Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridFormatStyle Class : Parse Method

style

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Shared Shadows Function Parse( _
   ByVal style As System.String _
) As WebGridFormatStyle
Visual Basic (Usage) Copy Code
Dim style As System.String
Dim value As WebGridFormatStyle

value = WebGridFormatStyle.Parse(style)
C#
public new static WebGridFormatStyle Parse(
   System.string style
)
Delphi
public function Parse(
    style: System.String
): WebGridFormatStyle; static;
JScript
public hide static function Parse(
   style : System.String
) : WebGridFormatStyle;
Managed Extensions for C++
public: new static WebGridFormatStyle* Parse(
   System.string* style
)
C++/CLI
public:
new static WebGridFormatStyle^ Parse(
   System.String^ style
)

Parameters

style

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridFormatStyle Class
WebGridFormatStyle Members


Reset Method

[image]
Intersoft WebGrid Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridFormatStyle Class : Reset Method

Glossary Item Box

Overload List

Overload | Description
Reset |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridFormatStyle Class
WebGridFormatStyle Members


Reset() Method

[image]
Intersoft WebGrid Documentation
Reset() Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridFormatStyle Class : Reset() Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As WebGridFormatStyle

instance.Reset()
C#
public override void Reset()
Delphi
public procedure Reset(); override;
JScript
public override function Reset();
Managed Extensions for C++
public: void Reset(); override
C++/CLI
public:
void Reset(); override

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridFormatStyle Class
WebGridFormatStyle Members


SerializeObjectData Method

[image]
Intersoft WebGrid Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridFormatStyle Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebGridFormatStyle
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure SerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function SerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void SerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void SerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridFormatStyle Class
WebGridFormatStyle Members


SetDirty Method

[image]
Intersoft WebGrid Documentation
SetDirty Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridFormatStyle Class : SetDirty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SetDirty()
Visual Basic (Usage) Copy Code
Dim instance As WebGridFormatStyle

instance.SetDirty()
C#
public void SetDirty()
Delphi
public procedure SetDirty();
JScript
public function SetDirty();
Managed Extensions for C++
public: void SetDirty();
C++/CLI
public:
void SetDirty();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridFormatStyle Class
WebGridFormatStyle Members


ToString Method

[image]
Intersoft WebGrid Documentation
ToString Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridFormatStyle Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebGridFormatStyle
Dim value As System.String

value = instance.ToString()
C#
public virtual System.string ToString()
Delphi
public function ToString(): System.String; virtual;
JScript
public function ToString() : System.String;
Managed Extensions for C++
public: virtual System.string* ToString();
C++/CLI
public:
virtual System.String^ ToString();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridFormatStyle Class
WebGridFormatStyle Members


BackColor Property

[image]
Intersoft WebGrid Documentation
BackColor Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridFormatStyle Class : BackColor Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Appearance")>
<ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.Layout)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Overridable Property BackColor As System.Drawing.Color
Visual Basic (Usage) Copy Code
Dim instance As WebGridFormatStyle
Dim value As System.Drawing.Color

instance.BackColor = value

value = instance.BackColor
C#
[System.ComponentModel.CategoryAttribute("Appearance")]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.Layout)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
public virtual System.Drawing.Color BackColor {get; set;}
Delphi
public read-write property BackColor: System.Drawing.Color; virtual;
JScript
System.ComponentModel.CategoryAttribute("Appearance")
ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.Layout)
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get,set BackColor : System.Drawing.Color
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Appearance")]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.Layout)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property virtual System.Drawing.Color get_BackColor();
public: __property virtual void set_BackColor(
   System.Drawing.Color value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Appearance")]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.Layout)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
virtual property System.Drawing.Color BackColor {
   System.Drawing.Color get();
   void set (    System.Drawing.Color value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridFormatStyle Class
WebGridFormatStyle Members


BackColor2 Property

[image]
Intersoft WebGrid Documentation
BackColor2 Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridFormatStyle Class : BackColor2 Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.Layout)>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Appearance")>
<System.ComponentModel.DescriptionAttribute("End background color of the controls applied with this style. When specified, gradient back color will be rendered from BackColor to BackColor2.")>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Overridable Property BackColor2 As System.Drawing.Color
Visual Basic (Usage) Copy Code
Dim instance As WebGridFormatStyle
Dim value As System.Drawing.Color

instance.BackColor2 = value

value = instance.BackColor2
C#
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.Layout)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.DescriptionAttribute("End background color of the controls applied with this style. When specified, gradient back color will be rendered from BackColor to BackColor2.")]
[ISNet.Serialization.BinarySerializableAttribute()]
public virtual System.Drawing.Color BackColor2 {get; set;}
Delphi
public read-write property BackColor2: System.Drawing.Color; virtual;
JScript
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.Layout)
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Appearance")
System.ComponentModel.DescriptionAttribute("End background color of the controls applied with this style. When specified, gradient back color will be rendered from BackColor to BackColor2.")
ISNet.Serialization.BinarySerializableAttribute()
public function get,set BackColor2 : System.Drawing.Color
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.Layout)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.DescriptionAttribute("End background color of the controls applied with this style. When specified, gradient back color will be rendered from BackColor to BackColor2.")]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property virtual System.Drawing.Color get_BackColor2();
public: __property virtual void set_BackColor2(
   System.Drawing.Color value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.Layout)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.DescriptionAttribute("End background color of the controls applied with this style. When specified, gradient back color will be rendered from BackColor to BackColor2.")]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
virtual property System.Drawing.Color BackColor2 {
   System.Drawing.Color get();
   void set (    System.Drawing.Color value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridFormatStyle Class
WebGridFormatStyle Members


BackgroundImage Property

[image]
Intersoft WebGrid Documentation
BackgroundImage Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridFormatStyle Class : BackgroundImage Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.Layout)>
<System.ComponentModel.CategoryAttribute("Images")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Determines the file name of an image to be displayed in the background of the object associated with the style.")>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Overridable Property BackgroundImage As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebGridFormatStyle
Dim value As System.String

instance.BackgroundImage = value

value = instance.BackgroundImage
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.Layout)]
[System.ComponentModel.CategoryAttribute("Images")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Determines the file name of an image to be displayed in the background of the object associated with the style.")]
[ISNet.Serialization.BinarySerializableAttribute()]
public virtual System.string BackgroundImage {get; set;}
Delphi
public read-write property BackgroundImage: System.String; virtual;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.Layout)
System.ComponentModel.CategoryAttribute("Images")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Determines the file name of an image to be displayed in the background of the object associated with the style.")
ISNet.Serialization.BinarySerializableAttribute()
public function get,set BackgroundImage : System.String
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.Layout)]
[System.ComponentModel.CategoryAttribute("Images")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Determines the file name of an image to be displayed in the background of the object associated with the style.")]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property virtual System.string* get_BackgroundImage();
public: __property virtual void set_BackgroundImage(
   System.string* value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.Layout)]
[System.ComponentModel.CategoryAttribute("Images")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Determines the file name of an image to be displayed in the background of the object associated with the style.")]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
virtual property System.String^ BackgroundImage {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridFormatStyle Class
WebGridFormatStyle Members


BaseStyle Property

[image]
Intersoft WebGrid Documentation
BaseStyle Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridFormatStyle Class : BaseStyle Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.Layout)>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Returns or sets the base style that this style will inherit from. This property is only useful when the style is contained in DynamicStyle object.")>
<System.ComponentModel.CategoryAttribute("Appearance")>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Overridable Property BaseStyle As ISNet.WebUI.BaseStyleType
Visual Basic (Usage) Copy Code
Dim instance As WebGridFormatStyle
Dim value As ISNet.WebUI.BaseStyleType

instance.BaseStyle = value

value = instance.BaseStyle
C#
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.Layout)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Returns or sets the base style that this style will inherit from. This property is only useful when the style is contained in DynamicStyle object.")]
[System.ComponentModel.CategoryAttribute("Appearance")]
[ISNet.Serialization.BinarySerializableAttribute()]
public virtual ISNet.WebUI.BaseStyleType BaseStyle {get; set;}
Delphi
public read-write property BaseStyle: ISNet.WebUI.BaseStyleType; virtual;
JScript
ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.Layout)
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Returns or sets the base style that this style will inherit from. This property is only useful when the style is contained in DynamicStyle object.")
System.ComponentModel.CategoryAttribute("Appearance")
ISNet.Serialization.BinarySerializableAttribute()
public function get,set BaseStyle : ISNet.WebUI.BaseStyleType
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.Layout)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Returns or sets the base style that this style will inherit from. This property is only useful when the style is contained in DynamicStyle object.")]
[System.ComponentModel.CategoryAttribute("Appearance")]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property virtual ISNet.WebUI.BaseStyleType get_BaseStyle();
public: __property virtual void set_BaseStyle(
   ISNet.WebUI.BaseStyleType value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.Layout)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Returns or sets the base style that this style will inherit from. This property is only useful when the style is contained in DynamicStyle object.")]
[System.ComponentModel.CategoryAttribute("Appearance")]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
virtual property ISNet.WebUI.BaseStyleType BaseStyle {
   ISNet.WebUI.BaseStyleType get();
   void set (    ISNet.WebUI.BaseStyleType value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridFormatStyle Class
WebGridFormatStyle Members


BorderColor Property

[image]
Intersoft WebGrid Documentation
BorderColor Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridFormatStyle Class : BorderColor Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.Layout)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Appearance")>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Overridable Property BorderColor As System.Drawing.Color
Visual Basic (Usage) Copy Code
Dim instance As WebGridFormatStyle
Dim value As System.Drawing.Color

instance.BorderColor = value

value = instance.BorderColor
C#
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.Layout)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Appearance")]
[ISNet.Serialization.BinarySerializableAttribute()]
public virtual System.Drawing.Color BorderColor {get; set;}
Delphi
public read-write property BorderColor: System.Drawing.Color; virtual;
JScript
ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.Layout)
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Appearance")
ISNet.Serialization.BinarySerializableAttribute()
public function get,set BorderColor : System.Drawing.Color
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.Layout)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Appearance")]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property virtual System.Drawing.Color get_BorderColor();
public: __property virtual void set_BorderColor(
   System.Drawing.Color value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.Layout)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Appearance")]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
virtual property System.Drawing.Color BorderColor {
   System.Drawing.Color get();
   void set (    System.Drawing.Color value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridFormatStyle Class
WebGridFormatStyle Members


BorderSettings Property

[image]
Intersoft WebGrid Documentation
BorderSettings Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridFormatStyle Class : BorderSettings Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Appearance")>
<System.ComponentModel.DescriptionAttribute("Customize the border's appearance in more details.")>
<ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.Layout)>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
Public Overridable Property BorderSettings As ISNet.WebUI.BorderSettings
Visual Basic (Usage) Copy Code
Dim instance As WebGridFormatStyle
Dim value As ISNet.WebUI.BorderSettings

instance.BorderSettings = value

value = instance.BorderSettings
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.DescriptionAttribute("Customize the border's appearance in more details.")]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.Layout)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
public virtual ISNet.WebUI.BorderSettings BorderSettings {get; set;}
Delphi
public read-write property BorderSettings: ISNet.WebUI.BorderSettings; virtual;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Appearance")
System.ComponentModel.DescriptionAttribute("Customize the border's appearance in more details.")
ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.Layout)
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
public function get,set BorderSettings : ISNet.WebUI.BorderSettings
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.DescriptionAttribute("Customize the border's appearance in more details.")]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.Layout)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
public: __property virtual ISNet.WebUI.BorderSettings* get_BorderSettings();
public: __property virtual void set_BorderSettings(
   ISNet.WebUI.BorderSettings* value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.DescriptionAttribute("Customize the border's appearance in more details.")]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.Layout)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
public:
virtual property ISNet.WebUI.BorderSettings^ BorderSettings {
   ISNet.WebUI.BorderSettings^ get();
   void set (    ISNet.WebUI.BorderSettings^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridFormatStyle Class
WebGridFormatStyle Members


BorderStyle Property

[image]
Intersoft WebGrid Documentation
BorderStyle Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridFormatStyle Class : BorderStyle Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.Layout)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("Appearance")>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Overridable Property BorderStyle As System.Web.UI.WebControls.BorderStyle
Visual Basic (Usage) Copy Code
Dim instance As WebGridFormatStyle
Dim value As System.Web.UI.WebControls.BorderStyle

instance.BorderStyle = value

value = instance.BorderStyle
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.Layout)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Appearance")]
[ISNet.Serialization.BinarySerializableAttribute()]
public virtual System.Web.UI.WebControls.BorderStyle BorderStyle {get; set;}
Delphi
public read-write property BorderStyle: System.Web.UI.WebControls.BorderStyle; virtual;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.Layout)
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("Appearance")
ISNet.Serialization.BinarySerializableAttribute()
public function get,set BorderStyle : System.Web.UI.WebControls.BorderStyle
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.Layout)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Appearance")]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property virtual System.Web.UI.WebControls.BorderStyle get_BorderStyle();
public: __property virtual void set_BorderStyle(
   System.Web.UI.WebControls.BorderStyle value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.Layout)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Appearance")]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
virtual property System.Web.UI.WebControls.BorderStyle BorderStyle {
   System.Web.UI.WebControls.BorderStyle get();
   void set (    System.Web.UI.WebControls.BorderStyle value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridFormatStyle Class
WebGridFormatStyle Members


BorderWidth Property

[image]
Intersoft WebGrid Documentation
BorderWidth Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridFormatStyle Class : BorderWidth Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.Layout)>
<System.ComponentModel.CategoryAttribute("Appearance")>
<System.ComponentModel.DefaultValueAttribute()>
Public Overridable Property BorderWidth As System.Web.UI.WebControls.Unit
Visual Basic (Usage) Copy Code
Dim instance As WebGridFormatStyle
Dim value As System.Web.UI.WebControls.Unit

instance.BorderWidth = value

value = instance.BorderWidth
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.Layout)]
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.DefaultValueAttribute()]
public virtual System.Web.UI.WebControls.Unit BorderWidth {get; set;}
Delphi
public read-write property BorderWidth: System.Web.UI.WebControls.Unit; virtual;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.Layout)
System.ComponentModel.CategoryAttribute("Appearance")
System.ComponentModel.DefaultValueAttribute()
public function get,set BorderWidth : System.Web.UI.WebControls.Unit
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.Layout)]
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property virtual System.Web.UI.WebControls.Unit get_BorderWidth();
public: __property virtual void set_BorderWidth(
   System.Web.UI.WebControls.Unit value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.Layout)]
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.DefaultValueAttribute()]
public:
virtual property System.Web.UI.WebControls.Unit BorderWidth {
   System.Web.UI.WebControls.Unit get();
   void set (    System.Web.UI.WebControls.Unit value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridFormatStyle Class
WebGridFormatStyle Members


CssClass Property

[image]
Intersoft WebGrid Documentation
CssClass Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridFormatStyle Class : CssClass Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("Appearance")>
<ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.Layout)>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Overridable Property CssClass As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebGridFormatStyle
Dim value As System.String

instance.CssClass = value

value = instance.CssClass
C#
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Appearance")]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.Layout)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
public virtual System.string CssClass {get; set;}
Delphi
public read-write property CssClass: System.String; virtual;
JScript
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("Appearance")
ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.Layout)
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get,set CssClass : System.String
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Appearance")]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.Layout)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property virtual System.string* get_CssClass();
public: __property virtual void set_CssClass(
   System.string* value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Appearance")]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.Layout)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
virtual property System.String^ CssClass {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridFormatStyle Class
WebGridFormatStyle Members


Cursor Property

[image]
Intersoft WebGrid Documentation
Cursor Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridFormatStyle Class : Cursor Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Appearance")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Type of cursor displayed for the object associated with the style when the mouse pointer is over it.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.Layout)>
Public Overridable Property Cursor As ISNet.WebUI.Cursors
Visual Basic (Usage) Copy Code
Dim instance As WebGridFormatStyle
Dim value As ISNet.WebUI.Cursors

instance.Cursor = value

value = instance.Cursor
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Type of cursor displayed for the object associated with the style when the mouse pointer is over it.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.Layout)]
public virtual ISNet.WebUI.Cursors Cursor {get; set;}
Delphi
public read-write property Cursor: ISNet.WebUI.Cursors; virtual;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Appearance")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Type of cursor displayed for the object associated with the style when the mouse pointer is over it.")
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.Layout)
public function get,set Cursor : ISNet.WebUI.Cursors
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Type of cursor displayed for the object associated with the style when the mouse pointer is over it.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.Layout)]
public: __property virtual ISNet.WebUI.Cursors get_Cursor();
public: __property virtual void set_Cursor(
   ISNet.WebUI.Cursors value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Type of cursor displayed for the object associated with the style when the mouse pointer is over it.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.Layout)]
public:
virtual property ISNet.WebUI.Cursors Cursor {
   ISNet.WebUI.Cursors get();
   void set (    ISNet.WebUI.Cursors value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridFormatStyle Class
WebGridFormatStyle Members


CustomRules Property

[image]
Intersoft WebGrid Documentation
CustomRules Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridFormatStyle Class : CustomRules Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.Layout)>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Appearance")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Determines additional CSS rules to apply to the object associated with the style.")>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Overridable Property CustomRules As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebGridFormatStyle
Dim value As System.String

instance.CustomRules = value

value = instance.CustomRules
C#
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.Layout)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Determines additional CSS rules to apply to the object associated with the style.")]
[ISNet.Serialization.BinarySerializableAttribute()]
public virtual System.string CustomRules {get; set;}
Delphi
public read-write property CustomRules: System.String; virtual;
JScript
ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.Layout)
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Appearance")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Determines additional CSS rules to apply to the object associated with the style.")
ISNet.Serialization.BinarySerializableAttribute()
public function get,set CustomRules : System.String
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.Layout)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Determines additional CSS rules to apply to the object associated with the style.")]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property virtual System.string* get_CustomRules();
public: __property virtual void set_CustomRules(
   System.string* value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.Layout)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Determines additional CSS rules to apply to the object associated with the style.")]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
virtual property System.String^ CustomRules {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridFormatStyle Class
WebGridFormatStyle Members


Font Property

[image]
Intersoft WebGrid Documentation
Font Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridFormatStyle Class : Font Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Appearance")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.Layout)>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Overridable ReadOnly Property Font As System.Web.UI.WebControls.FontInfo
Visual Basic (Usage) Copy Code
Dim instance As WebGridFormatStyle
Dim value As System.Web.UI.WebControls.FontInfo

value = instance.Font
C#
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.Layout)]
[ISNet.Serialization.BinarySerializableAttribute()]
public virtual System.Web.UI.WebControls.FontInfo Font {get;}
Delphi
public read-only property Font: System.Web.UI.WebControls.FontInfo; virtual;
JScript
System.ComponentModel.CategoryAttribute("Appearance")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.Layout)
ISNet.Serialization.BinarySerializableAttribute()
public function get Font : System.Web.UI.WebControls.FontInfo
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.Layout)]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property virtual System.Web.UI.WebControls.FontInfo* get_Font();
C++/CLI
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.Layout)]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
virtual property System.Web.UI.WebControls.FontInfo^ Font {
   System.Web.UI.WebControls.FontInfo^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridFormatStyle Class
WebGridFormatStyle Members


ForeColor Property

[image]
Intersoft WebGrid Documentation
ForeColor Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridFormatStyle Class : ForeColor Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.Layout)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Appearance")>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Overridable Property ForeColor As System.Drawing.Color
Visual Basic (Usage) Copy Code
Dim instance As WebGridFormatStyle
Dim value As System.Drawing.Color

instance.ForeColor = value

value = instance.ForeColor
C#
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.Layout)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Appearance")]
[ISNet.Serialization.BinarySerializableAttribute()]
public virtual System.Drawing.Color ForeColor {get; set;}
Delphi
public read-write property ForeColor: System.Drawing.Color; virtual;
JScript
ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.Layout)
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Appearance")
ISNet.Serialization.BinarySerializableAttribute()
public function get,set ForeColor : System.Drawing.Color
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.Layout)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Appearance")]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property virtual System.Drawing.Color get_ForeColor();
public: __property virtual void set_ForeColor(
   System.Drawing.Color value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.Layout)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Appearance")]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
virtual property System.Drawing.Color ForeColor {
   System.Drawing.Color get();
   void set (    System.Drawing.Color value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridFormatStyle Class
WebGridFormatStyle Members


GradientType Property

[image]
Intersoft WebGrid Documentation
GradientType Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridFormatStyle Class : GradientType Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Appearance")>
<System.ComponentModel.DescriptionAttribute("Specifies the gradient type for back color when BackColor2 is specified.")>
<ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.Layout)>
Public Property GradientType As ISNet.WebUI.GradientType
Visual Basic (Usage) Copy Code
Dim instance As WebGridFormatStyle
Dim value As ISNet.WebUI.GradientType

instance.GradientType = value

value = instance.GradientType
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.DescriptionAttribute("Specifies the gradient type for back color when BackColor2 is specified.")]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.Layout)]
public ISNet.WebUI.GradientType GradientType {get; set;}
Delphi
public read-write property GradientType: ISNet.WebUI.GradientType;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Appearance")
System.ComponentModel.DescriptionAttribute("Specifies the gradient type for back color when BackColor2 is specified.")
ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.Layout)
public function get,set GradientType : ISNet.WebUI.GradientType
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.DescriptionAttribute("Specifies the gradient type for back color when BackColor2 is specified.")]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.Layout)]
public: __property ISNet.WebUI.GradientType get_GradientType();
public: __property void set_GradientType(
   ISNet.WebUI.GradientType value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.DescriptionAttribute("Specifies the gradient type for back color when BackColor2 is specified.")]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.Layout)]
public:
property ISNet.WebUI.GradientType GradientType {
   ISNet.WebUI.GradientType get();
   void set (    ISNet.WebUI.GradientType value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridFormatStyle Class
WebGridFormatStyle Members


Height Property

[image]
Intersoft WebGrid Documentation
Height Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridFormatStyle Class : Height Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.Layout)>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Appearance")>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Overridable Property Height As System.Web.UI.WebControls.Unit
Visual Basic (Usage) Copy Code
Dim instance As WebGridFormatStyle
Dim value As System.Web.UI.WebControls.Unit

instance.Height = value

value = instance.Height
C#
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.Layout)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Appearance")]
[ISNet.Serialization.BinarySerializableAttribute()]
public virtual System.Web.UI.WebControls.Unit Height {get; set;}
Delphi
public read-write property Height: System.Web.UI.WebControls.Unit; virtual;
JScript
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.Layout)
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Appearance")
ISNet.Serialization.BinarySerializableAttribute()
public function get,set Height : System.Web.UI.WebControls.Unit
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.Layout)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Appearance")]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property virtual System.Web.UI.WebControls.Unit get_Height();
public: __property virtual void set_Height(
   System.Web.UI.WebControls.Unit value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.Layout)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Appearance")]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
virtual property System.Web.UI.WebControls.Unit Height {
   System.Web.UI.WebControls.Unit get();
   void set (    System.Web.UI.WebControls.Unit value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridFormatStyle Class
WebGridFormatStyle Members


HorizontalAlign Property

[image]
Intersoft WebGrid Documentation
HorizontalAlign Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridFormatStyle Class : HorizontalAlign Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies the horizontal alignment of the text associated with the style.")>
<ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.Layout)>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("Appearance")>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Overridable Property HorizontalAlign As ISNet.WebUI.HorizontalAlign
Visual Basic (Usage) Copy Code
Dim instance As WebGridFormatStyle
Dim value As ISNet.WebUI.HorizontalAlign

instance.HorizontalAlign = value

value = instance.HorizontalAlign
C#
[System.ComponentModel.DescriptionAttribute("Specifies the horizontal alignment of the text associated with the style.")]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.Layout)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Appearance")]
[ISNet.Serialization.BinarySerializableAttribute()]
public virtual ISNet.WebUI.HorizontalAlign HorizontalAlign {get; set;}
Delphi
public read-write property HorizontalAlign: ISNet.WebUI.HorizontalAlign; virtual;
JScript
System.ComponentModel.DescriptionAttribute("Specifies the horizontal alignment of the text associated with the style.")
ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.Layout)
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("Appearance")
ISNet.Serialization.BinarySerializableAttribute()
public function get,set HorizontalAlign : ISNet.WebUI.HorizontalAlign
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies the horizontal alignment of the text associated with the style.")]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.Layout)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Appearance")]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property virtual ISNet.WebUI.HorizontalAlign get_HorizontalAlign();
public: __property virtual void set_HorizontalAlign(
   ISNet.WebUI.HorizontalAlign value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies the horizontal alignment of the text associated with the style.")]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.Layout)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Appearance")]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
virtual property ISNet.WebUI.HorizontalAlign HorizontalAlign {
   ISNet.WebUI.HorizontalAlign get();
   void set (    ISNet.WebUI.HorizontalAlign value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridFormatStyle Class
WebGridFormatStyle Members


Margin Property

[image]
Intersoft WebGrid Documentation
Margin Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridFormatStyle Class : Margin Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)>
<System.ComponentModel.CategoryAttribute("Appearance")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Determines the amount of space for the style associated object's margins.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.Layout)>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
Public Overridable Property Margin As ISNet.WebUI.Margin
Visual Basic (Usage) Copy Code
Dim instance As WebGridFormatStyle
Dim value As ISNet.WebUI.Margin

instance.Margin = value

value = instance.Margin
C#
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Determines the amount of space for the style associated object's margins.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.Layout)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
public virtual ISNet.WebUI.Margin Margin {get; set;}
Delphi
public read-write property Margin: ISNet.WebUI.Margin; virtual;
JScript
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)
System.ComponentModel.CategoryAttribute("Appearance")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Determines the amount of space for the style associated object's margins.")
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.Layout)
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
public function get,set Margin : ISNet.WebUI.Margin
Managed Extensions for C++
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Determines the amount of space for the style associated object's margins.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.Layout)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
public: __property virtual ISNet.WebUI.Margin* get_Margin();
public: __property virtual void set_Margin(
   ISNet.WebUI.Margin* value
);
C++/CLI
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Determines the amount of space for the style associated object's margins.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.Layout)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
public:
virtual property ISNet.WebUI.Margin^ Margin {
   ISNet.WebUI.Margin^ get();
   void set (    ISNet.WebUI.Margin^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridFormatStyle Class
WebGridFormatStyle Members


WebGridFormatStyle Class Properties

[image]
Intersoft WebGrid Documentation
WebGridFormatStyle Class Properties
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : WebGridFormatStyle Class

Glossary Item Box

For a list of all members of this type, see WebGridFormatStyle members.

Public Properties

 | Name | Description
Public Property | BackColor | (Inherited from ISNet.WebUI.WebStyle)
Public Property | BackColor2 | (Inherited from ISNet.WebUI.WebStyle)
Public Property | BackgroundImage | (Inherited from ISNet.WebUI.WebStyle)
Public Property | BaseStyle | (Inherited from ISNet.WebUI.WebStyle)
Public Property | BorderColor | (Inherited from ISNet.WebUI.WebStyle)
Public Property | BorderSettings | (Inherited from ISNet.WebUI.WebStyle)
Public Property | BorderStyle | (Inherited from ISNet.WebUI.WebStyle)
Public Property | BorderWidth | (Inherited from ISNet.WebUI.WebStyle)
Public Property | CssClass | (Inherited from ISNet.WebUI.WebStyle)
Public Property | Cursor | (Inherited from ISNet.WebUI.WebStyle)
Public Property | CustomRules | (Inherited from ISNet.WebUI.WebStyle)
Public Property | Font | (Inherited from ISNet.WebUI.WebStyle)
Public Property | ForeColor | (Inherited from ISNet.WebUI.WebStyle)
Public Property | GradientType | (Inherited from ISNet.WebUI.WebStyle)
Public Property | Height | (Inherited from ISNet.WebUI.WebStyle)
Public Property | HorizontalAlign | (Inherited from ISNet.WebUI.WebStyle)
Public Property | Margin | (Inherited from ISNet.WebUI.WebStyle)
Public Property | Overflow | Overridden.
Public Property | OverflowX | Overridden.
Public Property | OverflowY | Overridden.
Public Property | Padding | (Inherited from ISNet.WebUI.WebStyle)
Public Property | VerticalAlign | (Inherited from ISNet.WebUI.WebStyle)
Public Property | Width | (Inherited from ISNet.WebUI.WebStyle)
Public Property | Wrap |
Top

See Also

Reference

WebGridFormatStyle Class
ISNet.WebUI.WebGrid Namespace


WebGridFormatStyle Constructor

[image]
Intersoft WebGrid Documentation
WebGridFormatStyle Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridFormatStyle Class : WebGridFormatStyle Constructor

Glossary Item Box

Overload List

Overload | Description
WebGridFormatStyle Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridFormatStyle Class
WebGridFormatStyle Members


Overflow Property

[image]
Intersoft WebGrid Documentation
Overflow Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridFormatStyle Class : Overflow Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
Public Overrides Property Overflow As ISNet.WebUI.Overflow
Visual Basic (Usage) Copy Code
Dim instance As WebGridFormatStyle
Dim value As ISNet.WebUI.Overflow

instance.Overflow = value

value = instance.Overflow
C#
[System.ComponentModel.DefaultValueAttribute()]
public override ISNet.WebUI.Overflow Overflow {get; set;}
Delphi
public read-write property Overflow: ISNet.WebUI.Overflow; override;
JScript
System.ComponentModel.DefaultValueAttribute()
public override function get,set Overflow : ISNet.WebUI.Overflow
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
public: __property ISNet.WebUI.Overflow get_Overflow() override;
public: __property void set_Overflow(
   ISNet.WebUI.Overflow value
) override;
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
public:
property ISNet.WebUI.Overflow Overflow {
   ISNet.WebUI.Overflow get() override;
   void set (    ISNet.WebUI.Overflow value) override;
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridFormatStyle Class
WebGridFormatStyle Members


OverflowX Property

[image]
Intersoft WebGrid Documentation
OverflowX Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridFormatStyle Class : OverflowX Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
Public Overrides Property OverflowX As ISNet.WebUI.Overflow
Visual Basic (Usage) Copy Code
Dim instance As WebGridFormatStyle
Dim value As ISNet.WebUI.Overflow

instance.OverflowX = value

value = instance.OverflowX
C#
[System.ComponentModel.DefaultValueAttribute()]
public override ISNet.WebUI.Overflow OverflowX {get; set;}
Delphi
public read-write property OverflowX: ISNet.WebUI.Overflow; override;
JScript
System.ComponentModel.DefaultValueAttribute()
public override function get,set OverflowX : ISNet.WebUI.Overflow
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
public: __property ISNet.WebUI.Overflow get_OverflowX() override;
public: __property void set_OverflowX(
   ISNet.WebUI.Overflow value
) override;
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
public:
property ISNet.WebUI.Overflow OverflowX {
   ISNet.WebUI.Overflow get() override;
   void set (    ISNet.WebUI.Overflow value) override;
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridFormatStyle Class
WebGridFormatStyle Members


OverflowY Property

[image]
Intersoft WebGrid Documentation
OverflowY Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridFormatStyle Class : OverflowY Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
Public Overrides Property OverflowY As ISNet.WebUI.Overflow
Visual Basic (Usage) Copy Code
Dim instance As WebGridFormatStyle
Dim value As ISNet.WebUI.Overflow

instance.OverflowY = value

value = instance.OverflowY
C#
[System.ComponentModel.DefaultValueAttribute()]
public override ISNet.WebUI.Overflow OverflowY {get; set;}
Delphi
public read-write property OverflowY: ISNet.WebUI.Overflow; override;
JScript
System.ComponentModel.DefaultValueAttribute()
public override function get,set OverflowY : ISNet.WebUI.Overflow
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
public: __property ISNet.WebUI.Overflow get_OverflowY() override;
public: __property void set_OverflowY(
   ISNet.WebUI.Overflow value
) override;
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
public:
property ISNet.WebUI.Overflow OverflowY {
   ISNet.WebUI.Overflow get() override;
   void set (    ISNet.WebUI.Overflow value) override;
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridFormatStyle Class
WebGridFormatStyle Members


Padding Property

[image]
Intersoft WebGrid Documentation
Padding Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridFormatStyle Class : Padding Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Appearance")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.DescriptionAttribute("Determines the amount of space to insert between the style associated object and its margin.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.Layout)>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)>
Public Overridable Property Padding As ISNet.WebUI.Padding
Visual Basic (Usage) Copy Code
Dim instance As WebGridFormatStyle
Dim value As ISNet.WebUI.Padding

instance.Padding = value

value = instance.Padding
C#
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DescriptionAttribute("Determines the amount of space to insert between the style associated object and its margin.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.Layout)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
public virtual ISNet.WebUI.Padding Padding {get; set;}
Delphi
public read-write property Padding: ISNet.WebUI.Padding; virtual;
JScript
System.ComponentModel.CategoryAttribute("Appearance")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.DescriptionAttribute("Determines the amount of space to insert between the style associated object and its margin.")
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.Layout)
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)
public function get,set Padding : ISNet.WebUI.Padding
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DescriptionAttribute("Determines the amount of space to insert between the style associated object and its margin.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.Layout)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
public: __property virtual ISNet.WebUI.Padding* get_Padding();
public: __property virtual void set_Padding(
   ISNet.WebUI.Padding* value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DescriptionAttribute("Determines the amount of space to insert between the style associated object and its margin.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.Layout)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
public:
virtual property ISNet.WebUI.Padding^ Padding {
   ISNet.WebUI.Padding^ get();
   void set (    ISNet.WebUI.Padding^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridFormatStyle Class
WebGridFormatStyle Members


VerticalAlign Property

[image]
Intersoft WebGrid Documentation
VerticalAlign Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridFormatStyle Class : VerticalAlign Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies the vertical alignment of the text associated with the style.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.Layout)>
<System.ComponentModel.CategoryAttribute("Appearance")>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Overridable Property VerticalAlign As ISNet.WebUI.VerticalAlign
Visual Basic (Usage) Copy Code
Dim instance As WebGridFormatStyle
Dim value As ISNet.WebUI.VerticalAlign

instance.VerticalAlign = value

value = instance.VerticalAlign
C#
[System.ComponentModel.DescriptionAttribute("Specifies the vertical alignment of the text associated with the style.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.Layout)]
[System.ComponentModel.CategoryAttribute("Appearance")]
[ISNet.Serialization.BinarySerializableAttribute()]
public virtual ISNet.WebUI.VerticalAlign VerticalAlign {get; set;}
Delphi
public read-write property VerticalAlign: ISNet.WebUI.VerticalAlign; virtual;
JScript
System.ComponentModel.DescriptionAttribute("Specifies the vertical alignment of the text associated with the style.")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.Layout)
System.ComponentModel.CategoryAttribute("Appearance")
ISNet.Serialization.BinarySerializableAttribute()
public function get,set VerticalAlign : ISNet.WebUI.VerticalAlign
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies the vertical alignment of the text associated with the style.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.Layout)]
[System.ComponentModel.CategoryAttribute("Appearance")]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property virtual ISNet.WebUI.VerticalAlign get_VerticalAlign();
public: __property virtual void set_VerticalAlign(
   ISNet.WebUI.VerticalAlign value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies the vertical alignment of the text associated with the style.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.Layout)]
[System.ComponentModel.CategoryAttribute("Appearance")]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
virtual property ISNet.WebUI.VerticalAlign VerticalAlign {
   ISNet.WebUI.VerticalAlign get();
   void set (    ISNet.WebUI.VerticalAlign value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridFormatStyle Class
WebGridFormatStyle Members


Width Property

[image]
Intersoft WebGrid Documentation
Width Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridFormatStyle Class : Width Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Appearance")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.Layout)>
Public Overridable Property Width As System.Web.UI.WebControls.Unit
Visual Basic (Usage) Copy Code
Dim instance As WebGridFormatStyle
Dim value As System.Web.UI.WebControls.Unit

instance.Width = value

value = instance.Width
C#
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.Layout)]
public virtual System.Web.UI.WebControls.Unit Width {get; set;}
Delphi
public read-write property Width: System.Web.UI.WebControls.Unit; virtual;
JScript
System.ComponentModel.CategoryAttribute("Appearance")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.Layout)
public function get,set Width : System.Web.UI.WebControls.Unit
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.Layout)]
public: __property virtual System.Web.UI.WebControls.Unit get_Width();
public: __property virtual void set_Width(
   System.Web.UI.WebControls.Unit value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.Layout)]
public:
virtual property System.Web.UI.WebControls.Unit Width {
   System.Web.UI.WebControls.Unit get();
   void set (    System.Web.UI.WebControls.Unit value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridFormatStyle Class
WebGridFormatStyle Members


Wrap Property

[image]
Intersoft WebGrid Documentation
Wrap Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridFormatStyle Class : Wrap Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Determines whether the text associated with the style is wrapped.")>
<ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.Layout)>
Public Property Wrap As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebGridFormatStyle
Dim value As System.Boolean

instance.Wrap = value

value = instance.Wrap
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Determines whether the text associated with the style is wrapped.")]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.Layout)]
public System.bool Wrap {get; set;}
Delphi
public read-write property Wrap: System.Boolean;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Determines whether the text associated with the style is wrapped.")
ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.Layout)
public function get,set Wrap : System.boolean
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Determines whether the text associated with the style is wrapped.")]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.Layout)]
public: __property System.bool get_Wrap();
public: __property void set_Wrap(
   System.bool value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Determines whether the text associated with the style is wrapped.")]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.Layout)]
public:
property System.bool Wrap {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridFormatStyle Class
WebGridFormatStyle Members


dynamicStyle Field

[image]
Intersoft WebGrid Documentation
dynamicStyle Field
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridFormatStyle Class : dynamicStyle Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public dynamicStyle As ISNet.WebUI.DynamicStyle
Visual Basic (Usage) Copy Code
Dim instance As WebGridFormatStyle
Dim value As ISNet.WebUI.DynamicStyle

value = instance.dynamicStyle

instance.dynamicStyle = value
C#
public ISNet.WebUI.DynamicStyle dynamicStyle
Delphi
public field dynamicStyle: ISNet.WebUI.DynamicStyle;
JScript
public var dynamicStyle : ISNet.WebUI.DynamicStyle;
Managed Extensions for C++
public: ISNet.WebUI.DynamicStyle* dynamicStyle
C++/CLI
public:
ISNet.WebUI.DynamicStyle^ dynamicStyle

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridFormatStyle Class
WebGridFormatStyle Members


layoutKey Field

[image]
Intersoft WebGrid Documentation
layoutKey Field
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridFormatStyle Class : layoutKey Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public layoutKey As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebGridFormatStyle
Dim value As System.String

value = instance.layoutKey

instance.layoutKey = value
C#
public System.string layoutKey
Delphi
public field layoutKey: System.String;
JScript
public var layoutKey : System.String;
Managed Extensions for C++
public: System.string* layoutKey
C++/CLI
public:
System.String^ layoutKey

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridFormatStyle Class
WebGridFormatStyle Members


styleState Field

[image]
Intersoft WebGrid Documentation
styleState Field
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridFormatStyle Class : styleState Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public styleState As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebGridFormatStyle
Dim value As System.String

value = instance.styleState

instance.styleState = value
C#
public System.string styleState
Delphi
public field styleState: System.String;
JScript
public var styleState : System.String;
Managed Extensions for C++
public: System.string* styleState
C++/CLI
public:
System.String^ styleState

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridFormatStyle Class
WebGridFormatStyle Members


WebGridFreezePaneSettings Class

[image]
Intersoft WebGrid Documentation
WebGridFreezePaneSettings Class
Members See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : WebGridFreezePaneSettings Class

Glossary Item Box

Object Model

WebGridFreezePaneSettings Class

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.DescriptionAttribute()>
<System.SerializableAttribute()>
Public Class WebGridFreezePaneSettings
   Inherits ISNet.WebUI.WebUIBaseClass
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Visual Basic (Usage) Copy Code
Dim instance As WebGridFreezePaneSettings
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DescriptionAttribute()]
[System.SerializableAttribute()]
public class WebGridFreezePaneSettings : ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Delphi
public class WebGridFreezePaneSettings = class(ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize)
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.DescriptionAttribute()
System.SerializableAttribute()
public class WebGridFreezePaneSettings extends ISNet.WebUI.WebUIBaseClass implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DescriptionAttribute()]
[System.SerializableAttribute()]
public __gc class WebGridFreezePaneSettings : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DescriptionAttribute()]
[System.SerializableAttribute()]
public ref class WebGridFreezePaneSettings : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.WebGrid.WebGridFreezePaneSettings

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridFreezePaneSettings Members
ISNet.WebUI.WebGrid Namespace


WebGridFreezePaneSettings Class Members

[image]
Intersoft WebGrid Documentation
WebGridFreezePaneSettings Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebGrid Namespace : WebGridFreezePaneSettings Class

Glossary Item Box

The following tables list the members exposed by WebGridFreezePaneSettings.

Public Constructors

 | Name | Description
Public Constructor | WebGridFreezePaneSettings Constructor |
Top

Public Properties

 | Name | Description
Public Property | AbsoluteScrolling |
Public Property | ActiveFrozenColumns |
Public Property | MaxFrozenColumns |
Public Property | ShowInContextMenu |
Public Property | ShowSplitterLine |
Public Property | SplitterLineColor |
Public Property | SplitterLineWidth |
Public Property | SuppressErrorMessage |
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebGridFreezePaneSettings Class
ISNet.WebUI.WebGrid Namespace


WebGridFreezePaneSettings Constructor

[image]
Intersoft WebGrid Documentation
WebGridFreezePaneSettings Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridFreezePaneSettings Class : WebGridFreezePaneSettings Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebGridFreezePaneSettings()
C#
public WebGridFreezePaneSettings()
Delphi
public WebGridFreezePaneSettings();
JScript
public function WebGridFreezePaneSettings();
Managed Extensions for C++
public: WebGridFreezePaneSettings();
C++/CLI
public:
WebGridFreezePaneSettings();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridFreezePaneSettings Class
WebGridFreezePaneSettings Members


Clone Method

[image]
Intersoft WebGrid Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridFreezePaneSettings Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As System.Object
Visual Basic (Usage) Copy Code
Dim instance As WebGridFreezePaneSettings
Dim value As System.Object

value = instance.Clone()
C#
public virtual System.object Clone()
Delphi
public function Clone(): System.TObject; virtual;
JScript
public function Clone() : System.Object;
Managed Extensions for C++
public: virtual System.Object* Clone();
C++/CLI
public:
virtual System.Object^ Clone();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridFreezePaneSettings Class
WebGridFreezePaneSettings Members


CopyFrom Method

[image]
Intersoft WebGrid Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridFreezePaneSettings Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridFreezePaneSettings Class
WebGridFreezePaneSettings Members


CopyFrom(Object) Method

[image]
Intersoft WebGrid Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridFreezePaneSettings Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebGridFreezePaneSettings
Dim objSource As System.Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   System.object objSource
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridFreezePaneSettings Class
WebGridFreezePaneSettings Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebGrid Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridFreezePaneSettings Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object, _
   ByVal cloneSourceValue As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebGridFreezePaneSettings
Dim objSource As System.Object
Dim cloneSourceValue As System.Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   System.object objSource,
   System.bool cloneSourceValue
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject;
    cloneSourceValue: System.Boolean
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object,
   cloneSourceValue : System.boolean
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource,
   System.bool cloneSourceValue
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource,
   System.bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridFreezePaneSettings Class
WebGridFreezePaneSettings Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebGrid Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridFreezePaneSettings Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebGridFreezePaneSettings
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure DeSerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function DeSerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void DeSerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void DeSerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridFreezePaneSettings Class
WebGridFreezePaneSettings Members


GetHashCode Method

[image]
Intersoft WebGrid Documentation
GetHashCode Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridFreezePaneSettings Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebGridFreezePaneSettings
Dim value As System.Integer

value = instance.GetHashCode()
C#
public virtual System.int GetHashCode()
Delphi
public function GetHashCode(): System.Integer; virtual;
JScript
public function GetHashCode() : System.int;
Managed Extensions for C++
public: virtual System.int GetHashCode();
C++/CLI
public:
virtual System.int GetHashCode();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridFreezePaneSettings Class
WebGridFreezePaneSettings Members


WebGridFreezePaneSettings Class Methods

[image]
Intersoft WebGrid Documentation
WebGridFreezePaneSettings Class Methods
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : WebGridFreezePaneSettings Class

Glossary Item Box

For a list of all members of this type, see WebGridFreezePaneSettings members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebGridFreezePaneSettings Class
ISNet.WebUI.WebGrid Namespace


GetObjectData Method

[image]
Intersoft WebGrid Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridFreezePaneSettings Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebGridFreezePaneSettings
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure GetObjectData(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
); override;
JScript
public override function GetObjectData(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void GetObjectData(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
) override
C++/CLI
public:
void GetObjectData(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
) override

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridFreezePaneSettings Class
WebGridFreezePaneSettings Members


IsEmpty Method

[image]
Intersoft WebGrid Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridFreezePaneSettings Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebGridFreezePaneSettings
Dim value As System.Boolean

value = instance.IsEmpty()
C#
public virtual System.bool IsEmpty()
Delphi
public function IsEmpty(): System.Boolean; virtual;
JScript
public function IsEmpty() : System.boolean;
Managed Extensions for C++
public: virtual System.bool IsEmpty();
C++/CLI
public:
virtual System.bool IsEmpty();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridFreezePaneSettings Class
WebGridFreezePaneSettings Members


Reset Method

[image]
Intersoft WebGrid Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridFreezePaneSettings Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As WebGridFreezePaneSettings

instance.Reset()
C#
public virtual void Reset()
Delphi
public procedure Reset(); virtual;
JScript
public function Reset();
Managed Extensions for C++
public: virtual void Reset();
C++/CLI
public:
virtual void Reset();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridFreezePaneSettings Class
WebGridFreezePaneSettings Members


SerializeObjectData Method

[image]
Intersoft WebGrid Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridFreezePaneSettings Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebGridFreezePaneSettings
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure SerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function SerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void SerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void SerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridFreezePaneSettings Class
WebGridFreezePaneSettings Members


ToString Method

[image]
Intersoft WebGrid Documentation
ToString Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridFreezePaneSettings Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebGridFreezePaneSettings
Dim value As System.String

value = instance.ToString()
C#
public virtual System.string ToString()
Delphi
public function ToString(): System.String; virtual;
JScript
public function ToString() : System.String;
Managed Extensions for C++
public: virtual System.string* ToString();
C++/CLI
public:
virtual System.String^ ToString();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridFreezePaneSettings Class
WebGridFreezePaneSettings Members


WebGridFreezePaneSettings Class Properties

[image]
Intersoft WebGrid Documentation
WebGridFreezePaneSettings Class Properties
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : WebGridFreezePaneSettings Class

Glossary Item Box

For a list of all members of this type, see WebGridFreezePaneSettings members.

Public Properties

 | Name | Description
Public Property | AbsoluteScrolling |
Public Property | ActiveFrozenColumns |
Public Property | MaxFrozenColumns |
Public Property | ShowInContextMenu |
Public Property | ShowSplitterLine |
Public Property | SplitterLineColor |
Public Property | SplitterLineWidth |
Public Property | SuppressErrorMessage |
Top

See Also

Reference

WebGridFreezePaneSettings Class
ISNet.WebUI.WebGrid Namespace


WebGridFreezePaneSettings Constructor

[image]
Intersoft WebGrid Documentation
WebGridFreezePaneSettings Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridFreezePaneSettings Class : WebGridFreezePaneSettings Constructor

Glossary Item Box

Overload List

Overload | Description
WebGridFreezePaneSettings Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridFreezePaneSettings Class
WebGridFreezePaneSettings Members


AbsoluteScrolling Property

[image]
Intersoft WebGrid Documentation
AbsoluteScrolling Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridFreezePaneSettings Class : AbsoluteScrolling Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Determines whether the scrolling should absolutely seek the next valid column position.")>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Property AbsoluteScrolling As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebGridFreezePaneSettings
Dim value As System.Boolean

instance.AbsoluteScrolling = value

value = instance.AbsoluteScrolling
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Determines whether the scrolling should absolutely seek the next valid column position.")]
[ISNet.Serialization.XmlSerializableAttribute()]
public System.bool AbsoluteScrolling {get; set;}
Delphi
public read-write property AbsoluteScrolling: System.Boolean;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Determines whether the scrolling should absolutely seek the next valid column position.")
ISNet.Serialization.XmlSerializableAttribute()
public function get,set AbsoluteScrolling : System.boolean
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Determines whether the scrolling should absolutely seek the next valid column position.")]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property System.bool get_AbsoluteScrolling();
public: __property void set_AbsoluteScrolling(
   System.bool value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Determines whether the scrolling should absolutely seek the next valid column position.")]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property System.bool AbsoluteScrolling {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridFreezePaneSettings Class
WebGridFreezePaneSettings Members


ActiveFrozenColumns Property

[image]
Intersoft WebGrid Documentation
ActiveFrozenColumns Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridFreezePaneSettings Class : ActiveFrozenColumns Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Gets or sets the number of columns (based on zero-index position) to be set as active frozen columns.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property ActiveFrozenColumns As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebGridFreezePaneSettings
Dim value As System.Integer

instance.ActiveFrozenColumns = value

value = instance.ActiveFrozenColumns
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the number of columns (based on zero-index position) to be set as active frozen columns.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public System.int ActiveFrozenColumns {get; set;}
Delphi
public read-write property ActiveFrozenColumns: System.Integer;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the number of columns (based on zero-index position) to be set as active frozen columns.")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get,set ActiveFrozenColumns : System.int
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the number of columns (based on zero-index position) to be set as active frozen columns.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.int get_ActiveFrozenColumns();
public: __property void set_ActiveFrozenColumns(
   System.int value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the number of columns (based on zero-index position) to be set as active frozen columns.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.int ActiveFrozenColumns {
   System.int get();
   void set (    System.int value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridFreezePaneSettings Class
WebGridFreezePaneSettings Members


MaxFrozenColumns Property

[image]
Intersoft WebGrid Documentation
MaxFrozenColumns Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridFreezePaneSettings Class : MaxFrozenColumns Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies the maximum number of columns that allowed to be freeze.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property MaxFrozenColumns As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebGridFreezePaneSettings
Dim value As System.Integer

instance.MaxFrozenColumns = value

value = instance.MaxFrozenColumns
C#
[System.ComponentModel.DescriptionAttribute("Specifies the maximum number of columns that allowed to be freeze.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public System.int MaxFrozenColumns {get; set;}
Delphi
public read-write property MaxFrozenColumns: System.Integer;
JScript
System.ComponentModel.DescriptionAttribute("Specifies the maximum number of columns that allowed to be freeze.")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get,set MaxFrozenColumns : System.int
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies the maximum number of columns that allowed to be freeze.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.int get_MaxFrozenColumns();
public: __property void set_MaxFrozenColumns(
   System.int value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies the maximum number of columns that allowed to be freeze.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.int MaxFrozenColumns {
   System.int get();
   void set (    System.int value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridFreezePaneSettings Class
WebGridFreezePaneSettings Members


ShowInContextMenu Property

[image]
Intersoft WebGrid Documentation
ShowInContextMenu Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridFreezePaneSettings Class : ShowInContextMenu Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Gets or sets whether the freezing commands are shown in column context menu.")>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Property ShowInContextMenu As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebGridFreezePaneSettings
Dim value As System.Boolean

instance.ShowInContextMenu = value

value = instance.ShowInContextMenu
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets whether the freezing commands are shown in column context menu.")]
[ISNet.Serialization.XmlSerializableAttribute()]
public System.bool ShowInContextMenu {get; set;}
Delphi
public read-write property ShowInContextMenu: System.Boolean;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets whether the freezing commands are shown in column context menu.")
ISNet.Serialization.XmlSerializableAttribute()
public function get,set ShowInContextMenu : System.boolean
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets whether the freezing commands are shown in column context menu.")]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property System.bool get_ShowInContextMenu();
public: __property void set_ShowInContextMenu(
   System.bool value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets whether the freezing commands are shown in column context menu.")]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property System.bool ShowInContextMenu {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridFreezePaneSettings Class
WebGridFreezePaneSettings Members


ShowSplitterLine Property

[image]
Intersoft WebGrid Documentation
ShowSplitterLine Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridFreezePaneSettings Class : ShowSplitterLine Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies whether the splitter line that separate frozen columns and non-frozen columns is shown.")>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Property ShowSplitterLine As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebGridFreezePaneSettings
Dim value As System.Boolean

instance.ShowSplitterLine = value

value = instance.ShowSplitterLine
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether the splitter line that separate frozen columns and non-frozen columns is shown.")]
[ISNet.Serialization.XmlSerializableAttribute()]
public System.bool ShowSplitterLine {get; set;}
Delphi
public read-write property ShowSplitterLine: System.Boolean;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Specifies whether the splitter line that separate frozen columns and non-frozen columns is shown.")
ISNet.Serialization.XmlSerializableAttribute()
public function get,set ShowSplitterLine : System.boolean
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether the splitter line that separate frozen columns and non-frozen columns is shown.")]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property System.bool get_ShowSplitterLine();
public: __property void set_ShowSplitterLine(
   System.bool value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether the splitter line that separate frozen columns and non-frozen columns is shown.")]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property System.bool ShowSplitterLine {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridFreezePaneSettings Class
WebGridFreezePaneSettings Members


SplitterLineColor Property

[image]
Intersoft WebGrid Documentation
SplitterLineColor Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridFreezePaneSettings Class : SplitterLineColor Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Gets or sets the splitter line's color.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
Public Property SplitterLineColor As System.Drawing.Color
Visual Basic (Usage) Copy Code
Dim instance As WebGridFreezePaneSettings
Dim value As System.Drawing.Color

instance.SplitterLineColor = value

value = instance.SplitterLineColor
C#
[System.ComponentModel.DescriptionAttribute("Gets or sets the splitter line's color.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public System.Drawing.Color SplitterLineColor {get; set;}
Delphi
public read-write property SplitterLineColor: System.Drawing.Color;
JScript
System.ComponentModel.DescriptionAttribute("Gets or sets the splitter line's color.")
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
public function get,set SplitterLineColor : System.Drawing.Color
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Gets or sets the splitter line's color.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.Drawing.Color get_SplitterLineColor();
public: __property void set_SplitterLineColor(
   System.Drawing.Color value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Gets or sets the splitter line's color.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.Drawing.Color SplitterLineColor {
   System.Drawing.Color get();
   void set (    System.Drawing.Color value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridFreezePaneSettings Class
WebGridFreezePaneSettings Members


SplitterLineWidth Property

[image]
Intersoft WebGrid Documentation
SplitterLineWidth Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridFreezePaneSettings Class : SplitterLineWidth Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Gets or sets the splitter line's width.")>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Property SplitterLineWidth As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebGridFreezePaneSettings
Dim value As System.Integer

instance.SplitterLineWidth = value

value = instance.SplitterLineWidth
C#
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the splitter line's width.")]
[ISNet.Serialization.XmlSerializableAttribute()]
public System.int SplitterLineWidth {get; set;}
Delphi
public read-write property SplitterLineWidth: System.Integer;
JScript
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the splitter line's width.")
ISNet.Serialization.XmlSerializableAttribute()
public function get,set SplitterLineWidth : System.int
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the splitter line's width.")]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property System.int get_SplitterLineWidth();
public: __property void set_SplitterLineWidth(
   System.int value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the splitter line's width.")]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property System.int SplitterLineWidth {
   System.int get();
   void set (    System.int value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridFreezePaneSettings Class
WebGridFreezePaneSettings Members


SuppressErrorMessage Property

[image]
Intersoft WebGrid Documentation
SuppressErrorMessage Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridFreezePaneSettings Class : SuppressErrorMessage Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies whether error message related to freeze column should be suppressed.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property SuppressErrorMessage As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebGridFreezePaneSettings
Dim value As System.Boolean

instance.SuppressErrorMessage = value

value = instance.SuppressErrorMessage
C#
[System.ComponentModel.DescriptionAttribute("Specifies whether error message related to freeze column should be suppressed.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public System.bool SuppressErrorMessage {get; set;}
Delphi
public read-write property SuppressErrorMessage: System.Boolean;
JScript
System.ComponentModel.DescriptionAttribute("Specifies whether error message related to freeze column should be suppressed.")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get,set SuppressErrorMessage : System.boolean
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies whether error message related to freeze column should be suppressed.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.bool get_SuppressErrorMessage();
public: __property void set_SuppressErrorMessage(
   System.bool value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies whether error message related to freeze column should be suppressed.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.bool SuppressErrorMessage {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridFreezePaneSettings Class
WebGridFreezePaneSettings Members


WebGridGroup Class

[image]
Intersoft WebGrid Documentation
WebGridGroup Class
Members See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : WebGridGroup Class

Glossary Item Box

Object Model

WebGridGroup Class

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute()>
<System.SerializableAttribute()>
Public Class WebGridGroup
   Inherits ISNet.WebUI.NamedObjectBase
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject
Visual Basic (Usage) Copy Code
Dim instance As WebGridGroup
C#
[System.ComponentModel.DescriptionAttribute()]
[System.SerializableAttribute()]
public class WebGridGroup : ISNet.WebUI.NamedObjectBase, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject
Delphi
public class WebGridGroup = class(ISNet.WebUI.NamedObjectBase, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject)
JScript
System.ComponentModel.DescriptionAttribute()
System.SerializableAttribute()
public class WebGridGroup extends ISNet.WebUI.NamedObjectBase implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute()]
[System.SerializableAttribute()]
public __gc class WebGridGroup : public ISNet.WebUI.NamedObjectBase, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject
C++/CLI
[System.ComponentModel.DescriptionAttribute()]
[System.SerializableAttribute()]
public ref class WebGridGroup : public ISNet.WebUI.NamedObjectBase, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.NamedObjectBase
ISNet.WebUI.WebGrid.WebGridGroup
ISNet.WebUI.WebGrid.WebGridFilter

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridGroup Members
ISNet.WebUI.WebGrid Namespace


WebGridGroup Class Members

[image]
Intersoft WebGrid Documentation
WebGridGroup Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebGrid Namespace : WebGridGroup Class

Glossary Item Box

The following tables list the members exposed by WebGridGroup.

Public Constructors

 | Name | Description
Public Constructor | WebGridGroup Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | CaseSensitive |
Public Property | ColumnMember |
Public Property | GroupInterval |
Public Property | GroupMode |
Public Property | GroupRowValueFormatString |
Public Property | SortOrder |
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString |
Top

See Also

Reference

WebGridGroup Class
ISNet.WebUI.WebGrid Namespace


WebGridGroup Constructor

[image]
Intersoft WebGrid Documentation
WebGridGroup Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridGroup Class : WebGridGroup Constructor

Glossary Item Box

Overload List

Overload | Description
WebGridGroup Constructor() |
WebGridGroup Constructor(String,SortOrder) |
WebGridGroup Constructor(String,SortOrder,GroupMode) |
WebGridGroup Constructor(String,SortOrder,GroupMode,GroupInterval) |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridGroup Class
WebGridGroup Members


WebGridGroup Constructor()

[image]
Intersoft WebGrid Documentation
WebGridGroup Constructor()
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridGroup Class > WebGridGroup Constructor : WebGridGroup Constructor()

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebGridGroup()
C#
public WebGridGroup()
Delphi
public WebGridGroup();
JScript
public function WebGridGroup();
Managed Extensions for C++
public: WebGridGroup();
C++/CLI
public:
WebGridGroup();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridGroup Class
WebGridGroup Members
Overload List


WebGridGroup Constructor(String,SortOrder)

[image]
Intersoft WebGrid Documentation
WebGridGroup Constructor(String,SortOrder)
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridGroup Class > WebGridGroup Constructor : WebGridGroup Constructor(String,SortOrder)

columnMember
sortOrder

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal columnMember As System.String, _
   ByVal sortOrder As SortOrder _
)
Visual Basic (Usage) Copy Code
Dim columnMember As System.String
Dim sortOrder As SortOrder

Dim instance As New WebGridGroup(columnMember, sortOrder)
C#
public WebGridGroup(
   System.string columnMember,
   SortOrder sortOrder
)
Delphi
public WebGridGroup(
    columnMember: System.String;
    sortOrder: SortOrder
);
JScript
public function WebGridGroup(
   columnMember : System.String,
   sortOrder : SortOrder
);
Managed Extensions for C++
public: WebGridGroup(
   System.string* columnMember,
   SortOrder sortOrder
)
C++/CLI
public:
WebGridGroup(
   System.String^ columnMember,
   SortOrder sortOrder
)

Parameters

columnMember
sortOrder

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridGroup Class
WebGridGroup Members
Overload List


WebGridGroup Constructor(String,SortOrder,GroupMode)

[image]
Intersoft WebGrid Documentation
WebGridGroup Constructor(String,SortOrder,GroupMode)
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridGroup Class > WebGridGroup Constructor : WebGridGroup Constructor(String,SortOrder,GroupMode)

columnMember
sortOrder
groupMode

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal columnMember As System.String, _
   ByVal sortOrder As SortOrder, _
   ByVal groupMode As GroupMode _
)
Visual Basic (Usage) Copy Code
Dim columnMember As System.String
Dim sortOrder As SortOrder
Dim groupMode As GroupMode

Dim instance As New WebGridGroup(columnMember, sortOrder, groupMode)
C#
public WebGridGroup(
   System.string columnMember,
   SortOrder sortOrder,
   GroupMode groupMode
)
Delphi
public WebGridGroup(
    columnMember: System.String;
    sortOrder: SortOrder;
    groupMode: GroupMode
);
JScript
public function WebGridGroup(
   columnMember : System.String,
   sortOrder : SortOrder,
   groupMode : GroupMode
);
Managed Extensions for C++
public: WebGridGroup(
   System.string* columnMember,
   SortOrder sortOrder,
   GroupMode groupMode
)
C++/CLI
public:
WebGridGroup(
   System.String^ columnMember,
   SortOrder sortOrder,
   GroupMode groupMode
)

Parameters

columnMember
sortOrder
groupMode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridGroup Class
WebGridGroup Members
Overload List


WebGridGroup Constructor(String,SortOrder,GroupMode,GroupInterval)

[image]
Intersoft WebGrid Documentation
WebGridGroup Constructor(String,SortOrder,GroupMode,GroupInterval)
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridGroup Class > WebGridGroup Constructor : WebGridGroup Constructor(String,SortOrder,GroupMode,GroupInterval)

columnMember
sortOrder
groupMode
groupInterval

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal columnMember As System.String, _
   ByVal sortOrder As SortOrder, _
   ByVal groupMode As GroupMode, _
   ByVal groupInterval As GroupInterval _
)
Visual Basic (Usage) Copy Code
Dim columnMember As System.String
Dim sortOrder As SortOrder
Dim groupMode As GroupMode
Dim groupInterval As GroupInterval

Dim instance As New WebGridGroup(columnMember, sortOrder, groupMode, groupInterval)
C#
public WebGridGroup(
   System.string columnMember,
   SortOrder sortOrder,
   GroupMode groupMode,
   GroupInterval groupInterval
)
Delphi
public WebGridGroup(
    columnMember: System.String;
    sortOrder: SortOrder;
    groupMode: GroupMode;
    groupInterval: GroupInterval
);
JScript
public function WebGridGroup(
   columnMember : System.String,
   sortOrder : SortOrder,
   groupMode : GroupMode,
   groupInterval : GroupInterval
);
Managed Extensions for C++
public: WebGridGroup(
   System.string* columnMember,
   SortOrder sortOrder,
   GroupMode groupMode,
   GroupInterval groupInterval
)
C++/CLI
public:
WebGridGroup(
   System.String^ columnMember,
   SortOrder sortOrder,
   GroupMode groupMode,
   GroupInterval groupInterval
)

Parameters

columnMember
sortOrder
groupMode
groupInterval

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridGroup Class
WebGridGroup Members
Overload List


Clone Method

[image]
Intersoft WebGrid Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridGroup Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As System.Object
Visual Basic (Usage) Copy Code
Dim instance As WebGridGroup
Dim value As System.Object

value = instance.Clone()
C#
public virtual System.object Clone()
Delphi
public function Clone(): System.TObject; virtual;
JScript
public function Clone() : System.Object;
Managed Extensions for C++
public: virtual System.Object* Clone();
C++/CLI
public:
virtual System.Object^ Clone();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridGroup Class
WebGridGroup Members


CopyFrom Method

[image]
Intersoft WebGrid Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridGroup Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridGroup Class
WebGridGroup Members


CopyFrom(Object) Method

[image]
Intersoft WebGrid Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridGroup Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebGridGroup
Dim objSource As System.Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   System.object objSource
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridGroup Class
WebGridGroup Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebGrid Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridGroup Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object, _
   ByVal cloneSourceValue As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebGridGroup
Dim objSource As System.Object
Dim cloneSourceValue As System.Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   System.object objSource,
   System.bool cloneSourceValue
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject;
    cloneSourceValue: System.Boolean
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object,
   cloneSourceValue : System.boolean
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource,
   System.bool cloneSourceValue
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource,
   System.bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridGroup Class
WebGridGroup Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebGrid Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridGroup Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebGridGroup
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure DeSerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function DeSerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void DeSerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void DeSerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridGroup Class
WebGridGroup Members


GetHashCode Method

[image]
Intersoft WebGrid Documentation
GetHashCode Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridGroup Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebGridGroup
Dim value As System.Integer

value = instance.GetHashCode()
C#
public virtual System.int GetHashCode()
Delphi
public function GetHashCode(): System.Integer; virtual;
JScript
public function GetHashCode() : System.int;
Managed Extensions for C++
public: virtual System.int GetHashCode();
C++/CLI
public:
virtual System.int GetHashCode();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridGroup Class
WebGridGroup Members


WebGridGroup Class Methods

[image]
Intersoft WebGrid Documentation
WebGridGroup Class Methods
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : WebGridGroup Class

Glossary Item Box

For a list of all members of this type, see WebGridGroup members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString |
Top

See Also

Reference

WebGridGroup Class
ISNet.WebUI.WebGrid Namespace


GetObjectData Method

[image]
Intersoft WebGrid Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridGroup Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebGridGroup
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure GetObjectData(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
); override;
JScript
public override function GetObjectData(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void GetObjectData(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
) override
C++/CLI
public:
void GetObjectData(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
) override

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridGroup Class
WebGridGroup Members


IsEmpty Method

[image]
Intersoft WebGrid Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridGroup Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebGridGroup
Dim value As System.Boolean

value = instance.IsEmpty()
C#
public virtual System.bool IsEmpty()
Delphi
public function IsEmpty(): System.Boolean; virtual;
JScript
public function IsEmpty() : System.boolean;
Managed Extensions for C++
public: virtual System.bool IsEmpty();
C++/CLI
public:
virtual System.bool IsEmpty();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridGroup Class
WebGridGroup Members


Reset Method

[image]
Intersoft WebGrid Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridGroup Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As WebGridGroup

instance.Reset()
C#
public virtual void Reset()
Delphi
public procedure Reset(); virtual;
JScript
public function Reset();
Managed Extensions for C++
public: virtual void Reset();
C++/CLI
public:
virtual void Reset();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridGroup Class
WebGridGroup Members


SerializeObjectData Method

[image]
Intersoft WebGrid Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridGroup Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebGridGroup
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure SerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function SerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void SerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void SerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridGroup Class
WebGridGroup Members


ToString Method

[image]
Intersoft WebGrid Documentation
ToString Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridGroup Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString() As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebGridGroup
Dim value As System.String

value = instance.ToString()
C#
public override System.string ToString()
Delphi
public function ToString(): System.String; override;
JScript
public override function ToString() : System.String;
Managed Extensions for C++
public: System.string* ToString(); override
C++/CLI
public:
System.String^ ToString(); override

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridGroup Class
WebGridGroup Members


WebGridGroup Class Properties

[image]
Intersoft WebGrid Documentation
WebGridGroup Class Properties
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : WebGridGroup Class

Glossary Item Box

For a list of all members of this type, see WebGridGroup members.

Public Properties

 | Name | Description
Public Property | CaseSensitive |
Public Property | ColumnMember |
Public Property | GroupInterval |
Public Property | GroupMode |
Public Property | GroupRowValueFormatString |
Public Property | SortOrder |
Top

See Also

Reference

WebGridGroup Class
ISNet.WebUI.WebGrid Namespace


CaseSensitive Property

[image]
Intersoft WebGrid Documentation
CaseSensitive Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridGroup Class : CaseSensitive Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies whether the grouping should be case sensitive when comparing text values.")>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Property CaseSensitive As CaseSensitive
Visual Basic (Usage) Copy Code
Dim instance As WebGridGroup
Dim value As CaseSensitive

instance.CaseSensitive = value

value = instance.CaseSensitive
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether the grouping should be case sensitive when comparing text values.")]
[ISNet.Serialization.XmlSerializableAttribute()]
public CaseSensitive CaseSensitive {get; set;}
Delphi
public read-write property CaseSensitive: CaseSensitive;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Specifies whether the grouping should be case sensitive when comparing text values.")
ISNet.Serialization.XmlSerializableAttribute()
public function get,set CaseSensitive : CaseSensitive
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether the grouping should be case sensitive when comparing text values.")]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property CaseSensitive get_CaseSensitive();
public: __property void set_CaseSensitive(
   CaseSensitive value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether the grouping should be case sensitive when comparing text values.")]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property CaseSensitive CaseSensitive {
   CaseSensitive get();
   void set (    CaseSensitive value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridGroup Class
WebGridGroup Members


ColumnMember Property

[image]
Intersoft WebGrid Documentation
ColumnMember Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridGroup Class : ColumnMember Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Gets or sets the column name of which its column will be grouped or sorted.")>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebGrid.FieldTypeEditor, ISNet.WebUI.WebGrid, Version=9.0.7200.1, Culture=neutral, PublicKeyToken=3e60b85fb8502d5e")>
Public Property ColumnMember As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebGridGroup
Dim value As System.String

instance.ColumnMember = value

value = instance.ColumnMember
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the column name of which its column will be grouped or sorted.")]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebGrid.FieldTypeEditor, ISNet.WebUI.WebGrid, Version=9.0.7200.1, Culture=neutral, PublicKeyToken=3e60b85fb8502d5e")]
public System.string ColumnMember {get; set;}
Delphi
public read-write property ColumnMember: System.String;
JScript
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the column name of which its column will be grouped or sorted.")
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebGrid.FieldTypeEditor, ISNet.WebUI.WebGrid, Version=9.0.7200.1, Culture=neutral, PublicKeyToken=3e60b85fb8502d5e")
public function get,set ColumnMember : System.String
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the column name of which its column will be grouped or sorted.")]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebGrid.FieldTypeEditor, ISNet.WebUI.WebGrid, Version=9.0.7200.1, Culture=neutral, PublicKeyToken=3e60b85fb8502d5e")]
public: __property System.string* get_ColumnMember();
public: __property void set_ColumnMember(
   System.string* value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the column name of which its column will be grouped or sorted.")]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebGrid.FieldTypeEditor, ISNet.WebUI.WebGrid, Version=9.0.7200.1, Culture=neutral, PublicKeyToken=3e60b85fb8502d5e")]
public:
property System.String^ ColumnMember {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridGroup Class
WebGridGroup Members


GroupInterval Property

[image]
Intersoft WebGrid Documentation
GroupInterval Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridGroup Class : GroupInterval Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Gets or sets a value that determines how groups should be calculated.")>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Property GroupInterval As GroupInterval
Visual Basic (Usage) Copy Code
Dim instance As WebGridGroup
Dim value As GroupInterval

instance.GroupInterval = value

value = instance.GroupInterval
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets a value that determines how groups should be calculated.")]
[ISNet.Serialization.XmlSerializableAttribute()]
public GroupInterval GroupInterval {get; set;}
Delphi
public read-write property GroupInterval: GroupInterval;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets a value that determines how groups should be calculated.")
ISNet.Serialization.XmlSerializableAttribute()
public function get,set GroupInterval : GroupInterval
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets a value that determines how groups should be calculated.")]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property GroupInterval get_GroupInterval();
public: __property void set_GroupInterval(
   GroupInterval value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets a value that determines how groups should be calculated.")]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property GroupInterval GroupInterval {
   GroupInterval get();
   void set (    GroupInterval value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridGroup Class
WebGridGroup Members


GroupMode Property

[image]
Intersoft WebGrid Documentation
GroupMode Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridGroup Class : GroupMode Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Gets or sets a value indicating whether groups should be collapsed or expanded when groups are calculated.")>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Property GroupMode As GroupMode
Visual Basic (Usage) Copy Code
Dim instance As WebGridGroup
Dim value As GroupMode

instance.GroupMode = value

value = instance.GroupMode
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets a value indicating whether groups should be collapsed or expanded when groups are calculated.")]
[ISNet.Serialization.XmlSerializableAttribute()]
public GroupMode GroupMode {get; set;}
Delphi
public read-write property GroupMode: GroupMode;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets a value indicating whether groups should be collapsed or expanded when groups are calculated.")
ISNet.Serialization.XmlSerializableAttribute()
public function get,set GroupMode : GroupMode
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets a value indicating whether groups should be collapsed or expanded when groups are calculated.")]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property GroupMode get_GroupMode();
public: __property void set_GroupMode(
   GroupMode value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets a value indicating whether groups should be collapsed or expanded when groups are calculated.")]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property GroupMode GroupMode {
   GroupMode get();
   void set (    GroupMode value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridGroup Class
WebGridGroup Members


GroupRowValueFormatString Property

[image]
Intersoft WebGrid Documentation
GroupRowValueFormatString Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridGroup Class : GroupRowValueFormatString Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Gets or sets the string format for the group row's value.")>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property GroupRowValueFormatString As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebGridGroup
Dim value As System.String

instance.GroupRowValueFormatString = value

value = instance.GroupRowValueFormatString
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the string format for the group row's value.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public System.string GroupRowValueFormatString {get; set;}
Delphi
public read-write property GroupRowValueFormatString: System.String;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the string format for the group row's value.")
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get,set GroupRowValueFormatString : System.String
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the string format for the group row's value.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.string* get_GroupRowValueFormatString();
public: __property void set_GroupRowValueFormatString(
   System.string* value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the string format for the group row's value.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.String^ GroupRowValueFormatString {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridGroup Class
WebGridGroup Members


SortOrder Property

[image]
Intersoft WebGrid Documentation
SortOrder Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridGroup Class : SortOrder Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Gets or sets the sort order of the WebGridGroup object.")>
Public Property SortOrder As SortOrder
Visual Basic (Usage) Copy Code
Dim instance As WebGridGroup
Dim value As SortOrder

instance.SortOrder = value

value = instance.SortOrder
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the sort order of the WebGridGroup object.")]
public SortOrder SortOrder {get; set;}
Delphi
public read-write property SortOrder: SortOrder;
JScript
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the sort order of the WebGridGroup object.")
public function get,set SortOrder : SortOrder
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the sort order of the WebGridGroup object.")]
public: __property SortOrder get_SortOrder();
public: __property void set_SortOrder(
   SortOrder value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the sort order of the WebGridGroup object.")]
public:
property SortOrder SortOrder {
   SortOrder get();
   void set (    SortOrder value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridGroup Class
WebGridGroup Members


WebGridGroupCollection Class

[image]
Intersoft WebGrid Documentation
WebGridGroupCollection Class
Members See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : WebGridGroupCollection Class

Glossary Item Box

Object Model

WebGridGroupCollection Class

Syntax

Visual Basic (Declaration)
<System.Reflection.DefaultMemberAttribute("Item")>
<System.SerializableAttribute()>
Public Class WebGridGroupCollection
   Inherits ISNet.WebUI.ISCollectionBase
Visual Basic (Usage) Copy Code
Dim instance As WebGridGroupCollection
C#
[System.Reflection.DefaultMemberAttribute("Item")]
[System.SerializableAttribute()]
public class WebGridGroupCollection : ISNet.WebUI.ISCollectionBase
Delphi
public class WebGridGroupCollection = class(ISNet.WebUI.ISCollectionBase)
JScript
System.Reflection.DefaultMemberAttribute("Item")
System.SerializableAttribute()
public class WebGridGroupCollection extends ISNet.WebUI.ISCollectionBase
Managed Extensions for C++
[System.Reflection.DefaultMemberAttribute("Item")]
[System.SerializableAttribute()]
public __gc class WebGridGroupCollection : public ISNet.WebUI.ISCollectionBase
C++/CLI
[System.Reflection.DefaultMemberAttribute("Item")]
[System.SerializableAttribute()]
public ref class WebGridGroupCollection : public ISNet.WebUI.ISCollectionBase

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
ISNet.WebUI.ISCollectionBase
ISNet.WebUI.WebGrid.WebGridGroupCollection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridGroupCollection Members
ISNet.WebUI.WebGrid Namespace


WebGridGroupCollection Class Members

[image]
Intersoft WebGrid Documentation
WebGridGroupCollection Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebGrid Namespace : WebGridGroupCollection Class

Glossary Item Box

The following tables list the members exposed by WebGridGroupCollection.

Public Constructors

 | Name | Description
Public Constructor | WebGridGroupCollection Constructor |
Top

Public Properties

 | Name | Description
Public Property | Capacity | (Inherited from System.Collections.CollectionBase)
Public Property | Count | (Inherited from System.Collections.CollectionBase)
Public Property | IsReadOnly | Overridden.
Public Property | Item |
Public Property | Parent | (Inherited from ISNet.WebUI.ISCollectionBase)
Top

Public Methods

 | Name | Description
Public Method | Add | Overloaded.
Public Method | Clear |
Public Method | Contains | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | CopyFrom |
Public Method | CopyTo | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | Exists | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | GetEnumerator |
Public Method | GetItem | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | GetNamedItem |
Public Method | GetSortExpression |
Public Method | IndexOf | Overloaded. (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | Insert |
Public Method | IntInsert | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | Remove |
Public Method | setParent | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | SortByIndex |
Top

See Also

Reference

WebGridGroupCollection Class
ISNet.WebUI.WebGrid Namespace


WebGridGroupCollection Constructor

[image]
Intersoft WebGrid Documentation
WebGridGroupCollection Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridGroupCollection Class : WebGridGroupCollection Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebGridGroupCollection()
C#
public WebGridGroupCollection()
Delphi
public WebGridGroupCollection();
JScript
public function WebGridGroupCollection();
Managed Extensions for C++
public: WebGridGroupCollection();
C++/CLI
public:
WebGridGroupCollection();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridGroupCollection Class
WebGridGroupCollection Members


WebGridGroupCollection Class Methods

[image]
Intersoft WebGrid Documentation
WebGridGroupCollection Class Methods
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : WebGridGroupCollection Class

Glossary Item Box

For a list of all members of this type, see WebGridGroupCollection members.

Public Methods

 | Name | Description
Public Method | Add | Overloaded.
Public Method | Clear |
Public Method | Contains | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | CopyFrom |
Public Method | CopyTo | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | Exists | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | GetEnumerator |
Public Method | GetItem | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | GetNamedItem |
Public Method | GetSortExpression |
Public Method | IndexOf | Overloaded. (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | Insert |
Public Method | IntInsert | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | Remove |
Public Method | setParent | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | SortByIndex |
Top

See Also

Reference

WebGridGroupCollection Class
ISNet.WebUI.WebGrid Namespace


Add Method

[image]
Intersoft WebGrid Documentation
Add Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridGroupCollection Class : Add Method

Glossary Item Box

Overload List

Overload | Description
Add(WebGridGroup) |
Add(String) |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridGroupCollection Class
WebGridGroupCollection Members


Add(WebGridGroup) Method

[image]
Intersoft WebGrid Documentation
Add(WebGridGroup) Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridGroupCollection Class > Add Method : Add(WebGridGroup) Method

webGridGroup

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function Add( _
   ByVal webGridGroup As WebGridGroup _
) As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebGridGroupCollection
Dim webGridGroup As WebGridGroup
Dim value As System.Integer

value = instance.Add(webGridGroup)
C#
public virtual System.int Add(
   WebGridGroup webGridGroup
)
Delphi
public function Add(
    webGridGroup: WebGridGroup
): System.Integer; virtual;
JScript
public function Add(
   webGridGroup : WebGridGroup
) : System.int;
Managed Extensions for C++
public: virtual System.int Add(
   WebGridGroup* webGridGroup
)
C++/CLI
public:
virtual System.int Add(
   WebGridGroup^ webGridGroup
)

Parameters

webGridGroup

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridGroupCollection Class
WebGridGroupCollection Members
Overload List


Add(String) Method

[image]
Intersoft WebGrid Documentation
Add(String) Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridGroupCollection Class > Add Method : Add(String) Method

name

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function Add( _
   ByVal name As System.String _
) As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebGridGroupCollection
Dim name As System.String
Dim value As System.Integer

value = instance.Add(name)
C#
public System.int Add(
   System.string name
)
Delphi
public function Add(
    name: System.String
): System.Integer;
JScript
public function Add(
   name : System.String
) : System.int;
Managed Extensions for C++
public: System.int Add(
   System.string* name
)
C++/CLI
public:
System.int Add(
   System.String^ name
)

Parameters

name

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridGroupCollection Class
WebGridGroupCollection Members
Overload List


Clear Method

[image]
Intersoft WebGrid Documentation
Clear Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridGroupCollection Class : Clear Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Shadows Sub Clear()
Visual Basic (Usage) Copy Code
Dim instance As WebGridGroupCollection

instance.Clear()
C#
public new void Clear()
Delphi
public procedure Clear();
JScript
public hide function Clear();
Managed Extensions for C++
public: new void Clear();
C++/CLI
public:
new void Clear();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridGroupCollection Class
WebGridGroupCollection Members


Contains Method

[image]
Intersoft WebGrid Documentation
Contains Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridGroupCollection Class : Contains Method

value

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function Contains( _
   ByVal value As ISNet.WebUI.INamedObject _
) As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebGridGroupCollection
Dim value As ISNet.WebUI.INamedObject
Dim value As System.Boolean

value = instance.Contains(value)
C#
public System.bool Contains(
   ISNet.WebUI.INamedObject value
)
Delphi
public function Contains(
    value: ISNet.WebUI.INamedObject
): System.Boolean;
JScript
public function Contains(
   value : ISNet.WebUI.INamedObject
) : System.boolean;
Managed Extensions for C++
public: System.bool Contains(
   ISNet.WebUI.INamedObject* value
)
C++/CLI
public:
System.bool Contains(
   ISNet.WebUI.INamedObject^ value
)

Parameters

value

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridGroupCollection Class
WebGridGroupCollection Members


CopyFrom Method

[image]
Intersoft WebGrid Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridGroupCollection Class : CopyFrom Method

passIn

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function CopyFrom( _
   ByVal passIn As WebGridGroupCollection _
) As WebGridGroupCollection
Visual Basic (Usage) Copy Code
Dim instance As WebGridGroupCollection
Dim passIn As WebGridGroupCollection
Dim value As WebGridGroupCollection

value = instance.CopyFrom(passIn)
C#
public WebGridGroupCollection CopyFrom(
   WebGridGroupCollection passIn
)
Delphi
public function CopyFrom(
    passIn: WebGridGroupCollection
): WebGridGroupCollection;
JScript
public function CopyFrom(
   passIn : WebGridGroupCollection
) : WebGridGroupCollection;
Managed Extensions for C++
public: WebGridGroupCollection* CopyFrom(
   WebGridGroupCollection* passIn
)
C++/CLI
public:
WebGridGroupCollection^ CopyFrom(
   WebGridGroupCollection^ passIn
)

Parameters

passIn

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridGroupCollection Class
WebGridGroupCollection Members


CopyTo Method

[image]
Intersoft WebGrid Documentation
CopyTo Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridGroupCollection Class : CopyTo Method

array
index

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub CopyTo( _
   ByVal array() As ISNet.WebUI.INamedObject, _
   ByVal index As System.Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As WebGridGroupCollection
Dim array() As ISNet.WebUI.INamedObject
Dim index As System.Integer

instance.CopyTo(array, index)
C#
public void CopyTo(
   ISNet.WebUI.INamedObject[] array,
   System.int index
)
Delphi
public procedure CopyTo(
    array: ISNet.WebUI.INamedObjectarray of;
    index: System.Integer
);
JScript
public function CopyTo(
   array : ISNet.WebUI.INamedObject[],
   index : System.int
);
Managed Extensions for C++
public: void CopyTo(
   ISNet.WebUI.INamedObject*[]* array,
   System.int index
)
C++/CLI
public:
void CopyTo(
   ISNet.WebUI.array<INamedObject^>^ array,
   System.int index
)

Parameters

array
index

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridGroupCollection Class
WebGridGroupCollection Members


Exists Method

[image]
Intersoft WebGrid Documentation
Exists Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridGroupCollection Class : Exists Method

name

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function Exists( _
   ByVal name As System.String _
) As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebGridGroupCollection
Dim name As System.String
Dim value As System.Boolean

value = instance.Exists(name)
C#
public System.bool Exists(
   System.string name
)
Delphi
public function Exists(
    name: System.String
): System.Boolean;
JScript
public function Exists(
   name : System.String
) : System.boolean;
Managed Extensions for C++
public: System.bool Exists(
   System.string* name
)
C++/CLI
public:
System.bool Exists(
   System.String^ name
)

Parameters

name

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridGroupCollection Class
WebGridGroupCollection Members


GetEnumerator Method

[image]
Intersoft WebGrid Documentation
GetEnumerator Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridGroupCollection Class : GetEnumerator Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Shadows Function GetEnumerator() As System.Collections.IEnumerator
Visual Basic (Usage) Copy Code
Dim instance As WebGridGroupCollection
Dim value As System.Collections.IEnumerator

value = instance.GetEnumerator()
C#
public new System.Collections.IEnumerator GetEnumerator()
Delphi
public function GetEnumerator(): System.Collections.IEnumerator;
JScript
public hide function GetEnumerator() : System.Collections.IEnumerator;
Managed Extensions for C++
public: new System.Collections.IEnumerator* GetEnumerator();
C++/CLI
public:
new System.Collections.IEnumerator^ GetEnumerator();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridGroupCollection Class
WebGridGroupCollection Members


GetItem Method

[image]
Intersoft WebGrid Documentation
GetItem Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridGroupCollection Class : GetItem Method

Glossary Item Box

Overload List

Overload | Description
GetItem | (Inherited from ISNet.WebUI.ISCollectionBase)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridGroupCollection Class
WebGridGroupCollection Members


GetItem(Int32) Method

[image]
Intersoft WebGrid Documentation
GetItem(Int32) Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridGroupCollection Class : GetItem(Int32) Method

index

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetItem( _
   ByVal index As System.Integer _
) As ISNet.WebUI.INamedObject
Visual Basic (Usage) Copy Code
Dim instance As WebGridGroupCollection
Dim index As System.Integer
Dim value As ISNet.WebUI.INamedObject

value = instance.GetItem(index)
C#
public virtual ISNet.WebUI.INamedObject GetItem(
   System.int index
)
Delphi
public function GetItem(
    index: System.Integer
): ISNet.WebUI.INamedObject; virtual;
JScript
public function GetItem(
   index : System.int
) : ISNet.WebUI.INamedObject;
Managed Extensions for C++
public: virtual ISNet.WebUI.INamedObject* GetItem(
   System.int index
)
C++/CLI
public:
virtual ISNet.WebUI.INamedObject^ GetItem(
   System.int index
)

Parameters

index

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridGroupCollection Class
WebGridGroupCollection Members


GetNamedItem Method

[image]
Intersoft WebGrid Documentation
GetNamedItem Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridGroupCollection Class : GetNamedItem Method

name

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetNamedItem( _
   ByVal name As System.String _
) As WebGridGroup
Visual Basic (Usage) Copy Code
Dim instance As WebGridGroupCollection
Dim name As System.String
Dim value As WebGridGroup

value = instance.GetNamedItem(name)
C#
public WebGridGroup GetNamedItem(
   System.string name
)
Delphi
public function GetNamedItem(
    name: System.String
): WebGridGroup;
JScript
public function GetNamedItem(
   name : System.String
) : WebGridGroup;
Managed Extensions for C++
public: WebGridGroup* GetNamedItem(
   System.string* name
)
C++/CLI
public:
WebGridGroup^ GetNamedItem(
   System.String^ name
)

Parameters

name

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridGroupCollection Class
WebGridGroupCollection Members


GetSortExpression Method

[image]
Intersoft WebGrid Documentation
GetSortExpression Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridGroupCollection Class : GetSortExpression Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetSortExpression() As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebGridGroupCollection
Dim value As System.String

value = instance.GetSortExpression()
C#
public System.string GetSortExpression()
Delphi
public function GetSortExpression(): System.String;
JScript
public function GetSortExpression() : System.String;
Managed Extensions for C++
public: System.string* GetSortExpression();
C++/CLI
public:
System.String^ GetSortExpression();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridGroupCollection Class
WebGridGroupCollection Members


IndexOf Method

[image]
Intersoft WebGrid Documentation
IndexOf Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridGroupCollection Class : IndexOf Method

Glossary Item Box

Overload List

Overload | Description
IndexOf(String) | (Inherited from ISNet.WebUI.ISCollectionBase)
IndexOf(INamedObject) | (Inherited from ISNet.WebUI.ISCollectionBase)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridGroupCollection Class
WebGridGroupCollection Members


IndexOf(String) Method

[image]
Intersoft WebGrid Documentation
IndexOf(String) Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridGroupCollection Class > IndexOf Method : IndexOf(String) Method

name

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function IndexOf( _
   ByVal name As System.String _
) As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebGridGroupCollection
Dim name As System.String
Dim value As System.Integer

value = instance.IndexOf(name)
C#
public virtual System.int IndexOf(
   System.string name
)
Delphi
public function IndexOf(
    name: System.String
): System.Integer; virtual;
JScript
public function IndexOf(
   name : System.String
) : System.int;
Managed Extensions for C++
public: virtual System.int IndexOf(
   System.string* name
)
C++/CLI
public:
virtual System.int IndexOf(
   System.String^ name
)

Parameters

name

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridGroupCollection Class
WebGridGroupCollection Members
Overload List


IndexOf(INamedObject) Method

[image]
Intersoft WebGrid Documentation
IndexOf(INamedObject) Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridGroupCollection Class > IndexOf Method : IndexOf(INamedObject) Method

value

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function IndexOf( _
   ByVal value As ISNet.WebUI.INamedObject _
) As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebGridGroupCollection
Dim value As ISNet.WebUI.INamedObject
Dim value As System.Integer

value = instance.IndexOf(value)
C#
public System.int IndexOf(
   ISNet.WebUI.INamedObject value
)
Delphi
public function IndexOf(
    value: ISNet.WebUI.INamedObject
): System.Integer;
JScript
public function IndexOf(
   value : ISNet.WebUI.INamedObject
) : System.int;
Managed Extensions for C++
public: System.int IndexOf(
   ISNet.WebUI.INamedObject* value
)
C++/CLI
public:
System.int IndexOf(
   ISNet.WebUI.INamedObject^ value
)

Parameters

value

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridGroupCollection Class
WebGridGroupCollection Members
Overload List


Insert Method

[image]
Intersoft WebGrid Documentation
Insert Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridGroupCollection Class : Insert Method

index
webGridGroup

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub Insert( _
   ByVal index As System.Integer, _
   ByVal webGridGroup As WebGridGroup _
)
Visual Basic (Usage) Copy Code
Dim instance As WebGridGroupCollection
Dim index As System.Integer
Dim webGridGroup As WebGridGroup

instance.Insert(index, webGridGroup)
C#
public void Insert(
   System.int index,
   WebGridGroup webGridGroup
)
Delphi
public procedure Insert(
    index: System.Integer;
    webGridGroup: WebGridGroup
);
JScript
public function Insert(
   index : System.int,
   webGridGroup : WebGridGroup
);
Managed Extensions for C++
public: void Insert(
   System.int index,
   WebGridGroup* webGridGroup
)
C++/CLI
public:
void Insert(
   System.int index,
   WebGridGroup^ webGridGroup
)

Parameters

index
webGridGroup

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridGroupCollection Class
WebGridGroupCollection Members


IntInsert Method

[image]
Intersoft WebGrid Documentation
IntInsert Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridGroupCollection Class : IntInsert Method

index
value

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub IntInsert( _
   ByVal index As System.Integer, _
   ByVal value As ISNet.WebUI.INamedObject _
)
Visual Basic (Usage) Copy Code
Dim instance As WebGridGroupCollection
Dim index As System.Integer
Dim value As ISNet.WebUI.INamedObject

instance.IntInsert(index, value)
C#
public void IntInsert(
   System.int index,
   ISNet.WebUI.INamedObject value
)
Delphi
public procedure IntInsert(
    index: System.Integer;
    value: ISNet.WebUI.INamedObject
);
JScript
public function IntInsert(
   index : System.int,
   value : ISNet.WebUI.INamedObject
);
Managed Extensions for C++
public: void IntInsert(
   System.int index,
   ISNet.WebUI.INamedObject* value
)
C++/CLI
public:
void IntInsert(
   System.int index,
   ISNet.WebUI.INamedObject^ value
)

Parameters

index
value

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridGroupCollection Class
WebGridGroupCollection Members


Remove Method

[image]
Intersoft WebGrid Documentation
Remove Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridGroupCollection Class : Remove Method

webGridGroup

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub Remove( _
   ByVal webGridGroup As WebGridGroup _
)
Visual Basic (Usage) Copy Code
Dim instance As WebGridGroupCollection
Dim webGridGroup As WebGridGroup

instance.Remove(webGridGroup)
C#
public void Remove(
   WebGridGroup webGridGroup
)
Delphi
public procedure Remove(
    webGridGroup: WebGridGroup
);
JScript
public function Remove(
   webGridGroup : WebGridGroup
);
Managed Extensions for C++
public: void Remove(
   WebGridGroup* webGridGroup
)
C++/CLI
public:
void Remove(
   WebGridGroup^ webGridGroup
)

Parameters

webGridGroup

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridGroupCollection Class
WebGridGroupCollection Members


setParent Method

[image]
Intersoft WebGrid Documentation
setParent Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridGroupCollection Class : setParent Method

parent

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub setParent( _
   ByVal parent As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebGridGroupCollection
Dim parent As System.Object

instance.setParent(parent)
C#
public virtual void setParent(
   System.object parent
)
Delphi
public procedure setParent(
    parent: System.TObject
); virtual;
JScript
public function setParent(
   parent : System.Object
);
Managed Extensions for C++
public: virtual void setParent(
   System.Object* parent
)
C++/CLI
public:
virtual void setParent(
   System.Object^ parent
)

Parameters

parent

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridGroupCollection Class
WebGridGroupCollection Members


SortByIndex Method

[image]
Intersoft WebGrid Documentation
SortByIndex Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridGroupCollection Class : SortByIndex Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SortByIndex()
Visual Basic (Usage) Copy Code
Dim instance As WebGridGroupCollection

instance.SortByIndex()
C#
public void SortByIndex()
Delphi
public procedure SortByIndex();
JScript
public function SortByIndex();
Managed Extensions for C++
public: void SortByIndex();
C++/CLI
public:
void SortByIndex();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridGroupCollection Class
WebGridGroupCollection Members


Capacity Property

[image]
Intersoft WebGrid Documentation
Capacity Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridGroupCollection Class : Capacity Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Runtime.InteropServices.ComVisibleAttribute(False)>
Public Property Capacity As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebGridGroupCollection
Dim value As System.Integer

instance.Capacity = value

value = instance.Capacity
C#
[System.Runtime.InteropServices.ComVisibleAttribute(false)]
public System.int Capacity {get; set;}
Delphi
public read-write property Capacity: System.Integer;
JScript
System.Runtime.InteropServices.ComVisibleAttribute()
public function get,set Capacity : System.int
Managed Extensions for C++
[System.Runtime.InteropServices.ComVisibleAttribute(false)]
public: __property System.int get_Capacity();
public: __property void set_Capacity(
   System.int value
);
C++/CLI
[System.Runtime.InteropServices.ComVisibleAttribute(false)]
public:
property System.int Capacity {
   System.int get();
   void set (    System.int value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridGroupCollection Class
WebGridGroupCollection Members


Count Property

[image]
Intersoft WebGrid Documentation
Count Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridGroupCollection Class : Count Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Count As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebGridGroupCollection
Dim value As System.Integer

value = instance.Count
C#
public System.int Count {get;}
Delphi
public read-only property Count: System.Integer;
JScript
public function get Count : System.int
Managed Extensions for C++
public: __property System.int get_Count();
C++/CLI
public:
property System.int Count {
   System.int get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridGroupCollection Class
WebGridGroupCollection Members


WebGridGroupCollection Class Properties

[image]
Intersoft WebGrid Documentation
WebGridGroupCollection Class Properties
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : WebGridGroupCollection Class

Glossary Item Box

For a list of all members of this type, see WebGridGroupCollection members.

Public Properties

 | Name | Description
Public Property | Capacity | (Inherited from System.Collections.CollectionBase)
Public Property | Count | (Inherited from System.Collections.CollectionBase)
Public Property | IsReadOnly | Overridden.
Public Property | Item |
Public Property | Parent | (Inherited from ISNet.WebUI.ISCollectionBase)
Top

See Also

Reference

WebGridGroupCollection Class
ISNet.WebUI.WebGrid Namespace


WebGridGroupCollection Constructor

[image]
Intersoft WebGrid Documentation
WebGridGroupCollection Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridGroupCollection Class : WebGridGroupCollection Constructor

Glossary Item Box

Overload List

Overload | Description
WebGridGroupCollection Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridGroupCollection Class
WebGridGroupCollection Members


IsReadOnly Property

[image]
Intersoft WebGrid Documentation
IsReadOnly Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridGroupCollection Class : IsReadOnly Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property IsReadOnly As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebGridGroupCollection
Dim value As System.Boolean

value = instance.IsReadOnly
C#
public override System.bool IsReadOnly {get;}
Delphi
public read-only property IsReadOnly: System.Boolean; override;
JScript
public override function get IsReadOnly : System.boolean
Managed Extensions for C++
public: __property System.bool get_IsReadOnly() override;
C++/CLI
public:
property System.bool IsReadOnly {
   System.bool get() override;
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridGroupCollection Class
WebGridGroupCollection Members


Item Property

[image]
Intersoft WebGrid Documentation
Item Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridGroupCollection Class : Item Property

index

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Default Property Item( _
   ByVal index As System.Integer _
) As WebGridGroup
Visual Basic (Usage) Copy Code
Dim instance As WebGridGroupCollection
Dim index As System.Integer
Dim value As WebGridGroup

value = instance.Item(index)
C#
public WebGridGroup this[
   System.int index
]; {get;}
Delphi
public  this: : WebGridGroup;[
    index: System.Integer
]; read-only
JScript
public  this[
   index : System.int
] get : WebGridGroup
Managed Extensions for C++
public: __property WebGridGroup* get_Item   System.int index
;
C++/CLI
public:
property WebGridGroup^ default [int] {
   WebGridGroup^ get(System.int index);
}

Parameters

index

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridGroupCollection Class
WebGridGroupCollection Members


Parent Property

[image]
Intersoft WebGrid Documentation
Parent Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridGroupCollection Class : Parent Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Parent As System.Object
Visual Basic (Usage) Copy Code
Dim instance As WebGridGroupCollection
Dim value As System.Object

value = instance.Parent
C#
public System.object Parent {get;}
Delphi
public read-only property Parent: System.TObject;
JScript
public function get Parent : System.Object
Managed Extensions for C++
public: __property System.Object* get_Parent();
C++/CLI
public:
property System.Object^ Parent {
   System.Object^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridGroupCollection Class
WebGridGroupCollection Members


WebGridObjectRelation Class

[image]
Intersoft WebGrid Documentation
WebGridObjectRelation Class
Members See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : WebGridObjectRelation Class

Glossary Item Box

Object Model

WebGridObjectRelation Class

Syntax

Visual Basic (Declaration)
Public Class WebGridObjectRelation
Visual Basic (Usage) Copy Code
Dim instance As WebGridObjectRelation
C#
public class WebGridObjectRelation
Delphi
public class WebGridObjectRelation
JScript
public class WebGridObjectRelation
Managed Extensions for C++
public __gc class WebGridObjectRelation
C++/CLI
public ref class WebGridObjectRelation

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebGrid.WebGridObjectRelation

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridObjectRelation Members
ISNet.WebUI.WebGrid Namespace


WebGridObjectRelation Class Members

[image]
Intersoft WebGrid Documentation
WebGridObjectRelation Class Members
See Also Methods Send Feedback
ISNet.WebUI.WebGrid Namespace : WebGridObjectRelation Class

Glossary Item Box

The following tables list the members exposed by WebGridObjectRelation.

Public Constructors

 | Name | Description
Public Constructor | WebGridObjectRelation Constructor | Overloaded.
Top

Public Methods

 | Name | Description
Public Method | SetParentObjectType |
Top

See Also

Reference

WebGridObjectRelation Class
ISNet.WebUI.WebGrid Namespace


WebGridObjectRelation Constructor

[image]
Intersoft WebGrid Documentation
WebGridObjectRelation Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridObjectRelation Class : WebGridObjectRelation Constructor

Glossary Item Box

Overload List

Overload | Description
WebGridObjectRelation Constructor(Type,String,String,Type,String) |
WebGridObjectRelation Constructor(Type,String[],String,Type,String[]) |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridObjectRelation Class
WebGridObjectRelation Members


WebGridObjectRelation Constructor(Type,String,String,Type,String)

[image]
Intersoft WebGrid Documentation
WebGridObjectRelation Constructor(Type,String,String,Type,String)
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridObjectRelation Class > WebGridObjectRelation Constructor : WebGridObjectRelation Constructor(Type,String,String,Type,String)

parentObjectType
parentMember
childCollectionProperty
childObjectType
childMember

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal parentObjectType As System.Type, _
   ByVal parentMember As System.String, _
   ByVal childCollectionProperty As System.String, _
   ByVal childObjectType As System.Type, _
   ByVal childMember As System.String _
)
Visual Basic (Usage) Copy Code
Dim parentObjectType As System.Type
Dim parentMember As System.String
Dim childCollectionProperty As System.String
Dim childObjectType As System.Type
Dim childMember As System.String

Dim instance As New WebGridObjectRelation(parentObjectType, parentMember, childCollectionProperty, childObjectType, childMember)
C#
public WebGridObjectRelation(
   System.Type parentObjectType,
   System.string parentMember,
   System.string childCollectionProperty,
   System.Type childObjectType,
   System.string childMember
)
Delphi
public WebGridObjectRelation(
    parentObjectType: System.Type;
    parentMember: System.String;
    childCollectionProperty: System.String;
    childObjectType: System.Type;
    childMember: System.String
);
JScript
public function WebGridObjectRelation(
   parentObjectType : System.Type,
   parentMember : System.String,
   childCollectionProperty : System.String,
   childObjectType : System.Type,
   childMember : System.String
);
Managed Extensions for C++
public: WebGridObjectRelation(
   System.Type* parentObjectType,
   System.string* parentMember,
   System.string* childCollectionProperty,
   System.Type* childObjectType,
   System.string* childMember
)
C++/CLI
public:
WebGridObjectRelation(
   System.Type^ parentObjectType,
   System.String^ parentMember,
   System.String^ childCollectionProperty,
   System.Type^ childObjectType,
   System.String^ childMember
)

Parameters

parentObjectType
parentMember
childCollectionProperty
childObjectType
childMember

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridObjectRelation Class
WebGridObjectRelation Members
Overload List


WebGridObjectRelation Constructor(Type,String[],String,Type,String[])

[image]
Intersoft WebGrid Documentation
WebGridObjectRelation Constructor(Type,String[],String,Type,String[])
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridObjectRelation Class > WebGridObjectRelation Constructor : WebGridObjectRelation Constructor(Type,String[],String,Type,String[])

parentObjectType
parentMember
childCollectionProperty
childObjectType
childMember

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal parentObjectType As System.Type, _
   ByVal parentMember() As System.String, _
   ByVal childCollectionProperty As System.String, _
   ByVal childObjectType As System.Type, _
   ByVal childMember() As System.String _
)
Visual Basic (Usage) Copy Code
Dim parentObjectType As System.Type
Dim parentMember() As System.String
Dim childCollectionProperty As System.String
Dim childObjectType As System.Type
Dim childMember() As System.String

Dim instance As New WebGridObjectRelation(parentObjectType, parentMember, childCollectionProperty, childObjectType, childMember)
C#
public WebGridObjectRelation(
   System.Type parentObjectType,
   System.string[] parentMember,
   System.string childCollectionProperty,
   System.Type childObjectType,
   System.string[] childMember
)
Delphi
public WebGridObjectRelation(
    parentObjectType: System.Type;
    parentMember: System.Stringarray of;
    childCollectionProperty: System.String;
    childObjectType: System.Type;
    childMember: System.Stringarray of
);
JScript
public function WebGridObjectRelation(
   parentObjectType : System.Type,
   parentMember : System.String[],
   childCollectionProperty : System.String,
   childObjectType : System.Type,
   childMember : System.String[]
);
Managed Extensions for C++
public: WebGridObjectRelation(
   System.Type* parentObjectType,
   System.string*[]* parentMember,
   System.string* childCollectionProperty,
   System.Type* childObjectType,
   System.string*[]* childMember
)
C++/CLI
public:
WebGridObjectRelation(
   System.Type^ parentObjectType,
   System.array<String^>^ parentMember,
   System.String^ childCollectionProperty,
   System.Type^ childObjectType,
   System.array<String^>^ childMember
)

Parameters

parentObjectType
parentMember
childCollectionProperty
childObjectType
childMember

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridObjectRelation Class
WebGridObjectRelation Members
Overload List


WebGridObjectRelation Class Methods

[image]
Intersoft WebGrid Documentation
WebGridObjectRelation Class Methods
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : WebGridObjectRelation Class

Glossary Item Box

For a list of all members of this type, see WebGridObjectRelation members.

Public Methods

 | Name | Description
Public Method | SetParentObjectType |
Top

See Also

Reference

WebGridObjectRelation Class
ISNet.WebUI.WebGrid Namespace


SetParentObjectType Method

[image]
Intersoft WebGrid Documentation
SetParentObjectType Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridObjectRelation Class : SetParentObjectType Method

parentObjectType

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SetParentObjectType( _
   ByVal parentObjectType As System.Type _
)
Visual Basic (Usage) Copy Code
Dim instance As WebGridObjectRelation
Dim parentObjectType As System.Type

instance.SetParentObjectType(parentObjectType)
C#
public void SetParentObjectType(
   System.Type parentObjectType
)
Delphi
public procedure SetParentObjectType(
    parentObjectType: System.Type
);
JScript
public function SetParentObjectType(
   parentObjectType : System.Type
);
Managed Extensions for C++
public: void SetParentObjectType(
   System.Type* parentObjectType
)
C++/CLI
public:
void SetParentObjectType(
   System.Type^ parentObjectType
)

Parameters

parentObjectType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridObjectRelation Class
WebGridObjectRelation Members


WebGridRow Class

[image]
Intersoft WebGrid Documentation
WebGridRow Class
Members See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : WebGridRow Class

Glossary Item Box

Object Model

WebGridRow Class

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute()>
<System.SerializableAttribute()>
Public Class WebGridRow
   Inherits ISNet.WebUI.NamedObjectBase
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject
Visual Basic (Usage) Copy Code
Dim instance As WebGridRow
C#
[System.ComponentModel.DescriptionAttribute()]
[System.SerializableAttribute()]
public class WebGridRow : ISNet.WebUI.NamedObjectBase, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject
Delphi
public class WebGridRow = class(ISNet.WebUI.NamedObjectBase, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject)
JScript
System.ComponentModel.DescriptionAttribute()
System.SerializableAttribute()
public class WebGridRow extends ISNet.WebUI.NamedObjectBase implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute()]
[System.SerializableAttribute()]
public __gc class WebGridRow : public ISNet.WebUI.NamedObjectBase, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject
C++/CLI
[System.ComponentModel.DescriptionAttribute()]
[System.SerializableAttribute()]
public ref class WebGridRow : public ISNet.WebUI.NamedObjectBase, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.NamedObjectBase
ISNet.WebUI.WebGrid.WebGridRow

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridRow Members
ISNet.WebUI.WebGrid Namespace


WebGridRow Class Members

[image]
Intersoft WebGrid Documentation
WebGridRow Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebGrid Namespace : WebGridRow Class

Glossary Item Box

The following tables list the members exposed by WebGridRow.

Public Constructors

 | Name | Description
Public Constructor | WebGridRow Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | Cells |
Public Property | Checked |
Public Property | ChildNotExpandable |
Public Property | Expanded |
Public Property | ForceNoEdit |
Public Property | Height |
Public Property | SelfRefChildNotExpandable |
Public Property | Style |
Public Property | Visible |
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ExpandChildRow |
Public Method | ExpandGroupRow | Overloaded.
Public Method | ExpandSelfRefRow | Overloaded.
Public Method | FillChildRow |
Public Method | GetChildGroupRowsCount |
Public Method | GetChildTableRows |
Public Method | GetDataRow |
Public Method | GetGroup |
Public Method | GetGroupRowFullPathName |
Public Method | GetGroupRowLevel |
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | GetObjectRow |
Public Method | GetParentRow |
Public Method | GetRootRow |
Public Method | GetRootSelfRefRow |
Public Method | HasCollapsedParents |
Public Method | HasExpandedChilds |
Public Method | HasGrouppedChilds |
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString |
Top

See Also

Reference

WebGridRow Class
ISNet.WebUI.WebGrid Namespace


WebGridRow Constructor

[image]
Intersoft WebGrid Documentation
WebGridRow Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridRow Class : WebGridRow Constructor

Glossary Item Box

Overload List

Overload | Description
WebGridRow Constructor() |
WebGridRow Constructor(WebGridCell[]) |
WebGridRow Constructor(Object[]) |
WebGridRow Constructor(String[],Object[]) |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridRow Class
WebGridRow Members


WebGridRow Constructor()

[image]
Intersoft WebGrid Documentation
WebGridRow Constructor()
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridRow Class > WebGridRow Constructor : WebGridRow Constructor()

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebGridRow()
C#
public WebGridRow()
Delphi
public WebGridRow();
JScript
public function WebGridRow();
Managed Extensions for C++
public: WebGridRow();
C++/CLI
public:
WebGridRow();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridRow Class
WebGridRow Members
Overload List


WebGridRow Constructor(WebGridCell[])

[image]
Intersoft WebGrid Documentation
WebGridRow Constructor(WebGridCell[])
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridRow Class > WebGridRow Constructor : WebGridRow Constructor(WebGridCell[])

cells

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal cells() As WebGridCell _
)
Visual Basic (Usage) Copy Code
Dim cells() As WebGridCell

Dim instance As New WebGridRow(cells)
C#
public WebGridRow(
   WebGridCell[] cells
)
Delphi
public WebGridRow(
    cells: WebGridCellarray of
);
JScript
public function WebGridRow(
   cells : WebGridCell[]
);
Managed Extensions for C++
public: WebGridRow(
   WebGridCell*[]* cells
)
C++/CLI
public:
WebGridRow(
   array<WebGridCell^>^ cells
)

Parameters

cells

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridRow Class
WebGridRow Members
Overload List


WebGridRow Constructor(Object[])

[image]
Intersoft WebGrid Documentation
WebGridRow Constructor(Object[])
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridRow Class > WebGridRow Constructor : WebGridRow Constructor(Object[])

cellData

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal cellData() As System.Object _
)
Visual Basic (Usage) Copy Code
Dim cellData() As System.Object

Dim instance As New WebGridRow(cellData)
C#
public WebGridRow(
   System.object[] cellData
)
Delphi
public WebGridRow(
    cellData: System.TObjectarray of
);
JScript
public function WebGridRow(
   cellData : System.Object[]
);
Managed Extensions for C++
public: WebGridRow(
   System.Object*[]* cellData
)
C++/CLI
public:
WebGridRow(
   System.array<Object^>^ cellData
)

Parameters

cellData

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridRow Class
WebGridRow Members
Overload List


WebGridRow Constructor(String[],Object[])

[image]
Intersoft WebGrid Documentation
WebGridRow Constructor(String[],Object[])
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridRow Class > WebGridRow Constructor : WebGridRow Constructor(String[],Object[])

cellText
cellValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal cellText() As System.String, _
   ByVal cellValue() As System.Object _
)
Visual Basic (Usage) Copy Code
Dim cellText() As System.String
Dim cellValue() As System.Object

Dim instance As New WebGridRow(cellText, cellValue)
C#
public WebGridRow(
   System.string[] cellText,
   System.object[] cellValue
)
Delphi
public WebGridRow(
    cellText: System.Stringarray of;
    cellValue: System.TObjectarray of
);
JScript
public function WebGridRow(
   cellText : System.String[],
   cellValue : System.Object[]
);
Managed Extensions for C++
public: WebGridRow(
   System.string*[]* cellText,
   System.Object*[]* cellValue
)
C++/CLI
public:
WebGridRow(
   System.array<String^>^ cellText,
   System.array<Object^>^ cellValue
)

Parameters

cellText
cellValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridRow Class
WebGridRow Members
Overload List


Clone Method

[image]
Intersoft WebGrid Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridRow Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As System.Object
Visual Basic (Usage) Copy Code
Dim instance As WebGridRow
Dim value As System.Object

value = instance.Clone()
C#
public virtual System.object Clone()
Delphi
public function Clone(): System.TObject; virtual;
JScript
public function Clone() : System.Object;
Managed Extensions for C++
public: virtual System.Object* Clone();
C++/CLI
public:
virtual System.Object^ Clone();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridRow Class
WebGridRow Members


CopyFrom Method

[image]
Intersoft WebGrid Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridRow Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridRow Class
WebGridRow Members


CopyFrom(Object) Method

[image]
Intersoft WebGrid Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridRow Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebGridRow
Dim objSource As System.Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   System.object objSource
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridRow Class
WebGridRow Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebGrid Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridRow Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object, _
   ByVal cloneSourceValue As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebGridRow
Dim objSource As System.Object
Dim cloneSourceValue As System.Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   System.object objSource,
   System.bool cloneSourceValue
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject;
    cloneSourceValue: System.Boolean
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object,
   cloneSourceValue : System.boolean
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource,
   System.bool cloneSourceValue
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource,
   System.bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridRow Class
WebGridRow Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebGrid Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridRow Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebGridRow
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure DeSerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function DeSerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void DeSerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void DeSerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridRow Class
WebGridRow Members


WebGridRow Class Methods

[image]
Intersoft WebGrid Documentation
WebGridRow Class Methods
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : WebGridRow Class

Glossary Item Box

For a list of all members of this type, see WebGridRow members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ExpandChildRow |
Public Method | ExpandGroupRow | Overloaded.
Public Method | ExpandSelfRefRow | Overloaded.
Public Method | FillChildRow |
Public Method | GetChildGroupRowsCount |
Public Method | GetChildTableRows |
Public Method | GetDataRow |
Public Method | GetGroup |
Public Method | GetGroupRowFullPathName |
Public Method | GetGroupRowLevel |
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | GetObjectRow |
Public Method | GetParentRow |
Public Method | GetRootRow |
Public Method | GetRootSelfRefRow |
Public Method | HasCollapsedParents |
Public Method | HasExpandedChilds |
Public Method | HasGrouppedChilds |
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString |
Top

See Also

Reference

WebGridRow Class
ISNet.WebUI.WebGrid Namespace


ExpandChildRow Method

[image]
Intersoft WebGrid Documentation
ExpandChildRow Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridRow Class : ExpandChildRow Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub ExpandChildRow()
Visual Basic (Usage) Copy Code
Dim instance As WebGridRow

instance.ExpandChildRow()
C#
public void ExpandChildRow()
Delphi
public procedure ExpandChildRow();
JScript
public function ExpandChildRow();
Managed Extensions for C++
public: void ExpandChildRow();
C++/CLI
public:
void ExpandChildRow();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridRow Class
WebGridRow Members


ExpandGroupRow Method

[image]
Intersoft WebGrid Documentation
ExpandGroupRow Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridRow Class : ExpandGroupRow Method

Glossary Item Box

Overload List

Overload | Description
ExpandGroupRow() |
ExpandGroupRow(Boolean) |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridRow Class
WebGridRow Members


ExpandGroupRow() Method

[image]
Intersoft WebGrid Documentation
ExpandGroupRow() Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridRow Class > ExpandGroupRow Method : ExpandGroupRow() Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Sub ExpandGroupRow()
Visual Basic (Usage) Copy Code
Dim instance As WebGridRow

instance.ExpandGroupRow()
C#
public void ExpandGroupRow()
Delphi
public procedure ExpandGroupRow();
JScript
public function ExpandGroupRow();
Managed Extensions for C++
public: void ExpandGroupRow();
C++/CLI
public:
void ExpandGroupRow();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridRow Class
WebGridRow Members
Overload List


ExpandGroupRow(Boolean) Method

[image]
Intersoft WebGrid Documentation
ExpandGroupRow(Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridRow Class > ExpandGroupRow Method : ExpandGroupRow(Boolean) Method

allSubGroup

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Sub ExpandGroupRow( _
   ByVal allSubGroup As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebGridRow
Dim allSubGroup As System.Boolean

instance.ExpandGroupRow(allSubGroup)
C#
public void ExpandGroupRow(
   System.bool allSubGroup
)
Delphi
public procedure ExpandGroupRow(
    allSubGroup: System.Boolean
);
JScript
public function ExpandGroupRow(
   allSubGroup : System.boolean
);
Managed Extensions for C++
public: void ExpandGroupRow(
   System.bool allSubGroup
)
C++/CLI
public:
void ExpandGroupRow(
   System.bool allSubGroup
)

Parameters

allSubGroup

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridRow Class
WebGridRow Members
Overload List


ExpandSelfRefRow Method

[image]
Intersoft WebGrid Documentation
ExpandSelfRefRow Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridRow Class : ExpandSelfRefRow Method

Glossary Item Box

Overload List

Overload | Description
ExpandSelfRefRow() |
ExpandSelfRefRow(Boolean) |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridRow Class
WebGridRow Members


ExpandSelfRefRow() Method

[image]
Intersoft WebGrid Documentation
ExpandSelfRefRow() Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridRow Class > ExpandSelfRefRow Method : ExpandSelfRefRow() Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Sub ExpandSelfRefRow()
Visual Basic (Usage) Copy Code
Dim instance As WebGridRow

instance.ExpandSelfRefRow()
C#
public void ExpandSelfRefRow()
Delphi
public procedure ExpandSelfRefRow();
JScript
public function ExpandSelfRefRow();
Managed Extensions for C++
public: void ExpandSelfRefRow();
C++/CLI
public:
void ExpandSelfRefRow();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridRow Class
WebGridRow Members
Overload List


ExpandSelfRefRow(Boolean) Method

[image]
Intersoft WebGrid Documentation
ExpandSelfRefRow(Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridRow Class > ExpandSelfRefRow Method : ExpandSelfRefRow(Boolean) Method

isLoadOnDemand

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Sub ExpandSelfRefRow( _
   ByVal isLoadOnDemand As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebGridRow
Dim isLoadOnDemand As System.Boolean

instance.ExpandSelfRefRow(isLoadOnDemand)
C#
public void ExpandSelfRefRow(
   System.bool isLoadOnDemand
)
Delphi
public procedure ExpandSelfRefRow(
    isLoadOnDemand: System.Boolean
);
JScript
public function ExpandSelfRefRow(
   isLoadOnDemand : System.boolean
);
Managed Extensions for C++
public: void ExpandSelfRefRow(
   System.bool isLoadOnDemand
)
C++/CLI
public:
void ExpandSelfRefRow(
   System.bool isLoadOnDemand
)

Parameters

isLoadOnDemand

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridRow Class
WebGridRow Members
Overload List


FillChildRow Method

[image]
Intersoft WebGrid Documentation
FillChildRow Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridRow Class : FillChildRow Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub FillChildRow()
Visual Basic (Usage) Copy Code
Dim instance As WebGridRow

instance.FillChildRow()
C#
public void FillChildRow()
Delphi
public procedure FillChildRow();
JScript
public function FillChildRow();
Managed Extensions for C++
public: void FillChildRow();
C++/CLI
public:
void FillChildRow();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridRow Class
WebGridRow Members


GetChildGroupRowsCount Method

[image]
Intersoft WebGrid Documentation
GetChildGroupRowsCount Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridRow Class : GetChildGroupRowsCount Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetChildGroupRowsCount() As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebGridRow
Dim value As System.Integer

value = instance.GetChildGroupRowsCount()
C#
public System.int GetChildGroupRowsCount()
Delphi
public function GetChildGroupRowsCount(): System.Integer;
JScript
public function GetChildGroupRowsCount() : System.int;
Managed Extensions for C++
public: System.int GetChildGroupRowsCount();
C++/CLI
public:
System.int GetChildGroupRowsCount();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridRow Class
WebGridRow Members


GetChildTableRows Method

[image]
Intersoft WebGrid Documentation
GetChildTableRows Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridRow Class : GetChildTableRows Method

childTable

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetChildTableRows( _
   ByVal childTable As WebGridTable _
) As WebGridRowCollection
Visual Basic (Usage) Copy Code
Dim instance As WebGridRow
Dim childTable As WebGridTable
Dim value As WebGridRowCollection

value = instance.GetChildTableRows(childTable)
C#
public WebGridRowCollection GetChildTableRows(
   WebGridTable childTable
)
Delphi
public function GetChildTableRows(
    childTable: WebGridTable
): WebGridRowCollection;
JScript
public function GetChildTableRows(
   childTable : WebGridTable
) : WebGridRowCollection;
Managed Extensions for C++
public: WebGridRowCollection* GetChildTableRows(
   WebGridTable* childTable
)
C++/CLI
public:
WebGridRowCollection^ GetChildTableRows(
   WebGridTable^ childTable
)

Parameters

childTable

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridRow Class
WebGridRow Members


GetDataRow Method

[image]
Intersoft WebGrid Documentation
GetDataRow Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridRow Class : GetDataRow Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetDataRow() As System.Data.DataRow
Visual Basic (Usage) Copy Code
Dim instance As WebGridRow
Dim value As System.Data.DataRow

value = instance.GetDataRow()
C#
public System.Data.DataRow GetDataRow()
Delphi
public function GetDataRow(): System.Data.DataRow;
JScript
public function GetDataRow() : System.Data.DataRow;
Managed Extensions for C++
public: System.Data.DataRow* GetDataRow();
C++/CLI
public:
System.Data.DataRow^ GetDataRow();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridRow Class
WebGridRow Members


GetGroup Method

[image]
Intersoft WebGrid Documentation
GetGroup Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridRow Class : GetGroup Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetGroup() As WebGridGroup
Visual Basic (Usage) Copy Code
Dim instance As WebGridRow
Dim value As WebGridGroup

value = instance.GetGroup()
C#
public WebGridGroup GetGroup()
Delphi
public function GetGroup(): WebGridGroup;
JScript
public function GetGroup() : WebGridGroup;
Managed Extensions for C++
public: WebGridGroup* GetGroup();
C++/CLI
public:
WebGridGroup^ GetGroup();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridRow Class
WebGridRow Members


GetGroupRowFullPathName Method

[image]
Intersoft WebGrid Documentation
GetGroupRowFullPathName Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridRow Class : GetGroupRowFullPathName Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetGroupRowFullPathName() As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebGridRow
Dim value As System.String

value = instance.GetGroupRowFullPathName()
C#
public System.string GetGroupRowFullPathName()
Delphi
public function GetGroupRowFullPathName(): System.String;
JScript
public function GetGroupRowFullPathName() : System.String;
Managed Extensions for C++
public: System.string* GetGroupRowFullPathName();
C++/CLI
public:
System.String^ GetGroupRowFullPathName();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridRow Class
WebGridRow Members


GetGroupRowLevel Method

[image]
Intersoft WebGrid Documentation
GetGroupRowLevel Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridRow Class : GetGroupRowLevel Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetGroupRowLevel() As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebGridRow
Dim value As System.String

value = instance.GetGroupRowLevel()
C#
public System.string GetGroupRowLevel()
Delphi
public function GetGroupRowLevel(): System.String;
JScript
public function GetGroupRowLevel() : System.String;
Managed Extensions for C++
public: System.string* GetGroupRowLevel();
C++/CLI
public:
System.String^ GetGroupRowLevel();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridRow Class
WebGridRow Members


GetHashCode Method

[image]
Intersoft WebGrid Documentation
GetHashCode Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridRow Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebGridRow
Dim value As System.Integer

value = instance.GetHashCode()
C#
public virtual System.int GetHashCode()
Delphi
public function GetHashCode(): System.Integer; virtual;
JScript
public function GetHashCode() : System.int;
Managed Extensions for C++
public: virtual System.int GetHashCode();
C++/CLI
public:
virtual System.int GetHashCode();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridRow Class
WebGridRow Members


GetObjectData Method

[image]
Intersoft WebGrid Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridRow Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebGridRow
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure GetObjectData(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
); override;
JScript
public override function GetObjectData(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void GetObjectData(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
) override
C++/CLI
public:
void GetObjectData(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
) override

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridRow Class
WebGridRow Members


GetObjectRow Method

[image]
Intersoft WebGrid Documentation
GetObjectRow Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridRow Class : GetObjectRow Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetObjectRow() As System.Object
Visual Basic (Usage) Copy Code
Dim instance As WebGridRow
Dim value As System.Object

value = instance.GetObjectRow()
C#
public System.object GetObjectRow()
Delphi
public function GetObjectRow(): System.TObject;
JScript
public function GetObjectRow() : System.Object;
Managed Extensions for C++
public: System.Object* GetObjectRow();
C++/CLI
public:
System.Object^ GetObjectRow();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridRow Class
WebGridRow Members


GetParentRow Method

[image]
Intersoft WebGrid Documentation
GetParentRow Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridRow Class : GetParentRow Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetParentRow() As WebGridRow
Visual Basic (Usage) Copy Code
Dim instance As WebGridRow
Dim value As WebGridRow

value = instance.GetParentRow()
C#
public WebGridRow GetParentRow()
Delphi
public function GetParentRow(): WebGridRow;
JScript
public function GetParentRow() : WebGridRow;
Managed Extensions for C++
public: WebGridRow* GetParentRow();
C++/CLI
public:
WebGridRow^ GetParentRow();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridRow Class
WebGridRow Members


GetRootRow Method

[image]
Intersoft WebGrid Documentation
GetRootRow Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridRow Class : GetRootRow Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetRootRow() As WebGridRow
Visual Basic (Usage) Copy Code
Dim instance As WebGridRow
Dim value As WebGridRow

value = instance.GetRootRow()
C#
public WebGridRow GetRootRow()
Delphi
public function GetRootRow(): WebGridRow;
JScript
public function GetRootRow() : WebGridRow;
Managed Extensions for C++
public: WebGridRow* GetRootRow();
C++/CLI
public:
WebGridRow^ GetRootRow();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridRow Class
WebGridRow Members


GetRootSelfRefRow Method

[image]
Intersoft WebGrid Documentation
GetRootSelfRefRow Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridRow Class : GetRootSelfRefRow Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetRootSelfRefRow() As WebGridRow
Visual Basic (Usage) Copy Code
Dim instance As WebGridRow
Dim value As WebGridRow

value = instance.GetRootSelfRefRow()
C#
public WebGridRow GetRootSelfRefRow()
Delphi
public function GetRootSelfRefRow(): WebGridRow;
JScript
public function GetRootSelfRefRow() : WebGridRow;
Managed Extensions for C++
public: WebGridRow* GetRootSelfRefRow();
C++/CLI
public:
WebGridRow^ GetRootSelfRefRow();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridRow Class
WebGridRow Members


HasCollapsedParents Method

[image]
Intersoft WebGrid Documentation
HasCollapsedParents Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridRow Class : HasCollapsedParents Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function HasCollapsedParents() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebGridRow
Dim value As System.Boolean

value = instance.HasCollapsedParents()
C#
public System.bool HasCollapsedParents()
Delphi
public function HasCollapsedParents(): System.Boolean;
JScript
public function HasCollapsedParents() : System.boolean;
Managed Extensions for C++
public: System.bool HasCollapsedParents();
C++/CLI
public:
System.bool HasCollapsedParents();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridRow Class
WebGridRow Members


HasExpandedChilds Method

[image]
Intersoft WebGrid Documentation
HasExpandedChilds Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridRow Class : HasExpandedChilds Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function HasExpandedChilds() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebGridRow
Dim value As System.Boolean

value = instance.HasExpandedChilds()
C#
public System.bool HasExpandedChilds()
Delphi
public function HasExpandedChilds(): System.Boolean;
JScript
public function HasExpandedChilds() : System.boolean;
Managed Extensions for C++
public: System.bool HasExpandedChilds();
C++/CLI
public:
System.bool HasExpandedChilds();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridRow Class
WebGridRow Members


HasGrouppedChilds Method

[image]
Intersoft WebGrid Documentation
HasGrouppedChilds Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridRow Class : HasGrouppedChilds Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function HasGrouppedChilds() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebGridRow
Dim value As System.Boolean

value = instance.HasGrouppedChilds()
C#
public System.bool HasGrouppedChilds()
Delphi
public function HasGrouppedChilds(): System.Boolean;
JScript
public function HasGrouppedChilds() : System.boolean;
Managed Extensions for C++
public: System.bool HasGrouppedChilds();
C++/CLI
public:
System.bool HasGrouppedChilds();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridRow Class
WebGridRow Members


IsEmpty Method

[image]
Intersoft WebGrid Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridRow Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebGridRow
Dim value As System.Boolean

value = instance.IsEmpty()
C#
public virtual System.bool IsEmpty()
Delphi
public function IsEmpty(): System.Boolean; virtual;
JScript
public function IsEmpty() : System.boolean;
Managed Extensions for C++
public: virtual System.bool IsEmpty();
C++/CLI
public:
virtual System.bool IsEmpty();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridRow Class
WebGridRow Members


Reset Method

[image]
Intersoft WebGrid Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridRow Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As WebGridRow

instance.Reset()
C#
public virtual void Reset()
Delphi
public procedure Reset(); virtual;
JScript
public function Reset();
Managed Extensions for C++
public: virtual void Reset();
C++/CLI
public:
virtual void Reset();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridRow Class
WebGridRow Members


SerializeObjectData Method

[image]
Intersoft WebGrid Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridRow Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebGridRow
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure SerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function SerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void SerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void SerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridRow Class
WebGridRow Members


ToString Method

[image]
Intersoft WebGrid Documentation
ToString Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridRow Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString() As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebGridRow
Dim value As System.String

value = instance.ToString()
C#
public override System.string ToString()
Delphi
public function ToString(): System.String; override;
JScript
public override function ToString() : System.String;
Managed Extensions for C++
public: System.string* ToString(); override
C++/CLI
public:
System.String^ ToString(); override

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridRow Class
WebGridRow Members


WebGridRow Class Properties

[image]
Intersoft WebGrid Documentation
WebGridRow Class Properties
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : WebGridRow Class

Glossary Item Box

For a list of all members of this type, see WebGridRow members.

Public Properties

 | Name | Description
Public Property | Cells |
Public Property | Checked |
Public Property | ChildNotExpandable |
Public Property | Expanded |
Public Property | ForceNoEdit |
Public Property | Height |
Public Property | SelfRefChildNotExpandable |
Public Property | Style |
Public Property | Visible |
Top

See Also

Reference

WebGridRow Class
ISNet.WebUI.WebGrid Namespace


Cells Property

[image]
Intersoft WebGrid Documentation
Cells Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridRow Class : Cells Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute()>
Public ReadOnly Property Cells As WebGridCellCollection
Visual Basic (Usage) Copy Code
Dim instance As WebGridRow
Dim value As WebGridCellCollection

value = instance.Cells
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute()]
public WebGridCellCollection Cells {get;}
Delphi
public read-only property Cells: WebGridCellCollection;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute()
public function get Cells : WebGridCellCollection
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute()]
public: __property WebGridCellCollection* get_Cells();
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute()]
public:
property WebGridCellCollection^ Cells {
   WebGridCellCollection^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridRow Class
WebGridRow Members


Checked Property

[image]
Intersoft WebGrid Documentation
Checked Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridRow Class : Checked Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Specifies whether this row should be checked or not.")>
Public Property Checked As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebGridRow
Dim value As System.Boolean

instance.Checked = value

value = instance.Checked
C#
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies whether this row should be checked or not.")]
public System.bool Checked {get; set;}
Delphi
public read-write property Checked: System.Boolean;
JScript
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Specifies whether this row should be checked or not.")
public function get,set Checked : System.boolean
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies whether this row should be checked or not.")]
public: __property System.bool get_Checked();
public: __property void set_Checked(
   System.bool value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies whether this row should be checked or not.")]
public:
property System.bool Checked {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridRow Class
WebGridRow Members


ChildNotExpandable Property

[image]
Intersoft WebGrid Documentation
ChildNotExpandable Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridRow Class : ChildNotExpandable Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Gets or sets a value indicating whether or not the child row is expandable. When set to True, the expand/plus icon will not be shown.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
Public Property ChildNotExpandable As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebGridRow
Dim value As System.Boolean

instance.ChildNotExpandable = value

value = instance.ChildNotExpandable
C#
[System.ComponentModel.DescriptionAttribute("Gets or sets a value indicating whether or not the child row is expandable. When set to True, the expand/plus icon will not be shown.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public System.bool ChildNotExpandable {get; set;}
Delphi
public read-write property ChildNotExpandable: System.Boolean;
JScript
System.ComponentModel.DescriptionAttribute("Gets or sets a value indicating whether or not the child row is expandable. When set to True, the expand/plus icon will not be shown.")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
public function get,set ChildNotExpandable : System.boolean
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Gets or sets a value indicating whether or not the child row is expandable. When set to True, the expand/plus icon will not be shown.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.bool get_ChildNotExpandable();
public: __property void set_ChildNotExpandable(
   System.bool value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Gets or sets a value indicating whether or not the child row is expandable. When set to True, the expand/plus icon will not be shown.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.bool ChildNotExpandable {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridRow Class
WebGridRow Members


Expanded Property

[image]
Intersoft WebGrid Documentation
Expanded Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridRow Class : Expanded Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Gets or sets a value whether or not the row is expanded.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
Public Property Expanded As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebGridRow
Dim value As System.Boolean

instance.Expanded = value

value = instance.Expanded
C#
[System.ComponentModel.DescriptionAttribute("Gets or sets a value whether or not the row is expanded.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public System.bool Expanded {get; set;}
Delphi
public read-write property Expanded: System.Boolean;
JScript
System.ComponentModel.DescriptionAttribute("Gets or sets a value whether or not the row is expanded.")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
public function get,set Expanded : System.boolean
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Gets or sets a value whether or not the row is expanded.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.bool get_Expanded();
public: __property void set_Expanded(
   System.bool value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Gets or sets a value whether or not the row is expanded.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.bool Expanded {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridRow Class
WebGridRow Members


ForceNoEdit Property

[image]
Intersoft WebGrid Documentation
ForceNoEdit Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridRow Class : ForceNoEdit Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Determines whether this row will be forced to not allow editing.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
Public Property ForceNoEdit As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebGridRow
Dim value As System.Boolean

instance.ForceNoEdit = value

value = instance.ForceNoEdit
C#
[System.ComponentModel.DescriptionAttribute("Determines whether this row will be forced to not allow editing.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public System.bool ForceNoEdit {get; set;}
Delphi
public read-write property ForceNoEdit: System.Boolean;
JScript
System.ComponentModel.DescriptionAttribute("Determines whether this row will be forced to not allow editing.")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
public function get,set ForceNoEdit : System.boolean
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Determines whether this row will be forced to not allow editing.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.bool get_ForceNoEdit();
public: __property void set_ForceNoEdit(
   System.bool value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Determines whether this row will be forced to not allow editing.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.bool ForceNoEdit {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridRow Class
WebGridRow Members


Height Property

[image]
Intersoft WebGrid Documentation
Height Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridRow Class : Height Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Gets or sets the height of the row in Unit.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property Height As System.Web.UI.WebControls.Unit
Visual Basic (Usage) Copy Code
Dim instance As WebGridRow
Dim value As System.Web.UI.WebControls.Unit

instance.Height = value

value = instance.Height
C#
[System.ComponentModel.DescriptionAttribute("Gets or sets the height of the row in Unit.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
public System.Web.UI.WebControls.Unit Height {get; set;}
Delphi
public read-write property Height: System.Web.UI.WebControls.Unit;
JScript
System.ComponentModel.DescriptionAttribute("Gets or sets the height of the row in Unit.")
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get,set Height : System.Web.UI.WebControls.Unit
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Gets or sets the height of the row in Unit.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.Web.UI.WebControls.Unit get_Height();
public: __property void set_Height(
   System.Web.UI.WebControls.Unit value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Gets or sets the height of the row in Unit.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.Web.UI.WebControls.Unit Height {
   System.Web.UI.WebControls.Unit get();
   void set (    System.Web.UI.WebControls.Unit value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridRow Class
WebGridRow Members


SelfRefChildNotExpandable Property

[image]
Intersoft WebGrid Documentation
SelfRefChildNotExpandable Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridRow Class : SelfRefChildNotExpandable Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Gets or sets a value indicating whether or not the self ref child row is expandable. When set to True, the expand/plus icon will not be shown.")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property SelfRefChildNotExpandable As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebGridRow
Dim value As System.Boolean

instance.SelfRefChildNotExpandable = value

value = instance.SelfRefChildNotExpandable
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets a value indicating whether or not the self ref child row is expandable. When set to True, the expand/plus icon will not be shown.")]
[System.ComponentModel.DefaultValueAttribute()]
public System.bool SelfRefChildNotExpandable {get; set;}
Delphi
public read-write property SelfRefChildNotExpandable: System.Boolean;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets a value indicating whether or not the self ref child row is expandable. When set to True, the expand/plus icon will not be shown.")
System.ComponentModel.DefaultValueAttribute()
public function get,set SelfRefChildNotExpandable : System.boolean
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets a value indicating whether or not the self ref child row is expandable. When set to True, the expand/plus icon will not be shown.")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.bool get_SelfRefChildNotExpandable();
public: __property void set_SelfRefChildNotExpandable(
   System.bool value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets a value indicating whether or not the self ref child row is expandable. When set to True, the expand/plus icon will not be shown.")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.bool SelfRefChildNotExpandable {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridRow Class
WebGridRow Members


Style Property

[image]
Intersoft WebGrid Documentation
Style Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridRow Class : Style Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Gets or sets the style applied to the row.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
Public Property Style As WebGridFormatStyle
Visual Basic (Usage) Copy Code
Dim instance As WebGridRow
Dim value As WebGridFormatStyle

instance.Style = value

value = instance.Style
C#
[System.ComponentModel.DescriptionAttribute("Gets or sets the style applied to the row.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
public WebGridFormatStyle Style {get; set;}
Delphi
public read-write property Style: WebGridFormatStyle;
JScript
System.ComponentModel.DescriptionAttribute("Gets or sets the style applied to the row.")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
public function get,set Style : WebGridFormatStyle
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Gets or sets the style applied to the row.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
public: __property WebGridFormatStyle* get_Style();
public: __property void set_Style(
   WebGridFormatStyle* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Gets or sets the style applied to the row.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
public:
property WebGridFormatStyle^ Style {
   WebGridFormatStyle^ get();
   void set (    WebGridFormatStyle^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridRow Class
WebGridRow Members


Visible Property

[image]
Intersoft WebGrid Documentation
Visible Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridRow Class : Visible Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Specifies whether the row should be rendered.")>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property Visible As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebGridRow
Dim value As System.Boolean

instance.Visible = value

value = instance.Visible
C#
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies whether the row should be rendered.")]
[ISNet.Serialization.BinarySerializableAttribute()]
public System.bool Visible {get; set;}
Delphi
public read-write property Visible: System.Boolean;
JScript
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Specifies whether the row should be rendered.")
ISNet.Serialization.BinarySerializableAttribute()
public function get,set Visible : System.boolean
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies whether the row should be rendered.")]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.bool get_Visible();
public: __property void set_Visible(
   System.bool value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies whether the row should be rendered.")]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.bool Visible {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridRow Class
WebGridRow Members


WebGridRowChanges Class

[image]
Intersoft WebGrid Documentation
WebGridRowChanges Class
Members See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : WebGridRowChanges Class

Glossary Item Box

Object Model

WebGridRowChanges Class

Syntax

Visual Basic (Declaration)
Public Class WebGridRowChanges
Visual Basic (Usage) Copy Code
Dim instance As WebGridRowChanges
C#
public class WebGridRowChanges
Delphi
public class WebGridRowChanges
JScript
public class WebGridRowChanges
Managed Extensions for C++
public __gc class WebGridRowChanges
C++/CLI
public ref class WebGridRowChanges

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebGrid.WebGridRowChanges

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridRowChanges Members
ISNet.WebUI.WebGrid Namespace


WebGridRowChanges Class Members

[image]
Intersoft WebGrid Documentation
WebGridRowChanges Class Members
See Also Properties Send Feedback
ISNet.WebUI.WebGrid Namespace : WebGridRowChanges Class

Glossary Item Box

The following tables list the members exposed by WebGridRowChanges.

Public Constructors

 | Name | Description
Public Constructor | WebGridRowChanges Constructor |
Top

Public Properties

 | Name | Description
Public Property | Data |
Public Property | KeyValue |
Public Property | KeyValues |
Public Property | ParentRowChanges |
Public Property | ParentRowKeyValues |
Public Property | ParentTable |
Public Property | Row |
Public Property | RowState |
Public Property | Table |
Top

See Also

Reference

WebGridRowChanges Class
ISNet.WebUI.WebGrid Namespace


WebGridRowChanges Constructor

[image]
Intersoft WebGrid Documentation
WebGridRowChanges Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridRowChanges Class : WebGridRowChanges Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebGridRowChanges()
C#
public WebGridRowChanges()
Delphi
public WebGridRowChanges();
JScript
public function WebGridRowChanges();
Managed Extensions for C++
public: WebGridRowChanges();
C++/CLI
public:
WebGridRowChanges();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridRowChanges Class
WebGridRowChanges Members


WebGridRowChanges Class Properties

[image]
Intersoft WebGrid Documentation
WebGridRowChanges Class Properties
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : WebGridRowChanges Class

Glossary Item Box

For a list of all members of this type, see WebGridRowChanges members.

Public Properties

 | Name | Description
Public Property | Data |
Public Property | KeyValue |
Public Property | KeyValues |
Public Property | ParentRowChanges |
Public Property | ParentRowKeyValues |
Public Property | ParentTable |
Public Property | Row |
Public Property | RowState |
Public Property | Table |
Top

See Also

Reference

WebGridRowChanges Class
ISNet.WebUI.WebGrid Namespace


Data Property

[image]
Intersoft WebGrid Documentation
Data Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridRowChanges Class : Data Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Data As System.Collections.Generic.List(Of WebGridCellData)
Visual Basic (Usage) Copy Code
Dim instance As WebGridRowChanges
Dim value As System.Collections.Generic.List(Of WebGridCellData)

value = instance.Data
C#
public System.Collections.Generic.List<WebGridCellData> Data {get;}
Delphi
public read-only property Data: System.Collections.Generic.List;
JScript
public function get Data : System.Collections.Generic.List
Managed Extensions for C++
public: __property System.Collections.Generic.List<WebGridCellData*>* get_Data();
C++/CLI
public:
property System.Collections.Generic.List<WebGridCellData^>^ Data {
   System.Collections.Generic.List<WebGridCellData^>^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridRowChanges Class
WebGridRowChanges Members


KeyValue Property

[image]
Intersoft WebGrid Documentation
KeyValue Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridRowChanges Class : KeyValue Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property KeyValue As System.Object
Visual Basic (Usage) Copy Code
Dim instance As WebGridRowChanges
Dim value As System.Object

value = instance.KeyValue
C#
public System.object KeyValue {get;}
Delphi
public read-only property KeyValue: System.TObject;
JScript
public function get KeyValue : System.Object
Managed Extensions for C++
public: __property System.Object* get_KeyValue();
C++/CLI
public:
property System.Object^ KeyValue {
   System.Object^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridRowChanges Class
WebGridRowChanges Members


KeyValues Property

[image]
Intersoft WebGrid Documentation
KeyValues Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridRowChanges Class : KeyValues Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property KeyValues As System.Collections.ArrayList
Visual Basic (Usage) Copy Code
Dim instance As WebGridRowChanges
Dim value As System.Collections.ArrayList

value = instance.KeyValues
C#
public System.Collections.ArrayList KeyValues {get;}
Delphi
public read-only property KeyValues: System.Collections.ArrayList;
JScript
public function get KeyValues : System.Collections.ArrayList
Managed Extensions for C++
public: __property System.Collections.ArrayList* get_KeyValues();
C++/CLI
public:
property System.Collections.ArrayList^ KeyValues {
   System.Collections.ArrayList^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridRowChanges Class
WebGridRowChanges Members


ParentRowChanges Property

[image]
Intersoft WebGrid Documentation
ParentRowChanges Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridRowChanges Class : ParentRowChanges Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ParentRowChanges As WebGridRowChanges
Visual Basic (Usage) Copy Code
Dim instance As WebGridRowChanges
Dim value As WebGridRowChanges

value = instance.ParentRowChanges
C#
public WebGridRowChanges ParentRowChanges {get;}
Delphi
public read-only property ParentRowChanges: WebGridRowChanges;
JScript
public function get ParentRowChanges : WebGridRowChanges
Managed Extensions for C++
public: __property WebGridRowChanges* get_ParentRowChanges();
C++/CLI
public:
property WebGridRowChanges^ ParentRowChanges {
   WebGridRowChanges^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridRowChanges Class
WebGridRowChanges Members


ParentRowKeyValues Property

[image]
Intersoft WebGrid Documentation
ParentRowKeyValues Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridRowChanges Class : ParentRowKeyValues Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ParentRowKeyValues As System.Collections.ArrayList
Visual Basic (Usage) Copy Code
Dim instance As WebGridRowChanges
Dim value As System.Collections.ArrayList

value = instance.ParentRowKeyValues
C#
public System.Collections.ArrayList ParentRowKeyValues {get;}
Delphi
public read-only property ParentRowKeyValues: System.Collections.ArrayList;
JScript
public function get ParentRowKeyValues : System.Collections.ArrayList
Managed Extensions for C++
public: __property System.Collections.ArrayList* get_ParentRowKeyValues();
C++/CLI
public:
property System.Collections.ArrayList^ ParentRowKeyValues {
   System.Collections.ArrayList^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridRowChanges Class
WebGridRowChanges Members


ParentTable Property

[image]
Intersoft WebGrid Documentation
ParentTable Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridRowChanges Class : ParentTable Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ParentTable As WebGridTable
Visual Basic (Usage) Copy Code
Dim instance As WebGridRowChanges
Dim value As WebGridTable

value = instance.ParentTable
C#
public WebGridTable ParentTable {get;}
Delphi
public read-only property ParentTable: WebGridTable;
JScript
public function get ParentTable : WebGridTable
Managed Extensions for C++
public: __property WebGridTable* get_ParentTable();
C++/CLI
public:
property WebGridTable^ ParentTable {
   WebGridTable^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridRowChanges Class
WebGridRowChanges Members


Row Property

[image]
Intersoft WebGrid Documentation
Row Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridRowChanges Class : Row Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Row As WebGridRow
Visual Basic (Usage) Copy Code
Dim instance As WebGridRowChanges
Dim value As WebGridRow

value = instance.Row
C#
public WebGridRow Row {get;}
Delphi
public read-only property Row: WebGridRow;
JScript
public function get Row : WebGridRow
Managed Extensions for C++
public: __property WebGridRow* get_Row();
C++/CLI
public:
property WebGridRow^ Row {
   WebGridRow^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridRowChanges Class
WebGridRowChanges Members


RowState Property

[image]
Intersoft WebGrid Documentation
RowState Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridRowChanges Class : RowState Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("The change state of the row.")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property RowState As RowState
Visual Basic (Usage) Copy Code
Dim instance As WebGridRowChanges
Dim value As RowState

instance.RowState = value

value = instance.RowState
C#
[System.ComponentModel.DescriptionAttribute("The change state of the row.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public RowState RowState {get; set;}
Delphi
public read-write property RowState: RowState;
JScript
System.ComponentModel.DescriptionAttribute("The change state of the row.")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set RowState : RowState
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("The change state of the row.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property RowState get_RowState();
public: __property void set_RowState(
   RowState value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("The change state of the row.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property RowState RowState {
   RowState get();
   void set (    RowState value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridRowChanges Class
WebGridRowChanges Members


Table Property

[image]
Intersoft WebGrid Documentation
Table Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridRowChanges Class : Table Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Table As WebGridTable
Visual Basic (Usage) Copy Code
Dim instance As WebGridRowChanges
Dim value As WebGridTable

value = instance.Table
C#
public WebGridTable Table {get;}
Delphi
public read-only property Table: WebGridTable;
JScript
public function get Table : WebGridTable
Managed Extensions for C++
public: __property WebGridTable* get_Table();
C++/CLI
public:
property WebGridTable^ Table {
   WebGridTable^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridRowChanges Class
WebGridRowChanges Members


WebGridRowCollection Class

[image]
Intersoft WebGrid Documentation
WebGridRowCollection Class
Members See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : WebGridRowCollection Class

Glossary Item Box

Object Model

WebGridRowCollection Class

Syntax

Visual Basic (Declaration)
<System.Reflection.DefaultMemberAttribute("Item")>
<System.SerializableAttribute()>
Public Class WebGridRowCollection
   Inherits ISNet.WebUI.ISCollectionBase
Visual Basic (Usage) Copy Code
Dim instance As WebGridRowCollection
C#
[System.Reflection.DefaultMemberAttribute("Item")]
[System.SerializableAttribute()]
public class WebGridRowCollection : ISNet.WebUI.ISCollectionBase
Delphi
public class WebGridRowCollection = class(ISNet.WebUI.ISCollectionBase)
JScript
System.Reflection.DefaultMemberAttribute("Item")
System.SerializableAttribute()
public class WebGridRowCollection extends ISNet.WebUI.ISCollectionBase
Managed Extensions for C++
[System.Reflection.DefaultMemberAttribute("Item")]
[System.SerializableAttribute()]
public __gc class WebGridRowCollection : public ISNet.WebUI.ISCollectionBase
C++/CLI
[System.Reflection.DefaultMemberAttribute("Item")]
[System.SerializableAttribute()]
public ref class WebGridRowCollection : public ISNet.WebUI.ISCollectionBase

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
ISNet.WebUI.ISCollectionBase
ISNet.WebUI.WebGrid.WebGridRowCollection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridRowCollection Members
ISNet.WebUI.WebGrid Namespace


WebGridRowCollection Class Members

[image]
Intersoft WebGrid Documentation
WebGridRowCollection Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebGrid Namespace : WebGridRowCollection Class

Glossary Item Box

The following tables list the members exposed by WebGridRowCollection.

Public Constructors

 | Name | Description
Public Constructor | WebGridRowCollection Constructor |
Top

Public Properties

 | Name | Description
Public Property | Capacity | (Inherited from System.Collections.CollectionBase)
Public Property | Count | (Inherited from System.Collections.CollectionBase)
Public Property | IsReadOnly | Overridden.
Public Property | Item |
Public Property | Parent | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Property | Table |
Top

Public Methods

 | Name | Description
Public Method | Add | Overloaded.
Public Method | AddRange |
Public Method | Clear |
Public Method | Contains | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | CopyFrom |
Public Method | CopyTo | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | Exists | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | GetEnumerator |
Public Method | GetItem | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | GetNamedItem |
Public Method | GetRowByKeyValue |
static (Shared in Visual Basic) | ImportFrom |
Public Method | IndexOf | Overloaded. (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | Insert |
Public Method | IntInsert | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | Remove |
Public Method | SetHierarchicalType |
Public Method | setParent | (Inherited from ISNet.WebUI.ISCollectionBase)
Top

See Also

Reference

WebGridRowCollection Class
ISNet.WebUI.WebGrid Namespace


WebGridRowCollection Constructor

[image]
Intersoft WebGrid Documentation
WebGridRowCollection Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridRowCollection Class : WebGridRowCollection Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebGridRowCollection()
C#
public WebGridRowCollection()
Delphi
public WebGridRowCollection();
JScript
public function WebGridRowCollection();
Managed Extensions for C++
public: WebGridRowCollection();
C++/CLI
public:
WebGridRowCollection();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridRowCollection Class
WebGridRowCollection Members


WebGridRowCollection Class Methods

[image]
Intersoft WebGrid Documentation
WebGridRowCollection Class Methods
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : WebGridRowCollection Class

Glossary Item Box

For a list of all members of this type, see WebGridRowCollection members.

Public Methods

 | Name | Description
Public Method | Add | Overloaded.
Public Method | AddRange |
Public Method | Clear |
Public Method | Contains | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | CopyFrom |
Public Method | CopyTo | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | Exists | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | GetEnumerator |
Public Method | GetItem | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | GetNamedItem |
Public Method | GetRowByKeyValue |
static (Shared in Visual Basic) | ImportFrom |
Public Method | IndexOf | Overloaded. (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | Insert |
Public Method | IntInsert | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | Remove |
Public Method | SetHierarchicalType |
Public Method | setParent | (Inherited from ISNet.WebUI.ISCollectionBase)
Top

See Also

Reference

WebGridRowCollection Class
ISNet.WebUI.WebGrid Namespace


Add Method

[image]
Intersoft WebGrid Documentation
Add Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridRowCollection Class : Add Method

Glossary Item Box

Overload List

Overload | Description
Add(WebGridRow) |
Add(String) |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridRowCollection Class
WebGridRowCollection Members


Add(WebGridRow) Method

[image]
Intersoft WebGrid Documentation
Add(WebGridRow) Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridRowCollection Class > Add Method : Add(WebGridRow) Method

webGridRow

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function Add( _
   ByVal webGridRow As WebGridRow _
) As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebGridRowCollection
Dim webGridRow As WebGridRow
Dim value As System.Integer

value = instance.Add(webGridRow)
C#
public virtual System.int Add(
   WebGridRow webGridRow
)
Delphi
public function Add(
    webGridRow: WebGridRow
): System.Integer; virtual;
JScript
public function Add(
   webGridRow : WebGridRow
) : System.int;
Managed Extensions for C++
public: virtual System.int Add(
   WebGridRow* webGridRow
)
C++/CLI
public:
virtual System.int Add(
   WebGridRow^ webGridRow
)

Parameters

webGridRow

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridRowCollection Class
WebGridRowCollection Members
Overload List


Add(String) Method

[image]
Intersoft WebGrid Documentation
Add(String) Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridRowCollection Class > Add Method : Add(String) Method

name

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function Add( _
   ByVal name As System.String _
) As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebGridRowCollection
Dim name As System.String
Dim value As System.Integer

value = instance.Add(name)
C#
public System.int Add(
   System.string name
)
Delphi
public function Add(
    name: System.String
): System.Integer;
JScript
public function Add(
   name : System.String
) : System.int;
Managed Extensions for C++
public: System.int Add(
   System.string* name
)
C++/CLI
public:
System.int Add(
   System.String^ name
)

Parameters

name

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridRowCollection Class
WebGridRowCollection Members
Overload List


AddRange Method

[image]
Intersoft WebGrid Documentation
AddRange Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridRowCollection Class : AddRange Method

rows

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub AddRange( _
   ByVal rows() As WebGridRow _
)
Visual Basic (Usage) Copy Code
Dim instance As WebGridRowCollection
Dim rows() As WebGridRow

instance.AddRange(rows)
C#
public virtual void AddRange(
   WebGridRow[] rows
)
Delphi
public procedure AddRange(
    rows: WebGridRowarray of
); virtual;
JScript
public function AddRange(
   rows : WebGridRow[]
);
Managed Extensions for C++
public: virtual void AddRange(
   WebGridRow*[]* rows
)
C++/CLI
public:
virtual void AddRange(
   array<WebGridRow^>^ rows
)

Parameters

rows

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridRowCollection Class
WebGridRowCollection Members


Clear Method

[image]
Intersoft WebGrid Documentation
Clear Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridRowCollection Class : Clear Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Shadows Sub Clear()
Visual Basic (Usage) Copy Code
Dim instance As WebGridRowCollection

instance.Clear()
C#
public new void Clear()
Delphi
public procedure Clear();
JScript
public hide function Clear();
Managed Extensions for C++
public: new void Clear();
C++/CLI
public:
new void Clear();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridRowCollection Class
WebGridRowCollection Members


Contains Method

[image]
Intersoft WebGrid Documentation
Contains Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridRowCollection Class : Contains Method

value

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function Contains( _
   ByVal value As ISNet.WebUI.INamedObject _
) As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebGridRowCollection
Dim value As ISNet.WebUI.INamedObject
Dim value As System.Boolean

value = instance.Contains(value)
C#
public System.bool Contains(
   ISNet.WebUI.INamedObject value
)
Delphi
public function Contains(
    value: ISNet.WebUI.INamedObject
): System.Boolean;
JScript
public function Contains(
   value : ISNet.WebUI.INamedObject
) : System.boolean;
Managed Extensions for C++
public: System.bool Contains(
   ISNet.WebUI.INamedObject* value
)
C++/CLI
public:
System.bool Contains(
   ISNet.WebUI.INamedObject^ value
)

Parameters

value

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridRowCollection Class
WebGridRowCollection Members


CopyFrom Method

[image]
Intersoft WebGrid Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridRowCollection Class : CopyFrom Method

passIn

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function CopyFrom( _
   ByVal passIn As WebGridRowCollection _
) As WebGridRowCollection
Visual Basic (Usage) Copy Code
Dim instance As WebGridRowCollection
Dim passIn As WebGridRowCollection
Dim value As WebGridRowCollection

value = instance.CopyFrom(passIn)
C#
public WebGridRowCollection CopyFrom(
   WebGridRowCollection passIn
)
Delphi
public function CopyFrom(
    passIn: WebGridRowCollection
): WebGridRowCollection;
JScript
public function CopyFrom(
   passIn : WebGridRowCollection
) : WebGridRowCollection;
Managed Extensions for C++
public: WebGridRowCollection* CopyFrom(
   WebGridRowCollection* passIn
)
C++/CLI
public:
WebGridRowCollection^ CopyFrom(
   WebGridRowCollection^ passIn
)

Parameters

passIn

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridRowCollection Class
WebGridRowCollection Members


CopyTo Method

[image]
Intersoft WebGrid Documentation
CopyTo Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridRowCollection Class : CopyTo Method

array
index

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub CopyTo( _
   ByVal array() As ISNet.WebUI.INamedObject, _
   ByVal index As System.Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As WebGridRowCollection
Dim array() As ISNet.WebUI.INamedObject
Dim index As System.Integer

instance.CopyTo(array, index)
C#
public void CopyTo(
   ISNet.WebUI.INamedObject[] array,
   System.int index
)
Delphi
public procedure CopyTo(
    array: ISNet.WebUI.INamedObjectarray of;
    index: System.Integer
);
JScript
public function CopyTo(
   array : ISNet.WebUI.INamedObject[],
   index : System.int
);
Managed Extensions for C++
public: void CopyTo(
   ISNet.WebUI.INamedObject*[]* array,
   System.int index
)
C++/CLI
public:
void CopyTo(
   ISNet.WebUI.array<INamedObject^>^ array,
   System.int index
)

Parameters

array
index

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridRowCollection Class
WebGridRowCollection Members


Exists Method

[image]
Intersoft WebGrid Documentation
Exists Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridRowCollection Class : Exists Method

name

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function Exists( _
   ByVal name As System.String _
) As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebGridRowCollection
Dim name As System.String
Dim value As System.Boolean

value = instance.Exists(name)
C#
public System.bool Exists(
   System.string name
)
Delphi
public function Exists(
    name: System.String
): System.Boolean;
JScript
public function Exists(
   name : System.String
) : System.boolean;
Managed Extensions for C++
public: System.bool Exists(
   System.string* name
)
C++/CLI
public:
System.bool Exists(
   System.String^ name
)

Parameters

name

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridRowCollection Class
WebGridRowCollection Members


GetEnumerator Method

[image]
Intersoft WebGrid Documentation
GetEnumerator Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridRowCollection Class : GetEnumerator Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Shadows Function GetEnumerator() As System.Collections.IEnumerator
Visual Basic (Usage) Copy Code
Dim instance As WebGridRowCollection
Dim value As System.Collections.IEnumerator

value = instance.GetEnumerator()
C#
public new System.Collections.IEnumerator GetEnumerator()
Delphi
public function GetEnumerator(): System.Collections.IEnumerator;
JScript
public hide function GetEnumerator() : System.Collections.IEnumerator;
Managed Extensions for C++
public: new System.Collections.IEnumerator* GetEnumerator();
C++/CLI
public:
new System.Collections.IEnumerator^ GetEnumerator();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridRowCollection Class
WebGridRowCollection Members


GetItem Method

[image]
Intersoft WebGrid Documentation
GetItem Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridRowCollection Class : GetItem Method

Glossary Item Box

Overload List

Overload | Description
GetItem | (Inherited from ISNet.WebUI.ISCollectionBase)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridRowCollection Class
WebGridRowCollection Members


GetItem(Int32) Method

[image]
Intersoft WebGrid Documentation
GetItem(Int32) Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridRowCollection Class : GetItem(Int32) Method

index

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetItem( _
   ByVal index As System.Integer _
) As ISNet.WebUI.INamedObject
Visual Basic (Usage) Copy Code
Dim instance As WebGridRowCollection
Dim index As System.Integer
Dim value As ISNet.WebUI.INamedObject

value = instance.GetItem(index)
C#
public virtual ISNet.WebUI.INamedObject GetItem(
   System.int index
)
Delphi
public function GetItem(
    index: System.Integer
): ISNet.WebUI.INamedObject; virtual;
JScript
public function GetItem(
   index : System.int
) : ISNet.WebUI.INamedObject;
Managed Extensions for C++
public: virtual ISNet.WebUI.INamedObject* GetItem(
   System.int index
)
C++/CLI
public:
virtual ISNet.WebUI.INamedObject^ GetItem(
   System.int index
)

Parameters

index

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridRowCollection Class
WebGridRowCollection Members


GetNamedItem Method

[image]
Intersoft WebGrid Documentation
GetNamedItem Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridRowCollection Class : GetNamedItem Method

name

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetNamedItem( _
   ByVal name As System.String _
) As WebGridRow
Visual Basic (Usage) Copy Code
Dim instance As WebGridRowCollection
Dim name As System.String
Dim value As WebGridRow

value = instance.GetNamedItem(name)
C#
public WebGridRow GetNamedItem(
   System.string name
)
Delphi
public function GetNamedItem(
    name: System.String
): WebGridRow;
JScript
public function GetNamedItem(
   name : System.String
) : WebGridRow;
Managed Extensions for C++
public: WebGridRow* GetNamedItem(
   System.string* name
)
C++/CLI
public:
WebGridRow^ GetNamedItem(
   System.String^ name
)

Parameters

name

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridRowCollection Class
WebGridRowCollection Members


GetRowByKeyValue Method

[image]
Intersoft WebGrid Documentation
GetRowByKeyValue Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridRowCollection Class : GetRowByKeyValue Method

keyValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetRowByKeyValue( _
   ByVal keyValue As System.Object _
) As WebGridRow
Visual Basic (Usage) Copy Code
Dim instance As WebGridRowCollection
Dim keyValue As System.Object
Dim value As WebGridRow

value = instance.GetRowByKeyValue(keyValue)
C#
public WebGridRow GetRowByKeyValue(
   System.object keyValue
)
Delphi
public function GetRowByKeyValue(
    keyValue: System.TObject
): WebGridRow;
JScript
public function GetRowByKeyValue(
   keyValue : System.Object
) : WebGridRow;
Managed Extensions for C++
public: WebGridRow* GetRowByKeyValue(
   System.Object* keyValue
)
C++/CLI
public:
WebGridRow^ GetRowByKeyValue(
   System.Object^ keyValue
)

Parameters

keyValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridRowCollection Class
WebGridRowCollection Members


ImportFrom Method

[image]
Intersoft WebGrid Documentation
ImportFrom Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridRowCollection Class : ImportFrom Method

arrayOfRows

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Shared Function ImportFrom( _
   ByVal ParamArray arrayOfRows() As WebGridRow _
) As WebGridRowCollection
Visual Basic (Usage) Copy Code
Dim arrayOfRows() As WebGridRow
Dim value As WebGridRowCollection

value = WebGridRowCollection.ImportFrom(arrayOfRows)
C#
public static WebGridRowCollection ImportFrom(
   params WebGridRow[] arrayOfRows
)
Delphi
public function ImportFrom(
   params  arrayOfRows: WebGridRowarray of
): WebGridRowCollection; static;
JScript
public static function ImportFrom(
   arrayOfRows : WebGridRow[]
) : WebGridRowCollection;
Managed Extensions for C++
public: static WebGridRowCollection* ImportFrom(
   params WebGridRow*[]* arrayOfRows
)
C++/CLI
public:
static WebGridRowCollection^ ImportFrom(
   ... array<WebGridRow^>^ arrayOfRows
)

Parameters

arrayOfRows

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridRowCollection Class
WebGridRowCollection Members


IndexOf Method

[image]
Intersoft WebGrid Documentation
IndexOf Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridRowCollection Class : IndexOf Method

Glossary Item Box

Overload List

Overload | Description
IndexOf(String) | (Inherited from ISNet.WebUI.ISCollectionBase)
IndexOf(INamedObject) | (Inherited from ISNet.WebUI.ISCollectionBase)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridRowCollection Class
WebGridRowCollection Members


IndexOf(String) Method

[image]
Intersoft WebGrid Documentation
IndexOf(String) Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridRowCollection Class > IndexOf Method : IndexOf(String) Method

name

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function IndexOf( _
   ByVal name As System.String _
) As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebGridRowCollection
Dim name As System.String
Dim value As System.Integer

value = instance.IndexOf(name)
C#
public virtual System.int IndexOf(
   System.string name
)
Delphi
public function IndexOf(
    name: System.String
): System.Integer; virtual;
JScript
public function IndexOf(
   name : System.String
) : System.int;
Managed Extensions for C++
public: virtual System.int IndexOf(
   System.string* name
)
C++/CLI
public:
virtual System.int IndexOf(
   System.String^ name
)

Parameters

name

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridRowCollection Class
WebGridRowCollection Members
Overload List


IndexOf(INamedObject) Method

[image]
Intersoft WebGrid Documentation
IndexOf(INamedObject) Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridRowCollection Class > IndexOf Method : IndexOf(INamedObject) Method

value

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function IndexOf( _
   ByVal value As ISNet.WebUI.INamedObject _
) As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebGridRowCollection
Dim value As ISNet.WebUI.INamedObject
Dim value As System.Integer

value = instance.IndexOf(value)
C#
public System.int IndexOf(
   ISNet.WebUI.INamedObject value
)
Delphi
public function IndexOf(
    value: ISNet.WebUI.INamedObject
): System.Integer;
JScript
public function IndexOf(
   value : ISNet.WebUI.INamedObject
) : System.int;
Managed Extensions for C++
public: System.int IndexOf(
   ISNet.WebUI.INamedObject* value
)
C++/CLI
public:
System.int IndexOf(
   ISNet.WebUI.INamedObject^ value
)

Parameters

value

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridRowCollection Class
WebGridRowCollection Members
Overload List


Insert Method

[image]
Intersoft WebGrid Documentation
Insert Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridRowCollection Class : Insert Method

index
webGridRow

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub Insert( _
   ByVal index As System.Integer, _
   ByVal webGridRow As WebGridRow _
)
Visual Basic (Usage) Copy Code
Dim instance As WebGridRowCollection
Dim index As System.Integer
Dim webGridRow As WebGridRow

instance.Insert(index, webGridRow)
C#
public void Insert(
   System.int index,
   WebGridRow webGridRow
)
Delphi
public procedure Insert(
    index: System.Integer;
    webGridRow: WebGridRow
);
JScript
public function Insert(
   index : System.int,
   webGridRow : WebGridRow
);
Managed Extensions for C++
public: void Insert(
   System.int index,
   WebGridRow* webGridRow
)
C++/CLI
public:
void Insert(
   System.int index,
   WebGridRow^ webGridRow
)

Parameters

index
webGridRow

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridRowCollection Class
WebGridRowCollection Members


IntInsert Method

[image]
Intersoft WebGrid Documentation
IntInsert Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridRowCollection Class : IntInsert Method

index
value

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub IntInsert( _
   ByVal index As System.Integer, _
   ByVal value As ISNet.WebUI.INamedObject _
)
Visual Basic (Usage) Copy Code
Dim instance As WebGridRowCollection
Dim index As System.Integer
Dim value As ISNet.WebUI.INamedObject

instance.IntInsert(index, value)
C#
public void IntInsert(
   System.int index,
   ISNet.WebUI.INamedObject value
)
Delphi
public procedure IntInsert(
    index: System.Integer;
    value: ISNet.WebUI.INamedObject
);
JScript
public function IntInsert(
   index : System.int,
   value : ISNet.WebUI.INamedObject
);
Managed Extensions for C++
public: void IntInsert(
   System.int index,
   ISNet.WebUI.INamedObject* value
)
C++/CLI
public:
void IntInsert(
   System.int index,
   ISNet.WebUI.INamedObject^ value
)

Parameters

index
value

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridRowCollection Class
WebGridRowCollection Members


Remove Method

[image]
Intersoft WebGrid Documentation
Remove Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridRowCollection Class : Remove Method

webGridRow

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub Remove( _
   ByVal webGridRow As WebGridRow _
)
Visual Basic (Usage) Copy Code
Dim instance As WebGridRowCollection
Dim webGridRow As WebGridRow

instance.Remove(webGridRow)
C#
public void Remove(
   WebGridRow webGridRow
)
Delphi
public procedure Remove(
    webGridRow: WebGridRow
);
JScript
public function Remove(
   webGridRow : WebGridRow
);
Managed Extensions for C++
public: void Remove(
   WebGridRow* webGridRow
)
C++/CLI
public:
void Remove(
   WebGridRow^ webGridRow
)

Parameters

webGridRow

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridRowCollection Class
WebGridRowCollection Members


SetHierarchicalType Method

[image]
Intersoft WebGrid Documentation
SetHierarchicalType Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridRowCollection Class : SetHierarchicalType Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SetHierarchicalType()
Visual Basic (Usage) Copy Code
Dim instance As WebGridRowCollection

instance.SetHierarchicalType()
C#
public void SetHierarchicalType()
Delphi
public procedure SetHierarchicalType();
JScript
public function SetHierarchicalType();
Managed Extensions for C++
public: void SetHierarchicalType();
C++/CLI
public:
void SetHierarchicalType();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridRowCollection Class
WebGridRowCollection Members


setParent Method

[image]
Intersoft WebGrid Documentation
setParent Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridRowCollection Class : setParent Method

parent

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub setParent( _
   ByVal parent As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebGridRowCollection
Dim parent As System.Object

instance.setParent(parent)
C#
public virtual void setParent(
   System.object parent
)
Delphi
public procedure setParent(
    parent: System.TObject
); virtual;
JScript
public function setParent(
   parent : System.Object
);
Managed Extensions for C++
public: virtual void setParent(
   System.Object* parent
)
C++/CLI
public:
virtual void setParent(
   System.Object^ parent
)

Parameters

parent

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridRowCollection Class
WebGridRowCollection Members


Capacity Property

[image]
Intersoft WebGrid Documentation
Capacity Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridRowCollection Class : Capacity Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Runtime.InteropServices.ComVisibleAttribute(False)>
Public Property Capacity As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebGridRowCollection
Dim value As System.Integer

instance.Capacity = value

value = instance.Capacity
C#
[System.Runtime.InteropServices.ComVisibleAttribute(false)]
public System.int Capacity {get; set;}
Delphi
public read-write property Capacity: System.Integer;
JScript
System.Runtime.InteropServices.ComVisibleAttribute()
public function get,set Capacity : System.int
Managed Extensions for C++
[System.Runtime.InteropServices.ComVisibleAttribute(false)]
public: __property System.int get_Capacity();
public: __property void set_Capacity(
   System.int value
);
C++/CLI
[System.Runtime.InteropServices.ComVisibleAttribute(false)]
public:
property System.int Capacity {
   System.int get();
   void set (    System.int value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridRowCollection Class
WebGridRowCollection Members


Count Property

[image]
Intersoft WebGrid Documentation
Count Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridRowCollection Class : Count Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Count As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebGridRowCollection
Dim value As System.Integer

value = instance.Count
C#
public System.int Count {get;}
Delphi
public read-only property Count: System.Integer;
JScript
public function get Count : System.int
Managed Extensions for C++
public: __property System.int get_Count();
C++/CLI
public:
property System.int Count {
   System.int get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridRowCollection Class
WebGridRowCollection Members


WebGridRowCollection Class Properties

[image]
Intersoft WebGrid Documentation
WebGridRowCollection Class Properties
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : WebGridRowCollection Class

Glossary Item Box

For a list of all members of this type, see WebGridRowCollection members.

Public Properties

 | Name | Description
Public Property | Capacity | (Inherited from System.Collections.CollectionBase)
Public Property | Count | (Inherited from System.Collections.CollectionBase)
Public Property | IsReadOnly | Overridden.
Public Property | Item |
Public Property | Parent | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Property | Table |
Top

See Also

Reference

WebGridRowCollection Class
ISNet.WebUI.WebGrid Namespace


WebGridRowCollection Constructor

[image]
Intersoft WebGrid Documentation
WebGridRowCollection Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridRowCollection Class : WebGridRowCollection Constructor

Glossary Item Box

Overload List

Overload | Description
WebGridRowCollection Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridRowCollection Class
WebGridRowCollection Members


IsReadOnly Property

[image]
Intersoft WebGrid Documentation
IsReadOnly Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridRowCollection Class : IsReadOnly Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property IsReadOnly As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebGridRowCollection
Dim value As System.Boolean

value = instance.IsReadOnly
C#
public override System.bool IsReadOnly {get;}
Delphi
public read-only property IsReadOnly: System.Boolean; override;
JScript
public override function get IsReadOnly : System.boolean
Managed Extensions for C++
public: __property System.bool get_IsReadOnly() override;
C++/CLI
public:
property System.bool IsReadOnly {
   System.bool get() override;
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridRowCollection Class
WebGridRowCollection Members


Item Property

[image]
Intersoft WebGrid Documentation
Item Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridRowCollection Class : Item Property

index

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Default Property Item( _
   ByVal index As System.Integer _
) As WebGridRow
Visual Basic (Usage) Copy Code
Dim instance As WebGridRowCollection
Dim index As System.Integer
Dim value As WebGridRow

value = instance.Item(index)
C#
public WebGridRow this[
   System.int index
]; {get;}
Delphi
public  this: : WebGridRow;[
    index: System.Integer
]; read-only
JScript
public  this[
   index : System.int
] get : WebGridRow
Managed Extensions for C++
public: __property WebGridRow* get_Item   System.int index
;
C++/CLI
public:
property WebGridRow^ default [int] {
   WebGridRow^ get(System.int index);
}

Parameters

index

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridRowCollection Class
WebGridRowCollection Members


Parent Property

[image]
Intersoft WebGrid Documentation
Parent Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridRowCollection Class : Parent Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Parent As System.Object
Visual Basic (Usage) Copy Code
Dim instance As WebGridRowCollection
Dim value As System.Object

value = instance.Parent
C#
public System.object Parent {get;}
Delphi
public read-only property Parent: System.TObject;
JScript
public function get Parent : System.Object
Managed Extensions for C++
public: __property System.Object* get_Parent();
C++/CLI
public:
property System.Object^ Parent {
   System.Object^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridRowCollection Class
WebGridRowCollection Members


Table Property

[image]
Intersoft WebGrid Documentation
Table Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridRowCollection Class : Table Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Table As WebGridTable
Visual Basic (Usage) Copy Code
Dim instance As WebGridRowCollection
Dim value As WebGridTable

value = instance.Table
C#
public WebGridTable Table {get;}
Delphi
public read-only property Table: WebGridTable;
JScript
public function get Table : WebGridTable
Managed Extensions for C++
public: __property WebGridTable* get_Table();
C++/CLI
public:
property WebGridTable^ Table {
   WebGridTable^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridRowCollection Class
WebGridRowCollection Members


WebGridRowLayout Class

[image]
Intersoft WebGrid Documentation
WebGridRowLayout Class
Members See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : WebGridRowLayout Class

Glossary Item Box

Object Model

WebGridRowLayout Class

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute()>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.SerializableAttribute()>
Public Class WebGridRowLayout
   Inherits ISNet.WebUI.NamedObjectBase
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject
Visual Basic (Usage) Copy Code
Dim instance As WebGridRowLayout
C#
[System.ComponentModel.DescriptionAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public class WebGridRowLayout : ISNet.WebUI.NamedObjectBase, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject
Delphi
public class WebGridRowLayout = class(ISNet.WebUI.NamedObjectBase, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject)
JScript
System.ComponentModel.DescriptionAttribute()
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.SerializableAttribute()
public class WebGridRowLayout extends ISNet.WebUI.NamedObjectBase implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public __gc class WebGridRowLayout : public ISNet.WebUI.NamedObjectBase, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject
C++/CLI
[System.ComponentModel.DescriptionAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public ref class WebGridRowLayout : public ISNet.WebUI.NamedObjectBase, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.NamedObjectBase
ISNet.WebUI.WebGrid.WebGridRowLayout

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridRowLayout Members
ISNet.WebUI.WebGrid Namespace


WebGridRowLayout Class Members

[image]
Intersoft WebGrid Documentation
WebGridRowLayout Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebGrid Namespace : WebGridRowLayout Class

Glossary Item Box

The following tables list the members exposed by WebGridRowLayout.

Public Constructors

 | Name | Description
Public Constructor | WebGridRowLayout Constructor |
Top

Public Properties

 | Name | Description
Public Property | Col |
Public Property | ColSpan |
Public Property | ColumnMember |
Public Property | Height |
Public Property | Row |
Public Property | RowSpan |
Public Property | Width |
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | OnColSpanBeforeChanged |
Public Method | OnColSpanChanged |
Public Method | OnColumnMemberChanged |
Public Method | OnHeightChanged |
Public Method | OnPropertyChanged |
Public Method | OnRowSpanBeforeChanged |
Public Method | OnRowSpanChanged |
Public Method | OnWidthChanged |
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString |
Top

See Also

Reference

WebGridRowLayout Class
ISNet.WebUI.WebGrid Namespace


WebGridRowLayout Constructor

[image]
Intersoft WebGrid Documentation
WebGridRowLayout Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridRowLayout Class : WebGridRowLayout Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebGridRowLayout()
C#
public WebGridRowLayout()
Delphi
public WebGridRowLayout();
JScript
public function WebGridRowLayout();
Managed Extensions for C++
public: WebGridRowLayout();
C++/CLI
public:
WebGridRowLayout();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridRowLayout Class
WebGridRowLayout Members


Clone Method

[image]
Intersoft WebGrid Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridRowLayout Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As System.Object
Visual Basic (Usage) Copy Code
Dim instance As WebGridRowLayout
Dim value As System.Object

value = instance.Clone()
C#
public virtual System.object Clone()
Delphi
public function Clone(): System.TObject; virtual;
JScript
public function Clone() : System.Object;
Managed Extensions for C++
public: virtual System.Object* Clone();
C++/CLI
public:
virtual System.Object^ Clone();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridRowLayout Class
WebGridRowLayout Members


CopyFrom Method

[image]
Intersoft WebGrid Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridRowLayout Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridRowLayout Class
WebGridRowLayout Members


CopyFrom(Object) Method

[image]
Intersoft WebGrid Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridRowLayout Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebGridRowLayout
Dim objSource As System.Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   System.object objSource
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridRowLayout Class
WebGridRowLayout Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebGrid Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridRowLayout Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object, _
   ByVal cloneSourceValue As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebGridRowLayout
Dim objSource As System.Object
Dim cloneSourceValue As System.Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   System.object objSource,
   System.bool cloneSourceValue
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject;
    cloneSourceValue: System.Boolean
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object,
   cloneSourceValue : System.boolean
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource,
   System.bool cloneSourceValue
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource,
   System.bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridRowLayout Class
WebGridRowLayout Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebGrid Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridRowLayout Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebGridRowLayout
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure DeSerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function DeSerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void DeSerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void DeSerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridRowLayout Class
WebGridRowLayout Members


GetHashCode Method

[image]
Intersoft WebGrid Documentation
GetHashCode Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridRowLayout Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebGridRowLayout
Dim value As System.Integer

value = instance.GetHashCode()
C#
public virtual System.int GetHashCode()
Delphi
public function GetHashCode(): System.Integer; virtual;
JScript
public function GetHashCode() : System.int;
Managed Extensions for C++
public: virtual System.int GetHashCode();
C++/CLI
public:
virtual System.int GetHashCode();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridRowLayout Class
WebGridRowLayout Members


WebGridRowLayout Class Methods

[image]
Intersoft WebGrid Documentation
WebGridRowLayout Class Methods
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : WebGridRowLayout Class

Glossary Item Box

For a list of all members of this type, see WebGridRowLayout members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | OnColSpanBeforeChanged |
Public Method | OnColSpanChanged |
Public Method | OnColumnMemberChanged |
Public Method | OnHeightChanged |
Public Method | OnPropertyChanged |
Public Method | OnRowSpanBeforeChanged |
Public Method | OnRowSpanChanged |
Public Method | OnWidthChanged |
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString |
Top

See Also

Reference

WebGridRowLayout Class
ISNet.WebUI.WebGrid Namespace


GetObjectData Method

[image]
Intersoft WebGrid Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridRowLayout Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebGridRowLayout
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure GetObjectData(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
); override;
JScript
public override function GetObjectData(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void GetObjectData(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
) override
C++/CLI
public:
void GetObjectData(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
) override

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridRowLayout Class
WebGridRowLayout Members


IsEmpty Method

[image]
Intersoft WebGrid Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridRowLayout Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebGridRowLayout
Dim value As System.Boolean

value = instance.IsEmpty()
C#
public virtual System.bool IsEmpty()
Delphi
public function IsEmpty(): System.Boolean; virtual;
JScript
public function IsEmpty() : System.boolean;
Managed Extensions for C++
public: virtual System.bool IsEmpty();
C++/CLI
public:
virtual System.bool IsEmpty();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridRowLayout Class
WebGridRowLayout Members


OnColSpanBeforeChanged Method

[image]
Intersoft WebGrid Documentation
OnColSpanBeforeChanged Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridRowLayout Class : OnColSpanBeforeChanged Method

e

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub OnColSpanBeforeChanged( _
   ByVal e As SpanEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As WebGridRowLayout
Dim e As SpanEventArgs

instance.OnColSpanBeforeChanged(e)
C#
public void OnColSpanBeforeChanged(
   SpanEventArgs e
)
Delphi
public procedure OnColSpanBeforeChanged(
    e: SpanEventArgs
);
JScript
public function OnColSpanBeforeChanged(
   e : SpanEventArgs
);
Managed Extensions for C++
public: void OnColSpanBeforeChanged(
   SpanEventArgs* e
)
C++/CLI
public:
void OnColSpanBeforeChanged(
   SpanEventArgs^ e
)

Parameters

e

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridRowLayout Class
WebGridRowLayout Members


OnColSpanChanged Method

[image]
Intersoft WebGrid Documentation
OnColSpanChanged Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridRowLayout Class : OnColSpanChanged Method

e

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub OnColSpanChanged( _
   ByVal e As SpanEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As WebGridRowLayout
Dim e As SpanEventArgs

instance.OnColSpanChanged(e)
C#
public void OnColSpanChanged(
   SpanEventArgs e
)
Delphi
public procedure OnColSpanChanged(
    e: SpanEventArgs
);
JScript
public function OnColSpanChanged(
   e : SpanEventArgs
);
Managed Extensions for C++
public: void OnColSpanChanged(
   SpanEventArgs* e
)
C++/CLI
public:
void OnColSpanChanged(
   SpanEventArgs^ e
)

Parameters

e

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridRowLayout Class
WebGridRowLayout Members


OnColumnMemberChanged Method

[image]
Intersoft WebGrid Documentation
OnColumnMemberChanged Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridRowLayout Class : OnColumnMemberChanged Method

e

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub OnColumnMemberChanged( _
   ByVal e As System.EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As WebGridRowLayout
Dim e As System.EventArgs

instance.OnColumnMemberChanged(e)
C#
public void OnColumnMemberChanged(
   System.EventArgs e
)
Delphi
public procedure OnColumnMemberChanged(
    e: System.EventArgs
);
JScript
public function OnColumnMemberChanged(
   e : System.EventArgs
);
Managed Extensions for C++
public: void OnColumnMemberChanged(
   System.EventArgs* e
)
C++/CLI
public:
void OnColumnMemberChanged(
   System.EventArgs^ e
)

Parameters

e

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridRowLayout Class
WebGridRowLayout Members


OnHeightChanged Method

[image]
Intersoft WebGrid Documentation
OnHeightChanged Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridRowLayout Class : OnHeightChanged Method

e

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub OnHeightChanged( _
   ByVal e As System.EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As WebGridRowLayout
Dim e As System.EventArgs

instance.OnHeightChanged(e)
C#
public void OnHeightChanged(
   System.EventArgs e
)
Delphi
public procedure OnHeightChanged(
    e: System.EventArgs
);
JScript
public function OnHeightChanged(
   e : System.EventArgs
);
Managed Extensions for C++
public: void OnHeightChanged(
   System.EventArgs* e
)
C++/CLI
public:
void OnHeightChanged(
   System.EventArgs^ e
)

Parameters

e

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridRowLayout Class
WebGridRowLayout Members


OnPropertyChanged Method

[image]
Intersoft WebGrid Documentation
OnPropertyChanged Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridRowLayout Class : OnPropertyChanged Method

e

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub OnPropertyChanged( _
   ByVal e As System.EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As WebGridRowLayout
Dim e As System.EventArgs

instance.OnPropertyChanged(e)
C#
public void OnPropertyChanged(
   System.EventArgs e
)
Delphi
public procedure OnPropertyChanged(
    e: System.EventArgs
);
JScript
public function OnPropertyChanged(
   e : System.EventArgs
);
Managed Extensions for C++
public: void OnPropertyChanged(
   System.EventArgs* e
)
C++/CLI
public:
void OnPropertyChanged(
   System.EventArgs^ e
)

Parameters

e

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridRowLayout Class
WebGridRowLayout Members


OnRowSpanBeforeChanged Method

[image]
Intersoft WebGrid Documentation
OnRowSpanBeforeChanged Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridRowLayout Class : OnRowSpanBeforeChanged Method

e

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub OnRowSpanBeforeChanged( _
   ByVal e As SpanEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As WebGridRowLayout
Dim e As SpanEventArgs

instance.OnRowSpanBeforeChanged(e)
C#
public void OnRowSpanBeforeChanged(
   SpanEventArgs e
)
Delphi
public procedure OnRowSpanBeforeChanged(
    e: SpanEventArgs
);
JScript
public function OnRowSpanBeforeChanged(
   e : SpanEventArgs
);
Managed Extensions for C++
public: void OnRowSpanBeforeChanged(
   SpanEventArgs* e
)
C++/CLI
public:
void OnRowSpanBeforeChanged(
   SpanEventArgs^ e
)

Parameters

e

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridRowLayout Class
WebGridRowLayout Members


OnRowSpanChanged Method

[image]
Intersoft WebGrid Documentation
OnRowSpanChanged Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridRowLayout Class : OnRowSpanChanged Method

e

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub OnRowSpanChanged( _
   ByVal e As SpanEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As WebGridRowLayout
Dim e As SpanEventArgs

instance.OnRowSpanChanged(e)
C#
public void OnRowSpanChanged(
   SpanEventArgs e
)
Delphi
public procedure OnRowSpanChanged(
    e: SpanEventArgs
);
JScript
public function OnRowSpanChanged(
   e : SpanEventArgs
);
Managed Extensions for C++
public: void OnRowSpanChanged(
   SpanEventArgs* e
)
C++/CLI
public:
void OnRowSpanChanged(
   SpanEventArgs^ e
)

Parameters

e

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridRowLayout Class
WebGridRowLayout Members


OnWidthChanged Method

[image]
Intersoft WebGrid Documentation
OnWidthChanged Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridRowLayout Class : OnWidthChanged Method

e

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub OnWidthChanged( _
   ByVal e As System.EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As WebGridRowLayout
Dim e As System.EventArgs

instance.OnWidthChanged(e)
C#
public void OnWidthChanged(
   System.EventArgs e
)
Delphi
public procedure OnWidthChanged(
    e: System.EventArgs
);
JScript
public function OnWidthChanged(
   e : System.EventArgs
);
Managed Extensions for C++
public: void OnWidthChanged(
   System.EventArgs* e
)
C++/CLI
public:
void OnWidthChanged(
   System.EventArgs^ e
)

Parameters

e

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridRowLayout Class
WebGridRowLayout Members


Reset Method

[image]
Intersoft WebGrid Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridRowLayout Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As WebGridRowLayout

instance.Reset()
C#
public virtual void Reset()
Delphi
public procedure Reset(); virtual;
JScript
public function Reset();
Managed Extensions for C++
public: virtual void Reset();
C++/CLI
public:
virtual void Reset();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridRowLayout Class
WebGridRowLayout Members


SerializeObjectData Method

[image]
Intersoft WebGrid Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridRowLayout Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebGridRowLayout
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure SerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function SerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void SerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void SerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridRowLayout Class
WebGridRowLayout Members


ToString Method

[image]
Intersoft WebGrid Documentation
ToString Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridRowLayout Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString() As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebGridRowLayout
Dim value As System.String

value = instance.ToString()
C#
public override System.string ToString()
Delphi
public function ToString(): System.String; override;
JScript
public override function ToString() : System.String;
Managed Extensions for C++
public: System.string* ToString(); override
C++/CLI
public:
System.String^ ToString(); override

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridRowLayout Class
WebGridRowLayout Members


WebGridRowLayout Class Properties

[image]
Intersoft WebGrid Documentation
WebGridRowLayout Class Properties
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : WebGridRowLayout Class

Glossary Item Box

For a list of all members of this type, see WebGridRowLayout members.

Public Properties

 | Name | Description
Public Property | Col |
Public Property | ColSpan |
Public Property | ColumnMember |
Public Property | Height |
Public Property | Row |
Public Property | RowSpan |
Public Property | Width |
Top

See Also

Reference

WebGridRowLayout Class
ISNet.WebUI.WebGrid Namespace


WebGridRowLayout Constructor

[image]
Intersoft WebGrid Documentation
WebGridRowLayout Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridRowLayout Class : WebGridRowLayout Constructor

Glossary Item Box

Overload List

Overload | Description
WebGridRowLayout Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridRowLayout Class
WebGridRowLayout Members


Col Property

[image]
Intersoft WebGrid Documentation
Col Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridRowLayout Class : Col Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property Col As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebGridRowLayout
Dim value As System.Integer

instance.Col = value

value = instance.Col
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public System.int Col {get; set;}
Delphi
public read-write property Col: System.Integer;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute()
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get,set Col : System.int
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.int get_Col();
public: __property void set_Col(
   System.int value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.int Col {
   System.int get();
   void set (    System.int value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridRowLayout Class
WebGridRowLayout Members


ColSpan Property

[image]
Intersoft WebGrid Documentation
ColSpan Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridRowLayout Class : ColSpan Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property ColSpan As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebGridRowLayout
Dim value As System.Integer

instance.ColSpan = value

value = instance.ColSpan
C#
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public System.int ColSpan {get; set;}
Delphi
public read-write property ColSpan: System.Integer;
JScript
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute()
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get,set ColSpan : System.int
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.int get_ColSpan();
public: __property void set_ColSpan(
   System.int value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.int ColSpan {
   System.int get();
   void set (    System.int value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridRowLayout Class
WebGridRowLayout Members


ColumnMember Property

[image]
Intersoft WebGrid Documentation
ColumnMember Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridRowLayout Class : ColumnMember Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property ColumnMember As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebGridRowLayout
Dim value As System.String

instance.ColumnMember = value

value = instance.ColumnMember
C#
[System.ComponentModel.DescriptionAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public System.string ColumnMember {get; set;}
Delphi
public read-write property ColumnMember: System.String;
JScript
System.ComponentModel.DescriptionAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get,set ColumnMember : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.string* get_ColumnMember();
public: __property void set_ColumnMember(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.String^ ColumnMember {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridRowLayout Class
WebGridRowLayout Members


Height Property

[image]
Intersoft WebGrid Documentation
Height Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridRowLayout Class : Height Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property Height As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebGridRowLayout
Dim value As System.Integer

instance.Height = value

value = instance.Height
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public System.int Height {get; set;}
Delphi
public read-write property Height: System.Integer;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute()
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get,set Height : System.int
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.int get_Height();
public: __property void set_Height(
   System.int value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.int Height {
   System.int get();
   void set (    System.int value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridRowLayout Class
WebGridRowLayout Members


Row Property

[image]
Intersoft WebGrid Documentation
Row Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridRowLayout Class : Row Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property Row As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebGridRowLayout
Dim value As System.Integer

instance.Row = value

value = instance.Row
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.int Row {get; set;}
Delphi
public read-write property Row: System.Integer;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set Row : System.int
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.int get_Row();
public: __property void set_Row(
   System.int value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.int Row {
   System.int get();
   void set (    System.int value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridRowLayout Class
WebGridRowLayout Members


RowSpan Property

[image]
Intersoft WebGrid Documentation
RowSpan Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridRowLayout Class : RowSpan Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property RowSpan As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebGridRowLayout
Dim value As System.Integer

instance.RowSpan = value

value = instance.RowSpan
C#
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public System.int RowSpan {get; set;}
Delphi
public read-write property RowSpan: System.Integer;
JScript
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute()
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get,set RowSpan : System.int
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.int get_RowSpan();
public: __property void set_RowSpan(
   System.int value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.int RowSpan {
   System.int get();
   void set (    System.int value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridRowLayout Class
WebGridRowLayout Members


Width Property

[image]
Intersoft WebGrid Documentation
Width Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridRowLayout Class : Width Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property Width As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebGridRowLayout
Dim value As System.Integer

instance.Width = value

value = instance.Width
C#
[System.ComponentModel.DescriptionAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public System.int Width {get; set;}
Delphi
public read-write property Width: System.Integer;
JScript
System.ComponentModel.DescriptionAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get,set Width : System.int
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.int get_Width();
public: __property void set_Width(
   System.int value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.int Width {
   System.int get();
   void set (    System.int value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridRowLayout Class
WebGridRowLayout Members


WebGridRowLayoutCollection Class

[image]
Intersoft WebGrid Documentation
WebGridRowLayoutCollection Class
Members See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : WebGridRowLayoutCollection Class

Glossary Item Box

Object Model

WebGridRowLayoutCollection Class

Syntax

Visual Basic (Declaration)
<System.Reflection.DefaultMemberAttribute("Item")>
<System.SerializableAttribute()>
Public Class WebGridRowLayoutCollection
   Inherits ISNet.WebUI.ISCollectionBase
Visual Basic (Usage) Copy Code
Dim instance As WebGridRowLayoutCollection
C#
[System.Reflection.DefaultMemberAttribute("Item")]
[System.SerializableAttribute()]
public class WebGridRowLayoutCollection : ISNet.WebUI.ISCollectionBase
Delphi
public class WebGridRowLayoutCollection = class(ISNet.WebUI.ISCollectionBase)
JScript
System.Reflection.DefaultMemberAttribute("Item")
System.SerializableAttribute()
public class WebGridRowLayoutCollection extends ISNet.WebUI.ISCollectionBase
Managed Extensions for C++
[System.Reflection.DefaultMemberAttribute("Item")]
[System.SerializableAttribute()]
public __gc class WebGridRowLayoutCollection : public ISNet.WebUI.ISCollectionBase
C++/CLI
[System.Reflection.DefaultMemberAttribute("Item")]
[System.SerializableAttribute()]
public ref class WebGridRowLayoutCollection : public ISNet.WebUI.ISCollectionBase

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
ISNet.WebUI.ISCollectionBase
ISNet.WebUI.WebGrid.WebGridRowLayoutCollection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridRowLayoutCollection Members
ISNet.WebUI.WebGrid Namespace


WebGridRowLayoutCollection Class Members

[image]
Intersoft WebGrid Documentation
WebGridRowLayoutCollection Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebGrid Namespace : WebGridRowLayoutCollection Class

Glossary Item Box

The following tables list the members exposed by WebGridRowLayoutCollection.

Public Constructors

 | Name | Description
Public Constructor | WebGridRowLayoutCollection Constructor |
Top

Public Properties

 | Name | Description
Public Property | Capacity | (Inherited from System.Collections.CollectionBase)
Public Property | Count | (Inherited from System.Collections.CollectionBase)
Public Property | IsReadOnly | Overridden.
Public Property | Item |
Public Property | Parent | (Inherited from ISNet.WebUI.ISCollectionBase)
Top

Public Methods

 | Name | Description
Public Method | Add | Overloaded.
Public Method | Clear |
Public Method | Contains | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | CopyFrom |
Public Method | CopyTo | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | Exists | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | GetEnumerator |
Public Method | GetItem | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | GetNamedItem |
Public Method | IndexOf | Overloaded. (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | Insert |
Public Method | IntInsert | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | Remove |
Public Method | setParent | (Inherited from ISNet.WebUI.ISCollectionBase)
Top

See Also

Reference

WebGridRowLayoutCollection Class
ISNet.WebUI.WebGrid Namespace


WebGridRowLayoutCollection Constructor

[image]
Intersoft WebGrid Documentation
WebGridRowLayoutCollection Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridRowLayoutCollection Class : WebGridRowLayoutCollection Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebGridRowLayoutCollection()
C#
public WebGridRowLayoutCollection()
Delphi
public WebGridRowLayoutCollection();
JScript
public function WebGridRowLayoutCollection();
Managed Extensions for C++
public: WebGridRowLayoutCollection();
C++/CLI
public:
WebGridRowLayoutCollection();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridRowLayoutCollection Class
WebGridRowLayoutCollection Members


WebGridRowLayoutCollection Class Methods

[image]
Intersoft WebGrid Documentation
WebGridRowLayoutCollection Class Methods
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : WebGridRowLayoutCollection Class

Glossary Item Box

For a list of all members of this type, see WebGridRowLayoutCollection members.

Public Methods

 | Name | Description
Public Method | Add | Overloaded.
Public Method | Clear |
Public Method | Contains | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | CopyFrom |
Public Method | CopyTo | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | Exists | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | GetEnumerator |
Public Method | GetItem | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | GetNamedItem |
Public Method | IndexOf | Overloaded. (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | Insert |
Public Method | IntInsert | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | Remove |
Public Method | setParent | (Inherited from ISNet.WebUI.ISCollectionBase)
Top

See Also

Reference

WebGridRowLayoutCollection Class
ISNet.WebUI.WebGrid Namespace


Add Method

[image]
Intersoft WebGrid Documentation
Add Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridRowLayoutCollection Class : Add Method

Glossary Item Box

Overload List

Overload | Description
Add(WebGridRowLayout) |
Add(String) |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridRowLayoutCollection Class
WebGridRowLayoutCollection Members


Add(WebGridRowLayout) Method

[image]
Intersoft WebGrid Documentation
Add(WebGridRowLayout) Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridRowLayoutCollection Class > Add Method : Add(WebGridRowLayout) Method

webGridRowLayout

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function Add( _
   ByVal webGridRowLayout As WebGridRowLayout _
) As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebGridRowLayoutCollection
Dim webGridRowLayout As WebGridRowLayout
Dim value As System.Integer

value = instance.Add(webGridRowLayout)
C#
public virtual System.int Add(
   WebGridRowLayout webGridRowLayout
)
Delphi
public function Add(
    webGridRowLayout: WebGridRowLayout
): System.Integer; virtual;
JScript
public function Add(
   webGridRowLayout : WebGridRowLayout
) : System.int;
Managed Extensions for C++
public: virtual System.int Add(
   WebGridRowLayout* webGridRowLayout
)
C++/CLI
public:
virtual System.int Add(
   WebGridRowLayout^ webGridRowLayout
)

Parameters

webGridRowLayout

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridRowLayoutCollection Class
WebGridRowLayoutCollection Members
Overload List


Add(String) Method

[image]
Intersoft WebGrid Documentation
Add(String) Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridRowLayoutCollection Class > Add Method : Add(String) Method

name

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function Add( _
   ByVal name As System.String _
) As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebGridRowLayoutCollection
Dim name As System.String
Dim value As System.Integer

value = instance.Add(name)
C#
public System.int Add(
   System.string name
)
Delphi
public function Add(
    name: System.String
): System.Integer;
JScript
public function Add(
   name : System.String
) : System.int;
Managed Extensions for C++
public: System.int Add(
   System.string* name
)
C++/CLI
public:
System.int Add(
   System.String^ name
)

Parameters

name

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridRowLayoutCollection Class
WebGridRowLayoutCollection Members
Overload List


Clear Method

[image]
Intersoft WebGrid Documentation
Clear Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridRowLayoutCollection Class : Clear Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Shadows Sub Clear()
Visual Basic (Usage) Copy Code
Dim instance As WebGridRowLayoutCollection

instance.Clear()
C#
public new void Clear()
Delphi
public procedure Clear();
JScript
public hide function Clear();
Managed Extensions for C++
public: new void Clear();
C++/CLI
public:
new void Clear();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridRowLayoutCollection Class
WebGridRowLayoutCollection Members


Contains Method

[image]
Intersoft WebGrid Documentation
Contains Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridRowLayoutCollection Class : Contains Method

value

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function Contains( _
   ByVal value As ISNet.WebUI.INamedObject _
) As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebGridRowLayoutCollection
Dim value As ISNet.WebUI.INamedObject
Dim value As System.Boolean

value = instance.Contains(value)
C#
public System.bool Contains(
   ISNet.WebUI.INamedObject value
)
Delphi
public function Contains(
    value: ISNet.WebUI.INamedObject
): System.Boolean;
JScript
public function Contains(
   value : ISNet.WebUI.INamedObject
) : System.boolean;
Managed Extensions for C++
public: System.bool Contains(
   ISNet.WebUI.INamedObject* value
)
C++/CLI
public:
System.bool Contains(
   ISNet.WebUI.INamedObject^ value
)

Parameters

value

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridRowLayoutCollection Class
WebGridRowLayoutCollection Members


CopyFrom Method

[image]
Intersoft WebGrid Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridRowLayoutCollection Class : CopyFrom Method

passIn

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function CopyFrom( _
   ByVal passIn As WebGridRowLayoutCollection _
) As WebGridRowLayoutCollection
Visual Basic (Usage) Copy Code
Dim instance As WebGridRowLayoutCollection
Dim passIn As WebGridRowLayoutCollection
Dim value As WebGridRowLayoutCollection

value = instance.CopyFrom(passIn)
C#
public WebGridRowLayoutCollection CopyFrom(
   WebGridRowLayoutCollection passIn
)
Delphi
public function CopyFrom(
    passIn: WebGridRowLayoutCollection
): WebGridRowLayoutCollection;
JScript
public function CopyFrom(
   passIn : WebGridRowLayoutCollection
) : WebGridRowLayoutCollection;
Managed Extensions for C++
public: WebGridRowLayoutCollection* CopyFrom(
   WebGridRowLayoutCollection* passIn
)
C++/CLI
public:
WebGridRowLayoutCollection^ CopyFrom(
   WebGridRowLayoutCollection^ passIn
)

Parameters

passIn

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridRowLayoutCollection Class
WebGridRowLayoutCollection Members


CopyTo Method

[image]
Intersoft WebGrid Documentation
CopyTo Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridRowLayoutCollection Class : CopyTo Method

array
index

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub CopyTo( _
   ByVal array() As ISNet.WebUI.INamedObject, _
   ByVal index As System.Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As WebGridRowLayoutCollection
Dim array() As ISNet.WebUI.INamedObject
Dim index As System.Integer

instance.CopyTo(array, index)
C#
public void CopyTo(
   ISNet.WebUI.INamedObject[] array,
   System.int index
)
Delphi
public procedure CopyTo(
    array: ISNet.WebUI.INamedObjectarray of;
    index: System.Integer
);
JScript
public function CopyTo(
   array : ISNet.WebUI.INamedObject[],
   index : System.int
);
Managed Extensions for C++
public: void CopyTo(
   ISNet.WebUI.INamedObject*[]* array,
   System.int index
)
C++/CLI
public:
void CopyTo(
   ISNet.WebUI.array<INamedObject^>^ array,
   System.int index
)

Parameters

array
index

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridRowLayoutCollection Class
WebGridRowLayoutCollection Members


Exists Method

[image]
Intersoft WebGrid Documentation
Exists Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridRowLayoutCollection Class : Exists Method

name

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function Exists( _
   ByVal name As System.String _
) As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebGridRowLayoutCollection
Dim name As System.String
Dim value As System.Boolean

value = instance.Exists(name)
C#
public System.bool Exists(
   System.string name
)
Delphi
public function Exists(
    name: System.String
): System.Boolean;
JScript
public function Exists(
   name : System.String
) : System.boolean;
Managed Extensions for C++
public: System.bool Exists(
   System.string* name
)
C++/CLI
public:
System.bool Exists(
   System.String^ name
)

Parameters

name

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridRowLayoutCollection Class
WebGridRowLayoutCollection Members


GetEnumerator Method

[image]
Intersoft WebGrid Documentation
GetEnumerator Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridRowLayoutCollection Class : GetEnumerator Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Shadows Function GetEnumerator() As System.Collections.IEnumerator
Visual Basic (Usage) Copy Code
Dim instance As WebGridRowLayoutCollection
Dim value As System.Collections.IEnumerator

value = instance.GetEnumerator()
C#
public new System.Collections.IEnumerator GetEnumerator()
Delphi
public function GetEnumerator(): System.Collections.IEnumerator;
JScript
public hide function GetEnumerator() : System.Collections.IEnumerator;
Managed Extensions for C++
public: new System.Collections.IEnumerator* GetEnumerator();
C++/CLI
public:
new System.Collections.IEnumerator^ GetEnumerator();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridRowLayoutCollection Class
WebGridRowLayoutCollection Members


GetItem Method

[image]
Intersoft WebGrid Documentation
GetItem Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridRowLayoutCollection Class : GetItem Method

Glossary Item Box

Overload List

Overload | Description
GetItem | (Inherited from ISNet.WebUI.ISCollectionBase)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridRowLayoutCollection Class
WebGridRowLayoutCollection Members


GetItem(Int32) Method

[image]
Intersoft WebGrid Documentation
GetItem(Int32) Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridRowLayoutCollection Class : GetItem(Int32) Method

index

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetItem( _
   ByVal index As System.Integer _
) As ISNet.WebUI.INamedObject
Visual Basic (Usage) Copy Code
Dim instance As WebGridRowLayoutCollection
Dim index As System.Integer
Dim value As ISNet.WebUI.INamedObject

value = instance.GetItem(index)
C#
public virtual ISNet.WebUI.INamedObject GetItem(
   System.int index
)
Delphi
public function GetItem(
    index: System.Integer
): ISNet.WebUI.INamedObject; virtual;
JScript
public function GetItem(
   index : System.int
) : ISNet.WebUI.INamedObject;
Managed Extensions for C++
public: virtual ISNet.WebUI.INamedObject* GetItem(
   System.int index
)
C++/CLI
public:
virtual ISNet.WebUI.INamedObject^ GetItem(
   System.int index
)

Parameters

index

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridRowLayoutCollection Class
WebGridRowLayoutCollection Members


GetNamedItem Method

[image]
Intersoft WebGrid Documentation
GetNamedItem Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridRowLayoutCollection Class : GetNamedItem Method

name

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetNamedItem( _
   ByVal name As System.String _
) As WebGridRowLayout
Visual Basic (Usage) Copy Code
Dim instance As WebGridRowLayoutCollection
Dim name As System.String
Dim value As WebGridRowLayout

value = instance.GetNamedItem(name)
C#
public WebGridRowLayout GetNamedItem(
   System.string name
)
Delphi
public function GetNamedItem(
    name: System.String
): WebGridRowLayout;
JScript
public function GetNamedItem(
   name : System.String
) : WebGridRowLayout;
Managed Extensions for C++
public: WebGridRowLayout* GetNamedItem(
   System.string* name
)
C++/CLI
public:
WebGridRowLayout^ GetNamedItem(
   System.String^ name
)

Parameters

name

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridRowLayoutCollection Class
WebGridRowLayoutCollection Members


IndexOf Method

[image]
Intersoft WebGrid Documentation
IndexOf Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridRowLayoutCollection Class : IndexOf Method

Glossary Item Box

Overload List

Overload | Description
IndexOf(String) | (Inherited from ISNet.WebUI.ISCollectionBase)
IndexOf(INamedObject) | (Inherited from ISNet.WebUI.ISCollectionBase)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridRowLayoutCollection Class
WebGridRowLayoutCollection Members


IndexOf(String) Method

[image]
Intersoft WebGrid Documentation
IndexOf(String) Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridRowLayoutCollection Class > IndexOf Method : IndexOf(String) Method

name

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function IndexOf( _
   ByVal name As System.String _
) As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebGridRowLayoutCollection
Dim name As System.String
Dim value As System.Integer

value = instance.IndexOf(name)
C#
public virtual System.int IndexOf(
   System.string name
)
Delphi
public function IndexOf(
    name: System.String
): System.Integer; virtual;
JScript
public function IndexOf(
   name : System.String
) : System.int;
Managed Extensions for C++
public: virtual System.int IndexOf(
   System.string* name
)
C++/CLI
public:
virtual System.int IndexOf(
   System.String^ name
)

Parameters

name

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridRowLayoutCollection Class
WebGridRowLayoutCollection Members
Overload List


IndexOf(INamedObject) Method

[image]
Intersoft WebGrid Documentation
IndexOf(INamedObject) Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridRowLayoutCollection Class > IndexOf Method : IndexOf(INamedObject) Method

value

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function IndexOf( _
   ByVal value As ISNet.WebUI.INamedObject _
) As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebGridRowLayoutCollection
Dim value As ISNet.WebUI.INamedObject
Dim value As System.Integer

value = instance.IndexOf(value)
C#
public System.int IndexOf(
   ISNet.WebUI.INamedObject value
)
Delphi
public function IndexOf(
    value: ISNet.WebUI.INamedObject
): System.Integer;
JScript
public function IndexOf(
   value : ISNet.WebUI.INamedObject
) : System.int;
Managed Extensions for C++
public: System.int IndexOf(
   ISNet.WebUI.INamedObject* value
)
C++/CLI
public:
System.int IndexOf(
   ISNet.WebUI.INamedObject^ value
)

Parameters

value

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridRowLayoutCollection Class
WebGridRowLayoutCollection Members
Overload List


Insert Method

[image]
Intersoft WebGrid Documentation
Insert Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridRowLayoutCollection Class : Insert Method

index
webGridRowLayout

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub Insert( _
   ByVal index As System.Integer, _
   ByVal webGridRowLayout As WebGridRowLayout _
)
Visual Basic (Usage) Copy Code
Dim instance As WebGridRowLayoutCollection
Dim index As System.Integer
Dim webGridRowLayout As WebGridRowLayout

instance.Insert(index, webGridRowLayout)
C#
public void Insert(
   System.int index,
   WebGridRowLayout webGridRowLayout
)
Delphi
public procedure Insert(
    index: System.Integer;
    webGridRowLayout: WebGridRowLayout
);
JScript
public function Insert(
   index : System.int,
   webGridRowLayout : WebGridRowLayout
);
Managed Extensions for C++
public: void Insert(
   System.int index,
   WebGridRowLayout* webGridRowLayout
)
C++/CLI
public:
void Insert(
   System.int index,
   WebGridRowLayout^ webGridRowLayout
)

Parameters

index
webGridRowLayout

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridRowLayoutCollection Class
WebGridRowLayoutCollection Members


IntInsert Method

[image]
Intersoft WebGrid Documentation
IntInsert Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridRowLayoutCollection Class : IntInsert Method

index
value

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub IntInsert( _
   ByVal index As System.Integer, _
   ByVal value As ISNet.WebUI.INamedObject _
)
Visual Basic (Usage) Copy Code
Dim instance As WebGridRowLayoutCollection
Dim index As System.Integer
Dim value As ISNet.WebUI.INamedObject

instance.IntInsert(index, value)
C#
public void IntInsert(
   System.int index,
   ISNet.WebUI.INamedObject value
)
Delphi
public procedure IntInsert(
    index: System.Integer;
    value: ISNet.WebUI.INamedObject
);
JScript
public function IntInsert(
   index : System.int,
   value : ISNet.WebUI.INamedObject
);
Managed Extensions for C++
public: void IntInsert(
   System.int index,
   ISNet.WebUI.INamedObject* value
)
C++/CLI
public:
void IntInsert(
   System.int index,
   ISNet.WebUI.INamedObject^ value
)

Parameters

index
value

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridRowLayoutCollection Class
WebGridRowLayoutCollection Members


Remove Method

[image]
Intersoft WebGrid Documentation
Remove Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridRowLayoutCollection Class : Remove Method

webGridRowLayout

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub Remove( _
   ByVal webGridRowLayout As WebGridRowLayout _
)
Visual Basic (Usage) Copy Code
Dim instance As WebGridRowLayoutCollection
Dim webGridRowLayout As WebGridRowLayout

instance.Remove(webGridRowLayout)
C#
public void Remove(
   WebGridRowLayout webGridRowLayout
)
Delphi
public procedure Remove(
    webGridRowLayout: WebGridRowLayout
);
JScript
public function Remove(
   webGridRowLayout : WebGridRowLayout
);
Managed Extensions for C++
public: void Remove(
   WebGridRowLayout* webGridRowLayout
)
C++/CLI
public:
void Remove(
   WebGridRowLayout^ webGridRowLayout
)

Parameters

webGridRowLayout

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridRowLayoutCollection Class
WebGridRowLayoutCollection Members


setParent Method

[image]
Intersoft WebGrid Documentation
setParent Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridRowLayoutCollection Class : setParent Method

parent

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub setParent( _
   ByVal parent As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebGridRowLayoutCollection
Dim parent As System.Object

instance.setParent(parent)
C#
public virtual void setParent(
   System.object parent
)
Delphi
public procedure setParent(
    parent: System.TObject
); virtual;
JScript
public function setParent(
   parent : System.Object
);
Managed Extensions for C++
public: virtual void setParent(
   System.Object* parent
)
C++/CLI
public:
virtual void setParent(
   System.Object^ parent
)

Parameters

parent

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridRowLayoutCollection Class
WebGridRowLayoutCollection Members


Capacity Property

[image]
Intersoft WebGrid Documentation
Capacity Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridRowLayoutCollection Class : Capacity Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Runtime.InteropServices.ComVisibleAttribute(False)>
Public Property Capacity As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebGridRowLayoutCollection
Dim value As System.Integer

instance.Capacity = value

value = instance.Capacity
C#
[System.Runtime.InteropServices.ComVisibleAttribute(false)]
public System.int Capacity {get; set;}
Delphi
public read-write property Capacity: System.Integer;
JScript
System.Runtime.InteropServices.ComVisibleAttribute()
public function get,set Capacity : System.int
Managed Extensions for C++
[System.Runtime.InteropServices.ComVisibleAttribute(false)]
public: __property System.int get_Capacity();
public: __property void set_Capacity(
   System.int value
);
C++/CLI
[System.Runtime.InteropServices.ComVisibleAttribute(false)]
public:
property System.int Capacity {
   System.int get();
   void set (    System.int value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridRowLayoutCollection Class
WebGridRowLayoutCollection Members


Count Property

[image]
Intersoft WebGrid Documentation
Count Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridRowLayoutCollection Class : Count Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Count As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebGridRowLayoutCollection
Dim value As System.Integer

value = instance.Count
C#
public System.int Count {get;}
Delphi
public read-only property Count: System.Integer;
JScript
public function get Count : System.int
Managed Extensions for C++
public: __property System.int get_Count();
C++/CLI
public:
property System.int Count {
   System.int get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridRowLayoutCollection Class
WebGridRowLayoutCollection Members


WebGridRowLayoutCollection Class Properties

[image]
Intersoft WebGrid Documentation
WebGridRowLayoutCollection Class Properties
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : WebGridRowLayoutCollection Class

Glossary Item Box

For a list of all members of this type, see WebGridRowLayoutCollection members.

Public Properties

 | Name | Description
Public Property | Capacity | (Inherited from System.Collections.CollectionBase)
Public Property | Count | (Inherited from System.Collections.CollectionBase)
Public Property | IsReadOnly | Overridden.
Public Property | Item |
Public Property | Parent | (Inherited from ISNet.WebUI.ISCollectionBase)
Top

See Also

Reference

WebGridRowLayoutCollection Class
ISNet.WebUI.WebGrid Namespace


WebGridRowLayoutCollection Constructor

[image]
Intersoft WebGrid Documentation
WebGridRowLayoutCollection Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridRowLayoutCollection Class : WebGridRowLayoutCollection Constructor

Glossary Item Box

Overload List

Overload | Description
WebGridRowLayoutCollection Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridRowLayoutCollection Class
WebGridRowLayoutCollection Members


IsReadOnly Property

[image]
Intersoft WebGrid Documentation
IsReadOnly Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridRowLayoutCollection Class : IsReadOnly Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property IsReadOnly As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebGridRowLayoutCollection
Dim value As System.Boolean

value = instance.IsReadOnly
C#
public override System.bool IsReadOnly {get;}
Delphi
public read-only property IsReadOnly: System.Boolean; override;
JScript
public override function get IsReadOnly : System.boolean
Managed Extensions for C++
public: __property System.bool get_IsReadOnly() override;
C++/CLI
public:
property System.bool IsReadOnly {
   System.bool get() override;
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridRowLayoutCollection Class
WebGridRowLayoutCollection Members


Item Property

[image]
Intersoft WebGrid Documentation
Item Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridRowLayoutCollection Class : Item Property

index

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Default Property Item( _
   ByVal index As System.Integer _
) As WebGridRowLayout
Visual Basic (Usage) Copy Code
Dim instance As WebGridRowLayoutCollection
Dim index As System.Integer
Dim value As WebGridRowLayout

value = instance.Item(index)
C#
public WebGridRowLayout this[
   System.int index
]; {get;}
Delphi
public  this: : WebGridRowLayout;[
    index: System.Integer
]; read-only
JScript
public  this[
   index : System.int
] get : WebGridRowLayout
Managed Extensions for C++
public: __property WebGridRowLayout* get_Item   System.int index
;
C++/CLI
public:
property WebGridRowLayout^ default [int] {
   WebGridRowLayout^ get(System.int index);
}

Parameters

index

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridRowLayoutCollection Class
WebGridRowLayoutCollection Members


Parent Property

[image]
Intersoft WebGrid Documentation
Parent Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridRowLayoutCollection Class : Parent Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Parent As System.Object
Visual Basic (Usage) Copy Code
Dim instance As WebGridRowLayoutCollection
Dim value As System.Object

value = instance.Parent
C#
public System.object Parent {get;}
Delphi
public read-only property Parent: System.TObject;
JScript
public function get Parent : System.Object
Managed Extensions for C++
public: __property System.Object* get_Parent();
C++/CLI
public:
property System.Object^ Parent {
   System.Object^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridRowLayoutCollection Class
WebGridRowLayoutCollection Members


WebGridScrollBarStyle Class

[image]
Intersoft WebGrid Documentation
WebGridScrollBarStyle Class
Members See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : WebGridScrollBarStyle Class

Glossary Item Box

Object Model

WebGridScrollBarStyle Class

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute()>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.SerializableAttribute()>
Public Class WebGridScrollBarStyle
Visual Basic (Usage) Copy Code
Dim instance As WebGridScrollBarStyle
C#
[System.ComponentModel.DescriptionAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public class WebGridScrollBarStyle
Delphi
public class WebGridScrollBarStyle
JScript
System.ComponentModel.DescriptionAttribute()
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.SerializableAttribute()
public class WebGridScrollBarStyle
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public __gc class WebGridScrollBarStyle
C++/CLI
[System.ComponentModel.DescriptionAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public ref class WebGridScrollBarStyle

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebGrid.WebGridScrollBarStyle

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridScrollBarStyle Members
ISNet.WebUI.WebGrid Namespace


WebGridScrollBarStyle Class Members

[image]
Intersoft WebGrid Documentation
WebGridScrollBarStyle Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebGrid Namespace : WebGridScrollBarStyle Class

Glossary Item Box

The following tables list the members exposed by WebGridScrollBarStyle.

Public Constructors

 | Name | Description
Public Constructor | WebGridScrollBarStyle Constructor |
Top

Public Properties

 | Name | Description
Public Property | ArrowColor |
Public Property | BaseColor |
Public Property | DarkShadowColor |
Public Property | FaceColor |
Public Property | HighlightColor |
Public Property | LightColor |
Public Property | ShadowColor |
Public Property | TrackColor |
Top

Public Methods

 | Name | Description
Public Method | Clone |
Public Method | CopyFrom |
Public Method | CopyFromSerializable |
Public Method | GetObjectData |
Public Method | IsEmpty |
Public Method | Reset |
Public Method | ToString |
Top

See Also

Reference

WebGridScrollBarStyle Class
ISNet.WebUI.WebGrid Namespace


WebGridScrollBarStyle Constructor

[image]
Intersoft WebGrid Documentation
WebGridScrollBarStyle Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridScrollBarStyle Class : WebGridScrollBarStyle Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebGridScrollBarStyle()
C#
public WebGridScrollBarStyle()
Delphi
public WebGridScrollBarStyle();
JScript
public function WebGridScrollBarStyle();
Managed Extensions for C++
public: WebGridScrollBarStyle();
C++/CLI
public:
WebGridScrollBarStyle();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridScrollBarStyle Class
WebGridScrollBarStyle Members


WebGridScrollBarStyle Class Methods

[image]
Intersoft WebGrid Documentation
WebGridScrollBarStyle Class Methods
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : WebGridScrollBarStyle Class

Glossary Item Box

For a list of all members of this type, see WebGridScrollBarStyle members.

Public Methods

 | Name | Description
Public Method | Clone |
Public Method | CopyFrom |
Public Method | CopyFromSerializable |
Public Method | GetObjectData |
Public Method | IsEmpty |
Public Method | Reset |
Public Method | ToString |
Top

See Also

Reference

WebGridScrollBarStyle Class
ISNet.WebUI.WebGrid Namespace


Clone Method

[image]
Intersoft WebGrid Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridScrollBarStyle Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub Clone()
Visual Basic (Usage) Copy Code
Dim instance As WebGridScrollBarStyle

instance.Clone()
C#
public void Clone()
Delphi
public procedure Clone();
JScript
public function Clone();
Managed Extensions for C++
public: void Clone();
C++/CLI
public:
void Clone();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridScrollBarStyle Class
WebGridScrollBarStyle Members


CopyFrom Method

[image]
Intersoft WebGrid Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridScrollBarStyle Class : CopyFrom Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub CopyFrom( _
   ByVal objSource As WebGridScrollBarStyle _
)
Visual Basic (Usage) Copy Code
Dim instance As WebGridScrollBarStyle
Dim objSource As WebGridScrollBarStyle

instance.CopyFrom(objSource)
C#
public void CopyFrom(
   WebGridScrollBarStyle objSource
)
Delphi
public procedure CopyFrom(
    objSource: WebGridScrollBarStyle
);
JScript
public function CopyFrom(
   objSource : WebGridScrollBarStyle
);
Managed Extensions for C++
public: void CopyFrom(
   WebGridScrollBarStyle* objSource
)
C++/CLI
public:
void CopyFrom(
   WebGridScrollBarStyle^ objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridScrollBarStyle Class
WebGridScrollBarStyle Members


CopyFromSerializable Method

[image]
Intersoft WebGrid Documentation
CopyFromSerializable Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridScrollBarStyle Class : CopyFromSerializable Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub CopyFromSerializable( _
   ByVal objSource As WebGridScrollBarStyle _
)
Visual Basic (Usage) Copy Code
Dim instance As WebGridScrollBarStyle
Dim objSource As WebGridScrollBarStyle

instance.CopyFromSerializable(objSource)
C#
public void CopyFromSerializable(
   WebGridScrollBarStyle objSource
)
Delphi
public procedure CopyFromSerializable(
    objSource: WebGridScrollBarStyle
);
JScript
public function CopyFromSerializable(
   objSource : WebGridScrollBarStyle
);
Managed Extensions for C++
public: void CopyFromSerializable(
   WebGridScrollBarStyle* objSource
)
C++/CLI
public:
void CopyFromSerializable(
   WebGridScrollBarStyle^ objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridScrollBarStyle Class
WebGridScrollBarStyle Members


GetObjectData Method

[image]
Intersoft WebGrid Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridScrollBarStyle Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebGridScrollBarStyle
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
public void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure GetObjectData(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function GetObjectData(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void GetObjectData(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void GetObjectData(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridScrollBarStyle Class
WebGridScrollBarStyle Members


IsEmpty Method

[image]
Intersoft WebGrid Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridScrollBarStyle Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsEmpty() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebGridScrollBarStyle
Dim value As System.Boolean

value = instance.IsEmpty()
C#
public System.bool IsEmpty()
Delphi
public function IsEmpty(): System.Boolean;
JScript
public function IsEmpty() : System.boolean;
Managed Extensions for C++
public: System.bool IsEmpty();
C++/CLI
public:
System.bool IsEmpty();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridScrollBarStyle Class
WebGridScrollBarStyle Members


Reset Method

[image]
Intersoft WebGrid Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridScrollBarStyle Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As WebGridScrollBarStyle

instance.Reset()
C#
public void Reset()
Delphi
public procedure Reset();
JScript
public function Reset();
Managed Extensions for C++
public: void Reset();
C++/CLI
public:
void Reset();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridScrollBarStyle Class
WebGridScrollBarStyle Members


ToString Method

[image]
Intersoft WebGrid Documentation
ToString Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridScrollBarStyle Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString() As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebGridScrollBarStyle
Dim value As System.String

value = instance.ToString()
C#
public override System.string ToString()
Delphi
public function ToString(): System.String; override;
JScript
public override function ToString() : System.String;
Managed Extensions for C++
public: System.string* ToString(); override
C++/CLI
public:
System.String^ ToString(); override

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridScrollBarStyle Class
WebGridScrollBarStyle Members


WebGridScrollBarStyle Class Properties

[image]
Intersoft WebGrid Documentation
WebGridScrollBarStyle Class Properties
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : WebGridScrollBarStyle Class

Glossary Item Box

For a list of all members of this type, see WebGridScrollBarStyle members.

Public Properties

 | Name | Description
Public Property | ArrowColor |
Public Property | BaseColor |
Public Property | DarkShadowColor |
Public Property | FaceColor |
Public Property | HighlightColor |
Public Property | LightColor |
Public Property | ShadowColor |
Public Property | TrackColor |
Top

See Also

Reference

WebGridScrollBarStyle Class
ISNet.WebUI.WebGrid Namespace


WebGridScrollBarStyle Constructor

[image]
Intersoft WebGrid Documentation
WebGridScrollBarStyle Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridScrollBarStyle Class : WebGridScrollBarStyle Constructor

Glossary Item Box

Overload List

Overload | Description
WebGridScrollBarStyle Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridScrollBarStyle Class
WebGridScrollBarStyle Members


ArrowColor Property

[image]
Intersoft WebGrid Documentation
ArrowColor Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridScrollBarStyle Class : ArrowColor Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
Public Property ArrowColor As System.Drawing.Color
Visual Basic (Usage) Copy Code
Dim instance As WebGridScrollBarStyle
Dim value As System.Drawing.Color

instance.ArrowColor = value

value = instance.ArrowColor
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public System.Drawing.Color ArrowColor {get; set;}
Delphi
public read-write property ArrowColor: System.Drawing.Color;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute()
System.ComponentModel.DefaultValueAttribute()
public function get,set ArrowColor : System.Drawing.Color
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.Drawing.Color get_ArrowColor();
public: __property void set_ArrowColor(
   System.Drawing.Color value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.Drawing.Color ArrowColor {
   System.Drawing.Color get();
   void set (    System.Drawing.Color value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridScrollBarStyle Class
WebGridScrollBarStyle Members


BaseColor Property

[image]
Intersoft WebGrid Documentation
BaseColor Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridScrollBarStyle Class : BaseColor Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
Public Property BaseColor As System.Drawing.Color
Visual Basic (Usage) Copy Code
Dim instance As WebGridScrollBarStyle
Dim value As System.Drawing.Color

instance.BaseColor = value

value = instance.BaseColor
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public System.Drawing.Color BaseColor {get; set;}
Delphi
public read-write property BaseColor: System.Drawing.Color;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute()
System.ComponentModel.DefaultValueAttribute()
public function get,set BaseColor : System.Drawing.Color
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.Drawing.Color get_BaseColor();
public: __property void set_BaseColor(
   System.Drawing.Color value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.Drawing.Color BaseColor {
   System.Drawing.Color get();
   void set (    System.Drawing.Color value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridScrollBarStyle Class
WebGridScrollBarStyle Members


DarkShadowColor Property

[image]
Intersoft WebGrid Documentation
DarkShadowColor Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridScrollBarStyle Class : DarkShadowColor Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
Public Property DarkShadowColor As System.Drawing.Color
Visual Basic (Usage) Copy Code
Dim instance As WebGridScrollBarStyle
Dim value As System.Drawing.Color

instance.DarkShadowColor = value

value = instance.DarkShadowColor
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public System.Drawing.Color DarkShadowColor {get; set;}
Delphi
public read-write property DarkShadowColor: System.Drawing.Color;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute()
System.ComponentModel.DefaultValueAttribute()
public function get,set DarkShadowColor : System.Drawing.Color
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.Drawing.Color get_DarkShadowColor();
public: __property void set_DarkShadowColor(
   System.Drawing.Color value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.Drawing.Color DarkShadowColor {
   System.Drawing.Color get();
   void set (    System.Drawing.Color value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridScrollBarStyle Class
WebGridScrollBarStyle Members


FaceColor Property

[image]
Intersoft WebGrid Documentation
FaceColor Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridScrollBarStyle Class : FaceColor Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
Public Property FaceColor As System.Drawing.Color
Visual Basic (Usage) Copy Code
Dim instance As WebGridScrollBarStyle
Dim value As System.Drawing.Color

instance.FaceColor = value

value = instance.FaceColor
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public System.Drawing.Color FaceColor {get; set;}
Delphi
public read-write property FaceColor: System.Drawing.Color;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute()
System.ComponentModel.DefaultValueAttribute()
public function get,set FaceColor : System.Drawing.Color
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.Drawing.Color get_FaceColor();
public: __property void set_FaceColor(
   System.Drawing.Color value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.Drawing.Color FaceColor {
   System.Drawing.Color get();
   void set (    System.Drawing.Color value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridScrollBarStyle Class
WebGridScrollBarStyle Members


HighlightColor Property

[image]
Intersoft WebGrid Documentation
HighlightColor Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridScrollBarStyle Class : HighlightColor Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
Public Property HighlightColor As System.Drawing.Color
Visual Basic (Usage) Copy Code
Dim instance As WebGridScrollBarStyle
Dim value As System.Drawing.Color

instance.HighlightColor = value

value = instance.HighlightColor
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public System.Drawing.Color HighlightColor {get; set;}
Delphi
public read-write property HighlightColor: System.Drawing.Color;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute()
System.ComponentModel.DefaultValueAttribute()
public function get,set HighlightColor : System.Drawing.Color
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.Drawing.Color get_HighlightColor();
public: __property void set_HighlightColor(
   System.Drawing.Color value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.Drawing.Color HighlightColor {
   System.Drawing.Color get();
   void set (    System.Drawing.Color value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridScrollBarStyle Class
WebGridScrollBarStyle Members


LightColor Property

[image]
Intersoft WebGrid Documentation
LightColor Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridScrollBarStyle Class : LightColor Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
Public Property LightColor As System.Drawing.Color
Visual Basic (Usage) Copy Code
Dim instance As WebGridScrollBarStyle
Dim value As System.Drawing.Color

instance.LightColor = value

value = instance.LightColor
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public System.Drawing.Color LightColor {get; set;}
Delphi
public read-write property LightColor: System.Drawing.Color;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute()
System.ComponentModel.DefaultValueAttribute()
public function get,set LightColor : System.Drawing.Color
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.Drawing.Color get_LightColor();
public: __property void set_LightColor(
   System.Drawing.Color value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.Drawing.Color LightColor {
   System.Drawing.Color get();
   void set (    System.Drawing.Color value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridScrollBarStyle Class
WebGridScrollBarStyle Members


ShadowColor Property

[image]
Intersoft WebGrid Documentation
ShadowColor Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridScrollBarStyle Class : ShadowColor Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
Public Property ShadowColor As System.Drawing.Color
Visual Basic (Usage) Copy Code
Dim instance As WebGridScrollBarStyle
Dim value As System.Drawing.Color

instance.ShadowColor = value

value = instance.ShadowColor
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public System.Drawing.Color ShadowColor {get; set;}
Delphi
public read-write property ShadowColor: System.Drawing.Color;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute()
System.ComponentModel.DefaultValueAttribute()
public function get,set ShadowColor : System.Drawing.Color
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.Drawing.Color get_ShadowColor();
public: __property void set_ShadowColor(
   System.Drawing.Color value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.Drawing.Color ShadowColor {
   System.Drawing.Color get();
   void set (    System.Drawing.Color value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridScrollBarStyle Class
WebGridScrollBarStyle Members


TrackColor Property

[image]
Intersoft WebGrid Documentation
TrackColor Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridScrollBarStyle Class : TrackColor Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
Public Property TrackColor As System.Drawing.Color
Visual Basic (Usage) Copy Code
Dim instance As WebGridScrollBarStyle
Dim value As System.Drawing.Color

instance.TrackColor = value

value = instance.TrackColor
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public System.Drawing.Color TrackColor {get; set;}
Delphi
public read-write property TrackColor: System.Drawing.Color;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute()
System.ComponentModel.DefaultValueAttribute()
public function get,set TrackColor : System.Drawing.Color
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.Drawing.Color get_TrackColor();
public: __property void set_TrackColor(
   System.Drawing.Color value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.Drawing.Color TrackColor {
   System.Drawing.Color get();
   void set (    System.Drawing.Color value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridScrollBarStyle Class
WebGridScrollBarStyle Members


WebGridTable Class

[image]
Intersoft WebGrid Documentation
WebGridTable Class
Members See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : WebGridTable Class

Glossary Item Box

Object Model

WebGridTable Class

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.DescriptionAttribute()>
<System.SerializableAttribute()>
Public Class WebGridTable
   Inherits ISNet.WebUI.NamedObjectBase
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.Serialization.XmlSerialization.ICustomXmlSerializer, ISNet.WebUI.INamedObject
Visual Basic (Usage) Copy Code
Dim instance As WebGridTable
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DescriptionAttribute()]
[System.SerializableAttribute()]
public class WebGridTable : ISNet.WebUI.NamedObjectBase, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.Serialization.XmlSerialization.ICustomXmlSerializer, ISNet.WebUI.INamedObject
Delphi
public class WebGridTable = class(ISNet.WebUI.NamedObjectBase, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.Serialization.XmlSerialization.ICustomXmlSerializer, ISNet.WebUI.INamedObject)
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.DescriptionAttribute()
System.SerializableAttribute()
public class WebGridTable extends ISNet.WebUI.NamedObjectBase implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.Serialization.XmlSerialization.ICustomXmlSerializer, ISNet.WebUI.INamedObject
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DescriptionAttribute()]
[System.SerializableAttribute()]
public __gc class WebGridTable : public ISNet.WebUI.NamedObjectBase, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.Serialization.XmlSerialization.ICustomXmlSerializer, ISNet.WebUI.INamedObject
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DescriptionAttribute()]
[System.SerializableAttribute()]
public ref class WebGridTable : public ISNet.WebUI.NamedObjectBase, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.Serialization.XmlSerialization.ICustomXmlSerializer, ISNet.WebUI.INamedObject

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.NamedObjectBase
ISNet.WebUI.WebGrid.WebGridTable

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridTable Members
ISNet.WebUI.WebGrid Namespace


WebGridTable Class Members

[image]
Intersoft WebGrid Documentation
WebGridTable Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebGrid Namespace : WebGridTable Class

Glossary Item Box

The following tables list the members exposed by WebGridTable.

Public Constructors

 | Name | Description
Public Constructor | WebGridTable Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | AllowAddNew |
Public Property | AllowColumnMove |
Public Property | AllowColumnSizing |
Public Property | AllowDelete |
Public Property | AllowEdit |
Public Property | AllowFilter |
Public Property | AllowGrouping |
Public Property | AllowMultipleSelection |
Public Property | AllowSelectColumns |
Public Property | AllowSorting |
Public Property | AutomaticFilter |
Public Property | AutomaticSort |
Public Property | ButtonStyle |
Public Property | Caption |
Public Property | CaptionImage |
Public Property | CellClickAction |
Public Property | CellPaddingDefault |
Public Property | CellSpacingDefault |
Public Property | CheckedRowStyle |
Public Property | ColumnFooters |
Public Property | ColumnHeaders |
Public Property | ColumnSetSettings |
Public Property | ColumnWidthDefault |
Public Property | DataKeyField |
Public Property | DataMember |
Public Property | FocusCellStyle |
Public Property | FooterStyle |
Public Property | GridLineColor |
Public Property | GridLines |
Public Property | GridLineStyle |
Public Property | GroupMode |
Public Property | GroupRowInfoFormatDefault |
Public Property | GroupRowInfoStyle |
Public Property | GroupTotalStyle |
Public Property | GroupTotalVisible |
Public Property | HeaderClickAction |
Public Property | HeaderStyle |
Public Property | HideColumnsWhenGrouped |
Public Property | HyperlinkStyle |
Public Property | NewRowInfoText |
Public Property | NewRowStyle |
Public Property | PreviewRowSettings |
Public Property | PreviewRowVisible |
Public Property | RowHeaders |
Public Property | RowHeaderStyle |
Public Property | RowHeaderWidth |
Public Property | RowHeightDefault |
Public Property | RowLayout |
Public Property | RowStyle |
Public Property | SelectedRowStyle |
Public Property | SelfReferencingSettings |
Public Property | SortedColumnStyle |
Public Property | TableHeaderStyle |
Public Property | TableHeaderVisible |
Public Property | TreeNodeField |
Public Property | UseValueListForFilter |
Public Property | UseValueListForSorting |
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CreateRow |
Public Method | CustomDeserialize |
Public Method | CustomSerialize |
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DispatchDataTableFromDataSource |
Public Method | GetAggregatedDataKeyFields |
Public Method | GetChanges |
Public Method | GetCheckedRows |
Public Method | GetCombinedSortExpression |
Public Method | GetCompositeDataKeyFields |
Public Method | GetCompositeDataKeyFieldsString |
Public Method | GetExpandedChildRows |
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | GetUngrouppedRows |
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | IsKeyValueEqual |
Public Method | PerformAutomaticAggregation |
Public Method | ReindexColumnsPosition |
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | RetrieveHierarchicalStructure |
Public Method | RetrieveStructure |
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SetLayout |
Public Method | Sort | Overloaded.
Public Method | ToString |
Public Method | UpdateRowIdentity |
Public Method | UpdateToDataSourceControl |
Top

See Also

Reference

WebGridTable Class
ISNet.WebUI.WebGrid Namespace


WebGridTable Constructor

[image]
Intersoft WebGrid Documentation
WebGridTable Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridTable Class : WebGridTable Constructor

Glossary Item Box

Overload List

Overload | Description
WebGridTable Constructor() |
WebGridTable Constructor(String) |
WebGridTable Constructor(String,String) |
WebGridTable Constructor(String,String,String) |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridTable Class
WebGridTable Members


WebGridTable Constructor()

[image]
Intersoft WebGrid Documentation
WebGridTable Constructor()
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridTable Class > WebGridTable Constructor : WebGridTable Constructor()

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebGridTable()
C#
public WebGridTable()
Delphi
public WebGridTable();
JScript
public function WebGridTable();
Managed Extensions for C++
public: WebGridTable();
C++/CLI
public:
WebGridTable();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridTable Class
WebGridTable Members
Overload List


WebGridTable Constructor(String)

[image]
Intersoft WebGrid Documentation
WebGridTable Constructor(String)
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridTable Class > WebGridTable Constructor : WebGridTable Constructor(String)

name

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal name As System.String _
)
Visual Basic (Usage) Copy Code
Dim name As System.String

Dim instance As New WebGridTable(name)
C#
public WebGridTable(
   System.string name
)
Delphi
public WebGridTable(
    name: System.String
);
JScript
public function WebGridTable(
   name : System.String
);
Managed Extensions for C++
public: WebGridTable(
   System.string* name
)
C++/CLI
public:
WebGridTable(
   System.String^ name
)

Parameters

name

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridTable Class
WebGridTable Members
Overload List


WebGridTable Constructor(String,String)

[image]
Intersoft WebGrid Documentation
WebGridTable Constructor(String,String)
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridTable Class > WebGridTable Constructor : WebGridTable Constructor(String,String)

name
dataMember

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal name As System.String, _
   ByVal dataMember As System.String _
)
Visual Basic (Usage) Copy Code
Dim name As System.String
Dim dataMember As System.String

Dim instance As New WebGridTable(name, dataMember)
C#
public WebGridTable(
   System.string name,
   System.string dataMember
)
Delphi
public WebGridTable(
    name: System.String;
    dataMember: System.String
);
JScript
public function WebGridTable(
   name : System.String,
   dataMember : System.String
);
Managed Extensions for C++
public: WebGridTable(
   System.string* name,
   System.string* dataMember
)
C++/CLI
public:
WebGridTable(
   System.String^ name,
   System.String^ dataMember
)

Parameters

name
dataMember

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridTable Class
WebGridTable Members
Overload List


WebGridTable Constructor(String,String,String)

[image]
Intersoft WebGrid Documentation
WebGridTable Constructor(String,String,String)
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridTable Class > WebGridTable Constructor : WebGridTable Constructor(String,String,String)

name
dataMember
caption

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal name As System.String, _
   ByVal dataMember As System.String, _
   ByVal caption As System.String _
)
Visual Basic (Usage) Copy Code
Dim name As System.String
Dim dataMember As System.String
Dim caption As System.String

Dim instance As New WebGridTable(name, dataMember, caption)
C#
public WebGridTable(
   System.string name,
   System.string dataMember,
   System.string caption
)
Delphi
public WebGridTable(
    name: System.String;
    dataMember: System.String;
    caption: System.String
);
JScript
public function WebGridTable(
   name : System.String,
   dataMember : System.String,
   caption : System.String
);
Managed Extensions for C++
public: WebGridTable(
   System.string* name,
   System.string* dataMember,
   System.string* caption
)
C++/CLI
public:
WebGridTable(
   System.String^ name,
   System.String^ dataMember,
   System.String^ caption
)

Parameters

name
dataMember
caption

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridTable Class
WebGridTable Members
Overload List


Clone Method

[image]
Intersoft WebGrid Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridTable Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As System.Object
Visual Basic (Usage) Copy Code
Dim instance As WebGridTable
Dim value As System.Object

value = instance.Clone()
C#
public virtual System.object Clone()
Delphi
public function Clone(): System.TObject; virtual;
JScript
public function Clone() : System.Object;
Managed Extensions for C++
public: virtual System.Object* Clone();
C++/CLI
public:
virtual System.Object^ Clone();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridTable Class
WebGridTable Members


CopyFrom Method

[image]
Intersoft WebGrid Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridTable Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridTable Class
WebGridTable Members


CopyFrom(Object) Method

[image]
Intersoft WebGrid Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridTable Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebGridTable
Dim objSource As System.Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   System.object objSource
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridTable Class
WebGridTable Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebGrid Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridTable Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object, _
   ByVal cloneSourceValue As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebGridTable
Dim objSource As System.Object
Dim cloneSourceValue As System.Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   System.object objSource,
   System.bool cloneSourceValue
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject;
    cloneSourceValue: System.Boolean
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object,
   cloneSourceValue : System.boolean
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource,
   System.bool cloneSourceValue
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource,
   System.bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridTable Class
WebGridTable Members
Overload List


WebGridTable Class Methods

[image]
Intersoft WebGrid Documentation
WebGridTable Class Methods
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : WebGridTable Class

Glossary Item Box

For a list of all members of this type, see WebGridTable members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CreateRow |
Public Method | CustomDeserialize |
Public Method | CustomSerialize |
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DispatchDataTableFromDataSource |
Public Method | GetAggregatedDataKeyFields |
Public Method | GetChanges |
Public Method | GetCheckedRows |
Public Method | GetCombinedSortExpression |
Public Method | GetCompositeDataKeyFields |
Public Method | GetCompositeDataKeyFieldsString |
Public Method | GetExpandedChildRows |
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | GetUngrouppedRows |
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | IsKeyValueEqual |
Public Method | PerformAutomaticAggregation |
Public Method | ReindexColumnsPosition |
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | RetrieveHierarchicalStructure |
Public Method | RetrieveStructure |
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SetLayout |
Public Method | Sort | Overloaded.
Public Method | ToString |
Public Method | UpdateRowIdentity |
Public Method | UpdateToDataSourceControl |
Top

See Also

Reference

WebGridTable Class
ISNet.WebUI.WebGrid Namespace


CreateRow Method

[image]
Intersoft WebGrid Documentation
CreateRow Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridTable Class : CreateRow Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function CreateRow() As WebGridRow
Visual Basic (Usage) Copy Code
Dim instance As WebGridTable
Dim value As WebGridRow

value = instance.CreateRow()
C#
public WebGridRow CreateRow()
Delphi
public function CreateRow(): WebGridRow;
JScript
public function CreateRow() : WebGridRow;
Managed Extensions for C++
public: WebGridRow* CreateRow();
C++/CLI
public:
WebGridRow^ CreateRow();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridTable Class
WebGridTable Members


CustomDeserialize Method

[image]
Intersoft WebGrid Documentation
CustomDeserialize Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridTable Class : CustomDeserialize Method

mi
currentObj
parentNode
currentNode

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub CustomDeserialize( _
   ByVal mi As System.Reflection.MemberInfo, _
   ByVal currentObj As System.Object, _
   ByVal parentNode As System.Xml.XmlNode, _
   ByVal currentNode As System.Xml.XmlNode _
)
Visual Basic (Usage) Copy Code
Dim instance As WebGridTable
Dim mi As System.Reflection.MemberInfo
Dim currentObj As System.Object
Dim parentNode As System.Xml.XmlNode
Dim currentNode As System.Xml.XmlNode

instance.CustomDeserialize(mi, currentObj, parentNode, currentNode)
C#
public void CustomDeserialize(
   System.Reflection.MemberInfo mi,
   System.object currentObj,
   System.Xml.XmlNode parentNode,
   System.Xml.XmlNode currentNode
)
Delphi
public procedure CustomDeserialize(
    mi: System.Reflection.MemberInfo;
    currentObj: System.TObject;
    parentNode: System.Xml.XmlNode;
    currentNode: System.Xml.XmlNode
);
JScript
public function CustomDeserialize(
   mi : System.Reflection.MemberInfo,
   currentObj : System.Object,
   parentNode : System.Xml.XmlNode,
   currentNode : System.Xml.XmlNode
);
Managed Extensions for C++
public: void CustomDeserialize(
   System.Reflection.MemberInfo* mi,
   System.Object* currentObj,
   System.Xml.XmlNode* parentNode,
   System.Xml.XmlNode* currentNode
)
C++/CLI
public:
void CustomDeserialize(
   System.Reflection.MemberInfo^ mi,
   System.Object^ currentObj,
   System.Xml.XmlNode^ parentNode,
   System.Xml.XmlNode^ currentNode
)

Parameters

mi
currentObj
parentNode
currentNode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridTable Class
WebGridTable Members


CustomSerialize Method

[image]
Intersoft WebGrid Documentation
CustomSerialize Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridTable Class : CustomSerialize Method

doc
node

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub CustomSerialize( _
   ByVal doc As System.Xml.XmlDocument, _
   ByVal node As System.Xml.XmlNode _
)
Visual Basic (Usage) Copy Code
Dim instance As WebGridTable
Dim doc As System.Xml.XmlDocument
Dim node As System.Xml.XmlNode

instance.CustomSerialize(doc, node)
C#
public void CustomSerialize(
   System.Xml.XmlDocument doc,
   System.Xml.XmlNode node
)
Delphi
public procedure CustomSerialize(
    doc: System.Xml.XmlDocument;
    node: System.Xml.XmlNode
);
JScript
public function CustomSerialize(
   doc : System.Xml.XmlDocument,
   node : System.Xml.XmlNode
);
Managed Extensions for C++
public: void CustomSerialize(
   System.Xml.XmlDocument* doc,
   System.Xml.XmlNode* node
)
C++/CLI
public:
void CustomSerialize(
   System.Xml.XmlDocument^ doc,
   System.Xml.XmlNode^ node
)

Parameters

doc
node

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridTable Class
WebGridTable Members


DeSerializeObjectData Method

[image]
Intersoft WebGrid Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridTable Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebGridTable
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure DeSerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function DeSerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void DeSerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void DeSerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridTable Class
WebGridTable Members


DispatchDataTableFromDataSource Method

[image]
Intersoft WebGrid Documentation
DispatchDataTableFromDataSource Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridTable Class : DispatchDataTableFromDataSource Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function DispatchDataTableFromDataSource() As System.Data.DataTable
Visual Basic (Usage) Copy Code
Dim instance As WebGridTable
Dim value As System.Data.DataTable

value = instance.DispatchDataTableFromDataSource()
C#
public System.Data.DataTable DispatchDataTableFromDataSource()
Delphi
public function DispatchDataTableFromDataSource(): System.Data.DataTable;
JScript
public function DispatchDataTableFromDataSource() : System.Data.DataTable;
Managed Extensions for C++
public: System.Data.DataTable* DispatchDataTableFromDataSource();
C++/CLI
public:
System.Data.DataTable^ DispatchDataTableFromDataSource();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridTable Class
WebGridTable Members


GetAggregatedDataKeyFields Method

[image]
Intersoft WebGrid Documentation
GetAggregatedDataKeyFields Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridTable Class : GetAggregatedDataKeyFields Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetAggregatedDataKeyFields() As System.Collections.ArrayList
Visual Basic (Usage) Copy Code
Dim instance As WebGridTable
Dim value As System.Collections.ArrayList

value = instance.GetAggregatedDataKeyFields()
C#
public System.Collections.ArrayList GetAggregatedDataKeyFields()
Delphi
public function GetAggregatedDataKeyFields(): System.Collections.ArrayList;
JScript
public function GetAggregatedDataKeyFields() : System.Collections.ArrayList;
Managed Extensions for C++
public: System.Collections.ArrayList* GetAggregatedDataKeyFields();
C++/CLI
public:
System.Collections.ArrayList^ GetAggregatedDataKeyFields();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridTable Class
WebGridTable Members


GetChanges Method

[image]
Intersoft WebGrid Documentation
GetChanges Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridTable Class : GetChanges Method

state

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetChanges( _
   ByVal state As RowState _
) As System.Collections.Generic.List(Of WebGridRowChanges)
Visual Basic (Usage) Copy Code
Dim instance As WebGridTable
Dim state As RowState
Dim value As System.Collections.Generic.List(Of WebGridRowChanges)

value = instance.GetChanges(state)
C#
public System.Collections.Generic.List<WebGridRowChanges> GetChanges(
   RowState state
)
Delphi
public function GetChanges(
    state: RowState
): System.Collections.Generic.List;
JScript
public function GetChanges(
   state : RowState
) : System.Collections.Generic.List;
Managed Extensions for C++
public: System.Collections.Generic.List<WebGridRowChanges*>* GetChanges(
   RowState state
)
C++/CLI
public:
System.Collections.Generic.List<WebGridRowChanges^>^ GetChanges(
   RowState state
)

Parameters

state

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridTable Class
WebGridTable Members


GetCheckedRows Method

[image]
Intersoft WebGrid Documentation
GetCheckedRows Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridTable Class : GetCheckedRows Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetCheckedRows() As System.Collections.ArrayList
Visual Basic (Usage) Copy Code
Dim instance As WebGridTable
Dim value As System.Collections.ArrayList

value = instance.GetCheckedRows()
C#
public System.Collections.ArrayList GetCheckedRows()
Delphi
public function GetCheckedRows(): System.Collections.ArrayList;
JScript
public function GetCheckedRows() : System.Collections.ArrayList;
Managed Extensions for C++
public: System.Collections.ArrayList* GetCheckedRows();
C++/CLI
public:
System.Collections.ArrayList^ GetCheckedRows();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridTable Class
WebGridTable Members


GetCombinedSortExpression Method

[image]
Intersoft WebGrid Documentation
GetCombinedSortExpression Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridTable Class : GetCombinedSortExpression Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetCombinedSortExpression() As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebGridTable
Dim value As System.String

value = instance.GetCombinedSortExpression()
C#
public System.string GetCombinedSortExpression()
Delphi
public function GetCombinedSortExpression(): System.String;
JScript
public function GetCombinedSortExpression() : System.String;
Managed Extensions for C++
public: System.string* GetCombinedSortExpression();
C++/CLI
public:
System.String^ GetCombinedSortExpression();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridTable Class
WebGridTable Members


GetCompositeDataKeyFields Method

[image]
Intersoft WebGrid Documentation
GetCompositeDataKeyFields Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridTable Class : GetCompositeDataKeyFields Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetCompositeDataKeyFields() As System.Collections.ArrayList
Visual Basic (Usage) Copy Code
Dim instance As WebGridTable
Dim value As System.Collections.ArrayList

value = instance.GetCompositeDataKeyFields()
C#
public System.Collections.ArrayList GetCompositeDataKeyFields()
Delphi
public function GetCompositeDataKeyFields(): System.Collections.ArrayList;
JScript
public function GetCompositeDataKeyFields() : System.Collections.ArrayList;
Managed Extensions for C++
public: System.Collections.ArrayList* GetCompositeDataKeyFields();
C++/CLI
public:
System.Collections.ArrayList^ GetCompositeDataKeyFields();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridTable Class
WebGridTable Members


GetCompositeDataKeyFieldsString Method

[image]
Intersoft WebGrid Documentation
GetCompositeDataKeyFieldsString Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridTable Class : GetCompositeDataKeyFieldsString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetCompositeDataKeyFieldsString() As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebGridTable
Dim value As System.String

value = instance.GetCompositeDataKeyFieldsString()
C#
public System.string GetCompositeDataKeyFieldsString()
Delphi
public function GetCompositeDataKeyFieldsString(): System.String;
JScript
public function GetCompositeDataKeyFieldsString() : System.String;
Managed Extensions for C++
public: System.string* GetCompositeDataKeyFieldsString();
C++/CLI
public:
System.String^ GetCompositeDataKeyFieldsString();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridTable Class
WebGridTable Members


GetExpandedChildRows Method

[image]
Intersoft WebGrid Documentation
GetExpandedChildRows Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridTable Class : GetExpandedChildRows Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetExpandedChildRows() As System.Collections.ArrayList
Visual Basic (Usage) Copy Code
Dim instance As WebGridTable
Dim value As System.Collections.ArrayList

value = instance.GetExpandedChildRows()
C#
public System.Collections.ArrayList GetExpandedChildRows()
Delphi
public function GetExpandedChildRows(): System.Collections.ArrayList;
JScript
public function GetExpandedChildRows() : System.Collections.ArrayList;
Managed Extensions for C++
public: System.Collections.ArrayList* GetExpandedChildRows();
C++/CLI
public:
System.Collections.ArrayList^ GetExpandedChildRows();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridTable Class
WebGridTable Members


GetHashCode Method

[image]
Intersoft WebGrid Documentation
GetHashCode Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridTable Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebGridTable
Dim value As System.Integer

value = instance.GetHashCode()
C#
public virtual System.int GetHashCode()
Delphi
public function GetHashCode(): System.Integer; virtual;
JScript
public function GetHashCode() : System.int;
Managed Extensions for C++
public: virtual System.int GetHashCode();
C++/CLI
public:
virtual System.int GetHashCode();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridTable Class
WebGridTable Members


GetObjectData Method

[image]
Intersoft WebGrid Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridTable Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebGridTable
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure GetObjectData(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
); override;
JScript
public override function GetObjectData(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void GetObjectData(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
) override
C++/CLI
public:
void GetObjectData(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
) override

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridTable Class
WebGridTable Members


GetUngrouppedRows Method

[image]
Intersoft WebGrid Documentation
GetUngrouppedRows Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridTable Class : GetUngrouppedRows Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetUngrouppedRows() As WebGridRowCollection
Visual Basic (Usage) Copy Code
Dim instance As WebGridTable
Dim value As WebGridRowCollection

value = instance.GetUngrouppedRows()
C#
public WebGridRowCollection GetUngrouppedRows()
Delphi
public function GetUngrouppedRows(): WebGridRowCollection;
JScript
public function GetUngrouppedRows() : WebGridRowCollection;
Managed Extensions for C++
public: WebGridRowCollection* GetUngrouppedRows();
C++/CLI
public:
WebGridRowCollection^ GetUngrouppedRows();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridTable Class
WebGridTable Members


IsEmpty Method

[image]
Intersoft WebGrid Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridTable Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebGridTable
Dim value As System.Boolean

value = instance.IsEmpty()
C#
public virtual System.bool IsEmpty()
Delphi
public function IsEmpty(): System.Boolean; virtual;
JScript
public function IsEmpty() : System.boolean;
Managed Extensions for C++
public: virtual System.bool IsEmpty();
C++/CLI
public:
virtual System.bool IsEmpty();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridTable Class
WebGridTable Members


IsKeyValueEqual Method

[image]
Intersoft WebGrid Documentation
IsKeyValueEqual Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridTable Class : IsKeyValueEqual Method

row
oKeyValues

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsKeyValueEqual( _
   ByVal row As WebGridRow, _
   ByVal oKeyValues As System.Object _
) As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebGridTable
Dim row As WebGridRow
Dim oKeyValues As System.Object
Dim value As System.Boolean

value = instance.IsKeyValueEqual(row, oKeyValues)
C#
public System.bool IsKeyValueEqual(
   WebGridRow row,
   System.object oKeyValues
)
Delphi
public function IsKeyValueEqual(
    row: WebGridRow;
    oKeyValues: System.TObject
): System.Boolean;
JScript
public function IsKeyValueEqual(
   row : WebGridRow,
   oKeyValues : System.Object
) : System.boolean;
Managed Extensions for C++
public: System.bool IsKeyValueEqual(
   WebGridRow* row,
   System.Object* oKeyValues
)
C++/CLI
public:
System.bool IsKeyValueEqual(
   WebGridRow^ row,
   System.Object^ oKeyValues
)

Parameters

row
oKeyValues

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridTable Class
WebGridTable Members


PerformAutomaticAggregation Method

[image]
Intersoft WebGrid Documentation
PerformAutomaticAggregation Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridTable Class : PerformAutomaticAggregation Method

command
autoCloseConnection

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub PerformAutomaticAggregation( _
   ByVal command As System.Data.Common.DbCommand, _
   ByVal autoCloseConnection As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebGridTable
Dim command As System.Data.Common.DbCommand
Dim autoCloseConnection As System.Boolean

instance.PerformAutomaticAggregation(command, autoCloseConnection)
C#
public void PerformAutomaticAggregation(
   System.Data.Common.DbCommand command,
   System.bool autoCloseConnection
)
Delphi
public procedure PerformAutomaticAggregation(
    command: System.Data.Common.DbCommand;
    autoCloseConnection: System.Boolean
);
JScript
public function PerformAutomaticAggregation(
   command : System.Data.Common.DbCommand,
   autoCloseConnection : System.boolean
);
Managed Extensions for C++
public: void PerformAutomaticAggregation(
   System.Data.Common.DbCommand* command,
   System.bool autoCloseConnection
)
C++/CLI
public:
void PerformAutomaticAggregation(
   System.Data.Common.DbCommand^ command,
   System.bool autoCloseConnection
)

Parameters

command
autoCloseConnection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridTable Class
WebGridTable Members


ReindexColumnsPosition Method

[image]
Intersoft WebGrid Documentation
ReindexColumnsPosition Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridTable Class : ReindexColumnsPosition Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub ReindexColumnsPosition()
Visual Basic (Usage) Copy Code
Dim instance As WebGridTable

instance.ReindexColumnsPosition()
C#
public void ReindexColumnsPosition()
Delphi
public procedure ReindexColumnsPosition();
JScript
public function ReindexColumnsPosition();
Managed Extensions for C++
public: void ReindexColumnsPosition();
C++/CLI
public:
void ReindexColumnsPosition();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridTable Class
WebGridTable Members


Reset Method

[image]
Intersoft WebGrid Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridTable Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As WebGridTable

instance.Reset()
C#
public virtual void Reset()
Delphi
public procedure Reset(); virtual;
JScript
public function Reset();
Managed Extensions for C++
public: virtual void Reset();
C++/CLI
public:
virtual void Reset();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridTable Class
WebGridTable Members


RetrieveHierarchicalStructure Method

[image]
Intersoft WebGrid Documentation
RetrieveHierarchicalStructure Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridTable Class : RetrieveHierarchicalStructure Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub RetrieveHierarchicalStructure()
Visual Basic (Usage) Copy Code
Dim instance As WebGridTable

instance.RetrieveHierarchicalStructure()
C#
public void RetrieveHierarchicalStructure()
Delphi
public procedure RetrieveHierarchicalStructure();
JScript
public function RetrieveHierarchicalStructure();
Managed Extensions for C++
public: void RetrieveHierarchicalStructure();
C++/CLI
public:
void RetrieveHierarchicalStructure();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridTable Class
WebGridTable Members


RetrieveStructure Method

[image]
Intersoft WebGrid Documentation
RetrieveStructure Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridTable Class : RetrieveStructure Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub RetrieveStructure()
Visual Basic (Usage) Copy Code
Dim instance As WebGridTable

instance.RetrieveStructure()
C#
public void RetrieveStructure()
Delphi
public procedure RetrieveStructure();
JScript
public function RetrieveStructure();
Managed Extensions for C++
public: void RetrieveStructure();
C++/CLI
public:
void RetrieveStructure();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridTable Class
WebGridTable Members


SerializeObjectData Method

[image]
Intersoft WebGrid Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridTable Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebGridTable
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure SerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function SerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void SerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void SerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridTable Class
WebGridTable Members


SetLayout Method

[image]
Intersoft WebGrid Documentation
SetLayout Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridTable Class : SetLayout Method

layoutSet

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SetLayout( _
   ByVal layoutSet As LayoutSet _
)
Visual Basic (Usage) Copy Code
Dim instance As WebGridTable
Dim layoutSet As LayoutSet

instance.SetLayout(layoutSet)
C#
public void SetLayout(
   LayoutSet layoutSet
)
Delphi
public procedure SetLayout(
    layoutSet: LayoutSet
);
JScript
public function SetLayout(
   layoutSet : LayoutSet
);
Managed Extensions for C++
public: void SetLayout(
   LayoutSet* layoutSet
)
C++/CLI
public:
void SetLayout(
   LayoutSet^ layoutSet
)

Parameters

layoutSet

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridTable Class
WebGridTable Members


Sort Method

[image]
Intersoft WebGrid Documentation
Sort Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridTable Class : Sort Method

Glossary Item Box

Overload List

Overload | Description
Sort() |
Sort(WebGridGroupCollection) |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridTable Class
WebGridTable Members


Sort() Method

[image]
Intersoft WebGrid Documentation
Sort() Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridTable Class > Sort Method : Sort() Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Sub Sort()
Visual Basic (Usage) Copy Code
Dim instance As WebGridTable

instance.Sort()
C#
public void Sort()
Delphi
public procedure Sort();
JScript
public function Sort();
Managed Extensions for C++
public: void Sort();
C++/CLI
public:
void Sort();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridTable Class
WebGridTable Members
Overload List


Sort(WebGridGroupCollection) Method

[image]
Intersoft WebGrid Documentation
Sort(WebGridGroupCollection) Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridTable Class > Sort Method : Sort(WebGridGroupCollection) Method

sortColumns

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Sub Sort( _
   ByVal sortColumns As WebGridGroupCollection _
)
Visual Basic (Usage) Copy Code
Dim instance As WebGridTable
Dim sortColumns As WebGridGroupCollection

instance.Sort(sortColumns)
C#
public void Sort(
   WebGridGroupCollection sortColumns
)
Delphi
public procedure Sort(
    sortColumns: WebGridGroupCollection
);
JScript
public function Sort(
   sortColumns : WebGridGroupCollection
);
Managed Extensions for C++
public: void Sort(
   WebGridGroupCollection* sortColumns
)
C++/CLI
public:
void Sort(
   WebGridGroupCollection^ sortColumns
)

Parameters

sortColumns

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridTable Class
WebGridTable Members
Overload List


ToString Method

[image]
Intersoft WebGrid Documentation
ToString Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridTable Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString() As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebGridTable
Dim value As System.String

value = instance.ToString()
C#
public override System.string ToString()
Delphi
public function ToString(): System.String; override;
JScript
public override function ToString() : System.String;
Managed Extensions for C++
public: System.string* ToString(); override
C++/CLI
public:
System.String^ ToString(); override

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridTable Class
WebGridTable Members


UpdateRowIdentity Method

[image]
Intersoft WebGrid Documentation
UpdateRowIdentity Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridTable Class : UpdateRowIdentity Method

dataMember
originalValue
processedValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub UpdateRowIdentity( _
   ByVal dataMember As System.String, _
   ByVal originalValue As System.Object, _
   ByVal processedValue As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebGridTable
Dim dataMember As System.String
Dim originalValue As System.Object
Dim processedValue As System.Object

instance.UpdateRowIdentity(dataMember, originalValue, processedValue)
C#
public void UpdateRowIdentity(
   System.string dataMember,
   System.object originalValue,
   System.object processedValue
)
Delphi
public procedure UpdateRowIdentity(
    dataMember: System.String;
    originalValue: System.TObject;
    processedValue: System.TObject
);
JScript
public function UpdateRowIdentity(
   dataMember : System.String,
   originalValue : System.Object,
   processedValue : System.Object
);
Managed Extensions for C++
public: void UpdateRowIdentity(
   System.string* dataMember,
   System.Object* originalValue,
   System.Object* processedValue
)
C++/CLI
public:
void UpdateRowIdentity(
   System.String^ dataMember,
   System.Object^ originalValue,
   System.Object^ processedValue
)

Parameters

dataMember
originalValue
processedValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridTable Class
WebGridTable Members


UpdateToDataSourceControl Method

[image]
Intersoft WebGrid Documentation
UpdateToDataSourceControl Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridTable Class : UpdateToDataSourceControl Method

queryCommandMode
row
dataTable

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function UpdateToDataSourceControl( _
   ByVal queryCommandMode As QueryCommand, _
   ByVal row As WebGridRow, _
   ByVal dataTable As System.Data.DataTable _
) As UpdateResult
Visual Basic (Usage) Copy Code
Dim instance As WebGridTable
Dim queryCommandMode As QueryCommand
Dim row As WebGridRow
Dim dataTable As System.Data.DataTable
Dim value As UpdateResult

value = instance.UpdateToDataSourceControl(queryCommandMode, row, dataTable)
C#
public UpdateResult UpdateToDataSourceControl(
   QueryCommand queryCommandMode,
   WebGridRow row,
   System.Data.DataTable dataTable
)
Delphi
public function UpdateToDataSourceControl(
    queryCommandMode: QueryCommand;
    row: WebGridRow;
    dataTable: System.Data.DataTable
): UpdateResult;
JScript
public function UpdateToDataSourceControl(
   queryCommandMode : QueryCommand,
   row : WebGridRow,
   dataTable : System.Data.DataTable
) : UpdateResult;
Managed Extensions for C++
public: UpdateResult* UpdateToDataSourceControl(
   QueryCommand queryCommandMode,
   WebGridRow* row,
   System.Data.DataTable* dataTable
)
C++/CLI
public:
UpdateResult^ UpdateToDataSourceControl(
   QueryCommand queryCommandMode,
   WebGridRow^ row,
   System.Data.DataTable^ dataTable
)

Parameters

queryCommandMode
row
dataTable

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridTable Class
WebGridTable Members


WebGridTable Class Properties

[image]
Intersoft WebGrid Documentation
WebGridTable Class Properties
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : WebGridTable Class

Glossary Item Box

For a list of all members of this type, see WebGridTable members.

Public Properties

 | Name | Description
Public Property | AllowAddNew |
Public Property | AllowColumnMove |
Public Property | AllowColumnSizing |
Public Property | AllowDelete |
Public Property | AllowEdit |
Public Property | AllowFilter |
Public Property | AllowGrouping |
Public Property | AllowMultipleSelection |
Public Property | AllowSelectColumns |
Public Property | AllowSorting |
Public Property | AutomaticFilter |
Public Property | AutomaticSort |
Public Property | ButtonStyle |
Public Property | Caption |
Public Property | CaptionImage |
Public Property | CellClickAction |
Public Property | CellPaddingDefault |
Public Property | CellSpacingDefault |
Public Property | CheckedRowStyle |
Public Property | ColumnFooters |
Public Property | ColumnHeaders |
Public Property | ColumnSetSettings |
Public Property | ColumnWidthDefault |
Public Property | DataKeyField |
Public Property | DataMember |
Public Property | FocusCellStyle |
Public Property | FooterStyle |
Public Property | GridLineColor |
Public Property | GridLines |
Public Property | GridLineStyle |
Public Property | GroupMode |
Public Property | GroupRowInfoFormatDefault |
Public Property | GroupRowInfoStyle |
Public Property | GroupTotalStyle |
Public Property | GroupTotalVisible |
Public Property | HeaderClickAction |
Public Property | HeaderStyle |
Public Property | HideColumnsWhenGrouped |
Public Property | HyperlinkStyle |
Public Property | NewRowInfoText |
Public Property | NewRowStyle |
Public Property | PreviewRowSettings |
Public Property | PreviewRowVisible |
Public Property | RowHeaders |
Public Property | RowHeaderStyle |
Public Property | RowHeaderWidth |
Public Property | RowHeightDefault |
Public Property | RowLayout |
Public Property | RowStyle |
Public Property | SelectedRowStyle |
Public Property | SelfReferencingSettings |
Public Property | SortedColumnStyle |
Public Property | TableHeaderStyle |
Public Property | TableHeaderVisible |
Public Property | TreeNodeField |
Public Property | UseValueListForFilter |
Public Property | UseValueListForSorting |
Top

See Also

Reference

WebGridTable Class
ISNet.WebUI.WebGrid Namespace


AllowAddNew Property

[image]
Intersoft WebGrid Documentation
AllowAddNew Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridTable Class : AllowAddNew Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies whether or not to allow users add new row.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property AllowAddNew As AddNew
Visual Basic (Usage) Copy Code
Dim instance As WebGridTable
Dim value As AddNew

instance.AllowAddNew = value

value = instance.AllowAddNew
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether or not to allow users add new row.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public AddNew AllowAddNew {get; set;}
Delphi
public read-write property AllowAddNew: AddNew;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Specifies whether or not to allow users add new row.")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get,set AllowAddNew : AddNew
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether or not to allow users add new row.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property AddNew get_AllowAddNew();
public: __property void set_AllowAddNew(
   AddNew value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether or not to allow users add new row.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property AddNew AllowAddNew {
   AddNew get();
   void set (    AddNew value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridTable Class
WebGridTable Members


AllowColumnMove Property

[image]
Intersoft WebGrid Documentation
AllowColumnMove Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridTable Class : AllowColumnMove Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies whether or not to allow users move columns.")>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Property AllowColumnMove As ColumnMove
Visual Basic (Usage) Copy Code
Dim instance As WebGridTable
Dim value As ColumnMove

instance.AllowColumnMove = value

value = instance.AllowColumnMove
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether or not to allow users move columns.")]
[ISNet.Serialization.XmlSerializableAttribute()]
public ColumnMove AllowColumnMove {get; set;}
Delphi
public read-write property AllowColumnMove: ColumnMove;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Specifies whether or not to allow users move columns.")
ISNet.Serialization.XmlSerializableAttribute()
public function get,set AllowColumnMove : ColumnMove
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether or not to allow users move columns.")]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property ColumnMove get_AllowColumnMove();
public: __property void set_AllowColumnMove(
   ColumnMove value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether or not to allow users move columns.")]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property ColumnMove AllowColumnMove {
   ColumnMove get();
   void set (    ColumnMove value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridTable Class
WebGridTable Members


AllowColumnSizing Property

[image]
Intersoft WebGrid Documentation
AllowColumnSizing Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridTable Class : AllowColumnSizing Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies whether or not to allow users resize column's width.")>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Property AllowColumnSizing As ColumnSizing
Visual Basic (Usage) Copy Code
Dim instance As WebGridTable
Dim value As ColumnSizing

instance.AllowColumnSizing = value

value = instance.AllowColumnSizing
C#
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether or not to allow users resize column's width.")]
[ISNet.Serialization.XmlSerializableAttribute()]
public ColumnSizing AllowColumnSizing {get; set;}
Delphi
public read-write property AllowColumnSizing: ColumnSizing;
JScript
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DescriptionAttribute("Specifies whether or not to allow users resize column's width.")
ISNet.Serialization.XmlSerializableAttribute()
public function get,set AllowColumnSizing : ColumnSizing
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether or not to allow users resize column's width.")]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property ColumnSizing get_AllowColumnSizing();
public: __property void set_AllowColumnSizing(
   ColumnSizing value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether or not to allow users resize column's width.")]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property ColumnSizing AllowColumnSizing {
   ColumnSizing get();
   void set (    ColumnSizing value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridTable Class
WebGridTable Members


AllowDelete Property

[image]
Intersoft WebGrid Documentation
AllowDelete Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridTable Class : AllowDelete Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies whether or not to allow users delete data from within WebGrid.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property AllowDelete As Delete
Visual Basic (Usage) Copy Code
Dim instance As WebGridTable
Dim value As Delete

instance.AllowDelete = value

value = instance.AllowDelete
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether or not to allow users delete data from within WebGrid.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public Delete AllowDelete {get; set;}
Delphi
public read-write property AllowDelete: Delete;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Specifies whether or not to allow users delete data from within WebGrid.")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get,set AllowDelete : Delete
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether or not to allow users delete data from within WebGrid.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property Delete get_AllowDelete();
public: __property void set_AllowDelete(
   Delete value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether or not to allow users delete data from within WebGrid.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property Delete AllowDelete {
   Delete get();
   void set (    Delete value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridTable Class
WebGridTable Members


AllowEdit Property

[image]
Intersoft WebGrid Documentation
AllowEdit Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridTable Class : AllowEdit Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies whether or not to allow users edit and modify data.")>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property AllowEdit As Edit
Visual Basic (Usage) Copy Code
Dim instance As WebGridTable
Dim value As Edit

instance.AllowEdit = value

value = instance.AllowEdit
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether or not to allow users edit and modify data.")]
[ISNet.Serialization.BinarySerializableAttribute()]
public Edit AllowEdit {get; set;}
Delphi
public read-write property AllowEdit: Edit;
JScript
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Specifies whether or not to allow users edit and modify data.")
ISNet.Serialization.BinarySerializableAttribute()
public function get,set AllowEdit : Edit
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether or not to allow users edit and modify data.")]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property Edit get_AllowEdit();
public: __property void set_AllowEdit(
   Edit value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether or not to allow users edit and modify data.")]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property Edit AllowEdit {
   Edit get();
   void set (    Edit value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridTable Class
WebGridTable Members


AllowFilter Property

[image]
Intersoft WebGrid Documentation
AllowFilter Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridTable Class : AllowFilter Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies whether or not to allow users filtering data from within WebGrid.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property AllowFilter As Filter
Visual Basic (Usage) Copy Code
Dim instance As WebGridTable
Dim value As Filter

instance.AllowFilter = value

value = instance.AllowFilter
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether or not to allow users filtering data from within WebGrid.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public Filter AllowFilter {get; set;}
Delphi
public read-write property AllowFilter: Filter;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Specifies whether or not to allow users filtering data from within WebGrid.")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get,set AllowFilter : Filter
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether or not to allow users filtering data from within WebGrid.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property Filter get_AllowFilter();
public: __property void set_AllowFilter(
   Filter value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether or not to allow users filtering data from within WebGrid.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property Filter AllowFilter {
   Filter get();
   void set (    Filter value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridTable Class
WebGridTable Members


AllowGrouping Property

[image]
Intersoft WebGrid Documentation
AllowGrouping Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridTable Class : AllowGrouping Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies whether or not to allow users group columns from within WebGrid.")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property AllowGrouping As Grouping
Visual Basic (Usage) Copy Code
Dim instance As WebGridTable
Dim value As Grouping

instance.AllowGrouping = value

value = instance.AllowGrouping
C#
[System.ComponentModel.DescriptionAttribute("Specifies whether or not to allow users group columns from within WebGrid.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public Grouping AllowGrouping {get; set;}
Delphi
public read-write property AllowGrouping: Grouping;
JScript
System.ComponentModel.DescriptionAttribute("Specifies whether or not to allow users group columns from within WebGrid.")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get,set AllowGrouping : Grouping
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies whether or not to allow users group columns from within WebGrid.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property Grouping get_AllowGrouping();
public: __property void set_AllowGrouping(
   Grouping value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies whether or not to allow users group columns from within WebGrid.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property Grouping AllowGrouping {
   Grouping get();
   void set (    Grouping value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridTable Class
WebGridTable Members


AllowMultipleSelection Property

[image]
Intersoft WebGrid Documentation
AllowMultipleSelection Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridTable Class : AllowMultipleSelection Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies whether user is allowed to perform multiple row selection for this table instance by using combination of Ctrl/Shift keys and mouse click.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Property AllowMultipleSelection As MultipleSelection
Visual Basic (Usage) Copy Code
Dim instance As WebGridTable
Dim value As MultipleSelection

instance.AllowMultipleSelection = value

value = instance.AllowMultipleSelection
C#
[System.ComponentModel.DescriptionAttribute("Specifies whether user is allowed to perform multiple row selection for this table instance by using combination of Ctrl/Shift keys and mouse click.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public MultipleSelection AllowMultipleSelection {get; set;}
Delphi
public read-write property AllowMultipleSelection: MultipleSelection;
JScript
System.ComponentModel.DescriptionAttribute("Specifies whether user is allowed to perform multiple row selection for this table instance by using combination of Ctrl/Shift keys and mouse click.")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute()
public function get,set AllowMultipleSelection : MultipleSelection
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies whether user is allowed to perform multiple row selection for this table instance by using combination of Ctrl/Shift keys and mouse click.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property MultipleSelection get_AllowMultipleSelection();
public: __property void set_AllowMultipleSelection(
   MultipleSelection value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies whether user is allowed to perform multiple row selection for this table instance by using combination of Ctrl/Shift keys and mouse click.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property MultipleSelection AllowMultipleSelection {
   MultipleSelection get();
   void set (    MultipleSelection value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridTable Class
WebGridTable Members


AllowSelectColumns Property

[image]
Intersoft WebGrid Documentation
AllowSelectColumns Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridTable Class : AllowSelectColumns Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies whether or not to allow users select columns from within WebGrid.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property AllowSelectColumns As SelectColumns
Visual Basic (Usage) Copy Code
Dim instance As WebGridTable
Dim value As SelectColumns

instance.AllowSelectColumns = value

value = instance.AllowSelectColumns
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether or not to allow users select columns from within WebGrid.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public SelectColumns AllowSelectColumns {get; set;}
Delphi
public read-write property AllowSelectColumns: SelectColumns;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Specifies whether or not to allow users select columns from within WebGrid.")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get,set AllowSelectColumns : SelectColumns
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether or not to allow users select columns from within WebGrid.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property SelectColumns get_AllowSelectColumns();
public: __property void set_AllowSelectColumns(
   SelectColumns value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether or not to allow users select columns from within WebGrid.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property SelectColumns AllowSelectColumns {
   SelectColumns get();
   void set (    SelectColumns value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridTable Class
WebGridTable Members


AllowSorting Property

[image]
Intersoft WebGrid Documentation
AllowSorting Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridTable Class : AllowSorting Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies whether or not to allow users sort columns from within WebGrid.")>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Property AllowSorting As Sorting
Visual Basic (Usage) Copy Code
Dim instance As WebGridTable
Dim value As Sorting

instance.AllowSorting = value

value = instance.AllowSorting
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether or not to allow users sort columns from within WebGrid.")]
[ISNet.Serialization.XmlSerializableAttribute()]
public Sorting AllowSorting {get; set;}
Delphi
public read-write property AllowSorting: Sorting;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Specifies whether or not to allow users sort columns from within WebGrid.")
ISNet.Serialization.XmlSerializableAttribute()
public function get,set AllowSorting : Sorting
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether or not to allow users sort columns from within WebGrid.")]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property Sorting get_AllowSorting();
public: __property void set_AllowSorting(
   Sorting value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether or not to allow users sort columns from within WebGrid.")]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property Sorting AllowSorting {
   Sorting get();
   void set (    Sorting value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridTable Class
WebGridTable Members


AutomaticFilter Property

[image]
Intersoft WebGrid Documentation
AutomaticFilter Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridTable Class : AutomaticFilter Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies whether or not to allow WebGrid automatically handle filtering operation.")>
Public Property AutomaticFilter As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebGridTable
Dim value As System.Boolean

instance.AutomaticFilter = value

value = instance.AutomaticFilter
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether or not to allow WebGrid automatically handle filtering operation.")]
public System.bool AutomaticFilter {get; set;}
Delphi
public read-write property AutomaticFilter: System.Boolean;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Specifies whether or not to allow WebGrid automatically handle filtering operation.")
public function get,set AutomaticFilter : System.boolean
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether or not to allow WebGrid automatically handle filtering operation.")]
public: __property System.bool get_AutomaticFilter();
public: __property void set_AutomaticFilter(
   System.bool value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether or not to allow WebGrid automatically handle filtering operation.")]
public:
property System.bool AutomaticFilter {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridTable Class
WebGridTable Members


AutomaticSort Property

[image]
Intersoft WebGrid Documentation
AutomaticSort Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridTable Class : AutomaticSort Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies whether or not to allow WebGrid automatically handle sorting operation.")>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property AutomaticSort As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebGridTable
Dim value As System.Boolean

instance.AutomaticSort = value

value = instance.AutomaticSort
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether or not to allow WebGrid automatically handle sorting operation.")]
[ISNet.Serialization.BinarySerializableAttribute()]
public System.bool AutomaticSort {get; set;}
Delphi
public read-write property AutomaticSort: System.Boolean;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Specifies whether or not to allow WebGrid automatically handle sorting operation.")
ISNet.Serialization.BinarySerializableAttribute()
public function get,set AutomaticSort : System.boolean
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether or not to allow WebGrid automatically handle sorting operation.")]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.bool get_AutomaticSort();
public: __property void set_AutomaticSort(
   System.bool value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether or not to allow WebGrid automatically handle sorting operation.")]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.bool AutomaticSort {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridTable Class
WebGridTable Members


ButtonStyle Property

[image]
Intersoft WebGrid Documentation
ButtonStyle Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridTable Class : ButtonStyle Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("The style of button object of Button Column.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property ButtonStyle As WebGridFormatStyle
Visual Basic (Usage) Copy Code
Dim instance As WebGridTable
Dim value As WebGridFormatStyle

instance.ButtonStyle = value

value = instance.ButtonStyle
C#
[System.ComponentModel.DescriptionAttribute("The style of button object of Button Column.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.Serialization.BinarySerializableAttribute()]
public WebGridFormatStyle ButtonStyle {get; set;}
Delphi
public read-write property ButtonStyle: WebGridFormatStyle;
JScript
System.ComponentModel.DescriptionAttribute("The style of button object of Button Column.")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
ISNet.Serialization.BinarySerializableAttribute()
public function get,set ButtonStyle : WebGridFormatStyle
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("The style of button object of Button Column.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property WebGridFormatStyle* get_ButtonStyle();
public: __property void set_ButtonStyle(
   WebGridFormatStyle* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("The style of button object of Button Column.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property WebGridFormatStyle^ ButtonStyle {
   WebGridFormatStyle^ get();
   void set (    WebGridFormatStyle^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridTable Class
WebGridTable Members


Caption Property

[image]
Intersoft WebGrid Documentation
Caption Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridTable Class : Caption Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Gets or sets the text displayed in the table header.")>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property Caption As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebGridTable
Dim value As System.String

instance.Caption = value

value = instance.Caption
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the text displayed in the table header.")]
[ISNet.Serialization.BinarySerializableAttribute()]
public System.string Caption {get; set;}
Delphi
public read-write property Caption: System.String;
JScript
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the text displayed in the table header.")
ISNet.Serialization.BinarySerializableAttribute()
public function get,set Caption : System.String
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the text displayed in the table header.")]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.string* get_Caption();
public: __property void set_Caption(
   System.string* value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the text displayed in the table header.")]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.String^ Caption {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridTable Class
WebGridTable Members


CaptionImage Property

[image]
Intersoft WebGrid Documentation
CaptionImage Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridTable Class : CaptionImage Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Gets or sets the image that will be displayed in the table header, before Caption.")>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Property CaptionImage As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebGridTable
Dim value As System.String

instance.CaptionImage = value

value = instance.CaptionImage
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the image that will be displayed in the table header, before Caption.")]
[ISNet.Serialization.XmlSerializableAttribute()]
public System.string CaptionImage {get; set;}
Delphi
public read-write property CaptionImage: System.String;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the image that will be displayed in the table header, before Caption.")
ISNet.Serialization.XmlSerializableAttribute()
public function get,set CaptionImage : System.String
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the image that will be displayed in the table header, before Caption.")]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property System.string* get_CaptionImage();
public: __property void set_CaptionImage(
   System.string* value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the image that will be displayed in the table header, before Caption.")]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property System.String^ CaptionImage {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridTable Class
WebGridTable Members


CellClickAction Property

[image]
Intersoft WebGrid Documentation
CellClickAction Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridTable Class : CellClickAction Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies the action when users click on a cell.")>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property CellClickAction As CellClick
Visual Basic (Usage) Copy Code
Dim instance As WebGridTable
Dim value As CellClick

instance.CellClickAction = value

value = instance.CellClickAction
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the action when users click on a cell.")]
[ISNet.Serialization.BinarySerializableAttribute()]
public CellClick CellClickAction {get; set;}
Delphi
public read-write property CellClickAction: CellClick;
JScript
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the action when users click on a cell.")
ISNet.Serialization.BinarySerializableAttribute()
public function get,set CellClickAction : CellClick
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the action when users click on a cell.")]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property CellClick get_CellClickAction();
public: __property void set_CellClickAction(
   CellClick value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the action when users click on a cell.")]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property CellClick CellClickAction {
   CellClick get();
   void set (    CellClick value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridTable Class
WebGridTable Members


CellPaddingDefault Property

[image]
Intersoft WebGrid Documentation
CellPaddingDefault Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridTable Class : CellPaddingDefault Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies the default cell padding that controls the Table cell's padding.")>
Public Property CellPaddingDefault As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebGridTable
Dim value As System.Integer

instance.CellPaddingDefault = value

value = instance.CellPaddingDefault
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the default cell padding that controls the Table cell's padding.")]
public System.int CellPaddingDefault {get; set;}
Delphi
public read-write property CellPaddingDefault: System.Integer;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the default cell padding that controls the Table cell's padding.")
public function get,set CellPaddingDefault : System.int
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the default cell padding that controls the Table cell's padding.")]
public: __property System.int get_CellPaddingDefault();
public: __property void set_CellPaddingDefault(
   System.int value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the default cell padding that controls the Table cell's padding.")]
public:
property System.int CellPaddingDefault {
   System.int get();
   void set (    System.int value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridTable Class
WebGridTable Members


CellSpacingDefault Property

[image]
Intersoft WebGrid Documentation
CellSpacingDefault Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridTable Class : CellSpacingDefault Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies the default cell spacing that controls the Table cell's spacing.")>
Public Property CellSpacingDefault As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebGridTable
Dim value As System.Integer

instance.CellSpacingDefault = value

value = instance.CellSpacingDefault
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the default cell spacing that controls the Table cell's spacing.")]
public System.int CellSpacingDefault {get; set;}
Delphi
public read-write property CellSpacingDefault: System.Integer;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the default cell spacing that controls the Table cell's spacing.")
public function get,set CellSpacingDefault : System.int
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the default cell spacing that controls the Table cell's spacing.")]
public: __property System.int get_CellSpacingDefault();
public: __property void set_CellSpacingDefault(
   System.int value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the default cell spacing that controls the Table cell's spacing.")]
public:
property System.int CellSpacingDefault {
   System.int get();
   void set (    System.int value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridTable Class
WebGridTable Members


CheckedRowStyle Property

[image]
Intersoft WebGrid Documentation
CheckedRowStyle Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridTable Class : CheckedRowStyle Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute()>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
Public Property CheckedRowStyle As WebGridFormatStyle
Visual Basic (Usage) Copy Code
Dim instance As WebGridTable
Dim value As WebGridFormatStyle

instance.CheckedRowStyle = value

value = instance.CheckedRowStyle
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
public WebGridFormatStyle CheckedRowStyle {get; set;}
Delphi
public read-write property CheckedRowStyle: WebGridFormatStyle;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute()
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
public function get,set CheckedRowStyle : WebGridFormatStyle
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
public: __property WebGridFormatStyle* get_CheckedRowStyle();
public: __property void set_CheckedRowStyle(
   WebGridFormatStyle* value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
public:
property WebGridFormatStyle^ CheckedRowStyle {
   WebGridFormatStyle^ get();
   void set (    WebGridFormatStyle^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridTable Class
WebGridTable Members


ColumnFooters Property

[image]
Intersoft WebGrid Documentation
ColumnFooters Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridTable Class : ColumnFooters Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies whether or not to display column footers.")>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property ColumnFooters As ColumnVisibility
Visual Basic (Usage) Copy Code
Dim instance As WebGridTable
Dim value As ColumnVisibility

instance.ColumnFooters = value

value = instance.ColumnFooters
C#
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether or not to display column footers.")]
[ISNet.Serialization.BinarySerializableAttribute()]
public ColumnVisibility ColumnFooters {get; set;}
Delphi
public read-write property ColumnFooters: ColumnVisibility;
JScript
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DescriptionAttribute("Specifies whether or not to display column footers.")
ISNet.Serialization.BinarySerializableAttribute()
public function get,set ColumnFooters : ColumnVisibility
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether or not to display column footers.")]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property ColumnVisibility get_ColumnFooters();
public: __property void set_ColumnFooters(
   ColumnVisibility value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether or not to display column footers.")]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property ColumnVisibility ColumnFooters {
   ColumnVisibility get();
   void set (    ColumnVisibility value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridTable Class
WebGridTable Members


ColumnHeaders Property

[image]
Intersoft WebGrid Documentation
ColumnHeaders Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridTable Class : ColumnHeaders Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Specifies whether or not to display column headers.")>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Property ColumnHeaders As ColumnVisibility
Visual Basic (Usage) Copy Code
Dim instance As WebGridTable
Dim value As ColumnVisibility

instance.ColumnHeaders = value

value = instance.ColumnHeaders
C#
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies whether or not to display column headers.")]
[ISNet.Serialization.XmlSerializableAttribute()]
public ColumnVisibility ColumnHeaders {get; set;}
Delphi
public read-write property ColumnHeaders: ColumnVisibility;
JScript
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Specifies whether or not to display column headers.")
ISNet.Serialization.XmlSerializableAttribute()
public function get,set ColumnHeaders : ColumnVisibility
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies whether or not to display column headers.")]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property ColumnVisibility get_ColumnHeaders();
public: __property void set_ColumnHeaders(
   ColumnVisibility value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies whether or not to display column headers.")]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property ColumnVisibility ColumnHeaders {
   ColumnVisibility get();
   void set (    ColumnVisibility value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridTable Class
WebGridTable Members


ColumnSetSettings Property

[image]
Intersoft WebGrid Documentation
ColumnSetSettings Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridTable Class : ColumnSetSettings Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute()>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Visible)>
<ISNet.Serialization.XmlSerializableAttribute(True)>
Public Property ColumnSetSettings As ColumnSetSettings
Visual Basic (Usage) Copy Code
Dim instance As WebGridTable
Dim value As ColumnSetSettings

instance.ColumnSetSettings = value

value = instance.ColumnSetSettings
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Visible)]
[ISNet.Serialization.XmlSerializableAttribute(true)]
public ColumnSetSettings ColumnSetSettings {get; set;}
Delphi
public read-write property ColumnSetSettings: ColumnSetSettings;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute()
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Visible)
ISNet.Serialization.XmlSerializableAttribute()
public function get,set ColumnSetSettings : ColumnSetSettings
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Visible)]
[ISNet.Serialization.XmlSerializableAttribute(true)]
public: __property ColumnSetSettings* get_ColumnSetSettings();
public: __property void set_ColumnSetSettings(
   ColumnSetSettings* value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Visible)]
[ISNet.Serialization.XmlSerializableAttribute(true)]
public:
property ColumnSetSettings^ ColumnSetSettings {
   ColumnSetSettings^ get();
   void set (    ColumnSetSettings^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridTable Class
WebGridTable Members


ColumnWidthDefault Property

[image]
Intersoft WebGrid Documentation
ColumnWidthDefault Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridTable Class : ColumnWidthDefault Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Specifies the default column's width in Unit.")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property ColumnWidthDefault As System.Web.UI.WebControls.Unit
Visual Basic (Usage) Copy Code
Dim instance As WebGridTable
Dim value As System.Web.UI.WebControls.Unit

instance.ColumnWidthDefault = value

value = instance.ColumnWidthDefault
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the default column's width in Unit.")]
[System.ComponentModel.DefaultValueAttribute()]
public System.Web.UI.WebControls.Unit ColumnWidthDefault {get; set;}
Delphi
public read-write property ColumnWidthDefault: System.Web.UI.WebControls.Unit;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the default column's width in Unit.")
System.ComponentModel.DefaultValueAttribute()
public function get,set ColumnWidthDefault : System.Web.UI.WebControls.Unit
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the default column's width in Unit.")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.Web.UI.WebControls.Unit get_ColumnWidthDefault();
public: __property void set_ColumnWidthDefault(
   System.Web.UI.WebControls.Unit value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the default column's width in Unit.")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.Web.UI.WebControls.Unit ColumnWidthDefault {
   System.Web.UI.WebControls.Unit get();
   void set (    System.Web.UI.WebControls.Unit value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridTable Class
WebGridTable Members


DataKeyField Property

[image]
Intersoft WebGrid Documentation
DataKeyField Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridTable Class : DataKeyField Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Gets or sets the key field in the data source specified by the DataSource property and DataMember specified in the WebGridTable object.")>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebGrid.DataFieldEditor, ISNet.WebUI.WebGrid, Version=9.0.7200.1, Culture=neutral, PublicKeyToken=3e60b85fb8502d5e")>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property DataKeyField As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebGridTable
Dim value As System.String

instance.DataKeyField = value

value = instance.DataKeyField
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the key field in the data source specified by the DataSource property and DataMember specified in the WebGridTable object.")]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebGrid.DataFieldEditor, ISNet.WebUI.WebGrid, Version=9.0.7200.1, Culture=neutral, PublicKeyToken=3e60b85fb8502d5e")]
[ISNet.Serialization.BinarySerializableAttribute()]
public System.string DataKeyField {get; set;}
Delphi
public read-write property DataKeyField: System.String;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the key field in the data source specified by the DataSource property and DataMember specified in the WebGridTable object.")
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebGrid.DataFieldEditor, ISNet.WebUI.WebGrid, Version=9.0.7200.1, Culture=neutral, PublicKeyToken=3e60b85fb8502d5e")
ISNet.Serialization.BinarySerializableAttribute()
public function get,set DataKeyField : System.String
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the key field in the data source specified by the DataSource property and DataMember specified in the WebGridTable object.")]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebGrid.DataFieldEditor, ISNet.WebUI.WebGrid, Version=9.0.7200.1, Culture=neutral, PublicKeyToken=3e60b85fb8502d5e")]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.string* get_DataKeyField();
public: __property void set_DataKeyField(
   System.string* value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the key field in the data source specified by the DataSource property and DataMember specified in the WebGridTable object.")]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebGrid.DataFieldEditor, ISNet.WebUI.WebGrid, Version=9.0.7200.1, Culture=neutral, PublicKeyToken=3e60b85fb8502d5e")]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.String^ DataKeyField {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridTable Class
WebGridTable Members


DataMember Property

[image]
Intersoft WebGrid Documentation
DataMember Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridTable Class : DataMember Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Gets or sets the name of data source for which the table displays its data.")>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property DataMember As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebGridTable
Dim value As System.String

instance.DataMember = value

value = instance.DataMember
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the name of data source for which the table displays its data.")]
[ISNet.Serialization.BinarySerializableAttribute()]
public System.string DataMember {get; set;}
Delphi
public read-write property DataMember: System.String;
JScript
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the name of data source for which the table displays its data.")
ISNet.Serialization.BinarySerializableAttribute()
public function get,set DataMember : System.String
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the name of data source for which the table displays its data.")]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.string* get_DataMember();
public: __property void set_DataMember(
   System.string* value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the name of data source for which the table displays its data.")]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.String^ DataMember {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridTable Class
WebGridTable Members


FocusCellStyle Property

[image]
Intersoft WebGrid Documentation
FocusCellStyle Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridTable Class : FocusCellStyle Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Gets or sets the style used when a row or cell is focused/selected.")>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property FocusCellStyle As FocusStyle
Visual Basic (Usage) Copy Code
Dim instance As WebGridTable
Dim value As FocusStyle

instance.FocusCellStyle = value

value = instance.FocusCellStyle
C#
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the style used when a row or cell is focused/selected.")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public FocusStyle FocusCellStyle {get; set;}
Delphi
public read-write property FocusCellStyle: FocusStyle;
JScript
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the style used when a row or cell is focused/selected.")
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get,set FocusCellStyle : FocusStyle
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the style used when a row or cell is focused/selected.")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property FocusStyle* get_FocusCellStyle();
public: __property void set_FocusCellStyle(
   FocusStyle* value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the style used when a row or cell is focused/selected.")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property FocusStyle^ FocusCellStyle {
   FocusStyle^ get();
   void set (    FocusStyle^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridTable Class
WebGridTable Members


FooterStyle Property

[image]
Intersoft WebGrid Documentation
FooterStyle Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridTable Class : FooterStyle Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Gets or sets the style applied to the footer row.")>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property FooterStyle As WebGridFormatStyle
Visual Basic (Usage) Copy Code
Dim instance As WebGridTable
Dim value As WebGridFormatStyle

instance.FooterStyle = value

value = instance.FooterStyle
C#
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the style applied to the footer row.")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
public WebGridFormatStyle FooterStyle {get; set;}
Delphi
public read-write property FooterStyle: WebGridFormatStyle;
JScript
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the style applied to the footer row.")
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get,set FooterStyle : WebGridFormatStyle
Managed Extensions for C++
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the style applied to the footer row.")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property WebGridFormatStyle* get_FooterStyle();
public: __property void set_FooterStyle(
   WebGridFormatStyle* value
);
C++/CLI
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the style applied to the footer row.")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property WebGridFormatStyle^ FooterStyle {
   WebGridFormatStyle^ get();
   void set (    WebGridFormatStyle^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridTable Class
WebGridTable Members


GridLineColor Property

[image]
Intersoft WebGrid Documentation
GridLineColor Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridTable Class : GridLineColor Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Specifies the gridline's color.")>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property GridLineColor As System.Drawing.Color
Visual Basic (Usage) Copy Code
Dim instance As WebGridTable
Dim value As System.Drawing.Color

instance.GridLineColor = value

value = instance.GridLineColor
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the gridline's color.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public System.Drawing.Color GridLineColor {get; set;}
Delphi
public read-write property GridLineColor: System.Drawing.Color;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the gridline's color.")
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get,set GridLineColor : System.Drawing.Color
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the gridline's color.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.Drawing.Color get_GridLineColor();
public: __property void set_GridLineColor(
   System.Drawing.Color value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the gridline's color.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.Drawing.Color GridLineColor {
   System.Drawing.Color get();
   void set (    System.Drawing.Color value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridTable Class
WebGridTable Members


GridLines Property

[image]
Intersoft WebGrid Documentation
GridLines Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridTable Class : GridLines Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies the appearance of Table's GridLines that will separate between rows and cells.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property GridLines As GridLines
Visual Basic (Usage) Copy Code
Dim instance As WebGridTable
Dim value As GridLines

instance.GridLines = value

value = instance.GridLines
C#
[System.ComponentModel.DescriptionAttribute("Specifies the appearance of Table's GridLines that will separate between rows and cells.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public GridLines GridLines {get; set;}
Delphi
public read-write property GridLines: GridLines;
JScript
System.ComponentModel.DescriptionAttribute("Specifies the appearance of Table's GridLines that will separate between rows and cells.")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get,set GridLines : GridLines
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies the appearance of Table's GridLines that will separate between rows and cells.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property GridLines get_GridLines();
public: __property void set_GridLines(
   GridLines value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies the appearance of Table's GridLines that will separate between rows and cells.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property GridLines GridLines {
   GridLines get();
   void set (    GridLines value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridTable Class
WebGridTable Members


GridLineStyle Property

[image]
Intersoft WebGrid Documentation
GridLineStyle Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridTable Class : GridLineStyle Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies the gridline's style.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property GridLineStyle As System.Web.UI.WebControls.BorderStyle
Visual Basic (Usage) Copy Code
Dim instance As WebGridTable
Dim value As System.Web.UI.WebControls.BorderStyle

instance.GridLineStyle = value

value = instance.GridLineStyle
C#
[System.ComponentModel.DescriptionAttribute("Specifies the gridline's style.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public System.Web.UI.WebControls.BorderStyle GridLineStyle {get; set;}
Delphi
public read-write property GridLineStyle: System.Web.UI.WebControls.BorderStyle;
JScript
System.ComponentModel.DescriptionAttribute("Specifies the gridline's style.")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get,set GridLineStyle : System.Web.UI.WebControls.BorderStyle
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies the gridline's style.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.Web.UI.WebControls.BorderStyle get_GridLineStyle();
public: __property void set_GridLineStyle(
   System.Web.UI.WebControls.BorderStyle value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies the gridline's style.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.Web.UI.WebControls.BorderStyle GridLineStyle {
   System.Web.UI.WebControls.BorderStyle get();
   void set (    System.Web.UI.WebControls.BorderStyle value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridTable Class
WebGridTable Members


GroupMode Property

[image]
Intersoft WebGrid Documentation
GroupMode Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridTable Class : GroupMode Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Gets or sets a value indicating whether groups should be collapsed or expanded when groups are calculated.")>
Public Property GroupMode As GroupMode
Visual Basic (Usage) Copy Code
Dim instance As WebGridTable
Dim value As GroupMode

instance.GroupMode = value

value = instance.GroupMode
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets a value indicating whether groups should be collapsed or expanded when groups are calculated.")]
public GroupMode GroupMode {get; set;}
Delphi
public read-write property GroupMode: GroupMode;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets a value indicating whether groups should be collapsed or expanded when groups are calculated.")
public function get,set GroupMode : GroupMode
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets a value indicating whether groups should be collapsed or expanded when groups are calculated.")]
public: __property GroupMode get_GroupMode();
public: __property void set_GroupMode(
   GroupMode value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets a value indicating whether groups should be collapsed or expanded when groups are calculated.")]
public:
property GroupMode GroupMode {
   GroupMode get();
   void set (    GroupMode value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridTable Class
WebGridTable Members


GroupRowInfoFormatDefault Property

[image]
Intersoft WebGrid Documentation
GroupRowInfoFormatDefault Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridTable Class : GroupRowInfoFormatDefault Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Gets or sets the default group row's format string.")>
Public Property GroupRowInfoFormatDefault As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebGridTable
Dim value As System.String

instance.GroupRowInfoFormatDefault = value

value = instance.GroupRowInfoFormatDefault
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the default group row's format string.")]
public System.string GroupRowInfoFormatDefault {get; set;}
Delphi
public read-write property GroupRowInfoFormatDefault: System.String;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the default group row's format string.")
public function get,set GroupRowInfoFormatDefault : System.String
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the default group row's format string.")]
public: __property System.string* get_GroupRowInfoFormatDefault();
public: __property void set_GroupRowInfoFormatDefault(
   System.string* value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the default group row's format string.")]
public:
property System.String^ GroupRowInfoFormatDefault {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridTable Class
WebGridTable Members


GroupRowInfoStyle Property

[image]
Intersoft WebGrid Documentation
GroupRowInfoStyle Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridTable Class : GroupRowInfoStyle Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Gets or sets the style for GroupRow.")>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
Public Property GroupRowInfoStyle As WebGridFormatStyle
Visual Basic (Usage) Copy Code
Dim instance As WebGridTable
Dim value As WebGridFormatStyle

instance.GroupRowInfoStyle = value

value = instance.GroupRowInfoStyle
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the style for GroupRow.")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
public WebGridFormatStyle GroupRowInfoStyle {get; set;}
Delphi
public read-write property GroupRowInfoStyle: WebGridFormatStyle;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the style for GroupRow.")
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
public function get,set GroupRowInfoStyle : WebGridFormatStyle
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the style for GroupRow.")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
public: __property WebGridFormatStyle* get_GroupRowInfoStyle();
public: __property void set_GroupRowInfoStyle(
   WebGridFormatStyle* value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the style for GroupRow.")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
public:
property WebGridFormatStyle^ GroupRowInfoStyle {
   WebGridFormatStyle^ get();
   void set (    WebGridFormatStyle^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridTable Class
WebGridTable Members


GroupTotalStyle Property

[image]
Intersoft WebGrid Documentation
GroupTotalStyle Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridTable Class : GroupTotalStyle Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Gets or sets the style applied to group total row.")>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
Public Property GroupTotalStyle As WebGridFormatStyle
Visual Basic (Usage) Copy Code
Dim instance As WebGridTable
Dim value As WebGridFormatStyle

instance.GroupTotalStyle = value

value = instance.GroupTotalStyle
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the style applied to group total row.")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
public WebGridFormatStyle GroupTotalStyle {get; set;}
Delphi
public read-write property GroupTotalStyle: WebGridFormatStyle;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the style applied to group total row.")
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
public function get,set GroupTotalStyle : WebGridFormatStyle
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the style applied to group total row.")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
public: __property WebGridFormatStyle* get_GroupTotalStyle();
public: __property void set_GroupTotalStyle(
   WebGridFormatStyle* value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the style applied to group total row.")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
public:
property WebGridFormatStyle^ GroupTotalStyle {
   WebGridFormatStyle^ get();
   void set (    WebGridFormatStyle^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridTable Class
WebGridTable Members


GroupTotalVisible Property

[image]
Intersoft WebGrid Documentation
GroupTotalVisible Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridTable Class : GroupTotalVisible Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Determines whether total row for each GroupRow is shown.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Property GroupTotalVisible As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebGridTable
Dim value As System.Boolean

instance.GroupTotalVisible = value

value = instance.GroupTotalVisible
C#
[System.ComponentModel.DescriptionAttribute("Determines whether total row for each GroupRow is shown.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public System.bool GroupTotalVisible {get; set;}
Delphi
public read-write property GroupTotalVisible: System.Boolean;
JScript
System.ComponentModel.DescriptionAttribute("Determines whether total row for each GroupRow is shown.")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute()
public function get,set GroupTotalVisible : System.boolean
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Determines whether total row for each GroupRow is shown.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property System.bool get_GroupTotalVisible();
public: __property void set_GroupTotalVisible(
   System.bool value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Determines whether total row for each GroupRow is shown.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property System.bool GroupTotalVisible {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridTable Class
WebGridTable Members


HeaderClickAction Property

[image]
Intersoft WebGrid Documentation
HeaderClickAction Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridTable Class : HeaderClickAction Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies the action when users click on column's header.")>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Property HeaderClickAction As HeaderClick
Visual Basic (Usage) Copy Code
Dim instance As WebGridTable
Dim value As HeaderClick

instance.HeaderClickAction = value

value = instance.HeaderClickAction
C#
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the action when users click on column's header.")]
[ISNet.Serialization.XmlSerializableAttribute()]
public HeaderClick HeaderClickAction {get; set;}
Delphi
public read-write property HeaderClickAction: HeaderClick;
JScript
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the action when users click on column's header.")
ISNet.Serialization.XmlSerializableAttribute()
public function get,set HeaderClickAction : HeaderClick
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the action when users click on column's header.")]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property HeaderClick get_HeaderClickAction();
public: __property void set_HeaderClickAction(
   HeaderClick value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the action when users click on column's header.")]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property HeaderClick HeaderClickAction {
   HeaderClick get();
   void set (    HeaderClick value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridTable Class
WebGridTable Members


HeaderStyle Property

[image]
Intersoft WebGrid Documentation
HeaderStyle Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridTable Class : HeaderStyle Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Gets or sets the style applied to the row.")>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property HeaderStyle As WebGridFormatStyle
Visual Basic (Usage) Copy Code
Dim instance As WebGridTable
Dim value As WebGridFormatStyle

instance.HeaderStyle = value

value = instance.HeaderStyle
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the style applied to the row.")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.Serialization.BinarySerializableAttribute()]
public WebGridFormatStyle HeaderStyle {get; set;}
Delphi
public read-write property HeaderStyle: WebGridFormatStyle;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the style applied to the row.")
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
ISNet.Serialization.BinarySerializableAttribute()
public function get,set HeaderStyle : WebGridFormatStyle
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the style applied to the row.")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property WebGridFormatStyle* get_HeaderStyle();
public: __property void set_HeaderStyle(
   WebGridFormatStyle* value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the style applied to the row.")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property WebGridFormatStyle^ HeaderStyle {
   WebGridFormatStyle^ get();
   void set (    WebGridFormatStyle^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridTable Class
WebGridTable Members


HideColumnsWhenGrouped Property

[image]
Intersoft WebGrid Documentation
HideColumnsWhenGrouped Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridTable Class : HideColumnsWhenGrouped Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies whether the column headers of grouped columns is hidden.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property HideColumnsWhenGrouped As HideColumns
Visual Basic (Usage) Copy Code
Dim instance As WebGridTable
Dim value As HideColumns

instance.HideColumnsWhenGrouped = value

value = instance.HideColumnsWhenGrouped
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether the column headers of grouped columns is hidden.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
public HideColumns HideColumnsWhenGrouped {get; set;}
Delphi
public read-write property HideColumnsWhenGrouped: HideColumns;
JScript
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Specifies whether the column headers of grouped columns is hidden.")
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get,set HideColumnsWhenGrouped : HideColumns
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether the column headers of grouped columns is hidden.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property HideColumns get_HideColumnsWhenGrouped();
public: __property void set_HideColumnsWhenGrouped(
   HideColumns value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether the column headers of grouped columns is hidden.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property HideColumns HideColumnsWhenGrouped {
   HideColumns get();
   void set (    HideColumns value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridTable Class
WebGridTable Members


HyperlinkStyle Property

[image]
Intersoft WebGrid Documentation
HyperlinkStyle Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridTable Class : HyperlinkStyle Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute()>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
Public Property HyperlinkStyle As WebGridFormatStyle
Visual Basic (Usage) Copy Code
Dim instance As WebGridTable
Dim value As WebGridFormatStyle

instance.HyperlinkStyle = value

value = instance.HyperlinkStyle
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
public WebGridFormatStyle HyperlinkStyle {get; set;}
Delphi
public read-write property HyperlinkStyle: WebGridFormatStyle;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute()
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
public function get,set HyperlinkStyle : WebGridFormatStyle
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
public: __property WebGridFormatStyle* get_HyperlinkStyle();
public: __property void set_HyperlinkStyle(
   WebGridFormatStyle* value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
public:
property WebGridFormatStyle^ HyperlinkStyle {
   WebGridFormatStyle^ get();
   void set (    WebGridFormatStyle^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridTable Class
WebGridTable Members


NewRowInfoText Property

[image]
Intersoft WebGrid Documentation
NewRowInfoText Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridTable Class : NewRowInfoText Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Gets or sets the text that will be displayed in new row when new row isn't focused.")>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Property NewRowInfoText As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebGridTable
Dim value As System.String

instance.NewRowInfoText = value

value = instance.NewRowInfoText
C#
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the text that will be displayed in new row when new row isn't focused.")]
[ISNet.Serialization.XmlSerializableAttribute()]
public System.string NewRowInfoText {get; set;}
Delphi
public read-write property NewRowInfoText: System.String;
JScript
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the text that will be displayed in new row when new row isn't focused.")
ISNet.Serialization.XmlSerializableAttribute()
public function get,set NewRowInfoText : System.String
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the text that will be displayed in new row when new row isn't focused.")]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property System.string* get_NewRowInfoText();
public: __property void set_NewRowInfoText(
   System.string* value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the text that will be displayed in new row when new row isn't focused.")]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property System.String^ NewRowInfoText {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridTable Class
WebGridTable Members


NewRowStyle Property

[image]
Intersoft WebGrid Documentation
NewRowStyle Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridTable Class : NewRowStyle Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("The style applied to new row.")>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property NewRowStyle As WebGridFormatStyle
Visual Basic (Usage) Copy Code
Dim instance As WebGridTable
Dim value As WebGridFormatStyle

instance.NewRowStyle = value

value = instance.NewRowStyle
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("The style applied to new row.")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.Serialization.BinarySerializableAttribute()]
public WebGridFormatStyle NewRowStyle {get; set;}
Delphi
public read-write property NewRowStyle: WebGridFormatStyle;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("The style applied to new row.")
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
ISNet.Serialization.BinarySerializableAttribute()
public function get,set NewRowStyle : WebGridFormatStyle
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("The style applied to new row.")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property WebGridFormatStyle* get_NewRowStyle();
public: __property void set_NewRowStyle(
   WebGridFormatStyle* value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("The style applied to new row.")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property WebGridFormatStyle^ NewRowStyle {
   WebGridFormatStyle^ get();
   void set (    WebGridFormatStyle^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridTable Class
WebGridTable Members


PreviewRowSettings Property

[image]
Intersoft WebGrid Documentation
PreviewRowSettings Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridTable Class : PreviewRowSettings Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute()>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Visible)>
<ISNet.Serialization.XmlSerializableAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property PreviewRowSettings As PreviewRowSettings
Visual Basic (Usage) Copy Code
Dim instance As WebGridTable
Dim value As PreviewRowSettings

instance.PreviewRowSettings = value

value = instance.PreviewRowSettings
C#
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Visible)]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
public PreviewRowSettings PreviewRowSettings {get; set;}
Delphi
public read-write property PreviewRowSettings: PreviewRowSettings;
JScript
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute()
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Visible)
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get,set PreviewRowSettings : PreviewRowSettings
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Visible)]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property PreviewRowSettings* get_PreviewRowSettings();
public: __property void set_PreviewRowSettings(
   PreviewRowSettings* value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Visible)]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property PreviewRowSettings^ PreviewRowSettings {
   PreviewRowSettings^ get();
   void set (    PreviewRowSettings^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridTable Class
WebGridTable Members


PreviewRowVisible Property

[image]
Intersoft WebGrid Documentation
PreviewRowVisible Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridTable Class : PreviewRowVisible Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property PreviewRowVisible As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebGridTable
Dim value As System.Boolean

instance.PreviewRowVisible = value

value = instance.PreviewRowVisible
C#
[System.ComponentModel.DescriptionAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public System.bool PreviewRowVisible {get; set;}
Delphi
public read-write property PreviewRowVisible: System.Boolean;
JScript
System.ComponentModel.DescriptionAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get,set PreviewRowVisible : System.boolean
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.bool get_PreviewRowVisible();
public: __property void set_PreviewRowVisible(
   System.bool value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.bool PreviewRowVisible {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridTable Class
WebGridTable Members


RowHeaders Property

[image]
Intersoft WebGrid Documentation
RowHeaders Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridTable Class : RowHeaders Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies whether or not to display row's header.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property RowHeaders As RowHeaders
Visual Basic (Usage) Copy Code
Dim instance As WebGridTable
Dim value As RowHeaders

instance.RowHeaders = value

value = instance.RowHeaders
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether or not to display row's header.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
public RowHeaders RowHeaders {get; set;}
Delphi
public read-write property RowHeaders: RowHeaders;
JScript
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Specifies whether or not to display row's header.")
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get,set RowHeaders : RowHeaders
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether or not to display row's header.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property RowHeaders get_RowHeaders();
public: __property void set_RowHeaders(
   RowHeaders value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether or not to display row's header.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property RowHeaders RowHeaders {
   RowHeaders get();
   void set (    RowHeaders value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridTable Class
WebGridTable Members


RowHeaderStyle Property

[image]
Intersoft WebGrid Documentation
RowHeaderStyle Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridTable Class : RowHeaderStyle Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
Public Property RowHeaderStyle As WebGridFormatStyle
Visual Basic (Usage) Copy Code
Dim instance As WebGridTable
Dim value As WebGridFormatStyle

instance.RowHeaderStyle = value

value = instance.RowHeaderStyle
C#
[System.ComponentModel.DescriptionAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
public WebGridFormatStyle RowHeaderStyle {get; set;}
Delphi
public read-write property RowHeaderStyle: WebGridFormatStyle;
JScript
System.ComponentModel.DescriptionAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
public function get,set RowHeaderStyle : WebGridFormatStyle
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
public: __property WebGridFormatStyle* get_RowHeaderStyle();
public: __property void set_RowHeaderStyle(
   WebGridFormatStyle* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
public:
property WebGridFormatStyle^ RowHeaderStyle {
   WebGridFormatStyle^ get();
   void set (    WebGridFormatStyle^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridTable Class
WebGridTable Members


RowHeaderWidth Property

[image]
Intersoft WebGrid Documentation
RowHeaderWidth Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridTable Class : RowHeaderWidth Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute(" Specifies the width of RowHeader in Unit.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property RowHeaderWidth As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebGridTable
Dim value As System.Integer

instance.RowHeaderWidth = value

value = instance.RowHeaderWidth
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute(" Specifies the width of RowHeader in Unit.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public System.int RowHeaderWidth {get; set;}
Delphi
public read-write property RowHeaderWidth: System.Integer;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute(" Specifies the width of RowHeader in Unit.")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get,set RowHeaderWidth : System.int
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute(" Specifies the width of RowHeader in Unit.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.int get_RowHeaderWidth();
public: __property void set_RowHeaderWidth(
   System.int value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute(" Specifies the width of RowHeader in Unit.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.int RowHeaderWidth {
   System.int get();
   void set (    System.int value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridTable Class
WebGridTable Members


RowHeightDefault Property

[image]
Intersoft WebGrid Documentation
RowHeightDefault Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridTable Class : RowHeightDefault Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies the default row height in Unit.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property RowHeightDefault As System.Web.UI.WebControls.Unit
Visual Basic (Usage) Copy Code
Dim instance As WebGridTable
Dim value As System.Web.UI.WebControls.Unit

instance.RowHeightDefault = value

value = instance.RowHeightDefault
C#
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the default row height in Unit.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
public System.Web.UI.WebControls.Unit RowHeightDefault {get; set;}
Delphi
public read-write property RowHeightDefault: System.Web.UI.WebControls.Unit;
JScript
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the default row height in Unit.")
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get,set RowHeightDefault : System.Web.UI.WebControls.Unit
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the default row height in Unit.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.Web.UI.WebControls.Unit get_RowHeightDefault();
public: __property void set_RowHeightDefault(
   System.Web.UI.WebControls.Unit value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the default row height in Unit.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.Web.UI.WebControls.Unit RowHeightDefault {
   System.Web.UI.WebControls.Unit get();
   void set (    System.Web.UI.WebControls.Unit value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridTable Class
WebGridTable Members


RowLayout Property

[image]
Intersoft WebGrid Documentation
RowLayout Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridTable Class : RowLayout Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies the row's rendering layout mode.")>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Property RowLayout As RowLayoutMode
Visual Basic (Usage) Copy Code
Dim instance As WebGridTable
Dim value As RowLayoutMode

instance.RowLayout = value

value = instance.RowLayout
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the row's rendering layout mode.")]
[ISNet.Serialization.XmlSerializableAttribute()]
public RowLayoutMode RowLayout {get; set;}
Delphi
public read-write property RowLayout: RowLayoutMode;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the row's rendering layout mode.")
ISNet.Serialization.XmlSerializableAttribute()
public function get,set RowLayout : RowLayoutMode
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the row's rendering layout mode.")]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property RowLayoutMode get_RowLayout();
public: __property void set_RowLayout(
   RowLayoutMode value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the row's rendering layout mode.")]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property RowLayoutMode RowLayout {
   RowLayoutMode get();
   void set (    RowLayoutMode value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridTable Class
WebGridTable Members


RowStyle Property

[image]
Intersoft WebGrid Documentation
RowStyle Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridTable Class : RowStyle Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Gets or sets the style applied to the row.")>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
Public Property RowStyle As WebGridFormatStyle
Visual Basic (Usage) Copy Code
Dim instance As WebGridTable
Dim value As WebGridFormatStyle

instance.RowStyle = value

value = instance.RowStyle
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the style applied to the row.")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
public WebGridFormatStyle RowStyle {get; set;}
Delphi
public read-write property RowStyle: WebGridFormatStyle;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the style applied to the row.")
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
public function get,set RowStyle : WebGridFormatStyle
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the style applied to the row.")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
public: __property WebGridFormatStyle* get_RowStyle();
public: __property void set_RowStyle(
   WebGridFormatStyle* value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the style applied to the row.")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
public:
property WebGridFormatStyle^ RowStyle {
   WebGridFormatStyle^ get();
   void set (    WebGridFormatStyle^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridTable Class
WebGridTable Members


SelectedRowStyle Property

[image]
Intersoft WebGrid Documentation
SelectedRowStyle Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridTable Class : SelectedRowStyle Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Gets or sets the style applied to the selected row.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property SelectedRowStyle As WebGridFormatStyle
Visual Basic (Usage) Copy Code
Dim instance As WebGridTable
Dim value As WebGridFormatStyle

instance.SelectedRowStyle = value

value = instance.SelectedRowStyle
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the style applied to the selected row.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.Serialization.BinarySerializableAttribute()]
public WebGridFormatStyle SelectedRowStyle {get; set;}
Delphi
public read-write property SelectedRowStyle: WebGridFormatStyle;
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the style applied to the selected row.")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
ISNet.Serialization.BinarySerializableAttribute()
public function get,set SelectedRowStyle : WebGridFormatStyle
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the style applied to the selected row.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property WebGridFormatStyle* get_SelectedRowStyle();
public: __property void set_SelectedRowStyle(
   WebGridFormatStyle* value
);
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the style applied to the selected row.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property WebGridFormatStyle^ SelectedRowStyle {
   WebGridFormatStyle^ get();
   void set (    WebGridFormatStyle^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridTable Class
WebGridTable Members


SelfReferencingSettings Property

[image]
Intersoft WebGrid Documentation
SelfReferencingSettings Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridTable Class : SelfReferencingSettings Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute()>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<ISNet.Serialization.XmlSerializableAttribute(True)>
Public Property SelfReferencingSettings As SelfReferencingSettings
Visual Basic (Usage) Copy Code
Dim instance As WebGridTable
Dim value As SelfReferencingSettings

instance.SelfReferencingSettings = value

value = instance.SelfReferencingSettings
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.Serialization.XmlSerializableAttribute(true)]
public SelfReferencingSettings SelfReferencingSettings {get; set;}
Delphi
public read-write property SelfReferencingSettings: SelfReferencingSettings;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute()
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
ISNet.Serialization.XmlSerializableAttribute()
public function get,set SelfReferencingSettings : SelfReferencingSettings
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.Serialization.XmlSerializableAttribute(true)]
public: __property SelfReferencingSettings* get_SelfReferencingSettings();
public: __property void set_SelfReferencingSettings(
   SelfReferencingSettings* value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.Serialization.XmlSerializableAttribute(true)]
public:
property SelfReferencingSettings^ SelfReferencingSettings {
   SelfReferencingSettings^ get();
   void set (    SelfReferencingSettings^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridTable Class
WebGridTable Members


SortedColumnStyle Property

[image]
Intersoft WebGrid Documentation
SortedColumnStyle Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridTable Class : SortedColumnStyle Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute()>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
Public Property SortedColumnStyle As WebGridFormatStyle
Visual Basic (Usage) Copy Code
Dim instance As WebGridTable
Dim value As WebGridFormatStyle

instance.SortedColumnStyle = value

value = instance.SortedColumnStyle
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
public WebGridFormatStyle SortedColumnStyle {get; set;}
Delphi
public read-write property SortedColumnStyle: WebGridFormatStyle;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute()
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
public function get,set SortedColumnStyle : WebGridFormatStyle
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
public: __property WebGridFormatStyle* get_SortedColumnStyle();
public: __property void set_SortedColumnStyle(
   WebGridFormatStyle* value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
public:
property WebGridFormatStyle^ SortedColumnStyle {
   WebGridFormatStyle^ get();
   void set (    WebGridFormatStyle^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridTable Class
WebGridTable Members


TableHeaderStyle Property

[image]
Intersoft WebGrid Documentation
TableHeaderStyle Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridTable Class : TableHeaderStyle Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Gets or sets the style applied to table header.")>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property TableHeaderStyle As WebGridFormatStyle
Visual Basic (Usage) Copy Code
Dim instance As WebGridTable
Dim value As WebGridFormatStyle

instance.TableHeaderStyle = value

value = instance.TableHeaderStyle
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the style applied to table header.")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.Serialization.BinarySerializableAttribute()]
public WebGridFormatStyle TableHeaderStyle {get; set;}
Delphi
public read-write property TableHeaderStyle: WebGridFormatStyle;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the style applied to table header.")
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
ISNet.Serialization.BinarySerializableAttribute()
public function get,set TableHeaderStyle : WebGridFormatStyle
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the style applied to table header.")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property WebGridFormatStyle* get_TableHeaderStyle();
public: __property void set_TableHeaderStyle(
   WebGridFormatStyle* value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the style applied to table header.")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property WebGridFormatStyle^ TableHeaderStyle {
   WebGridFormatStyle^ get();
   void set (    WebGridFormatStyle^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridTable Class
WebGridTable Members


TableHeaderVisible Property

[image]
Intersoft WebGrid Documentation
TableHeaderVisible Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridTable Class : TableHeaderVisible Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Determines whether or not to display table header.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property TableHeaderVisible As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebGridTable
Dim value As System.Boolean

instance.TableHeaderVisible = value

value = instance.TableHeaderVisible
C#
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Determines whether or not to display table header.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public System.bool TableHeaderVisible {get; set;}
Delphi
public read-write property TableHeaderVisible: System.Boolean;
JScript
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Determines whether or not to display table header.")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get,set TableHeaderVisible : System.boolean
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Determines whether or not to display table header.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.bool get_TableHeaderVisible();
public: __property void set_TableHeaderVisible(
   System.bool value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Determines whether or not to display table header.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.bool TableHeaderVisible {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridTable Class
WebGridTable Members


TreeNodeField Property

[image]
Intersoft WebGrid Documentation
TreeNodeField Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridTable Class : TreeNodeField Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Gets or sets the data field to be used when the WebGrid is configured to use TreeView mode (bound to XmlDataSource control)")>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Property TreeNodeField As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebGridTable
Dim value As System.String

instance.TreeNodeField = value

value = instance.TreeNodeField
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the data field to be used when the WebGrid is configured to use TreeView mode (bound to XmlDataSource control)")]
[ISNet.Serialization.XmlSerializableAttribute()]
public System.string TreeNodeField {get; set;}
Delphi
public read-write property TreeNodeField: System.String;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the data field to be used when the WebGrid is configured to use TreeView mode (bound to XmlDataSource control)")
ISNet.Serialization.XmlSerializableAttribute()
public function get,set TreeNodeField : System.String
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the data field to be used when the WebGrid is configured to use TreeView mode (bound to XmlDataSource control)")]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property System.string* get_TreeNodeField();
public: __property void set_TreeNodeField(
   System.string* value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the data field to be used when the WebGrid is configured to use TreeView mode (bound to XmlDataSource control)")]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property System.String^ TreeNodeField {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridTable Class
WebGridTable Members


UseValueListForFilter Property

[image]
Intersoft WebGrid Documentation
UseValueListForFilter Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridTable Class : UseValueListForFilter Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Indicates whether the value list data should be used for sorting a column.")>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Property UseValueListForFilter As ValueListFilter
Visual Basic (Usage) Copy Code
Dim instance As WebGridTable
Dim value As ValueListFilter

instance.UseValueListForFilter = value

value = instance.UseValueListForFilter
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Indicates whether the value list data should be used for sorting a column.")]
[ISNet.Serialization.XmlSerializableAttribute()]
public ValueListFilter UseValueListForFilter {get; set;}
Delphi
public read-write property UseValueListForFilter: ValueListFilter;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Indicates whether the value list data should be used for sorting a column.")
ISNet.Serialization.XmlSerializableAttribute()
public function get,set UseValueListForFilter : ValueListFilter
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Indicates whether the value list data should be used for sorting a column.")]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property ValueListFilter get_UseValueListForFilter();
public: __property void set_UseValueListForFilter(
   ValueListFilter value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Indicates whether the value list data should be used for sorting a column.")]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property ValueListFilter UseValueListForFilter {
   ValueListFilter get();
   void set (    ValueListFilter value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridTable Class
WebGridTable Members


UseValueListForSorting Property

[image]
Intersoft WebGrid Documentation
UseValueListForSorting Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridTable Class : UseValueListForSorting Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Indicates whether the value list data should be used for sorting a column.")>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Property UseValueListForSorting As ValueListSorting
Visual Basic (Usage) Copy Code
Dim instance As WebGridTable
Dim value As ValueListSorting

instance.UseValueListForSorting = value

value = instance.UseValueListForSorting
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Indicates whether the value list data should be used for sorting a column.")]
[ISNet.Serialization.XmlSerializableAttribute()]
public ValueListSorting UseValueListForSorting {get; set;}
Delphi
public read-write property UseValueListForSorting: ValueListSorting;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Indicates whether the value list data should be used for sorting a column.")
ISNet.Serialization.XmlSerializableAttribute()
public function get,set UseValueListForSorting : ValueListSorting
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Indicates whether the value list data should be used for sorting a column.")]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property ValueListSorting get_UseValueListForSorting();
public: __property void set_UseValueListForSorting(
   ValueListSorting value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Indicates whether the value list data should be used for sorting a column.")]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property ValueListSorting UseValueListForSorting {
   ValueListSorting get();
   void set (    ValueListSorting value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridTable Class
WebGridTable Members


WebGridTableCollection Class

[image]
Intersoft WebGrid Documentation
WebGridTableCollection Class
Members See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : WebGridTableCollection Class

Glossary Item Box

Object Model

WebGridTableCollection Class

Syntax

Visual Basic (Declaration)
<System.Reflection.DefaultMemberAttribute("Item")>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.SerializableAttribute()>
Public Class WebGridTableCollection
   Inherits ISNet.WebUI.ISCollectionBase
Visual Basic (Usage) Copy Code
Dim instance As WebGridTableCollection
C#
[System.Reflection.DefaultMemberAttribute("Item")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public class WebGridTableCollection : ISNet.WebUI.ISCollectionBase
Delphi
public class WebGridTableCollection = class(ISNet.WebUI.ISCollectionBase)
JScript
System.Reflection.DefaultMemberAttribute("Item")
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.SerializableAttribute()
public class WebGridTableCollection extends ISNet.WebUI.ISCollectionBase
Managed Extensions for C++
[System.Reflection.DefaultMemberAttribute("Item")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public __gc class WebGridTableCollection : public ISNet.WebUI.ISCollectionBase
C++/CLI
[System.Reflection.DefaultMemberAttribute("Item")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public ref class WebGridTableCollection : public ISNet.WebUI.ISCollectionBase

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
ISNet.WebUI.ISCollectionBase
ISNet.WebUI.WebGrid.WebGridTableCollection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridTableCollection Members
ISNet.WebUI.WebGrid Namespace


WebGridTableCollection Class Members

[image]
Intersoft WebGrid Documentation
WebGridTableCollection Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebGrid Namespace : WebGridTableCollection Class

Glossary Item Box

The following tables list the members exposed by WebGridTableCollection.

Public Constructors

 | Name | Description
Public Constructor | WebGridTableCollection Constructor |
Top

Public Properties

 | Name | Description
Public Property | Capacity | (Inherited from System.Collections.CollectionBase)
Public Property | Count | (Inherited from System.Collections.CollectionBase)
Public Property | IsReadOnly | Overridden.
Public Property | Item |
Public Property | Owner |
Public Property | Parent | (Inherited from ISNet.WebUI.ISCollectionBase)
Top

Public Methods

 | Name | Description
Public Method | Add | Overloaded.
Public Method | Clear |
Public Method | Contains | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | CopyFrom |
Public Method | CopyTo | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | Exists | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | GetEnumerator |
Public Method | GetItem | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | GetNamedItem |
Public Method | IndexOf | Overloaded. (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | Insert |
Public Method | IntInsert | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | Remove |
Public Method | setParent | (Inherited from ISNet.WebUI.ISCollectionBase)
Top

See Also

Reference

WebGridTableCollection Class
ISNet.WebUI.WebGrid Namespace


WebGridTableCollection Constructor

[image]
Intersoft WebGrid Documentation
WebGridTableCollection Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridTableCollection Class : WebGridTableCollection Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebGridTableCollection()
C#
public WebGridTableCollection()
Delphi
public WebGridTableCollection();
JScript
public function WebGridTableCollection();
Managed Extensions for C++
public: WebGridTableCollection();
C++/CLI
public:
WebGridTableCollection();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridTableCollection Class
WebGridTableCollection Members


WebGridTableCollection Class Methods

[image]
Intersoft WebGrid Documentation
WebGridTableCollection Class Methods
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : WebGridTableCollection Class

Glossary Item Box

For a list of all members of this type, see WebGridTableCollection members.

Public Methods

 | Name | Description
Public Method | Add | Overloaded.
Public Method | Clear |
Public Method | Contains | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | CopyFrom |
Public Method | CopyTo | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | Exists | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | GetEnumerator |
Public Method | GetItem | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | GetNamedItem |
Public Method | IndexOf | Overloaded. (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | Insert |
Public Method | IntInsert | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | Remove |
Public Method | setParent | (Inherited from ISNet.WebUI.ISCollectionBase)
Top

See Also

Reference

WebGridTableCollection Class
ISNet.WebUI.WebGrid Namespace


Add Method

[image]
Intersoft WebGrid Documentation
Add Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridTableCollection Class : Add Method

Glossary Item Box

Overload List

Overload | Description
Add(WebGridTable) |
Add(String) |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridTableCollection Class
WebGridTableCollection Members


Add(WebGridTable) Method

[image]
Intersoft WebGrid Documentation
Add(WebGridTable) Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridTableCollection Class > Add Method : Add(WebGridTable) Method

webGridTable

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function Add( _
   ByVal webGridTable As WebGridTable _
) As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebGridTableCollection
Dim webGridTable As WebGridTable
Dim value As System.Integer

value = instance.Add(webGridTable)
C#
public virtual System.int Add(
   WebGridTable webGridTable
)
Delphi
public function Add(
    webGridTable: WebGridTable
): System.Integer; virtual;
JScript
public function Add(
   webGridTable : WebGridTable
) : System.int;
Managed Extensions for C++
public: virtual System.int Add(
   WebGridTable* webGridTable
)
C++/CLI
public:
virtual System.int Add(
   WebGridTable^ webGridTable
)

Parameters

webGridTable

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridTableCollection Class
WebGridTableCollection Members
Overload List


Add(String) Method

[image]
Intersoft WebGrid Documentation
Add(String) Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridTableCollection Class > Add Method : Add(String) Method

name

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function Add( _
   ByVal name As System.String _
) As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebGridTableCollection
Dim name As System.String
Dim value As System.Integer

value = instance.Add(name)
C#
public System.int Add(
   System.string name
)
Delphi
public function Add(
    name: System.String
): System.Integer;
JScript
public function Add(
   name : System.String
) : System.int;
Managed Extensions for C++
public: System.int Add(
   System.string* name
)
C++/CLI
public:
System.int Add(
   System.String^ name
)

Parameters

name

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridTableCollection Class
WebGridTableCollection Members
Overload List


Clear Method

[image]
Intersoft WebGrid Documentation
Clear Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridTableCollection Class : Clear Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Shadows Sub Clear()
Visual Basic (Usage) Copy Code
Dim instance As WebGridTableCollection

instance.Clear()
C#
public new void Clear()
Delphi
public procedure Clear();
JScript
public hide function Clear();
Managed Extensions for C++
public: new void Clear();
C++/CLI
public:
new void Clear();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridTableCollection Class
WebGridTableCollection Members


Contains Method

[image]
Intersoft WebGrid Documentation
Contains Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridTableCollection Class : Contains Method

value

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function Contains( _
   ByVal value As ISNet.WebUI.INamedObject _
) As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebGridTableCollection
Dim value As ISNet.WebUI.INamedObject
Dim value As System.Boolean

value = instance.Contains(value)
C#
public System.bool Contains(
   ISNet.WebUI.INamedObject value
)
Delphi
public function Contains(
    value: ISNet.WebUI.INamedObject
): System.Boolean;
JScript
public function Contains(
   value : ISNet.WebUI.INamedObject
) : System.boolean;
Managed Extensions for C++
public: System.bool Contains(
   ISNet.WebUI.INamedObject* value
)
C++/CLI
public:
System.bool Contains(
   ISNet.WebUI.INamedObject^ value
)

Parameters

value

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridTableCollection Class
WebGridTableCollection Members


CopyFrom Method

[image]
Intersoft WebGrid Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridTableCollection Class : CopyFrom Method

passIn

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function CopyFrom( _
   ByVal passIn As WebGridTableCollection _
) As WebGridTableCollection
Visual Basic (Usage) Copy Code
Dim instance As WebGridTableCollection
Dim passIn As WebGridTableCollection
Dim value As WebGridTableCollection

value = instance.CopyFrom(passIn)
C#
public WebGridTableCollection CopyFrom(
   WebGridTableCollection passIn
)
Delphi
public function CopyFrom(
    passIn: WebGridTableCollection
): WebGridTableCollection;
JScript
public function CopyFrom(
   passIn : WebGridTableCollection
) : WebGridTableCollection;
Managed Extensions for C++
public: WebGridTableCollection* CopyFrom(
   WebGridTableCollection* passIn
)
C++/CLI
public:
WebGridTableCollection^ CopyFrom(
   WebGridTableCollection^ passIn
)

Parameters

passIn

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridTableCollection Class
WebGridTableCollection Members


CopyTo Method

[image]
Intersoft WebGrid Documentation
CopyTo Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridTableCollection Class : CopyTo Method

array
index

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub CopyTo( _
   ByVal array() As ISNet.WebUI.INamedObject, _
   ByVal index As System.Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As WebGridTableCollection
Dim array() As ISNet.WebUI.INamedObject
Dim index As System.Integer

instance.CopyTo(array, index)
C#
public void CopyTo(
   ISNet.WebUI.INamedObject[] array,
   System.int index
)
Delphi
public procedure CopyTo(
    array: ISNet.WebUI.INamedObjectarray of;
    index: System.Integer
);
JScript
public function CopyTo(
   array : ISNet.WebUI.INamedObject[],
   index : System.int
);
Managed Extensions for C++
public: void CopyTo(
   ISNet.WebUI.INamedObject*[]* array,
   System.int index
)
C++/CLI
public:
void CopyTo(
   ISNet.WebUI.array<INamedObject^>^ array,
   System.int index
)

Parameters

array
index

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridTableCollection Class
WebGridTableCollection Members


Exists Method

[image]
Intersoft WebGrid Documentation
Exists Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridTableCollection Class : Exists Method

name

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function Exists( _
   ByVal name As System.String _
) As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebGridTableCollection
Dim name As System.String
Dim value As System.Boolean

value = instance.Exists(name)
C#
public System.bool Exists(
   System.string name
)
Delphi
public function Exists(
    name: System.String
): System.Boolean;
JScript
public function Exists(
   name : System.String
) : System.boolean;
Managed Extensions for C++
public: System.bool Exists(
   System.string* name
)
C++/CLI
public:
System.bool Exists(
   System.String^ name
)

Parameters

name

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridTableCollection Class
WebGridTableCollection Members


GetEnumerator Method

[image]
Intersoft WebGrid Documentation
GetEnumerator Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridTableCollection Class : GetEnumerator Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Shadows Function GetEnumerator() As System.Collections.IEnumerator
Visual Basic (Usage) Copy Code
Dim instance As WebGridTableCollection
Dim value As System.Collections.IEnumerator

value = instance.GetEnumerator()
C#
public new System.Collections.IEnumerator GetEnumerator()
Delphi
public function GetEnumerator(): System.Collections.IEnumerator;
JScript
public hide function GetEnumerator() : System.Collections.IEnumerator;
Managed Extensions for C++
public: new System.Collections.IEnumerator* GetEnumerator();
C++/CLI
public:
new System.Collections.IEnumerator^ GetEnumerator();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridTableCollection Class
WebGridTableCollection Members


GetItem Method

[image]
Intersoft WebGrid Documentation
GetItem Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridTableCollection Class : GetItem Method

Glossary Item Box

Overload List

Overload | Description
GetItem | (Inherited from ISNet.WebUI.ISCollectionBase)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridTableCollection Class
WebGridTableCollection Members


GetItem(Int32) Method

[image]
Intersoft WebGrid Documentation
GetItem(Int32) Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridTableCollection Class : GetItem(Int32) Method

index

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetItem( _
   ByVal index As System.Integer _
) As ISNet.WebUI.INamedObject
Visual Basic (Usage) Copy Code
Dim instance As WebGridTableCollection
Dim index As System.Integer
Dim value As ISNet.WebUI.INamedObject

value = instance.GetItem(index)
C#
public virtual ISNet.WebUI.INamedObject GetItem(
   System.int index
)
Delphi
public function GetItem(
    index: System.Integer
): ISNet.WebUI.INamedObject; virtual;
JScript
public function GetItem(
   index : System.int
) : ISNet.WebUI.INamedObject;
Managed Extensions for C++
public: virtual ISNet.WebUI.INamedObject* GetItem(
   System.int index
)
C++/CLI
public:
virtual ISNet.WebUI.INamedObject^ GetItem(
   System.int index
)

Parameters

index

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridTableCollection Class
WebGridTableCollection Members


GetNamedItem Method

[image]
Intersoft WebGrid Documentation
GetNamedItem Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridTableCollection Class : GetNamedItem Method

name

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetNamedItem( _
   ByVal name As System.String _
) As WebGridTable
Visual Basic (Usage) Copy Code
Dim instance As WebGridTableCollection
Dim name As System.String
Dim value As WebGridTable

value = instance.GetNamedItem(name)
C#
public WebGridTable GetNamedItem(
   System.string name
)
Delphi
public function GetNamedItem(
    name: System.String
): WebGridTable;
JScript
public function GetNamedItem(
   name : System.String
) : WebGridTable;
Managed Extensions for C++
public: WebGridTable* GetNamedItem(
   System.string* name
)
C++/CLI
public:
WebGridTable^ GetNamedItem(
   System.String^ name
)

Parameters

name

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridTableCollection Class
WebGridTableCollection Members


IndexOf Method

[image]
Intersoft WebGrid Documentation
IndexOf Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridTableCollection Class : IndexOf Method

Glossary Item Box

Overload List

Overload | Description
IndexOf(String) | (Inherited from ISNet.WebUI.ISCollectionBase)
IndexOf(INamedObject) | (Inherited from ISNet.WebUI.ISCollectionBase)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridTableCollection Class
WebGridTableCollection Members


IndexOf(String) Method

[image]
Intersoft WebGrid Documentation
IndexOf(String) Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridTableCollection Class > IndexOf Method : IndexOf(String) Method

name

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function IndexOf( _
   ByVal name As System.String _
) As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebGridTableCollection
Dim name As System.String
Dim value As System.Integer

value = instance.IndexOf(name)
C#
public virtual System.int IndexOf(
   System.string name
)
Delphi
public function IndexOf(
    name: System.String
): System.Integer; virtual;
JScript
public function IndexOf(
   name : System.String
) : System.int;
Managed Extensions for C++
public: virtual System.int IndexOf(
   System.string* name
)
C++/CLI
public:
virtual System.int IndexOf(
   System.String^ name
)

Parameters

name

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridTableCollection Class
WebGridTableCollection Members
Overload List


IndexOf(INamedObject) Method

[image]
Intersoft WebGrid Documentation
IndexOf(INamedObject) Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridTableCollection Class > IndexOf Method : IndexOf(INamedObject) Method

value

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function IndexOf( _
   ByVal value As ISNet.WebUI.INamedObject _
) As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebGridTableCollection
Dim value As ISNet.WebUI.INamedObject
Dim value As System.Integer

value = instance.IndexOf(value)
C#
public System.int IndexOf(
   ISNet.WebUI.INamedObject value
)
Delphi
public function IndexOf(
    value: ISNet.WebUI.INamedObject
): System.Integer;
JScript
public function IndexOf(
   value : ISNet.WebUI.INamedObject
) : System.int;
Managed Extensions for C++
public: System.int IndexOf(
   ISNet.WebUI.INamedObject* value
)
C++/CLI
public:
System.int IndexOf(
   ISNet.WebUI.INamedObject^ value
)

Parameters

value

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridTableCollection Class
WebGridTableCollection Members
Overload List


Insert Method

[image]
Intersoft WebGrid Documentation
Insert Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridTableCollection Class : Insert Method

index
webGridTable

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub Insert( _
   ByVal index As System.Integer, _
   ByVal webGridTable As WebGridTable _
)
Visual Basic (Usage) Copy Code
Dim instance As WebGridTableCollection
Dim index As System.Integer
Dim webGridTable As WebGridTable

instance.Insert(index, webGridTable)
C#
public void Insert(
   System.int index,
   WebGridTable webGridTable
)
Delphi
public procedure Insert(
    index: System.Integer;
    webGridTable: WebGridTable
);
JScript
public function Insert(
   index : System.int,
   webGridTable : WebGridTable
);
Managed Extensions for C++
public: void Insert(
   System.int index,
   WebGridTable* webGridTable
)
C++/CLI
public:
void Insert(
   System.int index,
   WebGridTable^ webGridTable
)

Parameters

index
webGridTable

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridTableCollection Class
WebGridTableCollection Members


IntInsert Method

[image]
Intersoft WebGrid Documentation
IntInsert Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridTableCollection Class : IntInsert Method

index
value

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub IntInsert( _
   ByVal index As System.Integer, _
   ByVal value As ISNet.WebUI.INamedObject _
)
Visual Basic (Usage) Copy Code
Dim instance As WebGridTableCollection
Dim index As System.Integer
Dim value As ISNet.WebUI.INamedObject

instance.IntInsert(index, value)
C#
public void IntInsert(
   System.int index,
   ISNet.WebUI.INamedObject value
)
Delphi
public procedure IntInsert(
    index: System.Integer;
    value: ISNet.WebUI.INamedObject
);
JScript
public function IntInsert(
   index : System.int,
   value : ISNet.WebUI.INamedObject
);
Managed Extensions for C++
public: void IntInsert(
   System.int index,
   ISNet.WebUI.INamedObject* value
)
C++/CLI
public:
void IntInsert(
   System.int index,
   ISNet.WebUI.INamedObject^ value
)

Parameters

index
value

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridTableCollection Class
WebGridTableCollection Members


Remove Method

[image]
Intersoft WebGrid Documentation
Remove Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridTableCollection Class : Remove Method

webGridTable

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub Remove( _
   ByVal webGridTable As WebGridTable _
)
Visual Basic (Usage) Copy Code
Dim instance As WebGridTableCollection
Dim webGridTable As WebGridTable

instance.Remove(webGridTable)
C#
public void Remove(
   WebGridTable webGridTable
)
Delphi
public procedure Remove(
    webGridTable: WebGridTable
);
JScript
public function Remove(
   webGridTable : WebGridTable
);
Managed Extensions for C++
public: void Remove(
   WebGridTable* webGridTable
)
C++/CLI
public:
void Remove(
   WebGridTable^ webGridTable
)

Parameters

webGridTable

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridTableCollection Class
WebGridTableCollection Members


setParent Method

[image]
Intersoft WebGrid Documentation
setParent Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridTableCollection Class : setParent Method

parent

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub setParent( _
   ByVal parent As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebGridTableCollection
Dim parent As System.Object

instance.setParent(parent)
C#
public virtual void setParent(
   System.object parent
)
Delphi
public procedure setParent(
    parent: System.TObject
); virtual;
JScript
public function setParent(
   parent : System.Object
);
Managed Extensions for C++
public: virtual void setParent(
   System.Object* parent
)
C++/CLI
public:
virtual void setParent(
   System.Object^ parent
)

Parameters

parent

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridTableCollection Class
WebGridTableCollection Members


Capacity Property

[image]
Intersoft WebGrid Documentation
Capacity Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridTableCollection Class : Capacity Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Runtime.InteropServices.ComVisibleAttribute(False)>
Public Property Capacity As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebGridTableCollection
Dim value As System.Integer

instance.Capacity = value

value = instance.Capacity
C#
[System.Runtime.InteropServices.ComVisibleAttribute(false)]
public System.int Capacity {get; set;}
Delphi
public read-write property Capacity: System.Integer;
JScript
System.Runtime.InteropServices.ComVisibleAttribute()
public function get,set Capacity : System.int
Managed Extensions for C++
[System.Runtime.InteropServices.ComVisibleAttribute(false)]
public: __property System.int get_Capacity();
public: __property void set_Capacity(
   System.int value
);
C++/CLI
[System.Runtime.InteropServices.ComVisibleAttribute(false)]
public:
property System.int Capacity {
   System.int get();
   void set (    System.int value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridTableCollection Class
WebGridTableCollection Members


Count Property

[image]
Intersoft WebGrid Documentation
Count Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridTableCollection Class : Count Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Count As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebGridTableCollection
Dim value As System.Integer

value = instance.Count
C#
public System.int Count {get;}
Delphi
public read-only property Count: System.Integer;
JScript
public function get Count : System.int
Managed Extensions for C++
public: __property System.int get_Count();
C++/CLI
public:
property System.int Count {
   System.int get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridTableCollection Class
WebGridTableCollection Members


WebGridTableCollection Class Properties

[image]
Intersoft WebGrid Documentation
WebGridTableCollection Class Properties
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : WebGridTableCollection Class

Glossary Item Box

For a list of all members of this type, see WebGridTableCollection members.

Public Properties

 | Name | Description
Public Property | Capacity | (Inherited from System.Collections.CollectionBase)
Public Property | Count | (Inherited from System.Collections.CollectionBase)
Public Property | IsReadOnly | Overridden.
Public Property | Item |
Public Property | Owner |
Public Property | Parent | (Inherited from ISNet.WebUI.ISCollectionBase)
Top

See Also

Reference

WebGridTableCollection Class
ISNet.WebUI.WebGrid Namespace


WebGridTableCollection Constructor

[image]
Intersoft WebGrid Documentation
WebGridTableCollection Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridTableCollection Class : WebGridTableCollection Constructor

Glossary Item Box

Overload List

Overload | Description
WebGridTableCollection Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridTableCollection Class
WebGridTableCollection Members


IsReadOnly Property

[image]
Intersoft WebGrid Documentation
IsReadOnly Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridTableCollection Class : IsReadOnly Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property IsReadOnly As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebGridTableCollection
Dim value As System.Boolean

value = instance.IsReadOnly
C#
public override System.bool IsReadOnly {get;}
Delphi
public read-only property IsReadOnly: System.Boolean; override;
JScript
public override function get IsReadOnly : System.boolean
Managed Extensions for C++
public: __property System.bool get_IsReadOnly() override;
C++/CLI
public:
property System.bool IsReadOnly {
   System.bool get() override;
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridTableCollection Class
WebGridTableCollection Members


Item Property

[image]
Intersoft WebGrid Documentation
Item Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridTableCollection Class : Item Property

index

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Default Property Item( _
   ByVal index As System.Integer _
) As WebGridTable
Visual Basic (Usage) Copy Code
Dim instance As WebGridTableCollection
Dim index As System.Integer
Dim value As WebGridTable

value = instance.Item(index)
C#
public WebGridTable this[
   System.int index
]; {get;}
Delphi
public  this: : WebGridTable;[
    index: System.Integer
]; read-only
JScript
public  this[
   index : System.int
] get : WebGridTable
Managed Extensions for C++
public: __property WebGridTable* get_Item   System.int index
;
C++/CLI
public:
property WebGridTable^ default [int] {
   WebGridTable^ get(System.int index);
}

Parameters

index

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridTableCollection Class
WebGridTableCollection Members


Owner Property

[image]
Intersoft WebGrid Documentation
Owner Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridTableCollection Class : Owner Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Owner As WebGridTable
Visual Basic (Usage) Copy Code
Dim instance As WebGridTableCollection
Dim value As WebGridTable

value = instance.Owner
C#
public WebGridTable Owner {get;}
Delphi
public read-only property Owner: WebGridTable;
JScript
public function get Owner : WebGridTable
Managed Extensions for C++
public: __property WebGridTable* get_Owner();
C++/CLI
public:
property WebGridTable^ Owner {
   WebGridTable^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridTableCollection Class
WebGridTableCollection Members


Parent Property

[image]
Intersoft WebGrid Documentation
Parent Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridTableCollection Class : Parent Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Parent As System.Object
Visual Basic (Usage) Copy Code
Dim instance As WebGridTableCollection
Dim value As System.Object

value = instance.Parent
C#
public System.object Parent {get;}
Delphi
public read-only property Parent: System.TObject;
JScript
public function get Parent : System.Object
Managed Extensions for C++
public: __property System.Object* get_Parent();
C++/CLI
public:
property System.Object^ Parent {
   System.Object^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridTableCollection Class
WebGridTableCollection Members


WebGridTextItem Class

[image]
Intersoft WebGrid Documentation
WebGridTextItem Class
Members See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : WebGridTextItem Class

Glossary Item Box

Object Model

WebGridTextItem Class

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.DescriptionAttribute()>
<System.SerializableAttribute()>
Public Class WebGridTextItem
   Inherits ISNet.WebUI.NamedObjectBase
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject
Visual Basic (Usage) Copy Code
Dim instance As WebGridTextItem
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DescriptionAttribute()]
[System.SerializableAttribute()]
public class WebGridTextItem : ISNet.WebUI.NamedObjectBase, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject
Delphi
public class WebGridTextItem = class(ISNet.WebUI.NamedObjectBase, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject)
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.DescriptionAttribute()
System.SerializableAttribute()
public class WebGridTextItem extends ISNet.WebUI.NamedObjectBase implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DescriptionAttribute()]
[System.SerializableAttribute()]
public __gc class WebGridTextItem : public ISNet.WebUI.NamedObjectBase, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DescriptionAttribute()]
[System.SerializableAttribute()]
public ref class WebGridTextItem : public ISNet.WebUI.NamedObjectBase, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.NamedObjectBase
ISNet.WebUI.WebGrid.WebGridTextItem

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridTextItem Members
ISNet.WebUI.WebGrid Namespace


WebGridTextItem Class Members

[image]
Intersoft WebGrid Documentation
WebGridTextItem Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebGrid Namespace : WebGridTextItem Class

Glossary Item Box

The following tables list the members exposed by WebGridTextItem.

Public Constructors

 | Name | Description
Public Constructor | WebGridTextItem Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | TextItem |
Public Property | TextValue |
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString |
Top

See Also

Reference

WebGridTextItem Class
ISNet.WebUI.WebGrid Namespace


WebGridTextItem Constructor

[image]
Intersoft WebGrid Documentation
WebGridTextItem Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridTextItem Class : WebGridTextItem Constructor

Glossary Item Box

Overload List

Overload | Description
WebGridTextItem Constructor() |
WebGridTextItem Constructor(String,String) |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridTextItem Class
WebGridTextItem Members


WebGridTextItem Constructor()

[image]
Intersoft WebGrid Documentation
WebGridTextItem Constructor()
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridTextItem Class > WebGridTextItem Constructor : WebGridTextItem Constructor()

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebGridTextItem()
C#
public WebGridTextItem()
Delphi
public WebGridTextItem();
JScript
public function WebGridTextItem();
Managed Extensions for C++
public: WebGridTextItem();
C++/CLI
public:
WebGridTextItem();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridTextItem Class
WebGridTextItem Members
Overload List


WebGridTextItem Constructor(String,String)

[image]
Intersoft WebGrid Documentation
WebGridTextItem Constructor(String,String)
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridTextItem Class > WebGridTextItem Constructor : WebGridTextItem Constructor(String,String)

textItem
textValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal textItem As System.String, _
   ByVal textValue As System.String _
)
Visual Basic (Usage) Copy Code
Dim textItem As System.String
Dim textValue As System.String

Dim instance As New WebGridTextItem(textItem, textValue)
C#
public WebGridTextItem(
   System.string textItem,
   System.string textValue
)
Delphi
public WebGridTextItem(
    textItem: System.String;
    textValue: System.String
);
JScript
public function WebGridTextItem(
   textItem : System.String,
   textValue : System.String
);
Managed Extensions for C++
public: WebGridTextItem(
   System.string* textItem,
   System.string* textValue
)
C++/CLI
public:
WebGridTextItem(
   System.String^ textItem,
   System.String^ textValue
)

Parameters

textItem
textValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridTextItem Class
WebGridTextItem Members
Overload List


Clone Method

[image]
Intersoft WebGrid Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridTextItem Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As System.Object
Visual Basic (Usage) Copy Code
Dim instance As WebGridTextItem
Dim value As System.Object

value = instance.Clone()
C#
public virtual System.object Clone()
Delphi
public function Clone(): System.TObject; virtual;
JScript
public function Clone() : System.Object;
Managed Extensions for C++
public: virtual System.Object* Clone();
C++/CLI
public:
virtual System.Object^ Clone();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridTextItem Class
WebGridTextItem Members


CopyFrom Method

[image]
Intersoft WebGrid Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridTextItem Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridTextItem Class
WebGridTextItem Members


CopyFrom(Object) Method

[image]
Intersoft WebGrid Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridTextItem Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebGridTextItem
Dim objSource As System.Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   System.object objSource
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridTextItem Class
WebGridTextItem Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebGrid Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridTextItem Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object, _
   ByVal cloneSourceValue As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebGridTextItem
Dim objSource As System.Object
Dim cloneSourceValue As System.Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   System.object objSource,
   System.bool cloneSourceValue
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject;
    cloneSourceValue: System.Boolean
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object,
   cloneSourceValue : System.boolean
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource,
   System.bool cloneSourceValue
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource,
   System.bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridTextItem Class
WebGridTextItem Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebGrid Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridTextItem Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebGridTextItem
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure DeSerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function DeSerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void DeSerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void DeSerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridTextItem Class
WebGridTextItem Members


GetHashCode Method

[image]
Intersoft WebGrid Documentation
GetHashCode Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridTextItem Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebGridTextItem
Dim value As System.Integer

value = instance.GetHashCode()
C#
public virtual System.int GetHashCode()
Delphi
public function GetHashCode(): System.Integer; virtual;
JScript
public function GetHashCode() : System.int;
Managed Extensions for C++
public: virtual System.int GetHashCode();
C++/CLI
public:
virtual System.int GetHashCode();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridTextItem Class
WebGridTextItem Members


WebGridTextItem Class Methods

[image]
Intersoft WebGrid Documentation
WebGridTextItem Class Methods
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : WebGridTextItem Class

Glossary Item Box

For a list of all members of this type, see WebGridTextItem members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString |
Top

See Also

Reference

WebGridTextItem Class
ISNet.WebUI.WebGrid Namespace


GetObjectData Method

[image]
Intersoft WebGrid Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridTextItem Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebGridTextItem
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure GetObjectData(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
); override;
JScript
public override function GetObjectData(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void GetObjectData(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
) override
C++/CLI
public:
void GetObjectData(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
) override

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridTextItem Class
WebGridTextItem Members


IsEmpty Method

[image]
Intersoft WebGrid Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridTextItem Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebGridTextItem
Dim value As System.Boolean

value = instance.IsEmpty()
C#
public virtual System.bool IsEmpty()
Delphi
public function IsEmpty(): System.Boolean; virtual;
JScript
public function IsEmpty() : System.boolean;
Managed Extensions for C++
public: virtual System.bool IsEmpty();
C++/CLI
public:
virtual System.bool IsEmpty();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridTextItem Class
WebGridTextItem Members


Reset Method

[image]
Intersoft WebGrid Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridTextItem Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As WebGridTextItem

instance.Reset()
C#
public virtual void Reset()
Delphi
public procedure Reset(); virtual;
JScript
public function Reset();
Managed Extensions for C++
public: virtual void Reset();
C++/CLI
public:
virtual void Reset();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridTextItem Class
WebGridTextItem Members


SerializeObjectData Method

[image]
Intersoft WebGrid Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridTextItem Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebGridTextItem
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure SerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function SerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void SerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void SerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridTextItem Class
WebGridTextItem Members


ToString Method

[image]
Intersoft WebGrid Documentation
ToString Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridTextItem Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString() As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebGridTextItem
Dim value As System.String

value = instance.ToString()
C#
public override System.string ToString()
Delphi
public function ToString(): System.String; override;
JScript
public override function ToString() : System.String;
Managed Extensions for C++
public: System.string* ToString(); override
C++/CLI
public:
System.String^ ToString(); override

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridTextItem Class
WebGridTextItem Members


WebGridTextItem Class Properties

[image]
Intersoft WebGrid Documentation
WebGridTextItem Class Properties
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : WebGridTextItem Class

Glossary Item Box

For a list of all members of this type, see WebGridTextItem members.

Public Properties

 | Name | Description
Public Property | TextItem |
Public Property | TextValue |
Top

See Also

Reference

WebGridTextItem Class
ISNet.WebUI.WebGrid Namespace


TextItem Property

[image]
Intersoft WebGrid Documentation
TextItem Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridTextItem Class : TextItem Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebGrid.TextItemEditor, ISNet.WebUI.WebGrid, Version=9.0.7200.1, Culture=neutral, PublicKeyToken=3e60b85fb8502d5e")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Property TextItem As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebGridTextItem
Dim value As System.String

instance.TextItem = value

value = instance.TextItem
C#
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebGrid.TextItemEditor, ISNet.WebUI.WebGrid, Version=9.0.7200.1, Culture=neutral, PublicKeyToken=3e60b85fb8502d5e")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public System.string TextItem {get; set;}
Delphi
public read-write property TextItem: System.String;
JScript
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebGrid.TextItemEditor, ISNet.WebUI.WebGrid, Version=9.0.7200.1, Culture=neutral, PublicKeyToken=3e60b85fb8502d5e")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute()
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute()
public function get,set TextItem : System.String
Managed Extensions for C++
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebGrid.TextItemEditor, ISNet.WebUI.WebGrid, Version=9.0.7200.1, Culture=neutral, PublicKeyToken=3e60b85fb8502d5e")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property System.string* get_TextItem();
public: __property void set_TextItem(
   System.string* value
);
C++/CLI
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebGrid.TextItemEditor, ISNet.WebUI.WebGrid, Version=9.0.7200.1, Culture=neutral, PublicKeyToken=3e60b85fb8502d5e")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property System.String^ TextItem {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridTextItem Class
WebGridTextItem Members


TextValue Property

[image]
Intersoft WebGrid Documentation
TextValue Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridTextItem Class : TextValue Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Property TextValue As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebGridTextItem
Dim value As System.String

instance.TextValue = value

value = instance.TextValue
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public System.string TextValue {get; set;}
Delphi
public read-write property TextValue: System.String;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute()
ISNet.Serialization.XmlSerializableAttribute()
public function get,set TextValue : System.String
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property System.string* get_TextValue();
public: __property void set_TextValue(
   System.string* value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property System.String^ TextValue {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridTextItem Class
WebGridTextItem Members


WebGridTextItemCollection Class

[image]
Intersoft WebGrid Documentation
WebGridTextItemCollection Class
Members See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : WebGridTextItemCollection Class

Glossary Item Box

Object Model

WebGridTextItemCollection Class

Syntax

Visual Basic (Declaration)
<System.Reflection.DefaultMemberAttribute("Item")>
<System.SerializableAttribute()>
Public Class WebGridTextItemCollection
   Inherits ISNet.WebUI.ISCollectionBase
Visual Basic (Usage) Copy Code
Dim instance As WebGridTextItemCollection
C#
[System.Reflection.DefaultMemberAttribute("Item")]
[System.SerializableAttribute()]
public class WebGridTextItemCollection : ISNet.WebUI.ISCollectionBase
Delphi
public class WebGridTextItemCollection = class(ISNet.WebUI.ISCollectionBase)
JScript
System.Reflection.DefaultMemberAttribute("Item")
System.SerializableAttribute()
public class WebGridTextItemCollection extends ISNet.WebUI.ISCollectionBase
Managed Extensions for C++
[System.Reflection.DefaultMemberAttribute("Item")]
[System.SerializableAttribute()]
public __gc class WebGridTextItemCollection : public ISNet.WebUI.ISCollectionBase
C++/CLI
[System.Reflection.DefaultMemberAttribute("Item")]
[System.SerializableAttribute()]
public ref class WebGridTextItemCollection : public ISNet.WebUI.ISCollectionBase

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
ISNet.WebUI.ISCollectionBase
ISNet.WebUI.WebGrid.WebGridTextItemCollection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridTextItemCollection Members
ISNet.WebUI.WebGrid Namespace


WebGridTextItemCollection Class Members

[image]
Intersoft WebGrid Documentation
WebGridTextItemCollection Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebGrid Namespace : WebGridTextItemCollection Class

Glossary Item Box

The following tables list the members exposed by WebGridTextItemCollection.

Public Constructors

 | Name | Description
Public Constructor | WebGridTextItemCollection Constructor |
Top

Public Properties

 | Name | Description
Public Property | Capacity | (Inherited from System.Collections.CollectionBase)
Public Property | Count | (Inherited from System.Collections.CollectionBase)
Public Property | IsReadOnly | Overridden.
Public Property | Item |
Public Property | Parent | (Inherited from ISNet.WebUI.ISCollectionBase)
Top

Public Methods

 | Name | Description
Public Method | Add | Overloaded.
Public Method | Clear |
Public Method | Contains | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | CopyFrom |
Public Method | CopyTo | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | Exists | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | GetByTextItem |
Public Method | GetEnumerator |
Public Method | GetItem | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | GetNamedItem |
Public Method | IndexOf | Overloaded. (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | Insert |
Public Method | IntInsert | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | Remove |
Public Method | setParent | (Inherited from ISNet.WebUI.ISCollectionBase)
Top

See Also

Reference

WebGridTextItemCollection Class
ISNet.WebUI.WebGrid Namespace


WebGridTextItemCollection Constructor

[image]
Intersoft WebGrid Documentation
WebGridTextItemCollection Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridTextItemCollection Class : WebGridTextItemCollection Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebGridTextItemCollection()
C#
public WebGridTextItemCollection()
Delphi
public WebGridTextItemCollection();
JScript
public function WebGridTextItemCollection();
Managed Extensions for C++
public: WebGridTextItemCollection();
C++/CLI
public:
WebGridTextItemCollection();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridTextItemCollection Class
WebGridTextItemCollection Members


WebGridTextItemCollection Class Methods

[image]
Intersoft WebGrid Documentation
WebGridTextItemCollection Class Methods
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : WebGridTextItemCollection Class

Glossary Item Box

For a list of all members of this type, see WebGridTextItemCollection members.

Public Methods

 | Name | Description
Public Method | Add | Overloaded.
Public Method | Clear |
Public Method | Contains | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | CopyFrom |
Public Method | CopyTo | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | Exists | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | GetByTextItem |
Public Method | GetEnumerator |
Public Method | GetItem | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | GetNamedItem |
Public Method | IndexOf | Overloaded. (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | Insert |
Public Method | IntInsert | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | Remove |
Public Method | setParent | (Inherited from ISNet.WebUI.ISCollectionBase)
Top

See Also

Reference

WebGridTextItemCollection Class
ISNet.WebUI.WebGrid Namespace


Add Method

[image]
Intersoft WebGrid Documentation
Add Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridTextItemCollection Class : Add Method

Glossary Item Box

Overload List

Overload | Description
Add(WebGridTextItem) |
Add(String) |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridTextItemCollection Class
WebGridTextItemCollection Members


Add(WebGridTextItem) Method

[image]
Intersoft WebGrid Documentation
Add(WebGridTextItem) Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridTextItemCollection Class > Add Method : Add(WebGridTextItem) Method

webGridTextItem

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function Add( _
   ByVal webGridTextItem As WebGridTextItem _
) As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebGridTextItemCollection
Dim webGridTextItem As WebGridTextItem
Dim value As System.Integer

value = instance.Add(webGridTextItem)
C#
public virtual System.int Add(
   WebGridTextItem webGridTextItem
)
Delphi
public function Add(
    webGridTextItem: WebGridTextItem
): System.Integer; virtual;
JScript
public function Add(
   webGridTextItem : WebGridTextItem
) : System.int;
Managed Extensions for C++
public: virtual System.int Add(
   WebGridTextItem* webGridTextItem
)
C++/CLI
public:
virtual System.int Add(
   WebGridTextItem^ webGridTextItem
)

Parameters

webGridTextItem

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridTextItemCollection Class
WebGridTextItemCollection Members
Overload List


Add(String) Method

[image]
Intersoft WebGrid Documentation
Add(String) Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridTextItemCollection Class > Add Method : Add(String) Method

name

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function Add( _
   ByVal name As System.String _
) As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebGridTextItemCollection
Dim name As System.String
Dim value As System.Integer

value = instance.Add(name)
C#
public System.int Add(
   System.string name
)
Delphi
public function Add(
    name: System.String
): System.Integer;
JScript
public function Add(
   name : System.String
) : System.int;
Managed Extensions for C++
public: System.int Add(
   System.string* name
)
C++/CLI
public:
System.int Add(
   System.String^ name
)

Parameters

name

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridTextItemCollection Class
WebGridTextItemCollection Members
Overload List


Clear Method

[image]
Intersoft WebGrid Documentation
Clear Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridTextItemCollection Class : Clear Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Shadows Sub Clear()
Visual Basic (Usage) Copy Code
Dim instance As WebGridTextItemCollection

instance.Clear()
C#
public new void Clear()
Delphi
public procedure Clear();
JScript
public hide function Clear();
Managed Extensions for C++
public: new void Clear();
C++/CLI
public:
new void Clear();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridTextItemCollection Class
WebGridTextItemCollection Members


Contains Method

[image]
Intersoft WebGrid Documentation
Contains Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridTextItemCollection Class : Contains Method

value

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function Contains( _
   ByVal value As ISNet.WebUI.INamedObject _
) As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebGridTextItemCollection
Dim value As ISNet.WebUI.INamedObject
Dim value As System.Boolean

value = instance.Contains(value)
C#
public System.bool Contains(
   ISNet.WebUI.INamedObject value
)
Delphi
public function Contains(
    value: ISNet.WebUI.INamedObject
): System.Boolean;
JScript
public function Contains(
   value : ISNet.WebUI.INamedObject
) : System.boolean;
Managed Extensions for C++
public: System.bool Contains(
   ISNet.WebUI.INamedObject* value
)
C++/CLI
public:
System.bool Contains(
   ISNet.WebUI.INamedObject^ value
)

Parameters

value

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridTextItemCollection Class
WebGridTextItemCollection Members


CopyFrom Method

[image]
Intersoft WebGrid Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridTextItemCollection Class : CopyFrom Method

passIn

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function CopyFrom( _
   ByVal passIn As WebGridTextItemCollection _
) As WebGridTextItemCollection
Visual Basic (Usage) Copy Code
Dim instance As WebGridTextItemCollection
Dim passIn As WebGridTextItemCollection
Dim value As WebGridTextItemCollection

value = instance.CopyFrom(passIn)
C#
public WebGridTextItemCollection CopyFrom(
   WebGridTextItemCollection passIn
)
Delphi
public function CopyFrom(
    passIn: WebGridTextItemCollection
): WebGridTextItemCollection;
JScript
public function CopyFrom(
   passIn : WebGridTextItemCollection
) : WebGridTextItemCollection;
Managed Extensions for C++
public: WebGridTextItemCollection* CopyFrom(
   WebGridTextItemCollection* passIn
)
C++/CLI
public:
WebGridTextItemCollection^ CopyFrom(
   WebGridTextItemCollection^ passIn
)

Parameters

passIn

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridTextItemCollection Class
WebGridTextItemCollection Members


CopyTo Method

[image]
Intersoft WebGrid Documentation
CopyTo Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridTextItemCollection Class : CopyTo Method

array
index

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub CopyTo( _
   ByVal array() As ISNet.WebUI.INamedObject, _
   ByVal index As System.Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As WebGridTextItemCollection
Dim array() As ISNet.WebUI.INamedObject
Dim index As System.Integer

instance.CopyTo(array, index)
C#
public void CopyTo(
   ISNet.WebUI.INamedObject[] array,
   System.int index
)
Delphi
public procedure CopyTo(
    array: ISNet.WebUI.INamedObjectarray of;
    index: System.Integer
);
JScript
public function CopyTo(
   array : ISNet.WebUI.INamedObject[],
   index : System.int
);
Managed Extensions for C++
public: void CopyTo(
   ISNet.WebUI.INamedObject*[]* array,
   System.int index
)
C++/CLI
public:
void CopyTo(
   ISNet.WebUI.array<INamedObject^>^ array,
   System.int index
)

Parameters

array
index

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridTextItemCollection Class
WebGridTextItemCollection Members


Exists Method

[image]
Intersoft WebGrid Documentation
Exists Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridTextItemCollection Class : Exists Method

name

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function Exists( _
   ByVal name As System.String _
) As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebGridTextItemCollection
Dim name As System.String
Dim value As System.Boolean

value = instance.Exists(name)
C#
public System.bool Exists(
   System.string name
)
Delphi
public function Exists(
    name: System.String
): System.Boolean;
JScript
public function Exists(
   name : System.String
) : System.boolean;
Managed Extensions for C++
public: System.bool Exists(
   System.string* name
)
C++/CLI
public:
System.bool Exists(
   System.String^ name
)

Parameters

name

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridTextItemCollection Class
WebGridTextItemCollection Members


GetByTextItem Method

[image]
Intersoft WebGrid Documentation
GetByTextItem Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridTextItemCollection Class : GetByTextItem Method

textItem

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetByTextItem( _
   ByVal textItem As System.String _
) As WebGridTextItem
Visual Basic (Usage) Copy Code
Dim instance As WebGridTextItemCollection
Dim textItem As System.String
Dim value As WebGridTextItem

value = instance.GetByTextItem(textItem)
C#
public WebGridTextItem GetByTextItem(
   System.string textItem
)
Delphi
public function GetByTextItem(
    textItem: System.String
): WebGridTextItem;
JScript
public function GetByTextItem(
   textItem : System.String
) : WebGridTextItem;
Managed Extensions for C++
public: WebGridTextItem* GetByTextItem(
   System.string* textItem
)
C++/CLI
public:
WebGridTextItem^ GetByTextItem(
   System.String^ textItem
)

Parameters

textItem

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridTextItemCollection Class
WebGridTextItemCollection Members


GetEnumerator Method

[image]
Intersoft WebGrid Documentation
GetEnumerator Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridTextItemCollection Class : GetEnumerator Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Shadows Function GetEnumerator() As System.Collections.IEnumerator
Visual Basic (Usage) Copy Code
Dim instance As WebGridTextItemCollection
Dim value As System.Collections.IEnumerator

value = instance.GetEnumerator()
C#
public new System.Collections.IEnumerator GetEnumerator()
Delphi
public function GetEnumerator(): System.Collections.IEnumerator;
JScript
public hide function GetEnumerator() : System.Collections.IEnumerator;
Managed Extensions for C++
public: new System.Collections.IEnumerator* GetEnumerator();
C++/CLI
public:
new System.Collections.IEnumerator^ GetEnumerator();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridTextItemCollection Class
WebGridTextItemCollection Members


GetItem Method

[image]
Intersoft WebGrid Documentation
GetItem Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridTextItemCollection Class : GetItem Method

Glossary Item Box

Overload List

Overload | Description
GetItem | (Inherited from ISNet.WebUI.ISCollectionBase)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridTextItemCollection Class
WebGridTextItemCollection Members


GetItem(Int32) Method

[image]
Intersoft WebGrid Documentation
GetItem(Int32) Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridTextItemCollection Class : GetItem(Int32) Method

index

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetItem( _
   ByVal index As System.Integer _
) As ISNet.WebUI.INamedObject
Visual Basic (Usage) Copy Code
Dim instance As WebGridTextItemCollection
Dim index As System.Integer
Dim value As ISNet.WebUI.INamedObject

value = instance.GetItem(index)
C#
public virtual ISNet.WebUI.INamedObject GetItem(
   System.int index
)
Delphi
public function GetItem(
    index: System.Integer
): ISNet.WebUI.INamedObject; virtual;
JScript
public function GetItem(
   index : System.int
) : ISNet.WebUI.INamedObject;
Managed Extensions for C++
public: virtual ISNet.WebUI.INamedObject* GetItem(
   System.int index
)
C++/CLI
public:
virtual ISNet.WebUI.INamedObject^ GetItem(
   System.int index
)

Parameters

index

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridTextItemCollection Class
WebGridTextItemCollection Members


GetNamedItem Method

[image]
Intersoft WebGrid Documentation
GetNamedItem Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridTextItemCollection Class : GetNamedItem Method

name

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetNamedItem( _
   ByVal name As System.String _
) As WebGridTextItem
Visual Basic (Usage) Copy Code
Dim instance As WebGridTextItemCollection
Dim name As System.String
Dim value As WebGridTextItem

value = instance.GetNamedItem(name)
C#
public WebGridTextItem GetNamedItem(
   System.string name
)
Delphi
public function GetNamedItem(
    name: System.String
): WebGridTextItem;
JScript
public function GetNamedItem(
   name : System.String
) : WebGridTextItem;
Managed Extensions for C++
public: WebGridTextItem* GetNamedItem(
   System.string* name
)
C++/CLI
public:
WebGridTextItem^ GetNamedItem(
   System.String^ name
)

Parameters

name

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridTextItemCollection Class
WebGridTextItemCollection Members


IndexOf Method

[image]
Intersoft WebGrid Documentation
IndexOf Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridTextItemCollection Class : IndexOf Method

Glossary Item Box

Overload List

Overload | Description
IndexOf(String) | (Inherited from ISNet.WebUI.ISCollectionBase)
IndexOf(INamedObject) | (Inherited from ISNet.WebUI.ISCollectionBase)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridTextItemCollection Class
WebGridTextItemCollection Members


IndexOf(String) Method

[image]
Intersoft WebGrid Documentation
IndexOf(String) Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridTextItemCollection Class > IndexOf Method : IndexOf(String) Method

name

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function IndexOf( _
   ByVal name As System.String _
) As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebGridTextItemCollection
Dim name As System.String
Dim value As System.Integer

value = instance.IndexOf(name)
C#
public virtual System.int IndexOf(
   System.string name
)
Delphi
public function IndexOf(
    name: System.String
): System.Integer; virtual;
JScript
public function IndexOf(
   name : System.String
) : System.int;
Managed Extensions for C++
public: virtual System.int IndexOf(
   System.string* name
)
C++/CLI
public:
virtual System.int IndexOf(
   System.String^ name
)

Parameters

name

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridTextItemCollection Class
WebGridTextItemCollection Members
Overload List


IndexOf(INamedObject) Method

[image]
Intersoft WebGrid Documentation
IndexOf(INamedObject) Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridTextItemCollection Class > IndexOf Method : IndexOf(INamedObject) Method

value

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function IndexOf( _
   ByVal value As ISNet.WebUI.INamedObject _
) As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebGridTextItemCollection
Dim value As ISNet.WebUI.INamedObject
Dim value As System.Integer

value = instance.IndexOf(value)
C#
public System.int IndexOf(
   ISNet.WebUI.INamedObject value
)
Delphi
public function IndexOf(
    value: ISNet.WebUI.INamedObject
): System.Integer;
JScript
public function IndexOf(
   value : ISNet.WebUI.INamedObject
) : System.int;
Managed Extensions for C++
public: System.int IndexOf(
   ISNet.WebUI.INamedObject* value
)
C++/CLI
public:
System.int IndexOf(
   ISNet.WebUI.INamedObject^ value
)

Parameters

value

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridTextItemCollection Class
WebGridTextItemCollection Members
Overload List


Insert Method

[image]
Intersoft WebGrid Documentation
Insert Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridTextItemCollection Class : Insert Method

index
webGridTextItem

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub Insert( _
   ByVal index As System.Integer, _
   ByVal webGridTextItem As WebGridTextItem _
)
Visual Basic (Usage) Copy Code
Dim instance As WebGridTextItemCollection
Dim index As System.Integer
Dim webGridTextItem As WebGridTextItem

instance.Insert(index, webGridTextItem)
C#
public void Insert(
   System.int index,
   WebGridTextItem webGridTextItem
)
Delphi
public procedure Insert(
    index: System.Integer;
    webGridTextItem: WebGridTextItem
);
JScript
public function Insert(
   index : System.int,
   webGridTextItem : WebGridTextItem
);
Managed Extensions for C++
public: void Insert(
   System.int index,
   WebGridTextItem* webGridTextItem
)
C++/CLI
public:
void Insert(
   System.int index,
   WebGridTextItem^ webGridTextItem
)

Parameters

index
webGridTextItem

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridTextItemCollection Class
WebGridTextItemCollection Members


IntInsert Method

[image]
Intersoft WebGrid Documentation
IntInsert Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridTextItemCollection Class : IntInsert Method

index
value

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub IntInsert( _
   ByVal index As System.Integer, _
   ByVal value As ISNet.WebUI.INamedObject _
)
Visual Basic (Usage) Copy Code
Dim instance As WebGridTextItemCollection
Dim index As System.Integer
Dim value As ISNet.WebUI.INamedObject

instance.IntInsert(index, value)
C#
public void IntInsert(
   System.int index,
   ISNet.WebUI.INamedObject value
)
Delphi
public procedure IntInsert(
    index: System.Integer;
    value: ISNet.WebUI.INamedObject
);
JScript
public function IntInsert(
   index : System.int,
   value : ISNet.WebUI.INamedObject
);
Managed Extensions for C++
public: void IntInsert(
   System.int index,
   ISNet.WebUI.INamedObject* value
)
C++/CLI
public:
void IntInsert(
   System.int index,
   ISNet.WebUI.INamedObject^ value
)

Parameters

index
value

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridTextItemCollection Class
WebGridTextItemCollection Members


Remove Method

[image]
Intersoft WebGrid Documentation
Remove Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridTextItemCollection Class : Remove Method

webGridTextItem

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub Remove( _
   ByVal webGridTextItem As WebGridTextItem _
)
Visual Basic (Usage) Copy Code
Dim instance As WebGridTextItemCollection
Dim webGridTextItem As WebGridTextItem

instance.Remove(webGridTextItem)
C#
public void Remove(
   WebGridTextItem webGridTextItem
)
Delphi
public procedure Remove(
    webGridTextItem: WebGridTextItem
);
JScript
public function Remove(
   webGridTextItem : WebGridTextItem
);
Managed Extensions for C++
public: void Remove(
   WebGridTextItem* webGridTextItem
)
C++/CLI
public:
void Remove(
   WebGridTextItem^ webGridTextItem
)

Parameters

webGridTextItem

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridTextItemCollection Class
WebGridTextItemCollection Members


setParent Method

[image]
Intersoft WebGrid Documentation
setParent Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridTextItemCollection Class : setParent Method

parent

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub setParent( _
   ByVal parent As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebGridTextItemCollection
Dim parent As System.Object

instance.setParent(parent)
C#
public virtual void setParent(
   System.object parent
)
Delphi
public procedure setParent(
    parent: System.TObject
); virtual;
JScript
public function setParent(
   parent : System.Object
);
Managed Extensions for C++
public: virtual void setParent(
   System.Object* parent
)
C++/CLI
public:
virtual void setParent(
   System.Object^ parent
)

Parameters

parent

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridTextItemCollection Class
WebGridTextItemCollection Members


Capacity Property

[image]
Intersoft WebGrid Documentation
Capacity Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridTextItemCollection Class : Capacity Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Runtime.InteropServices.ComVisibleAttribute(False)>
Public Property Capacity As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebGridTextItemCollection
Dim value As System.Integer

instance.Capacity = value

value = instance.Capacity
C#
[System.Runtime.InteropServices.ComVisibleAttribute(false)]
public System.int Capacity {get; set;}
Delphi
public read-write property Capacity: System.Integer;
JScript
System.Runtime.InteropServices.ComVisibleAttribute()
public function get,set Capacity : System.int
Managed Extensions for C++
[System.Runtime.InteropServices.ComVisibleAttribute(false)]
public: __property System.int get_Capacity();
public: __property void set_Capacity(
   System.int value
);
C++/CLI
[System.Runtime.InteropServices.ComVisibleAttribute(false)]
public:
property System.int Capacity {
   System.int get();
   void set (    System.int value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridTextItemCollection Class
WebGridTextItemCollection Members


Count Property

[image]
Intersoft WebGrid Documentation
Count Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridTextItemCollection Class : Count Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Count As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebGridTextItemCollection
Dim value As System.Integer

value = instance.Count
C#
public System.int Count {get;}
Delphi
public read-only property Count: System.Integer;
JScript
public function get Count : System.int
Managed Extensions for C++
public: __property System.int get_Count();
C++/CLI
public:
property System.int Count {
   System.int get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridTextItemCollection Class
WebGridTextItemCollection Members


WebGridTextItemCollection Class Properties

[image]
Intersoft WebGrid Documentation
WebGridTextItemCollection Class Properties
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : WebGridTextItemCollection Class

Glossary Item Box

For a list of all members of this type, see WebGridTextItemCollection members.

Public Properties

 | Name | Description
Public Property | Capacity | (Inherited from System.Collections.CollectionBase)
Public Property | Count | (Inherited from System.Collections.CollectionBase)
Public Property | IsReadOnly | Overridden.
Public Property | Item |
Public Property | Parent | (Inherited from ISNet.WebUI.ISCollectionBase)
Top

See Also

Reference

WebGridTextItemCollection Class
ISNet.WebUI.WebGrid Namespace


WebGridTextItemCollection Constructor

[image]
Intersoft WebGrid Documentation
WebGridTextItemCollection Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridTextItemCollection Class : WebGridTextItemCollection Constructor

Glossary Item Box

Overload List

Overload | Description
WebGridTextItemCollection Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridTextItemCollection Class
WebGridTextItemCollection Members


IsReadOnly Property

[image]
Intersoft WebGrid Documentation
IsReadOnly Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridTextItemCollection Class : IsReadOnly Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property IsReadOnly As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebGridTextItemCollection
Dim value As System.Boolean

value = instance.IsReadOnly
C#
public override System.bool IsReadOnly {get;}
Delphi
public read-only property IsReadOnly: System.Boolean; override;
JScript
public override function get IsReadOnly : System.boolean
Managed Extensions for C++
public: __property System.bool get_IsReadOnly() override;
C++/CLI
public:
property System.bool IsReadOnly {
   System.bool get() override;
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridTextItemCollection Class
WebGridTextItemCollection Members


Item Property

[image]
Intersoft WebGrid Documentation
Item Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridTextItemCollection Class : Item Property

index

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Default Property Item( _
   ByVal index As System.Integer _
) As WebGridTextItem
Visual Basic (Usage) Copy Code
Dim instance As WebGridTextItemCollection
Dim index As System.Integer
Dim value As WebGridTextItem

value = instance.Item(index)
C#
public WebGridTextItem this[
   System.int index
]; {get;}
Delphi
public  this: : WebGridTextItem;[
    index: System.Integer
]; read-only
JScript
public  this[
   index : System.int
] get : WebGridTextItem
Managed Extensions for C++
public: __property WebGridTextItem* get_Item   System.int index
;
C++/CLI
public:
property WebGridTextItem^ default [int] {
   WebGridTextItem^ get(System.int index);
}

Parameters

index

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridTextItemCollection Class
WebGridTextItemCollection Members


Parent Property

[image]
Intersoft WebGrid Documentation
Parent Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebGridTextItemCollection Class : Parent Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Parent As System.Object
Visual Basic (Usage) Copy Code
Dim instance As WebGridTextItemCollection
Dim value As System.Object

value = instance.Parent
C#
public System.object Parent {get;}
Delphi
public read-only property Parent: System.TObject;
JScript
public function get Parent : System.Object
Managed Extensions for C++
public: __property System.Object* get_Parent();
C++/CLI
public:
property System.Object^ Parent {
   System.Object^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridTextItemCollection Class
WebGridTextItemCollection Members


WebValueList Class

[image]
Intersoft WebGrid Documentation
WebValueList Class
Members See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : WebValueList Class

Glossary Item Box

Object Model

WebValueList Class

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute()>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.SerializableAttribute()>
Public Class WebValueList
   Inherits ISNet.WebUI.NamedObjectBase
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.Serialization.XmlSerialization.ICustomXmlSerializer, ISNet.WebUI.IAutoDataCache, ISNet.WebUI.IDataSourceControlSupport, ISNet.WebUI.INamedObject, ISNet.WebUI.ISDataSource
Visual Basic (Usage) Copy Code
Dim instance As WebValueList
C#
[System.ComponentModel.DescriptionAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public class WebValueList : ISNet.WebUI.NamedObjectBase, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.Serialization.XmlSerialization.ICustomXmlSerializer, ISNet.WebUI.IAutoDataCache, ISNet.WebUI.IDataSourceControlSupport, ISNet.WebUI.INamedObject, ISNet.WebUI.ISDataSource
Delphi
public class WebValueList = class(ISNet.WebUI.NamedObjectBase, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.Serialization.XmlSerialization.ICustomXmlSerializer, ISNet.WebUI.IAutoDataCache, ISNet.WebUI.IDataSourceControlSupport, ISNet.WebUI.INamedObject, ISNet.WebUI.ISDataSource)
JScript
System.ComponentModel.DescriptionAttribute()
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.SerializableAttribute()
public class WebValueList extends ISNet.WebUI.NamedObjectBase implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.Serialization.XmlSerialization.ICustomXmlSerializer, ISNet.WebUI.IAutoDataCache, ISNet.WebUI.IDataSourceControlSupport, ISNet.WebUI.INamedObject, ISNet.WebUI.ISDataSource
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public __gc class WebValueList : public ISNet.WebUI.NamedObjectBase, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.Serialization.XmlSerialization.ICustomXmlSerializer, ISNet.WebUI.IAutoDataCache, ISNet.WebUI.IDataSourceControlSupport, ISNet.WebUI.INamedObject, ISNet.WebUI.ISDataSource
C++/CLI
[System.ComponentModel.DescriptionAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public ref class WebValueList : public ISNet.WebUI.NamedObjectBase, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.Serialization.XmlSerialization.ICustomXmlSerializer, ISNet.WebUI.IAutoDataCache, ISNet.WebUI.IDataSourceControlSupport, ISNet.WebUI.INamedObject, ISNet.WebUI.ISDataSource

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.NamedObjectBase
ISNet.WebUI.WebGrid.WebValueList

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebValueList Members
ISNet.WebUI.WebGrid Namespace


WebValueList Class Members

[image]
Intersoft WebGrid Documentation
WebValueList Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebGrid Namespace : WebValueList Class

Glossary Item Box

The following tables list the members exposed by WebValueList.

Public Constructors

 | Name | Description
Public Constructor | WebValueList Constructor |
Top

Public Properties

 | Name | Description
Public Property | DataMember |
Public Property | DataSourceID |
Public Property | DataTextField |
Public Property | DataValueField |
Public Property | EnableMultipleValues |
Public Property | MultipleValuesSeparator |
Public Property | Style |
Top

Public Methods

 | Name | Description
Public Method | ClearCachedDataSource |
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CustomDeserialize |
Public Method | CustomSerialize |
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetCachedDataSource |
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsDataCached |
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SetDataSource | Overloaded.
Public Method | SetDataSourceInternal |
Public Method | ToString |
Top

See Also

Reference

WebValueList Class
ISNet.WebUI.WebGrid Namespace


WebValueList Constructor

[image]
Intersoft WebGrid Documentation
WebValueList Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebValueList Class : WebValueList Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebValueList()
C#
public WebValueList()
Delphi
public WebValueList();
JScript
public function WebValueList();
Managed Extensions for C++
public: WebValueList();
C++/CLI
public:
WebValueList();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebValueList Class
WebValueList Members


WebValueList Class Methods

[image]
Intersoft WebGrid Documentation
WebValueList Class Methods
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : WebValueList Class

Glossary Item Box

For a list of all members of this type, see WebValueList members.

Public Methods

 | Name | Description
Public Method | ClearCachedDataSource |
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CustomDeserialize |
Public Method | CustomSerialize |
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetCachedDataSource |
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsDataCached |
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SetDataSource | Overloaded.
Public Method | SetDataSourceInternal |
Public Method | ToString |
Top

See Also

Reference

WebValueList Class
ISNet.WebUI.WebGrid Namespace


ClearCachedDataSource Method

[image]
Intersoft WebGrid Documentation
ClearCachedDataSource Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebValueList Class : ClearCachedDataSource Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub ClearCachedDataSource()
Visual Basic (Usage) Copy Code
Dim instance As WebValueList

instance.ClearCachedDataSource()
C#
public void ClearCachedDataSource()
Delphi
public procedure ClearCachedDataSource();
JScript
public function ClearCachedDataSource();
Managed Extensions for C++
public: void ClearCachedDataSource();
C++/CLI
public:
void ClearCachedDataSource();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebValueList Class
WebValueList Members


Clone Method

[image]
Intersoft WebGrid Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebValueList Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As System.Object
Visual Basic (Usage) Copy Code
Dim instance As WebValueList
Dim value As System.Object

value = instance.Clone()
C#
public virtual System.object Clone()
Delphi
public function Clone(): System.TObject; virtual;
JScript
public function Clone() : System.Object;
Managed Extensions for C++
public: virtual System.Object* Clone();
C++/CLI
public:
virtual System.Object^ Clone();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebValueList Class
WebValueList Members


CopyFrom Method

[image]
Intersoft WebGrid Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebValueList Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebValueList Class
WebValueList Members


CopyFrom(Object) Method

[image]
Intersoft WebGrid Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebValueList Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebValueList
Dim objSource As System.Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   System.object objSource
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebValueList Class
WebValueList Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebGrid Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebValueList Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object, _
   ByVal cloneSourceValue As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebValueList
Dim objSource As System.Object
Dim cloneSourceValue As System.Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   System.object objSource,
   System.bool cloneSourceValue
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject;
    cloneSourceValue: System.Boolean
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object,
   cloneSourceValue : System.boolean
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource,
   System.bool cloneSourceValue
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource,
   System.bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebValueList Class
WebValueList Members
Overload List


CustomDeserialize Method

[image]
Intersoft WebGrid Documentation
CustomDeserialize Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebValueList Class : CustomDeserialize Method

mi
currentObj
parentNode
currentNode

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub CustomDeserialize( _
   ByVal mi As System.Reflection.MemberInfo, _
   ByVal currentObj As System.Object, _
   ByVal parentNode As System.Xml.XmlNode, _
   ByVal currentNode As System.Xml.XmlNode _
)
Visual Basic (Usage) Copy Code
Dim instance As WebValueList
Dim mi As System.Reflection.MemberInfo
Dim currentObj As System.Object
Dim parentNode As System.Xml.XmlNode
Dim currentNode As System.Xml.XmlNode

instance.CustomDeserialize(mi, currentObj, parentNode, currentNode)
C#
public void CustomDeserialize(
   System.Reflection.MemberInfo mi,
   System.object currentObj,
   System.Xml.XmlNode parentNode,
   System.Xml.XmlNode currentNode
)
Delphi
public procedure CustomDeserialize(
    mi: System.Reflection.MemberInfo;
    currentObj: System.TObject;
    parentNode: System.Xml.XmlNode;
    currentNode: System.Xml.XmlNode
);
JScript
public function CustomDeserialize(
   mi : System.Reflection.MemberInfo,
   currentObj : System.Object,
   parentNode : System.Xml.XmlNode,
   currentNode : System.Xml.XmlNode
);
Managed Extensions for C++
public: void CustomDeserialize(
   System.Reflection.MemberInfo* mi,
   System.Object* currentObj,
   System.Xml.XmlNode* parentNode,
   System.Xml.XmlNode* currentNode
)
C++/CLI
public:
void CustomDeserialize(
   System.Reflection.MemberInfo^ mi,
   System.Object^ currentObj,
   System.Xml.XmlNode^ parentNode,
   System.Xml.XmlNode^ currentNode
)

Parameters

mi
currentObj
parentNode
currentNode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebValueList Class
WebValueList Members


CustomSerialize Method

[image]
Intersoft WebGrid Documentation
CustomSerialize Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebValueList Class : CustomSerialize Method

doc
node

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub CustomSerialize( _
   ByVal doc As System.Xml.XmlDocument, _
   ByVal node As System.Xml.XmlNode _
)
Visual Basic (Usage) Copy Code
Dim instance As WebValueList
Dim doc As System.Xml.XmlDocument
Dim node As System.Xml.XmlNode

instance.CustomSerialize(doc, node)
C#
public void CustomSerialize(
   System.Xml.XmlDocument doc,
   System.Xml.XmlNode node
)
Delphi
public procedure CustomSerialize(
    doc: System.Xml.XmlDocument;
    node: System.Xml.XmlNode
);
JScript
public function CustomSerialize(
   doc : System.Xml.XmlDocument,
   node : System.Xml.XmlNode
);
Managed Extensions for C++
public: void CustomSerialize(
   System.Xml.XmlDocument* doc,
   System.Xml.XmlNode* node
)
C++/CLI
public:
void CustomSerialize(
   System.Xml.XmlDocument^ doc,
   System.Xml.XmlNode^ node
)

Parameters

doc
node

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebValueList Class
WebValueList Members


DeSerializeObjectData Method

[image]
Intersoft WebGrid Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebValueList Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebValueList
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure DeSerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function DeSerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void DeSerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void DeSerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebValueList Class
WebValueList Members


GetCachedDataSource Method

[image]
Intersoft WebGrid Documentation
GetCachedDataSource Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebValueList Class : GetCachedDataSource Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetCachedDataSource() As System.Object
Visual Basic (Usage) Copy Code
Dim instance As WebValueList
Dim value As System.Object

value = instance.GetCachedDataSource()
C#
public System.object GetCachedDataSource()
Delphi
public function GetCachedDataSource(): System.TObject;
JScript
public function GetCachedDataSource() : System.Object;
Managed Extensions for C++
public: System.Object* GetCachedDataSource();
C++/CLI
public:
System.Object^ GetCachedDataSource();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebValueList Class
WebValueList Members


GetHashCode Method

[image]
Intersoft WebGrid Documentation
GetHashCode Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebValueList Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebValueList
Dim value As System.Integer

value = instance.GetHashCode()
C#
public virtual System.int GetHashCode()
Delphi
public function GetHashCode(): System.Integer; virtual;
JScript
public function GetHashCode() : System.int;
Managed Extensions for C++
public: virtual System.int GetHashCode();
C++/CLI
public:
virtual System.int GetHashCode();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebValueList Class
WebValueList Members


GetObjectData Method

[image]
Intersoft WebGrid Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebValueList Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebValueList
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure GetObjectData(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
); override;
JScript
public override function GetObjectData(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void GetObjectData(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
) override
C++/CLI
public:
void GetObjectData(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
) override

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebValueList Class
WebValueList Members


IsDataCached Method

[image]
Intersoft WebGrid Documentation
IsDataCached Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebValueList Class : IsDataCached Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsDataCached() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebValueList
Dim value As System.Boolean

value = instance.IsDataCached()
C#
public System.bool IsDataCached()
Delphi
public function IsDataCached(): System.Boolean;
JScript
public function IsDataCached() : System.boolean;
Managed Extensions for C++
public: System.bool IsDataCached();
C++/CLI
public:
System.bool IsDataCached();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebValueList Class
WebValueList Members


IsEmpty Method

[image]
Intersoft WebGrid Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebValueList Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebValueList
Dim value As System.Boolean

value = instance.IsEmpty()
C#
public virtual System.bool IsEmpty()
Delphi
public function IsEmpty(): System.Boolean; virtual;
JScript
public function IsEmpty() : System.boolean;
Managed Extensions for C++
public: virtual System.bool IsEmpty();
C++/CLI
public:
virtual System.bool IsEmpty();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebValueList Class
WebValueList Members


Reset Method

[image]
Intersoft WebGrid Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebValueList Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As WebValueList

instance.Reset()
C#
public virtual void Reset()
Delphi
public procedure Reset(); virtual;
JScript
public function Reset();
Managed Extensions for C++
public: virtual void Reset();
C++/CLI
public:
virtual void Reset();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebValueList Class
WebValueList Members


SerializeObjectData Method

[image]
Intersoft WebGrid Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebValueList Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebValueList
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure SerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function SerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void SerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void SerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebValueList Class
WebValueList Members


SetDataSource Method

[image]
Intersoft WebGrid Documentation
SetDataSource Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebValueList Class : SetDataSource Method

Glossary Item Box

Overload List

Overload | Description
SetDataSource(Object,String,String) |
SetDataSource(String,String,String,String) |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebValueList Class
WebValueList Members


SetDataSource(Object,String,String) Method

[image]
Intersoft WebGrid Documentation
SetDataSource(Object,String,String) Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebValueList Class > SetDataSource Method : SetDataSource(Object,String,String) Method

dataSource
dataTextField
dataValueField

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Sub SetDataSource( _
   ByVal dataSource As System.Object, _
   ByVal dataTextField As System.String, _
   ByVal dataValueField As System.String _
)
Visual Basic (Usage) Copy Code
Dim instance As WebValueList
Dim dataSource As System.Object
Dim dataTextField As System.String
Dim dataValueField As System.String

instance.SetDataSource(dataSource, dataTextField, dataValueField)
C#
public void SetDataSource(
   System.object dataSource,
   System.string dataTextField,
   System.string dataValueField
)
Delphi
public procedure SetDataSource(
    dataSource: System.TObject;
    dataTextField: System.String;
    dataValueField: System.String
);
JScript
public function SetDataSource(
   dataSource : System.Object,
   dataTextField : System.String,
   dataValueField : System.String
);
Managed Extensions for C++
public: void SetDataSource(
   System.Object* dataSource,
   System.string* dataTextField,
   System.string* dataValueField
)
C++/CLI
public:
void SetDataSource(
   System.Object^ dataSource,
   System.String^ dataTextField,
   System.String^ dataValueField
)

Parameters

dataSource
dataTextField
dataValueField

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebValueList Class
WebValueList Members
Overload List


SetDataSource(String,String,String,String) Method

[image]
Intersoft WebGrid Documentation
SetDataSource(String,String,String,String) Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebValueList Class > SetDataSource Method : SetDataSource(String,String,String,String) Method

dataSourceID
dataMember
dataTextField
dataValueField

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Sub SetDataSource( _
   ByVal dataSourceID As System.String, _
   ByVal dataMember As System.String, _
   ByVal dataTextField As System.String, _
   ByVal dataValueField As System.String _
)
Visual Basic (Usage) Copy Code
Dim instance As WebValueList
Dim dataSourceID As System.String
Dim dataMember As System.String
Dim dataTextField As System.String
Dim dataValueField As System.String

instance.SetDataSource(dataSourceID, dataMember, dataTextField, dataValueField)
C#
public void SetDataSource(
   System.string dataSourceID,
   System.string dataMember,
   System.string dataTextField,
   System.string dataValueField
)
Delphi
public procedure SetDataSource(
    dataSourceID: System.String;
    dataMember: System.String;
    dataTextField: System.String;
    dataValueField: System.String
);
JScript
public function SetDataSource(
   dataSourceID : System.String,
   dataMember : System.String,
   dataTextField : System.String,
   dataValueField : System.String
);
Managed Extensions for C++
public: void SetDataSource(
   System.string* dataSourceID,
   System.string* dataMember,
   System.string* dataTextField,
   System.string* dataValueField
)
C++/CLI
public:
void SetDataSource(
   System.String^ dataSourceID,
   System.String^ dataMember,
   System.String^ dataTextField,
   System.String^ dataValueField
)

Parameters

dataSourceID
dataMember
dataTextField
dataValueField

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebValueList Class
WebValueList Members
Overload List


SetDataSourceInternal Method

[image]
Intersoft WebGrid Documentation
SetDataSourceInternal Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebValueList Class : SetDataSourceInternal Method

dataSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SetDataSourceInternal( _
   ByVal dataSource As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebValueList
Dim dataSource As System.Object

instance.SetDataSourceInternal(dataSource)
C#
public void SetDataSourceInternal(
   System.object dataSource
)
Delphi
public procedure SetDataSourceInternal(
    dataSource: System.TObject
);
JScript
public function SetDataSourceInternal(
   dataSource : System.Object
);
Managed Extensions for C++
public: void SetDataSourceInternal(
   System.Object* dataSource
)
C++/CLI
public:
void SetDataSourceInternal(
   System.Object^ dataSource
)

Parameters

dataSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebValueList Class
WebValueList Members


ToString Method

[image]
Intersoft WebGrid Documentation
ToString Method
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebValueList Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString() As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebValueList
Dim value As System.String

value = instance.ToString()
C#
public override System.string ToString()
Delphi
public function ToString(): System.String; override;
JScript
public override function ToString() : System.String;
Managed Extensions for C++
public: System.string* ToString(); override
C++/CLI
public:
System.String^ ToString(); override

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebValueList Class
WebValueList Members


WebValueList Class Properties

[image]
Intersoft WebGrid Documentation
WebValueList Class Properties
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : WebValueList Class

Glossary Item Box

For a list of all members of this type, see WebValueList members.

Public Properties

 | Name | Description
Public Property | DataMember |
Public Property | DataSourceID |
Public Property | DataTextField |
Public Property | DataValueField |
Public Property | EnableMultipleValues |
Public Property | MultipleValuesSeparator |
Public Property | Style |
Top

See Also

Reference

WebValueList Class
ISNet.WebUI.WebGrid Namespace


WebValueList Constructor

[image]
Intersoft WebGrid Documentation
WebValueList Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebValueList Class : WebValueList Constructor

Glossary Item Box

Overload List

Overload | Description
WebValueList Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebValueList Class
WebValueList Members


DataMember Property

[image]
Intersoft WebGrid Documentation
DataMember Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebValueList Class : DataMember Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies the data member if the assigned DataSource contains multiple DataTable objects.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property DataMember As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebValueList
Dim value As System.String

instance.DataMember = value

value = instance.DataMember
C#
[System.ComponentModel.DescriptionAttribute("Specifies the data member if the assigned DataSource contains multiple DataTable objects.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public System.string DataMember {get; set;}
Delphi
public read-write property DataMember: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Specifies the data member if the assigned DataSource contains multiple DataTable objects.")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get,set DataMember : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies the data member if the assigned DataSource contains multiple DataTable objects.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.string* get_DataMember();
public: __property void set_DataMember(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies the data member if the assigned DataSource contains multiple DataTable objects.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.String^ DataMember {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebValueList Class
WebValueList Members


DataSourceID Property

[image]
Intersoft WebGrid Documentation
DataSourceID Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebValueList Class : DataSourceID Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Data")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Gets or sets the ID of the control from which the WebValueList retrieves its list.")>
<System.Web.UI.IDReferencePropertyAttribute(System.Web.UI.DataSourceControl)>
Public Property DataSourceID As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebValueList
Dim value As System.String

instance.DataSourceID = value

value = instance.DataSourceID
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Data")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the ID of the control from which the WebValueList retrieves its list.")]
[System.Web.UI.IDReferencePropertyAttribute(System.Web.UI.DataSourceControl)]
public System.string DataSourceID {get; set;}
Delphi
public read-write property DataSourceID: System.String;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Data")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the ID of the control from which the WebValueList retrieves its list.")
System.Web.UI.IDReferencePropertyAttribute(System.Web.UI.DataSourceControl)
public function get,set DataSourceID : System.String
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Data")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the ID of the control from which the WebValueList retrieves its list.")]
[System.Web.UI.IDReferencePropertyAttribute(System.Web.UI.DataSourceControl)]
public: __property System.string* get_DataSourceID();
public: __property void set_DataSourceID(
   System.string* value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Data")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the ID of the control from which the WebValueList retrieves its list.")]
[System.Web.UI.IDReferencePropertyAttribute(System.Web.UI.DataSourceControl)]
public:
property System.String^ DataSourceID {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebValueList Class
WebValueList Members


DataTextField Property

[image]
Intersoft WebGrid Documentation
DataTextField Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebValueList Class : DataTextField Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies the data field which its value will be used to translate cell's value.")>
Public Property DataTextField As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebValueList
Dim value As System.String

instance.DataTextField = value

value = instance.DataTextField
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the data field which its value will be used to translate cell's value.")]
public System.string DataTextField {get; set;}
Delphi
public read-write property DataTextField: System.String;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the data field which its value will be used to translate cell's value.")
public function get,set DataTextField : System.String
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the data field which its value will be used to translate cell's value.")]
public: __property System.string* get_DataTextField();
public: __property void set_DataTextField(
   System.string* value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the data field which its value will be used to translate cell's value.")]
public:
property System.String^ DataTextField {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebValueList Class
WebValueList Members


DataValueField Property

[image]
Intersoft WebGrid Documentation
DataValueField Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebValueList Class : DataValueField Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies the data field that used to match its value against cell's text.")>
Public Property DataValueField As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebValueList
Dim value As System.String

instance.DataValueField = value

value = instance.DataValueField
C#
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the data field that used to match its value against cell's text.")]
public System.string DataValueField {get; set;}
Delphi
public read-write property DataValueField: System.String;
JScript
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the data field that used to match its value against cell's text.")
public function get,set DataValueField : System.String
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the data field that used to match its value against cell's text.")]
public: __property System.string* get_DataValueField();
public: __property void set_DataValueField(
   System.string* value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the data field that used to match its value against cell's text.")]
public:
property System.String^ DataValueField {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebValueList Class
WebValueList Members


EnableMultipleValues Property

[image]
Intersoft WebGrid Documentation
EnableMultipleValues Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebValueList Class : EnableMultipleValues Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Indicates whether multiple values data of the associated column should be translated.")>
Public Property EnableMultipleValues As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebValueList
Dim value As System.Boolean

instance.EnableMultipleValues = value

value = instance.EnableMultipleValues
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Indicates whether multiple values data of the associated column should be translated.")]
public System.bool EnableMultipleValues {get; set;}
Delphi
public read-write property EnableMultipleValues: System.Boolean;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Indicates whether multiple values data of the associated column should be translated.")
public function get,set EnableMultipleValues : System.boolean
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Indicates whether multiple values data of the associated column should be translated.")]
public: __property System.bool get_EnableMultipleValues();
public: __property void set_EnableMultipleValues(
   System.bool value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Indicates whether multiple values data of the associated column should be translated.")]
public:
property System.bool EnableMultipleValues {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebValueList Class
WebValueList Members


MultipleValuesSeparator Property

[image]
Intersoft WebGrid Documentation
MultipleValuesSeparator Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebValueList Class : MultipleValuesSeparator Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Gets or sets the character used as separator between data values.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
Public Property MultipleValuesSeparator As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebValueList
Dim value As System.String

instance.MultipleValuesSeparator = value

value = instance.MultipleValuesSeparator
C#
[System.ComponentModel.DescriptionAttribute("Gets or sets the character used as separator between data values.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public System.string MultipleValuesSeparator {get; set;}
Delphi
public read-write property MultipleValuesSeparator: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Gets or sets the character used as separator between data values.")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
public function get,set MultipleValuesSeparator : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Gets or sets the character used as separator between data values.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.string* get_MultipleValuesSeparator();
public: __property void set_MultipleValuesSeparator(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Gets or sets the character used as separator between data values.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.String^ MultipleValuesSeparator {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebValueList Class
WebValueList Members


Style Property

[image]
Intersoft WebGrid Documentation
Style Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > WebValueList Class : Style Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("The style applied to the WebValueList's Edit object.")>
Public Property Style As WebGridFormatStyle
Visual Basic (Usage) Copy Code
Dim instance As WebValueList
Dim value As WebGridFormatStyle

instance.Style = value

value = instance.Style
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("The style applied to the WebValueList's Edit object.")]
public WebGridFormatStyle Style {get; set;}
Delphi
public read-write property Style: WebGridFormatStyle;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("The style applied to the WebValueList's Edit object.")
public function get,set Style : WebGridFormatStyle
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("The style applied to the WebValueList's Edit object.")]
public: __property WebGridFormatStyle* get_Style();
public: __property void set_Style(
   WebGridFormatStyle* value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("The style applied to the WebValueList's Edit object.")]
public:
property WebGridFormatStyle^ Style {
   WebGridFormatStyle^ get();
   void set (    WebGridFormatStyle^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebValueList Class
WebValueList Members


AddNew Enumeration

[image]
Intersoft WebGrid Documentation
AddNew Enumeration
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : AddNew Enumeration

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Enum AddNew
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As AddNew
C#
public enum AddNew : System.Enum
Delphi
public enum AddNew = class(System.Enum)
JScript
public enum AddNew extends System.Enum
Managed Extensions for C++
__value public enum AddNew : public System.Enum
C++/CLI
public enum class AddNew : public System.Enum

Members

Member | Description
Default |
No |
Yes |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebGrid.AddNew

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebGrid Namespace


AggregateFunctions Enumeration

[image]
Intersoft WebGrid Documentation
AggregateFunctions Enumeration
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : AggregateFunctions Enumeration

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Enum AggregateFunctions
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As AggregateFunctions
C#
public enum AggregateFunctions : System.Enum
Delphi
public enum AggregateFunctions = class(System.Enum)
JScript
public enum AggregateFunctions extends System.Enum
Managed Extensions for C++
__value public enum AggregateFunctions : public System.Enum
C++/CLI
public enum class AggregateFunctions : public System.Enum

Members

Member | Description
Avg |
Count |
Custom |
Max |
Min |
None |
Sum |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebGrid.AggregateFunctions

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebGrid Namespace


Alignment Enumeration

[image]
Intersoft WebGrid Documentation
Alignment Enumeration
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : Alignment Enumeration

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Enum Alignment
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As Alignment
C#
public enum Alignment : System.Enum
Delphi
public enum Alignment = class(System.Enum)
JScript
public enum Alignment extends System.Enum
Managed Extensions for C++
__value public enum Alignment : public System.Enum
C++/CLI
public enum class Alignment : public System.Enum

Members

Member | Description
Center |
Left |
Right |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebGrid.Alignment

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebGrid Namespace


BaseEditorType Enumeration

[image]
Intersoft WebGrid Documentation
BaseEditorType Enumeration
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : BaseEditorType Enumeration

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Enum BaseEditorType
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As BaseEditorType
C#
public enum BaseEditorType : System.Enum
Delphi
public enum BaseEditorType = class(System.Enum)
JScript
public enum BaseEditorType extends System.Enum
Managed Extensions for C++
__value public enum BaseEditorType : public System.Enum
C++/CLI
public enum class BaseEditorType : public System.Enum

Members

Member | Description
Custom |
Textbox |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebGrid.BaseEditorType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebGrid Namespace


CaseSensitive Enumeration

[image]
Intersoft WebGrid Documentation
CaseSensitive Enumeration
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : CaseSensitive Enumeration

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Enum CaseSensitive
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As CaseSensitive
C#
public enum CaseSensitive : System.Enum
Delphi
public enum CaseSensitive = class(System.Enum)
JScript
public enum CaseSensitive extends System.Enum
Managed Extensions for C++
__value public enum CaseSensitive : public System.Enum
C++/CLI
public enum class CaseSensitive : public System.Enum

Members

Member | Description
Default |
No |
Yes |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebGrid.CaseSensitive

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebGrid Namespace


CellClick Enumeration

[image]
Intersoft WebGrid Documentation
CellClick Enumeration
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : CellClick Enumeration

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Enum CellClick
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As CellClick
C#
public enum CellClick : System.Enum
Delphi
public enum CellClick = class(System.Enum)
JScript
public enum CellClick extends System.Enum
Managed Extensions for C++
__value public enum CellClick : public System.Enum
C++/CLI
public enum class CellClick : public System.Enum

Members

Member | Description
CellSelect |
None |
NotSet |
RowSelect |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebGrid.CellClick

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebGrid Namespace


ChartPosition Enumeration

[image]
Intersoft WebGrid Documentation
ChartPosition Enumeration
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : ChartPosition Enumeration

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Enum ChartPosition
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As ChartPosition
C#
public enum ChartPosition : System.Enum
Delphi
public enum ChartPosition = class(System.Enum)
JScript
public enum ChartPosition extends System.Enum
Managed Extensions for C++
__value public enum ChartPosition : public System.Enum
C++/CLI
public enum class ChartPosition : public System.Enum

Members

Member | Description
Bottom |
Custom |
Top |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebGrid.ChartPosition

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebGrid Namespace


ChildrenType Enumeration

[image]
Intersoft WebGrid Documentation
ChildrenType Enumeration
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : ChildrenType Enumeration

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Enum ChildrenType
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As ChildrenType
C#
public enum ChildrenType : System.Enum
Delphi
public enum ChildrenType = class(System.Enum)
JScript
public enum ChildrenType extends System.Enum
Managed Extensions for C++
__value public enum ChildrenType : public System.Enum
C++/CLI
public enum class ChildrenType : public System.Enum

Members

Member | Description
Collection |
Group |
HierarchicalChild |
SelfReferenceChild |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebGrid.ChildrenType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebGrid Namespace


ChildRowAction Enumeration

[image]
Intersoft WebGrid Documentation
ChildRowAction Enumeration
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : ChildRowAction Enumeration

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Enum ChildRowAction
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As ChildRowAction
C#
public enum ChildRowAction : System.Enum
Delphi
public enum ChildRowAction = class(System.Enum)
JScript
public enum ChildRowAction extends System.Enum
Managed Extensions for C++
__value public enum ChildRowAction : public System.Enum
C++/CLI
public enum class ChildRowAction : public System.Enum

Members

Member | Description
DisplayMessageBox |
HideChildContent |
ShowChildContent |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebGrid.ChildRowAction

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebGrid Namespace


ClassicPagingExportMode Enumeration

[image]
Intersoft WebGrid Documentation
ClassicPagingExportMode Enumeration
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : ClassicPagingExportMode Enumeration

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Enum ClassicPagingExportMode
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As ClassicPagingExportMode
C#
public enum ClassicPagingExportMode : System.Enum
Delphi
public enum ClassicPagingExportMode = class(System.Enum)
JScript
public enum ClassicPagingExportMode extends System.Enum
Managed Extensions for C++
__value public enum ClassicPagingExportMode : public System.Enum
C++/CLI
public enum class ClassicPagingExportMode : public System.Enum

Members

Member | Description
ExportAllData |
ExportCurrentPageView |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebGrid.ClassicPagingExportMode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebGrid Namespace


ClassicPagingLoadMode Enumeration

[image]
Intersoft WebGrid Documentation
ClassicPagingLoadMode Enumeration
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : ClassicPagingLoadMode Enumeration

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Enum ClassicPagingLoadMode
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As ClassicPagingLoadMode
C#
public enum ClassicPagingLoadMode : System.Enum
Delphi
public enum ClassicPagingLoadMode = class(System.Enum)
JScript
public enum ClassicPagingLoadMode extends System.Enum
Managed Extensions for C++
__value public enum ClassicPagingLoadMode : public System.Enum
C++/CLI
public enum class ClassicPagingLoadMode : public System.Enum

Members

Member | Description
Automatic |
Custom |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebGrid.ClassicPagingLoadMode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebGrid Namespace


ClassicPagingRetrievalMode Enumeration

[image]
Intersoft WebGrid Documentation
ClassicPagingRetrievalMode Enumeration
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : ClassicPagingRetrievalMode Enumeration

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Enum ClassicPagingRetrievalMode
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As ClassicPagingRetrievalMode
C#
public enum ClassicPagingRetrievalMode : System.Enum
Delphi
public enum ClassicPagingRetrievalMode = class(System.Enum)
JScript
public enum ClassicPagingRetrievalMode extends System.Enum
Managed Extensions for C++
__value public enum ClassicPagingRetrievalMode : public System.Enum
C++/CLI
public enum class ClassicPagingRetrievalMode : public System.Enum

Members

Member | Description
ReturnPartialRows |
ReturnTopNRows |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebGrid.ClassicPagingRetrievalMode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebGrid Namespace


ClassicPagingStyle Enumeration

[image]
Intersoft WebGrid Documentation
ClassicPagingStyle Enumeration
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : ClassicPagingStyle Enumeration

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Enum ClassicPagingStyle
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As ClassicPagingStyle
C#
public enum ClassicPagingStyle : System.Enum
Delphi
public enum ClassicPagingStyle = class(System.Enum)
JScript
public enum ClassicPagingStyle extends System.Enum
Managed Extensions for C++
__value public enum ClassicPagingStyle : public System.Enum
C++/CLI
public enum class ClassicPagingStyle : public System.Enum

Members

Member | Description
FirstPrevNextLast |
SimpleDropDown |
Slider |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebGrid.ClassicPagingStyle

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebGrid Namespace


ClipboardCopyMode Enumeration

[image]
Intersoft WebGrid Documentation
ClipboardCopyMode Enumeration
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : ClipboardCopyMode Enumeration

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Enum ClipboardCopyMode
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As ClipboardCopyMode
C#
public enum ClipboardCopyMode : System.Enum
Delphi
public enum ClipboardCopyMode = class(System.Enum)
JScript
public enum ClipboardCopyMode extends System.Enum
Managed Extensions for C++
__value public enum ClipboardCopyMode : public System.Enum
C++/CLI
public enum class ClipboardCopyMode : public System.Enum

Members

Member | Description
Text |
Value |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebGrid.ClipboardCopyMode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebGrid Namespace


ColumnFilterType Enumeration

[image]
Intersoft WebGrid Documentation
ColumnFilterType Enumeration
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : ColumnFilterType Enumeration

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Enum ColumnFilterType
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As ColumnFilterType
C#
public enum ColumnFilterType : System.Enum
Delphi
public enum ColumnFilterType = class(System.Enum)
JScript
public enum ColumnFilterType extends System.Enum
Managed Extensions for C++
__value public enum ColumnFilterType : public System.Enum
C++/CLI
public enum class ColumnFilterType : public System.Enum

Members

Member | Description
Between |
Contain |
EqualTo |
GreaterThan |
GreaterThanOrEqualTo |
IsEmpty |
IsNull |
LessThan |
LessThanOrEqualTo |
Like |
NoFilter |
NotBetween |
NotContain |
NotEqualTo |
NotIsEmpty |
NotIsNull |
NotLike |
NotSet |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebGrid.ColumnFilterType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebGrid Namespace


ColumnFooterAggregateMode Enumeration

[image]
Intersoft WebGrid Documentation
ColumnFooterAggregateMode Enumeration
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : ColumnFooterAggregateMode Enumeration

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Enum ColumnFooterAggregateMode
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As ColumnFooterAggregateMode
C#
public enum ColumnFooterAggregateMode : System.Enum
Delphi
public enum ColumnFooterAggregateMode = class(System.Enum)
JScript
public enum ColumnFooterAggregateMode extends System.Enum
Managed Extensions for C++
__value public enum ColumnFooterAggregateMode : public System.Enum
C++/CLI
public enum class ColumnFooterAggregateMode : public System.Enum

Members

Member | Description
CalculateAllData |
CalculatePerPage |
ExternalDataSource |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebGrid.ColumnFooterAggregateMode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebGrid Namespace


ColumnFreezing Enumeration

[image]
Intersoft WebGrid Documentation
ColumnFreezing Enumeration
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : ColumnFreezing Enumeration

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Enum ColumnFreezing
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As ColumnFreezing
C#
public enum ColumnFreezing : System.Enum
Delphi
public enum ColumnFreezing = class(System.Enum)
JScript
public enum ColumnFreezing extends System.Enum
Managed Extensions for C++
__value public enum ColumnFreezing : public System.Enum
C++/CLI
public enum class ColumnFreezing : public System.Enum

Members

Member | Description
Default |
No |
Yes |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebGrid.ColumnFreezing

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebGrid Namespace


ColumnMove Enumeration

[image]
Intersoft WebGrid Documentation
ColumnMove Enumeration
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : ColumnMove Enumeration

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Enum ColumnMove
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As ColumnMove
C#
public enum ColumnMove : System.Enum
Delphi
public enum ColumnMove = class(System.Enum)
JScript
public enum ColumnMove extends System.Enum
Managed Extensions for C++
__value public enum ColumnMove : public System.Enum
C++/CLI
public enum class ColumnMove : public System.Enum

Members

Member | Description
Default |
No |
Yes |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebGrid.ColumnMove

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebGrid Namespace


ColumnSizing Enumeration

[image]
Intersoft WebGrid Documentation
ColumnSizing Enumeration
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : ColumnSizing Enumeration

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Enum ColumnSizing
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As ColumnSizing
C#
public enum ColumnSizing : System.Enum
Delphi
public enum ColumnSizing = class(System.Enum)
JScript
public enum ColumnSizing extends System.Enum
Managed Extensions for C++
__value public enum ColumnSizing : public System.Enum
C++/CLI
public enum class ColumnSizing : public System.Enum

Members

Member | Description
Default |
No |
Yes |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebGrid.ColumnSizing

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebGrid Namespace


ColumnType Enumeration

[image]
Intersoft WebGrid Documentation
ColumnType Enumeration
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : ColumnType Enumeration

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Enum ColumnType
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As ColumnType
C#
public enum ColumnType : System.Enum
Delphi
public enum ColumnType = class(System.Enum)
JScript
public enum ColumnType extends System.Enum
Managed Extensions for C++
__value public enum ColumnType : public System.Enum
C++/CLI
public enum class ColumnType : public System.Enum

Members

Member | Description
Button |
ButtonImage |
CheckBox |
Custom |
HyperLink |
Image |
ImageAndText |
Template |
Text |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebGrid.ColumnType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebGrid Namespace


ColumnVisibility Enumeration

[image]
Intersoft WebGrid Documentation
ColumnVisibility Enumeration
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : ColumnVisibility Enumeration

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Enum ColumnVisibility
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As ColumnVisibility
C#
public enum ColumnVisibility : System.Enum
Delphi
public enum ColumnVisibility = class(System.Enum)
JScript
public enum ColumnVisibility extends System.Enum
Managed Extensions for C++
__value public enum ColumnVisibility : public System.Enum
C++/CLI
public enum class ColumnVisibility : public System.Enum

Members

Member | Description
Default |
No |
Yes |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebGrid.ColumnVisibility

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebGrid Namespace


ControlType Enumeration

[image]
Intersoft WebGrid Documentation
ControlType Enumeration
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : ControlType Enumeration

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Enum ControlType
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As ControlType
C#
public enum ControlType : System.Enum
Delphi
public enum ControlType = class(System.Enum)
JScript
public enum ControlType extends System.Enum
Managed Extensions for C++
__value public enum ControlType : public System.Enum
C++/CLI
public enum class ControlType : public System.Enum

Members

Member | Description
DHTMLClientControl |
ServerControl |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebGrid.ControlType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebGrid Namespace


DefaultStyleKind Enumeration

[image]
Intersoft WebGrid Documentation
DefaultStyleKind Enumeration
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : DefaultStyleKind Enumeration

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Enum DefaultStyleKind
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As DefaultStyleKind
C#
public enum DefaultStyleKind : System.Enum
Delphi
public enum DefaultStyleKind = class(System.Enum)
JScript
public enum DefaultStyleKind extends System.Enum
Managed Extensions for C++
__value public enum DefaultStyleKind : public System.Enum
C++/CLI
public enum class DefaultStyleKind : public System.Enum

Members

Member | Description
Black |
Elegant |
Silver |
Standard |
Win7 |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebGrid.DefaultStyleKind

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebGrid Namespace


Delete Enumeration

[image]
Intersoft WebGrid Documentation
Delete Enumeration
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : Delete Enumeration

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Enum Delete
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As Delete
C#
public enum Delete : System.Enum
Delphi
public enum Delete = class(System.Enum)
JScript
public enum Delete extends System.Enum
Managed Extensions for C++
__value public enum Delete : public System.Enum
C++/CLI
public enum class Delete : public System.Enum

Members

Member | Description
Default |
No |
Yes |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebGrid.Delete

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebGrid Namespace


DropdownButtonType Enumeration

[image]
Intersoft WebGrid Documentation
DropdownButtonType Enumeration
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : DropdownButtonType Enumeration

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Enum DropdownButtonType
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As DropdownButtonType
C#
public enum DropdownButtonType : System.Enum
Delphi
public enum DropdownButtonType = class(System.Enum)
JScript
public enum DropdownButtonType extends System.Enum
Managed Extensions for C++
__value public enum DropdownButtonType : public System.Enum
C++/CLI
public enum class DropdownButtonType : public System.Enum

Members

Member | Description
Custom |
Image |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebGrid.DropdownButtonType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebGrid Namespace


Edit Enumeration

[image]
Intersoft WebGrid Documentation
Edit Enumeration
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : Edit Enumeration

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Enum Edit
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As Edit
C#
public enum Edit : System.Enum
Delphi
public enum Edit = class(System.Enum)
JScript
public enum Edit extends System.Enum
Managed Extensions for C++
__value public enum Edit : public System.Enum
C++/CLI
public enum class Edit : public System.Enum

Members

Member | Description
Default |
No |
Yes |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebGrid.Edit

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebGrid Namespace


EditKeyMode Enumeration

[image]
Intersoft WebGrid Documentation
EditKeyMode Enumeration
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : EditKeyMode Enumeration

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Enum EditKeyMode
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As EditKeyMode
C#
public enum EditKeyMode : System.Enum
Delphi
public enum EditKeyMode = class(System.Enum)
JScript
public enum EditKeyMode extends System.Enum
Managed Extensions for C++
__value public enum EditKeyMode : public System.Enum
C++/CLI
public enum class EditKeyMode : public System.Enum

Members

Member | Description
Enter |
ShiftEnter |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebGrid.EditKeyMode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebGrid Namespace


EditType Enumeration

[image]
Intersoft WebGrid Documentation
EditType Enumeration
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : EditType Enumeration

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Enum EditType
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As EditType
C#
public enum EditType : System.Enum
Delphi
public enum EditType = class(System.Enum)
JScript
public enum EditType extends System.Enum
Managed Extensions for C++
__value public enum EditType : public System.Enum
C++/CLI
public enum class EditType : public System.Enum

Members

Member | Description
CalendarCombo |
CalendarDropdown |
Checkbox |
Custom |
DropdownList |
MultilineTextbox |
NoEdit |
ResizableTextbox |
TextBox |
WebComboNET |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebGrid.EditType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebGrid Namespace


Export Enumeration

[image]
Intersoft WebGrid Documentation
Export Enumeration
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : Export Enumeration

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Enum Export
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As Export
C#
public enum Export : System.Enum
Delphi
public enum Export = class(System.Enum)
JScript
public enum Export extends System.Enum
Managed Extensions for C++
__value public enum Export : public System.Enum
C++/CLI
public enum class Export : public System.Enum

Members

Member | Description
Default |
No |
Yes |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebGrid.Export

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebGrid Namespace


Filter Enumeration

[image]
Intersoft WebGrid Documentation
Filter Enumeration
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : Filter Enumeration

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Enum Filter
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As Filter
C#
public enum Filter : System.Enum
Delphi
public enum Filter = class(System.Enum)
JScript
public enum Filter extends System.Enum
Managed Extensions for C++
__value public enum Filter : public System.Enum
C++/CLI
public enum class Filter : public System.Enum

Members

Member | Description
Default |
No |
Yes |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebGrid.Filter

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebGrid Namespace


FilterEditType Enumeration

[image]
Intersoft WebGrid Documentation
FilterEditType Enumeration
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : FilterEditType Enumeration

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Enum FilterEditType
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As FilterEditType
C#
public enum FilterEditType : System.Enum
Delphi
public enum FilterEditType = class(System.Enum)
JScript
public enum FilterEditType extends System.Enum
Managed Extensions for C++
__value public enum FilterEditType : public System.Enum
C++/CLI
public enum class FilterEditType : public System.Enum

Members

Member | Description
CalendarCombo |
Checkbox |
DropdownList |
NoEdit |
SameAsEditType |
TextBox |
WebComboNET |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebGrid.FilterEditType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebGrid Namespace


FilterKeyMode Enumeration

[image]
Intersoft WebGrid Documentation
FilterKeyMode Enumeration
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : FilterKeyMode Enumeration

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Enum FilterKeyMode
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As FilterKeyMode
C#
public enum FilterKeyMode : System.Enum
Delphi
public enum FilterKeyMode = class(System.Enum)
JScript
public enum FilterKeyMode extends System.Enum
Managed Extensions for C++
__value public enum FilterKeyMode : public System.Enum
C++/CLI
public enum class FilterKeyMode : public System.Enum

Members

Member | Description
Enter |
ShiftEnter |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebGrid.FilterKeyMode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebGrid Namespace


GridInitialView Enumeration

[image]
Intersoft WebGrid Documentation
GridInitialView Enumeration
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : GridInitialView Enumeration

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Enum GridInitialView
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As GridInitialView
C#
public enum GridInitialView : System.Enum
Delphi
public enum GridInitialView = class(System.Enum)
JScript
public enum GridInitialView extends System.Enum
Managed Extensions for C++
__value public enum GridInitialView : public System.Enum
C++/CLI
public enum class GridInitialView : public System.Enum

Members

Member | Description
Both |
GridView |
PivotChartView |
PivotChartViewExclusive |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebGrid.GridInitialView

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebGrid Namespace


GridLines Enumeration

[image]
Intersoft WebGrid Documentation
GridLines Enumeration
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : GridLines Enumeration

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Enum GridLines
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As GridLines
C#
public enum GridLines : System.Enum
Delphi
public enum GridLines = class(System.Enum)
JScript
public enum GridLines extends System.Enum
Managed Extensions for C++
__value public enum GridLines : public System.Enum
C++/CLI
public enum class GridLines : public System.Enum

Members

Member | Description
Both |
Default |
Horizontal |
None |
Vertical |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebGrid.GridLines

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebGrid Namespace


GridPrintLayoutMode Enumeration

[image]
Intersoft WebGrid Documentation
GridPrintLayoutMode Enumeration
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : GridPrintLayoutMode Enumeration

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Enum GridPrintLayoutMode
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As GridPrintLayoutMode
C#
public enum GridPrintLayoutMode : System.Enum
Delphi
public enum GridPrintLayoutMode = class(System.Enum)
JScript
public enum GridPrintLayoutMode extends System.Enum
Managed Extensions for C++
__value public enum GridPrintLayoutMode : public System.Enum
C++/CLI
public enum class GridPrintLayoutMode : public System.Enum

Members

Member | Description
AsDisplayedInBrowser |
ExpandAllRowsToVisible |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebGrid.GridPrintLayoutMode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebGrid Namespace


Grouping Enumeration

[image]
Intersoft WebGrid Documentation
Grouping Enumeration
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : Grouping Enumeration

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Enum Grouping
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As Grouping
C#
public enum Grouping : System.Enum
Delphi
public enum Grouping = class(System.Enum)
JScript
public enum Grouping extends System.Enum
Managed Extensions for C++
__value public enum Grouping : public System.Enum
C++/CLI
public enum class Grouping : public System.Enum

Members

Member | Description
Default |
No |
Yes |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebGrid.Grouping

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebGrid Namespace


GroupInterval Enumeration

[image]
Intersoft WebGrid Documentation
GroupInterval Enumeration
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : GroupInterval Enumeration

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Enum GroupInterval
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As GroupInterval
C#
public enum GroupInterval : System.Enum
Delphi
public enum GroupInterval = class(System.Enum)
JScript
public enum GroupInterval extends System.Enum
Managed Extensions for C++
__value public enum GroupInterval : public System.Enum
C++/CLI
public enum class GroupInterval : public System.Enum

Members

Member | Description
Alphabetical |
Date |
Default |
Hour |
Minute |
Month |
NamedPeriod |
Quarterly |
ShortTime |
Text |
Value |
Year |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebGrid.GroupInterval

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebGrid Namespace


GroupMode Enumeration

[image]
Intersoft WebGrid Documentation
GroupMode Enumeration
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : GroupMode Enumeration

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Enum GroupMode
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As GroupMode
C#
public enum GroupMode : System.Enum
Delphi
public enum GroupMode = class(System.Enum)
JScript
public enum GroupMode extends System.Enum
Managed Extensions for C++
__value public enum GroupMode : public System.Enum
C++/CLI
public enum class GroupMode : public System.Enum

Members

Member | Description
Collapsed |
Default |
Expanded |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebGrid.GroupMode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebGrid Namespace


HeaderClick Enumeration

[image]
Intersoft WebGrid Documentation
HeaderClick Enumeration
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : HeaderClick Enumeration

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Enum HeaderClick
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As HeaderClick
C#
public enum HeaderClick : System.Enum
Delphi
public enum HeaderClick = class(System.Enum)
JScript
public enum HeaderClick extends System.Enum
Managed Extensions for C++
__value public enum HeaderClick : public System.Enum
C++/CLI
public enum class HeaderClick : public System.Enum

Members

Member | Description
NotSet |
SortMulti |
SortSingle |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebGrid.HeaderClick

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebGrid Namespace


HideColumns Enumeration

[image]
Intersoft WebGrid Documentation
HideColumns Enumeration
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : HideColumns Enumeration

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Enum HideColumns
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As HideColumns
C#
public enum HideColumns : System.Enum
Delphi
public enum HideColumns = class(System.Enum)
JScript
public enum HideColumns extends System.Enum
Managed Extensions for C++
__value public enum HideColumns : public System.Enum
C++/CLI
public enum class HideColumns : public System.Enum

Members

Member | Description
Default |
No |
Yes |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebGrid.HideColumns

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebGrid Namespace


HierarchicalOperation Enumeration

[image]
Intersoft WebGrid Documentation
HierarchicalOperation Enumeration
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : HierarchicalOperation Enumeration

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Enum HierarchicalOperation
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As HierarchicalOperation
C#
public enum HierarchicalOperation : System.Enum
Delphi
public enum HierarchicalOperation = class(System.Enum)
JScript
public enum HierarchicalOperation extends System.Enum
Managed Extensions for C++
__value public enum HierarchicalOperation : public System.Enum
C++/CLI
public enum class HierarchicalOperation : public System.Enum

Members

Member | Description
LoadOnDemand |
Preload |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebGrid.HierarchicalOperation

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebGrid Namespace


HtmlHeaderScope Enumeration

[image]
Intersoft WebGrid Documentation
HtmlHeaderScope Enumeration
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : HtmlHeaderScope Enumeration

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Enum HtmlHeaderScope
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As HtmlHeaderScope
C#
public enum HtmlHeaderScope : System.Enum
Delphi
public enum HtmlHeaderScope = class(System.Enum)
JScript
public enum HtmlHeaderScope extends System.Enum
Managed Extensions for C++
__value public enum HtmlHeaderScope : public System.Enum
C++/CLI
public enum class HtmlHeaderScope : public System.Enum

Members

Member | Description
Col |
ColGroup |
None |
Row |
RowGroup |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebGrid.HtmlHeaderScope

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebGrid Namespace


HyperlinkTarget Enumeration

[image]
Intersoft WebGrid Documentation
HyperlinkTarget Enumeration
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : HyperlinkTarget Enumeration

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Enum HyperlinkTarget
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As HyperlinkTarget
C#
public enum HyperlinkTarget : System.Enum
Delphi
public enum HyperlinkTarget = class(System.Enum)
JScript
public enum HyperlinkTarget extends System.Enum
Managed Extensions for C++
__value public enum HyperlinkTarget : public System.Enum
C++/CLI
public enum class HyperlinkTarget : public System.Enum

Members

Member | Description
Blank |
Custom |
Parent |
Search |
Self |
Top |
UseBase |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebGrid.HyperlinkTarget

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebGrid Namespace


InProgressUIBehavior Enumeration

[image]
Intersoft WebGrid Documentation
InProgressUIBehavior Enumeration
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : InProgressUIBehavior Enumeration

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Enum InProgressUIBehavior
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As InProgressUIBehavior
C#
public enum InProgressUIBehavior : System.Enum
Delphi
public enum InProgressUIBehavior = class(System.Enum)
JScript
public enum InProgressUIBehavior extends System.Enum
Managed Extensions for C++
__value public enum InProgressUIBehavior : public System.Enum
C++/CLI
public enum class InProgressUIBehavior : public System.Enum

Members

Member | Description
ChangeCursorToHourGlass |
DisplayMessageBox |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebGrid.InProgressUIBehavior

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebGrid Namespace


LanguageMode Enumeration

[image]
Intersoft WebGrid Documentation
LanguageMode Enumeration
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : LanguageMode Enumeration

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Enum LanguageMode
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As LanguageMode
C#
public enum LanguageMode : System.Enum
Delphi
public enum LanguageMode = class(System.Enum)
JScript
public enum LanguageMode extends System.Enum
Managed Extensions for C++
__value public enum LanguageMode : public System.Enum
C++/CLI
public enum class LanguageMode : public System.Enum

Members

Member | Description
UseCulture |
UseCustom |
UseDefault |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebGrid.LanguageMode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebGrid Namespace


LostFocusMode Enumeration

[image]
Intersoft WebGrid Documentation
LostFocusMode Enumeration
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : LostFocusMode Enumeration

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Enum LostFocusMode
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As LostFocusMode
C#
public enum LostFocusMode : System.Enum
Delphi
public enum LostFocusMode = class(System.Enum)
JScript
public enum LostFocusMode extends System.Enum
Managed Extensions for C++
__value public enum LostFocusMode : public System.Enum
C++/CLI
public enum class LostFocusMode : public System.Enum

Members

Member | Description
AlwaysPrompt |
AlwaysUpdate |
NeverUpdate |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebGrid.LostFocusMode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebGrid Namespace


MultipleSelection Enumeration

[image]
Intersoft WebGrid Documentation
MultipleSelection Enumeration
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : MultipleSelection Enumeration

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Enum MultipleSelection
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As MultipleSelection
C#
public enum MultipleSelection : System.Enum
Delphi
public enum MultipleSelection = class(System.Enum)
JScript
public enum MultipleSelection extends System.Enum
Managed Extensions for C++
__value public enum MultipleSelection : public System.Enum
C++/CLI
public enum class MultipleSelection : public System.Enum

Members

Member | Description
Default |
No |
Yes |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebGrid.MultipleSelection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebGrid Namespace


NewRowEditType Enumeration

[image]
Intersoft WebGrid Documentation
NewRowEditType Enumeration
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : NewRowEditType Enumeration

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Enum NewRowEditType
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As NewRowEditType
C#
public enum NewRowEditType : System.Enum
Delphi
public enum NewRowEditType = class(System.Enum)
JScript
public enum NewRowEditType extends System.Enum
Managed Extensions for C++
__value public enum NewRowEditType : public System.Enum
C++/CLI
public enum class NewRowEditType : public System.Enum

Members

Member | Description
CalendarCombo |
Checkbox |
DropdownList |
NoEdit |
SameAsEditType |
TextBox |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebGrid.NewRowEditType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebGrid Namespace


PageOrientation Enumeration

[image]
Intersoft WebGrid Documentation
PageOrientation Enumeration
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : PageOrientation Enumeration

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Enum PageOrientation
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As PageOrientation
C#
public enum PageOrientation : System.Enum
Delphi
public enum PageOrientation = class(System.Enum)
JScript
public enum PageOrientation extends System.Enum
Managed Extensions for C++
__value public enum PageOrientation : public System.Enum
C++/CLI
public enum class PageOrientation : public System.Enum

Members

Member | Description
Default |
Landscape |
Portrait |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebGrid.PageOrientation

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebGrid Namespace


PagingMode Enumeration

[image]
Intersoft WebGrid Documentation
PagingMode Enumeration
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : PagingMode Enumeration

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Enum PagingMode
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As PagingMode
C#
public enum PagingMode : System.Enum
Delphi
public enum PagingMode = class(System.Enum)
JScript
public enum PagingMode extends System.Enum
Managed Extensions for C++
__value public enum PagingMode : public System.Enum
C++/CLI
public enum class PagingMode : public System.Enum

Members

Member | Description
ClassicPaging |
None |
VirtualLoad |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebGrid.PagingMode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebGrid Namespace


ParentRootMode Enumeration

[image]
Intersoft WebGrid Documentation
ParentRootMode Enumeration
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : ParentRootMode Enumeration

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Enum ParentRootMode
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As ParentRootMode
C#
public enum ParentRootMode : System.Enum
Delphi
public enum ParentRootMode = class(System.Enum)
JScript
public enum ParentRootMode extends System.Enum
Managed Extensions for C++
__value public enum ParentRootMode : public System.Enum
C++/CLI
public enum class ParentRootMode : public System.Enum

Members

Member | Description
NullValue |
SelfReferencingNode |
UseParentRootValue |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebGrid.ParentRootMode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebGrid Namespace


PersistenceType Enumeration

[image]
Intersoft WebGrid Documentation
PersistenceType Enumeration
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : PersistenceType Enumeration

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Enum PersistenceType
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As PersistenceType
C#
public enum PersistenceType : System.Enum
Delphi
public enum PersistenceType = class(System.Enum)
JScript
public enum PersistenceType extends System.Enum
Managed Extensions for C++
__value public enum PersistenceType : public System.Enum
C++/CLI
public enum class PersistenceType : public System.Enum

Members

Member | Description
DesignerLevel |
GridLevel |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebGrid.PersistenceType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebGrid Namespace


PostbackMode Enumeration

[image]
Intersoft WebGrid Documentation
PostbackMode Enumeration
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : PostbackMode Enumeration

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Enum PostbackMode
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As PostbackMode
C#
public enum PostbackMode : System.Enum
Delphi
public enum PostbackMode = class(System.Enum)
JScript
public enum PostbackMode extends System.Enum
Managed Extensions for C++
__value public enum PostbackMode : public System.Enum
C++/CLI
public enum class PostbackMode : public System.Enum

Members

Member | Description
FullPagePostback |
OnTheFly |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebGrid.PostbackMode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebGrid Namespace


Print Enumeration

[image]
Intersoft WebGrid Documentation
Print Enumeration
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : Print Enumeration

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Enum Print
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As Print
C#
public enum Print : System.Enum
Delphi
public enum Print = class(System.Enum)
JScript
public enum Print extends System.Enum
Managed Extensions for C++
__value public enum Print : public System.Enum
C++/CLI
public enum class Print : public System.Enum

Members

Member | Description
Default |
No |
Yes |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebGrid.Print

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebGrid Namespace


ReportFileFormat Enumeration

[image]
Intersoft WebGrid Documentation
ReportFileFormat Enumeration
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : ReportFileFormat Enumeration

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Enum ReportFileFormat
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As ReportFileFormat
C#
public enum ReportFileFormat : System.Enum
Delphi
public enum ReportFileFormat = class(System.Enum)
JScript
public enum ReportFileFormat extends System.Enum
Managed Extensions for C++
__value public enum ReportFileFormat : public System.Enum
C++/CLI
public enum class ReportFileFormat : public System.Enum

Members

Member | Description
ExecutionTime |
GUID |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebGrid.ReportFileFormat

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebGrid Namespace


RestorationLevel Enumeration

[image]
Intersoft WebGrid Documentation
RestorationLevel Enumeration
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : RestorationLevel Enumeration

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Enum RestorationLevel
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As RestorationLevel
C#
public enum RestorationLevel : System.Enum
Delphi
public enum RestorationLevel = class(System.Enum)
JScript
public enum RestorationLevel extends System.Enum
Managed Extensions for C++
__value public enum RestorationLevel : public System.Enum
C++/CLI
public enum class RestorationLevel : public System.Enum

Members

Member | Description
High |
Low |
Medium |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebGrid.RestorationLevel

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebGrid Namespace


RestoreSelection Enumeration

[image]
Intersoft WebGrid Documentation
RestoreSelection Enumeration
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : RestoreSelection Enumeration

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Enum RestoreSelection
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As RestoreSelection
C#
public enum RestoreSelection : System.Enum
Delphi
public enum RestoreSelection = class(System.Enum)
JScript
public enum RestoreSelection extends System.Enum
Managed Extensions for C++
__value public enum RestoreSelection : public System.Enum
C++/CLI
public enum class RestoreSelection : public System.Enum

Members

Member | Description
All |
ChildTableOnly |
Disabled |
RootTableOnly |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebGrid.RestoreSelection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebGrid Namespace


RowChangedAction Enumeration

[image]
Intersoft WebGrid Documentation
RowChangedAction Enumeration
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : RowChangedAction Enumeration

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Enum RowChangedAction
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As RowChangedAction
C#
public enum RowChangedAction : System.Enum
Delphi
public enum RowChangedAction = class(System.Enum)
JScript
public enum RowChangedAction extends System.Enum
Managed Extensions for C++
__value public enum RowChangedAction : public System.Enum
C++/CLI
public enum class RowChangedAction : public System.Enum

Members

Member | Description
FullPagePostback |
None |
OnTheFlyPostback |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebGrid.RowChangedAction

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebGrid Namespace


RowHeaders Enumeration

[image]
Intersoft WebGrid Documentation
RowHeaders Enumeration
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : RowHeaders Enumeration

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Enum RowHeaders
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As RowHeaders
C#
public enum RowHeaders : System.Enum
Delphi
public enum RowHeaders = class(System.Enum)
JScript
public enum RowHeaders extends System.Enum
Managed Extensions for C++
__value public enum RowHeaders : public System.Enum
C++/CLI
public enum class RowHeaders : public System.Enum

Members

Member | Description
Default |
No |
Yes |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebGrid.RowHeaders

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebGrid Namespace


RowHighlightType Enumeration

[image]
Intersoft WebGrid Documentation
RowHighlightType Enumeration
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : RowHighlightType Enumeration

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Enum RowHighlightType
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As RowHighlightType
C#
public enum RowHighlightType : System.Enum
Delphi
public enum RowHighlightType = class(System.Enum)
JScript
public enum RowHighlightType extends System.Enum
Managed Extensions for C++
__value public enum RowHighlightType : public System.Enum
C++/CLI
public enum class RowHighlightType : public System.Enum

Members

Member | Description
BackgroundOnly |
EntireRow |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebGrid.RowHighlightType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebGrid Namespace


RowLayoutMode Enumeration

[image]
Intersoft WebGrid Documentation
RowLayoutMode Enumeration
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : RowLayoutMode Enumeration

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Enum RowLayoutMode
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As RowLayoutMode
C#
public enum RowLayoutMode : System.Enum
Delphi
public enum RowLayoutMode = class(System.Enum)
JScript
public enum RowLayoutMode extends System.Enum
Managed Extensions for C++
__value public enum RowLayoutMode : public System.Enum
C++/CLI
public enum class RowLayoutMode : public System.Enum

Members

Member | Description
ColumnSet |
PlainColumn |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebGrid.RowLayoutMode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebGrid Namespace


RowLayoutSpan Enumeration

[image]
Intersoft WebGrid Documentation
RowLayoutSpan Enumeration
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : RowLayoutSpan Enumeration

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Enum RowLayoutSpan
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As RowLayoutSpan
C#
public enum RowLayoutSpan : System.Enum
Delphi
public enum RowLayoutSpan = class(System.Enum)
JScript
public enum RowLayoutSpan extends System.Enum
Managed Extensions for C++
__value public enum RowLayoutSpan : public System.Enum
C++/CLI
public enum class RowLayoutSpan : public System.Enum

Members

Member | Description
Column |
None |
Row |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebGrid.RowLayoutSpan

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebGrid Namespace


RowState Enumeration

[image]
Intersoft WebGrid Documentation
RowState Enumeration
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : RowState Enumeration

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.FlagsAttribute()>
Public Enum RowState
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As RowState
C#
[System.FlagsAttribute()]
public enum RowState : System.Enum
Delphi
public enum RowState = class(System.Enum)
JScript
System.FlagsAttribute()
public enum RowState extends System.Enum
Managed Extensions for C++
[System.FlagsAttribute()]
__value public enum RowState : public System.Enum
C++/CLI
[System.FlagsAttribute()]
public enum class RowState : public System.Enum

Members

Member | Description
Added |
Deleted |
Modified |
Unmodified |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebGrid.RowState

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebGrid Namespace


RowType Enumeration

[image]
Intersoft WebGrid Documentation
RowType Enumeration
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : RowType Enumeration

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Enum RowType
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As RowType
C#
public enum RowType : System.Enum
Delphi
public enum RowType = class(System.Enum)
JScript
public enum RowType extends System.Enum
Managed Extensions for C++
__value public enum RowType : public System.Enum
C++/CLI
public enum class RowType : public System.Enum

Members

Member | Description
GroupHeader |
NewRecord |
Record |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebGrid.RowType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebGrid Namespace


SchemaRetrievalMode Enumeration

[image]
Intersoft WebGrid Documentation
SchemaRetrievalMode Enumeration
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : SchemaRetrievalMode Enumeration

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Enum SchemaRetrievalMode
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As SchemaRetrievalMode
C#
public enum SchemaRetrievalMode : System.Enum
Delphi
public enum SchemaRetrievalMode = class(System.Enum)
JScript
public enum SchemaRetrievalMode extends System.Enum
Managed Extensions for C++
__value public enum SchemaRetrievalMode : public System.Enum
C++/CLI
public enum class SchemaRetrievalMode : public System.Enum

Members

Member | Description
Auto |
UseISDataSource |
UseWebGrid |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebGrid.SchemaRetrievalMode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebGrid Namespace


SelectColumns Enumeration

[image]
Intersoft WebGrid Documentation
SelectColumns Enumeration
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : SelectColumns Enumeration

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Enum SelectColumns
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As SelectColumns
C#
public enum SelectColumns : System.Enum
Delphi
public enum SelectColumns = class(System.Enum)
JScript
public enum SelectColumns extends System.Enum
Managed Extensions for C++
__value public enum SelectColumns : public System.Enum
C++/CLI
public enum class SelectColumns : public System.Enum

Members

Member | Description
Default |
No |
Yes |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebGrid.SelectColumns

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebGrid Namespace


Sorting Enumeration

[image]
Intersoft WebGrid Documentation
Sorting Enumeration
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : Sorting Enumeration

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Enum Sorting
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As Sorting
C#
public enum Sorting : System.Enum
Delphi
public enum Sorting = class(System.Enum)
JScript
public enum Sorting extends System.Enum
Managed Extensions for C++
__value public enum Sorting : public System.Enum
C++/CLI
public enum class Sorting : public System.Enum

Members

Member | Description
Default |
No |
Yes |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebGrid.Sorting

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebGrid Namespace


SortOrder Enumeration

[image]
Intersoft WebGrid Documentation
SortOrder Enumeration
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : SortOrder Enumeration

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Enum SortOrder
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As SortOrder
C#
public enum SortOrder : System.Enum
Delphi
public enum SortOrder = class(System.Enum)
JScript
public enum SortOrder extends System.Enum
Managed Extensions for C++
__value public enum SortOrder : public System.Enum
C++/CLI
public enum class SortOrder : public System.Enum

Members

Member | Description
Ascending |
Descending |
Disabled |
None |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebGrid.SortOrder

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebGrid Namespace


TargetObjectType Enumeration

[image]
Intersoft WebGrid Documentation
TargetObjectType Enumeration
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : TargetObjectType Enumeration

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Enum TargetObjectType
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As TargetObjectType
C#
public enum TargetObjectType : System.Enum
Delphi
public enum TargetObjectType = class(System.Enum)
JScript
public enum TargetObjectType extends System.Enum
Managed Extensions for C++
__value public enum TargetObjectType : public System.Enum
C++/CLI
public enum class TargetObjectType : public System.Enum

Members

Member | Description
Cell |
Row |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebGrid.TargetObjectType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebGrid Namespace


ValueListFilter Enumeration

[image]
Intersoft WebGrid Documentation
ValueListFilter Enumeration
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : ValueListFilter Enumeration

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Enum ValueListFilter
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As ValueListFilter
C#
public enum ValueListFilter : System.Enum
Delphi
public enum ValueListFilter = class(System.Enum)
JScript
public enum ValueListFilter extends System.Enum
Managed Extensions for C++
__value public enum ValueListFilter : public System.Enum
C++/CLI
public enum class ValueListFilter : public System.Enum

Members

Member | Description
Default |
No |
Yes |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebGrid.ValueListFilter

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebGrid Namespace


ValueListSorting Enumeration

[image]
Intersoft WebGrid Documentation
ValueListSorting Enumeration
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : ValueListSorting Enumeration

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Enum ValueListSorting
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As ValueListSorting
C#
public enum ValueListSorting : System.Enum
Delphi
public enum ValueListSorting = class(System.Enum)
JScript
public enum ValueListSorting extends System.Enum
Managed Extensions for C++
__value public enum ValueListSorting : public System.Enum
C++/CLI
public enum class ValueListSorting : public System.Enum

Members

Member | Description
Default |
No |
Yes |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebGrid.ValueListSorting

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebGrid Namespace


VirtualLoadMode Enumeration

[image]
Intersoft WebGrid Documentation
VirtualLoadMode Enumeration
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : VirtualLoadMode Enumeration

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Enum VirtualLoadMode
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As VirtualLoadMode
C#
public enum VirtualLoadMode : System.Enum
Delphi
public enum VirtualLoadMode = class(System.Enum)
JScript
public enum VirtualLoadMode extends System.Enum
Managed Extensions for C++
__value public enum VirtualLoadMode : public System.Enum
C++/CLI
public enum class VirtualLoadMode : public System.Enum

Members

Member | Description
Custom |
Default |
LargeData |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebGrid.VirtualLoadMode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebGrid Namespace


WebGridDesigner.DialogType Enumeration

[image]
Intersoft WebGrid Documentation
WebGridDesigner.DialogType Enumeration
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : WebGridDesigner.DialogType Enumeration

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Enum WebGridDesigner.DialogType
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As WebGridDesigner.DialogType
C#
public enum WebGridDesigner.DialogType : System.Enum
Delphi
public enum WebGridDesigner.DialogType = class(System.Enum)
JScript
public enum WebGridDesigner.DialogType extends System.Enum
Managed Extensions for C++
__value public enum WebGridDesigner.DialogType : public System.Enum
C++/CLI
public enum class WebGridDesigner.DialogType : public System.Enum

Members

Member | Description
DataSourceAdvanced |
PivotCharting |
PopularSettings |
QuickStart |
Styles |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebGrid.WebGridDesigner.DialogType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebGrid Namespace


DynARFonts Structure

[image]
Intersoft WebGrid Documentation
DynARFonts Structure
Members See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : DynARFonts Structure

Glossary Item Box

Object Model

DynARFonts Structure

Syntax

Visual Basic (Declaration)
Public Structure DynARFonts
   Inherits System.ValueType
Visual Basic (Usage) Copy Code
Dim instance As DynARFonts
C#
public struct DynARFonts : System.ValueType
Delphi
public type DynARFonts = class(System.ValueType)
JScript
In JScript, you can use structures in other assemblies, but you cannot define your own.
Managed Extensions for C++
public __value struct DynARFonts : public System.ValueType
C++/CLI
public value class DynARFonts : public System.ValueType

Inheritance Hierarchy

System.Object
System.ValueType
ISNet.WebUI.WebGrid.DynARFonts

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DynARFonts Members
ISNet.WebUI.WebGrid Namespace


DynARFonts Structure Members

[image]
Intersoft WebGrid Documentation
DynARFonts Structure Members
See Also Fields Send Feedback
ISNet.WebUI.WebGrid Namespace : DynARFonts Structure

Glossary Item Box

The following tables list the members exposed by DynARFonts.

Public Constructors

 | Name | Description
Public Constructor | DynARFonts Constructor |
Top

Public Fields

 | Name | Description
Public Field | DateCaptionFont |
Public Field | DetailFont |
Public Field | FooterFont |
Public Field | GroupFooterFont |
Public Field | GroupHeaderFont |
Public Field | HeaderFont |
Public Field | PageCountCaptionFont |
Public Field | ParentInfoFont |
Public Field | TitleFont |
Top

See Also

Reference

DynARFonts Structure
ISNet.WebUI.WebGrid Namespace


DynARFonts Constructor

[image]
Intersoft WebGrid Documentation
DynARFonts Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > DynARFonts Structure : DynARFonts Constructor

titleFont
parentInfoFont
headerFont
groupHeaderFont
detailFont
groupFooterFont
footerFont
dateCaptionFont
pageCountCaptionFont

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal titleFont As System.Object, _
   ByVal parentInfoFont As System.Object, _
   ByVal headerFont As System.Object, _
   ByVal groupHeaderFont As System.Object, _
   ByVal detailFont As System.Object, _
   ByVal groupFooterFont As System.Object, _
   ByVal footerFont As System.Object, _
   ByVal dateCaptionFont As System.Object, _
   ByVal pageCountCaptionFont As System.Object _
)
Visual Basic (Usage) Copy Code
Dim titleFont As System.Object
Dim parentInfoFont As System.Object
Dim headerFont As System.Object
Dim groupHeaderFont As System.Object
Dim detailFont As System.Object
Dim groupFooterFont As System.Object
Dim footerFont As System.Object
Dim dateCaptionFont As System.Object
Dim pageCountCaptionFont As System.Object

Dim instance As New DynARFonts(titleFont, parentInfoFont, headerFont, groupHeaderFont, detailFont, groupFooterFont, footerFont, dateCaptionFont, pageCountCaptionFont)
C#
public DynARFonts(
   System.object titleFont,
   System.object parentInfoFont,
   System.object headerFont,
   System.object groupHeaderFont,
   System.object detailFont,
   System.object groupFooterFont,
   System.object footerFont,
   System.object dateCaptionFont,
   System.object pageCountCaptionFont
)
Delphi
public DynARFonts(
    titleFont: System.TObject;
    parentInfoFont: System.TObject;
    headerFont: System.TObject;
    groupHeaderFont: System.TObject;
    detailFont: System.TObject;
    groupFooterFont: System.TObject;
    footerFont: System.TObject;
    dateCaptionFont: System.TObject;
    pageCountCaptionFont: System.TObject
);
JScript
public function DynARFonts(
   titleFont : System.Object,
   parentInfoFont : System.Object,
   headerFont : System.Object,
   groupHeaderFont : System.Object,
   detailFont : System.Object,
   groupFooterFont : System.Object,
   footerFont : System.Object,
   dateCaptionFont : System.Object,
   pageCountCaptionFont : System.Object
);
Managed Extensions for C++
public: DynARFonts(
   System.Object* titleFont,
   System.Object* parentInfoFont,
   System.Object* headerFont,
   System.Object* groupHeaderFont,
   System.Object* detailFont,
   System.Object* groupFooterFont,
   System.Object* footerFont,
   System.Object* dateCaptionFont,
   System.Object* pageCountCaptionFont
)
C++/CLI
public:
DynARFonts(
   System.Object^ titleFont,
   System.Object^ parentInfoFont,
   System.Object^ headerFont,
   System.Object^ groupHeaderFont,
   System.Object^ detailFont,
   System.Object^ groupFooterFont,
   System.Object^ footerFont,
   System.Object^ dateCaptionFont,
   System.Object^ pageCountCaptionFont
)

Parameters

titleFont
parentInfoFont
headerFont
groupHeaderFont
detailFont
groupFooterFont
footerFont
dateCaptionFont
pageCountCaptionFont

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DynARFonts Structure
DynARFonts Members


DynARFonts Structure Fields

[image]
Intersoft WebGrid Documentation
DynARFonts Structure Fields
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : DynARFonts Structure

Glossary Item Box

For a list of all members of this type, see DynARFonts members.

Public Fields

 | Name | Description
Public Field | DateCaptionFont |
Public Field | DetailFont |
Public Field | FooterFont |
Public Field | GroupFooterFont |
Public Field | GroupHeaderFont |
Public Field | HeaderFont |
Public Field | PageCountCaptionFont |
Public Field | ParentInfoFont |
Public Field | TitleFont |
Top

See Also

Reference

DynARFonts Structure
ISNet.WebUI.WebGrid Namespace


DateCaptionFont Field

[image]
Intersoft WebGrid Documentation
DateCaptionFont Field
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > DynARFonts Structure : DateCaptionFont Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public DateCaptionFont As System.Object
Visual Basic (Usage) Copy Code
Dim instance As DynARFonts
Dim value As System.Object

value = instance.DateCaptionFont

instance.DateCaptionFont = value
C#
public System.object DateCaptionFont
Delphi
public field DateCaptionFont: System.TObject;
JScript
public var DateCaptionFont : System.Object;
Managed Extensions for C++
public: System.Object* DateCaptionFont
C++/CLI
public:
System.Object^ DateCaptionFont

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DynARFonts Structure
DynARFonts Members


DetailFont Field

[image]
Intersoft WebGrid Documentation
DetailFont Field
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > DynARFonts Structure : DetailFont Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public DetailFont As System.Object
Visual Basic (Usage) Copy Code
Dim instance As DynARFonts
Dim value As System.Object

value = instance.DetailFont

instance.DetailFont = value
C#
public System.object DetailFont
Delphi
public field DetailFont: System.TObject;
JScript
public var DetailFont : System.Object;
Managed Extensions for C++
public: System.Object* DetailFont
C++/CLI
public:
System.Object^ DetailFont

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DynARFonts Structure
DynARFonts Members


FooterFont Field

[image]
Intersoft WebGrid Documentation
FooterFont Field
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > DynARFonts Structure : FooterFont Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public FooterFont As System.Object
Visual Basic (Usage) Copy Code
Dim instance As DynARFonts
Dim value As System.Object

value = instance.FooterFont

instance.FooterFont = value
C#
public System.object FooterFont
Delphi
public field FooterFont: System.TObject;
JScript
public var FooterFont : System.Object;
Managed Extensions for C++
public: System.Object* FooterFont
C++/CLI
public:
System.Object^ FooterFont

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DynARFonts Structure
DynARFonts Members


GroupFooterFont Field

[image]
Intersoft WebGrid Documentation
GroupFooterFont Field
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > DynARFonts Structure : GroupFooterFont Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public GroupFooterFont As System.Object
Visual Basic (Usage) Copy Code
Dim instance As DynARFonts
Dim value As System.Object

value = instance.GroupFooterFont

instance.GroupFooterFont = value
C#
public System.object GroupFooterFont
Delphi
public field GroupFooterFont: System.TObject;
JScript
public var GroupFooterFont : System.Object;
Managed Extensions for C++
public: System.Object* GroupFooterFont
C++/CLI
public:
System.Object^ GroupFooterFont

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DynARFonts Structure
DynARFonts Members


GroupHeaderFont Field

[image]
Intersoft WebGrid Documentation
GroupHeaderFont Field
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > DynARFonts Structure : GroupHeaderFont Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public GroupHeaderFont As System.Object
Visual Basic (Usage) Copy Code
Dim instance As DynARFonts
Dim value As System.Object

value = instance.GroupHeaderFont

instance.GroupHeaderFont = value
C#
public System.object GroupHeaderFont
Delphi
public field GroupHeaderFont: System.TObject;
JScript
public var GroupHeaderFont : System.Object;
Managed Extensions for C++
public: System.Object* GroupHeaderFont
C++/CLI
public:
System.Object^ GroupHeaderFont

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DynARFonts Structure
DynARFonts Members


HeaderFont Field

[image]
Intersoft WebGrid Documentation
HeaderFont Field
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > DynARFonts Structure : HeaderFont Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public HeaderFont As System.Object
Visual Basic (Usage) Copy Code
Dim instance As DynARFonts
Dim value As System.Object

value = instance.HeaderFont

instance.HeaderFont = value
C#
public System.object HeaderFont
Delphi
public field HeaderFont: System.TObject;
JScript
public var HeaderFont : System.Object;
Managed Extensions for C++
public: System.Object* HeaderFont
C++/CLI
public:
System.Object^ HeaderFont

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DynARFonts Structure
DynARFonts Members


PageCountCaptionFont Field

[image]
Intersoft WebGrid Documentation
PageCountCaptionFont Field
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > DynARFonts Structure : PageCountCaptionFont Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public PageCountCaptionFont As System.Object
Visual Basic (Usage) Copy Code
Dim instance As DynARFonts
Dim value As System.Object

value = instance.PageCountCaptionFont

instance.PageCountCaptionFont = value
C#
public System.object PageCountCaptionFont
Delphi
public field PageCountCaptionFont: System.TObject;
JScript
public var PageCountCaptionFont : System.Object;
Managed Extensions for C++
public: System.Object* PageCountCaptionFont
C++/CLI
public:
System.Object^ PageCountCaptionFont

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DynARFonts Structure
DynARFonts Members


ParentInfoFont Field

[image]
Intersoft WebGrid Documentation
ParentInfoFont Field
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > DynARFonts Structure : ParentInfoFont Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ParentInfoFont As System.Object
Visual Basic (Usage) Copy Code
Dim instance As DynARFonts
Dim value As System.Object

value = instance.ParentInfoFont

instance.ParentInfoFont = value
C#
public System.object ParentInfoFont
Delphi
public field ParentInfoFont: System.TObject;
JScript
public var ParentInfoFont : System.Object;
Managed Extensions for C++
public: System.Object* ParentInfoFont
C++/CLI
public:
System.Object^ ParentInfoFont

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DynARFonts Structure
DynARFonts Members


TitleFont Field

[image]
Intersoft WebGrid Documentation
TitleFont Field
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > DynARFonts Structure : TitleFont Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public TitleFont As System.Object
Visual Basic (Usage) Copy Code
Dim instance As DynARFonts
Dim value As System.Object

value = instance.TitleFont

instance.TitleFont = value
C#
public System.object TitleFont
Delphi
public field TitleFont: System.TObject;
JScript
public var TitleFont : System.Object;
Managed Extensions for C++
public: System.Object* TitleFont
C++/CLI
public:
System.Object^ TitleFont

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DynARFonts Structure
DynARFonts Members


DynRptCaptions Structure

[image]
Intersoft WebGrid Documentation
DynRptCaptions Structure
Members See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : DynRptCaptions Structure

Glossary Item Box

Object Model

DynRptCaptions Structure

Syntax

Visual Basic (Declaration)
Public Structure DynRptCaptions
   Inherits System.ValueType
Visual Basic (Usage) Copy Code
Dim instance As DynRptCaptions
C#
public struct DynRptCaptions : System.ValueType
Delphi
public type DynRptCaptions = class(System.ValueType)
JScript
In JScript, you can use structures in other assemblies, but you cannot define your own.
Managed Extensions for C++
public __value struct DynRptCaptions : public System.ValueType
C++/CLI
public value class DynRptCaptions : public System.ValueType

Inheritance Hierarchy

System.Object
System.ValueType
ISNet.WebUI.WebGrid.DynRptCaptions

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DynRptCaptions Members
ISNet.WebUI.WebGrid Namespace


DynRptCaptions Structure Members

[image]
Intersoft WebGrid Documentation
DynRptCaptions Structure Members
See Also Fields Send Feedback
ISNet.WebUI.WebGrid Namespace : DynRptCaptions Structure

Glossary Item Box

The following tables list the members exposed by DynRptCaptions.

Public Constructors

 | Name | Description
Public Constructor | DynRptCaptions Constructor |
Top

Public Fields

 | Name | Description
Public Field | DateCaption |
Public Field | DateCaptionFormat |
Public Field | PageCountCaption |
Public Field | PageCountCaptionFormat |
Top

See Also

Reference

DynRptCaptions Structure
ISNet.WebUI.WebGrid Namespace


DynRptCaptions Constructor

[image]
Intersoft WebGrid Documentation
DynRptCaptions Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > DynRptCaptions Structure : DynRptCaptions Constructor

dateCaption
dateCaptionFormat
pageCountCaption
pageCountCaptionFormat

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal dateCaption As System.String, _
   ByVal dateCaptionFormat As System.String, _
   ByVal pageCountCaption As System.String, _
   ByVal pageCountCaptionFormat As System.String _
)
Visual Basic (Usage) Copy Code
Dim dateCaption As System.String
Dim dateCaptionFormat As System.String
Dim pageCountCaption As System.String
Dim pageCountCaptionFormat As System.String

Dim instance As New DynRptCaptions(dateCaption, dateCaptionFormat, pageCountCaption, pageCountCaptionFormat)
C#
public DynRptCaptions(
   System.string dateCaption,
   System.string dateCaptionFormat,
   System.string pageCountCaption,
   System.string pageCountCaptionFormat
)
Delphi
public DynRptCaptions(
    dateCaption: System.String;
    dateCaptionFormat: System.String;
    pageCountCaption: System.String;
    pageCountCaptionFormat: System.String
);
JScript
public function DynRptCaptions(
   dateCaption : System.String,
   dateCaptionFormat : System.String,
   pageCountCaption : System.String,
   pageCountCaptionFormat : System.String
);
Managed Extensions for C++
public: DynRptCaptions(
   System.string* dateCaption,
   System.string* dateCaptionFormat,
   System.string* pageCountCaption,
   System.string* pageCountCaptionFormat
)
C++/CLI
public:
DynRptCaptions(
   System.String^ dateCaption,
   System.String^ dateCaptionFormat,
   System.String^ pageCountCaption,
   System.String^ pageCountCaptionFormat
)

Parameters

dateCaption
dateCaptionFormat
pageCountCaption
pageCountCaptionFormat

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DynRptCaptions Structure
DynRptCaptions Members


DynRptCaptions Structure Fields

[image]
Intersoft WebGrid Documentation
DynRptCaptions Structure Fields
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : DynRptCaptions Structure

Glossary Item Box

For a list of all members of this type, see DynRptCaptions members.

Public Fields

 | Name | Description
Public Field | DateCaption |
Public Field | DateCaptionFormat |
Public Field | PageCountCaption |
Public Field | PageCountCaptionFormat |
Top

See Also

Reference

DynRptCaptions Structure
ISNet.WebUI.WebGrid Namespace


DateCaption Field

[image]
Intersoft WebGrid Documentation
DateCaption Field
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > DynRptCaptions Structure : DateCaption Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public DateCaption As System.String
Visual Basic (Usage) Copy Code
Dim instance As DynRptCaptions
Dim value As System.String

value = instance.DateCaption

instance.DateCaption = value
C#
public System.string DateCaption
Delphi
public field DateCaption: System.String;
JScript
public var DateCaption : System.String;
Managed Extensions for C++
public: System.string* DateCaption
C++/CLI
public:
System.String^ DateCaption

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DynRptCaptions Structure
DynRptCaptions Members


DateCaptionFormat Field

[image]
Intersoft WebGrid Documentation
DateCaptionFormat Field
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > DynRptCaptions Structure : DateCaptionFormat Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public DateCaptionFormat As System.String
Visual Basic (Usage) Copy Code
Dim instance As DynRptCaptions
Dim value As System.String

value = instance.DateCaptionFormat

instance.DateCaptionFormat = value
C#
public System.string DateCaptionFormat
Delphi
public field DateCaptionFormat: System.String;
JScript
public var DateCaptionFormat : System.String;
Managed Extensions for C++
public: System.string* DateCaptionFormat
C++/CLI
public:
System.String^ DateCaptionFormat

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DynRptCaptions Structure
DynRptCaptions Members


PageCountCaption Field

[image]
Intersoft WebGrid Documentation
PageCountCaption Field
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > DynRptCaptions Structure : PageCountCaption Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public PageCountCaption As System.String
Visual Basic (Usage) Copy Code
Dim instance As DynRptCaptions
Dim value As System.String

value = instance.PageCountCaption

instance.PageCountCaption = value
C#
public System.string PageCountCaption
Delphi
public field PageCountCaption: System.String;
JScript
public var PageCountCaption : System.String;
Managed Extensions for C++
public: System.string* PageCountCaption
C++/CLI
public:
System.String^ PageCountCaption

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DynRptCaptions Structure
DynRptCaptions Members


PageCountCaptionFormat Field

[image]
Intersoft WebGrid Documentation
PageCountCaptionFormat Field
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > DynRptCaptions Structure : PageCountCaptionFormat Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public PageCountCaptionFormat As System.String
Visual Basic (Usage) Copy Code
Dim instance As DynRptCaptions
Dim value As System.String

value = instance.PageCountCaptionFormat

instance.PageCountCaptionFormat = value
C#
public System.string PageCountCaptionFormat
Delphi
public field PageCountCaptionFormat: System.String;
JScript
public var PageCountCaptionFormat : System.String;
Managed Extensions for C++
public: System.string* PageCountCaptionFormat
C++/CLI
public:
System.String^ PageCountCaptionFormat

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DynRptCaptions Structure
DynRptCaptions Members


IHierarchicalList Interface

[image]
Intersoft WebGrid Documentation
IHierarchicalList Interface
Members See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : IHierarchicalList Interface

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Interface IHierarchicalList
Visual Basic (Usage) Copy Code
Dim instance As IHierarchicalList
C#
public interface IHierarchicalList
Delphi
public interface IHierarchicalList
JScript
public interface IHierarchicalList
Managed Extensions for C++
public __gc __interface IHierarchicalList
C++/CLI
public interface class IHierarchicalList

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IHierarchicalList Members
ISNet.WebUI.WebGrid Namespace


IHierarchicalList Interface Members

[image]
Intersoft WebGrid Documentation
IHierarchicalList Interface Members
See Also Properties Send Feedback
ISNet.WebUI.WebGrid Namespace : IHierarchicalList Interface

Glossary Item Box

The following tables list the members exposed by IHierarchicalList.

Public Properties

 | Name | Description
Property | ItemType |
Top

See Also

Reference

IHierarchicalList Interface
ISNet.WebUI.WebGrid Namespace


IHierarchicalList Interface Properties

[image]
Intersoft WebGrid Documentation
IHierarchicalList Interface Properties
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : IHierarchicalList Interface

Glossary Item Box

For a list of all members of this type, see IHierarchicalList members.

Public Properties

 | Name | Description
Property | ItemType |
Top

See Also

Reference

IHierarchicalList Interface
ISNet.WebUI.WebGrid Namespace


ItemType Property

[image]
Intersoft WebGrid Documentation
ItemType Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > IHierarchicalList Interface : ItemType Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property ItemType As System.Type
Visual Basic (Usage) Copy Code
Dim instance As IHierarchicalList
Dim value As System.Type

value = instance.ItemType
C#
System.Type ItemType {get;}
Delphi
read-only property ItemType: System.Type;
JScript
function get ItemType : System.Type
Managed Extensions for C++
__property System.Type* get_ItemType();
C++/CLI
property System.Type^ ItemType {
   System.Type^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IHierarchicalList Interface
IHierarchicalList Members


IHierarchicalObject Interface

[image]
Intersoft WebGrid Documentation
IHierarchicalObject Interface
Members See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : IHierarchicalObject Interface

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Interface IHierarchicalObject
Visual Basic (Usage) Copy Code
Dim instance As IHierarchicalObject
C#
public interface IHierarchicalObject
Delphi
public interface IHierarchicalObject
JScript
public interface IHierarchicalObject
Managed Extensions for C++
public __gc __interface IHierarchicalObject
C++/CLI
public interface class IHierarchicalObject

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IHierarchicalObject Members
ISNet.WebUI.WebGrid Namespace


IHierarchicalObject Interface Members

[image]
Intersoft WebGrid Documentation
IHierarchicalObject Interface Members
See Also Properties Send Feedback
ISNet.WebUI.WebGrid Namespace : IHierarchicalObject Interface

Glossary Item Box

The following tables list the members exposed by IHierarchicalObject.

Public Properties

 | Name | Description
Property | PrimaryKeys |
Property | Relations |
Top

See Also

Reference

IHierarchicalObject Interface
ISNet.WebUI.WebGrid Namespace


IHierarchicalObject Interface Properties

[image]
Intersoft WebGrid Documentation
IHierarchicalObject Interface Properties
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : IHierarchicalObject Interface

Glossary Item Box

For a list of all members of this type, see IHierarchicalObject members.

Public Properties

 | Name | Description
Property | PrimaryKeys |
Property | Relations |
Top

See Also

Reference

IHierarchicalObject Interface
ISNet.WebUI.WebGrid Namespace


PrimaryKeys Property

[image]
Intersoft WebGrid Documentation
PrimaryKeys Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > IHierarchicalObject Interface : PrimaryKeys Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<NonRetrievableAttribute()>
ReadOnly Property PrimaryKeys As System.String()
Visual Basic (Usage) Copy Code
Dim instance As IHierarchicalObject
Dim value() As System.String

value = instance.PrimaryKeys
C#
[NonRetrievableAttribute()]
System.string[] PrimaryKeys {get;}
Delphi
read-only property PrimaryKeys: System.array of String;
JScript
NonRetrievableAttribute()
function get PrimaryKeys : System.String[]
Managed Extensions for C++
[NonRetrievableAttribute()]
__property System.string*[]* get_PrimaryKeys();
C++/CLI
[NonRetrievableAttribute()]
property System.array<String^>^ PrimaryKeys {
   System.array<String^>^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IHierarchicalObject Interface
IHierarchicalObject Members


Relations Property

[image]
Intersoft WebGrid Documentation
Relations Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > IHierarchicalObject Interface : Relations Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<NonRetrievableAttribute()>
ReadOnly Property Relations As System.Collections.ArrayList
Visual Basic (Usage) Copy Code
Dim instance As IHierarchicalObject
Dim value As System.Collections.ArrayList

value = instance.Relations
C#
[NonRetrievableAttribute()]
System.Collections.ArrayList Relations {get;}
Delphi
read-only property Relations: System.Collections.ArrayList;
JScript
NonRetrievableAttribute()
function get Relations : System.Collections.ArrayList
Managed Extensions for C++
[NonRetrievableAttribute()]
__property System.Collections.ArrayList* get_Relations();
C++/CLI
[NonRetrievableAttribute()]
property System.Collections.ArrayList^ Relations {
   System.Collections.ArrayList^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IHierarchicalObject Interface
IHierarchicalObject Members


IObjectRelations Interface

[image]
Intersoft WebGrid Documentation
IObjectRelations Interface
Members See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : IObjectRelations Interface

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Interface IObjectRelations
Visual Basic (Usage) Copy Code
Dim instance As IObjectRelations
C#
public interface IObjectRelations
Delphi
public interface IObjectRelations
JScript
public interface IObjectRelations
Managed Extensions for C++
public __gc __interface IObjectRelations
C++/CLI
public interface class IObjectRelations

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IObjectRelations Members
ISNet.WebUI.WebGrid Namespace


IObjectRelations Interface Members

[image]
Intersoft WebGrid Documentation
IObjectRelations Interface Members
See Also Properties Send Feedback
ISNet.WebUI.WebGrid Namespace : IObjectRelations Interface

Glossary Item Box

The following tables list the members exposed by IObjectRelations.

Public Properties

 | Name | Description
Property | Relations |
Top

See Also

Reference

IObjectRelations Interface
ISNet.WebUI.WebGrid Namespace


IObjectRelations Interface Properties

[image]
Intersoft WebGrid Documentation
IObjectRelations Interface Properties
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : IObjectRelations Interface

Glossary Item Box

For a list of all members of this type, see IObjectRelations members.

Public Properties

 | Name | Description
Property | Relations |
Top

See Also

Reference

IObjectRelations Interface
ISNet.WebUI.WebGrid Namespace


Relations Property

[image]
Intersoft WebGrid Documentation
Relations Property
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace > IObjectRelations Interface : Relations Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Relations As System.Collections.ArrayList
Visual Basic (Usage) Copy Code
Dim instance As IObjectRelations
Dim value As System.Collections.ArrayList

value = instance.Relations
C#
System.Collections.ArrayList Relations {get;}
Delphi
read-only property Relations: System.Collections.ArrayList;
JScript
function get Relations : System.Collections.ArrayList
Managed Extensions for C++
__property System.Collections.ArrayList* get_Relations();
C++/CLI
property System.Collections.ArrayList^ Relations {
   System.Collections.ArrayList^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IObjectRelations Interface
IObjectRelations Members


AddRowEventHandler Delegate

[image]
Intersoft WebGrid Documentation
AddRowEventHandler Delegate
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : AddRowEventHandler Delegate

sender
e

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Delegate Sub AddRowEventHandler( _
   ByVal sender As System.Object, _
   ByVal e As RowEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As New AddRowEventHandler(AddressOf HandlerMethod)
C#
public delegate void AddRowEventHandler(
   System.object sender,
   RowEventArgs e
)
Delphi
public delegate AddRowEventHandler(
    sender: System.TObject;
    e: RowEventArgs
);
JScript
public delegate AddRowEventHandler(
   sender : System.Object,
   e : RowEventArgs
)
Managed Extensions for C++
public: __gc __delegate void AddRowEventHandler(
   System.Object* sender,
   RowEventArgs* e
)
C++/CLI
public delegate void AddRowEventHandler(
   System.Object^ sender,
   RowEventArgs^ e
)

Parameters

sender
e

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AddRowEventHandler Members
ISNet.WebUI.WebGrid Namespace


ButtonClickEventHandler Delegate

[image]
Intersoft WebGrid Documentation
ButtonClickEventHandler Delegate
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : ButtonClickEventHandler Delegate

sender
e

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Delegate Sub ButtonClickEventHandler( _
   ByVal sender As System.Object, _
   ByVal e As ButtonEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As New ButtonClickEventHandler(AddressOf HandlerMethod)
C#
public delegate void ButtonClickEventHandler(
   System.object sender,
   ButtonEventArgs e
)
Delphi
public delegate ButtonClickEventHandler(
    sender: System.TObject;
    e: ButtonEventArgs
);
JScript
public delegate ButtonClickEventHandler(
   sender : System.Object,
   e : ButtonEventArgs
)
Managed Extensions for C++
public: __gc __delegate void ButtonClickEventHandler(
   System.Object* sender,
   ButtonEventArgs* e
)
C++/CLI
public delegate void ButtonClickEventHandler(
   System.Object^ sender,
   ButtonEventArgs^ e
)

Parameters

sender
e

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ButtonClickEventHandler Members
ISNet.WebUI.WebGrid Namespace


CellEventHandler Delegate

[image]
Intersoft WebGrid Documentation
CellEventHandler Delegate
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : CellEventHandler Delegate

sender
e

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Delegate Sub CellEventHandler( _
   ByVal sender As System.Object, _
   ByVal e As CellEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As New CellEventHandler(AddressOf HandlerMethod)
C#
public delegate void CellEventHandler(
   System.object sender,
   CellEventArgs e
)
Delphi
public delegate CellEventHandler(
    sender: System.TObject;
    e: CellEventArgs
);
JScript
public delegate CellEventHandler(
   sender : System.Object,
   e : CellEventArgs
)
Managed Extensions for C++
public: __gc __delegate void CellEventHandler(
   System.Object* sender,
   CellEventArgs* e
)
C++/CLI
public delegate void CellEventHandler(
   System.Object^ sender,
   CellEventArgs^ e
)

Parameters

sender
e

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CellEventHandler Members
ISNet.WebUI.WebGrid Namespace


ChildTableDataSourceEventHandler Delegate

[image]
Intersoft WebGrid Documentation
ChildTableDataSourceEventHandler Delegate
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : ChildTableDataSourceEventHandler Delegate

sender
e

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Delegate Sub ChildTableDataSourceEventHandler( _
   ByVal sender As System.Object, _
   ByVal e As ChildTableDataSourceEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As New ChildTableDataSourceEventHandler(AddressOf HandlerMethod)
C#
public delegate void ChildTableDataSourceEventHandler(
   System.object sender,
   ChildTableDataSourceEventArgs e
)
Delphi
public delegate ChildTableDataSourceEventHandler(
    sender: System.TObject;
    e: ChildTableDataSourceEventArgs
);
JScript
public delegate ChildTableDataSourceEventHandler(
   sender : System.Object,
   e : ChildTableDataSourceEventArgs
)
Managed Extensions for C++
public: __gc __delegate void ChildTableDataSourceEventHandler(
   System.Object* sender,
   ChildTableDataSourceEventArgs* e
)
C++/CLI
public delegate void ChildTableDataSourceEventHandler(
   System.Object^ sender,
   ChildTableDataSourceEventArgs^ e
)

Parameters

sender
e

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChildTableDataSourceEventHandler Members
ISNet.WebUI.WebGrid Namespace


ColumnEventHandler Delegate

[image]
Intersoft WebGrid Documentation
ColumnEventHandler Delegate
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : ColumnEventHandler Delegate

sender
e

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Delegate Sub ColumnEventHandler( _
   ByVal sender As System.Object, _
   ByVal e As ColumnEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As New ColumnEventHandler(AddressOf HandlerMethod)
C#
public delegate void ColumnEventHandler(
   System.object sender,
   ColumnEventArgs e
)
Delphi
public delegate ColumnEventHandler(
    sender: System.TObject;
    e: ColumnEventArgs
);
JScript
public delegate ColumnEventHandler(
   sender : System.Object,
   e : ColumnEventArgs
)
Managed Extensions for C++
public: __gc __delegate void ColumnEventHandler(
   System.Object* sender,
   ColumnEventArgs* e
)
C++/CLI
public delegate void ColumnEventHandler(
   System.Object^ sender,
   ColumnEventArgs^ e
)

Parameters

sender
e

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ColumnEventHandler Members
ISNet.WebUI.WebGrid Namespace


CustomAggregateEventHandler Delegate

[image]
Intersoft WebGrid Documentation
CustomAggregateEventHandler Delegate
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : CustomAggregateEventHandler Delegate

sender
e

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Delegate Sub CustomAggregateEventHandler( _
   ByVal sender As System.Object, _
   ByVal e As CustomAggregateArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As New CustomAggregateEventHandler(AddressOf HandlerMethod)
C#
public delegate void CustomAggregateEventHandler(
   System.object sender,
   CustomAggregateArgs e
)
Delphi
public delegate CustomAggregateEventHandler(
    sender: System.TObject;
    e: CustomAggregateArgs
);
JScript
public delegate CustomAggregateEventHandler(
   sender : System.Object,
   e : CustomAggregateArgs
)
Managed Extensions for C++
public: __gc __delegate void CustomAggregateEventHandler(
   System.Object* sender,
   CustomAggregateArgs* e
)
C++/CLI
public delegate void CustomAggregateEventHandler(
   System.Object^ sender,
   CustomAggregateArgs^ e
)

Parameters

sender
e

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CustomAggregateEventHandler Members
ISNet.WebUI.WebGrid Namespace


CustomFilterEventHandler Delegate

[image]
Intersoft WebGrid Documentation
CustomFilterEventHandler Delegate
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : CustomFilterEventHandler Delegate

sender
e

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Delegate Sub CustomFilterEventHandler( _
   ByVal sender As System.Object, _
   ByVal e As FilterEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As New CustomFilterEventHandler(AddressOf HandlerMethod)
C#
public delegate void CustomFilterEventHandler(
   System.object sender,
   FilterEventArgs e
)
Delphi
public delegate CustomFilterEventHandler(
    sender: System.TObject;
    e: FilterEventArgs
);
JScript
public delegate CustomFilterEventHandler(
   sender : System.Object,
   e : FilterEventArgs
)
Managed Extensions for C++
public: __gc __delegate void CustomFilterEventHandler(
   System.Object* sender,
   FilterEventArgs* e
)
C++/CLI
public delegate void CustomFilterEventHandler(
   System.Object^ sender,
   FilterEventArgs^ e
)

Parameters

sender
e

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CustomFilterEventHandler Members
ISNet.WebUI.WebGrid Namespace


CustomSortEventHandler Delegate

[image]
Intersoft WebGrid Documentation
CustomSortEventHandler Delegate
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : CustomSortEventHandler Delegate

sender
e

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Delegate Sub CustomSortEventHandler( _
   ByVal sender As System.Object, _
   ByVal e As SortEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As New CustomSortEventHandler(AddressOf HandlerMethod)
C#
public delegate void CustomSortEventHandler(
   System.object sender,
   SortEventArgs e
)
Delphi
public delegate CustomSortEventHandler(
    sender: System.TObject;
    e: SortEventArgs
);
JScript
public delegate CustomSortEventHandler(
   sender : System.Object,
   e : SortEventArgs
)
Managed Extensions for C++
public: __gc __delegate void CustomSortEventHandler(
   System.Object* sender,
   SortEventArgs* e
)
C++/CLI
public delegate void CustomSortEventHandler(
   System.Object^ sender,
   SortEventArgs^ e
)

Parameters

sender
e

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CustomSortEventHandler Members
ISNet.WebUI.WebGrid Namespace


DataSourceEventHandler Delegate

[image]
Intersoft WebGrid Documentation
DataSourceEventHandler Delegate
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : DataSourceEventHandler Delegate

sender
e

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Delegate Sub DataSourceEventHandler( _
   ByVal sender As System.Object, _
   ByVal e As DataSourceEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As New DataSourceEventHandler(AddressOf HandlerMethod)
C#
public delegate void DataSourceEventHandler(
   System.object sender,
   DataSourceEventArgs e
)
Delphi
public delegate DataSourceEventHandler(
    sender: System.TObject;
    e: DataSourceEventArgs
);
JScript
public delegate DataSourceEventHandler(
   sender : System.Object,
   e : DataSourceEventArgs
)
Managed Extensions for C++
public: __gc __delegate void DataSourceEventHandler(
   System.Object* sender,
   DataSourceEventArgs* e
)
C++/CLI
public delegate void DataSourceEventHandler(
   System.Object^ sender,
   DataSourceEventArgs^ e
)

Parameters

sender
e

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataSourceEventHandler Members
ISNet.WebUI.WebGrid Namespace


DeleteRowEventHandler Delegate

[image]
Intersoft WebGrid Documentation
DeleteRowEventHandler Delegate
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : DeleteRowEventHandler Delegate

sender
e

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Delegate Sub DeleteRowEventHandler( _
   ByVal sender As System.Object, _
   ByVal e As RowEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As New DeleteRowEventHandler(AddressOf HandlerMethod)
C#
public delegate void DeleteRowEventHandler(
   System.object sender,
   RowEventArgs e
)
Delphi
public delegate DeleteRowEventHandler(
    sender: System.TObject;
    e: RowEventArgs
);
JScript
public delegate DeleteRowEventHandler(
   sender : System.Object,
   e : RowEventArgs
)
Managed Extensions for C++
public: __gc __delegate void DeleteRowEventHandler(
   System.Object* sender,
   RowEventArgs* e
)
C++/CLI
public delegate void DeleteRowEventHandler(
   System.Object^ sender,
   RowEventArgs^ e
)

Parameters

sender
e

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DeleteRowEventHandler Members
ISNet.WebUI.WebGrid Namespace


ExportCompletedEventHandler Delegate

[image]
Intersoft WebGrid Documentation
ExportCompletedEventHandler Delegate
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : ExportCompletedEventHandler Delegate

sender
e

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Delegate Sub ExportCompletedEventHandler( _
   ByVal sender As System.Object, _
   ByVal e As ExportCompletedEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As New ExportCompletedEventHandler(AddressOf HandlerMethod)
C#
public delegate void ExportCompletedEventHandler(
   System.object sender,
   ExportCompletedEventArgs e
)
Delphi
public delegate ExportCompletedEventHandler(
    sender: System.TObject;
    e: ExportCompletedEventArgs
);
JScript
public delegate ExportCompletedEventHandler(
   sender : System.Object,
   e : ExportCompletedEventArgs
)
Managed Extensions for C++
public: __gc __delegate void ExportCompletedEventHandler(
   System.Object* sender,
   ExportCompletedEventArgs* e
)
C++/CLI
public delegate void ExportCompletedEventHandler(
   System.Object^ sender,
   ExportCompletedEventArgs^ e
)

Parameters

sender
e

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ExportCompletedEventHandler Members
ISNet.WebUI.WebGrid Namespace


ExportEventHandler Delegate

[image]
Intersoft WebGrid Documentation
ExportEventHandler Delegate
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : ExportEventHandler Delegate

sender
e

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Delegate Sub ExportEventHandler( _
   ByVal sender As System.Object, _
   ByVal e As ExportEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As New ExportEventHandler(AddressOf HandlerMethod)
C#
public delegate void ExportEventHandler(
   System.object sender,
   ExportEventArgs e
)
Delphi
public delegate ExportEventHandler(
    sender: System.TObject;
    e: ExportEventArgs
);
JScript
public delegate ExportEventHandler(
   sender : System.Object,
   e : ExportEventArgs
)
Managed Extensions for C++
public: __gc __delegate void ExportEventHandler(
   System.Object* sender,
   ExportEventArgs* e
)
C++/CLI
public delegate void ExportEventHandler(
   System.Object^ sender,
   ExportEventArgs^ e
)

Parameters

sender
e

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ExportEventHandler Members
ISNet.WebUI.WebGrid Namespace


LayoutEventHandler Delegate

[image]
Intersoft WebGrid Documentation
LayoutEventHandler Delegate
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : LayoutEventHandler Delegate

sender
e

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Delegate Sub LayoutEventHandler( _
   ByVal sender As System.Object, _
   ByVal e As LayoutEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As New LayoutEventHandler(AddressOf HandlerMethod)
C#
public delegate void LayoutEventHandler(
   System.object sender,
   LayoutEventArgs e
)
Delphi
public delegate LayoutEventHandler(
    sender: System.TObject;
    e: LayoutEventArgs
);
JScript
public delegate LayoutEventHandler(
   sender : System.Object,
   e : LayoutEventArgs
)
Managed Extensions for C++
public: __gc __delegate void LayoutEventHandler(
   System.Object* sender,
   LayoutEventArgs* e
)
C++/CLI
public delegate void LayoutEventHandler(
   System.Object^ sender,
   LayoutEventArgs^ e
)

Parameters

sender
e

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LayoutEventHandler Members
ISNet.WebUI.WebGrid Namespace


PostBackEventHandler Delegate

[image]
Intersoft WebGrid Documentation
PostBackEventHandler Delegate
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : PostBackEventHandler Delegate

sender
e

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Delegate Sub PostBackEventHandler( _
   ByVal sender As System.Object, _
   ByVal e As PostbackEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As New PostBackEventHandler(AddressOf HandlerMethod)
C#
public delegate void PostBackEventHandler(
   System.object sender,
   PostbackEventArgs e
)
Delphi
public delegate PostBackEventHandler(
    sender: System.TObject;
    e: PostbackEventArgs
);
JScript
public delegate PostBackEventHandler(
   sender : System.Object,
   e : PostbackEventArgs
)
Managed Extensions for C++
public: __gc __delegate void PostBackEventHandler(
   System.Object* sender,
   PostbackEventArgs* e
)
C++/CLI
public delegate void PostBackEventHandler(
   System.Object^ sender,
   PostbackEventArgs^ e
)

Parameters

sender
e

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PostBackEventHandler Members
ISNet.WebUI.WebGrid Namespace


PrepareExportExecuteEventHandler Delegate

[image]
Intersoft WebGrid Documentation
PrepareExportExecuteEventHandler Delegate
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : PrepareExportExecuteEventHandler Delegate

sender
e

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Delegate Sub PrepareExportExecuteEventHandler( _
   ByVal sender As System.Object, _
   ByVal e As PrepareExportExecuteEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As New PrepareExportExecuteEventHandler(AddressOf HandlerMethod)
C#
public delegate void PrepareExportExecuteEventHandler(
   System.object sender,
   PrepareExportExecuteEventArgs e
)
Delphi
public delegate PrepareExportExecuteEventHandler(
    sender: System.TObject;
    e: PrepareExportExecuteEventArgs
);
JScript
public delegate PrepareExportExecuteEventHandler(
   sender : System.Object,
   e : PrepareExportExecuteEventArgs
)
Managed Extensions for C++
public: __gc __delegate void PrepareExportExecuteEventHandler(
   System.Object* sender,
   PrepareExportExecuteEventArgs* e
)
C++/CLI
public delegate void PrepareExportExecuteEventHandler(
   System.Object^ sender,
   PrepareExportExecuteEventArgs^ e
)

Parameters

sender
e

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PrepareExportExecuteEventHandler Members
ISNet.WebUI.WebGrid Namespace


RowEventHandler Delegate

[image]
Intersoft WebGrid Documentation
RowEventHandler Delegate
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : RowEventHandler Delegate

sender
e

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Delegate Sub RowEventHandler( _
   ByVal sender As System.Object, _
   ByVal e As RowEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As New RowEventHandler(AddressOf HandlerMethod)
C#
public delegate void RowEventHandler(
   System.object sender,
   RowEventArgs e
)
Delphi
public delegate RowEventHandler(
    sender: System.TObject;
    e: RowEventArgs
);
JScript
public delegate RowEventHandler(
   sender : System.Object,
   e : RowEventArgs
)
Managed Extensions for C++
public: __gc __delegate void RowEventHandler(
   System.Object* sender,
   RowEventArgs* e
)
C++/CLI
public delegate void RowEventHandler(
   System.Object^ sender,
   RowEventArgs^ e
)

Parameters

sender
e

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RowEventHandler Members
ISNet.WebUI.WebGrid Namespace


RowLayoutSpanEventHandler Delegate

[image]
Intersoft WebGrid Documentation
RowLayoutSpanEventHandler Delegate
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : RowLayoutSpanEventHandler Delegate

sender
e

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Delegate Sub RowLayoutSpanEventHandler( _
   ByVal sender As System.Object, _
   ByVal e As SpanEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As New RowLayoutSpanEventHandler(AddressOf HandlerMethod)
C#
public delegate void RowLayoutSpanEventHandler(
   System.object sender,
   SpanEventArgs e
)
Delphi
public delegate RowLayoutSpanEventHandler(
    sender: System.TObject;
    e: SpanEventArgs
);
JScript
public delegate RowLayoutSpanEventHandler(
   sender : System.Object,
   e : SpanEventArgs
)
Managed Extensions for C++
public: __gc __delegate void RowLayoutSpanEventHandler(
   System.Object* sender,
   SpanEventArgs* e
)
C++/CLI
public delegate void RowLayoutSpanEventHandler(
   System.Object^ sender,
   SpanEventArgs^ e
)

Parameters

sender
e

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RowLayoutSpanEventHandler Members
ISNet.WebUI.WebGrid Namespace


TableEventHandler Delegate

[image]
Intersoft WebGrid Documentation
TableEventHandler Delegate
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : TableEventHandler Delegate

sender
e

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Delegate Sub TableEventHandler( _
   ByVal sender As System.Object, _
   ByVal e As TableEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As New TableEventHandler(AddressOf HandlerMethod)
C#
public delegate void TableEventHandler(
   System.object sender,
   TableEventArgs e
)
Delphi
public delegate TableEventHandler(
    sender: System.TObject;
    e: TableEventArgs
);
JScript
public delegate TableEventHandler(
   sender : System.Object,
   e : TableEventArgs
)
Managed Extensions for C++
public: __gc __delegate void TableEventHandler(
   System.Object* sender,
   TableEventArgs* e
)
C++/CLI
public delegate void TableEventHandler(
   System.Object^ sender,
   TableEventArgs^ e
)

Parameters

sender
e

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TableEventHandler Members
ISNet.WebUI.WebGrid Namespace


UpdateRowEventHandler Delegate

[image]
Intersoft WebGrid Documentation
UpdateRowEventHandler Delegate
See Also Send Feedback
ISNet.WebUI.WebGrid Namespace : UpdateRowEventHandler Delegate

sender
e

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Delegate Sub UpdateRowEventHandler( _
   ByVal sender As System.Object, _
   ByVal e As RowEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As New UpdateRowEventHandler(AddressOf HandlerMethod)
C#
public delegate void UpdateRowEventHandler(
   System.object sender,
   RowEventArgs e
)
Delphi
public delegate UpdateRowEventHandler(
    sender: System.TObject;
    e: RowEventArgs
);
JScript
public delegate UpdateRowEventHandler(
   sender : System.Object,
   e : RowEventArgs
)
Managed Extensions for C++
public: __gc __delegate void UpdateRowEventHandler(
   System.Object* sender,
   RowEventArgs* e
)
C++/CLI
public delegate void UpdateRowEventHandler(
   System.Object^ sender,
   RowEventArgs^ e
)

Parameters

sender
e

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

UpdateRowEventHandler Members
ISNet.WebUI.WebGrid Namespace


ISNet.WebUI.WebGrid.Chart Namespace

ISNet.WebUI.WebGrid.Chart Namespace
See Also Inheritance Hierarchy Send Feedback

Glossary Item Box

Classes

 | Class | Description
Class | ChartAreaTypeSettings |
Class | ChartAxisSettings |
Class | ChartBackgroundSettings |
Class | ChartBackplaneStyle |
Class | ChartBarTypeSettings |
Class | ChartBevelAndEmbossImageFilterSettings |
Class | ChartBlurImageFilterSettings |
Class | ChartColorFillStyle |
Class | ChartColumnTypeSettings |
Class | ChartConfig |
Class | ChartDataLabelStyle |
Class | ChartDataManager |
Class | ChartDoughnutTypeSettings |
Class | ChartEmptyDataPointsStyle |
Class | ChartFilterDataSettings |
Class | ChartFontStyle |
Class | ChartFrameStyle |
Class | ChartGlowImageFilterSettings |
Class | ChartGradientFillStyle |
Class | ChartHatchFillStyle |
Class | ChartImageFillStyle |
Class | ChartImageFilterSettings |
Class | ChartImageFrameStyle |
Class | ChartInteractiveStyle |
Class | ChartInteractiveUISettings |
Class | ChartLabelSettings |
Class | ChartLegendDataSettings |
Class | ChartLegendSettings |
Class | ChartLegendTitle |
Class | ChartLightingImageFilterSettings |
Class | ChartLightModelSettings |
Class | ChartLightSourceCollection |
Class | ChartLineTypeSettings |
Class | ChartMarginValue |
Class | ChartMaterialStyle |
Class | ChartPieTypeSettings |
Class | ChartPivotDataConfigCollection |
Class | ChartPivotFilterConfigCollection |
Class | ChartPointValue |
Class | ChartProjectionSettings |
Class | ChartRequestHandler |
Class | ChartScaleGridStyle |
Class | ChartScaleLabelAngleValue |
Class | ChartScaleLabelStyle |
Class | ChartScaleTitleStyle |
Class | ChartSeriesAreaSettings |
Class | ChartSeriesBarSettings |
Class | ChartSeriesBubbleSettings |
Class | ChartSeriesColorCollection |
Class | ChartSeriesColorCollectionSettings |
Class | ChartSeriesColumnSettings |
Class | ChartSeriesDoughnutSettings |
Class | ChartSeriesLineSettings |
Class | ChartSeriesMarkerCollection |
Class | ChartSeriesMarkerCollectionSettings |
Class | ChartSeriesPieSettings |
Class | ChartSeriesPolarSettings |
Class | ChartSeriesRadarSettings |
Class | ChartSeriesSmoothLineSettings |
Class | ChartSeriesStepLineSettings |
Class | ChartSeriesStockSettings |
Class | ChartSeriesXYSettings |
Class | ChartSettings |
Class | ChartShadowStyle |
Class | ChartShowOrHideRibbonSettings |
Class | ChartSizeValue |
Class | ChartSmoothLineTypeSettings |
Class | ChartStandardFrameStyle |
Class | ChartStepLineTypeSettings |
Class | ChartStrokeStyle |
Class | ChartTextStyle |
Class | ChartTextureFillStyle |
Class | ChartTextureMappingStyle |
Class | ChartTitleRibbonSettings |
Class | ChartTypeRibbonSettings |
Class | ChartVector3DValue |
Class | ChartVisualEffectSettings |
Class | ChartWalls |
Class | ChartWallSettings |
Class | ChartXAxisSettings |
Class | ChartYAxisSettings |
Class | ChartZAxisSettings |
Class | Series |
Class | SeriesArea |
Class | SeriesBar |
Class | SeriesBase |
Class | SeriesBubble |
Class | SeriesLegend |
Class | SeriesLine |
Class | SeriesLineBase |
Class | SeriesPie |
Class | SeriesPoint |
Class | SeriesPolar |
Class | SeriesRadar |
Class | SeriesSmoothLine |
Class | SeriesStepLine |
Class | SeriesStock |
Class | SeriesXYScatter |
Class | SeriesXYZScatter |
Class | WebGridChartEventArgs |
Class | WebGridChartStatusArgs |

Interfaces

 | Interface | Description
Interface | IChartEngine |

Delegates

 | Delegate | Description
Delegate | WebGridChartProcessedEventHandler |
Delegate | WebGridChartProcessingEventHandler |

Enumerations

 | Enumeration | Description
Enumeration | AutoCalc |
Enumeration | BackplaneShape |
Enumeration | BarShape |
Enumeration | BevelType |
Enumeration | BlurType |
Enumeration | BoundsMode |
Enumeration | CandleStyle |
Enumeration | ChartAxis |
Enumeration | ChartEngineType |
Enumeration | ChartFillType |
Enumeration | ChartFrameType |
Enumeration | ChartImageFormat |
Enumeration | ChartMode |
Enumeration | ChartType |
Enumeration | ContentAlignment |
Enumeration | CursorType |
Enumeration | DateInterval |
Enumeration | EmptyDataPointsAppearanceMode |
Enumeration | EmptyDataPointsMarkerMode |
Enumeration | FrameBevelStyle |
Enumeration | GlowType |
Enumeration | GradientStyle |
Enumeration | GradientVariant |
Enumeration | HeaderAlignment |
Enumeration | HorizontalAlign |
Enumeration | ImageFrameType |
Enumeration | LabelGenerationMode |
Enumeration | LegendExpandMode |
Enumeration | LegendMode |
Enumeration | LevelOfDetail |
Enumeration | LightSourceType |
Enumeration | LinePattern |
Enumeration | LineSegmentShape |
Enumeration | MajorTickMode |
Enumeration | MapLayout |
Enumeration | MapMode |
Enumeration | PieExplodeMode |
Enumeration | PieLabelMode |
Enumeration | PieStyle |
Enumeration | PivotCriteriaState |
Enumeration | PivotDataType |
Enumeration | PivotType |
Enumeration | PointShape |
Enumeration | PredefinedLightModel |
Enumeration | PredefinedProjection |
Enumeration | PredefinedStandardFrame |
Enumeration | ProjectionType |
Enumeration | RenderSurface |
Enumeration | RibbonState |
Enumeration | ScaleLabelAngleMode |
Enumeration | ScaleLevelShape |
Enumeration | SeriesAppearanceMode |
Enumeration | SeriesAreaType |
Enumeration | SeriesBarType |
Enumeration | SeriesBubbleType |
Enumeration | SeriesColumnType |
Enumeration | SeriesDoughnutType |
Enumeration | SeriesLegendMode |
Enumeration | SeriesLineType |
Enumeration | SeriesPieType |
Enumeration | SeriesPolarType |
Enumeration | SeriesRadarType |
Enumeration | SeriesSmoothLineType |
Enumeration | SeriesStepLineType |
Enumeration | SeriesStockType |
Enumeration | SeriesXYType |
Enumeration | ShadowType |
Enumeration | ShapeRenderingMode |
Enumeration | SortOrder |
Enumeration | StringFormatType |
Enumeration | TextDirection |
Enumeration | TextFormat |
Enumeration | VerticalAlign |

See Also

Reference

ISNet.WebUI.WebGrid Assembly


ISNet.WebUI.WebGrid.Chart Namespace Inheritance Hierarchy

ISNet.WebUI.WebGrid.Chart Namespace Inheritance Hierarchy
See Also Send Feedback

Glossary Item Box

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebGrid.Chart.ChartDataManager
ISNet.WebUI.WebGrid.Chart.ChartFilterDataSettings
ISNet.WebUI.WebGrid.Chart.ChartRequestHandler
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.WebGrid.Chart.ChartAreaTypeSettings
ISNet.WebUI.WebGrid.Chart.ChartAxisSettings
ISNet.WebUI.WebGrid.Chart.ChartXAxisSettings
ISNet.WebUI.WebGrid.Chart.ChartYAxisSettings
ISNet.WebUI.WebGrid.Chart.ChartZAxisSettings
ISNet.WebUI.WebGrid.Chart.ChartBackgroundSettings
ISNet.WebUI.WebGrid.Chart.ChartBackplaneStyle
ISNet.WebUI.WebGrid.Chart.ChartBarTypeSettings
ISNet.WebUI.WebGrid.Chart.ChartColorFillStyle
ISNet.WebUI.WebGrid.Chart.ChartColumnTypeSettings
ISNet.WebUI.WebGrid.Chart.ChartConfig
ISNet.WebUI.WebGrid.Chart.ChartDataLabelStyle
ISNet.WebUI.WebGrid.Chart.ChartDoughnutTypeSettings
ISNet.WebUI.WebGrid.Chart.ChartEmptyDataPointsStyle
ISNet.WebUI.WebGrid.Chart.ChartFontStyle
ISNet.WebUI.WebGrid.Chart.ChartFrameStyle
ISNet.WebUI.WebGrid.Chart.ChartImageFilterSettings
ISNet.WebUI.WebGrid.Chart.ChartBevelAndEmbossImageFilterSettings
ISNet.WebUI.WebGrid.Chart.ChartBlurImageFilterSettings
ISNet.WebUI.WebGrid.Chart.ChartGlowImageFilterSettings
ISNet.WebUI.WebGrid.Chart.ChartLightingImageFilterSettings
ISNet.WebUI.WebGrid.Chart.ChartImageFrameStyle
ISNet.WebUI.WebGrid.Chart.ChartInteractiveStyle
ISNet.WebUI.WebGrid.Chart.ChartInteractiveUISettings
ISNet.WebUI.WebGrid.Chart.ChartLabelSettings
ISNet.WebUI.WebGrid.Chart.ChartLegendDataSettings
ISNet.WebUI.WebGrid.Chart.ChartLegendSettings
ISNet.WebUI.WebGrid.Chart.ChartLegendTitle
ISNet.WebUI.WebGrid.Chart.ChartLightModelSettings
ISNet.WebUI.WebGrid.Chart.ChartLineTypeSettings
ISNet.WebUI.WebGrid.Chart.ChartMarginValue
ISNet.WebUI.WebGrid.Chart.ChartMaterialStyle
ISNet.WebUI.WebGrid.Chart.ChartPieTypeSettings
ISNet.WebUI.WebGrid.Chart.ChartPointValue
ISNet.WebUI.WebGrid.Chart.ChartProjectionSettings
ISNet.WebUI.WebGrid.Chart.ChartScaleGridStyle
ISNet.WebUI.WebGrid.Chart.ChartScaleLabelAngleValue
ISNet.WebUI.WebGrid.Chart.ChartScaleLabelStyle
ISNet.WebUI.WebGrid.Chart.ChartScaleTitleStyle
ISNet.WebUI.WebGrid.Chart.ChartSeriesAreaSettings
ISNet.WebUI.WebGrid.Chart.ChartSeriesBarSettings
ISNet.WebUI.WebGrid.Chart.ChartSeriesBubbleSettings
ISNet.WebUI.WebGrid.Chart.ChartSeriesColorCollectionSettings
ISNet.WebUI.WebGrid.Chart.ChartSeriesColumnSettings
ISNet.WebUI.WebGrid.Chart.ChartSeriesDoughnutSettings
ISNet.WebUI.WebGrid.Chart.ChartSeriesLineSettings
ISNet.WebUI.WebGrid.Chart.ChartSeriesMarkerCollectionSettings
ISNet.WebUI.WebGrid.Chart.ChartSeriesPieSettings
ISNet.WebUI.WebGrid.Chart.ChartSeriesPolarSettings
ISNet.WebUI.WebGrid.Chart.ChartSeriesRadarSettings
ISNet.WebUI.WebGrid.Chart.ChartSeriesSmoothLineSettings
ISNet.WebUI.WebGrid.Chart.ChartSeriesStepLineSettings
ISNet.WebUI.WebGrid.Chart.ChartSeriesStockSettings
ISNet.WebUI.WebGrid.Chart.ChartSeriesXYSettings
ISNet.WebUI.WebGrid.Chart.ChartSettings
ISNet.WebUI.WebGrid.Chart.ChartShadowStyle
ISNet.WebUI.WebGrid.Chart.ChartShowOrHideRibbonSettings
ISNet.WebUI.WebGrid.Chart.ChartSizeValue
ISNet.WebUI.WebGrid.Chart.ChartSmoothLineTypeSettings
ISNet.WebUI.WebGrid.Chart.ChartStandardFrameStyle
ISNet.WebUI.WebGrid.Chart.ChartStepLineTypeSettings
ISNet.WebUI.WebGrid.Chart.ChartStrokeStyle
ISNet.WebUI.WebGrid.Chart.ChartTextStyle
ISNet.WebUI.WebGrid.Chart.ChartTextureFillStyle
ISNet.WebUI.WebGrid.Chart.ChartGradientFillStyle
ISNet.WebUI.WebGrid.Chart.ChartHatchFillStyle
ISNet.WebUI.WebGrid.Chart.ChartImageFillStyle
ISNet.WebUI.WebGrid.Chart.ChartTextureMappingStyle
ISNet.WebUI.WebGrid.Chart.ChartTitleRibbonSettings
ISNet.WebUI.WebGrid.Chart.ChartTypeRibbonSettings
ISNet.WebUI.WebGrid.Chart.ChartVector3DValue
ISNet.WebUI.WebGrid.Chart.ChartVisualEffectSettings
ISNet.WebUI.WebGrid.Chart.ChartWalls
ISNet.WebUI.WebGrid.Chart.ChartWallSettings
ISNet.WebUI.WebGrid.Chart.SeriesBase
ISNet.WebUI.WebGrid.Chart.Series
ISNet.WebUI.WebGrid.Chart.SeriesPie
ISNet.WebUI.WebGrid.Chart.SeriesPolar
ISNet.WebUI.WebGrid.Chart.SeriesRadar
ISNet.WebUI.WebGrid.Chart.SeriesXYScatter
ISNet.WebUI.WebGrid.Chart.SeriesArea
ISNet.WebUI.WebGrid.Chart.SeriesStock
ISNet.WebUI.WebGrid.Chart.SeriesXYZScatter
ISNet.WebUI.WebGrid.Chart.SeriesBar
ISNet.WebUI.WebGrid.Chart.SeriesBubble
ISNet.WebUI.WebGrid.Chart.SeriesLineBase
ISNet.WebUI.WebGrid.Chart.SeriesLine
ISNet.WebUI.WebGrid.Chart.SeriesSmoothLine
ISNet.WebUI.WebGrid.Chart.SeriesStepLine
ISNet.WebUI.WebGrid.Chart.SeriesPoint
ISNet.WebUI.WebGrid.Chart.SeriesLegend
System.Collections.CollectionBase
ISNet.WebUI.ISCollectionBase
ISNet.WebUI.WebGrid.Chart.ChartLightSourceCollection
ISNet.WebUI.WebGrid.Chart.ChartPivotDataConfigCollection
ISNet.WebUI.WebGrid.Chart.ChartPivotFilterConfigCollection
ISNet.WebUI.WebGrid.Chart.ChartSeriesColorCollection
ISNet.WebUI.WebGrid.Chart.ChartSeriesMarkerCollection
System.EventArgs
ISNet.WebUI.WebGrid.BaseEventArgs
ISNet.WebUI.WebGrid.Chart.WebGridChartEventArgs
ISNet.WebUI.WebGrid.Chart.WebGridChartStatusArgs

See Also

Reference

ISNet.WebUI.WebGrid Assembly


ChartAreaTypeSettings Class

[image]
Intersoft WebGrid Documentation
ChartAreaTypeSettings Class
Members See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartAreaTypeSettings Class

Glossary Item Box

Object Model

ChartAreaTypeSettings Class

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.SerializableAttribute()>
Public Class ChartAreaTypeSettings
   Inherits ISNet.WebUI.WebUIBaseClass
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Visual Basic (Usage) Copy Code
Dim instance As ChartAreaTypeSettings
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public class ChartAreaTypeSettings : ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Delphi
public class ChartAreaTypeSettings = class(ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize)
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.SerializableAttribute()
public class ChartAreaTypeSettings extends ISNet.WebUI.WebUIBaseClass implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public __gc class ChartAreaTypeSettings : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public ref class ChartAreaTypeSettings : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.WebGrid.Chart.ChartAreaTypeSettings

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartAreaTypeSettings Members
ISNet.WebUI.WebGrid.Chart Namespace


ChartAreaTypeSettings Class Members

[image]
Intersoft WebGrid Documentation
ChartAreaTypeSettings Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartAreaTypeSettings Class

Glossary Item Box

The following tables list the members exposed by ChartAreaTypeSettings.

Public Constructors

 | Name | Description
Public Constructor | ChartAreaTypeSettings Constructor |
Top

Public Properties

 | Name | Description
Public Property | EnableAreaType |
Public Property | EnableBasic3DAreaType |
Public Property | Enabled |
Public Property | EnableStacked3DAreaType |
Public Property | EnableStackedAreaType |
Public Property | EnableStackedPercentage3DAreaType |
Public Property | EnableStackedPercentageAreaType |
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

ChartAreaTypeSettings Class
ISNet.WebUI.WebGrid.Chart Namespace


ChartAreaTypeSettings Constructor

[image]
Intersoft WebGrid Documentation
ChartAreaTypeSettings Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartAreaTypeSettings Class : ChartAreaTypeSettings Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New ChartAreaTypeSettings()
C#
public ChartAreaTypeSettings()
Delphi
public ChartAreaTypeSettings();
JScript
public function ChartAreaTypeSettings();
Managed Extensions for C++
public: ChartAreaTypeSettings();
C++/CLI
public:
ChartAreaTypeSettings();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartAreaTypeSettings Class
ChartAreaTypeSettings Members


Clone Method

[image]
Intersoft WebGrid Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartAreaTypeSettings Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As System.Object
Visual Basic (Usage) Copy Code
Dim instance As ChartAreaTypeSettings
Dim value As System.Object

value = instance.Clone()
C#
public virtual System.object Clone()
Delphi
public function Clone(): System.TObject; virtual;
JScript
public function Clone() : System.Object;
Managed Extensions for C++
public: virtual System.Object* Clone();
C++/CLI
public:
virtual System.Object^ Clone();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartAreaTypeSettings Class
ChartAreaTypeSettings Members


CopyFrom Method

[image]
Intersoft WebGrid Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartAreaTypeSettings Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartAreaTypeSettings Class
ChartAreaTypeSettings Members


CopyFrom(Object) Method

[image]
Intersoft WebGrid Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartAreaTypeSettings Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartAreaTypeSettings
Dim objSource As System.Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   System.object objSource
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartAreaTypeSettings Class
ChartAreaTypeSettings Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebGrid Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartAreaTypeSettings Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object, _
   ByVal cloneSourceValue As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartAreaTypeSettings
Dim objSource As System.Object
Dim cloneSourceValue As System.Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   System.object objSource,
   System.bool cloneSourceValue
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject;
    cloneSourceValue: System.Boolean
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object,
   cloneSourceValue : System.boolean
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource,
   System.bool cloneSourceValue
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource,
   System.bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartAreaTypeSettings Class
ChartAreaTypeSettings Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebGrid Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartAreaTypeSettings Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartAreaTypeSettings
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure DeSerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function DeSerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void DeSerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void DeSerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartAreaTypeSettings Class
ChartAreaTypeSettings Members


GetHashCode Method

[image]
Intersoft WebGrid Documentation
GetHashCode Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartAreaTypeSettings Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As ChartAreaTypeSettings
Dim value As System.Integer

value = instance.GetHashCode()
C#
public virtual System.int GetHashCode()
Delphi
public function GetHashCode(): System.Integer; virtual;
JScript
public function GetHashCode() : System.int;
Managed Extensions for C++
public: virtual System.int GetHashCode();
C++/CLI
public:
virtual System.int GetHashCode();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartAreaTypeSettings Class
ChartAreaTypeSettings Members


ChartAreaTypeSettings Class Methods

[image]
Intersoft WebGrid Documentation
ChartAreaTypeSettings Class Methods
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartAreaTypeSettings Class

Glossary Item Box

For a list of all members of this type, see ChartAreaTypeSettings members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

ChartAreaTypeSettings Class
ISNet.WebUI.WebGrid.Chart Namespace


GetObjectData Method

[image]
Intersoft WebGrid Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartAreaTypeSettings Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=False,
   UnmanagedCode=False,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=True,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Action=SecurityAction.Demand,
   Unrestricted=False)>
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartAreaTypeSettings
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure GetObjectData(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
); override;
JScript
System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=,
   UnmanagedCode=,
   SkipVerification=,
   Execution=,
   ControlThread=,
   ControlEvidence=,
   ControlPolicy=,
   SerializationFormatter=,
   ControlDomainPolicy=,
   ControlPrincipal=,
   ControlAppDomain=,
   RemotingConfiguration=,
   Infrastructure=,
   BindingRedirects=,
   Action=SecurityAction.Demand,
   Unrestricted=)
public override function GetObjectData(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public: void GetObjectData(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
) override
C++/CLI
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public:
void GetObjectData(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
) override

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartAreaTypeSettings Class
ChartAreaTypeSettings Members


IsEmpty Method

[image]
Intersoft WebGrid Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartAreaTypeSettings Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As ChartAreaTypeSettings
Dim value As System.Boolean

value = instance.IsEmpty()
C#
public virtual System.bool IsEmpty()
Delphi
public function IsEmpty(): System.Boolean; virtual;
JScript
public function IsEmpty() : System.boolean;
Managed Extensions for C++
public: virtual System.bool IsEmpty();
C++/CLI
public:
virtual System.bool IsEmpty();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartAreaTypeSettings Class
ChartAreaTypeSettings Members


Reset Method

[image]
Intersoft WebGrid Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartAreaTypeSettings Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As ChartAreaTypeSettings

instance.Reset()
C#
public virtual void Reset()
Delphi
public procedure Reset(); virtual;
JScript
public function Reset();
Managed Extensions for C++
public: virtual void Reset();
C++/CLI
public:
virtual void Reset();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartAreaTypeSettings Class
ChartAreaTypeSettings Members


SerializeObjectData Method

[image]
Intersoft WebGrid Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartAreaTypeSettings Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartAreaTypeSettings
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure SerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function SerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void SerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void SerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartAreaTypeSettings Class
ChartAreaTypeSettings Members


ToString Method

[image]
Intersoft WebGrid Documentation
ToString Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartAreaTypeSettings Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As System.String
Visual Basic (Usage) Copy Code
Dim instance As ChartAreaTypeSettings
Dim value As System.String

value = instance.ToString()
C#
public virtual System.string ToString()
Delphi
public function ToString(): System.String; virtual;
JScript
public function ToString() : System.String;
Managed Extensions for C++
public: virtual System.string* ToString();
C++/CLI
public:
virtual System.String^ ToString();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartAreaTypeSettings Class
ChartAreaTypeSettings Members


ChartAreaTypeSettings Class Properties

[image]
Intersoft WebGrid Documentation
ChartAreaTypeSettings Class Properties
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartAreaTypeSettings Class

Glossary Item Box

For a list of all members of this type, see ChartAreaTypeSettings members.

Public Properties

 | Name | Description
Public Property | EnableAreaType |
Public Property | EnableBasic3DAreaType |
Public Property | Enabled |
Public Property | EnableStacked3DAreaType |
Public Property | EnableStackedAreaType |
Public Property | EnableStackedPercentage3DAreaType |
Public Property | EnableStackedPercentageAreaType |
Top

See Also

Reference

ChartAreaTypeSettings Class
ISNet.WebUI.WebGrid.Chart Namespace


ChartAreaTypeSettings Constructor

[image]
Intersoft WebGrid Documentation
ChartAreaTypeSettings Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartAreaTypeSettings Class : ChartAreaTypeSettings Constructor

Glossary Item Box

Overload List

Overload | Description
ChartAreaTypeSettings Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartAreaTypeSettings Class
ChartAreaTypeSettings Members


EnableAreaType Property

[image]
Intersoft WebGrid Documentation
EnableAreaType Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartAreaTypeSettings Class : EnableAreaType Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Options")>
<System.ComponentModel.DescriptionAttribute("Enable user to switch chart to Area type.")>
Public Property EnableAreaType As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As ChartAreaTypeSettings
Dim value As System.Boolean

instance.EnableAreaType = value

value = instance.EnableAreaType
C#
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Options")]
[System.ComponentModel.DescriptionAttribute("Enable user to switch chart to Area type.")]
public System.bool EnableAreaType {get; set;}
Delphi
public read-write property EnableAreaType: System.Boolean;
JScript
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Options")
System.ComponentModel.DescriptionAttribute("Enable user to switch chart to Area type.")
public function get,set EnableAreaType : System.boolean
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Options")]
[System.ComponentModel.DescriptionAttribute("Enable user to switch chart to Area type.")]
public: __property System.bool get_EnableAreaType();
public: __property void set_EnableAreaType(
   System.bool value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Options")]
[System.ComponentModel.DescriptionAttribute("Enable user to switch chart to Area type.")]
public:
property System.bool EnableAreaType {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartAreaTypeSettings Class
ChartAreaTypeSettings Members


EnableBasic3DAreaType Property

[image]
Intersoft WebGrid Documentation
EnableBasic3DAreaType Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartAreaTypeSettings Class : EnableBasic3DAreaType Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Options")>
<System.ComponentModel.DescriptionAttribute("Enable user to switch chart to Basic 3D Area type.")>
Public Property EnableBasic3DAreaType As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As ChartAreaTypeSettings
Dim value As System.Boolean

instance.EnableBasic3DAreaType = value

value = instance.EnableBasic3DAreaType
C#
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Options")]
[System.ComponentModel.DescriptionAttribute("Enable user to switch chart to Basic 3D Area type.")]
public System.bool EnableBasic3DAreaType {get; set;}
Delphi
public read-write property EnableBasic3DAreaType: System.Boolean;
JScript
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Options")
System.ComponentModel.DescriptionAttribute("Enable user to switch chart to Basic 3D Area type.")
public function get,set EnableBasic3DAreaType : System.boolean
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Options")]
[System.ComponentModel.DescriptionAttribute("Enable user to switch chart to Basic 3D Area type.")]
public: __property System.bool get_EnableBasic3DAreaType();
public: __property void set_EnableBasic3DAreaType(
   System.bool value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Options")]
[System.ComponentModel.DescriptionAttribute("Enable user to switch chart to Basic 3D Area type.")]
public:
property System.bool EnableBasic3DAreaType {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartAreaTypeSettings Class
ChartAreaTypeSettings Members


Enabled Property

[image]
Intersoft WebGrid Documentation
Enabled Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartAreaTypeSettings Class : Enabled Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Options")>
<System.ComponentModel.DescriptionAttribute("Enable user to switch chart to Series Area types.")>
Public Property Enabled As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As ChartAreaTypeSettings
Dim value As System.Boolean

instance.Enabled = value

value = instance.Enabled
C#
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Options")]
[System.ComponentModel.DescriptionAttribute("Enable user to switch chart to Series Area types.")]
public System.bool Enabled {get; set;}
Delphi
public read-write property Enabled: System.Boolean;
JScript
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Options")
System.ComponentModel.DescriptionAttribute("Enable user to switch chart to Series Area types.")
public function get,set Enabled : System.boolean
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Options")]
[System.ComponentModel.DescriptionAttribute("Enable user to switch chart to Series Area types.")]
public: __property System.bool get_Enabled();
public: __property void set_Enabled(
   System.bool value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Options")]
[System.ComponentModel.DescriptionAttribute("Enable user to switch chart to Series Area types.")]
public:
property System.bool Enabled {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartAreaTypeSettings Class
ChartAreaTypeSettings Members


EnableStacked3DAreaType Property

[image]
Intersoft WebGrid Documentation
EnableStacked3DAreaType Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartAreaTypeSettings Class : EnableStacked3DAreaType Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("Options")>
<System.ComponentModel.DescriptionAttribute("Enable user to switch chart to Stacked 3D Area type.")>
Public Property EnableStacked3DAreaType As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As ChartAreaTypeSettings
Dim value As System.Boolean

instance.EnableStacked3DAreaType = value

value = instance.EnableStacked3DAreaType
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Options")]
[System.ComponentModel.DescriptionAttribute("Enable user to switch chart to Stacked 3D Area type.")]
public System.bool EnableStacked3DAreaType {get; set;}
Delphi
public read-write property EnableStacked3DAreaType: System.Boolean;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("Options")
System.ComponentModel.DescriptionAttribute("Enable user to switch chart to Stacked 3D Area type.")
public function get,set EnableStacked3DAreaType : System.boolean
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Options")]
[System.ComponentModel.DescriptionAttribute("Enable user to switch chart to Stacked 3D Area type.")]
public: __property System.bool get_EnableStacked3DAreaType();
public: __property void set_EnableStacked3DAreaType(
   System.bool value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Options")]
[System.ComponentModel.DescriptionAttribute("Enable user to switch chart to Stacked 3D Area type.")]
public:
property System.bool EnableStacked3DAreaType {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartAreaTypeSettings Class
ChartAreaTypeSettings Members


EnableStackedAreaType Property

[image]
Intersoft WebGrid Documentation
EnableStackedAreaType Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartAreaTypeSettings Class : EnableStackedAreaType Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("Options")>
<System.ComponentModel.DescriptionAttribute("Enable user to switch chart to Stacked Area type.")>
Public Property EnableStackedAreaType As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As ChartAreaTypeSettings
Dim value As System.Boolean

instance.EnableStackedAreaType = value

value = instance.EnableStackedAreaType
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Options")]
[System.ComponentModel.DescriptionAttribute("Enable user to switch chart to Stacked Area type.")]
public System.bool EnableStackedAreaType {get; set;}
Delphi
public read-write property EnableStackedAreaType: System.Boolean;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("Options")
System.ComponentModel.DescriptionAttribute("Enable user to switch chart to Stacked Area type.")
public function get,set EnableStackedAreaType : System.boolean
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Options")]
[System.ComponentModel.DescriptionAttribute("Enable user to switch chart to Stacked Area type.")]
public: __property System.bool get_EnableStackedAreaType();
public: __property void set_EnableStackedAreaType(
   System.bool value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Options")]
[System.ComponentModel.DescriptionAttribute("Enable user to switch chart to Stacked Area type.")]
public:
property System.bool EnableStackedAreaType {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartAreaTypeSettings Class
ChartAreaTypeSettings Members


EnableStackedPercentage3DAreaType Property

[image]
Intersoft WebGrid Documentation
EnableStackedPercentage3DAreaType Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartAreaTypeSettings Class : EnableStackedPercentage3DAreaType Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Options")>
<System.ComponentModel.DescriptionAttribute("Enable user to switch chart to 100% Stacked 3D Area type.")>
Public Property EnableStackedPercentage3DAreaType As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As ChartAreaTypeSettings
Dim value As System.Boolean

instance.EnableStackedPercentage3DAreaType = value

value = instance.EnableStackedPercentage3DAreaType
C#
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Options")]
[System.ComponentModel.DescriptionAttribute("Enable user to switch chart to 100% Stacked 3D Area type.")]
public System.bool EnableStackedPercentage3DAreaType {get; set;}
Delphi
public read-write property EnableStackedPercentage3DAreaType: System.Boolean;
JScript
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Options")
System.ComponentModel.DescriptionAttribute("Enable user to switch chart to 100% Stacked 3D Area type.")
public function get,set EnableStackedPercentage3DAreaType : System.boolean
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Options")]
[System.ComponentModel.DescriptionAttribute("Enable user to switch chart to 100% Stacked 3D Area type.")]
public: __property System.bool get_EnableStackedPercentage3DAreaType();
public: __property void set_EnableStackedPercentage3DAreaType(
   System.bool value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Options")]
[System.ComponentModel.DescriptionAttribute("Enable user to switch chart to 100% Stacked 3D Area type.")]
public:
property System.bool EnableStackedPercentage3DAreaType {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartAreaTypeSettings Class
ChartAreaTypeSettings Members


EnableStackedPercentageAreaType Property

[image]
Intersoft WebGrid Documentation
EnableStackedPercentageAreaType Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartAreaTypeSettings Class : EnableStackedPercentageAreaType Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("Options")>
<System.ComponentModel.DescriptionAttribute("Enable user to switch chart to 100% Stacked Area type.")>
Public Property EnableStackedPercentageAreaType As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As ChartAreaTypeSettings
Dim value As System.Boolean

instance.EnableStackedPercentageAreaType = value

value = instance.EnableStackedPercentageAreaType
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Options")]
[System.ComponentModel.DescriptionAttribute("Enable user to switch chart to 100% Stacked Area type.")]
public System.bool EnableStackedPercentageAreaType {get; set;}
Delphi
public read-write property EnableStackedPercentageAreaType: System.Boolean;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("Options")
System.ComponentModel.DescriptionAttribute("Enable user to switch chart to 100% Stacked Area type.")
public function get,set EnableStackedPercentageAreaType : System.boolean
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Options")]
[System.ComponentModel.DescriptionAttribute("Enable user to switch chart to 100% Stacked Area type.")]
public: __property System.bool get_EnableStackedPercentageAreaType();
public: __property void set_EnableStackedPercentageAreaType(
   System.bool value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Options")]
[System.ComponentModel.DescriptionAttribute("Enable user to switch chart to 100% Stacked Area type.")]
public:
property System.bool EnableStackedPercentageAreaType {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartAreaTypeSettings Class
ChartAreaTypeSettings Members


ChartAxisSettings Class

[image]
Intersoft WebGrid Documentation
ChartAxisSettings Class
Members See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartAxisSettings Class

Glossary Item Box

Object Model

ChartAxisSettings Class

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.SerializableAttribute()>
Public Class ChartAxisSettings
   Inherits ISNet.WebUI.WebUIBaseClass
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Visual Basic (Usage) Copy Code
Dim instance As ChartAxisSettings
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public class ChartAxisSettings : ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Delphi
public class ChartAxisSettings = class(ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize)
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.SerializableAttribute()
public class ChartAxisSettings extends ISNet.WebUI.WebUIBaseClass implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public __gc class ChartAxisSettings : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public ref class ChartAxisSettings : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.WebGrid.Chart.ChartAxisSettings
ISNet.WebUI.WebGrid.Chart.ChartXAxisSettings
ISNet.WebUI.WebGrid.Chart.ChartYAxisSettings
ISNet.WebUI.WebGrid.Chart.ChartZAxisSettings

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartAxisSettings Members
ISNet.WebUI.WebGrid.Chart Namespace


ChartAxisSettings Class Members

[image]
Intersoft WebGrid Documentation
ChartAxisSettings Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartAxisSettings Class

Glossary Item Box

The following tables list the members exposed by ChartAxisSettings.

Public Constructors

 | Name | Description
Public Constructor | ChartAxisSettings Constructor |
Top

Public Properties

 | Name | Description
Public Property | AutoLabels |
Public Property | AutoMinorTicks |
Public Property | Invert |
Public Property | LabelGenerationMode |
Public Property | LabelStyle |
Public Property | MajorGridStyle |
Public Property | MinorGridStyle |
Public Property | MinorTickCount |
Public Property | NumberOfTicksPerLabel |
Public Property | StripStyles |
Public Property | Title |
Public Property | Visible |
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

ChartAxisSettings Class
ISNet.WebUI.WebGrid.Chart Namespace


ChartAxisSettings Constructor

[image]
Intersoft WebGrid Documentation
ChartAxisSettings Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartAxisSettings Class : ChartAxisSettings Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New ChartAxisSettings()
C#
public ChartAxisSettings()
Delphi
public ChartAxisSettings();
JScript
public function ChartAxisSettings();
Managed Extensions for C++
public: ChartAxisSettings();
C++/CLI
public:
ChartAxisSettings();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartAxisSettings Class
ChartAxisSettings Members


Clone Method

[image]
Intersoft WebGrid Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartAxisSettings Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As System.Object
Visual Basic (Usage) Copy Code
Dim instance As ChartAxisSettings
Dim value As System.Object

value = instance.Clone()
C#
public virtual System.object Clone()
Delphi
public function Clone(): System.TObject; virtual;
JScript
public function Clone() : System.Object;
Managed Extensions for C++
public: virtual System.Object* Clone();
C++/CLI
public:
virtual System.Object^ Clone();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartAxisSettings Class
ChartAxisSettings Members


CopyFrom Method

[image]
Intersoft WebGrid Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartAxisSettings Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartAxisSettings Class
ChartAxisSettings Members


CopyFrom(Object) Method

[image]
Intersoft WebGrid Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartAxisSettings Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartAxisSettings
Dim objSource As System.Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   System.object objSource
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartAxisSettings Class
ChartAxisSettings Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebGrid Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartAxisSettings Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object, _
   ByVal cloneSourceValue As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartAxisSettings
Dim objSource As System.Object
Dim cloneSourceValue As System.Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   System.object objSource,
   System.bool cloneSourceValue
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject;
    cloneSourceValue: System.Boolean
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object,
   cloneSourceValue : System.boolean
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource,
   System.bool cloneSourceValue
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource,
   System.bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartAxisSettings Class
ChartAxisSettings Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebGrid Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartAxisSettings Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartAxisSettings
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure DeSerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function DeSerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void DeSerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void DeSerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartAxisSettings Class
ChartAxisSettings Members


GetHashCode Method

[image]
Intersoft WebGrid Documentation
GetHashCode Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartAxisSettings Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As ChartAxisSettings
Dim value As System.Integer

value = instance.GetHashCode()
C#
public virtual System.int GetHashCode()
Delphi
public function GetHashCode(): System.Integer; virtual;
JScript
public function GetHashCode() : System.int;
Managed Extensions for C++
public: virtual System.int GetHashCode();
C++/CLI
public:
virtual System.int GetHashCode();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartAxisSettings Class
ChartAxisSettings Members


ChartAxisSettings Class Methods

[image]
Intersoft WebGrid Documentation
ChartAxisSettings Class Methods
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartAxisSettings Class

Glossary Item Box

For a list of all members of this type, see ChartAxisSettings members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

ChartAxisSettings Class
ISNet.WebUI.WebGrid.Chart Namespace


GetObjectData Method

[image]
Intersoft WebGrid Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartAxisSettings Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=False,
   UnmanagedCode=False,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=True,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Action=SecurityAction.Demand,
   Unrestricted=False)>
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartAxisSettings
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure GetObjectData(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
); override;
JScript
System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=,
   UnmanagedCode=,
   SkipVerification=,
   Execution=,
   ControlThread=,
   ControlEvidence=,
   ControlPolicy=,
   SerializationFormatter=,
   ControlDomainPolicy=,
   ControlPrincipal=,
   ControlAppDomain=,
   RemotingConfiguration=,
   Infrastructure=,
   BindingRedirects=,
   Action=SecurityAction.Demand,
   Unrestricted=)
public override function GetObjectData(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public: void GetObjectData(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
) override
C++/CLI
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public:
void GetObjectData(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
) override

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartAxisSettings Class
ChartAxisSettings Members


IsEmpty Method

[image]
Intersoft WebGrid Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartAxisSettings Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As ChartAxisSettings
Dim value As System.Boolean

value = instance.IsEmpty()
C#
public virtual System.bool IsEmpty()
Delphi
public function IsEmpty(): System.Boolean; virtual;
JScript
public function IsEmpty() : System.boolean;
Managed Extensions for C++
public: virtual System.bool IsEmpty();
C++/CLI
public:
virtual System.bool IsEmpty();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartAxisSettings Class
ChartAxisSettings Members


Reset Method

[image]
Intersoft WebGrid Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartAxisSettings Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As ChartAxisSettings

instance.Reset()
C#
public virtual void Reset()
Delphi
public procedure Reset(); virtual;
JScript
public function Reset();
Managed Extensions for C++
public: virtual void Reset();
C++/CLI
public:
virtual void Reset();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartAxisSettings Class
ChartAxisSettings Members


SerializeObjectData Method

[image]
Intersoft WebGrid Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartAxisSettings Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartAxisSettings
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure SerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function SerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void SerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void SerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartAxisSettings Class
ChartAxisSettings Members


ToString Method

[image]
Intersoft WebGrid Documentation
ToString Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartAxisSettings Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As System.String
Visual Basic (Usage) Copy Code
Dim instance As ChartAxisSettings
Dim value As System.String

value = instance.ToString()
C#
public virtual System.string ToString()
Delphi
public function ToString(): System.String; virtual;
JScript
public function ToString() : System.String;
Managed Extensions for C++
public: virtual System.string* ToString();
C++/CLI
public:
virtual System.String^ ToString();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartAxisSettings Class
ChartAxisSettings Members


ChartAxisSettings Class Properties

[image]
Intersoft WebGrid Documentation
ChartAxisSettings Class Properties
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartAxisSettings Class

Glossary Item Box

For a list of all members of this type, see ChartAxisSettings members.

Public Properties

 | Name | Description
Public Property | AutoLabels |
Public Property | AutoMinorTicks |
Public Property | Invert |
Public Property | LabelGenerationMode |
Public Property | LabelStyle |
Public Property | MajorGridStyle |
Public Property | MinorGridStyle |
Public Property | MinorTickCount |
Public Property | NumberOfTicksPerLabel |
Public Property | StripStyles |
Public Property | Title |
Public Property | Visible |
Top

See Also

Reference

ChartAxisSettings Class
ISNet.WebUI.WebGrid.Chart Namespace


ChartAxisSettings Constructor

[image]
Intersoft WebGrid Documentation
ChartAxisSettings Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartAxisSettings Class : ChartAxisSettings Constructor

Glossary Item Box

Overload List

Overload | Description
ChartAxisSettings Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartAxisSettings Class
ChartAxisSettings Members


AutoLabels Property

[image]
Intersoft WebGrid Documentation
AutoLabels Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartAxisSettings Class : AutoLabels Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("Labels")>
<System.ComponentModel.DescriptionAttribute("When set to false labels are extracted from the Labels collection of the axis. When set to true labels are automatically generated from this axis scale (if it is the active one)")>
Public Property AutoLabels As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As ChartAxisSettings
Dim value As System.Boolean

instance.AutoLabels = value

value = instance.AutoLabels
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Labels")]
[System.ComponentModel.DescriptionAttribute("When set to false labels are extracted from the Labels collection of the axis. When set to true labels are automatically generated from this axis scale (if it is the active one)")]
public System.bool AutoLabels {get; set;}
Delphi
public read-write property AutoLabels: System.Boolean;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("Labels")
System.ComponentModel.DescriptionAttribute("When set to false labels are extracted from the Labels collection of the axis. When set to true labels are automatically generated from this axis scale (if it is the active one)")
public function get,set AutoLabels : System.boolean
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Labels")]
[System.ComponentModel.DescriptionAttribute("When set to false labels are extracted from the Labels collection of the axis. When set to true labels are automatically generated from this axis scale (if it is the active one)")]
public: __property System.bool get_AutoLabels();
public: __property void set_AutoLabels(
   System.bool value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Labels")]
[System.ComponentModel.DescriptionAttribute("When set to false labels are extracted from the Labels collection of the axis. When set to true labels are automatically generated from this axis scale (if it is the active one)")]
public:
property System.bool AutoLabels {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartAxisSettings Class
ChartAxisSettings Members


AutoMinorTicks Property

[image]
Intersoft WebGrid Documentation
AutoMinorTicks Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartAxisSettings Class : AutoMinorTicks Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies whether minor ticks are automatically generated.")>
<System.ComponentModel.CategoryAttribute("Ticks")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property AutoMinorTicks As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As ChartAxisSettings
Dim value As System.Boolean

instance.AutoMinorTicks = value

value = instance.AutoMinorTicks
C#
[System.ComponentModel.DescriptionAttribute("Specifies whether minor ticks are automatically generated.")]
[System.ComponentModel.CategoryAttribute("Ticks")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
public System.bool AutoMinorTicks {get; set;}
Delphi
public read-write property AutoMinorTicks: System.Boolean;
JScript
System.ComponentModel.DescriptionAttribute("Specifies whether minor ticks are automatically generated.")
System.ComponentModel.CategoryAttribute("Ticks")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get,set AutoMinorTicks : System.boolean
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies whether minor ticks are automatically generated.")]
[System.ComponentModel.CategoryAttribute("Ticks")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.bool get_AutoMinorTicks();
public: __property void set_AutoMinorTicks(
   System.bool value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies whether minor ticks are automatically generated.")]
[System.ComponentModel.CategoryAttribute("Ticks")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.bool AutoMinorTicks {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartAxisSettings Class
ChartAxisSettings Members


Invert Property

[image]
Intersoft WebGrid Documentation
Invert Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartAxisSettings Class : Invert Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Gets or sets a value indicating whether this scale is inverted.")>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Scale")>
Public Property Invert As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As ChartAxisSettings
Dim value As System.Boolean

instance.Invert = value

value = instance.Invert
C#
[System.ComponentModel.DescriptionAttribute("Gets or sets a value indicating whether this scale is inverted.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Scale")]
public System.bool Invert {get; set;}
Delphi
public read-write property Invert: System.Boolean;
JScript
System.ComponentModel.DescriptionAttribute("Gets or sets a value indicating whether this scale is inverted.")
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Scale")
public function get,set Invert : System.boolean
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Gets or sets a value indicating whether this scale is inverted.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Scale")]
public: __property System.bool get_Invert();
public: __property void set_Invert(
   System.bool value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Gets or sets a value indicating whether this scale is inverted.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Scale")]
public:
property System.bool Invert {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartAxisSettings Class
ChartAxisSettings Members


LabelGenerationMode Property

[image]
Intersoft WebGrid Documentation
LabelGenerationMode Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartAxisSettings Class : LabelGenerationMode Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Labels")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Gets or sets a property indicating the number of levels for the scale labels")>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property LabelGenerationMode As LabelGenerationMode
Visual Basic (Usage) Copy Code
Dim instance As ChartAxisSettings
Dim value As LabelGenerationMode

instance.LabelGenerationMode = value

value = instance.LabelGenerationMode
C#
[System.ComponentModel.CategoryAttribute("Labels")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets a property indicating the number of levels for the scale labels")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public LabelGenerationMode LabelGenerationMode {get; set;}
Delphi
public read-write property LabelGenerationMode: LabelGenerationMode;
JScript
System.ComponentModel.CategoryAttribute("Labels")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets a property indicating the number of levels for the scale labels")
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get,set LabelGenerationMode : LabelGenerationMode
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Labels")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets a property indicating the number of levels for the scale labels")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property LabelGenerationMode get_LabelGenerationMode();
public: __property void set_LabelGenerationMode(
   LabelGenerationMode value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Labels")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets a property indicating the number of levels for the scale labels")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property LabelGenerationMode LabelGenerationMode {
   LabelGenerationMode get();
   void set (    LabelGenerationMode value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartAxisSettings Class
ChartAxisSettings Members


LabelStyle Property

[image]
Intersoft WebGrid Documentation
LabelStyle Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartAxisSettings Class : LabelStyle Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Labels")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Controls the appearance of scale labels")>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<ISNet.Serialization.BinarySerializableAttribute("setLabelStyle")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
Public ReadOnly Property LabelStyle As ChartScaleLabelStyle
Visual Basic (Usage) Copy Code
Dim instance As ChartAxisSettings
Dim value As ChartScaleLabelStyle

value = instance.LabelStyle
C#
[System.ComponentModel.CategoryAttribute("Labels")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Controls the appearance of scale labels")]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.Serialization.BinarySerializableAttribute("setLabelStyle")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
public ChartScaleLabelStyle LabelStyle {get;}
Delphi
public read-only property LabelStyle: ChartScaleLabelStyle;
JScript
System.ComponentModel.CategoryAttribute("Labels")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Controls the appearance of scale labels")
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
ISNet.Serialization.BinarySerializableAttribute("setLabelStyle")
System.ComponentModel.NotifyParentPropertyAttribute()
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
public function get LabelStyle : ChartScaleLabelStyle
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Labels")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Controls the appearance of scale labels")]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.Serialization.BinarySerializableAttribute("setLabelStyle")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
public: __property ChartScaleLabelStyle* get_LabelStyle();
C++/CLI
[System.ComponentModel.CategoryAttribute("Labels")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Controls the appearance of scale labels")]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.Serialization.BinarySerializableAttribute("setLabelStyle")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
public:
property ChartScaleLabelStyle^ LabelStyle {
   ChartScaleLabelStyle^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartAxisSettings Class
ChartAxisSettings Members


MajorGridStyle Property

[image]
Intersoft WebGrid Documentation
MajorGridStyle Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartAxisSettings Class : MajorGridStyle Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute("setMajorGridStyle")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<System.ComponentModel.CategoryAttribute("Grid Lines")>
<System.ComponentModel.DescriptionAttribute("Controls the major grid lines displayed by the scale")>
Public ReadOnly Property MajorGridStyle As ChartScaleGridStyle
Visual Basic (Usage) Copy Code
Dim instance As ChartAxisSettings
Dim value As ChartScaleGridStyle

value = instance.MajorGridStyle
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute("setMajorGridStyle")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.CategoryAttribute("Grid Lines")]
[System.ComponentModel.DescriptionAttribute("Controls the major grid lines displayed by the scale")]
public ChartScaleGridStyle MajorGridStyle {get;}
Delphi
public read-only property MajorGridStyle: ChartScaleGridStyle;
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute("setMajorGridStyle")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
System.ComponentModel.CategoryAttribute("Grid Lines")
System.ComponentModel.DescriptionAttribute("Controls the major grid lines displayed by the scale")
public function get MajorGridStyle : ChartScaleGridStyle
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute("setMajorGridStyle")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.CategoryAttribute("Grid Lines")]
[System.ComponentModel.DescriptionAttribute("Controls the major grid lines displayed by the scale")]
public: __property ChartScaleGridStyle* get_MajorGridStyle();
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute("setMajorGridStyle")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.CategoryAttribute("Grid Lines")]
[System.ComponentModel.DescriptionAttribute("Controls the major grid lines displayed by the scale")]
public:
property ChartScaleGridStyle^ MajorGridStyle {
   ChartScaleGridStyle^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartAxisSettings Class
ChartAxisSettings Members


MinorGridStyle Property

[image]
Intersoft WebGrid Documentation
MinorGridStyle Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartAxisSettings Class : MinorGridStyle Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Controls the minor grid lines displayed by the scale")>
<ISNet.Serialization.BinarySerializableAttribute("setMinorGridStyle")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<System.ComponentModel.CategoryAttribute("Grid Lines")>
Public ReadOnly Property MinorGridStyle As ChartScaleGridStyle
Visual Basic (Usage) Copy Code
Dim instance As ChartAxisSettings
Dim value As ChartScaleGridStyle

value = instance.MinorGridStyle
C#
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Controls the minor grid lines displayed by the scale")]
[ISNet.Serialization.BinarySerializableAttribute("setMinorGridStyle")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.CategoryAttribute("Grid Lines")]
public ChartScaleGridStyle MinorGridStyle {get;}
Delphi
public read-only property MinorGridStyle: ChartScaleGridStyle;
JScript
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Controls the minor grid lines displayed by the scale")
ISNet.Serialization.BinarySerializableAttribute("setMinorGridStyle")
System.ComponentModel.NotifyParentPropertyAttribute()
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
System.ComponentModel.CategoryAttribute("Grid Lines")
public function get MinorGridStyle : ChartScaleGridStyle
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Controls the minor grid lines displayed by the scale")]
[ISNet.Serialization.BinarySerializableAttribute("setMinorGridStyle")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.CategoryAttribute("Grid Lines")]
public: __property ChartScaleGridStyle* get_MinorGridStyle();
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Controls the minor grid lines displayed by the scale")]
[ISNet.Serialization.BinarySerializableAttribute("setMinorGridStyle")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.CategoryAttribute("Grid Lines")]
public:
property ChartScaleGridStyle^ MinorGridStyle {
   ChartScaleGridStyle^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartAxisSettings Class
ChartAxisSettings Members


MinorTickCount Property

[image]
Intersoft WebGrid Documentation
MinorTickCount Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartAxisSettings Class : MinorTickCount Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Controls the count of the automatic minor ticks between two major ticks")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("Ticks")>
Public Property MinorTickCount As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As ChartAxisSettings
Dim value As System.Integer

instance.MinorTickCount = value

value = instance.MinorTickCount
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Controls the count of the automatic minor ticks between two major ticks")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Ticks")]
public System.int MinorTickCount {get; set;}
Delphi
public read-write property MinorTickCount: System.Integer;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Controls the count of the automatic minor ticks between two major ticks")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("Ticks")
public function get,set MinorTickCount : System.int
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Controls the count of the automatic minor ticks between two major ticks")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Ticks")]
public: __property System.int get_MinorTickCount();
public: __property void set_MinorTickCount(
   System.int value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Controls the count of the automatic minor ticks between two major ticks")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Ticks")]
public:
property System.int MinorTickCount {
   System.int get();
   void set (    System.int value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartAxisSettings Class
ChartAxisSettings Members


NumberOfTicksPerLabel Property

[image]
Intersoft WebGrid Documentation
NumberOfTicksPerLabel Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartAxisSettings Class : NumberOfTicksPerLabel Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Labels")>
<System.ComponentModel.DescriptionAttribute("Controls the number of ticks that are generated between two labels")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property NumberOfTicksPerLabel As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As ChartAxisSettings
Dim value As System.Integer

instance.NumberOfTicksPerLabel = value

value = instance.NumberOfTicksPerLabel
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Labels")]
[System.ComponentModel.DescriptionAttribute("Controls the number of ticks that are generated between two labels")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.int NumberOfTicksPerLabel {get; set;}
Delphi
public read-write property NumberOfTicksPerLabel: System.Integer;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Labels")
System.ComponentModel.DescriptionAttribute("Controls the number of ticks that are generated between two labels")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set NumberOfTicksPerLabel : System.int
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Labels")]
[System.ComponentModel.DescriptionAttribute("Controls the number of ticks that are generated between two labels")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.int get_NumberOfTicksPerLabel();
public: __property void set_NumberOfTicksPerLabel(
   System.int value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Labels")]
[System.ComponentModel.DescriptionAttribute("Controls the number of ticks that are generated between two labels")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.int NumberOfTicksPerLabel {
   System.int get();
   void set (    System.int value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartAxisSettings Class
ChartAxisSettings Members


StripStyles Property

[image]
Intersoft WebGrid Documentation
StripStyles Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartAxisSettings Class : StripStyles Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Gets or sets the scale strip styles applied on the scale.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.CategoryAttribute("General")>
Public ReadOnly Property StripStyles As System.Collections.ObjectModel.Collection(Of ChartScaleStripStyle)
Visual Basic (Usage) Copy Code
Dim instance As ChartAxisSettings
Dim value As System.Collections.ObjectModel.Collection(Of ChartScaleStripStyle)

value = instance.StripStyles
C#
[System.ComponentModel.DescriptionAttribute("Gets or sets the scale strip styles applied on the scale.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.CategoryAttribute("General")]
public System.Collections.ObjectModel.Collection<ChartScaleStripStyle> StripStyles {get;}
Delphi
public read-only property StripStyles: System.Collections.ObjectModel.Collection;
JScript
System.ComponentModel.DescriptionAttribute("Gets or sets the scale strip styles applied on the scale.")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.CategoryAttribute("General")
public function get StripStyles : System.Collections.ObjectModel.Collection
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Gets or sets the scale strip styles applied on the scale.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.CategoryAttribute("General")]
public: __property System.Collections.ObjectModel.Collection<ChartScaleStripStyle*>* get_StripStyles();
C++/CLI
[System.ComponentModel.DescriptionAttribute("Gets or sets the scale strip styles applied on the scale.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.CategoryAttribute("General")]
public:
property System.Collections.ObjectModel.Collection<ChartScaleStripStyle^>^ StripStyles {
   System.Collections.ObjectModel.Collection<ChartScaleStripStyle^>^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartAxisSettings Class
ChartAxisSettings Members


Title Property

[image]
Intersoft WebGrid Documentation
Title Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartAxisSettings Class : Title Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.DescriptionAttribute("Gets or sets the angle of the scale value labels")>
<ISNet.Serialization.XmlSerializableAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute("setTitle")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<System.ComponentModel.CategoryAttribute("Labels")>
Public ReadOnly Property Title As ChartScaleTitleStyle
Visual Basic (Usage) Copy Code
Dim instance As ChartAxisSettings
Dim value As ChartScaleTitleStyle

value = instance.Title
C#
[System.ComponentModel.DefaultValueAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the angle of the scale value labels")]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute("setTitle")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.CategoryAttribute("Labels")]
public ChartScaleTitleStyle Title {get;}
Delphi
public read-only property Title: ChartScaleTitleStyle;
JScript
System.ComponentModel.DefaultValueAttribute()
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.DescriptionAttribute("Gets or sets the angle of the scale value labels")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute("setTitle")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
System.ComponentModel.CategoryAttribute("Labels")
public function get Title : ChartScaleTitleStyle
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the angle of the scale value labels")]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute("setTitle")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.CategoryAttribute("Labels")]
public: __property ChartScaleTitleStyle* get_Title();
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the angle of the scale value labels")]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute("setTitle")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.CategoryAttribute("Labels")]
public:
property ChartScaleTitleStyle^ Title {
   ChartScaleTitleStyle^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartAxisSettings Class
ChartAxisSettings Members


Visible Property

[image]
Intersoft WebGrid Documentation
Visible Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartAxisSettings Class : Visible Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("General")>
<System.ComponentModel.DescriptionAttribute("Axis visibility")>
Public Property Visible As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As ChartAxisSettings
Dim value As System.Boolean

instance.Visible = value

value = instance.Visible
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DescriptionAttribute("Axis visibility")]
public System.bool Visible {get; set;}
Delphi
public read-write property Visible: System.Boolean;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("General")
System.ComponentModel.DescriptionAttribute("Axis visibility")
public function get,set Visible : System.boolean
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DescriptionAttribute("Axis visibility")]
public: __property System.bool get_Visible();
public: __property void set_Visible(
   System.bool value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DescriptionAttribute("Axis visibility")]
public:
property System.bool Visible {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartAxisSettings Class
ChartAxisSettings Members


ChartBackgroundSettings Class

[image]
Intersoft WebGrid Documentation
ChartBackgroundSettings Class
Members See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartBackgroundSettings Class

Glossary Item Box

Object Model

ChartBackgroundSettings Class

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.SerializableAttribute()>
Public Class ChartBackgroundSettings
   Inherits ISNet.WebUI.WebUIBaseClass
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Visual Basic (Usage) Copy Code
Dim instance As ChartBackgroundSettings
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public class ChartBackgroundSettings : ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Delphi
public class ChartBackgroundSettings = class(ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize)
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.SerializableAttribute()
public class ChartBackgroundSettings extends ISNet.WebUI.WebUIBaseClass implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public __gc class ChartBackgroundSettings : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public ref class ChartBackgroundSettings : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.WebGrid.Chart.ChartBackgroundSettings

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartBackgroundSettings Members
ISNet.WebUI.WebGrid.Chart Namespace


ChartBackgroundSettings Class Members

[image]
Intersoft WebGrid Documentation
ChartBackgroundSettings Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartBackgroundSettings Class

Glossary Item Box

The following tables list the members exposed by ChartBackgroundSettings.

Public Constructors

 | Name | Description
Public Constructor | ChartBackgroundSettings Constructor |
Top

Public Properties

 | Name | Description
Public Property | FillStyle |
Public Property | FrameStyle |
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

ChartBackgroundSettings Class
ISNet.WebUI.WebGrid.Chart Namespace


ChartBackgroundSettings Constructor

[image]
Intersoft WebGrid Documentation
ChartBackgroundSettings Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartBackgroundSettings Class : ChartBackgroundSettings Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New ChartBackgroundSettings()
C#
public ChartBackgroundSettings()
Delphi
public ChartBackgroundSettings();
JScript
public function ChartBackgroundSettings();
Managed Extensions for C++
public: ChartBackgroundSettings();
C++/CLI
public:
ChartBackgroundSettings();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartBackgroundSettings Class
ChartBackgroundSettings Members


Clone Method

[image]
Intersoft WebGrid Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartBackgroundSettings Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As System.Object
Visual Basic (Usage) Copy Code
Dim instance As ChartBackgroundSettings
Dim value As System.Object

value = instance.Clone()
C#
public virtual System.object Clone()
Delphi
public function Clone(): System.TObject; virtual;
JScript
public function Clone() : System.Object;
Managed Extensions for C++
public: virtual System.Object* Clone();
C++/CLI
public:
virtual System.Object^ Clone();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartBackgroundSettings Class
ChartBackgroundSettings Members


CopyFrom Method

[image]
Intersoft WebGrid Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartBackgroundSettings Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartBackgroundSettings Class
ChartBackgroundSettings Members


CopyFrom(Object) Method

[image]
Intersoft WebGrid Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartBackgroundSettings Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartBackgroundSettings
Dim objSource As System.Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   System.object objSource
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartBackgroundSettings Class
ChartBackgroundSettings Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebGrid Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartBackgroundSettings Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object, _
   ByVal cloneSourceValue As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartBackgroundSettings
Dim objSource As System.Object
Dim cloneSourceValue As System.Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   System.object objSource,
   System.bool cloneSourceValue
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject;
    cloneSourceValue: System.Boolean
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object,
   cloneSourceValue : System.boolean
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource,
   System.bool cloneSourceValue
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource,
   System.bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartBackgroundSettings Class
ChartBackgroundSettings Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebGrid Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartBackgroundSettings Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartBackgroundSettings
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure DeSerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function DeSerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void DeSerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void DeSerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartBackgroundSettings Class
ChartBackgroundSettings Members


GetHashCode Method

[image]
Intersoft WebGrid Documentation
GetHashCode Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartBackgroundSettings Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As ChartBackgroundSettings
Dim value As System.Integer

value = instance.GetHashCode()
C#
public virtual System.int GetHashCode()
Delphi
public function GetHashCode(): System.Integer; virtual;
JScript
public function GetHashCode() : System.int;
Managed Extensions for C++
public: virtual System.int GetHashCode();
C++/CLI
public:
virtual System.int GetHashCode();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartBackgroundSettings Class
ChartBackgroundSettings Members


ChartBackgroundSettings Class Methods

[image]
Intersoft WebGrid Documentation
ChartBackgroundSettings Class Methods
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartBackgroundSettings Class

Glossary Item Box

For a list of all members of this type, see ChartBackgroundSettings members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

ChartBackgroundSettings Class
ISNet.WebUI.WebGrid.Chart Namespace


GetObjectData Method

[image]
Intersoft WebGrid Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartBackgroundSettings Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=False,
   UnmanagedCode=False,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=True,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Action=SecurityAction.Demand,
   Unrestricted=False)>
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartBackgroundSettings
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure GetObjectData(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
); override;
JScript
System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=,
   UnmanagedCode=,
   SkipVerification=,
   Execution=,
   ControlThread=,
   ControlEvidence=,
   ControlPolicy=,
   SerializationFormatter=,
   ControlDomainPolicy=,
   ControlPrincipal=,
   ControlAppDomain=,
   RemotingConfiguration=,
   Infrastructure=,
   BindingRedirects=,
   Action=SecurityAction.Demand,
   Unrestricted=)
public override function GetObjectData(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public: void GetObjectData(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
) override
C++/CLI
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public:
void GetObjectData(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
) override

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartBackgroundSettings Class
ChartBackgroundSettings Members


IsEmpty Method

[image]
Intersoft WebGrid Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartBackgroundSettings Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As ChartBackgroundSettings
Dim value As System.Boolean

value = instance.IsEmpty()
C#
public virtual System.bool IsEmpty()
Delphi
public function IsEmpty(): System.Boolean; virtual;
JScript
public function IsEmpty() : System.boolean;
Managed Extensions for C++
public: virtual System.bool IsEmpty();
C++/CLI
public:
virtual System.bool IsEmpty();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartBackgroundSettings Class
ChartBackgroundSettings Members


Reset Method

[image]
Intersoft WebGrid Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartBackgroundSettings Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As ChartBackgroundSettings

instance.Reset()
C#
public virtual void Reset()
Delphi
public procedure Reset(); virtual;
JScript
public function Reset();
Managed Extensions for C++
public: virtual void Reset();
C++/CLI
public:
virtual void Reset();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartBackgroundSettings Class
ChartBackgroundSettings Members


SerializeObjectData Method

[image]
Intersoft WebGrid Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartBackgroundSettings Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartBackgroundSettings
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure SerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function SerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void SerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void SerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartBackgroundSettings Class
ChartBackgroundSettings Members


ToString Method

[image]
Intersoft WebGrid Documentation
ToString Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartBackgroundSettings Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As System.String
Visual Basic (Usage) Copy Code
Dim instance As ChartBackgroundSettings
Dim value As System.String

value = instance.ToString()
C#
public virtual System.string ToString()
Delphi
public function ToString(): System.String; virtual;
JScript
public function ToString() : System.String;
Managed Extensions for C++
public: virtual System.string* ToString();
C++/CLI
public:
virtual System.String^ ToString();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartBackgroundSettings Class
ChartBackgroundSettings Members


ChartBackgroundSettings Class Properties

[image]
Intersoft WebGrid Documentation
ChartBackgroundSettings Class Properties
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartBackgroundSettings Class

Glossary Item Box

For a list of all members of this type, see ChartBackgroundSettings members.

Public Properties

 | Name | Description
Public Property | FillStyle |
Public Property | FrameStyle |
Top

See Also

Reference

ChartBackgroundSettings Class
ISNet.WebUI.WebGrid.Chart Namespace


ChartBackgroundSettings Constructor

[image]
Intersoft WebGrid Documentation
ChartBackgroundSettings Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartBackgroundSettings Class : ChartBackgroundSettings Constructor

Glossary Item Box

Overload List

Overload | Description
ChartBackgroundSettings Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartBackgroundSettings Class
ChartBackgroundSettings Members


FillStyle Property

[image]
Intersoft WebGrid Documentation
FillStyle Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartBackgroundSettings Class : FillStyle Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Controls the Fill Style effect applied on the background.")>
<ISNet.Serialization.BinarySerializableAttribute("setFillStyle")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<System.ComponentModel.CategoryAttribute("General")>
Public ReadOnly Property FillStyle As ChartFillStyle
Visual Basic (Usage) Copy Code
Dim instance As ChartBackgroundSettings
Dim value As ChartFillStyle

value = instance.FillStyle
C#
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Controls the Fill Style effect applied on the background.")]
[ISNet.Serialization.BinarySerializableAttribute("setFillStyle")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.CategoryAttribute("General")]
public ChartFillStyle FillStyle {get;}
Delphi
public read-only property FillStyle: ChartFillStyle;
JScript
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Controls the Fill Style effect applied on the background.")
ISNet.Serialization.BinarySerializableAttribute("setFillStyle")
System.ComponentModel.NotifyParentPropertyAttribute()
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
System.ComponentModel.CategoryAttribute("General")
public function get FillStyle : ChartFillStyle
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Controls the Fill Style effect applied on the background.")]
[ISNet.Serialization.BinarySerializableAttribute("setFillStyle")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.CategoryAttribute("General")]
public: __property ChartFillStyle* get_FillStyle();
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Controls the Fill Style effect applied on the background.")]
[ISNet.Serialization.BinarySerializableAttribute("setFillStyle")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.CategoryAttribute("General")]
public:
property ChartFillStyle^ FillStyle {
   ChartFillStyle^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartBackgroundSettings Class
ChartBackgroundSettings Members


FrameStyle Property

[image]
Intersoft WebGrid Documentation
FrameStyle Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartBackgroundSettings Class : FrameStyle Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Controls the type of the background frame.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<System.ComponentModel.CategoryAttribute("Frame")>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute("setFrameStyle")>
Public ReadOnly Property FrameStyle As ChartFrameStyle
Visual Basic (Usage) Copy Code
Dim instance As ChartBackgroundSettings
Dim value As ChartFrameStyle

value = instance.FrameStyle
C#
[System.ComponentModel.DescriptionAttribute("Controls the type of the background frame.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.CategoryAttribute("Frame")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute("setFrameStyle")]
public ChartFrameStyle FrameStyle {get;}
Delphi
public read-only property FrameStyle: ChartFrameStyle;
JScript
System.ComponentModel.DescriptionAttribute("Controls the type of the background frame.")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
System.ComponentModel.CategoryAttribute("Frame")
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute("setFrameStyle")
public function get FrameStyle : ChartFrameStyle
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Controls the type of the background frame.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.CategoryAttribute("Frame")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute("setFrameStyle")]
public: __property ChartFrameStyle* get_FrameStyle();
C++/CLI
[System.ComponentModel.DescriptionAttribute("Controls the type of the background frame.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.CategoryAttribute("Frame")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute("setFrameStyle")]
public:
property ChartFrameStyle^ FrameStyle {
   ChartFrameStyle^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartBackgroundSettings Class
ChartBackgroundSettings Members


ChartBackplaneStyle Class

[image]
Intersoft WebGrid Documentation
ChartBackplaneStyle Class
Members See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartBackplaneStyle Class

Glossary Item Box

Object Model

ChartBackplaneStyle Class

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.SerializableAttribute()>
Public Class ChartBackplaneStyle
   Inherits ISNet.WebUI.WebUIBaseClass
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Visual Basic (Usage) Copy Code
Dim instance As ChartBackplaneStyle
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public class ChartBackplaneStyle : ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Delphi
public class ChartBackplaneStyle = class(ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize)
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.SerializableAttribute()
public class ChartBackplaneStyle extends ISNet.WebUI.WebUIBaseClass implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public __gc class ChartBackplaneStyle : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public ref class ChartBackplaneStyle : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.WebGrid.Chart.ChartBackplaneStyle

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartBackplaneStyle Members
ISNet.WebUI.WebGrid.Chart Namespace


ChartBackplaneStyle Class Members

[image]
Intersoft WebGrid Documentation
ChartBackplaneStyle Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartBackplaneStyle Class

Glossary Item Box

The following tables list the members exposed by ChartBackplaneStyle.

Public Constructors

 | Name | Description
Public Constructor | ChartBackplaneStyle Constructor |
Top

Public Properties

 | Name | Description
Public Property | EdgePercent |
Public Property | FillStyle |
Public Property | Inflate |
Public Property | ShadowStyle |
Public Property | Shape |
Public Property | StandardFrameStyle |
Public Property | Visible |
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

ChartBackplaneStyle Class
ISNet.WebUI.WebGrid.Chart Namespace


ChartBackplaneStyle Constructor

[image]
Intersoft WebGrid Documentation
ChartBackplaneStyle Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartBackplaneStyle Class : ChartBackplaneStyle Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New ChartBackplaneStyle()
C#
public ChartBackplaneStyle()
Delphi
public ChartBackplaneStyle();
JScript
public function ChartBackplaneStyle();
Managed Extensions for C++
public: ChartBackplaneStyle();
C++/CLI
public:
ChartBackplaneStyle();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartBackplaneStyle Class
ChartBackplaneStyle Members


Clone Method

[image]
Intersoft WebGrid Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartBackplaneStyle Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As System.Object
Visual Basic (Usage) Copy Code
Dim instance As ChartBackplaneStyle
Dim value As System.Object

value = instance.Clone()
C#
public virtual System.object Clone()
Delphi
public function Clone(): System.TObject; virtual;
JScript
public function Clone() : System.Object;
Managed Extensions for C++
public: virtual System.Object* Clone();
C++/CLI
public:
virtual System.Object^ Clone();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartBackplaneStyle Class
ChartBackplaneStyle Members


CopyFrom Method

[image]
Intersoft WebGrid Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartBackplaneStyle Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartBackplaneStyle Class
ChartBackplaneStyle Members


CopyFrom(Object) Method

[image]
Intersoft WebGrid Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartBackplaneStyle Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartBackplaneStyle
Dim objSource As System.Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   System.object objSource
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartBackplaneStyle Class
ChartBackplaneStyle Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebGrid Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartBackplaneStyle Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object, _
   ByVal cloneSourceValue As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartBackplaneStyle
Dim objSource As System.Object
Dim cloneSourceValue As System.Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   System.object objSource,
   System.bool cloneSourceValue
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject;
    cloneSourceValue: System.Boolean
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object,
   cloneSourceValue : System.boolean
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource,
   System.bool cloneSourceValue
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource,
   System.bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartBackplaneStyle Class
ChartBackplaneStyle Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebGrid Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartBackplaneStyle Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartBackplaneStyle
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure DeSerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function DeSerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void DeSerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void DeSerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartBackplaneStyle Class
ChartBackplaneStyle Members


GetHashCode Method

[image]
Intersoft WebGrid Documentation
GetHashCode Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartBackplaneStyle Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As ChartBackplaneStyle
Dim value As System.Integer

value = instance.GetHashCode()
C#
public virtual System.int GetHashCode()
Delphi
public function GetHashCode(): System.Integer; virtual;
JScript
public function GetHashCode() : System.int;
Managed Extensions for C++
public: virtual System.int GetHashCode();
C++/CLI
public:
virtual System.int GetHashCode();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartBackplaneStyle Class
ChartBackplaneStyle Members


ChartBackplaneStyle Class Methods

[image]
Intersoft WebGrid Documentation
ChartBackplaneStyle Class Methods
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartBackplaneStyle Class

Glossary Item Box

For a list of all members of this type, see ChartBackplaneStyle members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

ChartBackplaneStyle Class
ISNet.WebUI.WebGrid.Chart Namespace


GetObjectData Method

[image]
Intersoft WebGrid Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartBackplaneStyle Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=False,
   UnmanagedCode=False,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=True,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Action=SecurityAction.Demand,
   Unrestricted=False)>
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartBackplaneStyle
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure GetObjectData(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
); override;
JScript
System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=,
   UnmanagedCode=,
   SkipVerification=,
   Execution=,
   ControlThread=,
   ControlEvidence=,
   ControlPolicy=,
   SerializationFormatter=,
   ControlDomainPolicy=,
   ControlPrincipal=,
   ControlAppDomain=,
   RemotingConfiguration=,
   Infrastructure=,
   BindingRedirects=,
   Action=SecurityAction.Demand,
   Unrestricted=)
public override function GetObjectData(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public: void GetObjectData(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
) override
C++/CLI
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public:
void GetObjectData(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
) override

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartBackplaneStyle Class
ChartBackplaneStyle Members


IsEmpty Method

[image]
Intersoft WebGrid Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartBackplaneStyle Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As ChartBackplaneStyle
Dim value As System.Boolean

value = instance.IsEmpty()
C#
public virtual System.bool IsEmpty()
Delphi
public function IsEmpty(): System.Boolean; virtual;
JScript
public function IsEmpty() : System.boolean;
Managed Extensions for C++
public: virtual System.bool IsEmpty();
C++/CLI
public:
virtual System.bool IsEmpty();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartBackplaneStyle Class
ChartBackplaneStyle Members


Reset Method

[image]
Intersoft WebGrid Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartBackplaneStyle Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As ChartBackplaneStyle

instance.Reset()
C#
public virtual void Reset()
Delphi
public procedure Reset(); virtual;
JScript
public function Reset();
Managed Extensions for C++
public: virtual void Reset();
C++/CLI
public:
virtual void Reset();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartBackplaneStyle Class
ChartBackplaneStyle Members


SerializeObjectData Method

[image]
Intersoft WebGrid Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartBackplaneStyle Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartBackplaneStyle
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure SerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function SerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void SerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void SerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartBackplaneStyle Class
ChartBackplaneStyle Members


ToString Method

[image]
Intersoft WebGrid Documentation
ToString Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartBackplaneStyle Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As System.String
Visual Basic (Usage) Copy Code
Dim instance As ChartBackplaneStyle
Dim value As System.String

value = instance.ToString()
C#
public virtual System.string ToString()
Delphi
public function ToString(): System.String; virtual;
JScript
public function ToString() : System.String;
Managed Extensions for C++
public: virtual System.string* ToString();
C++/CLI
public:
virtual System.String^ ToString();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartBackplaneStyle Class
ChartBackplaneStyle Members


ChartBackplaneStyle Class Properties

[image]
Intersoft WebGrid Documentation
ChartBackplaneStyle Class Properties
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartBackplaneStyle Class

Glossary Item Box

For a list of all members of this type, see ChartBackplaneStyle members.

Public Properties

 | Name | Description
Public Property | EdgePercent |
Public Property | FillStyle |
Public Property | Inflate |
Public Property | ShadowStyle |
Public Property | Shape |
Public Property | StandardFrameStyle |
Public Property | Visible |
Top

See Also

Reference

ChartBackplaneStyle Class
ISNet.WebUI.WebGrid.Chart Namespace


ChartBackplaneStyle Constructor

[image]
Intersoft WebGrid Documentation
ChartBackplaneStyle Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartBackplaneStyle Class : ChartBackplaneStyle Constructor

Glossary Item Box

Overload List

Overload | Description
ChartBackplaneStyle Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartBackplaneStyle Class
ChartBackplaneStyle Members


EdgePercent Property

[image]
Intersoft WebGrid Documentation
EdgePercent Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartBackplaneStyle Class : EdgePercent Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("General")>
<System.ComponentModel.DescriptionAttribute("Controls the edge size of the smooth edge or cut edge rectangle.")>
Public Property EdgePercent As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As ChartBackplaneStyle
Dim value As System.Integer

instance.EdgePercent = value

value = instance.EdgePercent
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DescriptionAttribute("Controls the edge size of the smooth edge or cut edge rectangle.")]
public System.int EdgePercent {get; set;}
Delphi
public read-write property EdgePercent: System.Integer;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("General")
System.ComponentModel.DescriptionAttribute("Controls the edge size of the smooth edge or cut edge rectangle.")
public function get,set EdgePercent : System.int
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DescriptionAttribute("Controls the edge size of the smooth edge or cut edge rectangle.")]
public: __property System.int get_EdgePercent();
public: __property void set_EdgePercent(
   System.int value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DescriptionAttribute("Controls the edge size of the smooth edge or cut edge rectangle.")]
public:
property System.int EdgePercent {
   System.int get();
   void set (    System.int value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartBackplaneStyle Class
ChartBackplaneStyle Members


FillStyle Property

[image]
Intersoft WebGrid Documentation
FillStyle Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartBackplaneStyle Class : FillStyle Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.CategoryAttribute("Appearance")>
<System.ComponentModel.DescriptionAttribute("The fill effect applied on the backplane.")>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<ISNet.Serialization.BinarySerializableAttribute("setFillStyle")>
<System.ComponentModel.DefaultValueAttribute()>
Public ReadOnly Property FillStyle As ChartFillStyle
Visual Basic (Usage) Copy Code
Dim instance As ChartBackplaneStyle
Dim value As ChartFillStyle

value = instance.FillStyle
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.DescriptionAttribute("The fill effect applied on the backplane.")]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.Serialization.BinarySerializableAttribute("setFillStyle")]
[System.ComponentModel.DefaultValueAttribute()]
public ChartFillStyle FillStyle {get;}
Delphi
public read-only property FillStyle: ChartFillStyle;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.CategoryAttribute("Appearance")
System.ComponentModel.DescriptionAttribute("The fill effect applied on the backplane.")
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
ISNet.Serialization.BinarySerializableAttribute("setFillStyle")
System.ComponentModel.DefaultValueAttribute()
public function get FillStyle : ChartFillStyle
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.DescriptionAttribute("The fill effect applied on the backplane.")]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.Serialization.BinarySerializableAttribute("setFillStyle")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property ChartFillStyle* get_FillStyle();
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.DescriptionAttribute("The fill effect applied on the backplane.")]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.Serialization.BinarySerializableAttribute("setFillStyle")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property ChartFillStyle^ FillStyle {
   ChartFillStyle^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartBackplaneStyle Class
ChartBackplaneStyle Members


Inflate Property

[image]
Intersoft WebGrid Documentation
Inflate Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartBackplaneStyle Class : Inflate Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Inflates the backplane dimensions in pixels.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.CategoryAttribute("General")>
<ISNet.Serialization.BinarySerializableAttribute("setInflate")>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<System.ComponentModel.DefaultValueAttribute()>
Public ReadOnly Property Inflate As ChartSizeValue
Visual Basic (Usage) Copy Code
Dim instance As ChartBackplaneStyle
Dim value As ChartSizeValue

value = instance.Inflate
C#
[System.ComponentModel.DescriptionAttribute("Inflates the backplane dimensions in pixels.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.CategoryAttribute("General")]
[ISNet.Serialization.BinarySerializableAttribute("setInflate")]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DefaultValueAttribute()]
public ChartSizeValue Inflate {get;}
Delphi
public read-only property Inflate: ChartSizeValue;
JScript
System.ComponentModel.DescriptionAttribute("Inflates the backplane dimensions in pixels.")
System.ComponentModel.NotifyParentPropertyAttribute()
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.CategoryAttribute("General")
ISNet.Serialization.BinarySerializableAttribute("setInflate")
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
System.ComponentModel.DefaultValueAttribute()
public function get Inflate : ChartSizeValue
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Inflates the backplane dimensions in pixels.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.CategoryAttribute("General")]
[ISNet.Serialization.BinarySerializableAttribute("setInflate")]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property ChartSizeValue* get_Inflate();
C++/CLI
[System.ComponentModel.DescriptionAttribute("Inflates the backplane dimensions in pixels.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.CategoryAttribute("General")]
[ISNet.Serialization.BinarySerializableAttribute("setInflate")]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property ChartSizeValue^ Inflate {
   ChartSizeValue^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartBackplaneStyle Class
ChartBackplaneStyle Members


ShadowStyle Property

[image]
Intersoft WebGrid Documentation
ShadowStyle Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartBackplaneStyle Class : ShadowStyle Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<System.ComponentModel.CategoryAttribute("Appearance")>
<System.ComponentModel.DescriptionAttribute("Controls the shadow of the backplane.")>
<ISNet.Serialization.BinarySerializableAttribute("setShadowStyle")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public ReadOnly Property ShadowStyle As ChartShadowStyle
Visual Basic (Usage) Copy Code
Dim instance As ChartBackplaneStyle
Dim value As ChartShadowStyle

value = instance.ShadowStyle
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.DescriptionAttribute("Controls the shadow of the backplane.")]
[ISNet.Serialization.BinarySerializableAttribute("setShadowStyle")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public ChartShadowStyle ShadowStyle {get;}
Delphi
public read-only property ShadowStyle: ChartShadowStyle;
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
System.ComponentModel.CategoryAttribute("Appearance")
System.ComponentModel.DescriptionAttribute("Controls the shadow of the backplane.")
ISNet.Serialization.BinarySerializableAttribute("setShadowStyle")
System.ComponentModel.NotifyParentPropertyAttribute()
public function get ShadowStyle : ChartShadowStyle
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.DescriptionAttribute("Controls the shadow of the backplane.")]
[ISNet.Serialization.BinarySerializableAttribute("setShadowStyle")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property ChartShadowStyle* get_ShadowStyle();
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.DescriptionAttribute("Controls the shadow of the backplane.")]
[ISNet.Serialization.BinarySerializableAttribute("setShadowStyle")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property ChartShadowStyle^ ShadowStyle {
   ChartShadowStyle^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartBackplaneStyle Class
ChartBackplaneStyle Members


Shape Property

[image]
Intersoft WebGrid Documentation
Shape Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartBackplaneStyle Class : Shape Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Defines the style of the backplane.")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("General")>
Public Property Shape As BackplaneShape
Visual Basic (Usage) Copy Code
Dim instance As ChartBackplaneStyle
Dim value As BackplaneShape

instance.Shape = value

value = instance.Shape
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Defines the style of the backplane.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
public BackplaneShape Shape {get; set;}
Delphi
public read-write property Shape: BackplaneShape;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Defines the style of the backplane.")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("General")
public function get,set Shape : BackplaneShape
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Defines the style of the backplane.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
public: __property BackplaneShape get_Shape();
public: __property void set_Shape(
   BackplaneShape value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Defines the style of the backplane.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
public:
property BackplaneShape Shape {
   BackplaneShape get();
   void set (    BackplaneShape value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartBackplaneStyle Class
ChartBackplaneStyle Members


StandardFrameStyle Property

[image]
Intersoft WebGrid Documentation
StandardFrameStyle Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartBackplaneStyle Class : StandardFrameStyle Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Controls the standard frame of the backplane.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<System.ComponentModel.CategoryAttribute("Appearance")>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute("setStandardFrameStyle")>
Public ReadOnly Property StandardFrameStyle As ChartStandardFrameStyle
Visual Basic (Usage) Copy Code
Dim instance As ChartBackplaneStyle
Dim value As ChartStandardFrameStyle

value = instance.StandardFrameStyle
C#
[System.ComponentModel.DescriptionAttribute("Controls the standard frame of the backplane.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute("setStandardFrameStyle")]
public ChartStandardFrameStyle StandardFrameStyle {get;}
Delphi
public read-only property StandardFrameStyle: ChartStandardFrameStyle;
JScript
System.ComponentModel.DescriptionAttribute("Controls the standard frame of the backplane.")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
System.ComponentModel.CategoryAttribute("Appearance")
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute("setStandardFrameStyle")
public function get StandardFrameStyle : ChartStandardFrameStyle
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Controls the standard frame of the backplane.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute("setStandardFrameStyle")]
public: __property ChartStandardFrameStyle* get_StandardFrameStyle();
C++/CLI
[System.ComponentModel.DescriptionAttribute("Controls the standard frame of the backplane.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute("setStandardFrameStyle")]
public:
property ChartStandardFrameStyle^ StandardFrameStyle {
   ChartStandardFrameStyle^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartBackplaneStyle Class
ChartBackplaneStyle Members


Visible Property

[image]
Intersoft WebGrid Documentation
Visible Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartBackplaneStyle Class : Visible Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("General")>
<System.ComponentModel.DescriptionAttribute("Controls the visibility of the back plane.")>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property Visible As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As ChartBackplaneStyle
Dim value As System.Boolean

instance.Visible = value

value = instance.Visible
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DescriptionAttribute("Controls the visibility of the back plane.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public System.bool Visible {get; set;}
Delphi
public read-write property Visible: System.Boolean;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("General")
System.ComponentModel.DescriptionAttribute("Controls the visibility of the back plane.")
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get,set Visible : System.boolean
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DescriptionAttribute("Controls the visibility of the back plane.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.bool get_Visible();
public: __property void set_Visible(
   System.bool value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DescriptionAttribute("Controls the visibility of the back plane.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.bool Visible {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartBackplaneStyle Class
ChartBackplaneStyle Members


ChartBarTypeSettings Class

[image]
Intersoft WebGrid Documentation
ChartBarTypeSettings Class
Members See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartBarTypeSettings Class

Glossary Item Box

Object Model

ChartBarTypeSettings Class

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.SerializableAttribute()>
Public Class ChartBarTypeSettings
   Inherits ISNet.WebUI.WebUIBaseClass
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Visual Basic (Usage) Copy Code
Dim instance As ChartBarTypeSettings
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public class ChartBarTypeSettings : ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Delphi
public class ChartBarTypeSettings = class(ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize)
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.SerializableAttribute()
public class ChartBarTypeSettings extends ISNet.WebUI.WebUIBaseClass implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public __gc class ChartBarTypeSettings : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public ref class ChartBarTypeSettings : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.WebGrid.Chart.ChartBarTypeSettings

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartBarTypeSettings Members
ISNet.WebUI.WebGrid.Chart Namespace


ChartBarTypeSettings Class Members

[image]
Intersoft WebGrid Documentation
ChartBarTypeSettings Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartBarTypeSettings Class

Glossary Item Box

The following tables list the members exposed by ChartBarTypeSettings.

Public Constructors

 | Name | Description
Public Constructor | ChartBarTypeSettings Constructor |
Top

Public Properties

 | Name | Description
Public Property | EnableBasic3DBarType |
Public Property | EnableClustered3DBarType |
Public Property | EnableClusteredBarType |
Public Property | Enabled |
Public Property | EnableStacked3DBarType |
Public Property | EnableStackedBarType |
Public Property | EnableStackedPercentage3DBarType |
Public Property | EnableStackedPercentageBarType |
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

ChartBarTypeSettings Class
ISNet.WebUI.WebGrid.Chart Namespace


ChartBarTypeSettings Constructor

[image]
Intersoft WebGrid Documentation
ChartBarTypeSettings Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartBarTypeSettings Class : ChartBarTypeSettings Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New ChartBarTypeSettings()
C#
public ChartBarTypeSettings()
Delphi
public ChartBarTypeSettings();
JScript
public function ChartBarTypeSettings();
Managed Extensions for C++
public: ChartBarTypeSettings();
C++/CLI
public:
ChartBarTypeSettings();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartBarTypeSettings Class
ChartBarTypeSettings Members


Clone Method

[image]
Intersoft WebGrid Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartBarTypeSettings Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As System.Object
Visual Basic (Usage) Copy Code
Dim instance As ChartBarTypeSettings
Dim value As System.Object

value = instance.Clone()
C#
public virtual System.object Clone()
Delphi
public function Clone(): System.TObject; virtual;
JScript
public function Clone() : System.Object;
Managed Extensions for C++
public: virtual System.Object* Clone();
C++/CLI
public:
virtual System.Object^ Clone();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartBarTypeSettings Class
ChartBarTypeSettings Members


CopyFrom Method

[image]
Intersoft WebGrid Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartBarTypeSettings Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartBarTypeSettings Class
ChartBarTypeSettings Members


CopyFrom(Object) Method

[image]
Intersoft WebGrid Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartBarTypeSettings Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartBarTypeSettings
Dim objSource As System.Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   System.object objSource
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartBarTypeSettings Class
ChartBarTypeSettings Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebGrid Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartBarTypeSettings Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object, _
   ByVal cloneSourceValue As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartBarTypeSettings
Dim objSource As System.Object
Dim cloneSourceValue As System.Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   System.object objSource,
   System.bool cloneSourceValue
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject;
    cloneSourceValue: System.Boolean
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object,
   cloneSourceValue : System.boolean
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource,
   System.bool cloneSourceValue
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource,
   System.bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartBarTypeSettings Class
ChartBarTypeSettings Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebGrid Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartBarTypeSettings Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartBarTypeSettings
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure DeSerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function DeSerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void DeSerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void DeSerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartBarTypeSettings Class
ChartBarTypeSettings Members


GetHashCode Method

[image]
Intersoft WebGrid Documentation
GetHashCode Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartBarTypeSettings Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As ChartBarTypeSettings
Dim value As System.Integer

value = instance.GetHashCode()
C#
public virtual System.int GetHashCode()
Delphi
public function GetHashCode(): System.Integer; virtual;
JScript
public function GetHashCode() : System.int;
Managed Extensions for C++
public: virtual System.int GetHashCode();
C++/CLI
public:
virtual System.int GetHashCode();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartBarTypeSettings Class
ChartBarTypeSettings Members


ChartBarTypeSettings Class Methods

[image]
Intersoft WebGrid Documentation
ChartBarTypeSettings Class Methods
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartBarTypeSettings Class

Glossary Item Box

For a list of all members of this type, see ChartBarTypeSettings members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

ChartBarTypeSettings Class
ISNet.WebUI.WebGrid.Chart Namespace


GetObjectData Method

[image]
Intersoft WebGrid Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartBarTypeSettings Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=False,
   UnmanagedCode=False,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=True,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Action=SecurityAction.Demand,
   Unrestricted=False)>
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartBarTypeSettings
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure GetObjectData(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
); override;
JScript
System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=,
   UnmanagedCode=,
   SkipVerification=,
   Execution=,
   ControlThread=,
   ControlEvidence=,
   ControlPolicy=,
   SerializationFormatter=,
   ControlDomainPolicy=,
   ControlPrincipal=,
   ControlAppDomain=,
   RemotingConfiguration=,
   Infrastructure=,
   BindingRedirects=,
   Action=SecurityAction.Demand,
   Unrestricted=)
public override function GetObjectData(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public: void GetObjectData(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
) override
C++/CLI
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public:
void GetObjectData(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
) override

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartBarTypeSettings Class
ChartBarTypeSettings Members


IsEmpty Method

[image]
Intersoft WebGrid Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartBarTypeSettings Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As ChartBarTypeSettings
Dim value As System.Boolean

value = instance.IsEmpty()
C#
public virtual System.bool IsEmpty()
Delphi
public function IsEmpty(): System.Boolean; virtual;
JScript
public function IsEmpty() : System.boolean;
Managed Extensions for C++
public: virtual System.bool IsEmpty();
C++/CLI
public:
virtual System.bool IsEmpty();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartBarTypeSettings Class
ChartBarTypeSettings Members


Reset Method

[image]
Intersoft WebGrid Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartBarTypeSettings Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As ChartBarTypeSettings

instance.Reset()
C#
public virtual void Reset()
Delphi
public procedure Reset(); virtual;
JScript
public function Reset();
Managed Extensions for C++
public: virtual void Reset();
C++/CLI
public:
virtual void Reset();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartBarTypeSettings Class
ChartBarTypeSettings Members


SerializeObjectData Method

[image]
Intersoft WebGrid Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartBarTypeSettings Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartBarTypeSettings
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure SerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function SerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void SerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void SerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartBarTypeSettings Class
ChartBarTypeSettings Members


ToString Method

[image]
Intersoft WebGrid Documentation
ToString Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartBarTypeSettings Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As System.String
Visual Basic (Usage) Copy Code
Dim instance As ChartBarTypeSettings
Dim value As System.String

value = instance.ToString()
C#
public virtual System.string ToString()
Delphi
public function ToString(): System.String; virtual;
JScript
public function ToString() : System.String;
Managed Extensions for C++
public: virtual System.string* ToString();
C++/CLI
public:
virtual System.String^ ToString();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartBarTypeSettings Class
ChartBarTypeSettings Members


ChartBarTypeSettings Class Properties

[image]
Intersoft WebGrid Documentation
ChartBarTypeSettings Class Properties
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartBarTypeSettings Class

Glossary Item Box

For a list of all members of this type, see ChartBarTypeSettings members.

Public Properties

 | Name | Description
Public Property | EnableBasic3DBarType |
Public Property | EnableClustered3DBarType |
Public Property | EnableClusteredBarType |
Public Property | Enabled |
Public Property | EnableStacked3DBarType |
Public Property | EnableStackedBarType |
Public Property | EnableStackedPercentage3DBarType |
Public Property | EnableStackedPercentageBarType |
Top

See Also

Reference

ChartBarTypeSettings Class
ISNet.WebUI.WebGrid.Chart Namespace


ChartBarTypeSettings Constructor

[image]
Intersoft WebGrid Documentation
ChartBarTypeSettings Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartBarTypeSettings Class : ChartBarTypeSettings Constructor

Glossary Item Box

Overload List

Overload | Description
ChartBarTypeSettings Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartBarTypeSettings Class
ChartBarTypeSettings Members


EnableBasic3DBarType Property

[image]
Intersoft WebGrid Documentation
EnableBasic3DBarType Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartBarTypeSettings Class : EnableBasic3DBarType Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Options")>
<System.ComponentModel.DescriptionAttribute("Enable user to switch chart to Basic 3D Bar type.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
Public Property EnableBasic3DBarType As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As ChartBarTypeSettings
Dim value As System.Boolean

instance.EnableBasic3DBarType = value

value = instance.EnableBasic3DBarType
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Options")]
[System.ComponentModel.DescriptionAttribute("Enable user to switch chart to Basic 3D Bar type.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public System.bool EnableBasic3DBarType {get; set;}
Delphi
public read-write property EnableBasic3DBarType: System.Boolean;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Options")
System.ComponentModel.DescriptionAttribute("Enable user to switch chart to Basic 3D Bar type.")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
public function get,set EnableBasic3DBarType : System.boolean
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Options")]
[System.ComponentModel.DescriptionAttribute("Enable user to switch chart to Basic 3D Bar type.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.bool get_EnableBasic3DBarType();
public: __property void set_EnableBasic3DBarType(
   System.bool value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Options")]
[System.ComponentModel.DescriptionAttribute("Enable user to switch chart to Basic 3D Bar type.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.bool EnableBasic3DBarType {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartBarTypeSettings Class
ChartBarTypeSettings Members


EnableClustered3DBarType Property

[image]
Intersoft WebGrid Documentation
EnableClustered3DBarType Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartBarTypeSettings Class : EnableClustered3DBarType Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Enable user to switch chart to Clustered 3D Bar type.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Options")>
Public Property EnableClustered3DBarType As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As ChartBarTypeSettings
Dim value As System.Boolean

instance.EnableClustered3DBarType = value

value = instance.EnableClustered3DBarType
C#
[System.ComponentModel.DescriptionAttribute("Enable user to switch chart to Clustered 3D Bar type.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Options")]
public System.bool EnableClustered3DBarType {get; set;}
Delphi
public read-write property EnableClustered3DBarType: System.Boolean;
JScript
System.ComponentModel.DescriptionAttribute("Enable user to switch chart to Clustered 3D Bar type.")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Options")
public function get,set EnableClustered3DBarType : System.boolean
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Enable user to switch chart to Clustered 3D Bar type.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Options")]
public: __property System.bool get_EnableClustered3DBarType();
public: __property void set_EnableClustered3DBarType(
   System.bool value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Enable user to switch chart to Clustered 3D Bar type.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Options")]
public:
property System.bool EnableClustered3DBarType {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartBarTypeSettings Class
ChartBarTypeSettings Members


EnableClusteredBarType Property

[image]
Intersoft WebGrid Documentation
EnableClusteredBarType Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartBarTypeSettings Class : EnableClusteredBarType Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Options")>
<System.ComponentModel.DescriptionAttribute("Enable user to switch chart to Clustered Bar type.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
Public Property EnableClusteredBarType As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As ChartBarTypeSettings
Dim value As System.Boolean

instance.EnableClusteredBarType = value

value = instance.EnableClusteredBarType
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Options")]
[System.ComponentModel.DescriptionAttribute("Enable user to switch chart to Clustered Bar type.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public System.bool EnableClusteredBarType {get; set;}
Delphi
public read-write property EnableClusteredBarType: System.Boolean;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Options")
System.ComponentModel.DescriptionAttribute("Enable user to switch chart to Clustered Bar type.")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
public function get,set EnableClusteredBarType : System.boolean
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Options")]
[System.ComponentModel.DescriptionAttribute("Enable user to switch chart to Clustered Bar type.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.bool get_EnableClusteredBarType();
public: __property void set_EnableClusteredBarType(
   System.bool value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Options")]
[System.ComponentModel.DescriptionAttribute("Enable user to switch chart to Clustered Bar type.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.bool EnableClusteredBarType {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartBarTypeSettings Class
ChartBarTypeSettings Members


Enabled Property

[image]
Intersoft WebGrid Documentation
Enabled Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartBarTypeSettings Class : Enabled Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Enable user to switch chart to Series Bar types.")>
<System.ComponentModel.CategoryAttribute("Options")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property Enabled As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As ChartBarTypeSettings
Dim value As System.Boolean

instance.Enabled = value

value = instance.Enabled
C#
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Enable user to switch chart to Series Bar types.")]
[System.ComponentModel.CategoryAttribute("Options")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public System.bool Enabled {get; set;}
Delphi
public read-write property Enabled: System.Boolean;
JScript
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Enable user to switch chart to Series Bar types.")
System.ComponentModel.CategoryAttribute("Options")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get,set Enabled : System.boolean
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Enable user to switch chart to Series Bar types.")]
[System.ComponentModel.CategoryAttribute("Options")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.bool get_Enabled();
public: __property void set_Enabled(
   System.bool value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Enable user to switch chart to Series Bar types.")]
[System.ComponentModel.CategoryAttribute("Options")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.bool Enabled {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartBarTypeSettings Class
ChartBarTypeSettings Members


EnableStacked3DBarType Property

[image]
Intersoft WebGrid Documentation
EnableStacked3DBarType Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartBarTypeSettings Class : EnableStacked3DBarType Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Enable user to switch chart to Stacked 3D Bar type.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Options")>
Public Property EnableStacked3DBarType As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As ChartBarTypeSettings
Dim value As System.Boolean

instance.EnableStacked3DBarType = value

value = instance.EnableStacked3DBarType
C#
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Enable user to switch chart to Stacked 3D Bar type.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Options")]
public System.bool EnableStacked3DBarType {get; set;}
Delphi
public read-write property EnableStacked3DBarType: System.Boolean;
JScript
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Enable user to switch chart to Stacked 3D Bar type.")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Options")
public function get,set EnableStacked3DBarType : System.boolean
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Enable user to switch chart to Stacked 3D Bar type.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Options")]
public: __property System.bool get_EnableStacked3DBarType();
public: __property void set_EnableStacked3DBarType(
   System.bool value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Enable user to switch chart to Stacked 3D Bar type.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Options")]
public:
property System.bool EnableStacked3DBarType {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartBarTypeSettings Class
ChartBarTypeSettings Members


EnableStackedBarType Property

[image]
Intersoft WebGrid Documentation
EnableStackedBarType Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartBarTypeSettings Class : EnableStackedBarType Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Enable user to switch chart to Stacked Bar type.")>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Options")>
Public Property EnableStackedBarType As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As ChartBarTypeSettings
Dim value As System.Boolean

instance.EnableStackedBarType = value

value = instance.EnableStackedBarType
C#
[System.ComponentModel.DescriptionAttribute("Enable user to switch chart to Stacked Bar type.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Options")]
public System.bool EnableStackedBarType {get; set;}
Delphi
public read-write property EnableStackedBarType: System.Boolean;
JScript
System.ComponentModel.DescriptionAttribute("Enable user to switch chart to Stacked Bar type.")
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Options")
public function get,set EnableStackedBarType : System.boolean
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Enable user to switch chart to Stacked Bar type.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Options")]
public: __property System.bool get_EnableStackedBarType();
public: __property void set_EnableStackedBarType(
   System.bool value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Enable user to switch chart to Stacked Bar type.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Options")]
public:
property System.bool EnableStackedBarType {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartBarTypeSettings Class
ChartBarTypeSettings Members


EnableStackedPercentage3DBarType Property

[image]
Intersoft WebGrid Documentation
EnableStackedPercentage3DBarType Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartBarTypeSettings Class : EnableStackedPercentage3DBarType Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Options")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Enable user to switch chart to 100% Stacked 3D Bar type.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Property EnableStackedPercentage3DBarType As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As ChartBarTypeSettings
Dim value As System.Boolean

instance.EnableStackedPercentage3DBarType = value

value = instance.EnableStackedPercentage3DBarType
C#
[System.ComponentModel.CategoryAttribute("Options")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Enable user to switch chart to 100% Stacked 3D Bar type.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public System.bool EnableStackedPercentage3DBarType {get; set;}
Delphi
public read-write property EnableStackedPercentage3DBarType: System.Boolean;
JScript
System.ComponentModel.CategoryAttribute("Options")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DescriptionAttribute("Enable user to switch chart to 100% Stacked 3D Bar type.")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute()
public function get,set EnableStackedPercentage3DBarType : System.boolean
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Options")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Enable user to switch chart to 100% Stacked 3D Bar type.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property System.bool get_EnableStackedPercentage3DBarType();
public: __property void set_EnableStackedPercentage3DBarType(
   System.bool value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Options")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Enable user to switch chart to 100% Stacked 3D Bar type.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property System.bool EnableStackedPercentage3DBarType {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartBarTypeSettings Class
ChartBarTypeSettings Members


EnableStackedPercentageBarType Property

[image]
Intersoft WebGrid Documentation
EnableStackedPercentageBarType Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartBarTypeSettings Class : EnableStackedPercentageBarType Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Enable user to switch chart to 100% Stacked Bar type.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("Options")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property EnableStackedPercentageBarType As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As ChartBarTypeSettings
Dim value As System.Boolean

instance.EnableStackedPercentageBarType = value

value = instance.EnableStackedPercentageBarType
C#
[System.ComponentModel.DescriptionAttribute("Enable user to switch chart to 100% Stacked Bar type.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Options")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public System.bool EnableStackedPercentageBarType {get; set;}
Delphi
public read-write property EnableStackedPercentageBarType: System.Boolean;
JScript
System.ComponentModel.DescriptionAttribute("Enable user to switch chart to 100% Stacked Bar type.")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("Options")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get,set EnableStackedPercentageBarType : System.boolean
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Enable user to switch chart to 100% Stacked Bar type.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Options")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.bool get_EnableStackedPercentageBarType();
public: __property void set_EnableStackedPercentageBarType(
   System.bool value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Enable user to switch chart to 100% Stacked Bar type.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Options")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.bool EnableStackedPercentageBarType {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartBarTypeSettings Class
ChartBarTypeSettings Members


ChartBevelAndEmbossImageFilterSettings Class

[image]
Intersoft WebGrid Documentation
ChartBevelAndEmbossImageFilterSettings Class
Members See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartBevelAndEmbossImageFilterSettings Class

Glossary Item Box

Object Model

ChartBevelAndEmbossImageFilterSettings Class

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.SerializableAttribute()>
Public Class ChartBevelAndEmbossImageFilterSettings
   Inherits ChartImageFilterSettings
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Visual Basic (Usage) Copy Code
Dim instance As ChartBevelAndEmbossImageFilterSettings
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public class ChartBevelAndEmbossImageFilterSettings : ChartImageFilterSettings, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Delphi
public class ChartBevelAndEmbossImageFilterSettings = class(ChartImageFilterSettings, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize)
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.SerializableAttribute()
public class ChartBevelAndEmbossImageFilterSettings extends ChartImageFilterSettings implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public __gc class ChartBevelAndEmbossImageFilterSettings : public ChartImageFilterSettings, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public ref class ChartBevelAndEmbossImageFilterSettings : public ChartImageFilterSettings, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.WebGrid.Chart.ChartImageFilterSettings
ISNet.WebUI.WebGrid.Chart.ChartBevelAndEmbossImageFilterSettings

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartBevelAndEmbossImageFilterSettings Members
ISNet.WebUI.WebGrid.Chart Namespace


ChartBevelAndEmbossImageFilterSettings Class Members

[image]
Intersoft WebGrid Documentation
ChartBevelAndEmbossImageFilterSettings Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartBevelAndEmbossImageFilterSettings Class

Glossary Item Box

The following tables list the members exposed by ChartBevelAndEmbossImageFilterSettings.

Public Constructors

 | Name | Description
Public Constructor | ChartBevelAndEmbossImageFilterSettings Constructor |
Top

Public Properties

 | Name | Description
Public Property | Angle |
Public Property | BevelType |
Public Property | BlurType | (Inherited from ISNet.WebUI.WebGrid.Chart.ChartImageFilterSettings)
Public Property | Depth |
Public Property | Enabled | (Inherited from ISNet.WebUI.WebGrid.Chart.ChartImageFilterSettings)
Public Property | LightColor |
Public Property | OriginalOpacity |
Public Property | ShadowColor |
Public Property | Soften |
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

ChartBevelAndEmbossImageFilterSettings Class
ISNet.WebUI.WebGrid.Chart Namespace


ChartBevelAndEmbossImageFilterSettings Constructor

[image]
Intersoft WebGrid Documentation
ChartBevelAndEmbossImageFilterSettings Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartBevelAndEmbossImageFilterSettings Class : ChartBevelAndEmbossImageFilterSettings Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New ChartBevelAndEmbossImageFilterSettings()
C#
public ChartBevelAndEmbossImageFilterSettings()
Delphi
public ChartBevelAndEmbossImageFilterSettings();
JScript
public function ChartBevelAndEmbossImageFilterSettings();
Managed Extensions for C++
public: ChartBevelAndEmbossImageFilterSettings();
C++/CLI
public:
ChartBevelAndEmbossImageFilterSettings();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartBevelAndEmbossImageFilterSettings Class
ChartBevelAndEmbossImageFilterSettings Members


Clone Method

[image]
Intersoft WebGrid Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartBevelAndEmbossImageFilterSettings Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As System.Object
Visual Basic (Usage) Copy Code
Dim instance As ChartBevelAndEmbossImageFilterSettings
Dim value As System.Object

value = instance.Clone()
C#
public virtual System.object Clone()
Delphi
public function Clone(): System.TObject; virtual;
JScript
public function Clone() : System.Object;
Managed Extensions for C++
public: virtual System.Object* Clone();
C++/CLI
public:
virtual System.Object^ Clone();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartBevelAndEmbossImageFilterSettings Class
ChartBevelAndEmbossImageFilterSettings Members


CopyFrom Method

[image]
Intersoft WebGrid Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartBevelAndEmbossImageFilterSettings Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartBevelAndEmbossImageFilterSettings Class
ChartBevelAndEmbossImageFilterSettings Members


CopyFrom(Object) Method

[image]
Intersoft WebGrid Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartBevelAndEmbossImageFilterSettings Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartBevelAndEmbossImageFilterSettings
Dim objSource As System.Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   System.object objSource
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartBevelAndEmbossImageFilterSettings Class
ChartBevelAndEmbossImageFilterSettings Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebGrid Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartBevelAndEmbossImageFilterSettings Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object, _
   ByVal cloneSourceValue As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartBevelAndEmbossImageFilterSettings
Dim objSource As System.Object
Dim cloneSourceValue As System.Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   System.object objSource,
   System.bool cloneSourceValue
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject;
    cloneSourceValue: System.Boolean
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object,
   cloneSourceValue : System.boolean
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource,
   System.bool cloneSourceValue
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource,
   System.bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartBevelAndEmbossImageFilterSettings Class
ChartBevelAndEmbossImageFilterSettings Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebGrid Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartBevelAndEmbossImageFilterSettings Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartBevelAndEmbossImageFilterSettings
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure DeSerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function DeSerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void DeSerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void DeSerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartBevelAndEmbossImageFilterSettings Class
ChartBevelAndEmbossImageFilterSettings Members


GetHashCode Method

[image]
Intersoft WebGrid Documentation
GetHashCode Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartBevelAndEmbossImageFilterSettings Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As ChartBevelAndEmbossImageFilterSettings
Dim value As System.Integer

value = instance.GetHashCode()
C#
public virtual System.int GetHashCode()
Delphi
public function GetHashCode(): System.Integer; virtual;
JScript
public function GetHashCode() : System.int;
Managed Extensions for C++
public: virtual System.int GetHashCode();
C++/CLI
public:
virtual System.int GetHashCode();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartBevelAndEmbossImageFilterSettings Class
ChartBevelAndEmbossImageFilterSettings Members


ChartBevelAndEmbossImageFilterSettings Class Methods

[image]
Intersoft WebGrid Documentation
ChartBevelAndEmbossImageFilterSettings Class Methods
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartBevelAndEmbossImageFilterSettings Class

Glossary Item Box

For a list of all members of this type, see ChartBevelAndEmbossImageFilterSettings members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

ChartBevelAndEmbossImageFilterSettings Class
ISNet.WebUI.WebGrid.Chart Namespace


GetObjectData Method

[image]
Intersoft WebGrid Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartBevelAndEmbossImageFilterSettings Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=False,
   UnmanagedCode=False,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=True,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Action=SecurityAction.Demand,
   Unrestricted=False)>
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartBevelAndEmbossImageFilterSettings
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure GetObjectData(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
); override;
JScript
System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=,
   UnmanagedCode=,
   SkipVerification=,
   Execution=,
   ControlThread=,
   ControlEvidence=,
   ControlPolicy=,
   SerializationFormatter=,
   ControlDomainPolicy=,
   ControlPrincipal=,
   ControlAppDomain=,
   RemotingConfiguration=,
   Infrastructure=,
   BindingRedirects=,
   Action=SecurityAction.Demand,
   Unrestricted=)
public override function GetObjectData(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public: void GetObjectData(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
) override
C++/CLI
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public:
void GetObjectData(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
) override

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartBevelAndEmbossImageFilterSettings Class
ChartBevelAndEmbossImageFilterSettings Members


IsEmpty Method

[image]
Intersoft WebGrid Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartBevelAndEmbossImageFilterSettings Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As ChartBevelAndEmbossImageFilterSettings
Dim value As System.Boolean

value = instance.IsEmpty()
C#
public virtual System.bool IsEmpty()
Delphi
public function IsEmpty(): System.Boolean; virtual;
JScript
public function IsEmpty() : System.boolean;
Managed Extensions for C++
public: virtual System.bool IsEmpty();
C++/CLI
public:
virtual System.bool IsEmpty();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartBevelAndEmbossImageFilterSettings Class
ChartBevelAndEmbossImageFilterSettings Members


Reset Method

[image]
Intersoft WebGrid Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartBevelAndEmbossImageFilterSettings Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As ChartBevelAndEmbossImageFilterSettings

instance.Reset()
C#
public virtual void Reset()
Delphi
public procedure Reset(); virtual;
JScript
public function Reset();
Managed Extensions for C++
public: virtual void Reset();
C++/CLI
public:
virtual void Reset();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartBevelAndEmbossImageFilterSettings Class
ChartBevelAndEmbossImageFilterSettings Members


SerializeObjectData Method

[image]
Intersoft WebGrid Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartBevelAndEmbossImageFilterSettings Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartBevelAndEmbossImageFilterSettings
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure SerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function SerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void SerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void SerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartBevelAndEmbossImageFilterSettings Class
ChartBevelAndEmbossImageFilterSettings Members


ToString Method

[image]
Intersoft WebGrid Documentation
ToString Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartBevelAndEmbossImageFilterSettings Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As System.String
Visual Basic (Usage) Copy Code
Dim instance As ChartBevelAndEmbossImageFilterSettings
Dim value As System.String

value = instance.ToString()
C#
public virtual System.string ToString()
Delphi
public function ToString(): System.String; virtual;
JScript
public function ToString() : System.String;
Managed Extensions for C++
public: virtual System.string* ToString();
C++/CLI
public:
virtual System.String^ ToString();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartBevelAndEmbossImageFilterSettings Class
ChartBevelAndEmbossImageFilterSettings Members


ChartBevelAndEmbossImageFilterSettings Class Properties

[image]
Intersoft WebGrid Documentation
ChartBevelAndEmbossImageFilterSettings Class Properties
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartBevelAndEmbossImageFilterSettings Class

Glossary Item Box

For a list of all members of this type, see ChartBevelAndEmbossImageFilterSettings members.

Public Properties

 | Name | Description
Public Property | Angle |
Public Property | BevelType |
Public Property | BlurType | (Inherited from ISNet.WebUI.WebGrid.Chart.ChartImageFilterSettings)
Public Property | Depth |
Public Property | Enabled | (Inherited from ISNet.WebUI.WebGrid.Chart.ChartImageFilterSettings)
Public Property | LightColor |
Public Property | OriginalOpacity |
Public Property | ShadowColor |
Public Property | Soften |
Top

See Also

Reference

ChartBevelAndEmbossImageFilterSettings Class
ISNet.WebUI.WebGrid.Chart Namespace


ChartBevelAndEmbossImageFilterSettings Constructor

[image]
Intersoft WebGrid Documentation
ChartBevelAndEmbossImageFilterSettings Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartBevelAndEmbossImageFilterSettings Class : ChartBevelAndEmbossImageFilterSettings Constructor

Glossary Item Box

Overload List

Overload | Description
ChartBevelAndEmbossImageFilterSettings Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartBevelAndEmbossImageFilterSettings Class
ChartBevelAndEmbossImageFilterSettings Members


Angle Property

[image]
Intersoft WebGrid Documentation
Angle Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartBevelAndEmbossImageFilterSettings Class : Angle Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("The angle of offset.")>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Size")>
Public Property Angle As System.Single
Visual Basic (Usage) Copy Code
Dim instance As ChartBevelAndEmbossImageFilterSettings
Dim value As System.Single

instance.Angle = value

value = instance.Angle
C#
[System.ComponentModel.DescriptionAttribute("The angle of offset.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Size")]
public System.float Angle {get; set;}
Delphi
public read-write property Angle: System.Single;
JScript
System.ComponentModel.DescriptionAttribute("The angle of offset.")
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Size")
public function get,set Angle : System.float
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("The angle of offset.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Size")]
public: __property System.float get_Angle();
public: __property void set_Angle(
   System.float value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("The angle of offset.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Size")]
public:
property System.float Angle {
   System.float get();
   void set (    System.float value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartBevelAndEmbossImageFilterSettings Class
ChartBevelAndEmbossImageFilterSettings Members


BevelType Property

[image]
Intersoft WebGrid Documentation
BevelType Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartBevelAndEmbossImageFilterSettings Class : BevelType Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("The type of bevel effect to generate.")>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Appearance")>
Public Property BevelType As BevelType
Visual Basic (Usage) Copy Code
Dim instance As ChartBevelAndEmbossImageFilterSettings
Dim value As BevelType

instance.BevelType = value

value = instance.BevelType
C#
[System.ComponentModel.DescriptionAttribute("The type of bevel effect to generate.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Appearance")]
public BevelType BevelType {get; set;}
Delphi
public read-write property BevelType: BevelType;
JScript
System.ComponentModel.DescriptionAttribute("The type of bevel effect to generate.")
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Appearance")
public function get,set BevelType : BevelType
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("The type of bevel effect to generate.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Appearance")]
public: __property BevelType get_BevelType();
public: __property void set_BevelType(
   BevelType value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("The type of bevel effect to generate.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Appearance")]
public:
property BevelType BevelType {
   BevelType get();
   void set (    BevelType value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartBevelAndEmbossImageFilterSettings Class
ChartBevelAndEmbossImageFilterSettings Members


Depth Property

[image]
Intersoft WebGrid Documentation
Depth Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartBevelAndEmbossImageFilterSettings Class : Depth Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Size")>
<System.ComponentModel.DescriptionAttribute("The depth of the bevel effect, affects the distance between the highlight and shadow shapes offset across the direction specified in 'Angle'.")>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property Depth As System.Nullable(Of Single)
Visual Basic (Usage) Copy Code
Dim instance As ChartBevelAndEmbossImageFilterSettings
Dim value As System.Nullable(Of Single)

instance.Depth = value

value = instance.Depth
C#
[System.ComponentModel.CategoryAttribute("Size")]
[System.ComponentModel.DescriptionAttribute("The depth of the bevel effect, affects the distance between the highlight and shadow shapes offset across the direction specified in 'Angle'.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.Nullable<float> Depth {get; set;}
Delphi
public read-write property Depth: System.Nullable;
JScript
System.ComponentModel.CategoryAttribute("Size")
System.ComponentModel.DescriptionAttribute("The depth of the bevel effect, affects the distance between the highlight and shadow shapes offset across the direction specified in 'Angle'.")
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set Depth : System.Nullable
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Size")]
[System.ComponentModel.DescriptionAttribute("The depth of the bevel effect, affects the distance between the highlight and shadow shapes offset across the direction specified in 'Angle'.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.Nullable<float> get_Depth();
public: __property void set_Depth(
   System.Nullable<float> value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Size")]
[System.ComponentModel.DescriptionAttribute("The depth of the bevel effect, affects the distance between the highlight and shadow shapes offset across the direction specified in 'Angle'.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.Nullable<float> Depth {
   System.Nullable<float> get();
   void set (    System.Nullable<float> value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartBevelAndEmbossImageFilterSettings Class
ChartBevelAndEmbossImageFilterSettings Members


LightColor Property

[image]
Intersoft WebGrid Documentation
LightColor Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartBevelAndEmbossImageFilterSettings Class : LightColor Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("The light color of the contour.")>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Appearance")>
Public Property LightColor As System.Drawing.Color
Visual Basic (Usage) Copy Code
Dim instance As ChartBevelAndEmbossImageFilterSettings
Dim value As System.Drawing.Color

instance.LightColor = value

value = instance.LightColor
C#
[System.ComponentModel.DescriptionAttribute("The light color of the contour.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Appearance")]
public System.Drawing.Color LightColor {get; set;}
Delphi
public read-write property LightColor: System.Drawing.Color;
JScript
System.ComponentModel.DescriptionAttribute("The light color of the contour.")
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Appearance")
public function get,set LightColor : System.Drawing.Color
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("The light color of the contour.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Appearance")]
public: __property System.Drawing.Color get_LightColor();
public: __property void set_LightColor(
   System.Drawing.Color value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("The light color of the contour.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Appearance")]
public:
property System.Drawing.Color LightColor {
   System.Drawing.Color get();
   void set (    System.Drawing.Color value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartBevelAndEmbossImageFilterSettings Class
ChartBevelAndEmbossImageFilterSettings Members


OriginalOpacity Property

[image]
Intersoft WebGrid Documentation
OriginalOpacity Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartBevelAndEmbossImageFilterSettings Class : OriginalOpacity Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Fades out the original image leaving only the bevel effect.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Appearance")>
Public Property OriginalOpacity As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As ChartBevelAndEmbossImageFilterSettings
Dim value As System.Integer

instance.OriginalOpacity = value

value = instance.OriginalOpacity
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Fades out the original image leaving only the bevel effect.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Appearance")]
public System.int OriginalOpacity {get; set;}
Delphi
public read-write property OriginalOpacity: System.Integer;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Fades out the original image leaving only the bevel effect.")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Appearance")
public function get,set OriginalOpacity : System.int
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Fades out the original image leaving only the bevel effect.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Appearance")]
public: __property System.int get_OriginalOpacity();
public: __property void set_OriginalOpacity(
   System.int value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Fades out the original image leaving only the bevel effect.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Appearance")]
public:
property System.int OriginalOpacity {
   System.int get();
   void set (    System.int value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartBevelAndEmbossImageFilterSettings Class
ChartBevelAndEmbossImageFilterSettings Members


ShadowColor Property

[image]
Intersoft WebGrid Documentation
ShadowColor Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartBevelAndEmbossImageFilterSettings Class : ShadowColor Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("The shadow color of the contour.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Appearance")>
Public Property ShadowColor As System.Drawing.Color
Visual Basic (Usage) Copy Code
Dim instance As ChartBevelAndEmbossImageFilterSettings
Dim value As System.Drawing.Color

instance.ShadowColor = value

value = instance.ShadowColor
C#
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("The shadow color of the contour.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Appearance")]
public System.Drawing.Color ShadowColor {get; set;}
Delphi
public read-write property ShadowColor: System.Drawing.Color;
JScript
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("The shadow color of the contour.")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Appearance")
public function get,set ShadowColor : System.Drawing.Color
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("The shadow color of the contour.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Appearance")]
public: __property System.Drawing.Color get_ShadowColor();
public: __property void set_ShadowColor(
   System.Drawing.Color value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("The shadow color of the contour.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Appearance")]
public:
property System.Drawing.Color ShadowColor {
   System.Drawing.Color get();
   void set (    System.Drawing.Color value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartBevelAndEmbossImageFilterSettings Class
ChartBevelAndEmbossImageFilterSettings Members


Soften Property

[image]
Intersoft WebGrid Documentation
Soften Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartBevelAndEmbossImageFilterSettings Class : Soften Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Blur")>
<System.ComponentModel.DescriptionAttribute("Blur amount of the bevel shapes.")>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property Soften As System.Nullable(Of Single)
Visual Basic (Usage) Copy Code
Dim instance As ChartBevelAndEmbossImageFilterSettings
Dim value As System.Nullable(Of Single)

instance.Soften = value

value = instance.Soften
C#
[System.ComponentModel.CategoryAttribute("Blur")]
[System.ComponentModel.DescriptionAttribute("Blur amount of the bevel shapes.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.Nullable<float> Soften {get; set;}
Delphi
public read-write property Soften: System.Nullable;
JScript
System.ComponentModel.CategoryAttribute("Blur")
System.ComponentModel.DescriptionAttribute("Blur amount of the bevel shapes.")
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set Soften : System.Nullable
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Blur")]
[System.ComponentModel.DescriptionAttribute("Blur amount of the bevel shapes.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.Nullable<float> get_Soften();
public: __property void set_Soften(
   System.Nullable<float> value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Blur")]
[System.ComponentModel.DescriptionAttribute("Blur amount of the bevel shapes.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.Nullable<float> Soften {
   System.Nullable<float> get();
   void set (    System.Nullable<float> value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartBevelAndEmbossImageFilterSettings Class
ChartBevelAndEmbossImageFilterSettings Members


ChartBlurImageFilterSettings Class

[image]
Intersoft WebGrid Documentation
ChartBlurImageFilterSettings Class
Members See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartBlurImageFilterSettings Class

Glossary Item Box

Object Model

ChartBlurImageFilterSettings Class

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.SerializableAttribute()>
Public Class ChartBlurImageFilterSettings
   Inherits ChartImageFilterSettings
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Visual Basic (Usage) Copy Code
Dim instance As ChartBlurImageFilterSettings
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public class ChartBlurImageFilterSettings : ChartImageFilterSettings, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Delphi
public class ChartBlurImageFilterSettings = class(ChartImageFilterSettings, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize)
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.SerializableAttribute()
public class ChartBlurImageFilterSettings extends ChartImageFilterSettings implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public __gc class ChartBlurImageFilterSettings : public ChartImageFilterSettings, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public ref class ChartBlurImageFilterSettings : public ChartImageFilterSettings, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.WebGrid.Chart.ChartImageFilterSettings
ISNet.WebUI.WebGrid.Chart.ChartBlurImageFilterSettings

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartBlurImageFilterSettings Members
ISNet.WebUI.WebGrid.Chart Namespace


ChartBlurImageFilterSettings Class Members

[image]
Intersoft WebGrid Documentation
ChartBlurImageFilterSettings Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartBlurImageFilterSettings Class

Glossary Item Box

The following tables list the members exposed by ChartBlurImageFilterSettings.

Public Constructors

 | Name | Description
Public Constructor | ChartBlurImageFilterSettings Constructor |
Top

Public Properties

 | Name | Description
Public Property | AlphaChannelOnly |
Public Property | BlurBottom |
Public Property | BlurLeft |
Public Property | BlurRight |
Public Property | BlurTop |
Public Property | BlurType | (Inherited from ISNet.WebUI.WebGrid.Chart.ChartImageFilterSettings)
Public Property | Enabled | (Inherited from ISNet.WebUI.WebGrid.Chart.ChartImageFilterSettings)
Public Property | Size |
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

ChartBlurImageFilterSettings Class
ISNet.WebUI.WebGrid.Chart Namespace


ChartBlurImageFilterSettings Constructor

[image]
Intersoft WebGrid Documentation
ChartBlurImageFilterSettings Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartBlurImageFilterSettings Class : ChartBlurImageFilterSettings Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New ChartBlurImageFilterSettings()
C#
public ChartBlurImageFilterSettings()
Delphi
public ChartBlurImageFilterSettings();
JScript
public function ChartBlurImageFilterSettings();
Managed Extensions for C++
public: ChartBlurImageFilterSettings();
C++/CLI
public:
ChartBlurImageFilterSettings();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartBlurImageFilterSettings Class
ChartBlurImageFilterSettings Members


Clone Method

[image]
Intersoft WebGrid Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartBlurImageFilterSettings Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As System.Object
Visual Basic (Usage) Copy Code
Dim instance As ChartBlurImageFilterSettings
Dim value As System.Object

value = instance.Clone()
C#
public virtual System.object Clone()
Delphi
public function Clone(): System.TObject; virtual;
JScript
public function Clone() : System.Object;
Managed Extensions for C++
public: virtual System.Object* Clone();
C++/CLI
public:
virtual System.Object^ Clone();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartBlurImageFilterSettings Class
ChartBlurImageFilterSettings Members


CopyFrom Method

[image]
Intersoft WebGrid Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartBlurImageFilterSettings Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartBlurImageFilterSettings Class
ChartBlurImageFilterSettings Members


CopyFrom(Object) Method

[image]
Intersoft WebGrid Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartBlurImageFilterSettings Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartBlurImageFilterSettings
Dim objSource As System.Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   System.object objSource
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartBlurImageFilterSettings Class
ChartBlurImageFilterSettings Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebGrid Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartBlurImageFilterSettings Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object, _
   ByVal cloneSourceValue As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartBlurImageFilterSettings
Dim objSource As System.Object
Dim cloneSourceValue As System.Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   System.object objSource,
   System.bool cloneSourceValue
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject;
    cloneSourceValue: System.Boolean
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object,
   cloneSourceValue : System.boolean
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource,
   System.bool cloneSourceValue
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource,
   System.bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartBlurImageFilterSettings Class
ChartBlurImageFilterSettings Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebGrid Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartBlurImageFilterSettings Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartBlurImageFilterSettings
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure DeSerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function DeSerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void DeSerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void DeSerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartBlurImageFilterSettings Class
ChartBlurImageFilterSettings Members


GetHashCode Method

[image]
Intersoft WebGrid Documentation
GetHashCode Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartBlurImageFilterSettings Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As ChartBlurImageFilterSettings
Dim value As System.Integer

value = instance.GetHashCode()
C#
public virtual System.int GetHashCode()
Delphi
public function GetHashCode(): System.Integer; virtual;
JScript
public function GetHashCode() : System.int;
Managed Extensions for C++
public: virtual System.int GetHashCode();
C++/CLI
public:
virtual System.int GetHashCode();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartBlurImageFilterSettings Class
ChartBlurImageFilterSettings Members


ChartBlurImageFilterSettings Class Methods

[image]
Intersoft WebGrid Documentation
ChartBlurImageFilterSettings Class Methods
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartBlurImageFilterSettings Class

Glossary Item Box

For a list of all members of this type, see ChartBlurImageFilterSettings members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

ChartBlurImageFilterSettings Class
ISNet.WebUI.WebGrid.Chart Namespace


GetObjectData Method

[image]
Intersoft WebGrid Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartBlurImageFilterSettings Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=False,
   UnmanagedCode=False,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=True,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Action=SecurityAction.Demand,
   Unrestricted=False)>
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartBlurImageFilterSettings
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure GetObjectData(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
); override;
JScript
System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=,
   UnmanagedCode=,
   SkipVerification=,
   Execution=,
   ControlThread=,
   ControlEvidence=,
   ControlPolicy=,
   SerializationFormatter=,
   ControlDomainPolicy=,
   ControlPrincipal=,
   ControlAppDomain=,
   RemotingConfiguration=,
   Infrastructure=,
   BindingRedirects=,
   Action=SecurityAction.Demand,
   Unrestricted=)
public override function GetObjectData(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public: void GetObjectData(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
) override
C++/CLI
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public:
void GetObjectData(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
) override

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartBlurImageFilterSettings Class
ChartBlurImageFilterSettings Members


IsEmpty Method

[image]
Intersoft WebGrid Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartBlurImageFilterSettings Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As ChartBlurImageFilterSettings
Dim value As System.Boolean

value = instance.IsEmpty()
C#
public virtual System.bool IsEmpty()
Delphi
public function IsEmpty(): System.Boolean; virtual;
JScript
public function IsEmpty() : System.boolean;
Managed Extensions for C++
public: virtual System.bool IsEmpty();
C++/CLI
public:
virtual System.bool IsEmpty();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartBlurImageFilterSettings Class
ChartBlurImageFilterSettings Members


Reset Method

[image]
Intersoft WebGrid Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartBlurImageFilterSettings Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As ChartBlurImageFilterSettings

instance.Reset()
C#
public virtual void Reset()
Delphi
public procedure Reset(); virtual;
JScript
public function Reset();
Managed Extensions for C++
public: virtual void Reset();
C++/CLI
public:
virtual void Reset();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartBlurImageFilterSettings Class
ChartBlurImageFilterSettings Members


SerializeObjectData Method

[image]
Intersoft WebGrid Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartBlurImageFilterSettings Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartBlurImageFilterSettings
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure SerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function SerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void SerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void SerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartBlurImageFilterSettings Class
ChartBlurImageFilterSettings Members


ToString Method

[image]
Intersoft WebGrid Documentation
ToString Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartBlurImageFilterSettings Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As System.String
Visual Basic (Usage) Copy Code
Dim instance As ChartBlurImageFilterSettings
Dim value As System.String

value = instance.ToString()
C#
public virtual System.string ToString()
Delphi
public function ToString(): System.String; virtual;
JScript
public function ToString() : System.String;
Managed Extensions for C++
public: virtual System.string* ToString();
C++/CLI
public:
virtual System.String^ ToString();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartBlurImageFilterSettings Class
ChartBlurImageFilterSettings Members


ChartBlurImageFilterSettings Class Properties

[image]
Intersoft WebGrid Documentation
ChartBlurImageFilterSettings Class Properties
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartBlurImageFilterSettings Class

Glossary Item Box

For a list of all members of this type, see ChartBlurImageFilterSettings members.

Public Properties

 | Name | Description
Public Property | AlphaChannelOnly |
Public Property | BlurBottom |
Public Property | BlurLeft |
Public Property | BlurRight |
Public Property | BlurTop |
Public Property | BlurType | (Inherited from ISNet.WebUI.WebGrid.Chart.ChartImageFilterSettings)
Public Property | Enabled | (Inherited from ISNet.WebUI.WebGrid.Chart.ChartImageFilterSettings)
Public Property | Size |
Top

See Also

Reference

ChartBlurImageFilterSettings Class
ISNet.WebUI.WebGrid.Chart Namespace


ChartBlurImageFilterSettings Constructor

[image]
Intersoft WebGrid Documentation
ChartBlurImageFilterSettings Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartBlurImageFilterSettings Class : ChartBlurImageFilterSettings Constructor

Glossary Item Box

Overload List

Overload | Description
ChartBlurImageFilterSettings Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartBlurImageFilterSettings Class
ChartBlurImageFilterSettings Members


AlphaChannelOnly Property

[image]
Intersoft WebGrid Documentation
AlphaChannelOnly Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartBlurImageFilterSettings Class : AlphaChannelOnly Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Whether or not to blur the alpha channel or all color channels of the image (ARGB).")>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Appearance")>
Public Property AlphaChannelOnly As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As ChartBlurImageFilterSettings
Dim value As System.Boolean

instance.AlphaChannelOnly = value

value = instance.AlphaChannelOnly
C#
[System.ComponentModel.DescriptionAttribute("Whether or not to blur the alpha channel or all color channels of the image (ARGB).")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Appearance")]
public System.bool AlphaChannelOnly {get; set;}
Delphi
public read-write property AlphaChannelOnly: System.Boolean;
JScript
System.ComponentModel.DescriptionAttribute("Whether or not to blur the alpha channel or all color channels of the image (ARGB).")
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Appearance")
public function get,set AlphaChannelOnly : System.boolean
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Whether or not to blur the alpha channel or all color channels of the image (ARGB).")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Appearance")]
public: __property System.bool get_AlphaChannelOnly();
public: __property void set_AlphaChannelOnly(
   System.bool value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Whether or not to blur the alpha channel or all color channels of the image (ARGB).")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Appearance")]
public:
property System.bool AlphaChannelOnly {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartBlurImageFilterSettings Class
ChartBlurImageFilterSettings Members


BlurBottom Property

[image]
Intersoft WebGrid Documentation
BlurBottom Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartBlurImageFilterSettings Class : BlurBottom Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Appearance")>
<System.ComponentModel.DescriptionAttribute("When set to true the bottom corners of the image will be blured.")>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property BlurBottom As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As ChartBlurImageFilterSettings
Dim value As System.Boolean

instance.BlurBottom = value

value = instance.BlurBottom
C#
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.DescriptionAttribute("When set to true the bottom corners of the image will be blured.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.bool BlurBottom {get; set;}
Delphi
public read-write property BlurBottom: System.Boolean;
JScript
System.ComponentModel.CategoryAttribute("Appearance")
System.ComponentModel.DescriptionAttribute("When set to true the bottom corners of the image will be blured.")
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set BlurBottom : System.boolean
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.DescriptionAttribute("When set to true the bottom corners of the image will be blured.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.bool get_BlurBottom();
public: __property void set_BlurBottom(
   System.bool value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.DescriptionAttribute("When set to true the bottom corners of the image will be blured.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.bool BlurBottom {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartBlurImageFilterSettings Class
ChartBlurImageFilterSettings Members


BlurLeft Property

[image]
Intersoft WebGrid Documentation
BlurLeft Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartBlurImageFilterSettings Class : BlurLeft Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Appearance")>
<System.ComponentModel.DescriptionAttribute("When set to true the left corners of the image will be blured.")>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property BlurLeft As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As ChartBlurImageFilterSettings
Dim value As System.Boolean

instance.BlurLeft = value

value = instance.BlurLeft
C#
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.DescriptionAttribute("When set to true the left corners of the image will be blured.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.bool BlurLeft {get; set;}
Delphi
public read-write property BlurLeft: System.Boolean;
JScript
System.ComponentModel.CategoryAttribute("Appearance")
System.ComponentModel.DescriptionAttribute("When set to true the left corners of the image will be blured.")
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set BlurLeft : System.boolean
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.DescriptionAttribute("When set to true the left corners of the image will be blured.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.bool get_BlurLeft();
public: __property void set_BlurLeft(
   System.bool value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.DescriptionAttribute("When set to true the left corners of the image will be blured.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.bool BlurLeft {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartBlurImageFilterSettings Class
ChartBlurImageFilterSettings Members


BlurRight Property

[image]
Intersoft WebGrid Documentation
BlurRight Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartBlurImageFilterSettings Class : BlurRight Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Appearance")>
<System.ComponentModel.DescriptionAttribute("When set to true the right corners of the image will be blured.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
Public Property BlurRight As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As ChartBlurImageFilterSettings
Dim value As System.Boolean

instance.BlurRight = value

value = instance.BlurRight
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.DescriptionAttribute("When set to true the right corners of the image will be blured.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public System.bool BlurRight {get; set;}
Delphi
public read-write property BlurRight: System.Boolean;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Appearance")
System.ComponentModel.DescriptionAttribute("When set to true the right corners of the image will be blured.")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
public function get,set BlurRight : System.boolean
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.DescriptionAttribute("When set to true the right corners of the image will be blured.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.bool get_BlurRight();
public: __property void set_BlurRight(
   System.bool value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.DescriptionAttribute("When set to true the right corners of the image will be blured.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.bool BlurRight {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartBlurImageFilterSettings Class
ChartBlurImageFilterSettings Members


BlurTop Property

[image]
Intersoft WebGrid Documentation
BlurTop Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartBlurImageFilterSettings Class : BlurTop Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("When set to true the top corners of the image will be blured.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Appearance")>
Public Property BlurTop As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As ChartBlurImageFilterSettings
Dim value As System.Boolean

instance.BlurTop = value

value = instance.BlurTop
C#
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("When set to true the top corners of the image will be blured.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Appearance")]
public System.bool BlurTop {get; set;}
Delphi
public read-write property BlurTop: System.Boolean;
JScript
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("When set to true the top corners of the image will be blured.")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Appearance")
public function get,set BlurTop : System.boolean
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("When set to true the top corners of the image will be blured.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Appearance")]
public: __property System.bool get_BlurTop();
public: __property void set_BlurTop(
   System.bool value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("When set to true the top corners of the image will be blured.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Appearance")]
public:
property System.bool BlurTop {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartBlurImageFilterSettings Class
ChartBlurImageFilterSettings Members


Size Property

[image]
Intersoft WebGrid Documentation
Size Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartBlurImageFilterSettings Class : Size Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("The size of the horizontal and vertical blur matrices.")>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.CategoryAttribute("Blur")>
<ISNet.Serialization.BinarySerializableAttribute("setSize")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
Public ReadOnly Property Size As ChartSizeValue
Visual Basic (Usage) Copy Code
Dim instance As ChartBlurImageFilterSettings
Dim value As ChartSizeValue

value = instance.Size
C#
[System.ComponentModel.DescriptionAttribute("The size of the horizontal and vertical blur matrices.")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.CategoryAttribute("Blur")]
[ISNet.Serialization.BinarySerializableAttribute("setSize")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
public ChartSizeValue Size {get;}
Delphi
public read-only property Size: ChartSizeValue;
JScript
System.ComponentModel.DescriptionAttribute("The size of the horizontal and vertical blur matrices.")
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.CategoryAttribute("Blur")
ISNet.Serialization.BinarySerializableAttribute("setSize")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
public function get Size : ChartSizeValue
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("The size of the horizontal and vertical blur matrices.")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.CategoryAttribute("Blur")]
[ISNet.Serialization.BinarySerializableAttribute("setSize")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
public: __property ChartSizeValue* get_Size();
C++/CLI
[System.ComponentModel.DescriptionAttribute("The size of the horizontal and vertical blur matrices.")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.CategoryAttribute("Blur")]
[ISNet.Serialization.BinarySerializableAttribute("setSize")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
public:
property ChartSizeValue^ Size {
   ChartSizeValue^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartBlurImageFilterSettings Class
ChartBlurImageFilterSettings Members


ChartColorFillStyle Class

[image]
Intersoft WebGrid Documentation
ChartColorFillStyle Class
Members See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartColorFillStyle Class

Glossary Item Box

Object Model

ChartColorFillStyle Class

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.SerializableAttribute()>
Public Class ChartColorFillStyle
   Inherits ISNet.WebUI.WebUIBaseClass
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Visual Basic (Usage) Copy Code
Dim instance As ChartColorFillStyle
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public class ChartColorFillStyle : ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Delphi
public class ChartColorFillStyle = class(ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize)
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.SerializableAttribute()
public class ChartColorFillStyle extends ISNet.WebUI.WebUIBaseClass implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public __gc class ChartColorFillStyle : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public ref class ChartColorFillStyle : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.WebGrid.Chart.ChartColorFillStyle

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartColorFillStyle Members
ISNet.WebUI.WebGrid.Chart Namespace


ChartColorFillStyle Class Members

[image]
Intersoft WebGrid Documentation
ChartColorFillStyle Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartColorFillStyle Class

Glossary Item Box

The following tables list the members exposed by ChartColorFillStyle.

Public Constructors

 | Name | Description
Public Constructor | ChartColorFillStyle Constructor |
Top

Public Properties

 | Name | Description
Public Property | Color |
Public Property | TransparancyPercent |
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

ChartColorFillStyle Class
ISNet.WebUI.WebGrid.Chart Namespace


ChartColorFillStyle Constructor

[image]
Intersoft WebGrid Documentation
ChartColorFillStyle Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartColorFillStyle Class : ChartColorFillStyle Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New ChartColorFillStyle()
C#
public ChartColorFillStyle()
Delphi
public ChartColorFillStyle();
JScript
public function ChartColorFillStyle();
Managed Extensions for C++
public: ChartColorFillStyle();
C++/CLI
public:
ChartColorFillStyle();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartColorFillStyle Class
ChartColorFillStyle Members


Clone Method

[image]
Intersoft WebGrid Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartColorFillStyle Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As System.Object
Visual Basic (Usage) Copy Code
Dim instance As ChartColorFillStyle
Dim value As System.Object

value = instance.Clone()
C#
public virtual System.object Clone()
Delphi
public function Clone(): System.TObject; virtual;
JScript
public function Clone() : System.Object;
Managed Extensions for C++
public: virtual System.Object* Clone();
C++/CLI
public:
virtual System.Object^ Clone();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartColorFillStyle Class
ChartColorFillStyle Members


CopyFrom Method

[image]
Intersoft WebGrid Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartColorFillStyle Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartColorFillStyle Class
ChartColorFillStyle Members


CopyFrom(Object) Method

[image]
Intersoft WebGrid Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartColorFillStyle Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartColorFillStyle
Dim objSource As System.Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   System.object objSource
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartColorFillStyle Class
ChartColorFillStyle Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebGrid Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartColorFillStyle Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object, _
   ByVal cloneSourceValue As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartColorFillStyle
Dim objSource As System.Object
Dim cloneSourceValue As System.Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   System.object objSource,
   System.bool cloneSourceValue
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject;
    cloneSourceValue: System.Boolean
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object,
   cloneSourceValue : System.boolean
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource,
   System.bool cloneSourceValue
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource,
   System.bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartColorFillStyle Class
ChartColorFillStyle Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebGrid Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartColorFillStyle Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartColorFillStyle
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure DeSerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function DeSerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void DeSerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void DeSerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartColorFillStyle Class
ChartColorFillStyle Members


GetHashCode Method

[image]
Intersoft WebGrid Documentation
GetHashCode Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartColorFillStyle Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As ChartColorFillStyle
Dim value As System.Integer

value = instance.GetHashCode()
C#
public virtual System.int GetHashCode()
Delphi
public function GetHashCode(): System.Integer; virtual;
JScript
public function GetHashCode() : System.int;
Managed Extensions for C++
public: virtual System.int GetHashCode();
C++/CLI
public:
virtual System.int GetHashCode();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartColorFillStyle Class
ChartColorFillStyle Members


ChartColorFillStyle Class Methods

[image]
Intersoft WebGrid Documentation
ChartColorFillStyle Class Methods
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartColorFillStyle Class

Glossary Item Box

For a list of all members of this type, see ChartColorFillStyle members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

ChartColorFillStyle Class
ISNet.WebUI.WebGrid.Chart Namespace


GetObjectData Method

[image]
Intersoft WebGrid Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartColorFillStyle Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=False,
   UnmanagedCode=False,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=True,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Action=SecurityAction.Demand,
   Unrestricted=False)>
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartColorFillStyle
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure GetObjectData(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
); override;
JScript
System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=,
   UnmanagedCode=,
   SkipVerification=,
   Execution=,
   ControlThread=,
   ControlEvidence=,
   ControlPolicy=,
   SerializationFormatter=,
   ControlDomainPolicy=,
   ControlPrincipal=,
   ControlAppDomain=,
   RemotingConfiguration=,
   Infrastructure=,
   BindingRedirects=,
   Action=SecurityAction.Demand,
   Unrestricted=)
public override function GetObjectData(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public: void GetObjectData(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
) override
C++/CLI
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public:
void GetObjectData(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
) override

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartColorFillStyle Class
ChartColorFillStyle Members


IsEmpty Method

[image]
Intersoft WebGrid Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartColorFillStyle Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As ChartColorFillStyle
Dim value As System.Boolean

value = instance.IsEmpty()
C#
public virtual System.bool IsEmpty()
Delphi
public function IsEmpty(): System.Boolean; virtual;
JScript
public function IsEmpty() : System.boolean;
Managed Extensions for C++
public: virtual System.bool IsEmpty();
C++/CLI
public:
virtual System.bool IsEmpty();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartColorFillStyle Class
ChartColorFillStyle Members


Reset Method

[image]
Intersoft WebGrid Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartColorFillStyle Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As ChartColorFillStyle

instance.Reset()
C#
public virtual void Reset()
Delphi
public procedure Reset(); virtual;
JScript
public function Reset();
Managed Extensions for C++
public: virtual void Reset();
C++/CLI
public:
virtual void Reset();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartColorFillStyle Class
ChartColorFillStyle Members


SerializeObjectData Method

[image]
Intersoft WebGrid Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartColorFillStyle Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartColorFillStyle
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure SerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function SerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void SerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void SerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartColorFillStyle Class
ChartColorFillStyle Members


ToString Method

[image]
Intersoft WebGrid Documentation
ToString Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartColorFillStyle Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As System.String
Visual Basic (Usage) Copy Code
Dim instance As ChartColorFillStyle
Dim value As System.String

value = instance.ToString()
C#
public virtual System.string ToString()
Delphi
public function ToString(): System.String; virtual;
JScript
public function ToString() : System.String;
Managed Extensions for C++
public: virtual System.string* ToString();
C++/CLI
public:
virtual System.String^ ToString();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartColorFillStyle Class
ChartColorFillStyle Members


ChartColorFillStyle Class Properties

[image]
Intersoft WebGrid Documentation
ChartColorFillStyle Class Properties
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartColorFillStyle Class

Glossary Item Box

For a list of all members of this type, see ChartColorFillStyle members.

Public Properties

 | Name | Description
Public Property | Color |
Public Property | TransparancyPercent |
Top

See Also

Reference

ChartColorFillStyle Class
ISNet.WebUI.WebGrid.Chart Namespace


ChartColorFillStyle Constructor

[image]
Intersoft WebGrid Documentation
ChartColorFillStyle Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartColorFillStyle Class : ChartColorFillStyle Constructor

Glossary Item Box

Overload List

Overload | Description
ChartColorFillStyle Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartColorFillStyle Class
ChartColorFillStyle Members


Color Property

[image]
Intersoft WebGrid Documentation
Color Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartColorFillStyle Class : Color Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("The color of the filling.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("Appearance")>
Public Property Color As System.Drawing.Color
Visual Basic (Usage) Copy Code
Dim instance As ChartColorFillStyle
Dim value As System.Drawing.Color

instance.Color = value

value = instance.Color
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("The color of the filling.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Appearance")]
public System.Drawing.Color Color {get; set;}
Delphi
public read-write property Color: System.Drawing.Color;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("The color of the filling.")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("Appearance")
public function get,set Color : System.Drawing.Color
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("The color of the filling.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Appearance")]
public: __property System.Drawing.Color get_Color();
public: __property void set_Color(
   System.Drawing.Color value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("The color of the filling.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Appearance")]
public:
property System.Drawing.Color Color {
   System.Drawing.Color get();
   void set (    System.Drawing.Color value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartColorFillStyle Class
ChartColorFillStyle Members


TransparancyPercent Property

[image]
Intersoft WebGrid Documentation
TransparancyPercent Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartColorFillStyle Class : TransparancyPercent Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Controls the transparency percent of the diffuse and ambient material colors. ")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("Appearance")>
Public Property TransparancyPercent As System.Single
Visual Basic (Usage) Copy Code
Dim instance As ChartColorFillStyle
Dim value As System.Single

instance.TransparancyPercent = value

value = instance.TransparancyPercent
C#
[System.ComponentModel.DescriptionAttribute("Controls the transparency percent of the diffuse and ambient material colors. ")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Appearance")]
public System.float TransparancyPercent {get; set;}
Delphi
public read-write property TransparancyPercent: System.Single;
JScript
System.ComponentModel.DescriptionAttribute("Controls the transparency percent of the diffuse and ambient material colors. ")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("Appearance")
public function get,set TransparancyPercent : System.float
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Controls the transparency percent of the diffuse and ambient material colors. ")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Appearance")]
public: __property System.float get_TransparancyPercent();
public: __property void set_TransparancyPercent(
   System.float value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Controls the transparency percent of the diffuse and ambient material colors. ")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Appearance")]
public:
property System.float TransparancyPercent {
   System.float get();
   void set (    System.float value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartColorFillStyle Class
ChartColorFillStyle Members


ChartColumnTypeSettings Class

[image]
Intersoft WebGrid Documentation
ChartColumnTypeSettings Class
Members See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartColumnTypeSettings Class

Glossary Item Box

Object Model

ChartColumnTypeSettings Class

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.SerializableAttribute()>
Public Class ChartColumnTypeSettings
   Inherits ISNet.WebUI.WebUIBaseClass
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Visual Basic (Usage) Copy Code
Dim instance As ChartColumnTypeSettings
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public class ChartColumnTypeSettings : ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Delphi
public class ChartColumnTypeSettings = class(ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize)
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.SerializableAttribute()
public class ChartColumnTypeSettings extends ISNet.WebUI.WebUIBaseClass implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public __gc class ChartColumnTypeSettings : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public ref class ChartColumnTypeSettings : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.WebGrid.Chart.ChartColumnTypeSettings

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartColumnTypeSettings Members
ISNet.WebUI.WebGrid.Chart Namespace


ChartColumnTypeSettings Class Members

[image]
Intersoft WebGrid Documentation
ChartColumnTypeSettings Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartColumnTypeSettings Class

Glossary Item Box

The following tables list the members exposed by ChartColumnTypeSettings.

Public Constructors

 | Name | Description
Public Constructor | ChartColumnTypeSettings Constructor |
Top

Public Properties

 | Name | Description
Public Property | EnableBasic3DColumnType |
Public Property | EnableClustered3DColumnType |
Public Property | EnableClusteredColumnType |
Public Property | Enabled |
Public Property | EnableStacked3DColumnType |
Public Property | EnableStackedColumnType |
Public Property | EnableStackedPercentage3DColumnType |
Public Property | EnableStackedPercentageColumnType |
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

ChartColumnTypeSettings Class
ISNet.WebUI.WebGrid.Chart Namespace


ChartColumnTypeSettings Constructor

[image]
Intersoft WebGrid Documentation
ChartColumnTypeSettings Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartColumnTypeSettings Class : ChartColumnTypeSettings Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New ChartColumnTypeSettings()
C#
public ChartColumnTypeSettings()
Delphi
public ChartColumnTypeSettings();
JScript
public function ChartColumnTypeSettings();
Managed Extensions for C++
public: ChartColumnTypeSettings();
C++/CLI
public:
ChartColumnTypeSettings();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartColumnTypeSettings Class
ChartColumnTypeSettings Members


Clone Method

[image]
Intersoft WebGrid Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartColumnTypeSettings Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As System.Object
Visual Basic (Usage) Copy Code
Dim instance As ChartColumnTypeSettings
Dim value As System.Object

value = instance.Clone()
C#
public virtual System.object Clone()
Delphi
public function Clone(): System.TObject; virtual;
JScript
public function Clone() : System.Object;
Managed Extensions for C++
public: virtual System.Object* Clone();
C++/CLI
public:
virtual System.Object^ Clone();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartColumnTypeSettings Class
ChartColumnTypeSettings Members


CopyFrom Method

[image]
Intersoft WebGrid Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartColumnTypeSettings Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartColumnTypeSettings Class
ChartColumnTypeSettings Members


CopyFrom(Object) Method

[image]
Intersoft WebGrid Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartColumnTypeSettings Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartColumnTypeSettings
Dim objSource As System.Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   System.object objSource
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartColumnTypeSettings Class
ChartColumnTypeSettings Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebGrid Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartColumnTypeSettings Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object, _
   ByVal cloneSourceValue As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartColumnTypeSettings
Dim objSource As System.Object
Dim cloneSourceValue As System.Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   System.object objSource,
   System.bool cloneSourceValue
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject;
    cloneSourceValue: System.Boolean
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object,
   cloneSourceValue : System.boolean
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource,
   System.bool cloneSourceValue
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource,
   System.bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartColumnTypeSettings Class
ChartColumnTypeSettings Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebGrid Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartColumnTypeSettings Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartColumnTypeSettings
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure DeSerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function DeSerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void DeSerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void DeSerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartColumnTypeSettings Class
ChartColumnTypeSettings Members


GetHashCode Method

[image]
Intersoft WebGrid Documentation
GetHashCode Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartColumnTypeSettings Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As ChartColumnTypeSettings
Dim value As System.Integer

value = instance.GetHashCode()
C#
public virtual System.int GetHashCode()
Delphi
public function GetHashCode(): System.Integer; virtual;
JScript
public function GetHashCode() : System.int;
Managed Extensions for C++
public: virtual System.int GetHashCode();
C++/CLI
public:
virtual System.int GetHashCode();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartColumnTypeSettings Class
ChartColumnTypeSettings Members


ChartColumnTypeSettings Class Methods

[image]
Intersoft WebGrid Documentation
ChartColumnTypeSettings Class Methods
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartColumnTypeSettings Class

Glossary Item Box

For a list of all members of this type, see ChartColumnTypeSettings members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

ChartColumnTypeSettings Class
ISNet.WebUI.WebGrid.Chart Namespace


GetObjectData Method

[image]
Intersoft WebGrid Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartColumnTypeSettings Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=False,
   UnmanagedCode=False,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=True,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Action=SecurityAction.Demand,
   Unrestricted=False)>
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartColumnTypeSettings
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure GetObjectData(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
); override;
JScript
System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=,
   UnmanagedCode=,
   SkipVerification=,
   Execution=,
   ControlThread=,
   ControlEvidence=,
   ControlPolicy=,
   SerializationFormatter=,
   ControlDomainPolicy=,
   ControlPrincipal=,
   ControlAppDomain=,
   RemotingConfiguration=,
   Infrastructure=,
   BindingRedirects=,
   Action=SecurityAction.Demand,
   Unrestricted=)
public override function GetObjectData(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public: void GetObjectData(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
) override
C++/CLI
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public:
void GetObjectData(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
) override

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartColumnTypeSettings Class
ChartColumnTypeSettings Members


IsEmpty Method

[image]
Intersoft WebGrid Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartColumnTypeSettings Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As ChartColumnTypeSettings
Dim value As System.Boolean

value = instance.IsEmpty()
C#
public virtual System.bool IsEmpty()
Delphi
public function IsEmpty(): System.Boolean; virtual;
JScript
public function IsEmpty() : System.boolean;
Managed Extensions for C++
public: virtual System.bool IsEmpty();
C++/CLI
public:
virtual System.bool IsEmpty();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartColumnTypeSettings Class
ChartColumnTypeSettings Members


Reset Method

[image]
Intersoft WebGrid Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartColumnTypeSettings Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As ChartColumnTypeSettings

instance.Reset()
C#
public virtual void Reset()
Delphi
public procedure Reset(); virtual;
JScript
public function Reset();
Managed Extensions for C++
public: virtual void Reset();
C++/CLI
public:
virtual void Reset();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartColumnTypeSettings Class
ChartColumnTypeSettings Members


SerializeObjectData Method

[image]
Intersoft WebGrid Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartColumnTypeSettings Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartColumnTypeSettings
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure SerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function SerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void SerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void SerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartColumnTypeSettings Class
ChartColumnTypeSettings Members


ToString Method

[image]
Intersoft WebGrid Documentation
ToString Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartColumnTypeSettings Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As System.String
Visual Basic (Usage) Copy Code
Dim instance As ChartColumnTypeSettings
Dim value As System.String

value = instance.ToString()
C#
public virtual System.string ToString()
Delphi
public function ToString(): System.String; virtual;
JScript
public function ToString() : System.String;
Managed Extensions for C++
public: virtual System.string* ToString();
C++/CLI
public:
virtual System.String^ ToString();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartColumnTypeSettings Class
ChartColumnTypeSettings Members


ChartColumnTypeSettings Class Properties

[image]
Intersoft WebGrid Documentation
ChartColumnTypeSettings Class Properties
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartColumnTypeSettings Class

Glossary Item Box

For a list of all members of this type, see ChartColumnTypeSettings members.

Public Properties

 | Name | Description
Public Property | EnableBasic3DColumnType |
Public Property | EnableClustered3DColumnType |
Public Property | EnableClusteredColumnType |
Public Property | Enabled |
Public Property | EnableStacked3DColumnType |
Public Property | EnableStackedColumnType |
Public Property | EnableStackedPercentage3DColumnType |
Public Property | EnableStackedPercentageColumnType |
Top

See Also

Reference

ChartColumnTypeSettings Class
ISNet.WebUI.WebGrid.Chart Namespace


ChartColumnTypeSettings Constructor

[image]
Intersoft WebGrid Documentation
ChartColumnTypeSettings Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartColumnTypeSettings Class : ChartColumnTypeSettings Constructor

Glossary Item Box

Overload List

Overload | Description
ChartColumnTypeSettings Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartColumnTypeSettings Class
ChartColumnTypeSettings Members


EnableBasic3DColumnType Property

[image]
Intersoft WebGrid Documentation
EnableBasic3DColumnType Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartColumnTypeSettings Class : EnableBasic3DColumnType Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Options")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Enable user to switch chart to Basic 3D Column type.")>
Public Property EnableBasic3DColumnType As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As ChartColumnTypeSettings
Dim value As System.Boolean

instance.EnableBasic3DColumnType = value

value = instance.EnableBasic3DColumnType
C#
[System.ComponentModel.CategoryAttribute("Options")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Enable user to switch chart to Basic 3D Column type.")]
public System.bool EnableBasic3DColumnType {get; set;}
Delphi
public read-write property EnableBasic3DColumnType: System.Boolean;
JScript
System.ComponentModel.CategoryAttribute("Options")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Enable user to switch chart to Basic 3D Column type.")
public function get,set EnableBasic3DColumnType : System.boolean
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Options")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Enable user to switch chart to Basic 3D Column type.")]
public: __property System.bool get_EnableBasic3DColumnType();
public: __property void set_EnableBasic3DColumnType(
   System.bool value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Options")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Enable user to switch chart to Basic 3D Column type.")]
public:
property System.bool EnableBasic3DColumnType {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartColumnTypeSettings Class
ChartColumnTypeSettings Members


EnableClustered3DColumnType Property

[image]
Intersoft WebGrid Documentation
EnableClustered3DColumnType Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartColumnTypeSettings Class : EnableClustered3DColumnType Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Options")>
<System.ComponentModel.DescriptionAttribute("Enable user to switch chart to Clustered 3D Column type.")>
Public Property EnableClustered3DColumnType As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As ChartColumnTypeSettings
Dim value As System.Boolean

instance.EnableClustered3DColumnType = value

value = instance.EnableClustered3DColumnType
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Options")]
[System.ComponentModel.DescriptionAttribute("Enable user to switch chart to Clustered 3D Column type.")]
public System.bool EnableClustered3DColumnType {get; set;}
Delphi
public read-write property EnableClustered3DColumnType: System.Boolean;
JScript
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Options")
System.ComponentModel.DescriptionAttribute("Enable user to switch chart to Clustered 3D Column type.")
public function get,set EnableClustered3DColumnType : System.boolean
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Options")]
[System.ComponentModel.DescriptionAttribute("Enable user to switch chart to Clustered 3D Column type.")]
public: __property System.bool get_EnableClustered3DColumnType();
public: __property void set_EnableClustered3DColumnType(
   System.bool value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Options")]
[System.ComponentModel.DescriptionAttribute("Enable user to switch chart to Clustered 3D Column type.")]
public:
property System.bool EnableClustered3DColumnType {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartColumnTypeSettings Class
ChartColumnTypeSettings Members


EnableClusteredColumnType Property

[image]
Intersoft WebGrid Documentation
EnableClusteredColumnType Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartColumnTypeSettings Class : EnableClusteredColumnType Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Enable user to switch chart to Clustered Column type.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Options")>
Public Property EnableClusteredColumnType As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As ChartColumnTypeSettings
Dim value As System.Boolean

instance.EnableClusteredColumnType = value

value = instance.EnableClusteredColumnType
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Enable user to switch chart to Clustered Column type.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Options")]
public System.bool EnableClusteredColumnType {get; set;}
Delphi
public read-write property EnableClusteredColumnType: System.Boolean;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DescriptionAttribute("Enable user to switch chart to Clustered Column type.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Options")
public function get,set EnableClusteredColumnType : System.boolean
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Enable user to switch chart to Clustered Column type.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Options")]
public: __property System.bool get_EnableClusteredColumnType();
public: __property void set_EnableClusteredColumnType(
   System.bool value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Enable user to switch chart to Clustered Column type.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Options")]
public:
property System.bool EnableClusteredColumnType {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartColumnTypeSettings Class
ChartColumnTypeSettings Members


Enabled Property

[image]
Intersoft WebGrid Documentation
Enabled Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartColumnTypeSettings Class : Enabled Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Options")>
<System.ComponentModel.DescriptionAttribute("Enable user to switch chart to Series Column types.")>
Public Property Enabled As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As ChartColumnTypeSettings
Dim value As System.Boolean

instance.Enabled = value

value = instance.Enabled
C#
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Options")]
[System.ComponentModel.DescriptionAttribute("Enable user to switch chart to Series Column types.")]
public System.bool Enabled {get; set;}
Delphi
public read-write property Enabled: System.Boolean;
JScript
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Options")
System.ComponentModel.DescriptionAttribute("Enable user to switch chart to Series Column types.")
public function get,set Enabled : System.boolean
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Options")]
[System.ComponentModel.DescriptionAttribute("Enable user to switch chart to Series Column types.")]
public: __property System.bool get_Enabled();
public: __property void set_Enabled(
   System.bool value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Options")]
[System.ComponentModel.DescriptionAttribute("Enable user to switch chart to Series Column types.")]
public:
property System.bool Enabled {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartColumnTypeSettings Class
ChartColumnTypeSettings Members


EnableStacked3DColumnType Property

[image]
Intersoft WebGrid Documentation
EnableStacked3DColumnType Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartColumnTypeSettings Class : EnableStacked3DColumnType Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Enable user to switch chart to Stacked 3D Column type.")>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Options")>
Public Property EnableStacked3DColumnType As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As ChartColumnTypeSettings
Dim value As System.Boolean

instance.EnableStacked3DColumnType = value

value = instance.EnableStacked3DColumnType
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Enable user to switch chart to Stacked 3D Column type.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Options")]
public System.bool EnableStacked3DColumnType {get; set;}
Delphi
public read-write property EnableStacked3DColumnType: System.Boolean;
JScript
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DescriptionAttribute("Enable user to switch chart to Stacked 3D Column type.")
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Options")
public function get,set EnableStacked3DColumnType : System.boolean
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Enable user to switch chart to Stacked 3D Column type.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Options")]
public: __property System.bool get_EnableStacked3DColumnType();
public: __property void set_EnableStacked3DColumnType(
   System.bool value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Enable user to switch chart to Stacked 3D Column type.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Options")]
public:
property System.bool EnableStacked3DColumnType {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartColumnTypeSettings Class
ChartColumnTypeSettings Members


EnableStackedColumnType Property

[image]
Intersoft WebGrid Documentation
EnableStackedColumnType Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartColumnTypeSettings Class : EnableStackedColumnType Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("Options")>
<System.ComponentModel.DescriptionAttribute("Enable user to switch chart to Stacked Column type.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Property EnableStackedColumnType As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As ChartColumnTypeSettings
Dim value As System.Boolean

instance.EnableStackedColumnType = value

value = instance.EnableStackedColumnType
C#
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Options")]
[System.ComponentModel.DescriptionAttribute("Enable user to switch chart to Stacked Column type.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
public System.bool EnableStackedColumnType {get; set;}
Delphi
public read-write property EnableStackedColumnType: System.Boolean;
JScript
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("Options")
System.ComponentModel.DescriptionAttribute("Enable user to switch chart to Stacked Column type.")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.XmlSerializableAttribute()
public function get,set EnableStackedColumnType : System.boolean
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Options")]
[System.ComponentModel.DescriptionAttribute("Enable user to switch chart to Stacked Column type.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property System.bool get_EnableStackedColumnType();
public: __property void set_EnableStackedColumnType(
   System.bool value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Options")]
[System.ComponentModel.DescriptionAttribute("Enable user to switch chart to Stacked Column type.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property System.bool EnableStackedColumnType {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartColumnTypeSettings Class
ChartColumnTypeSettings Members


EnableStackedPercentage3DColumnType Property

[image]
Intersoft WebGrid Documentation
EnableStackedPercentage3DColumnType Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartColumnTypeSettings Class : EnableStackedPercentage3DColumnType Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Enable user to switch chart to 100% Stacked 3D Column type.")>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Options")>
Public Property EnableStackedPercentage3DColumnType As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As ChartColumnTypeSettings
Dim value As System.Boolean

instance.EnableStackedPercentage3DColumnType = value

value = instance.EnableStackedPercentage3DColumnType
C#
[System.ComponentModel.DescriptionAttribute("Enable user to switch chart to 100% Stacked 3D Column type.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Options")]
public System.bool EnableStackedPercentage3DColumnType {get; set;}
Delphi
public read-write property EnableStackedPercentage3DColumnType: System.Boolean;
JScript
System.ComponentModel.DescriptionAttribute("Enable user to switch chart to 100% Stacked 3D Column type.")
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Options")
public function get,set EnableStackedPercentage3DColumnType : System.boolean
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Enable user to switch chart to 100% Stacked 3D Column type.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Options")]
public: __property System.bool get_EnableStackedPercentage3DColumnType();
public: __property void set_EnableStackedPercentage3DColumnType(
   System.bool value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Enable user to switch chart to 100% Stacked 3D Column type.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Options")]
public:
property System.bool EnableStackedPercentage3DColumnType {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartColumnTypeSettings Class
ChartColumnTypeSettings Members


EnableStackedPercentageColumnType Property

[image]
Intersoft WebGrid Documentation
EnableStackedPercentageColumnType Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartColumnTypeSettings Class : EnableStackedPercentageColumnType Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Enable user to switch chart to 100% Stacked Column type.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Options")>
Public Property EnableStackedPercentageColumnType As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As ChartColumnTypeSettings
Dim value As System.Boolean

instance.EnableStackedPercentageColumnType = value

value = instance.EnableStackedPercentageColumnType
C#
[System.ComponentModel.DescriptionAttribute("Enable user to switch chart to 100% Stacked Column type.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Options")]
public System.bool EnableStackedPercentageColumnType {get; set;}
Delphi
public read-write property EnableStackedPercentageColumnType: System.Boolean;
JScript
System.ComponentModel.DescriptionAttribute("Enable user to switch chart to 100% Stacked Column type.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Options")
public function get,set EnableStackedPercentageColumnType : System.boolean
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Enable user to switch chart to 100% Stacked Column type.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Options")]
public: __property System.bool get_EnableStackedPercentageColumnType();
public: __property void set_EnableStackedPercentageColumnType(
   System.bool value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Enable user to switch chart to 100% Stacked Column type.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Options")]
public:
property System.bool EnableStackedPercentageColumnType {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartColumnTypeSettings Class
ChartColumnTypeSettings Members


ChartConfig Class

[image]
Intersoft WebGrid Documentation
ChartConfig Class
Members See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartConfig Class

Glossary Item Box

Object Model

ChartConfig Class

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.SerializableAttribute()>
Public Class ChartConfig
   Inherits ISNet.WebUI.WebUIBaseClass
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Visual Basic (Usage) Copy Code
Dim instance As ChartConfig
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public class ChartConfig : ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Delphi
public class ChartConfig = class(ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize)
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.SerializableAttribute()
public class ChartConfig extends ISNet.WebUI.WebUIBaseClass implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public __gc class ChartConfig : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public ref class ChartConfig : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.WebGrid.Chart.ChartConfig

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartConfig Members
ISNet.WebUI.WebGrid.Chart Namespace


ChartConfig Class Members

[image]
Intersoft WebGrid Documentation
ChartConfig Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartConfig Class

Glossary Item Box

The following tables list the members exposed by ChartConfig.

Public Constructors

 | Name | Description
Public Constructor | ChartConfig Constructor |
Top

Public Properties

 | Name | Description
Public Property | ChartCategoryCollection |
Public Property | ChartDataCollection |
Public Property | ChartFilterCollection |
Public Property | ChartInteractiveUI |
Public Property | ChartMode |
Public Property | ChartSeriesCollection |
Public Property | ChartSettings |
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

ChartConfig Class
ISNet.WebUI.WebGrid.Chart Namespace


ChartConfig Constructor

[image]
Intersoft WebGrid Documentation
ChartConfig Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartConfig Class : ChartConfig Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New ChartConfig()
C#
public ChartConfig()
Delphi
public ChartConfig();
JScript
public function ChartConfig();
Managed Extensions for C++
public: ChartConfig();
C++/CLI
public:
ChartConfig();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartConfig Class
ChartConfig Members


Clone Method

[image]
Intersoft WebGrid Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartConfig Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As System.Object
Visual Basic (Usage) Copy Code
Dim instance As ChartConfig
Dim value As System.Object

value = instance.Clone()
C#
public virtual System.object Clone()
Delphi
public function Clone(): System.TObject; virtual;
JScript
public function Clone() : System.Object;
Managed Extensions for C++
public: virtual System.Object* Clone();
C++/CLI
public:
virtual System.Object^ Clone();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartConfig Class
ChartConfig Members


CopyFrom Method

[image]
Intersoft WebGrid Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartConfig Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartConfig Class
ChartConfig Members


CopyFrom(Object) Method

[image]
Intersoft WebGrid Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartConfig Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartConfig
Dim objSource As System.Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   System.object objSource
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartConfig Class
ChartConfig Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebGrid Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartConfig Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object, _
   ByVal cloneSourceValue As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartConfig
Dim objSource As System.Object
Dim cloneSourceValue As System.Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   System.object objSource,
   System.bool cloneSourceValue
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject;
    cloneSourceValue: System.Boolean
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object,
   cloneSourceValue : System.boolean
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource,
   System.bool cloneSourceValue
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource,
   System.bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartConfig Class
ChartConfig Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebGrid Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartConfig Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartConfig
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure DeSerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function DeSerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void DeSerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void DeSerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartConfig Class
ChartConfig Members


GetHashCode Method

[image]
Intersoft WebGrid Documentation
GetHashCode Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartConfig Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As ChartConfig
Dim value As System.Integer

value = instance.GetHashCode()
C#
public virtual System.int GetHashCode()
Delphi
public function GetHashCode(): System.Integer; virtual;
JScript
public function GetHashCode() : System.int;
Managed Extensions for C++
public: virtual System.int GetHashCode();
C++/CLI
public:
virtual System.int GetHashCode();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartConfig Class
ChartConfig Members


ChartConfig Class Methods

[image]
Intersoft WebGrid Documentation
ChartConfig Class Methods
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartConfig Class

Glossary Item Box

For a list of all members of this type, see ChartConfig members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

ChartConfig Class
ISNet.WebUI.WebGrid.Chart Namespace


GetObjectData Method

[image]
Intersoft WebGrid Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartConfig Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=False,
   UnmanagedCode=False,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=True,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Action=SecurityAction.Demand,
   Unrestricted=False)>
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartConfig
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure GetObjectData(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
); override;
JScript
System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=,
   UnmanagedCode=,
   SkipVerification=,
   Execution=,
   ControlThread=,
   ControlEvidence=,
   ControlPolicy=,
   SerializationFormatter=,
   ControlDomainPolicy=,
   ControlPrincipal=,
   ControlAppDomain=,
   RemotingConfiguration=,
   Infrastructure=,
   BindingRedirects=,
   Action=SecurityAction.Demand,
   Unrestricted=)
public override function GetObjectData(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public: void GetObjectData(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
) override
C++/CLI
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public:
void GetObjectData(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
) override

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartConfig Class
ChartConfig Members


IsEmpty Method

[image]
Intersoft WebGrid Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartConfig Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As ChartConfig
Dim value As System.Boolean

value = instance.IsEmpty()
C#
public virtual System.bool IsEmpty()
Delphi
public function IsEmpty(): System.Boolean; virtual;
JScript
public function IsEmpty() : System.boolean;
Managed Extensions for C++
public: virtual System.bool IsEmpty();
C++/CLI
public:
virtual System.bool IsEmpty();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartConfig Class
ChartConfig Members


Reset Method

[image]
Intersoft WebGrid Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartConfig Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As ChartConfig

instance.Reset()
C#
public virtual void Reset()
Delphi
public procedure Reset(); virtual;
JScript
public function Reset();
Managed Extensions for C++
public: virtual void Reset();
C++/CLI
public:
virtual void Reset();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartConfig Class
ChartConfig Members


SerializeObjectData Method

[image]
Intersoft WebGrid Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartConfig Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartConfig
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure SerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function SerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void SerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void SerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartConfig Class
ChartConfig Members


ToString Method

[image]
Intersoft WebGrid Documentation
ToString Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartConfig Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As System.String
Visual Basic (Usage) Copy Code
Dim instance As ChartConfig
Dim value As System.String

value = instance.ToString()
C#
public virtual System.string ToString()
Delphi
public function ToString(): System.String; virtual;
JScript
public function ToString() : System.String;
Managed Extensions for C++
public: virtual System.string* ToString();
C++/CLI
public:
virtual System.String^ ToString();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartConfig Class
ChartConfig Members


ChartConfig Class Properties

[image]
Intersoft WebGrid Documentation
ChartConfig Class Properties
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartConfig Class

Glossary Item Box

For a list of all members of this type, see ChartConfig members.

Public Properties

 | Name | Description
Public Property | ChartCategoryCollection |
Public Property | ChartDataCollection |
Public Property | ChartFilterCollection |
Public Property | ChartInteractiveUI |
Public Property | ChartMode |
Public Property | ChartSeriesCollection |
Public Property | ChartSettings |
Top

See Also

Reference

ChartConfig Class
ISNet.WebUI.WebGrid.Chart Namespace


ChartConfig Constructor

[image]
Intersoft WebGrid Documentation
ChartConfig Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartConfig Class : ChartConfig Constructor

Glossary Item Box

Overload List

Overload | Description
ChartConfig Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartConfig Class
ChartConfig Members


ChartCategoryCollection Property

[image]
Intersoft WebGrid Documentation
ChartCategoryCollection Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartConfig Class : ChartCategoryCollection Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.DefaultValueAttribute()>
Public ReadOnly Property ChartCategoryCollection As ChartPivotFilterConfigCollection
Visual Basic (Usage) Copy Code
Dim instance As ChartConfig
Dim value As ChartPivotFilterConfigCollection

value = instance.ChartCategoryCollection
C#
[ISNet.Serialization.XmlSerializableAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DefaultValueAttribute()]
public ChartPivotFilterConfigCollection ChartCategoryCollection {get;}
Delphi
public read-only property ChartCategoryCollection: ChartPivotFilterConfigCollection;
JScript
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.DefaultValueAttribute()
public function get ChartCategoryCollection : ChartPivotFilterConfigCollection
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DefaultValueAttribute()]
public: __property ChartPivotFilterConfigCollection* get_ChartCategoryCollection();
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DefaultValueAttribute()]
public:
property ChartPivotFilterConfigCollection^ ChartCategoryCollection {
   ChartPivotFilterConfigCollection^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartConfig Class
ChartConfig Members


ChartDataCollection Property

[image]
Intersoft WebGrid Documentation
ChartDataCollection Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartConfig Class : ChartDataCollection Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<ISNet.Serialization.XmlSerializableAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public ReadOnly Property ChartDataCollection As ChartPivotDataConfigCollection
Visual Basic (Usage) Copy Code
Dim instance As ChartConfig
Dim value As ChartPivotDataConfigCollection

value = instance.ChartDataCollection
C#
[System.ComponentModel.DefaultValueAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public ChartPivotDataConfigCollection ChartDataCollection {get;}
Delphi
public read-only property ChartDataCollection: ChartPivotDataConfigCollection;
JScript
System.ComponentModel.DefaultValueAttribute()
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
public function get ChartDataCollection : ChartPivotDataConfigCollection
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property ChartPivotDataConfigCollection* get_ChartDataCollection();
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property ChartPivotDataConfigCollection^ ChartDataCollection {
   ChartPivotDataConfigCollection^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartConfig Class
ChartConfig Members


ChartFilterCollection Property

[image]
Intersoft WebGrid Documentation
ChartFilterCollection Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartConfig Class : ChartFilterCollection Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute(True)>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.DefaultValueAttribute()>
Public ReadOnly Property ChartFilterCollection As ChartPivotFilterConfigCollection
Visual Basic (Usage) Copy Code
Dim instance As ChartConfig
Dim value As ChartPivotFilterConfigCollection

value = instance.ChartFilterCollection
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DefaultValueAttribute()]
public ChartPivotFilterConfigCollection ChartFilterCollection {get;}
Delphi
public read-only property ChartFilterCollection: ChartPivotFilterConfigCollection;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.DefaultValueAttribute()
public function get ChartFilterCollection : ChartPivotFilterConfigCollection
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DefaultValueAttribute()]
public: __property ChartPivotFilterConfigCollection* get_ChartFilterCollection();
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DefaultValueAttribute()]
public:
property ChartPivotFilterConfigCollection^ ChartFilterCollection {
   ChartPivotFilterConfigCollection^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartConfig Class
ChartConfig Members


ChartInteractiveUI Property

[image]
Intersoft WebGrid Documentation
ChartInteractiveUI Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartConfig Class : ChartInteractiveUI Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public ReadOnly Property ChartInteractiveUI As ChartInteractiveUISettings
Visual Basic (Usage) Copy Code
Dim instance As ChartConfig
Dim value As ChartInteractiveUISettings

value = instance.ChartInteractiveUI
C#
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public ChartInteractiveUISettings ChartInteractiveUI {get;}
Delphi
public read-only property ChartInteractiveUI: ChartInteractiveUISettings;
JScript
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
public function get ChartInteractiveUI : ChartInteractiveUISettings
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property ChartInteractiveUISettings* get_ChartInteractiveUI();
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property ChartInteractiveUISettings^ ChartInteractiveUI {
   ChartInteractiveUISettings^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartConfig Class
ChartConfig Members


ChartMode Property

[image]
Intersoft WebGrid Documentation
ChartMode Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartConfig Class : ChartMode Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property ChartMode As ChartMode
Visual Basic (Usage) Copy Code
Dim instance As ChartConfig
Dim value As ChartMode

instance.ChartMode = value

value = instance.ChartMode
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public ChartMode ChartMode {get; set;}
Delphi
public read-write property ChartMode: ChartMode;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get,set ChartMode : ChartMode
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property ChartMode get_ChartMode();
public: __property void set_ChartMode(
   ChartMode value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property ChartMode ChartMode {
   ChartMode get();
   void set (    ChartMode value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartConfig Class
ChartConfig Members


ChartSeriesCollection Property

[image]
Intersoft WebGrid Documentation
ChartSeriesCollection Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartConfig Class : ChartSeriesCollection Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.XmlSerializableAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
Public ReadOnly Property ChartSeriesCollection As ChartPivotFilterConfigCollection
Visual Basic (Usage) Copy Code
Dim instance As ChartConfig
Dim value As ChartPivotFilterConfigCollection

value = instance.ChartSeriesCollection
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
public ChartPivotFilterConfigCollection ChartSeriesCollection {get;}
Delphi
public read-only property ChartSeriesCollection: ChartPivotFilterConfigCollection;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
public function get ChartSeriesCollection : ChartPivotFilterConfigCollection
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
public: __property ChartPivotFilterConfigCollection* get_ChartSeriesCollection();
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
public:
property ChartPivotFilterConfigCollection^ ChartSeriesCollection {
   ChartPivotFilterConfigCollection^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartConfig Class
ChartConfig Members


ChartSettings Property

[image]
Intersoft WebGrid Documentation
ChartSettings Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartConfig Class : ChartSettings Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
Public ReadOnly Property ChartSettings As ChartSettings
Visual Basic (Usage) Copy Code
Dim instance As ChartConfig
Dim value As ChartSettings

value = instance.ChartSettings
C#
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
public ChartSettings ChartSettings {get;}
Delphi
public read-only property ChartSettings: ChartSettings;
JScript
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
ISNet.Serialization.XmlSerializableAttribute()
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
public function get ChartSettings : ChartSettings
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
public: __property ChartSettings* get_ChartSettings();
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
public:
property ChartSettings^ ChartSettings {
   ChartSettings^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartConfig Class
ChartConfig Members


ChartDataLabelStyle Class

[image]
Intersoft WebGrid Documentation
ChartDataLabelStyle Class
Members See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartDataLabelStyle Class

Glossary Item Box

Object Model

ChartDataLabelStyle Class

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.SerializableAttribute()>
Public Class ChartDataLabelStyle
   Inherits ISNet.WebUI.WebUIBaseClass
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Visual Basic (Usage) Copy Code
Dim instance As ChartDataLabelStyle
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public class ChartDataLabelStyle : ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Delphi
public class ChartDataLabelStyle = class(ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize)
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.SerializableAttribute()
public class ChartDataLabelStyle extends ISNet.WebUI.WebUIBaseClass implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public __gc class ChartDataLabelStyle : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public ref class ChartDataLabelStyle : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.WebGrid.Chart.ChartDataLabelStyle

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartDataLabelStyle Members
ISNet.WebUI.WebGrid.Chart Namespace


ChartDataLabelStyle Class Members

[image]
Intersoft WebGrid Documentation
ChartDataLabelStyle Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartDataLabelStyle Class

Glossary Item Box

The following tables list the members exposed by ChartDataLabelStyle.

Public Constructors

 | Name | Description
Public Constructor | ChartDataLabelStyle Constructor |
Top

Public Properties

 | Name | Description
Public Property | ArrowLength |
Public Property | ArrowPointerLength |
Public Property | ArrowStrokeStyle |
Public Property | Format |
Public Property | TextStyle |
Public Property | VerticalAlign |
Public Property | Visible |
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

ChartDataLabelStyle Class
ISNet.WebUI.WebGrid.Chart Namespace


ChartDataLabelStyle Constructor

[image]
Intersoft WebGrid Documentation
ChartDataLabelStyle Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartDataLabelStyle Class : ChartDataLabelStyle Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New ChartDataLabelStyle()
C#
public ChartDataLabelStyle()
Delphi
public ChartDataLabelStyle();
JScript
public function ChartDataLabelStyle();
Managed Extensions for C++
public: ChartDataLabelStyle();
C++/CLI
public:
ChartDataLabelStyle();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartDataLabelStyle Class
ChartDataLabelStyle Members


Clone Method

[image]
Intersoft WebGrid Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartDataLabelStyle Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As System.Object
Visual Basic (Usage) Copy Code
Dim instance As ChartDataLabelStyle
Dim value As System.Object

value = instance.Clone()
C#
public virtual System.object Clone()
Delphi
public function Clone(): System.TObject; virtual;
JScript
public function Clone() : System.Object;
Managed Extensions for C++
public: virtual System.Object* Clone();
C++/CLI
public:
virtual System.Object^ Clone();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartDataLabelStyle Class
ChartDataLabelStyle Members


CopyFrom Method

[image]
Intersoft WebGrid Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartDataLabelStyle Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartDataLabelStyle Class
ChartDataLabelStyle Members


CopyFrom(Object) Method

[image]
Intersoft WebGrid Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartDataLabelStyle Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartDataLabelStyle
Dim objSource As System.Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   System.object objSource
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartDataLabelStyle Class
ChartDataLabelStyle Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebGrid Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartDataLabelStyle Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object, _
   ByVal cloneSourceValue As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartDataLabelStyle
Dim objSource As System.Object
Dim cloneSourceValue As System.Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   System.object objSource,
   System.bool cloneSourceValue
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject;
    cloneSourceValue: System.Boolean
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object,
   cloneSourceValue : System.boolean
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource,
   System.bool cloneSourceValue
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource,
   System.bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartDataLabelStyle Class
ChartDataLabelStyle Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebGrid Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartDataLabelStyle Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartDataLabelStyle
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure DeSerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function DeSerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void DeSerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void DeSerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartDataLabelStyle Class
ChartDataLabelStyle Members


GetHashCode Method

[image]
Intersoft WebGrid Documentation
GetHashCode Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartDataLabelStyle Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As ChartDataLabelStyle
Dim value As System.Integer

value = instance.GetHashCode()
C#
public virtual System.int GetHashCode()
Delphi
public function GetHashCode(): System.Integer; virtual;
JScript
public function GetHashCode() : System.int;
Managed Extensions for C++
public: virtual System.int GetHashCode();
C++/CLI
public:
virtual System.int GetHashCode();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartDataLabelStyle Class
ChartDataLabelStyle Members


ChartDataLabelStyle Class Methods

[image]
Intersoft WebGrid Documentation
ChartDataLabelStyle Class Methods
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartDataLabelStyle Class

Glossary Item Box

For a list of all members of this type, see ChartDataLabelStyle members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

ChartDataLabelStyle Class
ISNet.WebUI.WebGrid.Chart Namespace


GetObjectData Method

[image]
Intersoft WebGrid Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartDataLabelStyle Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=False,
   UnmanagedCode=False,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=True,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Action=SecurityAction.Demand,
   Unrestricted=False)>
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartDataLabelStyle
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure GetObjectData(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
); override;
JScript
System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=,
   UnmanagedCode=,
   SkipVerification=,
   Execution=,
   ControlThread=,
   ControlEvidence=,
   ControlPolicy=,
   SerializationFormatter=,
   ControlDomainPolicy=,
   ControlPrincipal=,
   ControlAppDomain=,
   RemotingConfiguration=,
   Infrastructure=,
   BindingRedirects=,
   Action=SecurityAction.Demand,
   Unrestricted=)
public override function GetObjectData(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public: void GetObjectData(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
) override
C++/CLI
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public:
void GetObjectData(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
) override

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartDataLabelStyle Class
ChartDataLabelStyle Members


IsEmpty Method

[image]
Intersoft WebGrid Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartDataLabelStyle Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As ChartDataLabelStyle
Dim value As System.Boolean

value = instance.IsEmpty()
C#
public virtual System.bool IsEmpty()
Delphi
public function IsEmpty(): System.Boolean; virtual;
JScript
public function IsEmpty() : System.boolean;
Managed Extensions for C++
public: virtual System.bool IsEmpty();
C++/CLI
public:
virtual System.bool IsEmpty();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartDataLabelStyle Class
ChartDataLabelStyle Members


Reset Method

[image]
Intersoft WebGrid Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartDataLabelStyle Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As ChartDataLabelStyle

instance.Reset()
C#
public virtual void Reset()
Delphi
public procedure Reset(); virtual;
JScript
public function Reset();
Managed Extensions for C++
public: virtual void Reset();
C++/CLI
public:
virtual void Reset();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartDataLabelStyle Class
ChartDataLabelStyle Members


SerializeObjectData Method

[image]
Intersoft WebGrid Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartDataLabelStyle Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartDataLabelStyle
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure SerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function SerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void SerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void SerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartDataLabelStyle Class
ChartDataLabelStyle Members


ToString Method

[image]
Intersoft WebGrid Documentation
ToString Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartDataLabelStyle Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As System.String
Visual Basic (Usage) Copy Code
Dim instance As ChartDataLabelStyle
Dim value As System.String

value = instance.ToString()
C#
public virtual System.string ToString()
Delphi
public function ToString(): System.String; virtual;
JScript
public function ToString() : System.String;
Managed Extensions for C++
public: virtual System.string* ToString();
C++/CLI
public:
virtual System.String^ ToString();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartDataLabelStyle Class
ChartDataLabelStyle Members


ChartDataLabelStyle Class Properties

[image]
Intersoft WebGrid Documentation
ChartDataLabelStyle Class Properties
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartDataLabelStyle Class

Glossary Item Box

For a list of all members of this type, see ChartDataLabelStyle members.

Public Properties

 | Name | Description
Public Property | ArrowLength |
Public Property | ArrowPointerLength |
Public Property | ArrowStrokeStyle |
Public Property | Format |
Public Property | TextStyle |
Public Property | VerticalAlign |
Public Property | Visible |
Top

See Also

Reference

ChartDataLabelStyle Class
ISNet.WebUI.WebGrid.Chart Namespace


ChartDataLabelStyle Constructor

[image]
Intersoft WebGrid Documentation
ChartDataLabelStyle Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartDataLabelStyle Class : ChartDataLabelStyle Constructor

Glossary Item Box

Overload List

Overload | Description
ChartDataLabelStyle Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartDataLabelStyle Class
ChartDataLabelStyle Members


ArrowLength Property

[image]
Intersoft WebGrid Documentation
ArrowLength Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartDataLabelStyle Class : ArrowLength Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Controls the length of the arrow connecting the data point and the text label.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Arrow")>
Public Property ArrowLength As System.Nullable(Of Single)
Visual Basic (Usage) Copy Code
Dim instance As ChartDataLabelStyle
Dim value As System.Nullable(Of Single)

instance.ArrowLength = value

value = instance.ArrowLength
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Controls the length of the arrow connecting the data point and the text label.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Arrow")]
public System.Nullable<float> ArrowLength {get; set;}
Delphi
public read-write property ArrowLength: System.Nullable;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DescriptionAttribute("Controls the length of the arrow connecting the data point and the text label.")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Arrow")
public function get,set ArrowLength : System.Nullable
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Controls the length of the arrow connecting the data point and the text label.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Arrow")]
public: __property System.Nullable<float> get_ArrowLength();
public: __property void set_ArrowLength(
   System.Nullable<float> value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Controls the length of the arrow connecting the data point and the text label.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Arrow")]
public:
property System.Nullable<float> ArrowLength {
   System.Nullable<float> get();
   void set (    System.Nullable<float> value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartDataLabelStyle Class
ChartDataLabelStyle Members


ArrowPointerLength Property

[image]
Intersoft WebGrid Documentation
ArrowPointerLength Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartDataLabelStyle Class : ArrowPointerLength Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Controls the length of the arrow pointer pointing to the data labal text.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Arrow")>
Public Property ArrowPointerLength As System.Nullable(Of Single)
Visual Basic (Usage) Copy Code
Dim instance As ChartDataLabelStyle
Dim value As System.Nullable(Of Single)

instance.ArrowPointerLength = value

value = instance.ArrowPointerLength
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Controls the length of the arrow pointer pointing to the data labal text.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Arrow")]
public System.Nullable<float> ArrowPointerLength {get; set;}
Delphi
public read-write property ArrowPointerLength: System.Nullable;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Controls the length of the arrow pointer pointing to the data labal text.")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Arrow")
public function get,set ArrowPointerLength : System.Nullable
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Controls the length of the arrow pointer pointing to the data labal text.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Arrow")]
public: __property System.Nullable<float> get_ArrowPointerLength();
public: __property void set_ArrowPointerLength(
   System.Nullable<float> value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Controls the length of the arrow pointer pointing to the data labal text.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Arrow")]
public:
property System.Nullable<float> ArrowPointerLength {
   System.Nullable<float> get();
   void set (    System.Nullable<float> value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartDataLabelStyle Class
ChartDataLabelStyle Members


ArrowStrokeStyle Property

[image]
Intersoft WebGrid Documentation
ArrowStrokeStyle Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartDataLabelStyle Class : ArrowStrokeStyle Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Appearance of the arrow.")>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute("setArrowStrokeStyle")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<System.ComponentModel.CategoryAttribute("Arrow")>
Public ReadOnly Property ArrowStrokeStyle As ChartStrokeStyle
Visual Basic (Usage) Copy Code
Dim instance As ChartDataLabelStyle
Dim value As ChartStrokeStyle

value = instance.ArrowStrokeStyle
C#
[System.ComponentModel.DescriptionAttribute("Appearance of the arrow.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute("setArrowStrokeStyle")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.CategoryAttribute("Arrow")]
public ChartStrokeStyle ArrowStrokeStyle {get;}
Delphi
public read-only property ArrowStrokeStyle: ChartStrokeStyle;
JScript
System.ComponentModel.DescriptionAttribute("Appearance of the arrow.")
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute("setArrowStrokeStyle")
System.ComponentModel.NotifyParentPropertyAttribute()
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
System.ComponentModel.CategoryAttribute("Arrow")
public function get ArrowStrokeStyle : ChartStrokeStyle
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Appearance of the arrow.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute("setArrowStrokeStyle")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.CategoryAttribute("Arrow")]
public: __property ChartStrokeStyle* get_ArrowStrokeStyle();
C++/CLI
[System.ComponentModel.DescriptionAttribute("Appearance of the arrow.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute("setArrowStrokeStyle")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.CategoryAttribute("Arrow")]
public:
property ChartStrokeStyle^ ArrowStrokeStyle {
   ChartStrokeStyle^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartDataLabelStyle Class
ChartDataLabelStyle Members


Format Property

[image]
Intersoft WebGrid Documentation
Format Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartDataLabelStyle Class : Format Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Data label format string.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Text")>
Public Property Format As System.String
Visual Basic (Usage) Copy Code
Dim instance As ChartDataLabelStyle
Dim value As System.String

instance.Format = value

value = instance.Format
C#
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Data label format string.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Text")]
public System.string Format {get; set;}
Delphi
public read-write property Format: System.String;
JScript
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Data label format string.")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Text")
public function get,set Format : System.String
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Data label format string.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Text")]
public: __property System.string* get_Format();
public: __property void set_Format(
   System.string* value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Data label format string.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Text")]
public:
property System.String^ Format {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartDataLabelStyle Class
ChartDataLabelStyle Members


TextStyle Property

[image]
Intersoft WebGrid Documentation
TextStyle Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartDataLabelStyle Class : TextStyle Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute("setTextStyle")>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<System.ComponentModel.DescriptionAttribute("Gets or sets the text style applied to the data labels")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Text")>
Public ReadOnly Property TextStyle As ChartTextStyle
Visual Basic (Usage) Copy Code
Dim instance As ChartDataLabelStyle
Dim value As ChartTextStyle

value = instance.TextStyle
C#
[ISNet.Serialization.BinarySerializableAttribute("setTextStyle")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the text style applied to the data labels")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Text")]
public ChartTextStyle TextStyle {get;}
Delphi
public read-only property TextStyle: ChartTextStyle;
JScript
ISNet.Serialization.BinarySerializableAttribute("setTextStyle")
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
System.ComponentModel.DescriptionAttribute("Gets or sets the text style applied to the data labels")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Text")
public function get TextStyle : ChartTextStyle
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute("setTextStyle")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the text style applied to the data labels")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Text")]
public: __property ChartTextStyle* get_TextStyle();
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute("setTextStyle")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the text style applied to the data labels")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Text")]
public:
property ChartTextStyle^ TextStyle {
   ChartTextStyle^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartDataLabelStyle Class
ChartDataLabelStyle Members


VerticalAlign Property

[image]
Intersoft WebGrid Documentation
VerticalAlign Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartDataLabelStyle Class : VerticalAlign Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Alignment")>
<System.ComponentModel.DescriptionAttribute("Controls the vertical data label alignment relative to the data point bound.")>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property VerticalAlign As VerticalAlign
Visual Basic (Usage) Copy Code
Dim instance As ChartDataLabelStyle
Dim value As VerticalAlign

instance.VerticalAlign = value

value = instance.VerticalAlign
C#
[System.ComponentModel.CategoryAttribute("Alignment")]
[System.ComponentModel.DescriptionAttribute("Controls the vertical data label alignment relative to the data point bound.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public VerticalAlign VerticalAlign {get; set;}
Delphi
public read-write property VerticalAlign: VerticalAlign;
JScript
System.ComponentModel.CategoryAttribute("Alignment")
System.ComponentModel.DescriptionAttribute("Controls the vertical data label alignment relative to the data point bound.")
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set VerticalAlign : VerticalAlign
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Alignment")]
[System.ComponentModel.DescriptionAttribute("Controls the vertical data label alignment relative to the data point bound.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property VerticalAlign get_VerticalAlign();
public: __property void set_VerticalAlign(
   VerticalAlign value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Alignment")]
[System.ComponentModel.DescriptionAttribute("Controls the vertical data label alignment relative to the data point bound.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property VerticalAlign VerticalAlign {
   VerticalAlign get();
   void set (    VerticalAlign value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartDataLabelStyle Class
ChartDataLabelStyle Members


Visible Property

[image]
Intersoft WebGrid Documentation
Visible Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartDataLabelStyle Class : Visible Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("General")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Controls the visibility of the data label.")>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property Visible As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As ChartDataLabelStyle
Dim value As System.Boolean

instance.Visible = value

value = instance.Visible
C#
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Controls the visibility of the data label.")]
[ISNet.Serialization.BinarySerializableAttribute()]
public System.bool Visible {get; set;}
Delphi
public read-write property Visible: System.Boolean;
JScript
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("General")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Controls the visibility of the data label.")
ISNet.Serialization.BinarySerializableAttribute()
public function get,set Visible : System.boolean
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Controls the visibility of the data label.")]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.bool get_Visible();
public: __property void set_Visible(
   System.bool value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Controls the visibility of the data label.")]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.bool Visible {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartDataLabelStyle Class
ChartDataLabelStyle Members


ChartDataManager Class

[image]
Intersoft WebGrid Documentation
ChartDataManager Class
Members See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartDataManager Class

Glossary Item Box

Object Model

ChartDataManager Class

Syntax

Visual Basic (Declaration)
Public MustInherit Class ChartDataManager
Visual Basic (Usage) Copy Code
Dim instance As ChartDataManager
C#
public abstract class ChartDataManager
Delphi
public class ChartDataManager abstract;
JScript
public abstract class ChartDataManager
Managed Extensions for C++
public __gc abstract class ChartDataManager
C++/CLI
public ref class ChartDataManager abstract

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebGrid.Chart.ChartDataManager

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartDataManager Members
ISNet.WebUI.WebGrid.Chart Namespace


ChartDataManager Class Members

[image]
Intersoft WebGrid Documentation
ChartDataManager Class Members
See Also Methods Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartDataManager Class

Glossary Item Box

The following tables list the members exposed by ChartDataManager.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | RetrieveChartData |
static (Shared in Visual Basic) | RetrievePivotData |
Top

See Also

Reference

ChartDataManager Class
ISNet.WebUI.WebGrid.Chart Namespace


ChartDataManager Class Methods

[image]
Intersoft WebGrid Documentation
ChartDataManager Class Methods
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartDataManager Class

Glossary Item Box

For a list of all members of this type, see ChartDataManager members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | RetrieveChartData |
static (Shared in Visual Basic) | RetrievePivotData |
Top

See Also

Reference

ChartDataManager Class
ISNet.WebUI.WebGrid.Chart Namespace


RetrieveChartData Method

[image]
Intersoft WebGrid Documentation
RetrieveChartData Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartDataManager Class : RetrieveChartData Method

Glossary Item Box

Overload List

Overload | Description
RetrieveChartData |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartDataManager Class
ChartDataManager Members


RetrieveChartData(ChartConfig,DataTable) Method

[image]
Intersoft WebGrid Documentation
RetrieveChartData(ChartConfig,DataTable) Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartDataManager Class : RetrieveChartData(ChartConfig,DataTable) Method

chartConfig
table

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Shared Function RetrieveChartData( _
   ByVal chartConfig As ChartConfig, _
   ByVal table As System.Data.DataTable _
) As System.Collections.ObjectModel.Collection(Of DataTable)
Visual Basic (Usage) Copy Code
Dim chartConfig As ChartConfig
Dim table As System.Data.DataTable
Dim value As System.Collections.ObjectModel.Collection(Of DataTable)

value = ChartDataManager.RetrieveChartData(chartConfig, table)
C#
public static System.Collections.ObjectModel.Collection<DataTable> RetrieveChartData(
   ChartConfig chartConfig,
   System.Data.DataTable table
)
Delphi
public function RetrieveChartData(
    chartConfig: ChartConfig;
    table: System.Data.DataTable
): System.Collections.ObjectModel.Collection; static;
JScript
public static function RetrieveChartData(
   chartConfig : ChartConfig,
   table : System.Data.DataTable
) : System.Collections.ObjectModel.Collection;
Managed Extensions for C++
public: static System.Collections.ObjectModel.Collection<DataTable*>* RetrieveChartData(
   ChartConfig* chartConfig,
   System.Data.DataTable* table
)
C++/CLI
public:
static System.Collections.ObjectModel.Collection<DataTable^>^ RetrieveChartData(
   ChartConfig^ chartConfig,
   System.Data.DataTable^ table
)

Parameters

chartConfig
table

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartDataManager Class
ChartDataManager Members


RetrievePivotData Method

[image]
Intersoft WebGrid Documentation
RetrievePivotData Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartDataManager Class : RetrievePivotData Method

Glossary Item Box

Overload List

Overload | Description
RetrievePivotData |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartDataManager Class
ChartDataManager Members


RetrievePivotData(DataTable,ChartPivotFilterConfig) Method

[image]
Intersoft WebGrid Documentation
RetrievePivotData(DataTable,ChartPivotFilterConfig) Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartDataManager Class : RetrievePivotData(DataTable,ChartPivotFilterConfig) Method

table
filterConfig

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Shared Function RetrievePivotData( _
   ByVal table As System.Data.DataTable, _
   ByVal filterConfig As ChartPivotFilterConfig _
) As System.Collections.Generic.List(Of String)
Visual Basic (Usage) Copy Code
Dim table As System.Data.DataTable
Dim filterConfig As ChartPivotFilterConfig
Dim value As System.Collections.Generic.List(Of String)

value = ChartDataManager.RetrievePivotData(table, filterConfig)
C#
public static System.Collections.Generic.List<string> RetrievePivotData(
   System.Data.DataTable table,
   ChartPivotFilterConfig filterConfig
)
Delphi
public function RetrievePivotData(
    table: System.Data.DataTable;
    filterConfig: ChartPivotFilterConfig
): System.Collections.Generic.List; static;
JScript
public static function RetrievePivotData(
   table : System.Data.DataTable,
   filterConfig : ChartPivotFilterConfig
) : System.Collections.Generic.List;
Managed Extensions for C++
public: static System.Collections.Generic.List<string*>* RetrievePivotData(
   System.Data.DataTable* table,
   ChartPivotFilterConfig* filterConfig
)
C++/CLI
public:
static System.Collections.Generic.List<String^>^ RetrievePivotData(
   System.Data.DataTable^ table,
   ChartPivotFilterConfig^ filterConfig
)

Parameters

table
filterConfig

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartDataManager Class
ChartDataManager Members


ChartDoughnutTypeSettings Class

[image]
Intersoft WebGrid Documentation
ChartDoughnutTypeSettings Class
Members See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartDoughnutTypeSettings Class

Glossary Item Box

Object Model

ChartDoughnutTypeSettings Class

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.SerializableAttribute()>
Public Class ChartDoughnutTypeSettings
   Inherits ISNet.WebUI.WebUIBaseClass
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Visual Basic (Usage) Copy Code
Dim instance As ChartDoughnutTypeSettings
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public class ChartDoughnutTypeSettings : ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Delphi
public class ChartDoughnutTypeSettings = class(ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize)
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.SerializableAttribute()
public class ChartDoughnutTypeSettings extends ISNet.WebUI.WebUIBaseClass implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public __gc class ChartDoughnutTypeSettings : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public ref class ChartDoughnutTypeSettings : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.WebGrid.Chart.ChartDoughnutTypeSettings

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartDoughnutTypeSettings Members
ISNet.WebUI.WebGrid.Chart Namespace


ChartDoughnutTypeSettings Class Members

[image]
Intersoft WebGrid Documentation
ChartDoughnutTypeSettings Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartDoughnutTypeSettings Class

Glossary Item Box

The following tables list the members exposed by ChartDoughnutTypeSettings.

Public Constructors

 | Name | Description
Public Constructor | ChartDoughnutTypeSettings Constructor |
Top

Public Properties

 | Name | Description
Public Property | EnableBasic3DDoughnutType |
Public Property | Enabled |
Public Property | EnableDoughnutType |
Public Property | EnableExploded3DDoughnutType |
Public Property | EnableExplodedDoughnutType |
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

ChartDoughnutTypeSettings Class
ISNet.WebUI.WebGrid.Chart Namespace


ChartDoughnutTypeSettings Constructor

[image]
Intersoft WebGrid Documentation
ChartDoughnutTypeSettings Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartDoughnutTypeSettings Class : ChartDoughnutTypeSettings Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New ChartDoughnutTypeSettings()
C#
public ChartDoughnutTypeSettings()
Delphi
public ChartDoughnutTypeSettings();
JScript
public function ChartDoughnutTypeSettings();
Managed Extensions for C++
public: ChartDoughnutTypeSettings();
C++/CLI
public:
ChartDoughnutTypeSettings();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartDoughnutTypeSettings Class
ChartDoughnutTypeSettings Members


Clone Method

[image]
Intersoft WebGrid Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartDoughnutTypeSettings Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As System.Object
Visual Basic (Usage) Copy Code
Dim instance As ChartDoughnutTypeSettings
Dim value As System.Object

value = instance.Clone()
C#
public virtual System.object Clone()
Delphi
public function Clone(): System.TObject; virtual;
JScript
public function Clone() : System.Object;
Managed Extensions for C++
public: virtual System.Object* Clone();
C++/CLI
public:
virtual System.Object^ Clone();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartDoughnutTypeSettings Class
ChartDoughnutTypeSettings Members


CopyFrom Method

[image]
Intersoft WebGrid Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartDoughnutTypeSettings Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartDoughnutTypeSettings Class
ChartDoughnutTypeSettings Members


CopyFrom(Object) Method

[image]
Intersoft WebGrid Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartDoughnutTypeSettings Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartDoughnutTypeSettings
Dim objSource As System.Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   System.object objSource
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartDoughnutTypeSettings Class
ChartDoughnutTypeSettings Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebGrid Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartDoughnutTypeSettings Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object, _
   ByVal cloneSourceValue As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartDoughnutTypeSettings
Dim objSource As System.Object
Dim cloneSourceValue As System.Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   System.object objSource,
   System.bool cloneSourceValue
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject;
    cloneSourceValue: System.Boolean
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object,
   cloneSourceValue : System.boolean
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource,
   System.bool cloneSourceValue
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource,
   System.bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartDoughnutTypeSettings Class
ChartDoughnutTypeSettings Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebGrid Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartDoughnutTypeSettings Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartDoughnutTypeSettings
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure DeSerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function DeSerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void DeSerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void DeSerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartDoughnutTypeSettings Class
ChartDoughnutTypeSettings Members


GetHashCode Method

[image]
Intersoft WebGrid Documentation
GetHashCode Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartDoughnutTypeSettings Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As ChartDoughnutTypeSettings
Dim value As System.Integer

value = instance.GetHashCode()
C#
public virtual System.int GetHashCode()
Delphi
public function GetHashCode(): System.Integer; virtual;
JScript
public function GetHashCode() : System.int;
Managed Extensions for C++
public: virtual System.int GetHashCode();
C++/CLI
public:
virtual System.int GetHashCode();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartDoughnutTypeSettings Class
ChartDoughnutTypeSettings Members


ChartDoughnutTypeSettings Class Methods

[image]
Intersoft WebGrid Documentation
ChartDoughnutTypeSettings Class Methods
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartDoughnutTypeSettings Class

Glossary Item Box

For a list of all members of this type, see ChartDoughnutTypeSettings members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

ChartDoughnutTypeSettings Class
ISNet.WebUI.WebGrid.Chart Namespace


GetObjectData Method

[image]
Intersoft WebGrid Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartDoughnutTypeSettings Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=False,
   UnmanagedCode=False,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=True,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Action=SecurityAction.Demand,
   Unrestricted=False)>
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartDoughnutTypeSettings
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure GetObjectData(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
); override;
JScript
System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=,
   UnmanagedCode=,
   SkipVerification=,
   Execution=,
   ControlThread=,
   ControlEvidence=,
   ControlPolicy=,
   SerializationFormatter=,
   ControlDomainPolicy=,
   ControlPrincipal=,
   ControlAppDomain=,
   RemotingConfiguration=,
   Infrastructure=,
   BindingRedirects=,
   Action=SecurityAction.Demand,
   Unrestricted=)
public override function GetObjectData(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public: void GetObjectData(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
) override
C++/CLI
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public:
void GetObjectData(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
) override

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartDoughnutTypeSettings Class
ChartDoughnutTypeSettings Members


IsEmpty Method

[image]
Intersoft WebGrid Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartDoughnutTypeSettings Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As ChartDoughnutTypeSettings
Dim value As System.Boolean

value = instance.IsEmpty()
C#
public virtual System.bool IsEmpty()
Delphi
public function IsEmpty(): System.Boolean; virtual;
JScript
public function IsEmpty() : System.boolean;
Managed Extensions for C++
public: virtual System.bool IsEmpty();
C++/CLI
public:
virtual System.bool IsEmpty();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartDoughnutTypeSettings Class
ChartDoughnutTypeSettings Members


Reset Method

[image]
Intersoft WebGrid Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartDoughnutTypeSettings Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As ChartDoughnutTypeSettings

instance.Reset()
C#
public virtual void Reset()
Delphi
public procedure Reset(); virtual;
JScript
public function Reset();
Managed Extensions for C++
public: virtual void Reset();
C++/CLI
public:
virtual void Reset();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartDoughnutTypeSettings Class
ChartDoughnutTypeSettings Members


SerializeObjectData Method

[image]
Intersoft WebGrid Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartDoughnutTypeSettings Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartDoughnutTypeSettings
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure SerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function SerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void SerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void SerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartDoughnutTypeSettings Class
ChartDoughnutTypeSettings Members


ToString Method

[image]
Intersoft WebGrid Documentation
ToString Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartDoughnutTypeSettings Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As System.String
Visual Basic (Usage) Copy Code
Dim instance As ChartDoughnutTypeSettings
Dim value As System.String

value = instance.ToString()
C#
public virtual System.string ToString()
Delphi
public function ToString(): System.String; virtual;
JScript
public function ToString() : System.String;
Managed Extensions for C++
public: virtual System.string* ToString();
C++/CLI
public:
virtual System.String^ ToString();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartDoughnutTypeSettings Class
ChartDoughnutTypeSettings Members


ChartDoughnutTypeSettings Class Properties

[image]
Intersoft WebGrid Documentation
ChartDoughnutTypeSettings Class Properties
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartDoughnutTypeSettings Class

Glossary Item Box

For a list of all members of this type, see ChartDoughnutTypeSettings members.

Public Properties

 | Name | Description
Public Property | EnableBasic3DDoughnutType |
Public Property | Enabled |
Public Property | EnableDoughnutType |
Public Property | EnableExploded3DDoughnutType |
Public Property | EnableExplodedDoughnutType |
Top

See Also

Reference

ChartDoughnutTypeSettings Class
ISNet.WebUI.WebGrid.Chart Namespace


ChartDoughnutTypeSettings Constructor

[image]
Intersoft WebGrid Documentation
ChartDoughnutTypeSettings Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartDoughnutTypeSettings Class : ChartDoughnutTypeSettings Constructor

Glossary Item Box

Overload List

Overload | Description
ChartDoughnutTypeSettings Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartDoughnutTypeSettings Class
ChartDoughnutTypeSettings Members


EnableBasic3DDoughnutType Property

[image]
Intersoft WebGrid Documentation
EnableBasic3DDoughnutType Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartDoughnutTypeSettings Class : EnableBasic3DDoughnutType Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Enable user to switch chart to Basic 3D Doughnut type.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("Options")>
Public Property EnableBasic3DDoughnutType As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As ChartDoughnutTypeSettings
Dim value As System.Boolean

instance.EnableBasic3DDoughnutType = value

value = instance.EnableBasic3DDoughnutType
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Enable user to switch chart to Basic 3D Doughnut type.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Options")]
public System.bool EnableBasic3DDoughnutType {get; set;}
Delphi
public read-write property EnableBasic3DDoughnutType: System.Boolean;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Enable user to switch chart to Basic 3D Doughnut type.")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("Options")
public function get,set EnableBasic3DDoughnutType : System.boolean
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Enable user to switch chart to Basic 3D Doughnut type.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Options")]
public: __property System.bool get_EnableBasic3DDoughnutType();
public: __property void set_EnableBasic3DDoughnutType(
   System.bool value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Enable user to switch chart to Basic 3D Doughnut type.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Options")]
public:
property System.bool EnableBasic3DDoughnutType {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartDoughnutTypeSettings Class
ChartDoughnutTypeSettings Members


Enabled Property

[image]
Intersoft WebGrid Documentation
Enabled Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartDoughnutTypeSettings Class : Enabled Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Enable user to switch chart to Series Doughnut types.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("Options")>
Public Property Enabled As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As ChartDoughnutTypeSettings
Dim value As System.Boolean

instance.Enabled = value

value = instance.Enabled
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Enable user to switch chart to Series Doughnut types.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Options")]
public System.bool Enabled {get; set;}
Delphi
public read-write property Enabled: System.Boolean;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Enable user to switch chart to Series Doughnut types.")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("Options")
public function get,set Enabled : System.boolean
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Enable user to switch chart to Series Doughnut types.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Options")]
public: __property System.bool get_Enabled();
public: __property void set_Enabled(
   System.bool value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Enable user to switch chart to Series Doughnut types.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Options")]
public:
property System.bool Enabled {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartDoughnutTypeSettings Class
ChartDoughnutTypeSettings Members


EnableDoughnutType Property

[image]
Intersoft WebGrid Documentation
EnableDoughnutType Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartDoughnutTypeSettings Class : EnableDoughnutType Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Options")>
<System.ComponentModel.DescriptionAttribute("Enable user to switch chart to Doughnut type.")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property EnableDoughnutType As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As ChartDoughnutTypeSettings
Dim value As System.Boolean

instance.EnableDoughnutType = value

value = instance.EnableDoughnutType
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Options")]
[System.ComponentModel.DescriptionAttribute("Enable user to switch chart to Doughnut type.")]
[System.ComponentModel.DefaultValueAttribute()]
public System.bool EnableDoughnutType {get; set;}
Delphi
public read-write property EnableDoughnutType: System.Boolean;
JScript
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Options")
System.ComponentModel.DescriptionAttribute("Enable user to switch chart to Doughnut type.")
System.ComponentModel.DefaultValueAttribute()
public function get,set EnableDoughnutType : System.boolean
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Options")]
[System.ComponentModel.DescriptionAttribute("Enable user to switch chart to Doughnut type.")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.bool get_EnableDoughnutType();
public: __property void set_EnableDoughnutType(
   System.bool value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Options")]
[System.ComponentModel.DescriptionAttribute("Enable user to switch chart to Doughnut type.")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.bool EnableDoughnutType {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartDoughnutTypeSettings Class
ChartDoughnutTypeSettings Members


EnableExploded3DDoughnutType Property

[image]
Intersoft WebGrid Documentation
EnableExploded3DDoughnutType Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartDoughnutTypeSettings Class : EnableExploded3DDoughnutType Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Enable user to switch chart to Exploded 3D Doughnut type.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Options")>
Public Property EnableExploded3DDoughnutType As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As ChartDoughnutTypeSettings
Dim value As System.Boolean

instance.EnableExploded3DDoughnutType = value

value = instance.EnableExploded3DDoughnutType
C#
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Enable user to switch chart to Exploded 3D Doughnut type.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Options")]
public System.bool EnableExploded3DDoughnutType {get; set;}
Delphi
public read-write property EnableExploded3DDoughnutType: System.Boolean;
JScript
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Enable user to switch chart to Exploded 3D Doughnut type.")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Options")
public function get,set EnableExploded3DDoughnutType : System.boolean
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Enable user to switch chart to Exploded 3D Doughnut type.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Options")]
public: __property System.bool get_EnableExploded3DDoughnutType();
public: __property void set_EnableExploded3DDoughnutType(
   System.bool value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Enable user to switch chart to Exploded 3D Doughnut type.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Options")]
public:
property System.bool EnableExploded3DDoughnutType {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartDoughnutTypeSettings Class
ChartDoughnutTypeSettings Members


EnableExplodedDoughnutType Property

[image]
Intersoft WebGrid Documentation
EnableExplodedDoughnutType Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartDoughnutTypeSettings Class : EnableExplodedDoughnutType Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Options")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Enable user to switch chart to Exploded Doughnut type.")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property EnableExplodedDoughnutType As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As ChartDoughnutTypeSettings
Dim value As System.Boolean

instance.EnableExplodedDoughnutType = value

value = instance.EnableExplodedDoughnutType
C#
[System.ComponentModel.CategoryAttribute("Options")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Enable user to switch chart to Exploded Doughnut type.")]
[System.ComponentModel.DefaultValueAttribute()]
public System.bool EnableExplodedDoughnutType {get; set;}
Delphi
public read-write property EnableExplodedDoughnutType: System.Boolean;
JScript
System.ComponentModel.CategoryAttribute("Options")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Enable user to switch chart to Exploded Doughnut type.")
System.ComponentModel.DefaultValueAttribute()
public function get,set EnableExplodedDoughnutType : System.boolean
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Options")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Enable user to switch chart to Exploded Doughnut type.")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.bool get_EnableExplodedDoughnutType();
public: __property void set_EnableExplodedDoughnutType(
   System.bool value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Options")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Enable user to switch chart to Exploded Doughnut type.")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.bool EnableExplodedDoughnutType {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartDoughnutTypeSettings Class
ChartDoughnutTypeSettings Members


ChartEmptyDataPointsStyle Class

[image]
Intersoft WebGrid Documentation
ChartEmptyDataPointsStyle Class
Members See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartEmptyDataPointsStyle Class

Glossary Item Box

Object Model

ChartEmptyDataPointsStyle Class

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.SerializableAttribute()>
Public Class ChartEmptyDataPointsStyle
   Inherits ISNet.WebUI.WebUIBaseClass
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Visual Basic (Usage) Copy Code
Dim instance As ChartEmptyDataPointsStyle
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public class ChartEmptyDataPointsStyle : ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Delphi
public class ChartEmptyDataPointsStyle = class(ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize)
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.SerializableAttribute()
public class ChartEmptyDataPointsStyle extends ISNet.WebUI.WebUIBaseClass implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public __gc class ChartEmptyDataPointsStyle : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public ref class ChartEmptyDataPointsStyle : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.WebGrid.Chart.ChartEmptyDataPointsStyle

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartEmptyDataPointsStyle Members
ISNet.WebUI.WebGrid.Chart Namespace


ChartEmptyDataPointsStyle Class Members

[image]
Intersoft WebGrid Documentation
ChartEmptyDataPointsStyle Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartEmptyDataPointsStyle Class

Glossary Item Box

The following tables list the members exposed by ChartEmptyDataPointsStyle.

Public Constructors

 | Name | Description
Public Constructor | ChartEmptyDataPointsStyle Constructor |
Top

Public Properties

 | Name | Description
Public Property | AppearanceMode |
Public Property | BorderStyle |
Public Property | FillStyle |
Public Property | MarkerMode |
Public Property | ShowLabels |
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

ChartEmptyDataPointsStyle Class
ISNet.WebUI.WebGrid.Chart Namespace


ChartEmptyDataPointsStyle Constructor

[image]
Intersoft WebGrid Documentation
ChartEmptyDataPointsStyle Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartEmptyDataPointsStyle Class : ChartEmptyDataPointsStyle Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New ChartEmptyDataPointsStyle()
C#
public ChartEmptyDataPointsStyle()
Delphi
public ChartEmptyDataPointsStyle();
JScript
public function ChartEmptyDataPointsStyle();
Managed Extensions for C++
public: ChartEmptyDataPointsStyle();
C++/CLI
public:
ChartEmptyDataPointsStyle();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartEmptyDataPointsStyle Class
ChartEmptyDataPointsStyle Members


Clone Method

[image]
Intersoft WebGrid Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartEmptyDataPointsStyle Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As System.Object
Visual Basic (Usage) Copy Code
Dim instance As ChartEmptyDataPointsStyle
Dim value As System.Object

value = instance.Clone()
C#
public virtual System.object Clone()
Delphi
public function Clone(): System.TObject; virtual;
JScript
public function Clone() : System.Object;
Managed Extensions for C++
public: virtual System.Object* Clone();
C++/CLI
public:
virtual System.Object^ Clone();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartEmptyDataPointsStyle Class
ChartEmptyDataPointsStyle Members


CopyFrom Method

[image]
Intersoft WebGrid Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartEmptyDataPointsStyle Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartEmptyDataPointsStyle Class
ChartEmptyDataPointsStyle Members


CopyFrom(Object) Method

[image]
Intersoft WebGrid Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartEmptyDataPointsStyle Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartEmptyDataPointsStyle
Dim objSource As System.Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   System.object objSource
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartEmptyDataPointsStyle Class
ChartEmptyDataPointsStyle Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebGrid Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartEmptyDataPointsStyle Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object, _
   ByVal cloneSourceValue As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartEmptyDataPointsStyle
Dim objSource As System.Object
Dim cloneSourceValue As System.Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   System.object objSource,
   System.bool cloneSourceValue
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject;
    cloneSourceValue: System.Boolean
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object,
   cloneSourceValue : System.boolean
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource,
   System.bool cloneSourceValue
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource,
   System.bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartEmptyDataPointsStyle Class
ChartEmptyDataPointsStyle Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebGrid Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartEmptyDataPointsStyle Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartEmptyDataPointsStyle
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure DeSerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function DeSerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void DeSerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void DeSerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartEmptyDataPointsStyle Class
ChartEmptyDataPointsStyle Members


GetHashCode Method

[image]
Intersoft WebGrid Documentation
GetHashCode Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartEmptyDataPointsStyle Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As ChartEmptyDataPointsStyle
Dim value As System.Integer

value = instance.GetHashCode()
C#
public virtual System.int GetHashCode()
Delphi
public function GetHashCode(): System.Integer; virtual;
JScript
public function GetHashCode() : System.int;
Managed Extensions for C++
public: virtual System.int GetHashCode();
C++/CLI
public:
virtual System.int GetHashCode();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartEmptyDataPointsStyle Class
ChartEmptyDataPointsStyle Members


ChartEmptyDataPointsStyle Class Methods

[image]
Intersoft WebGrid Documentation
ChartEmptyDataPointsStyle Class Methods
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartEmptyDataPointsStyle Class

Glossary Item Box

For a list of all members of this type, see ChartEmptyDataPointsStyle members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

ChartEmptyDataPointsStyle Class
ISNet.WebUI.WebGrid.Chart Namespace


GetObjectData Method

[image]
Intersoft WebGrid Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartEmptyDataPointsStyle Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=False,
   UnmanagedCode=False,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=True,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Action=SecurityAction.Demand,
   Unrestricted=False)>
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartEmptyDataPointsStyle
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure GetObjectData(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
); override;
JScript
System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=,
   UnmanagedCode=,
   SkipVerification=,
   Execution=,
   ControlThread=,
   ControlEvidence=,
   ControlPolicy=,
   SerializationFormatter=,
   ControlDomainPolicy=,
   ControlPrincipal=,
   ControlAppDomain=,
   RemotingConfiguration=,
   Infrastructure=,
   BindingRedirects=,
   Action=SecurityAction.Demand,
   Unrestricted=)
public override function GetObjectData(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public: void GetObjectData(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
) override
C++/CLI
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public:
void GetObjectData(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
) override

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartEmptyDataPointsStyle Class
ChartEmptyDataPointsStyle Members


IsEmpty Method

[image]
Intersoft WebGrid Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartEmptyDataPointsStyle Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As ChartEmptyDataPointsStyle
Dim value As System.Boolean

value = instance.IsEmpty()
C#
public virtual System.bool IsEmpty()
Delphi
public function IsEmpty(): System.Boolean; virtual;
JScript
public function IsEmpty() : System.boolean;
Managed Extensions for C++
public: virtual System.bool IsEmpty();
C++/CLI
public:
virtual System.bool IsEmpty();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartEmptyDataPointsStyle Class
ChartEmptyDataPointsStyle Members


Reset Method

[image]
Intersoft WebGrid Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartEmptyDataPointsStyle Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As ChartEmptyDataPointsStyle

instance.Reset()
C#
public virtual void Reset()
Delphi
public procedure Reset(); virtual;
JScript
public function Reset();
Managed Extensions for C++
public: virtual void Reset();
C++/CLI
public:
virtual void Reset();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartEmptyDataPointsStyle Class
ChartEmptyDataPointsStyle Members


SerializeObjectData Method

[image]
Intersoft WebGrid Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartEmptyDataPointsStyle Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartEmptyDataPointsStyle
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure SerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function SerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void SerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void SerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartEmptyDataPointsStyle Class
ChartEmptyDataPointsStyle Members


ToString Method

[image]
Intersoft WebGrid Documentation
ToString Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartEmptyDataPointsStyle Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As System.String
Visual Basic (Usage) Copy Code
Dim instance As ChartEmptyDataPointsStyle
Dim value As System.String

value = instance.ToString()
C#
public virtual System.string ToString()
Delphi
public function ToString(): System.String; virtual;
JScript
public function ToString() : System.String;
Managed Extensions for C++
public: virtual System.string* ToString();
C++/CLI
public:
virtual System.String^ ToString();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartEmptyDataPointsStyle Class
ChartEmptyDataPointsStyle Members


ChartEmptyDataPointsStyle Class Properties

[image]
Intersoft WebGrid Documentation
ChartEmptyDataPointsStyle Class Properties
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartEmptyDataPointsStyle Class

Glossary Item Box

For a list of all members of this type, see ChartEmptyDataPointsStyle members.

Public Properties

 | Name | Description
Public Property | AppearanceMode |
Public Property | BorderStyle |
Public Property | FillStyle |
Public Property | MarkerMode |
Public Property | ShowLabels |
Top

See Also

Reference

ChartEmptyDataPointsStyle Class
ISNet.WebUI.WebGrid.Chart Namespace


ChartEmptyDataPointsStyle Constructor

[image]
Intersoft WebGrid Documentation
ChartEmptyDataPointsStyle Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartEmptyDataPointsStyle Class : ChartEmptyDataPointsStyle Constructor

Glossary Item Box

Overload List

Overload | Description
ChartEmptyDataPointsStyle Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartEmptyDataPointsStyle Class
ChartEmptyDataPointsStyle Members


AppearanceMode Property

[image]
Intersoft WebGrid Documentation
AppearanceMode Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartEmptyDataPointsStyle Class : AppearanceMode Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies the appearance mode for the empty data points")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Empty Data Points Appearance")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property AppearanceMode As EmptyDataPointsAppearanceMode
Visual Basic (Usage) Copy Code
Dim instance As ChartEmptyDataPointsStyle
Dim value As EmptyDataPointsAppearanceMode

instance.AppearanceMode = value

value = instance.AppearanceMode
C#
[System.ComponentModel.DescriptionAttribute("Specifies the appearance mode for the empty data points")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Empty Data Points Appearance")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public EmptyDataPointsAppearanceMode AppearanceMode {get; set;}
Delphi
public read-write property AppearanceMode: EmptyDataPointsAppearanceMode;
JScript
System.ComponentModel.DescriptionAttribute("Specifies the appearance mode for the empty data points")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Empty Data Points Appearance")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set AppearanceMode : EmptyDataPointsAppearanceMode
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies the appearance mode for the empty data points")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Empty Data Points Appearance")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property EmptyDataPointsAppearanceMode get_AppearanceMode();
public: __property void set_AppearanceMode(
   EmptyDataPointsAppearanceMode value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies the appearance mode for the empty data points")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Empty Data Points Appearance")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property EmptyDataPointsAppearanceMode AppearanceMode {
   EmptyDataPointsAppearanceMode get();
   void set (    EmptyDataPointsAppearanceMode value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartEmptyDataPointsStyle Class
ChartEmptyDataPointsStyle Members


BorderStyle Property

[image]
Intersoft WebGrid Documentation
BorderStyle Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartEmptyDataPointsStyle Class : BorderStyle Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Empty Data Points Appearance")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute("setBorderStyle")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Controls the stroke style of the empty data points when the AppearanceMode is set to Special.")>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
Public ReadOnly Property BorderStyle As ChartStrokeStyle
Visual Basic (Usage) Copy Code
Dim instance As ChartEmptyDataPointsStyle
Dim value As ChartStrokeStyle

value = instance.BorderStyle
C#
[System.ComponentModel.CategoryAttribute("Empty Data Points Appearance")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute("setBorderStyle")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Controls the stroke style of the empty data points when the AppearanceMode is set to Special.")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
public ChartStrokeStyle BorderStyle {get;}
Delphi
public read-only property BorderStyle: ChartStrokeStyle;
JScript
System.ComponentModel.CategoryAttribute("Empty Data Points Appearance")
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute("setBorderStyle")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Controls the stroke style of the empty data points when the AppearanceMode is set to Special.")
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
public function get BorderStyle : ChartStrokeStyle
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Empty Data Points Appearance")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute("setBorderStyle")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Controls the stroke style of the empty data points when the AppearanceMode is set to Special.")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
public: __property ChartStrokeStyle* get_BorderStyle();
C++/CLI
[System.ComponentModel.CategoryAttribute("Empty Data Points Appearance")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute("setBorderStyle")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Controls the stroke style of the empty data points when the AppearanceMode is set to Special.")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
public:
property ChartStrokeStyle^ BorderStyle {
   ChartStrokeStyle^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartEmptyDataPointsStyle Class
ChartEmptyDataPointsStyle Members


FillStyle Property

[image]
Intersoft WebGrid Documentation
FillStyle Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartEmptyDataPointsStyle Class : FillStyle Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Empty Data Points Appearance")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute("setFillStyle")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<System.ComponentModel.DescriptionAttribute("Controls the fill style applied to the empty data points when the Mode is set to ")>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
Public ReadOnly Property FillStyle As ChartFillStyle
Visual Basic (Usage) Copy Code
Dim instance As ChartEmptyDataPointsStyle
Dim value As ChartFillStyle

value = instance.FillStyle
C#
[System.ComponentModel.CategoryAttribute("Empty Data Points Appearance")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute("setFillStyle")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DescriptionAttribute("Controls the fill style applied to the empty data points when the Mode is set to ")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
public ChartFillStyle FillStyle {get;}
Delphi
public read-only property FillStyle: ChartFillStyle;
JScript
System.ComponentModel.CategoryAttribute("Empty Data Points Appearance")
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute("setFillStyle")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
System.ComponentModel.DescriptionAttribute("Controls the fill style applied to the empty data points when the Mode is set to ")
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
public function get FillStyle : ChartFillStyle
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Empty Data Points Appearance")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute("setFillStyle")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DescriptionAttribute("Controls the fill style applied to the empty data points when the Mode is set to ")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
public: __property ChartFillStyle* get_FillStyle();
C++/CLI
[System.ComponentModel.CategoryAttribute("Empty Data Points Appearance")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute("setFillStyle")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DescriptionAttribute("Controls the fill style applied to the empty data points when the Mode is set to ")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
public:
property ChartFillStyle^ FillStyle {
   ChartFillStyle^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartEmptyDataPointsStyle Class
ChartEmptyDataPointsStyle Members


MarkerMode Property

[image]
Intersoft WebGrid Documentation
MarkerMode Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartEmptyDataPointsStyle Class : MarkerMode Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies the marker mode for empty data points")>
<System.ComponentModel.CategoryAttribute("Empty Data Points Appearance")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property MarkerMode As EmptyDataPointsMarkerMode
Visual Basic (Usage) Copy Code
Dim instance As ChartEmptyDataPointsStyle
Dim value As EmptyDataPointsMarkerMode

instance.MarkerMode = value

value = instance.MarkerMode
C#
[System.ComponentModel.DescriptionAttribute("Specifies the marker mode for empty data points")]
[System.ComponentModel.CategoryAttribute("Empty Data Points Appearance")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public EmptyDataPointsMarkerMode MarkerMode {get; set;}
Delphi
public read-write property MarkerMode: EmptyDataPointsMarkerMode;
JScript
System.ComponentModel.DescriptionAttribute("Specifies the marker mode for empty data points")
System.ComponentModel.CategoryAttribute("Empty Data Points Appearance")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set MarkerMode : EmptyDataPointsMarkerMode
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies the marker mode for empty data points")]
[System.ComponentModel.CategoryAttribute("Empty Data Points Appearance")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property EmptyDataPointsMarkerMode get_MarkerMode();
public: __property void set_MarkerMode(
   EmptyDataPointsMarkerMode value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies the marker mode for empty data points")]
[System.ComponentModel.CategoryAttribute("Empty Data Points Appearance")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property EmptyDataPointsMarkerMode MarkerMode {
   EmptyDataPointsMarkerMode get();
   void set (    EmptyDataPointsMarkerMode value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartEmptyDataPointsStyle Class
ChartEmptyDataPointsStyle Members


ShowLabels Property

[image]
Intersoft WebGrid Documentation
ShowLabels Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartEmptyDataPointsStyle Class : ShowLabels Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Enables or disables data labels for empty data points")>
<System.ComponentModel.CategoryAttribute("Empty Data Points Appearance")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
Public Property ShowLabels As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As ChartEmptyDataPointsStyle
Dim value As System.Boolean

instance.ShowLabels = value

value = instance.ShowLabels
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Enables or disables data labels for empty data points")]
[System.ComponentModel.CategoryAttribute("Empty Data Points Appearance")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public System.bool ShowLabels {get; set;}
Delphi
public read-write property ShowLabels: System.Boolean;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DescriptionAttribute("Enables or disables data labels for empty data points")
System.ComponentModel.CategoryAttribute("Empty Data Points Appearance")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
public function get,set ShowLabels : System.boolean
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Enables or disables data labels for empty data points")]
[System.ComponentModel.CategoryAttribute("Empty Data Points Appearance")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.bool get_ShowLabels();
public: __property void set_ShowLabels(
   System.bool value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Enables or disables data labels for empty data points")]
[System.ComponentModel.CategoryAttribute("Empty Data Points Appearance")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.bool ShowLabels {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartEmptyDataPointsStyle Class
ChartEmptyDataPointsStyle Members


ChartFilterDataSettings Class

[image]
Intersoft WebGrid Documentation
ChartFilterDataSettings Class
Members See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartFilterDataSettings Class

Glossary Item Box

Object Model

ChartFilterDataSettings Class

Syntax

Visual Basic (Declaration)
Public Class ChartFilterDataSettings
Visual Basic (Usage) Copy Code
Dim instance As ChartFilterDataSettings
C#
public class ChartFilterDataSettings
Delphi
public class ChartFilterDataSettings
JScript
public class ChartFilterDataSettings
Managed Extensions for C++
public __gc class ChartFilterDataSettings
C++/CLI
public ref class ChartFilterDataSettings

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebGrid.Chart.ChartFilterDataSettings

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartFilterDataSettings Members
ISNet.WebUI.WebGrid.Chart Namespace


ChartFilterDataSettings Class Members

[image]
Intersoft WebGrid Documentation
ChartFilterDataSettings Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartFilterDataSettings Class

Glossary Item Box

The following tables list the members exposed by ChartFilterDataSettings.

Public Constructors

 | Name | Description
Public Constructor | ChartFilterDataSettings Constructor |
Top

Public Properties

 | Name | Description
Public Property | AggregateExpression |
Public Property | FilterExpression |
Top

Public Methods

 | Name | Description
Public Method | AppendFilterExpression |
Top

See Also

Reference

ChartFilterDataSettings Class
ISNet.WebUI.WebGrid.Chart Namespace


ChartFilterDataSettings Constructor

[image]
Intersoft WebGrid Documentation
ChartFilterDataSettings Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartFilterDataSettings Class : ChartFilterDataSettings Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New ChartFilterDataSettings()
C#
public ChartFilterDataSettings()
Delphi
public ChartFilterDataSettings();
JScript
public function ChartFilterDataSettings();
Managed Extensions for C++
public: ChartFilterDataSettings();
C++/CLI
public:
ChartFilterDataSettings();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartFilterDataSettings Class
ChartFilterDataSettings Members


ChartFilterDataSettings Class Methods

[image]
Intersoft WebGrid Documentation
ChartFilterDataSettings Class Methods
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartFilterDataSettings Class

Glossary Item Box

For a list of all members of this type, see ChartFilterDataSettings members.

Public Methods

 | Name | Description
Public Method | AppendFilterExpression |
Top

See Also

Reference

ChartFilterDataSettings Class
ISNet.WebUI.WebGrid.Chart Namespace


AppendFilterExpression Method

[image]
Intersoft WebGrid Documentation
AppendFilterExpression Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartFilterDataSettings Class : AppendFilterExpression Method

expression

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function AppendFilterExpression( _
   ByVal expression As System.String _
) As System.String
Visual Basic (Usage) Copy Code
Dim instance As ChartFilterDataSettings
Dim expression As System.String
Dim value As System.String

value = instance.AppendFilterExpression(expression)
C#
public System.string AppendFilterExpression(
   System.string expression
)
Delphi
public function AppendFilterExpression(
    expression: System.String
): System.String;
JScript
public function AppendFilterExpression(
   expression : System.String
) : System.String;
Managed Extensions for C++
public: System.string* AppendFilterExpression(
   System.string* expression
)
C++/CLI
public:
System.String^ AppendFilterExpression(
   System.String^ expression
)

Parameters

expression

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartFilterDataSettings Class
ChartFilterDataSettings Members


ChartFilterDataSettings Class Properties

[image]
Intersoft WebGrid Documentation
ChartFilterDataSettings Class Properties
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartFilterDataSettings Class

Glossary Item Box

For a list of all members of this type, see ChartFilterDataSettings members.

Public Properties

 | Name | Description
Public Property | AggregateExpression |
Public Property | FilterExpression |
Top

See Also

Reference

ChartFilterDataSettings Class
ISNet.WebUI.WebGrid.Chart Namespace


AggregateExpression Property

[image]
Intersoft WebGrid Documentation
AggregateExpression Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartFilterDataSettings Class : AggregateExpression Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property AggregateExpression As System.String
Visual Basic (Usage) Copy Code
Dim instance As ChartFilterDataSettings
Dim value As System.String

instance.AggregateExpression = value

value = instance.AggregateExpression
C#
public System.string AggregateExpression {get; set;}
Delphi
public read-write property AggregateExpression: System.String;
JScript
public function get,set AggregateExpression : System.String
Managed Extensions for C++
public: __property System.string* get_AggregateExpression();
public: __property void set_AggregateExpression(
   System.string* value
);
C++/CLI
public:
property System.String^ AggregateExpression {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartFilterDataSettings Class
ChartFilterDataSettings Members


FilterExpression Property

[image]
Intersoft WebGrid Documentation
FilterExpression Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartFilterDataSettings Class : FilterExpression Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property FilterExpression As System.String
Visual Basic (Usage) Copy Code
Dim instance As ChartFilterDataSettings
Dim value As System.String

instance.FilterExpression = value

value = instance.FilterExpression
C#
public System.string FilterExpression {get; set;}
Delphi
public read-write property FilterExpression: System.String;
JScript
public function get,set FilterExpression : System.String
Managed Extensions for C++
public: __property System.string* get_FilterExpression();
public: __property void set_FilterExpression(
   System.string* value
);
C++/CLI
public:
property System.String^ FilterExpression {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartFilterDataSettings Class
ChartFilterDataSettings Members


ChartFontStyle Class

[image]
Intersoft WebGrid Documentation
ChartFontStyle Class
Members See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartFontStyle Class

Glossary Item Box

Object Model

ChartFontStyle Class

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.SerializableAttribute()>
Public Class ChartFontStyle
   Inherits ISNet.WebUI.WebUIBaseClass
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Visual Basic (Usage) Copy Code
Dim instance As ChartFontStyle
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public class ChartFontStyle : ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Delphi
public class ChartFontStyle = class(ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize)
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.SerializableAttribute()
public class ChartFontStyle extends ISNet.WebUI.WebUIBaseClass implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public __gc class ChartFontStyle : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public ref class ChartFontStyle : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.WebGrid.Chart.ChartFontStyle

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartFontStyle Members
ISNet.WebUI.WebGrid.Chart Namespace


ChartFontStyle Class Members

[image]
Intersoft WebGrid Documentation
ChartFontStyle Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartFontStyle Class

Glossary Item Box

The following tables list the members exposed by ChartFontStyle.

Public Constructors

 | Name | Description
Public Constructor | ChartFontStyle Constructor |
Top

Public Properties

 | Name | Description
Public Property | EmSize |
Public Property | GdiCharSet |
Public Property | GdiVerticalFont |
Public Property | Name |
Public Property | Style |
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

ChartFontStyle Class
ISNet.WebUI.WebGrid.Chart Namespace


ChartFontStyle Constructor

[image]
Intersoft WebGrid Documentation
ChartFontStyle Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartFontStyle Class : ChartFontStyle Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New ChartFontStyle()
C#
public ChartFontStyle()
Delphi
public ChartFontStyle();
JScript
public function ChartFontStyle();
Managed Extensions for C++
public: ChartFontStyle();
C++/CLI
public:
ChartFontStyle();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartFontStyle Class
ChartFontStyle Members


Clone Method

[image]
Intersoft WebGrid Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartFontStyle Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As System.Object
Visual Basic (Usage) Copy Code
Dim instance As ChartFontStyle
Dim value As System.Object

value = instance.Clone()
C#
public virtual System.object Clone()
Delphi
public function Clone(): System.TObject; virtual;
JScript
public function Clone() : System.Object;
Managed Extensions for C++
public: virtual System.Object* Clone();
C++/CLI
public:
virtual System.Object^ Clone();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartFontStyle Class
ChartFontStyle Members


CopyFrom Method

[image]
Intersoft WebGrid Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartFontStyle Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartFontStyle Class
ChartFontStyle Members


CopyFrom(Object) Method

[image]
Intersoft WebGrid Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartFontStyle Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartFontStyle
Dim objSource As System.Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   System.object objSource
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartFontStyle Class
ChartFontStyle Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebGrid Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartFontStyle Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object, _
   ByVal cloneSourceValue As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartFontStyle
Dim objSource As System.Object
Dim cloneSourceValue As System.Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   System.object objSource,
   System.bool cloneSourceValue
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject;
    cloneSourceValue: System.Boolean
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object,
   cloneSourceValue : System.boolean
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource,
   System.bool cloneSourceValue
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource,
   System.bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartFontStyle Class
ChartFontStyle Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebGrid Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartFontStyle Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartFontStyle
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure DeSerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function DeSerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void DeSerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void DeSerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartFontStyle Class
ChartFontStyle Members


GetHashCode Method

[image]
Intersoft WebGrid Documentation
GetHashCode Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartFontStyle Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As ChartFontStyle
Dim value As System.Integer

value = instance.GetHashCode()
C#
public virtual System.int GetHashCode()
Delphi
public function GetHashCode(): System.Integer; virtual;
JScript
public function GetHashCode() : System.int;
Managed Extensions for C++
public: virtual System.int GetHashCode();
C++/CLI
public:
virtual System.int GetHashCode();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartFontStyle Class
ChartFontStyle Members


ChartFontStyle Class Methods

[image]
Intersoft WebGrid Documentation
ChartFontStyle Class Methods
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartFontStyle Class

Glossary Item Box

For a list of all members of this type, see ChartFontStyle members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

ChartFontStyle Class
ISNet.WebUI.WebGrid.Chart Namespace


GetObjectData Method

[image]
Intersoft WebGrid Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartFontStyle Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=False,
   UnmanagedCode=False,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=True,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Action=SecurityAction.Demand,
   Unrestricted=False)>
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartFontStyle
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure GetObjectData(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
); override;
JScript
System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=,
   UnmanagedCode=,
   SkipVerification=,
   Execution=,
   ControlThread=,
   ControlEvidence=,
   ControlPolicy=,
   SerializationFormatter=,
   ControlDomainPolicy=,
   ControlPrincipal=,
   ControlAppDomain=,
   RemotingConfiguration=,
   Infrastructure=,
   BindingRedirects=,
   Action=SecurityAction.Demand,
   Unrestricted=)
public override function GetObjectData(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public: void GetObjectData(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
) override
C++/CLI
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public:
void GetObjectData(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
) override

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartFontStyle Class
ChartFontStyle Members


IsEmpty Method

[image]
Intersoft WebGrid Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartFontStyle Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As ChartFontStyle
Dim value As System.Boolean

value = instance.IsEmpty()
C#
public virtual System.bool IsEmpty()
Delphi
public function IsEmpty(): System.Boolean; virtual;
JScript
public function IsEmpty() : System.boolean;
Managed Extensions for C++
public: virtual System.bool IsEmpty();
C++/CLI
public:
virtual System.bool IsEmpty();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartFontStyle Class
ChartFontStyle Members


Reset Method

[image]
Intersoft WebGrid Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartFontStyle Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As ChartFontStyle

instance.Reset()
C#
public virtual void Reset()
Delphi
public procedure Reset(); virtual;
JScript
public function Reset();
Managed Extensions for C++
public: virtual void Reset();
C++/CLI
public:
virtual void Reset();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartFontStyle Class
ChartFontStyle Members


SerializeObjectData Method

[image]
Intersoft WebGrid Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartFontStyle Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartFontStyle
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure SerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function SerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void SerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void SerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartFontStyle Class
ChartFontStyle Members


ToString Method

[image]
Intersoft WebGrid Documentation
ToString Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartFontStyle Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As System.String
Visual Basic (Usage) Copy Code
Dim instance As ChartFontStyle
Dim value As System.String

value = instance.ToString()
C#
public virtual System.string ToString()
Delphi
public function ToString(): System.String; virtual;
JScript
public function ToString() : System.String;
Managed Extensions for C++
public: virtual System.string* ToString();
C++/CLI
public:
virtual System.String^ ToString();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartFontStyle Class
ChartFontStyle Members


ChartFontStyle Class Properties

[image]
Intersoft WebGrid Documentation
ChartFontStyle Class Properties
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartFontStyle Class

Glossary Item Box

For a list of all members of this type, see ChartFontStyle members.

Public Properties

 | Name | Description
Public Property | EmSize |
Public Property | GdiCharSet |
Public Property | GdiVerticalFont |
Public Property | Name |
Public Property | Style |
Top

See Also

Reference

ChartFontStyle Class
ISNet.WebUI.WebGrid.Chart Namespace


ChartFontStyle Constructor

[image]
Intersoft WebGrid Documentation
ChartFontStyle Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartFontStyle Class : ChartFontStyle Constructor

Glossary Item Box

Overload List

Overload | Description
ChartFontStyle Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartFontStyle Class
ChartFontStyle Members


EmSize Property

[image]
Intersoft WebGrid Documentation
EmSize Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartFontStyle Class : EmSize Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Controls the name of the text font.")>
<System.ComponentModel.CategoryAttribute("Font")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property EmSize As System.Nullable(Of Single)
Visual Basic (Usage) Copy Code
Dim instance As ChartFontStyle
Dim value As System.Nullable(Of Single)

instance.EmSize = value

value = instance.EmSize
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Controls the name of the text font.")]
[System.ComponentModel.CategoryAttribute("Font")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.Nullable<float> EmSize {get; set;}
Delphi
public read-write property EmSize: System.Nullable;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Controls the name of the text font.")
System.ComponentModel.CategoryAttribute("Font")
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set EmSize : System.Nullable
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Controls the name of the text font.")]
[System.ComponentModel.CategoryAttribute("Font")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.Nullable<float> get_EmSize();
public: __property void set_EmSize(
   System.Nullable<float> value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Controls the name of the text font.")]
[System.ComponentModel.CategoryAttribute("Font")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.Nullable<float> EmSize {
   System.Nullable<float> get();
   void set (    System.Nullable<float> value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartFontStyle Class
ChartFontStyle Members


GdiCharSet Property

[image]
Intersoft WebGrid Documentation
GdiCharSet Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartFontStyle Class : GdiCharSet Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Font")>
<System.ComponentModel.DescriptionAttribute("Controls the font GDI char set.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
Public Property GdiCharSet As System.Byte
Visual Basic (Usage) Copy Code
Dim instance As ChartFontStyle
Dim value As System.Byte

instance.GdiCharSet = value

value = instance.GdiCharSet
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Font")]
[System.ComponentModel.DescriptionAttribute("Controls the font GDI char set.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public System.byte GdiCharSet {get; set;}
Delphi
public read-write property GdiCharSet: System.Byte;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Font")
System.ComponentModel.DescriptionAttribute("Controls the font GDI char set.")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
public function get,set GdiCharSet : System.byte
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Font")]
[System.ComponentModel.DescriptionAttribute("Controls the font GDI char set.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.byte get_GdiCharSet();
public: __property void set_GdiCharSet(
   System.byte value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Font")]
[System.ComponentModel.DescriptionAttribute("Controls the font GDI char set.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.byte GdiCharSet {
   System.byte get();
   void set (    System.byte value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartFontStyle Class
ChartFontStyle Members


GdiVerticalFont Property

[image]
Intersoft WebGrid Documentation
GdiVerticalFont Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartFontStyle Class : GdiVerticalFont Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Indicates whether this Font object is derived from a GDI vertical font.")>
<System.ComponentModel.CategoryAttribute("Font")>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property GdiVerticalFont As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As ChartFontStyle
Dim value As System.Boolean

instance.GdiVerticalFont = value

value = instance.GdiVerticalFont
C#
[System.ComponentModel.DescriptionAttribute("Indicates whether this Font object is derived from a GDI vertical font.")]
[System.ComponentModel.CategoryAttribute("Font")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.bool GdiVerticalFont {get; set;}
Delphi
public read-write property GdiVerticalFont: System.Boolean;
JScript
System.ComponentModel.DescriptionAttribute("Indicates whether this Font object is derived from a GDI vertical font.")
System.ComponentModel.CategoryAttribute("Font")
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set GdiVerticalFont : System.boolean
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Indicates whether this Font object is derived from a GDI vertical font.")]
[System.ComponentModel.CategoryAttribute("Font")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.bool get_GdiVerticalFont();
public: __property void set_GdiVerticalFont(
   System.bool value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Indicates whether this Font object is derived from a GDI vertical font.")]
[System.ComponentModel.CategoryAttribute("Font")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.bool GdiVerticalFont {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartFontStyle Class
ChartFontStyle Members


Name Property

[image]
Intersoft WebGrid Documentation
Name Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartFontStyle Class : Name Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.TypeConverterAttribute("System.Drawing.FontConverter+FontNameConverter, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")>
<System.ComponentModel.CategoryAttribute("Font")>
<System.ComponentModel.DescriptionAttribute("Controls the name of the text font.")>
Public Property Name As System.String
Visual Basic (Usage) Copy Code
Dim instance As ChartFontStyle
Dim value As System.String

instance.Name = value

value = instance.Name
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.TypeConverterAttribute("System.Drawing.FontConverter+FontNameConverter, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[System.ComponentModel.CategoryAttribute("Font")]
[System.ComponentModel.DescriptionAttribute("Controls the name of the text font.")]
public System.string Name {get; set;}
Delphi
public read-write property Name: System.String;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.TypeConverterAttribute("System.Drawing.FontConverter+FontNameConverter, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")
System.ComponentModel.CategoryAttribute("Font")
System.ComponentModel.DescriptionAttribute("Controls the name of the text font.")
public function get,set Name : System.String
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.TypeConverterAttribute("System.Drawing.FontConverter+FontNameConverter, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[System.ComponentModel.CategoryAttribute("Font")]
[System.ComponentModel.DescriptionAttribute("Controls the name of the text font.")]
public: __property System.string* get_Name();
public: __property void set_Name(
   System.string* value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.TypeConverterAttribute("System.Drawing.FontConverter+FontNameConverter, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[System.ComponentModel.CategoryAttribute("Font")]
[System.ComponentModel.DescriptionAttribute("Controls the name of the text font.")]
public:
property System.String^ Name {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartFontStyle Class
ChartFontStyle Members


Style Property

[image]
Intersoft WebGrid Documentation
Style Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartFontStyle Class : Style Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Controls the style of the font.")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("Font")>
Public Property Style As System.Drawing.FontStyle
Visual Basic (Usage) Copy Code
Dim instance As ChartFontStyle
Dim value As System.Drawing.FontStyle

instance.Style = value

value = instance.Style
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Controls the style of the font.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Font")]
public System.Drawing.FontStyle Style {get; set;}
Delphi
public read-write property Style: System.Drawing.FontStyle;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Controls the style of the font.")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("Font")
public function get,set Style : System.Drawing.FontStyle
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Controls the style of the font.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Font")]
public: __property System.Drawing.FontStyle get_Style();
public: __property void set_Style(
   System.Drawing.FontStyle value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Controls the style of the font.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Font")]
public:
property System.Drawing.FontStyle Style {
   System.Drawing.FontStyle get();
   void set (    System.Drawing.FontStyle value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartFontStyle Class
ChartFontStyle Members


ChartFrameStyle Class

[image]
Intersoft WebGrid Documentation
ChartFrameStyle Class
Members See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartFrameStyle Class

Glossary Item Box

Object Model

ChartFrameStyle Class

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.SerializableAttribute()>
Public Class ChartFrameStyle
   Inherits ISNet.WebUI.WebUIBaseClass
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Visual Basic (Usage) Copy Code
Dim instance As ChartFrameStyle
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public class ChartFrameStyle : ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Delphi
public class ChartFrameStyle = class(ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize)
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.SerializableAttribute()
public class ChartFrameStyle extends ISNet.WebUI.WebUIBaseClass implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public __gc class ChartFrameStyle : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public ref class ChartFrameStyle : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.WebGrid.Chart.ChartFrameStyle

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartFrameStyle Members
ISNet.WebUI.WebGrid.Chart Namespace


ChartFrameStyle Class Members

[image]
Intersoft WebGrid Documentation
ChartFrameStyle Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartFrameStyle Class

Glossary Item Box

The following tables list the members exposed by ChartFrameStyle.

Public Constructors

 | Name | Description
Public Constructor | ChartFrameStyle Constructor |
Top

Public Properties

 | Name | Description
Public Property | ChartFrameType |
Public Property | ImageFrameStyle |
Public Property | StandardFrameStyle |
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

ChartFrameStyle Class
ISNet.WebUI.WebGrid.Chart Namespace


ChartFrameStyle Constructor

[image]
Intersoft WebGrid Documentation
ChartFrameStyle Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartFrameStyle Class : ChartFrameStyle Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New ChartFrameStyle()
C#
public ChartFrameStyle()
Delphi
public ChartFrameStyle();
JScript
public function ChartFrameStyle();
Managed Extensions for C++
public: ChartFrameStyle();
C++/CLI
public:
ChartFrameStyle();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartFrameStyle Class
ChartFrameStyle Members


Clone Method

[image]
Intersoft WebGrid Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartFrameStyle Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As System.Object
Visual Basic (Usage) Copy Code
Dim instance As ChartFrameStyle
Dim value As System.Object

value = instance.Clone()
C#
public virtual System.object Clone()
Delphi
public function Clone(): System.TObject; virtual;
JScript
public function Clone() : System.Object;
Managed Extensions for C++
public: virtual System.Object* Clone();
C++/CLI
public:
virtual System.Object^ Clone();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartFrameStyle Class
ChartFrameStyle Members


CopyFrom Method

[image]
Intersoft WebGrid Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartFrameStyle Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartFrameStyle Class
ChartFrameStyle Members


CopyFrom(Object) Method

[image]
Intersoft WebGrid Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartFrameStyle Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartFrameStyle
Dim objSource As System.Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   System.object objSource
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartFrameStyle Class
ChartFrameStyle Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebGrid Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartFrameStyle Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object, _
   ByVal cloneSourceValue As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartFrameStyle
Dim objSource As System.Object
Dim cloneSourceValue As System.Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   System.object objSource,
   System.bool cloneSourceValue
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject;
    cloneSourceValue: System.Boolean
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object,
   cloneSourceValue : System.boolean
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource,
   System.bool cloneSourceValue
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource,
   System.bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartFrameStyle Class
ChartFrameStyle Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebGrid Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartFrameStyle Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartFrameStyle
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure DeSerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function DeSerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void DeSerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void DeSerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartFrameStyle Class
ChartFrameStyle Members


GetHashCode Method

[image]
Intersoft WebGrid Documentation
GetHashCode Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartFrameStyle Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As ChartFrameStyle
Dim value As System.Integer

value = instance.GetHashCode()
C#
public virtual System.int GetHashCode()
Delphi
public function GetHashCode(): System.Integer; virtual;
JScript
public function GetHashCode() : System.int;
Managed Extensions for C++
public: virtual System.int GetHashCode();
C++/CLI
public:
virtual System.int GetHashCode();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartFrameStyle Class
ChartFrameStyle Members


ChartFrameStyle Class Methods

[image]
Intersoft WebGrid Documentation
ChartFrameStyle Class Methods
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartFrameStyle Class

Glossary Item Box

For a list of all members of this type, see ChartFrameStyle members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

ChartFrameStyle Class
ISNet.WebUI.WebGrid.Chart Namespace


GetObjectData Method

[image]
Intersoft WebGrid Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartFrameStyle Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=False,
   UnmanagedCode=False,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=True,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Action=SecurityAction.Demand,
   Unrestricted=False)>
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartFrameStyle
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure GetObjectData(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
); override;
JScript
System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=,
   UnmanagedCode=,
   SkipVerification=,
   Execution=,
   ControlThread=,
   ControlEvidence=,
   ControlPolicy=,
   SerializationFormatter=,
   ControlDomainPolicy=,
   ControlPrincipal=,
   ControlAppDomain=,
   RemotingConfiguration=,
   Infrastructure=,
   BindingRedirects=,
   Action=SecurityAction.Demand,
   Unrestricted=)
public override function GetObjectData(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public: void GetObjectData(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
) override
C++/CLI
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public:
void GetObjectData(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
) override

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartFrameStyle Class
ChartFrameStyle Members


IsEmpty Method

[image]
Intersoft WebGrid Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartFrameStyle Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As ChartFrameStyle
Dim value As System.Boolean

value = instance.IsEmpty()
C#
public virtual System.bool IsEmpty()
Delphi
public function IsEmpty(): System.Boolean; virtual;
JScript
public function IsEmpty() : System.boolean;
Managed Extensions for C++
public: virtual System.bool IsEmpty();
C++/CLI
public:
virtual System.bool IsEmpty();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartFrameStyle Class
ChartFrameStyle Members


Reset Method

[image]
Intersoft WebGrid Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartFrameStyle Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As ChartFrameStyle

instance.Reset()
C#
public virtual void Reset()
Delphi
public procedure Reset(); virtual;
JScript
public function Reset();
Managed Extensions for C++
public: virtual void Reset();
C++/CLI
public:
virtual void Reset();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartFrameStyle Class
ChartFrameStyle Members


SerializeObjectData Method

[image]
Intersoft WebGrid Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartFrameStyle Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartFrameStyle
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure SerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function SerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void SerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void SerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartFrameStyle Class
ChartFrameStyle Members


ToString Method

[image]
Intersoft WebGrid Documentation
ToString Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartFrameStyle Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As System.String
Visual Basic (Usage) Copy Code
Dim instance As ChartFrameStyle
Dim value As System.String

value = instance.ToString()
C#
public virtual System.string ToString()
Delphi
public function ToString(): System.String; virtual;
JScript
public function ToString() : System.String;
Managed Extensions for C++
public: virtual System.string* ToString();
C++/CLI
public:
virtual System.String^ ToString();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartFrameStyle Class
ChartFrameStyle Members


ChartFrameStyle Class Properties

[image]
Intersoft WebGrid Documentation
ChartFrameStyle Class Properties
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartFrameStyle Class

Glossary Item Box

For a list of all members of this type, see ChartFrameStyle members.

Public Properties

 | Name | Description
Public Property | ChartFrameType |
Public Property | ImageFrameStyle |
Public Property | StandardFrameStyle |
Top

See Also

Reference

ChartFrameStyle Class
ISNet.WebUI.WebGrid.Chart Namespace


ChartFrameStyle Constructor

[image]
Intersoft WebGrid Documentation
ChartFrameStyle Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartFrameStyle Class : ChartFrameStyle Constructor

Glossary Item Box

Overload List

Overload | Description
ChartFrameStyle Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartFrameStyle Class
ChartFrameStyle Members


ChartFrameType Property

[image]
Intersoft WebGrid Documentation
ChartFrameType Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartFrameStyle Class : ChartFrameType Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("General")>
<System.ComponentModel.DescriptionAttribute("Defines the type of FrameStyle to be applied.")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property ChartFrameType As ChartFrameType
Visual Basic (Usage) Copy Code
Dim instance As ChartFrameStyle
Dim value As ChartFrameType

instance.ChartFrameType = value

value = instance.ChartFrameType
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DescriptionAttribute("Defines the type of FrameStyle to be applied.")]
[System.ComponentModel.DefaultValueAttribute()]
public ChartFrameType ChartFrameType {get; set;}
Delphi
public read-write property ChartFrameType: ChartFrameType;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("General")
System.ComponentModel.DescriptionAttribute("Defines the type of FrameStyle to be applied.")
System.ComponentModel.DefaultValueAttribute()
public function get,set ChartFrameType : ChartFrameType
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DescriptionAttribute("Defines the type of FrameStyle to be applied.")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property ChartFrameType get_ChartFrameType();
public: __property void set_ChartFrameType(
   ChartFrameType value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DescriptionAttribute("Defines the type of FrameStyle to be applied.")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property ChartFrameType ChartFrameType {
   ChartFrameType get();
   void set (    ChartFrameType value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartFrameStyle Class
ChartFrameStyle Members


ImageFrameStyle Property

[image]
Intersoft WebGrid Documentation
ImageFrameStyle Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartFrameStyle Class : ImageFrameStyle Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute("setImageFrameStyle")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<System.ComponentModel.DescriptionAttribute("Represents an vector image frame around an object.")>
<System.ComponentModel.CategoryAttribute("General")>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public ReadOnly Property ImageFrameStyle As ChartImageFrameStyle
Visual Basic (Usage) Copy Code
Dim instance As ChartFrameStyle
Dim value As ChartImageFrameStyle

value = instance.ImageFrameStyle
C#
[ISNet.Serialization.BinarySerializableAttribute("setImageFrameStyle")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DescriptionAttribute("Represents an vector image frame around an object.")]
[System.ComponentModel.CategoryAttribute("General")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public ChartImageFrameStyle ImageFrameStyle {get;}
Delphi
public read-only property ImageFrameStyle: ChartImageFrameStyle;
JScript
ISNet.Serialization.BinarySerializableAttribute("setImageFrameStyle")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
System.ComponentModel.DescriptionAttribute("Represents an vector image frame around an object.")
System.ComponentModel.CategoryAttribute("General")
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.NotifyParentPropertyAttribute()
public function get ImageFrameStyle : ChartImageFrameStyle
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute("setImageFrameStyle")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DescriptionAttribute("Represents an vector image frame around an object.")]
[System.ComponentModel.CategoryAttribute("General")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property ChartImageFrameStyle* get_ImageFrameStyle();
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute("setImageFrameStyle")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DescriptionAttribute("Represents an vector image frame around an object.")]
[System.ComponentModel.CategoryAttribute("General")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property ChartImageFrameStyle^ ImageFrameStyle {
   ChartImageFrameStyle^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartFrameStyle Class
ChartFrameStyle Members


StandardFrameStyle Property

[image]
Intersoft WebGrid Documentation
StandardFrameStyle Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartFrameStyle Class : StandardFrameStyle Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("General")>
<System.ComponentModel.DescriptionAttribute("Represents a rectangular frame around an object.")>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute("setStandardFrameStyle")>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
Public ReadOnly Property StandardFrameStyle As ChartStandardFrameStyle
Visual Basic (Usage) Copy Code
Dim instance As ChartFrameStyle
Dim value As ChartStandardFrameStyle

value = instance.StandardFrameStyle
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DescriptionAttribute("Represents a rectangular frame around an object.")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute("setStandardFrameStyle")]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
public ChartStandardFrameStyle StandardFrameStyle {get;}
Delphi
public read-only property StandardFrameStyle: ChartStandardFrameStyle;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("General")
System.ComponentModel.DescriptionAttribute("Represents a rectangular frame around an object.")
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute("setStandardFrameStyle")
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
public function get StandardFrameStyle : ChartStandardFrameStyle
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DescriptionAttribute("Represents a rectangular frame around an object.")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute("setStandardFrameStyle")]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
public: __property ChartStandardFrameStyle* get_StandardFrameStyle();
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DescriptionAttribute("Represents a rectangular frame around an object.")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute("setStandardFrameStyle")]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
public:
property ChartStandardFrameStyle^ StandardFrameStyle {
   ChartStandardFrameStyle^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartFrameStyle Class
ChartFrameStyle Members


ChartGlowImageFilterSettings Class

[image]
Intersoft WebGrid Documentation
ChartGlowImageFilterSettings Class
Members See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartGlowImageFilterSettings Class

Glossary Item Box

Object Model

ChartGlowImageFilterSettings Class

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.SerializableAttribute()>
Public Class ChartGlowImageFilterSettings
   Inherits ChartImageFilterSettings
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Visual Basic (Usage) Copy Code
Dim instance As ChartGlowImageFilterSettings
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public class ChartGlowImageFilterSettings : ChartImageFilterSettings, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Delphi
public class ChartGlowImageFilterSettings = class(ChartImageFilterSettings, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize)
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.SerializableAttribute()
public class ChartGlowImageFilterSettings extends ChartImageFilterSettings implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public __gc class ChartGlowImageFilterSettings : public ChartImageFilterSettings, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public ref class ChartGlowImageFilterSettings : public ChartImageFilterSettings, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.WebGrid.Chart.ChartImageFilterSettings
ISNet.WebUI.WebGrid.Chart.ChartGlowImageFilterSettings

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartGlowImageFilterSettings Members
ISNet.WebUI.WebGrid.Chart Namespace


ChartGlowImageFilterSettings Class Members

[image]
Intersoft WebGrid Documentation
ChartGlowImageFilterSettings Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartGlowImageFilterSettings Class

Glossary Item Box

The following tables list the members exposed by ChartGlowImageFilterSettings.

Public Constructors

 | Name | Description
Public Constructor | ChartGlowImageFilterSettings Constructor |
Top

Public Properties

 | Name | Description
Public Property | BlurType | (Inherited from ISNet.WebUI.WebGrid.Chart.ChartImageFilterSettings)
Public Property | Color |
Public Property | Depth |
Public Property | Enabled | (Inherited from ISNet.WebUI.WebGrid.Chart.ChartImageFilterSettings)
Public Property | GlowType |
Public Property | OriginalOpacity |
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

ChartGlowImageFilterSettings Class
ISNet.WebUI.WebGrid.Chart Namespace


ChartGlowImageFilterSettings Constructor

[image]
Intersoft WebGrid Documentation
ChartGlowImageFilterSettings Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartGlowImageFilterSettings Class : ChartGlowImageFilterSettings Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New ChartGlowImageFilterSettings()
C#
public ChartGlowImageFilterSettings()
Delphi
public ChartGlowImageFilterSettings();
JScript
public function ChartGlowImageFilterSettings();
Managed Extensions for C++
public: ChartGlowImageFilterSettings();
C++/CLI
public:
ChartGlowImageFilterSettings();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartGlowImageFilterSettings Class
ChartGlowImageFilterSettings Members


Clone Method

[image]
Intersoft WebGrid Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartGlowImageFilterSettings Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As System.Object
Visual Basic (Usage) Copy Code
Dim instance As ChartGlowImageFilterSettings
Dim value As System.Object

value = instance.Clone()
C#
public virtual System.object Clone()
Delphi
public function Clone(): System.TObject; virtual;
JScript
public function Clone() : System.Object;
Managed Extensions for C++
public: virtual System.Object* Clone();
C++/CLI
public:
virtual System.Object^ Clone();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartGlowImageFilterSettings Class
ChartGlowImageFilterSettings Members


CopyFrom Method

[image]
Intersoft WebGrid Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartGlowImageFilterSettings Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartGlowImageFilterSettings Class
ChartGlowImageFilterSettings Members


CopyFrom(Object) Method

[image]
Intersoft WebGrid Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartGlowImageFilterSettings Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartGlowImageFilterSettings
Dim objSource As System.Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   System.object objSource
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartGlowImageFilterSettings Class
ChartGlowImageFilterSettings Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebGrid Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartGlowImageFilterSettings Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object, _
   ByVal cloneSourceValue As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartGlowImageFilterSettings
Dim objSource As System.Object
Dim cloneSourceValue As System.Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   System.object objSource,
   System.bool cloneSourceValue
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject;
    cloneSourceValue: System.Boolean
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object,
   cloneSourceValue : System.boolean
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource,
   System.bool cloneSourceValue
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource,
   System.bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartGlowImageFilterSettings Class
ChartGlowImageFilterSettings Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebGrid Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartGlowImageFilterSettings Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartGlowImageFilterSettings
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure DeSerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function DeSerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void DeSerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void DeSerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartGlowImageFilterSettings Class
ChartGlowImageFilterSettings Members


GetHashCode Method

[image]
Intersoft WebGrid Documentation
GetHashCode Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartGlowImageFilterSettings Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As ChartGlowImageFilterSettings
Dim value As System.Integer

value = instance.GetHashCode()
C#
public virtual System.int GetHashCode()
Delphi
public function GetHashCode(): System.Integer; virtual;
JScript
public function GetHashCode() : System.int;
Managed Extensions for C++
public: virtual System.int GetHashCode();
C++/CLI
public:
virtual System.int GetHashCode();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartGlowImageFilterSettings Class
ChartGlowImageFilterSettings Members


ChartGlowImageFilterSettings Class Methods

[image]
Intersoft WebGrid Documentation
ChartGlowImageFilterSettings Class Methods
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartGlowImageFilterSettings Class

Glossary Item Box

For a list of all members of this type, see ChartGlowImageFilterSettings members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

ChartGlowImageFilterSettings Class
ISNet.WebUI.WebGrid.Chart Namespace


GetObjectData Method

[image]
Intersoft WebGrid Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartGlowImageFilterSettings Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=False,
   UnmanagedCode=False,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=True,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Action=SecurityAction.Demand,
   Unrestricted=False)>
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartGlowImageFilterSettings
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure GetObjectData(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
); override;
JScript
System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=,
   UnmanagedCode=,
   SkipVerification=,
   Execution=,
   ControlThread=,
   ControlEvidence=,
   ControlPolicy=,
   SerializationFormatter=,
   ControlDomainPolicy=,
   ControlPrincipal=,
   ControlAppDomain=,
   RemotingConfiguration=,
   Infrastructure=,
   BindingRedirects=,
   Action=SecurityAction.Demand,
   Unrestricted=)
public override function GetObjectData(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public: void GetObjectData(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
) override
C++/CLI
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public:
void GetObjectData(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
) override

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartGlowImageFilterSettings Class
ChartGlowImageFilterSettings Members


IsEmpty Method

[image]
Intersoft WebGrid Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartGlowImageFilterSettings Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As ChartGlowImageFilterSettings
Dim value As System.Boolean

value = instance.IsEmpty()
C#
public virtual System.bool IsEmpty()
Delphi
public function IsEmpty(): System.Boolean; virtual;
JScript
public function IsEmpty() : System.boolean;
Managed Extensions for C++
public: virtual System.bool IsEmpty();
C++/CLI
public:
virtual System.bool IsEmpty();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartGlowImageFilterSettings Class
ChartGlowImageFilterSettings Members


Reset Method

[image]
Intersoft WebGrid Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartGlowImageFilterSettings Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As ChartGlowImageFilterSettings

instance.Reset()
C#
public virtual void Reset()
Delphi
public procedure Reset(); virtual;
JScript
public function Reset();
Managed Extensions for C++
public: virtual void Reset();
C++/CLI
public:
virtual void Reset();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartGlowImageFilterSettings Class
ChartGlowImageFilterSettings Members


SerializeObjectData Method

[image]
Intersoft WebGrid Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartGlowImageFilterSettings Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartGlowImageFilterSettings
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure SerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function SerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void SerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void SerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartGlowImageFilterSettings Class
ChartGlowImageFilterSettings Members


ToString Method

[image]
Intersoft WebGrid Documentation
ToString Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartGlowImageFilterSettings Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As System.String
Visual Basic (Usage) Copy Code
Dim instance As ChartGlowImageFilterSettings
Dim value As System.String

value = instance.ToString()
C#
public virtual System.string ToString()
Delphi
public function ToString(): System.String; virtual;
JScript
public function ToString() : System.String;
Managed Extensions for C++
public: virtual System.string* ToString();
C++/CLI
public:
virtual System.String^ ToString();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartGlowImageFilterSettings Class
ChartGlowImageFilterSettings Members


ChartGlowImageFilterSettings Class Properties

[image]
Intersoft WebGrid Documentation
ChartGlowImageFilterSettings Class Properties
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartGlowImageFilterSettings Class

Glossary Item Box

For a list of all members of this type, see ChartGlowImageFilterSettings members.

Public Properties

 | Name | Description
Public Property | BlurType | (Inherited from ISNet.WebUI.WebGrid.Chart.ChartImageFilterSettings)
Public Property | Color |
Public Property | Depth |
Public Property | Enabled | (Inherited from ISNet.WebUI.WebGrid.Chart.ChartImageFilterSettings)
Public Property | GlowType |
Public Property | OriginalOpacity |
Top

See Also

Reference

ChartGlowImageFilterSettings Class
ISNet.WebUI.WebGrid.Chart Namespace


ChartGlowImageFilterSettings Constructor

[image]
Intersoft WebGrid Documentation
ChartGlowImageFilterSettings Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartGlowImageFilterSettings Class : ChartGlowImageFilterSettings Constructor

Glossary Item Box

Overload List

Overload | Description
ChartGlowImageFilterSettings Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartGlowImageFilterSettings Class
ChartGlowImageFilterSettings Members


Color Property

[image]
Intersoft WebGrid Documentation
Color Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartGlowImageFilterSettings Class : Color Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Appearance")>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("The color of the glow effect.")>
Public Property Color As System.Drawing.Color
Visual Basic (Usage) Copy Code
Dim instance As ChartGlowImageFilterSettings
Dim value As System.Drawing.Color

instance.Color = value

value = instance.Color
C#
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("The color of the glow effect.")]
public System.Drawing.Color Color {get; set;}
Delphi
public read-write property Color: System.Drawing.Color;
JScript
System.ComponentModel.CategoryAttribute("Appearance")
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("The color of the glow effect.")
public function get,set Color : System.Drawing.Color
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("The color of the glow effect.")]
public: __property System.Drawing.Color get_Color();
public: __property void set_Color(
   System.Drawing.Color value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("The color of the glow effect.")]
public:
property System.Drawing.Color Color {
   System.Drawing.Color get();
   void set (    System.Drawing.Color value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartGlowImageFilterSettings Class
ChartGlowImageFilterSettings Members


Depth Property

[image]
Intersoft WebGrid Documentation
Depth Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartGlowImageFilterSettings Class : Depth Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Appearance")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("The depth of the glow effect")>
Public Property Depth As System.Nullable(Of Single)
Visual Basic (Usage) Copy Code
Dim instance As ChartGlowImageFilterSettings
Dim value As System.Nullable(Of Single)

instance.Depth = value

value = instance.Depth
C#
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("The depth of the glow effect")]
public System.Nullable<float> Depth {get; set;}
Delphi
public read-write property Depth: System.Nullable;
JScript
System.ComponentModel.CategoryAttribute("Appearance")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DescriptionAttribute("The depth of the glow effect")
public function get,set Depth : System.Nullable
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("The depth of the glow effect")]
public: __property System.Nullable<float> get_Depth();
public: __property void set_Depth(
   System.Nullable<float> value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("The depth of the glow effect")]
public:
property System.Nullable<float> Depth {
   System.Nullable<float> get();
   void set (    System.Nullable<float> value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartGlowImageFilterSettings Class
ChartGlowImageFilterSettings Members


GlowType Property

[image]
Intersoft WebGrid Documentation
GlowType Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartGlowImageFilterSettings Class : GlowType Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("Appearance")>
<System.ComponentModel.DescriptionAttribute("The type of glow effect.")>
Public Property GlowType As GlowType
Visual Basic (Usage) Copy Code
Dim instance As ChartGlowImageFilterSettings
Dim value As GlowType

instance.GlowType = value

value = instance.GlowType
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.DescriptionAttribute("The type of glow effect.")]
public GlowType GlowType {get; set;}
Delphi
public read-write property GlowType: GlowType;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("Appearance")
System.ComponentModel.DescriptionAttribute("The type of glow effect.")
public function get,set GlowType : GlowType
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.DescriptionAttribute("The type of glow effect.")]
public: __property GlowType get_GlowType();
public: __property void set_GlowType(
   GlowType value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.DescriptionAttribute("The type of glow effect.")]
public:
property GlowType GlowType {
   GlowType get();
   void set (    GlowType value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartGlowImageFilterSettings Class
ChartGlowImageFilterSettings Members


OriginalOpacity Property

[image]
Intersoft WebGrid Documentation
OriginalOpacity Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartGlowImageFilterSettings Class : OriginalOpacity Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Appearance")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Fades out the original image leaving only the glow effect.")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property OriginalOpacity As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As ChartGlowImageFilterSettings
Dim value As System.Integer

instance.OriginalOpacity = value

value = instance.OriginalOpacity
C#
[System.ComponentModel.CategoryAttribute("Appearance")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Fades out the original image leaving only the glow effect.")]
[System.ComponentModel.DefaultValueAttribute()]
public System.int OriginalOpacity {get; set;}
Delphi
public read-write property OriginalOpacity: System.Integer;
JScript
System.ComponentModel.CategoryAttribute("Appearance")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Fades out the original image leaving only the glow effect.")
System.ComponentModel.DefaultValueAttribute()
public function get,set OriginalOpacity : System.int
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Appearance")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Fades out the original image leaving only the glow effect.")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.int get_OriginalOpacity();
public: __property void set_OriginalOpacity(
   System.int value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Appearance")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Fades out the original image leaving only the glow effect.")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.int OriginalOpacity {
   System.int get();
   void set (    System.int value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartGlowImageFilterSettings Class
ChartGlowImageFilterSettings Members


ChartGradientFillStyle Class

[image]
Intersoft WebGrid Documentation
ChartGradientFillStyle Class
Members See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartGradientFillStyle Class

Glossary Item Box

Object Model

ChartGradientFillStyle Class

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.SerializableAttribute()>
Public Class ChartGradientFillStyle
   Inherits ChartTextureFillStyle
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Visual Basic (Usage) Copy Code
Dim instance As ChartGradientFillStyle
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public class ChartGradientFillStyle : ChartTextureFillStyle, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Delphi
public class ChartGradientFillStyle = class(ChartTextureFillStyle, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize)
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.SerializableAttribute()
public class ChartGradientFillStyle extends ChartTextureFillStyle implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public __gc class ChartGradientFillStyle : public ChartTextureFillStyle, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public ref class ChartGradientFillStyle : public ChartTextureFillStyle, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.WebGrid.Chart.ChartTextureFillStyle
ISNet.WebUI.WebGrid.Chart.ChartGradientFillStyle

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartGradientFillStyle Members
ISNet.WebUI.WebGrid.Chart Namespace


ChartGradientFillStyle Class Members

[image]
Intersoft WebGrid Documentation
ChartGradientFillStyle Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartGradientFillStyle Class

Glossary Item Box

The following tables list the members exposed by ChartGradientFillStyle.

Public Constructors

 | Name | Description
Public Constructor | ChartGradientFillStyle Constructor |
Top

Public Properties

 | Name | Description
Public Property | BeginColor |
Public Property | EndColor |
Public Property | Style |
Public Property | TextureMappingStyle | (Inherited from ISNet.WebUI.WebGrid.Chart.ChartTextureFillStyle)
Public Property | TransparancyPercent | (Inherited from ISNet.WebUI.WebGrid.Chart.ChartTextureFillStyle)
Public Property | Variant |
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

ChartGradientFillStyle Class
ISNet.WebUI.WebGrid.Chart Namespace


ChartGradientFillStyle Constructor

[image]
Intersoft WebGrid Documentation
ChartGradientFillStyle Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartGradientFillStyle Class : ChartGradientFillStyle Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New ChartGradientFillStyle()
C#
public ChartGradientFillStyle()
Delphi
public ChartGradientFillStyle();
JScript
public function ChartGradientFillStyle();
Managed Extensions for C++
public: ChartGradientFillStyle();
C++/CLI
public:
ChartGradientFillStyle();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartGradientFillStyle Class
ChartGradientFillStyle Members


Clone Method

[image]
Intersoft WebGrid Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartGradientFillStyle Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As System.Object
Visual Basic (Usage) Copy Code
Dim instance As ChartGradientFillStyle
Dim value As System.Object

value = instance.Clone()
C#
public virtual System.object Clone()
Delphi
public function Clone(): System.TObject; virtual;
JScript
public function Clone() : System.Object;
Managed Extensions for C++
public: virtual System.Object* Clone();
C++/CLI
public:
virtual System.Object^ Clone();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartGradientFillStyle Class
ChartGradientFillStyle Members


CopyFrom Method

[image]
Intersoft WebGrid Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartGradientFillStyle Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartGradientFillStyle Class
ChartGradientFillStyle Members


CopyFrom(Object) Method

[image]
Intersoft WebGrid Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartGradientFillStyle Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartGradientFillStyle
Dim objSource As System.Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   System.object objSource
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartGradientFillStyle Class
ChartGradientFillStyle Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebGrid Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartGradientFillStyle Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object, _
   ByVal cloneSourceValue As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartGradientFillStyle
Dim objSource As System.Object
Dim cloneSourceValue As System.Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   System.object objSource,
   System.bool cloneSourceValue
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject;
    cloneSourceValue: System.Boolean
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object,
   cloneSourceValue : System.boolean
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource,
   System.bool cloneSourceValue
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource,
   System.bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartGradientFillStyle Class
ChartGradientFillStyle Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebGrid Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartGradientFillStyle Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartGradientFillStyle
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure DeSerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function DeSerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void DeSerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void DeSerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartGradientFillStyle Class
ChartGradientFillStyle Members


GetHashCode Method

[image]
Intersoft WebGrid Documentation
GetHashCode Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartGradientFillStyle Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As ChartGradientFillStyle
Dim value As System.Integer

value = instance.GetHashCode()
C#
public virtual System.int GetHashCode()
Delphi
public function GetHashCode(): System.Integer; virtual;
JScript
public function GetHashCode() : System.int;
Managed Extensions for C++
public: virtual System.int GetHashCode();
C++/CLI
public:
virtual System.int GetHashCode();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartGradientFillStyle Class
ChartGradientFillStyle Members


ChartGradientFillStyle Class Methods

[image]
Intersoft WebGrid Documentation
ChartGradientFillStyle Class Methods
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartGradientFillStyle Class

Glossary Item Box

For a list of all members of this type, see ChartGradientFillStyle members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

ChartGradientFillStyle Class
ISNet.WebUI.WebGrid.Chart Namespace


GetObjectData Method

[image]
Intersoft WebGrid Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartGradientFillStyle Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=False,
   UnmanagedCode=False,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=True,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Action=SecurityAction.Demand,
   Unrestricted=False)>
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartGradientFillStyle
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure GetObjectData(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
); override;
JScript
System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=,
   UnmanagedCode=,
   SkipVerification=,
   Execution=,
   ControlThread=,
   ControlEvidence=,
   ControlPolicy=,
   SerializationFormatter=,
   ControlDomainPolicy=,
   ControlPrincipal=,
   ControlAppDomain=,
   RemotingConfiguration=,
   Infrastructure=,
   BindingRedirects=,
   Action=SecurityAction.Demand,
   Unrestricted=)
public override function GetObjectData(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public: void GetObjectData(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
) override
C++/CLI
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public:
void GetObjectData(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
) override

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartGradientFillStyle Class
ChartGradientFillStyle Members


IsEmpty Method

[image]
Intersoft WebGrid Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartGradientFillStyle Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As ChartGradientFillStyle
Dim value As System.Boolean

value = instance.IsEmpty()
C#
public virtual System.bool IsEmpty()
Delphi
public function IsEmpty(): System.Boolean; virtual;
JScript
public function IsEmpty() : System.boolean;
Managed Extensions for C++
public: virtual System.bool IsEmpty();
C++/CLI
public:
virtual System.bool IsEmpty();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartGradientFillStyle Class
ChartGradientFillStyle Members


Reset Method

[image]
Intersoft WebGrid Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartGradientFillStyle Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As ChartGradientFillStyle

instance.Reset()
C#
public virtual void Reset()
Delphi
public procedure Reset(); virtual;
JScript
public function Reset();
Managed Extensions for C++
public: virtual void Reset();
C++/CLI
public:
virtual void Reset();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartGradientFillStyle Class
ChartGradientFillStyle Members


SerializeObjectData Method

[image]
Intersoft WebGrid Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartGradientFillStyle Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartGradientFillStyle
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure SerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function SerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void SerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void SerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartGradientFillStyle Class
ChartGradientFillStyle Members


ToString Method

[image]
Intersoft WebGrid Documentation
ToString Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartGradientFillStyle Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As System.String
Visual Basic (Usage) Copy Code
Dim instance As ChartGradientFillStyle
Dim value As System.String

value = instance.ToString()
C#
public virtual System.string ToString()
Delphi
public function ToString(): System.String; virtual;
JScript
public function ToString() : System.String;
Managed Extensions for C++
public: virtual System.string* ToString();
C++/CLI
public:
virtual System.String^ ToString();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartGradientFillStyle Class
ChartGradientFillStyle Members


ChartGradientFillStyle Class Properties

[image]
Intersoft WebGrid Documentation
ChartGradientFillStyle Class Properties
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartGradientFillStyle Class

Glossary Item Box

For a list of all members of this type, see ChartGradientFillStyle members.

Public Properties

 | Name | Description
Public Property | BeginColor |
Public Property | EndColor |
Public Property | Style |
Public Property | TextureMappingStyle | (Inherited from ISNet.WebUI.WebGrid.Chart.ChartTextureFillStyle)
Public Property | TransparancyPercent | (Inherited from ISNet.WebUI.WebGrid.Chart.ChartTextureFillStyle)
Public Property | Variant |
Top

See Also

Reference

ChartGradientFillStyle Class
ISNet.WebUI.WebGrid.Chart Namespace


ChartGradientFillStyle Constructor

[image]
Intersoft WebGrid Documentation
ChartGradientFillStyle Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartGradientFillStyle Class : ChartGradientFillStyle Constructor

Glossary Item Box

Overload List

Overload | Description
ChartGradientFillStyle Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartGradientFillStyle Class
ChartGradientFillStyle Members


BeginColor Property

[image]
Intersoft WebGrid Documentation
BeginColor Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartGradientFillStyle Class : BeginColor Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("Appearance")>
<System.ComponentModel.DescriptionAttribute("The begin color of the gradient.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property BeginColor As System.Drawing.Color
Visual Basic (Usage) Copy Code
Dim instance As ChartGradientFillStyle
Dim value As System.Drawing.Color

instance.BeginColor = value

value = instance.BeginColor
C#
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.DescriptionAttribute("The begin color of the gradient.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.Drawing.Color BeginColor {get; set;}
Delphi
public read-write property BeginColor: System.Drawing.Color;
JScript
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("Appearance")
System.ComponentModel.DescriptionAttribute("The begin color of the gradient.")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set BeginColor : System.Drawing.Color
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.DescriptionAttribute("The begin color of the gradient.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.Drawing.Color get_BeginColor();
public: __property void set_BeginColor(
   System.Drawing.Color value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.DescriptionAttribute("The begin color of the gradient.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.Drawing.Color BeginColor {
   System.Drawing.Color get();
   void set (    System.Drawing.Color value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartGradientFillStyle Class
ChartGradientFillStyle Members


EndColor Property

[image]
Intersoft WebGrid Documentation
EndColor Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartGradientFillStyle Class : EndColor Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Appearance")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("The end color of the gradient. ")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property EndColor As System.Drawing.Color
Visual Basic (Usage) Copy Code
Dim instance As ChartGradientFillStyle
Dim value As System.Drawing.Color

instance.EndColor = value

value = instance.EndColor
C#
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("The end color of the gradient. ")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
public System.Drawing.Color EndColor {get; set;}
Delphi
public read-write property EndColor: System.Drawing.Color;
JScript
System.ComponentModel.CategoryAttribute("Appearance")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("The end color of the gradient. ")
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get,set EndColor : System.Drawing.Color
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("The end color of the gradient. ")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.Drawing.Color get_EndColor();
public: __property void set_EndColor(
   System.Drawing.Color value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("The end color of the gradient. ")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.Drawing.Color EndColor {
   System.Drawing.Color get();
   void set (    System.Drawing.Color value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartGradientFillStyle Class
ChartGradientFillStyle Members


Style Property

[image]
Intersoft WebGrid Documentation
Style Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartGradientFillStyle Class : Style Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Appearance")>
<System.ComponentModel.DescriptionAttribute("Controls the gradient style.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
Public Property Style As GradientStyle
Visual Basic (Usage) Copy Code
Dim instance As ChartGradientFillStyle
Dim value As GradientStyle

instance.Style = value

value = instance.Style
C#
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.DescriptionAttribute("Controls the gradient style.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public GradientStyle Style {get; set;}
Delphi
public read-write property Style: GradientStyle;
JScript
System.ComponentModel.CategoryAttribute("Appearance")
System.ComponentModel.DescriptionAttribute("Controls the gradient style.")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
public function get,set Style : GradientStyle
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.DescriptionAttribute("Controls the gradient style.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public: __property GradientStyle get_Style();
public: __property void set_Style(
   GradientStyle value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.DescriptionAttribute("Controls the gradient style.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public:
property GradientStyle Style {
   GradientStyle get();
   void set (    GradientStyle value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartGradientFillStyle Class
ChartGradientFillStyle Members


Variant Property

[image]
Intersoft WebGrid Documentation
Variant Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartGradientFillStyle Class : Variant Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Appearance")>
<System.ComponentModel.DescriptionAttribute("The gradient variant of the ChartGradientFillStyle.")>
Public Property Variant As GradientVariant
Visual Basic (Usage) Copy Code
Dim instance As ChartGradientFillStyle
Dim value As GradientVariant

instance.Variant = value

value = instance.Variant
C#
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.DescriptionAttribute("The gradient variant of the ChartGradientFillStyle.")]
public GradientVariant Variant {get; set;}
Delphi
public read-write property Variant: GradientVariant;
JScript
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Appearance")
System.ComponentModel.DescriptionAttribute("The gradient variant of the ChartGradientFillStyle.")
public function get,set Variant : GradientVariant
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.DescriptionAttribute("The gradient variant of the ChartGradientFillStyle.")]
public: __property GradientVariant get_Variant();
public: __property void set_Variant(
   GradientVariant value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.DescriptionAttribute("The gradient variant of the ChartGradientFillStyle.")]
public:
property GradientVariant Variant {
   GradientVariant get();
   void set (    GradientVariant value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartGradientFillStyle Class
ChartGradientFillStyle Members


ChartHatchFillStyle Class

[image]
Intersoft WebGrid Documentation
ChartHatchFillStyle Class
Members See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartHatchFillStyle Class

Glossary Item Box

Object Model

ChartHatchFillStyle Class

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.SerializableAttribute()>
Public Class ChartHatchFillStyle
   Inherits ChartTextureFillStyle
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Visual Basic (Usage) Copy Code
Dim instance As ChartHatchFillStyle
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public class ChartHatchFillStyle : ChartTextureFillStyle, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Delphi
public class ChartHatchFillStyle = class(ChartTextureFillStyle, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize)
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.SerializableAttribute()
public class ChartHatchFillStyle extends ChartTextureFillStyle implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public __gc class ChartHatchFillStyle : public ChartTextureFillStyle, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public ref class ChartHatchFillStyle : public ChartTextureFillStyle, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.WebGrid.Chart.ChartTextureFillStyle
ISNet.WebUI.WebGrid.Chart.ChartHatchFillStyle

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartHatchFillStyle Members
ISNet.WebUI.WebGrid.Chart Namespace


ChartHatchFillStyle Class Members

[image]
Intersoft WebGrid Documentation
ChartHatchFillStyle Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartHatchFillStyle Class

Glossary Item Box

The following tables list the members exposed by ChartHatchFillStyle.

Public Constructors

 | Name | Description
Public Constructor | ChartHatchFillStyle Constructor |
Top

Public Properties

 | Name | Description
Public Property | BackgroundColor |
Public Property | ForegroundColor |
Public Property | Pattern |
Public Property | TextureMappingStyle | (Inherited from ISNet.WebUI.WebGrid.Chart.ChartTextureFillStyle)
Public Property | TransparancyPercent | (Inherited from ISNet.WebUI.WebGrid.Chart.ChartTextureFillStyle)
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

ChartHatchFillStyle Class
ISNet.WebUI.WebGrid.Chart Namespace


ChartHatchFillStyle Constructor

[image]
Intersoft WebGrid Documentation
ChartHatchFillStyle Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartHatchFillStyle Class : ChartHatchFillStyle Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New ChartHatchFillStyle()
C#
public ChartHatchFillStyle()
Delphi
public ChartHatchFillStyle();
JScript
public function ChartHatchFillStyle();
Managed Extensions for C++
public: ChartHatchFillStyle();
C++/CLI
public:
ChartHatchFillStyle();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartHatchFillStyle Class
ChartHatchFillStyle Members


Clone Method

[image]
Intersoft WebGrid Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartHatchFillStyle Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As System.Object
Visual Basic (Usage) Copy Code
Dim instance As ChartHatchFillStyle
Dim value As System.Object

value = instance.Clone()
C#
public virtual System.object Clone()
Delphi
public function Clone(): System.TObject; virtual;
JScript
public function Clone() : System.Object;
Managed Extensions for C++
public: virtual System.Object* Clone();
C++/CLI
public:
virtual System.Object^ Clone();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartHatchFillStyle Class
ChartHatchFillStyle Members


CopyFrom Method

[image]
Intersoft WebGrid Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartHatchFillStyle Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartHatchFillStyle Class
ChartHatchFillStyle Members


CopyFrom(Object) Method

[image]
Intersoft WebGrid Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartHatchFillStyle Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartHatchFillStyle
Dim objSource As System.Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   System.object objSource
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartHatchFillStyle Class
ChartHatchFillStyle Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebGrid Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartHatchFillStyle Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object, _
   ByVal cloneSourceValue As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartHatchFillStyle
Dim objSource As System.Object
Dim cloneSourceValue As System.Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   System.object objSource,
   System.bool cloneSourceValue
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject;
    cloneSourceValue: System.Boolean
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object,
   cloneSourceValue : System.boolean
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource,
   System.bool cloneSourceValue
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource,
   System.bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartHatchFillStyle Class
ChartHatchFillStyle Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebGrid Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartHatchFillStyle Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartHatchFillStyle
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure DeSerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function DeSerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void DeSerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void DeSerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartHatchFillStyle Class
ChartHatchFillStyle Members


GetHashCode Method

[image]
Intersoft WebGrid Documentation
GetHashCode Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartHatchFillStyle Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As ChartHatchFillStyle
Dim value As System.Integer

value = instance.GetHashCode()
C#
public virtual System.int GetHashCode()
Delphi
public function GetHashCode(): System.Integer; virtual;
JScript
public function GetHashCode() : System.int;
Managed Extensions for C++
public: virtual System.int GetHashCode();
C++/CLI
public:
virtual System.int GetHashCode();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartHatchFillStyle Class
ChartHatchFillStyle Members


ChartHatchFillStyle Class Methods

[image]
Intersoft WebGrid Documentation
ChartHatchFillStyle Class Methods
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartHatchFillStyle Class

Glossary Item Box

For a list of all members of this type, see ChartHatchFillStyle members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

ChartHatchFillStyle Class
ISNet.WebUI.WebGrid.Chart Namespace


GetObjectData Method

[image]
Intersoft WebGrid Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartHatchFillStyle Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=False,
   UnmanagedCode=False,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=True,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Action=SecurityAction.Demand,
   Unrestricted=False)>
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartHatchFillStyle
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure GetObjectData(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
); override;
JScript
System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=,
   UnmanagedCode=,
   SkipVerification=,
   Execution=,
   ControlThread=,
   ControlEvidence=,
   ControlPolicy=,
   SerializationFormatter=,
   ControlDomainPolicy=,
   ControlPrincipal=,
   ControlAppDomain=,
   RemotingConfiguration=,
   Infrastructure=,
   BindingRedirects=,
   Action=SecurityAction.Demand,
   Unrestricted=)
public override function GetObjectData(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public: void GetObjectData(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
) override
C++/CLI
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public:
void GetObjectData(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
) override

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartHatchFillStyle Class
ChartHatchFillStyle Members


IsEmpty Method

[image]
Intersoft WebGrid Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartHatchFillStyle Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As ChartHatchFillStyle
Dim value As System.Boolean

value = instance.IsEmpty()
C#
public virtual System.bool IsEmpty()
Delphi
public function IsEmpty(): System.Boolean; virtual;
JScript
public function IsEmpty() : System.boolean;
Managed Extensions for C++
public: virtual System.bool IsEmpty();
C++/CLI
public:
virtual System.bool IsEmpty();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartHatchFillStyle Class
ChartHatchFillStyle Members


Reset Method

[image]
Intersoft WebGrid Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartHatchFillStyle Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As ChartHatchFillStyle

instance.Reset()
C#
public virtual void Reset()
Delphi
public procedure Reset(); virtual;
JScript
public function Reset();
Managed Extensions for C++
public: virtual void Reset();
C++/CLI
public:
virtual void Reset();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartHatchFillStyle Class
ChartHatchFillStyle Members


SerializeObjectData Method

[image]
Intersoft WebGrid Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartHatchFillStyle Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartHatchFillStyle
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure SerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function SerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void SerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void SerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartHatchFillStyle Class
ChartHatchFillStyle Members


ToString Method

[image]
Intersoft WebGrid Documentation
ToString Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartHatchFillStyle Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As System.String
Visual Basic (Usage) Copy Code
Dim instance As ChartHatchFillStyle
Dim value As System.String

value = instance.ToString()
C#
public virtual System.string ToString()
Delphi
public function ToString(): System.String; virtual;
JScript
public function ToString() : System.String;
Managed Extensions for C++
public: virtual System.string* ToString();
C++/CLI
public:
virtual System.String^ ToString();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartHatchFillStyle Class
ChartHatchFillStyle Members


ChartHatchFillStyle Class Properties

[image]
Intersoft WebGrid Documentation
ChartHatchFillStyle Class Properties
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartHatchFillStyle Class

Glossary Item Box

For a list of all members of this type, see ChartHatchFillStyle members.

Public Properties

 | Name | Description
Public Property | BackgroundColor |
Public Property | ForegroundColor |
Public Property | Pattern |
Public Property | TextureMappingStyle | (Inherited from ISNet.WebUI.WebGrid.Chart.ChartTextureFillStyle)
Public Property | TransparancyPercent | (Inherited from ISNet.WebUI.WebGrid.Chart.ChartTextureFillStyle)
Top

See Also

Reference

ChartHatchFillStyle Class
ISNet.WebUI.WebGrid.Chart Namespace


ChartHatchFillStyle Constructor

[image]
Intersoft WebGrid Documentation
ChartHatchFillStyle Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartHatchFillStyle Class : ChartHatchFillStyle Constructor

Glossary Item Box

Overload List

Overload | Description
ChartHatchFillStyle Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartHatchFillStyle Class
ChartHatchFillStyle Members


BackgroundColor Property

[image]
Intersoft WebGrid Documentation
BackgroundColor Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartHatchFillStyle Class : BackgroundColor Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Appearance")>
<System.ComponentModel.DescriptionAttribute("The background color of the gradient. ")>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property BackgroundColor As System.Drawing.Color
Visual Basic (Usage) Copy Code
Dim instance As ChartHatchFillStyle
Dim value As System.Drawing.Color

instance.BackgroundColor = value

value = instance.BackgroundColor
C#
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.DescriptionAttribute("The background color of the gradient. ")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.Drawing.Color BackgroundColor {get; set;}
Delphi
public read-write property BackgroundColor: System.Drawing.Color;
JScript
System.ComponentModel.CategoryAttribute("Appearance")
System.ComponentModel.DescriptionAttribute("The background color of the gradient. ")
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set BackgroundColor : System.Drawing.Color
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.DescriptionAttribute("The background color of the gradient. ")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.Drawing.Color get_BackgroundColor();
public: __property void set_BackgroundColor(
   System.Drawing.Color value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.DescriptionAttribute("The background color of the gradient. ")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.Drawing.Color BackgroundColor {
   System.Drawing.Color get();
   void set (    System.Drawing.Color value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartHatchFillStyle Class
ChartHatchFillStyle Members


ForegroundColor Property

[image]
Intersoft WebGrid Documentation
ForegroundColor Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartHatchFillStyle Class : ForegroundColor Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Appearance")>
<System.ComponentModel.DescriptionAttribute("The foreground color of the gradient. ")>
Public Property ForegroundColor As System.Drawing.Color
Visual Basic (Usage) Copy Code
Dim instance As ChartHatchFillStyle
Dim value As System.Drawing.Color

instance.ForegroundColor = value

value = instance.ForegroundColor
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.DescriptionAttribute("The foreground color of the gradient. ")]
public System.Drawing.Color ForegroundColor {get; set;}
Delphi
public read-write property ForegroundColor: System.Drawing.Color;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Appearance")
System.ComponentModel.DescriptionAttribute("The foreground color of the gradient. ")
public function get,set ForegroundColor : System.Drawing.Color
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.DescriptionAttribute("The foreground color of the gradient. ")]
public: __property System.Drawing.Color get_ForegroundColor();
public: __property void set_ForegroundColor(
   System.Drawing.Color value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.DescriptionAttribute("The foreground color of the gradient. ")]
public:
property System.Drawing.Color ForegroundColor {
   System.Drawing.Color get();
   void set (    System.Drawing.Color value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartHatchFillStyle Class
ChartHatchFillStyle Members


Pattern Property

[image]
Intersoft WebGrid Documentation
Pattern Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartHatchFillStyle Class : Pattern Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("The hatch style.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Appearance")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property Pattern As System.Drawing.Drawing2D.HatchStyle
Visual Basic (Usage) Copy Code
Dim instance As ChartHatchFillStyle
Dim value As System.Drawing.Drawing2D.HatchStyle

instance.Pattern = value

value = instance.Pattern
C#
[System.ComponentModel.DescriptionAttribute("The hatch style.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.DefaultValueAttribute()]
public System.Drawing.Drawing2D.HatchStyle Pattern {get; set;}
Delphi
public read-write property Pattern: System.Drawing.Drawing2D.HatchStyle;
JScript
System.ComponentModel.DescriptionAttribute("The hatch style.")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Appearance")
System.ComponentModel.DefaultValueAttribute()
public function get,set Pattern : System.Drawing.Drawing2D.HatchStyle
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("The hatch style.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.Drawing.Drawing2D.HatchStyle get_Pattern();
public: __property void set_Pattern(
   System.Drawing.Drawing2D.HatchStyle value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("The hatch style.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.Drawing.Drawing2D.HatchStyle Pattern {
   System.Drawing.Drawing2D.HatchStyle get();
   void set (    System.Drawing.Drawing2D.HatchStyle value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartHatchFillStyle Class
ChartHatchFillStyle Members


ChartImageFillStyle Class

[image]
Intersoft WebGrid Documentation
ChartImageFillStyle Class
Members See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartImageFillStyle Class

Glossary Item Box

Object Model

ChartImageFillStyle Class

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.SerializableAttribute()>
Public Class ChartImageFillStyle
   Inherits ChartTextureFillStyle
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Visual Basic (Usage) Copy Code
Dim instance As ChartImageFillStyle
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public class ChartImageFillStyle : ChartTextureFillStyle, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Delphi
public class ChartImageFillStyle = class(ChartTextureFillStyle, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize)
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.SerializableAttribute()
public class ChartImageFillStyle extends ChartTextureFillStyle implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public __gc class ChartImageFillStyle : public ChartTextureFillStyle, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public ref class ChartImageFillStyle : public ChartTextureFillStyle, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.WebGrid.Chart.ChartTextureFillStyle
ISNet.WebUI.WebGrid.Chart.ChartImageFillStyle

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartImageFillStyle Members
ISNet.WebUI.WebGrid.Chart Namespace


ChartImageFillStyle Class Members

[image]
Intersoft WebGrid Documentation
ChartImageFillStyle Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartImageFillStyle Class

Glossary Item Box

The following tables list the members exposed by ChartImageFillStyle.

Public Constructors

 | Name | Description
Public Constructor | ChartImageFillStyle Constructor |
Top

Public Properties

 | Name | Description
Public Property | Alpha |
Public Property | ImageUrl |
Public Property | TextureMappingStyle | (Inherited from ISNet.WebUI.WebGrid.Chart.ChartTextureFillStyle)
Public Property | TransparancyPercent | (Inherited from ISNet.WebUI.WebGrid.Chart.ChartTextureFillStyle)
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

ChartImageFillStyle Class
ISNet.WebUI.WebGrid.Chart Namespace


ChartImageFillStyle Constructor

[image]
Intersoft WebGrid Documentation
ChartImageFillStyle Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartImageFillStyle Class : ChartImageFillStyle Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New ChartImageFillStyle()
C#
public ChartImageFillStyle()
Delphi
public ChartImageFillStyle();
JScript
public function ChartImageFillStyle();
Managed Extensions for C++
public: ChartImageFillStyle();
C++/CLI
public:
ChartImageFillStyle();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartImageFillStyle Class
ChartImageFillStyle Members


Clone Method

[image]
Intersoft WebGrid Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartImageFillStyle Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As System.Object
Visual Basic (Usage) Copy Code
Dim instance As ChartImageFillStyle
Dim value As System.Object

value = instance.Clone()
C#
public virtual System.object Clone()
Delphi
public function Clone(): System.TObject; virtual;
JScript
public function Clone() : System.Object;
Managed Extensions for C++
public: virtual System.Object* Clone();
C++/CLI
public:
virtual System.Object^ Clone();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartImageFillStyle Class
ChartImageFillStyle Members


CopyFrom Method

[image]
Intersoft WebGrid Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartImageFillStyle Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartImageFillStyle Class
ChartImageFillStyle Members


CopyFrom(Object) Method

[image]
Intersoft WebGrid Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartImageFillStyle Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartImageFillStyle
Dim objSource As System.Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   System.object objSource
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartImageFillStyle Class
ChartImageFillStyle Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebGrid Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartImageFillStyle Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object, _
   ByVal cloneSourceValue As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartImageFillStyle
Dim objSource As System.Object
Dim cloneSourceValue As System.Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   System.object objSource,
   System.bool cloneSourceValue
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject;
    cloneSourceValue: System.Boolean
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object,
   cloneSourceValue : System.boolean
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource,
   System.bool cloneSourceValue
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource,
   System.bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartImageFillStyle Class
ChartImageFillStyle Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebGrid Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartImageFillStyle Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartImageFillStyle
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure DeSerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function DeSerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void DeSerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void DeSerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartImageFillStyle Class
ChartImageFillStyle Members


GetHashCode Method

[image]
Intersoft WebGrid Documentation
GetHashCode Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartImageFillStyle Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As ChartImageFillStyle
Dim value As System.Integer

value = instance.GetHashCode()
C#
public virtual System.int GetHashCode()
Delphi
public function GetHashCode(): System.Integer; virtual;
JScript
public function GetHashCode() : System.int;
Managed Extensions for C++
public: virtual System.int GetHashCode();
C++/CLI
public:
virtual System.int GetHashCode();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartImageFillStyle Class
ChartImageFillStyle Members


ChartImageFillStyle Class Methods

[image]
Intersoft WebGrid Documentation
ChartImageFillStyle Class Methods
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartImageFillStyle Class

Glossary Item Box

For a list of all members of this type, see ChartImageFillStyle members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

ChartImageFillStyle Class
ISNet.WebUI.WebGrid.Chart Namespace


GetObjectData Method

[image]
Intersoft WebGrid Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartImageFillStyle Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=False,
   UnmanagedCode=False,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=True,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Action=SecurityAction.Demand,
   Unrestricted=False)>
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartImageFillStyle
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure GetObjectData(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
); override;
JScript
System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=,
   UnmanagedCode=,
   SkipVerification=,
   Execution=,
   ControlThread=,
   ControlEvidence=,
   ControlPolicy=,
   SerializationFormatter=,
   ControlDomainPolicy=,
   ControlPrincipal=,
   ControlAppDomain=,
   RemotingConfiguration=,
   Infrastructure=,
   BindingRedirects=,
   Action=SecurityAction.Demand,
   Unrestricted=)
public override function GetObjectData(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public: void GetObjectData(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
) override
C++/CLI
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public:
void GetObjectData(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
) override

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartImageFillStyle Class
ChartImageFillStyle Members


IsEmpty Method

[image]
Intersoft WebGrid Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartImageFillStyle Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As ChartImageFillStyle
Dim value As System.Boolean

value = instance.IsEmpty()
C#
public virtual System.bool IsEmpty()
Delphi
public function IsEmpty(): System.Boolean; virtual;
JScript
public function IsEmpty() : System.boolean;
Managed Extensions for C++
public: virtual System.bool IsEmpty();
C++/CLI
public:
virtual System.bool IsEmpty();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartImageFillStyle Class
ChartImageFillStyle Members


Reset Method

[image]
Intersoft WebGrid Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartImageFillStyle Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As ChartImageFillStyle

instance.Reset()
C#
public virtual void Reset()
Delphi
public procedure Reset(); virtual;
JScript
public function Reset();
Managed Extensions for C++
public: virtual void Reset();
C++/CLI
public:
virtual void Reset();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartImageFillStyle Class
ChartImageFillStyle Members


SerializeObjectData Method

[image]
Intersoft WebGrid Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartImageFillStyle Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartImageFillStyle
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure SerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function SerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void SerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void SerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartImageFillStyle Class
ChartImageFillStyle Members


ToString Method

[image]
Intersoft WebGrid Documentation
ToString Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartImageFillStyle Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As System.String
Visual Basic (Usage) Copy Code
Dim instance As ChartImageFillStyle
Dim value As System.String

value = instance.ToString()
C#
public virtual System.string ToString()
Delphi
public function ToString(): System.String; virtual;
JScript
public function ToString() : System.String;
Managed Extensions for C++
public: virtual System.string* ToString();
C++/CLI
public:
virtual System.String^ ToString();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartImageFillStyle Class
ChartImageFillStyle Members


ChartImageFillStyle Class Properties

[image]
Intersoft WebGrid Documentation
ChartImageFillStyle Class Properties
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartImageFillStyle Class

Glossary Item Box

For a list of all members of this type, see ChartImageFillStyle members.

Public Properties

 | Name | Description
Public Property | Alpha |
Public Property | ImageUrl |
Public Property | TextureMappingStyle | (Inherited from ISNet.WebUI.WebGrid.Chart.ChartTextureFillStyle)
Public Property | TransparancyPercent | (Inherited from ISNet.WebUI.WebGrid.Chart.ChartTextureFillStyle)
Top

See Also

Reference

ChartImageFillStyle Class
ISNet.WebUI.WebGrid.Chart Namespace


ChartImageFillStyle Constructor

[image]
Intersoft WebGrid Documentation
ChartImageFillStyle Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartImageFillStyle Class : ChartImageFillStyle Constructor

Glossary Item Box

Overload List

Overload | Description
ChartImageFillStyle Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartImageFillStyle Class
ChartImageFillStyle Members


Alpha Property

[image]
Intersoft WebGrid Documentation
Alpha Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartImageFillStyle Class : Alpha Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("The alpha value applied on the image. ")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Appearance")>
Public Property Alpha As System.Byte
Visual Basic (Usage) Copy Code
Dim instance As ChartImageFillStyle
Dim value As System.Byte

instance.Alpha = value

value = instance.Alpha
C#
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("The alpha value applied on the image. ")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Appearance")]
public System.byte Alpha {get; set;}
Delphi
public read-write property Alpha: System.Byte;
JScript
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("The alpha value applied on the image. ")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Appearance")
public function get,set Alpha : System.byte
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("The alpha value applied on the image. ")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Appearance")]
public: __property System.byte get_Alpha();
public: __property void set_Alpha(
   System.byte value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("The alpha value applied on the image. ")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Appearance")]
public:
property System.byte Alpha {
   System.byte get();
   void set (    System.byte value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartImageFillStyle Class
ChartImageFillStyle Members


ImageUrl Property

[image]
Intersoft WebGrid Documentation
ImageUrl Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartImageFillStyle Class : ImageUrl Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Web.UI.UrlPropertyAttribute()>
<System.ComponentModel.DescriptionAttribute("The full path to an image file used to create a texture.")>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="System.Web.UI.Design.ImageUrlEditor, System.Design, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")>
<System.ComponentModel.CategoryAttribute("Appearance")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property ImageUrl As System.String
Visual Basic (Usage) Copy Code
Dim instance As ChartImageFillStyle
Dim value As System.String

instance.ImageUrl = value

value = instance.ImageUrl
C#
[System.Web.UI.UrlPropertyAttribute()]
[System.ComponentModel.DescriptionAttribute("The full path to an image file used to create a texture.")]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="System.Web.UI.Design.ImageUrlEditor, System.Design, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[System.ComponentModel.CategoryAttribute("Appearance")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.string ImageUrl {get; set;}
Delphi
public read-write property ImageUrl: System.String;
JScript
System.Web.UI.UrlPropertyAttribute()
System.ComponentModel.DescriptionAttribute("The full path to an image file used to create a texture.")
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="System.Web.UI.Design.ImageUrlEditor, System.Design, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")
System.ComponentModel.CategoryAttribute("Appearance")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set ImageUrl : System.String
Managed Extensions for C++
[System.Web.UI.UrlPropertyAttribute()]
[System.ComponentModel.DescriptionAttribute("The full path to an image file used to create a texture.")]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="System.Web.UI.Design.ImageUrlEditor, System.Design, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[System.ComponentModel.CategoryAttribute("Appearance")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.string* get_ImageUrl();
public: __property void set_ImageUrl(
   System.string* value
);
C++/CLI
[System.Web.UI.UrlPropertyAttribute()]
[System.ComponentModel.DescriptionAttribute("The full path to an image file used to create a texture.")]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="System.Web.UI.Design.ImageUrlEditor, System.Design, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[System.ComponentModel.CategoryAttribute("Appearance")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.String^ ImageUrl {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartImageFillStyle Class
ChartImageFillStyle Members


ChartImageFilterSettings Class

[image]
Intersoft WebGrid Documentation
ChartImageFilterSettings Class
Members See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartImageFilterSettings Class

Glossary Item Box

Object Model

ChartImageFilterSettings Class

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.SerializableAttribute()>
Public Class ChartImageFilterSettings
   Inherits ISNet.WebUI.WebUIBaseClass
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Visual Basic (Usage) Copy Code
Dim instance As ChartImageFilterSettings
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public class ChartImageFilterSettings : ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Delphi
public class ChartImageFilterSettings = class(ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize)
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.SerializableAttribute()
public class ChartImageFilterSettings extends ISNet.WebUI.WebUIBaseClass implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public __gc class ChartImageFilterSettings : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public ref class ChartImageFilterSettings : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.WebGrid.Chart.ChartImageFilterSettings
ISNet.WebUI.WebGrid.Chart.ChartBevelAndEmbossImageFilterSettings
ISNet.WebUI.WebGrid.Chart.ChartBlurImageFilterSettings
ISNet.WebUI.WebGrid.Chart.ChartGlowImageFilterSettings
ISNet.WebUI.WebGrid.Chart.ChartLightingImageFilterSettings

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartImageFilterSettings Members
ISNet.WebUI.WebGrid.Chart Namespace


ChartImageFilterSettings Class Members

[image]
Intersoft WebGrid Documentation
ChartImageFilterSettings Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartImageFilterSettings Class

Glossary Item Box

The following tables list the members exposed by ChartImageFilterSettings.

Public Constructors

 | Name | Description
Public Constructor | ChartImageFilterSettings Constructor |
Top

Public Properties

 | Name | Description
Public Property | BlurType |
Public Property | Enabled |
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

ChartImageFilterSettings Class
ISNet.WebUI.WebGrid.Chart Namespace


ChartImageFilterSettings Constructor

[image]
Intersoft WebGrid Documentation
ChartImageFilterSettings Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartImageFilterSettings Class : ChartImageFilterSettings Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New ChartImageFilterSettings()
C#
public ChartImageFilterSettings()
Delphi
public ChartImageFilterSettings();
JScript
public function ChartImageFilterSettings();
Managed Extensions for C++
public: ChartImageFilterSettings();
C++/CLI
public:
ChartImageFilterSettings();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartImageFilterSettings Class
ChartImageFilterSettings Members


Clone Method

[image]
Intersoft WebGrid Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartImageFilterSettings Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As System.Object
Visual Basic (Usage) Copy Code
Dim instance As ChartImageFilterSettings
Dim value As System.Object

value = instance.Clone()
C#
public virtual System.object Clone()
Delphi
public function Clone(): System.TObject; virtual;
JScript
public function Clone() : System.Object;
Managed Extensions for C++
public: virtual System.Object* Clone();
C++/CLI
public:
virtual System.Object^ Clone();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartImageFilterSettings Class
ChartImageFilterSettings Members


CopyFrom Method

[image]
Intersoft WebGrid Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartImageFilterSettings Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartImageFilterSettings Class
ChartImageFilterSettings Members


CopyFrom(Object) Method

[image]
Intersoft WebGrid Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartImageFilterSettings Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartImageFilterSettings
Dim objSource As System.Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   System.object objSource
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartImageFilterSettings Class
ChartImageFilterSettings Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebGrid Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartImageFilterSettings Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object, _
   ByVal cloneSourceValue As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartImageFilterSettings
Dim objSource As System.Object
Dim cloneSourceValue As System.Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   System.object objSource,
   System.bool cloneSourceValue
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject;
    cloneSourceValue: System.Boolean
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object,
   cloneSourceValue : System.boolean
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource,
   System.bool cloneSourceValue
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource,
   System.bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartImageFilterSettings Class
ChartImageFilterSettings Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebGrid Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartImageFilterSettings Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartImageFilterSettings
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure DeSerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function DeSerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void DeSerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void DeSerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartImageFilterSettings Class
ChartImageFilterSettings Members


GetHashCode Method

[image]
Intersoft WebGrid Documentation
GetHashCode Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartImageFilterSettings Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As ChartImageFilterSettings
Dim value As System.Integer

value = instance.GetHashCode()
C#
public virtual System.int GetHashCode()
Delphi
public function GetHashCode(): System.Integer; virtual;
JScript
public function GetHashCode() : System.int;
Managed Extensions for C++
public: virtual System.int GetHashCode();
C++/CLI
public:
virtual System.int GetHashCode();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartImageFilterSettings Class
ChartImageFilterSettings Members


ChartImageFilterSettings Class Methods

[image]
Intersoft WebGrid Documentation
ChartImageFilterSettings Class Methods
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartImageFilterSettings Class

Glossary Item Box

For a list of all members of this type, see ChartImageFilterSettings members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

ChartImageFilterSettings Class
ISNet.WebUI.WebGrid.Chart Namespace


GetObjectData Method

[image]
Intersoft WebGrid Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartImageFilterSettings Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=False,
   UnmanagedCode=False,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=True,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Action=SecurityAction.Demand,
   Unrestricted=False)>
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartImageFilterSettings
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure GetObjectData(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
); override;
JScript
System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=,
   UnmanagedCode=,
   SkipVerification=,
   Execution=,
   ControlThread=,
   ControlEvidence=,
   ControlPolicy=,
   SerializationFormatter=,
   ControlDomainPolicy=,
   ControlPrincipal=,
   ControlAppDomain=,
   RemotingConfiguration=,
   Infrastructure=,
   BindingRedirects=,
   Action=SecurityAction.Demand,
   Unrestricted=)
public override function GetObjectData(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public: void GetObjectData(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
) override
C++/CLI
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public:
void GetObjectData(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
) override

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartImageFilterSettings Class
ChartImageFilterSettings Members


IsEmpty Method

[image]
Intersoft WebGrid Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartImageFilterSettings Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As ChartImageFilterSettings
Dim value As System.Boolean

value = instance.IsEmpty()
C#
public virtual System.bool IsEmpty()
Delphi
public function IsEmpty(): System.Boolean; virtual;
JScript
public function IsEmpty() : System.boolean;
Managed Extensions for C++
public: virtual System.bool IsEmpty();
C++/CLI
public:
virtual System.bool IsEmpty();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartImageFilterSettings Class
ChartImageFilterSettings Members


Reset Method

[image]
Intersoft WebGrid Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartImageFilterSettings Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As ChartImageFilterSettings

instance.Reset()
C#
public virtual void Reset()
Delphi
public procedure Reset(); virtual;
JScript
public function Reset();
Managed Extensions for C++
public: virtual void Reset();
C++/CLI
public:
virtual void Reset();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartImageFilterSettings Class
ChartImageFilterSettings Members


SerializeObjectData Method

[image]
Intersoft WebGrid Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartImageFilterSettings Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartImageFilterSettings
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure SerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function SerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void SerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void SerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartImageFilterSettings Class
ChartImageFilterSettings Members


ToString Method

[image]
Intersoft WebGrid Documentation
ToString Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartImageFilterSettings Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As System.String
Visual Basic (Usage) Copy Code
Dim instance As ChartImageFilterSettings
Dim value As System.String

value = instance.ToString()
C#
public virtual System.string ToString()
Delphi
public function ToString(): System.String; virtual;
JScript
public function ToString() : System.String;
Managed Extensions for C++
public: virtual System.string* ToString();
C++/CLI
public:
virtual System.String^ ToString();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartImageFilterSettings Class
ChartImageFilterSettings Members


ChartImageFilterSettings Class Properties

[image]
Intersoft WebGrid Documentation
ChartImageFilterSettings Class Properties
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartImageFilterSettings Class

Glossary Item Box

For a list of all members of this type, see ChartImageFilterSettings members.

Public Properties

 | Name | Description
Public Property | BlurType |
Public Property | Enabled |
Top

See Also

Reference

ChartImageFilterSettings Class
ISNet.WebUI.WebGrid.Chart Namespace


ChartImageFilterSettings Constructor

[image]
Intersoft WebGrid Documentation
ChartImageFilterSettings Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartImageFilterSettings Class : ChartImageFilterSettings Constructor

Glossary Item Box

Overload List

Overload | Description
ChartImageFilterSettings Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartImageFilterSettings Class
ChartImageFilterSettings Members


BlurType Property

[image]
Intersoft WebGrid Documentation
BlurType Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartImageFilterSettings Class : BlurType Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("The type of the blur to use.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Blur")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property BlurType As BlurType
Visual Basic (Usage) Copy Code
Dim instance As ChartImageFilterSettings
Dim value As BlurType

instance.BlurType = value

value = instance.BlurType
C#
[System.ComponentModel.DescriptionAttribute("The type of the blur to use.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Blur")]
[System.ComponentModel.DefaultValueAttribute()]
public BlurType BlurType {get; set;}
Delphi
public read-write property BlurType: BlurType;
JScript
System.ComponentModel.DescriptionAttribute("The type of the blur to use.")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Blur")
System.ComponentModel.DefaultValueAttribute()
public function get,set BlurType : BlurType
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("The type of the blur to use.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Blur")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property BlurType get_BlurType();
public: __property void set_BlurType(
   BlurType value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("The type of the blur to use.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Blur")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property BlurType BlurType {
   BlurType get();
   void set (    BlurType value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartImageFilterSettings Class
ChartImageFilterSettings Members


Enabled Property

[image]
Intersoft WebGrid Documentation
Enabled Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartImageFilterSettings Class : Enabled Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Enable image filtering effect.")>
<System.ComponentModel.CategoryAttribute("General")>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property Enabled As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As ChartImageFilterSettings
Dim value As System.Boolean

instance.Enabled = value

value = instance.Enabled
C#
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Enable image filtering effect.")]
[System.ComponentModel.CategoryAttribute("General")]
[ISNet.Serialization.BinarySerializableAttribute()]
public System.bool Enabled {get; set;}
Delphi
public read-write property Enabled: System.Boolean;
JScript
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Enable image filtering effect.")
System.ComponentModel.CategoryAttribute("General")
ISNet.Serialization.BinarySerializableAttribute()
public function get,set Enabled : System.boolean
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Enable image filtering effect.")]
[System.ComponentModel.CategoryAttribute("General")]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.bool get_Enabled();
public: __property void set_Enabled(
   System.bool value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Enable image filtering effect.")]
[System.ComponentModel.CategoryAttribute("General")]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.bool Enabled {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartImageFilterSettings Class
ChartImageFilterSettings Members


ChartImageFrameStyle Class

[image]
Intersoft WebGrid Documentation
ChartImageFrameStyle Class
Members See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartImageFrameStyle Class

Glossary Item Box

Object Model

ChartImageFrameStyle Class

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.SerializableAttribute()>
Public Class ChartImageFrameStyle
   Inherits ISNet.WebUI.WebUIBaseClass
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Visual Basic (Usage) Copy Code
Dim instance As ChartImageFrameStyle
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public class ChartImageFrameStyle : ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Delphi
public class ChartImageFrameStyle = class(ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize)
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.SerializableAttribute()
public class ChartImageFrameStyle extends ISNet.WebUI.WebUIBaseClass implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public __gc class ChartImageFrameStyle : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public ref class ChartImageFrameStyle : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.WebGrid.Chart.ChartImageFrameStyle

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartImageFrameStyle Members
ISNet.WebUI.WebGrid.Chart Namespace


ChartImageFrameStyle Class Members

[image]
Intersoft WebGrid Documentation
ChartImageFrameStyle Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartImageFrameStyle Class

Glossary Item Box

The following tables list the members exposed by ChartImageFrameStyle.

Public Constructors

 | Name | Description
Public Constructor | ChartImageFrameStyle Constructor |
Top

Public Properties

 | Name | Description
Public Property | BackgroundColor |
Public Property | BorderStyle |
Public Property | CornerMargins |
Public Property | DarkBorderStyle |
Public Property | FillStyle |
Public Property | InnerEdgePercent |
Public Property | LightBorderStyle |
Public Property | LightColor |
Public Property | LightEffectSize |
Public Property | OuterEdgePercent |
Public Property | ShadowColor |
Public Property | ShadowStyle |
Public Property | TubeMargins |
Public Property | Type |
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

ChartImageFrameStyle Class
ISNet.WebUI.WebGrid.Chart Namespace


ChartImageFrameStyle Constructor

[image]
Intersoft WebGrid Documentation
ChartImageFrameStyle Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartImageFrameStyle Class : ChartImageFrameStyle Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New ChartImageFrameStyle()
C#
public ChartImageFrameStyle()
Delphi
public ChartImageFrameStyle();
JScript
public function ChartImageFrameStyle();
Managed Extensions for C++
public: ChartImageFrameStyle();
C++/CLI
public:
ChartImageFrameStyle();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartImageFrameStyle Class
ChartImageFrameStyle Members


Clone Method

[image]
Intersoft WebGrid Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartImageFrameStyle Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As System.Object
Visual Basic (Usage) Copy Code
Dim instance As ChartImageFrameStyle
Dim value As System.Object

value = instance.Clone()
C#
public virtual System.object Clone()
Delphi
public function Clone(): System.TObject; virtual;
JScript
public function Clone() : System.Object;
Managed Extensions for C++
public: virtual System.Object* Clone();
C++/CLI
public:
virtual System.Object^ Clone();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartImageFrameStyle Class
ChartImageFrameStyle Members


CopyFrom Method

[image]
Intersoft WebGrid Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartImageFrameStyle Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartImageFrameStyle Class
ChartImageFrameStyle Members


CopyFrom(Object) Method

[image]
Intersoft WebGrid Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartImageFrameStyle Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartImageFrameStyle
Dim objSource As System.Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   System.object objSource
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartImageFrameStyle Class
ChartImageFrameStyle Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebGrid Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartImageFrameStyle Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object, _
   ByVal cloneSourceValue As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartImageFrameStyle
Dim objSource As System.Object
Dim cloneSourceValue As System.Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   System.object objSource,
   System.bool cloneSourceValue
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject;
    cloneSourceValue: System.Boolean
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object,
   cloneSourceValue : System.boolean
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource,
   System.bool cloneSourceValue
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource,
   System.bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartImageFrameStyle Class
ChartImageFrameStyle Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebGrid Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartImageFrameStyle Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartImageFrameStyle
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure DeSerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function DeSerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void DeSerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void DeSerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartImageFrameStyle Class
ChartImageFrameStyle Members


GetHashCode Method

[image]
Intersoft WebGrid Documentation
GetHashCode Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartImageFrameStyle Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As ChartImageFrameStyle
Dim value As System.Integer

value = instance.GetHashCode()
C#
public virtual System.int GetHashCode()
Delphi
public function GetHashCode(): System.Integer; virtual;
JScript
public function GetHashCode() : System.int;
Managed Extensions for C++
public: virtual System.int GetHashCode();
C++/CLI
public:
virtual System.int GetHashCode();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartImageFrameStyle Class
ChartImageFrameStyle Members


ChartImageFrameStyle Class Methods

[image]
Intersoft WebGrid Documentation
ChartImageFrameStyle Class Methods
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartImageFrameStyle Class

Glossary Item Box

For a list of all members of this type, see ChartImageFrameStyle members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

ChartImageFrameStyle Class
ISNet.WebUI.WebGrid.Chart Namespace


GetObjectData Method

[image]
Intersoft WebGrid Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartImageFrameStyle Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=False,
   UnmanagedCode=False,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=True,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Action=SecurityAction.Demand,
   Unrestricted=False)>
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartImageFrameStyle
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure GetObjectData(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
); override;
JScript
System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=,
   UnmanagedCode=,
   SkipVerification=,
   Execution=,
   ControlThread=,
   ControlEvidence=,
   ControlPolicy=,
   SerializationFormatter=,
   ControlDomainPolicy=,
   ControlPrincipal=,
   ControlAppDomain=,
   RemotingConfiguration=,
   Infrastructure=,
   BindingRedirects=,
   Action=SecurityAction.Demand,
   Unrestricted=)
public override function GetObjectData(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public: void GetObjectData(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
) override
C++/CLI
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public:
void GetObjectData(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
) override

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartImageFrameStyle Class
ChartImageFrameStyle Members


IsEmpty Method

[image]
Intersoft WebGrid Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartImageFrameStyle Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As ChartImageFrameStyle
Dim value As System.Boolean

value = instance.IsEmpty()
C#
public virtual System.bool IsEmpty()
Delphi
public function IsEmpty(): System.Boolean; virtual;
JScript
public function IsEmpty() : System.boolean;
Managed Extensions for C++
public: virtual System.bool IsEmpty();
C++/CLI
public:
virtual System.bool IsEmpty();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartImageFrameStyle Class
ChartImageFrameStyle Members


Reset Method

[image]
Intersoft WebGrid Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartImageFrameStyle Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As ChartImageFrameStyle

instance.Reset()
C#
public virtual void Reset()
Delphi
public procedure Reset(); virtual;
JScript
public function Reset();
Managed Extensions for C++
public: virtual void Reset();
C++/CLI
public:
virtual void Reset();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartImageFrameStyle Class
ChartImageFrameStyle Members


SerializeObjectData Method

[image]
Intersoft WebGrid Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartImageFrameStyle Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartImageFrameStyle
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure SerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function SerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void SerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void SerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartImageFrameStyle Class
ChartImageFrameStyle Members


ToString Method

[image]
Intersoft WebGrid Documentation
ToString Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartImageFrameStyle Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As System.String
Visual Basic (Usage) Copy Code
Dim instance As ChartImageFrameStyle
Dim value As System.String

value = instance.ToString()
C#
public virtual System.string ToString()
Delphi
public function ToString(): System.String; virtual;
JScript
public function ToString() : System.String;
Managed Extensions for C++
public: virtual System.string* ToString();
C++/CLI
public:
virtual System.String^ ToString();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartImageFrameStyle Class
ChartImageFrameStyle Members


ChartImageFrameStyle Class Properties

[image]
Intersoft WebGrid Documentation
ChartImageFrameStyle Class Properties
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartImageFrameStyle Class

Glossary Item Box

For a list of all members of this type, see ChartImageFrameStyle members.

Public Properties

 | Name | Description
Public Property | BackgroundColor |
Public Property | BorderStyle |
Public Property | CornerMargins |
Public Property | DarkBorderStyle |
Public Property | FillStyle |
Public Property | InnerEdgePercent |
Public Property | LightBorderStyle |
Public Property | LightColor |
Public Property | LightEffectSize |
Public Property | OuterEdgePercent |
Public Property | ShadowColor |
Public Property | ShadowStyle |
Public Property | TubeMargins |
Public Property | Type |
Top

See Also

Reference

ChartImageFrameStyle Class
ISNet.WebUI.WebGrid.Chart Namespace


ChartImageFrameStyle Constructor

[image]
Intersoft WebGrid Documentation
ChartImageFrameStyle Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartImageFrameStyle Class : ChartImageFrameStyle Constructor

Glossary Item Box

Overload List

Overload | Description
ChartImageFrameStyle Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartImageFrameStyle Class
ChartImageFrameStyle Members


BackgroundColor Property

[image]
Intersoft WebGrid Documentation
BackgroundColor Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartImageFrameStyle Class : BackgroundColor Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Appearance")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("The background color of the frame.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property BackgroundColor As System.Drawing.Color
Visual Basic (Usage) Copy Code
Dim instance As ChartImageFrameStyle
Dim value As System.Drawing.Color

instance.BackgroundColor = value

value = instance.BackgroundColor
C#
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("The background color of the frame.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.Drawing.Color BackgroundColor {get; set;}
Delphi
public read-write property BackgroundColor: System.Drawing.Color;
JScript
System.ComponentModel.CategoryAttribute("Appearance")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("The background color of the frame.")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set BackgroundColor : System.Drawing.Color
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("The background color of the frame.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.Drawing.Color get_BackgroundColor();
public: __property void set_BackgroundColor(
   System.Drawing.Color value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("The background color of the frame.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.Drawing.Color BackgroundColor {
   System.Drawing.Color get();
   void set (    System.Drawing.Color value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartImageFrameStyle Class
ChartImageFrameStyle Members


BorderStyle Property

[image]
Intersoft WebGrid Documentation
BorderStyle Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartImageFrameStyle Class : BorderStyle Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Controls the border of the image frame.")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<System.ComponentModel.CategoryAttribute("Appearance")>
<ISNet.Serialization.BinarySerializableAttribute("setBorderStyle")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
Public ReadOnly Property BorderStyle As ChartStrokeStyle
Visual Basic (Usage) Copy Code
Dim instance As ChartImageFrameStyle
Dim value As ChartStrokeStyle

value = instance.BorderStyle
C#
[System.ComponentModel.DescriptionAttribute("Controls the border of the image frame.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.CategoryAttribute("Appearance")]
[ISNet.Serialization.BinarySerializableAttribute("setBorderStyle")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
public ChartStrokeStyle BorderStyle {get;}
Delphi
public read-only property BorderStyle: ChartStrokeStyle;
JScript
System.ComponentModel.DescriptionAttribute("Controls the border of the image frame.")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
System.ComponentModel.CategoryAttribute("Appearance")
ISNet.Serialization.BinarySerializableAttribute("setBorderStyle")
System.ComponentModel.NotifyParentPropertyAttribute()
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
public function get BorderStyle : ChartStrokeStyle
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Controls the border of the image frame.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.CategoryAttribute("Appearance")]
[ISNet.Serialization.BinarySerializableAttribute("setBorderStyle")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
public: __property ChartStrokeStyle* get_BorderStyle();
C++/CLI
[System.ComponentModel.DescriptionAttribute("Controls the border of the image frame.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.CategoryAttribute("Appearance")]
[ISNet.Serialization.BinarySerializableAttribute("setBorderStyle")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
public:
property ChartStrokeStyle^ BorderStyle {
   ChartStrokeStyle^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartImageFrameStyle Class
ChartImageFrameStyle Members


CornerMargins Property

[image]
Intersoft WebGrid Documentation
CornerMargins Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartImageFrameStyle Class : CornerMargins Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("The corner margins of the image frame.")>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.CategoryAttribute("Dimensions")>
<ISNet.Serialization.BinarySerializableAttribute("setCornerMargins")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<System.ComponentModel.DefaultValueAttribute()>
Public ReadOnly Property CornerMargins As ChartMarginValue
Visual Basic (Usage) Copy Code
Dim instance As ChartImageFrameStyle
Dim value As ChartMarginValue

value = instance.CornerMargins
C#
[System.ComponentModel.DescriptionAttribute("The corner margins of the image frame.")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.CategoryAttribute("Dimensions")]
[ISNet.Serialization.BinarySerializableAttribute("setCornerMargins")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DefaultValueAttribute()]
public ChartMarginValue CornerMargins {get;}
Delphi
public read-only property CornerMargins: ChartMarginValue;
JScript
System.ComponentModel.DescriptionAttribute("The corner margins of the image frame.")
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.CategoryAttribute("Dimensions")
ISNet.Serialization.BinarySerializableAttribute("setCornerMargins")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
System.ComponentModel.DefaultValueAttribute()
public function get CornerMargins : ChartMarginValue
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("The corner margins of the image frame.")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.CategoryAttribute("Dimensions")]
[ISNet.Serialization.BinarySerializableAttribute("setCornerMargins")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property ChartMarginValue* get_CornerMargins();
C++/CLI
[System.ComponentModel.DescriptionAttribute("The corner margins of the image frame.")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.CategoryAttribute("Dimensions")]
[ISNet.Serialization.BinarySerializableAttribute("setCornerMargins")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property ChartMarginValue^ CornerMargins {
   ChartMarginValue^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartImageFrameStyle Class
ChartImageFrameStyle Members


DarkBorderStyle Property

[image]
Intersoft WebGrid Documentation
DarkBorderStyle Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartImageFrameStyle Class : DarkBorderStyle Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.CategoryAttribute("Appearance")>
<System.ComponentModel.DescriptionAttribute("Obtains the dark border style.")>
<ISNet.Serialization.BinarySerializableAttribute("setDarkBorderStyle")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
Public ReadOnly Property DarkBorderStyle As ChartStrokeStyle
Visual Basic (Usage) Copy Code
Dim instance As ChartImageFrameStyle
Dim value As ChartStrokeStyle

value = instance.DarkBorderStyle
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.DescriptionAttribute("Obtains the dark border style.")]
[ISNet.Serialization.BinarySerializableAttribute("setDarkBorderStyle")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
public ChartStrokeStyle DarkBorderStyle {get;}
Delphi
public read-only property DarkBorderStyle: ChartStrokeStyle;
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.CategoryAttribute("Appearance")
System.ComponentModel.DescriptionAttribute("Obtains the dark border style.")
ISNet.Serialization.BinarySerializableAttribute("setDarkBorderStyle")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
public function get DarkBorderStyle : ChartStrokeStyle
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.DescriptionAttribute("Obtains the dark border style.")]
[ISNet.Serialization.BinarySerializableAttribute("setDarkBorderStyle")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
public: __property ChartStrokeStyle* get_DarkBorderStyle();
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.DescriptionAttribute("Obtains the dark border style.")]
[ISNet.Serialization.BinarySerializableAttribute("setDarkBorderStyle")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
public:
property ChartStrokeStyle^ DarkBorderStyle {
   ChartStrokeStyle^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartImageFrameStyle Class
ChartImageFrameStyle Members


FillStyle Property

[image]
Intersoft WebGrid Documentation
FillStyle Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartImageFrameStyle Class : FillStyle Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Appearance")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<ISNet.Serialization.BinarySerializableAttribute("setFillStyle")>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.DescriptionAttribute("The fill effect applied on the frame.")>
<System.ComponentModel.DefaultValueAttribute()>
Public ReadOnly Property FillStyle As ChartFillStyle
Visual Basic (Usage) Copy Code
Dim instance As ChartImageFrameStyle
Dim value As ChartFillStyle

value = instance.FillStyle
C#
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.Serialization.BinarySerializableAttribute("setFillStyle")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DescriptionAttribute("The fill effect applied on the frame.")]
[System.ComponentModel.DefaultValueAttribute()]
public ChartFillStyle FillStyle {get;}
Delphi
public read-only property FillStyle: ChartFillStyle;
JScript
System.ComponentModel.CategoryAttribute("Appearance")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
ISNet.Serialization.BinarySerializableAttribute("setFillStyle")
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.DescriptionAttribute("The fill effect applied on the frame.")
System.ComponentModel.DefaultValueAttribute()
public function get FillStyle : ChartFillStyle
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.Serialization.BinarySerializableAttribute("setFillStyle")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DescriptionAttribute("The fill effect applied on the frame.")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property ChartFillStyle* get_FillStyle();
C++/CLI
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.Serialization.BinarySerializableAttribute("setFillStyle")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DescriptionAttribute("The fill effect applied on the frame.")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property ChartFillStyle^ FillStyle {
   ChartFillStyle^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartImageFrameStyle Class
ChartImageFrameStyle Members


InnerEdgePercent Property

[image]
Intersoft WebGrid Documentation
InnerEdgePercent Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartImageFrameStyle Class : InnerEdgePercent Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Edge Rounding")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("The amount of rounding of the outer edges relative to the corner and tube size.")>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property InnerEdgePercent As System.Single
Visual Basic (Usage) Copy Code
Dim instance As ChartImageFrameStyle
Dim value As System.Single

instance.InnerEdgePercent = value

value = instance.InnerEdgePercent
C#
[System.ComponentModel.CategoryAttribute("Edge Rounding")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("The amount of rounding of the outer edges relative to the corner and tube size.")]
[ISNet.Serialization.BinarySerializableAttribute()]
public System.float InnerEdgePercent {get; set;}
Delphi
public read-write property InnerEdgePercent: System.Single;
JScript
System.ComponentModel.CategoryAttribute("Edge Rounding")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("The amount of rounding of the outer edges relative to the corner and tube size.")
ISNet.Serialization.BinarySerializableAttribute()
public function get,set InnerEdgePercent : System.float
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Edge Rounding")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("The amount of rounding of the outer edges relative to the corner and tube size.")]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.float get_InnerEdgePercent();
public: __property void set_InnerEdgePercent(
   System.float value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Edge Rounding")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("The amount of rounding of the outer edges relative to the corner and tube size.")]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.float InnerEdgePercent {
   System.float get();
   void set (    System.float value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartImageFrameStyle Class
ChartImageFrameStyle Members


LightBorderStyle Property

[image]
Intersoft WebGrid Documentation
LightBorderStyle Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartImageFrameStyle Class : LightBorderStyle Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Appearance")>
<ISNet.Serialization.BinarySerializableAttribute("setLightBorderStyle")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Obtains the light border style.")>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<System.ComponentModel.DefaultValueAttribute()>
Public ReadOnly Property LightBorderStyle As ChartStrokeStyle
Visual Basic (Usage) Copy Code
Dim instance As ChartImageFrameStyle
Dim value As ChartStrokeStyle

value = instance.LightBorderStyle
C#
[System.ComponentModel.CategoryAttribute("Appearance")]
[ISNet.Serialization.BinarySerializableAttribute("setLightBorderStyle")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Obtains the light border style.")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DefaultValueAttribute()]
public ChartStrokeStyle LightBorderStyle {get;}
Delphi
public read-only property LightBorderStyle: ChartStrokeStyle;
JScript
System.ComponentModel.CategoryAttribute("Appearance")
ISNet.Serialization.BinarySerializableAttribute("setLightBorderStyle")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Obtains the light border style.")
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
System.ComponentModel.DefaultValueAttribute()
public function get LightBorderStyle : ChartStrokeStyle
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Appearance")]
[ISNet.Serialization.BinarySerializableAttribute("setLightBorderStyle")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Obtains the light border style.")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property ChartStrokeStyle* get_LightBorderStyle();
C++/CLI
[System.ComponentModel.CategoryAttribute("Appearance")]
[ISNet.Serialization.BinarySerializableAttribute("setLightBorderStyle")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Obtains the light border style.")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property ChartStrokeStyle^ LightBorderStyle {
   ChartStrokeStyle^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartImageFrameStyle Class
ChartImageFrameStyle Members


LightColor Property

[image]
Intersoft WebGrid Documentation
LightColor Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartImageFrameStyle Class : LightColor Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("The light color of the bevel effect applied on the frame.")>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Bevel Effect")>
Public Property LightColor As System.Drawing.Color
Visual Basic (Usage) Copy Code
Dim instance As ChartImageFrameStyle
Dim value As System.Drawing.Color

instance.LightColor = value

value = instance.LightColor
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("The light color of the bevel effect applied on the frame.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Bevel Effect")]
public System.Drawing.Color LightColor {get; set;}
Delphi
public read-write property LightColor: System.Drawing.Color;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("The light color of the bevel effect applied on the frame.")
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Bevel Effect")
public function get,set LightColor : System.Drawing.Color
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("The light color of the bevel effect applied on the frame.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Bevel Effect")]
public: __property System.Drawing.Color get_LightColor();
public: __property void set_LightColor(
   System.Drawing.Color value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("The light color of the bevel effect applied on the frame.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Bevel Effect")]
public:
property System.Drawing.Color LightColor {
   System.Drawing.Color get();
   void set (    System.Drawing.Color value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartImageFrameStyle Class
ChartImageFrameStyle Members


LightEffectSize Property

[image]
Intersoft WebGrid Documentation
LightEffectSize Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartImageFrameStyle Class : LightEffectSize Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Controls the size of the light bevel.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Bevel Effect")>
Public Property LightEffectSize As System.Nullable(Of Single)
Visual Basic (Usage) Copy Code
Dim instance As ChartImageFrameStyle
Dim value As System.Nullable(Of Single)

instance.LightEffectSize = value

value = instance.LightEffectSize
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Controls the size of the light bevel.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Bevel Effect")]
public System.Nullable<float> LightEffectSize {get; set;}
Delphi
public read-write property LightEffectSize: System.Nullable;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DescriptionAttribute("Controls the size of the light bevel.")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Bevel Effect")
public function get,set LightEffectSize : System.Nullable
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Controls the size of the light bevel.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Bevel Effect")]
public: __property System.Nullable<float> get_LightEffectSize();
public: __property void set_LightEffectSize(
   System.Nullable<float> value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Controls the size of the light bevel.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Bevel Effect")]
public:
property System.Nullable<float> LightEffectSize {
   System.Nullable<float> get();
   void set (    System.Nullable<float> value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartImageFrameStyle Class
ChartImageFrameStyle Members


OuterEdgePercent Property

[image]
Intersoft WebGrid Documentation
OuterEdgePercent Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartImageFrameStyle Class : OuterEdgePercent Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Edge Rounding")>
<System.ComponentModel.DescriptionAttribute("The amount of rounding when the image frame has round edges.")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property OuterEdgePercent As System.Single
Visual Basic (Usage) Copy Code
Dim instance As ChartImageFrameStyle
Dim value As System.Single

instance.OuterEdgePercent = value

value = instance.OuterEdgePercent
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Edge Rounding")]
[System.ComponentModel.DescriptionAttribute("The amount of rounding when the image frame has round edges.")]
[System.ComponentModel.DefaultValueAttribute()]
public System.float OuterEdgePercent {get; set;}
Delphi
public read-write property OuterEdgePercent: System.Single;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Edge Rounding")
System.ComponentModel.DescriptionAttribute("The amount of rounding when the image frame has round edges.")
System.ComponentModel.DefaultValueAttribute()
public function get,set OuterEdgePercent : System.float
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Edge Rounding")]
[System.ComponentModel.DescriptionAttribute("The amount of rounding when the image frame has round edges.")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.float get_OuterEdgePercent();
public: __property void set_OuterEdgePercent(
   System.float value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Edge Rounding")]
[System.ComponentModel.DescriptionAttribute("The amount of rounding when the image frame has round edges.")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.float OuterEdgePercent {
   System.float get();
   void set (    System.float value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartImageFrameStyle Class
ChartImageFrameStyle Members


ShadowColor Property

[image]
Intersoft WebGrid Documentation
ShadowColor Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartImageFrameStyle Class : ShadowColor Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Bevel Effect")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("The shadow color of the bevel effect applied on the frame.")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property ShadowColor As System.Drawing.Color
Visual Basic (Usage) Copy Code
Dim instance As ChartImageFrameStyle
Dim value As System.Drawing.Color

instance.ShadowColor = value

value = instance.ShadowColor
C#
[System.ComponentModel.CategoryAttribute("Bevel Effect")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("The shadow color of the bevel effect applied on the frame.")]
[System.ComponentModel.DefaultValueAttribute()]
public System.Drawing.Color ShadowColor {get; set;}
Delphi
public read-write property ShadowColor: System.Drawing.Color;
JScript
System.ComponentModel.CategoryAttribute("Bevel Effect")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("The shadow color of the bevel effect applied on the frame.")
System.ComponentModel.DefaultValueAttribute()
public function get,set ShadowColor : System.Drawing.Color
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Bevel Effect")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("The shadow color of the bevel effect applied on the frame.")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.Drawing.Color get_ShadowColor();
public: __property void set_ShadowColor(
   System.Drawing.Color value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Bevel Effect")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("The shadow color of the bevel effect applied on the frame.")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.Drawing.Color ShadowColor {
   System.Drawing.Color get();
   void set (    System.Drawing.Color value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartImageFrameStyle Class
ChartImageFrameStyle Members


ShadowStyle Property

[image]
Intersoft WebGrid Documentation
ShadowStyle Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartImageFrameStyle Class : ShadowStyle Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<System.ComponentModel.CategoryAttribute("Appearance")>
<System.ComponentModel.DescriptionAttribute("Controls the shadow of the image frame.")>
<ISNet.Serialization.BinarySerializableAttribute("setShadowStyle")>
Public ReadOnly Property ShadowStyle As ChartShadowStyle
Visual Basic (Usage) Copy Code
Dim instance As ChartImageFrameStyle
Dim value As ChartShadowStyle

value = instance.ShadowStyle
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.DescriptionAttribute("Controls the shadow of the image frame.")]
[ISNet.Serialization.BinarySerializableAttribute("setShadowStyle")]
public ChartShadowStyle ShadowStyle {get;}
Delphi
public read-only property ShadowStyle: ChartShadowStyle;
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
System.ComponentModel.CategoryAttribute("Appearance")
System.ComponentModel.DescriptionAttribute("Controls the shadow of the image frame.")
ISNet.Serialization.BinarySerializableAttribute("setShadowStyle")
public function get ShadowStyle : ChartShadowStyle
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.DescriptionAttribute("Controls the shadow of the image frame.")]
[ISNet.Serialization.BinarySerializableAttribute("setShadowStyle")]
public: __property ChartShadowStyle* get_ShadowStyle();
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.DescriptionAttribute("Controls the shadow of the image frame.")]
[ISNet.Serialization.BinarySerializableAttribute("setShadowStyle")]
public:
property ChartShadowStyle^ ShadowStyle {
   ChartShadowStyle^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartImageFrameStyle Class
ChartImageFrameStyle Members


TubeMargins Property

[image]
Intersoft WebGrid Documentation
TubeMargins Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartImageFrameStyle Class : TubeMargins Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Dimensions")>
<System.ComponentModel.DescriptionAttribute("The tube margins the image frame.")>
<ISNet.Serialization.BinarySerializableAttribute("setTubeMargins")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<System.ComponentModel.DefaultValueAttribute()>
Public ReadOnly Property TubeMargins As ChartMarginValue
Visual Basic (Usage) Copy Code
Dim instance As ChartImageFrameStyle
Dim value As ChartMarginValue

value = instance.TubeMargins
C#
[System.ComponentModel.CategoryAttribute("Dimensions")]
[System.ComponentModel.DescriptionAttribute("The tube margins the image frame.")]
[ISNet.Serialization.BinarySerializableAttribute("setTubeMargins")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DefaultValueAttribute()]
public ChartMarginValue TubeMargins {get;}
Delphi
public read-only property TubeMargins: ChartMarginValue;
JScript
System.ComponentModel.CategoryAttribute("Dimensions")
System.ComponentModel.DescriptionAttribute("The tube margins the image frame.")
ISNet.Serialization.BinarySerializableAttribute("setTubeMargins")
System.ComponentModel.NotifyParentPropertyAttribute()
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
System.ComponentModel.DefaultValueAttribute()
public function get TubeMargins : ChartMarginValue
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Dimensions")]
[System.ComponentModel.DescriptionAttribute("The tube margins the image frame.")]
[ISNet.Serialization.BinarySerializableAttribute("setTubeMargins")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property ChartMarginValue* get_TubeMargins();
C++/CLI
[System.ComponentModel.CategoryAttribute("Dimensions")]
[System.ComponentModel.DescriptionAttribute("The tube margins the image frame.")]
[ISNet.Serialization.BinarySerializableAttribute("setTubeMargins")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property ChartMarginValue^ TubeMargins {
   ChartMarginValue^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartImageFrameStyle Class
ChartImageFrameStyle Members


Type Property

[image]
Intersoft WebGrid Documentation
Type Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartImageFrameStyle Class : Type Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("The type of the image frame.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Appearance")>
Public Property Type As ImageFrameType
Visual Basic (Usage) Copy Code
Dim instance As ChartImageFrameStyle
Dim value As ImageFrameType

instance.Type = value

value = instance.Type
C#
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("The type of the image frame.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Appearance")]
public ImageFrameType Type {get; set;}
Delphi
public read-write property Type: ImageFrameType;
JScript
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("The type of the image frame.")
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Appearance")
public function get,set Type : ImageFrameType
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("The type of the image frame.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Appearance")]
public: __property ImageFrameType get_Type();
public: __property void set_Type(
   ImageFrameType value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("The type of the image frame.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Appearance")]
public:
property ImageFrameType Type {
   ImageFrameType get();
   void set (    ImageFrameType value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartImageFrameStyle Class
ChartImageFrameStyle Members


ChartInteractiveStyle Class

[image]
Intersoft WebGrid Documentation
ChartInteractiveStyle Class
Members See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartInteractiveStyle Class

Glossary Item Box

Object Model

ChartInteractiveStyle Class

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.SerializableAttribute()>
Public Class ChartInteractiveStyle
   Inherits ISNet.WebUI.WebUIBaseClass
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Visual Basic (Usage) Copy Code
Dim instance As ChartInteractiveStyle
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public class ChartInteractiveStyle : ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Delphi
public class ChartInteractiveStyle = class(ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize)
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.SerializableAttribute()
public class ChartInteractiveStyle extends ISNet.WebUI.WebUIBaseClass implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public __gc class ChartInteractiveStyle : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public ref class ChartInteractiveStyle : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.WebGrid.Chart.ChartInteractiveStyle

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartInteractiveStyle Members
ISNet.WebUI.WebGrid.Chart Namespace


ChartInteractiveStyle Class Members

[image]
Intersoft WebGrid Documentation
ChartInteractiveStyle Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartInteractiveStyle Class

Glossary Item Box

The following tables list the members exposed by ChartInteractiveStyle.

Public Constructors

 | Name | Description
Public Constructor | ChartInteractiveStyle Constructor |
Top

Public Properties

 | Name | Description
Public Property | CursorType |
Public Property | Enabled |
Public Property | OnClick |
Public Property | OnDoubleClick |
Public Property | OnMouseOut |
Public Property | OnMouseOver |
Public Property | ToolTip |
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

ChartInteractiveStyle Class
ISNet.WebUI.WebGrid.Chart Namespace


ChartInteractiveStyle Constructor

[image]
Intersoft WebGrid Documentation
ChartInteractiveStyle Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartInteractiveStyle Class : ChartInteractiveStyle Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New ChartInteractiveStyle()
C#
public ChartInteractiveStyle()
Delphi
public ChartInteractiveStyle();
JScript
public function ChartInteractiveStyle();
Managed Extensions for C++
public: ChartInteractiveStyle();
C++/CLI
public:
ChartInteractiveStyle();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartInteractiveStyle Class
ChartInteractiveStyle Members


Clone Method

[image]
Intersoft WebGrid Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartInteractiveStyle Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As System.Object
Visual Basic (Usage) Copy Code
Dim instance As ChartInteractiveStyle
Dim value As System.Object

value = instance.Clone()
C#
public virtual System.object Clone()
Delphi
public function Clone(): System.TObject; virtual;
JScript
public function Clone() : System.Object;
Managed Extensions for C++
public: virtual System.Object* Clone();
C++/CLI
public:
virtual System.Object^ Clone();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartInteractiveStyle Class
ChartInteractiveStyle Members


CopyFrom Method

[image]
Intersoft WebGrid Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartInteractiveStyle Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartInteractiveStyle Class
ChartInteractiveStyle Members


CopyFrom(Object) Method

[image]
Intersoft WebGrid Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartInteractiveStyle Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartInteractiveStyle
Dim objSource As System.Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   System.object objSource
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartInteractiveStyle Class
ChartInteractiveStyle Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebGrid Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartInteractiveStyle Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object, _
   ByVal cloneSourceValue As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartInteractiveStyle
Dim objSource As System.Object
Dim cloneSourceValue As System.Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   System.object objSource,
   System.bool cloneSourceValue
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject;
    cloneSourceValue: System.Boolean
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object,
   cloneSourceValue : System.boolean
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource,
   System.bool cloneSourceValue
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource,
   System.bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartInteractiveStyle Class
ChartInteractiveStyle Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebGrid Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartInteractiveStyle Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartInteractiveStyle
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure DeSerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function DeSerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void DeSerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void DeSerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartInteractiveStyle Class
ChartInteractiveStyle Members


GetHashCode Method

[image]
Intersoft WebGrid Documentation
GetHashCode Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartInteractiveStyle Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As ChartInteractiveStyle
Dim value As System.Integer

value = instance.GetHashCode()
C#
public virtual System.int GetHashCode()
Delphi
public function GetHashCode(): System.Integer; virtual;
JScript
public function GetHashCode() : System.int;
Managed Extensions for C++
public: virtual System.int GetHashCode();
C++/CLI
public:
virtual System.int GetHashCode();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartInteractiveStyle Class
ChartInteractiveStyle Members


ChartInteractiveStyle Class Methods

[image]
Intersoft WebGrid Documentation
ChartInteractiveStyle Class Methods
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartInteractiveStyle Class

Glossary Item Box

For a list of all members of this type, see ChartInteractiveStyle members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

ChartInteractiveStyle Class
ISNet.WebUI.WebGrid.Chart Namespace


GetObjectData Method

[image]
Intersoft WebGrid Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartInteractiveStyle Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=False,
   UnmanagedCode=False,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=True,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Action=SecurityAction.Demand,
   Unrestricted=False)>
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartInteractiveStyle
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure GetObjectData(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
); override;
JScript
System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=,
   UnmanagedCode=,
   SkipVerification=,
   Execution=,
   ControlThread=,
   ControlEvidence=,
   ControlPolicy=,
   SerializationFormatter=,
   ControlDomainPolicy=,
   ControlPrincipal=,
   ControlAppDomain=,
   RemotingConfiguration=,
   Infrastructure=,
   BindingRedirects=,
   Action=SecurityAction.Demand,
   Unrestricted=)
public override function GetObjectData(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public: void GetObjectData(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
) override
C++/CLI
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public:
void GetObjectData(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
) override

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartInteractiveStyle Class
ChartInteractiveStyle Members


IsEmpty Method

[image]
Intersoft WebGrid Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartInteractiveStyle Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As ChartInteractiveStyle
Dim value As System.Boolean

value = instance.IsEmpty()
C#
public virtual System.bool IsEmpty()
Delphi
public function IsEmpty(): System.Boolean; virtual;
JScript
public function IsEmpty() : System.boolean;
Managed Extensions for C++
public: virtual System.bool IsEmpty();
C++/CLI
public:
virtual System.bool IsEmpty();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartInteractiveStyle Class
ChartInteractiveStyle Members


Reset Method

[image]
Intersoft WebGrid Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartInteractiveStyle Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As ChartInteractiveStyle

instance.Reset()
C#
public virtual void Reset()
Delphi
public procedure Reset(); virtual;
JScript
public function Reset();
Managed Extensions for C++
public: virtual void Reset();
C++/CLI
public:
virtual void Reset();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartInteractiveStyle Class
ChartInteractiveStyle Members


SerializeObjectData Method

[image]
Intersoft WebGrid Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartInteractiveStyle Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartInteractiveStyle
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure SerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function SerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void SerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void SerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartInteractiveStyle Class
ChartInteractiveStyle Members


ToString Method

[image]
Intersoft WebGrid Documentation
ToString Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartInteractiveStyle Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As System.String
Visual Basic (Usage) Copy Code
Dim instance As ChartInteractiveStyle
Dim value As System.String

value = instance.ToString()
C#
public virtual System.string ToString()
Delphi
public function ToString(): System.String; virtual;
JScript
public function ToString() : System.String;
Managed Extensions for C++
public: virtual System.string* ToString();
C++/CLI
public:
virtual System.String^ ToString();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartInteractiveStyle Class
ChartInteractiveStyle Members


ChartInteractiveStyle Class Properties

[image]
Intersoft WebGrid Documentation
ChartInteractiveStyle Class Properties
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartInteractiveStyle Class

Glossary Item Box

For a list of all members of this type, see ChartInteractiveStyle members.

Public Properties

 | Name | Description
Public Property | CursorType |
Public Property | Enabled |
Public Property | OnClick |
Public Property | OnDoubleClick |
Public Property | OnMouseOut |
Public Property | OnMouseOver |
Public Property | ToolTip |
Top

See Also

Reference

ChartInteractiveStyle Class
ISNet.WebUI.WebGrid.Chart Namespace


ChartInteractiveStyle Constructor

[image]
Intersoft WebGrid Documentation
ChartInteractiveStyle Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartInteractiveStyle Class : ChartInteractiveStyle Constructor

Glossary Item Box

Overload List

Overload | Description
ChartInteractiveStyle Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartInteractiveStyle Class
ChartInteractiveStyle Members


CursorType Property

[image]
Intersoft WebGrid Documentation
CursorType Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartInteractiveStyle Class : CursorType Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("The cursor type when the mouse is over the object.")>
<System.ComponentModel.CategoryAttribute("General")>
Public Property CursorType As ISNet.WebUI.Cursors
Visual Basic (Usage) Copy Code
Dim instance As ChartInteractiveStyle
Dim value As ISNet.WebUI.Cursors

instance.CursorType = value

value = instance.CursorType
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("The cursor type when the mouse is over the object.")]
[System.ComponentModel.CategoryAttribute("General")]
public ISNet.WebUI.Cursors CursorType {get; set;}
Delphi
public read-write property CursorType: ISNet.WebUI.Cursors;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("The cursor type when the mouse is over the object.")
System.ComponentModel.CategoryAttribute("General")
public function get,set CursorType : ISNet.WebUI.Cursors
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("The cursor type when the mouse is over the object.")]
[System.ComponentModel.CategoryAttribute("General")]
public: __property ISNet.WebUI.Cursors get_CursorType();
public: __property void set_CursorType(
   ISNet.WebUI.Cursors value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("The cursor type when the mouse is over the object.")]
[System.ComponentModel.CategoryAttribute("General")]
public:
property ISNet.WebUI.Cursors CursorType {
   ISNet.WebUI.Cursors get();
   void set (    ISNet.WebUI.Cursors value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartInteractiveStyle Class
ChartInteractiveStyle Members


Enabled Property

[image]
Intersoft WebGrid Documentation
Enabled Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartInteractiveStyle Class : Enabled Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("General")>
<System.ComponentModel.DescriptionAttribute("Enable the interactive style behavior.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
Public Property Enabled As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As ChartInteractiveStyle
Dim value As System.Boolean

instance.Enabled = value

value = instance.Enabled
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DescriptionAttribute("Enable the interactive style behavior.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public System.bool Enabled {get; set;}
Delphi
public read-write property Enabled: System.Boolean;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("General")
System.ComponentModel.DescriptionAttribute("Enable the interactive style behavior.")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
public function get,set Enabled : System.boolean
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DescriptionAttribute("Enable the interactive style behavior.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.bool get_Enabled();
public: __property void set_Enabled(
   System.bool value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DescriptionAttribute("Enable the interactive style behavior.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.bool Enabled {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartInteractiveStyle Class
ChartInteractiveStyle Members


OnClick Property

[image]
Intersoft WebGrid Documentation
OnClick Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartInteractiveStyle Class : OnClick Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Client side event when a mouse is clicked on the object.")>
<System.ComponentModel.CategoryAttribute("General")>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property OnClick As System.String
Visual Basic (Usage) Copy Code
Dim instance As ChartInteractiveStyle
Dim value As System.String

instance.OnClick = value

value = instance.OnClick
C#
[System.ComponentModel.DescriptionAttribute("Client side event when a mouse is clicked on the object.")]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.string OnClick {get; set;}
Delphi
public read-write property OnClick: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Client side event when a mouse is clicked on the object.")
System.ComponentModel.CategoryAttribute("General")
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set OnClick : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Client side event when a mouse is clicked on the object.")]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.string* get_OnClick();
public: __property void set_OnClick(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Client side event when a mouse is clicked on the object.")]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.String^ OnClick {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartInteractiveStyle Class
ChartInteractiveStyle Members


OnDoubleClick Property

[image]
Intersoft WebGrid Documentation
OnDoubleClick Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartInteractiveStyle Class : OnDoubleClick Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("General")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Client side event when a mouse is double clicked on the object.")>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property OnDoubleClick As System.String
Visual Basic (Usage) Copy Code
Dim instance As ChartInteractiveStyle
Dim value As System.String

instance.OnDoubleClick = value

value = instance.OnDoubleClick
C#
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Client side event when a mouse is double clicked on the object.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public System.string OnDoubleClick {get; set;}
Delphi
public read-write property OnDoubleClick: System.String;
JScript
System.ComponentModel.CategoryAttribute("General")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Client side event when a mouse is double clicked on the object.")
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get,set OnDoubleClick : System.String
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Client side event when a mouse is double clicked on the object.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.string* get_OnDoubleClick();
public: __property void set_OnDoubleClick(
   System.string* value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Client side event when a mouse is double clicked on the object.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.String^ OnDoubleClick {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartInteractiveStyle Class
ChartInteractiveStyle Members


OnMouseOut Property

[image]
Intersoft WebGrid Documentation
OnMouseOut Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartInteractiveStyle Class : OnMouseOut Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("General")>
<System.ComponentModel.DescriptionAttribute("Client side event when a mouse is moved out an object.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
Public Property OnMouseOut As System.String
Visual Basic (Usage) Copy Code
Dim instance As ChartInteractiveStyle
Dim value As System.String

instance.OnMouseOut = value

value = instance.OnMouseOut
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DescriptionAttribute("Client side event when a mouse is moved out an object.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public System.string OnMouseOut {get; set;}
Delphi
public read-write property OnMouseOut: System.String;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("General")
System.ComponentModel.DescriptionAttribute("Client side event when a mouse is moved out an object.")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
public function get,set OnMouseOut : System.String
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DescriptionAttribute("Client side event when a mouse is moved out an object.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.string* get_OnMouseOut();
public: __property void set_OnMouseOut(
   System.string* value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DescriptionAttribute("Client side event when a mouse is moved out an object.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.String^ OnMouseOut {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartInteractiveStyle Class
ChartInteractiveStyle Members


OnMouseOver Property

[image]
Intersoft WebGrid Documentation
OnMouseOver Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartInteractiveStyle Class : OnMouseOver Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("General")>
<System.ComponentModel.DescriptionAttribute("Client side event when a mouse is moved over an object.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
Public Property OnMouseOver As System.String
Visual Basic (Usage) Copy Code
Dim instance As ChartInteractiveStyle
Dim value As System.String

instance.OnMouseOver = value

value = instance.OnMouseOver
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DescriptionAttribute("Client side event when a mouse is moved over an object.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public System.string OnMouseOver {get; set;}
Delphi
public read-write property OnMouseOver: System.String;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("General")
System.ComponentModel.DescriptionAttribute("Client side event when a mouse is moved over an object.")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
public function get,set OnMouseOver : System.String
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DescriptionAttribute("Client side event when a mouse is moved over an object.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.string* get_OnMouseOver();
public: __property void set_OnMouseOver(
   System.string* value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DescriptionAttribute("Client side event when a mouse is moved over an object.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.String^ OnMouseOver {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartInteractiveStyle Class
ChartInteractiveStyle Members


ToolTip Property

[image]
Intersoft WebGrid Documentation
ToolTip Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartInteractiveStyle Class : ToolTip Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("General")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("The tooltip of the object when the mouse passes over it.")>
Public Property ToolTip As System.String
Visual Basic (Usage) Copy Code
Dim instance As ChartInteractiveStyle
Dim value As System.String

instance.ToolTip = value

value = instance.ToolTip
C#
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("The tooltip of the object when the mouse passes over it.")]
public System.string ToolTip {get; set;}
Delphi
public read-write property ToolTip: System.String;
JScript
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("General")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("The tooltip of the object when the mouse passes over it.")
public function get,set ToolTip : System.String
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("The tooltip of the object when the mouse passes over it.")]
public: __property System.string* get_ToolTip();
public: __property void set_ToolTip(
   System.string* value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("The tooltip of the object when the mouse passes over it.")]
public:
property System.String^ ToolTip {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartInteractiveStyle Class
ChartInteractiveStyle Members


ChartInteractiveUISettings Class

[image]
Intersoft WebGrid Documentation
ChartInteractiveUISettings Class
Members See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartInteractiveUISettings Class

Glossary Item Box

Object Model

ChartInteractiveUISettings Class

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.SerializableAttribute()>
Public Class ChartInteractiveUISettings
   Inherits ISNet.WebUI.WebUIBaseClass
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Visual Basic (Usage) Copy Code
Dim instance As ChartInteractiveUISettings
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public class ChartInteractiveUISettings : ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Delphi
public class ChartInteractiveUISettings = class(ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize)
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.SerializableAttribute()
public class ChartInteractiveUISettings extends ISNet.WebUI.WebUIBaseClass implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public __gc class ChartInteractiveUISettings : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public ref class ChartInteractiveUISettings : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.WebGrid.Chart.ChartInteractiveUISettings

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartInteractiveUISettings Members
ISNet.WebUI.WebGrid.Chart Namespace


ChartInteractiveUISettings Class Members

[image]
Intersoft WebGrid Documentation
ChartInteractiveUISettings Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartInteractiveUISettings Class

Glossary Item Box

The following tables list the members exposed by ChartInteractiveUISettings.

Public Constructors

 | Name | Description
Public Constructor | ChartInteractiveUISettings Constructor |
Top

Public Properties

 | Name | Description
Public Property | ChartAutoRefresh |
Public Property | ChartTypeRibbon |
Public Property | FilterAndSortRibbon |
Public Property | RibbonState |
Public Property | ShowOrHideRibbon |
Public Property | TitlesRibbon |
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

ChartInteractiveUISettings Class
ISNet.WebUI.WebGrid.Chart Namespace


ChartInteractiveUISettings Constructor

[image]
Intersoft WebGrid Documentation
ChartInteractiveUISettings Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartInteractiveUISettings Class : ChartInteractiveUISettings Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New ChartInteractiveUISettings()
C#
public ChartInteractiveUISettings()
Delphi
public ChartInteractiveUISettings();
JScript
public function ChartInteractiveUISettings();
Managed Extensions for C++
public: ChartInteractiveUISettings();
C++/CLI
public:
ChartInteractiveUISettings();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartInteractiveUISettings Class
ChartInteractiveUISettings Members


Clone Method

[image]
Intersoft WebGrid Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartInteractiveUISettings Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As System.Object
Visual Basic (Usage) Copy Code
Dim instance As ChartInteractiveUISettings
Dim value As System.Object

value = instance.Clone()
C#
public virtual System.object Clone()
Delphi
public function Clone(): System.TObject; virtual;
JScript
public function Clone() : System.Object;
Managed Extensions for C++
public: virtual System.Object* Clone();
C++/CLI
public:
virtual System.Object^ Clone();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartInteractiveUISettings Class
ChartInteractiveUISettings Members


CopyFrom Method

[image]
Intersoft WebGrid Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartInteractiveUISettings Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartInteractiveUISettings Class
ChartInteractiveUISettings Members


CopyFrom(Object) Method

[image]
Intersoft WebGrid Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartInteractiveUISettings Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartInteractiveUISettings
Dim objSource As System.Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   System.object objSource
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartInteractiveUISettings Class
ChartInteractiveUISettings Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebGrid Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartInteractiveUISettings Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object, _
   ByVal cloneSourceValue As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartInteractiveUISettings
Dim objSource As System.Object
Dim cloneSourceValue As System.Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   System.object objSource,
   System.bool cloneSourceValue
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject;
    cloneSourceValue: System.Boolean
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object,
   cloneSourceValue : System.boolean
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource,
   System.bool cloneSourceValue
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource,
   System.bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartInteractiveUISettings Class
ChartInteractiveUISettings Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebGrid Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartInteractiveUISettings Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartInteractiveUISettings
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure DeSerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function DeSerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void DeSerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void DeSerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartInteractiveUISettings Class
ChartInteractiveUISettings Members


GetHashCode Method

[image]
Intersoft WebGrid Documentation
GetHashCode Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartInteractiveUISettings Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As ChartInteractiveUISettings
Dim value As System.Integer

value = instance.GetHashCode()
C#
public virtual System.int GetHashCode()
Delphi
public function GetHashCode(): System.Integer; virtual;
JScript
public function GetHashCode() : System.int;
Managed Extensions for C++
public: virtual System.int GetHashCode();
C++/CLI
public:
virtual System.int GetHashCode();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartInteractiveUISettings Class
ChartInteractiveUISettings Members


ChartInteractiveUISettings Class Methods

[image]
Intersoft WebGrid Documentation
ChartInteractiveUISettings Class Methods
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartInteractiveUISettings Class

Glossary Item Box

For a list of all members of this type, see ChartInteractiveUISettings members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

ChartInteractiveUISettings Class
ISNet.WebUI.WebGrid.Chart Namespace


GetObjectData Method

[image]
Intersoft WebGrid Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartInteractiveUISettings Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=False,
   UnmanagedCode=False,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=True,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Action=SecurityAction.Demand,
   Unrestricted=False)>
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartInteractiveUISettings
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure GetObjectData(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
); override;
JScript
System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=,
   UnmanagedCode=,
   SkipVerification=,
   Execution=,
   ControlThread=,
   ControlEvidence=,
   ControlPolicy=,
   SerializationFormatter=,
   ControlDomainPolicy=,
   ControlPrincipal=,
   ControlAppDomain=,
   RemotingConfiguration=,
   Infrastructure=,
   BindingRedirects=,
   Action=SecurityAction.Demand,
   Unrestricted=)
public override function GetObjectData(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public: void GetObjectData(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
) override
C++/CLI
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public:
void GetObjectData(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
) override

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartInteractiveUISettings Class
ChartInteractiveUISettings Members


IsEmpty Method

[image]
Intersoft WebGrid Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartInteractiveUISettings Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As ChartInteractiveUISettings
Dim value As System.Boolean

value = instance.IsEmpty()
C#
public virtual System.bool IsEmpty()
Delphi
public function IsEmpty(): System.Boolean; virtual;
JScript
public function IsEmpty() : System.boolean;
Managed Extensions for C++
public: virtual System.bool IsEmpty();
C++/CLI
public:
virtual System.bool IsEmpty();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartInteractiveUISettings Class
ChartInteractiveUISettings Members


Reset Method

[image]
Intersoft WebGrid Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartInteractiveUISettings Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As ChartInteractiveUISettings

instance.Reset()
C#
public virtual void Reset()
Delphi
public procedure Reset(); virtual;
JScript
public function Reset();
Managed Extensions for C++
public: virtual void Reset();
C++/CLI
public:
virtual void Reset();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartInteractiveUISettings Class
ChartInteractiveUISettings Members


SerializeObjectData Method

[image]
Intersoft WebGrid Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartInteractiveUISettings Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartInteractiveUISettings
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure SerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function SerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void SerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void SerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartInteractiveUISettings Class
ChartInteractiveUISettings Members


ToString Method

[image]
Intersoft WebGrid Documentation
ToString Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartInteractiveUISettings Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As System.String
Visual Basic (Usage) Copy Code
Dim instance As ChartInteractiveUISettings
Dim value As System.String

value = instance.ToString()
C#
public virtual System.string ToString()
Delphi
public function ToString(): System.String; virtual;
JScript
public function ToString() : System.String;
Managed Extensions for C++
public: virtual System.string* ToString();
C++/CLI
public:
virtual System.String^ ToString();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartInteractiveUISettings Class
ChartInteractiveUISettings Members


ChartInteractiveUISettings Class Properties

[image]
Intersoft WebGrid Documentation
ChartInteractiveUISettings Class Properties
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartInteractiveUISettings Class

Glossary Item Box

For a list of all members of this type, see ChartInteractiveUISettings members.

Public Properties

 | Name | Description
Public Property | ChartAutoRefresh |
Public Property | ChartTypeRibbon |
Public Property | FilterAndSortRibbon |
Public Property | RibbonState |
Public Property | ShowOrHideRibbon |
Public Property | TitlesRibbon |
Top

See Also

Reference

ChartInteractiveUISettings Class
ISNet.WebUI.WebGrid.Chart Namespace


ChartInteractiveUISettings Constructor

[image]
Intersoft WebGrid Documentation
ChartInteractiveUISettings Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartInteractiveUISettings Class : ChartInteractiveUISettings Constructor

Glossary Item Box

Overload List

Overload | Description
ChartInteractiveUISettings Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartInteractiveUISettings Class
ChartInteractiveUISettings Members


ChartAutoRefresh Property

[image]
Intersoft WebGrid Documentation
ChartAutoRefresh Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartInteractiveUISettings Class : ChartAutoRefresh Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Options")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Indicates whether or not chart auto refresh is activated.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property ChartAutoRefresh As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As ChartInteractiveUISettings
Dim value As System.Boolean

instance.ChartAutoRefresh = value

value = instance.ChartAutoRefresh
C#
[System.ComponentModel.CategoryAttribute("Options")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Indicates whether or not chart auto refresh is activated.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public System.bool ChartAutoRefresh {get; set;}
Delphi
public read-write property ChartAutoRefresh: System.Boolean;
JScript
System.ComponentModel.CategoryAttribute("Options")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Indicates whether or not chart auto refresh is activated.")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get,set ChartAutoRefresh : System.boolean
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Options")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Indicates whether or not chart auto refresh is activated.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.bool get_ChartAutoRefresh();
public: __property void set_ChartAutoRefresh(
   System.bool value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Options")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Indicates whether or not chart auto refresh is activated.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.bool ChartAutoRefresh {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartInteractiveUISettings Class
ChartInteractiveUISettings Members


ChartTypeRibbon Property

[image]
Intersoft WebGrid Documentation
ChartTypeRibbon Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartInteractiveUISettings Class : ChartTypeRibbon Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Options")>
<System.ComponentModel.DescriptionAttribute("Controls the ChartType Ribbon.")>
<ISNet.Serialization.XmlSerializableAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute("setChartTypeRibbon")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<System.ComponentModel.DefaultValueAttribute()>
Public ReadOnly Property ChartTypeRibbon As ChartTypeRibbonSettings
Visual Basic (Usage) Copy Code
Dim instance As ChartInteractiveUISettings
Dim value As ChartTypeRibbonSettings

value = instance.ChartTypeRibbon
C#
[System.ComponentModel.CategoryAttribute("Options")]
[System.ComponentModel.DescriptionAttribute("Controls the ChartType Ribbon.")]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute("setChartTypeRibbon")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DefaultValueAttribute()]
public ChartTypeRibbonSettings ChartTypeRibbon {get;}
Delphi
public read-only property ChartTypeRibbon: ChartTypeRibbonSettings;
JScript
System.ComponentModel.CategoryAttribute("Options")
System.ComponentModel.DescriptionAttribute("Controls the ChartType Ribbon.")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute("setChartTypeRibbon")
System.ComponentModel.NotifyParentPropertyAttribute()
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
System.ComponentModel.DefaultValueAttribute()
public function get ChartTypeRibbon : ChartTypeRibbonSettings
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Options")]
[System.ComponentModel.DescriptionAttribute("Controls the ChartType Ribbon.")]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute("setChartTypeRibbon")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property ChartTypeRibbonSettings* get_ChartTypeRibbon();
C++/CLI
[System.ComponentModel.CategoryAttribute("Options")]
[System.ComponentModel.DescriptionAttribute("Controls the ChartType Ribbon.")]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute("setChartTypeRibbon")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property ChartTypeRibbonSettings^ ChartTypeRibbon {
   ChartTypeRibbonSettings^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartInteractiveUISettings Class
ChartInteractiveUISettings Members


FilterAndSortRibbon Property

[image]
Intersoft WebGrid Documentation
FilterAndSortRibbon Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartInteractiveUISettings Class : FilterAndSortRibbon Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute("setFilterAndSortRibbon")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<System.ComponentModel.CategoryAttribute("Options")>
<System.ComponentModel.DescriptionAttribute("Controls the FilterAndSort Ribbon.")>
Public ReadOnly Property FilterAndSortRibbon As ChartFilterAndSortRibbonSettings
Visual Basic (Usage) Copy Code
Dim instance As ChartInteractiveUISettings
Dim value As ChartFilterAndSortRibbonSettings

value = instance.FilterAndSortRibbon
C#
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute("setFilterAndSortRibbon")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.CategoryAttribute("Options")]
[System.ComponentModel.DescriptionAttribute("Controls the FilterAndSort Ribbon.")]
public ChartFilterAndSortRibbonSettings FilterAndSortRibbon {get;}
Delphi
public read-only property FilterAndSortRibbon: ChartFilterAndSortRibbonSettings;
JScript
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute("setFilterAndSortRibbon")
System.ComponentModel.NotifyParentPropertyAttribute()
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
System.ComponentModel.CategoryAttribute("Options")
System.ComponentModel.DescriptionAttribute("Controls the FilterAndSort Ribbon.")
public function get FilterAndSortRibbon : ChartFilterAndSortRibbonSettings
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute("setFilterAndSortRibbon")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.CategoryAttribute("Options")]
[System.ComponentModel.DescriptionAttribute("Controls the FilterAndSort Ribbon.")]
public: __property ChartFilterAndSortRibbonSettings* get_FilterAndSortRibbon();
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute("setFilterAndSortRibbon")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.CategoryAttribute("Options")]
[System.ComponentModel.DescriptionAttribute("Controls the FilterAndSort Ribbon.")]
public:
property ChartFilterAndSortRibbonSettings^ FilterAndSortRibbon {
   ChartFilterAndSortRibbonSettings^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartInteractiveUISettings Class
ChartInteractiveUISettings Members


RibbonState Property

[image]
Intersoft WebGrid Documentation
RibbonState Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartInteractiveUISettings Class : RibbonState Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Control the Ribbon's initial state.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Options")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property RibbonState As RibbonState
Visual Basic (Usage) Copy Code
Dim instance As ChartInteractiveUISettings
Dim value As RibbonState

instance.RibbonState = value

value = instance.RibbonState
C#
[System.ComponentModel.DescriptionAttribute("Control the Ribbon's initial state.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Options")]
[System.ComponentModel.DefaultValueAttribute()]
public RibbonState RibbonState {get; set;}
Delphi
public read-write property RibbonState: RibbonState;
JScript
System.ComponentModel.DescriptionAttribute("Control the Ribbon's initial state.")
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Options")
System.ComponentModel.DefaultValueAttribute()
public function get,set RibbonState : RibbonState
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Control the Ribbon's initial state.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Options")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property RibbonState get_RibbonState();
public: __property void set_RibbonState(
   RibbonState value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Control the Ribbon's initial state.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Options")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property RibbonState RibbonState {
   RibbonState get();
   void set (    RibbonState value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartInteractiveUISettings Class
ChartInteractiveUISettings Members


ShowOrHideRibbon Property

[image]
Intersoft WebGrid Documentation
ShowOrHideRibbon Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartInteractiveUISettings Class : ShowOrHideRibbon Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.CategoryAttribute("Options")>
<System.ComponentModel.DescriptionAttribute("Controls the ShowOrHide Ribbon.")>
<ISNet.Serialization.XmlSerializableAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute("setShowOrHideRibbon")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
Public ReadOnly Property ShowOrHideRibbon As ChartShowOrHideRibbonSettings
Visual Basic (Usage) Copy Code
Dim instance As ChartInteractiveUISettings
Dim value As ChartShowOrHideRibbonSettings

value = instance.ShowOrHideRibbon
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.CategoryAttribute("Options")]
[System.ComponentModel.DescriptionAttribute("Controls the ShowOrHide Ribbon.")]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute("setShowOrHideRibbon")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
public ChartShowOrHideRibbonSettings ShowOrHideRibbon {get;}
Delphi
public read-only property ShowOrHideRibbon: ChartShowOrHideRibbonSettings;
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.CategoryAttribute("Options")
System.ComponentModel.DescriptionAttribute("Controls the ShowOrHide Ribbon.")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute("setShowOrHideRibbon")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
public function get ShowOrHideRibbon : ChartShowOrHideRibbonSettings
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.CategoryAttribute("Options")]
[System.ComponentModel.DescriptionAttribute("Controls the ShowOrHide Ribbon.")]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute("setShowOrHideRibbon")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
public: __property ChartShowOrHideRibbonSettings* get_ShowOrHideRibbon();
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.CategoryAttribute("Options")]
[System.ComponentModel.DescriptionAttribute("Controls the ShowOrHide Ribbon.")]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute("setShowOrHideRibbon")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
public:
property ChartShowOrHideRibbonSettings^ ShowOrHideRibbon {
   ChartShowOrHideRibbonSettings^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartInteractiveUISettings Class
ChartInteractiveUISettings Members


TitlesRibbon Property

[image]
Intersoft WebGrid Documentation
TitlesRibbon Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartInteractiveUISettings Class : TitlesRibbon Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Controls the Title Ribbon.")>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute("setTitlesRibbon")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<System.ComponentModel.CategoryAttribute("Options")>
<ISNet.Serialization.XmlSerializableAttribute(True)>
Public ReadOnly Property TitlesRibbon As ChartTitleRibbonSettings
Visual Basic (Usage) Copy Code
Dim instance As ChartInteractiveUISettings
Dim value As ChartTitleRibbonSettings

value = instance.TitlesRibbon
C#
[System.ComponentModel.DescriptionAttribute("Controls the Title Ribbon.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute("setTitlesRibbon")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.CategoryAttribute("Options")]
[ISNet.Serialization.XmlSerializableAttribute(true)]
public ChartTitleRibbonSettings TitlesRibbon {get;}
Delphi
public read-only property TitlesRibbon: ChartTitleRibbonSettings;
JScript
System.ComponentModel.DescriptionAttribute("Controls the Title Ribbon.")
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute("setTitlesRibbon")
System.ComponentModel.NotifyParentPropertyAttribute()
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
System.ComponentModel.CategoryAttribute("Options")
ISNet.Serialization.XmlSerializableAttribute()
public function get TitlesRibbon : ChartTitleRibbonSettings
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Controls the Title Ribbon.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute("setTitlesRibbon")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.CategoryAttribute("Options")]
[ISNet.Serialization.XmlSerializableAttribute(true)]
public: __property ChartTitleRibbonSettings* get_TitlesRibbon();
C++/CLI
[System.ComponentModel.DescriptionAttribute("Controls the Title Ribbon.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute("setTitlesRibbon")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.CategoryAttribute("Options")]
[ISNet.Serialization.XmlSerializableAttribute(true)]
public:
property ChartTitleRibbonSettings^ TitlesRibbon {
   ChartTitleRibbonSettings^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartInteractiveUISettings Class
ChartInteractiveUISettings Members


ChartLabelSettings Class

[image]
Intersoft WebGrid Documentation
ChartLabelSettings Class
Members See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartLabelSettings Class

Glossary Item Box

Object Model

ChartLabelSettings Class

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.SerializableAttribute()>
Public Class ChartLabelSettings
   Inherits ISNet.WebUI.WebUIBaseClass
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Visual Basic (Usage) Copy Code
Dim instance As ChartLabelSettings
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public class ChartLabelSettings : ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Delphi
public class ChartLabelSettings = class(ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize)
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.SerializableAttribute()
public class ChartLabelSettings extends ISNet.WebUI.WebUIBaseClass implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public __gc class ChartLabelSettings : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public ref class ChartLabelSettings : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.WebGrid.Chart.ChartLabelSettings

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartLabelSettings Members
ISNet.WebUI.WebGrid.Chart Namespace


ChartLabelSettings Class Members

[image]
Intersoft WebGrid Documentation
ChartLabelSettings Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartLabelSettings Class

Glossary Item Box

The following tables list the members exposed by ChartLabelSettings.

Public Constructors

 | Name | Description
Public Constructor | ChartLabelSettings Constructor |
Top

Public Properties

 | Name | Description
Public Property | Alignment |
Public Property | Text |
Public Property | TextStyle |
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

ChartLabelSettings Class
ISNet.WebUI.WebGrid.Chart Namespace


ChartLabelSettings Constructor

[image]
Intersoft WebGrid Documentation
ChartLabelSettings Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartLabelSettings Class : ChartLabelSettings Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New ChartLabelSettings()
C#
public ChartLabelSettings()
Delphi
public ChartLabelSettings();
JScript
public function ChartLabelSettings();
Managed Extensions for C++
public: ChartLabelSettings();
C++/CLI
public:
ChartLabelSettings();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartLabelSettings Class
ChartLabelSettings Members


Clone Method

[image]
Intersoft WebGrid Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartLabelSettings Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As System.Object
Visual Basic (Usage) Copy Code
Dim instance As ChartLabelSettings
Dim value As System.Object

value = instance.Clone()
C#
public virtual System.object Clone()
Delphi
public function Clone(): System.TObject; virtual;
JScript
public function Clone() : System.Object;
Managed Extensions for C++
public: virtual System.Object* Clone();
C++/CLI
public:
virtual System.Object^ Clone();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartLabelSettings Class
ChartLabelSettings Members


CopyFrom Method

[image]
Intersoft WebGrid Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartLabelSettings Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartLabelSettings Class
ChartLabelSettings Members


CopyFrom(Object) Method

[image]
Intersoft WebGrid Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartLabelSettings Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartLabelSettings
Dim objSource As System.Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   System.object objSource
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartLabelSettings Class
ChartLabelSettings Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebGrid Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartLabelSettings Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object, _
   ByVal cloneSourceValue As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartLabelSettings
Dim objSource As System.Object
Dim cloneSourceValue As System.Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   System.object objSource,
   System.bool cloneSourceValue
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject;
    cloneSourceValue: System.Boolean
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object,
   cloneSourceValue : System.boolean
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource,
   System.bool cloneSourceValue
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource,
   System.bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartLabelSettings Class
ChartLabelSettings Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebGrid Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartLabelSettings Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartLabelSettings
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure DeSerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function DeSerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void DeSerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void DeSerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartLabelSettings Class
ChartLabelSettings Members


GetHashCode Method

[image]
Intersoft WebGrid Documentation
GetHashCode Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartLabelSettings Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As ChartLabelSettings
Dim value As System.Integer

value = instance.GetHashCode()
C#
public virtual System.int GetHashCode()
Delphi
public function GetHashCode(): System.Integer; virtual;
JScript
public function GetHashCode() : System.int;
Managed Extensions for C++
public: virtual System.int GetHashCode();
C++/CLI
public:
virtual System.int GetHashCode();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartLabelSettings Class
ChartLabelSettings Members


ChartLabelSettings Class Methods

[image]
Intersoft WebGrid Documentation
ChartLabelSettings Class Methods
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartLabelSettings Class

Glossary Item Box

For a list of all members of this type, see ChartLabelSettings members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

ChartLabelSettings Class
ISNet.WebUI.WebGrid.Chart Namespace


GetObjectData Method

[image]
Intersoft WebGrid Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartLabelSettings Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=False,
   UnmanagedCode=False,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=True,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Action=SecurityAction.Demand,
   Unrestricted=False)>
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartLabelSettings
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure GetObjectData(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
); override;
JScript
System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=,
   UnmanagedCode=,
   SkipVerification=,
   Execution=,
   ControlThread=,
   ControlEvidence=,
   ControlPolicy=,
   SerializationFormatter=,
   ControlDomainPolicy=,
   ControlPrincipal=,
   ControlAppDomain=,
   RemotingConfiguration=,
   Infrastructure=,
   BindingRedirects=,
   Action=SecurityAction.Demand,
   Unrestricted=)
public override function GetObjectData(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public: void GetObjectData(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
) override
C++/CLI
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public:
void GetObjectData(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
) override

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartLabelSettings Class
ChartLabelSettings Members


IsEmpty Method

[image]
Intersoft WebGrid Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartLabelSettings Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As ChartLabelSettings
Dim value As System.Boolean

value = instance.IsEmpty()
C#
public virtual System.bool IsEmpty()
Delphi
public function IsEmpty(): System.Boolean; virtual;
JScript
public function IsEmpty() : System.boolean;
Managed Extensions for C++
public: virtual System.bool IsEmpty();
C++/CLI
public:
virtual System.bool IsEmpty();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartLabelSettings Class
ChartLabelSettings Members


Reset Method

[image]
Intersoft WebGrid Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartLabelSettings Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As ChartLabelSettings

instance.Reset()
C#
public virtual void Reset()
Delphi
public procedure Reset(); virtual;
JScript
public function Reset();
Managed Extensions for C++
public: virtual void Reset();
C++/CLI
public:
virtual void Reset();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartLabelSettings Class
ChartLabelSettings Members


SerializeObjectData Method

[image]
Intersoft WebGrid Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartLabelSettings Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartLabelSettings
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure SerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function SerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void SerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void SerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartLabelSettings Class
ChartLabelSettings Members


ToString Method

[image]
Intersoft WebGrid Documentation
ToString Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartLabelSettings Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As System.String
Visual Basic (Usage) Copy Code
Dim instance As ChartLabelSettings
Dim value As System.String

value = instance.ToString()
C#
public virtual System.string ToString()
Delphi
public function ToString(): System.String; virtual;
JScript
public function ToString() : System.String;
Managed Extensions for C++
public: virtual System.string* ToString();
C++/CLI
public:
virtual System.String^ ToString();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartLabelSettings Class
ChartLabelSettings Members


ChartLabelSettings Class Properties

[image]
Intersoft WebGrid Documentation
ChartLabelSettings Class Properties
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartLabelSettings Class

Glossary Item Box

For a list of all members of this type, see ChartLabelSettings members.

Public Properties

 | Name | Description
Public Property | Alignment |
Public Property | Text |
Public Property | TextStyle |
Top

See Also

Reference

ChartLabelSettings Class
ISNet.WebUI.WebGrid.Chart Namespace


ChartLabelSettings Constructor

[image]
Intersoft WebGrid Documentation
ChartLabelSettings Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartLabelSettings Class : ChartLabelSettings Constructor

Glossary Item Box

Overload List

Overload | Description
ChartLabelSettings Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartLabelSettings Class
ChartLabelSettings Members


Alignment Property

[image]
Intersoft WebGrid Documentation
Alignment Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartLabelSettings Class : Alignment Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("The alignment of the header text")>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Layout")>
Public Property Alignment As HeaderAlignment
Visual Basic (Usage) Copy Code
Dim instance As ChartLabelSettings
Dim value As HeaderAlignment

instance.Alignment = value

value = instance.Alignment
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("The alignment of the header text")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Layout")]
public HeaderAlignment Alignment {get; set;}
Delphi
public read-write property Alignment: HeaderAlignment;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("The alignment of the header text")
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Layout")
public function get,set Alignment : HeaderAlignment
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("The alignment of the header text")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Layout")]
public: __property HeaderAlignment get_Alignment();
public: __property void set_Alignment(
   HeaderAlignment value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("The alignment of the header text")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Layout")]
public:
property HeaderAlignment Alignment {
   HeaderAlignment get();
   void set (    HeaderAlignment value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartLabelSettings Class
ChartLabelSettings Members


Text Property

[image]
Intersoft WebGrid Documentation
Text Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartLabelSettings Class : Text Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("The text displayed by the label.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Text")>
Public Property Text As System.String
Visual Basic (Usage) Copy Code
Dim instance As ChartLabelSettings
Dim value As System.String

instance.Text = value

value = instance.Text
C#
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("The text displayed by the label.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Text")]
public System.string Text {get; set;}
Delphi
public read-write property Text: System.String;
JScript
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("The text displayed by the label.")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Text")
public function get,set Text : System.String
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("The text displayed by the label.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Text")]
public: __property System.string* get_Text();
public: __property void set_Text(
   System.string* value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("The text displayed by the label.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Text")]
public:
property System.String^ Text {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartLabelSettings Class
ChartLabelSettings Members


TextStyle Property

[image]
Intersoft WebGrid Documentation
TextStyle Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartLabelSettings Class : TextStyle Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Controls the text style appearance of the label.")>
<ISNet.Serialization.BinarySerializableAttribute("setTextStyle")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<System.ComponentModel.CategoryAttribute("Text")>
Public ReadOnly Property TextStyle As ChartTextStyle
Visual Basic (Usage) Copy Code
Dim instance As ChartLabelSettings
Dim value As ChartTextStyle

value = instance.TextStyle
C#
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Controls the text style appearance of the label.")]
[ISNet.Serialization.BinarySerializableAttribute("setTextStyle")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.CategoryAttribute("Text")]
public ChartTextStyle TextStyle {get;}
Delphi
public read-only property TextStyle: ChartTextStyle;
JScript
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Controls the text style appearance of the label.")
ISNet.Serialization.BinarySerializableAttribute("setTextStyle")
System.ComponentModel.NotifyParentPropertyAttribute()
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
System.ComponentModel.CategoryAttribute("Text")
public function get TextStyle : ChartTextStyle
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Controls the text style appearance of the label.")]
[ISNet.Serialization.BinarySerializableAttribute("setTextStyle")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.CategoryAttribute("Text")]
public: __property ChartTextStyle* get_TextStyle();
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Controls the text style appearance of the label.")]
[ISNet.Serialization.BinarySerializableAttribute("setTextStyle")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.CategoryAttribute("Text")]
public:
property ChartTextStyle^ TextStyle {
   ChartTextStyle^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartLabelSettings Class
ChartLabelSettings Members


ChartLegendDataSettings Class

[image]
Intersoft WebGrid Documentation
ChartLegendDataSettings Class
Members See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartLegendDataSettings Class

Glossary Item Box

Object Model

ChartLegendDataSettings Class

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.SerializableAttribute()>
Public Class ChartLegendDataSettings
   Inherits ISNet.WebUI.WebUIBaseClass
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Visual Basic (Usage) Copy Code
Dim instance As ChartLegendDataSettings
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public class ChartLegendDataSettings : ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Delphi
public class ChartLegendDataSettings = class(ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize)
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.SerializableAttribute()
public class ChartLegendDataSettings extends ISNet.WebUI.WebUIBaseClass implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public __gc class ChartLegendDataSettings : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public ref class ChartLegendDataSettings : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.WebGrid.Chart.ChartLegendDataSettings

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartLegendDataSettings Members
ISNet.WebUI.WebGrid.Chart Namespace


ChartLegendDataSettings Class Members

[image]
Intersoft WebGrid Documentation
ChartLegendDataSettings Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartLegendDataSettings Class

Glossary Item Box

The following tables list the members exposed by ChartLegendDataSettings.

Public Constructors

 | Name | Description
Public Constructor | ChartLegendDataSettings Constructor |
Top

Public Properties

 | Name | Description
Public Property | CellMargins |
Public Property | ColCount |
Public Property | ExpandMode |
Public Property | MarkSize |
Public Property | RowCount |
Public Property | TextOffset |
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

ChartLegendDataSettings Class
ISNet.WebUI.WebGrid.Chart Namespace


ChartLegendDataSettings Constructor

[image]
Intersoft WebGrid Documentation
ChartLegendDataSettings Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartLegendDataSettings Class : ChartLegendDataSettings Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New ChartLegendDataSettings()
C#
public ChartLegendDataSettings()
Delphi
public ChartLegendDataSettings();
JScript
public function ChartLegendDataSettings();
Managed Extensions for C++
public: ChartLegendDataSettings();
C++/CLI
public:
ChartLegendDataSettings();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartLegendDataSettings Class
ChartLegendDataSettings Members


Clone Method

[image]
Intersoft WebGrid Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartLegendDataSettings Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As System.Object
Visual Basic (Usage) Copy Code
Dim instance As ChartLegendDataSettings
Dim value As System.Object

value = instance.Clone()
C#
public virtual System.object Clone()
Delphi
public function Clone(): System.TObject; virtual;
JScript
public function Clone() : System.Object;
Managed Extensions for C++
public: virtual System.Object* Clone();
C++/CLI
public:
virtual System.Object^ Clone();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartLegendDataSettings Class
ChartLegendDataSettings Members


CopyFrom Method

[image]
Intersoft WebGrid Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartLegendDataSettings Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartLegendDataSettings Class
ChartLegendDataSettings Members


CopyFrom(Object) Method

[image]
Intersoft WebGrid Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartLegendDataSettings Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartLegendDataSettings
Dim objSource As System.Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   System.object objSource
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartLegendDataSettings Class
ChartLegendDataSettings Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebGrid Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartLegendDataSettings Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object, _
   ByVal cloneSourceValue As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartLegendDataSettings
Dim objSource As System.Object
Dim cloneSourceValue As System.Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   System.object objSource,
   System.bool cloneSourceValue
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject;
    cloneSourceValue: System.Boolean
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object,
   cloneSourceValue : System.boolean
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource,
   System.bool cloneSourceValue
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource,
   System.bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartLegendDataSettings Class
ChartLegendDataSettings Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebGrid Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartLegendDataSettings Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartLegendDataSettings
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure DeSerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function DeSerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void DeSerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void DeSerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartLegendDataSettings Class
ChartLegendDataSettings Members


GetHashCode Method

[image]
Intersoft WebGrid Documentation
GetHashCode Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartLegendDataSettings Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As ChartLegendDataSettings
Dim value As System.Integer

value = instance.GetHashCode()
C#
public virtual System.int GetHashCode()
Delphi
public function GetHashCode(): System.Integer; virtual;
JScript
public function GetHashCode() : System.int;
Managed Extensions for C++
public: virtual System.int GetHashCode();
C++/CLI
public:
virtual System.int GetHashCode();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartLegendDataSettings Class
ChartLegendDataSettings Members


ChartLegendDataSettings Class Methods

[image]
Intersoft WebGrid Documentation
ChartLegendDataSettings Class Methods
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartLegendDataSettings Class

Glossary Item Box

For a list of all members of this type, see ChartLegendDataSettings members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

ChartLegendDataSettings Class
ISNet.WebUI.WebGrid.Chart Namespace


GetObjectData Method

[image]
Intersoft WebGrid Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartLegendDataSettings Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=False,
   UnmanagedCode=False,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=True,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Action=SecurityAction.Demand,
   Unrestricted=False)>
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartLegendDataSettings
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure GetObjectData(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
); override;
JScript
System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=,
   UnmanagedCode=,
   SkipVerification=,
   Execution=,
   ControlThread=,
   ControlEvidence=,
   ControlPolicy=,
   SerializationFormatter=,
   ControlDomainPolicy=,
   ControlPrincipal=,
   ControlAppDomain=,
   RemotingConfiguration=,
   Infrastructure=,
   BindingRedirects=,
   Action=SecurityAction.Demand,
   Unrestricted=)
public override function GetObjectData(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public: void GetObjectData(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
) override
C++/CLI
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public:
void GetObjectData(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
) override

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartLegendDataSettings Class
ChartLegendDataSettings Members


IsEmpty Method

[image]
Intersoft WebGrid Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartLegendDataSettings Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As ChartLegendDataSettings
Dim value As System.Boolean

value = instance.IsEmpty()
C#
public virtual System.bool IsEmpty()
Delphi
public function IsEmpty(): System.Boolean; virtual;
JScript
public function IsEmpty() : System.boolean;
Managed Extensions for C++
public: virtual System.bool IsEmpty();
C++/CLI
public:
virtual System.bool IsEmpty();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartLegendDataSettings Class
ChartLegendDataSettings Members


Reset Method

[image]
Intersoft WebGrid Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartLegendDataSettings Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As ChartLegendDataSettings

instance.Reset()
C#
public virtual void Reset()
Delphi
public procedure Reset(); virtual;
JScript
public function Reset();
Managed Extensions for C++
public: virtual void Reset();
C++/CLI
public:
virtual void Reset();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartLegendDataSettings Class
ChartLegendDataSettings Members


SerializeObjectData Method

[image]
Intersoft WebGrid Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartLegendDataSettings Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartLegendDataSettings
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure SerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function SerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void SerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void SerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartLegendDataSettings Class
ChartLegendDataSettings Members


ToString Method

[image]
Intersoft WebGrid Documentation
ToString Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartLegendDataSettings Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As System.String
Visual Basic (Usage) Copy Code
Dim instance As ChartLegendDataSettings
Dim value As System.String

value = instance.ToString()
C#
public virtual System.string ToString()
Delphi
public function ToString(): System.String; virtual;
JScript
public function ToString() : System.String;
Managed Extensions for C++
public: virtual System.string* ToString();
C++/CLI
public:
virtual System.String^ ToString();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartLegendDataSettings Class
ChartLegendDataSettings Members


ChartLegendDataSettings Class Properties

[image]
Intersoft WebGrid Documentation
ChartLegendDataSettings Class Properties
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartLegendDataSettings Class

Glossary Item Box

For a list of all members of this type, see ChartLegendDataSettings members.

Public Properties

 | Name | Description
Public Property | CellMargins |
Public Property | ColCount |
Public Property | ExpandMode |
Public Property | MarkSize |
Public Property | RowCount |
Public Property | TextOffset |
Top

See Also

Reference

ChartLegendDataSettings Class
ISNet.WebUI.WebGrid.Chart Namespace


ChartLegendDataSettings Constructor

[image]
Intersoft WebGrid Documentation
ChartLegendDataSettings Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartLegendDataSettings Class : ChartLegendDataSettings Constructor

Glossary Item Box

Overload List

Overload | Description
ChartLegendDataSettings Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartLegendDataSettings Class
ChartLegendDataSettings Members


CellMargins Property

[image]
Intersoft WebGrid Documentation
CellMargins Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartLegendDataSettings Class : CellMargins Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("The margins of the cell content from the grid lines.")>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute("setCellMargins")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<System.ComponentModel.CategoryAttribute("Dimensions")>
Public ReadOnly Property CellMargins As ChartMarginValue
Visual Basic (Usage) Copy Code
Dim instance As ChartLegendDataSettings
Dim value As ChartMarginValue

value = instance.CellMargins
C#
[System.ComponentModel.DescriptionAttribute("The margins of the cell content from the grid lines.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute("setCellMargins")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.CategoryAttribute("Dimensions")]
public ChartMarginValue CellMargins {get;}
Delphi
public read-only property CellMargins: ChartMarginValue;
JScript
System.ComponentModel.DescriptionAttribute("The margins of the cell content from the grid lines.")
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute("setCellMargins")
System.ComponentModel.NotifyParentPropertyAttribute()
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
System.ComponentModel.CategoryAttribute("Dimensions")
public function get CellMargins : ChartMarginValue
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("The margins of the cell content from the grid lines.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute("setCellMargins")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.CategoryAttribute("Dimensions")]
public: __property ChartMarginValue* get_CellMargins();
C++/CLI
[System.ComponentModel.DescriptionAttribute("The margins of the cell content from the grid lines.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute("setCellMargins")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.CategoryAttribute("Dimensions")]
public:
property ChartMarginValue^ CellMargins {
   ChartMarginValue^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartLegendDataSettings Class
ChartLegendDataSettings Members


ColCount Property

[image]
Intersoft WebGrid Documentation
ColCount Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartLegendDataSettings Class : ColCount Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("The maximum column count allowed when ExpandMode is ColsFixed.")>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Layout")>
Public Property ColCount As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As ChartLegendDataSettings
Dim value As System.Integer

instance.ColCount = value

value = instance.ColCount
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("The maximum column count allowed when ExpandMode is ColsFixed.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Layout")]
public System.int ColCount {get; set;}
Delphi
public read-write property ColCount: System.Integer;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("The maximum column count allowed when ExpandMode is ColsFixed.")
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Layout")
public function get,set ColCount : System.int
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("The maximum column count allowed when ExpandMode is ColsFixed.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Layout")]
public: __property System.int get_ColCount();
public: __property void set_ColCount(
   System.int value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("The maximum column count allowed when ExpandMode is ColsFixed.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Layout")]
public:
property System.int ColCount {
   System.int get();
   void set (    System.int value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartLegendDataSettings Class
ChartLegendDataSettings Members


ExpandMode Property

[image]
Intersoft WebGrid Documentation
ExpandMode Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartLegendDataSettings Class : ExpandMode Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("The expand strategy of the legend.")>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Layout")>
Public Property ExpandMode As LegendExpandMode
Visual Basic (Usage) Copy Code
Dim instance As ChartLegendDataSettings
Dim value As LegendExpandMode

instance.ExpandMode = value

value = instance.ExpandMode
C#
[System.ComponentModel.DescriptionAttribute("The expand strategy of the legend.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Layout")]
public LegendExpandMode ExpandMode {get; set;}
Delphi
public read-write property ExpandMode: LegendExpandMode;
JScript
System.ComponentModel.DescriptionAttribute("The expand strategy of the legend.")
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Layout")
public function get,set ExpandMode : LegendExpandMode
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("The expand strategy of the legend.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Layout")]
public: __property LegendExpandMode get_ExpandMode();
public: __property void set_ExpandMode(
   LegendExpandMode value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("The expand strategy of the legend.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Layout")]
public:
property LegendExpandMode ExpandMode {
   LegendExpandMode get();
   void set (    LegendExpandMode value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartLegendDataSettings Class
ChartLegendDataSettings Members


MarkSize Property

[image]
Intersoft WebGrid Documentation
MarkSize Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartLegendDataSettings Class : MarkSize Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Dimensions")>
<System.ComponentModel.DescriptionAttribute("The size of the legend items marks.")>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute("setMarkSize")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
Public ReadOnly Property MarkSize As ChartSizeValue
Visual Basic (Usage) Copy Code
Dim instance As ChartLegendDataSettings
Dim value As ChartSizeValue

value = instance.MarkSize
C#
[System.ComponentModel.CategoryAttribute("Dimensions")]
[System.ComponentModel.DescriptionAttribute("The size of the legend items marks.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute("setMarkSize")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
public ChartSizeValue MarkSize {get;}
Delphi
public read-only property MarkSize: ChartSizeValue;
JScript
System.ComponentModel.CategoryAttribute("Dimensions")
System.ComponentModel.DescriptionAttribute("The size of the legend items marks.")
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute("setMarkSize")
System.ComponentModel.NotifyParentPropertyAttribute()
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
public function get MarkSize : ChartSizeValue
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Dimensions")]
[System.ComponentModel.DescriptionAttribute("The size of the legend items marks.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute("setMarkSize")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
public: __property ChartSizeValue* get_MarkSize();
C++/CLI
[System.ComponentModel.CategoryAttribute("Dimensions")]
[System.ComponentModel.DescriptionAttribute("The size of the legend items marks.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute("setMarkSize")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
public:
property ChartSizeValue^ MarkSize {
   ChartSizeValue^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartLegendDataSettings Class
ChartLegendDataSettings Members


RowCount Property

[image]
Intersoft WebGrid Documentation
RowCount Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartLegendDataSettings Class : RowCount Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Layout")>
<System.ComponentModel.DescriptionAttribute("The maximum row count allowed when ExpandMode is RowsFixed.")>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property RowCount As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As ChartLegendDataSettings
Dim value As System.Integer

instance.RowCount = value

value = instance.RowCount
C#
[System.ComponentModel.CategoryAttribute("Layout")]
[System.ComponentModel.DescriptionAttribute("The maximum row count allowed when ExpandMode is RowsFixed.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.int RowCount {get; set;}
Delphi
public read-write property RowCount: System.Integer;
JScript
System.ComponentModel.CategoryAttribute("Layout")
System.ComponentModel.DescriptionAttribute("The maximum row count allowed when ExpandMode is RowsFixed.")
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set RowCount : System.int
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Layout")]
[System.ComponentModel.DescriptionAttribute("The maximum row count allowed when ExpandMode is RowsFixed.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.int get_RowCount();
public: __property void set_RowCount(
   System.int value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Layout")]
[System.ComponentModel.DescriptionAttribute("The maximum row count allowed when ExpandMode is RowsFixed.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.int RowCount {
   System.int get();
   void set (    System.int value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartLegendDataSettings Class
ChartLegendDataSettings Members


TextOffset Property

[image]
Intersoft WebGrid Documentation
TextOffset Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartLegendDataSettings Class : TextOffset Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("The offset of the the text from the margin bounds.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Dimensions")>
Public Property TextOffset As System.Nullable(Of Single)
Visual Basic (Usage) Copy Code
Dim instance As ChartLegendDataSettings
Dim value As System.Nullable(Of Single)

instance.TextOffset = value

value = instance.TextOffset
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("The offset of the the text from the margin bounds.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Dimensions")]
public System.Nullable<float> TextOffset {get; set;}
Delphi
public read-write property TextOffset: System.Nullable;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("The offset of the the text from the margin bounds.")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Dimensions")
public function get,set TextOffset : System.Nullable
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("The offset of the the text from the margin bounds.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Dimensions")]
public: __property System.Nullable<float> get_TextOffset();
public: __property void set_TextOffset(
   System.Nullable<float> value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("The offset of the the text from the margin bounds.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Dimensions")]
public:
property System.Nullable<float> TextOffset {
   System.Nullable<float> get();
   void set (    System.Nullable<float> value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartLegendDataSettings Class
ChartLegendDataSettings Members


ChartLegendSettings Class

[image]
Intersoft WebGrid Documentation
ChartLegendSettings Class
Members See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartLegendSettings Class

Glossary Item Box

Object Model

ChartLegendSettings Class

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.SerializableAttribute()>
Public Class ChartLegendSettings
   Inherits ISNet.WebUI.WebUIBaseClass
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Visual Basic (Usage) Copy Code
Dim instance As ChartLegendSettings
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public class ChartLegendSettings : ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Delphi
public class ChartLegendSettings = class(ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize)
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.SerializableAttribute()
public class ChartLegendSettings extends ISNet.WebUI.WebUIBaseClass implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public __gc class ChartLegendSettings : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public ref class ChartLegendSettings : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.WebGrid.Chart.ChartLegendSettings

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartLegendSettings Members
ISNet.WebUI.WebGrid.Chart Namespace


ChartLegendSettings Class Members

[image]
Intersoft WebGrid Documentation
ChartLegendSettings Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartLegendSettings Class

Glossary Item Box

The following tables list the members exposed by ChartLegendSettings.

Public Constructors

 | Name | Description
Public Constructor | ChartLegendSettings Constructor |
Top

Public Properties

 | Name | Description
Public Property | DataSettings |
Public Property | Dock |
Public Property | FillStyle |
Public Property | Footer |
Public Property | Header |
Public Property | HorizontalBorderStyle |
Public Property | Mode |
Public Property | OuterBottomBorderStyle |
Public Property | OuterLeftBorderStyle |
Public Property | OuterRightBorderStyle |
Public Property | OuterTopBorderStyle |
Public Property | ScaleLegendGridLines |
Public Property | ShadowStyle |
Public Property | VerticalBorderStyle |
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

ChartLegendSettings Class
ISNet.WebUI.WebGrid.Chart Namespace


ChartLegendSettings Constructor

[image]
Intersoft WebGrid Documentation
ChartLegendSettings Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartLegendSettings Class : ChartLegendSettings Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New ChartLegendSettings()
C#
public ChartLegendSettings()
Delphi
public ChartLegendSettings();
JScript
public function ChartLegendSettings();
Managed Extensions for C++
public: ChartLegendSettings();
C++/CLI
public:
ChartLegendSettings();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartLegendSettings Class
ChartLegendSettings Members


Clone Method

[image]
Intersoft WebGrid Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartLegendSettings Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As System.Object
Visual Basic (Usage) Copy Code
Dim instance As ChartLegendSettings
Dim value As System.Object

value = instance.Clone()
C#
public virtual System.object Clone()
Delphi
public function Clone(): System.TObject; virtual;
JScript
public function Clone() : System.Object;
Managed Extensions for C++
public: virtual System.Object* Clone();
C++/CLI
public:
virtual System.Object^ Clone();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartLegendSettings Class
ChartLegendSettings Members


CopyFrom Method

[image]
Intersoft WebGrid Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartLegendSettings Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartLegendSettings Class
ChartLegendSettings Members


CopyFrom(Object) Method

[image]
Intersoft WebGrid Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartLegendSettings Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartLegendSettings
Dim objSource As System.Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   System.object objSource
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartLegendSettings Class
ChartLegendSettings Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebGrid Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartLegendSettings Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object, _
   ByVal cloneSourceValue As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartLegendSettings
Dim objSource As System.Object
Dim cloneSourceValue As System.Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   System.object objSource,
   System.bool cloneSourceValue
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject;
    cloneSourceValue: System.Boolean
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object,
   cloneSourceValue : System.boolean
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource,
   System.bool cloneSourceValue
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource,
   System.bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartLegendSettings Class
ChartLegendSettings Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebGrid Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartLegendSettings Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartLegendSettings
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure DeSerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function DeSerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void DeSerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void DeSerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartLegendSettings Class
ChartLegendSettings Members


GetHashCode Method

[image]
Intersoft WebGrid Documentation
GetHashCode Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartLegendSettings Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As ChartLegendSettings
Dim value As System.Integer

value = instance.GetHashCode()
C#
public virtual System.int GetHashCode()
Delphi
public function GetHashCode(): System.Integer; virtual;
JScript
public function GetHashCode() : System.int;
Managed Extensions for C++
public: virtual System.int GetHashCode();
C++/CLI
public:
virtual System.int GetHashCode();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartLegendSettings Class
ChartLegendSettings Members


ChartLegendSettings Class Methods

[image]
Intersoft WebGrid Documentation
ChartLegendSettings Class Methods
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartLegendSettings Class

Glossary Item Box

For a list of all members of this type, see ChartLegendSettings members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

ChartLegendSettings Class
ISNet.WebUI.WebGrid.Chart Namespace


GetObjectData Method

[image]
Intersoft WebGrid Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartLegendSettings Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=False,
   UnmanagedCode=False,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=True,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Action=SecurityAction.Demand,
   Unrestricted=False)>
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartLegendSettings
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure GetObjectData(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
); override;
JScript
System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=,
   UnmanagedCode=,
   SkipVerification=,
   Execution=,
   ControlThread=,
   ControlEvidence=,
   ControlPolicy=,
   SerializationFormatter=,
   ControlDomainPolicy=,
   ControlPrincipal=,
   ControlAppDomain=,
   RemotingConfiguration=,
   Infrastructure=,
   BindingRedirects=,
   Action=SecurityAction.Demand,
   Unrestricted=)
public override function GetObjectData(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public: void GetObjectData(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
) override
C++/CLI
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public:
void GetObjectData(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
) override

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartLegendSettings Class
ChartLegendSettings Members


IsEmpty Method

[image]
Intersoft WebGrid Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartLegendSettings Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As ChartLegendSettings
Dim value As System.Boolean

value = instance.IsEmpty()
C#
public virtual System.bool IsEmpty()
Delphi
public function IsEmpty(): System.Boolean; virtual;
JScript
public function IsEmpty() : System.boolean;
Managed Extensions for C++
public: virtual System.bool IsEmpty();
C++/CLI
public:
virtual System.bool IsEmpty();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartLegendSettings Class
ChartLegendSettings Members


Reset Method

[image]
Intersoft WebGrid Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartLegendSettings Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As ChartLegendSettings

instance.Reset()
C#
public virtual void Reset()
Delphi
public procedure Reset(); virtual;
JScript
public function Reset();
Managed Extensions for C++
public: virtual void Reset();
C++/CLI
public:
virtual void Reset();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartLegendSettings Class
ChartLegendSettings Members


SerializeObjectData Method

[image]
Intersoft WebGrid Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartLegendSettings Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartLegendSettings
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure SerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function SerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void SerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void SerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartLegendSettings Class
ChartLegendSettings Members


ToString Method

[image]
Intersoft WebGrid Documentation
ToString Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartLegendSettings Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As System.String
Visual Basic (Usage) Copy Code
Dim instance As ChartLegendSettings
Dim value As System.String

value = instance.ToString()
C#
public virtual System.string ToString()
Delphi
public function ToString(): System.String; virtual;
JScript
public function ToString() : System.String;
Managed Extensions for C++
public: virtual System.string* ToString();
C++/CLI
public:
virtual System.String^ ToString();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartLegendSettings Class
ChartLegendSettings Members


ChartLegendSettings Class Properties

[image]
Intersoft WebGrid Documentation
ChartLegendSettings Class Properties
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartLegendSettings Class

Glossary Item Box

For a list of all members of this type, see ChartLegendSettings members.

Public Properties

 | Name | Description
Public Property | DataSettings |
Public Property | Dock |
Public Property | FillStyle |
Public Property | Footer |
Public Property | Header |
Public Property | HorizontalBorderStyle |
Public Property | Mode |
Public Property | OuterBottomBorderStyle |
Public Property | OuterLeftBorderStyle |
Public Property | OuterRightBorderStyle |
Public Property | OuterTopBorderStyle |
Public Property | ScaleLegendGridLines |
Public Property | ShadowStyle |
Public Property | VerticalBorderStyle |
Top

See Also

Reference

ChartLegendSettings Class
ISNet.WebUI.WebGrid.Chart Namespace


ChartLegendSettings Constructor

[image]
Intersoft WebGrid Documentation
ChartLegendSettings Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartLegendSettings Class : ChartLegendSettings Constructor

Glossary Item Box

Overload List

Overload | Description
ChartLegendSettings Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartLegendSettings Class
ChartLegendSettings Members


DataSettings Property

[image]
Intersoft WebGrid Documentation
DataSettings Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartLegendSettings Class : DataSettings Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Controls chart legend data layout.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Appearance")>
<ISNet.Serialization.BinarySerializableAttribute("setDataSettings")>
<System.ComponentModel.DefaultValueAttribute()>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
Public ReadOnly Property DataSettings As ChartLegendDataSettings
Visual Basic (Usage) Copy Code
Dim instance As ChartLegendSettings
Dim value As ChartLegendDataSettings

value = instance.DataSettings
C#
[System.ComponentModel.DescriptionAttribute("Controls chart legend data layout.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Appearance")]
[ISNet.Serialization.BinarySerializableAttribute("setDataSettings")]
[System.ComponentModel.DefaultValueAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
public ChartLegendDataSettings DataSettings {get;}
Delphi
public read-only property DataSettings: ChartLegendDataSettings;
JScript
System.ComponentModel.DescriptionAttribute("Controls chart legend data layout.")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Appearance")
ISNet.Serialization.BinarySerializableAttribute("setDataSettings")
System.ComponentModel.DefaultValueAttribute()
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
public function get DataSettings : ChartLegendDataSettings
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Controls chart legend data layout.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Appearance")]
[ISNet.Serialization.BinarySerializableAttribute("setDataSettings")]
[System.ComponentModel.DefaultValueAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
public: __property ChartLegendDataSettings* get_DataSettings();
C++/CLI
[System.ComponentModel.DescriptionAttribute("Controls chart legend data layout.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Appearance")]
[ISNet.Serialization.BinarySerializableAttribute("setDataSettings")]
[System.ComponentModel.DefaultValueAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
public:
property ChartLegendDataSettings^ DataSettings {
   ChartLegendDataSettings^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartLegendSettings Class
ChartLegendSettings Members


Dock Property

[image]
Intersoft WebGrid Documentation
Dock Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartLegendSettings Class : Dock Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Specifies the dock position of the legend.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Appearance")>
Public Property Dock As System.Windows.Forms.DockStyle
Visual Basic (Usage) Copy Code
Dim instance As ChartLegendSettings
Dim value As System.Windows.Forms.DockStyle

instance.Dock = value

value = instance.Dock
C#
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the dock position of the legend.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Appearance")]
public System.Windows.Forms.DockStyle Dock {get; set;}
Delphi
public read-write property Dock: System.Windows.Forms.DockStyle;
JScript
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the dock position of the legend.")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Appearance")
public function get,set Dock : System.Windows.Forms.DockStyle
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the dock position of the legend.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Appearance")]
public: __property System.Windows.Forms.DockStyle get_Dock();
public: __property void set_Dock(
   System.Windows.Forms.DockStyle value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the dock position of the legend.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Appearance")]
public:
property System.Windows.Forms.DockStyle Dock {
   System.Windows.Forms.DockStyle get();
   void set (    System.Windows.Forms.DockStyle value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartLegendSettings Class
ChartLegendSettings Members


FillStyle Property

[image]
Intersoft WebGrid Documentation
FillStyle Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartLegendSettings Class : FillStyle Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute("setFillStyle")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Gets or sets the fill style applied to the legend background.")>
<System.ComponentModel.CategoryAttribute("Appearance")>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
Public ReadOnly Property FillStyle As ChartFillStyle
Visual Basic (Usage) Copy Code
Dim instance As ChartLegendSettings
Dim value As ChartFillStyle

value = instance.FillStyle
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute("setFillStyle")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the fill style applied to the legend background.")]
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
public ChartFillStyle FillStyle {get;}
Delphi
public read-only property FillStyle: ChartFillStyle;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute("setFillStyle")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the fill style applied to the legend background.")
System.ComponentModel.CategoryAttribute("Appearance")
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
public function get FillStyle : ChartFillStyle
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute("setFillStyle")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the fill style applied to the legend background.")]
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
public: __property ChartFillStyle* get_FillStyle();
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute("setFillStyle")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the fill style applied to the legend background.")]
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
public:
property ChartFillStyle^ FillStyle {
   ChartFillStyle^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartLegendSettings Class
ChartLegendSettings Members


Footer Property

[image]
Intersoft WebGrid Documentation
Footer Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartLegendSettings Class : Footer Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("The footer of the legend.")>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute("setFooter")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<System.ComponentModel.CategoryAttribute("Content")>
Public ReadOnly Property Footer As ChartLegendTitle
Visual Basic (Usage) Copy Code
Dim instance As ChartLegendSettings
Dim value As ChartLegendTitle

value = instance.Footer
C#
[System.ComponentModel.DescriptionAttribute("The footer of the legend.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute("setFooter")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.CategoryAttribute("Content")]
public ChartLegendTitle Footer {get;}
Delphi
public read-only property Footer: ChartLegendTitle;
JScript
System.ComponentModel.DescriptionAttribute("The footer of the legend.")
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute("setFooter")
System.ComponentModel.NotifyParentPropertyAttribute()
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
System.ComponentModel.CategoryAttribute("Content")
public function get Footer : ChartLegendTitle
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("The footer of the legend.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute("setFooter")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.CategoryAttribute("Content")]
public: __property ChartLegendTitle* get_Footer();
C++/CLI
[System.ComponentModel.DescriptionAttribute("The footer of the legend.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute("setFooter")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.CategoryAttribute("Content")]
public:
property ChartLegendTitle^ Footer {
   ChartLegendTitle^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartLegendSettings Class
ChartLegendSettings Members


Header Property

[image]
Intersoft WebGrid Documentation
Header Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartLegendSettings Class : Header Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("The header of the legend.")>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<System.ComponentModel.CategoryAttribute("Content")>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute("setHeader")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public ReadOnly Property Header As ChartLegendTitle
Visual Basic (Usage) Copy Code
Dim instance As ChartLegendSettings
Dim value As ChartLegendTitle

value = instance.Header
C#
[System.ComponentModel.DescriptionAttribute("The header of the legend.")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.CategoryAttribute("Content")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute("setHeader")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public ChartLegendTitle Header {get;}
Delphi
public read-only property Header: ChartLegendTitle;
JScript
System.ComponentModel.DescriptionAttribute("The header of the legend.")
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
System.ComponentModel.CategoryAttribute("Content")
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute("setHeader")
System.ComponentModel.NotifyParentPropertyAttribute()
public function get Header : ChartLegendTitle
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("The header of the legend.")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.CategoryAttribute("Content")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute("setHeader")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property ChartLegendTitle* get_Header();
C++/CLI
[System.ComponentModel.DescriptionAttribute("The header of the legend.")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.CategoryAttribute("Content")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute("setHeader")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property ChartLegendTitle^ Header {
   ChartLegendTitle^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartLegendSettings Class
ChartLegendSettings Members


HorizontalBorderStyle Property

[image]
Intersoft WebGrid Documentation
HorizontalBorderStyle Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartLegendSettings Class : HorizontalBorderStyle Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Appearance")>
<System.ComponentModel.DescriptionAttribute("The line style of the horizontal legend grid lines")>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute("setHorizontalBorderStyle")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
Public ReadOnly Property HorizontalBorderStyle As ChartStrokeStyle
Visual Basic (Usage) Copy Code
Dim instance As ChartLegendSettings
Dim value As ChartStrokeStyle

value = instance.HorizontalBorderStyle
C#
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.DescriptionAttribute("The line style of the horizontal legend grid lines")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute("setHorizontalBorderStyle")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
public ChartStrokeStyle HorizontalBorderStyle {get;}
Delphi
public read-only property HorizontalBorderStyle: ChartStrokeStyle;
JScript
System.ComponentModel.CategoryAttribute("Appearance")
System.ComponentModel.DescriptionAttribute("The line style of the horizontal legend grid lines")
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute("setHorizontalBorderStyle")
System.ComponentModel.NotifyParentPropertyAttribute()
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
public function get HorizontalBorderStyle : ChartStrokeStyle
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.DescriptionAttribute("The line style of the horizontal legend grid lines")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute("setHorizontalBorderStyle")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
public: __property ChartStrokeStyle* get_HorizontalBorderStyle();
C++/CLI
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.DescriptionAttribute("The line style of the horizontal legend grid lines")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute("setHorizontalBorderStyle")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
public:
property ChartStrokeStyle^ HorizontalBorderStyle {
   ChartStrokeStyle^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartLegendSettings Class
ChartLegendSettings Members


Mode Property

[image]
Intersoft WebGrid Documentation
Mode Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartLegendSettings Class : Mode Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Controls the mode of the legend")>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Content")>
Public Property Mode As LegendMode
Visual Basic (Usage) Copy Code
Dim instance As ChartLegendSettings
Dim value As LegendMode

instance.Mode = value

value = instance.Mode
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Controls the mode of the legend")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Content")]
public LegendMode Mode {get; set;}
Delphi
public read-write property Mode: LegendMode;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Controls the mode of the legend")
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Content")
public function get,set Mode : LegendMode
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Controls the mode of the legend")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Content")]
public: __property LegendMode get_Mode();
public: __property void set_Mode(
   LegendMode value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Controls the mode of the legend")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Content")]
public:
property LegendMode Mode {
   LegendMode get();
   void set (    LegendMode value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartLegendSettings Class
ChartLegendSettings Members


OuterBottomBorderStyle Property

[image]
Intersoft WebGrid Documentation
OuterBottomBorderStyle Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartLegendSettings Class : OuterBottomBorderStyle Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Appearance")>
<System.ComponentModel.DescriptionAttribute("The line style of the outer bottom legend border")>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute("setOuterBottomBorderStyle")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
Public ReadOnly Property OuterBottomBorderStyle As ChartStrokeStyle
Visual Basic (Usage) Copy Code
Dim instance As ChartLegendSettings
Dim value As ChartStrokeStyle

value = instance.OuterBottomBorderStyle
C#
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.DescriptionAttribute("The line style of the outer bottom legend border")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute("setOuterBottomBorderStyle")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
public ChartStrokeStyle OuterBottomBorderStyle {get;}
Delphi
public read-only property OuterBottomBorderStyle: ChartStrokeStyle;
JScript
System.ComponentModel.CategoryAttribute("Appearance")
System.ComponentModel.DescriptionAttribute("The line style of the outer bottom legend border")
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute("setOuterBottomBorderStyle")
System.ComponentModel.NotifyParentPropertyAttribute()
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
public function get OuterBottomBorderStyle : ChartStrokeStyle
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.DescriptionAttribute("The line style of the outer bottom legend border")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute("setOuterBottomBorderStyle")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
public: __property ChartStrokeStyle* get_OuterBottomBorderStyle();
C++/CLI
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.DescriptionAttribute("The line style of the outer bottom legend border")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute("setOuterBottomBorderStyle")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
public:
property ChartStrokeStyle^ OuterBottomBorderStyle {
   ChartStrokeStyle^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartLegendSettings Class
ChartLegendSettings Members


OuterLeftBorderStyle Property

[image]
Intersoft WebGrid Documentation
OuterLeftBorderStyle Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartLegendSettings Class : OuterLeftBorderStyle Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute("setOuterLeftBorderStyle")>
<System.ComponentModel.CategoryAttribute("Appearance")>
<System.ComponentModel.DescriptionAttribute("The line style of the outer left legend border")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
Public ReadOnly Property OuterLeftBorderStyle As ChartStrokeStyle
Visual Basic (Usage) Copy Code
Dim instance As ChartLegendSettings
Dim value As ChartStrokeStyle

value = instance.OuterLeftBorderStyle
C#
[ISNet.Serialization.BinarySerializableAttribute("setOuterLeftBorderStyle")]
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.DescriptionAttribute("The line style of the outer left legend border")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
public ChartStrokeStyle OuterLeftBorderStyle {get;}
Delphi
public read-only property OuterLeftBorderStyle: ChartStrokeStyle;
JScript
ISNet.Serialization.BinarySerializableAttribute("setOuterLeftBorderStyle")
System.ComponentModel.CategoryAttribute("Appearance")
System.ComponentModel.DescriptionAttribute("The line style of the outer left legend border")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
public function get OuterLeftBorderStyle : ChartStrokeStyle
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute("setOuterLeftBorderStyle")]
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.DescriptionAttribute("The line style of the outer left legend border")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
public: __property ChartStrokeStyle* get_OuterLeftBorderStyle();
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute("setOuterLeftBorderStyle")]
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.DescriptionAttribute("The line style of the outer left legend border")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
public:
property ChartStrokeStyle^ OuterLeftBorderStyle {
   ChartStrokeStyle^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartLegendSettings Class
ChartLegendSettings Members


OuterRightBorderStyle Property

[image]
Intersoft WebGrid Documentation
OuterRightBorderStyle Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartLegendSettings Class : OuterRightBorderStyle Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("The line style of the outer right legend border")>
<ISNet.Serialization.BinarySerializableAttribute("setOuterRightBorderStyle")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<System.ComponentModel.CategoryAttribute("Appearance")>
Public ReadOnly Property OuterRightBorderStyle As ChartStrokeStyle
Visual Basic (Usage) Copy Code
Dim instance As ChartLegendSettings
Dim value As ChartStrokeStyle

value = instance.OuterRightBorderStyle
C#
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("The line style of the outer right legend border")]
[ISNet.Serialization.BinarySerializableAttribute("setOuterRightBorderStyle")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.CategoryAttribute("Appearance")]
public ChartStrokeStyle OuterRightBorderStyle {get;}
Delphi
public read-only property OuterRightBorderStyle: ChartStrokeStyle;
JScript
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("The line style of the outer right legend border")
ISNet.Serialization.BinarySerializableAttribute("setOuterRightBorderStyle")
System.ComponentModel.NotifyParentPropertyAttribute()
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
System.ComponentModel.CategoryAttribute("Appearance")
public function get OuterRightBorderStyle : ChartStrokeStyle
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("The line style of the outer right legend border")]
[ISNet.Serialization.BinarySerializableAttribute("setOuterRightBorderStyle")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.CategoryAttribute("Appearance")]
public: __property ChartStrokeStyle* get_OuterRightBorderStyle();
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("The line style of the outer right legend border")]
[ISNet.Serialization.BinarySerializableAttribute("setOuterRightBorderStyle")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.CategoryAttribute("Appearance")]
public:
property ChartStrokeStyle^ OuterRightBorderStyle {
   ChartStrokeStyle^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartLegendSettings Class
ChartLegendSettings Members


OuterTopBorderStyle Property

[image]
Intersoft WebGrid Documentation
OuterTopBorderStyle Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartLegendSettings Class : OuterTopBorderStyle Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("The line style of the outer top legend border")>
<System.ComponentModel.CategoryAttribute("Appearance")>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute("setOuterTopBorderStyle")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public ReadOnly Property OuterTopBorderStyle As ChartStrokeStyle
Visual Basic (Usage) Copy Code
Dim instance As ChartLegendSettings
Dim value As ChartStrokeStyle

value = instance.OuterTopBorderStyle
C#
[System.ComponentModel.DescriptionAttribute("The line style of the outer top legend border")]
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute("setOuterTopBorderStyle")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public ChartStrokeStyle OuterTopBorderStyle {get;}
Delphi
public read-only property OuterTopBorderStyle: ChartStrokeStyle;
JScript
System.ComponentModel.DescriptionAttribute("The line style of the outer top legend border")
System.ComponentModel.CategoryAttribute("Appearance")
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute("setOuterTopBorderStyle")
System.ComponentModel.NotifyParentPropertyAttribute()
public function get OuterTopBorderStyle : ChartStrokeStyle
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("The line style of the outer top legend border")]
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute("setOuterTopBorderStyle")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property ChartStrokeStyle* get_OuterTopBorderStyle();
C++/CLI
[System.ComponentModel.DescriptionAttribute("The line style of the outer top legend border")]
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute("setOuterTopBorderStyle")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property ChartStrokeStyle^ OuterTopBorderStyle {
   ChartStrokeStyle^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartLegendSettings Class
ChartLegendSettings Members


ScaleLegendGridLines Property

[image]
Intersoft WebGrid Documentation
ScaleLegendGridLines Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartLegendSettings Class : ScaleLegendGridLines Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Whether or not legend grid lines should be scaled when the legend is in Stretch or Fit bounds mode.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Panel")>
Public Property ScaleLegendGridLines As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As ChartLegendSettings
Dim value As System.Boolean

instance.ScaleLegendGridLines = value

value = instance.ScaleLegendGridLines
C#
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Whether or not legend grid lines should be scaled when the legend is in Stretch or Fit bounds mode.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Panel")]
public System.bool ScaleLegendGridLines {get; set;}
Delphi
public read-write property ScaleLegendGridLines: System.Boolean;
JScript
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DescriptionAttribute("Whether or not legend grid lines should be scaled when the legend is in Stretch or Fit bounds mode.")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Panel")
public function get,set ScaleLegendGridLines : System.boolean
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Whether or not legend grid lines should be scaled when the legend is in Stretch or Fit bounds mode.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Panel")]
public: __property System.bool get_ScaleLegendGridLines();
public: __property void set_ScaleLegendGridLines(
   System.bool value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Whether or not legend grid lines should be scaled when the legend is in Stretch or Fit bounds mode.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Panel")]
public:
property System.bool ScaleLegendGridLines {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartLegendSettings Class
ChartLegendSettings Members


ShadowStyle Property

[image]
Intersoft WebGrid Documentation
ShadowStyle Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartLegendSettings Class : ShadowStyle Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("Apperance")>
<System.ComponentModel.DescriptionAttribute("The shadow style of the legend")>
<ISNet.Serialization.BinarySerializableAttribute("setShadowStyle")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
Public ReadOnly Property ShadowStyle As ChartShadowStyle
Visual Basic (Usage) Copy Code
Dim instance As ChartLegendSettings
Dim value As ChartShadowStyle

value = instance.ShadowStyle
C#
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Apperance")]
[System.ComponentModel.DescriptionAttribute("The shadow style of the legend")]
[ISNet.Serialization.BinarySerializableAttribute("setShadowStyle")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
public ChartShadowStyle ShadowStyle {get;}
Delphi
public read-only property ShadowStyle: ChartShadowStyle;
JScript
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("Apperance")
System.ComponentModel.DescriptionAttribute("The shadow style of the legend")
ISNet.Serialization.BinarySerializableAttribute("setShadowStyle")
System.ComponentModel.NotifyParentPropertyAttribute()
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
public function get ShadowStyle : ChartShadowStyle
Managed Extensions for C++
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Apperance")]
[System.ComponentModel.DescriptionAttribute("The shadow style of the legend")]
[ISNet.Serialization.BinarySerializableAttribute("setShadowStyle")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
public: __property ChartShadowStyle* get_ShadowStyle();
C++/CLI
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Apperance")]
[System.ComponentModel.DescriptionAttribute("The shadow style of the legend")]
[ISNet.Serialization.BinarySerializableAttribute("setShadowStyle")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
public:
property ChartShadowStyle^ ShadowStyle {
   ChartShadowStyle^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartLegendSettings Class
ChartLegendSettings Members


VerticalBorderStyle Property

[image]
Intersoft WebGrid Documentation
VerticalBorderStyle Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartLegendSettings Class : VerticalBorderStyle Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute("setVerticalBorderStyle")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<System.ComponentModel.DescriptionAttribute("The line style of the vertical legend grid lines")>
<System.ComponentModel.CategoryAttribute("Apperance")>
Public ReadOnly Property VerticalBorderStyle As ChartStrokeStyle
Visual Basic (Usage) Copy Code
Dim instance As ChartLegendSettings
Dim value As ChartStrokeStyle

value = instance.VerticalBorderStyle
C#
[ISNet.Serialization.BinarySerializableAttribute("setVerticalBorderStyle")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DescriptionAttribute("The line style of the vertical legend grid lines")]
[System.ComponentModel.CategoryAttribute("Apperance")]
public ChartStrokeStyle VerticalBorderStyle {get;}
Delphi
public read-only property VerticalBorderStyle: ChartStrokeStyle;
JScript
ISNet.Serialization.BinarySerializableAttribute("setVerticalBorderStyle")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
System.ComponentModel.DescriptionAttribute("The line style of the vertical legend grid lines")
System.ComponentModel.CategoryAttribute("Apperance")
public function get VerticalBorderStyle : ChartStrokeStyle
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute("setVerticalBorderStyle")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DescriptionAttribute("The line style of the vertical legend grid lines")]
[System.ComponentModel.CategoryAttribute("Apperance")]
public: __property ChartStrokeStyle* get_VerticalBorderStyle();
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute("setVerticalBorderStyle")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DescriptionAttribute("The line style of the vertical legend grid lines")]
[System.ComponentModel.CategoryAttribute("Apperance")]
public:
property ChartStrokeStyle^ VerticalBorderStyle {
   ChartStrokeStyle^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartLegendSettings Class
ChartLegendSettings Members


ChartLegendTitle Class

[image]
Intersoft WebGrid Documentation
ChartLegendTitle Class
Members See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartLegendTitle Class

Glossary Item Box

Object Model

ChartLegendTitle Class

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.SerializableAttribute()>
Public Class ChartLegendTitle
   Inherits ISNet.WebUI.WebUIBaseClass
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Visual Basic (Usage) Copy Code
Dim instance As ChartLegendTitle
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public class ChartLegendTitle : ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Delphi
public class ChartLegendTitle = class(ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize)
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.SerializableAttribute()
public class ChartLegendTitle extends ISNet.WebUI.WebUIBaseClass implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public __gc class ChartLegendTitle : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public ref class ChartLegendTitle : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.WebGrid.Chart.ChartLegendTitle

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartLegendTitle Members
ISNet.WebUI.WebGrid.Chart Namespace


ChartLegendTitle Class Members

[image]
Intersoft WebGrid Documentation
ChartLegendTitle Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartLegendTitle Class

Glossary Item Box

The following tables list the members exposed by ChartLegendTitle.

Public Constructors

 | Name | Description
Public Constructor | ChartLegendTitle Constructor |
Top

Public Properties

 | Name | Description
Public Property | Inflate |
Public Property | Text |
Public Property | TextStyle |
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

ChartLegendTitle Class
ISNet.WebUI.WebGrid.Chart Namespace


ChartLegendTitle Constructor

[image]
Intersoft WebGrid Documentation
ChartLegendTitle Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartLegendTitle Class : ChartLegendTitle Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New ChartLegendTitle()
C#
public ChartLegendTitle()
Delphi
public ChartLegendTitle();
JScript
public function ChartLegendTitle();
Managed Extensions for C++
public: ChartLegendTitle();
C++/CLI
public:
ChartLegendTitle();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartLegendTitle Class
ChartLegendTitle Members


Clone Method

[image]
Intersoft WebGrid Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartLegendTitle Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As System.Object
Visual Basic (Usage) Copy Code
Dim instance As ChartLegendTitle
Dim value As System.Object

value = instance.Clone()
C#
public virtual System.object Clone()
Delphi
public function Clone(): System.TObject; virtual;
JScript
public function Clone() : System.Object;
Managed Extensions for C++
public: virtual System.Object* Clone();
C++/CLI
public:
virtual System.Object^ Clone();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartLegendTitle Class
ChartLegendTitle Members


CopyFrom Method

[image]
Intersoft WebGrid Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartLegendTitle Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartLegendTitle Class
ChartLegendTitle Members


CopyFrom(Object) Method

[image]
Intersoft WebGrid Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartLegendTitle Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartLegendTitle
Dim objSource As System.Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   System.object objSource
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartLegendTitle Class
ChartLegendTitle Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebGrid Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartLegendTitle Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object, _
   ByVal cloneSourceValue As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartLegendTitle
Dim objSource As System.Object
Dim cloneSourceValue As System.Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   System.object objSource,
   System.bool cloneSourceValue
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject;
    cloneSourceValue: System.Boolean
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object,
   cloneSourceValue : System.boolean
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource,
   System.bool cloneSourceValue
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource,
   System.bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartLegendTitle Class
ChartLegendTitle Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebGrid Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartLegendTitle Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartLegendTitle
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure DeSerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function DeSerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void DeSerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void DeSerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartLegendTitle Class
ChartLegendTitle Members


GetHashCode Method

[image]
Intersoft WebGrid Documentation
GetHashCode Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartLegendTitle Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As ChartLegendTitle
Dim value As System.Integer

value = instance.GetHashCode()
C#
public virtual System.int GetHashCode()
Delphi
public function GetHashCode(): System.Integer; virtual;
JScript
public function GetHashCode() : System.int;
Managed Extensions for C++
public: virtual System.int GetHashCode();
C++/CLI
public:
virtual System.int GetHashCode();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartLegendTitle Class
ChartLegendTitle Members


ChartLegendTitle Class Methods

[image]
Intersoft WebGrid Documentation
ChartLegendTitle Class Methods
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartLegendTitle Class

Glossary Item Box

For a list of all members of this type, see ChartLegendTitle members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

ChartLegendTitle Class
ISNet.WebUI.WebGrid.Chart Namespace


GetObjectData Method

[image]
Intersoft WebGrid Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartLegendTitle Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=False,
   UnmanagedCode=False,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=True,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Action=SecurityAction.Demand,
   Unrestricted=False)>
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartLegendTitle
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure GetObjectData(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
); override;
JScript
System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=,
   UnmanagedCode=,
   SkipVerification=,
   Execution=,
   ControlThread=,
   ControlEvidence=,
   ControlPolicy=,
   SerializationFormatter=,
   ControlDomainPolicy=,
   ControlPrincipal=,
   ControlAppDomain=,
   RemotingConfiguration=,
   Infrastructure=,
   BindingRedirects=,
   Action=SecurityAction.Demand,
   Unrestricted=)
public override function GetObjectData(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public: void GetObjectData(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
) override
C++/CLI
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public:
void GetObjectData(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
) override

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartLegendTitle Class
ChartLegendTitle Members


IsEmpty Method

[image]
Intersoft WebGrid Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartLegendTitle Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As ChartLegendTitle
Dim value As System.Boolean

value = instance.IsEmpty()
C#
public virtual System.bool IsEmpty()
Delphi
public function IsEmpty(): System.Boolean; virtual;
JScript
public function IsEmpty() : System.boolean;
Managed Extensions for C++
public: virtual System.bool IsEmpty();
C++/CLI
public:
virtual System.bool IsEmpty();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartLegendTitle Class
ChartLegendTitle Members


Reset Method

[image]
Intersoft WebGrid Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartLegendTitle Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As ChartLegendTitle

instance.Reset()
C#
public virtual void Reset()
Delphi
public procedure Reset(); virtual;
JScript
public function Reset();
Managed Extensions for C++
public: virtual void Reset();
C++/CLI
public:
virtual void Reset();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartLegendTitle Class
ChartLegendTitle Members


SerializeObjectData Method

[image]
Intersoft WebGrid Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartLegendTitle Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartLegendTitle
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure SerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function SerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void SerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void SerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartLegendTitle Class
ChartLegendTitle Members


ToString Method

[image]
Intersoft WebGrid Documentation
ToString Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartLegendTitle Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As System.String
Visual Basic (Usage) Copy Code
Dim instance As ChartLegendTitle
Dim value As System.String

value = instance.ToString()
C#
public virtual System.string ToString()
Delphi
public function ToString(): System.String; virtual;
JScript
public function ToString() : System.String;
Managed Extensions for C++
public: virtual System.string* ToString();
C++/CLI
public:
virtual System.String^ ToString();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartLegendTitle Class
ChartLegendTitle Members


ChartLegendTitle Class Properties

[image]
Intersoft WebGrid Documentation
ChartLegendTitle Class Properties
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartLegendTitle Class

Glossary Item Box

For a list of all members of this type, see ChartLegendTitle members.

Public Properties

 | Name | Description
Public Property | Inflate |
Public Property | Text |
Public Property | TextStyle |
Top

See Also

Reference

ChartLegendTitle Class
ISNet.WebUI.WebGrid.Chart Namespace


ChartLegendTitle Constructor

[image]
Intersoft WebGrid Documentation
ChartLegendTitle Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartLegendTitle Class : ChartLegendTitle Constructor

Glossary Item Box

Overload List

Overload | Description
ChartLegendTitle Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartLegendTitle Class
ChartLegendTitle Members


Inflate Property

[image]
Intersoft WebGrid Documentation
Inflate Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartLegendTitle Class : Inflate Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute("setInflate")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("General")>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Specifies an additional inflate of the cell.")>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
Public ReadOnly Property Inflate As ChartSizeValue
Visual Basic (Usage) Copy Code
Dim instance As ChartLegendTitle
Dim value As ChartSizeValue

value = instance.Inflate
C#
[ISNet.Serialization.BinarySerializableAttribute("setInflate")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies an additional inflate of the cell.")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
public ChartSizeValue Inflate {get;}
Delphi
public read-only property Inflate: ChartSizeValue;
JScript
ISNet.Serialization.BinarySerializableAttribute("setInflate")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("General")
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Specifies an additional inflate of the cell.")
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
public function get Inflate : ChartSizeValue
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute("setInflate")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies an additional inflate of the cell.")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
public: __property ChartSizeValue* get_Inflate();
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute("setInflate")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies an additional inflate of the cell.")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
public:
property ChartSizeValue^ Inflate {
   ChartSizeValue^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartLegendTitle Class
ChartLegendTitle Members


Text Property

[image]
Intersoft WebGrid Documentation
Text Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartLegendTitle Class : Text Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("General")>
<System.ComponentModel.DescriptionAttribute("The texts displayed as legend header or footer.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property Text As System.String
Visual Basic (Usage) Copy Code
Dim instance As ChartLegendTitle
Dim value As System.String

instance.Text = value

value = instance.Text
C#
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DescriptionAttribute("The texts displayed as legend header or footer.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.string Text {get; set;}
Delphi
public read-write property Text: System.String;
JScript
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("General")
System.ComponentModel.DescriptionAttribute("The texts displayed as legend header or footer.")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set Text : System.String
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DescriptionAttribute("The texts displayed as legend header or footer.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.string* get_Text();
public: __property void set_Text(
   System.string* value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DescriptionAttribute("The texts displayed as legend header or footer.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.String^ Text {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartLegendTitle Class
ChartLegendTitle Members


TextStyle Property

[image]
Intersoft WebGrid Documentation
TextStyle Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartLegendTitle Class : TextStyle Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("The text properties of the legend header or footer.")>
<System.ComponentModel.CategoryAttribute("General")>
<System.ComponentModel.DefaultValueAttribute()>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<ISNet.Serialization.BinarySerializableAttribute("setTextStyle")>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public ReadOnly Property TextStyle As ChartTextStyle
Visual Basic (Usage) Copy Code
Dim instance As ChartLegendTitle
Dim value As ChartTextStyle

value = instance.TextStyle
C#
[System.ComponentModel.DescriptionAttribute("The text properties of the legend header or footer.")]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DefaultValueAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[ISNet.Serialization.BinarySerializableAttribute("setTextStyle")]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public ChartTextStyle TextStyle {get;}
Delphi
public read-only property TextStyle: ChartTextStyle;
JScript
System.ComponentModel.DescriptionAttribute("The text properties of the legend header or footer.")
System.ComponentModel.CategoryAttribute("General")
System.ComponentModel.DefaultValueAttribute()
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
ISNet.Serialization.BinarySerializableAttribute("setTextStyle")
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
System.ComponentModel.NotifyParentPropertyAttribute()
public function get TextStyle : ChartTextStyle
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("The text properties of the legend header or footer.")]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DefaultValueAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[ISNet.Serialization.BinarySerializableAttribute("setTextStyle")]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property ChartTextStyle* get_TextStyle();
C++/CLI
[System.ComponentModel.DescriptionAttribute("The text properties of the legend header or footer.")]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DefaultValueAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[ISNet.Serialization.BinarySerializableAttribute("setTextStyle")]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property ChartTextStyle^ TextStyle {
   ChartTextStyle^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartLegendTitle Class
ChartLegendTitle Members


ChartLightingImageFilterSettings Class

[image]
Intersoft WebGrid Documentation
ChartLightingImageFilterSettings Class
Members See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartLightingImageFilterSettings Class

Glossary Item Box

Object Model

ChartLightingImageFilterSettings Class

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.SerializableAttribute()>
Public Class ChartLightingImageFilterSettings
   Inherits ChartImageFilterSettings
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Visual Basic (Usage) Copy Code
Dim instance As ChartLightingImageFilterSettings
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public class ChartLightingImageFilterSettings : ChartImageFilterSettings, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Delphi
public class ChartLightingImageFilterSettings = class(ChartImageFilterSettings, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize)
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.SerializableAttribute()
public class ChartLightingImageFilterSettings extends ChartImageFilterSettings implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public __gc class ChartLightingImageFilterSettings : public ChartImageFilterSettings, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public ref class ChartLightingImageFilterSettings : public ChartImageFilterSettings, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.WebGrid.Chart.ChartImageFilterSettings
ISNet.WebUI.WebGrid.Chart.ChartLightingImageFilterSettings

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartLightingImageFilterSettings Members
ISNet.WebUI.WebGrid.Chart Namespace


ChartLightingImageFilterSettings Class Members

[image]
Intersoft WebGrid Documentation
ChartLightingImageFilterSettings Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartLightingImageFilterSettings Class

Glossary Item Box

The following tables list the members exposed by ChartLightingImageFilterSettings.

Public Constructors

 | Name | Description
Public Constructor | ChartLightingImageFilterSettings Constructor |
Top

Public Properties

 | Name | Description
Public Property | BevelDepth |
Public Property | BlurType | (Inherited from ISNet.WebUI.WebGrid.Chart.ChartImageFilterSettings)
Public Property | DifuseColor |
Public Property | Enabled | (Inherited from ISNet.WebUI.WebGrid.Chart.ChartImageFilterSettings)
Public Property | LightSourceType |
Public Property | Position |
Public Property | Shininess |
Public Property | SpecularColor |
Public Property | SurfaceScale |
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

ChartLightingImageFilterSettings Class
ISNet.WebUI.WebGrid.Chart Namespace


ChartLightingImageFilterSettings Constructor

[image]
Intersoft WebGrid Documentation
ChartLightingImageFilterSettings Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartLightingImageFilterSettings Class : ChartLightingImageFilterSettings Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New ChartLightingImageFilterSettings()
C#
public ChartLightingImageFilterSettings()
Delphi
public ChartLightingImageFilterSettings();
JScript
public function ChartLightingImageFilterSettings();
Managed Extensions for C++
public: ChartLightingImageFilterSettings();
C++/CLI
public:
ChartLightingImageFilterSettings();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartLightingImageFilterSettings Class
ChartLightingImageFilterSettings Members


Clone Method

[image]
Intersoft WebGrid Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartLightingImageFilterSettings Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As System.Object
Visual Basic (Usage) Copy Code
Dim instance As ChartLightingImageFilterSettings
Dim value As System.Object

value = instance.Clone()
C#
public virtual System.object Clone()
Delphi
public function Clone(): System.TObject; virtual;
JScript
public function Clone() : System.Object;
Managed Extensions for C++
public: virtual System.Object* Clone();
C++/CLI
public:
virtual System.Object^ Clone();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartLightingImageFilterSettings Class
ChartLightingImageFilterSettings Members


CopyFrom Method

[image]
Intersoft WebGrid Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartLightingImageFilterSettings Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartLightingImageFilterSettings Class
ChartLightingImageFilterSettings Members


CopyFrom(Object) Method

[image]
Intersoft WebGrid Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartLightingImageFilterSettings Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartLightingImageFilterSettings
Dim objSource As System.Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   System.object objSource
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartLightingImageFilterSettings Class
ChartLightingImageFilterSettings Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebGrid Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartLightingImageFilterSettings Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object, _
   ByVal cloneSourceValue As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartLightingImageFilterSettings
Dim objSource As System.Object
Dim cloneSourceValue As System.Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   System.object objSource,
   System.bool cloneSourceValue
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject;
    cloneSourceValue: System.Boolean
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object,
   cloneSourceValue : System.boolean
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource,
   System.bool cloneSourceValue
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource,
   System.bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartLightingImageFilterSettings Class
ChartLightingImageFilterSettings Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebGrid Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartLightingImageFilterSettings Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartLightingImageFilterSettings
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure DeSerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function DeSerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void DeSerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void DeSerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartLightingImageFilterSettings Class
ChartLightingImageFilterSettings Members


GetHashCode Method

[image]
Intersoft WebGrid Documentation
GetHashCode Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartLightingImageFilterSettings Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As ChartLightingImageFilterSettings
Dim value As System.Integer

value = instance.GetHashCode()
C#
public virtual System.int GetHashCode()
Delphi
public function GetHashCode(): System.Integer; virtual;
JScript
public function GetHashCode() : System.int;
Managed Extensions for C++
public: virtual System.int GetHashCode();
C++/CLI
public:
virtual System.int GetHashCode();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartLightingImageFilterSettings Class
ChartLightingImageFilterSettings Members


ChartLightingImageFilterSettings Class Methods

[image]
Intersoft WebGrid Documentation
ChartLightingImageFilterSettings Class Methods
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartLightingImageFilterSettings Class

Glossary Item Box

For a list of all members of this type, see ChartLightingImageFilterSettings members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

ChartLightingImageFilterSettings Class
ISNet.WebUI.WebGrid.Chart Namespace


GetObjectData Method

[image]
Intersoft WebGrid Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartLightingImageFilterSettings Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=False,
   UnmanagedCode=False,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=True,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Action=SecurityAction.Demand,
   Unrestricted=False)>
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartLightingImageFilterSettings
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure GetObjectData(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
); override;
JScript
System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=,
   UnmanagedCode=,
   SkipVerification=,
   Execution=,
   ControlThread=,
   ControlEvidence=,
   ControlPolicy=,
   SerializationFormatter=,
   ControlDomainPolicy=,
   ControlPrincipal=,
   ControlAppDomain=,
   RemotingConfiguration=,
   Infrastructure=,
   BindingRedirects=,
   Action=SecurityAction.Demand,
   Unrestricted=)
public override function GetObjectData(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public: void GetObjectData(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
) override
C++/CLI
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public:
void GetObjectData(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
) override

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartLightingImageFilterSettings Class
ChartLightingImageFilterSettings Members


IsEmpty Method

[image]
Intersoft WebGrid Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartLightingImageFilterSettings Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As ChartLightingImageFilterSettings
Dim value As System.Boolean

value = instance.IsEmpty()
C#
public virtual System.bool IsEmpty()
Delphi
public function IsEmpty(): System.Boolean; virtual;
JScript
public function IsEmpty() : System.boolean;
Managed Extensions for C++
public: virtual System.bool IsEmpty();
C++/CLI
public:
virtual System.bool IsEmpty();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartLightingImageFilterSettings Class
ChartLightingImageFilterSettings Members


Reset Method

[image]
Intersoft WebGrid Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartLightingImageFilterSettings Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As ChartLightingImageFilterSettings

instance.Reset()
C#
public virtual void Reset()
Delphi
public procedure Reset(); virtual;
JScript
public function Reset();
Managed Extensions for C++
public: virtual void Reset();
C++/CLI
public:
virtual void Reset();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartLightingImageFilterSettings Class
ChartLightingImageFilterSettings Members


SerializeObjectData Method

[image]
Intersoft WebGrid Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartLightingImageFilterSettings Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartLightingImageFilterSettings
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure SerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function SerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void SerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void SerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartLightingImageFilterSettings Class
ChartLightingImageFilterSettings Members


ToString Method

[image]
Intersoft WebGrid Documentation
ToString Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartLightingImageFilterSettings Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As System.String
Visual Basic (Usage) Copy Code
Dim instance As ChartLightingImageFilterSettings
Dim value As System.String

value = instance.ToString()
C#
public virtual System.string ToString()
Delphi
public function ToString(): System.String; virtual;
JScript
public function ToString() : System.String;
Managed Extensions for C++
public: virtual System.string* ToString();
C++/CLI
public:
virtual System.String^ ToString();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartLightingImageFilterSettings Class
ChartLightingImageFilterSettings Members


ChartLightingImageFilterSettings Class Properties

[image]
Intersoft WebGrid Documentation
ChartLightingImageFilterSettings Class Properties
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartLightingImageFilterSettings Class

Glossary Item Box

For a list of all members of this type, see ChartLightingImageFilterSettings members.

Public Properties

 | Name | Description
Public Property | BevelDepth |
Public Property | BlurType | (Inherited from ISNet.WebUI.WebGrid.Chart.ChartImageFilterSettings)
Public Property | DifuseColor |
Public Property | Enabled | (Inherited from ISNet.WebUI.WebGrid.Chart.ChartImageFilterSettings)
Public Property | LightSourceType |
Public Property | Position |
Public Property | Shininess |
Public Property | SpecularColor |
Public Property | SurfaceScale |
Top

See Also

Reference

ChartLightingImageFilterSettings Class
ISNet.WebUI.WebGrid.Chart Namespace


ChartLightingImageFilterSettings Constructor

[image]
Intersoft WebGrid Documentation
ChartLightingImageFilterSettings Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartLightingImageFilterSettings Class : ChartLightingImageFilterSettings Constructor

Glossary Item Box

Overload List

Overload | Description
ChartLightingImageFilterSettings Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartLightingImageFilterSettings Class
ChartLightingImageFilterSettings Members


BevelDepth Property

[image]
Intersoft WebGrid Documentation
BevelDepth Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartLightingImageFilterSettings Class : BevelDepth Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Blur")>
<System.ComponentModel.DescriptionAttribute("The length of the image bevel in pixels.")>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property BevelDepth As System.Nullable(Of Single)
Visual Basic (Usage) Copy Code
Dim instance As ChartLightingImageFilterSettings
Dim value As System.Nullable(Of Single)

instance.BevelDepth = value

value = instance.BevelDepth
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Blur")]
[System.ComponentModel.DescriptionAttribute("The length of the image bevel in pixels.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public System.Nullable<float> BevelDepth {get; set;}
Delphi
public read-write property BevelDepth: System.Nullable;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Blur")
System.ComponentModel.DescriptionAttribute("The length of the image bevel in pixels.")
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get,set BevelDepth : System.Nullable
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Blur")]
[System.ComponentModel.DescriptionAttribute("The length of the image bevel in pixels.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.Nullable<float> get_BevelDepth();
public: __property void set_BevelDepth(
   System.Nullable<float> value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Blur")]
[System.ComponentModel.DescriptionAttribute("The length of the image bevel in pixels.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.Nullable<float> BevelDepth {
   System.Nullable<float> get();
   void set (    System.Nullable<float> value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartLightingImageFilterSettings Class
ChartLightingImageFilterSettings Members


DifuseColor Property

[image]
Intersoft WebGrid Documentation
DifuseColor Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartLightingImageFilterSettings Class : DifuseColor Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Appearance")>
<System.ComponentModel.DescriptionAttribute("The diffuse color of the light source.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property DifuseColor As System.Drawing.Color
Visual Basic (Usage) Copy Code
Dim instance As ChartLightingImageFilterSettings
Dim value As System.Drawing.Color

instance.DifuseColor = value

value = instance.DifuseColor
C#
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.DescriptionAttribute("The diffuse color of the light source.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.Drawing.Color DifuseColor {get; set;}
Delphi
public read-write property DifuseColor: System.Drawing.Color;
JScript
System.ComponentModel.CategoryAttribute("Appearance")
System.ComponentModel.DescriptionAttribute("The diffuse color of the light source.")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set DifuseColor : System.Drawing.Color
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.DescriptionAttribute("The diffuse color of the light source.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.Drawing.Color get_DifuseColor();
public: __property void set_DifuseColor(
   System.Drawing.Color value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.DescriptionAttribute("The diffuse color of the light source.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.Drawing.Color DifuseColor {
   System.Drawing.Color get();
   void set (    System.Drawing.Color value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartLightingImageFilterSettings Class
ChartLightingImageFilterSettings Members


LightSourceType Property

[image]
Intersoft WebGrid Documentation
LightSourceType Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartLightingImageFilterSettings Class : LightSourceType Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("The type of the light source.")>
<System.ComponentModel.CategoryAttribute("Appearance")>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property LightSourceType As LightSourceType
Visual Basic (Usage) Copy Code
Dim instance As ChartLightingImageFilterSettings
Dim value As LightSourceType

instance.LightSourceType = value

value = instance.LightSourceType
C#
[System.ComponentModel.DescriptionAttribute("The type of the light source.")]
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public LightSourceType LightSourceType {get; set;}
Delphi
public read-write property LightSourceType: LightSourceType;
JScript
System.ComponentModel.DescriptionAttribute("The type of the light source.")
System.ComponentModel.CategoryAttribute("Appearance")
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set LightSourceType : LightSourceType
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("The type of the light source.")]
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property LightSourceType get_LightSourceType();
public: __property void set_LightSourceType(
   LightSourceType value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("The type of the light source.")]
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property LightSourceType LightSourceType {
   LightSourceType get();
   void set (    LightSourceType value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartLightingImageFilterSettings Class
ChartLightingImageFilterSettings Members


Position Property

[image]
Intersoft WebGrid Documentation
Position Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartLightingImageFilterSettings Class : Position Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Appearance")>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<ISNet.Serialization.BinarySerializableAttribute("setPosition")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.DescriptionAttribute("The Position of the light source.")>
Public ReadOnly Property Position As ChartVector3DValue
Visual Basic (Usage) Copy Code
Dim instance As ChartLightingImageFilterSettings
Dim value As ChartVector3DValue

value = instance.Position
C#
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.Serialization.BinarySerializableAttribute("setPosition")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DescriptionAttribute("The Position of the light source.")]
public ChartVector3DValue Position {get;}
Delphi
public read-only property Position: ChartVector3DValue;
JScript
System.ComponentModel.CategoryAttribute("Appearance")
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
ISNet.Serialization.BinarySerializableAttribute("setPosition")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.DescriptionAttribute("The Position of the light source.")
public function get Position : ChartVector3DValue
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.Serialization.BinarySerializableAttribute("setPosition")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DescriptionAttribute("The Position of the light source.")]
public: __property ChartVector3DValue* get_Position();
C++/CLI
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.Serialization.BinarySerializableAttribute("setPosition")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DescriptionAttribute("The Position of the light source.")]
public:
property ChartVector3DValue^ Position {
   ChartVector3DValue^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartLightingImageFilterSettings Class
ChartLightingImageFilterSettings Members


Shininess Property

[image]
Intersoft WebGrid Documentation
Shininess Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartLightingImageFilterSettings Class : Shininess Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Appearance")>
<System.ComponentModel.DescriptionAttribute("The Shininess of the material used to cover the surface. ")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property Shininess As System.Single
Visual Basic (Usage) Copy Code
Dim instance As ChartLightingImageFilterSettings
Dim value As System.Single

instance.Shininess = value

value = instance.Shininess
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.DescriptionAttribute("The Shininess of the material used to cover the surface. ")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.float Shininess {get; set;}
Delphi
public read-write property Shininess: System.Single;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Appearance")
System.ComponentModel.DescriptionAttribute("The Shininess of the material used to cover the surface. ")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set Shininess : System.float
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.DescriptionAttribute("The Shininess of the material used to cover the surface. ")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.float get_Shininess();
public: __property void set_Shininess(
   System.float value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.DescriptionAttribute("The Shininess of the material used to cover the surface. ")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.float Shininess {
   System.float get();
   void set (    System.float value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartLightingImageFilterSettings Class
ChartLightingImageFilterSettings Members


SpecularColor Property

[image]
Intersoft WebGrid Documentation
SpecularColor Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartLightingImageFilterSettings Class : SpecularColor Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("The specular color of the light source.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Appearance")>
Public Property SpecularColor As System.Drawing.Color
Visual Basic (Usage) Copy Code
Dim instance As ChartLightingImageFilterSettings
Dim value As System.Drawing.Color

instance.SpecularColor = value

value = instance.SpecularColor
C#
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("The specular color of the light source.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Appearance")]
public System.Drawing.Color SpecularColor {get; set;}
Delphi
public read-write property SpecularColor: System.Drawing.Color;
JScript
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("The specular color of the light source.")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Appearance")
public function get,set SpecularColor : System.Drawing.Color
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("The specular color of the light source.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Appearance")]
public: __property System.Drawing.Color get_SpecularColor();
public: __property void set_SpecularColor(
   System.Drawing.Color value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("The specular color of the light source.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Appearance")]
public:
property System.Drawing.Color SpecularColor {
   System.Drawing.Color get();
   void set (    System.Drawing.Color value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartLightingImageFilterSettings Class
ChartLightingImageFilterSettings Members


SurfaceScale Property

[image]
Intersoft WebGrid Documentation
SurfaceScale Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartLightingImageFilterSettings Class : SurfaceScale Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("The scale of the surface.")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("Appearance")>
Public Property SurfaceScale As System.Single
Visual Basic (Usage) Copy Code
Dim instance As ChartLightingImageFilterSettings
Dim value As System.Single

instance.SurfaceScale = value

value = instance.SurfaceScale
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("The scale of the surface.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Appearance")]
public System.float SurfaceScale {get; set;}
Delphi
public read-write property SurfaceScale: System.Single;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DescriptionAttribute("The scale of the surface.")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("Appearance")
public function get,set SurfaceScale : System.float
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("The scale of the surface.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Appearance")]
public: __property System.float get_SurfaceScale();
public: __property void set_SurfaceScale(
   System.float value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("The scale of the surface.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Appearance")]
public:
property System.float SurfaceScale {
   System.float get();
   void set (    System.float value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartLightingImageFilterSettings Class
ChartLightingImageFilterSettings Members


ChartLightModelSettings Class

[image]
Intersoft WebGrid Documentation
ChartLightModelSettings Class
Members See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartLightModelSettings Class

Glossary Item Box

Object Model

ChartLightModelSettings Class

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.SerializableAttribute()>
Public Class ChartLightModelSettings
   Inherits ISNet.WebUI.WebUIBaseClass
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Visual Basic (Usage) Copy Code
Dim instance As ChartLightModelSettings
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public class ChartLightModelSettings : ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Delphi
public class ChartLightModelSettings = class(ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize)
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.SerializableAttribute()
public class ChartLightModelSettings extends ISNet.WebUI.WebUIBaseClass implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public __gc class ChartLightModelSettings : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public ref class ChartLightModelSettings : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.WebGrid.Chart.ChartLightModelSettings

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartLightModelSettings Members
ISNet.WebUI.WebGrid.Chart Namespace


ChartLightModelSettings Class Members

[image]
Intersoft WebGrid Documentation
ChartLightModelSettings Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartLightModelSettings Class

Glossary Item Box

The following tables list the members exposed by ChartLightModelSettings.

Public Constructors

 | Name | Description
Public Constructor | ChartLightModelSettings Constructor |
Top

Public Properties

 | Name | Description
Public Property | EnableLighting |
Public Property | GlobalAmbientLight |
Public Property | LightModel |
Public Property | LightSources |
Public Property | LocalViewpointLighting |
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

ChartLightModelSettings Class
ISNet.WebUI.WebGrid.Chart Namespace


ChartLightModelSettings Constructor

[image]
Intersoft WebGrid Documentation
ChartLightModelSettings Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartLightModelSettings Class : ChartLightModelSettings Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New ChartLightModelSettings()
C#
public ChartLightModelSettings()
Delphi
public ChartLightModelSettings();
JScript
public function ChartLightModelSettings();
Managed Extensions for C++
public: ChartLightModelSettings();
C++/CLI
public:
ChartLightModelSettings();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartLightModelSettings Class
ChartLightModelSettings Members


Clone Method

[image]
Intersoft WebGrid Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartLightModelSettings Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As System.Object
Visual Basic (Usage) Copy Code
Dim instance As ChartLightModelSettings
Dim value As System.Object

value = instance.Clone()
C#
public virtual System.object Clone()
Delphi
public function Clone(): System.TObject; virtual;
JScript
public function Clone() : System.Object;
Managed Extensions for C++
public: virtual System.Object* Clone();
C++/CLI
public:
virtual System.Object^ Clone();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartLightModelSettings Class
ChartLightModelSettings Members


CopyFrom Method

[image]
Intersoft WebGrid Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartLightModelSettings Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartLightModelSettings Class
ChartLightModelSettings Members


CopyFrom(Object) Method

[image]
Intersoft WebGrid Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartLightModelSettings Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartLightModelSettings
Dim objSource As System.Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   System.object objSource
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartLightModelSettings Class
ChartLightModelSettings Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebGrid Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartLightModelSettings Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object, _
   ByVal cloneSourceValue As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartLightModelSettings
Dim objSource As System.Object
Dim cloneSourceValue As System.Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   System.object objSource,
   System.bool cloneSourceValue
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject;
    cloneSourceValue: System.Boolean
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object,
   cloneSourceValue : System.boolean
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource,
   System.bool cloneSourceValue
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource,
   System.bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartLightModelSettings Class
ChartLightModelSettings Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebGrid Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartLightModelSettings Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartLightModelSettings
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure DeSerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function DeSerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void DeSerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void DeSerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartLightModelSettings Class
ChartLightModelSettings Members


GetHashCode Method

[image]
Intersoft WebGrid Documentation
GetHashCode Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartLightModelSettings Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As ChartLightModelSettings
Dim value As System.Integer

value = instance.GetHashCode()
C#
public virtual System.int GetHashCode()
Delphi
public function GetHashCode(): System.Integer; virtual;
JScript
public function GetHashCode() : System.int;
Managed Extensions for C++
public: virtual System.int GetHashCode();
C++/CLI
public:
virtual System.int GetHashCode();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartLightModelSettings Class
ChartLightModelSettings Members


ChartLightModelSettings Class Methods

[image]
Intersoft WebGrid Documentation
ChartLightModelSettings Class Methods
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartLightModelSettings Class

Glossary Item Box

For a list of all members of this type, see ChartLightModelSettings members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

ChartLightModelSettings Class
ISNet.WebUI.WebGrid.Chart Namespace


GetObjectData Method

[image]
Intersoft WebGrid Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartLightModelSettings Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=False,
   UnmanagedCode=False,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=True,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Action=SecurityAction.Demand,
   Unrestricted=False)>
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartLightModelSettings
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure GetObjectData(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
); override;
JScript
System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=,
   UnmanagedCode=,
   SkipVerification=,
   Execution=,
   ControlThread=,
   ControlEvidence=,
   ControlPolicy=,
   SerializationFormatter=,
   ControlDomainPolicy=,
   ControlPrincipal=,
   ControlAppDomain=,
   RemotingConfiguration=,
   Infrastructure=,
   BindingRedirects=,
   Action=SecurityAction.Demand,
   Unrestricted=)
public override function GetObjectData(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public: void GetObjectData(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
) override
C++/CLI
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public:
void GetObjectData(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
) override

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartLightModelSettings Class
ChartLightModelSettings Members


IsEmpty Method

[image]
Intersoft WebGrid Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartLightModelSettings Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As ChartLightModelSettings
Dim value As System.Boolean

value = instance.IsEmpty()
C#
public virtual System.bool IsEmpty()
Delphi
public function IsEmpty(): System.Boolean; virtual;
JScript
public function IsEmpty() : System.boolean;
Managed Extensions for C++
public: virtual System.bool IsEmpty();
C++/CLI
public:
virtual System.bool IsEmpty();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartLightModelSettings Class
ChartLightModelSettings Members


Reset Method

[image]
Intersoft WebGrid Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartLightModelSettings Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As ChartLightModelSettings

instance.Reset()
C#
public virtual void Reset()
Delphi
public procedure Reset(); virtual;
JScript
public function Reset();
Managed Extensions for C++
public: virtual void Reset();
C++/CLI
public:
virtual void Reset();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartLightModelSettings Class
ChartLightModelSettings Members


SerializeObjectData Method

[image]
Intersoft WebGrid Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartLightModelSettings Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartLightModelSettings
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure SerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function SerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void SerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void SerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartLightModelSettings Class
ChartLightModelSettings Members


ToString Method

[image]
Intersoft WebGrid Documentation
ToString Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartLightModelSettings Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As System.String
Visual Basic (Usage) Copy Code
Dim instance As ChartLightModelSettings
Dim value As System.String

value = instance.ToString()
C#
public virtual System.string ToString()
Delphi
public function ToString(): System.String; virtual;
JScript
public function ToString() : System.String;
Managed Extensions for C++
public: virtual System.string* ToString();
C++/CLI
public:
virtual System.String^ ToString();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartLightModelSettings Class
ChartLightModelSettings Members


ChartLightModelSettings Class Properties

[image]
Intersoft WebGrid Documentation
ChartLightModelSettings Class Properties
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartLightModelSettings Class

Glossary Item Box

For a list of all members of this type, see ChartLightModelSettings members.

Public Properties

 | Name | Description
Public Property | EnableLighting |
Public Property | GlobalAmbientLight |
Public Property | LightModel |
Public Property | LightSources |
Public Property | LocalViewpointLighting |
Top

See Also

Reference

ChartLightModelSettings Class
ISNet.WebUI.WebGrid.Chart Namespace


ChartLightModelSettings Constructor

[image]
Intersoft WebGrid Documentation
ChartLightModelSettings Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartLightModelSettings Class : ChartLightModelSettings Constructor

Glossary Item Box

Overload List

Overload | Description
ChartLightModelSettings Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartLightModelSettings Class
ChartLightModelSettings Members


EnableLighting Property

[image]
Intersoft WebGrid Documentation
EnableLighting Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartLightModelSettings Class : EnableLighting Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.CategoryAttribute("General")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Enables/disables the lighting effects.")>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property EnableLighting As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As ChartLightModelSettings
Dim value As System.Boolean

instance.EnableLighting = value

value = instance.EnableLighting
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Enables/disables the lighting effects.")]
[ISNet.Serialization.BinarySerializableAttribute()]
public System.bool EnableLighting {get; set;}
Delphi
public read-write property EnableLighting: System.Boolean;
JScript
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.CategoryAttribute("General")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Enables/disables the lighting effects.")
ISNet.Serialization.BinarySerializableAttribute()
public function get,set EnableLighting : System.boolean
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Enables/disables the lighting effects.")]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.bool get_EnableLighting();
public: __property void set_EnableLighting(
   System.bool value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Enables/disables the lighting effects.")]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.bool EnableLighting {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartLightModelSettings Class
ChartLightModelSettings Members


GlobalAmbientLight Property

[image]
Intersoft WebGrid Documentation
GlobalAmbientLight Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartLightModelSettings Class : GlobalAmbientLight Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("General")>
<System.ComponentModel.DescriptionAttribute("Specifies the color of the global ambient light.")>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property GlobalAmbientLight As System.Drawing.Color
Visual Basic (Usage) Copy Code
Dim instance As ChartLightModelSettings
Dim value As System.Drawing.Color

instance.GlobalAmbientLight = value

value = instance.GlobalAmbientLight
C#
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DescriptionAttribute("Specifies the color of the global ambient light.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.Drawing.Color GlobalAmbientLight {get; set;}
Delphi
public read-write property GlobalAmbientLight: System.Drawing.Color;
JScript
System.ComponentModel.CategoryAttribute("General")
System.ComponentModel.DescriptionAttribute("Specifies the color of the global ambient light.")
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set GlobalAmbientLight : System.Drawing.Color
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DescriptionAttribute("Specifies the color of the global ambient light.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.Drawing.Color get_GlobalAmbientLight();
public: __property void set_GlobalAmbientLight(
   System.Drawing.Color value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DescriptionAttribute("Specifies the color of the global ambient light.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.Drawing.Color GlobalAmbientLight {
   System.Drawing.Color get();
   void set (    System.Drawing.Color value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartLightModelSettings Class
ChartLightModelSettings Members


LightModel Property

[image]
Intersoft WebGrid Documentation
LightModel Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartLightModelSettings Class : LightModel Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies predefined light model.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("General")>
Public Property LightModel As PredefinedLightModel
Visual Basic (Usage) Copy Code
Dim instance As ChartLightModelSettings
Dim value As PredefinedLightModel

instance.LightModel = value

value = instance.LightModel
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies predefined light model.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("General")]
public PredefinedLightModel LightModel {get; set;}
Delphi
public read-write property LightModel: PredefinedLightModel;
JScript
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Specifies predefined light model.")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("General")
public function get,set LightModel : PredefinedLightModel
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies predefined light model.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("General")]
public: __property PredefinedLightModel get_LightModel();
public: __property void set_LightModel(
   PredefinedLightModel value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies predefined light model.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("General")]
public:
property PredefinedLightModel LightModel {
   PredefinedLightModel get();
   void set (    PredefinedLightModel value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartLightModelSettings Class
ChartLightModelSettings Members


LightSources Property

[image]
Intersoft WebGrid Documentation
LightSources Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartLightModelSettings Class : LightSources Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Represents the collection of light sources that are applied to the scene.")>
<ISNet.Serialization.XmlSerializableAttribute(RecreateItemsOnDeserialization=True, DiscardEmptyObject=True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.CategoryAttribute("General")>
Public ReadOnly Property LightSources As ChartLightSourceCollection
Visual Basic (Usage) Copy Code
Dim instance As ChartLightModelSettings
Dim value As ChartLightSourceCollection

value = instance.LightSources
C#
[System.ComponentModel.DescriptionAttribute("Represents the collection of light sources that are applied to the scene.")]
[ISNet.Serialization.XmlSerializableAttribute(RecreateItemsOnDeserialization=true, DiscardEmptyObject=true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.CategoryAttribute("General")]
public ChartLightSourceCollection LightSources {get;}
Delphi
public read-only property LightSources: ChartLightSourceCollection;
JScript
System.ComponentModel.DescriptionAttribute("Represents the collection of light sources that are applied to the scene.")
ISNet.Serialization.XmlSerializableAttribute(RecreateItemsOnDeserialization=, DiscardEmptyObject=)
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.CategoryAttribute("General")
public function get LightSources : ChartLightSourceCollection
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Represents the collection of light sources that are applied to the scene.")]
[ISNet.Serialization.XmlSerializableAttribute(RecreateItemsOnDeserialization=true, DiscardEmptyObject=true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.CategoryAttribute("General")]
public: __property ChartLightSourceCollection* get_LightSources();
C++/CLI
[System.ComponentModel.DescriptionAttribute("Represents the collection of light sources that are applied to the scene.")]
[ISNet.Serialization.XmlSerializableAttribute(RecreateItemsOnDeserialization=true, DiscardEmptyObject=true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.CategoryAttribute("General")]
public:
property ChartLightSourceCollection^ LightSources {
   ChartLightSourceCollection^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartLightModelSettings Class
ChartLightModelSettings Members


LocalViewpointLighting Property

[image]
Intersoft WebGrid Documentation
LocalViewpointLighting Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartLightModelSettings Class : LocalViewpointLighting Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Enables/disables local viewpoint lighting. The local viewpoint lighting controls the way OpenGL calculates specular reflection angles.")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("General")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property LocalViewpointLighting As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As ChartLightModelSettings
Dim value As System.Boolean

instance.LocalViewpointLighting = value

value = instance.LocalViewpointLighting
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Enables/disables local viewpoint lighting. The local viewpoint lighting controls the way OpenGL calculates specular reflection angles.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.bool LocalViewpointLighting {get; set;}
Delphi
public read-write property LocalViewpointLighting: System.Boolean;
JScript
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DescriptionAttribute("Enables/disables local viewpoint lighting. The local viewpoint lighting controls the way OpenGL calculates specular reflection angles.")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("General")
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set LocalViewpointLighting : System.boolean
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Enables/disables local viewpoint lighting. The local viewpoint lighting controls the way OpenGL calculates specular reflection angles.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.bool get_LocalViewpointLighting();
public: __property void set_LocalViewpointLighting(
   System.bool value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Enables/disables local viewpoint lighting. The local viewpoint lighting controls the way OpenGL calculates specular reflection angles.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.bool LocalViewpointLighting {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartLightModelSettings Class
ChartLightModelSettings Members


ChartLightSourceCollection Class

[image]
Intersoft WebGrid Documentation
ChartLightSourceCollection Class
Members See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartLightSourceCollection Class

Glossary Item Box

Object Model

ChartLightSourceCollection Class

Syntax

Visual Basic (Declaration)
<System.Reflection.DefaultMemberAttribute("Item")>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.SerializableAttribute()>
Public Class ChartLightSourceCollection
   Inherits ISNet.WebUI.ISCollectionBase
Visual Basic (Usage) Copy Code
Dim instance As ChartLightSourceCollection
C#
[System.Reflection.DefaultMemberAttribute("Item")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public class ChartLightSourceCollection : ISNet.WebUI.ISCollectionBase
Delphi
public class ChartLightSourceCollection = class(ISNet.WebUI.ISCollectionBase)
JScript
System.Reflection.DefaultMemberAttribute("Item")
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.SerializableAttribute()
public class ChartLightSourceCollection extends ISNet.WebUI.ISCollectionBase
Managed Extensions for C++
[System.Reflection.DefaultMemberAttribute("Item")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public __gc class ChartLightSourceCollection : public ISNet.WebUI.ISCollectionBase
C++/CLI
[System.Reflection.DefaultMemberAttribute("Item")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public ref class ChartLightSourceCollection : public ISNet.WebUI.ISCollectionBase

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
ISNet.WebUI.ISCollectionBase
ISNet.WebUI.WebGrid.Chart.ChartLightSourceCollection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartLightSourceCollection Members
ISNet.WebUI.WebGrid.Chart Namespace


ChartLightSourceCollection Class Members

[image]
Intersoft WebGrid Documentation
ChartLightSourceCollection Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartLightSourceCollection Class

Glossary Item Box

The following tables list the members exposed by ChartLightSourceCollection.

Public Constructors

 | Name | Description
Public Constructor | ChartLightSourceCollection Constructor |
Top

Public Properties

 | Name | Description
Public Property | Capacity | (Inherited from System.Collections.CollectionBase)
Public Property | Count | (Inherited from System.Collections.CollectionBase)
Public Property | IsReadOnly | Overridden.
Public Property | Item |
Public Property | Parent | (Inherited from ISNet.WebUI.ISCollectionBase)
Top

Public Methods

 | Name | Description
Public Method | Add |
Public Method | Clear |
Public Method | Contains | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | CopyFrom |
Public Method | CopyTo | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | Exists | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | GetEnumerator |
Public Method | GetItem | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | GetNamedItem |
Public Method | IndexOf | Overloaded.
Public Method | Insert |
Public Method | IntInsert | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | Remove |
Public Method | setParent | (Inherited from ISNet.WebUI.ISCollectionBase)
Top

See Also

Reference

ChartLightSourceCollection Class
ISNet.WebUI.WebGrid.Chart Namespace


ChartLightSourceCollection Constructor

[image]
Intersoft WebGrid Documentation
ChartLightSourceCollection Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartLightSourceCollection Class : ChartLightSourceCollection Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New ChartLightSourceCollection()
C#
public ChartLightSourceCollection()
Delphi
public ChartLightSourceCollection();
JScript
public function ChartLightSourceCollection();
Managed Extensions for C++
public: ChartLightSourceCollection();
C++/CLI
public:
ChartLightSourceCollection();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartLightSourceCollection Class
ChartLightSourceCollection Members


ChartLightSourceCollection Class Methods

[image]
Intersoft WebGrid Documentation
ChartLightSourceCollection Class Methods
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartLightSourceCollection Class

Glossary Item Box

For a list of all members of this type, see ChartLightSourceCollection members.

Public Methods

 | Name | Description
Public Method | Add |
Public Method | Clear |
Public Method | Contains | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | CopyFrom |
Public Method | CopyTo | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | Exists | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | GetEnumerator |
Public Method | GetItem | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | GetNamedItem |
Public Method | IndexOf | Overloaded.
Public Method | Insert |
Public Method | IntInsert | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | Remove |
Public Method | setParent | (Inherited from ISNet.WebUI.ISCollectionBase)
Top

See Also

Reference

ChartLightSourceCollection Class
ISNet.WebUI.WebGrid.Chart Namespace


Add Method

[image]
Intersoft WebGrid Documentation
Add Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartLightSourceCollection Class : Add Method

item

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function Add( _
   ByVal item As ChartLightSourceSettings _
) As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As ChartLightSourceCollection
Dim item As ChartLightSourceSettings
Dim value As System.Integer

value = instance.Add(item)
C#
public System.int Add(
   ChartLightSourceSettings item
)
Delphi
public function Add(
    item: ChartLightSourceSettings
): System.Integer;
JScript
public function Add(
   item : ChartLightSourceSettings
) : System.int;
Managed Extensions for C++
public: System.int Add(
   ChartLightSourceSettings* item
)
C++/CLI
public:
System.int Add(
   ChartLightSourceSettings^ item
)

Parameters

item

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartLightSourceCollection Class
ChartLightSourceCollection Members


Clear Method

[image]
Intersoft WebGrid Documentation
Clear Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartLightSourceCollection Class : Clear Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Shadows Sub Clear()
Visual Basic (Usage) Copy Code
Dim instance As ChartLightSourceCollection

instance.Clear()
C#
public new void Clear()
Delphi
public procedure Clear();
JScript
public hide function Clear();
Managed Extensions for C++
public: new void Clear();
C++/CLI
public:
new void Clear();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartLightSourceCollection Class
ChartLightSourceCollection Members


Contains Method

[image]
Intersoft WebGrid Documentation
Contains Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartLightSourceCollection Class : Contains Method

value

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function Contains( _
   ByVal value As ISNet.WebUI.INamedObject _
) As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As ChartLightSourceCollection
Dim value As ISNet.WebUI.INamedObject
Dim value As System.Boolean

value = instance.Contains(value)
C#
public System.bool Contains(
   ISNet.WebUI.INamedObject value
)
Delphi
public function Contains(
    value: ISNet.WebUI.INamedObject
): System.Boolean;
JScript
public function Contains(
   value : ISNet.WebUI.INamedObject
) : System.boolean;
Managed Extensions for C++
public: System.bool Contains(
   ISNet.WebUI.INamedObject* value
)
C++/CLI
public:
System.bool Contains(
   ISNet.WebUI.INamedObject^ value
)

Parameters

value

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartLightSourceCollection Class
ChartLightSourceCollection Members


CopyFrom Method

[image]
Intersoft WebGrid Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartLightSourceCollection Class : CopyFrom Method

passIn

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function CopyFrom( _
   ByVal passIn As ChartLightSourceCollection _
) As ChartLightSourceCollection
Visual Basic (Usage) Copy Code
Dim instance As ChartLightSourceCollection
Dim passIn As ChartLightSourceCollection
Dim value As ChartLightSourceCollection

value = instance.CopyFrom(passIn)
C#
public ChartLightSourceCollection CopyFrom(
   ChartLightSourceCollection passIn
)
Delphi
public function CopyFrom(
    passIn: ChartLightSourceCollection
): ChartLightSourceCollection;
JScript
public function CopyFrom(
   passIn : ChartLightSourceCollection
) : ChartLightSourceCollection;
Managed Extensions for C++
public: ChartLightSourceCollection* CopyFrom(
   ChartLightSourceCollection* passIn
)
C++/CLI
public:
ChartLightSourceCollection^ CopyFrom(
   ChartLightSourceCollection^ passIn
)

Parameters

passIn

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartLightSourceCollection Class
ChartLightSourceCollection Members


CopyTo Method

[image]
Intersoft WebGrid Documentation
CopyTo Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartLightSourceCollection Class : CopyTo Method

array
index

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub CopyTo( _
   ByVal array() As ISNet.WebUI.INamedObject, _
   ByVal index As System.Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartLightSourceCollection
Dim array() As ISNet.WebUI.INamedObject
Dim index As System.Integer

instance.CopyTo(array, index)
C#
public void CopyTo(
   ISNet.WebUI.INamedObject[] array,
   System.int index
)
Delphi
public procedure CopyTo(
    array: ISNet.WebUI.INamedObjectarray of;
    index: System.Integer
);
JScript
public function CopyTo(
   array : ISNet.WebUI.INamedObject[],
   index : System.int
);
Managed Extensions for C++
public: void CopyTo(
   ISNet.WebUI.INamedObject*[]* array,
   System.int index
)
C++/CLI
public:
void CopyTo(
   ISNet.WebUI.array<INamedObject^>^ array,
   System.int index
)

Parameters

array
index

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartLightSourceCollection Class
ChartLightSourceCollection Members


Exists Method

[image]
Intersoft WebGrid Documentation
Exists Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartLightSourceCollection Class : Exists Method

name

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function Exists( _
   ByVal name As System.String _
) As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As ChartLightSourceCollection
Dim name As System.String
Dim value As System.Boolean

value = instance.Exists(name)
C#
public System.bool Exists(
   System.string name
)
Delphi
public function Exists(
    name: System.String
): System.Boolean;
JScript
public function Exists(
   name : System.String
) : System.boolean;
Managed Extensions for C++
public: System.bool Exists(
   System.string* name
)
C++/CLI
public:
System.bool Exists(
   System.String^ name
)

Parameters

name

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartLightSourceCollection Class
ChartLightSourceCollection Members


GetEnumerator Method

[image]
Intersoft WebGrid Documentation
GetEnumerator Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartLightSourceCollection Class : GetEnumerator Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Shadows Function GetEnumerator() As System.Collections.IEnumerator
Visual Basic (Usage) Copy Code
Dim instance As ChartLightSourceCollection
Dim value As System.Collections.IEnumerator

value = instance.GetEnumerator()
C#
public new System.Collections.IEnumerator GetEnumerator()
Delphi
public function GetEnumerator(): System.Collections.IEnumerator;
JScript
public hide function GetEnumerator() : System.Collections.IEnumerator;
Managed Extensions for C++
public: new System.Collections.IEnumerator* GetEnumerator();
C++/CLI
public:
new System.Collections.IEnumerator^ GetEnumerator();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartLightSourceCollection Class
ChartLightSourceCollection Members


GetItem Method

[image]
Intersoft WebGrid Documentation
GetItem Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartLightSourceCollection Class : GetItem Method

Glossary Item Box

Overload List

Overload | Description
GetItem | (Inherited from ISNet.WebUI.ISCollectionBase)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartLightSourceCollection Class
ChartLightSourceCollection Members


GetItem(Int32) Method

[image]
Intersoft WebGrid Documentation
GetItem(Int32) Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartLightSourceCollection Class : GetItem(Int32) Method

index

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetItem( _
   ByVal index As System.Integer _
) As ISNet.WebUI.INamedObject
Visual Basic (Usage) Copy Code
Dim instance As ChartLightSourceCollection
Dim index As System.Integer
Dim value As ISNet.WebUI.INamedObject

value = instance.GetItem(index)
C#
public virtual ISNet.WebUI.INamedObject GetItem(
   System.int index
)
Delphi
public function GetItem(
    index: System.Integer
): ISNet.WebUI.INamedObject; virtual;
JScript
public function GetItem(
   index : System.int
) : ISNet.WebUI.INamedObject;
Managed Extensions for C++
public: virtual ISNet.WebUI.INamedObject* GetItem(
   System.int index
)
C++/CLI
public:
virtual ISNet.WebUI.INamedObject^ GetItem(
   System.int index
)

Parameters

index

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartLightSourceCollection Class
ChartLightSourceCollection Members


GetNamedItem Method

[image]
Intersoft WebGrid Documentation
GetNamedItem Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartLightSourceCollection Class : GetNamedItem Method

name

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetNamedItem( _
   ByVal name As System.String _
) As ChartLightSourceSettings
Visual Basic (Usage) Copy Code
Dim instance As ChartLightSourceCollection
Dim name As System.String
Dim value As ChartLightSourceSettings

value = instance.GetNamedItem(name)
C#
public ChartLightSourceSettings GetNamedItem(
   System.string name
)
Delphi
public function GetNamedItem(
    name: System.String
): ChartLightSourceSettings;
JScript
public function GetNamedItem(
   name : System.String
) : ChartLightSourceSettings;
Managed Extensions for C++
public: ChartLightSourceSettings* GetNamedItem(
   System.string* name
)
C++/CLI
public:
ChartLightSourceSettings^ GetNamedItem(
   System.String^ name
)

Parameters

name

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartLightSourceCollection Class
ChartLightSourceCollection Members


IndexOf Method

[image]
Intersoft WebGrid Documentation
IndexOf Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartLightSourceCollection Class : IndexOf Method

Glossary Item Box

Overload List

Overload | Description
IndexOf(String) | (Inherited from ISNet.WebUI.ISCollectionBase)
IndexOf(INamedObject) | (Inherited from ISNet.WebUI.ISCollectionBase)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartLightSourceCollection Class
ChartLightSourceCollection Members


IndexOf(String) Method

[image]
Intersoft WebGrid Documentation
IndexOf(String) Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartLightSourceCollection Class > IndexOf Method : IndexOf(String) Method

name

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function IndexOf( _
   ByVal name As System.String _
) As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As ChartLightSourceCollection
Dim name As System.String
Dim value As System.Integer

value = instance.IndexOf(name)
C#
public virtual System.int IndexOf(
   System.string name
)
Delphi
public function IndexOf(
    name: System.String
): System.Integer; virtual;
JScript
public function IndexOf(
   name : System.String
) : System.int;
Managed Extensions for C++
public: virtual System.int IndexOf(
   System.string* name
)
C++/CLI
public:
virtual System.int IndexOf(
   System.String^ name
)

Parameters

name

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartLightSourceCollection Class
ChartLightSourceCollection Members
Overload List


IndexOf(INamedObject) Method

[image]
Intersoft WebGrid Documentation
IndexOf(INamedObject) Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartLightSourceCollection Class > IndexOf Method : IndexOf(INamedObject) Method

value

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function IndexOf( _
   ByVal value As ISNet.WebUI.INamedObject _
) As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As ChartLightSourceCollection
Dim value As ISNet.WebUI.INamedObject
Dim value As System.Integer

value = instance.IndexOf(value)
C#
public System.int IndexOf(
   ISNet.WebUI.INamedObject value
)
Delphi
public function IndexOf(
    value: ISNet.WebUI.INamedObject
): System.Integer;
JScript
public function IndexOf(
   value : ISNet.WebUI.INamedObject
) : System.int;
Managed Extensions for C++
public: System.int IndexOf(
   ISNet.WebUI.INamedObject* value
)
C++/CLI
public:
System.int IndexOf(
   ISNet.WebUI.INamedObject^ value
)

Parameters

value

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartLightSourceCollection Class
ChartLightSourceCollection Members
Overload List


Insert Method

[image]
Intersoft WebGrid Documentation
Insert Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartLightSourceCollection Class : Insert Method

index
item

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub Insert( _
   ByVal index As System.Integer, _
   ByVal item As ChartLightSourceSettings _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartLightSourceCollection
Dim index As System.Integer
Dim item As ChartLightSourceSettings

instance.Insert(index, item)
C#
public void Insert(
   System.int index,
   ChartLightSourceSettings item
)
Delphi
public procedure Insert(
    index: System.Integer;
    item: ChartLightSourceSettings
);
JScript
public function Insert(
   index : System.int,
   item : ChartLightSourceSettings
);
Managed Extensions for C++
public: void Insert(
   System.int index,
   ChartLightSourceSettings* item
)
C++/CLI
public:
void Insert(
   System.int index,
   ChartLightSourceSettings^ item
)

Parameters

index
item

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartLightSourceCollection Class
ChartLightSourceCollection Members


IntInsert Method

[image]
Intersoft WebGrid Documentation
IntInsert Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartLightSourceCollection Class : IntInsert Method

index
value

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub IntInsert( _
   ByVal index As System.Integer, _
   ByVal value As ISNet.WebUI.INamedObject _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartLightSourceCollection
Dim index As System.Integer
Dim value As ISNet.WebUI.INamedObject

instance.IntInsert(index, value)
C#
public void IntInsert(
   System.int index,
   ISNet.WebUI.INamedObject value
)
Delphi
public procedure IntInsert(
    index: System.Integer;
    value: ISNet.WebUI.INamedObject
);
JScript
public function IntInsert(
   index : System.int,
   value : ISNet.WebUI.INamedObject
);
Managed Extensions for C++
public: void IntInsert(
   System.int index,
   ISNet.WebUI.INamedObject* value
)
C++/CLI
public:
void IntInsert(
   System.int index,
   ISNet.WebUI.INamedObject^ value
)

Parameters

index
value

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartLightSourceCollection Class
ChartLightSourceCollection Members


Remove Method

[image]
Intersoft WebGrid Documentation
Remove Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartLightSourceCollection Class : Remove Method

item

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub Remove( _
   ByVal item As ChartLightSourceSettings _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartLightSourceCollection
Dim item As ChartLightSourceSettings

instance.Remove(item)
C#
public void Remove(
   ChartLightSourceSettings item
)
Delphi
public procedure Remove(
    item: ChartLightSourceSettings
);
JScript
public function Remove(
   item : ChartLightSourceSettings
);
Managed Extensions for C++
public: void Remove(
   ChartLightSourceSettings* item
)
C++/CLI
public:
void Remove(
   ChartLightSourceSettings^ item
)

Parameters

item

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartLightSourceCollection Class
ChartLightSourceCollection Members


setParent Method

[image]
Intersoft WebGrid Documentation
setParent Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartLightSourceCollection Class : setParent Method

parent

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub setParent( _
   ByVal parent As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartLightSourceCollection
Dim parent As System.Object

instance.setParent(parent)
C#
public virtual void setParent(
   System.object parent
)
Delphi
public procedure setParent(
    parent: System.TObject
); virtual;
JScript
public function setParent(
   parent : System.Object
);
Managed Extensions for C++
public: virtual void setParent(
   System.Object* parent
)
C++/CLI
public:
virtual void setParent(
   System.Object^ parent
)

Parameters

parent

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartLightSourceCollection Class
ChartLightSourceCollection Members


Capacity Property

[image]
Intersoft WebGrid Documentation
Capacity Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartLightSourceCollection Class : Capacity Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Runtime.InteropServices.ComVisibleAttribute(False)>
Public Property Capacity As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As ChartLightSourceCollection
Dim value As System.Integer

instance.Capacity = value

value = instance.Capacity
C#
[System.Runtime.InteropServices.ComVisibleAttribute(false)]
public System.int Capacity {get; set;}
Delphi
public read-write property Capacity: System.Integer;
JScript
System.Runtime.InteropServices.ComVisibleAttribute()
public function get,set Capacity : System.int
Managed Extensions for C++
[System.Runtime.InteropServices.ComVisibleAttribute(false)]
public: __property System.int get_Capacity();
public: __property void set_Capacity(
   System.int value
);
C++/CLI
[System.Runtime.InteropServices.ComVisibleAttribute(false)]
public:
property System.int Capacity {
   System.int get();
   void set (    System.int value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartLightSourceCollection Class
ChartLightSourceCollection Members


Count Property

[image]
Intersoft WebGrid Documentation
Count Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartLightSourceCollection Class : Count Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Count As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As ChartLightSourceCollection
Dim value As System.Integer

value = instance.Count
C#
public System.int Count {get;}
Delphi
public read-only property Count: System.Integer;
JScript
public function get Count : System.int
Managed Extensions for C++
public: __property System.int get_Count();
C++/CLI
public:
property System.int Count {
   System.int get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartLightSourceCollection Class
ChartLightSourceCollection Members


ChartLightSourceCollection Class Properties

[image]
Intersoft WebGrid Documentation
ChartLightSourceCollection Class Properties
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartLightSourceCollection Class

Glossary Item Box

For a list of all members of this type, see ChartLightSourceCollection members.

Public Properties

 | Name | Description
Public Property | Capacity | (Inherited from System.Collections.CollectionBase)
Public Property | Count | (Inherited from System.Collections.CollectionBase)
Public Property | IsReadOnly | Overridden.
Public Property | Item |
Public Property | Parent | (Inherited from ISNet.WebUI.ISCollectionBase)
Top

See Also

Reference

ChartLightSourceCollection Class
ISNet.WebUI.WebGrid.Chart Namespace


ChartLightSourceCollection Constructor

[image]
Intersoft WebGrid Documentation
ChartLightSourceCollection Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartLightSourceCollection Class : ChartLightSourceCollection Constructor

Glossary Item Box

Overload List

Overload | Description
ChartLightSourceCollection Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartLightSourceCollection Class
ChartLightSourceCollection Members


IsReadOnly Property

[image]
Intersoft WebGrid Documentation
IsReadOnly Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartLightSourceCollection Class : IsReadOnly Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property IsReadOnly As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As ChartLightSourceCollection
Dim value As System.Boolean

value = instance.IsReadOnly
C#
public override System.bool IsReadOnly {get;}
Delphi
public read-only property IsReadOnly: System.Boolean; override;
JScript
public override function get IsReadOnly : System.boolean
Managed Extensions for C++
public: __property System.bool get_IsReadOnly() override;
C++/CLI
public:
property System.bool IsReadOnly {
   System.bool get() override;
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartLightSourceCollection Class
ChartLightSourceCollection Members


Item Property

[image]
Intersoft WebGrid Documentation
Item Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartLightSourceCollection Class : Item Property

index

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Default Property Item( _
   ByVal index As System.Integer _
) As ChartLightSourceSettings
Visual Basic (Usage) Copy Code
Dim instance As ChartLightSourceCollection
Dim index As System.Integer
Dim value As ChartLightSourceSettings

instance.Item(index) = value

value = instance.Item(index)
C#
public ChartLightSourceSettings this[
   System.int index
]; {get; set;}
Delphi
public  this: : ChartLightSourceSettings;[
    index: System.Integer
]; read-write
JScript
public  this[
   index : System.int
] get,set : ChartLightSourceSettings
Managed Extensions for C++
public: __property ChartLightSourceSettings* get_Item   System.int index
;
public: __property void set_Item   System.int index,
   ChartLightSourceSettings* value
;
C++/CLI
public:
property ChartLightSourceSettings^ default [int] {
   ChartLightSourceSettings^ get(System.int index);
   void set (System.int index, ChartLightSourceSettings^ value);
}

Parameters

index

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartLightSourceCollection Class
ChartLightSourceCollection Members


Parent Property

[image]
Intersoft WebGrid Documentation
Parent Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartLightSourceCollection Class : Parent Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Parent As System.Object
Visual Basic (Usage) Copy Code
Dim instance As ChartLightSourceCollection
Dim value As System.Object

value = instance.Parent
C#
public System.object Parent {get;}
Delphi
public read-only property Parent: System.TObject;
JScript
public function get Parent : System.Object
Managed Extensions for C++
public: __property System.Object* get_Parent();
C++/CLI
public:
property System.Object^ Parent {
   System.Object^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartLightSourceCollection Class
ChartLightSourceCollection Members


ChartLineTypeSettings Class

[image]
Intersoft WebGrid Documentation
ChartLineTypeSettings Class
Members See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartLineTypeSettings Class

Glossary Item Box

Object Model

ChartLineTypeSettings Class

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.SerializableAttribute()>
Public Class ChartLineTypeSettings
   Inherits ISNet.WebUI.WebUIBaseClass
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Visual Basic (Usage) Copy Code
Dim instance As ChartLineTypeSettings
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public class ChartLineTypeSettings : ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Delphi
public class ChartLineTypeSettings = class(ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize)
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.SerializableAttribute()
public class ChartLineTypeSettings extends ISNet.WebUI.WebUIBaseClass implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public __gc class ChartLineTypeSettings : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public ref class ChartLineTypeSettings : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.WebGrid.Chart.ChartLineTypeSettings

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartLineTypeSettings Members
ISNet.WebUI.WebGrid.Chart Namespace


ChartLineTypeSettings Class Members

[image]
Intersoft WebGrid Documentation
ChartLineTypeSettings Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartLineTypeSettings Class

Glossary Item Box

The following tables list the members exposed by ChartLineTypeSettings.

Public Constructors

 | Name | Description
Public Constructor | ChartLineTypeSettings Constructor |
Top

Public Properties

 | Name | Description
Public Property | EnableBasic3DLineType |
Public Property | EnableBasic3DLineWithMarkersType |
Public Property | Enabled |
Public Property | EnableOverlapped3DLineType |
Public Property | EnableOverlapped3DLineWithMarkersType |
Public Property | EnableOverlappedLineType |
Public Property | EnableOverlappedLineWithMarkersType |
Public Property | EnableStacked3DLineType |
Public Property | EnableStacked3DLineWithMarkersType |
Public Property | EnableStackedLineType |
Public Property | EnableStackedLineWithMarkersType |
Public Property | EnableStackedPercentage3DLineType |
Public Property | EnableStackedPercentage3DLineWithMarkersType |
Public Property | EnableStackedPercentageLineType |
Public Property | EnableStackedPercentageLineWithMarkersType |
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

ChartLineTypeSettings Class
ISNet.WebUI.WebGrid.Chart Namespace


ChartLineTypeSettings Constructor

[image]
Intersoft WebGrid Documentation
ChartLineTypeSettings Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartLineTypeSettings Class : ChartLineTypeSettings Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New ChartLineTypeSettings()
C#
public ChartLineTypeSettings()
Delphi
public ChartLineTypeSettings();
JScript
public function ChartLineTypeSettings();
Managed Extensions for C++
public: ChartLineTypeSettings();
C++/CLI
public:
ChartLineTypeSettings();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartLineTypeSettings Class
ChartLineTypeSettings Members


Clone Method

[image]
Intersoft WebGrid Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartLineTypeSettings Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As System.Object
Visual Basic (Usage) Copy Code
Dim instance As ChartLineTypeSettings
Dim value As System.Object

value = instance.Clone()
C#
public virtual System.object Clone()
Delphi
public function Clone(): System.TObject; virtual;
JScript
public function Clone() : System.Object;
Managed Extensions for C++
public: virtual System.Object* Clone();
C++/CLI
public:
virtual System.Object^ Clone();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartLineTypeSettings Class
ChartLineTypeSettings Members


CopyFrom Method

[image]
Intersoft WebGrid Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartLineTypeSettings Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartLineTypeSettings Class
ChartLineTypeSettings Members


CopyFrom(Object) Method

[image]
Intersoft WebGrid Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartLineTypeSettings Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartLineTypeSettings
Dim objSource As System.Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   System.object objSource
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartLineTypeSettings Class
ChartLineTypeSettings Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebGrid Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartLineTypeSettings Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object, _
   ByVal cloneSourceValue As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartLineTypeSettings
Dim objSource As System.Object
Dim cloneSourceValue As System.Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   System.object objSource,
   System.bool cloneSourceValue
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject;
    cloneSourceValue: System.Boolean
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object,
   cloneSourceValue : System.boolean
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource,
   System.bool cloneSourceValue
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource,
   System.bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartLineTypeSettings Class
ChartLineTypeSettings Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebGrid Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartLineTypeSettings Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartLineTypeSettings
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure DeSerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function DeSerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void DeSerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void DeSerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartLineTypeSettings Class
ChartLineTypeSettings Members


GetHashCode Method

[image]
Intersoft WebGrid Documentation
GetHashCode Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartLineTypeSettings Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As ChartLineTypeSettings
Dim value As System.Integer

value = instance.GetHashCode()
C#
public virtual System.int GetHashCode()
Delphi
public function GetHashCode(): System.Integer; virtual;
JScript
public function GetHashCode() : System.int;
Managed Extensions for C++
public: virtual System.int GetHashCode();
C++/CLI
public:
virtual System.int GetHashCode();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartLineTypeSettings Class
ChartLineTypeSettings Members


ChartLineTypeSettings Class Methods

[image]
Intersoft WebGrid Documentation
ChartLineTypeSettings Class Methods
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartLineTypeSettings Class

Glossary Item Box

For a list of all members of this type, see ChartLineTypeSettings members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

ChartLineTypeSettings Class
ISNet.WebUI.WebGrid.Chart Namespace


GetObjectData Method

[image]
Intersoft WebGrid Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartLineTypeSettings Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=False,
   UnmanagedCode=False,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=True,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Action=SecurityAction.Demand,
   Unrestricted=False)>
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartLineTypeSettings
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure GetObjectData(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
); override;
JScript
System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=,
   UnmanagedCode=,
   SkipVerification=,
   Execution=,
   ControlThread=,
   ControlEvidence=,
   ControlPolicy=,
   SerializationFormatter=,
   ControlDomainPolicy=,
   ControlPrincipal=,
   ControlAppDomain=,
   RemotingConfiguration=,
   Infrastructure=,
   BindingRedirects=,
   Action=SecurityAction.Demand,
   Unrestricted=)
public override function GetObjectData(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public: void GetObjectData(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
) override
C++/CLI
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public:
void GetObjectData(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
) override

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartLineTypeSettings Class
ChartLineTypeSettings Members


IsEmpty Method

[image]
Intersoft WebGrid Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartLineTypeSettings Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As ChartLineTypeSettings
Dim value As System.Boolean

value = instance.IsEmpty()
C#
public virtual System.bool IsEmpty()
Delphi
public function IsEmpty(): System.Boolean; virtual;
JScript
public function IsEmpty() : System.boolean;
Managed Extensions for C++
public: virtual System.bool IsEmpty();
C++/CLI
public:
virtual System.bool IsEmpty();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartLineTypeSettings Class
ChartLineTypeSettings Members


Reset Method

[image]
Intersoft WebGrid Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartLineTypeSettings Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As ChartLineTypeSettings

instance.Reset()
C#
public virtual void Reset()
Delphi
public procedure Reset(); virtual;
JScript
public function Reset();
Managed Extensions for C++
public: virtual void Reset();
C++/CLI
public:
virtual void Reset();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartLineTypeSettings Class
ChartLineTypeSettings Members


SerializeObjectData Method

[image]
Intersoft WebGrid Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartLineTypeSettings Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartLineTypeSettings
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure SerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function SerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void SerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void SerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartLineTypeSettings Class
ChartLineTypeSettings Members


ToString Method

[image]
Intersoft WebGrid Documentation
ToString Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartLineTypeSettings Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As System.String
Visual Basic (Usage) Copy Code
Dim instance As ChartLineTypeSettings
Dim value As System.String

value = instance.ToString()
C#
public virtual System.string ToString()
Delphi
public function ToString(): System.String; virtual;
JScript
public function ToString() : System.String;
Managed Extensions for C++
public: virtual System.string* ToString();
C++/CLI
public:
virtual System.String^ ToString();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartLineTypeSettings Class
ChartLineTypeSettings Members


ChartLineTypeSettings Class Properties

[image]
Intersoft WebGrid Documentation
ChartLineTypeSettings Class Properties
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartLineTypeSettings Class

Glossary Item Box

For a list of all members of this type, see ChartLineTypeSettings members.

Public Properties

 | Name | Description
Public Property | EnableBasic3DLineType |
Public Property | EnableBasic3DLineWithMarkersType |
Public Property | Enabled |
Public Property | EnableOverlapped3DLineType |
Public Property | EnableOverlapped3DLineWithMarkersType |
Public Property | EnableOverlappedLineType |
Public Property | EnableOverlappedLineWithMarkersType |
Public Property | EnableStacked3DLineType |
Public Property | EnableStacked3DLineWithMarkersType |
Public Property | EnableStackedLineType |
Public Property | EnableStackedLineWithMarkersType |
Public Property | EnableStackedPercentage3DLineType |
Public Property | EnableStackedPercentage3DLineWithMarkersType |
Public Property | EnableStackedPercentageLineType |
Public Property | EnableStackedPercentageLineWithMarkersType |
Top

See Also

Reference

ChartLineTypeSettings Class
ISNet.WebUI.WebGrid.Chart Namespace


ChartLineTypeSettings Constructor

[image]
Intersoft WebGrid Documentation
ChartLineTypeSettings Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartLineTypeSettings Class : ChartLineTypeSettings Constructor

Glossary Item Box

Overload List

Overload | Description
ChartLineTypeSettings Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartLineTypeSettings Class
ChartLineTypeSettings Members


EnableBasic3DLineType Property

[image]
Intersoft WebGrid Documentation
EnableBasic3DLineType Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartLineTypeSettings Class : EnableBasic3DLineType Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Options")>
<System.ComponentModel.DescriptionAttribute("Enable user to switch chart to Basic 3D Line type.")>
Public Property EnableBasic3DLineType As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As ChartLineTypeSettings
Dim value As System.Boolean

instance.EnableBasic3DLineType = value

value = instance.EnableBasic3DLineType
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Options")]
[System.ComponentModel.DescriptionAttribute("Enable user to switch chart to Basic 3D Line type.")]
public System.bool EnableBasic3DLineType {get; set;}
Delphi
public read-write property EnableBasic3DLineType: System.Boolean;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Options")
System.ComponentModel.DescriptionAttribute("Enable user to switch chart to Basic 3D Line type.")
public function get,set EnableBasic3DLineType : System.boolean
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Options")]
[System.ComponentModel.DescriptionAttribute("Enable user to switch chart to Basic 3D Line type.")]
public: __property System.bool get_EnableBasic3DLineType();
public: __property void set_EnableBasic3DLineType(
   System.bool value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Options")]
[System.ComponentModel.DescriptionAttribute("Enable user to switch chart to Basic 3D Line type.")]
public:
property System.bool EnableBasic3DLineType {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartLineTypeSettings Class
ChartLineTypeSettings Members


EnableBasic3DLineWithMarkersType Property

[image]
Intersoft WebGrid Documentation
EnableBasic3DLineWithMarkersType Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartLineTypeSettings Class : EnableBasic3DLineWithMarkersType Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Enable user to switch chart to Basic 3D Line with Markers type.")>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Options")>
Public Property EnableBasic3DLineWithMarkersType As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As ChartLineTypeSettings
Dim value As System.Boolean

instance.EnableBasic3DLineWithMarkersType = value

value = instance.EnableBasic3DLineWithMarkersType
C#
[System.ComponentModel.DescriptionAttribute("Enable user to switch chart to Basic 3D Line with Markers type.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Options")]
public System.bool EnableBasic3DLineWithMarkersType {get; set;}
Delphi
public read-write property EnableBasic3DLineWithMarkersType: System.Boolean;
JScript
System.ComponentModel.DescriptionAttribute("Enable user to switch chart to Basic 3D Line with Markers type.")
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Options")
public function get,set EnableBasic3DLineWithMarkersType : System.boolean
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Enable user to switch chart to Basic 3D Line with Markers type.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Options")]
public: __property System.bool get_EnableBasic3DLineWithMarkersType();
public: __property void set_EnableBasic3DLineWithMarkersType(
   System.bool value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Enable user to switch chart to Basic 3D Line with Markers type.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Options")]
public:
property System.bool EnableBasic3DLineWithMarkersType {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartLineTypeSettings Class
ChartLineTypeSettings Members


Enabled Property

[image]
Intersoft WebGrid Documentation
Enabled Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartLineTypeSettings Class : Enabled Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Options")>
<System.ComponentModel.DescriptionAttribute("Enable user to switch chart to Series Line types.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
Public Property Enabled As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As ChartLineTypeSettings
Dim value As System.Boolean

instance.Enabled = value

value = instance.Enabled
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Options")]
[System.ComponentModel.DescriptionAttribute("Enable user to switch chart to Series Line types.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public System.bool Enabled {get; set;}
Delphi
public read-write property Enabled: System.Boolean;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Options")
System.ComponentModel.DescriptionAttribute("Enable user to switch chart to Series Line types.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
public function get,set Enabled : System.boolean
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Options")]
[System.ComponentModel.DescriptionAttribute("Enable user to switch chart to Series Line types.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.bool get_Enabled();
public: __property void set_Enabled(
   System.bool value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Options")]
[System.ComponentModel.DescriptionAttribute("Enable user to switch chart to Series Line types.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.bool Enabled {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartLineTypeSettings Class
ChartLineTypeSettings Members


EnableOverlapped3DLineType Property

[image]
Intersoft WebGrid Documentation
EnableOverlapped3DLineType Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartLineTypeSettings Class : EnableOverlapped3DLineType Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Options")>
<System.ComponentModel.DescriptionAttribute("Enable user to switch chart to Overlapped 3D Line type.")>
Public Property EnableOverlapped3DLineType As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As ChartLineTypeSettings
Dim value As System.Boolean

instance.EnableOverlapped3DLineType = value

value = instance.EnableOverlapped3DLineType
C#
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Options")]
[System.ComponentModel.DescriptionAttribute("Enable user to switch chart to Overlapped 3D Line type.")]
public System.bool EnableOverlapped3DLineType {get; set;}
Delphi
public read-write property EnableOverlapped3DLineType: System.Boolean;
JScript
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Options")
System.ComponentModel.DescriptionAttribute("Enable user to switch chart to Overlapped 3D Line type.")
public function get,set EnableOverlapped3DLineType : System.boolean
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Options")]
[System.ComponentModel.DescriptionAttribute("Enable user to switch chart to Overlapped 3D Line type.")]
public: __property System.bool get_EnableOverlapped3DLineType();
public: __property void set_EnableOverlapped3DLineType(
   System.bool value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Options")]
[System.ComponentModel.DescriptionAttribute("Enable user to switch chart to Overlapped 3D Line type.")]
public:
property System.bool EnableOverlapped3DLineType {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartLineTypeSettings Class
ChartLineTypeSettings Members


EnableOverlapped3DLineWithMarkersType Property

[image]
Intersoft WebGrid Documentation
EnableOverlapped3DLineWithMarkersType Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartLineTypeSettings Class : EnableOverlapped3DLineWithMarkersType Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Enable user to switch chart to Overlapped 3D Line with Markers type.")>
<System.ComponentModel.CategoryAttribute("Options")>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property EnableOverlapped3DLineWithMarkersType As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As ChartLineTypeSettings
Dim value As System.Boolean

instance.EnableOverlapped3DLineWithMarkersType = value

value = instance.EnableOverlapped3DLineWithMarkersType
C#
[System.ComponentModel.DescriptionAttribute("Enable user to switch chart to Overlapped 3D Line with Markers type.")]
[System.ComponentModel.CategoryAttribute("Options")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.bool EnableOverlapped3DLineWithMarkersType {get; set;}
Delphi
public read-write property EnableOverlapped3DLineWithMarkersType: System.Boolean;
JScript
System.ComponentModel.DescriptionAttribute("Enable user to switch chart to Overlapped 3D Line with Markers type.")
System.ComponentModel.CategoryAttribute("Options")
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set EnableOverlapped3DLineWithMarkersType : System.boolean
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Enable user to switch chart to Overlapped 3D Line with Markers type.")]
[System.ComponentModel.CategoryAttribute("Options")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.bool get_EnableOverlapped3DLineWithMarkersType();
public: __property void set_EnableOverlapped3DLineWithMarkersType(
   System.bool value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Enable user to switch chart to Overlapped 3D Line with Markers type.")]
[System.ComponentModel.CategoryAttribute("Options")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.bool EnableOverlapped3DLineWithMarkersType {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartLineTypeSettings Class
ChartLineTypeSettings Members


EnableOverlappedLineType Property

[image]
Intersoft WebGrid Documentation
EnableOverlappedLineType Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartLineTypeSettings Class : EnableOverlappedLineType Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Options")>
<System.ComponentModel.DescriptionAttribute("Enable user to switch chart to Overlapped Line type.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
Public Property EnableOverlappedLineType As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As ChartLineTypeSettings
Dim value As System.Boolean

instance.EnableOverlappedLineType = value

value = instance.EnableOverlappedLineType
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Options")]
[System.ComponentModel.DescriptionAttribute("Enable user to switch chart to Overlapped Line type.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public System.bool EnableOverlappedLineType {get; set;}
Delphi
public read-write property EnableOverlappedLineType: System.Boolean;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Options")
System.ComponentModel.DescriptionAttribute("Enable user to switch chart to Overlapped Line type.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
public function get,set EnableOverlappedLineType : System.boolean
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Options")]
[System.ComponentModel.DescriptionAttribute("Enable user to switch chart to Overlapped Line type.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.bool get_EnableOverlappedLineType();
public: __property void set_EnableOverlappedLineType(
   System.bool value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Options")]
[System.ComponentModel.DescriptionAttribute("Enable user to switch chart to Overlapped Line type.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.bool EnableOverlappedLineType {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartLineTypeSettings Class
ChartLineTypeSettings Members


EnableOverlappedLineWithMarkersType Property

[image]
Intersoft WebGrid Documentation
EnableOverlappedLineWithMarkersType Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartLineTypeSettings Class : EnableOverlappedLineWithMarkersType Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Enable user to switch chart to Overlapped Line with Markers type.")>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Options")>
Public Property EnableOverlappedLineWithMarkersType As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As ChartLineTypeSettings
Dim value As System.Boolean

instance.EnableOverlappedLineWithMarkersType = value

value = instance.EnableOverlappedLineWithMarkersType
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Enable user to switch chart to Overlapped Line with Markers type.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Options")]
public System.bool EnableOverlappedLineWithMarkersType {get; set;}
Delphi
public read-write property EnableOverlappedLineWithMarkersType: System.Boolean;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Enable user to switch chart to Overlapped Line with Markers type.")
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Options")
public function get,set EnableOverlappedLineWithMarkersType : System.boolean
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Enable user to switch chart to Overlapped Line with Markers type.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Options")]
public: __property System.bool get_EnableOverlappedLineWithMarkersType();
public: __property void set_EnableOverlappedLineWithMarkersType(
   System.bool value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Enable user to switch chart to Overlapped Line with Markers type.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Options")]
public:
property System.bool EnableOverlappedLineWithMarkersType {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartLineTypeSettings Class
ChartLineTypeSettings Members


EnableStacked3DLineType Property

[image]
Intersoft WebGrid Documentation
EnableStacked3DLineType Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartLineTypeSettings Class : EnableStacked3DLineType Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Options")>
<System.ComponentModel.DescriptionAttribute("Enable user to switch chart to Stacked 3D Line type.")>
Public Property EnableStacked3DLineType As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As ChartLineTypeSettings
Dim value As System.Boolean

instance.EnableStacked3DLineType = value

value = instance.EnableStacked3DLineType
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Options")]
[System.ComponentModel.DescriptionAttribute("Enable user to switch chart to Stacked 3D Line type.")]
public System.bool EnableStacked3DLineType {get; set;}
Delphi
public read-write property EnableStacked3DLineType: System.Boolean;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Options")
System.ComponentModel.DescriptionAttribute("Enable user to switch chart to Stacked 3D Line type.")
public function get,set EnableStacked3DLineType : System.boolean
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Options")]
[System.ComponentModel.DescriptionAttribute("Enable user to switch chart to Stacked 3D Line type.")]
public: __property System.bool get_EnableStacked3DLineType();
public: __property void set_EnableStacked3DLineType(
   System.bool value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Options")]
[System.ComponentModel.DescriptionAttribute("Enable user to switch chart to Stacked 3D Line type.")]
public:
property System.bool EnableStacked3DLineType {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartLineTypeSettings Class
ChartLineTypeSettings Members


EnableStacked3DLineWithMarkersType Property

[image]
Intersoft WebGrid Documentation
EnableStacked3DLineWithMarkersType Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartLineTypeSettings Class : EnableStacked3DLineWithMarkersType Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Enable user to switch chart to Stacked 3D Line with Markers type.")>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Options")>
Public Property EnableStacked3DLineWithMarkersType As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As ChartLineTypeSettings
Dim value As System.Boolean

instance.EnableStacked3DLineWithMarkersType = value

value = instance.EnableStacked3DLineWithMarkersType
C#
[System.ComponentModel.DescriptionAttribute("Enable user to switch chart to Stacked 3D Line with Markers type.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Options")]
public System.bool EnableStacked3DLineWithMarkersType {get; set;}
Delphi
public read-write property EnableStacked3DLineWithMarkersType: System.Boolean;
JScript
System.ComponentModel.DescriptionAttribute("Enable user to switch chart to Stacked 3D Line with Markers type.")
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Options")
public function get,set EnableStacked3DLineWithMarkersType : System.boolean
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Enable user to switch chart to Stacked 3D Line with Markers type.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Options")]
public: __property System.bool get_EnableStacked3DLineWithMarkersType();
public: __property void set_EnableStacked3DLineWithMarkersType(
   System.bool value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Enable user to switch chart to Stacked 3D Line with Markers type.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Options")]
public:
property System.bool EnableStacked3DLineWithMarkersType {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartLineTypeSettings Class
ChartLineTypeSettings Members


EnableStackedLineType Property

[image]
Intersoft WebGrid Documentation
EnableStackedLineType Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartLineTypeSettings Class : EnableStackedLineType Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Enable user to switch chart to Stacked Line type.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Options")>
Public Property EnableStackedLineType As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As ChartLineTypeSettings
Dim value As System.Boolean

instance.EnableStackedLineType = value

value = instance.EnableStackedLineType
C#
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Enable user to switch chart to Stacked Line type.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Options")]
public System.bool EnableStackedLineType {get; set;}
Delphi
public read-write property EnableStackedLineType: System.Boolean;
JScript
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Enable user to switch chart to Stacked Line type.")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Options")
public function get,set EnableStackedLineType : System.boolean
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Enable user to switch chart to Stacked Line type.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Options")]
public: __property System.bool get_EnableStackedLineType();
public: __property void set_EnableStackedLineType(
   System.bool value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Enable user to switch chart to Stacked Line type.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Options")]
public:
property System.bool EnableStackedLineType {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartLineTypeSettings Class
ChartLineTypeSettings Members


EnableStackedLineWithMarkersType Property

[image]
Intersoft WebGrid Documentation
EnableStackedLineWithMarkersType Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartLineTypeSettings Class : EnableStackedLineWithMarkersType Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Enable user to switch chart to Stacked Line with Markers type.")>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Options")>
Public Property EnableStackedLineWithMarkersType As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As ChartLineTypeSettings
Dim value As System.Boolean

instance.EnableStackedLineWithMarkersType = value

value = instance.EnableStackedLineWithMarkersType
C#
[System.ComponentModel.DescriptionAttribute("Enable user to switch chart to Stacked Line with Markers type.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Options")]
public System.bool EnableStackedLineWithMarkersType {get; set;}
Delphi
public read-write property EnableStackedLineWithMarkersType: System.Boolean;
JScript
System.ComponentModel.DescriptionAttribute("Enable user to switch chart to Stacked Line with Markers type.")
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Options")
public function get,set EnableStackedLineWithMarkersType : System.boolean
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Enable user to switch chart to Stacked Line with Markers type.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Options")]
public: __property System.bool get_EnableStackedLineWithMarkersType();
public: __property void set_EnableStackedLineWithMarkersType(
   System.bool value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Enable user to switch chart to Stacked Line with Markers type.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Options")]
public:
property System.bool EnableStackedLineWithMarkersType {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartLineTypeSettings Class
ChartLineTypeSettings Members


EnableStackedPercentage3DLineType Property

[image]
Intersoft WebGrid Documentation
EnableStackedPercentage3DLineType Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartLineTypeSettings Class : EnableStackedPercentage3DLineType Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Enable user to switch chart to 100% Stacked 3D Line type.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Options")>
Public Property EnableStackedPercentage3DLineType As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As ChartLineTypeSettings
Dim value As System.Boolean

instance.EnableStackedPercentage3DLineType = value

value = instance.EnableStackedPercentage3DLineType
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Enable user to switch chart to 100% Stacked 3D Line type.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Options")]
public System.bool EnableStackedPercentage3DLineType {get; set;}
Delphi
public read-write property EnableStackedPercentage3DLineType: System.Boolean;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DescriptionAttribute("Enable user to switch chart to 100% Stacked 3D Line type.")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Options")
public function get,set EnableStackedPercentage3DLineType : System.boolean
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Enable user to switch chart to 100% Stacked 3D Line type.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Options")]
public: __property System.bool get_EnableStackedPercentage3DLineType();
public: __property void set_EnableStackedPercentage3DLineType(
   System.bool value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Enable user to switch chart to 100% Stacked 3D Line type.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Options")]
public:
property System.bool EnableStackedPercentage3DLineType {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartLineTypeSettings Class
ChartLineTypeSettings Members


EnableStackedPercentage3DLineWithMarkersType Property

[image]
Intersoft WebGrid Documentation
EnableStackedPercentage3DLineWithMarkersType Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartLineTypeSettings Class : EnableStackedPercentage3DLineWithMarkersType Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Options")>
<System.ComponentModel.DescriptionAttribute("Enable user to switch chart to 100% Stacked 3D Line with Markers type.")>
Public Property EnableStackedPercentage3DLineWithMarkersType As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As ChartLineTypeSettings
Dim value As System.Boolean

instance.EnableStackedPercentage3DLineWithMarkersType = value

value = instance.EnableStackedPercentage3DLineWithMarkersType
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Options")]
[System.ComponentModel.DescriptionAttribute("Enable user to switch chart to 100% Stacked 3D Line with Markers type.")]
public System.bool EnableStackedPercentage3DLineWithMarkersType {get; set;}
Delphi
public read-write property EnableStackedPercentage3DLineWithMarkersType: System.Boolean;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Options")
System.ComponentModel.DescriptionAttribute("Enable user to switch chart to 100% Stacked 3D Line with Markers type.")
public function get,set EnableStackedPercentage3DLineWithMarkersType : System.boolean
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Options")]
[System.ComponentModel.DescriptionAttribute("Enable user to switch chart to 100% Stacked 3D Line with Markers type.")]
public: __property System.bool get_EnableStackedPercentage3DLineWithMarkersType();
public: __property void set_EnableStackedPercentage3DLineWithMarkersType(
   System.bool value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Options")]
[System.ComponentModel.DescriptionAttribute("Enable user to switch chart to 100% Stacked 3D Line with Markers type.")]
public:
property System.bool EnableStackedPercentage3DLineWithMarkersType {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartLineTypeSettings Class
ChartLineTypeSettings Members


EnableStackedPercentageLineType Property

[image]
Intersoft WebGrid Documentation
EnableStackedPercentageLineType Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartLineTypeSettings Class : EnableStackedPercentageLineType Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Enable user to switch chart to 100% Stacked Line type.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Options")>
Public Property EnableStackedPercentageLineType As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As ChartLineTypeSettings
Dim value As System.Boolean

instance.EnableStackedPercentageLineType = value

value = instance.EnableStackedPercentageLineType
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Enable user to switch chart to 100% Stacked Line type.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Options")]
public System.bool EnableStackedPercentageLineType {get; set;}
Delphi
public read-write property EnableStackedPercentageLineType: System.Boolean;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DescriptionAttribute("Enable user to switch chart to 100% Stacked Line type.")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Options")
public function get,set EnableStackedPercentageLineType : System.boolean
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Enable user to switch chart to 100% Stacked Line type.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Options")]
public: __property System.bool get_EnableStackedPercentageLineType();
public: __property void set_EnableStackedPercentageLineType(
   System.bool value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Enable user to switch chart to 100% Stacked Line type.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Options")]
public:
property System.bool EnableStackedPercentageLineType {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartLineTypeSettings Class
ChartLineTypeSettings Members


EnableStackedPercentageLineWithMarkersType Property

[image]
Intersoft WebGrid Documentation
EnableStackedPercentageLineWithMarkersType Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartLineTypeSettings Class : EnableStackedPercentageLineWithMarkersType Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Enable user to switch chart to 100% Stacked Line with Markers type.")>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Options")>
Public Property EnableStackedPercentageLineWithMarkersType As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As ChartLineTypeSettings
Dim value As System.Boolean

instance.EnableStackedPercentageLineWithMarkersType = value

value = instance.EnableStackedPercentageLineWithMarkersType
C#
[System.ComponentModel.DescriptionAttribute("Enable user to switch chart to 100% Stacked Line with Markers type.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Options")]
public System.bool EnableStackedPercentageLineWithMarkersType {get; set;}
Delphi
public read-write property EnableStackedPercentageLineWithMarkersType: System.Boolean;
JScript
System.ComponentModel.DescriptionAttribute("Enable user to switch chart to 100% Stacked Line with Markers type.")
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Options")
public function get,set EnableStackedPercentageLineWithMarkersType : System.boolean
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Enable user to switch chart to 100% Stacked Line with Markers type.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Options")]
public: __property System.bool get_EnableStackedPercentageLineWithMarkersType();
public: __property void set_EnableStackedPercentageLineWithMarkersType(
   System.bool value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Enable user to switch chart to 100% Stacked Line with Markers type.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Options")]
public:
property System.bool EnableStackedPercentageLineWithMarkersType {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartLineTypeSettings Class
ChartLineTypeSettings Members


ChartMarginValue Class

[image]
Intersoft WebGrid Documentation
ChartMarginValue Class
Members See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartMarginValue Class

Glossary Item Box

Object Model

ChartMarginValue Class

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.SerializableAttribute()>
Public Class ChartMarginValue
   Inherits ISNet.WebUI.WebUIBaseClass
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Visual Basic (Usage) Copy Code
Dim instance As ChartMarginValue
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public class ChartMarginValue : ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Delphi
public class ChartMarginValue = class(ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize)
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.SerializableAttribute()
public class ChartMarginValue extends ISNet.WebUI.WebUIBaseClass implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public __gc class ChartMarginValue : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public ref class ChartMarginValue : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.WebGrid.Chart.ChartMarginValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartMarginValue Members
ISNet.WebUI.WebGrid.Chart Namespace


ChartMarginValue Class Members

[image]
Intersoft WebGrid Documentation
ChartMarginValue Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartMarginValue Class

Glossary Item Box

The following tables list the members exposed by ChartMarginValue.

Public Constructors

 | Name | Description
Public Constructor | ChartMarginValue Constructor |
Top

Public Properties

 | Name | Description
Public Property | Bottom |
Public Property | Left |
Public Property | Right |
Public Property | Top |
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

ChartMarginValue Class
ISNet.WebUI.WebGrid.Chart Namespace


ChartMarginValue Constructor

[image]
Intersoft WebGrid Documentation
ChartMarginValue Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartMarginValue Class : ChartMarginValue Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New ChartMarginValue()
C#
public ChartMarginValue()
Delphi
public ChartMarginValue();
JScript
public function ChartMarginValue();
Managed Extensions for C++
public: ChartMarginValue();
C++/CLI
public:
ChartMarginValue();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartMarginValue Class
ChartMarginValue Members


Clone Method

[image]
Intersoft WebGrid Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartMarginValue Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As System.Object
Visual Basic (Usage) Copy Code
Dim instance As ChartMarginValue
Dim value As System.Object

value = instance.Clone()
C#
public virtual System.object Clone()
Delphi
public function Clone(): System.TObject; virtual;
JScript
public function Clone() : System.Object;
Managed Extensions for C++
public: virtual System.Object* Clone();
C++/CLI
public:
virtual System.Object^ Clone();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartMarginValue Class
ChartMarginValue Members


CopyFrom Method

[image]
Intersoft WebGrid Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartMarginValue Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartMarginValue Class
ChartMarginValue Members


CopyFrom(Object) Method

[image]
Intersoft WebGrid Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartMarginValue Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartMarginValue
Dim objSource As System.Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   System.object objSource
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartMarginValue Class
ChartMarginValue Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebGrid Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartMarginValue Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object, _
   ByVal cloneSourceValue As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartMarginValue
Dim objSource As System.Object
Dim cloneSourceValue As System.Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   System.object objSource,
   System.bool cloneSourceValue
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject;
    cloneSourceValue: System.Boolean
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object,
   cloneSourceValue : System.boolean
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource,
   System.bool cloneSourceValue
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource,
   System.bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartMarginValue Class
ChartMarginValue Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebGrid Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartMarginValue Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartMarginValue
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure DeSerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function DeSerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void DeSerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void DeSerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartMarginValue Class
ChartMarginValue Members


GetHashCode Method

[image]
Intersoft WebGrid Documentation
GetHashCode Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartMarginValue Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As ChartMarginValue
Dim value As System.Integer

value = instance.GetHashCode()
C#
public virtual System.int GetHashCode()
Delphi
public function GetHashCode(): System.Integer; virtual;
JScript
public function GetHashCode() : System.int;
Managed Extensions for C++
public: virtual System.int GetHashCode();
C++/CLI
public:
virtual System.int GetHashCode();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartMarginValue Class
ChartMarginValue Members


ChartMarginValue Class Methods

[image]
Intersoft WebGrid Documentation
ChartMarginValue Class Methods
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartMarginValue Class

Glossary Item Box

For a list of all members of this type, see ChartMarginValue members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

ChartMarginValue Class
ISNet.WebUI.WebGrid.Chart Namespace


GetObjectData Method

[image]
Intersoft WebGrid Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartMarginValue Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=False,
   UnmanagedCode=False,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=True,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Action=SecurityAction.Demand,
   Unrestricted=False)>
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartMarginValue
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure GetObjectData(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
); override;
JScript
System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=,
   UnmanagedCode=,
   SkipVerification=,
   Execution=,
   ControlThread=,
   ControlEvidence=,
   ControlPolicy=,
   SerializationFormatter=,
   ControlDomainPolicy=,
   ControlPrincipal=,
   ControlAppDomain=,
   RemotingConfiguration=,
   Infrastructure=,
   BindingRedirects=,
   Action=SecurityAction.Demand,
   Unrestricted=)
public override function GetObjectData(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public: void GetObjectData(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
) override
C++/CLI
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public:
void GetObjectData(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
) override

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartMarginValue Class
ChartMarginValue Members


IsEmpty Method

[image]
Intersoft WebGrid Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartMarginValue Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As ChartMarginValue
Dim value As System.Boolean

value = instance.IsEmpty()
C#
public virtual System.bool IsEmpty()
Delphi
public function IsEmpty(): System.Boolean; virtual;
JScript
public function IsEmpty() : System.boolean;
Managed Extensions for C++
public: virtual System.bool IsEmpty();
C++/CLI
public:
virtual System.bool IsEmpty();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartMarginValue Class
ChartMarginValue Members


Reset Method

[image]
Intersoft WebGrid Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartMarginValue Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As ChartMarginValue

instance.Reset()
C#
public virtual void Reset()
Delphi
public procedure Reset(); virtual;
JScript
public function Reset();
Managed Extensions for C++
public: virtual void Reset();
C++/CLI
public:
virtual void Reset();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartMarginValue Class
ChartMarginValue Members


SerializeObjectData Method

[image]
Intersoft WebGrid Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartMarginValue Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartMarginValue
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure SerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function SerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void SerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void SerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartMarginValue Class
ChartMarginValue Members


ToString Method

[image]
Intersoft WebGrid Documentation
ToString Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartMarginValue Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As System.String
Visual Basic (Usage) Copy Code
Dim instance As ChartMarginValue
Dim value As System.String

value = instance.ToString()
C#
public virtual System.string ToString()
Delphi
public function ToString(): System.String; virtual;
JScript
public function ToString() : System.String;
Managed Extensions for C++
public: virtual System.string* ToString();
C++/CLI
public:
virtual System.String^ ToString();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartMarginValue Class
ChartMarginValue Members


ChartMarginValue Class Properties

[image]
Intersoft WebGrid Documentation
ChartMarginValue Class Properties
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartMarginValue Class

Glossary Item Box

For a list of all members of this type, see ChartMarginValue members.

Public Properties

 | Name | Description
Public Property | Bottom |
Public Property | Left |
Public Property | Right |
Public Property | Top |
Top

See Also

Reference

ChartMarginValue Class
ISNet.WebUI.WebGrid.Chart Namespace


ChartMarginValue Constructor

[image]
Intersoft WebGrid Documentation
ChartMarginValue Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartMarginValue Class : ChartMarginValue Constructor

Glossary Item Box

Overload List

Overload | Description
ChartMarginValue Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartMarginValue Class
ChartMarginValue Members


Bottom Property

[image]
Intersoft WebGrid Documentation
Bottom Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartMarginValue Class : Bottom Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Bottom Margin.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("General")>
Public Property Bottom As System.Nullable(Of Single)
Visual Basic (Usage) Copy Code
Dim instance As ChartMarginValue
Dim value As System.Nullable(Of Single)

instance.Bottom = value

value = instance.Bottom
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Bottom Margin.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
public System.Nullable<float> Bottom {get; set;}
Delphi
public read-write property Bottom: System.Nullable;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Bottom Margin.")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("General")
public function get,set Bottom : System.Nullable
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Bottom Margin.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
public: __property System.Nullable<float> get_Bottom();
public: __property void set_Bottom(
   System.Nullable<float> value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Bottom Margin.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
public:
property System.Nullable<float> Bottom {
   System.Nullable<float> get();
   void set (    System.Nullable<float> value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartMarginValue Class
ChartMarginValue Members


Left Property

[image]
Intersoft WebGrid Documentation
Left Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartMarginValue Class : Left Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("General")>
<System.ComponentModel.DescriptionAttribute("Left Margin.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property Left As System.Nullable(Of Single)
Visual Basic (Usage) Copy Code
Dim instance As ChartMarginValue
Dim value As System.Nullable(Of Single)

instance.Left = value

value = instance.Left
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DescriptionAttribute("Left Margin.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.Nullable<float> Left {get; set;}
Delphi
public read-write property Left: System.Nullable;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("General")
System.ComponentModel.DescriptionAttribute("Left Margin.")
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set Left : System.Nullable
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DescriptionAttribute("Left Margin.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.Nullable<float> get_Left();
public: __property void set_Left(
   System.Nullable<float> value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DescriptionAttribute("Left Margin.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.Nullable<float> Left {
   System.Nullable<float> get();
   void set (    System.Nullable<float> value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartMarginValue Class
ChartMarginValue Members


Right Property

[image]
Intersoft WebGrid Documentation
Right Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartMarginValue Class : Right Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("General")>
<System.ComponentModel.DescriptionAttribute("Right Margin.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property Right As System.Nullable(Of Single)
Visual Basic (Usage) Copy Code
Dim instance As ChartMarginValue
Dim value As System.Nullable(Of Single)

instance.Right = value

value = instance.Right
C#
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DescriptionAttribute("Right Margin.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.Nullable<float> Right {get; set;}
Delphi
public read-write property Right: System.Nullable;
JScript
System.ComponentModel.CategoryAttribute("General")
System.ComponentModel.DescriptionAttribute("Right Margin.")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set Right : System.Nullable
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DescriptionAttribute("Right Margin.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.Nullable<float> get_Right();
public: __property void set_Right(
   System.Nullable<float> value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DescriptionAttribute("Right Margin.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.Nullable<float> Right {
   System.Nullable<float> get();
   void set (    System.Nullable<float> value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartMarginValue Class
ChartMarginValue Members


Top Property

[image]
Intersoft WebGrid Documentation
Top Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartMarginValue Class : Top Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Top Margin.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("General")>
Public Property Top As System.Nullable(Of Single)
Visual Basic (Usage) Copy Code
Dim instance As ChartMarginValue
Dim value As System.Nullable(Of Single)

instance.Top = value

value = instance.Top
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Top Margin.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("General")]
public System.Nullable<float> Top {get; set;}
Delphi
public read-write property Top: System.Nullable;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DescriptionAttribute("Top Margin.")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("General")
public function get,set Top : System.Nullable
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Top Margin.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("General")]
public: __property System.Nullable<float> get_Top();
public: __property void set_Top(
   System.Nullable<float> value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Top Margin.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("General")]
public:
property System.Nullable<float> Top {
   System.Nullable<float> get();
   void set (    System.Nullable<float> value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartMarginValue Class
ChartMarginValue Members


ChartMaterialStyle Class

[image]
Intersoft WebGrid Documentation
ChartMaterialStyle Class
Members See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartMaterialStyle Class

Glossary Item Box

Object Model

ChartMaterialStyle Class

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.SerializableAttribute()>
Public Class ChartMaterialStyle
   Inherits ISNet.WebUI.WebUIBaseClass
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Visual Basic (Usage) Copy Code
Dim instance As ChartMaterialStyle
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public class ChartMaterialStyle : ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Delphi
public class ChartMaterialStyle = class(ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize)
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.SerializableAttribute()
public class ChartMaterialStyle extends ISNet.WebUI.WebUIBaseClass implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public __gc class ChartMaterialStyle : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public ref class ChartMaterialStyle : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.WebGrid.Chart.ChartMaterialStyle

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartMaterialStyle Members
ISNet.WebUI.WebGrid.Chart Namespace


ChartMaterialStyle Class Members

[image]
Intersoft WebGrid Documentation
ChartMaterialStyle Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartMaterialStyle Class

Glossary Item Box

The following tables list the members exposed by ChartMaterialStyle.

Public Constructors

 | Name | Description
Public Constructor | ChartMaterialStyle Constructor |
Top

Public Properties

 | Name | Description
Public Property | Ambient |
Public Property | Diffuse |
Public Property | Emissive |
Public Property | Shininess |
Public Property | Specular |
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

ChartMaterialStyle Class
ISNet.WebUI.WebGrid.Chart Namespace


ChartMaterialStyle Constructor

[image]
Intersoft WebGrid Documentation
ChartMaterialStyle Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartMaterialStyle Class : ChartMaterialStyle Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New ChartMaterialStyle()
C#
public ChartMaterialStyle()
Delphi
public ChartMaterialStyle();
JScript
public function ChartMaterialStyle();
Managed Extensions for C++
public: ChartMaterialStyle();
C++/CLI
public:
ChartMaterialStyle();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartMaterialStyle Class
ChartMaterialStyle Members


Clone Method

[image]
Intersoft WebGrid Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartMaterialStyle Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As System.Object
Visual Basic (Usage) Copy Code
Dim instance As ChartMaterialStyle
Dim value As System.Object

value = instance.Clone()
C#
public virtual System.object Clone()
Delphi
public function Clone(): System.TObject; virtual;
JScript
public function Clone() : System.Object;
Managed Extensions for C++
public: virtual System.Object* Clone();
C++/CLI
public:
virtual System.Object^ Clone();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartMaterialStyle Class
ChartMaterialStyle Members


CopyFrom Method

[image]
Intersoft WebGrid Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartMaterialStyle Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartMaterialStyle Class
ChartMaterialStyle Members


CopyFrom(Object) Method

[image]
Intersoft WebGrid Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartMaterialStyle Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartMaterialStyle
Dim objSource As System.Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   System.object objSource
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartMaterialStyle Class
ChartMaterialStyle Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebGrid Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartMaterialStyle Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object, _
   ByVal cloneSourceValue As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartMaterialStyle
Dim objSource As System.Object
Dim cloneSourceValue As System.Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   System.object objSource,
   System.bool cloneSourceValue
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject;
    cloneSourceValue: System.Boolean
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object,
   cloneSourceValue : System.boolean
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource,
   System.bool cloneSourceValue
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource,
   System.bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartMaterialStyle Class
ChartMaterialStyle Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebGrid Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartMaterialStyle Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartMaterialStyle
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure DeSerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function DeSerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void DeSerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void DeSerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartMaterialStyle Class
ChartMaterialStyle Members


GetHashCode Method

[image]
Intersoft WebGrid Documentation
GetHashCode Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartMaterialStyle Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As ChartMaterialStyle
Dim value As System.Integer

value = instance.GetHashCode()
C#
public virtual System.int GetHashCode()
Delphi
public function GetHashCode(): System.Integer; virtual;
JScript
public function GetHashCode() : System.int;
Managed Extensions for C++
public: virtual System.int GetHashCode();
C++/CLI
public:
virtual System.int GetHashCode();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartMaterialStyle Class
ChartMaterialStyle Members


ChartMaterialStyle Class Methods

[image]
Intersoft WebGrid Documentation
ChartMaterialStyle Class Methods
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartMaterialStyle Class

Glossary Item Box

For a list of all members of this type, see ChartMaterialStyle members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

ChartMaterialStyle Class
ISNet.WebUI.WebGrid.Chart Namespace


GetObjectData Method

[image]
Intersoft WebGrid Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartMaterialStyle Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=False,
   UnmanagedCode=False,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=True,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Action=SecurityAction.Demand,
   Unrestricted=False)>
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartMaterialStyle
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure GetObjectData(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
); override;
JScript
System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=,
   UnmanagedCode=,
   SkipVerification=,
   Execution=,
   ControlThread=,
   ControlEvidence=,
   ControlPolicy=,
   SerializationFormatter=,
   ControlDomainPolicy=,
   ControlPrincipal=,
   ControlAppDomain=,
   RemotingConfiguration=,
   Infrastructure=,
   BindingRedirects=,
   Action=SecurityAction.Demand,
   Unrestricted=)
public override function GetObjectData(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public: void GetObjectData(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
) override
C++/CLI
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public:
void GetObjectData(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
) override

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartMaterialStyle Class
ChartMaterialStyle Members


IsEmpty Method

[image]
Intersoft WebGrid Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartMaterialStyle Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As ChartMaterialStyle
Dim value As System.Boolean

value = instance.IsEmpty()
C#
public virtual System.bool IsEmpty()
Delphi
public function IsEmpty(): System.Boolean; virtual;
JScript
public function IsEmpty() : System.boolean;
Managed Extensions for C++
public: virtual System.bool IsEmpty();
C++/CLI
public:
virtual System.bool IsEmpty();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartMaterialStyle Class
ChartMaterialStyle Members


Reset Method

[image]
Intersoft WebGrid Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartMaterialStyle Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As ChartMaterialStyle

instance.Reset()
C#
public virtual void Reset()
Delphi
public procedure Reset(); virtual;
JScript
public function Reset();
Managed Extensions for C++
public: virtual void Reset();
C++/CLI
public:
virtual void Reset();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartMaterialStyle Class
ChartMaterialStyle Members


SerializeObjectData Method

[image]
Intersoft WebGrid Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartMaterialStyle Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartMaterialStyle
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure SerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function SerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void SerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void SerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartMaterialStyle Class
ChartMaterialStyle Members


ToString Method

[image]
Intersoft WebGrid Documentation
ToString Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartMaterialStyle Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As System.String
Visual Basic (Usage) Copy Code
Dim instance As ChartMaterialStyle
Dim value As System.String

value = instance.ToString()
C#
public virtual System.string ToString()
Delphi
public function ToString(): System.String; virtual;
JScript
public function ToString() : System.String;
Managed Extensions for C++
public: virtual System.string* ToString();
C++/CLI
public:
virtual System.String^ ToString();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartMaterialStyle Class
ChartMaterialStyle Members


ChartMaterialStyle Class Properties

[image]
Intersoft WebGrid Documentation
ChartMaterialStyle Class Properties
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartMaterialStyle Class

Glossary Item Box

For a list of all members of this type, see ChartMaterialStyle members.

Public Properties

 | Name | Description
Public Property | Ambient |
Public Property | Diffuse |
Public Property | Emissive |
Public Property | Shininess |
Public Property | Specular |
Top

See Also

Reference

ChartMaterialStyle Class
ISNet.WebUI.WebGrid.Chart Namespace


ChartMaterialStyle Constructor

[image]
Intersoft WebGrid Documentation
ChartMaterialStyle Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartMaterialStyle Class : ChartMaterialStyle Constructor

Glossary Item Box

Overload List

Overload | Description
ChartMaterialStyle Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartMaterialStyle Class
ChartMaterialStyle Members


Ambient Property

[image]
Intersoft WebGrid Documentation
Ambient Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartMaterialStyle Class : Ambient Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Appearance")>
<System.ComponentModel.DescriptionAttribute("The ambient color.")>
Public Property Ambient As System.Drawing.Color
Visual Basic (Usage) Copy Code
Dim instance As ChartMaterialStyle
Dim value As System.Drawing.Color

instance.Ambient = value

value = instance.Ambient
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.DescriptionAttribute("The ambient color.")]
public System.Drawing.Color Ambient {get; set;}
Delphi
public read-write property Ambient: System.Drawing.Color;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Appearance")
System.ComponentModel.DescriptionAttribute("The ambient color.")
public function get,set Ambient : System.Drawing.Color
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.DescriptionAttribute("The ambient color.")]
public: __property System.Drawing.Color get_Ambient();
public: __property void set_Ambient(
   System.Drawing.Color value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.DescriptionAttribute("The ambient color.")]
public:
property System.Drawing.Color Ambient {
   System.Drawing.Color get();
   void set (    System.Drawing.Color value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartMaterialStyle Class
ChartMaterialStyle Members


Diffuse Property

[image]
Intersoft WebGrid Documentation
Diffuse Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartMaterialStyle Class : Diffuse Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("The diffuse color of this material style. ")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Appearance")>
Public Property Diffuse As System.Drawing.Color
Visual Basic (Usage) Copy Code
Dim instance As ChartMaterialStyle
Dim value As System.Drawing.Color

instance.Diffuse = value

value = instance.Diffuse
C#
[System.ComponentModel.DescriptionAttribute("The diffuse color of this material style. ")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Appearance")]
public System.Drawing.Color Diffuse {get; set;}
Delphi
public read-write property Diffuse: System.Drawing.Color;
JScript
System.ComponentModel.DescriptionAttribute("The diffuse color of this material style. ")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Appearance")
public function get,set Diffuse : System.Drawing.Color
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("The diffuse color of this material style. ")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Appearance")]
public: __property System.Drawing.Color get_Diffuse();
public: __property void set_Diffuse(
   System.Drawing.Color value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("The diffuse color of this material style. ")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Appearance")]
public:
property System.Drawing.Color Diffuse {
   System.Drawing.Color get();
   void set (    System.Drawing.Color value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartMaterialStyle Class
ChartMaterialStyle Members


Emissive Property

[image]
Intersoft WebGrid Documentation
Emissive Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartMaterialStyle Class : Emissive Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Appearance")>
<System.ComponentModel.DescriptionAttribute("The emissive color.")>
Public Property Emissive As System.Drawing.Color
Visual Basic (Usage) Copy Code
Dim instance As ChartMaterialStyle
Dim value As System.Drawing.Color

instance.Emissive = value

value = instance.Emissive
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.DescriptionAttribute("The emissive color.")]
public System.Drawing.Color Emissive {get; set;}
Delphi
public read-write property Emissive: System.Drawing.Color;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Appearance")
System.ComponentModel.DescriptionAttribute("The emissive color.")
public function get,set Emissive : System.Drawing.Color
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.DescriptionAttribute("The emissive color.")]
public: __property System.Drawing.Color get_Emissive();
public: __property void set_Emissive(
   System.Drawing.Color value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.DescriptionAttribute("The emissive color.")]
public:
property System.Drawing.Color Emissive {
   System.Drawing.Color get();
   void set (    System.Drawing.Color value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartMaterialStyle Class
ChartMaterialStyle Members


Shininess Property

[image]
Intersoft WebGrid Documentation
Shininess Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartMaterialStyle Class : Shininess Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("The shininess of the fill style. ")>
<System.ComponentModel.CategoryAttribute("Appearance")>
Public Property Shininess As System.Single
Visual Basic (Usage) Copy Code
Dim instance As ChartMaterialStyle
Dim value As System.Single

instance.Shininess = value

value = instance.Shininess
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("The shininess of the fill style. ")]
[System.ComponentModel.CategoryAttribute("Appearance")]
public System.float Shininess {get; set;}
Delphi
public read-write property Shininess: System.Single;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("The shininess of the fill style. ")
System.ComponentModel.CategoryAttribute("Appearance")
public function get,set Shininess : System.float
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("The shininess of the fill style. ")]
[System.ComponentModel.CategoryAttribute("Appearance")]
public: __property System.float get_Shininess();
public: __property void set_Shininess(
   System.float value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("The shininess of the fill style. ")]
[System.ComponentModel.CategoryAttribute("Appearance")]
public:
property System.float Shininess {
   System.float get();
   void set (    System.float value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartMaterialStyle Class
ChartMaterialStyle Members


Specular Property

[image]
Intersoft WebGrid Documentation
Specular Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartMaterialStyle Class : Specular Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Appearance")>
<System.ComponentModel.DescriptionAttribute("The specular color.")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property Specular As System.Drawing.Color
Visual Basic (Usage) Copy Code
Dim instance As ChartMaterialStyle
Dim value As System.Drawing.Color

instance.Specular = value

value = instance.Specular
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.DescriptionAttribute("The specular color.")]
[System.ComponentModel.DefaultValueAttribute()]
public System.Drawing.Color Specular {get; set;}
Delphi
public read-write property Specular: System.Drawing.Color;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Appearance")
System.ComponentModel.DescriptionAttribute("The specular color.")
System.ComponentModel.DefaultValueAttribute()
public function get,set Specular : System.Drawing.Color
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.DescriptionAttribute("The specular color.")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.Drawing.Color get_Specular();
public: __property void set_Specular(
   System.Drawing.Color value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.DescriptionAttribute("The specular color.")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.Drawing.Color Specular {
   System.Drawing.Color get();
   void set (    System.Drawing.Color value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartMaterialStyle Class
ChartMaterialStyle Members


ChartPieTypeSettings Class

[image]
Intersoft WebGrid Documentation
ChartPieTypeSettings Class
Members See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartPieTypeSettings Class

Glossary Item Box

Object Model

ChartPieTypeSettings Class

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.SerializableAttribute()>
Public Class ChartPieTypeSettings
   Inherits ISNet.WebUI.WebUIBaseClass
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Visual Basic (Usage) Copy Code
Dim instance As ChartPieTypeSettings
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public class ChartPieTypeSettings : ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Delphi
public class ChartPieTypeSettings = class(ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize)
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.SerializableAttribute()
public class ChartPieTypeSettings extends ISNet.WebUI.WebUIBaseClass implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public __gc class ChartPieTypeSettings : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public ref class ChartPieTypeSettings : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.WebGrid.Chart.ChartPieTypeSettings

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartPieTypeSettings Members
ISNet.WebUI.WebGrid.Chart Namespace


ChartPieTypeSettings Class Members

[image]
Intersoft WebGrid Documentation
ChartPieTypeSettings Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartPieTypeSettings Class

Glossary Item Box

The following tables list the members exposed by ChartPieTypeSettings.

Public Constructors

 | Name | Description
Public Constructor | ChartPieTypeSettings Constructor |
Top

Public Properties

 | Name | Description
Public Property | EnableBasic3DPieType |
Public Property | Enabled |
Public Property | EnableExploded3DPieType |
Public Property | EnableExplodedPieType |
Public Property | EnablePieType |
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

ChartPieTypeSettings Class
ISNet.WebUI.WebGrid.Chart Namespace


ChartPieTypeSettings Constructor

[image]
Intersoft WebGrid Documentation
ChartPieTypeSettings Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartPieTypeSettings Class : ChartPieTypeSettings Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New ChartPieTypeSettings()
C#
public ChartPieTypeSettings()
Delphi
public ChartPieTypeSettings();
JScript
public function ChartPieTypeSettings();
Managed Extensions for C++
public: ChartPieTypeSettings();
C++/CLI
public:
ChartPieTypeSettings();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartPieTypeSettings Class
ChartPieTypeSettings Members


Clone Method

[image]
Intersoft WebGrid Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartPieTypeSettings Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As System.Object
Visual Basic (Usage) Copy Code
Dim instance As ChartPieTypeSettings
Dim value As System.Object

value = instance.Clone()
C#
public virtual System.object Clone()
Delphi
public function Clone(): System.TObject; virtual;
JScript
public function Clone() : System.Object;
Managed Extensions for C++
public: virtual System.Object* Clone();
C++/CLI
public:
virtual System.Object^ Clone();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartPieTypeSettings Class
ChartPieTypeSettings Members


CopyFrom Method

[image]
Intersoft WebGrid Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartPieTypeSettings Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartPieTypeSettings Class
ChartPieTypeSettings Members


CopyFrom(Object) Method

[image]
Intersoft WebGrid Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartPieTypeSettings Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartPieTypeSettings
Dim objSource As System.Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   System.object objSource
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartPieTypeSettings Class
ChartPieTypeSettings Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebGrid Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartPieTypeSettings Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object, _
   ByVal cloneSourceValue As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartPieTypeSettings
Dim objSource As System.Object
Dim cloneSourceValue As System.Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   System.object objSource,
   System.bool cloneSourceValue
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject;
    cloneSourceValue: System.Boolean
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object,
   cloneSourceValue : System.boolean
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource,
   System.bool cloneSourceValue
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource,
   System.bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartPieTypeSettings Class
ChartPieTypeSettings Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebGrid Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartPieTypeSettings Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartPieTypeSettings
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure DeSerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function DeSerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void DeSerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void DeSerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartPieTypeSettings Class
ChartPieTypeSettings Members


GetHashCode Method

[image]
Intersoft WebGrid Documentation
GetHashCode Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartPieTypeSettings Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As ChartPieTypeSettings
Dim value As System.Integer

value = instance.GetHashCode()
C#
public virtual System.int GetHashCode()
Delphi
public function GetHashCode(): System.Integer; virtual;
JScript
public function GetHashCode() : System.int;
Managed Extensions for C++
public: virtual System.int GetHashCode();
C++/CLI
public:
virtual System.int GetHashCode();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartPieTypeSettings Class
ChartPieTypeSettings Members


ChartPieTypeSettings Class Methods

[image]
Intersoft WebGrid Documentation
ChartPieTypeSettings Class Methods
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartPieTypeSettings Class

Glossary Item Box

For a list of all members of this type, see ChartPieTypeSettings members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

ChartPieTypeSettings Class
ISNet.WebUI.WebGrid.Chart Namespace


GetObjectData Method

[image]
Intersoft WebGrid Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartPieTypeSettings Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=False,
   UnmanagedCode=False,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=True,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Action=SecurityAction.Demand,
   Unrestricted=False)>
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartPieTypeSettings
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure GetObjectData(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
); override;
JScript
System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=,
   UnmanagedCode=,
   SkipVerification=,
   Execution=,
   ControlThread=,
   ControlEvidence=,
   ControlPolicy=,
   SerializationFormatter=,
   ControlDomainPolicy=,
   ControlPrincipal=,
   ControlAppDomain=,
   RemotingConfiguration=,
   Infrastructure=,
   BindingRedirects=,
   Action=SecurityAction.Demand,
   Unrestricted=)
public override function GetObjectData(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public: void GetObjectData(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
) override
C++/CLI
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public:
void GetObjectData(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
) override

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartPieTypeSettings Class
ChartPieTypeSettings Members


IsEmpty Method

[image]
Intersoft WebGrid Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartPieTypeSettings Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As ChartPieTypeSettings
Dim value As System.Boolean

value = instance.IsEmpty()
C#
public virtual System.bool IsEmpty()
Delphi
public function IsEmpty(): System.Boolean; virtual;
JScript
public function IsEmpty() : System.boolean;
Managed Extensions for C++
public: virtual System.bool IsEmpty();
C++/CLI
public:
virtual System.bool IsEmpty();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartPieTypeSettings Class
ChartPieTypeSettings Members


Reset Method

[image]
Intersoft WebGrid Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartPieTypeSettings Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As ChartPieTypeSettings

instance.Reset()
C#
public virtual void Reset()
Delphi
public procedure Reset(); virtual;
JScript
public function Reset();
Managed Extensions for C++
public: virtual void Reset();
C++/CLI
public:
virtual void Reset();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartPieTypeSettings Class
ChartPieTypeSettings Members


SerializeObjectData Method

[image]
Intersoft WebGrid Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartPieTypeSettings Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartPieTypeSettings
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure SerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function SerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void SerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void SerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartPieTypeSettings Class
ChartPieTypeSettings Members


ToString Method

[image]
Intersoft WebGrid Documentation
ToString Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartPieTypeSettings Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As System.String
Visual Basic (Usage) Copy Code
Dim instance As ChartPieTypeSettings
Dim value As System.String

value = instance.ToString()
C#
public virtual System.string ToString()
Delphi
public function ToString(): System.String; virtual;
JScript
public function ToString() : System.String;
Managed Extensions for C++
public: virtual System.string* ToString();
C++/CLI
public:
virtual System.String^ ToString();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartPieTypeSettings Class
ChartPieTypeSettings Members


ChartPieTypeSettings Class Properties

[image]
Intersoft WebGrid Documentation
ChartPieTypeSettings Class Properties
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartPieTypeSettings Class

Glossary Item Box

For a list of all members of this type, see ChartPieTypeSettings members.

Public Properties

 | Name | Description
Public Property | EnableBasic3DPieType |
Public Property | Enabled |
Public Property | EnableExploded3DPieType |
Public Property | EnableExplodedPieType |
Public Property | EnablePieType |
Top

See Also

Reference

ChartPieTypeSettings Class
ISNet.WebUI.WebGrid.Chart Namespace


ChartPieTypeSettings Constructor

[image]
Intersoft WebGrid Documentation
ChartPieTypeSettings Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartPieTypeSettings Class : ChartPieTypeSettings Constructor

Glossary Item Box

Overload List

Overload | Description
ChartPieTypeSettings Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartPieTypeSettings Class
ChartPieTypeSettings Members


EnableBasic3DPieType Property

[image]
Intersoft WebGrid Documentation
EnableBasic3DPieType Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartPieTypeSettings Class : EnableBasic3DPieType Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Enable user to switch chart to Basic 3D Pie type.")>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Options")>
Public Property EnableBasic3DPieType As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As ChartPieTypeSettings
Dim value As System.Boolean

instance.EnableBasic3DPieType = value

value = instance.EnableBasic3DPieType
C#
[System.ComponentModel.DescriptionAttribute("Enable user to switch chart to Basic 3D Pie type.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Options")]
public System.bool EnableBasic3DPieType {get; set;}
Delphi
public read-write property EnableBasic3DPieType: System.Boolean;
JScript
System.ComponentModel.DescriptionAttribute("Enable user to switch chart to Basic 3D Pie type.")
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Options")
public function get,set EnableBasic3DPieType : System.boolean
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Enable user to switch chart to Basic 3D Pie type.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Options")]
public: __property System.bool get_EnableBasic3DPieType();
public: __property void set_EnableBasic3DPieType(
   System.bool value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Enable user to switch chart to Basic 3D Pie type.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Options")]
public:
property System.bool EnableBasic3DPieType {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartPieTypeSettings Class
ChartPieTypeSettings Members


Enabled Property

[image]
Intersoft WebGrid Documentation
Enabled Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartPieTypeSettings Class : Enabled Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Enable user to switch chart to Series Pie types.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Options")>
Public Property Enabled As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As ChartPieTypeSettings
Dim value As System.Boolean

instance.Enabled = value

value = instance.Enabled
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Enable user to switch chart to Series Pie types.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Options")]
public System.bool Enabled {get; set;}
Delphi
public read-write property Enabled: System.Boolean;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DescriptionAttribute("Enable user to switch chart to Series Pie types.")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Options")
public function get,set Enabled : System.boolean
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Enable user to switch chart to Series Pie types.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Options")]
public: __property System.bool get_Enabled();
public: __property void set_Enabled(
   System.bool value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Enable user to switch chart to Series Pie types.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Options")]
public:
property System.bool Enabled {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartPieTypeSettings Class
ChartPieTypeSettings Members


EnableExploded3DPieType Property

[image]
Intersoft WebGrid Documentation
EnableExploded3DPieType Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartPieTypeSettings Class : EnableExploded3DPieType Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Options")>
<System.ComponentModel.DescriptionAttribute("Enable user to switch chart to Exploded 3D Pie type.")>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property EnableExploded3DPieType As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As ChartPieTypeSettings
Dim value As System.Boolean

instance.EnableExploded3DPieType = value

value = instance.EnableExploded3DPieType
C#
[System.ComponentModel.CategoryAttribute("Options")]
[System.ComponentModel.DescriptionAttribute("Enable user to switch chart to Exploded 3D Pie type.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.bool EnableExploded3DPieType {get; set;}
Delphi
public read-write property EnableExploded3DPieType: System.Boolean;
JScript
System.ComponentModel.CategoryAttribute("Options")
System.ComponentModel.DescriptionAttribute("Enable user to switch chart to Exploded 3D Pie type.")
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set EnableExploded3DPieType : System.boolean
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Options")]
[System.ComponentModel.DescriptionAttribute("Enable user to switch chart to Exploded 3D Pie type.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.bool get_EnableExploded3DPieType();
public: __property void set_EnableExploded3DPieType(
   System.bool value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Options")]
[System.ComponentModel.DescriptionAttribute("Enable user to switch chart to Exploded 3D Pie type.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.bool EnableExploded3DPieType {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartPieTypeSettings Class
ChartPieTypeSettings Members


EnableExplodedPieType Property

[image]
Intersoft WebGrid Documentation
EnableExplodedPieType Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartPieTypeSettings Class : EnableExplodedPieType Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Enable user to switch chart to Exploded Pie type.")>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Options")>
Public Property EnableExplodedPieType As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As ChartPieTypeSettings
Dim value As System.Boolean

instance.EnableExplodedPieType = value

value = instance.EnableExplodedPieType
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Enable user to switch chart to Exploded Pie type.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Options")]
public System.bool EnableExplodedPieType {get; set;}
Delphi
public read-write property EnableExplodedPieType: System.Boolean;
JScript
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DescriptionAttribute("Enable user to switch chart to Exploded Pie type.")
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Options")
public function get,set EnableExplodedPieType : System.boolean
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Enable user to switch chart to Exploded Pie type.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Options")]
public: __property System.bool get_EnableExplodedPieType();
public: __property void set_EnableExplodedPieType(
   System.bool value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Enable user to switch chart to Exploded Pie type.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Options")]
public:
property System.bool EnableExplodedPieType {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartPieTypeSettings Class
ChartPieTypeSettings Members


EnablePieType Property

[image]
Intersoft WebGrid Documentation
EnablePieType Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartPieTypeSettings Class : EnablePieType Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Enable user to switch chart to Pie type.")>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Options")>
Public Property EnablePieType As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As ChartPieTypeSettings
Dim value As System.Boolean

instance.EnablePieType = value

value = instance.EnablePieType
C#
[System.ComponentModel.DescriptionAttribute("Enable user to switch chart to Pie type.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Options")]
public System.bool EnablePieType {get; set;}
Delphi
public read-write property EnablePieType: System.Boolean;
JScript
System.ComponentModel.DescriptionAttribute("Enable user to switch chart to Pie type.")
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Options")
public function get,set EnablePieType : System.boolean
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Enable user to switch chart to Pie type.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Options")]
public: __property System.bool get_EnablePieType();
public: __property void set_EnablePieType(
   System.bool value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Enable user to switch chart to Pie type.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Options")]
public:
property System.bool EnablePieType {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartPieTypeSettings Class
ChartPieTypeSettings Members


ChartPivotDataConfigCollection Class

[image]
Intersoft WebGrid Documentation
ChartPivotDataConfigCollection Class
Members See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartPivotDataConfigCollection Class

Glossary Item Box

Object Model

ChartPivotDataConfigCollection Class

Syntax

Visual Basic (Declaration)
<System.Reflection.DefaultMemberAttribute("Item")>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.SerializableAttribute()>
Public Class ChartPivotDataConfigCollection
   Inherits ISNet.WebUI.ISCollectionBase
Visual Basic (Usage) Copy Code
Dim instance As ChartPivotDataConfigCollection
C#
[System.Reflection.DefaultMemberAttribute("Item")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public class ChartPivotDataConfigCollection : ISNet.WebUI.ISCollectionBase
Delphi
public class ChartPivotDataConfigCollection = class(ISNet.WebUI.ISCollectionBase)
JScript
System.Reflection.DefaultMemberAttribute("Item")
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.SerializableAttribute()
public class ChartPivotDataConfigCollection extends ISNet.WebUI.ISCollectionBase
Managed Extensions for C++
[System.Reflection.DefaultMemberAttribute("Item")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public __gc class ChartPivotDataConfigCollection : public ISNet.WebUI.ISCollectionBase
C++/CLI
[System.Reflection.DefaultMemberAttribute("Item")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public ref class ChartPivotDataConfigCollection : public ISNet.WebUI.ISCollectionBase

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
ISNet.WebUI.ISCollectionBase
ISNet.WebUI.WebGrid.Chart.ChartPivotDataConfigCollection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartPivotDataConfigCollection Members
ISNet.WebUI.WebGrid.Chart Namespace


ChartPivotDataConfigCollection Class Members

[image]
Intersoft WebGrid Documentation
ChartPivotDataConfigCollection Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartPivotDataConfigCollection Class

Glossary Item Box

The following tables list the members exposed by ChartPivotDataConfigCollection.

Public Constructors

 | Name | Description
Public Constructor | ChartPivotDataConfigCollection Constructor |
Top

Public Properties

 | Name | Description
Public Property | Capacity | (Inherited from System.Collections.CollectionBase)
Public Property | Count | (Inherited from System.Collections.CollectionBase)
Public Property | IsReadOnly | Overridden.
Public Property | Item |
Public Property | Parent | (Inherited from ISNet.WebUI.ISCollectionBase)
Top

Public Methods

 | Name | Description
Public Method | Add | Overloaded.
Public Method | Clear |
Public Method | Contains | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | CopyFrom |
Public Method | CopyTo | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | Exists | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | GetEnumerator |
Public Method | GetItem | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | GetNamedItem |
Public Method | IndexOf | Overloaded.
Public Method | Insert |
Public Method | IntInsert | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | Remove |
Public Method | setParent | (Inherited from ISNet.WebUI.ISCollectionBase)
Top

See Also

Reference

ChartPivotDataConfigCollection Class
ISNet.WebUI.WebGrid.Chart Namespace


ChartPivotDataConfigCollection Constructor

[image]
Intersoft WebGrid Documentation
ChartPivotDataConfigCollection Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartPivotDataConfigCollection Class : ChartPivotDataConfigCollection Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New ChartPivotDataConfigCollection()
C#
public ChartPivotDataConfigCollection()
Delphi
public ChartPivotDataConfigCollection();
JScript
public function ChartPivotDataConfigCollection();
Managed Extensions for C++
public: ChartPivotDataConfigCollection();
C++/CLI
public:
ChartPivotDataConfigCollection();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartPivotDataConfigCollection Class
ChartPivotDataConfigCollection Members


ChartPivotDataConfigCollection Class Methods

[image]
Intersoft WebGrid Documentation
ChartPivotDataConfigCollection Class Methods
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartPivotDataConfigCollection Class

Glossary Item Box

For a list of all members of this type, see ChartPivotDataConfigCollection members.

Public Methods

 | Name | Description
Public Method | Add | Overloaded.
Public Method | Clear |
Public Method | Contains | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | CopyFrom |
Public Method | CopyTo | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | Exists | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | GetEnumerator |
Public Method | GetItem | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | GetNamedItem |
Public Method | IndexOf | Overloaded.
Public Method | Insert |
Public Method | IntInsert | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | Remove |
Public Method | setParent | (Inherited from ISNet.WebUI.ISCollectionBase)
Top

See Also

Reference

ChartPivotDataConfigCollection Class
ISNet.WebUI.WebGrid.Chart Namespace


Add Method

[image]
Intersoft WebGrid Documentation
Add Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartPivotDataConfigCollection Class : Add Method

Glossary Item Box

Overload List

Overload | Description
Add(ChartPivotDataConfig) |
Add(String) |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartPivotDataConfigCollection Class
ChartPivotDataConfigCollection Members


Add(ChartPivotDataConfig) Method

[image]
Intersoft WebGrid Documentation
Add(ChartPivotDataConfig) Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartPivotDataConfigCollection Class > Add Method : Add(ChartPivotDataConfig) Method

item

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function Add( _
   ByVal item As ChartPivotDataConfig _
) As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As ChartPivotDataConfigCollection
Dim item As ChartPivotDataConfig
Dim value As System.Integer

value = instance.Add(item)
C#
public System.int Add(
   ChartPivotDataConfig item
)
Delphi
public function Add(
    item: ChartPivotDataConfig
): System.Integer;
JScript
public function Add(
   item : ChartPivotDataConfig
) : System.int;
Managed Extensions for C++
public: System.int Add(
   ChartPivotDataConfig* item
)
C++/CLI
public:
System.int Add(
   ChartPivotDataConfig^ item
)

Parameters

item

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartPivotDataConfigCollection Class
ChartPivotDataConfigCollection Members
Overload List


Add(String) Method

[image]
Intersoft WebGrid Documentation
Add(String) Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartPivotDataConfigCollection Class > Add Method : Add(String) Method

name

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function Add( _
   ByVal name As System.String _
) As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As ChartPivotDataConfigCollection
Dim name As System.String
Dim value As System.Integer

value = instance.Add(name)
C#
public System.int Add(
   System.string name
)
Delphi
public function Add(
    name: System.String
): System.Integer;
JScript
public function Add(
   name : System.String
) : System.int;
Managed Extensions for C++
public: System.int Add(
   System.string* name
)
C++/CLI
public:
System.int Add(
   System.String^ name
)

Parameters

name

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartPivotDataConfigCollection Class
ChartPivotDataConfigCollection Members
Overload List


Clear Method

[image]
Intersoft WebGrid Documentation
Clear Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartPivotDataConfigCollection Class : Clear Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Shadows Sub Clear()
Visual Basic (Usage) Copy Code
Dim instance As ChartPivotDataConfigCollection

instance.Clear()
C#
public new void Clear()
Delphi
public procedure Clear();
JScript
public hide function Clear();
Managed Extensions for C++
public: new void Clear();
C++/CLI
public:
new void Clear();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartPivotDataConfigCollection Class
ChartPivotDataConfigCollection Members


Contains Method

[image]
Intersoft WebGrid Documentation
Contains Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartPivotDataConfigCollection Class : Contains Method

value

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function Contains( _
   ByVal value As ISNet.WebUI.INamedObject _
) As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As ChartPivotDataConfigCollection
Dim value As ISNet.WebUI.INamedObject
Dim value As System.Boolean

value = instance.Contains(value)
C#
public System.bool Contains(
   ISNet.WebUI.INamedObject value
)
Delphi
public function Contains(
    value: ISNet.WebUI.INamedObject
): System.Boolean;
JScript
public function Contains(
   value : ISNet.WebUI.INamedObject
) : System.boolean;
Managed Extensions for C++
public: System.bool Contains(
   ISNet.WebUI.INamedObject* value
)
C++/CLI
public:
System.bool Contains(
   ISNet.WebUI.INamedObject^ value
)

Parameters

value

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartPivotDataConfigCollection Class
ChartPivotDataConfigCollection Members


CopyFrom Method

[image]
Intersoft WebGrid Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartPivotDataConfigCollection Class : CopyFrom Method

passIn

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function CopyFrom( _
   ByVal passIn As ChartPivotDataConfigCollection _
) As ChartPivotDataConfigCollection
Visual Basic (Usage) Copy Code
Dim instance As ChartPivotDataConfigCollection
Dim passIn As ChartPivotDataConfigCollection
Dim value As ChartPivotDataConfigCollection

value = instance.CopyFrom(passIn)
C#
public ChartPivotDataConfigCollection CopyFrom(
   ChartPivotDataConfigCollection passIn
)
Delphi
public function CopyFrom(
    passIn: ChartPivotDataConfigCollection
): ChartPivotDataConfigCollection;
JScript
public function CopyFrom(
   passIn : ChartPivotDataConfigCollection
) : ChartPivotDataConfigCollection;
Managed Extensions for C++
public: ChartPivotDataConfigCollection* CopyFrom(
   ChartPivotDataConfigCollection* passIn
)
C++/CLI
public:
ChartPivotDataConfigCollection^ CopyFrom(
   ChartPivotDataConfigCollection^ passIn
)

Parameters

passIn

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartPivotDataConfigCollection Class
ChartPivotDataConfigCollection Members


CopyTo Method

[image]
Intersoft WebGrid Documentation
CopyTo Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartPivotDataConfigCollection Class : CopyTo Method

array
index

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub CopyTo( _
   ByVal array() As ISNet.WebUI.INamedObject, _
   ByVal index As System.Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartPivotDataConfigCollection
Dim array() As ISNet.WebUI.INamedObject
Dim index As System.Integer

instance.CopyTo(array, index)
C#
public void CopyTo(
   ISNet.WebUI.INamedObject[] array,
   System.int index
)
Delphi
public procedure CopyTo(
    array: ISNet.WebUI.INamedObjectarray of;
    index: System.Integer
);
JScript
public function CopyTo(
   array : ISNet.WebUI.INamedObject[],
   index : System.int
);
Managed Extensions for C++
public: void CopyTo(
   ISNet.WebUI.INamedObject*[]* array,
   System.int index
)
C++/CLI
public:
void CopyTo(
   ISNet.WebUI.array<INamedObject^>^ array,
   System.int index
)

Parameters

array
index

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartPivotDataConfigCollection Class
ChartPivotDataConfigCollection Members


Exists Method

[image]
Intersoft WebGrid Documentation
Exists Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartPivotDataConfigCollection Class : Exists Method

name

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function Exists( _
   ByVal name As System.String _
) As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As ChartPivotDataConfigCollection
Dim name As System.String
Dim value As System.Boolean

value = instance.Exists(name)
C#
public System.bool Exists(
   System.string name
)
Delphi
public function Exists(
    name: System.String
): System.Boolean;
JScript
public function Exists(
   name : System.String
) : System.boolean;
Managed Extensions for C++
public: System.bool Exists(
   System.string* name
)
C++/CLI
public:
System.bool Exists(
   System.String^ name
)

Parameters

name

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartPivotDataConfigCollection Class
ChartPivotDataConfigCollection Members


GetEnumerator Method

[image]
Intersoft WebGrid Documentation
GetEnumerator Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartPivotDataConfigCollection Class : GetEnumerator Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Shadows Function GetEnumerator() As System.Collections.IEnumerator
Visual Basic (Usage) Copy Code
Dim instance As ChartPivotDataConfigCollection
Dim value As System.Collections.IEnumerator

value = instance.GetEnumerator()
C#
public new System.Collections.IEnumerator GetEnumerator()
Delphi
public function GetEnumerator(): System.Collections.IEnumerator;
JScript
public hide function GetEnumerator() : System.Collections.IEnumerator;
Managed Extensions for C++
public: new System.Collections.IEnumerator* GetEnumerator();
C++/CLI
public:
new System.Collections.IEnumerator^ GetEnumerator();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartPivotDataConfigCollection Class
ChartPivotDataConfigCollection Members


GetItem Method

[image]
Intersoft WebGrid Documentation
GetItem Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartPivotDataConfigCollection Class : GetItem Method

Glossary Item Box

Overload List

Overload | Description
GetItem | (Inherited from ISNet.WebUI.ISCollectionBase)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartPivotDataConfigCollection Class
ChartPivotDataConfigCollection Members


GetItem(Int32) Method

[image]
Intersoft WebGrid Documentation
GetItem(Int32) Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartPivotDataConfigCollection Class : GetItem(Int32) Method

index

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetItem( _
   ByVal index As System.Integer _
) As ISNet.WebUI.INamedObject
Visual Basic (Usage) Copy Code
Dim instance As ChartPivotDataConfigCollection
Dim index As System.Integer
Dim value As ISNet.WebUI.INamedObject

value = instance.GetItem(index)
C#
public virtual ISNet.WebUI.INamedObject GetItem(
   System.int index
)
Delphi
public function GetItem(
    index: System.Integer
): ISNet.WebUI.INamedObject; virtual;
JScript
public function GetItem(
   index : System.int
) : ISNet.WebUI.INamedObject;
Managed Extensions for C++
public: virtual ISNet.WebUI.INamedObject* GetItem(
   System.int index
)
C++/CLI
public:
virtual ISNet.WebUI.INamedObject^ GetItem(
   System.int index
)

Parameters

index

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartPivotDataConfigCollection Class
ChartPivotDataConfigCollection Members


GetNamedItem Method

[image]
Intersoft WebGrid Documentation
GetNamedItem Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartPivotDataConfigCollection Class : GetNamedItem Method

name

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetNamedItem( _
   ByVal name As System.String _
) As ChartPivotDataConfig
Visual Basic (Usage) Copy Code
Dim instance As ChartPivotDataConfigCollection
Dim name As System.String
Dim value As ChartPivotDataConfig

value = instance.GetNamedItem(name)
C#
public ChartPivotDataConfig GetNamedItem(
   System.string name
)
Delphi
public function GetNamedItem(
    name: System.String
): ChartPivotDataConfig;
JScript
public function GetNamedItem(
   name : System.String
) : ChartPivotDataConfig;
Managed Extensions for C++
public: ChartPivotDataConfig* GetNamedItem(
   System.string* name
)
C++/CLI
public:
ChartPivotDataConfig^ GetNamedItem(
   System.String^ name
)

Parameters

name

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartPivotDataConfigCollection Class
ChartPivotDataConfigCollection Members


IndexOf Method

[image]
Intersoft WebGrid Documentation
IndexOf Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartPivotDataConfigCollection Class : IndexOf Method

Glossary Item Box

Overload List

Overload | Description
IndexOf(String) | (Inherited from ISNet.WebUI.ISCollectionBase)
IndexOf(INamedObject) | (Inherited from ISNet.WebUI.ISCollectionBase)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartPivotDataConfigCollection Class
ChartPivotDataConfigCollection Members


IndexOf(String) Method

[image]
Intersoft WebGrid Documentation
IndexOf(String) Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartPivotDataConfigCollection Class > IndexOf Method : IndexOf(String) Method

name

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function IndexOf( _
   ByVal name As System.String _
) As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As ChartPivotDataConfigCollection
Dim name As System.String
Dim value As System.Integer

value = instance.IndexOf(name)
C#
public virtual System.int IndexOf(
   System.string name
)
Delphi
public function IndexOf(
    name: System.String
): System.Integer; virtual;
JScript
public function IndexOf(
   name : System.String
) : System.int;
Managed Extensions for C++
public: virtual System.int IndexOf(
   System.string* name
)
C++/CLI
public:
virtual System.int IndexOf(
   System.String^ name
)

Parameters

name

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartPivotDataConfigCollection Class
ChartPivotDataConfigCollection Members
Overload List


IndexOf(INamedObject) Method

[image]
Intersoft WebGrid Documentation
IndexOf(INamedObject) Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartPivotDataConfigCollection Class > IndexOf Method : IndexOf(INamedObject) Method

value

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function IndexOf( _
   ByVal value As ISNet.WebUI.INamedObject _
) As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As ChartPivotDataConfigCollection
Dim value As ISNet.WebUI.INamedObject
Dim value As System.Integer

value = instance.IndexOf(value)
C#
public System.int IndexOf(
   ISNet.WebUI.INamedObject value
)
Delphi
public function IndexOf(
    value: ISNet.WebUI.INamedObject
): System.Integer;
JScript
public function IndexOf(
   value : ISNet.WebUI.INamedObject
) : System.int;
Managed Extensions for C++
public: System.int IndexOf(
   ISNet.WebUI.INamedObject* value
)
C++/CLI
public:
System.int IndexOf(
   ISNet.WebUI.INamedObject^ value
)

Parameters

value

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartPivotDataConfigCollection Class
ChartPivotDataConfigCollection Members
Overload List


Insert Method

[image]
Intersoft WebGrid Documentation
Insert Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartPivotDataConfigCollection Class : Insert Method

index
item

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub Insert( _
   ByVal index As System.Integer, _
   ByVal item As ChartPivotDataConfig _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartPivotDataConfigCollection
Dim index As System.Integer
Dim item As ChartPivotDataConfig

instance.Insert(index, item)
C#
public void Insert(
   System.int index,
   ChartPivotDataConfig item
)
Delphi
public procedure Insert(
    index: System.Integer;
    item: ChartPivotDataConfig
);
JScript
public function Insert(
   index : System.int,
   item : ChartPivotDataConfig
);
Managed Extensions for C++
public: void Insert(
   System.int index,
   ChartPivotDataConfig* item
)
C++/CLI
public:
void Insert(
   System.int index,
   ChartPivotDataConfig^ item
)

Parameters

index
item

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartPivotDataConfigCollection Class
ChartPivotDataConfigCollection Members


IntInsert Method

[image]
Intersoft WebGrid Documentation
IntInsert Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartPivotDataConfigCollection Class : IntInsert Method

index
value

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub IntInsert( _
   ByVal index As System.Integer, _
   ByVal value As ISNet.WebUI.INamedObject _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartPivotDataConfigCollection
Dim index As System.Integer
Dim value As ISNet.WebUI.INamedObject

instance.IntInsert(index, value)
C#
public void IntInsert(
   System.int index,
   ISNet.WebUI.INamedObject value
)
Delphi
public procedure IntInsert(
    index: System.Integer;
    value: ISNet.WebUI.INamedObject
);
JScript
public function IntInsert(
   index : System.int,
   value : ISNet.WebUI.INamedObject
);
Managed Extensions for C++
public: void IntInsert(
   System.int index,
   ISNet.WebUI.INamedObject* value
)
C++/CLI
public:
void IntInsert(
   System.int index,
   ISNet.WebUI.INamedObject^ value
)

Parameters

index
value

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartPivotDataConfigCollection Class
ChartPivotDataConfigCollection Members


Remove Method

[image]
Intersoft WebGrid Documentation
Remove Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartPivotDataConfigCollection Class : Remove Method

item

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub Remove( _
   ByVal item As ChartPivotDataConfig _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartPivotDataConfigCollection
Dim item As ChartPivotDataConfig

instance.Remove(item)
C#
public void Remove(
   ChartPivotDataConfig item
)
Delphi
public procedure Remove(
    item: ChartPivotDataConfig
);
JScript
public function Remove(
   item : ChartPivotDataConfig
);
Managed Extensions for C++
public: void Remove(
   ChartPivotDataConfig* item
)
C++/CLI
public:
void Remove(
   ChartPivotDataConfig^ item
)

Parameters

item

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartPivotDataConfigCollection Class
ChartPivotDataConfigCollection Members


setParent Method

[image]
Intersoft WebGrid Documentation
setParent Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartPivotDataConfigCollection Class : setParent Method

parent

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub setParent( _
   ByVal parent As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartPivotDataConfigCollection
Dim parent As System.Object

instance.setParent(parent)
C#
public virtual void setParent(
   System.object parent
)
Delphi
public procedure setParent(
    parent: System.TObject
); virtual;
JScript
public function setParent(
   parent : System.Object
);
Managed Extensions for C++
public: virtual void setParent(
   System.Object* parent
)
C++/CLI
public:
virtual void setParent(
   System.Object^ parent
)

Parameters

parent

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartPivotDataConfigCollection Class
ChartPivotDataConfigCollection Members


Capacity Property

[image]
Intersoft WebGrid Documentation
Capacity Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartPivotDataConfigCollection Class : Capacity Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Runtime.InteropServices.ComVisibleAttribute(False)>
Public Property Capacity As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As ChartPivotDataConfigCollection
Dim value As System.Integer

instance.Capacity = value

value = instance.Capacity
C#
[System.Runtime.InteropServices.ComVisibleAttribute(false)]
public System.int Capacity {get; set;}
Delphi
public read-write property Capacity: System.Integer;
JScript
System.Runtime.InteropServices.ComVisibleAttribute()
public function get,set Capacity : System.int
Managed Extensions for C++
[System.Runtime.InteropServices.ComVisibleAttribute(false)]
public: __property System.int get_Capacity();
public: __property void set_Capacity(
   System.int value
);
C++/CLI
[System.Runtime.InteropServices.ComVisibleAttribute(false)]
public:
property System.int Capacity {
   System.int get();
   void set (    System.int value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartPivotDataConfigCollection Class
ChartPivotDataConfigCollection Members


Count Property

[image]
Intersoft WebGrid Documentation
Count Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartPivotDataConfigCollection Class : Count Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Count As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As ChartPivotDataConfigCollection
Dim value As System.Integer

value = instance.Count
C#
public System.int Count {get;}
Delphi
public read-only property Count: System.Integer;
JScript
public function get Count : System.int
Managed Extensions for C++
public: __property System.int get_Count();
C++/CLI
public:
property System.int Count {
   System.int get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartPivotDataConfigCollection Class
ChartPivotDataConfigCollection Members


ChartPivotDataConfigCollection Class Properties

[image]
Intersoft WebGrid Documentation
ChartPivotDataConfigCollection Class Properties
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartPivotDataConfigCollection Class

Glossary Item Box

For a list of all members of this type, see ChartPivotDataConfigCollection members.

Public Properties

 | Name | Description
Public Property | Capacity | (Inherited from System.Collections.CollectionBase)
Public Property | Count | (Inherited from System.Collections.CollectionBase)
Public Property | IsReadOnly | Overridden.
Public Property | Item |
Public Property | Parent | (Inherited from ISNet.WebUI.ISCollectionBase)
Top

See Also

Reference

ChartPivotDataConfigCollection Class
ISNet.WebUI.WebGrid.Chart Namespace


ChartPivotDataConfigCollection Constructor

[image]
Intersoft WebGrid Documentation
ChartPivotDataConfigCollection Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartPivotDataConfigCollection Class : ChartPivotDataConfigCollection Constructor

Glossary Item Box

Overload List

Overload | Description
ChartPivotDataConfigCollection Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartPivotDataConfigCollection Class
ChartPivotDataConfigCollection Members


IsReadOnly Property

[image]
Intersoft WebGrid Documentation
IsReadOnly Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartPivotDataConfigCollection Class : IsReadOnly Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property IsReadOnly As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As ChartPivotDataConfigCollection
Dim value As System.Boolean

value = instance.IsReadOnly
C#
public override System.bool IsReadOnly {get;}
Delphi
public read-only property IsReadOnly: System.Boolean; override;
JScript
public override function get IsReadOnly : System.boolean
Managed Extensions for C++
public: __property System.bool get_IsReadOnly() override;
C++/CLI
public:
property System.bool IsReadOnly {
   System.bool get() override;
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartPivotDataConfigCollection Class
ChartPivotDataConfigCollection Members


Item Property

[image]
Intersoft WebGrid Documentation
Item Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartPivotDataConfigCollection Class : Item Property

index

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Default Property Item( _
   ByVal index As System.Integer _
) As ChartPivotDataConfig
Visual Basic (Usage) Copy Code
Dim instance As ChartPivotDataConfigCollection
Dim index As System.Integer
Dim value As ChartPivotDataConfig

instance.Item(index) = value

value = instance.Item(index)
C#
public ChartPivotDataConfig this[
   System.int index
]; {get; set;}
Delphi
public  this: : ChartPivotDataConfig;[
    index: System.Integer
]; read-write
JScript
public  this[
   index : System.int
] get,set : ChartPivotDataConfig
Managed Extensions for C++
public: __property ChartPivotDataConfig* get_Item   System.int index
;
public: __property void set_Item   System.int index,
   ChartPivotDataConfig* value
;
C++/CLI
public:
property ChartPivotDataConfig^ default [int] {
   ChartPivotDataConfig^ get(System.int index);
   void set (System.int index, ChartPivotDataConfig^ value);
}

Parameters

index

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartPivotDataConfigCollection Class
ChartPivotDataConfigCollection Members


Parent Property

[image]
Intersoft WebGrid Documentation
Parent Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartPivotDataConfigCollection Class : Parent Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Parent As System.Object
Visual Basic (Usage) Copy Code
Dim instance As ChartPivotDataConfigCollection
Dim value As System.Object

value = instance.Parent
C#
public System.object Parent {get;}
Delphi
public read-only property Parent: System.TObject;
JScript
public function get Parent : System.Object
Managed Extensions for C++
public: __property System.Object* get_Parent();
C++/CLI
public:
property System.Object^ Parent {
   System.Object^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartPivotDataConfigCollection Class
ChartPivotDataConfigCollection Members


ChartPivotFilterConfigCollection Class

[image]
Intersoft WebGrid Documentation
ChartPivotFilterConfigCollection Class
Members See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartPivotFilterConfigCollection Class

Glossary Item Box

Object Model

ChartPivotFilterConfigCollection Class

Syntax

Visual Basic (Declaration)
<System.Reflection.DefaultMemberAttribute("Item")>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.SerializableAttribute()>
Public Class ChartPivotFilterConfigCollection
   Inherits ISNet.WebUI.ISCollectionBase
Visual Basic (Usage) Copy Code
Dim instance As ChartPivotFilterConfigCollection
C#
[System.Reflection.DefaultMemberAttribute("Item")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public class ChartPivotFilterConfigCollection : ISNet.WebUI.ISCollectionBase
Delphi
public class ChartPivotFilterConfigCollection = class(ISNet.WebUI.ISCollectionBase)
JScript
System.Reflection.DefaultMemberAttribute("Item")
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.SerializableAttribute()
public class ChartPivotFilterConfigCollection extends ISNet.WebUI.ISCollectionBase
Managed Extensions for C++
[System.Reflection.DefaultMemberAttribute("Item")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public __gc class ChartPivotFilterConfigCollection : public ISNet.WebUI.ISCollectionBase
C++/CLI
[System.Reflection.DefaultMemberAttribute("Item")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public ref class ChartPivotFilterConfigCollection : public ISNet.WebUI.ISCollectionBase

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
ISNet.WebUI.ISCollectionBase
ISNet.WebUI.WebGrid.Chart.ChartPivotFilterConfigCollection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartPivotFilterConfigCollection Members
ISNet.WebUI.WebGrid.Chart Namespace


ChartPivotFilterConfigCollection Class Members

[image]
Intersoft WebGrid Documentation
ChartPivotFilterConfigCollection Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartPivotFilterConfigCollection Class

Glossary Item Box

The following tables list the members exposed by ChartPivotFilterConfigCollection.

Public Constructors

 | Name | Description
Public Constructor | ChartPivotFilterConfigCollection Constructor |
Top

Public Properties

 | Name | Description
Public Property | Capacity | (Inherited from System.Collections.CollectionBase)
Public Property | Count | (Inherited from System.Collections.CollectionBase)
Public Property | IsReadOnly | Overridden.
Public Property | Item |
Public Property | Parent | (Inherited from ISNet.WebUI.ISCollectionBase)
Top

Public Methods

 | Name | Description
Public Method | Add | Overloaded.
Public Method | Clear |
Public Method | Contains | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | CopyFrom |
Public Method | CopyTo | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | Exists | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | GetEnumerator |
Public Method | GetItem | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | GetNamedItem |
Public Method | IndexOf | Overloaded.
Public Method | Insert |
Public Method | IntInsert | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | Remove |
Public Method | setParent | (Inherited from ISNet.WebUI.ISCollectionBase)
Top

See Also

Reference

ChartPivotFilterConfigCollection Class
ISNet.WebUI.WebGrid.Chart Namespace


ChartPivotFilterConfigCollection Constructor

[image]
Intersoft WebGrid Documentation
ChartPivotFilterConfigCollection Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartPivotFilterConfigCollection Class : ChartPivotFilterConfigCollection Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New ChartPivotFilterConfigCollection()
C#
public ChartPivotFilterConfigCollection()
Delphi
public ChartPivotFilterConfigCollection();
JScript
public function ChartPivotFilterConfigCollection();
Managed Extensions for C++
public: ChartPivotFilterConfigCollection();
C++/CLI
public:
ChartPivotFilterConfigCollection();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartPivotFilterConfigCollection Class
ChartPivotFilterConfigCollection Members


ChartPivotFilterConfigCollection Class Methods

[image]
Intersoft WebGrid Documentation
ChartPivotFilterConfigCollection Class Methods
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartPivotFilterConfigCollection Class

Glossary Item Box

For a list of all members of this type, see ChartPivotFilterConfigCollection members.

Public Methods

 | Name | Description
Public Method | Add | Overloaded.
Public Method | Clear |
Public Method | Contains | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | CopyFrom |
Public Method | CopyTo | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | Exists | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | GetEnumerator |
Public Method | GetItem | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | GetNamedItem |
Public Method | IndexOf | Overloaded.
Public Method | Insert |
Public Method | IntInsert | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | Remove |
Public Method | setParent | (Inherited from ISNet.WebUI.ISCollectionBase)
Top

See Also

Reference

ChartPivotFilterConfigCollection Class
ISNet.WebUI.WebGrid.Chart Namespace


Add Method

[image]
Intersoft WebGrid Documentation
Add Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartPivotFilterConfigCollection Class : Add Method

Glossary Item Box

Overload List

Overload | Description
Add(ChartPivotFilterConfig) |
Add(String) |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartPivotFilterConfigCollection Class
ChartPivotFilterConfigCollection Members


Add(ChartPivotFilterConfig) Method

[image]
Intersoft WebGrid Documentation
Add(ChartPivotFilterConfig) Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartPivotFilterConfigCollection Class > Add Method : Add(ChartPivotFilterConfig) Method

item

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function Add( _
   ByVal item As ChartPivotFilterConfig _
) As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As ChartPivotFilterConfigCollection
Dim item As ChartPivotFilterConfig
Dim value As System.Integer

value = instance.Add(item)
C#
public System.int Add(
   ChartPivotFilterConfig item
)
Delphi
public function Add(
    item: ChartPivotFilterConfig
): System.Integer;
JScript
public function Add(
   item : ChartPivotFilterConfig
) : System.int;
Managed Extensions for C++
public: System.int Add(
   ChartPivotFilterConfig* item
)
C++/CLI
public:
System.int Add(
   ChartPivotFilterConfig^ item
)

Parameters

item

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartPivotFilterConfigCollection Class
ChartPivotFilterConfigCollection Members
Overload List


Add(String) Method

[image]
Intersoft WebGrid Documentation
Add(String) Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartPivotFilterConfigCollection Class > Add Method : Add(String) Method

name

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function Add( _
   ByVal name As System.String _
) As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As ChartPivotFilterConfigCollection
Dim name As System.String
Dim value As System.Integer

value = instance.Add(name)
C#
public System.int Add(
   System.string name
)
Delphi
public function Add(
    name: System.String
): System.Integer;
JScript
public function Add(
   name : System.String
) : System.int;
Managed Extensions for C++
public: System.int Add(
   System.string* name
)
C++/CLI
public:
System.int Add(
   System.String^ name
)

Parameters

name

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartPivotFilterConfigCollection Class
ChartPivotFilterConfigCollection Members
Overload List


Clear Method

[image]
Intersoft WebGrid Documentation
Clear Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartPivotFilterConfigCollection Class : Clear Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Shadows Sub Clear()
Visual Basic (Usage) Copy Code
Dim instance As ChartPivotFilterConfigCollection

instance.Clear()
C#
public new void Clear()
Delphi
public procedure Clear();
JScript
public hide function Clear();
Managed Extensions for C++
public: new void Clear();
C++/CLI
public:
new void Clear();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartPivotFilterConfigCollection Class
ChartPivotFilterConfigCollection Members


Contains Method

[image]
Intersoft WebGrid Documentation
Contains Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartPivotFilterConfigCollection Class : Contains Method

value

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function Contains( _
   ByVal value As ISNet.WebUI.INamedObject _
) As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As ChartPivotFilterConfigCollection
Dim value As ISNet.WebUI.INamedObject
Dim value As System.Boolean

value = instance.Contains(value)
C#
public System.bool Contains(
   ISNet.WebUI.INamedObject value
)
Delphi
public function Contains(
    value: ISNet.WebUI.INamedObject
): System.Boolean;
JScript
public function Contains(
   value : ISNet.WebUI.INamedObject
) : System.boolean;
Managed Extensions for C++
public: System.bool Contains(
   ISNet.WebUI.INamedObject* value
)
C++/CLI
public:
System.bool Contains(
   ISNet.WebUI.INamedObject^ value
)

Parameters

value

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartPivotFilterConfigCollection Class
ChartPivotFilterConfigCollection Members


CopyFrom Method

[image]
Intersoft WebGrid Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartPivotFilterConfigCollection Class : CopyFrom Method

passIn

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function CopyFrom( _
   ByVal passIn As ChartPivotFilterConfigCollection _
) As ChartPivotFilterConfigCollection
Visual Basic (Usage) Copy Code
Dim instance As ChartPivotFilterConfigCollection
Dim passIn As ChartPivotFilterConfigCollection
Dim value As ChartPivotFilterConfigCollection

value = instance.CopyFrom(passIn)
C#
public ChartPivotFilterConfigCollection CopyFrom(
   ChartPivotFilterConfigCollection passIn
)
Delphi
public function CopyFrom(
    passIn: ChartPivotFilterConfigCollection
): ChartPivotFilterConfigCollection;
JScript
public function CopyFrom(
   passIn : ChartPivotFilterConfigCollection
) : ChartPivotFilterConfigCollection;
Managed Extensions for C++
public: ChartPivotFilterConfigCollection* CopyFrom(
   ChartPivotFilterConfigCollection* passIn
)
C++/CLI
public:
ChartPivotFilterConfigCollection^ CopyFrom(
   ChartPivotFilterConfigCollection^ passIn
)

Parameters

passIn

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartPivotFilterConfigCollection Class
ChartPivotFilterConfigCollection Members


CopyTo Method

[image]
Intersoft WebGrid Documentation
CopyTo Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartPivotFilterConfigCollection Class : CopyTo Method

array
index

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub CopyTo( _
   ByVal array() As ISNet.WebUI.INamedObject, _
   ByVal index As System.Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartPivotFilterConfigCollection
Dim array() As ISNet.WebUI.INamedObject
Dim index As System.Integer

instance.CopyTo(array, index)
C#
public void CopyTo(
   ISNet.WebUI.INamedObject[] array,
   System.int index
)
Delphi
public procedure CopyTo(
    array: ISNet.WebUI.INamedObjectarray of;
    index: System.Integer
);
JScript
public function CopyTo(
   array : ISNet.WebUI.INamedObject[],
   index : System.int
);
Managed Extensions for C++
public: void CopyTo(
   ISNet.WebUI.INamedObject*[]* array,
   System.int index
)
C++/CLI
public:
void CopyTo(
   ISNet.WebUI.array<INamedObject^>^ array,
   System.int index
)

Parameters

array
index

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartPivotFilterConfigCollection Class
ChartPivotFilterConfigCollection Members


Exists Method

[image]
Intersoft WebGrid Documentation
Exists Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartPivotFilterConfigCollection Class : Exists Method

name

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function Exists( _
   ByVal name As System.String _
) As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As ChartPivotFilterConfigCollection
Dim name As System.String
Dim value As System.Boolean

value = instance.Exists(name)
C#
public System.bool Exists(
   System.string name
)
Delphi
public function Exists(
    name: System.String
): System.Boolean;
JScript
public function Exists(
   name : System.String
) : System.boolean;
Managed Extensions for C++
public: System.bool Exists(
   System.string* name
)
C++/CLI
public:
System.bool Exists(
   System.String^ name
)

Parameters

name

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartPivotFilterConfigCollection Class
ChartPivotFilterConfigCollection Members


GetEnumerator Method

[image]
Intersoft WebGrid Documentation
GetEnumerator Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartPivotFilterConfigCollection Class : GetEnumerator Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Shadows Function GetEnumerator() As System.Collections.IEnumerator
Visual Basic (Usage) Copy Code
Dim instance As ChartPivotFilterConfigCollection
Dim value As System.Collections.IEnumerator

value = instance.GetEnumerator()
C#
public new System.Collections.IEnumerator GetEnumerator()
Delphi
public function GetEnumerator(): System.Collections.IEnumerator;
JScript
public hide function GetEnumerator() : System.Collections.IEnumerator;
Managed Extensions for C++
public: new System.Collections.IEnumerator* GetEnumerator();
C++/CLI
public:
new System.Collections.IEnumerator^ GetEnumerator();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartPivotFilterConfigCollection Class
ChartPivotFilterConfigCollection Members


GetItem Method

[image]
Intersoft WebGrid Documentation
GetItem Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartPivotFilterConfigCollection Class : GetItem Method

Glossary Item Box

Overload List

Overload | Description
GetItem | (Inherited from ISNet.WebUI.ISCollectionBase)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartPivotFilterConfigCollection Class
ChartPivotFilterConfigCollection Members


GetItem(Int32) Method

[image]
Intersoft WebGrid Documentation
GetItem(Int32) Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartPivotFilterConfigCollection Class : GetItem(Int32) Method

index

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetItem( _
   ByVal index As System.Integer _
) As ISNet.WebUI.INamedObject
Visual Basic (Usage) Copy Code
Dim instance As ChartPivotFilterConfigCollection
Dim index As System.Integer
Dim value As ISNet.WebUI.INamedObject

value = instance.GetItem(index)
C#
public virtual ISNet.WebUI.INamedObject GetItem(
   System.int index
)
Delphi
public function GetItem(
    index: System.Integer
): ISNet.WebUI.INamedObject; virtual;
JScript
public function GetItem(
   index : System.int
) : ISNet.WebUI.INamedObject;
Managed Extensions for C++
public: virtual ISNet.WebUI.INamedObject* GetItem(
   System.int index
)
C++/CLI
public:
virtual ISNet.WebUI.INamedObject^ GetItem(
   System.int index
)

Parameters

index

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartPivotFilterConfigCollection Class
ChartPivotFilterConfigCollection Members


GetNamedItem Method

[image]
Intersoft WebGrid Documentation
GetNamedItem Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartPivotFilterConfigCollection Class : GetNamedItem Method

name

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetNamedItem( _
   ByVal name As System.String _
) As ChartPivotFilterConfig
Visual Basic (Usage) Copy Code
Dim instance As ChartPivotFilterConfigCollection
Dim name As System.String
Dim value As ChartPivotFilterConfig

value = instance.GetNamedItem(name)
C#
public ChartPivotFilterConfig GetNamedItem(
   System.string name
)
Delphi
public function GetNamedItem(
    name: System.String
): ChartPivotFilterConfig;
JScript
public function GetNamedItem(
   name : System.String
) : ChartPivotFilterConfig;
Managed Extensions for C++
public: ChartPivotFilterConfig* GetNamedItem(
   System.string* name
)
C++/CLI
public:
ChartPivotFilterConfig^ GetNamedItem(
   System.String^ name
)

Parameters

name

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartPivotFilterConfigCollection Class
ChartPivotFilterConfigCollection Members


IndexOf Method

[image]
Intersoft WebGrid Documentation
IndexOf Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartPivotFilterConfigCollection Class : IndexOf Method

Glossary Item Box

Overload List

Overload | Description
IndexOf(String) | (Inherited from ISNet.WebUI.ISCollectionBase)
IndexOf(INamedObject) | (Inherited from ISNet.WebUI.ISCollectionBase)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartPivotFilterConfigCollection Class
ChartPivotFilterConfigCollection Members


IndexOf(String) Method

[image]
Intersoft WebGrid Documentation
IndexOf(String) Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartPivotFilterConfigCollection Class > IndexOf Method : IndexOf(String) Method

name

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function IndexOf( _
   ByVal name As System.String _
) As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As ChartPivotFilterConfigCollection
Dim name As System.String
Dim value As System.Integer

value = instance.IndexOf(name)
C#
public virtual System.int IndexOf(
   System.string name
)
Delphi
public function IndexOf(
    name: System.String
): System.Integer; virtual;
JScript
public function IndexOf(
   name : System.String
) : System.int;
Managed Extensions for C++
public: virtual System.int IndexOf(
   System.string* name
)
C++/CLI
public:
virtual System.int IndexOf(
   System.String^ name
)

Parameters

name

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartPivotFilterConfigCollection Class
ChartPivotFilterConfigCollection Members
Overload List


IndexOf(INamedObject) Method

[image]
Intersoft WebGrid Documentation
IndexOf(INamedObject) Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartPivotFilterConfigCollection Class > IndexOf Method : IndexOf(INamedObject) Method

value

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function IndexOf( _
   ByVal value As ISNet.WebUI.INamedObject _
) As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As ChartPivotFilterConfigCollection
Dim value As ISNet.WebUI.INamedObject
Dim value As System.Integer

value = instance.IndexOf(value)
C#
public System.int IndexOf(
   ISNet.WebUI.INamedObject value
)
Delphi
public function IndexOf(
    value: ISNet.WebUI.INamedObject
): System.Integer;
JScript
public function IndexOf(
   value : ISNet.WebUI.INamedObject
) : System.int;
Managed Extensions for C++
public: System.int IndexOf(
   ISNet.WebUI.INamedObject* value
)
C++/CLI
public:
System.int IndexOf(
   ISNet.WebUI.INamedObject^ value
)

Parameters

value

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartPivotFilterConfigCollection Class
ChartPivotFilterConfigCollection Members
Overload List


Insert Method

[image]
Intersoft WebGrid Documentation
Insert Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartPivotFilterConfigCollection Class : Insert Method

index
item

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub Insert( _
   ByVal index As System.Integer, _
   ByVal item As ChartPivotFilterConfig _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartPivotFilterConfigCollection
Dim index As System.Integer
Dim item As ChartPivotFilterConfig

instance.Insert(index, item)
C#
public void Insert(
   System.int index,
   ChartPivotFilterConfig item
)
Delphi
public procedure Insert(
    index: System.Integer;
    item: ChartPivotFilterConfig
);
JScript
public function Insert(
   index : System.int,
   item : ChartPivotFilterConfig
);
Managed Extensions for C++
public: void Insert(
   System.int index,
   ChartPivotFilterConfig* item
)
C++/CLI
public:
void Insert(
   System.int index,
   ChartPivotFilterConfig^ item
)

Parameters

index
item

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartPivotFilterConfigCollection Class
ChartPivotFilterConfigCollection Members


IntInsert Method

[image]
Intersoft WebGrid Documentation
IntInsert Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartPivotFilterConfigCollection Class : IntInsert Method

index
value

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub IntInsert( _
   ByVal index As System.Integer, _
   ByVal value As ISNet.WebUI.INamedObject _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartPivotFilterConfigCollection
Dim index As System.Integer
Dim value As ISNet.WebUI.INamedObject

instance.IntInsert(index, value)
C#
public void IntInsert(
   System.int index,
   ISNet.WebUI.INamedObject value
)
Delphi
public procedure IntInsert(
    index: System.Integer;
    value: ISNet.WebUI.INamedObject
);
JScript
public function IntInsert(
   index : System.int,
   value : ISNet.WebUI.INamedObject
);
Managed Extensions for C++
public: void IntInsert(
   System.int index,
   ISNet.WebUI.INamedObject* value
)
C++/CLI
public:
void IntInsert(
   System.int index,
   ISNet.WebUI.INamedObject^ value
)

Parameters

index
value

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartPivotFilterConfigCollection Class
ChartPivotFilterConfigCollection Members


Remove Method

[image]
Intersoft WebGrid Documentation
Remove Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartPivotFilterConfigCollection Class : Remove Method

item

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub Remove( _
   ByVal item As ChartPivotFilterConfig _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartPivotFilterConfigCollection
Dim item As ChartPivotFilterConfig

instance.Remove(item)
C#
public void Remove(
   ChartPivotFilterConfig item
)
Delphi
public procedure Remove(
    item: ChartPivotFilterConfig
);
JScript
public function Remove(
   item : ChartPivotFilterConfig
);
Managed Extensions for C++
public: void Remove(
   ChartPivotFilterConfig* item
)
C++/CLI
public:
void Remove(
   ChartPivotFilterConfig^ item
)

Parameters

item

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartPivotFilterConfigCollection Class
ChartPivotFilterConfigCollection Members


setParent Method

[image]
Intersoft WebGrid Documentation
setParent Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartPivotFilterConfigCollection Class : setParent Method

parent

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub setParent( _
   ByVal parent As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartPivotFilterConfigCollection
Dim parent As System.Object

instance.setParent(parent)
C#
public virtual void setParent(
   System.object parent
)
Delphi
public procedure setParent(
    parent: System.TObject
); virtual;
JScript
public function setParent(
   parent : System.Object
);
Managed Extensions for C++
public: virtual void setParent(
   System.Object* parent
)
C++/CLI
public:
virtual void setParent(
   System.Object^ parent
)

Parameters

parent

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartPivotFilterConfigCollection Class
ChartPivotFilterConfigCollection Members


Capacity Property

[image]
Intersoft WebGrid Documentation
Capacity Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartPivotFilterConfigCollection Class : Capacity Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Runtime.InteropServices.ComVisibleAttribute(False)>
Public Property Capacity As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As ChartPivotFilterConfigCollection
Dim value As System.Integer

instance.Capacity = value

value = instance.Capacity
C#
[System.Runtime.InteropServices.ComVisibleAttribute(false)]
public System.int Capacity {get; set;}
Delphi
public read-write property Capacity: System.Integer;
JScript
System.Runtime.InteropServices.ComVisibleAttribute()
public function get,set Capacity : System.int
Managed Extensions for C++
[System.Runtime.InteropServices.ComVisibleAttribute(false)]
public: __property System.int get_Capacity();
public: __property void set_Capacity(
   System.int value
);
C++/CLI
[System.Runtime.InteropServices.ComVisibleAttribute(false)]
public:
property System.int Capacity {
   System.int get();
   void set (    System.int value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartPivotFilterConfigCollection Class
ChartPivotFilterConfigCollection Members


Count Property

[image]
Intersoft WebGrid Documentation
Count Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartPivotFilterConfigCollection Class : Count Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Count As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As ChartPivotFilterConfigCollection
Dim value As System.Integer

value = instance.Count
C#
public System.int Count {get;}
Delphi
public read-only property Count: System.Integer;
JScript
public function get Count : System.int
Managed Extensions for C++
public: __property System.int get_Count();
C++/CLI
public:
property System.int Count {
   System.int get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartPivotFilterConfigCollection Class
ChartPivotFilterConfigCollection Members


ChartPivotFilterConfigCollection Class Properties

[image]
Intersoft WebGrid Documentation
ChartPivotFilterConfigCollection Class Properties
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartPivotFilterConfigCollection Class

Glossary Item Box

For a list of all members of this type, see ChartPivotFilterConfigCollection members.

Public Properties

 | Name | Description
Public Property | Capacity | (Inherited from System.Collections.CollectionBase)
Public Property | Count | (Inherited from System.Collections.CollectionBase)
Public Property | IsReadOnly | Overridden.
Public Property | Item |
Public Property | Parent | (Inherited from ISNet.WebUI.ISCollectionBase)
Top

See Also

Reference

ChartPivotFilterConfigCollection Class
ISNet.WebUI.WebGrid.Chart Namespace


ChartPivotFilterConfigCollection Constructor

[image]
Intersoft WebGrid Documentation
ChartPivotFilterConfigCollection Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartPivotFilterConfigCollection Class : ChartPivotFilterConfigCollection Constructor

Glossary Item Box

Overload List

Overload | Description
ChartPivotFilterConfigCollection Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartPivotFilterConfigCollection Class
ChartPivotFilterConfigCollection Members


IsReadOnly Property

[image]
Intersoft WebGrid Documentation
IsReadOnly Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartPivotFilterConfigCollection Class : IsReadOnly Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property IsReadOnly As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As ChartPivotFilterConfigCollection
Dim value As System.Boolean

value = instance.IsReadOnly
C#
public override System.bool IsReadOnly {get;}
Delphi
public read-only property IsReadOnly: System.Boolean; override;
JScript
public override function get IsReadOnly : System.boolean
Managed Extensions for C++
public: __property System.bool get_IsReadOnly() override;
C++/CLI
public:
property System.bool IsReadOnly {
   System.bool get() override;
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartPivotFilterConfigCollection Class
ChartPivotFilterConfigCollection Members


Item Property

[image]
Intersoft WebGrid Documentation
Item Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartPivotFilterConfigCollection Class : Item Property

index

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Default Property Item( _
   ByVal index As System.Integer _
) As ChartPivotFilterConfig
Visual Basic (Usage) Copy Code
Dim instance As ChartPivotFilterConfigCollection
Dim index As System.Integer
Dim value As ChartPivotFilterConfig

instance.Item(index) = value

value = instance.Item(index)
C#
public ChartPivotFilterConfig this[
   System.int index
]; {get; set;}
Delphi
public  this: : ChartPivotFilterConfig;[
    index: System.Integer
]; read-write
JScript
public  this[
   index : System.int
] get,set : ChartPivotFilterConfig
Managed Extensions for C++
public: __property ChartPivotFilterConfig* get_Item   System.int index
;
public: __property void set_Item   System.int index,
   ChartPivotFilterConfig* value
;
C++/CLI
public:
property ChartPivotFilterConfig^ default [int] {
   ChartPivotFilterConfig^ get(System.int index);
   void set (System.int index, ChartPivotFilterConfig^ value);
}

Parameters

index

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartPivotFilterConfigCollection Class
ChartPivotFilterConfigCollection Members


Parent Property

[image]
Intersoft WebGrid Documentation
Parent Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartPivotFilterConfigCollection Class : Parent Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Parent As System.Object
Visual Basic (Usage) Copy Code
Dim instance As ChartPivotFilterConfigCollection
Dim value As System.Object

value = instance.Parent
C#
public System.object Parent {get;}
Delphi
public read-only property Parent: System.TObject;
JScript
public function get Parent : System.Object
Managed Extensions for C++
public: __property System.Object* get_Parent();
C++/CLI
public:
property System.Object^ Parent {
   System.Object^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartPivotFilterConfigCollection Class
ChartPivotFilterConfigCollection Members


ChartPointValue Class

[image]
Intersoft WebGrid Documentation
ChartPointValue Class
Members See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartPointValue Class

Glossary Item Box

Object Model

ChartPointValue Class

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.SerializableAttribute()>
Public Class ChartPointValue
   Inherits ISNet.WebUI.WebUIBaseClass
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Visual Basic (Usage) Copy Code
Dim instance As ChartPointValue
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public class ChartPointValue : ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Delphi
public class ChartPointValue = class(ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize)
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.SerializableAttribute()
public class ChartPointValue extends ISNet.WebUI.WebUIBaseClass implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public __gc class ChartPointValue : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public ref class ChartPointValue : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.WebGrid.Chart.ChartPointValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartPointValue Members
ISNet.WebUI.WebGrid.Chart Namespace


ChartPointValue Class Members

[image]
Intersoft WebGrid Documentation
ChartPointValue Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartPointValue Class

Glossary Item Box

The following tables list the members exposed by ChartPointValue.

Public Constructors

 | Name | Description
Public Constructor | ChartPointValue Constructor |
Top

Public Properties

 | Name | Description
Public Property | X |
Public Property | Y |
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

ChartPointValue Class
ISNet.WebUI.WebGrid.Chart Namespace


ChartPointValue Constructor

[image]
Intersoft WebGrid Documentation
ChartPointValue Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartPointValue Class : ChartPointValue Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New ChartPointValue()
C#
public ChartPointValue()
Delphi
public ChartPointValue();
JScript
public function ChartPointValue();
Managed Extensions for C++
public: ChartPointValue();
C++/CLI
public:
ChartPointValue();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartPointValue Class
ChartPointValue Members


Clone Method

[image]
Intersoft WebGrid Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartPointValue Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As System.Object
Visual Basic (Usage) Copy Code
Dim instance As ChartPointValue
Dim value As System.Object

value = instance.Clone()
C#
public virtual System.object Clone()
Delphi
public function Clone(): System.TObject; virtual;
JScript
public function Clone() : System.Object;
Managed Extensions for C++
public: virtual System.Object* Clone();
C++/CLI
public:
virtual System.Object^ Clone();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartPointValue Class
ChartPointValue Members


CopyFrom Method

[image]
Intersoft WebGrid Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartPointValue Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartPointValue Class
ChartPointValue Members


CopyFrom(Object) Method

[image]
Intersoft WebGrid Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartPointValue Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartPointValue
Dim objSource As System.Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   System.object objSource
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartPointValue Class
ChartPointValue Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebGrid Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartPointValue Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object, _
   ByVal cloneSourceValue As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartPointValue
Dim objSource As System.Object
Dim cloneSourceValue As System.Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   System.object objSource,
   System.bool cloneSourceValue
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject;
    cloneSourceValue: System.Boolean
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object,
   cloneSourceValue : System.boolean
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource,
   System.bool cloneSourceValue
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource,
   System.bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartPointValue Class
ChartPointValue Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebGrid Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartPointValue Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartPointValue
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure DeSerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function DeSerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void DeSerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void DeSerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartPointValue Class
ChartPointValue Members


GetHashCode Method

[image]
Intersoft WebGrid Documentation
GetHashCode Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartPointValue Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As ChartPointValue
Dim value As System.Integer

value = instance.GetHashCode()
C#
public virtual System.int GetHashCode()
Delphi
public function GetHashCode(): System.Integer; virtual;
JScript
public function GetHashCode() : System.int;
Managed Extensions for C++
public: virtual System.int GetHashCode();
C++/CLI
public:
virtual System.int GetHashCode();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartPointValue Class
ChartPointValue Members


ChartPointValue Class Methods

[image]
Intersoft WebGrid Documentation
ChartPointValue Class Methods
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartPointValue Class

Glossary Item Box

For a list of all members of this type, see ChartPointValue members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

ChartPointValue Class
ISNet.WebUI.WebGrid.Chart Namespace


GetObjectData Method

[image]
Intersoft WebGrid Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartPointValue Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=False,
   UnmanagedCode=False,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=True,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Action=SecurityAction.Demand,
   Unrestricted=False)>
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartPointValue
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure GetObjectData(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
); override;
JScript
System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=,
   UnmanagedCode=,
   SkipVerification=,
   Execution=,
   ControlThread=,
   ControlEvidence=,
   ControlPolicy=,
   SerializationFormatter=,
   ControlDomainPolicy=,
   ControlPrincipal=,
   ControlAppDomain=,
   RemotingConfiguration=,
   Infrastructure=,
   BindingRedirects=,
   Action=SecurityAction.Demand,
   Unrestricted=)
public override function GetObjectData(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public: void GetObjectData(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
) override
C++/CLI
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public:
void GetObjectData(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
) override

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartPointValue Class
ChartPointValue Members


IsEmpty Method

[image]
Intersoft WebGrid Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartPointValue Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As ChartPointValue
Dim value As System.Boolean

value = instance.IsEmpty()
C#
public virtual System.bool IsEmpty()
Delphi
public function IsEmpty(): System.Boolean; virtual;
JScript
public function IsEmpty() : System.boolean;
Managed Extensions for C++
public: virtual System.bool IsEmpty();
C++/CLI
public:
virtual System.bool IsEmpty();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartPointValue Class
ChartPointValue Members


Reset Method

[image]
Intersoft WebGrid Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartPointValue Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As ChartPointValue

instance.Reset()
C#
public virtual void Reset()
Delphi
public procedure Reset(); virtual;
JScript
public function Reset();
Managed Extensions for C++
public: virtual void Reset();
C++/CLI
public:
virtual void Reset();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartPointValue Class
ChartPointValue Members


SerializeObjectData Method

[image]
Intersoft WebGrid Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartPointValue Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartPointValue
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure SerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function SerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void SerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void SerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartPointValue Class
ChartPointValue Members


ToString Method

[image]
Intersoft WebGrid Documentation
ToString Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartPointValue Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As System.String
Visual Basic (Usage) Copy Code
Dim instance As ChartPointValue
Dim value As System.String

value = instance.ToString()
C#
public virtual System.string ToString()
Delphi
public function ToString(): System.String; virtual;
JScript
public function ToString() : System.String;
Managed Extensions for C++
public: virtual System.string* ToString();
C++/CLI
public:
virtual System.String^ ToString();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartPointValue Class
ChartPointValue Members


ChartPointValue Class Properties

[image]
Intersoft WebGrid Documentation
ChartPointValue Class Properties
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartPointValue Class

Glossary Item Box

For a list of all members of this type, see ChartPointValue members.

Public Properties

 | Name | Description
Public Property | X |
Public Property | Y |
Top

See Also

Reference

ChartPointValue Class
ISNet.WebUI.WebGrid.Chart Namespace


ChartPointValue Constructor

[image]
Intersoft WebGrid Documentation
ChartPointValue Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartPointValue Class : ChartPointValue Constructor

Glossary Item Box

Overload List

Overload | Description
ChartPointValue Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartPointValue Class
ChartPointValue Members


X Property

[image]
Intersoft WebGrid Documentation
X Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartPointValue Class : X Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Layout")>
<System.ComponentModel.DescriptionAttribute("The X coordinate.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property X As System.Nullable(Of Single)
Visual Basic (Usage) Copy Code
Dim instance As ChartPointValue
Dim value As System.Nullable(Of Single)

instance.X = value

value = instance.X
C#
[System.ComponentModel.CategoryAttribute("Layout")]
[System.ComponentModel.DescriptionAttribute("The X coordinate.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.Nullable<float> X {get; set;}
Delphi
public read-write property X: System.Nullable;
JScript
System.ComponentModel.CategoryAttribute("Layout")
System.ComponentModel.DescriptionAttribute("The X coordinate.")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set X : System.Nullable
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Layout")]
[System.ComponentModel.DescriptionAttribute("The X coordinate.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.Nullable<float> get_X();
public: __property void set_X(
   System.Nullable<float> value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Layout")]
[System.ComponentModel.DescriptionAttribute("The X coordinate.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.Nullable<float> X {
   System.Nullable<float> get();
   void set (    System.Nullable<float> value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartPointValue Class
ChartPointValue Members


Y Property

[image]
Intersoft WebGrid Documentation
Y Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartPointValue Class : Y Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("The Y coordinate.")>
<System.ComponentModel.CategoryAttribute("Layout")>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property Y As System.Nullable(Of Single)
Visual Basic (Usage) Copy Code
Dim instance As ChartPointValue
Dim value As System.Nullable(Of Single)

instance.Y = value

value = instance.Y
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("The Y coordinate.")]
[System.ComponentModel.CategoryAttribute("Layout")]
[ISNet.Serialization.BinarySerializableAttribute()]
public System.Nullable<float> Y {get; set;}
Delphi
public read-write property Y: System.Nullable;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("The Y coordinate.")
System.ComponentModel.CategoryAttribute("Layout")
ISNet.Serialization.BinarySerializableAttribute()
public function get,set Y : System.Nullable
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("The Y coordinate.")]
[System.ComponentModel.CategoryAttribute("Layout")]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.Nullable<float> get_Y();
public: __property void set_Y(
   System.Nullable<float> value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("The Y coordinate.")]
[System.ComponentModel.CategoryAttribute("Layout")]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.Nullable<float> Y {
   System.Nullable<float> get();
   void set (    System.Nullable<float> value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartPointValue Class
ChartPointValue Members


ChartProjectionSettings Class

[image]
Intersoft WebGrid Documentation
ChartProjectionSettings Class
Members See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartProjectionSettings Class

Glossary Item Box

Object Model

ChartProjectionSettings Class

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.SerializableAttribute()>
Public Class ChartProjectionSettings
   Inherits ISNet.WebUI.WebUIBaseClass
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Visual Basic (Usage) Copy Code
Dim instance As ChartProjectionSettings
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public class ChartProjectionSettings : ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Delphi
public class ChartProjectionSettings = class(ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize)
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.SerializableAttribute()
public class ChartProjectionSettings extends ISNet.WebUI.WebUIBaseClass implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public __gc class ChartProjectionSettings : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public ref class ChartProjectionSettings : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.WebGrid.Chart.ChartProjectionSettings

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartProjectionSettings Members
ISNet.WebUI.WebGrid.Chart Namespace


ChartProjectionSettings Class Members

[image]
Intersoft WebGrid Documentation
ChartProjectionSettings Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartProjectionSettings Class

Glossary Item Box

The following tables list the members exposed by ChartProjectionSettings.

Public Constructors

 | Name | Description
Public Constructor | ChartProjectionSettings Constructor |
Top

Public Properties

 | Name | Description
Public Property | Elevation |
Public Property | PerspectiveAngle |
Public Property | PredefinedProjection |
Public Property | ProjectionType |
Public Property | Rotation |
Public Property | UsePredefinedProjection |
Public Property | ViewerRotation |
Public Property | XDepth |
Public Property | YDepth |
Public Property | Zoom |
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

ChartProjectionSettings Class
ISNet.WebUI.WebGrid.Chart Namespace


ChartProjectionSettings Constructor

[image]
Intersoft WebGrid Documentation
ChartProjectionSettings Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartProjectionSettings Class : ChartProjectionSettings Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New ChartProjectionSettings()
C#
public ChartProjectionSettings()
Delphi
public ChartProjectionSettings();
JScript
public function ChartProjectionSettings();
Managed Extensions for C++
public: ChartProjectionSettings();
C++/CLI
public:
ChartProjectionSettings();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartProjectionSettings Class
ChartProjectionSettings Members


Clone Method

[image]
Intersoft WebGrid Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartProjectionSettings Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As System.Object
Visual Basic (Usage) Copy Code
Dim instance As ChartProjectionSettings
Dim value As System.Object

value = instance.Clone()
C#
public virtual System.object Clone()
Delphi
public function Clone(): System.TObject; virtual;
JScript
public function Clone() : System.Object;
Managed Extensions for C++
public: virtual System.Object* Clone();
C++/CLI
public:
virtual System.Object^ Clone();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartProjectionSettings Class
ChartProjectionSettings Members


CopyFrom Method

[image]
Intersoft WebGrid Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartProjectionSettings Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartProjectionSettings Class
ChartProjectionSettings Members


CopyFrom(Object) Method

[image]
Intersoft WebGrid Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartProjectionSettings Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartProjectionSettings
Dim objSource As System.Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   System.object objSource
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartProjectionSettings Class
ChartProjectionSettings Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebGrid Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartProjectionSettings Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object, _
   ByVal cloneSourceValue As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartProjectionSettings
Dim objSource As System.Object
Dim cloneSourceValue As System.Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   System.object objSource,
   System.bool cloneSourceValue
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject;
    cloneSourceValue: System.Boolean
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object,
   cloneSourceValue : System.boolean
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource,
   System.bool cloneSourceValue
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource,
   System.bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartProjectionSettings Class
ChartProjectionSettings Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebGrid Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartProjectionSettings Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartProjectionSettings
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure DeSerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function DeSerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void DeSerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void DeSerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartProjectionSettings Class
ChartProjectionSettings Members


GetHashCode Method

[image]
Intersoft WebGrid Documentation
GetHashCode Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartProjectionSettings Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As ChartProjectionSettings
Dim value As System.Integer

value = instance.GetHashCode()
C#
public virtual System.int GetHashCode()
Delphi
public function GetHashCode(): System.Integer; virtual;
JScript
public function GetHashCode() : System.int;
Managed Extensions for C++
public: virtual System.int GetHashCode();
C++/CLI
public:
virtual System.int GetHashCode();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartProjectionSettings Class
ChartProjectionSettings Members


ChartProjectionSettings Class Methods

[image]
Intersoft WebGrid Documentation
ChartProjectionSettings Class Methods
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartProjectionSettings Class

Glossary Item Box

For a list of all members of this type, see ChartProjectionSettings members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

ChartProjectionSettings Class
ISNet.WebUI.WebGrid.Chart Namespace


GetObjectData Method

[image]
Intersoft WebGrid Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartProjectionSettings Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=False,
   UnmanagedCode=False,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=True,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Action=SecurityAction.Demand,
   Unrestricted=False)>
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartProjectionSettings
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure GetObjectData(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
); override;
JScript
System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=,
   UnmanagedCode=,
   SkipVerification=,
   Execution=,
   ControlThread=,
   ControlEvidence=,
   ControlPolicy=,
   SerializationFormatter=,
   ControlDomainPolicy=,
   ControlPrincipal=,
   ControlAppDomain=,
   RemotingConfiguration=,
   Infrastructure=,
   BindingRedirects=,
   Action=SecurityAction.Demand,
   Unrestricted=)
public override function GetObjectData(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public: void GetObjectData(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
) override
C++/CLI
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public:
void GetObjectData(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
) override

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartProjectionSettings Class
ChartProjectionSettings Members


IsEmpty Method

[image]
Intersoft WebGrid Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartProjectionSettings Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As ChartProjectionSettings
Dim value As System.Boolean

value = instance.IsEmpty()
C#
public virtual System.bool IsEmpty()
Delphi
public function IsEmpty(): System.Boolean; virtual;
JScript
public function IsEmpty() : System.boolean;
Managed Extensions for C++
public: virtual System.bool IsEmpty();
C++/CLI
public:
virtual System.bool IsEmpty();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartProjectionSettings Class
ChartProjectionSettings Members


Reset Method

[image]
Intersoft WebGrid Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartProjectionSettings Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As ChartProjectionSettings

instance.Reset()
C#
public virtual void Reset()
Delphi
public procedure Reset(); virtual;
JScript
public function Reset();
Managed Extensions for C++
public: virtual void Reset();
C++/CLI
public:
virtual void Reset();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartProjectionSettings Class
ChartProjectionSettings Members


SerializeObjectData Method

[image]
Intersoft WebGrid Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartProjectionSettings Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartProjectionSettings
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure SerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function SerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void SerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void SerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartProjectionSettings Class
ChartProjectionSettings Members


ToString Method

[image]
Intersoft WebGrid Documentation
ToString Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartProjectionSettings Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As System.String
Visual Basic (Usage) Copy Code
Dim instance As ChartProjectionSettings
Dim value As System.String

value = instance.ToString()
C#
public virtual System.string ToString()
Delphi
public function ToString(): System.String; virtual;
JScript
public function ToString() : System.String;
Managed Extensions for C++
public: virtual System.string* ToString();
C++/CLI
public:
virtual System.String^ ToString();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartProjectionSettings Class
ChartProjectionSettings Members


ChartProjectionSettings Class Properties

[image]
Intersoft WebGrid Documentation
ChartProjectionSettings Class Properties
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartProjectionSettings Class

Glossary Item Box

For a list of all members of this type, see ChartProjectionSettings members.

Public Properties

 | Name | Description
Public Property | Elevation |
Public Property | PerspectiveAngle |
Public Property | PredefinedProjection |
Public Property | ProjectionType |
Public Property | Rotation |
Public Property | UsePredefinedProjection |
Public Property | ViewerRotation |
Public Property | XDepth |
Public Property | YDepth |
Public Property | Zoom |
Top

See Also

Reference

ChartProjectionSettings Class
ISNet.WebUI.WebGrid.Chart Namespace


ChartProjectionSettings Constructor

[image]
Intersoft WebGrid Documentation
ChartProjectionSettings Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartProjectionSettings Class : ChartProjectionSettings Constructor

Glossary Item Box

Overload List

Overload | Description
ChartProjectionSettings Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartProjectionSettings Class
ChartProjectionSettings Members


Elevation Property

[image]
Intersoft WebGrid Documentation
Elevation Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartProjectionSettings Class : Elevation Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("General")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("The elevation of the viewpoint in degrees. ")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property Elevation As System.Single
Visual Basic (Usage) Copy Code
Dim instance As ChartProjectionSettings
Dim value As System.Single

instance.Elevation = value

value = instance.Elevation
C#
[System.ComponentModel.CategoryAttribute("General")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("The elevation of the viewpoint in degrees. ")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.float Elevation {get; set;}
Delphi
public read-write property Elevation: System.Single;
JScript
System.ComponentModel.CategoryAttribute("General")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("The elevation of the viewpoint in degrees. ")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set Elevation : System.float
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("General")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("The elevation of the viewpoint in degrees. ")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.float get_Elevation();
public: __property void set_Elevation(
   System.float value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("General")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("The elevation of the viewpoint in degrees. ")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.float Elevation {
   System.float get();
   void set (    System.float value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartProjectionSettings Class
ChartProjectionSettings Members


PerspectiveAngle Property

[image]
Intersoft WebGrid Documentation
PerspectiveAngle Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartProjectionSettings Class : PerspectiveAngle Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("The field of view angle, in degrees when the Projection property is set to ProjectionType.Perspective")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("General")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property PerspectiveAngle As System.Single
Visual Basic (Usage) Copy Code
Dim instance As ChartProjectionSettings
Dim value As System.Single

instance.PerspectiveAngle = value

value = instance.PerspectiveAngle
C#
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("The field of view angle, in degrees when the Projection property is set to ProjectionType.Perspective")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.float PerspectiveAngle {get; set;}
Delphi
public read-write property PerspectiveAngle: System.Single;
JScript
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("The field of view angle, in degrees when the Projection property is set to ProjectionType.Perspective")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("General")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set PerspectiveAngle : System.float
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("The field of view angle, in degrees when the Projection property is set to ProjectionType.Perspective")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.float get_PerspectiveAngle();
public: __property void set_PerspectiveAngle(
   System.float value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("The field of view angle, in degrees when the Projection property is set to ProjectionType.Perspective")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.float PerspectiveAngle {
   System.float get();
   void set (    System.float value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartProjectionSettings Class
ChartProjectionSettings Members


PredefinedProjection Property

[image]
Intersoft WebGrid Documentation
PredefinedProjection Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartProjectionSettings Class : PredefinedProjection Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("General")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Specified the predefined projection")>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property PredefinedProjection As PredefinedProjection
Visual Basic (Usage) Copy Code
Dim instance As ChartProjectionSettings
Dim value As PredefinedProjection

instance.PredefinedProjection = value

value = instance.PredefinedProjection
C#
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specified the predefined projection")]
[ISNet.Serialization.BinarySerializableAttribute()]
public PredefinedProjection PredefinedProjection {get; set;}
Delphi
public read-write property PredefinedProjection: PredefinedProjection;
JScript
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("General")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Specified the predefined projection")
ISNet.Serialization.BinarySerializableAttribute()
public function get,set PredefinedProjection : PredefinedProjection
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specified the predefined projection")]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property PredefinedProjection get_PredefinedProjection();
public: __property void set_PredefinedProjection(
   PredefinedProjection value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specified the predefined projection")]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property PredefinedProjection PredefinedProjection {
   PredefinedProjection get();
   void set (    PredefinedProjection value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartProjectionSettings Class
ChartProjectionSettings Members


ProjectionType Property

[image]
Intersoft WebGrid Documentation
ProjectionType Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartProjectionSettings Class : ProjectionType Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Controls the projection type of the camera. Can be ProjectionType.Orthogonal or ProjectionType.Perspective.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("General")>
Public Property ProjectionType As ProjectionType
Visual Basic (Usage) Copy Code
Dim instance As ChartProjectionSettings
Dim value As ProjectionType

instance.ProjectionType = value

value = instance.ProjectionType
C#
[System.ComponentModel.DescriptionAttribute("Controls the projection type of the camera. Can be ProjectionType.Orthogonal or ProjectionType.Perspective.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("General")]
public ProjectionType ProjectionType {get; set;}
Delphi
public read-write property ProjectionType: ProjectionType;
JScript
System.ComponentModel.DescriptionAttribute("Controls the projection type of the camera. Can be ProjectionType.Orthogonal or ProjectionType.Perspective.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("General")
public function get,set ProjectionType : ProjectionType
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Controls the projection type of the camera. Can be ProjectionType.Orthogonal or ProjectionType.Perspective.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("General")]
public: __property ProjectionType get_ProjectionType();
public: __property void set_ProjectionType(
   ProjectionType value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Controls the projection type of the camera. Can be ProjectionType.Orthogonal or ProjectionType.Perspective.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("General")]
public:
property ProjectionType ProjectionType {
   ProjectionType get();
   void set (    ProjectionType value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartProjectionSettings Class
ChartProjectionSettings Members


Rotation Property

[image]
Intersoft WebGrid Documentation
Rotation Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartProjectionSettings Class : Rotation Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("General")>
<System.ComponentModel.DescriptionAttribute("The rotation of the viewpoint in degrees.")>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property Rotation As System.Single
Visual Basic (Usage) Copy Code
Dim instance As ChartProjectionSettings
Dim value As System.Single

instance.Rotation = value

value = instance.Rotation
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DescriptionAttribute("The rotation of the viewpoint in degrees.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.float Rotation {get; set;}
Delphi
public read-write property Rotation: System.Single;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("General")
System.ComponentModel.DescriptionAttribute("The rotation of the viewpoint in degrees.")
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set Rotation : System.float
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DescriptionAttribute("The rotation of the viewpoint in degrees.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.float get_Rotation();
public: __property void set_Rotation(
   System.float value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DescriptionAttribute("The rotation of the viewpoint in degrees.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.float Rotation {
   System.float get();
   void set (    System.float value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartProjectionSettings Class
ChartProjectionSettings Members


UsePredefinedProjection Property

[image]
Intersoft WebGrid Documentation
UsePredefinedProjection Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartProjectionSettings Class : UsePredefinedProjection Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("General")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Gets or sets a value indicating whether predefined projection is used.")>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property UsePredefinedProjection As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As ChartProjectionSettings
Dim value As System.Boolean

instance.UsePredefinedProjection = value

value = instance.UsePredefinedProjection
C#
[System.ComponentModel.CategoryAttribute("General")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets a value indicating whether predefined projection is used.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.bool UsePredefinedProjection {get; set;}
Delphi
public read-write property UsePredefinedProjection: System.Boolean;
JScript
System.ComponentModel.CategoryAttribute("General")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets a value indicating whether predefined projection is used.")
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set UsePredefinedProjection : System.boolean
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("General")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets a value indicating whether predefined projection is used.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.bool get_UsePredefinedProjection();
public: __property void set_UsePredefinedProjection(
   System.bool value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("General")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets a value indicating whether predefined projection is used.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.bool UsePredefinedProjection {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartProjectionSettings Class
ChartProjectionSettings Members


ViewerRotation Property

[image]
Intersoft WebGrid Documentation
ViewerRotation Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartProjectionSettings Class : ViewerRotation Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("General")>
<System.ComponentModel.DescriptionAttribute("The rotation (or tilting) of the camera.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property ViewerRotation As System.Single
Visual Basic (Usage) Copy Code
Dim instance As ChartProjectionSettings
Dim value As System.Single

instance.ViewerRotation = value

value = instance.ViewerRotation
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DescriptionAttribute("The rotation (or tilting) of the camera.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.float ViewerRotation {get; set;}
Delphi
public read-write property ViewerRotation: System.Single;
JScript
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("General")
System.ComponentModel.DescriptionAttribute("The rotation (or tilting) of the camera.")
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set ViewerRotation : System.float
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DescriptionAttribute("The rotation (or tilting) of the camera.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.float get_ViewerRotation();
public: __property void set_ViewerRotation(
   System.float value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DescriptionAttribute("The rotation (or tilting) of the camera.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.float ViewerRotation {
   System.float get();
   void set (    System.float value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartProjectionSettings Class
ChartProjectionSettings Members


XDepth Property

[image]
Intersoft WebGrid Documentation
XDepth Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartProjectionSettings Class : XDepth Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("General")>
<System.ComponentModel.DescriptionAttribute("The offset of the 3D objects along the X axis depending on their Z depth when the projection is ProjectionType.Orthogonal")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
Public Property XDepth As System.Single
Visual Basic (Usage) Copy Code
Dim instance As ChartProjectionSettings
Dim value As System.Single

instance.XDepth = value

value = instance.XDepth
C#
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DescriptionAttribute("The offset of the 3D objects along the X axis depending on their Z depth when the projection is ProjectionType.Orthogonal")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public System.float XDepth {get; set;}
Delphi
public read-write property XDepth: System.Single;
JScript
System.ComponentModel.CategoryAttribute("General")
System.ComponentModel.DescriptionAttribute("The offset of the 3D objects along the X axis depending on their Z depth when the projection is ProjectionType.Orthogonal")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
public function get,set XDepth : System.float
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DescriptionAttribute("The offset of the 3D objects along the X axis depending on their Z depth when the projection is ProjectionType.Orthogonal")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.float get_XDepth();
public: __property void set_XDepth(
   System.float value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DescriptionAttribute("The offset of the 3D objects along the X axis depending on their Z depth when the projection is ProjectionType.Orthogonal")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.float XDepth {
   System.float get();
   void set (    System.float value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartProjectionSettings Class
ChartProjectionSettings Members


YDepth Property

[image]
Intersoft WebGrid Documentation
YDepth Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartProjectionSettings Class : YDepth Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.CategoryAttribute("General")>
<System.ComponentModel.DescriptionAttribute("The offset of the 3D objects along the Y axis depending on their Z depth when the projection is ProjectionType.Orthogonal.")>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property YDepth As System.Single
Visual Basic (Usage) Copy Code
Dim instance As ChartProjectionSettings
Dim value As System.Single

instance.YDepth = value

value = instance.YDepth
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DescriptionAttribute("The offset of the 3D objects along the Y axis depending on their Z depth when the projection is ProjectionType.Orthogonal.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.float YDepth {get; set;}
Delphi
public read-write property YDepth: System.Single;
JScript
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.CategoryAttribute("General")
System.ComponentModel.DescriptionAttribute("The offset of the 3D objects along the Y axis depending on their Z depth when the projection is ProjectionType.Orthogonal.")
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set YDepth : System.float
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DescriptionAttribute("The offset of the 3D objects along the Y axis depending on their Z depth when the projection is ProjectionType.Orthogonal.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.float get_YDepth();
public: __property void set_YDepth(
   System.float value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DescriptionAttribute("The offset of the 3D objects along the Y axis depending on their Z depth when the projection is ProjectionType.Orthogonal.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.float YDepth {
   System.float get();
   void set (    System.float value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartProjectionSettings Class
ChartProjectionSettings Members


Zoom Property

[image]
Intersoft WebGrid Documentation
Zoom Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartProjectionSettings Class : Zoom Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("The zooming factor applied to the chart camera in percents.")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("General")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Property Zoom As System.Single
Visual Basic (Usage) Copy Code
Dim instance As ChartProjectionSettings
Dim value As System.Single

instance.Zoom = value

value = instance.Zoom
C#
[System.ComponentModel.DescriptionAttribute("The zooming factor applied to the chart camera in percents.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
public System.float Zoom {get; set;}
Delphi
public read-write property Zoom: System.Single;
JScript
System.ComponentModel.DescriptionAttribute("The zooming factor applied to the chart camera in percents.")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("General")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.XmlSerializableAttribute()
public function get,set Zoom : System.float
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("The zooming factor applied to the chart camera in percents.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property System.float get_Zoom();
public: __property void set_Zoom(
   System.float value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("The zooming factor applied to the chart camera in percents.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property System.float Zoom {
   System.float get();
   void set (    System.float value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartProjectionSettings Class
ChartProjectionSettings Members


ChartRequestHandler Class

[image]
Intersoft WebGrid Documentation
ChartRequestHandler Class
Members See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartRequestHandler Class

Glossary Item Box

Object Model

ChartRequestHandler Class

Syntax

Visual Basic (Declaration)
Public Class ChartRequestHandler
Visual Basic (Usage) Copy Code
Dim instance As ChartRequestHandler
C#
public class ChartRequestHandler
Delphi
public class ChartRequestHandler
JScript
public class ChartRequestHandler
Managed Extensions for C++
public __gc class ChartRequestHandler
C++/CLI
public ref class ChartRequestHandler

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebGrid.Chart.ChartRequestHandler

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartRequestHandler Members
ISNet.WebUI.WebGrid.Chart Namespace


ChartRequestHandler Class Members

[image]
Intersoft WebGrid Documentation
ChartRequestHandler Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartRequestHandler Class

Glossary Item Box

The following tables list the members exposed by ChartRequestHandler.

Public Constructors

 | Name | Description
Public Constructor | ChartRequestHandler Constructor |
Top

Public Properties

 | Name | Description
Public Property | IsReusable |
Top

Public Methods

 | Name | Description
Public Method | ProcessRequest |
Top

See Also

Reference

ChartRequestHandler Class
ISNet.WebUI.WebGrid.Chart Namespace


ChartRequestHandler Constructor

[image]
Intersoft WebGrid Documentation
ChartRequestHandler Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartRequestHandler Class : ChartRequestHandler Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New ChartRequestHandler()
C#
public ChartRequestHandler()
Delphi
public ChartRequestHandler();
JScript
public function ChartRequestHandler();
Managed Extensions for C++
public: ChartRequestHandler();
C++/CLI
public:
ChartRequestHandler();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartRequestHandler Class
ChartRequestHandler Members


ChartRequestHandler Class Methods

[image]
Intersoft WebGrid Documentation
ChartRequestHandler Class Methods
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartRequestHandler Class

Glossary Item Box

For a list of all members of this type, see ChartRequestHandler members.

Public Methods

 | Name | Description
Public Method | ProcessRequest |
Top

See Also

Reference

ChartRequestHandler Class
ISNet.WebUI.WebGrid.Chart Namespace


ProcessRequest Method

[image]
Intersoft WebGrid Documentation
ProcessRequest Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartRequestHandler Class : ProcessRequest Method

context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub ProcessRequest( _
   ByVal context As System.Web.HttpContext _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartRequestHandler
Dim context As System.Web.HttpContext

instance.ProcessRequest(context)
C#
public void ProcessRequest(
   System.Web.HttpContext context
)
Delphi
public procedure ProcessRequest(
    context: System.Web.HttpContext
);
JScript
public function ProcessRequest(
   context : System.Web.HttpContext
);
Managed Extensions for C++
public: void ProcessRequest(
   System.Web.HttpContext* context
)
C++/CLI
public:
void ProcessRequest(
   System.Web.HttpContext^ context
)

Parameters

context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartRequestHandler Class
ChartRequestHandler Members


ChartRequestHandler Class Properties

[image]
Intersoft WebGrid Documentation
ChartRequestHandler Class Properties
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartRequestHandler Class

Glossary Item Box

For a list of all members of this type, see ChartRequestHandler members.

Public Properties

 | Name | Description
Public Property | IsReusable |
Top

See Also

Reference

ChartRequestHandler Class
ISNet.WebUI.WebGrid.Chart Namespace


IsReusable Property

[image]
Intersoft WebGrid Documentation
IsReusable Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartRequestHandler Class : IsReusable Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsReusable As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As ChartRequestHandler
Dim value As System.Boolean

value = instance.IsReusable
C#
public System.bool IsReusable {get;}
Delphi
public read-only property IsReusable: System.Boolean;
JScript
public function get IsReusable : System.boolean
Managed Extensions for C++
public: __property System.bool get_IsReusable();
C++/CLI
public:
property System.bool IsReusable {
   System.bool get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartRequestHandler Class
ChartRequestHandler Members


ChartScaleGridStyle Class

[image]
Intersoft WebGrid Documentation
ChartScaleGridStyle Class
Members See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartScaleGridStyle Class

Glossary Item Box

Object Model

ChartScaleGridStyle Class

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.SerializableAttribute()>
Public Class ChartScaleGridStyle
   Inherits ISNet.WebUI.WebUIBaseClass
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Visual Basic (Usage) Copy Code
Dim instance As ChartScaleGridStyle
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public class ChartScaleGridStyle : ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Delphi
public class ChartScaleGridStyle = class(ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize)
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.SerializableAttribute()
public class ChartScaleGridStyle extends ISNet.WebUI.WebUIBaseClass implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public __gc class ChartScaleGridStyle : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public ref class ChartScaleGridStyle : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.WebGrid.Chart.ChartScaleGridStyle

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartScaleGridStyle Members
ISNet.WebUI.WebGrid.Chart Namespace


ChartScaleGridStyle Class Members

[image]
Intersoft WebGrid Documentation
ChartScaleGridStyle Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartScaleGridStyle Class

Glossary Item Box

The following tables list the members exposed by ChartScaleGridStyle.

Public Constructors

 | Name | Description
Public Constructor | ChartScaleGridStyle Constructor |
Top

Public Properties

 | Name | Description
Public Property | LineStyle |
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

ChartScaleGridStyle Class
ISNet.WebUI.WebGrid.Chart Namespace


ChartScaleGridStyle Constructor

[image]
Intersoft WebGrid Documentation
ChartScaleGridStyle Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartScaleGridStyle Class : ChartScaleGridStyle Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New ChartScaleGridStyle()
C#
public ChartScaleGridStyle()
Delphi
public ChartScaleGridStyle();
JScript
public function ChartScaleGridStyle();
Managed Extensions for C++
public: ChartScaleGridStyle();
C++/CLI
public:
ChartScaleGridStyle();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartScaleGridStyle Class
ChartScaleGridStyle Members


Clone Method

[image]
Intersoft WebGrid Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartScaleGridStyle Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As System.Object
Visual Basic (Usage) Copy Code
Dim instance As ChartScaleGridStyle
Dim value As System.Object

value = instance.Clone()
C#
public virtual System.object Clone()
Delphi
public function Clone(): System.TObject; virtual;
JScript
public function Clone() : System.Object;
Managed Extensions for C++
public: virtual System.Object* Clone();
C++/CLI
public:
virtual System.Object^ Clone();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartScaleGridStyle Class
ChartScaleGridStyle Members


CopyFrom Method

[image]
Intersoft WebGrid Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartScaleGridStyle Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartScaleGridStyle Class
ChartScaleGridStyle Members


CopyFrom(Object) Method

[image]
Intersoft WebGrid Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartScaleGridStyle Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartScaleGridStyle
Dim objSource As System.Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   System.object objSource
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartScaleGridStyle Class
ChartScaleGridStyle Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebGrid Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartScaleGridStyle Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object, _
   ByVal cloneSourceValue As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartScaleGridStyle
Dim objSource As System.Object
Dim cloneSourceValue As System.Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   System.object objSource,
   System.bool cloneSourceValue
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject;
    cloneSourceValue: System.Boolean
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object,
   cloneSourceValue : System.boolean
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource,
   System.bool cloneSourceValue
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource,
   System.bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartScaleGridStyle Class
ChartScaleGridStyle Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebGrid Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartScaleGridStyle Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartScaleGridStyle
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure DeSerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function DeSerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void DeSerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void DeSerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartScaleGridStyle Class
ChartScaleGridStyle Members


GetHashCode Method

[image]
Intersoft WebGrid Documentation
GetHashCode Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartScaleGridStyle Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As ChartScaleGridStyle
Dim value As System.Integer

value = instance.GetHashCode()
C#
public virtual System.int GetHashCode()
Delphi
public function GetHashCode(): System.Integer; virtual;
JScript
public function GetHashCode() : System.int;
Managed Extensions for C++
public: virtual System.int GetHashCode();
C++/CLI
public:
virtual System.int GetHashCode();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartScaleGridStyle Class
ChartScaleGridStyle Members


ChartScaleGridStyle Class Methods

[image]
Intersoft WebGrid Documentation
ChartScaleGridStyle Class Methods
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartScaleGridStyle Class

Glossary Item Box

For a list of all members of this type, see ChartScaleGridStyle members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

ChartScaleGridStyle Class
ISNet.WebUI.WebGrid.Chart Namespace


GetObjectData Method

[image]
Intersoft WebGrid Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartScaleGridStyle Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=False,
   UnmanagedCode=False,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=True,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Action=SecurityAction.Demand,
   Unrestricted=False)>
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartScaleGridStyle
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure GetObjectData(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
); override;
JScript
System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=,
   UnmanagedCode=,
   SkipVerification=,
   Execution=,
   ControlThread=,
   ControlEvidence=,
   ControlPolicy=,
   SerializationFormatter=,
   ControlDomainPolicy=,
   ControlPrincipal=,
   ControlAppDomain=,
   RemotingConfiguration=,
   Infrastructure=,
   BindingRedirects=,
   Action=SecurityAction.Demand,
   Unrestricted=)
public override function GetObjectData(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public: void GetObjectData(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
) override
C++/CLI
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public:
void GetObjectData(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
) override

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartScaleGridStyle Class
ChartScaleGridStyle Members


IsEmpty Method

[image]
Intersoft WebGrid Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartScaleGridStyle Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As ChartScaleGridStyle
Dim value As System.Boolean

value = instance.IsEmpty()
C#
public virtual System.bool IsEmpty()
Delphi
public function IsEmpty(): System.Boolean; virtual;
JScript
public function IsEmpty() : System.boolean;
Managed Extensions for C++
public: virtual System.bool IsEmpty();
C++/CLI
public:
virtual System.bool IsEmpty();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartScaleGridStyle Class
ChartScaleGridStyle Members


Reset Method

[image]
Intersoft WebGrid Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartScaleGridStyle Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As ChartScaleGridStyle

instance.Reset()
C#
public virtual void Reset()
Delphi
public procedure Reset(); virtual;
JScript
public function Reset();
Managed Extensions for C++
public: virtual void Reset();
C++/CLI
public:
virtual void Reset();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartScaleGridStyle Class
ChartScaleGridStyle Members


SerializeObjectData Method

[image]
Intersoft WebGrid Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartScaleGridStyle Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartScaleGridStyle
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure SerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function SerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void SerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void SerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartScaleGridStyle Class
ChartScaleGridStyle Members


ToString Method

[image]
Intersoft WebGrid Documentation
ToString Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartScaleGridStyle Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As System.String
Visual Basic (Usage) Copy Code
Dim instance As ChartScaleGridStyle
Dim value As System.String

value = instance.ToString()
C#
public virtual System.string ToString()
Delphi
public function ToString(): System.String; virtual;
JScript
public function ToString() : System.String;
Managed Extensions for C++
public: virtual System.string* ToString();
C++/CLI
public:
virtual System.String^ ToString();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartScaleGridStyle Class
ChartScaleGridStyle Members


ChartScaleGridStyle Class Properties

[image]
Intersoft WebGrid Documentation
ChartScaleGridStyle Class Properties
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartScaleGridStyle Class

Glossary Item Box

For a list of all members of this type, see ChartScaleGridStyle members.

Public Properties

 | Name | Description
Public Property | LineStyle |
Top

See Also

Reference

ChartScaleGridStyle Class
ISNet.WebUI.WebGrid.Chart Namespace


ChartScaleGridStyle Constructor

[image]
Intersoft WebGrid Documentation
ChartScaleGridStyle Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartScaleGridStyle Class : ChartScaleGridStyle Constructor

Glossary Item Box

Overload List

Overload | Description
ChartScaleGridStyle Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartScaleGridStyle Class
ChartScaleGridStyle Members


LineStyle Property

[image]
Intersoft WebGrid Documentation
LineStyle Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartScaleGridStyle Class : LineStyle Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("General")>
<System.ComponentModel.DescriptionAttribute("The stroke style of the grid lines")>
<ISNet.Serialization.BinarySerializableAttribute("setLineStyle")>
Public ReadOnly Property LineStyle As ChartStrokeStyle
Visual Basic (Usage) Copy Code
Dim instance As ChartScaleGridStyle
Dim value As ChartStrokeStyle

value = instance.LineStyle
C#
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DescriptionAttribute("The stroke style of the grid lines")]
[ISNet.Serialization.BinarySerializableAttribute("setLineStyle")]
public ChartStrokeStyle LineStyle {get;}
Delphi
public read-only property LineStyle: ChartStrokeStyle;
JScript
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
System.ComponentModel.NotifyParentPropertyAttribute()
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("General")
System.ComponentModel.DescriptionAttribute("The stroke style of the grid lines")
ISNet.Serialization.BinarySerializableAttribute("setLineStyle")
public function get LineStyle : ChartStrokeStyle
Managed Extensions for C++
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DescriptionAttribute("The stroke style of the grid lines")]
[ISNet.Serialization.BinarySerializableAttribute("setLineStyle")]
public: __property ChartStrokeStyle* get_LineStyle();
C++/CLI
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DescriptionAttribute("The stroke style of the grid lines")]
[ISNet.Serialization.BinarySerializableAttribute("setLineStyle")]
public:
property ChartStrokeStyle^ LineStyle {
   ChartStrokeStyle^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartScaleGridStyle Class
ChartScaleGridStyle Members


ChartScaleLabelAngleValue Class

[image]
Intersoft WebGrid Documentation
ChartScaleLabelAngleValue Class
Members See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartScaleLabelAngleValue Class

Glossary Item Box

Object Model

ChartScaleLabelAngleValue Class

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.SerializableAttribute()>
Public Class ChartScaleLabelAngleValue
   Inherits ISNet.WebUI.WebUIBaseClass
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Visual Basic (Usage) Copy Code
Dim instance As ChartScaleLabelAngleValue
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public class ChartScaleLabelAngleValue : ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Delphi
public class ChartScaleLabelAngleValue = class(ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize)
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.SerializableAttribute()
public class ChartScaleLabelAngleValue extends ISNet.WebUI.WebUIBaseClass implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public __gc class ChartScaleLabelAngleValue : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public ref class ChartScaleLabelAngleValue : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.WebGrid.Chart.ChartScaleLabelAngleValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartScaleLabelAngleValue Members
ISNet.WebUI.WebGrid.Chart Namespace


ChartScaleLabelAngleValue Class Members

[image]
Intersoft WebGrid Documentation
ChartScaleLabelAngleValue Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartScaleLabelAngleValue Class

Glossary Item Box

The following tables list the members exposed by ChartScaleLabelAngleValue.

Public Constructors

 | Name | Description
Public Constructor | ChartScaleLabelAngleValue Constructor |
Top

Public Properties

 | Name | Description
Public Property | CustomAngle |
Public Property | LabelAngleMode |
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

ChartScaleLabelAngleValue Class
ISNet.WebUI.WebGrid.Chart Namespace


ChartScaleLabelAngleValue Constructor

[image]
Intersoft WebGrid Documentation
ChartScaleLabelAngleValue Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartScaleLabelAngleValue Class : ChartScaleLabelAngleValue Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New ChartScaleLabelAngleValue()
C#
public ChartScaleLabelAngleValue()
Delphi
public ChartScaleLabelAngleValue();
JScript
public function ChartScaleLabelAngleValue();
Managed Extensions for C++
public: ChartScaleLabelAngleValue();
C++/CLI
public:
ChartScaleLabelAngleValue();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartScaleLabelAngleValue Class
ChartScaleLabelAngleValue Members


Clone Method

[image]
Intersoft WebGrid Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartScaleLabelAngleValue Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As System.Object
Visual Basic (Usage) Copy Code
Dim instance As ChartScaleLabelAngleValue
Dim value As System.Object

value = instance.Clone()
C#
public virtual System.object Clone()
Delphi
public function Clone(): System.TObject; virtual;
JScript
public function Clone() : System.Object;
Managed Extensions for C++
public: virtual System.Object* Clone();
C++/CLI
public:
virtual System.Object^ Clone();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartScaleLabelAngleValue Class
ChartScaleLabelAngleValue Members


CopyFrom Method

[image]
Intersoft WebGrid Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartScaleLabelAngleValue Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartScaleLabelAngleValue Class
ChartScaleLabelAngleValue Members


CopyFrom(Object) Method

[image]
Intersoft WebGrid Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartScaleLabelAngleValue Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartScaleLabelAngleValue
Dim objSource As System.Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   System.object objSource
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartScaleLabelAngleValue Class
ChartScaleLabelAngleValue Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebGrid Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartScaleLabelAngleValue Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object, _
   ByVal cloneSourceValue As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartScaleLabelAngleValue
Dim objSource As System.Object
Dim cloneSourceValue As System.Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   System.object objSource,
   System.bool cloneSourceValue
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject;
    cloneSourceValue: System.Boolean
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object,
   cloneSourceValue : System.boolean
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource,
   System.bool cloneSourceValue
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource,
   System.bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartScaleLabelAngleValue Class
ChartScaleLabelAngleValue Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebGrid Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartScaleLabelAngleValue Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartScaleLabelAngleValue
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure DeSerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function DeSerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void DeSerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void DeSerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartScaleLabelAngleValue Class
ChartScaleLabelAngleValue Members


GetHashCode Method

[image]
Intersoft WebGrid Documentation
GetHashCode Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartScaleLabelAngleValue Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As ChartScaleLabelAngleValue
Dim value As System.Integer

value = instance.GetHashCode()
C#
public virtual System.int GetHashCode()
Delphi
public function GetHashCode(): System.Integer; virtual;
JScript
public function GetHashCode() : System.int;
Managed Extensions for C++
public: virtual System.int GetHashCode();
C++/CLI
public:
virtual System.int GetHashCode();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartScaleLabelAngleValue Class
ChartScaleLabelAngleValue Members


ChartScaleLabelAngleValue Class Methods

[image]
Intersoft WebGrid Documentation
ChartScaleLabelAngleValue Class Methods
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartScaleLabelAngleValue Class

Glossary Item Box

For a list of all members of this type, see ChartScaleLabelAngleValue members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

ChartScaleLabelAngleValue Class
ISNet.WebUI.WebGrid.Chart Namespace


GetObjectData Method

[image]
Intersoft WebGrid Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartScaleLabelAngleValue Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=False,
   UnmanagedCode=False,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=True,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Action=SecurityAction.Demand,
   Unrestricted=False)>
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartScaleLabelAngleValue
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure GetObjectData(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
); override;
JScript
System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=,
   UnmanagedCode=,
   SkipVerification=,
   Execution=,
   ControlThread=,
   ControlEvidence=,
   ControlPolicy=,
   SerializationFormatter=,
   ControlDomainPolicy=,
   ControlPrincipal=,
   ControlAppDomain=,
   RemotingConfiguration=,
   Infrastructure=,
   BindingRedirects=,
   Action=SecurityAction.Demand,
   Unrestricted=)
public override function GetObjectData(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public: void GetObjectData(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
) override
C++/CLI
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public:
void GetObjectData(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
) override

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartScaleLabelAngleValue Class
ChartScaleLabelAngleValue Members


IsEmpty Method

[image]
Intersoft WebGrid Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartScaleLabelAngleValue Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As ChartScaleLabelAngleValue
Dim value As System.Boolean

value = instance.IsEmpty()
C#
public virtual System.bool IsEmpty()
Delphi
public function IsEmpty(): System.Boolean; virtual;
JScript
public function IsEmpty() : System.boolean;
Managed Extensions for C++
public: virtual System.bool IsEmpty();
C++/CLI
public:
virtual System.bool IsEmpty();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartScaleLabelAngleValue Class
ChartScaleLabelAngleValue Members


Reset Method

[image]
Intersoft WebGrid Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartScaleLabelAngleValue Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As ChartScaleLabelAngleValue

instance.Reset()
C#
public virtual void Reset()
Delphi
public procedure Reset(); virtual;
JScript
public function Reset();
Managed Extensions for C++
public: virtual void Reset();
C++/CLI
public:
virtual void Reset();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartScaleLabelAngleValue Class
ChartScaleLabelAngleValue Members


SerializeObjectData Method

[image]
Intersoft WebGrid Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartScaleLabelAngleValue Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartScaleLabelAngleValue
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure SerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function SerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void SerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void SerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartScaleLabelAngleValue Class
ChartScaleLabelAngleValue Members


ToString Method

[image]
Intersoft WebGrid Documentation
ToString Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartScaleLabelAngleValue Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As System.String
Visual Basic (Usage) Copy Code
Dim instance As ChartScaleLabelAngleValue
Dim value As System.String

value = instance.ToString()
C#
public virtual System.string ToString()
Delphi
public function ToString(): System.String; virtual;
JScript
public function ToString() : System.String;
Managed Extensions for C++
public: virtual System.string* ToString();
C++/CLI
public:
virtual System.String^ ToString();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartScaleLabelAngleValue Class
ChartScaleLabelAngleValue Members


ChartScaleLabelAngleValue Class Properties

[image]
Intersoft WebGrid Documentation
ChartScaleLabelAngleValue Class Properties
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartScaleLabelAngleValue Class

Glossary Item Box

For a list of all members of this type, see ChartScaleLabelAngleValue members.

Public Properties

 | Name | Description
Public Property | CustomAngle |
Public Property | LabelAngleMode |
Top

See Also

Reference

ChartScaleLabelAngleValue Class
ISNet.WebUI.WebGrid.Chart Namespace


ChartScaleLabelAngleValue Constructor

[image]
Intersoft WebGrid Documentation
ChartScaleLabelAngleValue Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartScaleLabelAngleValue Class : ChartScaleLabelAngleValue Constructor

Glossary Item Box

Overload List

Overload | Description
ChartScaleLabelAngleValue Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartScaleLabelAngleValue Class
ChartScaleLabelAngleValue Members


CustomAngle Property

[image]
Intersoft WebGrid Documentation
CustomAngle Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartScaleLabelAngleValue Class : CustomAngle Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("General")>
<System.ComponentModel.DescriptionAttribute("Custom angle in degress.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
Public Property CustomAngle As System.Single
Visual Basic (Usage) Copy Code
Dim instance As ChartScaleLabelAngleValue
Dim value As System.Single

instance.CustomAngle = value

value = instance.CustomAngle
C#
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DescriptionAttribute("Custom angle in degress.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public System.float CustomAngle {get; set;}
Delphi
public read-write property CustomAngle: System.Single;
JScript
System.ComponentModel.CategoryAttribute("General")
System.ComponentModel.DescriptionAttribute("Custom angle in degress.")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
public function get,set CustomAngle : System.float
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DescriptionAttribute("Custom angle in degress.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.float get_CustomAngle();
public: __property void set_CustomAngle(
   System.float value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DescriptionAttribute("Custom angle in degress.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.float CustomAngle {
   System.float get();
   void set (    System.float value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartScaleLabelAngleValue Class
ChartScaleLabelAngleValue Members


LabelAngleMode Property

[image]
Intersoft WebGrid Documentation
LabelAngleMode Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartScaleLabelAngleValue Class : LabelAngleMode Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Angle mode of the scale label.")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("General")>
Public Property LabelAngleMode As ScaleLabelAngleMode
Visual Basic (Usage) Copy Code
Dim instance As ChartScaleLabelAngleValue
Dim value As ScaleLabelAngleMode

instance.LabelAngleMode = value

value = instance.LabelAngleMode
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Angle mode of the scale label.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("General")]
public ScaleLabelAngleMode LabelAngleMode {get; set;}
Delphi
public read-write property LabelAngleMode: ScaleLabelAngleMode;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DescriptionAttribute("Angle mode of the scale label.")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("General")
public function get,set LabelAngleMode : ScaleLabelAngleMode
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Angle mode of the scale label.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("General")]
public: __property ScaleLabelAngleMode get_LabelAngleMode();
public: __property void set_LabelAngleMode(
   ScaleLabelAngleMode value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Angle mode of the scale label.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("General")]
public:
property ScaleLabelAngleMode LabelAngleMode {
   ScaleLabelAngleMode get();
   void set (    ScaleLabelAngleMode value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartScaleLabelAngleValue Class
ChartScaleLabelAngleValue Members


ChartScaleLabelStyle Class

[image]
Intersoft WebGrid Documentation
ChartScaleLabelStyle Class
Members See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartScaleLabelStyle Class

Glossary Item Box

Object Model

ChartScaleLabelStyle Class

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.SerializableAttribute()>
Public Class ChartScaleLabelStyle
   Inherits ISNet.WebUI.WebUIBaseClass
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Visual Basic (Usage) Copy Code
Dim instance As ChartScaleLabelStyle
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public class ChartScaleLabelStyle : ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Delphi
public class ChartScaleLabelStyle = class(ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize)
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.SerializableAttribute()
public class ChartScaleLabelStyle extends ISNet.WebUI.WebUIBaseClass implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public __gc class ChartScaleLabelStyle : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public ref class ChartScaleLabelStyle : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.WebGrid.Chart.ChartScaleLabelStyle

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartScaleLabelStyle Members
ISNet.WebUI.WebGrid.Chart Namespace


ChartScaleLabelStyle Class Members

[image]
Intersoft WebGrid Documentation
ChartScaleLabelStyle Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartScaleLabelStyle Class

Glossary Item Box

The following tables list the members exposed by ChartScaleLabelStyle.

Public Constructors

 | Name | Description
Public Constructor | ChartScaleLabelStyle Constructor |
Top

Public Properties

 | Name | Description
Public Property | Angle |
Public Property | ContentAlignment |
Public Property | Offset |
Public Property | RangeAlignment |
Public Property | TextStyle |
Public Property | ValueOffset |
Public Property | ValueScale |
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

ChartScaleLabelStyle Class
ISNet.WebUI.WebGrid.Chart Namespace


ChartScaleLabelStyle Constructor

[image]
Intersoft WebGrid Documentation
ChartScaleLabelStyle Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartScaleLabelStyle Class : ChartScaleLabelStyle Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New ChartScaleLabelStyle()
C#
public ChartScaleLabelStyle()
Delphi
public ChartScaleLabelStyle();
JScript
public function ChartScaleLabelStyle();
Managed Extensions for C++
public: ChartScaleLabelStyle();
C++/CLI
public:
ChartScaleLabelStyle();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartScaleLabelStyle Class
ChartScaleLabelStyle Members


Clone Method

[image]
Intersoft WebGrid Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartScaleLabelStyle Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As System.Object
Visual Basic (Usage) Copy Code
Dim instance As ChartScaleLabelStyle
Dim value As System.Object

value = instance.Clone()
C#
public virtual System.object Clone()
Delphi
public function Clone(): System.TObject; virtual;
JScript
public function Clone() : System.Object;
Managed Extensions for C++
public: virtual System.Object* Clone();
C++/CLI
public:
virtual System.Object^ Clone();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartScaleLabelStyle Class
ChartScaleLabelStyle Members


CopyFrom Method

[image]
Intersoft WebGrid Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartScaleLabelStyle Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartScaleLabelStyle Class
ChartScaleLabelStyle Members


CopyFrom(Object) Method

[image]
Intersoft WebGrid Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartScaleLabelStyle Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartScaleLabelStyle
Dim objSource As System.Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   System.object objSource
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartScaleLabelStyle Class
ChartScaleLabelStyle Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebGrid Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartScaleLabelStyle Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object, _
   ByVal cloneSourceValue As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartScaleLabelStyle
Dim objSource As System.Object
Dim cloneSourceValue As System.Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   System.object objSource,
   System.bool cloneSourceValue
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject;
    cloneSourceValue: System.Boolean
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object,
   cloneSourceValue : System.boolean
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource,
   System.bool cloneSourceValue
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource,
   System.bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartScaleLabelStyle Class
ChartScaleLabelStyle Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebGrid Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartScaleLabelStyle Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartScaleLabelStyle
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure DeSerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function DeSerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void DeSerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void DeSerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartScaleLabelStyle Class
ChartScaleLabelStyle Members


GetHashCode Method

[image]
Intersoft WebGrid Documentation
GetHashCode Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartScaleLabelStyle Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As ChartScaleLabelStyle
Dim value As System.Integer

value = instance.GetHashCode()
C#
public virtual System.int GetHashCode()
Delphi
public function GetHashCode(): System.Integer; virtual;
JScript
public function GetHashCode() : System.int;
Managed Extensions for C++
public: virtual System.int GetHashCode();
C++/CLI
public:
virtual System.int GetHashCode();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartScaleLabelStyle Class
ChartScaleLabelStyle Members


ChartScaleLabelStyle Class Methods

[image]
Intersoft WebGrid Documentation
ChartScaleLabelStyle Class Methods
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartScaleLabelStyle Class

Glossary Item Box

For a list of all members of this type, see ChartScaleLabelStyle members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

ChartScaleLabelStyle Class
ISNet.WebUI.WebGrid.Chart Namespace


GetObjectData Method

[image]
Intersoft WebGrid Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartScaleLabelStyle Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=False,
   UnmanagedCode=False,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=True,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Action=SecurityAction.Demand,
   Unrestricted=False)>
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartScaleLabelStyle
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure GetObjectData(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
); override;
JScript
System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=,
   UnmanagedCode=,
   SkipVerification=,
   Execution=,
   ControlThread=,
   ControlEvidence=,
   ControlPolicy=,
   SerializationFormatter=,
   ControlDomainPolicy=,
   ControlPrincipal=,
   ControlAppDomain=,
   RemotingConfiguration=,
   Infrastructure=,
   BindingRedirects=,
   Action=SecurityAction.Demand,
   Unrestricted=)
public override function GetObjectData(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public: void GetObjectData(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
) override
C++/CLI
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public:
void GetObjectData(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
) override

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartScaleLabelStyle Class
ChartScaleLabelStyle Members


IsEmpty Method

[image]
Intersoft WebGrid Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartScaleLabelStyle Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As ChartScaleLabelStyle
Dim value As System.Boolean

value = instance.IsEmpty()
C#
public virtual System.bool IsEmpty()
Delphi
public function IsEmpty(): System.Boolean; virtual;
JScript
public function IsEmpty() : System.boolean;
Managed Extensions for C++
public: virtual System.bool IsEmpty();
C++/CLI
public:
virtual System.bool IsEmpty();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartScaleLabelStyle Class
ChartScaleLabelStyle Members


Reset Method

[image]
Intersoft WebGrid Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartScaleLabelStyle Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As ChartScaleLabelStyle

instance.Reset()
C#
public virtual void Reset()
Delphi
public procedure Reset(); virtual;
JScript
public function Reset();
Managed Extensions for C++
public: virtual void Reset();
C++/CLI
public:
virtual void Reset();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartScaleLabelStyle Class
ChartScaleLabelStyle Members


SerializeObjectData Method

[image]
Intersoft WebGrid Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartScaleLabelStyle Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartScaleLabelStyle
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure SerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function SerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void SerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void SerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartScaleLabelStyle Class
ChartScaleLabelStyle Members


ToString Method

[image]
Intersoft WebGrid Documentation
ToString Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartScaleLabelStyle Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As System.String
Visual Basic (Usage) Copy Code
Dim instance As ChartScaleLabelStyle
Dim value As System.String

value = instance.ToString()
C#
public virtual System.string ToString()
Delphi
public function ToString(): System.String; virtual;
JScript
public function ToString() : System.String;
Managed Extensions for C++
public: virtual System.string* ToString();
C++/CLI
public:
virtual System.String^ ToString();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartScaleLabelStyle Class
ChartScaleLabelStyle Members


ChartScaleLabelStyle Class Properties

[image]
Intersoft WebGrid Documentation
ChartScaleLabelStyle Class Properties
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartScaleLabelStyle Class

Glossary Item Box

For a list of all members of this type, see ChartScaleLabelStyle members.

Public Properties

 | Name | Description
Public Property | Angle |
Public Property | ContentAlignment |
Public Property | Offset |
Public Property | RangeAlignment |
Public Property | TextStyle |
Public Property | ValueOffset |
Public Property | ValueScale |
Top

See Also

Reference

ChartScaleLabelStyle Class
ISNet.WebUI.WebGrid.Chart Namespace


ChartScaleLabelStyle Constructor

[image]
Intersoft WebGrid Documentation
ChartScaleLabelStyle Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartScaleLabelStyle Class : ChartScaleLabelStyle Constructor

Glossary Item Box

Overload List

Overload | Description
ChartScaleLabelStyle Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartScaleLabelStyle Class
ChartScaleLabelStyle Members


Angle Property

[image]
Intersoft WebGrid Documentation
Angle Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartScaleLabelStyle Class : Angle Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Gets or sets the angle of the scale value labels")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute("setAngle")>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<System.ComponentModel.CategoryAttribute("Texts")>
Public ReadOnly Property Angle As ChartScaleLabelAngleValue
Visual Basic (Usage) Copy Code
Dim instance As ChartScaleLabelStyle
Dim value As ChartScaleLabelAngleValue

value = instance.Angle
C#
[System.ComponentModel.DescriptionAttribute("Gets or sets the angle of the scale value labels")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute("setAngle")]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.CategoryAttribute("Texts")]
public ChartScaleLabelAngleValue Angle {get;}
Delphi
public read-only property Angle: ChartScaleLabelAngleValue;
JScript
System.ComponentModel.DescriptionAttribute("Gets or sets the angle of the scale value labels")
System.ComponentModel.NotifyParentPropertyAttribute()
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute("setAngle")
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
System.ComponentModel.CategoryAttribute("Texts")
public function get Angle : ChartScaleLabelAngleValue
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Gets or sets the angle of the scale value labels")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute("setAngle")]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.CategoryAttribute("Texts")]
public: __property ChartScaleLabelAngleValue* get_Angle();
C++/CLI
[System.ComponentModel.DescriptionAttribute("Gets or sets the angle of the scale value labels")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute("setAngle")]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.CategoryAttribute("Texts")]
public:
property ChartScaleLabelAngleValue^ Angle {
   ChartScaleLabelAngleValue^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartScaleLabelStyle Class
ChartScaleLabelStyle Members


ContentAlignment Property

[image]
Intersoft WebGrid Documentation
ContentAlignment Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartScaleLabelStyle Class : ContentAlignment Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Gets or sets the alignment of value labels relative to their origin point on the scale")>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Texts")>
Public Property ContentAlignment As ContentAlignment
Visual Basic (Usage) Copy Code
Dim instance As ChartScaleLabelStyle
Dim value As ContentAlignment

instance.ContentAlignment = value

value = instance.ContentAlignment
C#
[System.ComponentModel.DescriptionAttribute("Gets or sets the alignment of value labels relative to their origin point on the scale")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Texts")]
public ContentAlignment ContentAlignment {get; set;}
Delphi
public read-write property ContentAlignment: ContentAlignment;
JScript
System.ComponentModel.DescriptionAttribute("Gets or sets the alignment of value labels relative to their origin point on the scale")
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Texts")
public function get,set ContentAlignment : ContentAlignment
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Gets or sets the alignment of value labels relative to their origin point on the scale")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Texts")]
public: __property ContentAlignment get_ContentAlignment();
public: __property void set_ContentAlignment(
   ContentAlignment value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Gets or sets the alignment of value labels relative to their origin point on the scale")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Texts")]
public:
property ContentAlignment ContentAlignment {
   ContentAlignment get();
   void set (    ContentAlignment value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartScaleLabelStyle Class
ChartScaleLabelStyle Members


Offset Property

[image]
Intersoft WebGrid Documentation
Offset Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartScaleLabelStyle Class : Offset Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies the offset of the scale labels from the tickmarks")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Texts")>
Public Property Offset As System.Nullable(Of Single)
Visual Basic (Usage) Copy Code
Dim instance As ChartScaleLabelStyle
Dim value As System.Nullable(Of Single)

instance.Offset = value

value = instance.Offset
C#
[System.ComponentModel.DescriptionAttribute("Specifies the offset of the scale labels from the tickmarks")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Texts")]
public System.Nullable<float> Offset {get; set;}
Delphi
public read-write property Offset: System.Nullable;
JScript
System.ComponentModel.DescriptionAttribute("Specifies the offset of the scale labels from the tickmarks")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Texts")
public function get,set Offset : System.Nullable
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies the offset of the scale labels from the tickmarks")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Texts")]
public: __property System.Nullable<float> get_Offset();
public: __property void set_Offset(
   System.Nullable<float> value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies the offset of the scale labels from the tickmarks")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Texts")]
public:
property System.Nullable<float> Offset {
   System.Nullable<float> get();
   void set (    System.Nullable<float> value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartScaleLabelStyle Class
ChartScaleLabelStyle Members


RangeAlignment Property

[image]
Intersoft WebGrid Documentation
RangeAlignment Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartScaleLabelStyle Class : RangeAlignment Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Texts")>
<System.ComponentModel.DescriptionAttribute("Gets or sets the alignment of value labels relative to the to scale range it represents")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
Public Property RangeAlignment As HorizontalAlign
Visual Basic (Usage) Copy Code
Dim instance As ChartScaleLabelStyle
Dim value As HorizontalAlign

instance.RangeAlignment = value

value = instance.RangeAlignment
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Texts")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the alignment of value labels relative to the to scale range it represents")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public HorizontalAlign RangeAlignment {get; set;}
Delphi
public read-write property RangeAlignment: HorizontalAlign;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Texts")
System.ComponentModel.DescriptionAttribute("Gets or sets the alignment of value labels relative to the to scale range it represents")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
public function get,set RangeAlignment : HorizontalAlign
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Texts")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the alignment of value labels relative to the to scale range it represents")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public: __property HorizontalAlign get_RangeAlignment();
public: __property void set_RangeAlignment(
   HorizontalAlign value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Texts")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the alignment of value labels relative to the to scale range it represents")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public:
property HorizontalAlign RangeAlignment {
   HorizontalAlign get();
   void set (    HorizontalAlign value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartScaleLabelStyle Class
ChartScaleLabelStyle Members


TextStyle Property

[image]
Intersoft WebGrid Documentation
TextStyle Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartScaleLabelStyle Class : TextStyle Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Gets or sets the TextStyle object applied to the scale value labels text")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute("setTextStyle")>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<System.ComponentModel.CategoryAttribute("Texts")>
Public ReadOnly Property TextStyle As ChartTextStyle
Visual Basic (Usage) Copy Code
Dim instance As ChartScaleLabelStyle
Dim value As ChartTextStyle

value = instance.TextStyle
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the TextStyle object applied to the scale value labels text")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute("setTextStyle")]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.CategoryAttribute("Texts")]
public ChartTextStyle TextStyle {get;}
Delphi
public read-only property TextStyle: ChartTextStyle;
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the TextStyle object applied to the scale value labels text")
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute("setTextStyle")
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
System.ComponentModel.CategoryAttribute("Texts")
public function get TextStyle : ChartTextStyle
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the TextStyle object applied to the scale value labels text")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute("setTextStyle")]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.CategoryAttribute("Texts")]
public: __property ChartTextStyle* get_TextStyle();
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the TextStyle object applied to the scale value labels text")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute("setTextStyle")]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.CategoryAttribute("Texts")]
public:
property ChartTextStyle^ TextStyle {
   ChartTextStyle^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartScaleLabelStyle Class
ChartScaleLabelStyle Members


ValueOffset Property

[image]
Intersoft WebGrid Documentation
ValueOffset Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartScaleLabelStyle Class : ValueOffset Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Texts")>
<System.ComponentModel.DescriptionAttribute("Value to be added when the label is generated.")>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property ValueOffset As System.Double
Visual Basic (Usage) Copy Code
Dim instance As ChartScaleLabelStyle
Dim value As System.Double

instance.ValueOffset = value

value = instance.ValueOffset
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Texts")]
[System.ComponentModel.DescriptionAttribute("Value to be added when the label is generated.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public System.double ValueOffset {get; set;}
Delphi
public read-write property ValueOffset: System.Double;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Texts")
System.ComponentModel.DescriptionAttribute("Value to be added when the label is generated.")
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get,set ValueOffset : System.double
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Texts")]
[System.ComponentModel.DescriptionAttribute("Value to be added when the label is generated.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.double get_ValueOffset();
public: __property void set_ValueOffset(
   System.double value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Texts")]
[System.ComponentModel.DescriptionAttribute("Value to be added when the label is generated.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.double ValueOffset {
   System.double get();
   void set (    System.double value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartScaleLabelStyle Class
ChartScaleLabelStyle Members


ValueScale Property

[image]
Intersoft WebGrid Documentation
ValueScale Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartScaleLabelStyle Class : ValueScale Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Value to be multiplied to the label value when the label is generated .")>
<System.ComponentModel.CategoryAttribute("Texts")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property ValueScale As System.Double
Visual Basic (Usage) Copy Code
Dim instance As ChartScaleLabelStyle
Dim value As System.Double

instance.ValueScale = value

value = instance.ValueScale
C#
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Value to be multiplied to the label value when the label is generated .")]
[System.ComponentModel.CategoryAttribute("Texts")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.double ValueScale {get; set;}
Delphi
public read-write property ValueScale: System.Double;
JScript
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Value to be multiplied to the label value when the label is generated .")
System.ComponentModel.CategoryAttribute("Texts")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set ValueScale : System.double
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Value to be multiplied to the label value when the label is generated .")]
[System.ComponentModel.CategoryAttribute("Texts")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.double get_ValueScale();
public: __property void set_ValueScale(
   System.double value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Value to be multiplied to the label value when the label is generated .")]
[System.ComponentModel.CategoryAttribute("Texts")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.double ValueScale {
   System.double get();
   void set (    System.double value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartScaleLabelStyle Class
ChartScaleLabelStyle Members


ChartScaleTitleStyle Class

[image]
Intersoft WebGrid Documentation
ChartScaleTitleStyle Class
Members See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartScaleTitleStyle Class

Glossary Item Box

Object Model

ChartScaleTitleStyle Class

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.SerializableAttribute()>
Public Class ChartScaleTitleStyle
   Inherits ISNet.WebUI.WebUIBaseClass
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Visual Basic (Usage) Copy Code
Dim instance As ChartScaleTitleStyle
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public class ChartScaleTitleStyle : ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Delphi
public class ChartScaleTitleStyle = class(ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize)
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.SerializableAttribute()
public class ChartScaleTitleStyle extends ISNet.WebUI.WebUIBaseClass implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public __gc class ChartScaleTitleStyle : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public ref class ChartScaleTitleStyle : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.WebGrid.Chart.ChartScaleTitleStyle

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartScaleTitleStyle Members
ISNet.WebUI.WebGrid.Chart Namespace


ChartScaleTitleStyle Class Members

[image]
Intersoft WebGrid Documentation
ChartScaleTitleStyle Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartScaleTitleStyle Class

Glossary Item Box

The following tables list the members exposed by ChartScaleTitleStyle.

Public Constructors

 | Name | Description
Public Constructor | ChartScaleTitleStyle Constructor |
Top

Public Properties

 | Name | Description
Public Property | Angle |
Public Property | Offset |
Public Property | RulerAlignment |
Public Property | RulerOffset |
Public Property | Text |
Public Property | TextStyle |
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

ChartScaleTitleStyle Class
ISNet.WebUI.WebGrid.Chart Namespace


ChartScaleTitleStyle Constructor

[image]
Intersoft WebGrid Documentation
ChartScaleTitleStyle Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartScaleTitleStyle Class : ChartScaleTitleStyle Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New ChartScaleTitleStyle()
C#
public ChartScaleTitleStyle()
Delphi
public ChartScaleTitleStyle();
JScript
public function ChartScaleTitleStyle();
Managed Extensions for C++
public: ChartScaleTitleStyle();
C++/CLI
public:
ChartScaleTitleStyle();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartScaleTitleStyle Class
ChartScaleTitleStyle Members


Clone Method

[image]
Intersoft WebGrid Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartScaleTitleStyle Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As System.Object
Visual Basic (Usage) Copy Code
Dim instance As ChartScaleTitleStyle
Dim value As System.Object

value = instance.Clone()
C#
public virtual System.object Clone()
Delphi
public function Clone(): System.TObject; virtual;
JScript
public function Clone() : System.Object;
Managed Extensions for C++
public: virtual System.Object* Clone();
C++/CLI
public:
virtual System.Object^ Clone();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartScaleTitleStyle Class
ChartScaleTitleStyle Members


CopyFrom Method

[image]
Intersoft WebGrid Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartScaleTitleStyle Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartScaleTitleStyle Class
ChartScaleTitleStyle Members


CopyFrom(Object) Method

[image]
Intersoft WebGrid Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartScaleTitleStyle Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartScaleTitleStyle
Dim objSource As System.Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   System.object objSource
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartScaleTitleStyle Class
ChartScaleTitleStyle Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebGrid Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartScaleTitleStyle Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object, _
   ByVal cloneSourceValue As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartScaleTitleStyle
Dim objSource As System.Object
Dim cloneSourceValue As System.Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   System.object objSource,
   System.bool cloneSourceValue
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject;
    cloneSourceValue: System.Boolean
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object,
   cloneSourceValue : System.boolean
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource,
   System.bool cloneSourceValue
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource,
   System.bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartScaleTitleStyle Class
ChartScaleTitleStyle Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebGrid Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartScaleTitleStyle Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartScaleTitleStyle
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure DeSerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function DeSerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void DeSerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void DeSerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartScaleTitleStyle Class
ChartScaleTitleStyle Members


GetHashCode Method

[image]
Intersoft WebGrid Documentation
GetHashCode Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartScaleTitleStyle Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As ChartScaleTitleStyle
Dim value As System.Integer

value = instance.GetHashCode()
C#
public virtual System.int GetHashCode()
Delphi
public function GetHashCode(): System.Integer; virtual;
JScript
public function GetHashCode() : System.int;
Managed Extensions for C++
public: virtual System.int GetHashCode();
C++/CLI
public:
virtual System.int GetHashCode();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartScaleTitleStyle Class
ChartScaleTitleStyle Members


ChartScaleTitleStyle Class Methods

[image]
Intersoft WebGrid Documentation
ChartScaleTitleStyle Class Methods
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartScaleTitleStyle Class

Glossary Item Box

For a list of all members of this type, see ChartScaleTitleStyle members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

ChartScaleTitleStyle Class
ISNet.WebUI.WebGrid.Chart Namespace


GetObjectData Method

[image]
Intersoft WebGrid Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartScaleTitleStyle Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=False,
   UnmanagedCode=False,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=True,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Action=SecurityAction.Demand,
   Unrestricted=False)>
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartScaleTitleStyle
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure GetObjectData(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
); override;
JScript
System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=,
   UnmanagedCode=,
   SkipVerification=,
   Execution=,
   ControlThread=,
   ControlEvidence=,
   ControlPolicy=,
   SerializationFormatter=,
   ControlDomainPolicy=,
   ControlPrincipal=,
   ControlAppDomain=,
   RemotingConfiguration=,
   Infrastructure=,
   BindingRedirects=,
   Action=SecurityAction.Demand,
   Unrestricted=)
public override function GetObjectData(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public: void GetObjectData(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
) override
C++/CLI
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public:
void GetObjectData(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
) override

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartScaleTitleStyle Class
ChartScaleTitleStyle Members


IsEmpty Method

[image]
Intersoft WebGrid Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartScaleTitleStyle Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As ChartScaleTitleStyle
Dim value As System.Boolean

value = instance.IsEmpty()
C#
public virtual System.bool IsEmpty()
Delphi
public function IsEmpty(): System.Boolean; virtual;
JScript
public function IsEmpty() : System.boolean;
Managed Extensions for C++
public: virtual System.bool IsEmpty();
C++/CLI
public:
virtual System.bool IsEmpty();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartScaleTitleStyle Class
ChartScaleTitleStyle Members


Reset Method

[image]
Intersoft WebGrid Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartScaleTitleStyle Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As ChartScaleTitleStyle

instance.Reset()
C#
public virtual void Reset()
Delphi
public procedure Reset(); virtual;
JScript
public function Reset();
Managed Extensions for C++
public: virtual void Reset();
C++/CLI
public:
virtual void Reset();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartScaleTitleStyle Class
ChartScaleTitleStyle Members


SerializeObjectData Method

[image]
Intersoft WebGrid Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartScaleTitleStyle Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartScaleTitleStyle
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure SerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function SerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void SerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void SerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartScaleTitleStyle Class
ChartScaleTitleStyle Members


ToString Method

[image]
Intersoft WebGrid Documentation
ToString Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartScaleTitleStyle Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As System.String
Visual Basic (Usage) Copy Code
Dim instance As ChartScaleTitleStyle
Dim value As System.String

value = instance.ToString()
C#
public virtual System.string ToString()
Delphi
public function ToString(): System.String; virtual;
JScript
public function ToString() : System.String;
Managed Extensions for C++
public: virtual System.string* ToString();
C++/CLI
public:
virtual System.String^ ToString();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartScaleTitleStyle Class
ChartScaleTitleStyle Members


ChartScaleTitleStyle Class Properties

[image]
Intersoft WebGrid Documentation
ChartScaleTitleStyle Class Properties
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartScaleTitleStyle Class

Glossary Item Box

For a list of all members of this type, see ChartScaleTitleStyle members.

Public Properties

 | Name | Description
Public Property | Angle |
Public Property | Offset |
Public Property | RulerAlignment |
Public Property | RulerOffset |
Public Property | Text |
Public Property | TextStyle |
Top

See Also

Reference

ChartScaleTitleStyle Class
ISNet.WebUI.WebGrid.Chart Namespace


ChartScaleTitleStyle Constructor

[image]
Intersoft WebGrid Documentation
ChartScaleTitleStyle Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartScaleTitleStyle Class : ChartScaleTitleStyle Constructor

Glossary Item Box

Overload List

Overload | Description
ChartScaleTitleStyle Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartScaleTitleStyle Class
ChartScaleTitleStyle Members


Angle Property

[image]
Intersoft WebGrid Documentation
Angle Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartScaleTitleStyle Class : Angle Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.CategoryAttribute("General")>
<System.ComponentModel.DescriptionAttribute("The angle of the axis title")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute("setAngle")>
Public ReadOnly Property Angle As ChartScaleLabelAngleValue
Visual Basic (Usage) Copy Code
Dim instance As ChartScaleTitleStyle
Dim value As ChartScaleLabelAngleValue

value = instance.Angle
C#
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DescriptionAttribute("The angle of the axis title")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute("setAngle")]
public ChartScaleLabelAngleValue Angle {get;}
Delphi
public read-only property Angle: ChartScaleLabelAngleValue;
JScript
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.CategoryAttribute("General")
System.ComponentModel.DescriptionAttribute("The angle of the axis title")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute("setAngle")
public function get Angle : ChartScaleLabelAngleValue
Managed Extensions for C++
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DescriptionAttribute("The angle of the axis title")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute("setAngle")]
public: __property ChartScaleLabelAngleValue* get_Angle();
C++/CLI
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DescriptionAttribute("The angle of the axis title")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute("setAngle")]
public:
property ChartScaleLabelAngleValue^ Angle {
   ChartScaleLabelAngleValue^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartScaleTitleStyle Class
ChartScaleTitleStyle Members


Offset Property

[image]
Intersoft WebGrid Documentation
Offset Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartScaleTitleStyle Class : Offset Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("The offset of the title from the lables in the scale.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("General")>
Public Property Offset As System.Nullable(Of Single)
Visual Basic (Usage) Copy Code
Dim instance As ChartScaleTitleStyle
Dim value As System.Nullable(Of Single)

instance.Offset = value

value = instance.Offset
C#
[System.ComponentModel.DescriptionAttribute("The offset of the title from the lables in the scale.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("General")]
public System.Nullable<float> Offset {get; set;}
Delphi
public read-write property Offset: System.Nullable;
JScript
System.ComponentModel.DescriptionAttribute("The offset of the title from the lables in the scale.")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("General")
public function get,set Offset : System.Nullable
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("The offset of the title from the lables in the scale.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("General")]
public: __property System.Nullable<float> get_Offset();
public: __property void set_Offset(
   System.Nullable<float> value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("The offset of the title from the lables in the scale.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("General")]
public:
property System.Nullable<float> Offset {
   System.Nullable<float> get();
   void set (    System.Nullable<float> value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartScaleTitleStyle Class
ChartScaleTitleStyle Members


RulerAlignment Property

[image]
Intersoft WebGrid Documentation
RulerAlignment Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartScaleTitleStyle Class : RulerAlignment Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("The alignment of the title relative to the axis ruler. ")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("General")>
Public Property RulerAlignment As HorizontalAlign
Visual Basic (Usage) Copy Code
Dim instance As ChartScaleTitleStyle
Dim value As HorizontalAlign

instance.RulerAlignment = value

value = instance.RulerAlignment
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("The alignment of the title relative to the axis ruler. ")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("General")]
public HorizontalAlign RulerAlignment {get; set;}
Delphi
public read-write property RulerAlignment: HorizontalAlign;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("The alignment of the title relative to the axis ruler. ")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("General")
public function get,set RulerAlignment : HorizontalAlign
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("The alignment of the title relative to the axis ruler. ")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("General")]
public: __property HorizontalAlign get_RulerAlignment();
public: __property void set_RulerAlignment(
   HorizontalAlign value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("The alignment of the title relative to the axis ruler. ")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("General")]
public:
property HorizontalAlign RulerAlignment {
   HorizontalAlign get();
   void set (    HorizontalAlign value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartScaleTitleStyle Class
ChartScaleTitleStyle Members


RulerOffset Property

[image]
Intersoft WebGrid Documentation
RulerOffset Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartScaleTitleStyle Class : RulerOffset Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("The offset of the label from it's anchor point on the axis ruler.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("General")>
Public Property RulerOffset As System.Nullable(Of Single)
Visual Basic (Usage) Copy Code
Dim instance As ChartScaleTitleStyle
Dim value As System.Nullable(Of Single)

instance.RulerOffset = value

value = instance.RulerOffset
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("The offset of the label from it's anchor point on the axis ruler.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
public System.Nullable<float> RulerOffset {get; set;}
Delphi
public read-write property RulerOffset: System.Nullable;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("The offset of the label from it's anchor point on the axis ruler.")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("General")
public function get,set RulerOffset : System.Nullable
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("The offset of the label from it's anchor point on the axis ruler.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
public: __property System.Nullable<float> get_RulerOffset();
public: __property void set_RulerOffset(
   System.Nullable<float> value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("The offset of the label from it's anchor point on the axis ruler.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
public:
property System.Nullable<float> RulerOffset {
   System.Nullable<float> get();
   void set (    System.Nullable<float> value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartScaleTitleStyle Class
ChartScaleTitleStyle Members


Text Property

[image]
Intersoft WebGrid Documentation
Text Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartScaleTitleStyle Class : Text Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("General")>
<System.ComponentModel.DescriptionAttribute("The text of the axis title.")>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property Text As System.String
Visual Basic (Usage) Copy Code
Dim instance As ChartScaleTitleStyle
Dim value As System.String

instance.Text = value

value = instance.Text
C#
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DescriptionAttribute("The text of the axis title.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.string Text {get; set;}
Delphi
public read-write property Text: System.String;
JScript
System.ComponentModel.CategoryAttribute("General")
System.ComponentModel.DescriptionAttribute("The text of the axis title.")
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set Text : System.String
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DescriptionAttribute("The text of the axis title.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.string* get_Text();
public: __property void set_Text(
   System.string* value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DescriptionAttribute("The text of the axis title.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.String^ Text {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartScaleTitleStyle Class
ChartScaleTitleStyle Members


TextStyle Property

[image]
Intersoft WebGrid Documentation
TextStyle Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartScaleTitleStyle Class : TextStyle Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("General")>
<System.ComponentModel.DescriptionAttribute("Controls the axis text style.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<ISNet.Serialization.BinarySerializableAttribute("setTextStyle")>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
Public ReadOnly Property TextStyle As ChartTextStyle
Visual Basic (Usage) Copy Code
Dim instance As ChartScaleTitleStyle
Dim value As ChartTextStyle

value = instance.TextStyle
C#
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DescriptionAttribute("Controls the axis text style.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[ISNet.Serialization.BinarySerializableAttribute("setTextStyle")]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
public ChartTextStyle TextStyle {get;}
Delphi
public read-only property TextStyle: ChartTextStyle;
JScript
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("General")
System.ComponentModel.DescriptionAttribute("Controls the axis text style.")
System.ComponentModel.NotifyParentPropertyAttribute()
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
ISNet.Serialization.BinarySerializableAttribute("setTextStyle")
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
public function get TextStyle : ChartTextStyle
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DescriptionAttribute("Controls the axis text style.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[ISNet.Serialization.BinarySerializableAttribute("setTextStyle")]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
public: __property ChartTextStyle* get_TextStyle();
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DescriptionAttribute("Controls the axis text style.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[ISNet.Serialization.BinarySerializableAttribute("setTextStyle")]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
public:
property ChartTextStyle^ TextStyle {
   ChartTextStyle^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartScaleTitleStyle Class
ChartScaleTitleStyle Members


ChartSeriesAreaSettings Class

[image]
Intersoft WebGrid Documentation
ChartSeriesAreaSettings Class
Members See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartSeriesAreaSettings Class

Glossary Item Box

Object Model

ChartSeriesAreaSettings Class

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.SerializableAttribute()>
Public Class ChartSeriesAreaSettings
   Inherits ISNet.WebUI.WebUIBaseClass
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesAreaSettings
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public class ChartSeriesAreaSettings : ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Delphi
public class ChartSeriesAreaSettings = class(ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize)
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.SerializableAttribute()
public class ChartSeriesAreaSettings extends ISNet.WebUI.WebUIBaseClass implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public __gc class ChartSeriesAreaSettings : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public ref class ChartSeriesAreaSettings : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.WebGrid.Chart.ChartSeriesAreaSettings

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesAreaSettings Members
ISNet.WebUI.WebGrid.Chart Namespace


ChartSeriesAreaSettings Class Members

[image]
Intersoft WebGrid Documentation
ChartSeriesAreaSettings Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartSeriesAreaSettings Class

Glossary Item Box

The following tables list the members exposed by ChartSeriesAreaSettings.

Public Constructors

 | Name | Description
Public Constructor | ChartSeriesAreaSettings Constructor |
Top

Public Properties

 | Name | Description
Public Property | Settings |
Public Property | Type |
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

ChartSeriesAreaSettings Class
ISNet.WebUI.WebGrid.Chart Namespace


ChartSeriesAreaSettings Constructor

[image]
Intersoft WebGrid Documentation
ChartSeriesAreaSettings Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSeriesAreaSettings Class : ChartSeriesAreaSettings Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New ChartSeriesAreaSettings()
C#
public ChartSeriesAreaSettings()
Delphi
public ChartSeriesAreaSettings();
JScript
public function ChartSeriesAreaSettings();
Managed Extensions for C++
public: ChartSeriesAreaSettings();
C++/CLI
public:
ChartSeriesAreaSettings();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesAreaSettings Class
ChartSeriesAreaSettings Members


Clone Method

[image]
Intersoft WebGrid Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSeriesAreaSettings Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As System.Object
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesAreaSettings
Dim value As System.Object

value = instance.Clone()
C#
public virtual System.object Clone()
Delphi
public function Clone(): System.TObject; virtual;
JScript
public function Clone() : System.Object;
Managed Extensions for C++
public: virtual System.Object* Clone();
C++/CLI
public:
virtual System.Object^ Clone();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesAreaSettings Class
ChartSeriesAreaSettings Members


CopyFrom Method

[image]
Intersoft WebGrid Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSeriesAreaSettings Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesAreaSettings Class
ChartSeriesAreaSettings Members


CopyFrom(Object) Method

[image]
Intersoft WebGrid Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSeriesAreaSettings Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesAreaSettings
Dim objSource As System.Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   System.object objSource
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesAreaSettings Class
ChartSeriesAreaSettings Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebGrid Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSeriesAreaSettings Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object, _
   ByVal cloneSourceValue As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesAreaSettings
Dim objSource As System.Object
Dim cloneSourceValue As System.Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   System.object objSource,
   System.bool cloneSourceValue
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject;
    cloneSourceValue: System.Boolean
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object,
   cloneSourceValue : System.boolean
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource,
   System.bool cloneSourceValue
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource,
   System.bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesAreaSettings Class
ChartSeriesAreaSettings Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebGrid Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSeriesAreaSettings Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesAreaSettings
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure DeSerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function DeSerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void DeSerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void DeSerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesAreaSettings Class
ChartSeriesAreaSettings Members


GetHashCode Method

[image]
Intersoft WebGrid Documentation
GetHashCode Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSeriesAreaSettings Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesAreaSettings
Dim value As System.Integer

value = instance.GetHashCode()
C#
public virtual System.int GetHashCode()
Delphi
public function GetHashCode(): System.Integer; virtual;
JScript
public function GetHashCode() : System.int;
Managed Extensions for C++
public: virtual System.int GetHashCode();
C++/CLI
public:
virtual System.int GetHashCode();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesAreaSettings Class
ChartSeriesAreaSettings Members


ChartSeriesAreaSettings Class Methods

[image]
Intersoft WebGrid Documentation
ChartSeriesAreaSettings Class Methods
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartSeriesAreaSettings Class

Glossary Item Box

For a list of all members of this type, see ChartSeriesAreaSettings members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

ChartSeriesAreaSettings Class
ISNet.WebUI.WebGrid.Chart Namespace


GetObjectData Method

[image]
Intersoft WebGrid Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSeriesAreaSettings Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=False,
   UnmanagedCode=False,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=True,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Action=SecurityAction.Demand,
   Unrestricted=False)>
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesAreaSettings
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure GetObjectData(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
); override;
JScript
System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=,
   UnmanagedCode=,
   SkipVerification=,
   Execution=,
   ControlThread=,
   ControlEvidence=,
   ControlPolicy=,
   SerializationFormatter=,
   ControlDomainPolicy=,
   ControlPrincipal=,
   ControlAppDomain=,
   RemotingConfiguration=,
   Infrastructure=,
   BindingRedirects=,
   Action=SecurityAction.Demand,
   Unrestricted=)
public override function GetObjectData(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public: void GetObjectData(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
) override
C++/CLI
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public:
void GetObjectData(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
) override

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesAreaSettings Class
ChartSeriesAreaSettings Members


IsEmpty Method

[image]
Intersoft WebGrid Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSeriesAreaSettings Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesAreaSettings
Dim value As System.Boolean

value = instance.IsEmpty()
C#
public virtual System.bool IsEmpty()
Delphi
public function IsEmpty(): System.Boolean; virtual;
JScript
public function IsEmpty() : System.boolean;
Managed Extensions for C++
public: virtual System.bool IsEmpty();
C++/CLI
public:
virtual System.bool IsEmpty();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesAreaSettings Class
ChartSeriesAreaSettings Members


Reset Method

[image]
Intersoft WebGrid Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSeriesAreaSettings Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesAreaSettings

instance.Reset()
C#
public virtual void Reset()
Delphi
public procedure Reset(); virtual;
JScript
public function Reset();
Managed Extensions for C++
public: virtual void Reset();
C++/CLI
public:
virtual void Reset();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesAreaSettings Class
ChartSeriesAreaSettings Members


SerializeObjectData Method

[image]
Intersoft WebGrid Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSeriesAreaSettings Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesAreaSettings
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure SerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function SerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void SerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void SerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesAreaSettings Class
ChartSeriesAreaSettings Members


ToString Method

[image]
Intersoft WebGrid Documentation
ToString Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSeriesAreaSettings Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As System.String
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesAreaSettings
Dim value As System.String

value = instance.ToString()
C#
public virtual System.string ToString()
Delphi
public function ToString(): System.String; virtual;
JScript
public function ToString() : System.String;
Managed Extensions for C++
public: virtual System.string* ToString();
C++/CLI
public:
virtual System.String^ ToString();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesAreaSettings Class
ChartSeriesAreaSettings Members


ChartSeriesAreaSettings Class Properties

[image]
Intersoft WebGrid Documentation
ChartSeriesAreaSettings Class Properties
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartSeriesAreaSettings Class

Glossary Item Box

For a list of all members of this type, see ChartSeriesAreaSettings members.

Public Properties

 | Name | Description
Public Property | Settings |
Public Property | Type |
Top

See Also

Reference

ChartSeriesAreaSettings Class
ISNet.WebUI.WebGrid.Chart Namespace


ChartSeriesAreaSettings Constructor

[image]
Intersoft WebGrid Documentation
ChartSeriesAreaSettings Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSeriesAreaSettings Class : ChartSeriesAreaSettings Constructor

Glossary Item Box

Overload List

Overload | Description
ChartSeriesAreaSettings Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesAreaSettings Class
ChartSeriesAreaSettings Members


Settings Property

[image]
Intersoft WebGrid Documentation
Settings Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSeriesAreaSettings Class : Settings Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.DescriptionAttribute("Controls the Series Area appearance.")>
<ISNet.Serialization.BinarySerializableAttribute("setSettings")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<System.ComponentModel.CategoryAttribute("General")>
Public ReadOnly Property Settings As SeriesArea
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesAreaSettings
Dim value As SeriesArea

value = instance.Settings
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DescriptionAttribute("Controls the Series Area appearance.")]
[ISNet.Serialization.BinarySerializableAttribute("setSettings")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.CategoryAttribute("General")]
public SeriesArea Settings {get;}
Delphi
public read-only property Settings: SeriesArea;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.DescriptionAttribute("Controls the Series Area appearance.")
ISNet.Serialization.BinarySerializableAttribute("setSettings")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
System.ComponentModel.CategoryAttribute("General")
public function get Settings : SeriesArea
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DescriptionAttribute("Controls the Series Area appearance.")]
[ISNet.Serialization.BinarySerializableAttribute("setSettings")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.CategoryAttribute("General")]
public: __property SeriesArea* get_Settings();
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DescriptionAttribute("Controls the Series Area appearance.")]
[ISNet.Serialization.BinarySerializableAttribute("setSettings")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.CategoryAttribute("General")]
public:
property SeriesArea^ Settings {
   SeriesArea^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesAreaSettings Class
ChartSeriesAreaSettings Members


Type Property

[image]
Intersoft WebGrid Documentation
Type Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSeriesAreaSettings Class : Type Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("General")>
<System.ComponentModel.DescriptionAttribute("Type of Series Area")>
Public Property Type As SeriesAreaType
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesAreaSettings
Dim value As SeriesAreaType

instance.Type = value

value = instance.Type
C#
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DescriptionAttribute("Type of Series Area")]
public SeriesAreaType Type {get; set;}
Delphi
public read-write property Type: SeriesAreaType;
JScript
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("General")
System.ComponentModel.DescriptionAttribute("Type of Series Area")
public function get,set Type : SeriesAreaType
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DescriptionAttribute("Type of Series Area")]
public: __property SeriesAreaType get_Type();
public: __property void set_Type(
   SeriesAreaType value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DescriptionAttribute("Type of Series Area")]
public:
property SeriesAreaType Type {
   SeriesAreaType get();
   void set (    SeriesAreaType value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesAreaSettings Class
ChartSeriesAreaSettings Members


ChartSeriesBarSettings Class

[image]
Intersoft WebGrid Documentation
ChartSeriesBarSettings Class
Members See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartSeriesBarSettings Class

Glossary Item Box

Object Model

ChartSeriesBarSettings Class

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.SerializableAttribute()>
Public Class ChartSeriesBarSettings
   Inherits ISNet.WebUI.WebUIBaseClass
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesBarSettings
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public class ChartSeriesBarSettings : ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Delphi
public class ChartSeriesBarSettings = class(ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize)
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.SerializableAttribute()
public class ChartSeriesBarSettings extends ISNet.WebUI.WebUIBaseClass implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public __gc class ChartSeriesBarSettings : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public ref class ChartSeriesBarSettings : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.WebGrid.Chart.ChartSeriesBarSettings

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesBarSettings Members
ISNet.WebUI.WebGrid.Chart Namespace


ChartSeriesBarSettings Class Members

[image]
Intersoft WebGrid Documentation
ChartSeriesBarSettings Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartSeriesBarSettings Class

Glossary Item Box

The following tables list the members exposed by ChartSeriesBarSettings.

Public Constructors

 | Name | Description
Public Constructor | ChartSeriesBarSettings Constructor |
Top

Public Properties

 | Name | Description
Public Property | Settings |
Public Property | Type |
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

ChartSeriesBarSettings Class
ISNet.WebUI.WebGrid.Chart Namespace


ChartSeriesBarSettings Constructor

[image]
Intersoft WebGrid Documentation
ChartSeriesBarSettings Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSeriesBarSettings Class : ChartSeriesBarSettings Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New ChartSeriesBarSettings()
C#
public ChartSeriesBarSettings()
Delphi
public ChartSeriesBarSettings();
JScript
public function ChartSeriesBarSettings();
Managed Extensions for C++
public: ChartSeriesBarSettings();
C++/CLI
public:
ChartSeriesBarSettings();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesBarSettings Class
ChartSeriesBarSettings Members


Clone Method

[image]
Intersoft WebGrid Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSeriesBarSettings Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As System.Object
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesBarSettings
Dim value As System.Object

value = instance.Clone()
C#
public virtual System.object Clone()
Delphi
public function Clone(): System.TObject; virtual;
JScript
public function Clone() : System.Object;
Managed Extensions for C++
public: virtual System.Object* Clone();
C++/CLI
public:
virtual System.Object^ Clone();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesBarSettings Class
ChartSeriesBarSettings Members


CopyFrom Method

[image]
Intersoft WebGrid Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSeriesBarSettings Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesBarSettings Class
ChartSeriesBarSettings Members


CopyFrom(Object) Method

[image]
Intersoft WebGrid Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSeriesBarSettings Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesBarSettings
Dim objSource As System.Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   System.object objSource
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesBarSettings Class
ChartSeriesBarSettings Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebGrid Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSeriesBarSettings Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object, _
   ByVal cloneSourceValue As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesBarSettings
Dim objSource As System.Object
Dim cloneSourceValue As System.Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   System.object objSource,
   System.bool cloneSourceValue
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject;
    cloneSourceValue: System.Boolean
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object,
   cloneSourceValue : System.boolean
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource,
   System.bool cloneSourceValue
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource,
   System.bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesBarSettings Class
ChartSeriesBarSettings Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebGrid Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSeriesBarSettings Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesBarSettings
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure DeSerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function DeSerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void DeSerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void DeSerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesBarSettings Class
ChartSeriesBarSettings Members


GetHashCode Method

[image]
Intersoft WebGrid Documentation
GetHashCode Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSeriesBarSettings Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesBarSettings
Dim value As System.Integer

value = instance.GetHashCode()
C#
public virtual System.int GetHashCode()
Delphi
public function GetHashCode(): System.Integer; virtual;
JScript
public function GetHashCode() : System.int;
Managed Extensions for C++
public: virtual System.int GetHashCode();
C++/CLI
public:
virtual System.int GetHashCode();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesBarSettings Class
ChartSeriesBarSettings Members


ChartSeriesBarSettings Class Methods

[image]
Intersoft WebGrid Documentation
ChartSeriesBarSettings Class Methods
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartSeriesBarSettings Class

Glossary Item Box

For a list of all members of this type, see ChartSeriesBarSettings members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

ChartSeriesBarSettings Class
ISNet.WebUI.WebGrid.Chart Namespace


GetObjectData Method

[image]
Intersoft WebGrid Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSeriesBarSettings Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=False,
   UnmanagedCode=False,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=True,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Action=SecurityAction.Demand,
   Unrestricted=False)>
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesBarSettings
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure GetObjectData(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
); override;
JScript
System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=,
   UnmanagedCode=,
   SkipVerification=,
   Execution=,
   ControlThread=,
   ControlEvidence=,
   ControlPolicy=,
   SerializationFormatter=,
   ControlDomainPolicy=,
   ControlPrincipal=,
   ControlAppDomain=,
   RemotingConfiguration=,
   Infrastructure=,
   BindingRedirects=,
   Action=SecurityAction.Demand,
   Unrestricted=)
public override function GetObjectData(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public: void GetObjectData(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
) override
C++/CLI
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public:
void GetObjectData(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
) override

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesBarSettings Class
ChartSeriesBarSettings Members


IsEmpty Method

[image]
Intersoft WebGrid Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSeriesBarSettings Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesBarSettings
Dim value As System.Boolean

value = instance.IsEmpty()
C#
public virtual System.bool IsEmpty()
Delphi
public function IsEmpty(): System.Boolean; virtual;
JScript
public function IsEmpty() : System.boolean;
Managed Extensions for C++
public: virtual System.bool IsEmpty();
C++/CLI
public:
virtual System.bool IsEmpty();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesBarSettings Class
ChartSeriesBarSettings Members


Reset Method

[image]
Intersoft WebGrid Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSeriesBarSettings Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesBarSettings

instance.Reset()
C#
public virtual void Reset()
Delphi
public procedure Reset(); virtual;
JScript
public function Reset();
Managed Extensions for C++
public: virtual void Reset();
C++/CLI
public:
virtual void Reset();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesBarSettings Class
ChartSeriesBarSettings Members


SerializeObjectData Method

[image]
Intersoft WebGrid Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSeriesBarSettings Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesBarSettings
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure SerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function SerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void SerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void SerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesBarSettings Class
ChartSeriesBarSettings Members


ToString Method

[image]
Intersoft WebGrid Documentation
ToString Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSeriesBarSettings Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As System.String
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesBarSettings
Dim value As System.String

value = instance.ToString()
C#
public virtual System.string ToString()
Delphi
public function ToString(): System.String; virtual;
JScript
public function ToString() : System.String;
Managed Extensions for C++
public: virtual System.string* ToString();
C++/CLI
public:
virtual System.String^ ToString();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesBarSettings Class
ChartSeriesBarSettings Members


ChartSeriesBarSettings Class Properties

[image]
Intersoft WebGrid Documentation
ChartSeriesBarSettings Class Properties
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartSeriesBarSettings Class

Glossary Item Box

For a list of all members of this type, see ChartSeriesBarSettings members.

Public Properties

 | Name | Description
Public Property | Settings |
Public Property | Type |
Top

See Also

Reference

ChartSeriesBarSettings Class
ISNet.WebUI.WebGrid.Chart Namespace


ChartSeriesBarSettings Constructor

[image]
Intersoft WebGrid Documentation
ChartSeriesBarSettings Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSeriesBarSettings Class : ChartSeriesBarSettings Constructor

Glossary Item Box

Overload List

Overload | Description
ChartSeriesBarSettings Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesBarSettings Class
ChartSeriesBarSettings Members


Settings Property

[image]
Intersoft WebGrid Documentation
Settings Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSeriesBarSettings Class : Settings Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute("setSettings")>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.DefaultValueAttribute()>
Public ReadOnly Property Settings As SeriesBar
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesBarSettings
Dim value As SeriesBar

value = instance.Settings
C#
[ISNet.Serialization.BinarySerializableAttribute("setSettings")]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DefaultValueAttribute()]
public SeriesBar Settings {get;}
Delphi
public read-only property Settings: SeriesBar;
JScript
ISNet.Serialization.BinarySerializableAttribute("setSettings")
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
System.ComponentModel.NotifyParentPropertyAttribute()
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.DefaultValueAttribute()
public function get Settings : SeriesBar
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute("setSettings")]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DefaultValueAttribute()]
public: __property SeriesBar* get_Settings();
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute("setSettings")]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DefaultValueAttribute()]
public:
property SeriesBar^ Settings {
   SeriesBar^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesBarSettings Class
ChartSeriesBarSettings Members


Type Property

[image]
Intersoft WebGrid Documentation
Type Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSeriesBarSettings Class : Type Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property Type As SeriesBarType
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesBarSettings
Dim value As SeriesBarType

instance.Type = value

value = instance.Type
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public SeriesBarType Type {get; set;}
Delphi
public read-write property Type: SeriesBarType;
JScript
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set Type : SeriesBarType
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property SeriesBarType get_Type();
public: __property void set_Type(
   SeriesBarType value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property SeriesBarType Type {
   SeriesBarType get();
   void set (    SeriesBarType value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesBarSettings Class
ChartSeriesBarSettings Members


ChartSeriesBubbleSettings Class

[image]
Intersoft WebGrid Documentation
ChartSeriesBubbleSettings Class
Members See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartSeriesBubbleSettings Class

Glossary Item Box

Object Model

ChartSeriesBubbleSettings Class

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.SerializableAttribute()>
Public Class ChartSeriesBubbleSettings
   Inherits ISNet.WebUI.WebUIBaseClass
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesBubbleSettings
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public class ChartSeriesBubbleSettings : ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Delphi
public class ChartSeriesBubbleSettings = class(ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize)
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.SerializableAttribute()
public class ChartSeriesBubbleSettings extends ISNet.WebUI.WebUIBaseClass implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public __gc class ChartSeriesBubbleSettings : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public ref class ChartSeriesBubbleSettings : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.WebGrid.Chart.ChartSeriesBubbleSettings

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesBubbleSettings Members
ISNet.WebUI.WebGrid.Chart Namespace


ChartSeriesBubbleSettings Class Members

[image]
Intersoft WebGrid Documentation
ChartSeriesBubbleSettings Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartSeriesBubbleSettings Class

Glossary Item Box

The following tables list the members exposed by ChartSeriesBubbleSettings.

Public Constructors

 | Name | Description
Public Constructor | ChartSeriesBubbleSettings Constructor |
Top

Public Properties

 | Name | Description
Public Property | Settings |
Public Property | Type |
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

ChartSeriesBubbleSettings Class
ISNet.WebUI.WebGrid.Chart Namespace


ChartSeriesBubbleSettings Constructor

[image]
Intersoft WebGrid Documentation
ChartSeriesBubbleSettings Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSeriesBubbleSettings Class : ChartSeriesBubbleSettings Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New ChartSeriesBubbleSettings()
C#
public ChartSeriesBubbleSettings()
Delphi
public ChartSeriesBubbleSettings();
JScript
public function ChartSeriesBubbleSettings();
Managed Extensions for C++
public: ChartSeriesBubbleSettings();
C++/CLI
public:
ChartSeriesBubbleSettings();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesBubbleSettings Class
ChartSeriesBubbleSettings Members


Clone Method

[image]
Intersoft WebGrid Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSeriesBubbleSettings Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As System.Object
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesBubbleSettings
Dim value As System.Object

value = instance.Clone()
C#
public virtual System.object Clone()
Delphi
public function Clone(): System.TObject; virtual;
JScript
public function Clone() : System.Object;
Managed Extensions for C++
public: virtual System.Object* Clone();
C++/CLI
public:
virtual System.Object^ Clone();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesBubbleSettings Class
ChartSeriesBubbleSettings Members


CopyFrom Method

[image]
Intersoft WebGrid Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSeriesBubbleSettings Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesBubbleSettings Class
ChartSeriesBubbleSettings Members


CopyFrom(Object) Method

[image]
Intersoft WebGrid Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSeriesBubbleSettings Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesBubbleSettings
Dim objSource As System.Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   System.object objSource
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesBubbleSettings Class
ChartSeriesBubbleSettings Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebGrid Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSeriesBubbleSettings Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object, _
   ByVal cloneSourceValue As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesBubbleSettings
Dim objSource As System.Object
Dim cloneSourceValue As System.Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   System.object objSource,
   System.bool cloneSourceValue
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject;
    cloneSourceValue: System.Boolean
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object,
   cloneSourceValue : System.boolean
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource,
   System.bool cloneSourceValue
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource,
   System.bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesBubbleSettings Class
ChartSeriesBubbleSettings Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebGrid Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSeriesBubbleSettings Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesBubbleSettings
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure DeSerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function DeSerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void DeSerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void DeSerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesBubbleSettings Class
ChartSeriesBubbleSettings Members


GetHashCode Method

[image]
Intersoft WebGrid Documentation
GetHashCode Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSeriesBubbleSettings Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesBubbleSettings
Dim value As System.Integer

value = instance.GetHashCode()
C#
public virtual System.int GetHashCode()
Delphi
public function GetHashCode(): System.Integer; virtual;
JScript
public function GetHashCode() : System.int;
Managed Extensions for C++
public: virtual System.int GetHashCode();
C++/CLI
public:
virtual System.int GetHashCode();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesBubbleSettings Class
ChartSeriesBubbleSettings Members


ChartSeriesBubbleSettings Class Methods

[image]
Intersoft WebGrid Documentation
ChartSeriesBubbleSettings Class Methods
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartSeriesBubbleSettings Class

Glossary Item Box

For a list of all members of this type, see ChartSeriesBubbleSettings members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

ChartSeriesBubbleSettings Class
ISNet.WebUI.WebGrid.Chart Namespace


GetObjectData Method

[image]
Intersoft WebGrid Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSeriesBubbleSettings Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=False,
   UnmanagedCode=False,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=True,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Action=SecurityAction.Demand,
   Unrestricted=False)>
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesBubbleSettings
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure GetObjectData(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
); override;
JScript
System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=,
   UnmanagedCode=,
   SkipVerification=,
   Execution=,
   ControlThread=,
   ControlEvidence=,
   ControlPolicy=,
   SerializationFormatter=,
   ControlDomainPolicy=,
   ControlPrincipal=,
   ControlAppDomain=,
   RemotingConfiguration=,
   Infrastructure=,
   BindingRedirects=,
   Action=SecurityAction.Demand,
   Unrestricted=)
public override function GetObjectData(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public: void GetObjectData(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
) override
C++/CLI
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public:
void GetObjectData(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
) override

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesBubbleSettings Class
ChartSeriesBubbleSettings Members


IsEmpty Method

[image]
Intersoft WebGrid Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSeriesBubbleSettings Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesBubbleSettings
Dim value As System.Boolean

value = instance.IsEmpty()
C#
public virtual System.bool IsEmpty()
Delphi
public function IsEmpty(): System.Boolean; virtual;
JScript
public function IsEmpty() : System.boolean;
Managed Extensions for C++
public: virtual System.bool IsEmpty();
C++/CLI
public:
virtual System.bool IsEmpty();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesBubbleSettings Class
ChartSeriesBubbleSettings Members


Reset Method

[image]
Intersoft WebGrid Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSeriesBubbleSettings Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesBubbleSettings

instance.Reset()
C#
public virtual void Reset()
Delphi
public procedure Reset(); virtual;
JScript
public function Reset();
Managed Extensions for C++
public: virtual void Reset();
C++/CLI
public:
virtual void Reset();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesBubbleSettings Class
ChartSeriesBubbleSettings Members


SerializeObjectData Method

[image]
Intersoft WebGrid Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSeriesBubbleSettings Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesBubbleSettings
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure SerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function SerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void SerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void SerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesBubbleSettings Class
ChartSeriesBubbleSettings Members


ToString Method

[image]
Intersoft WebGrid Documentation
ToString Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSeriesBubbleSettings Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As System.String
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesBubbleSettings
Dim value As System.String

value = instance.ToString()
C#
public virtual System.string ToString()
Delphi
public function ToString(): System.String; virtual;
JScript
public function ToString() : System.String;
Managed Extensions for C++
public: virtual System.string* ToString();
C++/CLI
public:
virtual System.String^ ToString();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesBubbleSettings Class
ChartSeriesBubbleSettings Members


ChartSeriesBubbleSettings Class Properties

[image]
Intersoft WebGrid Documentation
ChartSeriesBubbleSettings Class Properties
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartSeriesBubbleSettings Class

Glossary Item Box

For a list of all members of this type, see ChartSeriesBubbleSettings members.

Public Properties

 | Name | Description
Public Property | Settings |
Public Property | Type |
Top

See Also

Reference

ChartSeriesBubbleSettings Class
ISNet.WebUI.WebGrid.Chart Namespace


ChartSeriesBubbleSettings Constructor

[image]
Intersoft WebGrid Documentation
ChartSeriesBubbleSettings Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSeriesBubbleSettings Class : ChartSeriesBubbleSettings Constructor

Glossary Item Box

Overload List

Overload | Description
ChartSeriesBubbleSettings Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesBubbleSettings Class
ChartSeriesBubbleSettings Members


Settings Property

[image]
Intersoft WebGrid Documentation
Settings Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSeriesBubbleSettings Class : Settings Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute("setSettings")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
Public ReadOnly Property Settings As SeriesBubble
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesBubbleSettings
Dim value As SeriesBubble

value = instance.Settings
C#
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute("setSettings")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
public SeriesBubble Settings {get;}
Delphi
public read-only property Settings: SeriesBubble;
JScript
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute("setSettings")
System.ComponentModel.NotifyParentPropertyAttribute()
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
public function get Settings : SeriesBubble
Managed Extensions for C++
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute("setSettings")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
public: __property SeriesBubble* get_Settings();
C++/CLI
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute("setSettings")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
public:
property SeriesBubble^ Settings {
   SeriesBubble^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesBubbleSettings Class
ChartSeriesBubbleSettings Members


Type Property

[image]
Intersoft WebGrid Documentation
Type Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSeriesBubbleSettings Class : Type Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Property Type As SeriesBubbleType
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesBubbleSettings
Dim value As SeriesBubbleType

instance.Type = value

value = instance.Type
C#
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public SeriesBubbleType Type {get; set;}
Delphi
public read-write property Type: SeriesBubbleType;
JScript
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute()
public function get,set Type : SeriesBubbleType
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property SeriesBubbleType get_Type();
public: __property void set_Type(
   SeriesBubbleType value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property SeriesBubbleType Type {
   SeriesBubbleType get();
   void set (    SeriesBubbleType value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesBubbleSettings Class
ChartSeriesBubbleSettings Members


ChartSeriesColorCollection Class

[image]
Intersoft WebGrid Documentation
ChartSeriesColorCollection Class
Members See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartSeriesColorCollection Class

Glossary Item Box

Object Model

ChartSeriesColorCollection Class

Syntax

Visual Basic (Declaration)
<System.Reflection.DefaultMemberAttribute("Item")>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.SerializableAttribute()>
Public Class ChartSeriesColorCollection
   Inherits ISNet.WebUI.ISCollectionBase
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesColorCollection
C#
[System.Reflection.DefaultMemberAttribute("Item")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public class ChartSeriesColorCollection : ISNet.WebUI.ISCollectionBase
Delphi
public class ChartSeriesColorCollection = class(ISNet.WebUI.ISCollectionBase)
JScript
System.Reflection.DefaultMemberAttribute("Item")
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.SerializableAttribute()
public class ChartSeriesColorCollection extends ISNet.WebUI.ISCollectionBase
Managed Extensions for C++
[System.Reflection.DefaultMemberAttribute("Item")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public __gc class ChartSeriesColorCollection : public ISNet.WebUI.ISCollectionBase
C++/CLI
[System.Reflection.DefaultMemberAttribute("Item")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public ref class ChartSeriesColorCollection : public ISNet.WebUI.ISCollectionBase

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
ISNet.WebUI.ISCollectionBase
ISNet.WebUI.WebGrid.Chart.ChartSeriesColorCollection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesColorCollection Members
ISNet.WebUI.WebGrid.Chart Namespace


ChartSeriesColorCollection Class Members

[image]
Intersoft WebGrid Documentation
ChartSeriesColorCollection Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartSeriesColorCollection Class

Glossary Item Box

The following tables list the members exposed by ChartSeriesColorCollection.

Public Constructors

 | Name | Description
Public Constructor | ChartSeriesColorCollection Constructor |
Top

Public Properties

 | Name | Description
Public Property | Capacity | (Inherited from System.Collections.CollectionBase)
Public Property | Count | (Inherited from System.Collections.CollectionBase)
Public Property | IsReadOnly | Overridden.
Public Property | Item |
Public Property | Parent | (Inherited from ISNet.WebUI.ISCollectionBase)
Top

Public Methods

 | Name | Description
Public Method | Add |
Public Method | Clear |
Public Method | Contains | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | CopyFrom |
Public Method | CopyTo | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | Exists | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | GetEnumerator |
Public Method | GetItem | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | GetNamedItem |
Public Method | IndexOf | Overloaded.
Public Method | Insert |
Public Method | IntInsert | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | Remove |
Public Method | setParent | (Inherited from ISNet.WebUI.ISCollectionBase)
Top

See Also

Reference

ChartSeriesColorCollection Class
ISNet.WebUI.WebGrid.Chart Namespace


ChartSeriesColorCollection Constructor

[image]
Intersoft WebGrid Documentation
ChartSeriesColorCollection Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSeriesColorCollection Class : ChartSeriesColorCollection Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New ChartSeriesColorCollection()
C#
public ChartSeriesColorCollection()
Delphi
public ChartSeriesColorCollection();
JScript
public function ChartSeriesColorCollection();
Managed Extensions for C++
public: ChartSeriesColorCollection();
C++/CLI
public:
ChartSeriesColorCollection();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesColorCollection Class
ChartSeriesColorCollection Members


ChartSeriesColorCollection Class Methods

[image]
Intersoft WebGrid Documentation
ChartSeriesColorCollection Class Methods
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartSeriesColorCollection Class

Glossary Item Box

For a list of all members of this type, see ChartSeriesColorCollection members.

Public Methods

 | Name | Description
Public Method | Add |
Public Method | Clear |
Public Method | Contains | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | CopyFrom |
Public Method | CopyTo | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | Exists | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | GetEnumerator |
Public Method | GetItem | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | GetNamedItem |
Public Method | IndexOf | Overloaded.
Public Method | Insert |
Public Method | IntInsert | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | Remove |
Public Method | setParent | (Inherited from ISNet.WebUI.ISCollectionBase)
Top

See Also

Reference

ChartSeriesColorCollection Class
ISNet.WebUI.WebGrid.Chart Namespace


Add Method

[image]
Intersoft WebGrid Documentation
Add Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSeriesColorCollection Class : Add Method

item

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function Add( _
   ByVal item As ChartFillStyle _
) As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesColorCollection
Dim item As ChartFillStyle
Dim value As System.Integer

value = instance.Add(item)
C#
public System.int Add(
   ChartFillStyle item
)
Delphi
public function Add(
    item: ChartFillStyle
): System.Integer;
JScript
public function Add(
   item : ChartFillStyle
) : System.int;
Managed Extensions for C++
public: System.int Add(
   ChartFillStyle* item
)
C++/CLI
public:
System.int Add(
   ChartFillStyle^ item
)

Parameters

item

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesColorCollection Class
ChartSeriesColorCollection Members


Clear Method

[image]
Intersoft WebGrid Documentation
Clear Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSeriesColorCollection Class : Clear Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Shadows Sub Clear()
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesColorCollection

instance.Clear()
C#
public new void Clear()
Delphi
public procedure Clear();
JScript
public hide function Clear();
Managed Extensions for C++
public: new void Clear();
C++/CLI
public:
new void Clear();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesColorCollection Class
ChartSeriesColorCollection Members


Contains Method

[image]
Intersoft WebGrid Documentation
Contains Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSeriesColorCollection Class : Contains Method

value

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function Contains( _
   ByVal value As ISNet.WebUI.INamedObject _
) As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesColorCollection
Dim value As ISNet.WebUI.INamedObject
Dim value As System.Boolean

value = instance.Contains(value)
C#
public System.bool Contains(
   ISNet.WebUI.INamedObject value
)
Delphi
public function Contains(
    value: ISNet.WebUI.INamedObject
): System.Boolean;
JScript
public function Contains(
   value : ISNet.WebUI.INamedObject
) : System.boolean;
Managed Extensions for C++
public: System.bool Contains(
   ISNet.WebUI.INamedObject* value
)
C++/CLI
public:
System.bool Contains(
   ISNet.WebUI.INamedObject^ value
)

Parameters

value

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesColorCollection Class
ChartSeriesColorCollection Members


CopyFrom Method

[image]
Intersoft WebGrid Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSeriesColorCollection Class : CopyFrom Method

passIn

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function CopyFrom( _
   ByVal passIn As ChartSeriesColorCollection _
) As ChartSeriesColorCollection
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesColorCollection
Dim passIn As ChartSeriesColorCollection
Dim value As ChartSeriesColorCollection

value = instance.CopyFrom(passIn)
C#
public ChartSeriesColorCollection CopyFrom(
   ChartSeriesColorCollection passIn
)
Delphi
public function CopyFrom(
    passIn: ChartSeriesColorCollection
): ChartSeriesColorCollection;
JScript
public function CopyFrom(
   passIn : ChartSeriesColorCollection
) : ChartSeriesColorCollection;
Managed Extensions for C++
public: ChartSeriesColorCollection* CopyFrom(
   ChartSeriesColorCollection* passIn
)
C++/CLI
public:
ChartSeriesColorCollection^ CopyFrom(
   ChartSeriesColorCollection^ passIn
)

Parameters

passIn

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesColorCollection Class
ChartSeriesColorCollection Members


CopyTo Method

[image]
Intersoft WebGrid Documentation
CopyTo Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSeriesColorCollection Class : CopyTo Method

array
index

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub CopyTo( _
   ByVal array() As ISNet.WebUI.INamedObject, _
   ByVal index As System.Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesColorCollection
Dim array() As ISNet.WebUI.INamedObject
Dim index As System.Integer

instance.CopyTo(array, index)
C#
public void CopyTo(
   ISNet.WebUI.INamedObject[] array,
   System.int index
)
Delphi
public procedure CopyTo(
    array: ISNet.WebUI.INamedObjectarray of;
    index: System.Integer
);
JScript
public function CopyTo(
   array : ISNet.WebUI.INamedObject[],
   index : System.int
);
Managed Extensions for C++
public: void CopyTo(
   ISNet.WebUI.INamedObject*[]* array,
   System.int index
)
C++/CLI
public:
void CopyTo(
   ISNet.WebUI.array<INamedObject^>^ array,
   System.int index
)

Parameters

array
index

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesColorCollection Class
ChartSeriesColorCollection Members


Exists Method

[image]
Intersoft WebGrid Documentation
Exists Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSeriesColorCollection Class : Exists Method

name

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function Exists( _
   ByVal name As System.String _
) As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesColorCollection
Dim name As System.String
Dim value As System.Boolean

value = instance.Exists(name)
C#
public System.bool Exists(
   System.string name
)
Delphi
public function Exists(
    name: System.String
): System.Boolean;
JScript
public function Exists(
   name : System.String
) : System.boolean;
Managed Extensions for C++
public: System.bool Exists(
   System.string* name
)
C++/CLI
public:
System.bool Exists(
   System.String^ name
)

Parameters

name

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesColorCollection Class
ChartSeriesColorCollection Members


GetEnumerator Method

[image]
Intersoft WebGrid Documentation
GetEnumerator Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSeriesColorCollection Class : GetEnumerator Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Shadows Function GetEnumerator() As System.Collections.IEnumerator
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesColorCollection
Dim value As System.Collections.IEnumerator

value = instance.GetEnumerator()
C#
public new System.Collections.IEnumerator GetEnumerator()
Delphi
public function GetEnumerator(): System.Collections.IEnumerator;
JScript
public hide function GetEnumerator() : System.Collections.IEnumerator;
Managed Extensions for C++
public: new System.Collections.IEnumerator* GetEnumerator();
C++/CLI
public:
new System.Collections.IEnumerator^ GetEnumerator();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesColorCollection Class
ChartSeriesColorCollection Members


GetItem Method

[image]
Intersoft WebGrid Documentation
GetItem Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSeriesColorCollection Class : GetItem Method

Glossary Item Box

Overload List

Overload | Description
GetItem | (Inherited from ISNet.WebUI.ISCollectionBase)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesColorCollection Class
ChartSeriesColorCollection Members


GetItem(Int32) Method

[image]
Intersoft WebGrid Documentation
GetItem(Int32) Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSeriesColorCollection Class : GetItem(Int32) Method

index

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetItem( _
   ByVal index As System.Integer _
) As ISNet.WebUI.INamedObject
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesColorCollection
Dim index As System.Integer
Dim value As ISNet.WebUI.INamedObject

value = instance.GetItem(index)
C#
public virtual ISNet.WebUI.INamedObject GetItem(
   System.int index
)
Delphi
public function GetItem(
    index: System.Integer
): ISNet.WebUI.INamedObject; virtual;
JScript
public function GetItem(
   index : System.int
) : ISNet.WebUI.INamedObject;
Managed Extensions for C++
public: virtual ISNet.WebUI.INamedObject* GetItem(
   System.int index
)
C++/CLI
public:
virtual ISNet.WebUI.INamedObject^ GetItem(
   System.int index
)

Parameters

index

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesColorCollection Class
ChartSeriesColorCollection Members


GetNamedItem Method

[image]
Intersoft WebGrid Documentation
GetNamedItem Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSeriesColorCollection Class : GetNamedItem Method

name

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetNamedItem( _
   ByVal name As System.String _
) As ChartFillStyle
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesColorCollection
Dim name As System.String
Dim value As ChartFillStyle

value = instance.GetNamedItem(name)
C#
public ChartFillStyle GetNamedItem(
   System.string name
)
Delphi
public function GetNamedItem(
    name: System.String
): ChartFillStyle;
JScript
public function GetNamedItem(
   name : System.String
) : ChartFillStyle;
Managed Extensions for C++
public: ChartFillStyle* GetNamedItem(
   System.string* name
)
C++/CLI
public:
ChartFillStyle^ GetNamedItem(
   System.String^ name
)

Parameters

name

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesColorCollection Class
ChartSeriesColorCollection Members


IndexOf Method

[image]
Intersoft WebGrid Documentation
IndexOf Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSeriesColorCollection Class : IndexOf Method

Glossary Item Box

Overload List

Overload | Description
IndexOf(String) | (Inherited from ISNet.WebUI.ISCollectionBase)
IndexOf(INamedObject) | (Inherited from ISNet.WebUI.ISCollectionBase)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesColorCollection Class
ChartSeriesColorCollection Members


IndexOf(String) Method

[image]
Intersoft WebGrid Documentation
IndexOf(String) Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSeriesColorCollection Class > IndexOf Method : IndexOf(String) Method

name

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function IndexOf( _
   ByVal name As System.String _
) As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesColorCollection
Dim name As System.String
Dim value As System.Integer

value = instance.IndexOf(name)
C#
public virtual System.int IndexOf(
   System.string name
)
Delphi
public function IndexOf(
    name: System.String
): System.Integer; virtual;
JScript
public function IndexOf(
   name : System.String
) : System.int;
Managed Extensions for C++
public: virtual System.int IndexOf(
   System.string* name
)
C++/CLI
public:
virtual System.int IndexOf(
   System.String^ name
)

Parameters

name

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesColorCollection Class
ChartSeriesColorCollection Members
Overload List


IndexOf(INamedObject) Method

[image]
Intersoft WebGrid Documentation
IndexOf(INamedObject) Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSeriesColorCollection Class > IndexOf Method : IndexOf(INamedObject) Method

value

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function IndexOf( _
   ByVal value As ISNet.WebUI.INamedObject _
) As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesColorCollection
Dim value As ISNet.WebUI.INamedObject
Dim value As System.Integer

value = instance.IndexOf(value)
C#
public System.int IndexOf(
   ISNet.WebUI.INamedObject value
)
Delphi
public function IndexOf(
    value: ISNet.WebUI.INamedObject
): System.Integer;
JScript
public function IndexOf(
   value : ISNet.WebUI.INamedObject
) : System.int;
Managed Extensions for C++
public: System.int IndexOf(
   ISNet.WebUI.INamedObject* value
)
C++/CLI
public:
System.int IndexOf(
   ISNet.WebUI.INamedObject^ value
)

Parameters

value

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesColorCollection Class
ChartSeriesColorCollection Members
Overload List


Insert Method

[image]
Intersoft WebGrid Documentation
Insert Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSeriesColorCollection Class : Insert Method

index
item

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub Insert( _
   ByVal index As System.Integer, _
   ByVal item As ChartFillStyle _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesColorCollection
Dim index As System.Integer
Dim item As ChartFillStyle

instance.Insert(index, item)
C#
public void Insert(
   System.int index,
   ChartFillStyle item
)
Delphi
public procedure Insert(
    index: System.Integer;
    item: ChartFillStyle
);
JScript
public function Insert(
   index : System.int,
   item : ChartFillStyle
);
Managed Extensions for C++
public: void Insert(
   System.int index,
   ChartFillStyle* item
)
C++/CLI
public:
void Insert(
   System.int index,
   ChartFillStyle^ item
)

Parameters

index
item

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesColorCollection Class
ChartSeriesColorCollection Members


IntInsert Method

[image]
Intersoft WebGrid Documentation
IntInsert Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSeriesColorCollection Class : IntInsert Method

index
value

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub IntInsert( _
   ByVal index As System.Integer, _
   ByVal value As ISNet.WebUI.INamedObject _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesColorCollection
Dim index As System.Integer
Dim value As ISNet.WebUI.INamedObject

instance.IntInsert(index, value)
C#
public void IntInsert(
   System.int index,
   ISNet.WebUI.INamedObject value
)
Delphi
public procedure IntInsert(
    index: System.Integer;
    value: ISNet.WebUI.INamedObject
);
JScript
public function IntInsert(
   index : System.int,
   value : ISNet.WebUI.INamedObject
);
Managed Extensions for C++
public: void IntInsert(
   System.int index,
   ISNet.WebUI.INamedObject* value
)
C++/CLI
public:
void IntInsert(
   System.int index,
   ISNet.WebUI.INamedObject^ value
)

Parameters

index
value

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesColorCollection Class
ChartSeriesColorCollection Members


Remove Method

[image]
Intersoft WebGrid Documentation
Remove Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSeriesColorCollection Class : Remove Method

item

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub Remove( _
   ByVal item As ChartFillStyle _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesColorCollection
Dim item As ChartFillStyle

instance.Remove(item)
C#
public void Remove(
   ChartFillStyle item
)
Delphi
public procedure Remove(
    item: ChartFillStyle
);
JScript
public function Remove(
   item : ChartFillStyle
);
Managed Extensions for C++
public: void Remove(
   ChartFillStyle* item
)
C++/CLI
public:
void Remove(
   ChartFillStyle^ item
)

Parameters

item

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesColorCollection Class
ChartSeriesColorCollection Members


setParent Method

[image]
Intersoft WebGrid Documentation
setParent Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSeriesColorCollection Class : setParent Method

parent

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub setParent( _
   ByVal parent As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesColorCollection
Dim parent As System.Object

instance.setParent(parent)
C#
public virtual void setParent(
   System.object parent
)
Delphi
public procedure setParent(
    parent: System.TObject
); virtual;
JScript
public function setParent(
   parent : System.Object
);
Managed Extensions for C++
public: virtual void setParent(
   System.Object* parent
)
C++/CLI
public:
virtual void setParent(
   System.Object^ parent
)

Parameters

parent

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesColorCollection Class
ChartSeriesColorCollection Members


Capacity Property

[image]
Intersoft WebGrid Documentation
Capacity Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSeriesColorCollection Class : Capacity Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Runtime.InteropServices.ComVisibleAttribute(False)>
Public Property Capacity As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesColorCollection
Dim value As System.Integer

instance.Capacity = value

value = instance.Capacity
C#
[System.Runtime.InteropServices.ComVisibleAttribute(false)]
public System.int Capacity {get; set;}
Delphi
public read-write property Capacity: System.Integer;
JScript
System.Runtime.InteropServices.ComVisibleAttribute()
public function get,set Capacity : System.int
Managed Extensions for C++
[System.Runtime.InteropServices.ComVisibleAttribute(false)]
public: __property System.int get_Capacity();
public: __property void set_Capacity(
   System.int value
);
C++/CLI
[System.Runtime.InteropServices.ComVisibleAttribute(false)]
public:
property System.int Capacity {
   System.int get();
   void set (    System.int value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesColorCollection Class
ChartSeriesColorCollection Members


Count Property

[image]
Intersoft WebGrid Documentation
Count Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSeriesColorCollection Class : Count Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Count As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesColorCollection
Dim value As System.Integer

value = instance.Count
C#
public System.int Count {get;}
Delphi
public read-only property Count: System.Integer;
JScript
public function get Count : System.int
Managed Extensions for C++
public: __property System.int get_Count();
C++/CLI
public:
property System.int Count {
   System.int get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesColorCollection Class
ChartSeriesColorCollection Members


ChartSeriesColorCollection Class Properties

[image]
Intersoft WebGrid Documentation
ChartSeriesColorCollection Class Properties
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartSeriesColorCollection Class

Glossary Item Box

For a list of all members of this type, see ChartSeriesColorCollection members.

Public Properties

 | Name | Description
Public Property | Capacity | (Inherited from System.Collections.CollectionBase)
Public Property | Count | (Inherited from System.Collections.CollectionBase)
Public Property | IsReadOnly | Overridden.
Public Property | Item |
Public Property | Parent | (Inherited from ISNet.WebUI.ISCollectionBase)
Top

See Also

Reference

ChartSeriesColorCollection Class
ISNet.WebUI.WebGrid.Chart Namespace


ChartSeriesColorCollection Constructor

[image]
Intersoft WebGrid Documentation
ChartSeriesColorCollection Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSeriesColorCollection Class : ChartSeriesColorCollection Constructor

Glossary Item Box

Overload List

Overload | Description
ChartSeriesColorCollection Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesColorCollection Class
ChartSeriesColorCollection Members


IsReadOnly Property

[image]
Intersoft WebGrid Documentation
IsReadOnly Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSeriesColorCollection Class : IsReadOnly Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property IsReadOnly As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesColorCollection
Dim value As System.Boolean

value = instance.IsReadOnly
C#
public override System.bool IsReadOnly {get;}
Delphi
public read-only property IsReadOnly: System.Boolean; override;
JScript
public override function get IsReadOnly : System.boolean
Managed Extensions for C++
public: __property System.bool get_IsReadOnly() override;
C++/CLI
public:
property System.bool IsReadOnly {
   System.bool get() override;
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesColorCollection Class
ChartSeriesColorCollection Members


Item Property

[image]
Intersoft WebGrid Documentation
Item Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSeriesColorCollection Class : Item Property

index

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Default Property Item( _
   ByVal index As System.Integer _
) As ChartFillStyle
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesColorCollection
Dim index As System.Integer
Dim value As ChartFillStyle

instance.Item(index) = value

value = instance.Item(index)
C#
public ChartFillStyle this[
   System.int index
]; {get; set;}
Delphi
public  this: : ChartFillStyle;[
    index: System.Integer
]; read-write
JScript
public  this[
   index : System.int
] get,set : ChartFillStyle
Managed Extensions for C++
public: __property ChartFillStyle* get_Item   System.int index
;
public: __property void set_Item   System.int index,
   ChartFillStyle* value
;
C++/CLI
public:
property ChartFillStyle^ default [int] {
   ChartFillStyle^ get(System.int index);
   void set (System.int index, ChartFillStyle^ value);
}

Parameters

index

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesColorCollection Class
ChartSeriesColorCollection Members


Parent Property

[image]
Intersoft WebGrid Documentation
Parent Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSeriesColorCollection Class : Parent Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Parent As System.Object
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesColorCollection
Dim value As System.Object

value = instance.Parent
C#
public System.object Parent {get;}
Delphi
public read-only property Parent: System.TObject;
JScript
public function get Parent : System.Object
Managed Extensions for C++
public: __property System.Object* get_Parent();
C++/CLI
public:
property System.Object^ Parent {
   System.Object^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesColorCollection Class
ChartSeriesColorCollection Members


ChartSeriesColorCollectionSettings Class

[image]
Intersoft WebGrid Documentation
ChartSeriesColorCollectionSettings Class
Members See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartSeriesColorCollectionSettings Class

Glossary Item Box

Object Model

ChartSeriesColorCollectionSettings Class

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.SerializableAttribute()>
Public Class ChartSeriesColorCollectionSettings
   Inherits ISNet.WebUI.WebUIBaseClass
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesColorCollectionSettings
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public class ChartSeriesColorCollectionSettings : ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Delphi
public class ChartSeriesColorCollectionSettings = class(ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize)
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.SerializableAttribute()
public class ChartSeriesColorCollectionSettings extends ISNet.WebUI.WebUIBaseClass implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public __gc class ChartSeriesColorCollectionSettings : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public ref class ChartSeriesColorCollectionSettings : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.WebGrid.Chart.ChartSeriesColorCollectionSettings

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesColorCollectionSettings Members
ISNet.WebUI.WebGrid.Chart Namespace


ChartSeriesColorCollectionSettings Class Members

[image]
Intersoft WebGrid Documentation
ChartSeriesColorCollectionSettings Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartSeriesColorCollectionSettings Class

Glossary Item Box

The following tables list the members exposed by ChartSeriesColorCollectionSettings.

Public Constructors

 | Name | Description
Public Constructor | ChartSeriesColorCollectionSettings Constructor |
Top

Public Properties

 | Name | Description
Public Property | Collection |
Public Property | StartIndex |
Public Property | UsePredefinedCollection |
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

ChartSeriesColorCollectionSettings Class
ISNet.WebUI.WebGrid.Chart Namespace


ChartSeriesColorCollectionSettings Constructor

[image]
Intersoft WebGrid Documentation
ChartSeriesColorCollectionSettings Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSeriesColorCollectionSettings Class : ChartSeriesColorCollectionSettings Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New ChartSeriesColorCollectionSettings()
C#
public ChartSeriesColorCollectionSettings()
Delphi
public ChartSeriesColorCollectionSettings();
JScript
public function ChartSeriesColorCollectionSettings();
Managed Extensions for C++
public: ChartSeriesColorCollectionSettings();
C++/CLI
public:
ChartSeriesColorCollectionSettings();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesColorCollectionSettings Class
ChartSeriesColorCollectionSettings Members


Clone Method

[image]
Intersoft WebGrid Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSeriesColorCollectionSettings Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As System.Object
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesColorCollectionSettings
Dim value As System.Object

value = instance.Clone()
C#
public virtual System.object Clone()
Delphi
public function Clone(): System.TObject; virtual;
JScript
public function Clone() : System.Object;
Managed Extensions for C++
public: virtual System.Object* Clone();
C++/CLI
public:
virtual System.Object^ Clone();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesColorCollectionSettings Class
ChartSeriesColorCollectionSettings Members


CopyFrom Method

[image]
Intersoft WebGrid Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSeriesColorCollectionSettings Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesColorCollectionSettings Class
ChartSeriesColorCollectionSettings Members


CopyFrom(Object) Method

[image]
Intersoft WebGrid Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSeriesColorCollectionSettings Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesColorCollectionSettings
Dim objSource As System.Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   System.object objSource
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesColorCollectionSettings Class
ChartSeriesColorCollectionSettings Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebGrid Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSeriesColorCollectionSettings Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object, _
   ByVal cloneSourceValue As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesColorCollectionSettings
Dim objSource As System.Object
Dim cloneSourceValue As System.Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   System.object objSource,
   System.bool cloneSourceValue
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject;
    cloneSourceValue: System.Boolean
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object,
   cloneSourceValue : System.boolean
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource,
   System.bool cloneSourceValue
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource,
   System.bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesColorCollectionSettings Class
ChartSeriesColorCollectionSettings Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebGrid Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSeriesColorCollectionSettings Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesColorCollectionSettings
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure DeSerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function DeSerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void DeSerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void DeSerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesColorCollectionSettings Class
ChartSeriesColorCollectionSettings Members


GetHashCode Method

[image]
Intersoft WebGrid Documentation
GetHashCode Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSeriesColorCollectionSettings Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesColorCollectionSettings
Dim value As System.Integer

value = instance.GetHashCode()
C#
public virtual System.int GetHashCode()
Delphi
public function GetHashCode(): System.Integer; virtual;
JScript
public function GetHashCode() : System.int;
Managed Extensions for C++
public: virtual System.int GetHashCode();
C++/CLI
public:
virtual System.int GetHashCode();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesColorCollectionSettings Class
ChartSeriesColorCollectionSettings Members


ChartSeriesColorCollectionSettings Class Methods

[image]
Intersoft WebGrid Documentation
ChartSeriesColorCollectionSettings Class Methods
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartSeriesColorCollectionSettings Class

Glossary Item Box

For a list of all members of this type, see ChartSeriesColorCollectionSettings members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

ChartSeriesColorCollectionSettings Class
ISNet.WebUI.WebGrid.Chart Namespace


GetObjectData Method

[image]
Intersoft WebGrid Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSeriesColorCollectionSettings Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=False,
   UnmanagedCode=False,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=True,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Action=SecurityAction.Demand,
   Unrestricted=False)>
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesColorCollectionSettings
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure GetObjectData(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
); override;
JScript
System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=,
   UnmanagedCode=,
   SkipVerification=,
   Execution=,
   ControlThread=,
   ControlEvidence=,
   ControlPolicy=,
   SerializationFormatter=,
   ControlDomainPolicy=,
   ControlPrincipal=,
   ControlAppDomain=,
   RemotingConfiguration=,
   Infrastructure=,
   BindingRedirects=,
   Action=SecurityAction.Demand,
   Unrestricted=)
public override function GetObjectData(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public: void GetObjectData(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
) override
C++/CLI
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public:
void GetObjectData(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
) override

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesColorCollectionSettings Class
ChartSeriesColorCollectionSettings Members


IsEmpty Method

[image]
Intersoft WebGrid Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSeriesColorCollectionSettings Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesColorCollectionSettings
Dim value As System.Boolean

value = instance.IsEmpty()
C#
public virtual System.bool IsEmpty()
Delphi
public function IsEmpty(): System.Boolean; virtual;
JScript
public function IsEmpty() : System.boolean;
Managed Extensions for C++
public: virtual System.bool IsEmpty();
C++/CLI
public:
virtual System.bool IsEmpty();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesColorCollectionSettings Class
ChartSeriesColorCollectionSettings Members


Reset Method

[image]
Intersoft WebGrid Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSeriesColorCollectionSettings Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesColorCollectionSettings

instance.Reset()
C#
public virtual void Reset()
Delphi
public procedure Reset(); virtual;
JScript
public function Reset();
Managed Extensions for C++
public: virtual void Reset();
C++/CLI
public:
virtual void Reset();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesColorCollectionSettings Class
ChartSeriesColorCollectionSettings Members


SerializeObjectData Method

[image]
Intersoft WebGrid Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSeriesColorCollectionSettings Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesColorCollectionSettings
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure SerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function SerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void SerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void SerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesColorCollectionSettings Class
ChartSeriesColorCollectionSettings Members


ToString Method

[image]
Intersoft WebGrid Documentation
ToString Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSeriesColorCollectionSettings Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As System.String
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesColorCollectionSettings
Dim value As System.String

value = instance.ToString()
C#
public virtual System.string ToString()
Delphi
public function ToString(): System.String; virtual;
JScript
public function ToString() : System.String;
Managed Extensions for C++
public: virtual System.string* ToString();
C++/CLI
public:
virtual System.String^ ToString();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesColorCollectionSettings Class
ChartSeriesColorCollectionSettings Members


ChartSeriesColorCollectionSettings Class Properties

[image]
Intersoft WebGrid Documentation
ChartSeriesColorCollectionSettings Class Properties
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartSeriesColorCollectionSettings Class

Glossary Item Box

For a list of all members of this type, see ChartSeriesColorCollectionSettings members.

Public Properties

 | Name | Description
Public Property | Collection |
Public Property | StartIndex |
Public Property | UsePredefinedCollection |
Top

See Also

Reference

ChartSeriesColorCollectionSettings Class
ISNet.WebUI.WebGrid.Chart Namespace


ChartSeriesColorCollectionSettings Constructor

[image]
Intersoft WebGrid Documentation
ChartSeriesColorCollectionSettings Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSeriesColorCollectionSettings Class : ChartSeriesColorCollectionSettings Constructor

Glossary Item Box

Overload List

Overload | Description
ChartSeriesColorCollectionSettings Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesColorCollectionSettings Class
ChartSeriesColorCollectionSettings Members


Collection Property

[image]
Intersoft WebGrid Documentation
Collection Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSeriesColorCollectionSettings Class : Collection Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Collection of user defined series color")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.CategoryAttribute("General")>
Public ReadOnly Property Collection As ChartSeriesColorCollection
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesColorCollectionSettings
Dim value As ChartSeriesColorCollection

value = instance.Collection
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Collection of user defined series color")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.CategoryAttribute("General")]
public ChartSeriesColorCollection Collection {get;}
Delphi
public read-only property Collection: ChartSeriesColorCollection;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Collection of user defined series color")
ISNet.Serialization.BinarySerializableAttribute()
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.CategoryAttribute("General")
public function get Collection : ChartSeriesColorCollection
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Collection of user defined series color")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.CategoryAttribute("General")]
public: __property ChartSeriesColorCollection* get_Collection();
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Collection of user defined series color")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.CategoryAttribute("General")]
public:
property ChartSeriesColorCollection^ Collection {
   ChartSeriesColorCollection^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesColorCollectionSettings Class
ChartSeriesColorCollectionSettings Members


StartIndex Property

[image]
Intersoft WebGrid Documentation
StartIndex Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSeriesColorCollectionSettings Class : StartIndex Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("General")>
<System.ComponentModel.DescriptionAttribute("Specifies the start index of the color used as the first color from the series color collection.")>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property StartIndex As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesColorCollectionSettings
Dim value As System.Integer

instance.StartIndex = value

value = instance.StartIndex
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DescriptionAttribute("Specifies the start index of the color used as the first color from the series color collection.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public System.int StartIndex {get; set;}
Delphi
public read-write property StartIndex: System.Integer;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("General")
System.ComponentModel.DescriptionAttribute("Specifies the start index of the color used as the first color from the series color collection.")
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get,set StartIndex : System.int
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DescriptionAttribute("Specifies the start index of the color used as the first color from the series color collection.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.int get_StartIndex();
public: __property void set_StartIndex(
   System.int value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DescriptionAttribute("Specifies the start index of the color used as the first color from the series color collection.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.int StartIndex {
   System.int get();
   void set (    System.int value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesColorCollectionSettings Class
ChartSeriesColorCollectionSettings Members


UsePredefinedCollection Property

[image]
Intersoft WebGrid Documentation
UsePredefinedCollection Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSeriesColorCollectionSettings Class : UsePredefinedCollection Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Determine whether predefined collection.")>
<System.ComponentModel.CategoryAttribute("General")>
Public Property UsePredefinedCollection As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesColorCollectionSettings
Dim value As System.Boolean

instance.UsePredefinedCollection = value

value = instance.UsePredefinedCollection
C#
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Determine whether predefined collection.")]
[System.ComponentModel.CategoryAttribute("General")]
public System.bool UsePredefinedCollection {get; set;}
Delphi
public read-write property UsePredefinedCollection: System.Boolean;
JScript
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Determine whether predefined collection.")
System.ComponentModel.CategoryAttribute("General")
public function get,set UsePredefinedCollection : System.boolean
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Determine whether predefined collection.")]
[System.ComponentModel.CategoryAttribute("General")]
public: __property System.bool get_UsePredefinedCollection();
public: __property void set_UsePredefinedCollection(
   System.bool value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Determine whether predefined collection.")]
[System.ComponentModel.CategoryAttribute("General")]
public:
property System.bool UsePredefinedCollection {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesColorCollectionSettings Class
ChartSeriesColorCollectionSettings Members


ChartSeriesColumnSettings Class

[image]
Intersoft WebGrid Documentation
ChartSeriesColumnSettings Class
Members See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartSeriesColumnSettings Class

Glossary Item Box

Object Model

ChartSeriesColumnSettings Class

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.SerializableAttribute()>
Public Class ChartSeriesColumnSettings
   Inherits ISNet.WebUI.WebUIBaseClass
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesColumnSettings
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public class ChartSeriesColumnSettings : ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Delphi
public class ChartSeriesColumnSettings = class(ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize)
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.SerializableAttribute()
public class ChartSeriesColumnSettings extends ISNet.WebUI.WebUIBaseClass implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public __gc class ChartSeriesColumnSettings : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public ref class ChartSeriesColumnSettings : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.WebGrid.Chart.ChartSeriesColumnSettings

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesColumnSettings Members
ISNet.WebUI.WebGrid.Chart Namespace


ChartSeriesColumnSettings Class Members

[image]
Intersoft WebGrid Documentation
ChartSeriesColumnSettings Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartSeriesColumnSettings Class

Glossary Item Box

The following tables list the members exposed by ChartSeriesColumnSettings.

Public Constructors

 | Name | Description
Public Constructor | ChartSeriesColumnSettings Constructor |
Top

Public Properties

 | Name | Description
Public Property | Settings |
Public Property | Type |
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

ChartSeriesColumnSettings Class
ISNet.WebUI.WebGrid.Chart Namespace


ChartSeriesColumnSettings Constructor

[image]
Intersoft WebGrid Documentation
ChartSeriesColumnSettings Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSeriesColumnSettings Class : ChartSeriesColumnSettings Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New ChartSeriesColumnSettings()
C#
public ChartSeriesColumnSettings()
Delphi
public ChartSeriesColumnSettings();
JScript
public function ChartSeriesColumnSettings();
Managed Extensions for C++
public: ChartSeriesColumnSettings();
C++/CLI
public:
ChartSeriesColumnSettings();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesColumnSettings Class
ChartSeriesColumnSettings Members


Clone Method

[image]
Intersoft WebGrid Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSeriesColumnSettings Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As System.Object
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesColumnSettings
Dim value As System.Object

value = instance.Clone()
C#
public virtual System.object Clone()
Delphi
public function Clone(): System.TObject; virtual;
JScript
public function Clone() : System.Object;
Managed Extensions for C++
public: virtual System.Object* Clone();
C++/CLI
public:
virtual System.Object^ Clone();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesColumnSettings Class
ChartSeriesColumnSettings Members


CopyFrom Method

[image]
Intersoft WebGrid Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSeriesColumnSettings Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesColumnSettings Class
ChartSeriesColumnSettings Members


CopyFrom(Object) Method

[image]
Intersoft WebGrid Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSeriesColumnSettings Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesColumnSettings
Dim objSource As System.Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   System.object objSource
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesColumnSettings Class
ChartSeriesColumnSettings Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebGrid Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSeriesColumnSettings Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object, _
   ByVal cloneSourceValue As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesColumnSettings
Dim objSource As System.Object
Dim cloneSourceValue As System.Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   System.object objSource,
   System.bool cloneSourceValue
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject;
    cloneSourceValue: System.Boolean
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object,
   cloneSourceValue : System.boolean
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource,
   System.bool cloneSourceValue
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource,
   System.bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesColumnSettings Class
ChartSeriesColumnSettings Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebGrid Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSeriesColumnSettings Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesColumnSettings
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure DeSerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function DeSerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void DeSerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void DeSerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesColumnSettings Class
ChartSeriesColumnSettings Members


GetHashCode Method

[image]
Intersoft WebGrid Documentation
GetHashCode Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSeriesColumnSettings Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesColumnSettings
Dim value As System.Integer

value = instance.GetHashCode()
C#
public virtual System.int GetHashCode()
Delphi
public function GetHashCode(): System.Integer; virtual;
JScript
public function GetHashCode() : System.int;
Managed Extensions for C++
public: virtual System.int GetHashCode();
C++/CLI
public:
virtual System.int GetHashCode();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesColumnSettings Class
ChartSeriesColumnSettings Members


ChartSeriesColumnSettings Class Methods

[image]
Intersoft WebGrid Documentation
ChartSeriesColumnSettings Class Methods
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartSeriesColumnSettings Class

Glossary Item Box

For a list of all members of this type, see ChartSeriesColumnSettings members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

ChartSeriesColumnSettings Class
ISNet.WebUI.WebGrid.Chart Namespace


GetObjectData Method

[image]
Intersoft WebGrid Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSeriesColumnSettings Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=False,
   UnmanagedCode=False,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=True,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Action=SecurityAction.Demand,
   Unrestricted=False)>
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesColumnSettings
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure GetObjectData(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
); override;
JScript
System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=,
   UnmanagedCode=,
   SkipVerification=,
   Execution=,
   ControlThread=,
   ControlEvidence=,
   ControlPolicy=,
   SerializationFormatter=,
   ControlDomainPolicy=,
   ControlPrincipal=,
   ControlAppDomain=,
   RemotingConfiguration=,
   Infrastructure=,
   BindingRedirects=,
   Action=SecurityAction.Demand,
   Unrestricted=)
public override function GetObjectData(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public: void GetObjectData(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
) override
C++/CLI
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public:
void GetObjectData(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
) override

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesColumnSettings Class
ChartSeriesColumnSettings Members


IsEmpty Method

[image]
Intersoft WebGrid Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSeriesColumnSettings Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesColumnSettings
Dim value As System.Boolean

value = instance.IsEmpty()
C#
public virtual System.bool IsEmpty()
Delphi
public function IsEmpty(): System.Boolean; virtual;
JScript
public function IsEmpty() : System.boolean;
Managed Extensions for C++
public: virtual System.bool IsEmpty();
C++/CLI
public:
virtual System.bool IsEmpty();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesColumnSettings Class
ChartSeriesColumnSettings Members


Reset Method

[image]
Intersoft WebGrid Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSeriesColumnSettings Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesColumnSettings

instance.Reset()
C#
public virtual void Reset()
Delphi
public procedure Reset(); virtual;
JScript
public function Reset();
Managed Extensions for C++
public: virtual void Reset();
C++/CLI
public:
virtual void Reset();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesColumnSettings Class
ChartSeriesColumnSettings Members


SerializeObjectData Method

[image]
Intersoft WebGrid Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSeriesColumnSettings Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesColumnSettings
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure SerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function SerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void SerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void SerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesColumnSettings Class
ChartSeriesColumnSettings Members


ToString Method

[image]
Intersoft WebGrid Documentation
ToString Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSeriesColumnSettings Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As System.String
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesColumnSettings
Dim value As System.String

value = instance.ToString()
C#
public virtual System.string ToString()
Delphi
public function ToString(): System.String; virtual;
JScript
public function ToString() : System.String;
Managed Extensions for C++
public: virtual System.string* ToString();
C++/CLI
public:
virtual System.String^ ToString();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesColumnSettings Class
ChartSeriesColumnSettings Members


ChartSeriesColumnSettings Class Properties

[image]
Intersoft WebGrid Documentation
ChartSeriesColumnSettings Class Properties
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartSeriesColumnSettings Class

Glossary Item Box

For a list of all members of this type, see ChartSeriesColumnSettings members.

Public Properties

 | Name | Description
Public Property | Settings |
Public Property | Type |
Top

See Also

Reference

ChartSeriesColumnSettings Class
ISNet.WebUI.WebGrid.Chart Namespace


ChartSeriesColumnSettings Constructor

[image]
Intersoft WebGrid Documentation
ChartSeriesColumnSettings Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSeriesColumnSettings Class : ChartSeriesColumnSettings Constructor

Glossary Item Box

Overload List

Overload | Description
ChartSeriesColumnSettings Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesColumnSettings Class
ChartSeriesColumnSettings Members


Settings Property

[image]
Intersoft WebGrid Documentation
Settings Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSeriesColumnSettings Class : Settings Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute("setSettings")>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
Public ReadOnly Property Settings As SeriesBar
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesColumnSettings
Dim value As SeriesBar

value = instance.Settings
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute("setSettings")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
public SeriesBar Settings {get;}
Delphi
public read-only property Settings: SeriesBar;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute("setSettings")
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
public function get Settings : SeriesBar
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute("setSettings")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
public: __property SeriesBar* get_Settings();
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute("setSettings")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
public:
property SeriesBar^ Settings {
   SeriesBar^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesColumnSettings Class
ChartSeriesColumnSettings Members


Type Property

[image]
Intersoft WebGrid Documentation
Type Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSeriesColumnSettings Class : Type Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
Public Property Type As SeriesColumnType
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesColumnSettings
Dim value As SeriesColumnType

instance.Type = value

value = instance.Type
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public SeriesColumnType Type {get; set;}
Delphi
public read-write property Type: SeriesColumnType;
JScript
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
public function get,set Type : SeriesColumnType
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public: __property SeriesColumnType get_Type();
public: __property void set_Type(
   SeriesColumnType value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public:
property SeriesColumnType Type {
   SeriesColumnType get();
   void set (    SeriesColumnType value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesColumnSettings Class
ChartSeriesColumnSettings Members


ChartSeriesDoughnutSettings Class

[image]
Intersoft WebGrid Documentation
ChartSeriesDoughnutSettings Class
Members See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartSeriesDoughnutSettings Class

Glossary Item Box

Object Model

ChartSeriesDoughnutSettings Class

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.SerializableAttribute()>
Public Class ChartSeriesDoughnutSettings
   Inherits ISNet.WebUI.WebUIBaseClass
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesDoughnutSettings
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public class ChartSeriesDoughnutSettings : ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Delphi
public class ChartSeriesDoughnutSettings = class(ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize)
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.SerializableAttribute()
public class ChartSeriesDoughnutSettings extends ISNet.WebUI.WebUIBaseClass implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public __gc class ChartSeriesDoughnutSettings : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public ref class ChartSeriesDoughnutSettings : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.WebGrid.Chart.ChartSeriesDoughnutSettings

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesDoughnutSettings Members
ISNet.WebUI.WebGrid.Chart Namespace


ChartSeriesDoughnutSettings Class Members

[image]
Intersoft WebGrid Documentation
ChartSeriesDoughnutSettings Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartSeriesDoughnutSettings Class

Glossary Item Box

The following tables list the members exposed by ChartSeriesDoughnutSettings.

Public Constructors

 | Name | Description
Public Constructor | ChartSeriesDoughnutSettings Constructor |
Top

Public Properties

 | Name | Description
Public Property | Settings |
Public Property | Type |
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

ChartSeriesDoughnutSettings Class
ISNet.WebUI.WebGrid.Chart Namespace


ChartSeriesDoughnutSettings Constructor

[image]
Intersoft WebGrid Documentation
ChartSeriesDoughnutSettings Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSeriesDoughnutSettings Class : ChartSeriesDoughnutSettings Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New ChartSeriesDoughnutSettings()
C#
public ChartSeriesDoughnutSettings()
Delphi
public ChartSeriesDoughnutSettings();
JScript
public function ChartSeriesDoughnutSettings();
Managed Extensions for C++
public: ChartSeriesDoughnutSettings();
C++/CLI
public:
ChartSeriesDoughnutSettings();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesDoughnutSettings Class
ChartSeriesDoughnutSettings Members


Clone Method

[image]
Intersoft WebGrid Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSeriesDoughnutSettings Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As System.Object
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesDoughnutSettings
Dim value As System.Object

value = instance.Clone()
C#
public virtual System.object Clone()
Delphi
public function Clone(): System.TObject; virtual;
JScript
public function Clone() : System.Object;
Managed Extensions for C++
public: virtual System.Object* Clone();
C++/CLI
public:
virtual System.Object^ Clone();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesDoughnutSettings Class
ChartSeriesDoughnutSettings Members


CopyFrom Method

[image]
Intersoft WebGrid Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSeriesDoughnutSettings Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesDoughnutSettings Class
ChartSeriesDoughnutSettings Members


CopyFrom(Object) Method

[image]
Intersoft WebGrid Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSeriesDoughnutSettings Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesDoughnutSettings
Dim objSource As System.Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   System.object objSource
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesDoughnutSettings Class
ChartSeriesDoughnutSettings Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebGrid Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSeriesDoughnutSettings Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object, _
   ByVal cloneSourceValue As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesDoughnutSettings
Dim objSource As System.Object
Dim cloneSourceValue As System.Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   System.object objSource,
   System.bool cloneSourceValue
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject;
    cloneSourceValue: System.Boolean
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object,
   cloneSourceValue : System.boolean
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource,
   System.bool cloneSourceValue
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource,
   System.bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesDoughnutSettings Class
ChartSeriesDoughnutSettings Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebGrid Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSeriesDoughnutSettings Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesDoughnutSettings
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure DeSerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function DeSerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void DeSerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void DeSerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesDoughnutSettings Class
ChartSeriesDoughnutSettings Members


GetHashCode Method

[image]
Intersoft WebGrid Documentation
GetHashCode Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSeriesDoughnutSettings Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesDoughnutSettings
Dim value As System.Integer

value = instance.GetHashCode()
C#
public virtual System.int GetHashCode()
Delphi
public function GetHashCode(): System.Integer; virtual;
JScript
public function GetHashCode() : System.int;
Managed Extensions for C++
public: virtual System.int GetHashCode();
C++/CLI
public:
virtual System.int GetHashCode();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesDoughnutSettings Class
ChartSeriesDoughnutSettings Members


ChartSeriesDoughnutSettings Class Methods

[image]
Intersoft WebGrid Documentation
ChartSeriesDoughnutSettings Class Methods
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartSeriesDoughnutSettings Class

Glossary Item Box

For a list of all members of this type, see ChartSeriesDoughnutSettings members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

ChartSeriesDoughnutSettings Class
ISNet.WebUI.WebGrid.Chart Namespace


GetObjectData Method

[image]
Intersoft WebGrid Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSeriesDoughnutSettings Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=False,
   UnmanagedCode=False,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=True,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Action=SecurityAction.Demand,
   Unrestricted=False)>
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesDoughnutSettings
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure GetObjectData(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
); override;
JScript
System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=,
   UnmanagedCode=,
   SkipVerification=,
   Execution=,
   ControlThread=,
   ControlEvidence=,
   ControlPolicy=,
   SerializationFormatter=,
   ControlDomainPolicy=,
   ControlPrincipal=,
   ControlAppDomain=,
   RemotingConfiguration=,
   Infrastructure=,
   BindingRedirects=,
   Action=SecurityAction.Demand,
   Unrestricted=)
public override function GetObjectData(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public: void GetObjectData(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
) override
C++/CLI
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public:
void GetObjectData(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
) override

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesDoughnutSettings Class
ChartSeriesDoughnutSettings Members


IsEmpty Method

[image]
Intersoft WebGrid Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSeriesDoughnutSettings Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesDoughnutSettings
Dim value As System.Boolean

value = instance.IsEmpty()
C#
public virtual System.bool IsEmpty()
Delphi
public function IsEmpty(): System.Boolean; virtual;
JScript
public function IsEmpty() : System.boolean;
Managed Extensions for C++
public: virtual System.bool IsEmpty();
C++/CLI
public:
virtual System.bool IsEmpty();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesDoughnutSettings Class
ChartSeriesDoughnutSettings Members


Reset Method

[image]
Intersoft WebGrid Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSeriesDoughnutSettings Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesDoughnutSettings

instance.Reset()
C#
public virtual void Reset()
Delphi
public procedure Reset(); virtual;
JScript
public function Reset();
Managed Extensions for C++
public: virtual void Reset();
C++/CLI
public:
virtual void Reset();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesDoughnutSettings Class
ChartSeriesDoughnutSettings Members


SerializeObjectData Method

[image]
Intersoft WebGrid Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSeriesDoughnutSettings Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesDoughnutSettings
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure SerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function SerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void SerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void SerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesDoughnutSettings Class
ChartSeriesDoughnutSettings Members


ToString Method

[image]
Intersoft WebGrid Documentation
ToString Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSeriesDoughnutSettings Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As System.String
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesDoughnutSettings
Dim value As System.String

value = instance.ToString()
C#
public virtual System.string ToString()
Delphi
public function ToString(): System.String; virtual;
JScript
public function ToString() : System.String;
Managed Extensions for C++
public: virtual System.string* ToString();
C++/CLI
public:
virtual System.String^ ToString();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesDoughnutSettings Class
ChartSeriesDoughnutSettings Members


ChartSeriesDoughnutSettings Class Properties

[image]
Intersoft WebGrid Documentation
ChartSeriesDoughnutSettings Class Properties
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartSeriesDoughnutSettings Class

Glossary Item Box

For a list of all members of this type, see ChartSeriesDoughnutSettings members.

Public Properties

 | Name | Description
Public Property | Settings |
Public Property | Type |
Top

See Also

Reference

ChartSeriesDoughnutSettings Class
ISNet.WebUI.WebGrid.Chart Namespace


ChartSeriesDoughnutSettings Constructor

[image]
Intersoft WebGrid Documentation
ChartSeriesDoughnutSettings Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSeriesDoughnutSettings Class : ChartSeriesDoughnutSettings Constructor

Glossary Item Box

Overload List

Overload | Description
ChartSeriesDoughnutSettings Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesDoughnutSettings Class
ChartSeriesDoughnutSettings Members


Settings Property

[image]
Intersoft WebGrid Documentation
Settings Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSeriesDoughnutSettings Class : Settings Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<ISNet.Serialization.BinarySerializableAttribute("setSettings")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
Public ReadOnly Property Settings As SeriesPie
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesDoughnutSettings
Dim value As SeriesPie

value = instance.Settings
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[ISNet.Serialization.BinarySerializableAttribute("setSettings")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
public SeriesPie Settings {get;}
Delphi
public read-only property Settings: SeriesPie;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
ISNet.Serialization.BinarySerializableAttribute("setSettings")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
public function get Settings : SeriesPie
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[ISNet.Serialization.BinarySerializableAttribute("setSettings")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
public: __property SeriesPie* get_Settings();
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[ISNet.Serialization.BinarySerializableAttribute("setSettings")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
public:
property SeriesPie^ Settings {
   SeriesPie^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesDoughnutSettings Class
ChartSeriesDoughnutSettings Members


Type Property

[image]
Intersoft WebGrid Documentation
Type Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSeriesDoughnutSettings Class : Type Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property Type As SeriesDoughnutType
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesDoughnutSettings
Dim value As SeriesDoughnutType

instance.Type = value

value = instance.Type
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public SeriesDoughnutType Type {get; set;}
Delphi
public read-write property Type: SeriesDoughnutType;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get,set Type : SeriesDoughnutType
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property SeriesDoughnutType get_Type();
public: __property void set_Type(
   SeriesDoughnutType value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property SeriesDoughnutType Type {
   SeriesDoughnutType get();
   void set (    SeriesDoughnutType value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesDoughnutSettings Class
ChartSeriesDoughnutSettings Members


ChartSeriesLineSettings Class

[image]
Intersoft WebGrid Documentation
ChartSeriesLineSettings Class
Members See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartSeriesLineSettings Class

Glossary Item Box

Object Model

ChartSeriesLineSettings Class

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.SerializableAttribute()>
Public Class ChartSeriesLineSettings
   Inherits ISNet.WebUI.WebUIBaseClass
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesLineSettings
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public class ChartSeriesLineSettings : ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Delphi
public class ChartSeriesLineSettings = class(ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize)
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.SerializableAttribute()
public class ChartSeriesLineSettings extends ISNet.WebUI.WebUIBaseClass implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public __gc class ChartSeriesLineSettings : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public ref class ChartSeriesLineSettings : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.WebGrid.Chart.ChartSeriesLineSettings

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesLineSettings Members
ISNet.WebUI.WebGrid.Chart Namespace


ChartSeriesLineSettings Class Members

[image]
Intersoft WebGrid Documentation
ChartSeriesLineSettings Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartSeriesLineSettings Class

Glossary Item Box

The following tables list the members exposed by ChartSeriesLineSettings.

Public Constructors

 | Name | Description
Public Constructor | ChartSeriesLineSettings Constructor |
Top

Public Properties

 | Name | Description
Public Property | Settings |
Public Property | Type |
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

ChartSeriesLineSettings Class
ISNet.WebUI.WebGrid.Chart Namespace


ChartSeriesLineSettings Constructor

[image]
Intersoft WebGrid Documentation
ChartSeriesLineSettings Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSeriesLineSettings Class : ChartSeriesLineSettings Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New ChartSeriesLineSettings()
C#
public ChartSeriesLineSettings()
Delphi
public ChartSeriesLineSettings();
JScript
public function ChartSeriesLineSettings();
Managed Extensions for C++
public: ChartSeriesLineSettings();
C++/CLI
public:
ChartSeriesLineSettings();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesLineSettings Class
ChartSeriesLineSettings Members


Clone Method

[image]
Intersoft WebGrid Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSeriesLineSettings Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As System.Object
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesLineSettings
Dim value As System.Object

value = instance.Clone()
C#
public virtual System.object Clone()
Delphi
public function Clone(): System.TObject; virtual;
JScript
public function Clone() : System.Object;
Managed Extensions for C++
public: virtual System.Object* Clone();
C++/CLI
public:
virtual System.Object^ Clone();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesLineSettings Class
ChartSeriesLineSettings Members


CopyFrom Method

[image]
Intersoft WebGrid Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSeriesLineSettings Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesLineSettings Class
ChartSeriesLineSettings Members


CopyFrom(Object) Method

[image]
Intersoft WebGrid Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSeriesLineSettings Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesLineSettings
Dim objSource As System.Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   System.object objSource
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesLineSettings Class
ChartSeriesLineSettings Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebGrid Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSeriesLineSettings Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object, _
   ByVal cloneSourceValue As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesLineSettings
Dim objSource As System.Object
Dim cloneSourceValue As System.Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   System.object objSource,
   System.bool cloneSourceValue
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject;
    cloneSourceValue: System.Boolean
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object,
   cloneSourceValue : System.boolean
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource,
   System.bool cloneSourceValue
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource,
   System.bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesLineSettings Class
ChartSeriesLineSettings Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebGrid Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSeriesLineSettings Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesLineSettings
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure DeSerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function DeSerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void DeSerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void DeSerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesLineSettings Class
ChartSeriesLineSettings Members


GetHashCode Method

[image]
Intersoft WebGrid Documentation
GetHashCode Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSeriesLineSettings Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesLineSettings
Dim value As System.Integer

value = instance.GetHashCode()
C#
public virtual System.int GetHashCode()
Delphi
public function GetHashCode(): System.Integer; virtual;
JScript
public function GetHashCode() : System.int;
Managed Extensions for C++
public: virtual System.int GetHashCode();
C++/CLI
public:
virtual System.int GetHashCode();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesLineSettings Class
ChartSeriesLineSettings Members


ChartSeriesLineSettings Class Methods

[image]
Intersoft WebGrid Documentation
ChartSeriesLineSettings Class Methods
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartSeriesLineSettings Class

Glossary Item Box

For a list of all members of this type, see ChartSeriesLineSettings members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

ChartSeriesLineSettings Class
ISNet.WebUI.WebGrid.Chart Namespace


GetObjectData Method

[image]
Intersoft WebGrid Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSeriesLineSettings Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=False,
   UnmanagedCode=False,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=True,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Action=SecurityAction.Demand,
   Unrestricted=False)>
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesLineSettings
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure GetObjectData(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
); override;
JScript
System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=,
   UnmanagedCode=,
   SkipVerification=,
   Execution=,
   ControlThread=,
   ControlEvidence=,
   ControlPolicy=,
   SerializationFormatter=,
   ControlDomainPolicy=,
   ControlPrincipal=,
   ControlAppDomain=,
   RemotingConfiguration=,
   Infrastructure=,
   BindingRedirects=,
   Action=SecurityAction.Demand,
   Unrestricted=)
public override function GetObjectData(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public: void GetObjectData(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
) override
C++/CLI
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public:
void GetObjectData(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
) override

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesLineSettings Class
ChartSeriesLineSettings Members


IsEmpty Method

[image]
Intersoft WebGrid Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSeriesLineSettings Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesLineSettings
Dim value As System.Boolean

value = instance.IsEmpty()
C#
public virtual System.bool IsEmpty()
Delphi
public function IsEmpty(): System.Boolean; virtual;
JScript
public function IsEmpty() : System.boolean;
Managed Extensions for C++
public: virtual System.bool IsEmpty();
C++/CLI
public:
virtual System.bool IsEmpty();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesLineSettings Class
ChartSeriesLineSettings Members


Reset Method

[image]
Intersoft WebGrid Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSeriesLineSettings Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesLineSettings

instance.Reset()
C#
public virtual void Reset()
Delphi
public procedure Reset(); virtual;
JScript
public function Reset();
Managed Extensions for C++
public: virtual void Reset();
C++/CLI
public:
virtual void Reset();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesLineSettings Class
ChartSeriesLineSettings Members


SerializeObjectData Method

[image]
Intersoft WebGrid Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSeriesLineSettings Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesLineSettings
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure SerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function SerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void SerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void SerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesLineSettings Class
ChartSeriesLineSettings Members


ToString Method

[image]
Intersoft WebGrid Documentation
ToString Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSeriesLineSettings Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As System.String
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesLineSettings
Dim value As System.String

value = instance.ToString()
C#
public virtual System.string ToString()
Delphi
public function ToString(): System.String; virtual;
JScript
public function ToString() : System.String;
Managed Extensions for C++
public: virtual System.string* ToString();
C++/CLI
public:
virtual System.String^ ToString();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesLineSettings Class
ChartSeriesLineSettings Members


ChartSeriesLineSettings Class Properties

[image]
Intersoft WebGrid Documentation
ChartSeriesLineSettings Class Properties
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartSeriesLineSettings Class

Glossary Item Box

For a list of all members of this type, see ChartSeriesLineSettings members.

Public Properties

 | Name | Description
Public Property | Settings |
Public Property | Type |
Top

See Also

Reference

ChartSeriesLineSettings Class
ISNet.WebUI.WebGrid.Chart Namespace


ChartSeriesLineSettings Constructor

[image]
Intersoft WebGrid Documentation
ChartSeriesLineSettings Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSeriesLineSettings Class : ChartSeriesLineSettings Constructor

Glossary Item Box

Overload List

Overload | Description
ChartSeriesLineSettings Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesLineSettings Class
ChartSeriesLineSettings Members


Settings Property

[image]
Intersoft WebGrid Documentation
Settings Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSeriesLineSettings Class : Settings Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<ISNet.Serialization.BinarySerializableAttribute("setSettings")>
<System.ComponentModel.DefaultValueAttribute()>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public ReadOnly Property Settings As SeriesLine
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesLineSettings
Dim value As SeriesLine

value = instance.Settings
C#
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.Serialization.BinarySerializableAttribute("setSettings")]
[System.ComponentModel.DefaultValueAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public SeriesLine Settings {get;}
Delphi
public read-only property Settings: SeriesLine;
JScript
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
ISNet.Serialization.BinarySerializableAttribute("setSettings")
System.ComponentModel.DefaultValueAttribute()
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.NotifyParentPropertyAttribute()
public function get Settings : SeriesLine
Managed Extensions for C++
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.Serialization.BinarySerializableAttribute("setSettings")]
[System.ComponentModel.DefaultValueAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property SeriesLine* get_Settings();
C++/CLI
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.Serialization.BinarySerializableAttribute("setSettings")]
[System.ComponentModel.DefaultValueAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property SeriesLine^ Settings {
   SeriesLine^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesLineSettings Class
ChartSeriesLineSettings Members


Type Property

[image]
Intersoft WebGrid Documentation
Type Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSeriesLineSettings Class : Type Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property Type As SeriesLineType
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesLineSettings
Dim value As SeriesLineType

instance.Type = value

value = instance.Type
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public SeriesLineType Type {get; set;}
Delphi
public read-write property Type: SeriesLineType;
JScript
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set Type : SeriesLineType
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property SeriesLineType get_Type();
public: __property void set_Type(
   SeriesLineType value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property SeriesLineType Type {
   SeriesLineType get();
   void set (    SeriesLineType value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesLineSettings Class
ChartSeriesLineSettings Members


ChartSeriesMarkerCollection Class

[image]
Intersoft WebGrid Documentation
ChartSeriesMarkerCollection Class
Members See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartSeriesMarkerCollection Class

Glossary Item Box

Object Model

ChartSeriesMarkerCollection Class

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.Reflection.DefaultMemberAttribute("Item")>
<System.SerializableAttribute()>
Public Class ChartSeriesMarkerCollection
   Inherits ISNet.WebUI.ISCollectionBase
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesMarkerCollection
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.Reflection.DefaultMemberAttribute("Item")]
[System.SerializableAttribute()]
public class ChartSeriesMarkerCollection : ISNet.WebUI.ISCollectionBase
Delphi
public class ChartSeriesMarkerCollection = class(ISNet.WebUI.ISCollectionBase)
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.Reflection.DefaultMemberAttribute("Item")
System.SerializableAttribute()
public class ChartSeriesMarkerCollection extends ISNet.WebUI.ISCollectionBase
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.Reflection.DefaultMemberAttribute("Item")]
[System.SerializableAttribute()]
public __gc class ChartSeriesMarkerCollection : public ISNet.WebUI.ISCollectionBase
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.Reflection.DefaultMemberAttribute("Item")]
[System.SerializableAttribute()]
public ref class ChartSeriesMarkerCollection : public ISNet.WebUI.ISCollectionBase

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
ISNet.WebUI.ISCollectionBase
ISNet.WebUI.WebGrid.Chart.ChartSeriesMarkerCollection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesMarkerCollection Members
ISNet.WebUI.WebGrid.Chart Namespace


ChartSeriesMarkerCollection Class Members

[image]
Intersoft WebGrid Documentation
ChartSeriesMarkerCollection Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartSeriesMarkerCollection Class

Glossary Item Box

The following tables list the members exposed by ChartSeriesMarkerCollection.

Public Constructors

 | Name | Description
Public Constructor | ChartSeriesMarkerCollection Constructor |
Top

Public Properties

 | Name | Description
Public Property | Capacity | (Inherited from System.Collections.CollectionBase)
Public Property | Count | (Inherited from System.Collections.CollectionBase)
Public Property | IsReadOnly | Overridden.
Public Property | Item |
Public Property | Parent | (Inherited from ISNet.WebUI.ISCollectionBase)
Top

Public Methods

 | Name | Description
Public Method | Add |
Public Method | Clear |
Public Method | Contains | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | CopyFrom |
Public Method | CopyTo | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | Exists | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | GetEnumerator |
Public Method | GetItem | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | GetNamedItem |
Public Method | IndexOf | Overloaded.
Public Method | Insert |
Public Method | IntInsert | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | Remove |
Public Method | setParent | (Inherited from ISNet.WebUI.ISCollectionBase)
Top

See Also

Reference

ChartSeriesMarkerCollection Class
ISNet.WebUI.WebGrid.Chart Namespace


ChartSeriesMarkerCollection Constructor

[image]
Intersoft WebGrid Documentation
ChartSeriesMarkerCollection Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSeriesMarkerCollection Class : ChartSeriesMarkerCollection Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New ChartSeriesMarkerCollection()
C#
public ChartSeriesMarkerCollection()
Delphi
public ChartSeriesMarkerCollection();
JScript
public function ChartSeriesMarkerCollection();
Managed Extensions for C++
public: ChartSeriesMarkerCollection();
C++/CLI
public:
ChartSeriesMarkerCollection();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesMarkerCollection Class
ChartSeriesMarkerCollection Members


ChartSeriesMarkerCollection Class Methods

[image]
Intersoft WebGrid Documentation
ChartSeriesMarkerCollection Class Methods
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartSeriesMarkerCollection Class

Glossary Item Box

For a list of all members of this type, see ChartSeriesMarkerCollection members.

Public Methods

 | Name | Description
Public Method | Add |
Public Method | Clear |
Public Method | Contains | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | CopyFrom |
Public Method | CopyTo | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | Exists | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | GetEnumerator |
Public Method | GetItem | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | GetNamedItem |
Public Method | IndexOf | Overloaded.
Public Method | Insert |
Public Method | IntInsert | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | Remove |
Public Method | setParent | (Inherited from ISNet.WebUI.ISCollectionBase)
Top

See Also

Reference

ChartSeriesMarkerCollection Class
ISNet.WebUI.WebGrid.Chart Namespace


Add Method

[image]
Intersoft WebGrid Documentation
Add Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSeriesMarkerCollection Class : Add Method

item

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function Add( _
   ByVal item As ChartMarkerStyle _
) As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesMarkerCollection
Dim item As ChartMarkerStyle
Dim value As System.Integer

value = instance.Add(item)
C#
public System.int Add(
   ChartMarkerStyle item
)
Delphi
public function Add(
    item: ChartMarkerStyle
): System.Integer;
JScript
public function Add(
   item : ChartMarkerStyle
) : System.int;
Managed Extensions for C++
public: System.int Add(
   ChartMarkerStyle* item
)
C++/CLI
public:
System.int Add(
   ChartMarkerStyle^ item
)

Parameters

item

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesMarkerCollection Class
ChartSeriesMarkerCollection Members


Clear Method

[image]
Intersoft WebGrid Documentation
Clear Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSeriesMarkerCollection Class : Clear Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Shadows Sub Clear()
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesMarkerCollection

instance.Clear()
C#
public new void Clear()
Delphi
public procedure Clear();
JScript
public hide function Clear();
Managed Extensions for C++
public: new void Clear();
C++/CLI
public:
new void Clear();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesMarkerCollection Class
ChartSeriesMarkerCollection Members


Contains Method

[image]
Intersoft WebGrid Documentation
Contains Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSeriesMarkerCollection Class : Contains Method

value

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function Contains( _
   ByVal value As ISNet.WebUI.INamedObject _
) As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesMarkerCollection
Dim value As ISNet.WebUI.INamedObject
Dim value As System.Boolean

value = instance.Contains(value)
C#
public System.bool Contains(
   ISNet.WebUI.INamedObject value
)
Delphi
public function Contains(
    value: ISNet.WebUI.INamedObject
): System.Boolean;
JScript
public function Contains(
   value : ISNet.WebUI.INamedObject
) : System.boolean;
Managed Extensions for C++
public: System.bool Contains(
   ISNet.WebUI.INamedObject* value
)
C++/CLI
public:
System.bool Contains(
   ISNet.WebUI.INamedObject^ value
)

Parameters

value

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesMarkerCollection Class
ChartSeriesMarkerCollection Members


CopyFrom Method

[image]
Intersoft WebGrid Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSeriesMarkerCollection Class : CopyFrom Method

passIn

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function CopyFrom( _
   ByVal passIn As ChartSeriesMarkerCollection _
) As ChartSeriesMarkerCollection
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesMarkerCollection
Dim passIn As ChartSeriesMarkerCollection
Dim value As ChartSeriesMarkerCollection

value = instance.CopyFrom(passIn)
C#
public ChartSeriesMarkerCollection CopyFrom(
   ChartSeriesMarkerCollection passIn
)
Delphi
public function CopyFrom(
    passIn: ChartSeriesMarkerCollection
): ChartSeriesMarkerCollection;
JScript
public function CopyFrom(
   passIn : ChartSeriesMarkerCollection
) : ChartSeriesMarkerCollection;
Managed Extensions for C++
public: ChartSeriesMarkerCollection* CopyFrom(
   ChartSeriesMarkerCollection* passIn
)
C++/CLI
public:
ChartSeriesMarkerCollection^ CopyFrom(
   ChartSeriesMarkerCollection^ passIn
)

Parameters

passIn

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesMarkerCollection Class
ChartSeriesMarkerCollection Members


CopyTo Method

[image]
Intersoft WebGrid Documentation
CopyTo Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSeriesMarkerCollection Class : CopyTo Method

array
index

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub CopyTo( _
   ByVal array() As ISNet.WebUI.INamedObject, _
   ByVal index As System.Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesMarkerCollection
Dim array() As ISNet.WebUI.INamedObject
Dim index As System.Integer

instance.CopyTo(array, index)
C#
public void CopyTo(
   ISNet.WebUI.INamedObject[] array,
   System.int index
)
Delphi
public procedure CopyTo(
    array: ISNet.WebUI.INamedObjectarray of;
    index: System.Integer
);
JScript
public function CopyTo(
   array : ISNet.WebUI.INamedObject[],
   index : System.int
);
Managed Extensions for C++
public: void CopyTo(
   ISNet.WebUI.INamedObject*[]* array,
   System.int index
)
C++/CLI
public:
void CopyTo(
   ISNet.WebUI.array<INamedObject^>^ array,
   System.int index
)

Parameters

array
index

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesMarkerCollection Class
ChartSeriesMarkerCollection Members


Exists Method

[image]
Intersoft WebGrid Documentation
Exists Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSeriesMarkerCollection Class : Exists Method

name

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function Exists( _
   ByVal name As System.String _
) As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesMarkerCollection
Dim name As System.String
Dim value As System.Boolean

value = instance.Exists(name)
C#
public System.bool Exists(
   System.string name
)
Delphi
public function Exists(
    name: System.String
): System.Boolean;
JScript
public function Exists(
   name : System.String
) : System.boolean;
Managed Extensions for C++
public: System.bool Exists(
   System.string* name
)
C++/CLI
public:
System.bool Exists(
   System.String^ name
)

Parameters

name

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesMarkerCollection Class
ChartSeriesMarkerCollection Members


GetEnumerator Method

[image]
Intersoft WebGrid Documentation
GetEnumerator Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSeriesMarkerCollection Class : GetEnumerator Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Shadows Function GetEnumerator() As System.Collections.IEnumerator
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesMarkerCollection
Dim value As System.Collections.IEnumerator

value = instance.GetEnumerator()
C#
public new System.Collections.IEnumerator GetEnumerator()
Delphi
public function GetEnumerator(): System.Collections.IEnumerator;
JScript
public hide function GetEnumerator() : System.Collections.IEnumerator;
Managed Extensions for C++
public: new System.Collections.IEnumerator* GetEnumerator();
C++/CLI
public:
new System.Collections.IEnumerator^ GetEnumerator();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesMarkerCollection Class
ChartSeriesMarkerCollection Members


GetItem Method

[image]
Intersoft WebGrid Documentation
GetItem Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSeriesMarkerCollection Class : GetItem Method

Glossary Item Box

Overload List

Overload | Description
GetItem | (Inherited from ISNet.WebUI.ISCollectionBase)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesMarkerCollection Class
ChartSeriesMarkerCollection Members


GetItem(Int32) Method

[image]
Intersoft WebGrid Documentation
GetItem(Int32) Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSeriesMarkerCollection Class : GetItem(Int32) Method

index

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetItem( _
   ByVal index As System.Integer _
) As ISNet.WebUI.INamedObject
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesMarkerCollection
Dim index As System.Integer
Dim value As ISNet.WebUI.INamedObject

value = instance.GetItem(index)
C#
public virtual ISNet.WebUI.INamedObject GetItem(
   System.int index
)
Delphi
public function GetItem(
    index: System.Integer
): ISNet.WebUI.INamedObject; virtual;
JScript
public function GetItem(
   index : System.int
) : ISNet.WebUI.INamedObject;
Managed Extensions for C++
public: virtual ISNet.WebUI.INamedObject* GetItem(
   System.int index
)
C++/CLI
public:
virtual ISNet.WebUI.INamedObject^ GetItem(
   System.int index
)

Parameters

index

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesMarkerCollection Class
ChartSeriesMarkerCollection Members


GetNamedItem Method

[image]
Intersoft WebGrid Documentation
GetNamedItem Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSeriesMarkerCollection Class : GetNamedItem Method

name

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetNamedItem( _
   ByVal name As System.String _
) As ChartMarkerStyle
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesMarkerCollection
Dim name As System.String
Dim value As ChartMarkerStyle

value = instance.GetNamedItem(name)
C#
public ChartMarkerStyle GetNamedItem(
   System.string name
)
Delphi
public function GetNamedItem(
    name: System.String
): ChartMarkerStyle;
JScript
public function GetNamedItem(
   name : System.String
) : ChartMarkerStyle;
Managed Extensions for C++
public: ChartMarkerStyle* GetNamedItem(
   System.string* name
)
C++/CLI
public:
ChartMarkerStyle^ GetNamedItem(
   System.String^ name
)

Parameters

name

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesMarkerCollection Class
ChartSeriesMarkerCollection Members


IndexOf Method

[image]
Intersoft WebGrid Documentation
IndexOf Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSeriesMarkerCollection Class : IndexOf Method

Glossary Item Box

Overload List

Overload | Description
IndexOf(String) | (Inherited from ISNet.WebUI.ISCollectionBase)
IndexOf(INamedObject) | (Inherited from ISNet.WebUI.ISCollectionBase)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesMarkerCollection Class
ChartSeriesMarkerCollection Members


IndexOf(String) Method

[image]
Intersoft WebGrid Documentation
IndexOf(String) Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSeriesMarkerCollection Class > IndexOf Method : IndexOf(String) Method

name

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function IndexOf( _
   ByVal name As System.String _
) As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesMarkerCollection
Dim name As System.String
Dim value As System.Integer

value = instance.IndexOf(name)
C#
public virtual System.int IndexOf(
   System.string name
)
Delphi
public function IndexOf(
    name: System.String
): System.Integer; virtual;
JScript
public function IndexOf(
   name : System.String
) : System.int;
Managed Extensions for C++
public: virtual System.int IndexOf(
   System.string* name
)
C++/CLI
public:
virtual System.int IndexOf(
   System.String^ name
)

Parameters

name

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesMarkerCollection Class
ChartSeriesMarkerCollection Members
Overload List


IndexOf(INamedObject) Method

[image]
Intersoft WebGrid Documentation
IndexOf(INamedObject) Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSeriesMarkerCollection Class > IndexOf Method : IndexOf(INamedObject) Method

value

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function IndexOf( _
   ByVal value As ISNet.WebUI.INamedObject _
) As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesMarkerCollection
Dim value As ISNet.WebUI.INamedObject
Dim value As System.Integer

value = instance.IndexOf(value)
C#
public System.int IndexOf(
   ISNet.WebUI.INamedObject value
)
Delphi
public function IndexOf(
    value: ISNet.WebUI.INamedObject
): System.Integer;
JScript
public function IndexOf(
   value : ISNet.WebUI.INamedObject
) : System.int;
Managed Extensions for C++
public: System.int IndexOf(
   ISNet.WebUI.INamedObject* value
)
C++/CLI
public:
System.int IndexOf(
   ISNet.WebUI.INamedObject^ value
)

Parameters

value

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesMarkerCollection Class
ChartSeriesMarkerCollection Members
Overload List


Insert Method

[image]
Intersoft WebGrid Documentation
Insert Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSeriesMarkerCollection Class : Insert Method

index
item

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub Insert( _
   ByVal index As System.Integer, _
   ByVal item As ChartMarkerStyle _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesMarkerCollection
Dim index As System.Integer
Dim item As ChartMarkerStyle

instance.Insert(index, item)
C#
public void Insert(
   System.int index,
   ChartMarkerStyle item
)
Delphi
public procedure Insert(
    index: System.Integer;
    item: ChartMarkerStyle
);
JScript
public function Insert(
   index : System.int,
   item : ChartMarkerStyle
);
Managed Extensions for C++
public: void Insert(
   System.int index,
   ChartMarkerStyle* item
)
C++/CLI
public:
void Insert(
   System.int index,
   ChartMarkerStyle^ item
)

Parameters

index
item

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesMarkerCollection Class
ChartSeriesMarkerCollection Members


IntInsert Method

[image]
Intersoft WebGrid Documentation
IntInsert Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSeriesMarkerCollection Class : IntInsert Method

index
value

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub IntInsert( _
   ByVal index As System.Integer, _
   ByVal value As ISNet.WebUI.INamedObject _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesMarkerCollection
Dim index As System.Integer
Dim value As ISNet.WebUI.INamedObject

instance.IntInsert(index, value)
C#
public void IntInsert(
   System.int index,
   ISNet.WebUI.INamedObject value
)
Delphi
public procedure IntInsert(
    index: System.Integer;
    value: ISNet.WebUI.INamedObject
);
JScript
public function IntInsert(
   index : System.int,
   value : ISNet.WebUI.INamedObject
);
Managed Extensions for C++
public: void IntInsert(
   System.int index,
   ISNet.WebUI.INamedObject* value
)
C++/CLI
public:
void IntInsert(
   System.int index,
   ISNet.WebUI.INamedObject^ value
)

Parameters

index
value

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesMarkerCollection Class
ChartSeriesMarkerCollection Members


Remove Method

[image]
Intersoft WebGrid Documentation
Remove Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSeriesMarkerCollection Class : Remove Method

item

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub Remove( _
   ByVal item As ChartMarkerStyle _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesMarkerCollection
Dim item As ChartMarkerStyle

instance.Remove(item)
C#
public void Remove(
   ChartMarkerStyle item
)
Delphi
public procedure Remove(
    item: ChartMarkerStyle
);
JScript
public function Remove(
   item : ChartMarkerStyle
);
Managed Extensions for C++
public: void Remove(
   ChartMarkerStyle* item
)
C++/CLI
public:
void Remove(
   ChartMarkerStyle^ item
)

Parameters

item

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesMarkerCollection Class
ChartSeriesMarkerCollection Members


setParent Method

[image]
Intersoft WebGrid Documentation
setParent Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSeriesMarkerCollection Class : setParent Method

parent

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub setParent( _
   ByVal parent As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesMarkerCollection
Dim parent As System.Object

instance.setParent(parent)
C#
public virtual void setParent(
   System.object parent
)
Delphi
public procedure setParent(
    parent: System.TObject
); virtual;
JScript
public function setParent(
   parent : System.Object
);
Managed Extensions for C++
public: virtual void setParent(
   System.Object* parent
)
C++/CLI
public:
virtual void setParent(
   System.Object^ parent
)

Parameters

parent

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesMarkerCollection Class
ChartSeriesMarkerCollection Members


Capacity Property

[image]
Intersoft WebGrid Documentation
Capacity Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSeriesMarkerCollection Class : Capacity Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Runtime.InteropServices.ComVisibleAttribute(False)>
Public Property Capacity As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesMarkerCollection
Dim value As System.Integer

instance.Capacity = value

value = instance.Capacity
C#
[System.Runtime.InteropServices.ComVisibleAttribute(false)]
public System.int Capacity {get; set;}
Delphi
public read-write property Capacity: System.Integer;
JScript
System.Runtime.InteropServices.ComVisibleAttribute()
public function get,set Capacity : System.int
Managed Extensions for C++
[System.Runtime.InteropServices.ComVisibleAttribute(false)]
public: __property System.int get_Capacity();
public: __property void set_Capacity(
   System.int value
);
C++/CLI
[System.Runtime.InteropServices.ComVisibleAttribute(false)]
public:
property System.int Capacity {
   System.int get();
   void set (    System.int value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesMarkerCollection Class
ChartSeriesMarkerCollection Members


Count Property

[image]
Intersoft WebGrid Documentation
Count Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSeriesMarkerCollection Class : Count Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Count As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesMarkerCollection
Dim value As System.Integer

value = instance.Count
C#
public System.int Count {get;}
Delphi
public read-only property Count: System.Integer;
JScript
public function get Count : System.int
Managed Extensions for C++
public: __property System.int get_Count();
C++/CLI
public:
property System.int Count {
   System.int get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesMarkerCollection Class
ChartSeriesMarkerCollection Members


ChartSeriesMarkerCollection Class Properties

[image]
Intersoft WebGrid Documentation
ChartSeriesMarkerCollection Class Properties
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartSeriesMarkerCollection Class

Glossary Item Box

For a list of all members of this type, see ChartSeriesMarkerCollection members.

Public Properties

 | Name | Description
Public Property | Capacity | (Inherited from System.Collections.CollectionBase)
Public Property | Count | (Inherited from System.Collections.CollectionBase)
Public Property | IsReadOnly | Overridden.
Public Property | Item |
Public Property | Parent | (Inherited from ISNet.WebUI.ISCollectionBase)
Top

See Also

Reference

ChartSeriesMarkerCollection Class
ISNet.WebUI.WebGrid.Chart Namespace


ChartSeriesMarkerCollection Constructor

[image]
Intersoft WebGrid Documentation
ChartSeriesMarkerCollection Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSeriesMarkerCollection Class : ChartSeriesMarkerCollection Constructor

Glossary Item Box

Overload List

Overload | Description
ChartSeriesMarkerCollection Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesMarkerCollection Class
ChartSeriesMarkerCollection Members


IsReadOnly Property

[image]
Intersoft WebGrid Documentation
IsReadOnly Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSeriesMarkerCollection Class : IsReadOnly Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property IsReadOnly As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesMarkerCollection
Dim value As System.Boolean

value = instance.IsReadOnly
C#
public override System.bool IsReadOnly {get;}
Delphi
public read-only property IsReadOnly: System.Boolean; override;
JScript
public override function get IsReadOnly : System.boolean
Managed Extensions for C++
public: __property System.bool get_IsReadOnly() override;
C++/CLI
public:
property System.bool IsReadOnly {
   System.bool get() override;
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesMarkerCollection Class
ChartSeriesMarkerCollection Members


Item Property

[image]
Intersoft WebGrid Documentation
Item Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSeriesMarkerCollection Class : Item Property

index

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Default Property Item( _
   ByVal index As System.Integer _
) As ChartMarkerStyle
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesMarkerCollection
Dim index As System.Integer
Dim value As ChartMarkerStyle

instance.Item(index) = value

value = instance.Item(index)
C#
public ChartMarkerStyle this[
   System.int index
]; {get; set;}
Delphi
public  this: : ChartMarkerStyle;[
    index: System.Integer
]; read-write
JScript
public  this[
   index : System.int
] get,set : ChartMarkerStyle
Managed Extensions for C++
public: __property ChartMarkerStyle* get_Item   System.int index
;
public: __property void set_Item   System.int index,
   ChartMarkerStyle* value
;
C++/CLI
public:
property ChartMarkerStyle^ default [int] {
   ChartMarkerStyle^ get(System.int index);
   void set (System.int index, ChartMarkerStyle^ value);
}

Parameters

index

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesMarkerCollection Class
ChartSeriesMarkerCollection Members


Parent Property

[image]
Intersoft WebGrid Documentation
Parent Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSeriesMarkerCollection Class : Parent Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Parent As System.Object
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesMarkerCollection
Dim value As System.Object

value = instance.Parent
C#
public System.object Parent {get;}
Delphi
public read-only property Parent: System.TObject;
JScript
public function get Parent : System.Object
Managed Extensions for C++
public: __property System.Object* get_Parent();
C++/CLI
public:
property System.Object^ Parent {
   System.Object^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesMarkerCollection Class
ChartSeriesMarkerCollection Members


ChartSeriesMarkerCollectionSettings Class

[image]
Intersoft WebGrid Documentation
ChartSeriesMarkerCollectionSettings Class
Members See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartSeriesMarkerCollectionSettings Class

Glossary Item Box

Object Model

ChartSeriesMarkerCollectionSettings Class

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.SerializableAttribute()>
Public Class ChartSeriesMarkerCollectionSettings
   Inherits ISNet.WebUI.WebUIBaseClass
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesMarkerCollectionSettings
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public class ChartSeriesMarkerCollectionSettings : ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Delphi
public class ChartSeriesMarkerCollectionSettings = class(ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize)
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.SerializableAttribute()
public class ChartSeriesMarkerCollectionSettings extends ISNet.WebUI.WebUIBaseClass implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public __gc class ChartSeriesMarkerCollectionSettings : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public ref class ChartSeriesMarkerCollectionSettings : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.WebGrid.Chart.ChartSeriesMarkerCollectionSettings

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesMarkerCollectionSettings Members
ISNet.WebUI.WebGrid.Chart Namespace


ChartSeriesMarkerCollectionSettings Class Members

[image]
Intersoft WebGrid Documentation
ChartSeriesMarkerCollectionSettings Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartSeriesMarkerCollectionSettings Class

Glossary Item Box

The following tables list the members exposed by ChartSeriesMarkerCollectionSettings.

Public Constructors

 | Name | Description
Public Constructor | ChartSeriesMarkerCollectionSettings Constructor |
Top

Public Properties

 | Name | Description
Public Property | Collection |
Public Property | UsePredefinedCollection |
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

ChartSeriesMarkerCollectionSettings Class
ISNet.WebUI.WebGrid.Chart Namespace


ChartSeriesMarkerCollectionSettings Constructor

[image]
Intersoft WebGrid Documentation
ChartSeriesMarkerCollectionSettings Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSeriesMarkerCollectionSettings Class : ChartSeriesMarkerCollectionSettings Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New ChartSeriesMarkerCollectionSettings()
C#
public ChartSeriesMarkerCollectionSettings()
Delphi
public ChartSeriesMarkerCollectionSettings();
JScript
public function ChartSeriesMarkerCollectionSettings();
Managed Extensions for C++
public: ChartSeriesMarkerCollectionSettings();
C++/CLI
public:
ChartSeriesMarkerCollectionSettings();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesMarkerCollectionSettings Class
ChartSeriesMarkerCollectionSettings Members


Clone Method

[image]
Intersoft WebGrid Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSeriesMarkerCollectionSettings Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As System.Object
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesMarkerCollectionSettings
Dim value As System.Object

value = instance.Clone()
C#
public virtual System.object Clone()
Delphi
public function Clone(): System.TObject; virtual;
JScript
public function Clone() : System.Object;
Managed Extensions for C++
public: virtual System.Object* Clone();
C++/CLI
public:
virtual System.Object^ Clone();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesMarkerCollectionSettings Class
ChartSeriesMarkerCollectionSettings Members


CopyFrom Method

[image]
Intersoft WebGrid Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSeriesMarkerCollectionSettings Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesMarkerCollectionSettings Class
ChartSeriesMarkerCollectionSettings Members


CopyFrom(Object) Method

[image]
Intersoft WebGrid Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSeriesMarkerCollectionSettings Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesMarkerCollectionSettings
Dim objSource As System.Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   System.object objSource
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesMarkerCollectionSettings Class
ChartSeriesMarkerCollectionSettings Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebGrid Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSeriesMarkerCollectionSettings Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object, _
   ByVal cloneSourceValue As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesMarkerCollectionSettings
Dim objSource As System.Object
Dim cloneSourceValue As System.Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   System.object objSource,
   System.bool cloneSourceValue
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject;
    cloneSourceValue: System.Boolean
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object,
   cloneSourceValue : System.boolean
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource,
   System.bool cloneSourceValue
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource,
   System.bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesMarkerCollectionSettings Class
ChartSeriesMarkerCollectionSettings Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebGrid Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSeriesMarkerCollectionSettings Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesMarkerCollectionSettings
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure DeSerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function DeSerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void DeSerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void DeSerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesMarkerCollectionSettings Class
ChartSeriesMarkerCollectionSettings Members


GetHashCode Method

[image]
Intersoft WebGrid Documentation
GetHashCode Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSeriesMarkerCollectionSettings Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesMarkerCollectionSettings
Dim value As System.Integer

value = instance.GetHashCode()
C#
public virtual System.int GetHashCode()
Delphi
public function GetHashCode(): System.Integer; virtual;
JScript
public function GetHashCode() : System.int;
Managed Extensions for C++
public: virtual System.int GetHashCode();
C++/CLI
public:
virtual System.int GetHashCode();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesMarkerCollectionSettings Class
ChartSeriesMarkerCollectionSettings Members


ChartSeriesMarkerCollectionSettings Class Methods

[image]
Intersoft WebGrid Documentation
ChartSeriesMarkerCollectionSettings Class Methods
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartSeriesMarkerCollectionSettings Class

Glossary Item Box

For a list of all members of this type, see ChartSeriesMarkerCollectionSettings members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

ChartSeriesMarkerCollectionSettings Class
ISNet.WebUI.WebGrid.Chart Namespace


GetObjectData Method

[image]
Intersoft WebGrid Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSeriesMarkerCollectionSettings Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=False,
   UnmanagedCode=False,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=True,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Action=SecurityAction.Demand,
   Unrestricted=False)>
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesMarkerCollectionSettings
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure GetObjectData(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
); override;
JScript
System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=,
   UnmanagedCode=,
   SkipVerification=,
   Execution=,
   ControlThread=,
   ControlEvidence=,
   ControlPolicy=,
   SerializationFormatter=,
   ControlDomainPolicy=,
   ControlPrincipal=,
   ControlAppDomain=,
   RemotingConfiguration=,
   Infrastructure=,
   BindingRedirects=,
   Action=SecurityAction.Demand,
   Unrestricted=)
public override function GetObjectData(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public: void GetObjectData(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
) override
C++/CLI
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public:
void GetObjectData(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
) override

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesMarkerCollectionSettings Class
ChartSeriesMarkerCollectionSettings Members


IsEmpty Method

[image]
Intersoft WebGrid Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSeriesMarkerCollectionSettings Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesMarkerCollectionSettings
Dim value As System.Boolean

value = instance.IsEmpty()
C#
public virtual System.bool IsEmpty()
Delphi
public function IsEmpty(): System.Boolean; virtual;
JScript
public function IsEmpty() : System.boolean;
Managed Extensions for C++
public: virtual System.bool IsEmpty();
C++/CLI
public:
virtual System.bool IsEmpty();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesMarkerCollectionSettings Class
ChartSeriesMarkerCollectionSettings Members


Reset Method

[image]
Intersoft WebGrid Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSeriesMarkerCollectionSettings Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesMarkerCollectionSettings

instance.Reset()
C#
public virtual void Reset()
Delphi
public procedure Reset(); virtual;
JScript
public function Reset();
Managed Extensions for C++
public: virtual void Reset();
C++/CLI
public:
virtual void Reset();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesMarkerCollectionSettings Class
ChartSeriesMarkerCollectionSettings Members


SerializeObjectData Method

[image]
Intersoft WebGrid Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSeriesMarkerCollectionSettings Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesMarkerCollectionSettings
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure SerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function SerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void SerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void SerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesMarkerCollectionSettings Class
ChartSeriesMarkerCollectionSettings Members


ToString Method

[image]
Intersoft WebGrid Documentation
ToString Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSeriesMarkerCollectionSettings Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As System.String
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesMarkerCollectionSettings
Dim value As System.String

value = instance.ToString()
C#
public virtual System.string ToString()
Delphi
public function ToString(): System.String; virtual;
JScript
public function ToString() : System.String;
Managed Extensions for C++
public: virtual System.string* ToString();
C++/CLI
public:
virtual System.String^ ToString();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesMarkerCollectionSettings Class
ChartSeriesMarkerCollectionSettings Members


ChartSeriesMarkerCollectionSettings Class Properties

[image]
Intersoft WebGrid Documentation
ChartSeriesMarkerCollectionSettings Class Properties
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartSeriesMarkerCollectionSettings Class

Glossary Item Box

For a list of all members of this type, see ChartSeriesMarkerCollectionSettings members.

Public Properties

 | Name | Description
Public Property | Collection |
Public Property | UsePredefinedCollection |
Top

See Also

Reference

ChartSeriesMarkerCollectionSettings Class
ISNet.WebUI.WebGrid.Chart Namespace


ChartSeriesMarkerCollectionSettings Constructor

[image]
Intersoft WebGrid Documentation
ChartSeriesMarkerCollectionSettings Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSeriesMarkerCollectionSettings Class : ChartSeriesMarkerCollectionSettings Constructor

Glossary Item Box

Overload List

Overload | Description
ChartSeriesMarkerCollectionSettings Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesMarkerCollectionSettings Class
ChartSeriesMarkerCollectionSettings Members


Collection Property

[image]
Intersoft WebGrid Documentation
Collection Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSeriesMarkerCollectionSettings Class : Collection Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<ISNet.Serialization.BinarySerializableAttribute()>
Public ReadOnly Property Collection As ChartSeriesMarkerCollection
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesMarkerCollectionSettings
Dim value As ChartSeriesMarkerCollection

value = instance.Collection
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[ISNet.Serialization.BinarySerializableAttribute()]
public ChartSeriesMarkerCollection Collection {get;}
Delphi
public read-only property Collection: ChartSeriesMarkerCollection;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
ISNet.Serialization.BinarySerializableAttribute()
public function get Collection : ChartSeriesMarkerCollection
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property ChartSeriesMarkerCollection* get_Collection();
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property ChartSeriesMarkerCollection^ Collection {
   ChartSeriesMarkerCollection^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesMarkerCollectionSettings Class
ChartSeriesMarkerCollectionSettings Members


UsePredefinedCollection Property

[image]
Intersoft WebGrid Documentation
UsePredefinedCollection Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSeriesMarkerCollectionSettings Class : UsePredefinedCollection Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property UsePredefinedCollection As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesMarkerCollectionSettings
Dim value As System.Boolean

instance.UsePredefinedCollection = value

value = instance.UsePredefinedCollection
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public System.bool UsePredefinedCollection {get; set;}
Delphi
public read-write property UsePredefinedCollection: System.Boolean;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get,set UsePredefinedCollection : System.boolean
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.bool get_UsePredefinedCollection();
public: __property void set_UsePredefinedCollection(
   System.bool value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.bool UsePredefinedCollection {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesMarkerCollectionSettings Class
ChartSeriesMarkerCollectionSettings Members


ChartSeriesPieSettings Class

[image]
Intersoft WebGrid Documentation
ChartSeriesPieSettings Class
Members See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartSeriesPieSettings Class

Glossary Item Box

Object Model

ChartSeriesPieSettings Class

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.SerializableAttribute()>
Public Class ChartSeriesPieSettings
   Inherits ISNet.WebUI.WebUIBaseClass
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesPieSettings
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public class ChartSeriesPieSettings : ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Delphi
public class ChartSeriesPieSettings = class(ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize)
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.SerializableAttribute()
public class ChartSeriesPieSettings extends ISNet.WebUI.WebUIBaseClass implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public __gc class ChartSeriesPieSettings : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public ref class ChartSeriesPieSettings : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.WebGrid.Chart.ChartSeriesPieSettings

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesPieSettings Members
ISNet.WebUI.WebGrid.Chart Namespace


ChartSeriesPieSettings Class Members

[image]
Intersoft WebGrid Documentation
ChartSeriesPieSettings Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartSeriesPieSettings Class

Glossary Item Box

The following tables list the members exposed by ChartSeriesPieSettings.

Public Constructors

 | Name | Description
Public Constructor | ChartSeriesPieSettings Constructor |
Top

Public Properties

 | Name | Description
Public Property | Settings |
Public Property | Type |
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

ChartSeriesPieSettings Class
ISNet.WebUI.WebGrid.Chart Namespace


ChartSeriesPieSettings Constructor

[image]
Intersoft WebGrid Documentation
ChartSeriesPieSettings Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSeriesPieSettings Class : ChartSeriesPieSettings Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New ChartSeriesPieSettings()
C#
public ChartSeriesPieSettings()
Delphi
public ChartSeriesPieSettings();
JScript
public function ChartSeriesPieSettings();
Managed Extensions for C++
public: ChartSeriesPieSettings();
C++/CLI
public:
ChartSeriesPieSettings();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesPieSettings Class
ChartSeriesPieSettings Members


Clone Method

[image]
Intersoft WebGrid Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSeriesPieSettings Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As System.Object
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesPieSettings
Dim value As System.Object

value = instance.Clone()
C#
public virtual System.object Clone()
Delphi
public function Clone(): System.TObject; virtual;
JScript
public function Clone() : System.Object;
Managed Extensions for C++
public: virtual System.Object* Clone();
C++/CLI
public:
virtual System.Object^ Clone();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesPieSettings Class
ChartSeriesPieSettings Members


CopyFrom Method

[image]
Intersoft WebGrid Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSeriesPieSettings Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesPieSettings Class
ChartSeriesPieSettings Members


CopyFrom(Object) Method

[image]
Intersoft WebGrid Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSeriesPieSettings Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesPieSettings
Dim objSource As System.Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   System.object objSource
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesPieSettings Class
ChartSeriesPieSettings Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebGrid Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSeriesPieSettings Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object, _
   ByVal cloneSourceValue As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesPieSettings
Dim objSource As System.Object
Dim cloneSourceValue As System.Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   System.object objSource,
   System.bool cloneSourceValue
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject;
    cloneSourceValue: System.Boolean
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object,
   cloneSourceValue : System.boolean
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource,
   System.bool cloneSourceValue
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource,
   System.bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesPieSettings Class
ChartSeriesPieSettings Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebGrid Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSeriesPieSettings Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesPieSettings
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure DeSerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function DeSerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void DeSerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void DeSerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesPieSettings Class
ChartSeriesPieSettings Members


GetHashCode Method

[image]
Intersoft WebGrid Documentation
GetHashCode Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSeriesPieSettings Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesPieSettings
Dim value As System.Integer

value = instance.GetHashCode()
C#
public virtual System.int GetHashCode()
Delphi
public function GetHashCode(): System.Integer; virtual;
JScript
public function GetHashCode() : System.int;
Managed Extensions for C++
public: virtual System.int GetHashCode();
C++/CLI
public:
virtual System.int GetHashCode();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesPieSettings Class
ChartSeriesPieSettings Members


ChartSeriesPieSettings Class Methods

[image]
Intersoft WebGrid Documentation
ChartSeriesPieSettings Class Methods
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartSeriesPieSettings Class

Glossary Item Box

For a list of all members of this type, see ChartSeriesPieSettings members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

ChartSeriesPieSettings Class
ISNet.WebUI.WebGrid.Chart Namespace


GetObjectData Method

[image]
Intersoft WebGrid Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSeriesPieSettings Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=False,
   UnmanagedCode=False,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=True,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Action=SecurityAction.Demand,
   Unrestricted=False)>
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesPieSettings
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure GetObjectData(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
); override;
JScript
System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=,
   UnmanagedCode=,
   SkipVerification=,
   Execution=,
   ControlThread=,
   ControlEvidence=,
   ControlPolicy=,
   SerializationFormatter=,
   ControlDomainPolicy=,
   ControlPrincipal=,
   ControlAppDomain=,
   RemotingConfiguration=,
   Infrastructure=,
   BindingRedirects=,
   Action=SecurityAction.Demand,
   Unrestricted=)
public override function GetObjectData(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public: void GetObjectData(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
) override
C++/CLI
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public:
void GetObjectData(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
) override

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesPieSettings Class
ChartSeriesPieSettings Members


IsEmpty Method

[image]
Intersoft WebGrid Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSeriesPieSettings Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesPieSettings
Dim value As System.Boolean

value = instance.IsEmpty()
C#
public virtual System.bool IsEmpty()
Delphi
public function IsEmpty(): System.Boolean; virtual;
JScript
public function IsEmpty() : System.boolean;
Managed Extensions for C++
public: virtual System.bool IsEmpty();
C++/CLI
public:
virtual System.bool IsEmpty();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesPieSettings Class
ChartSeriesPieSettings Members


Reset Method

[image]
Intersoft WebGrid Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSeriesPieSettings Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesPieSettings

instance.Reset()
C#
public virtual void Reset()
Delphi
public procedure Reset(); virtual;
JScript
public function Reset();
Managed Extensions for C++
public: virtual void Reset();
C++/CLI
public:
virtual void Reset();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesPieSettings Class
ChartSeriesPieSettings Members


SerializeObjectData Method

[image]
Intersoft WebGrid Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSeriesPieSettings Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesPieSettings
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure SerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function SerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void SerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void SerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesPieSettings Class
ChartSeriesPieSettings Members


ToString Method

[image]
Intersoft WebGrid Documentation
ToString Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSeriesPieSettings Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As System.String
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesPieSettings
Dim value As System.String

value = instance.ToString()
C#
public virtual System.string ToString()
Delphi
public function ToString(): System.String; virtual;
JScript
public function ToString() : System.String;
Managed Extensions for C++
public: virtual System.string* ToString();
C++/CLI
public:
virtual System.String^ ToString();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesPieSettings Class
ChartSeriesPieSettings Members


ChartSeriesPieSettings Class Properties

[image]
Intersoft WebGrid Documentation
ChartSeriesPieSettings Class Properties
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartSeriesPieSettings Class

Glossary Item Box

For a list of all members of this type, see ChartSeriesPieSettings members.

Public Properties

 | Name | Description
Public Property | Settings |
Public Property | Type |
Top

See Also

Reference

ChartSeriesPieSettings Class
ISNet.WebUI.WebGrid.Chart Namespace


ChartSeriesPieSettings Constructor

[image]
Intersoft WebGrid Documentation
ChartSeriesPieSettings Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSeriesPieSettings Class : ChartSeriesPieSettings Constructor

Glossary Item Box

Overload List

Overload | Description
ChartSeriesPieSettings Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesPieSettings Class
ChartSeriesPieSettings Members


Settings Property

[image]
Intersoft WebGrid Documentation
Settings Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSeriesPieSettings Class : Settings Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute("setSettings")>
Public ReadOnly Property Settings As SeriesPie
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesPieSettings
Dim value As SeriesPie

value = instance.Settings
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute("setSettings")]
public SeriesPie Settings {get;}
Delphi
public read-only property Settings: SeriesPie;
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute("setSettings")
public function get Settings : SeriesPie
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute("setSettings")]
public: __property SeriesPie* get_Settings();
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute("setSettings")]
public:
property SeriesPie^ Settings {
   SeriesPie^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesPieSettings Class
ChartSeriesPieSettings Members


Type Property

[image]
Intersoft WebGrid Documentation
Type Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSeriesPieSettings Class : Type Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property Type As SeriesPieType
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesPieSettings
Dim value As SeriesPieType

instance.Type = value

value = instance.Type
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public SeriesPieType Type {get; set;}
Delphi
public read-write property Type: SeriesPieType;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get,set Type : SeriesPieType
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property SeriesPieType get_Type();
public: __property void set_Type(
   SeriesPieType value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property SeriesPieType Type {
   SeriesPieType get();
   void set (    SeriesPieType value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesPieSettings Class
ChartSeriesPieSettings Members


ChartSeriesPolarSettings Class

[image]
Intersoft WebGrid Documentation
ChartSeriesPolarSettings Class
Members See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartSeriesPolarSettings Class

Glossary Item Box

Object Model

ChartSeriesPolarSettings Class

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.SerializableAttribute()>
Public Class ChartSeriesPolarSettings
   Inherits ISNet.WebUI.WebUIBaseClass
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesPolarSettings
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public class ChartSeriesPolarSettings : ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Delphi
public class ChartSeriesPolarSettings = class(ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize)
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.SerializableAttribute()
public class ChartSeriesPolarSettings extends ISNet.WebUI.WebUIBaseClass implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public __gc class ChartSeriesPolarSettings : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public ref class ChartSeriesPolarSettings : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.WebGrid.Chart.ChartSeriesPolarSettings

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesPolarSettings Members
ISNet.WebUI.WebGrid.Chart Namespace


ChartSeriesPolarSettings Class Members

[image]
Intersoft WebGrid Documentation
ChartSeriesPolarSettings Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartSeriesPolarSettings Class

Glossary Item Box

The following tables list the members exposed by ChartSeriesPolarSettings.

Public Constructors

 | Name | Description
Public Constructor | ChartSeriesPolarSettings Constructor |
Top

Public Properties

 | Name | Description
Public Property | Settings |
Public Property | Type |
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

ChartSeriesPolarSettings Class
ISNet.WebUI.WebGrid.Chart Namespace


ChartSeriesPolarSettings Constructor

[image]
Intersoft WebGrid Documentation
ChartSeriesPolarSettings Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSeriesPolarSettings Class : ChartSeriesPolarSettings Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New ChartSeriesPolarSettings()
C#
public ChartSeriesPolarSettings()
Delphi
public ChartSeriesPolarSettings();
JScript
public function ChartSeriesPolarSettings();
Managed Extensions for C++
public: ChartSeriesPolarSettings();
C++/CLI
public:
ChartSeriesPolarSettings();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesPolarSettings Class
ChartSeriesPolarSettings Members


Clone Method

[image]
Intersoft WebGrid Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSeriesPolarSettings Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As System.Object
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesPolarSettings
Dim value As System.Object

value = instance.Clone()
C#
public virtual System.object Clone()
Delphi
public function Clone(): System.TObject; virtual;
JScript
public function Clone() : System.Object;
Managed Extensions for C++
public: virtual System.Object* Clone();
C++/CLI
public:
virtual System.Object^ Clone();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesPolarSettings Class
ChartSeriesPolarSettings Members


CopyFrom Method

[image]
Intersoft WebGrid Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSeriesPolarSettings Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesPolarSettings Class
ChartSeriesPolarSettings Members


CopyFrom(Object) Method

[image]
Intersoft WebGrid Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSeriesPolarSettings Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesPolarSettings
Dim objSource As System.Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   System.object objSource
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesPolarSettings Class
ChartSeriesPolarSettings Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebGrid Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSeriesPolarSettings Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object, _
   ByVal cloneSourceValue As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesPolarSettings
Dim objSource As System.Object
Dim cloneSourceValue As System.Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   System.object objSource,
   System.bool cloneSourceValue
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject;
    cloneSourceValue: System.Boolean
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object,
   cloneSourceValue : System.boolean
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource,
   System.bool cloneSourceValue
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource,
   System.bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesPolarSettings Class
ChartSeriesPolarSettings Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebGrid Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSeriesPolarSettings Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesPolarSettings
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure DeSerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function DeSerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void DeSerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void DeSerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesPolarSettings Class
ChartSeriesPolarSettings Members


GetHashCode Method

[image]
Intersoft WebGrid Documentation
GetHashCode Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSeriesPolarSettings Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesPolarSettings
Dim value As System.Integer

value = instance.GetHashCode()
C#
public virtual System.int GetHashCode()
Delphi
public function GetHashCode(): System.Integer; virtual;
JScript
public function GetHashCode() : System.int;
Managed Extensions for C++
public: virtual System.int GetHashCode();
C++/CLI
public:
virtual System.int GetHashCode();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesPolarSettings Class
ChartSeriesPolarSettings Members


ChartSeriesPolarSettings Class Methods

[image]
Intersoft WebGrid Documentation
ChartSeriesPolarSettings Class Methods
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartSeriesPolarSettings Class

Glossary Item Box

For a list of all members of this type, see ChartSeriesPolarSettings members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

ChartSeriesPolarSettings Class
ISNet.WebUI.WebGrid.Chart Namespace


GetObjectData Method

[image]
Intersoft WebGrid Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSeriesPolarSettings Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=False,
   UnmanagedCode=False,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=True,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Action=SecurityAction.Demand,
   Unrestricted=False)>
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesPolarSettings
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure GetObjectData(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
); override;
JScript
System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=,
   UnmanagedCode=,
   SkipVerification=,
   Execution=,
   ControlThread=,
   ControlEvidence=,
   ControlPolicy=,
   SerializationFormatter=,
   ControlDomainPolicy=,
   ControlPrincipal=,
   ControlAppDomain=,
   RemotingConfiguration=,
   Infrastructure=,
   BindingRedirects=,
   Action=SecurityAction.Demand,
   Unrestricted=)
public override function GetObjectData(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public: void GetObjectData(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
) override
C++/CLI
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public:
void GetObjectData(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
) override

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesPolarSettings Class
ChartSeriesPolarSettings Members


IsEmpty Method

[image]
Intersoft WebGrid Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSeriesPolarSettings Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesPolarSettings
Dim value As System.Boolean

value = instance.IsEmpty()
C#
public virtual System.bool IsEmpty()
Delphi
public function IsEmpty(): System.Boolean; virtual;
JScript
public function IsEmpty() : System.boolean;
Managed Extensions for C++
public: virtual System.bool IsEmpty();
C++/CLI
public:
virtual System.bool IsEmpty();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesPolarSettings Class
ChartSeriesPolarSettings Members


Reset Method

[image]
Intersoft WebGrid Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSeriesPolarSettings Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesPolarSettings

instance.Reset()
C#
public virtual void Reset()
Delphi
public procedure Reset(); virtual;
JScript
public function Reset();
Managed Extensions for C++
public: virtual void Reset();
C++/CLI
public:
virtual void Reset();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesPolarSettings Class
ChartSeriesPolarSettings Members


SerializeObjectData Method

[image]
Intersoft WebGrid Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSeriesPolarSettings Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesPolarSettings
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure SerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function SerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void SerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void SerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesPolarSettings Class
ChartSeriesPolarSettings Members


ToString Method

[image]
Intersoft WebGrid Documentation
ToString Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSeriesPolarSettings Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As System.String
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesPolarSettings
Dim value As System.String

value = instance.ToString()
C#
public virtual System.string ToString()
Delphi
public function ToString(): System.String; virtual;
JScript
public function ToString() : System.String;
Managed Extensions for C++
public: virtual System.string* ToString();
C++/CLI
public:
virtual System.String^ ToString();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesPolarSettings Class
ChartSeriesPolarSettings Members


ChartSeriesPolarSettings Class Properties

[image]
Intersoft WebGrid Documentation
ChartSeriesPolarSettings Class Properties
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartSeriesPolarSettings Class

Glossary Item Box

For a list of all members of this type, see ChartSeriesPolarSettings members.

Public Properties

 | Name | Description
Public Property | Settings |
Public Property | Type |
Top

See Also

Reference

ChartSeriesPolarSettings Class
ISNet.WebUI.WebGrid.Chart Namespace


ChartSeriesPolarSettings Constructor

[image]
Intersoft WebGrid Documentation
ChartSeriesPolarSettings Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSeriesPolarSettings Class : ChartSeriesPolarSettings Constructor

Glossary Item Box

Overload List

Overload | Description
ChartSeriesPolarSettings Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesPolarSettings Class
ChartSeriesPolarSettings Members


Settings Property

[image]
Intersoft WebGrid Documentation
Settings Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSeriesPolarSettings Class : Settings Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<System.ComponentModel.DefaultValueAttribute()>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<ISNet.Serialization.BinarySerializableAttribute("setSettings")>
Public ReadOnly Property Settings As SeriesPolar
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesPolarSettings
Dim value As SeriesPolar

value = instance.Settings
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DefaultValueAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[ISNet.Serialization.BinarySerializableAttribute("setSettings")]
public SeriesPolar Settings {get;}
Delphi
public read-only property Settings: SeriesPolar;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
System.ComponentModel.DefaultValueAttribute()
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
ISNet.Serialization.BinarySerializableAttribute("setSettings")
public function get Settings : SeriesPolar
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DefaultValueAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[ISNet.Serialization.BinarySerializableAttribute("setSettings")]
public: __property SeriesPolar* get_Settings();
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DefaultValueAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[ISNet.Serialization.BinarySerializableAttribute("setSettings")]
public:
property SeriesPolar^ Settings {
   SeriesPolar^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesPolarSettings Class
ChartSeriesPolarSettings Members


Type Property

[image]
Intersoft WebGrid Documentation
Type Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSeriesPolarSettings Class : Type Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Property Type As SeriesPolarType
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesPolarSettings
Dim value As SeriesPolarType

instance.Type = value

value = instance.Type
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public SeriesPolarType Type {get; set;}
Delphi
public read-write property Type: SeriesPolarType;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute()
public function get,set Type : SeriesPolarType
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property SeriesPolarType get_Type();
public: __property void set_Type(
   SeriesPolarType value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property SeriesPolarType Type {
   SeriesPolarType get();
   void set (    SeriesPolarType value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesPolarSettings Class
ChartSeriesPolarSettings Members


ChartSeriesRadarSettings Class

[image]
Intersoft WebGrid Documentation
ChartSeriesRadarSettings Class
Members See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartSeriesRadarSettings Class

Glossary Item Box

Object Model

ChartSeriesRadarSettings Class

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.SerializableAttribute()>
Public Class ChartSeriesRadarSettings
   Inherits ISNet.WebUI.WebUIBaseClass
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesRadarSettings
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public class ChartSeriesRadarSettings : ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Delphi
public class ChartSeriesRadarSettings = class(ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize)
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.SerializableAttribute()
public class ChartSeriesRadarSettings extends ISNet.WebUI.WebUIBaseClass implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public __gc class ChartSeriesRadarSettings : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public ref class ChartSeriesRadarSettings : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.WebGrid.Chart.ChartSeriesRadarSettings

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesRadarSettings Members
ISNet.WebUI.WebGrid.Chart Namespace


ChartSeriesRadarSettings Class Members

[image]
Intersoft WebGrid Documentation
ChartSeriesRadarSettings Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartSeriesRadarSettings Class

Glossary Item Box

The following tables list the members exposed by ChartSeriesRadarSettings.

Public Constructors

 | Name | Description
Public Constructor | ChartSeriesRadarSettings Constructor |
Top

Public Properties

 | Name | Description
Public Property | Settings |
Public Property | Type |
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

ChartSeriesRadarSettings Class
ISNet.WebUI.WebGrid.Chart Namespace


ChartSeriesRadarSettings Constructor

[image]
Intersoft WebGrid Documentation
ChartSeriesRadarSettings Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSeriesRadarSettings Class : ChartSeriesRadarSettings Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New ChartSeriesRadarSettings()
C#
public ChartSeriesRadarSettings()
Delphi
public ChartSeriesRadarSettings();
JScript
public function ChartSeriesRadarSettings();
Managed Extensions for C++
public: ChartSeriesRadarSettings();
C++/CLI
public:
ChartSeriesRadarSettings();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesRadarSettings Class
ChartSeriesRadarSettings Members


Clone Method

[image]
Intersoft WebGrid Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSeriesRadarSettings Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As System.Object
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesRadarSettings
Dim value As System.Object

value = instance.Clone()
C#
public virtual System.object Clone()
Delphi
public function Clone(): System.TObject; virtual;
JScript
public function Clone() : System.Object;
Managed Extensions for C++
public: virtual System.Object* Clone();
C++/CLI
public:
virtual System.Object^ Clone();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesRadarSettings Class
ChartSeriesRadarSettings Members


CopyFrom Method

[image]
Intersoft WebGrid Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSeriesRadarSettings Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesRadarSettings Class
ChartSeriesRadarSettings Members


CopyFrom(Object) Method

[image]
Intersoft WebGrid Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSeriesRadarSettings Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesRadarSettings
Dim objSource As System.Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   System.object objSource
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesRadarSettings Class
ChartSeriesRadarSettings Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebGrid Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSeriesRadarSettings Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object, _
   ByVal cloneSourceValue As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesRadarSettings
Dim objSource As System.Object
Dim cloneSourceValue As System.Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   System.object objSource,
   System.bool cloneSourceValue
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject;
    cloneSourceValue: System.Boolean
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object,
   cloneSourceValue : System.boolean
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource,
   System.bool cloneSourceValue
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource,
   System.bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesRadarSettings Class
ChartSeriesRadarSettings Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebGrid Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSeriesRadarSettings Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesRadarSettings
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure DeSerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function DeSerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void DeSerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void DeSerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesRadarSettings Class
ChartSeriesRadarSettings Members


GetHashCode Method

[image]
Intersoft WebGrid Documentation
GetHashCode Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSeriesRadarSettings Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesRadarSettings
Dim value As System.Integer

value = instance.GetHashCode()
C#
public virtual System.int GetHashCode()
Delphi
public function GetHashCode(): System.Integer; virtual;
JScript
public function GetHashCode() : System.int;
Managed Extensions for C++
public: virtual System.int GetHashCode();
C++/CLI
public:
virtual System.int GetHashCode();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesRadarSettings Class
ChartSeriesRadarSettings Members


ChartSeriesRadarSettings Class Methods

[image]
Intersoft WebGrid Documentation
ChartSeriesRadarSettings Class Methods
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartSeriesRadarSettings Class

Glossary Item Box

For a list of all members of this type, see ChartSeriesRadarSettings members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

ChartSeriesRadarSettings Class
ISNet.WebUI.WebGrid.Chart Namespace


GetObjectData Method

[image]
Intersoft WebGrid Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSeriesRadarSettings Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=False,
   UnmanagedCode=False,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=True,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Action=SecurityAction.Demand,
   Unrestricted=False)>
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesRadarSettings
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure GetObjectData(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
); override;
JScript
System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=,
   UnmanagedCode=,
   SkipVerification=,
   Execution=,
   ControlThread=,
   ControlEvidence=,
   ControlPolicy=,
   SerializationFormatter=,
   ControlDomainPolicy=,
   ControlPrincipal=,
   ControlAppDomain=,
   RemotingConfiguration=,
   Infrastructure=,
   BindingRedirects=,
   Action=SecurityAction.Demand,
   Unrestricted=)
public override function GetObjectData(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public: void GetObjectData(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
) override
C++/CLI
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public:
void GetObjectData(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
) override

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesRadarSettings Class
ChartSeriesRadarSettings Members


IsEmpty Method

[image]
Intersoft WebGrid Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSeriesRadarSettings Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesRadarSettings
Dim value As System.Boolean

value = instance.IsEmpty()
C#
public virtual System.bool IsEmpty()
Delphi
public function IsEmpty(): System.Boolean; virtual;
JScript
public function IsEmpty() : System.boolean;
Managed Extensions for C++
public: virtual System.bool IsEmpty();
C++/CLI
public:
virtual System.bool IsEmpty();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesRadarSettings Class
ChartSeriesRadarSettings Members


Reset Method

[image]
Intersoft WebGrid Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSeriesRadarSettings Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesRadarSettings

instance.Reset()
C#
public virtual void Reset()
Delphi
public procedure Reset(); virtual;
JScript
public function Reset();
Managed Extensions for C++
public: virtual void Reset();
C++/CLI
public:
virtual void Reset();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesRadarSettings Class
ChartSeriesRadarSettings Members


SerializeObjectData Method

[image]
Intersoft WebGrid Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSeriesRadarSettings Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesRadarSettings
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure SerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function SerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void SerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void SerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesRadarSettings Class
ChartSeriesRadarSettings Members


ToString Method

[image]
Intersoft WebGrid Documentation
ToString Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSeriesRadarSettings Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As System.String
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesRadarSettings
Dim value As System.String

value = instance.ToString()
C#
public virtual System.string ToString()
Delphi
public function ToString(): System.String; virtual;
JScript
public function ToString() : System.String;
Managed Extensions for C++
public: virtual System.string* ToString();
C++/CLI
public:
virtual System.String^ ToString();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesRadarSettings Class
ChartSeriesRadarSettings Members


ChartSeriesRadarSettings Class Properties

[image]
Intersoft WebGrid Documentation
ChartSeriesRadarSettings Class Properties
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartSeriesRadarSettings Class

Glossary Item Box

For a list of all members of this type, see ChartSeriesRadarSettings members.

Public Properties

 | Name | Description
Public Property | Settings |
Public Property | Type |
Top

See Also

Reference

ChartSeriesRadarSettings Class
ISNet.WebUI.WebGrid.Chart Namespace


ChartSeriesRadarSettings Constructor

[image]
Intersoft WebGrid Documentation
ChartSeriesRadarSettings Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSeriesRadarSettings Class : ChartSeriesRadarSettings Constructor

Glossary Item Box

Overload List

Overload | Description
ChartSeriesRadarSettings Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesRadarSettings Class
ChartSeriesRadarSettings Members


Settings Property

[image]
Intersoft WebGrid Documentation
Settings Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSeriesRadarSettings Class : Settings Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute("setSettings")>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<System.ComponentModel.DefaultValueAttribute()>
Public ReadOnly Property Settings As SeriesRadar
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesRadarSettings
Dim value As SeriesRadar

value = instance.Settings
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute("setSettings")]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DefaultValueAttribute()]
public SeriesRadar Settings {get;}
Delphi
public read-only property Settings: SeriesRadar;
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute("setSettings")
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
System.ComponentModel.DefaultValueAttribute()
public function get Settings : SeriesRadar
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute("setSettings")]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property SeriesRadar* get_Settings();
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute("setSettings")]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property SeriesRadar^ Settings {
   SeriesRadar^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesRadarSettings Class
ChartSeriesRadarSettings Members


Type Property

[image]
Intersoft WebGrid Documentation
Type Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSeriesRadarSettings Class : Type Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
Public Property Type As SeriesRadarType
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesRadarSettings
Dim value As SeriesRadarType

instance.Type = value

value = instance.Type
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public SeriesRadarType Type {get; set;}
Delphi
public read-write property Type: SeriesRadarType;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
public function get,set Type : SeriesRadarType
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public: __property SeriesRadarType get_Type();
public: __property void set_Type(
   SeriesRadarType value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public:
property SeriesRadarType Type {
   SeriesRadarType get();
   void set (    SeriesRadarType value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesRadarSettings Class
ChartSeriesRadarSettings Members


ChartSeriesSmoothLineSettings Class

[image]
Intersoft WebGrid Documentation
ChartSeriesSmoothLineSettings Class
Members See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartSeriesSmoothLineSettings Class

Glossary Item Box

Object Model

ChartSeriesSmoothLineSettings Class

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.SerializableAttribute()>
Public Class ChartSeriesSmoothLineSettings
   Inherits ISNet.WebUI.WebUIBaseClass
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesSmoothLineSettings
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public class ChartSeriesSmoothLineSettings : ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Delphi
public class ChartSeriesSmoothLineSettings = class(ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize)
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.SerializableAttribute()
public class ChartSeriesSmoothLineSettings extends ISNet.WebUI.WebUIBaseClass implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public __gc class ChartSeriesSmoothLineSettings : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public ref class ChartSeriesSmoothLineSettings : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.WebGrid.Chart.ChartSeriesSmoothLineSettings

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesSmoothLineSettings Members
ISNet.WebUI.WebGrid.Chart Namespace


ChartSeriesSmoothLineSettings Class Members

[image]
Intersoft WebGrid Documentation
ChartSeriesSmoothLineSettings Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartSeriesSmoothLineSettings Class

Glossary Item Box

The following tables list the members exposed by ChartSeriesSmoothLineSettings.

Public Constructors

 | Name | Description
Public Constructor | ChartSeriesSmoothLineSettings Constructor |
Top

Public Properties

 | Name | Description
Public Property | Settings |
Public Property | Type |
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

ChartSeriesSmoothLineSettings Class
ISNet.WebUI.WebGrid.Chart Namespace


ChartSeriesSmoothLineSettings Constructor

[image]
Intersoft WebGrid Documentation
ChartSeriesSmoothLineSettings Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSeriesSmoothLineSettings Class : ChartSeriesSmoothLineSettings Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New ChartSeriesSmoothLineSettings()
C#
public ChartSeriesSmoothLineSettings()
Delphi
public ChartSeriesSmoothLineSettings();
JScript
public function ChartSeriesSmoothLineSettings();
Managed Extensions for C++
public: ChartSeriesSmoothLineSettings();
C++/CLI
public:
ChartSeriesSmoothLineSettings();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesSmoothLineSettings Class
ChartSeriesSmoothLineSettings Members


Clone Method

[image]
Intersoft WebGrid Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSeriesSmoothLineSettings Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As System.Object
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesSmoothLineSettings
Dim value As System.Object

value = instance.Clone()
C#
public virtual System.object Clone()
Delphi
public function Clone(): System.TObject; virtual;
JScript
public function Clone() : System.Object;
Managed Extensions for C++
public: virtual System.Object* Clone();
C++/CLI
public:
virtual System.Object^ Clone();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesSmoothLineSettings Class
ChartSeriesSmoothLineSettings Members


CopyFrom Method

[image]
Intersoft WebGrid Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSeriesSmoothLineSettings Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesSmoothLineSettings Class
ChartSeriesSmoothLineSettings Members


CopyFrom(Object) Method

[image]
Intersoft WebGrid Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSeriesSmoothLineSettings Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesSmoothLineSettings
Dim objSource As System.Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   System.object objSource
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesSmoothLineSettings Class
ChartSeriesSmoothLineSettings Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebGrid Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSeriesSmoothLineSettings Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object, _
   ByVal cloneSourceValue As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesSmoothLineSettings
Dim objSource As System.Object
Dim cloneSourceValue As System.Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   System.object objSource,
   System.bool cloneSourceValue
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject;
    cloneSourceValue: System.Boolean
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object,
   cloneSourceValue : System.boolean
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource,
   System.bool cloneSourceValue
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource,
   System.bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesSmoothLineSettings Class
ChartSeriesSmoothLineSettings Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebGrid Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSeriesSmoothLineSettings Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesSmoothLineSettings
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure DeSerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function DeSerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void DeSerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void DeSerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesSmoothLineSettings Class
ChartSeriesSmoothLineSettings Members


GetHashCode Method

[image]
Intersoft WebGrid Documentation
GetHashCode Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSeriesSmoothLineSettings Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesSmoothLineSettings
Dim value As System.Integer

value = instance.GetHashCode()
C#
public virtual System.int GetHashCode()
Delphi
public function GetHashCode(): System.Integer; virtual;
JScript
public function GetHashCode() : System.int;
Managed Extensions for C++
public: virtual System.int GetHashCode();
C++/CLI
public:
virtual System.int GetHashCode();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesSmoothLineSettings Class
ChartSeriesSmoothLineSettings Members


ChartSeriesSmoothLineSettings Class Methods

[image]
Intersoft WebGrid Documentation
ChartSeriesSmoothLineSettings Class Methods
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartSeriesSmoothLineSettings Class

Glossary Item Box

For a list of all members of this type, see ChartSeriesSmoothLineSettings members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

ChartSeriesSmoothLineSettings Class
ISNet.WebUI.WebGrid.Chart Namespace


GetObjectData Method

[image]
Intersoft WebGrid Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSeriesSmoothLineSettings Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=False,
   UnmanagedCode=False,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=True,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Action=SecurityAction.Demand,
   Unrestricted=False)>
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesSmoothLineSettings
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure GetObjectData(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
); override;
JScript
System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=,
   UnmanagedCode=,
   SkipVerification=,
   Execution=,
   ControlThread=,
   ControlEvidence=,
   ControlPolicy=,
   SerializationFormatter=,
   ControlDomainPolicy=,
   ControlPrincipal=,
   ControlAppDomain=,
   RemotingConfiguration=,
   Infrastructure=,
   BindingRedirects=,
   Action=SecurityAction.Demand,
   Unrestricted=)
public override function GetObjectData(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public: void GetObjectData(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
) override
C++/CLI
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public:
void GetObjectData(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
) override

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesSmoothLineSettings Class
ChartSeriesSmoothLineSettings Members


IsEmpty Method

[image]
Intersoft WebGrid Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSeriesSmoothLineSettings Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesSmoothLineSettings
Dim value As System.Boolean

value = instance.IsEmpty()
C#
public virtual System.bool IsEmpty()
Delphi
public function IsEmpty(): System.Boolean; virtual;
JScript
public function IsEmpty() : System.boolean;
Managed Extensions for C++
public: virtual System.bool IsEmpty();
C++/CLI
public:
virtual System.bool IsEmpty();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesSmoothLineSettings Class
ChartSeriesSmoothLineSettings Members


Reset Method

[image]
Intersoft WebGrid Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSeriesSmoothLineSettings Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesSmoothLineSettings

instance.Reset()
C#
public virtual void Reset()
Delphi
public procedure Reset(); virtual;
JScript
public function Reset();
Managed Extensions for C++
public: virtual void Reset();
C++/CLI
public:
virtual void Reset();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesSmoothLineSettings Class
ChartSeriesSmoothLineSettings Members


SerializeObjectData Method

[image]
Intersoft WebGrid Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSeriesSmoothLineSettings Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesSmoothLineSettings
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure SerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function SerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void SerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void SerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesSmoothLineSettings Class
ChartSeriesSmoothLineSettings Members


ToString Method

[image]
Intersoft WebGrid Documentation
ToString Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSeriesSmoothLineSettings Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As System.String
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesSmoothLineSettings
Dim value As System.String

value = instance.ToString()
C#
public virtual System.string ToString()
Delphi
public function ToString(): System.String; virtual;
JScript
public function ToString() : System.String;
Managed Extensions for C++
public: virtual System.string* ToString();
C++/CLI
public:
virtual System.String^ ToString();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesSmoothLineSettings Class
ChartSeriesSmoothLineSettings Members


ChartSeriesSmoothLineSettings Class Properties

[image]
Intersoft WebGrid Documentation
ChartSeriesSmoothLineSettings Class Properties
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartSeriesSmoothLineSettings Class

Glossary Item Box

For a list of all members of this type, see ChartSeriesSmoothLineSettings members.

Public Properties

 | Name | Description
Public Property | Settings |
Public Property | Type |
Top

See Also

Reference

ChartSeriesSmoothLineSettings Class
ISNet.WebUI.WebGrid.Chart Namespace


ChartSeriesSmoothLineSettings Constructor

[image]
Intersoft WebGrid Documentation
ChartSeriesSmoothLineSettings Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSeriesSmoothLineSettings Class : ChartSeriesSmoothLineSettings Constructor

Glossary Item Box

Overload List

Overload | Description
ChartSeriesSmoothLineSettings Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesSmoothLineSettings Class
ChartSeriesSmoothLineSettings Members


Settings Property

[image]
Intersoft WebGrid Documentation
Settings Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSeriesSmoothLineSettings Class : Settings Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute("setSettings")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<System.ComponentModel.DefaultValueAttribute()>
Public ReadOnly Property Settings As SeriesSmoothLine
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesSmoothLineSettings
Dim value As SeriesSmoothLine

value = instance.Settings
C#
[ISNet.Serialization.BinarySerializableAttribute("setSettings")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DefaultValueAttribute()]
public SeriesSmoothLine Settings {get;}
Delphi
public read-only property Settings: SeriesSmoothLine;
JScript
ISNet.Serialization.BinarySerializableAttribute("setSettings")
System.ComponentModel.NotifyParentPropertyAttribute()
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
System.ComponentModel.DefaultValueAttribute()
public function get Settings : SeriesSmoothLine
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute("setSettings")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property SeriesSmoothLine* get_Settings();
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute("setSettings")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property SeriesSmoothLine^ Settings {
   SeriesSmoothLine^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesSmoothLineSettings Class
ChartSeriesSmoothLineSettings Members


Type Property

[image]
Intersoft WebGrid Documentation
Type Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSeriesSmoothLineSettings Class : Type Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Property Type As SeriesSmoothLineType
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesSmoothLineSettings
Dim value As SeriesSmoothLineType

instance.Type = value

value = instance.Type
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public SeriesSmoothLineType Type {get; set;}
Delphi
public read-write property Type: SeriesSmoothLineType;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute()
public function get,set Type : SeriesSmoothLineType
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property SeriesSmoothLineType get_Type();
public: __property void set_Type(
   SeriesSmoothLineType value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property SeriesSmoothLineType Type {
   SeriesSmoothLineType get();
   void set (    SeriesSmoothLineType value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesSmoothLineSettings Class
ChartSeriesSmoothLineSettings Members


ChartSeriesStepLineSettings Class

[image]
Intersoft WebGrid Documentation
ChartSeriesStepLineSettings Class
Members See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartSeriesStepLineSettings Class

Glossary Item Box

Object Model

ChartSeriesStepLineSettings Class

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.SerializableAttribute()>
Public Class ChartSeriesStepLineSettings
   Inherits ISNet.WebUI.WebUIBaseClass
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesStepLineSettings
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public class ChartSeriesStepLineSettings : ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Delphi
public class ChartSeriesStepLineSettings = class(ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize)
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.SerializableAttribute()
public class ChartSeriesStepLineSettings extends ISNet.WebUI.WebUIBaseClass implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public __gc class ChartSeriesStepLineSettings : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public ref class ChartSeriesStepLineSettings : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.WebGrid.Chart.ChartSeriesStepLineSettings

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesStepLineSettings Members
ISNet.WebUI.WebGrid.Chart Namespace


ChartSeriesStepLineSettings Class Members

[image]
Intersoft WebGrid Documentation
ChartSeriesStepLineSettings Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartSeriesStepLineSettings Class

Glossary Item Box

The following tables list the members exposed by ChartSeriesStepLineSettings.

Public Constructors

 | Name | Description
Public Constructor | ChartSeriesStepLineSettings Constructor |
Top

Public Properties

 | Name | Description
Public Property | Settings |
Public Property | Type |
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

ChartSeriesStepLineSettings Class
ISNet.WebUI.WebGrid.Chart Namespace


ChartSeriesStepLineSettings Constructor

[image]
Intersoft WebGrid Documentation
ChartSeriesStepLineSettings Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSeriesStepLineSettings Class : ChartSeriesStepLineSettings Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New ChartSeriesStepLineSettings()
C#
public ChartSeriesStepLineSettings()
Delphi
public ChartSeriesStepLineSettings();
JScript
public function ChartSeriesStepLineSettings();
Managed Extensions for C++
public: ChartSeriesStepLineSettings();
C++/CLI
public:
ChartSeriesStepLineSettings();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesStepLineSettings Class
ChartSeriesStepLineSettings Members


Clone Method

[image]
Intersoft WebGrid Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSeriesStepLineSettings Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As System.Object
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesStepLineSettings
Dim value As System.Object

value = instance.Clone()
C#
public virtual System.object Clone()
Delphi
public function Clone(): System.TObject; virtual;
JScript
public function Clone() : System.Object;
Managed Extensions for C++
public: virtual System.Object* Clone();
C++/CLI
public:
virtual System.Object^ Clone();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesStepLineSettings Class
ChartSeriesStepLineSettings Members


CopyFrom Method

[image]
Intersoft WebGrid Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSeriesStepLineSettings Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesStepLineSettings Class
ChartSeriesStepLineSettings Members


CopyFrom(Object) Method

[image]
Intersoft WebGrid Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSeriesStepLineSettings Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesStepLineSettings
Dim objSource As System.Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   System.object objSource
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesStepLineSettings Class
ChartSeriesStepLineSettings Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebGrid Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSeriesStepLineSettings Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object, _
   ByVal cloneSourceValue As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesStepLineSettings
Dim objSource As System.Object
Dim cloneSourceValue As System.Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   System.object objSource,
   System.bool cloneSourceValue
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject;
    cloneSourceValue: System.Boolean
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object,
   cloneSourceValue : System.boolean
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource,
   System.bool cloneSourceValue
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource,
   System.bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesStepLineSettings Class
ChartSeriesStepLineSettings Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebGrid Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSeriesStepLineSettings Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesStepLineSettings
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure DeSerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function DeSerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void DeSerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void DeSerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesStepLineSettings Class
ChartSeriesStepLineSettings Members


GetHashCode Method

[image]
Intersoft WebGrid Documentation
GetHashCode Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSeriesStepLineSettings Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesStepLineSettings
Dim value As System.Integer

value = instance.GetHashCode()
C#
public virtual System.int GetHashCode()
Delphi
public function GetHashCode(): System.Integer; virtual;
JScript
public function GetHashCode() : System.int;
Managed Extensions for C++
public: virtual System.int GetHashCode();
C++/CLI
public:
virtual System.int GetHashCode();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesStepLineSettings Class
ChartSeriesStepLineSettings Members


ChartSeriesStepLineSettings Class Methods

[image]
Intersoft WebGrid Documentation
ChartSeriesStepLineSettings Class Methods
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartSeriesStepLineSettings Class

Glossary Item Box

For a list of all members of this type, see ChartSeriesStepLineSettings members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

ChartSeriesStepLineSettings Class
ISNet.WebUI.WebGrid.Chart Namespace


GetObjectData Method

[image]
Intersoft WebGrid Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSeriesStepLineSettings Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=False,
   UnmanagedCode=False,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=True,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Action=SecurityAction.Demand,
   Unrestricted=False)>
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesStepLineSettings
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure GetObjectData(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
); override;
JScript
System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=,
   UnmanagedCode=,
   SkipVerification=,
   Execution=,
   ControlThread=,
   ControlEvidence=,
   ControlPolicy=,
   SerializationFormatter=,
   ControlDomainPolicy=,
   ControlPrincipal=,
   ControlAppDomain=,
   RemotingConfiguration=,
   Infrastructure=,
   BindingRedirects=,
   Action=SecurityAction.Demand,
   Unrestricted=)
public override function GetObjectData(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public: void GetObjectData(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
) override
C++/CLI
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public:
void GetObjectData(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
) override

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesStepLineSettings Class
ChartSeriesStepLineSettings Members


IsEmpty Method

[image]
Intersoft WebGrid Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSeriesStepLineSettings Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesStepLineSettings
Dim value As System.Boolean

value = instance.IsEmpty()
C#
public virtual System.bool IsEmpty()
Delphi
public function IsEmpty(): System.Boolean; virtual;
JScript
public function IsEmpty() : System.boolean;
Managed Extensions for C++
public: virtual System.bool IsEmpty();
C++/CLI
public:
virtual System.bool IsEmpty();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesStepLineSettings Class
ChartSeriesStepLineSettings Members


Reset Method

[image]
Intersoft WebGrid Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSeriesStepLineSettings Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesStepLineSettings

instance.Reset()
C#
public virtual void Reset()
Delphi
public procedure Reset(); virtual;
JScript
public function Reset();
Managed Extensions for C++
public: virtual void Reset();
C++/CLI
public:
virtual void Reset();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesStepLineSettings Class
ChartSeriesStepLineSettings Members


SerializeObjectData Method

[image]
Intersoft WebGrid Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSeriesStepLineSettings Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesStepLineSettings
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure SerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function SerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void SerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void SerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesStepLineSettings Class
ChartSeriesStepLineSettings Members


ToString Method

[image]
Intersoft WebGrid Documentation
ToString Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSeriesStepLineSettings Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As System.String
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesStepLineSettings
Dim value As System.String

value = instance.ToString()
C#
public virtual System.string ToString()
Delphi
public function ToString(): System.String; virtual;
JScript
public function ToString() : System.String;
Managed Extensions for C++
public: virtual System.string* ToString();
C++/CLI
public:
virtual System.String^ ToString();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesStepLineSettings Class
ChartSeriesStepLineSettings Members


ChartSeriesStepLineSettings Class Properties

[image]
Intersoft WebGrid Documentation
ChartSeriesStepLineSettings Class Properties
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartSeriesStepLineSettings Class

Glossary Item Box

For a list of all members of this type, see ChartSeriesStepLineSettings members.

Public Properties

 | Name | Description
Public Property | Settings |
Public Property | Type |
Top

See Also

Reference

ChartSeriesStepLineSettings Class
ISNet.WebUI.WebGrid.Chart Namespace


ChartSeriesStepLineSettings Constructor

[image]
Intersoft WebGrid Documentation
ChartSeriesStepLineSettings Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSeriesStepLineSettings Class : ChartSeriesStepLineSettings Constructor

Glossary Item Box

Overload List

Overload | Description
ChartSeriesStepLineSettings Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesStepLineSettings Class
ChartSeriesStepLineSettings Members


Settings Property

[image]
Intersoft WebGrid Documentation
Settings Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSeriesStepLineSettings Class : Settings Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute("setSettings")>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public ReadOnly Property Settings As SeriesStepLine
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesStepLineSettings
Dim value As SeriesStepLine

value = instance.Settings
C#
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute("setSettings")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public SeriesStepLine Settings {get;}
Delphi
public read-only property Settings: SeriesStepLine;
JScript
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute("setSettings")
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.NotifyParentPropertyAttribute()
public function get Settings : SeriesStepLine
Managed Extensions for C++
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute("setSettings")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property SeriesStepLine* get_Settings();
C++/CLI
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute("setSettings")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property SeriesStepLine^ Settings {
   SeriesStepLine^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesStepLineSettings Class
ChartSeriesStepLineSettings Members


Type Property

[image]
Intersoft WebGrid Documentation
Type Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSeriesStepLineSettings Class : Type Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
Public Property Type As SeriesStepLineType
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesStepLineSettings
Dim value As SeriesStepLineType

instance.Type = value

value = instance.Type
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public SeriesStepLineType Type {get; set;}
Delphi
public read-write property Type: SeriesStepLineType;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
public function get,set Type : SeriesStepLineType
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public: __property SeriesStepLineType get_Type();
public: __property void set_Type(
   SeriesStepLineType value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public:
property SeriesStepLineType Type {
   SeriesStepLineType get();
   void set (    SeriesStepLineType value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesStepLineSettings Class
ChartSeriesStepLineSettings Members


ChartSeriesStockSettings Class

[image]
Intersoft WebGrid Documentation
ChartSeriesStockSettings Class
Members See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartSeriesStockSettings Class

Glossary Item Box

Object Model

ChartSeriesStockSettings Class

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.SerializableAttribute()>
Public Class ChartSeriesStockSettings
   Inherits ISNet.WebUI.WebUIBaseClass
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesStockSettings
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public class ChartSeriesStockSettings : ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Delphi
public class ChartSeriesStockSettings = class(ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize)
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.SerializableAttribute()
public class ChartSeriesStockSettings extends ISNet.WebUI.WebUIBaseClass implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public __gc class ChartSeriesStockSettings : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public ref class ChartSeriesStockSettings : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.WebGrid.Chart.ChartSeriesStockSettings

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesStockSettings Members
ISNet.WebUI.WebGrid.Chart Namespace


ChartSeriesStockSettings Class Members

[image]
Intersoft WebGrid Documentation
ChartSeriesStockSettings Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartSeriesStockSettings Class

Glossary Item Box

The following tables list the members exposed by ChartSeriesStockSettings.

Public Constructors

 | Name | Description
Public Constructor | ChartSeriesStockSettings Constructor |
Top

Public Properties

 | Name | Description
Public Property | Settings |
Public Property | Type |
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

ChartSeriesStockSettings Class
ISNet.WebUI.WebGrid.Chart Namespace


ChartSeriesStockSettings Constructor

[image]
Intersoft WebGrid Documentation
ChartSeriesStockSettings Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSeriesStockSettings Class : ChartSeriesStockSettings Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New ChartSeriesStockSettings()
C#
public ChartSeriesStockSettings()
Delphi
public ChartSeriesStockSettings();
JScript
public function ChartSeriesStockSettings();
Managed Extensions for C++
public: ChartSeriesStockSettings();
C++/CLI
public:
ChartSeriesStockSettings();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesStockSettings Class
ChartSeriesStockSettings Members


Clone Method

[image]
Intersoft WebGrid Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSeriesStockSettings Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As System.Object
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesStockSettings
Dim value As System.Object

value = instance.Clone()
C#
public virtual System.object Clone()
Delphi
public function Clone(): System.TObject; virtual;
JScript
public function Clone() : System.Object;
Managed Extensions for C++
public: virtual System.Object* Clone();
C++/CLI
public:
virtual System.Object^ Clone();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesStockSettings Class
ChartSeriesStockSettings Members


CopyFrom Method

[image]
Intersoft WebGrid Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSeriesStockSettings Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesStockSettings Class
ChartSeriesStockSettings Members


CopyFrom(Object) Method

[image]
Intersoft WebGrid Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSeriesStockSettings Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesStockSettings
Dim objSource As System.Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   System.object objSource
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesStockSettings Class
ChartSeriesStockSettings Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebGrid Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSeriesStockSettings Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object, _
   ByVal cloneSourceValue As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesStockSettings
Dim objSource As System.Object
Dim cloneSourceValue As System.Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   System.object objSource,
   System.bool cloneSourceValue
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject;
    cloneSourceValue: System.Boolean
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object,
   cloneSourceValue : System.boolean
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource,
   System.bool cloneSourceValue
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource,
   System.bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesStockSettings Class
ChartSeriesStockSettings Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebGrid Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSeriesStockSettings Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesStockSettings
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure DeSerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function DeSerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void DeSerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void DeSerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesStockSettings Class
ChartSeriesStockSettings Members


GetHashCode Method

[image]
Intersoft WebGrid Documentation
GetHashCode Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSeriesStockSettings Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesStockSettings
Dim value As System.Integer

value = instance.GetHashCode()
C#
public virtual System.int GetHashCode()
Delphi
public function GetHashCode(): System.Integer; virtual;
JScript
public function GetHashCode() : System.int;
Managed Extensions for C++
public: virtual System.int GetHashCode();
C++/CLI
public:
virtual System.int GetHashCode();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesStockSettings Class
ChartSeriesStockSettings Members


ChartSeriesStockSettings Class Methods

[image]
Intersoft WebGrid Documentation
ChartSeriesStockSettings Class Methods
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartSeriesStockSettings Class

Glossary Item Box

For a list of all members of this type, see ChartSeriesStockSettings members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

ChartSeriesStockSettings Class
ISNet.WebUI.WebGrid.Chart Namespace


GetObjectData Method

[image]
Intersoft WebGrid Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSeriesStockSettings Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=False,
   UnmanagedCode=False,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=True,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Action=SecurityAction.Demand,
   Unrestricted=False)>
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesStockSettings
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure GetObjectData(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
); override;
JScript
System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=,
   UnmanagedCode=,
   SkipVerification=,
   Execution=,
   ControlThread=,
   ControlEvidence=,
   ControlPolicy=,
   SerializationFormatter=,
   ControlDomainPolicy=,
   ControlPrincipal=,
   ControlAppDomain=,
   RemotingConfiguration=,
   Infrastructure=,
   BindingRedirects=,
   Action=SecurityAction.Demand,
   Unrestricted=)
public override function GetObjectData(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public: void GetObjectData(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
) override
C++/CLI
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public:
void GetObjectData(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
) override

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesStockSettings Class
ChartSeriesStockSettings Members


IsEmpty Method

[image]
Intersoft WebGrid Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSeriesStockSettings Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesStockSettings
Dim value As System.Boolean

value = instance.IsEmpty()
C#
public virtual System.bool IsEmpty()
Delphi
public function IsEmpty(): System.Boolean; virtual;
JScript
public function IsEmpty() : System.boolean;
Managed Extensions for C++
public: virtual System.bool IsEmpty();
C++/CLI
public:
virtual System.bool IsEmpty();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesStockSettings Class
ChartSeriesStockSettings Members


Reset Method

[image]
Intersoft WebGrid Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSeriesStockSettings Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesStockSettings

instance.Reset()
C#
public virtual void Reset()
Delphi
public procedure Reset(); virtual;
JScript
public function Reset();
Managed Extensions for C++
public: virtual void Reset();
C++/CLI
public:
virtual void Reset();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesStockSettings Class
ChartSeriesStockSettings Members


SerializeObjectData Method

[image]
Intersoft WebGrid Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSeriesStockSettings Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesStockSettings
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure SerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function SerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void SerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void SerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesStockSettings Class
ChartSeriesStockSettings Members


ToString Method

[image]
Intersoft WebGrid Documentation
ToString Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSeriesStockSettings Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As System.String
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesStockSettings
Dim value As System.String

value = instance.ToString()
C#
public virtual System.string ToString()
Delphi
public function ToString(): System.String; virtual;
JScript
public function ToString() : System.String;
Managed Extensions for C++
public: virtual System.string* ToString();
C++/CLI
public:
virtual System.String^ ToString();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesStockSettings Class
ChartSeriesStockSettings Members


ChartSeriesStockSettings Class Properties

[image]
Intersoft WebGrid Documentation
ChartSeriesStockSettings Class Properties
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartSeriesStockSettings Class

Glossary Item Box

For a list of all members of this type, see ChartSeriesStockSettings members.

Public Properties

 | Name | Description
Public Property | Settings |
Public Property | Type |
Top

See Also

Reference

ChartSeriesStockSettings Class
ISNet.WebUI.WebGrid.Chart Namespace


ChartSeriesStockSettings Constructor

[image]
Intersoft WebGrid Documentation
ChartSeriesStockSettings Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSeriesStockSettings Class : ChartSeriesStockSettings Constructor

Glossary Item Box

Overload List

Overload | Description
ChartSeriesStockSettings Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesStockSettings Class
ChartSeriesStockSettings Members


Settings Property

[image]
Intersoft WebGrid Documentation
Settings Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSeriesStockSettings Class : Settings Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<ISNet.Serialization.BinarySerializableAttribute("setSettings")>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
Public ReadOnly Property Settings As SeriesStock
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesStockSettings
Dim value As SeriesStock

value = instance.Settings
C#
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.Serialization.BinarySerializableAttribute("setSettings")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
public SeriesStock Settings {get;}
Delphi
public read-only property Settings: SeriesStock;
JScript
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
ISNet.Serialization.BinarySerializableAttribute("setSettings")
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
public function get Settings : SeriesStock
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.Serialization.BinarySerializableAttribute("setSettings")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
public: __property SeriesStock* get_Settings();
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.Serialization.BinarySerializableAttribute("setSettings")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
public:
property SeriesStock^ Settings {
   SeriesStock^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesStockSettings Class
ChartSeriesStockSettings Members


Type Property

[image]
Intersoft WebGrid Documentation
Type Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSeriesStockSettings Class : Type Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
Public Property Type As SeriesStockType
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesStockSettings
Dim value As SeriesStockType

instance.Type = value

value = instance.Type
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public SeriesStockType Type {get; set;}
Delphi
public read-write property Type: SeriesStockType;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
public function get,set Type : SeriesStockType
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public: __property SeriesStockType get_Type();
public: __property void set_Type(
   SeriesStockType value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public:
property SeriesStockType Type {
   SeriesStockType get();
   void set (    SeriesStockType value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesStockSettings Class
ChartSeriesStockSettings Members


ChartSeriesXYSettings Class

[image]
Intersoft WebGrid Documentation
ChartSeriesXYSettings Class
Members See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartSeriesXYSettings Class

Glossary Item Box

Object Model

ChartSeriesXYSettings Class

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.SerializableAttribute()>
Public Class ChartSeriesXYSettings
   Inherits ISNet.WebUI.WebUIBaseClass
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesXYSettings
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public class ChartSeriesXYSettings : ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Delphi
public class ChartSeriesXYSettings = class(ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize)
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.SerializableAttribute()
public class ChartSeriesXYSettings extends ISNet.WebUI.WebUIBaseClass implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public __gc class ChartSeriesXYSettings : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public ref class ChartSeriesXYSettings : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.WebGrid.Chart.ChartSeriesXYSettings

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesXYSettings Members
ISNet.WebUI.WebGrid.Chart Namespace


ChartSeriesXYSettings Class Members

[image]
Intersoft WebGrid Documentation
ChartSeriesXYSettings Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartSeriesXYSettings Class

Glossary Item Box

The following tables list the members exposed by ChartSeriesXYSettings.

Public Constructors

 | Name | Description
Public Constructor | ChartSeriesXYSettings Constructor |
Top

Public Properties

 | Name | Description
Public Property | Settings |
Public Property | Type |
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

ChartSeriesXYSettings Class
ISNet.WebUI.WebGrid.Chart Namespace


ChartSeriesXYSettings Constructor

[image]
Intersoft WebGrid Documentation
ChartSeriesXYSettings Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSeriesXYSettings Class : ChartSeriesXYSettings Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New ChartSeriesXYSettings()
C#
public ChartSeriesXYSettings()
Delphi
public ChartSeriesXYSettings();
JScript
public function ChartSeriesXYSettings();
Managed Extensions for C++
public: ChartSeriesXYSettings();
C++/CLI
public:
ChartSeriesXYSettings();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesXYSettings Class
ChartSeriesXYSettings Members


Clone Method

[image]
Intersoft WebGrid Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSeriesXYSettings Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As System.Object
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesXYSettings
Dim value As System.Object

value = instance.Clone()
C#
public virtual System.object Clone()
Delphi
public function Clone(): System.TObject; virtual;
JScript
public function Clone() : System.Object;
Managed Extensions for C++
public: virtual System.Object* Clone();
C++/CLI
public:
virtual System.Object^ Clone();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesXYSettings Class
ChartSeriesXYSettings Members


CopyFrom Method

[image]
Intersoft WebGrid Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSeriesXYSettings Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesXYSettings Class
ChartSeriesXYSettings Members


CopyFrom(Object) Method

[image]
Intersoft WebGrid Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSeriesXYSettings Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesXYSettings
Dim objSource As System.Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   System.object objSource
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesXYSettings Class
ChartSeriesXYSettings Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebGrid Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSeriesXYSettings Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object, _
   ByVal cloneSourceValue As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesXYSettings
Dim objSource As System.Object
Dim cloneSourceValue As System.Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   System.object objSource,
   System.bool cloneSourceValue
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject;
    cloneSourceValue: System.Boolean
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object,
   cloneSourceValue : System.boolean
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource,
   System.bool cloneSourceValue
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource,
   System.bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesXYSettings Class
ChartSeriesXYSettings Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebGrid Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSeriesXYSettings Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesXYSettings
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure DeSerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function DeSerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void DeSerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void DeSerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesXYSettings Class
ChartSeriesXYSettings Members


GetHashCode Method

[image]
Intersoft WebGrid Documentation
GetHashCode Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSeriesXYSettings Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesXYSettings
Dim value As System.Integer

value = instance.GetHashCode()
C#
public virtual System.int GetHashCode()
Delphi
public function GetHashCode(): System.Integer; virtual;
JScript
public function GetHashCode() : System.int;
Managed Extensions for C++
public: virtual System.int GetHashCode();
C++/CLI
public:
virtual System.int GetHashCode();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesXYSettings Class
ChartSeriesXYSettings Members


ChartSeriesXYSettings Class Methods

[image]
Intersoft WebGrid Documentation
ChartSeriesXYSettings Class Methods
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartSeriesXYSettings Class

Glossary Item Box

For a list of all members of this type, see ChartSeriesXYSettings members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

ChartSeriesXYSettings Class
ISNet.WebUI.WebGrid.Chart Namespace


GetObjectData Method

[image]
Intersoft WebGrid Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSeriesXYSettings Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=False,
   UnmanagedCode=False,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=True,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Action=SecurityAction.Demand,
   Unrestricted=False)>
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesXYSettings
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure GetObjectData(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
); override;
JScript
System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=,
   UnmanagedCode=,
   SkipVerification=,
   Execution=,
   ControlThread=,
   ControlEvidence=,
   ControlPolicy=,
   SerializationFormatter=,
   ControlDomainPolicy=,
   ControlPrincipal=,
   ControlAppDomain=,
   RemotingConfiguration=,
   Infrastructure=,
   BindingRedirects=,
   Action=SecurityAction.Demand,
   Unrestricted=)
public override function GetObjectData(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public: void GetObjectData(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
) override
C++/CLI
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public:
void GetObjectData(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
) override

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesXYSettings Class
ChartSeriesXYSettings Members


IsEmpty Method

[image]
Intersoft WebGrid Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSeriesXYSettings Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesXYSettings
Dim value As System.Boolean

value = instance.IsEmpty()
C#
public virtual System.bool IsEmpty()
Delphi
public function IsEmpty(): System.Boolean; virtual;
JScript
public function IsEmpty() : System.boolean;
Managed Extensions for C++
public: virtual System.bool IsEmpty();
C++/CLI
public:
virtual System.bool IsEmpty();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesXYSettings Class
ChartSeriesXYSettings Members


Reset Method

[image]
Intersoft WebGrid Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSeriesXYSettings Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesXYSettings

instance.Reset()
C#
public virtual void Reset()
Delphi
public procedure Reset(); virtual;
JScript
public function Reset();
Managed Extensions for C++
public: virtual void Reset();
C++/CLI
public:
virtual void Reset();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesXYSettings Class
ChartSeriesXYSettings Members


SerializeObjectData Method

[image]
Intersoft WebGrid Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSeriesXYSettings Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesXYSettings
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure SerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function SerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void SerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void SerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesXYSettings Class
ChartSeriesXYSettings Members


ToString Method

[image]
Intersoft WebGrid Documentation
ToString Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSeriesXYSettings Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As System.String
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesXYSettings
Dim value As System.String

value = instance.ToString()
C#
public virtual System.string ToString()
Delphi
public function ToString(): System.String; virtual;
JScript
public function ToString() : System.String;
Managed Extensions for C++
public: virtual System.string* ToString();
C++/CLI
public:
virtual System.String^ ToString();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesXYSettings Class
ChartSeriesXYSettings Members


ChartSeriesXYSettings Class Properties

[image]
Intersoft WebGrid Documentation
ChartSeriesXYSettings Class Properties
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartSeriesXYSettings Class

Glossary Item Box

For a list of all members of this type, see ChartSeriesXYSettings members.

Public Properties

 | Name | Description
Public Property | Settings |
Public Property | Type |
Top

See Also

Reference

ChartSeriesXYSettings Class
ISNet.WebUI.WebGrid.Chart Namespace


ChartSeriesXYSettings Constructor

[image]
Intersoft WebGrid Documentation
ChartSeriesXYSettings Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSeriesXYSettings Class : ChartSeriesXYSettings Constructor

Glossary Item Box

Overload List

Overload | Description
ChartSeriesXYSettings Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesXYSettings Class
ChartSeriesXYSettings Members


Settings Property

[image]
Intersoft WebGrid Documentation
Settings Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSeriesXYSettings Class : Settings Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<ISNet.Serialization.BinarySerializableAttribute("setSettings")>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
Public ReadOnly Property Settings As SeriesPoint
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesXYSettings
Dim value As SeriesPoint

value = instance.Settings
C#
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[ISNet.Serialization.BinarySerializableAttribute("setSettings")]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
public SeriesPoint Settings {get;}
Delphi
public read-only property Settings: SeriesPoint;
JScript
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
ISNet.Serialization.BinarySerializableAttribute("setSettings")
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
public function get Settings : SeriesPoint
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[ISNet.Serialization.BinarySerializableAttribute("setSettings")]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
public: __property SeriesPoint* get_Settings();
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[ISNet.Serialization.BinarySerializableAttribute("setSettings")]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
public:
property SeriesPoint^ Settings {
   SeriesPoint^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesXYSettings Class
ChartSeriesXYSettings Members


Type Property

[image]
Intersoft WebGrid Documentation
Type Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSeriesXYSettings Class : Type Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property Type As SeriesXYType
Visual Basic (Usage) Copy Code
Dim instance As ChartSeriesXYSettings
Dim value As SeriesXYType

instance.Type = value

value = instance.Type
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public SeriesXYType Type {get; set;}
Delphi
public read-write property Type: SeriesXYType;
JScript
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get,set Type : SeriesXYType
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property SeriesXYType get_Type();
public: __property void set_Type(
   SeriesXYType value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property SeriesXYType Type {
   SeriesXYType get();
   void set (    SeriesXYType value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSeriesXYSettings Class
ChartSeriesXYSettings Members


ChartSettings Class

[image]
Intersoft WebGrid Documentation
ChartSettings Class
Members See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartSettings Class

Glossary Item Box

Object Model

ChartSettings Class

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.SerializableAttribute()>
Public Class ChartSettings
   Inherits ISNet.WebUI.WebUIBaseClass
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Visual Basic (Usage) Copy Code
Dim instance As ChartSettings
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public class ChartSettings : ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Delphi
public class ChartSettings = class(ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize)
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.SerializableAttribute()
public class ChartSettings extends ISNet.WebUI.WebUIBaseClass implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public __gc class ChartSettings : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public ref class ChartSettings : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.WebGrid.Chart.ChartSettings

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSettings Members
ISNet.WebUI.WebGrid.Chart Namespace


ChartSettings Class Members

[image]
Intersoft WebGrid Documentation
ChartSettings Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartSettings Class

Glossary Item Box

The following tables list the members exposed by ChartSettings.

Public Constructors

 | Name | Description
Public Constructor | ChartSettings Constructor |
Top

Public Properties

 | Name | Description
Public Property | BackgroundSettings |
Public Property | BoundsMode |
Public Property | ChartEngine |
Public Property | ChartType |
Public Property | ChartWalls |
Public Property | Depth |
Public Property | Grid |
Public Property | HeaderSettings |
Public Property | ImageFormat |
Public Property | LegendSettings |
Public Property | LightModelSettings |
Public Property | ProjectionSettings |
Public Property | SeriesAreaSettings |
Public Property | SeriesBarSettings |
Public Property | SeriesColorCollection |
Public Property | SeriesColumnSettings |
Public Property | SeriesDoughnutSettings |
Public Property | SeriesLineSettings |
Public Property | SeriesMarkerCollection |
Public Property | SeriesPieSettings |
Public Property | SeriesSmoothLineSettings |
Public Property | SeriesStepLineSettings |
Public Property | Visible |
Public Property | VisualEffectSettings |
Public Property | XAxis |
Public Property | YAxis |
Public Property | ZAxis |
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | GetSeries |
Public Method | Is3DChart |
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

ChartSettings Class
ISNet.WebUI.WebGrid.Chart Namespace


ChartSettings Constructor

[image]
Intersoft WebGrid Documentation
ChartSettings Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSettings Class : ChartSettings Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New ChartSettings()
C#
public ChartSettings()
Delphi
public ChartSettings();
JScript
public function ChartSettings();
Managed Extensions for C++
public: ChartSettings();
C++/CLI
public:
ChartSettings();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSettings Class
ChartSettings Members


Clone Method

[image]
Intersoft WebGrid Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSettings Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As System.Object
Visual Basic (Usage) Copy Code
Dim instance As ChartSettings
Dim value As System.Object

value = instance.Clone()
C#
public virtual System.object Clone()
Delphi
public function Clone(): System.TObject; virtual;
JScript
public function Clone() : System.Object;
Managed Extensions for C++
public: virtual System.Object* Clone();
C++/CLI
public:
virtual System.Object^ Clone();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSettings Class
ChartSettings Members


CopyFrom Method

[image]
Intersoft WebGrid Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSettings Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSettings Class
ChartSettings Members


CopyFrom(Object) Method

[image]
Intersoft WebGrid Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSettings Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartSettings
Dim objSource As System.Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   System.object objSource
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSettings Class
ChartSettings Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebGrid Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSettings Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object, _
   ByVal cloneSourceValue As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartSettings
Dim objSource As System.Object
Dim cloneSourceValue As System.Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   System.object objSource,
   System.bool cloneSourceValue
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject;
    cloneSourceValue: System.Boolean
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object,
   cloneSourceValue : System.boolean
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource,
   System.bool cloneSourceValue
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource,
   System.bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSettings Class
ChartSettings Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebGrid Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSettings Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartSettings
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure DeSerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function DeSerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void DeSerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void DeSerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSettings Class
ChartSettings Members


GetHashCode Method

[image]
Intersoft WebGrid Documentation
GetHashCode Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSettings Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As ChartSettings
Dim value As System.Integer

value = instance.GetHashCode()
C#
public virtual System.int GetHashCode()
Delphi
public function GetHashCode(): System.Integer; virtual;
JScript
public function GetHashCode() : System.int;
Managed Extensions for C++
public: virtual System.int GetHashCode();
C++/CLI
public:
virtual System.int GetHashCode();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSettings Class
ChartSettings Members


ChartSettings Class Methods

[image]
Intersoft WebGrid Documentation
ChartSettings Class Methods
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartSettings Class

Glossary Item Box

For a list of all members of this type, see ChartSettings members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | GetSeries |
Public Method | Is3DChart |
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

ChartSettings Class
ISNet.WebUI.WebGrid.Chart Namespace


GetObjectData Method

[image]
Intersoft WebGrid Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSettings Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=False,
   UnmanagedCode=False,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=True,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Action=SecurityAction.Demand,
   Unrestricted=False)>
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartSettings
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure GetObjectData(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
); override;
JScript
System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=,
   UnmanagedCode=,
   SkipVerification=,
   Execution=,
   ControlThread=,
   ControlEvidence=,
   ControlPolicy=,
   SerializationFormatter=,
   ControlDomainPolicy=,
   ControlPrincipal=,
   ControlAppDomain=,
   RemotingConfiguration=,
   Infrastructure=,
   BindingRedirects=,
   Action=SecurityAction.Demand,
   Unrestricted=)
public override function GetObjectData(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public: void GetObjectData(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
) override
C++/CLI
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public:
void GetObjectData(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
) override

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSettings Class
ChartSettings Members


GetSeries Method

[image]
Intersoft WebGrid Documentation
GetSeries Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSettings Class : GetSeries Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetSeries() As Series
Visual Basic (Usage) Copy Code
Dim instance As ChartSettings
Dim value As Series

value = instance.GetSeries()
C#
public Series GetSeries()
Delphi
public function GetSeries(): Series;
JScript
public function GetSeries() : Series;
Managed Extensions for C++
public: Series* GetSeries();
C++/CLI
public:
Series^ GetSeries();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSettings Class
ChartSettings Members


Is3DChart Method

[image]
Intersoft WebGrid Documentation
Is3DChart Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSettings Class : Is3DChart Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function Is3DChart() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As ChartSettings
Dim value As System.Boolean

value = instance.Is3DChart()
C#
public System.bool Is3DChart()
Delphi
public function Is3DChart(): System.Boolean;
JScript
public function Is3DChart() : System.boolean;
Managed Extensions for C++
public: System.bool Is3DChart();
C++/CLI
public:
System.bool Is3DChart();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSettings Class
ChartSettings Members


IsEmpty Method

[image]
Intersoft WebGrid Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSettings Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As ChartSettings
Dim value As System.Boolean

value = instance.IsEmpty()
C#
public virtual System.bool IsEmpty()
Delphi
public function IsEmpty(): System.Boolean; virtual;
JScript
public function IsEmpty() : System.boolean;
Managed Extensions for C++
public: virtual System.bool IsEmpty();
C++/CLI
public:
virtual System.bool IsEmpty();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSettings Class
ChartSettings Members


Reset Method

[image]
Intersoft WebGrid Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSettings Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As ChartSettings

instance.Reset()
C#
public virtual void Reset()
Delphi
public procedure Reset(); virtual;
JScript
public function Reset();
Managed Extensions for C++
public: virtual void Reset();
C++/CLI
public:
virtual void Reset();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSettings Class
ChartSettings Members


SerializeObjectData Method

[image]
Intersoft WebGrid Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSettings Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartSettings
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure SerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function SerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void SerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void SerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSettings Class
ChartSettings Members


ToString Method

[image]
Intersoft WebGrid Documentation
ToString Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSettings Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As System.String
Visual Basic (Usage) Copy Code
Dim instance As ChartSettings
Dim value As System.String

value = instance.ToString()
C#
public virtual System.string ToString()
Delphi
public function ToString(): System.String; virtual;
JScript
public function ToString() : System.String;
Managed Extensions for C++
public: virtual System.string* ToString();
C++/CLI
public:
virtual System.String^ ToString();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSettings Class
ChartSettings Members


ChartSettings Class Properties

[image]
Intersoft WebGrid Documentation
ChartSettings Class Properties
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartSettings Class

Glossary Item Box

For a list of all members of this type, see ChartSettings members.

Public Properties

 | Name | Description
Public Property | BackgroundSettings |
Public Property | BoundsMode |
Public Property | ChartEngine |
Public Property | ChartType |
Public Property | ChartWalls |
Public Property | Depth |
Public Property | Grid |
Public Property | HeaderSettings |
Public Property | ImageFormat |
Public Property | LegendSettings |
Public Property | LightModelSettings |
Public Property | ProjectionSettings |
Public Property | SeriesAreaSettings |
Public Property | SeriesBarSettings |
Public Property | SeriesColorCollection |
Public Property | SeriesColumnSettings |
Public Property | SeriesDoughnutSettings |
Public Property | SeriesLineSettings |
Public Property | SeriesMarkerCollection |
Public Property | SeriesPieSettings |
Public Property | SeriesSmoothLineSettings |
Public Property | SeriesStepLineSettings |
Public Property | Visible |
Public Property | VisualEffectSettings |
Public Property | XAxis |
Public Property | YAxis |
Public Property | ZAxis |
Top

See Also

Reference

ChartSettings Class
ISNet.WebUI.WebGrid.Chart Namespace


ChartSettings Constructor

[image]
Intersoft WebGrid Documentation
ChartSettings Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSettings Class : ChartSettings Constructor

Glossary Item Box

Overload List

Overload | Description
ChartSettings Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSettings Class
ChartSettings Members


BackgroundSettings Property

[image]
Intersoft WebGrid Documentation
BackgroundSettings Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSettings Class : BackgroundSettings Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Controls the chart background appearance")>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<System.ComponentModel.CategoryAttribute("General")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute(True)>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<ISNet.Serialization.BinarySerializableAttribute("setBackgroundSettings")>
Public ReadOnly Property BackgroundSettings As ChartBackgroundSettings
Visual Basic (Usage) Copy Code
Dim instance As ChartSettings
Dim value As ChartBackgroundSettings

value = instance.BackgroundSettings
C#
[System.ComponentModel.DescriptionAttribute("Controls the chart background appearance")]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[ISNet.Serialization.BinarySerializableAttribute("setBackgroundSettings")]
public ChartBackgroundSettings BackgroundSettings {get;}
Delphi
public read-only property BackgroundSettings: ChartBackgroundSettings;
JScript
System.ComponentModel.DescriptionAttribute("Controls the chart background appearance")
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
System.ComponentModel.CategoryAttribute("General")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
ISNet.Serialization.BinarySerializableAttribute("setBackgroundSettings")
public function get BackgroundSettings : ChartBackgroundSettings
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Controls the chart background appearance")]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[ISNet.Serialization.BinarySerializableAttribute("setBackgroundSettings")]
public: __property ChartBackgroundSettings* get_BackgroundSettings();
C++/CLI
[System.ComponentModel.DescriptionAttribute("Controls the chart background appearance")]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[ISNet.Serialization.BinarySerializableAttribute("setBackgroundSettings")]
public:
property ChartBackgroundSettings^ BackgroundSettings {
   ChartBackgroundSettings^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSettings Class
ChartSettings Members


BoundsMode Property

[image]
Intersoft WebGrid Documentation
BoundsMode Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSettings Class : BoundsMode Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Controls the content panel mode")>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("General")>
Public Property BoundsMode As BoundsMode
Visual Basic (Usage) Copy Code
Dim instance As ChartSettings
Dim value As BoundsMode

instance.BoundsMode = value

value = instance.BoundsMode
C#
[System.ComponentModel.DescriptionAttribute("Controls the content panel mode")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("General")]
public BoundsMode BoundsMode {get; set;}
Delphi
public read-write property BoundsMode: BoundsMode;
JScript
System.ComponentModel.DescriptionAttribute("Controls the content panel mode")
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("General")
public function get,set BoundsMode : BoundsMode
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Controls the content panel mode")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("General")]
public: __property BoundsMode get_BoundsMode();
public: __property void set_BoundsMode(
   BoundsMode value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Controls the content panel mode")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("General")]
public:
property BoundsMode BoundsMode {
   BoundsMode get();
   void set (    BoundsMode value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSettings Class
ChartSettings Members


ChartEngine Property

[image]
Intersoft WebGrid Documentation
ChartEngine Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSettings Class : ChartEngine Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("General")>
<System.ComponentModel.DescriptionAttribute("Specifies the runtime Charting engine used by the Pivot Charting feature")>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property ChartEngine As ChartEngineType
Visual Basic (Usage) Copy Code
Dim instance As ChartSettings
Dim value As ChartEngineType

instance.ChartEngine = value

value = instance.ChartEngine
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DescriptionAttribute("Specifies the runtime Charting engine used by the Pivot Charting feature")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public ChartEngineType ChartEngine {get; set;}
Delphi
public read-write property ChartEngine: ChartEngineType;
JScript
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("General")
System.ComponentModel.DescriptionAttribute("Specifies the runtime Charting engine used by the Pivot Charting feature")
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get,set ChartEngine : ChartEngineType
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DescriptionAttribute("Specifies the runtime Charting engine used by the Pivot Charting feature")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property ChartEngineType get_ChartEngine();
public: __property void set_ChartEngine(
   ChartEngineType value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DescriptionAttribute("Specifies the runtime Charting engine used by the Pivot Charting feature")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property ChartEngineType ChartEngine {
   ChartEngineType get();
   void set (    ChartEngineType value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSettings Class
ChartSettings Members


ChartType Property

[image]
Intersoft WebGrid Documentation
ChartType Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSettings Class : ChartType Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("General")>
<System.ComponentModel.DescriptionAttribute("Specifies the type of the chart to be displayed.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property ChartType As ChartType
Visual Basic (Usage) Copy Code
Dim instance As ChartSettings
Dim value As ChartType

instance.ChartType = value

value = instance.ChartType
C#
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DescriptionAttribute("Specifies the type of the chart to be displayed.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public ChartType ChartType {get; set;}
Delphi
public read-write property ChartType: ChartType;
JScript
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("General")
System.ComponentModel.DescriptionAttribute("Specifies the type of the chart to be displayed.")
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set ChartType : ChartType
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DescriptionAttribute("Specifies the type of the chart to be displayed.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property ChartType get_ChartType();
public: __property void set_ChartType(
   ChartType value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DescriptionAttribute("Specifies the type of the chart to be displayed.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property ChartType ChartType {
   ChartType get();
   void set (    ChartType value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSettings Class
ChartSettings Members


ChartWalls Property

[image]
Intersoft WebGrid Documentation
ChartWalls Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSettings Class : ChartWalls Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("General")>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<ISNet.Serialization.XmlSerializableAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute("setChartWalls")>
<System.ComponentModel.DescriptionAttribute("Controls the walls appearance of the chart")>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
Public ReadOnly Property ChartWalls As ChartWalls
Visual Basic (Usage) Copy Code
Dim instance As ChartSettings
Dim value As ChartWalls

value = instance.ChartWalls
C#
[System.ComponentModel.CategoryAttribute("General")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute("setChartWalls")]
[System.ComponentModel.DescriptionAttribute("Controls the walls appearance of the chart")]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public ChartWalls ChartWalls {get;}
Delphi
public read-only property ChartWalls: ChartWalls;
JScript
System.ComponentModel.CategoryAttribute("General")
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute("setChartWalls")
System.ComponentModel.DescriptionAttribute("Controls the walls appearance of the chart")
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
public function get ChartWalls : ChartWalls
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("General")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute("setChartWalls")]
[System.ComponentModel.DescriptionAttribute("Controls the walls appearance of the chart")]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public: __property ChartWalls* get_ChartWalls();
C++/CLI
[System.ComponentModel.CategoryAttribute("General")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute("setChartWalls")]
[System.ComponentModel.DescriptionAttribute("Controls the walls appearance of the chart")]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public:
property ChartWalls^ ChartWalls {
   ChartWalls^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSettings Class
ChartSettings Members


Depth Property

[image]
Intersoft WebGrid Documentation
Depth Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSettings Class : Depth Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Controls the chart area depth in model units.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("General")>
Public Property Depth As System.Nullable(Of Single)
Visual Basic (Usage) Copy Code
Dim instance As ChartSettings
Dim value As System.Nullable(Of Single)

instance.Depth = value

value = instance.Depth
C#
[System.ComponentModel.DescriptionAttribute("Controls the chart area depth in model units.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("General")]
public System.Nullable<float> Depth {get; set;}
Delphi
public read-write property Depth: System.Nullable;
JScript
System.ComponentModel.DescriptionAttribute("Controls the chart area depth in model units.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("General")
public function get,set Depth : System.Nullable
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Controls the chart area depth in model units.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("General")]
public: __property System.Nullable<float> get_Depth();
public: __property void set_Depth(
   System.Nullable<float> value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Controls the chart area depth in model units.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("General")]
public:
property System.Nullable<float> Depth {
   System.Nullable<float> get();
   void set (    System.Nullable<float> value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSettings Class
ChartSettings Members


Grid Property

[image]
Intersoft WebGrid Documentation
Grid Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSettings Class : Grid Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Grid As WebGrid
Visual Basic (Usage) Copy Code
Dim instance As ChartSettings
Dim value As WebGrid

instance.Grid = value

value = instance.Grid
C#
public WebGrid Grid {get; set;}
Delphi
public read-write property Grid: WebGrid;
JScript
public function get,set Grid : WebGrid
Managed Extensions for C++
public: __property WebGrid* get_Grid();
public: __property void set_Grid(
   WebGrid* value
);
C++/CLI
public:
property WebGrid^ Grid {
   WebGrid^ get();
   void set (    WebGrid^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSettings Class
ChartSettings Members


HeaderSettings Property

[image]
Intersoft WebGrid Documentation
HeaderSettings Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSettings Class : HeaderSettings Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Controls the chart header / title appearance")>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.CategoryAttribute("General")>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute("setHeaderSettings")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public ReadOnly Property HeaderSettings As ChartLabelSettings
Visual Basic (Usage) Copy Code
Dim instance As ChartSettings
Dim value As ChartLabelSettings

value = instance.HeaderSettings
C#
[System.ComponentModel.DescriptionAttribute("Controls the chart header / title appearance")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute("setHeaderSettings")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public ChartLabelSettings HeaderSettings {get;}
Delphi
public read-only property HeaderSettings: ChartLabelSettings;
JScript
System.ComponentModel.DescriptionAttribute("Controls the chart header / title appearance")
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.CategoryAttribute("General")
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute("setHeaderSettings")
System.ComponentModel.NotifyParentPropertyAttribute()
public function get HeaderSettings : ChartLabelSettings
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Controls the chart header / title appearance")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute("setHeaderSettings")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property ChartLabelSettings* get_HeaderSettings();
C++/CLI
[System.ComponentModel.DescriptionAttribute("Controls the chart header / title appearance")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute("setHeaderSettings")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property ChartLabelSettings^ HeaderSettings {
   ChartLabelSettings^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSettings Class
ChartSettings Members


ImageFormat Property

[image]
Intersoft WebGrid Documentation
ImageFormat Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSettings Class : ImageFormat Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Specifies the image format of the chart")>
<System.ComponentModel.CategoryAttribute("General")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Property ImageFormat As ChartImageFormat
Visual Basic (Usage) Copy Code
Dim instance As ChartSettings
Dim value As ChartImageFormat

instance.ImageFormat = value

value = instance.ImageFormat
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the image format of the chart")]
[System.ComponentModel.CategoryAttribute("General")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public ChartImageFormat ImageFormat {get; set;}
Delphi
public read-write property ImageFormat: ChartImageFormat;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the image format of the chart")
System.ComponentModel.CategoryAttribute("General")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute()
public function get,set ImageFormat : ChartImageFormat
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the image format of the chart")]
[System.ComponentModel.CategoryAttribute("General")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property ChartImageFormat get_ImageFormat();
public: __property void set_ImageFormat(
   ChartImageFormat value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the image format of the chart")]
[System.ComponentModel.CategoryAttribute("General")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property ChartImageFormat ImageFormat {
   ChartImageFormat get();
   void set (    ChartImageFormat value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSettings Class
ChartSettings Members


LegendSettings Property

[image]
Intersoft WebGrid Documentation
LegendSettings Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSettings Class : LegendSettings Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute("setLegendSettings")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<System.ComponentModel.CategoryAttribute("General")>
<System.ComponentModel.DescriptionAttribute("Controls the chart legend appearance")>
Public ReadOnly Property LegendSettings As ChartLegendSettings
Visual Basic (Usage) Copy Code
Dim instance As ChartSettings
Dim value As ChartLegendSettings

value = instance.LegendSettings
C#
[ISNet.Serialization.XmlSerializableAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute("setLegendSettings")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DescriptionAttribute("Controls the chart legend appearance")]
public ChartLegendSettings LegendSettings {get;}
Delphi
public read-only property LegendSettings: ChartLegendSettings;
JScript
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute("setLegendSettings")
System.ComponentModel.NotifyParentPropertyAttribute()
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
System.ComponentModel.CategoryAttribute("General")
System.ComponentModel.DescriptionAttribute("Controls the chart legend appearance")
public function get LegendSettings : ChartLegendSettings
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute("setLegendSettings")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DescriptionAttribute("Controls the chart legend appearance")]
public: __property ChartLegendSettings* get_LegendSettings();
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute("setLegendSettings")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DescriptionAttribute("Controls the chart legend appearance")]
public:
property ChartLegendSettings^ LegendSettings {
   ChartLegendSettings^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSettings Class
ChartSettings Members


LightModelSettings Property

[image]
Intersoft WebGrid Documentation
LightModelSettings Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSettings Class : LightModelSettings Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<System.ComponentModel.DescriptionAttribute("Controls the lighting effect in chart (3D)")>
<ISNet.Serialization.BinarySerializableAttribute("setLightModelSettings")>
<System.ComponentModel.CategoryAttribute("General")>
<ISNet.Serialization.XmlSerializableAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
Public ReadOnly Property LightModelSettings As ChartLightModelSettings
Visual Basic (Usage) Copy Code
Dim instance As ChartSettings
Dim value As ChartLightModelSettings

value = instance.LightModelSettings
C#
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DescriptionAttribute("Controls the lighting effect in chart (3D)")]
[ISNet.Serialization.BinarySerializableAttribute("setLightModelSettings")]
[System.ComponentModel.CategoryAttribute("General")]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
public ChartLightModelSettings LightModelSettings {get;}
Delphi
public read-only property LightModelSettings: ChartLightModelSettings;
JScript
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
System.ComponentModel.DescriptionAttribute("Controls the lighting effect in chart (3D)")
ISNet.Serialization.BinarySerializableAttribute("setLightModelSettings")
System.ComponentModel.CategoryAttribute("General")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
public function get LightModelSettings : ChartLightModelSettings
Managed Extensions for C++
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DescriptionAttribute("Controls the lighting effect in chart (3D)")]
[ISNet.Serialization.BinarySerializableAttribute("setLightModelSettings")]
[System.ComponentModel.CategoryAttribute("General")]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
public: __property ChartLightModelSettings* get_LightModelSettings();
C++/CLI
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DescriptionAttribute("Controls the lighting effect in chart (3D)")]
[ISNet.Serialization.BinarySerializableAttribute("setLightModelSettings")]
[System.ComponentModel.CategoryAttribute("General")]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
public:
property ChartLightModelSettings^ LightModelSettings {
   ChartLightModelSettings^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSettings Class
ChartSettings Members


ProjectionSettings Property

[image]
Intersoft WebGrid Documentation
ProjectionSettings Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSettings Class : ProjectionSettings Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<System.ComponentModel.DescriptionAttribute("Controls the projection of the chart")>
<System.ComponentModel.CategoryAttribute("General")>
<ISNet.Serialization.XmlSerializableAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute("setProjectionSettings")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public ReadOnly Property ProjectionSettings As ChartProjectionSettings
Visual Basic (Usage) Copy Code
Dim instance As ChartSettings
Dim value As ChartProjectionSettings

value = instance.ProjectionSettings
C#
[System.ComponentModel.DefaultValueAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DescriptionAttribute("Controls the projection of the chart")]
[System.ComponentModel.CategoryAttribute("General")]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute("setProjectionSettings")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public ChartProjectionSettings ProjectionSettings {get;}
Delphi
public read-only property ProjectionSettings: ChartProjectionSettings;
JScript
System.ComponentModel.DefaultValueAttribute()
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
System.ComponentModel.DescriptionAttribute("Controls the projection of the chart")
System.ComponentModel.CategoryAttribute("General")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute("setProjectionSettings")
System.ComponentModel.NotifyParentPropertyAttribute()
public function get ProjectionSettings : ChartProjectionSettings
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DescriptionAttribute("Controls the projection of the chart")]
[System.ComponentModel.CategoryAttribute("General")]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute("setProjectionSettings")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property ChartProjectionSettings* get_ProjectionSettings();
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DescriptionAttribute("Controls the projection of the chart")]
[System.ComponentModel.CategoryAttribute("General")]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute("setProjectionSettings")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property ChartProjectionSettings^ ProjectionSettings {
   ChartProjectionSettings^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSettings Class
ChartSettings Members


SeriesAreaSettings Property

[image]
Intersoft WebGrid Documentation
SeriesAreaSettings Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSettings Class : SeriesAreaSettings Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Controls the look and feel of series area type")>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<System.ComponentModel.CategoryAttribute("Series")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<ISNet.Serialization.BinarySerializableAttribute("setSeriesAreaSettings")>
Public ReadOnly Property SeriesAreaSettings As ChartSeriesAreaSettings
Visual Basic (Usage) Copy Code
Dim instance As ChartSettings
Dim value As ChartSeriesAreaSettings

value = instance.SeriesAreaSettings
C#
[ISNet.Serialization.XmlSerializableAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Controls the look and feel of series area type")]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.CategoryAttribute("Series")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[ISNet.Serialization.BinarySerializableAttribute("setSeriesAreaSettings")]
public ChartSeriesAreaSettings SeriesAreaSettings {get;}
Delphi
public read-only property SeriesAreaSettings: ChartSeriesAreaSettings;
JScript
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DescriptionAttribute("Controls the look and feel of series area type")
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
System.ComponentModel.CategoryAttribute("Series")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
ISNet.Serialization.BinarySerializableAttribute("setSeriesAreaSettings")
public function get SeriesAreaSettings : ChartSeriesAreaSettings
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Controls the look and feel of series area type")]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.CategoryAttribute("Series")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[ISNet.Serialization.BinarySerializableAttribute("setSeriesAreaSettings")]
public: __property ChartSeriesAreaSettings* get_SeriesAreaSettings();
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Controls the look and feel of series area type")]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.CategoryAttribute("Series")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[ISNet.Serialization.BinarySerializableAttribute("setSeriesAreaSettings")]
public:
property ChartSeriesAreaSettings^ SeriesAreaSettings {
   ChartSeriesAreaSettings^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSettings Class
ChartSettings Members


SeriesBarSettings Property

[image]
Intersoft WebGrid Documentation
SeriesBarSettings Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSettings Class : SeriesBarSettings Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<System.ComponentModel.CategoryAttribute("Series")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Controls the look and feel of series bar type")>
<ISNet.Serialization.BinarySerializableAttribute("setSeriesBarSettings")>
Public ReadOnly Property SeriesBarSettings As ChartSeriesBarSettings
Visual Basic (Usage) Copy Code
Dim instance As ChartSettings
Dim value As ChartSeriesBarSettings

value = instance.SeriesBarSettings
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.CategoryAttribute("Series")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Controls the look and feel of series bar type")]
[ISNet.Serialization.BinarySerializableAttribute("setSeriesBarSettings")]
public ChartSeriesBarSettings SeriesBarSettings {get;}
Delphi
public read-only property SeriesBarSettings: ChartSeriesBarSettings;
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
System.ComponentModel.CategoryAttribute("Series")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DescriptionAttribute("Controls the look and feel of series bar type")
ISNet.Serialization.BinarySerializableAttribute("setSeriesBarSettings")
public function get SeriesBarSettings : ChartSeriesBarSettings
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.CategoryAttribute("Series")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Controls the look and feel of series bar type")]
[ISNet.Serialization.BinarySerializableAttribute("setSeriesBarSettings")]
public: __property ChartSeriesBarSettings* get_SeriesBarSettings();
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.CategoryAttribute("Series")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Controls the look and feel of series bar type")]
[ISNet.Serialization.BinarySerializableAttribute("setSeriesBarSettings")]
public:
property ChartSeriesBarSettings^ SeriesBarSettings {
   ChartSeriesBarSettings^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSettings Class
ChartSettings Members


SeriesColorCollection Property

[image]
Intersoft WebGrid Documentation
SeriesColorCollection Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSettings Class : SeriesColorCollection Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Collection of SeriesColor")>
<ISNet.Serialization.BinarySerializableAttribute("setColorCollection")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.CategoryAttribute("General")>
<ISNet.Serialization.XmlSerializableAttribute(RecreateItemsOnDeserialization=True, DiscardEmptyObject=True)>
Public ReadOnly Property SeriesColorCollection As ChartSeriesColorCollectionSettings
Visual Basic (Usage) Copy Code
Dim instance As ChartSettings
Dim value As ChartSeriesColorCollectionSettings

value = instance.SeriesColorCollection
C#
[System.ComponentModel.DescriptionAttribute("Collection of SeriesColor")]
[ISNet.Serialization.BinarySerializableAttribute("setColorCollection")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.CategoryAttribute("General")]
[ISNet.Serialization.XmlSerializableAttribute(RecreateItemsOnDeserialization=true, DiscardEmptyObject=true)]
public ChartSeriesColorCollectionSettings SeriesColorCollection {get;}
Delphi
public read-only property SeriesColorCollection: ChartSeriesColorCollectionSettings;
JScript
System.ComponentModel.DescriptionAttribute("Collection of SeriesColor")
ISNet.Serialization.BinarySerializableAttribute("setColorCollection")
System.ComponentModel.NotifyParentPropertyAttribute()
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.CategoryAttribute("General")
ISNet.Serialization.XmlSerializableAttribute(RecreateItemsOnDeserialization=, DiscardEmptyObject=)
public function get SeriesColorCollection : ChartSeriesColorCollectionSettings
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Collection of SeriesColor")]
[ISNet.Serialization.BinarySerializableAttribute("setColorCollection")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.CategoryAttribute("General")]
[ISNet.Serialization.XmlSerializableAttribute(RecreateItemsOnDeserialization=true, DiscardEmptyObject=true)]
public: __property ChartSeriesColorCollectionSettings* get_SeriesColorCollection();
C++/CLI
[System.ComponentModel.DescriptionAttribute("Collection of SeriesColor")]
[ISNet.Serialization.BinarySerializableAttribute("setColorCollection")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.CategoryAttribute("General")]
[ISNet.Serialization.XmlSerializableAttribute(RecreateItemsOnDeserialization=true, DiscardEmptyObject=true)]
public:
property ChartSeriesColorCollectionSettings^ SeriesColorCollection {
   ChartSeriesColorCollectionSettings^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSettings Class
ChartSettings Members


SeriesColumnSettings Property

[image]
Intersoft WebGrid Documentation
SeriesColumnSettings Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSettings Class : SeriesColumnSettings Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Controls the look and feel of series column type")>
<ISNet.Serialization.XmlSerializableAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute("setSeriesColumnSettings")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<System.ComponentModel.CategoryAttribute("Series")>
Public ReadOnly Property SeriesColumnSettings As ChartSeriesColumnSettings
Visual Basic (Usage) Copy Code
Dim instance As ChartSettings
Dim value As ChartSeriesColumnSettings

value = instance.SeriesColumnSettings
C#
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Controls the look and feel of series column type")]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute("setSeriesColumnSettings")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.CategoryAttribute("Series")]
public ChartSeriesColumnSettings SeriesColumnSettings {get;}
Delphi
public read-only property SeriesColumnSettings: ChartSeriesColumnSettings;
JScript
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Controls the look and feel of series column type")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute("setSeriesColumnSettings")
System.ComponentModel.NotifyParentPropertyAttribute()
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
System.ComponentModel.CategoryAttribute("Series")
public function get SeriesColumnSettings : ChartSeriesColumnSettings
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Controls the look and feel of series column type")]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute("setSeriesColumnSettings")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.CategoryAttribute("Series")]
public: __property ChartSeriesColumnSettings* get_SeriesColumnSettings();
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Controls the look and feel of series column type")]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute("setSeriesColumnSettings")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.CategoryAttribute("Series")]
public:
property ChartSeriesColumnSettings^ SeriesColumnSettings {
   ChartSeriesColumnSettings^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSettings Class
ChartSettings Members


SeriesDoughnutSettings Property

[image]
Intersoft WebGrid Documentation
SeriesDoughnutSettings Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSettings Class : SeriesDoughnutSettings Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute("setSeriesDoughnutSettings")>
<System.ComponentModel.DescriptionAttribute("Controls the look and feel of series doughnut type")>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute(True)>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<System.ComponentModel.CategoryAttribute("Series")>
Public ReadOnly Property SeriesDoughnutSettings As ChartSeriesDoughnutSettings
Visual Basic (Usage) Copy Code
Dim instance As ChartSettings
Dim value As ChartSeriesDoughnutSettings

value = instance.SeriesDoughnutSettings
C#
[ISNet.Serialization.BinarySerializableAttribute("setSeriesDoughnutSettings")]
[System.ComponentModel.DescriptionAttribute("Controls the look and feel of series doughnut type")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.CategoryAttribute("Series")]
public ChartSeriesDoughnutSettings SeriesDoughnutSettings {get;}
Delphi
public read-only property SeriesDoughnutSettings: ChartSeriesDoughnutSettings;
JScript
ISNet.Serialization.BinarySerializableAttribute("setSeriesDoughnutSettings")
System.ComponentModel.DescriptionAttribute("Controls the look and feel of series doughnut type")
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
System.ComponentModel.CategoryAttribute("Series")
public function get SeriesDoughnutSettings : ChartSeriesDoughnutSettings
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute("setSeriesDoughnutSettings")]
[System.ComponentModel.DescriptionAttribute("Controls the look and feel of series doughnut type")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.CategoryAttribute("Series")]
public: __property ChartSeriesDoughnutSettings* get_SeriesDoughnutSettings();
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute("setSeriesDoughnutSettings")]
[System.ComponentModel.DescriptionAttribute("Controls the look and feel of series doughnut type")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.CategoryAttribute("Series")]
public:
property ChartSeriesDoughnutSettings^ SeriesDoughnutSettings {
   ChartSeriesDoughnutSettings^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSettings Class
ChartSettings Members


SeriesLineSettings Property

[image]
Intersoft WebGrid Documentation
SeriesLineSettings Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSettings Class : SeriesLineSettings Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.XmlSerializableAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute("setSeriesLineSettings")>
<System.ComponentModel.DefaultValueAttribute()>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<System.ComponentModel.CategoryAttribute("Series")>
<System.ComponentModel.DescriptionAttribute("Controls the look and feel of series line type")>
Public ReadOnly Property SeriesLineSettings As ChartSeriesLineSettings
Visual Basic (Usage) Copy Code
Dim instance As ChartSettings
Dim value As ChartSeriesLineSettings

value = instance.SeriesLineSettings
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute("setSeriesLineSettings")]
[System.ComponentModel.DefaultValueAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.CategoryAttribute("Series")]
[System.ComponentModel.DescriptionAttribute("Controls the look and feel of series line type")]
public ChartSeriesLineSettings SeriesLineSettings {get;}
Delphi
public read-only property SeriesLineSettings: ChartSeriesLineSettings;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute("setSeriesLineSettings")
System.ComponentModel.DefaultValueAttribute()
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
System.ComponentModel.CategoryAttribute("Series")
System.ComponentModel.DescriptionAttribute("Controls the look and feel of series line type")
public function get SeriesLineSettings : ChartSeriesLineSettings
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute("setSeriesLineSettings")]
[System.ComponentModel.DefaultValueAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.CategoryAttribute("Series")]
[System.ComponentModel.DescriptionAttribute("Controls the look and feel of series line type")]
public: __property ChartSeriesLineSettings* get_SeriesLineSettings();
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute("setSeriesLineSettings")]
[System.ComponentModel.DefaultValueAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.CategoryAttribute("Series")]
[System.ComponentModel.DescriptionAttribute("Controls the look and feel of series line type")]
public:
property ChartSeriesLineSettings^ SeriesLineSettings {
   ChartSeriesLineSettings^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSettings Class
ChartSettings Members


SeriesMarkerCollection Property

[image]
Intersoft WebGrid Documentation
SeriesMarkerCollection Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSettings Class : SeriesMarkerCollection Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.DescriptionAttribute("Collection of SeriesMarker")>
<System.ComponentModel.CategoryAttribute("General")>
<ISNet.Serialization.XmlSerializableAttribute(RecreateItemsOnDeserialization=True, DiscardEmptyObject=True)>
<ISNet.Serialization.BinarySerializableAttribute("setMarkerCollection")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public ReadOnly Property SeriesMarkerCollection As ChartSeriesMarkerCollectionSettings
Visual Basic (Usage) Copy Code
Dim instance As ChartSettings
Dim value As ChartSeriesMarkerCollectionSettings

value = instance.SeriesMarkerCollection
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DescriptionAttribute("Collection of SeriesMarker")]
[System.ComponentModel.CategoryAttribute("General")]
[ISNet.Serialization.XmlSerializableAttribute(RecreateItemsOnDeserialization=true, DiscardEmptyObject=true)]
[ISNet.Serialization.BinarySerializableAttribute("setMarkerCollection")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public ChartSeriesMarkerCollectionSettings SeriesMarkerCollection {get;}
Delphi
public read-only property SeriesMarkerCollection: ChartSeriesMarkerCollectionSettings;
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.DescriptionAttribute("Collection of SeriesMarker")
System.ComponentModel.CategoryAttribute("General")
ISNet.Serialization.XmlSerializableAttribute(RecreateItemsOnDeserialization=, DiscardEmptyObject=)
ISNet.Serialization.BinarySerializableAttribute("setMarkerCollection")
System.ComponentModel.NotifyParentPropertyAttribute()
public function get SeriesMarkerCollection : ChartSeriesMarkerCollectionSettings
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DescriptionAttribute("Collection of SeriesMarker")]
[System.ComponentModel.CategoryAttribute("General")]
[ISNet.Serialization.XmlSerializableAttribute(RecreateItemsOnDeserialization=true, DiscardEmptyObject=true)]
[ISNet.Serialization.BinarySerializableAttribute("setMarkerCollection")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property ChartSeriesMarkerCollectionSettings* get_SeriesMarkerCollection();
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DescriptionAttribute("Collection of SeriesMarker")]
[System.ComponentModel.CategoryAttribute("General")]
[ISNet.Serialization.XmlSerializableAttribute(RecreateItemsOnDeserialization=true, DiscardEmptyObject=true)]
[ISNet.Serialization.BinarySerializableAttribute("setMarkerCollection")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property ChartSeriesMarkerCollectionSettings^ SeriesMarkerCollection {
   ChartSeriesMarkerCollectionSettings^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSettings Class
ChartSettings Members


SeriesPieSettings Property

[image]
Intersoft WebGrid Documentation
SeriesPieSettings Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSettings Class : SeriesPieSettings Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.DescriptionAttribute("Controls the look and feel of series pie type")>
<ISNet.Serialization.XmlSerializableAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute("setSeriesPieSettings")>
<System.ComponentModel.CategoryAttribute("Series")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
Public ReadOnly Property SeriesPieSettings As ChartSeriesPieSettings
Visual Basic (Usage) Copy Code
Dim instance As ChartSettings
Dim value As ChartSeriesPieSettings

value = instance.SeriesPieSettings
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DescriptionAttribute("Controls the look and feel of series pie type")]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute("setSeriesPieSettings")]
[System.ComponentModel.CategoryAttribute("Series")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
public ChartSeriesPieSettings SeriesPieSettings {get;}
Delphi
public read-only property SeriesPieSettings: ChartSeriesPieSettings;
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.DescriptionAttribute("Controls the look and feel of series pie type")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute("setSeriesPieSettings")
System.ComponentModel.CategoryAttribute("Series")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
public function get SeriesPieSettings : ChartSeriesPieSettings
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DescriptionAttribute("Controls the look and feel of series pie type")]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute("setSeriesPieSettings")]
[System.ComponentModel.CategoryAttribute("Series")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
public: __property ChartSeriesPieSettings* get_SeriesPieSettings();
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DescriptionAttribute("Controls the look and feel of series pie type")]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute("setSeriesPieSettings")]
[System.ComponentModel.CategoryAttribute("Series")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
public:
property ChartSeriesPieSettings^ SeriesPieSettings {
   ChartSeriesPieSettings^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSettings Class
ChartSettings Members


SeriesSmoothLineSettings Property

[image]
Intersoft WebGrid Documentation
SeriesSmoothLineSettings Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSettings Class : SeriesSmoothLineSettings Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<System.ComponentModel.DescriptionAttribute("Controls the look and feel of series smooth line type")>
<ISNet.Serialization.XmlSerializableAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute("setSeriesSmoothLineSettings")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.CategoryAttribute("Series")>
Public ReadOnly Property SeriesSmoothLineSettings As ChartSeriesSmoothLineSettings
Visual Basic (Usage) Copy Code
Dim instance As ChartSettings
Dim value As ChartSeriesSmoothLineSettings

value = instance.SeriesSmoothLineSettings
C#
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DescriptionAttribute("Controls the look and feel of series smooth line type")]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute("setSeriesSmoothLineSettings")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.CategoryAttribute("Series")]
public ChartSeriesSmoothLineSettings SeriesSmoothLineSettings {get;}
Delphi
public read-only property SeriesSmoothLineSettings: ChartSeriesSmoothLineSettings;
JScript
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
System.ComponentModel.DescriptionAttribute("Controls the look and feel of series smooth line type")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute("setSeriesSmoothLineSettings")
System.ComponentModel.NotifyParentPropertyAttribute()
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.CategoryAttribute("Series")
public function get SeriesSmoothLineSettings : ChartSeriesSmoothLineSettings
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DescriptionAttribute("Controls the look and feel of series smooth line type")]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute("setSeriesSmoothLineSettings")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.CategoryAttribute("Series")]
public: __property ChartSeriesSmoothLineSettings* get_SeriesSmoothLineSettings();
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DescriptionAttribute("Controls the look and feel of series smooth line type")]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute("setSeriesSmoothLineSettings")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.CategoryAttribute("Series")]
public:
property ChartSeriesSmoothLineSettings^ SeriesSmoothLineSettings {
   ChartSeriesSmoothLineSettings^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSettings Class
ChartSettings Members


SeriesStepLineSettings Property

[image]
Intersoft WebGrid Documentation
SeriesStepLineSettings Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSettings Class : SeriesStepLineSettings Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Controls the look and feel of series step line type")>
<ISNet.Serialization.XmlSerializableAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute("setSeriesStepLineSettings")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<System.ComponentModel.CategoryAttribute("Series")>
Public ReadOnly Property SeriesStepLineSettings As ChartSeriesStepLineSettings
Visual Basic (Usage) Copy Code
Dim instance As ChartSettings
Dim value As ChartSeriesStepLineSettings

value = instance.SeriesStepLineSettings
C#
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Controls the look and feel of series step line type")]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute("setSeriesStepLineSettings")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.CategoryAttribute("Series")]
public ChartSeriesStepLineSettings SeriesStepLineSettings {get;}
Delphi
public read-only property SeriesStepLineSettings: ChartSeriesStepLineSettings;
JScript
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Controls the look and feel of series step line type")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute("setSeriesStepLineSettings")
System.ComponentModel.NotifyParentPropertyAttribute()
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
System.ComponentModel.CategoryAttribute("Series")
public function get SeriesStepLineSettings : ChartSeriesStepLineSettings
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Controls the look and feel of series step line type")]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute("setSeriesStepLineSettings")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.CategoryAttribute("Series")]
public: __property ChartSeriesStepLineSettings* get_SeriesStepLineSettings();
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Controls the look and feel of series step line type")]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute("setSeriesStepLineSettings")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.CategoryAttribute("Series")]
public:
property ChartSeriesStepLineSettings^ SeriesStepLineSettings {
   ChartSeriesStepLineSettings^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSettings Class
ChartSettings Members


Visible Property

[image]
Intersoft WebGrid Documentation
Visible Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSettings Class : Visible Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Indicates whether the chart is visible")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("General")>
Public Property Visible As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As ChartSettings
Dim value As System.Boolean

instance.Visible = value

value = instance.Visible
C#
[System.ComponentModel.DescriptionAttribute("Indicates whether the chart is visible")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("General")]
public System.bool Visible {get; set;}
Delphi
public read-write property Visible: System.Boolean;
JScript
System.ComponentModel.DescriptionAttribute("Indicates whether the chart is visible")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("General")
public function get,set Visible : System.boolean
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Indicates whether the chart is visible")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("General")]
public: __property System.bool get_Visible();
public: __property void set_Visible(
   System.bool value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Indicates whether the chart is visible")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("General")]
public:
property System.bool Visible {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSettings Class
ChartSettings Members


VisualEffectSettings Property

[image]
Intersoft WebGrid Documentation
VisualEffectSettings Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSettings Class : VisualEffectSettings Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Controls the visual effect of the chart")>
<ISNet.Serialization.BinarySerializableAttribute("setVisualEffectSettings")>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute(True)>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.CategoryAttribute("General")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
Public ReadOnly Property VisualEffectSettings As ChartVisualEffectSettings
Visual Basic (Usage) Copy Code
Dim instance As ChartSettings
Dim value As ChartVisualEffectSettings

value = instance.VisualEffectSettings
C#
[System.ComponentModel.DescriptionAttribute("Controls the visual effect of the chart")]
[ISNet.Serialization.BinarySerializableAttribute("setVisualEffectSettings")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
public ChartVisualEffectSettings VisualEffectSettings {get;}
Delphi
public read-only property VisualEffectSettings: ChartVisualEffectSettings;
JScript
System.ComponentModel.DescriptionAttribute("Controls the visual effect of the chart")
ISNet.Serialization.BinarySerializableAttribute("setVisualEffectSettings")
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.CategoryAttribute("General")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
public function get VisualEffectSettings : ChartVisualEffectSettings
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Controls the visual effect of the chart")]
[ISNet.Serialization.BinarySerializableAttribute("setVisualEffectSettings")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
public: __property ChartVisualEffectSettings* get_VisualEffectSettings();
C++/CLI
[System.ComponentModel.DescriptionAttribute("Controls the visual effect of the chart")]
[ISNet.Serialization.BinarySerializableAttribute("setVisualEffectSettings")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
public:
property ChartVisualEffectSettings^ VisualEffectSettings {
   ChartVisualEffectSettings^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSettings Class
ChartSettings Members


XAxis Property

[image]
Intersoft WebGrid Documentation
XAxis Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSettings Class : XAxis Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute("setXAxis")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.XmlSerializableAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<System.ComponentModel.DescriptionAttribute("Controls the X axis appearance")>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.CategoryAttribute("General")>
Public ReadOnly Property XAxis As ChartXAxisSettings
Visual Basic (Usage) Copy Code
Dim instance As ChartSettings
Dim value As ChartXAxisSettings

value = instance.XAxis
C#
[ISNet.Serialization.BinarySerializableAttribute("setXAxis")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DescriptionAttribute("Controls the X axis appearance")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.CategoryAttribute("General")]
public ChartXAxisSettings XAxis {get;}
Delphi
public read-only property XAxis: ChartXAxisSettings;
JScript
ISNet.Serialization.BinarySerializableAttribute("setXAxis")
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
System.ComponentModel.DescriptionAttribute("Controls the X axis appearance")
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.CategoryAttribute("General")
public function get XAxis : ChartXAxisSettings
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute("setXAxis")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DescriptionAttribute("Controls the X axis appearance")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.CategoryAttribute("General")]
public: __property ChartXAxisSettings* get_XAxis();
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute("setXAxis")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DescriptionAttribute("Controls the X axis appearance")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.CategoryAttribute("General")]
public:
property ChartXAxisSettings^ XAxis {
   ChartXAxisSettings^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSettings Class
ChartSettings Members


YAxis Property

[image]
Intersoft WebGrid Documentation
YAxis Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSettings Class : YAxis Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute("setYAxis")>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Controls the Y axis appearance")>
<ISNet.Serialization.XmlSerializableAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<System.ComponentModel.CategoryAttribute("General")>
Public ReadOnly Property YAxis As ChartYAxisSettings
Visual Basic (Usage) Copy Code
Dim instance As ChartSettings
Dim value As ChartYAxisSettings

value = instance.YAxis
C#
[ISNet.Serialization.BinarySerializableAttribute("setYAxis")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Controls the Y axis appearance")]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.CategoryAttribute("General")]
public ChartYAxisSettings YAxis {get;}
Delphi
public read-only property YAxis: ChartYAxisSettings;
JScript
ISNet.Serialization.BinarySerializableAttribute("setYAxis")
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Controls the Y axis appearance")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
System.ComponentModel.CategoryAttribute("General")
public function get YAxis : ChartYAxisSettings
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute("setYAxis")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Controls the Y axis appearance")]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.CategoryAttribute("General")]
public: __property ChartYAxisSettings* get_YAxis();
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute("setYAxis")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Controls the Y axis appearance")]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.CategoryAttribute("General")]
public:
property ChartYAxisSettings^ YAxis {
   ChartYAxisSettings^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSettings Class
ChartSettings Members


ZAxis Property

[image]
Intersoft WebGrid Documentation
ZAxis Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSettings Class : ZAxis Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Controls the Z axis appearance")>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<ISNet.Serialization.BinarySerializableAttribute("setZAxis")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("General")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<ISNet.Serialization.XmlSerializableAttribute(True)>
Public ReadOnly Property ZAxis As ChartZAxisSettings
Visual Basic (Usage) Copy Code
Dim instance As ChartSettings
Dim value As ChartZAxisSettings

value = instance.ZAxis
C#
[System.ComponentModel.DescriptionAttribute("Controls the Z axis appearance")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[ISNet.Serialization.BinarySerializableAttribute("setZAxis")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.Serialization.XmlSerializableAttribute(true)]
public ChartZAxisSettings ZAxis {get;}
Delphi
public read-only property ZAxis: ChartZAxisSettings;
JScript
System.ComponentModel.DescriptionAttribute("Controls the Z axis appearance")
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
ISNet.Serialization.BinarySerializableAttribute("setZAxis")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("General")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
ISNet.Serialization.XmlSerializableAttribute()
public function get ZAxis : ChartZAxisSettings
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Controls the Z axis appearance")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[ISNet.Serialization.BinarySerializableAttribute("setZAxis")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.Serialization.XmlSerializableAttribute(true)]
public: __property ChartZAxisSettings* get_ZAxis();
C++/CLI
[System.ComponentModel.DescriptionAttribute("Controls the Z axis appearance")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[ISNet.Serialization.BinarySerializableAttribute("setZAxis")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.Serialization.XmlSerializableAttribute(true)]
public:
property ChartZAxisSettings^ ZAxis {
   ChartZAxisSettings^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSettings Class
ChartSettings Members


ChartShadowStyle Class

[image]
Intersoft WebGrid Documentation
ChartShadowStyle Class
Members See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartShadowStyle Class

Glossary Item Box

Object Model

ChartShadowStyle Class

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.SerializableAttribute()>
Public Class ChartShadowStyle
   Inherits ISNet.WebUI.WebUIBaseClass
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Visual Basic (Usage) Copy Code
Dim instance As ChartShadowStyle
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public class ChartShadowStyle : ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Delphi
public class ChartShadowStyle = class(ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize)
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.SerializableAttribute()
public class ChartShadowStyle extends ISNet.WebUI.WebUIBaseClass implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public __gc class ChartShadowStyle : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public ref class ChartShadowStyle : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.WebGrid.Chart.ChartShadowStyle

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartShadowStyle Members
ISNet.WebUI.WebGrid.Chart Namespace


ChartShadowStyle Class Members

[image]
Intersoft WebGrid Documentation
ChartShadowStyle Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartShadowStyle Class

Glossary Item Box

The following tables list the members exposed by ChartShadowStyle.

Public Constructors

 | Name | Description
Public Constructor | ChartShadowStyle Constructor |
Top

Public Properties

 | Name | Description
Public Property | Color |
Public Property | FadeLength |
Public Property | Offset |
Public Property | Scale |
Public Property | Type |
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

ChartShadowStyle Class
ISNet.WebUI.WebGrid.Chart Namespace


ChartShadowStyle Constructor

[image]
Intersoft WebGrid Documentation
ChartShadowStyle Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartShadowStyle Class : ChartShadowStyle Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New ChartShadowStyle()
C#
public ChartShadowStyle()
Delphi
public ChartShadowStyle();
JScript
public function ChartShadowStyle();
Managed Extensions for C++
public: ChartShadowStyle();
C++/CLI
public:
ChartShadowStyle();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartShadowStyle Class
ChartShadowStyle Members


Clone Method

[image]
Intersoft WebGrid Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartShadowStyle Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As System.Object
Visual Basic (Usage) Copy Code
Dim instance As ChartShadowStyle
Dim value As System.Object

value = instance.Clone()
C#
public virtual System.object Clone()
Delphi
public function Clone(): System.TObject; virtual;
JScript
public function Clone() : System.Object;
Managed Extensions for C++
public: virtual System.Object* Clone();
C++/CLI
public:
virtual System.Object^ Clone();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartShadowStyle Class
ChartShadowStyle Members


CopyFrom Method

[image]
Intersoft WebGrid Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartShadowStyle Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartShadowStyle Class
ChartShadowStyle Members


CopyFrom(Object) Method

[image]
Intersoft WebGrid Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartShadowStyle Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartShadowStyle
Dim objSource As System.Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   System.object objSource
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartShadowStyle Class
ChartShadowStyle Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebGrid Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartShadowStyle Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object, _
   ByVal cloneSourceValue As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartShadowStyle
Dim objSource As System.Object
Dim cloneSourceValue As System.Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   System.object objSource,
   System.bool cloneSourceValue
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject;
    cloneSourceValue: System.Boolean
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object,
   cloneSourceValue : System.boolean
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource,
   System.bool cloneSourceValue
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource,
   System.bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartShadowStyle Class
ChartShadowStyle Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebGrid Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartShadowStyle Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartShadowStyle
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure DeSerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function DeSerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void DeSerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void DeSerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartShadowStyle Class
ChartShadowStyle Members


GetHashCode Method

[image]
Intersoft WebGrid Documentation
GetHashCode Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartShadowStyle Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As ChartShadowStyle
Dim value As System.Integer

value = instance.GetHashCode()
C#
public virtual System.int GetHashCode()
Delphi
public function GetHashCode(): System.Integer; virtual;
JScript
public function GetHashCode() : System.int;
Managed Extensions for C++
public: virtual System.int GetHashCode();
C++/CLI
public:
virtual System.int GetHashCode();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartShadowStyle Class
ChartShadowStyle Members


ChartShadowStyle Class Methods

[image]
Intersoft WebGrid Documentation
ChartShadowStyle Class Methods
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartShadowStyle Class

Glossary Item Box

For a list of all members of this type, see ChartShadowStyle members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

ChartShadowStyle Class
ISNet.WebUI.WebGrid.Chart Namespace


GetObjectData Method

[image]
Intersoft WebGrid Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartShadowStyle Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=False,
   UnmanagedCode=False,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=True,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Action=SecurityAction.Demand,
   Unrestricted=False)>
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartShadowStyle
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure GetObjectData(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
); override;
JScript
System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=,
   UnmanagedCode=,
   SkipVerification=,
   Execution=,
   ControlThread=,
   ControlEvidence=,
   ControlPolicy=,
   SerializationFormatter=,
   ControlDomainPolicy=,
   ControlPrincipal=,
   ControlAppDomain=,
   RemotingConfiguration=,
   Infrastructure=,
   BindingRedirects=,
   Action=SecurityAction.Demand,
   Unrestricted=)
public override function GetObjectData(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public: void GetObjectData(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
) override
C++/CLI
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public:
void GetObjectData(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
) override

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartShadowStyle Class
ChartShadowStyle Members


IsEmpty Method

[image]
Intersoft WebGrid Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartShadowStyle Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As ChartShadowStyle
Dim value As System.Boolean

value = instance.IsEmpty()
C#
public virtual System.bool IsEmpty()
Delphi
public function IsEmpty(): System.Boolean; virtual;
JScript
public function IsEmpty() : System.boolean;
Managed Extensions for C++
public: virtual System.bool IsEmpty();
C++/CLI
public:
virtual System.bool IsEmpty();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartShadowStyle Class
ChartShadowStyle Members


Reset Method

[image]
Intersoft WebGrid Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartShadowStyle Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As ChartShadowStyle

instance.Reset()
C#
public virtual void Reset()
Delphi
public procedure Reset(); virtual;
JScript
public function Reset();
Managed Extensions for C++
public: virtual void Reset();
C++/CLI
public:
virtual void Reset();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartShadowStyle Class
ChartShadowStyle Members


SerializeObjectData Method

[image]
Intersoft WebGrid Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartShadowStyle Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartShadowStyle
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure SerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function SerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void SerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void SerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartShadowStyle Class
ChartShadowStyle Members


ToString Method

[image]
Intersoft WebGrid Documentation
ToString Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartShadowStyle Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As System.String
Visual Basic (Usage) Copy Code
Dim instance As ChartShadowStyle
Dim value As System.String

value = instance.ToString()
C#
public virtual System.string ToString()
Delphi
public function ToString(): System.String; virtual;
JScript
public function ToString() : System.String;
Managed Extensions for C++
public: virtual System.string* ToString();
C++/CLI
public:
virtual System.String^ ToString();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartShadowStyle Class
ChartShadowStyle Members


ChartShadowStyle Class Properties

[image]
Intersoft WebGrid Documentation
ChartShadowStyle Class Properties
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartShadowStyle Class

Glossary Item Box

For a list of all members of this type, see ChartShadowStyle members.

Public Properties

 | Name | Description
Public Property | Color |
Public Property | FadeLength |
Public Property | Offset |
Public Property | Scale |
Public Property | Type |
Top

See Also

Reference

ChartShadowStyle Class
ISNet.WebUI.WebGrid.Chart Namespace


ChartShadowStyle Constructor

[image]
Intersoft WebGrid Documentation
ChartShadowStyle Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartShadowStyle Class : ChartShadowStyle Constructor

Glossary Item Box

Overload List

Overload | Description
ChartShadowStyle Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartShadowStyle Class
ChartShadowStyle Members


Color Property

[image]
Intersoft WebGrid Documentation
Color Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartShadowStyle Class : Color Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("General")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies the color of the shadow")>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property Color As System.Drawing.Color
Visual Basic (Usage) Copy Code
Dim instance As ChartShadowStyle
Dim value As System.Drawing.Color

instance.Color = value

value = instance.Color
C#
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the color of the shadow")]
[ISNet.Serialization.BinarySerializableAttribute()]
public System.Drawing.Color Color {get; set;}
Delphi
public read-write property Color: System.Drawing.Color;
JScript
System.ComponentModel.CategoryAttribute("General")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the color of the shadow")
ISNet.Serialization.BinarySerializableAttribute()
public function get,set Color : System.Drawing.Color
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the color of the shadow")]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.Drawing.Color get_Color();
public: __property void set_Color(
   System.Drawing.Color value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the color of the shadow")]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.Drawing.Color Color {
   System.Drawing.Color get();
   void set (    System.Drawing.Color value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartShadowStyle Class
ChartShadowStyle Members


FadeLength Property

[image]
Intersoft WebGrid Documentation
FadeLength Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartShadowStyle Class : FadeLength Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("General")>
<System.ComponentModel.DescriptionAttribute("Controls the length of the fading area")>
Public Property FadeLength As System.Nullable(Of Single)
Visual Basic (Usage) Copy Code
Dim instance As ChartShadowStyle
Dim value As System.Nullable(Of Single)

instance.FadeLength = value

value = instance.FadeLength
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DescriptionAttribute("Controls the length of the fading area")]
public System.Nullable<float> FadeLength {get; set;}
Delphi
public read-write property FadeLength: System.Nullable;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("General")
System.ComponentModel.DescriptionAttribute("Controls the length of the fading area")
public function get,set FadeLength : System.Nullable
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DescriptionAttribute("Controls the length of the fading area")]
public: __property System.Nullable<float> get_FadeLength();
public: __property void set_FadeLength(
   System.Nullable<float> value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DescriptionAttribute("Controls the length of the fading area")]
public:
property System.Nullable<float> FadeLength {
   System.Nullable<float> get();
   void set (    System.Nullable<float> value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartShadowStyle Class
ChartShadowStyle Members


Offset Property

[image]
Intersoft WebGrid Documentation
Offset Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartShadowStyle Class : Offset Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("General")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Controls the shadow offset")>
<ISNet.Serialization.BinarySerializableAttribute("setOffset")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
Public ReadOnly Property Offset As ChartPointValue
Visual Basic (Usage) Copy Code
Dim instance As ChartShadowStyle
Dim value As ChartPointValue

value = instance.Offset
C#
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Controls the shadow offset")]
[ISNet.Serialization.BinarySerializableAttribute("setOffset")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
public ChartPointValue Offset {get;}
Delphi
public read-only property Offset: ChartPointValue;
JScript
System.ComponentModel.CategoryAttribute("General")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Controls the shadow offset")
ISNet.Serialization.BinarySerializableAttribute("setOffset")
System.ComponentModel.NotifyParentPropertyAttribute()
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
public function get Offset : ChartPointValue
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Controls the shadow offset")]
[ISNet.Serialization.BinarySerializableAttribute("setOffset")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
public: __property ChartPointValue* get_Offset();
C++/CLI
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Controls the shadow offset")]
[ISNet.Serialization.BinarySerializableAttribute("setOffset")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
public:
property ChartPointValue^ Offset {
   ChartPointValue^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartShadowStyle Class
ChartShadowStyle Members


Scale Property

[image]
Intersoft WebGrid Documentation
Scale Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartShadowStyle Class : Scale Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("General")>
<System.ComponentModel.DescriptionAttribute("Scales the shadow.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property Scale As System.Single
Visual Basic (Usage) Copy Code
Dim instance As ChartShadowStyle
Dim value As System.Single

instance.Scale = value

value = instance.Scale
C#
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DescriptionAttribute("Scales the shadow.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.float Scale {get; set;}
Delphi
public read-write property Scale: System.Single;
JScript
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("General")
System.ComponentModel.DescriptionAttribute("Scales the shadow.")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set Scale : System.float
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DescriptionAttribute("Scales the shadow.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.float get_Scale();
public: __property void set_Scale(
   System.float value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DescriptionAttribute("Scales the shadow.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.float Scale {
   System.float get();
   void set (    System.float value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartShadowStyle Class
ChartShadowStyle Members


Type Property

[image]
Intersoft WebGrid Documentation
Type Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartShadowStyle Class : Type Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("General")>
<System.ComponentModel.DescriptionAttribute("Controls the type of the shadow ")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property Type As ShadowType
Visual Basic (Usage) Copy Code
Dim instance As ChartShadowStyle
Dim value As ShadowType

instance.Type = value

value = instance.Type
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DescriptionAttribute("Controls the type of the shadow ")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public ShadowType Type {get; set;}
Delphi
public read-write property Type: ShadowType;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("General")
System.ComponentModel.DescriptionAttribute("Controls the type of the shadow ")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set Type : ShadowType
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DescriptionAttribute("Controls the type of the shadow ")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property ShadowType get_Type();
public: __property void set_Type(
   ShadowType value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DescriptionAttribute("Controls the type of the shadow ")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property ShadowType Type {
   ShadowType get();
   void set (    ShadowType value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartShadowStyle Class
ChartShadowStyle Members


ChartShowOrHideRibbonSettings Class

[image]
Intersoft WebGrid Documentation
ChartShowOrHideRibbonSettings Class
Members See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartShowOrHideRibbonSettings Class

Glossary Item Box

Object Model

ChartShowOrHideRibbonSettings Class

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.SerializableAttribute()>
Public Class ChartShowOrHideRibbonSettings
   Inherits ISNet.WebUI.WebUIBaseClass
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Visual Basic (Usage) Copy Code
Dim instance As ChartShowOrHideRibbonSettings
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public class ChartShowOrHideRibbonSettings : ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Delphi
public class ChartShowOrHideRibbonSettings = class(ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize)
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.SerializableAttribute()
public class ChartShowOrHideRibbonSettings extends ISNet.WebUI.WebUIBaseClass implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public __gc class ChartShowOrHideRibbonSettings : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public ref class ChartShowOrHideRibbonSettings : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.WebGrid.Chart.ChartShowOrHideRibbonSettings

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartShowOrHideRibbonSettings Members
ISNet.WebUI.WebGrid.Chart Namespace


ChartShowOrHideRibbonSettings Class Members

[image]
Intersoft WebGrid Documentation
ChartShowOrHideRibbonSettings Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartShowOrHideRibbonSettings Class

Glossary Item Box

The following tables list the members exposed by ChartShowOrHideRibbonSettings.

Public Constructors

 | Name | Description
Public Constructor | ChartShowOrHideRibbonSettings Constructor |
Top

Public Properties

 | Name | Description
Public Property | ShowDropZone |
Public Property | ShowFieldList |
Public Property | Visible |
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

ChartShowOrHideRibbonSettings Class
ISNet.WebUI.WebGrid.Chart Namespace


ChartShowOrHideRibbonSettings Constructor

[image]
Intersoft WebGrid Documentation
ChartShowOrHideRibbonSettings Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartShowOrHideRibbonSettings Class : ChartShowOrHideRibbonSettings Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New ChartShowOrHideRibbonSettings()
C#
public ChartShowOrHideRibbonSettings()
Delphi
public ChartShowOrHideRibbonSettings();
JScript
public function ChartShowOrHideRibbonSettings();
Managed Extensions for C++
public: ChartShowOrHideRibbonSettings();
C++/CLI
public:
ChartShowOrHideRibbonSettings();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartShowOrHideRibbonSettings Class
ChartShowOrHideRibbonSettings Members


Clone Method

[image]
Intersoft WebGrid Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartShowOrHideRibbonSettings Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As System.Object
Visual Basic (Usage) Copy Code
Dim instance As ChartShowOrHideRibbonSettings
Dim value As System.Object

value = instance.Clone()
C#
public virtual System.object Clone()
Delphi
public function Clone(): System.TObject; virtual;
JScript
public function Clone() : System.Object;
Managed Extensions for C++
public: virtual System.Object* Clone();
C++/CLI
public:
virtual System.Object^ Clone();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartShowOrHideRibbonSettings Class
ChartShowOrHideRibbonSettings Members


CopyFrom Method

[image]
Intersoft WebGrid Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartShowOrHideRibbonSettings Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartShowOrHideRibbonSettings Class
ChartShowOrHideRibbonSettings Members


CopyFrom(Object) Method

[image]
Intersoft WebGrid Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartShowOrHideRibbonSettings Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartShowOrHideRibbonSettings
Dim objSource As System.Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   System.object objSource
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartShowOrHideRibbonSettings Class
ChartShowOrHideRibbonSettings Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebGrid Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartShowOrHideRibbonSettings Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object, _
   ByVal cloneSourceValue As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartShowOrHideRibbonSettings
Dim objSource As System.Object
Dim cloneSourceValue As System.Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   System.object objSource,
   System.bool cloneSourceValue
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject;
    cloneSourceValue: System.Boolean
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object,
   cloneSourceValue : System.boolean
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource,
   System.bool cloneSourceValue
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource,
   System.bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartShowOrHideRibbonSettings Class
ChartShowOrHideRibbonSettings Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebGrid Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartShowOrHideRibbonSettings Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartShowOrHideRibbonSettings
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure DeSerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function DeSerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void DeSerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void DeSerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartShowOrHideRibbonSettings Class
ChartShowOrHideRibbonSettings Members


GetHashCode Method

[image]
Intersoft WebGrid Documentation
GetHashCode Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartShowOrHideRibbonSettings Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As ChartShowOrHideRibbonSettings
Dim value As System.Integer

value = instance.GetHashCode()
C#
public virtual System.int GetHashCode()
Delphi
public function GetHashCode(): System.Integer; virtual;
JScript
public function GetHashCode() : System.int;
Managed Extensions for C++
public: virtual System.int GetHashCode();
C++/CLI
public:
virtual System.int GetHashCode();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartShowOrHideRibbonSettings Class
ChartShowOrHideRibbonSettings Members


ChartShowOrHideRibbonSettings Class Methods

[image]
Intersoft WebGrid Documentation
ChartShowOrHideRibbonSettings Class Methods
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartShowOrHideRibbonSettings Class

Glossary Item Box

For a list of all members of this type, see ChartShowOrHideRibbonSettings members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

ChartShowOrHideRibbonSettings Class
ISNet.WebUI.WebGrid.Chart Namespace


GetObjectData Method

[image]
Intersoft WebGrid Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartShowOrHideRibbonSettings Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=False,
   UnmanagedCode=False,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=True,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Action=SecurityAction.Demand,
   Unrestricted=False)>
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartShowOrHideRibbonSettings
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure GetObjectData(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
); override;
JScript
System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=,
   UnmanagedCode=,
   SkipVerification=,
   Execution=,
   ControlThread=,
   ControlEvidence=,
   ControlPolicy=,
   SerializationFormatter=,
   ControlDomainPolicy=,
   ControlPrincipal=,
   ControlAppDomain=,
   RemotingConfiguration=,
   Infrastructure=,
   BindingRedirects=,
   Action=SecurityAction.Demand,
   Unrestricted=)
public override function GetObjectData(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public: void GetObjectData(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
) override
C++/CLI
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public:
void GetObjectData(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
) override

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartShowOrHideRibbonSettings Class
ChartShowOrHideRibbonSettings Members


IsEmpty Method

[image]
Intersoft WebGrid Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartShowOrHideRibbonSettings Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As ChartShowOrHideRibbonSettings
Dim value As System.Boolean

value = instance.IsEmpty()
C#
public virtual System.bool IsEmpty()
Delphi
public function IsEmpty(): System.Boolean; virtual;
JScript
public function IsEmpty() : System.boolean;
Managed Extensions for C++
public: virtual System.bool IsEmpty();
C++/CLI
public:
virtual System.bool IsEmpty();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartShowOrHideRibbonSettings Class
ChartShowOrHideRibbonSettings Members


Reset Method

[image]
Intersoft WebGrid Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartShowOrHideRibbonSettings Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As ChartShowOrHideRibbonSettings

instance.Reset()
C#
public virtual void Reset()
Delphi
public procedure Reset(); virtual;
JScript
public function Reset();
Managed Extensions for C++
public: virtual void Reset();
C++/CLI
public:
virtual void Reset();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartShowOrHideRibbonSettings Class
ChartShowOrHideRibbonSettings Members


SerializeObjectData Method

[image]
Intersoft WebGrid Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartShowOrHideRibbonSettings Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartShowOrHideRibbonSettings
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure SerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function SerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void SerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void SerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartShowOrHideRibbonSettings Class
ChartShowOrHideRibbonSettings Members


ToString Method

[image]
Intersoft WebGrid Documentation
ToString Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartShowOrHideRibbonSettings Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As System.String
Visual Basic (Usage) Copy Code
Dim instance As ChartShowOrHideRibbonSettings
Dim value As System.String

value = instance.ToString()
C#
public virtual System.string ToString()
Delphi
public function ToString(): System.String; virtual;
JScript
public function ToString() : System.String;
Managed Extensions for C++
public: virtual System.string* ToString();
C++/CLI
public:
virtual System.String^ ToString();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartShowOrHideRibbonSettings Class
ChartShowOrHideRibbonSettings Members


ChartShowOrHideRibbonSettings Class Properties

[image]
Intersoft WebGrid Documentation
ChartShowOrHideRibbonSettings Class Properties
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartShowOrHideRibbonSettings Class

Glossary Item Box

For a list of all members of this type, see ChartShowOrHideRibbonSettings members.

Public Properties

 | Name | Description
Public Property | ShowDropZone |
Public Property | ShowFieldList |
Public Property | Visible |
Top

See Also

Reference

ChartShowOrHideRibbonSettings Class
ISNet.WebUI.WebGrid.Chart Namespace


ChartShowOrHideRibbonSettings Constructor

[image]
Intersoft WebGrid Documentation
ChartShowOrHideRibbonSettings Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartShowOrHideRibbonSettings Class : ChartShowOrHideRibbonSettings Constructor

Glossary Item Box

Overload List

Overload | Description
ChartShowOrHideRibbonSettings Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartShowOrHideRibbonSettings Class
ChartShowOrHideRibbonSettings Members


ShowDropZone Property

[image]
Intersoft WebGrid Documentation
ShowDropZone Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartShowOrHideRibbonSettings Class : ShowDropZone Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Specifies whether drop zone is activated initially.")>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Options")>
Public Property ShowDropZone As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As ChartShowOrHideRibbonSettings
Dim value As System.Boolean

instance.ShowDropZone = value

value = instance.ShowDropZone
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies whether drop zone is activated initially.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Options")]
public System.bool ShowDropZone {get; set;}
Delphi
public read-write property ShowDropZone: System.Boolean;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Specifies whether drop zone is activated initially.")
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Options")
public function get,set ShowDropZone : System.boolean
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies whether drop zone is activated initially.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Options")]
public: __property System.bool get_ShowDropZone();
public: __property void set_ShowDropZone(
   System.bool value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies whether drop zone is activated initially.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Options")]
public:
property System.bool ShowDropZone {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartShowOrHideRibbonSettings Class
ChartShowOrHideRibbonSettings Members


ShowFieldList Property

[image]
Intersoft WebGrid Documentation
ShowFieldList Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartShowOrHideRibbonSettings Class : ShowFieldList Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Specifies whether field list is activated initially.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Options")>
Public Property ShowFieldList As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As ChartShowOrHideRibbonSettings
Dim value As System.Boolean

instance.ShowFieldList = value

value = instance.ShowFieldList
C#
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies whether field list is activated initially.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Options")]
public System.bool ShowFieldList {get; set;}
Delphi
public read-write property ShowFieldList: System.Boolean;
JScript
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Specifies whether field list is activated initially.")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Options")
public function get,set ShowFieldList : System.boolean
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies whether field list is activated initially.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Options")]
public: __property System.bool get_ShowFieldList();
public: __property void set_ShowFieldList(
   System.bool value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies whether field list is activated initially.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Options")]
public:
property System.bool ShowFieldList {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartShowOrHideRibbonSettings Class
ChartShowOrHideRibbonSettings Members


Visible Property

[image]
Intersoft WebGrid Documentation
Visible Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartShowOrHideRibbonSettings Class : Visible Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Controls the visibility of the ribbon.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Options")>
Public Property Visible As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As ChartShowOrHideRibbonSettings
Dim value As System.Boolean

instance.Visible = value

value = instance.Visible
C#
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Controls the visibility of the ribbon.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Options")]
public System.bool Visible {get; set;}
Delphi
public read-write property Visible: System.Boolean;
JScript
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Controls the visibility of the ribbon.")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Options")
public function get,set Visible : System.boolean
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Controls the visibility of the ribbon.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Options")]
public: __property System.bool get_Visible();
public: __property void set_Visible(
   System.bool value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Controls the visibility of the ribbon.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Options")]
public:
property System.bool Visible {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartShowOrHideRibbonSettings Class
ChartShowOrHideRibbonSettings Members


ChartSizeValue Class

[image]
Intersoft WebGrid Documentation
ChartSizeValue Class
Members See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartSizeValue Class

Glossary Item Box

Object Model

ChartSizeValue Class

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.SerializableAttribute()>
Public Class ChartSizeValue
   Inherits ISNet.WebUI.WebUIBaseClass
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Visual Basic (Usage) Copy Code
Dim instance As ChartSizeValue
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public class ChartSizeValue : ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Delphi
public class ChartSizeValue = class(ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize)
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.SerializableAttribute()
public class ChartSizeValue extends ISNet.WebUI.WebUIBaseClass implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public __gc class ChartSizeValue : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public ref class ChartSizeValue : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.WebGrid.Chart.ChartSizeValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSizeValue Members
ISNet.WebUI.WebGrid.Chart Namespace


ChartSizeValue Class Members

[image]
Intersoft WebGrid Documentation
ChartSizeValue Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartSizeValue Class

Glossary Item Box

The following tables list the members exposed by ChartSizeValue.

Public Constructors

 | Name | Description
Public Constructor | ChartSizeValue Constructor |
Top

Public Properties

 | Name | Description
Public Property | Height |
Public Property | Width |
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

ChartSizeValue Class
ISNet.WebUI.WebGrid.Chart Namespace


ChartSizeValue Constructor

[image]
Intersoft WebGrid Documentation
ChartSizeValue Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSizeValue Class : ChartSizeValue Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New ChartSizeValue()
C#
public ChartSizeValue()
Delphi
public ChartSizeValue();
JScript
public function ChartSizeValue();
Managed Extensions for C++
public: ChartSizeValue();
C++/CLI
public:
ChartSizeValue();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSizeValue Class
ChartSizeValue Members


Clone Method

[image]
Intersoft WebGrid Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSizeValue Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As System.Object
Visual Basic (Usage) Copy Code
Dim instance As ChartSizeValue
Dim value As System.Object

value = instance.Clone()
C#
public virtual System.object Clone()
Delphi
public function Clone(): System.TObject; virtual;
JScript
public function Clone() : System.Object;
Managed Extensions for C++
public: virtual System.Object* Clone();
C++/CLI
public:
virtual System.Object^ Clone();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSizeValue Class
ChartSizeValue Members


CopyFrom Method

[image]
Intersoft WebGrid Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSizeValue Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSizeValue Class
ChartSizeValue Members


CopyFrom(Object) Method

[image]
Intersoft WebGrid Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSizeValue Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartSizeValue
Dim objSource As System.Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   System.object objSource
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSizeValue Class
ChartSizeValue Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebGrid Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSizeValue Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object, _
   ByVal cloneSourceValue As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartSizeValue
Dim objSource As System.Object
Dim cloneSourceValue As System.Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   System.object objSource,
   System.bool cloneSourceValue
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject;
    cloneSourceValue: System.Boolean
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object,
   cloneSourceValue : System.boolean
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource,
   System.bool cloneSourceValue
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource,
   System.bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSizeValue Class
ChartSizeValue Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebGrid Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSizeValue Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartSizeValue
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure DeSerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function DeSerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void DeSerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void DeSerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSizeValue Class
ChartSizeValue Members


GetHashCode Method

[image]
Intersoft WebGrid Documentation
GetHashCode Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSizeValue Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As ChartSizeValue
Dim value As System.Integer

value = instance.GetHashCode()
C#
public virtual System.int GetHashCode()
Delphi
public function GetHashCode(): System.Integer; virtual;
JScript
public function GetHashCode() : System.int;
Managed Extensions for C++
public: virtual System.int GetHashCode();
C++/CLI
public:
virtual System.int GetHashCode();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSizeValue Class
ChartSizeValue Members


ChartSizeValue Class Methods

[image]
Intersoft WebGrid Documentation
ChartSizeValue Class Methods
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartSizeValue Class

Glossary Item Box

For a list of all members of this type, see ChartSizeValue members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

ChartSizeValue Class
ISNet.WebUI.WebGrid.Chart Namespace


GetObjectData Method

[image]
Intersoft WebGrid Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSizeValue Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=False,
   UnmanagedCode=False,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=True,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Action=SecurityAction.Demand,
   Unrestricted=False)>
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartSizeValue
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure GetObjectData(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
); override;
JScript
System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=,
   UnmanagedCode=,
   SkipVerification=,
   Execution=,
   ControlThread=,
   ControlEvidence=,
   ControlPolicy=,
   SerializationFormatter=,
   ControlDomainPolicy=,
   ControlPrincipal=,
   ControlAppDomain=,
   RemotingConfiguration=,
   Infrastructure=,
   BindingRedirects=,
   Action=SecurityAction.Demand,
   Unrestricted=)
public override function GetObjectData(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public: void GetObjectData(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
) override
C++/CLI
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public:
void GetObjectData(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
) override

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSizeValue Class
ChartSizeValue Members


IsEmpty Method

[image]
Intersoft WebGrid Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSizeValue Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As ChartSizeValue
Dim value As System.Boolean

value = instance.IsEmpty()
C#
public virtual System.bool IsEmpty()
Delphi
public function IsEmpty(): System.Boolean; virtual;
JScript
public function IsEmpty() : System.boolean;
Managed Extensions for C++
public: virtual System.bool IsEmpty();
C++/CLI
public:
virtual System.bool IsEmpty();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSizeValue Class
ChartSizeValue Members


Reset Method

[image]
Intersoft WebGrid Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSizeValue Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As ChartSizeValue

instance.Reset()
C#
public virtual void Reset()
Delphi
public procedure Reset(); virtual;
JScript
public function Reset();
Managed Extensions for C++
public: virtual void Reset();
C++/CLI
public:
virtual void Reset();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSizeValue Class
ChartSizeValue Members


SerializeObjectData Method

[image]
Intersoft WebGrid Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSizeValue Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartSizeValue
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure SerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function SerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void SerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void SerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSizeValue Class
ChartSizeValue Members


ToString Method

[image]
Intersoft WebGrid Documentation
ToString Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSizeValue Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As System.String
Visual Basic (Usage) Copy Code
Dim instance As ChartSizeValue
Dim value As System.String

value = instance.ToString()
C#
public virtual System.string ToString()
Delphi
public function ToString(): System.String; virtual;
JScript
public function ToString() : System.String;
Managed Extensions for C++
public: virtual System.string* ToString();
C++/CLI
public:
virtual System.String^ ToString();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSizeValue Class
ChartSizeValue Members


ChartSizeValue Class Properties

[image]
Intersoft WebGrid Documentation
ChartSizeValue Class Properties
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartSizeValue Class

Glossary Item Box

For a list of all members of this type, see ChartSizeValue members.

Public Properties

 | Name | Description
Public Property | Height |
Public Property | Width |
Top

See Also

Reference

ChartSizeValue Class
ISNet.WebUI.WebGrid.Chart Namespace


ChartSizeValue Constructor

[image]
Intersoft WebGrid Documentation
ChartSizeValue Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSizeValue Class : ChartSizeValue Constructor

Glossary Item Box

Overload List

Overload | Description
ChartSizeValue Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSizeValue Class
ChartSizeValue Members


Height Property

[image]
Intersoft WebGrid Documentation
Height Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSizeValue Class : Height Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("General")>
<System.ComponentModel.DescriptionAttribute("Height.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property Height As System.Nullable(Of Unit)
Visual Basic (Usage) Copy Code
Dim instance As ChartSizeValue
Dim value As System.Nullable(Of Unit)

instance.Height = value

value = instance.Height
C#
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DescriptionAttribute("Height.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.Nullable<Unit> Height {get; set;}
Delphi
public read-write property Height: System.Nullable;
JScript
System.ComponentModel.CategoryAttribute("General")
System.ComponentModel.DescriptionAttribute("Height.")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set Height : System.Nullable
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DescriptionAttribute("Height.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.Nullable<Unit> get_Height();
public: __property void set_Height(
   System.Nullable<Unit> value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DescriptionAttribute("Height.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.Nullable<Unit> Height {
   System.Nullable<Unit> get();
   void set (    System.Nullable<Unit> value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSizeValue Class
ChartSizeValue Members


Width Property

[image]
Intersoft WebGrid Documentation
Width Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSizeValue Class : Width Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("General")>
<System.ComponentModel.DescriptionAttribute("Width.")>
Public Property Width As System.Nullable(Of Unit)
Visual Basic (Usage) Copy Code
Dim instance As ChartSizeValue
Dim value As System.Nullable(Of Unit)

instance.Width = value

value = instance.Width
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DescriptionAttribute("Width.")]
public System.Nullable<Unit> Width {get; set;}
Delphi
public read-write property Width: System.Nullable;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("General")
System.ComponentModel.DescriptionAttribute("Width.")
public function get,set Width : System.Nullable
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DescriptionAttribute("Width.")]
public: __property System.Nullable<Unit> get_Width();
public: __property void set_Width(
   System.Nullable<Unit> value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DescriptionAttribute("Width.")]
public:
property System.Nullable<Unit> Width {
   System.Nullable<Unit> get();
   void set (    System.Nullable<Unit> value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSizeValue Class
ChartSizeValue Members


ChartSmoothLineTypeSettings Class

[image]
Intersoft WebGrid Documentation
ChartSmoothLineTypeSettings Class
Members See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartSmoothLineTypeSettings Class

Glossary Item Box

Object Model

ChartSmoothLineTypeSettings Class

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.SerializableAttribute()>
Public Class ChartSmoothLineTypeSettings
   Inherits ISNet.WebUI.WebUIBaseClass
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Visual Basic (Usage) Copy Code
Dim instance As ChartSmoothLineTypeSettings
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public class ChartSmoothLineTypeSettings : ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Delphi
public class ChartSmoothLineTypeSettings = class(ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize)
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.SerializableAttribute()
public class ChartSmoothLineTypeSettings extends ISNet.WebUI.WebUIBaseClass implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public __gc class ChartSmoothLineTypeSettings : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public ref class ChartSmoothLineTypeSettings : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.WebGrid.Chart.ChartSmoothLineTypeSettings

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSmoothLineTypeSettings Members
ISNet.WebUI.WebGrid.Chart Namespace


ChartSmoothLineTypeSettings Class Members

[image]
Intersoft WebGrid Documentation
ChartSmoothLineTypeSettings Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartSmoothLineTypeSettings Class

Glossary Item Box

The following tables list the members exposed by ChartSmoothLineTypeSettings.

Public Constructors

 | Name | Description
Public Constructor | ChartSmoothLineTypeSettings Constructor |
Top

Public Properties

 | Name | Description
Public Property | Enabled |
Public Property | EnableOverlappedSmoothLineType |
Public Property | EnableOverlappedSmoothLineWithMarkersType |
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

ChartSmoothLineTypeSettings Class
ISNet.WebUI.WebGrid.Chart Namespace


ChartSmoothLineTypeSettings Constructor

[image]
Intersoft WebGrid Documentation
ChartSmoothLineTypeSettings Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSmoothLineTypeSettings Class : ChartSmoothLineTypeSettings Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New ChartSmoothLineTypeSettings()
C#
public ChartSmoothLineTypeSettings()
Delphi
public ChartSmoothLineTypeSettings();
JScript
public function ChartSmoothLineTypeSettings();
Managed Extensions for C++
public: ChartSmoothLineTypeSettings();
C++/CLI
public:
ChartSmoothLineTypeSettings();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSmoothLineTypeSettings Class
ChartSmoothLineTypeSettings Members


Clone Method

[image]
Intersoft WebGrid Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSmoothLineTypeSettings Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As System.Object
Visual Basic (Usage) Copy Code
Dim instance As ChartSmoothLineTypeSettings
Dim value As System.Object

value = instance.Clone()
C#
public virtual System.object Clone()
Delphi
public function Clone(): System.TObject; virtual;
JScript
public function Clone() : System.Object;
Managed Extensions for C++
public: virtual System.Object* Clone();
C++/CLI
public:
virtual System.Object^ Clone();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSmoothLineTypeSettings Class
ChartSmoothLineTypeSettings Members


CopyFrom Method

[image]
Intersoft WebGrid Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSmoothLineTypeSettings Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSmoothLineTypeSettings Class
ChartSmoothLineTypeSettings Members


CopyFrom(Object) Method

[image]
Intersoft WebGrid Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSmoothLineTypeSettings Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartSmoothLineTypeSettings
Dim objSource As System.Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   System.object objSource
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSmoothLineTypeSettings Class
ChartSmoothLineTypeSettings Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebGrid Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSmoothLineTypeSettings Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object, _
   ByVal cloneSourceValue As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartSmoothLineTypeSettings
Dim objSource As System.Object
Dim cloneSourceValue As System.Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   System.object objSource,
   System.bool cloneSourceValue
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject;
    cloneSourceValue: System.Boolean
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object,
   cloneSourceValue : System.boolean
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource,
   System.bool cloneSourceValue
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource,
   System.bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSmoothLineTypeSettings Class
ChartSmoothLineTypeSettings Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebGrid Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSmoothLineTypeSettings Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartSmoothLineTypeSettings
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure DeSerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function DeSerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void DeSerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void DeSerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSmoothLineTypeSettings Class
ChartSmoothLineTypeSettings Members


GetHashCode Method

[image]
Intersoft WebGrid Documentation
GetHashCode Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSmoothLineTypeSettings Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As ChartSmoothLineTypeSettings
Dim value As System.Integer

value = instance.GetHashCode()
C#
public virtual System.int GetHashCode()
Delphi
public function GetHashCode(): System.Integer; virtual;
JScript
public function GetHashCode() : System.int;
Managed Extensions for C++
public: virtual System.int GetHashCode();
C++/CLI
public:
virtual System.int GetHashCode();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSmoothLineTypeSettings Class
ChartSmoothLineTypeSettings Members


ChartSmoothLineTypeSettings Class Methods

[image]
Intersoft WebGrid Documentation
ChartSmoothLineTypeSettings Class Methods
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartSmoothLineTypeSettings Class

Glossary Item Box

For a list of all members of this type, see ChartSmoothLineTypeSettings members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

ChartSmoothLineTypeSettings Class
ISNet.WebUI.WebGrid.Chart Namespace


GetObjectData Method

[image]
Intersoft WebGrid Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSmoothLineTypeSettings Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=False,
   UnmanagedCode=False,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=True,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Action=SecurityAction.Demand,
   Unrestricted=False)>
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartSmoothLineTypeSettings
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure GetObjectData(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
); override;
JScript
System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=,
   UnmanagedCode=,
   SkipVerification=,
   Execution=,
   ControlThread=,
   ControlEvidence=,
   ControlPolicy=,
   SerializationFormatter=,
   ControlDomainPolicy=,
   ControlPrincipal=,
   ControlAppDomain=,
   RemotingConfiguration=,
   Infrastructure=,
   BindingRedirects=,
   Action=SecurityAction.Demand,
   Unrestricted=)
public override function GetObjectData(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public: void GetObjectData(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
) override
C++/CLI
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public:
void GetObjectData(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
) override

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSmoothLineTypeSettings Class
ChartSmoothLineTypeSettings Members


IsEmpty Method

[image]
Intersoft WebGrid Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSmoothLineTypeSettings Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As ChartSmoothLineTypeSettings
Dim value As System.Boolean

value = instance.IsEmpty()
C#
public virtual System.bool IsEmpty()
Delphi
public function IsEmpty(): System.Boolean; virtual;
JScript
public function IsEmpty() : System.boolean;
Managed Extensions for C++
public: virtual System.bool IsEmpty();
C++/CLI
public:
virtual System.bool IsEmpty();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSmoothLineTypeSettings Class
ChartSmoothLineTypeSettings Members


Reset Method

[image]
Intersoft WebGrid Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSmoothLineTypeSettings Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As ChartSmoothLineTypeSettings

instance.Reset()
C#
public virtual void Reset()
Delphi
public procedure Reset(); virtual;
JScript
public function Reset();
Managed Extensions for C++
public: virtual void Reset();
C++/CLI
public:
virtual void Reset();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSmoothLineTypeSettings Class
ChartSmoothLineTypeSettings Members


SerializeObjectData Method

[image]
Intersoft WebGrid Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSmoothLineTypeSettings Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartSmoothLineTypeSettings
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure SerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function SerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void SerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void SerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSmoothLineTypeSettings Class
ChartSmoothLineTypeSettings Members


ToString Method

[image]
Intersoft WebGrid Documentation
ToString Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSmoothLineTypeSettings Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As System.String
Visual Basic (Usage) Copy Code
Dim instance As ChartSmoothLineTypeSettings
Dim value As System.String

value = instance.ToString()
C#
public virtual System.string ToString()
Delphi
public function ToString(): System.String; virtual;
JScript
public function ToString() : System.String;
Managed Extensions for C++
public: virtual System.string* ToString();
C++/CLI
public:
virtual System.String^ ToString();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSmoothLineTypeSettings Class
ChartSmoothLineTypeSettings Members


ChartSmoothLineTypeSettings Class Properties

[image]
Intersoft WebGrid Documentation
ChartSmoothLineTypeSettings Class Properties
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartSmoothLineTypeSettings Class

Glossary Item Box

For a list of all members of this type, see ChartSmoothLineTypeSettings members.

Public Properties

 | Name | Description
Public Property | Enabled |
Public Property | EnableOverlappedSmoothLineType |
Public Property | EnableOverlappedSmoothLineWithMarkersType |
Top

See Also

Reference

ChartSmoothLineTypeSettings Class
ISNet.WebUI.WebGrid.Chart Namespace


ChartSmoothLineTypeSettings Constructor

[image]
Intersoft WebGrid Documentation
ChartSmoothLineTypeSettings Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSmoothLineTypeSettings Class : ChartSmoothLineTypeSettings Constructor

Glossary Item Box

Overload List

Overload | Description
ChartSmoothLineTypeSettings Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSmoothLineTypeSettings Class
ChartSmoothLineTypeSettings Members


Enabled Property

[image]
Intersoft WebGrid Documentation
Enabled Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSmoothLineTypeSettings Class : Enabled Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Options")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Enable user to switch chart to Series Smooth Line types.")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property Enabled As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As ChartSmoothLineTypeSettings
Dim value As System.Boolean

instance.Enabled = value

value = instance.Enabled
C#
[System.ComponentModel.CategoryAttribute("Options")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Enable user to switch chart to Series Smooth Line types.")]
[System.ComponentModel.DefaultValueAttribute()]
public System.bool Enabled {get; set;}
Delphi
public read-write property Enabled: System.Boolean;
JScript
System.ComponentModel.CategoryAttribute("Options")
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DescriptionAttribute("Enable user to switch chart to Series Smooth Line types.")
System.ComponentModel.DefaultValueAttribute()
public function get,set Enabled : System.boolean
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Options")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Enable user to switch chart to Series Smooth Line types.")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.bool get_Enabled();
public: __property void set_Enabled(
   System.bool value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Options")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Enable user to switch chart to Series Smooth Line types.")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.bool Enabled {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSmoothLineTypeSettings Class
ChartSmoothLineTypeSettings Members


EnableOverlappedSmoothLineType Property

[image]
Intersoft WebGrid Documentation
EnableOverlappedSmoothLineType Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSmoothLineTypeSettings Class : EnableOverlappedSmoothLineType Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Enable user to switch chart to Overlapped Smooth Line type.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Options")>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Property EnableOverlappedSmoothLineType As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As ChartSmoothLineTypeSettings
Dim value As System.Boolean

instance.EnableOverlappedSmoothLineType = value

value = instance.EnableOverlappedSmoothLineType
C#
[System.ComponentModel.DescriptionAttribute("Enable user to switch chart to Overlapped Smooth Line type.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Options")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public System.bool EnableOverlappedSmoothLineType {get; set;}
Delphi
public read-write property EnableOverlappedSmoothLineType: System.Boolean;
JScript
System.ComponentModel.DescriptionAttribute("Enable user to switch chart to Overlapped Smooth Line type.")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Options")
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute()
public function get,set EnableOverlappedSmoothLineType : System.boolean
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Enable user to switch chart to Overlapped Smooth Line type.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Options")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property System.bool get_EnableOverlappedSmoothLineType();
public: __property void set_EnableOverlappedSmoothLineType(
   System.bool value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Enable user to switch chart to Overlapped Smooth Line type.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Options")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property System.bool EnableOverlappedSmoothLineType {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSmoothLineTypeSettings Class
ChartSmoothLineTypeSettings Members


EnableOverlappedSmoothLineWithMarkersType Property

[image]
Intersoft WebGrid Documentation
EnableOverlappedSmoothLineWithMarkersType Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartSmoothLineTypeSettings Class : EnableOverlappedSmoothLineWithMarkersType Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Enable user to switch chart to Overlapped Smooth Line with Markers type.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Options")>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property EnableOverlappedSmoothLineWithMarkersType As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As ChartSmoothLineTypeSettings
Dim value As System.Boolean

instance.EnableOverlappedSmoothLineWithMarkersType = value

value = instance.EnableOverlappedSmoothLineWithMarkersType
C#
[System.ComponentModel.DescriptionAttribute("Enable user to switch chart to Overlapped Smooth Line with Markers type.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Options")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public System.bool EnableOverlappedSmoothLineWithMarkersType {get; set;}
Delphi
public read-write property EnableOverlappedSmoothLineWithMarkersType: System.Boolean;
JScript
System.ComponentModel.DescriptionAttribute("Enable user to switch chart to Overlapped Smooth Line with Markers type.")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Options")
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get,set EnableOverlappedSmoothLineWithMarkersType : System.boolean
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Enable user to switch chart to Overlapped Smooth Line with Markers type.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Options")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.bool get_EnableOverlappedSmoothLineWithMarkersType();
public: __property void set_EnableOverlappedSmoothLineWithMarkersType(
   System.bool value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Enable user to switch chart to Overlapped Smooth Line with Markers type.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Options")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.bool EnableOverlappedSmoothLineWithMarkersType {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartSmoothLineTypeSettings Class
ChartSmoothLineTypeSettings Members


ChartStandardFrameStyle Class

[image]
Intersoft WebGrid Documentation
ChartStandardFrameStyle Class
Members See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartStandardFrameStyle Class

Glossary Item Box

Object Model

ChartStandardFrameStyle Class

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.SerializableAttribute()>
Public Class ChartStandardFrameStyle
   Inherits ISNet.WebUI.WebUIBaseClass
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Visual Basic (Usage) Copy Code
Dim instance As ChartStandardFrameStyle
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public class ChartStandardFrameStyle : ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Delphi
public class ChartStandardFrameStyle = class(ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize)
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.SerializableAttribute()
public class ChartStandardFrameStyle extends ISNet.WebUI.WebUIBaseClass implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public __gc class ChartStandardFrameStyle : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public ref class ChartStandardFrameStyle : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.WebGrid.Chart.ChartStandardFrameStyle

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartStandardFrameStyle Members
ISNet.WebUI.WebGrid.Chart Namespace


ChartStandardFrameStyle Class Members

[image]
Intersoft WebGrid Documentation
ChartStandardFrameStyle Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartStandardFrameStyle Class

Glossary Item Box

The following tables list the members exposed by ChartStandardFrameStyle.

Public Constructors

 | Name | Description
Public Constructor | ChartStandardFrameStyle Constructor |
Top

Public Properties

 | Name | Description
Public Property | InnerBevelDarkColor |
Public Property | InnerBevelLightColor |
Public Property | InnerBevelStyle |
Public Property | InnerBevelWidth |
Public Property | InnerBorderColor |
Public Property | InnerBorderWidth |
Public Property | OuterBevelDarkColor |
Public Property | OuterBevelLightColor |
Public Property | OuterBevelStyle |
Public Property | OuterBevelWidth |
Public Property | OuterBorderColor |
Public Property | OuterBorderWidth |
Public Property | PredefinedFrameStyle |
Public Property | UsePredefinedFrameStyle |
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

ChartStandardFrameStyle Class
ISNet.WebUI.WebGrid.Chart Namespace


ChartStandardFrameStyle Constructor

[image]
Intersoft WebGrid Documentation
ChartStandardFrameStyle Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartStandardFrameStyle Class : ChartStandardFrameStyle Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New ChartStandardFrameStyle()
C#
public ChartStandardFrameStyle()
Delphi
public ChartStandardFrameStyle();
JScript
public function ChartStandardFrameStyle();
Managed Extensions for C++
public: ChartStandardFrameStyle();
C++/CLI
public:
ChartStandardFrameStyle();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartStandardFrameStyle Class
ChartStandardFrameStyle Members


Clone Method

[image]
Intersoft WebGrid Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartStandardFrameStyle Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As System.Object
Visual Basic (Usage) Copy Code
Dim instance As ChartStandardFrameStyle
Dim value As System.Object

value = instance.Clone()
C#
public virtual System.object Clone()
Delphi
public function Clone(): System.TObject; virtual;
JScript
public function Clone() : System.Object;
Managed Extensions for C++
public: virtual System.Object* Clone();
C++/CLI
public:
virtual System.Object^ Clone();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartStandardFrameStyle Class
ChartStandardFrameStyle Members


CopyFrom Method

[image]
Intersoft WebGrid Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartStandardFrameStyle Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartStandardFrameStyle Class
ChartStandardFrameStyle Members


CopyFrom(Object) Method

[image]
Intersoft WebGrid Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartStandardFrameStyle Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartStandardFrameStyle
Dim objSource As System.Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   System.object objSource
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartStandardFrameStyle Class
ChartStandardFrameStyle Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebGrid Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartStandardFrameStyle Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object, _
   ByVal cloneSourceValue As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartStandardFrameStyle
Dim objSource As System.Object
Dim cloneSourceValue As System.Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   System.object objSource,
   System.bool cloneSourceValue
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject;
    cloneSourceValue: System.Boolean
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object,
   cloneSourceValue : System.boolean
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource,
   System.bool cloneSourceValue
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource,
   System.bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartStandardFrameStyle Class
ChartStandardFrameStyle Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebGrid Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartStandardFrameStyle Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartStandardFrameStyle
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure DeSerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function DeSerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void DeSerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void DeSerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartStandardFrameStyle Class
ChartStandardFrameStyle Members


GetHashCode Method

[image]
Intersoft WebGrid Documentation
GetHashCode Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartStandardFrameStyle Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As ChartStandardFrameStyle
Dim value As System.Integer

value = instance.GetHashCode()
C#
public virtual System.int GetHashCode()
Delphi
public function GetHashCode(): System.Integer; virtual;
JScript
public function GetHashCode() : System.int;
Managed Extensions for C++
public: virtual System.int GetHashCode();
C++/CLI
public:
virtual System.int GetHashCode();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartStandardFrameStyle Class
ChartStandardFrameStyle Members


ChartStandardFrameStyle Class Methods

[image]
Intersoft WebGrid Documentation
ChartStandardFrameStyle Class Methods
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartStandardFrameStyle Class

Glossary Item Box

For a list of all members of this type, see ChartStandardFrameStyle members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

ChartStandardFrameStyle Class
ISNet.WebUI.WebGrid.Chart Namespace


GetObjectData Method

[image]
Intersoft WebGrid Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartStandardFrameStyle Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=False,
   UnmanagedCode=False,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=True,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Action=SecurityAction.Demand,
   Unrestricted=False)>
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartStandardFrameStyle
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure GetObjectData(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
); override;
JScript
System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=,
   UnmanagedCode=,
   SkipVerification=,
   Execution=,
   ControlThread=,
   ControlEvidence=,
   ControlPolicy=,
   SerializationFormatter=,
   ControlDomainPolicy=,
   ControlPrincipal=,
   ControlAppDomain=,
   RemotingConfiguration=,
   Infrastructure=,
   BindingRedirects=,
   Action=SecurityAction.Demand,
   Unrestricted=)
public override function GetObjectData(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public: void GetObjectData(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
) override
C++/CLI
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public:
void GetObjectData(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
) override

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartStandardFrameStyle Class
ChartStandardFrameStyle Members


IsEmpty Method

[image]
Intersoft WebGrid Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartStandardFrameStyle Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As ChartStandardFrameStyle
Dim value As System.Boolean

value = instance.IsEmpty()
C#
public virtual System.bool IsEmpty()
Delphi
public function IsEmpty(): System.Boolean; virtual;
JScript
public function IsEmpty() : System.boolean;
Managed Extensions for C++
public: virtual System.bool IsEmpty();
C++/CLI
public:
virtual System.bool IsEmpty();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartStandardFrameStyle Class
ChartStandardFrameStyle Members


Reset Method

[image]
Intersoft WebGrid Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartStandardFrameStyle Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As ChartStandardFrameStyle

instance.Reset()
C#
public virtual void Reset()
Delphi
public procedure Reset(); virtual;
JScript
public function Reset();
Managed Extensions for C++
public: virtual void Reset();
C++/CLI
public:
virtual void Reset();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartStandardFrameStyle Class
ChartStandardFrameStyle Members


SerializeObjectData Method

[image]
Intersoft WebGrid Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartStandardFrameStyle Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartStandardFrameStyle
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure SerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function SerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void SerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void SerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartStandardFrameStyle Class
ChartStandardFrameStyle Members


ToString Method

[image]
Intersoft WebGrid Documentation
ToString Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartStandardFrameStyle Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As System.String
Visual Basic (Usage) Copy Code
Dim instance As ChartStandardFrameStyle
Dim value As System.String

value = instance.ToString()
C#
public virtual System.string ToString()
Delphi
public function ToString(): System.String; virtual;
JScript
public function ToString() : System.String;
Managed Extensions for C++
public: virtual System.string* ToString();
C++/CLI
public:
virtual System.String^ ToString();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartStandardFrameStyle Class
ChartStandardFrameStyle Members


ChartStandardFrameStyle Class Properties

[image]
Intersoft WebGrid Documentation
ChartStandardFrameStyle Class Properties
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartStandardFrameStyle Class

Glossary Item Box

For a list of all members of this type, see ChartStandardFrameStyle members.

Public Properties

 | Name | Description
Public Property | InnerBevelDarkColor |
Public Property | InnerBevelLightColor |
Public Property | InnerBevelStyle |
Public Property | InnerBevelWidth |
Public Property | InnerBorderColor |
Public Property | InnerBorderWidth |
Public Property | OuterBevelDarkColor |
Public Property | OuterBevelLightColor |
Public Property | OuterBevelStyle |
Public Property | OuterBevelWidth |
Public Property | OuterBorderColor |
Public Property | OuterBorderWidth |
Public Property | PredefinedFrameStyle |
Public Property | UsePredefinedFrameStyle |
Top

See Also

Reference

ChartStandardFrameStyle Class
ISNet.WebUI.WebGrid.Chart Namespace


ChartStandardFrameStyle Constructor

[image]
Intersoft WebGrid Documentation
ChartStandardFrameStyle Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartStandardFrameStyle Class : ChartStandardFrameStyle Constructor

Glossary Item Box

Overload List

Overload | Description
ChartStandardFrameStyle Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartStandardFrameStyle Class
ChartStandardFrameStyle Members


InnerBevelDarkColor Property

[image]
Intersoft WebGrid Documentation
InnerBevelDarkColor Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartStandardFrameStyle Class : InnerBevelDarkColor Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Appearance")>
<System.ComponentModel.DescriptionAttribute("The color of the dark inner bevel side.")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property InnerBevelDarkColor As System.Drawing.Color
Visual Basic (Usage) Copy Code
Dim instance As ChartStandardFrameStyle
Dim value As System.Drawing.Color

instance.InnerBevelDarkColor = value

value = instance.InnerBevelDarkColor
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.DescriptionAttribute("The color of the dark inner bevel side.")]
[System.ComponentModel.DefaultValueAttribute()]
public System.Drawing.Color InnerBevelDarkColor {get; set;}
Delphi
public read-write property InnerBevelDarkColor: System.Drawing.Color;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Appearance")
System.ComponentModel.DescriptionAttribute("The color of the dark inner bevel side.")
System.ComponentModel.DefaultValueAttribute()
public function get,set InnerBevelDarkColor : System.Drawing.Color
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.DescriptionAttribute("The color of the dark inner bevel side.")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.Drawing.Color get_InnerBevelDarkColor();
public: __property void set_InnerBevelDarkColor(
   System.Drawing.Color value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.DescriptionAttribute("The color of the dark inner bevel side.")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.Drawing.Color InnerBevelDarkColor {
   System.Drawing.Color get();
   void set (    System.Drawing.Color value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartStandardFrameStyle Class
ChartStandardFrameStyle Members


InnerBevelLightColor Property

[image]
Intersoft WebGrid Documentation
InnerBevelLightColor Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartStandardFrameStyle Class : InnerBevelLightColor Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Appearance")>
<System.ComponentModel.DescriptionAttribute("The color of the light inner bevel side.")>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property InnerBevelLightColor As System.Drawing.Color
Visual Basic (Usage) Copy Code
Dim instance As ChartStandardFrameStyle
Dim value As System.Drawing.Color

instance.InnerBevelLightColor = value

value = instance.InnerBevelLightColor
C#
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.DescriptionAttribute("The color of the light inner bevel side.")]
[ISNet.Serialization.BinarySerializableAttribute()]
public System.Drawing.Color InnerBevelLightColor {get; set;}
Delphi
public read-write property InnerBevelLightColor: System.Drawing.Color;
JScript
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Appearance")
System.ComponentModel.DescriptionAttribute("The color of the light inner bevel side.")
ISNet.Serialization.BinarySerializableAttribute()
public function get,set InnerBevelLightColor : System.Drawing.Color
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.DescriptionAttribute("The color of the light inner bevel side.")]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.Drawing.Color get_InnerBevelLightColor();
public: __property void set_InnerBevelLightColor(
   System.Drawing.Color value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.DescriptionAttribute("The color of the light inner bevel side.")]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.Drawing.Color InnerBevelLightColor {
   System.Drawing.Color get();
   void set (    System.Drawing.Color value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartStandardFrameStyle Class
ChartStandardFrameStyle Members


InnerBevelStyle Property

[image]
Intersoft WebGrid Documentation
InnerBevelStyle Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartStandardFrameStyle Class : InnerBevelStyle Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Appearance")>
<System.ComponentModel.DescriptionAttribute("Controls the inner style of the frame.")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property InnerBevelStyle As FrameBevelStyle
Visual Basic (Usage) Copy Code
Dim instance As ChartStandardFrameStyle
Dim value As FrameBevelStyle

instance.InnerBevelStyle = value

value = instance.InnerBevelStyle
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.DescriptionAttribute("Controls the inner style of the frame.")]
[System.ComponentModel.DefaultValueAttribute()]
public FrameBevelStyle InnerBevelStyle {get; set;}
Delphi
public read-write property InnerBevelStyle: FrameBevelStyle;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Appearance")
System.ComponentModel.DescriptionAttribute("Controls the inner style of the frame.")
System.ComponentModel.DefaultValueAttribute()
public function get,set InnerBevelStyle : FrameBevelStyle
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.DescriptionAttribute("Controls the inner style of the frame.")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property FrameBevelStyle get_InnerBevelStyle();
public: __property void set_InnerBevelStyle(
   FrameBevelStyle value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.DescriptionAttribute("Controls the inner style of the frame.")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property FrameBevelStyle InnerBevelStyle {
   FrameBevelStyle get();
   void set (    FrameBevelStyle value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartStandardFrameStyle Class
ChartStandardFrameStyle Members


InnerBevelWidth Property

[image]
Intersoft WebGrid Documentation
InnerBevelWidth Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartStandardFrameStyle Class : InnerBevelWidth Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Controls the distance between the inner and the outer bevel.")>
<System.ComponentModel.CategoryAttribute("Size")>
Public Property InnerBevelWidth As System.Nullable(Of Single)
Visual Basic (Usage) Copy Code
Dim instance As ChartStandardFrameStyle
Dim value As System.Nullable(Of Single)

instance.InnerBevelWidth = value

value = instance.InnerBevelWidth
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Controls the distance between the inner and the outer bevel.")]
[System.ComponentModel.CategoryAttribute("Size")]
public System.Nullable<float> InnerBevelWidth {get; set;}
Delphi
public read-write property InnerBevelWidth: System.Nullable;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Controls the distance between the inner and the outer bevel.")
System.ComponentModel.CategoryAttribute("Size")
public function get,set InnerBevelWidth : System.Nullable
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Controls the distance between the inner and the outer bevel.")]
[System.ComponentModel.CategoryAttribute("Size")]
public: __property System.Nullable<float> get_InnerBevelWidth();
public: __property void set_InnerBevelWidth(
   System.Nullable<float> value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Controls the distance between the inner and the outer bevel.")]
[System.ComponentModel.CategoryAttribute("Size")]
public:
property System.Nullable<float> InnerBevelWidth {
   System.Nullable<float> get();
   void set (    System.Nullable<float> value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartStandardFrameStyle Class
ChartStandardFrameStyle Members


InnerBorderColor Property

[image]
Intersoft WebGrid Documentation
InnerBorderColor Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartStandardFrameStyle Class : InnerBorderColor Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Appearance")>
<System.ComponentModel.DescriptionAttribute("The color used to fill the inner border")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property InnerBorderColor As System.Drawing.Color
Visual Basic (Usage) Copy Code
Dim instance As ChartStandardFrameStyle
Dim value As System.Drawing.Color

instance.InnerBorderColor = value

value = instance.InnerBorderColor
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.DescriptionAttribute("The color used to fill the inner border")]
[System.ComponentModel.DefaultValueAttribute()]
public System.Drawing.Color InnerBorderColor {get; set;}
Delphi
public read-write property InnerBorderColor: System.Drawing.Color;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Appearance")
System.ComponentModel.DescriptionAttribute("The color used to fill the inner border")
System.ComponentModel.DefaultValueAttribute()
public function get,set InnerBorderColor : System.Drawing.Color
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.DescriptionAttribute("The color used to fill the inner border")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.Drawing.Color get_InnerBorderColor();
public: __property void set_InnerBorderColor(
   System.Drawing.Color value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.DescriptionAttribute("The color used to fill the inner border")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.Drawing.Color InnerBorderColor {
   System.Drawing.Color get();
   void set (    System.Drawing.Color value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartStandardFrameStyle Class
ChartStandardFrameStyle Members


InnerBorderWidth Property

[image]
Intersoft WebGrid Documentation
InnerBorderWidth Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartStandardFrameStyle Class : InnerBorderWidth Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Controls the width inner border.")>
<System.ComponentModel.CategoryAttribute("Size")>
Public Property InnerBorderWidth As System.Nullable(Of Single)
Visual Basic (Usage) Copy Code
Dim instance As ChartStandardFrameStyle
Dim value As System.Nullable(Of Single)

instance.InnerBorderWidth = value

value = instance.InnerBorderWidth
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Controls the width inner border.")]
[System.ComponentModel.CategoryAttribute("Size")]
public System.Nullable<float> InnerBorderWidth {get; set;}
Delphi
public read-write property InnerBorderWidth: System.Nullable;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Controls the width inner border.")
System.ComponentModel.CategoryAttribute("Size")
public function get,set InnerBorderWidth : System.Nullable
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Controls the width inner border.")]
[System.ComponentModel.CategoryAttribute("Size")]
public: __property System.Nullable<float> get_InnerBorderWidth();
public: __property void set_InnerBorderWidth(
   System.Nullable<float> value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Controls the width inner border.")]
[System.ComponentModel.CategoryAttribute("Size")]
public:
property System.Nullable<float> InnerBorderWidth {
   System.Nullable<float> get();
   void set (    System.Nullable<float> value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartStandardFrameStyle Class
ChartStandardFrameStyle Members


OuterBevelDarkColor Property

[image]
Intersoft WebGrid Documentation
OuterBevelDarkColor Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartStandardFrameStyle Class : OuterBevelDarkColor Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Appearance")>
<System.ComponentModel.DescriptionAttribute("The color of the dark outer bevel side.")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property OuterBevelDarkColor As System.Drawing.Color
Visual Basic (Usage) Copy Code
Dim instance As ChartStandardFrameStyle
Dim value As System.Drawing.Color

instance.OuterBevelDarkColor = value

value = instance.OuterBevelDarkColor
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.DescriptionAttribute("The color of the dark outer bevel side.")]
[System.ComponentModel.DefaultValueAttribute()]
public System.Drawing.Color OuterBevelDarkColor {get; set;}
Delphi
public read-write property OuterBevelDarkColor: System.Drawing.Color;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Appearance")
System.ComponentModel.DescriptionAttribute("The color of the dark outer bevel side.")
System.ComponentModel.DefaultValueAttribute()
public function get,set OuterBevelDarkColor : System.Drawing.Color
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.DescriptionAttribute("The color of the dark outer bevel side.")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.Drawing.Color get_OuterBevelDarkColor();
public: __property void set_OuterBevelDarkColor(
   System.Drawing.Color value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.DescriptionAttribute("The color of the dark outer bevel side.")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.Drawing.Color OuterBevelDarkColor {
   System.Drawing.Color get();
   void set (    System.Drawing.Color value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartStandardFrameStyle Class
ChartStandardFrameStyle Members


OuterBevelLightColor Property

[image]
Intersoft WebGrid Documentation
OuterBevelLightColor Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartStandardFrameStyle Class : OuterBevelLightColor Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("Appearance")>
<System.ComponentModel.DescriptionAttribute("The color of the light outer bevel side.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property OuterBevelLightColor As System.Drawing.Color
Visual Basic (Usage) Copy Code
Dim instance As ChartStandardFrameStyle
Dim value As System.Drawing.Color

instance.OuterBevelLightColor = value

value = instance.OuterBevelLightColor
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.DescriptionAttribute("The color of the light outer bevel side.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.Drawing.Color OuterBevelLightColor {get; set;}
Delphi
public read-write property OuterBevelLightColor: System.Drawing.Color;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("Appearance")
System.ComponentModel.DescriptionAttribute("The color of the light outer bevel side.")
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set OuterBevelLightColor : System.Drawing.Color
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.DescriptionAttribute("The color of the light outer bevel side.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.Drawing.Color get_OuterBevelLightColor();
public: __property void set_OuterBevelLightColor(
   System.Drawing.Color value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.DescriptionAttribute("The color of the light outer bevel side.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.Drawing.Color OuterBevelLightColor {
   System.Drawing.Color get();
   void set (    System.Drawing.Color value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartStandardFrameStyle Class
ChartStandardFrameStyle Members


OuterBevelStyle Property

[image]
Intersoft WebGrid Documentation
OuterBevelStyle Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartStandardFrameStyle Class : OuterBevelStyle Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Appearance")>
<System.ComponentModel.DescriptionAttribute("Controls the outer bevel style of the frame.")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property OuterBevelStyle As FrameBevelStyle
Visual Basic (Usage) Copy Code
Dim instance As ChartStandardFrameStyle
Dim value As FrameBevelStyle

instance.OuterBevelStyle = value

value = instance.OuterBevelStyle
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.DescriptionAttribute("Controls the outer bevel style of the frame.")]
[System.ComponentModel.DefaultValueAttribute()]
public FrameBevelStyle OuterBevelStyle {get; set;}
Delphi
public read-write property OuterBevelStyle: FrameBevelStyle;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Appearance")
System.ComponentModel.DescriptionAttribute("Controls the outer bevel style of the frame.")
System.ComponentModel.DefaultValueAttribute()
public function get,set OuterBevelStyle : FrameBevelStyle
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.DescriptionAttribute("Controls the outer bevel style of the frame.")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property FrameBevelStyle get_OuterBevelStyle();
public: __property void set_OuterBevelStyle(
   FrameBevelStyle value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.DescriptionAttribute("Controls the outer bevel style of the frame.")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property FrameBevelStyle OuterBevelStyle {
   FrameBevelStyle get();
   void set (    FrameBevelStyle value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartStandardFrameStyle Class
ChartStandardFrameStyle Members


OuterBevelWidth Property

[image]
Intersoft WebGrid Documentation
OuterBevelWidth Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartStandardFrameStyle Class : OuterBevelWidth Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Size")>
<System.ComponentModel.DescriptionAttribute("Controls the width of the inner and the outer bevels.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property OuterBevelWidth As System.Nullable(Of Single)
Visual Basic (Usage) Copy Code
Dim instance As ChartStandardFrameStyle
Dim value As System.Nullable(Of Single)

instance.OuterBevelWidth = value

value = instance.OuterBevelWidth
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Size")]
[System.ComponentModel.DescriptionAttribute("Controls the width of the inner and the outer bevels.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.Nullable<float> OuterBevelWidth {get; set;}
Delphi
public read-write property OuterBevelWidth: System.Nullable;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Size")
System.ComponentModel.DescriptionAttribute("Controls the width of the inner and the outer bevels.")
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set OuterBevelWidth : System.Nullable
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Size")]
[System.ComponentModel.DescriptionAttribute("Controls the width of the inner and the outer bevels.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.Nullable<float> get_OuterBevelWidth();
public: __property void set_OuterBevelWidth(
   System.Nullable<float> value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Size")]
[System.ComponentModel.DescriptionAttribute("Controls the width of the inner and the outer bevels.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.Nullable<float> OuterBevelWidth {
   System.Nullable<float> get();
   void set (    System.Nullable<float> value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartStandardFrameStyle Class
ChartStandardFrameStyle Members


OuterBorderColor Property

[image]
Intersoft WebGrid Documentation
OuterBorderColor Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartStandardFrameStyle Class : OuterBorderColor Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Appearance")>
<System.ComponentModel.DescriptionAttribute("The color used to fill the gap between the inner and the outer bevel.")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property OuterBorderColor As System.Drawing.Color
Visual Basic (Usage) Copy Code
Dim instance As ChartStandardFrameStyle
Dim value As System.Drawing.Color

instance.OuterBorderColor = value

value = instance.OuterBorderColor
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.DescriptionAttribute("The color used to fill the gap between the inner and the outer bevel.")]
[System.ComponentModel.DefaultValueAttribute()]
public System.Drawing.Color OuterBorderColor {get; set;}
Delphi
public read-write property OuterBorderColor: System.Drawing.Color;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Appearance")
System.ComponentModel.DescriptionAttribute("The color used to fill the gap between the inner and the outer bevel.")
System.ComponentModel.DefaultValueAttribute()
public function get,set OuterBorderColor : System.Drawing.Color
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.DescriptionAttribute("The color used to fill the gap between the inner and the outer bevel.")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.Drawing.Color get_OuterBorderColor();
public: __property void set_OuterBorderColor(
   System.Drawing.Color value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.DescriptionAttribute("The color used to fill the gap between the inner and the outer bevel.")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.Drawing.Color OuterBorderColor {
   System.Drawing.Color get();
   void set (    System.Drawing.Color value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartStandardFrameStyle Class
ChartStandardFrameStyle Members


OuterBorderWidth Property

[image]
Intersoft WebGrid Documentation
OuterBorderWidth Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartStandardFrameStyle Class : OuterBorderWidth Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Size")>
<System.ComponentModel.DescriptionAttribute("Controls the width outer border (between the inner and the outer bevels).")>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property OuterBorderWidth As System.Nullable(Of Single)
Visual Basic (Usage) Copy Code
Dim instance As ChartStandardFrameStyle
Dim value As System.Nullable(Of Single)

instance.OuterBorderWidth = value

value = instance.OuterBorderWidth
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Size")]
[System.ComponentModel.DescriptionAttribute("Controls the width outer border (between the inner and the outer bevels).")]
[ISNet.Serialization.BinarySerializableAttribute()]
public System.Nullable<float> OuterBorderWidth {get; set;}
Delphi
public read-write property OuterBorderWidth: System.Nullable;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Size")
System.ComponentModel.DescriptionAttribute("Controls the width outer border (between the inner and the outer bevels).")
ISNet.Serialization.BinarySerializableAttribute()
public function get,set OuterBorderWidth : System.Nullable
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Size")]
[System.ComponentModel.DescriptionAttribute("Controls the width outer border (between the inner and the outer bevels).")]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.Nullable<float> get_OuterBorderWidth();
public: __property void set_OuterBorderWidth(
   System.Nullable<float> value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Size")]
[System.ComponentModel.DescriptionAttribute("Controls the width outer border (between the inner and the outer bevels).")]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.Nullable<float> OuterBorderWidth {
   System.Nullable<float> get();
   void set (    System.Nullable<float> value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartStandardFrameStyle Class
ChartStandardFrameStyle Members


PredefinedFrameStyle Property

[image]
Intersoft WebGrid Documentation
PredefinedFrameStyle Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartStandardFrameStyle Class : PredefinedFrameStyle Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("General")>
<System.ComponentModel.DescriptionAttribute("Predefined frame style.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property PredefinedFrameStyle As PredefinedStandardFrame
Visual Basic (Usage) Copy Code
Dim instance As ChartStandardFrameStyle
Dim value As PredefinedStandardFrame

instance.PredefinedFrameStyle = value

value = instance.PredefinedFrameStyle
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DescriptionAttribute("Predefined frame style.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public PredefinedStandardFrame PredefinedFrameStyle {get; set;}
Delphi
public read-write property PredefinedFrameStyle: PredefinedStandardFrame;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("General")
System.ComponentModel.DescriptionAttribute("Predefined frame style.")
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set PredefinedFrameStyle : PredefinedStandardFrame
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DescriptionAttribute("Predefined frame style.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property PredefinedStandardFrame get_PredefinedFrameStyle();
public: __property void set_PredefinedFrameStyle(
   PredefinedStandardFrame value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DescriptionAttribute("Predefined frame style.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property PredefinedStandardFrame PredefinedFrameStyle {
   PredefinedStandardFrame get();
   void set (    PredefinedStandardFrame value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartStandardFrameStyle Class
ChartStandardFrameStyle Members


UsePredefinedFrameStyle Property

[image]
Intersoft WebGrid Documentation
UsePredefinedFrameStyle Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartStandardFrameStyle Class : UsePredefinedFrameStyle Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("General")>
<System.ComponentModel.DescriptionAttribute("Use predefined frame style specified in PredefinedFrameStyle property.")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property UsePredefinedFrameStyle As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As ChartStandardFrameStyle
Dim value As System.Boolean

instance.UsePredefinedFrameStyle = value

value = instance.UsePredefinedFrameStyle
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DescriptionAttribute("Use predefined frame style specified in PredefinedFrameStyle property.")]
[System.ComponentModel.DefaultValueAttribute()]
public System.bool UsePredefinedFrameStyle {get; set;}
Delphi
public read-write property UsePredefinedFrameStyle: System.Boolean;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("General")
System.ComponentModel.DescriptionAttribute("Use predefined frame style specified in PredefinedFrameStyle property.")
System.ComponentModel.DefaultValueAttribute()
public function get,set UsePredefinedFrameStyle : System.boolean
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DescriptionAttribute("Use predefined frame style specified in PredefinedFrameStyle property.")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.bool get_UsePredefinedFrameStyle();
public: __property void set_UsePredefinedFrameStyle(
   System.bool value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DescriptionAttribute("Use predefined frame style specified in PredefinedFrameStyle property.")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.bool UsePredefinedFrameStyle {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartStandardFrameStyle Class
ChartStandardFrameStyle Members


ChartStepLineTypeSettings Class

[image]
Intersoft WebGrid Documentation
ChartStepLineTypeSettings Class
Members See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartStepLineTypeSettings Class

Glossary Item Box

Object Model

ChartStepLineTypeSettings Class

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.SerializableAttribute()>
Public Class ChartStepLineTypeSettings
   Inherits ISNet.WebUI.WebUIBaseClass
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Visual Basic (Usage) Copy Code
Dim instance As ChartStepLineTypeSettings
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public class ChartStepLineTypeSettings : ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Delphi
public class ChartStepLineTypeSettings = class(ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize)
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.SerializableAttribute()
public class ChartStepLineTypeSettings extends ISNet.WebUI.WebUIBaseClass implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public __gc class ChartStepLineTypeSettings : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public ref class ChartStepLineTypeSettings : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.WebGrid.Chart.ChartStepLineTypeSettings

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartStepLineTypeSettings Members
ISNet.WebUI.WebGrid.Chart Namespace


ChartStepLineTypeSettings Class Members

[image]
Intersoft WebGrid Documentation
ChartStepLineTypeSettings Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartStepLineTypeSettings Class

Glossary Item Box

The following tables list the members exposed by ChartStepLineTypeSettings.

Public Constructors

 | Name | Description
Public Constructor | ChartStepLineTypeSettings Constructor |
Top

Public Properties

 | Name | Description
Public Property | EnableBasic3DStepLineType |
Public Property | EnableBasic3DStepLineWithMarkersType |
Public Property | Enabled |
Public Property | EnableOverlappedStepLineType |
Public Property | EnableOverlappedStepLineWithMarkersType |
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

ChartStepLineTypeSettings Class
ISNet.WebUI.WebGrid.Chart Namespace


ChartStepLineTypeSettings Constructor

[image]
Intersoft WebGrid Documentation
ChartStepLineTypeSettings Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartStepLineTypeSettings Class : ChartStepLineTypeSettings Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New ChartStepLineTypeSettings()
C#
public ChartStepLineTypeSettings()
Delphi
public ChartStepLineTypeSettings();
JScript
public function ChartStepLineTypeSettings();
Managed Extensions for C++
public: ChartStepLineTypeSettings();
C++/CLI
public:
ChartStepLineTypeSettings();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartStepLineTypeSettings Class
ChartStepLineTypeSettings Members


Clone Method

[image]
Intersoft WebGrid Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartStepLineTypeSettings Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As System.Object
Visual Basic (Usage) Copy Code
Dim instance As ChartStepLineTypeSettings
Dim value As System.Object

value = instance.Clone()
C#
public virtual System.object Clone()
Delphi
public function Clone(): System.TObject; virtual;
JScript
public function Clone() : System.Object;
Managed Extensions for C++
public: virtual System.Object* Clone();
C++/CLI
public:
virtual System.Object^ Clone();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartStepLineTypeSettings Class
ChartStepLineTypeSettings Members


CopyFrom Method

[image]
Intersoft WebGrid Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartStepLineTypeSettings Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartStepLineTypeSettings Class
ChartStepLineTypeSettings Members


CopyFrom(Object) Method

[image]
Intersoft WebGrid Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartStepLineTypeSettings Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartStepLineTypeSettings
Dim objSource As System.Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   System.object objSource
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartStepLineTypeSettings Class
ChartStepLineTypeSettings Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebGrid Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartStepLineTypeSettings Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object, _
   ByVal cloneSourceValue As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartStepLineTypeSettings
Dim objSource As System.Object
Dim cloneSourceValue As System.Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   System.object objSource,
   System.bool cloneSourceValue
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject;
    cloneSourceValue: System.Boolean
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object,
   cloneSourceValue : System.boolean
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource,
   System.bool cloneSourceValue
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource,
   System.bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartStepLineTypeSettings Class
ChartStepLineTypeSettings Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebGrid Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartStepLineTypeSettings Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartStepLineTypeSettings
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure DeSerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function DeSerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void DeSerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void DeSerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartStepLineTypeSettings Class
ChartStepLineTypeSettings Members


GetHashCode Method

[image]
Intersoft WebGrid Documentation
GetHashCode Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartStepLineTypeSettings Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As ChartStepLineTypeSettings
Dim value As System.Integer

value = instance.GetHashCode()
C#
public virtual System.int GetHashCode()
Delphi
public function GetHashCode(): System.Integer; virtual;
JScript
public function GetHashCode() : System.int;
Managed Extensions for C++
public: virtual System.int GetHashCode();
C++/CLI
public:
virtual System.int GetHashCode();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartStepLineTypeSettings Class
ChartStepLineTypeSettings Members


ChartStepLineTypeSettings Class Methods

[image]
Intersoft WebGrid Documentation
ChartStepLineTypeSettings Class Methods
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartStepLineTypeSettings Class

Glossary Item Box

For a list of all members of this type, see ChartStepLineTypeSettings members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

ChartStepLineTypeSettings Class
ISNet.WebUI.WebGrid.Chart Namespace


GetObjectData Method

[image]
Intersoft WebGrid Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartStepLineTypeSettings Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=False,
   UnmanagedCode=False,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=True,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Action=SecurityAction.Demand,
   Unrestricted=False)>
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartStepLineTypeSettings
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure GetObjectData(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
); override;
JScript
System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=,
   UnmanagedCode=,
   SkipVerification=,
   Execution=,
   ControlThread=,
   ControlEvidence=,
   ControlPolicy=,
   SerializationFormatter=,
   ControlDomainPolicy=,
   ControlPrincipal=,
   ControlAppDomain=,
   RemotingConfiguration=,
   Infrastructure=,
   BindingRedirects=,
   Action=SecurityAction.Demand,
   Unrestricted=)
public override function GetObjectData(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public: void GetObjectData(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
) override
C++/CLI
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public:
void GetObjectData(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
) override

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartStepLineTypeSettings Class
ChartStepLineTypeSettings Members


IsEmpty Method

[image]
Intersoft WebGrid Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartStepLineTypeSettings Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As ChartStepLineTypeSettings
Dim value As System.Boolean

value = instance.IsEmpty()
C#
public virtual System.bool IsEmpty()
Delphi
public function IsEmpty(): System.Boolean; virtual;
JScript
public function IsEmpty() : System.boolean;
Managed Extensions for C++
public: virtual System.bool IsEmpty();
C++/CLI
public:
virtual System.bool IsEmpty();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartStepLineTypeSettings Class
ChartStepLineTypeSettings Members


Reset Method

[image]
Intersoft WebGrid Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartStepLineTypeSettings Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As ChartStepLineTypeSettings

instance.Reset()
C#
public virtual void Reset()
Delphi
public procedure Reset(); virtual;
JScript
public function Reset();
Managed Extensions for C++
public: virtual void Reset();
C++/CLI
public:
virtual void Reset();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartStepLineTypeSettings Class
ChartStepLineTypeSettings Members


SerializeObjectData Method

[image]
Intersoft WebGrid Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartStepLineTypeSettings Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartStepLineTypeSettings
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure SerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function SerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void SerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void SerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartStepLineTypeSettings Class
ChartStepLineTypeSettings Members


ToString Method

[image]
Intersoft WebGrid Documentation
ToString Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartStepLineTypeSettings Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As System.String
Visual Basic (Usage) Copy Code
Dim instance As ChartStepLineTypeSettings
Dim value As System.String

value = instance.ToString()
C#
public virtual System.string ToString()
Delphi
public function ToString(): System.String; virtual;
JScript
public function ToString() : System.String;
Managed Extensions for C++
public: virtual System.string* ToString();
C++/CLI
public:
virtual System.String^ ToString();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartStepLineTypeSettings Class
ChartStepLineTypeSettings Members


ChartStepLineTypeSettings Class Properties

[image]
Intersoft WebGrid Documentation
ChartStepLineTypeSettings Class Properties
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartStepLineTypeSettings Class

Glossary Item Box

For a list of all members of this type, see ChartStepLineTypeSettings members.

Public Properties

 | Name | Description
Public Property | EnableBasic3DStepLineType |
Public Property | EnableBasic3DStepLineWithMarkersType |
Public Property | Enabled |
Public Property | EnableOverlappedStepLineType |
Public Property | EnableOverlappedStepLineWithMarkersType |
Top

See Also

Reference

ChartStepLineTypeSettings Class
ISNet.WebUI.WebGrid.Chart Namespace


ChartStepLineTypeSettings Constructor

[image]
Intersoft WebGrid Documentation
ChartStepLineTypeSettings Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartStepLineTypeSettings Class : ChartStepLineTypeSettings Constructor

Glossary Item Box

Overload List

Overload | Description
ChartStepLineTypeSettings Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartStepLineTypeSettings Class
ChartStepLineTypeSettings Members


EnableBasic3DStepLineType Property

[image]
Intersoft WebGrid Documentation
EnableBasic3DStepLineType Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartStepLineTypeSettings Class : EnableBasic3DStepLineType Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Options")>
<System.ComponentModel.DescriptionAttribute("Enable user to switch chart to Basic 3D StepLine type.")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property EnableBasic3DStepLineType As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As ChartStepLineTypeSettings
Dim value As System.Boolean

instance.EnableBasic3DStepLineType = value

value = instance.EnableBasic3DStepLineType
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Options")]
[System.ComponentModel.DescriptionAttribute("Enable user to switch chart to Basic 3D StepLine type.")]
[System.ComponentModel.DefaultValueAttribute()]
public System.bool EnableBasic3DStepLineType {get; set;}
Delphi
public read-write property EnableBasic3DStepLineType: System.Boolean;
JScript
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Options")
System.ComponentModel.DescriptionAttribute("Enable user to switch chart to Basic 3D StepLine type.")
System.ComponentModel.DefaultValueAttribute()
public function get,set EnableBasic3DStepLineType : System.boolean
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Options")]
[System.ComponentModel.DescriptionAttribute("Enable user to switch chart to Basic 3D StepLine type.")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.bool get_EnableBasic3DStepLineType();
public: __property void set_EnableBasic3DStepLineType(
   System.bool value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Options")]
[System.ComponentModel.DescriptionAttribute("Enable user to switch chart to Basic 3D StepLine type.")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.bool EnableBasic3DStepLineType {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartStepLineTypeSettings Class
ChartStepLineTypeSettings Members


EnableBasic3DStepLineWithMarkersType Property

[image]
Intersoft WebGrid Documentation
EnableBasic3DStepLineWithMarkersType Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartStepLineTypeSettings Class : EnableBasic3DStepLineWithMarkersType Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Options")>
<System.ComponentModel.DescriptionAttribute("Enable user to switch chart to Basic 3D StepLine with Markers type.")>
Public Property EnableBasic3DStepLineWithMarkersType As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As ChartStepLineTypeSettings
Dim value As System.Boolean

instance.EnableBasic3DStepLineWithMarkersType = value

value = instance.EnableBasic3DStepLineWithMarkersType
C#
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Options")]
[System.ComponentModel.DescriptionAttribute("Enable user to switch chart to Basic 3D StepLine with Markers type.")]
public System.bool EnableBasic3DStepLineWithMarkersType {get; set;}
Delphi
public read-write property EnableBasic3DStepLineWithMarkersType: System.Boolean;
JScript
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Options")
System.ComponentModel.DescriptionAttribute("Enable user to switch chart to Basic 3D StepLine with Markers type.")
public function get,set EnableBasic3DStepLineWithMarkersType : System.boolean
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Options")]
[System.ComponentModel.DescriptionAttribute("Enable user to switch chart to Basic 3D StepLine with Markers type.")]
public: __property System.bool get_EnableBasic3DStepLineWithMarkersType();
public: __property void set_EnableBasic3DStepLineWithMarkersType(
   System.bool value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Options")]
[System.ComponentModel.DescriptionAttribute("Enable user to switch chart to Basic 3D StepLine with Markers type.")]
public:
property System.bool EnableBasic3DStepLineWithMarkersType {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartStepLineTypeSettings Class
ChartStepLineTypeSettings Members


Enabled Property

[image]
Intersoft WebGrid Documentation
Enabled Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartStepLineTypeSettings Class : Enabled Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Enable user to switch chart to Series StepLine types.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Options")>
Public Property Enabled As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As ChartStepLineTypeSettings
Dim value As System.Boolean

instance.Enabled = value

value = instance.Enabled
C#
[System.ComponentModel.DescriptionAttribute("Enable user to switch chart to Series StepLine types.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Options")]
public System.bool Enabled {get; set;}
Delphi
public read-write property Enabled: System.Boolean;
JScript
System.ComponentModel.DescriptionAttribute("Enable user to switch chart to Series StepLine types.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Options")
public function get,set Enabled : System.boolean
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Enable user to switch chart to Series StepLine types.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Options")]
public: __property System.bool get_Enabled();
public: __property void set_Enabled(
   System.bool value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Enable user to switch chart to Series StepLine types.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Options")]
public:
property System.bool Enabled {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartStepLineTypeSettings Class
ChartStepLineTypeSettings Members


EnableOverlappedStepLineType Property

[image]
Intersoft WebGrid Documentation
EnableOverlappedStepLineType Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartStepLineTypeSettings Class : EnableOverlappedStepLineType Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Enable user to switch chart to Overlapped StepLine type.")>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Options")>
Public Property EnableOverlappedStepLineType As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As ChartStepLineTypeSettings
Dim value As System.Boolean

instance.EnableOverlappedStepLineType = value

value = instance.EnableOverlappedStepLineType
C#
[System.ComponentModel.DescriptionAttribute("Enable user to switch chart to Overlapped StepLine type.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Options")]
public System.bool EnableOverlappedStepLineType {get; set;}
Delphi
public read-write property EnableOverlappedStepLineType: System.Boolean;
JScript
System.ComponentModel.DescriptionAttribute("Enable user to switch chart to Overlapped StepLine type.")
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Options")
public function get,set EnableOverlappedStepLineType : System.boolean
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Enable user to switch chart to Overlapped StepLine type.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Options")]
public: __property System.bool get_EnableOverlappedStepLineType();
public: __property void set_EnableOverlappedStepLineType(
   System.bool value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Enable user to switch chart to Overlapped StepLine type.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Options")]
public:
property System.bool EnableOverlappedStepLineType {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartStepLineTypeSettings Class
ChartStepLineTypeSettings Members


EnableOverlappedStepLineWithMarkersType Property

[image]
Intersoft WebGrid Documentation
EnableOverlappedStepLineWithMarkersType Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartStepLineTypeSettings Class : EnableOverlappedStepLineWithMarkersType Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Options")>
<System.ComponentModel.DescriptionAttribute("Enable user to switch chart to Overlapped StepLine with Markers type.")>
Public Property EnableOverlappedStepLineWithMarkersType As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As ChartStepLineTypeSettings
Dim value As System.Boolean

instance.EnableOverlappedStepLineWithMarkersType = value

value = instance.EnableOverlappedStepLineWithMarkersType
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Options")]
[System.ComponentModel.DescriptionAttribute("Enable user to switch chart to Overlapped StepLine with Markers type.")]
public System.bool EnableOverlappedStepLineWithMarkersType {get; set;}
Delphi
public read-write property EnableOverlappedStepLineWithMarkersType: System.Boolean;
JScript
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Options")
System.ComponentModel.DescriptionAttribute("Enable user to switch chart to Overlapped StepLine with Markers type.")
public function get,set EnableOverlappedStepLineWithMarkersType : System.boolean
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Options")]
[System.ComponentModel.DescriptionAttribute("Enable user to switch chart to Overlapped StepLine with Markers type.")]
public: __property System.bool get_EnableOverlappedStepLineWithMarkersType();
public: __property void set_EnableOverlappedStepLineWithMarkersType(
   System.bool value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Options")]
[System.ComponentModel.DescriptionAttribute("Enable user to switch chart to Overlapped StepLine with Markers type.")]
public:
property System.bool EnableOverlappedStepLineWithMarkersType {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartStepLineTypeSettings Class
ChartStepLineTypeSettings Members


ChartStrokeStyle Class

[image]
Intersoft WebGrid Documentation
ChartStrokeStyle Class
Members See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartStrokeStyle Class

Glossary Item Box

Object Model

ChartStrokeStyle Class

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.SerializableAttribute()>
Public Class ChartStrokeStyle
   Inherits ISNet.WebUI.WebUIBaseClass
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Visual Basic (Usage) Copy Code
Dim instance As ChartStrokeStyle
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public class ChartStrokeStyle : ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Delphi
public class ChartStrokeStyle = class(ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize)
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.SerializableAttribute()
public class ChartStrokeStyle extends ISNet.WebUI.WebUIBaseClass implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public __gc class ChartStrokeStyle : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public ref class ChartStrokeStyle : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.WebGrid.Chart.ChartStrokeStyle

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartStrokeStyle Members
ISNet.WebUI.WebGrid.Chart Namespace


ChartStrokeStyle Class Members

[image]
Intersoft WebGrid Documentation
ChartStrokeStyle Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartStrokeStyle Class

Glossary Item Box

The following tables list the members exposed by ChartStrokeStyle.

Public Constructors

 | Name | Description
Public Constructor | ChartStrokeStyle Constructor |
Top

Public Properties

 | Name | Description
Public Property | Alignment |
Public Property | Color |
Public Property | DashCap |
Public Property | EndCap |
Public Property | Factor |
Public Property | LineJoin |
Public Property | Pattern |
Public Property | StartCap |
Public Property | Width |
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

ChartStrokeStyle Class
ISNet.WebUI.WebGrid.Chart Namespace


ChartStrokeStyle Constructor

[image]
Intersoft WebGrid Documentation
ChartStrokeStyle Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartStrokeStyle Class : ChartStrokeStyle Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New ChartStrokeStyle()
C#
public ChartStrokeStyle()
Delphi
public ChartStrokeStyle();
JScript
public function ChartStrokeStyle();
Managed Extensions for C++
public: ChartStrokeStyle();
C++/CLI
public:
ChartStrokeStyle();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartStrokeStyle Class
ChartStrokeStyle Members


Clone Method

[image]
Intersoft WebGrid Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartStrokeStyle Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As System.Object
Visual Basic (Usage) Copy Code
Dim instance As ChartStrokeStyle
Dim value As System.Object

value = instance.Clone()
C#
public virtual System.object Clone()
Delphi
public function Clone(): System.TObject; virtual;
JScript
public function Clone() : System.Object;
Managed Extensions for C++
public: virtual System.Object* Clone();
C++/CLI
public:
virtual System.Object^ Clone();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartStrokeStyle Class
ChartStrokeStyle Members


CopyFrom Method

[image]
Intersoft WebGrid Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartStrokeStyle Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartStrokeStyle Class
ChartStrokeStyle Members


CopyFrom(Object) Method

[image]
Intersoft WebGrid Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartStrokeStyle Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartStrokeStyle
Dim objSource As System.Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   System.object objSource
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartStrokeStyle Class
ChartStrokeStyle Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebGrid Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartStrokeStyle Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object, _
   ByVal cloneSourceValue As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartStrokeStyle
Dim objSource As System.Object
Dim cloneSourceValue As System.Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   System.object objSource,
   System.bool cloneSourceValue
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject;
    cloneSourceValue: System.Boolean
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object,
   cloneSourceValue : System.boolean
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource,
   System.bool cloneSourceValue
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource,
   System.bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartStrokeStyle Class
ChartStrokeStyle Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebGrid Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartStrokeStyle Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartStrokeStyle
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure DeSerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function DeSerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void DeSerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void DeSerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartStrokeStyle Class
ChartStrokeStyle Members


GetHashCode Method

[image]
Intersoft WebGrid Documentation
GetHashCode Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartStrokeStyle Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As ChartStrokeStyle
Dim value As System.Integer

value = instance.GetHashCode()
C#
public virtual System.int GetHashCode()
Delphi
public function GetHashCode(): System.Integer; virtual;
JScript
public function GetHashCode() : System.int;
Managed Extensions for C++
public: virtual System.int GetHashCode();
C++/CLI
public:
virtual System.int GetHashCode();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartStrokeStyle Class
ChartStrokeStyle Members


ChartStrokeStyle Class Methods

[image]
Intersoft WebGrid Documentation
ChartStrokeStyle Class Methods
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartStrokeStyle Class

Glossary Item Box

For a list of all members of this type, see ChartStrokeStyle members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

ChartStrokeStyle Class
ISNet.WebUI.WebGrid.Chart Namespace


GetObjectData Method

[image]
Intersoft WebGrid Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartStrokeStyle Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=False,
   UnmanagedCode=False,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=True,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Action=SecurityAction.Demand,
   Unrestricted=False)>
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartStrokeStyle
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure GetObjectData(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
); override;
JScript
System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=,
   UnmanagedCode=,
   SkipVerification=,
   Execution=,
   ControlThread=,
   ControlEvidence=,
   ControlPolicy=,
   SerializationFormatter=,
   ControlDomainPolicy=,
   ControlPrincipal=,
   ControlAppDomain=,
   RemotingConfiguration=,
   Infrastructure=,
   BindingRedirects=,
   Action=SecurityAction.Demand,
   Unrestricted=)
public override function GetObjectData(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public: void GetObjectData(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
) override
C++/CLI
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public:
void GetObjectData(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
) override

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartStrokeStyle Class
ChartStrokeStyle Members


IsEmpty Method

[image]
Intersoft WebGrid Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartStrokeStyle Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As ChartStrokeStyle
Dim value As System.Boolean

value = instance.IsEmpty()
C#
public virtual System.bool IsEmpty()
Delphi
public function IsEmpty(): System.Boolean; virtual;
JScript
public function IsEmpty() : System.boolean;
Managed Extensions for C++
public: virtual System.bool IsEmpty();
C++/CLI
public:
virtual System.bool IsEmpty();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartStrokeStyle Class
ChartStrokeStyle Members


Reset Method

[image]
Intersoft WebGrid Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartStrokeStyle Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As ChartStrokeStyle

instance.Reset()
C#
public virtual void Reset()
Delphi
public procedure Reset(); virtual;
JScript
public function Reset();
Managed Extensions for C++
public: virtual void Reset();
C++/CLI
public:
virtual void Reset();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartStrokeStyle Class
ChartStrokeStyle Members


SerializeObjectData Method

[image]
Intersoft WebGrid Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartStrokeStyle Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartStrokeStyle
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure SerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function SerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void SerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void SerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartStrokeStyle Class
ChartStrokeStyle Members


ToString Method

[image]
Intersoft WebGrid Documentation
ToString Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartStrokeStyle Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As System.String
Visual Basic (Usage) Copy Code
Dim instance As ChartStrokeStyle
Dim value As System.String

value = instance.ToString()
C#
public virtual System.string ToString()
Delphi
public function ToString(): System.String; virtual;
JScript
public function ToString() : System.String;
Managed Extensions for C++
public: virtual System.string* ToString();
C++/CLI
public:
virtual System.String^ ToString();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartStrokeStyle Class
ChartStrokeStyle Members


ChartStrokeStyle Class Properties

[image]
Intersoft WebGrid Documentation
ChartStrokeStyle Class Properties
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartStrokeStyle Class

Glossary Item Box

For a list of all members of this type, see ChartStrokeStyle members.

Public Properties

 | Name | Description
Public Property | Alignment |
Public Property | Color |
Public Property | DashCap |
Public Property | EndCap |
Public Property | Factor |
Public Property | LineJoin |
Public Property | Pattern |
Public Property | StartCap |
Public Property | Width |
Top

See Also

Reference

ChartStrokeStyle Class
ISNet.WebUI.WebGrid.Chart Namespace


ChartStrokeStyle Constructor

[image]
Intersoft WebGrid Documentation
ChartStrokeStyle Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartStrokeStyle Class : ChartStrokeStyle Constructor

Glossary Item Box

Overload List

Overload | Description
ChartStrokeStyle Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartStrokeStyle Class
ChartStrokeStyle Members


Alignment Property

[image]
Intersoft WebGrid Documentation
Alignment Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartStrokeStyle Class : Alignment Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("General")>
<System.ComponentModel.DescriptionAttribute("Specifies the alignment of a Pen object in relation to the theoretical, zero-width line.")>
Public Property Alignment As System.Drawing.Drawing2D.PenAlignment
Visual Basic (Usage) Copy Code
Dim instance As ChartStrokeStyle
Dim value As System.Drawing.Drawing2D.PenAlignment

instance.Alignment = value

value = instance.Alignment
C#
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DescriptionAttribute("Specifies the alignment of a Pen object in relation to the theoretical, zero-width line.")]
public System.Drawing.Drawing2D.PenAlignment Alignment {get; set;}
Delphi
public read-write property Alignment: System.Drawing.Drawing2D.PenAlignment;
JScript
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("General")
System.ComponentModel.DescriptionAttribute("Specifies the alignment of a Pen object in relation to the theoretical, zero-width line.")
public function get,set Alignment : System.Drawing.Drawing2D.PenAlignment
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DescriptionAttribute("Specifies the alignment of a Pen object in relation to the theoretical, zero-width line.")]
public: __property System.Drawing.Drawing2D.PenAlignment get_Alignment();
public: __property void set_Alignment(
   System.Drawing.Drawing2D.PenAlignment value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DescriptionAttribute("Specifies the alignment of a Pen object in relation to the theoretical, zero-width line.")]
public:
property System.Drawing.Drawing2D.PenAlignment Alignment {
   System.Drawing.Drawing2D.PenAlignment get();
   void set (    System.Drawing.Drawing2D.PenAlignment value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartStrokeStyle Class
ChartStrokeStyle Members


Color Property

[image]
Intersoft WebGrid Documentation
Color Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartStrokeStyle Class : Color Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Controls the line color.")>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("General")>
Public Property Color As System.Drawing.Color
Visual Basic (Usage) Copy Code
Dim instance As ChartStrokeStyle
Dim value As System.Drawing.Color

instance.Color = value

value = instance.Color
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Controls the line color.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
public System.Drawing.Color Color {get; set;}
Delphi
public read-write property Color: System.Drawing.Color;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Controls the line color.")
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("General")
public function get,set Color : System.Drawing.Color
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Controls the line color.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
public: __property System.Drawing.Color get_Color();
public: __property void set_Color(
   System.Drawing.Color value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Controls the line color.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
public:
property System.Drawing.Color Color {
   System.Drawing.Color get();
   void set (    System.Drawing.Color value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartStrokeStyle Class
ChartStrokeStyle Members


DashCap Property

[image]
Intersoft WebGrid Documentation
DashCap Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartStrokeStyle Class : DashCap Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Cap style used at the end of the dashes drawn with this stroke style.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("General")>
Public Property DashCap As System.Drawing.Drawing2D.DashCap
Visual Basic (Usage) Copy Code
Dim instance As ChartStrokeStyle
Dim value As System.Drawing.Drawing2D.DashCap

instance.DashCap = value

value = instance.DashCap
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Cap style used at the end of the dashes drawn with this stroke style.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("General")]
public System.Drawing.Drawing2D.DashCap DashCap {get; set;}
Delphi
public read-write property DashCap: System.Drawing.Drawing2D.DashCap;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Cap style used at the end of the dashes drawn with this stroke style.")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("General")
public function get,set DashCap : System.Drawing.Drawing2D.DashCap
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Cap style used at the end of the dashes drawn with this stroke style.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("General")]
public: __property System.Drawing.Drawing2D.DashCap get_DashCap();
public: __property void set_DashCap(
   System.Drawing.Drawing2D.DashCap value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Cap style used at the end of the dashes drawn with this stroke style.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("General")]
public:
property System.Drawing.Drawing2D.DashCap DashCap {
   System.Drawing.Drawing2D.DashCap get();
   void set (    System.Drawing.Drawing2D.DashCap value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartStrokeStyle Class
ChartStrokeStyle Members


EndCap Property

[image]
Intersoft WebGrid Documentation
EndCap Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartStrokeStyle Class : EndCap Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Cap style used at the end of lines drawn with this stroke style.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("General")>
Public Property EndCap As System.Drawing.Drawing2D.LineCap
Visual Basic (Usage) Copy Code
Dim instance As ChartStrokeStyle
Dim value As System.Drawing.Drawing2D.LineCap

instance.EndCap = value

value = instance.EndCap
C#
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Cap style used at the end of lines drawn with this stroke style.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("General")]
public System.Drawing.Drawing2D.LineCap EndCap {get; set;}
Delphi
public read-write property EndCap: System.Drawing.Drawing2D.LineCap;
JScript
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Cap style used at the end of lines drawn with this stroke style.")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("General")
public function get,set EndCap : System.Drawing.Drawing2D.LineCap
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Cap style used at the end of lines drawn with this stroke style.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("General")]
public: __property System.Drawing.Drawing2D.LineCap get_EndCap();
public: __property void set_EndCap(
   System.Drawing.Drawing2D.LineCap value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Cap style used at the end of lines drawn with this stroke style.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("General")]
public:
property System.Drawing.Drawing2D.LineCap EndCap {
   System.Drawing.Drawing2D.LineCap get();
   void set (    System.Drawing.Drawing2D.LineCap value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartStrokeStyle Class
ChartStrokeStyle Members


Factor Property

[image]
Intersoft WebGrid Documentation
Factor Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartStrokeStyle Class : Factor Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("General")>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("A multiplier for each bit in the line stipple pattern.")>
Public Property Factor As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As ChartStrokeStyle
Dim value As System.Integer

instance.Factor = value

value = instance.Factor
C#
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("A multiplier for each bit in the line stipple pattern.")]
public System.int Factor {get; set;}
Delphi
public read-write property Factor: System.Integer;
JScript
System.ComponentModel.CategoryAttribute("General")
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("A multiplier for each bit in the line stipple pattern.")
public function get,set Factor : System.int
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("A multiplier for each bit in the line stipple pattern.")]
public: __property System.int get_Factor();
public: __property void set_Factor(
   System.int value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("A multiplier for each bit in the line stipple pattern.")]
public:
property System.int Factor {
   System.int get();
   void set (    System.int value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartStrokeStyle Class
ChartStrokeStyle Members


LineJoin Property

[image]
Intersoft WebGrid Documentation
LineJoin Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartStrokeStyle Class : LineJoin Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("General")>
<System.ComponentModel.DescriptionAttribute("Specifies how to join consecutive line or curve segments in a figure (subpath) contained in a GraphicsPath object. ")>
Public Property LineJoin As System.Drawing.Drawing2D.LineJoin
Visual Basic (Usage) Copy Code
Dim instance As ChartStrokeStyle
Dim value As System.Drawing.Drawing2D.LineJoin

instance.LineJoin = value

value = instance.LineJoin
C#
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DescriptionAttribute("Specifies how to join consecutive line or curve segments in a figure (subpath) contained in a GraphicsPath object. ")]
public System.Drawing.Drawing2D.LineJoin LineJoin {get; set;}
Delphi
public read-write property LineJoin: System.Drawing.Drawing2D.LineJoin;
JScript
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("General")
System.ComponentModel.DescriptionAttribute("Specifies how to join consecutive line or curve segments in a figure (subpath) contained in a GraphicsPath object. ")
public function get,set LineJoin : System.Drawing.Drawing2D.LineJoin
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DescriptionAttribute("Specifies how to join consecutive line or curve segments in a figure (subpath) contained in a GraphicsPath object. ")]
public: __property System.Drawing.Drawing2D.LineJoin get_LineJoin();
public: __property void set_LineJoin(
   System.Drawing.Drawing2D.LineJoin value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DescriptionAttribute("Specifies how to join consecutive line or curve segments in a figure (subpath) contained in a GraphicsPath object. ")]
public:
property System.Drawing.Drawing2D.LineJoin LineJoin {
   System.Drawing.Drawing2D.LineJoin get();
   void set (    System.Drawing.Drawing2D.LineJoin value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartStrokeStyle Class
ChartStrokeStyle Members


Pattern Property

[image]
Intersoft WebGrid Documentation
Pattern Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartStrokeStyle Class : Pattern Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("General")>
<System.ComponentModel.DescriptionAttribute("Defines the line pattern. ")>
Public Property Pattern As LinePattern
Visual Basic (Usage) Copy Code
Dim instance As ChartStrokeStyle
Dim value As LinePattern

instance.Pattern = value

value = instance.Pattern
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DescriptionAttribute("Defines the line pattern. ")]
public LinePattern Pattern {get; set;}
Delphi
public read-write property Pattern: LinePattern;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("General")
System.ComponentModel.DescriptionAttribute("Defines the line pattern. ")
public function get,set Pattern : LinePattern
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DescriptionAttribute("Defines the line pattern. ")]
public: __property LinePattern get_Pattern();
public: __property void set_Pattern(
   LinePattern value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DescriptionAttribute("Defines the line pattern. ")]
public:
property LinePattern Pattern {
   LinePattern get();
   void set (    LinePattern value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartStrokeStyle Class
ChartStrokeStyle Members


StartCap Property

[image]
Intersoft WebGrid Documentation
StartCap Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartStrokeStyle Class : StartCap Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Gets or sets the cap style used at the beginning of lines drawn with this stroke style ")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("General")>
Public Property StartCap As System.Drawing.Drawing2D.LineCap
Visual Basic (Usage) Copy Code
Dim instance As ChartStrokeStyle
Dim value As System.Drawing.Drawing2D.LineCap

instance.StartCap = value

value = instance.StartCap
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the cap style used at the beginning of lines drawn with this stroke style ")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("General")]
public System.Drawing.Drawing2D.LineCap StartCap {get; set;}
Delphi
public read-write property StartCap: System.Drawing.Drawing2D.LineCap;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the cap style used at the beginning of lines drawn with this stroke style ")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("General")
public function get,set StartCap : System.Drawing.Drawing2D.LineCap
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the cap style used at the beginning of lines drawn with this stroke style ")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("General")]
public: __property System.Drawing.Drawing2D.LineCap get_StartCap();
public: __property void set_StartCap(
   System.Drawing.Drawing2D.LineCap value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the cap style used at the beginning of lines drawn with this stroke style ")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("General")]
public:
property System.Drawing.Drawing2D.LineCap StartCap {
   System.Drawing.Drawing2D.LineCap get();
   void set (    System.Drawing.Drawing2D.LineCap value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartStrokeStyle Class
ChartStrokeStyle Members


Width Property

[image]
Intersoft WebGrid Documentation
Width Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartStrokeStyle Class : Width Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Gets or sets the cap style used at the beginning of lines drawn with this stroke style ")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("General")>
Public Property Width As System.Nullable(Of Single)
Visual Basic (Usage) Copy Code
Dim instance As ChartStrokeStyle
Dim value As System.Nullable(Of Single)

instance.Width = value

value = instance.Width
C#
[System.ComponentModel.DescriptionAttribute("Gets or sets the cap style used at the beginning of lines drawn with this stroke style ")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("General")]
public System.Nullable<float> Width {get; set;}
Delphi
public read-write property Width: System.Nullable;
JScript
System.ComponentModel.DescriptionAttribute("Gets or sets the cap style used at the beginning of lines drawn with this stroke style ")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("General")
public function get,set Width : System.Nullable
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Gets or sets the cap style used at the beginning of lines drawn with this stroke style ")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("General")]
public: __property System.Nullable<float> get_Width();
public: __property void set_Width(
   System.Nullable<float> value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Gets or sets the cap style used at the beginning of lines drawn with this stroke style ")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("General")]
public:
property System.Nullable<float> Width {
   System.Nullable<float> get();
   void set (    System.Nullable<float> value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartStrokeStyle Class
ChartStrokeStyle Members


ChartTextStyle Class

[image]
Intersoft WebGrid Documentation
ChartTextStyle Class
Members See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartTextStyle Class

Glossary Item Box

Object Model

ChartTextStyle Class

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.SerializableAttribute()>
Public Class ChartTextStyle
   Inherits ISNet.WebUI.WebUIBaseClass
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Visual Basic (Usage) Copy Code
Dim instance As ChartTextStyle
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public class ChartTextStyle : ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Delphi
public class ChartTextStyle = class(ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize)
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.SerializableAttribute()
public class ChartTextStyle extends ISNet.WebUI.WebUIBaseClass implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public __gc class ChartTextStyle : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public ref class ChartTextStyle : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.WebGrid.Chart.ChartTextStyle

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartTextStyle Members
ISNet.WebUI.WebGrid.Chart Namespace


ChartTextStyle Class Members

[image]
Intersoft WebGrid Documentation
ChartTextStyle Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartTextStyle Class

Glossary Item Box

The following tables list the members exposed by ChartTextStyle.

Public Constructors

 | Name | Description
Public Constructor | ChartTextStyle Constructor |
Top

Public Properties

 | Name | Description
Public Property | BackPlaneStyle |
Public Property | BorderStyle |
Public Property | FillStyle |
Public Property | FontStyle |
Public Property | Orientation |
Public Property | ReplaceTabsWithSpaces |
Public Property | ShadowStyle |
Public Property | TabSizeInSpaces |
Public Property | TextOverlapsImage |
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

ChartTextStyle Class
ISNet.WebUI.WebGrid.Chart Namespace


ChartTextStyle Constructor

[image]
Intersoft WebGrid Documentation
ChartTextStyle Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartTextStyle Class : ChartTextStyle Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New ChartTextStyle()
C#
public ChartTextStyle()
Delphi
public ChartTextStyle();
JScript
public function ChartTextStyle();
Managed Extensions for C++
public: ChartTextStyle();
C++/CLI
public:
ChartTextStyle();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartTextStyle Class
ChartTextStyle Members


Clone Method

[image]
Intersoft WebGrid Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartTextStyle Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As System.Object
Visual Basic (Usage) Copy Code
Dim instance As ChartTextStyle
Dim value As System.Object

value = instance.Clone()
C#
public virtual System.object Clone()
Delphi
public function Clone(): System.TObject; virtual;
JScript
public function Clone() : System.Object;
Managed Extensions for C++
public: virtual System.Object* Clone();
C++/CLI
public:
virtual System.Object^ Clone();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartTextStyle Class
ChartTextStyle Members


CopyFrom Method

[image]
Intersoft WebGrid Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartTextStyle Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartTextStyle Class
ChartTextStyle Members


CopyFrom(Object) Method

[image]
Intersoft WebGrid Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartTextStyle Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartTextStyle
Dim objSource As System.Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   System.object objSource
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartTextStyle Class
ChartTextStyle Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebGrid Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartTextStyle Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object, _
   ByVal cloneSourceValue As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartTextStyle
Dim objSource As System.Object
Dim cloneSourceValue As System.Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   System.object objSource,
   System.bool cloneSourceValue
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject;
    cloneSourceValue: System.Boolean
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object,
   cloneSourceValue : System.boolean
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource,
   System.bool cloneSourceValue
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource,
   System.bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartTextStyle Class
ChartTextStyle Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebGrid Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartTextStyle Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartTextStyle
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure DeSerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function DeSerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void DeSerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void DeSerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartTextStyle Class
ChartTextStyle Members


GetHashCode Method

[image]
Intersoft WebGrid Documentation
GetHashCode Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartTextStyle Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As ChartTextStyle
Dim value As System.Integer

value = instance.GetHashCode()
C#
public virtual System.int GetHashCode()
Delphi
public function GetHashCode(): System.Integer; virtual;
JScript
public function GetHashCode() : System.int;
Managed Extensions for C++
public: virtual System.int GetHashCode();
C++/CLI
public:
virtual System.int GetHashCode();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartTextStyle Class
ChartTextStyle Members


ChartTextStyle Class Methods

[image]
Intersoft WebGrid Documentation
ChartTextStyle Class Methods
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartTextStyle Class

Glossary Item Box

For a list of all members of this type, see ChartTextStyle members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

ChartTextStyle Class
ISNet.WebUI.WebGrid.Chart Namespace


GetObjectData Method

[image]
Intersoft WebGrid Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartTextStyle Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=False,
   UnmanagedCode=False,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=True,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Action=SecurityAction.Demand,
   Unrestricted=False)>
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartTextStyle
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure GetObjectData(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
); override;
JScript
System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=,
   UnmanagedCode=,
   SkipVerification=,
   Execution=,
   ControlThread=,
   ControlEvidence=,
   ControlPolicy=,
   SerializationFormatter=,
   ControlDomainPolicy=,
   ControlPrincipal=,
   ControlAppDomain=,
   RemotingConfiguration=,
   Infrastructure=,
   BindingRedirects=,
   Action=SecurityAction.Demand,
   Unrestricted=)
public override function GetObjectData(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public: void GetObjectData(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
) override
C++/CLI
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public:
void GetObjectData(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
) override

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartTextStyle Class
ChartTextStyle Members


IsEmpty Method

[image]
Intersoft WebGrid Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartTextStyle Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As ChartTextStyle
Dim value As System.Boolean

value = instance.IsEmpty()
C#
public virtual System.bool IsEmpty()
Delphi
public function IsEmpty(): System.Boolean; virtual;
JScript
public function IsEmpty() : System.boolean;
Managed Extensions for C++
public: virtual System.bool IsEmpty();
C++/CLI
public:
virtual System.bool IsEmpty();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartTextStyle Class
ChartTextStyle Members


Reset Method

[image]
Intersoft WebGrid Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartTextStyle Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As ChartTextStyle

instance.Reset()
C#
public virtual void Reset()
Delphi
public procedure Reset(); virtual;
JScript
public function Reset();
Managed Extensions for C++
public: virtual void Reset();
C++/CLI
public:
virtual void Reset();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartTextStyle Class
ChartTextStyle Members


SerializeObjectData Method

[image]
Intersoft WebGrid Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartTextStyle Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartTextStyle
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure SerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function SerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void SerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void SerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartTextStyle Class
ChartTextStyle Members


ToString Method

[image]
Intersoft WebGrid Documentation
ToString Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartTextStyle Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As System.String
Visual Basic (Usage) Copy Code
Dim instance As ChartTextStyle
Dim value As System.String

value = instance.ToString()
C#
public virtual System.string ToString()
Delphi
public function ToString(): System.String; virtual;
JScript
public function ToString() : System.String;
Managed Extensions for C++
public: virtual System.string* ToString();
C++/CLI
public:
virtual System.String^ ToString();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartTextStyle Class
ChartTextStyle Members


ChartTextStyle Class Properties

[image]
Intersoft WebGrid Documentation
ChartTextStyle Class Properties
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartTextStyle Class

Glossary Item Box

For a list of all members of this type, see ChartTextStyle members.

Public Properties

 | Name | Description
Public Property | BackPlaneStyle |
Public Property | BorderStyle |
Public Property | FillStyle |
Public Property | FontStyle |
Public Property | Orientation |
Public Property | ReplaceTabsWithSpaces |
Public Property | ShadowStyle |
Public Property | TabSizeInSpaces |
Public Property | TextOverlapsImage |
Top

See Also

Reference

ChartTextStyle Class
ISNet.WebUI.WebGrid.Chart Namespace


ChartTextStyle Constructor

[image]
Intersoft WebGrid Documentation
ChartTextStyle Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartTextStyle Class : ChartTextStyle Constructor

Glossary Item Box

Overload List

Overload | Description
ChartTextStyle Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartTextStyle Class
ChartTextStyle Members


BackPlaneStyle Property

[image]
Intersoft WebGrid Documentation
BackPlaneStyle Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartTextStyle Class : BackPlaneStyle Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Controls the backplane style applied on the text.")>
<ISNet.Serialization.BinarySerializableAttribute("setBackPlaneStyle")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<System.ComponentModel.CategoryAttribute("General")>
Public ReadOnly Property BackPlaneStyle As ChartBackplaneStyle
Visual Basic (Usage) Copy Code
Dim instance As ChartTextStyle
Dim value As ChartBackplaneStyle

value = instance.BackPlaneStyle
C#
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Controls the backplane style applied on the text.")]
[ISNet.Serialization.BinarySerializableAttribute("setBackPlaneStyle")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.CategoryAttribute("General")]
public ChartBackplaneStyle BackPlaneStyle {get;}
Delphi
public read-only property BackPlaneStyle: ChartBackplaneStyle;
JScript
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Controls the backplane style applied on the text.")
ISNet.Serialization.BinarySerializableAttribute("setBackPlaneStyle")
System.ComponentModel.NotifyParentPropertyAttribute()
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
System.ComponentModel.CategoryAttribute("General")
public function get BackPlaneStyle : ChartBackplaneStyle
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Controls the backplane style applied on the text.")]
[ISNet.Serialization.BinarySerializableAttribute("setBackPlaneStyle")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.CategoryAttribute("General")]
public: __property ChartBackplaneStyle* get_BackPlaneStyle();
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Controls the backplane style applied on the text.")]
[ISNet.Serialization.BinarySerializableAttribute("setBackPlaneStyle")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.CategoryAttribute("General")]
public:
property ChartBackplaneStyle^ BackPlaneStyle {
   ChartBackplaneStyle^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartTextStyle Class
ChartTextStyle Members


BorderStyle Property

[image]
Intersoft WebGrid Documentation
BorderStyle Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartTextStyle Class : BorderStyle Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Controls the border applied on the text.")>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute("setBorderStyle")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<System.ComponentModel.CategoryAttribute("Appearance")>
Public ReadOnly Property BorderStyle As ChartStrokeStyle
Visual Basic (Usage) Copy Code
Dim instance As ChartTextStyle
Dim value As ChartStrokeStyle

value = instance.BorderStyle
C#
[System.ComponentModel.DescriptionAttribute("Controls the border applied on the text.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute("setBorderStyle")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.CategoryAttribute("Appearance")]
public ChartStrokeStyle BorderStyle {get;}
Delphi
public read-only property BorderStyle: ChartStrokeStyle;
JScript
System.ComponentModel.DescriptionAttribute("Controls the border applied on the text.")
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute("setBorderStyle")
System.ComponentModel.NotifyParentPropertyAttribute()
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
System.ComponentModel.CategoryAttribute("Appearance")
public function get BorderStyle : ChartStrokeStyle
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Controls the border applied on the text.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute("setBorderStyle")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.CategoryAttribute("Appearance")]
public: __property ChartStrokeStyle* get_BorderStyle();
C++/CLI
[System.ComponentModel.DescriptionAttribute("Controls the border applied on the text.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute("setBorderStyle")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.CategoryAttribute("Appearance")]
public:
property ChartStrokeStyle^ BorderStyle {
   ChartStrokeStyle^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartTextStyle Class
ChartTextStyle Members


FillStyle Property

[image]
Intersoft WebGrid Documentation
FillStyle Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartTextStyle Class : FillStyle Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Appearance")>
<System.ComponentModel.DescriptionAttribute("Controls the fill style applied on the text.")>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute("setFillStyle")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
Public ReadOnly Property FillStyle As ChartFillStyle
Visual Basic (Usage) Copy Code
Dim instance As ChartTextStyle
Dim value As ChartFillStyle

value = instance.FillStyle
C#
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.DescriptionAttribute("Controls the fill style applied on the text.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute("setFillStyle")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
public ChartFillStyle FillStyle {get;}
Delphi
public read-only property FillStyle: ChartFillStyle;
JScript
System.ComponentModel.CategoryAttribute("Appearance")
System.ComponentModel.DescriptionAttribute("Controls the fill style applied on the text.")
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute("setFillStyle")
System.ComponentModel.NotifyParentPropertyAttribute()
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
public function get FillStyle : ChartFillStyle
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.DescriptionAttribute("Controls the fill style applied on the text.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute("setFillStyle")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
public: __property ChartFillStyle* get_FillStyle();
C++/CLI
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.DescriptionAttribute("Controls the fill style applied on the text.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute("setFillStyle")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
public:
property ChartFillStyle^ FillStyle {
   ChartFillStyle^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartTextStyle Class
ChartTextStyle Members


FontStyle Property

[image]
Intersoft WebGrid Documentation
FontStyle Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartTextStyle Class : FontStyle Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Appearance")>
<System.ComponentModel.DescriptionAttribute("Controls the font style applied on the text.")>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute("setFontStyle")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
Public ReadOnly Property FontStyle As ChartFontStyle
Visual Basic (Usage) Copy Code
Dim instance As ChartTextStyle
Dim value As ChartFontStyle

value = instance.FontStyle
C#
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.DescriptionAttribute("Controls the font style applied on the text.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute("setFontStyle")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
public ChartFontStyle FontStyle {get;}
Delphi
public read-only property FontStyle: ChartFontStyle;
JScript
System.ComponentModel.CategoryAttribute("Appearance")
System.ComponentModel.DescriptionAttribute("Controls the font style applied on the text.")
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute("setFontStyle")
System.ComponentModel.NotifyParentPropertyAttribute()
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
public function get FontStyle : ChartFontStyle
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.DescriptionAttribute("Controls the font style applied on the text.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute("setFontStyle")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
public: __property ChartFontStyle* get_FontStyle();
C++/CLI
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.DescriptionAttribute("Controls the font style applied on the text.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute("setFontStyle")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
public:
property ChartFontStyle^ FontStyle {
   ChartFontStyle^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartTextStyle Class
ChartTextStyle Members


Orientation Property

[image]
Intersoft WebGrid Documentation
Orientation Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartTextStyle Class : Orientation Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Controls the orientation of the texts in degress.")>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Position")>
Public Property Orientation As System.Single
Visual Basic (Usage) Copy Code
Dim instance As ChartTextStyle
Dim value As System.Single

instance.Orientation = value

value = instance.Orientation
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Controls the orientation of the texts in degress.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Position")]
public System.float Orientation {get; set;}
Delphi
public read-write property Orientation: System.Single;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Controls the orientation of the texts in degress.")
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Position")
public function get,set Orientation : System.float
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Controls the orientation of the texts in degress.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Position")]
public: __property System.float get_Orientation();
public: __property void set_Orientation(
   System.float value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Controls the orientation of the texts in degress.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Position")]
public:
property System.float Orientation {
   System.float get();
   void set (    System.float value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartTextStyle Class
ChartTextStyle Members


ReplaceTabsWithSpaces Property

[image]
Intersoft WebGrid Documentation
ReplaceTabsWithSpaces Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartTextStyle Class : ReplaceTabsWithSpaces Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("Formatting")>
<System.ComponentModel.DescriptionAttribute("Determines whether the control should replace tabs with spaces.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property ReplaceTabsWithSpaces As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As ChartTextStyle
Dim value As System.Boolean

instance.ReplaceTabsWithSpaces = value

value = instance.ReplaceTabsWithSpaces
C#
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Formatting")]
[System.ComponentModel.DescriptionAttribute("Determines whether the control should replace tabs with spaces.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.bool ReplaceTabsWithSpaces {get; set;}
Delphi
public read-write property ReplaceTabsWithSpaces: System.Boolean;
JScript
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("Formatting")
System.ComponentModel.DescriptionAttribute("Determines whether the control should replace tabs with spaces.")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set ReplaceTabsWithSpaces : System.boolean
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Formatting")]
[System.ComponentModel.DescriptionAttribute("Determines whether the control should replace tabs with spaces.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.bool get_ReplaceTabsWithSpaces();
public: __property void set_ReplaceTabsWithSpaces(
   System.bool value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Formatting")]
[System.ComponentModel.DescriptionAttribute("Determines whether the control should replace tabs with spaces.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.bool ReplaceTabsWithSpaces {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartTextStyle Class
ChartTextStyle Members


ShadowStyle Property

[image]
Intersoft WebGrid Documentation
ShadowStyle Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartTextStyle Class : ShadowStyle Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<System.ComponentModel.DescriptionAttribute("Controls the text shadow.")>
<System.ComponentModel.CategoryAttribute("Appearance")>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute("setShadowStyle")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
Public ReadOnly Property ShadowStyle As ChartShadowStyle
Visual Basic (Usage) Copy Code
Dim instance As ChartTextStyle
Dim value As ChartShadowStyle

value = instance.ShadowStyle
C#
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DescriptionAttribute("Controls the text shadow.")]
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute("setShadowStyle")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
public ChartShadowStyle ShadowStyle {get;}
Delphi
public read-only property ShadowStyle: ChartShadowStyle;
JScript
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
System.ComponentModel.DescriptionAttribute("Controls the text shadow.")
System.ComponentModel.CategoryAttribute("Appearance")
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute("setShadowStyle")
System.ComponentModel.NotifyParentPropertyAttribute()
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
public function get ShadowStyle : ChartShadowStyle
Managed Extensions for C++
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DescriptionAttribute("Controls the text shadow.")]
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute("setShadowStyle")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
public: __property ChartShadowStyle* get_ShadowStyle();
C++/CLI
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DescriptionAttribute("Controls the text shadow.")]
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute("setShadowStyle")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
public:
property ChartShadowStyle^ ShadowStyle {
   ChartShadowStyle^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartTextStyle Class
ChartTextStyle Members


TabSizeInSpaces Property

[image]
Intersoft WebGrid Documentation
TabSizeInSpaces Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartTextStyle Class : TabSizeInSpaces Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("The number of spaces that replace a single tab if ReplaceTabsWithSpaces is set to true.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("General")>
Public Property TabSizeInSpaces As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As ChartTextStyle
Dim value As System.Integer

instance.TabSizeInSpaces = value

value = instance.TabSizeInSpaces
C#
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("The number of spaces that replace a single tab if ReplaceTabsWithSpaces is set to true.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("General")]
public System.int TabSizeInSpaces {get; set;}
Delphi
public read-write property TabSizeInSpaces: System.Integer;
JScript
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("The number of spaces that replace a single tab if ReplaceTabsWithSpaces is set to true.")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("General")
public function get,set TabSizeInSpaces : System.int
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("The number of spaces that replace a single tab if ReplaceTabsWithSpaces is set to true.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("General")]
public: __property System.int get_TabSizeInSpaces();
public: __property void set_TabSizeInSpaces(
   System.int value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("The number of spaces that replace a single tab if ReplaceTabsWithSpaces is set to true.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("General")]
public:
property System.int TabSizeInSpaces {
   System.int get();
   void set (    System.int value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartTextStyle Class
ChartTextStyle Members


TextOverlapsImage Property

[image]
Intersoft WebGrid Documentation
TextOverlapsImage Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartTextStyle Class : TextOverlapsImage Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Controls whether or not the text should use the Z position of the base point")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("General")>
Public Property TextOverlapsImage As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As ChartTextStyle
Dim value As System.Boolean

instance.TextOverlapsImage = value

value = instance.TextOverlapsImage
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Controls whether or not the text should use the Z position of the base point")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("General")]
public System.bool TextOverlapsImage {get; set;}
Delphi
public read-write property TextOverlapsImage: System.Boolean;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DescriptionAttribute("Controls whether or not the text should use the Z position of the base point")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("General")
public function get,set TextOverlapsImage : System.boolean
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Controls whether or not the text should use the Z position of the base point")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("General")]
public: __property System.bool get_TextOverlapsImage();
public: __property void set_TextOverlapsImage(
   System.bool value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Controls whether or not the text should use the Z position of the base point")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("General")]
public:
property System.bool TextOverlapsImage {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartTextStyle Class
ChartTextStyle Members


ChartTextureFillStyle Class

[image]
Intersoft WebGrid Documentation
ChartTextureFillStyle Class
Members See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartTextureFillStyle Class

Glossary Item Box

Object Model

ChartTextureFillStyle Class

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.SerializableAttribute()>
Public Class ChartTextureFillStyle
   Inherits ISNet.WebUI.WebUIBaseClass
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Visual Basic (Usage) Copy Code
Dim instance As ChartTextureFillStyle
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public class ChartTextureFillStyle : ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Delphi
public class ChartTextureFillStyle = class(ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize)
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.SerializableAttribute()
public class ChartTextureFillStyle extends ISNet.WebUI.WebUIBaseClass implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public __gc class ChartTextureFillStyle : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public ref class ChartTextureFillStyle : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.WebGrid.Chart.ChartTextureFillStyle
ISNet.WebUI.WebGrid.Chart.ChartGradientFillStyle
ISNet.WebUI.WebGrid.Chart.ChartHatchFillStyle
ISNet.WebUI.WebGrid.Chart.ChartImageFillStyle

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartTextureFillStyle Members
ISNet.WebUI.WebGrid.Chart Namespace


ChartTextureFillStyle Class Members

[image]
Intersoft WebGrid Documentation
ChartTextureFillStyle Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartTextureFillStyle Class

Glossary Item Box

The following tables list the members exposed by ChartTextureFillStyle.

Public Constructors

 | Name | Description
Public Constructor | ChartTextureFillStyle Constructor |
Top

Public Properties

 | Name | Description
Public Property | TextureMappingStyle |
Public Property | TransparancyPercent |
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

ChartTextureFillStyle Class
ISNet.WebUI.WebGrid.Chart Namespace


ChartTextureFillStyle Constructor

[image]
Intersoft WebGrid Documentation
ChartTextureFillStyle Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartTextureFillStyle Class : ChartTextureFillStyle Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New ChartTextureFillStyle()
C#
public ChartTextureFillStyle()
Delphi
public ChartTextureFillStyle();
JScript
public function ChartTextureFillStyle();
Managed Extensions for C++
public: ChartTextureFillStyle();
C++/CLI
public:
ChartTextureFillStyle();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartTextureFillStyle Class
ChartTextureFillStyle Members


Clone Method

[image]
Intersoft WebGrid Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartTextureFillStyle Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As System.Object
Visual Basic (Usage) Copy Code
Dim instance As ChartTextureFillStyle
Dim value As System.Object

value = instance.Clone()
C#
public virtual System.object Clone()
Delphi
public function Clone(): System.TObject; virtual;
JScript
public function Clone() : System.Object;
Managed Extensions for C++
public: virtual System.Object* Clone();
C++/CLI
public:
virtual System.Object^ Clone();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartTextureFillStyle Class
ChartTextureFillStyle Members


CopyFrom Method

[image]
Intersoft WebGrid Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartTextureFillStyle Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartTextureFillStyle Class
ChartTextureFillStyle Members


CopyFrom(Object) Method

[image]
Intersoft WebGrid Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartTextureFillStyle Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartTextureFillStyle
Dim objSource As System.Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   System.object objSource
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartTextureFillStyle Class
ChartTextureFillStyle Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebGrid Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartTextureFillStyle Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object, _
   ByVal cloneSourceValue As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartTextureFillStyle
Dim objSource As System.Object
Dim cloneSourceValue As System.Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   System.object objSource,
   System.bool cloneSourceValue
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject;
    cloneSourceValue: System.Boolean
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object,
   cloneSourceValue : System.boolean
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource,
   System.bool cloneSourceValue
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource,
   System.bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartTextureFillStyle Class
ChartTextureFillStyle Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebGrid Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartTextureFillStyle Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartTextureFillStyle
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure DeSerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function DeSerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void DeSerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void DeSerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartTextureFillStyle Class
ChartTextureFillStyle Members


GetHashCode Method

[image]
Intersoft WebGrid Documentation
GetHashCode Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartTextureFillStyle Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As ChartTextureFillStyle
Dim value As System.Integer

value = instance.GetHashCode()
C#
public virtual System.int GetHashCode()
Delphi
public function GetHashCode(): System.Integer; virtual;
JScript
public function GetHashCode() : System.int;
Managed Extensions for C++
public: virtual System.int GetHashCode();
C++/CLI
public:
virtual System.int GetHashCode();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartTextureFillStyle Class
ChartTextureFillStyle Members


ChartTextureFillStyle Class Methods

[image]
Intersoft WebGrid Documentation
ChartTextureFillStyle Class Methods
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartTextureFillStyle Class

Glossary Item Box

For a list of all members of this type, see ChartTextureFillStyle members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

ChartTextureFillStyle Class
ISNet.WebUI.WebGrid.Chart Namespace


GetObjectData Method

[image]
Intersoft WebGrid Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartTextureFillStyle Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=False,
   UnmanagedCode=False,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=True,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Action=SecurityAction.Demand,
   Unrestricted=False)>
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartTextureFillStyle
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure GetObjectData(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
); override;
JScript
System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=,
   UnmanagedCode=,
   SkipVerification=,
   Execution=,
   ControlThread=,
   ControlEvidence=,
   ControlPolicy=,
   SerializationFormatter=,
   ControlDomainPolicy=,
   ControlPrincipal=,
   ControlAppDomain=,
   RemotingConfiguration=,
   Infrastructure=,
   BindingRedirects=,
   Action=SecurityAction.Demand,
   Unrestricted=)
public override function GetObjectData(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public: void GetObjectData(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
) override
C++/CLI
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public:
void GetObjectData(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
) override

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartTextureFillStyle Class
ChartTextureFillStyle Members


IsEmpty Method

[image]
Intersoft WebGrid Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartTextureFillStyle Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As ChartTextureFillStyle
Dim value As System.Boolean

value = instance.IsEmpty()
C#
public virtual System.bool IsEmpty()
Delphi
public function IsEmpty(): System.Boolean; virtual;
JScript
public function IsEmpty() : System.boolean;
Managed Extensions for C++
public: virtual System.bool IsEmpty();
C++/CLI
public:
virtual System.bool IsEmpty();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartTextureFillStyle Class
ChartTextureFillStyle Members


Reset Method

[image]
Intersoft WebGrid Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartTextureFillStyle Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As ChartTextureFillStyle

instance.Reset()
C#
public virtual void Reset()
Delphi
public procedure Reset(); virtual;
JScript
public function Reset();
Managed Extensions for C++
public: virtual void Reset();
C++/CLI
public:
virtual void Reset();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartTextureFillStyle Class
ChartTextureFillStyle Members


SerializeObjectData Method

[image]
Intersoft WebGrid Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartTextureFillStyle Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartTextureFillStyle
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure SerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function SerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void SerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void SerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartTextureFillStyle Class
ChartTextureFillStyle Members


ToString Method

[image]
Intersoft WebGrid Documentation
ToString Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartTextureFillStyle Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As System.String
Visual Basic (Usage) Copy Code
Dim instance As ChartTextureFillStyle
Dim value As System.String

value = instance.ToString()
C#
public virtual System.string ToString()
Delphi
public function ToString(): System.String; virtual;
JScript
public function ToString() : System.String;
Managed Extensions for C++
public: virtual System.string* ToString();
C++/CLI
public:
virtual System.String^ ToString();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartTextureFillStyle Class
ChartTextureFillStyle Members


ChartTextureFillStyle Class Properties

[image]
Intersoft WebGrid Documentation
ChartTextureFillStyle Class Properties
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartTextureFillStyle Class

Glossary Item Box

For a list of all members of this type, see ChartTextureFillStyle members.

Public Properties

 | Name | Description
Public Property | TextureMappingStyle |
Public Property | TransparancyPercent |
Top

See Also

Reference

ChartTextureFillStyle Class
ISNet.WebUI.WebGrid.Chart Namespace


ChartTextureFillStyle Constructor

[image]
Intersoft WebGrid Documentation
ChartTextureFillStyle Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartTextureFillStyle Class : ChartTextureFillStyle Constructor

Glossary Item Box

Overload List

Overload | Description
ChartTextureFillStyle Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartTextureFillStyle Class
ChartTextureFillStyle Members


TextureMappingStyle Property

[image]
Intersoft WebGrid Documentation
TextureMappingStyle Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartTextureFillStyle Class : TextureMappingStyle Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.CategoryAttribute("Appearance")>
<System.ComponentModel.DescriptionAttribute("Controls how texture based fillings are mapped on the object.")>
<ISNet.Serialization.BinarySerializableAttribute("setTextureMappingStyle")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
Public ReadOnly Property TextureMappingStyle As ChartTextureMappingStyle
Visual Basic (Usage) Copy Code
Dim instance As ChartTextureFillStyle
Dim value As ChartTextureMappingStyle

value = instance.TextureMappingStyle
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.DescriptionAttribute("Controls how texture based fillings are mapped on the object.")]
[ISNet.Serialization.BinarySerializableAttribute("setTextureMappingStyle")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
public ChartTextureMappingStyle TextureMappingStyle {get;}
Delphi
public read-only property TextureMappingStyle: ChartTextureMappingStyle;
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.CategoryAttribute("Appearance")
System.ComponentModel.DescriptionAttribute("Controls how texture based fillings are mapped on the object.")
ISNet.Serialization.BinarySerializableAttribute("setTextureMappingStyle")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
public function get TextureMappingStyle : ChartTextureMappingStyle
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.DescriptionAttribute("Controls how texture based fillings are mapped on the object.")]
[ISNet.Serialization.BinarySerializableAttribute("setTextureMappingStyle")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
public: __property ChartTextureMappingStyle* get_TextureMappingStyle();
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.DescriptionAttribute("Controls how texture based fillings are mapped on the object.")]
[ISNet.Serialization.BinarySerializableAttribute("setTextureMappingStyle")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
public:
property ChartTextureMappingStyle^ TextureMappingStyle {
   ChartTextureMappingStyle^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartTextureFillStyle Class
ChartTextureFillStyle Members


TransparancyPercent Property

[image]
Intersoft WebGrid Documentation
TransparancyPercent Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartTextureFillStyle Class : TransparancyPercent Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Appearance")>
<System.ComponentModel.DescriptionAttribute("Controls the transparency percent of the diffuse and ambient material colors. ")>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property TransparancyPercent As System.Single
Visual Basic (Usage) Copy Code
Dim instance As ChartTextureFillStyle
Dim value As System.Single

instance.TransparancyPercent = value

value = instance.TransparancyPercent
C#
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.DescriptionAttribute("Controls the transparency percent of the diffuse and ambient material colors. ")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.float TransparancyPercent {get; set;}
Delphi
public read-write property TransparancyPercent: System.Single;
JScript
System.ComponentModel.CategoryAttribute("Appearance")
System.ComponentModel.DescriptionAttribute("Controls the transparency percent of the diffuse and ambient material colors. ")
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set TransparancyPercent : System.float
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.DescriptionAttribute("Controls the transparency percent of the diffuse and ambient material colors. ")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.float get_TransparancyPercent();
public: __property void set_TransparancyPercent(
   System.float value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.DescriptionAttribute("Controls the transparency percent of the diffuse and ambient material colors. ")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.float TransparancyPercent {
   System.float get();
   void set (    System.float value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartTextureFillStyle Class
ChartTextureFillStyle Members


ChartTextureMappingStyle Class

[image]
Intersoft WebGrid Documentation
ChartTextureMappingStyle Class
Members See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartTextureMappingStyle Class

Glossary Item Box

Object Model

ChartTextureMappingStyle Class

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.SerializableAttribute()>
Public Class ChartTextureMappingStyle
   Inherits ISNet.WebUI.WebUIBaseClass
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Visual Basic (Usage) Copy Code
Dim instance As ChartTextureMappingStyle
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public class ChartTextureMappingStyle : ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Delphi
public class ChartTextureMappingStyle = class(ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize)
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.SerializableAttribute()
public class ChartTextureMappingStyle extends ISNet.WebUI.WebUIBaseClass implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public __gc class ChartTextureMappingStyle : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public ref class ChartTextureMappingStyle : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.WebGrid.Chart.ChartTextureMappingStyle

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartTextureMappingStyle Members
ISNet.WebUI.WebGrid.Chart Namespace


ChartTextureMappingStyle Class Members

[image]
Intersoft WebGrid Documentation
ChartTextureMappingStyle Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartTextureMappingStyle Class

Glossary Item Box

The following tables list the members exposed by ChartTextureMappingStyle.

Public Constructors

 | Name | Description
Public Constructor | ChartTextureMappingStyle Constructor |
Top

Public Properties

 | Name | Description
Public Property | BorderColor |
Public Property | HorizontalScale |
Public Property | MapLayout |
Public Property | MapMode |
Public Property | VerticalScale |
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

ChartTextureMappingStyle Class
ISNet.WebUI.WebGrid.Chart Namespace


ChartTextureMappingStyle Constructor

[image]
Intersoft WebGrid Documentation
ChartTextureMappingStyle Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartTextureMappingStyle Class : ChartTextureMappingStyle Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New ChartTextureMappingStyle()
C#
public ChartTextureMappingStyle()
Delphi
public ChartTextureMappingStyle();
JScript
public function ChartTextureMappingStyle();
Managed Extensions for C++
public: ChartTextureMappingStyle();
C++/CLI
public:
ChartTextureMappingStyle();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartTextureMappingStyle Class
ChartTextureMappingStyle Members


Clone Method

[image]
Intersoft WebGrid Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartTextureMappingStyle Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As System.Object
Visual Basic (Usage) Copy Code
Dim instance As ChartTextureMappingStyle
Dim value As System.Object

value = instance.Clone()
C#
public virtual System.object Clone()
Delphi
public function Clone(): System.TObject; virtual;
JScript
public function Clone() : System.Object;
Managed Extensions for C++
public: virtual System.Object* Clone();
C++/CLI
public:
virtual System.Object^ Clone();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartTextureMappingStyle Class
ChartTextureMappingStyle Members


CopyFrom Method

[image]
Intersoft WebGrid Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartTextureMappingStyle Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartTextureMappingStyle Class
ChartTextureMappingStyle Members


CopyFrom(Object) Method

[image]
Intersoft WebGrid Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartTextureMappingStyle Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartTextureMappingStyle
Dim objSource As System.Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   System.object objSource
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartTextureMappingStyle Class
ChartTextureMappingStyle Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebGrid Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartTextureMappingStyle Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object, _
   ByVal cloneSourceValue As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartTextureMappingStyle
Dim objSource As System.Object
Dim cloneSourceValue As System.Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   System.object objSource,
   System.bool cloneSourceValue
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject;
    cloneSourceValue: System.Boolean
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object,
   cloneSourceValue : System.boolean
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource,
   System.bool cloneSourceValue
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource,
   System.bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartTextureMappingStyle Class
ChartTextureMappingStyle Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebGrid Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartTextureMappingStyle Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartTextureMappingStyle
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure DeSerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function DeSerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void DeSerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void DeSerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartTextureMappingStyle Class
ChartTextureMappingStyle Members


GetHashCode Method

[image]
Intersoft WebGrid Documentation
GetHashCode Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartTextureMappingStyle Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As ChartTextureMappingStyle
Dim value As System.Integer

value = instance.GetHashCode()
C#
public virtual System.int GetHashCode()
Delphi
public function GetHashCode(): System.Integer; virtual;
JScript
public function GetHashCode() : System.int;
Managed Extensions for C++
public: virtual System.int GetHashCode();
C++/CLI
public:
virtual System.int GetHashCode();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartTextureMappingStyle Class
ChartTextureMappingStyle Members


ChartTextureMappingStyle Class Methods

[image]
Intersoft WebGrid Documentation
ChartTextureMappingStyle Class Methods
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartTextureMappingStyle Class

Glossary Item Box

For a list of all members of this type, see ChartTextureMappingStyle members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

ChartTextureMappingStyle Class
ISNet.WebUI.WebGrid.Chart Namespace


GetObjectData Method

[image]
Intersoft WebGrid Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartTextureMappingStyle Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=False,
   UnmanagedCode=False,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=True,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Action=SecurityAction.Demand,
   Unrestricted=False)>
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartTextureMappingStyle
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure GetObjectData(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
); override;
JScript
System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=,
   UnmanagedCode=,
   SkipVerification=,
   Execution=,
   ControlThread=,
   ControlEvidence=,
   ControlPolicy=,
   SerializationFormatter=,
   ControlDomainPolicy=,
   ControlPrincipal=,
   ControlAppDomain=,
   RemotingConfiguration=,
   Infrastructure=,
   BindingRedirects=,
   Action=SecurityAction.Demand,
   Unrestricted=)
public override function GetObjectData(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public: void GetObjectData(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
) override
C++/CLI
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public:
void GetObjectData(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
) override

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartTextureMappingStyle Class
ChartTextureMappingStyle Members


IsEmpty Method

[image]
Intersoft WebGrid Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartTextureMappingStyle Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As ChartTextureMappingStyle
Dim value As System.Boolean

value = instance.IsEmpty()
C#
public virtual System.bool IsEmpty()
Delphi
public function IsEmpty(): System.Boolean; virtual;
JScript
public function IsEmpty() : System.boolean;
Managed Extensions for C++
public: virtual System.bool IsEmpty();
C++/CLI
public:
virtual System.bool IsEmpty();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartTextureMappingStyle Class
ChartTextureMappingStyle Members


Reset Method

[image]
Intersoft WebGrid Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartTextureMappingStyle Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As ChartTextureMappingStyle

instance.Reset()
C#
public virtual void Reset()
Delphi
public procedure Reset(); virtual;
JScript
public function Reset();
Managed Extensions for C++
public: virtual void Reset();
C++/CLI
public:
virtual void Reset();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartTextureMappingStyle Class
ChartTextureMappingStyle Members


SerializeObjectData Method

[image]
Intersoft WebGrid Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartTextureMappingStyle Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartTextureMappingStyle
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure SerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function SerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void SerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void SerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartTextureMappingStyle Class
ChartTextureMappingStyle Members


ToString Method

[image]
Intersoft WebGrid Documentation
ToString Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartTextureMappingStyle Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As System.String
Visual Basic (Usage) Copy Code
Dim instance As ChartTextureMappingStyle
Dim value As System.String

value = instance.ToString()
C#
public virtual System.string ToString()
Delphi
public function ToString(): System.String; virtual;
JScript
public function ToString() : System.String;
Managed Extensions for C++
public: virtual System.string* ToString();
C++/CLI
public:
virtual System.String^ ToString();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartTextureMappingStyle Class
ChartTextureMappingStyle Members


ChartTextureMappingStyle Class Properties

[image]
Intersoft WebGrid Documentation
ChartTextureMappingStyle Class Properties
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartTextureMappingStyle Class

Glossary Item Box

For a list of all members of this type, see ChartTextureMappingStyle members.

Public Properties

 | Name | Description
Public Property | BorderColor |
Public Property | HorizontalScale |
Public Property | MapLayout |
Public Property | MapMode |
Public Property | VerticalScale |
Top

See Also

Reference

ChartTextureMappingStyle Class
ISNet.WebUI.WebGrid.Chart Namespace


ChartTextureMappingStyle Constructor

[image]
Intersoft WebGrid Documentation
ChartTextureMappingStyle Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartTextureMappingStyle Class : ChartTextureMappingStyle Constructor

Glossary Item Box

Overload List

Overload | Description
ChartTextureMappingStyle Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartTextureMappingStyle Class
ChartTextureMappingStyle Members


BorderColor Property

[image]
Intersoft WebGrid Documentation
BorderColor Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartTextureMappingStyle Class : BorderColor Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Appearance")>
<System.ComponentModel.DescriptionAttribute("The color used to fill the parts of the object not covered by the texture. ")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property BorderColor As System.Drawing.Color
Visual Basic (Usage) Copy Code
Dim instance As ChartTextureMappingStyle
Dim value As System.Drawing.Color

instance.BorderColor = value

value = instance.BorderColor
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.DescriptionAttribute("The color used to fill the parts of the object not covered by the texture. ")]
[System.ComponentModel.DefaultValueAttribute()]
public System.Drawing.Color BorderColor {get; set;}
Delphi
public read-write property BorderColor: System.Drawing.Color;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Appearance")
System.ComponentModel.DescriptionAttribute("The color used to fill the parts of the object not covered by the texture. ")
System.ComponentModel.DefaultValueAttribute()
public function get,set BorderColor : System.Drawing.Color
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.DescriptionAttribute("The color used to fill the parts of the object not covered by the texture. ")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.Drawing.Color get_BorderColor();
public: __property void set_BorderColor(
   System.Drawing.Color value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.DescriptionAttribute("The color used to fill the parts of the object not covered by the texture. ")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.Drawing.Color BorderColor {
   System.Drawing.Color get();
   void set (    System.Drawing.Color value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartTextureMappingStyle Class
ChartTextureMappingStyle Members


HorizontalScale Property

[image]
Intersoft WebGrid Documentation
HorizontalScale Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartTextureMappingStyle Class : HorizontalScale Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Appearance")>
<System.ComponentModel.DescriptionAttribute("An additional scale in the X dimension to be applied to the texture when mapped. ")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property HorizontalScale As System.Single
Visual Basic (Usage) Copy Code
Dim instance As ChartTextureMappingStyle
Dim value As System.Single

instance.HorizontalScale = value

value = instance.HorizontalScale
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.DescriptionAttribute("An additional scale in the X dimension to be applied to the texture when mapped. ")]
[System.ComponentModel.DefaultValueAttribute()]
public System.float HorizontalScale {get; set;}
Delphi
public read-write property HorizontalScale: System.Single;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Appearance")
System.ComponentModel.DescriptionAttribute("An additional scale in the X dimension to be applied to the texture when mapped. ")
System.ComponentModel.DefaultValueAttribute()
public function get,set HorizontalScale : System.float
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.DescriptionAttribute("An additional scale in the X dimension to be applied to the texture when mapped. ")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.float get_HorizontalScale();
public: __property void set_HorizontalScale(
   System.float value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.DescriptionAttribute("An additional scale in the X dimension to be applied to the texture when mapped. ")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.float HorizontalScale {
   System.float get();
   void set (    System.float value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartTextureMappingStyle Class
ChartTextureMappingStyle Members


MapLayout Property

[image]
Intersoft WebGrid Documentation
MapLayout Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartTextureMappingStyle Class : MapLayout Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Appearance")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Controls how the texture is positioned relative to the object. ")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property MapLayout As MapLayout
Visual Basic (Usage) Copy Code
Dim instance As ChartTextureMappingStyle
Dim value As MapLayout

instance.MapLayout = value

value = instance.MapLayout
C#
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Controls how the texture is positioned relative to the object. ")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
public MapLayout MapLayout {get; set;}
Delphi
public read-write property MapLayout: MapLayout;
JScript
System.ComponentModel.CategoryAttribute("Appearance")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Controls how the texture is positioned relative to the object. ")
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get,set MapLayout : MapLayout
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Controls how the texture is positioned relative to the object. ")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property MapLayout get_MapLayout();
public: __property void set_MapLayout(
   MapLayout value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Controls how the texture is positioned relative to the object. ")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property MapLayout MapLayout {
   MapLayout get();
   void set (    MapLayout value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartTextureMappingStyle Class
ChartTextureMappingStyle Members


MapMode Property

[image]
Intersoft WebGrid Documentation
MapMode Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartTextureMappingStyle Class : MapMode Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("Appearance")>
<System.ComponentModel.DescriptionAttribute("There are three mapping types, but you'll most likely use only the relative to object mapping type (MapMode.RelativeToObject) where texture coordinates are computed relatively to the object position.")>
Public Property MapMode As MapMode
Visual Basic (Usage) Copy Code
Dim instance As ChartTextureMappingStyle
Dim value As MapMode

instance.MapMode = value

value = instance.MapMode
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.DescriptionAttribute("There are three mapping types, but you'll most likely use only the relative to object mapping type (MapMode.RelativeToObject) where texture coordinates are computed relatively to the object position.")]
public MapMode MapMode {get; set;}
Delphi
public read-write property MapMode: MapMode;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("Appearance")
System.ComponentModel.DescriptionAttribute("There are three mapping types, but you'll most likely use only the relative to object mapping type (MapMode.RelativeToObject) where texture coordinates are computed relatively to the object position.")
public function get,set MapMode : MapMode
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.DescriptionAttribute("There are three mapping types, but you'll most likely use only the relative to object mapping type (MapMode.RelativeToObject) where texture coordinates are computed relatively to the object position.")]
public: __property MapMode get_MapMode();
public: __property void set_MapMode(
   MapMode value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.DescriptionAttribute("There are three mapping types, but you'll most likely use only the relative to object mapping type (MapMode.RelativeToObject) where texture coordinates are computed relatively to the object position.")]
public:
property MapMode MapMode {
   MapMode get();
   void set (    MapMode value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartTextureMappingStyle Class
ChartTextureMappingStyle Members


VerticalScale Property

[image]
Intersoft WebGrid Documentation
VerticalScale Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartTextureMappingStyle Class : VerticalScale Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Appearance")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("An additional scale in the Y dimension to be applied to the texture when mapped. ")>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property VerticalScale As System.Single
Visual Basic (Usage) Copy Code
Dim instance As ChartTextureMappingStyle
Dim value As System.Single

instance.VerticalScale = value

value = instance.VerticalScale
C#
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("An additional scale in the Y dimension to be applied to the texture when mapped. ")]
[ISNet.Serialization.BinarySerializableAttribute()]
public System.float VerticalScale {get; set;}
Delphi
public read-write property VerticalScale: System.Single;
JScript
System.ComponentModel.CategoryAttribute("Appearance")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("An additional scale in the Y dimension to be applied to the texture when mapped. ")
ISNet.Serialization.BinarySerializableAttribute()
public function get,set VerticalScale : System.float
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("An additional scale in the Y dimension to be applied to the texture when mapped. ")]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.float get_VerticalScale();
public: __property void set_VerticalScale(
   System.float value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("An additional scale in the Y dimension to be applied to the texture when mapped. ")]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.float VerticalScale {
   System.float get();
   void set (    System.float value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartTextureMappingStyle Class
ChartTextureMappingStyle Members


ChartTitleRibbonSettings Class

[image]
Intersoft WebGrid Documentation
ChartTitleRibbonSettings Class
Members See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartTitleRibbonSettings Class

Glossary Item Box

Object Model

ChartTitleRibbonSettings Class

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.SerializableAttribute()>
Public Class ChartTitleRibbonSettings
   Inherits ISNet.WebUI.WebUIBaseClass
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Visual Basic (Usage) Copy Code
Dim instance As ChartTitleRibbonSettings
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public class ChartTitleRibbonSettings : ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Delphi
public class ChartTitleRibbonSettings = class(ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize)
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.SerializableAttribute()
public class ChartTitleRibbonSettings extends ISNet.WebUI.WebUIBaseClass implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public __gc class ChartTitleRibbonSettings : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public ref class ChartTitleRibbonSettings : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.WebGrid.Chart.ChartTitleRibbonSettings

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartTitleRibbonSettings Members
ISNet.WebUI.WebGrid.Chart Namespace


ChartTitleRibbonSettings Class Members

[image]
Intersoft WebGrid Documentation
ChartTitleRibbonSettings Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartTitleRibbonSettings Class

Glossary Item Box

The following tables list the members exposed by ChartTitleRibbonSettings.

Public Constructors

 | Name | Description
Public Constructor | ChartTitleRibbonSettings Constructor |
Top

Public Properties

 | Name | Description
Public Property | AllowEditXTitle |
Public Property | AllowEditYTitle |
Public Property | AllowEditZTitle |
Public Property | Visible |
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

ChartTitleRibbonSettings Class
ISNet.WebUI.WebGrid.Chart Namespace


ChartTitleRibbonSettings Constructor

[image]
Intersoft WebGrid Documentation
ChartTitleRibbonSettings Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartTitleRibbonSettings Class : ChartTitleRibbonSettings Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New ChartTitleRibbonSettings()
C#
public ChartTitleRibbonSettings()
Delphi
public ChartTitleRibbonSettings();
JScript
public function ChartTitleRibbonSettings();
Managed Extensions for C++
public: ChartTitleRibbonSettings();
C++/CLI
public:
ChartTitleRibbonSettings();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartTitleRibbonSettings Class
ChartTitleRibbonSettings Members


Clone Method

[image]
Intersoft WebGrid Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartTitleRibbonSettings Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As System.Object
Visual Basic (Usage) Copy Code
Dim instance As ChartTitleRibbonSettings
Dim value As System.Object

value = instance.Clone()
C#
public virtual System.object Clone()
Delphi
public function Clone(): System.TObject; virtual;
JScript
public function Clone() : System.Object;
Managed Extensions for C++
public: virtual System.Object* Clone();
C++/CLI
public:
virtual System.Object^ Clone();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartTitleRibbonSettings Class
ChartTitleRibbonSettings Members


CopyFrom Method

[image]
Intersoft WebGrid Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartTitleRibbonSettings Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartTitleRibbonSettings Class
ChartTitleRibbonSettings Members


CopyFrom(Object) Method

[image]
Intersoft WebGrid Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartTitleRibbonSettings Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartTitleRibbonSettings
Dim objSource As System.Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   System.object objSource
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartTitleRibbonSettings Class
ChartTitleRibbonSettings Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebGrid Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartTitleRibbonSettings Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object, _
   ByVal cloneSourceValue As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartTitleRibbonSettings
Dim objSource As System.Object
Dim cloneSourceValue As System.Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   System.object objSource,
   System.bool cloneSourceValue
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject;
    cloneSourceValue: System.Boolean
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object,
   cloneSourceValue : System.boolean
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource,
   System.bool cloneSourceValue
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource,
   System.bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartTitleRibbonSettings Class
ChartTitleRibbonSettings Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebGrid Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartTitleRibbonSettings Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartTitleRibbonSettings
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure DeSerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function DeSerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void DeSerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void DeSerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartTitleRibbonSettings Class
ChartTitleRibbonSettings Members


GetHashCode Method

[image]
Intersoft WebGrid Documentation
GetHashCode Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartTitleRibbonSettings Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As ChartTitleRibbonSettings
Dim value As System.Integer

value = instance.GetHashCode()
C#
public virtual System.int GetHashCode()
Delphi
public function GetHashCode(): System.Integer; virtual;
JScript
public function GetHashCode() : System.int;
Managed Extensions for C++
public: virtual System.int GetHashCode();
C++/CLI
public:
virtual System.int GetHashCode();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartTitleRibbonSettings Class
ChartTitleRibbonSettings Members


ChartTitleRibbonSettings Class Methods

[image]
Intersoft WebGrid Documentation
ChartTitleRibbonSettings Class Methods
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartTitleRibbonSettings Class

Glossary Item Box

For a list of all members of this type, see ChartTitleRibbonSettings members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

ChartTitleRibbonSettings Class
ISNet.WebUI.WebGrid.Chart Namespace


GetObjectData Method

[image]
Intersoft WebGrid Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartTitleRibbonSettings Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=False,
   UnmanagedCode=False,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=True,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Action=SecurityAction.Demand,
   Unrestricted=False)>
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartTitleRibbonSettings
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure GetObjectData(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
); override;
JScript
System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=,
   UnmanagedCode=,
   SkipVerification=,
   Execution=,
   ControlThread=,
   ControlEvidence=,
   ControlPolicy=,
   SerializationFormatter=,
   ControlDomainPolicy=,
   ControlPrincipal=,
   ControlAppDomain=,
   RemotingConfiguration=,
   Infrastructure=,
   BindingRedirects=,
   Action=SecurityAction.Demand,
   Unrestricted=)
public override function GetObjectData(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public: void GetObjectData(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
) override
C++/CLI
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public:
void GetObjectData(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
) override

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartTitleRibbonSettings Class
ChartTitleRibbonSettings Members


IsEmpty Method

[image]
Intersoft WebGrid Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartTitleRibbonSettings Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As ChartTitleRibbonSettings
Dim value As System.Boolean

value = instance.IsEmpty()
C#
public virtual System.bool IsEmpty()
Delphi
public function IsEmpty(): System.Boolean; virtual;
JScript
public function IsEmpty() : System.boolean;
Managed Extensions for C++
public: virtual System.bool IsEmpty();
C++/CLI
public:
virtual System.bool IsEmpty();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartTitleRibbonSettings Class
ChartTitleRibbonSettings Members


Reset Method

[image]
Intersoft WebGrid Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartTitleRibbonSettings Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As ChartTitleRibbonSettings

instance.Reset()
C#
public virtual void Reset()
Delphi
public procedure Reset(); virtual;
JScript
public function Reset();
Managed Extensions for C++
public: virtual void Reset();
C++/CLI
public:
virtual void Reset();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartTitleRibbonSettings Class
ChartTitleRibbonSettings Members


SerializeObjectData Method

[image]
Intersoft WebGrid Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartTitleRibbonSettings Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartTitleRibbonSettings
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure SerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function SerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void SerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void SerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartTitleRibbonSettings Class
ChartTitleRibbonSettings Members


ToString Method

[image]
Intersoft WebGrid Documentation
ToString Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartTitleRibbonSettings Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As System.String
Visual Basic (Usage) Copy Code
Dim instance As ChartTitleRibbonSettings
Dim value As System.String

value = instance.ToString()
C#
public virtual System.string ToString()
Delphi
public function ToString(): System.String; virtual;
JScript
public function ToString() : System.String;
Managed Extensions for C++
public: virtual System.string* ToString();
C++/CLI
public:
virtual System.String^ ToString();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartTitleRibbonSettings Class
ChartTitleRibbonSettings Members


ChartTitleRibbonSettings Class Properties

[image]
Intersoft WebGrid Documentation
ChartTitleRibbonSettings Class Properties
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartTitleRibbonSettings Class

Glossary Item Box

For a list of all members of this type, see ChartTitleRibbonSettings members.

Public Properties

 | Name | Description
Public Property | AllowEditXTitle |
Public Property | AllowEditYTitle |
Public Property | AllowEditZTitle |
Public Property | Visible |
Top

See Also

Reference

ChartTitleRibbonSettings Class
ISNet.WebUI.WebGrid.Chart Namespace


ChartTitleRibbonSettings Constructor

[image]
Intersoft WebGrid Documentation
ChartTitleRibbonSettings Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartTitleRibbonSettings Class : ChartTitleRibbonSettings Constructor

Glossary Item Box

Overload List

Overload | Description
ChartTitleRibbonSettings Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartTitleRibbonSettings Class
ChartTitleRibbonSettings Members


AllowEditXTitle Property

[image]
Intersoft WebGrid Documentation
AllowEditXTitle Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartTitleRibbonSettings Class : AllowEditXTitle Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Allow X axis title to be editable")>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Options")>
Public Property AllowEditXTitle As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As ChartTitleRibbonSettings
Dim value As System.Boolean

instance.AllowEditXTitle = value

value = instance.AllowEditXTitle
C#
[System.ComponentModel.DescriptionAttribute("Allow X axis title to be editable")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Options")]
public System.bool AllowEditXTitle {get; set;}
Delphi
public read-write property AllowEditXTitle: System.Boolean;
JScript
System.ComponentModel.DescriptionAttribute("Allow X axis title to be editable")
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Options")
public function get,set AllowEditXTitle : System.boolean
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Allow X axis title to be editable")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Options")]
public: __property System.bool get_AllowEditXTitle();
public: __property void set_AllowEditXTitle(
   System.bool value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Allow X axis title to be editable")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Options")]
public:
property System.bool AllowEditXTitle {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartTitleRibbonSettings Class
ChartTitleRibbonSettings Members


AllowEditYTitle Property

[image]
Intersoft WebGrid Documentation
AllowEditYTitle Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartTitleRibbonSettings Class : AllowEditYTitle Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("Options")>
<System.ComponentModel.DescriptionAttribute("Allow Y axis title to be editable")>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Property AllowEditYTitle As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As ChartTitleRibbonSettings
Dim value As System.Boolean

instance.AllowEditYTitle = value

value = instance.AllowEditYTitle
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Options")]
[System.ComponentModel.DescriptionAttribute("Allow Y axis title to be editable")]
[ISNet.Serialization.XmlSerializableAttribute()]
public System.bool AllowEditYTitle {get; set;}
Delphi
public read-write property AllowEditYTitle: System.Boolean;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("Options")
System.ComponentModel.DescriptionAttribute("Allow Y axis title to be editable")
ISNet.Serialization.XmlSerializableAttribute()
public function get,set AllowEditYTitle : System.boolean
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Options")]
[System.ComponentModel.DescriptionAttribute("Allow Y axis title to be editable")]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property System.bool get_AllowEditYTitle();
public: __property void set_AllowEditYTitle(
   System.bool value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Options")]
[System.ComponentModel.DescriptionAttribute("Allow Y axis title to be editable")]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property System.bool AllowEditYTitle {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartTitleRibbonSettings Class
ChartTitleRibbonSettings Members


AllowEditZTitle Property

[image]
Intersoft WebGrid Documentation
AllowEditZTitle Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartTitleRibbonSettings Class : AllowEditZTitle Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Options")>
<System.ComponentModel.DescriptionAttribute("Allow Z axis title to be editable")>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Property AllowEditZTitle As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As ChartTitleRibbonSettings
Dim value As System.Boolean

instance.AllowEditZTitle = value

value = instance.AllowEditZTitle
C#
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Options")]
[System.ComponentModel.DescriptionAttribute("Allow Z axis title to be editable")]
[ISNet.Serialization.XmlSerializableAttribute()]
public System.bool AllowEditZTitle {get; set;}
Delphi
public read-write property AllowEditZTitle: System.Boolean;
JScript
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Options")
System.ComponentModel.DescriptionAttribute("Allow Z axis title to be editable")
ISNet.Serialization.XmlSerializableAttribute()
public function get,set AllowEditZTitle : System.boolean
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Options")]
[System.ComponentModel.DescriptionAttribute("Allow Z axis title to be editable")]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property System.bool get_AllowEditZTitle();
public: __property void set_AllowEditZTitle(
   System.bool value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Options")]
[System.ComponentModel.DescriptionAttribute("Allow Z axis title to be editable")]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property System.bool AllowEditZTitle {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartTitleRibbonSettings Class
ChartTitleRibbonSettings Members


Visible Property

[image]
Intersoft WebGrid Documentation
Visible Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartTitleRibbonSettings Class : Visible Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Options")>
<System.ComponentModel.DescriptionAttribute("Controls the visibility of the ribbon.")>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property Visible As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As ChartTitleRibbonSettings
Dim value As System.Boolean

instance.Visible = value

value = instance.Visible
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Options")]
[System.ComponentModel.DescriptionAttribute("Controls the visibility of the ribbon.")]
[ISNet.Serialization.BinarySerializableAttribute()]
public System.bool Visible {get; set;}
Delphi
public read-write property Visible: System.Boolean;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.CategoryAttribute("Options")
System.ComponentModel.DescriptionAttribute("Controls the visibility of the ribbon.")
ISNet.Serialization.BinarySerializableAttribute()
public function get,set Visible : System.boolean
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Options")]
[System.ComponentModel.DescriptionAttribute("Controls the visibility of the ribbon.")]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.bool get_Visible();
public: __property void set_Visible(
   System.bool value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Options")]
[System.ComponentModel.DescriptionAttribute("Controls the visibility of the ribbon.")]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.bool Visible {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartTitleRibbonSettings Class
ChartTitleRibbonSettings Members


ChartTypeRibbonSettings Class

[image]
Intersoft WebGrid Documentation
ChartTypeRibbonSettings Class
Members See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartTypeRibbonSettings Class

Glossary Item Box

Object Model

ChartTypeRibbonSettings Class

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.SerializableAttribute()>
Public Class ChartTypeRibbonSettings
   Inherits ISNet.WebUI.WebUIBaseClass
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Visual Basic (Usage) Copy Code
Dim instance As ChartTypeRibbonSettings
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public class ChartTypeRibbonSettings : ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Delphi
public class ChartTypeRibbonSettings = class(ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize)
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.SerializableAttribute()
public class ChartTypeRibbonSettings extends ISNet.WebUI.WebUIBaseClass implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public __gc class ChartTypeRibbonSettings : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public ref class ChartTypeRibbonSettings : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.WebGrid.Chart.ChartTypeRibbonSettings

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartTypeRibbonSettings Members
ISNet.WebUI.WebGrid.Chart Namespace


ChartTypeRibbonSettings Class Members

[image]
Intersoft WebGrid Documentation
ChartTypeRibbonSettings Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartTypeRibbonSettings Class

Glossary Item Box

The following tables list the members exposed by ChartTypeRibbonSettings.

Public Constructors

 | Name | Description
Public Constructor | ChartTypeRibbonSettings Constructor |
Top

Public Properties

 | Name | Description
Public Property | AreaType |
Public Property | BarType |
Public Property | ColumnType |
Public Property | DoughnutType |
Public Property | LineType |
Public Property | PieType |
Public Property | SmoothLineType |
Public Property | StepLineType |
Public Property | Visible |
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

ChartTypeRibbonSettings Class
ISNet.WebUI.WebGrid.Chart Namespace


ChartTypeRibbonSettings Constructor

[image]
Intersoft WebGrid Documentation
ChartTypeRibbonSettings Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartTypeRibbonSettings Class : ChartTypeRibbonSettings Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New ChartTypeRibbonSettings()
C#
public ChartTypeRibbonSettings()
Delphi
public ChartTypeRibbonSettings();
JScript
public function ChartTypeRibbonSettings();
Managed Extensions for C++
public: ChartTypeRibbonSettings();
C++/CLI
public:
ChartTypeRibbonSettings();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartTypeRibbonSettings Class
ChartTypeRibbonSettings Members


Clone Method

[image]
Intersoft WebGrid Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartTypeRibbonSettings Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As System.Object
Visual Basic (Usage) Copy Code
Dim instance As ChartTypeRibbonSettings
Dim value As System.Object

value = instance.Clone()
C#
public virtual System.object Clone()
Delphi
public function Clone(): System.TObject; virtual;
JScript
public function Clone() : System.Object;
Managed Extensions for C++
public: virtual System.Object* Clone();
C++/CLI
public:
virtual System.Object^ Clone();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartTypeRibbonSettings Class
ChartTypeRibbonSettings Members


CopyFrom Method

[image]
Intersoft WebGrid Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartTypeRibbonSettings Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartTypeRibbonSettings Class
ChartTypeRibbonSettings Members


CopyFrom(Object) Method

[image]
Intersoft WebGrid Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartTypeRibbonSettings Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartTypeRibbonSettings
Dim objSource As System.Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   System.object objSource
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartTypeRibbonSettings Class
ChartTypeRibbonSettings Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebGrid Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartTypeRibbonSettings Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object, _
   ByVal cloneSourceValue As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartTypeRibbonSettings
Dim objSource As System.Object
Dim cloneSourceValue As System.Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   System.object objSource,
   System.bool cloneSourceValue
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject;
    cloneSourceValue: System.Boolean
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object,
   cloneSourceValue : System.boolean
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource,
   System.bool cloneSourceValue
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource,
   System.bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartTypeRibbonSettings Class
ChartTypeRibbonSettings Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebGrid Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartTypeRibbonSettings Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartTypeRibbonSettings
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure DeSerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function DeSerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void DeSerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void DeSerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartTypeRibbonSettings Class
ChartTypeRibbonSettings Members


GetHashCode Method

[image]
Intersoft WebGrid Documentation
GetHashCode Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartTypeRibbonSettings Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As ChartTypeRibbonSettings
Dim value As System.Integer

value = instance.GetHashCode()
C#
public virtual System.int GetHashCode()
Delphi
public function GetHashCode(): System.Integer; virtual;
JScript
public function GetHashCode() : System.int;
Managed Extensions for C++
public: virtual System.int GetHashCode();
C++/CLI
public:
virtual System.int GetHashCode();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartTypeRibbonSettings Class
ChartTypeRibbonSettings Members


ChartTypeRibbonSettings Class Methods

[image]
Intersoft WebGrid Documentation
ChartTypeRibbonSettings Class Methods
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartTypeRibbonSettings Class

Glossary Item Box

For a list of all members of this type, see ChartTypeRibbonSettings members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

ChartTypeRibbonSettings Class
ISNet.WebUI.WebGrid.Chart Namespace


GetObjectData Method

[image]
Intersoft WebGrid Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartTypeRibbonSettings Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=False,
   UnmanagedCode=False,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=True,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Action=SecurityAction.Demand,
   Unrestricted=False)>
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartTypeRibbonSettings
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure GetObjectData(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
); override;
JScript
System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=,
   UnmanagedCode=,
   SkipVerification=,
   Execution=,
   ControlThread=,
   ControlEvidence=,
   ControlPolicy=,
   SerializationFormatter=,
   ControlDomainPolicy=,
   ControlPrincipal=,
   ControlAppDomain=,
   RemotingConfiguration=,
   Infrastructure=,
   BindingRedirects=,
   Action=SecurityAction.Demand,
   Unrestricted=)
public override function GetObjectData(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public: void GetObjectData(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
) override
C++/CLI
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public:
void GetObjectData(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
) override

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartTypeRibbonSettings Class
ChartTypeRibbonSettings Members


IsEmpty Method

[image]
Intersoft WebGrid Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartTypeRibbonSettings Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As ChartTypeRibbonSettings
Dim value As System.Boolean

value = instance.IsEmpty()
C#
public virtual System.bool IsEmpty()
Delphi
public function IsEmpty(): System.Boolean; virtual;
JScript
public function IsEmpty() : System.boolean;
Managed Extensions for C++
public: virtual System.bool IsEmpty();
C++/CLI
public:
virtual System.bool IsEmpty();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartTypeRibbonSettings Class
ChartTypeRibbonSettings Members


Reset Method

[image]
Intersoft WebGrid Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartTypeRibbonSettings Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As ChartTypeRibbonSettings

instance.Reset()
C#
public virtual void Reset()
Delphi
public procedure Reset(); virtual;
JScript
public function Reset();
Managed Extensions for C++
public: virtual void Reset();
C++/CLI
public:
virtual void Reset();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartTypeRibbonSettings Class
ChartTypeRibbonSettings Members


SerializeObjectData Method

[image]
Intersoft WebGrid Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartTypeRibbonSettings Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartTypeRibbonSettings
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure SerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function SerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void SerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void SerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartTypeRibbonSettings Class
ChartTypeRibbonSettings Members


ToString Method

[image]
Intersoft WebGrid Documentation
ToString Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartTypeRibbonSettings Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As System.String
Visual Basic (Usage) Copy Code
Dim instance As ChartTypeRibbonSettings
Dim value As System.String

value = instance.ToString()
C#
public virtual System.string ToString()
Delphi
public function ToString(): System.String; virtual;
JScript
public function ToString() : System.String;
Managed Extensions for C++
public: virtual System.string* ToString();
C++/CLI
public:
virtual System.String^ ToString();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartTypeRibbonSettings Class
ChartTypeRibbonSettings Members


ChartTypeRibbonSettings Class Properties

[image]
Intersoft WebGrid Documentation
ChartTypeRibbonSettings Class Properties
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartTypeRibbonSettings Class

Glossary Item Box

For a list of all members of this type, see ChartTypeRibbonSettings members.

Public Properties

 | Name | Description
Public Property | AreaType |
Public Property | BarType |
Public Property | ColumnType |
Public Property | DoughnutType |
Public Property | LineType |
Public Property | PieType |
Public Property | SmoothLineType |
Public Property | StepLineType |
Public Property | Visible |
Top

See Also

Reference

ChartTypeRibbonSettings Class
ISNet.WebUI.WebGrid.Chart Namespace


ChartTypeRibbonSettings Constructor

[image]
Intersoft WebGrid Documentation
ChartTypeRibbonSettings Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartTypeRibbonSettings Class : ChartTypeRibbonSettings Constructor

Glossary Item Box

Overload List

Overload | Description
ChartTypeRibbonSettings Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartTypeRibbonSettings Class
ChartTypeRibbonSettings Members


AreaType Property

[image]
Intersoft WebGrid Documentation
AreaType Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartTypeRibbonSettings Class : AreaType Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<ISNet.Serialization.XmlSerializableAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute("setAreaType")>
<System.ComponentModel.DefaultValueAttribute()>
Public ReadOnly Property AreaType As ChartAreaTypeSettings
Visual Basic (Usage) Copy Code
Dim instance As ChartTypeRibbonSettings
Dim value As ChartAreaTypeSettings

value = instance.AreaType
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute("setAreaType")]
[System.ComponentModel.DefaultValueAttribute()]
public ChartAreaTypeSettings AreaType {get;}
Delphi
public read-only property AreaType: ChartAreaTypeSettings;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute("setAreaType")
System.ComponentModel.DefaultValueAttribute()
public function get AreaType : ChartAreaTypeSettings
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute("setAreaType")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property ChartAreaTypeSettings* get_AreaType();
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute("setAreaType")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property ChartAreaTypeSettings^ AreaType {
   ChartAreaTypeSettings^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartTypeRibbonSettings Class
ChartTypeRibbonSettings Members


BarType Property

[image]
Intersoft WebGrid Documentation
BarType Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartTypeRibbonSettings Class : BarType Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<ISNet.Serialization.XmlSerializableAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute("setBarType")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public ReadOnly Property BarType As ChartBarTypeSettings
Visual Basic (Usage) Copy Code
Dim instance As ChartTypeRibbonSettings
Dim value As ChartBarTypeSettings

value = instance.BarType
C#
[System.ComponentModel.DefaultValueAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute("setBarType")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public ChartBarTypeSettings BarType {get;}
Delphi
public read-only property BarType: ChartBarTypeSettings;
JScript
System.ComponentModel.DefaultValueAttribute()
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute("setBarType")
System.ComponentModel.NotifyParentPropertyAttribute()
public function get BarType : ChartBarTypeSettings
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute("setBarType")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property ChartBarTypeSettings* get_BarType();
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute("setBarType")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property ChartBarTypeSettings^ BarType {
   ChartBarTypeSettings^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartTypeRibbonSettings Class
ChartTypeRibbonSettings Members


ColumnType Property

[image]
Intersoft WebGrid Documentation
ColumnType Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartTypeRibbonSettings Class : ColumnType Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<ISNet.Serialization.BinarySerializableAttribute("setColumnType")>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute(True)>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
Public ReadOnly Property ColumnType As ChartColumnTypeSettings
Visual Basic (Usage) Copy Code
Dim instance As ChartTypeRibbonSettings
Dim value As ChartColumnTypeSettings

value = instance.ColumnType
C#
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.Serialization.BinarySerializableAttribute("setColumnType")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
public ChartColumnTypeSettings ColumnType {get;}
Delphi
public read-only property ColumnType: ChartColumnTypeSettings;
JScript
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
ISNet.Serialization.BinarySerializableAttribute("setColumnType")
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
public function get ColumnType : ChartColumnTypeSettings
Managed Extensions for C++
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.Serialization.BinarySerializableAttribute("setColumnType")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
public: __property ChartColumnTypeSettings* get_ColumnType();
C++/CLI
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.Serialization.BinarySerializableAttribute("setColumnType")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
public:
property ChartColumnTypeSettings^ ColumnType {
   ChartColumnTypeSettings^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartTypeRibbonSettings Class
ChartTypeRibbonSettings Members


DoughnutType Property

[image]
Intersoft WebGrid Documentation
DoughnutType Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartTypeRibbonSettings Class : DoughnutType Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute("setDoughnutType")>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute(True)>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
Public ReadOnly Property DoughnutType As ChartDoughnutTypeSettings
Visual Basic (Usage) Copy Code
Dim instance As ChartTypeRibbonSettings
Dim value As ChartDoughnutTypeSettings

value = instance.DoughnutType
C#
[ISNet.Serialization.BinarySerializableAttribute("setDoughnutType")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
public ChartDoughnutTypeSettings DoughnutType {get;}
Delphi
public read-only property DoughnutType: ChartDoughnutTypeSettings;
JScript
ISNet.Serialization.BinarySerializableAttribute("setDoughnutType")
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
System.ComponentModel.NotifyParentPropertyAttribute()
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
public function get DoughnutType : ChartDoughnutTypeSettings
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute("setDoughnutType")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
public: __property ChartDoughnutTypeSettings* get_DoughnutType();
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute("setDoughnutType")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
public:
property ChartDoughnutTypeSettings^ DoughnutType {
   ChartDoughnutTypeSettings^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartTypeRibbonSettings Class
ChartTypeRibbonSettings Members


LineType Property

[image]
Intersoft WebGrid Documentation
LineType Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartTypeRibbonSettings Class : LineType Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute("setLineType")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
Public ReadOnly Property LineType As ChartLineTypeSettings
Visual Basic (Usage) Copy Code
Dim instance As ChartTypeRibbonSettings
Dim value As ChartLineTypeSettings

value = instance.LineType
C#
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute("setLineType")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
public ChartLineTypeSettings LineType {get;}
Delphi
public read-only property LineType: ChartLineTypeSettings;
JScript
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute("setLineType")
System.ComponentModel.NotifyParentPropertyAttribute()
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
public function get LineType : ChartLineTypeSettings
Managed Extensions for C++
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute("setLineType")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
public: __property ChartLineTypeSettings* get_LineType();
C++/CLI
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute("setLineType")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
public:
property ChartLineTypeSettings^ LineType {
   ChartLineTypeSettings^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartTypeRibbonSettings Class
ChartTypeRibbonSettings Members


PieType Property

[image]
Intersoft WebGrid Documentation
PieType Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartTypeRibbonSettings Class : PieType Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute(True)>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<ISNet.Serialization.BinarySerializableAttribute("setPieType")>
Public ReadOnly Property PieType As ChartPieTypeSettings
Visual Basic (Usage) Copy Code
Dim instance As ChartTypeRibbonSettings
Dim value As ChartPieTypeSettings

value = instance.PieType
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.Serialization.BinarySerializableAttribute("setPieType")]
public ChartPieTypeSettings PieType {get;}
Delphi
public read-only property PieType: ChartPieTypeSettings;
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
ISNet.Serialization.BinarySerializableAttribute("setPieType")
public function get PieType : ChartPieTypeSettings
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.Serialization.BinarySerializableAttribute("setPieType")]
public: __property ChartPieTypeSettings* get_PieType();
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.Serialization.BinarySerializableAttribute("setPieType")]
public:
property ChartPieTypeSettings^ PieType {
   ChartPieTypeSettings^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartTypeRibbonSettings Class
ChartTypeRibbonSettings Members


SmoothLineType Property

[image]
Intersoft WebGrid Documentation
SmoothLineType Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartTypeRibbonSettings Class : SmoothLineType Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute("setSmoothLineType")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<ISNet.Serialization.XmlSerializableAttribute(True)>
Public ReadOnly Property SmoothLineType As ChartSmoothLineTypeSettings
Visual Basic (Usage) Copy Code
Dim instance As ChartTypeRibbonSettings
Dim value As ChartSmoothLineTypeSettings

value = instance.SmoothLineType
C#
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute("setSmoothLineType")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[ISNet.Serialization.XmlSerializableAttribute(true)]
public ChartSmoothLineTypeSettings SmoothLineType {get;}
Delphi
public read-only property SmoothLineType: ChartSmoothLineTypeSettings;
JScript
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute("setSmoothLineType")
System.ComponentModel.NotifyParentPropertyAttribute()
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
ISNet.Serialization.XmlSerializableAttribute()
public function get SmoothLineType : ChartSmoothLineTypeSettings
Managed Extensions for C++
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute("setSmoothLineType")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[ISNet.Serialization.XmlSerializableAttribute(true)]
public: __property ChartSmoothLineTypeSettings* get_SmoothLineType();
C++/CLI
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute("setSmoothLineType")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[ISNet.Serialization.XmlSerializableAttribute(true)]
public:
property ChartSmoothLineTypeSettings^ SmoothLineType {
   ChartSmoothLineTypeSettings^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartTypeRibbonSettings Class
ChartTypeRibbonSettings Members


StepLineType Property

[image]
Intersoft WebGrid Documentation
StepLineType Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartTypeRibbonSettings Class : StepLineType Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute("setStepLineType")>
<ISNet.Serialization.XmlSerializableAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
Public ReadOnly Property StepLineType As ChartStepLineTypeSettings
Visual Basic (Usage) Copy Code
Dim instance As ChartTypeRibbonSettings
Dim value As ChartStepLineTypeSettings

value = instance.StepLineType
C#
[ISNet.Serialization.BinarySerializableAttribute("setStepLineType")]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
public ChartStepLineTypeSettings StepLineType {get;}
Delphi
public read-only property StepLineType: ChartStepLineTypeSettings;
JScript
ISNet.Serialization.BinarySerializableAttribute("setStepLineType")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
public function get StepLineType : ChartStepLineTypeSettings
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute("setStepLineType")]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
public: __property ChartStepLineTypeSettings* get_StepLineType();
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute("setStepLineType")]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
public:
property ChartStepLineTypeSettings^ StepLineType {
   ChartStepLineTypeSettings^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartTypeRibbonSettings Class
ChartTypeRibbonSettings Members


Visible Property

[image]
Intersoft WebGrid Documentation
Visible Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartTypeRibbonSettings Class : Visible Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Controls the visibility of the ribbon.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Options")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property Visible As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As ChartTypeRibbonSettings
Dim value As System.Boolean

instance.Visible = value

value = instance.Visible
C#
[System.ComponentModel.DescriptionAttribute("Controls the visibility of the ribbon.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Options")]
[System.ComponentModel.DefaultValueAttribute()]
public System.bool Visible {get; set;}
Delphi
public read-write property Visible: System.Boolean;
JScript
System.ComponentModel.DescriptionAttribute("Controls the visibility of the ribbon.")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Options")
System.ComponentModel.DefaultValueAttribute()
public function get,set Visible : System.boolean
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Controls the visibility of the ribbon.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Options")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.bool get_Visible();
public: __property void set_Visible(
   System.bool value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Controls the visibility of the ribbon.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Options")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.bool Visible {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartTypeRibbonSettings Class
ChartTypeRibbonSettings Members


ChartVector3DValue Class

[image]
Intersoft WebGrid Documentation
ChartVector3DValue Class
Members See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartVector3DValue Class

Glossary Item Box

Object Model

ChartVector3DValue Class

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.SerializableAttribute()>
Public Class ChartVector3DValue
   Inherits ISNet.WebUI.WebUIBaseClass
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Visual Basic (Usage) Copy Code
Dim instance As ChartVector3DValue
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public class ChartVector3DValue : ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Delphi
public class ChartVector3DValue = class(ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize)
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.SerializableAttribute()
public class ChartVector3DValue extends ISNet.WebUI.WebUIBaseClass implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public __gc class ChartVector3DValue : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public ref class ChartVector3DValue : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.WebGrid.Chart.ChartVector3DValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartVector3DValue Members
ISNet.WebUI.WebGrid.Chart Namespace


ChartVector3DValue Class Members

[image]
Intersoft WebGrid Documentation
ChartVector3DValue Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartVector3DValue Class

Glossary Item Box

The following tables list the members exposed by ChartVector3DValue.

Public Constructors

 | Name | Description
Public Constructor | ChartVector3DValue Constructor |
Top

Public Properties

 | Name | Description
Public Property | X |
Public Property | Y |
Public Property | Z |
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

ChartVector3DValue Class
ISNet.WebUI.WebGrid.Chart Namespace


ChartVector3DValue Constructor

[image]
Intersoft WebGrid Documentation
ChartVector3DValue Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartVector3DValue Class : ChartVector3DValue Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New ChartVector3DValue()
C#
public ChartVector3DValue()
Delphi
public ChartVector3DValue();
JScript
public function ChartVector3DValue();
Managed Extensions for C++
public: ChartVector3DValue();
C++/CLI
public:
ChartVector3DValue();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartVector3DValue Class
ChartVector3DValue Members


Clone Method

[image]
Intersoft WebGrid Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartVector3DValue Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As System.Object
Visual Basic (Usage) Copy Code
Dim instance As ChartVector3DValue
Dim value As System.Object

value = instance.Clone()
C#
public virtual System.object Clone()
Delphi
public function Clone(): System.TObject; virtual;
JScript
public function Clone() : System.Object;
Managed Extensions for C++
public: virtual System.Object* Clone();
C++/CLI
public:
virtual System.Object^ Clone();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartVector3DValue Class
ChartVector3DValue Members


CopyFrom Method

[image]
Intersoft WebGrid Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartVector3DValue Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartVector3DValue Class
ChartVector3DValue Members


CopyFrom(Object) Method

[image]
Intersoft WebGrid Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartVector3DValue Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartVector3DValue
Dim objSource As System.Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   System.object objSource
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartVector3DValue Class
ChartVector3DValue Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebGrid Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartVector3DValue Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object, _
   ByVal cloneSourceValue As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartVector3DValue
Dim objSource As System.Object
Dim cloneSourceValue As System.Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   System.object objSource,
   System.bool cloneSourceValue
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject;
    cloneSourceValue: System.Boolean
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object,
   cloneSourceValue : System.boolean
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource,
   System.bool cloneSourceValue
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource,
   System.bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartVector3DValue Class
ChartVector3DValue Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebGrid Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartVector3DValue Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartVector3DValue
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure DeSerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function DeSerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void DeSerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void DeSerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartVector3DValue Class
ChartVector3DValue Members


GetHashCode Method

[image]
Intersoft WebGrid Documentation
GetHashCode Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartVector3DValue Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As ChartVector3DValue
Dim value As System.Integer

value = instance.GetHashCode()
C#
public virtual System.int GetHashCode()
Delphi
public function GetHashCode(): System.Integer; virtual;
JScript
public function GetHashCode() : System.int;
Managed Extensions for C++
public: virtual System.int GetHashCode();
C++/CLI
public:
virtual System.int GetHashCode();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartVector3DValue Class
ChartVector3DValue Members


ChartVector3DValue Class Methods

[image]
Intersoft WebGrid Documentation
ChartVector3DValue Class Methods
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartVector3DValue Class

Glossary Item Box

For a list of all members of this type, see ChartVector3DValue members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

ChartVector3DValue Class
ISNet.WebUI.WebGrid.Chart Namespace


GetObjectData Method

[image]
Intersoft WebGrid Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartVector3DValue Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=False,
   UnmanagedCode=False,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=True,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Action=SecurityAction.Demand,
   Unrestricted=False)>
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartVector3DValue
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure GetObjectData(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
); override;
JScript
System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=,
   UnmanagedCode=,
   SkipVerification=,
   Execution=,
   ControlThread=,
   ControlEvidence=,
   ControlPolicy=,
   SerializationFormatter=,
   ControlDomainPolicy=,
   ControlPrincipal=,
   ControlAppDomain=,
   RemotingConfiguration=,
   Infrastructure=,
   BindingRedirects=,
   Action=SecurityAction.Demand,
   Unrestricted=)
public override function GetObjectData(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public: void GetObjectData(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
) override
C++/CLI
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public:
void GetObjectData(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
) override

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartVector3DValue Class
ChartVector3DValue Members


IsEmpty Method

[image]
Intersoft WebGrid Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartVector3DValue Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As ChartVector3DValue
Dim value As System.Boolean

value = instance.IsEmpty()
C#
public virtual System.bool IsEmpty()
Delphi
public function IsEmpty(): System.Boolean; virtual;
JScript
public function IsEmpty() : System.boolean;
Managed Extensions for C++
public: virtual System.bool IsEmpty();
C++/CLI
public:
virtual System.bool IsEmpty();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartVector3DValue Class
ChartVector3DValue Members


Reset Method

[image]
Intersoft WebGrid Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartVector3DValue Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As ChartVector3DValue

instance.Reset()
C#
public virtual void Reset()
Delphi
public procedure Reset(); virtual;
JScript
public function Reset();
Managed Extensions for C++
public: virtual void Reset();
C++/CLI
public:
virtual void Reset();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartVector3DValue Class
ChartVector3DValue Members


SerializeObjectData Method

[image]
Intersoft WebGrid Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartVector3DValue Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartVector3DValue
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure SerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function SerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void SerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void SerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartVector3DValue Class
ChartVector3DValue Members


ToString Method

[image]
Intersoft WebGrid Documentation
ToString Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartVector3DValue Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As System.String
Visual Basic (Usage) Copy Code
Dim instance As ChartVector3DValue
Dim value As System.String

value = instance.ToString()
C#
public virtual System.string ToString()
Delphi
public function ToString(): System.String; virtual;
JScript
public function ToString() : System.String;
Managed Extensions for C++
public: virtual System.string* ToString();
C++/CLI
public:
virtual System.String^ ToString();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartVector3DValue Class
ChartVector3DValue Members


ChartVector3DValue Class Properties

[image]
Intersoft WebGrid Documentation
ChartVector3DValue Class Properties
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartVector3DValue Class

Glossary Item Box

For a list of all members of this type, see ChartVector3DValue members.

Public Properties

 | Name | Description
Public Property | X |
Public Property | Y |
Public Property | Z |
Top

See Also

Reference

ChartVector3DValue Class
ISNet.WebUI.WebGrid.Chart Namespace


ChartVector3DValue Constructor

[image]
Intersoft WebGrid Documentation
ChartVector3DValue Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartVector3DValue Class : ChartVector3DValue Constructor

Glossary Item Box

Overload List

Overload | Description
ChartVector3DValue Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartVector3DValue Class
ChartVector3DValue Members


X Property

[image]
Intersoft WebGrid Documentation
X Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartVector3DValue Class : X Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("General")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("X Position")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
Public Property X As System.Single
Visual Basic (Usage) Copy Code
Dim instance As ChartVector3DValue
Dim value As System.Single

instance.X = value

value = instance.X
C#
[System.ComponentModel.CategoryAttribute("General")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("X Position")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public System.float X {get; set;}
Delphi
public read-write property X: System.Single;
JScript
System.ComponentModel.CategoryAttribute("General")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DescriptionAttribute("X Position")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
public function get,set X : System.float
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("General")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("X Position")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.float get_X();
public: __property void set_X(
   System.float value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("General")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("X Position")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.float X {
   System.float get();
   void set (    System.float value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartVector3DValue Class
ChartVector3DValue Members


Y Property

[image]
Intersoft WebGrid Documentation
Y Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartVector3DValue Class : Y Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Y Position")>
<System.ComponentModel.CategoryAttribute("General")>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property Y As System.Single
Visual Basic (Usage) Copy Code
Dim instance As ChartVector3DValue
Dim value As System.Single

instance.Y = value

value = instance.Y
C#
[System.ComponentModel.DescriptionAttribute("Y Position")]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.float Y {get; set;}
Delphi
public read-write property Y: System.Single;
JScript
System.ComponentModel.DescriptionAttribute("Y Position")
System.ComponentModel.CategoryAttribute("General")
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set Y : System.float
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Y Position")]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.float get_Y();
public: __property void set_Y(
   System.float value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Y Position")]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.float Y {
   System.float get();
   void set (    System.float value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartVector3DValue Class
ChartVector3DValue Members


Z Property

[image]
Intersoft WebGrid Documentation
Z Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartVector3DValue Class : Z Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Z Position")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("General")>
Public Property Z As System.Single
Visual Basic (Usage) Copy Code
Dim instance As ChartVector3DValue
Dim value As System.Single

instance.Z = value

value = instance.Z
C#
[System.ComponentModel.DescriptionAttribute("Z Position")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("General")]
public System.float Z {get; set;}
Delphi
public read-write property Z: System.Single;
JScript
System.ComponentModel.DescriptionAttribute("Z Position")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("General")
public function get,set Z : System.float
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Z Position")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("General")]
public: __property System.float get_Z();
public: __property void set_Z(
   System.float value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Z Position")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("General")]
public:
property System.float Z {
   System.float get();
   void set (    System.float value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartVector3DValue Class
ChartVector3DValue Members


ChartVisualEffectSettings Class

[image]
Intersoft WebGrid Documentation
ChartVisualEffectSettings Class
Members See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartVisualEffectSettings Class

Glossary Item Box

Object Model

ChartVisualEffectSettings Class

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.SerializableAttribute()>
Public Class ChartVisualEffectSettings
   Inherits ISNet.WebUI.WebUIBaseClass
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Visual Basic (Usage) Copy Code
Dim instance As ChartVisualEffectSettings
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public class ChartVisualEffectSettings : ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Delphi
public class ChartVisualEffectSettings = class(ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize)
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.SerializableAttribute()
public class ChartVisualEffectSettings extends ISNet.WebUI.WebUIBaseClass implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public __gc class ChartVisualEffectSettings : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public ref class ChartVisualEffectSettings : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.WebGrid.Chart.ChartVisualEffectSettings

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartVisualEffectSettings Members
ISNet.WebUI.WebGrid.Chart Namespace


ChartVisualEffectSettings Class Members

[image]
Intersoft WebGrid Documentation
ChartVisualEffectSettings Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartVisualEffectSettings Class

Glossary Item Box

The following tables list the members exposed by ChartVisualEffectSettings.

Public Constructors

 | Name | Description
Public Constructor | ChartVisualEffectSettings Constructor |
Top

Public Properties

 | Name | Description
Public Property | EnableJittering |
Public Property | JitteringDeviation |
Public Property | JitteringSteps |
Public Property | RenderSurface |
Public Property | ShapeRenderingMode |
Public Property | TextRenderingHint |
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

ChartVisualEffectSettings Class
ISNet.WebUI.WebGrid.Chart Namespace


ChartVisualEffectSettings Constructor

[image]
Intersoft WebGrid Documentation
ChartVisualEffectSettings Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartVisualEffectSettings Class : ChartVisualEffectSettings Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New ChartVisualEffectSettings()
C#
public ChartVisualEffectSettings()
Delphi
public ChartVisualEffectSettings();
JScript
public function ChartVisualEffectSettings();
Managed Extensions for C++
public: ChartVisualEffectSettings();
C++/CLI
public:
ChartVisualEffectSettings();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartVisualEffectSettings Class
ChartVisualEffectSettings Members


Clone Method

[image]
Intersoft WebGrid Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartVisualEffectSettings Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As System.Object
Visual Basic (Usage) Copy Code
Dim instance As ChartVisualEffectSettings
Dim value As System.Object

value = instance.Clone()
C#
public virtual System.object Clone()
Delphi
public function Clone(): System.TObject; virtual;
JScript
public function Clone() : System.Object;
Managed Extensions for C++
public: virtual System.Object* Clone();
C++/CLI
public:
virtual System.Object^ Clone();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartVisualEffectSettings Class
ChartVisualEffectSettings Members


CopyFrom Method

[image]
Intersoft WebGrid Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartVisualEffectSettings Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartVisualEffectSettings Class
ChartVisualEffectSettings Members


CopyFrom(Object) Method

[image]
Intersoft WebGrid Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartVisualEffectSettings Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartVisualEffectSettings
Dim objSource As System.Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   System.object objSource
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartVisualEffectSettings Class
ChartVisualEffectSettings Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebGrid Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartVisualEffectSettings Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object, _
   ByVal cloneSourceValue As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartVisualEffectSettings
Dim objSource As System.Object
Dim cloneSourceValue As System.Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   System.object objSource,
   System.bool cloneSourceValue
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject;
    cloneSourceValue: System.Boolean
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object,
   cloneSourceValue : System.boolean
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource,
   System.bool cloneSourceValue
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource,
   System.bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartVisualEffectSettings Class
ChartVisualEffectSettings Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebGrid Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartVisualEffectSettings Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartVisualEffectSettings
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure DeSerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function DeSerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void DeSerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void DeSerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartVisualEffectSettings Class
ChartVisualEffectSettings Members


GetHashCode Method

[image]
Intersoft WebGrid Documentation
GetHashCode Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartVisualEffectSettings Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As ChartVisualEffectSettings
Dim value As System.Integer

value = instance.GetHashCode()
C#
public virtual System.int GetHashCode()
Delphi
public function GetHashCode(): System.Integer; virtual;
JScript
public function GetHashCode() : System.int;
Managed Extensions for C++
public: virtual System.int GetHashCode();
C++/CLI
public:
virtual System.int GetHashCode();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartVisualEffectSettings Class
ChartVisualEffectSettings Members


ChartVisualEffectSettings Class Methods

[image]
Intersoft WebGrid Documentation
ChartVisualEffectSettings Class Methods
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartVisualEffectSettings Class

Glossary Item Box

For a list of all members of this type, see ChartVisualEffectSettings members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

ChartVisualEffectSettings Class
ISNet.WebUI.WebGrid.Chart Namespace


GetObjectData Method

[image]
Intersoft WebGrid Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartVisualEffectSettings Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=False,
   UnmanagedCode=False,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=True,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Action=SecurityAction.Demand,
   Unrestricted=False)>
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartVisualEffectSettings
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure GetObjectData(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
); override;
JScript
System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=,
   UnmanagedCode=,
   SkipVerification=,
   Execution=,
   ControlThread=,
   ControlEvidence=,
   ControlPolicy=,
   SerializationFormatter=,
   ControlDomainPolicy=,
   ControlPrincipal=,
   ControlAppDomain=,
   RemotingConfiguration=,
   Infrastructure=,
   BindingRedirects=,
   Action=SecurityAction.Demand,
   Unrestricted=)
public override function GetObjectData(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public: void GetObjectData(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
) override
C++/CLI
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public:
void GetObjectData(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
) override

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartVisualEffectSettings Class
ChartVisualEffectSettings Members


IsEmpty Method

[image]
Intersoft WebGrid Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartVisualEffectSettings Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As ChartVisualEffectSettings
Dim value As System.Boolean

value = instance.IsEmpty()
C#
public virtual System.bool IsEmpty()
Delphi
public function IsEmpty(): System.Boolean; virtual;
JScript
public function IsEmpty() : System.boolean;
Managed Extensions for C++
public: virtual System.bool IsEmpty();
C++/CLI
public:
virtual System.bool IsEmpty();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartVisualEffectSettings Class
ChartVisualEffectSettings Members


Reset Method

[image]
Intersoft WebGrid Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartVisualEffectSettings Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As ChartVisualEffectSettings

instance.Reset()
C#
public virtual void Reset()
Delphi
public procedure Reset(); virtual;
JScript
public function Reset();
Managed Extensions for C++
public: virtual void Reset();
C++/CLI
public:
virtual void Reset();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartVisualEffectSettings Class
ChartVisualEffectSettings Members


SerializeObjectData Method

[image]
Intersoft WebGrid Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartVisualEffectSettings Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartVisualEffectSettings
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure SerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function SerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void SerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void SerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartVisualEffectSettings Class
ChartVisualEffectSettings Members


ToString Method

[image]
Intersoft WebGrid Documentation
ToString Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartVisualEffectSettings Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As System.String
Visual Basic (Usage) Copy Code
Dim instance As ChartVisualEffectSettings
Dim value As System.String

value = instance.ToString()
C#
public virtual System.string ToString()
Delphi
public function ToString(): System.String; virtual;
JScript
public function ToString() : System.String;
Managed Extensions for C++
public: virtual System.string* ToString();
C++/CLI
public:
virtual System.String^ ToString();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartVisualEffectSettings Class
ChartVisualEffectSettings Members


ChartVisualEffectSettings Class Properties

[image]
Intersoft WebGrid Documentation
ChartVisualEffectSettings Class Properties
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartVisualEffectSettings Class

Glossary Item Box

For a list of all members of this type, see ChartVisualEffectSettings members.

Public Properties

 | Name | Description
Public Property | EnableJittering |
Public Property | JitteringDeviation |
Public Property | JitteringSteps |
Public Property | RenderSurface |
Public Property | ShapeRenderingMode |
Public Property | TextRenderingHint |
Top

See Also

Reference

ChartVisualEffectSettings Class
ISNet.WebUI.WebGrid.Chart Namespace


ChartVisualEffectSettings Constructor

[image]
Intersoft WebGrid Documentation
ChartVisualEffectSettings Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartVisualEffectSettings Class : ChartVisualEffectSettings Constructor

Glossary Item Box

Overload List

Overload | Description
ChartVisualEffectSettings Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartVisualEffectSettings Class
ChartVisualEffectSettings Members


EnableJittering Property

[image]
Intersoft WebGrid Documentation
EnableJittering Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartVisualEffectSettings Class : EnableJittering Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Enable the jittering (full context antialiasing) feature of the control.")>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("General")>
Public Property EnableJittering As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As ChartVisualEffectSettings
Dim value As System.Boolean

instance.EnableJittering = value

value = instance.EnableJittering
C#
[System.ComponentModel.DescriptionAttribute("Enable the jittering (full context antialiasing) feature of the control.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("General")]
public System.bool EnableJittering {get; set;}
Delphi
public read-write property EnableJittering: System.Boolean;
JScript
System.ComponentModel.DescriptionAttribute("Enable the jittering (full context antialiasing) feature of the control.")
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("General")
public function get,set EnableJittering : System.boolean
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Enable the jittering (full context antialiasing) feature of the control.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("General")]
public: __property System.bool get_EnableJittering();
public: __property void set_EnableJittering(
   System.bool value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Enable the jittering (full context antialiasing) feature of the control.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("General")]
public:
property System.bool EnableJittering {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartVisualEffectSettings Class
ChartVisualEffectSettings Members


JitteringDeviation Property

[image]
Intersoft WebGrid Documentation
JitteringDeviation Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartVisualEffectSettings Class : JitteringDeviation Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("The maximum deviation of the jittering samples from the original image in pixels. ")>
<System.ComponentModel.CategoryAttribute("General")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property JitteringDeviation As System.Single
Visual Basic (Usage) Copy Code
Dim instance As ChartVisualEffectSettings
Dim value As System.Single

instance.JitteringDeviation = value

value = instance.JitteringDeviation
C#
[System.ComponentModel.DescriptionAttribute("The maximum deviation of the jittering samples from the original image in pixels. ")]
[System.ComponentModel.CategoryAttribute("General")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.float JitteringDeviation {get; set;}
Delphi
public read-write property JitteringDeviation: System.Single;
JScript
System.ComponentModel.DescriptionAttribute("The maximum deviation of the jittering samples from the original image in pixels. ")
System.ComponentModel.CategoryAttribute("General")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set JitteringDeviation : System.float
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("The maximum deviation of the jittering samples from the original image in pixels. ")]
[System.ComponentModel.CategoryAttribute("General")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.float get_JitteringDeviation();
public: __property void set_JitteringDeviation(
   System.float value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("The maximum deviation of the jittering samples from the original image in pixels. ")]
[System.ComponentModel.CategoryAttribute("General")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.float JitteringDeviation {
   System.float get();
   void set (    System.float value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartVisualEffectSettings Class
ChartVisualEffectSettings Members


JitteringSteps Property

[image]
Intersoft WebGrid Documentation
JitteringSteps Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartVisualEffectSettings Class : JitteringSteps Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("General")>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("The number of image samples rendered by the control to produce a jittered image.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property JitteringSteps As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As ChartVisualEffectSettings
Dim value As System.Integer

instance.JitteringSteps = value

value = instance.JitteringSteps
C#
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("The number of image samples rendered by the control to produce a jittered image.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.int JitteringSteps {get; set;}
Delphi
public read-write property JitteringSteps: System.Integer;
JScript
System.ComponentModel.CategoryAttribute("General")
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DescriptionAttribute("The number of image samples rendered by the control to produce a jittered image.")
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set JitteringSteps : System.int
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("The number of image samples rendered by the control to produce a jittered image.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.int get_JitteringSteps();
public: __property void set_JitteringSteps(
   System.int value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("The number of image samples rendered by the control to produce a jittered image.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.int JitteringSteps {
   System.int get();
   void set (    System.int value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartVisualEffectSettings Class
ChartVisualEffectSettings Members


RenderSurface Property

[image]
Intersoft WebGrid Documentation
RenderSurface Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartVisualEffectSettings Class : RenderSurface Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Whether or not to render the chart to a bitmap or use a double buffer window.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("General")>
Public Property RenderSurface As RenderSurface
Visual Basic (Usage) Copy Code
Dim instance As ChartVisualEffectSettings
Dim value As RenderSurface

instance.RenderSurface = value

value = instance.RenderSurface
C#
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Whether or not to render the chart to a bitmap or use a double buffer window.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("General")]
public RenderSurface RenderSurface {get; set;}
Delphi
public read-write property RenderSurface: RenderSurface;
JScript
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Whether or not to render the chart to a bitmap or use a double buffer window.")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("General")
public function get,set RenderSurface : RenderSurface
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Whether or not to render the chart to a bitmap or use a double buffer window.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("General")]
public: __property RenderSurface get_RenderSurface();
public: __property void set_RenderSurface(
   RenderSurface value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Whether or not to render the chart to a bitmap or use a double buffer window.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("General")]
public:
property RenderSurface RenderSurface {
   RenderSurface get();
   void set (    RenderSurface value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartVisualEffectSettings Class
ChartVisualEffectSettings Members


ShapeRenderingMode Property

[image]
Intersoft WebGrid Documentation
ShapeRenderingMode Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartVisualEffectSettings Class : ShapeRenderingMode Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Controls the antialising (smoothing) feature of the control.")>
<System.ComponentModel.CategoryAttribute("General")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property ShapeRenderingMode As ShapeRenderingMode
Visual Basic (Usage) Copy Code
Dim instance As ChartVisualEffectSettings
Dim value As ShapeRenderingMode

instance.ShapeRenderingMode = value

value = instance.ShapeRenderingMode
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Controls the antialising (smoothing) feature of the control.")]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DefaultValueAttribute()]
public ShapeRenderingMode ShapeRenderingMode {get; set;}
Delphi
public read-write property ShapeRenderingMode: ShapeRenderingMode;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Controls the antialising (smoothing) feature of the control.")
System.ComponentModel.CategoryAttribute("General")
System.ComponentModel.DefaultValueAttribute()
public function get,set ShapeRenderingMode : ShapeRenderingMode
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Controls the antialising (smoothing) feature of the control.")]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property ShapeRenderingMode get_ShapeRenderingMode();
public: __property void set_ShapeRenderingMode(
   ShapeRenderingMode value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Controls the antialising (smoothing) feature of the control.")]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property ShapeRenderingMode ShapeRenderingMode {
   ShapeRenderingMode get();
   void set (    ShapeRenderingMode value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartVisualEffectSettings Class
ChartVisualEffectSettings Members


TextRenderingHint Property

[image]
Intersoft WebGrid Documentation
TextRenderingHint Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartVisualEffectSettings Class : TextRenderingHint Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("General")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Controls the text rendering hint (antialising) applied to text in the control.")>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property TextRenderingHint As System.Drawing.Text.TextRenderingHint
Visual Basic (Usage) Copy Code
Dim instance As ChartVisualEffectSettings
Dim value As System.Drawing.Text.TextRenderingHint

instance.TextRenderingHint = value

value = instance.TextRenderingHint
C#
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Controls the text rendering hint (antialising) applied to text in the control.")]
[ISNet.Serialization.BinarySerializableAttribute()]
public System.Drawing.Text.TextRenderingHint TextRenderingHint {get; set;}
Delphi
public read-write property TextRenderingHint: System.Drawing.Text.TextRenderingHint;
JScript
System.ComponentModel.CategoryAttribute("General")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Controls the text rendering hint (antialising) applied to text in the control.")
ISNet.Serialization.BinarySerializableAttribute()
public function get,set TextRenderingHint : System.Drawing.Text.TextRenderingHint
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Controls the text rendering hint (antialising) applied to text in the control.")]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.Drawing.Text.TextRenderingHint get_TextRenderingHint();
public: __property void set_TextRenderingHint(
   System.Drawing.Text.TextRenderingHint value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Controls the text rendering hint (antialising) applied to text in the control.")]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.Drawing.Text.TextRenderingHint TextRenderingHint {
   System.Drawing.Text.TextRenderingHint get();
   void set (    System.Drawing.Text.TextRenderingHint value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartVisualEffectSettings Class
ChartVisualEffectSettings Members


ChartWalls Class

[image]
Intersoft WebGrid Documentation
ChartWalls Class
Members See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartWalls Class

Glossary Item Box

Object Model

ChartWalls Class

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.SerializableAttribute()>
Public Class ChartWalls
   Inherits ISNet.WebUI.WebUIBaseClass
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Visual Basic (Usage) Copy Code
Dim instance As ChartWalls
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public class ChartWalls : ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Delphi
public class ChartWalls = class(ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize)
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.SerializableAttribute()
public class ChartWalls extends ISNet.WebUI.WebUIBaseClass implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public __gc class ChartWalls : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public ref class ChartWalls : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.WebGrid.Chart.ChartWalls

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartWalls Members
ISNet.WebUI.WebGrid.Chart Namespace


ChartWalls Class Members

[image]
Intersoft WebGrid Documentation
ChartWalls Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartWalls Class

Glossary Item Box

The following tables list the members exposed by ChartWalls.

Public Constructors

 | Name | Description
Public Constructor | ChartWalls Constructor |
Top

Public Properties

 | Name | Description
Public Property | Back |
Public Property | Floor |
Public Property | Left |
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

ChartWalls Class
ISNet.WebUI.WebGrid.Chart Namespace


ChartWalls Constructor

[image]
Intersoft WebGrid Documentation
ChartWalls Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartWalls Class : ChartWalls Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New ChartWalls()
C#
public ChartWalls()
Delphi
public ChartWalls();
JScript
public function ChartWalls();
Managed Extensions for C++
public: ChartWalls();
C++/CLI
public:
ChartWalls();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartWalls Class
ChartWalls Members


Clone Method

[image]
Intersoft WebGrid Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartWalls Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As System.Object
Visual Basic (Usage) Copy Code
Dim instance As ChartWalls
Dim value As System.Object

value = instance.Clone()
C#
public virtual System.object Clone()
Delphi
public function Clone(): System.TObject; virtual;
JScript
public function Clone() : System.Object;
Managed Extensions for C++
public: virtual System.Object* Clone();
C++/CLI
public:
virtual System.Object^ Clone();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartWalls Class
ChartWalls Members


CopyFrom Method

[image]
Intersoft WebGrid Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartWalls Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartWalls Class
ChartWalls Members


CopyFrom(Object) Method

[image]
Intersoft WebGrid Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartWalls Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartWalls
Dim objSource As System.Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   System.object objSource
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartWalls Class
ChartWalls Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebGrid Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartWalls Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object, _
   ByVal cloneSourceValue As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartWalls
Dim objSource As System.Object
Dim cloneSourceValue As System.Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   System.object objSource,
   System.bool cloneSourceValue
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject;
    cloneSourceValue: System.Boolean
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object,
   cloneSourceValue : System.boolean
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource,
   System.bool cloneSourceValue
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource,
   System.bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartWalls Class
ChartWalls Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebGrid Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartWalls Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartWalls
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure DeSerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function DeSerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void DeSerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void DeSerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartWalls Class
ChartWalls Members


GetHashCode Method

[image]
Intersoft WebGrid Documentation
GetHashCode Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartWalls Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As ChartWalls
Dim value As System.Integer

value = instance.GetHashCode()
C#
public virtual System.int GetHashCode()
Delphi
public function GetHashCode(): System.Integer; virtual;
JScript
public function GetHashCode() : System.int;
Managed Extensions for C++
public: virtual System.int GetHashCode();
C++/CLI
public:
virtual System.int GetHashCode();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartWalls Class
ChartWalls Members


ChartWalls Class Methods

[image]
Intersoft WebGrid Documentation
ChartWalls Class Methods
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartWalls Class

Glossary Item Box

For a list of all members of this type, see ChartWalls members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

ChartWalls Class
ISNet.WebUI.WebGrid.Chart Namespace


GetObjectData Method

[image]
Intersoft WebGrid Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartWalls Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=False,
   UnmanagedCode=False,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=True,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Action=SecurityAction.Demand,
   Unrestricted=False)>
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartWalls
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure GetObjectData(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
); override;
JScript
System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=,
   UnmanagedCode=,
   SkipVerification=,
   Execution=,
   ControlThread=,
   ControlEvidence=,
   ControlPolicy=,
   SerializationFormatter=,
   ControlDomainPolicy=,
   ControlPrincipal=,
   ControlAppDomain=,
   RemotingConfiguration=,
   Infrastructure=,
   BindingRedirects=,
   Action=SecurityAction.Demand,
   Unrestricted=)
public override function GetObjectData(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public: void GetObjectData(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
) override
C++/CLI
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public:
void GetObjectData(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
) override

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartWalls Class
ChartWalls Members


IsEmpty Method

[image]
Intersoft WebGrid Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartWalls Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As ChartWalls
Dim value As System.Boolean

value = instance.IsEmpty()
C#
public virtual System.bool IsEmpty()
Delphi
public function IsEmpty(): System.Boolean; virtual;
JScript
public function IsEmpty() : System.boolean;
Managed Extensions for C++
public: virtual System.bool IsEmpty();
C++/CLI
public:
virtual System.bool IsEmpty();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartWalls Class
ChartWalls Members


Reset Method

[image]
Intersoft WebGrid Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartWalls Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As ChartWalls

instance.Reset()
C#
public virtual void Reset()
Delphi
public procedure Reset(); virtual;
JScript
public function Reset();
Managed Extensions for C++
public: virtual void Reset();
C++/CLI
public:
virtual void Reset();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartWalls Class
ChartWalls Members


SerializeObjectData Method

[image]
Intersoft WebGrid Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartWalls Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartWalls
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure SerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function SerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void SerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void SerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartWalls Class
ChartWalls Members


ToString Method

[image]
Intersoft WebGrid Documentation
ToString Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartWalls Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As System.String
Visual Basic (Usage) Copy Code
Dim instance As ChartWalls
Dim value As System.String

value = instance.ToString()
C#
public virtual System.string ToString()
Delphi
public function ToString(): System.String; virtual;
JScript
public function ToString() : System.String;
Managed Extensions for C++
public: virtual System.string* ToString();
C++/CLI
public:
virtual System.String^ ToString();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartWalls Class
ChartWalls Members


ChartWalls Class Properties

[image]
Intersoft WebGrid Documentation
ChartWalls Class Properties
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartWalls Class

Glossary Item Box

For a list of all members of this type, see ChartWalls members.

Public Properties

 | Name | Description
Public Property | Back |
Public Property | Floor |
Public Property | Left |
Top

See Also

Reference

ChartWalls Class
ISNet.WebUI.WebGrid.Chart Namespace


ChartWalls Constructor

[image]
Intersoft WebGrid Documentation
ChartWalls Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartWalls Class : ChartWalls Constructor

Glossary Item Box

Overload List

Overload | Description
ChartWalls Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartWalls Class
ChartWalls Members


Back Property

[image]
Intersoft WebGrid Documentation
Back Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartWalls Class : Back Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<ISNet.Serialization.BinarySerializableAttribute("setBack")>
<System.ComponentModel.DescriptionAttribute("Controls chart back wall's appearance")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("General")>
Public ReadOnly Property Back As ChartWallSettings
Visual Basic (Usage) Copy Code
Dim instance As ChartWalls
Dim value As ChartWallSettings

value = instance.Back
C#
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.Serialization.BinarySerializableAttribute("setBack")]
[System.ComponentModel.DescriptionAttribute("Controls chart back wall's appearance")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
public ChartWallSettings Back {get;}
Delphi
public read-only property Back: ChartWallSettings;
JScript
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
ISNet.Serialization.BinarySerializableAttribute("setBack")
System.ComponentModel.DescriptionAttribute("Controls chart back wall's appearance")
System.ComponentModel.NotifyParentPropertyAttribute()
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("General")
public function get Back : ChartWallSettings
Managed Extensions for C++
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.Serialization.BinarySerializableAttribute("setBack")]
[System.ComponentModel.DescriptionAttribute("Controls chart back wall's appearance")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
public: __property ChartWallSettings* get_Back();
C++/CLI
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.Serialization.BinarySerializableAttribute("setBack")]
[System.ComponentModel.DescriptionAttribute("Controls chart back wall's appearance")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
public:
property ChartWallSettings^ Back {
   ChartWallSettings^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartWalls Class
ChartWalls Members


Floor Property

[image]
Intersoft WebGrid Documentation
Floor Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartWalls Class : Floor Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<System.ComponentModel.CategoryAttribute("General")>
<System.ComponentModel.DescriptionAttribute("Controls chart floor wall's appearance")>
<ISNet.Serialization.BinarySerializableAttribute("setFloor")>
<System.ComponentModel.DefaultValueAttribute()>
Public ReadOnly Property Floor As ChartWallSettings
Visual Basic (Usage) Copy Code
Dim instance As ChartWalls
Dim value As ChartWallSettings

value = instance.Floor
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DescriptionAttribute("Controls chart floor wall's appearance")]
[ISNet.Serialization.BinarySerializableAttribute("setFloor")]
[System.ComponentModel.DefaultValueAttribute()]
public ChartWallSettings Floor {get;}
Delphi
public read-only property Floor: ChartWallSettings;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
System.ComponentModel.CategoryAttribute("General")
System.ComponentModel.DescriptionAttribute("Controls chart floor wall's appearance")
ISNet.Serialization.BinarySerializableAttribute("setFloor")
System.ComponentModel.DefaultValueAttribute()
public function get Floor : ChartWallSettings
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DescriptionAttribute("Controls chart floor wall's appearance")]
[ISNet.Serialization.BinarySerializableAttribute("setFloor")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property ChartWallSettings* get_Floor();
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DescriptionAttribute("Controls chart floor wall's appearance")]
[ISNet.Serialization.BinarySerializableAttribute("setFloor")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property ChartWallSettings^ Floor {
   ChartWallSettings^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartWalls Class
ChartWalls Members


Left Property

[image]
Intersoft WebGrid Documentation
Left Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartWalls Class : Left Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute("setLeft")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<System.ComponentModel.CategoryAttribute("General")>
<System.ComponentModel.DescriptionAttribute("Controls chart left wall's appearance")>
<System.ComponentModel.DefaultValueAttribute()>
Public ReadOnly Property Left As ChartWallSettings
Visual Basic (Usage) Copy Code
Dim instance As ChartWalls
Dim value As ChartWallSettings

value = instance.Left
C#
[ISNet.Serialization.BinarySerializableAttribute("setLeft")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DescriptionAttribute("Controls chart left wall's appearance")]
[System.ComponentModel.DefaultValueAttribute()]
public ChartWallSettings Left {get;}
Delphi
public read-only property Left: ChartWallSettings;
JScript
ISNet.Serialization.BinarySerializableAttribute("setLeft")
System.ComponentModel.NotifyParentPropertyAttribute()
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
System.ComponentModel.CategoryAttribute("General")
System.ComponentModel.DescriptionAttribute("Controls chart left wall's appearance")
System.ComponentModel.DefaultValueAttribute()
public function get Left : ChartWallSettings
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute("setLeft")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DescriptionAttribute("Controls chart left wall's appearance")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property ChartWallSettings* get_Left();
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute("setLeft")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DescriptionAttribute("Controls chart left wall's appearance")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property ChartWallSettings^ Left {
   ChartWallSettings^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartWalls Class
ChartWalls Members


ChartWallSettings Class

[image]
Intersoft WebGrid Documentation
ChartWallSettings Class
Members See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartWallSettings Class

Glossary Item Box

Object Model

ChartWallSettings Class

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.SerializableAttribute()>
Public Class ChartWallSettings
   Inherits ISNet.WebUI.WebUIBaseClass
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Visual Basic (Usage) Copy Code
Dim instance As ChartWallSettings
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public class ChartWallSettings : ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Delphi
public class ChartWallSettings = class(ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize)
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.SerializableAttribute()
public class ChartWallSettings extends ISNet.WebUI.WebUIBaseClass implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public __gc class ChartWallSettings : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public ref class ChartWallSettings : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.WebGrid.Chart.ChartWallSettings

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartWallSettings Members
ISNet.WebUI.WebGrid.Chart Namespace


ChartWallSettings Class Members

[image]
Intersoft WebGrid Documentation
ChartWallSettings Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartWallSettings Class

Glossary Item Box

The following tables list the members exposed by ChartWallSettings.

Public Constructors

 | Name | Description
Public Constructor | ChartWallSettings Constructor |
Top

Public Properties

 | Name | Description
Public Property | BorderStyle |
Public Property | FillStyle |
Public Property | ShadowStyle |
Public Property | Visible |
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

ChartWallSettings Class
ISNet.WebUI.WebGrid.Chart Namespace


ChartWallSettings Constructor

[image]
Intersoft WebGrid Documentation
ChartWallSettings Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartWallSettings Class : ChartWallSettings Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New ChartWallSettings()
C#
public ChartWallSettings()
Delphi
public ChartWallSettings();
JScript
public function ChartWallSettings();
Managed Extensions for C++
public: ChartWallSettings();
C++/CLI
public:
ChartWallSettings();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartWallSettings Class
ChartWallSettings Members


Clone Method

[image]
Intersoft WebGrid Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartWallSettings Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As System.Object
Visual Basic (Usage) Copy Code
Dim instance As ChartWallSettings
Dim value As System.Object

value = instance.Clone()
C#
public virtual System.object Clone()
Delphi
public function Clone(): System.TObject; virtual;
JScript
public function Clone() : System.Object;
Managed Extensions for C++
public: virtual System.Object* Clone();
C++/CLI
public:
virtual System.Object^ Clone();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartWallSettings Class
ChartWallSettings Members


CopyFrom Method

[image]
Intersoft WebGrid Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartWallSettings Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartWallSettings Class
ChartWallSettings Members


CopyFrom(Object) Method

[image]
Intersoft WebGrid Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartWallSettings Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartWallSettings
Dim objSource As System.Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   System.object objSource
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartWallSettings Class
ChartWallSettings Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebGrid Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartWallSettings Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object, _
   ByVal cloneSourceValue As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartWallSettings
Dim objSource As System.Object
Dim cloneSourceValue As System.Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   System.object objSource,
   System.bool cloneSourceValue
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject;
    cloneSourceValue: System.Boolean
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object,
   cloneSourceValue : System.boolean
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource,
   System.bool cloneSourceValue
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource,
   System.bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartWallSettings Class
ChartWallSettings Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebGrid Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartWallSettings Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartWallSettings
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure DeSerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function DeSerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void DeSerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void DeSerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartWallSettings Class
ChartWallSettings Members


GetHashCode Method

[image]
Intersoft WebGrid Documentation
GetHashCode Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartWallSettings Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As ChartWallSettings
Dim value As System.Integer

value = instance.GetHashCode()
C#
public virtual System.int GetHashCode()
Delphi
public function GetHashCode(): System.Integer; virtual;
JScript
public function GetHashCode() : System.int;
Managed Extensions for C++
public: virtual System.int GetHashCode();
C++/CLI
public:
virtual System.int GetHashCode();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartWallSettings Class
ChartWallSettings Members


ChartWallSettings Class Methods

[image]
Intersoft WebGrid Documentation
ChartWallSettings Class Methods
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartWallSettings Class

Glossary Item Box

For a list of all members of this type, see ChartWallSettings members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

ChartWallSettings Class
ISNet.WebUI.WebGrid.Chart Namespace


GetObjectData Method

[image]
Intersoft WebGrid Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartWallSettings Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=False,
   UnmanagedCode=False,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=True,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Action=SecurityAction.Demand,
   Unrestricted=False)>
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartWallSettings
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure GetObjectData(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
); override;
JScript
System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=,
   UnmanagedCode=,
   SkipVerification=,
   Execution=,
   ControlThread=,
   ControlEvidence=,
   ControlPolicy=,
   SerializationFormatter=,
   ControlDomainPolicy=,
   ControlPrincipal=,
   ControlAppDomain=,
   RemotingConfiguration=,
   Infrastructure=,
   BindingRedirects=,
   Action=SecurityAction.Demand,
   Unrestricted=)
public override function GetObjectData(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public: void GetObjectData(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
) override
C++/CLI
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public:
void GetObjectData(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
) override

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartWallSettings Class
ChartWallSettings Members


IsEmpty Method

[image]
Intersoft WebGrid Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartWallSettings Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As ChartWallSettings
Dim value As System.Boolean

value = instance.IsEmpty()
C#
public virtual System.bool IsEmpty()
Delphi
public function IsEmpty(): System.Boolean; virtual;
JScript
public function IsEmpty() : System.boolean;
Managed Extensions for C++
public: virtual System.bool IsEmpty();
C++/CLI
public:
virtual System.bool IsEmpty();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartWallSettings Class
ChartWallSettings Members


Reset Method

[image]
Intersoft WebGrid Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartWallSettings Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As ChartWallSettings

instance.Reset()
C#
public virtual void Reset()
Delphi
public procedure Reset(); virtual;
JScript
public function Reset();
Managed Extensions for C++
public: virtual void Reset();
C++/CLI
public:
virtual void Reset();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartWallSettings Class
ChartWallSettings Members


SerializeObjectData Method

[image]
Intersoft WebGrid Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartWallSettings Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartWallSettings
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure SerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function SerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void SerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void SerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartWallSettings Class
ChartWallSettings Members


ToString Method

[image]
Intersoft WebGrid Documentation
ToString Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartWallSettings Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As System.String
Visual Basic (Usage) Copy Code
Dim instance As ChartWallSettings
Dim value As System.String

value = instance.ToString()
C#
public virtual System.string ToString()
Delphi
public function ToString(): System.String; virtual;
JScript
public function ToString() : System.String;
Managed Extensions for C++
public: virtual System.string* ToString();
C++/CLI
public:
virtual System.String^ ToString();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartWallSettings Class
ChartWallSettings Members


ChartWallSettings Class Properties

[image]
Intersoft WebGrid Documentation
ChartWallSettings Class Properties
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartWallSettings Class

Glossary Item Box

For a list of all members of this type, see ChartWallSettings members.

Public Properties

 | Name | Description
Public Property | BorderStyle |
Public Property | FillStyle |
Public Property | ShadowStyle |
Public Property | Visible |
Top

See Also

Reference

ChartWallSettings Class
ISNet.WebUI.WebGrid.Chart Namespace


ChartWallSettings Constructor

[image]
Intersoft WebGrid Documentation
ChartWallSettings Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartWallSettings Class : ChartWallSettings Constructor

Glossary Item Box

Overload List

Overload | Description
ChartWallSettings Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartWallSettings Class
ChartWallSettings Members


BorderStyle Property

[image]
Intersoft WebGrid Documentation
BorderStyle Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartWallSettings Class : BorderStyle Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute("setBorderStyle")>
<System.ComponentModel.DescriptionAttribute("Gets or sets the stroke style applied to the chart wall border")>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<System.ComponentModel.CategoryAttribute("Appearance")>
Public ReadOnly Property BorderStyle As ChartStrokeStyle
Visual Basic (Usage) Copy Code
Dim instance As ChartWallSettings
Dim value As ChartStrokeStyle

value = instance.BorderStyle
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute("setBorderStyle")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the stroke style applied to the chart wall border")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.CategoryAttribute("Appearance")]
public ChartStrokeStyle BorderStyle {get;}
Delphi
public read-only property BorderStyle: ChartStrokeStyle;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute("setBorderStyle")
System.ComponentModel.DescriptionAttribute("Gets or sets the stroke style applied to the chart wall border")
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
System.ComponentModel.CategoryAttribute("Appearance")
public function get BorderStyle : ChartStrokeStyle
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute("setBorderStyle")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the stroke style applied to the chart wall border")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.CategoryAttribute("Appearance")]
public: __property ChartStrokeStyle* get_BorderStyle();
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute("setBorderStyle")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the stroke style applied to the chart wall border")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.CategoryAttribute("Appearance")]
public:
property ChartStrokeStyle^ BorderStyle {
   ChartStrokeStyle^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartWallSettings Class
ChartWallSettings Members


FillStyle Property

[image]
Intersoft WebGrid Documentation
FillStyle Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartWallSettings Class : FillStyle Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Appearance")>
<System.ComponentModel.DescriptionAttribute("Controls the fill style applied to the chart wall")>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute("setFillStyle")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
Public ReadOnly Property FillStyle As ChartFillStyle
Visual Basic (Usage) Copy Code
Dim instance As ChartWallSettings
Dim value As ChartFillStyle

value = instance.FillStyle
C#
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.DescriptionAttribute("Controls the fill style applied to the chart wall")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute("setFillStyle")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
public ChartFillStyle FillStyle {get;}
Delphi
public read-only property FillStyle: ChartFillStyle;
JScript
System.ComponentModel.CategoryAttribute("Appearance")
System.ComponentModel.DescriptionAttribute("Controls the fill style applied to the chart wall")
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute("setFillStyle")
System.ComponentModel.NotifyParentPropertyAttribute()
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
public function get FillStyle : ChartFillStyle
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.DescriptionAttribute("Controls the fill style applied to the chart wall")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute("setFillStyle")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
public: __property ChartFillStyle* get_FillStyle();
C++/CLI
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.DescriptionAttribute("Controls the fill style applied to the chart wall")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute("setFillStyle")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
public:
property ChartFillStyle^ FillStyle {
   ChartFillStyle^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartWallSettings Class
ChartWallSettings Members


ShadowStyle Property

[image]
Intersoft WebGrid Documentation
ShadowStyle Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartWallSettings Class : ShadowStyle Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<ISNet.Serialization.BinarySerializableAttribute("setShadowStyle")>
<System.ComponentModel.DescriptionAttribute("Controls the shadow of the wall.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<System.ComponentModel.CategoryAttribute("Appearance")>
Public ReadOnly Property ShadowStyle As ChartShadowStyle
Visual Basic (Usage) Copy Code
Dim instance As ChartWallSettings
Dim value As ChartShadowStyle

value = instance.ShadowStyle
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[ISNet.Serialization.BinarySerializableAttribute("setShadowStyle")]
[System.ComponentModel.DescriptionAttribute("Controls the shadow of the wall.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.CategoryAttribute("Appearance")]
public ChartShadowStyle ShadowStyle {get;}
Delphi
public read-only property ShadowStyle: ChartShadowStyle;
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
ISNet.Serialization.BinarySerializableAttribute("setShadowStyle")
System.ComponentModel.DescriptionAttribute("Controls the shadow of the wall.")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
System.ComponentModel.CategoryAttribute("Appearance")
public function get ShadowStyle : ChartShadowStyle
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[ISNet.Serialization.BinarySerializableAttribute("setShadowStyle")]
[System.ComponentModel.DescriptionAttribute("Controls the shadow of the wall.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.CategoryAttribute("Appearance")]
public: __property ChartShadowStyle* get_ShadowStyle();
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[ISNet.Serialization.BinarySerializableAttribute("setShadowStyle")]
[System.ComponentModel.DescriptionAttribute("Controls the shadow of the wall.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.CategoryAttribute("Appearance")]
public:
property ChartShadowStyle^ ShadowStyle {
   ChartShadowStyle^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartWallSettings Class
ChartWallSettings Members


Visible Property

[image]
Intersoft WebGrid Documentation
Visible Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartWallSettings Class : Visible Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Controls the visibility of the chat wall")>
<System.ComponentModel.CategoryAttribute("General")>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property Visible As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As ChartWallSettings
Dim value As System.Boolean

instance.Visible = value

value = instance.Visible
C#
[System.ComponentModel.DescriptionAttribute("Controls the visibility of the chat wall")]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.bool Visible {get; set;}
Delphi
public read-write property Visible: System.Boolean;
JScript
System.ComponentModel.DescriptionAttribute("Controls the visibility of the chat wall")
System.ComponentModel.CategoryAttribute("General")
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set Visible : System.boolean
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Controls the visibility of the chat wall")]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.bool get_Visible();
public: __property void set_Visible(
   System.bool value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Controls the visibility of the chat wall")]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.bool Visible {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartWallSettings Class
ChartWallSettings Members


ChartXAxisSettings Class

[image]
Intersoft WebGrid Documentation
ChartXAxisSettings Class
Members See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartXAxisSettings Class

Glossary Item Box

Object Model

ChartXAxisSettings Class

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.SerializableAttribute()>
Public Class ChartXAxisSettings
   Inherits ChartAxisSettings
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Visual Basic (Usage) Copy Code
Dim instance As ChartXAxisSettings
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public class ChartXAxisSettings : ChartAxisSettings, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Delphi
public class ChartXAxisSettings = class(ChartAxisSettings, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize)
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.SerializableAttribute()
public class ChartXAxisSettings extends ChartAxisSettings implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public __gc class ChartXAxisSettings : public ChartAxisSettings, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public ref class ChartXAxisSettings : public ChartAxisSettings, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.WebGrid.Chart.ChartAxisSettings
ISNet.WebUI.WebGrid.Chart.ChartXAxisSettings

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartXAxisSettings Members
ISNet.WebUI.WebGrid.Chart Namespace


ChartXAxisSettings Class Members

[image]
Intersoft WebGrid Documentation
ChartXAxisSettings Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartXAxisSettings Class

Glossary Item Box

The following tables list the members exposed by ChartXAxisSettings.

Public Constructors

 | Name | Description
Public Constructor | ChartXAxisSettings Constructor |
Top

Public Properties

 | Name | Description
Public Property | AutoLabels |
Public Property | AutoMinorTicks | (Inherited from ISNet.WebUI.WebGrid.Chart.ChartAxisSettings)
Public Property | Invert | (Inherited from ISNet.WebUI.WebGrid.Chart.ChartAxisSettings)
Public Property | LabelGenerationMode | (Inherited from ISNet.WebUI.WebGrid.Chart.ChartAxisSettings)
Public Property | LabelStyle | (Inherited from ISNet.WebUI.WebGrid.Chart.ChartAxisSettings)
Public Property | MajorGridStyle | (Inherited from ISNet.WebUI.WebGrid.Chart.ChartAxisSettings)
Public Property | MinorGridStyle | (Inherited from ISNet.WebUI.WebGrid.Chart.ChartAxisSettings)
Public Property | MinorTickCount | (Inherited from ISNet.WebUI.WebGrid.Chart.ChartAxisSettings)
Public Property | NumberOfTicksPerLabel | (Inherited from ISNet.WebUI.WebGrid.Chart.ChartAxisSettings)
Public Property | StripStyles | (Inherited from ISNet.WebUI.WebGrid.Chart.ChartAxisSettings)
Public Property | Title | (Inherited from ISNet.WebUI.WebGrid.Chart.ChartAxisSettings)
Public Property | Visible | (Inherited from ISNet.WebUI.WebGrid.Chart.ChartAxisSettings)
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

ChartXAxisSettings Class
ISNet.WebUI.WebGrid.Chart Namespace


ChartXAxisSettings Constructor

[image]
Intersoft WebGrid Documentation
ChartXAxisSettings Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartXAxisSettings Class : ChartXAxisSettings Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New ChartXAxisSettings()
C#
public ChartXAxisSettings()
Delphi
public ChartXAxisSettings();
JScript
public function ChartXAxisSettings();
Managed Extensions for C++
public: ChartXAxisSettings();
C++/CLI
public:
ChartXAxisSettings();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartXAxisSettings Class
ChartXAxisSettings Members


Clone Method

[image]
Intersoft WebGrid Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartXAxisSettings Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As System.Object
Visual Basic (Usage) Copy Code
Dim instance As ChartXAxisSettings
Dim value As System.Object

value = instance.Clone()
C#
public virtual System.object Clone()
Delphi
public function Clone(): System.TObject; virtual;
JScript
public function Clone() : System.Object;
Managed Extensions for C++
public: virtual System.Object* Clone();
C++/CLI
public:
virtual System.Object^ Clone();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartXAxisSettings Class
ChartXAxisSettings Members


CopyFrom Method

[image]
Intersoft WebGrid Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartXAxisSettings Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartXAxisSettings Class
ChartXAxisSettings Members


CopyFrom(Object) Method

[image]
Intersoft WebGrid Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartXAxisSettings Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartXAxisSettings
Dim objSource As System.Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   System.object objSource
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartXAxisSettings Class
ChartXAxisSettings Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebGrid Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartXAxisSettings Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object, _
   ByVal cloneSourceValue As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartXAxisSettings
Dim objSource As System.Object
Dim cloneSourceValue As System.Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   System.object objSource,
   System.bool cloneSourceValue
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject;
    cloneSourceValue: System.Boolean
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object,
   cloneSourceValue : System.boolean
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource,
   System.bool cloneSourceValue
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource,
   System.bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartXAxisSettings Class
ChartXAxisSettings Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebGrid Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartXAxisSettings Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartXAxisSettings
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure DeSerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function DeSerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void DeSerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void DeSerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartXAxisSettings Class
ChartXAxisSettings Members


GetHashCode Method

[image]
Intersoft WebGrid Documentation
GetHashCode Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartXAxisSettings Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As ChartXAxisSettings
Dim value As System.Integer

value = instance.GetHashCode()
C#
public virtual System.int GetHashCode()
Delphi
public function GetHashCode(): System.Integer; virtual;
JScript
public function GetHashCode() : System.int;
Managed Extensions for C++
public: virtual System.int GetHashCode();
C++/CLI
public:
virtual System.int GetHashCode();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartXAxisSettings Class
ChartXAxisSettings Members


ChartXAxisSettings Class Methods

[image]
Intersoft WebGrid Documentation
ChartXAxisSettings Class Methods
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartXAxisSettings Class

Glossary Item Box

For a list of all members of this type, see ChartXAxisSettings members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

ChartXAxisSettings Class
ISNet.WebUI.WebGrid.Chart Namespace


GetObjectData Method

[image]
Intersoft WebGrid Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartXAxisSettings Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=False,
   UnmanagedCode=False,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=True,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Action=SecurityAction.Demand,
   Unrestricted=False)>
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartXAxisSettings
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure GetObjectData(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
); override;
JScript
System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=,
   UnmanagedCode=,
   SkipVerification=,
   Execution=,
   ControlThread=,
   ControlEvidence=,
   ControlPolicy=,
   SerializationFormatter=,
   ControlDomainPolicy=,
   ControlPrincipal=,
   ControlAppDomain=,
   RemotingConfiguration=,
   Infrastructure=,
   BindingRedirects=,
   Action=SecurityAction.Demand,
   Unrestricted=)
public override function GetObjectData(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public: void GetObjectData(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
) override
C++/CLI
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public:
void GetObjectData(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
) override

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartXAxisSettings Class
ChartXAxisSettings Members


IsEmpty Method

[image]
Intersoft WebGrid Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartXAxisSettings Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As ChartXAxisSettings
Dim value As System.Boolean

value = instance.IsEmpty()
C#
public virtual System.bool IsEmpty()
Delphi
public function IsEmpty(): System.Boolean; virtual;
JScript
public function IsEmpty() : System.boolean;
Managed Extensions for C++
public: virtual System.bool IsEmpty();
C++/CLI
public:
virtual System.bool IsEmpty();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartXAxisSettings Class
ChartXAxisSettings Members


Reset Method

[image]
Intersoft WebGrid Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartXAxisSettings Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As ChartXAxisSettings

instance.Reset()
C#
public virtual void Reset()
Delphi
public procedure Reset(); virtual;
JScript
public function Reset();
Managed Extensions for C++
public: virtual void Reset();
C++/CLI
public:
virtual void Reset();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartXAxisSettings Class
ChartXAxisSettings Members


SerializeObjectData Method

[image]
Intersoft WebGrid Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartXAxisSettings Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartXAxisSettings
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure SerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function SerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void SerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void SerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartXAxisSettings Class
ChartXAxisSettings Members


ToString Method

[image]
Intersoft WebGrid Documentation
ToString Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartXAxisSettings Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As System.String
Visual Basic (Usage) Copy Code
Dim instance As ChartXAxisSettings
Dim value As System.String

value = instance.ToString()
C#
public virtual System.string ToString()
Delphi
public function ToString(): System.String; virtual;
JScript
public function ToString() : System.String;
Managed Extensions for C++
public: virtual System.string* ToString();
C++/CLI
public:
virtual System.String^ ToString();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartXAxisSettings Class
ChartXAxisSettings Members


ChartXAxisSettings Class Properties

[image]
Intersoft WebGrid Documentation
ChartXAxisSettings Class Properties
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartXAxisSettings Class

Glossary Item Box

For a list of all members of this type, see ChartXAxisSettings members.

Public Properties

 | Name | Description
Public Property | AutoLabels |
Public Property | AutoMinorTicks | (Inherited from ISNet.WebUI.WebGrid.Chart.ChartAxisSettings)
Public Property | Invert | (Inherited from ISNet.WebUI.WebGrid.Chart.ChartAxisSettings)
Public Property | LabelGenerationMode | (Inherited from ISNet.WebUI.WebGrid.Chart.ChartAxisSettings)
Public Property | LabelStyle | (Inherited from ISNet.WebUI.WebGrid.Chart.ChartAxisSettings)
Public Property | MajorGridStyle | (Inherited from ISNet.WebUI.WebGrid.Chart.ChartAxisSettings)
Public Property | MinorGridStyle | (Inherited from ISNet.WebUI.WebGrid.Chart.ChartAxisSettings)
Public Property | MinorTickCount | (Inherited from ISNet.WebUI.WebGrid.Chart.ChartAxisSettings)
Public Property | NumberOfTicksPerLabel | (Inherited from ISNet.WebUI.WebGrid.Chart.ChartAxisSettings)
Public Property | StripStyles | (Inherited from ISNet.WebUI.WebGrid.Chart.ChartAxisSettings)
Public Property | Title | (Inherited from ISNet.WebUI.WebGrid.Chart.ChartAxisSettings)
Public Property | Visible | (Inherited from ISNet.WebUI.WebGrid.Chart.ChartAxisSettings)
Top

See Also

Reference

ChartXAxisSettings Class
ISNet.WebUI.WebGrid.Chart Namespace


ChartXAxisSettings Constructor

[image]
Intersoft WebGrid Documentation
ChartXAxisSettings Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartXAxisSettings Class : ChartXAxisSettings Constructor

Glossary Item Box

Overload List

Overload | Description
ChartXAxisSettings Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartXAxisSettings Class
ChartXAxisSettings Members


AutoLabels Property

[image]
Intersoft WebGrid Documentation
AutoLabels Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartXAxisSettings Class : AutoLabels Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("When set to false labels are extracted from the Labels collection of the axis. When set to true labels are automatically generated from this axis scale (if it is the active one)")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Labels")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Shadows Property AutoLabels As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As ChartXAxisSettings
Dim value As System.Boolean

instance.AutoLabels = value

value = instance.AutoLabels
C#
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("When set to false labels are extracted from the Labels collection of the axis. When set to true labels are automatically generated from this axis scale (if it is the active one)")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Labels")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public new System.bool AutoLabels {get; set;}
Delphi
public read-write property AutoLabels: System.Boolean;
JScript
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("When set to false labels are extracted from the Labels collection of the axis. When set to true labels are automatically generated from this axis scale (if it is the active one)")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Labels")
System.ComponentModel.NotifyParentPropertyAttribute()
public hide function get,set AutoLabels : System.boolean
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("When set to false labels are extracted from the Labels collection of the axis. When set to true labels are automatically generated from this axis scale (if it is the active one)")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Labels")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property new System.bool get_AutoLabels();
public: __property new void set_AutoLabels(
   System.bool value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("When set to false labels are extracted from the Labels collection of the axis. When set to true labels are automatically generated from this axis scale (if it is the active one)")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Labels")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
new property System.bool AutoLabels {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartXAxisSettings Class
ChartXAxisSettings Members


ChartYAxisSettings Class

[image]
Intersoft WebGrid Documentation
ChartYAxisSettings Class
Members See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartYAxisSettings Class

Glossary Item Box

Object Model

ChartYAxisSettings Class

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.SerializableAttribute()>
Public Class ChartYAxisSettings
   Inherits ChartAxisSettings
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Visual Basic (Usage) Copy Code
Dim instance As ChartYAxisSettings
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public class ChartYAxisSettings : ChartAxisSettings, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Delphi
public class ChartYAxisSettings = class(ChartAxisSettings, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize)
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.SerializableAttribute()
public class ChartYAxisSettings extends ChartAxisSettings implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public __gc class ChartYAxisSettings : public ChartAxisSettings, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public ref class ChartYAxisSettings : public ChartAxisSettings, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.WebGrid.Chart.ChartAxisSettings
ISNet.WebUI.WebGrid.Chart.ChartYAxisSettings

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartYAxisSettings Members
ISNet.WebUI.WebGrid.Chart Namespace


ChartYAxisSettings Class Members

[image]
Intersoft WebGrid Documentation
ChartYAxisSettings Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartYAxisSettings Class

Glossary Item Box

The following tables list the members exposed by ChartYAxisSettings.

Public Constructors

 | Name | Description
Public Constructor | ChartYAxisSettings Constructor |
Top

Public Properties

 | Name | Description
Public Property | AutoLabels | (Inherited from ISNet.WebUI.WebGrid.Chart.ChartAxisSettings)
Public Property | AutoMinorTicks | (Inherited from ISNet.WebUI.WebGrid.Chart.ChartAxisSettings)
Public Property | Invert | (Inherited from ISNet.WebUI.WebGrid.Chart.ChartAxisSettings)
Public Property | LabelGenerationMode | (Inherited from ISNet.WebUI.WebGrid.Chart.ChartAxisSettings)
Public Property | LabelStyle | (Inherited from ISNet.WebUI.WebGrid.Chart.ChartAxisSettings)
Public Property | MajorGridStyle | (Inherited from ISNet.WebUI.WebGrid.Chart.ChartAxisSettings)
Public Property | MinorGridStyle | (Inherited from ISNet.WebUI.WebGrid.Chart.ChartAxisSettings)
Public Property | MinorTickCount |
Public Property | NumberOfTicksPerLabel | (Inherited from ISNet.WebUI.WebGrid.Chart.ChartAxisSettings)
Public Property | StripStyles | (Inherited from ISNet.WebUI.WebGrid.Chart.ChartAxisSettings)
Public Property | Title | (Inherited from ISNet.WebUI.WebGrid.Chart.ChartAxisSettings)
Public Property | Visible | (Inherited from ISNet.WebUI.WebGrid.Chart.ChartAxisSettings)
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

ChartYAxisSettings Class
ISNet.WebUI.WebGrid.Chart Namespace


ChartYAxisSettings Constructor

[image]
Intersoft WebGrid Documentation
ChartYAxisSettings Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartYAxisSettings Class : ChartYAxisSettings Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New ChartYAxisSettings()
C#
public ChartYAxisSettings()
Delphi
public ChartYAxisSettings();
JScript
public function ChartYAxisSettings();
Managed Extensions for C++
public: ChartYAxisSettings();
C++/CLI
public:
ChartYAxisSettings();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartYAxisSettings Class
ChartYAxisSettings Members


Clone Method

[image]
Intersoft WebGrid Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartYAxisSettings Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As System.Object
Visual Basic (Usage) Copy Code
Dim instance As ChartYAxisSettings
Dim value As System.Object

value = instance.Clone()
C#
public virtual System.object Clone()
Delphi
public function Clone(): System.TObject; virtual;
JScript
public function Clone() : System.Object;
Managed Extensions for C++
public: virtual System.Object* Clone();
C++/CLI
public:
virtual System.Object^ Clone();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartYAxisSettings Class
ChartYAxisSettings Members


CopyFrom Method

[image]
Intersoft WebGrid Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartYAxisSettings Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartYAxisSettings Class
ChartYAxisSettings Members


CopyFrom(Object) Method

[image]
Intersoft WebGrid Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartYAxisSettings Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartYAxisSettings
Dim objSource As System.Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   System.object objSource
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartYAxisSettings Class
ChartYAxisSettings Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebGrid Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartYAxisSettings Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object, _
   ByVal cloneSourceValue As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartYAxisSettings
Dim objSource As System.Object
Dim cloneSourceValue As System.Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   System.object objSource,
   System.bool cloneSourceValue
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject;
    cloneSourceValue: System.Boolean
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object,
   cloneSourceValue : System.boolean
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource,
   System.bool cloneSourceValue
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource,
   System.bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartYAxisSettings Class
ChartYAxisSettings Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebGrid Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartYAxisSettings Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartYAxisSettings
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure DeSerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function DeSerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void DeSerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void DeSerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartYAxisSettings Class
ChartYAxisSettings Members


GetHashCode Method

[image]
Intersoft WebGrid Documentation
GetHashCode Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartYAxisSettings Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As ChartYAxisSettings
Dim value As System.Integer

value = instance.GetHashCode()
C#
public virtual System.int GetHashCode()
Delphi
public function GetHashCode(): System.Integer; virtual;
JScript
public function GetHashCode() : System.int;
Managed Extensions for C++
public: virtual System.int GetHashCode();
C++/CLI
public:
virtual System.int GetHashCode();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartYAxisSettings Class
ChartYAxisSettings Members


ChartYAxisSettings Class Methods

[image]
Intersoft WebGrid Documentation
ChartYAxisSettings Class Methods
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartYAxisSettings Class

Glossary Item Box

For a list of all members of this type, see ChartYAxisSettings members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

ChartYAxisSettings Class
ISNet.WebUI.WebGrid.Chart Namespace


GetObjectData Method

[image]
Intersoft WebGrid Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartYAxisSettings Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=False,
   UnmanagedCode=False,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=True,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Action=SecurityAction.Demand,
   Unrestricted=False)>
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartYAxisSettings
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure GetObjectData(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
); override;
JScript
System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=,
   UnmanagedCode=,
   SkipVerification=,
   Execution=,
   ControlThread=,
   ControlEvidence=,
   ControlPolicy=,
   SerializationFormatter=,
   ControlDomainPolicy=,
   ControlPrincipal=,
   ControlAppDomain=,
   RemotingConfiguration=,
   Infrastructure=,
   BindingRedirects=,
   Action=SecurityAction.Demand,
   Unrestricted=)
public override function GetObjectData(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public: void GetObjectData(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
) override
C++/CLI
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public:
void GetObjectData(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
) override

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartYAxisSettings Class
ChartYAxisSettings Members


IsEmpty Method

[image]
Intersoft WebGrid Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartYAxisSettings Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As ChartYAxisSettings
Dim value As System.Boolean

value = instance.IsEmpty()
C#
public virtual System.bool IsEmpty()
Delphi
public function IsEmpty(): System.Boolean; virtual;
JScript
public function IsEmpty() : System.boolean;
Managed Extensions for C++
public: virtual System.bool IsEmpty();
C++/CLI
public:
virtual System.bool IsEmpty();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartYAxisSettings Class
ChartYAxisSettings Members


Reset Method

[image]
Intersoft WebGrid Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartYAxisSettings Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As ChartYAxisSettings

instance.Reset()
C#
public virtual void Reset()
Delphi
public procedure Reset(); virtual;
JScript
public function Reset();
Managed Extensions for C++
public: virtual void Reset();
C++/CLI
public:
virtual void Reset();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartYAxisSettings Class
ChartYAxisSettings Members


SerializeObjectData Method

[image]
Intersoft WebGrid Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartYAxisSettings Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartYAxisSettings
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure SerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function SerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void SerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void SerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartYAxisSettings Class
ChartYAxisSettings Members


ToString Method

[image]
Intersoft WebGrid Documentation
ToString Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartYAxisSettings Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As System.String
Visual Basic (Usage) Copy Code
Dim instance As ChartYAxisSettings
Dim value As System.String

value = instance.ToString()
C#
public virtual System.string ToString()
Delphi
public function ToString(): System.String; virtual;
JScript
public function ToString() : System.String;
Managed Extensions for C++
public: virtual System.string* ToString();
C++/CLI
public:
virtual System.String^ ToString();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartYAxisSettings Class
ChartYAxisSettings Members


ChartYAxisSettings Class Properties

[image]
Intersoft WebGrid Documentation
ChartYAxisSettings Class Properties
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartYAxisSettings Class

Glossary Item Box

For a list of all members of this type, see ChartYAxisSettings members.

Public Properties

 | Name | Description
Public Property | AutoLabels | (Inherited from ISNet.WebUI.WebGrid.Chart.ChartAxisSettings)
Public Property | AutoMinorTicks | (Inherited from ISNet.WebUI.WebGrid.Chart.ChartAxisSettings)
Public Property | Invert | (Inherited from ISNet.WebUI.WebGrid.Chart.ChartAxisSettings)
Public Property | LabelGenerationMode | (Inherited from ISNet.WebUI.WebGrid.Chart.ChartAxisSettings)
Public Property | LabelStyle | (Inherited from ISNet.WebUI.WebGrid.Chart.ChartAxisSettings)
Public Property | MajorGridStyle | (Inherited from ISNet.WebUI.WebGrid.Chart.ChartAxisSettings)
Public Property | MinorGridStyle | (Inherited from ISNet.WebUI.WebGrid.Chart.ChartAxisSettings)
Public Property | MinorTickCount |
Public Property | NumberOfTicksPerLabel | (Inherited from ISNet.WebUI.WebGrid.Chart.ChartAxisSettings)
Public Property | StripStyles | (Inherited from ISNet.WebUI.WebGrid.Chart.ChartAxisSettings)
Public Property | Title | (Inherited from ISNet.WebUI.WebGrid.Chart.ChartAxisSettings)
Public Property | Visible | (Inherited from ISNet.WebUI.WebGrid.Chart.ChartAxisSettings)
Top

See Also

Reference

ChartYAxisSettings Class
ISNet.WebUI.WebGrid.Chart Namespace


ChartYAxisSettings Constructor

[image]
Intersoft WebGrid Documentation
ChartYAxisSettings Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartYAxisSettings Class : ChartYAxisSettings Constructor

Glossary Item Box

Overload List

Overload | Description
ChartYAxisSettings Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartYAxisSettings Class
ChartYAxisSettings Members


MinorTickCount Property

[image]
Intersoft WebGrid Documentation
MinorTickCount Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartYAxisSettings Class : MinorTickCount Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Ticks")>
<System.ComponentModel.DescriptionAttribute("Controls the count of the automatic minor ticks between two major ticks")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Shadows Property MinorTickCount As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As ChartYAxisSettings
Dim value As System.Integer

instance.MinorTickCount = value

value = instance.MinorTickCount
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Ticks")]
[System.ComponentModel.DescriptionAttribute("Controls the count of the automatic minor ticks between two major ticks")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public new System.int MinorTickCount {get; set;}
Delphi
public read-write property MinorTickCount: System.Integer;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Ticks")
System.ComponentModel.DescriptionAttribute("Controls the count of the automatic minor ticks between two major ticks")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
public hide function get,set MinorTickCount : System.int
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Ticks")]
[System.ComponentModel.DescriptionAttribute("Controls the count of the automatic minor ticks between two major ticks")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property new System.int get_MinorTickCount();
public: __property new void set_MinorTickCount(
   System.int value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Ticks")]
[System.ComponentModel.DescriptionAttribute("Controls the count of the automatic minor ticks between two major ticks")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
new property System.int MinorTickCount {
   System.int get();
   void set (    System.int value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartYAxisSettings Class
ChartYAxisSettings Members


ChartZAxisSettings Class

[image]
Intersoft WebGrid Documentation
ChartZAxisSettings Class
Members See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartZAxisSettings Class

Glossary Item Box

Object Model

ChartZAxisSettings Class

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.SerializableAttribute()>
Public Class ChartZAxisSettings
   Inherits ChartAxisSettings
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Visual Basic (Usage) Copy Code
Dim instance As ChartZAxisSettings
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public class ChartZAxisSettings : ChartAxisSettings, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Delphi
public class ChartZAxisSettings = class(ChartAxisSettings, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize)
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.SerializableAttribute()
public class ChartZAxisSettings extends ChartAxisSettings implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public __gc class ChartZAxisSettings : public ChartAxisSettings, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public ref class ChartZAxisSettings : public ChartAxisSettings, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.WebGrid.Chart.ChartAxisSettings
ISNet.WebUI.WebGrid.Chart.ChartZAxisSettings

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartZAxisSettings Members
ISNet.WebUI.WebGrid.Chart Namespace


ChartZAxisSettings Class Members

[image]
Intersoft WebGrid Documentation
ChartZAxisSettings Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartZAxisSettings Class

Glossary Item Box

The following tables list the members exposed by ChartZAxisSettings.

Public Constructors

 | Name | Description
Public Constructor | ChartZAxisSettings Constructor |
Top

Public Properties

 | Name | Description
Public Property | AutoLabels |
Public Property | AutoMinorTicks | (Inherited from ISNet.WebUI.WebGrid.Chart.ChartAxisSettings)
Public Property | Invert | (Inherited from ISNet.WebUI.WebGrid.Chart.ChartAxisSettings)
Public Property | LabelGenerationMode | (Inherited from ISNet.WebUI.WebGrid.Chart.ChartAxisSettings)
Public Property | LabelStyle | (Inherited from ISNet.WebUI.WebGrid.Chart.ChartAxisSettings)
Public Property | MajorGridStyle | (Inherited from ISNet.WebUI.WebGrid.Chart.ChartAxisSettings)
Public Property | MinorGridStyle | (Inherited from ISNet.WebUI.WebGrid.Chart.ChartAxisSettings)
Public Property | MinorTickCount | (Inherited from ISNet.WebUI.WebGrid.Chart.ChartAxisSettings)
Public Property | NumberOfTicksPerLabel | (Inherited from ISNet.WebUI.WebGrid.Chart.ChartAxisSettings)
Public Property | StripStyles | (Inherited from ISNet.WebUI.WebGrid.Chart.ChartAxisSettings)
Public Property | Title | (Inherited from ISNet.WebUI.WebGrid.Chart.ChartAxisSettings)
Public Property | Visible | (Inherited from ISNet.WebUI.WebGrid.Chart.ChartAxisSettings)
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

ChartZAxisSettings Class
ISNet.WebUI.WebGrid.Chart Namespace


ChartZAxisSettings Constructor

[image]
Intersoft WebGrid Documentation
ChartZAxisSettings Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartZAxisSettings Class : ChartZAxisSettings Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New ChartZAxisSettings()
C#
public ChartZAxisSettings()
Delphi
public ChartZAxisSettings();
JScript
public function ChartZAxisSettings();
Managed Extensions for C++
public: ChartZAxisSettings();
C++/CLI
public:
ChartZAxisSettings();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartZAxisSettings Class
ChartZAxisSettings Members


Clone Method

[image]
Intersoft WebGrid Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartZAxisSettings Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As System.Object
Visual Basic (Usage) Copy Code
Dim instance As ChartZAxisSettings
Dim value As System.Object

value = instance.Clone()
C#
public virtual System.object Clone()
Delphi
public function Clone(): System.TObject; virtual;
JScript
public function Clone() : System.Object;
Managed Extensions for C++
public: virtual System.Object* Clone();
C++/CLI
public:
virtual System.Object^ Clone();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartZAxisSettings Class
ChartZAxisSettings Members


CopyFrom Method

[image]
Intersoft WebGrid Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartZAxisSettings Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartZAxisSettings Class
ChartZAxisSettings Members


CopyFrom(Object) Method

[image]
Intersoft WebGrid Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartZAxisSettings Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartZAxisSettings
Dim objSource As System.Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   System.object objSource
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartZAxisSettings Class
ChartZAxisSettings Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebGrid Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartZAxisSettings Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object, _
   ByVal cloneSourceValue As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartZAxisSettings
Dim objSource As System.Object
Dim cloneSourceValue As System.Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   System.object objSource,
   System.bool cloneSourceValue
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject;
    cloneSourceValue: System.Boolean
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object,
   cloneSourceValue : System.boolean
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource,
   System.bool cloneSourceValue
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource,
   System.bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartZAxisSettings Class
ChartZAxisSettings Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebGrid Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartZAxisSettings Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartZAxisSettings
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure DeSerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function DeSerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void DeSerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void DeSerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartZAxisSettings Class
ChartZAxisSettings Members


GetHashCode Method

[image]
Intersoft WebGrid Documentation
GetHashCode Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartZAxisSettings Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As ChartZAxisSettings
Dim value As System.Integer

value = instance.GetHashCode()
C#
public virtual System.int GetHashCode()
Delphi
public function GetHashCode(): System.Integer; virtual;
JScript
public function GetHashCode() : System.int;
Managed Extensions for C++
public: virtual System.int GetHashCode();
C++/CLI
public:
virtual System.int GetHashCode();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartZAxisSettings Class
ChartZAxisSettings Members


ChartZAxisSettings Class Methods

[image]
Intersoft WebGrid Documentation
ChartZAxisSettings Class Methods
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartZAxisSettings Class

Glossary Item Box

For a list of all members of this type, see ChartZAxisSettings members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

ChartZAxisSettings Class
ISNet.WebUI.WebGrid.Chart Namespace


GetObjectData Method

[image]
Intersoft WebGrid Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartZAxisSettings Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=False,
   UnmanagedCode=False,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=True,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Action=SecurityAction.Demand,
   Unrestricted=False)>
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartZAxisSettings
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure GetObjectData(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
); override;
JScript
System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=,
   UnmanagedCode=,
   SkipVerification=,
   Execution=,
   ControlThread=,
   ControlEvidence=,
   ControlPolicy=,
   SerializationFormatter=,
   ControlDomainPolicy=,
   ControlPrincipal=,
   ControlAppDomain=,
   RemotingConfiguration=,
   Infrastructure=,
   BindingRedirects=,
   Action=SecurityAction.Demand,
   Unrestricted=)
public override function GetObjectData(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public: void GetObjectData(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
) override
C++/CLI
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public:
void GetObjectData(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
) override

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartZAxisSettings Class
ChartZAxisSettings Members


IsEmpty Method

[image]
Intersoft WebGrid Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartZAxisSettings Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As ChartZAxisSettings
Dim value As System.Boolean

value = instance.IsEmpty()
C#
public virtual System.bool IsEmpty()
Delphi
public function IsEmpty(): System.Boolean; virtual;
JScript
public function IsEmpty() : System.boolean;
Managed Extensions for C++
public: virtual System.bool IsEmpty();
C++/CLI
public:
virtual System.bool IsEmpty();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartZAxisSettings Class
ChartZAxisSettings Members


Reset Method

[image]
Intersoft WebGrid Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartZAxisSettings Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As ChartZAxisSettings

instance.Reset()
C#
public virtual void Reset()
Delphi
public procedure Reset(); virtual;
JScript
public function Reset();
Managed Extensions for C++
public: virtual void Reset();
C++/CLI
public:
virtual void Reset();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartZAxisSettings Class
ChartZAxisSettings Members


SerializeObjectData Method

[image]
Intersoft WebGrid Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartZAxisSettings Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartZAxisSettings
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure SerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function SerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void SerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void SerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartZAxisSettings Class
ChartZAxisSettings Members


ToString Method

[image]
Intersoft WebGrid Documentation
ToString Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartZAxisSettings Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As System.String
Visual Basic (Usage) Copy Code
Dim instance As ChartZAxisSettings
Dim value As System.String

value = instance.ToString()
C#
public virtual System.string ToString()
Delphi
public function ToString(): System.String; virtual;
JScript
public function ToString() : System.String;
Managed Extensions for C++
public: virtual System.string* ToString();
C++/CLI
public:
virtual System.String^ ToString();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartZAxisSettings Class
ChartZAxisSettings Members


ChartZAxisSettings Class Properties

[image]
Intersoft WebGrid Documentation
ChartZAxisSettings Class Properties
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartZAxisSettings Class

Glossary Item Box

For a list of all members of this type, see ChartZAxisSettings members.

Public Properties

 | Name | Description
Public Property | AutoLabels |
Public Property | AutoMinorTicks | (Inherited from ISNet.WebUI.WebGrid.Chart.ChartAxisSettings)
Public Property | Invert | (Inherited from ISNet.WebUI.WebGrid.Chart.ChartAxisSettings)
Public Property | LabelGenerationMode | (Inherited from ISNet.WebUI.WebGrid.Chart.ChartAxisSettings)
Public Property | LabelStyle | (Inherited from ISNet.WebUI.WebGrid.Chart.ChartAxisSettings)
Public Property | MajorGridStyle | (Inherited from ISNet.WebUI.WebGrid.Chart.ChartAxisSettings)
Public Property | MinorGridStyle | (Inherited from ISNet.WebUI.WebGrid.Chart.ChartAxisSettings)
Public Property | MinorTickCount | (Inherited from ISNet.WebUI.WebGrid.Chart.ChartAxisSettings)
Public Property | NumberOfTicksPerLabel | (Inherited from ISNet.WebUI.WebGrid.Chart.ChartAxisSettings)
Public Property | StripStyles | (Inherited from ISNet.WebUI.WebGrid.Chart.ChartAxisSettings)
Public Property | Title | (Inherited from ISNet.WebUI.WebGrid.Chart.ChartAxisSettings)
Public Property | Visible | (Inherited from ISNet.WebUI.WebGrid.Chart.ChartAxisSettings)
Top

See Also

Reference

ChartZAxisSettings Class
ISNet.WebUI.WebGrid.Chart Namespace


ChartZAxisSettings Constructor

[image]
Intersoft WebGrid Documentation
ChartZAxisSettings Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartZAxisSettings Class : ChartZAxisSettings Constructor

Glossary Item Box

Overload List

Overload | Description
ChartZAxisSettings Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartZAxisSettings Class
ChartZAxisSettings Members


AutoLabels Property

[image]
Intersoft WebGrid Documentation
AutoLabels Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > ChartZAxisSettings Class : AutoLabels Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Labels")>
<System.ComponentModel.DescriptionAttribute("When set to false labels are extracted from the Labels collection of the axis. When set to true labels are automatically generated from this axis scale (if it is the active one)")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Shadows Property AutoLabels As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As ChartZAxisSettings
Dim value As System.Boolean

instance.AutoLabels = value

value = instance.AutoLabels
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Labels")]
[System.ComponentModel.DescriptionAttribute("When set to false labels are extracted from the Labels collection of the axis. When set to true labels are automatically generated from this axis scale (if it is the active one)")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public new System.bool AutoLabels {get; set;}
Delphi
public read-write property AutoLabels: System.Boolean;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Labels")
System.ComponentModel.DescriptionAttribute("When set to false labels are extracted from the Labels collection of the axis. When set to true labels are automatically generated from this axis scale (if it is the active one)")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
public hide function get,set AutoLabels : System.boolean
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Labels")]
[System.ComponentModel.DescriptionAttribute("When set to false labels are extracted from the Labels collection of the axis. When set to true labels are automatically generated from this axis scale (if it is the active one)")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property new System.bool get_AutoLabels();
public: __property new void set_AutoLabels(
   System.bool value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Labels")]
[System.ComponentModel.DescriptionAttribute("When set to false labels are extracted from the Labels collection of the axis. When set to true labels are automatically generated from this axis scale (if it is the active one)")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
new property System.bool AutoLabels {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartZAxisSettings Class
ChartZAxisSettings Members


Series Class

[image]
Intersoft WebGrid Documentation
Series Class
Members See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : Series Class

Glossary Item Box

Object Model

Series Class

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.SerializableAttribute()>
Public Class Series
   Inherits SeriesBase
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Visual Basic (Usage) Copy Code
Dim instance As Series
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public class Series : SeriesBase, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Delphi
public class Series = class(SeriesBase, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize)
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.SerializableAttribute()
public class Series extends SeriesBase implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public __gc class Series : public SeriesBase, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public ref class Series : public SeriesBase, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.WebGrid.Chart.SeriesBase
ISNet.WebUI.WebGrid.Chart.Series
ISNet.WebUI.WebGrid.Chart.SeriesPie
ISNet.WebUI.WebGrid.Chart.SeriesPolar
ISNet.WebUI.WebGrid.Chart.SeriesRadar
ISNet.WebUI.WebGrid.Chart.SeriesXYScatter

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Series Members
ISNet.WebUI.WebGrid.Chart Namespace


Series Class Members

[image]
Intersoft WebGrid Documentation
Series Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : Series Class

Glossary Item Box

The following tables list the members exposed by Series.

Public Constructors

 | Name | Description
Public Constructor | Series Constructor |
Top

Public Properties

 | Name | Description
Public Property | BevelAndEmbossImageFilter |
Public Property | BlurImageFilter |
Public Property | BorderStyle |
Public Property | ChartFillType |
Public Property | DataLabelStyle |
Public Property | EmptyDataPointStyle |
Public Property | GlowImageFilter |
Public Property | InteractiveStyle |
Public Property | LightingImageFilter |
Public Property | SeriesLegend | (Inherited from ISNet.WebUI.WebGrid.Chart.SeriesBase)
Public Property | ShadowStyle | (Inherited from ISNet.WebUI.WebGrid.Chart.SeriesBase)
Public Property | Visible | (Inherited from ISNet.WebUI.WebGrid.Chart.SeriesBase)
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

Series Class
ISNet.WebUI.WebGrid.Chart Namespace


Series Constructor

[image]
Intersoft WebGrid Documentation
Series Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > Series Class : Series Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New Series()
C#
public Series()
Delphi
public Series();
JScript
public function Series();
Managed Extensions for C++
public: Series();
C++/CLI
public:
Series();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Series Class
Series Members


Clone Method

[image]
Intersoft WebGrid Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > Series Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As System.Object
Visual Basic (Usage) Copy Code
Dim instance As Series
Dim value As System.Object

value = instance.Clone()
C#
public virtual System.object Clone()
Delphi
public function Clone(): System.TObject; virtual;
JScript
public function Clone() : System.Object;
Managed Extensions for C++
public: virtual System.Object* Clone();
C++/CLI
public:
virtual System.Object^ Clone();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Series Class
Series Members


CopyFrom Method

[image]
Intersoft WebGrid Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > Series Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Series Class
Series Members


CopyFrom(Object) Method

[image]
Intersoft WebGrid Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > Series Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As Series
Dim objSource As System.Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   System.object objSource
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Series Class
Series Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebGrid Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > Series Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object, _
   ByVal cloneSourceValue As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As Series
Dim objSource As System.Object
Dim cloneSourceValue As System.Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   System.object objSource,
   System.bool cloneSourceValue
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject;
    cloneSourceValue: System.Boolean
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object,
   cloneSourceValue : System.boolean
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource,
   System.bool cloneSourceValue
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource,
   System.bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Series Class
Series Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebGrid Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > Series Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As Series
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure DeSerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function DeSerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void DeSerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void DeSerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Series Class
Series Members


GetHashCode Method

[image]
Intersoft WebGrid Documentation
GetHashCode Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > Series Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As Series
Dim value As System.Integer

value = instance.GetHashCode()
C#
public virtual System.int GetHashCode()
Delphi
public function GetHashCode(): System.Integer; virtual;
JScript
public function GetHashCode() : System.int;
Managed Extensions for C++
public: virtual System.int GetHashCode();
C++/CLI
public:
virtual System.int GetHashCode();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Series Class
Series Members


Series Class Methods

[image]
Intersoft WebGrid Documentation
Series Class Methods
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : Series Class

Glossary Item Box

For a list of all members of this type, see Series members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

Series Class
ISNet.WebUI.WebGrid.Chart Namespace


GetObjectData Method

[image]
Intersoft WebGrid Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > Series Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=False,
   UnmanagedCode=False,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=True,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Action=SecurityAction.Demand,
   Unrestricted=False)>
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As Series
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure GetObjectData(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
); override;
JScript
System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=,
   UnmanagedCode=,
   SkipVerification=,
   Execution=,
   ControlThread=,
   ControlEvidence=,
   ControlPolicy=,
   SerializationFormatter=,
   ControlDomainPolicy=,
   ControlPrincipal=,
   ControlAppDomain=,
   RemotingConfiguration=,
   Infrastructure=,
   BindingRedirects=,
   Action=SecurityAction.Demand,
   Unrestricted=)
public override function GetObjectData(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public: void GetObjectData(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
) override
C++/CLI
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public:
void GetObjectData(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
) override

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Series Class
Series Members


IsEmpty Method

[image]
Intersoft WebGrid Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > Series Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As Series
Dim value As System.Boolean

value = instance.IsEmpty()
C#
public virtual System.bool IsEmpty()
Delphi
public function IsEmpty(): System.Boolean; virtual;
JScript
public function IsEmpty() : System.boolean;
Managed Extensions for C++
public: virtual System.bool IsEmpty();
C++/CLI
public:
virtual System.bool IsEmpty();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Series Class
Series Members


Reset Method

[image]
Intersoft WebGrid Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > Series Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As Series

instance.Reset()
C#
public virtual void Reset()
Delphi
public procedure Reset(); virtual;
JScript
public function Reset();
Managed Extensions for C++
public: virtual void Reset();
C++/CLI
public:
virtual void Reset();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Series Class
Series Members


SerializeObjectData Method

[image]
Intersoft WebGrid Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > Series Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As Series
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure SerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function SerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void SerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void SerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Series Class
Series Members


ToString Method

[image]
Intersoft WebGrid Documentation
ToString Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > Series Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As System.String
Visual Basic (Usage) Copy Code
Dim instance As Series
Dim value As System.String

value = instance.ToString()
C#
public virtual System.string ToString()
Delphi
public function ToString(): System.String; virtual;
JScript
public function ToString() : System.String;
Managed Extensions for C++
public: virtual System.string* ToString();
C++/CLI
public:
virtual System.String^ ToString();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Series Class
Series Members


Series Class Properties

[image]
Intersoft WebGrid Documentation
Series Class Properties
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : Series Class

Glossary Item Box

For a list of all members of this type, see Series members.

Public Properties

 | Name | Description
Public Property | BevelAndEmbossImageFilter |
Public Property | BlurImageFilter |
Public Property | BorderStyle |
Public Property | ChartFillType |
Public Property | DataLabelStyle |
Public Property | EmptyDataPointStyle |
Public Property | GlowImageFilter |
Public Property | InteractiveStyle |
Public Property | LightingImageFilter |
Public Property | SeriesLegend | (Inherited from ISNet.WebUI.WebGrid.Chart.SeriesBase)
Public Property | ShadowStyle | (Inherited from ISNet.WebUI.WebGrid.Chart.SeriesBase)
Public Property | Visible | (Inherited from ISNet.WebUI.WebGrid.Chart.SeriesBase)
Top

See Also

Reference

Series Class
ISNet.WebUI.WebGrid.Chart Namespace


Series Constructor

[image]
Intersoft WebGrid Documentation
Series Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > Series Class : Series Constructor

Glossary Item Box

Overload List

Overload | Description
Series Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Series Class
Series Members


BevelAndEmbossImageFilter Property

[image]
Intersoft WebGrid Documentation
BevelAndEmbossImageFilter Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > Series Class : BevelAndEmbossImageFilter Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute("setBevelAndEmbossImageFilter")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<System.ComponentModel.CategoryAttribute("Styles")>
<System.ComponentModel.DescriptionAttribute("Controls the bevel and emboss visual effect.")>
Public ReadOnly Property BevelAndEmbossImageFilter As ChartBevelAndEmbossImageFilterSettings
Visual Basic (Usage) Copy Code
Dim instance As Series
Dim value As ChartBevelAndEmbossImageFilterSettings

value = instance.BevelAndEmbossImageFilter
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute("setBevelAndEmbossImageFilter")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.CategoryAttribute("Styles")]
[System.ComponentModel.DescriptionAttribute("Controls the bevel and emboss visual effect.")]
public ChartBevelAndEmbossImageFilterSettings BevelAndEmbossImageFilter {get;}
Delphi
public read-only property BevelAndEmbossImageFilter: ChartBevelAndEmbossImageFilterSettings;
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute("setBevelAndEmbossImageFilter")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
System.ComponentModel.CategoryAttribute("Styles")
System.ComponentModel.DescriptionAttribute("Controls the bevel and emboss visual effect.")
public function get BevelAndEmbossImageFilter : ChartBevelAndEmbossImageFilterSettings
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute("setBevelAndEmbossImageFilter")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.CategoryAttribute("Styles")]
[System.ComponentModel.DescriptionAttribute("Controls the bevel and emboss visual effect.")]
public: __property ChartBevelAndEmbossImageFilterSettings* get_BevelAndEmbossImageFilter();
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute("setBevelAndEmbossImageFilter")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.CategoryAttribute("Styles")]
[System.ComponentModel.DescriptionAttribute("Controls the bevel and emboss visual effect.")]
public:
property ChartBevelAndEmbossImageFilterSettings^ BevelAndEmbossImageFilter {
   ChartBevelAndEmbossImageFilterSettings^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Series Class
Series Members


BlurImageFilter Property

[image]
Intersoft WebGrid Documentation
BlurImageFilter Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > Series Class : BlurImageFilter Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Controls the blur visual effect.")>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute("setBlurImageFilter")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<System.ComponentModel.CategoryAttribute("Styles")>
Public ReadOnly Property BlurImageFilter As ChartBlurImageFilterSettings
Visual Basic (Usage) Copy Code
Dim instance As Series
Dim value As ChartBlurImageFilterSettings

value = instance.BlurImageFilter
C#
[System.ComponentModel.DescriptionAttribute("Controls the blur visual effect.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute("setBlurImageFilter")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.CategoryAttribute("Styles")]
public ChartBlurImageFilterSettings BlurImageFilter {get;}
Delphi
public read-only property BlurImageFilter: ChartBlurImageFilterSettings;
JScript
System.ComponentModel.DescriptionAttribute("Controls the blur visual effect.")
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute("setBlurImageFilter")
System.ComponentModel.NotifyParentPropertyAttribute()
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
System.ComponentModel.CategoryAttribute("Styles")
public function get BlurImageFilter : ChartBlurImageFilterSettings
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Controls the blur visual effect.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute("setBlurImageFilter")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.CategoryAttribute("Styles")]
public: __property ChartBlurImageFilterSettings* get_BlurImageFilter();
C++/CLI
[System.ComponentModel.DescriptionAttribute("Controls the blur visual effect.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute("setBlurImageFilter")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.CategoryAttribute("Styles")]
public:
property ChartBlurImageFilterSettings^ BlurImageFilter {
   ChartBlurImageFilterSettings^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Series Class
Series Members


BorderStyle Property

[image]
Intersoft WebGrid Documentation
BorderStyle Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > Series Class : BorderStyle Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Styles")>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Controls the border style of the series.")>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<ISNet.Serialization.BinarySerializableAttribute("setBorderStyle")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public ReadOnly Property BorderStyle As ChartStrokeStyle
Visual Basic (Usage) Copy Code
Dim instance As Series
Dim value As ChartStrokeStyle

value = instance.BorderStyle
C#
[System.ComponentModel.CategoryAttribute("Styles")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Controls the border style of the series.")]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.Serialization.BinarySerializableAttribute("setBorderStyle")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public ChartStrokeStyle BorderStyle {get;}
Delphi
public read-only property BorderStyle: ChartStrokeStyle;
JScript
System.ComponentModel.CategoryAttribute("Styles")
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Controls the border style of the series.")
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
ISNet.Serialization.BinarySerializableAttribute("setBorderStyle")
System.ComponentModel.NotifyParentPropertyAttribute()
public function get BorderStyle : ChartStrokeStyle
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Styles")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Controls the border style of the series.")]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.Serialization.BinarySerializableAttribute("setBorderStyle")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property ChartStrokeStyle* get_BorderStyle();
C++/CLI
[System.ComponentModel.CategoryAttribute("Styles")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Controls the border style of the series.")]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.Serialization.BinarySerializableAttribute("setBorderStyle")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property ChartStrokeStyle^ BorderStyle {
   ChartStrokeStyle^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Series Class
Series Members


ChartFillType Property

[image]
Intersoft WebGrid Documentation
ChartFillType Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > Series Class : ChartFillType Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Defines the type of Fill Style to be applied to the series object.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Styles")>
Public Property ChartFillType As ChartFillType
Visual Basic (Usage) Copy Code
Dim instance As Series
Dim value As ChartFillType

instance.ChartFillType = value

value = instance.ChartFillType
C#
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Defines the type of Fill Style to be applied to the series object.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Styles")]
public ChartFillType ChartFillType {get; set;}
Delphi
public read-write property ChartFillType: ChartFillType;
JScript
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Defines the type of Fill Style to be applied to the series object.")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Styles")
public function get,set ChartFillType : ChartFillType
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Defines the type of Fill Style to be applied to the series object.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Styles")]
public: __property ChartFillType get_ChartFillType();
public: __property void set_ChartFillType(
   ChartFillType value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Defines the type of Fill Style to be applied to the series object.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Styles")]
public:
property ChartFillType ChartFillType {
   ChartFillType get();
   void set (    ChartFillType value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Series Class
Series Members


DataLabelStyle Property

[image]
Intersoft WebGrid Documentation
DataLabelStyle Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > Series Class : DataLabelStyle Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<System.ComponentModel.CategoryAttribute("Styles")>
<System.ComponentModel.DescriptionAttribute("Controls the appearance of the data point labels.")>
<ISNet.Serialization.BinarySerializableAttribute("setDataLabelStyle")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
Public ReadOnly Property DataLabelStyle As ChartDataLabelStyle
Visual Basic (Usage) Copy Code
Dim instance As Series
Dim value As ChartDataLabelStyle

value = instance.DataLabelStyle
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.CategoryAttribute("Styles")]
[System.ComponentModel.DescriptionAttribute("Controls the appearance of the data point labels.")]
[ISNet.Serialization.BinarySerializableAttribute("setDataLabelStyle")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public ChartDataLabelStyle DataLabelStyle {get;}
Delphi
public read-only property DataLabelStyle: ChartDataLabelStyle;
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
System.ComponentModel.CategoryAttribute("Styles")
System.ComponentModel.DescriptionAttribute("Controls the appearance of the data point labels.")
ISNet.Serialization.BinarySerializableAttribute("setDataLabelStyle")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
public function get DataLabelStyle : ChartDataLabelStyle
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.CategoryAttribute("Styles")]
[System.ComponentModel.DescriptionAttribute("Controls the appearance of the data point labels.")]
[ISNet.Serialization.BinarySerializableAttribute("setDataLabelStyle")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public: __property ChartDataLabelStyle* get_DataLabelStyle();
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.CategoryAttribute("Styles")]
[System.ComponentModel.DescriptionAttribute("Controls the appearance of the data point labels.")]
[ISNet.Serialization.BinarySerializableAttribute("setDataLabelStyle")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public:
property ChartDataLabelStyle^ DataLabelStyle {
   ChartDataLabelStyle^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Series Class
Series Members


EmptyDataPointStyle Property

[image]
Intersoft WebGrid Documentation
EmptyDataPointStyle Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > Series Class : EmptyDataPointStyle Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Controls the appearance of the empty data points.")>
<ISNet.Serialization.BinarySerializableAttribute("setEmptyDataPointStyle")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<System.ComponentModel.CategoryAttribute("Styles")>
Public ReadOnly Property EmptyDataPointStyle As ChartEmptyDataPointsStyle
Visual Basic (Usage) Copy Code
Dim instance As Series
Dim value As ChartEmptyDataPointsStyle

value = instance.EmptyDataPointStyle
C#
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Controls the appearance of the empty data points.")]
[ISNet.Serialization.BinarySerializableAttribute("setEmptyDataPointStyle")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.CategoryAttribute("Styles")]
public ChartEmptyDataPointsStyle EmptyDataPointStyle {get;}
Delphi
public read-only property EmptyDataPointStyle: ChartEmptyDataPointsStyle;
JScript
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Controls the appearance of the empty data points.")
ISNet.Serialization.BinarySerializableAttribute("setEmptyDataPointStyle")
System.ComponentModel.NotifyParentPropertyAttribute()
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
System.ComponentModel.CategoryAttribute("Styles")
public function get EmptyDataPointStyle : ChartEmptyDataPointsStyle
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Controls the appearance of the empty data points.")]
[ISNet.Serialization.BinarySerializableAttribute("setEmptyDataPointStyle")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.CategoryAttribute("Styles")]
public: __property ChartEmptyDataPointsStyle* get_EmptyDataPointStyle();
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Controls the appearance of the empty data points.")]
[ISNet.Serialization.BinarySerializableAttribute("setEmptyDataPointStyle")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.CategoryAttribute("Styles")]
public:
property ChartEmptyDataPointsStyle^ EmptyDataPointStyle {
   ChartEmptyDataPointsStyle^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Series Class
Series Members


GlowImageFilter Property

[image]
Intersoft WebGrid Documentation
GlowImageFilter Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > Series Class : GlowImageFilter Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute("setGlowImageFilter")>
<System.ComponentModel.DescriptionAttribute("Controls the glow visual effect.")>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<System.ComponentModel.CategoryAttribute("Styles")>
Public ReadOnly Property GlowImageFilter As ChartGlowImageFilterSettings
Visual Basic (Usage) Copy Code
Dim instance As Series
Dim value As ChartGlowImageFilterSettings

value = instance.GlowImageFilter
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute("setGlowImageFilter")]
[System.ComponentModel.DescriptionAttribute("Controls the glow visual effect.")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.CategoryAttribute("Styles")]
public ChartGlowImageFilterSettings GlowImageFilter {get;}
Delphi
public read-only property GlowImageFilter: ChartGlowImageFilterSettings;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute("setGlowImageFilter")
System.ComponentModel.DescriptionAttribute("Controls the glow visual effect.")
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
System.ComponentModel.CategoryAttribute("Styles")
public function get GlowImageFilter : ChartGlowImageFilterSettings
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute("setGlowImageFilter")]
[System.ComponentModel.DescriptionAttribute("Controls the glow visual effect.")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.CategoryAttribute("Styles")]
public: __property ChartGlowImageFilterSettings* get_GlowImageFilter();
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute("setGlowImageFilter")]
[System.ComponentModel.DescriptionAttribute("Controls the glow visual effect.")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.CategoryAttribute("Styles")]
public:
property ChartGlowImageFilterSettings^ GlowImageFilter {
   ChartGlowImageFilterSettings^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Series Class
Series Members


InteractiveStyle Property

[image]
Intersoft WebGrid Documentation
InteractiveStyle Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > Series Class : InteractiveStyle Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute("setInteractiveStyle")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("Styles")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<System.ComponentModel.DescriptionAttribute("Controls the properties related to the interactivity behavior of the object it is attached to.")>
Public ReadOnly Property InteractiveStyle As ChartInteractiveStyle
Visual Basic (Usage) Copy Code
Dim instance As Series
Dim value As ChartInteractiveStyle

value = instance.InteractiveStyle
C#
[ISNet.Serialization.BinarySerializableAttribute("setInteractiveStyle")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Styles")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DescriptionAttribute("Controls the properties related to the interactivity behavior of the object it is attached to.")]
public ChartInteractiveStyle InteractiveStyle {get;}
Delphi
public read-only property InteractiveStyle: ChartInteractiveStyle;
JScript
ISNet.Serialization.BinarySerializableAttribute("setInteractiveStyle")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("Styles")
System.ComponentModel.NotifyParentPropertyAttribute()
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
System.ComponentModel.DescriptionAttribute("Controls the properties related to the interactivity behavior of the object it is attached to.")
public function get InteractiveStyle : ChartInteractiveStyle
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute("setInteractiveStyle")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Styles")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DescriptionAttribute("Controls the properties related to the interactivity behavior of the object it is attached to.")]
public: __property ChartInteractiveStyle* get_InteractiveStyle();
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute("setInteractiveStyle")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Styles")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DescriptionAttribute("Controls the properties related to the interactivity behavior of the object it is attached to.")]
public:
property ChartInteractiveStyle^ InteractiveStyle {
   ChartInteractiveStyle^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Series Class
Series Members


LightingImageFilter Property

[image]
Intersoft WebGrid Documentation
LightingImageFilter Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > Series Class : LightingImageFilter Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Controls the lighting visual effect.")>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute("setLightingImageFilter")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<System.ComponentModel.CategoryAttribute("Styles")>
Public ReadOnly Property LightingImageFilter As ChartLightingImageFilterSettings
Visual Basic (Usage) Copy Code
Dim instance As Series
Dim value As ChartLightingImageFilterSettings

value = instance.LightingImageFilter
C#
[System.ComponentModel.DescriptionAttribute("Controls the lighting visual effect.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute("setLightingImageFilter")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.CategoryAttribute("Styles")]
public ChartLightingImageFilterSettings LightingImageFilter {get;}
Delphi
public read-only property LightingImageFilter: ChartLightingImageFilterSettings;
JScript
System.ComponentModel.DescriptionAttribute("Controls the lighting visual effect.")
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute("setLightingImageFilter")
System.ComponentModel.NotifyParentPropertyAttribute()
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
System.ComponentModel.CategoryAttribute("Styles")
public function get LightingImageFilter : ChartLightingImageFilterSettings
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Controls the lighting visual effect.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute("setLightingImageFilter")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.CategoryAttribute("Styles")]
public: __property ChartLightingImageFilterSettings* get_LightingImageFilter();
C++/CLI
[System.ComponentModel.DescriptionAttribute("Controls the lighting visual effect.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute("setLightingImageFilter")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.CategoryAttribute("Styles")]
public:
property ChartLightingImageFilterSettings^ LightingImageFilter {
   ChartLightingImageFilterSettings^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Series Class
Series Members


SeriesArea Class

[image]
Intersoft WebGrid Documentation
SeriesArea Class
Members See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : SeriesArea Class

Glossary Item Box

Object Model

SeriesArea Class

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.SerializableAttribute()>
Public Class SeriesArea
   Inherits SeriesXYScatter
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Visual Basic (Usage) Copy Code
Dim instance As SeriesArea
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public class SeriesArea : SeriesXYScatter, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Delphi
public class SeriesArea = class(SeriesXYScatter, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize)
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.SerializableAttribute()
public class SeriesArea extends SeriesXYScatter implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public __gc class SeriesArea : public SeriesXYScatter, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public ref class SeriesArea : public SeriesXYScatter, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.WebGrid.Chart.SeriesBase
ISNet.WebUI.WebGrid.Chart.Series
ISNet.WebUI.WebGrid.Chart.SeriesXYScatter
ISNet.WebUI.WebGrid.Chart.SeriesArea

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesArea Members
ISNet.WebUI.WebGrid.Chart Namespace


SeriesArea Class Members

[image]
Intersoft WebGrid Documentation
SeriesArea Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : SeriesArea Class

Glossary Item Box

The following tables list the members exposed by SeriesArea.

Public Constructors

 | Name | Description
Public Constructor | SeriesArea Constructor |
Top

Public Properties

 | Name | Description
Public Property | BevelAndEmbossImageFilter | (Inherited from ISNet.WebUI.WebGrid.Chart.Series)
Public Property | BlurImageFilter | (Inherited from ISNet.WebUI.WebGrid.Chart.Series)
Public Property | BorderStyle | (Inherited from ISNet.WebUI.WebGrid.Chart.Series)
Public Property | ChartFillType | (Inherited from ISNet.WebUI.WebGrid.Chart.Series)
Public Property | DataLabelStyle | (Inherited from ISNet.WebUI.WebGrid.Chart.Series)
Public Property | DepthPercent |
Public Property | DropLines |
Public Property | EmptyDataPointStyle | (Inherited from ISNet.WebUI.WebGrid.Chart.Series)
Public Property | GlowImageFilter | (Inherited from ISNet.WebUI.WebGrid.Chart.Series)
Public Property | InteractiveStyle | (Inherited from ISNet.WebUI.WebGrid.Chart.Series)
Public Property | LightingImageFilter | (Inherited from ISNet.WebUI.WebGrid.Chart.Series)
Public Property | Origin |
Public Property | SeriesLegend | (Inherited from ISNet.WebUI.WebGrid.Chart.SeriesBase)
Public Property | ShadowStyle | (Inherited from ISNet.WebUI.WebGrid.Chart.SeriesBase)
Public Property | UseOrigin |
Public Property | Visible | (Inherited from ISNet.WebUI.WebGrid.Chart.SeriesBase)
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

SeriesArea Class
ISNet.WebUI.WebGrid.Chart Namespace


SeriesArea Constructor

[image]
Intersoft WebGrid Documentation
SeriesArea Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > SeriesArea Class : SeriesArea Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New SeriesArea()
C#
public SeriesArea()
Delphi
public SeriesArea();
JScript
public function SeriesArea();
Managed Extensions for C++
public: SeriesArea();
C++/CLI
public:
SeriesArea();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesArea Class
SeriesArea Members


Clone Method

[image]
Intersoft WebGrid Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > SeriesArea Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As System.Object
Visual Basic (Usage) Copy Code
Dim instance As SeriesArea
Dim value As System.Object

value = instance.Clone()
C#
public virtual System.object Clone()
Delphi
public function Clone(): System.TObject; virtual;
JScript
public function Clone() : System.Object;
Managed Extensions for C++
public: virtual System.Object* Clone();
C++/CLI
public:
virtual System.Object^ Clone();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesArea Class
SeriesArea Members


CopyFrom Method

[image]
Intersoft WebGrid Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > SeriesArea Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesArea Class
SeriesArea Members


CopyFrom(Object) Method

[image]
Intersoft WebGrid Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > SeriesArea Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As SeriesArea
Dim objSource As System.Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   System.object objSource
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesArea Class
SeriesArea Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebGrid Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > SeriesArea Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object, _
   ByVal cloneSourceValue As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As SeriesArea
Dim objSource As System.Object
Dim cloneSourceValue As System.Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   System.object objSource,
   System.bool cloneSourceValue
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject;
    cloneSourceValue: System.Boolean
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object,
   cloneSourceValue : System.boolean
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource,
   System.bool cloneSourceValue
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource,
   System.bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesArea Class
SeriesArea Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebGrid Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > SeriesArea Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As SeriesArea
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure DeSerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function DeSerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void DeSerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void DeSerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesArea Class
SeriesArea Members


GetHashCode Method

[image]
Intersoft WebGrid Documentation
GetHashCode Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > SeriesArea Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As SeriesArea
Dim value As System.Integer

value = instance.GetHashCode()
C#
public virtual System.int GetHashCode()
Delphi
public function GetHashCode(): System.Integer; virtual;
JScript
public function GetHashCode() : System.int;
Managed Extensions for C++
public: virtual System.int GetHashCode();
C++/CLI
public:
virtual System.int GetHashCode();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesArea Class
SeriesArea Members


SeriesArea Class Methods

[image]
Intersoft WebGrid Documentation
SeriesArea Class Methods
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : SeriesArea Class

Glossary Item Box

For a list of all members of this type, see SeriesArea members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

SeriesArea Class
ISNet.WebUI.WebGrid.Chart Namespace


GetObjectData Method

[image]
Intersoft WebGrid Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > SeriesArea Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=False,
   UnmanagedCode=False,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=True,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Action=SecurityAction.Demand,
   Unrestricted=False)>
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As SeriesArea
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure GetObjectData(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
); override;
JScript
System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=,
   UnmanagedCode=,
   SkipVerification=,
   Execution=,
   ControlThread=,
   ControlEvidence=,
   ControlPolicy=,
   SerializationFormatter=,
   ControlDomainPolicy=,
   ControlPrincipal=,
   ControlAppDomain=,
   RemotingConfiguration=,
   Infrastructure=,
   BindingRedirects=,
   Action=SecurityAction.Demand,
   Unrestricted=)
public override function GetObjectData(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public: void GetObjectData(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
) override
C++/CLI
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public:
void GetObjectData(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
) override

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesArea Class
SeriesArea Members


IsEmpty Method

[image]
Intersoft WebGrid Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > SeriesArea Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As SeriesArea
Dim value As System.Boolean

value = instance.IsEmpty()
C#
public virtual System.bool IsEmpty()
Delphi
public function IsEmpty(): System.Boolean; virtual;
JScript
public function IsEmpty() : System.boolean;
Managed Extensions for C++
public: virtual System.bool IsEmpty();
C++/CLI
public:
virtual System.bool IsEmpty();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesArea Class
SeriesArea Members


Reset Method

[image]
Intersoft WebGrid Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > SeriesArea Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As SeriesArea

instance.Reset()
C#
public virtual void Reset()
Delphi
public procedure Reset(); virtual;
JScript
public function Reset();
Managed Extensions for C++
public: virtual void Reset();
C++/CLI
public:
virtual void Reset();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesArea Class
SeriesArea Members


SerializeObjectData Method

[image]
Intersoft WebGrid Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > SeriesArea Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As SeriesArea
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure SerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function SerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void SerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void SerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesArea Class
SeriesArea Members


ToString Method

[image]
Intersoft WebGrid Documentation
ToString Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > SeriesArea Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As System.String
Visual Basic (Usage) Copy Code
Dim instance As SeriesArea
Dim value As System.String

value = instance.ToString()
C#
public virtual System.string ToString()
Delphi
public function ToString(): System.String; virtual;
JScript
public function ToString() : System.String;
Managed Extensions for C++
public: virtual System.string* ToString();
C++/CLI
public:
virtual System.String^ ToString();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesArea Class
SeriesArea Members


SeriesArea Class Properties

[image]
Intersoft WebGrid Documentation
SeriesArea Class Properties
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : SeriesArea Class

Glossary Item Box

For a list of all members of this type, see SeriesArea members.

Public Properties

 | Name | Description
Public Property | BevelAndEmbossImageFilter | (Inherited from ISNet.WebUI.WebGrid.Chart.Series)
Public Property | BlurImageFilter | (Inherited from ISNet.WebUI.WebGrid.Chart.Series)
Public Property | BorderStyle | (Inherited from ISNet.WebUI.WebGrid.Chart.Series)
Public Property | ChartFillType | (Inherited from ISNet.WebUI.WebGrid.Chart.Series)
Public Property | DataLabelStyle | (Inherited from ISNet.WebUI.WebGrid.Chart.Series)
Public Property | DepthPercent |
Public Property | DropLines |
Public Property | EmptyDataPointStyle | (Inherited from ISNet.WebUI.WebGrid.Chart.Series)
Public Property | GlowImageFilter | (Inherited from ISNet.WebUI.WebGrid.Chart.Series)
Public Property | InteractiveStyle | (Inherited from ISNet.WebUI.WebGrid.Chart.Series)
Public Property | LightingImageFilter | (Inherited from ISNet.WebUI.WebGrid.Chart.Series)
Public Property | Origin |
Public Property | SeriesLegend | (Inherited from ISNet.WebUI.WebGrid.Chart.SeriesBase)
Public Property | ShadowStyle | (Inherited from ISNet.WebUI.WebGrid.Chart.SeriesBase)
Public Property | UseOrigin |
Public Property | Visible | (Inherited from ISNet.WebUI.WebGrid.Chart.SeriesBase)
Top

See Also

Reference

SeriesArea Class
ISNet.WebUI.WebGrid.Chart Namespace


SeriesArea Constructor

[image]
Intersoft WebGrid Documentation
SeriesArea Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > SeriesArea Class : SeriesArea Constructor

Glossary Item Box

Overload List

Overload | Description
SeriesArea Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesArea Class
SeriesArea Members


DepthPercent Property

[image]
Intersoft WebGrid Documentation
DepthPercent Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > SeriesArea Class : DepthPercent Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Controls the depth of area in percents of the floor grid cell depth.")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Options")>
Public Property DepthPercent As System.Single
Visual Basic (Usage) Copy Code
Dim instance As SeriesArea
Dim value As System.Single

instance.DepthPercent = value

value = instance.DepthPercent
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Controls the depth of area in percents of the floor grid cell depth.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Options")]
public System.float DepthPercent {get; set;}
Delphi
public read-write property DepthPercent: System.Single;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DescriptionAttribute("Controls the depth of area in percents of the floor grid cell depth.")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Options")
public function get,set DepthPercent : System.float
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Controls the depth of area in percents of the floor grid cell depth.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Options")]
public: __property System.float get_DepthPercent();
public: __property void set_DepthPercent(
   System.float value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Controls the depth of area in percents of the floor grid cell depth.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Options")]
public:
property System.float DepthPercent {
   System.float get();
   void set (    System.float value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesArea Class
SeriesArea Members


DropLines Property

[image]
Intersoft WebGrid Documentation
DropLines Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > SeriesArea Class : DropLines Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Controls the visibility of the area segment separation lines.")>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Options")>
Public Property DropLines As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As SeriesArea
Dim value As System.Boolean

instance.DropLines = value

value = instance.DropLines
C#
[System.ComponentModel.DescriptionAttribute("Controls the visibility of the area segment separation lines.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Options")]
public System.bool DropLines {get; set;}
Delphi
public read-write property DropLines: System.Boolean;
JScript
System.ComponentModel.DescriptionAttribute("Controls the visibility of the area segment separation lines.")
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Options")
public function get,set DropLines : System.boolean
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Controls the visibility of the area segment separation lines.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Options")]
public: __property System.bool get_DropLines();
public: __property void set_DropLines(
   System.bool value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Controls the visibility of the area segment separation lines.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Options")]
public:
property System.bool DropLines {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesArea Class
SeriesArea Members


Origin Property

[image]
Intersoft WebGrid Documentation
Origin Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > SeriesArea Class : Origin Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Options")>
<System.ComponentModel.DescriptionAttribute("Specifies the custom area origin.")>
Public Property Origin As System.Single
Visual Basic (Usage) Copy Code
Dim instance As SeriesArea
Dim value As System.Single

instance.Origin = value

value = instance.Origin
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Options")]
[System.ComponentModel.DescriptionAttribute("Specifies the custom area origin.")]
public System.float Origin {get; set;}
Delphi
public read-write property Origin: System.Single;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Options")
System.ComponentModel.DescriptionAttribute("Specifies the custom area origin.")
public function get,set Origin : System.float
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Options")]
[System.ComponentModel.DescriptionAttribute("Specifies the custom area origin.")]
public: __property System.float get_Origin();
public: __property void set_Origin(
   System.float value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Options")]
[System.ComponentModel.DescriptionAttribute("Specifies the custom area origin.")]
public:
property System.float Origin {
   System.float get();
   void set (    System.float value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesArea Class
SeriesArea Members


UseOrigin Property

[image]
Intersoft WebGrid Documentation
UseOrigin Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > SeriesArea Class : UseOrigin Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies whether a custom area origin must be used.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Options")>
Public Property UseOrigin As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As SeriesArea
Dim value As System.Boolean

instance.UseOrigin = value

value = instance.UseOrigin
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether a custom area origin must be used.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Options")]
public System.bool UseOrigin {get; set;}
Delphi
public read-write property UseOrigin: System.Boolean;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Specifies whether a custom area origin must be used.")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Options")
public function get,set UseOrigin : System.boolean
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether a custom area origin must be used.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Options")]
public: __property System.bool get_UseOrigin();
public: __property void set_UseOrigin(
   System.bool value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether a custom area origin must be used.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Options")]
public:
property System.bool UseOrigin {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesArea Class
SeriesArea Members


SeriesBar Class

[image]
Intersoft WebGrid Documentation
SeriesBar Class
Members See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : SeriesBar Class

Glossary Item Box

Object Model

SeriesBar Class

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.SerializableAttribute()>
Public Class SeriesBar
   Inherits SeriesXYZScatter
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Visual Basic (Usage) Copy Code
Dim instance As SeriesBar
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public class SeriesBar : SeriesXYZScatter, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Delphi
public class SeriesBar = class(SeriesXYZScatter, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize)
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.SerializableAttribute()
public class SeriesBar extends SeriesXYZScatter implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public __gc class SeriesBar : public SeriesXYZScatter, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public ref class SeriesBar : public SeriesXYZScatter, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.WebGrid.Chart.SeriesBase
ISNet.WebUI.WebGrid.Chart.Series
ISNet.WebUI.WebGrid.Chart.SeriesXYScatter
ISNet.WebUI.WebGrid.Chart.SeriesXYZScatter
ISNet.WebUI.WebGrid.Chart.SeriesBar

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesBar Members
ISNet.WebUI.WebGrid.Chart Namespace


SeriesBar Class Members

[image]
Intersoft WebGrid Documentation
SeriesBar Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : SeriesBar Class

Glossary Item Box

The following tables list the members exposed by SeriesBar.

Public Constructors

 | Name | Description
Public Constructor | SeriesBar Constructor |
Top

Public Properties

 | Name | Description
Public Property | BarDepth |
Public Property | BarEdgePercent |
Public Property | BarShape |
Public Property | BarWidth |
Public Property | BevelAndEmbossImageFilter | (Inherited from ISNet.WebUI.WebGrid.Chart.Series)
Public Property | BlurImageFilter | (Inherited from ISNet.WebUI.WebGrid.Chart.Series)
Public Property | BorderStyle | (Inherited from ISNet.WebUI.WebGrid.Chart.Series)
Public Property | ChartFillType | (Inherited from ISNet.WebUI.WebGrid.Chart.Series)
Public Property | DataLabelStyle | (Inherited from ISNet.WebUI.WebGrid.Chart.Series)
Public Property | DepthPercent |
Public Property | EmptyDataPointStyle | (Inherited from ISNet.WebUI.WebGrid.Chart.Series)
Public Property | GapPercent |
Public Property | GlowImageFilter | (Inherited from ISNet.WebUI.WebGrid.Chart.Series)
Public Property | HasBottomEdge |
Public Property | HasTopEdge |
Public Property | InteractiveStyle | (Inherited from ISNet.WebUI.WebGrid.Chart.Series)
Public Property | LightingImageFilter | (Inherited from ISNet.WebUI.WebGrid.Chart.Series)
Public Property | Origin |
Public Property | SeriesLegend | (Inherited from ISNet.WebUI.WebGrid.Chart.SeriesBase)
Public Property | ShadowStyle | (Inherited from ISNet.WebUI.WebGrid.Chart.SeriesBase)
Public Property | UseOrigin |
Public Property | Visible | (Inherited from ISNet.WebUI.WebGrid.Chart.SeriesBase)
Public Property | WidthPercent |
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

SeriesBar Class
ISNet.WebUI.WebGrid.Chart Namespace


SeriesBar Constructor

[image]
Intersoft WebGrid Documentation
SeriesBar Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > SeriesBar Class : SeriesBar Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New SeriesBar()
C#
public SeriesBar()
Delphi
public SeriesBar();
JScript
public function SeriesBar();
Managed Extensions for C++
public: SeriesBar();
C++/CLI
public:
SeriesBar();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesBar Class
SeriesBar Members


Clone Method

[image]
Intersoft WebGrid Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > SeriesBar Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As System.Object
Visual Basic (Usage) Copy Code
Dim instance As SeriesBar
Dim value As System.Object

value = instance.Clone()
C#
public virtual System.object Clone()
Delphi
public function Clone(): System.TObject; virtual;
JScript
public function Clone() : System.Object;
Managed Extensions for C++
public: virtual System.Object* Clone();
C++/CLI
public:
virtual System.Object^ Clone();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesBar Class
SeriesBar Members


CopyFrom Method

[image]
Intersoft WebGrid Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > SeriesBar Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesBar Class
SeriesBar Members


CopyFrom(Object) Method

[image]
Intersoft WebGrid Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > SeriesBar Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As SeriesBar
Dim objSource As System.Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   System.object objSource
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesBar Class
SeriesBar Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebGrid Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > SeriesBar Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object, _
   ByVal cloneSourceValue As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As SeriesBar
Dim objSource As System.Object
Dim cloneSourceValue As System.Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   System.object objSource,
   System.bool cloneSourceValue
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject;
    cloneSourceValue: System.Boolean
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object,
   cloneSourceValue : System.boolean
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource,
   System.bool cloneSourceValue
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource,
   System.bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesBar Class
SeriesBar Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebGrid Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > SeriesBar Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As SeriesBar
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure DeSerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function DeSerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void DeSerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void DeSerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesBar Class
SeriesBar Members


GetHashCode Method

[image]
Intersoft WebGrid Documentation
GetHashCode Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > SeriesBar Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As SeriesBar
Dim value As System.Integer

value = instance.GetHashCode()
C#
public virtual System.int GetHashCode()
Delphi
public function GetHashCode(): System.Integer; virtual;
JScript
public function GetHashCode() : System.int;
Managed Extensions for C++
public: virtual System.int GetHashCode();
C++/CLI
public:
virtual System.int GetHashCode();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesBar Class
SeriesBar Members


SeriesBar Class Methods

[image]
Intersoft WebGrid Documentation
SeriesBar Class Methods
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : SeriesBar Class

Glossary Item Box

For a list of all members of this type, see SeriesBar members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

SeriesBar Class
ISNet.WebUI.WebGrid.Chart Namespace


GetObjectData Method

[image]
Intersoft WebGrid Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > SeriesBar Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=False,
   UnmanagedCode=False,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=True,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Action=SecurityAction.Demand,
   Unrestricted=False)>
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As SeriesBar
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure GetObjectData(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
); override;
JScript
System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=,
   UnmanagedCode=,
   SkipVerification=,
   Execution=,
   ControlThread=,
   ControlEvidence=,
   ControlPolicy=,
   SerializationFormatter=,
   ControlDomainPolicy=,
   ControlPrincipal=,
   ControlAppDomain=,
   RemotingConfiguration=,
   Infrastructure=,
   BindingRedirects=,
   Action=SecurityAction.Demand,
   Unrestricted=)
public override function GetObjectData(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public: void GetObjectData(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
) override
C++/CLI
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public:
void GetObjectData(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
) override

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesBar Class
SeriesBar Members


IsEmpty Method

[image]
Intersoft WebGrid Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > SeriesBar Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As SeriesBar
Dim value As System.Boolean

value = instance.IsEmpty()
C#
public virtual System.bool IsEmpty()
Delphi
public function IsEmpty(): System.Boolean; virtual;
JScript
public function IsEmpty() : System.boolean;
Managed Extensions for C++
public: virtual System.bool IsEmpty();
C++/CLI
public:
virtual System.bool IsEmpty();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesBar Class
SeriesBar Members


Reset Method

[image]
Intersoft WebGrid Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > SeriesBar Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As SeriesBar

instance.Reset()
C#
public virtual void Reset()
Delphi
public procedure Reset(); virtual;
JScript
public function Reset();
Managed Extensions for C++
public: virtual void Reset();
C++/CLI
public:
virtual void Reset();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesBar Class
SeriesBar Members


SerializeObjectData Method

[image]
Intersoft WebGrid Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > SeriesBar Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As SeriesBar
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure SerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function SerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void SerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void SerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesBar Class
SeriesBar Members


ToString Method

[image]
Intersoft WebGrid Documentation
ToString Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > SeriesBar Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As System.String
Visual Basic (Usage) Copy Code
Dim instance As SeriesBar
Dim value As System.String

value = instance.ToString()
C#
public virtual System.string ToString()
Delphi
public function ToString(): System.String; virtual;
JScript
public function ToString() : System.String;
Managed Extensions for C++
public: virtual System.string* ToString();
C++/CLI
public:
virtual System.String^ ToString();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesBar Class
SeriesBar Members


SeriesBar Class Properties

[image]
Intersoft WebGrid Documentation
SeriesBar Class Properties
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : SeriesBar Class

Glossary Item Box

For a list of all members of this type, see SeriesBar members.

Public Properties

 | Name | Description
Public Property | BarDepth |
Public Property | BarEdgePercent |
Public Property | BarShape |
Public Property | BarWidth |
Public Property | BevelAndEmbossImageFilter | (Inherited from ISNet.WebUI.WebGrid.Chart.Series)
Public Property | BlurImageFilter | (Inherited from ISNet.WebUI.WebGrid.Chart.Series)
Public Property | BorderStyle | (Inherited from ISNet.WebUI.WebGrid.Chart.Series)
Public Property | ChartFillType | (Inherited from ISNet.WebUI.WebGrid.Chart.Series)
Public Property | DataLabelStyle | (Inherited from ISNet.WebUI.WebGrid.Chart.Series)
Public Property | DepthPercent |
Public Property | EmptyDataPointStyle | (Inherited from ISNet.WebUI.WebGrid.Chart.Series)
Public Property | GapPercent |
Public Property | GlowImageFilter | (Inherited from ISNet.WebUI.WebGrid.Chart.Series)
Public Property | HasBottomEdge |
Public Property | HasTopEdge |
Public Property | InteractiveStyle | (Inherited from ISNet.WebUI.WebGrid.Chart.Series)
Public Property | LightingImageFilter | (Inherited from ISNet.WebUI.WebGrid.Chart.Series)
Public Property | Origin |
Public Property | SeriesLegend | (Inherited from ISNet.WebUI.WebGrid.Chart.SeriesBase)
Public Property | ShadowStyle | (Inherited from ISNet.WebUI.WebGrid.Chart.SeriesBase)
Public Property | UseOrigin |
Public Property | Visible | (Inherited from ISNet.WebUI.WebGrid.Chart.SeriesBase)
Public Property | WidthPercent |
Top

See Also

Reference

SeriesBar Class
ISNet.WebUI.WebGrid.Chart Namespace


SeriesBar Constructor

[image]
Intersoft WebGrid Documentation
SeriesBar Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > SeriesBar Class : SeriesBar Constructor

Glossary Item Box

Overload List

Overload | Description
SeriesBar Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesBar Class
SeriesBar Members


BarDepth Property

[image]
Intersoft WebGrid Documentation
BarDepth Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > SeriesBar Class : BarDepth Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Controls the depth of the bars in model units, when the series is in Z scatter mode.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Options")>
Public Property BarDepth As System.Nullable(Of Single)
Visual Basic (Usage) Copy Code
Dim instance As SeriesBar
Dim value As System.Nullable(Of Single)

instance.BarDepth = value

value = instance.BarDepth
C#
[System.ComponentModel.DescriptionAttribute("Controls the depth of the bars in model units, when the series is in Z scatter mode.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Options")]
public System.Nullable<float> BarDepth {get; set;}
Delphi
public read-write property BarDepth: System.Nullable;
JScript
System.ComponentModel.DescriptionAttribute("Controls the depth of the bars in model units, when the series is in Z scatter mode.")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Options")
public function get,set BarDepth : System.Nullable
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Controls the depth of the bars in model units, when the series is in Z scatter mode.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Options")]
public: __property System.Nullable<float> get_BarDepth();
public: __property void set_BarDepth(
   System.Nullable<float> value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Controls the depth of the bars in model units, when the series is in Z scatter mode.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Options")]
public:
property System.Nullable<float> BarDepth {
   System.Nullable<float> get();
   void set (    System.Nullable<float> value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesBar Class
SeriesBar Members


BarEdgePercent Property

[image]
Intersoft WebGrid Documentation
BarEdgePercent Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > SeriesBar Class : BarEdgePercent Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Controls the edge percent of smooth edge bars and cut edge bars. The edge percent must be between 0 and 50.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Options")>
Public Property BarEdgePercent As System.Single
Visual Basic (Usage) Copy Code
Dim instance As SeriesBar
Dim value As System.Single

instance.BarEdgePercent = value

value = instance.BarEdgePercent
C#
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Controls the edge percent of smooth edge bars and cut edge bars. The edge percent must be between 0 and 50.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Options")]
public System.float BarEdgePercent {get; set;}
Delphi
public read-write property BarEdgePercent: System.Single;
JScript
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Controls the edge percent of smooth edge bars and cut edge bars. The edge percent must be between 0 and 50.")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Options")
public function get,set BarEdgePercent : System.float
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Controls the edge percent of smooth edge bars and cut edge bars. The edge percent must be between 0 and 50.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Options")]
public: __property System.float get_BarEdgePercent();
public: __property void set_BarEdgePercent(
   System.float value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Controls the edge percent of smooth edge bars and cut edge bars. The edge percent must be between 0 and 50.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Options")]
public:
property System.float BarEdgePercent {
   System.float get();
   void set (    System.float value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesBar Class
SeriesBar Members


BarShape Property

[image]
Intersoft WebGrid Documentation
BarShape Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > SeriesBar Class : BarShape Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Controls the shape of the bars.")>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Options")>
Public Property BarShape As BarShape
Visual Basic (Usage) Copy Code
Dim instance As SeriesBar
Dim value As BarShape

instance.BarShape = value

value = instance.BarShape
C#
[System.ComponentModel.DescriptionAttribute("Controls the shape of the bars.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Options")]
public BarShape BarShape {get; set;}
Delphi
public read-write property BarShape: BarShape;
JScript
System.ComponentModel.DescriptionAttribute("Controls the shape of the bars.")
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Options")
public function get,set BarShape : BarShape
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Controls the shape of the bars.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Options")]
public: __property BarShape get_BarShape();
public: __property void set_BarShape(
   BarShape value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Controls the shape of the bars.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Options")]
public:
property BarShape BarShape {
   BarShape get();
   void set (    BarShape value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesBar Class
SeriesBar Members


BarWidth Property

[image]
Intersoft WebGrid Documentation
BarWidth Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > SeriesBar Class : BarWidth Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Options")>
<System.ComponentModel.DescriptionAttribute("Controls the width of the bars in model units, when the series is in X scatter mode.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property BarWidth As System.Nullable(Of Single)
Visual Basic (Usage) Copy Code
Dim instance As SeriesBar
Dim value As System.Nullable(Of Single)

instance.BarWidth = value

value = instance.BarWidth
C#
[System.ComponentModel.CategoryAttribute("Options")]
[System.ComponentModel.DescriptionAttribute("Controls the width of the bars in model units, when the series is in X scatter mode.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.Nullable<float> BarWidth {get; set;}
Delphi
public read-write property BarWidth: System.Nullable;
JScript
System.ComponentModel.CategoryAttribute("Options")
System.ComponentModel.DescriptionAttribute("Controls the width of the bars in model units, when the series is in X scatter mode.")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set BarWidth : System.Nullable
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Options")]
[System.ComponentModel.DescriptionAttribute("Controls the width of the bars in model units, when the series is in X scatter mode.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.Nullable<float> get_BarWidth();
public: __property void set_BarWidth(
   System.Nullable<float> value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Options")]
[System.ComponentModel.DescriptionAttribute("Controls the width of the bars in model units, when the series is in X scatter mode.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.Nullable<float> BarWidth {
   System.Nullable<float> get();
   void set (    System.Nullable<float> value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesBar Class
SeriesBar Members


DepthPercent Property

[image]
Intersoft WebGrid Documentation
DepthPercent Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > SeriesBar Class : DepthPercent Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Options")>
<System.ComponentModel.DescriptionAttribute("Controls the depth of bars in percents of the floor grid cell depth.")>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property DepthPercent As System.Single
Visual Basic (Usage) Copy Code
Dim instance As SeriesBar
Dim value As System.Single

instance.DepthPercent = value

value = instance.DepthPercent
C#
[System.ComponentModel.CategoryAttribute("Options")]
[System.ComponentModel.DescriptionAttribute("Controls the depth of bars in percents of the floor grid cell depth.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.float DepthPercent {get; set;}
Delphi
public read-write property DepthPercent: System.Single;
JScript
System.ComponentModel.CategoryAttribute("Options")
System.ComponentModel.DescriptionAttribute("Controls the depth of bars in percents of the floor grid cell depth.")
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set DepthPercent : System.float
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Options")]
[System.ComponentModel.DescriptionAttribute("Controls the depth of bars in percents of the floor grid cell depth.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.float get_DepthPercent();
public: __property void set_DepthPercent(
   System.float value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Options")]
[System.ComponentModel.DescriptionAttribute("Controls the depth of bars in percents of the floor grid cell depth.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.float DepthPercent {
   System.float get();
   void set (    System.float value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesBar Class
SeriesBar Members


GapPercent Property

[image]
Intersoft WebGrid Documentation
GapPercent Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > SeriesBar Class : GapPercent Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("Options")>
<System.ComponentModel.DescriptionAttribute("Controls the gap between the bars in percents of the floor grid cell width.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property GapPercent As System.Single
Visual Basic (Usage) Copy Code
Dim instance As SeriesBar
Dim value As System.Single

instance.GapPercent = value

value = instance.GapPercent
C#
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Options")]
[System.ComponentModel.DescriptionAttribute("Controls the gap between the bars in percents of the floor grid cell width.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.float GapPercent {get; set;}
Delphi
public read-write property GapPercent: System.Single;
JScript
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("Options")
System.ComponentModel.DescriptionAttribute("Controls the gap between the bars in percents of the floor grid cell width.")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set GapPercent : System.float
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Options")]
[System.ComponentModel.DescriptionAttribute("Controls the gap between the bars in percents of the floor grid cell width.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.float get_GapPercent();
public: __property void set_GapPercent(
   System.float value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Options")]
[System.ComponentModel.DescriptionAttribute("Controls the gap between the bars in percents of the floor grid cell width.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.float GapPercent {
   System.float get();
   void set (    System.float value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesBar Class
SeriesBar Members


HasBottomEdge Property

[image]
Intersoft WebGrid Documentation
HasBottomEdge Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > SeriesBar Class : HasBottomEdge Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Controls the visibility of the bottom edge of smooth edge bars and cut edge bars.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Options")>
Public Property HasBottomEdge As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As SeriesBar
Dim value As System.Boolean

instance.HasBottomEdge = value

value = instance.HasBottomEdge
C#
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Controls the visibility of the bottom edge of smooth edge bars and cut edge bars.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Options")]
public System.bool HasBottomEdge {get; set;}
Delphi
public read-write property HasBottomEdge: System.Boolean;
JScript
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Controls the visibility of the bottom edge of smooth edge bars and cut edge bars.")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Options")
public function get,set HasBottomEdge : System.boolean
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Controls the visibility of the bottom edge of smooth edge bars and cut edge bars.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Options")]
public: __property System.bool get_HasBottomEdge();
public: __property void set_HasBottomEdge(
   System.bool value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Controls the visibility of the bottom edge of smooth edge bars and cut edge bars.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Options")]
public:
property System.bool HasBottomEdge {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesBar Class
SeriesBar Members


HasTopEdge Property

[image]
Intersoft WebGrid Documentation
HasTopEdge Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > SeriesBar Class : HasTopEdge Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Options")>
<System.ComponentModel.DescriptionAttribute("Controls the visibility of the top edge of smooth edge bars and cut edge bars.")>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property HasTopEdge As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As SeriesBar
Dim value As System.Boolean

instance.HasTopEdge = value

value = instance.HasTopEdge
C#
[System.ComponentModel.CategoryAttribute("Options")]
[System.ComponentModel.DescriptionAttribute("Controls the visibility of the top edge of smooth edge bars and cut edge bars.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.bool HasTopEdge {get; set;}
Delphi
public read-write property HasTopEdge: System.Boolean;
JScript
System.ComponentModel.CategoryAttribute("Options")
System.ComponentModel.DescriptionAttribute("Controls the visibility of the top edge of smooth edge bars and cut edge bars.")
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set HasTopEdge : System.boolean
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Options")]
[System.ComponentModel.DescriptionAttribute("Controls the visibility of the top edge of smooth edge bars and cut edge bars.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.bool get_HasTopEdge();
public: __property void set_HasTopEdge(
   System.bool value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Options")]
[System.ComponentModel.DescriptionAttribute("Controls the visibility of the top edge of smooth edge bars and cut edge bars.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.bool HasTopEdge {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesBar Class
SeriesBar Members


Origin Property

[image]
Intersoft WebGrid Documentation
Origin Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > SeriesBar Class : Origin Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies the custom area origin.")>
<System.ComponentModel.CategoryAttribute("Options")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property Origin As System.Single
Visual Basic (Usage) Copy Code
Dim instance As SeriesBar
Dim value As System.Single

instance.Origin = value

value = instance.Origin
C#
[System.ComponentModel.DescriptionAttribute("Specifies the custom area origin.")]
[System.ComponentModel.CategoryAttribute("Options")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.float Origin {get; set;}
Delphi
public read-write property Origin: System.Single;
JScript
System.ComponentModel.DescriptionAttribute("Specifies the custom area origin.")
System.ComponentModel.CategoryAttribute("Options")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set Origin : System.float
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies the custom area origin.")]
[System.ComponentModel.CategoryAttribute("Options")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.float get_Origin();
public: __property void set_Origin(
   System.float value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies the custom area origin.")]
[System.ComponentModel.CategoryAttribute("Options")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.float Origin {
   System.float get();
   void set (    System.float value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesBar Class
SeriesBar Members


UseOrigin Property

[image]
Intersoft WebGrid Documentation
UseOrigin Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > SeriesBar Class : UseOrigin Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Specifies whether a custom area origin must be used.")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("Options")>
Public Property UseOrigin As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As SeriesBar
Dim value As System.Boolean

instance.UseOrigin = value

value = instance.UseOrigin
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies whether a custom area origin must be used.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Options")]
public System.bool UseOrigin {get; set;}
Delphi
public read-write property UseOrigin: System.Boolean;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Specifies whether a custom area origin must be used.")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("Options")
public function get,set UseOrigin : System.boolean
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies whether a custom area origin must be used.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Options")]
public: __property System.bool get_UseOrigin();
public: __property void set_UseOrigin(
   System.bool value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies whether a custom area origin must be used.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Options")]
public:
property System.bool UseOrigin {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesBar Class
SeriesBar Members


WidthPercent Property

[image]
Intersoft WebGrid Documentation
WidthPercent Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > SeriesBar Class : WidthPercent Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Controls the width of the bars in percents of the floor grid cell width.")>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Options")>
Public Property WidthPercent As System.Single
Visual Basic (Usage) Copy Code
Dim instance As SeriesBar
Dim value As System.Single

instance.WidthPercent = value

value = instance.WidthPercent
C#
[System.ComponentModel.DescriptionAttribute("Controls the width of the bars in percents of the floor grid cell width.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Options")]
public System.float WidthPercent {get; set;}
Delphi
public read-write property WidthPercent: System.Single;
JScript
System.ComponentModel.DescriptionAttribute("Controls the width of the bars in percents of the floor grid cell width.")
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Options")
public function get,set WidthPercent : System.float
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Controls the width of the bars in percents of the floor grid cell width.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Options")]
public: __property System.float get_WidthPercent();
public: __property void set_WidthPercent(
   System.float value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Controls the width of the bars in percents of the floor grid cell width.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Options")]
public:
property System.float WidthPercent {
   System.float get();
   void set (    System.float value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesBar Class
SeriesBar Members


SeriesBase Class

[image]
Intersoft WebGrid Documentation
SeriesBase Class
Members See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : SeriesBase Class

Glossary Item Box

Object Model

SeriesBase Class

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.SerializableAttribute()>
Public Class SeriesBase
   Inherits ISNet.WebUI.WebUIBaseClass
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Visual Basic (Usage) Copy Code
Dim instance As SeriesBase
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public class SeriesBase : ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Delphi
public class SeriesBase = class(ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize)
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.SerializableAttribute()
public class SeriesBase extends ISNet.WebUI.WebUIBaseClass implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public __gc class SeriesBase : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public ref class SeriesBase : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.WebGrid.Chart.SeriesBase
ISNet.WebUI.WebGrid.Chart.Series

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesBase Members
ISNet.WebUI.WebGrid.Chart Namespace


SeriesBase Class Members

[image]
Intersoft WebGrid Documentation
SeriesBase Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : SeriesBase Class

Glossary Item Box

The following tables list the members exposed by SeriesBase.

Public Constructors

 | Name | Description
Public Constructor | SeriesBase Constructor |
Top

Public Properties

 | Name | Description
Public Property | SeriesLegend |
Public Property | ShadowStyle |
Public Property | Visible |
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

SeriesBase Class
ISNet.WebUI.WebGrid.Chart Namespace


SeriesBase Constructor

[image]
Intersoft WebGrid Documentation
SeriesBase Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > SeriesBase Class : SeriesBase Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New SeriesBase()
C#
public SeriesBase()
Delphi
public SeriesBase();
JScript
public function SeriesBase();
Managed Extensions for C++
public: SeriesBase();
C++/CLI
public:
SeriesBase();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesBase Class
SeriesBase Members


Clone Method

[image]
Intersoft WebGrid Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > SeriesBase Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As System.Object
Visual Basic (Usage) Copy Code
Dim instance As SeriesBase
Dim value As System.Object

value = instance.Clone()
C#
public virtual System.object Clone()
Delphi
public function Clone(): System.TObject; virtual;
JScript
public function Clone() : System.Object;
Managed Extensions for C++
public: virtual System.Object* Clone();
C++/CLI
public:
virtual System.Object^ Clone();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesBase Class
SeriesBase Members


CopyFrom Method

[image]
Intersoft WebGrid Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > SeriesBase Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesBase Class
SeriesBase Members


CopyFrom(Object) Method

[image]
Intersoft WebGrid Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > SeriesBase Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As SeriesBase
Dim objSource As System.Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   System.object objSource
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesBase Class
SeriesBase Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebGrid Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > SeriesBase Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object, _
   ByVal cloneSourceValue As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As SeriesBase
Dim objSource As System.Object
Dim cloneSourceValue As System.Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   System.object objSource,
   System.bool cloneSourceValue
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject;
    cloneSourceValue: System.Boolean
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object,
   cloneSourceValue : System.boolean
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource,
   System.bool cloneSourceValue
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource,
   System.bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesBase Class
SeriesBase Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebGrid Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > SeriesBase Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As SeriesBase
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure DeSerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function DeSerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void DeSerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void DeSerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesBase Class
SeriesBase Members


GetHashCode Method

[image]
Intersoft WebGrid Documentation
GetHashCode Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > SeriesBase Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As SeriesBase
Dim value As System.Integer

value = instance.GetHashCode()
C#
public virtual System.int GetHashCode()
Delphi
public function GetHashCode(): System.Integer; virtual;
JScript
public function GetHashCode() : System.int;
Managed Extensions for C++
public: virtual System.int GetHashCode();
C++/CLI
public:
virtual System.int GetHashCode();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesBase Class
SeriesBase Members


SeriesBase Class Methods

[image]
Intersoft WebGrid Documentation
SeriesBase Class Methods
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : SeriesBase Class

Glossary Item Box

For a list of all members of this type, see SeriesBase members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

SeriesBase Class
ISNet.WebUI.WebGrid.Chart Namespace


GetObjectData Method

[image]
Intersoft WebGrid Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > SeriesBase Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=False,
   UnmanagedCode=False,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=True,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Action=SecurityAction.Demand,
   Unrestricted=False)>
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As SeriesBase
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure GetObjectData(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
); override;
JScript
System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=,
   UnmanagedCode=,
   SkipVerification=,
   Execution=,
   ControlThread=,
   ControlEvidence=,
   ControlPolicy=,
   SerializationFormatter=,
   ControlDomainPolicy=,
   ControlPrincipal=,
   ControlAppDomain=,
   RemotingConfiguration=,
   Infrastructure=,
   BindingRedirects=,
   Action=SecurityAction.Demand,
   Unrestricted=)
public override function GetObjectData(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public: void GetObjectData(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
) override
C++/CLI
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public:
void GetObjectData(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
) override

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesBase Class
SeriesBase Members


IsEmpty Method

[image]
Intersoft WebGrid Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > SeriesBase Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As SeriesBase
Dim value As System.Boolean

value = instance.IsEmpty()
C#
public virtual System.bool IsEmpty()
Delphi
public function IsEmpty(): System.Boolean; virtual;
JScript
public function IsEmpty() : System.boolean;
Managed Extensions for C++
public: virtual System.bool IsEmpty();
C++/CLI
public:
virtual System.bool IsEmpty();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesBase Class
SeriesBase Members


Reset Method

[image]
Intersoft WebGrid Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > SeriesBase Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As SeriesBase

instance.Reset()
C#
public virtual void Reset()
Delphi
public procedure Reset(); virtual;
JScript
public function Reset();
Managed Extensions for C++
public: virtual void Reset();
C++/CLI
public:
virtual void Reset();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesBase Class
SeriesBase Members


SerializeObjectData Method

[image]
Intersoft WebGrid Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > SeriesBase Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As SeriesBase
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure SerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function SerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void SerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void SerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesBase Class
SeriesBase Members


ToString Method

[image]
Intersoft WebGrid Documentation
ToString Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > SeriesBase Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As System.String
Visual Basic (Usage) Copy Code
Dim instance As SeriesBase
Dim value As System.String

value = instance.ToString()
C#
public virtual System.string ToString()
Delphi
public function ToString(): System.String; virtual;
JScript
public function ToString() : System.String;
Managed Extensions for C++
public: virtual System.string* ToString();
C++/CLI
public:
virtual System.String^ ToString();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesBase Class
SeriesBase Members


SeriesBase Class Properties

[image]
Intersoft WebGrid Documentation
SeriesBase Class Properties
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : SeriesBase Class

Glossary Item Box

For a list of all members of this type, see SeriesBase members.

Public Properties

 | Name | Description
Public Property | SeriesLegend |
Public Property | ShadowStyle |
Public Property | Visible |
Top

See Also

Reference

SeriesBase Class
ISNet.WebUI.WebGrid.Chart Namespace


SeriesBase Constructor

[image]
Intersoft WebGrid Documentation
SeriesBase Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > SeriesBase Class : SeriesBase Constructor

Glossary Item Box

Overload List

Overload | Description
SeriesBase Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesBase Class
SeriesBase Members


SeriesLegend Property

[image]
Intersoft WebGrid Documentation
SeriesLegend Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > SeriesBase Class : SeriesLegend Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Controls the representation of the series in the legend.")>
<ISNet.Serialization.BinarySerializableAttribute("setSeriesLegend")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<System.ComponentModel.CategoryAttribute("Attributes")>
<System.ComponentModel.DefaultValueAttribute()>
Public ReadOnly Property SeriesLegend As SeriesLegend
Visual Basic (Usage) Copy Code
Dim instance As SeriesBase
Dim value As SeriesLegend

value = instance.SeriesLegend
C#
[System.ComponentModel.DescriptionAttribute("Controls the representation of the series in the legend.")]
[ISNet.Serialization.BinarySerializableAttribute("setSeriesLegend")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.CategoryAttribute("Attributes")]
[System.ComponentModel.DefaultValueAttribute()]
public SeriesLegend SeriesLegend {get;}
Delphi
public read-only property SeriesLegend: SeriesLegend;
JScript
System.ComponentModel.DescriptionAttribute("Controls the representation of the series in the legend.")
ISNet.Serialization.BinarySerializableAttribute("setSeriesLegend")
System.ComponentModel.NotifyParentPropertyAttribute()
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
System.ComponentModel.CategoryAttribute("Attributes")
System.ComponentModel.DefaultValueAttribute()
public function get SeriesLegend : SeriesLegend
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Controls the representation of the series in the legend.")]
[ISNet.Serialization.BinarySerializableAttribute("setSeriesLegend")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.CategoryAttribute("Attributes")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property SeriesLegend* get_SeriesLegend();
C++/CLI
[System.ComponentModel.DescriptionAttribute("Controls the representation of the series in the legend.")]
[ISNet.Serialization.BinarySerializableAttribute("setSeriesLegend")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.CategoryAttribute("Attributes")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property SeriesLegend^ SeriesLegend {
   SeriesLegend^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesBase Class
SeriesBase Members


ShadowStyle Property

[image]
Intersoft WebGrid Documentation
ShadowStyle Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > SeriesBase Class : ShadowStyle Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Styles")>
<ISNet.Serialization.BinarySerializableAttribute("setShadowStyle")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Controls the shadow of the series.")>
Public ReadOnly Property ShadowStyle As ChartShadowStyle
Visual Basic (Usage) Copy Code
Dim instance As SeriesBase
Dim value As ChartShadowStyle

value = instance.ShadowStyle
C#
[System.ComponentModel.CategoryAttribute("Styles")]
[ISNet.Serialization.BinarySerializableAttribute("setShadowStyle")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Controls the shadow of the series.")]
public ChartShadowStyle ShadowStyle {get;}
Delphi
public read-only property ShadowStyle: ChartShadowStyle;
JScript
System.ComponentModel.CategoryAttribute("Styles")
ISNet.Serialization.BinarySerializableAttribute("setShadowStyle")
System.ComponentModel.NotifyParentPropertyAttribute()
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Controls the shadow of the series.")
public function get ShadowStyle : ChartShadowStyle
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Styles")]
[ISNet.Serialization.BinarySerializableAttribute("setShadowStyle")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Controls the shadow of the series.")]
public: __property ChartShadowStyle* get_ShadowStyle();
C++/CLI
[System.ComponentModel.CategoryAttribute("Styles")]
[ISNet.Serialization.BinarySerializableAttribute("setShadowStyle")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Controls the shadow of the series.")]
public:
property ChartShadowStyle^ ShadowStyle {
   ChartShadowStyle^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesBase Class
SeriesBase Members


Visible Property

[image]
Intersoft WebGrid Documentation
Visible Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > SeriesBase Class : Visible Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("General")>
<System.ComponentModel.DescriptionAttribute("Controls the visibility of the series.")>
Public Property Visible As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As SeriesBase
Dim value As System.Boolean

instance.Visible = value

value = instance.Visible
C#
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DescriptionAttribute("Controls the visibility of the series.")]
public System.bool Visible {get; set;}
Delphi
public read-write property Visible: System.Boolean;
JScript
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("General")
System.ComponentModel.DescriptionAttribute("Controls the visibility of the series.")
public function get,set Visible : System.boolean
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DescriptionAttribute("Controls the visibility of the series.")]
public: __property System.bool get_Visible();
public: __property void set_Visible(
   System.bool value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DescriptionAttribute("Controls the visibility of the series.")]
public:
property System.bool Visible {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesBase Class
SeriesBase Members


SeriesBubble Class

[image]
Intersoft WebGrid Documentation
SeriesBubble Class
Members See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : SeriesBubble Class

Glossary Item Box

Object Model

SeriesBubble Class

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.SerializableAttribute()>
Public Class SeriesBubble
   Inherits SeriesXYZScatter
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Visual Basic (Usage) Copy Code
Dim instance As SeriesBubble
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public class SeriesBubble : SeriesXYZScatter, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Delphi
public class SeriesBubble = class(SeriesXYZScatter, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize)
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.SerializableAttribute()
public class SeriesBubble extends SeriesXYZScatter implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public __gc class SeriesBubble : public SeriesXYZScatter, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public ref class SeriesBubble : public SeriesXYZScatter, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.WebGrid.Chart.SeriesBase
ISNet.WebUI.WebGrid.Chart.Series
ISNet.WebUI.WebGrid.Chart.SeriesXYScatter
ISNet.WebUI.WebGrid.Chart.SeriesXYZScatter
ISNet.WebUI.WebGrid.Chart.SeriesBubble

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesBubble Members
ISNet.WebUI.WebGrid.Chart Namespace


SeriesBubble Class Members

[image]
Intersoft WebGrid Documentation
SeriesBubble Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : SeriesBubble Class

Glossary Item Box

The following tables list the members exposed by SeriesBubble.

Public Constructors

 | Name | Description
Public Constructor | SeriesBubble Constructor |
Top

Public Properties

 | Name | Description
Public Property | BevelAndEmbossImageFilter | (Inherited from ISNet.WebUI.WebGrid.Chart.Series)
Public Property | BlurImageFilter | (Inherited from ISNet.WebUI.WebGrid.Chart.Series)
Public Property | BorderStyle | (Inherited from ISNet.WebUI.WebGrid.Chart.Series)
Public Property | BubbleShape |
Public Property | ChartFillType | (Inherited from ISNet.WebUI.WebGrid.Chart.Series)
Public Property | DataLabelStyle | (Inherited from ISNet.WebUI.WebGrid.Chart.Series)
Public Property | EmptyDataPointStyle | (Inherited from ISNet.WebUI.WebGrid.Chart.Series)
Public Property | GlowImageFilter | (Inherited from ISNet.WebUI.WebGrid.Chart.Series)
Public Property | InteractiveStyle | (Inherited from ISNet.WebUI.WebGrid.Chart.Series)
Public Property | LightingImageFilter | (Inherited from ISNet.WebUI.WebGrid.Chart.Series)
Public Property | MaxSize |
Public Property | MinSize |
Public Property | SeriesLegend | (Inherited from ISNet.WebUI.WebGrid.Chart.SeriesBase)
Public Property | ShadowStyle | (Inherited from ISNet.WebUI.WebGrid.Chart.SeriesBase)
Public Property | Visible | (Inherited from ISNet.WebUI.WebGrid.Chart.SeriesBase)
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

SeriesBubble Class
ISNet.WebUI.WebGrid.Chart Namespace


SeriesBubble Constructor

[image]
Intersoft WebGrid Documentation
SeriesBubble Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > SeriesBubble Class : SeriesBubble Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New SeriesBubble()
C#
public SeriesBubble()
Delphi
public SeriesBubble();
JScript
public function SeriesBubble();
Managed Extensions for C++
public: SeriesBubble();
C++/CLI
public:
SeriesBubble();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesBubble Class
SeriesBubble Members


Clone Method

[image]
Intersoft WebGrid Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > SeriesBubble Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As System.Object
Visual Basic (Usage) Copy Code
Dim instance As SeriesBubble
Dim value As System.Object

value = instance.Clone()
C#
public virtual System.object Clone()
Delphi
public function Clone(): System.TObject; virtual;
JScript
public function Clone() : System.Object;
Managed Extensions for C++
public: virtual System.Object* Clone();
C++/CLI
public:
virtual System.Object^ Clone();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesBubble Class
SeriesBubble Members


CopyFrom Method

[image]
Intersoft WebGrid Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > SeriesBubble Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesBubble Class
SeriesBubble Members


CopyFrom(Object) Method

[image]
Intersoft WebGrid Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > SeriesBubble Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As SeriesBubble
Dim objSource As System.Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   System.object objSource
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesBubble Class
SeriesBubble Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebGrid Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > SeriesBubble Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object, _
   ByVal cloneSourceValue As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As SeriesBubble
Dim objSource As System.Object
Dim cloneSourceValue As System.Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   System.object objSource,
   System.bool cloneSourceValue
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject;
    cloneSourceValue: System.Boolean
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object,
   cloneSourceValue : System.boolean
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource,
   System.bool cloneSourceValue
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource,
   System.bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesBubble Class
SeriesBubble Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebGrid Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > SeriesBubble Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As SeriesBubble
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure DeSerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function DeSerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void DeSerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void DeSerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesBubble Class
SeriesBubble Members


GetHashCode Method

[image]
Intersoft WebGrid Documentation
GetHashCode Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > SeriesBubble Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As SeriesBubble
Dim value As System.Integer

value = instance.GetHashCode()
C#
public virtual System.int GetHashCode()
Delphi
public function GetHashCode(): System.Integer; virtual;
JScript
public function GetHashCode() : System.int;
Managed Extensions for C++
public: virtual System.int GetHashCode();
C++/CLI
public:
virtual System.int GetHashCode();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesBubble Class
SeriesBubble Members


SeriesBubble Class Methods

[image]
Intersoft WebGrid Documentation
SeriesBubble Class Methods
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : SeriesBubble Class

Glossary Item Box

For a list of all members of this type, see SeriesBubble members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

SeriesBubble Class
ISNet.WebUI.WebGrid.Chart Namespace


GetObjectData Method

[image]
Intersoft WebGrid Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > SeriesBubble Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=False,
   UnmanagedCode=False,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=True,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Action=SecurityAction.Demand,
   Unrestricted=False)>
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As SeriesBubble
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure GetObjectData(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
); override;
JScript
System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=,
   UnmanagedCode=,
   SkipVerification=,
   Execution=,
   ControlThread=,
   ControlEvidence=,
   ControlPolicy=,
   SerializationFormatter=,
   ControlDomainPolicy=,
   ControlPrincipal=,
   ControlAppDomain=,
   RemotingConfiguration=,
   Infrastructure=,
   BindingRedirects=,
   Action=SecurityAction.Demand,
   Unrestricted=)
public override function GetObjectData(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public: void GetObjectData(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
) override
C++/CLI
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public:
void GetObjectData(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
) override

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesBubble Class
SeriesBubble Members


IsEmpty Method

[image]
Intersoft WebGrid Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > SeriesBubble Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As SeriesBubble
Dim value As System.Boolean

value = instance.IsEmpty()
C#
public virtual System.bool IsEmpty()
Delphi
public function IsEmpty(): System.Boolean; virtual;
JScript
public function IsEmpty() : System.boolean;
Managed Extensions for C++
public: virtual System.bool IsEmpty();
C++/CLI
public:
virtual System.bool IsEmpty();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesBubble Class
SeriesBubble Members


Reset Method

[image]
Intersoft WebGrid Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > SeriesBubble Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As SeriesBubble

instance.Reset()
C#
public virtual void Reset()
Delphi
public procedure Reset(); virtual;
JScript
public function Reset();
Managed Extensions for C++
public: virtual void Reset();
C++/CLI
public:
virtual void Reset();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesBubble Class
SeriesBubble Members


SerializeObjectData Method

[image]
Intersoft WebGrid Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > SeriesBubble Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As SeriesBubble
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure SerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function SerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void SerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void SerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesBubble Class
SeriesBubble Members


ToString Method

[image]
Intersoft WebGrid Documentation
ToString Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > SeriesBubble Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As System.String
Visual Basic (Usage) Copy Code
Dim instance As SeriesBubble
Dim value As System.String

value = instance.ToString()
C#
public virtual System.string ToString()
Delphi
public function ToString(): System.String; virtual;
JScript
public function ToString() : System.String;
Managed Extensions for C++
public: virtual System.string* ToString();
C++/CLI
public:
virtual System.String^ ToString();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesBubble Class
SeriesBubble Members


SeriesBubble Class Properties

[image]
Intersoft WebGrid Documentation
SeriesBubble Class Properties
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : SeriesBubble Class

Glossary Item Box

For a list of all members of this type, see SeriesBubble members.

Public Properties

 | Name | Description
Public Property | BevelAndEmbossImageFilter | (Inherited from ISNet.WebUI.WebGrid.Chart.Series)
Public Property | BlurImageFilter | (Inherited from ISNet.WebUI.WebGrid.Chart.Series)
Public Property | BorderStyle | (Inherited from ISNet.WebUI.WebGrid.Chart.Series)
Public Property | BubbleShape |
Public Property | ChartFillType | (Inherited from ISNet.WebUI.WebGrid.Chart.Series)
Public Property | DataLabelStyle | (Inherited from ISNet.WebUI.WebGrid.Chart.Series)
Public Property | EmptyDataPointStyle | (Inherited from ISNet.WebUI.WebGrid.Chart.Series)
Public Property | GlowImageFilter | (Inherited from ISNet.WebUI.WebGrid.Chart.Series)
Public Property | InteractiveStyle | (Inherited from ISNet.WebUI.WebGrid.Chart.Series)
Public Property | LightingImageFilter | (Inherited from ISNet.WebUI.WebGrid.Chart.Series)
Public Property | MaxSize |
Public Property | MinSize |
Public Property | SeriesLegend | (Inherited from ISNet.WebUI.WebGrid.Chart.SeriesBase)
Public Property | ShadowStyle | (Inherited from ISNet.WebUI.WebGrid.Chart.SeriesBase)
Public Property | Visible | (Inherited from ISNet.WebUI.WebGrid.Chart.SeriesBase)
Top

See Also

Reference

SeriesBubble Class
ISNet.WebUI.WebGrid.Chart Namespace


SeriesBubble Constructor

[image]
Intersoft WebGrid Documentation
SeriesBubble Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > SeriesBubble Class : SeriesBubble Constructor

Glossary Item Box

Overload List

Overload | Description
SeriesBubble Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesBubble Class
SeriesBubble Members


BubbleShape Property

[image]
Intersoft WebGrid Documentation
BubbleShape Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > SeriesBubble Class : BubbleShape Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Options")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Controls the bubble style.")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property BubbleShape As PointShape
Visual Basic (Usage) Copy Code
Dim instance As SeriesBubble
Dim value As PointShape

instance.BubbleShape = value

value = instance.BubbleShape
C#
[System.ComponentModel.CategoryAttribute("Options")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Controls the bubble style.")]
[System.ComponentModel.DefaultValueAttribute()]
public PointShape BubbleShape {get; set;}
Delphi
public read-write property BubbleShape: PointShape;
JScript
System.ComponentModel.CategoryAttribute("Options")
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DescriptionAttribute("Controls the bubble style.")
System.ComponentModel.DefaultValueAttribute()
public function get,set BubbleShape : PointShape
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Options")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Controls the bubble style.")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property PointShape get_BubbleShape();
public: __property void set_BubbleShape(
   PointShape value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Options")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Controls the bubble style.")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property PointShape BubbleShape {
   PointShape get();
   void set (    PointShape value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesBubble Class
SeriesBubble Members


MaxSize Property

[image]
Intersoft WebGrid Documentation
MaxSize Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > SeriesBubble Class : MaxSize Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Options")>
<System.ComponentModel.DescriptionAttribute("Controls the maximal bubble size.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property MaxSize As System.Nullable(Of Single)
Visual Basic (Usage) Copy Code
Dim instance As SeriesBubble
Dim value As System.Nullable(Of Single)

instance.MaxSize = value

value = instance.MaxSize
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Options")]
[System.ComponentModel.DescriptionAttribute("Controls the maximal bubble size.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.Nullable<float> MaxSize {get; set;}
Delphi
public read-write property MaxSize: System.Nullable;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Options")
System.ComponentModel.DescriptionAttribute("Controls the maximal bubble size.")
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set MaxSize : System.Nullable
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Options")]
[System.ComponentModel.DescriptionAttribute("Controls the maximal bubble size.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.Nullable<float> get_MaxSize();
public: __property void set_MaxSize(
   System.Nullable<float> value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Options")]
[System.ComponentModel.DescriptionAttribute("Controls the maximal bubble size.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.Nullable<float> MaxSize {
   System.Nullable<float> get();
   void set (    System.Nullable<float> value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesBubble Class
SeriesBubble Members


MinSize Property

[image]
Intersoft WebGrid Documentation
MinSize Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > SeriesBubble Class : MinSize Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Options")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Controls the minimal bubble size.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property MinSize As System.Nullable(Of Single)
Visual Basic (Usage) Copy Code
Dim instance As SeriesBubble
Dim value As System.Nullable(Of Single)

instance.MinSize = value

value = instance.MinSize
C#
[System.ComponentModel.CategoryAttribute("Options")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Controls the minimal bubble size.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.Nullable<float> MinSize {get; set;}
Delphi
public read-write property MinSize: System.Nullable;
JScript
System.ComponentModel.CategoryAttribute("Options")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DescriptionAttribute("Controls the minimal bubble size.")
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set MinSize : System.Nullable
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Options")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Controls the minimal bubble size.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.Nullable<float> get_MinSize();
public: __property void set_MinSize(
   System.Nullable<float> value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Options")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Controls the minimal bubble size.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.Nullable<float> MinSize {
   System.Nullable<float> get();
   void set (    System.Nullable<float> value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesBubble Class
SeriesBubble Members


SeriesLegend Class

[image]
Intersoft WebGrid Documentation
SeriesLegend Class
Members See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : SeriesLegend Class

Glossary Item Box

Object Model

SeriesLegend Class

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.SerializableAttribute()>
Public Class SeriesLegend
   Inherits ISNet.WebUI.WebUIBaseClass
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Visual Basic (Usage) Copy Code
Dim instance As SeriesLegend
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public class SeriesLegend : ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Delphi
public class SeriesLegend = class(ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize)
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.SerializableAttribute()
public class SeriesLegend extends ISNet.WebUI.WebUIBaseClass implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public __gc class SeriesLegend : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public ref class SeriesLegend : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.WebGrid.Chart.SeriesLegend

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesLegend Members
ISNet.WebUI.WebGrid.Chart Namespace


SeriesLegend Class Members

[image]
Intersoft WebGrid Documentation
SeriesLegend Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : SeriesLegend Class

Glossary Item Box

The following tables list the members exposed by SeriesLegend.

Public Constructors

 | Name | Description
Public Constructor | SeriesLegend Constructor |
Top

Public Properties

 | Name | Description
Public Property | Format |
Public Property | InheritSeriesShadowColor |
Public Property | InheritSeriesShadowType |
Public Property | Mode |
Public Property | ShadowStyle |
Public Property | TextStyle |
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

SeriesLegend Class
ISNet.WebUI.WebGrid.Chart Namespace


SeriesLegend Constructor

[image]
Intersoft WebGrid Documentation
SeriesLegend Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > SeriesLegend Class : SeriesLegend Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New SeriesLegend()
C#
public SeriesLegend()
Delphi
public SeriesLegend();
JScript
public function SeriesLegend();
Managed Extensions for C++
public: SeriesLegend();
C++/CLI
public:
SeriesLegend();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesLegend Class
SeriesLegend Members


Clone Method

[image]
Intersoft WebGrid Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > SeriesLegend Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As System.Object
Visual Basic (Usage) Copy Code
Dim instance As SeriesLegend
Dim value As System.Object

value = instance.Clone()
C#
public virtual System.object Clone()
Delphi
public function Clone(): System.TObject; virtual;
JScript
public function Clone() : System.Object;
Managed Extensions for C++
public: virtual System.Object* Clone();
C++/CLI
public:
virtual System.Object^ Clone();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesLegend Class
SeriesLegend Members


CopyFrom Method

[image]
Intersoft WebGrid Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > SeriesLegend Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesLegend Class
SeriesLegend Members


CopyFrom(Object) Method

[image]
Intersoft WebGrid Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > SeriesLegend Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As SeriesLegend
Dim objSource As System.Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   System.object objSource
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesLegend Class
SeriesLegend Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebGrid Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > SeriesLegend Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object, _
   ByVal cloneSourceValue As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As SeriesLegend
Dim objSource As System.Object
Dim cloneSourceValue As System.Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   System.object objSource,
   System.bool cloneSourceValue
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject;
    cloneSourceValue: System.Boolean
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object,
   cloneSourceValue : System.boolean
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource,
   System.bool cloneSourceValue
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource,
   System.bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesLegend Class
SeriesLegend Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebGrid Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > SeriesLegend Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As SeriesLegend
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure DeSerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function DeSerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void DeSerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void DeSerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesLegend Class
SeriesLegend Members


GetHashCode Method

[image]
Intersoft WebGrid Documentation
GetHashCode Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > SeriesLegend Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As SeriesLegend
Dim value As System.Integer

value = instance.GetHashCode()
C#
public virtual System.int GetHashCode()
Delphi
public function GetHashCode(): System.Integer; virtual;
JScript
public function GetHashCode() : System.int;
Managed Extensions for C++
public: virtual System.int GetHashCode();
C++/CLI
public:
virtual System.int GetHashCode();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesLegend Class
SeriesLegend Members


SeriesLegend Class Methods

[image]
Intersoft WebGrid Documentation
SeriesLegend Class Methods
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : SeriesLegend Class

Glossary Item Box

For a list of all members of this type, see SeriesLegend members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

SeriesLegend Class
ISNet.WebUI.WebGrid.Chart Namespace


GetObjectData Method

[image]
Intersoft WebGrid Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > SeriesLegend Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=False,
   UnmanagedCode=False,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=True,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Action=SecurityAction.Demand,
   Unrestricted=False)>
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As SeriesLegend
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure GetObjectData(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
); override;
JScript
System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=,
   UnmanagedCode=,
   SkipVerification=,
   Execution=,
   ControlThread=,
   ControlEvidence=,
   ControlPolicy=,
   SerializationFormatter=,
   ControlDomainPolicy=,
   ControlPrincipal=,
   ControlAppDomain=,
   RemotingConfiguration=,
   Infrastructure=,
   BindingRedirects=,
   Action=SecurityAction.Demand,
   Unrestricted=)
public override function GetObjectData(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public: void GetObjectData(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
) override
C++/CLI
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public:
void GetObjectData(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
) override

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesLegend Class
SeriesLegend Members


IsEmpty Method

[image]
Intersoft WebGrid Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > SeriesLegend Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As SeriesLegend
Dim value As System.Boolean

value = instance.IsEmpty()
C#
public virtual System.bool IsEmpty()
Delphi
public function IsEmpty(): System.Boolean; virtual;
JScript
public function IsEmpty() : System.boolean;
Managed Extensions for C++
public: virtual System.bool IsEmpty();
C++/CLI
public:
virtual System.bool IsEmpty();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesLegend Class
SeriesLegend Members


Reset Method

[image]
Intersoft WebGrid Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > SeriesLegend Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As SeriesLegend

instance.Reset()
C#
public virtual void Reset()
Delphi
public procedure Reset(); virtual;
JScript
public function Reset();
Managed Extensions for C++
public: virtual void Reset();
C++/CLI
public:
virtual void Reset();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesLegend Class
SeriesLegend Members


SerializeObjectData Method

[image]
Intersoft WebGrid Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > SeriesLegend Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As SeriesLegend
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure SerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function SerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void SerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void SerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesLegend Class
SeriesLegend Members


ToString Method

[image]
Intersoft WebGrid Documentation
ToString Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > SeriesLegend Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As System.String
Visual Basic (Usage) Copy Code
Dim instance As SeriesLegend
Dim value As System.String

value = instance.ToString()
C#
public virtual System.string ToString()
Delphi
public function ToString(): System.String; virtual;
JScript
public function ToString() : System.String;
Managed Extensions for C++
public: virtual System.string* ToString();
C++/CLI
public:
virtual System.String^ ToString();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesLegend Class
SeriesLegend Members


SeriesLegend Class Properties

[image]
Intersoft WebGrid Documentation
SeriesLegend Class Properties
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : SeriesLegend Class

Glossary Item Box

For a list of all members of this type, see SeriesLegend members.

Public Properties

 | Name | Description
Public Property | Format |
Public Property | InheritSeriesShadowColor |
Public Property | InheritSeriesShadowType |
Public Property | Mode |
Public Property | ShadowStyle |
Public Property | TextStyle |
Top

See Also

Reference

SeriesLegend Class
ISNet.WebUI.WebGrid.Chart Namespace


SeriesLegend Constructor

[image]
Intersoft WebGrid Documentation
SeriesLegend Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > SeriesLegend Class : SeriesLegend Constructor

Glossary Item Box

Overload List

Overload | Description
SeriesLegend Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesLegend Class
SeriesLegend Members


Format Property

[image]
Intersoft WebGrid Documentation
Format Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > SeriesLegend Class : Format Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Defines the information which must be displayed for each data point if the Mode is set to DataPoints.")>
<System.ComponentModel.CategoryAttribute("General")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property Format As System.String
Visual Basic (Usage) Copy Code
Dim instance As SeriesLegend
Dim value As System.String

instance.Format = value

value = instance.Format
C#
[System.ComponentModel.DescriptionAttribute("Defines the information which must be displayed for each data point if the Mode is set to DataPoints.")]
[System.ComponentModel.CategoryAttribute("General")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.string Format {get; set;}
Delphi
public read-write property Format: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Defines the information which must be displayed for each data point if the Mode is set to DataPoints.")
System.ComponentModel.CategoryAttribute("General")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set Format : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Defines the information which must be displayed for each data point if the Mode is set to DataPoints.")]
[System.ComponentModel.CategoryAttribute("General")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.string* get_Format();
public: __property void set_Format(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Defines the information which must be displayed for each data point if the Mode is set to DataPoints.")]
[System.ComponentModel.CategoryAttribute("General")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.String^ Format {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesLegend Class
SeriesLegend Members


InheritSeriesShadowColor Property

[image]
Intersoft WebGrid Documentation
InheritSeriesShadowColor Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > SeriesLegend Class : InheritSeriesShadowColor Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("General")>
<System.ComponentModel.DescriptionAttribute("When set to true the legend entries created from the series will inherit the series shadow color.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
Public Property InheritSeriesShadowColor As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As SeriesLegend
Dim value As System.Boolean

instance.InheritSeriesShadowColor = value

value = instance.InheritSeriesShadowColor
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DescriptionAttribute("When set to true the legend entries created from the series will inherit the series shadow color.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public System.bool InheritSeriesShadowColor {get; set;}
Delphi
public read-write property InheritSeriesShadowColor: System.Boolean;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("General")
System.ComponentModel.DescriptionAttribute("When set to true the legend entries created from the series will inherit the series shadow color.")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
public function get,set InheritSeriesShadowColor : System.boolean
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DescriptionAttribute("When set to true the legend entries created from the series will inherit the series shadow color.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.bool get_InheritSeriesShadowColor();
public: __property void set_InheritSeriesShadowColor(
   System.bool value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DescriptionAttribute("When set to true the legend entries created from the series will inherit the series shadow color.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.bool InheritSeriesShadowColor {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesLegend Class
SeriesLegend Members


InheritSeriesShadowType Property

[image]
Intersoft WebGrid Documentation
InheritSeriesShadowType Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > SeriesLegend Class : InheritSeriesShadowType Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("General")>
<System.ComponentModel.DescriptionAttribute("When set to true the legend entries created from the series will inherit the series shadow type.")>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property InheritSeriesShadowType As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As SeriesLegend
Dim value As System.Boolean

instance.InheritSeriesShadowType = value

value = instance.InheritSeriesShadowType
C#
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DescriptionAttribute("When set to true the legend entries created from the series will inherit the series shadow type.")]
[ISNet.Serialization.BinarySerializableAttribute()]
public System.bool InheritSeriesShadowType {get; set;}
Delphi
public read-write property InheritSeriesShadowType: System.Boolean;
JScript
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("General")
System.ComponentModel.DescriptionAttribute("When set to true the legend entries created from the series will inherit the series shadow type.")
ISNet.Serialization.BinarySerializableAttribute()
public function get,set InheritSeriesShadowType : System.boolean
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DescriptionAttribute("When set to true the legend entries created from the series will inherit the series shadow type.")]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.bool get_InheritSeriesShadowType();
public: __property void set_InheritSeriesShadowType(
   System.bool value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DescriptionAttribute("When set to true the legend entries created from the series will inherit the series shadow type.")]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.bool InheritSeriesShadowType {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesLegend Class
SeriesLegend Members


Mode Property

[image]
Intersoft WebGrid Documentation
Mode Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > SeriesLegend Class : Mode Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("General")>
<System.ComponentModel.DescriptionAttribute("Determines the mode in which the legend is filled with information about the series.")>
Public Property Mode As SeriesLegendMode
Visual Basic (Usage) Copy Code
Dim instance As SeriesLegend
Dim value As SeriesLegendMode

instance.Mode = value

value = instance.Mode
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DescriptionAttribute("Determines the mode in which the legend is filled with information about the series.")]
public SeriesLegendMode Mode {get; set;}
Delphi
public read-write property Mode: SeriesLegendMode;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("General")
System.ComponentModel.DescriptionAttribute("Determines the mode in which the legend is filled with information about the series.")
public function get,set Mode : SeriesLegendMode
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DescriptionAttribute("Determines the mode in which the legend is filled with information about the series.")]
public: __property SeriesLegendMode get_Mode();
public: __property void set_Mode(
   SeriesLegendMode value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DescriptionAttribute("Determines the mode in which the legend is filled with information about the series.")]
public:
property SeriesLegendMode Mode {
   SeriesLegendMode get();
   void set (    SeriesLegendMode value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesLegend Class
SeriesLegend Members


ShadowStyle Property

[image]
Intersoft WebGrid Documentation
ShadowStyle Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > SeriesLegend Class : ShadowStyle Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute("setShadowStyle")>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.DescriptionAttribute("Defines the shadow style used to display the series legend entries.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<System.ComponentModel.CategoryAttribute("General")>
Public ReadOnly Property ShadowStyle As ChartShadowStyle
Visual Basic (Usage) Copy Code
Dim instance As SeriesLegend
Dim value As ChartShadowStyle

value = instance.ShadowStyle
C#
[ISNet.Serialization.BinarySerializableAttribute("setShadowStyle")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DescriptionAttribute("Defines the shadow style used to display the series legend entries.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.CategoryAttribute("General")]
public ChartShadowStyle ShadowStyle {get;}
Delphi
public read-only property ShadowStyle: ChartShadowStyle;
JScript
ISNet.Serialization.BinarySerializableAttribute("setShadowStyle")
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.DescriptionAttribute("Defines the shadow style used to display the series legend entries.")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
System.ComponentModel.CategoryAttribute("General")
public function get ShadowStyle : ChartShadowStyle
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute("setShadowStyle")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DescriptionAttribute("Defines the shadow style used to display the series legend entries.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.CategoryAttribute("General")]
public: __property ChartShadowStyle* get_ShadowStyle();
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute("setShadowStyle")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DescriptionAttribute("Defines the shadow style used to display the series legend entries.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.CategoryAttribute("General")]
public:
property ChartShadowStyle^ ShadowStyle {
   ChartShadowStyle^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesLegend Class
SeriesLegend Members


TextStyle Property

[image]
Intersoft WebGrid Documentation
TextStyle Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > SeriesLegend Class : TextStyle Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("General")>
<ISNet.Serialization.BinarySerializableAttribute("setTextStyle")>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<System.ComponentModel.DefaultValueAttribute()>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.DescriptionAttribute("Defines the text style used to display the series legend entries.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public ReadOnly Property TextStyle As ChartTextStyle
Visual Basic (Usage) Copy Code
Dim instance As SeriesLegend
Dim value As ChartTextStyle

value = instance.TextStyle
C#
[System.ComponentModel.CategoryAttribute("General")]
[ISNet.Serialization.BinarySerializableAttribute("setTextStyle")]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DefaultValueAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DescriptionAttribute("Defines the text style used to display the series legend entries.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public ChartTextStyle TextStyle {get;}
Delphi
public read-only property TextStyle: ChartTextStyle;
JScript
System.ComponentModel.CategoryAttribute("General")
ISNet.Serialization.BinarySerializableAttribute("setTextStyle")
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
System.ComponentModel.DefaultValueAttribute()
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.DescriptionAttribute("Defines the text style used to display the series legend entries.")
System.ComponentModel.NotifyParentPropertyAttribute()
public function get TextStyle : ChartTextStyle
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("General")]
[ISNet.Serialization.BinarySerializableAttribute("setTextStyle")]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DefaultValueAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DescriptionAttribute("Defines the text style used to display the series legend entries.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property ChartTextStyle* get_TextStyle();
C++/CLI
[System.ComponentModel.CategoryAttribute("General")]
[ISNet.Serialization.BinarySerializableAttribute("setTextStyle")]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DefaultValueAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DescriptionAttribute("Defines the text style used to display the series legend entries.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property ChartTextStyle^ TextStyle {
   ChartTextStyle^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesLegend Class
SeriesLegend Members


SeriesLine Class

[image]
Intersoft WebGrid Documentation
SeriesLine Class
Members See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : SeriesLine Class

Glossary Item Box

Object Model

SeriesLine Class

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.SerializableAttribute()>
Public Class SeriesLine
   Inherits SeriesLineBase
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Visual Basic (Usage) Copy Code
Dim instance As SeriesLine
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public class SeriesLine : SeriesLineBase, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Delphi
public class SeriesLine = class(SeriesLineBase, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize)
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.SerializableAttribute()
public class SeriesLine extends SeriesLineBase implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public __gc class SeriesLine : public SeriesLineBase, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public ref class SeriesLine : public SeriesLineBase, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.WebGrid.Chart.SeriesBase
ISNet.WebUI.WebGrid.Chart.Series
ISNet.WebUI.WebGrid.Chart.SeriesXYScatter
ISNet.WebUI.WebGrid.Chart.SeriesXYZScatter
ISNet.WebUI.WebGrid.Chart.SeriesLineBase
ISNet.WebUI.WebGrid.Chart.SeriesLine

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesLine Members
ISNet.WebUI.WebGrid.Chart Namespace


SeriesLine Class Members

[image]
Intersoft WebGrid Documentation
SeriesLine Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : SeriesLine Class

Glossary Item Box

The following tables list the members exposed by SeriesLine.

Public Constructors

 | Name | Description
Public Constructor | SeriesLine Constructor |
Top

Public Properties

 | Name | Description
Public Property | BevelAndEmbossImageFilter | (Inherited from ISNet.WebUI.WebGrid.Chart.Series)
Public Property | BlurImageFilter | (Inherited from ISNet.WebUI.WebGrid.Chart.Series)
Public Property | BorderStyle | (Inherited from ISNet.WebUI.WebGrid.Chart.Series)
Public Property | ChartFillType | (Inherited from ISNet.WebUI.WebGrid.Chart.Series)
Public Property | DataLabelStyle | (Inherited from ISNet.WebUI.WebGrid.Chart.Series)
Public Property | DepthPercent |
Public Property | EmptyDataPointStyle | (Inherited from ISNet.WebUI.WebGrid.Chart.Series)
Public Property | GlowImageFilter | (Inherited from ISNet.WebUI.WebGrid.Chart.Series)
Public Property | InteractiveStyle | (Inherited from ISNet.WebUI.WebGrid.Chart.Series)
Public Property | LightingImageFilter | (Inherited from ISNet.WebUI.WebGrid.Chart.Series)
Public Property | LineSegmentShape |
Public Property | LineSize |
Public Property | SeriesLegend | (Inherited from ISNet.WebUI.WebGrid.Chart.SeriesBase)
Public Property | ShadowStyle | (Inherited from ISNet.WebUI.WebGrid.Chart.SeriesBase)
Public Property | Visible | (Inherited from ISNet.WebUI.WebGrid.Chart.SeriesBase)
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

SeriesLine Class
ISNet.WebUI.WebGrid.Chart Namespace


SeriesLine Constructor

[image]
Intersoft WebGrid Documentation
SeriesLine Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > SeriesLine Class : SeriesLine Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New SeriesLine()
C#
public SeriesLine()
Delphi
public SeriesLine();
JScript
public function SeriesLine();
Managed Extensions for C++
public: SeriesLine();
C++/CLI
public:
SeriesLine();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesLine Class
SeriesLine Members


Clone Method

[image]
Intersoft WebGrid Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > SeriesLine Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As System.Object
Visual Basic (Usage) Copy Code
Dim instance As SeriesLine
Dim value As System.Object

value = instance.Clone()
C#
public virtual System.object Clone()
Delphi
public function Clone(): System.TObject; virtual;
JScript
public function Clone() : System.Object;
Managed Extensions for C++
public: virtual System.Object* Clone();
C++/CLI
public:
virtual System.Object^ Clone();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesLine Class
SeriesLine Members


CopyFrom Method

[image]
Intersoft WebGrid Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > SeriesLine Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesLine Class
SeriesLine Members


CopyFrom(Object) Method

[image]
Intersoft WebGrid Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > SeriesLine Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As SeriesLine
Dim objSource As System.Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   System.object objSource
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesLine Class
SeriesLine Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebGrid Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > SeriesLine Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object, _
   ByVal cloneSourceValue As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As SeriesLine
Dim objSource As System.Object
Dim cloneSourceValue As System.Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   System.object objSource,
   System.bool cloneSourceValue
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject;
    cloneSourceValue: System.Boolean
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object,
   cloneSourceValue : System.boolean
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource,
   System.bool cloneSourceValue
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource,
   System.bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesLine Class
SeriesLine Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebGrid Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > SeriesLine Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As SeriesLine
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure DeSerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function DeSerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void DeSerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void DeSerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesLine Class
SeriesLine Members


GetHashCode Method

[image]
Intersoft WebGrid Documentation
GetHashCode Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > SeriesLine Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As SeriesLine
Dim value As System.Integer

value = instance.GetHashCode()
C#
public virtual System.int GetHashCode()
Delphi
public function GetHashCode(): System.Integer; virtual;
JScript
public function GetHashCode() : System.int;
Managed Extensions for C++
public: virtual System.int GetHashCode();
C++/CLI
public:
virtual System.int GetHashCode();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesLine Class
SeriesLine Members


SeriesLine Class Methods

[image]
Intersoft WebGrid Documentation
SeriesLine Class Methods
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : SeriesLine Class

Glossary Item Box

For a list of all members of this type, see SeriesLine members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

SeriesLine Class
ISNet.WebUI.WebGrid.Chart Namespace


GetObjectData Method

[image]
Intersoft WebGrid Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > SeriesLine Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=False,
   UnmanagedCode=False,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=True,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Action=SecurityAction.Demand,
   Unrestricted=False)>
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As SeriesLine
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure GetObjectData(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
); override;
JScript
System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=,
   UnmanagedCode=,
   SkipVerification=,
   Execution=,
   ControlThread=,
   ControlEvidence=,
   ControlPolicy=,
   SerializationFormatter=,
   ControlDomainPolicy=,
   ControlPrincipal=,
   ControlAppDomain=,
   RemotingConfiguration=,
   Infrastructure=,
   BindingRedirects=,
   Action=SecurityAction.Demand,
   Unrestricted=)
public override function GetObjectData(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public: void GetObjectData(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
) override
C++/CLI
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public:
void GetObjectData(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
) override

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesLine Class
SeriesLine Members


IsEmpty Method

[image]
Intersoft WebGrid Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > SeriesLine Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As SeriesLine
Dim value As System.Boolean

value = instance.IsEmpty()
C#
public virtual System.bool IsEmpty()
Delphi
public function IsEmpty(): System.Boolean; virtual;
JScript
public function IsEmpty() : System.boolean;
Managed Extensions for C++
public: virtual System.bool IsEmpty();
C++/CLI
public:
virtual System.bool IsEmpty();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesLine Class
SeriesLine Members


Reset Method

[image]
Intersoft WebGrid Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > SeriesLine Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As SeriesLine

instance.Reset()
C#
public virtual void Reset()
Delphi
public procedure Reset(); virtual;
JScript
public function Reset();
Managed Extensions for C++
public: virtual void Reset();
C++/CLI
public:
virtual void Reset();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesLine Class
SeriesLine Members


SerializeObjectData Method

[image]
Intersoft WebGrid Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > SeriesLine Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As SeriesLine
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure SerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function SerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void SerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void SerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesLine Class
SeriesLine Members


ToString Method

[image]
Intersoft WebGrid Documentation
ToString Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > SeriesLine Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As System.String
Visual Basic (Usage) Copy Code
Dim instance As SeriesLine
Dim value As System.String

value = instance.ToString()
C#
public virtual System.string ToString()
Delphi
public function ToString(): System.String; virtual;
JScript
public function ToString() : System.String;
Managed Extensions for C++
public: virtual System.string* ToString();
C++/CLI
public:
virtual System.String^ ToString();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesLine Class
SeriesLine Members


SeriesLine Class Properties

[image]
Intersoft WebGrid Documentation
SeriesLine Class Properties
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : SeriesLine Class

Glossary Item Box

For a list of all members of this type, see SeriesLine members.

Public Properties

 | Name | Description
Public Property | BevelAndEmbossImageFilter | (Inherited from ISNet.WebUI.WebGrid.Chart.Series)
Public Property | BlurImageFilter | (Inherited from ISNet.WebUI.WebGrid.Chart.Series)
Public Property | BorderStyle | (Inherited from ISNet.WebUI.WebGrid.Chart.Series)
Public Property | ChartFillType | (Inherited from ISNet.WebUI.WebGrid.Chart.Series)
Public Property | DataLabelStyle | (Inherited from ISNet.WebUI.WebGrid.Chart.Series)
Public Property | DepthPercent |
Public Property | EmptyDataPointStyle | (Inherited from ISNet.WebUI.WebGrid.Chart.Series)
Public Property | GlowImageFilter | (Inherited from ISNet.WebUI.WebGrid.Chart.Series)
Public Property | InteractiveStyle | (Inherited from ISNet.WebUI.WebGrid.Chart.Series)
Public Property | LightingImageFilter | (Inherited from ISNet.WebUI.WebGrid.Chart.Series)
Public Property | LineSegmentShape |
Public Property | LineSize |
Public Property | SeriesLegend | (Inherited from ISNet.WebUI.WebGrid.Chart.SeriesBase)
Public Property | ShadowStyle | (Inherited from ISNet.WebUI.WebGrid.Chart.SeriesBase)
Public Property | Visible | (Inherited from ISNet.WebUI.WebGrid.Chart.SeriesBase)
Top

See Also

Reference

SeriesLine Class
ISNet.WebUI.WebGrid.Chart Namespace


SeriesLine Constructor

[image]
Intersoft WebGrid Documentation
SeriesLine Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > SeriesLine Class : SeriesLine Constructor

Glossary Item Box

Overload List

Overload | Description
SeriesLine Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesLine Class
SeriesLine Members


DepthPercent Property

[image]
Intersoft WebGrid Documentation
DepthPercent Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > SeriesLine Class : DepthPercent Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Controls the depth of the line in percents of the series depth when the LineSegmentShape is set to Tape, Tube or Ellipsoid.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("Options")>
Public Property DepthPercent As System.Single
Visual Basic (Usage) Copy Code
Dim instance As SeriesLine
Dim value As System.Single

instance.DepthPercent = value

value = instance.DepthPercent
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Controls the depth of the line in percents of the series depth when the LineSegmentShape is set to Tape, Tube or Ellipsoid.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Options")]
public System.float DepthPercent {get; set;}
Delphi
public read-write property DepthPercent: System.Single;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Controls the depth of the line in percents of the series depth when the LineSegmentShape is set to Tape, Tube or Ellipsoid.")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("Options")
public function get,set DepthPercent : System.float
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Controls the depth of the line in percents of the series depth when the LineSegmentShape is set to Tape, Tube or Ellipsoid.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Options")]
public: __property System.float get_DepthPercent();
public: __property void set_DepthPercent(
   System.float value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Controls the depth of the line in percents of the series depth when the LineSegmentShape is set to Tape, Tube or Ellipsoid.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Options")]
public:
property System.float DepthPercent {
   System.float get();
   void set (    System.float value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesLine Class
SeriesLine Members


LineSegmentShape Property

[image]
Intersoft WebGrid Documentation
LineSegmentShape Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > SeriesLine Class : LineSegmentShape Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Controls the style of the lines.")>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Options")>
Public Property LineSegmentShape As LineSegmentShape
Visual Basic (Usage) Copy Code
Dim instance As SeriesLine
Dim value As LineSegmentShape

instance.LineSegmentShape = value

value = instance.LineSegmentShape
C#
[System.ComponentModel.DescriptionAttribute("Controls the style of the lines.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Options")]
public LineSegmentShape LineSegmentShape {get; set;}
Delphi
public read-write property LineSegmentShape: LineSegmentShape;
JScript
System.ComponentModel.DescriptionAttribute("Controls the style of the lines.")
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Options")
public function get,set LineSegmentShape : LineSegmentShape
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Controls the style of the lines.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Options")]
public: __property LineSegmentShape get_LineSegmentShape();
public: __property void set_LineSegmentShape(
   LineSegmentShape value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Controls the style of the lines.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Options")]
public:
property LineSegmentShape LineSegmentShape {
   LineSegmentShape get();
   void set (    LineSegmentShape value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesLine Class
SeriesLine Members


LineSize Property

[image]
Intersoft WebGrid Documentation
LineSize Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > SeriesLine Class : LineSize Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Controls the diameter of the tube / ellipsoid segments. Controls the depth of the tape segments in Z scatter mode.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Options")>
Public Property LineSize As System.Nullable(Of Single)
Visual Basic (Usage) Copy Code
Dim instance As SeriesLine
Dim value As System.Nullable(Of Single)

instance.LineSize = value

value = instance.LineSize
C#
[System.ComponentModel.DescriptionAttribute("Controls the diameter of the tube / ellipsoid segments. Controls the depth of the tape segments in Z scatter mode.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Options")]
public System.Nullable<float> LineSize {get; set;}
Delphi
public read-write property LineSize: System.Nullable;
JScript
System.ComponentModel.DescriptionAttribute("Controls the diameter of the tube / ellipsoid segments. Controls the depth of the tape segments in Z scatter mode.")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Options")
public function get,set LineSize : System.Nullable
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Controls the diameter of the tube / ellipsoid segments. Controls the depth of the tape segments in Z scatter mode.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Options")]
public: __property System.Nullable<float> get_LineSize();
public: __property void set_LineSize(
   System.Nullable<float> value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Controls the diameter of the tube / ellipsoid segments. Controls the depth of the tape segments in Z scatter mode.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Options")]
public:
property System.Nullable<float> LineSize {
   System.Nullable<float> get();
   void set (    System.Nullable<float> value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesLine Class
SeriesLine Members


SeriesLineBase Class

[image]
Intersoft WebGrid Documentation
SeriesLineBase Class
Members See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : SeriesLineBase Class

Glossary Item Box

Object Model

SeriesLineBase Class

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.SerializableAttribute()>
Public Class SeriesLineBase
   Inherits SeriesXYZScatter
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Visual Basic (Usage) Copy Code
Dim instance As SeriesLineBase
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public class SeriesLineBase : SeriesXYZScatter, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Delphi
public class SeriesLineBase = class(SeriesXYZScatter, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize)
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.SerializableAttribute()
public class SeriesLineBase extends SeriesXYZScatter implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public __gc class SeriesLineBase : public SeriesXYZScatter, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public ref class SeriesLineBase : public SeriesXYZScatter, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.WebGrid.Chart.SeriesBase
ISNet.WebUI.WebGrid.Chart.Series
ISNet.WebUI.WebGrid.Chart.SeriesXYScatter
ISNet.WebUI.WebGrid.Chart.SeriesXYZScatter
ISNet.WebUI.WebGrid.Chart.SeriesLineBase
ISNet.WebUI.WebGrid.Chart.SeriesLine
ISNet.WebUI.WebGrid.Chart.SeriesSmoothLine
ISNet.WebUI.WebGrid.Chart.SeriesStepLine

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesLineBase Members
ISNet.WebUI.WebGrid.Chart Namespace


SeriesLineBase Class Members

[image]
Intersoft WebGrid Documentation
SeriesLineBase Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : SeriesLineBase Class

Glossary Item Box

The following tables list the members exposed by SeriesLineBase.

Public Constructors

 | Name | Description
Public Constructor | SeriesLineBase Constructor |
Top

Public Properties

 | Name | Description
Public Property | BevelAndEmbossImageFilter | (Inherited from ISNet.WebUI.WebGrid.Chart.Series)
Public Property | BlurImageFilter | (Inherited from ISNet.WebUI.WebGrid.Chart.Series)
Public Property | BorderStyle | (Inherited from ISNet.WebUI.WebGrid.Chart.Series)
Public Property | ChartFillType | (Inherited from ISNet.WebUI.WebGrid.Chart.Series)
Public Property | DataLabelStyle | (Inherited from ISNet.WebUI.WebGrid.Chart.Series)
Public Property | EmptyDataPointStyle | (Inherited from ISNet.WebUI.WebGrid.Chart.Series)
Public Property | GlowImageFilter | (Inherited from ISNet.WebUI.WebGrid.Chart.Series)
Public Property | InteractiveStyle | (Inherited from ISNet.WebUI.WebGrid.Chart.Series)
Public Property | LightingImageFilter | (Inherited from ISNet.WebUI.WebGrid.Chart.Series)
Public Property | SeriesLegend | (Inherited from ISNet.WebUI.WebGrid.Chart.SeriesBase)
Public Property | ShadowStyle | (Inherited from ISNet.WebUI.WebGrid.Chart.SeriesBase)
Public Property | Visible | (Inherited from ISNet.WebUI.WebGrid.Chart.SeriesBase)
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

SeriesLineBase Class
ISNet.WebUI.WebGrid.Chart Namespace


SeriesLineBase Constructor

[image]
Intersoft WebGrid Documentation
SeriesLineBase Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > SeriesLineBase Class : SeriesLineBase Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New SeriesLineBase()
C#
public SeriesLineBase()
Delphi
public SeriesLineBase();
JScript
public function SeriesLineBase();
Managed Extensions for C++
public: SeriesLineBase();
C++/CLI
public:
SeriesLineBase();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesLineBase Class
SeriesLineBase Members


Clone Method

[image]
Intersoft WebGrid Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > SeriesLineBase Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As System.Object
Visual Basic (Usage) Copy Code
Dim instance As SeriesLineBase
Dim value As System.Object

value = instance.Clone()
C#
public virtual System.object Clone()
Delphi
public function Clone(): System.TObject; virtual;
JScript
public function Clone() : System.Object;
Managed Extensions for C++
public: virtual System.Object* Clone();
C++/CLI
public:
virtual System.Object^ Clone();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesLineBase Class
SeriesLineBase Members


CopyFrom Method

[image]
Intersoft WebGrid Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > SeriesLineBase Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesLineBase Class
SeriesLineBase Members


CopyFrom(Object) Method

[image]
Intersoft WebGrid Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > SeriesLineBase Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As SeriesLineBase
Dim objSource As System.Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   System.object objSource
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesLineBase Class
SeriesLineBase Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebGrid Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > SeriesLineBase Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object, _
   ByVal cloneSourceValue As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As SeriesLineBase
Dim objSource As System.Object
Dim cloneSourceValue As System.Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   System.object objSource,
   System.bool cloneSourceValue
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject;
    cloneSourceValue: System.Boolean
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object,
   cloneSourceValue : System.boolean
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource,
   System.bool cloneSourceValue
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource,
   System.bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesLineBase Class
SeriesLineBase Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebGrid Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > SeriesLineBase Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As SeriesLineBase
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure DeSerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function DeSerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void DeSerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void DeSerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesLineBase Class
SeriesLineBase Members


GetHashCode Method

[image]
Intersoft WebGrid Documentation
GetHashCode Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > SeriesLineBase Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As SeriesLineBase
Dim value As System.Integer

value = instance.GetHashCode()
C#
public virtual System.int GetHashCode()
Delphi
public function GetHashCode(): System.Integer; virtual;
JScript
public function GetHashCode() : System.int;
Managed Extensions for C++
public: virtual System.int GetHashCode();
C++/CLI
public:
virtual System.int GetHashCode();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesLineBase Class
SeriesLineBase Members


SeriesLineBase Class Methods

[image]
Intersoft WebGrid Documentation
SeriesLineBase Class Methods
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : SeriesLineBase Class

Glossary Item Box

For a list of all members of this type, see SeriesLineBase members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

SeriesLineBase Class
ISNet.WebUI.WebGrid.Chart Namespace


SeriesLineBase Class Properties

[image]
Intersoft WebGrid Documentation
SeriesLineBase Class Properties
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : SeriesLineBase Class

Glossary Item Box

For a list of all members of this type, see SeriesLineBase members.

Public Properties

 | Name | Description
Public Property | BevelAndEmbossImageFilter | (Inherited from ISNet.WebUI.WebGrid.Chart.Series)
Public Property | BlurImageFilter | (Inherited from ISNet.WebUI.WebGrid.Chart.Series)
Public Property | BorderStyle | (Inherited from ISNet.WebUI.WebGrid.Chart.Series)
Public Property | ChartFillType | (Inherited from ISNet.WebUI.WebGrid.Chart.Series)
Public Property | DataLabelStyle | (Inherited from ISNet.WebUI.WebGrid.Chart.Series)
Public Property | EmptyDataPointStyle | (Inherited from ISNet.WebUI.WebGrid.Chart.Series)
Public Property | GlowImageFilter | (Inherited from ISNet.WebUI.WebGrid.Chart.Series)
Public Property | InteractiveStyle | (Inherited from ISNet.WebUI.WebGrid.Chart.Series)
Public Property | LightingImageFilter | (Inherited from ISNet.WebUI.WebGrid.Chart.Series)
Public Property | SeriesLegend | (Inherited from ISNet.WebUI.WebGrid.Chart.SeriesBase)
Public Property | ShadowStyle | (Inherited from ISNet.WebUI.WebGrid.Chart.SeriesBase)
Public Property | Visible | (Inherited from ISNet.WebUI.WebGrid.Chart.SeriesBase)
Top

See Also

Reference

SeriesLineBase Class
ISNet.WebUI.WebGrid.Chart Namespace


SeriesLineBase Constructor

[image]
Intersoft WebGrid Documentation
SeriesLineBase Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > SeriesLineBase Class : SeriesLineBase Constructor

Glossary Item Box

Overload List

Overload | Description
SeriesLineBase Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesLineBase Class
SeriesLineBase Members


GetObjectData Method

[image]
Intersoft WebGrid Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > SeriesLineBase Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=False,
   UnmanagedCode=False,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=True,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Action=SecurityAction.Demand,
   Unrestricted=False)>
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As SeriesLineBase
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure GetObjectData(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
); override;
JScript
System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=,
   UnmanagedCode=,
   SkipVerification=,
   Execution=,
   ControlThread=,
   ControlEvidence=,
   ControlPolicy=,
   SerializationFormatter=,
   ControlDomainPolicy=,
   ControlPrincipal=,
   ControlAppDomain=,
   RemotingConfiguration=,
   Infrastructure=,
   BindingRedirects=,
   Action=SecurityAction.Demand,
   Unrestricted=)
public override function GetObjectData(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public: void GetObjectData(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
) override
C++/CLI
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public:
void GetObjectData(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
) override

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesLineBase Class
SeriesLineBase Members


IsEmpty Method

[image]
Intersoft WebGrid Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > SeriesLineBase Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As SeriesLineBase
Dim value As System.Boolean

value = instance.IsEmpty()
C#
public virtual System.bool IsEmpty()
Delphi
public function IsEmpty(): System.Boolean; virtual;
JScript
public function IsEmpty() : System.boolean;
Managed Extensions for C++
public: virtual System.bool IsEmpty();
C++/CLI
public:
virtual System.bool IsEmpty();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesLineBase Class
SeriesLineBase Members


Reset Method

[image]
Intersoft WebGrid Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > SeriesLineBase Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As SeriesLineBase

instance.Reset()
C#
public virtual void Reset()
Delphi
public procedure Reset(); virtual;
JScript
public function Reset();
Managed Extensions for C++
public: virtual void Reset();
C++/CLI
public:
virtual void Reset();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesLineBase Class
SeriesLineBase Members


SerializeObjectData Method

[image]
Intersoft WebGrid Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > SeriesLineBase Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As SeriesLineBase
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure SerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function SerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void SerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void SerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesLineBase Class
SeriesLineBase Members


ToString Method

[image]
Intersoft WebGrid Documentation
ToString Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > SeriesLineBase Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As System.String
Visual Basic (Usage) Copy Code
Dim instance As SeriesLineBase
Dim value As System.String

value = instance.ToString()
C#
public virtual System.string ToString()
Delphi
public function ToString(): System.String; virtual;
JScript
public function ToString() : System.String;
Managed Extensions for C++
public: virtual System.string* ToString();
C++/CLI
public:
virtual System.String^ ToString();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesLineBase Class
SeriesLineBase Members


SeriesPie Class

[image]
Intersoft WebGrid Documentation
SeriesPie Class
Members See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : SeriesPie Class

Glossary Item Box

Object Model

SeriesPie Class

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.SerializableAttribute()>
Public Class SeriesPie
   Inherits Series
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Visual Basic (Usage) Copy Code
Dim instance As SeriesPie
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public class SeriesPie : Series, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Delphi
public class SeriesPie = class(Series, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize)
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.SerializableAttribute()
public class SeriesPie extends Series implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public __gc class SeriesPie : public Series, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public ref class SeriesPie : public Series, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.WebGrid.Chart.SeriesBase
ISNet.WebUI.WebGrid.Chart.Series
ISNet.WebUI.WebGrid.Chart.SeriesPie

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesPie Members
ISNet.WebUI.WebGrid.Chart Namespace


SeriesPie Class Members

[image]
Intersoft WebGrid Documentation
SeriesPie Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : SeriesPie Class

Glossary Item Box

The following tables list the members exposed by SeriesPie.

Public Constructors

 | Name | Description
Public Constructor | SeriesPie Constructor |
Top

Public Properties

 | Name | Description
Public Property | BeginAngle |
Public Property | BevelAndEmbossImageFilter | (Inherited from ISNet.WebUI.WebGrid.Chart.Series)
Public Property | BlurImageFilter | (Inherited from ISNet.WebUI.WebGrid.Chart.Series)
Public Property | BorderStyle | (Inherited from ISNet.WebUI.WebGrid.Chart.Series)
Public Property | ChartFillType | (Inherited from ISNet.WebUI.WebGrid.Chart.Series)
Public Property | ClockwiseDirection |
Public Property | DataLabelStyle | (Inherited from ISNet.WebUI.WebGrid.Chart.Series)
Public Property | EmptyDataPointStyle | (Inherited from ISNet.WebUI.WebGrid.Chart.Series)
Public Property | ExplodeMode |
Public Property | Explosion |
Public Property | GlowImageFilter | (Inherited from ISNet.WebUI.WebGrid.Chart.Series)
Public Property | InnerRadius |
Public Property | InteractiveStyle | (Inherited from ISNet.WebUI.WebGrid.Chart.Series)
Public Property | LabelMode |
Public Property | LightingImageFilter | (Inherited from ISNet.WebUI.WebGrid.Chart.Series)
Public Property | PieEdgePercent |
Public Property | PieStyle |
Public Property | Radius |
Public Property | SeriesLegend | (Inherited from ISNet.WebUI.WebGrid.Chart.SeriesBase)
Public Property | ShadowStyle | (Inherited from ISNet.WebUI.WebGrid.Chart.SeriesBase)
Public Property | TotalAngle |
Public Property | Visible | (Inherited from ISNet.WebUI.WebGrid.Chart.SeriesBase)
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

SeriesPie Class
ISNet.WebUI.WebGrid.Chart Namespace


SeriesPie Constructor

[image]
Intersoft WebGrid Documentation
SeriesPie Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > SeriesPie Class : SeriesPie Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New SeriesPie()
C#
public SeriesPie()
Delphi
public SeriesPie();
JScript
public function SeriesPie();
Managed Extensions for C++
public: SeriesPie();
C++/CLI
public:
SeriesPie();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesPie Class
SeriesPie Members


Clone Method

[image]
Intersoft WebGrid Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > SeriesPie Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As System.Object
Visual Basic (Usage) Copy Code
Dim instance As SeriesPie
Dim value As System.Object

value = instance.Clone()
C#
public virtual System.object Clone()
Delphi
public function Clone(): System.TObject; virtual;
JScript
public function Clone() : System.Object;
Managed Extensions for C++
public: virtual System.Object* Clone();
C++/CLI
public:
virtual System.Object^ Clone();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesPie Class
SeriesPie Members


CopyFrom Method

[image]
Intersoft WebGrid Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > SeriesPie Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesPie Class
SeriesPie Members


CopyFrom(Object) Method

[image]
Intersoft WebGrid Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > SeriesPie Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As SeriesPie
Dim objSource As System.Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   System.object objSource
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesPie Class
SeriesPie Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebGrid Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > SeriesPie Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object, _
   ByVal cloneSourceValue As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As SeriesPie
Dim objSource As System.Object
Dim cloneSourceValue As System.Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   System.object objSource,
   System.bool cloneSourceValue
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject;
    cloneSourceValue: System.Boolean
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object,
   cloneSourceValue : System.boolean
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource,
   System.bool cloneSourceValue
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource,
   System.bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesPie Class
SeriesPie Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebGrid Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > SeriesPie Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As SeriesPie
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure DeSerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function DeSerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void DeSerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void DeSerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesPie Class
SeriesPie Members


GetHashCode Method

[image]
Intersoft WebGrid Documentation
GetHashCode Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > SeriesPie Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As SeriesPie
Dim value As System.Integer

value = instance.GetHashCode()
C#
public virtual System.int GetHashCode()
Delphi
public function GetHashCode(): System.Integer; virtual;
JScript
public function GetHashCode() : System.int;
Managed Extensions for C++
public: virtual System.int GetHashCode();
C++/CLI
public:
virtual System.int GetHashCode();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesPie Class
SeriesPie Members


SeriesPie Class Methods

[image]
Intersoft WebGrid Documentation
SeriesPie Class Methods
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : SeriesPie Class

Glossary Item Box

For a list of all members of this type, see SeriesPie members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

SeriesPie Class
ISNet.WebUI.WebGrid.Chart Namespace


GetObjectData Method

[image]
Intersoft WebGrid Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > SeriesPie Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=False,
   UnmanagedCode=False,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=True,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Action=SecurityAction.Demand,
   Unrestricted=False)>
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As SeriesPie
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure GetObjectData(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
); override;
JScript
System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=,
   UnmanagedCode=,
   SkipVerification=,
   Execution=,
   ControlThread=,
   ControlEvidence=,
   ControlPolicy=,
   SerializationFormatter=,
   ControlDomainPolicy=,
   ControlPrincipal=,
   ControlAppDomain=,
   RemotingConfiguration=,
   Infrastructure=,
   BindingRedirects=,
   Action=SecurityAction.Demand,
   Unrestricted=)
public override function GetObjectData(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public: void GetObjectData(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
) override
C++/CLI
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public:
void GetObjectData(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
) override

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesPie Class
SeriesPie Members


IsEmpty Method

[image]
Intersoft WebGrid Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > SeriesPie Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As SeriesPie
Dim value As System.Boolean

value = instance.IsEmpty()
C#
public virtual System.bool IsEmpty()
Delphi
public function IsEmpty(): System.Boolean; virtual;
JScript
public function IsEmpty() : System.boolean;
Managed Extensions for C++
public: virtual System.bool IsEmpty();
C++/CLI
public:
virtual System.bool IsEmpty();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesPie Class
SeriesPie Members


Reset Method

[image]
Intersoft WebGrid Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > SeriesPie Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As SeriesPie

instance.Reset()
C#
public virtual void Reset()
Delphi
public procedure Reset(); virtual;
JScript
public function Reset();
Managed Extensions for C++
public: virtual void Reset();
C++/CLI
public:
virtual void Reset();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesPie Class
SeriesPie Members


SerializeObjectData Method

[image]
Intersoft WebGrid Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > SeriesPie Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As SeriesPie
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure SerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function SerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void SerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void SerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesPie Class
SeriesPie Members


ToString Method

[image]
Intersoft WebGrid Documentation
ToString Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > SeriesPie Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As System.String
Visual Basic (Usage) Copy Code
Dim instance As SeriesPie
Dim value As System.String

value = instance.ToString()
C#
public virtual System.string ToString()
Delphi
public function ToString(): System.String; virtual;
JScript
public function ToString() : System.String;
Managed Extensions for C++
public: virtual System.string* ToString();
C++/CLI
public:
virtual System.String^ ToString();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesPie Class
SeriesPie Members


SeriesPie Class Properties

[image]
Intersoft WebGrid Documentation
SeriesPie Class Properties
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : SeriesPie Class

Glossary Item Box

For a list of all members of this type, see SeriesPie members.

Public Properties

 | Name | Description
Public Property | BeginAngle |
Public Property | BevelAndEmbossImageFilter | (Inherited from ISNet.WebUI.WebGrid.Chart.Series)
Public Property | BlurImageFilter | (Inherited from ISNet.WebUI.WebGrid.Chart.Series)
Public Property | BorderStyle | (Inherited from ISNet.WebUI.WebGrid.Chart.Series)
Public Property | ChartFillType | (Inherited from ISNet.WebUI.WebGrid.Chart.Series)
Public Property | ClockwiseDirection |
Public Property | DataLabelStyle | (Inherited from ISNet.WebUI.WebGrid.Chart.Series)
Public Property | EmptyDataPointStyle | (Inherited from ISNet.WebUI.WebGrid.Chart.Series)
Public Property | ExplodeMode |
Public Property | Explosion |
Public Property | GlowImageFilter | (Inherited from ISNet.WebUI.WebGrid.Chart.Series)
Public Property | InnerRadius |
Public Property | InteractiveStyle | (Inherited from ISNet.WebUI.WebGrid.Chart.Series)
Public Property | LabelMode |
Public Property | LightingImageFilter | (Inherited from ISNet.WebUI.WebGrid.Chart.Series)
Public Property | PieEdgePercent |
Public Property | PieStyle |
Public Property | Radius |
Public Property | SeriesLegend | (Inherited from ISNet.WebUI.WebGrid.Chart.SeriesBase)
Public Property | ShadowStyle | (Inherited from ISNet.WebUI.WebGrid.Chart.SeriesBase)
Public Property | TotalAngle |
Public Property | Visible | (Inherited from ISNet.WebUI.WebGrid.Chart.SeriesBase)
Top

See Also

Reference

SeriesPie Class
ISNet.WebUI.WebGrid.Chart Namespace


SeriesPie Constructor

[image]
Intersoft WebGrid Documentation
SeriesPie Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > SeriesPie Class : SeriesPie Constructor

Glossary Item Box

Overload List

Overload | Description
SeriesPie Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesPie Class
SeriesPie Members


BeginAngle Property

[image]
Intersoft WebGrid Documentation
BeginAngle Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > SeriesPie Class : BeginAngle Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Options")>
<System.ComponentModel.DescriptionAttribute("Controls the begin angle of the pie segments.")>
Public Property BeginAngle As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As SeriesPie
Dim value As System.Integer

instance.BeginAngle = value

value = instance.BeginAngle
C#
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Options")]
[System.ComponentModel.DescriptionAttribute("Controls the begin angle of the pie segments.")]
public System.int BeginAngle {get; set;}
Delphi
public read-write property BeginAngle: System.Integer;
JScript
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Options")
System.ComponentModel.DescriptionAttribute("Controls the begin angle of the pie segments.")
public function get,set BeginAngle : System.int
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Options")]
[System.ComponentModel.DescriptionAttribute("Controls the begin angle of the pie segments.")]
public: __property System.int get_BeginAngle();
public: __property void set_BeginAngle(
   System.int value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Options")]
[System.ComponentModel.DescriptionAttribute("Controls the begin angle of the pie segments.")]
public:
property System.int BeginAngle {
   System.int get();
   void set (    System.int value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesPie Class
SeriesPie Members


ClockwiseDirection Property

[image]
Intersoft WebGrid Documentation
ClockwiseDirection Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > SeriesPie Class : ClockwiseDirection Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Controls the direction in which pie segments expand.")>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Options")>
Public Property ClockwiseDirection As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As SeriesPie
Dim value As System.Boolean

instance.ClockwiseDirection = value

value = instance.ClockwiseDirection
C#
[System.ComponentModel.DescriptionAttribute("Controls the direction in which pie segments expand.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Options")]
public System.bool ClockwiseDirection {get; set;}
Delphi
public read-write property ClockwiseDirection: System.Boolean;
JScript
System.ComponentModel.DescriptionAttribute("Controls the direction in which pie segments expand.")
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Options")
public function get,set ClockwiseDirection : System.boolean
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Controls the direction in which pie segments expand.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Options")]
public: __property System.bool get_ClockwiseDirection();
public: __property void set_ClockwiseDirection(
   System.bool value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Controls the direction in which pie segments expand.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Options")]
public:
property System.bool ClockwiseDirection {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesPie Class
SeriesPie Members


ExplodeMode Property

[image]
Intersoft WebGrid Documentation
ExplodeMode Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > SeriesPie Class : ExplodeMode Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Controls the explosion mode when the Exploded Pie / Exploded Doughnut type is used.")>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Options")>
Public Property ExplodeMode As PieExplodeMode
Visual Basic (Usage) Copy Code
Dim instance As SeriesPie
Dim value As PieExplodeMode

instance.ExplodeMode = value

value = instance.ExplodeMode
C#
[System.ComponentModel.DescriptionAttribute("Controls the explosion mode when the Exploded Pie / Exploded Doughnut type is used.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Options")]
public PieExplodeMode ExplodeMode {get; set;}
Delphi
public read-write property ExplodeMode: PieExplodeMode;
JScript
System.ComponentModel.DescriptionAttribute("Controls the explosion mode when the Exploded Pie / Exploded Doughnut type is used.")
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Options")
public function get,set ExplodeMode : PieExplodeMode
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Controls the explosion mode when the Exploded Pie / Exploded Doughnut type is used.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Options")]
public: __property PieExplodeMode get_ExplodeMode();
public: __property void set_ExplodeMode(
   PieExplodeMode value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Controls the explosion mode when the Exploded Pie / Exploded Doughnut type is used.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Options")]
public:
property PieExplodeMode ExplodeMode {
   PieExplodeMode get();
   void set (    PieExplodeMode value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesPie Class
SeriesPie Members


Explosion Property

[image]
Intersoft WebGrid Documentation
Explosion Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > SeriesPie Class : Explosion Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Controls the length of the explosion when the Exploded Pie / Exploded Doughnut type is used.")>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Options")>
Public Property Explosion As System.Single
Visual Basic (Usage) Copy Code
Dim instance As SeriesPie
Dim value As System.Single

instance.Explosion = value

value = instance.Explosion
C#
[System.ComponentModel.DescriptionAttribute("Controls the length of the explosion when the Exploded Pie / Exploded Doughnut type is used.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Options")]
public System.float Explosion {get; set;}
Delphi
public read-write property Explosion: System.Single;
JScript
System.ComponentModel.DescriptionAttribute("Controls the length of the explosion when the Exploded Pie / Exploded Doughnut type is used.")
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Options")
public function get,set Explosion : System.float
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Controls the length of the explosion when the Exploded Pie / Exploded Doughnut type is used.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Options")]
public: __property System.float get_Explosion();
public: __property void set_Explosion(
   System.float value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Controls the length of the explosion when the Exploded Pie / Exploded Doughnut type is used.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Options")]
public:
property System.float Explosion {
   System.float get();
   void set (    System.float value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesPie Class
SeriesPie Members


InnerRadius Property

[image]
Intersoft WebGrid Documentation
InnerRadius Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > SeriesPie Class : InnerRadius Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Controls the inner radius of the pie.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Options")>
Public Property InnerRadius As System.Nullable(Of Single)
Visual Basic (Usage) Copy Code
Dim instance As SeriesPie
Dim value As System.Nullable(Of Single)

instance.InnerRadius = value

value = instance.InnerRadius
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Controls the inner radius of the pie.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Options")]
public System.Nullable<float> InnerRadius {get; set;}
Delphi
public read-write property InnerRadius: System.Nullable;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DescriptionAttribute("Controls the inner radius of the pie.")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Options")
public function get,set InnerRadius : System.Nullable
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Controls the inner radius of the pie.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Options")]
public: __property System.Nullable<float> get_InnerRadius();
public: __property void set_InnerRadius(
   System.Nullable<float> value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Controls the inner radius of the pie.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Options")]
public:
property System.Nullable<float> InnerRadius {
   System.Nullable<float> get();
   void set (    System.Nullable<float> value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesPie Class
SeriesPie Members


LabelMode Property

[image]
Intersoft WebGrid Documentation
LabelMode Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > SeriesPie Class : LabelMode Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Options")>
<System.ComponentModel.DescriptionAttribute("Controls the pie label mode.")>
Public Property LabelMode As PieLabelMode
Visual Basic (Usage) Copy Code
Dim instance As SeriesPie
Dim value As PieLabelMode

instance.LabelMode = value

value = instance.LabelMode
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Options")]
[System.ComponentModel.DescriptionAttribute("Controls the pie label mode.")]
public PieLabelMode LabelMode {get; set;}
Delphi
public read-write property LabelMode: PieLabelMode;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Options")
System.ComponentModel.DescriptionAttribute("Controls the pie label mode.")
public function get,set LabelMode : PieLabelMode
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Options")]
[System.ComponentModel.DescriptionAttribute("Controls the pie label mode.")]
public: __property PieLabelMode get_LabelMode();
public: __property void set_LabelMode(
   PieLabelMode value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Options")]
[System.ComponentModel.DescriptionAttribute("Controls the pie label mode.")]
public:
property PieLabelMode LabelMode {
   PieLabelMode get();
   void set (    PieLabelMode value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesPie Class
SeriesPie Members


PieEdgePercent Property

[image]
Intersoft WebGrid Documentation
PieEdgePercent Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > SeriesPie Class : PieEdgePercent Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Options")>
<System.ComponentModel.DescriptionAttribute("Controls the edge percent for smooth edge pie.")>
Public Property PieEdgePercent As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As SeriesPie
Dim value As System.Integer

instance.PieEdgePercent = value

value = instance.PieEdgePercent
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Options")]
[System.ComponentModel.DescriptionAttribute("Controls the edge percent for smooth edge pie.")]
public System.int PieEdgePercent {get; set;}
Delphi
public read-write property PieEdgePercent: System.Integer;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Options")
System.ComponentModel.DescriptionAttribute("Controls the edge percent for smooth edge pie.")
public function get,set PieEdgePercent : System.int
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Options")]
[System.ComponentModel.DescriptionAttribute("Controls the edge percent for smooth edge pie.")]
public: __property System.int get_PieEdgePercent();
public: __property void set_PieEdgePercent(
   System.int value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Options")]
[System.ComponentModel.DescriptionAttribute("Controls the edge percent for smooth edge pie.")]
public:
property System.int PieEdgePercent {
   System.int get();
   void set (    System.int value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesPie Class
SeriesPie Members


PieStyle Property

[image]
Intersoft WebGrid Documentation
PieStyle Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > SeriesPie Class : PieStyle Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Options")>
<System.ComponentModel.DescriptionAttribute("Controls the shape of the pie segments.")>
Public Property PieStyle As PieStyle
Visual Basic (Usage) Copy Code
Dim instance As SeriesPie
Dim value As PieStyle

instance.PieStyle = value

value = instance.PieStyle
C#
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Options")]
[System.ComponentModel.DescriptionAttribute("Controls the shape of the pie segments.")]
public PieStyle PieStyle {get; set;}
Delphi
public read-write property PieStyle: PieStyle;
JScript
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Options")
System.ComponentModel.DescriptionAttribute("Controls the shape of the pie segments.")
public function get,set PieStyle : PieStyle
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Options")]
[System.ComponentModel.DescriptionAttribute("Controls the shape of the pie segments.")]
public: __property PieStyle get_PieStyle();
public: __property void set_PieStyle(
   PieStyle value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Options")]
[System.ComponentModel.DescriptionAttribute("Controls the shape of the pie segments.")]
public:
property PieStyle PieStyle {
   PieStyle get();
   void set (    PieStyle value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesPie Class
SeriesPie Members


Radius Property

[image]
Intersoft WebGrid Documentation
Radius Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > SeriesPie Class : Radius Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Options")>
<System.ComponentModel.DescriptionAttribute("Controls the radius of the pie.")>
Public Property Radius As System.Nullable(Of Single)
Visual Basic (Usage) Copy Code
Dim instance As SeriesPie
Dim value As System.Nullable(Of Single)

instance.Radius = value

value = instance.Radius
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Options")]
[System.ComponentModel.DescriptionAttribute("Controls the radius of the pie.")]
public System.Nullable<float> Radius {get; set;}
Delphi
public read-write property Radius: System.Nullable;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Options")
System.ComponentModel.DescriptionAttribute("Controls the radius of the pie.")
public function get,set Radius : System.Nullable
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Options")]
[System.ComponentModel.DescriptionAttribute("Controls the radius of the pie.")]
public: __property System.Nullable<float> get_Radius();
public: __property void set_Radius(
   System.Nullable<float> value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Options")]
[System.ComponentModel.DescriptionAttribute("Controls the radius of the pie.")]
public:
property System.Nullable<float> Radius {
   System.Nullable<float> get();
   void set (    System.Nullable<float> value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesPie Class
SeriesPie Members


TotalAngle Property

[image]
Intersoft WebGrid Documentation
TotalAngle Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > SeriesPie Class : TotalAngle Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Options")>
<System.ComponentModel.DescriptionAttribute("Controls the total angle displayed as a pie.")>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property TotalAngle As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As SeriesPie
Dim value As System.Integer

instance.TotalAngle = value

value = instance.TotalAngle
C#
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Options")]
[System.ComponentModel.DescriptionAttribute("Controls the total angle displayed as a pie.")]
[ISNet.Serialization.BinarySerializableAttribute()]
public System.int TotalAngle {get; set;}
Delphi
public read-write property TotalAngle: System.Integer;
JScript
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Options")
System.ComponentModel.DescriptionAttribute("Controls the total angle displayed as a pie.")
ISNet.Serialization.BinarySerializableAttribute()
public function get,set TotalAngle : System.int
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Options")]
[System.ComponentModel.DescriptionAttribute("Controls the total angle displayed as a pie.")]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.int get_TotalAngle();
public: __property void set_TotalAngle(
   System.int value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Options")]
[System.ComponentModel.DescriptionAttribute("Controls the total angle displayed as a pie.")]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.int TotalAngle {
   System.int get();
   void set (    System.int value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesPie Class
SeriesPie Members


SeriesPoint Class

[image]
Intersoft WebGrid Documentation
SeriesPoint Class
Members See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : SeriesPoint Class

Glossary Item Box

Object Model

SeriesPoint Class

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.SerializableAttribute()>
Public Class SeriesPoint
   Inherits SeriesXYZScatter
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Visual Basic (Usage) Copy Code
Dim instance As SeriesPoint
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public class SeriesPoint : SeriesXYZScatter, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Delphi
public class SeriesPoint = class(SeriesXYZScatter, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize)
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.SerializableAttribute()
public class SeriesPoint extends SeriesXYZScatter implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public __gc class SeriesPoint : public SeriesXYZScatter, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public ref class SeriesPoint : public SeriesXYZScatter, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.WebGrid.Chart.SeriesBase
ISNet.WebUI.WebGrid.Chart.Series
ISNet.WebUI.WebGrid.Chart.SeriesXYScatter
ISNet.WebUI.WebGrid.Chart.SeriesXYZScatter
ISNet.WebUI.WebGrid.Chart.SeriesPoint

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesPoint Members
ISNet.WebUI.WebGrid.Chart Namespace


SeriesPoint Class Members

[image]
Intersoft WebGrid Documentation
SeriesPoint Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : SeriesPoint Class

Glossary Item Box

The following tables list the members exposed by SeriesPoint.

Public Constructors

 | Name | Description
Public Constructor | SeriesPoint Constructor |
Top

Public Properties

 | Name | Description
Public Property | BevelAndEmbossImageFilter | (Inherited from ISNet.WebUI.WebGrid.Chart.Series)
Public Property | BlurImageFilter | (Inherited from ISNet.WebUI.WebGrid.Chart.Series)
Public Property | BorderStyle | (Inherited from ISNet.WebUI.WebGrid.Chart.Series)
Public Property | ChartFillType | (Inherited from ISNet.WebUI.WebGrid.Chart.Series)
Public Property | DataLabelStyle | (Inherited from ISNet.WebUI.WebGrid.Chart.Series)
Public Property | EmptyDataPointStyle | (Inherited from ISNet.WebUI.WebGrid.Chart.Series)
Public Property | GlowImageFilter | (Inherited from ISNet.WebUI.WebGrid.Chart.Series)
Public Property | InteractiveStyle | (Inherited from ISNet.WebUI.WebGrid.Chart.Series)
Public Property | LightingImageFilter | (Inherited from ISNet.WebUI.WebGrid.Chart.Series)
Public Property | SeriesLegend | (Inherited from ISNet.WebUI.WebGrid.Chart.SeriesBase)
Public Property | ShadowStyle | (Inherited from ISNet.WebUI.WebGrid.Chart.SeriesBase)
Public Property | Size |
Public Property | SphereDetail |
Public Property | Visible | (Inherited from ISNet.WebUI.WebGrid.Chart.SeriesBase)
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

SeriesPoint Class
ISNet.WebUI.WebGrid.Chart Namespace


SeriesPoint Constructor

[image]
Intersoft WebGrid Documentation
SeriesPoint Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > SeriesPoint Class : SeriesPoint Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New SeriesPoint()
C#
public SeriesPoint()
Delphi
public SeriesPoint();
JScript
public function SeriesPoint();
Managed Extensions for C++
public: SeriesPoint();
C++/CLI
public:
SeriesPoint();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesPoint Class
SeriesPoint Members


Clone Method

[image]
Intersoft WebGrid Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > SeriesPoint Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As System.Object
Visual Basic (Usage) Copy Code
Dim instance As SeriesPoint
Dim value As System.Object

value = instance.Clone()
C#
public virtual System.object Clone()
Delphi
public function Clone(): System.TObject; virtual;
JScript
public function Clone() : System.Object;
Managed Extensions for C++
public: virtual System.Object* Clone();
C++/CLI
public:
virtual System.Object^ Clone();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesPoint Class
SeriesPoint Members


CopyFrom Method

[image]
Intersoft WebGrid Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > SeriesPoint Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesPoint Class
SeriesPoint Members


CopyFrom(Object) Method

[image]
Intersoft WebGrid Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > SeriesPoint Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As SeriesPoint
Dim objSource As System.Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   System.object objSource
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesPoint Class
SeriesPoint Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebGrid Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > SeriesPoint Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object, _
   ByVal cloneSourceValue As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As SeriesPoint
Dim objSource As System.Object
Dim cloneSourceValue As System.Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   System.object objSource,
   System.bool cloneSourceValue
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject;
    cloneSourceValue: System.Boolean
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object,
   cloneSourceValue : System.boolean
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource,
   System.bool cloneSourceValue
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource,
   System.bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesPoint Class
SeriesPoint Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebGrid Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > SeriesPoint Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As SeriesPoint
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure DeSerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function DeSerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void DeSerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void DeSerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesPoint Class
SeriesPoint Members


GetHashCode Method

[image]
Intersoft WebGrid Documentation
GetHashCode Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > SeriesPoint Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As SeriesPoint
Dim value As System.Integer

value = instance.GetHashCode()
C#
public virtual System.int GetHashCode()
Delphi
public function GetHashCode(): System.Integer; virtual;
JScript
public function GetHashCode() : System.int;
Managed Extensions for C++
public: virtual System.int GetHashCode();
C++/CLI
public:
virtual System.int GetHashCode();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesPoint Class
SeriesPoint Members


SeriesPoint Class Methods

[image]
Intersoft WebGrid Documentation
SeriesPoint Class Methods
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : SeriesPoint Class

Glossary Item Box

For a list of all members of this type, see SeriesPoint members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

SeriesPoint Class
ISNet.WebUI.WebGrid.Chart Namespace


GetObjectData Method

[image]
Intersoft WebGrid Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > SeriesPoint Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=False,
   UnmanagedCode=False,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=True,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Action=SecurityAction.Demand,
   Unrestricted=False)>
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As SeriesPoint
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure GetObjectData(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
); override;
JScript
System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=,
   UnmanagedCode=,
   SkipVerification=,
   Execution=,
   ControlThread=,
   ControlEvidence=,
   ControlPolicy=,
   SerializationFormatter=,
   ControlDomainPolicy=,
   ControlPrincipal=,
   ControlAppDomain=,
   RemotingConfiguration=,
   Infrastructure=,
   BindingRedirects=,
   Action=SecurityAction.Demand,
   Unrestricted=)
public override function GetObjectData(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public: void GetObjectData(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
) override
C++/CLI
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public:
void GetObjectData(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
) override

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesPoint Class
SeriesPoint Members


IsEmpty Method

[image]
Intersoft WebGrid Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > SeriesPoint Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As SeriesPoint
Dim value As System.Boolean

value = instance.IsEmpty()
C#
public virtual System.bool IsEmpty()
Delphi
public function IsEmpty(): System.Boolean; virtual;
JScript
public function IsEmpty() : System.boolean;
Managed Extensions for C++
public: virtual System.bool IsEmpty();
C++/CLI
public:
virtual System.bool IsEmpty();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesPoint Class
SeriesPoint Members


Reset Method

[image]
Intersoft WebGrid Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > SeriesPoint Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As SeriesPoint

instance.Reset()
C#
public virtual void Reset()
Delphi
public procedure Reset(); virtual;
JScript
public function Reset();
Managed Extensions for C++
public: virtual void Reset();
C++/CLI
public:
virtual void Reset();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesPoint Class
SeriesPoint Members


SerializeObjectData Method

[image]
Intersoft WebGrid Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > SeriesPoint Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As SeriesPoint
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure SerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function SerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void SerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void SerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesPoint Class
SeriesPoint Members


ToString Method

[image]
Intersoft WebGrid Documentation
ToString Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > SeriesPoint Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As System.String
Visual Basic (Usage) Copy Code
Dim instance As SeriesPoint
Dim value As System.String

value = instance.ToString()
C#
public virtual System.string ToString()
Delphi
public function ToString(): System.String; virtual;
JScript
public function ToString() : System.String;
Managed Extensions for C++
public: virtual System.string* ToString();
C++/CLI
public:
virtual System.String^ ToString();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesPoint Class
SeriesPoint Members


SeriesPoint Class Properties

[image]
Intersoft WebGrid Documentation
SeriesPoint Class Properties
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : SeriesPoint Class

Glossary Item Box

For a list of all members of this type, see SeriesPoint members.

Public Properties

 | Name | Description
Public Property | BevelAndEmbossImageFilter | (Inherited from ISNet.WebUI.WebGrid.Chart.Series)
Public Property | BlurImageFilter | (Inherited from ISNet.WebUI.WebGrid.Chart.Series)
Public Property | BorderStyle | (Inherited from ISNet.WebUI.WebGrid.Chart.Series)
Public Property | ChartFillType | (Inherited from ISNet.WebUI.WebGrid.Chart.Series)
Public Property | DataLabelStyle | (Inherited from ISNet.WebUI.WebGrid.Chart.Series)
Public Property | EmptyDataPointStyle | (Inherited from ISNet.WebUI.WebGrid.Chart.Series)
Public Property | GlowImageFilter | (Inherited from ISNet.WebUI.WebGrid.Chart.Series)
Public Property | InteractiveStyle | (Inherited from ISNet.WebUI.WebGrid.Chart.Series)
Public Property | LightingImageFilter | (Inherited from ISNet.WebUI.WebGrid.Chart.Series)
Public Property | SeriesLegend | (Inherited from ISNet.WebUI.WebGrid.Chart.SeriesBase)
Public Property | ShadowStyle | (Inherited from ISNet.WebUI.WebGrid.Chart.SeriesBase)
Public Property | Size |
Public Property | SphereDetail |
Public Property | Visible | (Inherited from ISNet.WebUI.WebGrid.Chart.SeriesBase)
Top

See Also

Reference

SeriesPoint Class
ISNet.WebUI.WebGrid.Chart Namespace


SeriesPoint Constructor

[image]
Intersoft WebGrid Documentation
SeriesPoint Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > SeriesPoint Class : SeriesPoint Constructor

Glossary Item Box

Overload List

Overload | Description
SeriesPoint Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesPoint Class
SeriesPoint Members


Size Property

[image]
Intersoft WebGrid Documentation
Size Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > SeriesPoint Class : Size Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Controls the size of the value point marks..")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Options")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property Size As System.Nullable(Of Single)
Visual Basic (Usage) Copy Code
Dim instance As SeriesPoint
Dim value As System.Nullable(Of Single)

instance.Size = value

value = instance.Size
C#
[System.ComponentModel.DescriptionAttribute("Controls the size of the value point marks..")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Options")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.Nullable<float> Size {get; set;}
Delphi
public read-write property Size: System.Nullable;
JScript
System.ComponentModel.DescriptionAttribute("Controls the size of the value point marks..")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Options")
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set Size : System.Nullable
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Controls the size of the value point marks..")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Options")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.Nullable<float> get_Size();
public: __property void set_Size(
   System.Nullable<float> value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Controls the size of the value point marks..")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Options")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.Nullable<float> Size {
   System.Nullable<float> get();
   void set (    System.Nullable<float> value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesPoint Class
SeriesPoint Members


SphereDetail Property

[image]
Intersoft WebGrid Documentation
SphereDetail Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > SeriesPoint Class : SphereDetail Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Controls the level of detail of spheres.")>
<System.ComponentModel.CategoryAttribute("Options")>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property SphereDetail As LevelOfDetail
Visual Basic (Usage) Copy Code
Dim instance As SeriesPoint
Dim value As LevelOfDetail

instance.SphereDetail = value

value = instance.SphereDetail
C#
[System.ComponentModel.DescriptionAttribute("Controls the level of detail of spheres.")]
[System.ComponentModel.CategoryAttribute("Options")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public LevelOfDetail SphereDetail {get; set;}
Delphi
public read-write property SphereDetail: LevelOfDetail;
JScript
System.ComponentModel.DescriptionAttribute("Controls the level of detail of spheres.")
System.ComponentModel.CategoryAttribute("Options")
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set SphereDetail : LevelOfDetail
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Controls the level of detail of spheres.")]
[System.ComponentModel.CategoryAttribute("Options")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property LevelOfDetail get_SphereDetail();
public: __property void set_SphereDetail(
   LevelOfDetail value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Controls the level of detail of spheres.")]
[System.ComponentModel.CategoryAttribute("Options")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property LevelOfDetail SphereDetail {
   LevelOfDetail get();
   void set (    LevelOfDetail value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesPoint Class
SeriesPoint Members


SeriesPolar Class

[image]
Intersoft WebGrid Documentation
SeriesPolar Class
Members See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : SeriesPolar Class

Glossary Item Box

Object Model

SeriesPolar Class

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.SerializableAttribute()>
Public Class SeriesPolar
   Inherits Series
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Visual Basic (Usage) Copy Code
Dim instance As SeriesPolar
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public class SeriesPolar : Series, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Delphi
public class SeriesPolar = class(Series, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize)
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.SerializableAttribute()
public class SeriesPolar extends Series implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public __gc class SeriesPolar : public Series, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public ref class SeriesPolar : public Series, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.WebGrid.Chart.SeriesBase
ISNet.WebUI.WebGrid.Chart.Series
ISNet.WebUI.WebGrid.Chart.SeriesPolar

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesPolar Members
ISNet.WebUI.WebGrid.Chart Namespace


SeriesPolar Class Members

[image]
Intersoft WebGrid Documentation
SeriesPolar Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : SeriesPolar Class

Glossary Item Box

The following tables list the members exposed by SeriesPolar.

Public Constructors

 | Name | Description
Public Constructor | SeriesPolar Constructor |
Top

Public Properties

 | Name | Description
Public Property | BevelAndEmbossImageFilter | (Inherited from ISNet.WebUI.WebGrid.Chart.Series)
Public Property | BlurImageFilter | (Inherited from ISNet.WebUI.WebGrid.Chart.Series)
Public Property | BorderStyle | (Inherited from ISNet.WebUI.WebGrid.Chart.Series)
Public Property | ChartFillType | (Inherited from ISNet.WebUI.WebGrid.Chart.Series)
Public Property | CloseContour |
Public Property | DataLabelStyle | (Inherited from ISNet.WebUI.WebGrid.Chart.Series)
Public Property | EmptyDataPointStyle | (Inherited from ISNet.WebUI.WebGrid.Chart.Series)
Public Property | GlowImageFilter | (Inherited from ISNet.WebUI.WebGrid.Chart.Series)
Public Property | InteractiveStyle | (Inherited from ISNet.WebUI.WebGrid.Chart.Series)
Public Property | LightingImageFilter | (Inherited from ISNet.WebUI.WebGrid.Chart.Series)
Public Property | SeriesLegend | (Inherited from ISNet.WebUI.WebGrid.Chart.SeriesBase)
Public Property | ShadowStyle | (Inherited from ISNet.WebUI.WebGrid.Chart.SeriesBase)
Public Property | Visible | (Inherited from ISNet.WebUI.WebGrid.Chart.SeriesBase)
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

SeriesPolar Class
ISNet.WebUI.WebGrid.Chart Namespace


SeriesPolar Constructor

[image]
Intersoft WebGrid Documentation
SeriesPolar Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > SeriesPolar Class : SeriesPolar Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New SeriesPolar()
C#
public SeriesPolar()
Delphi
public SeriesPolar();
JScript
public function SeriesPolar();
Managed Extensions for C++
public: SeriesPolar();
C++/CLI
public:
SeriesPolar();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesPolar Class
SeriesPolar Members


Clone Method

[image]
Intersoft WebGrid Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > SeriesPolar Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As System.Object
Visual Basic (Usage) Copy Code
Dim instance As SeriesPolar
Dim value As System.Object

value = instance.Clone()
C#
public virtual System.object Clone()
Delphi
public function Clone(): System.TObject; virtual;
JScript
public function Clone() : System.Object;
Managed Extensions for C++
public: virtual System.Object* Clone();
C++/CLI
public:
virtual System.Object^ Clone();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesPolar Class
SeriesPolar Members


CopyFrom Method

[image]
Intersoft WebGrid Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > SeriesPolar Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesPolar Class
SeriesPolar Members


CopyFrom(Object) Method

[image]
Intersoft WebGrid Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > SeriesPolar Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As SeriesPolar
Dim objSource As System.Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   System.object objSource
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesPolar Class
SeriesPolar Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebGrid Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > SeriesPolar Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object, _
   ByVal cloneSourceValue As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As SeriesPolar
Dim objSource As System.Object
Dim cloneSourceValue As System.Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   System.object objSource,
   System.bool cloneSourceValue
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject;
    cloneSourceValue: System.Boolean
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object,
   cloneSourceValue : System.boolean
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource,
   System.bool cloneSourceValue
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource,
   System.bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesPolar Class
SeriesPolar Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebGrid Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > SeriesPolar Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As SeriesPolar
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure DeSerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function DeSerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void DeSerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void DeSerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesPolar Class
SeriesPolar Members


GetHashCode Method

[image]
Intersoft WebGrid Documentation
GetHashCode Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > SeriesPolar Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As SeriesPolar
Dim value As System.Integer

value = instance.GetHashCode()
C#
public virtual System.int GetHashCode()
Delphi
public function GetHashCode(): System.Integer; virtual;
JScript
public function GetHashCode() : System.int;
Managed Extensions for C++
public: virtual System.int GetHashCode();
C++/CLI
public:
virtual System.int GetHashCode();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesPolar Class
SeriesPolar Members


SeriesPolar Class Methods

[image]
Intersoft WebGrid Documentation
SeriesPolar Class Methods
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : SeriesPolar Class

Glossary Item Box

For a list of all members of this type, see SeriesPolar members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

SeriesPolar Class
ISNet.WebUI.WebGrid.Chart Namespace


GetObjectData Method

[image]
Intersoft WebGrid Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > SeriesPolar Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=False,
   UnmanagedCode=False,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=True,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Action=SecurityAction.Demand,
   Unrestricted=False)>
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As SeriesPolar
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure GetObjectData(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
); override;
JScript
System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=,
   UnmanagedCode=,
   SkipVerification=,
   Execution=,
   ControlThread=,
   ControlEvidence=,
   ControlPolicy=,
   SerializationFormatter=,
   ControlDomainPolicy=,
   ControlPrincipal=,
   ControlAppDomain=,
   RemotingConfiguration=,
   Infrastructure=,
   BindingRedirects=,
   Action=SecurityAction.Demand,
   Unrestricted=)
public override function GetObjectData(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public: void GetObjectData(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
) override
C++/CLI
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public:
void GetObjectData(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
) override

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesPolar Class
SeriesPolar Members


IsEmpty Method

[image]
Intersoft WebGrid Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > SeriesPolar Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As SeriesPolar
Dim value As System.Boolean

value = instance.IsEmpty()
C#
public virtual System.bool IsEmpty()
Delphi
public function IsEmpty(): System.Boolean; virtual;
JScript
public function IsEmpty() : System.boolean;
Managed Extensions for C++
public: virtual System.bool IsEmpty();
C++/CLI
public:
virtual System.bool IsEmpty();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesPolar Class
SeriesPolar Members


Reset Method

[image]
Intersoft WebGrid Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > SeriesPolar Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As SeriesPolar

instance.Reset()
C#
public virtual void Reset()
Delphi
public procedure Reset(); virtual;
JScript
public function Reset();
Managed Extensions for C++
public: virtual void Reset();
C++/CLI
public:
virtual void Reset();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesPolar Class
SeriesPolar Members


SerializeObjectData Method

[image]
Intersoft WebGrid Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > SeriesPolar Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As SeriesPolar
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure SerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function SerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void SerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void SerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesPolar Class
SeriesPolar Members


ToString Method

[image]
Intersoft WebGrid Documentation
ToString Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > SeriesPolar Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As System.String
Visual Basic (Usage) Copy Code
Dim instance As SeriesPolar
Dim value As System.String

value = instance.ToString()
C#
public virtual System.string ToString()
Delphi
public function ToString(): System.String; virtual;
JScript
public function ToString() : System.String;
Managed Extensions for C++
public: virtual System.string* ToString();
C++/CLI
public:
virtual System.String^ ToString();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesPolar Class
SeriesPolar Members


SeriesPolar Class Properties

[image]
Intersoft WebGrid Documentation
SeriesPolar Class Properties
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : SeriesPolar Class

Glossary Item Box

For a list of all members of this type, see SeriesPolar members.

Public Properties

 | Name | Description
Public Property | BevelAndEmbossImageFilter | (Inherited from ISNet.WebUI.WebGrid.Chart.Series)
Public Property | BlurImageFilter | (Inherited from ISNet.WebUI.WebGrid.Chart.Series)
Public Property | BorderStyle | (Inherited from ISNet.WebUI.WebGrid.Chart.Series)
Public Property | ChartFillType | (Inherited from ISNet.WebUI.WebGrid.Chart.Series)
Public Property | CloseContour |
Public Property | DataLabelStyle | (Inherited from ISNet.WebUI.WebGrid.Chart.Series)
Public Property | EmptyDataPointStyle | (Inherited from ISNet.WebUI.WebGrid.Chart.Series)
Public Property | GlowImageFilter | (Inherited from ISNet.WebUI.WebGrid.Chart.Series)
Public Property | InteractiveStyle | (Inherited from ISNet.WebUI.WebGrid.Chart.Series)
Public Property | LightingImageFilter | (Inherited from ISNet.WebUI.WebGrid.Chart.Series)
Public Property | SeriesLegend | (Inherited from ISNet.WebUI.WebGrid.Chart.SeriesBase)
Public Property | ShadowStyle | (Inherited from ISNet.WebUI.WebGrid.Chart.SeriesBase)
Public Property | Visible | (Inherited from ISNet.WebUI.WebGrid.Chart.SeriesBase)
Top

See Also

Reference

SeriesPolar Class
ISNet.WebUI.WebGrid.Chart Namespace


SeriesPolar Constructor

[image]
Intersoft WebGrid Documentation
SeriesPolar Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > SeriesPolar Class : SeriesPolar Constructor

Glossary Item Box

Overload List

Overload | Description
SeriesPolar Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesPolar Class
SeriesPolar Members


CloseContour Property

[image]
Intersoft WebGrid Documentation
CloseContour Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > SeriesPolar Class : CloseContour Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Instructs the polar series to connect the first and last polar points.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Options")>
Public Property CloseContour As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As SeriesPolar
Dim value As System.Boolean

instance.CloseContour = value

value = instance.CloseContour
C#
[System.ComponentModel.DescriptionAttribute("Instructs the polar series to connect the first and last polar points.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Options")]
public System.bool CloseContour {get; set;}
Delphi
public read-write property CloseContour: System.Boolean;
JScript
System.ComponentModel.DescriptionAttribute("Instructs the polar series to connect the first and last polar points.")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Options")
public function get,set CloseContour : System.boolean
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Instructs the polar series to connect the first and last polar points.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Options")]
public: __property System.bool get_CloseContour();
public: __property void set_CloseContour(
   System.bool value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Instructs the polar series to connect the first and last polar points.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Options")]
public:
property System.bool CloseContour {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesPolar Class
SeriesPolar Members


SeriesRadar Class

[image]
Intersoft WebGrid Documentation
SeriesRadar Class
Members See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : SeriesRadar Class

Glossary Item Box

Object Model

SeriesRadar Class

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.SerializableAttribute()>
Public Class SeriesRadar
   Inherits Series
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Visual Basic (Usage) Copy Code
Dim instance As SeriesRadar
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public class SeriesRadar : Series, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Delphi
public class SeriesRadar = class(Series, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize)
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.SerializableAttribute()
public class SeriesRadar extends Series implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public __gc class SeriesRadar : public Series, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public ref class SeriesRadar : public Series, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.WebGrid.Chart.SeriesBase
ISNet.WebUI.WebGrid.Chart.Series
ISNet.WebUI.WebGrid.Chart.SeriesRadar

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesRadar Members
ISNet.WebUI.WebGrid.Chart Namespace


SeriesRadar Class Members

[image]
Intersoft WebGrid Documentation
SeriesRadar Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : SeriesRadar Class

Glossary Item Box

The following tables list the members exposed by SeriesRadar.

Public Constructors

 | Name | Description
Public Constructor | SeriesRadar Constructor |
Top

Public Properties

 | Name | Description
Public Property | BevelAndEmbossImageFilter | (Inherited from ISNet.WebUI.WebGrid.Chart.Series)
Public Property | BlurImageFilter | (Inherited from ISNet.WebUI.WebGrid.Chart.Series)
Public Property | BorderStyle | (Inherited from ISNet.WebUI.WebGrid.Chart.Series)
Public Property | ChartFillType | (Inherited from ISNet.WebUI.WebGrid.Chart.Series)
Public Property | DataLabelStyle | (Inherited from ISNet.WebUI.WebGrid.Chart.Series)
Public Property | EmptyDataPointStyle | (Inherited from ISNet.WebUI.WebGrid.Chart.Series)
Public Property | GlowImageFilter | (Inherited from ISNet.WebUI.WebGrid.Chart.Series)
Public Property | InteractiveStyle | (Inherited from ISNet.WebUI.WebGrid.Chart.Series)
Public Property | LightingImageFilter | (Inherited from ISNet.WebUI.WebGrid.Chart.Series)
Public Property | SeriesLegend | (Inherited from ISNet.WebUI.WebGrid.Chart.SeriesBase)
Public Property | ShadowStyle | (Inherited from ISNet.WebUI.WebGrid.Chart.SeriesBase)
Public Property | Visible | (Inherited from ISNet.WebUI.WebGrid.Chart.SeriesBase)
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

SeriesRadar Class
ISNet.WebUI.WebGrid.Chart Namespace


SeriesRadar Constructor

[image]
Intersoft WebGrid Documentation
SeriesRadar Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > SeriesRadar Class : SeriesRadar Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New SeriesRadar()
C#
public SeriesRadar()
Delphi
public SeriesRadar();
JScript
public function SeriesRadar();
Managed Extensions for C++
public: SeriesRadar();
C++/CLI
public:
SeriesRadar();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesRadar Class
SeriesRadar Members


Clone Method

[image]
Intersoft WebGrid Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > SeriesRadar Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As System.Object
Visual Basic (Usage) Copy Code
Dim instance As SeriesRadar
Dim value As System.Object

value = instance.Clone()
C#
public virtual System.object Clone()
Delphi
public function Clone(): System.TObject; virtual;
JScript
public function Clone() : System.Object;
Managed Extensions for C++
public: virtual System.Object* Clone();
C++/CLI
public:
virtual System.Object^ Clone();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesRadar Class
SeriesRadar Members


CopyFrom Method

[image]
Intersoft WebGrid Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > SeriesRadar Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesRadar Class
SeriesRadar Members


CopyFrom(Object) Method

[image]
Intersoft WebGrid Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > SeriesRadar Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As SeriesRadar
Dim objSource As System.Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   System.object objSource
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesRadar Class
SeriesRadar Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebGrid Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > SeriesRadar Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object, _
   ByVal cloneSourceValue As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As SeriesRadar
Dim objSource As System.Object
Dim cloneSourceValue As System.Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   System.object objSource,
   System.bool cloneSourceValue
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject;
    cloneSourceValue: System.Boolean
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object,
   cloneSourceValue : System.boolean
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource,
   System.bool cloneSourceValue
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource,
   System.bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesRadar Class
SeriesRadar Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebGrid Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > SeriesRadar Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As SeriesRadar
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure DeSerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function DeSerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void DeSerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void DeSerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesRadar Class
SeriesRadar Members


GetHashCode Method

[image]
Intersoft WebGrid Documentation
GetHashCode Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > SeriesRadar Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As SeriesRadar
Dim value As System.Integer

value = instance.GetHashCode()
C#
public virtual System.int GetHashCode()
Delphi
public function GetHashCode(): System.Integer; virtual;
JScript
public function GetHashCode() : System.int;
Managed Extensions for C++
public: virtual System.int GetHashCode();
C++/CLI
public:
virtual System.int GetHashCode();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesRadar Class
SeriesRadar Members


SeriesRadar Class Methods

[image]
Intersoft WebGrid Documentation
SeriesRadar Class Methods
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : SeriesRadar Class

Glossary Item Box

For a list of all members of this type, see SeriesRadar members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

SeriesRadar Class
ISNet.WebUI.WebGrid.Chart Namespace


SeriesRadar Class Properties

[image]
Intersoft WebGrid Documentation
SeriesRadar Class Properties
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : SeriesRadar Class

Glossary Item Box

For a list of all members of this type, see SeriesRadar members.

Public Properties

 | Name | Description
Public Property | BevelAndEmbossImageFilter | (Inherited from ISNet.WebUI.WebGrid.Chart.Series)
Public Property | BlurImageFilter | (Inherited from ISNet.WebUI.WebGrid.Chart.Series)
Public Property | BorderStyle | (Inherited from ISNet.WebUI.WebGrid.Chart.Series)
Public Property | ChartFillType | (Inherited from ISNet.WebUI.WebGrid.Chart.Series)
Public Property | DataLabelStyle | (Inherited from ISNet.WebUI.WebGrid.Chart.Series)
Public Property | EmptyDataPointStyle | (Inherited from ISNet.WebUI.WebGrid.Chart.Series)
Public Property | GlowImageFilter | (Inherited from ISNet.WebUI.WebGrid.Chart.Series)
Public Property | InteractiveStyle | (Inherited from ISNet.WebUI.WebGrid.Chart.Series)
Public Property | LightingImageFilter | (Inherited from ISNet.WebUI.WebGrid.Chart.Series)
Public Property | SeriesLegend | (Inherited from ISNet.WebUI.WebGrid.Chart.SeriesBase)
Public Property | ShadowStyle | (Inherited from ISNet.WebUI.WebGrid.Chart.SeriesBase)
Public Property | Visible | (Inherited from ISNet.WebUI.WebGrid.Chart.SeriesBase)
Top

See Also

Reference

SeriesRadar Class
ISNet.WebUI.WebGrid.Chart Namespace


SeriesRadar Constructor

[image]
Intersoft WebGrid Documentation
SeriesRadar Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > SeriesRadar Class : SeriesRadar Constructor

Glossary Item Box

Overload List

Overload | Description
SeriesRadar Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesRadar Class
SeriesRadar Members


GetObjectData Method

[image]
Intersoft WebGrid Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > SeriesRadar Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=False,
   UnmanagedCode=False,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=True,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Action=SecurityAction.Demand,
   Unrestricted=False)>
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As SeriesRadar
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure GetObjectData(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
); override;
JScript
System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=,
   UnmanagedCode=,
   SkipVerification=,
   Execution=,
   ControlThread=,
   ControlEvidence=,
   ControlPolicy=,
   SerializationFormatter=,
   ControlDomainPolicy=,
   ControlPrincipal=,
   ControlAppDomain=,
   RemotingConfiguration=,
   Infrastructure=,
   BindingRedirects=,
   Action=SecurityAction.Demand,
   Unrestricted=)
public override function GetObjectData(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public: void GetObjectData(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
) override
C++/CLI
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public:
void GetObjectData(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
) override

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesRadar Class
SeriesRadar Members


IsEmpty Method

[image]
Intersoft WebGrid Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > SeriesRadar Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As SeriesRadar
Dim value As System.Boolean

value = instance.IsEmpty()
C#
public virtual System.bool IsEmpty()
Delphi
public function IsEmpty(): System.Boolean; virtual;
JScript
public function IsEmpty() : System.boolean;
Managed Extensions for C++
public: virtual System.bool IsEmpty();
C++/CLI
public:
virtual System.bool IsEmpty();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesRadar Class
SeriesRadar Members


Reset Method

[image]
Intersoft WebGrid Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > SeriesRadar Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As SeriesRadar

instance.Reset()
C#
public virtual void Reset()
Delphi
public procedure Reset(); virtual;
JScript
public function Reset();
Managed Extensions for C++
public: virtual void Reset();
C++/CLI
public:
virtual void Reset();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesRadar Class
SeriesRadar Members


SerializeObjectData Method

[image]
Intersoft WebGrid Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > SeriesRadar Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As SeriesRadar
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure SerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function SerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void SerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void SerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesRadar Class
SeriesRadar Members


ToString Method

[image]
Intersoft WebGrid Documentation
ToString Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > SeriesRadar Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As System.String
Visual Basic (Usage) Copy Code
Dim instance As SeriesRadar
Dim value As System.String

value = instance.ToString()
C#
public virtual System.string ToString()
Delphi
public function ToString(): System.String; virtual;
JScript
public function ToString() : System.String;
Managed Extensions for C++
public: virtual System.string* ToString();
C++/CLI
public:
virtual System.String^ ToString();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesRadar Class
SeriesRadar Members


SeriesSmoothLine Class

[image]
Intersoft WebGrid Documentation
SeriesSmoothLine Class
Members See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : SeriesSmoothLine Class

Glossary Item Box

Object Model

SeriesSmoothLine Class

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.SerializableAttribute()>
Public Class SeriesSmoothLine
   Inherits SeriesLineBase
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Visual Basic (Usage) Copy Code
Dim instance As SeriesSmoothLine
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public class SeriesSmoothLine : SeriesLineBase, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Delphi
public class SeriesSmoothLine = class(SeriesLineBase, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize)
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.SerializableAttribute()
public class SeriesSmoothLine extends SeriesLineBase implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public __gc class SeriesSmoothLine : public SeriesLineBase, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public ref class SeriesSmoothLine : public SeriesLineBase, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.WebGrid.Chart.SeriesBase
ISNet.WebUI.WebGrid.Chart.Series
ISNet.WebUI.WebGrid.Chart.SeriesXYScatter
ISNet.WebUI.WebGrid.Chart.SeriesXYZScatter
ISNet.WebUI.WebGrid.Chart.SeriesLineBase
ISNet.WebUI.WebGrid.Chart.SeriesSmoothLine

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesSmoothLine Members
ISNet.WebUI.WebGrid.Chart Namespace


SeriesSmoothLine Class Members

[image]
Intersoft WebGrid Documentation
SeriesSmoothLine Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : SeriesSmoothLine Class

Glossary Item Box

The following tables list the members exposed by SeriesSmoothLine.

Public Constructors

 | Name | Description
Public Constructor | SeriesSmoothLine Constructor |
Top

Public Properties

 | Name | Description
Public Property | BevelAndEmbossImageFilter | (Inherited from ISNet.WebUI.WebGrid.Chart.Series)
Public Property | BlurImageFilter | (Inherited from ISNet.WebUI.WebGrid.Chart.Series)
Public Property | BorderStyle | (Inherited from ISNet.WebUI.WebGrid.Chart.Series)
Public Property | ChartFillType | (Inherited from ISNet.WebUI.WebGrid.Chart.Series)
Public Property | DataLabelStyle | (Inherited from ISNet.WebUI.WebGrid.Chart.Series)
Public Property | EmptyDataPointStyle | (Inherited from ISNet.WebUI.WebGrid.Chart.Series)
Public Property | GlowImageFilter | (Inherited from ISNet.WebUI.WebGrid.Chart.Series)
Public Property | InteractiveStyle | (Inherited from ISNet.WebUI.WebGrid.Chart.Series)
Public Property | LightingImageFilter | (Inherited from ISNet.WebUI.WebGrid.Chart.Series)
Public Property | SeriesLegend | (Inherited from ISNet.WebUI.WebGrid.Chart.SeriesBase)
Public Property | ShadowStyle | (Inherited from ISNet.WebUI.WebGrid.Chart.SeriesBase)
Public Property | Use1DInterpolationForXYScatter |
Public Property | Visible | (Inherited from ISNet.WebUI.WebGrid.Chart.SeriesBase)
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

SeriesSmoothLine Class
ISNet.WebUI.WebGrid.Chart Namespace


SeriesSmoothLine Constructor

[image]
Intersoft WebGrid Documentation
SeriesSmoothLine Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > SeriesSmoothLine Class : SeriesSmoothLine Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New SeriesSmoothLine()
C#
public SeriesSmoothLine()
Delphi
public SeriesSmoothLine();
JScript
public function SeriesSmoothLine();
Managed Extensions for C++
public: SeriesSmoothLine();
C++/CLI
public:
SeriesSmoothLine();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesSmoothLine Class
SeriesSmoothLine Members


Clone Method

[image]
Intersoft WebGrid Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > SeriesSmoothLine Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As System.Object
Visual Basic (Usage) Copy Code
Dim instance As SeriesSmoothLine
Dim value As System.Object

value = instance.Clone()
C#
public virtual System.object Clone()
Delphi
public function Clone(): System.TObject; virtual;
JScript
public function Clone() : System.Object;
Managed Extensions for C++
public: virtual System.Object* Clone();
C++/CLI
public:
virtual System.Object^ Clone();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesSmoothLine Class
SeriesSmoothLine Members


CopyFrom Method

[image]
Intersoft WebGrid Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > SeriesSmoothLine Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesSmoothLine Class
SeriesSmoothLine Members


CopyFrom(Object) Method

[image]
Intersoft WebGrid Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > SeriesSmoothLine Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As SeriesSmoothLine
Dim objSource As System.Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   System.object objSource
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesSmoothLine Class
SeriesSmoothLine Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebGrid Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > SeriesSmoothLine Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object, _
   ByVal cloneSourceValue As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As SeriesSmoothLine
Dim objSource As System.Object
Dim cloneSourceValue As System.Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   System.object objSource,
   System.bool cloneSourceValue
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject;
    cloneSourceValue: System.Boolean
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object,
   cloneSourceValue : System.boolean
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource,
   System.bool cloneSourceValue
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource,
   System.bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesSmoothLine Class
SeriesSmoothLine Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebGrid Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > SeriesSmoothLine Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As SeriesSmoothLine
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure DeSerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function DeSerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void DeSerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void DeSerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesSmoothLine Class
SeriesSmoothLine Members


GetHashCode Method

[image]
Intersoft WebGrid Documentation
GetHashCode Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > SeriesSmoothLine Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As SeriesSmoothLine
Dim value As System.Integer

value = instance.GetHashCode()
C#
public virtual System.int GetHashCode()
Delphi
public function GetHashCode(): System.Integer; virtual;
JScript
public function GetHashCode() : System.int;
Managed Extensions for C++
public: virtual System.int GetHashCode();
C++/CLI
public:
virtual System.int GetHashCode();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesSmoothLine Class
SeriesSmoothLine Members


SeriesSmoothLine Class Methods

[image]
Intersoft WebGrid Documentation
SeriesSmoothLine Class Methods
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : SeriesSmoothLine Class

Glossary Item Box

For a list of all members of this type, see SeriesSmoothLine members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

SeriesSmoothLine Class
ISNet.WebUI.WebGrid.Chart Namespace


GetObjectData Method

[image]
Intersoft WebGrid Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > SeriesSmoothLine Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=False,
   UnmanagedCode=False,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=True,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Action=SecurityAction.Demand,
   Unrestricted=False)>
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As SeriesSmoothLine
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure GetObjectData(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
); override;
JScript
System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=,
   UnmanagedCode=,
   SkipVerification=,
   Execution=,
   ControlThread=,
   ControlEvidence=,
   ControlPolicy=,
   SerializationFormatter=,
   ControlDomainPolicy=,
   ControlPrincipal=,
   ControlAppDomain=,
   RemotingConfiguration=,
   Infrastructure=,
   BindingRedirects=,
   Action=SecurityAction.Demand,
   Unrestricted=)
public override function GetObjectData(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public: void GetObjectData(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
) override
C++/CLI
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public:
void GetObjectData(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
) override

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesSmoothLine Class
SeriesSmoothLine Members


IsEmpty Method

[image]
Intersoft WebGrid Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > SeriesSmoothLine Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As SeriesSmoothLine
Dim value As System.Boolean

value = instance.IsEmpty()
C#
public virtual System.bool IsEmpty()
Delphi
public function IsEmpty(): System.Boolean; virtual;
JScript
public function IsEmpty() : System.boolean;
Managed Extensions for C++
public: virtual System.bool IsEmpty();
C++/CLI
public:
virtual System.bool IsEmpty();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesSmoothLine Class
SeriesSmoothLine Members


Reset Method

[image]
Intersoft WebGrid Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > SeriesSmoothLine Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As SeriesSmoothLine

instance.Reset()
C#
public virtual void Reset()
Delphi
public procedure Reset(); virtual;
JScript
public function Reset();
Managed Extensions for C++
public: virtual void Reset();
C++/CLI
public:
virtual void Reset();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesSmoothLine Class
SeriesSmoothLine Members


SerializeObjectData Method

[image]
Intersoft WebGrid Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > SeriesSmoothLine Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As SeriesSmoothLine
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure SerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function SerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void SerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void SerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesSmoothLine Class
SeriesSmoothLine Members


ToString Method

[image]
Intersoft WebGrid Documentation
ToString Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > SeriesSmoothLine Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As System.String
Visual Basic (Usage) Copy Code
Dim instance As SeriesSmoothLine
Dim value As System.String

value = instance.ToString()
C#
public virtual System.string ToString()
Delphi
public function ToString(): System.String; virtual;
JScript
public function ToString() : System.String;
Managed Extensions for C++
public: virtual System.string* ToString();
C++/CLI
public:
virtual System.String^ ToString();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesSmoothLine Class
SeriesSmoothLine Members


SeriesSmoothLine Class Properties

[image]
Intersoft WebGrid Documentation
SeriesSmoothLine Class Properties
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : SeriesSmoothLine Class

Glossary Item Box

For a list of all members of this type, see SeriesSmoothLine members.

Public Properties

 | Name | Description
Public Property | BevelAndEmbossImageFilter | (Inherited from ISNet.WebUI.WebGrid.Chart.Series)
Public Property | BlurImageFilter | (Inherited from ISNet.WebUI.WebGrid.Chart.Series)
Public Property | BorderStyle | (Inherited from ISNet.WebUI.WebGrid.Chart.Series)
Public Property | ChartFillType | (Inherited from ISNet.WebUI.WebGrid.Chart.Series)
Public Property | DataLabelStyle | (Inherited from ISNet.WebUI.WebGrid.Chart.Series)
Public Property | EmptyDataPointStyle | (Inherited from ISNet.WebUI.WebGrid.Chart.Series)
Public Property | GlowImageFilter | (Inherited from ISNet.WebUI.WebGrid.Chart.Series)
Public Property | InteractiveStyle | (Inherited from ISNet.WebUI.WebGrid.Chart.Series)
Public Property | LightingImageFilter | (Inherited from ISNet.WebUI.WebGrid.Chart.Series)
Public Property | SeriesLegend | (Inherited from ISNet.WebUI.WebGrid.Chart.SeriesBase)
Public Property | ShadowStyle | (Inherited from ISNet.WebUI.WebGrid.Chart.SeriesBase)
Public Property | Use1DInterpolationForXYScatter |
Public Property | Visible | (Inherited from ISNet.WebUI.WebGrid.Chart.SeriesBase)
Top

See Also

Reference

SeriesSmoothLine Class
ISNet.WebUI.WebGrid.Chart Namespace


SeriesSmoothLine Constructor

[image]
Intersoft WebGrid Documentation
SeriesSmoothLine Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > SeriesSmoothLine Class : SeriesSmoothLine Constructor

Glossary Item Box

Overload List

Overload | Description
SeriesSmoothLine Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesSmoothLine Class
SeriesSmoothLine Members


Use1DInterpolationForXYScatter Property

[image]
Intersoft WebGrid Documentation
Use1DInterpolationForXYScatter Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > SeriesSmoothLine Class : Use1DInterpolationForXYScatter Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Options")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Controls the interpolation method for XY scatter smooth lines.")>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property Use1DInterpolationForXYScatter As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As SeriesSmoothLine
Dim value As System.Boolean

instance.Use1DInterpolationForXYScatter = value

value = instance.Use1DInterpolationForXYScatter
C#
[System.ComponentModel.CategoryAttribute("Options")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Controls the interpolation method for XY scatter smooth lines.")]
[ISNet.Serialization.BinarySerializableAttribute()]
public System.bool Use1DInterpolationForXYScatter {get; set;}
Delphi
public read-write property Use1DInterpolationForXYScatter: System.Boolean;
JScript
System.ComponentModel.CategoryAttribute("Options")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Controls the interpolation method for XY scatter smooth lines.")
ISNet.Serialization.BinarySerializableAttribute()
public function get,set Use1DInterpolationForXYScatter : System.boolean
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Options")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Controls the interpolation method for XY scatter smooth lines.")]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.bool get_Use1DInterpolationForXYScatter();
public: __property void set_Use1DInterpolationForXYScatter(
   System.bool value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Options")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Controls the interpolation method for XY scatter smooth lines.")]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.bool Use1DInterpolationForXYScatter {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesSmoothLine Class
SeriesSmoothLine Members


SeriesStepLine Class

[image]
Intersoft WebGrid Documentation
SeriesStepLine Class
Members See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : SeriesStepLine Class

Glossary Item Box

Object Model

SeriesStepLine Class

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.SerializableAttribute()>
Public Class SeriesStepLine
   Inherits SeriesLineBase
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Visual Basic (Usage) Copy Code
Dim instance As SeriesStepLine
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public class SeriesStepLine : SeriesLineBase, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Delphi
public class SeriesStepLine = class(SeriesLineBase, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize)
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.SerializableAttribute()
public class SeriesStepLine extends SeriesLineBase implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public __gc class SeriesStepLine : public SeriesLineBase, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public ref class SeriesStepLine : public SeriesLineBase, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.WebGrid.Chart.SeriesBase
ISNet.WebUI.WebGrid.Chart.Series
ISNet.WebUI.WebGrid.Chart.SeriesXYScatter
ISNet.WebUI.WebGrid.Chart.SeriesXYZScatter
ISNet.WebUI.WebGrid.Chart.SeriesLineBase
ISNet.WebUI.WebGrid.Chart.SeriesStepLine

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesStepLine Members
ISNet.WebUI.WebGrid.Chart Namespace


SeriesStepLine Class Members

[image]
Intersoft WebGrid Documentation
SeriesStepLine Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : SeriesStepLine Class

Glossary Item Box

The following tables list the members exposed by SeriesStepLine.

Public Constructors

 | Name | Description
Public Constructor | SeriesStepLine Constructor |
Top

Public Properties

 | Name | Description
Public Property | BevelAndEmbossImageFilter | (Inherited from ISNet.WebUI.WebGrid.Chart.Series)
Public Property | BlurImageFilter | (Inherited from ISNet.WebUI.WebGrid.Chart.Series)
Public Property | BorderStyle | (Inherited from ISNet.WebUI.WebGrid.Chart.Series)
Public Property | ChartFillType | (Inherited from ISNet.WebUI.WebGrid.Chart.Series)
Public Property | DataLabelStyle | (Inherited from ISNet.WebUI.WebGrid.Chart.Series)
Public Property | DepthPercent |
Public Property | EmptyDataPointStyle | (Inherited from ISNet.WebUI.WebGrid.Chart.Series)
Public Property | GlowImageFilter | (Inherited from ISNet.WebUI.WebGrid.Chart.Series)
Public Property | InteractiveStyle | (Inherited from ISNet.WebUI.WebGrid.Chart.Series)
Public Property | LightingImageFilter | (Inherited from ISNet.WebUI.WebGrid.Chart.Series)
Public Property | LineSegmentShape |
Public Property | LineSize |
Public Property | SeriesLegend | (Inherited from ISNet.WebUI.WebGrid.Chart.SeriesBase)
Public Property | ShadowStyle | (Inherited from ISNet.WebUI.WebGrid.Chart.SeriesBase)
Public Property | Visible | (Inherited from ISNet.WebUI.WebGrid.Chart.SeriesBase)
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

SeriesStepLine Class
ISNet.WebUI.WebGrid.Chart Namespace


SeriesStepLine Constructor

[image]
Intersoft WebGrid Documentation
SeriesStepLine Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > SeriesStepLine Class : SeriesStepLine Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New SeriesStepLine()
C#
public SeriesStepLine()
Delphi
public SeriesStepLine();
JScript
public function SeriesStepLine();
Managed Extensions for C++
public: SeriesStepLine();
C++/CLI
public:
SeriesStepLine();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesStepLine Class
SeriesStepLine Members


Clone Method

[image]
Intersoft WebGrid Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > SeriesStepLine Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As System.Object
Visual Basic (Usage) Copy Code
Dim instance As SeriesStepLine
Dim value As System.Object

value = instance.Clone()
C#
public virtual System.object Clone()
Delphi
public function Clone(): System.TObject; virtual;
JScript
public function Clone() : System.Object;
Managed Extensions for C++
public: virtual System.Object* Clone();
C++/CLI
public:
virtual System.Object^ Clone();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesStepLine Class
SeriesStepLine Members


CopyFrom Method

[image]
Intersoft WebGrid Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > SeriesStepLine Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesStepLine Class
SeriesStepLine Members


CopyFrom(Object) Method

[image]
Intersoft WebGrid Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > SeriesStepLine Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As SeriesStepLine
Dim objSource As System.Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   System.object objSource
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesStepLine Class
SeriesStepLine Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebGrid Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > SeriesStepLine Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object, _
   ByVal cloneSourceValue As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As SeriesStepLine
Dim objSource As System.Object
Dim cloneSourceValue As System.Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   System.object objSource,
   System.bool cloneSourceValue
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject;
    cloneSourceValue: System.Boolean
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object,
   cloneSourceValue : System.boolean
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource,
   System.bool cloneSourceValue
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource,
   System.bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesStepLine Class
SeriesStepLine Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebGrid Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > SeriesStepLine Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As SeriesStepLine
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure DeSerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function DeSerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void DeSerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void DeSerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesStepLine Class
SeriesStepLine Members


GetHashCode Method

[image]
Intersoft WebGrid Documentation
GetHashCode Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > SeriesStepLine Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As SeriesStepLine
Dim value As System.Integer

value = instance.GetHashCode()
C#
public virtual System.int GetHashCode()
Delphi
public function GetHashCode(): System.Integer; virtual;
JScript
public function GetHashCode() : System.int;
Managed Extensions for C++
public: virtual System.int GetHashCode();
C++/CLI
public:
virtual System.int GetHashCode();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesStepLine Class
SeriesStepLine Members


SeriesStepLine Class Methods

[image]
Intersoft WebGrid Documentation
SeriesStepLine Class Methods
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : SeriesStepLine Class

Glossary Item Box

For a list of all members of this type, see SeriesStepLine members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

SeriesStepLine Class
ISNet.WebUI.WebGrid.Chart Namespace


GetObjectData Method

[image]
Intersoft WebGrid Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > SeriesStepLine Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=False,
   UnmanagedCode=False,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=True,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Action=SecurityAction.Demand,
   Unrestricted=False)>
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As SeriesStepLine
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure GetObjectData(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
); override;
JScript
System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=,
   UnmanagedCode=,
   SkipVerification=,
   Execution=,
   ControlThread=,
   ControlEvidence=,
   ControlPolicy=,
   SerializationFormatter=,
   ControlDomainPolicy=,
   ControlPrincipal=,
   ControlAppDomain=,
   RemotingConfiguration=,
   Infrastructure=,
   BindingRedirects=,
   Action=SecurityAction.Demand,
   Unrestricted=)
public override function GetObjectData(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public: void GetObjectData(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
) override
C++/CLI
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public:
void GetObjectData(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
) override

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesStepLine Class
SeriesStepLine Members


IsEmpty Method

[image]
Intersoft WebGrid Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > SeriesStepLine Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As SeriesStepLine
Dim value As System.Boolean

value = instance.IsEmpty()
C#
public virtual System.bool IsEmpty()
Delphi
public function IsEmpty(): System.Boolean; virtual;
JScript
public function IsEmpty() : System.boolean;
Managed Extensions for C++
public: virtual System.bool IsEmpty();
C++/CLI
public:
virtual System.bool IsEmpty();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesStepLine Class
SeriesStepLine Members


Reset Method

[image]
Intersoft WebGrid Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > SeriesStepLine Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As SeriesStepLine

instance.Reset()
C#
public virtual void Reset()
Delphi
public procedure Reset(); virtual;
JScript
public function Reset();
Managed Extensions for C++
public: virtual void Reset();
C++/CLI
public:
virtual void Reset();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesStepLine Class
SeriesStepLine Members


SerializeObjectData Method

[image]
Intersoft WebGrid Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > SeriesStepLine Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As SeriesStepLine
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure SerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function SerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void SerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void SerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesStepLine Class
SeriesStepLine Members


ToString Method

[image]
Intersoft WebGrid Documentation
ToString Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > SeriesStepLine Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As System.String
Visual Basic (Usage) Copy Code
Dim instance As SeriesStepLine
Dim value As System.String

value = instance.ToString()
C#
public virtual System.string ToString()
Delphi
public function ToString(): System.String; virtual;
JScript
public function ToString() : System.String;
Managed Extensions for C++
public: virtual System.string* ToString();
C++/CLI
public:
virtual System.String^ ToString();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesStepLine Class
SeriesStepLine Members


SeriesStepLine Class Properties

[image]
Intersoft WebGrid Documentation
SeriesStepLine Class Properties
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : SeriesStepLine Class

Glossary Item Box

For a list of all members of this type, see SeriesStepLine members.

Public Properties

 | Name | Description
Public Property | BevelAndEmbossImageFilter | (Inherited from ISNet.WebUI.WebGrid.Chart.Series)
Public Property | BlurImageFilter | (Inherited from ISNet.WebUI.WebGrid.Chart.Series)
Public Property | BorderStyle | (Inherited from ISNet.WebUI.WebGrid.Chart.Series)
Public Property | ChartFillType | (Inherited from ISNet.WebUI.WebGrid.Chart.Series)
Public Property | DataLabelStyle | (Inherited from ISNet.WebUI.WebGrid.Chart.Series)
Public Property | DepthPercent |
Public Property | EmptyDataPointStyle | (Inherited from ISNet.WebUI.WebGrid.Chart.Series)
Public Property | GlowImageFilter | (Inherited from ISNet.WebUI.WebGrid.Chart.Series)
Public Property | InteractiveStyle | (Inherited from ISNet.WebUI.WebGrid.Chart.Series)
Public Property | LightingImageFilter | (Inherited from ISNet.WebUI.WebGrid.Chart.Series)
Public Property | LineSegmentShape |
Public Property | LineSize |
Public Property | SeriesLegend | (Inherited from ISNet.WebUI.WebGrid.Chart.SeriesBase)
Public Property | ShadowStyle | (Inherited from ISNet.WebUI.WebGrid.Chart.SeriesBase)
Public Property | Visible | (Inherited from ISNet.WebUI.WebGrid.Chart.SeriesBase)
Top

See Also

Reference

SeriesStepLine Class
ISNet.WebUI.WebGrid.Chart Namespace


SeriesStepLine Constructor

[image]
Intersoft WebGrid Documentation
SeriesStepLine Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > SeriesStepLine Class : SeriesStepLine Constructor

Glossary Item Box

Overload List

Overload | Description
SeriesStepLine Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesStepLine Class
SeriesStepLine Members


DepthPercent Property

[image]
Intersoft WebGrid Documentation
DepthPercent Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > SeriesStepLine Class : DepthPercent Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Controls the depth of the line in percents of the series depth when the LineSegmentShape is set to Tape, Tube or Ellipsoid.")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("Options")>
Public Property DepthPercent As System.Single
Visual Basic (Usage) Copy Code
Dim instance As SeriesStepLine
Dim value As System.Single

instance.DepthPercent = value

value = instance.DepthPercent
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Controls the depth of the line in percents of the series depth when the LineSegmentShape is set to Tape, Tube or Ellipsoid.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Options")]
public System.float DepthPercent {get; set;}
Delphi
public read-write property DepthPercent: System.Single;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DescriptionAttribute("Controls the depth of the line in percents of the series depth when the LineSegmentShape is set to Tape, Tube or Ellipsoid.")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("Options")
public function get,set DepthPercent : System.float
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Controls the depth of the line in percents of the series depth when the LineSegmentShape is set to Tape, Tube or Ellipsoid.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Options")]
public: __property System.float get_DepthPercent();
public: __property void set_DepthPercent(
   System.float value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Controls the depth of the line in percents of the series depth when the LineSegmentShape is set to Tape, Tube or Ellipsoid.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Options")]
public:
property System.float DepthPercent {
   System.float get();
   void set (    System.float value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesStepLine Class
SeriesStepLine Members


LineSegmentShape Property

[image]
Intersoft WebGrid Documentation
LineSegmentShape Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > SeriesStepLine Class : LineSegmentShape Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Options")>
<System.ComponentModel.DescriptionAttribute("Controls the style of the lines.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
Public Property LineSegmentShape As LineSegmentShape
Visual Basic (Usage) Copy Code
Dim instance As SeriesStepLine
Dim value As LineSegmentShape

instance.LineSegmentShape = value

value = instance.LineSegmentShape
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Options")]
[System.ComponentModel.DescriptionAttribute("Controls the style of the lines.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public LineSegmentShape LineSegmentShape {get; set;}
Delphi
public read-write property LineSegmentShape: LineSegmentShape;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Options")
System.ComponentModel.DescriptionAttribute("Controls the style of the lines.")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
public function get,set LineSegmentShape : LineSegmentShape
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Options")]
[System.ComponentModel.DescriptionAttribute("Controls the style of the lines.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public: __property LineSegmentShape get_LineSegmentShape();
public: __property void set_LineSegmentShape(
   LineSegmentShape value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Options")]
[System.ComponentModel.DescriptionAttribute("Controls the style of the lines.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public:
property LineSegmentShape LineSegmentShape {
   LineSegmentShape get();
   void set (    LineSegmentShape value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesStepLine Class
SeriesStepLine Members


LineSize Property

[image]
Intersoft WebGrid Documentation
LineSize Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > SeriesStepLine Class : LineSize Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Options")>
<System.ComponentModel.DescriptionAttribute("Controls the diameter of the tube / ellipsoid segments. Controls the depth of the tape segments in Z scatter mode.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property LineSize As System.Nullable(Of Single)
Visual Basic (Usage) Copy Code
Dim instance As SeriesStepLine
Dim value As System.Nullable(Of Single)

instance.LineSize = value

value = instance.LineSize
C#
[System.ComponentModel.CategoryAttribute("Options")]
[System.ComponentModel.DescriptionAttribute("Controls the diameter of the tube / ellipsoid segments. Controls the depth of the tape segments in Z scatter mode.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
public System.Nullable<float> LineSize {get; set;}
Delphi
public read-write property LineSize: System.Nullable;
JScript
System.ComponentModel.CategoryAttribute("Options")
System.ComponentModel.DescriptionAttribute("Controls the diameter of the tube / ellipsoid segments. Controls the depth of the tape segments in Z scatter mode.")
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get,set LineSize : System.Nullable
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Options")]
[System.ComponentModel.DescriptionAttribute("Controls the diameter of the tube / ellipsoid segments. Controls the depth of the tape segments in Z scatter mode.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.Nullable<float> get_LineSize();
public: __property void set_LineSize(
   System.Nullable<float> value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Options")]
[System.ComponentModel.DescriptionAttribute("Controls the diameter of the tube / ellipsoid segments. Controls the depth of the tape segments in Z scatter mode.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.Nullable<float> LineSize {
   System.Nullable<float> get();
   void set (    System.Nullable<float> value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesStepLine Class
SeriesStepLine Members


SeriesStock Class

[image]
Intersoft WebGrid Documentation
SeriesStock Class
Members See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : SeriesStock Class

Glossary Item Box

Object Model

SeriesStock Class

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.SerializableAttribute()>
Public Class SeriesStock
   Inherits SeriesXYScatter
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Visual Basic (Usage) Copy Code
Dim instance As SeriesStock
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public class SeriesStock : SeriesXYScatter, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Delphi
public class SeriesStock = class(SeriesXYScatter, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize)
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.SerializableAttribute()
public class SeriesStock extends SeriesXYScatter implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public __gc class SeriesStock : public SeriesXYScatter, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public ref class SeriesStock : public SeriesXYScatter, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.WebGrid.Chart.SeriesBase
ISNet.WebUI.WebGrid.Chart.Series
ISNet.WebUI.WebGrid.Chart.SeriesXYScatter
ISNet.WebUI.WebGrid.Chart.SeriesStock

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesStock Members
ISNet.WebUI.WebGrid.Chart Namespace


SeriesStock Class Members

[image]
Intersoft WebGrid Documentation
SeriesStock Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : SeriesStock Class

Glossary Item Box

The following tables list the members exposed by SeriesStock.

Public Constructors

 | Name | Description
Public Constructor | SeriesStock Constructor |
Top

Public Properties

 | Name | Description
Public Property | AppearanceMode |
Public Property | BevelAndEmbossImageFilter | (Inherited from ISNet.WebUI.WebGrid.Chart.Series)
Public Property | BlurImageFilter | (Inherited from ISNet.WebUI.WebGrid.Chart.Series)
Public Property | BorderStyle | (Inherited from ISNet.WebUI.WebGrid.Chart.Series)
Public Property | CandleDepthPercent |
Public Property | CandleStyle |
Public Property | CandleWidth |
Public Property | ChartFillType | (Inherited from ISNet.WebUI.WebGrid.Chart.Series)
Public Property | DataLabelStyle | (Inherited from ISNet.WebUI.WebGrid.Chart.Series)
Public Property | DownFillStyle |
Public Property | DownStrokeStyle |
Public Property | EmptyDataPointStyle | (Inherited from ISNet.WebUI.WebGrid.Chart.Series)
Public Property | GlowImageFilter | (Inherited from ISNet.WebUI.WebGrid.Chart.Series)
Public Property | HighLowStrokeStyle |
Public Property | InteractiveStyle | (Inherited from ISNet.WebUI.WebGrid.Chart.Series)
Public Property | LightingImageFilter | (Inherited from ISNet.WebUI.WebGrid.Chart.Series)
Public Property | SeriesLegend | (Inherited from ISNet.WebUI.WebGrid.Chart.SeriesBase)
Public Property | ShadowStyle | (Inherited from ISNet.WebUI.WebGrid.Chart.SeriesBase)
Public Property | UpFillStyle |
Public Property | UpStrokeStyle |
Public Property | Visible | (Inherited from ISNet.WebUI.WebGrid.Chart.SeriesBase)
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

SeriesStock Class
ISNet.WebUI.WebGrid.Chart Namespace


SeriesStock Constructor

[image]
Intersoft WebGrid Documentation
SeriesStock Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > SeriesStock Class : SeriesStock Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New SeriesStock()
C#
public SeriesStock()
Delphi
public SeriesStock();
JScript
public function SeriesStock();
Managed Extensions for C++
public: SeriesStock();
C++/CLI
public:
SeriesStock();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesStock Class
SeriesStock Members


Clone Method

[image]
Intersoft WebGrid Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > SeriesStock Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As System.Object
Visual Basic (Usage) Copy Code
Dim instance As SeriesStock
Dim value As System.Object

value = instance.Clone()
C#
public virtual System.object Clone()
Delphi
public function Clone(): System.TObject; virtual;
JScript
public function Clone() : System.Object;
Managed Extensions for C++
public: virtual System.Object* Clone();
C++/CLI
public:
virtual System.Object^ Clone();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesStock Class
SeriesStock Members


CopyFrom Method

[image]
Intersoft WebGrid Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > SeriesStock Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesStock Class
SeriesStock Members


CopyFrom(Object) Method

[image]
Intersoft WebGrid Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > SeriesStock Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As SeriesStock
Dim objSource As System.Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   System.object objSource
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesStock Class
SeriesStock Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebGrid Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > SeriesStock Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object, _
   ByVal cloneSourceValue As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As SeriesStock
Dim objSource As System.Object
Dim cloneSourceValue As System.Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   System.object objSource,
   System.bool cloneSourceValue
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject;
    cloneSourceValue: System.Boolean
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object,
   cloneSourceValue : System.boolean
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource,
   System.bool cloneSourceValue
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource,
   System.bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesStock Class
SeriesStock Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebGrid Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > SeriesStock Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As SeriesStock
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure DeSerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function DeSerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void DeSerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void DeSerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesStock Class
SeriesStock Members


GetHashCode Method

[image]
Intersoft WebGrid Documentation
GetHashCode Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > SeriesStock Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As SeriesStock
Dim value As System.Integer

value = instance.GetHashCode()
C#
public virtual System.int GetHashCode()
Delphi
public function GetHashCode(): System.Integer; virtual;
JScript
public function GetHashCode() : System.int;
Managed Extensions for C++
public: virtual System.int GetHashCode();
C++/CLI
public:
virtual System.int GetHashCode();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesStock Class
SeriesStock Members


SeriesStock Class Methods

[image]
Intersoft WebGrid Documentation
SeriesStock Class Methods
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : SeriesStock Class

Glossary Item Box

For a list of all members of this type, see SeriesStock members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

SeriesStock Class
ISNet.WebUI.WebGrid.Chart Namespace


GetObjectData Method

[image]
Intersoft WebGrid Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > SeriesStock Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=False,
   UnmanagedCode=False,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=True,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Action=SecurityAction.Demand,
   Unrestricted=False)>
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As SeriesStock
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure GetObjectData(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
); override;
JScript
System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=,
   UnmanagedCode=,
   SkipVerification=,
   Execution=,
   ControlThread=,
   ControlEvidence=,
   ControlPolicy=,
   SerializationFormatter=,
   ControlDomainPolicy=,
   ControlPrincipal=,
   ControlAppDomain=,
   RemotingConfiguration=,
   Infrastructure=,
   BindingRedirects=,
   Action=SecurityAction.Demand,
   Unrestricted=)
public override function GetObjectData(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public: void GetObjectData(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
) override
C++/CLI
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public:
void GetObjectData(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
) override

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesStock Class
SeriesStock Members


IsEmpty Method

[image]
Intersoft WebGrid Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > SeriesStock Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As SeriesStock
Dim value As System.Boolean

value = instance.IsEmpty()
C#
public virtual System.bool IsEmpty()
Delphi
public function IsEmpty(): System.Boolean; virtual;
JScript
public function IsEmpty() : System.boolean;
Managed Extensions for C++
public: virtual System.bool IsEmpty();
C++/CLI
public:
virtual System.bool IsEmpty();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesStock Class
SeriesStock Members


Reset Method

[image]
Intersoft WebGrid Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > SeriesStock Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As SeriesStock

instance.Reset()
C#
public virtual void Reset()
Delphi
public procedure Reset(); virtual;
JScript
public function Reset();
Managed Extensions for C++
public: virtual void Reset();
C++/CLI
public:
virtual void Reset();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesStock Class
SeriesStock Members


SerializeObjectData Method

[image]
Intersoft WebGrid Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > SeriesStock Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As SeriesStock
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure SerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function SerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void SerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void SerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesStock Class
SeriesStock Members


ToString Method

[image]
Intersoft WebGrid Documentation
ToString Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > SeriesStock Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As System.String
Visual Basic (Usage) Copy Code
Dim instance As SeriesStock
Dim value As System.String

value = instance.ToString()
C#
public virtual System.string ToString()
Delphi
public function ToString(): System.String; virtual;
JScript
public function ToString() : System.String;
Managed Extensions for C++
public: virtual System.string* ToString();
C++/CLI
public:
virtual System.String^ ToString();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesStock Class
SeriesStock Members


SeriesStock Class Properties

[image]
Intersoft WebGrid Documentation
SeriesStock Class Properties
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : SeriesStock Class

Glossary Item Box

For a list of all members of this type, see SeriesStock members.

Public Properties

 | Name | Description
Public Property | AppearanceMode |
Public Property | BevelAndEmbossImageFilter | (Inherited from ISNet.WebUI.WebGrid.Chart.Series)
Public Property | BlurImageFilter | (Inherited from ISNet.WebUI.WebGrid.Chart.Series)
Public Property | BorderStyle | (Inherited from ISNet.WebUI.WebGrid.Chart.Series)
Public Property | CandleDepthPercent |
Public Property | CandleStyle |
Public Property | CandleWidth |
Public Property | ChartFillType | (Inherited from ISNet.WebUI.WebGrid.Chart.Series)
Public Property | DataLabelStyle | (Inherited from ISNet.WebUI.WebGrid.Chart.Series)
Public Property | DownFillStyle |
Public Property | DownStrokeStyle |
Public Property | EmptyDataPointStyle | (Inherited from ISNet.WebUI.WebGrid.Chart.Series)
Public Property | GlowImageFilter | (Inherited from ISNet.WebUI.WebGrid.Chart.Series)
Public Property | HighLowStrokeStyle |
Public Property | InteractiveStyle | (Inherited from ISNet.WebUI.WebGrid.Chart.Series)
Public Property | LightingImageFilter | (Inherited from ISNet.WebUI.WebGrid.Chart.Series)
Public Property | SeriesLegend | (Inherited from ISNet.WebUI.WebGrid.Chart.SeriesBase)
Public Property | ShadowStyle | (Inherited from ISNet.WebUI.WebGrid.Chart.SeriesBase)
Public Property | UpFillStyle |
Public Property | UpStrokeStyle |
Public Property | Visible | (Inherited from ISNet.WebUI.WebGrid.Chart.SeriesBase)
Top

See Also

Reference

SeriesStock Class
ISNet.WebUI.WebGrid.Chart Namespace


SeriesStock Constructor

[image]
Intersoft WebGrid Documentation
SeriesStock Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > SeriesStock Class : SeriesStock Constructor

Glossary Item Box

Overload List

Overload | Description
SeriesStock Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesStock Class
SeriesStock Members


AppearanceMode Property

[image]
Intersoft WebGrid Documentation
AppearanceMode Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > SeriesStock Class : AppearanceMode Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Controls the appearance mode of the stock series.")>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Options")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property AppearanceMode As SeriesAppearanceMode
Visual Basic (Usage) Copy Code
Dim instance As SeriesStock
Dim value As SeriesAppearanceMode

instance.AppearanceMode = value

value = instance.AppearanceMode
C#
[System.ComponentModel.DescriptionAttribute("Controls the appearance mode of the stock series.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Options")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public SeriesAppearanceMode AppearanceMode {get; set;}
Delphi
public read-write property AppearanceMode: SeriesAppearanceMode;
JScript
System.ComponentModel.DescriptionAttribute("Controls the appearance mode of the stock series.")
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Options")
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set AppearanceMode : SeriesAppearanceMode
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Controls the appearance mode of the stock series.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Options")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property SeriesAppearanceMode get_AppearanceMode();
public: __property void set_AppearanceMode(
   SeriesAppearanceMode value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Controls the appearance mode of the stock series.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Options")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property SeriesAppearanceMode AppearanceMode {
   SeriesAppearanceMode get();
   void set (    SeriesAppearanceMode value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesStock Class
SeriesStock Members


CandleDepthPercent Property

[image]
Intersoft WebGrid Documentation
CandleDepthPercent Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > SeriesStock Class : CandleDepthPercent Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Controls the appearance mode of the stock series.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("Options")>
Public Property CandleDepthPercent As System.Single
Visual Basic (Usage) Copy Code
Dim instance As SeriesStock
Dim value As System.Single

instance.CandleDepthPercent = value

value = instance.CandleDepthPercent
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Controls the appearance mode of the stock series.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Options")]
public System.float CandleDepthPercent {get; set;}
Delphi
public read-write property CandleDepthPercent: System.Single;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Controls the appearance mode of the stock series.")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("Options")
public function get,set CandleDepthPercent : System.float
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Controls the appearance mode of the stock series.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Options")]
public: __property System.float get_CandleDepthPercent();
public: __property void set_CandleDepthPercent(
   System.float value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Controls the appearance mode of the stock series.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Options")]
public:
property System.float CandleDepthPercent {
   System.float get();
   void set (    System.float value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesStock Class
SeriesStock Members


CandleStyle Property

[image]
Intersoft WebGrid Documentation
CandleStyle Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > SeriesStock Class : CandleStyle Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Options")>
<System.ComponentModel.DescriptionAttribute("Controls the shape of the candle")>
Public Property CandleStyle As CandleStyle
Visual Basic (Usage) Copy Code
Dim instance As SeriesStock
Dim value As CandleStyle

instance.CandleStyle = value

value = instance.CandleStyle
C#
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Options")]
[System.ComponentModel.DescriptionAttribute("Controls the shape of the candle")]
public CandleStyle CandleStyle {get; set;}
Delphi
public read-write property CandleStyle: CandleStyle;
JScript
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Options")
System.ComponentModel.DescriptionAttribute("Controls the shape of the candle")
public function get,set CandleStyle : CandleStyle
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Options")]
[System.ComponentModel.DescriptionAttribute("Controls the shape of the candle")]
public: __property CandleStyle get_CandleStyle();
public: __property void set_CandleStyle(
   CandleStyle value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Options")]
[System.ComponentModel.DescriptionAttribute("Controls the shape of the candle")]
public:
property CandleStyle CandleStyle {
   CandleStyle get();
   void set (    CandleStyle value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesStock Class
SeriesStock Members


CandleWidth Property

[image]
Intersoft WebGrid Documentation
CandleWidth Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > SeriesStock Class : CandleWidth Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Controls the width of the candle in model units.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Options")>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property CandleWidth As System.Nullable(Of Single)
Visual Basic (Usage) Copy Code
Dim instance As SeriesStock
Dim value As System.Nullable(Of Single)

instance.CandleWidth = value

value = instance.CandleWidth
C#
[System.ComponentModel.DescriptionAttribute("Controls the width of the candle in model units.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Options")]
[ISNet.Serialization.BinarySerializableAttribute()]
public System.Nullable<float> CandleWidth {get; set;}
Delphi
public read-write property CandleWidth: System.Nullable;
JScript
System.ComponentModel.DescriptionAttribute("Controls the width of the candle in model units.")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Options")
ISNet.Serialization.BinarySerializableAttribute()
public function get,set CandleWidth : System.Nullable
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Controls the width of the candle in model units.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Options")]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.Nullable<float> get_CandleWidth();
public: __property void set_CandleWidth(
   System.Nullable<float> value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Controls the width of the candle in model units.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Options")]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.Nullable<float> CandleWidth {
   System.Nullable<float> get();
   void set (    System.Nullable<float> value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesStock Class
SeriesStock Members


DownFillStyle Property

[image]
Intersoft WebGrid Documentation
DownFillStyle Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > SeriesStock Class : DownFillStyle Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Fill style applied to 'down' candles / sticks.")>
<ISNet.Serialization.BinarySerializableAttribute("setDownFillStyle")>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<System.ComponentModel.CategoryAttribute("Styles")>
Public ReadOnly Property DownFillStyle As ChartFillStyle
Visual Basic (Usage) Copy Code
Dim instance As SeriesStock
Dim value As ChartFillStyle

value = instance.DownFillStyle
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Fill style applied to 'down' candles / sticks.")]
[ISNet.Serialization.BinarySerializableAttribute("setDownFillStyle")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.CategoryAttribute("Styles")]
public ChartFillStyle DownFillStyle {get;}
Delphi
public read-only property DownFillStyle: ChartFillStyle;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Fill style applied to 'down' candles / sticks.")
ISNet.Serialization.BinarySerializableAttribute("setDownFillStyle")
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
System.ComponentModel.CategoryAttribute("Styles")
public function get DownFillStyle : ChartFillStyle
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Fill style applied to 'down' candles / sticks.")]
[ISNet.Serialization.BinarySerializableAttribute("setDownFillStyle")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.CategoryAttribute("Styles")]
public: __property ChartFillStyle* get_DownFillStyle();
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Fill style applied to 'down' candles / sticks.")]
[ISNet.Serialization.BinarySerializableAttribute("setDownFillStyle")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.CategoryAttribute("Styles")]
public:
property ChartFillStyle^ DownFillStyle {
   ChartFillStyle^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesStock Class
SeriesStock Members


DownStrokeStyle Property

[image]
Intersoft WebGrid Documentation
DownStrokeStyle Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > SeriesStock Class : DownStrokeStyle Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Stroke style applied to the 'down' candles / sticks.")>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute("setDownStrokeStyle")>
<System.ComponentModel.CategoryAttribute("Styles")>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
Public ReadOnly Property DownStrokeStyle As ChartStrokeStyle
Visual Basic (Usage) Copy Code
Dim instance As SeriesStock
Dim value As ChartStrokeStyle

value = instance.DownStrokeStyle
C#
[System.ComponentModel.DescriptionAttribute("Stroke style applied to the 'down' candles / sticks.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute("setDownStrokeStyle")]
[System.ComponentModel.CategoryAttribute("Styles")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
public ChartStrokeStyle DownStrokeStyle {get;}
Delphi
public read-only property DownStrokeStyle: ChartStrokeStyle;
JScript
System.ComponentModel.DescriptionAttribute("Stroke style applied to the 'down' candles / sticks.")
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute("setDownStrokeStyle")
System.ComponentModel.CategoryAttribute("Styles")
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
public function get DownStrokeStyle : ChartStrokeStyle
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Stroke style applied to the 'down' candles / sticks.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute("setDownStrokeStyle")]
[System.ComponentModel.CategoryAttribute("Styles")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
public: __property ChartStrokeStyle* get_DownStrokeStyle();
C++/CLI
[System.ComponentModel.DescriptionAttribute("Stroke style applied to the 'down' candles / sticks.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute("setDownStrokeStyle")]
[System.ComponentModel.CategoryAttribute("Styles")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
public:
property ChartStrokeStyle^ DownStrokeStyle {
   ChartStrokeStyle^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesStock Class
SeriesStock Members


HighLowStrokeStyle Property

[image]
Intersoft WebGrid Documentation
HighLowStrokeStyle Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > SeriesStock Class : HighLowStrokeStyle Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<ISNet.Serialization.BinarySerializableAttribute("setHighLowStrokeStyle")>
<System.ComponentModel.DescriptionAttribute("Stroke style applied to the high low line.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("Styles")>
Public ReadOnly Property HighLowStrokeStyle As ChartStrokeStyle
Visual Basic (Usage) Copy Code
Dim instance As SeriesStock
Dim value As ChartStrokeStyle

value = instance.HighLowStrokeStyle
C#
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.Serialization.BinarySerializableAttribute("setHighLowStrokeStyle")]
[System.ComponentModel.DescriptionAttribute("Stroke style applied to the high low line.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Styles")]
public ChartStrokeStyle HighLowStrokeStyle {get;}
Delphi
public read-only property HighLowStrokeStyle: ChartStrokeStyle;
JScript
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
ISNet.Serialization.BinarySerializableAttribute("setHighLowStrokeStyle")
System.ComponentModel.DescriptionAttribute("Stroke style applied to the high low line.")
System.ComponentModel.NotifyParentPropertyAttribute()
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("Styles")
public function get HighLowStrokeStyle : ChartStrokeStyle
Managed Extensions for C++
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.Serialization.BinarySerializableAttribute("setHighLowStrokeStyle")]
[System.ComponentModel.DescriptionAttribute("Stroke style applied to the high low line.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Styles")]
public: __property ChartStrokeStyle* get_HighLowStrokeStyle();
C++/CLI
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.Serialization.BinarySerializableAttribute("setHighLowStrokeStyle")]
[System.ComponentModel.DescriptionAttribute("Stroke style applied to the high low line.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Styles")]
public:
property ChartStrokeStyle^ HighLowStrokeStyle {
   ChartStrokeStyle^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesStock Class
SeriesStock Members


UpFillStyle Property

[image]
Intersoft WebGrid Documentation
UpFillStyle Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > SeriesStock Class : UpFillStyle Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<System.ComponentModel.DescriptionAttribute("Fill style applied to 'up' candles / sticks.")>
<ISNet.Serialization.BinarySerializableAttribute("setUpFillStyle")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.CategoryAttribute("Styles")>
Public ReadOnly Property UpFillStyle As ChartFillStyle
Visual Basic (Usage) Copy Code
Dim instance As SeriesStock
Dim value As ChartFillStyle

value = instance.UpFillStyle
C#
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DescriptionAttribute("Fill style applied to 'up' candles / sticks.")]
[ISNet.Serialization.BinarySerializableAttribute("setUpFillStyle")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.CategoryAttribute("Styles")]
public ChartFillStyle UpFillStyle {get;}
Delphi
public read-only property UpFillStyle: ChartFillStyle;
JScript
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
System.ComponentModel.DescriptionAttribute("Fill style applied to 'up' candles / sticks.")
ISNet.Serialization.BinarySerializableAttribute("setUpFillStyle")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.CategoryAttribute("Styles")
public function get UpFillStyle : ChartFillStyle
Managed Extensions for C++
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DescriptionAttribute("Fill style applied to 'up' candles / sticks.")]
[ISNet.Serialization.BinarySerializableAttribute("setUpFillStyle")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.CategoryAttribute("Styles")]
public: __property ChartFillStyle* get_UpFillStyle();
C++/CLI
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DescriptionAttribute("Fill style applied to 'up' candles / sticks.")]
[ISNet.Serialization.BinarySerializableAttribute("setUpFillStyle")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.CategoryAttribute("Styles")]
public:
property ChartFillStyle^ UpFillStyle {
   ChartFillStyle^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesStock Class
SeriesStock Members


UpStrokeStyle Property

[image]
Intersoft WebGrid Documentation
UpStrokeStyle Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > SeriesStock Class : UpStrokeStyle Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Stroke style applied to 'up' candles / sticks.")>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<System.ComponentModel.CategoryAttribute("Styles")>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute("setUpStrokeStyle")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public ReadOnly Property UpStrokeStyle As ChartStrokeStyle
Visual Basic (Usage) Copy Code
Dim instance As SeriesStock
Dim value As ChartStrokeStyle

value = instance.UpStrokeStyle
C#
[System.ComponentModel.DescriptionAttribute("Stroke style applied to 'up' candles / sticks.")]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.CategoryAttribute("Styles")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute("setUpStrokeStyle")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public ChartStrokeStyle UpStrokeStyle {get;}
Delphi
public read-only property UpStrokeStyle: ChartStrokeStyle;
JScript
System.ComponentModel.DescriptionAttribute("Stroke style applied to 'up' candles / sticks.")
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
System.ComponentModel.CategoryAttribute("Styles")
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute("setUpStrokeStyle")
System.ComponentModel.NotifyParentPropertyAttribute()
public function get UpStrokeStyle : ChartStrokeStyle
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Stroke style applied to 'up' candles / sticks.")]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.CategoryAttribute("Styles")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute("setUpStrokeStyle")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property ChartStrokeStyle* get_UpStrokeStyle();
C++/CLI
[System.ComponentModel.DescriptionAttribute("Stroke style applied to 'up' candles / sticks.")]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.CategoryAttribute("Styles")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute("setUpStrokeStyle")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property ChartStrokeStyle^ UpStrokeStyle {
   ChartStrokeStyle^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesStock Class
SeriesStock Members


SeriesXYScatter Class

[image]
Intersoft WebGrid Documentation
SeriesXYScatter Class
Members See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : SeriesXYScatter Class

Glossary Item Box

Object Model

SeriesXYScatter Class

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.SerializableAttribute()>
Public Class SeriesXYScatter
   Inherits Series
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Visual Basic (Usage) Copy Code
Dim instance As SeriesXYScatter
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public class SeriesXYScatter : Series, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Delphi
public class SeriesXYScatter = class(Series, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize)
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.SerializableAttribute()
public class SeriesXYScatter extends Series implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public __gc class SeriesXYScatter : public Series, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public ref class SeriesXYScatter : public Series, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.WebGrid.Chart.SeriesBase
ISNet.WebUI.WebGrid.Chart.Series
ISNet.WebUI.WebGrid.Chart.SeriesXYScatter
ISNet.WebUI.WebGrid.Chart.SeriesArea
ISNet.WebUI.WebGrid.Chart.SeriesStock
ISNet.WebUI.WebGrid.Chart.SeriesXYZScatter

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesXYScatter Members
ISNet.WebUI.WebGrid.Chart Namespace


SeriesXYScatter Class Members

[image]
Intersoft WebGrid Documentation
SeriesXYScatter Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : SeriesXYScatter Class

Glossary Item Box

The following tables list the members exposed by SeriesXYScatter.

Public Constructors

 | Name | Description
Public Constructor | SeriesXYScatter Constructor |
Top

Public Properties

 | Name | Description
Public Property | BevelAndEmbossImageFilter | (Inherited from ISNet.WebUI.WebGrid.Chart.Series)
Public Property | BlurImageFilter | (Inherited from ISNet.WebUI.WebGrid.Chart.Series)
Public Property | BorderStyle | (Inherited from ISNet.WebUI.WebGrid.Chart.Series)
Public Property | ChartFillType | (Inherited from ISNet.WebUI.WebGrid.Chart.Series)
Public Property | DataLabelStyle | (Inherited from ISNet.WebUI.WebGrid.Chart.Series)
Public Property | EmptyDataPointStyle | (Inherited from ISNet.WebUI.WebGrid.Chart.Series)
Public Property | GlowImageFilter | (Inherited from ISNet.WebUI.WebGrid.Chart.Series)
Public Property | InteractiveStyle | (Inherited from ISNet.WebUI.WebGrid.Chart.Series)
Public Property | LightingImageFilter | (Inherited from ISNet.WebUI.WebGrid.Chart.Series)
Public Property | SeriesLegend | (Inherited from ISNet.WebUI.WebGrid.Chart.SeriesBase)
Public Property | ShadowStyle | (Inherited from ISNet.WebUI.WebGrid.Chart.SeriesBase)
Public Property | Visible | (Inherited from ISNet.WebUI.WebGrid.Chart.SeriesBase)
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

SeriesXYScatter Class
ISNet.WebUI.WebGrid.Chart Namespace


SeriesXYScatter Constructor

[image]
Intersoft WebGrid Documentation
SeriesXYScatter Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > SeriesXYScatter Class : SeriesXYScatter Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New SeriesXYScatter()
C#
public SeriesXYScatter()
Delphi
public SeriesXYScatter();
JScript
public function SeriesXYScatter();
Managed Extensions for C++
public: SeriesXYScatter();
C++/CLI
public:
SeriesXYScatter();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesXYScatter Class
SeriesXYScatter Members


Clone Method

[image]
Intersoft WebGrid Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > SeriesXYScatter Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As System.Object
Visual Basic (Usage) Copy Code
Dim instance As SeriesXYScatter
Dim value As System.Object

value = instance.Clone()
C#
public virtual System.object Clone()
Delphi
public function Clone(): System.TObject; virtual;
JScript
public function Clone() : System.Object;
Managed Extensions for C++
public: virtual System.Object* Clone();
C++/CLI
public:
virtual System.Object^ Clone();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesXYScatter Class
SeriesXYScatter Members


CopyFrom Method

[image]
Intersoft WebGrid Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > SeriesXYScatter Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesXYScatter Class
SeriesXYScatter Members


CopyFrom(Object) Method

[image]
Intersoft WebGrid Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > SeriesXYScatter Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As SeriesXYScatter
Dim objSource As System.Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   System.object objSource
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesXYScatter Class
SeriesXYScatter Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebGrid Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > SeriesXYScatter Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object, _
   ByVal cloneSourceValue As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As SeriesXYScatter
Dim objSource As System.Object
Dim cloneSourceValue As System.Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   System.object objSource,
   System.bool cloneSourceValue
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject;
    cloneSourceValue: System.Boolean
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object,
   cloneSourceValue : System.boolean
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource,
   System.bool cloneSourceValue
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource,
   System.bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesXYScatter Class
SeriesXYScatter Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebGrid Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > SeriesXYScatter Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As SeriesXYScatter
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure DeSerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function DeSerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void DeSerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void DeSerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesXYScatter Class
SeriesXYScatter Members


GetHashCode Method

[image]
Intersoft WebGrid Documentation
GetHashCode Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > SeriesXYScatter Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As SeriesXYScatter
Dim value As System.Integer

value = instance.GetHashCode()
C#
public virtual System.int GetHashCode()
Delphi
public function GetHashCode(): System.Integer; virtual;
JScript
public function GetHashCode() : System.int;
Managed Extensions for C++
public: virtual System.int GetHashCode();
C++/CLI
public:
virtual System.int GetHashCode();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesXYScatter Class
SeriesXYScatter Members


SeriesXYScatter Class Methods

[image]
Intersoft WebGrid Documentation
SeriesXYScatter Class Methods
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : SeriesXYScatter Class

Glossary Item Box

For a list of all members of this type, see SeriesXYScatter members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

SeriesXYScatter Class
ISNet.WebUI.WebGrid.Chart Namespace


SeriesXYScatter Class Properties

[image]
Intersoft WebGrid Documentation
SeriesXYScatter Class Properties
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : SeriesXYScatter Class

Glossary Item Box

For a list of all members of this type, see SeriesXYScatter members.

Public Properties

 | Name | Description
Public Property | BevelAndEmbossImageFilter | (Inherited from ISNet.WebUI.WebGrid.Chart.Series)
Public Property | BlurImageFilter | (Inherited from ISNet.WebUI.WebGrid.Chart.Series)
Public Property | BorderStyle | (Inherited from ISNet.WebUI.WebGrid.Chart.Series)
Public Property | ChartFillType | (Inherited from ISNet.WebUI.WebGrid.Chart.Series)
Public Property | DataLabelStyle | (Inherited from ISNet.WebUI.WebGrid.Chart.Series)
Public Property | EmptyDataPointStyle | (Inherited from ISNet.WebUI.WebGrid.Chart.Series)
Public Property | GlowImageFilter | (Inherited from ISNet.WebUI.WebGrid.Chart.Series)
Public Property | InteractiveStyle | (Inherited from ISNet.WebUI.WebGrid.Chart.Series)
Public Property | LightingImageFilter | (Inherited from ISNet.WebUI.WebGrid.Chart.Series)
Public Property | SeriesLegend | (Inherited from ISNet.WebUI.WebGrid.Chart.SeriesBase)
Public Property | ShadowStyle | (Inherited from ISNet.WebUI.WebGrid.Chart.SeriesBase)
Public Property | Visible | (Inherited from ISNet.WebUI.WebGrid.Chart.SeriesBase)
Top

See Also

Reference

SeriesXYScatter Class
ISNet.WebUI.WebGrid.Chart Namespace


SeriesXYScatter Constructor

[image]
Intersoft WebGrid Documentation
SeriesXYScatter Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > SeriesXYScatter Class : SeriesXYScatter Constructor

Glossary Item Box

Overload List

Overload | Description
SeriesXYScatter Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesXYScatter Class
SeriesXYScatter Members


GetObjectData Method

[image]
Intersoft WebGrid Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > SeriesXYScatter Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=False,
   UnmanagedCode=False,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=True,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Action=SecurityAction.Demand,
   Unrestricted=False)>
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As SeriesXYScatter
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure GetObjectData(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
); override;
JScript
System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=,
   UnmanagedCode=,
   SkipVerification=,
   Execution=,
   ControlThread=,
   ControlEvidence=,
   ControlPolicy=,
   SerializationFormatter=,
   ControlDomainPolicy=,
   ControlPrincipal=,
   ControlAppDomain=,
   RemotingConfiguration=,
   Infrastructure=,
   BindingRedirects=,
   Action=SecurityAction.Demand,
   Unrestricted=)
public override function GetObjectData(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public: void GetObjectData(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
) override
C++/CLI
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public:
void GetObjectData(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
) override

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesXYScatter Class
SeriesXYScatter Members


IsEmpty Method

[image]
Intersoft WebGrid Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > SeriesXYScatter Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As SeriesXYScatter
Dim value As System.Boolean

value = instance.IsEmpty()
C#
public virtual System.bool IsEmpty()
Delphi
public function IsEmpty(): System.Boolean; virtual;
JScript
public function IsEmpty() : System.boolean;
Managed Extensions for C++
public: virtual System.bool IsEmpty();
C++/CLI
public:
virtual System.bool IsEmpty();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesXYScatter Class
SeriesXYScatter Members


Reset Method

[image]
Intersoft WebGrid Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > SeriesXYScatter Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As SeriesXYScatter

instance.Reset()
C#
public virtual void Reset()
Delphi
public procedure Reset(); virtual;
JScript
public function Reset();
Managed Extensions for C++
public: virtual void Reset();
C++/CLI
public:
virtual void Reset();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesXYScatter Class
SeriesXYScatter Members


SerializeObjectData Method

[image]
Intersoft WebGrid Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > SeriesXYScatter Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As SeriesXYScatter
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure SerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function SerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void SerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void SerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesXYScatter Class
SeriesXYScatter Members


ToString Method

[image]
Intersoft WebGrid Documentation
ToString Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > SeriesXYScatter Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As System.String
Visual Basic (Usage) Copy Code
Dim instance As SeriesXYScatter
Dim value As System.String

value = instance.ToString()
C#
public virtual System.string ToString()
Delphi
public function ToString(): System.String; virtual;
JScript
public function ToString() : System.String;
Managed Extensions for C++
public: virtual System.string* ToString();
C++/CLI
public:
virtual System.String^ ToString();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesXYScatter Class
SeriesXYScatter Members


SeriesXYZScatter Class

[image]
Intersoft WebGrid Documentation
SeriesXYZScatter Class
Members See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : SeriesXYZScatter Class

Glossary Item Box

Object Model

SeriesXYZScatter Class

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.SerializableAttribute()>
Public Class SeriesXYZScatter
   Inherits SeriesXYScatter
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Visual Basic (Usage) Copy Code
Dim instance As SeriesXYZScatter
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public class SeriesXYZScatter : SeriesXYScatter, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Delphi
public class SeriesXYZScatter = class(SeriesXYScatter, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize)
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.SerializableAttribute()
public class SeriesXYZScatter extends SeriesXYScatter implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public __gc class SeriesXYZScatter : public SeriesXYScatter, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public ref class SeriesXYZScatter : public SeriesXYScatter, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.WebGrid.Chart.SeriesBase
ISNet.WebUI.WebGrid.Chart.Series
ISNet.WebUI.WebGrid.Chart.SeriesXYScatter
ISNet.WebUI.WebGrid.Chart.SeriesXYZScatter
ISNet.WebUI.WebGrid.Chart.SeriesBar
ISNet.WebUI.WebGrid.Chart.SeriesBubble
ISNet.WebUI.WebGrid.Chart.SeriesLineBase
ISNet.WebUI.WebGrid.Chart.SeriesPoint

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesXYZScatter Members
ISNet.WebUI.WebGrid.Chart Namespace


SeriesXYZScatter Class Members

[image]
Intersoft WebGrid Documentation
SeriesXYZScatter Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : SeriesXYZScatter Class

Glossary Item Box

The following tables list the members exposed by SeriesXYZScatter.

Public Constructors

 | Name | Description
Public Constructor | SeriesXYZScatter Constructor |
Top

Public Properties

 | Name | Description
Public Property | BevelAndEmbossImageFilter | (Inherited from ISNet.WebUI.WebGrid.Chart.Series)
Public Property | BlurImageFilter | (Inherited from ISNet.WebUI.WebGrid.Chart.Series)
Public Property | BorderStyle | (Inherited from ISNet.WebUI.WebGrid.Chart.Series)
Public Property | ChartFillType | (Inherited from ISNet.WebUI.WebGrid.Chart.Series)
Public Property | DataLabelStyle | (Inherited from ISNet.WebUI.WebGrid.Chart.Series)
Public Property | EmptyDataPointStyle | (Inherited from ISNet.WebUI.WebGrid.Chart.Series)
Public Property | GlowImageFilter | (Inherited from ISNet.WebUI.WebGrid.Chart.Series)
Public Property | InteractiveStyle | (Inherited from ISNet.WebUI.WebGrid.Chart.Series)
Public Property | LightingImageFilter | (Inherited from ISNet.WebUI.WebGrid.Chart.Series)
Public Property | SeriesLegend | (Inherited from ISNet.WebUI.WebGrid.Chart.SeriesBase)
Public Property | ShadowStyle | (Inherited from ISNet.WebUI.WebGrid.Chart.SeriesBase)
Public Property | Visible | (Inherited from ISNet.WebUI.WebGrid.Chart.SeriesBase)
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

SeriesXYZScatter Class
ISNet.WebUI.WebGrid.Chart Namespace


SeriesXYZScatter Constructor

[image]
Intersoft WebGrid Documentation
SeriesXYZScatter Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > SeriesXYZScatter Class : SeriesXYZScatter Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New SeriesXYZScatter()
C#
public SeriesXYZScatter()
Delphi
public SeriesXYZScatter();
JScript
public function SeriesXYZScatter();
Managed Extensions for C++
public: SeriesXYZScatter();
C++/CLI
public:
SeriesXYZScatter();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesXYZScatter Class
SeriesXYZScatter Members


Clone Method

[image]
Intersoft WebGrid Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > SeriesXYZScatter Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As System.Object
Visual Basic (Usage) Copy Code
Dim instance As SeriesXYZScatter
Dim value As System.Object

value = instance.Clone()
C#
public virtual System.object Clone()
Delphi
public function Clone(): System.TObject; virtual;
JScript
public function Clone() : System.Object;
Managed Extensions for C++
public: virtual System.Object* Clone();
C++/CLI
public:
virtual System.Object^ Clone();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesXYZScatter Class
SeriesXYZScatter Members


CopyFrom Method

[image]
Intersoft WebGrid Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > SeriesXYZScatter Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesXYZScatter Class
SeriesXYZScatter Members


CopyFrom(Object) Method

[image]
Intersoft WebGrid Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > SeriesXYZScatter Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As SeriesXYZScatter
Dim objSource As System.Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   System.object objSource
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesXYZScatter Class
SeriesXYZScatter Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebGrid Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > SeriesXYZScatter Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object, _
   ByVal cloneSourceValue As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As SeriesXYZScatter
Dim objSource As System.Object
Dim cloneSourceValue As System.Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   System.object objSource,
   System.bool cloneSourceValue
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject;
    cloneSourceValue: System.Boolean
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object,
   cloneSourceValue : System.boolean
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource,
   System.bool cloneSourceValue
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource,
   System.bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesXYZScatter Class
SeriesXYZScatter Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebGrid Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > SeriesXYZScatter Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As SeriesXYZScatter
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure DeSerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function DeSerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void DeSerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void DeSerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesXYZScatter Class
SeriesXYZScatter Members


GetHashCode Method

[image]
Intersoft WebGrid Documentation
GetHashCode Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > SeriesXYZScatter Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As SeriesXYZScatter
Dim value As System.Integer

value = instance.GetHashCode()
C#
public virtual System.int GetHashCode()
Delphi
public function GetHashCode(): System.Integer; virtual;
JScript
public function GetHashCode() : System.int;
Managed Extensions for C++
public: virtual System.int GetHashCode();
C++/CLI
public:
virtual System.int GetHashCode();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesXYZScatter Class
SeriesXYZScatter Members


SeriesXYZScatter Class Methods

[image]
Intersoft WebGrid Documentation
SeriesXYZScatter Class Methods
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : SeriesXYZScatter Class

Glossary Item Box

For a list of all members of this type, see SeriesXYZScatter members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

SeriesXYZScatter Class
ISNet.WebUI.WebGrid.Chart Namespace


SeriesXYZScatter Class Properties

[image]
Intersoft WebGrid Documentation
SeriesXYZScatter Class Properties
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : SeriesXYZScatter Class

Glossary Item Box

For a list of all members of this type, see SeriesXYZScatter members.

Public Properties

 | Name | Description
Public Property | BevelAndEmbossImageFilter | (Inherited from ISNet.WebUI.WebGrid.Chart.Series)
Public Property | BlurImageFilter | (Inherited from ISNet.WebUI.WebGrid.Chart.Series)
Public Property | BorderStyle | (Inherited from ISNet.WebUI.WebGrid.Chart.Series)
Public Property | ChartFillType | (Inherited from ISNet.WebUI.WebGrid.Chart.Series)
Public Property | DataLabelStyle | (Inherited from ISNet.WebUI.WebGrid.Chart.Series)
Public Property | EmptyDataPointStyle | (Inherited from ISNet.WebUI.WebGrid.Chart.Series)
Public Property | GlowImageFilter | (Inherited from ISNet.WebUI.WebGrid.Chart.Series)
Public Property | InteractiveStyle | (Inherited from ISNet.WebUI.WebGrid.Chart.Series)
Public Property | LightingImageFilter | (Inherited from ISNet.WebUI.WebGrid.Chart.Series)
Public Property | SeriesLegend | (Inherited from ISNet.WebUI.WebGrid.Chart.SeriesBase)
Public Property | ShadowStyle | (Inherited from ISNet.WebUI.WebGrid.Chart.SeriesBase)
Public Property | Visible | (Inherited from ISNet.WebUI.WebGrid.Chart.SeriesBase)
Top

See Also

Reference

SeriesXYZScatter Class
ISNet.WebUI.WebGrid.Chart Namespace


SeriesXYZScatter Constructor

[image]
Intersoft WebGrid Documentation
SeriesXYZScatter Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > SeriesXYZScatter Class : SeriesXYZScatter Constructor

Glossary Item Box

Overload List

Overload | Description
SeriesXYZScatter Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesXYZScatter Class
SeriesXYZScatter Members


GetObjectData Method

[image]
Intersoft WebGrid Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > SeriesXYZScatter Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=False,
   UnmanagedCode=False,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=True,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Action=SecurityAction.Demand,
   Unrestricted=False)>
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As SeriesXYZScatter
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure GetObjectData(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
); override;
JScript
System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=,
   UnmanagedCode=,
   SkipVerification=,
   Execution=,
   ControlThread=,
   ControlEvidence=,
   ControlPolicy=,
   SerializationFormatter=,
   ControlDomainPolicy=,
   ControlPrincipal=,
   ControlAppDomain=,
   RemotingConfiguration=,
   Infrastructure=,
   BindingRedirects=,
   Action=SecurityAction.Demand,
   Unrestricted=)
public override function GetObjectData(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public: void GetObjectData(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
) override
C++/CLI
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public:
void GetObjectData(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
) override

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesXYZScatter Class
SeriesXYZScatter Members


IsEmpty Method

[image]
Intersoft WebGrid Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > SeriesXYZScatter Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As SeriesXYZScatter
Dim value As System.Boolean

value = instance.IsEmpty()
C#
public virtual System.bool IsEmpty()
Delphi
public function IsEmpty(): System.Boolean; virtual;
JScript
public function IsEmpty() : System.boolean;
Managed Extensions for C++
public: virtual System.bool IsEmpty();
C++/CLI
public:
virtual System.bool IsEmpty();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesXYZScatter Class
SeriesXYZScatter Members


Reset Method

[image]
Intersoft WebGrid Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > SeriesXYZScatter Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As SeriesXYZScatter

instance.Reset()
C#
public virtual void Reset()
Delphi
public procedure Reset(); virtual;
JScript
public function Reset();
Managed Extensions for C++
public: virtual void Reset();
C++/CLI
public:
virtual void Reset();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesXYZScatter Class
SeriesXYZScatter Members


SerializeObjectData Method

[image]
Intersoft WebGrid Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > SeriesXYZScatter Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As SeriesXYZScatter
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure SerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function SerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void SerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void SerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesXYZScatter Class
SeriesXYZScatter Members


ToString Method

[image]
Intersoft WebGrid Documentation
ToString Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > SeriesXYZScatter Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As System.String
Visual Basic (Usage) Copy Code
Dim instance As SeriesXYZScatter
Dim value As System.String

value = instance.ToString()
C#
public virtual System.string ToString()
Delphi
public function ToString(): System.String; virtual;
JScript
public function ToString() : System.String;
Managed Extensions for C++
public: virtual System.string* ToString();
C++/CLI
public:
virtual System.String^ ToString();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesXYZScatter Class
SeriesXYZScatter Members


WebGridChartEventArgs Class

[image]
Intersoft WebGrid Documentation
WebGridChartEventArgs Class
Members See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : WebGridChartEventArgs Class

Glossary Item Box

Object Model

WebGridChartEventArgs Class

Syntax

Visual Basic (Declaration)
<System.Web.AspNetHostingPermissionAttribute(Level=AspNetHostingPermissionLevel.Minimal,
   Action=SecurityAction.Demand Or  _
    SecurityAction.Deny Or  _
    SecurityAction.LinkDemand,
   Unrestricted=False)>
<System.Web.AspNetHostingPermissionAttribute(Level=AspNetHostingPermissionLevel.Minimal,
   Action=SecurityAction.Demand Or  _
    SecurityAction.Assert Or  _
    SecurityAction.Deny Or  _
    SecurityAction.PermitOnly Or  _
    SecurityAction.LinkDemand Or  _
    SecurityAction.InheritanceDemand,
   Unrestricted=False)>
Public Class WebGridChartEventArgs
   Inherits ISNet.WebUI.WebGrid.BaseEventArgs
Visual Basic (Usage) Copy Code
Dim instance As WebGridChartEventArgs
C#
[System.Web.AspNetHostingPermissionAttribute(Level=AspNetHostingPermissionLevel.Minimal,
   Action=SecurityAction.Demand |
    SecurityAction.Deny |
    SecurityAction.LinkDemand,
   Unrestricted=false)]
[System.Web.AspNetHostingPermissionAttribute(Level=AspNetHostingPermissionLevel.Minimal,
   Action=SecurityAction.Demand |
    SecurityAction.Assert |
    SecurityAction.Deny |
    SecurityAction.PermitOnly |
    SecurityAction.LinkDemand |
    SecurityAction.InheritanceDemand,
   Unrestricted=false)]
public class WebGridChartEventArgs : ISNet.WebUI.WebGrid.BaseEventArgs
Delphi
public class WebGridChartEventArgs = class(ISNet.WebUI.WebGrid.BaseEventArgs)
JScript
System.Web.AspNetHostingPermissionAttribute(Level=AspNetHostingPermissionLevel.Minimal,
   Action=SecurityAction.Demand |
    SecurityAction.Deny |
    SecurityAction.LinkDemand,
   Unrestricted=)
System.Web.AspNetHostingPermissionAttribute(Level=AspNetHostingPermissionLevel.Minimal,
   Action=SecurityAction.Demand |
    SecurityAction.Assert |
    SecurityAction.Deny |
    SecurityAction.PermitOnly |
    SecurityAction.LinkDemand |
    SecurityAction.InheritanceDemand,
   Unrestricted=)
public class WebGridChartEventArgs extends ISNet.WebUI.WebGrid.BaseEventArgs
Managed Extensions for C++
[System.Web.AspNetHostingPermissionAttribute(Level=AspNetHostingPermissionLevel.Minimal,
   Action=SecurityAction.Demand |
    SecurityAction.Deny |
    SecurityAction.LinkDemand,
   Unrestricted=false)]
[System.Web.AspNetHostingPermissionAttribute(Level=AspNetHostingPermissionLevel.Minimal,
   Action=SecurityAction.Demand |
    SecurityAction.Assert |
    SecurityAction.Deny |
    SecurityAction.PermitOnly |
    SecurityAction.LinkDemand |
    SecurityAction.InheritanceDemand,
   Unrestricted=false)]
public __gc class WebGridChartEventArgs : public ISNet.WebUI.WebGrid.BaseEventArgs
C++/CLI
[System.Web.AspNetHostingPermissionAttribute(Level=AspNetHostingPermissionLevel.Minimal,
   Action=SecurityAction.Demand |
    SecurityAction.Deny |
    SecurityAction.LinkDemand,
   Unrestricted=false)]
[System.Web.AspNetHostingPermissionAttribute(Level=AspNetHostingPermissionLevel.Minimal,
   Action=SecurityAction.Demand |
    SecurityAction.Assert |
    SecurityAction.Deny |
    SecurityAction.PermitOnly |
    SecurityAction.LinkDemand |
    SecurityAction.InheritanceDemand,
   Unrestricted=false)]
public ref class WebGridChartEventArgs : public ISNet.WebUI.WebGrid.BaseEventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
ISNet.WebUI.WebGrid.BaseEventArgs
ISNet.WebUI.WebGrid.Chart.WebGridChartEventArgs

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridChartEventArgs Members
ISNet.WebUI.WebGrid.Chart Namespace


WebGridChartEventArgs Class Members

[image]
Intersoft WebGrid Documentation
WebGridChartEventArgs Class Members
See Also Properties Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : WebGridChartEventArgs Class

Glossary Item Box

The following tables list the members exposed by WebGridChartEventArgs.

Public Constructors

 | Name | Description
Public Constructor | WebGridChartEventArgs Constructor |
Top

Public Properties

 | Name | Description
Public Property | AlternativeChartEngine |
Public Property | ChartConfig |
Public Property | ReturnValue | (Inherited from ISNet.WebUI.WebGrid.BaseEventArgs)
Public Property | Table |
Top

See Also

Reference

WebGridChartEventArgs Class
ISNet.WebUI.WebGrid.Chart Namespace


WebGridChartEventArgs Constructor

[image]
Intersoft WebGrid Documentation
WebGridChartEventArgs Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > WebGridChartEventArgs Class : WebGridChartEventArgs Constructor

chartConfig
table

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal chartConfig As ChartConfig, _
   ByVal table As System.Data.DataTable _
)
Visual Basic (Usage) Copy Code
Dim chartConfig As ChartConfig
Dim table As System.Data.DataTable

Dim instance As New WebGridChartEventArgs(chartConfig, table)
C#
public WebGridChartEventArgs(
   ChartConfig chartConfig,
   System.Data.DataTable table
)
Delphi
public WebGridChartEventArgs(
    chartConfig: ChartConfig;
    table: System.Data.DataTable
);
JScript
public function WebGridChartEventArgs(
   chartConfig : ChartConfig,
   table : System.Data.DataTable
);
Managed Extensions for C++
public: WebGridChartEventArgs(
   ChartConfig* chartConfig,
   System.Data.DataTable* table
)
C++/CLI
public:
WebGridChartEventArgs(
   ChartConfig^ chartConfig,
   System.Data.DataTable^ table
)

Parameters

chartConfig
table

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridChartEventArgs Class
WebGridChartEventArgs Members


WebGridChartEventArgs Class Properties

[image]
Intersoft WebGrid Documentation
WebGridChartEventArgs Class Properties
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : WebGridChartEventArgs Class

Glossary Item Box

For a list of all members of this type, see WebGridChartEventArgs members.

Public Properties

 | Name | Description
Public Property | AlternativeChartEngine |
Public Property | ChartConfig |
Public Property | ReturnValue | (Inherited from ISNet.WebUI.WebGrid.BaseEventArgs)
Public Property | Table |
Top

See Also

Reference

WebGridChartEventArgs Class
ISNet.WebUI.WebGrid.Chart Namespace


AlternativeChartEngine Property

[image]
Intersoft WebGrid Documentation
AlternativeChartEngine Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > WebGridChartEventArgs Class : AlternativeChartEngine Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property AlternativeChartEngine As IChartEngine
Visual Basic (Usage) Copy Code
Dim instance As WebGridChartEventArgs
Dim value As IChartEngine

instance.AlternativeChartEngine = value

value = instance.AlternativeChartEngine
C#
public IChartEngine AlternativeChartEngine {get; set;}
Delphi
public read-write property AlternativeChartEngine: IChartEngine;
JScript
public function get,set AlternativeChartEngine : IChartEngine
Managed Extensions for C++
public: __property IChartEngine* get_AlternativeChartEngine();
public: __property void set_AlternativeChartEngine(
   IChartEngine* value
);
C++/CLI
public:
property IChartEngine^ AlternativeChartEngine {
   IChartEngine^ get();
   void set (    IChartEngine^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridChartEventArgs Class
WebGridChartEventArgs Members


ChartConfig Property

[image]
Intersoft WebGrid Documentation
ChartConfig Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > WebGridChartEventArgs Class : ChartConfig Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ChartConfig As ChartConfig
Visual Basic (Usage) Copy Code
Dim instance As WebGridChartEventArgs
Dim value As ChartConfig

value = instance.ChartConfig
C#
public ChartConfig ChartConfig {get;}
Delphi
public read-only property ChartConfig: ChartConfig;
JScript
public function get ChartConfig : ChartConfig
Managed Extensions for C++
public: __property ChartConfig* get_ChartConfig();
C++/CLI
public:
property ChartConfig^ ChartConfig {
   ChartConfig^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridChartEventArgs Class
WebGridChartEventArgs Members


Table Property

[image]
Intersoft WebGrid Documentation
Table Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > WebGridChartEventArgs Class : Table Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Table As System.Data.DataTable
Visual Basic (Usage) Copy Code
Dim instance As WebGridChartEventArgs
Dim value As System.Data.DataTable

value = instance.Table
C#
public System.Data.DataTable Table {get;}
Delphi
public read-only property Table: System.Data.DataTable;
JScript
public function get Table : System.Data.DataTable
Managed Extensions for C++
public: __property System.Data.DataTable* get_Table();
C++/CLI
public:
property System.Data.DataTable^ Table {
   System.Data.DataTable^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridChartEventArgs Class
WebGridChartEventArgs Members


WebGridChartStatusArgs Class

[image]
Intersoft WebGrid Documentation
WebGridChartStatusArgs Class
Members See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : WebGridChartStatusArgs Class

Glossary Item Box

Object Model

WebGridChartStatusArgs Class

Syntax

Visual Basic (Declaration)
<System.Web.AspNetHostingPermissionAttribute(Level=AspNetHostingPermissionLevel.Minimal,
   Action=SecurityAction.Demand Or  _
    SecurityAction.Deny Or  _
    SecurityAction.LinkDemand,
   Unrestricted=False)>
<System.Web.AspNetHostingPermissionAttribute(Level=AspNetHostingPermissionLevel.Minimal,
   Action=SecurityAction.Demand Or  _
    SecurityAction.Assert Or  _
    SecurityAction.Deny Or  _
    SecurityAction.PermitOnly Or  _
    SecurityAction.LinkDemand Or  _
    SecurityAction.InheritanceDemand,
   Unrestricted=False)>
Public Class WebGridChartStatusArgs
   Inherits ISNet.WebUI.WebGrid.BaseEventArgs
Visual Basic (Usage) Copy Code
Dim instance As WebGridChartStatusArgs
C#
[System.Web.AspNetHostingPermissionAttribute(Level=AspNetHostingPermissionLevel.Minimal,
   Action=SecurityAction.Demand |
    SecurityAction.Deny |
    SecurityAction.LinkDemand,
   Unrestricted=false)]
[System.Web.AspNetHostingPermissionAttribute(Level=AspNetHostingPermissionLevel.Minimal,
   Action=SecurityAction.Demand |
    SecurityAction.Assert |
    SecurityAction.Deny |
    SecurityAction.PermitOnly |
    SecurityAction.LinkDemand |
    SecurityAction.InheritanceDemand,
   Unrestricted=false)]
public class WebGridChartStatusArgs : ISNet.WebUI.WebGrid.BaseEventArgs
Delphi
public class WebGridChartStatusArgs = class(ISNet.WebUI.WebGrid.BaseEventArgs)
JScript
System.Web.AspNetHostingPermissionAttribute(Level=AspNetHostingPermissionLevel.Minimal,
   Action=SecurityAction.Demand |
    SecurityAction.Deny |
    SecurityAction.LinkDemand,
   Unrestricted=)
System.Web.AspNetHostingPermissionAttribute(Level=AspNetHostingPermissionLevel.Minimal,
   Action=SecurityAction.Demand |
    SecurityAction.Assert |
    SecurityAction.Deny |
    SecurityAction.PermitOnly |
    SecurityAction.LinkDemand |
    SecurityAction.InheritanceDemand,
   Unrestricted=)
public class WebGridChartStatusArgs extends ISNet.WebUI.WebGrid.BaseEventArgs
Managed Extensions for C++
[System.Web.AspNetHostingPermissionAttribute(Level=AspNetHostingPermissionLevel.Minimal,
   Action=SecurityAction.Demand |
    SecurityAction.Deny |
    SecurityAction.LinkDemand,
   Unrestricted=false)]
[System.Web.AspNetHostingPermissionAttribute(Level=AspNetHostingPermissionLevel.Minimal,
   Action=SecurityAction.Demand |
    SecurityAction.Assert |
    SecurityAction.Deny |
    SecurityAction.PermitOnly |
    SecurityAction.LinkDemand |
    SecurityAction.InheritanceDemand,
   Unrestricted=false)]
public __gc class WebGridChartStatusArgs : public ISNet.WebUI.WebGrid.BaseEventArgs
C++/CLI
[System.Web.AspNetHostingPermissionAttribute(Level=AspNetHostingPermissionLevel.Minimal,
   Action=SecurityAction.Demand |
    SecurityAction.Deny |
    SecurityAction.LinkDemand,
   Unrestricted=false)]
[System.Web.AspNetHostingPermissionAttribute(Level=AspNetHostingPermissionLevel.Minimal,
   Action=SecurityAction.Demand |
    SecurityAction.Assert |
    SecurityAction.Deny |
    SecurityAction.PermitOnly |
    SecurityAction.LinkDemand |
    SecurityAction.InheritanceDemand,
   Unrestricted=false)]
public ref class WebGridChartStatusArgs : public ISNet.WebUI.WebGrid.BaseEventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
ISNet.WebUI.WebGrid.BaseEventArgs
ISNet.WebUI.WebGrid.Chart.WebGridChartStatusArgs

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridChartStatusArgs Members
ISNet.WebUI.WebGrid.Chart Namespace


WebGridChartStatusArgs Class Members

[image]
Intersoft WebGrid Documentation
WebGridChartStatusArgs Class Members
See Also Properties Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : WebGridChartStatusArgs Class

Glossary Item Box

The following tables list the members exposed by WebGridChartStatusArgs.

Public Constructors

 | Name | Description
Public Constructor | WebGridChartStatusArgs Constructor |
Top

Public Properties

 | Name | Description
Public Property | Image |
Public Property | ReturnValue | (Inherited from ISNet.WebUI.WebGrid.BaseEventArgs)
Top

See Also

Reference

WebGridChartStatusArgs Class
ISNet.WebUI.WebGrid.Chart Namespace


WebGridChartStatusArgs Constructor

[image]
Intersoft WebGrid Documentation
WebGridChartStatusArgs Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > WebGridChartStatusArgs Class : WebGridChartStatusArgs Constructor

image

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal image As System.Drawing.Bitmap _
)
Visual Basic (Usage) Copy Code
Dim image As System.Drawing.Bitmap

Dim instance As New WebGridChartStatusArgs(image)
C#
public WebGridChartStatusArgs(
   System.Drawing.Bitmap image
)
Delphi
public WebGridChartStatusArgs(
    image: System.Drawing.Bitmap
);
JScript
public function WebGridChartStatusArgs(
   image : System.Drawing.Bitmap
);
Managed Extensions for C++
public: WebGridChartStatusArgs(
   System.Drawing.Bitmap* image
)
C++/CLI
public:
WebGridChartStatusArgs(
   System.Drawing.Bitmap^ image
)

Parameters

image

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridChartStatusArgs Class
WebGridChartStatusArgs Members


WebGridChartStatusArgs Class Properties

[image]
Intersoft WebGrid Documentation
WebGridChartStatusArgs Class Properties
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : WebGridChartStatusArgs Class

Glossary Item Box

For a list of all members of this type, see WebGridChartStatusArgs members.

Public Properties

 | Name | Description
Public Property | Image |
Public Property | ReturnValue | (Inherited from ISNet.WebUI.WebGrid.BaseEventArgs)
Top

See Also

Reference

WebGridChartStatusArgs Class
ISNet.WebUI.WebGrid.Chart Namespace


Image Property

[image]
Intersoft WebGrid Documentation
Image Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > WebGridChartStatusArgs Class : Image Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Image As System.Drawing.Bitmap
Visual Basic (Usage) Copy Code
Dim instance As WebGridChartStatusArgs
Dim value As System.Drawing.Bitmap

value = instance.Image
C#
public System.Drawing.Bitmap Image {get;}
Delphi
public read-only property Image: System.Drawing.Bitmap;
JScript
public function get Image : System.Drawing.Bitmap
Managed Extensions for C++
public: __property System.Drawing.Bitmap* get_Image();
C++/CLI
public:
property System.Drawing.Bitmap^ Image {
   System.Drawing.Bitmap^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridChartStatusArgs Class
WebGridChartStatusArgs Members


AutoCalc Enumeration

[image]
Intersoft WebGrid Documentation
AutoCalc Enumeration
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : AutoCalc Enumeration

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Enum AutoCalc
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As AutoCalc
C#
public enum AutoCalc : System.Enum
Delphi
public enum AutoCalc = class(System.Enum)
JScript
public enum AutoCalc extends System.Enum
Managed Extensions for C++
__value public enum AutoCalc : public System.Enum
C++/CLI
public enum class AutoCalc : public System.Enum

Members

Member | Description
Avg |
Count |
Max |
Min |
StDev |
Sum |
Var |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebGrid.Chart.AutoCalc

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebGrid.Chart Namespace


BackplaneShape Enumeration

[image]
Intersoft WebGrid Documentation
BackplaneShape Enumeration
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : BackplaneShape Enumeration

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Enum BackplaneShape
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As BackplaneShape
C#
public enum BackplaneShape : System.Enum
Delphi
public enum BackplaneShape = class(System.Enum)
JScript
public enum BackplaneShape extends System.Enum
Managed Extensions for C++
__value public enum BackplaneShape : public System.Enum
C++/CLI
public enum class BackplaneShape : public System.Enum

Members

Member | Description
Circle |
CutEdgeRectangle |
Ellipse |
Rectangle |
SmoothEdgeRectangle |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebGrid.Chart.BackplaneShape

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebGrid.Chart Namespace


BarShape Enumeration

[image]
Intersoft WebGrid Documentation
BarShape Enumeration
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : BarShape Enumeration

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Enum BarShape
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As BarShape
C#
public enum BarShape : System.Enum
Delphi
public enum BarShape = class(System.Enum)
JScript
public enum BarShape extends System.Enum
Managed Extensions for C++
__value public enum BarShape : public System.Enum
C++/CLI
public enum class BarShape : public System.Enum

Members

Member | Description
Bar |
Cone |
CutEdgeBar |
Cylinder |
Ellipsoid |
InvertedCone |
InvertedPyramid |
Pyramid |
SmoothEdgeBar |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebGrid.Chart.BarShape

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebGrid.Chart Namespace


BevelType Enumeration

[image]
Intersoft WebGrid Documentation
BevelType Enumeration
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : BevelType Enumeration

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Enum BevelType
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As BevelType
C#
public enum BevelType : System.Enum
Delphi
public enum BevelType = class(System.Enum)
JScript
public enum BevelType extends System.Enum
Managed Extensions for C++
__value public enum BevelType : public System.Enum
C++/CLI
public enum class BevelType : public System.Enum

Members

Member | Description
Emboss |
Inner |
Outer |
PillowEmboss |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebGrid.Chart.BevelType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebGrid.Chart Namespace


BlurType Enumeration

[image]
Intersoft WebGrid Documentation
BlurType Enumeration
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : BlurType Enumeration

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Enum BlurType
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As BlurType
C#
public enum BlurType : System.Enum
Delphi
public enum BlurType = class(System.Enum)
JScript
public enum BlurType extends System.Enum
Managed Extensions for C++
__value public enum BlurType : public System.Enum
C++/CLI
public enum class BlurType : public System.Enum

Members

Member | Description
Gaussian |
Linear |
Radial |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebGrid.Chart.BlurType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebGrid.Chart Namespace


BoundsMode Enumeration

[image]
Intersoft WebGrid Documentation
BoundsMode Enumeration
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : BoundsMode Enumeration

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Enum BoundsMode
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As BoundsMode
C#
public enum BoundsMode : System.Enum
Delphi
public enum BoundsMode = class(System.Enum)
JScript
public enum BoundsMode extends System.Enum
Managed Extensions for C++
__value public enum BoundsMode : public System.Enum
C++/CLI
public enum class BoundsMode : public System.Enum

Members

Member | Description
Automatic |
Fit |
None |
Stretch |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebGrid.Chart.BoundsMode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebGrid.Chart Namespace


CandleStyle Enumeration

[image]
Intersoft WebGrid Documentation
CandleStyle Enumeration
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : CandleStyle Enumeration

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Enum CandleStyle
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As CandleStyle
C#
public enum CandleStyle : System.Enum
Delphi
public enum CandleStyle = class(System.Enum)
JScript
public enum CandleStyle extends System.Enum
Managed Extensions for C++
__value public enum CandleStyle : public System.Enum
C++/CLI
public enum class CandleStyle : public System.Enum

Members

Member | Description
Bar |
Stick |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebGrid.Chart.CandleStyle

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebGrid.Chart Namespace


ChartAxis Enumeration

[image]
Intersoft WebGrid Documentation
ChartAxis Enumeration
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartAxis Enumeration

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Enum ChartAxis
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As ChartAxis
C#
public enum ChartAxis : System.Enum
Delphi
public enum ChartAxis = class(System.Enum)
JScript
public enum ChartAxis extends System.Enum
Managed Extensions for C++
__value public enum ChartAxis : public System.Enum
C++/CLI
public enum class ChartAxis : public System.Enum

Members

Member | Description
XAxis |
YAxis |
ZAxis |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebGrid.Chart.ChartAxis

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebGrid.Chart Namespace


ChartEngineType Enumeration

[image]
Intersoft WebGrid Documentation
ChartEngineType Enumeration
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartEngineType Enumeration

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Enum ChartEngineType
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As ChartEngineType
C#
public enum ChartEngineType : System.Enum
Delphi
public enum ChartEngineType = class(System.Enum)
JScript
public enum ChartEngineType extends System.Enum
Managed Extensions for C++
__value public enum ChartEngineType : public System.Enum
C++/CLI
public enum class ChartEngineType : public System.Enum

Members

Member | Description
BuiltIn |
Nevron |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebGrid.Chart.ChartEngineType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebGrid.Chart Namespace


ChartFillType Enumeration

[image]
Intersoft WebGrid Documentation
ChartFillType Enumeration
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartFillType Enumeration

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Enum ChartFillType
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As ChartFillType
C#
public enum ChartFillType : System.Enum
Delphi
public enum ChartFillType = class(System.Enum)
JScript
public enum ChartFillType extends System.Enum
Managed Extensions for C++
__value public enum ChartFillType : public System.Enum
C++/CLI
public enum class ChartFillType : public System.Enum

Members

Member | Description
ColorFill |
GradientFill |
HatchFill |
ImageFill |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebGrid.Chart.ChartFillType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebGrid.Chart Namespace


ChartFrameType Enumeration

[image]
Intersoft WebGrid Documentation
ChartFrameType Enumeration
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartFrameType Enumeration

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Enum ChartFrameType
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As ChartFrameType
C#
public enum ChartFrameType : System.Enum
Delphi
public enum ChartFrameType = class(System.Enum)
JScript
public enum ChartFrameType extends System.Enum
Managed Extensions for C++
__value public enum ChartFrameType : public System.Enum
C++/CLI
public enum class ChartFrameType : public System.Enum

Members

Member | Description
ImageFrame |
None |
StandardFrame |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebGrid.Chart.ChartFrameType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebGrid.Chart Namespace


ChartImageFormat Enumeration

[image]
Intersoft WebGrid Documentation
ChartImageFormat Enumeration
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartImageFormat Enumeration

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Enum ChartImageFormat
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As ChartImageFormat
C#
public enum ChartImageFormat : System.Enum
Delphi
public enum ChartImageFormat = class(System.Enum)
JScript
public enum ChartImageFormat extends System.Enum
Managed Extensions for C++
__value public enum ChartImageFormat : public System.Enum
C++/CLI
public enum class ChartImageFormat : public System.Enum

Members

Member | Description
Bitmap |
Gif |
Jpeg |
Png |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebGrid.Chart.ChartImageFormat

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebGrid.Chart Namespace


ChartMode Enumeration

[image]
Intersoft WebGrid Documentation
ChartMode Enumeration
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartMode Enumeration

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Enum ChartMode
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As ChartMode
C#
public enum ChartMode : System.Enum
Delphi
public enum ChartMode = class(System.Enum)
JScript
public enum ChartMode extends System.Enum
Managed Extensions for C++
__value public enum ChartMode : public System.Enum
C++/CLI
public enum class ChartMode : public System.Enum

Members

Member | Description
DisplayOnly |
InteractiveUI |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebGrid.Chart.ChartMode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebGrid.Chart Namespace


ChartType Enumeration

[image]
Intersoft WebGrid Documentation
ChartType Enumeration
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ChartType Enumeration

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Enum ChartType
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As ChartType
C#
public enum ChartType : System.Enum
Delphi
public enum ChartType = class(System.Enum)
JScript
public enum ChartType extends System.Enum
Managed Extensions for C++
__value public enum ChartType : public System.Enum
C++/CLI
public enum class ChartType : public System.Enum

Members

Member | Description
Area |
Bar |
Column |
Doughnut |
Line |
Pie |
SmoothLine |
StepLine |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebGrid.Chart.ChartType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebGrid.Chart Namespace


ContentAlignment Enumeration

[image]
Intersoft WebGrid Documentation
ContentAlignment Enumeration
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ContentAlignment Enumeration

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Enum ContentAlignment
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As ContentAlignment
C#
public enum ContentAlignment : System.Enum
Delphi
public enum ContentAlignment = class(System.Enum)
JScript
public enum ContentAlignment extends System.Enum
Managed Extensions for C++
__value public enum ContentAlignment : public System.Enum
C++/CLI
public enum class ContentAlignment : public System.Enum

Members

Member | Description
BottomCenter |
BottomLeft |
BottomRight |
MiddleCenter |
MiddleLeft |
MiddleRight |
TopCenter |
TopLeft |
TopRight |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebGrid.Chart.ContentAlignment

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebGrid.Chart Namespace


CursorType Enumeration

[image]
Intersoft WebGrid Documentation
CursorType Enumeration
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : CursorType Enumeration

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Enum CursorType
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As CursorType
C#
public enum CursorType : System.Enum
Delphi
public enum CursorType = class(System.Enum)
JScript
public enum CursorType extends System.Enum
Managed Extensions for C++
__value public enum CursorType : public System.Enum
C++/CLI
public enum class CursorType : public System.Enum

Members

Member | Description
AppStarting |
Arrow |
Cross |
Default |
Hand |
Help |
HSplit |
IBeam |
No |
NoMove2D |
NoMoveHoriz |
NoMoveVert |
PanEast |
PanNE |
PanNorth |
PanNW |
PanSE |
PanSouth |
PanSW |
PanWest |
SizeAll |
SizeNESW |
SizeNS |
SizeNWSE |
SizeWE |
UpArrow |
VSplit |
WaitCursor |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebGrid.Chart.CursorType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebGrid.Chart Namespace


DateInterval Enumeration

[image]
Intersoft WebGrid Documentation
DateInterval Enumeration
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : DateInterval Enumeration

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Enum DateInterval
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As DateInterval
C#
public enum DateInterval : System.Enum
Delphi
public enum DateInterval = class(System.Enum)
JScript
public enum DateInterval extends System.Enum
Managed Extensions for C++
__value public enum DateInterval : public System.Enum
C++/CLI
public enum class DateInterval : public System.Enum

Members

Member | Description
Months |
Quarters |
Weeks |
Years |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebGrid.Chart.DateInterval

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebGrid.Chart Namespace


EmptyDataPointsAppearanceMode Enumeration

[image]
Intersoft WebGrid Documentation
EmptyDataPointsAppearanceMode Enumeration
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : EmptyDataPointsAppearanceMode Enumeration

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Enum EmptyDataPointsAppearanceMode
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As EmptyDataPointsAppearanceMode
C#
public enum EmptyDataPointsAppearanceMode : System.Enum
Delphi
public enum EmptyDataPointsAppearanceMode = class(System.Enum)
JScript
public enum EmptyDataPointsAppearanceMode extends System.Enum
Managed Extensions for C++
__value public enum EmptyDataPointsAppearanceMode : public System.Enum
C++/CLI
public enum class EmptyDataPointsAppearanceMode : public System.Enum

Members

Member | Description
None |
Normal |
Special |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebGrid.Chart.EmptyDataPointsAppearanceMode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebGrid.Chart Namespace


EmptyDataPointsMarkerMode Enumeration

[image]
Intersoft WebGrid Documentation
EmptyDataPointsMarkerMode Enumeration
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : EmptyDataPointsMarkerMode Enumeration

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Enum EmptyDataPointsMarkerMode
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As EmptyDataPointsMarkerMode
C#
public enum EmptyDataPointsMarkerMode : System.Enum
Delphi
public enum EmptyDataPointsMarkerMode = class(System.Enum)
JScript
public enum EmptyDataPointsMarkerMode extends System.Enum
Managed Extensions for C++
__value public enum EmptyDataPointsMarkerMode : public System.Enum
C++/CLI
public enum class EmptyDataPointsMarkerMode : public System.Enum

Members

Member | Description
Normal |
Special |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebGrid.Chart.EmptyDataPointsMarkerMode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebGrid.Chart Namespace


FrameBevelStyle Enumeration

[image]
Intersoft WebGrid Documentation
FrameBevelStyle Enumeration
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : FrameBevelStyle Enumeration

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Enum FrameBevelStyle
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As FrameBevelStyle
C#
public enum FrameBevelStyle : System.Enum
Delphi
public enum FrameBevelStyle = class(System.Enum)
JScript
public enum FrameBevelStyle extends System.Enum
Managed Extensions for C++
__value public enum FrameBevelStyle : public System.Enum
C++/CLI
public enum class FrameBevelStyle : public System.Enum

Members

Member | Description
None |
Raised |
Sunken |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebGrid.Chart.FrameBevelStyle

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebGrid.Chart Namespace


GlowType Enumeration

[image]
Intersoft WebGrid Documentation
GlowType Enumeration
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : GlowType Enumeration

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Enum GlowType
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As GlowType
C#
public enum GlowType : System.Enum
Delphi
public enum GlowType = class(System.Enum)
JScript
public enum GlowType extends System.Enum
Managed Extensions for C++
__value public enum GlowType : public System.Enum
C++/CLI
public enum class GlowType : public System.Enum

Members

Member | Description
Inner |
Outer |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebGrid.Chart.GlowType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebGrid.Chart Namespace


GradientStyle Enumeration

[image]
Intersoft WebGrid Documentation
GradientStyle Enumeration
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : GradientStyle Enumeration

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Enum GradientStyle
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As GradientStyle
C#
public enum GradientStyle : System.Enum
Delphi
public enum GradientStyle = class(System.Enum)
JScript
public enum GradientStyle extends System.Enum
Managed Extensions for C++
__value public enum GradientStyle : public System.Enum
C++/CLI
public enum class GradientStyle : public System.Enum

Members

Member | Description
DiagonalDown |
DiagonalUp |
FromCenter |
FromCorner |
Horizontal |
Vertical |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebGrid.Chart.GradientStyle

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebGrid.Chart Namespace


GradientVariant Enumeration

[image]
Intersoft WebGrid Documentation
GradientVariant Enumeration
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : GradientVariant Enumeration

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Enum GradientVariant
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As GradientVariant
C#
public enum GradientVariant : System.Enum
Delphi
public enum GradientVariant = class(System.Enum)
JScript
public enum GradientVariant extends System.Enum
Managed Extensions for C++
__value public enum GradientVariant : public System.Enum
C++/CLI
public enum class GradientVariant : public System.Enum

Members

Member | Description
Variant1 |
Variant2 |
Variant3 |
Variant4 |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebGrid.Chart.GradientVariant

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebGrid.Chart Namespace


HeaderAlignment Enumeration

[image]
Intersoft WebGrid Documentation
HeaderAlignment Enumeration
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : HeaderAlignment Enumeration

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Enum HeaderAlignment
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As HeaderAlignment
C#
public enum HeaderAlignment : System.Enum
Delphi
public enum HeaderAlignment = class(System.Enum)
JScript
public enum HeaderAlignment extends System.Enum
Managed Extensions for C++
__value public enum HeaderAlignment : public System.Enum
C++/CLI
public enum class HeaderAlignment : public System.Enum

Members

Member | Description
BottomCenter |
BottomLeft |
BottomRight |
TopCenter |
TopLeft |
TopRight |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebGrid.Chart.HeaderAlignment

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebGrid.Chart Namespace


HorizontalAlign Enumeration

[image]
Intersoft WebGrid Documentation
HorizontalAlign Enumeration
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : HorizontalAlign Enumeration

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Enum HorizontalAlign
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As HorizontalAlign
C#
public enum HorizontalAlign : System.Enum
Delphi
public enum HorizontalAlign = class(System.Enum)
JScript
public enum HorizontalAlign extends System.Enum
Managed Extensions for C++
__value public enum HorizontalAlign : public System.Enum
C++/CLI
public enum class HorizontalAlign : public System.Enum

Members

Member | Description
Center |
Left |
Right |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebGrid.Chart.HorizontalAlign

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebGrid.Chart Namespace


ImageFrameType Enumeration

[image]
Intersoft WebGrid Documentation
ImageFrameType Enumeration
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ImageFrameType Enumeration

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Enum ImageFrameType
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As ImageFrameType
C#
public enum ImageFrameType : System.Enum
Delphi
public enum ImageFrameType = class(System.Enum)
JScript
public enum ImageFrameType extends System.Enum
Managed Extensions for C++
__value public enum ImageFrameType : public System.Enum
C++/CLI
public enum class ImageFrameType : public System.Enum

Members

Member | Description
Embed |
Emboss |
None |
Raised |
Rectangle |
RectangleInnerRounded |
RectangleOuterRounded |
Rounded |
RoundedBottom |
RoundedOpenL |
RoundedOpenR |
RoundedOpenRL |
RoundedTop |
Sunken |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebGrid.Chart.ImageFrameType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebGrid.Chart Namespace


LabelGenerationMode Enumeration

[image]
Intersoft WebGrid Documentation
LabelGenerationMode Enumeration
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : LabelGenerationMode Enumeration

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Enum LabelGenerationMode
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As LabelGenerationMode
C#
public enum LabelGenerationMode : System.Enum
Delphi
public enum LabelGenerationMode = class(System.Enum)
JScript
public enum LabelGenerationMode extends System.Enum
Managed Extensions for C++
__value public enum LabelGenerationMode : public System.Enum
C++/CLI
public enum class LabelGenerationMode : public System.Enum

Members

Member | Description
AutoScale |
Rotate30 |
Rotate45 |
Rotate90 |
SingleLevel |
Stagger2 |
Stagger3 |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebGrid.Chart.LabelGenerationMode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebGrid.Chart Namespace


LegendExpandMode Enumeration

[image]
Intersoft WebGrid Documentation
LegendExpandMode Enumeration
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : LegendExpandMode Enumeration

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Enum LegendExpandMode
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As LegendExpandMode
C#
public enum LegendExpandMode : System.Enum
Delphi
public enum LegendExpandMode = class(System.Enum)
JScript
public enum LegendExpandMode extends System.Enum
Managed Extensions for C++
__value public enum LegendExpandMode : public System.Enum
C++/CLI
public enum class LegendExpandMode : public System.Enum

Members

Member | Description
ColsFixed |
ColsOnly |
RowsFixed |
RowsOnly |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebGrid.Chart.LegendExpandMode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebGrid.Chart Namespace


LegendMode Enumeration

[image]
Intersoft WebGrid Documentation
LegendMode Enumeration
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : LegendMode Enumeration

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Enum LegendMode
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As LegendMode
C#
public enum LegendMode : System.Enum
Delphi
public enum LegendMode = class(System.Enum)
JScript
public enum LegendMode extends System.Enum
Managed Extensions for C++
__value public enum LegendMode : public System.Enum
C++/CLI
public enum class LegendMode : public System.Enum

Members

Member | Description
Automatic |
Disabled |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebGrid.Chart.LegendMode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebGrid.Chart Namespace


LevelOfDetail Enumeration

[image]
Intersoft WebGrid Documentation
LevelOfDetail Enumeration
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : LevelOfDetail Enumeration

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Enum LevelOfDetail
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As LevelOfDetail
C#
public enum LevelOfDetail : System.Enum
Delphi
public enum LevelOfDetail = class(System.Enum)
JScript
public enum LevelOfDetail extends System.Enum
Managed Extensions for C++
__value public enum LevelOfDetail : public System.Enum
C++/CLI
public enum class LevelOfDetail : public System.Enum

Members

Member | Description
High |
Highest |
Low |
Medium |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebGrid.Chart.LevelOfDetail

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebGrid.Chart Namespace


LightSourceType Enumeration

[image]
Intersoft WebGrid Documentation
LightSourceType Enumeration
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : LightSourceType Enumeration

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Enum LightSourceType
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As LightSourceType
C#
public enum LightSourceType : System.Enum
Delphi
public enum LightSourceType = class(System.Enum)
JScript
public enum LightSourceType extends System.Enum
Managed Extensions for C++
__value public enum LightSourceType : public System.Enum
C++/CLI
public enum class LightSourceType : public System.Enum

Members

Member | Description
Directional |
Positional |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebGrid.Chart.LightSourceType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebGrid.Chart Namespace


LinePattern Enumeration

[image]
Intersoft WebGrid Documentation
LinePattern Enumeration
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : LinePattern Enumeration

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Enum LinePattern
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As LinePattern
C#
public enum LinePattern : System.Enum
Delphi
public enum LinePattern = class(System.Enum)
JScript
public enum LinePattern extends System.Enum
Managed Extensions for C++
__value public enum LinePattern : public System.Enum
C++/CLI
public enum class LinePattern : public System.Enum

Members

Member | Description
Dash |
DashDot |
DashDotDot |
Dot |
Solid |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebGrid.Chart.LinePattern

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebGrid.Chart Namespace


LineSegmentShape Enumeration

[image]
Intersoft WebGrid Documentation
LineSegmentShape Enumeration
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : LineSegmentShape Enumeration

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Enum LineSegmentShape
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As LineSegmentShape
C#
public enum LineSegmentShape : System.Enum
Delphi
public enum LineSegmentShape = class(System.Enum)
JScript
public enum LineSegmentShape extends System.Enum
Managed Extensions for C++
__value public enum LineSegmentShape : public System.Enum
C++/CLI
public enum class LineSegmentShape : public System.Enum

Members

Member | Description
Ellipsoid |
Line |
Tape |
Tube |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebGrid.Chart.LineSegmentShape

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebGrid.Chart Namespace


MajorTickMode Enumeration

[image]
Intersoft WebGrid Documentation
MajorTickMode Enumeration
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : MajorTickMode Enumeration

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Enum MajorTickMode
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As MajorTickMode
C#
public enum MajorTickMode : System.Enum
Delphi
public enum MajorTickMode = class(System.Enum)
JScript
public enum MajorTickMode extends System.Enum
Managed Extensions for C++
__value public enum MajorTickMode : public System.Enum
C++/CLI
public enum class MajorTickMode : public System.Enum

Members

Member | Description
AutoMaxCount |
AutoMinDistance |
CustomStep |
CustomSteps |
CustomTicks |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebGrid.Chart.MajorTickMode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebGrid.Chart Namespace


MapLayout Enumeration

[image]
Intersoft WebGrid Documentation
MapLayout Enumeration
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : MapLayout Enumeration

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Enum MapLayout
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As MapLayout
C#
public enum MapLayout : System.Enum
Delphi
public enum MapLayout = class(System.Enum)
JScript
public enum MapLayout extends System.Enum
Managed Extensions for C++
__value public enum MapLayout : public System.Enum
C++/CLI
public enum class MapLayout : public System.Enum

Members

Member | Description
Centered |
CropFitted |
Fitted |
Stretched |
StretchedToHeight |
StretchedToWidth |
Tiled |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebGrid.Chart.MapLayout

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebGrid.Chart Namespace


MapMode Enumeration

[image]
Intersoft WebGrid Documentation
MapMode Enumeration
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : MapMode Enumeration

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Enum MapMode
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As MapMode
C#
public enum MapMode : System.Enum
Delphi
public enum MapMode = class(System.Enum)
JScript
public enum MapMode extends System.Enum
Managed Extensions for C++
__value public enum MapMode : public System.Enum
C++/CLI
public enum class MapMode : public System.Enum

Members

Member | Description
RelativeToObject |
RelativeToViewer |
Sphere |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebGrid.Chart.MapMode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebGrid.Chart Namespace


PieExplodeMode Enumeration

[image]
Intersoft WebGrid Documentation
PieExplodeMode Enumeration
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : PieExplodeMode Enumeration

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Enum PieExplodeMode
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As PieExplodeMode
C#
public enum PieExplodeMode : System.Enum
Delphi
public enum PieExplodeMode = class(System.Enum)
JScript
public enum PieExplodeMode extends System.Enum
Managed Extensions for C++
__value public enum PieExplodeMode : public System.Enum
C++/CLI
public enum class PieExplodeMode : public System.Enum

Members

Member | Description
All |
Biggest |
None |
Smallest |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebGrid.Chart.PieExplodeMode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebGrid.Chart Namespace


PieLabelMode Enumeration

[image]
Intersoft WebGrid Documentation
PieLabelMode Enumeration
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : PieLabelMode Enumeration

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Enum PieLabelMode
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As PieLabelMode
C#
public enum PieLabelMode : System.Enum
Delphi
public enum PieLabelMode = class(System.Enum)
JScript
public enum PieLabelMode extends System.Enum
Managed Extensions for C++
__value public enum PieLabelMode : public System.Enum
C++/CLI
public enum class PieLabelMode : public System.Enum

Members

Member | Description
Center |
Rim |
Spider |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebGrid.Chart.PieLabelMode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebGrid.Chart Namespace


PieStyle Enumeration

[image]
Intersoft WebGrid Documentation
PieStyle Enumeration
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : PieStyle Enumeration

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Enum PieStyle
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As PieStyle
C#
public enum PieStyle : System.Enum
Delphi
public enum PieStyle = class(System.Enum)
JScript
public enum PieStyle extends System.Enum
Managed Extensions for C++
__value public enum PieStyle : public System.Enum
C++/CLI
public enum class PieStyle : public System.Enum

Members

Member | Description
Pie |
SmoothEdgePie |
Torus |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebGrid.Chart.PieStyle

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebGrid.Chart Namespace


PivotCriteriaState Enumeration

[image]
Intersoft WebGrid Documentation
PivotCriteriaState Enumeration
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : PivotCriteriaState Enumeration

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Enum PivotCriteriaState
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As PivotCriteriaState
C#
public enum PivotCriteriaState : System.Enum
Delphi
public enum PivotCriteriaState = class(System.Enum)
JScript
public enum PivotCriteriaState extends System.Enum
Managed Extensions for C++
__value public enum PivotCriteriaState : public System.Enum
C++/CLI
public enum class PivotCriteriaState : public System.Enum

Members

Member | Description
In |
NotIn |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebGrid.Chart.PivotCriteriaState

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebGrid.Chart Namespace


PivotDataType Enumeration

[image]
Intersoft WebGrid Documentation
PivotDataType Enumeration
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : PivotDataType Enumeration

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Enum PivotDataType
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As PivotDataType
C#
public enum PivotDataType : System.Enum
Delphi
public enum PivotDataType = class(System.Enum)
JScript
public enum PivotDataType extends System.Enum
Managed Extensions for C++
__value public enum PivotDataType : public System.Enum
C++/CLI
public enum class PivotDataType : public System.Enum

Members

Member | Description
BubbleData |
CloseData |
Data |
HighData |
LowData |
OpenData |
RadiusData |
ThetaData |
XData |
YData |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebGrid.Chart.PivotDataType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebGrid.Chart Namespace


PivotType Enumeration

[image]
Intersoft WebGrid Documentation
PivotType Enumeration
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : PivotType Enumeration

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Enum PivotType
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As PivotType
C#
public enum PivotType : System.Enum
Delphi
public enum PivotType = class(System.Enum)
JScript
public enum PivotType extends System.Enum
Managed Extensions for C++
__value public enum PivotType : public System.Enum
C++/CLI
public enum class PivotType : public System.Enum

Members

Member | Description
ByMonth |
ByWeek |
Field |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebGrid.Chart.PivotType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebGrid.Chart Namespace


PointShape Enumeration

[image]
Intersoft WebGrid Documentation
PointShape Enumeration
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : PointShape Enumeration

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Enum PointShape
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As PointShape
C#
public enum PointShape : System.Enum
Delphi
public enum PointShape = class(System.Enum)
JScript
public enum PointShape extends System.Enum
Managed Extensions for C++
__value public enum PointShape : public System.Enum
C++/CLI
public enum class PointShape : public System.Enum

Members

Member | Description
Bar |
Cone |
Cross |
Cylinder |
DiagonalCross |
Ellipse |
InvertedCone |
InvertedPyramid |
LineCross |
LineDiagonalCross |
Pyramid |
Sphere |
Star |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebGrid.Chart.PointShape

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebGrid.Chart Namespace


PredefinedLightModel Enumeration

[image]
Intersoft WebGrid Documentation
PredefinedLightModel Enumeration
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : PredefinedLightModel Enumeration

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Enum PredefinedLightModel
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As PredefinedLightModel
C#
public enum PredefinedLightModel : System.Enum
Delphi
public enum PredefinedLightModel = class(System.Enum)
JScript
public enum PredefinedLightModel extends System.Enum
Managed Extensions for C++
__value public enum PredefinedLightModel : public System.Enum
C++/CLI
public enum class PredefinedLightModel : public System.Enum

Members

Member | Description
ISLights |
MetallicLustre |
None |
NorthernLights |
ShinyFrontal |
ShinyTopLeft |
ShinyTopRight |
SoftFrontal |
SoftTopLeft |
SoftTopRight |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebGrid.Chart.PredefinedLightModel

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebGrid.Chart Namespace


PredefinedProjection Enumeration

[image]
Intersoft WebGrid Documentation
PredefinedProjection Enumeration
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : PredefinedProjection Enumeration

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Enum PredefinedProjection
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As PredefinedProjection
C#
public enum PredefinedProjection : System.Enum
Delphi
public enum PredefinedProjection = class(System.Enum)
JScript
public enum PredefinedProjection extends System.Enum
Managed Extensions for C++
__value public enum PredefinedProjection : public System.Enum
C++/CLI
public enum class PredefinedProjection : public System.Enum

Members

Member | Description
Orthogonal |
OrthogonalElevated |
OrthogonalHalf |
OrthogonalHalfElevated |
OrthogonalHalfHorizontalLeft |
OrthogonalHalfHorizontalRight |
OrthogonalHalfRotated |
OrthogonalHorizontalLeft |
OrthogonalHorizontalRight |
OrthogonalTop |
Perspective |
PerspectiveElevated |
PerspectiveHorizontalLeft |
PerspectiveHorizontalRight |
PerspectiveRotated |
PerspectiveTilted |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebGrid.Chart.PredefinedProjection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebGrid.Chart Namespace


PredefinedStandardFrame Enumeration

[image]
Intersoft WebGrid Documentation
PredefinedStandardFrame Enumeration
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : PredefinedStandardFrame Enumeration

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Enum PredefinedStandardFrame
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As PredefinedStandardFrame
C#
public enum PredefinedStandardFrame : System.Enum
Delphi
public enum PredefinedStandardFrame = class(System.Enum)
JScript
public enum PredefinedStandardFrame extends System.Enum
Managed Extensions for C++
__value public enum PredefinedStandardFrame : public System.Enum
C++/CLI
public enum class PredefinedStandardFrame : public System.Enum

Members

Member | Description
None |
Raised |
RaisedSunken |
SingleFixed |
Sunken |
SunkenRaised |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebGrid.Chart.PredefinedStandardFrame

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebGrid.Chart Namespace


ProjectionType Enumeration

[image]
Intersoft WebGrid Documentation
ProjectionType Enumeration
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ProjectionType Enumeration

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Enum ProjectionType
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As ProjectionType
C#
public enum ProjectionType : System.Enum
Delphi
public enum ProjectionType = class(System.Enum)
JScript
public enum ProjectionType extends System.Enum
Managed Extensions for C++
__value public enum ProjectionType : public System.Enum
C++/CLI
public enum class ProjectionType : public System.Enum

Members

Member | Description
Orthogonal |
Perspective |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebGrid.Chart.ProjectionType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebGrid.Chart Namespace


RenderSurface Enumeration

[image]
Intersoft WebGrid Documentation
RenderSurface Enumeration
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : RenderSurface Enumeration

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Enum RenderSurface
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As RenderSurface
C#
public enum RenderSurface : System.Enum
Delphi
public enum RenderSurface = class(System.Enum)
JScript
public enum RenderSurface extends System.Enum
Managed Extensions for C++
__value public enum RenderSurface : public System.Enum
C++/CLI
public enum class RenderSurface : public System.Enum

Members

Member | Description
Bitmap |
Window |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebGrid.Chart.RenderSurface

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebGrid.Chart Namespace


RibbonState Enumeration

[image]
Intersoft WebGrid Documentation
RibbonState Enumeration
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : RibbonState Enumeration

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Enum RibbonState
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As RibbonState
C#
public enum RibbonState : System.Enum
Delphi
public enum RibbonState = class(System.Enum)
JScript
public enum RibbonState extends System.Enum
Managed Extensions for C++
__value public enum RibbonState : public System.Enum
C++/CLI
public enum class RibbonState : public System.Enum

Members

Member | Description
Hidden |
Shown |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebGrid.Chart.RibbonState

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebGrid.Chart Namespace


ScaleLabelAngleMode Enumeration

[image]
Intersoft WebGrid Documentation
ScaleLabelAngleMode Enumeration
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ScaleLabelAngleMode Enumeration

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Enum ScaleLabelAngleMode
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As ScaleLabelAngleMode
C#
public enum ScaleLabelAngleMode : System.Enum
Delphi
public enum ScaleLabelAngleMode = class(System.Enum)
JScript
public enum ScaleLabelAngleMode extends System.Enum
Managed Extensions for C++
__value public enum ScaleLabelAngleMode : public System.Enum
C++/CLI
public enum class ScaleLabelAngleMode : public System.Enum

Members

Member | Description
SynchronizeWithRuler |
UseCustomAngle |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebGrid.Chart.ScaleLabelAngleMode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebGrid.Chart Namespace


ScaleLevelShape Enumeration

[image]
Intersoft WebGrid Documentation
ScaleLevelShape Enumeration
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ScaleLevelShape Enumeration

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Enum ScaleLevelShape
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As ScaleLevelShape
C#
public enum ScaleLevelShape : System.Enum
Delphi
public enum ScaleLevelShape = class(System.Enum)
JScript
public enum ScaleLevelShape extends System.Enum
Managed Extensions for C++
__value public enum ScaleLevelShape : public System.Enum
C++/CLI
public enum class ScaleLevelShape : public System.Enum

Members

Member | Description
Bar |
Line |
None |
Tube |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebGrid.Chart.ScaleLevelShape

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebGrid.Chart Namespace


SeriesAppearanceMode Enumeration

[image]
Intersoft WebGrid Documentation
SeriesAppearanceMode Enumeration
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : SeriesAppearanceMode Enumeration

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Enum SeriesAppearanceMode
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As SeriesAppearanceMode
C#
public enum SeriesAppearanceMode : System.Enum
Delphi
public enum SeriesAppearanceMode = class(System.Enum)
JScript
public enum SeriesAppearanceMode extends System.Enum
Managed Extensions for C++
__value public enum SeriesAppearanceMode : public System.Enum
C++/CLI
public enum class SeriesAppearanceMode : public System.Enum

Members

Member | Description
Generic |
SeriesLogic |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebGrid.Chart.SeriesAppearanceMode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebGrid.Chart Namespace


SeriesAreaType Enumeration

[image]
Intersoft WebGrid Documentation
SeriesAreaType Enumeration
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : SeriesAreaType Enumeration

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Enum SeriesAreaType
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As SeriesAreaType
C#
public enum SeriesAreaType : System.Enum
Delphi
public enum SeriesAreaType = class(System.Enum)
JScript
public enum SeriesAreaType extends System.Enum
Managed Extensions for C++
__value public enum SeriesAreaType : public System.Enum
C++/CLI
public enum class SeriesAreaType : public System.Enum

Members

Member | Description
Area |
Basic3DArea |
Stacked3DArea |
StackedArea |
StackedPercentage3DArea |
StackedPercentageArea |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebGrid.Chart.SeriesAreaType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebGrid.Chart Namespace


SeriesBarType Enumeration

[image]
Intersoft WebGrid Documentation
SeriesBarType Enumeration
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : SeriesBarType Enumeration

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Enum SeriesBarType
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As SeriesBarType
C#
public enum SeriesBarType : System.Enum
Delphi
public enum SeriesBarType = class(System.Enum)
JScript
public enum SeriesBarType extends System.Enum
Managed Extensions for C++
__value public enum SeriesBarType : public System.Enum
C++/CLI
public enum class SeriesBarType : public System.Enum

Members

Member | Description
Basic3DBar |
Clustered3DBar |
ClusteredBar |
Stacked3DBar |
StackedBar |
StackedPercentage3DBar |
StackedPercentageBar |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebGrid.Chart.SeriesBarType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebGrid.Chart Namespace


SeriesBubbleType Enumeration

[image]
Intersoft WebGrid Documentation
SeriesBubbleType Enumeration
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : SeriesBubbleType Enumeration

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Enum SeriesBubbleType
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As SeriesBubbleType
C#
public enum SeriesBubbleType : System.Enum
Delphi
public enum SeriesBubbleType = class(System.Enum)
JScript
public enum SeriesBubbleType extends System.Enum
Managed Extensions for C++
__value public enum SeriesBubbleType : public System.Enum
C++/CLI
public enum class SeriesBubbleType : public System.Enum

Members

Member | Description
Bubble |
BubbleLine |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebGrid.Chart.SeriesBubbleType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebGrid.Chart Namespace


SeriesColumnType Enumeration

[image]
Intersoft WebGrid Documentation
SeriesColumnType Enumeration
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : SeriesColumnType Enumeration

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Enum SeriesColumnType
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As SeriesColumnType
C#
public enum SeriesColumnType : System.Enum
Delphi
public enum SeriesColumnType = class(System.Enum)
JScript
public enum SeriesColumnType extends System.Enum
Managed Extensions for C++
__value public enum SeriesColumnType : public System.Enum
C++/CLI
public enum class SeriesColumnType : public System.Enum

Members

Member | Description
Basic3DColumn |
Clustered3DColumn |
ClusteredColumn |
Stacked3DColumn |
StackedColumn |
StackedPercentage3DColumn |
StackedPercentageColumn |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebGrid.Chart.SeriesColumnType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebGrid.Chart Namespace


SeriesDoughnutType Enumeration

[image]
Intersoft WebGrid Documentation
SeriesDoughnutType Enumeration
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : SeriesDoughnutType Enumeration

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Enum SeriesDoughnutType
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As SeriesDoughnutType
C#
public enum SeriesDoughnutType : System.Enum
Delphi
public enum SeriesDoughnutType = class(System.Enum)
JScript
public enum SeriesDoughnutType extends System.Enum
Managed Extensions for C++
__value public enum SeriesDoughnutType : public System.Enum
C++/CLI
public enum class SeriesDoughnutType : public System.Enum

Members

Member | Description
Basic3DDoughnut |
Doughnut |
Exploded3DDoughnut |
ExplodedDoughnut |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebGrid.Chart.SeriesDoughnutType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebGrid.Chart Namespace


SeriesLegendMode Enumeration

[image]
Intersoft WebGrid Documentation
SeriesLegendMode Enumeration
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : SeriesLegendMode Enumeration

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Enum SeriesLegendMode
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As SeriesLegendMode
C#
public enum SeriesLegendMode : System.Enum
Delphi
public enum SeriesLegendMode = class(System.Enum)
JScript
public enum SeriesLegendMode extends System.Enum
Managed Extensions for C++
__value public enum SeriesLegendMode : public System.Enum
C++/CLI
public enum class SeriesLegendMode : public System.Enum

Members

Member | Description
DataPoints |
None |
Series |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebGrid.Chart.SeriesLegendMode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebGrid.Chart Namespace


SeriesLineType Enumeration

[image]
Intersoft WebGrid Documentation
SeriesLineType Enumeration
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : SeriesLineType Enumeration

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Enum SeriesLineType
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As SeriesLineType
C#
public enum SeriesLineType : System.Enum
Delphi
public enum SeriesLineType = class(System.Enum)
JScript
public enum SeriesLineType extends System.Enum
Managed Extensions for C++
__value public enum SeriesLineType : public System.Enum
C++/CLI
public enum class SeriesLineType : public System.Enum

Members

Member | Description
Basic3DLine |
Basic3DLineWithMarkers |
Overlapped3DLine |
Overlapped3DLineWithMarkers |
OverlappedLine |
OverlappedLineWithMarkers |
Stacked3DLine |
Stacked3DLineWithMarkers |
StackedLine |
StackedLineWithMarkers |
StackedPercentage3DLine |
StackedPercentage3DLineWithMarkers |
StackedPercentageLine |
StackedPercentageLineWithMarkers |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebGrid.Chart.SeriesLineType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebGrid.Chart Namespace


SeriesPieType Enumeration

[image]
Intersoft WebGrid Documentation
SeriesPieType Enumeration
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : SeriesPieType Enumeration

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Enum SeriesPieType
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As SeriesPieType
C#
public enum SeriesPieType : System.Enum
Delphi
public enum SeriesPieType = class(System.Enum)
JScript
public enum SeriesPieType extends System.Enum
Managed Extensions for C++
__value public enum SeriesPieType : public System.Enum
C++/CLI
public enum class SeriesPieType : public System.Enum

Members

Member | Description
Basic3DPie |
Exploded3DPie |
ExplodedPie |
Pie |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebGrid.Chart.SeriesPieType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebGrid.Chart Namespace


SeriesPolarType Enumeration

[image]
Intersoft WebGrid Documentation
SeriesPolarType Enumeration
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : SeriesPolarType Enumeration

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Enum SeriesPolarType
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As SeriesPolarType
C#
public enum SeriesPolarType : System.Enum
Delphi
public enum SeriesPolarType = class(System.Enum)
JScript
public enum SeriesPolarType extends System.Enum
Managed Extensions for C++
__value public enum SeriesPolarType : public System.Enum
C++/CLI
public enum class SeriesPolarType : public System.Enum

Members

Member | Description
Polar |
PolarLine |
PolarLineWithMarkers |
PolarSmoothLine |
PolarSmoothLineWithMarkers |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebGrid.Chart.SeriesPolarType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebGrid.Chart Namespace


SeriesRadarType Enumeration

[image]
Intersoft WebGrid Documentation
SeriesRadarType Enumeration
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : SeriesRadarType Enumeration

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Enum SeriesRadarType
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As SeriesRadarType
C#
public enum SeriesRadarType : System.Enum
Delphi
public enum SeriesRadarType = class(System.Enum)
JScript
public enum SeriesRadarType extends System.Enum
Managed Extensions for C++
__value public enum SeriesRadarType : public System.Enum
C++/CLI
public enum class SeriesRadarType : public System.Enum

Members

Member | Description
FilledRadar |
Radar |
RadarSmoothLine |
RadarSmoothLineWithMarkers |
RadarWithMarkers |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebGrid.Chart.SeriesRadarType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebGrid.Chart Namespace


SeriesSmoothLineType Enumeration

[image]
Intersoft WebGrid Documentation
SeriesSmoothLineType Enumeration
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : SeriesSmoothLineType Enumeration

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Enum SeriesSmoothLineType
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As SeriesSmoothLineType
C#
public enum SeriesSmoothLineType : System.Enum
Delphi
public enum SeriesSmoothLineType = class(System.Enum)
JScript
public enum SeriesSmoothLineType extends System.Enum
Managed Extensions for C++
__value public enum SeriesSmoothLineType : public System.Enum
C++/CLI
public enum class SeriesSmoothLineType : public System.Enum

Members

Member | Description
OverlappedSmoothLine |
OverlappedSmoothLineWithMarkers |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebGrid.Chart.SeriesSmoothLineType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebGrid.Chart Namespace


SeriesStepLineType Enumeration

[image]
Intersoft WebGrid Documentation
SeriesStepLineType Enumeration
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : SeriesStepLineType Enumeration

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Enum SeriesStepLineType
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As SeriesStepLineType
C#
public enum SeriesStepLineType : System.Enum
Delphi
public enum SeriesStepLineType = class(System.Enum)
JScript
public enum SeriesStepLineType extends System.Enum
Managed Extensions for C++
__value public enum SeriesStepLineType : public System.Enum
C++/CLI
public enum class SeriesStepLineType : public System.Enum

Members

Member | Description
Basic3DStepLine |
Basic3DStepLineWithMarkers |
OverlappedStepLine |
OverlappedStepLineWithMarkers |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebGrid.Chart.SeriesStepLineType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebGrid.Chart Namespace


SeriesStockType Enumeration

[image]
Intersoft WebGrid Documentation
SeriesStockType Enumeration
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : SeriesStockType Enumeration

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Enum SeriesStockType
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As SeriesStockType
C#
public enum SeriesStockType : System.Enum
Delphi
public enum SeriesStockType = class(System.Enum)
JScript
public enum SeriesStockType extends System.Enum
Managed Extensions for C++
__value public enum SeriesStockType : public System.Enum
C++/CLI
public enum class SeriesStockType : public System.Enum

Members

Member | Description
HighLowClose |
OpenHighLowClose |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebGrid.Chart.SeriesStockType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebGrid.Chart Namespace


SeriesXYType Enumeration

[image]
Intersoft WebGrid Documentation
SeriesXYType Enumeration
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : SeriesXYType Enumeration

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Enum SeriesXYType
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As SeriesXYType
C#
public enum SeriesXYType : System.Enum
Delphi
public enum SeriesXYType = class(System.Enum)
JScript
public enum SeriesXYType extends System.Enum
Managed Extensions for C++
__value public enum SeriesXYType : public System.Enum
C++/CLI
public enum class SeriesXYType : public System.Enum

Members

Member | Description
FilledScatter |
Scatter |
ScatterLine |
ScatterLineWithMarkers |
ScatterSmoothLine |
ScatterSmoothLineWithMarkers |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebGrid.Chart.SeriesXYType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebGrid.Chart Namespace


ShadowType Enumeration

[image]
Intersoft WebGrid Documentation
ShadowType Enumeration
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ShadowType Enumeration

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Enum ShadowType
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As ShadowType
C#
public enum ShadowType : System.Enum
Delphi
public enum ShadowType = class(System.Enum)
JScript
public enum ShadowType extends System.Enum
Managed Extensions for C++
__value public enum ShadowType : public System.Enum
C++/CLI
public enum class ShadowType : public System.Enum

Members

Member | Description
GaussianBlur |
LinearBlur |
None |
RadialBlur |
Solid |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebGrid.Chart.ShadowType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebGrid.Chart Namespace


ShapeRenderingMode Enumeration

[image]
Intersoft WebGrid Documentation
ShapeRenderingMode Enumeration
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : ShapeRenderingMode Enumeration

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Enum ShapeRenderingMode
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As ShapeRenderingMode
C#
public enum ShapeRenderingMode : System.Enum
Delphi
public enum ShapeRenderingMode = class(System.Enum)
JScript
public enum ShapeRenderingMode extends System.Enum
Managed Extensions for C++
__value public enum ShapeRenderingMode : public System.Enum
C++/CLI
public enum class ShapeRenderingMode : public System.Enum

Members

Member | Description
AntiAlias |
Default |
HighQuality |
HighSpeed |
None |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebGrid.Chart.ShapeRenderingMode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebGrid.Chart Namespace


SortOrder Enumeration

[image]
Intersoft WebGrid Documentation
SortOrder Enumeration
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : SortOrder Enumeration

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Enum SortOrder
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As SortOrder
C#
public enum SortOrder : System.Enum
Delphi
public enum SortOrder = class(System.Enum)
JScript
public enum SortOrder extends System.Enum
Managed Extensions for C++
__value public enum SortOrder : public System.Enum
C++/CLI
public enum class SortOrder : public System.Enum

Members

Member | Description
Ascending |
Descending |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebGrid.Chart.SortOrder

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebGrid.Chart Namespace


StringFormatType Enumeration

[image]
Intersoft WebGrid Documentation
StringFormatType Enumeration
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : StringFormatType Enumeration

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Enum StringFormatType
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As StringFormatType
C#
public enum StringFormatType : System.Enum
Delphi
public enum StringFormatType = class(System.Enum)
JScript
public enum StringFormatType extends System.Enum
Managed Extensions for C++
__value public enum StringFormatType : public System.Enum
C++/CLI
public enum class StringFormatType : public System.Enum

Members

Member | Description
GenericDefault |
GenericTypographic |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebGrid.Chart.StringFormatType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebGrid.Chart Namespace


TextDirection Enumeration

[image]
Intersoft WebGrid Documentation
TextDirection Enumeration
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : TextDirection Enumeration

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Enum TextDirection
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As TextDirection
C#
public enum TextDirection : System.Enum
Delphi
public enum TextDirection = class(System.Enum)
JScript
public enum TextDirection extends System.Enum
Managed Extensions for C++
__value public enum TextDirection : public System.Enum
C++/CLI
public enum class TextDirection : public System.Enum

Members

Member | Description
LeftToRight |
RightToLeft |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebGrid.Chart.TextDirection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebGrid.Chart Namespace


TextFormat Enumeration

[image]
Intersoft WebGrid Documentation
TextFormat Enumeration
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : TextFormat Enumeration

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Enum TextFormat
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As TextFormat
C#
public enum TextFormat : System.Enum
Delphi
public enum TextFormat = class(System.Enum)
JScript
public enum TextFormat extends System.Enum
Managed Extensions for C++
__value public enum TextFormat : public System.Enum
C++/CLI
public enum class TextFormat : public System.Enum

Members

Member | Description
Simple |
XML |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebGrid.Chart.TextFormat

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebGrid.Chart Namespace


VerticalAlign Enumeration

[image]
Intersoft WebGrid Documentation
VerticalAlign Enumeration
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : VerticalAlign Enumeration

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Enum VerticalAlign
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As VerticalAlign
C#
public enum VerticalAlign : System.Enum
Delphi
public enum VerticalAlign = class(System.Enum)
JScript
public enum VerticalAlign extends System.Enum
Managed Extensions for C++
__value public enum VerticalAlign : public System.Enum
C++/CLI
public enum class VerticalAlign : public System.Enum

Members

Member | Description
Bottom |
Center |
Top |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebGrid.Chart.VerticalAlign

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebGrid.Chart Namespace


IChartEngine Interface

[image]
Intersoft WebGrid Documentation
IChartEngine Interface
Members See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : IChartEngine Interface

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Interface IChartEngine
Visual Basic (Usage) Copy Code
Dim instance As IChartEngine
C#
public interface IChartEngine
Delphi
public interface IChartEngine
JScript
public interface IChartEngine
Managed Extensions for C++
public __gc __interface IChartEngine
C++/CLI
public interface class IChartEngine

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IChartEngine Members
ISNet.WebUI.WebGrid.Chart Namespace


IChartEngine Interface Members

[image]
Intersoft WebGrid Documentation
IChartEngine Interface Members
See Also Methods Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : IChartEngine Interface

Glossary Item Box

The following tables list the members exposed by IChartEngine.

Public Methods

 | Name | Description
Method | GenerateChartImage |
Method | GenerateImageMap |
Top

See Also

Reference

IChartEngine Interface
ISNet.WebUI.WebGrid.Chart Namespace


IChartEngine Interface Methods

[image]
Intersoft WebGrid Documentation
IChartEngine Interface Methods
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : IChartEngine Interface

Glossary Item Box

For a list of all members of this type, see IChartEngine members.

Public Methods

 | Name | Description
Method | GenerateChartImage |
Method | GenerateImageMap |
Top

See Also

Reference

IChartEngine Interface
ISNet.WebUI.WebGrid.Chart Namespace


GenerateChartImage Method

[image]
Intersoft WebGrid Documentation
GenerateChartImage Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > IChartEngine Interface : GenerateChartImage Method

chartConfig
data

Glossary Item Box

Syntax

Visual Basic (Declaration)
Function GenerateChartImage( _
   ByVal chartConfig As ChartConfig, _
   ByVal data As System.Data.DataTable _
) As System.Drawing.Bitmap
Visual Basic (Usage) Copy Code
Dim instance As IChartEngine
Dim chartConfig As ChartConfig
Dim data As System.Data.DataTable
Dim value As System.Drawing.Bitmap

value = instance.GenerateChartImage(chartConfig, data)
C#
System.Drawing.Bitmap GenerateChartImage(
   ChartConfig chartConfig,
   System.Data.DataTable data
)
Delphi
function GenerateChartImage(
    chartConfig: ChartConfig;
    data: System.Data.DataTable
): System.Drawing.Bitmap;
JScript
function GenerateChartImage(
   chartConfig : ChartConfig,
   data : System.Data.DataTable
) : System.Drawing.Bitmap;
Managed Extensions for C++
System.Drawing.Bitmap* GenerateChartImage(
   ChartConfig* chartConfig,
   System.Data.DataTable* data
)
C++/CLI
System.Drawing.Bitmap^ GenerateChartImage(
   ChartConfig^ chartConfig,
   System.Data.DataTable^ data
)

Parameters

chartConfig
data

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IChartEngine Interface
IChartEngine Members


GenerateImageMap Method

[image]
Intersoft WebGrid Documentation
GenerateImageMap Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace > IChartEngine Interface : GenerateImageMap Method

page
data

Glossary Item Box

Syntax

Visual Basic (Declaration)
Function GenerateImageMap( _
   ByVal page As System.Web.UI.Page, _
   ByVal data As System.Object _
) As System.String
Visual Basic (Usage) Copy Code
Dim instance As IChartEngine
Dim page As System.Web.UI.Page
Dim data As System.Object
Dim value As System.String

value = instance.GenerateImageMap(page, data)
C#
System.string GenerateImageMap(
   System.Web.UI.Page page,
   System.object data
)
Delphi
function GenerateImageMap(
    page: System.Web.UI.Page;
    data: System.TObject
): System.String;
JScript
function GenerateImageMap(
   page : System.Web.UI.Page,
   data : System.Object
) : System.String;
Managed Extensions for C++
System.string* GenerateImageMap(
   System.Web.UI.Page* page,
   System.Object* data
)
C++/CLI
System.String^ GenerateImageMap(
   System.Web.UI.Page^ page,
   System.Object^ data
)

Parameters

page
data

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IChartEngine Interface
IChartEngine Members


WebGridChartProcessedEventHandler Delegate

[image]
Intersoft WebGrid Documentation
WebGridChartProcessedEventHandler Delegate
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : WebGridChartProcessedEventHandler Delegate

sender
e

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Delegate Sub WebGridChartProcessedEventHandler( _
   ByVal sender As System.Object, _
   ByVal e As WebGridChartStatusArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As New WebGridChartProcessedEventHandler(AddressOf HandlerMethod)
C#
public delegate void WebGridChartProcessedEventHandler(
   System.object sender,
   WebGridChartStatusArgs e
)
Delphi
public delegate WebGridChartProcessedEventHandler(
    sender: System.TObject;
    e: WebGridChartStatusArgs
);
JScript
public delegate WebGridChartProcessedEventHandler(
   sender : System.Object,
   e : WebGridChartStatusArgs
)
Managed Extensions for C++
public: __gc __delegate void WebGridChartProcessedEventHandler(
   System.Object* sender,
   WebGridChartStatusArgs* e
)
C++/CLI
public delegate void WebGridChartProcessedEventHandler(
   System.Object^ sender,
   WebGridChartStatusArgs^ e
)

Parameters

sender
e

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridChartProcessedEventHandler Members
ISNet.WebUI.WebGrid.Chart Namespace


WebGridChartProcessingEventHandler Delegate

[image]
Intersoft WebGrid Documentation
WebGridChartProcessingEventHandler Delegate
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart Namespace : WebGridChartProcessingEventHandler Delegate

sender
e

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Delegate Sub WebGridChartProcessingEventHandler( _
   ByVal sender As System.Object, _
   ByVal e As WebGridChartEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As New WebGridChartProcessingEventHandler(AddressOf HandlerMethod)
C#
public delegate void WebGridChartProcessingEventHandler(
   System.object sender,
   WebGridChartEventArgs e
)
Delphi
public delegate WebGridChartProcessingEventHandler(
    sender: System.TObject;
    e: WebGridChartEventArgs
);
JScript
public delegate WebGridChartProcessingEventHandler(
   sender : System.Object,
   e : WebGridChartEventArgs
)
Managed Extensions for C++
public: __gc __delegate void WebGridChartProcessingEventHandler(
   System.Object* sender,
   WebGridChartEventArgs* e
)
C++/CLI
public delegate void WebGridChartProcessingEventHandler(
   System.Object^ sender,
   WebGridChartEventArgs^ e
)

Parameters

sender
e

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebGridChartProcessingEventHandler Members
ISNet.WebUI.WebGrid.Chart Namespace


ISNet.WebUI.WebGrid.Chart.Settings Namespace

ISNet.WebUI.WebGrid.Chart.Settings Namespace
See Also Inheritance Hierarchy Send Feedback

Glossary Item Box

Classes

 | Class | Description
Class | ChartFilterAndSortRibbonSettings |

See Also

Reference

ISNet.WebUI.WebGrid Assembly


ISNet.WebUI.WebGrid.Chart.Settings Namespace Inheritance Hierarchy

ISNet.WebUI.WebGrid.Chart.Settings Namespace Inheritance Hierarchy
See Also Send Feedback

Glossary Item Box

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.WebGrid.Chart.Settings.ChartFilterAndSortRibbonSettings

See Also

Reference

ISNet.WebUI.WebGrid Assembly


ChartFilterAndSortRibbonSettings Class

[image]
Intersoft WebGrid Documentation
ChartFilterAndSortRibbonSettings Class
Members See Also Send Feedback
ISNet.WebUI.WebGrid.Chart.Settings Namespace : ChartFilterAndSortRibbonSettings Class

Glossary Item Box

Object Model

ChartFilterAndSortRibbonSettings Class

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.SerializableAttribute()>
Public Class ChartFilterAndSortRibbonSettings
   Inherits ISNet.WebUI.WebUIBaseClass
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Visual Basic (Usage) Copy Code
Dim instance As ChartFilterAndSortRibbonSettings
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public class ChartFilterAndSortRibbonSettings : ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Delphi
public class ChartFilterAndSortRibbonSettings = class(ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize)
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.SerializableAttribute()
public class ChartFilterAndSortRibbonSettings extends ISNet.WebUI.WebUIBaseClass implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public __gc class ChartFilterAndSortRibbonSettings : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public ref class ChartFilterAndSortRibbonSettings : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.WebGrid.Chart.Settings.ChartFilterAndSortRibbonSettings

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartFilterAndSortRibbonSettings Members
ISNet.WebUI.WebGrid.Chart.Settings Namespace


ChartFilterAndSortRibbonSettings Class Members

[image]
Intersoft WebGrid Documentation
ChartFilterAndSortRibbonSettings Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebGrid.Chart.Settings Namespace : ChartFilterAndSortRibbonSettings Class

Glossary Item Box

The following tables list the members exposed by ChartFilterAndSortRibbonSettings.

Public Constructors

 | Name | Description
Public Constructor | ChartFilterAndSortRibbonSettings Constructor |
Top

Public Properties

 | Name | Description
Public Property | ChartAutoFilter |
Public Property | Visible |
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

ChartFilterAndSortRibbonSettings Class
ISNet.WebUI.WebGrid.Chart.Settings Namespace


ChartFilterAndSortRibbonSettings Constructor

[image]
Intersoft WebGrid Documentation
ChartFilterAndSortRibbonSettings Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart.Settings Namespace > ChartFilterAndSortRibbonSettings Class : ChartFilterAndSortRibbonSettings Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New ChartFilterAndSortRibbonSettings()
C#
public ChartFilterAndSortRibbonSettings()
Delphi
public ChartFilterAndSortRibbonSettings();
JScript
public function ChartFilterAndSortRibbonSettings();
Managed Extensions for C++
public: ChartFilterAndSortRibbonSettings();
C++/CLI
public:
ChartFilterAndSortRibbonSettings();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartFilterAndSortRibbonSettings Class
ChartFilterAndSortRibbonSettings Members


Clone Method

[image]
Intersoft WebGrid Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart.Settings Namespace > ChartFilterAndSortRibbonSettings Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As System.Object
Visual Basic (Usage) Copy Code
Dim instance As ChartFilterAndSortRibbonSettings
Dim value As System.Object

value = instance.Clone()
C#
public virtual System.object Clone()
Delphi
public function Clone(): System.TObject; virtual;
JScript
public function Clone() : System.Object;
Managed Extensions for C++
public: virtual System.Object* Clone();
C++/CLI
public:
virtual System.Object^ Clone();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartFilterAndSortRibbonSettings Class
ChartFilterAndSortRibbonSettings Members


CopyFrom Method

[image]
Intersoft WebGrid Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart.Settings Namespace > ChartFilterAndSortRibbonSettings Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartFilterAndSortRibbonSettings Class
ChartFilterAndSortRibbonSettings Members


CopyFrom(Object) Method

[image]
Intersoft WebGrid Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart.Settings Namespace > ChartFilterAndSortRibbonSettings Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartFilterAndSortRibbonSettings
Dim objSource As System.Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   System.object objSource
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartFilterAndSortRibbonSettings Class
ChartFilterAndSortRibbonSettings Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebGrid Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart.Settings Namespace > ChartFilterAndSortRibbonSettings Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object, _
   ByVal cloneSourceValue As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartFilterAndSortRibbonSettings
Dim objSource As System.Object
Dim cloneSourceValue As System.Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   System.object objSource,
   System.bool cloneSourceValue
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject;
    cloneSourceValue: System.Boolean
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object,
   cloneSourceValue : System.boolean
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource,
   System.bool cloneSourceValue
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource,
   System.bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartFilterAndSortRibbonSettings Class
ChartFilterAndSortRibbonSettings Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebGrid Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart.Settings Namespace > ChartFilterAndSortRibbonSettings Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartFilterAndSortRibbonSettings
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure DeSerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function DeSerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void DeSerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void DeSerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartFilterAndSortRibbonSettings Class
ChartFilterAndSortRibbonSettings Members


GetHashCode Method

[image]
Intersoft WebGrid Documentation
GetHashCode Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart.Settings Namespace > ChartFilterAndSortRibbonSettings Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As ChartFilterAndSortRibbonSettings
Dim value As System.Integer

value = instance.GetHashCode()
C#
public virtual System.int GetHashCode()
Delphi
public function GetHashCode(): System.Integer; virtual;
JScript
public function GetHashCode() : System.int;
Managed Extensions for C++
public: virtual System.int GetHashCode();
C++/CLI
public:
virtual System.int GetHashCode();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartFilterAndSortRibbonSettings Class
ChartFilterAndSortRibbonSettings Members


ChartFilterAndSortRibbonSettings Class Methods

[image]
Intersoft WebGrid Documentation
ChartFilterAndSortRibbonSettings Class Methods
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart.Settings Namespace : ChartFilterAndSortRibbonSettings Class

Glossary Item Box

For a list of all members of this type, see ChartFilterAndSortRibbonSettings members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

ChartFilterAndSortRibbonSettings Class
ISNet.WebUI.WebGrid.Chart.Settings Namespace


GetObjectData Method

[image]
Intersoft WebGrid Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart.Settings Namespace > ChartFilterAndSortRibbonSettings Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=False,
   UnmanagedCode=False,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=True,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Action=SecurityAction.Demand,
   Unrestricted=False)>
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartFilterAndSortRibbonSettings
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure GetObjectData(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
); override;
JScript
System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=,
   UnmanagedCode=,
   SkipVerification=,
   Execution=,
   ControlThread=,
   ControlEvidence=,
   ControlPolicy=,
   SerializationFormatter=,
   ControlDomainPolicy=,
   ControlPrincipal=,
   ControlAppDomain=,
   RemotingConfiguration=,
   Infrastructure=,
   BindingRedirects=,
   Action=SecurityAction.Demand,
   Unrestricted=)
public override function GetObjectData(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public: void GetObjectData(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
) override
C++/CLI
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public:
void GetObjectData(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
) override

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartFilterAndSortRibbonSettings Class
ChartFilterAndSortRibbonSettings Members


IsEmpty Method

[image]
Intersoft WebGrid Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart.Settings Namespace > ChartFilterAndSortRibbonSettings Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As ChartFilterAndSortRibbonSettings
Dim value As System.Boolean

value = instance.IsEmpty()
C#
public virtual System.bool IsEmpty()
Delphi
public function IsEmpty(): System.Boolean; virtual;
JScript
public function IsEmpty() : System.boolean;
Managed Extensions for C++
public: virtual System.bool IsEmpty();
C++/CLI
public:
virtual System.bool IsEmpty();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartFilterAndSortRibbonSettings Class
ChartFilterAndSortRibbonSettings Members


Reset Method

[image]
Intersoft WebGrid Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart.Settings Namespace > ChartFilterAndSortRibbonSettings Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As ChartFilterAndSortRibbonSettings

instance.Reset()
C#
public virtual void Reset()
Delphi
public procedure Reset(); virtual;
JScript
public function Reset();
Managed Extensions for C++
public: virtual void Reset();
C++/CLI
public:
virtual void Reset();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartFilterAndSortRibbonSettings Class
ChartFilterAndSortRibbonSettings Members


SerializeObjectData Method

[image]
Intersoft WebGrid Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart.Settings Namespace > ChartFilterAndSortRibbonSettings Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As ChartFilterAndSortRibbonSettings
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure SerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function SerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void SerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void SerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartFilterAndSortRibbonSettings Class
ChartFilterAndSortRibbonSettings Members


ToString Method

[image]
Intersoft WebGrid Documentation
ToString Method
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart.Settings Namespace > ChartFilterAndSortRibbonSettings Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As System.String
Visual Basic (Usage) Copy Code
Dim instance As ChartFilterAndSortRibbonSettings
Dim value As System.String

value = instance.ToString()
C#
public virtual System.string ToString()
Delphi
public function ToString(): System.String; virtual;
JScript
public function ToString() : System.String;
Managed Extensions for C++
public: virtual System.string* ToString();
C++/CLI
public:
virtual System.String^ ToString();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartFilterAndSortRibbonSettings Class
ChartFilterAndSortRibbonSettings Members


ChartFilterAndSortRibbonSettings Class Properties

[image]
Intersoft WebGrid Documentation
ChartFilterAndSortRibbonSettings Class Properties
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart.Settings Namespace : ChartFilterAndSortRibbonSettings Class

Glossary Item Box

For a list of all members of this type, see ChartFilterAndSortRibbonSettings members.

Public Properties

 | Name | Description
Public Property | ChartAutoFilter |
Public Property | Visible |
Top

See Also

Reference

ChartFilterAndSortRibbonSettings Class
ISNet.WebUI.WebGrid.Chart.Settings Namespace


ChartFilterAndSortRibbonSettings Constructor

[image]
Intersoft WebGrid Documentation
ChartFilterAndSortRibbonSettings Constructor
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart.Settings Namespace > ChartFilterAndSortRibbonSettings Class : ChartFilterAndSortRibbonSettings Constructor

Glossary Item Box

Overload List

Overload | Description
ChartFilterAndSortRibbonSettings Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartFilterAndSortRibbonSettings Class
ChartFilterAndSortRibbonSettings Members


ChartAutoFilter Property

[image]
Intersoft WebGrid Documentation
ChartAutoFilter Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart.Settings Namespace > ChartFilterAndSortRibbonSettings Class : ChartAutoFilter Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Specifies whether auto filter is activated initially.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("Options")>
Public Property ChartAutoFilter As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As ChartFilterAndSortRibbonSettings
Dim value As System.Boolean

instance.ChartAutoFilter = value

value = instance.ChartAutoFilter
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies whether auto filter is activated initially.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Options")]
public System.bool ChartAutoFilter {get; set;}
Delphi
public read-write property ChartAutoFilter: System.Boolean;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Specifies whether auto filter is activated initially.")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("Options")
public function get,set ChartAutoFilter : System.boolean
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies whether auto filter is activated initially.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Options")]
public: __property System.bool get_ChartAutoFilter();
public: __property void set_ChartAutoFilter(
   System.bool value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies whether auto filter is activated initially.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Options")]
public:
property System.bool ChartAutoFilter {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartFilterAndSortRibbonSettings Class
ChartFilterAndSortRibbonSettings Members


Visible Property

[image]
Intersoft WebGrid Documentation
Visible Property
See Also Send Feedback
ISNet.WebUI.WebGrid.Chart.Settings Namespace > ChartFilterAndSortRibbonSettings Class : Visible Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Controls the visibility of the ribbon.")>
<System.ComponentModel.CategoryAttribute("Options")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property Visible As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As ChartFilterAndSortRibbonSettings
Dim value As System.Boolean

instance.Visible = value

value = instance.Visible
C#
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Controls the visibility of the ribbon.")]
[System.ComponentModel.CategoryAttribute("Options")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public System.bool Visible {get; set;}
Delphi
public read-write property Visible: System.Boolean;
JScript
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Controls the visibility of the ribbon.")
System.ComponentModel.CategoryAttribute("Options")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get,set Visible : System.boolean
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Controls the visibility of the ribbon.")]
[System.ComponentModel.CategoryAttribute("Options")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.bool get_Visible();
public: __property void set_Visible(
   System.bool value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Controls the visibility of the ribbon.")]
[System.ComponentModel.CategoryAttribute("Options")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.bool Visible {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartFilterAndSortRibbonSettings Class
ChartFilterAndSortRibbonSettings Members


Client-side References

Client-side References
Send Feedback
Intersoft WebGrid > Client-side References

Glossary Item Box

This section is designated to help user working with client-side references in WebGrid.

In This Section

ColumnSetSettings

FocusStyle

GroupByBoxObject

WebGridCell

PreviewRowSettings

SelfReferencingSettings

WebGridBatchUpdateSettings

WebGridCellData

WebGridClientSideEvents

WebGridColumn

WebGridColumnSet

WebGridCustomEditorBehavior

WebGridCustomEditor

WebGridFilter

WebGridGroup

WebGridImageSettings

WebGridLayoutSet

WebGrid

WebGridRowChanges

WebGridRowLayout

WebGridRow

WebGridTable

WebGridTextItem

WebGridTextSettings

WebGridSubTables

WebGridActiveCell

WebGridEditObject

SelectedObject

WebGrid Core

WebGrid Edit

WebGrid ColumnSet

WebGrid Events


ColumnSetSettings

ColumnSetSettings
Send Feedback
Intersoft WebGrid > Client-side References > ColumnSetSettings

Glossary Item Box

ColumnSetSettings Properties

ShowHeaders | Description Specifies whether to show the ColumnSet headers. ValueType boolean Default Value true
RowCount | Description Indicates the number of rows in a ColumnSet. ValueType integer Default Value -
GridLines | Description The grid lines that are used to separate each ColumnSet row and cell. ValueType string Default Value -
GridLineColor | Description Specifies the color of the grid lines. ValueType string Default Value -
GridLineStyle | Description Specifies the style of the grid lines. ValueType string Default Value -


FocusStyle

FocusStyle
Send Feedback
Intersoft WebGrid > Client-side References > FocusStyle

Glossary Item Box

FocusStyle Properties

BorderStyle | Description Gets the border style of a row that is in focus. ValueType string Default Value -
BorderWidth | Description Gets the border width of a row that is in focus. ValueType integer Default Value -
BorderColor | Description Gets the border color of a row that is in focus. ValueType string Default Value -


GroupByBoxObject

GroupByBoxObject
Send Feedback
Intersoft WebGrid > Client-side References > GroupByBoxObject

Glossary Item Box

GroupByBoxObject Properties

InfoText | Description Specifies the default info text to be displayed when no group columns exist. ValueType string Default Value "Drag a column header here to group by that column."
ConnectorLineColor | Description Specifies the color of the connector line that is used to display links between hierarchical group columns. ValueType string Default Value "White"
ConnectorLineStyle | Description Specifies the style of the connector line that is used to display links between hierarchical group columns. ValueType string Default Value -
ContextMenu | Description Specifies whether the GroupByBox menu item should be enabled or disabled in the column context menu. ValueType boolean Default Value true


WebGridCell

WebGridCell
Send Feedback
Intersoft WebGrid > Client-side References > WebGridCell

Glossary Item Box

WebGridCell Properties

Position | Description Gets the position of the cell from its collection. ValueType integer Default Value -
Text | Description Gets or sets the text that will be displayed in cell. ValueType string Default Value -
Tag | Description Gets the custom data for the cell object. ValueType string Default Value ""
Value | Description Gets the cell's value. ValueType object Default Value -
Column | Description Gets the column object to which this cell belongs. ValueType object (WebGridColumn) Default Value -
DataChanged | Description Returns whether cell's data has been changed. ValueType boolean Default Value false
ForceNoEdit | Description Determines whether this cell will be forced not to allow editing. ValueType boolean Default Value false
Name | Description The name of the item in its collection. ValueType string Default Value -
CellElement | Description Gets the HTML element of this cell object. ValueType object (HTML element) Default Value -
Row | Description Returns the row object to which this cell belongs. ValueType object (WebGridRow) Default Value -
Table | Description Returns the table object to which this cell belongs. ValueType object (WebGridTable) Default Value -
Grid | Description Returns the grid object to which this cell belongs. ValueType object (WebGrid) Default Value -
Modified | Description Represents whether this cell has been modified (dirty). ValueType boolean Default Value false
OldValue | Description Represents the cell value before the cell is modified. ValueType object Default Value ""
OldText | Description Represents the cell text before the cell is modified. ValueType string Default Value ""
ContentMode | Description Indicates whether to treat the cell text as HTML content or plain text. ValueType string Default Value "Text"
Value | Description Represents the value of the cell. ValueType object Default Value -

WebGridCell Methods

GetElement Description
Gets the HTML element of this cell.

Parameters
-

Remarks
-

Return Value

object (HTML element)

Samples

This functions sets the color of of a "CompanyName" cell from the selected row to green.

function ObtainCell()
{
var grid = ISGetObject("WebGrid1");
if (grid.GetSelectedObject() == null)
{
alert("Please select a row."); return;
}
var row = grid.GetSelectedObject().GetRowObject();
if (row.Type == "Record")
{
var cell = row.GetCell("CompanyName");
var cellElement = cell.GetElement();
 cellElement.style.color = "green";
alert("The CompanyName cell of current selected row's ForeColor is now Green.");
}
else
alert("Please select a Record Row");
}

IsForeignColumn Description
Returns true if the cell is in a foreign key column. This method is available only for the cell in a child table, meaning that the grid must be in Hierarchical mode.

Parameters
x ( string )
The XML string that contains the constraints of the childtable.

Remarks
-

Return Value

boolean

Samples

This function alerts the is-foreign-column status of a child table cell.

function IsForeignCell()
{
var grid = ISGetObject("WebGrid1");
if (grid.GetSelectedObject() == null)
{
alert("Please select a child row.");
return;
}
var row = grid.GetSelectedObject().GetRowObject();
if (row.Type == "Record" && row.SubTable != null)
{
var cell = row.GetCell("CustomerID");
var strXml = cell.SubTable.GetConstraintXml();
alert("The cell is in a foreign column: " + cell.IsForeignColumn(strXml));
}
else
alert("Please select a child row.");
}
IsActive Description
Returns a value that indicates whether the cell is in active edit mode.

Parameters
-

Remarks
-

Return Value

boolean

Samples

This function alerts the active status of a "CompanyName" cell of a selected row.

function IsCellActive()
{
var grid = ISGetObject("WebGrid1");
if (grid.GetSelectedObject() == null)
{
alert("Please select a row."); return;
}
var row = grid.GetSelectedObject().GetRowObject();
if (row.Type == "Record")
{
var cell = row.GetCell("CompanyName");
alert( cell.IsActive());
}
else
alert("Please select a Record Row");
}
GetParentKeyValue Description
Gets the key value of the cell's parent row. This method is available only for the cell in a child table, meaning that the grid must be in Hierarchical mode.

Parameters
x ( string )
The XML string that contains the constraints of the childtable.

Remarks
-

Return Value

string

Samples

This function alerts the cell's parent key value.

function ParentKeyValue()
{
var grid = ISGetObject("WebGrid1");
if (grid.GetSelectedObject() == null)
{
alert("Please select a child row.");
return;
}
var row = grid.GetSelectedObject().GetRowObject();
if (row.Type == "Record" && row.SubTable != null)
{
var cell = row.GetCell("CustomerID");
var strXml = cell.SubTable.GetConstraintXml();
alert("The cell's parent key value: " + cell.GetParentKeyValue(strXml));
}
else
alert("Please select a child row.");
}
SetText Description
Sets the text of this cell.

Parameters
s ( string )
The new text to be set.
sameValue ( boolean )
Determines whether the value of the cell should be the same as the new text.

Remarks

-

Return Value

void

Samples

This function changes the text of a cell from a selected row.

function SetText()
{
var grid = ISGetObject("WebGrid1");

if (grid.GetSelectedObject() == null)
alert("Please select a row."); return;

var row = grid.GetSelectedObject().GetRowObject();
var cell = row.GetCell("ProductName");

if (row.Type == "Record")
cell.SetText('Test', true);
else
alert("Please select a Record Row");
}
SetValue Description
Sets the value of this cell.

Parameters
v ( Depends on the cell type. )
The value to be set. No particular type required because we can assign a string, number or boolean value to the parameter.

Remarks

-

Return Value

void

Samples

This function changes the value of a cell from a selected row.

function SetValue()
{
var grid = ISGetObject("WebGrid1");

if (grid.GetSelectedObject() == null)
alert("Please select a row."); return;

var row = grid.GetSelectedObject().GetRowObject();
var cell = row.GetCell("ProductName");

if (row.Type == "Record")
cell.SetValue('Test');
else
alert("Please select a Record Row");
}
SetForceNoEdit Description
Forces this cell not to allow editing.

Parameters
v ( boolean )
If v is null or not specified then the default is true. If this is set to false, the cell would be editable.

Remarks

-

Return Value

void

Samples

This function sets a cell from the selected row not to allow editing.

function SetNoEdit()
{
var grid = ISGetObject("WebGrid1");

if (grid.GetSelectedObject() == null)
alert("Please select a row."); return;

var row = grid.GetSelectedObject().GetRowObject();
var cell = row.GetCell("ProductName");

if (row.Type == "Record")
cell.SetForceNoEdit(true);
else
alert("Please select a Record Row");
}
Select Description
Selects this cell.

Parameters

-

Remarks

-

Return Value

void

Samples

This function selects a "CompanyName" cell of a selected row.

function SelectCell()
{
var grid = ISGetObject("WebGrid1");
if (grid.GetSelectedObject() == null)
{
alert("Please select a row."); return;
}
var row = grid.GetSelectedObject().GetRowObject();
if (row.Type == "Record")
{
var cell = row.GetCell("CompanyName");
cell.Select();
}
else
alert("Please select a Record Row");
}
SetChanges Description
Change the text and value of this cell.

Parameters
text
The new text to be set.

value
The new value to be set. This parameter is optional, and only useful for valuelist column.

Remarks

-

Return Value

void

Samples

This function selects a "CompanyName" cell of a selected row.

function SelectCell()
{
var grid = ISGetObject("WebGrid1");
if (grid.GetSelectedObject() == null)
{
alert("Please select a row."); return;
}
var row = grid.GetSelectedObject().GetRowObject();
if (row.Type == "Record")
{
var cell = row.GetCell("CompanyName");
cell.Select();
}
else
alert("Please select a Record Row");
}


PreviewRowSettings

PreviewRowSettings
Send Feedback
Intersoft WebGrid > Client-side References > PreviewRowSettings

Glossary Item Box

PreviewRowSettings Properties

Style | Description Returns the style of the PreviewRow. ValueType string Default Value null
Indentation | Description Returns the indentation width. ValueType integer Default Value 18
Height | Description Gets the height of the PreviewRow. ValueType string Default Value null
DataMember | Description Gets the name of the column from which the data is obtained. ValueType string Default Value ""
Expandable | Description Indicates whether the PreviewRow is expandable. If this property is set to false, the PreviewRows would always show up. ValueType boolean Default Value true
DefaultExpanded | Description Indicates whether the PreviewRows should be initially expanded. ValueType boolean Default Value true
PreviewRowExpanded | Description Indicates whether the status of PreviewRow is expanded. ValueType boolean Default Value true

PreviewRow Methods

ExpandPreviewRow Description
Expands the row in PreviewRow of WebGrid.

Parameters
-

Remarks
-

Return Value

void

Samples

function doExpand()
{
var grid = ISGetObject("WebGrid1");
var row = grid.GetSelectedObject().GetRowObject();
row.ExpandPreviewRow();
}

CollapsePreviewRow Description
Collapses the row in PreviewRow of WebGrid.

Parameters
-

Remarks
-

Return Value

void

Samples

function doExpand()
{
var grid = ISGetObject("WebGrid1");
var row = grid.GetSelectedObject().GetRowObject();
row.CollapsePreviewRow();
}


SelfReferencingSettings

SelfReferencingSettings
Send Feedback
Intersoft WebGrid > Client-side References > SelfReferencingSettings

Glossary Item Box

SelfReferencingSettings Properties

Enabled | Description Gets the value that indicates whether self-referencing mode is enabled. ValueType boolean Default Value false
FitColumnOnExpand | Description Gets or sets whether the ExpandColumn's width should be automatically adjusted to fit the text. ValueType boolean Default Value false
ChildDataMember | Description Specifies the column where the child rows would refer to. ValueType string Default Value ""
ParentDataMember | Description Specifies the column where the parent rows would refer to. ValueType string Default Value ""
Table | Description Returns the WebGridTable object where this self-referencing mode is enabled. ValueType object (WebGridTable) Default Value null
ExpandColumnMember | Description Gets the column name that contains the expand button. ValueType string Default Value ""
ParentRootMode | Description Specifies the behavior of the self-referencing hierarchy. ValueType string Default Value "UseParentRootValue"
ParentRootValue | Description Designates a custom value other than 'NULL' as a ParentRootValue. This is used in conjunction with ParentRootMode that should be set to UseParentRootValue. ValueType string Default Value null
LoadOnDemand | Description Specifies whether to enable the LoadOnDemand feature. If this is enabled, the grid must have the InitializeSelfReferenceDataSource event handler implemented. ValueType boolean Default Value false
IsTreeViewSelectionMode | Description Specifies whether the selection mode will use TreeView-like selection. ValueType boolean Default Value false
ExpandColumnInnerTextPadding | Description Gets the padding size of the innerText of the ExpandColumn. ValueType integer Default Value 0


WebGridBatchUpdateSettings

WebGridBatchUpdateSettings
Send Feedback
Intersoft WebGrid > Client-side References > WebGridBatchUpdateSettings

Glossary Item Box

WebGridBatchUpdateSettings Properties

AllowReviewChanges | Description Specifies whether or not user is allowed to review pending changes. ValueType boolean Default Value False
AllowUndoChanges | Description Specifies whether or not user is allowed to undo pending changes. ValueType boolean Default Value True
AutomaticObjectUpdate | Description Specifies whether WebGrid should automatically update all pending changes to data objects whenever possible. ValueType readonly, boolean Default Value True
PromptOnUndoAllChanges | Description Specifies whether WebGrid should prompt users when undo all changes operation is being invoked. ValueType boolean Default Value True
NotifyOnLostFocus | Description Specifies whether WebGrid should notify users when the grid is losing its focus and there are unsaved pending changes. ValueType boolean Default Value False
HighlightChanges | Description Specifies whether pending changes rows should be highlighted. ValueType boolean Default Value True


WebGridCellData

WebGridCellData
Send Feedback
Intersoft WebGrid > Client-side References > WebGridCellData

Glossary Item Box

WebGridCellData Properties

Column | Description Gets the WebGridColumn of the changed cell. ValueType WebGridColumn object Default Value False
OldValue | Description Gets the value of the cell before it is modified by user. ValueType object Default Value True
OldText | Description Gets the text of the cell before it is modified by user. ValueType string Default Value True
NewValue | Description Gets the new value of the cell. ValueType object Default Value True
NewText | Description Gets the new text of the cell. ValueType string Default Value False
HighlightChanges | Description Gets the highlighted pending changes row. ValueType boolean Default Value True


WebGridClientSideEvents

WebGridClientSideEvents
Send Feedback
Intersoft WebGrid > Client-side References > WebGridClientSideEvents

Glossary Item Box

WebGridClientSideEvents Properties

OnBeforeRequest | Description Specifies the client-side function to be invoked when a request action to server is about to be made. ValueType string Default Value -
OnResponse | Description Specifies the client-side function to be invoked when a response from server is returned, irregardless of a successful response or error response (see also: OnActionDispatched). ValueType string Default Value -
OnColumnMove | Description Specifies the client-side function to be invoked when a column is being moved. ValueType string Default Value -
OnColumnResize | Description Specifies the client-side function to be invoked when a column is being resized. ValueType string Default Value -
OnColumnChanged | Description Specifies the client-side function to be invoked when a column is being removed or added directly from WebGrid client UI. ValueType string Default Value -
OnRowSelect | Description Specifies the client-side function to be invoked when a row is selected. ValueType string Default Value -
OnCellSelect | Description Specifies the client-side function to be invoked when a cell is selected. ValueType string Default Value -
OnCellClick | Description Specifies the client-side function to be invoked when a cell is clicked. ValueType string Default Value -
OnCellDblClick | Description Specifies the client-side function to be invoked when a cell is double clicked. ValueType string Default Value
OnGroupExpand | Description Specifies the client-side function to be invoked when a group is being expanded. ValueType string Default Value -
OnGroupCollapse | Description Specifies the client-side function to be invoked when a group is being collapsed. ValueType string Default Value
OnChildRowExpand | Description Specifies the client-side function to be invoked when a child row is being expanded. ValueType string Default Value -
OnChildRowCollapse | Description Specifies the client-side function to be invoked when a child row is being collapsed. ValueType string Default Value -
OnKeyDown | Description Specifies the client-side function to be invoked when a keystroke is being made. ValueType string Default Value -
OnRowSelectorClick | Description Specifies the client-side function to be invoked when a row selector is clicked. ValueType string Default Value -
OnEnterEditMode | Description Specifies the client-side function to be invoked when edit mode is about to be activated. ValueType string Default Value -
OnExitEditMode | Description Specifies the client-side function to be invoked when edit mode is being ended. ValueType string Default Value -
OnBeforeAdd | Description Specifies the client-side function to be invoked before a new row request is made. ValueType string Default Value -
OnAfterAdd | Description Specifies the client-side function to be invoked after a new row has been added. ValueType string Default Value -
OnBeforeUpdate | Description Specifies the client-side function to be invoked before the update request is made. ValueType string Default Value -
OnAfterUpdate | Description Specifies the client-side function to be invoked after the update process is done. ValueType string Default Value -
OnBeforeDelete | Description Specifies the client-side function to be invoked before a delete request is made. ValueType string Default Value -
OnAfterDelete | Description Specifies the client-side function to be invoked after a delete process is complete. ValueType string Default Value -
OnAfterResponseProcess | Description Specifies the client-side function to be invoked after the response of a request has been received. ValueType string Default Value -
OnUnhandledError | Description Specifies the client-side function to be invoked when an unhandled error occured. ValueType string Default Value -
OnRowValidate | Description Specifies the client-side function to be invoked when a row is being validated. ValueType string Default Value -
OnCalendarSelect | Description Specifies the client-side function to be invoked when selection is made from Calendar popup. ValueType string Default Value -
OnInitialize | Description Specifies the client-side function to be invoked when the grid is in initialization process. ValueType string Default Value -
OnRowContextMenu | Description Specifies the client-side function to be invoked when the row context menu is about to be displayed. ValueType string Default Value -
OnEditKeyDown | Description Specifies the client-side function to be invoked when a keypress is made while in edit mode (edit control is in focus). ValueType string Default Value -
OnFocus | Description Specifies the client-side function to be invoked when focus is set to the grid. ValueType string Default Value -
OnLostFocus | Description Specifies the client-side function to be invoked when the grid loses focus. ValueType string Default Value -
OnButtonClick | Description Specifies the client-side function to be invoked when a button cell is clicked. ValueType string Default Value -
OnCheckBoxClick | Description Specifies the client-side function to be invoked when a checkbox of a row-checker column or checkbox column-typed column is clicked. ValueType string Default Value -
OnActionDispatched | Description Specifies the client-side function to be invoked when a successful response is received from the server (no errors occured), similar to OnResponse. ValueType string Default Value -
OnSelfRefRowExpand | Description Specifies the client-side function to be invoked when a self-referencing row is being expanded. ValueType string Default Value -
OnSelfRefRowCollapse | Description Specifies the client-side function to be invoked when a self-referencing row is being collapsed. ValueType string Default Value -
OnColumnGroup | Description Specifies the client-side function to be invoked when a column is being grouped. ValueType string Default Value -
OnColumnUngroup | Description Specifies the client-side function to be invoked when a column is being ungrouped. ValueType string Default Value -
OnColumnGroupChange | Description Specifies the client-side function to be invoked when the order of a grouped column is changed by dragging the column to a new position. ValueType string Default Value -
OnColumnSort | Description Specifies the client-side function to be invoked when a column sorting request is being made. ValueType string Default Value -
OnColumnFilter | Description Specifies the client-side function to be invoked when a column filtering request is being made. ValueType string Default Value -
OnBeforeRowSelect | Description Specifies the client-side function to be invoked before a row is selected as current. ValueType string Default Value -
OnUndoChanges | Description Fired when a row changes is about to be undo'ed Parameters controlId The Id of WebGrid control. rowObject The row to be undo'ed. ValueType String Default Value -
OnUndoallChanges | Description Fired when undo all changes command is performed. Parameters controlId The Id of WebGrid control. ValueType String Default Value -
OnAcceptAllChanges | Description Fired when accept all changes command is performed. Parameters controlId The Id of WebGrid control. ValueType String Default Value -
OnAddPendingChanges | Description Fired when a pending changes is about to be added. Parameters controlId The Id of WebGrid control. table The table on which pending changes is added to. rowChange The row change object. ValueType String Default Value -
OnRemovePendingChanges | Description Fired when a pending changes is about to be removed. Parameters controlId The Id of WebGrid control. table The table on which pending changes is added to. rowChange The row change object. ValueType String Default Value -
OnBatchUpdateSuccess | Description Fired when batch update operation has been successfully completed. Parameters controlId The Id of WebGrid control. hasPartialErrors Whether the batch update contains one or more errors. partialErrorsXml The xml document contains partial errors data. ValueType String Default Value -
OnCustomAggregate | Description Fired when WebGrid needs to perform custom aggregation for column which AggregateType is set to Custom. Parameters controlId The Id of WebGrid control. column rows type ValueType String Default Value -
OnInitializeRow | Description Fired when a row is initialized. Parameters controlId The Id of WebGrid control. row ValueType String Default Value -
OnInitializeCell | Description Fired when a cell is initialized. Parameters controlId The Id of WebGrid control. cell ValueType String Default Value -
OnSynchronizeRow | Description Fired when a row requires synchronization. Parameters controlId The Id of WebGrid control. row ValueType String Default Value -
OnSynchronizeCell | Description Fired when a cell required synchronization. Parameters controlId The Id of WebGrid control. cell ValueType String Default Value -
OnDataSourceChanged | Description Fired when data source has been changed. Parameters controlId The Id of WebGrid control. ValueType String Default Value -
OnDataBound | Description Fired when data binding process is completed. Parameters controlId The Id of WebGrid control. hasPartialErrors Whether the batch update contains one or more errors. partialErrorsXml The xml document contains partial errors data. ValueType String Default Value -
OnPreRender | Description Fired when WebGrid enters rendering phase. Parameters controlId The Id of WebGrid control. ValueType String Default Value -
OnPostRender | Description Fired after rendering operation is completed. Parameters controlId The Id of WebGrid control. ValueType String Default Value -
OnAfterExitEditMode | Description This event is invoked after user exits cell-level editing. Parameters controlId The Id of WebGrid control. tableName editObject ValueType String Default Value -
OnBeginRowEditing | Description This event is invoked when user begins to edit a row. Parameters controlId The Id of WebGrid control. row ValueType String Default Value -
OnEndRowEditing | Description This event is invoked when user ended row editing completely. Parameters controlId The Id of WebGrid control. row ValueType String Default Value -
OnCancelRowEditing | Description This event is invoked when user canceled row editing. Parameters controlId The Id of WebGrid control. row ValueType String Default Value -
OnInitializeCustomEditor | Description Specifies the client side (JavaScript) function that will be invoked when a custom editor is about to be initialized. Parameters controlId The Id of WebGrid control. editorName editorObject customEditor ValueType string Default Value -
OnColumnContextMenu | Description Specifies the client side (JavaScript) function that will be invoked when the column's context menu is about to be displayed. Parameters controlId The Id of WebGrid control. col menu isGroup location ValueType string Default Value -
OnExportContextMenu | Description Specifies the client-side function to be invoked when a request action to server is about to be made. Parameters controlID The Id of WebGrid control. table menu location ValueType string Default Value -
OnBatchUpdateError | Description Specifies the client side (JavaScript) function that will be invoked when one or more records are failed to be updated during batch update process. Parameters controlId The Id of WebGrid control. errorXml ValueType string Default Value -
OnColumnAction | Description Specifies the client side (JavaScript) function that will be invoked when users click on the column action indicator. Parameters controlId The Id of WebGrid control. column ValueType string Default Value -


WebGridColumn

WebGridColumn
Send Feedback
Intersoft WebGrid > Client-side References > WebGridColumn

Glossary Item Box

WebGridColumn Properties

WebComboID | Description Gets the WebCombo.NET instance's ID associated with this column. ValueType string Default Value ""
Name | Description Gets the name of the column. ValueType string Default Value -
Table | Description Gets the table object that owns this column. ValueType object (WebGridTable) Default Value -
AggregateFunction | Description Gets the aggregate function which result will be shown in total rows or group total rows for a column. ValueType string Default Value "None"
AllowGrouping | Description Gets or sets whether grouping this column is allowed. ValueType string Default Value "Default"
AllowSizing | Description Gets or sets whether resizing this column is allowed. ValueType string Default Value "Default"
AllowSorting | Description Gets or sets whether sorting this column is allowed. ValueType string Default Value "Default"
Bound | Description Gets a value that indicates whether the column is bound to data. ValueType boolean Default Value -
DataMember | Description Gets the DataMember name to which the column is bound. ValueType string Default Value -
DefaultValue | Description Gets the default value of the column when a new row is added. ValueType string Default Value -
Caption | Description Gets the caption of the column. ValueType string Default Value -
GroupEmptyString | Description Gets the text displayed in a group row when the grouped value is an empty string or null. ValueType string Default Value "(none)"
GroupRowValueFormatString | Description Gets the format string for the group row's value. ValueType string Default Value ""
GroupRowInfoFormat | Description Gets the format string for the groupRow's info. ValueType string Default Value ""
EditType | Description Gets the edit control type for the column. ValueType string Default Value "TextBox"
GroupInterval | Description Gets the value that determines how groups should be calculated. ValueType string Default Value "Value"
ColumnType | Description Gets the type of the column that control how the column content will be rendered. ValueType string Default Value "Text"
HeaderTooltip | Description Gets the tool tip text that will be displayed when the mouse is over column heading area. ValueType string Default Value ""
NullText | Description Gets the text that will be displayed when a cell value is null or System.DBNull. ValueType string Default Value ""
ShowInSelectColumns | Description Specifies whether the column will be shown in Select Columns menu. ValueType string Default Value "Yes"
IsGrouped | Description Indicates whether the column is grouped. ValueType boolean Default Value false
IsSorted | Description Indicates whether the column is sorted. ValueType boolean Default Value false
Position | Description Gets the position of the column. ValueType integer Default Value -
SortKeyField | Description Gets the sort key field for SortColumn. ValueType string Default Value ""
FilterKeyField | Description Gets the filter key field for WebGridFilter object. ValueType string Default Value ""
SortOrder | Description Gets the column's sort order if the column is sorted and exists in SortColumns collection. ValueType string Default Value "None"
Visible | Description Gets the value that indicates whether the column will be rendered. ValueType boolean Default Value true
DefaultVisible | Description Gets the value that indicates whether the grid is visible by default on the first load. ValueType boolean Default Value true
Width | Description Gets the width of the column in Unit. ValueType integer Default Value 100
DataType | Description Gets the data type of the column. ValueType string Default Value -
TextboxMaxlength | Description Gets the maximum length of the TextBox Edit control. ValueType integer Default Value 0
AllowMultiLine | Description Specifies whether the cells that belong to this column can display multiple lines of data. ValueType boolean Default Value false
DataFormatString | Description Gets the format string to use when rendering values. ValueType string Default Value ""
DefaultText | Description Specifies the default text of this column when new row is added. ValueType string Default Value ""
IsRowChecker | Description Gets whether this column should act as a row checker column. ValueType boolean Default Value false
IsAutoWidth | Description Gets whether this column is an auto width column. ValueType string Default Value false
FilterEditType | Description Gets the filter edit type for this column. ValueType string Default Value "SameAsEditType"
HyperlinkTarget | Description Gets the target of this hyperlink column. ValueType string Default Value "Blank"
ButtonAutoPostback | Description Gets whether postback should be automatically performed on button click. ValueType boolean Default Value false
ButtonPostbackMode | Description Gets whether the postback should be performed by using OnTheFly or FullPagePostback mode when a button is clicked. ValueType string Default Value "OnTheFly"
HyperlinkDisplayText | Description Gets the text used for the hyperlink's display. ValueType string Default Value ""
HyperlinkFormatString | Description Gets the formatting string used to render the hyperlink's href. ValueType string Default Value
CustomEditorName | Description Gets the name of the custom editor set for this column. ValueType string Default Value ""
CustomEditorServerId | Description Gets the server ID of the custom editor set for this column. ValueType string Default Value ""
CustomEditorProperties | Description Gets the properties of the custom editor set for this column. ValueType string Default Value ""
ForceVisible | Description Gets the value that indicates whether the column is forced to visible. ValueType boolean Default Value false

WebGridColumn Methods

GetGrid Description
Gets the WebGrid instance that owns this column.

Parameters
-

Remarks
-

Return Value

void

Samples
-
GetElement Description
Gets the html element that represents the column's header.

Parameters
-

Remarks
-

Return Value

void

Samples
-
Resize Description
Resize the column to the specified width in pixel.

Parameters
width
The width of the column in pixel.

Remarks
-

Return Value

int

Samples
-
ResizeBestFit Description
Resize the column to the best fit based on the longest text in the cell.

Parameters
-

Remarks
-

Return Value

void

Samples
-
GetFilterEditType Description
Gets the filter edit type of this column.

Parameters
-

Remarks
-

Return Value

void

Samples
-
GetWidth Description
Gets the width of this column in pixel.

Parameters
-

Remarks
-

Return Value

void

Samples
-
HideFromView Description
Hides the column from view. Both parameters are optional.

Parameters
mode

partOption

Remarks
-

Return Value

-

Samples
-
Show Description
Shows the column into view. PartOption parameter is optional.

Parameters
partOption

Remarks
-

Return Value
-

Samples
-

GetViewPosition Description
Gets the column position in the view.

Parameters
-

Remarks
-

Return Value

-

Samples
-
GetViewVisiblePosition Description
Gets the column position which takes account any hidden columns.

Parameters
-

Remarks
-

Return Value

-

Samples
-
GetScrollWidth Description
Gets the scroll width of this column.

Parameters
-

Remarks
-

Return Value

-

Samples
-
GetNewRowEditType Description
Gets the edit type for the new row of this column.

Parameters
-

Remarks
-

Return Value

-

Samples
-
IsPrimaryKey Description
Determines whether this column is primary key.

Parameters
-

Remarks
-

Return Value

-

Samples
-
ShowContextMenu Description
Shows the column's context menu. Provides the selected row to the parameter when this method is called in a child table.

Parameters
row
The row that shows the context menu.

Remarks
-

Return Value

-

Samples
-


WebGridColumnSet

WebGridColumnSet
Send Feedback
Intersoft WebGrid > Client-side References > WebGridColumnSet

Glossary Item Box

WebGridColumnSet Properties

Position | Description Gets the position of the ColumnSet object. ValueType integer Default Value -
Caption | Description Gets the caption of the ColumnSet object. ValueType string Default Value -
ColumnCount | Description Gets the number of columns defined in the ColumnSet. ValueType integer Default Value 3
HeaderStyle | Description Gets the header style of the ColumnSet object. ValueType object (WebGridFormatStyle) Default Value -
Visible | Description Specifies whether the ColumnSet is visible. ValueType boolean Default Value true
Width | Description Returns the width of the ColumnSet object. ValueType integer Default Value 300
AllowSizing | Description Return a value that indicates whether the ColumnSet is allowed to be resized. ValueType string Default Value "Yes"
Name | Description Returns the name of this ColumnSet. ValueType string Default Value -
Layout | Description Returns the WebGridRowLayoutCollection object of this ColumnSet. ValueType object (WebGridRowLayout) Default Value -


WebGridCustomEditorBehavior

WebGridCustomEditorBehavior
Send Feedback
Intersoft WebGrid > Client-side References > WebGridCustomEditorBehavior

Glossary Item Box

WebGridCustomEditorBehavior Properties

BaseEditorType | Description Gets the base editor type of the custom editor. Most of scenarios will use Textbox as the base editor control, such as NumericUpDown or Calculator. In this case many of the base editing functionality is automatically handled by internal custom editor API. For more advanced scenarios, we can "draw" our own base editor type by setting this property to Custom. In that case we would need to completely implement the GetBaseEditorElement interface and handle the base editor creation manually. ValueType string Default Value "TextBox"
HasDropdownButton | Description Gets the value that indicates whether the custom editor has dropdown behavior. ValueType boolean Default Value false
DropdownButtonWidth | Description Gets the width of the dropdown button, if any. ValueType integer Default Value 16
DropdownButtonImageFile | Description Gets the name of the dropdown button's image file. ValueType string Default Value -
DropdownButtonType | Description Gets the dropdown button type. ValueType string Default Value "Image"
Tag | Description Gets additional information about the custom editor. ValueType string Default Value -


WebGridCustomEditor

WebGridCustomEditor
Send Feedback
Intersoft WebGrid > Client-side References > WebGridCustomEditor

Glossary Item Box

WebGridCustomEditor Properties
Name | Description Gets the name of the custom editor. The name must be unique through all collection regardless of whether it is installed custom editors or designer-persisted. ValueType string Default Value -
Index | Description Returns the position of the custom editor in the CustomEditors collection. ValueType integer Default Value -
ControlType | Description Gets the type of the custom editor. A Server Control or DHTML Client Control. ValueType string Default Value "ServerControl"
Persistence | Description Specifies how this custom editor should be persisted. Valid values are GridLevel and DesignerLevel. When GridLevel (default) is specified, the custom editor will be saved to the grid's instance and therefore will be applicable by that grid only and can't be seen in other grids. When DesignerLevel is specified, the custom editor definition will not be saved in the current webpage. Instead, it will be saved as a separate WCE file in a special CustomEditor folder. DesignerLevel's custom editors can be highly reusable and is visible throughout the entire project as well as in different projects. ValueType string Default Value "GridLevel"
JavascriptFiles | Description Gets the names of the JavaScript files required by this control. It is defined as the following, for instance: 'Object_Core.js, Object_UI.js'. ValueType string Default Value -
JavascriptEncoded | Description Specifies whether the javascript files for this control is encoded. ValueType boolean Default Value false
ScriptFolder | Description Specifies the folder containing the scripts that should be accessible through IIS. ValueType string Default Value -
Behavior | Description Returns the behavior object of the custom editor. ValueType object (WebGridCustomEditorBehavior) Default Value -
ServerControlFullName | Description Gets the Server Control's full name. This will return a value if the ControlType is set to ServerControl. ValueType string Default Value -


WebGridFilter

WebGridFilter
Send Feedback
Intersoft WebGrid > Client-side References > WebGridFilter

Glossary Item Box

WebGridFilter Properties

FilterText | Description Gets or sets the filter text used to filter data row for specified column member ValueType string Default Value -
FilterType | Description Gets or sets the ColumnFilterType ValueType string Default Value -
Index | Description Gets or sets the index of the WebGridGroup object based on WebGridGroupCollection object ValueType string Default Value -
ColumnMember | Description Gets or sets the column name of which its column will be grouped or sorted ValueType string Default Value -
Table | Description Gets or sets the WebGridTable of which the object belongs to ValueType string Default Value -
Name | Description Gets or sets the name of the item in its collection ValueType string Default Value -


WebGridGroup

WebGridGroup
Send Feedback
Intersoft WebGrid > Client-side References > WebGridGroup

Glossary Item Box

WebGridGroup Properties

GroupInterval | Description Gets or sets a value that determines how groups should be calculated ValueType string Default Value -
GroupMode | Description Gets or sets a value indicating whether groups should be collapsed or expanded when groups are calculated ValueType string Default Value -
GroupRowValueFormatString | Description Gets or sets the string format for the group row's value ValueType string Default Value -
SortOrder | Description Gets or sets the sort order of the WebGridGroup object ValueType string Default Value -
Index | Description Gets or sets the index of the WebGridGroup object based on WebGridGroupCollection object ValueType string Default Value -
ColumnMember | Description Gets or sets the column name of which its column will be grouped or sorted ValueType string Default Value -
Table | Description Gets or sets the WebGridTable of which the object belongs to ValueType string Default Value -
Name | Description Gets or sets the name of the item in its collection ValueType string Default Value -


WebGridImageSettings

WebGridImageSettings
Send Feedback
Intersoft WebGrid > Client-side References > WebGridImageSettings

Glossary Item Box

WebGridImageSettings Properties

Folder | Description Returns the directory path where the images used by the grid are located in. ValueType string Default Value "/CommonLibrary/Images/"
CollapseImage | Description Returns the file name of the CollapseImage. ValueType string Default Value "wg_minus.gif"
ExpandImage | Description Returns the file name of the ExpandImage. ValueType string Default Value "wg_plus.gif"
FilterImage | Description Returns the file name of the FilterImage. ValueType string Default Value "wg_filter.gif"
NewRowImage | Description Returns the file name of the NewRowImage. ValueType string Default Value "wg_newrow.gif"
SortAscImage | Description Gets or sets the file name of the SortAscImage. ValueType string Default Value -
SortDescImage | Description Gets or sets the file name of the SortDescImage. ValueType string Default Value -
InProgressImage | Description Gets or sets the file name of the InProgressImage. ValueType string Default Value "wg_inprogress.gif"
EditImage | Description Gets or sets the file name of the EditImage. ValueType string Default Value "wg_edit.gif"
GotoImage | Description Returns the file name of the GotoImage. ValueType string Default Value "wg_goto.gif"
CurrentRowImage | Description Gets or sets the file name of the CurrentRowImage. ValueType string Default Value "wg_currow.gif"
ColumnPointerImage | Description Gets or sets the file name of the ColumnPointerImage. ValueType string Default Value "wg_colptr.gif"
MoreDataImage | Description Gets or sets the file name of the MoreDataImage. ValueType string Default Value "wg_more2.gif"
RefreshImage | Description Gets or sets the file name of the RefreshImage. ValueType string Default Value "wg_refresh2.gif"
ExportImage | Description Gets or sets the file name of the ExportImage. ValueType string Default Value "wg_export.gif"
PreviewRowCollapseImage | Description Returns the file name of the PreviewRowCollapseImage. ValueType string Default Value "wg_prcol.gif"
PreviewRowExpandImage | Description Returns the file name of the PreviewRowExpandImage. ValueType string Default Value "wg_prexp.gif"
HelpImage | Description Returns the file name of the HelpImage. ValueType string Default Value "syshelp16.gif"


WebGridLayoutSet

WebGridLayoutSet
Send Feedback
Intersoft WebGrid > Client-side References > WebGridLayoutSet

Glossary Item Box

WebGridLayoutSet Properties

VirtualLoadMode | Description Gets the VirtualLoadMode property value. ValueType string Default Value "Default"
AllowContextMenu | Description Allows or disallows context menu for the grid. ValueType boolean Default Value true
Culture | Description Specifies the culture settings for current WebGrid instance. ValueType string Default Value "Default"
EditOnClick | Description Gets or sets whether to enter edit mode upon a cell click. ValueType boolean Default Value false
EditFocusCellStyle | Description The style of the focused cell object. ValueType string Default Value null
AllowGrouping | Description Enables or disables grouping feature on the client side. ValueType string Default Value "No"
VirtualPageSize | Description Gets the number of rows to retrieve when PagingMode is set to VirtualLoad. ValueType integer Default Value 50
ClientSideEvents | Description Returns ClientEvents object. ValueType object (WebGridClientEvents) Default Value -
SizeHeightBy | Description Specifies the grid height adjustment when working in AutoHeight mode. ValueType integer Default Value 0
SizeWidthBy | Description Specifies the grid width adjustment when working in AutoHeight mode. ValueType integer Default Value 0
AllowAddNew | Description Allows or disallows users to add a new row. ValueType string Default Value "No"
AllowColumnSizing | Description Specifies whether to allow users to resize the column width. ValueType string Default Value "Yes"
AllowColumnMove | Description Gets the property value that indicates whether column moving is allowed. ValueType string Default Value "No"
AllowEdit | Description Specifies whether to allow users to edit and modify data. ValueType string Default Value "No"
AllowDelete | Description Specifies whether to allow users to delete data within the grid. ValueType string Default Value "No"
AllowFilter | Description Specifies whether to allow users to filter the grid data. ValueType string Default Value "No"
AllowSelectColumns | Description Specifies whether to allow users to select columns within the grid. ValueType string Default Value "No"
AllowSorting | Description Specifies whether to allow users to sort columns within the grid. ValueType string Default Value "No"
AutoWidth | Description Specifies whether WebGrid will automatically calculate its height based on available page height. ValueType boolean Default Value false
AutoHeight | Description Specifies whether WebGrid will automatically calculate its width based on available page width. ValueType boolean Default Value false
AlternatingColors | Description Specifies whether to display alternate rows with AlternateRowStyle style. ValueType boolean Default Value true
CellClickAction | Description Specifies the action when a user clicks on a cell. ValueType string Default Value "RowSelect"
PagingMode | Description Specifies the paging mode that determines the rows retrieval behavior in WebGrid. ValueType string Default Value "None"
ColumnHeaders | Description Specifies whether to display column headers. ValueType string Default Value "Yes"
ColumnFooters | Description Indicates whether to display column footers. ValueType string Default Value "No"
HeaderClickAction | Description Specifies the action when users click on column's header. ValueType string Default Value "SortSingle"
GroupByBoxVisible | Description Indicates whether to show group by box. ValueType boolean Default Value false
GroupByBox | Description Gets or sets the GroupByBoxObject that is used to control the appearance of GroupBox. ValueType object (GroupByBoxObject) Default Value -
GroupRowInfoFormatDefault | Description Gets or sets the default group row format. ValueType string Default Value "[caption]: [value]"
RowHeaders | Description Specifies whether to display row headers. ValueType string Default Value "Yes"
Hierarchical | Description Indicates whether WebGrid is using hierarchical data structure. ValueType boolean Default Value false
ImageSettings | Description Gets the ImageSettings object which is used to store the images used by WebGrid. ValueType object (WebGridImageSettings) Default Value -
RowHeaderWidth | Description Gets the width of RowHeader in Unit. ValueType integer Default Value 18
RowHeightDefault | Description Gets the default row height in Unit. ValueType string Default Value "20px"
HideColumnsWhenGrouped | Description Specifies whether the column headers of the grouped columns is hidden. ValueType string Default Value "Yes"
Grid | Description Gets the grid object that owns this LayoutSet. ValueType object (WebGrid) Default Value -
StatusBarVisible | Description Specifies whether the status bar is visible. ValueType boolean Default Value true
ScriptDirectory | Description Specifies the WebGrid client-script files directory. ValueType string Default Value "/CommonLibrary/WebGrid/V4_0_6200/"
AlwaysShowHelpButton | Description Specifies whether Help button is always shown in WebGrid UI. ValueType boolean Default Value true
NewRowLostFocusAction | Description Specifies the action to take when the New Row loses its focus after any of its cells has been modified (row marked as dirty). ValueType string Default Value "NeverUpdate"
RowLostFocusAction | Description Specifies the action to take when a row loses its focus after any of its cells has been modified (row marked as dirty). ValueType string Default Value "AlwaysUpdate"
TextSettings | Description This property provides a convenient way to change textual settings used in WebGrid. ValueType object (WebGridTextSettings) Default Value -
AllowExport | Description Indicates whether grid exporting is allowed in UI. ValueType string Default Value "No"
ChildRowEmptyAction | Description Indicates what action to take if a row's child table is empty. ValueType string Default Value "ShowChildContent"
CustomFilterString | Description Gets or sets the custom filtering string. ValueType string Default Value -
ResetNewRowValuesOnError | Description Indicates whether the cell values of NewRow should be cleared if an error occurred during AddRow server event. ValueType boolean Default Value true
InProgressUIBehavior | Description Specifies the UI behavior when a request is in progress. ValueType string Default Value "DisplayMessageBox"
ColumnSetHeaders | Description Indicates whether the ColumnSet headers should be visible or not. ValueType string Default Value "Yes"
RowHeaderStyle | Description Gets the style applied to the row header. ValueType string Default Value -
TreeLines | Description Specifies whether the tree lines is shown for Hierarchical mode. ValueType Default Value
ChildTableSpacing | Description Gets or sets the spacing width between each child table at the same level. ValueType integer Default Value 4
ShowRefreshButton | Description Specifies whether the grid should display Refresh button in the status bar. ValueType boolean Default Value true
AutoFitColumns | Description Indicates whether all displayed columns' width should be fitted to grid. ValueType boolean Default Value false
FilterBarVisible | Description Specifies whether the filter bar would initially be visible. ValueType boolean Default Value true
ClientVisible | Description Specifies a value indicating grid's visibility on client side. ValueType boolean Default Value true
AutoColMinWidth | Description The minimum width for WebGridColumn when IsAutoWidth is set to true. ValueType integer Default Value 100
PromptBeforeDelete | Description Indicates whether to display a confirmation box before deleting a row. ValueType boolean Default Value false
ApplyFiltersKey | Description Gets or sets the key used to apply all filters. ValueType string Default Value "ShiftEnter"
HelpURL | Description Returns the URL of the custom Help document. ValueType string Default Value -
PersistRowChecker | Description Specifies whether to persist row checker values between Page Postbacks. ValueType boolean Default Value false


WebGrid

WebGrid
Send Feedback
Intersoft WebGrid > Client-side References > WebGrid

Glossary Item Box

WebGrid Properties

Version | Description Gets the complete version number of the WebGrid object including the build version number. ValueType string Default Value -
MajorVersion | Description Gets the major version number of the WebGrid. ValueType string Default Value -
RequiredFrameworkVersion | Description Gets the required Intersoft WebUI Framework version. ValueType string Default Value -
LayoutSettings | Description Gets the LayoutSettings which is the central object that contains all the behaviors and styles of the WebGrid control. ValueType object (LayoutSet) Default Value -
RootTable | Description Gets the WebGridTable object that is used as the root table in the WebGrid.NET control. ValueType object (WebGridTable) Default Value -
ScriptDirectory | Description Gets the directory path of the script files. ValueType string Default Value -
Enabled | Description Gets the value that indicates whether the WebGrid control is enabled. ValueType boolean Default Value true
Visible | Description Gets the value that indicates whether the control is visible. ValueType boolean Default Value true
Name | Description Gets the name of the grid. ValueType string Default Value -
TotalLoadedRows | Description Gets the number of the loaded rows. ValueType integer Default Value -
TotalRows | Description Gets the total number of rows that are assigned to the grid, including to be loaded ones. ValueType integer Default Value -
CultureInfo | Description Gets the current CultureInfo code of the grid object. ValueType string Default Value -
EnableV3XAPISupport | Description Gets the value of a property that indicates whether WebGrid V3.x APIs are supported. ValueType boolean Default Value false
ResizerStyle | Description Gets or sets the style of the object used to represent vertical resizing bar. ValueType string Default Value "position: absolute; z-index: 299; width: 2px; background-color: gray; display: none;"
SelectedHeaderBackColor | Description The backcolor of selected column header. ValueType string Default Value "black"
SelectedHeaderForeColor | Description The forecolor of selected column header. ValueType string Default Value "white"
HidePadColumn | Description Hides the pad column (a small section of the column headers above the vertical scrollbar). ValueType boolean Default Value false
NeedHeightResize | Description Sets the value that tells the grid whether it needs to resize its own height after one of its rows has been removed/hidden on client side. ValueType boolean Default Value false
NeedWidthResize | Description Sets the value that tells the grid whether it needs to resize its own width after one of its columns has been removed/hidden on client side. ValueType boolean Default Value false
IsInProgress | Description Gets or sets the grid state that indicates whether it is in processing request. ValueType boolean Default Value false
LastRequestObj | Description Gets the object used to process the last request. ValueType object Default Value -
LastAction | Description Gets the action name of the processed last request. ValueType string Default Value -
ValEngine | Description Returns the grid's validation engine object. ValueType object Default Value -
ExportTypeList | Description Gets or sets the export types displayed in the Export context menu. ValueType string (array) Default Value "HTML", "PDF", "XML"
ExportWndAttr | Description Gets or sets the window attributes for the export output. ValueType string Default Value "toolbar= no, menubar= yes, scrollbars= yes, resizable= yes"
LastError | Description Gets the last error message of the grid. ValueType string Default Value -
EditCtlTopAdj | Description Adjustment to top position of edit control relatively. ValueType integer Default Value -
EditCtlLeftAdj | Description Adjustment to left position of edit control relatively. ValueType integer Default Value -
PosRelativeTo | Description Sets where the grid is relatively located. Use this property to resolve the textbox offset position issue when the grid is inside a complex table or div structure while in edit mode. ValueType object (HTML Element) Default Value -
CheckedRowContext | Description Gets the checked-row context menu object. ValueType object Default Value -
HeaderContext | Description Gets the header context menu object. ValueType object Default Value -

WebGrid Methods

IsClassicPaging Description
Determines whether the WebGrid is using classic paging mode.

Parameters
-

Remarks
-

Return Value

boolean

Samples
-
GetCurrentPage Description
Gets the current page of the data in the grid.

Parameters
-

Remarks
-

Return Value

int

Samples
-
GetTotalPages Description
Gets the total pages of the data in the grid.

Parameters
-

Remarks
-

Return Value

int

Samples
-
GotoFirstPage Description
Switches to the first page of the data in the grid.

Parameters
-.

Remarks
-

Return Value

void

Samples
function MoveFirst()
{
var grid = ISGetObject("WebGrid1");
grid.GotoFirstPage();
}
GotoLastPage Description
Switches to the last page of the data in the grid.

Parameters
-

Remarks
-

Return Value

void

Samples
function MoveLast()
{
var grid = ISGetObject("WebGrid1");
grid.GotoLastPage();
}
GotoPreviousPage Description
Switches to the previous page of the data in the grid.

Parameters
-

Remarks
-

Return Value

void

Samples
function MovePrevious()
{
var grid = ISGetObject("WebGrid1");
grid.GotoPreviousPage();
}
GotoNextPage Description
Switches to the next page of the data in the grid.

Parameters
-

Remarks
-

Return Value

void

Samples
function MoveNext()
{
var grid = ISGetObject("WebGrid1");
grid.GotoNextPage();
}
GotoPage Description
Switches to specific page of the data in the grid.

Parameters
targetPageNumber ( int )
The number of the targeted page.

Remarks
-

Return Value

void

Samples
function MovePage()
{
var grid = ISGetObject("WebGrid1");
grid.GotoPage(5);
}
CreatePagingSlider Description
Creates the paging slider bar in the grid.

Parameters
containerId ( string )
The container's ID.

sliderId ( string )
The slider's ID.

Remarks
-

Return Value

Slidebar object

Samples
This function alerts the column name and type of a double-clicked cell.

function CreateSlider()
{
var grid = ISGetObject("WebGrid1");
var slider = grid.CreatePagingSlider("SliderContainer", grid.Id + "_slider");

slider.SliderSize = 16;
slider.SliderImage = "./images/vista_slider_thumb.gif";
slider.Width = ISPosLib.getWidth(document.getElementById("SliderContainer"));
slider.Initialize();

// create the slider object, instantiate it, and assign it to PagingSliderBar
grid.PagingSliderBar = slider;

UpdatePageStatus();
}
SynchronizeSliderUI Description
Synchronizes the slider state to reflect the current state every time after the paging action is done.

Parameters
-

Remarks
-

Return Value

void

Samples
function SynchronizeSlider()
{
var grid = ISGetObject("WebGrid1");
grid.SynchronizeSliderUI();
}
GetColumnByElement Description
Gets the WebGridColumn object given the column element.

Parameters
el ( object - column element )
A column HTML element object.

Remarks
-

Return Value

object (WebGridColumn)

Samples
This function alerts the column name and type of a double-clicked cell.

function onCellDblClick(gridId, tblName, rowIndex, cellIndex, cellElm) {
var grid = ISGetObject(gridId);
var wgCol = grid.GetColumnByElement(cellElm);

alert("wgCol's type: " + wgCol._Type + " " +
"wgCol's column name: " + wgCol.Name);

return true;
}
GetCellByElement Description
Gets the WebGridCell object given the cell element.

Parameters
el ( object - cell element )
A cell HTML element object.

Remarks
-

Return Value

object (WebGridCell)

Samples
This function alerts the double-clicked cell text.

function onCellDblClick(gridId, tblName, rowIndex, cellIndex, cellElm) {
var grid = ISGetObject(gridId);
var cell = grid.GetCellByElement(cellElm);
alert(cell.Text);
return true;
}
GetRowByElement Description
Gets the WebGridRow object given the row element.

Parameters
el ( object - row element )
A row HTML element object.

Remarks
-

Return Value

object (WebGridRow)

Samples
This function alerts the type of the row each time a user selects a row.

function DoRowSelect(controlId, tblName, rowIndex, rowElm)
{
var grid = ISGetObject(controlId);
var row = grid.GetRowByElement(rowElm);
alert(row.Type);
return true;
}

GetElement Description
Gets any element by specifying valid values in the parameters.

Parameters
gridPart ( constant )
The constant that represents the part of the grid, for example: WG40.COLHEADER.

htmlPart ( constant )

The constant that represents the HTML part of the grid, for example: WG40.HTMLTABLE.

Remarks
-

Return Value

object (HTML element)

Samples
This function alerts the text on the left-hand side of the status bar.

function LeftStatusBarText()
{
var grid = ISGetObject("WebGrid1");
var cell = grid.GetElement(WG40.STATUSBAR, WG40.HTMLCELL);
alert(cell.innerText);
}

SetStatus1 Description
Sets the left-most grid status text.

Parameters
text ( string )
The text to be applied.
attr ( string )
This parameter is no longer required in WebGrid v3.5.
lgAttr ( string )
The language TextItem key. If this parameter is supplied, the text parameter should be set to empty, e.g: CommonText/Ready.

Remarks
-

Return Value

void
Samples
This function sets the left-hand side text of the status bar to "I'm ready".

function setStatus1()
{
var grid = ISGetObject('WebGrid1');
grid.SetStatus1("I'm ready.");
}

SetStatus2 Description
Sets the right-most grid status text.

Parameters
text ( string )
The text to be applied.
attr ( string )
The language TextItem key. Set this to 'loaded' if you want to display loaded row status.
p1 ( integer )
The number of the loaded rows.
p2 ( integer )
The number of the total rows in the data source.

Remarks
-

Return Value

void

Samples

function setStatus2() {
var grid = ISGetObject('WebGrid1');
grid.SetStatus2("Obtained");
}

SendCustomRequest Description
Invokes OnTheFly PostBack and pass custom data to the server.

Parameters
-

Remarks
-

Return Value

void

Samples

var grid = ISGetObject('WebGrid1');
grid.SendCustomRequest();

ClearSelectedObject Description
Clears selected object of the grid.

Parameters
-

Remarks
-

Return Value

void

Samples

var grid = ISGetObject('WebGrid1');
grid.ClearSelectedObject();
GetSelectedObject Description
Gets the last selected object.

Parameters
-

Remarks
-

Return Value

object (SelectedObject)

Samples

function ObtainRow()
{
var grid = ISGetObject("WebGrid1");
if (grid.GetSelectedObject() == null)
{
alert("Please select a row."); return;
}
var wgRow = grid.GetSelectedObject().GetRowObject();
}

GetDefaultLanguageXml Description
Returns the XML document object for the default language.

Parameters
-

Remarks
-

Return Value

object (XML Document)

Samples

function buttonClick()
{
var grid = ISGetObject('WebGrid1');
var xmlDoc = grid.GetDefaultLanguageXml();
alert(xmlDoc.src);
}

GetLanguageXml Description
Returns the XML document object for the language.

Parameters
-

Remarks
-

Return Value

object (XML Document)

Samples

This function alerts the source of the XML document object.

function buttonClick()
{
var grid = ISGetObject('WebGrid1');
var xmlDoc = grid.GetLanguageXml();
alert(xmlDoc.src);
}

GetString Description
Returns the string representation of the language XML document object.

Parameters
lgAttr ( string )
The TextItem's name.

Remarks
-

Return Value

string

Samples

function buttonClick()
{
var grid = ISGetObject('WebGrid1');
var strXml = grid.GetString();
alert(strXml);
}

Refresh Description
Invokes refresh action to the grid. This method will refresh only the data.

Parameters
-

Remarks
-

Return Value

void

Samples

var grid = ISGetObject('WebGrid1');
grid.Refresh();

RefreshAll Description
Invokes full refresh action to the grid. This method will refresh the whole grid, including the grid structure. For instance, if the column structure has changed, the changes will be picked up upon calling this method.

Parameters
-

Remarks
-

Return Value

void

Samples

var grid = ISGetObject('WebGrid1');
grid.RefreshAll();
HasFocus Description
Determines whether the grid currently has the focus.

Parameters
-

Remarks
-

Return Value

boolean

Samples

var grid = ISGetObject('WebGrid1');
alert(grid.HasFocus());
HasGroup Description
Returns true if the grid has a grouped column or a child table.

Parameters
-

Remarks
-

Return Value

boolean

Samples

var grid = ISGetObject('WebGrid1');
alert(grid.HasGroup());
ActivateEditMode Description
Activates the grid's edit mode.

Parameters
isDirty ( boolean )
Specifies whether the edit mode activation will automatically mark the edit control dirty.

Remarks
-

Return Value
void

Samples
var grid = ISGetObject('WebGrid1');
grid.ActivateEditMode(false);
ExitEditMode Description
Quits the edit mode when an edit control is active (displayed).

Parameters
isCancel ( boolean )
Specifies whether the edit mode will be ended with cancel flag.

Remarks
-

Return Value

boolean
Samples
ISGetObject('WebGrid1');
grid.ExitEditMode(false);
ExitEdit Description
Exit from row editing completely. If a row has been modified (dirty), calling this method with success reasonFlag will update the active row.

Parameters
reasonFlag ( integer )
The reason flag that causes the row edit mode to be ended.
flag2 ( object )
Various flag, depends on reasonFlag.
flag3 ( object )
Various flag, depends on reasonFlag.

Remarks
-

Return Value
void

Samples

var grid = ISGetObject('WebGrid1');
grid.ExitEdit(1, 0, 0);
UpdateState Description
Updates the grid state.

Parameters
-

Remarks
-

Return Value
void

Samples

var grid = ISGetObject('WebGrid1');
grid.UpdateState();
HideGroupByBox Description
Hides the GroupByBox.

Parameters
-

Remarks
-

Return Value
void

Samples

var grid = ISGetObject('WebGrid1');
grid.HideGroupByBox();

IsGroupByBoxShown Description
Returns a value that indicates whether the GroupByBox is currently shown.

Parameters
-

Remarks
-

Return Value
boolean

Samples

var grid = ISGetObject('WebGrid1');
alert(grid.IsGroupByBoxShown());

ShowFilterBar Description
Displays the filter bar.

Parameters
-

Remarks
-

Return Value
void

Samples

var grid = ISGetObject('WebGrid1');
grid.ShowFilterBar();
HideFilterBar Description
Hides the filter bar.

Parameters
-

Remarks
-

Return Value
void

Samples

var grid = ISGetObject('WebGrid1');
grid.HideFilterBar();

IsVisible Description
Returns a value that indicates whether the grid is visible.

Parameters
-

Remarks
-

Return Value
boolean

Samples

var grid = ISGetObject('WebGrid1');
alert(grid.IsVisible());

SetBusy Description
Marks the grid status as busy. When a grid is busy, we have to wait until the grid is set to idle before we can invoke another action.

Parameters
-

Remarks
-

Return Value
void

Samples

var grid = ISGetObject('WebGrid1');
grid.SetBusy();

SetIdle Description
Marks the grid status as idle. When a grid is busy, we have to wait until the grid is set to idle before we can invoke another action.

Parameters
-

Remarks
-

Return Value
void

Samples

var grid = ISGetObject('WebGrid1');
grid.SetIdle();

GetBlurRowStyle Description
Gets the lost focus style.

Parameters
-

Remarks
-

Return Value
string

Samples

var grid = ISGetObject('WebGrid1');
var style = grid.GetBlurRowStyle();
alert(style);

GetEditFocusStyle Description
Gets the edit mode focus style.

Parameters
-

Remarks
-

Return Value
string

Samples

var grid = ISGetObject('WebGrid1');
var style = grid.GetEditFocusStyle();
alert(style);

MarkEdit Description
Marks the selected row of this grid to row edit mode.

Parameters
-

Remarks
-

Return Value
void

Samples

var grid = ISGetObject('WebGrid1');
grid.MarkEdit();

GetCurSelImage Description
Returns the path of currently selected image file.

Parameters
-

Remarks
-

Return Value
string

Samples
-

Show Description
Sets the grid's visibility to visible.

Parameters
-

Remarks
-

Return Value

void
Samples
var grid = ISGetObject('WebGrid1');
grid.Show();
SetFocus Description
Sets the focus to this grid.

Parameters
-

Remarks
-

Return Value

void

Samples

var grid = ISGetObject('WebGrid1');
grid.SetFocus();
Hide Description
Sets the grid's visibility to hidden.

Parameters
-

Remarks
-

Return Value

void
Samples
var grid = ISGetObject('WebGrid1');
grid.Hide();
ExportGrid Description
Exports the grid to a document.

Parameters
tblName ( string )
The name of the table to be exported.
-
exportType ( string )
The type of the exported document, e.g: "HTML", "PDF".
-
pageOrientation ( string )
The page orientation of the exported document, e.g: "PORTRAIT", "LANDSCAPE".
-
parentRow ( object - row element )
The parent row of the sub table to be exported, required only when exporting sub table.

Remarks
-

Return Value
void

Samples

var grid = ISGetObject('WebGrid1');
grid.ExportGrid("Customers", "PDF", "PORTRAIT");
GetActiveEditCell Description
Returns the currently active edit cell. This will return NULL if no cell is active.

Parameters
-

Remarks
-

Return Value

object (ActiveEditCell)

Samples
This function changes the innerText of the ActiveEditCell.

function buttonClick()
{
var grid = ISGetObject('WebGrid1');
var cell = grid.GetActiveEditCell();
cell.element.innerText = "This cell content is changed";
}

GetLastEditObject Description
Gets the last EditObject during edit mode.

Parameters
-

Remarks
-

Return Value
object (EditObject)

Samples
This function alerts the EditObject's table name when a user presses the Enter key when the grid is in edit mode.

function onEditKeyDown(gridId)
{
if (event.keycode == 13)
{
var grid = ISGetObject(gridId);
var ac = grid.GetLastEditObject();
alert(ac.tblName);
}
return true;
}

GetChangesCount Description
Returns the count of all pending changes regardless of the state and table.

Parameters
-

Remarks
-

Return Value
int

Samples
UpdatePendingChangesStatus Description
Synchronize pending changes with Grid�??s user interface elements

Parameters
-

Remarks
-

Return Value
void

Samples
UndoAllChanges Description
Undo all pending changes regardless of the state and table.

Parameters
-

Remarks
-

Return Value
void

Samples
AcceptAllChanges Description
Accept all pending changes and submit them to server for batch update.

Parameters
-

Remarks
-

Return Value
void

Samples
GetChanges Description
Returns a list of WebGridRowChange objects.

Parameters
rowState
Specifies the state of changes to get.

Remarks
-

Return Value
object (WebGridRowChange)

Samples
InvalidateChanges Description
Invalidate all pending changes to be reprocessed in the next synchronization.

Parameters
-

Remarks
-

Return Value
void

Samples
ClearChanges Description
Clear and remove all pending changes regardless of the state and table.

Parameters
-

Remarks
-

Return Value
void

Samples
SetDataSource

Description
Assign a new client-side datasource to WebGrid.

Parameters
datasource
The datasource to be assigned.

tableName
The table to be assigned.

Remarks
-

Return Value
void

Samples
GetConvertedDataSource Description
Gets the datasource that has been converted to CDOF-compatible object

Parameters
-

Remarks
-

Return Value
void

Samples
DataBind Description
Instructs WebGrid to perform data binding based on assigned datasource.

Parameters
-

Remarks
-

Return Value
void

Samples
LoadData Description
Instructs WebGrid to perform initial data loading.

Parameters
-

Remarks
-

Return Value
void

Samples
Render Description
Perform rendering based on bound data.

Parameters
-

Remarks
-

Return Value
void

Samples
RebindData Description
Rebind WebGrid with new datasource.

Parameters
dataSource

skipDataDispatch

Remarks
-

Return Value
void

Samples


WebGridRowChanges

WebGridRowChanges
Send Feedback
Intersoft WebGrid > Client-side References > WebGridRowChanges

Glossary Item Box

WebGridRowChanges Properties

RowState | Description The change state of the row. ValueType readonly, string Default Value Possible values: Added, Modified, Deleted
Element | Description The element of the row. ValueType readonly, HTMLRow object Default Value -
Data | Description Gets the collection of data indicating user modified cells. ValueType readonly, Array of WebGridCellData Default Value -
Row | Description Gets the corresponding WebGridRow object of the changed row. It will return null for added row. ValueType readonly, WebGridRow object Default Value -
KeyValues | Description Gets multiple key values of the changed row. ValueType readonly, string Default Value -
Table | Description Gets the WebGridTable of which the changed row belongs to. ValueType readonly, WebGridTable object Default Value -

WebGridRowChanges Methods

MergeChanges Description
.

Parameters

WebGridRow object
The row to be merged.

Remarks
-

Return Value

void

Samples

function doExpand()
{
var grid = ISGetObject("WebGrid1");
var row = grid.GetSelectedObject().GetRowObject();
row.ExpandPreviewRow();
}

GetExistingData Description
.

Parameters

string
The name of cell to retrieve.

Remarks
-

Return Value

void

Samples

function doExpand()
{
var grid = ISGetObject("WebGrid1");
var row = grid.GetSelectedObject().GetRowObject();
row.ExpandPreviewRow();
}


WebGridRowLayout

WebGridRowLayout
Send Feedback
Intersoft WebGrid > Client-side References > WebGridRowLayout

Glossary Item Box

WebGridRowLayout Properties

Name | Description The RowLayout object name ValueType string Default Value -
Row | Description The index of the row ValueType string Default Value -
Col | Description The index of the column ValueType string Default Value -
ColumnMember | Description The ColumnMember name ValueType string Default Value -
Width | Description The width of the RowLayout ValueType string Default Value -
Height | Description The height of the RowLayout ValueType string Default Value -
Spanned | Description Determine whether this RowLayout is span ValueType string Default Value -
Column | Description The column of the RowLayout ValueType string Default Value -
RowSpan | Description The row span ValueType string Default Value -
ColSpan | Description The column span ValueType string Default Value -


WebGridRow

WebGridRow
Send Feedback
Intersoft WebGrid > Client-side References > WebGridRow

Glossary Item Box

WebGridRow Properties

Table | Description Gets the WebGridTable to which the row belongs. ValueType object (WebGridTable) Default Value -
SubTable | Description Gets the SubTable of the current row. ValueType object (WebGridSubTable) Default Value -
ParentTableRow | Description Gets the parent table row that owns this row. ValueType object (WebGridRow) Default Value -
ParentRow | Description Gets the ParentRow of the current row. ValueType object (WebGridRow) Default Value -
KeyValues | Description Gets the key values of composite data key fields. ValueType string Default Value -
ChildrenLoaded | Description Returns whether children row's has been loaded. ValueType boolean Default Value -
Expanded | Description Gets or sets a value that indicates whether the row is expanded. ValueType boolean Default Value -
Grid | Description Gets the WebGrid object that owns the row. ValueType object (WebGrid) Default Value -
Parent | Description Gets the parent row that owns this row. ValueType object (WebGridRow) Default Value -
Position | Description Gets or sets the ordinal position of the row object. ValueType integer Default Value -
Selected | Description Determines whether the current row is selected or not. ValueType boolean Default Value -
Visible | Description Specifies whether the row should be rendered. ValueType boolean Default Value -
Type | Description Gets the type of the row. ValueType string Default Value -
DataChanged | Description Returns whether row's data has been changed. ValueType boolean Default Value -
KeyValue | Description Gets the key values of composite data key fields. ValueType string Default Value -
ForceNoEdit | Description Determines whether this row will be forced to not allow editing. ValueType boolean Default Value -
Checked | Description Determines whether the current row is checked. ValueType boolean Default Value -
Name | Description The Name of the item in its collection. ValueType string Default Value -
GroupRowText | Description Gets the GroupRow text. ValueType string Default Value -
GroupExpanded | Description Determines whether the GroupColumns of this row has been expanded. ValueType boolean Default Value -
ChildExpanded | Description Determines whether the Child Rows of current row is expanded. ValueType boolean Default Value -
SelfRefLevel | Description Gets the SelfReference level. ValueType integer Default Value -
IsSelfRefRow | Description Determines whether current row is SelfReference type row. ValueType boolean Default Value -
SelfRefRowCount | Description Gets the number of the child SelfReference row. ValueType integer Default Value -
SelfRefParentValue | Description Gets the SelfReference parent value. ValueType integer Default Value -

WebGridRow Methods

GetNextRow Description
Gets the next WebGridRow object.

Parameters
-

Remarks
-

Return Value

object (WebGridRow)

Samples

In this sample, GetNextRow() method is utilized in order to obtain the next WebGridRow object. This sample can be seen in WG40Tutorials -> Programmatic_UI2.aspx.

function CheckRows()
{
// obtain grid's object
var grid = ISGetObject("WebGrid1");
// obtain WebGridRow object of 6th row
var row = grid.RootTable.GetRow(5);

for (var i=0; i<5; i++)
{
// set the row as checked
row.Check();
// obtain the next WebGridRow object
row = row.GetNextRow();
}
}
GetPreviousRow Description
Gets the previous WebGridRow object.

Parameters
-

Remarks
-

Return Value

object (WebGridRow)

Samples

In this sample, GetPreviousRow() method is utilized in order to obtain the previous WebGridRow object. This sample can be seen in WG40Tutorials -> Programmatic_UI2.aspx.

function CheckRows()
{
// obtain grid's object
var grid = ISGetObject("WebGrid1");
// obtain WebGridRow object of 11th row
var row = grid.RootTable.GetRow(10);

for (var i=0; i<5; i++)
{
// set the row as checked
row.Check();
// obtain the previous WebGridRow object
row = row.GetPreviousRow();
}
}
Update Description
Performs row update.

Parameters
useSync ( boolean )
Indicates whether asynchronous mode is utilized.

Remarks
-

Return Value

void
Samples
Perform row update

function UpdateRow()
{
var grid = ISGetObject("WebGrid1");
// get WebGridRow object by key value.
var row = grid.RootTable.GetRowByKeyValue("SPLIR");
var cells = row.GetCells();

// select this row for focus
row.Select();
// change contact title cell to Owner
cells.GetNamedItem("ContactTitle").SetText("Owner", true);

// perform Update
row.Update();
alert("ContactTitle of this row has been changed to 'Owner'");
}
Delete Description
Performs row delete.

Parameters
useSync ( boolean )
Indicates whether asynchronous mode is utilized.

Remarks
-

Return Value
void
Samples
Perform delete row

function DeleteRow()
{
var grid = ISGetObject("WebGrid1");
// get WebGridRow object by key value.
var row = grid.RootTable.GetRowByKeyValue("VINET");

// select this row for focus
row.Select();
alert("Click OK to delete this row.");

// delete this row
row.Delete();
alert("Customer 'VINET' has been deleted!");
}
Validate Description
Invokes OnRowValidate client side event for the specified RowElement.

Parameters
-

Remarks
-

Return Value
void
Samples
Manually invoke OnRowValidate client side function

function DoPerformRowValidate()
{
var grid = ISGetObject("WebGrid1");
var firstRow = grid.RootTable.GetRow(0);
// Validate() method will automatically invoke
// OnRowValidate client side event
// Please attach a client side event
// on OnRowValidate before invoking this method
firstRow.Validate();

return true;
}
IsDirty Description
Determines whether the current row is dirty.

Parameters
-

Remarks
-

Return Value
boolean

Samples

Check whether the NewRow is dirty or not

function SelectNewRow()
{
var grid = ISGetObject("WebGrid1");
// return the html element of the newrow
var newRowElement = grid.RootTable.GetNewRow();
// convert to WebGridRow object
var newRow = grid.RootTable.ToRowObject(newRowElement);

// select new row
newRow.Select();

// populate cells
var cells = newRow.GetCells();
// activate edit cell on City cell, instead of first cell
cells.GetNamedItem("City").ActivateEdit();
// set the CustomerID cell's text to NEWCUST,
// 2nd parameter is true indicating that the value is same as the text.
cells.GetNamedItem("CustomerID").SetText("NEWCUST", true);
cells.GetNamedItem("Address").SetText("New Address", true);

// indicates that this row's data has been changed.
newRow.SetDataChanged();

// check whether the NewRow is dirty or not
alert( newRow.IsDirty() );
// sets the row's status as edited,
// as if user has typed inside the cell.
grid.MarkEdit();
}
SetDataChanged Description
Indicates that the current row's data has been changed.

Parameters
-

Remarks
-

Return Value
void
Samples
Use SetDataChanged method

function SelectNewRow()
{
var grid = ISGetObject("WebGrid1");
// return the html element of the newrow
var newRowElement = grid.RootTable.GetNewRow();
// convert to WebGridRow object
var newRow = grid.RootTable.ToRowObject(newRowElement);

// select new row
newRow.Select();

// populate cells
var cells = newRow.GetCells();
// activate edit cell on City cell, instead of first cell
cells.GetNamedItem("City").ActivateEdit();
// set the CustomerID cell's text to NEWCUST,
// 2nd parameter is true indicating that the value is same as the text.
cells.GetNamedItem("CustomerID").SetText("NEWCUST", true);
cells.GetNamedItem("Address").SetText("New Address", true);

// indicates that this row's data has been changed.
newRow.SetDataChanged();
// sets the row's status as edited,
// as if user has typed inside the cell.
grid.MarkEdit();
}
IsMarkedEdit Description
Determines whether the current row has been marked edit.

Parameters
-

Remarks
-

Return Value

boolean

Samples

Determine the value of IsMarkedEdit property

function CustomFunction()
{
var grid = ISGetObject("WebGrid1");
var wgRow = grid.GetSelectedObject().GetRowElement();
alert(wgRow.IsMarkedEdit());
return true;
}
CancelChanges Description
Perform CancelChanges to any row modification

Parameters
-

Remarks
-

Return Value

void

Samples

Perform CancelChanges

function CustomFunction()
{
var grid = ISGetObject("WebGrid1");
var wgRow = grid.GetSelectedObject().GetRowElement();
wgRow.CancelChanges();

return true;
}
AcceptChanges Description
Perform AcceptChanges to any row modification

Parameters
-

Remarks
-

Return Value

void

Samples

Perform AcceptChanges

function CustomFunction()
{
var grid = ISGetObject("WebGrid1");
var wgRow = grid.GetSelectedObject().GetRowElement();

wgRow.AcceptChanges();
return true;
}
BeginEdit Description
Perform EditMode

Parameters
-

Remarks
-

Return Value

void

Samples

Perform edit

function CustomFunction()
{
var grid = ISGetObject("WebGrid1");
var wgRow = grid.GetSelectedObject().GetRowElement();
wgRow.BeginEdit();
return true;
}
SetForceNoEdit Description
Sets the current row as editable.

Parameters
v ( boolean )
true means Not Editable, false means EditAble

Remarks

The parameter decides whether the current row is editable.
Return Value
void

Samples

Configure the row as not editable

function DoRowSelect(controlId, tblName, rowIndex, rowEl)
{
var grid = ISGetObject(controlId);
var row = grid.RootTable.ToRowObject(rowEl);

if (row.Type == "NewRow")
{
var cells = row.GetCells();
cells.GetNamedItem("CustomerID").SetForceNoEdit(newRowNoEdit);
}
}
Check Description
Sets the current row as checked.

Parameters
-

Remarks
-

Return Value

void

Samples

Check the current row sample

function CheckRows()
{
// obtain grid's object
var grid = ISGetObject("WebGrid1");
// obtain WebGridRow object of 11th row
var row = grid.RootTable.GetRow(10);

for (var i=0; i<5; i++)
{
// set the row as checked
row.Check();
// obtain the previous WebGridRow object
row = row.GetPreviousRow();
}
}
Uncheck Description
Sets the current row as unchecked.

Parameters
-

Remarks
-

Return Value

void

Samples

Uncheck the current row sample.

function UnCheckRows()
{
var grid = ISGetObject("WebGrid1");
var row = grid.RootTable.GetRow(3);

for (var i=0; i<4; i++)
{
row.Uncheck();
row = row.GetNextRow();
}
}
IsSelected Description
Determines whether the current row is selected.

Parameters
-

Remarks
-

Return Value

boolean

Samples

Determines whether the current row is selected.
function DoClick()
{

var grid = ISGetObject("WebGrid1");

if (grid.GetSelectedObject() == null)
{
alert("Please select a row.");
return;
}

var row = grid.GetSelectedObject().GetRowObject();
alert(row.IsSelected());
var firstRow = grid.RootTable.GetRow(0);
alert(firstRow.IsSelected());
return true;
}
GetElement Description
Gets the HTML element from current row.

Parameters
-

Remarks
-

Return Value

object (HTML element)

Samples

Obtain the raw HTML element from current WebGridRow object.

function ObtainRow()
{
var grid = ISGetObject("WebGrid1");

if (grid.GetSelectedObject() == null)
{
alert("Please select a row.");
return;
}

var row = grid.GetSelectedObject().GetRowObject();
// WG4 standardized on the keyword GetElement
// on every objects in order to get the html element.
var rowElement = row.GetElement();

rowElement.style.height = "30px";
alert("Current selected row's Height is now 30px");
}
GetCells Description
Gets the whole WebGridCell collection of the current row.

Parameters
-

Remarks
-

Return Value
object (WebGridCell collection)

Samples

function GetCellText()
{
var grid = ISGetObject("WebGrid1");
// get selected object
var curSelObj = grid.GetSelectedObject();

if (curSelObj == null)
{
alert("No row selected. Please select a row");
}
else
{
// get the WebGridRow object
var row = curSelObj.GetRowObject();
if (row.Type == "GroupHeader")
{
alert("Currently selected row is a Group Row. There is no cell information.");
}
else if (row.Type == "Record")
{
// obtain WebGridCellCollection of the specified row.
var cells = row.GetCells();
// get the address' WebGridCell object by name.
var addressCell = cells.GetNamedItem("Address");

alert("Current selected row's Address cell has this text : " + addressCell.Text + " The cell's value is : " + (addressCell.Value == null ? "No Value" : addressCell.Value));
}
}
}
GetCell Description
Gets the WebGridCell object from a row.

Parameters
-

Remarks
-

Return Value

object (WebGridCell)

Samples

Obtain a WebGridCell object by using GetCell method

function ObtainCell()
{
var grid = ISGetObject("WebGrid1");
if (grid.GetSelectedObject() == null)
{
alert("Please select a row.");
return;
}

var row = grid.GetSelectedObject().GetRowObject();

if (row.Type == "Record")
{
var cell = row.GetCell("CompanyName");
// WG 4 standarized on the keyword GetElement
//on every objects in order to get the html element.
var cellElement = cell.GetElement();
cellElement.style.color = "green";
alert("The CompanyName cell of current selected row's ForeColor is now Green.");
}
else
alert("Please select a Record Row");
}
ExpandGroupRow Description
Expands group rows of this row.

Parameters
-

Remarks
-

Return Value

void
Samples
Expand group row

function ExpandGroupRow()
{
var grid = ISGetObject("WebGrid1");
// get the WebGridRow object instead of element.
var currentRow = grid.GetSelectedObject().GetRowObject();
// expand group row
currentRow.ExpandGroupRow();
btnExpandGR.disabled = true;
btnCollapseGR.disabled = false;
}
CollapseGroupRow Description
Collapses group rows of this row.

Parameters
-

Remarks
-

Return Value

void

Samples

Collapse group row

function CollapseGroupRow()
{
var grid = ISGetObject("WebGrid1");
// get the WebGridRow object instead of element.
var currentRow = grid.GetSelectedObject().GetRowObject();
// collapse group row
currentRow.CollapseGroupRow();
btnExpandGR.disabled = false;
btnCollapseGR.disabled = true;
}
ExpandChildRow Description
Expands child rows of this row.

Parameters
-

Remarks
-

Return Value
void

Samples

Expand child row by using ExpandChildRow method

function ExpandChild()
{
var grid = ISGetObject("WebGrid1");
var selObj = grid.GetSelectedObject();

if (selObj == null)
{
alert("Please select a row");
return;
}
else
{
var row = selObj.GetRowObject();
// demonstrate server-side alike object model hierarchy
if (row.Table.ChildTables.length > 0)
{
if (!row.ChildExpanded)
row.ExpandChildRow();
 else
alert("Row already expanded!");
}
else
alert("This row doesn't have any child rows!");
}
}
CollapseChildRow Description
Collapses child rows of type Self Reference of this row.

Parameters
-

Remarks
-

Return Value
void

Samples

Collapse child rows by using CollapseChildRow method.

function CollapseChild()
{
var grid = ISGetObject("WebGrid1");
var selObj = grid.GetSelectedObject();

if (selObj == null)
{
alert("Please select a row");
return;
}
else
{
var row = selObj.GetRowObject();
// demonstrate server-side alike object model hierarchy
if (row.Table.ChildTables.length > 0)
{
if (row.ChildExpanded)
row.CollapseChildRow();
else
alert("Row already collapsed!");
}
else
alert("This row doesn't have any child rows!");
}
}
ExpandSelfRefRow Description
Expands child rows of type Self Reference of this row.

Parameters
-

Remarks
-

Return Value
void

Samples

Expand a self reference row type.

function ExpandSelfRefRow()
{
// obtain grid's object
var grid = ISGetObject("WebGrid1");
// select the first row
var row = grid.RootTable.GetRow(0);

// only expand the first row if :
// 1) It's a SelfReference row type
// 2) It hasn't been expanded yet
if (row.IsSelfRefRow && !SelfRefExpanded)
{
row.ExpandSelfRefRow();
}
return true;
}
CollapseSelfRefRow Description
Collapses child rows of type Self Reference of this row.

Parameters

-

Remarks

-

Return Value

void

Samples

Collapse SelfRef row

function CustomFunction()
{
// obtain grid's object
var grid = ISGetObject("WebGrid1");

// select the first row
var row = grid.RootTable.GetRow(0);

// only expand the first row if :
// 1) It's a SelfReference row type
// 2) It has been expanded
if (row.IsSelfRefRow && SelfRefExpanded)
{
row.CollapseSelfRefRow();
}
return true;
}
Select Description
Selects a row.

Parameters

-

Remarks

-

Return Value

void

Samples

Select a row

function SelectNewRow()
{
var grid = ISGetObject("WebGrid1");
// return the html element of the newrow
var newRowElement = grid.RootTable.GetNewRow();
// convert to WebGridRow object
var newRow = grid.RootTable.ToRowObject(newRowElement);

// select new row
newRow.Select();

// populate cells
var cells = newRow.GetCells();
// activate edit cell on City cell,
// instead of first cell
cells.GetNamedItem("City").ActivateEdit();
// set the CustomerID cell's text to NEWCUST,
// 2nd parameter is true indicating that the value is same as the text.
cells.GetNamedItem("CustomerID").SetText("NEWCUST", true);
cells.GetNamedItem("Address").SetText("New Address", true);

// indicates that this row's data has been changed.
newRow.SetDataChanged();
// sets the row's status as edited,
// as if user has typed inside the cell.
grid.MarkEdit();
}
GetChildRow Description
Gets the child row object based on defined relations.

Parameters

-

Remarks

-

Return Value

object (WebGridRow)

Samples

Gets the child row object based on defined relations.

function ExpandAndGetChild()
{
var grid = ISGetObject("WebGrid1");
var selObj = grid.GetSelectedObject();
if (selObj == null)
{
alert("Please select a row");
return;
}
else
{
var row = selObj.GetRowObject();
// demonstrate server-side alike
// object model hierarchy
if (row.Table.ChildTables.length > 0)
{
if (!row.ChildExpanded)
{
// 1st parameter indicates using synchronous mode
row.ExpandChildRow(true);

// the advantage of sync mode is the ability
// to get child rows in same code flow
// get the Orders child rows collection
// belong to this customer
var childRows = row.GetChildRow("Orders");
var s = "";

for (var i=0; i<childRows.length; i++)
s += " OrderID: " + childRows[i].KeyValue;

alert("Customer '" + row.KeyValue + "' has " + childRows.length + " orders. The orders are:" + s);
}
else
alert("Row already expanded!");
}
else
alert("This row doesn't have any child rows!");
}
}
GetParentRow Description
Gets the parent row based on defined relations.

Parameters

-

Remarks

-

Return Value

object (WebGridRow)

Samples

Obtains the parent's WebGridRow object of current child WebGridRow object.

function GetParentRow()
{
var grid = ISGetObject("WebGrid1");
var selObj = grid.GetSelectedObject();
if (selObj == null)
{
alert("Please select a row");
return;
}
else
{
var row = selObj.GetRowObject();
if (row.Table.IsRootTable)
alert("Please select a child row");
else
{
// get the parent row of this child
var parentRow = row.GetParentRow();
alert("The parent row of this order is: " + parentRow.KeyValue);
if (confirm("Do you want to select the parent row?"))
{
// select the parent row
parentRow.Select();
}
}
}
}
GetGroupChildRows Description
Gets the GroupChildRow collection of the current row.

Parameters
-

Remarks
-

Return Value

object (GroupChildRow)

Samples

In this sample, the group child rows of the current row object can be obtained further. This sample can be seen in Programmatic_UI.aspx sample.

function GetGroupRowChilds()
{
var grid = ISGetObject("WebGrid1");
// get the WebGridRow object
// instead of element.
var currentRow = grid.GetSelectedObject().GetRowObject();
// get group child rows of
// current row object.
var groupChildRows = currentRow.GetGroupChildRows();
var s = "Current selected group row is '" + currentRow.GroupRowText + "'. The child rows contained by this group are: ";

for (var i=0; i<groupChildRows.length; i++)
{
var row = groupChildRows[i];
s += "Row " + i + ", Type=" + row.Type + ", KeyValue=" + row.KeyValue + " ";
}
alert(s);
}
GetChanges Description
Returns the changes made to this row

Parameters
rowState
Specifies the state of the changes to get.

Remarks
-

Return Value

object (WebGridRowChanges)

Samples

GetRowState Description
Returns the state of this row. It will returns Unmodified if this row has no changes.

Parameters
-

Remarks
-

Return Value

void

Samples

InvalidateRowState Description
Invalidate the state of this row to be processed in the next synchronization.

Parameters
-

Remarks
-

Return Value

void

Samples

UndoChanges Description
Undo changes made to this row

Parameters
skipUpdateStatus
Specifies whether to skip the status updating after undo.

Remarks
-

Return Value

void

Samples

AddPendingChanges Description
Mark changes made to this row and add it into pending changes collection.

Parameters
-

Remarks
-

Return Value

void

Samples

UpdatePendingChangesUI Description
Synchronize the pending changes data with Grid's user interface elements.

Parameters
isProgrammatic
Specifies whether the method is called by user code.

Remarks
-

Return Value

void

Samples

SetDeleted Description
Mark this row as deleted.

Parameters
-

Remarks
-

Return Value

void

Samples

GetGroupRowLevel Description
Gets the group row level of this row.

Parameters
-

Remarks
-

Return Value

void

Samples

HasCollapsedParent Description
Whether this row has collapsed parents.

Parameters
-

Remarks
-

Return Value

boolean

Samples

HasGroupedChilds Description
Whether this row has grouped child rows.

Parameters
-

Remarks
-

Return Value

boolean

Samples

HasExpandedChilds Description
Whether this row has expanded child rows.

Parameters
-

Remarks
-

Return Value

boolean

Samples

ExpandGroupRowsToThisRow Description
Expand all parent group rows down to this row.

Parameters
-

Remarks
-

Return Value

void

Samples

CopyTo Description
Copies this row's structure and data to destination object.

Parameters
targetObject

isModifiedOnly

followTargetStructure

Remarks
-

Return Value

void

Samples


WebGridTable

WebGridTable
Send Feedback
Intersoft WebGrid > Client-side References > WebGridTable

Glossary Item Box

WebGridTable Properties

Name | Description The WebGridTable name. ValueType string Default Value -
Grid | Description Gets the WebGrid object that owns this table. ValueType object ( WebGrid ) Default Value -
IsRootTable | Description Returns whether the object is root table. ValueType Boolean Default Value -
ParentTable | Description Returns the parent table of this object. ValueType WebGridTable Default Value -
HasChildTable | Description Returns whether the object has child tables. ValueType Boolean Default Value -
TableLevel | Description Returns the deep level of the current object from Hierarchy structure. ValueType int Default Value -
Position | Description Returns the position of the object based on the Collection that owns this object. ValueType int Default Value -
AllowAddNew | Description Specifies whether to allow user to add new rows. ValueType string Default Value -
AllowColumnSizing | Description Specifies whether to allow user to resize the columns. ValueType string Default Value -
AllowColumnMove | Description Specifies whether to allow user to move the columns. ValueType string Default Value -
AllowEdit | Description Specifies whether to allow user to edit and modify data. ValueType string Default Value -
AllowDelete | Description Specifies whether to allow user to delete data from within WebGrid. ValueType string Default Value -
AllowFilter | Description Specifies whether to allow user to filter the rows from within WebGrid. ValueType string Default Value -
AllowSelectColumns | Description Specifies whether to allow user to select columns from within WebGrid. ValueType string Default Value -
AllowSorting | Description Specifies whether to allow user to sort the columns from within WebGrid. ValueType string Default Value -
AllowGrouping | Description Specifies whether to allow user to group columns from within WebGrid. ValueType string Default Value -
AutomaticSort | Description Specifies whether to allow WebGrid to automatically handle sorting operation. ValueType boolean Default Value -
AutomaticFilter | Description Specifies whether to allow WebGrid to automatically handle filtering operation. ValueType boolean Default Value -
CellClickAction | Description Specifies the action when a user clicks on a cell. ValueType string Default Value -
ColumnHeaders | Description Specifies whether to display column headers. ValueType string Default Value -
ColumnFooters | Description Specifies whether to display column footers. ValueType string Default Value -
ColumnWidthDefault | Description Specifies the default column width in Unit. ValueType integer Default Value -
HeaderClickAction | Description Specifies the action when a user clicks on a column header. ValueType string Default Value -
GroupRowInfoFormatDefault | Description Gets or sets the default group row's format string. ValueType string Default Value -
RowHeaders | Description Specifies whether to display row headers. ValueType string Default Value -
FocusCellStyle | Description Gets or sets the style used when a row or cell is focused/selected. ValueType object (FocusStyle) Default Value -
Caption | Description Gets or sets the text displayed in the table header. ValueType string Default Value -
DataKeyField | Description Gets or sets the key field in the data source specified by the DataSource property and DataMember specified in the WebGridTable object. ValueType string Default Value -
DataMember | Description Gets or sets the name of data source for which the table displays its data. ValueType string Default Value -
NewRowInfoText | Description Gets or sets the text that will be displayed in the NewRow when it is not in focus. ValueType string Default Value -
GroupMode | Description Gets or sets a value that indicates whether groups should be collapsed or expanded when groups are calculated. ValueType string Default Value -
RowStyle | Description Gets or sets the style applied to the row. ValueType string Default Value -
SelectedRowStyle | Description Gets or sets the style applied to the selected row. ValueType string Default Value -
HideColumnsWhenGrouped | Description Specifies whether the column headers of grouped columns is hidden. ValueType string Default Value -
NewRowStyle | Description The style applied to new row. ValueType string Default Value -
ChildTables | Description Gets the collection of child WebGridTable object. ValueType object (WebGridTable) Default Value -
Layout | Description Gets the LayoutSet object to which the object belongs. ValueType object (LayoutSet) Default Value -
Columns | Description Gets the collection of the WebGridColumn objects. ValueType object (WebGridColumn) Default Value -
Rows | Description Gets the collection of WebGridRow objects. ValueType object Default Value -
TableHeaderVisible | Description Determines whether to display table headers. ValueType boolean Default Value -
GroupTotalVisible | Description Determines whether total row for each GroupRow should be shown. ValueType boolean Default Value -
GroupedColumns | Description Gets the collection of WebGridGroup objects. ValueType object (WebGridGroup) Default Value -
SortedColumns | Description Gets the collection of WebGridGroup objects. ValueType object (WebGridGroup) Default Value -
FilteredColumns | Description Gets the collection of WebGridFilter objects. ValueType object (WebGridFilter) Default Value -
RowLayout | Description Specifies the row's rendering layout mode. ValueType string Default Value -
PreviewRowSettings | Description Specifies the PreviewRow settings. ValueType object (PreviewRowSettings) Default Value -
PreviewRowVisible | Description Set the visibility of the PreviewRow. ValueType boolean Default Value -
ColumnSets | Description Gets the collection of ColumnSet. ValueType object (ColumnSets) Default Value -
ColumnSetSettings | Description Specifies the ColumnSet settings. ValueType object (ColumnSetSettings) Default Value -
SelfReferencingSettings | Description Specifies the SelfReferencing settings. ValueType object (SelfReferencingSettings) Default Value -
IsUseColumnSet | Description Determines whether this table is valid to use ColumnSet for rendering the row layout. ValueType boolean Default Value -
HasMultiPrimaryKey | Description Determines whether this table has multiple primary keys. ValueType boolean Default Value -
DataKeyFields | Description Gets the DataKeyField collection. ValueType string Default Value -
DataKeyFieldsCount | Description Gets the number of the DataKeyFields. ValueType integer Default Value -
Id | Description Gets the WebGridTable ID. ValueType string Default Value -
SubTableIds | Description Gets the WebGridTable SubTable ID. ValueType object Default Value -
Formulas | Description Gets the WebGridTable formula. ValueType object (WebGridFormula Collection) Default Value -
GridId | Description Gets the WebGridTable grid ID. ValueType string Default Value -
UniqueConstraints | Description Gets the WebGridTable UniqueConstraints. ValueType string Default Value -

WebGridTable Methods

GetParentTables Description
Returns the XML Object of the table which is parent of this table.

Parameters
-

Remarks
-

Return Value
object (WebGridTable)

Samples
Obtains the parent table.

function DoGetParentTables()
{
var grid = ISGetObject("WebGrid1");
var childTbl = grid.Tables["Orders"];
alert(childTbl.GetParentTables());
return true;
}
GetChildTables Description
Returns the IXMLNodeList for available child tables of this table.

Parameters
-

Remarks
-

Return Value
object (WebGridTable)

Samples

Get the child table

function DoGetChildTables()
{
var grid = ISGetObject("WebGrid1");
var rootTbl = grid.RootTable;
alert(rootTbl.GetChildTables());
return true;
}
GetNewRow Description
Retrieves the HTML row element of the new row for the specified table.

Parameters
row ( HTML RowElement )
The HTML RowElement (optional)

Remarks
-

Return Value
object (TR row element)

Samples

Obtain New Row object

function SelectNewRow()
{
var grid = ISGetObject("WebGrid1");
// return the html element of the NewRow
var newRowElement = grid.RootTable.GetNewRow();
// convert to WebGridRow object
var newRow = grid.RootTable.ToRowObject(newRowElement);

// select new row
newRow.Select();

// populate cells
var cells = newRow.GetCells();
// activate edit cell on City cell, instead of first cell
cells.GetNamedItem("City").ActivateEdit();
// set the CustomerID cell's text to NEWCUST,
// 2nd parameter is true indicating that the value is same as the text.
cells.GetNamedItem("CustomerID").SetText("NEWCUST", true);
cells.GetNamedItem("Address").SetText("New Address", true);

// indicates that this row's data has been changed.
newRow.SetDataChanged();
// sets the row's status as edited,
// as if user has typed inside the cell.
grid.MarkEdit();
}
GetSubTablePosById Description
Gets the current SubTable position.

Parameters
id ( string )
WebGridSubTable SubId

Remarks
-

Return Value
integer

Samples

Gets SubTable position

function DoRowSelect(gridId, tblName, rowIdx, rowElm)
{
var grid = ISGetObject(gridId);
if(tblName == "Orders")
{
var subTblColl = grid.Tables[tblName].SubTableIds;
var firstSubTbl = subTblColl[0];
var parentRowKeyValue = ISGetObject("WebGrid1").GetSelectedObject().GetRowObject().GetParentRow().KeyValue;
alert( grid.Tables[tblName].GetSubTablePosById(firstSubTbl.SubId));
alert( grid.Tables[tblName].GetSubTableById(firstSubTbl.SubId).Id);
alert(ISGetObject("WebGrid1").Tables["Orders"].GetSubIdByParentKey(parentRowKeyValue));

}
return true;
}
GetContainer Description
Gets the container object for the child table referred by specified row object.

Parameters
tr ( HTML row element )
The HTML RowElement

Remarks
-

Return Value
object (TableContainer)

Samples

Get Container

function DoRowSelect(gridId, tblName, rowIdx, rowElm)
{
var grid = ISGetObject("WebGrid1");
alert(grid.Tables[tblName].GetContainer(rowElm));
return true;
}
SelectRow Description
Selects and highlights the specified row index.

Parameters
pos ( integer )
the row index position

Remarks

-

Return Value
void

Samples

Select a row

function DoSelectRow()
{
var grid = ISGetObject("WebGrid1");
grid.RootTable.SelectRow(1);

return true;
}
GetSelRowStyle Description
Returns the style used when the row is selected.

Parameters
-

Remarks
-

Return Value
string

Samples

Get the SelectedRow style

function DoGetSelRowStyle()
{
var grid = ISGetObject("WebGrid1");
alert(grid.RootTable.GetSelRowStyle());

return true;
}
GetFocusCellStyle Description
Returns the style of the focus cell.

Parameters
-

Remarks
-

Return Value
string

Samples
Obtain FocusCell style

function DoGetFocusCellStyle()
{
var grid = ISGetObject("WebGrid1");
alert(grid.RootTable.GetFocusCellStyle());

return true;
}
GetCheckedRowStyle Description
Returns the checked row style for this table.

Parameters
-

Remarks
-

Return Value
string

Samples

Obtain the checked RowStyle

function DoGetCheckedRowStyle()
{
var grid = ISGetObject("WebGrid1");
alert(grid.RootTable.GetCheckedRowStyle());

return true;
}
GetColumn Description
Returns the IXMLNodeList of available columns of this table.

Parameters
s ( string )
The Column's name

Remarks
-

Return Value
object (WebGridColumn)

Samples

Get CustomerID column.

function DoRowSelect(gridId, tblName, rowIdx, rowElm)
{
var grid = ISGetObject("WebGrid1");
alert(grid.Tables[tblName].GetColumn("CustomerID");
return true;
}
IsFilterRowVisible Description
Determines whether the filter row is visible.

Parameters
-

Remarks
-

Return Value
boolean

Samples

Determine whether the filter row is visible or not.

function GetFilterRowVisibility()
{
var grid = ISGetObject("WebGrid1");
alert(grid.RootTable.IsFilterRowVisible());
return true;
}
GetFilterEditType Description
Gets the filter edit type of specific column.

Parameters
cn ( string )
the Column's Name

Remarks
-

Return Value
string

Samples

Get FilterEditType

function DoRowSelect(gridId, tblName, rowIdx, rowElm)
{
var grid = ISGetObject("WebGrid1");
alert(grid.Tables[tblName].GetFilterEditType("CustomerID"));
return true;
}
GetRowCheckerColumn Description
Gets the column's name of the column which has been configured as RowChecker column.

Parameters
-

Remarks
-

Return Value
string

Samples

Get the column's name of the column which has been configured as RowChecker column.

function DoGetRowCheckerColumn()
{
var grid = ISGetObject("WebGrid1");

alert(grid.RootTable.GetRowCheckerColumn());

return true;
}
GetCheckedRows Description
Returns the checked rows for this table.

Parameters
-

Remarks
-

Return Value

object ( HTML RowElement Collection)

Samples

Get the KeyValue of the checked rows.

function DoGetCheckedRows()
{
var grid = ISGetObject("WebGrid1");
alert(grid.RootTable.GetCheckedRows);
var numOfCheckedRows = grid.RootTable.GetCheckedRows.length;
for(int i=0; i<numOfCheckedRows; i++)
{
var htmlRow = grid.RootTable.GetCheckedRows()[i];
var wgRowObject = grid.RootTable.ToRowObject(htmlRow);
alert(wgRowObject.KeyValue);
}

return true;
}
GetAutoWidthColumn Description
Gets the column name which has been set to AutoWidth.

Parameters
-

Remarks
-

Return Value

string

Samples

Get the column name which has been configured with AutoWidth.

function DoGetAutoWidthColumn()
{
var grid = ISGetObject("WebGrid1");
alert(grid.RootTable.GetAutoWidthColumn().Name);

return true;
}
GetSubTableById Description
Gets the WebGridSubTable object.

Parameters
id ( string )
The SubTable ID looks like: "tb_WebGrid1_Orders_1_0__1".

Remarks
-

Return Value

object (WebGridSubTable)

Samples

Gets SubTable.

function DoRowSelect(gridId, tblName, rowIdx, rowElm)
{
var grid = ISGetObject(gridId);
if(tblName == "Orders")
{
var subTblColl = grid.Tables[tblName].SubTableIds;
var firstSubTbl = subTblColl[0];
var parentRowKeyValue = ISGetObject("WebGrid1").GetSelectedObject().GetRowObject().GetParentRow().KeyValue;
alert( grid.Tables[tblName].GetSubTablePosById(firstSubTbl.SubId));
alert( grid.Tables[tblName].GetSubTableById(firstSubTbl.SubId).Id);
alert(ISGetObject("WebGrid1").Tables["Orders"].GetSubIdByParentKey(parentRowKeyValue));

}
return true;
}
GetRowLayoutByColName Description
Gets the WebGridRowLayout object by given column's name.

Parameters
name ( string )
The ColumnMember name of the WebGridRowLayout.

Remarks
-

Return Value
object (WebGridRowLayout)

Samples

Gets the FirstName RowLayout object.

function GetRowLayoutByColName()
{
var grid = ISGetObject("WebGrid1");
var rl = grid.RootTable.GetRowLayoutByColName("FirstName");
alert(rl.ColumnMember);

return true;
}
GetRowLayoutByIndex Description
Gets the WebGridRowLayout object from certain row and column.

Parameters
pos ( integer )
The RowLayout index
r ( integer )
The Row Index
c ( integer )
The Col Index

Remarks

-
Return Value
object (WebGridRowLayout)

Samples
Gets the column member from the RowLayout.

function GetColumnSetColumnMember()
{
var grid = ISGetObject("WebGrid1");
var rl = grid.RootTable.GetRowLayoutByIndex(0,1,2);
alert(rl.ColumnMember);

return true;
}
GetColumnSetByPos Description
Obtains the ColumnSet object of the WebGridTable.

Parameters
pos ( integer )
The index of the ColumnSet

Remarks
-

Return Value
object (WebGridColumnSet)

Samples

Get ColumnSet name

function GetColumnSetName()
{
var grid = ISGetObject("WebGrid1");
var cs = grid.RootTable.GetColumnSetByPos(0);
alert(cs.Caption);

return true;
}
GetParentRow Description
Gets the parent row HTML row element.

Parameters
tr ( object - HTML RowElement )
The HTML RowElement object of the child table's row

Remarks
-

Return Value
object (HTML RowElement)

Samples

Gets the parent row key value

function DoRowSelect(controlId, tblName, rowIndex, rowEl)
{
// use these codes
// only on child table

var grid = ISGetObject(controlId);
var parentRowElm = grid.Tables[tblName].GetParentRow(rowEl);
if(parentRowElm)
{
var keyValue = grid.RootTable.ToRowObject(parentRowElm).KeyValue;
alert(keyValue);
}
}
CreateFormula Description
Creates a formula in order to calculate the value of a cell.

Parameters
colName ( string )
The column's name which will be calculated based on the given formula
formula ( string )
The formula's definition

Remarks
-

Return Value
void

Samples

Create formula for SubTotal cell of OrderDetails table.

function InitializeGrid(gridId) {
var tb = wgGetGridById(gridId).Tables["Orderx0020xDetails"];
// create formula for SubTotal cell of Order Details table.
tb.CreateFormula("SubTotal", "[Quantity] * ([UnitPrice] - ([UnitPrice] * [Discount]) )");
}
Refresh Description
Performs refresh on the particular table only, without refreshing the whole tables (root table and child tables).

Parameters
-

Remarks
-

Return Value
void

Samples

Perform refresh on the particular table

function refreshChild() {
var grid = wgGetGridById("WebGrid1");
grid.Tables["Orders"].Refresh();
}
GetDataKeyFieldsCount Description
Gets the number of DataKeyField.

Parameters
-

Remarks
-

Return Value
integer

Samples

Get the number of DataKeyFields

function DoRowSelect(gridId, tblName, rowIdx, rowElm)
{
var grid = ISGetObject("WebGrid1");
alert(grid.Tables[tblName].GetDataKeyFieldsCount());
return true;
}
GetTableElementRowsCount Description
Gets the TableElement rows number.

Parameters
rowEl ( HTML RowElement )
The HTML RowElement

Remarks
-

Return Value
integer

Samples

Get Table Element Rows Count

function DoRowSelect(gridId, tblName, rowIdx, rowElm)
{
var grid = ISGetObject("WebGrid1");
alert(grid.Tables[tblName].GetTableElementRowsCount(rowElm));
return true;
}
GetRowsCount Description
Gets the number of row.

Parameters
-

Remarks
-

Return Value
integer

Samples

Obtain the number of rows

function DoGetRowsCount()
{
var grid = ISGetObject("WebGrid1");
var row = grid.RootTable.GetRowsCount();

return true;
}
ToRowObject Description
Converts the supplied HTML row element to WebGridRow object.

Parameters
row ( HTML Row Element )
The HTML RowElement

Remarks
-

Return Value
object (WebGridRow)

Samples

Convert to WebGridRow object sample

function SelectNewRow()
{
var grid = ISGetObject("WebGrid1");
// return the html element of the newrow
var newRowElement = grid.RootTable.GetNewRow();
// convert to WebGridRow object
var newRow = grid.RootTable.ToRowObject(newRowElement);

// select new row
newRow.Select();

// populate cells
var cells = newRow.GetCells();
// activate edit cell on City cell, instead of first cell
cells.GetNamedItem("City").ActivateEdit();
// set the CustomerID cell's text to NEWCUST,
// 2nd parameter is true indicating that the value is same as the text.
cells.GetNamedItem("CustomerID").SetText("NEWCUST", true);
cells.GetNamedItem("Address").SetText("New Address", true);

// indicates that this row's data has been changed.
newRow.SetDataChanged();
// sets the row's status as edited,
// as if user has typed inside the cell.
grid.MarkEdit();
}
GetRow Description
Obtains a WebGridRow object.

Parameters
pos ( integer )
the row index

Remarks
-

Return Value
object (WebGridRow)

Samples

Obtain a WebGridRow object

function DoGetRow()
{
var grid = ISGetObject("WebGrid1");
var row = grid.RootTable.GetRow(0);

return true;
}
GetRowByKeyValue Description
Gets a WebGridRow object by a KeyValue.

Parameters
kv ( string )
The key value of the intended row

Remarks
-

Return Value
object (WebGridRow)

Samples

Gets a WebGridRow object by a KeyValue

function DeleteRow()
{
var grid = ISGetObject("WebGrid1");
// get WebGridRow object by key value.
var row = grid.RootTable.GetRowByKeyValue("VINET");
// select this row for focus
row.Select();
alert("Click OK to delete this row.");
// delete this row
row.Delete();
alert("Customer 'VINET' has been deleted!");
}
GetRowByGroup Description
Gets group row at intended position which is located in certain group index.

Parameters
groupIdx ( integer )
The group index. A table could be grouped with more than one GroupColumn
groupPos ( integer )
The group row index position

Remarks
-

Return Value
object (WebGridRow)

Samples

Get group row at position 0 which group index is 0.

function SelectFirstRow()
{
var grid = ISGetObject("WebGrid1");
// access WebGridRow object at position 0
// (GetRow excluding GroupRows)
var row = grid.RootTable.GetRow(0);
if (grid.RootTable.GroupedColumns.length > 0)
{
// make sure first group is expanded
// get group row at position 0 which group index is 0.
var firstGroupRow= grid.RootTable.GetRowByGroup(0, 0);
if (!firstGroupRow.GroupExpanded)
firstGroupRow.ExpandGroupRow();
}

// select the row
row.Select();
}
GetSubIdByParentKey Description
Gets WebGridSubTable ID.

Parameters
relNames ( Xml )
The parent row key value

Remarks

the relNames parameter can be obtained from the grid.Tables[tblName].ToRowObject(rowElm).GetParentRow().RelNames

Return Value

integer

Samples

Gets SubTable Id

function DoRowSelect(gridId, tblName, rowIdx, rowElm)
{
var grid = ISGetObject(gridId);
if(tblName == "Orders")
{
var subTblColl = grid.Tables[tblName].SubTableIds;
var firstSubTbl = subTblColl[0];
var parentRowKeyValue = ISGetObject("WebGrid1").GetSelectedObject().GetRowObject().GetParentRow().KeyValue;
alert( grid.Tables[tblName].GetSubTablePosById(firstSubTbl.SubId));
alert( grid.Tables[tblName].GetSubTableById(firstSubTbl.SubId).Id);
alert(ISGetObject("WebGrid1"). Tables["Orders"].GetSubIdByParentKey(parentRowKeyValue));
var parentRowKeyValue = grid.Tables[tblName].ToRowObject(rowElm).GetParentRow().RelNames;

alert(grid. Tables[tblName].GetSubIdByParentKey(parentRowKeyValue));
}
return true;
}
NewRow Description
Gets the NewRow element.

Parameters
subTable ( string )
The subTable name

Remarks
-

Return Value
HTML row element

Samples

GetSelfRefParent Description
Gets SelReference parent HTML row element.

Parameters
tr ( HTML row element )
The HTML row element

Remarks
-

Return Value
HTML row element
Samples
GetGroupRows Description
Obtains the collection of the GroupRows.

Parameters
-

Remarks
-

Return Value
object (GroupRowsCollection)

Samples

Obtain the collection of the GroupRows

function GetRootGroupRows()
{
var grid = ISGetObject("WebGrid1");
// get group rows available in root table.
var groupRows = grid.RootTable.GetGroupRows();
var s = "Root Table has " + groupRows.length + " group rows. The group rows are: ";

for(var i=0; i<groupRows.length; i++)
{
var groupRow = groupRows[i];
// get the group row's text
s += groupRow.GroupRowText + " ";
}

alert(s);
}
UpdateUI Description
Updates user interface to reflect changes.

Parameters
-

Remarks
-

Return Value
void

Samples

Update user interface to reflect changes.

function AddFilter()
{
var grid = ISGetObject("WebGrid1");

// construct WebGridFilter object
var newFilter = new WebGridFilter();
// assign properties the same way as in server side
newFilter.ColumnMember = "ContactTitle";
// use the same enumeration as in server side
newFilter.FilterType = "EqualTo";
newFilter.FilterText = "Owner";

// add new filter column the same way as in server side
grid.RootTable.FilteredColumns.Add(newFilter);

// update User Interface to reflect changes
grid.RootTable.UpdateUI();

// perform refresh to get the filter applied
grid.Refresh();
alert("ContactTitle Column is now filtered!");
}
GetChanges Description
Returns a list of pending changes that existed in this table.

Parameters
rowState
Specifies the state of the changes to get.

Remarks
-

Return Value
object (WebGridRow object)

Samples

GetChangesCount Description
Returns the count of the pending changes in this table)

Parameters
-

Remarks
-

Return Value
int

Samples

UndoChanges Description
Undo all pending changes in this table

Parameters
-

Remarks
-

Return Value
void

Samples

InvalidateChanges Description
Invalidate all pending changes in this table.

Parameters
-

Remarks
-

Return Value
void

Samples

GetUngroupedRows Description
Gets ungrouped rows collection of this table.

Parameters
-

Remarks
-

Return Value
void

Samples

GetRowByKeyValues Description
Gets the WebGridRow based on the specified key values.

Parameters
keyValues

Remarks
-

Return Value
void

Samples

DispatchDataTable Description
Gets the CDOF data table object.

Parameters
-

Remarks
-

Return Value
void

Samples

GetView Description
Gets the CDOF data view object.

Parameters
-

Remarks
-

Return Value
void

Samples

DataBind Description
Perform data binding for this table.

Parameters
-

Remarks
-

Return Value
void

Samples

FillDataSourceArguments Description
Populate view state into data source arguments used for data retrieval operation.

Parameters
arguments

sortState

filterState

pagingState

Remarks
-

Return Value
void

Samples

GetSortExpression Description
Gets the sort expression required to construct the view for this table.

Parameters
-

Remarks
-

Return Value
void

Samples

GetFilterExpression Description
Gets the filter expression required to construct the view for this table.

Parameters
-

Remarks
-

Return Value
void

Samples

Render Description
Render the view for this table.

Parameters
subTable

Remarks
-

Return Value
void

Samples

UpdateDataStatus Description
Updates the status of current datasource to UI.

Parameters
-

Remarks
-

Return Value
void

Samples


WebGridTextItem

WebGridTextItem
Send Feedback
Intersoft WebGrid > Client-side References > WebGridTextItem

Glossary Item Box

WebGridTextItem Properties

Name | Description The name of the WebGridTextItem object. ValueType string Default Value -
TextItem | Description The value of the TextItem property. ValueType string Default Value -
TextValue | Description The value of the TextValue property. ValueType string Default Value -


WebGridTextSettings

WebGridTextSettings
Send Feedback
Intersoft WebGrid > Client-side References > WebGridTextSettings

Glossary Item Box

WebGridTextSettings Properties

LocalizationFolder | Description Gets the folder path where the localization files are located. ValueType string Default Value "/CommonLibrary/WebGrid/[WebGrid Version]/Localization/"
Language | Description Returns the language mode for the language settings. ValueType string Default Value "UseDefault"
UseLanguage | Description This property will be filled automatically after we set the language for the grid in WebGrid.NET Designer. ValueType string Default Value ""
TextItems | Description Returns the WebGridTextItem collection of the grid. ValueType object (WebGridTextItem) Default Value -


WebGridSubTables

WebGridSubTables
Send Feedback
Intersoft WebGrid > Client-side References > WebGridSubTables

Glossary Item Box

WebGridSubTables Properties

SubId | Description Gets the SubID part of the SubTable. ValueType string Default Value -
TblName | Description Gets the table name that owns this SubTable. ValueType string Default Value -
GridId | Description Gets the grid ID that owns this SubTable. ValueType string Default Value -
Id | Description Gets the ID of the WebGrid SubTable. ValueType string Default Value -
ParentPos | Description Gets the parent row position of the SubTable. ValueType integer Default Value -
Position | Description Gets the row position of this SubTable. ValueType integer Default Value -
UniqueConstraints | Description Gets the list of unique constraints available in this Table. If the constraints are more than one, it will be separated with ; character. ValueType string Default Value -
RelNames | Description Gets the key pair of the unique constraints' column names and its value in XML format. ValueType string Default Value -
PositionUpdated | Description Gets the updated position of the SubTable. ValueType integer Default Value -
Width | Description Gets the width of the SubTable. ValueType integer Default Value -

WebGridSubTables Methods
GetContainer Description
Gets the HTML element that is the container of this SubTable.

Parameters

-

Remarks

-

Return Value
object (HTML Div Element)

Samples
Get SubTable Container

function DoRowSelect(gridId, tblName, rowIdx, rowElm)
{
var grid = ISGetObject(gridId);
if (tblName == "Orders")
{
var subTblColl = grid.Tables[tblName].SubTableIds;
var firstSubTbl = subTblColl[0];
alert(firstSubTbl.GetContainer().tagName);
}

return true;
}
GetElement Description
Gets the HTML element of this SubTable.

Parameters
gridPart ( constant )
The WG40 Grid Part

htmlPart ( constant )

The WG40 HTML Part

Remarks

-

Return Value
object (HTML Element)

Samples
Get Table HTML Element

function DoRowSelect(gridId, tblName, rowIdx, rowElm)
{
var grid = ISGetObject(gridId);
if (tblName == "Orders")
{
var subTblColl = grid.Tables[tblName].SubTableIds;
var firstSubTbl = subTblColl[0];
alert(firstSubTbl.GetElement(WG40.BODY,
WG40.HTML).innerText);
}

return true;
}
GetParentRow Description
Gets the parent row element that owns this table based on specified row.

Parameters

-

Remarks

Returns HTML RowElement for 'hidden hierarchical container row'.

Return Value
object (HTML RowElement)

Samples
Get parent row HTML Element

function DoRowSelect(gridId, tblName, rowIdx, rowElm)
{
var grid = ISGetObject(gridId);
if (tblName == "Orders")
{
var subTblColl = grid.Tables[tblName].SubTableIds;
var firstSubTbl = subTblColl[0];
alert(firstSubTbl.GetParentRow().innerText);
}

return true;
}
GetParentRecordRow Description
Gets the parent record row element that owns this SubTable.

Parameters

-

Remarks

-

Return Value
object (WebGridRow)

Samples
Gets parent record row

function DoRowSelect(gridId, tblName, rowIdx, rowElm)
{
var grid = ISGetObject(gridId);
if (tblName == "Orders")
{
var subTblColl = grid.Tables[tblName].SubTableIds;
var firstSubTbl = subTblColl[0];
alert(firstSubTbl.GetParentRecordRow().innerText);
}

return true;
}
GetFooterCellByName Description
Gets the footer cell element of this SubTable.

Parameters
name ( string )
The column name

Remarks

-

Return Value
object (row element)

Samples
Get footer cell

function DoRowSelect(gridId, tblName, rowIdx, rowElm)
{
var grid = ISGetObject(gridId);
if (tblName == "Orders")
{
var subTblColl = grid.Tables[tblName].SubTableIds;
var firstSubTbl = subTblColl[0];
alert(firstSubTbl.GetFooterCellByName("CustomerID"));
}
return true;
}
GetRow Description
Gets the row of this SubTable.

Parameters
pos ( integer )
The row index

Remarks

-

Return Value
object (WebGridRow)

Samples
Get row by index

function DoRowSelect(gridId, tblName, rowIdx, rowElm)
{
var grid = ISGetObject(gridId);
if (tblName == "Orders")
{
var subTblColl = grid.Tables[tblName].SubTableIds;
var firstSubTbl = subTblColl[0];
alert(firstSubTbl.GetRow(0).KeyValue);
}
return true;
}
GetRowByKeyValue Description
Gets the row of this SubTable by providing Key Value.

Parameters
kv ( string )
The key value of the record

Remarks

-

Return Value
object (WebGridRow)

Samples
Gets the row by keyValue

function DoRowSelect(gridId, tblName, rowIdx, rowElm)
{
var grid = ISGetObject(gridId);
if (tblName == "Orders")
{
var subTblColl = grid.Tables[tblName].SubTableIds;
var firstSubTbl = subTblColl[0];
alert(firstSubTbl.GetRowByKeyValue("10355"));
}

return true;
}
SelectRow Description
Selects and highlights the specified row index.

Parameters
pos ( integer )
The row index

Remarks

-

Return Value
void

Samples
Select the first row

function DoRowSelect(gridId, tblName, rowIdx, rowElm)
{
var grid = ISGetObject(gridId);
if (tblName == "Orders")
{
var subTblColl = grid.Tables[tblName].SubTableIds;
var firstSubTbl = subTblColl[0];
firstSubTbl.SelectRow(1);
}
return true;
}
GetRowsCount Description
Gets the number of rows in this SubTable.

Parameters

-

Remarks

-

Return Value
integer

Samples
Gets the number of rows

function DoRowSelect(gridId, tblName, rowIdx, rowElm)
{
var grid = ISGetObject(gridId);
if (tblName == "Orders")
{
var subTblColl = grid.Tables[tblName].SubTableIds;
var firstSubTbl = subTblColl[0];
alert(firstSubTbl.GetRowsCount());
}
return true;
}
GetConstraintXml Description
Gets the XML Constraint of this SubTable

Parameters

-

Remarks

-

Return Value
object (xml)

Samples
Gets ConstraintXml text

function DoRowSelect(gridId, tblName, rowIdx, rowElm)
{
var grid = ISGetObject(gridId);
if (tblName == "Orders")
{
var subTblColl = grid.Tables[tblName].SubTableIds;
var firstSubTbl = subTblColl[0];
alert(firstSubTbl.GetConstraintXml().text);
}

return true;
}
GetTable Description
Gets the WebGridTable object

Parameters

-

Remarks

-

Return Value
object (WebGridTable)

Samples
Gets the table's name

function DoRowSelect(gridId, tblName, rowIdx, rowElm)
{
var grid = ISGetObject(gridId);
if (tblName == "Orders")
{
var subTblColl = grid.Tables[tblName].SubTableIds;
var firstSubTbl = subTblColl[0];
alert(firstSubTbl.GetTable().Name);
}

return true;
}
GetGrid Description
Gets the WebGrid object

Parameters

-

Remarks

-

Return Value
object (WebGrid)

Samples
Gets the WebGrid version

function DoRowSelect(gridId, tblName, rowIdx, rowElm)
{
var grid = ISGetObject(gridId);
if (tblName == "Orders")
{
var subTblColl = grid.Tables[tblName].SubTableIds;
var firstSubTbl = subTblColl[0];
alert(firstSubTbl.GetGrid().Version);
}

return true;
}


WebGridActiveCell

WebGridActiveCell
Send Feedback
Intersoft WebGrid > Client-side References > WebGridActiveCell

Glossary Item Box

WebGridActiveCell Properties

element | Description Returns the cell element of the active edit cell. ValueType object (cell element) Default Value -
tblName | Description Returns the table name of active edit cell. ValueType string Default Value -
gridId | Description Returns the ID of the WebGrid. ValueType string Default Value -
cellIndex | Description Returns the index of the active edit cell. ValueType integer Default Value -
rowElement | Description Returns the row element of the active edit cell. ValueType object (row element) Default Value -
rowChanged | Description Returns the flag that determines whether or not the row has changed. ValueType boolean Default Value -

WebGridActiveCell Methods
GetColSetRowElement Description
Gets the first/root row element of ColumnSet rows.

Parameters

-

Remarks

-

Return Value

object (row element)

Samples
This sample shows how to get the row element of the specified active cell.

function doEnterEditMode(gridId,tblName,editObject)
{
//get the grid object
var grid=ISGetObject(gridId);
//get the active cell
var activeCell = grid.GetActiveEditCell();
//get the row element
var row = activeCell.GetColSetRowElement();
return true;
}
GetColSetRowsElement Description
Gets the ColumnSet rows of active cell.

Parameters

-

Remarks

-

Return Value

array (row element collection)

Samples
This sample shows how to get the ColumnSet row elements of the specified active cell.

function doEnterEditMode(gridId,tblName,editObject)
{
//get the grid object
var grid=ISGetObject(gridId);
//get the active cell
var activeCell = grid.GetActiveEditCell();
//get the columnset row element
var csRows = activeCell.GetColSetRowsElement();
return true;
}


WebGridEditObject

WebGridEditObject
Send Feedback
Intersoft WebGrid > Client-side References > WebGridEditObject

Glossary Item Box

WebGridEditObject Properties

element | Description Returns the HTML element of the edit object. ValueType object ( EditObject element ) Default Value -
type | Description Returns the type of the edit object. ValueType string Default Value -
gridId | Description Returns the ID of the WebGrid. ValueType string Default Value -
tblName | Description Returns the table name of active edit cell. ValueType string Default Value -
cellElement | Description Returns the cell element that own this edit object. ValueType object (cell element) Default Value -


SelectedObject

SelectedObject
Send Feedback
Intersoft WebGrid > Client-side References > SelectedObject

Glossary Item Box

SelectedObject Properties

tblName | Description Returns the table name of the selected object. ValueType string Default Value -
gridId | Description Gets the ID of the WebGrid. ValueType string Default Value -
element | Description Returns the HTML element of the selected object. This method will return a TR object if selection mode is set to Row. Otherwise it will return TD object. ValueType object (HTML element) Default Value -
rowIndex | Description Returns the index of the selected row. ValueType integer Default Value -
cellIndex | Description Returns the index of the selected cell. Only available when selection mode is Cell. ValueType integer Default Value -
type | Description Returns the type of the selected object. Valid type is either Row or Cell. ValueType string Default Value -

SelectedObject Methods
GetRowElement Description
Gets the row HTML element of the selected object.

Parameters

Remarks
readonly

Return Value
object

Samples
The sample shows how to access GetRowElement using selected object.

//get grid object
var grid = ISGetObject("WebGrid1");

// get grid get row element using GetSelectedObject.
var rowElm = grid.GetSelectedObject().GetRowElement();
GetRowObject Description
Gets the row object of the selected object.

Parameters

Remarks
readonly

Return Value
object

Samples
The sample shows how to get row object using selected object.
//get grid object
var grid = ISGetObject("WebGrid1");

//get row object of the grid
var rowObj = grid.GetSelectedObject().GetRowObject();
GetColSetRowElement Description
Gets the root/first row of column set rows.

Parameters

Remarks
readonly

Return Value
object
GetColSetRowsElement Description
Gets the columnset rows of selected row.

Parameters

Remarks
readonly

Return Value
array


Mozilla Browser

Mozilla Browser
See Also Send Feedback

Glossary Item Box

Following are known issues when displaying WebGrid.NET in Mozilla-based browsers.

These issues have been clarified as BUGS in Mozilla and have been submitted through BugZilla website. These issues are clarified as BUGS until the time of the release on April 2005. The issues are:

  • Hierarchical treelines always disappear (will show up when a cell is clicked).
  • Height in childtables sometimes corrupted (will be corrected when a cell is clicked).
  • Caret disappears in textbox.
  • AutoFitColumns still shows the horizontal scrollbar, reason: the 'overflow-x' style is not supported.

The following issues have been clarified as BUGS in WebGrid and have been submitted to the developer team to be fixed.

  • HTML editor button cannot be clicked in Mozilla.
  • When using WebGrid with Pivot Chart, the WebGrid is not resized while the browser is resized in Mozilla.

All other challenges and issues in Mozilla such as box-sizing, flickering, focus, key navigations, and dozens more, have been fully taken care and supported by this release with the new invention of IEMozBridge architecture.

FireFox 1.0.3 and Mozilla 1.7.7 Notes

Due to a major bug in FireFox 1.0.3 and Mozilla 1.7.7 engine, WebGrid.NET Enterprise could not be rendered properly and could cause invalid behaviors to all user-interactive features.

If you're using the version mentioned above, please update your browser's version to FireFox 1.0.4 and Mozilla 1.7.8 which have the bug fixed.

See Also

Overview
Getting Started
WebGrid Features Overview

Other Resources
Walkthrough Topics
How-to Topics


WebGrid Core

WebGrid Core
See Also Send Feedback
Intersoft WebGrid > Client-side References > WebGrid Core

Glossary Item Box

WebGrid Core Global Functions
wgGetActiveGrid Description
Gets the currently active grid.

Return Value
object ( WebGrid )

Samples
Determine which grid is having focus currently.

function GetActiveGrid()
{
var grid = ISGetObject("WebGrid1");
grid.SetFocus();
alert(wgGetActiveGrid());
}
wgGetGridById Description
Gets the WebGrid instance by its ID.

Parameters
name ( string )
The WebGrid's ID.

Return Value

object ( WebGrid )

Samples
Gets the WebGrid's instance by ID.

function GetGridName()
{
var grid = wgGetGridById("WebGrid1");
alert(grid.Name);
// It's highly recommended not to use
// wgGetGridById method anymore for consistency purpose
// Please use ISGetObject method for future usage

var grid = ISGetObject("WebGrid1");
alert(grid.Name);
}
wgGetChildTableByRow Description
Returns the Container element of childtable by specific row and child table name.

Parameters
row ( object - row element )
The HTML row element.
childTblName ( string )
The child table's name.

Return Value

object (WebGridTable)

Samples
Get child table WebGridTable object

function DoSelectRow()
{
// a simple hiearchical tables
// Customers -> Orders

// try to expand the first row first
// and then use this function
// in order to use wgGetChildTableByRow
// the child table needs to be expanded first
var grid = ISGetObject("WebGrid1");
var wgRow = grid.GetSelectedObject().GetRowObject();
var htmlRow = wgRow.GetElement();
var chldTbl = wgGetChildTableByRow(htmlRow, "Orders");

return true;
}
wgGetCellCount Description
Gets the cell's count of the specified row.

Parameters
obj ( object - row element )
The RowElement

Return Value

integer

Samples
Get the number of cells in a table based on a RowElement.

function GetCellCount()
{
// a simple hiearchical tables
// Customers -> Orders
var grid = ISGetObject("WebGrid1");
var wgRow = grid.RootTable.GetRow(0);
var htmlRow = wgRow.GetElement();

alert(wgGetCellCount(htmlRow));

return true;
}
wgGetCellByPosition Description
Returns the cell HTML element based on specified row and position.

Parameters
obj ( object - HTML row element )
The HTML row element
pos ( integer )
The index of the column

Return Value

object (HTML cell element )

Samples
Gets the column's name of the intended cell based on the given HTML RowElement.

function GetCellContents()
{
// a simple hiearchical tables
// Customers -> Orders
var grid = ISGetObject("WebGrid1");
var wgRow = grid.RootTable.GetRow(0);
var htmlRow = wgRow.GetElement();

alert(wgGetCellByPosition(htmlRow, 1).innerText);

return true;
}
wgGetCellByName Description
Returns the cell HTML element based on the specified row and column's name.

Parameters
obj ( object - row element )
The HTML RowElement
name ( string )
The column's name

Return Value

object (cell element )

Samples
Gets the column's name of the given row element and also the column's name.

function GetCellContents()
{
// a simple hiearchical tables
// Customers -> Orders
var grid = ISGetObject("WebGrid1");
var wgRow = grid.RootTable.GetRow(0);
var htmlRow = wgRow.GetElement();

alert(wgGetCellByName(htmlRow, "Country").innerText);

return true;
}
wgGetCellPosByName Description
Returns the cell's position by column's name.

Parameters
obj ( object - row element )
The HTML row element

cell ( string )

The column's name

Return Value

integer

Samples
Gets the cell's position in the table.

function GetCellContents()
{
// a simple hiearchical tables
// Customers -> Orders
var grid = ISGetObject("WebGrid1");
var wgRow = grid.RootTable.GetRow(0);
var htmlRow = wgRow.GetElement();

// return null
alert(wgGetCellPosByName(htmlRow, "CustomerID"));

return true;
}
wgGetRowByPosition Description
Returns the row based on specified table and position.

Parameters
table ( object - table element )
The HTML table element object
pos ( integer )
The row index position

Return Value

object ( row element )

Samples
Gets the HTML row element.
function GetRowElement()
{
var grid = ISGetObject("WebGrid1");
var htmlTbl = grid.RootTable.GetElement(WG40.BODY, WG40.HTMLTABLE);
var htmlRowElm = wgGetRowByPosition(htmlTbl, 0);
alert(htmlRowElm.type);
return true;
}
wgGetRowByPositionExact Description
Gets the row based on specified exact position indexed by WebGrid internal row's position.

Parameters
table ( object )
The table element
pos ( integer )
The row index
startPos ( integer )
The starting row index (optional)

Return Value

object (row element)

Samples
the sample shows how to get row by position exact

// get the grid Object.
var grid = ISGetObject("WebGrid1");

// get HTML body of the table element.
var tblElm = grid.GetRootTable().GetElement(WG40.BODY,WG40.HTMLTABLE);

// get row by position exact.
var row = wgGetRowByPositionExact(tblElm,1,1);

wgGetRootRow Description
Gets the root/first row of a ColumnSet rows or PreviewRow.

Parameters
row ( object - row element )
The row element

Return Value

object (row element)

Samples
The sample shows how to get Gets the root/first row of a columnset rows or previewrow.

// get the grid Object.
var grid = ISGetObject("WebGrid1");

//get row element.
var rowElm = grid.GetSelectedObject().GetRowObject().GetElement();

// get the root of the rows.
var rootRow = wgGetRootRow(rowElm);
wgGetColNameByCell Description
Gets the column's name based on specified cell.

Parameters
cell ( object - cell element)
The cell element

Return Value

string

Samples
The sample shows how to get the column name with using cell element.

// get the grid Object.
var grid = ISGetObject("WebGrid1");

//get the row Element from the selected object.
var rowElm = grid.GetSelectedObject().GetRowObject().GetElement();

//get the string column name with using cell element.
var columnName = wgGetColNameByCell(rowElm.cells[3]);

wgGetSelectedObjectFromEvent Description
Gets the wgSelectedObject from event information.

Parameters
evnt ( object )
The event object

Return Value

object (SelectedObject)

Samples
The sample shows how to get the selected object from window.event.

//get the selected object from window. event.
var obj = wgGetSelectedObjectFromEvent(window.event);

//get the selected object from window. event.
var obj = wgGetSelectedObjectFromEvent(window.event);

//get the selected object from window. event.
var obj = wgGetSelectedObjectFromEvent(window.event);
wgIsColumnSetRow Description
Determines whether the specified row is a ColumnSet row.

Parameters
row ( object - row element )
The row element

Return Value

boolean

Samples
The sample shows wgIsColumnSetRow is false when the selected row is not in a column set.

//get the object of the grid
var grid = ISgetObject("WebGrid1");

//get the selected row element
var rowElm = grid.GetSelectedObject().GetRowObject().GetElement();

//check whether the row is a ColumnSet row or not.
var bool = wgIsColumnSetRow(rowElm) ;
wgGetPreviewRow Description
Gets the row html element of a PreviewRow object.

Parameters
row ( object - row element)
The row element

Return Value

object (row element)

Samples
The sample shows how to get the html row element of a selected preview row.

// get the grid object.
var grid = ISGetObject("WebGrid1");

// get the selected object row element.
var rowElm = grid.GetSelectedObject().GetRowObject().GetElement();

// get the html of the preview row.
var row = wgGetPreviewRow(rowElm);
wgGetPreviewRowCell Description
Gets the cell HTML element which contains data of the preview row.

Parameters
row ( object - row element )
The row element

Return Value

object (row element)

Samples
The sample shows how to get the cell element from row of the preview row

//get grid object
var grid = ISGetObject("WebGrid1");

//get the row element of the selected object
var rowElm = grid.GetSelectedObject().GetRowObject().GetElement();

//get the preview row element
var prevrow = wgGetPreviewRow(rowElm);

//get the preview cell element
var prevcell = wgGetPreviewRowCell(prevrow);
wgIsValidCell Description
Gets the valid cell.

Parameters
c ( object )
The cell element

Return Value

boolean

Samples
The sample shows how to get to know whether the first cell is valid or not.

//get the grid object.
var grid = ISGetObject("WebGrid1");

//get the row element.
var rowElm = grid.GetSelectedObject().GetRowObject().GetElement();

//get the first cell element.
var cellElm = rowElm.cells[1];

//get to know whether the cell element is valid or not.
var cellbool = wgIsValidCell(cellElm);
wgIsValidClickableCell Description
Gets the valid clickable cell.

Parameters
c ( object - cell element)
the cell element

Return Value

boolean

Samples
The sample shows whether the cell is valid clickable.

// get the grid Object.
var grid = ISGetObject("WebGrid1");

// get HTML row element.
var rowElm = grid.GetSelectedObject().GetRowObject().GetElement();

//get the status whether cell is valid clickable or not.
wgIsValidClickableCell(rowElm.cells[1]);

wgIsValidRow Description
Gets the valid row

Parameters
tr ( object - row element)
The row element

Return Value

boolean

Samples
The sample shows how to get to know whether the row is valid.

// get the grid Object.
var grid = ISGetObject("WebGrid1");

// get HTML row element.
var rowElm = grid.GetSelectedObject().GetRowObject().GetElement();

//get to know whether the row is valid or not
wgIsValidRow(rowElm);

wgGetPreviewRowParent Description
Gets the row html element of the parent row of specified preview row

Parameters
pr ( object - row element )
The row element

Return Value

object (row element)

Samples
The sample shows how to get the parent of the preview row.

// get the grid Object.
var grid = ISGetObject("WebGrid1");

// get HTML row element.
var rowElm = grid.GetSelectedObject().GetRowObject().GetElement();

//get the parent of the preview row
wgGetPreviewRowParent(rowElm);

wgIsSameRow Description
Determines whether row1 and row2 is in one DataRow.

Parameters
row1 ( object - row element )
The row element
row2 ( object - row element )
The row element

Return Value

boolean

Samples
the sample compares 2 row elements.

// get the grid Object.
var grid = ISGetObject("WebGrid1");

// get HTML row element.
var rowElm = grid.GetSelectedObject().GetRowObject().GetElement();

//get the status of comparing the two columnset row elements.
var isbool = wgIsSameRow(rowElm,wgGetRowByPositionExact(tblElm,1));

wgIsSameColumnSetRow Description
Determines whether the row1 and row2 is in the same ColumnSet rows.

Parameters
row1 ( object - row element )
The row element
row2 ( object - row element )
The row element

Return Value

boolean

Samples
The sample compares 2 columnset row elements.

// get the grid Object.
var grid = ISGetObject("WebGrid1");

// get HTML row element.
var rowElm = grid.GetSelectedObject().GetRowObject().GetElement();

//get the status of comparing the two columnset row elements.
var isbool = wgIsSameColumnSetRow(rowElm,wgGetRowByPositionExact(tblElm,1));

wgIsRecordRow Description
Determines whether the specified row is a record row

Parameters
row ( object - row element )
The row element

Return Value

boolean

Samples
The sample shows how to know whether the first cell is clickable or not

//get the grid object
var grid = ISGetObject("WebGrid1");

//get the row element
var rowElm = grid.GetSelectedObject().GetRowObject().GetElement()

//get the first cell status valid or not
var bool = wgIsRecordRow(rowElm);
wgGetHierRecord Description
Gets the child's row element from a specified row of hierarchical grid

Parameters
row ( object - row element )
The row element

Return Value

object ( row element)

Samples
This sample shows how to get the child's row element of the hierarchical grid.

function doRowSelect(controlId, tblName, rowIndex, rowEl)
{
var rec = wgGetHierRecord(rowEl);
}
wgGetRowByGroup Description
Gets the group's row element

Parameters
tb ( object - table element )
The table element
groupIdx ( integer )
The group index
groupPos ( integer )
The position of the group
startTR ( integer )
The start row index to search (optional)

Return Value

object (row element)

Samples
The sample shows how to get the first group's row element

function doButtonClick()
{
//get the grid object
var grid = ISGetObject("WebGrid1");

//make sure the grid is grouped
if (grid.RootTable.GroupedColumns.length > 0)
{
//get the first group row element
var firstGroupRow = wgGetRowByGroup(grid.RootTable.GetElement(WG40.BODY,WG40.HTMLTABLE),0,0);

alert(firstGroupRow.innerText);
}
}
wgIsFilterRow Description
Determines whether or not the row element is filter row.

Parameters
row ( object - row element )
The row element

Return Value

boolean

Samples
This sample shows how to determine whether or not a row is a filter row.

function doRowSelect(controlId, tblName, rowIndex, rowEl)
{
var flag = wgIsFilterRow(rowEl);
return true;
}
wgRemoveRow Description
Removes a row from table element.

Parameters
table ( object - table element )
The table element
row ( object - row element )
The row element

Return Value

void

Samples
The sample shows how to remove the selected row.

function doRowSelect(controlId, tblName, rowIndex, rowEl)
{
//get the grid object of the selected row
var grid = ISGetObject(controlId);

//get the table object of the selected row
var table = grid.Tables[tblName].GetElement(WG40.BODY,WG40.HTMLTABLE);

//remove the selected row
wgRemoveRow(table,rowEl);

return true;
}
wgGetGridByElement Description
Gets the grid object of HTML element.

Parameters
el ( object - HTML element )
The HTML element

Return Value

object (WebGrid)

Samples
The samples shows how to get the WebGrid object from the a cell element

function doRowSelect(controlId, tblName, rowIndex, rowEl)
{
//get the cell element of the selected row
var cell = wgGetCellByName(rowEl, "Address");

//get the grid object from the cell element
var grid = wgGetGridByElement(cell);

alert(grid.Id);

return true;
}
wgGetTableByElement Description
Gets the table object of table element.

Parameters
el ( object - table element )
The table element

Return Value

object (WebGridTable)

Samples
The samples shows how to get the WebGridTable object from a table element.

function doRowSelect(controlId, tblName, rowIndex, rowEl)
{
//get the grid object
var grid = ISGetObject(controlId);

//get the table element
var tbl = grid.Tables[tblName].GetElement(WG40.BODY,WG40.HTMLTABLE);

//get the table object
var tblEl = wgGetTableByElement(tbl);

return true;
}
wgGetColumnByElement Description
Gets the column object of column element.

Parameters
el ( object - column element )
The column element

Return Value

object (WebGridColumn)

Samples
The samples shows how to get the WebGridColumn object from the a column element.

function doRowSelect(controlId, tblName, rowIndex, rowEl)
{
//get the grid object
var grid = ISGetObject(controlId);

//get the table object
var tbl = grid.Tables[tblName];

//get the row object
var row = tbl.GetRow(0);

//get the cell element
var cell = row.GetCell(0).GetElement();

//get the WebGridColumn object
var col = wgGetColumnByElement(cell);

return true;
}
wgGetCellByElement Description
Gets the cell object of cell element.

Parameters
el ( object - cell element )
The cell element

Return Value

Object (WebGridCell)

Samples
The samples shows how to get the WebGridCell object from the a cell element.

function doRowSelect(controlId, tblName, rowIndex, rowEl)
{
//get the cell element of the selected row
var cell = wgGetCellByName(rowEl, "Address");

//get the WebGridCell object from the cell element
var cellObj = wgGetCellByElement(cell);
return true;
}
wgGetRowByElement Description
Gets the WebGridRow object of the row element.

Parameters
el ( object - row element )
The row element

Return Value

object (WebGridRow)

Samples
The samples shows how to get the WebGridRow object from the a row element.

function doRowSelect(controlId, tblName, rowIndex, rowEl)
{
//get the row object
var rowObj = wgGetRowByElement(rowEl);
return true;
}

See Also

References
{How-to: Get row by index}
{How-to: Get row by KeyValue}
{How-to: Get a cell by index}
{How-to: Get a cell by name}
{How-to: Get a column name of the selected cell}
{How-to: Set text to a specific cell}
{How-to: Get root row of ColumnSet layout}
{How-to: Get checked rows in client side}
{How-to: Retrieve Preview Row's text}


WebGrid Edit

WebGrid Edit
Send Feedback
Intersoft WebGrid > Client-side References > WebGrid Edit

Glossary Item Box

WebGrid Edit Global Functions
wgGetFirstEditableCell Description
Gets the first editable cell index of the specified row.

Parameters
row ( object - row element )
The row element

Return Value

integer

Samples

This sample shows how to get the first editable cell index in the specified row.

function doRowSelect(controlId, tblName, rowIndex, rowEl)
{
 //gets the first editable cell
var firstCellIndex = wgGetFirstEditableCell(rowEl);
return true;
}
wgGetNextEditableRow Description
Gets the next editable row from specified row.

Parameters
hTbl ( object - table element )
The table element
row ( object - row element )
The row element

Return Value

object (row element)

Samples
This sample shows how to get the next editable row from the current row selected.
function doRowSelect(controlId, tblName, rowIndex, rowEl)
{
 //gets the grid object
var grid = ISGetObject(controlId);

//gets the table element
 var tbl = grid.Tables[tblName].GetElement(WG40.BODY,WG40.HTMLTABLE);

//gets the next editable row
wgGetNextEditableRow(tbl,rowEl);

 return true;
}
wgGetPrevEditableRow Description
Gets the previous editable row from specified row.

Parameters
hTbl ( object - table element )
The table element
row ( object - row element )
The row element

Return Value

object (row element)

Samples
This sample shows how to get the previous editable row from the current row selected.
function doRowSelect(controlId, tblName, rowIndex, rowEl)
{
 //gets the grid object
var grid = ISGetObject(controlId);

//gets the table element
 var tbl = grid.Tables[tblName].GetElement(WG40.BODY,WG40.HTMLTABLE);

//gets the previous editable row
wgGetPrevEditableRow(tbl,rowEl);
 return true;
}

wgGetNextEditableCell Description
Gets the next editable cell based on a given cell element or row element.

Parameters
cell ( object - cell element )
The cell element
_row ( object - row element )
The row element (optional)

Return Value

object (cell element)

Samples
This sample shows how to get the next editable cell from the current cell selected.
function doEnterEditMode(gridId,tblName,editObject)
{
 //get the grid object
var grid = ISGetObject(gridId);

//get the current row object
var row = grid.GetSelectedObject().GetRowObject();

//get the current cell element
 var cell = row.GetCells().GetNamedItem("City").GetElement(WG40.BODY,WG40.HTMLCELL);

//get the next editable cell
var nextCell = wgGetNextEditableCell(cell);

 return true;
}
wgGetPrevEditableCell Description
Gets the previous editable cell based on a given cell element or row element.

Parameters
cell ( object - cell element )
The cell element
_row ( object - row element )
The row element (optional)

Return Value

object (cell element)

Samples
This sample shows how to get the previous editable cell from the current cell selected.
function doEnterEditMode(gridId,tblName,editObject)
{
 //get the grid object
var grid = ISGetObject(gridId);

//get the current row object
var row = grid.GetSelectedObject().GetRowObject()

//get the current cell element
 var cell = row.GetCells().GetNamedItem("City").GetElement(WG40.BODY,WG40.HTMLCELL);

//get the previous editable cell
var prevCell = wgGetPrevEditableCell(cell);

 return true;
}
wgGetLastEditableCell Description
Gets the last editable cell of the specified row element.

Parameters
row ( object - row element )
The row element

Return Value

object (cell element)

Samples
This sample shows how to get the last editable cell from the current cell selected.
function doEnterEditMode(gridId,tblName,editObject)
{
 //get the grid object
var grid = ISGetObject(gridId);

//get the current row object
var rowEl = grid.GetSelectedObject().GetRowObject(). GetElement(WG40.BODY,WG40.HTMLROW);

//get the last editable cell
var lastCell = wgGetLastEditableCell(rowEl);

 return true;
}
wgActiveCellValid Description
Determines whether the specified row element is currently an active cell row.

Parameters
grid ( object - WebGrid )
The grid object
row ( object - row element )
The row element

Return Value

boolean

Samples
This sample shows how to determine whether or not the selected row is an active cell row.

function doEnterEditMode(gridId,tblName,editObject)
{
//get the grid object
var grid = ISGetObject(gridId);

//get the row element of the selected row
var rowEl = grid.GetSelectedObject().GetRowObject().GetElement();

//determines whether or not the selected row is an active cell row
var flag = wgActiveCellValid(grid,rowEl); //will return true if in edit mode

return true;
}
wgIsRowEditable Description
Determines whether or not the specified row is editable.

Parameters
row ( object - row element )
The row element

Return Value

boolean

Samples
This sample shows how to determine whether or not the selected row is editable.

function doRowSelect(gridId, tblName, rowIndex, rowEl)
{
var flag = wgIsRowEditable(rowEl);
return true;
}
wgGetUnMask Description
Unmask a value of a specified cell.

Parameters
grid ( object - WebGrid )
The grid object
col ( object - WebGridColumn )
The column object
el ( object - cell element )
The cell element
returnText ( boolean )
The flag that determines whether or not the return type of unmasked value is text
text ( string )
The value that will be unmasked

Return Value

void

Samples
This sample shows how to unmask the value of a specified cell.

function doEnterEditMode(gridId,tblName,editObject)
{
 //get the grid object
var grid = ISGetObject(gridId);

//get the table object
 var oTbl = grid.RootTable;

 //get the cell element
 var cell = oTbl.GetRow(0).GetCells().GetNamedItem("ShipAddress").GetElement();
var col = grid.GetColumnByElement(cell);

//unmask the cell's value
 wgGetUnMask(grid,col,cell,true,cell.innerText);

return true;
}
wgGetMask Description
Masks a value of a specified cell.

Parameters
grid ( object - WebGrid )
The grid object
editObj ( object - EditObject )
The edit object
value ( string )
The value that will be masked
_table ( object - table element )
The table element (optional)
_cell ( object - cell element )
The cell element (optional)

Return Value

void

Samples
This sample shows how to mask the value of the specified cell.

function doEnterEditMode(gridId,tblName,editObject)
{
 //get the grid object
var grid = ISGetObject(gridId);

//get the table object
 var oTbl = grid.RootTable;

//get the table element
 var eTbl = oTbl.GetElement(WG40.BODY,WG40.HTMLTABLE);

//get the cell element
 var cell = oTbl.GetRow(0).GetCells().GetNamedItem("ShipAddress").GetElement();

//mask the cell's value
 wgGetMask(grid,editObject,cell.innerText,eTbl,cell);

return true;
}
wgDispObjGeneric Description
Displays generic edit object according to grid's active cell and specified parameters.

Parameters
grid ( object - grid element )
The grid element.
edit ( object - EditObject element )
The edit control html element.
el ( object - cell element )
The cell element to which the edit control is attached.
adjLeft ( integer )
The left adjustment to the cell position relatively.
adjTop ( integer )
The top adjustment to the cell position relatively.
ignoreSize ( boolean )
The flag that determines whether or not to ignore the size calculation of edit control.
editType ( string )
The edit type.
calDD ( boolean )
The flag that determines whether or not the edit object is a DropDownList object.

Return Value

void

Samples
This sample shows how to display the edit object of a specified cell.

function doEnterEditMode(gridId, tblName, editObject)
{
//get the grid object
var grid = ISGetObject(gridId);

//get the table object
var oTbl = grid.RootTable;

//get the cell element
var cell = oTbl.GetRow(0).GetCells().GetNamedItem("ShipAddress").GetElement();

//display the edit object at the specified cell
wgDispObjGeneric(grid, editObject.element, cell, 1, 1, null, null, false);

return true;
}
wgIsRowMarkedEdit Description
Determines whether or not the specified row has been marked as edited.

Parameters
row ( object - row element )
The row element

Return Value

boolean

Samples
This sample shows how to determine whether or not the selected row is marked edit.

function doEditKeyDown(gridId, tblName, editObject)
{
//get the grid object
var grid = ISGetObject(gridId);

//get the row element of the first row
var rowEl = grid.RootTable.GetRow(0).GetElement(WG40.BODY,WG40.HTMLROW);

//if the row element is dirty
if(wgIsRowMarkedEdit(rowEl))
alert("Row 1 is marked edit");

return true;
}
wgIsRowDirty Description
Determines whether or not the specified row is dirty (one of its cells' content has been modified).

Parameters
row ( object - row element )
The row element

Return Value

boolean

Samples
This sample shows how to determine whether or not the selected row is dirty.

function doEditKeyDown(gridId, tblName, editObject)
{
//get the grid object
var grid = ISGetObject(gridId);

//get the row element of the first row
var rowEl = grid.RootTable.GetRow(0).GetElement(WG40.BODY,WG40.HTMLROW);

//if the row element is dirty
if(wgIsRowDirty(rowEl))
alert("Row 1 is dirty");

return true;
}
wgHighlightEditCell Description
Highlights specified cell as current active edit cell.

Parameters
cell ( object - cell element )
The cell element
mode ( string )
For internal use only - not intended to be used directly by developers.
newcell ( string )
For internal use only - not intended to be used directly by developers.

Return Value

void

Samples
This sample shows how to highlight the first cell of the first row on a button click event.

function doButtonClick()
{
//get the grid object
var grid = ISGetObject("WebGrid1");

//get the table object
var table = grid.RootTable;

//get the first row object
var row = table.GetRow(0);

//get the first cell element
var cell = row.GetCell(0).GetElement();

//highlight the cell
wgHighlightEditCell(cell);

return true;
}


WebGrid ColumnSet

WebGrid ColumnSet
Send Feedback
Intersoft WebGrid > Client-side References > WebGrid ColumnSet

Glossary Item Box

WebGrid ColumnSet Global Functions
wgGetColumnSetRows Description
Gets the column set rows of specific row.

Parameters
row ( object )
The row element

Return Value

array

Samples
The sample shows how to get arrays of the columnset rows.

//get grid object
var grid = ISGetObject("WebGrid1");

//get row element
var rowElm = grid.GetSelectedObject().GetRowObject().GetElement();

//get the arrays contain columnset rows
var arr = wgGetColumnSetRows(rowElm)
wgGetLowestColumnSetRow Description
Gets the lowest column of the column set rows.

Parameters
obj ( object )
The row element

Return Value

object (row element)

Samples
The sample shows how to get the lowest columnset row element.

//get grid object
var grid = ISGetObject("WebGrid1");

//get row element
var rowElm = grid.GetSelectedObject().GetRowObject().GetElement();

//get the lowest column set row
wgGetLowestColumnSetRow(rowElm)
wgGetColumnSetRowByPos Description
Gets the row html element of the specified position in ColumnSet rows.

Parameters
obj ( object )
The table element
pos ( integer )
The row position

Return Value

object (row element)

Samples
The sample shows how to get row by position of the selected object.

// get the grid Object.
var grid = ISGetObject("WebGrid1");

// get HTML body of the table element.
var tblElm = grid.RootTable.GetElement(WG40.BODY,WG40.HTMLTABLE);

//get columnset row by position
wgGetColumnSetRowByPos(tblElm.rows,1)

wgGetColumnSetRow Description
Gets the first/root row HTML element of column set rows.

Parameters
obj ( object )
The row or cell element

Return Value

object (row or cell element)

Samples
The sample shows how to get the first HTML row element of the grid.

//get grid object
var grid = ISGetObject("WebGrid1");

//get row element of the grid object
var rowElm = grid.GetSelectedObject().GetRowObject().GetElement();

//get the HTML first row element.
var row1 = wgGetColumnSetRow(rowElm)
wgGetCSCellByPosition Description
Gets the ColumnSet cell by specified position.

Parameters
row ( object )
The row element
r ( integer )
The row position
c ( integer )
The column position
cs ( integer )
The column set position

Return Value

object (row element)

Samples
The sample shows how to get HTML cell element using positions of the row column.
//get grid object.
var grid = ISGetObject("WebGrid1");

//get row element object of the grid.
var rowElm = grid.GetSelectedObject().GetRowObject().GetElement();

//get HTML cell element by using the row element and positions.
var cell = wgGetCSCellByPosition(rowElm,1,1,1)
wgGetCSCellByName Description
Gets the ColumnSet cell html element by column's name.

Parameters
row ( object )
The row element
name ( string )
The column name

Return Value

object (cell element)

Samples
The sample shows how to get a cell HTML element using lastname and row element.

//get grid object
var grid = ISGetObject("WebGrid1");

//get row element
var rowElm = grid.GetSelectedRow().GetRowObject().GetElement();

//get cell HTML element sorted by lastname with row element.
var cellname = wgGetCSCellByName(rowElm,"LastName")
wgGetCSPosByRL Description
Gets the column set position by row layout.

Parameters
rl ( object )
The row layout object

Return Value

object

Samples
The sample shows position of the ColumnSet using row layout.

//get the grid object.
var grid = ISGetObject("WebGrid1");

//get row element.
var rowElm = grid.GetSelectedObject().GetRowObject().GetElement();

//get row layout by using column name, in this case we use "city".
var cityrl = grid.RootTable.GetRowLayoutByColName("City");

//get ColumnSet position by using row layout.
var pos = wgGetCSPosByRL(cityrl)
wgGetLastEditableCSCell Description
Gets the last editable ColumnSet cell.

Parameters
table ( object )
The table element
cs ( integer )
The column set position
row ( object )
The row element

Return Value

object (cell element)

Samples
wgGetPrevEditableCSCell Description
Gets previous editable column set cell.

Parameters
cell ( string )
The cell name
startcs ( integer )
The start count for searching

Return Value

object (cell element)

Samples
The sample shows how to get previous editable cell on the ColumnSet.

//get grid object
var grid =ISGetObject("WebGrid1");

//get row element
var rowElm = grid.GetSelectedObject().GetRowObject().GetElement();

//get the previous editable cell of the ColumnSet.
var cdcell = wgGetPrevEditableCSCell(rowElm.cells[1],1)
wgGetCSPrevEditableCell Description
Gets the previous editable cell in the column set.

Parameters
cell ( object )
The cell element
_row ( object )
The row element

Return Value

object (cell element)

Samples
The sample shows how to get the column set previous editable cell.
//get grid object
var grid = ISGetObject("WebGrid1");

//get row element
var rowElm = grid.GetSelectedObject().GetRowObject().GetElement();

//get cell element with n is an integer
var cellElm = rowElm[n];

//get previous editable cell of columnset
var cell = wgGetCSPrevEditableCell(rowElm.cells[1],rowElm)
wgGetCSLastEditableCell Description
Gets the last editable cell in the column set.

Parameters
row ( object )
The row element

Return Value

object (cell element)

Samples
The sample shows how to get last editable cell of ColumnSet.
//get grid object
var grid = IsGetObject("WebGrid1");

//get the row element
var rowElm = grid.GetSelectedObject().GetRowObject().GetElement();

//get the last editable cell of the columnset
var crow = wgGetCSLastEditableCell(rowElm)
wgGetCSFirstEditableCell Description
Gets the first editable cell in the column set.

Parameters
row ( object )
The row element

Return Value

object (cell element)

Samples
The sample shows how to get the first editable cell on column set.

//get grid object
var grid = IsGetObject("WebGrid1");

//get the row element
var rowElm = grid.GetSelectedObject().GetRowObject().GetElement();

//get the first editable cell of the columnset
var crow = wgGetCSFirstEditableCell(rowElm)
wgGetCSPrevEditableRow Description
Gets the last editable row in the column set.

Parameters
hTbl ( object )
The table html element
cell ( object )
The cell element
csno ( integer )
The column set number
colno ( integer )
The column number
isMin ( boolean )
The status shows whether the grid is start from min or not

Return Value

object (row element)

Samples
The sample shows how to get the previous editable row in columnset using table element, cell element, columnset number, and column number.

//get the grid object
var grid = ISGetObject("WebGrid1");

//get table element
var tblElm = grid.RootTable.GetElement(WG40.BODY,WG40.HTMLTABLE);

//get row element
var rowElm = grid.GetSelectedObject().GetRowObject().GetElement();

//get columnset previous editable row
wgGetCSPrevEditableRow(tblElm,rowElm.cells[1],1,1,false)
wgGetPrevCSRow Description
Gets the previous column set row.

Parameters
tb ( object )
The table element
row ( object )
The row element

Return Value

object (row element)

Samples
The sample shows how to get row of the previous column set row.
//get grid object
var grid = ISGetObject("WebGrid1");

//get table element of the grid
var tblElm = grid.RootTable.GetElement(WG40.BODY,WG40.HTMLTABLE);

//get row element of the grid
var rowElm = grid.GetSelectedObject().GetRowObject().GetElement();

//get the previous columnset row
var row = wgGetPrevCSRow(tblElm,rowElm)


WebGrid Events

WebGrid Events
Send Feedback
Intersoft WebGrid > Client-side References > WebGrid Events

Glossary Item Box

WebGrid Events Global Functions
wgGetLastSelectedObject Description
Gets grid last selected object.

Return Value
object ( SelectedObject )
Samples
wgGetValidActiveCell Description
Gets the valid active cell of the grid.

Parameters
cell ( object - cell element )

Return Value

object ( cell element )

Samples
The sample shows how to get the valid active cell element of the column set.
// get the grid Object.
var grid = ISGetObject("WebGrid1");

// get HTML row element.
var rowElm = grid.GetSelectedObject().GetRowObject().GetElement();

//get the valid active cell from the selected object
var cell = wgGetValidActiveCell(rowElm.cells[2]);
wgGetLastVisibleRow Description
Gets the last visible row of the selected object.

Parameters
tb ( object - table element )

Return Value

object (row element)

Samples
The sample shows how to get the last visible row of the grid

// get the grid Object.
var grid = ISGetObject("WebGrid1");

// get HTML body of the table element.
var tblElm = grid.RootTable.GetElement(WG40.BODY,WG40.HTMLTABLE);

// get the last visible row
wgGetLastVisibleRow(tblElm)
wgGetLastChildVisibleRow Description
Gets the last child of the visible row (intended intended to be used for advanced developers only, because the row element needs to be specific).

Parameters
res ( object - row element)

Return Value

object ( row element )

Samples
wgGetPrevVisibleRow Description
Gets the previous visible row.

Parameters
tb ( object - table element )
The table element of the table where the row is located in.
row ( object - row element)
The row element of the currently visible row.

Return Value

object ( row element )

Samples
The sample shows how to get the previous visible row of the selected object.

// get the grid Object.
var grid = ISGetObject("WebGrid1");

// get HTML body of the table element.
var tblElm = grid.RootTable.GetElement(WG40.BODY,WG40.HTMLTABLE);

// get HTML row element.
var rowElm = grid.GetSelectedObject().GetRowObject().GetElement();

//get the previous visible row
var row = wgGetPrevVisibleRow(tblElm,rowElm)


Troubleshooting

Troubleshooting
See Also Send Feedback
Intersoft WebGrid > Troubleshooting

Glossary Item Box

This section contains troubleshooting on WebGrid.NET.

Mozilla Browser

Following are known issues when displaying WebGrid.NET in Mozilla-based browsers.

These issues have been clarified as BUGS in Mozilla and have been submitted through BugZilla website. These issues are clarified as BUGS until the time of the release on April 2005. The issues are:

  • Hierarchical treelines always disappear (will show up when a cell is clicked).
  • Height in childtables sometimes corrupted (will be corrected when a cell is clicked).
  • Caret disappears in textbox.
  • AutoFitColumns still shows the horizontal scrollbar, reason: the 'overflow-x' style is not supported.

The following issues have been clarified as BUGS in WebGrid and have been submitted to the developer team to be fixed.

  • HTML editor button cannot be clicked in Mozilla.
  • When using WebGrid with Pivot Chart, the WebGrid is not resized while the browser is resized in Mozilla.

All other challenges and issues in Mozilla such as box-sizing, flickering, focus, key navigations, and dozens more, have been fully taken care and supported by this release with the new invention of IEMozBridge architecture.

FireFox 1.0.3 and Mozilla 1.7.7 Notes

Due to a major bug in FireFox 1.0.3 and Mozilla 1.7.7 engine, WebGrid.NET Enterprise could not be rendered properly and could cause invalid behaviors to all user-interactive features.

If you're using the version mentioned above, please update your browser's version to FireFox 1.0.4 and Mozilla 1.7.8 which have the bug fixed.

See Also

Overview
Getting Started
WebGrid Features Overview

Other Resources
Walkthrough Topics
How-to Topics


Support and Community

Support and Community
See Also Send Feedback
Intersoft WebGrid > Support and Community

Glossary Item Box

Intersoft Solutions provides full product support for all controls available in WebUI Studio. This topic outlines a number of ways to get product support, get involved with the community, as well as obtaining product updates.

Blogs

Intersoft development team members and community leaders author a variety of blogs that target ASP.NET web development in general using the recommended guidelines and best practice. The blogs often discuss interesting topics such as database access and connectivity challenges, as well as samples, videos and latest development news.

Visit Intersoft WebUI Studio Blog.

Forums

The Intersoft Community Forums is the best place where you can post your questions and technical problems, as well as discussing on the latest application development trend around the WebUI Studio controls.

Blending the modern minimalist styling and lightweight user interface, Intersoft Community is designed to be your most resource-wealth technical community center. You can create a new thread to ask question or simply to start a discussion, reply other user's questions or rate your most favorite threads – everything you need for a productive forum activity.

Visit Intersoft Community Forums.

Support Center

Intersoft Support Center provides a wealth of product resources and literatures that help you quickly find the solutions to your problems. With the intuitive navigation, you can quickly navigate to a product page, read the tutorial, watch getting started videos, browse knowledge base and latest development blogs and more.

Visit Intersoft Support Center.

Feedback Center

Issues can sometimes be difficult to resolve, or irresolvable. Such situations arise because of bugs in the technology, difficulties applying the technology to particular scenarios, or lack of support for particular scenarios. This information is important to Intersoft, and can be provided via the Product Feedback Center in Intersoft Developer Network.

Intersoft Developer Network is a web-based portal for its customers to send feedback, work with support inquiries, manage development accounts and download licensed products. You can use the user credentials in the purchase receipt email that sent from Intersoft Accounts when you purchased the product.

Items posted on the Product Feedback Center are routed to the Intersoft team's internal database. Consequently, it is the most reliable way to get your feedback to the product feature owner. In addition, you can validate and track suggestions and bugs as well as vote on them, which helps the development team to prioritize issues and feature requests.

Contact Technical Support

Depending on the support level agreement (SLA) as part of the benefits that you received from your purchase, you can contact our technical support through various ways such as email or phone call. More comprehensive support levels such as instant messaging and real-time web-based chat support are also provided. Please visit Intersoft Support Level site to learn your support benefits and find out the most convenient way for you to contact us.

Checking for Product Updates

Intersoft WebUI Studio® includes an update manager application which allows you to easily download and install new updates. Product hotfixes are released on monthly basis to provide the most time-efficient enhancements and values to existing customers. To check, download and install for updates, simply launch Update Manager from Intersoft WebUI Studio program group.

The following illustration shows the Update Manager application interface.

Bug Reports

When submitting the bug report, make sure you have following information to avoid multiple communication roundtrip:

  • Product Edition (if applicable)
  • Full Product Version. E.g.: 4.0.7200
  • Browsers (with Full Version, including Service Packs or HotFixes if any)
  • Operating System (with Full Version, including Service Packs or HotFixes if any)
  • Development Environment Products
  • Development Environment Versions
  • Affected Machines: Development, Production Server or Both
  • Monitors: Single or Dual

You also might need to provide issue-specific information such as:

  • Current results/behaviors
  • Expected results/behaviors
  • Steps to reproduce
  • Working/Compilable samples

In This Section

Bug Reports

Support Options

See Also

Overview
Getting Started
WebGrid Features Overview

Other Resources
Walkthrough Topics
How-to Topics
Bug Reports
Support Options


Bug Reports

Bug Reports
See Also Send Feedback
Intersoft WebGrid > Support and Community > Bug Reports

Glossary Item Box

Please submit any bugs or product issues to webgridentsupport@intersoftpt.com

When submitting the bug report, make sure you have following information to avoid multiple communication roundtrip:

  • Product Edition (if applicable)
  • Full Product Version. Eg: 7.0.7200
  • Browsers (with Full Version, including Service Packs or HotFixes if any)
  • Operating System (with Full Version, including Service Packs or HotFixes if any)
  • Development Environment Products
  • Development Environment Versions
  • Affected Machines: Development, Production Server or Both
  • Monitors: Single or Dual

You also might need to provide issue-specific information such as:

  • Current result/behavior
  • Expected result/behavior
  • Steps to reproduce
  • Working/Compilable Samples

See Also

Overview
Getting Started
WebGrid Features Overview

Other Resources
Walkthrough Topics
How-to Topics


Support Options

Support Options
See Also Send Feedback
Intersoft WebGrid > Support and Community > Support Options

Glossary Item Box

WebGrid.NET Enterprise is developed and fully supported by Intersoft Solutions Corp. The company provides several methods for registered customers to obtain technical supports.

Online Support

All of WebGrid.NET Enterprise users have free access to our online support at www.intersoftpt.com which includes latest product updates, bug fixes, FAQ, hundreds of Knowledge Base Articles.

Standard Email Support

You can also send email to webgridentsupport@intersoftpt.com for product troubleshooting or bugs. Please provides information on the product version, operating system name and version as well as your development environment and its version. Your email will be answered shortly by our technical support team.

The turnaround time for standard email support is 72 hours (at the latest).

Before sending out your email, we highly recommend you to initially search for the information on locally installed Reference and Online Support.

Developer Network Support

The company provides a rich web-based forums for registered customers to discuss about the product. You may find information and answer to your questions in the forums, or simply posting your message in the forums and our technical support team will answer it in short time.

To access the Developer Network, please go to Intersoft website and click on Developer Network.

Login details are required to access Developer Network. Please refer to your original order receipt sent from Intersoft Accounts. If you do not get the automated order receipt, please contact accounts@intersoftpt.com

Priority Support Options

The NEW Priority Support option allows registered customers to obtain technical support via direct e-mail or telephone support from our Senior Support Engineer.

This option is designated for advanced customers who require faster response time. The inquiries types are mostly intermediate to advanced involving application-specific scenarios, minor feature requests, quick patches and more.

For more information about the Priority Support pricing and online purchase, please visit Intersoft Solutions web site at http://www.intersoftpt.com

Phone Support

Phone Support is currently available only for registered customers who have purchased Priority Support. You can reach Technical Support through following numbers:

  • +62 21 45873997
  • +62 21 45873998
Please have your UserID ready when calling.

For pre-sales phone support, you may contact our Authorized Distributor at no cost.

See Also

Overview
Getting Started
WebGrid Features Overview

Other Resources
Walkthrough Topics
How-to Topics


Licensing

Licensing
See Also Send Feedback
Intersoft WebGrid > Licensing

Glossary Item Box

This topic provides links to information about the licensing mechanism in WebGrid which includes design-time licensing for development seat and application licensing for deployment. The link to the software license agreement is also provided in the sections below.

In This Section

License Agreement

Contains information about Software License Agreement for the end users.

Copyright Information

Provides information about the copyrights and trademarks of Intersoft Solutions products.

See Also

Overview
Getting Started
WebGrid Features Overview

Other Resources
Walkthrough Topics
How-to Topics


License Agreement

License Agreement
See Also Send Feedback
Intersoft WebGrid > Licensing > License Agreement

Glossary Item Box

Software License Agreement for Intersoft Solutions Corp.

VERY IMPORTANT -- By installing the WebGrid.NET Enterprise Edition Version 7.0 software (herein the 'SOFTWARE') developed by Intersoft Solutions Corp (hereinafter the 'VENDOR'), you are accepting the following License Agreement.

I. LICENSE AGREEMENT. This is a legal agreement between you (either an individual or a single entity) and VENDOR. By installing the SOFTWARE you are agreeing to be bound by the terms of this agreement. If you do not agree to the terms of this agreement, please kindly click the [CANCEL] icon to exit now. The installation process will be immediately terminated.

II. OWNERSHIP; GRANT OF LICENSE. This is a license agreement and NOT an agreement for sale. The VENDOR hereby grants to you, and you accept, a non-exclusive, non-transferable license to use, copy and modify the SOFTWARE only as authorized below.

III. PERMITTED USES. This LICENSE grants you the following rights:

A. The SOFTWARE is licensed per individual developer. You may make copies on more than one computer, as long as the use of the SOFTWARE is by the same developer. If you have purchased a "multi-pack" license, you may use a copy of the SOFTWARE identified in the multi-pack on the number of computers associated with the multi-pack (e.g. a five user multi-pack allows you to use the SOFTWARE on up to five computers concurrently or by five different developers, the ten user multi-pack on up to ten computers concurrently or by ten different developers). The SOFTWARE is in "use" on a computer when it is loaded into temporary memory (i.e. RAM) or installed into permanent memory (e.g. hard disk, CD-ROM, or other storage devise) of that computer. However, installation on a network server for the sole purpose of internal distribution to one or more other computer(s) shall not constitute "use" for which a separate license is required, provided you have a separate license for each computer to which the SOFTWARE is distributed.

B. Solely with respect to electronic documents included with the SOFTWARE, you may make a copy (either in hardcopy or electronic form) for each developer for which the Software has been licensed as described in Section III.A, above; provided, that such copies shall be used only by such developer for internal purposes and are not to be republished or distributed to any other third party.

C. Runtime and redistributable files. You may deploy your web applications using the SOFTWARE to any number of production server or clients with no additional charges. The SOFTWARE runtime files shouldn't be modified in any ways prior to deploying and all copyright notices should be retain.

IV. PROHIBITED USES. You may not, without the prior written permission of the VENDOR:

A. Disassemble, decompile or "unlock", decode or otherwise reverse translate or engineer, or attempt in any manner to reconstruct or discover any source code or underlying algorithms of SOFTWARE provided in object code form only.

B. Use, copy, modify, or merge copies of the SOFTWARE and any accompanying documents except as permitted in this LICENSE.

C. Transfer, rent, lease, or sublicense the SOFTWARE.

D. Separate the software programs comprising the SOFTWARE for use by more than one user at a time.

V. COPYRIGHT. All title and copyrights in and to the SOFTWARE (including but not limited to any images, photographs, animation, video, audio, music, text and "applets" incorporated into the SOFTWARE) and the accompanying printed materials are owned by the VENDOR or its suppliers. The SOFTWARE is protected by Indonesian copyright laws and international treaty provisions. All rights are reserved worldwide. You must treat the SOFTWARE like any other copyrighted material, except that you may, in addition to the copies permitted in this LICENSE, make one copy of the SOFTWARE solely for backup or archival purposes. No part of the accompanying printed materials may be reproduced, transmitted, transcribed, stored in any retrieval system, or translated into any language by any means without the express prior written permission of the VENDOR.

VI. TERMINATION

A. This LICENSE and your right to use the SOFTWARE will terminate immediately without notice from the VENDOR if you fail to comply with the terms and conditions of this LICENSE. Upon termination, you agree to destroy the SOFTWARE, including all accompanying documents and copies. This is in addition to and not in lieu of any criminal, civil or other remedies available to the VENDOR.

B. The VENDOR has the right to perform temporary or permanent TERMINATION to this LICENSE upon the detection of license violation described in Section III A. The SOFTWARE has implemented Installation Tracker which is used to increment the number of installations during the installation of SOFTWARE. Related to Section III A, the LICENSE will be temporarily or permanently terminated upon the detection of unauthorized transfer or distribution of the LICENSE to either private or public web site, or to ANY medium.

C. ANY VIOLATION TO THE COPYRIGHT, OR TO THIS LICENSE AGREEMENT, MAY RESULT IN SEVERE CIVIL AND CRIMINAL PENALTIES, AND WILL BE PROSECUTED TO THE MAXIMUM EXTENT POSSIBLE UNDER THE LAW.

VII. LIMITED WARRANTY.

A. The VENDOR warrants that the SOFTWARE will perform substantially in accordance with the accompanying printed materials or officially "online" documented materials for a period of thirty (30) days from the date of receipt. The VENDOR does not warranty that the SOFTWARE will be error-free.

B. Your exclusive remedy under the performance warranty set forth in Section X.A, shall be, at VENDOR's option, either (a) return of the purchase price paid, or (b) repair or replacement of the defective SOFTWARE. SOFTWARE purchased other than directly from the VENDOR shall be returned to the place it was purchased. This limited warranty is void if failure of the SOFTWARE has resulted from accident, abuse, or misapplication. Any replacement SOFTWARE will be warranted for the remainder of the original thirty (30) day period.

See Also

Overview
Getting Started
WebGrid Features Overview

Other Resources
Walkthrough Topics
How-to Topics


Copyright Information

Copyright Information
See Also Send Feedback
Intersoft WebGrid > Licensing > Copyright Information

Glossary Item Box

Information in this document, including URL and other Internet Web site references, is subject to change without notice. Complying with all applicable copyright laws is the responsibility of the user. Without limiting the rights under copyright, no part of this document may be reproduced, stored in or introduced into a retrieval system, or transmitted in any form or by any means (electronic, mechanical, photocopying, recording, or otherwise), or for any purpose, without the express written permission of Intersoft Solutions Corp.

Intersoft Solutions, Intersoft Solutions Logo, A Better Web Experience, WebUI.NET Framework, WebUI.NET Framework Logo, WebUI Studio.NET Family, WebCombo.NET, WebGrid.NET Enterprise, WebInput.NET, WebUIControls.NET, ISDataSource.NET, WebDesktop.NET, WebTreeView.NET are either trademarks or registered trademarks of Intersoft Solutions Corporation.

Copyright © 2000-2007 Intersoft Solutions Corp. All rights reserved.

ActiveX, Internet Explorer, Microsoft, Visual Basic, Visual Basic .NET, Visual C# .NET, Visual C++ .NET, Visual Studio, Visual Studio .NET, Windows, Windows 95, Windows 98, Windows 2000, Windows Millennium Edition, Windows .NET server family, Windows NT, Windows XP and Windows Vista are either registered trademarks or trademarks of Microsoft Corporation in the United States and/or other countries.

The names of actual companies and products mentioned herein may be the trademarks or registered trademarks of their respective owners.

See Also

Overview
Getting Started
WebGrid Features Overview

Other Resources
Walkthrough Topics
How-to Topics